Microsoft Exchange Troubleshooting Assistant 개요

최근 수정된 항목: 2007-02-15

다음 작업은 Microsoft® Exchange Troubleshooting Assistant를 통해 액세스할 수 있습니다.

  • Exchange Performance Troubleshooter

  • Exchange Database Troubleshooter

  • Exchange Database Recovery Management

  • Exchange Mail Flow Troubleshooter

Exchange Troubleshooting Assistant의 초기 화면은 다음과 같은 두 부분으로 구성되어 있습니다.

  • 증상 기반 선택의 집합

  • 관련되는 기능 선택의 집합

증상 기반의 선택은 성능 문제, 메일 흐름 문제 또는 저장소 탑재 문제 등의 데이터베이스 문제를 해결하기 위한 부분입니다. 관련되는 기능은 추적 제어, 메시지 추적 검색 및 데이터베이스 복구 관리 등의 항목을 포함합니다.

참고:
일부 항목은 Exchange 2007 서버에서만 사용할 수 있습니다.
참고:
Exchange Troubleshooting Assistant는 영문 버전의 Microsoft Windows® 운영 체제가 실행되는 워크스테이션이나 서버에 설치해야 합니다.


Microsoft Exchange Troubleshooting Assistant 설치
Microsoft Exchange Troubleshooting Assistant 개요 >

최근 수정된 항목: 2007-02-16

Microsoft® Exchange Troubleshooting Assistant를 설치하려면 분석 도구를 실행할 컴퓨터에서 Microsoft 설치 관리자 파일인 ExTRA.msi를 실행합니다. 설치 관리자는 기본적으로 <system drive>\Program Files\ 위치에 ExTRA라는 디렉터리를 만들고 필요한 파일을 이 새 디렉터리에 복사합니다.

설치할 컴퓨터 선택

Exchange Troubleshooting Assistant는 이 도구로 분석 작업할 서버나 이 도구에 대한 액세스 권한이 있는 다른 서버에 설치할 수 있습니다. 원격으로 실행하면 일부 기능을 사용할 수 없습니다.

전용 관리 스테이션을 설치 및 사용하는 방법에 대한 자세한 정보는 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?linkid=21769)를 참조하십시오.

참고:
Exchange Troubleshooting Assistant는 영문 버전의 Microsoft Windows® 운영 체제가 실행되는 워크스테이션이나 서버에 설치하십시오.

Exchange 조직 외부에 있는 컴퓨터에 도구를 설치하려면 Active Directory® 디렉터리 서비스와 Exchange 서버에 로그온하는 데 필요한 사용자 이름과 암호를 명시적으로 설정해야 합니다.

업데이트 확인

Exchange Troubleshooting Assistant를 시작하면 이 도구나 여러 가지 분석기 구성 파일(ExTRA.config.xml, ExPTA.config.xml 또는 ExDRA.config.xml)에 대한 업데이트를 먼저 검색합니다. 이러한 파일들은 정기적인 웹 릴리스 주기나 기타 특별 릴리스에 따라 업데이트 패키지로 업데이트되어 릴리스됩니다. 새 버전이 있으면 다음 절차에서 참조된 페이지에서 새 파일을 다운로드할 수 있습니다. 파일을 다운로드하려면 컴퓨터에 관리자로 로그온해야 합니다. 새 파일을 다운로드하지 않으려는 경우나 이 도구가 인터넷과 연결되지 않은 경우에는 도구가 실행되고 있는 컴퓨터에 있는 파일 복사복이 사용됩니다.

새 버전의 구성 파일을 수동으로 복사하려면 다음을 수행하십시오.

  1. 웹 브라우저에서 http://go.microsoft.com/fwlink/?linkid=50424의 Microsoft Exchange Troubleshooting Tool V1.0 업데이트 페이지를 찾습니다.

  2. 자동 압축 풀기 패키지를 다운로드하고 도구가 설치된 디렉터리(대개 C:\Program Files\ExBPA)와 다른 디렉터리에 새 파일의 압축을 풉니다.

  3. 업데이트 패키지에 들어 있는 파일을 메모합니다.

  4. 업데이트의 영향을 받게 되는 기존 파일의 이름을 바꿉니다.

  5. 도구가 설치된 디렉터리(대개 C:\Program Files\ExBPA)에 압축을 푼 파일을 복사합니다.

Exchange 로컬 컴퓨터가 분석되는 동안에만 작동하는 기능

이 표에는 Exchange Server가 설치된 로컬 컴퓨터를 분석하기 위해 Exchange Troubleshooting Assistant를 사용하는 동안에만 작동하는 기능이 나열되어 있습니다.

작업 | 증상 또는 기능
Exchange Performance Troubleshooter | 증상: 초당 RPC 작업 수가 예상보다 많습니다.
Exchange Mail Flow Troubleshooter | EdgeSync 가입 프로세스를 사용하도록 구성되어 있지 않은 Exchange Server 2007 Edge 전송 서버 역할을 분석할 때 모든 증상입니다.
Exchange Database Recovery Management | 데이터베이스 복구 작업입니다.


이전의 Microsoft Exchange Troubleshooting Assistant 보고서를 보는 방법
Microsoft Exchange Troubleshooting Assistant 개요 >

최근 수정된 항목: 2007-02-16

새 분석을 실행하는 대신, 이전 분석 보고서를 보는데 Microsoft® Exchange Troubleshooting Assistant를 사용할 수 있습니다.

절차

이전의 Exchange Troubleshooting Assistant 보고서 보기

  1. ExTrA.exe를 실행하거나 시작 메뉴에서 적절한 링크를 클릭하여 Exchange Troubleshooting Assistant를 시작합니다.

  2. 최신 업데이트가 있는 경우 다운로드할지 여부를 결정합니다.

  3. 시작 페이지에서 확인할 결과 파일 선택을 선택합니다.

  4. 로컬에 저장된 보고서 목록에서 확인할 보고서를 선택합니다. 도구는 <system drive>\Documents and Settings\<user>\Application Data\Microsoft\ExTRA에 저장된 파일의 목록을 만듭니다. 보고서를 클릭하면 도구에 보고서 파일의 크기 및 이름, 식별 레이블 및 데이터 수집에 사용된 도구 버전에 관한 자세한 정보가 표시됩니다. 또한 페이지의 오른쪽 맨 위에서 결과 파일 가져오기를 클릭하여 다른 위치에서 보고서를 가져올 수 있습니다.

  5. 보고서를 보려면 보고서 보기를 클릭합니다.


Microsoft Exchange Server Troubleshooting Assistant의 문제 해결 방법
Microsoft Exchange Troubleshooting Assistant 개요 >

최근 수정된 항목: 2007-02-16

일반적으로 Microsoft Exchange Server Analyzer - 문서라고 하는 섹션의 Microsoft® Exchange Server Troubleshooting Assistant에 대한 도움말 문서에는 특정 도구를 사용한 Exchange Server 문제 해결 방법에 대한 자세한 내용이 들어 있습니다. 이러한 문서는 다음과 같은 Exchange 주요 환경 영역별로 나누어져 있습니다.

  • Active Directory

  • Exchange 클러스터

  • Exchange Server

  • 하드웨어

  • 네트워크

  • 프로토콜

  • 저장소

  • 타사 소프트웨어

  • 전송

  • Exchange Server 2007 준비

예제 문서와 해당 내용

분석기 문서에 대한 다음 두 가지 예제는 식별된 문제 해결의 수행 과정을 상세하게 문서화하는 방법에 대해 간략하게 설명합니다.

예제 1: 라우팅 엔진: 구성 매개 변수가 기본값임

"라우팅 엔진: 구성 매개 변수가 기본값이 아님" 문서의 전송 범주에 있는 문제 해결 정보는 설정이 기본값에서 수정되었는지 여부를 확인하기 위해 Microsoft Exchange Server Analyzer Tool이 레지스트리 항목을 읽으면서 시작됩니다. 이 문서에서는 생성된 메시지에 대한 발생 원인을 설명하고 해결 방법을 안내합니다. 또한 WinRoute 도구를 사용해 링크 상태 정보를 보도록 권장하며

문제에 대한 기타 배경 정보와 보충 정보를 얻을 수 있는 포인터도 포함되어 있습니다.

예제 2: 일반 대상으로 식별된 사용자

"일반 대상으로 식별된 사용자"는 전송 범주에 해당하며 메일 흐름 문제에 대한 해결 방법 문서 중 하나입니다. 이 문서는 Exchange Troubleshooting Assistant이 특정 WMI 쿼리를 사용하여 큐에 대한 정보를 얻은 다음 오류나 경고를 표시하기 위해 특정 임계값을 적용하는 것을 설명합니다.

마찬가지로 다른 문서에서도 Exchange Troubleshooting Assistant가 문제 해결 단계를 실행할 때 표시하는 각 오류 및 경고와 관련한 기본 논리에 대한 자세한 설명을 얻을 수 있습니다.


Microsoft Exchange Performance Troubleshooting Analyzer Tool 개요
Microsoft Exchange Troubleshooting Assistant 개요 >

최근 수정된 항목: 2007-02-16

Microsoft® Exchange Performance Troubleshooter는 Exchange Server를 실행하는 서버에 영향을 줄 수 있는 성능 관련 문제를 찾고 확인합니다. 이러한 문제를 찾기 위해 다양한 설정, 로그 및 활성 데이터 캡처를 검사합니다. 다음 항목에서는 Exchange Performance Troubleshooter에 대한 자세한 내용을 제공합니다.

  • Microsoft Exchange Troubleshooting Assistant 설치

  • Microsoft Exchange Performance Troubleshooter 실행의 선행 조건

  • Microsoft Exchange Performance Troubleshooter에 대한 사용 권한

  • Microsoft Exchange Performance Troubleshooter를 사용하여 분석 시작

  • Microsoft Exchange Performance Troubleshooter 출력 이해

Exchange Performance Troubleshooter에 대한 사용자 의견, 제안 및 피드백을 보내 주십시오.


Microsoft Exchange Performance Troubleshooter 실행의 선행 조건
Microsoft Exchange Troubleshooting Assistant 개요 > Microsoft Exchange Performance Troubleshooting Analyzer Tool 개요 >

최근 수정된 항목: 2007-02-16

Microsoft® Exchange Performance Troubleshooter는 클라이언트 기반 또는 서버 기반 모드에서 실행됩니다.

선행 조건

Exchange Performance Troubleshooter를 제대로 실행하려면 도구가 실행될 컴퓨터에 Microsoft .NET Framework 1.1이 설치되어 있어야 합니다.

지원 환경

Exchange Performance Troubleshooter는 다음과 같은 환경에서 실행될 수 있습니다.

  • Microsoft Windows Server 2003에서 설치된 Exchange Server 2003(모든 서비스 팩)

  • Windows 2000 SP3 이상 버전에서 설치된 Exchange Server 2003(모든 서비스 팩)

  • Windows 2000 SP3 이상 버전에서 설치된 Exchange 2000 Server SP3 이상 버전

자세한 정보

Exchange Performance Troubleshooter를 설치하는 방법에 대한 자세한 내용은 Microsoft Exchange Troubleshooting Assistant 설치를 참조하십시오.


Microsoft Exchange Performance Troubleshooter에 대한 사용 권한
Microsoft Exchange Troubleshooting Assistant 개요 > Microsoft Exchange Performance Troubleshooting Analyzer Tool 개요 >

최근 수정된 항목: 2007-02-15

필요한 사용 권한을 모두 가진 자격 증명을 사용하여 도구를 실행할 경우 Microsoft® Exchange Performance Troubleshooter는 Active Directory® 디렉터리 서비스와 Exchange를 실행하는 서버에만 액세스할 수 있습니다.

Exchange Performance Troubleshooter를 실행하려면 다음 사용 권한이 있어야 합니다.

  • 연결 단계에서 지정된 글로벌 카탈로그 서버에 대한 도메인 사용자 이상의 사용 권한

  • 분석할 Exchange를 실행하는 각각의 서버에 대한 로컬 관리자 그룹의 구성원. 이러한 사용 권한은 Microsoft WMI(Windows® Management Instrumentation), 레지스트리 및 성능 데이터에 액세스하는 데 필요합니다.

현재 로그온한 사용자의 자격 증명에 Active Directory와 Exchange를 실행하는 서버를 액세스할 수 있는 사용 권한이 모두 포함되어 있지 않는 경우 이 도구 내에서 사용자 이름, 도메인 및 암호를 다시 정의할 수 있습니다.

추가 정보

Exchange Performance Troubleshooter를 설치하는 방법에 대한 자세한 내용은 Microsoft Exchange Performance Troubleshooter 설치를 참조하십시오.

도구를 실행하기 위한 선행 조건에 대한 자세한 내용은 Microsoft Exchange Performance Troubleshooter 실행의 선행 조건을 참조하십시오.


Microsoft Exchange Performance Troubleshooter를 사용하여 분석 시작
Microsoft Exchange Troubleshooting Assistant 개요 > Microsoft Exchange Performance Troubleshooting Analyzer Tool 개요 >

최근 수정된 항목: 2007-02-16

Microsoft® Exchange Performance Troubleshooter는 다양한 소스로부터 데이터를 수집하여 수정 권고 사항을 만듭니다. 각 단계에서 데이터를 수집하여 분석합니다. 각 단계의 결과에 따라 추가적으로 데이터를 수집해야 할 수도 있습니다. 증상과 같은 일부 데이터는 사용자 입력을 필요로 합니다. 기타 데이터는 문제 서버로부터 자동으로 수집됩니다.

증상 선택

분석 프로세스의 첫 단계로 Exchange Performance Troubleshooter에서 증상에 대해 알아 봅니다. 증상에 따라 다양한 문제 해결 단계가 발생합니다.

증상

  • 초당 RPC 작업 수가 예상보다 많습니다.

    Exchange가 실행 중인 서버의 작업량이 예상보다 더 많은 경우 이 증상을 선택합니다. 문제 해결의 일부로서 Microsoft ExMon(Exchange Server User Monitor) 도구를 통해 Microsoft Office® Outlook 및 기타 MAPI 클라이언트의 RPC(원격 프로시저 호출)를 추적합니다. 비정상적으로 높은 사용자 로드가 검색되면 Exchange Performance Troubleshooter에서 서버 성능 문제를 발생시키는 개별 사용자와 같은 문제의 원인을 파악합니다.

  • 여러 사용자가 Outlook 사용 시 지연에 대해 불평하거나 Outlook을 취소할 수 있는 RPC 대화 상자가 자주 표시됩니다.

    사용자가 Outlook 클라이언트 내 작업을 수행할 때 감당할 수 없는 시간 지연이 발생하는 경우 이 증상을 선택합니다. 예를 들어 받은 편지함에서 일정 폴더와 같이 한 폴더에서 다른 폴더로 전환할 때 심각한 시간 지연이 발생할 수 있습니다. 클라이언트 요청에 서버가 제때에 응답하지 않으면 일부 버전의 Outlook 클라이언트에서는 데이터 요청 중 창을 표시합니다. 대개 이러한 문제는 서버 로드나 서버 자체의 지체로 인해 발생합니다. Exchange Performance Troubleshooter에서 지체를 일으킨 원인을 파악합니다.

Exchange Performance Troubleshooter에서 분석이 완료되면 권장 사항 목록이 결과 페이지에 표시됩니다.

데이터 수집

다음과 같은 데이터 리포지토리를 사용하여 구성 설정을 가져옵니다.

  • Active Directory® 디렉터리 서비스

  • Microsoft WMI(Windows Management Instrumentation)

  • 레지스트리

또는 도구는 사용 중인 데이터를 캡처하여 성능 문제의 근본 원인을 파악합니다. 다음과 같은 데이터 리포지토리는 실시간 데이터를 샘플링하는 데 사용됩니다.

  • PDH(성능 데이터 도우미) 라이브러리

  • Microsoft ExMon(Exchange Server User Monitor) 도구로 데이터 추적

실시간 데이터의 경우 카운터와 로그가 주어진 기간에 걸쳐 샘플링됩니다. 이런 유형의 수집 작업을 완료하려면 몇 분이 소요될 수 있습니다.

추가 정보

Exchange Performance Troubleshooter에 대한 자세한 내용은 Microsoft Exchange Performance Troubleshooting Analyzer Tool 개요를 참조하십시오.

이 도구의 출력에 대한 자세한 내용은 Microsoft Exchange Performance Troubleshooter 출력 이해를 참조하십시오.


Microsoft Exchange Performance Troubleshooter 출력 이해
Microsoft Exchange Troubleshooting Assistant 개요 > Microsoft Exchange Performance Troubleshooting Analyzer Tool 개요 >

최근 수정된 항목: 2007-02-16

Microsoft® Exchange Performance Troubleshooter는 서버를 분석하는 동안 도구에 의해 수집된 데이터 결과를 표시하는 보고서를 만듭니다. 다음과 같은 5가지의 보기 유형 중에서 선택할 수 있습니다.

  • 치명적인 문제 목록 성능에 영향을 줄 수 있는 근본 원인 문제 및 기타 요인을 표시합니다.

  • 자세히 보기 분석 중 수집된 모든 데이터를 포함하는 트리 모양의 구조를 표시합니다.

  • 전체 문제 목록 성능 문제를 해결하기 위한 문제의 근본 원인 및 기타 제안을 표시합니다.

  • 런타임 로그 도구의 내부 처리 상태를 표시합니다.

  • 요약 보기 모든 권장 사항이 포함되어 있는 트리 모양의 구조를 표시합니다.

치명적인 문제 목록과 전체 문제 목록에서 오류나 경고 문제를 클릭하면 설명을 볼 수 있습니다. 그런 다음 이 문제와 해결 방법에 대해 자세히 알아봅니다.를 클릭하면 자세한 정보를 볼 수 있습니다.

보고서 창에서는 수집된 데이터를 인쇄하거나 내보내도록 선택할 수 있습니다. 지원되는 내보내기 형식에는 XML, HTML 및 CSV(쉼표로 구분된 값)가 있습니다.

참고:
수집된 모든 데이터는 <system drive>\Documents and Settings\<user>\Application Data\Microsoft\ExPTA에 있는 출력 XML 파일에 저장됩니다.

경우에 따라서는 새 분석을 시작하지 않고 이전 분석 보고서를 보게 될 경우가 있습니다. 이전 보고서를 보는 방법에 대한 자세한 내용은 이전의 Microsoft Exchange Troubleshooting Assistant 보고서를 보는 방법을 참조하십시오.


Microsoft Exchange Mail Flow Troubleshooter 개요
Microsoft Exchange Troubleshooting Assistant 개요 >

최근 수정된 항목: 2007-02-16

Microsoft® Exchange Mail Flow Troubleshooter는 다음 기능을 쉽게 수행하도록 해 주는 진단 도구입니다.

  • 메일 흐름 증상으로 시작한 다음 올바른 문제 해결 단계로 안내합니다.

  • 메일 흐름 관련 문제를 해결하는 데 필요한 여러 가지 데이터 소스에 쉽게 액세스할 수 있도록 합니다.

  • 검색된 데이터에 대해 자동으로 진단하여 추측 가능한 근본 원인을 분석한 자료를 제공합니다.

  • 수정 조치를 제안합니다.

  • 자동 진단이 불가능한 경우에는 사용자가 데이터를 수동으로 진단할 수 있도록 안내합니다.

Exchange Mail Flow Troubleshooter에 대한 사용자 의견, 제안 및 피드백을 보내 주십시오. 다음과 같이 피드백을 전달할 수 있습니다.

  • Microsoft 공용 뉴스 그룹 Exchange Mail Flow Troubleshooter 개발 팀의 구성원은 Exchange Server 및 Outlook에 대한 뉴스 그룹 사이트(http://go.microsoft.com/fwlink/?linkid=14926)를 자주 모니터합니다.

  • 이 뉴스 그룹 및 다른 Microsoft 뉴스 그룹에 참여하는 방법에 대한 자세한 내용은 Microsoft Exchange Analyzers 웹 사이트(http://go.microsoft.com/fwlink/?linkid=33938) 및 Microsoft 기술 지원 뉴스 그룹 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=50219)를 참조하십시오.


Microsoft Exchange Mail Flow Troubleshooter 실행의 선행 조건

Microsoft Exchange Mail Flow Troubleshooter 실행의 선행 조건 |
 | 참고 항목
Microsoft Exchange Troubleshooting Assistant 개요 > Microsoft Exchange Mail Flow Troubleshooter 개요 >

최근 수정된 항목: 2006-08-11

Microsoft® Exchange Mail Flow Troubleshooter는 클라이언트 기반 또는 서버 기반 모드에서 실행할 수 있습니다.

Exchange Mail Flow Troubleshooter를 제대로 실행하려면 Exchange 조직에 있는 컴퓨터에서 몇 가지 선행 조건을 만족해야 합니다. 이러한 요구 사항이 충족되지 않아도 많은 경우 도구는 실행되지만 모든 기능을 실행할 수 없거나 실행되는 성능 수준이 저하될 수 있습니다.

이 항목에는 Exchange Mail Flow Troubleshooter를 실행하기 위한 선행 조건 및 지원 환경에 대한 정보가 있습니다.

선행 조건

Exchange Mail Flow Troubleshooter를 제대로 실행하려면 도구가 실행될 컴퓨터에 Microsoft .NET Framework 1.1이 설치되어 있어야 합니다.

지원 환경

중요:
Exchange Server 토폴로지에 Exchange Server 2007(시험판 버전 포함)이 포함된 경우 Exchange Mail Flow Troubleshooter가 제대로 작동하지 않거나 일부 기능을 사용할 수 없습니다.

Exchange Mail Flow Troubleshooter는 다음과 같은 환경에서 실행될 수 있습니다.

  • Microsoft Windows Server 2003에서 설치된 Exchange Server 2003(모든 서비스 팩)

  • Windows 2000 Server SP3 이상 버전에서 설치된 Exchange Server 2003(모든 서비스 팩)

  • Exchange 2000 Server SP3 이상에서 설치된 Exchange 2000 Server SP3 이상 버전

참고:
Exchange Mail Flow Troubleshooter의 일부 기능은 Exchange Server 2003에서만 사용할 수 있습니다. Exchange 2000 Server 및 Windows Server 2000은 Exchange Server 2003 및 Windows Server 2003보다 데이터 검색을 위한 인터페이스가 더 적기 때문입니다.

참고 항목

개념

Microsoft Exchange Mail Flow Troubleshooter에 대한 사용 권한

© 2007 Microsoft Corporation. All rights reserved.


Microsoft Exchange Mail Flow Troubleshooter에 대한 사용 권한

Microsoft Exchange Mail Flow Troubleshooter에 대한 사용 권한 |
 | 참고 항목
Microsoft Exchange Troubleshooting Assistant 개요 > Microsoft Exchange Mail Flow Troubleshooter 개요 >

최근 수정된 항목: 2007-02-15

필요한 사용 권한을 모두 가진 자격 증명을 사용하여 도구를 실행할 경우 Microsoft® Exchange Mail Flow Troubleshooter는 Active Directory® 디렉터리 서비스와 Exchange Server에만 액세스 할 수 있습니다.

사용 권한

Exchange Mail Flow Troubleshooter를 실행하려면 다음 사용 권한이 있어야 합니다.

  • 도메인 관리자 또는 Active Directory 서버의 Builtin\Administrators 그룹 구성원 - Active Directory 정보를 열거하고 도메인 컨트롤러와 글로벌 카탈로그 서버에서 Microsoft WMI(Windows® Management Instrumentation) 공급자를 호출

  • 각 Exchange Server의 로컬 관리자 그룹 구성원 - WMI 공급자를 호출하고 레지스트리와 메타베이스에 액세스

  • 최소한 Exchange 조직에서 Exchange 보기 권한만 있는 사용 권한 위임

사용 권한이 충분하지 않은 계정으로 Exchange Mail Flow Troubleshooter가 실행될 컴퓨터에 로그온하는 경우 이 도구의 서버 및 사용자 정보 입력 페이지에서 사용할 계정의 자격 증명을 설정해야 합니다. 고급 로그온 옵션 표시를 클릭하고 옵션을 확장합니다. 계정은 하나만 입력할 수 있습니다. 따라서 계정에 필요한 모든 사용 권한이 갖춰졌는지 확인합니다.

참고 항목

개념

Microsoft Exchange Mail Flow Troubleshooter 실행의 선행 조건

© 2007 Microsoft Corporation. All rights reserved.


Microsoft Exchange Mail Flow Troubleshooter를 사용하여 분석 시작

Microsoft Exchange Mail Flow Troubleshooter를 사용하여 분석 시작 |
 | 참고 항목
Microsoft Exchange Troubleshooting Assistant 개요 > Microsoft Exchange Mail Flow Troubleshooter 개요 >

최근 수정된 항목: 2006-08-10

Microsoft® Exchange Mail Flow Troubleshooter는 다양한 원본으로부터 데이터를 수집하여 수정 권고 사항을 만듭니다. 각 단계에서 데이터를 수집하여 분석합니다. 각 단계의 결과에 따라 추가적으로 데이터를 수집해야 할 수도 있습니다. 증상과 같은 일부 데이터는 사용자 입력을 필요로 합니다. 기타 데이터는 문제 서버에서 자동으로 수집됩니다.

증상 선택

분석 프로세스의 첫 단계로 Exchange Mail Flow Troubleshooter에서 발견되는 증상에 대해 알아 봅니다. 증상에 따라 다양한 문제 해결 단계가 발생합니다.

증상

  • 사용자가 메시지를 보낼 때 배달 실패 보고서(NDR)를 받는 것에 대해 불평합니다.

    메시지가 되돌아 오고 배달 실패 보고서(NDR)가 보낸 사람에게 전송되는 경우 이 증상을 선택합니다. NDR은 Exchange 조직 외부 또는 내부로부터 전송될 수 있습니다. Exchange Mail Flow Troubleshooter는 사용자가 이 증상에 대한 올바른 문제 해결 단계를 결정할 수 있도록 안내합니다. 근본 원인이 Exchange 서버 외부에 있을 수 있기 때문에 문제 해결 안내는 매우 중요합니다.

  • 인터넷을 통해 외부에서 보내지는 메시지는 지체되거나 일부 받는 사람에게 전달되지 않습니다.

    이 증상과 다음 증상은 유사합니다. 회사 Exchange Server 조직으로 메시지가 전송되지 않거나 경계에서 Exchange가 아닌 게이트웨이 서버를 통해 메시지가 들어오는 경우 이 증상을 선택합니다. Exchange Mail Flow Troubleshooter는 Exchange Server 조직 내부와 게이트웨이를 모두 검사합니다.

  • 인터넷의 외부 받는 사람에게 보내지는 메시지는 지체되거나 일부 받는 사람에게 전달되지 않습니다.

    회사 Exchange Server 조직 외부로 전달되어야 하는 메시지가 기업 Exchange Server 조직에 머무르고 있거나 메시지가 경계에서 Exchange가 아닌 게이트웨이 서버를 통해 전송될 수 없는 경우 이 증상을 선택합니다. Exchange Mail Flow Troubleshooter는 Exchange Server 조직 내부와 게이트웨이를 모두 검사합니다(이전 증상에서와 같이).

  • 메시지는 서버에서 하나 이상의 큐에 백업됩니다.

    메시지가 Exchange Server 큐(주목할 만한 것으로는 원격 배달 큐, 디렉터리 조회 대기 큐 및 로컬 배달 큐가 있음)에 머무르고 있는 경우 이 증상을 선택합니다. 메시지가 라우팅되는 경로에 따라, 인터넷을 통해 들어오고 나가는 메시지 뿐만 아니라 동일한 Exchange Server 조직에서 라우팅되는 메시지가 백업에 의해 영향을 받습니다. 그러므로 이 증상을 처리하면 이러한 증상 목록에 있는 두 번째와 세 번째 문제도 처리할 수 있게 됩니다.

  • 사용자가 보낼 편지함에 메시지가 백업된다고 보고합니다(Exchange Server 2007에만 적용됨).

    메시지가 사용자의 사서함 서버에 머물고 있고 다른 서버로 전송되지 않는 경우 이 증상을 선택합니다. Exchange Mail Flow Troubleshooter는 사서함 역할과 Hub 전송 역할을 모두 검사합니다.

증상을 선택한 뒤에는 서버 및 사용자 정보를 묻는 메시지가 표시되며 해당 정보를 입력하면 분석이 시작됩니다. Exchange Mail Flow Troubleshooter가 분석을 완료하면 권장 사항 목록이 결과 페이지에 나타납니다.

데이터 수집

Exchange Mail Flow Troubleshooter는 여러 원본에서 데이터를 수집합니다. 다음 데이터 리포지토리를 사용하여 구성 설정을 가져옵니다.

  • Active Directory® 디렉터리 서비스

  • Microsoft WMI(Windows® Management Instrumentation)

  • 레지스트리

또한 도구는 사용 중인 데이터를 캡처하여 메일 흐름 문제의 근본 원인을 파악합니다. 데이터 리포지토리 PDH(성능 데이터 도우미) 라이브러리를 사용하여 실시간 데이터를 샘플링합니다.

실시간 데이터의 경우 카운터 및 로그가 주어진 기간에 걸쳐 샘플링됩니다. 이런 유형의 수집 작업을 완료하려면 몇 분이 소요될 수 있습니다.

참고 항목

개념

Microsoft Exchange Mail Flow Troubleshooter 개요
Microsoft Exchange Mail Flow Troubleshooter 출력 이해

© 2007 Microsoft Corporation. All rights reserved.


Microsoft Exchange Mail Flow Troubleshooter 출력 이해

Microsoft Exchange Mail Flow Troubleshooter 출력 이해 |
 | 참고 항목
Microsoft Exchange Troubleshooting Assistant 개요 > Microsoft Exchange Mail Flow Troubleshooter 개요 >

최근 수정된 항목: 2007-02-16

Microsoft® Exchange Mail Flow Troubleshooter는 서버를 분석하는 동안 도구에 의해 수집된 데이터의 결과를 표시하는 보고서를 만듭니다. 다음과 같은 3가지 보고서 유형 중에서 선택할 수 있습니다.

  • 목록 보고서는 다음과 같이 구성됩니다.

    • 개요 조사 대상인 서버의 전체 상태 표시

    • 근본 원인 식별된 문제의 가능한 근본 원인 표시

    • 메일 흐름 문제 메일 흐름에 영향을 줄 수 있는 중요한 문제 표시

    • 기타 오류 메일 흐름 외의 문제 표시

    • 경고 일반적으로 권장되지 않는 문제 표시

    • 권장 사항 알려진 권장 사항 표시

    • 정보 항목 문제가 아닌 항목 표시

  • 트리 보고서는 다음과 같이 구성됩니다.

    • 자세히 보기 분석 중 수집된 모든 데이터를 포함하는 트리와 유사한 구조 표시

    • 요약 보기 근본 원인, 오류, 경고, 관심 항목 및 권장 사항을 포함하는 트리와 유사한 구조 표시

  • 기타 보고서는 다음과 같이 구성됩니다.

    • 런타임 로그 도구의 내부 처리 상태 표시

목록 보고서 보고서 유형에서, 임의의 오류 또는 경고 문제를 클릭하면 설명을 볼 수 있습니다. 그런 다음 이 문제와 해결 방법에 대해 자세히 알아봅니다.를 클릭하면 자세한 정보를 볼 수 있습니다.

보고서 창에서 수집된 데이터를 인쇄하거나 내보내도록 선택할 수 있습니다. 지원되는 내보내기 형식에는 XML, HTML 및 CSV(쉼표로 구분된 값)가 있습니다.

참고:
수집된 모든 데이터는 <system drive>\Documents and Settings\<user>\Application Data\Microsoft\ExMFA에 있는 출력 XML 파일에 저장됩니다.

참고 항목

개념

Microsoft Exchange Mail Flow Troubleshooter를 사용하여 분석 시작

© 2007 Microsoft Corporation. All rights reserved.


Microsoft Exchange Database Recovery Management 개요
Microsoft Exchange Troubleshooting Assistant 개요 >

최근 수정된 항목: 2007-02-16

Microsoft® Exchange Database Recovery Management는 Exchange Server 데이터베이스 및 사용 가능한 트랜잭션 로그 파일에서 데이터베이스 복구 기능에 영향을 주는 문제를 검색합니다. 그런 다음 누락되었거나 손상된 로그 파일을 보고하고 해당 데이터베이스를 탑재 가능한 완전한 상태로 만들어 주는 단계를 안내합니다.

Exchange Database Recovery Management에는 다음과 같은 기능이 있습니다.

  • 트랜잭션 로그 파일을 재생할 수 없는 상황에 의해 발생된 데이터베이스 탑재에 관련한 문제 해결

  • "로그 드라이브 풀" 상황을 해결하기 위해 초과 트랜잭션 로그 파일을 안전하게 이동시켜 주는 마법사

  • Exchange 데이터베이스 관련 이벤트를 편리하게 보고 정렬할 수 있는 이벤트 로그 필터와 뷰어

  • 복구 저장소 그룹을 만들고 제거할 수 있는 복구 저장소 그룹 관리자(Exchange 2007의 경우에만 해당). 이 관리자를 사용하면 사서함 내용을 원본 또는 보관 사서함에 병합할 수도 있습니다.

Exchange Database Recovery Management에 대한 사용자 의견, 질문 및 제안을 보내 주십시오. 다음과 같이 피드백을 전달할 수 있습니다.

  • Microsoft 공용 뉴스 그룹 Exchange Database Recovery Management 개발 팀의 구성원은 news.microsoft.com의 microsoft.public.exchange.tools 뉴스 그룹을 자주 모니터합니다. 이 뉴스 그룹 및 다른 Microsoft 뉴스 그룹에 참여하는 방법에 대한 자세한 내용은 Microsoft Product Support Newsgroups 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=50219)를 참조하십시오.

  • Exchange Database Recovery Management 설명서 피드백 Exchange Database Recovery Management와 함께 제공된 설명서 및 문서에 대한 의견이나 질문이 있으시면 extoolfb@microsoft.com으로 피드백을 보내 주십시오.


Microsoft Exchange Database Recovery Management 실행의 선행 조건
Microsoft Exchange Troubleshooting Assistant 개요 > Microsoft Exchange Database Recovery Management 개요 >

최근 수정된 항목: 2007-02-16

Microsoft® Exchange Database Recovery Management는 자동 검색 또는 수동 입력이라는 두 가지 모드로 실행됩니다. 자동 검색 모드에서 Exchange Database Recovery Management는 Exchange 서버에 대한 Microsoft Active Directory® 디렉터리 서비스 구성에 액세스하여 구성된 경로 위치에 있는 데이터베이스 및 트랜잭션 로그 파일을 자동으로 찾을 수 있습니다. 수동 입력 모드에서는 사용자가 데이터베이스 및 트랜잭션 로그 파일로의 경로를 명시적으로 지정합니다.

선행 조건

  • 자동 검색 모드에서는 Active Directory에 Exchange 구성 정보를 읽을 수 있는 필요한 권한이 있어야 하며 Exchange 데이터가 저장되는 Exchange 서버 폴더에 대해 읽기 및 쓰기 권한이 있어야 합니다.

  • Exchange Database Recovery Management를 제대로 실행하려면 Exchange Database Recovery Management가 실행될 컴퓨터에 .NET Framework 1.1이 설치되어 있어야 합니다.

  • Exchange Database Recovery Management는 Microsoft Windows 2000 Server, Microsoft Windows Server 2003 및 Microsoft Windows XP가 실행되는 컴퓨터에서 실행할 수 있습니다.

지원 환경

Exchange Database Recovery Management는 다음과 같은 환경에서 실행됩니다.

  • Windows 2000 Server SP3 이상에 설치된 Exchange 2000 Server SP3 이상

  • Windows 2000 Server SP3 이상에 설치된 Exchange Server 2003(모든 서비스 팩)

  • Windows Server 2003에 설치된 Exchange Server 2003(모든 서비스 팩)


Microsoft Exchange Disaster Recovery Analyzer Tool의 성능에 대한 영향
Microsoft Exchange Troubleshooting Assistant 개요 > Microsoft Exchange Database Recovery Management 개요 >

최근 수정된 항목: 2007-02-16

Microsoft® Exchange Database Recovery Management가 Active Directory® 디렉터리 서비스 성능 또는 Exchange 서버 성능에 미치는 영향은 거의 없습니다. Exchange Database Recovery Management는 데이터베이스와 트랜잭션 로그 파일의 시작 부분에 있는 헤더 정보를 읽고 로그 파일을 검색하여 무결성을 확인합니다. Exchange Database Recovery Management는 완전히 읽기 전용 모드로 작동하며 데이터베이스나 트랜잭션 로그 파일을 변경하지 않습니다.


Task Center
Microsoft Exchange Troubleshooting Assistant 개요 > Microsoft Exchange Database Recovery Management 개요 >

최근 수정된 항목: 2007-02-16

Task Center 페이지는 Microsoft® Exchange Database Recovery Management의 핵심입니다. Task Center는 해결하려는 증상 또는 작업을 선택하는 곳입니다. Task Center 페이지에 액세스하기 전에 작업을 수행할 서버를 선택하거나 수동 모드를 선택해야 합니다.

Task Center에 나타나는 옵션은 작업하기 위해 선택한 서버에 따라 다릅니다. 관련이 없는 옵션은 표시되지 않습니다. 예를 들면 Exchange Server 2003 서버로 작업하기로 결정한 경우 Exchange Server 2007에서만 작업할 수 있는 기능은 숨겨집니다.

Task Center에서 사용할 수 있는 기능은 다음과 같습니다.

  • 데이터베이스 탑재 문제 해결

    이 문제 해결사는 서버의 문제를 초기에 진단하기 위해 Exchange 서버의 응용 프로그램 로그를 읽습니다. 문제가 여러 개인 경우 우선적으로 해결할 문제를 선택할 수 있습니다. 그런 다음 문제를 확인하고 문제를 수정하는 데 도움이 되는 추가 분석을 수행합니다.

  • 로그 드라이브 공간 분석

    이 마법사는 서버의 각 저장소 그룹에 대해 사용할 수 있는 트랜잭션 로그 파일 공간을 확인하고 디스크 공간이 부족할 경우 로그를 백업 위치로 이동하도록 합니다.

    Exchange 서버 저장소 그룹에 트랜잭션 로그 파일을 위한 디스크 공간이 부족할 경우 데이터베이스가 종료됩니다. 디스크 공간 문제를 해결해야만 데이터베이스를 다시 시작할 수 있습니다. 잘못된 로그 파일을 삭제한 경우 데이터베이스를 영구적으로 시작할 수 없을 수도 있습니다. Exchange Database Recovery Management는 안전하게 이동할 수 있는 로그 파일을 결정하고 다른 드라이브 또는 서버의 백업 위치로 해당 로그 파일을 이동합니다. 저장소 그룹의 모든 데이터베이스를 완전히 새로 백업한 뒤에만 이동한 로그를 삭제할 수 있습니다.

  • 데이터베이스 관련 이벤트 로그 표시

    응용 프로그램 로그에 있는 다수의 경고 및 오류 이벤트는 데이터베이스 문제와 관련이 있을 수 있습니다. 관련 이벤트와 이벤트가 표시하는 "메시지 내용"이 일치하는 경우는 흔치 않습니다. Analyzer의 이러한 기능은 Exchange 데이터베이스와 관련된 이벤트를 필터링하여 검색 및 정렬이 간편한 형식으로 나타냅니다.

  • Exchange 2007의 복구 저장소 그룹 관리자

    Exchange 2007의 Exchange 관리 콘솔에는 복구 저장소 그룹 관리 기능이 없습니다. 대신에 복구 저장소 그룹 관리는 Windows PowerShell 명령줄이나 이 도구의 복구 저장소 그룹 관리자에서 수행할 수 있습니다.

    Exchange 2003 인터페이스를 개선한 복구 저장소 그룹 관리자는 모든 관리 작업을 단일 위치에 통합함으로써 손쉽게 복구 저장소 그룹 관리를 수행합니다. 또한 중간 .pst 파일을 사용하지 않고도 사서함 콘텐츠를 복구 저장소 그룹에서 다시 원래 사서함 또는 다른 사서함으로 복사할 수 있도록 합니다. 병합 기능을 사용하여 여러 사서함의 콘텐츠를 하나의 보관 사서함으로 복사할 수도 있습니다.

  • 데이터베이스 복구

    이 마법사는 손상된 데이터베이스에 대해 자동으로 데이터베이스 복구, 데이터베이스 조각 모음 및 Isinteg를 실행하고 일관성 있는 상태로 되돌리려고 합니다. 이 기능은 로컬 컴퓨터에 대해 도구를 실행하는 경우에만 사용할 수 있습니다.

  • 로그 생성 번호 다시 설정

    이 마법사는 기존 트랜잭션 로그 파일을 백업 위치로 이동하여 데이터베이스가 새 로그 생성 번호로 마운트될 수 있도록 합니다. 이 마법사를 실행하려면 저장소 그룹의 모든 데이터베이스를 분리해야 하며 Exchange 2000 Server 및 Exchange Server 2003에만 사용할 수 있습니다.


Microsoft Exchange Server Analyzer - 문서

최근 수정된 항목: 2006-10-06

이 섹션에 제공되는 문서는 다음 Microsoft® Exchange Analyzer가 생성하는 규칙과 결과 메시지를 나타냅니다.

  • Exchange Best Practices Analyzer

  • Exchange Troubleshooting Assistant

Exchange Troubleshooting Assistant에서는 다음과 같은 기능을 액세스할 수 있습니다.

  • Exchange Performance Troubleshooter

  • Exchange Database Troubleshooter

  • Exchange Database Recovery Management

  • Exchange Mail Flow Troubleshooter

각 문서는 Exchange Server Analyzer를 통해 감지될 수 있는 단일 오류, 경고 또는 기본 구성이 아니라는 메시지에 대해 설명합니다.

Microsoft Exchange Analyzers 웹 페이지인 http://go.microsoft.com/fwlink/?linkid=34707에서는 Exchange Best Practice Analyzer와 Exchange Troubleshooting Assistant의 최신 버전을 다운로드할 수 있습니다. 또한 시스템 요구 사항 정보와 분석기에 대한 토론을 위한 뉴스 그룹 링크도 제공합니다.

Exchange Best Practices의 자동 업데이트 기능을 사용할 수 없는 환경에서 실행 중인 경우에는 Microsoft Exchange Best Practices Analyzer Web Update Pack 웹 페이지인 http://go.microsoft.com/fwlink/?linkid=34290을 액세스할 수 있습니다. 이 페이지에서는 가장 최근의 구성 파일 및 도움말 파일을 다운로드할 수 있습니다.

참고:
업데이트가 자동으로 적용되는 경우라면 이 다운로드를 사용할 필요가 없습니다.


Active Directory
Microsoft Exchange Server Analyzer - 문서 >

최근 수정된 항목: 2005-11-17

이 섹션의 문서에서는 Microsoft® Exchange Server Analyzer Tool이 평가하는 Active Directory® 디렉터리 서비스 관련 내용에 대해 자세히 설명합니다. 또한 이 문서에서는 Exchange Server Analyzer에서 발견하는 Active Directory 관련 오류, 경고 및 기본이 아닌 구성을 해결하기 위해 사용자가 취해야 할 조치를 설명합니다.


Active Directory Connector 서버가 다운되거나 연결할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 원격 프로시저 호출(RPC)을 사용하여 Active Directory Connector 서버의 다음 레지스트리 키에서 CurrentVersion 문자열 값을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Microsoft Windows® 2000 Server를 실행하는 컴퓨터의 경우 CurrentVersion 문자열의 올바른 값은 5.0입니다. Windows Server™ 2003을 실행하는 컴퓨터의 경우 올바른 값은 5.2입니다.

Exchange Server Analyzer가 어떤 이유로든 이 레지스트리 값을 읽을 수 없으면 오류가 표시됩니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ADC 서버가 시작되었는지, 네트워크에 연결되어 있는지 확인합니다.

  2. PING 명령을 사용하여 ADC 서버의 연결 상태를 확인합니다.

  3. 방화벽이 설치되어 있으면 RPC 포트가 차단되었는지 확인합니다.

  4. ADC 서버의 원격 레지스트리 서비스가 시작되었는지 확인합니다.

  5. Exchange Server Analyzer를 실행 중인 계정에 ADC 서버의 레지스트리를 읽을 수 있는 사용 권한이 있는지 확인합니다.

네트워크 연결 문제 해결에 대한 자세한 내용은 다음을 참조하십시오.

  • Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?LinkId=56285)


Active Directory Connector 서버는 연결 동의(CA)를 실행하고 있지 않으며 제거 후보입니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 ADC(Active Directory Connector) 서버에서 실행 중인 연결 동의(CA)를 나타내는 msExchChildSyncAgreements 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성 값은 다중값 문자열로 Active Directory 개체인 CN=Active Directory Connector(ServerName),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuratio,DC=Domain,DC=com에서 설정됩니다.

Exchange Server Analyzer는 이 특성의 항목 수(개수)를 검색합니다. 개수가 0이면 연결 동의(CA)가 실행되고 있지 않으므로 경고가 표시됩니다.

필요한 모든 연결 동의(CA)를 다른 ADC 서버에서 실행하고 있으면 이 서버에서 ADC 서비스를 제거하거나 사용하지 않도록 설정해야 합니다. 연결 동의(CA) 없이 ADC 서비스를 실행해도 문제는 발생하지 않습니다. 그러나 서비스가 필요 없는 경우에는 해당 서비스를 실행하지 않도록 설정하는 것이 좋습니다. 따라서 이 ADC 서버에서 ADC 서비스를 사용하지 않도록 설정하거나 제거해야 합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. ADC 서비스를 실행 중인 서버에서 ADC 서비스를 사용하지 않도록 설정하려면 바탕 화면에서 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 관리를 클릭합니다.

  2. 서비스 및 응용 프로그램 노드를 확장한 다음 서비스 노드를 클릭합니다.

  3. 오른쪽 창에서 Microsoft Active Directory Connector를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  4. 시작 유형을 사용 안 함으로 변경합니다. 컴퓨터를 다시 시작하면 ADC 서비스가 시작되지 않습니다.

  5. 적용을 클릭한 다음 확인을 클릭합니다.

ADC 서비스를 제거하려면 Microsoft Exchange 2000 Server나 Exchange Server 2003 CD를 사용합니다. \ADC\I386 폴더로 이동하고 Setup.exe 프로그램을 두 번 클릭합니다. 표시되는 지시에 따라 ADC 서비스를 제거합니다.

Active Directory Connector에 대한 자세한 내용은 다음 Microsoft 기술 지원 웹캐스트를 참조하십시오.

  • "Support Webcast: Introduction to the Active Directory Connector"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300)

  • "Support Webcast: Microsoft Advanced Active Directory Connector"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221)

  • Active Directory Connector 설치 및 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 312632, "HOWTO: Exchange 2000 Server에서 Active Directory Connector 설치 및 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632)을 참조하십시오.


Active Directory Connector 서버에서 최신 Windows 2000 Server 서비스 팩이 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 ADC(Active Directory Connector) 서버의 ServicePackMajorVersion 키 값을 확인할 때 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 검사합니다. 또한 Exchange Server Analyzer는 다음 레지스트리 항목을 검사하여 ADC 서버에서 실행 중인 Windows 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Exchange Server Analyzer는 ADC 서버에 Microsoft Windows 2000 Server 운영 체제가 실행되고 있지만 Windows 2000 Server 서비스 팩 4(SP4)가 실행되고 있지 않는 경우 경고를 표시합니다.

Exchange 배포 시 ADC 서버를 비롯한 모든 소프트웨어의 최신 서비스 팩을 실행하는 것이 좋습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 이 ADC 서버와 Windows 2000 Server 운영 체제가 실행되는 기타 서버를 SP4 및 Windows 업데이트 사이트에 있는 최신 핫픽스와 업데이트로 업데이트합니다.

  2. Windows 2000 Server 운영 체제가 실행되는 다른 모든 Exchange Server 컴퓨터를 최신 서비스 팩 및 롤업으로 업데이트합니다.

Windows 2000 Server 운영 체제의 서비스 팩을 받고 설치하는 방법에 대한 자세한 내용은 http://go.microsoft.com/fwlink/?LinkId=18353을 참조하십시오.

Exchange Server 서비스 팩 및 롤업을 받고 설치하는 방법에 대한 자세한 내용은 http://go.microsoft.com/fwlink/?LinkId=21573을 참조하십시오.


Active Directory Connector 서버가 오버로드되었을 수도 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 ADC(Active Directory Connector) 서버에서 실행 중인 연결 동의(CA)를 나타내는 msExchChildSyncAgreements 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성은 다중값 문자열로 Active Directory 개체인 CN=Active Directory Connector (ServerName),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com에서 설정됩니다.

Exchange Server Analyzer는 이 특성의 항목 수(개수)를 검색합니다. 개수가 80을 초과할 경우 경고를 표시합니다.

ADC 서버당 연결 동의(CA)는 80개 미만으로 실행하는 것이 좋습니다. 권장되는 최대 연결 동의(CA) 수를 호스팅하지 않는 추가 ADC 서버가 있을 경우 연결 동의(CA) 중 일부를 이 서버에서 다른 ADC 서버로 이동합니다. 다른 ADC 서버가 없을 경우 다른 Microsoft® Windows® 2000 Server 또는 Windows Server™ 2003을 실행하는 컴퓨터에서 Microsoft Exchange 2000 Server나 Exchange Server 2003에 포함되어 있는 ADC를 설치합니다.

연결 동의(CA)를 한 ADC 서버에서 다른 ADC 서버로 이동해도 특정 연결 동의의 핵심 특성은 변경되지 않습니다. 예를 들어 복제하도록 구성된 데이터뿐만 아니라 복제에 사용되는 원본 및 대상 컨테이너도 변경되지 않습니다. 연결 동의(CA)를 이동하면 해당 연결 동의를 실행했던 ADC 서버만 변경됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 시작, 프로그램을 차례로 클릭하고 관리 도구를 가리킨 다음 Active Directory Connector 관리를 클릭하여 ADC 관리 콘솔을 엽니다.

  2. MMC 콘솔의 왼쪽 창에 ADC 서비스를 실행하는 서버의 목록이 나타납니다. 이동할 연결 동의(CA)가 위치한 서버의 ADC를 선택합니다.

  3. MMC 콘솔의 세부 정보 창에 선택한 ADC 서버에서 호스팅되는 연결 동의(CA)가 나타납니다.

  4. 이동할 연결 동의(CA)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 일반 탭의 연결 동의(CA)를 실행할 서버 선택 드롭다운 목록에서 이 연결 동의(CA)를 실행할 서버를 선택한 다음 확인을 클릭합니다.

  6. 연결 계정(Windows Server)에서 ADC 서비스 계정과 암호를 입력한 다음 확인을 클릭합니다.

  7. 연결 계정(Exchange Server)에서 Exchange 서비스 계정과 암호를 입력한 다음 확인을 클릭합니다.

연결 동의(CA) 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서, "XADM: How to Move a Connection Agreement to Another Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=326060)를 참조하십시오.

다른 서버에서 Exchange 2000 Server ADC 프로그램을 설치하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서, 312632 "Exchange 2000 Server에서 Active Directory Connector 설치 및 구성"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312632)을 참조하십시오.

다른 서버에서 Exchange Server 2003 ADC 프로그램을 설치하는 방법에 대한 자세한 내용은 "Exchange Server 2003 배포 가이드"(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.


Active Directory Connector 소프트웨어 업데이트가 필요합니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-10-10

Microsoft® Exchange Server Analyzer Tool은 ADC(Active Directory Connector) 파일인 Adc.exe의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Version WMI 키는 이 파일의 빌드 번호를 나타냅니다.

또한 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스를 쿼리하여 Active Directory에 있는 포리스트 개체의 msDS-Behavior-Version 특성 값인 NTDS 설정을 확인합니다. 이 값은 Active Directory 포리스트 기능 수준을 나타냅니다. msDS-Behavior-Version 특성에 유효한 값은 다음 표에 표시되어 있습니다.

값 | 포리스트 기능 수준
0 | Microsoft Windows 2000 Server 혼합
1 | Windows Server™ 2003 임시
2 | Windows Server 2003 전용

Exchange Server Analyzer에서 Adc.exe의 빌드 번호가 Active Directory 포리스트의 Exchange Server가 실행 중인 컴퓨터에서 Windows Server 2003 임시 또는 전용 모드로 6.0.6615.0 이하임을 확인하면 오류를 표시합니다. 이 오류는 받는 ADC 프로그램의 Exchange 2000 Server 버전이 호환되지 않는 Windows Server 2003 Active Directory 포리스트 수준에서 실행함을 나타냅니다. 이 문제를 해결하려면 Exchange ADC(Active Directory Connector) 프로그램을 업데이트해야 합니다.

혼합 또는 전용 포리스트 기능 수준으로 ADC 이전 버전을 실행하면 디렉터리가 불완전하게 업데이트되거나 데이터가 손실될 수 있습니다. 조직의 모든 컴퓨터에서 ADC를 최신 Exchange Server 2003 버전으로 업그레이드하는 것이 좋습니다.

최신 버전의 ADC를 최신 Exchange Server 2003 서비스 팩과 함께 Downloads for Exchange Server 2003 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)에서 다운로드할 수 있습니다. Exchange Server CD에서 Exchange Server 2003 최종 버전의 ADC를 설치할 수도 있습니다.

최신 버전의 ADC로 업그레이드하려면 다음을 수행하십시오.

  1. 이전 버전의 ADC를 실행하는 서버에서 시작, 실행을 차례로 클릭한 다음 E:\setup\adc\i386\setup.exe를 입력합니다. 여기서 E는 Exchange Server 서비스 팩의 다운로드 위치입니다.

  2. Active Directory Connector 설치 마법사 시작 페이지에서 다음을 클릭합니다.

  3. 이전에 설치된 것이 발견되었습니다. 페이지에서 다시 설치를 클릭하여 ADC를 업그레이드합니다.

  4. Active Directory Connector 설치 마법사를 완료하고 있습니다. 페이지에서 마침을 클릭합니다.

포리스트 기능 수준이 ADC에 미치는 영향에 대한 자세한 내용은 Microsoft 기술 자료 문서 825916, "Exchange 2000 Active Directory Connector Does Not Successfully Replicate Changes to Group Membership in Windows Server 2003 Active Directory in Forest Functional Levels 1 or 2"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=825916)를 참조하십시오.

도메인과 포리스트 기능 수준에 대한 자세한 내용은 기술 자료 문서 322692, "HOWTO: Windows Server 2003 제품군에서 도메인 기능 수준 높이기"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322692)를 참조하십시오.


이 Active Directory 포리스트는 호스팅된 Exchange에 대해 구성되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Global-Address-List 스키마 특성 개체의 LinkID 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Global-Address-List 개체는 Exchange 컨테이너에서 사용되어 새롭게 만들어진 GAL(전체 주소 목록)의 고유 이름을 저장합니다.

Exchange Server Analyzer는 Global-Address-List 개체의 LinkID 특성 값이 4048로 설정되어 있음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다. 4048 값은 Active Directory 포리스트가 호스팅된 Exchange 환경에 대해 구성되어 있음을 나타냅니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

호스팅된 Exchange 환경에 대한 자세한 내용은 다음 문서를 참조하십시오.

  • "Information for Hosters"(http://go.microsoft.com/fwlink/?LinkId=46307)

  • Exchange Server 2000 Resource Kit(http://go.microsoft.com/fwlink/?LinkId=46326)의 "Chapter 23 - Hosted Service Environments"


Active Directory 서버가 다운되었거나 연결할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 원격 프로시저 호출(RPC)을 사용하여 Active Directory® 디렉터리 서버의 다음 레지스트리 키에서 CurrentVersion 문자열 값을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Microsoft Windows® 2000 Server를 실행하는 컴퓨터의 경우 CurrentVersion 문자열의 올바른 값은 5.0입니다. Windows Server™ 2003을 실행하는 컴퓨터의 경우 올바른 값은 5.2입니다.

Exchange Server Analyzer가 어떤 이유로든 이 레지스트리 값을 읽을 수 없으면 오류가 표시됩니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 디렉터리 서버가 시작되었는지, 네트워크에 연결되어 있는지 확인합니다.

  2. PING 명령을 사용하여 디렉터리 서버에 연결할 수 있는지 확인합니다.

  3. 방화벽이 설치되어 있으면 RPC 포트가 차단되었는지 확인합니다.

  4. 디렉터리 서버의 원격 레지스트리 서비스가 시작되었는지 확인합니다.

  5. Exchange Server Analyzer를 실행 중인 계정에 Active Directory 서버의 레지스트리를 읽을 수 있는 사용 권한이 있는지 확인합니다.

네트워크 연결 문제 해결에 대한 자세한 내용은 다음을 참조하십시오.

  • Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?LinkId=56285)


Active Directory 서버에 1GB 이하의 메모리가 있지만 Boot.ini 파일에 /3GB 및 /USERVA=3030 스위치가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서버의 실제 메모리와 사용자 모드 프로세스에 할당된 가상 주소 공간의 용량을 확인할 때 두 가지 Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 다음 표에서는 Exchange Server Analyzer가 계산하는 클래스와 키를 설명합니다.

클래스 | 키 | 설명
Win32_OperatingSystem | MaxProcessMemorySize | 프로세스에 할당할 수 있는 최대 메모리(킬로바이트)
Win32_OperatingSystem | OSProductSuite | 운영 체제에 추가로 설치 및 허가된 시스템 제품
Win32_ComputerSystem | TotalPhysicalMemory | 컴퓨터에 설치되어 있는 RAM의 용량

Exchange Server Analyzer에서 디렉터리 서버의 RAM 용량이 950MB 미만이고 MaxProcessMemorySize 값이 2097024보다 크거나 3104640보다 작으면 경고가 표시됩니다.

이 경고는 디렉터리 서버가 두 가지 측면에서 올바르게 구성되지 않아 메모리 사용이 최적화되지 않았음을 나타냅니다.

  • /USERVA=3030 시작 스위치가 설정되어 있습니다. 이 스위치는 Microsoft Windows Server™ 2003 운영 체제에서 실행 중이고 메모리가 1GB 이상인 Exchange Server 컴퓨터에만 필요합니다.

  • /3GB 시작 스위치가 설정되어 있습니다. 이 스위치는 메모리가 1GB 이상이고 다음 운영 체제 중 하나를 실행 중인 Exchange 서버에서만 사용해야 합니다.

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

중요:
Windows 2000 Server에서는 /3GB 스위치를 사용하지 않아야 합니다. 이러한 운영 체제에서는 이 스위치가 지원되지 않아 응용 프로그램이나 운영 체제가 충돌할 수 있기 때문입니다. 또한 /3GB 스위치는 위 운영 체제 중 1GB 이상의 실제 메모리가 설치되어 있는 경우에만 지원됩니다.

1GB의 실제 메모리가 설치되어 있는 시스템에서 이러한 경고가 발생한 경우는 비디오 카드 같은 다른 구성 요소가 하드웨어 수준에서 이 실제 메모리 중 일부를 할당 받으므로 할당된 실제 메모리를 운영 체제에서 사용할 수 없음을 나타냅니다. 이러한 경우 Windows에 따라 실제로 설치된 메모리 양은 컴퓨터에 설치되어 있는 실제 메모리의 실제 양보다 적습니다. 이러한 상황이 발생하면 BIOS에서 보고하는 설치된 메모리와 Windows에서 보고하는 설치된 메모리의 양을 비교해야 합니다.

Windows Server 2003에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. 내 컴퓨터를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다. 시스템 속성 대화 상자가 나타납니다.

  2. 고급을 클릭합니다.

  3. 시작 및 복구 영역에서 설정을 클릭합니다. 시작 및 복구 대화 상자가 나타납니다.

  4. 시스템 시작 영역에서 편집을 클릭합니다. 그러면 메모장에서 Windows Boot.ini 파일이 열립니다.

  5. [Operating Systems] 섹션의 모든 시작 줄에서 /3GB /USERVA=3030 스위치를 삭제합니다.

  6. 변경 내용을 저장하고 메모장을 닫습니다.

  7. 확인을 두 번 클릭하여 열려 있는 대화 상자를 닫은 다음 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

Windows 2000 Server에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. Windows 탐색기에서 시스템 파티션을 찾습니다.

  2. Boot.ini 파일을 볼 수 없는 경우는 폴더 옵션을 보호된 운영 체제 파일 숨기기로 설정했기 때문일 수 있습니다. 이러한 경우에는 탐색기에서 도구, 폴더 옵션을 차례로 클릭한 다음 보기 탭을 클릭합니다. 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 해제합니다. 경고 상자가 표시되면 예를 클릭합니다.

  3. 탐색기에서 Boot.ini 파일을 볼 수 있으면 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램을 클릭하고 Notepad를 클릭하여 파일을 엽니다.

  4. [Operating Systems] 섹션의 모든 시작 줄에서 /3GB /USERVA=3030 스위치를 삭제합니다.

  5. 변경 내용을 저장하고 메모장을 닫습니다.

  6. 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

/3GB 및 /USERVA 시작 스위치 사용 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 308356, "Windows Server 2003 또는 Windows 2000 Server를 실행하는 도메인 컨트롤러에서 Lsass.exe 프로세스의 메모리 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812, "How to Use the 4GT RAM Tuning Feature"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "The effects of 4GT tuning on system Page Table Entries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, "Boot.ini 파일에서 /USERVA 스위치를 사용하여 /3GB 구성을 조정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Boot.ini 파일에 /3GB 스위치가 설정되어 있지만 Active Directory 서버의 메모리가 1GB 미만입니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서버의 실제 메모리와 사용자 모드 프로세스에 할당된 가상 주소 공간의 용량을 확인할 때 두 가지 Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 다음 표에서는 Exchange Server Analyzer가 계산하는 클래스와 키를 설명합니다.

클래스 | 키 | 설명
Win32_OperatingSystem | MaxProcessMemorySize | 프로세스에 할당할 수 있는 최대 메모리(킬로바이트)
Win32_OperatingSystem | OSProductSuite | 운영 체제에 추가로 설치 및 사용 허가된 시스템 제품
Win32_ComputerSystem | TotalPhysicalMemory | 해당 컴퓨터에 설치되어 있는 RAM의 크기(바이트)

Exchange Server Analyzer에서 디렉터리 서버의 RAM 용량이 950MB 미만이고 MaxProcessMemorySize 값이 2097024보다 크고 3104640보다 작은 것으로 확인되면 경고가 표시됩니다.

이 경고는 디렉터리 서버가 올바르게 구성되지 않아 메모리 사용이 최적화되지 않았음을 나타냅니다. 이 컴퓨터에는 /3GB 시작 스위치가 설정되어 있습니다. 이 스위치는 제거해야 합니다. 이 스위치는 메모리가 1GB 이상이고 다음 운영 체제 중 하나를 실행 중인 Active Directory Server에서만 사용해야 합니다.

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server™ 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

중요:
Windows 2000 Server에서는 /3GB 스위치가 지원되지 않으며 응용 프로그램이나 운영 체제가 충돌할 수 있기 때문에 사용하지 않아야 합니다. 또한 /3GB 스위치는 위 운영 체제 중 1GB 이상의 실제 메모리가 설치되어 있는 경우에만 지원됩니다.

1GB의 실제 메모리가 설치되어 있는 시스템에서 이러한 경고가 발생한 경우는 비디오 카드 같은 다른 구성 요소가 하드웨어 수준에서 이 실제 메모리 중 일부를 할당 받으므로 할당된 실제 메모리를 운영 체제에서 사용할 수 없음을 나타냅니다. 이러한 경우 Windows에 따라 실제로 설치된 메모리 양은 컴퓨터에 설치되어 있는 실제 메모리의 실제 양보다 적습니다. 이러한 상황이 발생하면 BIOS에서 보고하는 설치된 메모리와 Windows에서 보고하는 설치된 메모리의 양을 비교해야 합니다.

Windows Server 2003에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. 시스템 속성 대화 상자가 나타납니다.

  2. 고급을 클릭합니다.

  3. 시작 및 복구 영역에서 설정을 클릭합니다. 시작 및 복구 대화 상자가 나타납니다.

  4. 시스템 시작 영역에서 편집을 클릭합니다. 그러면 메모장에서 Windows Boot.ini 파일이 열립니다.

  5. [Operating Systems] 섹션에 있는 모든 시작 줄에서 /3GB 스위치를 삭제합니다.

  6. 변경 내용을 저장하고 메모장을 닫습니다.

  7. 확인을 두 번 클릭하여 열려 있는 대화 상자를 닫은 다음 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

Windows 2000 Server에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. Windows 탐색기에서 시스템 파티션을 탐색합니다.

  2. Boot.ini 파일을 볼 수 없는 경우는 폴더 옵션을 보호된 운영 체제 파일 숨기기로 설정했기 때문일 수 있습니다. 이러한 경우에는 탐색기에서 도구, 폴더 옵션을 차례로 클릭한 다음 보기를 클릭합니다. 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 해제합니다. 경고 상자가 표시되면 예를 클릭합니다.

  3. 탐색기에서 Boot.ini 파일을 볼 수 있으면 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램을 클릭하고 Notepad를 클릭하여 파일을 엽니다.

  4. [Operating Systems] 섹션에 있는 모든 시작 줄에서 /3GB 스위치를 삭제합니다.

  5. 변경 내용을 저장하고 메모장을 닫습니다.

  6. 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

/3GB 시작 스위치 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 308356, "Windows Server 2003 또는 Windows 2000 Server를 실행하는 도메인 컨트롤러에서 Lsass.exe 프로세스의 메모리 사용" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812, "How to Use the 4GT RAM Tuning Feature"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "The effects of 4GT tuning on system Page Table Entries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, "Boot.ini 파일에서 /USERVA 스위치를 사용하여 /3GB 구성을 조정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Active Directory 서버에서 Windows 2000 Server가 실행 중이며 /3GB 스위치가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 사용자 모드 프로세스에 할당된 가상 주소 공간의 양(MaxProcessMemorySize) 및 Active Directory® 디렉터리 서비스 서버에서 실행 중인 Windows의 버전(OSProductSuite)을 확인합니다. 다음 표에서는 Exchange Server Analyzer에서 계산하는 클래스와 키를 설명합니다.

MaxProcessMemorySize 값이 3104640이고 OSProductSuite 값이 Windows 2000 Server이면 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 Microsoft Windows 2000 Server를 실행 중인 디렉터리 서버의 Boot.ini 파일에 /3GB 시작 스위치가 설정되어 있음을 나타냅니다. 이 스위치는 Windows 2000 Server에서는 지원되지 않으며, 메모리가 1GB 이상이고 다음 운영 체제 중 하나를 실행 중인 컴퓨터에서만 사용해야 합니다.

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Boot.ini 파일에서 /3GB 스위치를 제거하려면 다음을 수행합니다.

  1. Windows 탐색기에서 시스템 파티션을 탐색합니다.

  2. Boot.ini 파일을 볼 수 없는 경우는 폴더 옵션을 보호된 운영 체제 파일 숨기기로 설정했기 때문일 수 있습니다. 이러한 경우에는 탐색기에서 도구, 폴더 옵션을 차례로 클릭한 다음 보기 탭을 클릭합니다. 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 해제합니다. 경고 상자가 표시되면 예를 클릭합니다.

  3. 탐색기에서 Boot.ini 파일을 볼 수 있으면 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램을 클릭하고 Notepad를 선택하여 파일을 엽니다.

  4. [Operating Systems] 섹션의 모든 시작 줄에서 /3GB /USERVA=3030 스위치를 삭제합니다.

  5. 변경 내용을 저장하고 메모장을 닫습니다.

  6. 디렉터리 서버를 다시 시작하여 변경 내용을 적용합니다.

/3GB 시작 스위치 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 297812, "How to Use the 4GT RAM Tuning Feature"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "The effects of 4GT tuning on system Page Table Entries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, "Boot.ini 파일에서 /USERVA 스위치를 사용하여 /3GB 구성을 조정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Active Directory Server 레지스트리에 액세스할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 도메인 컨트롤러에서 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion\CurrentVersion

Exchange Server Analyzer가 어떤 이유로 레지스트리 값을 읽을 수 없는 경우 오류를 표시합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 도메인 컨트롤러가 시작되어 있는지, 네트워크에 연결되어 있는지 확인합니다.

  2. PING 명령을 사용하여 도메인 컨트롤러에 연결할 수 있는지 확인합니다.

  3. 방화벽이 있으면 RPC 포트가 차단되어 있는지 확인합니다.

  4. 도메인 컨트롤러에서 Remote Registry 서비스가 시작되었는지 확인합니다.

  5. Exchange Server Analyzer를 실행하는 계정에 대한 사용 권한을 검토합니다. Exchange Server Analyzer를 실행하는 계정에는 검색 중인 각 도메인 컨트롤러에 대한 로컬 관리자 권한이 있어야 합니다.

네트워크 연결 문제 해결에 대한 자세한 내용은 다음을 참조하십시오.

  • Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?LinkId=56285)

포트 요구 사항에 대한 자세한 내용은 기술 자료 문서 832017, "Microsoft Windows Server System의 포트 요구 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)을 참조하십시오.


Active Directory 서버 소프트웨어 업데이트 사용 가능
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2007-02-20

Microsoft Exchange Analyzer Tool은 이름 속성 값을 확인할 때 ROOT\MicrosoftExchangeV2 네임스페이스의 Exchange_DSAccessDC Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다. 이름 속성은 Active Directory 디렉터리 서비스 조회를 위해 Exchange 서버에서 사용하는 도메인 컨트롤러의 컴퓨터 이름을 지정합니다.

그런 다음 Exchange Analyzer는 다음 사항을 확인할 때 해당 도메인 컨트롤러의 특정 특성 값을 Active Directory에서 쿼리합니다.

  • Active Directory 도메인 컨트롤러에서 Windows Server 2003 운영 체제가 실행되고 있는지 여부

  • Active Directory 도메인 컨트롤러에서 비영어 버전의 Microsoft Windows Server 2003 운영 체제가 실행되고 있는지 여부

  • Exchange 조직에 Microsoft Exchange Server 2007 서버가 있는지 여부

  • 서버의 ntdsa.dll 파일에 대한 Version 키 값이 2700보다 작은지 여부

Exchange Analyzer는 이러한 조건이 모두 해당되는 경우 경고를 표시합니다.

이 경고는 Exchange Outlook Web Access 클라이언트에서 Exchange 주소록 인덱싱과 관련된 문제가 발생할 수 있음을 나타냅니다.

Outlook Web Access에서는 사용자가 UI(사용자 인터페이스)에 사용할 언어를 선택할 수 있습니다. 선택한 언어에 따라 로캘 설정이 달라집니다. 또한 Outlook Web Access에서는 해당 언어를 사용하여 주소록과 같은 Active Directory 결과를 정렬합니다. Exchange에서 VLV(가상 목록 보기) 쿼리를 실행하여 도메인 컨트롤러에서 사용할 수 없는 언어를 지정하면 오류가 발생합니다. 이 문제는 현재 VLV 쿼리에 대해 지정된 언어가 도메인 컨트롤러 언어와 일치하지 않을 때 Exchange에서 다른 언어를 사용할 수 있도록 하는 기본 인덱싱 메커니즘이 없기 때문에 발생합니다.

이 경고를 해결하려면 Microsoft 기술 자료 문서 919166, "The address book function in Exchange 2007 is broken when an Exchange OWA client and a Windows Server 2003-based domain controller do not have the same locale setting"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=919166)에서 설명하는 파일 업데이트를 구하여 설치합니다.


Active Directory Server WMI에 액세스할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 도메인 컨트롤러의 Name 키에 값이 설정되어 있는지 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. WMI 쿼리가 실패하면 Exchange Server Analyzer는 오류를 표시합니다.

이 오류에는 두 가지 원인이 있을 수 있습니다.

  • Exchange Server Analyzer를 실행하는 계정에 WMI 정보를 쿼리할 수 있는 권한이 충분하지 않습니다.

  • 네트워크 문제 때문에 Exchange Server Analyzer가 컴퓨터에 연결될 수 없습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. PING 명령을 사용하여 Exchange Server 컴퓨터에 연결할 수 있는지 확인합니다.

  3. 방화벽이 있으면 RPC 포트가 차단되어 있는지 확인합니다.

  4. Exchange Server Analyzer를 실행하는 계정에 대한 사용 권한을 검토합니다. Exchange Server Analyzer를 실행하는 계정에는 검색 중인 각 Exchange Server 컴퓨터에 대한 로컬 관리자 권한이 있어야 합니다.

    또는 Exchange Server Analyzer를 실행 중인 계정에 특정 WMI 사용 권한을 부여할 수 있습니다.

    1. Exchange 컴퓨터에서 컴퓨터 관리 MMC 콘솔 트리를 엽니다.

    2. 서비스 및 응용 프로그램에서 WMI 컨트롤을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

    3. WMI 컨트롤 속성 페이지에서 보안 탭을 클릭한 다음 루트를 확장합니다.

    4. CIMV2 폴더를 선택하고 보안을 클릭합니다.

    5. ROOT\CIMV2에 대한 보안 페이지에서 Exchange Server Analyzer를 실행하는 계정을 추가합니다.

    6. e단계에서 추가한 계정을 선택합니다.Selected_Account의 사용 권한에서 허용 열 아래의 원격으로부터 사용 가능 및 보안 읽기를 모두 선택한 다음 확인을 클릭합니다.

네트워크 연결 문제 해결에 대한 자세한 내용은 다음을 참조하십시오.

  • Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?LinkId=56285)

포트 요구 사항에 대한 자세한 내용은 기술 자료 문서 832017, "Microsoft Windows Server System의 포트 요구 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)을 참조하십시오.


ADCDisabledMail 특성이 감지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Exchange 조직이 혼합 모드인지 아니면 전용 모드인지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange 조직이 전용 모드에 있으면 Exchange Server Analyzer는 해당 조직의 도메인에서 메일 사용이 가능한 개체의 legacyExchangeDN 특성 값이 ADCDisabledMail로 설정되어 있는지 확인할 때 Active Directory를 쿼리합니다. 메일 사용이 가능한 개체의 legacyExchangeDN 특성 값이 ADCDisabledMail로 설정되어 있으면 해당 개체와 관련 도메인이 나열된 경고가 표시됩니다.

사서함이 삭제된 경우 Exchange 2000 Server 및 Exchange Server 2003 환경에서 모두 이 문제가 발생할 수 있습니다. 사서함이 삭제되면 계정의 legacyExchangeDN 특성 값이 ADCDisabledMail로 표시됩니다. 관련 개체가 Active Directory에서 메일을 사용할 수 없을 경우 이 값을 사용하여 ADC(Active Directory Connector)가 Exchange Server 5.5 디렉터리 서비스에서 개체를 삭제하도록 지시할 수 있습니다. 삭제된 대용량 메일 그룹에 여러 개의 사서함이 있는 경우 Active Directory에서 ADCDisabledMail의 고유 legacyExchangeDN 특성 값을 검색하는 동안 메시지가 지연됩니다. 여러 개의 사서함에 동일한 legacyExchangeDN attribute value가 있을 수 있으므로 검색에 오랜 시간이 걸립니다. 이로 인해 메시징 지연이 발생합니다. Microsoft Office Outlook® 2003 클라이언트의 메시지 "To:/Cc:/Bcc:" 줄에서 메일 그룹이 확장되는 경우에도 메시징 지연이 발생합니다.

이를 해결하려면 해당 개체를 삭제하거나 ADSI(Active Directory Service Interfaces) 편집 도구, ldp.exe 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용하여 legacyExchangeDn 특성을 제거합니다. legacyExchangeDN 특성 값을 NULL로 설정하면 Active Directory에 대한 검색이 "/O=NT5/ou=<objectGUID of the Domain>/cn=<objectGUID of the user>"로 설정되고 배달 못 함 보고서(NDR)가 훨씬 빠르게 생성됩니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
legacyExchangeDN 특성의 ADCDisabledMail 값을 제거하려면 다음을 수행합니다.

  1. Windows 2000 지원 도구 또는 Windows Server 2003 지원 도구에서 ADSI 편집 도구를 시작합니다.

  2. 다음 노드를 확장합니다.

    • Domain Container

    • DC=Domain_Name

    • Users Container

  3. User_Name을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. Attributes 목록의 legacyExchangeDN, Edit를 차례로 클릭합니다.

  5. 원본 값을 선택하고 지우기를 클릭하여 ADCDisabledMail이 포함된 원래 legacyExchangeDN 값을 제거합니다.

  6. 변경 내용을 적용하려면 확인을 두 번 클릭합니다.

ADSI 편집 작업 방법에 대한 자세한 내용은 Windows Server 온라인 도움말에서 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.

LDP 도구 사용 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.


주소 목록 필터 설정으로 새로 받는 사람이 주소 목록에 표시되지 않을 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 주소 목록 개체의 purportedSearch 특성에 대해 설정된 특성을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 purportedSearch 특성에 "proxyAddresses=*" 문자열이 들어 있는 경우 오류를 표시합니다.

새 사용자 개체를 만든 후에 받는 사람 업데이트 서비스는 프록시 주소와 같은 특정 특성을 해당 받는 사람 개체에 할당합니다. 그러나 받는 사람 업데이트 서비스는 ShowInAddressBook 특성을 할당하지 못할 수 있습니다. 받는 사람 개체의 ShowInAddressBook 특성은 받는 사람이 속해 있는 주소 목록을 나타냅니다. 이 특성이 할당되지 않은 받는 사람 개체는 개체가 받는 사람 정책 필터의 조건에 맞더라도 전체 주소 목록이나 다른 주소 목록에 표시되지 않습니다.

이 상황은 한 개 이상의 주소 목록 필터에 proxyAddresses 특성이 들어 있는 경우에 발생할 수 있습니다. 이 경우 각 주소 목록의 속성을 확인하고 필터 규칙 상자에서 "proxyAddresses=*" 문자열을 찾아 확인할 수 있습니다.

다음 절차를 수행하여 받는 사람 업데이트 서비스가 받는 사람 개체에 특성을 제대로 할당하도록 설정하여 전체 주소 목록이나 다른 주소 목록에 표시합니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람, 모든 전체 주소 목록을 차례로 확장한 다음 받는 사람 정책을 선택합니다.

  3. 오른쪽 창에서 편집할 주소 목록을 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  4. 속성 페이지의 일반 탭에서 필터 규칙 아래에 있는 수정을 클릭합니다.

  5. Exchange 받는 사람 찾기 드롭다운 메뉴에서 사용자 지정 검색을 선택합니다. 주소 목록이 원래 사용자 지정 검색에서 만들어졌으면 3단계에서 수정을 클릭한 후에 사용자 지정 검색 찾기 페이지가 표시됩니다.

  6. 조건 목록에서 프록시 주소가 명확하게 *입니다 항목을 선택한 다음 제거를 클릭합니다.

  7. 확인을 클릭하여 대화 상자를 닫습니다.

  8. 받는 사람 정책을 마우스 오른쪽 단추로 클릭하고 지금 이 정책 적용을 클릭합니다.

받는 사람 업데이트 서비스에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328738, "XADM: How the Recipient Update Service Applies Recipient Policies"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328738)

  • 319065, "How to work with the Exchange Recipient Update Service"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319065)


관리 그룹 모드를 알 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory의 관리 그룹 컨테이너에 있는 관리 그룹 개체의 msExchAdminGroupMode 특성을 검사하여 관리 그룹 모드를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchAdminGroupMode 특성 값이 0, 1 또는 2가 아닌 경우 오류를 표시합니다.

Exchange에서는 관리 그룹 모드를 사용하여 관리 그룹이 Exchange Server 5.5 서버 또는 Exchange Server 2003 서버(또는 Exchange 2000 Server 서버)를 포함할 수 있는지 나타냅니다. 이 특성 값이 0, 1 또는 2가 아니면 관리자가 수동으로 값을 변경한 것일 수 있습니다. Exchange 설치 프로그램 또는 Exchange System Manager에서 이 값이 잘못 설정되는 경우는 없습니다.

ADSI(Active Directory Service Interfaces) 편집 스냅인, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 도구를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

MSExchAdminGroupMode 특성을 수정하려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 사용하여 Active Directory에서 관리 그룹 개체를 찾습니다.

    MSExchAdminGroupMode 특성은 다음 위치에 있습니다.

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN=Administrative group

  2. 다음 정수 값 중 하나를 입력합니다.

    0=전용 모드(관리 그룹이 Exchange 2000 Server 또는 Exchange Server 2003을 사용하여 만들어짐)

    1=Exchange Server 5.5 모드(관리 그룹이 Exchange Server 5.5를 사용하여 만들어졌고 Exchange Server 5.5 서버만 포함)

    2=혼합 모드(관리 그룹은 Exchange Server 5.5 서버와 Exchange 2000 Server 둘 모두 또는 Exchange Server 2003 서버를 포함할 수 있음)

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 2003 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


호스팅된 Exchange에서 인증된 사용자 구성이 잘못되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Exchange Server가 호스팅된 Exchange 환경으로 구성되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server 환경이 호스팅된 Exchange 환경인 경우 Exchange Server Analyzer는 인증된 사용자 그룹이 도메인의 Windows 2000® 이전 버전 호환 액세스 그룹에 속하는지 확인할 때 Active Directory를 쿼리합니다.

인증된 사용자 그룹이 Windows 2000 이전 버전 호환 액세스 그룹의 구성원인 경우 Exchange Server Analyzer는 경고를 표시합니다. 이것은 호스팅된 Exchange 솔루션에 권장되는 구성이 아닙니다.

이 경고를 해결하려면 Windows 2000 이전 버전 호환 액세스 보안 그룹에서 인증된 사용자를 제거합니다.

  1. Active Directory 사용자 및 컴퓨터를 엽니다.

  2. 도메인 노드를 확장한 다음 기본 제공 컨테이너를 클릭합니다.

  3. Windows 2000 이전 버전 호환 액세스 보안 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  4. 구성원 탭을 클릭합니다.

  5. 인증된 사용자를 선택합니다.

  6. 제거를 클릭합니다.

  7. 확인을 클릭합니다.

호스팅된 Exchange 환경에 대한 자세한 내용은 다음 문서를 참조하십시오.

  • "Information for Hosters"(http://go.microsoft.com/fwlink/?LinkId=46307)

  • Exchange Server 2000 Resource Kit(http://go.microsoft.com/fwlink/?LinkId=46326)의 "Chapter 23 - Hosted Service Environments"


인증서 사용자가 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 Exchange 서버 시스템의 Server Certificate 개체를 쿼리하여 X509 인증서의 다양한 속성을 검색합니다. 발견된 SSL(Secure Sockets Layer) 인증서마다 Exchange Server Analyzer는 Principal 특성을 평가하여 인증서에 지정된 FQDN(정규화된 도메인 이름)(예: Microsoft.com)을 식별합니다.

Microsoft Exchange Server Analyzer는 Principal FDQN 이름이 호스트 주소나 URL과 일치하지 않을 경우 경고를 표시합니다. 인증서 Principal 불일치 경고는 사용자가 Exchange Server 2003용 Microsoft Office Outlook® Web Access, Exchange Server 2007용 Outlook Anywhere, Exchange Server ActiveSync 및 RPC over HTTP를 사용하여 사서함에 연결할 수 없음을 나타냅니다.

참고:
서버에서 SSL 프로토콜을 실행하는 경우 서버 인증서가 있어야 합니다. 옵션에 따라 서버에서 클라이언트의 인증서를 요청할 수도 있습니다. 서버 인증서에는 웹 사이트 이름이 포함되어 있습니다. 브라우저에서 웹 사이트 이름이 입력한 이름인지 확인합니다. 예를 들어 https://www.example.com 같은 웹 사이트가 있을 경우 인증서 이름은 www.example.com이어야 합니다.

다음과 같은 조건 중 하나에 해당하면 불일치 문제가 발생할 수 있습니다.

  • 인증서를 잘못된 서버에 실수로 적용했습니다.

  • 서버에 둘 이상의 호스트 이름이 있을 경우 클라이언트가 잘못된 호스트 URL을 통해 서버의 데이터에 액세스합니다.

인증서 이름 일치하지 않는 문제를 해결하려면 다음을 수행합니다.

  • SSL 인증서가 올바른 호스트에 제공 및 적용되었는지 확인합니다.

추가 정보

  • Exchange Server 2003의 가상 서버에서 인증서를 사용하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 823024, "How to Use Certificates with Virtual Servers in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024)을 참조하십시오.

  • SSL 사용 방법 및 서버 인증서를 얻고 설치하는 방법에 대한 자세한 내용은 Exchange Server 2003 클라이언트 액세스 가이드(http://go.microsoft.com/fwlink/?LinkId=47568)의 "클라이언트 액세스용 Exchange Server 2003 구성"을 참조하십시오.

  • SSL 사용 방법 및 Exchange Server 2007용 서버 인증서를 받아서 설치하는 방법은 "How to Configure SSL for Outlook Anywhere"(http://go.microsoft.com/fwlink/?LinkId=80875)를 참조하십시오.


연결 동의(CA) 활성화 일정이 사용 안 함으로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 연결 동의(CA) 개체의 activationStyle 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. activationStyle 특성은 연결 동의(CA)의 일정 설정을 나타냅니다. 일정이 사용 안 함으로 설정되어 있으면 경고가 표시됩니다.

연결 동의(CA)가 더 이상 필요하지 않은 것으로 확인되면 삭제해야 합니다. 해당 연결 동의(CA)가 필요한 경우 적합한 일정에 따라 실행되도록 구성해야 합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 시작, 프로그램, 관리 도구, Active Directory Connector를 차례로 클릭합니다.

  2. 왼쪽 창에서 수정할 연결 동의(CA)를 호스팅하는 ADC(Active Director Connector) 서버를 클릭합니다.

  3. 오른쪽 창에서 수정할 연결 동의(CA)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 일정 탭을 클릭합니다.

  5. 일정을 항상 또는 선택한 시간으로 설정합니다. 후자를 선택하는 경우 적절한 눈금 영역을 클릭하여 해당 시간에 연결 동의(CA)가 실행되도록 합니다.

양방향 받는 사람 연결 동의(CA) 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 296260, "XGEN: Exchange Server 5.5 사용자에 맞게 양방향 받는 사람 연결 동의를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260)을 참조하십시오.


연결 동의(CA)가 연결되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 연결 동의(CA)에서 msExchHomeSyncService 값이 유효한지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 이 특성에 대한 유효한 값이 포함되지 않은 연결 동의(CA)를 확인하면 경고를 표시합니다.

msExchHomeSyncService 특성에는 연결 동의(CA)가 위치한 ADC(Active Directory Connector) 서버가 포함됩니다.

ADC를 먼저 제거하거나 ADC 서버의 연결 동의(CA)를 제거하지 않고 ADC 서버를 제거하면 이 경고가 표시될 수 있습니다. ADC 서버를 제거하면 연결 동의(CA)와 ADC 서버 사이의 연결이 끊어집니다. 결과적으로 이러한 연결 동의(CA)가 담당하는 개체는 더 이상 복제되지 않습니다. 다른 ADC 서버의 ADC 관리자 스냅인을 사용할 경우 제거된 ADC 서버에 위치한 연결 동의(CA)는 표시되지 않습니다. 그러나 Active Directory에는 이러한 연결 동의(CA)가 계속 존재합니다.

이 문제를 해결하려면 새 ADC 서버와 이전 연결 동의(CA)를 다시 연결합니다. 이 작업을 수행하는 한 가지 방법은 새 ADC 서버에서 새 연결 동의(CA)를 만든 다음 msExchHomeSyncService 특성을 새 연결 동의(CA)에서 이전 연결 동의(CA)로 복사하여 붙이는 것입니다.

ADC 서버와 연결 동의(CA)를 다시 연결하려면 다음을 수행합니다.

  1. ADC 관리자 스냅인을 시작합니다.

  2. 새 연결 동의(CA)를 만듭니다.

  3. ADSI(Active Directory Service Interfaces) 편집을 시작합니다.

  4. 구성, 서비스, Microsoft Exchange를 차례로 확장한 후 Active Directory 연결을 클릭합니다.

  5. 오른쪽 창에서 방금 만든 연결 동의(CA)의 속성을 엽니다.

  6. Select a property to view 드롭다운 목록에서 msExchHomeSyncService를 클릭합니다.

  7. 값 상자에서 전체 특성을 복사한 다음 확인을 클릭합니다.

  8. 다시 연결해야 하는 연결 동의(CA)의 속성을 엽니다.

  9. Select a property to view 드롭다운 목록, msExchHomeSyncService 특성을 차례로 클릭합니다.

  10. 복사한 값을 특성 편집 상자에 붙여 넣습니다.

  11. 설정, 적용, 확인을 차례로 클릭합니다.

연결되지 않은 연결 동의(CA)에 대한 자세한 내용은 Microsoft 기술 자료 문서 319486, "XADM: Connection Agreements Disappear After You Remove Active Directory Connector"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319486)를 참조하십시오.


기본 표시 이름이 수정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 displaySpecifier 클래스를 가진 개체의 createDialog 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. displaySpecifier 클래스를 가진 개체는 Active Directory의 개체에 사용될 컨텍스트 메뉴 및 속성 페이지를 설명합니다. Exchange Server Analyzer는 createDialog 특성이 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

Active Directory에서 새 사용자 또는 연락처 개체를 생성할 때 전체 이름 필드는 항상 FirstName LastName 형식으로 생성됩니다. 이 필드는 작성 시 표시 이름을 설정하므로 FirstName LastName 형식의 전체 주소 목록을 지정할 수 있습니다.

원할 경우 ADSI(Active Directory Service Interface) 편집과 같은 Active Directory 편집기를 사용하여 표시 이름 필드 작성 방식을 수정할 수 있습니다. ADSI 편집은 이 필드 작성 방식뿐 아니라 전체 이름 필드도 변경하므로 사용자는 Active Directory 사용자 및 컴퓨터 내에 표시되는 선택된 형식으로 나타납니다.

주의:
ADSI 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생될 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이러한 내용을 변경하기 전에 발생 가능한 성능 저하에 대해서도 알아야 합니다. 변경에 따른 발생 가능한 문제에 대한 내용은 Microsoft 기술 자료 문서 276266, "Group Changes for Users with LDAP-Restricted Characters"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=276266)를 참조하십시오.

사용자 및 연락처 개체에 대한 기본 표시 형식을 변경하려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 엽니다.

  2. 맨 위 노드를 마우스 오른쪽 단추로 클릭한 다음 연결 대상을 클릭합니다.

  3. "Configuration Container"에 대한 명명 컨텍스트를 변경한 다음 OK를 클릭하여 바인딩 및 인증합니다.

  4. Configuration Container 노드를 확장한 다음 Configuration 노드를 확장합니다.

  5. cn=DisplaySpecifiers 노드를 확장한 다음 CN=409를 클릭합니다. 참고: 412는 한국어 로케일 ID입니다. 다중 언어 환경에서는 다른 코드로 변경해야 할 수도 있습니다.

  6. 오른쪽 창에서 CN=user-Display에 대한 속성을 엽니다.

  7. createDialog 옵션 특성으로 스크롤합니다.

  8. 특성을 %<sn>.%<givenName>으로 설정한 다음 설정을 클릭합니다. 참고: 형식을 지정할 수 있는 유일한 토큰은 %<sn>, %<givenName> 및 %<initials>입니다.

  9. 확인을 클릭하여 대화 상자를 닫습니다.

  10. Active Directory에 새 사용자를 만들어 전체 이름과 표시 이름이 예상한 대로 작성되었는지 확인합니다. 참고: 다중 도메인 환경에서는 Active Directory 사용자 및 컴퓨터 도구가 변경 내용을 적용하기 전에 복제가 완료되기를 기다려야 할 수도 있습니다.

위 절차를 수행하면 표시 이름이 LastName.FirstName 형식으로 나타납니다. 또한 위 절차는 사용자 개체에 적용됩니다. 연락처 개체의 경우 6단계에서 contact-Display로 변경합니다.

ADSI 스크립트를 사용하여 이 작업을 수행하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 277717, "How to Change the Display Names of Active Directory Users with Active Directory Services Interface Script"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277717)를 참조하십시오.

ITU(International Telecommunication Union) 및 ISO(International Organization for Standardization)는 코드 페이지를 정의합니다. 자세한 내용을 보려면 ITU 및 ISO 웹 페이지를 방문하십시오.

  • http://www.itu.int

  • http://www.iso.ch/iso/en/ISOOnline.openerpage

    참고:
    웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

지역화된 Exchange 클라이언트 지원에 대한 추가 정보는 Microsoft 기술 자료 문서 150977, "XADM: Supporting Localized Exchange Clients"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=150977)를 참조하십시오.


사서함 저장소에 삭제된 항목 보존을 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 사서함 저장소 개체의 garbageCollPeriod 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer가 garbageCollPeriod 특성이 사서함 저장소에 0으로 설정되어 있음을 확인하면 권장되는 유용한 정보 메시지가 표시됩니다.

가비지 수집은 사서함 저장소 데이터베이스 내의 공간을 비우는 내부 Exchange 정리 작업 프로세스입니다. 기본적으로 삭제된 항목은 일정 기간(일) 동안 사서함 저장소 데이터베이스에 저장된 다음 Exchange에서 영구적으로 삭제됩니다. 사서함 저장소 기본값을 사용하거나 삭제된 항목이 영구적으로 삭제되기 전의 보존 일 수를 선택하여 삭제된 항목 보존 기간을 설정할 수 있습니다.

삭제된 항목을 보관할 일 수를 지정할 때 0에서 24,855의 숫자를 선택할 수 있습니다. 이 설정은 7일로 구성하는 것이 좋습니다. 삭제된 항목 보존 기간을 0으로 설정하면 삭제된 항목은 해당 서버에서 영구적으로 즉시 제거됩니다. 디스크 공간이 문제가 되지 않는 한 삭제한 항목 보존 기간 기능을 사용할 수 있도록 하는 것이 좋습니다. 아래 절차에 따라 삭제된 항목이 영구적으로 삭제되기 전의 저장 일 수를 지정합니다.

Exchange System Manager의 삭제된 항목 보존을 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹 또는 조직을 확장한 다음 서버 및 사서함 저장소를 차례로 클릭합니다.

  3. 사서함 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 제한 탭에서 다음을 수행하여 삭제된 항목 보존 기간을 설정합니다.

    • 삭제된 항목의 보존 기간을 설정하려면 삭제된 항목 보존 기간(일)을 클릭한 다음 값을 입력합니다.

    • 백업할 때까지 항목을 보존하려면 저장소를 백업할 때까지는 사서함과 항목을 영구적으로 삭제하지 않음을 클릭합니다.

Active Directory 사용자와 컴퓨터에서 삭제된 항목 보존을 구성하려면 다음을 수행합니다.

  1. Active Directory 사용자 및 컴퓨터를 엽니다.

  2. 콘솔 트리에서 도메인을 확장합니다.

  3. 사용자를 두 번 클릭하거나 수정할 받는 사람 정보가 있는 노드를 두 번 클릭합니다.

  4. 자세히 창에서 수정할 받는 사람을 두 번 클릭합니다.

  5. Exchange 일반 탭에서 저장 용량 제한을 클릭합니다.

  6. 저장 용량 제한 대화 상자에서 삭제된 항목 보존의 사서함 저장소 기본값 사용 확인란을 클릭하여 선택을 해제한 다음 삭제된 항목 보존 기간(일)에 값을 입력합니다.

    삭제된 항목을 백업하기 전에 영구적으로 삭제하지 않도록 하려면 저장소를 백업할 때까지는 항목을 영구적으로 삭제하지 않음 확인란을 선택합니다.

사서함 저장 용량 제한 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 319583, "HOWTO: Exchange 2000에서 사서함에 대한 저장소 제한 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319583)을 참조하십시오.


삭제된 항목 보존을 공용 폴더 저장소에 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 공용 폴더 저장소의 garbageCollPeriod 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer가 garbageCollPeriod 특성이 공용 폴더 저장소에 대해 0으로 설정되어 있음을 확인하면 권장되는 유용한 정보 메시지가 표시됩니다.

가비지 수집은 공용 폴더 저장소 데이터베이스 내의 공간을 비우는 내부 Exchange 정리 작업 프로세스입니다. 기본적으로 삭제된 항목은 일정 기간(일) 동안 공용 폴더 저장소 데이터베이스에 저장된 다음 Exchange에서 영구적으로 삭제됩니다. 공용 폴더 저장소 기본값을 사용하거나 삭제된 항목이 영구적으로 삭제되기 전의 보존 일 수를 선택하여 삭제된 항목 보존 기간을 설정할 수 있습니다.

삭제된 항목을 보관할 일수를 지정할 때 0에서 24,855의 숫자를 선택할 수 있습니다. 이 설정은 7일로 구성하는 것이 좋습니다. 삭제된 항목 보존 기간을 0으로 설정하면 삭제된 항목은 해당 서버에서 영구적으로 즉시 제거됩니다. 디스크 공간이 문제가 되지 않는 한 삭제한 항목 보존 기간 기능을 사용할 수 있도록 하는 것이 좋습니다.

Exchange System Manager의 삭제된 항목 보존을 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹 또는 서버를 확장한 다음 서버 및 공용 폴더 저장소를 차례로 클릭합니다.

  3. 공용 폴더 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 제한 탭에서 다음을 수행하여 삭제된 항목 보존 기간을 설정합니다.

    • 삭제된 항목의 보존 기간을 설정하려면 삭제된 항목 보존 기간(일)을 클릭한 다음 값을 입력합니다.

    • 백업할 때까지 항목을 보존하려면 저장소를 백업할 때까지는 항목을 영구적으로 삭제하지 않음을 클릭합니다.

공용 폴더의 저장소 제한 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 319439, "HOW TO: Configure Storage Limits on Public Folders in Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319439)를 참조하십시오.


삭제된 사서함을 보존할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 사서함 저장소 개체의 msExchMailboxRetentionPeriod 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 사서함 저장소의 msExchMailboxRetentionPeriod 특성 값이 0으로 설정되어 있는 경우 유용한 정보 권장 사항을 표시합니다.

msExchMailboxRetentionPeriod 특성은 삭제된 사서함을 삭제하기 전에 보존하는 일 수를 나타냅니다. 삭제된 사서함을 보존할 일 수를 지정할 때 0에서 24,855의 숫자를 선택할 수 있습니다. 삭제된 사서함 보존의 기본 설정은 30일입니다. 사서함 보존 기간을 0으로 설정하면 삭제된 사서함은 해당 서버에서 영구적으로 즉시 제거됩니다. 디스크 공간이 문제가 되지 않는 한 삭제한 사서함 보존 기능을 사용할 수 있도록 하는 것이 좋습니다.

삭제된 사서함 보존을 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버, 사용 중인 저장소 그룹을 차례로 확장합니다. Exchange System Manager에 관리 그룹 노드가 표시되지 않으면 서버와 사용 중인 저장소 그룹을 차례로 확장합니다.

  3. 구성할 사서함 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  4. 제한 탭의 삭제된 사서함 보존 기간(일) 필드에 사서함 보존 기간을 입력합니다.

  5. 확인을 클릭하여 변경 내용을 저장합니다.
참고:
사서함 보존 기간이 만료되지 않았고 관련 사용자 개체가 삭제되지 않았으면 사서함을 복구할 수 있습니다.

삭제된 사서함 복구에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 274343, "XADM: Exchange 2000에서 삭제된 사서함을 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=274343)

  • 813337, "HOWTO: Exchange 2000 Server에서 단일 사서함 복구 또는 복원"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=813337)

  • 823176, "How to recover or to restore a single mailbox in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823176)


도메인에 알 수 없는 Exchange 서명이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-12-04

Microsoft® Exchange Server Analyzer Tool은 지정된 도메인에서 마지막으로 실행된 DomainPrep의 버전을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. DomainPrep의 버전 번호는 도메인의 Exchange 서명 역할을 합니다. Exchange Server Analyzer는 지정된 도메인의 Exchange System Objects 개체에 대한 objectVersion 특성을 검사합니다. 다음 두 가지 유효한 정수가 있습니다.

  • Exchange 2000 Server의 경우 objectVersion 값은 4406입니다.

  • Exchange Server 2003의 경우 objectVersion 값은 6936입니다.

  • Exchange Server 2007의 경우 objectVersion 값은 10628입니다.

Exchange Server Analyzer는 objectVersion 특성 값이 위와 같이 설정되어 있지 않은 경우 오류를 표시합니다.

해당 도메인에 시험판 Exchange 2000 Server 또는 Exchange Server 2003을 설치하고 정식 버전의 DomainPrep을 실행하지 않은 경우 이 값이 잘못 설정되어 있을 가능성이 큽니다.

참고:
Microsoft Exchange 2000 Server 및 Exchange Server 2003 에서는 setup /forestprep 및 setup /domainprep를 실행하여 Active Directory 준비 단계를 수행했습니다. Exchange 2007 에는 /forestprep 및 /domainprep 옵션이 없습니다. Exchange Server 2007의 경우에는 Active Directory 및 도메인 준비에 필요한 권한을 가진 계정에서 setup /PrepareDomain 프로세스 또는 설치 마법사를 실행합니다.

Exchange 2000 Server 또는 Exchange Server 2003에서 이 오류를 해결하려면 Exchange 2000 Server DomainPrep의 최종 출시 버전, Exchange Server 2003 DomainPrep 또는 PrepareDomain 프로세스의 최종 출시 버전, Exchange Server 2007 설치 마법사를 실행합니다. DomainPrep, PrepareDomain 또는 설치 마법사를 실행할 계정은 해당 로컬 도메인에 있는 Domain Admins 보안 그룹의 구성원 및 로컬 컴퓨터 관리자여야 합니다.

  • 루트 도메인

  • Exchange 2000 Server 컴퓨터나 Exchange Server 2003 컴퓨터가 포함될 모든 도메인

  • Exchange Server의 설치 여부에 상관없이 Exchange 2000 Server 또는 Exchange Server 2003 사서함 사용이 가능한 개체(예: 사용자 및 그룹)가 포함될 모든 도메인

  • Exchange 디렉터리 액세스 구성 요소가 사용할 가능성이 있는 글로벌 카탈로그 서버가 포함될 모든 도메인

  • Exchange 조직을 관리하는 데 사용할 Exchange 2000 Server 또는 Exchange Server 2003 사용자 및 그룹이 포함될 모든 도메인

Exchange 2000 Server 또는 Exchange Server 2003에서 DomainPrep를 실행하려면 다음을 수행하십시오.

  1. CD-ROM 드라이브에 Exchange CD를 넣습니다. 해당 도메인 내의 모든 컴퓨터에서 DomainPrep을 실행할 수 있습니다.

  2. 명령 프롬프트에 <drive>:\setup\i386\setup /DomainPrep를 입력합니다. 여기서 <drive>는 사용자의 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사 시작 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. 제품 ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지에서 작업이 DomainPrep으로 설정되었는지 확인합니다. 아닌 경우 드롭다운 화살표를 클릭한 다음 DomainPrep을 클릭합니다. 다음을 클릭합니다.

  7. Microsoft Exchange 마법사 완료 페이지에서 마침을 클릭합니다.

Exchange Server 2007에서 PrepareDomain을 실행하려면 다음을 수행하십시오.

  1. "Active Directory 및 도메인을 준비하는 방법"(http://go.microsoft.com/fwlink/?LinkId=78453)의 단계별 안내를 따르십시오.

Exchange Server 2003 DomainPrep 실행에 대한 자세한 내용은 Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.

Exchange 2000 DomainPrep 실행에 대한 자세한 내용은 "Microsoft Exchange 2000 Server Installation and Setup"(http://go.microsoft.com/fwlink/?LinkId=5906)을 참조하십시오.

Exchange Server 2007에서의 Active Directory 및 도메인 준비에 대한 자세한 내용은 "Active Directory 및 도메인을 준비하는 방법"(http://go.microsoft.com/fwlink/?LinkId=78453)을 참조하십시오.


도메인 컨트롤러에서 Exchange Server가 게스트로 설치된 Microsoft Virtual 2005가 실행되고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Model 키 값이 Virtual Machine으로 설정되었는지 확인하기 위해 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 다음 레지스트리 값이 있는지도 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

또한 Exchange Server Analyzer는 Microsoft Virtual Server 2005가 실행되고 있는 실제 컴퓨터에서 Win32_ComputerSystem의 Domain Role 키를 읽습니다. 이 값이 3보다 크면 실제 컴퓨터가 도메인 컴퓨터인 것입니다.

Exchange Server Analyzer는 Model 키에 문자열 Virtual Machine이 포함되어 있고 위의 레지스트리 분기가 존재하며 Domain Role이 3보다 클 경우 오류를 표시합니다.

Model 키의 Virtual Machine 값은 Exchange Server 컴퓨터가 Virtual Server 2005 또는 Microsoft Virtual PC 2004에서 게스트 가상 컴퓨터로 실행 중임을 나타냅니다. 위의 레지스트리 분기는 Virtual Server 2005에 의해서만 만들어지므로 이러한 분기가 있으면 Exchange Server 컴퓨터가 Virtual Server 2005에서 게스트 가상 컴퓨터로 실행 중이라는 뜻입니다.

Microsoft에서는 모든 Microsoft Exchange Server 버전을 가상 시스템이나 에뮬레이터에서 실행하는 것을 지원하지 않습니다. 이 사항은 Virtual Server 2005, Virtual PC 2004 또는 타사 가상 컴퓨터 프로그램에서 실행되는 Exchange Server에 해당되는 내용입니다. Exchange Server 플랫폼은 실제 하드웨어, 특히 Windows Server Catalog(http://go.microsoft.com/fwlink/?linkid=17219)에 나열된 하드웨어 플랫폼에서만 실행되도록 설계되고 테스트되었습니다.

또한 Exchange를 도메인 컨트롤러에서 가상 서버 게스트로 실행하면 서비스 간에 중복성이 허용되지 않으므로 바람직하지 않습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Virtual Server 2005로 실행되는 Exchange Server에서 비가상 Exchange Server 컴퓨터로 사서함을 옮깁니다.

  2. 모든 공용 폴더를 옮기고 필요할 경우 가상 Exchange 서버가 보유하고 있는 모든 역할을 전송합니다.

  3. 가상 컴퓨터에서 Exchange를 제거하여 Exchange 인프라 및 Active Directory® 디렉터리 서비스에서 Exchange를 제거합니다.

사서함 이동에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 822892, "Exchange 2003 사서함 이동의 개선 사항"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, XADM: Differences Between Move Mailbox Methods(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

가상 환경에서 실행되는 Exchange Server 컴퓨터 지원에 대한 자세한 내용은 Microsoft 기술 자료 문서 320220, "Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)을 참조하십시오.

Microsoft Virtual Server 2005에 대한 자세한 내용을 보려면 http://go.microsoft.com/fwlink/?LinkId=34938을 방문하십시오.

Microsoft Virtual PC 2004에 대한 자세한 내용을 보려면 http://go.microsoft.com/fwlink/?linkid=34663을 방문하십시오.


도메인 명명 FSMO 역할이 응답하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에 쿼리하여 구성 명명 컨텍스트에서 도메인 명명 작업 마스터의 fSMORoleOwner 특성 값을 확인합니다. 예를 들어 contoso.com이라는 도메인에서 도메인 명명 작업 마스터의 fSMORoleOwner는 CN=Partitions,CN=Configuration,DC=contoso,DC=com의 특성입니다. 그런 다음 Exchange Server Analyzer는 현재 이 역할을 수행하고 있는 도메인 컨트롤러의 TCP 포트 389에 LDAP(Lightweight Directory Access Protocol) 연결을 시도합니다. Exchange Server Analyzer는 이 도메인 컨트롤러에 연결할 수 없을 경우 오류를 표시합니다.

도메인 명명 마스터는 도메인에 관계없이 포리스트 계층 구조에 있는 모든 디렉터리 파티션의 추가와 제거를 관리하므로 포리스트 전반의 작업 마스터 역할입니다. 도메인 명명 마스터 역할이 있는 도메인 컨트롤러는 다음 작업을 수행할 수 있는 도메인 컨트롤러뿐입니다.

  • 포리스트에 새 도메인을 추가합니다.

  • 포리스트에서 기존 도메인을 제거합니다.

  • 외부 디렉터리에서 상호 참조 개체를 추가하거나 제거합니다.

전체 포리스트에는 하나의 도메인 명명 마스터만 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 오류에 지정된 디렉터리 서버가 온라인 상태인지 그리고 조직의 Exchange 서버에서 액세스할 수 있는지를 확인합니다.

  2. 이 디렉터리 서버의 역할이 해제되었으면 다른 도메인 컨트롤러에 도메인 명명 마스터 역할을 할당해야 합니다.

한 도메인 컨트롤러에서 다른 도메인 컨트롤러로 도메인 명명 작업 마스터 역할을 전송하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • Microsoft Windows Server™ 2003에 대한 자세한 내용은 324801, "Windows Server 2003에서 FSMO 역할을 보고 전송하기"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)를 참조하십시오.

  • Microsoft Windows® 2000 Server에 대한 자세한 내용은 255690, "그래픽 사용자 인터페이스에서 FSMO 역할을 보고 전송하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)을 참조하십시오.


도메인 명명 FSMO 역할을 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에 쿼리하여 구성 명명 컨텍스트에서 도메인 명명 작업 마스터의 fSMORoleOwner 특성을 확인합니다. 예를 들어 contoso.com이라는 도메인에서 도메인 명명 마스터의 fSMORoleOwner는 CN=Partitions, CN=Configuration, DC=contoso, DC=com의 특성입니다. 그런 다음 Exchange Server Analyzer는 도메인 컨트롤러에 LDAP(Lightweight Directory Access Protocol) 연결을 시도합니다. Exchange Server Analyzer는 fSMORoleOwner 특성에 지정된 도메인 컨트롤러가 응답하지 않을 경우 오류를 표시합니다.

도메인 명명 마스터 도메인 컨트롤러는 포리스트에서 도메인의 추가 또는 제거를 제어합니다. 전체 포리스트에는 하나의 도메인 명명 마스터만 있습니다.

사용 중인 Active Directory 포리스트에 대해 도메인 명명 마스터를 정의해야 합니다. Exchange 및 Exchange 서비스 팩을 설치하는 동안 도메인 명명 마스터 도메인 컨트롤러가 온라인 상태가 아니면 설치되지 않습니다. 도메인 명명 마스터로 표시된 도메인 컨트롤러가 오프라인 상태이면 다시 온라인 상태로 만들어야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 지정된 Active Directory 서버가 실제로 있는지 확인합니다.

  2. 이 디렉터리 서버의 역할이 해제되었으면 다른 도메인 컨트롤러에 도메인 명명 마스터 역할을 할당합니다.

도메인 명명 마스터의 역할을 다른 도메인 컨트롤러에 할당하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • Microsoft Windows Server™ 2003의 경우는 324801, "HOWTO: Windows Server 2003에서 FSMO 역할을 보고 전송하기"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)를 참조하십시오.

  • Microsoft Windows® 2000 Server의 경우는 255690, "그래픽 사용자 인터페이스에서 FSMO 역할을 보고 전송하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)을 참조하십시오.


디렉터리 서버 DNS 이름 확인 실패
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 Active Directory® 디렉터리 서비스 서버에 대해 구성된 DNS(Domain Name System) 서버에 대해 DNS 퀴리를 시도합니다. 이 연결은 이름 확인을 수행하고 결과를 분석하는 사용자 지정 개체 프로세서를 사용하여 이루어집니다. Exchange Server Analyzer에서 쿼리 결과의 일부로 IP 주소를 받지 못하면 오류를 표시합니다.

이 오류는 DNS에서 디렉터리 서버를 찾을 수 없음을 나타냅니다. Exchange Server 및 Active Directory가 올바르게 작동하려면 DNS가 제대로 구성되어 안정적으로 실행되어야 합니다. DNS 등록 및 확인 문제는 메시지 전송, 수신 및 배달 기능에 폭넓게 영향을 미칩니다.

Active Directory 및 Exchange Server가 올바르게 작동할 수 있도록 DNS를 제대로 구성해야 합니다. Active Directory에 대한 DNS 구성을 보다 자세히 이해하려면 Microsoft 기술 자료 문서 237675, "Active Directory용 도메인 이름 시스템 설정"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675)을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. 다음 구성 항목을 검토하여 DNS 상태가 안정적이고 Active Directory DNS 항목이 제대로 구성되어 있는지 확인하십시오.

    • DNS IP 구성

    • 동적 영역 업데이트

    • DNS 전달자

  2. 루트 영역 항목이 있는지 확인합니다. DNS 관리 콘솔에서 정방향 조회 영역을 봅니다. 해당 영역에 도메인에 대한 항목이 있습니다. 다른 영역 항목이 있을 수도 있습니다. 점(".") 영역이 있으면 안 됩니다. 점(".") 영역이 있으면 해당 점(".") 영역을 삭제합니다. 점(".") 영역은 DNS 서버를 루트 서버로 식별합니다. 일반적으로 외부(인터넷) 액세스가 필요한 Active Directory 도메인을 루트 DNS 서버로 구성해서는 안 됩니다. 점(".")을 삭제한 후 디렉터리 서버에서 Ipconfig /registerdns를 사용하여 디렉터리 서버 IP 주소를 수동으로 등록합니다. Netlogon 서비스를 다시 시작해야 할 수도 있습니다.

  3. 디렉터리 서버에서 netdiag /fix를 사용하여 Active Directory DNS 항목을 수동으로 다시 채웁니다.

Active Directory에 DNS를 사용하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 323418, "Windows Server 2003 제품군에서 Active Directory가 사용되는 경우 기존 DNS 인프라에 DNS를 통합하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418)을 참조하십시오.

DNS 및 Active Directory 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 260371, "Windows 2000에서 일반적인 Active Directory 설치 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371)을 참조하십시오.


dSHeuristics가 호스팅된 Exchange에 대해 제대로 설정되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 해당 배포가 호스팅된 Exchange 배포인지 여부를 확인합니다. Exchange 배포가 호스팅된 환경에서 실행 중인 경우 Exchange Server Analyzer는 Active Directory를 쿼리하여 디렉터리 서비스 컨테이너의 dSHeuristics 특성이 호스팅된 Exchange 배포에 대해 제대로 설정되어 있는지 확인합니다.

dSHeuristics 값이 1이 아니면 Exchange Server Analyzer에서 경고를 표시합니다. 호스팅된 Exchange 환경에서 dSHeuristics 특성은 1로 설정해야 합니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 경고를 해결하려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 사용하여 Active Directory에서 Directory Service 개체를 찾습니다.

    dSHeuristics 특성은 다음 위치에 있습니다.

    CN=Configuration, CN=Services, CN=Windows NT, CN=Directory Service

  2. dSHeuristics에 값 1을 입력합니다.

호스팅된 Exchange 환경에 대한 자세한 내용은 다음 문서를 참조하십시오.

  • "Information for Hosters"(http://go.microsoft.com/fwlink/?LinkId=46307)

  • Exchange Server 2000 Resource Kit(http://go.microsoft.com/fwlink/?LinkId=46326)의 "Hosted Service Environments"


Active Directory에 중복 Microsoft Exchange System Objects 컨테이너가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 도메인 명명 컨텍스트에 Microsoft Exchange System Objects 컨테이너가 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

Exchange Server Analyzer는 Active Directory에 중복 Microsoft Exchange System Objects 컨테이터가 있음을 발견하면 다음 오류 메시지를 표시합니다. "Active Directory 도메인이 Exchange용으로 준비되었지만 여러 개의 'Microsoft Exchange System Objects' 컨테이너가 있습니다. 정리가 필요할 수 있습니다."

이 문제는 Exchange Server 환경에서 다음과 같은 경우에 발생할 수 있습니다.

  • Active Directory에서 Exchange Server 5.5로의 양방향 ADC(Active Directory Connector) 서버 연결 동의(CA)가 삭제되고 바뀌었습니다.

  • Exchange Server 5.5에서 Active Directory로의 새 단방향 ADC 서버 연결 동의(CA)가 사용 중입니다.

  • Exchange Server 5.5를 실행하는 혼합 모드 환경이 Exchange Server 2003 환경으로 마이그레이션되었습니다.

  • 외부 메일 서버에서 Exchange Server 2003으로 마이그레이션되었습니다.

Exchange Server Analyzer가 이 오류를 표시하면 잘못된 중복 Microsoft Exchange System Objects 컨테이너 또는 조직 단위(OU)를 삭제해야 합니다. 중복 Microsoft Exchange System Objects 컨테이너가 있으면 DomainPrep을 다시 실행하여 문제를 해결할 수 없습니다. 잘못된 중복 Microsoft Exchange System Objects 컨테이너를 식별하여 삭제해야 합니다.

중복 Microsoft Exchange System Object 컨테이너를 제거하려면 다음을 수행합니다.

  1. 관리 자격 증명을 사용하여 도메인 컨트롤러에 로그온합니다.

  2. 시작, 프로그램, 관리 도구, Active Directory 사용자 및 컴퓨터를 차례로 클릭합니다.

  3. Active Directory 사용자 및 컴퓨터 관리 콘솔 창의 도구 모음 메뉴에서 보기를 클릭하고 고급 기능을 선택합니다.

  4. Active Directory 사용자 및 컴퓨터 관리 콘솔 창에서 잘못된 중복 Microsoft Exchange System Objects 컨테이너 또는 조직 단위(OU)를 찾습니다.

  5. 잘못된 중복 Microsoft Exchange System Objects 컨테이너 또는 OU에 잘못된 Active Directory 개체가 들어 있는지 확인합니다.

  6. 잘못된 중복 Microsoft Exchange System Objects 컨테이너 또는 OU를 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭합니다.

  7. Active Directory 대화 상자에서 예를 클릭하여 삭제를 확인합니다.

    참고:
    변경 내용을 즉시 복제하려면 도메인 컨트롤러 사이에서 복제를 수동으로 시작해야 합니다.

Exchange Server의 이 문제에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 316280, "XADM: A Description of the 'ADC Global Names' Attribute"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=316280)

  • 252228, "XADM: ADC Appears to Create Duplicate Objects"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=252228)

  • 253800, "XADM: ADC May Create Duplicate Objects in Active Directory"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253800)

  • 274480, "XADM: Duplicate Object Created When Replicating Objects from Exchange Server 5.5 to Windows 2000 Active Directory"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=274480)

  • 288578, "XADM: ADC Creates Duplicate Accounts in Exchange Server 5.5 and Active Directory"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288578)


Active Directory에 액세스하는 동안 오류가 발생했습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 도메인 컨트롤러를 사용할 수 없음을 확인했습니다. Active Directory 도메인 컨트롤러에 네트워크를 통해 연결되었는지 확인합니다.

이 오류를 수정하려면 다음을 수행합니다.

  • Exchange Server Analyzer에 Active Directory 도메인 컨트롤러를 지정한 경우에는 도메인 컨트롤러를 지정하지 않고 연결해 봅니다.

  • 도메인 컨트롤러를 지정하지 않은 경우에는 실행 중이고 사용 가능한 도메인 컨트롤러를 지정합니다.


Exchange 관리 그룹 액세스 오류
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool에서 Exchange 조직이 Active Directory® 디렉터리 서비스 포리스트에 설치되었고 사용자가 Active Directory의 Exchange 조직 구성 정보에 액세스했음을 확인했습니다. 그러나 Exchange 서버를 포함하는 관리 그룹은 발견하지 못했습니다.

이 오류를 수정하려면 다음을 수행합니다.

  • Active Directory에서 Exchange 관리 그룹에 대한 컨테이너에 액세스할 수 있는 적절한 권한이 사용자에게 있는지 확인합니다.

  • Exchange Server Analyzer를 실행 중인 워크스테이션이 다른 Active Directory 포리스트에 속해 있거나 도메인 계정을 사용하여 로그인하지 않은 경우 Exchange 서버를 호스트하는 포리스트의 Active Directory 도메인 컨트롤러에 연결해야 합니다.


Exchange 구성 컨테이너 액세스 오류
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Exchange 구성 컨테이너에 액세스할 수 없음을 확인했습니다. Exchange 조직, 관리 그룹 및 서버 구성 정보는 Active Directory® 디렉터리 서비스의 구성 명명 컨텍스트에 저장됩니다. Exchange 구성 정보에 액세스하려면 Active Directory 구성 컨테이너의 Microsoft Exchange 분기를 읽어야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  • Active Directory 구성 컨테이너를 읽는 데 필요한 권한이 있는지 확인합니다.

  • Active Directory 도메인 컨트롤러에 네트워크 연결이 되어 있는지 확인합니다.


Everyone 보안 그룹이 최상위 공용 폴더를 만드는 권리에 대해 거부되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-12-04

Microsoft® Exchange Server Analyzer Tool은 Exchange 조직 개체의 ntSecurityDescriptor에 Exchange 보안 그룹의 SID(보안 식별자)가 나열되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 Everyone 그룹의 SID가 조직 개체의 ntSecurityDescriptor에 있으면 경고를 표시합니다. 이 경고는 Everyone 그룹이 최상위 공용 폴더를 만드는 권한에 대해 거부되지 않았음을 의미합니다.

Exchange 2000 Server에서 최상위 공용 폴더를 만들 권한은 기본적으로 허용됩니다. 그러나 Exchange Server 2003 버전의 ForestPrep 또는 Exchange Server 2007 버전의 PrepareAD가 실행되면 Everyone 보안 그룹의 최상위 공용 폴더를 만드는 권한은 거부됩니다. 거부 기능은 보안 방법으로 구현되었습니다. Everyone 보안 그룹이 최상위 공용 폴더를 만들도록 허용하면 조직이 DoS(Denial-of-Service) 공격에 취약해질 수 있습니다.

따라서 Everyone 보안 그룹에게는 최상위 공용 폴더를 만드는 권한을 거부하는 것이 좋습니다. Exchange Server 2003 또는 Exchange Server 2007을 사용하는 경우에는 Exchange Server 2003 버전의 ForestPrep 또는 Exchange Server 2007 버전의 PrepareAD를 각각 실행해야 합니다. orestPrep의 Exchange Server 2003 버전은 Exchange 2000 Server 환경에서 실행할 수 있습니다. 그러나 Exchange 2000 Server를 후에 설치하면 Everyone 보안 그룹이 최상위 공용 폴더를 만들 수 있도록 허용하는 사용 권한이 다시 설정됩니다.

Exchange Server 2003 또는 Exchange Server 2007이 없는 경우, 이 사용 권한을 수동으로 설정할 수 있습니다. Exchange 2000 Server를 후에 설치하면 이 사용 권한이 다시 설정된다는 점을 명심하십시오. 따라서 Exchange 2000 Server의 각 설치 후에 이 사용 권한을 수동으로 구성해야 합니다. 사용 권한을 설정하려면 보안 탭이 Exchange System Manager에 표시되도록 설정해야 합니다.ShowSecurityPage 항목을 Exchange Server 컴퓨터의 레지스트리에 추가하면 됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.
ShowSecurityPage 항목을 레지스트리에 추가하려면 다음을 수행하십시오.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKEY_CURRENT_USER\Software\Microsoft\Exchange\ExAdmin을 탐색합니다.

  3. 편집, 새로 만들기, DWORD 값을 차례로 클릭합니다.

  4. 새 값 이름으로 ShowSecurityPage를 입력한 다음 Enter 키를 누릅니다.

  5. ShowSecurityPage를 두 번 클릭하고 값 데이터 필드에 1을 입력한 다음 확인을 클릭합니다.

Everyone 보안 그룹에 Exchange 2000 Server 환경에서 최상위 공용 폴더를 만들 수 있는 권한을 수동으로 거부하려면 다음을 수행하십시오.

  1. Exchange System Manager를 엽니다.

  2. Organization_Name을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. Organization_Name 속성 페이지에서 보안 탭을 클릭합니다.

  4. 보안 탭의 그룹 또는 사용자 이름에서 Everyone을 선택합니다. Everyone의 사용 권한 상자에서 최상위 공용 폴더 만들기 사용 권한이 나타날 때까지 아래로 스크롤하여 허용 열 확인란의 선택을 해제하고 적용을 클릭합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server 2003 ForestPrep 실행에 대한 자세한 내용은 Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.

Exchange Server 2007 PrepareAD 실행에 대한 자세한 내용은 "How to Prepare Active Directory and Domains"(http://go.microsoft.com/fwlink/?LinkId=78453)를 참조하십시오.

Exchange 2000 Server에서 Everyone 보안 그룹에게 최상위 공용 폴더를 만드는 권한을 거부하는 방법에 대한 자세한 내용은 기술 자료 문서 328808, "HOW TO: Remove User Permission from the Create Top-Level Public Folder in Exchange 2000"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328808)을 참조하십시오.


Exchange 도메인 컨테이너 문제
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 도메인 명명 컨텍스트에 Microsoft Exchange System Objects 컨테이너가 존재하는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 Microsoft Exchange System Objects 컨테이너가 존재하지 않거나 유효하지 않거나 형식에 문제가 있을 경우 오류를 표시합니다.

Microsoft Exchange System Objects 컨테이너는 Exchange DomainPrep이 실행될 때 각 도메인에서 생성됩니다.

이 오류가 발견된 도메인에서 DomainPrep을 실행해야 합니다. Microsoft Exchange System Objects 컨테이너가 없는 도메인 이름은 Exchange Server Analyzer 출력에 표시됩니다.

DomainPrep을 실행하는 데 사용하는 계정은 해당 로컬 도메인에 있는 Domain Admins 보안 그룹의 구성원 및 로컬 컴퓨터 관리자여야 합니다.

일반적으로 DomainPrep은 다음과 같은 도메인에서 실행해야 합니다.

  • 루트 도메인

  • Exchange 2000 Server 컴퓨터나 Exchange Server 2003 컴퓨터가 포함될 모든 도메인

  • Exchange 서버의 설치 여부에 상관없이 Exchange 2000 Server 또는 Exchange Server 2003 사서함 사용이 가능한 개체(예: 사용자 및 그룹)가 포함될 모든 도메인

  • Exchange 디렉터리 액세스 구성 요소가 사용할 가능성이 있는 글로벌 카탈로그 서버가 포함될 모든 도메인

  • Exchange 조직을 관리하는 데 사용할 Exchange 2000 Server 또는 Exchange Server 2003 사용자 및 그룹이 포함될 모든 도메인

DomainPrep을 실행하려면 다음을 수행합니다.

  1. CD-ROM 드라이브에 Exchange CD를 넣습니다. 해당 도메인 내의 모든 컴퓨터에서 DomainPrep을 실행할 수 있습니다.

  2. 명령 프롬프트에서 <drive>:\setup\i386\setup /DomainPrep를 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지에서 작업이 DomainPrep으로 설정되었는지 확인합니다. 아닌 경우 드롭다운 화살표를 클릭한 다음 DomainPrep을 클릭합니다. 다음을 클릭합니다.

  7. Microsoft Exchange 마법사 완료 페이지에서 마침을 클릭합니다.

Exchange Server 2003 DomainPrep 실행 방법에 대한 자세한 내용은 Exchange 2003 Server 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.

Exchange 2000 Server DomainPrep에 대한 자세한 내용은 기술 문서 "Microsoft Exchange 2000 Server Installation and Setup"(http://go.microsoft.com/fwlink/?LinkId=5906)을 참조하십시오.


Exchange 도메인 서버 그룹을 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 도메인에서 실행되고 있는 DomainPrep 버전을 확인하기 위해 Microsoft Exchange System Objects 개체의 ntSecurityDescriptor 특성 값을 확인합니다.

다음 두 가지 유효한 정수가 있습니다.

  • Exchange 2000 Server에 대한 ntSecurityDescriptor 값은 4406입니다.

  • Exchange Server 2003에 대한 ntSecurityDescriptor 값은 6936입니다.

위의 버전 중 하나의 DomainPrep이 사용된 경우 Exchange Server Analyzer는 Active Directory를 쿼리하여 Exchange Domain Servers 그룹의 존재 여부를 확인하기 위해 Microsoft Exchange System Objects 개체의 objectGuid 특성 값을 확인합니다. 이 그룹이 존재하지 않으면 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류를 해결하려면 최종 버전의 Exchange 2000 Server DomainPrep 또는 Exchange Server 2003 DomainPrep을 실행하십시오. DomainPrep을 실행하는 데 사용하는 계정은 해당 로컬 도메인에 있는 Domain Admins 보안 그룹의 구성원 및 로컬 컴퓨터 관리자여야 합니다.

DomainPrep은 다음과 같은 도메인에서 실행해야 합니다.

  • 루트 도메인

  • Exchange 2000 Server 컴퓨터나 Exchange Server 2003 컴퓨터가 포함될 모든 도메인

  • Exchange 서버의 설치 여부에 상관없이 Exchange 2000 Server 또는 Exchange Server 2003 사서함 사용이 가능한 개체(예: 사용자 및 그룹)가 포함될 모든 도메인

  • Exchange 디렉터리 액세스 구성 요소가 사용할 가능성이 있는 글로벌 카탈로그 서버가 포함될 모든 도메인

  • Exchange 조직을 관리하는 데 사용할 Exchange 2000 Server 또는 Exchange Server 2003 사용자 및 그룹이 포함될 모든 도메인

DomainPrep을 실행하려면 다음을 수행합니다.

  1. Exchange CD를 CD 드라이브에 넣습니다. 해당 도메인 내의 모든 컴퓨터에서 DomainPrep을 실행할 수 있습니다.

  2. 명령 프롬프트에서 <drive>:\setup\i386\setup /DomainPrep을 입력합니다. 여기서 <drive>는 CD 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지에서 작업이 DomainPrep으로 설정되었는지 확인합니다. 아닌 경우 드롭다운 화살표를 클릭한 다음 DomainPrep을 클릭합니다. 다음을 클릭합니다.

  7. Microsoft Exchange 마법사 완료 페이지에서 마침을 클릭합니다.

Exchange 2003 DomainPrep 실행 방법에 대한 자세한 내용은 Exchange 2003 Server 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.

Exchange 2000 DomainPrep 실행에 대한 자세한 내용은 "Microsoft Exchange 2000 Server Installation and Setup"(http://go.microsoft.com/fwlink/?LinkId=5906)을 참조하십시오.


Exchange Enterprise Servers 그룹을 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 도메인에서 실행되고 있는 DomainPrep 버전을 확인하기 위해 Microsoft Exchange System Objects 개체의 ntSecurityDescriptor 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

다음 두 가지 유효한 정수가 있습니다.

  • Exchange 2000 Server에 대한 ntSecurityDescriptor 값은 4406입니다.

  • Exchange Server 2003에 대한 ntSecurityDescriptor 값은 6936입니다.

위의 DomainPrep 버전이 둘 모두 존재하는 경우 Exchange Server Analyzer는 Exchange Enterprise Servers 그룹 존재 여부를 확인할 때 Microsoft Exchange System Objects 개체의 objectGuid 특성 값을 검토할 때 Active Directory를 쿼리합니다. Exchange Server Analyzer는 이 그룹이 존재하지 않는 경우 오류를 표시합니다.

이 오류를 해결하려면 최종 버전의 Exchange 2000 Server DomainPrep 또는 Exchange Server 2003 DomainPrep을 실행하십시오. DomainPrep을 실행하는 데 사용하는 계정은 해당 로컬 도메인에 있는 Domain Admins 보안 그룹의 구성원 및 로컬 컴퓨터 관리자여야 합니다.

DomainPrep은 다음과 같은 도메인에서 실행해야 합니다.

  • 루트 도메인

  • Exchange 2000 Server 컴퓨터나 Exchange Server 2003 컴퓨터가 포함될 모든 도메인

  • Exchange 서버의 설치 여부에 상관없이 Exchange 2000 Server 또는 Exchange Server 2003 사서함 사용이 가능한 개체(예: 사용자 및 그룹)가 포함될 모든 도메인

  • Exchange 디렉터리 액세스 구성 요소가 사용할 가능성이 있는 글로벌 카탈로그 서버가 포함될 모든 도메인

  • Exchange 조직을 관리하는 데 사용할 Exchange 2000 Server 또는 Exchange Server 2003 사용자 및 그룹이 포함될 모든 도메인

DomainPrep을 실행하려면 다음을 수행합니다.

  1. CD 드라이브에 Exchange CD를 넣습니다. 해당 도메인 내의 모든 컴퓨터에서 DomainPrep을 실행할 수 있습니다.

  2. 명령 프롬프트에 <drive>:\setup\i386\setup /DomainPrep을 입력합니다. 여기서 <drive>는 CD 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지에서 작업이 DomainPrep으로 설정되었는지 확인합니다. 아닌 경우 드롭다운 화살표를 클릭한 다음 DomainPrep을 클릭합니다. 다음을 클릭합니다.

  7. Microsoft Exchange 마법사 완료 페이지에서 마침을 클릭합니다.

Exchange Server 2003 DomainPrep에 대한 자세한 내용은 Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.

Exchange 2000 Server DomainPrep 실행에 대한 자세한 내용은 "Microsoft Exchange 2000 Server Installation and Setup"(http://go.microsoft.com/fwlink/?LinkId=5906)을 참조하십시오.


Lost and Found 컨테이너의 Exchange 개체
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-12-01

Microsoft® Exchange Server Analyzer Tool은 Configuration 컨테이너의 LostAndFoundConfig 컨테이너에 개체가 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 LostAndFoundConfig 컨테이너에 개체가 있을 경우 해당 개체와 이 개체가 파생된 개체 클래스를 나타내는 오류 메시지를 표시합니다.

LostAndFoundConfig 컨테이너는 Active Directory에 의해 조정될 수 없는 개체를 포함합니다. Exchange에서 LostAndFoundConfig 컨테이너에 있는 개체를 사용하려고 하므로 해당 개체를 모두 삭제해야 합니다. 예를 들어 Exchange가 Active Directory에서 개체 클래스(즉, Server)를 쿼리하면 LostAndFoundConfig 컨테이너에 존재하는지 여부에 관계없이 모든 개체가 유효한 개체로 반환됩니다. 그 결과 Exchange에서는 실제 개체 대신 the LostAndFoundConfig 컨테이너에 있는 서버에 연결하려고 할 수 있습니다. 이로 인해 Exchange가 예상치 못한 방식으로 작동할 수 있으며 서버 오류가 발생할 수도 있습니다. 또한 이러한 개체가 실제로 존재할 경우 같은 클래스의 개체가 생성되지 못할 수 있습니다.

이 문제를 해결하려면 ADSI(Active Directory Service Interfaces) 편집을 사용하여 Active Directory에서 LostAndFoundConfig 컨테이너의 항목을 제거해야 합니다.

주의:
ADSI 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생될 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
참고:
ADSI 편집은 Windows 2000 Server 및 Windows Server 2003 지원 도구와 함께 제공되는 도구입니다.

이 오류를 해결하려면 다음을 수행하십시오.

  1. ADSI 편집 MMC 스냅인을 엽니다.

  2. 동작 메뉴에서 연결 대상을 클릭합니다.

  3. Connection Settings 대화 상자의 Name 필드에 ADSI 연결의 이름을 입력합니다. Connection Point에서 Select a well-known Naming Context를 선택한 후 드롭다운 메뉴에서 Configuration을 선택합니다. OK를 클릭합니다.

  4. 왼쪽 창에서 Configuration 개체를 두 번 클릭하고 LostAndFoundConfig를 두 번 클릭합니다.

  5. 오른쪽 창에서 모든 개체와 컨테이너를 삭제합니다. 개체 또는 컨테이너를 마우스 오른쪽 단추로 클릭하고 삭제를 클릭한 후 예를 클릭합니다.

  6. ADSI 편집을 종료합니다.


Exchange 조직에 받는 사람 정책이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 Exchange 조직에 대한 받는 사람 정책 개체의 Name 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 받는 사람 정책 개체가 없거나 받는 사람 정책 개체에 받는 사람 정책이 없으면 오류를 표시합니다.

Exchange Server가 설치되어 있으면 SMTP(Simple Mail Transfer Protocol) 및 X.400 주소를 Exchange 조직의 모든 받는 사람에게 적용하는 기본 받는 사람 정책이 만들어집니다. 기본 정책을 수정하거나 새 정책을 만들 수 있습니다. 그러나 기본 정책을 삭제하면 안 됩니다. Exchange 조직의 모든 받는 사람은 SMTP 및 X.400 주소 모두를 가지고 있어야 합니다. Exchange 조직에 받는 사람 정책이 없으면 안정성 문제가 발생합니다.

받는 사람 정책을 만들려면 다음을 수행합니다.

  1. 시작, 모든 프로그램, Microsoft Exchange, System Manager를 차례로 클릭합니다.

  2. Exchange System Manager의 왼쪽 창에서 조직, 받는 사람을 차례로 확장하고 받는 사람 정책을 마우스 오른쪽 단추로 클릭한 다음 새로 만들기를 가리키고 받는 사람 정책을 클릭합니다.

  3. 새 정책 대화 상자에서 전자 메일 주소 확인란과 사서함 관리자 설정 확인란 중 하나를 선택하거나 둘 모두를 선택한 다음 확인을 선택하여 만들 정책 종류를 선택합니다.

  4. 속성 대화 상자에서 새 받는 사람 정책의 이름을 입력한 다음 수정을 클릭하여 받는 사람 정책의 필터를 만듭니다.

    참고:
    필터를 만들지 않으면 받는 사람에 정책이 적용되지 않습니다.

  5. 받는 사람 정책을 사용자 지정하려면 속성 대화 상자에서 전자 메일 주소(정책) 탭이나 사서함 관리자 설정(정책) 탭으로 전환합니다. 이러한 탭의 설정을 사용하여 받는 사람 정책을 구성한 다음 확인을 클릭하여 정책을 만듭니다.

  6. Exchange System Manager에서 받는 사람 정책을 마우스 오른쪽 단추로 클릭한 다음 지금 정책 적용을 클릭합니다.

받는 사람 및 받는 사람 정책에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=21769)의 "Managing Recipients and Recipient Policies"를 참조하십시오.

받는 사람 정책을 만들고 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 249299, "HOW TO: Configure Recipient Policies in Exchange"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249299)를 참조하십시오.


Exchange 조직에 시스템 정책이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 Exchange 조직에 대한 시스템 정책 개체의 각 시스템 정책 이름을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 시스템 정책 개체가 없거나 시스템 정책 개체에 시스템 정책이 없으면 오류를 표시합니다.

시스템 정책 개체를 사용하여 사서함 저장소, 공용 폴더 저장소 또는 서버 설정과 같은 단일 구성 개체를 통해 여러 Exchange Server에 대한 매개 변수를 구성하여 시스템 관리를 간소화할 수 있습니다. 기본적으로 조직에서 ForestPrep을 실행할 때 다음 시스템 정책이 만들어집니다.

  • Hidden DL Membership

  • Mail-Enabled Recipient

  • Mailbox-Enabled User

이러한 기본 시스템 정책이 Exchange 조직에 없으면 안정성 문제가 발생합니다. 기본 시스템 정책을 다시 만들려면 ForestPrep를 실행해야 합니다.

Exchange Server 2003 ForestPrep을 실행하려면 다음을 수행합니다.

  1. CD 드라이브에 Exchange CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 drive:\setup\i386\setup /ForestPrep을 입력합니다. 여기서 drive는 CD 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지에서 작업이 ForestPrep으로 설정되어 있는지 확인합니다. 이렇게 설정되어 있지 않으면 드롭다운 화살표를 클릭한 다음 ForestPrep을 클릭합니다. 다음을 클릭합니다.

    중요:
    ForestPrep이 작업에 나타나지 않으면 2단계에서 ForestPrep 명령을 잘못 입력했을 수 있습니다. ForestPrep 명령을 잘못 입력했으면 2단계로 돌아가 명령을 다시 입력합니다.

  7. Microsoft Exchange Server 관리자 계정 페이지에서 계정 상자에 Exchange를 설치하는 계정이나 그룹 이름을 입력합니다.

    참고:
    지정한 계정은 Exchange 관리 위임 마법사를 사용하여 다른 Exchange 관리자 계정을 만들 수 있는 사용 권한도 가지게 됩니다. Exchange 관리 위임 마법사에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?linkid=47617)를 참조하십시오.

  8. 다음을 클릭하여 ForestPrep을 시작합니다. ForestPrep을 시작한 다음에는 프로세스를 취소할 수 없습니다.

    참고:
    네트워크 토폴로지와 Microsoft Windows® 2000 또는 Microsoft Windows Server™ 2003 도메인 컨트롤러의 속도에 따라 ForestPrep을 완료하는 데 시간이 오래 걸릴 수 있습니다.

  9. Microsoft Exchange 마법사 완료 페이지에서 마침을 클릭합니다.

Exchange에서 시스템 정책이 사용되는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 253838, "XADM: Recipient Update Service가 시스템 정책을 적용하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253838)을 참조하십시오.

시스템 정책에 대한 자세한 내용은 Exchange Server 2003 기술 참조 가이드(http://go.microsoft.com/fwlink/?LinkId=47891)의 "Exchange System Manager 아키텍처"를 참조하십시오.

Exchange에서 기본이 아닌 시스템 정책을 만드는 방법에 대한 자세한 내용은 기술 자료 문서 256141, "How to Create System Policies in Exchange"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256141)를 참조하십시오.


글로벌 카탈로그 NSPI 포트가 다시 정의되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2007-01-15

Microsoft® Exchange Server Analyzer Tool은 글로벌 카탈로그 서버에서 다음 레지스트리 항목을 읽어 TCP/IP Port 레지스트리 키가 설정되었는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters\TCP/IP Port

Exchange Server Analyzer는 TCP/IP Port 레지스트리 키가 만들어지고 설정된 경우 기본 구성이 아니라는 메시지를 표시합니다.

글로벌 카탈로그 서버에서 특정 포트를 사용하여 MAPI 클라이언트를 제공해야 하는 경우 TCP/IP 포트 레지스트리 키가 필요합니다. Exchange 환경에서 이러한 요구 사항이 없을 경우에는 이 키를 제거할 수 있습니다.

.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

글로벌 카탈로그 서버에서 TCP/IP 포트를 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Parameters를 탐색합니다.

  3. TCP/IP Port 키를 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC over HTTP 구성에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "Office Outlook 2003에서 클라이언트 RPC over HTTP 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)

  • 298369, "MAPI 클라이언트를 서비스할 경우 특정 포트를 사용하도록 글로벌 카탈로그 서버를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298369)

  • 24823, "Exchange Server 2003 RPC over HTTP 배포 시나리오"(http://go.microsoft.com/fwlink/?linkid=24823)


글로벌 카탈로그 포트 3268이 응답하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 이 서버의 isGlobalCatalogReady 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성의 True 값은 디렉터리 서버도 작동하는 글로벌 카탈로그 서버임을, False 값은 디렉터리 서버가 글로벌 카탈로그 서버가 아님을 나타냅니다.

그런 다음 Exchange Server Analyzer는 Exchange 서버의 포트 3268에 연결하여 포트가 응답하는지 확인합니다.

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • 서버가 글로벌 카탈로그 서버입니다.

  • 포트 3268가 응답하지 않습니다.

참고:
Exchange Server Analyzer를 실행하는 컴퓨터와 글로벌 카탈로그 서버 사이에 방화벽이 있으면 이 메시지가 표시될 수 있습니다.

이 문제는 일반적으로 글로벌 카탈로그 서버 확인란이 선택되었지만 서버가 다시 시작되지 않은 경우 발생합니다.

이 문제를 해결하려면 다음을 수행합니다.

  • 서버를 다시 시작합니다.

도메인 컨트롤러의 수준을 올리는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 304403, "XADM: 도메인 컨트롤러를 글로벌 카탈로그 서버로 승격시키기 위한 Exchange 고려 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403)을 참조하십시오.


그룹 클래스 스키마 오류
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-12-01

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 Active Directory 스키마에 있는 그룹 개체의 auxiliaryClass 특성에 msExchBaseClass 클래스가 나타나는지 확인합니다.

Active Directory에는 디렉터리에서 제대로 작동해야 하는 서로 다른 모든 개체 유형을 정의한 미리 정의된 클래스가 있습니다. 개체 정의는 서로의 내부에 클래스를 중첩하여 만들어집니다. 클래스를 중첩하면 클래스 간의 상위/하위 관계가 생성됩니다.

Exchange 2000 Server, Exchange Server 2003 및 Exchange Server 2007을 설치할 때 msExchBaseClass 클래스가 Active Directory에 추가됩니다. msExchBaseClass 클래스는 CDOEX(Exchange 2000 Server, Exchange Server 2003 및 Exchange Server 2007용 CDO)에 의해 확장된 모든 클래스에 적용되는 기본 보조 클래스입니다. CDOEX는 Exchange 저장소에서 대부분의 정보 유형을 관리하는 데 사용되는 기본 COM(구성 요소 개체 모델) 클래스 및 인터페이스를 제공합니다.

Active Directory 스키마를 잘못 수정하면 그룹 개체의 msExchBaseClass 클래스 및 auxiliaryClass 특성 간 관계가 단절될 수 있습니다. 이 단절로 인해 받는 사람 업데이트 서비스 처리 오류와 같은 Exchange Server 불안정성 문제가 발생하거나 조직에 새 Exchange Server 200x 서버를 설치하지 못할 수 있습니다.

Exchange Server Analyzer는 msExchBaseClass 클래스가 Active Directory 스키마의 그룹 개체에 대한 auxiliaryClass 특성에 나타나지 않으면 이 관계가 단절되었음을 나타냅니다. Exchange Server Analyzer는 msExchBaseClass 클래스가 Active Directory 스키마의 그룹 개체에 대한 auxiliaryClass 특성에 나타나지 않으면 오류를 표시합니다.

이 오류를 해결하려면 Microsoft 고객 지원 서비스(http://go.microsoft.com/fwlink/?LinkId=41364)에 문의하십시오.


호스팅된 Exchange에는 전용 모드의 Exchange 조직이 필요합니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Exchange Server가 호스팅된 Exchange 환경으로 구성되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server 환경이 호스팅된 Exchange 환경인 경우, Exchange Server Analyzer는 Active Directory를 쿼리하여 Exchange 조직이 혼합 모드로 실행 중인지 확인합니다.

Exchange 조직이 혼합 모드로 실행 중인 경우 경고가 표시됩니다. 호스팅된 Exchange 솔루션에는 전용 모드 조직이 필요합니다.

전용 모드로 전환한 후에는 다시 혼합 모드로 되돌릴 수 없습니다.

전용 모드로 전환하려면 다음을 수행합니다.

  1. 시작을 클릭하고 모든 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭하여 Exchange System Manager를 시작합니다.

  2. 콘솔 트리에서 전용 모드로 전환할 조직을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. <조직 이름> 속성에서 작동 모드 변경 아래의 모드 변경을 클릭합니다.

  4. 경고 대화 상자에서 전용 모드로 영구적으로 전환하려면 예를 클릭합니다. 새 Exchange 모드를 적용하려면 적용을 클릭합니다.

Exchange 전용 모드를 최대한 활용하려면 Microsoft Exchange Information Store 서비스를 조직의 모든 Exchange 서버에서 다시 시작해야 합니다. 동시에 모든 Microsoft Exchange Information Store 서비스를 다시 시작해야 할 필요는 없지만 모든 Exchange 전용 모드 기능을 사용하려면 각 서버마다 해당 서버에 대한 서비스를 다시 시작해야 합니다. 전용 모드에 대한 변경 내용이 로컬 Microsoft Windows® 도메인 컨트롤러에 복제된 후에 서버에서 서비스를 다시 시작합니다.

Microsoft Exchange Information Store 서비스를 다시 시작하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 services.msc를 입력한 다음 확인을 클릭합니다.

  2. 서비스(로컬) 창에서 Microsoft Exchange Information Store 서비스를 찾습니다.

  3. 서비스를 마우스 오른쪽 단추로 클릭한 다음 다시 시작을 클릭합니다.

호스팅된 Exchange 환경에 대한 자세한 내용은 다음 문서를 참조하십시오.

  • "Information for Hosters"(http://go.microsoft.com/fwlink/?LinkId=46307)

  • Exchange Server 2000 Resource Kit(http://go.microsoft.com/fwlink/?LinkId=46326)의 "Chapter 23 - Hosted Service Environments"

혼합 모드에서 전용 모드로 전환하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 32779, "HOWTO: Exchange에서 혼합 모드에서 기본 모드로 변환"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779)을 참조하십시오.


인프라 FSMO 서버 역할이 응답하지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 도메인 명명 컨텍스트의 인프라 마스터에 대한 fSMORoleOwner 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 예를 들어 contoso.com이라는 도메인에서 인프라 마스터의 fSMORoleOwner 특성 값은 CN=Infrastructure,DC=contoso,DC=com입니다. 그런 다음 Exchange Server Analyzer는 현재 이 역할을 수행하고 있는 도메인 컨트롤러의 TCP 포트 389에 LDAP(Lightweight Directory Access Protocol) 연결을 시도합니다. Exchange Server Analyzer는 이 도메인 컨트롤러에 연결할 수 없을 경우 오류를 표시합니다.

인프라 마스터는 그룹 구성원의 이름이 바뀌거나 도메인에서 변경될 때마다 그룹-사용자 참조를 업데이트합니다. 그룹의 도메인에 대해 인프라 마스터 역할을 수행하는 도메인 컨트롤러는 사용자의 새 이름이 반영되도록 상호 도메인 그룹-사용자 참조를 업데이트합니다. 인프라 마스터는 주기적으로 도메인 계정을 검색하고 그룹의 구성원을 확인합니다. 사용자 계정이 새 도메인으로 이동되면 인프라 마스터는 사용자 계정의 새 도메인을 식별하여 그에 따라 그룹을 업데이트합니다. 이러한 참조를 로컬로 업데이트한 후에 인프라 마스터는 복제를 사용하여 도메인의 다른 모든 복제본을 업데이트합니다. 인프라 마스터를 사용할 수 없는 경우 이러한 업데이트가 지연됩니다. 각 도메인에서 인프라 마스터의 역할을 수행하는 도메인 컨트롤러는 항상 하나뿐입니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 오류에 지정된 디렉터리 서버가 온라인 상태인지, 조직의 Exchange 서버에서 액세스할 수 있는지를 확인합니다.

  2. 해당 디렉터리 서버의 역할이 해제되어 있으면 다른 도메인 컨트롤러에 인프라 마스터 역할을 할당해야 합니다.

한 도메인에서 다른 도메인으로 인프라 마스터 역할을 옮기는 데 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • Microsoft Windows Server™ 2003의 경우 324801, "HOWTO: Windows Server 2003에서 FSMO 역할을 보고 전송하기"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)를 참조하십시오.

  • Microsoft Windows 2000 Server의 경우 255690, "그래픽 사용자 인터페이스에서 FSMO 역할을 보고 전송하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)을 참조하십시오.


Exchange 조직 개체에 잘못된 버전 특성이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2007-02-28

Microsoft Exchange Server Analyzer Tool은 Exchange의 스키마 버전 정보를 확인할 때 Active Directory 디렉터리 서비스에 쿼리합니다. 특히 Exchange Server Analyzer는 rangeUpper 특성의 현재 값을 확인할 때 다음 Active Directory 개체를 검사합니다.

CN=ms-Exch-Schema-Version-Pt,CN=Schema,CN=Configuration,DC=<DN-of-forest-root-domain>

rangeUpper 값 4397은 Exchange 2000 Server가 설치되었음을 나타냅니다.

rangeUpper 값 6870은 Exchange Server 2003이 설치되었음을 나타냅니다.

rangeUpper 값 10637은 Exchange Server 2007이 설치되었음을 나타냅니다.

Exchange Server Analyzer는 rangeUpper의 값이 위 두 개의 값과 다른 경우 오류를 표시합니다.

rangeUpper 값은 ForestPrep 프로세스가 실행되는 동안 Exchange 2000 Server 또는 Exchange Server 2003에 의해 입력됩니다. 4397, 6870 또는 10637 이외의 다른 값은 보통 ForestPrep(Exchange Server 2007의 경우 PrepareDomain)을 수행하는 데 베타 버전이나 시험판 버전의 Exchange가 사용됨을 나타냅니다.

Exchange 2000 Server 또는 Exchange Server 2003의 경우, 이 문제를 해결하려면 사용자 환경에 설치되어 있는 Exchange의 정품 버전을 사용하여 ForestPrep 프로세스를 다시 실행합니다. Exchange Server 2007의 경우에는 사용자 환경에 설치되어 있는 Exchange의 정품 버전을 사용하여 PrepareSchema 프로세스를 다시 실행합니다. 단, 최소한 다음 권한이 있는 계정을 사용하여 로그인한 경우에만 ForestPrep 또는 PrepareSchema를 실행해야 합니다.

  • 엔터프라이즈 관리자

  • 스키마 관리자

  • 도메인 관리자

  • 로컬 컴퓨터 관리자(구성원 서버에서만 실행하는 경우)

Exchange 2000 Server 또는 Exchange Server 2003에서 이 오류를 해결하려면 다음을 수행하십시오.

  1. setup.exe /forestprep을 실행합니다.

  2. ForestPrep 프로세스가 성공적으로 완료되었는지 확인합니다.

Exchange Server 2007에서 이 오류를 해결하려면 다음을 수행하십시오.

  1. setup.exe /PrepareSchema를 실행합니다.

  2. PrepareSchema 프로세스가 성공적으로 완료되었는지 확인합니다.

Exchange를 설치하고 PrepareSchema 프로세스를 수행하는 방법에 대한 자세한 내용은 다음 제품 설명서를 참조하십시오.

  • "Active Directory 및 도메인을 준비하는 방법" http://go.microsoft.com/fwlink/?LinkId=78453

Exchange를 설치하고 ForestPrep 프로세스를 수행하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 312371, "HOW TO: Exchange 2000 Server에서 ForestPrep를 사용하여 포리스트 준비"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371) 이 문서 내용은 Exchange 2000 Server와 Exchange Server 2003 모두에 적용됩니다.

  • 274737, "Exchange 2000 Server 또는 Exchange Server 2003에서 ForestPrep 및 DomainPrep가 완료되었는지 확인하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=274737)

  • 828765, "Exchange Server 2003에서 구성 요소를 설치할 수 있는 사용 권한"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828765)


전용 모드 관리 그룹에 레거시 계정 정보가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 Exchange 관리 그룹 개체의 msExchLegacyAccount 특성에 데이터가 포함되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

또한 Exchange Server Analyzer는 각 관리 그룹의 msExchAdminGroupMode 특성 값을 확인할 때 Active Directory를 쿼리합니다. msExchAdminGroupMode 특성 값 0은 해당 관리 그룹이 Exchange 전용 모드에 있음을 나타냅니다. 값 1은 단순 Exchange Server 5.5 환경을 나타내고 값 2는 Exchange 혼합 모드를 나타냅니다.

Exchange Server Analyzer는 msExchLegacyAccount 특성에 데이터가 포함되어 있고 msExchAdminGroupMode 특성 값이 0일 경우 오류를 표시합니다.

Exchange 전용 모드로 전환하면 msExchLegacyAccount 특성이 삭제됩니다. 이 특성은 Exchange Server 5.5도 함께 있는 혼합 모드 Exchange 조직에서만 사용됩니다. 실제 특성 데이터가 Exchange Server 5.5 서비스 계정이고 전용 모드에 있는 Exchange 조직의 msExchLegacyAccount 특성에 존재하면 업그레이드 및 서비스 팩을 설치하는 동안 올바르게 동작하지 않습니다. 사실상 데이터가 없고 특성만 존재해도 올바르게 동작하지 않습니다. 이는 Exchange 설치 프로그램이 Exchange 조직이 혼합 모드인지 아니면 전용 모드인지를 확인할 때 이 특성을 사용하기 때문입니다. 이 특성이 있으면 Exchange 설치 프로그램은 실제로는 전용 모드에 있는 설치를 위해 혼합 모드 구성에서 실행됩니다.

ADSI(Active Directory Service Interfaces) 편집 스냅인을 사용하여 Active Directory에서 수동으로 데이터를 제거한 경우에도 msExchLegacyAccount 특성이 계속 존재할 수 있습니다.

LDP(ldp.exe) 도구로 특성을 수동으로 편집하여 msExchLegacyAccount에서 이 데이터를 제거해야 합니다. 디렉터리에서 데이터와 특성을 모두 완전히 제거하는 LDP 도구나 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용해야 합니다. ADSI 편집 스냅인은 데이터만 제거하고 특성은 남겨 두기 때문에 이 경우에는 적합하지 않습니다. LDP.exe는 Windows® 지원 도구 패키지에 포함되어 있습니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

msExchLegacyAccount 특성을 제거하려면 다음을 수행합니다.

  1. LDP.exe를 시작합니다.

  2. Connection 메뉴에서 Connect를 클릭합니다. Connect 대화 상자에서 사용자 Exchange 조직과 같은 Active Directory 포리스트에 있는 도메인 컨트롤러의 이름을 입력한 다음 OK를 클릭합니다.

  3. Connection 메뉴에서 Bind를 클릭합니다. Bind 대화 상자에서 최소한 관리 그룹 수준의 전체 Exchange 관리자 권한을 가진 자격 증명을 입력한 다음 OK를 클릭합니다.

  4. View 메뉴에서 Tree를 클릭합니다. Tree View 대화 상자에서 루트 도메인에서 연결할 경우에는 필드를 빈 채로 두고, 그렇지 않을 경우에는 CN=Configuration,DC=Domain_name, DC=Domain_suffix를 입력합니다. 여기서 Domain_name은 해당 Active Directory 포리스트의 루트 도메인이고 Domain_suffix는 com, net, org 등과 같은 도메인 접미사입니다. OK를 클릭합니다.

  5. 해당 관리 그룹을 열 때까지 LDP의 왼쪽 창에서 계층 구조 보기를 확장합니다. 이렇게 하려면 노드를 다음 순서로 두 번 클릭하면 됩니다. LDP에서 각 노드 뒤에는 전체 DN(고유 이름)이 나옵니다. 여기서는 분명하게 알 수 있도록 맨 왼쪽의 CN만 표시됩니다.

    1. DC=Domain_name

    2. CN=Configuration

    3. CN=Services

    4. CN=Microsoft Exchange

    5. CN=Organization_name

    6. CN=Administrative Groups

    7. CN=Administrative_group_name

    LDP의 세부 정보(오른쪽) 창에서 해당 관리 그룹의 특성이 나타날 때까지 아래로 스크롤합니다. msExchLegacyAccount 특성이 있을 경우 삭제해야 합니다. msExchLegacyAccount 특성이 있을 경우 msExchLegacyDomain 특성과 msExchEncryptedPassword 특성도 존재할 수 있습니다. 이 경우 이러한 특성 역시 삭제해야 합니다.

  6. LDP의 계층 구조(왼쪽) 창에서 Administrative_group_name을 마우스 오른쪽 단추로 클릭한 다음 Modify를 클릭합니다.

  7. Modify 대화 상자의 Dn 필드에 나와 있는 전체 DN에서 수정해야 할 관리 그룹을 올바르게 식별하는지 확인합니다. 전체 DN에서 CN=Administrative_group_name,CN=Administrative Groups,CN=Organization_name,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain_name을 읽어 와야 합니다.

  8. Modify 대화 상자의 Operation에서 Delete를 선택합니다. Edit Entry에서 Attribute 필드에 msExchLegacyAccount를 입력한 다음 Enter를 클릭합니다. 그러면 Entry List에 msExchLegacyAccount가 추가됩니다. Entry List는 Run을 클릭할 때 삭제될 특성을 정의합니다.

  9. msExchLegacyDomain 특성이나 msExchEncryptedPassword 특성 중 하나가 관리 그룹에 존재할 경우 8단계에 나와 있는 것처럼 Entry List에 이들 특성을 추가합니다.

  10. Entry List에 삭제해야 할 특성이 있을 경우 Run을 클릭합니다. LDP 세부 정보 창에 상태 메시지가 나타납니다.

  11. Connection 메뉴에서 New를 클릭하여 LDP 세부 정보 창을 비웁니다.

  12. CN=Administrative_group_name을 탐색하여 해당 개체를 두 번 클릭합니다. 오른쪽 창의 내용을 검토하여 해당 특성이 삭제되었는지 확인합니다.

LDP 도구를 사용하여 Active Directory를 수정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.


Exchange 조직의 legacyExchangeDN 특성이 올바르지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2007-02-01

Microsoft® Exchange Server Analyzer Tool은 Exchange 조직 개체의 legacyExchangeDN 특성 형식을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 legacyExchangeDN 특성이 올바르지 않거나 잘못된 경우 오류를 표시합니다.

이 특성 값은 /o=Organization 형식으로 되어 있습니다. 여기서 Organization는 해당 Exchange 조직의 이름입니다. 값이 /o=이나 /O= 이외의 다른 것으로 시작될 경우 잘못된 값으로 간주됩니다. 가능한 빨리 이 문제를 해결해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003의 경우 이 오류를 해결하려면 다음을 수행하십시오.

  1. Exchange Server ForestPrep 프로세스를 수행합니다. 이 프로세스 동안 설치 프로그램은 legacyExchangeDN이 잘못된 형식으로 되어 있으면 자동으로 문제를 해결합니다.

Exchange Server 2007에서 이 오류를 해결하려면 다음을 수행하십시오.

  1. Exchange Server PrepareAD 프로세스를 수행합니다. 이 프로세스 동안 설치 프로그램은 legacyExchangeDN이 잘못된 형식으로 되어 있으면 자동으로 문제를 해결합니다.

ForestPrep 프로세스에 대한 자세한 내용은 Microsoft 기술 자료 문서 312371, "HOW TO: Prepare the Forest by Using ForestPrep in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371)를 참조하십시오.

PrepareAD 프로세스에 대한 자세한 내용은 "How to Prepare Active Directory and Domains"(http://go.microsoft.com/fwlink/?LinkId=78453)를 참조하십시오.

legacyExchangeDN 특성과 특성 변경 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 324606, "XADM: Exchange 조직 또는 관리 그룹 이름을 수정하기 위해 Legacydn.exe를 사용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324606)

  • 286783, "XADM: Exchange 2000 Server에서 약속 있음/없음 데이터 업데이트 중 오류 메시지 발생"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=286783)

  • 301585, "XADM: MBconn.exe 관련 문제 해결 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301585)


레거시 도메인 정보가 전용 모드 관리 그룹에 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 Exchange 관리 그룹 개체의 msExchLegacyDomain 특성에 데이터가 포함되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

또한 Exchange Server Analyzer는 각 관리 그룹의 msExchAdminGroupMode 특성 값을 확인할 때 Active Directory를 쿼리합니다. msExchAdminGroupMode 특성 값이 0이면 관리 그룹이 Exchange 전용 모드에 있음을 나타냅니다. 값 1은 단순 Exchange Server 5.5 환경을 나타내고 값 2는 Exchange 혼합 모드를 나타냅니다.

Exchange Server Analyzer는 msExchLegacyDomain 특성에 데이터가 포함되어 있고 msExchAdminGroupMode 특성 값이 0일 경우 오류를 표시합니다.

Exchange를 전용 모드로 전환하면 msExchLegacyDomain 특성이 삭제됩니다. 이 특성은 Exchange Server 5.5도 함께 있는 혼합 모드 Exchange 조직에서만 사용됩니다. 실제 특성 데이터가 Exchange Server 5.5 서비스 계정 도메인이고 전용 모드에 있는 Exchange 조직의 msExchLegacyDomain 특성에 존재하면 업그레이드 및 서비스 팩을 설치하는 동안 올바르게 동작하지 않습니다. 실제로 특성에 데이터가 없더라도 특성이 있는 것만으로 오작동을 일으킵니다. 이것은 Exchange 설치 프로그램에서 Exchange 조직이 혼합 모드에 있는지 전용 모드에 있는지를 검색하는 방법으로 이 특성을 사용하기 때문입니다. 이 특성이 있으면 Exchange 설치 프로그램은 실제로는 전용 모드에 있는 설치를 위해 혼합 모드 구성에서 실행됩니다.

ADSI(Active Directory Service Interfaces) 편집 스냅인을 사용하여 Active Directory에서 수동으로 데이터를 제거한 경우에도 msExchLegacyDomain 특성이 계속 존재할 수 있습니다.

LDP(ldp.exe) 도구를 사용하여 특성을 수동으로 편집하여 msExchLegacyDomain에서 이 데이터를 제거해야 합니다. 디렉터리에서 데이터와 특성을 모두 완전히 제거하는 LDP 도구나 기타 LDAP(Lightweight Directory Access Protoco) 버전 3 클라이언트를 사용해야 합니다. ADSI 편집 스냅인은 데이터만 제거하고 특성은 남겨 두기 때문에 이 경우에는 적합하지 않습니다. LDP.exe는 Windows® 지원 도구 패키지에 포함되어 있습니다.

주의:
AdsiEdit, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생될 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

msExchLegacyDomain 특성을 제거하려면 다음을 수행합니다.

  1. LDP.exe를 시작합니다.

  2. 연결 메뉴에서 연결을 클릭하고 연결 대화 상자에서 Exchange 조직과 동일한 Active Directory 포리스트에 있는 도메인 컨트롤러 이름을 입력한 다음 확인을 클릭합니다.

  3. 연결 메뉴에서 바인딩을 클릭하고 바인딩 대화 상자에 관리 그룹 수준에서 최소한 Exchange 전체 관리 권한이 있는 자격 증명을 입력한 다음 확인을 클릭합니다.

  4. 보기 메뉴에서 트리를 클릭하고 트리 보기 대화 상자에서 루트 도메인에서 연결할 경우에는 필드를 빈 채로 두고, 그렇지 않을 경우에는 CN=Configuration,DC=Domain_name, DC=Domain_suffix를 입력합니다. 여기서 Domain_name은 해당 Active Directory 포리스트의 루트 도메인이고 Domain_suffix는 com, net, org 등과 같은 도메인 접미사입니다. 확인을 클릭합니다.

  5. 관리 그룹을 열 때까지 LDP의 왼쪽 창에서 계층 구조 보기를 확장합니다. 이렇게 하려면 노드를 다음 순서로 두 번 클릭하면 됩니다. LDP에서 각 노드 뒤에는 전체 DN(고유 이름)이 나옵니다. 여기서는 분명하게 알 수 있도록 맨 왼쪽의 CN만 표시됩니다.

    • DC=Domain_name

    • CN=Configuration

    • CN=Services

    • CN=Microsoft Exchange

    • CN=Organization_name

    • CN=Administrative Groups

    • CN=Administrative_group_name

    LDP의 세부 정보(오른쪽) 창에서 스크롤하여 관리 그룹의 특성을 봅니다. msExchLegacyDomain 특성이 있으면 삭제해야 합니다. msExchLegacyDomain 특성이 있으면 msExchLegacyDomain 및 msExchEncryptedPassword 특성도 있습니다. 이 경우 이러한 특성 역시 삭제해야 합니다.

  6. LDP의 계층 구조(왼쪽) 창에서 Administrative_group_name을 마우스 오른쪽 단추로 클릭한 다음 수정을 클릭합니다.

  7. 수정 대화 상자의 Dn 필드에 나와 있는 전체 DN에서 수정해야 할 관리 그룹을 올바르게 식별하는지 확인합니다. 전체 DN에서 CN=Administrative_group_name,CN=Administrative Groups,CN=Organization_name,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain_name을 읽어 와야 합니다.

  8. 수정 대화 상자의 작업에서 삭제를 선택하고, 항목 편집의 특성 필드에 msExchLegacyAccount를 입력한 다음 Enter 키를 클릭합니다. 이렇게 하면 msExchLegacyAccount가 항목 목록에 추가됩니다. 항목 목록은 실행을 클릭하면 삭제될 특성을 정의합니다.

  9. msExchLegacyAccount 또는 msExchEncryptedPassword 특성 중 하나가 관리 그룹에 존재할 경우 8단계에 나와 있는 것처럼 항목 목록에 이들 특성을 추가합니다.

  10. 항목 목록에 삭제해야 하는 특성이 들어 있는 경우 실행을 클릭합니다. LDP 세부 정보 창에 상태 메시지가 표시됩니다.

  11. 연결 메뉴에서 새로 만들기를 클릭하여 LDP 세부 정보 창을 지웁니다.

  12. CN=Administrative_group_name을 탐색하고 개체를 두 번 클릭합니다. 오른쪽 창의 내용을 검토하여 특성이 삭제되었는지 확인합니다.

LDP 도구를 사용하여 Active Directory를 수정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.


관리 그룹의 LegacyExchangeDN이 상위 조직과 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-11-30

Microsoft® Exchange Server Analyzer Tool은 관리 그룹 컨테이너 개체의 legacyExchangeDN 특성 형식을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange 조직의 legacyExchangeDN과 일치하지 않는 관리 그룹의 legacyExchangeDN 특성이 있으면 오류를 표시합니다.

Exchange에서는 legacyExchangeDN 값을 사용하여 Active Directory의 Exchange 개체를 식별합니다. legacyExchangeDN 값은 개체가 Exchange 조직의 어디에 적합한지를 나타내는 고유 이름입니다. 예를 들면 다음과 같습니다.

/o= organization /ou= administrative group

서버 및 폴더 계층 구조와 같은 개체는 관리 그룹에서 해당 legacyExchangeDN 값의 일부를 상속합니다. 따라서 관리 그룹 값에 문제가 있을 경우 다른 많은 개체가 동일한 문제를 상속할 수 있습니다.

일반적으로 legacyExchangeDN 문제는 관리자가 값을 직접 수정하려고 하는 경우에 발생합니다. ADSI(Active Directory Service Interfaces) 편집 스냅인, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 도구를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 해결하려면 다음을 수행하십시오.

  1. ADSI 편집과 같은 Active Directory 편집기를 사용하여 Active Directory에서 관리 그룹을 찾습니다.

    legacyExchangeDN 특성은 다음 위치에 있습니다.

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN= Administrative group

  2. 다음 형식으로 새 문자열 값을 입력합니다.

    /o= organization /ou= administrative group

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 2003 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


이 관리 그룹의 legacyExchangeDN이 잘못되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 관리 그룹의 legacyExchangeDN 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. legacyExchangeDN 값에 지정된 조직이나 관리 그룹 이름이 실제 이름과 일치하지 않거나 일부 값이 없는 경우 이 오류가 표시됩니다.

Exchange에서는 legacyExchangeDN 값을 사용하여 Active Directory의 Exchange 개체를 식별합니다. legacyExchangeDN 값은 개체가 Exchange 조직의 어디에 적합한지를 나타내는 고유 이름입니다. 예를 들면 다음과 같습니다.

/o=organization/ou=administrative group

서버 및 폴더 계층 구조와 같은 개체는 관리 그룹에서 해당 legacyExchangeDN 값의 일부를 상속합니다. 따라서 관리 그룹 값에 문제가 있을 경우 다른 많은 개체가 동일한 문제를 상속할 수 있습니다.

일반적으로 legacyExchangeDN 관련 문제는 관리자가 이 값을 직접 수정하려고 할 때 발생합니다. ADSI(Active Directory Service Interfaces) 편집 스냅인, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 도구를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. 이러한 Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 사용하여 Active Directory에서 관리 그룹 찾습니다.

    legacyExchangeDN 특성은 다음 위치에 있습니다.

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN=Administrative group

  2. 다음 형식으로 새 문자열 값을 입력합니다.

    /o=organization/ou=administrative group

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 2003 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


메일 사용이 가능하고 유니버설이 아닌 그룹이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 환경의 도메인 수를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 포리스트에서 분리된 여러 개의 Active Directory 도메인을 찾으면 각 도메인을 쿼리하여 해당 도메인에 메일 사용이 가능하고 유니버설이 아닌 그룹이 하나 이상 있는지 확인합니다.

Exchange Server Analyzer는 여러 도메인이 있는 포리스트에 메일 사용이 가능하고 유니버설이 아닌 그룹이 있음을 확인하면 경고를 표시합니다.

여러 도메인이 있는 포리스트에서 도메인 로컬 또는 글로벌 메일 그룹을 사용할 경우 다음 이유로 전자 메일 배달 문제가 발생할 수 있습니다.

  • 메일 그룹을 각 받는 사람으로 확장하기 위해 Exchange가 글로벌 카탈로그 서버에 연결합니다.

  • 글로벌 카탈로그 서버에 각 도메인에 속한 모든 유형의 그룹 목록이 있어도 원격 도메인에서 만들어진 도메인 로컬 및 글로벌 그룹의 구성원 목록은 포함되지 않습니다.

  • 메시지를 글로벌 메일 그룹에 보내지만 홈이 아닌 도메인에서 확장하면 Exchange는 그룹 구성원에게 메시지를 제대로 배달할 수 없습니다.

  • 분류기는 메일 그룹을 확장할 수 없으므로 사용자가 여러 도메인이 있는 포리스트의 글로벌 메일 그룹 또는 메일 사용이 가능한 보안 그룹에 메시지를 보내면 글로벌 메일 그룹의 사용자는 메시지를 받을 수 없습니다.

  • 분류기로 전송된 항목이 추적 로그의 마지막 항목이 됩니다. 메시지를 보낸 사람은 배달 못 함 보고서(NDR)를 받지 않습니다.

이 문제를 해결하고 전자 메일 배달을 확인하려면 여러 도메인이 있는 환경에서 유니버설 메일 그룹을 사용합니다. 유니버설 메일 그룹의 구성원은 각 도메인의 각 글로벌 카탈로그 서버로 복제됩니다.

특히 이 문제와 일반적인 유니버설 메일 그룹에 대한 자세한 내용은 다음 항목을 참조하십시오.

  • Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "다중 도메인 환경에서 메일 사용 가능 그룹 사용"

  • Active Directory(http://go.microsoft.com/fwlink/?LinkId=51276)에서 "Understanding Groups"의 "Group scope" 섹션

  • Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "쿼리 기반 메일 그룹 작성 지침"

또한 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 271930, "XADM: Message Delivery to Global Groups Does Not Work"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=271930)

  • 283051, "XCON: E-Mail Sent to Mail-Enabled Global Group May Disappear"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=283051)

  • 231273, "Group Type and Scope Usage in Windows"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231273)


사서함 사용 가능 사용자 시스템 정책을 변경해야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-08-10

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 각 Exchange 시스템 정책 개체의 purportedSearch 특성 값을 확인합니다. purportedSearch 특성은 정책이 적용될 때 사용되는 검색 인수를 나타냅니다.

또한 Exchange Server Analyzer는 Active Directory를 쿼리하여 Active Directory에 있는 포리스트 개체의 msDS-Behavior-Version 특성 값, 즉 NTDS 설정을 확인합니다. 이 값은 Active Directory 포리스트 기능 수준을 나타냅니다. msDS-Behavior-Version 특성에 유효한 값은 다음 표에 표시되어 있습니다.

값 | 포리스트 기능 수준
0 | Microsoft Windows® 2000 Server 혼합
1 | Microsoft Windows Server™ 2003 임시
2 | Microsoft Windows Server 2003 전용

뿐만 아니라 Exchange Server Analyzer는 Active Directory를 쿼리하여 Windows 2003 업데이트 컨테이너의 revision 특성 값을 확인합니다. 이 특성 값은 Active Directory 준비 유틸리티(ADPrep.exe)가 실행되었는지 여부를 나타냅니다.

마지막으로 Exchange Server Analyzer는 Win32_OperatingSystem Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리하여 OSProductSuite 키 값을 확인합니다. OSProductSuite 키 값은 컴퓨터에서 실행되고 있는 Windows의 버전을 나타냅니다.

Exchange Server Analyzer에서 다음 조건에 해당하면 경고를 표시합니다.

  • 사서함 사용 가능 사용자 시스템 정책의 purportedSearch 특성 값이 (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))와 다릅니다.

  • Active Directory 포리스트 기능 수준은 Windows Server 2003 임시 또는 Windows Server 2003 전용 모드입니다.

  • Exchange Server 컴퓨터가 Windows Small Business Server 2003을 실행하고 있지 않습니다.

사서함 상주 문제를 방지하려면 시스템 정책을 수정해야 합니다. 이 업데이트는 ADSI(Active Directory Service Interfaces) 편집(ADSIEdit.msc), LDP(ldp.exe) 도구 또는 기타 Active Directory 편집기 도구를 사용하여 수행할 수 있습니다.

Windows Server 2003이 도메인 컨트롤러로 사용되고 사서함 사용 가능 사용자 정책이 업데이트되지 않으면 Windows Server 2003의 연결된 값 복제로 인해 받는 사람 업데이트 서비스가 새 사용자의 homeMDB 특성 값이 서버의 처음 저장소에 상주하도록 덮어씁니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제가 발생하면 Windows Server 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 오류를 해결하려면 다음을 수행하십시오.

  1. ADSI 편집을 시작합니다.

  2. Configuration 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=<ExchangeOrganizationName>을 차례로 확장합니다.

  3. CN=System 정책을 선택합니다.

  4. 오른쪽 창에서 CN=Mailbox Enable User를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  5. 아래로 스크롤하여 purportedSearch 특성을 선택하고 편집을 클릭합니다.

  6. 특성을 지우고 다음 필터를 사용하여 구성합니다.

    (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

    참고:
    6단계에서 표시된 필터는 읽기 쉽도록 줄바꿈되었습니다. 반드시 공백이나 리턴없이 필터를 입력합니다.

  7. 확인을 다시 클릭하여 변경 내용을 저장하고 ADSI 편집을 닫습니다.

LDP 도구를 사용하여 Active Directory를 수정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: LDP 유틸리티를 사용하여 Active Directory 개체 특성 수정"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)을 참조하십시오.

이 문제와 그 영향에 대한 자세한 내용은 Microsoft 기술 자료 문서 903291 "Recipient Update Service may overwrite the value of the homeMDB attribute for new Exchange Server 2003 users"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=903291)를 참조하십시오.


글로벌 카탈로그에서 MAPI 인터페이스를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키를 읽어 해당 레지스트리 키가 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

Exchange Server Analyzer는 Initialize MAPI interface 키가 있으며 숫자 값을 갖도록 구성되어 있는 경우 오류를 표시합니다.

Initialize MAPI interface 레지스트리 키가 있으면 Microsoft Office Outlook® 클라이언트에서 이 서버의 주소록에 연결할 수 없습니다. 이 문제를 해결하려면 Initialize MAPI interface 레지스트리 키를 제거해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface를 탐색합니다.

  3. Initialize MAPI interface 키를 마우스 오른쪽 단추로 클릭한 다음 삭제를 선택합니다.

  4. 레지스트리 편집기를 닫고 Exchange 서버를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Initialize MAPI interface 레지스트리 키에 대한 자세한 내용은 Microsoft 기술 자료 문서 275127, "XADM: Exchange Server 5.5를 도메인 컨트롤러나 글로벌 카탈로그에서 실행하도록 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=275127)을 참조하십시오.


MaxActiveQueries가 수정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 동시에 처리할 수 있는 LDAP(Lightweight Directory Access Protocol) 쿼리의 최대 수를 확인하기 위해 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 값은 현재의 LDAP 관리 정책을 검토하여 확인할 수 있습니다. 특히 Exchange Server Analyzer는 MaxActiveQueries가 있는지 확인합니다. Exchange Server Analyzer는 MaxActiveQueries 가 존재하며 20 이외의 값으로 구성되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

LDAP 관리 제한은 Active Directory 작동 능력과 성능의 균형을 조정합니다. 이러한 제한으로 인해 특정 작업이 서버의 성능을 저하시키는 경우를 방지할 수 있습니다. 이 설정값을 기본값보다 크게 지정하면 Active Directory 인프라에 좋지 않은 영향을 줄 수 있습니다.

LDAPAdminLimits 특성의 MaxActiveQueries 값은 기본 쿼리 정책에 대한 동시 LDAP 쿼리의 최대 수를 제어합니다. 기본적으로 활성 쿼리 수는 20개로 제한됩니다. 이 제한에 도달하면 Active Directory는 "LDAP_ADMIN_LIMIT_EXCEEDED"를 반환하며 추가 LDAP 쿼리를 처리하지 않습니다.

Ntdsutil.exe를 시작하려면 다음을 수행합니다.

  1. 시작을 클릭한 다음 실행을 클릭합니다.

  2. 열기 텍스트 상자에서 ntdsutil을 입력한 후 Enter 키를 누릅니다. 언제든지 도움말을 보려면 명령 프롬프트에서 ?를 입력합니다.

정책 설정을 보려면 다음을 수행합니다.

  1. Ntdsutil.exe 명령 프롬프트에서 LDAP policies를 입력한 후 Enter 키를 누릅니다.

  2. LDAP 정책 명령 프롬프트에서 connections를 입력한 후 Enter 키를 누릅니다.

  3. 서버 연결 명령 프롬프트에서 connect to server 서버의 DNS 이름을 입력한 후 Enter 키를 누릅니다. 현재 작업 중인 서버에 연결하려고 합니다.

  4. 서버 연결 명령 프롬프트에서 q를 입력한 후 Enter 키를 눌러 이전 메뉴로 돌아갑니다.

  5. LDAP 정책 명령 프롬프트에서 Show Values를 입력한 후 Enter 키를 누릅니다.

    정책이 있는 그대로 표시됩니다.
참고:
이 절차는 기본 도메인 정책 설정만 보여 줍니다. 사용자가 직접 적용한 정책 설정은 표시되지 않습니다.

정책 설정을 변경하려면 다음을 수행합니다.

  1. Ntdsutil.exe 명령 프롬프트에서 LDAP policies를 입력한 후 Enter 키를 누릅니다.

  2. LDAP 정책 명령 프롬프트에서 Set MaxActiveQueries to 20을 입력한 다음 Enter 키를 누릅니다.

    Show Values 명령을 사용하여 변경 내용을 확인할 수 있습니다.

  3. 변경 내용을 저장하려면 Commit Changes를 사용합니다.

  4. 작업이 끝나면 q를 입력한 후 Enter 키를 누릅니다.

  5. Ntdsutil.exe를 끝내려면 명령 프롬프트에서 q를 입력한 후 Enter 키를 누릅니다.

LDAP 정책 구성에 대한 자세한 내용은 Microsoft 기술 자료 315071, "How to view and set lightweight directory access protocol policies by using Ntdsutil.exe in Windows 2000"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071)을 참조하십시오.


MaxPageSize 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스의 Query-Ploicies 컨테이너에서 기본 쿼리 정책 개체의 특성을 확인하여 도메인 컨트롤러의 LDAP(Lightweight Directory Access Protocol) 구성을 확인합니다. Exchange Server Analyzer는 LDAPAdminLimits 특성의 MaxPageSize 값이 기본값 1,000이 아닌 다른 값으로 변경된 경우 기본 구성이 아니라는 메시지를 표시합니다.

LDAP 관리 제한은 Active Directory의 작동 능력과 성능의 균형을 조정합니다. 이러한 제한은 특정 작업이 서버의 성능에 악영향을 주지 않도록 하고 서버가 DoS(Denail-of-Service) 공격을 받아도 회복할 수 있도록 합니다. 이 설정을 기본값 이상으로 증가시키면 Active Directory 인프라에 악영향을 줄 수 있습니다.

LDAP 정책은 queryPolicy 클래스의 개체를 사용하여 구현됩니다. 쿼리 정책 개체는 구성 명명 컨텍스트에서 Directory Service 컨테이너의 하위 항목인 Query-Policies 컨테이너에 만들어질 수 있습니다.

LDAPAdminLimits 특성의 MaxPageSize 값은 LDAP 쿼리에 대해 반환될 수 있는 레코드 수를 제어합니다. 기본값은 1,000 레코드입니다. 반환되는 항목이 1,000개가 넘으면 Active Directory는 이 최대값을 확인하고 아무것도 반환하지 않습니다.

이 제한은 지원 가능한 몇 가지 Active Directory 개체 유형의 수를 제어합니다. 예를 들어 조직마다 최대 1,000개의 서버, 최대 1,000개의 관리 그룹 및 최대 1,000개의 주소 목록을 가질 수 있고 관리 그룹마다 최대 1,000개의 라우팅 그룹을 가질 수 있으며 라우팅 그룹마다 최대 1,000개의 커넥터를 가질 수 있습니다.

Microsoft 기술 지원 서비스에서 다른 값을 사용하라는 지시가 없으면 이 값을 다시 1,000으로 설정해야 합니다.

Ntdsutil.exe를 시작하려면 다음을 수행합니다.

  1. 시작을 클릭한 다음 실행을 클릭합니다.

  2. 열기 텍스트 상자에 ntdsutil을 입력한 다음 Enter 키를 누릅니다. 언제든지 도움말을 보려면 명령 프롬프트에서 ?를 입력합니다.

정책 설정을 보려면 다음을 수행합니다.

  1. Ntdsutil.exe 명령 프롬프트에서 LDAP policies를 입력한 다음 Enter 키를 누릅니다.

  2. LDAP 정책 명령 프롬프트에서 connections를 입력한 다음 Enter 키를 누릅니다.

  3. 서버 연결 명령 프롬프트에서 connect to server DNS name of server를 입력한 다음 Enter 키를 누릅니다. 현재 작업하고 있는 서버에 연결하려고 합니다.

  4. 서버 연결 명령 프롬프트에서 q를 입력한 다음 Enter 키를 눌러 이전 메뉴로 돌아깁니다.

  5. LDAP 정책 명령 프롬프트에서 Show Values를 입력한 다음 Enter 키를 누릅니다.

    정책이 있는 그대로 표시됩니다.

    참고:
    이 절차는 기본 도메인 정책 설정만 보여 줍니다. 자체 정책 설정을 적용할 경우에는 해당 설정이 표시되지 않습니다.

정책 설정을 변경하려면 다음을 수행합니다.

  1. Ntdsutil.exe 명령 프롬프트에서 LDAP policies를 입력한 다음 Enter 키를 누릅니다.

  2. LDAP 정책 명령 프롬프트에서 Set MaxPageSize to 1000을 입력한 다음 Enter 키를 누릅니다.

    Show Values 명령을 사용하여 변경 내용을 확인할 수 있습니다.

  3. 변경 내용을 저장하려면 Commit Changes를 사용합니다.

  4. 마치면 q를 입력한 다음 Enter 키를 누릅니다.

  5. Ntdsutil.exe를 끝내려면 명령 프롬프트에서 q를 입력한 다음 Enter 키를 누릅니다.

LDAP 정책 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 315071, "How to view and set lightweight directory access protocol policies by using Ntdsutil.exe in Windows 2000"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071)을 참조하십시오.


MaxPageSize가 너무 높게 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Query-Policies 컨테이너에 있는 기본 쿼리 정책 개체의 LDAPAdminLimits 특성에 대한 MaxPageSize 값 설정을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 MaxPageSize 값이 2,500보다 크면 오류를 표시합니다.

LDAP(Lightweight Directory Access Protocol) 관리는 Active Directory 작동 능력과 성능의 균형을 조정합니다. 이러한 제한으로 인해 특정 작업이 서버의 성능을 저하시키는 경우를 방지할 수 있습니다. 이 제한은 서버가 DoS(Denail-of-Service) 공격을 받아도 회복할 수 있도록 합니다. 이 설정을 기본값 이상으로 증가시키면 Active Directory 인프라에 악영향을 줄 수 있습니다.

LDAP 정책은 queryPolicy 클래스의 개체를 사용하여 구현됩니다. 쿼리 정책 개체는 구성 명명 컨텍스트에서 Directory Service 컨테이너의 하위 항목인 Query-Policies 컨테이너에 만들어질 수 있습니다.

LDAPAdminLimits 특성의 MaxPageSize 값은 LDAP 쿼리에 대해 반환될 수 있는 레코드 수를 제어합니다. 기본 수는 1,000 레코드입니다. 반환되는 항목이 1,000개가 넘으면 Active Directory는 이 최대값을 확인하고 아무것도 반환하지 않습니다.

이 제한은 지원 가능한 몇 가지 Active Directory 개체 유형의 수를 제어합니다. 예를 들어 각 조직은 최대 1,000개의 서버, 최대 1,000개의 관리 그룹, 최대 1,000개의 주소 목록을 가질 수 있습니다. 각 관리 그룹은 최대 1,000개의 라우팅 그룹을 가지고 각 라우팅 그룹은 최대 1,000개의 커넥터를 가질 수 있습니다.

Microsoft 기술 지원 서비스에서 다른 값을 사용하라는 지시가 없으면 이 값을 다시 1,000으로 설정해야 합니다.

Ntdsutil.exe를 시작하려면 다음을 수행합니다.

  1. 시작을 클릭한 다음 실행을 클릭합니다.

  2. 열기 텍스트 상자에 ntdsutil을 입력한 다음 Enter 키를 누릅니다. 언제든지 도움말을 보려면 명령 프롬프트에서 ?를 입력합니다.
정책 설정을 보려면 다음을 수행합니다.

  1. Ntdsutil.exe 명령 프롬프트에서 LDAP policies를 입력한 다음 Enter 키를 누릅니다.

  2. LDAP 정책 명령 프롬프트에서 connections를 입력한 다음 Enter 키를 누릅니다.

  3. 서버 연결 명령 프롬프트에서 connect to server <DNS name of server>을 입력한 후 Enter 키를 누릅니다. 현재 작업 중인 서버에 연결합니다.

  4. 서버 연결 명령 프롬프트에서 q를 입력한 후 Enter 키를 눌러 이전 메뉴로 돌아갑니다.

  5. LDAP 정책 명령 프롬프트에서 Show Values를 입력한 다음 Enter 키를 누릅니다.

    정책이 있는 그대로 표시됩니다.

    참고:
    이 절차는 기본 도메인 정책 설정만 보여 줍니다. 사용자가 직접 적용한 정책 설정은 표시되지 않습니다.
정책 설정을 변경하려면 다음을 수행합니다.

  1. Ntdsutil.exe 명령 프롬프트에서 LDAP policies를 입력한 다음 Enter 키를 누릅니다.

  2. LDAP 정책 명령 프롬프트에서 Set MaxPageSize to 1000을 입력한 다음 Enter 키를 누릅니다.

    Show Values 명령을 사용하여 변경 내용을 확인할 수 있습니다.

  3. 변경 내용을 저장하려면 Commit Changes를 사용합니다.

  4. 마치면 q를 입력한 다음 Enter 키를 누릅니다.

  5. Ntdsutil.exe를 끝내려면 명령 프롬프트에서 q를 입력한 후 Enter 키를 누릅니다.

LDAP 정책 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 315071, "How to view and set LDAP policy in Active Directory by using Ntdsutil.exe"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071)를 참조하십시오.


주소 목록이 800개를 초과합니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory에서 모든 주소 목록 그룹의 주소 목록 수를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 Exchange Server 조직에 주소 목록이 800개보다 많으면 경고를 표시합니다.

받는 사람 업데이트 서비스 작업 동안 심각한 대기 시간을 방지하려면 모든 주소 목록 그룹의 주소 목록 수를 800개 미만으로 줄이는 것이 좋습니다. Exchange Server 조직의 주소 목록이 800개를 초과하면 받는 사람 업데이트 서비스가 메일 사용 가능 개체를 스탬프 처리하므로 심각한 대기 시간이 발생합니다.

또는 받는 사람 업데이트 서비스를 사용할 수 없게 설정하고 스크립트를 사용하여 받는 사람 업데이트 서비스가 수행하는 작업을 처리할 수 있습니다.

받는 사람 업데이트 서비스를 사용할 수 없게 설정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서, "Requirements for Disabling the Recipient Update Service"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479)를 참조하십시오.

주소 목록 및 받는 사람 업데이트 서비스에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "받는 사람 및 받는 사람 정채 관리"를 참조하십시오.


전체 주소 목록이 800개를 초과합니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory의 모든 전체 주소 목록의 주소 목록 수가 800개보다 많은지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 Exchange Server 조직에 전체 주소 목록이 800개보다 많으면 경고를 표시합니다.

모든 전체 주소 목록 그룹의 주소 목록 수를 800개보다 작게 줄여서 받는 사람 업데이트 서비스가 작동하는 동안의 심각한 대기 시간을 방지하는 것이 좋습니다. Exchange Server 조직에 전체 주소 목록이 800개보다 많으면 받는 사람 업데이트 서비스가 메일 사용 가능 개체로 스탬프 처리하므로 심각한 대기 시간을 발생시킵니다.

또는 받는 사람 업데이트 서비스를 사용할 수 없게 설정하고 스크립트를 사용하여 받는 사람 업데이트 서비스가 수행하는 작업을 처리할 수 있습니다.

받는 사람 업데이트 서비스를 사용할 수 없게 설정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 296479, "Requirements for Disabling the Recipient Update Service"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479)를 참조하십시오.

주소 목록 및 받는 사람 업데이트 서비스에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "받는 사람 및 받는 사람 정책 관리"를 참조하십시오.


msExchHomeMDB 특성이 인덱싱되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory의 인덱싱에 대해 라우팅 그룹 백링크 특성이 구성되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 특히 Exchange Server Analyzer는 Active Directory의 사서함 사용 가능 개체의 특성인 msExchHomeMDB 특성의 현재 인덱싱 값을 확인하기 위해 Active Directory를 쿼리합니다. 기본적으로 이 특성은 인덱싱되지 않습니다. Exchange Server Analyzer는 이 특성이 인덱싱되도록 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

msExchHomeMDB 특성을 인덱싱하는 경우 나타나는 효과는 거의 없습니다. 메모리에 인덱스가 유지되기 때문에 글로벌 카탈로그 서버에 사용되는 메모리 양이 약간 증가합니다.

조직이 다음 사항에 해당하는 경우 이 특성을 인덱싱하는 것이 좋습니다.

  • 메일을 사용하는 개체가 많습니다. 100,000개 이상의 메일 사용 개체가 있는 대규모 환경에서 이 특성을 인덱싱하면 Exchange System Manager의 성능과 Active Directory 사용자 및 컴퓨터를 통해 수행되는 Exchange 작업의 성능을 향상시킬 수 있습니다.

  • 중대 규모의 환경에서 ExMerge(Exchange Mailbox Merge Program)를 자주 사용하는 경우 때때로 msExchHomeMDB 특성을 인덱싱할 필요가 있는 것으로 나타났습니다. msExchHomeMDB 특성을 인덱싱하면 ExMerge의 속도와 성능이 향상됩니다.

이외의 경우에는 이 특성을 인덱싱하지 않도록 설정을 기본값으로 다시 변경하는 것이 좋습니다.

이 오류를 수정하려면 다음을 수행합니다.

  • Exchange Server Analyzer에서 생성된 메시지는 정보 제공만을 위한 것이므로 특별히 필요한 작업은 없습니다.


msExchRoutingGroupMembersBL 특성이 인덱싱되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory의 인덱싱을 위해 Routing Group Back-Link 특성이 구성되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 특히 msExchRoutingGroupMembersBL 특성의 현재 인덱싱 값을 확인하기 위해 다음 Active Directory 개체를 검토합니다.

CN=Configuration,DC=domain,DC=com, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Routing Groups, CN=RoutingGroupName

기본적으로 이 특성은 인덱싱되지 않습니다. Exchange Server Analyzer는 이 특성이 인덱싱되도록 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange의 분산 배포 또는 지점 배포 시에 많은 수의 라우팅 그룹이 포함되어 있는 경우 이 특성을 인덱싱되지 않도록 구성하면 성능이 저하될 수 있습니다. 예를 들어 Exchange 조직에 수백 개의 라우팅 그룹이 있으면 15분마다 하나 이상의 글로벌 카탈로그에서 작업이 늘어나는 것을 볼 수 있습니다. 이렇게 작업이 늘어나는 것은 Exchange의 DSAccess 구성 요소가 라우팅 그룹 구성을 다시 읽기 때문입니다. 심각한 경우 이 작업에 글로벌 카탈로그가 모두 소모될 수도 있습니다.

Routing Group Back-Link 특성을 인덱싱하여 이러한 글로벌 카탈로그의 로드를 최소화함으로써 DSAccess가 라우팅 그룹 정보를 읽는 데 소요되는 시간과 이 작업으로 인해 글로벌 카탈로그에 부과되는 로드를 줄일 수 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  • Exchange Server Analyzer에서 생성된 메시지는 정보 제공만을 위한 것이므로 특별히 필요한 작업은 없습니다.

최상의 성능을 얻을 수 있도록 Exchange를 조정하는 방법에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?linkid=47576)를 참조하십시오.


여러 개의 공용 폴더 계층 구조가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 msExchPFTreeType 특성에 대한 값이 1인 공용 폴더 계층 구조 수를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msExchPFTreeType 특성의 값이 1이면 공용 폴더 계층 구조가 MAPI 클라이언트용으로 지정된 공용 폴더 계층 구조임을 의미합니다. Exchange Server Analyzer는 Exchange 조직에서 둘 이상의 공용 폴더 계층 구조의 msExchPFTreeType 특성 값이 1인 경우 오류를 표시합니다.

이 오류는 Exchange 조직에 MAPI 클라이언트용 공용 폴더 계층 구조가 하나 이상 있음을 의미합니다. MAPI 클라이언트용 공용 폴더 계층 구조가 여러 개인 경우 문제가 발생할 수 있습니다.

이 문제를 해결하기 위해 Active Directory 편집 도구를 사용하여 MAPI 공용 폴더 계층 구조를 제외하고 모든 공용 폴더 계층 구조의 msExchPFTreeType 특성 값을 0으로 설정할 수 있습니다. 필요한 경우 MAPI 클라이언트용 기본 공용 폴더 저장소로서 MAPI 공용 폴더 계층 구조를 가리키도록 Exchange 서버의 사서함 저장소를 다시 구성합니다.

다음 도구는 Active Directory 편집 도구입니다.

  • ADSI(Active Directory Service Interfaces) 편집(AdsiEdit.msc)

  • LDP(ldp.exe) 도구

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 오류를 수정하려면 다음을 수행합니다.

  1. Active Directory 편집 도구를 사용하여 Active Directory의 공용 폴더 개체를 찾습니다. 공용 폴더 개체는 CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies에 있습니다.

  2. 0을 새 값으로 입력하여 MAPI 공용 폴더 계층 구조를 제외하고 모든 공용 폴더 계층 구조 개체의 msExchPFTreeType 특성을 변경합니다.

  3. Active Directory 편집기를 닫습니다.

  4. Exchange System Manager를 엽니다.

  5. 각 사서함 저장소의 속성에 액세스하려면 관리 그룹을 클릭하고 사용자의 관리 그룹, 서버, 사용자의 서버 및 저장소 그룹을 차례로 확장합니다. 그런 다음 변경하려는 특성이 있는 사서함 저장소를 클릭하고 특성을 선택합니다.

  6. 일반 탭의 기본 공용 저장소 필드에서 찾아보기를 클릭합니다.

  7. MAPI 공용 폴더 계층 구조를 선택한 다음 확인을 두 번 클릭하여 변경 내용을 저장합니다.

  8. 각 사서함 저장소마다 5-7단계를 반복합니다.

LDP 도구를 사용하여 Active Directory를 수정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

MAPI 및 응용 프로그램의 공용 폴더 계층 구조에 대한 자세한 내용은 다음 리소스를 참조하십시오.

  • Microsoft 기술 자료 문서 258509, "Description of public folder tree types in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • Exchange 팀 블로그 항목, "How mail-enabled Public Folders work"(http://go.microsoft.com/fwlink/?LinkId=41913)


'NeverPing' 매개 변수 권장
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-03-16

Microsoft® Exchange Server Analyzer Tool은 각 도메인에 설정된 트러스트 수를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 각 도메인에 있는 하나 이상의 도메인 컨트롤러에 NeverPing 값이 설정되어 있는 경우 이 도구는 유용한 정보 메시지를 표시합니다.

Exchange Server 2003 환경의 각 도메인이 다음 조건에 일치할 경우 Exchange Server Analyzer는 경고를 표시합니다.

  • 도메인에 트러스트가 50개 이상 설정되어 있습니다.

  • 도메인의 도메인 컨트롤러에 null(0)로 설정된 NeverPing 레지스트리 하위 키 값이 있습니다.

이 경고는 LSASS.exe 프로세스 또는 사용자를 도메인에 인증하는 프로세스가 지연될 수 있음을 나타냅니다. LSASS(Local Security Authority Subsystem Service)는 Windows 기반 컴퓨터나 서버에 로그온한 사용자를 확인하는 Microsoft Windows 운영 체제의 프로세스입니다.

이 문제를 해결하려면 다음과 같이 도메인 컨트롤러에 대한 NeverPing 레지스트리 하위 키 값을 1로 설정합니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 문제 발생 시 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
Exchange 2003 환경에서 도메인 컨트롤러에 대한 NeverPing 매개 변수를 설정하려면 다음을 수행합니다.

  1. 시작, 실행을 차례로 클릭하고 Regedit를 입력한 다음 확인을 클릭합니다.

  2. 레지스트리 하위 키 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters를 찾습니다.

  3. 이 하위 키를 마우스 오른쪽 단추로 클릭하고 새로 만들기, DWORD 값을 차례로 가리킨 다음 NeverPing을 입력하고 Enter 키를 누릅니다.

  4. NeverPing을 마우스 오른쪽 단추로 클릭하고 수정을 클릭한 다음 값 데이터 상자에 1을 입력하고 확인을 클릭합니다.

  5. 레지스트리 편집기를 종료합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

이 문제에 대한 자세한 내용을 보고 도메인 컨트롤러에 대한 NeverPing 매개 변수 값을 설정하려면 Microsoft 기술 자료 문서 825107, "The Lsass.exe process may stop responding if you have many external trusts on a Windows 2000 Server-based domain controller"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=825107)를 참조하십시오.

참고:
이 문서에서 Microsoft Windows 2000 Server를 설명하지만 해당 정보는 Windows Server™ 2003에도 적용됩니다. 이 문서에서 설명한 업데이트는 Windows Server 2003에 필요하지 않습니다.


새 버전의 Active Directory Connector를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 각 연결 동의(CA) 개체의 versionNumber 특성 값을 확인합니다. versionNumber 특성은 해당 컴퓨터에서 실행 중인 ADC(Active Directory Connector)의 버전을 나타냅니다.

또한 Exchange Server Analyzer Tool은 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 ADC(Active Directory Connector) 파일인 Adc.exe의 Version 키 값을 확인합니다. Version WMI 키는 이 파일의 빌드 번호를 나타냅니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고를 표시합니다.

  • 연결 동의(CA) 개체의 versionNumber 특성이 16973842로 설정되어 있습니다.

  • 연결 동의(CA) 개체의 versionNumber 특성이 16973843으로 설정되어 있고 Adc.exe의 Version 키 값이 7250.0보다 작습니다.

값이 16973842이면 컴퓨터에 Exchange Server 2003 CD에서 제공된 원래 버전의 ADC가 실행되고 있음을 나타내고 값이 16973843이고 Adc.exe의 Version 키 값이 7250.0보다 작으면 컴퓨터에 Exchange Server 2003 서비스 팩 1(SP1) 버전의 ADC가 실행되고 있음을 나타냅니다.

새 버전의 ADC는 Exchange Server 2003 서비스 팩 2에서 사용할 수 있습니다. 최상의 성능을 위해 최신 버전의 ADC를 사용하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 2003 서비스 팩 2 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=54751)로 이동하여 최신 버전의 ADC를 다운로드합니다.

  2. 기존 버전의 ADC를 제거하고 ADC의 업데이트 버전을 설치합니다.

ADC 연결 동의(CA)에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 823601, "Active Directory Connector Requirements and Implications Throughout an Organization"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180, "Active Directory Connector Connection Agreement Requirements for Mixed Administrative Groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721, "XADM: Exchange Server 5.5 Mailbox Owner Rights Are Removed When You Change the ADC Connection Agreement from a One-Way Connection Agreement to a Two-Way Connection Agreement"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


이 연결 동의(CA)에 대해 지정한 Exchange 서버가 조직에 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 연결 동의(CA) 개체의 msExchServer2NetworkAddress 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msExchServer2NetworkAddress 특성은 이 연결 동의(CA)에 참가하는 서버의 네트워크 주소를 나타냅니다. Exchange Server Analyzer는 Active Directory의 관리 그룹을 열거하여 이 서버 이름이 관리 그룹의 연결 동의(CA) 구성원에 포함되어 있는지 확인합니다. 이 서버 이름이 관리 그룹에 포함되어 있지 않으면 오류가 표시됩니다.

이 오류는 연결 동의(CA)가 연결되지 않았음을 나타냅니다. Exchange Server 컴퓨터의 서비스가 해제된 경우에 이 오류가 발생할 수 있습니다. Exchange Server 컴퓨터가 조직에서 제거된 경우 ADC(Active Directory Connector) 관리 도구에서 연결 동의(CA) 속성의 연결 탭에 있는 Exchange 서버 이름을 변경해야 합니다. 해당 Exchange 서버가 유지 관리 또는 다른 어떤 이유로 인해 오프라인 상태로 전환된 경우에는 이 오류를 무시해도 됩니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 시작, 프로그램, 관리 도구, Active Directory Connector를 차례로 클릭합니다.

  2. 왼쪽 창에서 수정할 연결 동의(CA)를 호스팅하는 ADC 서버를 클릭합니다.

  3. 오른쪽 창에서 수정할 연결 동의(CA)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 연결 탭을 클릭합니다.

  5. 연결에 사용되는 서버의 이름을 조직 내에 존재하는 서버 이름으로 변경합니다.

ADC 연결 동의(CA)에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 823601, "Active Directory Connector Requirements and Implications Throughout an Organization"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180, "Active Directory Connector Connection Agreement Requirements for Mixed Administrative Groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)


지정된 오프라인 주소록 서버가 조직에 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-12-03

Microsoft® Exchange Server Analyzer Tool은 오프라인 주소록 구성 개체의 offLineABSchedule 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. offLineABServer 특성은 오프라인 주소록 생성을 담당하는 Exchange Server 컴퓨터의 고유 이름을 저장하는 단일값 고유 이름 특성입니다.

또한 Exchange Server Analyzer는 Active Directory에서 Exchange Server 개체의 distinguishedName 특성 값을 조사합니다.

Exchange Server Analyzer는 offLineABServer 특성에 나열된 서버가 Exchange Server 개체의 발견된 distinguishedName 특성과 일치하지 않고 offLineABServer 특성에 DEL: 문자열이 포함되어 있지 않을 경우 오류를 표시합니다.

각 오프라인 주소록에 대해 Exchange는 지정된 서버에 있는 일련의 공용 폴더에 오프라인 주소록 파일을 생성 및 저장합니다. 이 메시지가 표시되면 오프라인 주소록 개체에 지정된 서버가 없다는 뜻입니다. 이전 오프라인 주소록 서버의 서비스가 해제되었거나 토폴로지에서 잘못 제거된 경우 이 상황이 발생할 수 있습니다. 새 서버를 지정할 때까지 Exchange에서는 오프라인 주소록이 생성되지 않습니다.

Exchange 2000 Server 및 Exchange Server 2003에서 이 오류를 해결하려면 다음을 수행하십시오.

  1. Exchange System Manager의 받는 사람에서 오프라인 주소록을 클릭합니다. 오른쪽 창에서 기본 오프라인 주소록(또는 이 메시지를 생성하는 다른 오프라인 주소록)을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭의 오프라인 주소록 서버에서 찾아보기를 클릭한 다음 사용할 서버를 클릭합니다.

Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행하십시오.

  1. Exchange 관리 콘솔을 엽니다.

  2. Microsoft Exchange와 조직 구성을 차례로 확장한 다음 사서함을 선택합니다.

  3. 결과 창에서 오프라인 주소록 탭을 클릭합니다.

  4. 오프라인 주소록 탭에서 "기본 오프라인 주소록"을 선택합니다. 작업 창에서 이동을 클릭하여 오프라인 주소록 이동 마법사를 시작합니다. 이 마법사를 통해 OAB 생성을 다른 서버로 이동할 수 있습니다. 또한 기존 OAB 파일을 지정된 서버에 복사할 수도 있습니다.

Exchange 관리 셸을 사용하여 오프라인 주소록 생성을 호스팅할 서버를 설정하려면 다음을 수행하십시오.

  • 다음 명령을 실행합니다.

    코드 복사
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    여기서 <OAB>는 OAB의 DN(고유 이름), 도메인\계정 이름 또는 GUID이며 <Server>는 선택한 작업이 수행될 Exchange 서버를 지정합니다.

    예를 들어 OAB 생성을 SERVER01.로 이동하려면 다음과 같이 입력합니다.
코드 복사
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Exchange Server 2003에서의 오프라인 주소록 작업에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 오프라인 주소록 구성"을 참조하십시오.

Exchange Server 2007에서의 오프라인 주소록 작업에 대한 자세한 내용은 "조직 구성 > 사서함 > 오프라인 주소록"(http://go.microsoft.com/fwlink/?LinkId=79247)을 참조하십시오.


지정된 받는 사람 업데이트 서비스 Exchange 서버가 조직에 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-03-29

Microsoft® Exchange Server Analyzer Tool은 디렉터리에 있는 모든 Exchange Server 개체의 distinguishedName 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 또한 Exchange Server Analyzer는 디렉터리에 있는 각 Recipient Update Service 개체의 msExchAddressListServiceLink 특성 값을 확인할 때 Active Directory를 쿼리합니다. msExchAddressListServiceLink 특성은 주소 목록 서비스에서 주소 목록 서비스가 실행 중이어야 하는 Exchange Server 컴퓨터까지의 링크입니다. Exchange Server Analyzer는 msExchAddressListServiceLink 특성 값이 DEL: 문자열을 포함하지 않고 이 특성이 디렉터리에 있는 Exchange Server 개체의 distinguishedName 특성과 일치하지 않을 경우 오류를 표시합니다.

각 받는 사람 업데이트 서비스 인스턴스는 받는 사람 업데이트 서비스를 실행하는 하나의 Exchange Server와 연관됩니다. 이 메시지가 나타나는 경우 받는 사람 업데이트 서비스 인스턴스는 Exchange 조직에 없는 Exchange Server 컴퓨터와 연관되어 있습니다. 서버 역할이 해제되었거나 토폴로지에서 제거되었을 수 있습니다.

받는 사람 업데이트 서비스의 이 인스턴스를 실행하려면 이것을 기존의 Exchange 서버와 연결해야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람에서 받는 사람 업데이트 서비스를 클릭합니다. 오른쪽 창에서 받는 사람 업데이트 서비스의 해당 인스턴스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭의 Exchange 서버에서 찾아보기를 클릭하고 이 인스턴스를 실행할 새 서버를 지정합니다.

  4. 확인을 클릭한 다음 다시 확인을 클릭하여 변경 내용을 적용합니다.

  5. Exchange System Manager를 닫습니다.

받는 사람 업데이트 서비스에 대한 자세한 내용은 다음 항목 및 Microsoft 기술 자료 문서를 참조하십시오.

  • Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?linkid=47617)의 "Exchange Server 2003에서 받는 사람 및 받는 사람 정책 관리"

  • 328738, "XADM: How the Recipient Update Service Applies Recipient Policies"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, "Recipient Update Service가 주소 목록을 생성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, "XADM: How to Check the Progress of the Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, "XADM: Tasks Performed by the Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


지정한 라우팅 그룹 마스터 서버가 관리 그룹에서 검색되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 라우팅 그룹 컨테이너의 msExchRoutingMasterDN 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchRoutingMasterDN 특성 값에 유효한 서버 이름이 포함되어 있지 않고 특성에 "DEL:"이라는 문자열이 없는 경우 경고를 표시합니다.

이전 라우팅 그룹 마스터가 역할 해제되거나 토폴로지에서 잘못 제거된 경우에 이러한 문제가 발생할 수 있습니다. 라우팅 그룹 마스터가 없으면 Exchange가 라우팅 토폴로지를 올바르게 업데이트하거나 유지할 수 없습니다.

라우팅 그룹을 만들 때 라우팅 그룹의 첫 번째 서버에는 라우팅 그룹 마스터 역할이 할당됩니다. 라우팅 그룹 마스터는 해당 라우팅 그룹의 현재 링크 상태 정보를 유지하고 라우팅 그룹의 다른 서버에 전파합니다. 라우팅 그룹 마스터는 해당 라우팅 그룹의 Active Directory에 기록된 라우팅 구성만 모니터링합니다. 구성원 서버는 커넥터 상태 또는 서버 가용성 정보를 라우팅 그룹 마스터로 전달할 수 있습니다. 예를 들어 구성원 서버가 커넥터를 통해 다른 라우팅 그룹에 있는 서버에 연결하려고 하지만 이 링크를 사용할 수 없는 경우 해당 구성원 서버는 즉시 라우팅 그룹 마스터에 알립니다. 마찬가지로 마스터 서버가 아닌 서버가 새 링크 상태 정보를 수신하면 즉시 해당 커넥터 상태 정보를 라우팅 그룹 마스터에 전송하여 다른 서버가 라우팅 변경 사항에 대한 정보를 수신할 수 있도록 합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager의 관리 그룹에서 AdministrativeGroup, 라우팅 그룹을 차례로 확장합니다.

  2. 라우팅 그룹을 확장한 다음 구성원을 클릭합니다.

  3. 오른쪽 창에서 라우팅 그룹 마스터로 구성할 Exchange 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 마스터로 설정을 클릭합니다.

라우팅 그룹 마스터에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?linkid=47579)의 "라우팅 토폴로지 구성"을 참조하십시오.


공용 폴더 연결 동의(CA) 수가 구성 연결 동의(CA) 수보다 적습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory 및 각 Exchange Server 5.5 사이트 간의 공용 폴더 연결 동의(CA) 수를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 동작은 공용 폴더 연결 동의(CA) 수와 구성 연결 동의(CA) 수를 쿼리하여 수행됩니다. Exchange Server Analyzer는 공용 폴더 연결 동의 수가 구성 연결 동의(CA) 수보다 적은 경우 경고를 표시합니다.

이 경고는 적어도 하나의 Exchange Server 5.5 사이트에 Active Directory에 대한 공용 폴더 연결 동의(CA)가 없거나 Active Directory로 공용 폴더의 디렉터리 개체를 복제할 수 없음을 나타냅니다. 따라서 메일은 Exchange 2000 Server 또는 Exchange Server 2003 사서함에서 Exchange Server 5.5 공용 폴더로 이동할 수 없고 Exchange Server 5.5 사서함에서 메일 사용 가능 Exchange 2000 Server 또는 Exchange Server 2003 공용 폴더로 이동할 수 없습니다.

구성 연결 동의(CA)는 단순 Exchange Server 5.5 사이트에 Exchange 2000 Server 또는 Exchange Server 2003 컴퓨터를 설치할 때 자동으로 생성됩니다. 공용 폴더 연결 동의(CA)는 사용자가 정의합니다. 각 Exchange Server 5.5 사이트 및 Active Directory 간에 공용 폴더 연결 동의(CA)가 있으면 공용 폴더 연결 동의(CA) 수가 적어도 구성 연결 동의(CA) 수만큼 있을 것입니다.

공용 폴더 연결 동의(CA)를 만들려면 다음을 수행합니다.

  1. ADC(Active Directory Connector) 서버에서 Active Directory Connector 관리자를 시작합니다. (시작 메뉴에서 프로그램 또는 모든 프로그램을 가리키고 Microsoft Exchange를 가리킨 다음 Active Directory Connector를 클릭합니다.)

  2. 콘솔 트리에서 Active Directory Connector를 클릭합니다. 오른쪽 창에 연결 동의 목록이 나열됩니다. 이 목록을 사용하여 공용 폴더 연결 동의(CA)를 가지지 않은 사이트를 확인합니다.

  3. 동작 메뉴에서 새로 만들기를 가리킨 다음 공용 폴더 연결 동의(CA)를 클릭하면 속성 대화 상자가 표시됩니다.

  4. 일반 탭의 이름 필드에 연결 동의(CA) 이름을 입력합니다.

  5. Active Directory Connector 서비스 상자에서 연결 동의(CA)를 실행할 서버를 선택합니다.

  6. 연결 탭에서 공용 폴더 개체를 복제할 Active Directory 서버 및 Exchange Server 5.5 서버를 선택하고 각각 적합한 계정 및 자격 증명을 지정합니다.

  7. 일정 탭에서 복제 일정을 선택합니다.

  8. 확인을 클릭합니다.

공용 폴더 및 구성 연결 동의(CA)에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 264889, "XADM: 공용 폴더 연결 동의"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=264889)

  • 281223, "Understanding Connection Agreements in Exchange"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=281223)


오프라인 주소록 생성이 계속 업데이트되도록 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-12-04

Microsoft® Exchange Server Analyzer Tool은 msExchOAB 클래스의 offLineABSchedule 특성 값이 오프라인 주소록 생성을 위해 구성되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. offLineABSchedule 특성은 오프라인 주소록에 대한 일정을 확인합니다. Exchange Server Analyzer는 오프라인 주소록에 대한 오프라인 주소록 생성 일정이 계속 업데이트되도록 설정되면 경고를 표시합니다.

오프라인 주소록은 오프라인 주소록의 수집을 저장하는 컨테이너입니다. 관리자는 사용할 수 있는 오프라인 주소록을 구성합니다. Microsoft Office Outlook® 2003 및 Outlook 2007 사용자는 다운로드할 오프라인 주소록을 선택할 수 있습니다. Outlook 2003 및 Outlook 2007 같은 MAPI 클라이언트는 오프라인 주소록을 다운로드할 수 있습니다. 따라서 사용자는 Exchange Server 연결이 끊어진 경우에도 전자 메일 메시지를 작성할 수 있습니다.

오프라인 주소록이 업데이트되는 시기를 예약할 수 있습니다. 그러나 다음 업데이트가 시작되기 전에 오프라인 주소록 생성이 완료되도록 업데이트 일정을 구성해야 합니다. 예를 들어 다음 조건에서 각 업데이트 간격은 4시간 이상이어야 합니다.

  • 24시간 간격으로 세 번 업데이트하도록 지정합니다.

  • 오프라인 주소록을 업데이트하는 데 4시간이 걸립니다.

자주 업데이트하면 클라이언트와 서버 성능에 다음과 같은 영향을 줄 수 있으므로 일반적으로 업데이트는 자주 수행하지 않는 것이 좋습니다.

  • 서버가 더 자주 오프라인 주소록을 생성해야 합니다. Active Directory 크기에 따라 완료하는 데 4시간이 걸릴 수 있습니다.

  • 각 업데이트에서 Outlook은 로컬 컴퓨터에 오프라인 주소록을 복사하고 서버에서 가져온 증분 변경 내용을 적용해야 합니다. 로컬 컴퓨터의 오프라인 주소록이 150MB이면 Outlook은 각 업데이트에서 150MB만큼의 데이터 복사본을 만들어야 합니다.

  • Outlook에는 사용자 작업이 감지될 때 오프라인 주소록 업데이트를 늦추는 "조절" 메커니즘이 있습니다. 사용자가 계속 작업하면 오프라인 주소록 크기가 업데이트에 필요한 시간에 영향을 미칩니다. 이 시간 간격은 1시간에서 8시간 사이로 광범위합니다.

업데이트 빈도를 높이려면 오프라인 주소록이 합리적으로 작아졌는지 확인합니다. 합리적인 압축 해제 크기는 1MB에서 25MB 사이입니다.

Exchange 2000 Server 및 Exchange Server 2003에서 오프라인 주소록의 업데이트 일정을 설정하려면 다음을 수행하십시오.

  1. System Manager에서 받는 사람을 두 번 클릭하고 오프라인 주소록을 클릭합니다.

  2. 세부 정보 창에서 업데이트 일정을 설정하려는 오프라인 주소록을 두 번 클릭합니다.

    1. 미리 구성된 업데이트 간격을 선택하려면 일반 탭의 업데이트 간격 드롭다운 목록에 제공된 간격 중 하나를 선택합니다.

      중요:
      드롭다운 목록에서 실행 안 함을 선택하면 오프라인 주소록이 업데이트되지 않습니다.
    2. 특정 업데이트 일정을 설정하려면 사용자 지정을 클릭합니다. 일정 대화 상자에서 표시된 날짜와 시간 눈금에서 일정을 설정하고 업데이트한 다음 확인을 클릭합니다.

Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행하십시오.

  1. Exchange 관리 콘솔을 엽니다.

  2. Microsoft Exchange와 조직 구성을 차례로 확장한 다음 사서함을 선택합니다.

  3. 결과 창에서 오프라인 주소록 탭을 클릭합니다.

  4. 오프라인 주소록 탭에서 "기본 오프라인 주소록"을 선택합니다. 작업 창에서 속성을 클릭합니다.

  5. 일반 탭의 업데이트 일정 드롭다운 목록에서 실행 시간을 선택하거나 사용자 지정을 클릭하여 사용자 지정 일정을 설정합니다.

  6. 확인을 클릭하여 변경 내용을 저장합니다.
Exchange 관리 셸을 사용하여 오프라인 주소록 생성 일정을 설정하려면 다음을 수행하십시오.

  • 다음 명령을 실행합니다.

    코드 복사
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    여기서 <OAB>는 OAB의 DN(고유 이름), 도메인\계정 이름 또는 GUID이며 <Schedule>은 OAB 생성을 시작하도록 예약된 시간으로서 StartDay.Hour:Minute [AM/PM] 형식으로 지정됩니다. 다음과 같은 요일 값을 사용할 수 있습니다.

    • 완전한 요일 이름

    • 간략한 요일 이름

    • 0에서 6까지의 정수(여기서 0은 일요일)

    24시간제를 사용할 경우에는 AM/PM을 생략합니다.

    예를 들어 기본 오프라인 주소록 생성 일정을 매일 1AM과 3AM 사이로 설정하려면 다음과 같이 입력합니다.
코드 복사
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

자세한 내용은 Offline Address Book Best Practices Guide(http://go.microsoft.com/fwlink/?LinkId=47583)를 참조하십시오.

Exchange Server 2003에서의 오프라인 주소록 작업에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 오프라인 주소록 구성"을 참조하십시오.

Exchange Server 2007에서의 오프라인 주소록 작업에 대한 자세한 내용은 "조직 구성 > 사서함 > 오프라인 주소록"(http://go.microsoft.com/fwlink/?LinkId=79247)을 참조하십시오.


오프라인 주소록 생성 일정이 사용 안 함으로 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-12-04

Microsoft® Exchange Server Analyzer Tool은 오프라인 주소록 구성 개체의 offLineABSchedule 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. offLineABSchedule 특성은 Active Directory의 주소록 컨테이너에 있는 기본 오프라인 주소록 개체에 대한 오프라인 주소록 생성 일정을 나타냅니다. Exchange Server Analyzer는 offLineABSchedule 특성이 사용 안 함으로 설정되어 있으면 경고를 표시합니다.

기본적으로 Exchange는 단일 오프라인 주소록을 유지 관리합니다. Exchange는 유지 관리 주기 중인 매일 밤 이 오프라인 주소록을 업데이트하거나 새 버전을 생성합니다. 추가 오프라인 주소록을 만들 수 있으며 다음 절차에 따라 생성 일정을 검토할 수 있습니다.

이 경고는 일정이 사용 안 함으로 변경되었음을 나타냅니다. Exchange는 새 일정이 설정될 때까지는 기존 오프라인 주소록을 업데이트하지 않습니다. 즉 사용자가 기존 오프라인 주소록을 다운로드할 수 있는 동안 업데이트를 받지 않습니다.

Exchange 2000 Server 및 Exchange Server 2003에서 이 경고를 해결하려면 다음을 수행하십시오.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람 아래에서 오프라인 주소록을 클릭합니다.

  3. 오른쪽 창에서 기본 오프라인 주소록을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. 오프라인 주소록을 사용하지 않으려면 기본 오프라인 주소록을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭합니다. 그렇지 않은 경우 이 절차 중 나머지 부분을 사용하여 일정을 설정합니다.

  4. 일반 탭의 업데이트 간격 드롭다운 목록에서 실행 시간을 선택하거나 사용자 지정을 클릭하여 사용자 지정 일정을 설정합니다.

  5. 변경 내용을 저장하려면 확인을 클릭합니다.

Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행하십시오.

  1. Exchange 관리 콘솔을 엽니다.

  2. Microsoft Exchange와 조직 구성을 차례로 확장한 다음 사서함을 선택합니다.

  3. 결과 창에서 오프라인 주소록 탭을 클릭합니다.

  4. 오프라인 주소록 탭에서 "기본 오프라인 주소록"을 선택합니다. 작업 창에서 속성을 클릭합니다.

  5. 일반 탭의 업데이트 일정 드롭다운 목록에서 실행 시간을 선택하거나 사용자 지정을 클릭하여 사용자 지정 일정을 설정합니다.

  6. 확인을 클릭하여 변경 내용을 저장합니다.

Exchange 관리 셸을 사용하여 오프라인 주소록 생성 일정을 설정하려면 다음을 수행하십시오.

  • 다음 명령을 실행합니다.

    코드 복사
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    여기서 <OAB>는 OAB의 DN(고유 이름), 도메인\계정 이름 또는 GUID이며 <Schedule>은 OAB 생성이 시작되도록 예약된 시간으로서 StartDay.Hour:Minute [AM/PM] 형식으로 지정합니다. 다음과 같은 요일 값을 사용할 수 있습니다.

    • 완전한 요일 이름

    • 간략한 요일 이름

    • 0에서 6까지의 정수(여기서 0은 일요일)

    24시간제를 사용할 경우에는 AM/PM을 생략합니다.

    예를 들어 기본 오프라인 주소록 생성 일정을 매일 1AM과 3AM 사이로 설정하려면 다음과 같이 입력합니다.
코드 복사
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

Exchange Server 2003에서의 오프라인 주소록 작업에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 오프라인 주소록 구성"을 참조하십시오.

Exchange Server 2007에서의 오프라인 주소록 작업에 대한 자세한 내용은 "조직 구성 > 사서함 > 오프라인 주소록"(http://go.microsoft.com/fwlink/?LinkId=79247)을 참조하십시오.


이전 연결 동의(CA) 버전이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 ADC(Active Directory Connector) 연결 동의(CA)의 versionNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

Exchange Server Analyzer는 Exchange Server 2003 컴퓨터가 한 대 이상 있는 Exchange 조직에 있는 연결 동의(CA)의 versionNumber 특성 값이 16973842 미만일 경우 경고를 표시합니다.

16973842 미만의 값은 해당 연결 동의(CA)가 만들어져서 현재 Exchange 2000 Server ADC에서 관리되고 있음을 나타냅니다. Exchange 2000 Server나 Exchange Server 5.5 중 하나가 실행 중인 조직에서 여러 Exchange Server 2003 인스턴스를 실행하는 경우에는 ADC의 모든 인스턴스를 Exchange Server 2003에 포함되어 있는 버전으로 업그레이드해야 합니다. Exchange Server 2003 버전의 ADC나 Exchange Server 2003 서비스 팩 1(SP1) 버전으로 업그레이드하면 이 ADC에서 소유하고 있는 연결 동의(CA)도 업데이트됩니다. 각 연결 동의(CA)의 versionNumber 특성이 최신 값으로 업데이트됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. http://go.microsoft.com/fwlink/?LinkId=29090에서 Exchange Server 2003 SP1을 다운로드합니다.

  2. Exchange Server 컴퓨터를 전체 백업합니다.

  3. Exchange 2000 Server ADC를 실행 중인 서버에서 시작, 실행을 차례로 클릭한 다음 <path>\adc\i386\setup.exe를 입력합니다. 여기서 <path>는 Exchange Server 2003 SP1의 다운로드 위치입니다.

  4. Active Directory Connector 설치 마법사 시작 페이지에서 다음을 클릭합니다.

  5. 이전에 설치된 것이 발견되었습니다. 페이지에서 다시 설치를 클릭하여 Exchange 2000 Server ADC를 Exchange Server 2003 ADC로 업그레이드합니다.

  6. Active Directory Connector 설치 마법사를 완료하고 있습니다. 페이지에서 마침을 클릭합니다.

ADC 설치 및 업그레이드에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 823601, "Active Directory Connector requirements and implications throughout an organization"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823601)

  • 822942, "Exchange Server 2003으로 업그레이드할 때의 고려 사항"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822942)


PDC 에뮬레이터 FSMO 역할이 응답하지 못했습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 도메인 명명 컨텍스트 내에서 도메인 디렉터리 파티션의 루트에 대한 fSMORoleOwner 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 예를 들어 contoso.com이라는 도메인에서 주 도메인 컨트롤러(PDC) 에뮬레이터의 fSMORoleOwner는 DC=contoso,DC=com의 특성에 해당합니다. 그런 다음 Exchange Server Analyzer는 현재 이 역할을 수행하고 있는 도메인 컨트롤러의 TCP 포트 389에 LDAP(Lightweight Directory Access Protocol) 연결을 시도합니다. Exchange Server Analyzer는 이 도메인 컨트롤러에 연결할 수 없을 경우 오류를 표시합니다.

PDC 에뮬레이터는 이전 버전의 Microsoft Windows® 운영 체제와의 호환성을 위해 주 도메인 컨트롤러로 작용합니다. Microsoft Windows 2000 Server와 Microsoft Windows Server™ 2003은 Microsoft Windows NT® 워크스테이션, 구성원 서버 및 백업 도메인 컨트롤러와 상호 작동합니다. Microsoft Windows NT 3.51 또는 Microsoft Windows NT 4.0 도메인의 PDC는 다음 작업을 수행합니다.

  • 사용자 및 컴퓨터의 암호 변경 내용 처리

  • 업데이트 내용을 백업 도메인 컨트롤러로 복제

  • 도메인 마스터 브라우저 실행

언제든지 PDC 에뮬레이터 마스터 역할을 각 도메인의 단일 도메인 컨트롤러에 할당할 수 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 오류에 지정된 디렉터리 서버가 온라인 상태인지, 그리고 조직의 Exchange 서버에서 액세스할 수 있는지를 확인합니다.

  2. 이 디렉터리 서버가 제거되었으면 PDC 에뮬레이터 역할을 다른 도메인 컨트롤러에 할당해야 합니다.

도메인 컨트롤러 간에 PDC 에뮬레이터 역할을 이전하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • Windows Server 2003의 경우는 324801, "HOWTO: Windows Server 2003에서 FSMO 역할을 보고 전송하기"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)를 참조하십시오.

  • Windows 2000 Server의 경우는 255690, "그래픽 사용자 인터페이스에서 FSMO 역할을 보고 전송하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)을 참조하십시오.


구성 개체에서 권한 상속이 차단되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-04-13

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 데이터베이스의 모든 Exchange 구성 개체를 쿼리하여 개체에 차단된 상속 권한이 있는지 확인합니다. Exchange 구성 개체에 대한 권한 상속이 차단된 경우 Exchange Server Analyzer는 오류를 표시합니다.

Exchange Server Analyzer는 권한 상속이 차단된 구성 개체를 식별합니다.

Exchange Server Analyzer는 Exchange 구성 개체에 대해 Active Directory에서 DACL(임의의 액세스 제어 목록)을 검색합니다. 기본적으로 Exchange 서버 및 Exchange Server 프로토콜 같은 구성 개체는 Exchange 설치 시 권한을 상속하도록 설정됩니다. 사용 권한을 실수로 선택하지 않거나 수정한 경우 구성 개체의 권한 상속이 차단될 수 있습니다. 이 경우 큐에 메시지 고정 등의 메일 흐름 문제와 저장소 탑재 문제 등으로 인해 Exchange Server 응답 속도가 저하될 수 있습니다.

참고:
ACL(액세스 제어 목록)은 모든 개체, 개체의 속성 집합 또는 개체의 개별 속성에 적용되는 보안 보호 목록입니다. 액세스 제어 목록에는 임의 및 시스템의 두 가지 종류가 있습니다.

개체에 대한 권한 상속을 다시 사용하여 문제를 수정할 수 있습니다.

Exchange 구성 개체에 대한 권한 상속을 다시 사용하려면 다음을 수행합니다.

  1. 레지스트리 매개 변수를 설정하여 Exchange System Manager의 개체 속성 상자에 대한 보안 탭을 활성화합니다. 자세한 내용은 Microsoft 기술 자료 문서 264733, "How to enable the Security tab for the organization object in Exchange 2000 and in Exchange 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264733)을 참조하십시오.

    참고:
    기본적으로 구성 개체 속성 상자에서 보안 탭이 활성화되어 있지 않습니다.

  2. Exchange System Manager를 열고 해당 개체를 찾아서 권한 상속을 다시 활성화합니다.

  3. Exchange Server를 다시 시작합니다.

Windows Server 2003 Active Directory의 임의의 액세스 제어 목록에 대한 자세한 내용은 "How Security Descriptors and Access Control Lists Work"

(http://go.microsoft.com/fwlink/?LinkId=64193)를 참조하십시오.

권한 상속에 대한 자세한 내용은 "How Permissions Work"(http://go.microsoft.com/fwlink/?LinkId=64195)를 참조하십시오.


도메인 개체에서 권한 상속이 차단되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-04-13

Microsoft® Exchange Server Analyzer Tool은 컨테이너 및 조직 단위와 같은 Active Directory® 도메인 개체를 검사합니다. 컨테이너 또는 조직 단위에서 권한 상속이 차단된 경우 Exchange Server Analyzer가 오류를 표시합니다.

Exchange Server Analyzer는 특정 개체를 식별합니다.

Active Directory 도메인 개체를 변경할 경우 ACL(액세스 제어 목록)의 변경 사항을 덮어씁니다. '부모로부터 상속'을 수동으로 사용하더라도 변경 사항을 ACL에 적용하면 적용된 상속을 사용할 수 없습니다. RUS(받는 사람 업데이트 서비스)에는 계정이 상주하는 Active Directory 조직 단위에 필요한 권한이 없기 때문에 이 조건으로 인해 RUS 문제가 발생합니다.

계정이 상주하는 Active Directory 조직 단위에서 부모로부터 상속 가능한 사용 권한을 이 개체로 전파할 수 있음 확인란의 선택을 해제한 경우 이 동작이 발생할 수 있습니다.

문제를 해결하려면 Active Directory 사용자 및 컴퓨터 스냅인이나 ADSI(Active Directory Service Interfaces) 편집을 사용하여 조직 단위에 대해 상속 가능한 권한을 다시 설정합니다. Microsoft 기술 자료 문서 254030, "Missing permissions cause the Recipient Update Service not to process accounts in Exchange 2000 Server and Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=254030)의 시나리오 두 개에 제공된 세부 단계를 수행합니다.

Microsoft Windows Server 2003™ Active Directory의 ACL(액세스 제어 목록)에 대한 자세한 내용은 "How Security Descriptors and Access Control Lists Work"(http://go.microsoft.com/fwlink/?LinkId=64193)를 참조하십시오.

권한 상속에 대한 자세한 내용은 "How Permissions Work"(http://go.microsoft.com/fwlink/?LinkId=64195)를 참조하십시오.


공용 폴더 계층 구조를 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 msExchPFTreeType 특성에 대한 값이 1인 공용 폴더 계층 구조 수를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msExchPFTreeType 특성의 1 값은 특정 공용 폴더 계층 구조가 MAPI 클라이언트에 대해 지정된 공용 폴더 계층 구조임을 나타냅니다. Exchange Server Analyzer는 Exchange 조직의 공용 폴더 계층 구조가 msExchPFTreeType 특성에 대해 1 값을 가지지 않을 경우 오류를 표시합니다.

이 오류는 MAPI 클라이언트에 대한 공용 폴더 계층 구조가 조직에 없음을 나타냅니다. MAPI 클라이언트에 대한 공용 폴더 계층 구조가 없으면 문제가 발생할 수 있습니다. 예를 들어 MAPI 클라이언트에 대한 공용 폴더 계층 구조가 없으면 Microsoft Windows® 서버 클러스터에서 실행하는 Exchange Virtual Server를 업그레이드하지 못할 수도 있습니다.

이 문제를 해결하려면 Active Directory 편집 도구를 사용하여 MAPI 클라이언트에 대한 공용 폴더 계층 구조의 msExchPFTreeType 특성 값을 1로 설정할 수 있습니다. 다음 도구는 Active Directory 편집 도구입니다.

  • ADSI(Active Directory Service Interfaces) 편집(AdsiEdit.msc)

  • LDP(ldp.exe) 도구

MAPI 공용 폴더 계층 구조만 수정해야 합니다. Exchange 조직에 응용 프로그램 공용 폴더 계층 구조가 있으면 MAPI 공용 폴더 계층 구조에 대한 특성만 수정해야 합니다.

MAPI 공용 폴더 계층 구조의 msExchPFTreeType 특성 값을 1로 설정했으면 Exchange Server의 사서함 저장소가 MAPI 공용 폴더 계층 구조를 기본 공용 폴더 저장소로 가리키도록 구성합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제가 발생하면 Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 오류를 수정하려면 다음을 수행합니다.

  1. Active Directory 편집 도구를 사용하여 Active Directory의 공용 폴더 계층 구조 개체를 찾습니다. 공용 폴더 개체는 CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies에서 찾을 수 있습니다.

  2. 새 값으로 1을 입력하여 msExchPFTreeType 특성을 변경합니다.

  3. Active Directory 편집기를 닫습니다.

  4. Exchange System Manager를 엽니다.

  5. 각 사서함 저장소에 대한 속성에 액세스하려면 관리 그룹을 클릭하고 사용 중인 관리 그룹, 서버, 사용 중인 서버, 저장소 그룹을 차례로 확장합니다. 그런 다음 변경하려는 특성이 있는 사서함 저장소를 클릭하고 특성을 선택합니다.

  6. 일반 탭의 기본 공용 저장소 필드에서 찾아보기를 클릭합니다.

  7. MAPI 공용 폴더 계층 구조를 선택한 다음 확인을 두 번 클릭하여 변경 내용을 저장합니다.

  8. 각 사서함 저장소마다 5-7단계를 반복합니다.

LDP 도구를 사용하여 Active Directory를 수정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

MAPI 및 응용 프로그램의 공용 폴더 계층 구조에 대한 자세한 내용은 다음 리소스를 참조하십시오.

  • Microsoft 기술 자료 문서 258509, "Description of public folder tree types in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • Exchange 팀 블로그 항목, "How mail-enabled Public Folders work"(http://go.microsoft.com/fwlink/?LinkId=41913)


받는 사람 연결 동의(CA) 복제 일정이 '항상'으로 설정되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 ADC(Active Directory Connector) 연결 동의(CA)의 activationStyle 특성이 어떤 값으로 설정되었는지 확인하기 위해 Active Directory® 디렉터리 서비스를 쿼리합니다. activationStyle 특성은 ADC 연결 동의(CA)가 실행되는 빈도에 해당합니다. 이 값이 0이면 복제 일정은 사용 안 함으로 설정되고, 이 값이 1이면 복제 일정은 선택한 시간으로 설정되며 이 값이 2이면 복제 일정은 항상으로 설정됩니다.

또한 Exchange Server Analyzer는 각 ADC 연결 동의(CA) 개체의 msExchServer2SearchFilter 특성 값을 확인할 때 Active Directory를 쿼리합니다. msExchServer2SearchFilter 특성은 디렉터리를 검색할 때 사용되는 검색 필터를 나타냅니다.

Exchange Server Analyzer는 activationStyle 특성이 항상으로 설정되어 있지 않고 msExchServer2SearchFilter 특성이 받는 사람 정보를 복제하는 경우 경고를 표시합니다.

일반적으로 받는 사람 연결 동의(CA)의 복제 일정을 항상 복제로 설정하는 것이 가장 좋습니다. 일부 경우에 연결 동의(CA)를 다른 일정으로 설정하고 Exchange 5.5 사이트에서 Exchange 2003 조직으로 사서함을 이동하면 배달 못 함 보고서(NDR)가 전달될 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Active Directory Connector 서비스 MMC 스냅인을 엽니다.

  2. 연결 동의(CA)를 엽니다.

  3. 연결 동의(CA) 속성 페이지에서 일정 탭을 선택하고 항상을 선택한 후 확인을 클릭합니다.

ADC 배포 및 연결 동의(CA) 구성에 대한 자세한 내용은 Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.


받는 사람 정책에 변수를 포함합니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 각 받는 사람 정책 개체의 gatewayProxy 특성 값을 확인합니다. Exchange Server Analyzer가 gatewayProxy 특성에 SMTP:% 문자열이 있는 받는 사람 정책 개체를 찾으면 기본 구성이 아니라는 메시지를 표시합니다.

대체 문자열을 사용하여 SMTP(Simple Mail Transfer Protocol) 주소를 생성하도록 받는 사람 정책을 수정하면 받는 사람 정책에 변수가 포함됩니다. Exchange 2000 Server 서비스 팩 2(SP2) 이전 버전에서는 기본 받는 사람 정책에 변수를 사용하면 복제 문제가 발생할 수 있습니다. 따라서 받는 사람 정책에 변수를 사용하지 않거나 Exchange 2000 Server를 최신 서비스 팩으로 업그레이드하는 것이 좋습니다. Exchange 2000 Server SP2 이후 버전은 기본 받는 사람 정책에서 변수를 지원합니다.

받는 사람 정책을 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 조직, 받는 사람, 받는 사람 정책을 차례로 클릭합니다.

  3. 변경할 정책을 두 번 클릭합니다.

  4. 전자 메일 주소 탭을 클릭한 다음 해당 SMTP 주소 또는 생성 규칙을 편집합니다.

받는 사람 정책 구성 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 249299, "XADM: Exchange 2000 Server에서 받는 사람 정책을 구성하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249299)을 참조하십시오.

생성 규칙을 사용하여 SMTP 주소를 사용자 지정하는 방법에 대한 자세한 내용은 기술 자료 문서 822447, "How to Modify an SMTP E-mail Address by Using Recipient Policies"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822447)를 참조하십시오.

기본 받는 사람 정책에 변수가 있는 경우 Exchange 2000 Server에 발생할 수 있는 문제에 대한 자세한 내용은 기술 자료 문서 271339, "XADM: 데이터베이스를 탑재할 수 없고 이벤트 ID 9546이 발생한다"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=271339)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩을 얻으려면 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


받는 사람 업데이트 서비스가 중단되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 Active Directory의 각 받는 사람 업데이트 서비스 개체에 대한 msExchServer1HighestUSN 특성 값을 확인합니다. 또한 Exchange Server Analyzer는 Active Directory를 쿼리하여 각 받는 사람 업데이트 서비스 개체의 activationStyle 특성 값을 확인합니다. activationStyle 특성은 받는 사람 업데이트 서비스의 업데이트 간격을 나타냅니다.

또한 Exchange Server Analyzer는 Active Directory를 쿼리하여 받는 사람 업데이트 서비스에서 사용하고 있는 도메인 컨트롤러의 RootDSE 특성에 대한 highestCommittedUSN 특성 값을 확인합니다. highestCommittedUSN 특성은 이 도메인 컨트롤러에서 데이터베이스에 커밋된 서버의 개체에 대한 가장 높은 업데이트 일련 번호(USN)입니다.

뿐만 아니라 Exchange Server Analyzer는 Active Directory를 쿼리하여 각 받는 사람 업데이트 서비스 개체의 msExchServer1LastUpdateTime 특성 값을 확인합니다. msExchServer1LastUpdateTime 특성은 이 디렉터리에서 마지막으로 성공한 동기화의 최신 업데이트 날짜와 시간을 나타냅니다.

Exchange Server Analyzer는 다음 세 가지 조건에 해당하면 경고를 표시합니다.

  • activationStyle 특성이 2로 설정됩니다. 이 값은 이 받는 사람 업데이트 서비스의 일정이 항상으로 설정되었음을 나타냅니다.

  • msExchServer1HighestUSN 값에 나열된 일련 번호가 5,000이거나 highestCommittedUSN에 나열된 일련 번호보다 큽니다.

  • msExchServer1LastUpdateTime 특성에 타임 스탬프가 기록된 후 6시간 이상이 경과되었습니다.

이 경고는 지정한 받는 사람 업데이트 서비스가 몇 시간 동안 실행하지 않았거나 중단되었을 수 있음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람을 확장하고 받는 사람 업데이트 서비스를 선택합니다.

  3. 지정된 받는 사람 업데이트 서비스를 마우스 오른쪽 단추로 클릭한 다음 지금 업데이트를 선택합니다.

  4. 30분 동안 기다린 다음 Exchange Server Analyzer를 다시 실행하여 이 경고 조건이 여전히 존재하는지 확인합니다. 여전히 존재할 경우 5단계를 계속합니다. 더 이상 존재하지 않을 경우 다른 작업을 수행하지 않아도 됩니다.

  5. Microsoft Exchange System Attendant 서비스를 다시 시작합니다.

받는 사람 업데이트 서비스에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 253770, "Tasks performed by the Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828, "Recipient Update Service가 주소 목록을 생성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, "XADM: Recipient Update Service가 시스템 정책을 적용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, "XADM: How the Recipient Update Service Applies Recipient Policies"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


받는 사람 업데이트 서비스가 모든 변경 내용을 처리하지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-03-16

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 Active Directory에 모든 받는 사람 업데이트 서비스 개체의 gatewayProxy 특성에 대한 값이 있는지 여부를 확인합니다. 받는 사람 업데이트 서비스 개체의 gatewayProxy 특성에 대한 값이 설정되어 있으면 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 받는 사람 업데이트 서비스 개체의 gatewayProxy 특성에 완전히 처리되지 않은 이전 데이터가 들어 있음을 나타냅니다. 이 데이터는 수동으로 제거해야 합니다.

gatewayProxy 특성의 이전 데이터를 제거해야 합니다. 그렇지 않으면 이 주소는 '적용됨' 상태가 됩니다. 관리자가 '다시 빌드' 또는 '지금 업데이트' 옵션을 사용하여 정책을 변경하도록 선택한 경우 유효한 사용자 주소를 실수로 덮어쓰게 되어 사용자의 SMTP 주소가 변경됩니다. 자세한 내용은 Exchange 블로그 문서 Recipient Policies and pure Exchange 2000/2003 sites를 참조하십시오.

참고:
이 블로그에 대한 링크는 오직 정보를 제공하기 위한 것입니다. 해당 내용은 예고 없이 변경될 수 있습니다.

받는 사람 업데이트 서비스 개체의 gatewayProxy 특성에는 다음 조건이 존재할 경우 완전히 처리되지 않은 이전 데이터가 들어 있을 수 있습니다.

  • Active Directory 복제에 문제가 있습니다. Exchange System Manager가 받는 사람 업데이트 서비스를 실행하는 Exchange Server에서 사용하는 도메인 컨트롤러가 아닌 도메인 컨트롤러를 사용하는 경우 대기 시간 문제나 Active Directory 복제의 다른 문제가 있을 수 있습니다.

  • 변경 내용이 손실되는 트랜잭션 타이밍 이외의 문제가 있습니다. 이 동작은 Exchange System Manager와 시스템 수행자가 동시에 gatewayProxy 특성에 액세스할 때 발생할 수 있습니다. Exchange System Manager와 시스템 수행자 모두가 특성을 읽으려고 시도하고, 변경하며, 특성을 쓰려고 시도합니다.

ADSI(Active Directory Service Interface) 편집(AdsiEdit.msc), LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트와 같은 도구를 사용하여 이전 데이터를 제거해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 경고를 해결하려면 다음을 수행합니다.

  1. 받는 사람 업데이트 서비스의 업데이트 간격을 다음과 같이 사용 안 함으로 설정합니다.

    1. Exchange System Manager를 엽니다.

    2. 받는 사람과 받는 사람 업데이트 서비스를 차례로 확장합니다.

    3. 수정할 받는 사람 업데이트 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

    4. 일반 탭에서 업데이트 간격 목록을 사용하여 일정을 사용 안 함으로 설정합니다.

  2. 1 - 2분 정도 기다립니다.

  3. 그런 다음 ADSI 편집 또는 유사 도구를 사용하여 gatewayProxy 특성에 이전 데이터가 있는 받는 사람 업데이트 서비스 개체를 찾습니다. 받는 사람 업데이트 서비스 개체는 아래 위치에 있습니다.

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

    1. 이전 데이터가 들어 있는 받는 사람 업데이트 서비스 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

    2. 특성 편집기 탭에서 아래로 스크롤하여 gatewayProxy 특성을 선택합니다.

    3. 편집을 클릭하여 이 특성을 편집합니다.

    4. 값 상자에서 제거할 레거시 주소 유형을 선택하고 제거, 확인을 차례로 클릭합니다. 주소 유형을 모두 제거할 때까지 이 단계를 반복합니다.

    5. 확인을 클릭하여 변경 내용을 저장하고 ADSI 편집을 닫습니다.

  4. gatewayProxy 특성을 지운 후에 디렉터리 복제가 발생하도록 지정합니다. 도메인 받는 사람 업데이트 서비스가 다시 실행되기 전에 복제가 발생하는지 확인합니다.

  5. 받는 사람 업데이트 서비스를 원래 일정대로 다시 구성합니다.

  6. 특정 받는 사람 정책을 다시 적용해야 할 경우 그렇게 합니다. Active Directory 사이트 및 서비스 스냅인을 사용하여 Active Directory를 수동으로 복제합니다.

이 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 821743, "The gatewayProxy attribute on the Recipient Update Service object is not cleared"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821743)를 참조하십시오.

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

디렉터리 복제 지정에 대한 자세한 내용은 Microsoft 기술 자료 문서 232072, "Active Directory 직접 복제 파트너 간에 복제 시작"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)을 참조하십시오.

ADSI 편집을 사용하는 방법에 대한 자세한 내용은 Windows Server 2003 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


받는 사람 업데이트 서비스 전체를 다시 빌드합니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Exchange Server에서 사용하는 구성 도메인 컨트롤러에서 받는 사람 업데이트 서비스 개체의 msDS-ReplAttributeMetaData 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msDS-ReplAttributeMetaData 특성에는 이 특성의 최근 변경 날짜와 시간뿐만 아니라 기타 정보도 들어 있습니다. Exchange Server Analyzer는 msDS-ReplAttributeMetaData 특성에 나열된 날짜와 시간에서 5일 이내로 경과된 경우 경고를 표시합니다.

이 경고는 이 받는 사람 업데이트 서비스 전체가 최근에 다시 빌드되도록 예약되었음을 나타냅니다. 전체 다시 빌드가 구성되면 다음에 받는 사람 업데이트 서비스를 예약대로 시작하거나 지금 업데이트 명령으로 시작할 때 받는 사람 업데이트 서비스가 새 개체만 쿼리하지 않고 모든 개체를 조사합니다. 이 프로세스에는 시간이 오래 걸릴 수 있으므로 시스템이 지연될 수 있습니다.

전체를 다시 빌드하는 경우 이 경고를 무시해도 됩니다. 전체를 다시 빌드하지 않는 경우 ADSI(Active Directory Service Interfaces) 편집(AdsiEdit.msc) 및 다음 절차를 이용하면 이 문제를 해결하여 Active Directory의 msExchDoFullReplication 특성 값을 True에서 False로 변경할 수 있습니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003이나 Exchange Server 2003을 다시 설치하거나 두 가지 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 경고를 해결하려면 다음을 수행합니다.

  1. ADSI 편집 또는 유사한 도구를 사용하여 지정된 받는 사람 업데이트 서비스 개체의 msExchDoFullReplication 특성을 찾습니다. 받는 사람 업데이트 서비스 개체는 CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services에 있습니다.

  2. 지정된 받는 사람 업데이트 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  3. 특성 편집기 탭에서 msExchDoFullReplication 특성이 나타날 때까지 아래로 스크롤하여 이 특성을 선택합니다.

  4. 편집을 클릭하여 이 특성을 편집합니다.

  5. 부울 특성 편집기 대화 상자에서 선택을 True에서 False로 변경한 다음 확인을 클릭합니다.

  6. 확인을 다시 클릭하여 변경 내용을 저장하고 ADSI 편집을 닫습니다.

받는 사람 업데이트 서비스에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 253770, "Tasks performed by the Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828, "XADM: Recipient Update Service가 주소 목록을 생성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, "XADM: Recipient Update Service가 시스템 정책을 적용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, "XADM: How the Recipient Update Service Applies Recipient Policies"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


받는 사람 업데이트 서비스가 전체를 다시 빌드하도록 구성되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 Active Directory의 각 받는 사람 업데이트 서비스 개체에 대한 msExchDoFullReplication 특성 값을 확인합니다. 받는 사람 업데이트 서비스 개체의 msExchDoFullReplication 특성 값이 True로 설정되어 있으면 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 이 받는 사람 업데이트 서비스가 다음 처리 주기에 전체를 다시 빌드하도록 구성되었음을 나타냅니다. msExchDoFullReplication 특성이 True로 설정되면 다음에 일정이나 지금 업데이트 명령으로 받는 사람 업데이트 서비스가 시작되면 새 개체에 대해서만 쿼리하는 것이 아니라 모든 개체를 검사합니다. 이 프로세스에는 시간이 오래 걸릴 수 있으므로 시스템이 지연될 수 있습니다.

전체를 다시 빌드하는 경우 이 경고를 무시해도 됩니다. 전체를 다시 빌드하지 않는 경우 ADSI(Active Directory Service Interfaces) 편집(AdsiEdit.msc)을 사용하여 다음 절차에 따라 Active Directory의 msExchDoFullReplication 특성 값을 True에서 False로 변경하여 이 문제를 해결할 수 있습니다.

주의:
ADSI 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생될 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 경고를 해결하려면 다음을 수행합니다.

  1. ADSI 편집 또는 유사한 도구를 사용하여 지정된 받는 사람 업데이트 서비스 개체의 msExchDoFullReplication 특성을 찾습니다. 받는 사람 업데이트 서비스 개체는 CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services에 있습니다.

  2. 지정된 받는 사람 업데이트 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  3. 특성 편집기 탭에서 아래로 스크롤하여 msExchDoFullReplication 특성을 선택합니다.

  4. 편집을 클릭하여 이 특성을 편집합니다.

  5. 부울 특성 편집기 대화 상자에서 선택을 True에서 False로 변경한 다음 확인을 클릭합니다.

  6. 확인을 다시 클릭하여 변경 내용을 저장하고 ADSI 편집을 닫습니다.

받는 사람 업데이트 서비스에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 253770, "받는 사람 업데이트에서 수행한 작업"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828, "Recipient Update Service가 주소 목록을 생성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, "XADM: Recipient Update Service가 시스템 정책을 적용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, "XADM: How the Recipient Update Service Applies Recipient Policies"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


받는 사람 업데이트 서비스가 비활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory의 각 받는 사람 업데이트 서비스 개체에 대한 activationStyle 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer에서 받는 사람 업데이트 서비스 개체의 activationStyle 특성 값이 0으로 설정되어 있음을 확인하면 경고가 표시됩니다.

이 경고는 받는 사람 업데이트 서비스 개체의 일정이 업데이트 안 함으로 설정되어 있음을 의미합니다. 받는 사람 업데이트 서비스의 일정이 업데이트 안 함으로 설정되어 있으면 새 개체가 처리되지 않습니다.

받는 사람 업데이트 서비스 개체가 필요하지 않는 경우 이 개체를 삭제하는 것이 좋습니다. 받는 사람 업데이트 서비스 개체가 필요한 경우 일정을 구성하는 것이 좋습니다.

일정을 구성하여 이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람을 확장한 다음 받는 사람 업데이트 서비스를 선택합니다.

  3. 일정이 업데이트 안 함으로 설정되어 있는 받는 사람 업데이트 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  4. 업데이트 간격 목록을 사용하여 미리 정의된 일정을 선택하거나 사용자 지정을 클릭하여 사용자 지정 일정을 만듭니다.

  5. 확인을 클릭하여 변경 내용을 저장합니다.

  6. 받는 사람 업데이트 서비스를 마우스 오른쪽 단추로 클릭한 다음 지금 업데이트를 선택합니다.

받는 사람 업데이트 서비스에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 253770, "Tasks performed by the Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828, "Recipient Update Service가 주소 목록을 생성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, "XADM: Recipient Update Service가 시스템 정책을 적용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, "XADM: How the Recipient Update Service Applies Recipient Policies"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


받는 사람 업데이트 서비스 소프트웨어를 업데이트해야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 받는 사람 업데이트 서비스라고도 하는 Address Book View and Dynamic Groups Service(abv_dg.dll)의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Version WMI 키는 이 파일의 빌드 번호를 나타냅니다.

또한 Exchange Server Analyzer는 NTDS 설정 개체의 msDS-Behavior-Version 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 값은 Active Directory® 디렉터리 서비스를 쿼리합니다. msDS-Behavior-Version 특성에 유효한 값은 다음 표에 표시되어 있습니다.

값 | 포리스트 기능 수준
0 | Microsoft Windows 2000 Server 혼합
1 | Microsoft Windows Server™ 2003 임시
2 | Microsoft Windows Server 2003 전용

Exchange Server Analyzer에서 abv_dg.dll의 빌드 번호가 Active Directory 포리스트의 Exchange Server에서 Windows Server 2003 임시 또는 전용 모드로 6.0.6615.0 이하임을 확인하면 오류가 표시됩니다. 이 오류는 받는 사람 업데이트 서비스의 Exchange 2000 Server 버전이 호환되지 않는 Windows Server 2003 Active Directory 포리스트 수준에서 실행함을 나타냅니다. 이 문제를 해결하려면 받는 사람 업데이트 서비스를 업데이트해야 합니다.

Exchange 2000 Server에서 받는 사람 업데이트 서비스를 사용하여 Windows Server 2003 포리스트의 받는 사람 개체를 업데이트하면 받는 사람 업데이트 서비스가 개체를 제대로 업데이트하지 않습니다. 예를 들어 받는 사람 업데이트 서비스가 그룹 구성원의 변경 내용을 인식하지 못합니다. Exchange 2000 Server ADC(Active Directory Connector)를 사용할 경우 ADC는 Active Directory의 그룹 구성원 변경 내용을 Exchange Server 5.5 디렉터리에 복제할 수 없습니다.

받는 사람 업데이트 서비스의 최신 버전으로 업그레이드하려면 다음을 수행합니다.

  1. Microsoft 기술 자료 문서 873059, "The Recipient Update Service does not update objects correctly when Exchange 2000 Server is running in a Windows Server 2003 forest"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=873059)의 다음 지침에 따라 필요한 업데이트를 얻습니다.

  2. 업데이트를 적용합니다. 이 업데이트를 적용한 후 컴퓨터를 다시 시작하지 않아도 됩니다. 그러나 이 업데이트를 적용하면 Exchange 관련 서비스가 자동으로 다시 시작됩니다.


도메인에 대한 RUS 인스턴스가 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 포리스트에 있는 도메인 목록을 반환할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 또한 msExchangeDomainLink 특성에 기존 도메인 RUS(받는 사람 업데이트 서비스) 인스턴스의 목록을 쿼리합니다. 그런 다음 반환된 도메인 목록을 반환된 RUS 인스턴스 목록과 비교하여 일치하는지 여부를 확인합니다. Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • 도메인이 있는 경우

  • 해당 도메인에 대한 RUS 인스턴스가 없는 경우

이 Exchange Server Analyzer는 DomainPrep를 사용하여 도메인이 준비되었지만 해당 도메인에 대한 RUS 인스턴스가 없는 경우 이 오류를 표시합니다. 관리자가 포리스트에 새 Active Directory 도메인을 추가하고 DomainPrep를 사용하여 Exchange 도메인을 준비한 다음 해당 도메인에 대한 RUS 인스턴스를 추가하지 않은 경우에 이러한 불일치가 발생할 수 있습니다. 이 동작이 발생하면 도메인에 생성된 새 사용자 개체가 해당 개체로 발행된 전자 메일 주소를 받지 못합니다. 이 오류 메시지가 나타나면 도메인에 대한 새 RUS(받는 사람 업데이트 서비스)를 만드십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람을 확장합니다.

  3. 받는 사람 업데이트 서비스 노드를 마우스 오른쪽 단추로 클릭하고 새로 만들기, 받는 사람 업데이트 서비스를 차례로 클릭합니다.

  4. 새 개체 창에서 찾아보기를 클릭하여 도메인의 이름을 찾습니다.

  5. 도메인의 이름을 선택한 다음 확인을 클릭합니다.

  6. 새 개체 창에서 다음을 클릭한 다음 마침을 클릭합니다.

받는 사람 업데이트 서비스에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328738, "How the Recipient Update Service applies recipient policies"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, "Recipient Update Service가 주소 목록을 생성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, " How to check the progress of the Exchange Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, "Tasks performed by the Exchange Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


복제 시기 변경
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 도메인 컨트롤러에 대한 NTDS Settings 개체의 ms-DS-ReplicationEpoch 특성이 설정되어 있는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

시기는 도메인이 특정 이름을 보유하는 기간입니다. 도메인이 처음 만들어질 때 및 도메인 이름이 변경될 때 새로운 시기가 시작됩니다.

ms-DS-ReplicationEpoch 특성은 모든 도메인 컨트롤러가 복제되는 시기에 적용됩니다. Exchange Server Analyzer는 이 특성에 대한 값이 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

일반적으로 ms-DS-ReplicationEpoch 특성 값이 있으면 영향을 받는 서버가 상주하는 도메인의 이름이 변경되었음을 의미합니다. Microsoft Windows Server™ 2003, Standard Edition, Windows Server 2003, Enterprise Edition 및 Windows Server 2003, Datacenter Edition을 사용할 경우에는 포리스트 구조가 만들어진 후에 관리자가 Active Directory 포리스트에 있는 도메인의 이름을 변경할 수 있습니다. Windows® 2000 Server 운영 체제를 사용할 경우에는 포리스트 구조가 만들어진 후에도 Active Directory 포리스트에 있는 도메인의 이름을 변경할 수 없습니다.

Active Directory 포리스트의 구조는 도메인을 만드는 순서와 해당 도메인의 계층 이름에 따라 결정됩니다. 포리스트 루트 도메인을 시작합니다. 모든 하위 도메인의 고유 이름과 기본 DNS 이름은 포리스트 루트 도메인 이름에서 파생됩니다. 포리스트에 추가되는 모든 트리에 대해서도 동일한 방식으로 계속합니다.

도메인의 이름을 변경하여 기존 도메인 트리의 계층 구조를 변경합니다. 예를 들어 다른 상위 도메인을 갖거나 새로운 트리 루트 도메인이 되도록 하위 도메인의 이름을 변경할 수 있습니다. 두 가지 예제에서는 기존 도메인의 위치를 바꾸어 다른 도메인 트리 구조를 만듭니다.

또한 구조에 영향을 주지 않고 도메인의 이름을 변경할 수 있습니다. 예를 들어 루트 도메인의 이름을 변경할 경우 해당 루트 도메인 아래의 모든 하위 도메인의 이름을 변경합니다. 그러나 다른 도메인 트리 구조를 만들지 않습니다.

도메인 이름 변경은 Exchange 2000 Server 또는 Exchange Server 5.5가 포함되어 있는 포리스트에서는 지원되지 않습니다. Windows Server 2003 도메인 이름 변경 도구는 Exchange 2000 Server 또는 Exchange Server 5.5 Server가 포함되지 않은 Active Directory 포리스트에 있는 도메인의 이름을 바꿀 수 있도록 디자인되었습니다. Windows Server 2003 도메인 이름 변경 도구에는 다음 조건 때문에 이와 같은 제한이 있습니다.

  • 도메인 이름 변경은 몇몇 Exchange 특성에 영향을 줍니다.

  • Windows Server 2003 도메인 이름 변경 도구에는 이러한 특성을 수정할 수 있는 기능이 없습니다.

도메인 이름 변경은 Exchange Server 2003이 포함된 포리스트에서는 지원됩니다. Exchange Domain Rename Fix-Up(XDR-fixup.exe) 도구는 Exchange 2003 Server 서버가 포함된 도메인의 이름을 변경한 후에 Exchange Server 특성을 수정합니다. Windows Server 2003 디렉터리 이름 변경 도구(Rendom.exe)와 함께 Exchange Domain Rename Fix-Up 도구를 사용할 수 있습니다.

Windows Server 2003 Active Directory 도메인 이름 변경 도구 및 Windows Server 2003 Active Directory 도메인 이름 변경 도구 다운로드 방법에 대한 자세한 내용은 "Windows Server 2003 Active Directory Domain Rename Tools"(http://go.microsoft.com/fwlink/?LinkId=40992)을 참조하십시오.

도메인의 이름을 변경하려면 XDR-fixup 도구를 실행해야 합니다. XDR-fixup 도구는 Exchange Server의 Active Directory 특성을 수정하여 새로운 도메인 이름을 반영합니다. XDR-fixup 도구를 Windows Server 2003 도메인 이름 변경 도구 대신 사용할 수 없습니다. 또한 XDR-fixup 도구는 Windows Server 2003 도메인 이름 변경 도구의 기능을 확장시키지 않습니다. Rendom.exe를 실행할 때마다 XDR-fixup 도구를 실행해야 합니다.

도메인의 이름을 변경하는 프로세스와 도메인 이름 변경 프로세스가 Exchange Server에 미치는 영향에 대한 자세한 내용은 다음 도구와 문서를 참조하십시오.

  • "Windows Server 2003 Active Directory Domain Rename Tools"(http://go.microsoft.com/fwlink/?LinkId=40992)

  • "Understanding How Domain Rename Works"(http://go.microsoft.com/fwlink/?LinkId=41906)

  • "Step-by-Step Guide to Implementing Domain Rename"(http://go.microsoft.com/fwlink/?LinkId=41359)

  • "Exchange Server 도메인 이름 변경 수정(XDR-Fixup)(http://go.microsoft.com/fwlink/?LinkId=34171)

  • "Exchange and Domain Rename Operations"(http://go.microsoft.com/fwlink/?LinkId=41908)


오프라인 주소록 버전 2의 복제본을 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2007-01-29

Microsoft® Exchange Server Analyzer Tool은 HasLocalReplica의 현재 값을 확인할 때 Exchange_Public_Folder Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 HasLocalReplica 값이 오프라인 주소 목록의 오프라인 주소록 버전 2 인스턴스에 대해 False로 설정되어 있는 경우 오류를 표시합니다.

HasLocalReplica가 오프라인 주소 목록의 오프라인 주소록 버전 2 인스턴스에 대해 False로 설정되면 오프라인 주소 목록이 제대로 생성되지 않습니다. 그러면 Microsoft Outlook® 2002 및 이전 버전 사용자는 오프라인 주소 목록을 다운로드할 수 없습니다.

이 문제는 공용 폴더 저장소에 오프라인 주소록 버전 2의 복제본이 포함되도록 구성하지 않은 경우에 발생할 수 있습니다. 기본적으로 오프라인 주소록은 설치되어 있는 서버의 공용 폴더에 해당 내용을 복제합니다. 공용 폴더 저장소가 오프라인 주소록의 복제 구성에서 제거되면 이전 단락에서 설명한 문제가 발생합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹을 확장한 다음 폴더를 클릭합니다.

  3. 공용 폴더를 마우스 오른쪽 단추로 클릭한 다음 시스템 폴더 보기를 클릭합니다.

  4. 오프라인 주소록 개체를 클릭하여 확장합니다.

  5. 오프라인 주소록에서 o=org/cn=addrlists/cn=oabs/cn=Default 오프라인 주소 목록을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  6. 복제 탭에서 공용 폴더 저장소가 다음 공용 저장소로 콘텐트 복제 상자에 입력되어 있는지 확인합니다. 공용 폴더 저장소가 입력되어 있지 않으면 추가를 클릭한 다음 오프라인 주소록에 적합한 공용 저장소를 입력합니다.

  7. 적용을 클릭한 다음 확인을 클릭합니다.

  8. o=org/cn=addrlists/cn=oabs/cn=Default 오프라인 주소 목록을 클릭하여 확장합니다.

  9. o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List 아래에서 오프라인 주소록 버전 2를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  10. 복제 탭에서 공용 폴더 저장소가 다음 공용 저장소로 콘텐트 복제 상자에 입력되어 있는지 확인합니다. 공용 폴더 저장소가 입력되어 있지 않으면 추가를 클릭한 다음 오프라인 주소록에 적합한 공용 저장소를 입력합니다.

  11. 적용을 클릭한 다음 확인을 클릭합니다.

이 문제에 관한 자세한 내용은 Microsoft 기술 자료 문서 286328, "Offline Address Book Is Missing and Cannot Be Generated in Microsoft Exchange"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328)를 참조하십시오.

오프라인 주소록 목록 생성에 대한 자세한 내용은 "Offline Address List Generation Overview"(http://go.microsoft.com/fwlink/?LinkId=82242)를 참조하십시오.

Exchange Server 2003을 실행하는 첫 번째 컴퓨터를 관리 그룹에서 올바르게 제거하는 방법에 대한 자세한 내용은 기술 자료 문서 822931, "사이트에서 첫 번째 Exchange 2003 Sever 컴퓨터를 제거하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931)을 참조하십시오.


오프라인 주소록 버전 3a의 복제본을 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 HasLocalReplica의 현재 값을 확인할 때 Exchange_Public_Folder Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 HasLocalReplica 값이 오프라인 주소 목록의 오프라인 주소록 버전 3a 인스턴스에 대해 False로 설정되어 있는 경우 오류를 표시합니다.

HasLocalReplica가 오프라인 주소 목록의 오프라인 주소록 버전 3a 인스턴스에 대해 False로 설정되면 오프라인 주소 목록이 제대로 생성되지 않습니다. 따라서 Microsoft Office Outlook® 2003 사용자가 오프라인 주소 목록을 다운로드할 수 없습니다.

오프라인 주소록 버전 3a에 대한 복제본을 포함하도록 공용 폴더 저장소를 구성하지 않은 경우 이러한 문제가 발생할 수 있습니다. 기본적으로 오프라인 주소록은 이 주소록이 설치된 서버의 공용 폴더 저장소로 주소록 내용을 복제합니다. 공용 폴더 저장소가 오프라인 주소록의 복제 구성에서 제거되면 이전 단락에서 설명한 문제가 발생합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹을 확장한 다음 폴더를 클릭합니다.

  3. 공용 폴더를 마우스 오른쪽 단추로 클릭한 다음 시스템 폴더 보기를 클릭합니다.

  4. 오프라인 주소록 개체를 클릭하여 확장합니다.

  5. 오프라인 주소록에서 o=org/cn=addrlists/cn=oabs/cn=Default 오프라인 주소 목록을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  6. 복제 탭에서 공용 폴더 저장소가 다음 공용 저장소로 콘텐트 복제 상자에 입력되어 있는지 확인합니다. 공용 폴더 저장소가 입력되어 있지 않으면 추가를 클릭한 다음 오프라인 주소록에 적합한 공용 저장소를 입력합니다.

  7. 적용을 클릭한 다음 확인을 클릭합니다.

  8. o=org/cn=addrlists/cn=oabs/cn=Default 오프라인 주소 목록을 클릭하여 확장합니다.

  9. o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List에서 offline Address Book Version 3a을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  10. 복제 탭에서 공용 폴더 저장소가 다음 공용 저장소로 콘텐트 복제 상자에 입력되어 있는지 확인합니다. 공용 폴더 저장소가 입력되어 있지 않으면 추가를 클릭한 다음 오프라인 주소록에 적합한 공용 저장소를 입력합니다.

  11. 적용을 클릭한 다음 확인을 클릭합니다.

이 문제에 관한 자세한 내용은 Microsoft 기술 자료 문서 286328, "Offline Address Book Is Missing and Cannot Be Generated in Microsoft Exchange"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328)를 참조하십시오.

Exchange Server 2003을 실행하는 첫 번째 컴퓨터를 관리 그룹에서 올바르게 제거하는 방법에 대한 자세한 내용은 기술 자료 문서 822931, "사이트에서 첫 번째 Exchange 2003 Sever 컴퓨터를 제거하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931)을 참조하십시오.


디렉터리 복제 커넥터 일정
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 ADC(Active Directory Connector) 연결 동의(CA) 개체의 activationSchedule 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. activationSchedule 특성은 ADC 연결 동의(CA)가 실행되는 빈도에 해당합니다. 이 값이 0이면 복제 일정은 사용 안 함으로 설정되고, 이 값이 1이면 복제 일정은 선택한 시간으로 설정되며 이 값이 2이면 복제 일정은 항상으로 설정됩니다.

또한 Exchange Server Analyzer는 각 ADC 연결 동의(CA) 개체의 msExchServer2SearchFilter 특성 값을 확인할 때 Active Directory를 쿼리합니다. msExchServer2SearchFilter 특성은 디렉터리를 검색할 때 사용되는 검색 필터를 나타냅니다.

Exchange Server Analyzer는 activationSchedule 특성이 선택한 시간으로 설정되어 있고 복제 간격이 6시간 이상이며 msExchServer2SearchFilter 특성이 받는 사람 정보를 복제하고 있을 경우 경고를 표시합니다.

일반적으로 받는 사람 연결 동의(CA)의 복제 일정을 항상 복제하도록(항상) 설정하는 것이 가장 좋습니다. 일부 경우에 연결 동의(CA)를 다른 일정으로 설정하고 Exchange Server 5.5 사이트에서 Exchange 2000 Server 또는 Exchange Sever 2003으로 사서함을 이동하면 배달 못 함 보고서(NDR)가 전달될 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Active Directory Connector 서비스 MMC 스냅인을 엽니다.

  2. 연결 동의(CA)를 엽니다.

  3. 연결 동의(CA) 속성 페이지에서 일정 탭을 선택하고 항상을 클릭한 후 확인을 클릭합니다.

ADC 배포 및 연결 동의(CA) 구성에 대한 자세한 내용은 Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.


RID FSMO 서버 역할이 응답하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에 쿼리하여 도메인 명명 컨텍스트에서 상대 ID(RID) 작업 마스터의 fSMORoleOwner 특성 값을 확인합니다. 예를 들어 contoso.com이라는 도메인에서 RID 작업 마스터의 fSMORoleOwner는 CN=RID Manager$, CN=System, DC=contoso, DC=com의 특성입니다. 그런 다음 Exchange Server Analyzer는 현재 이 역할을 수행하고 있는 도메인 컨트롤러의 TCP 포트 389에 LDAP(Lightweight Directory Access Protocol) 연결을 시도합니다. Exchange Server Analyzer는 이 도메인 컨트롤러에 연결할 수 없을 경우 오류를 표시합니다.

RID 마스터는 모든 도메인 컨트롤러에 상대 ID(RID)를 할당하여 모든 보안 계정이 고유 식별자를 갖도록 합니다. 모든 도메인 컨트롤러에 새 보안 계정 개체(사용자, 그룹 또는 컴퓨터)를 만들 수 있습니다. 보안 계정 개체를 만들면 도메인 컨트롤러는 개체에 고유 보안 식별자(SID)를 연결합니다. 도메인 SID의 요소는 네 개이며 그 중 하나가 도메인의 RID입니다. RID 작업 마스터는 특정 도메인에 있는 모든 도메인 컨트롤러의 RID 풀 요청을 처리해야 합니다. 항상 도메인에서 RID 마스터 역할을 수행하는 도메인 컨트롤러는 하나만 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 오류에 지정된 디렉터리 서버가 온라인 상태인지 그리고 조직의 Exchange 서버에서 액세스할 수 있는지를 확인합니다.

  2. 이 디렉터리 서버가 사용 중지되었으면 다른 도메인 컨트롤러에 RID 마스터 역할을 할당해야 합니다.

한 도메인 컨트롤러에서 다른 도메인 컨트롤러로 RID 작업 마스터 역할을 전송하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • Microsoft Windows Server™ 2003의 경우는 "HOWTO: Windows Server 2003에서 FSMO 역할을 보고 전송하기"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)를 참조하십시오.

  • Windows® 2000 Server에 대한 자세한 내용은 255690, "그래픽 사용자 인터페이스에서 FSMO 역할을 보고 전송하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)을 참조하십시오.


스키마 FSMO 역할을 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 FSMO 스키마로 지정된 도메인 컨트롤러(스키마 명명 컨텍스트상의 fSMORoleOwner )를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 fSMORoleOwner 특성에 지정된 도메인 컨트롤러가 포리스트에 존재하지 않을 경우 오류를 표시합니다.

스키마 명명 컨텍스트(CN=Schema,CN=Configuration,DC=domain,DC=com)에서 fSMORoleOwner 특성은 포리스트용 스키마 마스터인 도메인 컨트롤러를 정의합니다. 스키마 마스터 도메인 컨트롤러는 스키마에 대한 모든 업데이트 및 수정을 제어합니다. 포리스트의 스키마를 업데이트하려면 스키마 마스터에 대한 액세스 권한이 있어야 합니다. 전체 포리스트에는 단 하나의 스키마 마스터만 존재할 수 있습니다.

사용 중인 Active Directory 포리스트에는 스키마 마스터가 정의되어 있어야 합니다. 스키마를 업데이트하는 중이 아니라도 설치 프로그램 실행 중 스키마 마스터 도메인 컨트롤러가 온라인 상태가 아니면 Exchange 2000 Server 설치 및 Exchange 2000 Server 서비스 팩 설치가 중지됩니다. 스키마 마스터로 설정된 도메인 컨트롤러가 오프라인 상태인 경우 다시 온라인 상태로 만들어야 합니다. 이것은 Exchange Server 2003에는 적용되지 않습니다. Exchange Server 2003 설치는 스키마가 확장되지 않았으면 스키마 마스터에게만 접속합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 지정된 Active Directory 서버가 실제로 존재하는지 확인합니다.

  2. 이 디렉터리 서버의 제거가 완료되면 스키마 마스터의 역할을 다른 도메인 컨트롤러에 할당합니다.

스키마 마스터 역할을 다른 도메인 컨트롤러에 할당하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 280178, "XADM: Exchange 2000 Installation Requires Access to Schema Master"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=280178)

  • Microsoft Windows Server™ 2003의 경우는 "HOWTO: Windows Server 2003에서 FSMO 역할을 보고 전송하기"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)를 참조하십시오.

  • Microsoft Windows® 2000 Server의 경우는 255690, "그래픽 사용자 인터페이스에서 FSMO 역할을 보고 전송하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)을 참조하십시오.


스키마 FSMO 역할이 응답하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 스키마 명명 컨텍스트에 있는 스키마 작업 마스터에 대한 fSMORoleOwner 특성 값을 확인합니다. 예를 들어 contoso.com이라는 도메인에서 스키마 작업 마스터의 fSMORoleOwner는 특성 CN=Schema,CN=System,DC=contoso,DC=com에 해당합니다. 그런 다음 Exchange Server Analyzer는 현재 이 역할을 수행하고 있는 도메인 컨트롤러의 TCP 포트 389에 LDAP(Lightweight Directory Access Protocol) 연결을 시도합니다. 이 도메인 컨트롤러에 연결할 수 없으면 Exchange Server Analyzer에서 오류를 표시합니다.

스키마 마스터 역할을 보유하는 도메인 컨트롤러는 디렉터리 스키마에 대해 쓰기 작업을 수행할 수 있는 유일한 도메인 컨트롤러입니다. 이러한 스키마 업데이트는 스키마 마스터에서 포리스트의 다른 모든 도메인 컨트롤러로 복제됩니다. 도메인 수에 관계없이 포리스트에는 스키마가 하나만 있으므로 스키마 마스터는 포리스트당 작업 마스터 역할에 해당합니다. 포리스트의 스키마를 업데이트하려면 스키마 마스터에 대한 액세스 권한이 있어야 합니다. 전체 포리스트에는 스키마 마스터가 하나만 있을 수 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 오류에 지정된 디렉터리 서버가 온라인 상태인지, 그리고 조직의 Exchange 서버에서 액세스할 수 있는지를 확인합니다.

  2. 이 디렉터리 서버가 제거되었으면 스키마 마스터 역할을 다른 도메인 컨트롤러에 할당해야 합니다.

도메인 컨트롤러 간에 스키마 작업 마스터 역할을 이전하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • Microsoft Windows Server™ 2003에 대한 자세한 내용은 324801, "Windows Server 2003에서 FSMO 역할을 보고 전송하기"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)를 참조하십시오.

  • Microsoft Windows® 2000 Server에 대한 자세한 내용은 255690, "그래픽 사용자 인터페이스에서 FSMO 역할을 보고 전송하는 방법(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)을 참조하십시오.


Secure Sockets Layer 인증서가 곧 만료됩니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 Exchange 서버 시스템의 Server Certificate 개체를 쿼리하여 X509 인증서의 다양한 속성을 검색합니다. 찾은 각 SSL(Secure Sockets Layer) 인증서에 대해 Exchange Server Analyzer는 ExpirationDate 특성을 평가하여 인증서의 만료 날짜를 식별합니다.

참고:
서버에서 SSL 프로토콜을 실행할 경우 서버 인증서가 있어야 합니다. 서버 인증서에는 웹 사이트 이름이 포함되어 있습니다. 브라우저에서 웹 사이트 이름이 입력한 이름인지 확인합니다. 예를 들어 https://www.example.com 같은 웹 사이트가 있을 경우 인증서 이름은 www.example.com이어야 합니다.

Exchange Server Analyzer는 ExpirationDate의 남은 기간이 3일에서 20일인 경우 경고를 표시하고 ExpirationDate의 남은 기간이 3일 미만인 경우 오류를 표시합니다.

인증서가 만료된 경우 이 메시지에 지정된 URL에 대한 SSL 연결이 실패합니다. 마찬가지로 해당 URL을 사용하는 RPC over HTTP 및 Exchange Server ActiveSync 연결이 실패합니다.

이 인증서 만료 경고나 오류를 해결하려면 이 메시지에 지정된 인증서를 갱신합니다. 인증서를 갱신하기 위해 수행해야 하는 단계는 사용하는 인증 기관에 따라 다릅니다.

추가 정보

Exchange Server의 가상 서버에서의 SSL 및 인증서 사용에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003의 가상 서버에서 인증서를 사용하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 823024, "How to Use Certificates with Virtual Servers in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024)을 참조하십시오.

  • SSL 사용 방법 및 서버 인증서를 얻고 설치하는 방법에 대한 자세한 내용은 Exchange Server 클라이언트 액세스 가이드(http://go.microsoft.com/fwlink/?LinkId=47568)의 "클라이언트 액세스용 Exchange Server 2003 구성"을 참조하십시오.

  • SSL 사용 방법 및 Exchange Server 2007용 서버 인증서를 받아서 설치하는 방법은 "How to Configure SSL for Outlook Anywhere"(http://go.microsoft.com/fwlink/?LinkId =80875)를 참조하십시오.


서버 컨테이너가 없음
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-08-21

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 현재 관리 그룹에서 검색된 각 Routing Group 개체의 distingushedName 특성 값을 확인합니다.

그런 다음 Exchange Server Analyzer는 Active Directory를 쿼리하여 현재 관리 그룹에 서버 컨테이너가 있는지 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • 현재 관리 그룹에 하나 이상의 라우팅 그룹이 있습니다.

  • 서버 컨테이너가 없습니다.

이 오류는 관리 그룹에 설치된 서버가 없으며 라우팅 정보를 전체 Exchange 조직의 서버에 동적으로 전파할 수 없음을 나타냅니다.

이 오류를 해결하려면 Exchange 조직이 기본 모드인지 확인하고 다음 단계를 수행합니다.

해결 단계

  1. 새 관리 그룹을 만듭니다.

  2. 새 관리 그룹에 새 라우팅 그룹 컨테이너를 만듭니다.

  3. 이전 라우팅 그룹 컨테이너에 있는 기존 라우팅 그룹을 새 컨테이너로 끌어다 놓습니다.

  4. 모든 Exchange 서비스를 다시 시작합니다.

이 오류에 대한 자세한 내용은 Microsoft 기술 자료 문서 318491 "XADM: Routing Information Is Not Propagated Across an Exchange 2000 Organization"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=318491)을 참조하십시오.


글로벌 카탈로그 서버에서 누락된 SPN(서비스 사용자 이름)
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-05-12

The Microsoft® Exchange Server Analyzer Tool에서는 Active Directory® 디렉터리 서비스 글로벌 카탈로그 서버를 쿼리하여 exchangeAB 및 HOST리소스의 servicePrincipalName 특성에 대해 정규화된 도메인 이름(FQDN)과 NetBIOS 이름에 대해 반환된 값을 찾습니다.

다음 조건 중 하나에 해당되는 경우 Exchange Server Analyzer에서는 오류가 표시됩니다.

  • exchangeAB 리소스에 대한 servicePrincipalName 특성에 예상 FQDN이나 NetBIOS 이름 값 중 하나가 누락되어 있습니다.

  • HOST Exchange 리소스에 대한 servicePrincipalName 특성 에 예상 FQDN이나 NetBIOS 이름 값 중 하나가 누락되어 있습니다.

SPN(서비스 사용자 이름)은 서비스의 인스턴스를 식별하는 고유 이름이며 서비스 인스턴스를 실행하는 로그온 계정과 연결되어 있습니다. SPN이 올바르게 설정되어 있지 않으면 Exchange 서비스에서 Kerberos 인증을 사용할 수 없습니다.

  • Microsoft Outlook® 2003 이상 버전을 실행하는 클라이언트에 Active Directory 인증 문제가 있으면 이러한 문제는 exchangeAB 리소스에 대해 유효한 SPN이 없을 수 있음을 나타냅니다.

  • 서버 간의 인증 실패는 HOST 리소스에 대해 유효한 SPN이 없을 수 있음을 나타냅니다.

이러한 문제들을 해결하려면 다음 단계를 따라 servicePrincipalName 특성에 대해 누락된 값을 추가합니다.

누락된 값을 사용하여 SPN을 추가하려면 SETSPN.exe 도구를 사용합니다.

  1. Setspn.exe 도구를 설치합니다. Setspn.exe 도구를 얻으려면, http://go.microsoft.com/fwlink/?LinkId=28103(영문)의 "Windows 2000 Resource Kit Tool : Setspn.exe"를 참조하십시오.

    Setspn.exe 명령줄 도구의 Windows Server 2003 버전은 Windows Server 2003 CD에 포함된 Windows Server 2003 지원 도구에서 사용할 수 있습니다. Server 2003 지원 도구를 설치하려면 지원/도구 폴더 안의 Suptools.msi 파일을 두 번 클릭하십시오.

  2. Exchange 서버의 Active Directory 개체에 누락된 값을 추가하려면 SETSPN.EXE Setspn_d.txt 파일의 지침을 따릅니다. 다음 예는 가상 SMTP 서버 SPN의 FQDN 값을 추가에 대해 설명합니다.

    • 명령 프롬프트를 시작하고 Setspn.exe를 설치한 디렉터리로 변경합니다.

    • 명령 프롬프트에 다음 명령을 입력합니다.

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      참고:
      mail.yourdomain.com을 SMTP 가상 서버 FQDN로 바꾸고 YOURSERVERNAME을 Exchange 서버 이름으로 바꿉니다.
      그럼 다음 Enter 키를 누릅니다.


이 관리 그룹에 대한 사이트 폴더 서버 공용 폴더 저장소가 이 관리 그룹에 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 공용 폴더 저장소의 distinguishedName 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 또한 각 관리 그룹의 siteFolderServer 및 msExchAdminGroupMode 특성 값을 확인할 때 Active Directory를 쿼리합니다. siteFolderServer 특성은 사이트 폴더 호스팅을 담당하는 서버의 이름(보통 해당 사이트나 관리 그룹에 있는 첫 번째 서버의 이름)을 나타냅니다. msExchAdminGroupMode 특성은 해당 관리 그룹의 모드를 나타내며 다음과 같은 값을 가질 수 있습니다.

  • 단순 Exchange Server 5.5

  • Exchange Server 5.5, Exchange 2000 Server 및 Exchange Server 2003 Server 혼합 모드

  • Exchange 2000 Server 또는 Exchange Server 2003 전용 모드

Exchange Server Analyzer는 해당 관리 모드가 전용 모드가 아닌 상태에서 siteFolderServer 값이 공용 폴더 저장소의 distinguishedName 값과 일치하지 않고 siteFolderServer 특성 값에 DEL: 문자열이 없을 경우 경고를 표시합니다.

기본적으로 사이트 폴더 서버는 해당 관리 그룹에 설치되어 있는 첫 번째 서버입니다. 이 서버의 공용 폴더 저장소는 해당 관리 그룹의 약속 있음/없음 폴더와 오프라인 주소록 폴더의 기본 위치에 해당합니다. 이러한 폴더를 다른 서버로 복제하거나 해당 서버를 오프라인 주소록 서버로 지정하지 않고 사이트 폴더 서버를 제거 또는 역할 해제하면 Outlook에서 오프라인 주소록 및 약속 있음/없음 데이터에 문제가 있는 것으로 나타납니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 경고를 해결하려면 다음을 수행하십시오.

  1. ADSI 편집과 같은 Active Directory 편집기를 엽니다.

  2. CN=<PublicFolderStoreName>, CN=<StorageGroupName>, CN=InformationStore, CN=<ServerName>, CN=Servers, CN=<AdministrativeGroupName> ,CN=Administrative Groups, CN=<OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration,DC=<DomainName>,DC=com을 확장하여 사이트 폴더 서버로 지정할 공용 폴더 정보 저장소를 찾습니다.

  3. 오른쪽 창에서 CN=<PublicFolderStoreName>을 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  4. 특성 필드에서 distinguishedName 특성이 나타날 때까지 아래로 스크롤하여 이 특성을 선택합니다.

  5. Edit 단추를 클릭한 다음 전체 특성을 클립보드로 복사합니다.

  6. 구성 컨테이너를 확장한 다음 CN=Administrative Groups,CN=<OrganizationName>,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<DomainName>,DC=com을 확장합니다.

  7. 수정할 관리 그룹을 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  8. 특성 필드에서 siteFolderServer 특성이 나타날 때까지 아래로 스크롤하여 이 특성을 선택합니다.

  9. Edit 단추를 클릭하여 distinguishedName 특성 값을 Value 필드에 붙여 넣습니다.

  10. Value 필드의 내용을 두 번 검사하여 올바르게 붙여 넣었는지 확인한 다음 OK를 클릭하여 변경 내용을 저장합니다.

  11. 확인을 클릭하여 관리 그룹 속성 대화 상자를 닫습니다.

  12. ADSI 편집을 종료하고 해당 사이트 내의 모든 Exchange Server 컴퓨터에서 Microsoft Exchange Server Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

시스템 폴더 다시 만들기 및 사이트 폴더 서버 재설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 275171, "Exchange 2000 Server에서 시스템 폴더를 재설정하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=275171)

  • 284200, "Schedule+ Free/Busy System Folder Is Missing"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200)

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 2003 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


오프라인 주소록으로 사용되는 사이트 폴더 서버 공용 폴더 저장소가 검색되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2007-02-01

Microsoft® Exchange Server Analyzer Tool은 모든 Exchange 공용 폴더 저장소(objectClass=msExchPublicMDB의 objectClass를 가지는 저장소)의 siteFolderServer 특성에 대한 값을 확인할 때 Active® Directory 디렉터리 서비스를 쿼리합니다. siteFolderServer 특성은 오프라인 주소록 서버로 사용되는 공용 폴더 저장소를 나타냅니다.

Exchange Server Analyzer는 서버가 나열되지 않거나 나열된 서버가 다운되었거나 나열된 서버가 존재하지 않는 경우 경고를 표시합니다. siteFolderServer 속성에 DEL:이라는 문자열이 들어 있으면 Exchange Server Analyzer는 오류 메시지를 표시합니다.

기본적으로 Exchange Server 2003은 사이트 폴더 서버(관리 그룹에 설치된 첫 번째 서버)에 오프라인 주소록 파일을 생성합니다. 해당 오프라인 주소록 서버를 다른 서버로 지정한 경우 이 특성에 나열되는 공용 폴더 저장소는 관리 그룹의 실제 사이트 폴더 서버의 저장소가 아니라 새 오프라인 주소록 서버의 저장소가 됩니다.

Exchange Server 2003이 오프라인 주소록 파일을 생성할 때 해당 파일을 메일 메시지에 첨부하고 특정 공용 폴더에 메시지를 넣습니다. Microsoft Office Outlook® 2003은 폴더에서 이 메시지를 검색하여 첨부 파일을 다운로드합니다.

Exchange Server 2003에서 오프라인 주소록 메시지는 기본 공용 폴더 트리의 시스템 폴더 중 하나인 오프라인 주소록 폴더의 하위 폴더에 저장됩니다. 이 폴더에는 사용자의 토폴로지에 속하는 각 관리 그룹 또는 사이트에 대한 하위 폴더가 들어 있습니다. 기본적으로 특정 관리 그룹 폴더의 내용 복제본은 관리 그룹에 설치된 첫 번째 서버(사이트 폴더 서버)에 상주합니다.

Exchange 조직이 Exchange Server 2007이며, 하위 단계(Outlook 2003 이전 버전) 클라이언트가 없는 경우 이 경고나 오류를 무시할 수 있습니다. Outlook 2003 이전 버전을 실행 중인 클라이언트를 Exchange Server 2007 조직이 호스팅하는 경우, 다음 절차를 수행하여 오프라인 주소록 파일의 공용 폴더 배포를 사용합니다. 공용 폴더 배포란 오프라인으로 작업하거나 전화 접속 연결을 통해 Outlook 2003 이전 버전을 실행하고 있는 클라이언트가 OAB를 액세스하는 배포 방식입니다.

Exchange Server 2003에서 이 경고를 해결하려면 다음을 수행하십시오.

  1. 서버가 존재하는 경우 Exchange System Manager의 서버 아래에서 해당 서버를 확장하고 저장소 그룹을 확장한 다음 공용 폴더 저장소를 클릭합니다. 오른쪽 창에서 해당 저장소가 실행 중인지 확인합니다.

  2. 새 오프라인 주소록 서버로 지정하려면 받는 사람 아래에서 오프라인 주소록을 클릭합니다. 그런 다음 오른쪽 창에서 기본 오프라인 주소록 또는 이 메시지를 생성한 다른 오프라인 주소록을 클릭합니다.

    오프라인 주소록을 사용하지 않으려면 기본 오프라인 주소록을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭합니다. 그렇지 않은 경우 이 절차 중 나머지 부분을 사용하여 일정을 설정합니다.

  3. 기본 오프라인 주소록을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 일반 탭의 오프라인 주소록 서버 아래에서 찾아보기를 클릭하여 서버를 선택합니다.

Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행하십시오.

  1. Exchange 관리 콘솔을 엽니다.

  2. Microsoft Exchange와 조직 구성을 차례로 확장한 다음 사서함을 선택합니다.

  3. 결과 창에서 오프라인 주소록 탭을 클릭합니다.

  4. 오프라인 주소록 탭에서 "기본 오프라인 주소록"을 선택합니다.

    1. 오프라인 주소록의 공용 폴더 배포를 사용하려면 배포 탭에서 공용 폴더 배포 사용을 선택합니다.

    2. 변경 내용을 저장하려면 확인을 클릭합니다.

  5. 새로운 오프라인 주소록 서버를 지정하려면 작업 창에서 이동을 클릭하여 오프라인 주소록 이동 마법사를 시작합니다. 이 마법사를 통해 OAB 생성을 다른 서버로 이동할 수 있습니다. 또한 기존 OAB 파일을 지정된 서버에 복사할 수도 있습니다.

Exchange 관리 셸을 사용하여 오프라인 주소록 파일의 공용 폴더 배포를 지정하려면 다음을 수행하십시오.

  • 다음 명령을 실행합니다.

    코드 복사
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    여기서 <OAB>는 OAB의 DN(고유 이름), 도메인\계정 이름 또는 GUID입니다.

    예를 들어 기본 오프라인 주소록의 공용 폴더 배포를 사용하려면 다음과 같이 입력합니다.
코드 복사
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

Exchange 관리 셸을 사용하여 오프라인 주소록 생성을 호스팅할 서버를 설정하려면 다음을 수행하십시오.

  • 다음 명령을 실행합니다.

    코드 복사
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    여기서 <OAB>는 OAB의 DN(고유 이름), 도메인\계정 이름 또는 GUID이며 <Server>는 선택한 작업이 수행될 Exchange 서버를 지정합니다.

    예를 들어 OAB 생성을 SERVER01.로 이동하려면 다음과 같이 입력합니다.
코드 복사
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Exchange Server 2003에서의 오프라인 주소록 작업에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 오프라인 주소록 구성"을 참조하십시오.

Exchange Server 2007에서의 오프라인 주소록 작업에 대한 자세한 내용은 "조직 구성 > 사서함 > 오프라인 주소록"(http:// go.microsoft.com/fwlink/?LinkId =79247)을 참조하십시오.


SiteName이 하드코드입니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SiteName 레지스트리 값이 Exchange 서버에 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netlogon\Parameters\SiteName

Exchange Server Analyzer에서 SiteName 레지스트리 값이 있음을 확인하면 경고가 표시됩니다.

이 경고는 Active Directory® 디렉터리 서비스 사이트 구성원 자격이 이 Microsoft Windows® 운영 체제를 실행하고 있는 컴퓨터에 하드코드되었음을 나타냅니다. 이 구성은 Exchange Server에 권장되지 않습니다.

Windows 사이트를 하드코드화하면 Microsoft Exchange System Attendant 서비스와 일반 Exchange Server 오류가 발생할 수 있습니다. SiteName 레지스트리 값을 제거하도록 해야 합니다. SiteName 레지스트리 값을 제거하면 Windows는 자동으로 해당 Active Directory 사이트에 가입합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
SiteName 레지스트리 값을 제거하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\Netlogon\Parameters를 탐색합니다.

  3. 오른쪽 창에서 SiteName 레지스트리 값을 찾아 삭제합니다.

  4. 레지스트리 편집기를 닫고 서버를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

SiteName 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 322834, "XADM: Event 1005, System Attendant Does Not Start"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322834)를 참조하십시오.


Exchange 조직에 900개가 넘는 관리 그룹이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-04-21

Microsoft® Exchange Server Analyzer Tool은 Exchange 조직의 관리 그룹 수를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 관리 그룹이 900개가 넘으면 경고 메시지를 표시합니다.

단일 Exchange 개체 유형에 대해서는 최대 900개의 인스턴스만 사용하는 것이 좋습니다. 지정된 요청에 대해 Active Directory가 반환하는 최대 페이지 크기가 기본적으로 1,000이기 때문입니다. 따라서 개체에 대해 LDAP(Lightweight Directory Access Protocol) 요청이 있고 Active Directory에 있는 해당 개체의 인스턴스가 1,000개를 초과하면 최대 페이지 크기를 초과하므로 결과가 반환되지 않습니다.

Exchange의 경우 여러 프로세스에서 특정 개체 유형의 인스턴스화를 요청합니다. 예를 들어 Exchange System Manager는 Active Directory에 Exchange 조직의 모든 관리 그룹에 대한 목록 보기를 만들도록 LDAP 요청을 만듭니다. 관리 그룹이 1,000개가 넘으면 Active Directory에서 결과를 반환하지 않습니다. 그 결과 Exchange System Manager에 오류가 표시되고 관리 그룹이 표시되지 않습니다.

Active Directory의 최대 페이지 크기 값을 늘릴 수 있지만 Exchange에는 바람직하지 않거나 지원되지 않습니다. 최대 페이지 크기 값이 증가된 Exchange 환경에서는 이상 동작이나 실패가 발생합니다.

Exchange에서는 단일 개체 유형을 900개 이하로 유지하는 것이 좋지만 최대 1,000개의 개체 유형이 지원됩니다.

이 문제를 해결하려면 관리 그룹을 통합하십시오.

Exchange 사이트 및 관리 그룹의 통합에 대한 자세한 내용은 다음을 참조하십시오.

  • Deploying a Worldwide Site Consolidation Solution for Exchange Server 2003 at Microsoft(http://go.microsoft.com/fwlink/?LinkId=33531)


Exchange 조직에 900개가 넘는 Exchange 서버가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-03-30

Microsoft® Exchange Server Analyzer Tool은 msExchExchangeServer의 objectCategory가 있는 디렉터리의 개체 수를 가져올 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 숫자는 Active Directory에 있는 Exchange Server 컴퓨터의 수를 나타냅니다. Exchange Server Analyzer는 Exchange Server 컴퓨터가 900개가 넘는 경우 경고를 표시합니다.

단일 Exchange 개체 유형에 대해서는 최대 900개의 인스턴스만 사용하는 것이 좋습니다. 지정된 요청에 대해 Active Directory가 반환하는 최대 페이지 크기가 기본적으로 1,000이기 때문입니다. 따라서 개체에 대해 LDAP(Lightweight Directory Access Protocol) 요청이 있고 Active Directory에 있는 해당 개체의 인스턴스가 1,000개를 초과하면 최대 페이지 크기를 초과하므로 결과가 반환되지 않습니다.

Exchange Server의 경우 여러 프로세스에서 특정 개체 유형의 인스턴스화를 요청합니다. 예를 들어 Exchange System Manager는 Active Directory에 Exchange 조직의 모든 Exchange 서버에 대한 목록 보기를 만들도록 LDAP 요청을 만듭니다. Exchange 서버가 1,000개가 넘으면 Active Directory에서 결과를 반환하지 않습니다. 그 결과 Exchange System Manager에 오류가 표시되고 Exchange Server 컴퓨터가 표시되지 않습니다.

Active Directory의 최대 페이지 크기 값을 증가시킬 수 있지만 Exchange의 경우는 바람직하지 않거나 지원되지 않습니다. 최대 페이지 크기 값이 증가된 Exchange 환경에서는 이상 동작이나 실패가 발생합니다.

Exchange Server에서는 단일 개체 유형을 900개 이하로 유지하는 것이 좋지만 최대 1,000개의 개체 유형이 지원됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 조직의 Exchange 서버를 통합합니다.

  2. Active Directory에서 연결되지 않은 Exchange Server 컴퓨터를 검사하여 제거합니다.

Exchange 서버 통합에 대한 자세한 내용은 "Server Consolidation Strategies Using Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=47586)을 참조하십시오.


조직 수준에서 위임된 관리자가 10명이 넘습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-12-03

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에 쿼리하여 Exchange Administrators 또는 Exchange Full Administrators 권한이 있는 사용자 수를 확인합니다. Exchange Server Analyzer는 해당 권한과 함께 조직 내의 모든 Exchange 관리자에 대한 링크를 나타내는 msExchAdmins 특성에 나열된 항목 수를 계산합니다. Exchange Server Analyzer는 Exchange Administrator 및/또는 Exchange Full Administrator 권한이 있는 사용자가 10명이 넘는 경우 경고를 표시합니다.

msExchAdmins는 Exchange 루트 조직 컨테이너의 다중값 특성입니다. 여기에는 위임된 Exchange 권한이 있는 사용자 계정을 나타내는 SID(보안 식별자) 목록이 들어 있습니다.

Exchange 조직에 대한 쓰기 액세스 권한이 있는 사용자 수를 제한하는 것이 좋습니다. 조직 수준에서 Exchange Administrators 및 Exchange Full Administrators 수를 줄이는 것을 고려하십시오. 메시징 인프라 요구 사항에 대해 관리 역할을 검토하여 이러한 사용자 중 다수를 조직 수준에서 Exchange View-only Administrators로 변환하는 한편 관리 그룹 수준에서 그들에게 Exchange Administrator 역할을 위임할 수 있습니다.

이 경고를 해결하려면 다음을 수행하십시오.

  1. Exchange Administrator 및/또는 Exchange Full Administrator 권한이 있는 사용자 수를 줄이는 것이 좋습니다.

  2. 조직에서 Exchange Server 권한 감사를 수행하여 권한이 적당한지 확인하는 것이 좋습니다.

Exchange에서의 사용 권한 계획 및 구성에 대한 자세한 내용은 다음을 참조하십시오.

  • "Exchange 2003에서의 Active Directory 사용 권한 작업"(http://go.microsoft.com/fwlink/?LinkId=47592)

  • Microsoft Exchange Server 2007, Operations의 "Configuring Permissions"(http://go.microsoft.com/fwlink/?LinkId=78432).

  • Microsoft Exchange Server 2007, Planning and Architecture의 Planning Active Directory "Permission Considerations"(http://go.microsoft.com/fwlink/?LinkId=78433).

Exchange Server 2003에서의 관리 역할에 대한 자세한 내용은 Microsoft 기술 자료 문서 823018, "Overview of Exchange Administrative Role Permissions in Exchange 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823018)을 참조하십시오.

Exchange 2000 Server에서의 관리 역할에 대한 자세한 내용은 기술 자료 문서 289811, "XGEN: Exchange 2000 Role Permissions"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=289811)를 참조하십시오.


일치가 만들어지지 않는 경우 이 연결 동의(CA)는 사용하지 않는 계정을 만들지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 연결 동의(CA) 개체의 msExchServer1AlwaysCreateAs 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchServer1AlwaysCreateAs 특성이 1로 설정되지 않은 경우 경고를 표시합니다.

msExchServer1AlwaysCreateAs 특성은 X.500 개체가 Active Directory와 동기화되는 방식을 결정합니다. 이 값이 0인 경우 연결 동의(CA)가 Microsoft Windows® 연락처를 만들도록 구성된 것이고 이 특성 값이 1이면 연결 동의(CA)가 Active Directory에서 사용 안 함으로 설정된 Windows 사용자 계정을 만들도록 구성된 것입니다. 또한 이 값이 2인 경우 연결 동의(CA)가 새 Windows 사용자 계정을 만들도록 구성된 것입니다.

Exchange Server Analyzer는 Exchange Server 5.5를 Active Directory와 함께 사용해야 하며 Exchange Server 2003으로의 전체 마이그레이션을 계획하고 있으므로 ADC(Active Directory Connector)가 사용 안 함으로 설정된 Windows 사용자 계정을 만들어야 할 경우 경고를 표시합니다. 이와 같이 사용 안 함으로 설정된 Windows 사용자 계정은 "사서함을 사용할 수 있습니다." 즉, Exchange Server 5.5 컴퓨터에 있는 사서함에 논리적으로 연결되어 있습니다. Active Directory의 공용 폴더 및 기타 보안이 유지된 개체에 액세스하기 위해 이와 같이 사용 안 함으로 설정된 Windows 계정을 나타내는 사용자 개체에는 사용 안 함으로 설정된 Windows 사용자 계정이 반드시 있어야 합니다.

ADC 사용자 인터페이스에는 일치하는 개체가 Exchange Server 5.5의 사서함용 Active Directory에 없을 때 새 개체를 만들 수 있는 세 가지 옵션이 제공됩니다. 이러한 옵션은 연결 동의(CA) 속성의 고급 탭에 다음과 같이 표시됩니다.

  • Windows 연락처 만들기연락처 개체에 보안 컨텍스트가 없으므로 권장되지 않습니다.

  • 새 Windows 사용자 계정 만들기 만든 새 계정이 새 SID를 갖게 되면 SID가 서로 달라 마이그레이션 중에 Microsoft Windows NT® Server 4.0 사용자 계정의 SID 기록이 이 새 계정으로 전달되지 않으므로 권장되지 않습니다.

  • 사용 안 함으로 설정된 Windows 사용자 계정 만들기 전체 마이그레이션이 완료될 때까지 NWindows NT Server 4.0 사용자는 리소스에 대한 올바른 액세스 권한을 보유하며 공존할 수 있으므로 권장됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 사서함을 사용할 수 있는 사용 안 함으로 설정된 Windows 사용자 계정을 만들도록 Active Directory 받는 사람 연결 동의(CA)를 구성합니다.

  2. Windows NT Server 4.0 사용자 계정을 Active Directory로 마이그레이션하고 활성화된 Windows 계정을 만드는 Active Directory 마이그레이션 도구를 사용합니다. 이와 같이 활성화된 Windows 계정은 ADC로 만든 사용 안 함으로 설정된 Windows 계정과 동일한 SID를 갖습니다.

  3. Active Directory 마이그레이션 도구로 만든 계정의 정보를 ADC로 만든 계정에 병합하는 Active Directory 정리 마법사(ADClean)를 사용합니다.

ADC(Active Directory Connector) 받는 사람 연결 동의(CA)에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 823601, "Active Directory Connector Requirements and Implications Throughout an Organization"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180, "Active Directory Connector Requirements for Mixed Administrative Groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 296260, "XGEN: Exchange Server 5.5 사용자에 맞게 양방향 받는 사람 연결 동의를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260)

  • Active Directory 정리 마법사에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 270652, "Possible Uses of the Active Directory Account Cleanup Wizard"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270652)

  • Active Directory 마이그레이션 도구에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 260871, "HOWTO: Windows NT 4.0에서 Windows 2000으로 마이그레이션하기 위해 ADMT를 설정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260871)


Exchange의 단방향 연결 동의(CA)가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 연결 동의(CA) 개체에서 msExchSynchronizationDirection 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msExchSynchronizationDirection 특성은 디렉터리를 동기화할 방향을 나타냅니다. 특성이 2로 설정되어 있으면 경고가 표시됩니다.

msExchSynchronizationDirection 특성 값은 0 또는 2입니다. 이 특성이 0으로 설정되어 있으면 양방향 연결 동의(CA)를 나타냅니다. 특성이 2로 설정되어 있으면 Exchange Server 컴퓨터의 단방향 연결 동의(CA)를 나타냅니다.

이 특성은 양방향 연결 동의(CA)로 설정하는 것이 좋습니다. 혼합 모드 Exchange 환경(Exchange Server 5.5와 Exchange 2000 Server 및/또는 Exchang Server 2003이 공존하는 환경)에는 양방향 연결 동의(CA)가 필요합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 기존 단방향 연결 동의(CA)를 제거합니다.

  2. 대체할 양방향 연결 동의(CA)를 만듭니다.

ADC(Active Directory Connector) 연결 동의(CA)에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 823601, "Active Directory Connector Requirements and Implications Throughout an Organization"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180, "Active Directory Connector Connection Agreement Requirements for Mixed Administrative Groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721, "XADM: Exchange Server 5.5 Mailbox Owner Rights Are Removed When You Change the ADC Connection Agreement from a One-Way Connection Agreement to a Two-Way Connection Agreement"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


Windows의 단방향 연결 동의(CA)입니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 연결 동의(CA) 개체에서 msExchSynchronizationDirection 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msExchSynchronizationDirection 특성은 디렉터리를 동기화하는 방향을 나타냅니다. 특성이 1로 설정되어 있으면 경고가 표시됩니다.

msExchSynchronizationDirection 특성 값은 0, 1 또는 2로 설정할 수 있습니다. 값이 0인 경우 양방향 연결 동의(CA)를 나타내고, 1인 경우 Active Directory로부터의 단방향 연결을 나타내며, 2인 경우 Exchange Server 컴퓨터로부터의 단방향 연결 동의(CA)를 나타냅니다.

양방향 연결 동의(CA)를 사용하는 것이 좋습니다. Exchange Server 5.5와 Exchange 2000 Server 및/또는 Exchange Server 2003이 함께 사용되는 혼합 모드 Exchange 환경에서는 양방향 연결 동의(CA)가 필요합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 기존 단방향 연결 동의(CA)를 제거합니다.

  2. 기존 연결 동의(CA)를 대체할 양방향 연결 동의(CA)를 만듭니다.

ADC(Active Directory Connector) 연결 동의(CA)에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 823601, "Active Directory Connector Requirements and Implications Throughout an Organization"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180, "Active Directory Connector Connection Agreement Requirements for Mixed Administrative Groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721, "XADM: Exchange Server 5.5 Mailbox Owner Rights Are Removed When You Change the ADC Connection Agreement from a One-Way Connection Agreement to a Two-Way Connection Agreement"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


Exchange와 Active Directory 간의 타임스탬프 비교가 5분을 초과합니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 각 Exchange 서버에서 날짜와 시간을 확인할 때 Win32_UTCTime Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 또한 Exchange Server Analyzer는 기본 도메인 컨트롤러에서 현재 날짜와 시간을 검색합니다. Exchange Server Analyzer가 두 개의 서버 간에 5분 이상의 차이를 확인하게 되면 오류가 표시됩니다.

Microsoft Windows 2000 Server 및 Windows Server™ 2003은 Windows 시간 서비스를 사용하여 Windows 기반 네트워크에서 실행 중인 컴퓨터의 날짜 및 시간을 동기화합니다. 기본 인증 프로토콜은 인증 티켓을 생성하는 과정에서 워크스테이션 시간을 사용하므로 Windows 2000 및 Windows Server 2003에서 동기화된 시간이 매우 중요합니다. MIT Kerberos 버전 5는 기본 인증 프로토콜입니다.

Active Directory® 디렉터리 서비스 도메인의 모든 Windows 기반 서버에 대해 Windows 시간 서비스는 도메인 컨트롤러에서 사용할 수 있는 Windows 시간 서비스를 사용하여 자동으로 자체 구성합니다. Windows 시간 서비스는 해당 도메인의 도메인 컨트롤러를 신뢰할 수 있는 시간 원본으로 구성하고 주기적으로 이 원본과 동기화합니다.

이 오류를 해결하려면 Exchange Server의 클럭을 디렉터리 서버와 동기화합니다.

Active Directory 도메인에 있는 서버의 클럭을 동기화하려면 다음을 수행합니다.

  1. 명령 프롬프트를 엽니다.

  2. w32tm /resync를 입력한 다음 Enter 키를 누릅니다.

이 오류가 지속되거나 조직의 다수의 컴퓨터에서 이 오류가 발생되는 경우, Windows 시간 서비스를 배포하고 Active Directory 포리스트에서 구성한 방법을 검토하십시오. Windows 시간 서비스에 대한 자세한 내용은 "Windows Time Service Technical Reference"(http://go.microsoft.com/fwlink/?LinkId=40648)를 참조하십시오.

Exchange 프런트 엔드 서버가 Active Directory 시간과 동기화되지 않으면 클라이언트가 Microsoft Office Outlook® Web Access에 연결하려고 할 때 "HTTP 500 internal server" 오류 메시지가 표시될 수 있습니다. 이 상황에 대한 자세한 내용은 Microsoft 기술 자료 문서 841546, "Known issues that cause the 'HTTP 500 internal server error' error message in Exchange 2000 Outlook Web Access"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841546)를 참조하십시오.


Active Directory Connector 서버와 Active Directory간의 타임스탬프 차이가 5분을 초과합니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Win32_UTCTime WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 각 ADC(Active Directory Connector) 서버의 날짜와 시간을 확인합니다. 또한 Exchange Server Analyzer는 기본 도메인 컨트롤러에서 현재 날짜와 시간을 검색합니다. Exchange Server Analyzer가 두 개의 서버 간에 5분 이상의 차이를 확인하게 되면 오류가 표시됩니다.

Microsoft Windows 2000 Server 및 Windows Server™ 2003은 Windows 시간 서비스를 사용하여 Windows 기반 네트워크에서 실행 중인 컴퓨터의 날짜 및 시간을 동기화합니다. 기본 인증 프로토콜은 인증 티켓을 생성하는 과정에서 워크스테이션 시간을 사용하므로 Windows 2000 Server 및 Windows Server 2003에서 동기화된 시간이 매우 중요합니다. MIT Kerberos 버전 5는 기본 인증 프로토콜입니다.

Active Directory® 디렉터리 서비스 도메인의 모든 Windows 서버의 경우 Windows 시간 서비스는 도메인 컨트롤러에서 사용 가능한 Windows 시간 서비스를 사용하여 자동으로 구성됩니다. Windows 시간 서비스는 해당 도메인의 도메인 컨트롤러를 신뢰할 수 있는 시간 원본으로 구성하고 주기적으로 이 원본과 동기화합니다.

이 오류를 해결하려면 ADC 서버의 클럭을 디렉터리 서버와 동기화합니다.

Windows 2000 Server 또는 Windows Server 2003 도메인의 서버에서 클럭을 동기화하려면 다음을 수행합니다.

  1. 명령 프롬프트를 엽니다.

  2. w32tm /resync를 입력한 다음 Enter 키를 누릅니다.

이 오류가 지속되거나 조직의 다수의 컴퓨터에서 이 오류가 발생되는 경우, Windows 시간 서비스를 배포하고 Active Directory 포리스트에서 구성한 방법을 검토하십시오. Windows 시간 서비스에 대한 자세한 내용은 "Windows Time Service Technical Reference"(http://go.microsoft.com/fwlink/?LinkId=40648)를 참조하십시오.


Windows Server 2003에서 최종 빌드가 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Exchange 조직에 있는 ADC(Active Directory Connector) 서버의 Version 키 값을 확인할 때 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 또한 Exchange Server Analyzer는 다음 레지스트리 항목을 검사하여 ADC 서버에서 실행 중인 Windows 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Exchange Server Analyzer는 CurrentVersion의 두 번째 인스턴스 값이 5.2이고 Version 값이 5.2.3790이 아닌 경우 오류를 표시합니다.

CurrentVersion 값이 5.2이면 컴퓨터에 Windows Server 2003 운영 체제가 실행되고 있음을 나타냅니다. 모든 Windows Server 2003 운영 체제 정식 버전의 Version 값은 5.2.3790입니다. 그 밖의 다른 Version 키 값은 Windows Server 2003의 시험판 버전을 사용하고 있음을 나타냅니다.

기술 채택 프로그램(TAP)이거나 유사한 Microsoft 후원 프로그램이 아니면 업무 환경에서 시험판 소프트웨어를 사용하지 않는 것이 좋습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 도메인 컨트롤러, 글로벌 카탈로그 서버, ADC 서버, Exchange Server 컴퓨터 등의 모든 Exchange 인프라 서버를 최신 버전의 소프트웨어로 업그레이드합니다.

  2. 업그레이드 옵션이 사용 가능하거나 지원되는 경우 운영 체제를 다시 빌드하여 Exchange Server 설정 및 데이터를 복원합니다.

도메인 컨트롤러, 글로벌 카탈로그 서버, ADC 서버, Exchange Server 컴퓨터 등의 모든 Exchange 인프라 서버를 최근 버전의 소프트웨어로 업그레이드합니다.

Windows Server 2003 소프트웨어 업데이트에 대한 자세한 내용은 Windows Server 2003 Software Updates 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33760)를 참조하십시오.


Windows Server 2003에서 시험판 소프트웨어가 실행되고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 ServicePackMajorVersion 키 값을 확인할 때 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 검토합니다. 또한 Exchange Server Analyzer는 다음 레지스트리 항목을 조사하여 대상 컴퓨터에서 실행 중인 Windows 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion의 두 번째 인스턴스 값이 5.2이고 ServicePackMajorVersion 값이 1보다 클 경우 Exchange Server Analyzer는 경고 메시지를 표시합니다.

CurrentVersion 값 5.2는 해당 컴퓨터가 Microsoft Windows Server™ 2003 운영 체제를 실행하고 있음을 나타냅니다. 1보다 큰 ServicePackMajorVersion은 서비스 팩 1(SP1) 이상의 서비스 팩이 설치되어 있음을 나타냅니다. SP1이 Windows Server 2003에 대해 유일하게 릴리스된 서비스 팩이므로 설치된 모든 Windows Server 2003 서비스 팩 2 이상은 릴리스 이전 소프트웨어입니다.

TAP(Technology Adoption Program)나 Microsoft에서 후원하는 비슷한 프로그램의 구성원이 아니면 업무 환경에서 시험판 소프트웨어를 실행하지 않는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 설치된 시험판 소프트웨어를 모두 제거합니다.

  2. 제거 옵션을 사용할 수 있으면 운영 체제를 다시 빌드하고 Exchange Server 설정과 데이터를 복원합니다.

Windows Server 2003 소프트웨어 업데이트에 대한 자세한 내용은 Windows Server 2003 Software Updates 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33760)를 참조하십시오.


Windows 2000 Server에서 서비스 팩 4가 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 ServicePackMajorVersion 키 값을 확인할 때 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 검토합니다. 또한 Exchange Server Analyzer는 다음 레지스트리 항목을 검토하여 대상 컴퓨터에서 실행 중인 Windows 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Exchange Server Analyzer는 대상 시스템에서 Windows 2000 Server 운영 체제가 실행되고 있지만 Windows 2000 Server 서비스 팩 4가 실행되고 있지 않을 경우 경고를 표시합니다.

가장 좋은 방법은 Exchange 배포의 모든 소프트웨어에 대해 최신 서비스 팩을 설치하는 것입니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Windows 2000 Server 운영 체제가 실행 중인 모든 도메인 컨트롤러와 글로벌 카탈로그 서버를 서비스 팩 4 및 Windows 업데이트에 있는 최신 핫픽스와 업데이트로 업데이트합니다.

  2. 모든 Exchange Server 컴퓨터를 최신 서비스 팩 및 업데이트 롤업으로 업데이트합니다.

Windows 2000 Server 운영 체제에 대한 서비스 팩을 구하여 설치하는 방법에 대한 자세한 내용은 "Windows 2000 서비스 팩" 웹 사이트(http://go.microsoft.com/fwlink/?linkid=18353)를 참조하십시오.

Exchange Server 서비스 팩 및 롤업을 구하여 설치하는 방법에 대한 자세한 내용은 "Microsoft Exchange Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21573)를 참조하십시오.


Windows 2000 Server에서 최종 빌드가 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2005-11-17

Microsoft® Exchange Server Analyzer Tool은 Version 키 값을 확인할 때 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 다음 레지스트리 항목을 조사하여 컴퓨터에서 실행 중인 Windows 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 5.0은 해당 컴퓨터가 Microsoft Windows 2000 Server 운영 체제를 실행하고 있음을 나타냅니다. 모든 Windows 2000 Server 운영 체제의 릴리스 버전에 대한 Version 값은 5.0.2195입니다. Version 키 값이 이와 다르면 Windows 2000 Server의 시험판 버전이 사용되고 있다는 의미입니다.

Exchange Server Analyzer는 두 번째 CurrentVersion 인스턴스의 값이 5.0이고 Version 값이 5.0.2195가 아닐 경우 오류를 표시합니다.

TAP(Technology Adoption Program)나 Microsoft에서 후원하는 비슷한 프로그램의 구성원이 아니면 Microsoft에서는 업무 환경에서 시험판 소프트웨어의 사용을 지원하거나 권장하지 않습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 도메인 컨트롤러, 글로벌 카탈로그 서버, ADC(Active Directory Connector) 서버, Exchange Server 컴퓨터 등의 모든 Exchange 인프라 서버를 최신 버전의 소프트웨어로 업그레이드합니다.

  2. 업그레이드 옵션이 사용 가능하거나 지원될 경우 운영 체제를 다시 빌드하고 Exchange Server 설정과 데이터를 복원합니다.

Windows 2000 서비스 팩 4를 구하여 설치하는 방법에 대한 내용은 Windows 2000 서비스 팩 4 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33241)를 참조하십시오.


X.400 주소에 잘못된 마침 문자가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Active Directory >

최근 수정된 항목: 2006-12-03

Microsoft® Exchange Server Analyzer Tool은 받는 사람 정책의 gatewayProxy 값을 확인하고 X.400 주소가 세미콜론으로 끝나는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

받는 사람 정책에서 X.400 주소의 올바른 서식은 주소가 세미콜론으로 끝나는 것입니다. 세미콜론이 없으면 X.400 주소로의 메시지 라우팅이 끊어집니다.

이 문제를 해결하려면 ADSI(Active Directory Service Interfaces) 편집 또는 LDP 도구를 사용하여 주소 끝에 세미콜론을 추가해야 합니다.

주의:
ADSI 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생될 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 오류를 해결하려면 다음을 수행하십시오.

  1. ADSI 편집과 같은 Active Directory 편집기를 엽니다.

  2. Configuration [DomainName], CN=Configuration, DC=DomainName, DC=DomainSuffix를 차례로 확장합니다.

  3. CN=Services, CN=Microsoft Exchange를 차례로 확장합니다.

  4. CN=OrganizationName, CN=Administrative Groups, CN=Recipient Policies를 차례로 확장합니다.

  5. CN=PolicyName을 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  6. 아래로 스크롤하여 gatewayProxy를 찾아 선택하고 편집을 클릭합니다.

  7. 값 필드에 올바른 gatewayProxy를 입력합니다.

  8. Active Directory 편집기를 닫고 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.


데이터베이스 복구
Microsoft Exchange Server Analyzer - 문서 >

최근 수정된 항목: 2007-01-22

이 섹션의 문서에서는 Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 이벤트 로그에서 검색한 데이터베이스 오류 및 경고 이벤트에 대해 상세히 설명합니다. 데이터베이스 문제 해결사는 Microsoft Exchange Troubleshooting Assistant와 같은 엔진을 사용하여 데이터베이스 탑재 문제의 근본 원인을 확인하기 위한 문제 해결 단계를 프로그래밍 방식으로 실행합니다. 또한 이 문서에서는 증상을 확인하고 데이터베이스 관련 문제를 해결하기 위해 수행할 수 있는 단계에 대해서도 설명합니다.

도구에 대한 자세한 내용을 보거나 도구를 다운로드하려면 Microsoft Exchange Troubleshooting Assistant v1.0을 참조하십시오.


ESE 428(0xfffff8f0): 트랜잭션 로그 드라이브의 사용 가능한 공간 부족
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-04-02

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 ESE 428 이벤트를 하나 이상 검색했습니다. 이 이벤트는 트랜잭션 로그 드라이브에서 사용 가능한 공간이 부족함을 나타냅니다. 이 오류가 발생할 경우 Exchange Server는 새 트랜잭션 로그 파일을 만들 수 없습니다. 데이터베이스의 업데이트 내용은 트랜잭션 로그에 기록되어야 하므로 이러한 오류는 해당 저장소 그룹의 모든 데이터베이스를 오프라인 상태로 만듭니다.

설명

Exchange Server는 트랜잭션 로그 드라이브의 공간 부족을 방지하기 위해 다음과 같은 두 가지 메커니즘을 제공합니다.

  • 순환 로깅. 검사점을 지나면 트랜잭션 로그는 자동으로 삭제됩니다. 대부분의 경우 트랜잭션 로그 파일에 사용되는 디스크 공간은 50MB 이하로 유지됩니다. 백업 중에는 백업이 완료될 때까지 트랜잭션 로그 제거가 일시적으로 중단됩니다.

    참고:
    기본적으로 순환 로깅 메커니즘은 Microsoft Exchange 2000 Server 이상 버전에서 사용되지 않습니다.
  • 저장소 그룹 백업. Exchange Server는 VSS(볼륨 섀도 복사본 서비스) 또는 Exchange Server의 스트리밍 온라인 백업 API를 구현하는 백업 방식을 사용하여 저장소 그룹의 모든 데이터베이스에 대한 전체 또는 증분 온라인 백업을 수행한 다음 초과 로그를 제거합니다.

순환 로깅을 사용하지 않은 상태에서 다음 중 하나에 해당하는 경우, 하드 디스크 드라이브 공간을 모두 사용할 때까지 트랜잭션 로그 파일의 수가 증가합니다.

  • 백업 프로그램이 트랜잭션 로그 파일을 제거하지 않습니다.

  • 백업 프로그램이 실행을 중지했습니다.

  • 다른 방법을 사용하여 트랜잭션 로그 파일을 지울 수 없습니다.

남아 있는 하드 디스크 공간이 없을 때, 트랜잭션 로그 파일을 수동으로 제거해야만 하는 경우도 있습니다. 또는 하드 디스크 공간이 가득 찰 것으로 예상하는 경우 트랜잭션 로그 파일을 먼저 수동으로 제거한 후 특정 저장소 그룹의 모든 데이터베이스를 전체 또는 증분 온라인 백업할 수 있습니다. 데이터베이스 검사점을 지나지 않은 로그를 제거하면 해당 데이터베이스는 비정상적으로 중지되며 필요한 로그가 복원될 때까지 데이터베이스를 탑재할 수 없습니다. 따라서 Exchange Server 트랜잭션 로그 파일을 수동으로 삭제하기 전에 안전하게 제거할 수 있는 로그를 확인해야 합니다.

오류는 JET_errDiskFull 또는 오류 코드 0xfffff8f0으로 보고되기도 합니다. 이 오류는 다음 버전의 Exchange Server에 적용됩니다.

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

사용자 작업

오류 해결 방법은 다음과 같습니다.

  • 데이터베이스 복구 관리 도구를 실행합니다. Microsoft Exchange Server 2007에서 이 도구는 Exchange 관리 콘솔에 있는 도구 상자의 데이터베이스 복구 도구 아래에 나열되어 있습니다. Exchange Server Analyzer는 안전하게 제거할 수 있는 로그 파일을 자동으로 확인하여 사용자의 백업 위치에 복사합니다. Exchange Server Analyzer를 사용하여 로그 파일을 이동하는 것이 좋습니다.

    참고:
    데이터베이스가 있는 저장소 그룹을 CCR(Cluster Continuous Replication)에 사용하는 경우 Exchange Server Analyzer는 Exchange 2007에서 작동하지 않습니다.
  • 각 데이터베이스 헤더의 상태 및 필수 로그 값을 점검하여 안전하게 수동으로 제거할 수 있는 트랜잭션 로그 파일을 확인합니다.

    참고:
    트랜잭션 로그 파일의 제거는 해당 트랜잭션 로그 파일을 백업, 저장 또는 삭제할 수 있는 다른 위치로 이동하는 것을 의미합니다. 작업은 사용자의 요구 사항에 따라 결정됩니다. 트랜잭션 로그 파일의 삭제는 해당 트랜잭션 로그 파일을 백업 또는 복원할 수 없도록 제거하는 것을 의미합니다.

수동으로 안전하게 제거할 수 있는 트랜잭션 로그 파일을 확인하려면 이러한 상세 단계를 따릅니다.

데이터베이스 헤더를 검사하여 불필요한 로그 파일을 제거하려면 다음을 수행하십시오.

  1. 헤더를 검사할 데이터베이스를 분리합니다.

  2. 시작과 실행을 차례로 클릭한 다음, cmd를 입력하여 명령 프롬프트 창을 엽니다.

  3. 명령 프롬프트에서 데이터베이스 파일이 있는 디렉터리 경로로 이동합니다.

    참고:
    Exchange 2000 Server 및 Exchange Server 2003에서 .edb 및 .stm 데이터베이스 파일의 경로와 이름을 확인하려면 Exchange System Manager를 사용하여 각 데이터베이스 개체의 속성 대화 상자의 데이터베이스 탭을 확인합니다. Exchange Server 2007에서 데이터베이스 파일의 경로와 이름을 확인하려면 서버 구성의 Exchange 관리 콘솔을 확장하여 사서함을 클릭한 다음 데이터베이스 관리 탭을 확인합니다.

  4. 명령 프롬프트에서 다음 Eseutil 명령을 /MH 스위치와 함께 입력합니다.

    코드 복사
    "eseutil /MH databasefilename.edb"
    참고:
    이 구문에서 databasefilename은 검사할 데이터베이스의 이름입니다.

  5. 표시된 헤더 정보 중 상태 및 필수 로그 값을 검사합니다.

    상태 값은 다음과 같이 해당 데이터베이스가 올바르게 분리되었는지에 대한 정보를 제공합니다.

    • 데이터베이스가 올바르게 분리된 경우, 상태 값은 완전한 종료 또는 일치입니다. 이 값은 실행 중인 Exchange Server의 버전에 따라 정해집니다. 현재 트랜잭션 로그 파일을 제외한 모든 트랜잭션 로그 파일을 제거할 수 있습니다.

      참고:
      모든 데이터베이스가 완전한 종료 상태일 때 현재 로그 파일을 제거하면 로그 파일 순서가 다시 설정됩니다. 이 작업은 데이터베이스를 시작하는 데 문제가 되지는 않습니다. 그러나 로그 파일 순서가 다시 설정되므로 이전 백업에서 데이터베이스를 롤포워드하는 기능에는 영향을 미칩니다.
    • 데이터베이스가 잘못 분리된 경우, 상태 값은 부적절한 종료 또는 불일치입니다. 데이터베이스 헤더의 필수 로그 필드를 확인하여 제거할 수 있는 트랜잭션 로그 파일을 결정합니다.

      참고:
      데이터베이스의 상태가 부적절한 종료 또는 불일치라는 것은 기존의 트랜잭션 로그 파일 중 일부에 데이터베이스에서 필요한 미처리 트랜잭션이 포함되어 있음을 의미합니다. 이러한 경우에 트랜잭션 로그 파일을 제거하면 백업에서 데이터베이스를 복원하지 않는 한 해당 데이터베이스를 다시 시작할 수 없습니다. 또는 Eseutil 명령과 Isinteg 명령을 사용하여 데이터베이스를 복구할 수도 있습니다.
      저장소 그룹의 각 데이터베이스의 필수 로그 값을 해당 저장소 그룹의 로그를 제거하기 전에 검사해야 합니다.

      필수 로그 필드에는 해당 데이터베이스를 시작하는 데 필요한 로그 파일이 숫자 범위로 나열되어 있습니다. 범위가 0 - 0이면 데이터베이스를 시작하는 데 필요한 로그 파일이 없습니다. 이는 해당 데이터베이스가 완전한 종료 또는 일치 상태임을 나타냅니다. 검사점 로그 이전의 로그 파일이 있으면 검사점 로그를 제외한 모든 로그 파일을 제거할 수 있습니다.

      Exchange Server 2003 서비스 팩 1(SP1) 이전 버전의 Exchange Server를 실행하고 있다면 필수 로그 필드에 표시된 10진수 범위를 16진수 값으로 변환해야 합니다. 예를 들어 필수 로그 값이 28217 - 28221이면 06E39 - 06E3D 범위의 로그 파일이 데이터베이스에 필요합니다. Exchange 2003 SP1에서는 필수 로그 필드에 10진수와 16진수 값이 모두 표시되도록 향상되었습니다.

      참고:
      Windows 계산기의 공학용 모드를 사용하면 10진수를 16진수로 변환할 수 있습니다. 계산기를 시작한 다음 보기 메뉴에서 공학용 모드를 클릭합니다. 10진수를 입력한 다음 Hex를 클릭합니다.
      Exchange 2000과 Exchange 2003에서는 저장소 그룹을 4개까지 가질 수 있으며 각 저장소 그룹마다 특정 로그 파일 집합이 포함되므로 트랜잭션 로그 파일 이름에 Edb 접두사가 붙지 않습니다. Exchange 2000과 Exchange 2003에서 Edb 접두사는 E00, E01, E02 또는 E03으로 대체됩니다. 복구 저장소 그룹의 경우, Edb 접두사가 R00으로 대체됩니다. 저장소 그룹 로그 파일 접두사는 Exchange System Manager에서 특정 저장소 그룹 개체의 속성 대화 상자에 있는 일반 탭에 표시됩니다. 따라서 저장소 그룹 접두사가 E01이고 필수 로그 항목이 28217 - 28221(0x06E39 - 0x06E3D)인 경우, 실제로 필요한 로그는 E0106E39.log부터 E0106E3D.log까지입니다.

  6. 저장소 그룹에 있는 데이터베이스의 필수 로그 필드 내에 있는 가장 낮은 항목보다 번호가 작은 로그 파일은 모두 제거해도 됩니다.

    참고:
    이는 로그 파일을 삭제하는 것이 아닌 이동을 의미합니다.
    참고:
    가장 최근의 트랜잭션 로그 파일은 제거하지 않는 것이 가장 좋습니다. 이러한 로그 파일은 가장 최근의 타임스탬프를 가지고 있으며 파일 이름에 시퀀스 번호가 아직 없습니다. 안전하게 제거할 수 있는 파일로 확인된 경우라도 로그 파일 시퀀스가 다시 0으로 설정되지 않도록 합니다. 로그 파일 시퀀스를 다시 설정하면 백업 주기에 영향을 미칩니다. 다시 설정하기 이전에 수행된 백업으로부터 데이터베이스를 롤포워드하는 것이 불가능할 수도 있습니다.


ESE 454 -515: 필수 트랜잭션 로그 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Server Analyzer Tool에서 오류 코드 -515의 ESE 이벤트 454가 검색되었습니다. 이 오류는 필수 트랜잭션 로그 파일이 없기 때문에 Exchange 데이터베이스를 탑재할 수 없음을 나타냅니다.

설명

-515 오류의 ESE 454 이벤트는 복구 프로세스 동안 ESE(확장 가능한 저장소 엔진)가 저장소 그룹에 있는 모든 데이터베이스를 일관성 있는 상태로 설정하려고 시도하는 경우 발생할 수 있습니다. 필수 트랜잭션 로그 파일이 없으면 -515 오류로 인해 복구 프로세스가 실패하고 데이터베이스를 탑재할 수 없습니다.

사용자 작업

이 문제를 해결하려면 다음 중 하나 이상을 수행합니다.

  • 다음 절차를 사용하여 누락된 트랜잭션 로그 파일 및 그 위치를 확인합니다. 그런 다음 해당 파일을 저장소 그룹에 대한 트랜잭션 로그 디렉터리로 이동합니다.

  • 백업에서 영향을 받는 데이터베이스를 복원합니다.

주의:
누락된 특정 트랜잭션 로그 파일을 찾아서 복원하는 이전 솔루션이 실패하지 않은 경우에는 데이터베이스를 복원해서는 안 됩니다. 이렇게 하면 마지막으로 백업한 이후의 모든 데이터를 덮어쓰게 됩니다.
참고:
데이터베이스를 복원하기 전에 대상 경로에서 영향을 받는 저장소 그룹과 연결된 트랜잭션 로그 파일을 이동 또는 삭제합니다.
Exchange Server 2003 및 Exchange Server 2007에서 Microsoft Exchange Troubleshooting Assistant를 사용하여 누락된 트랜잭션 로그 파일을 식별하려면 다음을 수행합니다.

  1. Microsoft Exchange Troubleshooting Assistant의 이벤트 로그 검사 결과 표시 창에서 관련된 데이터베이스 복구 관리 작업을 사용하여 이 문제 확인 및 해결 링크를 클릭하여 누락된 필수 트랜잭션 로그 파일을 식별합니다.

  2. 1단계에서 보고된 로그 파일 이름을 기록합니다.

  3. 로그 파일의 현재 위치를 확인하고 이 파일을 필요한 위치로 다시 이동합니다.
참고:
누락된 트랜잭션 로그 파일의 현재 위치를 확인하려면 휴지통 및 바이러스 검색 격리 폴더를 검색해야 합니다.
  1. 영향을 받는 Exchange 데이터베이스를 탑재해 봅니다.

 Exchange 2000 Server 또는 Exchange Server 2003에서 누락된 트랜잭션 로그를 수동으로 식별 및 복원하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버를 차례로 확장하고 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭에서 트랜잭션 로그 위치 아래에 트랜잭션 로그 파일의 위치 경로를 기록합니다.

  4. 명령 프롬프트에서 Eseutil.exe가 있는 디렉터리를 엽니다. Exchange 2000 Server 및 Exchange Server 2003에서 Eseutil.exe의 기본 경로는 C:\program files\exchsrvr\bin입니다.

  5. 명령 프롬프트에 다음 명령을 입력합니다.

    코드 복사
    eseutil /ml "logpath\logprefix"

    여기서 logpath는 3단계에서 기록한 트랜잭션 로그 파일의 경로이며 logprefix 는 트랜잭션 로그 파일의 접두사로, 대개 e00입니다.

    기본값을 사용할 경우 이 명령의 예는 다음과 같습니다.

    eseutil /ml "c:\program files\exchsrvr\mdbdata\e00".

  6. 누락된 로그 파일에 따라 누락된 트랜잭션 로그 파일이 다음 두 가지 형식 중 하나로 보고됩니다.

    • 누락된 로그 파일: c:\program files\exchsrvr\mdbdata\E0002BE2.log

    • 오류: 로그 파일이 누락되었습니다. 로그 파일 생성 번호가 11,235(0x2BE3)이지만 11,234(0x2BE2)가 필요합니다.

    여기서 0x2BE2는 누락된 로그 파일 E0002BE2.log입니다.

  7. 6단계에서 보고된 로그 파일 이름을 기록합니다.

  8. 로그 파일의 현재 위치를 확인하고 3단계에서 이 파일을 필요한 위치로 다시 이동합니다.
참고:
누락된 트랜잭션 로그 파일의 현재 위치를 확인하려면 휴지통 및 바이러스 검색 격리 폴더를 검색해야 합니다.
  1. 영향을 받는 Exchange 데이터베이스를 탑재해 봅니다.

 Exchange Server 2007에서 누락된 트랜잭션 로그를 수동으로 식별 및 복원하려면 다음을 수행합니다.

  1. 저장소 그룹이 있는 서버에서 Exchange 관리 콘솔을 시작합니다.

  2. 콘솔 트리에서 서버 구성을 확장하고 사서함을 클릭합니다.

  3. 결과 창에서 누락된 트랜잭션 로그 파일을 복원할 저장소 그룹이 포함된 사서함 서버를 클릭합니다.

  4. 저장소 그룹을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  5. . 일반 탭에서 로그 경로 아래에 트랜잭션 로그 파일의 위치 경로를 기록합니다.

  6. 명령 프롬프트에서 Eseutil.exe가 있는 디렉터리를 엽니다. Exchange Server 2007 Eseutil은 기본 Exchange 설치 폴더에 있습니다. 기본 Exchange 설치 폴더는 <SystemDrive>:\Program Files\Microsoft\Exchange Server\Bin입니다.

  7. 명령 프롬프트에 다음 명령을 입력합니다.

    코드 복사
    eseutil /ml "logpath\logprefix"

    여기서 logpath는 5단계에서 기록한 트랜잭션 로그 파일의 경로이며 logprefix 는 트랜잭션 로그 파일의 접두사로, 대개 e00입니다.

    기본값을 사용할 경우 이 명령의 예는 다음과 같습니다.

    eseutil /ml "c:\Program Files\Microsoft\Exchange Server\Bin\e00".

  8. 누락된 로그 파일에 따라 누락된 트랜잭션 로그 파일이 다음 두 가지 형식 중 하나로 보고됩니다.

    • 누락된 로그 파일: c:\Program Files\Microsoft\Exchange Server\Bin\E000000049A.log

    • 오류: 로그 파일이 누락되었습니다. 로그 파일 생성 번호가 11,235(0x2BE3)이지만 11,234(0x2BE2)가 필요합니다.

    여기서 0x2BE2는 누락된 로그 파일 E0002BE2.log입니다.

  9. 8단계에서 보고된 로그 파일 이름을 기록합니다.

  10. 로그 파일의 현재 위치를 확인하고 5단계에서 이 파일을 필요한 위치로 다시 이동합니다.
참고:
누락된 트랜잭션 로그 파일의 현재 위치를 확인하려면 휴지통 및 바이러스 검색 격리 폴더를 검색해야 합니다.
  1. 영향을 받는 Exchange 데이터베이스를 탑재해 봅니다.

ESE 이벤트 454에 대한 자세한 내용은 "이벤트 및 오류 메시지 센터"(http://go.microsoft.com/fwlink/?LinkId=81883)를 참조하십시오.


ESE 455 -1811(0xfffff8ed): 현재(Exx.log) 트랜잭션 로그 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-05-31

Microsoft Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 -1811(0xfffff8ed)인 ESE 455 이벤트를 하나 이상 검색했습니다. 이 이벤트는 현재 트랜잭션 로그(exx.log)가 없거나 액세스할 수 없거나 서명이 일치하지 않음을 나타냅니다.

설명

이 오류의 원인은 다음과 같습니다.

  • JET_errFileNotFound에 해당되는 오류 1811입니다. 이 문제는 일치하지 않는 서명 및 내부 로그 생성 번호(LGeneration)가 있는 Exchange 로그 파일에서 발생합니다. 일반적으로 Exchange 로그 파일은 E00.log 파일입니다. E00.log 파일의 서명이 일치하지 않으면 데이터베이스가 일치하더라도 정보 저장소가 탑재되지 않습니다.

  • 바이러스 백신 프로그램이 현재 Exchange 로그 파일을 격리 또는 삭제합니다.

  • 해당 데이터베이스에서 eseutil /p 복구 명령이 실행되었으며 로그 파일이 제거되지 않았습니다.

  • 이 예제의 eseutil /r Exx.log와 같이 잘못된 로그 파일 기본 이름으로 eseutil /r 복구 명령이 실행되었습니다. 여기서 Exx.log는 세 자로 이루어진 로그 파일 기본 이름입니다.

이 오류는 오류 -1811인 JET_errFileNotFound로 식별될 수 있습니다. 이 오류는 다음 버전의 Exchange 서버에 적용됩니다.

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

사용자 작업

이 오류를 해결하려면 다음 중 하나 이상을 수행합니다.

  • 로그 파일의 서명 및 로그 생성 번호가 일치하지 않으면 Microsoft 기술 지원 서비스에 문의하십시오. 자세한 내용은 Microsoft 고객지원 웹 사이트의 문의처 페이지를 방문하십시오.

  • 바이러스 백신 프로그램이 현재 Exchange 로그 파일을 격리 또는 삭제할 경우 다음 단계를 수행합니다.

    • 바이러스 백신 프로그램의 구성을 검토합니다.

    • 바이러스 백신 프로그램이 Exchange Server 디렉터리를 검색하도록 구성되지 않아야 합니다.

    • 기본적으로 일부 바이러스 백신 프로그램은 수동 또는 자동 모드로 매주 드라이브 및 디렉터리를 검색하도록 설정되어 있습니다. 이 설정은 그냥 지나쳐 버리기 쉽습니다. 바이러스 백신 프로그램의 제외 위치에 Exchange Server 디렉터리를 추가해야 합니다. Exchange에서 작동하도록 바이러스 백신 프로그램을 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 823166, Exchange Server 2003 및 바이러스 백신 소프트웨어 개요를 참조하십시오.

    • 바이러스 백신 프로그램 로그 파일을 검토하여 Exchange 로그 파일이 격리 또는 삭제되었는지 확인합니다.

    다음 방법 중 하나를 사용하여 Exchange 로그 파일을 복구합니다.

방법 1: Exchange 로그 파일이 격리된 경우

  1. 프로덕션 로그 파일이 포함된 폴더로 Exchange 로그를 복구합니다.

  2. Microsoft Exchange Information Store 서비스를 시작합니다. 누락된 로그 파일이 없으면 데이터베이스가 탑재됩니다. 누락된 로그 파일이 있으면 해당 파일이 바이러스 백신 프로그램의 격리 폴더에 있는지 여부를 확인합니다. 해당 로그 파일이 격리 폴더에 없으면 방법 2를 참조하십시오.

Exchange 로그 파일이 삭제된 경우 백업에서 저장소 그룹 데이터베이스를 복원해야 합니다. 그런 다음 로그 파일을 재생해야 합니다. 사용 가능한 데이터베이스를 복원하려면 다음 단계를 따르십시오.

방법 2: Exchange 로그 파일이 삭제된 경우

  1. 일치하지 않는 모든 데이터베이스를 백업 폴더로 이동합니다.

  2. 새 E00.log 파일이 만들어진 경우 해당 새 E00.log 파일을 백업 폴더로 이동합니다. 또한 E00.chk 파일을 백업 폴더로 이동합니다.

  3. 기존의 모든 로그 파일을 백업 폴더로 복사합니다.참고 로그 파일을 복사해야 하며 이동하지 마십시오.

  4. 마지막 E00*.log 파일 이름을 E00.log로 바꿉니다.

  5. 백업에서 데이터베이스를 복원합니다. 그런 다음 로그 파일을 재생합니다. 이렇게 하면 데이터베이스가 일치 상태로 됩니다. 그러나 데이터베이스에는 백업 폴더로 복사된 E00.log 파일이 포함되지 않습니다. 데이터 손실이 있긴 하지만 이제 탑재할 수 있는 데이터베이스가 있습니다.

    참고:
    백업에서 데이터베이스를 복원할 수 없으면 데이터베이스에 대해 복구 유틸리티를 실행하여 데이터베이스를 일치 상태로 만듭니다.

  6. Microsoft Exchange Information Store 서비스를 시작합니다.

해당 데이터베이스에서 eseutil /p 복구 명령이 실행되었으며 로그 파일이 제거되지 않은 경우 다음 단계를 따르십시오.

eseutil /p 명령 실행 여부를 확인하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 cmd를 입력한 다음 확인을 클릭합니다.

  2. 명령 프롬프트에 다음을 입력합니다.

    코드 복사
    c:\program files\exchsrvr\bin\eseutil /mh "c:\program files\exchsrvr\mdbdata\<name of Exchange database.edb>"

    이 구문은 다음을 가정합니다.

    • Exchange Server 프로그램 파일이 c:\program files\exchsrvr 폴더에 설치되어 있습니다.

    • 데이터베이스가 c:\program files\exchsrvr\mdbdata 폴더에 있습니다.

  3. 복구 횟수 특성을 읽습니다. 복구 횟수 특성이 0이면 eseutil /p 명령이 실행되지 않은 것입니다. 복구 횟수 특성이 0이 아니면 eseutil /p 명령이 데이터베이스에서 실행된 것입니다.

공용 및 개인 데이터베이스가 일치 상태 또는 완전한 종료 상태이면 트랜잭션 로그 파일을 다른 폴더로 이동할 수 있습니다. 데이터베이스가 일관성 있는 상태 또는 완전하게 종료 상태인지 여부를 확인하려면 다음 단계를 따르십시오.

데이터베이스가 일치 상태 또는 완전한 종료 상태인지 여부를 확인하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 cmd를 입력한 다음 확인을 클릭합니다.

  2. 개인 정보 저장소를 검사하려면 다음을 입력하십시오.

    코드 복사
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\priv1.edb"

  3. 공용 정보 저장소를 검사하려면 다음을 입력하십시오.

    코드 복사
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\pub1.edb"

    2-3단계의 구문은 다음을 가정합니다.

    • Exchange Server 프로그램 파일이 c:\program files\exchsrvr 폴더에 설치되어 있습니다.

    • 데이터베이스가 c:\program files\exchsrvr\mdbdata 폴더에 있습니다.

  4. 일관성 검사 결과를 검토합니다. 데이터베이스가 일치하는 경우(상태 = 완전한 종료) 모든 로그 파일이 정보 저장소에 커밋되었습니다. 데이터베이스가 불일치하는 경우(상태 = 부적절한 종료)에도 데이터베이스가 손상되지 않을 수 있습니다. 로그 파일이 데이터베이스에 아직 커밋되지 않은 것일 수 있습니다.

  5. 상태가 완전한 종료를 보고할 경우 모든 mdbdata 디렉터리의 모든 로그 파일을 백업 폴더로 이동하십시오.

  6. 데이터베이스를 탑재합니다.
  • eseutil /r 복구 명령이 잘못된 로그 파일 기본 이름을 사용하여 실행된 경우 올바른 스위치를 사용하여 명령을 실행하십시오. 일반 로그 파일 기본 이름은 e00, e01, e02 및 e03입니다. 예를 들어 다음 명령에는 올바른 로그 파일 기본 이름이 포함되어 있습니다.

    코드 복사
    eseutil /r e00
  • 이 문제가 지속되면 Microsoft 기술 지원 서비스에 문의하십시오. 자세한 내용은 Microsoft 고객지원 웹 사이트의 문의처 페이지를 방문하십시오.


ESE 474 -1018: 데이터베이스에서 복구할 수 없는 오류가 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-03-28

Microsoft Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 -1018의 ESE 474 이벤트를 하나 이상 검색했습니다. 이 오류는 Microsoft Exchange 무결성 확인 구성 요소가 Exchange Server에서 하드 디스크 하위 시스템으로부터 Exchange 데이터베이스 파일 데이터를 제대로 저장하거나 검색할 수 없음을 확인하는 경우 생성됩니다.

설명

-1018 오류가 포함된 ESE 474 이벤트는 하드 디스크 하위 시스템 하드웨어 구성 요소에 결함이 있거나, 하드 디스크 하위 시스템의 드라이버 및/또는 펌웨어가 오래되었거나 호환되지 않는 경우 발생할 수 있습니다.

-1018 오류가 발생하고 나면 서버에 대해 실행되는 진단 하드웨어 테스트에서 디스크 하위 시스템 하드웨어 문제를 보고하지 않을 수 있으며, 일반적으로는 Exchange Server 때문에 이 문제가 발생한다고 보면 됩니다.

Microsoft 및 하드웨어 공급업체에서 실시한 광범위한 조사 결과 대부분의 -1018 오류는 드라이버 및/또는 펌웨어를 제공하는 디스크 하위 시스템 하드웨어 구성 요소 때문에 발생하는 것으로 나타났습니다.

Exchange 는 데이터베이스 파일에서 다음과 같은 조건의 초기화된 페이지가 발견되는 경우 -1018 오류를 보고합니다.

  • 페이지에 저장된 체크섬이 페이지를 읽을 때 수행한 체크섬 다시 계산 결과와 일치하지 않습니다.

  • 페이지에 저장된 페이지 번호가 데이터베이스 파일에서 해당 페이지의 실제 위치를 기반으로 페이지에 기록된 페이지 번호와 일치하지 않습니다.

다음 시나리오 중 하나가 발생하는 경우 Exchange 에서 자체적으로 -1018 오류를 생성할 수도 있습니다.

  • Exchange 에서 체크섬이 잘못된 페이지를 작성합니다.

  • Exchange 에서 페이지를 올바르게 작성하지만 운영 체제에 페이지를 잘못된 위치에 쓰도록 지시합니다.

Exchange 는 모든 데이터를 페이지에 쓴 후에 디스크에 쓸 예정인 페이지에 대해 체크섬을 생성합니다. 여기에는 페이지 번호도 포함됩니다. Exchange 는 페이지에 체크섬을 추가한 후에 Exchange 는 Windows 운영 체제에 게시된 표준 Windows 기반 API를 사용하여 디스크에 페이지를 쓰도록 지시합니다.

이때 일시적인 메모리 오류로 인해 하드 디스크에서 잘못된 위치에 페이지를 쓸 가능성이 있습니다.

그러면 페이지 체크섬이 올바른 경우에도 논리 페이지 번호가 실제 페이지 번호와 일치하지 않으므로 Exchange 는 -1018 오류를 보고합니다.

일반적으로 Exchange 데이터베이스에서 보고되는 단일 -1018 오류로 인해 Exchange 데이터베이스가 중지되거나 -1018 오류가 발생했다는 것 자체를 제외한 다른 증상이 발생하지는 않습니다. 오류에 해당하는 페이지가 보낸 편지함이나 지운 편지함 폴더 등 그다지 자주 액세스하지 않는 폴더에 있을 수도 있고 거의 열지 않거나 비어 있는 첨부 파일에 들어 있을 수도 있습니다.

이와 같이 단일 -1018 오류로 인해 광범위한 데이터 손실이 발생할 가능성은 거의 없지만, 이 오류는 저장소 시스템이 적어도 한 번 이상 데이터를 안정적으로 저장하거나 검색하지 못했음을 나타내므로 문제가 될 수 있습니다. -1018 오류는 향후 보다 심각한 상태가 될 수 있는 문제를 초기에 경고하는 오류입니다. 첫 -1018 오류가 데이터베이스의 빈 페이지에 대해 보고되었다 하더라도 다음에 손상될 페이지는 알 수가 없습니다. 중요한 글로벌 테이블이 손상되는 경우에는 Exchange 데이터베이스가 시작되지 않으며 데이터베이스 복구를 수행할 수 없거나 부분적으로만 수행할 수 있습니다.

-1018 오류가 기록되면 오류의 근본 원인을 찾을 때까지 즉시 발생할 수 있는 오류 또는 추가적인 임의 손상의 가능성을 고려하고 이에 대한 대비책을 계획하십시오.

사용자 작업

응용 프로그램 로그에 기록된 ESE 474 -1018 오류를 해결하기 전에 서버의 디스크 하위 시스템이 안정적인지 확인하십시오.

디스크 하위 시스템의 문제를 해결하려면 다음을 수행합니다.

  1. 응용 프로그램 로그를 열고 ESE 474 이벤트를 검색합니다. 각 이벤트에 대해 이벤트가 적용되는 데이터베이스의 전체 경로를 기록해 둡니다. 이벤트가 적용되는 데이터베이스의 목록을 컴파일한 후에 데이터베이스 경로에서 참조되는 드라이브 문자를 기록해 둡니다. 이 정보를 사용하면 해당 실제 디스크에 대해 직접 문제 해결 작업을 수행할 수 있습니다.

  2. 디스크 읽기, 쓰기 또는 시간 초과 오류가 기록되지 않았는지 시스템 로그를 검토합니다.

  3. 제조업체에서 제공한 디스크 하위 시스템 진단 유틸리티를 사용하고, 디스크 하위 시스템의 무결성 확인에 필요한 도움을 추가로 받으려면 디스크 하위 시스템 하드웨어 공급업체에 문의하십시오.

디스크 하위 시스템의 문제를 해결했거나 시스템의 안정성을 확인했으면 다음 방법을 사용하여 -1018 오류를 복구합니다. 복구 방법은 높은 선호도 또는 사용 빈도순으로 나열되어 있습니다.

첫 번째 방법 응용 프로그램 로그의 ESE 474 이벤트에 참조되어 있는 데이터베이스에서 사서함을 이동합니다. 사서함은 성공한 기존 저장소로 이동하거나, 이러한 용도로 사용할 사서함 저장소를 새로 만듭니다. 사서함을 모두 이동하고 나서 손상된 사서함 저장소를 삭제합니다.

Exchange 2000 Server 또는 Exchange Server 2003에서 사서함을 이동하려면 다음을 수행합니다.

  1. Active Directory 사용자 및 컴퓨터에서 이동할 사서함을 소유한 사용자를 선택합니다.

  2. 이전 단계에서 선택한 사용자 목록을 마우스 오른쪽 단추로 클릭한 다음 Exchange 작업을 클릭합니다.

  3. Exchange 작업 마법사의 사용 가능한 작업 페이지에서 사서함 이동을 클릭한 후 다음을 클릭합니다.

  4. 지침을 주의 깊게 읽고 마법사의 나머지 단계를 수행합니다.
Exchange Server 2003에서만 사서함을 이동하려면 다음을 수행합니다.

  1. Exchange 시스템 관리자에서 서버, 사서함을 이동해올 서버, 사서함을 이동해올 저장소 그룹, 이동할 사서함이 포함되어 있는 사서함 저장소를 차례로 확장한 다음 사서함을 클릭합니다.

  2. 세부 정보 창에서 이동할 사서함을 소유한 사용자를 마우스 오른쪽 단추로 클릭한 다음 Exchange 작업을 클릭합니다.

  3. Exchange 작업 마법사의 사용 가능한 작업 페이지에서 사서함 이동을 클릭한 후 다음을 클릭합니다.

  4. 지침을 주의 깊게 읽고 마법사의 나머지 단계를 수행합니다.
Exchange 관리 콘솔(Exchange Server 2007에만 해당)을 사용하여 사서함을 이동하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 시작합니다.

  2. 콘솔 트리에서 받는 사람 구성을 확장하고 사서함을 클릭합니다.

  3. 결과 창에서 이동할 사서함을 클릭합니다.

  4. 작업 창에서 사서함 이동을 클릭합니다.

  5. 사서함 이동 마법사의 소개 페이지에서 사서함을 이동할 서버, 저장소 그룹 및 사서함 데이터베이스를 선택하고 다음을 클릭합니다.

  6. 이동 옵션 페이지에서 사서함의 손상된 메시지를 처리하는 옵션을 선택하고 다음을 클릭합니다.

  7. 이동 일정 페이지에서 이동을 수행할 시간을 지정하고 다음을 클릭합니다.

  8. 사서함 이동 페이지에서 요약을 검토하여 사서함 이동을 확인하고 이동을 클릭합니다.

  9. 완료 페이지에서 마침을 클릭합니다.

사서함 이동 마법사 및 Move-Mailbox cmdlet 사용을 위해 지원되는 시나리오에 대한 자세한 내용은 Exchange Server 2007 제품 설명서에서 "사서함 이동"(http://go.microsoft.com/fwlink/?LinkId=85754)을 참조하십시오.

두 번째 방법 성공한 백업에서 데이터베이스를 복원합니다. Exchange Server 데이터베이스를 복원하는 방법에 대한 자세한 내용은 다음 문서를 참조하십시오.

  • Exchange Server 2007 "재해 복구"(http://go.microsoft.com/fwlink/?LinkId=85802)

  • "Exchange 2003 재해 복구 작업 가이드"(http://go.microsoft.com/fwlink/?linkid=30250)

세 번째 방법 Eseutil을 사용하여 이벤트가 적용된 데이터베이스에 대해 하드 복구를 수행합니다. 이 방법은 앞의 두 방법이 실패한 경우에만 수행해야 합니다. 하드 복구를 실행한 후에는 복구된 데이터베이스에 대해 오프라인 조각 모음도 수행해야 하며 Isinteg 도구를 실행하여 논리적 손상을 복구해야 합니다. 이러한 단계는 Exchange 데이터베이스 문제 해결사 복구 작업을 사용하여 수행할 수 있습니다. 이 작업을 수행하면 Eseutil /P, Eseutil /D 및 Isinteg 관리가 자동으로 실행됩니다.

추가 정보

이 문제에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서 및 Exchange 리소스를 참조하십시오.

  • 314917, "-1018, -1019 및 -1022 Exchange 데이터베이스 오류 이해 및 분석"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314917)

  • 867626, "New error correcting code is included in Exchange Server 2003 SP1"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=867626)

  • 259851, "Exchange에서 eseutil /p 또는 edbutil /d /r 명령을 실행할 때의 효과"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=259851)

  • "Exchange Server Error -1018"(http://go.microsoft.com/fwlink/?LinkId=85807)


MSExchangeIS 1003: Exchange 데이터베이스 드라이브의 사용 가능한 공간 부족
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-22

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 MSExchangeIS 1003 이벤트를 하나 이상 검색했습니다. 이 오류는 탑재하려는 데이터베이스가 포함된 드라이브에 사용 가능한 공간이 부족한 경우 발생할 수 있습니다.

설명

Exchange 데이터베이스가 포함된 디스크에 사용 가능한 공간이 부족한 경우 Microsoft Exchange Information Store 서비스는 MSExchangeIS 1003 이벤트를 기록하며 해당되는 데이터베이스가 분리됩니다. 이 오류가 발생하면 해당 저장소 그룹의 데이터베이스를 탑재하지 못할 수 있습니다. 이 오류는 다음 버전의 Exchange 서버에 적용됩니다.

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

사용자 작업

이 문제를 해결하려면 데이터베이스 드라이브에서 디스크 공간을 어느 정도 확보한 후 데이터베이스를 다시 탑재해 봅니다. 이를 위해 다음 중 하나 이상을 수행합니다.

  • 하드 디스크에 Exchange 데이터베이스 파일만 있을 경우 데이터베이스의 오프라인 조각 모음을 수행하여 디스크 공간을 확보해야 합니다.

    참고:
    데이터베이스의 사용 가능한 공간 크기에 따라 이 단계로 문제가 해결되지 않을 수 있습니다.
    이 단계 수행에 대한 자세한 내용은 Microsoft 기술 자료 문서 328804, Exchange 데이터베이스 조각 모음 방법을 참조하십시오.

    또한 How to Run Eseutil /D (Defragmentation)를 참조하십시오.

  • Exchange 트랜잭션 로그 파일도 이 드라이브에 있는 경우 불필요한 로그 파일을 제거하여 사용 가능한 공간을 확보할 수 있습니다.

    이 단계 수행에 대한 자세한 내용은 Microsoft 기술 자료 문서 240145, Exchange Server 트랜잭션 로그 파일을 제거하는 방법을 참조하십시오.


MSExchangeIS 1088: 잘못된 legacyExchangeDN으로 인해 데이터베이스를 탑재할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Database Troubleshooter Tool이 MSExchangeIS 1088 이벤트를 검색했습니다. 이 이벤트는 legacyExchangeDN 특성 값이 Active Directory에 저장된 것과 다르기 때문에 Exchange 데이터베이스를 탑재할 수 없음을 나타냅니다.

설명

MSExchangeIS 1088 이벤트는 legacyExchangeDN 특성 값이 원래 관리 그룹의 특성 값과 다른 관리 그룹으로 Exchange 데이터베이스가 복원된 경우에 발생할 수 있습니다. 이 동작은 의도된 것입니다. Exchange Server에서 저장소를 탑재하려면 Exchange 데이터베이스의 조직 및 관리 그룹의 legacyExchangeDN 특성 값이 Active Directory의 조직 및 관리 그룹의 legacyExchangeDN 특성 값과 일치해야 합니다.

사용자 작업

이 문제를 해결하려면 다음을 수행합니다.

  • Exchange 데이터베이스를 원래 관리 그룹으로 복원합니다.

  • Exchange 데이터베이스를 원래 관리 그룹으로 복원할 수 없는 경우 원하는 대상의 Active Directory 개체 이름을 변경하여 Exchange 데이터베이스와 동일한 legacyExchangeDN 특성 값을 갖도록 합니다. ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 도구를 사용하여 값을 수정할 수 있습니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 오류를 해결하려면 다음을 수행합니다.

  1. ADSI 편집이나 비슷한 도구를 사용하여 Active Directory에서 관리 그룹 개체를 찾습니다.

    legacyExchangeDN 특성은 다음 위치에 있습니다.

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. 다음 형식으로 새 문자열 값을 입력합니다.

    /o= organization /ou= administrative group

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 2003 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.

MSExchangeIS 이벤트 1088에 대한 자세한 내용은 다음 리소스를 참조하십시오.

  • 이벤트 및 오류 메시지 센터

  • Microsoft 기술 자료 문서 280652, "XADM: "Event ID 1088" Is Logged and Store Fails to Mount"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=280652)


MSExchangeIS 5000(0x3f5): 정보 저장소 서비스에 대한 서비스 계정이 잘못 구성되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-02-27

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0x3f5의 MSExchangeIS 5000 이벤트를 하나 이상 검색했습니다. 이 오류는 Microsoft Exchange Information Store 서비스가 로컬 시스템 이외의 계정으로 시작되도록 구성된 경우에 발생합니다.

설명

이 문제는 Microsoft Exchange Information Store 서비스(Store.exe)가 로컬 시스템 계정 이외의 계정을 사용하거나 도메인 컨트롤러, 도메인 또는 로컬 컴퓨터 보안 정책의 보안 감사 생성 정책에 로컬 서비스 계정이 포함되지 않은 경우에 발생할 수 있습니다. 이 문제가 발생하면 Exchange 정보 저장소 서비스가 초기화되지 않습니다. 이 오류는 다음 버전의 Exchange 서버에 적용됩니다.

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

사용자 작업

이 문제를 해결하려면 다음 중 하나 이상을 수행합니다.

  • 기본적으로 Exchange 정보 저장소 서비스는 로컬 시스템 계정을 사용하여 정보 저장소 서비스(MACHINENAME$)를 시작합니다. Services.msc 스냅인을 사용하여 정보 저장소 서비스를 시작하는 데 사용되는 계정이 무엇인지 확인합니다. 로컬 시스템 계정이 사용되는 경우 로컬 시스템 계정에 보안 감사 생성 권한을 부여해야 합니다. 이 작업을 수행하려면 다음 방법 중 하나를 수행합니다.

    • 이 컴퓨터에서 Exchange Setup /domainprep 명령을 다시 실행합니다.

    • 다음 정책 중 하나에서 로컬 시스템 계정에 보안 감사 생성 권한을 수동으로 부여합니다.

    1. 도메인 컨트롤러의 정책

    2. 도메인 정책

    3. 로컬 컴퓨터 보안 정책

      구성원 서버의 로컬 컴퓨터 보안 정책에 이 권한을 다시 부여하려면 다음 단계를 수행합니다.

      참고:
      한 서버에서만 이 문제가 발생하는 경우 이 방법을 사용하는 것이 좋습니다.
      구성원 서버의 로컬 컴퓨터 보안 정책에 감사 권한을 다시 부여하려면 다음을 수행합니다.

      1. 시작, 관리 도구, 로컬 보안 정책을 차례로 클릭합니다.

      2. 보안 설정을 확장하고 로컬 정책, 사용자 권한 할당을 차례로 클릭합니다.

      3. 오른쪽 창에서 보안 감사 생성을 두 번 클릭하고 추가를 클릭한 다음 MACHINENAME$을 입력하고 확인을 두 번 클릭합니다.

      4. 그룹 정책 스냅인을 종료합니다.
  • 로컬 시스템 계정 이외의 계정을 사용하여 정보 저장소 서비스를 시작하는 경우 해당 계정을 다시 로컬 시스템 계정(MACHINENAME$)으로 변경해야 합니다. 그런 다음 정보 저장소 서비스를 시작합니다. Exchange 2000 Server 및 Exchange Server 2003에서 로컬 시스템 계정을 사용하여 Exchange 서비스를 시작하는 이유에 대한 자세한 내용은 Microsoft 기술 자료 문서 239762, Exchange S ervices R un U nder LocalSystem을 참조하십시오.

자세한 정보

자세한 내용은 Microsoft 기술 자료 문서 281850, Information store does not start with event ID 9530 and 5000 messages in Exchange 2000 Server and in Exchange Server 2003을 참조하십시오.


MSExchangeIS 5000(0x80004005): 서비스 계정이 잘못되었거나 SeSecurityPrivilege 권한이 없거나 그룹 구성원이 잘못되었기 때문에 데이터베이스를 탑재할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-02-19

Microsoft Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0x80004005의 MSExchangeIS 5000 이벤트를 하나 이상 검색했습니다. 이 이벤트는 서비스 계정이 잘못되었거나 SeSecurityPrivilege 권한이 없거나 그룹 구성원이 잘못되었기 때문에 Exchange 서버의 데이터베이스를 탑재할 수 없음을 나타냅니다.

설명

이 이벤트는 다음 조건에 해당되는 경우 발생할 수 있습니다.

  • 하나 이상의 도메인 컨트롤러에 있는 Exchange Enterprise Servers 그룹에서 감사 및 보안 로그 관리 권한(SeSecurityPrivilege)이 제거되었습니다. Exchange Enterprise Servers 그룹에는 도메인의 모든 도메인 컨트롤러에 대한 감사 및 보안 로그 관리 권한이 있어야 합니다. 이 조건에 해당되는 경우 하나 이상의 Exchange Server 관련 서비스가 시작되지 않습니다.

  • Microsoft Exchange Information Store 서비스가 로컬 시스템 계정 이외의 계정으로 시작되거나 도메인 컨트롤러, 도메인 또는 로컬 컴퓨터 보안 정책의 보안 감사 생성 정책에 로컬 서비스 계정이 포함되어 있지 않습니다. 이 조건에 해당되는 경우 Exchange 정보 저장소 서비스가 시작되지 않습니다.

  • 부모 도메인의 Exchange Enterprise Servers 그룹에 자식 도메인의 Exchange Domain Servers 그룹이 포함되어 있지 않습니다.

이 이벤트는 MAPI_E_CALL_FAILED로 식별될 수도 있습니다. 이 이벤트는 다음 버전의 Exchange 서버에 적용됩니다.

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

사용자 작업

이 문제를 해결하려면 다음 중 하나 이상을 수행합니다.

  • 하나 이상의 도메인 컨트롤러에 있는 Exchange Enterprise Servers 그룹에서 감사 및 보안 로그 관리 권한(SeSecurityPrivilege)이 제거된 경우 다음 단계를 따르십시오.

    하나 이상의 도메인 컨트롤러에서 사용 권한을 추가하려면 다음을 수행합니다.

    1. Policytest.exe를 사용하여 사용 권한 문제를 해결합니다. Policytest.exe는 Exchange 2000 Server CD의 Support\Utils\I386 폴더 또는 Exchange Server 2003 CD의 Support\ExDeploy 폴더에 있습니다. Policytest.exe를 사용하여 Exchange Enterprise Servers 그룹에 대한 "감사 및 보안 로그 관리" 권한이 도메인 컨트롤러에 없는지 여부를 확인합니다. 결과가 성공적이면 다음과 비슷한 정보가 반환됩니다.

      Local domain is "<contoso.com>" (contoso) Account is "CONTOSO\Exchange Enterprise Servers" DC = "<ComputerName>" In site = "<Default-First-Site-Name>" Right found: "SeSecurityPrivilege"

      참고 성공적인 결과에는 "감사 및 보안 로그 관리" 권한이 있다고 표시됩니다. Policytest.exe를 실행하려면 도메인 관리자 권한이 있어야 합니다. Policytest.exe 유틸리티에 대한 자세한 내용은 Microsoft 기술 자료 문서 281537, XADM: Description of the Policytest.exe Utility를 참조하십시오.

    2. 도메인 수준에서 Exchange Enterprise Server 기본 사용 권한을 다시 설정합니다. 이렇게 하려면 다음 단계를 수행합니다.

      1. Exchange Server CD 또는 네트워크 설치 지점에서 setup /domainprep 명령을 실행합니다. setup /domainprep 명령을 실행하면 Exchange Enterprise Servers 그룹이 기본 사용 권한을 갖는 도메인에 추가됩니다. 또한 이 명령을 실행하면 한 도메인 컨트롤러에 사용 권한이 즉시 추가되고 변경 내용이 다른 도메인 컨트롤러로 복제됩니다.

      2. 사용 권한 상속을 다른 조직 단위로 복원합니다. 그런 다음 도메인 컨트롤러가 도메인 전체에 변경 내용을 복제할 때까지 기다립니다.

      3. Policytest.exe를 실행합니다. 다음과 같은 성공적인 결과를 반환한 도메인 컨트롤러를 확인합니다.

        Right found: "SeSecurityPrivilege"

        모든 도메인 컨트롤러에 올바른 사용 권한이 있으면 Exchange Server 서비스를 다시 시작하고 모든 도메인 컨트롤러에 올바른 사용 권한이 없으면 3단계를 참조하십시오.

    3. 기본 도메인 컨트롤러의 정책을 확인합니다. 이렇게 하려면 다음 단계를 수행합니다.

      1. Active Directory 사용자 및 컴퓨터 스냅인을 시작합니다.

      2. 도메인 컨트롤러 컨테이너를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

      3. 그룹 정책 탭을 클릭한 다음 기본 도메인 컨트롤러 정책이 그룹 정책 개체 연결 상자에 있는지 확인합니다.참고 기본 도메인 컨트롤러 정책이 표시되지 않으면 추가를 클릭한 다음 기본 도메인 컨트롤러 정책을 클릭하고 확인을 클릭합니다. 그런 다음 이 변경 내용이 다른 모든 도메인 컨트롤러로 복제될 때까지 기다립니다.

      4. Exchange Server CD 또는 네트워크 설치 지점에서 setup /domainprep 명령을 실행합니다. setup /domainprep 명령을 실행하면 Exchange Enterprise Servers 그룹이 기본 사용 권한을 갖는 도메인에 추가됩니다.

      5. Policytest.exe를 실행합니다. 다음과 같은 성공적인 결과를 반환한 도메인 컨트롤러를 확인합니다.

      Right found: "SeSecurityPrivilege"

      모든 도메인 컨트롤러에 올바른 사용 권한이 있으면 Exchange Server 서비스를 다시 시작하고 일부 도메인 컨트롤러에 올바른 사용 권한이 없으면 4단계를 참조하십시오.

    4. 도메인 컨트롤러에 수동으로 사용 권한을 추가합니다. setup /domainprep 명령을 실행한 다음 FRS(파일 복제 서비스)가 업데이트된 보안 정책을 하나 이상의 도메인 컨트롤러로 복제하지 않을 수 있습니다. 이 문제가 발생하면 Exchange Enterprise Servers 그룹에 올바른 사용 권한을 수동으로 할당해야 합니다. 일부 도메인 컨트롤러 또는 모든 도메인 컨트롤러에 올바른 사용 권한이 없으면 Exchange Enterprise Servers 그룹에 "감사 및 보안 로그 관리" 권한을 할당하십시오. 그런 다음 이 설정이 다른 도메인 컨트롤러로 복제될 때까지 기다립니다. 이렇게 하려면 다음 단계를 수행합니다.

      1. Active Directory 사용자 및 컴퓨터 스냅인을 시작합니다.

      2. 도메인 컨트롤러 컨테이너를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

      3. 그룹 정책 탭을 클릭하고 그룹 정책 개체 연결 상자에서 기본 도메인 컨트롤러 정책을 클릭한 다음 편집을 클릭합니다.

      4. 컴퓨터 구성, Windows 설정, 보안 설정, 로컬 정책을 차례로 확장한 다음 사용자 권한 할당을 클릭합니다.

      5. 오른쪽 창에서 감사 및 보안 로그 관리를 두 번 클릭하고 추가, 찾아보기를 차례로 클릭한 다음 Exchange Enterprise Servers 그룹을 추가합니다.

      6. 사용자 또는 그룹 추가 대화 상자에서 확인을 클릭합니다. 그런 다음 확인을 다시 클릭합니다.

      7. 그룹 정책 스냅인을 끝낸 다음 도메인 컨트롤러 속성 대화 상자에서 확인을 클릭합니다.참고 사용자 또는 그룹 추가 대화 상자에서 찾아보기를 클릭할 때 Exchange Enterprise Servers 그룹이 보이지 않을 수도 있습니다. 이 동작이 발생하면 Exchange Domain Servers 그룹을 추가합니다. 그런 다음 setup /domainprep 명령을 다시 실행합니다. 이 프로세스를 수행하면 추가한 Exchange Enterprise Servers 그룹이 모든 도메인 컨트롤러에서 유지됩니다.
  • Exchange 정보 저장소 서비스가 로컬 시스템 이외의 계정으로 시작되거나 도메인 컨트롤러, 도메인 또는 로컬 컴퓨터 보안 정책의 보안 감사 생성 정책에 로컬 서비스 계정이 포함되어 있지 않은 경우 다음 해결 방법을 따르십시오.

    기본적으로 Exchange 정보 저장소 서비스는 로컬 시스템 계정을 사용하여 정보 저장소 서비스(MACHINENAME$)를 시작합니다. Services.msc 스냅인을 사용하여 정보 저장소 서비스를 시작하는 데 사용되고 있는 계정을 확인합니다. 로컬 시스템 계정이 사용되는 경우 로컬 시스템 계정에 보안 감사 생성 권한을 다시 부여해야 합니다. 이 작업을 수행하려면 다음 방법 중 하나를 수행합니다.

    로컬 시스템 계정에 보안 감사 생성 권한을 다시 부여하려면 다음을 수행합니다.

    1. 이 컴퓨터에서 Setup /domainprep 명령을 다시 실행합니다.

    2. 다음 정책 중 하나에서 로컬 시스템 계정에 보안 감사 생성 권한을 수동으로 부여합니다.

      • 도메인 컨트롤러의 정책

      • 도메인 정책

      • 로컬 컴퓨터 보안 정책

    구성원 서버의 로컬 컴퓨터 보안 정책에 보안 감사 생성 권한을 다시 부여하려면 다음을 수행합니다.

    1. 시작, 관리 도구, 로컬 보안 정책을 차례로 클릭합니다.

    2. 보안 설정을 확장하고 로컬 정책, 사용자 권한 할당을 차례로 클릭합니다.

    3. 오른쪽 창에서 보안 감사 생성을 두 번 클릭하고 추가를 클릭한 다음 MACHINENAME$을 입력하고 확인을 차례로 두 번 클릭합니다.

    4. 그룹 정책 스냅인을 끝냅니다.

    로컬 시스템 계정 이외의 계정을 사용하여 정보 저장소 서비스를 시작하는 경우 해당 계정을 다시 로컬 시스템 계정(MACHINENAME$)으로 변경해야 합니다. 그런 다음 정보 저장소 서비스를 시작합니다. Exchange 2000 Server 및 Exchange Server 2003에서 로컬 시스템 계정을 사용하여 Exchange 서비스를 시작하는 이유에 대한 자세한 내용은 Microsoft 기술 자료 문서 239762, Exchange Services Run Under LocalSystem을 참조하십시오.

  • 부모 도메인의 Exchange Enterprise Servers 그룹에 자식 도메인의 Exchange Domain Servers 그룹이 포함되어 있지 않은 경우 자식 도메인의 Exchange Domain Servers 그룹을 부모 도메인의 Exchange Enterprise Servers 그룹에 추가합니다. 루트 도메인에 받는 사람 업데이트 서비스를 만들어 이 문제를 해결할 수도 있습니다.

    이 문제를 해결하려면 원격 Windows 도메인의 서버에서 /domainprep 스위치를 사용하여 Exchange 설치 프로그램을 실행하십시오. 그런 다음 Exchange 서버에서 Exchange System Manager를 사용하여 원격 도메인에 대해 받는 사람 업데이트 서비스를 만듭니다. 이렇게 하려면 다음 단계를 수행합니다.

    원격 도메인에 대한 받는 사람 업데이트 서비스를 만들려면 다음을 수행합니다.

    1. 시작, 프로그램, Microsoft Exchange, System Manager를 차례로 클릭합니다.

    2. 조직 개체, 받는 사람 컨테이너를 차례로 확장합니다.

    3. 받는 사람 업데이트 서비스를 클릭합니다.

    4. 오른쪽 창에서 새로 만들기를 클릭한 다음 받는 사람 업데이트 서비스를 클릭합니다.

    5. 받는 사람 업데이트 서비스의 인스턴스가 없으며 Exchange에서 업데이트해야 하는 사용자가 있는 도메인을 클릭합니다.

    6. 다음을 클릭합니다.

    7. 받는 사람 업데이트 서비스를 실행할 서버를 선택한 다음 Exchange 특성을 갖는 필요한 모든 사용자를 처리합니다.

    8. 다음을 클릭합니다.

    9. 마침을 클릭합니다.

    10. 해당 도메인에서 받는 사람의 업데이트를 수동으로 시작하려면 받는 사람 업데이트 서비스를 마우스 오른쪽 단추로 클릭한 다음 지금 업데이트를 클릭하여 업데이트하도록 합니다.
    자세한 내용은 Microsoft 기술 자료 문서 253770, Tasks performed by the Exchange Recipient Update Service를 참조하십시오.


MSExchangeIS 5000(0x80040154): SMTP 서비스 확장이 없거나 손상되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-02-19

Microsoft Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0x80040154의 MSExchangeIS 5000 이벤트를 하나 이상 검색했습니다. 이 오류는 Exchange Server SMTP(Simple Mail Transfer Protocol) 서비스 확장이 없거나 손상된 경우 발생할 수 있습니다.

설명

이 문제는 Exchange SMTP 서비스 확장이 없거나 손상되었기 때문에 발생합니다. 이 동작으로 인해 Exchange와 SMTP 서비스 간의 기능이 손실됩니다. SMTP 서비스는 Microsoft Internet Information Services(IIS)의 하위 구성 요소로 설치되는 필수 서비스입니다.

이 오류는 다음과 같은 이유로 발생합니다.

  • IIS가 제거되었습니다.

  • SMTP 서비스 하위 구성 요소가 IIS에서 제거되었습니다.

  • IIS가 제거된 다음 필수 SMTP 서비스 하위 구성 요소가 없는 Windows 구성 요소로 다시 설치되었습니다.

  • IIS가 제거된 다음 적합한 하위 구성 요소 목록이 있는 Windows 구성 요소로 다시 설치되었습니다. 그러나 Exchange SMTP 서비스 확장이 다시 설치되지 않았습니다.

이 오류는 다음 버전의 Exchange 서버에 적용됩니다.

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

사용자 작업

이 오류를 해결하려면 Microsoft 기술 자료 문서 326305, The Information Store does not start and MSExchangeIS Event ID 5000 and 9538 messages occur in Exchange 2000 Server and Exchange Server 2003를 참조하십시오.

SMTP 서비스 확장을 복원하려면 다음을 수행합니다.

  1. Exchange SMTP 서비스 확장이 없는지 확인합니다. 이렇게 하려면 다음 단계를 수행합니다.

    1. 관리 자격 증명이 있는 계정으로 Microsoft Exchange를 실행 중인 컴퓨터에 로그온합니다.

    2. 시작 및 실행을 차례로 클릭하고 cmd를 입력한 다음 확인을 클릭합니다.

    3. 명령 프롬프트에 telnet 127.0.0.1 25를 입력하여 "220 server.domain.com Microsoft ESMTP Mail Service" 항목을 확인합니다.

    4. EHLO를 입력한 다음 Enter 키를 눌러 250개의 명령 동사 목록을 확인합니다. 이름이 "X"로 시작하는 동사가 없으면 SMTP 서비스 확장이 없는 것입니다.

  2. 시스템 파티션을 완전히 백업합니다. 시스템 상태와 Exchange 데이터베이스 파일도 백업해야 합니다. 이 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 258243, Windows 백업 프로그램을 사용하여 Exchange 컴퓨터를 백업 및 복원하는 방법을 참조하십시오.

  3. Exchange에 종속되는 필요한 하위 구성 요소를 포함도록 IIS가 제대로 다시 설치되었는지 확인합니다.

    IIS 6.0

    1. 시작을 클릭하고 설정을 가리킨 다음 제어판을 클릭합니다.

    2. 프로그램 추가/제거를 두 번 클릭합니다.

    3. 왼쪽 창에서 Windows 구성 요소 추가/제거를 클릭합니다.

    4. Windows 구성 요소 마법사의 구성 요소 목록에서 응용 프로그램 서버를 찾은 다음 자세히를 클릭합니다.

    5. 다음 구성 요소 중 하나라도 설치되어 있지 않으면 설치하십시오.

      ASP.NET

      네트워크 COM+ 액세스 사용

      인터넷 정보 서비스(IIS)

    6. 인터넷 정보 서비스(IIS)를 클릭한 다음 자세히를 클릭합니다.

    7. 다음 구성 요소 중 하나라도 설치되어 있지 않으면 설치하십시오.

      공용 파일

      인터넷 정보 서비스 관리자

      NNTP 서비스

      SMTP 서비스

      World Wide Web 서비스

    8. 확인을 차례로 두 번 클릭합니다. 주 Windows 구성 요소 페이지에서 다음을 클릭한 다음 마침을 클릭합니다.

    IIS 5.0

    1. 시작을 클릭하고 설정을 가리킨 다음 제어판을 클릭합니다.

    2. 프로그램 추가/제거를 두 번 클릭합니다.

    3. 왼쪽 창에서 Windows 구성 요소 추가/제거를 클릭합니다.

    4. Windows 구성 요소 마법사 대화 상자의 구성 요소 목록에서 인터넷 정보 서비스(IIS)를 찾습니다. 인터넷 정보 서비스(IIS) 확인란을 선택하면 IIS가 설치됩니다. 설치된 IIS 하위 구성 요소를 확인하려면 인터넷 정보 서비스(IIS)를 클릭한 다음 자세히를 클릭합니다.

    5. IIS가 설치되지 않은 경우 인터넷 정보 서비스(IIS) 확인란을 클릭하여 선택한 다음 자세히를 클릭합니다. IIS 5.0 하위 구성 요소를 설치한 다음 확인을 클릭합니다. Exchange 2000을 설치하기 전에 필요한 최소 IIS 5.0 하위 구성 요소는 다음과 같습니다.

      공용 파일

      인터넷 정보 서비스 스냅인

      SMTP 서비스

      NNTP(Network News Transfer Protocol) 서비스(뉴스 그룹용)

      World Wide Web 서비스

    6. 다음을 클릭한 다음 마침을 클릭합니다.

  4. Exchange SMTP 서비스 확장을 복원합니다.

    Exchange Server 2003

    기존 Exchange 2003이 설치된 상태에서 Exchange 2003을 다시 설치하는 경우 데이터베이스 파일 및 사용 권한은 그대로 유지됩니다. 이렇게 하려면 다음 단계를 수행합니다.

    1. Exchange 2003 CD를 넣습니다.

    2. \SETUP\I386 폴더에서 Setup.exe 파일을 두 번 클릭합니다.

    3. 시작 페이지에서 구성 요소 선택 페이지가 나올 때까지 다음을 클릭합니다.

    4. 구성 요소 선택 페이지의 작업 열에서 다시 설치를 클릭한 후 다음을 클릭합니다.

    5. 설치 요약 페이지에서 선택 사항을 확인한 후 다음을 클릭하여 Exchange 2003 설치를 계속합니다.

    Exchange 2000 Server

    Exchange 2000 SMTP 서비스 확장 복원에 사용할 수 있는 방법은 제거된 IIS 하위 구성 요소의 수에 따라 다릅니다. IIS 하위 구성 요소 중에서 SMTP 서비스만 제거되었으며 Exchange 2000 Server 서비스 팩 2(SP2) 이상의 서비스 팩이 설치된 경우 Smtpreinstall.exe 명령줄 유틸리티를 사용합니다. Smtpreinstall.exe 명령줄 유틸리티는 Server\Support\Utils\I386 폴더에 있습니다.

    Smtpreinstall.exe 유틸리티를 사용하려면 다음을 수행합니다.

    1. Smtpreinstall.exe 파일을 Exchsrvr\Bin 폴더에 복사합니다.

    2. 명령 프롬프트에서 Exchsrvr\Bin 폴더로 변경한 후 다음 명령을 입력합니다.

      smtpreinstall.exe

    3. 컴퓨터를 다시 시작하라는 메시지가 표시되면 다시 시작합니다.

    IIS 5.0이 구성 요소로 제거되었거나 IIS 5.0에서 SMTP 서비스 하위 구성 요소 이외의 구성 요소까지 제거된 경우 Microsoft Small Business Server 2000의 통합 설치의 일부로 기존 설치 상태에서 Exchange 2000을 다시 설치합니다.

    Exchange 2000 Server를 다시 설치하려면 다음을 수행합니다.

    참고:
    기존 Exchange 2000이 설치된 상태에서 Exchange 2000을 다시 설치하는 경우 데이터베이스 파일 및 사용 권한은 그대로 유지됩니다.
    1. Exchange 2000 Server CD를 넣습니다.

    2. \SETUP\I386 폴더에서 Setup.exe 파일을 두 번 클릭합니다.

    3. 시작 페이지에서 다음을 클릭합니다.

    4. CD 키를 입력하라는 메시지가 표시되면 입력한 후 다음을 클릭합니다.

    5. 구성 요소 선택 페이지의 작업 열에서 다시 설치를 클릭한 후 다음을 클릭합니다.

    6. 설치 요약 페이지에서 선택 사항을 확인한 후 다음을 클릭하여 Exchange 2000 설치를 계속합니다.

  5. Exchange 서비스 팩 및 핫픽스를 다시 설치합니다.

    자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

    836993 How to obtain the latest service packs for Exchange Server 2003

    301378 최신 Exchange 2000 Server 서비스 팩을 구하는 방법


MSExchangeIS 5000(0xc004038a): 사용 권한이 잘못되었거나 라우팅 그룹이 삭제되었기 때문에 데이터베이스를 탑재할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-05-31

Microsoft Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xc004038a의 MSExchangeIS 5000 이벤트를 하나 이상 검색했습니다. 이 오류가 발생하면 Microsoft Exchange Information Store 서비스가 초기화되지 않으며 데이터베이스가 탑재되지 않습니다.

설명

사용 권한이 잘못되었거나 라우팅 그룹이 삭제된 경우 오류 코드 0xc004038a의 이벤트 MSExchangeIS 5000이 발생할 수 있습니다. 이 이벤트는 다음 중 하나 이상의 이유로 발생할 수 있습니다.

  • Exchange Server가 더 이상 라우팅 그룹의 구성원이 아니거나 해당 라우팅 그룹이 Active Directory에서 삭제되었습니다.

  • Active Directory에서 Exchange Domain Servers 그룹에 적절한 사용 권한이 없습니다.

이 이벤트는 다음 버전의 Exchange 서버에 적용됩니다.

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

사용자 작업

이 오류를 해결하려면 다음 중 하나 이상을 수행합니다.

  • Exchange Domain Servers 그룹에 적절한 사용 권한이 없을 경우 ADSI(Active Directory Service Interfaces) 편집 유틸리티를 사용하여 Active Directory에서 Exchange Domain Servers 그룹에 필요한 사용 권한을 부여합니다. Administrators 그룹, Exchange Domain Servers 그룹 및 구성과 관련된 기타 그룹의 보안 탭에서 부모로부터 상속 가능한 사용 권한을 이 개체로 전파하도록 허용 확인란을 선택합니다.

    참고:
    필요하면 도메인 컨트롤러에서 복제를 강제로 실행하여 변경 내용이 도메인 전체에 전파되도록 합니다.
    참고:
    ADSI 편집 도구는 Windows 2000 및 Windows 2003 설치 CD에 있는 Microsoft Windows 2000 지원 도구 및 Microsoft Windows Server 2003 지원 도구에 포함되어 있습니다.
  • Exchange 서버가 더 이상 라우팅 그룹의 구성원이 아니거나 해당 라우팅 그룹이 Active Directory에서 삭제된 경우 라우팅 그룹을 추가하거나 복원합니다. 다음 중 사용자의 상황에 가장 적합한 해결 방법을 따르십시오.

해결 방법 1: 라우팅 그룹에 서버를 추가합니다. 다음 단계에 따라 서버가 더 이상 라우팅 그룹의 구성원이 아닌지 확인합니다.

  1. Exchange System Manager를 시작합니다.

  2. 조직, 관리 그룹, AdministrativeGroupName, 라우팅 그룹을 차례로 확장합니다.

    참고:
    이 단계에서 AdministrativeGroupName은 관리 그룹의 이름입니다.
  3. 사용 가능한 모든 라우팅 그룹을 찾아보고 이 서버가 나열되어 있는지 확인합니다.

    참고:
    라우팅 그룹이 표시되지 않으면 해결 방법 2를 참조하십시오.
  4. 이 서버가 라우팅 그룹의 구성원이 아닌지 확인한 후에 서버를 기존 라우팅 그룹에 다시 추가합니다. 이렇게 하려면 다음 단계를 수행합니다.

    중요:
    ADSI 편집 스냅인, LDAP 유틸리티 또는 기타 LDAP 버전 3 클라이언트를 사용하는 상태에서 Active Directory 개체의 특성을 잘못 수정할 경우 심각한 문제가 발생할 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003 또는 Windows와 Exchange 모두를 다시 설치해야 할 수도 있습니다. Microsoft에서는 Active Directory 개체 특성을 잘못 수정하여 발생하는 문제의 해결에 대해서는 보장하지 않습니다. 이러한 특성의 수정에 따른 모든 책임은 사용자에게 있습니다.
서버를 라우팅 그룹에 다시 추가하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 adsiedit.msc를 입력한 다음 확인을 클릭합니다.

    참고:
    ADSI 편집 도구는 Microsoft Windows 2000 지원 도구 및 Microsoft Windows Server 2003 지원 도구에 포함되어 있습니다. 이러한 지원 도구를 설치하려면 다음 단계를 따르십시오.
    • Windows 2000 Server 기반 컴퓨터의 경우 Windows 2000 CD의 Support\Tools 폴더에 있는 Setup.exe를 두 번 클릭한 다음 Windows 지원 도구 설치 마법사의 단계에 따라 Windows 2000 지원 도구의 설치를 완료합니다.

    • Windows Server 2003 기반 컴퓨터의 경우 Windows Server 2003 CD의 Support\Tools 폴더에 있는 Suptools.msi를 마우스 오른쪽 단추로 클릭한 다음 Windows 지원 도구 설치 마법사의 단계에 따라 Windows Server 2003 지원 도구의 설치를 완료합니다.

  2. Configuration [ servername.domain_name.com ]을 확장하고, CN=Configuration, DC= domain_name, DC= com을 확장하고, CN=Services, CN=Microsoft Exchange, CN= OrganizationName, CN=Administrative Groups, CN= AdministrativeGroupName을 확장한 다음 CN=Routing Groups를 클릭합니다.

    참고:
    이 단계에서 servername은 서버의 이름, domain_name.com은 도메인의 이름, OrganizationName은 Exchange Server 조직의 이름 그리고 AdministrativeGroupName은 관리 그룹의 이름입니다.

  3. 이 서버를 구성원으로 지정할 라우팅 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. distinguishedName 특성을 클릭한 다음 편집을 클릭합니다.

  5. distinguishedName 특성 값을 메모장으로 복사합니다.

  6. 취소를 차례로 두 번 클릭하여 속성을 닫습니다.

  7. ADSIEdit 도구에서 Configuration [ servername.domain_name.com ]을 확장하고, CN=Configuration,DC= domain_name ,DC= com을 확장하고, CN=Services, CN=Microsoft Exchange, CN= OrganizationName, CN=Administrative Groups 및 CN= AdministrativeGroupName을 차례로 확장한 다음 CN=Servers를 확장합니다.

  8. servername을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  9. msExchHomeRoutingGroup 특성을 클릭한 다음 편집을 클릭합니다.

  10. 5단계에서 복사한 값을 메모장에 붙여넣은 다음 확인을 차례로 두 번 클릭하여 새 값을 저장합니다.

  11. Exchange System Manager에서 이 서버를 추가한 라우팅 그룹을 찾습니다.

  12. Exchange System Manager를 업데이트하여 이 서버를 확인합니다.

    참고:
    Exchange 서버가 즉시 나타나지 않으면 Active Directory 복제가 진행될 때까지 기다립니다.

  13. 이 라우팅 그룹에 서버 유형이 마스터로 설정된 다른 Exchange 서버가 없으면 이 Exchange 서버를 마우스 오른쪽 단추로 클릭한 다음 마스터로 설정을 클릭합니다.

  14. 정보 저장소 서비스 및 MTA Stacks 서비스를 시작합니다.

해결 방법 2: 라우팅 그룹을 복원합니다. 라우팅 그룹을 실수로 제거한 경우 시스템 상태 데이터의 가장 최근 백업을 사용하여 라우팅 그룹을 복원합니다. 시스템 상태 데이터의 최신 백업이 없고 도메인 컨트롤러가 두 개 이상 있는 경우 제거한 라우팅 그룹에 대해 신뢰할 수 있는 복원 작업을 수행합니다.

라우팅 그룹을 복원하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작한 다음 제거한 라우팅 그룹과 이름이 같은 새 라우팅 그룹을 만듭니다. 이렇게 하려면 다음 단계를 수행합니다.

    1. 관리 그룹, AdministrativeGroupName, 라우팅 그룹을 차례로 확장합니다.

      이 단계에서 AdministrativeGroupName은 관리 그룹의 이름입니다.

    2. 라우팅 그룹을 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 다음 라우팅 그룹을 클릭합니다.

    3. 이름 상자에 라우팅 그룹 이름을 입력한 다음 확인을 클릭합니다.

      실수로 제거한 라우팅 그룹에 사용한 것과 같은 이름을 사용합니다.

    4. Exchange 시스템 관리자를 끝냅니다.

  2. ADSI 편집을 시작합니다. 이렇게 하려면 시작, 실행을 차례로 클릭한 다음 열기 상자에 adsiedit.msc를 입력한 후 확인을 클릭합니다.

    참고:
    ADSI 편집 도구는 Microsoft Windows 2000 지원 도구 및 Microsoft Windows Server 2003 지원 도구에 포함되어 있습니다. 이러한 지원 도구를 설치하려면 다음을 수행합니다.
    • Windows 2000 Server 기반 컴퓨터의 경우 Windows 2000 CD의 Support\Tools 폴더에 있는 Setup.exe를 두 번 클릭한 다음 Windows 지원 도구 설치 마법사의 단계에 따라 Windows 2000 지원 도구의 설치를 완료합니다.

    • Windows Server 2003 기반 컴퓨터의 경우 Windows Server 2003 CD의 Support\Tools 폴더에 있는 Suptools.msi를 마우스 오른쪽 단추로 클릭한 다음 Windows 지원 도구 설치 마법사의 단계에 따라 Windows Server 2003 지원 도구의 설치를 완료합니다.

  3. Configuration [servername.domain_name.com]을 확장하고, CN=Configuration, DC= domain_name, DC= com을 확장하고, CN=Services, CN=Microsoft Exchange, CN= OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName을 차례로 확장한 다음 CN=Routing Groups를 클릭합니다.

    이 단계에서 servername은 서버의 이름, domain_name.com은 도메인의 이름, OrganizationName은 Exchange Server 조직의 이름 그리고 AdministrativeGroupName은 관리 그룹의 이름입니다.

  4. 오른쪽 창에서 만든 새 라우팅 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 필수 특성 표시 확인란과 선택 특성 표시 확인란을 아직 선택하지 않은 경우 클릭하여 선택합니다.

  6. 특성 목록에서 msExchRoutingGroupMembersBL을 클릭한 다음 편집을 클릭합니다.

    값 목록은 비어 있습니다.

  7. 취소를 클릭합니다.

  8. 특성 목록에서 distinguishedName을 두 번 클릭합니다.

  9. 값 상자에서 고유 이름을 마우스 오른쪽 단추로 클릭한 다음 복사를 클릭합니다.

  10. 메모장과 같은 텍스트 편집기를 시작한 다음 편집 메뉴에서 붙여넣기를 클릭하여 고유 이름을 붙여넣습니다.

  11. 문자열 특성 편집기 대화 상자에서 취소를 클릭한 다음 취소를 다시 클릭하여 CN=RoutingGroupName 대화 상자를 닫습니다.

    이 단계에서 RoutingGroupName은 라우팅 그룹의 이름입니다.

  12. ADSI 편집의 CN=AdministrativeGroupName에서 CN=Servers를 클릭합니다.

  13. 오른쪽 창에서 CN=ServerName을 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

    이 단계에서 ServerName은 이 라우팅 그룹에 있는 Exchange 컴퓨터 중 하나입니다.

  14. 특성 목록에서 msExchHomeRoutingGroup을 클릭한 다음 편집을 클릭합니다.

  15. 값 상자에 9~10단계에서 복사한 고유 이름을 붙여넣은 다음 확인을 클릭합니다.

  16. 적용을 클릭한 다음 확인을 클릭합니다.

  17. 실수로 제거한 라우팅 그룹의 구성원인 각 서버에 대해 13~15단계를 반복합니다.

  18. CN=AdministrativeGroupName에서 CN=Routing Groups를 클릭합니다.

  19. 오른쪽 창에서 만든 새 라우팅 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  20. 특성 목록에서 msExchRoutingGroupMembersBL을 클릭한 다음 편집을 클릭합니다.

    값 목록은 더 이상 비어 있지 않습니다.

  21. 취소를 차례로 두 번 클릭합니다.

  22. ADSI 편집을 끝냅니다.

  23. Exchange System Manager를 사용하여 라우팅 그룹 마스터를 설정합니다. 이렇게 하려면 다음 단계를 수행합니다.

    1. Exchange System Manager를 시작합니다.

    2. 관리 그룹, AdministrativeGroupName, 라우팅 그룹을 차례로 확장합니다.

    3. 만든 새 라우팅 그룹을 확장한 다음 구성원을 클릭합니다.

    4. 오른쪽 창에서 라우팅 그룹 마스터로 구성할 Exchange 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 마스터로 설정을 클릭합니다.

    5. Exchange 시스템 관리자를 끝냅니다.

  24. 변경 내용이 도메인 전체에 전파될 때까지 기다립니다.

  25. 중지된 Microsoft Exchange 서비스를 시작합니다.


MSExchangeIS 5000(0x8004010f): 사용 권한이 잘못되었거나 조직 이름에 잘못된 문자가 있기 때문에 데이터베이스를 탑재할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0x8004010f의 MSExchangeIS 5000 이벤트를 하나 이상 검색했습니다. 이 이벤트는 사용 권한이 잘못되었거나 Exchange 조직 이름의 문자가 잘못되었기 때문에 Exchange 서버의 데이터베이스를 탑재할 수 없음을 나타냅니다.

설명

다음 중 하나에 해당되면 오류 코드 0x8004010f의 MSExchangeIS 5000 이벤트가 발생할 수 있습니다.

  • 인증된 사용자에게 Active Directory의 도메인 또는 구성 컨테이너에 대한 읽기 권한이 없을 경우 이 이벤트가 발생합니다. 이러한 경우 이미 Exchange 서버가 포함되어 있는 관리 그룹에서 두 번째 Exchange 서버를 설치하려고 해도 설치할 수 없습니다. 또한 Microsoft Exchange Information Store 서비스를 시작할 수 없습니다.

  • Active Directory의 구성 컨테이너 아래에 있는 WellKnown 보안 계정 컨테이너에서 Everyone 계정에 읽기 권한이 없을 경우 이 이벤트가 발생합니다. 이러한 경우 구성원 서버에서 Exchange 정보 저장소 서비스를 시작할 수 없습니다.

  • Exchange 조직 이름에 지원되지 않는 문자가 포함된 경우 이 이벤트가 발생합니다. 이러한 경우 Exchange 2000 Server 또는 Exchange Server 2003을 설치한 후 Exchange 정보 저장소 서비스를 시작할 수 없으며 MSExchangeIS 5000 및 MSExchangeIS 1121 이벤트가 응용 프로그램 로그에 기록됩니다.

이 이벤트는 MAPI_E_NOT_FOUND로 식별될 수도 있습니다. 이 이벤트는 다음 버전의 Exchange 서버에 적용됩니다.

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

사용자 작업

이 문제를 해결하려면 다음 중 하나 이상을 수행합니다.

중요:
ADSI(Active Directory Service Interfaces) 편집 스냅인, LDP 유틸리티 또는 기타 LDAP 버전 3 클라이언트를 사용하는 경우 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제를 수정하려면 Microsoft Windows® 2000 Server, Microsoft Windows Server™ 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003 또는 Windows와 Exchange를 다시 설치해야 할 수 있습니다. Microsoft에서는 Active Directory 개체 특성을 잘못 수정할 경우 발생하는 문제의 해결 가능성을 보장하지 않습니다. 이러한 특성의 수정에 따른 모든 책임은 사용자에게 있습니다.
  • 인증된 사용자에게 Active Directory의 도메인 또는 구성 컨테이너에 대한 읽기 권한이 없을 경우 Exchange Server 2003 및 Exchange 2000 Server의 ADSI 편집 도구를 사용하여 인증된 사용자에게 Active Directory의 도메인 컨테이너 및 구성 컨테이너에 대한 읽기 권한을 부여합니다. 다음 단계를 수행합니다.

    참고:
    ADSI 편집 도구는 Microsoft Windows 2000 지원 도구 및 Microsoft Windows Server 2003 지원 도구에 있습니다. Windows 지원 도구를 설치하려면 Windows CD의 Support\Tools 폴더에서 설치 프로그램을 실행합니다. Windows 지원 도구에 대한 자세한 내용은 Windows CD의 Support\Tools 폴더에 있는 Sreadme.doc 파일을 참조하십시오.
사용자에게 Active Directory의 도메인 또는 구성 컨테이너에 대한 읽기 권한을 부여하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 adsiedit.msc를 입력한 다음 확인을 클릭합니다.

  2. 도메인 NC 컨테이너를 확장하고 도메인(DC=domain,DC=com)에 대한 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 폴더 속성을 엽니다.

  3. 보안 탭을 클릭하고 인증된 사용자 그룹에서 허용 열에 읽기 권한이 선택되어 있는지 확인합니다. 읽기가 선택되어 있지 않으면 읽기를 클릭하여 선택하고 확인을 클릭합니다.

  4. 구성 컨테이너를 확장하고 구성(CN=Configuration,DC=domain,DC=com)에 대한 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 폴더 속성을 엽니다.

  5. 보안 탭을 클릭하고 인증된 사용자 그룹에서 허용 열에 읽기 권한이 선택되어 있는지 확인합니다. 읽기가 선택되어 있지 않으면 읽기를 클릭하여 선택하고 확인을 클릭합니다.

  6. ADSI 편집을 끝냅니다.

  7. 도메인 컨트롤러 간에 변경 내용이 복제되는 시간이 필요합니다.

  8. 정보 저장소 서비스를 시작합니다.
  • Active Directory의 구성 컨테이너 아래에 있는 WellKnown 보안 계정 컨테이너에서 Everyone 계정에 읽기 권한이 없을 경우 다음 단계를 수행하여 문제를 해결합니다.

Active Directory의 WellKnown 보안 계정 컨테이너에서 Everyone 계정에 읽기 권한을 부여하려면 다음을 수행합니다.

  1. 도메인 관리자로 로그온하고 ADSI 편집을 시작합니다.

  2. 구성 컨테이너를 확장하고 CN=WellKnown 보안 계정 컨테이너를 클릭합니다.

  3. 속성을 마우스 오른쪽 단추로 클릭하고 보안 탭을 찾습니다.

  4. 추가를 클릭하고 everyone을 입력한 다음 확인을 클릭합니다.

  5. 허용 열에서 읽기 확인란을 클릭하여 선택합니다.
  • Exchange 조직 이름에 잘못된 문자가 있을 경우 조직 이름에서 해당 문자를 제거합니다. 잘못된 문자에 대한 자세한 내용은 Microsoft 기술 자료 문서 329599, Exchange Information Store Does Not Start and Events 1121 and 5000 Are Logged를 참조하십시오.


MSExchangeIS 9518(0xfffffddc): 이 저장소 그룹에 사용할 수 있는 최대 트랜잭션 로그 수를 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-22

Microsoft® Exchange Server Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffffddc의 MSExchangeIS 9518 이벤트를 하나 이상 검색했습니다. 이 이벤트는 이 저장소 그룹에 사용할 수 있는 최대 트랜잭션 로그 수가 초과되었음을 나타냅니다.

설명

다음 두 가지 조건에 모두 해당되는 경우 저장소 그룹의 데이터베이스를 탑재하려고 시도하면 오류 코드 0xfffffddc의 MSExchangeIS 9518 이벤트가 기록됩니다.

  • 이 저장소 그룹에 사용할 수 있는 최대 트랜잭션 로그 수가 초과된 경우

  • 이 저장소 그룹의 모든 데이터베이스가 완전하게 종료된 상태인 경우

또한 응용 프로그램 로그에 오류 코드 0xfffffdf9의 MSExchangeIS 1159 이벤트가 기록된 후에 해당 데이터베이스가 종료되어야 합니다. 이 이벤트는 Exchange Server에서 이 저장소 그룹에 사용할 수 있는 모든 트랜잭션 로그 수를 사용했음을 나타냅니다. 마지막 트랜잭션 로그가 입력되면 이 저장소 그룹의 모든 데이터베이스가 분리되며 다시 시작할 수 없습니다.

Exchange에서는 순차적으로 번호가 매겨지는 트랜잭션 로그 파일을 사용합니다. Exchange 2000 Server 및 Exchange Server 2003에서 트랜잭션 로그 파일은 Exx00001.log로 시작하여 ExxFFFF0.log까지 순차적으로 증가합니다. 단일 시퀀스에서 생성할 수 있는 최대 트랜잭션 로그 파일 수는 1,048,560(0xFFFF0)입니다. 일반적으로 이 정도로 많은 로그 파일이 생성되려면 몇 년이 걸립니다.

Exchange Server 2007에서는 생성할 수 있는 트랜잭션 로그 파일 수가 더 많습니다. 로그 스트림에 로그 파일(로그 파일 이름이 16진수이므로 16진수의 0x7FFFFFFF)이 최대 2,147,483,647개까지 있을 수 있습니다. 트랜잭션 로그 파일은 각각 1MB입니다. Exchange Server 2007에서는 이 오류가 거의 발생하지 않습니다.

사용자 작업

이 오류를 해결하려면 모든 트랜잭션 로그 파일을 제거하고 트랜잭션 로그 파일 시퀀스를 다시 1로 설정해야 합니다. 로그 파일 시퀀스를 다시 설정한 후 Exchange Server 2003 이하 버전에서는 로그 파일 이름이 Exx00001.log이고, Exchange Server 2007에서는 Exx00000001.log입니다.

Microsoft Exchange Troubleshooting Assistant의 일부인 Database Recovery Management 도구의 로그 생성 번호 다시 설정 작업을 통해 이 작업을 수행합니다. 이 도구는 모든 데이터베이스가 올바르게 종료되었는지 확인하고, 모든 트랜잭션 로그 파일을 백업 위치로 안전하게 이동합니다.

참고:
트랜잭션 로그 파일을 수동으로 제거할 수도 있지만 이 경우 저장소 그룹의 데이터베이스가 올바르게 종료되지 않을 수 있으며, 해당 데이터베이스를 다시 탑재할 수 없습니다. 이러한 문제를 방지하려면 Database Recovery Management 도구를 사용하는 것이 좋습니다.

도구에 대한 자세한 내용을 보거나 도구를 다운로드하려면 Microsoft Exchange Troubleshooting Assistant v1.0을 참조하십시오.


MSExchangeIS 9518 0xfffffbc4: 로그 파일 경로가 이미 사용 중입니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-05-14

Microsoft Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffffbc4의 MSExchangeIS 9518 이벤트를 하나 이상 검색했습니다. 이 오류 코드는 하나 이상의 저장소 그룹이 같은 로그 파일 경로나 시스템 파일 경로를 사용하도록 구성되어 있음을 나타냅니다.

설명

이 오류는 여러 저장소 그룹이 같은 로그 파일 경로나 시스템 파일 경로를 사용하도록 구성된 경우에 발생할 수 있습니다. Exchange를 설치하려면 각 저장소 그룹에 로그 및 시스템 파일용으로 고유한 경로가 지정되어 있어야 합니다.

사용자 작업

이 문제를 해결하려면 각 저장소 그룹에 고유한 로그 파일 경로 및 시스템 파일 경로가 구성되어 있는지 확인합니다.

참고:
각 저장소 그룹은 동일한 로그 파일 경로 및 시스템 파일 경로를 공유할 수 있습니다. 그러나 다른 저장소 그룹에 대해 같은 경로를 로그 파일 경로나 시스템 파일 경로로 사용할 수는 없습니다.
Exchange 2000 Server 또는 Exchange Server 2003에서 로그 파일 경로 및 시스템 파일 경로를 확인하거나 설정하려면 다음을 수행합니다.

  1. Exchange 시스템 관리자를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버를 차례로 확장하고 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭의 트랜잭션 로그 위치에서 찾아보기를 클릭합니다.

  4. 로그 파일 경로 및 시스템 파일 경로가 저장소 그룹에 대해 고유하게 지정되어 있는지 확인합니다.

  5. 저장소 그룹 로그 파일 경로 및 시스템 파일 경로가 저장소 그룹에 대해 고유하게 지정되어 있지 않은 경우 로그 파일 및/또는 시스템 파일에 대해 새 위치의 경로를 입력한 다음 확인을 클릭합니다.

  6. 확인를 클릭합니다.
Exchange Server 2007에서 저장소 그룹의 로그 파일 경로 및 시스템 파일 경로를 확인하거나 설정하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. 서버 구성을 확장하고 사서함을 강조 표시합니다.

  3. 사서함 창에서 작업할 서버를 선택합니다.

  4. 데이터베이스 관리 창에서 작업할 저장소 그룹을 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  5. 로그 파일 경로 및 시스템 파일 경로가 저장소 그룹에 대해 고유하게 지정되어 있는지 확인합니다.

  6. 저장소 그룹 로그 파일 경로 및 시스템 파일 경로가 저장소 그룹에 대해 고유하게 지정되어 있지 않은 경우 Exchange Server 2007 설명서의 "저장소 그룹 로그 파일의 위치를 설정하거나 변경하는 방법"(http://go.microsoft.com/fwlink/?LinkId=80702) 항목에 나와 있는 안내에 따라 파일 경로를 각 저장소 그룹에 대해 고유한 위치로 설정합니다.

Exchange Server 2003의 로그 파일을 이동하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 821915, "Exchange 2003 Server의 Exchange 데이터베이스와 로그를 이동하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915)을 참조하십시오.

Exchange 2000 Server의 로그 파일을 이동하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 239944, "XADM: 트랜잭션 또는 시스템 로그를 다른 위치로 이동하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944)을 참조하십시오.


MSExchangeIS 9518(0xfffff745): TMP 파일을 만들거나 해당 파일에 액세스할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffff745의 MSExchangeIS 9518 이벤트를 하나 이상 검색했습니다. 이 오류는 Exchange가 TMP 또는 TEMP 시스템 환경 변수에 지정된 폴더에 파일을 만들거나 해당 파일에 액세스할 수 없는 경우에 발생합니다.

설명

이 문제는 다음 중 하나에 해당되는 경우 발생할 수 있습니다.

  • TMP 또는 TEMP 환경 변수가 가리키는 경로를 사용할 수 없거나 읽기 전용입니다. 예를 들어 TMP 환경 변수가 원격 드라이브나 SAN(Storage Area Network)에 매핑된 후 매핑된 드라이브나 SAN을 더 이상 사용할 수 없는 경우에 이러한 문제가 발생합니다.

  • TMP 또는 TEMP 환경 변수의 레지스트리 설정이 잘못되었습니다.

  • Exchange에 루트 드라이브에서 트랜잭션 로그 및 데이터베이스까지에 대한 모든 권한이 없습니다.

사용자 작업

이 문제를 해결하려면 다음 중 하나 이상을 수행합니다.

참고 Microsoft Windows에는 여러 가지 버전이 있기 때문에 사용자의 컴퓨터에서는 다음 단계가 다를 수 있습니다. 이러한 경우에는 제품 설명서를 참조하여 해당 단계를 완료합니다.

  • Windows에서 TMP 환경 변수와 TEMP 환경 변수가 모두 올바른 위치를 가리키는지 확인합니다. 이렇게 하려면 다음 단계를 수행합니다.

    Temp 및 TMP 변수에 대해 유효한 경로를 설정하려면 다음을 수행합니다.

    1. 시작을 클릭하고 설정을 가리킨 다음 제어판을 클릭합니다.

    2. 시스템을 두 번 클릭하고 고급 탭을 클릭한 다음 환경 변수를 클릭합니다.

    3. 시스템 변수 아래에서 TEMP를 클릭하고 편집을 클릭합니다.

    4. 변수 값 상자에 유효한 경로가 나타나지 않으면 유효한 TEMP 변수 경로를 입력하고 확인을 클릭합니다. 예를 들어 %systemroot%\Temp를 입력하고 확인을 클릭합니다.

    5. 시스템 변수 아래에서 TMP를 클릭하고 편집을 클릭합니다.

    6. 변수 값 상자에 유효한 경로가 나타나지 않으면 유효한 TMP 변수 경로를 입력하고 확인을 클릭합니다. 예를 들어 %systemroot%\Temp를 입력하고 확인을 클릭합니다.

    7. 확인을 두 번 클릭하고 시스템 속성 대화 상자를 닫습니다.

    8. 컴퓨터를 다시 시작합니다.
  • 로컬 관리자 그룹 또는 SYSTEM 계정에 Temp 폴더에 대한 모든 권한을 확인 및 부여합니다. Domain Admins 그룹에 모든 권한을 부여하는 것만으로는 부족합니다. 기본적으로 TMP와 TEMP 시스템 환경 변수에 대해 다음과 같은 경로가 지정됩니다.

    %SYSTEMROOT%\Temp

    Exchange는 SYSTEM 계정을 사용하여 이 폴더 위치에 액세스해야 합니다. 이 사용 권한을 보려면 다음 단계를 수행합니다.

    Temp 폴더에 대한 사용 권한을 확인하려면 다음을 수행합니다.

    1. 시작을 마우스 오른쪽 단추로 클릭하고 탐색을 클릭합니다.

    2. 시스템 환경 변수에 지정된 Temp 폴더를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다. 일반적으로 이 폴더 위치는 %systemroot%\Temp입니다.

    3. 보안 탭을 클릭합니다.

    4. 이름 목록에서 SYSTEM을 클릭하고 사용 권한 목록에 표시되어 있는, 할당된 권한을 확인합니다.
    Temp 폴더에 대한 사용 권한이 올바른 경우 Exchange 데이터베이스 파일 또는 Exchange 로그 파일이 포함된 각 드라이브의 사용 권한을 확인합니다. SYSTEM 계정에는 루트 드라이브에 대한 모든 권한 및 Exchange 데이터베이스 파일이나 Exchange 트랜잭션 로그 파일이 포함된 각 폴더에 대한 모든 권한이 있어야 합니다. 예를 들어 C:\Exchsrvr\Mdbdata 폴더에 트랜잭션 로그가 있는 경우 SYSTEM 계정에는 C 드라이브의 루트 디렉터리, Exchsrvr 폴더 및 Mdbdata 폴더에 대한 모든 권한이 있어야 합니다.

  • 잘못된 레지스트리 설정으로 인해 문제가 발생했는지 확인합니다. 다음 단계를 수행합니다.

    레지스트리 설정을 확인하려면 다음을 수행합니다.

    1. 시작 및 실행을 차례로 클릭하고 Regedt32.exe를 입력한 다음 확인을 클릭합니다.

    2. 다음 위치의 레지스트리 키로 이동합니다.

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

    3. TMP 또는 TEMP 이름을 찾습니다. 이 키의 종류는 REG_EXPAND_SZ이어야 합니다.

    4. 두 키 중 하나라도 잘못된 경우 Environment 하위 키를 백업한 후 오른쪽에 있는 TMP 또는 TEMP 값을 삭제합니다.

    5. 시작 및 실행을 차례로 클릭하고 Sysdm.cpl을 입력한 다음 확인을 클릭합니다.

    6. 고급 탭에서 환경 변수를 클릭합니다.

    7. 시스템 변수 목록에 4단계에서 삭제한 값이 없는지 확인합니다.

      참고:
      TEMP 또는 TMP 변수를 보려면 아래로 스크롤해야 할 수 있습니다.

    8. 새로 만들기를 클릭합니다. 변수 이름 상자에 4단계에서 삭제한 이름을 입력합니다. 예를 들어 C:\Winnt\TEMP를 입력합니다.

    9. 확인을 세 번 클릭하고 컴퓨터를 다시 시작합니다.


MSExchangeIS 9518(0xfffffd9a): 검사점 파일이 없으며 1,008개가 넘는 트랜잭션 로그 파일이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffffd9a의 MSExchangeIS 9518 이벤트를 하나 이상 검색했습니다. 이 오류는 이 저장소 그룹에 대한 검사점 파일(Exx.chk)이 없거나 삭제되었고 데이터베이스로 재생할 트랜잭션 로그 파일 수가 1,008개를 초과함을 나타냅니다.

설명

이 문제는 다음 조건에 해당되는 경우 발생할 수 있습니다.

  • 로그 파일 및 데이터베이스가 올바르게 종료되었습니다. 그러므로 복구할 크래시가 없습니다.

  • Exx.chk 검사점 파일을 삭제했거나 이름을 변경했습니다.

  • 서버에서 재생할 검사점 간 로그 파일 수가 1,008개를 초과합니다.

  • "롤 포워드" 복구에서 저장소 그룹에 있는 데이터베이스가 하나 이상 손실되었지만 복구할 때 로그 파일이 서버에 그대로 남습니다. "롤 포워드" 복구 작업이 성공적으로 완료되지 않았습니다.

이러한 상황에서 Microsoft Exchange Information Store 서비스는 소프트 복구를 수행하고, 시작하는 동안 모든 로그 파일을 재생합니다. 로그 파일과 데이터베이스가 정상적으로 종료되었기 때문에 복구 작업을 수행할 필요가 없습니다. 검사점이 없으므로 Exchange에서는 레코드가 완전하게 종료될 때까지 모든 로그를 처리합니다. 로그 파일 수가 1,008개를 초과하기 때문에 Exchange에서는 완전하게 종료된 상태의 레코드를 찾기 전에 로그 파일 수의 한계인 1,008에 먼저 도달합니다.

참고:
앞에 나열된 조건에 해당되며 eseutil /r 명령을 사용하여 로그 파일을 재생하는 경우에도 설명된 증상이 나타날 수 있습니다. eseutil /r 명령은 사서함 저장소에서 소프트 복구를 수행하기도 합니다.

이 오류는 오류 JET_errCheckpointDepthTooDeep, -614로 식별될 수도 있으며 Microsoft Exchange Server 2003에만 적용됩니다.

사용자 작업

Exchange Server 2003에서 이 문제를 해결하려면 Microsoft 기술 자료 문서 836611, Information Store databases do not mount and you receive an "Operation terminated with error -614" error message when you start a computer that is running Exchange Server 2003에 지정된 핫픽스를 적용합니다.


MSExchangeIS 9518 0xfffffb40: 데이터베이스 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-05-23

Microsoft Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffffb40의 MSExchangeIS 9518 이벤트를 하나 이상 검색했습니다. 이 이벤트는 저장소 그룹에 하나 이상의 데이터베이스 파일이 없음을 나타냅니다.

설명

이 오류는 이 오류는 복구 동안에 ESE(Extensible Storage Engine)가 저장소 그룹에 있는 모든 데이터베이스를 일관성 있는 상태로 설정하려 할 때 데이터베이스 파일이 없거나 다른 버전으로 대체된 경우에 발생할 수 있습니다.

저장소 그룹의 데이터베이스 파일이 없거나 다른 버전으로 대체된 경우 ESE는 오류 -1216을 반환하고 복구를 중단하며 저장소 그룹을 시작하지 않습니다.

사용자 작업

이 문제를 해결하려면 다음 중 하나 이상을 수행합니다.

  • 첫 번째 방법: 데이터베이스 파일을 이동했거나 이름을 바꾸어 없는 것으로 인식되는 경우에는 응용 프로그램 로그에서 데이터베이스 탑재를 시도한 후에 발생한 ESE 494 이벤트를 모두 찾습니다. 각 이벤트에 대해 없는 것으로 보고된 특정 데이터베이스 파일을 확인하고 해당 파일의 현재 위치를 찾은 다음 적절한 위치로 이동합니다.

참고:
파일 수준 바이러스 백신 소프트웨어가 해당 서버에 설치되어 있으며 예외가 제대로 구성되어 있지 않은 경우 바이러스 백신 소프트웨어에 의해 데이터베이스가 삭제 또는 격리되었을 수 있습니다. 바이러스 백신 격리 및 삭제 로그에서 이러한 작업이 수행되었는지 확인하십시오.
  • 두 번째 방법:

    • 두 번째 방법(A): 없는 것으로 보고된 데이터베이스 파일이 삭제 또는 손실된 경우에는 해당 파일을 백업에서 프로덕션 저장소 그룹으로 복원합니다. Exchange 데이터베이스 복구 관리 도구의 데이터베이스 및 트랜잭션 로그 파일 확인 작업을 사용하여 복원된 데이터베이스 파일에 대해 복원을 수행할 수 있는지를 확인할 수 있습니다.

      이 데이터베이스 파일을 복원하는 동안 다음 단계를 완료하여 저장소 그룹에 있는 정상적인 다른 데이터베이스도 탑재 및 액세스할 수 있습니다.

정상적인 데이터베이스 파일에 대한 사용자 사서함 액세스를 허용하려면 다음을 수행합니다.

  1. eseutil /R /L <로그 파일로의 경로> /S <Path to System Files> Log Base Name /I 를 실행합니다. 여기서 로그 기본 이름은 E00, E01 등 해당 저장소 그룹 로그 파일의 처음 세 글자입니다. 이렇게 하면 ESE가 없는 데이터베이스 파일은 무시하고 현재 저장소 그룹에 있는 데이터베이스 파일을 동일한 상태로 설정할 수 있습니다. 이 명령을 실행한 후에는 없는 데이터베이스 파일을 백업에서 복원해야 합니다.
참고:
/L 및 /S 스위치는 선택적 항목이며 로그 파일과 시스템 파일이 있는 위치에서 eseutil을 실행하는 경우에는 사용하지 않아도 됩니다.
  1. 현재 저장소 그룹에 있으며 상태가 동일한 데이터베이스 파일을 탑재합니다.

  2. 그러면 현재 탑재된 데이터베이스가 호스트하는 사서함을 소유한 사용자가 자신의 메일에 액세스할 수 있습니다.
  • 두 번째 방법(B): 데이터베이스 파일을 백업에서 복구 저장소 그룹으로 복원합니다. 최대한 빨리 새 데이터베이스를 시작하여 보내기/받기 기능을 즉시 제공할 수 있습니다. 이를 발신음 복구라고 합니다. 클라이언트에는 사서함이 비어 있는 것으로 표시되지만 복구나 복원이 완료될 때까지 기다리는 것보다는 빠른 시간 내에 보내기 및 받기 기능을 사용할 수 있습니다.

참고:
발신음 옵션을 사용하려면 복원된 데이터에 포함된 새 데이터(발신음 이후 데이터)를 병합해야 합니다.

발신음 복구에 대한 자세한 내용은 Exchange 2007 제품 설명서의 재해 복구 항목에서 "발신음 이식성"()을 참조하십시오.

복구 저장소 그룹에 대한 자세한 내용은 Exchange 2007 제품 설명서의 재해 복구 항목에서 "복구 저장소 그룹 이해"()를 참조하십시오.
  • 세 번째 방법: 수동으로 또는 Exchange Troubleshooting Assistant의 데이터베이스 복구 작업을 통해 저장소 그룹에 있는 하나 이상의 데이터베이스에 대해 하드 복구를 실행했으며 데이터베이스가 동일한 상태인 경우 저장소 그룹의 로그 파일이 제거되지 않았을 수 있습니다. 저장소 그룹의 모든 데이터베이스가 올바른 위치에 있는 경우 다음 명령을 실행하여 모든 데이터베이스가 동일한 상태인지 확인하십시오.

데이터베이스 파일 일관성 상태를 수동으로 확인하려면 다음을 수행합니다.

  1. eseutil /mh <path to database .edb file>를 실행합니다.

  2. 이 명령의 출력에서 상태: 필드를 찾아 해당 값이 완전하게 종료된인지 확인합니다.

  3. 저장소 그룹의 모든 데이터베이스가 완전하게 종료된 상태이면 해당 저장소 그룹의 모든 트랜잭션 로그와 시스템 로그를 백업 위치로 이동한 다음 저장소를 탑재합니다. 모든 데이터베이스를 제대로 탑재할 수 있다면 즉시 해당 저장소 그룹의 백업을 만드는 것이 좋습니다.

추가 정보

오류 코드가 0xfffffb40인 MSExchangeIS 9518 이벤트에 대한 자세한 내용은 "Events and Errors Message Center"(http://go.microsoft.com/fwlink/?LinkId=91705)를 참조하십시오.

이 오류로부터 복구하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 296843, "How to recover an Exchange 2000 Server database after error -1216"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=296843)을 참조하십시오.

Exchange 재해 복구 계획에 대한 자세한 내용은 "Exchange 재해 복구 계획 가이드"(http://go.microsoft.com/fwlink/?LinkId=91706)를 참조하십시오.

데이터베이스 복구 관리 및 데이터베이스 문제 해결사 마법사에 대한 자세한 내용은 "데이터베이스 복구 관리 및 데이터베이스 문제 해결사 도구"(http://go.microsoft.com/fwlink/?LinkId=91707)를 참조하십시오.

발신음 복구에 대한 자세한 내용은 Exchange 2007 제품 설명서의 재해 복구 항목에서 "발신음 이식성"(http://go.microsoft.com/fwlink/?LinkId=91703)을 참조하십시오.

복구 저장소 그룹에 대한 자세한 내용은 Exchange 2007 제품 설명서의 재해 복구 항목에서 "복구 저장소 그룹 이해"(http://go.microsoft.com/fwlink/?LinkID=80784)를 참조하십시오.


MSExchangeIS 9518(0xfffffea8): 데이터베이스 파일에서 데이터베이스 타임 스탬프가 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffffea8의 MSExchangeIS 9518 이벤트를 하나 이상 검색했습니다. 이 오류는 영향을 받는 데이터베이스에서 현재 페이지의 dbtime이 데이터베이스의 글로벌 데이터베이스 dbtime보다 클 경우에 발생합니다.

설명

이 오류가 발생하면 영향을 받는 사서함 또는 공용 폴더 데이터베이스가 탑재되지 않습니다. 이 오류는 JET_errDbTimeCorrupted로도 식별됩니다.

이 오류는 다음 버전의 Exchange 서버에 적용됩니다.

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

사용자 작업

데이터베이스 타임 스탬프 불일치를 해결하려면 eseutil /d 명령을 실행하여 이 문제가 발생한 데이터베이스의 조각 모음을 실행한 다음 이 데이터베이스를 탑재합니다. eseutil /d를 실행하는 방법에 대한 자세한 내용은 How to Run Eseutil /D (Defragmentation)를 참조하십시오. 이와 더불어 Microsoft 기술 자료 문서 328804, Exchange 데이터베이스 조각 모음 방법을 참조하십시오.


MSExchangeIS 9518(0xfffff764): 스트리밍 파일이 없거나 해당 파일에 액세스할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffff764의 MSExchangeIS 9518 이벤트를 하나 이상 검색했습니다. 이 오류는 Exchange가 데이터베이스와 연결된 스트리밍 파일(.stm)에 액세스할 수 없는 경우에 발생할 수 있습니다.

설명

이 오류는 데이터베이스와 연결된 스트리밍 파일(.stm)이 삭제 또는 이동되었거나 사용 권한 변경으로 인해 Exchange에서 스트리밍 파일에 액세스할 수 없는 경우에 발생할 수 있습니다.

참고:
Microsoft Exchange 유용한 정보별로 검색할 때 Exchange 디렉터리를 제외하지 않았다면 특정 환경에서는 바이러스 백신 프로그램이 .stm 파일을 비롯한 Exchange 파일의 사용 권한을 삭제 또는 변경할 수 있습니다. 이 항목에 대한 자세한 내용은 Microsoft 기술 자료 문서 823166, Exchange Server 2003 및 바이러스 백신 소프트웨어 개요를 참조하십시오.

이 오류는 -2204로 식별될 수도 있으며, 다음 버전의 Exchange 서버에 적용됩니다.

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

사용자 작업

이 문제를 해결하려면 다음 중 하나 이상을 수행합니다.

  • 데이터베이스의 백업 복사본에서 스트리밍 파일을 복원합니다.

  • 바이러스 백신 소프트웨어에서 스트리밍 파일을 격리 폴더로 이동했는지 확인합니다. 이 파일이 격리 폴더에 있을 경우 원래 위치로 이동한 다음 바이러스 백신 프로그램이 Exchange Server 2003 폴더를 검색하지 않도록 구성합니다.

    참고:
    일부 바이러스 백신 프로그램은 파일을 격리 폴더로 이동할 때 파일 속성을 읽기 전용으로 변경합니다. 격리 폴더에서 스트리밍 파일을 찾은 경우 해당 파일을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. 데이터베이스를 탑재하기 전에 읽기 전용 확인란의 선택을 취소합니다.
  • Microsoft Exchange Troubleshooting Assistant에 포함되어 있는 Microsoft Exchange Database Recovery Management 도구를 실행할 수 있습니다. Database Recovery Management 도구는 이 저장소 그룹에 대한 데이터베이스 및 트랜잭션 로그 파일을 분석하고 문제에 대한 추가적인 세부 정보를 제공할 수 있습니다. 도구에 대한 자세한 내용을 보거나 도구를 다운로드하려면 Microsoft Exchange Troubleshooting Assistant v1.0을 참조하십시오.


MSExchangeIS 9518(0xfffffbf8): Exchange 데이터베이스 폴더 또는 드라이브에 필요한 사용 권한이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-03-15

Microsoft Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffffbf8의 MSExchangeIS 9518 이벤트를 하나 이상 검색했습니다. 이는 Exchange 데이터베이스가 포함된 폴더 또는 드라이브에 적절한 사용 권한이 할당되어 있지 않음을 나타냅니다.

설명

이 오류는 Exchange 데이터베이스 파일을 호스트하는 폴더 또는 드라이브에 최소한의 기능을 수행하는 데 필요한 사용 권한이 할당되어 있지 않음을 나타냅니다. 이로 인해 사서함 저장소나 공용 폴더 저장소 액세스 또는 탑재가 어려울 수 있습니다.

사용자 작업

이 문제를 해결하려면 Exchange 데이터베이스가 포함된 폴더 및 해당 폴더가 있는 드라이브에 기본 사용 권한을 부여합니다.

Exchange 2007에서 Exchange 데이터베이스가 포함된 폴더에 기본 사용 권한을 부여하려면 다음을 수행합니다.

  1. Windows 탐색기를 시작하여 Exchange 데이터베이스가 포함된 폴더를 탐색합니다. 이 폴더는 기본적으로 C:\Program Files\Microsoft\Exchange\Mailbox\저장소 그룹 이름\입니다.

  2. 해당 폴더를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  3. 보안 탭을 클릭하고 다음과 같은 기본 사용 권한을 부여합니다.

계정 | 사용 권한
Administrators | 모든 권한
System | 모든 권한
 Exchange 2007에서 Exchange 데이터베이스가 포함된 드라이브에 기본 사용 권한을 부여하려면 다음을 수행합니다.

  1. Windows 탐색기를 시작합니다.

  2. Exchange 데이터베이스 폴더가 포함된 로컬 디스크 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 보안 탭을 선택하고 설치된 운영 체제에 따라 다음과 같은 기본 사용 권한을 부여합니다.

Windows 2000 Server의 경우:

계정 | 사용 권한
Everyone | 모든 권한

Windows Server 2003의 경우:

계정 | 사용 권한
Administrators | 모든 권한
Creator Owner | 없음
Everyone | 없음
System | 모든 권한
Users | 읽기 및 실행, 폴더 내용 보기, 읽기
 Exchange 2000 Server 및 Exchange Server 2003의 Mdbdata 폴더에 기본 사용 권한을 부여하려면 다음을 수행합니다.

  1. Windows 탐색기를 시작하고 Exchsvr 폴더를 탐색하여 해당 폴더를 확장합니다.

  2. Mdbdata 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 보안 탭을 클릭하고 다음과 같은 기본 사용 권한을 부여합니다.

계정 | 사용 권한
Administrators | 모든 권한
Authenticated Users | 읽기 및 실행, 폴더 내용 보기, 읽기
Creator Owner | 없음
Server Operators | 수정, 읽기 및 실행, 폴더 내용 보기, 읽기, 쓰기
System | 모든 권한
 Exchange 2000 Server 및 Exchange Server 2003의 Mdbdata 폴더가 포함된 드라이브에 기본 사용 권한을 부여하려면 다음을 수행합니다.

  1. Windows 탐색기를 시작합니다.

  2. Mdbdata 폴더가 포함된 로컬 디스크 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 보안 탭을 선택하고 설치된 운영 체제에 따라 다음과 같은 기본 사용 권한을 부여합니다.

Windows 2000 Server의 경우:

계정 | 사용 권한
Everyone | 모든 권한

Windows Server 2003의 경우:

계정 | 사용 권한
Administrators | 모든 권한
Creator Owner | 없음
Everyone | 없음
System | 모든 권한
Users | 읽기 및 실행, 폴더 내용 보기, 읽기

추가 정보

이 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 823022, "Event ID 490 is logged, and you receive the following error message when you try to mount the mailbox store or the public store in Exchange Server: "ID No: c1041724""(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823022)를 참조하십시오.


MSExchangeIS 9518(0xfffff743): 임시 파일이 너무 많습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-03-14

Microsoft Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffff743의 MSExchangeIS 9518 이벤트를 하나 이상 검색했습니다. 이 이벤트는 서버의 임시 파일 네임스페이스를 모두 사용했거나 임시 폴더에 쓸 공간이 없음을 나타냅니다.

설명

Exchange 2000 Server 및 Exchange Server 2003에서는 메시지나 파일 등 크기가 큰 개체가 저장소로 스트림되는 경우 .stm 파일이 미세하게 조각화되어 있어 전체 개체를 해당 파일에 쓸 수 없으면 Temp 폴더에 임시 파일이 만들어집니다.

정상 작업 중에 Exchange 서비스가 중지되면 이러한 파일은 Temp 폴더에서 제거됩니다. 그러나 Exchange 서버가 예기치 않게 종료되거나 끝나는 경우 이러한 파일은 제거되지 않습니다. 그리고 나중에 Exchange 서비스를 다시 시작하면 새 임시 파일이 만들어집니다. 이와 같이 임시 파일의 양이 늘어나면 성능이 저하됩니다. 64,000개의 임시 파일 네임스페이스를 모두 사용하면 Exchange 서비스를 시작할 수 없으며 오류 코드가 0xfffff743인 9518 이벤트가 이벤트 뷰어 응용 프로그램 로그에 기록됩니다.

사용자 작업

이 문제를 해결하려면 다음을 수행합니다.

  • Windows Temp 폴더에 lb*.tmp 파일이 있는지 확인합니다. 이러한 파일이 있으면 다음 절차의 단계에 따라 제거합니다.

  • 사용 가능한 디스크 공간에 대해 Temp 폴더를 호스트하는 드라이브를 확인합니다. 이 디스크에 사용 가능한 공간이 없으면 다음 절차에 따라 Temp 및 Tmp 폴더를 다른 드라이브로 이동합니다.

Windows Temp 폴더에서 lb*.tmp 파일을 제거하려면 다음을 수행합니다.

  1. 시작을 클릭하고 프로그램과 관리 도구를 차례로 선택한 다음 서비스를 클릭합니다.

  2. 아래로 스크롤하여 Microsoft Exchange Information Store를 선택합니다.

  3. 서비스의 상태가 Started이면 서비스를 마우스 오른쪽 단추로 클릭하고 중지를 클릭합니다.
참고:
그러면 모든 사용자의 사서함 연결이 끊어집니다.
  1. %windir%\temp 폴더를 탐색합니다. 여기서 %windir%은 Windows의 시스템 루트 폴더로, 기본값은 C:\Windows\Temp입니다.

  2. lb*.tmp 파일을 모두 삭제합니다.

  3. 서비스 관리 콘솔에서 Microsoft Exchange Information Store 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

 Temp 및 Tmp 폴더를 다른 드라이브로 이동하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터에서 시작과 제어판을 차례로 클릭한 다음 시스템을 두 번 클릭합니다.

  2. 고급 탭을 클릭한 다음 환경 변수를 클릭합니다.

  3. 시스템 변수 아래에서 TEMP 변수 및 드라이브가 포함된 줄을 클릭하고 편집을 클릭한 다음 새 드라이브 위치를 입력합니다.

  4. 시스템 변수 아래에서 TMP 변수 및 드라이브가 포함된 줄을 클릭하고 편집을 클릭한 다음 새 드라이브 위치를 입력합니다.
참고:
이 변경 내용은 사용자 변수가 아닌 시스템 변수에 적용해야 합니다.
참고:
여기서 설명한 절차를 수행해도 이 문제가 해결되지 않으면 Microsoft 기술 자료 문서 307242, "Information store does not mount with 0xfffff745 and -2235 errors"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242)의 정보를 참조하십시오.

추가 정보

이 문제에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 294462, "Exchange lb*.tmp files in the Windows Temp folder cause ESE -2237 error"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=294462)

  • 307242, "Information store does not mount with 0xfffff745 and -2235 errors"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242)


MSExchangeIS 9519(0xfffffb3a): 여러 데이터베이스에서 같은 서명을 사용 중입니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffffb3a의 MSExchangeIS 9519 이벤트를 하나 이상 검색했습니다. 이 오류는 같은 데이터베이스의 또 다른 복사본이 이미 실행 중임을 나타냅니다.

설명

각 Exchange 데이터베이스에는 고유 서명이 있습니다. Microsoft Exchange Information Store 서비스에서 같은 서명을 사용하는 여러 개의 데이터베이스가 검색된 경우 이와 같은 중복 데이터베이스는 탑재되지 않습니다.

이 이벤트는 오류 -1222, JET_errDatabaseSignInUse로 식별될 수도 있습니다.

사용자 작업

다음 단계를 수행하여 단일 저장소 그룹 내에 해당 데이터베이스가 동일한 복사본 두 개가 있는지 확인할 수 있습니다.

  1. 저장소 그룹에서 다른 모든 데이터베이스를 분리하고 이 오류 메시지의 원인이 되는 데이터베이스를 탑재해 봅니다.

  2. 데이터베이스를 탑재할 수 있다면 해당 저장소 그룹에서 다른 모든 데이터베이스를 탑재해 보아야 합니다.

  3. 저장소 그룹에 있는 서로 다른 데이터베이스가 응용 프로그램 로그에 동일한 오류를 일으키는 경우 두 데이터베이스는 같은 서명을 사용하므로 동일한 데이터베이스의 복사본에 해당됩니다.

이 문제를 해결하려면 이 특정 저장소 그룹 내에 데이터베이스 복사본을 한 개만 유지합니다.


MSExchangeIS 9519(0xfffffe07): 백업 프로세스를 실행 중이므로 데이터베이스를 탑재할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-02-27

Microsoft Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffffe07의 MSExchangeIS 9519 이벤트를 하나 이상 검색했습니다. 이 오류는 백업 프로세스를 실행 중이므로 지정한 데이터베이스를 탑재할 수 없음을 나타냅니다.

설명

이 오류는 지정한 데이터베이스가 속한 저장소 그룹에 여러 데이터베이스(사서함 데이터베이스 또는 공용 폴더 데이터베이스)가 있으며 이러한 데이터베이스 중 하나를 백업하는 동안 해당 데이터베이스를 탑재하려고 시도할 경우 발생할 수 있습니다. 이 동작은 의도된 것입니다. 한 저장소 그룹에서 데이터베이스를 백업하는 동안 다른 데이터베이스를 탑재할 수 없습니다.

이 오류는 오류 -505, JET_errBackupInProgress로 식별될 수도 있습니다.

사용자 작업

저장소 그룹에서 백업 중인 데이터베이스가 없음을 확인한 다음 데이터베이스를 탑재해 봅니다. 또는 저장소 그룹에서 다른 데이터베이스의 백업이 완료될 때까지 기다린 후 이 데이터베이스를 탑재해 봅니다.


MSExchangeIS 9519(0x3f3): "복원 시 데이터베이스 덮어쓰기 가능" 확인란을 선택하지 않은 상태에서 복원했습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0x3f3의 MSExchangeIS 9519 이벤트를 하나 이상 검색했습니다. 이 오류는 "복원 시 데이터베이스 덮어쓰기 가능" 확인란이 선택되지 않은 상태에서 데이터베이스에서 복원을 수행했음을 나타냅니다.

설명

이 이벤트는 저장소 속성에서 "복원 시 데이터베이스 덮어쓰기 가능" 확인란을 선택하지 않고 데이터베이스 복원 작업을 수행한 경우에 발생합니다.

사용자 작업

이 문제를 해결하려면 다음 작업을 수행하여 복원 시 데이터베이스를 덮어쓸 수 있도록 합니다.

Exchange Server 2003 및 Exchange 2000 Server에서 이 옵션을 사용하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 해당되는 경우 관리 그룹을 확장합니다.

  3. 서버, <서버 이름>, <저장소 그룹>을 차례로 확장한 다음 복원된 데이터베이스를 클릭합니다.

  4. 데이터베이스를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  5. 데이터베이스 탭을 클릭합니다.

  6. 복원 시 데이터베이스 덮어쓰기 가능 확인란을 클릭하여 선택합니다.

  7. 확인을 클릭합니다.

  8. 데이터베이스를 탑재하려면 해당 데이터베이스를 마우스 오른쪽 단추로 클릭하고 저장소 탑재를 클릭합니다.
Exchange Server 2007에서 이 옵션을 사용하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 시작합니다.

  2. 서버 구성에서 사서함을 선택합니다.

  3. 데이터베이스 관리 창에서 복원된 데이터베이스를 마우스 오른쪽 단추로 클릭합니다.

  4. 속성을 클릭합니다.

  5. 일반 탭을 선택합니다.

  6. 복원 시 데이터베이스 덮어쓰기 가능 확인란을 클릭하여 선택합니다.

  7. 확인을 클릭합니다.

  8. 데이터베이스를 탑재하려면 해당 데이터베이스를 마우스 오른쪽 단추로 클릭하고 데이터베이스 탑재를 클릭합니다.


MSExchangeIS 9518(0xfffffc01): 데이터베이스 또는 트랜잭션 로그 드라이브 또는 디렉터리가 잘못되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffffc01의 MSExchangeIS 9518 이벤트를 하나 이상 검색했습니다. 이 이벤트는 Exchange 데이터베이스 또는 로그 파일에 대해 잘못된 드라이브 문자나 경로가 설정되었음을 나타냅니다.

설명

이 오류는 영향을 받는 저장소 그룹에서 데이터베이스 또는 로그 파일 경로가 잘못된 드라이브 문자를 가리키거나 파일 경로가 잘못되었음을 나타냅니다. 이 오류가 발생하면 영향을 받는 저장소 그룹의 모든 데이터베이스를 탑재할 수 없습니다.

바이러스 백신 소프트웨어에서 Exchange 데이터베이스 또는 트랜잭션 로그 파일이 포함된 드라이브에 대해 쓰기 액세스를 차단하는 경우에도 이 문제가 발생할 수 있습니다.

이 이벤트는 오류 -1023, JET_errInvalidPath로 식별될 수도 있습니다.

사용자 작업

이 문제를 해결하려면 다음 중 하나 이상을 수행합니다.

  • 바이러스 백신 소프트웨어로 인해 이 문제가 발생하는지 확인하려면 서비스 콘솔에서 바이러스 백신 소프트웨어를 일시적으로 비활성화합니다. 그런 다음 영향을 받는 데이터베이스를 탑재해 봅니다. 데이터베이스가 탑재되는 경우 바이러스 백신 소프트웨어 공급업체에 최신 소프트웨어 빌드를 요청합니다.

  • 이 오류의 영향을 받는 각 저장소 그룹 및 데이터베이스에 대해 올바른 시스템, 데이터베이스 및 트랜잭션 로그 파일 경로를 확인하고 설정합니다. 다음 단계를 수행합니다.

Exchange Server 2003 또는 Exchange 2000 Server에서 올바른 파일 경로를 확인하고 설정하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다. 시작을 클릭하고 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭합니다.

  2. Exchange System Manager에 관리 그룹이 표시되는 경우 관리 그룹을 확장하고 문제가 발생한 관리 그룹을 확장합니다.

  3. 서버를 확장하고 문제가 발생한 서버를 확장합니다.

  4. 탑재할 수 없는 저장소가 포함된 저장소 그룹을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  5. 일반 탭에서 트랜잭션 로그 위치 상자에 나타난 경로를 확인합니다. 시스템 경로 위치 상자에 나타난 경로를 확인합니다.

    이 경로가 잘못된 경우 Microsoft 기술 지원 서비스에 문의하여 이 문제를 해결합니다.

  6. 있을 수 있는 각 저장소 그룹에 대해 3단계부터 5단계까지 수행하여 데이터베이스 경로 및 트랜잭션 로그 파일 경로를 확인합니다.

  7. 각 저장소 그룹에 대한 시스템 경로 및 트랜잭션 로그 파일 경로를 확인한 후 각 저장소 그룹에 있는 각 저장소의 데이터베이스 경로를 확인합니다. 이렇게 하려면 다음 단계를 수행합니다.

    1. 저장소 그룹을 확장합니다. 예를 들어 기본 저장소 그룹을 확장합니다.

    2. StoreName(ServerName)을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

    3. 데이터베이스 탭을 클릭하고 Exchange 데이터베이스 상자에 나타난 경로를 확인합니다. 그런 다음 Exchange 스트리밍 데이터베이스 상자에 나타난 경로를 확인합니다.

      특정 경로가 잘못된 경우 Microsoft 기술 지원 서비스에 문의하여 이 문제를 해결합니다.

    4. 7b단계와 7c단계를 반복하여 각 저장소 그룹에 있는 각 사서함 저장소 또는 공용 폴더 저장소의 경로를 확인합니다.

  8. 사서함 저장소 또는 공용 폴더 저장소를 탑재합니다.

Exchange Server 2007에서 올바른 파일 경로를 확인하고 설정하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 시작합니다. 시작을 클릭하고 프로그램, Microsoft Exchange를 차례로 가리킨 다음 Exchange 관리 콘솔을 클릭합니다.

  2. 서버 구성을 확장하고 사서함을 선택합니다.

  3. 데이터베이스 관리 창에서 탑재할 수 없는 데이터베이스가 포함된 저장소 그룹을 선택합니다.

  4. 저장소 그룹을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  5. 일반 탭에서 로그 경로 및 시스템 경로 위치에 표시된 경로를 확인합니다.

    이 경로가 잘못된 경우 저장소 그룹을 마우스 오른쪽 단추로 클릭하고 저장소 그룹 경로 이동을 선택합니다. 로그 파일 경로 및 시스템 파일 경로에서 찾아보기를 클릭하여 트랜잭션 로그 파일 또는 데이터베이스 파일이 포함된 폴더를 찾습니다. 기본적으로 트랜잭션 로그 파일 및 데이터베이스 파일은 다음 폴더에 있습니다.

    %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<저장소 그룹 이름>

  6. 확인을 클릭합니다.

  7. 있을 수 있는 각 저장소 그룹에 대해 3단계부터 5단계까지 수행하여 시스템 경로 및 트랜잭션 로그 파일 경로를 확인합니다.

  8. 각 저장소 그룹에 대한 시스템 경로 및 트랜잭션 로그 파일 경로를 확인한 후 각 저장소 그룹에 있는 각 데이터베이스의 데이터베이스 경로를 확인합니다. 이렇게 하려면 다음 단계를 수행합니다.

    1. 저장소 그룹을 확장합니다. 예를 들어 기본 저장소 그룹을 확장합니다.

    2. 데이터베이스 관리 창의 데이터베이스 파일 경로에 나타난 경로를 확인합니다.

    3. 특정 경로가 잘못된 경우 데이터베이스를 마우스 오른쪽 단추로 클릭하고 데이터베이스 경로 이동을 클릭합니다.

    4. 찾아보기를 클릭하여 올바른 데이터베이스 파일 폴더를 찾습니다. 기본적으로 Exchange 데이터베이스 파일(.edb)은 다음 폴더에 있습니다.

      %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<저장소 그룹 이름>\<데이터베이스 이름.edb>

    5. 확인을 클릭합니다.

    6. 8b단계부터 8e단계까지 수행하여 각 저장소 그룹에 있는 각 사서함 또는 공용 폴더 데이터베이스의 경로를 확인합니다.

  9. 사서함 데이터베이스 또는 공용 폴더 데이터베이스를 탑재합니다.


MSExchangeIS 9519(0xfffffbda): 기본 시스템 로캘로 구성된 더블바이트 문자 집합 로캘이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffffbda의 MSExchangeIS 9519 이벤트를 하나 이상 검색했습니다. 이 이벤트는 영어가 아닌 언어의 기본 시스템 로캘이 설치되었음을 나타냅니다. Exchange Server를 설치한 후 기본 시스템 로캘이 제거되었습니다.

설명

Exchange Server를 다시 시작할 때 오류 코드 0xfffffbda의 MSExchangeIS 9519 이벤트가 트리거된 경우 Exchange 데이터베이스가 탑재되지 않습니다. 또한 응용 프로그램 이벤트 로그에 오류 이벤트 ESE 604 및 MSExchangeIS 9519가 기록됩니다.

이전에 영어가 아닌 언어 로캘을 기본 시스템 로캘로 설정한 경우 이러한 동작이 발생할 수 있습니다. 기본 시스템 로캘로 다른 로캘을 선택하고 영어가 아닌 언어 로캘을 제거한 다음 Exchange 2000 Server 또는 Exchange Server 2003을 다시 시작한 경우 이 이벤트가 발생합니다.

이 이벤트는 -1062, JET_errInvalidLanguageId로 식별될 수 있습니다. 이 이벤트는 다음 버전의 Exchange 서버에 적용됩니다.

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

사용자 작업

이 문제를 해결하려면 영어가 아닌 언어 로캘을 다시 설치하거나 새 데이터베이스를 만듭니다. 영어가 아닌 언어 로캘을 다시 설치하는 경우 이 로캘을 기본 시스템 로캘로 설정할 필요가 없습니다.


MSExchangeIS 9519(0xfffff05b): Exchange Server 2000 SP3 이상을 실행하는 서버에서 압축된 데이터베이스 또는 로그
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-02-19

Microsoft Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffff05b의 MSExchangeIS 9519 이벤트를 하나 이상 검색했습니다. 이 오류는 Exchange 데이터베이스 또는 트랜잭션 로그 파일이 파일 시스템 압축을 사용하는 드라이브에 있음을 나타냅니다.

설명

이 이벤트는 NTFS 파일 시스템 압축을 사용하여 압축된 정보 저장소 데이터베이스가 포함된 Exchange 2000 Server에 Exchange 2000 Server 서비스 팩 3(SP3)을 적용할 때 발생할 수 있습니다. 또한 Exchange 2000 Server 컴퓨터를 Exchange Server 2003으로 업그레이드하는 경우에도 이 문제가 발생할 수 있습니다. Exchange 2000 Server SP3, Exchange Server 2003 및 Exchange Server 2007에서는 압축된 정보 저장소 데이터베이스를 탑재할 수 없습니다.

이 오류는 -4005, JET_errFileCompressed로 식별될 수 있습니다. 또한 이 오류는 다음 버전의 Exchange 서버에 적용됩니다.

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server SP3

사용자 작업

이 문제를 해결하려면 정보 저장소 데이터베이스와 로그가 있는 폴더의 압축을 풀고 데이터베이스 조각 모음을 실행한 다음 데이터베이스 및 로그가 있는 정보 저장소의 저장소 그룹의 온라인 Exchange 인식 백업을 수행해야 합니다. 이 작업을 수행하려면 Microsoft 기술 자료 문서 327772, Database does not mount, and you receive error 0xfffff05b after you apply SP3 to Exchange 2000을 참조하십시오.


MSExchangeIS 9519(0xfffffa84): 데이터베이스 인덱스가 없거나 손상되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-01-22

Microsoft® Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0xfffffa84의 MSExchangeIS 9519 이벤트를 하나 이상 검색했습니다. 이 이벤트는 이 데이터베이스의 인덱스가 손상되었거나 없음을 나타냅니다.

설명

다음과 같은 이유로 데이터베이스 인덱스가 손상되었거나 없을 수 있습니다.

  • 새로운 Microsoft Windows 서비스 팩을 적용한 후 Exchange 데이터베이스 인덱스를 정리하는 동안 이러한 문제가 발생할 수 있습니다. 서비스 팩을 적용한 후 Exchange 서버에서 사서함 또는 공용 폴더 데이터베이스를 탑재할 수 없습니다. 또한 응용 프로그램 이벤트 로그에 이벤트 ESE 609 및 ESE 611이 기록됩니다.

  • 데이터베이스 복구 작업(eseutil /p)을 실행한 후 이러한 문제가 발생할 수 있습니다. 데이터베이스 복구 작업을 실행하면 데이터베이스를 처음 만들 때 생성된 인덱스가 제거될 수 있습니다. Eseutil 복구 명령을 실행하면 인덱스가 제거됩니다.

이 오류는 -1404, JET_errIndexNotFound로 식별될 수 있습니다. 이 오류는 다음 버전의 Exchange 서버에 적용됩니다.

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

사용자 작업

이 문제를 해결하려면 앞에서 설명된 문제 시나리오에 적절한 해결 방법을 따릅니다.

  • 새로운 Windows 서비스 팩을 적용한 후 Exchange 데이터베이스 인덱스를 정리하는 동안 색인이 손상된 경우 다음 단계를 수행합니다.

    1. 알려진 백업에서 영향을 받는 사서함 또는 공용 폴더 데이터베이스를 복원합니다.

    2. eseutil /d를 실행하여 영향을 받는 데이터베이스의 오프라인 조각 모음을 실행합니다. 영향을 받는 데이터베이스의 오프라인 조각 모음을 실행하는 방법에 대한 자세한 내용은 다음 항목을 참조하십시오.

      Exchange 2000 Server 및 Exchange Server 2003 데이터베이스: How to Run Eseutil /D (Defragmentation)

      Exchange Server 2007 데이터베이스: How to Run Eseutil /D (Defragmentation)

  • 데이터베이스 복구(eseutil /p) 작업을 실행한 후 인덱스가 없어진 경우 Microsoft 기술 자료 문서 924627, Event ID 9519 that includes error 0xfffffa84 is logged when you try to mount a database after you use the Eseutil and Isinteg utilities to recover the database in Exchange 2003에 지정된 핫픽스를 적용합니다.


MSExchangeIS 9519 0x972: 공용 폴더 컨테이너가 삭제되었거나 필요한 특성이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 데이터베이스 복구 >

최근 수정된 항목: 2007-08-30

Microsoft Exchange Database Troubleshooter Tool이 응용 프로그램 로그에서 오류 코드 0x972의 MSExchangeIS 9519 이벤트를 하나 이상 검색했습니다. 이것은 공용 폴더 컨테이너가 삭제되었거나 필요한 특성이 없기 때문에 공용 폴더 데이터베이스를 탑재하지 못했음을 나타냅니다.

설명

이 오류는 공용 폴더 컨테이너가 Active Directory에서 삭제되었거나 해당 공용 저장소가 공용 폴더 컨테이너를 사용하도록 구성되어 있지 않을 때, 즉 공용 폴더 컨테이너 msExchOwningPFTreeBL 특성 값이 공용 저장소를 가리키지 않을 때 발생할 수 있습니다. 이 오류의 가장 흔한 원인은 공용 폴더 컨테이너를 새 관리 그룹으로 먼저 이동하지 않고 공용 폴더 컨테이너를 포함하고 있는 관리 그룹을 삭제한 경우입니다.

사용자 작업

이 문제를 해결하려면 ADSI 편집 또는 비슷한 도구를 사용하여 공용 폴더 컨테이너가 있는지와 msExchOwningPFTreeBL 특성이 관련 공용 저장소를 가리키도록 올바로 구성되어 있는지 확인하십시오.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
오류의 원인을 확인하려면 다음을 수행합니다.

  1. ADSI 편집이나 비슷한 도구를 사용하여 Active Directory에서 각 관리 그룹 개체를 찾습니다.

    관리 그룹 개체는 아래에서 찾을 수 있습니다.

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. 각 관리 그룹을 확장하고 CN=Folder Hierarchies 컨테이너의 존재 여부를 확인합니다. CN=Folder Hierarchies 컨테이너가 있는 경우 이 컨테이너를 강조한 후 오른쪽 창에 CN=Public Folders 개체가 있는지 확인합니다. 모든 관리 그룹 아래에 CN=Public Folders 개체가 없으면 해결 방법 1, 폴더 계층 구조 및 공용 폴더 컨테이너 다시 만들기로 이동하십시오. CN=Public Folders 컨테이너가 없으면 3단계를 계속 진행합니다.

  3. CN=Public Folders 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 특성 목록에서 msExchOwningPFTreeBL 특성을 선택한 다음 편집을 클릭합니다.

  5. 해당 공용 폴더 저장소가 값 목록에 표시되어 있는지 확인합니다. 목록에 없으면 해결 방법 2를 진행하십시오.
해결 방법 1: 폴더 계층 구조 및 공용 폴더 컨테이너 다시 만들기

  1. ADSI 편집이나 비슷한 도구를 사용하여 Exchange 관리 그룹(FYDIBOHF23SPDLT)을 찾아 확장합니다.

    Exchange 관리 그룹(FYDIBOHF23SPDLT) 개체는 아래에서 찾을 수 있습니다.

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups

  2. Exchange 관리 그룹(FYDIBOHF23SPDLT) 개체를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 클릭한 다음 개체를 클릭합니다.

  3. 클래스 선택 목록에서 msExchPublicFolderTreeContainer를 선택한 후 다음을 클릭합니다.

  4. 값 상자에 폴더 계층 구조를 입력한 후 다음을 클릭하고 마침을 클릭합니다.

  5. 새로 만든 폴더 계층 구조 개체를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 클릭한 다음 개체를 클릭합니다.

  6. 클래스 선택 목록에서 msExchPFTree를 선택한 후 다음을 클릭합니다.

  7. 값 상자에 공용 폴더를 입력한 후 다음을 클릭합니다.

  8. 추가 특성을 클릭합니다.

  9. 표시할 속성 선택 드롭다운에서 msExchPFTree를 클릭합니다.

  10. 특성 편집 상자에 1을 입력한 다음 설정, 확인을 차례로 클릭하고 마침을 클릭합니다.

  11. 각 공용 저장소에 공용 폴더 컨테이너를 할당하려면 공용 폴더 컨테이너를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  12. 특성 목록에서 distinguishedName을 클릭한 다음 편집을 클릭합니다.

  13. 값 상자의 내용을 클립보드로 복사한 다음 취소를 클릭합니다.

  14. 오류 코드 0x972의 MSExchangeIS 9519 이벤트가 발생한 각 서버에 대해 공용 폴더 저장소 개체로 이동합니다. 이 개체의 기본 위치는 다음과 같습니다.

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT), CN=Servers, CN= ServerName , CN= InformationStore , CN=Second Storage Group.

  15. 공용 폴더 저장소 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  16. 특성 목록에서 msExchOwningPFTree를 선택한 다음 편집을 클릭합니다.

  17. 13단계에서 클립보드로 복사해둔 값을 값 상자에 붙여 넣은 다음 확인을 두 번 클릭하여 마칩니다.

  18. 오류 코드 0x972의 MSExchangeIS 9519 이벤트가 발생한 각 서버에 대해 15-17단계를 반복하십시오.

  19. 해당 서버에서 Microsoft Exchange 정보 저장소 서비스를 다시 시작합니다.

해결 방법 2: 공용 폴더 컨테이너 개체의 msExchOwningPFTreeBL 특성 값을 다시 채우기

  1. ADSI 편집이나 비슷한 도구를 사용하여 Active Directory에서 공용 폴더 개체를 찾습니다.

    공용 폴더 개체는 아래에서 찾을 수 있습니다.

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Folder Hierarchies,CN=Public Folders

  2. 공용 폴더 컨테이너를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  3. 특성 목록에서 distinguishedName을 클릭한 다음 편집을 클릭합니다.

  4. 값 상자의 내용을 클립보드로 복사한 다음 취소를 클릭합니다.

  5. 오류 코드 0x972의 MSExchangeIS 9519 이벤트가 발생한 각 서버에 대해 공용 폴더 저장소 개체로 이동합니다. 이 개체의 기본 위치는 다음과 같습니다.

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT), CN=Servers, CN= ServerName , CN= InformationStore , CN=Second Storage Group.

  6. 공용 폴더 저장소 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  7. 특성 목록에서 msExchOwningPFTree를 선택한 다음 편집을 클릭합니다.

  8. 4단계에서 클립보드로 복사해둔 값을 값 상자에 붙여 넣은 다음 확인을 두 번 클릭하여 마칩니다.

  9. 오류 코드 0x972의 MSExchangeIS 9519 이벤트가 발생한 각 서버에 대해 6-8단계를 반복하십시오.

  10. 해당 서버에서 Microsoft Exchange 정보 저장소 서비스를 다시 시작합니다.


Exchange 클러스터
Microsoft Exchange Server Analyzer - 문서 >

최근 수정된 항목: 2005-11-18

이 섹션의 문서에서는 Microsoft® Exchange Server Analyzer Tool이 평가하는 Exchange 클러스터 관련 내용에 대해 자세히 설명합니다. 또한 이 문서에서는 Exchange Server Analyzer에서 발견하는 Exchange 클러스터 관련 오류, 경고 및 기본이 아닌 구성을 해결하기 위해 사용자가 취해야 할 조치를 설명합니다.


클러스터 디버깅을 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 클러스터 디버깅이 서버에서 활성화되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Cluster\Debug

Exchange Server Analyzer에서 Debug 값이 1과 같음을 확인하면 경고를 표시합니다.

이 레지스트리 값의 클러스터 디버깅으로 인해 클러스터 리소스가 노드 간에 장애 조치를 수행하지 못합니다. 리소스가 장애 조치되지 못하도록 하는 문제를 디버깅할 때만 이 레지스트리 값을 사용해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
클러스터 디버깅 레지스트리 키를 사용하지 못하도록 하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\Microsoft\Exchange\Cluster 항목을 탐색합니다.

  3. Debug 값을 0으로 변경합니다.

  4. 레지스트리 편집기를 종료합니다.

레지스트리를 편집하기 전 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange 클러스터에 대한 자세한 내용은 Exchange 2003 Server 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "Exchange Server 2003의 Exchange 클러스터 관리"를 참조하십시오.


클러스터 전용 하트비트 네트워크 우선 순위가 잘못 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange 서버 클러스터에 있는 각 네트워크 인터페이스 리소스의 우선 순위를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Priority

네트워크 인터페이스 리소스에 대해 구성된 Priority 값은 네트워크 우선 순위를 나타냅니다. 우선 순위가 가장 높은 네트워크 인터페이스 리소스의 Priority 값은 1이고 다음으로 우선 순위가 높은 네트워크 인터페이스 리소스의 값은 2가 되는 식으로 구성됩니다.

또한 Exchange Server Analyzer는 Exchange 서버 클러스터의 각 네트워크에 대해 정의된 역할을 확인하기 위해 다음 레지스트리 항목을 확인합니다.

HKLM\Cluster\Networks\<NetworkInterfaceGUID>\Role

값이 1인 경우 네트워크 리소스가 전용 개인(하트비트) 네트워크로 구성되어 있음을 나타냅니다. 값이 2인 경우 네트워크 리소스가 전용 공용(클라이언트 액세스) 네트워크로 구성되어 있음을 나타냅니다. 값이 3인 경우 네트워크 리소스가 하트비트 트래픽과 클라이언트 액세스 트래픽을 모두 허용하는 혼합 네트워크로 구성되어 있음을 나타냅니다.

Exchange Server Analyzer는 Role 값이 1인 네트워크 인터페이스 리소스의 Priority 값이 1보다 크게 설정되어 있으면 경고를 표시합니다. 이 경고는 전용 하트비트 네트워크가 발견되었지만 해당 네트워크의 우선 순위가 잘못 설정되어 있음을 나타냅니다.

모든 Exchange Server 클러스터의 전용 개인 네트워크는 클러스터 하트비트에 사용되도록 구성하는 것이 좋습니다. 클러스터 작업이 순조롭게 수행되려면 노드 간의 통신이 매우 중요합니다. 다음 설명에 따라 전용 하트비트 네트워크의 네트워크 우선 순위를 올바르게 구성합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 클러스터 관리자를 열고 Exchange 서버 클러스터에 연결합니다.

  2. 왼쪽 창의 계층 구조 맨 위에 있는 클러스터 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 네트워크 우선 순위를 클릭합니다.

  4. 전용 하트비트 네트워크 리소스를 선택합니다.

  5. 전용 하트비트 네트워크 리소스가 네트워크 리소스 목록의 맨 위로 이동할 때까지 위로 이동을 클릭합니다.

  6. 확인을 클릭합니다.

클러스터 하트비트 네트워크에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 258750, "클러스터 서버에 권장하는 개인 "하트비트" 구성""(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)

  • 307962, "Multicast Support Enabled for the Cluster Heartbeat"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

자세한 내용은 Exchange Server 2003 Cluster Configuration Checklist(http://go.microsoft.com/fwlink/?linkid=36083)를 검토하십시오.


클러스터 노드 Windows 빌드 번호가 첫 번째 노드와 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 클러스터의 각 노드에서 실행 중인 Microsoft Windows® 운영 체제의 기본 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Cluster\Nodes\<Node Number>\BuildNumber

Exchange Server Analyzer는 Exchange 클러스터에 있는 두 번째 노드나 후속 노드의 BuildNumber 값이 해당 Exchange 클러스터에 있는 첫 번째 노드의 BuildNumber 값과 다르면 오류를 표시합니다.

Exchange 클러스터가 서로 다른 버전의 Windows를 실행할 경우 장애 조치(failover)가 예상했던 것이나 구성된 것과 다르게 발생할 수 있습니다. 혼합 Windows 제품 환경에서 장애 조치(failover)는 이전 버전의 운영 체제에서 이후 버전의 운영 체제로만 발생합니다. 예를 들어 장애 조치(failover)는 Windows 2000 Advanced Server에서 Windows Server™ 2003, Enterprise Edition으로 발생합니다. 이후 버전의 운영 체제에서 이전 버전의 운영 체제로는 발생하지 않습니다. 예를 들어 Windows Server 2003에서 Windows 2000 Server로는 발생하지 않습니다.

이 문제를 해결하려면 모든 노드를 같은 운영 체제와 서비스 팩으로 업그레이드해야 합니다. 시스템 중단 시간을 최소화하려면 클러스터의 롤링 업그레이드를 수행합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Microsoft 기술 자료 문서 811272, "Windows Server 2003 서버 클러스터의 롤링 업그레이드를 수행하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272)을 읽어 클러스터의 롤링 업그레이드를 수행하기 위한 지침을 검토하십시오.

  2. "Windows 2000 Clustering: Performing a rolling upgrade"(http://go.microsoft.com/fwlink/?linkid=1718) 문서를 검토하십시오.

  3. 해당 BuildNumber 값이 클러스터의 첫 번째 노드와 다른 노드 각각의 롤링 업그레이드를 수행합니다.

다른 절차에 대한 자세한 내용은 "Alternatives to Rolling Upgrades"(http://go.microsoft.com/fwlink/?LinkId=41363)를 참조하십시오.


클러스터 노드 Windows 서비스 팩 버전이 첫 번째 노드와 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 클러스터의 각 노드에 설치된 Microsoft Windows® 서비스 팩 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Cluster\Nodes\<Node Number>\CSDVersion

Exchange Server Analyzer는 Exchange 클러스터의 두 번째 또는 후속 노드에 있는 CSDVersion 값이 Exchange 클러스터의 첫 번째 노드에 있는 CSDVersion 값과 다르면 오류를 표시합니다.

이 오류는 이 Exchange 클러스터의 노드가 같은 수준의 Windows 서비스 팩을 실행하고 있지 않음을 나타냅니다. Exchange 클러스터의 모든 노드는 같은 수준의 운영 체제와 서비스 팩을 실행하는 것이 좋습니다.

이 문제를 해결하려면 모든 노드를 같은 운영 체제 및 서비스 팩으로 업그레이드해야 합니다. 중단 시간을 최소화하려면 클러스터의 롤링 업그레이드를 수행하면 됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Microsoft 기술 자료 문서 811272, "Windows Server 2003 서버 클러스터의 롤링 업그레이드를 수행하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272)을 읽고 클러스터의 롤링 업그레이드 수행 지침을 검토하십시오.

  2. "Windows 2000 Clustering: Performing a Rolling Upgrade"(http://go.microsoft.com/fwlink/?linkid=34288) 문서를 검토하십시오.

  3. CSDVersion 값이 클러스터의 첫 번째 노드와 다른 각 노드에 대해 롤링 업그레이드를 수행합니다.

다른 절차에 대한 자세한 내용은 "Alternatives to Rolling Upgrades"(http://go.microsoft.com/fwlink/?linkid=34289)를 참조하십시오.


클러스터 TEMP/TMP 경로가 시스템 파티션이 있는 드라이브에 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2005-11-18

클러스터되지 않은 Exchange Server 컴퓨터에서 Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 TEMP 및 TMP 환경 변수 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

Microsoft Windows® 서버 클러스터의 EVS(Exchange 가상 서버)에 대해 Exchange Server Analyzer를 실행할 경우 이 프로그램은 HKLM 레지스트리 하이브를 읽지 않습니다. 대신 다음 레지스트리 항목을 읽습니다.

HKEY_USERS\<클러스터 서비스 계정 SID>\Environment\TEMP

HKEY_USERS\<클러스터 서비스 계정 SID>\Environment\TMP

Exchange Server Analyzer는 TEMP 및/또는 TMP 환경 변수가 %SYSTEMROOT로 시작될 경우 경고를 표시합니다.

Microsoft Exchange Information Store 서비스 프로세스는 메시지 변환 및 사서함 이동 작업 같은 다양한 작업 중에 임시 저장소로 TEMP 및 TMP 폴더를 사용합니다. 클러스터되지 않은 Exchange 서버에서 Microsoft Exchange Information Store는 TEMP 및 TMP 둘 모두에 대해 기본 환경 변수 설정 %Systemroot%\Temp를 사용하는 SYSTEM(예: Local System)을 사용합니다.

Windows 서버 클러스터에서 실행되는 EVS는 특정 사용자 보안 규칙 컨텍스트에서 실행되는 클러스터 서비스 계정에 대해 이 환경 변수 설정을 사용합니다. 사용자 계정의 경우 TEMP 및 TMP에 대한 기본 환경 변수는 %Userprofile%\temp로 설정됩니다.

TEMP 및 TMP 환경 변수는 임시 작업 영역을 필요로 하는 응용 프로그램에 사용되는 파일 시스템의 폴더(경로)를 지정하는 데 사용됩니다. TEMP는 일반적으로 Exchange 같은 응용 프로그램에 사용되고 TMP는 Microsoft Visual C++® 같은 개발 도구에 주로 사용됩니다. 각 변수의 경로는 보통 응용 프로그램이나 도구의 보안 컨텍스트와 관련이 있습니다.

최적의 성능을 위해서는 Exchange에 사용되는 TEMP 및 TMP 폴더를 운영 체제가 포함된 디스크가 아닌 다른 디스크에 배치하는 것이 좋습니다. 또한 이러한 환경 변수는 RAID 0+1 스핀들 세트 같은 빠른 디스크 또는 디스크 하위 시스템의 경로로 설정되어야 합니다. 뿐만 아니라 Exchange 또는 Exchange 가상 서버에 사용되는 TEMP 및 TMP 폴더를 운영 체제가 포함된 디스크가 아닌 다른 디스크에 배치하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 클러스터 서비스 계정으로 클러스터의 노드에 로그온합니다.

  2. 내 컴퓨터를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  3. 고급을 선택합니다.

  4. 환경 변수를 클릭합니다.

  5. <account name>에 대한 사용자 변수 영역에서 TEMP를 선택하고 편집을 클릭합니다.

  6. 변수 값 필드에 TEMP 환경 변수의 새 경로를 입력하고 확인을 클릭합니다.

  7. <account name>에 대한 사용자 변수 영역에서 TMP를 선택하고 편집을 클릭합니다.

  8. 변수 값 필드에 TMP 환경 변수의 새 경로를 입력하고 확인을 클릭합니다.

  9. 확인을 클릭하여 환경 변수 대화 상자를 닫고 확인을 한 번 더 클릭하여 시스템 속성 대화 상자를 닫습니다.

  10. 노드를 다시 시작하여 변경 내용을 적용합니다.

  11. 클러스터의 각 노드에 대해 1-10단계를 반복합니다.

클러스터되지 않은 Exchange Server 컴퓨터에서의 TEMP/TMP 환경 변수 변경에 대한 자세한 내용은 TEMP/TMP 변수가 잘못되거나 적합하지 않은 폴더를 가리킵니다. 링크를 참조하십시오.


전용 클러스터 하트비트를 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange 서버 클러스터에서 각 네트워크 인터페이스 리소스에 정의된 역할을 확인합니다.

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Role

이 값이 1로 설정되면 네트워크 리소스가 개인 전용(하트비트) 네트워크로 구성되었음을 나타냅니다. 이 값이 2로 설정되면 네트워크 리소스가 공용 전용 네트워크(클라이언트 액세스)로 구성되었음을 나타냅니다. 값이 3인 경우 네트워크 리소스가 하트비트 트래픽과 클라이언트 액세스 트래픽을 모두 허용하는 혼합 네트워크로 구성되어 있음을 나타냅니다.

Exchange Server Analyzer는 ClusSvc(Cluster Service)의 Started 키 값을 확인할 때 Win32_Service WMI(Microsoft Windows® Management Instrumentation) 클래스를 쿼리합니다. 값이 True이면 클러스터 서비스가 시작되었음을 나타내고 False이면 클러스터 서비스가 실행되고 있지 않음을 나타냅니다.

Exchange Server Analyzer Tool은 Exchange 클러스터가 개인 전용 네트워크로 설정되어 있지 않을 경우 경고를 표시합니다.

모든 Exchange Server 클러스터에 권장하는 설정은 개인 전용 네트워크를 클러스터 하트비트용으로 구성하는 것입니다. 노드 간의 통신은 원활한 클러스터 작업에 중요합니다. 클러스터 통신에 사용되는 네트워크는 최적 설정으로 구성해야 하고 모든 하드웨어 호환성 목록의 요구 사항을 따라야 합니다. 네트워킹 구성 시 2개 이상의 독립형 네트워크와 클러스터의 노드를 연결하여 단일 지점에서 오류가 발생하지 않도록 해야 합니다. 일반적으로 2개의 LAN을 사용합니다. 클러스터의 노드에 네트워크 1개만 연결되도록 구성할 수는 없습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 이전에 설치한 네트워크 인터페이스 카드가 없으면 네트워크 인터페이스 카드를 Exchange 클러스터의 각 노드에 추가하고 이 카드를 Cluster Administrator에서 개인 네트워크로 구성합니다.

  2. 추가적인 네트워크 카드가 있지만 혼합 네트워크용으로 사용되고 있으면 구성을 수정하여 해당 네트워크가 개인 전용 네트워크의 역할을 하도록 다시 구성해야 합니다.

클러스터 하트비트 네트워크에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 258750, "클러스터 서버에 권장하는 개인 "하트비트" 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)

  • 307962, "Multicast Support Enabled for the Cluster Heartbeat"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

자세한 내용은 Exchange Server 2003 Cluster Configuration Checklist (http://go.microsoft.com/fwlink/?linkid=36083) 문서를 검토하십시오.


cluster.log의 기본 파일 크기는 32로 증가해야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 ClusterLogSize 매개 변수의 설정 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment\

Exchange Server Analyzer는 ClusterLogSize 값이 없거나 ClusterLogSize 값이 8보다 작거나 같음을 확인하면 경고를 표시합니다. 사용량이 많은 클러스터에서 cluster.log 파일은 다음과 같은 조건에서 장애 조치 상황을 해결할 때 빠르게 겹쳐쓰여지므로 항목이 손실될 수도 있습니다.

  • 문제를 해결하려면 클러스터 로그 파일을 자세히 검토해야 합니다.

  • 클러스터는 다수의 리소스를 관리합니다.

따라서 문제를 해결하기 위해 cluster.log 파일을 사용해야 할 때 ClusterLogSize 매개 변수를 만들고(없는 경우) 기본 크기를 적어도 32, 64 또는 96으로 증가시켜야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
ClusterLogSize 매개 변수를 만들고 값을 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedit32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment를 탐색합니다.

  3. 왼쪽 창에서 환경을 클릭합니다.

  4. 편집 메뉴에서 새로 만들기를 가리킨 다음 DWORD 값을 클릭합니다.

  5. ClusterLogSize를 입력한 다음 Enter 키를 눌러 새 레지스트리 항목에 이름을 지정합니다.

  6. ClusterLogSize를 마우스 오른쪽 단추로 클릭한 다음 수정을 클릭합니다.

  7. ClusterLogSize 값 데이터를 새 로그 파일 크기로 수정합니다. 예를 들어 ClusterLogSize 값을 32, 64 또는 96으로 수정한 다음 Enter 키를 누릅니다.

  8. 레지스트리 편집기를 종료합니다.
cluster.log 파일의 기본 크기를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment를 탐색합니다.

  3. ClusterLogSize를 마우스 오른쪽 단추로 클릭한 다음 수정을 클릭합니다.

  4. ClusterLogSize 값 데이터를 새 로그 파일 크기로 수정합니다. 예를 들어 ClusterLogSize 값을 32, 64 또는 96으로 수정한 다음 Enter 키를 누릅니다.

  5. 레지스트리 편집기를 종료합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Microsoft Cluster Server의 클러스터 로깅에 대한 자세한 내용은 Microsoft 기술 자료 문서 168801, "How to Turn on Cluster Logging in Microsoft Cluster Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=168801)를 참조하십시오.


SMTP용 Kerberos 인증 사용
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2006-05-12

The Microsoft® Exchange Server Analyzer Tool에서는 Active Directory® 디렉터리 서비스를 쿼리하여 Windows™ Server 2003 클러스터 서비스에 설치된 Microsoft Exchange Server 2003 서버에 servicePrincipalName 특성에 대한 SMTPSVC 리소스 값으로 서버의 정규화된 도메인 이름(FQDN)이 있는지 확인합니다.

Exchange Server Analyzer에서 클러스터 서비스의 SMTPSVC Exchange 리소스에 대한 servicePrincipalName 특성에 서버의 FQDN이 값으로 포함되지 않음을 발견하면 최적의 메시지가 표시됩니다.

Exchange Server 2003을 실행하는 Windows Server 2003 클러스터 서버에서 SMTP(Simple Mail Transfer Protocol)에 대한 Kerberos 인증을 사용하는 것이 좋습니다. SMTPSVC Exchange 리소스의 새로운 SPN(서비스 사용자 이름) 값을 수동으로 설정하여 Kerberos 인증을 사용할 수 있습니다.

기본적으로 Windows Server 2003은 NTLM 인증을 사용합니다. Kerberos 프로토콜은 NTLM보다 사용이 용이하고 효율적이며 안전합니다. Kerberos 인증 사용에 따른 이점은 다음과 같습니다.

  • 빠른 연결. 응용 프로그램 서버는 NTLM 인증을 사용하여 각각의 클라이언트를 인증하기 위해 도메인 컨트롤러에 연결되어야 합니다. 서버는 Kerberos 인증을 사용하여 도메인 컨트롤러를 찾을 필요는 없습니다. 서버는 클라이언트의 자격 증명을 검사하여 클라이언트를 인증할 수 있습니다. 클라이언트는 특정 서버에 대한 자격 증명을 한 번 얻으면 네트워크 로그온 세션을 통해 재사용할 수 있습니다.

  • 상호 인증. 서버에서 NTLM을 사용하여 클라이언트 ID를 확인할 수 있습니다. NTLM을 사용하여 클라이언트에서 서버 ID를 확인하거나 한 서버에서 다른 서버 ID를 확인할 수 없도록 할 수 있습니다. NTLM 인증은 서버가 정품이란 가정 아래에 네트워크 환경용으로 디자인되었습니다. Kerberos 프로토콜은 그러한 가정이 필요하지 않습니다. 네트워크 연결의 양쪽 끝에서 반대쪽 끝에 있는 서버 또는 클라이언트의 ID를 확인할 수 있습니다.

  • 위임된 인증. Windows 서비스는 클라이언트 대신 리소스에 액세스할 때 클라이언트를 가장합니다. 서비스는 종종 로컬 컴퓨터의 리소스에 액세스하여 클라이언트에 대한 작업을 완료할 수 있습니다. NTLM과 Kerberos는 로컬로 서비스의 클라이언트를 가장하기 위해 서비스에 꼭 필요한 정보를 제공합니다. 그러나 일부 분산된 응용 프로그램은 프런트 엔드 서비스에서 다른 컴퓨터의 백 엔드 서비스에 연결할 때 클라이언트를 가장하도록 디자인되었습니다. Kerberos 프로토콜에는 서비스에서 다른 서비스에 연결할 때 해당 서비스의 클라이언트를 가장할 수 있는 프록시 메커니즘이 있습니다. NTLM에 사용할 수 있는 동일한 메커니즘이 없습니다.

이 문제를 해결하려면 다음 단계를 따라 영향을 받는 특성에 대해 누락된 값을 추가합니다.

누락된 값을 사용하여 SPN을 추가하려면 SETSPN.exe 도구를 사용합니다.

  1. Setspn.exe 도구를 설치합니다. Setspn.exe 도구를 얻으려면, http://go.microsoft.com/fwlink/?LinkId=28103(영문)의 "Windows 2000 Resource Kit Tool : Setspn.exe"를 참조하십시오.

    Setspn.exe 명령줄 도구의 Windows Server 2003 버전은 Windows Server 2003 CD에 포함된 Windows Server 2003 지원 도구에서 사용할 수 있습니다. Server 2003 지원 도구를 설치하려면 지원/도구 폴더 안의 Suptools.msi 파일을 두 번 클릭합니다.

  2. Exchange 서버의 Active Directory 개체에 누락된 값을 추가하려면 SETSPN.EXE Setspn_d.txt 파일의 지침을 따릅니다. 다음 예는 가상 SMTP 서버 SPN의 FQDN 값 추가에 대해 설명합니다.

    • 명령 프롬프트를 시작하고 Setspn.exe를 설치한 디렉터리로 변경합니다.

    • 명령 프롬프트에 다음 명령을 입력합니다.

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      참고:
      mail.yourdomain.com을 SMTP 가상 서버 FQDN로 바꾸고 YOURSERVERNAME을 Exchange 서버 이름으로 바꿉니다.
    • 그럼 다음 Enter 키를 누릅니다.


Exchange 클러스터 노드에 연결할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 클러스터 서비스(ClusSvc)의 Started 키 값을 확인합니다. 값이 True이면 클러스터 서비스가 시작되었음을 나타내고 False이면 클러스터 서비스가 실행되고 있지 않음을 나타냅니다.

또한 Exchange Server Analyzer는 Exchange Server 컴퓨터에서 실행 중인 Windows 버전을 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 4.0은 해당 컴퓨터에 Microsoft Windows NT® Server 4.0이 실행되고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터에 Windows 2000 Server가 실행되고 있음을 나타내고 값 5.2는 해당 컴퓨터에 Windows Server™ 2003이 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 클러스터에서 실행 중인 Windows 버전을 확인할 수 없거나 클러스터 서비스가 실행 중인지 여부를 확인할 수 없으면 오류를 표시합니다. 이 오류는 Exchange Server Analyzer에서 Exchange Server 클러스터의 노드에 연결할 수 없음을 나타냅니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. ping 명령을 사용하여 Exchange Server 컴퓨터에 도달할 수 있는지 확인합니다.

  3. 방화벽이 설치되어 있으면 RPC(원격 프로시저 호출) 포트가 차단되었는지 확인합니다.

  4. Exchange Server 컴퓨터의 원격 레지스트리 서비스가 시작되었는지 확인합니다.

  5. Exchange Server Analyzer를 실행 중인 계정에 Exchange Server 컴퓨터의 레지스트리를 읽을 수 있는 충분한 사용 권한이 있는지 확인합니다.

네트워크 연결 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.


Active Directory의 Exchange 데이터 경로가 클러스터 레지스트리와 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2006-04-28

Microsoft® Exchange Server Analyzer Tool은 클러스터 레지스트리(HKEY_LOCAL_MACHINE\Cluster)와 Active Directory® 디렉터리 서비스를 모두 쿼리하여 Exchange 데이터 파일(예: 메시지 추적 로그 파일)의 경로가 두 곳에서 동일한지 확인합니다. Exchange Server는 Exchange 설치 프로그램을 사용하여 Microsoft Windows® 서버 클러스터의 노드에 Exchange를 설치할 때 이러한 값을 레지스트리와 Active Directory에 구성합니다.

Exchange 설치 프로그램이 만들고 Exchange Server Analyzer가 읽는 레지스트리 값은 다음과 같습니다.

HKLM\Cluster\Resources\<Resource GUID of Information Store resource>\Parameters\DestPath

Exchange 설치 프로그램이 만들고 Exchange Server Analyzer가 읽는 Active Directory 값은 msExchDataPath입니다. 이 값은 Active Directory에 있는 Exchange Server 컴퓨터 개체의 특성이며 다음 위치에 있습니다.

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganizationName =Administrative Groups, CN= AdministrativeGroupName , CN=Servers, CN= ServerName

Exchange Server Analyzer는 DestPath와 msExchDataPath의 값이 일치하지 않는 경우 오류를 표시합니다.

이러한 값이 일치하지 않는 일반적인 이유는 Exchange가 업무 환경에 사용된 후 Exchange 데이터 파일의 일부 또는 전부의 위치가 변경되었기 때문입니다. 예를 들어 하드웨어 업그레이드, 메시지 추적 로그 파일 이동, 드라이브 문자 변경 등의 변경 내용이 클러스터 레지스트리에는 반영되지만 Active Directory에는 반영되지 않는 경우입니다. 이러한 변경 후, 특히 Exchange 서비스 팩을 적용하거나 롤업 패키지를 설치할 때는 서비스 시작 오류, 데이터베이스 탑재 문제 및 기타 문제가 발생할 수 있습니다.

참고:
이러한 불일치는 가능하면 즉시 해결해야 합니다. 이 문제가 해결될 때까지는 Exchange Server에 대한 서비스 팩이나 업데이트를 설치하지 마십시오.

다음 절차를 수행하려면 ADSI(Active Directory Service Interfaces) 편집 또는 LDP(ldp.exe) 도구와 같은 Active Directory 편집기를 사용해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. EVS(Exchange 가상 서버)의 msExchDataPath 값이 클러스터 레지스트리의 DestPath 값과 일치하도록 수정합니다. msExchDataPath 특성의 위치는 CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName입니다.

  2. 가상 서버의 Exchange System Attendant 리소스를 다시 시작하여 변경 내용을 적용합니다.

LDP 도구를 사용하여 Active Directory를 수정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ADSI 편집을 사용하여 msExchDataPath 특성을 수정하는 방법에 대한 자세한 내용은 기술 자료 문서 288362, "XADM: "The System Cannot Find the Path Specified" Event ID 5007 Message is Logged by the Microsoft Exchange System Attendant"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288362)를 참조하십시오.


이벤트 로그를 복제할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 클러스터의 노드인 각 서버에서 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Cluster\Nodes\X\EnableEventLogReplication

참고:
X는 노드 수이며 1로 시작합니다.

Exchange Server Analyzer는 EnableEventLogReplication 값이 1인 경우 유용한 정보 메시지를 표시합니다.

EnableEventLogReplication 레지스트리 항목이 1로 설정되면 클러스터 노드는 이벤트 로그의 이벤트를 해당 클러스터의 다른 모든 노드에 복제합니다. 이벤트 로그를 복제할 수 있으면 MOM(Microsoft Operations Manager)과 같이 여러 서버를 모니터링하는 도구는 단일 이벤트를 각 노드에서 한 번씩, 여러 번 보고합니다. 자동 모니터링을 사용할 경우 클러스터 노드에서 이벤트 로그를 복제하지 않도록 설정하는 것이 좋습니다.

클러스터의 모든 노드에서 이벤트 로그를 복제하지 않도록 설정하려면 다음을 수행합니다.

  1. 도메인 사용자 계정 또는 글로벌 그룹 구성원인 계정으로 클러스터 노드에 로그온합니다.

  2. 시작 및 실행을 차례로 클릭한 다음 입력합니다.

    cluster /prop EnableEventLogReplication=0
단일 클러스터 노드에서 이벤트 로그를 복제하지 않도록 설정하려면 다음을 수행합니다.

  1. 도메인 사용자 계정 또는 글로벌 그룹 구성원인 계정으로 클러스터 노드에 로그온합니다.

  2. 시작 및 실행을 차례로 클릭한 다음 입력합니다.

    Cluster <name of node to disable> /prop EnableEventLogReplication=0

이벤트 로그 복제를 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 224969, "HOW TO: Configure Event Log Replication in Windows 2000 Cluster Servers"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224969)를 참조하십시오.

서버 클러스터 관리에 대한 자세한 내용은 Administering Server Clusters(http://go.microsoft.com/fwlink/?LinkId=45971)를 참조하십시오.


네트워크 이름 리소스에 Kerberos를 사용하지 않도록 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 서버에서 실행 중인 Microsoft Windows® 운영 체제의 버전을 확인하기 위해 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 4.0은 해당 컴퓨터가 Windows NT® Server 4.0을 실행하고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터에 Windows 2000 Server 운영 체제가 실행되고 있음을 나타내고, 값 5.2는 해당 컴퓨터에 Windows Server™ 2003 운영 체제가 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 5.5"가 포함되어 있으면 컴퓨터에서 Exchange Server 5.5가 실행되고 있는 것입니다. 문자열 값에 "Version 6.0"이 포함되어 있으면 컴퓨터에서 Exchange Server 2000이 실행되고 있는 것입니다. 문자열 값에 "Version 6.5"가 포함되어 있으면 컴퓨터에서 Exchange Server 2003이 실행되고 있는 것입니다.

마지막으로 Exchange Server Analyzer는 Exchange Server가 네트워크 이름 클러스터 리소스에 Kerberos 사용이 가능한 클러스터에서 실행되고 있는지 확인하기 위해 다음 레지스트리 값을 읽습니다.

HKLM\Cluster\Resources\<Resource GUID for Network Name resource>\Parameters\RequireKerberos

RequireKerberos의 값이 0이면 네트워크 이름 리소스에 Kerberos를 사용할 수 없음을 나타내고 값이 1이면 네트워크 이름 리소스에 Kerberos를 사용할 수 있음을 나타냅니다.

Windows Server 2003 서버 기반 클러스터에서 실행 중인 Exchange Server 2003 가상 서버의 RequireKerberos 값이 0으로 설정되어 있는 것으로 확인되면 경고가 표시됩니다.

이 경고는 Exchange Server 2003 가상 서버에 Kerberos를 사용하는 네트워크 이름 클러스터 리소스가 사용되지 않고 있음을 나타냅니다. 이러한 구성은 지원되지 않으므로 바로 수정해야 합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 클러스터 관리자 프로그램을 엽니다.

  2. 네트워크 이름 리소스를 오프라인으로 전환합니다. 그렇게 하면 Microsoft Exchange System Attendant를 포함하여 해당 네트워크 이름 리소스에 의존하는 모든 리소스가 오프라인으로 전환됩니다.

  3. 네트워크 이름 리소스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 매개 변수 탭에서 Kerberos 인증 사용 옵션을 클릭한 다음 확인을 클릭합니다.

  5. 네트워크 이름 리소스를 온라인으로 전환한 다음 오프라인 상태인 나머지 리소스를 온라인으로 전환합니다.

Windows Server 2003 클러스터에서 Kerberos 사용 네트워크 이름 리소스를 사용하는 데 대한 자세한 내용은 Microsoft 기술 자료 문서 302389, "Windows Server 2003의 클러스터 네트워크 이름 리소스 속성에 대한 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=302389)을 참조하십시오.

클러스터링에 대한 자세한 내용은 다음 항목을 참조하십시오.

  • Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?linkid=47569)의 "클러스터에 Exchange Server 2003 배포"

  • Exchange Server 2003 높은 수준의 가용성 가이드(http://go.microsoft.com/fwlink/?linkid=47571)의 "Exchange 클러스터링을 위한 계획"


네트워크 이름 리소스에 Kerberos를 사용하도록 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 서버에서 실행 중인 Microsoft Windows® 운영 체제의 버전을 확인하기 위해 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값이 4.0이면 해당 컴퓨터가 Windows NT® Server 4.0을 실행하고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터에 Windows® 2000 Server 운영 체제가 실행되고 있음을 나타내고, 값 5.2는 해당 컴퓨터에 Windows Server™ 2003 운영 체제가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 5.5"가 포함되어 있으면 컴퓨터에서 Exchange Server 5.5가 실행되고 있는 것입니다. 문자열 값에 "Version 6.0"이 있으면 해당 컴퓨터에 Exchange Server 2000 Server가 실행 중입니다. 문자열 값에 "Version 6.5"가 포함되어 있으면 컴퓨터에서 Exchange Server 2003이 실행되고 있는 것입니다.

마지막으로 Exchange Server Analyzer는 Exchange가 네트워크 이름 클러스터 리소스에 Kerberos 사용이 가능한 클러스터에서 실행되고 있는지 확인하기 위해 다음 레지스트리 값을 읽습니다.

HKLM\Cluster\Resources\<Resource GUID for Network Name resource>\RequireKerberos

RequireKerberos의 값이 0이면 네트워크 이름 리소스에 Kerberos를 사용할 수 없음을 나타내고 값이 1이면 네트워크 이름 리소스에 Kerberos를 사용할 수 있음을 나타냅니다.

Windows 2000 Server 서버 기반 클러스터에서 실행되는 Exchange 2000 Server 가상 서버의 RequireKerberos 값이 1로 설정되어 있는 것으로 확인되면 경고가 표시됩니다.

이 경고는 Exchange 2000 Server 가상 서버에 Kerberos를 사용하는 네트워크 이름 클러스터 리소스가 사용되고 있음을 나타냅니다. 이러한 구성은 지원되지 않으므로 바로 수정해야 합니다. Microsoft 기술 자료 문서 235529, "Kerberos support on Windows 2000-based server clusters"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529)에 설명된 바와 같이 Exchange 2000 Server 네트워크 이름 리소스의 Kerberos 인증은 지원되지 않습니다. Exchange 2000 Server는 클러스터된 Exchange 2000 Server 가상 서버의 Kerberos 인증 지원에 대한 테스트를 거치지 않았습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 클러스터의 노드에서 명령 프롬프트를 엽니다.

  2. cluster res "Name of Network Name Resource" /priv requirekerberos=0:dword 명령을 실행합니다.

    참고:
    리소스 이름은 따옴표로 묶어야 합니다.

  3. 네트워크 이름 리소스를 오프라인으로 전환한 후 삭제합니다.

  4. Active Directory 사용자 및 컴퓨터를 엽니다.

  5. 삭제한 네트워크 이름 리소스의 컴퓨터 계정 개체를 찾아 Active Directory에서 삭제합니다.

  6. 해당 EVS(Exchange 가상 서버)에 대한 네트워크 이름 리소스를 새로 만들고 Kerberos를 사용하지 않도록 설정합니다. 3단계에서 삭제한 네트워크 이름 리소스와 동일한 이름과 구성을 새 네트워크 이름 리소스에 사용할 수 있습니다.

  7. 새 네트워크 이름 리소스를 온라인으로 전환한 다음 EVS의 나머지 리소스를 온라인으로 전환합니다.

Windows 2000 Server 클러스터에서 Kerberos 사용 네트워크 이름 리소스를 사용하는 데 대한 자세한 내용은 Microsoft 기술 자료 문서 235529, "Kerberos support on Windows 2000-based server clusters"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529)를 참조하십시오.


MSDTC가 클러스터에 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2006-04-20

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽고 클러스터에 MSDTC(Microsoft Distributed Transaction Coordinator) 리소스가 있는지 확인합니다.

HKEY_LOCAL_MACHINE\Cluster\Resources\

ClusterMSDTCInstance의 값이 0인 경우 Exchange Server Analyzer는 경고를 표시합니다.

초기 설치와 서비스 팩 업그레이드를 지원하려면 Exchange Server 클러스터에 MSDTC 리소스가 있어야 합니다. 그러나 중요한 구성 요소는 아니므로 Exchange를 실행하는 동안에는 필요하지 않습니다.

Exchange 실행 중에는 MSDTC 리소스가 필요하지 않으므로 사용자나 조직의 다른 관리자가 이 리소스를 제거했을 수 있습니다.

그러나 Exchange Server 2003 초기 설치 후에는 MSDTC 리소스를 제거하지 않는 것이 좋습니다. MSDTC 리소스를 클러스터에 저장해 두면 서비스 팩 설치 및 기타 업데이트를 실행할 수 있습니다.

이 경고를 해결하려면 MSDTC 리소스를 새로 만듭니다. MSDTC 리소스를 만드는 방법에 대한 자세한 내용은 Exchange Server 2003 Deployment Guide(http://go.microsoft.com/fwlink/?LinkId=47569)의 "How to Install the Microsoft Distributed Transaction Coordinator in a Windows Server 2003 Server Cluster"를 참조하십시오.

추가 정보

MSDTC 및 Exchange에 대한 자세한 내용은 Exchange Server 2003 높은 가용성 가이드(http://go.microsoft.com/fwlink/?LinkId=47571)의 "Exchange Server 2003 클러스터링 이해"에서 "클러스터 그룹"을 참조하십시오.

Microsoft Windows Server™ 2003에서 MSDTC 리소스를 추가하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 301600, "How to Configure Microsoft Distributed Transaction Coordinator on a Windows Server 2003 Cluster"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600)를 참조하십시오.

참고:
기술 자료 문서 301600에는 기술 자료 문서 817064, "Windows Server 2003에서 네트워크 DTC 액세스를 사용 가능하게 설정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064)에 대한 참조가 포함되어 있습니다. Exchange Server 보안을 위한 가장 좋은 방법은 Exchange 클러스터에 대해 네트워크 DTC 액세스를 사용할 수 없게 설정하는 것입니다. Exchange 클러스터에 대해 DTC(Distributed Transaction Coordinator) 리소스를 구성하는 경우 네트워크 DTC 액세스를 사용하지 마십시오.


MSDTC 오류가 클러스터 그룹에 영향을 줍니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2006-03-16

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽고 MSDTC(Microsoft Distributed Transaction Coordinator) 리소스 오류가 그룹에 영향을 주도록 구성되었는지 확인합니다.

HKEY_LOCAL_MACHINE\Cluster\Resources\

ClusterMSDTCInstance의 값이 2이면 Exchange Server Analyzer는 경고를 표시합니다.

초기 설치와 서비스 팩 업그레이드를 지원하려면 Exchange 클러스터에 MSDTC 리소스가 있어야 합니다. 그러나 Exchange를 실행하는 동안에는 이 리소스가 필요하지 않습니다.

기본적으로 MSDTC 리소스 오류는 그룹에 영향을 줍니다. 리소스 오류의 두 가지 예는 다음과 같습니다.

  • 로그 파일 크기가 디스크 용량을 초과합니다.

  • MSDTC 리소스의 실제 디스크에 오류가 발생합니다.

특히 MSDTC 리소스 오류로 인해 해당 클러스터 노드에서 실행 중인 모든 Exchange 서비스가 클러스터의 다른 노드에 장애 조치(failover)됩니다. 그러나 MSDTC 리소스는 필수 리소스가 아니므로 그룹에 영향을 주도록 구성하지 않아도 됩니다.

이 경고를 해결하려면 MSDTC 리소스 오류가 그룹에 영향을 주지 않도록 Exchange 클러스터를 구성합니다.

MSDTC 리소스 오류가 그룹에 영향을 주지 않도록 Exchange를 구성하려면 다음을 수행합니다.

  1. 클러스터의 노드에 로그온합니다.

  2. 시작을 클릭하고 모든 프로그램, 관리 도구를 차례로 가리킨 다음 클러스터 관리자를 클릭합니다.

  3. 그룹에서 MSDTC 리소스가 포함된 클러스터 그룹을 마우스 오른쪽 단추로 클릭합니다.

  4. MSDTC 리소스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 고급 탭에서 그룹에 영향을 줌 확인란의 선택을 해제한 다음 확인을 클릭합니다.

추가 정보

MSDTC 리소스 작성 방법에 대한 자세한 내용은 Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)의 "Windows Server 2003 서버 클러스터에 Microsoft Distributed Transaction Coordinator 설치 방법"을 참조하십시오.

MSDTC 및 Exchange에 대한 자세한 내용은 Exchange Server 2003 높은 가용성 가이드(http://go.microsoft.com/fwlink/?LinkId=47571)의 "Exchange Server 2003 클러스터링 이해"에서 "클러스터 그룹"을 참조하십시오.

Microsoft Windows Server™ 2003에서 MSDTC 리소스를 추가하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 301600, "How to Configure Microsoft Distributed Transaction Coordinator on a Windows Server 2003 Cluster"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600)를 참조하십시오.

참고:
기술 자료 문서 301600에는 기술 자료 문서 817064, "Windows Server 2003에서 네트워크 DTC 액세스를 사용 가능하게 설정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064)에 대한 참조가 포함되어 있습니다. Exchange Server 보안을 위한 가장 좋은 방법은 Exchange 클러스터에 대해 네트워크 DTC 액세스를 사용할 수 없게 설정하는 것입니다. Exchange 클러스터에 대해 DTC(Distributed Transaction Coordinator) 리소스를 구성하는 경우 네트워크 DTC 액세스를 사용하지 마십시오.


MTA 오류가 클러스터 그룹에 영향을 줍니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2006-03-16

Microsoft® Exchange Server Analyzer Tool은 Exchange 서버 시스템의 Cluster\Resources 레지스트리 설정을 검사합니다.

HKEY_LOCAL_MACHINE\Cluster\Resources

Exchange Server Analyzer는 전용 모드 조직의 Exchange Server 2003 클러스터에서 MTA(Message Transfer Agent) Stacks 서비스 리소스가 실행 중임을 확인하면 유용한 정보 메시지를 표시합니다.

MTA 중지 또는 실패 시 MTA에서 가능한 Exchange 가상 서버 장애 조치(failover)를 발생시키지 않도록 Exchange 관리자가 MTA 리소스를 구성하는 것이 좋습니다.

참고:
혼합 모드 환경에서 Exchange 2000 Server나 Exchange Server 2003 서버와 Microsoft Exchange Server 5.5 서버 간에 이전 버전과 호환되는 메시지 전송 서비스를 제공할 때 Microsoft Exchange 2000 Server 및 Microsoft Exchange Server 2003의 MTA Stacks 서비스가 주로 사용됩니다. 단순 Exchange 2000 Server 또는 Exchange Server 2003 전용 모드 환경에서 전송한 경우 MTA는 Exchange 서비스를 실행하는 데 중요한 리소스가 아닙니다.

MTA Stacks 서비스가 실행을 중지하거나 실패한 경우 가능한 Exchange Virtual Server 장애 조치(failover) 설정이 해제될 수 있습니다. 가능한 EVS(Exchange Virtual Server) 장애 조치를 방지하려면 다음을 수행하여 장애 조치 방지를 위해 MTA Stacks 서비스를 구성하는 것이 좋습니다.

Exchange Server 클러스터의 영향을 받지 않은 상태로 MTA Stacks 서비스를 구성하려면 다음을 수행합니다.

  1. Cluster Administrator를 엽니다.

  2. MTA Stack 서비스 리소스에 대해 Affect this Group 옵션의 선택을 해제합니다.

추가 정보

Exchange Server 2003의 MTA Stacks 서비스 지원 가능성 지침에 대한 자세한 내용은 Microsoft 기술 자료 문서 810489, "MTA Stacks service supportability guidelines for Exchange 2000 Server and Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810489)을 참조하십시오.

Exchange Server 2003 아키텍처의 MTA에 대한 자세한 내용은 Exchange MTA in Exchange Server 2003 Architecture(http://go.microsoft.com/fwlink/?LinkId=63496)를 참조하십시오.

클러스터에 Exchange Server 2003을 배포하는 방법에 대한 자세한 내용은 "Deploying Exchange Server 2003 in a Cluster"(http://go.microsoft.com/fwlink/?LinkId=63495)를 참조하십시오.

클러스터 관리자 사용 방법에 대한 자세한 내용은 "Using Cluster Administrator to Manage Exchange Clusters"(http://go.microsoft.com/fwlink/?LinkId=63493)를 참조하십시오.


노드가 두 개인 액티브/액티브 클러스터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2006-04-28

Microsoft® Exchange Server Analyzer Tool은 클러스터 서비스인 ClusSvc의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 Cluster Service가 실행되고 있음을 나타내고 False 값은 실행되지 않음을 나타냅니다.

또한 Exchange Server Analyzer는 클러스터의 노드 수를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Cluster\Nodes\ <노드 수> \NodeName

NodeName의 인스턴스 개수는 클러스터의 노드 수를 나타냅니다. Exchange Server Analyzer는 또한 클러스터에서 Exchange Server 리소스 수를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKLM\Cluster\Resources\ <클러스터 리소스 GUID> \Parameters\DestPath

Exchange Server 클러스터에 있는 다음 리소스에는 DestPath 값이 설정됩니다.

  • Microsoft Exchange Message Transfer Agent

  • Microsoft Exchange 정보 저장소

DestPath의 인스턴스 개수는 클러스터에서 실행 중인 EVS(Exchange 가상 서버) 수를 나타냅니다.

Exchange Server Analyzer는 한 클러스터에서 NodeName에 2개의 인스턴스가 설정되어 있고 DestPath에 3개의 인스턴스가 설정되어 있을 경우 경고를 표시합니다. 이 경고는 이 클러스터가 액티브/액티브 클러스터라고 하는 2개의 EVS가 있는 2 노드 클러스터임을 나타냅니다.

  • 액티브/액티브 클러스터 모델에서 클러스터에 있는 Exchange 가상 서버 수는 클러스터의 실제 노드 수보다 크거나 같습니다.

참고:
액티브/액티브 Exchange 클러스터는 2개의 노드로 구성된 클러스터에서만 작성할 수 있습니다. 사용 중인 클러스터에 3개 이상의 노드가 있으면 액티브/패시브 모델을 사용해야 합니다.
  • 액티브/패시브 클러스터 모델에서 클러스터의 Exchange 가상 서버 수는 클러스터의 실제 노드 수보다 적습니다.

Exchange Server에 대한 액티브/액티브 클러스터링이 지원되긴 하지만 Exchange 클러스터에는 액티브/패시브 구현을 사용하는 것이 좋습니다. 다음 배율 제한을 따르는 액티브/액티브 Exchange 클러스터만 지원됩니다.

  • 실제 노드마다 Exchange 가상 서버당 동시 사용자 연결 수는 1,900 이하여야 합니다. 클러스터의 한 노드를 사용할 수 없고 모든 Exchange 가상 서버가 단일 노드에서 온라인 상태일 경우 배율 제한은 2개의 Exchange 가상 서버에 대해 연결 수 3,800을 유지합니다. 각 사용자가 복수의 연결을 만들 수 있기 때문에 사서함 수로는 연결 수를 정확하게 예측할 수 없습니다.

  • Exchange 저장소 프로세스당 평균 CPU 사용률은 40% 이하여야 합니다. 노드에서 STORE.EXE 프로세스에 의한 총 CPU 사용률이 10분 이상의 시간 동안 40%를 초과할 경우 사용자를 다른 Exchange 가상 서버나 Exchange 서버로 옮겨야 합니다. 관리 작업에 소비되는 CPU 사용률은 이 부하량에 포함되지 않습니다.

액티브/액티브 클러스터 구성에서 액티브/패시브 구성으로 마이그레이션하는 작업에는 두 번째 EVS로부터 모든 리소스를 옮긴 다음 이 서버를 제거하는 작업이 포함됩니다.

액티브/액티브 클러스터에서 액티브/패시브 클러스터로 마이그레이션하려면 다음을 수행합니다.

  1. 두 번째 EVS에서 호스팅되는 사서함을 클러스터의 첫 번째 EVS로 이동합니다. 클러스터의 첫 번째 EVS에는 항상 클러스터의 유일한 Microsoft Exchange 메시지 전송 에이전트(MTA) 리소스가 들어 있습니다.

  2. 모든 사서함을 첫 번째 EVS로 이동했으면 두 번째 EVS를 오프라인 상태로 만듭니다.

  3. 다음 중 한 가지를 수행하여 두 번째 EVS를 제거합니다.

    • Exchange Server 2003 클러스터에서 Microsoft Exchange System Attendant 리소스를 마우스 오른쪽 단추로 클릭하고 Exchange 가상 서버 제거를 클릭합니다.

    • Exchange 2000 Server 클러스터에서 Microsoft Exchange System Attendant 리소스를 마우스 오른쪽 단추로 클릭하고 삭제를 클릭합니다.

  4. EVS 개체가 Active Directory® 디렉터리 서비스에서 제거되었는지 확인합니다. Exchange Server 2003에서 클러스터 서비스 계정 권한이 변경되었으므로 사용 중인 계정에 Active Directory 개체를 제거할 수 있는 권한이 있어야 합니다.

  5. 두 번째 EVS의 나머지 리소스(예: 실제 디스크, 네트워크 이름 및 IP 주소)를 오프라인 상태로 전환한 다음 삭제합니다.

  6. 두 번째 EVS가 포함된 리소스 그룹을 삭제합니다.

EVS의 제거 방법에 대한 자세한 내용은 Deploying Microsoft Exchange 2000 Server Clusters Exchange(http://go.microsoft.com/fwlink/?LinkId=9393)의 "Removing an Exchange virtual server from a Cluster" 섹션을 참조하십시오.

Exchange 클러스터에 대한 유용한 정보와 권장 사항은 Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.

Windows 서버 클러스터의 Exchange 배포에 대한 자세한 내용은 Microsoft 기술 자료 문서 815180, "Active/Active 클러스터에 Exchange 배포 시 고려 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815180)을 참조하십시오.


쿼럼 로그가 너무 작습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange 클러스터 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 해당 클러스터에 대해 구성된 쿼럼 로그 크기를 확인합니다.

HKEY_LOCAL_MACHINE\Cluster\Quorum\MaxQuorumLogSize

Exchange Server Analyzer는 MaxQuorumLogSize 값이 10진수 4194304(16진수는 0x400000) 미만일 경우 경고를 표시합니다.

MaxQuorumLogSize 레지스트리 값은 다음 크기가 되면 쿼럼 로그를 새로 시작 클러스터 쿼럼 매개 변수에 대해 현재 구성된 값을 나타냅니다. 이 경고는 MaxQuorumLogSize가 4096KB(킬로바이트) 미만일 경우에 생성됩니다.

클러스터는 클러스터 데이터베이스의 모든 변경 내용을 쿼럼 로그 파일에 기록합니다. 쿼럼 로그가 지정된 크기에 도달하면 클러스터가 데이터베이스를 저장하고 로그 파일을 다시 설정합니다. Microsoft Windows® 2000 Server 기반 클러스터의 기본 쿼럼 크기 한계는 64KB입니다. Windows Server™ 2003 기반 클러스터의 기본 쿼럼 크기 한계는 4096KB입니다. Exchange Server 클러스터의 경우 다음 크기가 되면 쿼럼 로그를 새로 시작 속성을 4096KB로 구성하는 것이 좋습니다. 이렇게 하면 해당 클러스터에 속한 서버, 해당 클러스터에 설치된 리소스, 해당 리소스 상태(온라인 또는 오프라인) 같은 클러스터 구성 정보를 보관하기에 충분한 공간을 갖게 됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 클러스터 관리자를 엽니다.

  2. 왼쪽 창에서 해당 클러스터를 나타내는 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 쿼럼 탭에서 다음 크기가 되면 쿼럼 로그를 새로 시작을 4096 값으로 구성합니다.

  4. 변경 내용을 저장하려면 확인을 클릭합니다.

기본 쿼럼 로그 크기 제한에 대한 자세한 내용은 Microsoft 기술 자료 문서 225081, "Cluster Resources Quorum Log Size Defaults to 64 KB"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=225081)를 참조하십시오.


Exchange Server
Microsoft Exchange Server Analyzer - 문서 >

최근 수정된 항목: 2005-11-18

이 섹션의 문서에는 Exchange Server 컴퓨터와 관련된 Microsoft® Exchange Server Analyzer Tool의 평가 기능에 대한 자세한 내용이 나와 있습니다. 또한 이러한 문서는 Exchange Server Analyzer가 발견한 Exchange 관련 오류, 경고 및 기본 구성이 아닌 문제를 해결하기 위해 수행할 수 있는 작업을 설명합니다.


계정 잠금이 설치되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-08-28

Microsoft® Exchange Server Analyzer Tool은 ALockout.dll 파일이 Exchange Server의 System32 폴더에 있는지 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. ALockout.dll은 계정 잠금 및 관리 도구(ALTools.exe)의 일부입니다. 이러한 도구를 사용하여 관리자는 계정을 관리하고 계정 잠금 관련 문제를 해결할 수 있습니다.

Exchange Server Analyzer는 Exchange 서버에 ALockout.dll이 있으면 오류를 표시합니다.

Exchange 서버를 포함하여 네트워크 응용 프로그램 또는 서비스를 호스팅하는 서버에서는 계정 잠금 및 관리 도구를 사용하면 안 됩니다. Exchange 서버에 계정 잠금 및 관리 도구가 설치되어 있으면 Exchange 서비스를 시작하지 못할 수도 있습니다. 따라서 이 Exchange 서버에서 계정 잠금 및 관리 도구를 제거하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 오류를 수정하려면 다음을 수행합니다.

  1. 명령 프롬프트에 regsvr32 /u alockout.dll을 입력합니다.

  2. 레지스트리 키 HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs에서 ALockout.dll 값을 삭제합니다.
참고:
ALockout.dll 값을 삭제하면 AppInit_DLLs 레지스트리 항목은 비어 있습니다. 컴퓨터를 다시 시작합니다.
  1. System32 폴더에서 ALockout.dll 파일을 삭제합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

계정 잠금 및 관리 도구에 대한 자세한 내용은 Account Passwords and Policies(http://go.microsoft.com/fwlink/?LinkId=52465)의 "Account Lockout Tools"를 참조하십시오.


Active Directory 사이트가 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-03-16

Microsoft® Exchange Server Analyzer Tool은 Win32 API DsGetSiteName 함수를 구현하여 도메인 컨트롤러의 Active Directory® 디렉터리 서비스 사이트 이름과 로컬 Exchange Server의 Active Directory 사이트 이름을 쿼리합니다.

Exchange Server Analyzer는 도메인 컨트롤러의 Active Directory 사이트 이름과 로컬 Exchange Server의 Active Directory 사이트 이름이 일치하지 않으면 경고를 표시합니다.

이 경고는 DSAccess(Directory Service Access) 프로세스가 Exchange Server 성능을 심각하게 저하시킬 수 있는 LDAP(Lightweight Directory Access Protocol) 요청에 대해 로컬 Active Directory 사이트를 벗어남을 나타냅니다.

오프사이트 도메인 컨트롤러의 정적 구성, 사이트 상주 도메인 컨트롤러에 연결할 수 없게 하는 네트워크 또는 도메인 컨트롤러 컴퓨터 고장 또는 Exchange Server와 동일한 사이트에 Active Directory 도메인 컨트롤러를 포함하지 않는 잘못 설계된 Active Directory 토폴로지 등에 의해 이런 상황이 발생할 수 있습니다.

DSAccess는 캐시의 디렉터리 정보를 액세스 및 저장하는 공유 Exchange Server 구성 요소입니다. DSAccess는 Active Directory 사이트 구성 및 Active Directory 서버 가용성과 같은 조건에 따라 다른 Exchange 구성 요소에서 연결해야 하는 디렉터리 서버를 동적으로 검색합니다. Exchange 프런트 엔드 서버는 DSAccess를 사용하여 특정 사용자의 사서함, 사용자 개체에 대해 존재하는 SMTP(Simple Mail Transfer Protocol) 주소 및 공용 폴더 저장소를 포함하는 서버 등을 확인합니다.

초기화 시 DSAccess가 레지스트리에서 정적으로 구성된 도메인 컨트롤러나 글로벌 카탈로그 세트를 찾지 못하면 DSAccess는 검색 프로세스를 사용하여 네트워크 토폴로지를 식별하고 디렉터리 서버의 가용성 및 적합성을 평가합니다. 도메인 컨트롤러의 적합성을 확인하는 과정에 도메인 컨트롤러가 Exchange Server와 같은 Active Directory 사이트에 있는지 확인하는 과정이 포함됩니다.

사이트 간 LDAP 요청 때문에 생길 수 있는 대기 시간을 줄이려면 상주 도메인 컨트롤러가 있는 Active Directory 사이트에 Exchange Server가 있어야 합니다.

이 문제를 해결하려면 다음을 수행합니다.

  • Active Directory 토폴로지에 대한 사이트 정의를 평가하여 Exchange Server에 동일한 Active Directory 사이트의 도메인 컨트롤러에 대한 액세스 권한이 있는지 확인합니다.

  • 정적으로 구성된 도메인 컨트롤러가 Exchange Server와 동일한 Active Directory 사이트에 상주하는지 확인합니다.

추가 정보

DSAccess 구성 및 문제 해결 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Directory Integration and Exchange Server 2003(http://go.microsoft.com/fwlink/?LinkId=63447)

  • Understanding and Troubleshooting Directory Access(http://go.microsoft.com/fwlink/?LinkId=39012)

  • Microsoft 기술 자료 문서 250570, "디렉터리 서비스 서버 감지 및 DSAccess 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)


관리 파일 공유를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 기본 관리 공유가 사용할 수 없게 되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters\AutoShareServer

Exchange Server Analyzer는 AutoShareServer의 값이 0으로 설정된 경우 오류를 표시됩니다.

이 오류는 기본 서버에서 만든 관리 공유를 이 서버에서 사용 안 함으로 설정되었음을 의미합니다. 기본 관리 공유를 사용할 수 없게 하면 Exchange Server의 온라인 백업이나 복원이 실행되지 않습니다. 백업 프로그램에 따라 데이터를 복원하려고 할 때 오류 메시지가 나타날 수도 있습니다. 또한 테이프 백업 로그에 오류 메시지가 표시될 수도 있습니다.

또한 관리 공유를 제거하면 Exchange Server의 온라인 백업 동안 예기치 않은 오류 0xc0040000 Microsoft Exchange Server 컴퓨터를 사용할 수 없습니다와 같은 메시지가 나타납니다. 이 문제를 해결하려면 레지스트리를 편집하고 Server 서비스를 다시 시작하여 기본 관리 공유를 다시 사용할 수 있게 하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters를 탐색합니다.

  3. 오른쪽 창에서 AutoShareServer를 찾아 두 번 클릭합니다.

  4. 0에서 1로 값을 변경합니다.

  5. 레지스트리 편집기를 닫고 Server 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Microsoft Windows Server™ 2003의 기본 관리 공유를 복원하는 방법에 대한 자세한 내용은 기술 자료 문서 816113, "HOW TO: Use Registry Editor to Restore Administrative Shares in Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816113)을 참조하십시오.


AFD.SYS 드라이버 및 X.400 커넥터 상호 운용성
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터에서 실행 중인 Microsoft Windows® 버전을 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 4.0은 Exchange Server 컴퓨터에 Microsoft Windows NT® Server 4.0이 실행되고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터에 Windows 2000 Server가 실행되고 있음을 나타내고 값 5.2는 해당 컴퓨터에 Windows Server™ 2003이 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 NumberOfProcessors 키에 설정된 값을 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 값은 컴퓨터에 설치된 프로세서의 수를 나타냅니다. 이러한 프로세서는 실제 프로세서와 논리 프로세서를 모두 포함합니다. Intel의 하이퍼 스레딩 기술을 사용하면 실제 프로세서를 두 개의 논리 프로세서로 분할할 수 있습니다.

Exchange Server Analyzer는 Exchange Server가 X.400 커넥터의 브리지헤드인지 여부를 확인할 때도 다음 레지스트리 항목을 읽습니다.

HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeMTA

마지막으로 Exchange Server Analyzer는 Afd.sys 파일의 CIM_Datafile 키 값을 확인할 때 Version WMI(Windows Management Instrumentation) 클래스를 쿼리합니다.

Exchange Server Analyzer는 다음 조건에서 경고 메시지를 표시합니다.

  • Exchange Server 컴퓨터가 Windows Server 2000에서 실행되고 있습니다.

  • NumberOfProcessors 값이 1보다 큽니다.

  • Exchange Server가 X.400 커넥터의 브리지헤드입니다.

  • WINDOWSPATH%\\system32\\drivers\\afd.sys의 Version 키 값이 5.0.2195.7036과 5.0.2195.7060 범위에 있습니다.

이 경고는 서버에 설치된 Afd.sys 버전이 이 서버에서 실행하는 X.400 커넥터와 관련된 메일 흐름 문제를 일으킬 수 있음을 나타냅니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 904712, "Mail delivery is slower than expected, or mail delivery stops, on an X.400 connector to a remote site in Exchange Server 5.5"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=904712)에서 참조된 업데이트를 구하십시오.


데이터베이스에 대한 Aging Keep Time 간격이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 msExchAgingKeepTime 특성이 설정되었는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성은 인덱스, 보기 및 범주를 제거하는 시기를 결정하는 데 사용되는 시간 값을 나타냅니다. Exchange Server Analyzer에서 이 특성이 설정되어 있음을 확인하면 기본 구성이 아니라는 메시지가 표시됩니다.

Exchange 클라이언트가 Exchange 데이터베이스 테이블에 만든 보기에 사용된 인덱스 중 지정된 시간 동안 사용되지 않은 인덱스는 이 시점에 정리됩니다. msExchAgingKeepTime 특성은 인덱스가 삭제되기 전의 최소 인덱스 기간을 지정합니다. Exchange 2000 Server의 원래 릴리스 버전에서 기본값은 8일입니다. Exchange 2000 Server의 서비스 팩 1(SP1) 및 Exchange Server 2003 및 Exchange Server 2007을 비롯하여 모든 이후 버전의 Exchange Server에서 기본값은 40일입니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) ¹oAu 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
Aging Keep Time 값을 보거나 수정하려면 다음을 수행합니다.

  1. ADSI 편집을 시작합니다.

  2. Configuration 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=<ExchangeOrganizationName>을 차례로 확장합니다.

  3. CN=Administrative Groups, CN=<AdministrativeGroupName>, CN=Servers를 차례로 확장합니다.

  4. CN=<ServerName>, CN=InformationStore를 확장한 다음 CN=<StorageGroupName>을 선택합니다.

  5. 세부 정보 창에서 CN=<MailboxStoreName>을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  6. Attribute Editor에서 msExchMaxStoresPerGroup 특성을 클릭한 후 Edit를 클릭합니다.

  7. 특성 편집 상자에서 지우기를 클릭하여 값을 지웁니다.

  8. Apply를 클릭한 다음 OK를 클릭합니다.

  9. ADSI 편집을 닫습니다. 레지스트리 내용을 변경했으면 Microsoft Exchange Information Store 서비스를 다시 시작해야 변경 내용이 적용됩니다.

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

Exchange Server의 정보 저장소 폴더 액세스 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 216076, "XADM: 정보 저장소 폴더 액세스가 느려질 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=216076)를 참조하십시오.


Antigen 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-06-20

Microsoft Exchange Server Analyzer Tool은 MimeNavigator.dll의 Version 키 값을 확인할 때 CIM_Datafile Microsoft® WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 모듈은 Microsoft Antigen 버전 8 및 9에 포함되어 있습니다.

Exchange Analyzer는 MimeNavigator.dll의 Version 키 값이 8.00.1517.0 미만(버전 8의 경우) 및 9.00.1055.0 미만(버전 9의 경우)이면 경고를 표시합니다.

이 경고는 Microsoft Antigen 버전 8이나 9가 Exchange 서버에 설치되어 있고 소프트웨어 업데이트를 사용할 수 있음을 나타냅니다. 이 업데이트는 서버의 전반적인 성능과 안정성을 향상시켜 주므로 설치하는 것이 좋습니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 928082, Size of SMTP messages may increase during the scanning process in Antigen에 나와 있는 권장 사항을 검토하여 적용합니다.


응용 프로그램 로그 크기
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-11-09

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 응용 프로그램 로그 파일의 최대 크기를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application\MaxSize

Exchange Server Analyzer는 MaxSize 값이 41,943,040바이트(40MB) 미만인 경우 유용한 정보 메시지를 표시합니다.

기본적으로 응용 프로그램 로그 파일의 최대 로그 크기는 Windows Server 2003에서 16,777,216바이트(16348KB), Windows 2000 Server에서 524288바이트(512KB)입니다. Exchange Server를 실행하는 컴퓨터의 경우 응용 프로그램 로그 파일의 최대 크기를 40MB(40960KB로 입력) 이상으로 설정하는 것이 가장 좋습니다. 응용 프로그램 로그 파일 크기를 늘려 더 많은 응용 프로그램 이벤트를 보존합니다. 추가 이벤트 정보는 문제를 해결할 때 도움이 됩니다.

응용 프로그램 로그의 최대 크기를 늘리려면 다음을 수행하십시오.

  1. 이벤트 뷰어 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. 응용 프로그램 로그를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭의 로그 크기 아래에 있는 최대 로그 크기 상자에 40960 이상을 입력한 다음 확인을 클릭합니다.


ASP.NET Rootver가 손상되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 ASP.NET의 Rootver 키에 설정된 값을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\ASP.NET

Exchange Server Analyzer는 다음 조건이 존재하는 경우 오류를 표시합니다.

  • Exchange Server Analyzer에서 Rootver 값이 0.0.0.0으로 설정되어 있음을 확인합니다.

  • 클러스터 서비스가 실행 중입니다.

오류에 대해 알리지 않고 ASP.NET이 설치되지 않을 수도 있습니다. 이 경우 Rootver 키가 0.0.0.0으로 설정되어 있습니다. Rootver 값이 0.0.0.0으로 설정되면 Microsoft Exchange System Attendant 서비스 또는 다른 Exchange Server 서비스가 Exchange Server 2003 및 Exchange Server 2007 클러스터를 시작하지 못합니다. Rootver 값을 다음 중 하나로 설정하여 이 오류를 수정해야 합니다.

  • Exchange Server 2003 Rootver 키 = 1.1.4322.0.

  • Exchange Server 2007 Rootver 키 = 2.0.50727.0

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
Rootver를 1.1.4322.0으로 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\Microsoft\ASP.NET\ 를 탐색합니다.

  3. 세부 정보 창에서 RootVer 키를 두 번 클릭합니다.

  4. 문자열 편집 대화 상자에서 값 데이터를 위 문서의 적합한 값으로 설정하고 확인을 클릭합니다.

  5. 레지스트리 편집기를 종료합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


자동 운영 체제 디버깅이 활성화되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 운영 체제 디버깅이 활성화 되어 있지 않은지 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Auto

Exchange Server Analyzer는 Auto 값이 0으로 설정되어 있을 경우 경고를 표시합니다.

기본적으로 Microsoft Windows® 2000 Server 및 Windows Server™ 2003 운영 체제에는 Dr. Watson이라는 응용 프로그램 디버거가 설치되어 있습니다. 디버거는 다른 프로그램의 오류를 감지, 검색 및 수정하도록 돕는 프로그램으로 프로그래머가 해당 프로그램을 단계별로 실행하고 데이터를 확인하고 변수 값 같은 조건을 모니터링할 수 있습니다.

기본 옵션은 Dr. Watson이 처음 실행될 때 설정되며 이 시기는 프로그램에 오류가 발생하거나 Dr. Watson을 직접 시작할 때입니다.

응용 프로그램 오류가 발생하면 Windows가 프로그램 오류 처리기를 검색합니다. 프로그램 오류 처리기는 프로그램 실행 중에 발생하는 오류를 처리합니다. Windows가 프로그램 오류 처리기를 찾지 못하면 Windows는 해당 프로그램이 현재 디버깅 중이 아니라고 확인하고 오류가 처리되지 않은 것으로 간주합니다. 그런 다음 Windows는 프로그램 오류 디버거에 해당하는 레지스트리를 검색하여 처리되지 않은 오류를 처리합니다.

Windows의 동작은 HKLM\Software\Microsoft\Windows NT\CurrentVersion\AeDebug에 설정된 두 가지 레지스트리 값에 따라 다릅니다.

두 가지 레지스트리 항목은 Debugger와 Auto입니다. Debugger 항목 값은 프로그램 오류를 분석하는 데 사용할 디버거 명령을 지정합니다. Debugger 항목 값이 있으면 Windows는 Auto 항목 값이 0 또는 1로 설정되어 있는지 확인합니다.

  • Auto 항목 값이 0으로 설정되어 있으면 Windows는 프로그램 오류가 발생했음을 알리는 메시지 상자를 생성합니다. Debugger 항목 값에 올바른 디버거 명령이 지정되어 있으면 메시지 상자에는 확인 및 취소 단추가 표시됩니다. 확인을 클릭하면 프로그램이 중지됩니다. 취소를 클릭하면 지정된 디버거가 시작됩니다. Debugger 항목이 비어 있으면 메시지 박스에는 확인 단추만 표시되고 디버거는 시작되지 않습니다.

  • Auto 항목이 1로 설정되어 있고 Debugger 항목 값에 올바른 디버거 명령이 지정되어 있으면 시스템은 자동으로 디버거를 시작하고 메시지 상자를 생성하지 않습니다.

Windows를 설치할 때 Auto 항목 값은 기본적으로 1로 설정되고 Debugger 항목 값에는 Dr. Watson 시작 명령(drwtsn32 -p %ld -e %ld -g)이 지정됩니다. 이는 프로그램 오류가 발생할 때 Dr. Watson이 자동으로 오류를 진단하고 해당 진단 정보를 기록함을 나타냅니다.

Exchange Server 컴퓨터에서는 프로그램 오류 디버거를 사용하는 것이 좋습니다. Dr. Watson이 아닌 프로그램을 기본 디버거로 사용했지만 이 프로그램 대신에 Dr. Watson을 기본 디버거로 사용하려면 명령 프롬프트로 이동하여 drwtsn32 -i 명령을 입력하고 Dr. Watson을 시작합니다. -i를 입력하면 레지스트리에 필요한 변경 내용이 작성됩니다.

명령 프롬프트에서 Dr. Watson을 기본 디버거로 등록하려면 다음을 수행합니다.

  1. 명령 프롬프트 창을 엽니다.

  2. drwtsn32 -i 명령을 실행합니다.

  3. "Dr. Watson이 응용 프로그램 기본 디버거로 설치되었습니다."라는 메시지가 표시됩니다. 확인을 클릭하여 이 메시지를 확인합니다.

사용자 인터페이스에서 Dr. Watson을 기본 디버거로 등록하려면 다음을 수행합니다.

  1. 시작, 실행을 차례로 클릭하고 drwtsn32를 입력한 다음 Enter 키를 누릅니다. Windows용 Dr. Watson 사용자 인터페이스가 나타납니다.

  2. 크래시 덤프 파일 만들기 확인란을 선택합니다.

  3. 확인을 선택하여 변경 내용을 저장하고 Windows용 Dr. Watson 사용자 인터페이스를 닫습니다.

Windows용 Dr. Watson에 대한 자세한 내용은 Dr. Watson 사용자 인터페이스에서 F1 키를 눌러 Dr. Watson 도움말 파일을 참조하십시오.

Dr. Watson 외의 프로그램 오류 디버거를 사용하려면 Microsoft 기술 자료 문서 188296, "How to Disable Dr. Watson for Windows"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296)의 절차를 사용하여 Dr. Watson을 사용하지 않도록 설정할 수 있습니다.


평균 LDAP 읽기 대기 시간이 50밀리초를 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-14

Microsoft Exchange Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeDSAccess Process 성능 개체의 LDAP Read Time 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

LDAP Read Time 성능 카운터는 LDAP(Lightweight Directory Access Protocol) 읽기 요청이 수행되는 데 걸리는 시간(밀리초)을 표시합니다. Exchange Analyzer는 5분 동안 5초마다 샘플을 검색합니다. 그런 다음 Exchange Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 평균 값이 50밀리초를 초과하면 오류를 표시합니다.

RPC(원격 프로시저 호출) 대기 시간이 길거나 큐가 증가하면 LDAP 읽기 대기 시간이 길어질 수 있습니다. 긴 LDAP 읽기 대기 시간은 일반적으로 다음 문제 중 하나를 나타냅니다.

  • 도메인 컨트롤러에 대한 네트워크 연결에 성능 문제가 있습니다.

  • 도메인 컨트롤러 자체에 성능 문제가 있습니다.

참고:
사용자가 다른 실제 사이트에 있는 도메인 컨트롤러에 연결하는 경우 일반적으로 LDAP 대기 시간이 더 길어집니다. 그러나 이 문서에서 설명하는 권장 최대 대기 시간은 일반적으로 다음과 같아야 합니다.

이 경고를 기록한 도메인 컨트롤러가 다른 실제 사이트에 있는 경우 Exchange 서버에서 이 경고를 보고하는 도메인 컨트롤러를 사용하지 않음을 확인할 수 있으면 이 오류를 안전하게 무시할 수 있습니다. Exchange에서 도메인 컨트롤러를 사용하는지 여부를 확인하는 한 가지 방법은 MSExchangeDSAccess 서비스의 토폴로지 구성 요소에 대한 진단 로깅 수준을 최소로 높이는 것입니다. MSExchangeDSAccess 이벤트 ID 이벤트 2080이 표시되지 않으면 이 경고를 안전하게 무시할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  • 도메인 컨트롤러에 대한 모든 네트워크 연결이 작동하며 ICMP(Internet Control Monitoring Protocol) 트래픽을 지원하는지 확인합니다.

  • 다음 문서의 유용한 정보를 고려하십시오.

    • LDAP Read Time 성능 카운터 및 Active Directory 바운드 문제 해결에 사용할 수 있는 기타 카운터에 대한 자세한 내용은 Microsoft Exchange Server 성능 문제 해결(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Active Directory 바운드 문제 방지" 항목을 참조하십시오. 이 문서에는 Active Directory 성능을 향상시키는 방법에 대한 내용도 포함되어 있습니다.

    • Active Directory 성능을 최대화하는 방법에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "Active Directory 통합 튜닝" 항목을 참조하십시오.

    • Active Directory 서버에 높은 수준의 가용성을 제공하는 방법에 대한 자세한 내용은 Exchange 2003 높은 수준의 가용성 가이드(http://go.microsoft.com/fwlink/?LinkId=47571)의 "시스템 수준 내결함성 조치" 항목에서 Active Directory 및 DNS(Domain Name System)에 대한 안정적인 액세스 보장 아래 섹션을 참조하십시오.

    • 네트워크 대역폭 고려 사항에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "Exchange 성능 이해" 항목에서 네트워크 성능 섹션을 참조하십시오.


최대 LDAP 읽기 대기 시간이 100밀리초를 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-14

Microsoft Exchange Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeDSAccess Process 성능 개체의 LDAP Read Time 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

LDAP Read Time 성능 카운터는 LDAP(Lightweight Directory Access Protocol) 읽기 요청이 수행되는 데 걸리는 시간(밀리초)을 표시합니다. Exchange Analyzer는 5분 동안 5초마다 샘플을 검색합니다. 그런 다음 Exchange Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 최대값이 100밀리초를 초과하면 오류를 표시합니다.

RPC(원격 프로시저 호출) 대기 시간이 길거나 큐가 증가하면 LDAP 읽기 대기 시간이 길어질 수 있습니다. 긴 LDAP 읽기 대기 시간은 일반적으로 다음 문제 중 하나를 나타냅니다.

  • 도메인 컨트롤러에 대한 네트워크 연결에 성능 문제가 있습니다.

  • 도메인 컨트롤러 자체에 성능 문제가 있습니다.

참고:
사용자가 다른 실제 사이트에 있는 도메인 컨트롤러에 연결하는 경우 일반적으로 LDAP 대기 시간이 더 길어집니다. 그러나 이 문서에서 설명하는 권장 최대 대기 시간은 일반적으로 다음과 같아야 합니다.

Exchange 서버는 글로벌 카탈로그 서버와 도메인 컨트롤러 목록을 최신 상태로 유지하기 위해 도메인을 벗어난 글로벌 카탈로그 서버를 15분 간격으로 쿼리합니다. 이들 디렉터리 서버 중 일부는 원격 서버일 수 있으므로 이러한 쿼리의 대기 시간이 길어질 수 있습니다. 요청이 자주 발생하지 않으면 즉, 속도가 초당 0.5개 이하 요청이면 문제가 되지 않습니다.

이 오류를 기록한 도메인 컨트롤러가 다른 실제 사이트에 있는 경우 Exchange 서버에서 이 오류를 보고하는 도메인 컨트롤러를 사용하지 않는지 여부를 확인할 수 있으면 이 오류를 무시해도 안전합니다. Exchange에서 도메인 컨트롤러를 사용하는지 여부를 확인하는 한 가지 방법은 MSExchangeDSAccess 서비스의 토폴로지 구성 요소에 대한 진단 로깅 수준을 최소로 높이는 것입니다. MSExchangeDSAccess 이벤트 ID 이벤트 2080이 표시되지 않으면 이 오류를 안전하게 무시할 수 있습니다.

중요:
혼합 모드 환경의 경우에만 사용자가 구성원으로 속한 보안 그룹이 무엇인지와 Exchange 서버에서 사용자 홈 도메인의 신뢰할 수 있는 도메인 컨트롤러를 쿼리해야 하는 공용 폴더와 같은 리소스를 사용자가 안전하게 하기 위해 필요한 사용 권한이 무엇인지 확인하는 데 사용되는 tokenGroups 및 tokengroupsGlobalandUniversal과 같은 특정 보안 관련 사용자 특성을 위해 Exchange 2000 SP2 시간 프레임에 대해 동작이 도입되었습니다. 신뢰할 수 있는 도메인 컨트롤러는 원격 사이트에 있을 수 있으며 로컬 공용 폴더에 액세스하는 많은 원격 홈 도메인 사용자의 쿼리로 인해 RPC 대기 시간이 길어질 수 있습니다.

이 동작에 대한 자세한 내용은 다음 Exchange 서버 블로그 항목을 참조하십시오.

  • Exchange Does Not Always Use Local GCs

    참고:
    필요한 기술 정보를 찾는 데 도움이 되도록 블로그에 대한 링크를 제공합니다. 블로그의 내용과 해당 URL은 예고 없이 변경될 수 있습니다.

이 오류를 해결하려면 다음을 수행합니다.

  • 도메인 컨트롤러에 대한 모든 네트워크 연결이 작동하며 ICMP(Internet Control Monitoring Protocol) 트래픽을 지원하는지 확인합니다.

  • 다음 문서의 유용한 정보를 고려하십시오.

    • LDAP Read Time 성능 카운터 및 Active Directory 바운드 문제 해결에 사용할 수 있는 기타 카운터에 대한 자세한 내용은 Microsoft Exchange Server 성능 문제 해결(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Active Directory 바운드 문제 방지" 항목을 참조하십시오. 이 문서에는 Active Directory 성능을 향상시키는 방법에 대한 내용도 포함되어 있습니다.

    • Active Directory 성능을 최대화하는 방법에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "Active Directory 통합 튜닝" 항목을 참조하십시오.

    • Active Directory 서버에 높은 수준의 가용성을 제공하는 방법에 대한 자세한 내용은 Exchange 2003 높은 수준의 가용성 가이드(http://go.microsoft.com/fwlink/?LinkId=47571)의 "시스템 수준 내결함성 조치" 항목에서 Active Directory 및 DNS(Domain Name System)에 대한 안정적인 액세스 보장 아래 섹션을 참조하십시오.

    • 네트워크 대역폭 고려 사항에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "Exchange 성능 이해" 항목에서 네트워크 성능 섹션을 참조하십시오.


평균 LDAP 검색 대기 시간이 50밀리초를 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-14

Microsoft Exchange Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeDSAccess Process 성능 개체의 LDAP Search Time 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

LDAP Search Time 성능 카운터는 LDAP(Lightweight Directory Access Protocol) 검색 요청을 만족시키는 데 걸리는 시간(밀리초)을 표시합니다. Exchange Analyzer는 5분 동안 5초마다 샘플을 검색합니다. 그런 다음 Exchange Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 평균 값이 50밀리초를 초과하면 오류를 표시합니다.

RPC(원격 프로시저 호출) 대기 시간이 길거나 큐가 증가하면 LDAP 검색 대기 시간이 길어질 수 있습니다. 긴 LDAP 검색 대기 시간은 일반적으로 다음 문제 중 하나를 나타냅니다.

  • 도메인 컨트롤러에 대한 네트워크 연결에 성능 문제가 있습니다.

  • 도메인 컨트롤러 자체에 성능 문제가 있습니다.

참고:
사용자가 다른 실제 사이트에 있는 도메인 컨트롤러에 연결하는 경우 일반적으로 LDAP 대기 시간이 더 길어집니다. 그러나 이 문서에서 설명하는 권장 최대 대기 시간은 일반적으로 다음과 같아야 합니다.

이 경고를 기록한 도메인 컨트롤러가 다른 실제 사이트에 있는 경우 Exchange 서버에서 이 경고를 보고하는 도메인 컨트롤러를 사용하지 않음을 확인할 수 있으면 이 오류를 안전하게 무시할 수 있습니다. Exchange에서 도메인 컨트롤러를 사용하는지 여부를 확인하는 한 가지 방법은 MSExchangeDSAccess 서비스의 토폴로지 구성 요소에 대한 진단 로깅 수준을 최소로 높이는 것입니다. MSExchangeDSAccess 이벤트 ID 이벤트 2080이 표시되지 않으면 이 경고를 안전하게 무시할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  • 도메인 컨트롤러에 대한 모든 네트워크 연결이 작동하며 ICMP(Internet Control Monitoring Protocol) 트래픽을 지원하는지 확인합니다.

  • 다음 문서의 유용한 정보를 고려하십시오.

    • LDAP Read Time 성능 카운터 및 Active Directory 바운드 문제 해결에 사용할 수 있는 기타 카운터에 대한 자세한 내용은 Microsoft Exchange Server 성능 문제 해결(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Active Directory 바운드 문제 방지" 항목을 참조하십시오. 이 문서에는 Active Directory 성능을 향상시키는 방법에 대한 내용도 포함되어 있습니다.

    • Active Directory 성능을 최대화하는 방법에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "Active Directory 통합 튜닝" 항목을 참조하십시오.

    • Active Directory 서버에 높은 수준의 가용성을 제공하는 방법에 대한 자세한 내용은 Exchange 2003 높은 수준의 가용성 가이드(http://go.microsoft.com/fwlink/?LinkId=47571)의 "시스템 수준 내결함성 조치" 항목에서 Active Directory 및 DNS(Domain Name System)에 대한 안정적인 액세스 보장 아래 섹션을 참조하십시오.

    • 네트워크 대역폭 고려 사항에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "Exchange 성능 이해" 항목에서 네트워크 성능 섹션을 참조하십시오.


최대 LDAP 검색 대기 시간이 100밀리초를 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-14

Microsoft Exchange Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeDSAccess Process 성능 개체의 LDAP Search Time 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

LDAP Search Time 성능 카운터는 LDAP(Lightweight Directory Access Protocol) 검색 요청을 만족시키는 데 걸리는 시간(밀리초)을 표시합니다. Exchange Analyzer는 5분 동안 5초마다 샘플을 검색합니다. 그런 다음 Exchange Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 최대값이 100밀리초를 초과하면 오류를 표시합니다.

RPC(원격 프로시저 호출) 대기 시간이 길거나 큐가 증가하면 LDAP 검색 대기 시간이 길어질 수 있습니다. 긴 LDAP 검색 대기 시간은 일반적으로 다음 문제 중 하나를 나타냅니다.

  • 도메인 컨트롤러에 대한 네트워크 연결에 성능 문제가 있습니다.

  • 도메인 컨트롤러 자체에 성능 문제가 있습니다.

참고:
사용자가 다른 실제 사이트에 있는 도메인 컨트롤러에 연결하는 경우 일반적으로 LDAP 대기 시간이 더 길어집니다. 그러나 이 문서에서 설명하는 권장 최대 대기 시간은 일반적으로 다음과 같아야 합니다.

Exchange 서버는 글로벌 카탈로그 서버와 도메인 컨트롤러 목록을 최신 상태로 유지하기 위해 도메인을 벗어난 글로벌 카탈로그 서버를 15분 간격으로 쿼리합니다. 이들 디렉터리 서버 중 일부는 원격 서버일 수 있으므로 이러한 쿼리의 대기 시간이 길어질 수 있습니다. 요청이 자주 발생하지 않으면 즉, 속도가 초당 0.5개 이하 요청이면 문제가 되지 않습니다.

이 오류를 기록한 도메인 컨트롤러가 다른 실제 사이트에 있는 경우 Exchange 서버에서 이 오류를 보고하는 도메인 컨트롤러를 사용하지 않음을 확인할 수 있는 경우 이 오류를 무시해도 안전합니다. Exchange에서 도메인 컨트롤러를 사용하는지 여부를 확인하는 한 가지 방법은 MSExchangeDSAccess 서비스의 토폴로지 구성 요소에 대한 진단 로깅 수준을 최소로 높이는 것입니다. MSExchangeDSAccess 이벤트 ID 이벤트 2080이 표시되지 않으면 이 오류를 안전하게 무시할 수 있습니다.

중요:
혼합 모드 환경의 경우에만 tokenGroups 및 tokengroupsGlobalandUniversal 같은 특정 보안 관련 사용자 특성에 대해 Exchange 2000 SP2 시간 프레임에서 동작이 도입되었습니다. 이러한 특성은 사용자가 구성원으로 속한 보안 그룹이 무엇인지와 Exchange 서버에서 사용자 홈 도메인의 신뢰할 수 있는 도메인 컨트롤러를 쿼리해야 하는 공용 폴더와 같은 리소스를 사용자가 안전하게 하기 위해 필요한 사용 권한이 무엇인지 확인하는 데 사용되었습니다. 신뢰할 수 있는 도메인 컨트롤러는 원격 사이트에 있을 수 있으며 로컬 공용 폴더에 액세스하는 많은 원격 홈 도메인 사용자의 쿼리로 인해 RPC 대기 시간이 길어질 수 있습니다.

이 동작에 대한 자세한 내용은 다음 Exchange 서버 블로그 기사를 참조하십시오.

  • Exchange Does Not Always Use Local GCs

    참고:
    필요한 기술 정보를 찾는 데 도움이 되도록 블로그에 대한 링크를 제공합니다. 블로그의 내용과 해당 URL은 예고 없이 변경될 수 있습니다.

이 오류를 해결하려면 다음을 수행합니다.

  • 도메인 컨트롤러에 대한 모든 네트워크 연결이 작동하며 ICMP(Internet Control Monitoring Protocol) 트래픽을 지원하는지 확인합니다.

  • 다음 문서의 유용한 정보를 고려하십시오.

    • LDAP Read Time 성능 카운터 및 Active Directory 바운드 문제 해결에 사용할 수 있는 기타 카운터에 대한 자세한 내용은 Microsoft Exchange Server 성능 문제 해결(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Active Directory 바운드 문제 방지" 항목을 참조하십시오. 이 문서에는 Active Directory 성능을 향상시키는 방법에 대한 내용도 포함되어 있습니다.

    • Active Directory 성능을 최대화하는 방법에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "Active Directory 통합 튜닝" 항목을 참조하십시오.

    • Active Directory 서버에 높은 수준의 가용성을 제공하는 방법에 대한 자세한 내용은 Exchange 2003 높은 수준의 가용성 가이드(http://go.microsoft.com/fwlink/?LinkId=47571)의 "시스템 수준 내결함성 조치" 항목에서 Active Directory 및 DNS(Domain Name System)에 대한 안정적인 액세스 보장 아래 섹션을 참조하십시오.

    • 네트워크 대역폭 고려 사항에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "Exchange 성능 이해" 항목에서 네트워크 성능 섹션을 참조하십시오.


지정된 Exchange 게이트웨이를 확인할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-08-08

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에서 msExchExchangeServer의 개체 클래스가 있는 각 디렉터리 개체의 이름(cn)을 쿼리하여 사용자 지정 Exchange 게이트웨이 서버에 일치하는 항목이 있는지 확인합니다.

cn 값은 Exchange Server 컴퓨터의 약식 이름을 포함하는 문자열입니다.

Active Directory에서 사용자 지정 Exchange 게이트웨이 서버에 일치하는 cn 값을 찾을 수 없는 경우 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 다음 조건 중 하나에 해당함을 나타냅니다.

  • 로컬 Exchange Server 조직에 사용자 지정 Exchange 게이트웨이 서버가 없습니다.

  • 사용자 지정 Exchange 게이트웨이 서버가 잘못 입력되었습니다.

이 오류를 해결하려면 지정된 Exchange 게이트웨이 서버가 올바로 입력되었는지 확인하고 다시 작업해 보십시오.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
서버 이름(cn) 값을 확인하려면 다음을 수행합니다.

  1. ADSI 편집이나 비슷한 도구를 사용하여 Active Directory에서 서버 개체를 찾습니다.

    CN 특성은 다음 위치에 있습니다.

    코드 복사
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server.


Categorizer Queue Length가 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 SMTP Server 성능 개체의 Categorizer Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Exchange Server Analyzer는 샘플 시간 동안 Categorizer Queue Length 카운터가 최고값 10을 초과한 경우 오류를 표시합니다.

SMTP Server\Categorizer Queue Length 카운터는 SMTP(Simple Mail Transfer Protocol) 분류기 큐에서 글로벌 카탈로그 서버를 사용한 디렉터리 서비스 특성 검색을 기다리는 메시지 수를 나타냅니다.

분류기가 수행하는 핵심 작업은 다음과 같습니다.

  • 모든 받는 사람을 확인하고 유효성을 확인합니다.

  • 모든 받는 사람의 한계와 제한을 확인합니다.

  • 필요한 경우 메일 그룹을 확장합니다.

  • 메시지를 로컬 배달할지 아니면 원격 배달할지 확인합니다.

이 오류는 서버나 네트워크 성능, 디렉터리 서비스 액세스(DSAccess), Active Directory® 디렉터리 서비스 또는 Exchange Server 조직의 키 서버 중지 등의 문제가 있을 수 있음을 나타냅니다. Categorizer Queue Length 카운터 증가는 Active Directory에 대한 참조 또는 로컬 배달이나 SMTP에 대한 메시지 전달이 느려지거나 응답하지 않음을 나타낼 수 있습니다. 이 문제로 인해 메일 배달이 지연될 수 있습니다.

이 오류를 해결하려면 다음을 수행합니다.

  • Exchange 서버에 사용할 수 있는 Active Directory 리소스가 충분한지 확인합니다. 여기에는 도메인 컨트롤러와 글로벌 카탈로그 서버가 포함됩니다. 속도가 비슷한 Exchange 서버 프로세서와 글로벌 카탈로그 서버 프로세스 간의 권장 구성은 4:1 비율을 유지하는 것입니다.

  • Exchange System Manager에서 Exchange 서버의 DSAccess 탭에 나열된 모든 도메인 컨트롤러가 제대로 작동하고 있는지 확인합니다. 여기에는 ConfigDC에 나열된 서버, 도메인 컨트롤러 및 글로벌 카탈로그 서버 역할이 포함됩니다.

  • Exchange 서버와 해당 선택 도메인 컨트롤러 및 글로벌 카탈로그 서버 간의 네트워크 성능을 모니터링하여 네트워크 성능 지체가 있는지 확인합니다.

  • Exchange 서버의 프로세서 사용률 및 Inetinfo.exe 프로세스의 프로세서 사용률을 모니터링합니다. 여기에는 분류기 구성 요소가 포함됩니다.

  • Microsoft Exchange Server 배포 도구(http://go.microsoft.com/fwlink/?LinkId=21231)의 ConfigDSInteg 도구에서 e2kdsinteg 구성 개체를 사용하여 Exchange 관련 사용자 및 그룹 개체의 상태를 확인합니다. 잘못된 주소 또는 불완전한 정보가 있는 개체로 인해 받는 사람 확인 지연 및 지연 분류가 발생할 수 있습니다.

추가 정보

Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


CDO.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


CimWin32.dll 업데이트 사용 가능
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-09-19

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange Server 컴퓨터에서 실행 중인 Microsoft Windows® 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 4.0은 Exchange Server 컴퓨터에 Microsoft Windows NT® Server 4.0이 실행되고 있음을 나타냅니다. 값 5.0은 Exchange Server 컴퓨터에 Windows 2000 Server가 실행되고 있음을 나타내고 값 5.2는 Exchange Server 컴퓨터에 Windows Server™ 2003이 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 Cimwin32.dll 파일의 Version 키 값이 설정되어 있는지 확인할 때 CIM_Datafile Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 유용한 정보 메시지를 표시합니다.

  • Exchange Server 컴퓨터가 Windows 2000 Server에서 실행되고 있습니다.

  • Version 키 값이 Cimwin32.dll 파일의 특정 버전에 해당합니다.

Exchange Server Analyzer가 효과적으로 작업할 수 있도록 하는 Cimwin32.dll 파일 업데이트가 이용 가능합니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 820608, "CIM_DataFile class returns an incorrect or null value for files that are larger than 2 GB in Windows 2000"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=820608)에 나오는 권장 사항을 검토하고 적용하십시오.


클라이언트 응용 프로그램이 서버 성능에 영향을 줍니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange 조직에 서버 로드를 증가시킬 수 있는 클라이언트 컴퓨터 또는 클라이언트 쪽 응용 프로그램의 특정 유형을 확인했습니다.

다수의 응용 프로그램을 사용하면 서버에 로드가 증가될 수 있습니다. 로드가 증가할 경우 사용자가 실행하고 있는 응용 프로그램을 조사하고 사용자가 특정 응용 프로그램을 실행하지 못하도록 제한할지 여부를 결정해야 합니다. 전자 메일(타사 응용 프로그램 또는 Microsoft Office Outlook® 플러그 인)에 액세스하는 일부 응용 프로그램은 서버에 로드를 증가시킬 수 있습니다. 서버에서 RPC(원격 프로시저 호출) 대기 시간이 길어지거나 로드가 증가할 경우에는 해당 소스를 조사하는 것이 좋습니다.

ExMon(Exchange Server User Monitor)을 사용하여 대기 시간이 길거나 서버의 로드가 증가하는 사용자의 컴퓨터를 식별할 수 있습니다. ExMon을 다운로드하려면 Microsoft Download Center(http://go.microsoft.com/fwlink/?linkid=54983)를 참조하십시오.

절차

이 경고를 해결하려면 다음을 수행합니다.

  • ExMon을 사용하여 서버 로드를 증가시키는 사용자를 식별합니다. 사용자를 식별한 후 사용자와 연락하여 다음 응용 프로그램이 추가적인 로드를 발생시키는지 확인합니다.

    • 타사 클라이언트 컴퓨터 플러그 인

    • Exchange ActiveSync® 또는 Blackberry와 같은 데스크톱 동기화 장치

    • 데스크톱 검색 엔진과 같은 기타 MAPI 응용 프로그램

    이 응용 프로그램을 업무용으로 사용하지 않거나 응용 프로그램에 게시된 핫픽스가 있는 경우에는 해당 응용 프로그램을 해제하거나 업데이트하여 적절한 수준으로 로드를 줄이십시오.

  • 작업면에서 가장 부담이 큰 클라이언트 컴퓨터(특히 Restrict, SetColumns 또는 FindRow 작업에 대기 시간이 긴 컴퓨터)가 캐시된 Exchange 모드를 사용하도록 구성하십시오. 캐시된 Exchange 모드는 대부분의 초과 RPC 소통량으로부터 서버를 격리합니다.

    또한 폴더에 많은 항목을 갖고 있는 사용자들이 오래된 데이터를 .pst 파일에 보관하도록 하는 것이 좋습니다. 혹은 서버에 데이터를 보관하려는 하는 사용자들이 있다면 오래된 항목을 새로 만든 폴더로 이동하도록 하는 것이 좋습니다.

    마지막으로 받은 편지함, 일정, 보낸 편지함, 연락처 및 지운 편지함 폴더를 5,000 미만으로 유지하는 것이 좋습니다.
참고:
일부 응용 프로그램은 MAPI 작업 수를 많이 발생시키지 않고도 서버 로드를 상당히 증가시킬 수 있습니다. 이는 일부 작업이 다른 작업보다 부담이 크기 때문입니다. 부담이 큰 작업 수가 조금만 증가해도 서버 성능에 큰 영향을 미칠 수 있습니다. ExMon에서는 이 사용자들이 MAPI 작업 수를 많이 발생시키지 않고도 상대적으로 높은 CPU 영향을 주는 것으로 보고됩니다.

자세한 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • Outlook 클라이언트 성능 문제 해결에 대한 자세한 내용은 "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)를 참조하십시오.

  • 데스크톱 검색 소프트웨어에 대한 자세한 내용은 Microsoft 기술 자료 문서 905184, "Exchange 2000 Server and Exchange Server 2003 performance may be affected when desktop search engine software is running on Outlook or other MAPI client computers"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184)를 참조하십시오.


클러스터 TEMP 경로가 잘못되었거나 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

클러스터되지 않은 Exchange Server 컴퓨터에서 Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 TEMP 환경 변수 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

Microsoft Windows® 서버 클러스터의 EVS(Exchange 가상 서버)에 대해 Exchange Server Analyzer를 실행한 경우 Exchange Server Analyzer는 HKLM 레지스트리 하이브를 읽지 않습니다. 대신 다음 레지스트리 항목을 읽습니다.

HKEY_USERS\<Cluster service account SID>\Environment\TEMP

Exchange Server Analyzer는 TEMP 환경 변수가 현재 시스템에서 사용할 수 있는 경로로 설정되어 있지 않은 경우 경고를 표시합니다. 이 경로가 잘못된 경우 조직에서 메일 배달 문제가 발생할 수 있습니다. 기본적으로 기본 구성의 Exchange Server Analyzer는 이 경로가 %USERPROFILE%\Local Settings\Temp로 설정되어 있다고 가정합니다. 이 경로가 다른 위치를 가리키도록 수정할 수 있지만 핫픽스나 업데이트를 적용한 후 클러스터 노드를 다시 실행하면 시스템에서 기본값으로 설정된 경로를 찾습니다.

TEMP 환경 변수는 임시 작업 공간이 필요한 응용 프로그램에서 사용해야 하는 파일 시스템의 폴더를 지정하는 데 사용됩니다. Exchange Server와 같은 응용 프로그램에서 일반적으로 TEMP가 사용됩니다. 각 변수의 경로는 대개 응용 프로그램의 컨텍스트와 연관됩니다. 예를 들어 Microsoft Exchange Information Store 서비스 프로세스는 메시지 변환과 사서함 이동 작업 같은 다양한 작업 중에 TEMP 폴더를 임시 저장소로 사용합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 클러스터 서비스 계정으로 클러스터의 노드에 로그온합니다.

  2. 내 컴퓨터를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  3. 고급을 선택합니다.

  4. 환경 변수를 클릭합니다.

  5. <account name>에 대한 사용자 변수 영역에서 TEMP를 선택하고 편집을 클릭합니다.

  6. 변수 값 필드에서 TEMP 환경 변수의 기본 경로를 입력하고 확인을 클릭합니다.

  7. 확인을 클릭하여 환경 변수 대화 상자를 닫고 확인을 한 번 더 클릭하여 시스템 속성 대화 상자를 닫습니다.

  8. 노드를 다시 시작하여 변경 내용을 적용합니다.

  9. 클러스터에서 기본 설정이 아닌 각 노드에 대해 1-8단계를 반복합니다.


오프라인 주소록 복제본을 여러 개 만드십시오.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-08-14

Microsoft® Exchange Server Analyzer Tool은 root\MicrosoftExchangeV2 네임스페이스 아래의 Exchange_PublicFolder Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 ReplicaList 키의 항목 수를 확인합니다. 항목 수는 각 관리 그룹에 존재하는 오프라인 주소록 복제본 수를 나타냅니다.

또한 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스를 쿼리하여 legacyExchangeDN 특성이 설정된 공용 폴더 데이터베이스 개체 수를 확인합니다. 이 특성이 설정된 개체 수는 해당 조직에 존재하는 공용 폴더 저장소 수를 나타냅니다.

공용 폴더 저장소가 여러 개 있는 Exchange 조직에 오프라인 주소록 복제본이 하나만 있으면 Exchange Server Analyzer에서 유용한 정보 메시지를 표시합니다.

사용 가능성과 성능을 위해 각 오프라인 주소록의 복제본을 여러 개 배포하는 것이 좋습니다. 오프라인 주소록 복제본을 여러 개 사용하면 성능과 복원 기능이 향상될 수도 있습니다. 대규모 Exchange 조직에 오프라인 주소록 복제본이 하나만 있으면 과부하 상태가 될 수도 있습니다. 어떠한 Exchange 조직에서도 오프라인 주소록 복제본이 하나만 있으면 한 곳에서만 오류가 발생합니다.

복제본을 여러 개 사용하면 네트워크상에 복제 소통량이 추가로 발생하지만 복제본을 여러 개 사용하는 것이 좋습니다. 각 오프라인 주소록의 복제본이 두 개 이상 있어야 합니다.

Exchange 조직에 오프라인 주소록의 복제본을 추가하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 폴더를 확장하고 공용 폴더를 마우스 오른쪽 단추로 클릭한 다음 시스템 폴더 보기를 선택합니다. 참고 폴더 노드가 보이지 않으면 관리 그룹을 확장한 다음 보고자 하는 시스템 폴더가 있는 관리 그룹을 확장합니다. 그런 다음 공용 폴더를 마우스 오른쪽 단추로 클릭하고 시스템 폴더 보기를 선택합니다.

  3. 오프라인 주소록 컨테이너를 확장한 다음 결과 드롭다운 목록에서 속성을 선택하여 복제본을 추가할 오프라인 주소록을 마우스 오른쪽 단추로 클릭합니다.

  4. 복제 탭을 선택한 다음 추가를 클릭하여 복제본을 추가할 공용 저장소를 선택합니다. 확인을 클릭하여 작업을 마칩니다.

  5. 복제본을 추가할 오프라인 주소록 컨테이너 아래의 모든 자식 개체에 대해 3-4단계를 반복합니다. 반복 작업을 하면 지원되는 모든 형식이 복제본에 포함됩니다. 특히 OAB 버전 2, OAB 버전 3a 등과 같은 자식 개체를 추가하십시오.

오프라인 주소록을 관리하고 구성하는 방법에 대한 자세한 내용은 다음 Microsoft Exchange Server TechCenter 문서를 참조하십시오.

  • "Offline Address Book - Things to Consider"(http://go.microsoft.com/fwlink/?LinkId=57581).

  • "Exchange Server 2003 저장소 작업"(http://go.microsoft.com/fwlink/?LinkId=47595).

  • "Offline Address Book Best Practices Guide"(http://go.microsoft.com/fwlink/?LinkId=47583).

  • "OAB Version 4 in Exchange Server 2003 Service Pack 2"(http://go.microsoft.com/fwlink/?linkid=53097).

  • "How Outlook 2003 SP2 and Exchange Server 2003 SP2 OAB Version 4 Work Together"(http://go.microsoft.com/fwlink/?linkid=53099).


받는 사람 업데이트 도메인 컨트롤러에 대한 연결
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-05-18

Microsoft® Exchange Server Analyzer는 각 도메인 컨트롤러에서 포트 389에 대한 TCP 소켓 연결을 엽니다. 연결이 성공적일 경우 특정 문자열을 반환하는 사용자 지정 개체 프로세서를 사용하여 이 연결이 설정됩니다.

Exchange Server Analyzer는 반환되는 문자열에 389 Available이 없을 경우 경고를 표시합니다.

이 경고는 도메인 컨트롤러가 TCP 포트 389에서 연결 시도에 응답하지 않았음을 나타냅니다. TCP 포트 389는 LDAP(Lightweight Directory Access Protocol) 통신에 필요한 기본 포트입니다. 이 경고가 표시되는 경우 다음 조건이 존재할 수 있습니다.

  • Exchange Server Analyzer와 도메인 컨트롤러 간에 연결 문제가 있을 수 있습니다.

  • 서버가 다운되었을 수 있습니다.

  • 서버 역할이 해제되었을 수 있습니다.

Exchange Server Analyzer가 도메인 컨트롤러를 쿼리할 때 도메인 컨트롤러가 LDAP 요청을 올바르게 처리하지 못하는 데는 여러 가지 이유가 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server Analyzer를 실행하는 계정에 도메인 컨트롤러를 쿼리할 권한이 있는지 확인합니다. 도메인 컨트롤러가 실행 중인 도메인에 사용자 수준의 사용 권한이 있어야 합니다. Exchange Server Analyzer를 실행하는 데 필요한 사용 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말 파일에 나와 있습니다. Exchange Server Analyzer 도움말 파일을 열려면 Exchange Server Analyzer에서 도움말을 클릭한 다음 Microsoft Exchange Server Analyzer Tool 도움말을 클릭합니다.

  2. Exchange Server Analyzer를 실행하는 컴퓨터와 응답하지 않는 도메인 컨트롤러 사이에 방화벽 또는 포트 제한이 없는지 확인합니다.

  3. 도메인 컨트롤러가 네트워크에 연결되어 있고 제대로 작동하는지 확인합니다.

  4. 서버 역할이 해제되지 않았고 Exchange Server에 계속 사용 가능한 도메인 컨트롤러인지 확인합니다.

자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 319065, "Exchange Recipient Update Service로 작업하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065)

  • 816103, "Troubleshoot Active Directory Connectivity 문제에 Portqry 사용하는 방법" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103)


이 공용 폴더 저장소에 콘텐츠 인덱싱이 사용되지만 업데이트는 예약되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 공용 폴더 저장소의 msExchCIAvailable 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성 값은 공용 폴더 저장소에 콘텐츠 인덱싱이 사용되는지 여부를 나타냅니다. 값 True는 공용 폴더 저장소의 콘텐츠 인덱스가 있고 Exchange System Manager 설정인 클라이언트가 이 인덱스를 현재 검색할 수 있음 이 선택되었음을 나타냅니다. 값 False는 공용 폴더 저장소의 콘텐츠 인덱스가 있지만 Exchange System Manager 설정인 클라이언트가 이 인덱스를 현재 검색할 수 있음의 선택이 해제되어 있음을 나타냅니다. 값 <Not Set>은 공용 폴더 저장소의 콘텐츠 인덱스가 없음을 나타냅니다.

또한 Exchange Server Analyzer는 각 공용 폴더 저장소의 msExchCIRebuildSchedule 특성 값을 확인할 때 Active Directory를 쿼리합니다. 이 특성 값은 콘텐츠 인덱스에 대한 다시 작성 일정 설정을 나타냅니다. 이 특성은 82쌍의 16진수 값으로 된 8진수 문자열로 저장됩니다.

Exchange Server Analyzer는 msExchCIAvailable 특성 값이 True로 설정되었지만 msExchCIRebuildSchedule 특성의 8진수 문자열 값이 실행 안 함으로 해석되는 경우 경고를 표시합니다.

업데이트 간격을 설정할 때는 하루에 적어도 한 번씩 증분 업데이트가 수행되도록 예약하는 것이 좋습니다. 인덱스는 마지막으로 채워진 것만 최신 상태이므로 더 자주 업데이트할 수도 있습니다. 정기적으로 업데이트하지 않는 인덱스는 정확하지 않고 최신 상태가 아닌 결과를 생성할 수 있습니다.

또한 증분 채우기를 완료해야 하는 시기를 고려해야 합니다. 예를 들어 표준 일정에서는 매시 정각에 증분 업데이트가 수행되도록 설정합니다. 그러나 업데이트가 한 시간이 넘도록 계속되면 다음 증분 채우기는 그 다음 시간 정각에 시작됩니다.

일반적으로 공용 폴더 저장소가 6GB 이하이면 증분 업데이트를 매 시간 수행할 수 있습니다. 저장소가 6GB보다 크거나 서버의 메모리 사용량이 많으면 인덱스를 덜 자주 업데이트할 수 있습니다.

특정 공용 폴더 저장소에서 전체 텍스트 인덱싱 업데이트 간격을 설정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버, 사용 중인 서버, 저장소 그룹을 차례로 확장하고 공용 폴더 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. Exchange System Manager에 관리 그룹 노드가 표시되지 않으면 서버를 확장하고 사용 중인 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 전체 텍스트 인덱싱 탭에서 실행 안 함 이외의 옵션을 선택합니다.

  4. 사용자 지정 일정 사용을 선택한 경우 사용자 지정을 클릭하고 사용 중인 사용자 지정 일정을 설정한 다음 확인을 클릭합니다.

  5. 적용을 클릭합니다.

Exchange Server의 전체 텍스트 인덱싱에 대한 자세한 내용은 Best Practices for Deploying Full-Text Indexing(http://go.microsoft.com/fwlink/?linkid=5223)을 참조하십시오.


이 사서함 저장소에 콘텐츠 인덱싱이 사용되지만 업데이트는 예약되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 사서함 저장소 개체의 msExchCIAvailable 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성 값은 사서함 저장소에 대해 콘텐츠 인덱싱이 사용되는지 여부를 나타냅니다. 값이 TRUE이면 사서함 저장소에 대한 콘텐츠 인덱스가 있고 Exchange System Manager 설정인 "클라이언트가 이 인덱스를 현재 검색할 수 있음"이 선택되었음을 나타냅니다. 값이 FALSE이면 사서함 저장소에 대한 콘텐츠 인덱스가 있으나 Exchange System Manager 설정인 클라이언트가 이 인덱스를 현재 검색할 수 있음의 선택이 해제되었음을 나타냅니다. 값 <Not Set>은 사서함 저장소의 콘텐츠 인덱스가 없음을 나타냅니다.

Exchange Server Analyzer는 각 사서함 저장소의 msExchCIRebuildSchedule 특성 값을 확인할 때도 Active Directory를 쿼리합니다. 이 특성 값은 콘텐츠 인덱스에 대한 다시 작성 일정 설정을 나타냅니다. 이 특성은 82쌍의 16진수 값으로 된 8진수 문자열로 저장됩니다.

Exchange Server Analyzer는 msExchCIAvailable 특성 값이 TRUE로 설정되었으나 msExchCIRebuildSchedule 특성의 8진수 문자열 값이 "실행 안 함"으로 해석되는 경우 경고를 표시합니다.

업데이트 간격을 설정할 때는 하루에 적어도 한 번씩 증분 업데이트가 수행되도록 예약하는 것이 좋습니다. 인덱스는 마지막으로 채워진 것만 최신 상태이므로 더 자주 업데이트할 수도 있습니다. 정기적으로 업데이트하지 않는 인덱스는 정확하지 않고 최신 상태가 아닌 결과를 생성할 수 있습니다.

또한 증분 채우기를 완료하는 데 걸리는 시간을 고려해야 합니다. 예를 들어 표준 일정에서는 매시 정각에 증분 업데이트가 수행되도록 설정합니다. 그러나 업데이트가 한 시간이 넘도록 계속되면 다음 증분 채우기는 그 다음 시간 정각에 시작됩니다.

일반적으로 사서함 저장소가 6GB 이하이면 증분 업데이트를 매 시간 수행할 수 있습니다. 저장소가 6GB보다 크거나 서버의 메모리 사용량이 많으면 인덱스를 덜 자주 업데이트할 수 있습니다.

특정 사서함 저장소에서 전체 텍스트 인덱싱 업데이트 간격을 설정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버, 사용 중인 서버, 저장소 그룹을 차례로 확장하고 사서함 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. Exchange System Manager에 관리 그룹 노드가 표시되지 않으면 서버를 확장하고 사용 중인 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 전체 텍스트 인덱싱 탭에서 실행 안 함 이외의 옵션을 선택합니다.

  4. 사용자 지정 일정 사용을 선택한 경우 사용자 지정을 클릭하고 사용 중인 사용자 지정 일정을 설정한 다음 확인을 클릭합니다.

  5. 적용을 클릭합니다.

Exchange에서 전체 텍스트 인덱싱 구성 및 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 822932, "HOW TO: Configure Full-Text Indexing on Mailbox Stores in Exchange 2003"(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932) 및 319436, "How to configure full-text indexing on mailbox stores in Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436)을 참조하십시오.

Exchange Server의 전체 텍스트 인덱싱에 대한 자세한 내용은 Best Practices for Deploying Full-Text Indexing(http://go.microsoft.com/fwlink/?LinkId=5223)을 참조하십시오.


콘텐츠 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-06-21

자세한 내용은 Exchange Server 2007 설명서 다운로드 페이지를 참조하십시오.


CQPCIDRV.SYS 드라이버 업데이트를 사용할 수 있음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-08-14

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange Server를 실행하는 서버에서 실행 중인 Microsoft Windows®의 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값이 4.0이면 Exchange Server에서 Microsoft Window NT® Server 4.0을 실행하고 있습니다. 값이 5.0이면 Exchange Server에서 Window 2000 Server를 실행하고 있습니다. 값이 5.2이면 Exchange Server 컴퓨터에서 Windows Server™ 2003을 실행하고 있습니다.

또한 Exchange Server Analyzer는 Win32_Processor WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 DataWidth 키 값을 확인합니다.

DataWidth 키 값이 32이면 서버에서 32비트 버전의 Windows 운영 체제를 실행하고 있고 DataWidth 키 값이 64이면 서버에서 64비트 버전의 Windows 운영 체제를 실행하고 있습니다.

마지막으로 Exchange Server Analyzer는 CIM_Datafile WMI 클래스를 쿼리하여 CpqCiDrv.sys 파일의 Version 키 값을 확인합니다.

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • Exchange Server에서 Exchange Server 2003을 실행하고 있습니다.

  • Exchange Server에서 64비트 버전의 Windows 운영 체제를 실행하고 있습니다.

  • HP Integrated Lights-Out Management Interface 드라이버, CPQCIDRV.sys의 버전이 1.8보다 이전 버전입니다.

이 오류는 서버에 설치된 CpqCiDrv.sys의 버전으로 인해 커널 메모리 할당 오류가 발생할 수 있음을 나타냅니다.

이 문제를 해결하려면 문서 ID: c00688313(http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00688313)의 공급업체 지시에 따르십시오.

참고:
이 항목에 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 들어 있습니다. URL은 예고 없이 변경될 수 있습니다.


CrashOnAuditFail이 적용되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 CrashOnAuditFail 매개 변수가 설정되었는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA\CrashOnAuditFail

Exchange Server Analyzer는 CrashOnAuditFail 값이 2일 경우 오류를 표시합니다.

CrashonAuditFail 레지스트리 키는 보안 로그가 구성된 크기 제한에 도달할 경우 최종 사용자가 컴퓨터에 액세스할 수 없도록 서버를 구성하기 위한 것입니다. 컴퓨터에 대한 액세스를 허용하지 않으면 기록된 감사 정보가 손실되지 않습니다.

CrashonAuditFail 레지스트리 키는 사용될 경우 1로 설정됩니다. 그러나 보안 로그 제한에 도달하면 서버는 레지스트리 키를 2로 설정하므로 결과적으로 서버에서 처리가 중지됩니다. 때로는 이 과정 때문에 완전히 실패하거나 중지 오류라는 STOP 0xC0000244가 발생합니다. 최소한 사용자는 서버 리소스에 액세스할 수 없고 성능이 크게 떨어집니다. 또한 서버가 이 상태에 있으면 관리자 권한이 있는 사용자만 컴퓨터에 액세스할 수 있습니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Control\LSA를 탐색합니다.

  3. CrashOnAuditFail 값을 삭제합니다. 이 경우 값 데이터뿐 아니라 값 전체를 삭제해야 합니다.

  4. 보안 이벤트 로그를 별도의 위치에 복사합니다. 기본적으로 보안 이벤트 로그(SecEvent.Evt)는 %SystemRoot%\System32\Config에 있습니다. 여기서 %SystemRoot%는 Microsoft Windows® 운영 체제가 설치된 경로입니다.

  5. 이벤트 뷰어를 열고 보안을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  6. 보안 속성 페이지에서 로그 지우기를 클릭합니다. 로그를 저장하라는 메시지가 표시되면 예를 클릭한 다음 로그 파일을 저장할 위치를 지정합니다.

    참고 보안 속성 페이지에서 최대 로그 크기 필드를 편집한 다음 적용을 클릭하여 로그 크기를 증가시킬 수도 있습니다.

  7. 서버를 다시 시작합니다.

  8. Exchange 사서함에 로그온하여 사용자가 서버 리소스에 액세스할 수 있는지 확인합니다.

  9. CrashonAuditFail 레지스트리 키를 다시 만들고 값 데이터를 1로 설정합니다.

  10. 서버를 다시 시작하여 CrashonAuditFail 설정을 적용합니다.

  11. 서버의 보안 로그를 정기적으로 지우고 저장하여 최대 로그 크기가 초과되지 않도록 합니다. 자세한 내용은 Microsoft 기술 자료 문서 312571, "The event log stops logging events before reaching the maximum log size"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312571)를 참조하십시오.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

CrashOnAuditFail 실패를 복구하는 방법에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 232564, "STOP 0xC0000244 when security log full"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232564)

  • 829082, "You receive a "Stop error 0xC0000244 {Audit Failed}" error message when the crashonauditfail registry key is set to 1 on a Windows Server 2003-based computer"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=829082)


사용자 지정 공용 폴더 조회 목록
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 msExchFolderAffinityCustom 특성에 Exchange 서버 이름이 들어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchFolderAffinityCustom 특성에 서버 이름이 나열되면 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Exchange Server 2003에서는 라우팅 그룹을 사용하여 공용 폴더 조회를 확인합니다.

Exchange Server 2007에서는 기본적으로 Active Directory 디렉터리 서비스의 사이트 간 비용을 사용하여 공용 폴더 조회를 위한 라우팅을 확인합니다.

msExchFolderAffinityCustom 특성에 서버 이름이 나열되면 Exchange 서버에 사용자 지정 조회가 구성된 것입니다. msExchFolderAffinityCustom 특성은 서버별 특성입니다.

일반적으로 공용 폴더 조회에 기본 동작을 사용하는 것이 좋습니다. 그러나 사용자 지정 조회 목록을 만들어야 할 수 있습니다. 기본 구성이 아니라는 메시지는 정보 메시지입니다. 필요한 작업이 없습니다.

Exchange Server 2003에서 기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 사용자 지정 공용 폴더 조회가 구성되어 있는 서버 개체를 찾습니다. 사용자 지정 공용 폴더 조회가 구성되어 있는 Exchange 서버 이름은 Exchange Server Analyzer 메시지에 지정되어 있습니다.

  3. Server_Name을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 공용 폴더 조회 탭의 공용 폴더 조회 옵션 드롭다운 상자에서 라우팅 그룹 사용을 선택합니다.

  5. 적용을 클릭한 다음 확인을 클릭합니다.
Exchange Server 2007에서 기본 구성으로 되돌리려면 다음을 수행합니다.

  1. 다음 코드는 'MyServer\First Storage Group\Public Folder Database' 공용 폴더 데이터베이스에 대한 PublicFolderRefferalServerList를 사용할 수 없게 설정하는 Exchange 관리 셸 Set-PublicFolderDatabase 명령의 예입니다.
코드 복사
Set-PublicFolderDatabase -Identity "MyServer\First Storage Group\Public Folder Database" -UseCustomReferralServerList $false

UseCustomReferralServerList 매개 변수는 PublicFolderReferralServerList 매개 변수로 지정된 서버 비용의 사용 여부를 지정합니다. $true로 설정하면 서버에서 PublicFolderReferralServerList 매개 변수 비용을 사용하여 공용 폴더 조회를 실행합니다. $false로 설정하면 서버에서 Active Directory 사이트 간 비용을 사용하여 공용 폴더 조회를 실행합니다.

참고:
또한 이 매개 변수를 $false로 설정하면 PublicFolderReferralServerList 매개 변수가 삭제됩니다.

Exchange 관리 셸 Set-PublicFolderDatabase 명령에 대한 자세한 내용은 Exchange Server 2007 제품 설명서 기술 참조 "Set-PublicFolderDatabase"(http://go.microsoft.com/fwlink/?LinkId=80813)를 참조하십시오.

공용 폴더 복제에 대한 자세한 내용은 Best Practices for Exchange Server Public Folders(http://go.microsoft.com/fwlink/?LinkId=46437)를 참조하십시오.


데이터베이스 성능 모니터 개체를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터의 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 Database 성능 개체의 Log Record Stalls/sec 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. 카운터에서 올바른 데이터를 반환하지 않으면 Exchange Server Analyzer는 기본 메시지를 표시합니다.

다음과 같은 상황에서는 성능 데이터 수집 엔진에서 올바른 데이터가 반환되지 않습니다.

  • Database 성능 개체를 사용하지 않습니다.

  • Database 성능 모니터 개체가 없거나 손상되었습니다.

  • 성능 개체에 액세스할 수 있는 적절한 권한이 Exchange Server Analyzer에 없습니다.

맨 앞의 두 가지 상황은 확장 가능한 특정 카운터가 레지스트리를 손상시키거나 Microsoft WMI(Windows® Management Instrumentation) 기반 프로그램에서 레지스트리를 수정하는 경우에 발생할 수 있습니다.

다음 절차에서는 맨 앞의 두 가지 상황을 해결하는 방법을 설명합니다. 절차를 수행하기 전에 Exchange Server Analyzer에 적절한 권한이 있는지 확인합니다. Exchange Server Analyzer 실행에 필요한 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말을 참조하십시오. 도움말을 보려면 Exchange Server Analyzer를 열고 F1 키를 누르십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Database 성능 개체를 사용하는지 확인합니다.

    1. Extensible Performance Counter List 도구(Exctrlst.exe)를 다운로드하고 설치합니다. Exctrlst.exe: Extensible Performance Counter List(http://go.microsoft.com/fwlink/?LinkId=34436)에서 Exctrlst.exe를 다운로드할 수 있습니다.

    2. Exctrlst.exe를 열고 Sort Order와 Service를 차례로 클릭합니다.

    3. 성능 개체가 보고하는 서비스를 찾아 Performance Counters Enabled 확인란이 선택되었는지 확인합니다.

      Performance Counters Enabled 확인란이 선택되지 않았으면 이 확인란을 선택한 다음 성능 카운터에 연결된 서비스를 다시 시작하여 성능 카운터가 작동하는지 확인합니다. 성능 카운터가 작동하지 않거나 Performance Counters Enabled 확인란이 이미 선택되어 있으면 2단계로 넘어갑니다.

  2. Microsoft 기술 자료 문서 300965, "성능 카운터 라이브러리 값을 수동으로 다시 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956)에 지정된 대로 누락되거나 손상된 성능 카운터를 다시 빌드합니다.

  3. 이 기술 자료 문서에 따라 수행해도 문제가 해결되지 않으면 Exchange Server를 복구 모드로 다시 설치한 다음 최신 Exchange Server 서비스 팩을 적용해야 합니다.


DAVEX.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 다시 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


DHCP 클라이언트 서비스가 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 DHCP(Dynamic Host Configuration Protocol) 클라이언트 서비스에 대한 Started 키 값을 확인할 때 Win32_Service WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Exchange 서버에서 DHCP 클라이언트 서비스에 대한 Started 키 값이 False로 설정되어 있음을 확인하면 경고를 표시합니다.

이 경고는 DHCP 클라이언트 서비스가 실행되고 있지 않음을 나타냅니다. DHCP 클라이언트 서비스는 동적 DNS(Domain Name System) 업데이트를 수행합니다. DHCP 클라이언트 서비스가 실행되고 있지 않으면 동적 업데이트가 수행되지 않습니다. Exchange 서버에서 이 서비스가 실행되고 있지 않으면 메일 흐름 문제가 가장 일반적으로 발생합니다.

이 문제를 해결하려면 DHCP 클라이언트 서비스를 자동 시작으로 설정한 다음 서비스를 시작합니다.

참고:
서버에서 DHCP가 아니라 고정 IP 주소를 사용하도록 구성된 경우에도 DHCP 클라이언트 서비스가 실행 중이어야 합니다.
DHCP 클라이언트 서비스를 사용하려면 다음을 수행합니다.

  1. 서비스 스냅인을 엽니다.

  2. 세부 정보 창에서 DHCP Client Service를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭에서 시작 유형을 클릭하고 자동을 선택합니다.

  4. 시작, 확인을 차례로 클릭합니다.

DHCP 클라이언트 서비스에 대한 자세한 내용은 Microsoft 기술 자료 문서 264539, "Dynamic DNS updates do not work if the DHCP client service stops"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264539)를 참조하십시오.

DNS 동적 업데이트 프로토콜에 대한 자세한 내용은 Microsoft 기술 자료 문서 816592, "Windows Server 2003에서 DNS 동적 업데이트를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)을 참조하십시오.


Dr. Watson이 활성화되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 값을 읽어서 Dr. Watson이 Microsoft Windows® 운영 체제의 기본 응용 프로그램 디버거로 구성되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

Exchange Server Analyzer는 Debugger 값이 drwtsn32로 시작하지 않는 경우 기본 구성이 아니라는 메시지를 표시합니다.

이 메시지는 Dr. Watson을 사용할 수 없도록 설정되어 있음을 나타냅니다. Dr. Watson이라는 응용 프로그램 모드 디버거는 Windows NT®부터 Windows에 포함되었습니다. 응용 프로그램이 충돌하면 Dr. Watson에서는 이 오류를 추적할 수 있도록 플랫폼 정보, 실행 중인 프로세스 목록, 오류가 있는 프로세스의 ID, 오류가 있는 프로세스의 메모리 덤프, 하나 이상의 호출 스택 및 오류 자체를 가리키는 포인터 같은 다양한 정보를 기록합니다. 수집되는 대부분의 정보는 낮은 수준의 정보로, 오류가 있는 프로세스를 만든 개발자에게 제공됩니다.

Windows에서 응용 프로그램 모드 디버거를 사용할 수 있도록 설정하는 것이 좋습니다. Dr. Watson을 사용하지 않고 대체 응용 프로그램 디버거도 사용하지 않는 경우에는 다음 절차를 따라 Dr. Watson을 사용할 수 있게 설정하는 것이 좋습니다.

Dr. Watson을 사용하려면 다음을 수행합니다.

  1. 명령 프롬프트 창을 엽니다.

  2. 명령 프롬프트에서 drwtsn32 -i를 입력합니다.

Dr. Watson을 사용하거나 사용하지 않도록 설정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 188296, "How to Disable Dr. Watson for Windows"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296)를 참조하십시오.


DSA Computer 이름이 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 DSA Computer 값의 설정을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

또한 Exchange Server Analyzer는 각 Exchange 서버 개체의 name 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

마지막으로 Exchange Server Analyzer는 클러스터 서비스(ClusSvc)의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 클러스터 서비스가 시작되었음을 나타내고 False 값은 클러스터 서비스가 실행되고 있지 않음을 나타냅니다.

Exchange Server Analyzer는 DSA Computer 키 값이 Windows Server 클러스터에서 실행되고 있지 않은 Exchange Server 컴퓨터의 Active Directory에 포함된 해당 서버 개체의 name 특성 값과 일치하지 않을 경우 오류를 표시합니다.

이 오류를 해결하려면 DSA Computer 레지스트리 키를 Active Directory의 name 특성 값과 일치하도록 편집해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 편집하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. 오른쪽 창에서 DSA Computer를 두 번 클릭하고 이 컴퓨터의 올바른 이름을 입력한 후 확인을 클릭합니다.

  4. 레지스트리 편집기를 닫고 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


DSACCESS.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server 또는 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


DSAccess 구성 캐시가 꽉 찼습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-05-24

Microsoft® Exchange Server Analyzer Tool은 TotalEntriesMemoryConfigurationData 키의 현재 값을 확인할 때 Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 TotalEntriesMemoryConfigurationData 값이 DSAccess(Directory Service Access) 구성 캐시(MaxMemoryConfig)의 전체 크기와 같으면 경고를 표시합니다.

DSAccess는 Exchange 2000 Server 및 Exchange Server 2003의 내부 구성 요소로 모든 Exchange 구성 요소의 Active Directory® 디렉터리 서비스 액세스 방법을 관리합니다. DSAccess의 기본 기능은 다양한 디렉터리 관련 이벤트 및 작업에 대한 정보를 유지하는 것입니다. 예를 들어 DSAccess는 Active Directory 토폴로지를 검색하고 도메인 컨트롤러 및 글로벌 카탈로그 서버가 사용 가능하고 쿼리에 응답하는지 확인합니다. 또한 Microsoft Exchange 저장소 같은 내부 Exchange 구성 요소에 의해 만들어진 모든 디렉터리 쿼리는 받는 사람 확인, 구성 설정 조회 등과 같은 DSAccess를 통해 라우팅됩니다. 이러한 작업의 일부로, DSAccess는 같은 정보가 두 번 요청될 경우 Active Directory에 대해 다른 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 대신 DSAccess 캐시에서 이러한 정보를 검색할 수 있도록 일부 쿼리 결과를 메모리 내부 캐시에 유지합니다.

Exchange 2000 Server에서는 25MB였던 DSAccess 구성 캐시의 기본 최대 크기 설정이 Exchange Server 2003에서는 5MB로 줄었기 때문에 두 가지 버전의 Exchange에서 모두 이 경고 메시지가 생성될 수 있습니다. 이 경고 메시지를 생성한 Exchange의 버전에 관계없이 가능한 빨리 문제를 해결해야 합니다.

MaxMemoryConfig 값은 DSAccess 캐시의 사용자 데이터 개체에 사용될 수 있는 최대 메모리 용량을 제어하는 MaxMemoryUser 값과 함께 사용되는 경우가 많습니다. 다음 절차에서 설명한 것처럼 MaxMemoryConfig 값을 편집하거나 제거할 경우에는 마찬가지로 DSAccess 사용자 캐시 값이 기본값이 아닙니다.에서 설명한 것처럼 MaxMemoryUser 값도 편집하거나 제거해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0을 탐색합니다.

  3. MaxMemoryConfig의 값을 늘립니다. Instance0 키 또는 MaxMemoryConfig DWORD 값이 없으면 해당 값을 수동으로 만들 수 있습니다. MaxMemoryConfig 레지스트리 항목의 값 데이터는 킬로바이트(KB) 단위이므로 15000(10진수)은 15MB와 같습니다. 값이 있으면 10% 늘리고 값이 없으면 10MB로 초기 설정하는 것이 좋습니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange System Attendant를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


DSAccess 구성 캐시 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 DSAccess(Directory Service Access) 구성 개체 캐시의 크기가 기본값이 아닌 값으로 수정되었는지를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryConfig

Exchange Server Analyzer는 MaxMemoryConfig가 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

MaxMemoryConfig는 더 이상 Exchange Server 2003에서 일반적으로 사용되지 않는 Exchange 2000 Server 레지스트리 매개 변수입니다.MaxMemoryConfig는 DSAccess 구성 캐시의 구성 데이터 개체가 사용할 수 있는 메모리의 최대 용량을 제어합니다. DSAccess는 모든 Exchange 구성 요소가 Active Directory® 디렉터리 서비스에 액세스하는 방식을 제어하는 Exchange 2000 Server 및 Exchange Server 2003의 내부 구성 요소입니다. DSAccess의 기본 기능은 다양한 디렉터리 관련 이벤트 및 작업에 대한 정보를 유지하는 것입니다. 예를 들어 DSAccess는 Active Directory 토폴로지를 검색하고 도메인 컨트롤러 및 글로벌 카탈로그 서버가 사용 가능하고 쿼리에 응답하는지 확인합니다. 또한 Microsoft Exchange 저장소 같은 내부 Exchange 구성 요소에 의해 만들어진 모든 디렉터리 쿼리는 받는 사람 확인, 구성 설정 조회 등과 같은 DSAccess를 통해 라우팅됩니다. 이러한 작업의 일부로, DSAccess는 같은 정보가 두 번 요청될 경우 Active Directory에 대해 다른 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 대신 DSAccess 캐시에서 이러한 정보를 검색할 수 있도록 일부 쿼리 결과를 메모리 내부 캐시에 유지합니다.

Exchange 2000 Server에서는 사용자 캐시 크기가 처음에는 25MB(메가바이트)로 설정됩니다. 대부분의 Exchange 서버에서 필요한 크기는 이보다 훨씬 작습니다. MaxMemoryConfig 설정은 DSAccess 구성 캐시에 사용되는 메모리 중 일부를 다시 확보하거나 다시 할당하는 데 사용되었습니다. 일반적으로 이 설정은 5MB로 구성되었습니다. Microsoft는 내부 테스트와 사용자 의견을 기초로 3MB가 Exchange Server 2003의 초기 설정으로 가장 알맞은 크기라는 사실을 알게 되었습니다. Exchange 2000 Server를 Exchange Server 2003으로 업그레이드할 때 모든 수동 설정이 유지됩니다. 이 Exchange 서버가 Exchange 2000 Server에서 Exchange Server 2003으로 업그레이드된 것이라면 MaxMemoryConfig의 값이 5MB 이상인지 확인해야 합니다.

MaxMemoryConfig 값은 DSAccess 캐시의 사용자 데이터 개체에 사용될 수 있는 최대 메모리 용량을 제어하는 MaxMemoryUser 값과 함께 사용되는 경우가 많습니다. 아래 절차에 따라 MaxMemoryConfig 값을 편집하거나 제거하는 경우 DSAccess 사용자 캐시 값이 기본값이 아닙니다.의 설명에 따라 MaxMemoryUser 값도 동일하게 편집 또는 제거해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

MaxMemoryConfig 레지스트리 값을 사용하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0을 탐색합니다.

  3. MaxMemoryConfig의 값을 검사하거나 편집합니다.
참고:
이 레지스트리 항목의 값은 킬로바이트(KB) 단위를 사용합니다. 값이 3000 이하로 설정되어 있으면 MaxMemoryConfig를 삭제하고 Exchange Server 2003 기본값으로 다시 설정되도록 Microsoft Exchange System Attendant 서비스를 다시 시작해야 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

DSAccess에 대한 자세한 내용은 Microsoft 기술 자료 문서 250570, "XADM: 디렉터리 서비스 서버 감지 및 DSAccess 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)을 참조하십시오.


DSAccess DisableNetLogonCheck 레지스트리 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 디렉터리 서비스 액세스(DSAccess)가 기본값이 아닌 ping 프로토콜을 사용하도록 구성되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\DisableNetLogonCheck

Exchange Server Analyzer는 DisableNetLogonCheck가 있고 0보다 큰 값으로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

DSAccess는 Active Directory® 디렉터리 서비스 토폴로지를 검색한 후 검색된 도메인 컨트롤러와 글로벌 카탈로그 서버가 사용하기에 적합한지 여부를 확인합니다. 초기 검색과 지속적으로 이어지는 재검색 기간 동안 DSAccess는 일련의 테스트를 실행하여 서버의 적합성을 확인합니다. 한 번 테스트할 때마다 디렉터리 서버로 원격 프로시저 호출(RPC)을 보내 디렉터리 서버의 일반적인 적합성을 테스트합니다. 대개 RPC 트래픽이 허용되지 않는 주변 네트워크 시나리오에서는 DSAccess RPC 요청이 실패합니다. 하지만 DSAccess는 실패할 때까지 RPC를 계속 보내기 때문에 오랜 시간이 걸릴 수 있습니다. 이러한 반복적인 확인은 Exchange Server를 실행하는 컴퓨터의 성능에 나쁜 영향을 줄 수 있습니다. 따라서 관리자가 주변 네트워크에 있는 Exchange Server에서 DisableNetLogonCheck 레지스트리 키를 추가하고 1 값으로 구성하는 경우가 많습니다.

기본 구성이 아니라는 메시지를 생성하는 Exchange Server가 RPC를 사용하지 않는 주변 네트워크에 있거나 DSAccess에서 이 적합성 테스트를 수행하지 않게 하려면 DisableNetLogonCheck 키를 1로 설정해야 합니다. 또는 DisableNetLogonCheck 키를 제거해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

DisableNetLogonCheck 키를 사용하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess를 탐색합니다.

  3. DisableNetLogonCheck 키를 두 번 클릭하고 DWORD 값을 1.로 설정합니다.

  4. 레지스트리 편집기를 닫습니다. 변경 내용을 적용하기 위해 서비스를 다시 시작하지 않아도 됩니다.

DisableNetLogonCheck 키를 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess를 탐색합니다.

  3. DisableNetLogonCheck라는 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다. 변경 내용을 적용하기 위해 서비스를 다시 시작하지 않아도 됩니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

DisableNetLogonCheck 레지스트리 키에 대한 자세한 내용은 기술 자료 문서 320228, "XGEN: The DisableNetLogonCheck Registry Value and How to Use It"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320228)을 참조하십시오.


DSAccess가 하드 코드되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 ConfigurationType 키 값을 확인할 때 ROOT\MicrosoftExchangeV2 네임스페이스에서 Exchange_DSAccessDC Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키 값이 0이면 기본 구성이 아니라는 메시지를 표시합니다.

ConfigurationType 속성은 인스턴스가 자동으로 감지된 도메인 컨트롤러를 설명하는지 아니면 수동으로 지정된 도메인 컨트롤러를 설명하는지 여부를 나타냅니다. Exchange Server의 DSAccess(디렉터리 서비스 액세스) 구성 요소는 동적으로 Active Directory® 디렉터리 서비스 토폴로지를 감지하고 자동으로 도메인 컨트롤러와 글로벌 카탈로그 서버를 찾습니다. Exchange Server 2000 서비스 팩 2 이상 버전이나 Exchange Server 2003을 실행 중인 컴퓨터에 있는 Exchange System Manager에는 DSAccess가 사용할 하드 코드된 Active Directory 서버 목록을 입력할 수 있는 기능이 있습니다.

DSAccess용 디렉터리 서버를 하드 코드해야 할 특별한 이유가 없으면 서버 목록을 제거하고 기본 설정인 자동 검색으로 되돌리십시오. 글로벌 카탈로그 장애 조치를 이용할 수 있는 자동 토폴로지 검색을 사용하는 것이 좋습니다.

기본 설정으로 되돌리려면 다음을 수행합니다.

  1. 시작, 프로그램, Microsoft Exchange, System Manager를 차례로 클릭합니다.

  2. 관리 그룹, <AdminGroupName>, 서버, <ServerName>을 확장합니다. 여기서 AdminGroupName은 Exchange 서버를 포함한 관리 그룹 이름이고 ServerName은 구성하려는 Exchange 서버 이름입니다.

  3. Exchange 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 디렉터리 액세스 탭을 클릭합니다.

  5. 표시 목록 상자에서 구성 도메인 컨트롤러를 선택합니다.

  6. 서버 자동 검색 확인란을 선택합니다.

  7. "수동으로 선택한 지정된 서버는 삭제됩니다. 계속하시겠습니까?"라는 Exchange System Manager 프롬프트가 나타나면 예를 클릭합니다.

  8. 표시 목록 상자에서 도메인 컨트롤러를 선택합니다.

  9. 서버 자동 검색 확인란을 선택합니다.

  10. "수동으로 선택한 지정된 서버는 삭제됩니다. 계속하시겠습니까?"라는 Exchange System Manager 프롬프트가 나타나면 예를 클릭합니다.

  11. 표시 목록 상자에서 글로벌 카탈로그 서버를 선택합니다.

  12. 서버 자동 검색 확인란을 선택합니다.

  13. "수동으로 선택한 지정된 서버는 삭제됩니다. 계속하시겠습니까?"라는 Exchange System Manager 프롬프트가 나타나면 예를 클릭합니다.

  14. 변경 내용을 저장하려면 확인을 클릭합니다.

DSAccess와 디렉터리 서비스 검색에 대한 자세한 내용은 Microsoft 기술 자료 문서 250570, "디렉터리 서비스 서버 감지 및 DSAccess 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)을 참조하십시오.


DSAccess가 LDAP 도메인 컨트롤러 요청에 포트 389을 사용하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 LDAPPort 키 값을 확인할 때 ROOT\MicrosoftExchangeV2 네임스페이스의 Exchange_DSAccessDC Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. LDAPPort 키 값이 389로 설정되어 있지 않으면 기본 구성이 아니라는 메시지를 표시합니다.

LDAPPort 키는 도메인 컨트롤러가 LDAP(Lightweight Directory Access Protocol) 요청을 수신하는 TCP 포트 번호를 나타냅니다. 관리자는 TCP 포트 636(도메인 컨트롤러) 또는 TCP 포트 3269(글로벌 카탈로그)의 SSL(Secure Sockets Layer)을 통해 LDAP을 보안 방법으로 사용할 수 있습니다.

기본적으로 글로벌 카탈로그 서버는 포트 3268을 통해 LDAP 통신을 수신합니다. 그러나 엔터프라이즈 인증 기관이 설치되어 있으면 모든 도메인 컨트롤러가 자동으로 인증서를 요청하고 TCP 포트 636을 통한 SSL 통신에 대해 LDAP을 지원할 수 있습니다. 또한 도메인 컨트롤러가 글로벌 카탈로그로 구성되어 있으면 TCP 포트 3269를 통한 SSL 통신에 대해서도 LDAP을 지원할 수 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 특별한 조치가 필요 없습니다. Exchange Server Analyzer는 기본 구성이 아님을 식별합니다.

DSAccess 및 LDAP 포트에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 247078, "HOWTO: Windows 2000 도메인 컨트롤러용 LDAP를 통해 SSL(Secure Socket Layer) 통신 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=247078)

  • 246228, "XGEN: DSAccess Profiles"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228)


DSAccess가 LDAP 글로벌 카탈로그 요청에 포트 3268을 사용하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 LDAPPort 키 값을 확인할 때 ROOT\MicrosoftExchangeV2 네임스페이스의 Exchange_DSAccessDC Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. LDAPPort 키 값이 3268로 설정되어 있지 않으면 기본 구성이 아니라는 메시지를 표시합니다.

LDAPPort 키는 도메인 컨트롤러가 LDAP(Lightweight Directory Access Protocol) 요청을 수신하는 TCP 포트 번호를 나타냅니다. 관리자는 TCP 포트 636(도메인 컨트롤러) 또는 TCP 포트 3269(글로벌 카탈로그)의 SSL(Secure Sockets Layer)에 대해 LDAP을 보안 방법으로 사용할 수 있습니다.

기본적으로 글로벌 카탈로그 서버는 포트 3268을 통해 LDAP 통신을 수신합니다. 그러나 엔터프라이즈 인증 기관이 설치되어 있으면 모든 도메인 컨트롤러가 자동으로 인증서를 요청하고 TCP 포트 636을 통한 SSL 통신에 대해 LDAP을 지원할 수 있습니다. 또한 도메인 컨트롤러가 글로벌 카탈로그로 구성되어 있으면 TCP 포트 3269를 통한 SSL 통신에 대해서도 LDAP을 지원할 수 있습니다.

DSAccess 및 LDAP 포트에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 247078, "HOWTO: Windows 2000 도메인 컨트롤러용 LDAP를 통해 SSL(Secure Socket Layer) 통신 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=247078)

  • 246228, "XGEN: DSAccess Profiles"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228)


DSAccess LdapKeepAliveSecs 레지스트리 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 DSAccess(디렉터리 서비스 액세스)가 LDAP(Lightweight Directory Access Protocol) Microsoft Windows® 운영 체제 구현(wLDAP) 프로토콜을 사용하도록 구성되었는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

Exchange Server Analyzer는 LdapKeepAliveSecs가 존재하고 0의 값으로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

DSAccess는 Active Directory® 디렉터리 서비스 토폴로지를 검색한 다음 검색된 작업 도메인 컨트롤러 및 글로벌 카탈로그 서버 목록이 사용하기 적합한지 확인합니다. 초기 검색과 지속적으로 이어지는 재검색 기간 동안 DSAccess는 일련의 테스트를 실행하여 서버의 적합성을 확인합니다. 기본적으로 적합성 테스트 중 하나는 ICMP(Internet Control Message Protocol)를 사용하여 도메인 컨트롤러를 ping함으로써 서버가 사용 가능한지 확인합니다.

사용 중인 네트워크의 일부 연결에서 ICMP를 지원하지 않을 수 있습니다. 이러한 상황의 특정한 예로 주변 네트워크에서는 Exchange 서버와 도메인 컨트롤러 간에 ICMP 연결이 허용되지 않습니다. 이러한 경우에 LdapKeepAliveSecs 레지스트리 매개 변수를 0으로 설정하면 DSAccess가 적합성 테스트에 wLDAP(Windows의 LDAP 구현)을 사용합니다.

기본 구성이 아니라는 메시지를 생성한 Exchange 서버가 RPC(원격 프로시저 호출)를 사용할 수 없는 주변 네트워크나 ICMP가 허용되지 않는 네트워크에 있는 경우 LdapKeepAliveSecs 키를 원래대로 구성하십시오. 그렇지 않으면 해당 키를 삭제해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

LdapKeepAliveSecs 키를 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess를 탐색합니다.

  3. LdapKeepAliveSecs라는 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다. 변경 내용을 적용하기 위해 서비스를 다시 시작하지 않아도 됩니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

LdapKeepAliveSecs 레지스트리 키에 대한 자세한 내용은 기술 자료 문서 320529, "XADM: Using DSAccess in a Perimeter Network Firewall Scenario Requires a Registry Key Setting"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529)을 참조하십시오.


DSAccess LdapKeepAliveSecs 레지스트리 매개 변수가 지원되지 않는 값으로 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 DSAccess(디렉터리 서비스 액세스)가 LDAP(Lightweight Directory Access Protocol) Microsoft Windows® 운영 체제 구현(wLDAP) 프로토콜을 사용하도록 구성되었는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

Exchange Server Analyzer는 LdapKeepAliveSecs가 존재하고 0 이외의 값으로 구성된 경우 경고를 표시합니다.

DSAccess는 Active Directory® 디렉터리 서비스 토폴로지를 검색한 다음 검색된 작업 도메인 컨트롤러 및 글로벌 카탈로그 서버 목록이 사용하기 적합한지 여부를 확인합니다. 초기 검색과 지속적으로 이어지는 재검색 기간 동안 DSAccess는 일련의 테스트를 실행하여 서버의 적합성을 확인합니다. 기본적으로 적합성 테스트 중 하나는 ICMP(Internet Control Message Protocol)를 사용하여 도메인 컨트롤러를 ping함으로써 서버가 사용 가능한지 확인합니다.

사용 중인 네트워크의 일부 연결에서 ICMP를 지원하지 않을 수 있습니다. 이러한 상황의 특정한 예로 주변 네트워크에서는 Exchange 서버와 도메인 컨트롤러 간에 ICMP 연결이 허용되지 않습니다. 이러한 경우에 LdapKeepAliveSecs 레지스트리 매개 변수를 0으로 설정하면 DSAccess가 적합성 테스트에 wLDAP을 사용합니다.

이 경고를 생성한 Exchange 서버가 RPC(원격 프로시저 호출)를 사용할 수 없는 주변 네트워크나 ICMP가 허용되지 않는 네트워크에 있는 경우 LdapKeepAliveSecs 키를 0으로 설정하십시오. 그렇지 않으면 해당 키를 삭제해야 합니다. 0이 아닌 모든 값이 이 레지스트리 키에 대해 지원되는 것은 아닙니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

LdapKeepAliveSecs 키를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess를 탐색합니다.

  3. LdapKeepAliveSecs 키를 두 번 클릭하고 DWORD 값을 0(영)으로 설정합니다.

  4. 레지스트리 편집기를 닫습니다. 변경 내용을 적용하기 위해 서비스를 다시 시작하지 않아도 됩니다.

LdapKeepAliveSecs 키를 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess를 탐색합니다.

  3. LdapKeepAliveSecs라는 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다. 변경 내용을 적용하기 위해 서비스를 다시 시작하지 않아도 됩니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

LdapKeepAliveSecs 레지스트리 키에 대한 자세한 내용은 기술 자료 문서 320529, "XADM: Using DSAccess in a Perimeter Network Firewall Scenario Requires a Registry Key Setting"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529)을 참조하십시오.


DSAccess PreloadBaseDNs 레지스트리 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 DSAccess(디렉터리 서비스 액세스)의 검색 미리 로드 기능이 기본 구성과 다르게 변경되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadBaseDNs

PreloadBaseDNs에 대한 기본값 데이터는 다음과 같습니다.

'"'

'"'

'"'

'"'

'"'

Exchange Server Analyzer는 PreloadBaseDNs 값이 기본값과 다르게 수정된 경우 경고 메시지를 표시합니다. 이 레지스트리 설정은 Microsoft 기술 지원 서비스에 문의한 후에만 변경해야 하기 때문에 Exchange Server Analyzer는 이 구성을 보고합니다.

DSAccess 캐시는 Exchange Server에 상주하고 Active Directory® 디렉터리 서비스로 검색된 구성 및 사용자 레코드를 수집합니다. DSAccess 캐시의 레코드는 개체의 고유 이름, GUID(글로벌 고유 식별자) 또는 범위로부터 구성된 키, BaseDN 및 Active Directory에서 이 개체를 찾는 데 사용된 검색 필터를 사용하여 액세스됩니다. 동일한 고유 이름, GUID 또는 키를 사용하는 후속 액세스의 경우 캐시에 있는 레코드를 찾습니다. 따라서 동일한 검색에 대한 Active Directory의 불필요한 로드를 방지할 수 있습니다. 그러나 검색 필터가 캐시에 포함되어 있는 검색 필터와 다른 경우 DSAccess가 사용자 개체에 설정된 동일한 특성을 요청해도 DSAccess는 Active Directory의 로드를 방지하지 못합니다.

검색 미리 로드는 동일한 사용자 개체에서 다양한 검색 필터가 실행된 경우 발생할 수 있는 여러 Active Directory 검색 문제를 방지하는 방법입니다. 검색 항목이 해당 범위, BaseDN 및 검색 필터에 의해 구성되어 있는 이전에 언급한 키 구성에 따라 검색 미리 로드가 작동합니다.

DSAccess 검색 미리 로드 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 250572, "XCON: Preloading and the DSAccess Cache"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572)를 참조하십시오.


DSAccess PreloadFilters 레지스트리 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 DSAccess(디렉터리 서비스 액세스)의 검색 미리 로드 기능이 기본 구성과 다르게 변경되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadFilters

PreloadFilters에 대한 기본값 데이터는 다음과 같습니다.

(&(|(msExchMasterAccountSID=%)(objectSid=%))(!(objectClass=foreignSecurityPrincipal)))(|(msExchMailboxGUID=%)(objectGUID=%))(legacyExchangeDN=%)(msExchMailboxGUID=%)(&(proxyAddresses=%)(|(objectClass=user)(objectClass=contact)))

Exchange Server Analyzer는 PreloadFilters 값이 기본값과 다르게 수정된 경우 기본 구성이 아니라는 메시지를 표시합니다. PreloadFilters 레지스트리 설정은 Microsoft 기술 지원 서비스에 문의한 후에만 변경해야 하기 때문에 Exchange Server Analyzer는 이 구성을 보고합니다.

DSAccess 캐시는 Exchange Server에 상주하고 Active Directory® 디렉터리 서비스로 검색된 구성 및 사용자 레코드를 수집합니다. 캐시의 레코드는 개체의 고유 이름, GUID(글로벌 고유 식별자) 또는 범위로부터 구성된 키, BaseDN 및 Active Directory에서 이 개체를 찾는 데 사용된 검색 필터를 사용하여 액세스됩니다. 동일한 고유 이름, GUID 또는 키를 사용하는 후속 액세스의 경우 캐시에 있는 레코드를 찾습니다. 따라서 동일한 검색에 대한 Active Directory의 불필요한 로드를 방지할 수 있습니다. 그러나 검색 필터가 캐시에 포함되어 있는 검색 필터와 다른 경우 DSAccess가 사용자 개체에 설정된 동일한 특성을 요청해도 DSAccess는 Active Directory의 로드를 방지하지 못합니다.

검색 미리 로드는 여러 검색 필터가 동일한 사용자 개체에서 수행될 때 발생될 수 있는 다중 Active Directory 검색 문제를 방지하는 방법입니다. 검색 항목이 해당 범위, BaseDN 및 검색 필터에 의해 구성되어 있는 이전에 언급한 키 구성에 따라 검색 미리 로드가 작동합니다.

DSAccess 검색 미리 로드 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 250572, "XCON: Preloading and the DSAccess Cache"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572)를 참조하십시오.


DSAccess에서 이 Active Directory 서버가 작동하지 않는 것으로 보고됩니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 IsUp 키 값을 확인할 때 ROOT\MicrosoftExchangeV2 네임스페이스의 Exchange_DSAccessDC Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. IsUp 키가 False로 설정되어 있으면 오류가 표시됩니다.

IsUp 키가 True로 설정되어 있으면 Exchange 서버가 마지막으로 연결을 시도했을 때 도메인 컨트롤러가 응답했음을 나타냅니다. IsUp이 False로 설정되어 있으면 도메인 컨트롤러가 연결 시도에 대해 응답하지 않았음을 나타냅니다.

응답하지 않았다고 해서 도메인 컨트롤러 또는 글로벌 카탈로그가 반드시 중지되었거나 올바르게 작동하지 않는 것은 아닙니다. Exchange 서버와 도메인 컨트롤러 간의 네트워크 연결 문제로 인해 이 오류가 발생하는 경우도 있습니다. 또한 적절한 포트가 열려 있지 않은 Exchange 서버와 도메인 컨트롤러 사이의 방화벽 때문에 이러한 오류가 발생할 수도 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. PING을 수행하여 도메인 컨트롤러가 실행 중인지 확인합니다.

  2. 방화벽이 설치되어 있는 경우 올바른 포트가 열려 있는지 확인합니다. PING 패킷을 차단하도록 방화벽이 구성되어 있을 수도 있다는 점도 유의해야 합니다. 특정 포트를 열거나 닫는 방법에 대한 자세한 내용은 방화벽 설명서를 참조하십시오.

  3. 제대로 작동하지 않는 스위치, 라우터, 케이블 등 다른 네트워크 관련 문제가 없는지 확인합니다.

DSAccess와 디렉터리 서비스 검색에 대한 자세한 내용은 Microsoft 기술 자료 문서 250570, "디렉터리 서비스 서버 감지 및 DSAccess 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)을 참조하십시오.

네트워크 연결 문제 해결에 대한 자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.


DSAccess에서 이 Active Directory 서버가 나머지 토폴로지와 동기화되어 있지 않은 것으로 보고됩니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-21

Microsoft® Exchange Server Analyzer Tool은 IsInSync 키 값을 확인할 때 ROOT\MicrosoftExchangeV2 네임스페이스의 Exchange_DSAccessDC Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. IsInSync 값이 False이면 오류가 표시됩니다.

IsInSync 키는 도메인 컨트롤러가 글로벌 카탈로그 서버 및 구성 도메인 컨트롤러와 동기화되어 있는지 여부를 나타냅니다. True 값은 서버가 동기화되어 있음을 나타내고 False 값은 도메인 컨트롤러가 동기화되어 있지 않음을 나타냅니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 도메인 컨트롤러 또는 글로벌 컨트롤러의 시간을 검토하십시오. 시간 서비스가 시작되었는지 확인하고 수동으로 Exchange 서버의 시간을 글로벌 카탈로그 서버 또는 구성 도메인 컨트롤러와 동기화합니다.

  2. 복제 모니터 도구(Replmon)를 사용하여 도메인 컨트롤러 복제 문제가 있는지 확인하고 필요한 경우 문제를 해결합니다. Replmon은 Windows Server CD의 Support\Tools 폴더에 있는 Microsoft Windows 2000 Server 및 Microsoft Windows Server™ 2003 지원 도구에 포함되어 있습니다.

DSAccess 및 디렉터리 서비스 검색에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 316300, "Event ID 2080 and MSExchangeDSAccess"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=316300)

  • 250570, "디렉터리 서비스 서버 감지 및 DSAccess 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)


DSAccess에서 이 Active Directory 서버가 LDAP 요청에 응답하는 데 2초 이상 걸린다고 보고합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 ROOT\MicrosoftExchangeV2 네임스페이스에서 Exchange_DSAccessDC Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 IsFast 키 및 IsUp 키 값을 확인합니다. IsUp 키 값이 True이면 Exchange Server의 디렉터리 서비스 액세스(DSAccess) 구성 요소에서 사용하는 디렉터리 서버가 네트워크에 연결되어 있고 응답하고 있음을 나타냅니다. False 값은 디렉터리 서버가 응답하고 있지 않음을 나타냅니다. IsFast 값이 True이면 이 디렉터리 서버의 응답 시간이 2초 미만임을 나타냅니다. False 값은 응답 시간이 2초 이상임을 나타냅니다. IsUp 값은 True이지만 IsFast 값이 False이면 오류가 표시됩니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 도메인 컨트롤러와 글로벌 카탈로그의 로드를 검사합니다. 도메인 컨트롤러와 글로벌 카탈로그가 오버로드되면 LDAP(Lightweight Directory Access Protocol) 호출에 대한 응답 속도가 느려질 수 있습니다.

  2. 최적의 성능을 위해서는 로컬 Active Directory® 디렉터리 서비스 사이트에 글로벌 카탈로그가 두 개 이상 있어야 합니다.

DSAccess와 디렉터리 서비스 검색에 대한 자세한 내용은 Microsoft 기술 자료 문서 250570, "디렉터리 서비스 서버 감지 및 DSAccess 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)을 참조하십시오.


DSAccess TopoCreateTimeoutSecs 레지스트리 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 DSAccess(Directory Service Access) 초기화 시간 제한 기본값이 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess\TopoCreateTimeoutSecs

Exchange Server Analyzer는 TopoCreateTimeoutSecs 키가 있고 값이 0보다 큰 값으로 구성되었음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다.

시작할 때, DSAccess는 검색 프로세스를 사용하여 Active Directory® 디렉터리 서비스 토폴로지를 확인하고 도메인 컨트롤러와 글로벌 카탈로그 서버의 가용성을 평가합니다. 시작이 완료되면 이후 15분마다 DSAccess는 거의 동일한 프로세스를 사용하여 토폴로지를 다시 검색하고 서버 가용성에 변화가 있는지 확인합니다. 기본적으로 DSAccess 초기화는 시스템을 시작하는 동안 1분 내에 완료되어야 합니다. 그렇지 않으면 DSAccess가 중지됩니다. 일반적으로 1분은 DSAccess가 초기화되기에 충분한 시간입니다.

참고:
DSAccess에서 사용되는 디렉터리 서버를 하드 코드한 경우, DSAccess는 검색 프로세스를 무시하고 서버의 적합성만 확인합니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess를 탐색합니다.

  3. TopoCreateTimeoutSecs라는 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

이 레지스트리 키가 있는 경우 네트워크 토폴로지를 평가해야 합니다. 조직에서 추가 DSAccess 초기화 시간이 필요하다면 디자인이나 네트워크에 문제가 있을 수 있습니다. 최적의 Exchange 작업을 위해서는 특히 글로벌 카탈로그 서버 같은 도메인 컨트롤러에 빠르고 안정적으로 액세스해야 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

디렉터리 액세스에 대한 자세한 내용은 Understanding and Troubleshooting Directory Access(http://go.microsoft.com/fwlink/?LinkId=39012)를 참조하십시오.


DSAcess 사용자 캐시가 꽉 찼습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-20

Microsoft® Exchange Server Analyzer Tool은 Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 TotalEntriesMemoryUserData 키의 현재 값을 확인합니다. TotalEntriesMemoryUserData 값이 DSAccess(Directory Service Access) 사용자 캐시의 총 크기(MaxMemoryUser)와 같으면 Exchange Server Analyzer Tool에서 경고를 표시합니다.

DSAccess는 Exchange 2000 Server 및 Exchange Server 2003의 내부 구성 요소로 모든 Exchange 구성 요소의 Active Directory® 디렉터리 서비스 액세스 방법을 관리합니다. DSAccess의 기본 기능은 다양한 디렉터리 관련 이벤트 및 작업에 대한 정보를 유지하는 것입니다. 예를 들어 DSAccess는 Active Directory 토폴로지를 검색하고 도메인 컨트롤러 및 글로벌 카탈로그 서버가 사용 가능하고 쿼리에 응답하는지 확인합니다. 또한 Exchange 저장소 같은 내부 Exchange 구성 요소에 의해 만들어진 모든 디렉터리 쿼리는 받는 사람 확인, 구성 설정 조회 등과 같은 DSAccess를 통해 라우팅됩니다. 이러한 작업의 일부로, DSAccess는 같은 정보가 두 번 요청될 경우 Active Directory에 대해 다른 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 대신 DSAccess 캐시에서 이러한 정보를 검색할 수 있도록 일부 쿼리 결과를 메모리 내부 캐시에 유지합니다.

Exchange 2000 Server에서 사용자 캐시는 처음에 25MB로 설정됩니다. 많은 수의 Microsoft Office Outlook® 2003 클라이언트를 서비스하는 Exchange 2000 Server 컴퓨터에는 이 기본 DSAccess 사용자 캐시 크기로는 충분하지 않습니다. 성능을 향상시키려면 Exchange Server 2003에서 사용자 캐시 기본값이 최적화되도록 140MB로 설정해야 합니다.

DSAccess 사용자 캐시의 기본 설정 최대 크기 값은 Exchange 2000 Server의 25MB에서 Exchange Server 2003의 140MB로 증가되었기 때문에 이 경고 메시지는 Exchange 2000 Server 컴퓨터에서 주로 발생합니다. Exchange 버전에 관계없이 이 경고 메시지가 발생한 경우 가능한 빨리 문제를 수정해야 합니다. 시스템에 DSAccess 캐시가 부족한 경우 로컬 메시지 전달 및 주소록 이름 확인 속도가 느려질 수 있습니다.

사용자 캐시의 최대 크기는 Exchange 서버의 레지스트리 항목을 사용하여 수동으로 구성할 수 있습니다. MaxMemoryUser는 Exchange 2000 Server 레지스트리 매개 변수로, Exchange 관리자는 이 매개 변수를 통해 DSAccess 캐시의 사용자 데이터 개체에서 소비할 수 있는 최대 메모리 양을 제어합니다.

MaxMemoryUser 값은 DSAccess 캐시의 구성 데이터 개체가 소비할 수 있는 최대 메모리 양을 관리하는 MaxMemoryConfig 값으로 사용되기도 합니다. 다음 절차에 설명된 대로 MaxMemoryUser 값을 편집 또는 제거하는 경우 MaxMemoryConfig 값도 DSAccess 구성 캐시 값이 기본값이 아닙니다.에 설명된 대로 이와 유사하게 편집 또는 제거해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Exchange 2000 Server 컴퓨터에서 이 문제를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0을 탐색합니다.

  3. MaxMemoryUser 값을 증가시킵니다. 이 DWORD 값이 없으면 해당 값을 수동으로 값을 만들 수 있습니다. 이 레지스트리 항목에 대한 값 데이터는 킬로바이트(KB) 단위이므로 십진수 140000은 140MB와 같습니다.

  4. MaxMemoryConfig 값을 감소시킵니다. 이 DWORD 값이 없으면 해당 값을 수동으로 값을 만들 수 있습니다. 이 레지스트리 항목의 값 데이터는 킬로바이트(KB) 단위도 사용합니다. 값으로 십진수 5000(5MB)이 권장됩니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange System Attendant를 다시 시작하여 변경 내용을 적용합니다.

Exchange Server 2003 컴퓨터에서 이 문제를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0을 탐색합니다.

  3. MaxMemoryUser가 140MB 미만으로 구성되어 있는 경우 해당 MaxMemoryUser 값을 삭제합니다. MaxMemoryUser가 있고 140MB 이상으로 구성되어 있는 경우 값을 10%만큼 증가시킵니다.

  4. MaxMemoryConfig가 있는 경우 삭제합니다.

  5. 레지스트리 편집기를 닫고 Exchange System Attendant를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

DSAccess에 대한 자세한 내용은 기술 자료 문서 250570, "디렉터리 서비스 서버 감지 및 DSAccess 사용"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570)을 참조하십시오.


DSAccess 사용자 캐시 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 디렉터리 서비스 액세스(DSAccess) 사용자 개체 캐시 크기가 기본값과 다르게 수정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryUser

Exchange Server Analyzer는 MaxMemoryUser 가 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

MaxMemoryUser는 Exchange 서버 레지스트리 매개 변수로 Exchange 관리자가 이를 사용하여 DSAccess 캐시의 사용자 데이터 개체가 최대로 소비할 수 있는 메모리 양을 제어할 수 있습니다.

DSAccess는 Exchange 2000 Server 및 Exchange Server 2003의 내부 구성 요소로 모든 Exchange 구성 요소의 Active Directory® 디렉터리 서비스 액세스 방법을 관리합니다. DSAccess의 기본 기능은 다양한 디렉터리 관련 이벤트 및 작업에 대한 정보를 유지하는 것입니다. 예를 들어 DSAccess는 Active Directory 토폴로지를 검색하고 도메인 컨트롤러 및 글로벌 카탈로그 서버가 사용 가능하고 쿼리에 응답하는지 확인합니다. 또한 Exchange 저장소 같은 내부 Exchange 구성 요소에 의해 만들어진 모든 디렉터리 쿼리는 받는 사람 확인, 구성 설정 조회 등과 같은 DSAccess를 통해 라우팅됩니다. 이러한 작업의 일부로, DSAccess는 같은 정보가 두 번 요청될 경우 Active Directory에 대해 다른 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 대신 DSAccess 캐시에서 이러한 정보를 검색할 수 있도록 일부 쿼리 결과를 메모리 내부 캐시에 유지합니다.

Exchange 2000 Server에서는 사용자 캐시 크기가 처음에는 25MB로 설정됩니다. 많은 수의 Microsoft Office Outlook® 2003 클라이언트를 서비스하는 Exchange 2000 Server 컴퓨터에는 이 기본 DSAccess 사용자 캐시 크기로는 충분하지 않습니다. DSAccess 캐시 크기가 작은 시스템에서는 로컬 메시지 배달 및 주소록 이름 확인 속도가 적절한 속도보다 느릴 수 있습니다.

Exchange Server 2003에서는 성능을 향상시키기 위해 사용자 캐시 기본값이 최적화되었고 140MB로 설정되었습니다. Exchange 2000 Server를 Exchange Server 2003으로 업그레이드할 때 모든 수동 설정이 유지됩니다. 이 Exchange 서버를 Exchange 2000 Server에서 Exchange Server 2003으로 업그레이드한 경우 MaxMemoryUser 값이 140MB 이상인지 확인해야 합니다.

MaxMemoryUser 값은 DSAccess 캐시의 구성 데이터 개체가 최대로 소비할 수 있는 메모리 양을 제어하는 MaxMemoryConfig 값과 함께 사용됩니다. 아래 절차에 따라 MaxMemoryUser 값을 편집하거나 제거하는 경우 DSAccess 구성 캐시 값이 기본값이 아닙니다.의 설명에 따라 MaxMemoryConfig 값도 동일하게 편집하거나 제거해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

MaxMemoryUser 레지스트리 키를 사용하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0을 탐색합니다.

  3. MaxMemoryUser 값을 검사하거나 편집합니다.

    이 레지스트리 항목의 값은 킬로바이트(KB) 단위를 사용합니다. 값을 140000 이하로 설정한 경우에는 MaxMemoryUser를 삭제하고 Microsoft Exchange System Attendant를 다시 시작하여 기본적으로 Exchange Server 2003 설정을 사용하도록 해야 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

DSAccess에 대한 자세한 내용은 기술 자료 문서 250570, "XADM: 디렉터리 서비스 서버 감지 및 DSAccess 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)을 참조하십시오.


DSProxy RFR 서비스를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 디렉터리 서비스 프록시 조회(DSProxy RFR) 서비스가 비활성화되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\MSExchangeSA\Parameters\ No RFR Service

Exchange Server Analyzer는 No RFR Service가 존재하며 1로 설정되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange 2000 Server 및 Exchange Server 2003의 DSProxy 구성 요소는 Microsoft Outlook® 98 및 Outlook 97 클라이언트의 도메인 컨트롤러 또는 글로벌 카탈로그에 대한 디렉터리 액세스를 제공합니다. Outlook 2000 SR2(서비스 릴리스 2) 이상 버전은 글로벌 카탈로그 서버를 직접 쿼리할 수 있습니다.

Outlook 2000 SR2 이상 버전의 클라이언트가 처음으로 Exchange 2000 서버 이상 버전의 컴퓨터에 연결될 때 홈 Exchange 서버에서 디렉터리 서비스를 찾습니다. 처음에 Outlook은 첫 번째 세션을 위한 DSProxy 프로세스를 통과합니다. 클라이언트가 DSProxy 서비스에 연결되면(사용 가능한 모든 전송 프로토콜 시도) 조회가 클라이언트로 다시 전달되어 모든 후속 디렉터리 요청이 글로벌 카탈로그 서버로 이동해야 함을 알려 줍니다. Outlook은 레지스트리의 MAPI 프로필에 조회를 설정합니다. DSProxy 조회 메커니즘은 Exchange 서버의 로드를 줄이고 주소록 검색 대기 시간을 줄여 줍니다. 프로필에 명시적인 서버 이름을 입력한 경우 해당 Active Directory® 디렉터리 서비스 서버에 오류가 발생하면 Outlook을 다시 시작해야 합니다. 이 경우 Exchange 서버는 Outlook에 새 조회를 보냅니다.

일부 경우에 최신 버전을 비롯한 Outlook 클라이언트가 조회 과정 없이 항상 DSProxy 과정을 거치도록 할 수 있습니다. 예를 들어 Outlook 및 Exchange 서버 간에 방화벽이 존재할 경우 이러한 구성이 필요할 수 있습니다.

No RFR Service 레지스트리 항목을 추가하고 1로 설정하면 Exchange 서버는 직접 통신을 위해 해당 글로벌 카탈로그 서버에 클라이언트를 조회하는 대신 Outlook 클라이언트용 프록시로 작동합니다. No RFR Service 레지스트리 매개 변수를 1로 설정하면 Exchange 서버가 Active Directory와 직접 통신할 수 있는 Outlook 2000 SR2 이상의 클라이언트를 포함하는 모든 Outlook 클라이언트용 프록시로 작동하게 되므로 Exchange 서버의 성능이 저하됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

DSProxy RFR 서비스를 활성화하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. No RFR Service라는 새 DWORD 값을 만듭니다.

  4. No RFR Service 값을 1로 설정합니다.

DSProxy RFR 서비스를 비활성화하려면 No RFR Service 레지스트리 값을 삭제하거나 0으로 설정합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Outlook 2000 SR-2 이상 클라이언트가 Active Directory와 상호 작용하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 256976, "XCCC: Outlook 2000이 Active Directory에 액세스하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914)을 참조하십시오.

MAPI 클라이언트가 Active Directory에 액세스하는 방법에 대한 자세한 내용은 기술 자료 문서 256976, "XCLN: MAPI 클라이언트가 Active Directory에 액세스하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976)을 참조하십시오.


EMSMTA.EXE 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


EnableAuthEpResolution 레지스트리 키가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 RPC(원격 프로시저 호출) 인터페이스 제한 레지스트리 키가 설정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

Exchange Server Analyzer는 EnableAuthEpResolution 레지스트리 값이 충족되는 경우 기본 구성이 아니라는 메시지를 표시합니다.

RPC 인터페이스 제한을 사용하면 네트워크 보호가 강화되어 네트워크를 통한 공격에 대한 시스템의 취약성이 줄어듭니다.

Microsoft Windows® XP에서는 RPC 인터페이스가 기본적으로 등록되어 있고 원격 및 익명으로 사용 가능하여 공격 받을 가능성이 큽니다. RPC는 그러한 인터페이스를 등록하여 동적 종점을 사용하는 호출에 대해 종점을 확인할 수 있어야 합니다. RestrictRemoteClients 레지스트리 키는 시스템에서 모든 RPC 인터페이스의 동작을 수정합니다. 기본적으로 RestrictRemoteClients 레지스트리 키는 몇 가지 예외를 제외하면 시스템에서 RPC 인터페이스에 대한 원격 익명 액세스를 차단합니다. 따라서 RPC 종점 매퍼 인터페이스를 더 이상 익명으로 사용할 수 없습니다.

동적 종점을 사용하여 호출을 시도하는 RPC 클라이언트는 연결해야 하는 동적 종점을 확인할 때 맨 먼저 서버에서 RPC 종점 매퍼를 쿼리합니다. RPC 클라이언트 호출이 RPC 보안을 사용하여 수행되는 경우에도 이 쿼리는 익명으로 수행됩니다. 기본 RestrictRemoteClients 기능이 시스템에서 RPC 인터페이스에 대한 원격 익명 액세스를 차단하기 때문에 기본적으로 Microsoft Windows XP 서비스 팩 2에서 RPC 종점 매퍼 인터페이스에 대한 익명 호출이 실패합니다. 이러한 RPC 인터페이스 제한으로 인해 RPC 클라이언트 런타임이 종점 매퍼에 대해 인증된 쿼리를 수행하도록 수정됩니다. 이 RPC 인터페이스 제한은 Windows XP 서비스 팩 2의 기본 동작입니다. 그런 다음 RPC 클라이언트 런타임은 이전에는 NTLM이라고 했던 Windows 통합 인증을 사용하여 종점 매퍼를 인증합니다. 실제 RPC 클라이언트 호출이 이러한 종류의 인증을 사용하는 경우 Windows 통합 인증이 발생합니다. 다음 조건이 충족되는 경우 기본 구성이 아니라는 메시지가 표시됩니다.

  • RPC 레지스트리 키 및 EnableAuthEpResolution 값이 만들어졌습니다.

  • EnableAuthEpResolution 레지스트리 값이 0으로 설정되었습니다.

Windows XP 서비스 팩 2에서 RPC 서비스를 변경하는 방법에 대한 자세한 내용은 "RPC 인터페이스 제한"(http://go.microsoft.com/fwlink/?LinkId=47371)을 참조하십시오.


Epoxy Client Out Queue Length (IMAP)가 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Epoxy 성능 개체의 Client Out Queue Length (IMAP) 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Client Out Queue Length (IMAP) 성능 카운터는 큐에서 Inetinfo.exe 프로세스가 Store.exe 프로세스에 보낸 IMAP4 메시지를 포함한 메시지 수를 나타냅니다. 큐는 항상 50개 미만이어야 합니다. Exchange Server Analyzer는 샘플 시간 동안 Client Out Queue Length (IMAP) 카운터가 최고값 50을 초과한 경우 오류를 표시합니다.

Epoxy(ExIPC)는 Microsoft Internet Information Services(IIS)(Inetinfo.exe) 및 Microsoft Exchange Information Store 서비스(Store.exe)의 프로세스에서 데이터를 빠르게 주고 받을 수 있는 공유 메모리 메커니즘입니다. 이 메커니즘을 기반으로 Inetinfo.exe 프로세스와 Store.exe 프로세스 사이에 양방향 프로세스 간 통신이 허용됩니다.

참고:
Inetinfo.exe는 WebDAV, IMAP4, NNTP, POP3 및 SMTP와 같은 인터넷 프로토콜에서 요청을 받습니다.

이 메모리는 Active Directory® 정보를 캐시하는 Exchange 구성 요소인 DSAccess에서도 사용됩니다.

이 오류는 이 큐를 증가시키고 있는 Store.exe 프로세스 또는 Store.exe 프로세스가 종속된 리소스에 성능 문제가 있음을 나타냅니다. 이로 인해 서버 응답 시간이 증가할 수 있습니다.

이 문제를 해결하려면 "추가 정보" 섹션에서 참조하는 리소스를 사용하여 Store.exe 프로세스 또는 관련 리소스에 성능 지체가 있는지 확인합니다. 이 지체 현상은 낮은 디스크 성능 또는 높은 CPU 사용률과 관련되어 있을 수 있습니다.

추가 정보

  • Epoxy에서 증가하는 큐를 확인하는 방법에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Identifying Rising Queues in Epoxy"를 참조하십시오.

  • 프로세서 지체에 대한 자세한 내용은 프로세서 지체를 참조하십시오.

  • 디스크 지체에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

  • 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


Epoxy Client Out Queue Length (POP)가 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Epoxy 성능 개체의 Client Out Queue Length (POP) 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Client Out Queue Length (POP) 성능 카운터는 큐에서 Inetinfo.exe 프로세스가 Store.exe 프로세스에 보낸 POP3 메시지를 포함한 메시지 수를 나타냅니다. 큐는 항상 50개 미만이어야 합니다. Exchange Server Analyzer는 5분 동안 5초마다 이 카운터에서 샘플을 검색합니다. Exchange Server Analyzer는 샘플 시간 동안 Client Out Queue Length (POP) 카운터가 최고값 50을 초과한 경우 오류를 표시합니다.

Epoxy(ExIPC)는 Microsoft Internet Information Services(IIS)(Inetinfo.exe) 및 Microsoft Exchange Information Store 서비스(Store.exe)의 프로세스에서 데이터를 빠르게 주고 받을 수 있는 공유 메모리 메커니즘입니다. 이 메커니즘을 기반으로 Inetinfo.exe 프로세스와 Store.exe 프로세스 사이에 양방향 프로세스 간 통신이 허용됩니다.

참고:
Inetinfo.exe는 WebDAV, IMAP4, NNTP, POP3 및 SMTP와 같은 인터넷 프로토콜에서 요청을 받습니다.

이 메모리는 Active Directory® 정보를 캐시하는 Exchange 구성 요소인 DSAccess에서도 사용됩니다.

이 오류는 이 큐를 증가시키고 있는 Store.exe 프로세스 또는 Store.exe 프로세스가 종속된 리소스에 성능 문제가 있음을 나타냅니다. 이로 인해 서버 응답 시간이 증가할 수 있습니다.

이 문제를 해결하려면 "추가 정보" 섹션에서 참조하는 리소스를 사용하여 Store.exe 프로세스 또는 관련 리소스에 성능 지체가 있는지 확인합니다. 이 지체 현상은 낮은 디스크 성능 또는 높은 CPU 사용률과 관련되어 있을 수 있습니다.

추가 정보

  • Epoxy에서 증가하는 큐를 확인하는 방법에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Identifying Rising Queues in Epoxy"를 참조하십시오.

  • 프로세서 지체에 대한 자세한 내용은 프로세서 지체를 참조하십시오.

  • 디스크 지체에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

  • 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


EPOXY.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 해결하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


Epoxy 성능 모니터를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Epoxy 성능 개체의 Client Out Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. 카운터에서 올바른 데이터가 반환되지 않으면 Exchange Server Analyzer는 기본 메시지를 표시합니다.

다음과 같은 상황에서는 성능 데이터 수집 엔진에서 올바른 데이터가 반환되지 않습니다.

  • Epoxy 성능 모니터 개체를 사용할 수 없게 설정되어 있습니다.

  • Epoxy 성능 모니터 개체가 없거나 손상되었습니다.

  • 성능 개체에 액세스할 수 있는 적절한 권한이 Exchange Server Analyzer에 없습니다.

맨 앞의 두 가지 상황은 확장 가능한 특정 카운터가 레지스트리를 손상시키거나 Microsoft WMI(Windows® Management Instrumentation) 기반 프로그램에서 레지스트리를 수정하는 경우에 발생할 수 있습니다. 다음 절차에서는 맨 앞의 두 가지 상황을 해결하는 방법을 설명합니다. 해당 절차를 수행하기 전에 Exchange Server Analyzer에 적절한 권한이 있는지 확인합니다. Exchange Server Analyzer를 실행하는 데 필요한 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말을 참조하십시오. 도움말을 보려면 Exchange Server Analyzer를 열고 F1 키를 누르십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Epoxy 성능 개체를 사용하는지 확인합니다.

    1. Extensible Performance Counter List 도구(Exctrlst.exe)를 다운로드하고 설치합니다. 웹사이트 "Exctrlst.exe: Extensible Performance Counter List"(http://go.microsoft.com/fwlink/?LinkId=34436)에서 Exctrlst.exe를 다운로드할 수 있습니다.

    2. Exctrlst.exe를 열고 Sort Order와 Service를 차례로 클릭합니다.

    3. 성능 개체가 보고하는 서비스를 찾아 Performance Counters Enabled 확인란이 선택되었는지 확인합니다.

      Performance Counters Enabled 확인란이 선택되지 않았으면 이 확인란을 선택한 다음 성능 카운터에 연결된 서비스를 다시 시작하여 성능 카운터가 작동하는지 확인합니다. 성능 카운터가 작동하지 않거나 Performance Counters Enabled 확인란이 이미 선택되어 있으면 2단계로 넘어갑니다.

  2. Microsoft 기술 자료 문서 300956, "성능 카운터 라이브러리 값을 수동으로 다시 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956)에 지정된 대로 누락되거나 손상된 성능 카운터를 다시 빌드합니다.

  3. 이 기술 자료 문서에 따라 수행해도 문제가 해결되지 않으면 Exchange Server를 복구 모드로 다시 설치한 다음 최신 Exchange Server 서비스 팩을 적용해야 합니다.


Epoxy Store Out Queue Length (IMAP)가 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Epoxy 성능 개체의 Store Out Queue Length (IMAP) 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Store Out Queue Length (IMAP) 성능 카운터는 큐에서 Store.exe 프로세스가 Inetinfo.exe 프로세스에 보낸 IMAP4 메시지를 포함한 메시지 수를 나타냅니다. 큐는 항상 50개 미만이어야 합니다. Exchange Server Analyzer는 5분 동안 5초마다 이 카운터에서 샘플을 검색합니다. Exchange Server Analyzer는 샘플 시간 동안 Store Out Queue Length (IMAP) 카운터가 최고값 50을 초과한 경우 오류를 표시합니다.

Epoxy(ExIPC)는 Microsoft Internet Information Services(IIS)(Inetinfo.exe) 및 Microsoft Exchange Information Store 서비스(Store.exe)의 프로세스가 데이터를 빠르게 주고 받을 수 있게 하는 공유 메모리 메커니즘입니다. 이 메커니즘을 기반으로 Inetinfo.exe 프로세스와 Store.exe 프로세스 사이에 양방향 프로세스 간 통신이 허용됩니다.

참고:
Inetinfo.exe는 WebDAV, IMAP4, NNTP, POP3 및 SMTP와 같은 인터넷 프로토콜에서 요청을 받습니다.

이 메모리는 Active Directory® 정보를 캐시하는 Exchange 구성 요소인 DSAccess에서도 사용됩니다.

이러한 오류는 Inetinfo.exe 프로세스 또는 Inetinfo.exe 프로세스가 종속된 리소스에 이 큐를 증가시키는 성능 문제가 있음을 나타냅니다. 이로 인해 서버 응답 시간이 증가할 수 있습니다. 따라서 서버의 응답이 지연됩니다.

이 문제를 해결하려면 "추가 정보" 섹션에 참조된 리소스를 사용하여 Inetinfo.exe 또는 관련 리소스에 성능 지체가 있는지 확인합니다. 이 지체 현상은 낮은 디스크 성능 또는 높은 CPU 사용률과 관련되어 있을 수 있습니다.

추가 정보

  • Epoxy에서 증가하는 큐를 확인하는 방법에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Identifying Rising Queues in Epoxy"를 참조하십시오.

  • 프로세서 지체에 대한 자세한 내용은 프로세서 지체를 참조하십시오.

  • 디스크 지체에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

  • 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


Epoxy Store Out Queue Length (POP)가 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Epoxy 성능 개체의 Store Out Queue Length (POP) 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Store Out Queue Length (POP) 성능 카운터는 큐에서 Store.exe 프로세스가 Inetinfo.exe 프로세스에 보낸 POP3 메시지를 포함한 메시지 수를 나타냅니다. 큐는 항상 50개 미만이어야 합니다. Exchange Server Analyzer는 5분 동안 5초마다 이 카운터의 샘플을 검색합니다. Exchange Server Analyzer는 샘플 시간 동안 Store Out Queue Length (POP) 카운터가 최고값 50을 초과한 경우 오류를 표시합니다.

Epoxy(ExIPC)는 Microsoft Internet Information Services(IIS)(Inetinfo.exe) 및 Microsoft Exchange Information Store 서비스(Store.exe) 프로세스에서 데이터를 빠르게 주고받을 수 있게 해 주는 공유 메모리 메커니즘입니다. 이 메커니즘을 기반으로 Inetinfo.exe 프로세스와 Store.exe 프로세스 사이에 양방향 프로세스 간 통신이 허용됩니다.

참고:
Inetinfo.exe는 WebDAV, IMAP4, NNTP, POP3 및 SMTP와 같은 인터넷 프로토콜에서 요청을 받습니다.

이 메모리는 Active Directory® 정보를 캐시하는 Exchange 구성 요소인 DSAccess에서도 사용됩니다.

이러한 오류는 이 큐를 증가시키고 있는 Inetinfo.exe 프로세스 또는 Inetinfo.exe 프로세스가 종속된 리소스에 성능 문제가 있음을 나타냅니다. 이로 인해 서버 응답 시간이 증가할 수 있습니다. 따라서 서버의 응답이 지연됩니다.

이 문제를 해결하려면 "추가 정보" 섹션에 참조된 리소스를 사용하여 Inetinfo.exe 또는 관련 리소스에 성능 지체가 있는지 확인합니다. 이 지체 현상은 낮은 디스크 성능 또는 높은 CPU 사용률과 관련되어 있을 수 있습니다.

추가 정보

  • Epoxy에서 증가하는 큐를 확인하는 방법에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Identifying Rising Queues in Epoxy"를 참조하십시오.

  • 프로세서 지체에 대한 자세한 내용은 프로세서 지체을 참조하십시오.

  • 디스크 지체에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

  • 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


Exchange Server에 액세스하는 동안 오류가 발생했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

The Microsoft® Exchange Server Analyzer Tool cannot access your Exchange server. 이 오류는 Active Directory® 디렉터리 서비스에 지정한 Exchange 서버의 구성 정보가 없음을 나타냅니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 서버 이름을 제대로 입력했는지 확인합니다.

  • 정규화된 도메인 이름(예: Server1.example.com) 대신 서버의 호스트 또는 NetBIOS 이름(예: Server1)만 입력합니다.

  • 이 서버의 Active Directory 구성 정보에 액세스하는 데 필요한 사용 권한이 있는지 확인합니다.


Exchange Server 정보 액세스 오류
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에서 Exchange 서버에 대한 Active Directory® 디렉터리 서비스 구성 정보에 액세스하는 데 문제가 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 현재 로그온 계정에 Active Directory의 Exchange 서버 구성 정보를 읽을 수 있는 적절한 권한이 있는지 확인합니다.

  • Active Directory 도메인 컨트롤러에 네트워크 연결이 되어 있는지 확인합니다.

  • Exchange Server Analyzer Tool에 Active Directory에 액세스하기 위한 명시적 계정 자격 증명을 입력합니다.

  • Exchange Server Analyzer에서 Active Directory 도메인 컨트롤러를 지정합니다.

  • 지정한 Exchange 서버가 존재하고 서버 이름을 올바르게 입력했는지 확인합니다.


메시지 추적 로그 액세스 오류
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-06

Microsoft® Exchange Server Analyzer Tool은 Exchange_MessageTrackingEntry Microsoft WMI(Windows® Management Instrumentation) 클래스의 각 인스턴스에 대한 MessageID 속성을 쿼리합니다.

Exchange Server Analyzer가 쿼리 결과를 받지 못하면 오류를 표시합니다.

이런 오류는 대부분 메시지 추적 센터 기능이 사용 가능하지 않게 설정되어 있어 발생합니다.

메시지 추적 센터 기능을 사용하면 보낸 사람, 메일 메시지 및 메시지 받는 사람에 대한 정보를 기록할 수 있습니다. 특히, 메시지를 보내거나 받은 시간, 메시지 크기와 우선 순위 및 메시지 받는 사람 목록 등의 통계 정보를 살펴볼 수 있습니다. 또한 전자 메일 메시지의 제목 줄을 기록할 수도 있습니다. 메시지 추적 센터는 시스템 메시지, 공용 폴더 메시지 및 전자 메일 메시지 등의 메시지를 검색합니다.

메시지 추적을 원하는 각 서버에 대해 메시지 추적 센터를 사용 가능하게 설정해야 합니다. 이 기능이 설정되면 서버를 통해 라우팅되는 모든 메시지가 메시지 추적 로그에 추가됩니다.

Exchange Server Analyzer에서 검색을 시작하려면 메시지 추적 기능을 사용하도록 설정되어 있어야 합니다.

참고:
이 절차를 수행하려면 로컬 관리자 그룹의 구성원 및 관리 그룹 단계에서 적용된 Exchange 관리자 역할이 있는 그룹의 구성원과 같은 사용 권한이 있어야 합니다.
서버에 메시지 추적 센터를 사용하도록 설정하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버를 확장하여 메시지 추적을 사용할 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 메시지 추적 사용 확인란을 선택합니다.

  3. 서버를 통해 보내거나 받는 모든 메시지의 제목을 기록하려면 제목 로깅 및 표시 사용 확인란을 선택합니다.

    참고:
    제목 로깅을 사용하면 성능이 약간 저하될 수 있습니다.

  4. 로그 파일 유지 관리에서는 로그 파일을 제거할 수 없도록 하거나 로그 파일 보관 기간을 수정할 수 있습니다. 추적 로그를 보관하는 기본 기간은 7일입니다.

    참고:
    대량의 메일을 처리하는 서버에서는 추적 로그가 급속하게 늘어납니다. 로그 파일을 위한 디스크 공간과 해당 디스크를 사용하는 다른 서비스나 응용 프로그램의 디스크 공간이 충분한지 확인합니다.

  5. 확인 또는 적용을 클릭합니다. 변경 내용을 적용하기 위해 서비스를 다시 시작하지 않아도 됩니다.

메시지 추적 센터 사용 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 262162, "XADM: Using the Message Tracking Center to Track a Message"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)를 참조하십시오.

Exchange 서버 전송 문제 해결 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 821910, "Exchange Server 2003 전송 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910)을 참조하십시오.


ACL 업그레이드 중 오류 발생
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-02-15

Microsoft Exchange Analyzer Tool은 MSExchangeIS에 대한 이벤트 9551 오류가 최근 1시간 이내 기록되었는지 여부를 확인할 때 Win32_NTLogEvent Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다.

최근 1시간 이내 이벤트 9551 오류가 기록되면 Exchange Analyzer에서 해당 시간 동안 기록된 이벤트 9551 오류의 총 수를 계산합니다.

최근 1시간 이내 이벤트 9551 오류가 20번 이상 기록되면 Exchange Analyzer에서 경고를 표시합니다.

이 오류는 사서함 리소스 또는 공용 폴더의 ACL(액세스 제어 목록)에 나타나지만 올바른 Active Directory 디렉터리 서비스 개체와 연결되지 않은 사용자 계정이 있을 수 있음을 나타냅니다.

Microsoft Exchange Server 2003 또는 Exchange 2000 Server가 실행 중인 서버의 사서함은 Active Directory에 올바른 Active Directory 디렉터리 서비스 사용자 계정으로 표시되어야 액세스할 수 있습니다.

Exchange Server 5.5 기반 컴퓨터에서 사서함이 삭제된 후에 Exchange 2000 Server 또는 Exchange Server 2003 사서함 리소스 또는 공용 폴더가 업데이트되지 않은 경우 Active Directory에 올바른 계정으로 표시되지 않는 계정이 만들어질 수 있습니다.

삭제된 사서함 계정이 사서함 리소스 또는 공용 폴더의 ACL에 남아 있는 경우 사서함 리소스나 공용 폴더에 액세스하여 Exchange에서 나열된 계정을 확인하려고 할 때마다 Active Directory에 올바른 계정으로 표시되지 않는 계정을 확인할 수 없습니다. 이 프로세스는 그 자체만으로 성능 문제를 나타낼 수 있습니다.

이 문제를 해결하려면 다음을 수행합니다.

  • Exchange 2000 Server 서비스 팩(SP3) 이상 버전이 설치되어 있는지 확인합니다. 최신 Exchange 2000 Server 서비스 팩을 구하려면 Microsoft 기술 자료 문서 301378, "최신 Exchange 2000 Server 서비스 팩을 구하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)을 참조하십시오.

  • Exchange System Manager를 사용하여 ACL에서 잘못된 사서함 계정을 수동으로 제거합니다.

  • Exchange 환경이 Exchange 혼합 모드인 경우 정보 저장소에 대해 DS/IS 일관성 검사를 실행합니다.

  • Exchange 환경이 Exchange 전용 모드인 경우 Microsoft 기술 자료 문서 324323, "XADM: Skipping User Accounts That Are Not Represented in Active Directory During Access Control List Conversion"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323)의 안내를 따르십시오.

Exchange System Manager를 사용하여 ACL에서 잘못된 계정을 수동으로 제거하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작하여 9551 오류로 식별된 폴더를 찾습니다.

  2. 해당 폴더를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  3. 사용 권한 탭을 선택하고 클라이언트 권한을 클릭합니다.

  4. 이름 창에서 9551 오류로 식별된 사용자 계정을 선택한 다음 제거 단추를 클릭하여 ACL에서 해당 계정을 제거합니다.
Exchange 혼합 모드의 정보 저장소에 대해 DS/IS 일관성 검사를 실행하려면 다음을 수행합니다.

  1. Exchange Server 5.5 관리자 프로그램에서 정보 저장소가 포함된 Exchange 5.5 Server 컴퓨터를 클릭합니다.

  2. 파일 메뉴에서 속성을 클릭한 다음 고급 탭을 클릭합니다.

  3. 일관성 조정을 클릭합니다.

  4. 공용 폴더 사용 권한에서 알 수 없는 사용자 계정 제거 및 사서함 사용 권한에서 알 수 없는 사용자 계정 제거 확인란을 클릭하여 선택한 다음 모든 불일치를 클릭합니다.

  5. 다른 모든 확인란을 클릭하여 선택을 해제한 다음 확인을 클릭합니다.

자세한 정보

이 문제에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서 및 Exchange Server 리소스를 참조하십시오.

  • 이벤트 및 오류 메시지 센터: 이벤트 세부 정보: MSExchangeIS 사서함 저장소 이벤트 9551 세부 정보(http://go.microsoft.com/fwlink/?LinkId=83189)

  • Microsoft 기술 자료 문서 301378, "최신 Exchange 2000 Server 서비스 팩을 구하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)

  • Microsoft 기술 자료 문서 324323, "XADM: Skipping User Accounts That Are Not Represented in Active Directory During Access Control List Conversion"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323)


ESE.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-21

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Exchange용 다운로드"(http://go.microsoft.com/fwlink/?linkid=33457)를 참조하십시오.


ESEUTIL.EXE 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


EXCDO.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


EXCHMEM.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더 및 \Exchsrvr\bin 폴더 모두에서 확인)

  • Mapi32.dll(System32 폴더 및 \Exchsrvr\bin 폴더 모두에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


Exmime.dll 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 해결하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


EXOLEDB.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전의 최신 서비스 팩 또는 롤업을 설치하십시오. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server 또는 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭하고 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


EXPOP3.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 해결하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


EXPROX.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 해결하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


EXRES.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 해결하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


EXSMTP.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


EXSMTP.DLL 파일 버전이 오래되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

오류 메시지

소개

Microsoft® Exchange Server Analyzer Tool은 EXSMTP.DLL의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 EXSMTP.DLL의 Version 키 값이 6556.0이 아니면 경고를 표시합니다.

이 경고는 이 Exchange Server 컴퓨터에 설치된 EXSMTP.DLL의 버전이 2004년 5월 Exchange 2000 Server Post-Service Pack 3 Rollup 버전 1임을 나타냅니다. 최신 업데이트 롤업을 다운로드할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)에서 최신 업데이트(2004년 8월)를 다운로드합니다.

  2. Microsoft 기술 자료 문서 870540, "Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540)을 검토하여 최신 업데이트에 대해 알아보십시오.

  3. Exchange Server 컴퓨터를 전체 백업합니다.

  4. 2004년 8월자 업데이트를 적용합니다.

이 Exchange Server 업데이트와 다른 Exchange Server 업데이트의 설치에 대한 자세한 내용은 Microsoft 기술 자료 문서 328839, "HOWTO: Exchange 서비스 팩 및 핫픽스 적용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)을 참조하십시오.


현재 Exchange ActiveSync 추적이 활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange ActiveSync®에 대해 추적이 활성화되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync\Enabled

Exchange Server Analyzer는 Enabled 값이 존재하고 0보다 큰 값으로 구성되어 있을 경우 경고를 표시합니다.

Microsoft Exchange ActiveSync는 IIS(인터넷 정보 서비스)에서 ISAPI(Internet Server Application Programming Interface) 확장으로 구현됩니다. IIS, Exchange ActiveSync 및 Exchange ActiveSync를 사용하는 여러 클라이언트 장치에는 전용 추적 기능이 포함되어 있습니다. 따라서 Microsoft Windows Server™ 2003의 전용 추적 기능을 사용할 필요가 없습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync를 탐색합니다.

  3. Enabled 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange ActiveSync 및 Exchange ActiveSync 클라이언트의 추적 및 로깅에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 330463, "XCCC: Server ActiveSync HTTP 오류 코드 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=330463)

  • 330461, "HOWTO: Server ActiveSync 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=330461)

  • 822176, "Troubleshoot Exchange 2003 Always-Up-To-Date Notification"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822176)


Exchange 이진 파일 버전이 설치된 Exchange Server 버전보다 최신 버전입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더 및 \Exchsrvr\bin 폴더 모두에서 확인)

  • Mapi32.dll(System32 폴더 및 \Exchsrvr\bin 폴더 모두에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일의 Version 값이 Exchange Server Version 값보다 클 경우 경고를 표시합니다. 버전 번호가 더 높은 것은 파일이 필요한 것보다 최신 버전이라는 뜻입니다. 핫픽스가 설치된 경우 이런 상황이 발생할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 이 경우 수행해야 할 작업은 없습니다. 이 경고는 핫픽스나 기타 업데이트를 설치한 결과 최신 파일이 존재한다는 것을 나타낼 뿐입니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


이 Exchange 클러스터 노드가 도메인 컨트롤러이기도 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 서버에 대한 DomainRole 값을 확인할 때 Microsoft WMI(Windows® Management Instrumentation) 개체(Win32_ComputerSystem 클래스)를 쿼리합니다. DomainRole 값은 도메인에서 컴퓨터의 역할을 나타냅니다. 다음 표에는 DomainRole에 대한 올바른 값이 나열되어 있습니다.

값 | 의미
0 | 독립 실행형 워크스테이션
1 | 구성원 워크스테이션
2 | 독립 실행형 서버
3 | 구성원 서버
4 | 백업 도메인 컨트롤러
5 | 주 도메인 컨트롤러

또한 Exchange Server Analyzer는 Started 값을 확인할 때 ClusSvc WMI 개체(Windows 클러스터 서비스 개체 Win32_Service 클래스)를 쿼리합니다. True 값은 클러스터 서비스가 시작되었음을 나타내고 False 값은 서비스가 시작되지 않았음을 나타냅니다.

Exchange Server Analyzer는 DomainRole 값이 클러스터 서비스가 시작된 Exchange Server 컴퓨터에서 3보다 크면 오류를 표시합니다. 이 오류는 Exchange Server가 도메인 컨트롤러 노드를 가진 Windows Server Cluster에서 실행 중임을 나타냅니다.

Exchange Server 클러스터 노드를 도메인 컨트롤러로 실행하는 것은 지원되지 않는 구성입니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 도메인 컨트롤러로 실행할 클러스터가 아닌 서버를 선택하고 Active Directory 설치 마법사(dcpromo)를 실행하여 해당 서버의 수준을 올립니다.

  2. Active Directory® 디렉터리 서비스가 새 도메인 컨트롤러에서 구성되었으면 기존 Active Directory 내용이 새 서버로 복제되는 동안 기다립니다.

    Active Directory 크기에 따라 이 작업은 몇 시간이 소요될 수 있습니다.

  3. 클러스터 서버에서 Active Directory 설치 마법사(dcpromo)를 실행하여 해당 서버의 수준을 내리고 Active Directory를 제거합니다.

도메인 컨트롤러의 수준을 올리고 내리는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 "HOWTO: Windows 2000에서 도메인 컨트롤러 수준 올리기 및 내리기"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=238369)를 참조하십시오.


Exchange 오류 보고 기능이 비활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-21

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange 오류 보고 기능이 활성화되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\DisableErrorReporting

Exchange Server Analyzer는 DisableErrorReporting 값이 1로 설정되어 있을 경우 경고를 표시합니다. 값 1은 Exchange 오류 보고 기능이 비활성화되었음을 나타냅니다.

Windows 오류 보고, Microsoft 이벤트 보고 및 자동 오류 보고라고도 하는 Microsoft 오류 보고 기능은 Exchange 2000 Server 서비스 팩 2에 최초로 추가되었습니다. Exchange Server 2003에는 관리자에게 오류 보고 정보를 보내고 회사 오류 보고 기능과 통합되며 Exchange Server 2003 받는 사람 업데이트 서비스에 대한 향상된 보고 기능을 제공하는 Exchange 오류 보고라고 하는 뛰어난 Microsoft 오류 보고 기능이 포함되어 있습니다.

Exchange Server 관리자는 Exchange 오류 보고 기능을 사용하여 인터넷의 HTTPS를 통해 크래시 및 기타 오류를 Microsoft의 오류 보고 서버로 전송할 수 있습니다. Microsoft Online Crash Analysis로 오류 보고서를 보내는 것이 좋습니다. Exchange 서버에서 오류 데이터를 수집하면 Exchange 제품 팀에서 소프트웨어의 치명적 오류를 찾아 수정하는 데 도움이 됩니다.

Exchange System Manager를 사용하는 동안이나 Exchange System Manager가 설치된 컴퓨터에서 Active Directory 사용자 및 컴퓨터로 Exchange 관련 작업을 수행하는 중에 오류가 발생하면 Exchange 오류 보고 기능은 관리자에게 오류에 대한 정보를 알려주며 해당 오류를 Microsoft에 보고할지 묻는 메시지를 표시합니다. 또한 Exchange 보고 기능은 Microsoft Exchange System Attendant, Microsoft Exchange Information Store 및 기타 Exchange 서비스에서 발생한 오류를 잡아 보고하기도 합니다. 뿐만 아니라 받는 사람 업데이트 서비스에서 오류가 발생할 경우 시스템 수행자(System Attendant) 구성 요소가 불량 상태를 유지할 수 있으므로 Exchange 오류 보고 기능은 받는 사람 업데이트 서비스에서 발생하는 액세스 위반 및 기타 내부 결함도 보고합니다.

Exchange System Manager의 서버 속성 페이지에 있는 상자를 선택하여 치명적인 오류 정보를 보내도록 각 Exchange 서버를 구성할 수 있습니다.

Microsoft에 서버 오류 데이터를 보내도록 Exchange 2000 Server 또는 Exchange Server 2003을 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버를 차례로 확장하고 사용 중인 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. Exchange System Manager에 관리 그룹 노드가 표시되지 않으면 서버를 확장하고 사용 중인 서버를 마우스 오른쪽 단추로 클릭한 후 속성을 클릭합니다.

  3. <Server Name> 속성 페이지의 일반 탭에서 심각한 서비스 오류 정보를 Microsoft에 자동으로 보내기 상자를 선택한 다음 적용을 클릭합니다.

  4. 예를 클릭하여 Exchange 오류 보고 기능의 활성화를 확인합니다.

  5. 확인을 클릭합니다.

심각한 오류가 발생하면 약 10-50KB 크기로 압축된 오류 보고서 파일이 생성됩니다. 이 보고서에는 덤프 파일이 포함되어 있습니다. 덤프 파일은 오류가 발생한 프로세스에 대한 정보가 들어 있는 파일입니다. 다양한 프로그래밍 수준(예: 스레드 수준, 인터페이스 수준, 메서드 또는 함수 수준)에서 오류가 발생할 수 있지만 모두 단일 프로세스의 컨텍스트 내에서 발생합니다. 일반적으로 덤프 파일에는 각 스레드가 수행하는 작업의 세부 사항, 프로세스에 의해 사용되는 다양한 메모리 영역, 시스템 정보 및 기타 관련 디버깅 정보 등, 오류 발생 프로세스에 대한 정보가 포함되어 있습니다. Exchange Server를 사용할 경우에는 오류 보고서에 Exchange Server의 상태, 운영 체제 버전 정보, 컴퓨터 하드웨어에 대한 세부 정보, 컴퓨터의 IP 주소 및 제품 라이센스 식별에 사용되는 디지털 제품 ID에 대한 정보도 포함됩니다.

Microsoft에서 내부적으로 개인 정보를 수집하지 않지만 수집된 일부 정보에 사용자 시스템을 고유하게 식별하는 정보가 포함될 수 있습니다. 그러나 Microsoft는 이러한 방식으로 수집된 데이터를 사용하지 않으며 크래시 보고와 버그 수정에만 사용합니다. 자세한 내용은 오류 보고 정책인 "데이터 수집 정책"(http://go.microsoft.com/fwlink/?LinkId=33818)을 참조하십시오.


Exchange 프런트 엔드 서버의 Boot.ini 파일에 /3GB 시작 스위치가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터에서 사용자 모드 프로세스(MaxProcessMemorySize)에 할당된 가상 주소 공간의 양을 확인할 때 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 또한 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스에서 Exchange_Server WMI 클래스를 검토하여 IsFrontEndServer 키 값을 확인합니다. False 값은 Exchange Server 컴퓨터가 프런트 엔드 서버가 아님을 나타냅니다. True 값은 Exchange Server 컴퓨터가 프런트 엔드 서버임을 나타냅니다.

Exchange Server Analyzer는 MaxProcessMemorySize 키 값이 2097024가 아니고 IsFrontEndServer 키가 True로 설정되어 있지 않은 경우 경고를 표시합니다.

이 경고는 Boot.ini 파일에 /3GB 시작 스위치가 설정되어 있기 때문에 Exchange Server 컴퓨터가 최적화된 메모리 사용이 이루어질 수 있도록 구성되지 않았음을 나타냅니다. 이 스위치는 메모리가 1GB 이상이고 다음 운영 체제 중 하나를 실행 중인 Exchange 서버에서만 사용해야 합니다.

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

중요:
Windows 2000 Server에서는 /3GB 스위치를 사용하지 않아야 합니다. 이러한 운영 체제에서는 이 스위치가 지원되지 않아 응용 프로그램이나 운영 체제가 충돌할 수 있기 때문입니다. 또한 /3GB 스위치는 위 운영 체제 중 1GB 이상의 실제 메모리가 설치되어 있는 경우에만 지원됩니다.

Microsoft Windows 2000 Server 또는 Microsoft Windows Server 2003을 실행하는 서버의 Boot.ini 파일에 /3GB 매개 변수가 포함되어 있으면 Windows는 최대 4GB의 가상 주소 공간 중 3GB를 사용자 프로세스에 할당하고 1GB를 커널에 할당합니다. /3GB 매개 변수를 사용하지 않는 경우에 일반적으로 Windows는 2GB를 사용자 프로세스에 할당하고 나머지 2GB를 커널에 할당합니다. 따라서 /3GB 스위치를 사용하면 메모리를 많이 사용하는 응용 프로그램이 더 큰 가상 메모리 주소 공간을 사용하게 되어 성능이 향상됩니다.

/3GB 스위치를 사용하면 주로 사용자 사서함을 호스팅하는 Exchange 서버의 Store.exe 프로세스와 같은 메모리를 많이 사용하는 응용 프로그램에 도움이 됩니다. 따라서 사용자 사서함을 호스팅하지 않는 프런트 엔드 서버의 경우 /3GB 스위치를 사용하더라도 큰 효과를 기대할 수 없습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Windows 탐색기에서 시스템 파티션을 탐색합니다.

  2. Boot.ini 파일을 볼 수 없는 경우는 폴더 옵션을 보호된 운영 체제 파일 숨기기로 설정했기 때문일 수 있습니다. 이러한 경우에는 Windows 탐색기 창에서 도구, 폴더 옵션, 보기 탭을 클릭합니다. 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 해제합니다. 경고 상자가 표시되면 예를 클릭합니다.

  3. 탐색기에서 Boot.ini 파일을 볼 수 있으면 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램을 클릭하고 Notepad를 선택하여 파일을 엽니다.

  4. [Operating Systems] 섹션에 있는 모든 시작 줄에서 /3GB 스위치를 삭제합니다.

  5. 변경 내용을 저장하고 메모장을 닫습니다.

  6. 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

/3GB 시작 스위치 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 297812, "How to Use the 4GT RAM Tuning Feature"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "The effects of 4GT tuning on system Page Table Entries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 31679, "Boot.ini 파일에서 /USERVA 스위치를 사용하여 /3GB 구성을 조정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Exchange IFS 드라이브가 Windows 백업에서 명시적으로 제외되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 백업을 사용하여 백업에서 제외된 파일과 폴더를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Exchange Server Analyzer는 특히 Exchange IFS라는 문자열 값을 찾습니다.

Exchange Server Analyzer는 Exchange IFS(Installable File System) 드라이브를 나타내는 드라이브 문자를 가져올 때도 다음 레지스트리 항목을 읽습니다.

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Exchange2000 Server에서는 기본 드라이브 문자가 M입니다. Exchange Server 2003에서는 기본적으로 IFS 드라이브가 해제되어 있습니다.

Exchange Server Analyzer는 FilesNotToBackup 키에 Exchange IFS라는 문자열이 없거나 Exchange IFS가 있지만 Exchange IFS에 대한 값 데이터가 M:\* /s(여기서 M은 IFS를 나타내는 드라이브 문자임)가 아닐 경우 경고를 표시합니다.

기본적으로 IFS 드라이브 문자 매핑을 사용할 수 있게 설정하면 FilesNotToBackup 레지스트리 키에 Exchange IFS가 추가됩니다. M:\ 드라이브는 Exchange 저장소의 논리적 보기일 뿐이며 실제 드라이브가 아니므로 이를 백업하면 첨부 파일이 손실되는 등의 중대한 문제가 발생할 수 있습니다. 또한 백업 소프트웨어가 로그 파일을 적절한 크기로 자르지 않아 서버 디스크 공간이 예기치 않게 부족할 수 있습니다.

백업을 사용하지 않는 경우에는 이 경고를 무시해도 됩니다. 백업을 사용하고 있다면 모든 백업 작업에서 IFS 드라이브를 제외시키는 것이 좋습니다. 백업이나 그 밖의 다른 백업 프로그램으로 IFS 드라이브를 백업하면 정보 저장소 데이터베이스가 손상되고 데이터가 손실되어 IFS 드라이브 백업에서 데이터를 복원하지 못할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup을 탐색합니다.

  3. FilesNotToBackup을 마우스 오른쪽 단추로 클릭하고 새로 만들기 | 다중 문자열 값을 클릭합니다. 이름으로 Exchange IFS를 입력하고 Enter 키를 누릅니다.

  4. 오른쪽 창에서 Exchange IFS를 두 번 클릭하고 값 데이터 M:\* /s를 입력합니다. 해당 시스템에서 기본 드라이브 문자 M을 사용하지 않을 경우 올바른 드라이브 문자를 사용해야 합니다.

  5. 레지스트리 편집기를 닫습니다.

Microsoft Windows® 레지스트리에 대한 자세한 내용은 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)을 참조하십시오.

Exchange 백업 및 복원에 대한 자세한 내용은 Exchange Server 2003 재해 복구 작업 가이드(http://go.microsoft.com/fwlink/?LinkId=47570)를 참조하십시오. 추가 정보가 필요하면 다음 기술 자료 문서를 참조하십시오.

  • 258243, "XADM: Exchange 2000 Server 컴퓨터를 백업 및 복원하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258243)

  • 233427, "Ntbackup.exe 도구를 사용하여 백업되지 않는 파일 및 폴더"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=233427)

바이러스 백신 소프트웨어로 IFS 드라이브를 검색할 때 발생할 수 있는 문제에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 298924, "XADM: Exchange 2000 M 드라이브를 백업하거나 검색하지 않아야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: 데이터베이스를 탑재하려고 하면 "C1041737" 오류와 이벤트 470 메시지가 표시될 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: 일정 항목이 사용자 폴더에서 사라진다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


Exchange 사서함 서버에는 1GB 이상의 메모리가 있지만 Boot.ini 파일에 /3GB가 설정되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange 서버의 실제 메모리 양과 사용자 모드 프로세스에 할당된 가상 주소 공간 양을 확인할 때 두 Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 다음 표에서는 Exchange Server Analyzer가 계산하는 클래스와 키를 설명합니다.

쿼리한 클래스 | 쿼리한 키 | 설명
Win32_OperatingSystem | MaxProcessMemorySize | 프로세스에 할당할 수 있는 최대 메모리(킬로바이트)
Win32_OperatingSystem | OSProductSuite | 운영 체제에 추가로 설치 및 허가된 시스템 제품
Win32_ComputerSystem | TotalPhysicalMemory | 해당 컴퓨터에 설치되어 있는 RAM의 크기(바이트)

Exchange Server Analyzer는 Windows 2000 Server를 실행하지 않는 Exchange Server 컴퓨터에 1GB(기가바이트) 이상의 실제 메모리가 설치되어 있고 MaxProcessMemorySize가 2097024보다 크고 3104640보다 작으면 경고를 표시합니다.

이 경고는 Exchange 서버가 Microsoft 기술 자료 문서266096, "XGEN: 1GB 이상의 실제(Physical) RAM을 가진 Exchange 2000 서버에서 /3GB 스위치가 필요하다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)에 기술된 요구 사항에 맞지 않는다는 것을 나타냅니다. 이 설정은 프로덕션 구성에는 권장되지 않습니다.

Microsoft Windows Server™ 2003에서는 메모리 사용 및 메모리 주소 공간 할당을 조정할 수 있도록 두 시작 스위치 /3GB 및 /USERVA를 지원합니다. 시스템의 실제 메모리 양과 관계없이 Windows는 4GB의 가상 주소 공간을 사용합니다. 이 중 2GB는 응용 프로그램 같은 사용자 모드 프로세스에 할당되고 나머지 2GB는 운영 체제 및 커널 모드 드라이브 같은 커널 모드 프로세스에 할당됩니다. 1GB 이상의 실제 메모리를 가진 시스템에서는 이러한 두 개의 시작 스위치를 사용하여 응용 프로그램에는 더 많은 메모리(3GB)를 할당하고 운영 체제에는 더 적은 메모리(1GB)를 할당할 수 있습니다. 이 추가 가상 주소 공간은 Exchange 정보 저장소 프로세스의 가상 주소 공간에서 메모리 조각화 양을 줄이는 데 도움을 줍니다.

/3GB 스위치는 이러한 할당 변경 내용을 적용하는 데 사용됩니다. 시스템의 Boot.ini 파일에 이 스위치를 입력하고 시스템을 다시 시작하여 변경 내용을 적용합니다. 이 스위치는 메모리가 1GB 이상이고 다음 운영 체제 중 하나를 실행 중인 Exchange 서버에서만 사용해야 합니다.

  • Microsoft Windows Server 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

중요:
Windows 2000 Server에서는 /3GB 스위치를 사용하지 않아야 합니다. 이러한 운영 체제에서는 이 스위치가 지원되지 않아 응용 프로그램이나 운영 체제가 충돌할 수 있기 때문입니다. 또한 /3GB 스위치는 위 운영 체제 중 1GB 이상의 실제 메모리가 설치되어 있는 경우에만 지원됩니다.

/USERVA 스위치는 Windows Server 2003에 새로 추가된 기능입니다. 이 스위치는 사용자 모드 프로세스와 커널 모드 프로세스 사이에서 가상 주소 공간을 보다 명확하게 구분하기 위해 제공됩니다. 이 스위치는 Exchange 2000 Server 및 Exchange Server 2003 같은 지원되는 응용 프로그램에만 사용해야 하며 해당 응용 프로그램에서 지원하는 특정 값만 사용해야 합니다.

참고:
다른 /USERVA 설정을 사용할 경우 Microsoft 기술 지원 서비스를 받을 수 없습니다. 고객은 Boot.ini 파일에 제조업체가 권장하는 설정을 추가해야 합니다.

Exchange Server 2003 시스템에 사용할 경우 /USERVA 값으로 3030(예: /USERVA=3030)만 지원됩니다. 이 값을 사용하면 운영 체제에 40MB(메가바이트)를 추가로 할당할 수 있으며 사용 가능한 모든 시스템 리소스를 소모하지 않고도 사용자를 더 추가할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 내 컴퓨터를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다. 시스템 속성 대화 상자가 나타납니다.

  2. 고급 탭을 클릭합니다.

  3. 시작 및 복구 영역에서 설정을 클릭합니다. 시작 및 복구 대화 상자가 나타납니다.

  4. 시스템 시작 영역에서 편집을 클릭합니다. 그러면 메모장에서 Windows Boot.ini 파일이 열립니다.

  5. [Operating Systems] 섹션에서 /fastdetect 스위치를 포함하는 시작줄 끝에 /3GB /USERVA=3030 스위치를 추가합니다.

  6. 변경 내용을 저장하고 메모장을 닫습니다.

  7. 확인을 두 번 클릭하면 열린 대화 상자가 닫히고 Exchange Server 컴퓨터가 다시 시작되어 변경 내용이 적용됩니다.

Exchange Server의 메모리 사용 및 성능 최적화에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266096, "1GB 이상의 실제(Physical) RAM을 가진 Exchange 2000 서버에서 /3GB 스위치가 필요하다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 810371, "XADM: Windows 2003 Server 기반 Exchange Server에서 /Userva 스위치 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)

  • 823440, "Windows Server 2003 기반 시스템에 Exchange Server 2003을 설치한 경우 /3GB 스위치를 사용해야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

  • 822178, "Exchange Server 2003 기능의 종속성 및 요구 사항 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822178)


Exchange Management 서비스가 LocalSystem으로 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Management(MSExchangeMGMT) 서비스의 StartName 속성 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer에서 Exchange Management 서비스가 LocalSystem(SYSTEM) 계정 이외의 계정으로 실행 중임을 확인하면 오류를 표시합니다.

이 오류는 Exchange Management 서비스가 지원되는 구성으로 실행되고 있지 않음을 나타냅니다. 다른 계정으로 Exchange Management 서비스를 실행하는 경우 사용 권한 및 액세스 오류가 발생하게 됩니다.

이 오류를 해결하려면 Exchange Management 서비스를 구성하여 LocalSystem(SYSTEM) 계정으로 시작해야 합니다.

Exchange Management 서비스 계정을 구성하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. Microsoft Exchange Management 서비스를 찾아서 중지합니다.

  3. Microsoft Exchange Management 서비스를 두 번 클릭합니다.

  4. Microsoft Exchange Management 속성 페이지의 로그온 탭에서 다음 계정으로 로그온에서 로컬 시스템 계정을 선택한 다음 적용을 클릭합니다.

  5. 서비스 상태에서 시작을 클릭한 다음 확인을 클릭합니다.

  6. 서비스 스냅인을 닫습니다.

LocalSystem 계정을 사용하여 Exchange 서비스를 실행하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 239762, "Exchange Services Run Under LocalSystem"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)을 참조하십시오.


Exchange Management 서비스가 중지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Management 서비스를 나타내는 MSExchangeMGMT 인스턴스에 대한 Started 키 값을 확인할 때 Win32_Process Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 MSExchangeMGMT 인스턴스에 대한 Started 키 값이 True가 아니면 경고를 표시합니다.

Exchange Management 서비스는 Exchange 2000 서버 서비스 팩 2에 도입되었습니다. 일부 기능 중 Exchange Server 메시지 추적 센터 기능과 특정 Exchange System Manager 기능이 제대로 동작하려면 이 서비스가 필요합니다.

Exchange Management 서비스를 사용하면 사용자 인터페이스를 통해 Exchange Server 2003 또는 Exchange 2000 Server가 Active Directory® 디렉터리 서비스에 액세스할 때 사용할 도메인 컨트롤러 또는 글로벌 카탈로그 서버를 지정할 수 있습니다. 이 서비스는 메시지 추적에도 필요합니다. Exchange의 핵심 기능에 영향을 주지 않고 이 서비스를 사용하지 않도록 설정할 수 있습니다. 그러나 Exchange Server 기능을 감사할 때 메일을 라우팅하는 모든 Exchange Server 컴퓨터에 대한 메시지 추적 기능이 필요할 수 있습니다.

참고:
프런트 엔드 서버는 대체적으로 메일 라우팅보다는 메일 액세스에 사용되므로 프런트 엔드 서버에는 Exchange Management 서비스를 실행할 필요가 없습니다.

Exchange Management 서비스가 자동으로 시작되도록 구성하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. Microsoft Exchange Management 서비스를 두 번 클릭합니다.

  3. Microsoft Exchange Management 속성 페이지 일반 탭의 시작 유형 대화 상자에서 자동을 선택한 다음 적용을 클릭합니다.

  4. 서비스 상태에서 시작을 클릭한 다음 확인을 클릭합니다.

Exchange Management 서비스에 대한 자세한 내용은 Microsoft 기술 자료 문서 307413, "XGEN: General Information on Exchange Management Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307413)를 참조하십시오.

Exchange 관리에 대한 일반적인 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)를 참조하십시오.


Exchange 공급자 추적이 사용하도록 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-06-20

Microsoft Exchange Server Analyzer Tool은 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인하기 위해 Active Directory 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 5.5"가 포함되어 있으면 해당 컴퓨터에서 Microsoft Exchange Server 5.5를 실행하고 있는 것입니다. 문자열 값에 "Version 6.0"이 포함되어 있으면 해당 컴퓨터에서 Microsoft Exchange 2000 Server를 실행하고 있는 것입니다. 문자열 값에 "Version 6.5"가 포함되어 있으면 해당 컴퓨터에서 Microsoft Exchange Server 2003을 실행하고 있는 것이고, 문자열 값에 "Version 8.0"이 포함되어 있으면 컴퓨터에서 Microsoft Exchange Server 2007을 실행하고 있는 것입니다.

또한 Exchange Analyzer는 CIM_Datafile Microsoft® WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Exchange 전송 공급자인 Emsmdb32.dll의 Version 키 값을 확인합니다. Version WMI 키는 이 파일의 빌드 번호를 나타냅니다.

마지막으로 Exchange Analyzer는 다음 레지스트리 항목을 쿼리하여 Exchange 공급자 추적이 구성되었으며 사용하도록 설정되었는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing

Exchange Analyzer는 다음 조건에 해당하는 경우 오류 메시지를 표시합니다.

  • 서버에서 Exchange Server 2007을 실행하고 있지 않은 경우

  • Emsmdb32.dll의 Version 키 값이 6.5.7233.47 이상 버전인 경우

  • HKML\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing 항목이 있으며 0 이외의 값으로 설정되어 있는 경우

이 오류는 해당 컴퓨터에서 Exchange 전송 공급자 추적이 사용하도록 설정되어 있음을 나타냅니다.

6.5.7233.47 이상 버전의 Exchange 전송 공급자에는 추적 기능이 기본적으로 포함되어 있습니다. .ttd 파일을 통해 다음 프로그램을 추적할 수 있습니다.

  • Exchange Server 2003을 실행 중인 서버에서 MAPI를 사용하는 모든 프로그램

  • Microsoft Exchange 시스템 관리 도구를 사용하여 설치한 모든 프로그램

Exchange 전송 공급자 추적은 실제 문제 해결 시에만 사용하도록 설정해야 하며, 다른 용도로 사용하는 경우에는 일반 서버 성능이 저하될 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 포함되어 있습니다. 레지스트리를 편집하려면 먼저 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.
Exchange Server 2003에서 Exchange 공급자 추적을 사용하지 않도록 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKML\Software\Microsoft\Exchange\Exchange Provider\ 항목을 찾습니다.

  3. 오른쪽 탐색 창에서 다음을 수행합니다.

    1. 추적 사용 하위 키를 마우스 오른쪽 단추로 클릭하고 삭제합니다. 또는

    2. 추적 사용을 두 번 클릭합니다.

  4. 추적 사용 하위 키의 값을 0으로 구성합니다.

  5. 레지스트리 편집기를 닫습니다.

  6. Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, Microsoft Windows 레지스트리 설명을 참조하십시오.


Exchange 2000 Server에서 최신 서비스 팩이 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer는 각 Exchange 서버 개체의 versionNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. versionNumber 특성은 해당 컴퓨터에서 실행 중인 Exchange Server의 버전을 나타냅니다.

Exchange Server Analyzer는 STORE.EXE 프로세스의 Version 키 값을 확인할 때도 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 STORE.EXE의 Version 키 값이 4416보다 크고 6249보다 작거나 같을 경우 경고를 표시합니다.

이 경고는 Exchange Server 컴퓨터가 해당 컴퓨터에서 실행 중인 Exchange 버전에 사용할 수 있는 최신 코드를 실행하고 있지 않음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange 2000 Server 서비스 팩 3(http://go.microsoft.com/fwlink/?LinkId=17058)을 다운로드합니다.

  2. Exchange 2000 Server 서비스 팩 3 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=12337)를 검토하십시오.

  3. 최신 업데이트(2004년 8월)(http://go.microsoft.com/fwlink/?LinkId=33457)를 다운로드합니다.

  4. Microsoft 기술 자료 문서 870540, "Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540)을 검토하여 최신 업데이트 정보에 대해 알아보십시오.

  5. Exchange Server 컴퓨터를 전체 백업합니다.

  6. Exchange 2000 Server 서비스 팩 3을 적용합니다.

  7. 2004년 8월 업데이트를 적용합니다.

Exchange 2000 Server용 최신 서비스 팩을 구하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 301378, "최신 Exchange 2000 Server 서비스 팩을 구하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)을 참조하십시오.

이 Exchange Server 업데이트와 다른 Exchange Server 업데이트의 설치에 대한 자세한 내용은 기술 자료 문서 328839, "HOWTO: Exchange 서비스 팩 및 핫픽스 적용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)을 참조하십시오.


Windows Server 2003에서는 Exchange 2000 Server를 지원하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange Server 컴퓨터에서 실행 중인 Microsoft Windows® 운영 체제 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 4.0은 해당 컴퓨터가 Microsoft Windows NT® Server 4.0을 실행하고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터에 Windows 2000 Server가 실행되고 있음을 나타내고 값 5.2는 해당 컴퓨터에 Windows Server™ 2003이 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스에 쿼리하여 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인합니다. 문자열 값에 Version 5.5가 포함되어 있으면 시스템에서 Microsoft Exchange Server 버전 5.5가 실행되고 있는 것입니다. 문자열 값에 Version 6.0이 있으면 해당 컴퓨터에 Exchange Server 2000 Server가 실행 중입니다. 문자열 값에 Version 6.5가 있으면 해당 컴퓨터에 Exchange Server 2003이 실행 중입니다.

Exchange Server Analyzer는 CurrentVersion 값이 5.2이고 serialNumber 값에 "Version 6.0"이 포함되어 있을 경우 오류를 표시합니다. 이러한 구성은 지원되지 않으므로 가능한 빨리 이 오류를 수정해야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 다음 중 하나를 수행합니다.

    • 지원되는 운영 제제를 실행 중인 서버에서 Exchange 2000 Server를 설치하고 사서함을 해당 서버로 옮깁니다.

    • Exchange 2000 Server를 Exchange Server 2003으로 업그레이드합니다.

지원되는 구성에 대한 자세한 내용은 Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.

Exchange Server 및 Windows Server 2003에 대한 자세한 내용은 Microsoft 기술 자료 문서 810591, "Windows Server 2003과의 Exchange Server 호환성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591)을 참조하십시오.


Exchange 2007 시험판 버전이 설치됨
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-02-20

Microsoft Exchange Server Analyzer Tool은 디렉터리의 Exchange Server 개체에 대한 serialNumber 특성 값을 확인할 때 Active Directory 디렉터리 서비스에 쿼리합니다. serialNumber 특성은 Exchange Server 버전과 서비스 팩 버전(설치된 경우)을 포함하는 문자열 값입니다. 예를 들어 서비스 팩이 설치되지 않은 Exchange Server 2007 컴퓨터에서 serialNumber 특성은 Version 8.0 (Build 0685)과 같습니다.

serialNumber 특성의 문자열에 값 8.0이 포함되어 있으나 0685보다 작은 빌드 번호가 포함되어 있으면 오류가 표시됩니다.

이 오류는 Exchange Server 2007 컴퓨터에서 Exchange Server 2007 시험판 버전이 실행되고 있음을 나타냅니다.

Exchange Server 2007 시험판 버전의 설치는 업무 환경에서 지원되지 않습니다.

이 오류를 해결하려면 Exchange Server 2007 프로덕션 버전을 설치하십시오.


Exchange 2007 서버 개체가 다른 관리 그룹으로 이동되었음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-08-11

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 디렉터리에 있는 모든 Exchange Server 개체의 serialNumber 특성 값을 확인합니다.

또한 Exchange Server Analyzer는 전용 Exchange 2007 관리 그룹 Exchange 관리 그룹(FYDIBOHF23SPDLT)인지 확인할 수 있도록 Exchange Server를 실행하는 서버가 있는 관리 그룹의 cn 특성 값을 쿼리합니다.

서버가 Microsoft Exchange Server 2007을 실행하고 있지만 Exchange 관리 그룹(FYDIBOHF23SPDLT) 이외의 관리 그룹에 있는 경우 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 서버가 수동으로 Exchange 2007 관리 그룹에서 이동되었으며 메일 흐름 문제를 발생시킬 수 있음을 나타냅니다.

serialNumber 특성은 Exchange Server 버전과 서비스 팩 버전이 모두 설치된 경우 해당 버전을 모두 포함하는 문자열 값입니다. serialNumber 특성 값이 Version 8.0이면 서버에서 Exchange 2007을 실행하고 있습니다.

Microsoft Exchange Server 2003 및 Microsoft Exchange 2000 Server는 Exchange 개체를 관리하는 권한을 위임하기 위해 관리 그룹을 사용하여 이러한 개체를 그룹화합니다. Exchange 2007에서는 관리 그룹을 논리적 관리 단위로 사용하지 않습니다. Exchange Server 2003 또는 Exchange 2000 Server와 Exchange 2007의 동시 사용을 지원하기 위해 Exchange 2007을 설치할 때 자동으로 모든 Exchange 2007 서버가 단일 관리 그룹에 추가됩니다. 이 관리 그룹은Exchange Server 2003의 Exchange System Manager에서 Exchange 관리 그룹(FYDIBOHF23SPDLT)으로 인식됩니다.

이 문제를 해결하려면 서버를 제거한 후 다시 설치합니다.


Exchange가 글로벌 카탈로그 서버가 아닌 도메인 컨트롤러에 상주합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 DomainRole 키 값을 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키에 유효한 값은 다음 표에 표시되어 있습니다.

값 | 의미
0 | 독립 실행형 워크스테이션
1 | 구성원 워크스테이션
2 | 독립 실행형 서버
3 | 구성원 서버
4 | 백업 도메인 컨트롤러
5 | 주 도메인 컨트롤러

또한 Exchange Server Analyzer는 클러스터 서비스인 ClusSvc의 Started 키 값을 확인할 때 Win32_Service WMI 클래스를 쿼리합니다. 또한 Exchange Server Analyzer는 OSProductSuite 키 값을 확인할 때 Win32_OperatingSystem WMI 클래스를 쿼리합니다. OSProductSuite 키 값은 컴퓨터에서 실행 중인 Windows 버전을 나타냅니다.

또한 Exchange Server Analyzer는 개체 범주가 msExchExchangeServer인 모든 디렉터리 개체의 serialNumber 특성 값을 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. serialNumber 특성 값은 사용 중인 Exchange Server의 버전을 나타냅니다.

마지막으로 Exchange Server Analyzer는 이 서버의 isGlobalCatalogReady 특성 값을 확인할 때 Active Directory를 쿼리합니다. 이 특성의 True 값은 디렉터리 서버도 작동하는 글로벌 카탈로그 서버임을, False 값은 디렉터리 서버가 글로벌 카탈로그 서버가 아님을 나타냅니다.

Exchange Server Analyzer는 Exchange Server 컴퓨터에서 DomainRole 키 값이 3보다 큰 경우, Exchange Server 컴퓨터가 Windows Small Business Server, Exchange Server 버전 5.5를 실행하지 않거나 Windows 클러스터에서 실행되지 않는 경우, 그리고 isGlobalCatalogReady 특성이 False로 설정되어 있는 경우 경고를 표시합니다.

이 경고는 Exchange Server가 작동 중인 글로벌 카탈로그 서버도 아닌 디렉터리 서버에서 실행함을 나타냅니다. 이 구성은 지원되지 않으며 이로 인해 Exchange 서비스가 실패할 수 있습니다.

Small Business Server가 없는 도메인 컨트롤러에서 Exchange Server를 실행할 경우 다음 사항에 유의하십시오.

  • Exchange Server와 Active Directory는 모두 리소스를 많이 사용하는 응용 프로그램입니다. 한 대의 컴퓨터에서 두 프로그램을 모두 실행할 경우에는 성능 문제를 고려해야 합니다.

  • 도메인 컨트롤러에서 Exchange Server를 실행할 경우 도메인 컨트롤러를 글로벌 카탈로그 서버로 지정해야 합니다.

  • 디렉터리 서비스 액세스(DSAccess), 디렉터리 서비스 프록시(DSProxy) 및 메시지 분류기 같은 Exchange Server의 몇 가지 디렉터리 구성 요소는 다른 도메인 컨트롤러나 글로벌 카탈로그 서버로 장애 조치되지 않습니다.

  • Windows에서는 /3GB 시작 스위치를 사용해도 별다른 이점이 없습니다. Exchange Server가 모든 메모리를 사용하게 되어 Active Directory의 메모리가 부족해지기 때문입니다.

  • Exchange Server 서비스를 중지하지 않고 서버를 종료하거나 다시 시작하면 시스템이 종료되는 데 상당히 오래 걸립니다.

  • 이와 같이 구성할 경우 Exchange 관리자가 Active Directory에 대한 로컬 관리 권한을 가지게 되므로 보안 문제를 유발할 수 있으며 자신의 권한을 높일 수 있게 됩니다. 또한 Exchange Server나 Active Directory에서 나타나는 보안 취약점이 외부로 노출됩니다.

  • 도메인 컨트롤러에서 Exchange Server 2003 또는 Exchange Server 2007을 실행할 경우에는 도메인 컨트롤러 수준 올리기 도구(DCPromo)를 사용하여 컴퓨터 역할을 변경할 수 없으므로 Microsoft Outlook® Mobile Access와 같은 구성 요소가 중단되는 결과를 가져옵니다.

  • Active Directory 도메인 컨트롤러로도 지정된 클러스터된 노드에서는 Exchange Server 2003 또는 Exchange Server 2007을 실행할 수 없으므로 피해야 합니다. 즉, 도메인 컨트롤러로도 지정된 클러스터의 노드에서 Exchange 2000 Server를 실행할 경우 Exchange 2000 Server에서 Exchange Server 2003으로 업그레이드하여 구성원 서버로 서버 수준을 내려야 합니다.

컴퓨터에서 Exchange 2000 Server를 실행하는 경우 가능한 가장 빠른 시점에서 DCPromo를 사용하여 구성원 서버로 서버 수준을 내리는 것이 좋습니다. 컴퓨터에서 Exchange Server 2003 또는 Exchange Server 2007을 실행하는 경우에는 아래 절차 중 하나를 사용하여 이 경고를 해결합니다.

Exchange를 다른 컴퓨터로 옮겨 이 경고를 해결하려면 다음을 수행합니다.

  1. 다른 컴퓨터에 Exchange Server를 설치합니다.

  2. Exchange 작업 마법사의 사서함 이동을 사용하여 도메인 컨트롤러의 기존 사서함을 새 Exchange 서버로 모두 이동합니다.

  3. 이전 Exchange Server 컴퓨터가 보유했던 공용 폴더 및 역할을 새 Exchange Server 컴퓨터에 상주시킵니다.

  4. 도메인 컨트롤러에서 Exchange Server를 제거합니다.
Exchange Server를 글로벌 카탈로그 서버로 만들어 이 경고를 해결하려면 다음을 수행합니다.

  1. Active Directory 사이트 및 서비스를 엽니다.

  2. 사이트, 사이트 및 서버를 차례로 확장합니다.

  3. 글로벌 카탈로그 서버로 지정하려는 도메인 컨트롤러를 선택합니다.

  4. 오른쪽 창에서 NTDS 설정을 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  5. 일반 탭에서 글로벌 카탈로그 확인란을 선택합니다. 디렉터리 서버에서 서비스 팩 2 또는 이전 버전이 설치된 Windows 2000 Server를 실행하는 경우 서버를 다시 시작하여 변경 내용을 적용합니다. 디렉터리 서버에서 서비스 팩 3 이상이 설치된 Windows 2000 Server 또는 Windows Server™ 2003을 실행하는 경우 서버를 다시 시작하지 않아도 변경 내용이 동적으로 적용됩니다.

도메인 컨트롤러에서의 Exchange Server 설치에 대한 자세한 내용은 Microsoft 기술 자료 문서 250989, "XADM: Installing the ADC on a Windows 2000 Domain Controller That Also Runs Exchange Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989)를 참조하십시오.


Exchange Server 5.5가 검색됨
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-10-06

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인합니다. 문자열 값에 "Version 5.5"가 포함되어 있으면 컴퓨터에는 Microsoft Exchange Server 버전 5.5가 실행 중입니다. 문자열 값에 "Version 6.0"이 있으면 컴퓨터에는 Exchange 2000 Server가 실행 중입니다. 문자열 값에 "Version 6.5"가 있으면 컴퓨터에는 Exchange Server 2003이 실행 중입니다.

Exchange Server Analyzer는 serialNumber 값에 "Version 5.5"가 들어 있는 경우 오류를 표시합니다.

이 오류는 현재 버전의 Exchange Server Analyzer가 검색된 버전의 Exchange Server를 자세하게 분석할 수 없음을 나타냅니다.

Exchange Server Analyzer는 검색된 버전의 Exchange Server에서 사용할 수 없는 다양한 특정 프로그램 인터페이스에 따라 달라집니다.

오류를 해결하려면 Exchange 2000 이상 버전이 실행 중인 Exchange Server를 지정합니다.

이러한 규칙이 오류에서 트리거된 것으로 생각한다면 Active Directory에 있는 Exchange Server 개체의 serialNumber 특성 값이 올바르게 설정되었는지 확인합니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
serialNumber 특성 값을 보려면 다음을 수행하십시오.

  1. ADSI 편집을 시작합니다.

  2. 구성 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=<ExchangeOrganizationName>을 차례로 확장합니다.

  3. CN=Administrative Groups, CN=<AdministrativeGroupName>, CN=Servers를 차례로 확장합니다.

  4. 서버 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. serialNumber 특성을 두 번 클릭하면 현재 값이 표시됩니다.

Exchange Server 2003 배포 방법에 대한 자세한 내용을 보려면 "Exchange Server 2003 배포 가이드"(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.

Exchange Server 5.5에서 Exchange Server 2003으로 마이그레이션하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 259912, "XADM: Exchange Server 5.5를 Exchange 2000 Server 또는 Exchange Server 2003으로 업그레이드하기 위한 전제 조건"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912)을 참조하십시오.

Exchange Server 2003 마이그레이션 및 업그레이드 방법은 "Upgrade to Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=34186)을 참조하십시오.


Exchange Server 5.5에서 최신 서비스 팩이 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer는 각 Exchange 서버 개체의 versionNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. versionNumber 특성은 해당 컴퓨터에서 실행 중인 Exchange Server의 버전을 나타냅니다.

Exchange Server Analyzer는 STORE.EXE 프로세스의 Version 키 값을 확인할 때도 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 STORE.EXE의 Version 키 값이 1959보다 크고 2653보다 작은 경우 경고를 표시합니다. 이 값은 해당 컴퓨터에서 Exchange Server 5.5 서비스 팩 4 이전 버전을 실행하고 있음을 나타냅니다.

이 경고는 Exchange Server 컴퓨터가 해당 컴퓨터에서 실행 중인 Exchange 버전에 사용할 수 있는 최신 코드를 실행하고 있지 않음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 5.5 서비스 팩 4(http://go.microsoft.com/fwlink/?LinkId=33456)를 다운로드합니다.

  2. Microsoft 다운로드 센터(http://go.microsoft.com/fwlink/?LinkId=33456)에서 Exchange Server 5.5의 최신 업데이트(2004년 5월)를 다운로드합니다.

  3. Microsoft 기술 자료 문서 841765, "May 2004 Update Rollup for Exchange Server 5.5"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765)를 참조하여 이 업데이트에 대한 정보를 검토하십시오.

  4. Exchange Server 컴퓨터를 전체 백업합니다.

  5. Exchange Server 5.5 서비스 팩 4를 적용합니다.

  6. 2004년 5월 업데이트를 적용합니다.

이 Exchange Server 업데이트와 다른 Exchange Server 업데이트의 설치에 대한 자세한 내용은 Microsoft 기술 자료 문서 328839, "HOWTO: Exchange 서비스 팩 및 핫픽스 적용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)을 참조하십시오.


Windows 2003에서는 Exchange Server 5.5가 지원되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키를 읽어 Exchange Server 컴퓨터에서 실행 중인 Microsoft Windows® 운영 체제 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 4.0은 해당 컴퓨터가 Microsoft Windows NT® Server 4.0을 실행하고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터에 Windows 2000 Server가 실행되고 있음을 나타내고 값 5.2는 해당 컴퓨터에 Windows Server™ 2003이 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스에 쿼리하여 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인합니다. 문자열 값에 "Version 5.5"가 포함되어 있으면 시스템에서 Microsoft Exchange Server 버전 5.5가 실행되고 있는 것입니다. 문자열 값에 "Version 6.0"이 있으면 해당 컴퓨터에 Exchange 2000 Server가 실행 중입니다. 문자열 값에 "Version 6.5"가 있으면 해당 컴퓨터에 Exchange Server 2003이 실행 중입니다.

Exchange Server Analyzer는 CurrentVersion 값이 5.2이고 serialNumber 값에 Version 5.5가 포함되어 있을 경우 오류를 표시합니다. 이 구성은 지원되지 않으므로 오류를 최대한 빨리 수정해야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 다음 중 하나를 수행합니다.

    • 지원되는 운영 체제가 실행되는 서버에 Exchange Server 5.5를 설치한 후 사서함을 해당 서버로 이동합니다.

    • Exchange Server 5.5에서 Exchange Server 2003으로 마이그레이션합니다.

Exchange Server 2003 배포에 대한 자세한 내용을 보려면 Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.

Exchange Server 및 Windows Server 2003에 대한 자세한 내용은 Microsoft 기술 자료 문서 810591, "Windows Server 2003과의 Exchange Server 호환성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591)을 참조하십시오.

Exchange Server 5.5에서 Exchange Server 2003으로의 마이그레이션에 대한 자세한 내용은 Microsoft 기술 자료 문서 259912, "XADM: Exchange Server 5.5를 Exchange 2000 Server로 업그레이드하기 위한 전제 조건"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912)을 참조하십시오.

Exchange Server 2003 마이그레이션 및 업그레이드 방법은 마이그레이션 및 업그레이드 페이지 "Upgrade to Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=34186)을 참조하십시오.


Exchange Server 5.0은 최신 서비스 팩 또는 업데이트 롤업을 실행하고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer는 각 Exchange 서버 개체의 versionNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. versionNumber 특성은 해당 컴퓨터에서 실행 중인 Exchange Server의 버전을 나타냅니다.

Exchange Server Analyzer는 STORE.EXE 프로세스의 Version 키 값을 확인할 때도 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 STORE.EXE의 Version 키 값이 1456보다 크고 1460보다 작을 경우 경고를 표시합니다.

이 경고는 Exchange Server 컴퓨터가 해당 컴퓨터에서 실행 중인 Exchange 버전에 사용할 수 있는 최신 코드를 실행하고 있지 않음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858에서 Exchange Server 5.0 서비스 팩 2를 다운로드합니다.

  2. http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168735에서 서비스 팩 2 README.TXT 파일을 읽습니다.

  3. Exchange Server 5.0의 최신 업데이트(2004년 4월)를 다운로드하려면 Microsoft 다운로드 센터(http://go.microsoft.com/fwlink/?LinkId=41361)를 방문하십시오.

  4. Microsoft 기술 자료 문서 834130, "Microsoft Exchange Server 5.0 Update Rollup"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130)에서 이 업데이트에 대한 정보를 검토하십시오.

  5. Exchange Server 컴퓨터를 전체 백업합니다.

  6. Exchange Server 5.0 서비스 팩 2을 적용합니다.

  7. 2004년 4월 업데이트를 적용합니다.

이 Exchange Server 업데이트와 다른 Exchange Server 업데이트의 설치에 대한 자세한 내용은 Microsoft 기술 자료 문서 328839, "HOWTO: Exchange 서비스 팩 및 핫픽스 적용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)을 참조하십시오.


Active Directory 도메인 컨트롤러에 상주하는 Exchange Server 5.5
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 DomainRole 키 값을 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키에 유효한 값은 다음 표에 표시되어 있습니다.

값 | 의미
0 | 독립 실행형 워크스테이션
1 | 구성원 워크스테이션
2 | 독립 실행형 서버
3 | 구성원 서버
4 | 백업 도메인 컨트롤러
5 | 주 도메인 컨트롤러

또한 Exchange Server Analyzer는 클러스터 서비스 ClusSvc의 Started 키 값을 확인할 때 Win32_Service WMI 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 개체 범주가 msExchExchangeServer인 모든 디렉터리 개체의 serialNumber 특성 값을 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. serialNumber 특성 값은 사용 중인 Exchange Server의 버전을 나타냅니다.

Exchange Server Analyzer는 Exchange Server 컴퓨터에서 DomainRole 키 값이 3보다 큰 경우, Exchange Server 컴퓨터가 Windows 클러스터에서 실행되지 않는 경우 및 실행 중인 Exchange 버전이 Exchange Server 버전 5.5인 경우 경고를 표시합니다.

이 경고는 Exchange Server 5.5가 Active Directory 서버에서 실행 중임을 나타냅니다. 이러한 상황으로 인해 포트가 충돌할 수 있으므로 ADC(Active Directory Connector)에 문제가 발생할 수 있습니다. ADC가 이 서버를 대상으로 사용할 경우 올바른 LDAP(Exchange Lightweight Directory Access Protocol) 포트 번호가 사용되는지 확인해야 합니다. 기본적으로 디렉터리 서버는 TCP 포트 389을 통해 LDAP 요청을 수신합니다. Exchange 포트가 변경되지 않고 ADC가 Exchange 포트를 사용하도록 구성되지 않으면 ADC가 Exchange와 통신할 수 없습니다

Active Directory는 LDAP 액세스를 위해 표준 LDAP 포트 389를 사용합니다. 그러나 표준 포트 번호를 사용하면 LDAP 포트 389를 수신하려는 동일한 서버에 상주하는 Exchange Server가 무시됩니다. 해당 디렉터리에 Exchange 서버 LDAP 액세스를 허용하도록 Exchange LDAP 포트를 다시 할당해야 합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange 관리자를 엽니다.

  2. 사이트 이름, 구성, 프로토콜 및 LDAP (디렉터리) 사이트 기본값을 차례로 확장합니다.

  3. 포트 할당을 389에서 현재 사용되지 않는 포트로 변경합니다.

  4. 확인을 클릭하여 변경 내용을 저장합니다.

  5. Microsoft Exchange Directory Service를 다시 시작하여 변경 내용을 적용합니다.

  6. 필요한 경우 새 포트를 사용하도록 이 서버를 대상으로 사용하는 ADC를 다시 구성합니다.

Exchange Server 5.5의 LDAP 포트 할당을 변경하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 224447, "XADM: Exchange Server의 LDAP 포트 할당을 변경하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=224447)을 참조하십시오.


Exchange Server DNS 이름 확인 실패
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 Exchange Server 컴퓨터의 구성된 DNS 서버에 대해 DNS(Domain Name System) 쿼리를 시도합니다. 이 연결은 이름 확인을 수행하고 결과를 분석하는 사용자 지정 개체 프로세서를 사용하여 이루어집니다. Exchange Server Analyzer는 쿼리 결과의 일부로 IP(인터넷 프로토콜) 주소를 받지 못하면 오류를 표시합니다.

이 오류는 DNS에서 Exchange Server 컴퓨터를 찾을 수 없음을 나타냅니다. Exchange Server와 Active Directory® 디렉터리 서비스가 제대로 작동되려면 올바르게 구성되고 상태가 정상인 DNS가 필요합니다. DNS 등록 및 확인 문제는 메시지 전송, 수신 및 배달 기능에 폭넓게 영향을 미칩니다.

Active Directory 및 Exchange Server가 올바르게 작동할 수 있도록 DNS를 제대로 구성해야 합니다. Active Directory의 DNS 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 237675, "Active Directory용 도메인 이름 시스템 설정"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675)을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. 다음 구성 항목을 검토하여 DNS 상태가 정상이며 Exchange Server DNS 항목이 제대로 등록되어 있는지 확인합니다.

    • DNS IP 구성

    • 동적 영역 업데이트

    • DNS 전달자

  2. 루트 영역 항목이 있는지 확인합니다. DNS 관리 콘솔에서 정방향 조회 영역을 봅니다. 해당 영역에 도메인에 대한 항목이 있습니다. 다른 영역 항목이 있을 수도 있습니다. 점(".") 영역이 있으면 안 됩니다. 점(".") 영역이 있으면 해당 점(".") 영역을 삭제합니다. 점(".") 영역은 DNS 서버를 루트 서버로 식별합니다. 일반적으로 외부(인터넷) 액세스가 필요한 Active Directory 도메인을 루트 DNS 서버로 구성해서는 안 됩니다. 점(".")을 삭제한 후 디렉터리 서버에서 Ipconfig /registerdns를 사용하여 Exchange Server IP 주소를 수동으로 등록합니다. Netlogon 서비스를 다시 시작해야 할 수도 있습니다.

  3. Exchange Server 컴퓨터에서 netdiag /fix를 사용하여 Exchange Server DNS 항목을 수동으로 다시 채웁니다.

Active Directory에 DNS를 사용하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 323418, "HOWTO: Windows Server 2003 제품군에서 Active Directory가 사용되는 경우 기존 DNS 인프라에 DNS 통합"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418)을 참조하십시오.

DNS 및 Active Directory 문제 해결에 대한 자세한 내용은 기술 자료 문서 260371, "Windows 2000에서 일반적인 Active Directory 설치 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371)을 참조하십시오.


Exchange 서버가 프런트 엔드로 지정되어 호스트 사서함에 나타납니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 서버의 IsFrontEndServer 값을 확인하기 위해 Exchange Server Microsoft WMI(Windows® Management Instrumentation) 개체(Exchange_Server 클래스)를 쿼리합니다. 값이 True이면 해당 Exchange 서버가 프런트 엔드 서버 역할을 합니다. Exchange 서버가 사서함 저장소를 포함할 경우 Exchange Server Analyzer는 서버에 있는 사서함 수를 확인하기 위해 Active Directory® 디렉터리 서비스를 쿼리합니다. 각 사서함 저장소 개체(msExchPrivateMDB 클래스)는 저장소에 있는 모든 사서함을 나열하는 다중 값 특성 homeMDBBL을 갖습니다. Exchange Server Analyzer는 이러한 값을 계산하여 서버에 있는 사서함의 총 수를 구합니다.

Exchange 서버가 프런트 엔드 서버로 지정되어 있고 20개가 넘는 사서함이 구성되어 있으면 경고가 표시됩니다.

사용하는 구성에 따라 Exchange에서 프런트 엔드 서버에 서비스 사서함을 배치해야 할 수 있습니다. 예를 들어 프런트 엔드 서버가 인터넷에서 SMTP(Simple Mail Transfer Protocol) 메일을 수락할 경우 서버에 Exchange SMTP 서비스 전용 사서함이 필요할 수 있습니다. Exchange Server Analyzer는 Exchange 서버에 20개가 넘는 사서함이 구성된 경우에만 경고를 표시하여 이러한 서비스 사서함을 적절히 유지합니다.

프런트 엔드 서버에는 사용자 사서함을 배치하면 안 됩니다. 이러한 구성은 지원되지 않습니다.

프런트 엔드 서버에 사용자 사서함이 있으면 Exchange Server Manager(Exchange Server 2003에만 해당) 또는 Active Directory 사용자 및 컴퓨터를 사용하여 적절한 백 엔드 서버로 이동하십시오.

Exchange 2000 Server 또는 Exchange Server 2003에서 사서함을 이동하려면 다음을 수행합니다.

  1. Active Directory 사용자 및 컴퓨터에서 이동할 사서함을 소유한 사용자를 선택합니다.

  2. 이전 단계에서 선택한 사용자 목록을 마우스 오른쪽 단추로 클릭한 다음 Exchange 작업을 클릭합니다.

  3. Exchange 작업 마법사의 사용 가능한 작업 페이지에서 사서함 이동을 클릭한 후 다음을 클릭합니다.

  4. 지침을 주의 깊게 읽고 마법사의 나머지 단계를 수행합니다.

Exchange Server 2003에서만 사서함을 이동하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, 사서함을 이동해올 서버, 사서함을 이동해올 저장소 그룹, 이동할 사서함이 포함되어 있는 사서함 저장소를 차례로 확장한 다음 사서함을 클릭합니다.

  2. 세부 정보 창에서 이동할 사서함을 소유한 사용자를 마우스 오른쪽 단추로 클릭한 다음 Exchange 작업을 클릭합니다.

  3. Exchange 작업 마법사의 사용 가능한 작업 페이지에서 사서함 이동을 클릭한 후 다음을 클릭합니다.

  4. 지침을 주의 깊게 읽고 마법사의 나머지 단계를 수행합니다.

Exchange 프런트 엔드 서버의 올바른 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 822443, "Front-End Server Considerations in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822443)을 참조하십시오.

Exchange 프런트 엔드 서버 배포 및 구성에 대한 일반 권장 사항은 Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)를 참조하십시오.

Exchange 프런트 엔드 서버에서 사용자 사서함을 실행할 때 발생할 수 있는 오류에 대한 자세한 내용은 기술 자료 문서 273296, "XCON: Users Cannot Retrieve Mail on a Front-End Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273296)를 참조하십시오.

Exchange Server 2003의 사서함 이동에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 821829, "Moving Mailboxes in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)

  • 822892, "Exchange 2003 사서함 이동의 개선 사항"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)


이 Exchange 서버가 도메인 컨트롤러이기도 하지만 이것은 권장되는 구성이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-28

Microsoft® Exchange Server Analyzer Tool은 DomainRole 키 값을 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키에 유효한 값은 다음 표에 표시되어 있습니다.

값 | 의미
0 | 독립 실행형 워크스테이션
1 | 구성원 워크스테이션
2 | 독립 실행형 서버
3 | 구성원 서버
4 | 백업 도메인 컨트롤러
5 | 주 도메인 컨트롤러

또한 Exchange Server Analyzer는 클러스터 서비스 ClusSvc에 대한 Started 키 값을 확인할 때 Win32_Service WMI 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 개체 범주가 msExchExchangeServer인 모든 디렉터리 개체의 serialNumber 특성 값을 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. serialNumber 특성 값은 사용 중인 Exchange Server의 버전을 나타냅니다.

Exchange Server Analyzer는 Exchange Server 컴퓨터에서 DomainRole 키 값이 3보다 크고 Exchange Server 컴퓨터가 Exchange Server 버전 5.5를 실행하지 않거나 Windows 클러스터에서 실행되지 않을 경우 경고를 표시합니다.

Microsoft Windows Small Business Server 2000 또는 Windows Small Business Server 2003의 일부로 Exchange Server를 실행하고 있는 경우 도메인 컨트롤러에 Exchange Server를 설치할 수 있습니다. 그러나 Small Business Server의 일부로 Exchange Server를 실행하고 있지 않은 경우에는 도메인 컨트롤러에서 Exchange Server를 실행하지 않는 것이 좋습니다.

Small Business Server가 없는 도메인 컨트롤러에서 Exchange Server를 실행할 경우 다음 사항에 유의하십시오.

  • Exchange Server와 Active Directory는 모두 리소스를 많이 사용하는 응용 프로그램입니다. 한 대의 컴퓨터에서 두 프로그램을 모두 실행할 경우에는 성능 문제를 고려해야 합니다.

  • 도메인 컨트롤러에서 Exchange Server를 실행할 경우 도메인 컨트롤러를 글로벌 카탈로그 서버로 지정해야 합니다. 글로벌 카탈로그 서버를 만드는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 313994, "HOWTO: Windows 2000에서 글로벌 카탈로그를 만들거나 이동"(http://go.microsoft.com/fwlink/?linkid=3052&kbid= 313994)을 참조하십시오.

  • 디렉터리 서비스 액세스(DSAccess), 디렉터리 서비스 프록시(DSProxy) 및 메시지 분류기 같은 Exchange Server의 몇 가지 디렉터리 구성 요소는 다른 도메인 컨트롤러나 글로벌 카탈로그 서버로 장애 조치되지 않습니다.

  • Windows에서는 /3GB 시작 스위치를 사용해도 별다른 이점이 없습니다. Exchange Server가 모든 메모리를 사용하게 되어 Active Directory가 사용할 수 있는 메모리가 감소하기 때문입니다.

  • 서버를 종료하거나 다시 시작하기 전에 Exchange Server 서비스를 중지하지 않으면 시스템이 종료되는 데 상당히 오래 걸립니다.

  • 이와 같이 구성할 경우 Exchange 관리자는 Active Directory에 대해 로컬 관리 액세스 권한을 가지게 되어 자신의 권한을 높일 수 있게 되므로 보안 문제를 유발할 수 있습니다. 또한 Exchange Server나 Active Directory에서 나타나는 보안 취약점이 외부로 노출됩니다.

  • 도메인 컨트롤러에서 Exchange Server 2003 또는 Exchange Server 2007을 실행할 경우에는 도메인 컨트롤러 수준 올리기 도구(DCPromo)를 사용하여 컴퓨터 역할을 변경할 수 없으므로 Microsoft Outlook® Mobile Access와 같은 구성 요소가 중단되는 결과를 가져옵니다.

  • Active Directory 도메인 컨트롤러로도 지정된 클러스터된 노드에서는 Exchange Server 2003 또는 Exchange Server 2007을 실행하는 것이 지원되지 않으므로 피해야 합니다. 즉, 도메인 컨트롤러로도 지정된 클러스터의 노드에서 Exchange 2000 Server를 실행할 경우 Exchange 2000 Server에서 Exchange Server 2003으로 업그레이드하여 구성원 서버로 서버 수준을 내려야 합니다.

컴퓨터에서 Exchange 2000 Server를 실행할 경우 가능한 빨리 DCPromo를 사용하여 구성원 서버로 서버 수준을 내리는 것이 좋습니다. 컴퓨터에서 Exchange Server 2003이 실행될 경우에는 다음 절차를 따라 이 경고를 해결합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 다른 컴퓨터에 Exchange Server를 설치합니다.

  2. Exchange 작업 마법사의 사서함 이동을 사용하여 도메인 컨트롤러의 기존 사서함을 새 Exchange 서버로 모두 이동합니다.

  3. 이전 Exchange Server 컴퓨터가 보유했던 공용 폴더 및 역할을 새 Exchange Server 컴퓨터에 상주시킵니다.

  4. 도메인 컨트롤러에서 Exchange Server를 제거합니다.

도메인 컨트롤러에서의 Exchange Server 설치에 대한 자세한 내용은 Microsoft 기술 자료 문서 250989, "XADM: Installing the ADC on a Windows 2000 Domain Controller That Also Runs Exchange Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989)를 참조하십시오.


이 Exchange 서버가 다운되었거나 연결할 수 없는 상태입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-20

Microsoft® Exchange Server Analyzer Tool은 원격 프로시저 호출(RPC)을 사용하여 Exchange Server 컴퓨터의 다음 레지스트리 키에서 CurrentVersion 문자열 값을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Exchange Server Analyzer가 어떤 이유로든 이 레지스트리 값을 읽을 수 없으면 오류가 표시됩니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. Ping 명령을 사용하여 Exchange Server 컴퓨터에 연결할 수 있는지 확인합니다.

  3. 방화벽이 설치되어 있으면 RPC 포트가 차단되었는지 확인합니다.

  4. Exchange Server 컴퓨터에서 원격 레지스트리 서비스가 시작되었는지 확인합니다.

  5. Exchange Server Analyzer Tool을 실행 중인 계정의 권한을 검사하여 Exchange Server 컴퓨터의 레지스트리를 읽을 수 있는 충분한 권한이 있는지 확인합니다.

네트워크 연결 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

Exchange Server Best Practices Analyzer Tool 연결 문제 해결에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?linkid=56285)를 참조하십시오.


Exchange 서버가 Windows NT 4.0에서 실행되고 있습니다. 제한적인 진단 정보를 사용할 수 있습니다
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키를 읽어 Exchange Server 컴퓨터에서 실행 중인 Microsoft Windows® 운영 체제 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 4.0은 해당 컴퓨터가 Microsoft Windows NT® Server 4.0을 실행하고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터에 Windows 2000 Server가 실행되고 있음을 나타내고 값 5.2는 해당 컴퓨터에 Windows Server™ 2003이 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 CurrentVersion 값이 4.0으로 설정되어 있을 경우 경고를 표시합니다.

이 경고는 이 Exchange Server 컴퓨터에서 Windows NT Server 4.0이 실행되고 있음을 나타냅니다. Windows NT Server 4.0은 후속 버전의 Windows Server만큼 풍부한 진단 정보를 제공하지 않습니다. 따라서 Exchange Server Analyzer는 제한된 양의 정보만 수집하고 분석할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 이 경우 즉각적으로 수행해야 할 동작은 없습니다. 이 경고는 정보를 제공하기 위한 것입니다.

  2. Windows NT Server 4.0과 Exchange Server 버전 5.5는 제품 수명이 곧 끝나므로 Windows Server 2003 및 Exchange Server 2003으로 업그레이드하는 것이 좋습니다.

Windows NT Server 4.0 및 Exchange Server 5.5의 제품 수명에 대한 자세한 내용은 Microsoft Support Lifecycle 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21759)를 참조하십시오.

Windows Server 2003에 대한 자세한 내용을 보려면 "Microsoft Windows Server 2003" 제품 홈 페이지(http://go.microsoft.com/fwlink/?LinkId=26095)를 방문하십시오.

Exchange Server 2003에 대한 자세한 내용을 보려면 "Microsoft Exchange Server 2003" 제품 홈 페이지(http://go.microsoft.com/fwlink/?LinkId=21573)를 방문하십시오.


Exchange 2003 서버에서 최종 서비스 팩 2 빌드를 실행하고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 디렉터리에 있는 모든 Exchange Server 개체의 serialNumber 특성 값을 확인합니다. serialNumber 특성은 Exchange Server 버전과 서비스 팩 버전이 모두 설치된 경우 해당 버전을 모두 포함하는 문자열 값입니다. 예를 들어 서비스 팩 1이 설치된 Exchange Server 2003 컴퓨터에서 serialNumber 특성은 Version 6.5 (Build 7638: Service Pack 2)와 같습니다.

serialNumber 특성 값 문자열에 6.5 및 Service Pack 2는 포함되어 있는데 7638이 포함되어 있지 않으면 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 Exchange Server 2003 컴퓨터에서 Exchange Server 2003 서비스 팩 2의 시험판 버전을 실행하고 있음을 나타냅니다.

참고:
Exchange Server 서비스 팩은 제거할 수 없기 때문에 서비스 팩을 적용하기 전에 Exchange Server를 실행하는 컴퓨터를 전체 백업해 두는 것이 좋습니다.
이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 2003 서비스 팩 2 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=52073)에서 Exchange Server 2003 서비스 팩 2의 최종 버전을 다운로드합니다.

  2. Exchange Server 2003 서비스 팩 2 릴리스 정보(http://go.microsoft.com/fwlink/?LinkId=52072)를 검토합니다.

  3. Exchange Server 컴퓨터를 전체 백업합니다.

  4. Exchange Server 2003 서비스 팩 2를 적용합니다.

  5. Exchange Server를 실행하는 컴퓨터를 다시 전체 백업합니다.

Exchange Server 서비스 팩을 설치하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 328839, "HOWTO: Exchange 서비스 팩 및 핫픽스 적용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)을 참조하십시오.


Exchange Server가 SharePoint Portal Server를 실행하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Microsoft Windows SharePoint® Portal Server(MSDMSERV)의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 이 Exchange 서버에서 SharePoint Portal Server가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 SharePoint Portal Server가 Exchange Server 컴퓨터에서 실행하고 있으면 경고를 표시합니다.

SharePoint Portal Server는 Exchange Server와 호환되지 않으며 제거해야 합니다. SharePoint Portal Server 및 Exchange Server는 함께 작동하도록 설계되었으며 조직의 협력 환경에서 작동합니다. 그러나 SharePoint Portal Server 및 Exchange Server는 서로 함께 작동하도록 설계되었지만 동일한 하드웨어에서 공존하도록 설계되지는 않았습니다.

이 경고를 해결하려면 다음을 수행합니다.

  • Exchange Server 또는 SharePoint Portal Server를 다른 컴퓨터로 이동합니다. 컴퓨터에서 이러한 프로그램 중 하나를 제거하는 것이 좋습니다.

Exchange Server 2003의 사서함 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 821829, "Moving Mailboxes in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)을 참조하십시오.

Exchange Server 및 SharePoint Portal Server 호환성에 대한 자세한 내용은 기술 자료 문서 277567, "Cannot Install SharePoint Portal Server on a Computer Running Exchange Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=277567)를 참조하십시오.


Exchange Server에서 게스트로 설치된 다른 Exchange Server와 함께 Virtual Server 2005를 실행하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키 값을 읽어 해당 서버가 가상 서버인지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1

또한 Exchange Server Analyzer는 다음 레지스트리 값도 검사합니다.

HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters

또한 Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스(MSExchangeIS)가 Microsoft Virtual Server 2005를 실행 중인 실제 컴퓨터에서 실행되고 있는지 여부를 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

Exchange Server Analyzer는 해당 서버가 가상 서버이고 위에서 설명한 레지스트리 분기가 존재하며 실제 컴퓨터에서 MSExchangeIS가 실행되고 있는 경우 오류를 표시합니다.

HKLM\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1 키가 있으면 Exchange Server 컴퓨터에 Virtual Machine Additions가 설치되어 있음을 나타냅니다. 그리고 HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters 키가 있으면 Exchange Server 컴퓨터가 Virtual Server 2005에서 게스트 가상 컴퓨터로 실행되고 있음을 의미합니다.

Microsoft에서는 모든 Exchange Server 버전을 가상 컴퓨터나 에뮬레이터에서 실행하는 것을 지원하지 않습니다. 이 사항은 Virtual Server 2005, Microsoft Virtual PC 2004 또는 타사 가상 컴퓨터 프로그램에서 실행되는 Exchange Server에 해당되는 내용입니다. Exchange Server 플랫폼은 실제 하드웨어, 특히 Windows Server Catalog(http://go.microsoft.com/fwlink/?linkid=17219)에 나열된 하드웨어 플랫폼에서만 실행되도록 설계되고 테스트되었습니다.

또한 Exchange Server를 실행 중인 컴퓨터에서 Exchange를 가상 서버 게스트로 실행하면 서비스 간의 적절한 중복이 허용되지 않으므로 좋은 방법이 아닙니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Virtual Server 2005에서 실행되는 Exchange Server에서 비가상 Exchange Server 컴퓨터로 사서함을 옮깁니다.

  2. 모든 공용 폴더를 옮기고 필요에 따라 가상 Exchange 서버가 보유하고 있는 모든 역할을 전송합니다.

  3. 가상 컴퓨터에서 Exchange를 제거하여 역할을 해제하고 Exchange 인프라 및 Active Directory® 디렉터리 서비스에서 제거합니다.

사서함 이동에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 822892, "Exchange 2003 사서함 이동의 개선 사항"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, XADM: Differences Between Move Mailbox Methods(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

가상 환경에서 실행되는 Exchange Server 컴퓨터 지원에 대한 자세한 내용은 기술 자료 문서 320220, "Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)을 참조하십시오.

Virtual Server 2005에 대한 자세한 내용은 "Microsoft Virtual Server 2005"(http://go.microsoft.com/fwlink/?linkid=34938)를 참조하십시오.

Virtual PC 2004에 대한 자세한 내용은 "Microsoft Virtual PC 2004"(http://go.microsoft.com/fwlink/?linkid=34663)를 참조하십시오.


Exchange 서버에서 DNS 서비스가 실행되고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 DNS 서버 서비스(DNS)의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 이 Exchange 서버에서 DNS Server 서비스가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 OSProductSuite 키 값을 확인할 때도 Win32_OperatingSystem WMI 클래스를 쿼리합니다. 이 키에 대해 반환되는 값은 해당 Exchange Server 컴퓨터에서 실행 중인 Windows® 운영 체제의 버전을 나타냅니다.

또한 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열되어 있는 항목 수를 확인할 때 Active Directory 디렉터리 서비스를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다.

다음 조건을 만족하는 Exchange Server 컴퓨터에서 DNS Server 서비스가 시작된 것으로 확인되면 경고가 표시됩니다.

  • Exchange Server 컴퓨터에서 100개가 넘는 사서함을 호스팅합니다.

  • Exchange Server 컴퓨터가 Windows Small Business Server 2003 또는 Small Business Server 2000에서 실행되고 있지 않습니다.

DNS Server 서비스를 프로덕션 Exchange 사서함 서버와 동일한 컴퓨터에서 실행하지 않는 것이 좋습니다. 업무 환경에서 DNS Server 서비스와 Exchange Server를 같은 컴퓨터로 호스팅하면 두 서버 중 한쪽이나 양쪽 모두의 성능이 저하될 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 다음 중 한 가지 방법으로 이 경고를 수정할 수 있습니다.

    • Exchange Server 또는 DNS Server 서비스를 컴퓨터에서 제거합니다. 서버 응용 프로그램 중 하나를 컴퓨터에서 완전히 제거하는 것이 좋습니다.

    • Exchange 사서함을 서버에서 제거합니다. 최소한 사서함을 제거하고 Exchange 서버를 프로토콜 또는 인프라 서버로 변환해야 합니다. 이렇게 하면 디스크 I/O 로드가 상당히 줄어들고 CPU 로드도 약간 줄어듭니다. CPU 로드는 Exchange 인프라 역할에 따라 좌우됩니다.

    • 대신 Small Business Server를 설치할 것을 고려해 보십시오. Exchange 서버가 두 대 이상 필요하지 않고 사용자가 75명 미만인 소규모 환경에서 Exchange를 실행하는 경우 Small Business Server를 설치하는 것이 도움이 될 수 있습니다. Small Business Server는 그 밖의 핵심 Microsoft 서버 응용 프로그램과 함께 Microsoft SQL Server와 Exchange Server를 포함하며 단일 컴퓨터 설치에 맞게 개발, 테스트 및 최적화되었습니다.

사서함 및 Exchange 서버 이동에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 822892, "Exchange 2003 사서함 이동의 개선 사항"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, XADM: Differences Between Move Mailbox Methods(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

  • 297289, "Exchange 2000을 새 하드웨어로 이동하고 같은 서버 이름을 유지하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=297289)

Small Business Server에 대한 자세한 내용은 "Microsoft Windows Small Business Server 2003"(http://go.microsoft.com/fwlink/?linkid=23456)을 참조하십시오.


Exchange 서버에서 SQL Server가 실행되고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Microsoft SQL Server™ 서비스(MSSQLSERVER)의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 이 Exchange 서버에서 SQL Server 서비스가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 OSProductSuite 키 값을 확인할 때도 Win32_OperatingSystem WMI 클래스를 쿼리합니다. 이 키에 대해 반환되는 값은 해당 Exchange Server 컴퓨터에서 실행 중인 Windows 운영 체제의 버전을 나타냅니다.

또한 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열되어 있는 항목 수를 확인할 때 Active Directory 디렉터리 서비스를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다.

다음 조건을 모두 만족하는 Exchange Server 컴퓨터에서 SQL Server 서비스가 시작된 것으로 확인되면 경고가 표시됩니다.

  • Exchange Server 컴퓨터에서 100개가 넘는 사서함을 호스팅합니다.

  • Exchange Server 컴퓨터가 Windows Small Business Server 2003 또는 Small Business Server 2000상에서 실행되고 있지 않습니다.

SQL Server를 프로덕션 Exchange 사서함 서버와 동일한 컴퓨터에서 실행하지 않는 것이 좋습니다. SQL Server와 Exchange 사서함 서버는 둘 모두 최적화된 성능으로 작동하기 위해 많은 양의 메모리와 디스크 리소스를 소모합니다. 업무 환경에서 SQL Server와 Exchange Server를 같은 컴퓨터로 호스팅하면 두 서버 중 한쪽이나 양쪽 모두의 성능이 저하될 수 있습니다. 또한 이러한 환경에서는 문제 해결 및 보안이 어렵게 됩니다.

마지막으로 SQL Server와 Exchange Server를 같은 컴퓨터에서 실행하는 경우 발생할 수 있는 여러 가지 상호 운용성 문제가 알려져 있습니다. 이러한 문제 중 대부분은 MS DTC(Microsoft Distributed Transaction Coordinator), Microsoft ADO(ActiveX® Data Objects), OLE DB(OLE Database) 등 두 서버에서 일반적으로 사용되는 파일 또는 프로그램의 버전이 일치하지 않아 발생합니다.

이 경고를 해결하려면 다음을 수행합니다.

  • 다음 중 한 가지 방법으로 이 경고를 수정할 수 있습니다.

    • Exchange Server 또는 SQL Server를 컴퓨터에서 제거합니다. 이 두 프로그램 중 하나를 컴퓨터에서 완전히 제거하는 것이 좋습니다.

    • Exchange 사서함을 서버에서 제거합니다. 최소한 사서함을 제거하고 Exchange 서버를 프로토콜 또는 인프라 서버로 변환해야 합니다. 이렇게 하면 디스크 I/O 로드가 상당히 줄어들고 CPU 로드도 약간 줄어듭니다. CPU 로드는 Exchange 인프라 역할에 따라 좌우됩니다.

    • Small Business Server를 대신 설치할 것을 검토하십시오. Exchange 서버가 두 대 이상 필요하지 않은 소규모 환경에서 Exchange를 실행하는 경우 Small Business Server를 설치하는 것이 도움이 될 수 있습니다. Small Business Server는 그 밖의 핵심 Microsoft 서버 응용 프로그램과 함께 SQL Server와 Exchange Server를 포함하며 단일 컴퓨터 설치에 맞게 개발, 테스트 및 최적화되었습니다.

사서함 및 Exchange 서버 이동에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 822892, "Exchange 2003 사서함 이동의 개선 사항"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, XADM: Differences Between Move Mailbox Methods(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

  • 297289, "Exchange 2000을 새 하드웨어로 이동하고 같은 서버 이름을 유지하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=297289)

Small Business Server에 대한 자세한 내용은 "Microsoft Windows Small Business Server 2003"(http://go.microsoft.com/fwlink/?linkid=23456)을 참조하십시오,


Exchange 서버가 VMware에서 실행되고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-10-26

가상 환경에서 실행되는 Exchange Server 컴퓨터 지원에 대한 자세한 내용은 Microsoft 기술 자료 문서 897615, "Support policy for Microsoft software running in non-Microsoft hardware virtualization software"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=897615)를 참조하십시오.


Boot.ini 파일에 /3GB 및 /USERVA=3030 스위치가 설정되어 있지만 Exchange 서버의 메모리가 1GB 미만입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터의 실제 메모리 양과 사용자 모드 프로세스에 할당된 가상 주소 공간의 양을 확인할 때 두 개의 Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 다음 표에서는 Exchange Server Analyzer가 계산하는 클래스와 키를 설명합니다.

클래스 | 키 | 설명
Win32_OperatingSystem | MaxProcessMemorySize | 프로세스에 할당할 수 있는 최대 메모리(킬로바이트)
Win32_OperatingSystem | OSProductSuite | 운영 체제에 추가로 설치 및 허가된 시스템 제품
Win32_ComputerSystem | TotalPhysicalMemory | 해당 컴퓨터에 설치되어 있는 RAM의 크기(바이트)

Exchange Server Analyzer는 Exchange Server 컴퓨터의 RAM 용량이 950MB 미만이고 MaxProcessMemorySize의 값이 2097024 초과 3104640 미만이면 경고를 표시합니다.

이 경고는 Exchange Server 컴퓨터가 두 가지 측면에서 올바르게 구성되지 않아 메모리 사용이 최적화되지 않았음을 나타냅니다.

  • /USERVA=3030 시작 스위치가 설정되어 있습니다. 이 스위치는 Microsoft Windows Server™ 2003 운영 체제에서 실행 중이고 메모리가 1GB 이상인 Exchange Server 컴퓨터에만 필요합니다.

  • /3GB 시작 스위치가 설정되어 있습니다. 이 스위치는 메모리가 1GB 이상이고 다음 운영 체제 중 하나를 실행 중인 Exchange 서버에서만 사용해야 합니다.

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

중요:
Windows 2000 Server에서는 /3GB 스위치를 사용하지 않아야 합니다. 이러한 운영 체제에서는 이 스위치가 지원되지 않아 응용 프로그램이나 운영 체제가 충돌할 수 있기 때문입니다. 또한 /3GB 스위치는 위 운영 체제 중 1GB 이상의 실제 메모리가 설치되어 있는 경우에만 지원됩니다.

1GB의 실제 메모리가 설치되어 있는 시스템에서 이러한 경고가 발생한 경우는 비디오 카드 같은 다른 구성 요소가 하드웨어 수준에서 이 실제 메모리 중 일부를 할당 받으므로 할당된 실제 메모리를 운영 체제에서 사용할 수 없음을 나타냅니다. 이러한 경우 Windows에 따라 실제로 설치된 메모리 양은 컴퓨터에 설치되어 있는 실제 메모리의 실제 양보다 적습니다. 이러한 상황이 발생하면 BIOS에서 보고하는 설치된 메모리와 Windows에서 보고하는 설치된 메모리의 양을 비교해야 합니다.

Windows Server 2003에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. 시스템 속성 대화 상자가 나타납니다.

  2. 고급을 클릭합니다.

  3. 시작 및 복구 영역에서 설정을 클릭합니다. 시작 및 복구 대화 상자가 나타납니다.

  4. 시스템 시작 영역에서 편집을 클릭합니다. 그러면 메모장에서 Windows Boot.ini 파일이 열립니다.

  5. [Operating Systems] 섹션의 모든 시작 줄에서 /3GB /USERVA=3030 스위치를 삭제합니다.

  6. 변경 내용을 저장하고 메모장을 닫습니다.

  7. 확인을 차례로 두 번 클릭하여 열려 있는 대화 상자를 닫은 후 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

Windows 2000 Server에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. Windows 탐색기에서 시스템 파티션을 탐색합니다.

  2. Boot.ini 파일을 볼 수 없는 경우는 폴더 옵션을 보호된 운영 체제 파일 숨기기로 설정했기 때문일 수 있습니다. 이러한 경우에는 Windows 탐색기 창에서 도구, 폴더 옵션, 보기를 차례로 클릭합니다. 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 해제합니다. 경고 상자가 표시되면 예를 클릭합니다.

  3. Windows 탐색기에서 Boot.ini 파일이 표시되면 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램, Notepad를 차례로 클릭하여 파일을 엽니다.

  4. /3GB를 제거하고 /USERVA=3030이 있는 경우 제거합니다.

  5. 변경 내용을 저장하고 메모장을 닫습니다.

  6. 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

/3GB 및 /USERVA 시작 스위치 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 308356, "Windows Server 2003 또는 Windows 2000 Server를 실행하는 도메인 컨트롤러에서 Lsass.exe 프로세스의 메모리 사용" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812, "How to Use the 4GT RAM Tuning Feature"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "The effects of 4GT tuning on system Page Table Entries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, "Boot.ini 파일에서 /USERVA 스위치를 사용하여 /3GB 구성을 조정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


이 Exchange 서버의 메모리가 1GB보다 작은데 boot.ini 파일에 /3GB 스위치가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터의 실제 메모리 양과 Exchange Server 컴퓨터에서 실행되는 사용자 모드 프로세스에 할당된 가상 주소 공간의 양을 확인할 때 두 개의 Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 다음 표에서는 Exchange Server Analyzer가 계산하는 클래스와 키를 설명합니다.

쿼리한 클래스 | 쿼리한 키 | 설명
Win32_OperatingSystem | MaxProcessMemorySize | 프로세스에 할당할 수 있는 최대 메모리(킬로바이트)
Win32_ComputerSystem | TotalPhysicalMemory | 컴퓨터에 설치되어 있는 RAM의 바이트 수

Exchange Server Analyzer는 TotalPhysicalMemory 값이 1073741824보다 작고 MaxProcessMemorySize 값이 3145600인 경우 경고를 표시합니다.

이 경고는 시스템의 실제 메모리가 950MB보다 작은데 Boot.ini 파일에 /3GB시작 스위치가 설정되어 있음을 나타냅니다. 이 스위치는 메모리가 1GB 이상이고 다음 운영 체제 중 하나를 실행 중인 Exchange 서버에서만 사용해야 합니다.

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

중요:
Windows 2000 Server에서는 /3GB 스위치를 사용하지 않아야 합니다. 지원되지 않아 응용 프로그램이나 운영 체제가 충돌할 수 있기 때문입니다. 또한 /3GB 스위치는 위 운영 체제 중 1GB 이상의 실제 메모리가 설치되어 있는 경우에만 지원됩니다.

1GB의 실제 메모리가 설치되어 있는 시스템에서 이러한 경고가 발생한 경우는 비디오 카드 같은 다른 구성 요소가 하드웨어 수준에서 이 실제 메모리 중 일부를 할당 받으므로 할당된 실제 메모리를 운영 체제에서 사용할 수 없음을 나타냅니다. 이러한 경우 Windows에 따라 실제로 설치된 메모리 양은 컴퓨터에 설치되어 있는 실제 메모리의 실제 양보다 적습니다. 이러한 상황이 발생하면 BIOS에서 보고하는 설치된 메모리와 Windows에서 보고하는 설치된 메모리의 양을 비교해야 합니다.

Windows Server 2003에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. 시스템 속성 대화 상자가 나타납니다.

  2. 고급을 클릭합니다.

  3. 시작 및 복구 영역에서 설정을 클릭합니다. 시작 및 복구 대화 상자가 나타납니다.

  4. 시스템 시작 영역에서 편집을 클릭합니다. 그러면 메모장에서 Windows Boot.ini 파일이 열립니다.

  5. [Operating Systems] 섹션에 있는 모든 시작 줄에서 /3GB 스위치를 삭제합니다.

  6. 변경 내용을 저장하고 메모장을 닫습니다.

  7. 확인을 차례로 두 번 클릭하여 열려 있는 대화 상자를 닫은 후 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

Windows 2000 Server에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. Windows 탐색기에서 시스템 파티션을 탐색합니다. 시스템 파티션은 Boot.ini 및 NTLDR 같은 하드웨어 고유 파일이 저장된 파티션을 말합니다.

  2. Boot.ini 파일을 볼 수 없는 경우는 폴더 옵션에서 보호된 운영 체제 파일 숨기기로 설정했기 때문일 수 있습니다. 이러한 경우에는 Windows 탐색기 창에서 도구, 폴더 옵션, 보기를 차례로 클릭합니다. 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 해제합니다. 대화 상자가 표시되면 예를 클릭합니다.

  3. Windows 탐색기에서 Boot.ini 파일이 표시되면 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램, Notepad를 차례로 클릭하여 파일을 엽니다.

  4. [Operating Systems] 섹션에 있는 모든 시작 줄에서 /3GB 스위치를 삭제합니다.

  5. 변경 내용을 저장하고 메모장을 닫습니다.

  6. 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

Exchange Server의 메모리 사용 최적화에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


이 Exchange 서버의 Boot.ini 파일에 /3GB 시작 스위치가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터에서 사용자 모드 프로세스(MaxProcessMemorySize)에 할당된 가상 주소 공간의 양을 확인할 때 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스에서 Exchange_Server WMI 클래스를 검토하여 IsFrontEndServer 키 값을 확인합니다. False 값은 Exchange Server 컴퓨터가 프런트 엔드 서버가 아님을 나타냅니다. True 값은 Exchange Server 컴퓨터가 프런트 엔드 서버임을 나타냅니다.

뿐만 아니라 Exchange Server Analyzer는 Win32_Service WMI 클래스를 쿼리하여 클러스터 서비스(ClusSvc)가 존재하며 시작되었는지 확인합니다.

또한 Exchange Server Analyzer는 사서함 저장소 개체 msExchPrivateMDB의 homeMDBBL 특성에 나열된 항목 개수를 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server 컴퓨터에 있는 사서함 수가 표시됩니다.

Exchange Server Analyzer는 MaxProcessMemorySize 키 값이 2097024가 아니고, IsFrontEndServer 키가 False로 설정되어 있고, 클러스터 서비스가 실행되고 있지 않고, Exchange Server의 사서함 저장소에 20개 미만의 사서함이 포함되어 있고, Exchange가 Microsoft Windows Small Business Server Edition에서 실행되고 있지 않을 경우 경고를 표시합니다.

이 경고는 Boot.ini 파일에 /3GB 시작 스위치가 설정되어 있으므로 디렉터리 서버가 메모리를 최적으로 사용할 수 있게 구성되지 않았음을 나타냅니다. 이 스위치는 메모리가 1GB(기가바이트) 이상이고 다음 운영 체제 중 하나를 실행 중인 Exchange 서버에서만 사용해야 합니다.

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

중요:
Windows 2000 Server에서는 /3GB 스위치를 사용하지 않아야 합니다. 이러한 운영 체제에서는 이 스위치가 지원되지 않아 응용 프로그램이나 운영 체제가 충돌할 수 있기 때문입니다. 또한 /3GB 스위치는 위 운영 체제 중 1GB 이상의 실제 메모리가 설치되어 있는 경우에만 지원됩니다.

지원되는 운영 체제의 Boot.ini 파일에 /3GB 매개 변수가 포함되어 있으면 Windows는 최대 4GB의 가상 주소 공간 중 3GB를 사용자 프로세스에 할당하고 1GB를 커널에 할당합니다. /3GB 매개 변수를 사용하지 않는 경우에 일반적으로 Windows는 2GB를 사용자 프로세스에 할당하고 나머지 2GB를 커널에 할당합니다. 따라서 /3GB 스위치를 사용할 경우 메모리를 많이 사용하는 응용 프로그램이 더 큰 가상 메모리 주소 공간을 차지하므로 성능이 향상됩니다.

/3GB 스위치를 사용하면 사용자 사서함을 호스팅하는 Exchange 서버의 Store.exe 프로세스와 같이 메모리를 많이 사용하는 응용 프로그램의 작동이 향상됩니다. 프런트 엔드 서버는 사용자 사서함을 호스팅하지 않으므로 프런트 엔드 서버에서는 /3GB 스위치를 사용해도 별다른 이점이 없습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Windows 탐색기에서 시스템 파티션을 탐색합니다.

  2. Boot.ini 파일을 볼 수 없는 경우는 폴더 옵션을 보호된 운영 체제 파일 숨기기로 설정했기 때문일 수 있습니다. 이러한 경우에는 Windows 탐색기 창에서 도구, 폴더 옵션, 보기 탭을 클릭합니다. 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 해제합니다. 경고 상자가 표시되면 예를 클릭합니다.

  3. 탐색기에서 Boot.ini 파일을 볼 수 있으면 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램을 클릭하고 Notepad를 선택하여 파일을 엽니다.

  4. [Operating Systems] 섹션의 모든 시작 줄에서 /3GB 스위치를 삭제합니다.

  5. 변경 내용을 저장하고 메모장을 닫습니다.

  6. 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

/3GB 스위치 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372: "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)


Exchange 2003 서버에서 최종 서비스 팩 1 빌드(7226.6)를 실행하고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-21

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 디렉터리의 Exchange Server 개체에 대한 serialNumber 특성 값을 확인합니다. serialNumber 특성은 Exchange Server 버전과 설치된 경우 서비스 팩 버전을 포함하는 문자열 값입니다. 예를 들어 서비스 팩 1이 설치된 Exchange Server 2003 컴퓨터에서 serialNumber 특성은 Version 6.5 (Build 7226.6: Service Pack 1)과 같습니다.

serialNumber 특성 값에 6.5 및 Service Pack 1이 포함되어 있고 7226.6은 포함되어 있지 않으면 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 Exchange Server 2003 컴퓨터가 Exchange Server 2003 서비스 팩 1 이전 버전에서 실행되고 있음을 나타냅니다.

참고:
Exchange 서비스 팩은 제거할 수 없기 때문에 서비스 팩을 새로 적용하기 전에 Exchange Server 컴퓨터에 대한 전체 백업을 해 두는 것이 매우 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 최종 버전의 Exchange Server 2003 서비스 팩 1을 http://go.microsoft.com/fwlink/?LinkId=29090에서 구합니다.

  2. http://go.microsoft.com/fwlink/?linkid=23235에서 Exchange Server 2003 릴리스 정보를 검토하십시오.

  3. 서비스 팩 1(http://go.microsoft.com/fwlink/?linkid=34272)에 포함된 업데이트를 검토합니다.

  4. Exchange Server 컴퓨터를 전체 백업합니다.

  5. Exchange Server 2003 서비스 팩 1을 적용합니다.

  6. Exchange Server 컴퓨터를 다시 전체 백업합니다.

Exchange Server 서비스 팩 설치에 대한 자세한 내용은 Microsoft 기술 자료 문서 328839, "HOWTO: Exchange 서비스 팩 및 핫픽스 적용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)을 참조하십시오.


이 Exchange 서버에서 Windows 2000 Server가 실행되고 있으나 boot.ini 파일에 /3GB 스위치가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 두 개의 Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Exchange Server 컴퓨터의 실제 메모리 양과 사용자 모드 프로세스에 할당된 가상 주소 공간의 양을 확인합니다. 다음 표에서는 Exchange Server Analyzer에서 계산하는 클래스와 키를 설명합니다.

클래스 | 키 | 설명
Win32_OperatingSystem | MaxProcessMemorySize | 프로세스에 할당할 수 있는 최대 메모리(킬로바이트)
Win32_OperatingSystem | OSProductSuite | 운영 체제에 추가로 설치 및 허가된 시스템 제품
Win32_ComputerSystem | TotalPhysicalMemory | 해당 컴퓨터에 설치되어 있는 RAM의 크기(바이트)

MaxProcessMemorySize 키 값이 2097024와 같지 않고 OSProductSuite 키 값이 Windows 2000 Server로 확인되면 Exchange Server Analyzer에서 오류를 표시합니다.

이 경고는 Boot.ini 파일에 /3GB 시작 스위치가 설정되어 있으므로 디렉터리 서버가 메모리를 최적으로 사용할 수 있게 구성되지 않았음을 나타냅니다. 이 스위치는 메모리가 1GB 이상이고 다음 운영 체제 중 하나를 실행 중인 Exchange 서버에서만 사용해야 합니다.

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

중요:
Windows 2000 Server에서는 /3GB 스위치를 사용하지 않아야 합니다. 지원되지 않아 응용 프로그램이나 운영 체제가 충돌할 수 있기 때문입니다. 또한 /3GB 스위치는 위 운영 체제 중 1GB 이상의 실제 메모리가 설치되어 있는 경우에만 지원됩니다.

Windows Server 2003에서 이 오류를 수정하려면 다음을 수행합니다.

  1. 내 컴퓨터를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다. 시스템 속성 대화 상자가 나타납니다.

  2. 고급 탭을 클릭합니다.

  3. 시작 및 복구 영역에서 설정 단추를 클릭합니다. 시작 및 복구 대화 상자가 나타납니다.

  4. 시스템 시작 영역에서 편집 단추를 클릭합니다. 그러면 메모장에서 Windows Boot.ini 파일이 열립니다.

  5. [Operating Systems] 섹션에 있는 모든 시작 줄에서 /3GB 스위치를 삭제합니다.

  6. 변경 내용을 저장하고 메모장을 닫습니다.

  7. 확인을 차례로 두 번 클릭하여 열려 있는 대화 상자를 닫은 후 디렉터리 서버를 다시 시작하여 변경 내용을 적용합니다.

Windows 2000 Server에서 이 오류를 수정하려면 다음을 수행합니다.

  1. Windows 탐색기에서 시스템 파티션을 탐색합니다.

  2. Boot.ini 파일을 볼 수 없는 경우는 폴더 옵션을 보호된 운영 체제 파일 숨기기로 설정했기 때문일 수 있습니다. 이러한 경우에는 Windows 탐색기 창에서 도구, 폴더 옵션, 보기 탭을 클릭합니다. 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 해제합니다. 경고 상자가 표시되면 예를 클릭합니다.

  3. 탐색기에서 Boot.ini 파일을 볼 수 있으면 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램을 클릭하고 Notepad를 선택하여 파일을 엽니다.

  4. /3GB를 제거하고 파일을 저장합니다.

  5. 디렉터리 서버를 다시 시작하여 변경 내용을 적용합니다.

/3GB 및 /USERVA 시작 스위치 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 297812, "4GT RAM 조정 기능 사용 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "시스템에서 4GT 조정의 영향 페이지 테이블 항목"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, "Boot.ini 파일에서 /USERVA 스위치를 사용하여 /3GB 구성을 조정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Exchange Server WMI를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-08-24

Microsoft® Exchange Server Analyzer Tool은 값이 Name 키 값이 설정되어 있는지 여부를 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. WMI 쿼리에 실패하고 Exchange Server가 Microsoft Windows NT® Server°4.0에서 실행되고 있지 않으면 Exchange Server Analyzer는 오류를 표시합니다.

이 오류에는 두 가지 원인이 있을 수 있습니다.

  • Exchange Server Analyzer를 실행하는 계정에 WMI 클래스를 쿼리할 수 있는 충분한 권한이 없습니다.

  • 네트워크 문제 때문에 Exchange Server Analyzer가 컴퓨터에 연결될 수 없습니다.

이 오류를 해결하려면 다음을 수행하십시오.

  1. Exchange Server 컴퓨터가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. PING 명령을 사용하여 Exchange Server 컴퓨터에 연결할 수 있는지 확인합니다.

  3. 방화벽이 있으면 RPC(원격 프로시저 호출) 포트가 차단되어 있는지 확인합니다.

  4. Exchange Server Analyzer를 실행하는 계정에 대한 사용 권한을 검토합니다. Exchange Server Analyzer를 실행하는 계정에는 검색 중인 각 Exchange Server에 대한 로컬 관리자 권한이 있어야 합니다.

    또는 Exchange Server Analyzer를 실행 중인 계정에 특정 WMI 사용 권한을 부여할 수 있습니다.

    1. Exchange 컴퓨터에서 컴퓨터 관리 MMC(Microsoft Management Console) 트리를 엽니다.

    2. 서비스 및 응용 프로그램에서 WMI 컨트롤을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

    3. WMI 컨트롤 속성 페이지에서 보안 탭을 클릭한 다음 루트를 확장합니다.

    4. CIMV2 폴더를 선택하고 보안을 클릭합니다.

    5. ROOT\CIMV2에 대한 보안 페이지에서 Exchange Server Analyzer를 실행하는 계정을 추가합니다.

  5. 위의 5단계에서 추가한 계정을 선택합니다. Selected_Account의 사용 권한에서 허용 열 아래의 원격으로부터 사용 가능 및 보안 읽기를 모두 선택한 다음 확인을 클릭합니다.

네트워크 연결 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제 해결 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

Exchange Server Best Practices Analyzer Tool 연결 문제 해결에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?LinkId=56285)를 참조하십시오.

포트 요구 사항에 대한 자세한 내용은 기술 자료 문서 832017, "Microsoft Windows 서버 시스템의 서비스 개요 및 네트워크 포트 요구 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)을 참조하십시오.


이 프런트 엔드 서버에서 Exchange System Attendant 서비스가 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange System Attendant 서비스의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. False 값은 Exchange System Attendant 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 Exchange System Attendant 서비스가 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 IsFrontEndServer 키 값을 확인할 때 root\MicrosoftExchangeV2 네임스페이스에서 Exchange_Server WMI 클래스를 검토합니다. False 값은 Exchange Server 컴퓨터가 프런트 엔드 서버가 아님을 나타냅니다. True 값은 Exchange Server 컴퓨터가 프런트 엔드 서버임을 나타냅니다.

Exchange Server Analyzer는 Exchange 프런트 엔드 서버의 Started 키 값이 False로 설정되어 있는 경우 경고를 표시합니다.

일반적으로 대부분의 Exchange 서버에서는 System Attendant 서비스가 항상 실행 중입니다. 그러나 일부 경우에는 System Attendant 서비스가 실행되지 않아도 됩니다. 예를 들어 프론트 엔드 서버에서 서버의 구성 내용을 변경하는 경우에만 System Attendant 서비스가 필요합니다.

Exchange Server는 받는 사람 정책, SMTP(Simple Mail Transfer Protocol) 가상 서버 구성, RPC(원격 프로시저 호출) over HTTP(Hypertext Transfer Protocol) 설정 및 사용자 사서함에 대한 정보를 비롯하여 Active Directory® 디렉터리 서비스에 해당 구성 정보를 모두 저장합니다. 그러나 SMTP는 인터넷 정보 서비스(IIS) 메타베이스에서 관련 설정을 읽습니다. Exchange에서 SMTP 및 RPC over HTTP 기능을 제공하는 데 필요한 정보를 IIS 메타베이스에 채우기 위해 시스템 수행자의 DS2MB(Directory Service To Metabase) 구성 요소는 Active Directory의 구성 정보를 IIS 메타베이스로 복제합니다. System Attendant가 실행되지 않으면 Active Directory에 저장되어 있는 Exchange Server 구성 설정 변경 내용이 Exchange Server의 IIS 메타베이스로 복사되지 않습니다. 구성을 변경하지 않는 경우와 SMTP 메시지를 처리하지 않는 경우에는 시스템 수행자 서비스를 중지 상태로 두어도 됩니다.

구성을 변경해야 하는 경우 System Attendant 서비스를 시작하여 구성을 변경하고 변경 내용이 IIS 메타베이스에 복제될 때까지 기다립니다. 변경 내용이 Active Directory에서 IIS 메타베이스로 복제되었는지 여부를 확인하려면 Exchange Server의 응용 프로그램 이벤트 로그에서 이벤트 원본이 MSExchangeMU이고 이벤트 ID가 1005인 항목이 세 개 있는지 살펴 보십시오. 이러한 이벤트는 DS2MB 복제가 완료된 후에 기록됩니다. 이러한 이벤트가 기록된 후에는 System Attendant 서비스를 중지할 수 있습니다.

프런트 엔드 서버에서 SMTP를 사용하고 있는 경우 외에는 System Attendant 서비스를 중지한 다음 사용하지 않도록 구성하는 것이 좋습니다. 프런트 엔드 서버에서 SMTP가 사용되고 있다면 다른 모든 Exchange Server 컴퓨터에서 메시지를 전달하고 SMTP 및 사서함 저장소 트랜잭션을 서비스하고 DS2MB 복제를 수행할 수 있도록 Exchange System Attendant 서비스를 실행해야 합니다.

사서함 또는 공용 폴더가 포함된 백 엔드 서버와 기타 Exchange 서버에서는 항상 Exchange System Attendant 서비스를 실행해야 합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. 오른쪽 창에서 Microsoft Exchange System Attendant 서비스로 스크롤하여 두 번 클릭합니다. 그러면 System Attendant 서비스 속성 대화 상자가 표시됩니다.

  3. 시작 유형 드롭다운 목록의 값을 자동으로 설정합니다.

  4. 시작을 클릭하여 System Attendant 서비스를 시작합니다.

  5. 확인을 클릭하여 변경 내용을 저장하고 System Attendant 서비스 속성 대화 상자를 닫습니다.

  6. 서비스 스냅인을 닫습니다.

시스템 수행자 서비스를 사용하지 않도록 설정하고 Exchange 서버의 보안을 설정하는 방법에 대한 자세한 내용은 다음 Exchange Server 항목을 참조하십시오.

  • "Securing Exchange 2000 Servers Based on Role"(http://go.microsoft.com/fwlink/?LinkId=35585)

  • "Exchange Server 2003 보안 강화 가이드"(http://go.microsoft.com/fwlink/?LinkId=47578)


Exchange 시스템 수행자 서비스가 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange System Attendant 서비스의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. False 값은 Exchange System Attendant 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 Exchange System Attendant 서비스가 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스에서 Exchange_Server WMI 클래스를 검토하여 IsFrontEndServer 키 값을 확인합니다. False 값은 Exchange Server 컴퓨터가 프런트 엔드 서버가 아님을 나타냅니다. True 값은 Exchange Server 컴퓨터가 프런트 엔드 서버임을 나타냅니다.

Exchange Server Analyzer는 프런트 엔드 서버가 아닌 Exchange Server 컴퓨터에 대해 Started 키 값이 False로 설정되어 있는 경우 경고를 표시합니다.

일반적으로 대부분의 Exchange 서버에서는 System Attendant 서비스가 항상 실행됩니다. 그러나 시스템 수행자 서비스를 실행할 필요가 없는 경우도 있습니다. 예를 들어 Exchange 2000 Server 또는 Exchange Server 2003 프런트 엔드 서버에서 서버 구성을 변경하는 경우에만 System Attendant 서비스가 필요합니다.

Exchange Server는 받는 사람 정책, SMTP(Simple Mail Transfer Protocol) 가상 서버 구성, RPC(원격 프로시저 호출) over HTTP(Hypertext Transfer Protocol) 설정 및 사용자 사서함에 대한 정보를 비롯하여 Active Directory® 디렉터리 서비스에 해당 구성 정보를 모두 저장합니다. 그러나 SMTP는 인터넷 정보 서비스(IIS) 메타베이스에서 설정을 읽습니다. Exchange에서 SMTP 및 RPC over HTTP 기능을 제공하는 데 필요한 정보를 IIS 메타베이스에 채우기 위해 시스템 수행자의 DS2MB(Directory Service To Metabase) 구성 요소는 Active Directory의 구성 정보를 IIS 메타베이스로 복제합니다. System Attendant가 실행되지 않으면 Active Directory에 저장되어 있는 Exchange Server 구성 설정 변경 내용이 Exchange Server IIS 메타베이스로 복사되지 않습니다. 구성을 변경하지 않는 경우와 SMTP 메시지를 처리하지 않는 경우에는 System Attendant 서비스를 중지 상태로 두어도 됩니다.

구성을 변경해야 하는 경우 System Attendant 서비스를 시작하여 구성을 변경하고 변경 내용이 IIS 메타베이스에 복제될 때까지 기다립니다. 변경 내용이 Active Directory에서 IIS 메타베이스로 복제되었는지 여부를 확인하려면 Exchange Server의 응용 프로그램 이벤트 로그에서 이벤트 원본이 MSExchangeMU이고 이벤트 ID가 1005인 항목이 세 개 있는지 살펴 보십시오. 이러한 이벤트는 DS2MB 복제가 완료된 후에 기록됩니다. 이들 이벤트가 기록되고 나면 System Attendant 서비스를 중지할 수 있습니다.

Exchange 2000 Server 또는 Exchange Server 2003 프런트 엔드 서버에서 SMTP를 사용하는 경우를 제외하고 System Attendant 서비스를 중지한 다음 System Attendant 서비스가 비활성화되도록 구성하는 것이 좋습니다. SMTP를 사용하는 Exchange 2000 Server 또는 Exchange Server 2003 프런트 엔드 서버와 다른 모든 Exchange Server 컴퓨터에서 메시지를 배달하고 SMTP 및 사서함 저장소 트랜잭션을 제공하고 DS2MB 복제를 수행하려면 Exchange System Attendant 서비스를 실행해야 합니다.

사서함 또는 공용 폴더가 포함된 백 엔드 서버와 기타 Exchange 서버에서는 항상 Exchange 시스템 수행자 서비스를 실행해야 합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. 오른쪽 창에서 아래로 스크롤하여 Microsoft Exchange System Attendant 서비스를 두 번 클릭합니다. 그러면 System Attendant 서비스 속성 대화 상자가 표시됩니다.

  3. 시작 유형 드롭다운 메뉴의 값을 자동으로 설정합니다.

  4. 시작을 클릭하여 System Attendant 서비스를 시작합니다.

  5. 확인을 클릭하여 변경 내용을 저장하고 System Attendant 서비스 속성 대화 상자를 닫습니다.

  6. 서비스 스냅인을 닫습니다.

System Attendant 서비스를 사용하지 않도록 설정하고 Exchange Server의 보안을 설정하는 방법에 대한 자세한 내용은 "Securing Exchange 2000 Servers Based on Role"(http://go.microsoft.com/fwlink/?linkid=35585)을 참조하십시오.


Exchmem 힙이 성능 문제를 나타냅니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 MSExchangeIS 성능 개체의 Exchmem Heap 성능 카운터를 분석하여 Exchange 서버 성능이 저하되었음을 확인했습니다. Exchange Server Analyzer Tool은 다음과 같은 Exchmem 카운터에 대해 보고합니다.

  • Exchmem: Number of heaps with memory errors 수가 0보다 크면 Exchange Server Analyzer는 경고를 보고합니다. 이 값이 5보다 크면 Exchange Server Analyzer는 오류를 보고합니다.

  • Exchmem: Number of memory errors 수가 500보다 크면 Exchange Server Analyzer는 오류를 보고합니다.

  • Exchmem: Number Additional Heaps 수가 3보다 크면 Exchange Server Analyzer는 오류를 보고합니다.

Store.exe 프로세스에서는 자체 힙 할당 메커니즘 및 구조를 사용합니다. 이를 Exchmem이라고 합니다. 시작 시에 Store.exe 프로세스에서는 여러 Exchmem 힙을 만듭니다. 기존 수가 완전히 사용되거나 할당에 성공할 수 있는 충분한 인접 메모리를 찾을 수 없는 지점으로 조각화되는 경우가 아니면 Store.exe는 힙 수를 늘리지 않습니다.

메모리 사용률 문제 또는 내부 조각화, 즉 Exchange 저장소의 가상 메모리 공간 내부에 있는 Exchmem 힙의 조각화가 있는 경우에는 Store.exe 프로세스에서 새 Exchmem 힙을 만듭니다.

일반적으로 Store.exe 프로세스에서 반복적으로 추가 힙을 만들면 전체 Exchange 저장소 가상 메모리가 조각화되거나 감소합니다. 위에 나열된 카운터를 추적하면 Exchmem 힙이 문제의 원인인지 또는 이로 인해 힙이 조각화되면서 성능이 감소하는지 여부를 확인할 수 있습니다.

경고나 오류를 해결하려면 다음을 수행합니다.

  • 최신 Exchange 저장소 업데이트를 다운로드하여 설치합니다.

    • 최신 Exchange Server 2003 다운로드를 보려면 Downloads for Exchange Server 2003 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

    • 최신 Exchange 2000 Server 다운로드를 보려면 Download for Exchange 2000 Server 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.

  • Store.exe 프로세스를 실행하고 있는 모든 응용 프로그램의 최신 업데이트를 다운로드하여 설치합니다. 경우에 따라 Store.exe 프로세스를 실행하는 타사 응용 프로그램으로 인해 힙 조각화가 발생할 수 있습니다.

  • 해당 서버에서 다른 서버로 사용자 사서함을 이동하여 서버 로드를 줄여 봅니다. 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.

  • 문제의 원인을 파악할 때까지 필요에 따라 다시 시작하여 메모리를 다시 설정할 수 있습니다.

추가 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange 서버 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


EXCHMEM.DLL이 Windows System32 폴더에 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 \Windows\System32\Exchmem.dll의 Version 키 값을 읽을 수 있는지 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer가 Version 키를 읽을 수 있으면 Exchmem.dll은 System32 폴더에 있는 것입니다.

또한 Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 6"이 포함되어 있으면 컴퓨터에서 Exchange 2000 Server 또는 Exchange Server 2003이 실행되고 있는 것입니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 유용한 정보 메시지를 표시합니다.

  • Exchmem.dll이 System32 폴더에 있습니다.

  • 컴퓨터에서 Exchange 2000 Server 또는 Exchange Server 2003을 실행 중입니다.

대개 Exchmem.dll 복사본 두 개가 한 Exchange 서버에 있지는 않습니다. 그러나 이전 릴리스의 제품에서 현재 위치로 업그레이드를 사용하면 두 번째 Exchmem.dll 파일이 추가될 수 있습니다. 두 가지 버전의 파일이 있으면 서비스 팩 설치 과정에서 설치에 실패할 수 있습니다. 문제를 방지하려면 \Windows\System32 폴더의 Exchmem.dll 파일 이름을 바꾸거나 제거하는 것이 좋습니다.

Exchmem.dll의 두 번째 버전을 제거하거나 이름을 바꾸려면 다음을 수행합니다.

  1. 모든 Exchange 서비스를 중지합니다.

  2. \Windows\System32 폴더에서 Exchmem.dll 파일의 이름을 바꾸거나 제거합니다.

  3. 모든 Exchange 서비스를 다시 시작합니다.


오류 발생
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-10-06

Microsoft® Exchange Server Analyzer Tool은 분석을 수행하기 위해 다음과 같은 여러 가지 특정 리소스에 액세스합니다.

  • Microsoft Active Directory® 디렉터리 서비스

  • Exchange Server 메시지 추적 센터

  • Microsoft Windows® 레지스트리

  • Microsoft WMI(Windows® Management Instrumentation)

  • 인터넷 정보 서비스(IIS) 메타베이스

Exchange Server Analyzer는 필요한 하나 이상의 리소스에 액세스할 수 없는 경우에 오류를 표시합니다.

이 오류는 이러한 하나 이상의 기본 리소스에 액세스할 수 없으므로 추가적인 분석이 불가능하다는 것을 나타냅니다.

이 오류를 해결하려면 Exchange Server Analyzer에서 제공하는 리소스별 오류 안내 및 링크 정보를 살펴보십시오.


서버에 대해 FCL 로깅을 사용할 수 없도록 설정되어 있음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-20

Microsoft® Exchange Server Analyzer Tool은 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인하기 위해 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 Version 5.5가 나타나 있으면 해당 컴퓨터에 Microsoft Exchange Server 버전 5.5이 실행되고 있는 것입니다. 문자열 값에 Version 6.0이 있으면 해당 컴퓨터에 Exchange 2000 Server가 실행되고 있는 것입니다. 문자열 값에 Version 6.5가 있으면 해당 컴퓨터에 Exchange Server 2003이 실행되고 있는 것입니다.

또한 Exchange Server Analyzer는 다음 레지스트리 항목에서 Disable Call Tracing 하위 키의 존재 여부를 쿼리하여 Microsoft Exchange FCL(함수 호출 로깅) 기능이 Exchange 서버에서 사용하도록 설정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange 서버는 Microsoft Exchange Information Store 서비스(Store.exe)의 내부 호출에 대한 성능을 추적할 수 있습니다. FCL을 사용하면 이러한 성능 문제의 근본 원인이 될 수 있는 함수 호출과 구성 요소를 파악할 수 있습니다.

Microsoft Exchange Information Store 서비스의 FCL 기능은 다음과 같은 구성 요소에 대한 관련 호출을 계속 추적합니다.

  • Local Security Authentication Server(Lsass.exe)

  • DSAccess

  • ESE(확장 가능한 저장소 엔진)

  • IMAIL

  • Virusscan

FCL은 Exchange 서버에서의 종료 문제 또는 Exchange Information Store 서비스(Store.exe)의 성능 저하나 무응답 상황 등의 상황에 대한 문제 시나리오의 데이터를 수집하는 오버헤드가 낮은 로깅입니다.

이 기능을 사용하도록 설정되면 FCL은 자동으로 함수 호출 데이터를 기록합니다. 프로덕션 서버에 대한 사용자 덤프 파일을 얻어야 하거나 디버거를 사용해야 하는 등의 사용자 개입이나 특정 구성은 필요하지 않습니다.

기본적으로 FCL은 Exchange Server 2003에서는 사용하도록 설정되어 있지만 Exchange 2000 Server에서는 이 기능을 사용하도록 명시적으로 설정해야 합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 유용한 정보 메시지를 표시합니다.

  • Exchange 2000 Server가 실행 중인 서버에 Disable Call Tracing 하위키가 없는 상태이거나 또는 Disable Call Tracing 하위키는 있으나 0이 아닌 값이 포함되어 있습니다.

  • Exchange Server 2003이 실행 중인 서버에 0이 아닌 값을 가진 Disable Call Tracing 하위키가 있습니다.

이 유용한 정보 메시지는 FCL을 사용하지 않음을 나타냅니다.

모든 Exchange 서버에 FCL을 사용하도록 설정하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 방법에 대한 내용이 포함되어 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
Exchange 2000 Server에 함수 호출 로깅을 사용하도록 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing을 탐색합니다.

  3. 오른쪽 창에서 Disable Call Tracing을 두 번 클릭합니다. Disable Call Tracing 하위키가 없으면 DWORD 값으로 새로 만듭니다.

  4. Disable Call Tracing 하위키의 값을 0으로 구성합니다.
참고:
기본적으로 FCL은 Exchange 2000 Server에서 사용하지 않도록 설정되어 있으며 이 값은 1입니다.
  1. 레지스트리 편집기를 닫습니다.

  2. Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

 Exchange Server 2003에 함수 호출 로깅을 사용하도록 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing을 탐색합니다.

  3. 오른쪽 창에서 Disable Call Tracing을 두 번 클릭합니다.

  4. Disable Call Tracing 하위키의 값을 0으로 구성합니다.
참고:
기본적으로 FCL은 Exchange Server 2003에서 사용하도록 설정되어 있으며 Disable Call Tracing 하위키가 만들어져 있습니다. 하위키의 값은 0이 아닌 다른 값으로 설정되어 이 기능을 사용하지 않도록 합니다.
  1. 레지스트리 편집기를 닫습니다.

  2. Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


페이지 테이블 항목(PTE) 수가 위험 임계값에 도달했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 FreeSystemPageTableEntries 개체의 현재 값을 확인할 때 Win32_PerfRawData_PerfOS_Memory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. FreeSystemPageTableEntries의 값이 5000보다 작거나 같으면 오류가 표시됩니다.

Microsoft Windows Server™ 2003 및 Windows 2000 Server는 설치된 실제 RAM의 크기에 관계없이 4GB의 메모리 주소 공간에 주소를 직접 지정할 수 있습니다. 프로세스 측면에서 볼 때 가상 주소의 각 요소는 개념적으로 실제 메모리의 바이트를 말합니다. VMM(Virtual Memory Manager)은 프로세서 MMU(Memory Manager Unit)와 함께 각 가상 주소를 해당 실제 주소로 변환하거나 매핑합니다. VMM은 RAM을 고정 크기의 페이지 프레임으로 분할하고 이러한 페이지 프레임에 대한 정보를 저장할 시스템 페이지 테이블 항목(PTE)을 만든 다음 매핑하는 방법으로 매핑을 수행합니다. 시스템 PTE는 디스크 I/O 하위 시스템 및 네트워크와 통신하는 데 사용되는 메모리의 소형 커널 모드 버퍼입니다. 각 PTE는 페이지 프레임을 나타내며 VMM이 페이지를 찾는 데 필요한 정보를 포함합니다.

4KB 페이지 크기를 사용하는 x86 기반 시스템에서 2GB의 주소 공간을 매핑하는 데는 최대 524,288(2GB/4KB)개의 PTE가 필요합니다. /3GB 스위치를 사용하는 비슷한 시스템에서는 3GB의 주소 공간을 매핑하는 데 786,432(3GB/4KB)개의 PTE가 필요합니다. 일반적인 시스템에서 이 공간은 다음과 같이 사용됩니다.

  • 최대 50,000개의 PTE(약 195MB의 주소 공간)가 일반적인 용도로 예약됩니다.

  • 나머지 PTE는 매핑 시스템 캐시, 하이퍼스페이스, 페이징 풀, 비페이징 풀, 크래시 덤프 영역 등에서 사용됩니다.

이 PTE 풀 크기는 시스템의 실제 메모리 양을 바탕으로 시스템 시작 시 자동으로 결정됩니다. 이 풀은 페이징 풀과 비페이징 풀 사이에서 압축되어 있으며 시스템의 실제 메모리 양에 따라 증가합니다.

시스템 PTE 풀은 과다하게 사용 및 조각화될 수 있습니다. 그 결과 드라이버를 로드할 수 없는 상황이 발생할 수 있습니다. 또한 시스템 PTE 풀이 완전히 고갈될 경우 시스템의 다른 부분 성능이 떨어지고 스레드가 만들어지지 않으며 시스템이 중지되고 충돌할 수 있습니다.

정상적인 Exchange Server 컴퓨터의 경우 항상 최소 8,000개의 시스템 PTE를 사용할 수 있어야 합니다. If the number of free system PTEs drops below 8,000 but remains above 5,000, the warning described in 사용할 수 있는 페이지 테이블 항목(PTE) 수가 경고 임계값에 도달했습니다. will be displayed. 사용 가능한 시스템 PTE 수가 5,000개 미만으로 줄어들면 이 오류가 표시됩니다.

이 문제를 해결하려면 다음 절차를 따라 SystemPages 레지스트리 값을 Exchange Server 컴퓨터 운영 체제에 맞게 구성하면 됩니다. RAM 크기가 1GB 이상인 Windows Server 2003에서 Exchange Server 2003 서비스 팩1(SP1)을 실행하는 경우 SystemPages 레지스트리 키를 0으로 설정하는 것이 좋습니다. Windows 2000 Server의 경우 이와는 달리 SystemPages를 10진수 값 31000으로 설정하도록 권장됩니다.

다음 절차를 수행한 후에 사용 가능한 시스템 PTE의 수를 모니터링해야 합니다. 성능 모니터라고도 하는 Windows System Monitor를 사용하여 Memory | Free System Page Table Entries 성능 카운터를 모니터링하면 됩니다. 레지스트리를 변경한 후에도 사용 가능한 시스템 PTE의 수가 부족하면 다음을 확인하여 Exchange Server 컴퓨터 구성이 최적화되었는지 확인해야 합니다.

  • 드라이버 일반적으로 드라이버가 제대로 작동하지 않으면 시스템 PTE 수가 부족하게 됩니다. 모든 하드웨어에 최신 드라이버를 사용하고 있는지 하드웨어 제조업체에 확인합니다. 기본 드라이버로 다운그레이드할 수 있습니다. 예를 들어 Exchange Server 같은 서버 기반의 응용 프로그램을 실행하는 컴퓨터는 일반적으로 모든 기능이 제공되는 최고급 비디오 드라이버를 필요로 하지 않습니다. 대부분의 경우 기본 드라이버만으로도 충분합니다. 고급 비디오 드라이버에서 기본 비디오 드라이버로 전환하면 사용 가능한 시스템 PTE의 수가 증가합니다.

  • 시스템 구성 Windows Server 2003 시스템에 1GB 이상의 실제 메모리가 설치되어 있는 경우 Microsoft 기술 자료 문서 823440, "Windows Server 2003 기반 시스템에 Exchange Server 2003을 설치한 경우 /3GB 스위치를 사용해야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440) 및 기술 자료 문서 810371, "Windows 2003 Server 기반 Exchange Server에서 /Userva 스위치 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)에 설명되어 있는 것처럼 해당 Boot.ini 파일이 /3GB 및 /USERVA=3030 스위치로 제대로 구성되어 있는지 확인해야 합니다.

  • 이벤트 로그 Exchange 서버의 응용 프로그램 이벤트 로그에서 오류 및 경고를 확인하십시오. 특히 MSExchangeIS 이벤트 9582(오류 및 경고), 9665(경고) 및 12880(오류)이 표시되는지 확인하십시오. 이벤트 9665가 표시되면 SystemPages가 최적의 성능으로 구성되어 있지 않은 것입니다. 이러한 이벤트에 대한 자세한 내용은 기술 자료 문서 325044, "HOWTO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)을 참조하십시오.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Windows 2000 Server를 실행하는 컴퓨터에서 이 오류를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management로 이동합니다.

  3. 오른쪽 창에서 SystemPages를 두 번 클릭합니다.

  4. 값 데이터 필드에 십진수 값 31000(31000은 16진수 7918의 10진수 표시이고 Regedit.exe는 16진수 값을 기본값으로 사용함)을 입력한 다음 확인을 클릭합니다.

  5. 변경 내용을 적용하려면 레지스트리 편집기를 닫고 컴퓨터를 다시 시작합니다.

Windows Server 2003의 원본 릴리스 버전을 실행하는 컴퓨터에서 이 오류를 수정하려면 다음을 수행합니다.

  • 실제 사용 가능한 시스템 페이지 테이블 항목을 확인하려면 Microsoft 기술 자료 문서 894067, "The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067)의 내용을 검토하십시오.

Windows Server 2003 SP1을 실행하는 컴퓨터에서 이 오류를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management로 이동합니다.

  3. 오른쪽 창에서 SystemPages를 두 번 클릭합니다.

  4. 값 데이터 필드에 0을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫습니다.

  6. 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. 시스템 속성 대화 상자가 나타납니다.

  7. 고급을 클릭합니다.

  8. 시작 및 복구 영역에서 설정을 클릭합니다. 시작 및 복구 대화 상자가 나타납니다.

  9. 시스템 시작 영역에서 편집을 클릭합니다. 그러면 메모장에서 Windows Boot.ini 파일이 열립니다.

  10. [Operating Systems] 섹션을 검토합니다.

    1. /3GB 스위치가 있지만 /USERVA=3030 스위치가 없는 경우에는 /3GB /USERVA=3030으로 구성되도록 /USERVA=3030 스위치를 시작 줄에 추가합니다.

    2. /3GB /USERVA=3030 스위치가 이미 구성되어 있으면 /USERVA 스위치 값을 /USERVA=2970으로 변경합니다.

  11. 변경 내용을 저장하고 메모장을 닫습니다.

  12. 확인을 두 번 클릭하여 열려 있는 대화 상자를 닫은 다음 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server의 메모리 최적화에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 894067, "The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067)

  • 325044, "HOWTO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 823150, "Echange Server 2003 가상 메모리 문제를 해결하기 위해 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823150)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, "The effects of 4GT tuning on System Page Table Entries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


사용할 수 있는 페이지 테이블 항목(PTE) 수가 경고 임계값에 도달했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 FreeSystemPageTableEntries 개체의 현재 값을 확인할 때 Win32_PerfRawData_PerfOS_Memory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. FreeSystemPageTableEntries 값이 5000보다 크지만 8000보다 작거나 같을 경우 경고가 표시됩니다.

Microsoft Windows Server™ 2003 및 Windows 2000 Server는 설치된 실제 RAM의 크기에 관계없이 최대 4GB의 메모리 주소 공간에 주소를 직접 지정할 수 있습니다. 프로세스 측면에서 볼 때 가상 주소의 각 요소는 개념적으로 실제 메모리의 바이트를 말합니다. VMM(Virtual Memory Manager)은 프로세서 MMU(Memory Manager Unit)와 함께 각 가상 주소를 해당 실제 주소로 변환하거나 매핑합니다. VMM은 RAM을 고정 크기의 페이지 프레임으로 분할하고 이러한 페이지 프레임에 대한 정보를 저장할 시스템 페이지 테이블 항목(PTE)을 만든 다음 매핑하는 방법으로 매핑을 수행합니다. 시스템 PTE는 디스크 I/O 하위 시스템 및 네트워크와 통신하는 데 사용되는 메모리의 소형 커널 모드 버퍼입니다. 각 PTE는 페이지 프레임을 나타내며 VMM이 페이지를 찾는 데 필요한 정보를 포함합니다.

4KB 페이지 크기를 사용하는 x86 기반 시스템에서 2GB의 주소 공간을 매핑하는 데는 최대 524,288(2GB/4KB)개의 PTE가 필요합니다. /3GB 스위치를 사용하는 비슷한 시스템의 경우 3GB의 주소 공간을 매핑하는 데에는 786,432(3GB/4KB)개의 PTE가 필요합니다. 일반적인 시스템에서 이 공간은 다음과 같이 사용됩니다.

  • 최대 50,000개의 PTE(약 195MB의 주소 공간)가 일반적인 용도로 예약됩니다.

  • 나머지 PTE는 매핑 시스템 캐시, 하이퍼스페이스, 페이징 풀, 비페이징 풀, 크래시 덤프 영역 등에서 사용됩니다.

이 PTE 풀 크기는 시스템의 실제 메모리 양을 바탕으로 시스템 시작 시 자동으로 결정됩니다. 이 풀은 페이징 풀과 비페이징 풀 사이에 위치하며 시스템의 실제 메모리 양에 따라 증가합니다.

시스템 PTE 풀은 과다하게 사용 및 조각화될 수 있습니다. 이로 인해 드라이버가 로드되지 못할 수 있습니다. 시스템 PTE 풀이 완전히 고갈되면 시스템의 다른 부분에 대한 성능도 저하되므로 스레드가 생성되지 않으며 시스템이 중단되고 잠재적으로 시스템이 충돌할 수 있습니다.

정상적인 Exchange Server 컴퓨터의 경우 항상 최소 8,000개의 시스템 PTE를 사용할 수 있어야 합니다. 사용 가능한 시스템 PTE 수가 5,000 미만으로 떨어지면 페이지 테이블 항목(PTE) 수가 위험 임계값에 도달했습니다.에 설명된 오류가 표시됩니다. 사용 가능한 시스템 PTE 수가 8,000 미만으로 떨어지지만 5,000 이상으로 유지되면 경고가 표시됩니다.

이 문제를 해결하려면 다음 절차를 따라 SystemPages 레지스트리 값을 Exchange Server 컴퓨터 운영 체제에 맞게 구성하면 됩니다. RAM 크기가 1GB 이상인 Windows Server 2003에서 Exchange Server 2003 서비스 팩1(SP1)을 실행하는 경우 SystemPages 레지스트리 키를 0으로 설정하는 것이 좋습니다. Windows 2000 Server의 경우 이와는 달리 SystemPages를 10진수 값 31,000으로 설정하도록 권장됩니다.

다음 절차를 수행한 후에 사용 가능한 시스템 PTE의 수를 모니터링해야 합니다. 이것을 수행하려면 성능 모니터라고도 하는 Windows System Monitor를 사용하여 Memory | Free System Page Table Entries 성능 카운터를 모니터링합니다. 이 문서에 설명된 대로 레지스트리를 변경한 후에도 사용 가능한 시스템 PTE의 수가 부족하면 다음을 확인하여 Exchange Server 컴퓨터 구성이 최적화되었는지 확인해야 합니다.

  • 드라이버 일반적으로 드라이버가 제대로 작동하지 않으면 시스템 PTE 수가 부족하게 됩니다. 하드웨어 제조업체에 문의하여 모든 하드웨어에 대해 최신 드라이버를 사용하고 있는지 확인하십시오. 기본 드라이버로 다운그레이드할 수 있습니다. 예를 들어 Exchange Server 같은 서버 기반의 응용 프로그램을 실행하는 컴퓨터는 일반적으로 모든 기능이 제공되는 최고급 비디오 드라이버를 필요로 하지 않습니다. 대부분의 경우 기본 드라이버만으로도 충분합니다. 고급 비디오 드라이버에서 기본 비디오 드라이버로 전환하면 사용 가능한 시스템 PTE의 수가 증가합니다.

  • 시스템 구성 Windows Server 2003 시스템에 1GB 이상의 실제 메모리가 설치되어 있는 경우 Microsoft 기술 자료 문서 823440, "Windows Server 2003 기반 시스템에 Exchange Server 2003을 설치한 경우 /3GB 스위치를 사용해야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440) 및 기술 자료 문서 810371, "XADM: Windows 2003 Server 기반 Exchange Server에서 /Userva 스위치 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)에 설명된 대로 해당 Boot.ini 파일이 /3GB 및 /USERVA=3030 스위치로 제대로 구성되어 있는지 확인해야 합니다.

  • 이벤트 로그 Exchange 서버의 응용 프로그램 이벤트 로그에서 오류 및 경고를 확인하십시오. 특히 MSExchangeIS 이벤트 9582(오류 및 경고), 9665(경고) 및 12880(오류)이 표시되는지 확인하십시오. 이벤트 9665가 표시되면 SystemPages가 최적의 성능으로 구성되어 있지 않은 것입니다. 이러한 이벤트에 대한 자세한 내용은 기술 자료 문서 324044, "HOWTO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)을 참조하십시오.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Windows 2000 Server를 실행하는 컴퓨터에서 이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management를 탐색합니다.

  3. 오른쪽 창에서 SystemPages를 두 번 클릭합니다.

  4. 값 데이터 필드에 십진수 값 31000(31000은 16진수 7918의 10진수 표시이고 Regedit.exe는 16진수 값을 기본값으로 사용함)을 입력한 다음 확인을 클릭합니다.

  5. 변경 내용을 적용하려면 레지스트리 편집기를 닫고 컴퓨터를 다시 시작합니다.

Windows Server 2003의 원래 릴리스 버전을 실행하는 컴퓨터에서 이 경고를 해결하려면 다음을 수행합니다.

  • 실제 사용 가능한 시스템 페이지 테이블 항목을 확인하려면 Microsoft 기술 자료 문서 894067, "The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067)의 내용을 검토하십시오.

Windows Server 2003 SP1을 실행하는 컴퓨터에서 이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management를 탐색합니다.

  3. 오른쪽 창에서 SystemPages를 두 번 클릭합니다.

  4. 값 데이터 필드에 0을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫습니다.

  6. 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. 시스템 속성 대화 상자가 나타납니다.

  7. 고급을 클릭합니다.

  8. 시작 및 복구 영역에서 설정을 클릭합니다. 시작 및 복구 대화 상자가 나타납니다.

  9. 시스템 시작 영역에서 편집을 클릭합니다. 그러면 메모장에서 Windows Boot.ini 파일이 열립니다.

  10. [Operating Systems] 섹션을 검토합니다.

    1. /3GB 스위치가 있지만 /USERVA=3030 스위치가 없는 경우에는 /3GB /USERVA=3030으로 구성되도록 /USERVA=3030 스위치를 시작 줄에 추가합니다.

    2. /3GB /USERVA=3030 스위치가 이미 구성되어 있으면 /USERVA 스위치 값을 /USERVA=2970으로 변경합니다.

  11. 변경 내용을 저장하고 메모장을 닫습니다.

  12. 확인을 두 번 클릭하여 열려 있는 대화 상자를 닫은 다음 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server의 메모리 최적화에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 894067, "The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067)

  • 325044, "HOWTO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 823150, "Echange Server 2003 가상 메모리 문제를 해결하기 위해 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823150)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, "The effects of 4GT tuning on System Page Table Entries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


프런트 엔드 서버에서 사이트 복제 서비스를 실행하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 서버의 IsFrontEndServer 값을 확인할 때 Exchange Server Microsoft WMI(Windows® Management Instrumentation) 개체(Exchange_Server 클래스)를 쿼리합니다. 값이 True이면 해당 Exchange 서버가 프런트 엔드 서버 역할을 합니다. 또한 Exchange Server Analyzer Tool은 MSExchangeSRS WMI 개체의 Started 속성 값을 확인할 때 해당 개체(Win32_Service 클래스)를 쿼리합니다. 값이 True이면 이 서버에서 사이트 복제 서비스가 실행되고 있는 것입니다.

Exchange 서버가 프런트 엔드 서버로 지정되고 이 서버에 사이트 복제 서비스의 실행 중인 인스턴스가 있으면 경고가 표시됩니다.

Exchange는 토폴로지에 Exchange Server 버전 5.5와 Exchange 2000 Server 또는 Exchange Server 2003을 실행 중인 서버가 포함되어 있으면 사이트 복제 서비스를 사용합니다. 최신 버전의 Exchange는 이 서비스를 사용하여 서버 구성 정보를 Exchange Server 5.5 디렉터리와 호환되는 형식으로 Exchange Server 5.5 서버로 복제할 수 있으며 Exchange Server 5.5 디렉터리에서 복제한 구성 정보를 올바르게 처리하여 Active Directory® 디렉터리 서비스에 저장할 수 있습니다. 프런트 엔드 서버와 백 엔드 서버를 모두 사용할 수 있도록 토폴로지를 구성한 경우에는 백 엔드 서버에서만 사이트 복제 서비스를 실행해야 합니다. Exchange 2000 Server 서비스 팩 2에서는 사이트 복제 서비스가 프런트 엔드 서버에서 올바르게 작동하지 않으므로 문제가 발생할 수 있습니다.

이 문제를 해결하려면 프런트 엔드 서버를 백 엔드 서버로 변환하고 새 프런트 엔드 서버를 구성합니다. 서버에서 사이트 복제 서비스를 제거하지 않는 것이 좋습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 새 프런트 엔드 서버를 구성합니다.

  2. 문제가 발생한 프런트 엔드 서버의 Exchange System Manager에 있는 서버에서 문제가 발생한 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 프런트 엔드 서버로 사용 확인란의 선택을 해제합니다.

프런트 엔드 서버와 사이트 복제 서비스에 대한 자세한 내용은 Microsoft 기술 자료 문서 313646, "Services are Disabled on Front-end Servers After an Exchange 2000 Server SP2 Upgrade"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313646)를 참조하십시오.


GAPI32.DLL 파일이 bin 폴더에 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더 및 \Exchsrvr\bin 폴더 모두에서 확인)

  • Mapi32.dll(System32 폴더 및 \Exchsrvr\bin 폴더 모두에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


system32 폴더에 GAPI32.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 해결하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


GlobalFlag가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 GlobalFlag 항목의 값을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

Exchange Server Analyzer는 GlobalFlag 값이 0 또는 Null 이외의 값으로 구성되어 있는 경우 경고를 표시합니다.

GlobalFlag 레지스트리 값 설정은 특정 프로세스에 대해 디버깅 옵션이 설정되어 있는지 확인하는 비트 마스크입니다. 이 경우 Exchange Server Analyzer는 특히 다음과 같은 다양한 Exchange 구성 요소에 대해 디버깅 옵션이 설정되어 있는지 확인합니다.

  • STORE.EXE - 정보 저장소 프로세스

  • MAD.EXE - 시스템 수행자 프로세스

  • INETINFO.EXE - IIS 관리 및 상위 프로세스

  • EMSMTA.EXE - 메시지 전송 에이전트 프로세스

Microsoft 기술 지원 서비스의 도움을 받아 디버깅 또는 문제점 추적을 수행하지 않을 경우 항상 GlobalFlag 값을 0으로 설정하거나 완전히 삭제하는 것이 좋습니다. 두 경우의 결과는 같습니다.

기본적으로 GlobalFlag 레지스트리 값은 존재하지 않으므로 STORE.EXE 프로세스나 기타 프로세스의 디버깅이 필요할 경우 수동으로 추가해야 합니다. Windows CD의 \Support 폴더에 있는 Microsoft Windows Server™ 2003 지원 도구에 포함되어 있는 Gflags 도구를 사용할 수 있습니다. 또는 수동으로 이 값을 0으로 설정하거나 레지스트리 편집기를 사용하여 GlobalFlag 값을 완전히 삭제할 수 있습니다. 이 문서에서는 두 가지 절차에 대해 설명합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Gflags를 사용하여 이 오류를 수정하려면 다음을 수행합니다.

  1. 시작, 실행을 차례로 클릭한 다음 옵션 필드에 GFlags를 실행합니다. 글로벌 플래그 사용자 인터페이스가 나타납니다.

  2. Image File Name 필드에 STORE.EXE를 입력합니다.

  3. Image File Options를 선택합니다.

  4. 모든 확인란의 선택을 해제하고 Apply를 클릭합니다.

  5. 이 문서에 나열된 각각의 Exchange 프로세스에 대해 2-4단계를 반복합니다.

  6. OK를 클릭하여 GFlags 도구를 끝낸 후 영향 받은 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집기를 사용하여 이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE를 탐색합니다.

  3. GlobalFlag라는 값을 삭제합니다.

  4. 이 문서에 나열된 각각의 Exchange 프로세스에 대해 2-3단계를 반복합니다.

  5. 레지스트리 편집기를 닫고 영향 받은 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


다수의 ACL 업그레이드 오류가 발생합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 ACLUpgradefailures 키의 현재 값을 확인할 때 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. ACLUpgradefailures 키는 MSExchangeIS 성능 개체의 ACL Upgrade: failures 성능 카운터를 나타냅니다.

Exchange Server Analyzer는 ACLUpgradefailures 키 값이 500보다 큰 경우 경고를 표시합니다.

이 경고는 Exchange 서버가 많은 ACL(액세스 제어 목록) 업그레이드 오류를 보고했음을 나타냅니다. 과도한 ACL 업그레이드 오류로 인해 정보 저장소 프로세스(store.exe)에서 임의로 중지를 비롯하여 심각한 성능 문제가 발생할 수 있습니다.

ACL 업그레이드 오류는 여러 가지 이유로 인해 발생할 수 있으며 다음과 같은 조건에 해당하면 발생할 수 있습니다.

  • 혼합 모드의 Exchange 조직에서 Exchange Server 버전 5.5 일관성 조정자는 ADC(Active Directory Connector) 서버를 구현하기 전에는 실행되지 않았습니다. Exchange Server 5.5 일관성 조정자는 연결되지 않은 ACL을 제거합니다.

  • Active Directory 복제가 제대로 작동하지 않습니다.

  • Active Directory Connector 복제는 Exchange Server 5.5에서 Active Directory로 계정을 제대로 복제하지 않습니다.

  • 사용자 계정의 마이그레이션이 잘못되었습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Microsoft 기술 자료 문서 812963, "Using the Ignore Zombie Users Registry Key"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963)를 검토하십시오.

  2. Ignore Zombie Users 레지스트리 키 사용의 의미를 이해한 후에 신중하게 키를 추가합니다.

  3. Exchange Server Analyzer를 실행하거나 ACL Upgrade: failures 성능 카운터를 모니터하여 과도한 ACL 업그레이드 오류를 찾습니다.


사용량이 높은 Exmon 사용자
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-21

Microsoft® Exchange Server Analyzer Tool은 ExMon(Exchange Server User Monitor) 도구를 사용하여 사용자나 프로세스(또는 사용자 그룹이나 프로세스 그룹)가 현재 서버 로드 중 매우 많은 부분의 원인인지 여부를 확인합니다.

다음은 ExMon에서 사용하는 몇 가지 시나리오입니다.

  • 클라이언트 제한

  • 높은 대량 RPC(원격 프로시저 호출) 작업

  • 높은 RPC 동기화 작업

  • 많은 수의 클라이언트 온라인 작업

  • 사용자 보기 작업

다음 섹션에서는 각 시나리오의 자세한 정보와 각 시나리오에 대해 권장되는 작업을 설명합니다.

클라이언트 제한

이 시나리오에서 ExMon RPC 데이터를 통해 클라이언트 컴퓨터 제한으로 인해 이 서버에 많은 로드가 발생함을 알 수 있습니다. MAPI의 컨텍스트에서 제한은 Restrict라는 MAPI 작업을 참조합니다. 이 작업은 특정 기준에 맞는 항목을 선택하는 데 사용됩니다. Restrict 작업은 Exchange에서 폴더 또는 폴더 집합(실제로는 관련 기준을 가진 데이터베이스 테이블)에 보기를 만들도록 요청하는 프로세스의 일부입니다. 폴더 또는 폴더 집합의 보기에 이미 일치하는 제한이 있을 경우 Exchange는 기존 보기를 사용하여 사용자 요청을 처리합니다. 보기에 일치하는 제한이 없는 경우 Exchange는 새 보기를 만듭니다. 보기를 만드는 것은 기존 보기를 사용하는 것보다 훨씬 많은 비용이 듭니다.

많은 사서함이 이동한 후에는 클라이언트 제한으로 인해 잠시 동안 훨씬 많은 비용이 듭니다. move-mailbox 작업을 수행하면 서버에서 폴더에 인덱스를 다시 작성합니다. 따라서 클라이언트가 새 서버의 폴더를 처음 볼 때 모든 제한을 새로 만들어서 그 결과 성능이 저하될 수 있습니다. 최근에 사서함을 옮기지 않았다면 다음 사항을 검사합니다.

  • 다른 MAPI 응용 프로그램을 클라이언트 컴퓨터에 설치하지 않았는지 검사합니다. Microsoft Office Outlook® 추가 기능 또는 다른 MAPI 응용 프로그램으로 인해 너무 많은 제한을 만들어야 하는 경우가 있습니다.

  • 조직 전체에 맞게 사서함 크기를 조정하고 제한을 설정했는지 검사합니다.

사서함 크기 및 항목 수에 대한 자세한 내용은 Microsoft Exchange 팀 블로그, "Recommended Mailbox Size Limits"(http://go.microsoft.com/fwlink/?linkid=55097)를 참조하십시오.

높은 대량 RPC 작업

높은 대량 RPC 작업을 예로 들면 한 번의 작업으로 수 백 또는 수 천개의 항목을 이동 또는 삭제하거나 항목에 대한 속성을 설정(예: read flag)하는 것입니다. 이러한 유형의 작업을 수행하면 잠시 동안 서버 성능이 저하될 수 있습니다. 높은 대량 RPC 작업을 자주 수행하여 서버에서 디스크 또는 프로세서 병목 현상이 발생하는 경우 같은 서버에 있는 다른 사용자의 Outlook 성능이 저하됩니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 사서함 제한을 설정했는지 확인합니다.

  2. 사용자에게 항목을 .pst 파일에 보관하도록 권장합니다.

    참고:
    자주 사용하는 폴더에는 항목이 5,000개 미만 있는 것이 좋습니다.

높은 RPC 동기화 작업

높은 RPC 동기화 작업은 현재 많은 사용자가 항목을 동기화하고 있음을 나타냅니다. 그 결과 서버 로드가 증가합니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 캐시된 Exchange 모드에서 Outlook을 실행하고 있는 클라이언트 컴퓨터 수에 따라 Exchange 서버를 조정했는지 확인합니다. 자세한 내용은 Exchange Server 2003 RPC over HTTP Deployment Scenarios(http://go.microsoft.com/fwlink/?LinkId=47577)를 참조하십시오.

  • 캐시된 Exchange 모드 클라이언트 요청을 줄이면 높은 RPC 동기화 작업으로 인한 성능 문제를 막을 수도 있습니다. 자세한 내용은 Microsoft 기술 자료 문서 818484, "Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=818484)을 참조하십시오.

많은 수의 클라이언트 온라인 작업

사용자 간에 분산되어 있는 높은 로드로 인해 성능 문제가 발생할 때 Exchange에서 예외적인 스파이크가 일어나는 경우도 있습니다. 이는 조직이 커지는 데 반해 계획이 적절하지 않기 때문일 수 있습니다. 조직 조정 시 Microsoft의 유용한 정보를 따랐는데도 많은 클라이언트 온라인 작업으로 인해 성능 저하가 발생한다면 조직의 사용자가 타사 MAPI 응용 프로그램이나 Outlook 플러그 인을 실행하고 있을 수 있습니다.

사용자 보기 작업

ExMon RPC 데이터를 통해 사용자가 새로운 보기를 작성하고 있으며 이로 인해 서버에 높은 로드가 발생함을 알 수 있습니다. 이 시나리오에서는 RPC CPU 사용률 중 상당한 비율이 한 사용자 계정에 의한 것입니다.

이 문제를 조사하려면 다음 시나리오를 가정해 보십시오.

  • 사용자가 항목 수가 많은 폴더에 작업을 수행하고 있을 수 있습니다. 이 문제를 해결하려면 사용자에게 단일 폴더의 항목 수를 줄이도록 권장합니다. 일반적으로 폴더에 항목이 2,000개 미만 있어야 합니다.

  • 사용자가 과도한 로드를 발생시키는 잘못 작성된 응용 프로그램을 실행하고 있을 수 있습니다. 이 문제를 해결하려면 해당 응용 프로그램을 제거합니다.

추가 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 사서함 크기 및 항목 수에 대한 자세한 내용은 Microsoft Exchange 팀 블로그, "Recommended Mailbox Size Limits"(http://go.microsoft.com/fwlink/?linkid=55097)를 참조하십시오.

  • 사서함 제한에 대한 자세한 내용은 Microsoft Exchange 팀 블로그, "Putting the Restrictions on Restrictions"(http://go.microsoft.com/fwlink/?LinkId=55098)를 참조하십시오.

  • ExMon에 대한 자세한 내용은 ExMon 다운로드 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=54474)를 참조하십시오.


IIS가 64비트 컴퓨터에서 32비트 프로세스를 만들고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-05-03

Microsoft Exchange Server Analyzer Tool은 Exchange Server 2007을 실행 중인 모든 64비트 Windows Server 2003 서비스 팩 1(SP1) 서버에서 w3svc/AppPools/Enable32BitAppOnWin64 메타베이스 속성의 값에 대해 IIS(인터넷 정보 서비스) 메타베이스를 쿼리하여 IIS가 32비트 작업자 프로세스를 만들도록 구성되어 있는지 확인합니다.

속성 값이 1(true)인 경우 IIS가 32비트 작업자 프로세스를 만들도록 구성되어 있음을 나타냅니다. 그리고 속성 값이 0(false)인 경우 IIS가 64비트 작업자 프로세스를 만들도록 구성되어 있음을 나타냅니다.

Exchange Analyzer는 w3svc/AppPools/Enable32BitAppOnWin64 메타베이스 속성 값이 1(true)로 설정되어 있으면 오류를 표시합니다. 이 오류는 Exchange 2007을 실행 중인 64비트 Windows 서버에서 IIS가 32비트 작업자 프로세스를 만들도록 구성되어 있음을 나타냅니다. IIS가 이와 같이 구성되어 있는 경우 Exchange 2007 가상 디렉터리가 작동하지 않습니다.

이 오류를 해결하려면 Exchange 2007을 실행 중인 64비트 Windows Server 2003(SP1) 서버에서 IIS가 64비트 작업자 프로세스를 만들도록 구성하십시오.

IIS를 64비트 모드로 전환하려면 다음을 수행합니다.

  1. 명령 프롬프트를 엽니다.

  2. 다음을 입력합니다.

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. Enter 키를 누릅니다.

64비트 Windows Server 2003 SP1 서버에서 IIS 6.0 32비트 작업자 프로세스를 실행하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 895976, "Windows Server 2003 SP1 enables WOW64 compatibility for 32-bit Web applications in IIS 6.0"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=895976)을 참조하십시오.


커널 메모리 향상
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 시스템 메모리 수준을 테스트하여 허용 범위 내에 있는지 확인합니다. Exchange Server Analyzer는 Perfmon(성능 모니터) 커널 메모리 카운터가 적절한 수준 아래일 경우 문제 해결 메시지를 표시합니다.

Microsoft Windows® 커널 메모리는 페이징 풀과 비페이징 풀 메모리 및 시스템 페이지 테이블 항목을 포함하여 몇 개의 메모리 구조로 구성됩니다. 커널 메모리라고도 하는 이러한 메모리 구조는 Exchange와 같은 응용 프로그램용 환경을 제공하기 위해 운영 체제에서 사용됩니다. 정상적인 Exchange 배포를 유지 관리하려면 커널 메모리를 모니터링해야 합니다.

커널 메모리 최적화 작업은 복잡할 수 있습니다. 문제 해결 정보 및 커널 메모리 사용에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오. 서버 리소스를 늘리는 한 가지 방법은 서버의 사용자 사서함 로드를 확인하는 것입니다. 사용자 사서함을 다른 서버로 이동하여 서버 로드를 줄이고 문제가 해결되었는지 확인하십시오. 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.

자세한 정보

Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

사용자 사서함을 이동하여 서버 로드를 줄이는 것에 대한 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.


사용자 메모리 향상
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-28

Microsoft® Exchange Server Analyzer Tool에서 사용자 메모리 성능 카운터가 Exchange 서버의 올바른 임계값을 초과하는 것을 확인했습니다. Exchange Server Analyzer는 Memory 성능 개체의 Available Mbytes 성능 카운터와 Memory Pages/sec 카운터를 쿼리합니다. 서버의 메모리가 부족하거나 서버의 페이징이 높으면 서버는 메모리 병목 현상을 나타냅니다.

Available MBytes 성능 카운터는 프로세스나 시스템용으로 즉시 할당할 수 있는 실제 메모리의 양(MB)을 표시합니다. 사용할 수 있는 메모리 양은 대기 중(캐시 상태), 사용 가능 및 0으로 채워진 페이지 목록에 할당된 메모리의 합과 같습니다.

Memory Pages/sec 성능 카운터는 하드 페이지 폴트를 해결하기 위해 페이지를 디스크에서 읽거나 디스크에 쓰는 속도를 나타냅니다. 서버가 메모리를 사용할수록 사용 가능한 메모리가 부족하게 되므로 운영 체제에서 프로세스의 작업 집합을 지우고 보다 적극적으로 페이지 파일을 사용하기 시작합니다. 디스크 작업이 메모리 작업보다 시간이 더 걸리므로 페이지 파일의 사용은 전체 성능에 영향을 미칩니다. 이 카운터는 시스템 전체의 지연을 초래하는 폴트 유형의 기본 표시기입니다. 여기에는 파일 시스템 캐시에서 페이지 폴트를 해결하기 위해 검색된 페이지를 포함합니다. 일반적으로 응용 프로그램에서 이러한 페이지를 요청합니다. 이 카운터는 항상 1,000개 미만이어야 합니다.

Available Mbytes 성능 카운터에서 사용 가능한 메모리가 50MB 미만을 나타내거나 메모리 페이지를 디스크에 기록하거나 디스크에서 읽어 오는 속도가 초당 1,000페이지를 초과하면 Exchange Server Analyzer에서 오류를 표시합니다.

다음 목록은 사용자 공간 메모리의 성능을 향상시킬 수 있는 방법을 설명합니다.

이 문제를 해결하려면 다음을 수행합니다.

  1. Microsoft Exchange Server Analyzer Tool(http://go.microsoft.com/fwlink/?LinkId=34705)을 사용하여 서버의 메모리 설정이 적절하게 구성되어 있는지 확인합니다.

  2. 불필요한 소프트웨어를 제거합니다. Exchange에 사용할 수 있는 메모리 리소스를 늘리려면 모니터링 기능이나 꼭 필요하지 않은 서비스를 수행하는 타사 소프트웨어 도구를 제거합니다. 성능 스냅인(Perfmon.msc)을 사용하면 응용 프로그램에서 사용하고 있는 메모리 양을 파악할 수 있습니다.

  3. 서버 유지 관리 작업은 사용량이 많지 않은 시간에 실행합니다. 사용량이 많은 시간에 유지 관리 도구(예: Eseutil) 또는 작업(예: 사서함 관리)을 실행하면 Exchange에서 사용할 수도 있는 메모리를 사용하게 됩니다. 이러한 도구와 작업은 사용량이 많지 않은 시간이나 사용량이 적은 시간에 실행하는 것이 좋습니다.

  4. 영향을 받는 서버에서 다른 서버로 사용자 사서함을 옮겨서 서버 로드를 줄입니다. 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.

추가 정보

자세한 내용은 다음 Microsoft 리소스를 참조하십시오.

  • 다른 서버로 사용자 사서함 이동

  • Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 성능 및 확장성 가이드 (http://go.microsoft.com/fwlink/?LinkId=47576) 의 "Exchange Server 2003의 메모리 사용 최적화"

  • Microsoft Exchange Server Best Practices Analyzer Tool(http://go.microsoft.com/fwlink/?LinkId=34705)

  • Microsoft 기술 자료 문서 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • "Exchange 2003 Memory Configuration change for Windows 2003 (PAE Support)"(http://go.microsoft.com/fwlink/?LinkId=54979)

    참고:
    블로그의 내용과 해당 URL은 예고 없이 변경될 수 있습니다.


가상 메모리 향상
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 서버에 가상 메모리 조각화 문제가 있음을 확인했습니다.

32비트 Microsoft Windows® 시스템의 경우 두 가지 메모리가 있습니다.

  • 실제 메모리 시스템에 설치된 실제 메모리 양

  • 가상 메모리 주소 공간 가상화된 4GB 메모리 공간

해당 시스템에 설치되어 있는 실제 메모리 양에 관계없이 전체 가상 주소 공간 크기는 항상 4GB로 동일합니다. 모든 32비트 응용 프로그램에 적용되는 것은 아니지만 Exchange Server의 경우 가상 주소 공간은 가상 메모리와 동일합니다. 즉, 두 용어를 같은 의미로 사용할 수 있습니다.

Exchange 저장소는 정상적인 작업 중에 가상 메모리를 반복적으로 할당, 사용 및 할당 취소합니다. 가상 메모리를 할당하고 사용한 다음 할당을 취소하는 것을 자주 하면 가상 메모리가 조각화될 수 있습니다. 가상 메모리 조각화는 시간이 지나면서 발생할 수 있는 파일 시스템 조각화와 유사합니다. 어느 정도 시간이 지나면 할당된 가상 메모리 세그먼트가 더 이상 연속적이지 않아 성능이 저하됩니다. 파일 시스템의 경우 파일 시스템 조각 모음을 수행하는 응용 프로그램을 실행할 수 있습니다. 대부분의 경우 시스템이 온라인으로 액세스되고 있는 중에도 조각 모음을 수행할 수 있습니다. 가상 메모리 조각화가 발생할 경우 조각 모음 도구는 없습니다. 이 문제를 해결하려면 Exchange Information Store 서비스를 중지했다가 시작하거나 시스템을 다시 부팅해야 합니다.

저장소/inetinfo 프로세스에서 실행되는 타사 소프트웨어로 인해 가상 메모리 조각화가 발생할 수 있습니다. 모든 타사 응용 프로그램의 최신 드라이버를 설치했는지 확인하십시오. 시스템을 다시 시작한 후에도 문제가 재현되면 타사 소프트웨어를 비활성화하거나 다른 서버로 사용자 사서함을 이동하여 서버 로드를 줄이고 문제가 중지되는지 확인합니다. 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오

추가 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange 서버 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • Microsoft Exchange Server 2003 및 Exchange 2000 Server의 가상 메모리 조각화 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)을 참조하십시오.

  • 가상 메모리 사용 최적화 방법에 대한 자세한 내용은 기술 자료 문서 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)을 참조하십시오.

  • 사용자 사서함을 이동하여 서버 로드를 줄이는 방법에 대한 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.


지능형 메시지 필터가 Exchange Server 2003을 실행하는 여러 서버에 설치되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 조직에 있는 각 Exchange Server 개체의 msExchExchangeServer 특성 값을 확인하고 이 쿼리 결과를 사용하여 조직 내에 Exchange Server 2003을 실행하는 총 서버의 수를 확인합니다. 또한 Exchange Server Analyzer는 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 조직에 있는 모든 Exchange Server 2003 서버에 Exchange 지능형 메시지 필터가 설치되어 있는지 여부를 확인합니다. Exchange Server 2003을 실행하는 하나 이상의 서버에 지능형 메시지 필터가 설치되어 있지 않은 경우 Exchange Server Analyzer에서 유용한 정보 메시지를 표시합니다.

지능형 메시지 필터는 UCE(원치 않는 상업성 전자 메일 메시지) 같은 메시지를 식별할 수 있습니다. 일반적인 Exchange Server 2003 토폴로지에서는 들어오는 인터넷 전자 메일 메시지를 필터링하도록 지능형 메시지 필터가 게이트웨이 서버에 설치되어 있습니다. 타사 전자 메일 시스템을 인터넷 게이트웨이 서버로 사용할 경우 게이트웨이 서버에서 들어오는 인터넷 전자 메일 메시지를 받는 Exchange 브리지헤드에 지능형 메시지 필터를 설치해야 합니다.

지능형 메시지 필터를 설치하려면 로컬 관리 권한을 가진 계정을 사용하고 Exchange Administrator 역할이 할당된 그룹 구성원이어야 합니다.

자세한 내용은 "Exchange Intelligent Message Filter"(http://go.microsoft.com/fwlink/?LinkId=21607)를 참조하십시오.


ISA Server 2000 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Internet Security and Acceleration(ISA) Server 2000의 SMTP(Simple Mail Transfer Protocol) 메시지 차단기 기능에서 사용하는 smtpfltr.dll 파일의 버전을 확인합니다. Exchange Server Analyzer는 해당 버전 번호 값이 2004보다 이전 버전이면 경고를 표시합니다.

이 경고는 ISA Server 2000의 최신 버전이 있음을 나타냅니다. ISA Server 2000 서비스 팩 2를 설치하는 것이 좋습니다. 특히 SMTP 메시지 차단기 기능을 실행 중이면 반드시 서비스 팩 2로 업그레이드해야 합니다. 이전 버전의 SMTP 메시지 차단기를 사용하면 병목 현상이 발생하여 전체적인 메시지 처리량 성능이 저하됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Microsoft 다운로드 센터(http://go.microsoft.com/fwlink/?linkid=37592)에서 ISA Server 2000 서비스 팩 2를 다운로드합니다.

  2. 서비스 팩 2 릴리스 정보(http://go.microsoft.com/fwlink/?linkid=37584)를 검토하십시오.

  3. 릴리스 정보의 설명에 따라 서비스 팩 2를 설치합니다.

ISA Server 2000 서비스 팩 2를 포함하여 ISA Server 다운로드에 대한 자세한 내용은 "ISA Server 2000 Downloads" 웹 페이지(http://go.microsoft.com/fwlink/?LinkId=18919)를 참조하십시오.


저널링 받는 사람이 잘못되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-27

Microsoft® Exchange Server Analyzer Tool은 저널링 받는 사람 개체의 mailNickname 특성 값이 유효한지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. mailNickname 특성이 유효하도록 애칭을 설정해야 합니다. 지정한 저널링 받는 사람 개체의 mailNickname 특성이 유효하지 않으면 저널링 메시지가 지연됩니다. 또한 잘못된 mailNickname은 사서함을 사용할 수 없는 받는 사람 개체에 저널링 메시지를 복사하도록 저널링이 구성되었음을 나타낼 수 있습니다. Exchange Server Analyzer는 저널링 받는 사람 개체의 mailNickname 특성 값이 잘못된 경우 오류를 표시합니다.

Exchange Server 2003에 대한 이 오류를 해결하려면 Active Directory 사용자 및 컴퓨터와 Exchange System Manager를 사용하여 필요에 따라 다음을 수행합니다.

  • 저널링 받는 사람 개체를 사서함 사용이 가능하도록 설정합니다.

  • 새 사용자 사서함을 저널링 받는 사람으로 지정합니다.

Exchange Server 2003에 대한 이 오류를 해결하려면 Active Directory 사용자 및 컴퓨터와 Exchange System Manager를 사용하여 필요에 따라 다음을 수행합니다.

Exchange Server 2003에 대한 저널 받는 사람 개체를 사서함 사용이 가능하도록 설정하려면 다음을 수행합니다.

  1. Active Directory 사용자 및 컴퓨터를 엽니다.

  2. 콘솔 트리에서 도메인을 확장합니다.

  3. 수정할 받는 사람의 부모 컨테이너로 이동합니다.

  4. 세부 정보 창에서 수정할 받는 사람을 마우스 오른쪽 단추로 클릭한 다음 Exchange 작업을 선택합니다.

  5. Exchange 작업 마법사의 사용 가능한 작업 대화 상자에서 사서함 만들기를 선택한 후 다음을 클릭합니다.

  6. 사서함 만들기 대화 상자에서 별칭, 저장소 및 사서함 서버 필드의 정보를 확인한 후 다음을 클릭합니다.

  7. 마침을 클릭하여 Exchange 작업 마법사를 닫습니다.
Exchange Server 2003에서 새 사용자 사서함을 저널링 받는 사람으로 지정하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 서버, <your Exchange server>, <storage group>을 차례로 확장한 다음 사서함 저장소를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  3. 이 저장소의 사서함에서 주고받은 모든 메시지를 보관 텍스트의 오른쪽에 있는 찾아보기를 클릭하여 사서함을 저널링 사서함으로 지정합니다.

    참고:
    이 사서함 저장소의 보낸 사람에 대해 저널링된 모든 메시지는 지정한 사서함으로 보내집니다.

Exchange Server 2007에 대한 이 오류를 해결하려면 Exchange 관리 콘솔 또는 Exchange 관리 셸을 사용하여 필요에 따라 다음을 수행합니다.

  • 저널 받는 사람 개체에 대한 사서함을 만듭니다.

  • 새 사용자 사서함을 저널링 받는 사람으로 지정합니다.

Exchange 관리 콘솔을 사용하여 Exchange Server 2007에 대한 저널 받는 사람 개체를 사서함 사용이 가능하도록 설정하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔에서 받는 사람 구성을 확장하고 사서함 개체를 마우스 오른쪽 단추로 클릭한 다음 새 사서함을 선택하여 새 사서함 마법사를 시작합니다.

  2. 소개 창에서 사용자 사서함을 선택하고 다음을 클릭합니다.

  3. 사용자 유형 창에서 기존 사용자를 선택하고 찾아보기 단추를 사용하여 사서함을 만들 저널 받는 사람 개체를 선택합니다.

  4. 사서함 설정 창에서 별칭, 서버, 저장소 그룹 및 사서함 데이터베이스 필드의 정보를 확인한 후 다음을 클릭합니다.

  5. 새 사서함 창에서 새로 만들기를 클릭하여 저널 받는 사람 개체의 사서함을 만듭니다.

  6. 마침을 클릭하여 새 사서함 마법사를 닫습니다.
Exchange 관리 셸을 사용하여 Exchange Server 2007에 대한 저널 받는 사람 개체를 사서함 사용이 가능하도록 설정하려면 다음을 수행합니다.

  1. Exchange Server 2007 제품 설명서, "Enable-Mailbox"(http://go.microsoft.com/fwlink/?LinkID=80827)의 안내를 따릅니다.

Exchange Server 2007에서 새 사용자 사서함을 저널링 받는 사람으로 지정하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔에서 서버 구성, <your Exchange server>, <storage group>을 차례로 확장하고 사서함 데이터베이스를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  2. 일반 탭의 저널 받는 사람에서 찾아보기를 클릭하여 사서함을 저널링 사서함으로 지정합니다.

Exchange Server 2003을 사용하여 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server(http://go.microsoft.com/fwlink/?LinkId=47581)를 참조하십시오.

Exchange Server 2007을 사용하여 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Overview of Journaling(http://go.microsoft.com/fwlink/?LinkId=80820)을 참조하십시오.


삭제한 개체에 받는 사람 지점 저널링
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-02-01

Microsoft® Exchange Server Analyzer Tool은 msExchMessageJournalRecipient 특성 값에 DEL: 문자열이 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성은 삭제된 사서함에 메시지를 복사하기 위해 저널링이 구성되었음을 나타냅니다. 저널링이 제대로 작동하려면 복사한 메시지를 보낼 유효한 저널링 받는 사람 사서함이 있어야 합니다. 사서함 데이터베이스에서 저널링을 사용할 수 있게 되면 msExchMessageJournalRecipient 특성이 설정됩니다. 이 특성은 사서함 데이터베이스의 특성으로 저널링 사서함의 고유 이름을 가집니다.

저널링 받는 사람 사서함을 삭제한 경우 저널링 메시지 대기가 시작됩니다. Exchange Server Analyzer는 msExchMessageJournalRecipient 특성 값에 DEL:이라는 문자열이 들어 있는 경우 오류를 표시합니다.

이 오류를 수정하려면 Exchange System Manager 또는 Exchange 관리 콘솔을 사용하여 새 사서함을 저널링 받는 사람으로 지정합니다.

Exchange Server 2003에서 새 사용자 사서함을 저널링 받는 사람으로 지정하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 서버, <Exchange 서버>, <저장소 그룹>을 차례로 확장한 다음 사서함 저장소를 마우스 오른쪽으로 클릭하고 속성을 선택합니다.

  3. 찾아보기를 클릭하여 이 저장소의 사서함에서 주고받은 모든 메시지를 보관 텍스트의 오른쪽에서 사서함을 저널링 사서함으로 지정합니다.

    참고:
    이 사서함 저장소에서 보낸 사람에 대한 모든 저널링된 메시지가 지정한 사서함으로 전송됩니다.
Exchange Server 2007에서 새 사용자 사서함을 저널링 받는 사람으로 지정하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔에서 서버 구성, <your Exchange server>, <storage group>을 차례로 확장하고 사서함 데이터베이스를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  2. 일반 탭의 저널 받는 사람에서 찾아보기를 클릭하여 사서함을 저널링 사서함으로 지정합니다.

Exchange Server 2003 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server(http://go.microsoft.com/fwlink/?LinkId=47581)를 참조하십시오.

Exchange Server 2007을 사용하여 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Overview of Journaling(http://go.microsoft.com/fwlink/?LinkId=80820)을 참조하십시오.


저널링 받는 사람이 사용할 수 없는 계정을 가리킵니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 저널링 받는 사람 개체의 msExchUserAccountControl 특성 값이 사용할 수 없는 사용자 계정을 나타내도록 설정되어 있는지 여부를 확인합니다. 저널링 받는 사람 개체 msExchUserAccountControl 특성 값이 2이면 사용할 수 없는 사용자 계정으로 저널링 메시지를 복사하도록 저널링을 구성했음을 나타냅니다. 이렇게 구성하면 저널링 메시지를 큐나 Badmail 폴더로 보내게 됩니다. 저널링 받는 사람의 msExchUserAccountControl 특성 값이 사용할 수 없는 저널링 받는 사람 사용자 계정을 나타내도록 설정되어 있으면 Exchange Server Analyzer에서 오류를 표시합니다.

Exchange Server 2003에 대한 이 오류를 해결하려면 Active Directory 사용자 및 컴퓨터와 Exchange System Manager를 사용하여 필요에 따라 다음을 수행합니다.

  • 현재 저널링 받는 사람의 사용자 계정을 사용하도록 설정합니다.

  • 새 사용자 사서함을 저널링 받는 사람으로 지정합니다.

Exchange Server 2003에 대해 저널 받는 사람 계정을 사용하려면 다음을 수행합니다.

  1. Active Directory 사용자 및 컴퓨터를 엽니다.

  2. 콘솔 트리에서 도메인을 확장합니다.

  3. 수정할 저널 받는 사람의 부모 컨테이너로 이동합니다.

  4. 세부 정보 창에서 수정하고자 하는 받는 사람을 마우스 오른쪽 단추로 클릭한 다음 계정 사용을 선택합니다.
Exchange Server 2003에서 새 사용자 사서함을 저널링 받는 사람으로 지정하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 서버, <your Exchange server>, <storage group>을 차례로 확장한 다음 사서함 저장소를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  3. 이 저장소의 사서함에서 주고받은 모든 메시지를 보관 텍스트 오른쪽의 찾아보기를 클릭하여 사서함을 저널링 사서함으로 지정합니다.

    참고:
    이 사서함 저장소의 보낸 사람에 대해 저널링된 모든 메시지를 지정한 사서함으로 보냅니다.

Exchange Server 2007에 대한 이 오류를 해결하려면 Exchange 관리 콘솔 또는 Exchange 관리 셸을 사용하여 필요에 따라 다음을 수행합니다.

  • 저널 받는 사람 개체에 대한 사서함을 만듭니다.

  • 새 사용자 사서함을 저널링 받는 사람으로 지정합니다.

Exchange 관리 콘솔을 사용하여 Exchange Server 2007에 대한 저널 받는 사람 개체를 사서함 사용이 가능하도록 설정하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔에서 받는 사람 구성을 확장하고 사서함 개체를 마우스 오른쪽 단추로 클릭한 다음 새 사서함을 선택하여 새 사서함 마법사를 시작합니다.

  2. 소개 창에서 사용자 사서함을 선택하고 다음을 클릭합니다.

  3. 사용자 유형 창에서 기존 사용자를 선택하고 찾아보기 단추를 사용하여 사서함을 만들 저널 받는 사람 개체를 선택합니다.

  4. 사서함 설정 창에서 별칭, 서버, 저장소 그룹 및 사서함 데이터베이스 필드의 정보를 확인한 후 다음을 클릭합니다.

  5. 새 사서함 창에서 새로 만들기를 클릭하여 저널 받는 사람 개체의 사서함을 만듭니다.

  6. 마침을 클릭하여 새 사서함 마법사를 닫습니다.
Exchange 관리 셸을 사용하여 Exchange Server 2007에 대한 저널 받는 사람 개체를 사서함 사용이 가능하도록 설정하려면 다음을 수행합니다.

  1. Exchange Server 2007 제품 설명서, "Enable-Mailbox"(http://go.microsoft.com/fwlink/?LinkId=80827)의 안내를 따릅니다.

Exchange Server 2007에서 새 사용자 사서함을 저널링 받는 사람으로 지정하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔에서 서버 구성, <your Exchange server>, <storage group>을 차례로 확장하고 사서함 데이터베이스를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  2. 일반 탭의 저널 받는 사람에서 찾아보기를 클릭하여 사서함을 저널링 사서함으로 지정합니다.

Exchange Server 2003을 사용하여 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server(http://go.microsoft.com/fwlink/?LinkId=47581)를 참조하십시오.

Exchange Server 2007을 사용하여 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Overview of Journaling(http://go.microsoft.com/fwlink/?LinkID=80820)을 참조하십시오.


저널링 받는 사람이 로컬 서버를 가리킵니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 사서함 저장소 저널링 받는 사람 개체의 msExchHomeServerName 특성 값이 로컬 서버의 legacyExchangeDN 특성과 일치하는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이러한 특성 값이 일치하는 경우에는 실행되는 활성 저널링이 있는 해당 서버의 사서함에 저널링 메시지가 복사됨을 나타냅니다. 저널링 소통량 볼륨이 크게 생성될 수 있으므로 저널링 받는 사람 사서함이 전용 저널링 서버에 있는 것이 좋습니다.

Exchange Server Analyzer는 저널링 받는 사람 개체의 msExchHomeServerName 특성 값이 로컬 서버의 legacyExchangeDN 특성 값과 일치하면 유용한 정보 메시지를 표시합니다.

Exchange Server 2003을 사용하여 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server(http://go.microsoft.com/fwlink/?LinkId=47581)를 참조하십시오.

Exchange Server 2007을 사용하여 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Overview of Journaling(http://go.microsoft.com/fwlink/?LinkId=80820)을 참조하십시오.


저널링 받는 사람은 숨겨야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 저널링 받는 사람 개체의 msExchHideFromAddressLists 특성 값이 True로 설정되었는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성에 True 이외의 값으로 설정되어 있으면 사서함 저장소의 저널링 받는 사람이 Exchange Server 주소 목록에 표시되지 않고 저널링이 아닌 관련 메시지의 받는 사람이 될 수 있습니다. Exchange Server Analyzer는 저널링 받는 사람 개체의 msExchHideFromAddressLists 특성 값이 True로 설정되어 있지 않으면 유용한 정보 메시지를 표시합니다.

Exchange Server 2003에 대한 이 문제를 해결하려면 Active Directory 사용자 및 컴퓨터 도구를 사용하여 Exchange Server 주소 목록에서 저널링 받는 사람 사서함을 숨깁니다.

Exchange Server 2007에 대한 이 문제를 해결하려면 Exchange 관리 콘솔을 사용하여 Exchange Server 주소 목록에서 저널링 받는 사람 사서함을 숨깁니다.

Exchange Server 2003을 사용하여 Exchange Server 주소 목록에서 지정된 저널 받는 사람 사서함을 숨기려면 다음을 수행합니다.

  1. Active Directory 사용자 및 컴퓨터를 엽니다.

  2. 콘솔 트리에서 도메인을 확장합니다.

  3. 수정할 받는 사람의 부모 컨테이너로 이동합니다.

  4. 세부 정보 창에서 수정할 받는 사람을 두 번 클릭합니다.

  5. Exchange 고급 탭에서 Exchange 주소 목록에서 숨기기 확인란을 선택합니다.

  6. OK를 클릭합니다.
Exchange Server 2007을 사용하여 Exchange Server 주소 목록에서 지정된 저널 받는 사람 사서함을 숨기려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. 콘솔 트리에서 수정할 받는 사람의 부모 컨테이너로 이동합니다.

  3. 세부 정보 창에서 지정된 저널링 받는 사람의 사서함 개체를 두 번 클릭하여 해당 속성을 표시합니다.

  4. 일반 탭에서 Exchange 주소 목록에서 숨기기 확인란을 선택합니다.

  5. 확인을 클릭합니다.

Exchange Server 2003을 사용하여 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server(http://go.microsoft.com/fwlink/?LinkId=47581)를 참조하십시오.

Exchange Server 2007을 사용하여 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Overview of Journaling(http://go.microsoft.com/fwlink/?LinkId=80820)을 참조하십시오.


Junk store threshold not configured
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-07-30

Microsoft Exchange Analyzer Tool은 Exchange 환경을 쿼리해 Exchange Server 2007 허브 전송 또는 사서함 서버 역할의 존재 여부를 확인합니다.

Exchange Server 2007 허브 전송 또는 사서함 서버 역할이 있으면 Exchange Analyzer는 Exchange 다음과 같은 Exchange 관리 셸 cmdlet를 실행해 조직의 SCLJunkThreshold 매개 변수 값을 쿼리합니다.

Get-OrganizationConfig

조직의 SCLJunkThreshold 매개 변수는 해당 메시지를 정크 메일 폴더로 보내는 SCL(스팸 지수)를 지정합니다.

Exchange Analyzer는 조직의 SCLJunkThreshold 매개 변수를 확인하여 기본값인 8로 설정되어 있으면 경고를 표시합니다.

이 경고가 표시되면 해당 메시지만 정크 메일 폴더로 보내기 위한 스팸 지수 임계값의 현재 설정으로는 올바른 사용자가 보낸 메일까지 정크 메일로 필터링되어 정크 메일 폴더로 보내질 수 있다는 의미입니다. SCLJunkThreshold 매개 변수의 권장 값은 4입니다.

이 경고를 해결하려면 Exchange 관리 셸에서 Set-OrganizationConfig cmdlet를 사용하여 SCLJunkThreshold 매개 변수 값을 4로 설정하십시오.

Set-OrganizationConfig cmdlet를 사용하여 SCLJunkThreshold 매개 변수 값을 4로 설정하려면 다음을 수행합니다.

  1. 다음 코드는 SCLJunkThreshold 매개 변수 값을 4로 설정하는 Set-OrganizationConfig 명령의 예입니다.

  2. Set-OrganizationConfig -SCLJunkThreshold 4


커널 메모리 손실
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-02-15

Microsoft Exchange Analyzer Tool은 최근 24시간 이내 SRV(서버) 또는 NCP 서버 원본에 대해 이벤트 2000, 이벤트 2019 또는 이벤트 2020 오류가 기록되었는지 여부를 확인할 때 Win32_NTLogEvent Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다.

  • SRV(서버) 이벤트 ID 2000은 일반 시스템 커널 메모리 손실로 인해 시스템 서비스에 대한 서버 호출이 예기치 않게 실패했음을 나타냅니다.

  • SRV 이벤트 ID 2019는 시스템 비페이징 풀 메모리의 손실을 나타냅니다.

  • SRV 이벤트 ID 2020은 시스템 페이징 풀 메모리의 손실을 나타냅니다.

최근 24시간 이내 이러한 이벤트 중 하나 이상의 이벤트가 기록되면 Exchange Analyzer에서는 오류를 표시합니다.

이 경고는 서버의 커널 메모리가 손실되어 성능 문제가 나타날 수 있음을 나타냅니다.

Microsoft Windows 커널 메모리는 페이징 풀과 비페이징 풀 메모리 및 시스템 페이지 테이블 항목을 포함하여 몇 개의 메모리 구조로 구성됩니다. 커널 메모리라고도 하는 이러한 메모리 구조는 Exchange와 같은 응용 프로그램용 환경을 제공하기 위해 운영 체제에서 사용됩니다.

이 문제를 해결하려면 아래 나열된 문제별 Exchange Analyzer 문서의 안내를 따르십시오.

  • 커널 메모리 향상

  • 페이징 풀이 경고 임계값을 초과했습니다.

  • 비페이징 풀이 경고 임계값을 초과합니다.

  • 페이징 풀이 오류 임계값을 초과했습니다.

일반적으로 정상적인 Exchange 배포를 유지 관리하려면 Exchange Server의 커널 메모리를 주기적으로 모니터링해야 합니다.

자세한 정보

SRV 이벤트 2000, 2019 또는 2020에 대한 자세한 내용은 "이벤트 및 오류 메시지 센터: 이벤트 세부 정보"를 참조하십시오.

  • SRV 이벤트 ID 2000, http://go.microsoft.com/fwlink/?LinkId=83250

  • SRV 이벤트 ID 2019, http://go.microsoft.com/fwlink/?LinkId=83251

  • SRV 이벤트 ID 2020, http://go.microsoft.com/fwlink/?LinkId=83252

Exchange Server의 메모리 최적화에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 912376, "How to monitor and troubleshoot the use of paged pool memory in Exchange Server 2003 or in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 894067, "The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067)

  • 311901, "The effects of 4GT tuning on System Page Table Entries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 912376, "How to monitor and troubleshoot the use of paged pool memory in Exchange Server 2003 or in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376)


커널 리소스 고갈: 볼륨 섀도 복사본 서비스 업데이트
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool은 CIM_Datafile Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리하여 Vssvc.exe 파일이 있는지 확인합니다.

Exchange Server Analyzer는 다음 레지스트리를 쿼리하여 VSS(볼륨 섀도 복사본 서비스) 또는 VDS(가상 디스크 서비스)가 Windows Server에서 실행되고 있는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS

또한 Exchange Server Analyzer는 다음 레지스트리 값을 읽어 Exchange Server에서 실행 중인 Microsoft Windows® 운영 체제의 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값이 5.0이면 Exchange 서버가 Microsoft Windows 2000 Server에서 실행되고 있습니다. CurrentVersion 값이 5.2이면 Exchange 서버가 Microsoft Windows Server™ 2003에서 실행되고 있습니다.

마지막으로 Exchange Server Analyzer는 Win32_OperatingSystem WMI(Windows Management Instrumentation) 클래스를 쿼리하여 ServicePackMajorVersion 키 값을 확인합니다. ServicePackMajorVersion 키 값은 Windows 서비스 팩이 컴퓨터에 설치되어 있음을 나타냅니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • Exchange Server가 Exchange Server 2003 서비스 팩 1(SP1)에 설치되어 있습니다.

  • 볼륨 섀도 복사본 서비스 또는 가상 디스크 서비스가 Windows Server 2003 SP1에서 실행되고 있습니다.

  • VSS 업데이트가 이 Exchange Server 구성에 설치되어 있지 않습니다.

VSS 업데이트를 적용하면 커널 리소스 고갈과 같은 문제가 해결됩니다.

오류를 해결하려면 다음을 수행합니다.

  • Microsoft 기술 자료 문서 891957, "Update is available that fixes various Volume Shadow Copy Service issues in Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=891957)에서 다운로드할 수 있는 VSS 업데이트를 적용합니다.

Exchange Server 2003에서 VSS 사용에 대한 유용한 정보는 Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003(http://go.microsoft.com/fwlink/?LinkId=56571)을 참조하십시오.


LeakDiag가 설치되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 컴퓨터에 LeakDiag.exe가 설치되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag

Exchange Server Analyzer는 이 레지스트리 분기가 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

LeakDiag는 개발자, 기술 지원 전문가 및 IT 담당자가 Microsoft Windows NT® Server 4.0, Windows® 2000 Server, Windows XP 및 Windows Server™ 2003을 실행하는 컴퓨터에 있는 응용 프로그램이나 서비스에서 메모리 누수, 조각화 및 기타 메모리 관련 문제를 진단할 수 있도록 도와 주는 일련의 도구입니다.

LeakDiag 도구는 메모리 누수 지점을 코드의 줄 수준까지 정확히 진단할 수 있습니다. LeakDiag는 Microsoft의 Detours 기술을 통해 지정된 메모리 할당에 대한 호출을 차단하고 여러 호출 스택을 추적합니다. 또한 할당된 후 아직 해제되지 않은 메모리에 대해 보고합니다. 이 정보를 통해 해당 할당을 생성한 구성 요소를 정확히 찾아내어 메모리 누수 문제를 해결할 수 있습니다. 올바른 디버그 기호를 사용하면 할당을 요청한 코드의 줄까지 확인할 수 있습니다.

업무 환경의 Exchange 서버에서는 LeakDiag를 실행하지 않는 것이 좋습니다. LeakDiag를 사용하면 Exchange 서버가 시작될 때마다 모든 프로세스의 메모리 할당을 모두 추적하게 됩니다. 그러면 막대한 양의 프로세서 및 메모리 리소스가 소모되므로 메모리 관련 문제를 직접 해결하는 경우 외에는 사용하지 않는 것이 좋습니다. 메모리 관련 문제를 해결하는 경우 외에는 LeakDiag를 해제해야 합니다. 프로덕션 Exchange Server 환경에서 LeakDiag를 실행하면 메모리 조각화 및 손실이 발생하여 결국 Exchange 오류가 발생하게 됩니다.

참고:
항상 서버 사용량이 적은 시간에 LeakDiag를 사용하여 문제를 해결해야 합니다. 서버 사용량이 많을 때 LeakDiag를 사용하면 Exchange Server 컴퓨터의 성능이 현저히 저하될 수 있습니다.

이 메시지에 대한 정보

  1. 이 메시지는 정보 제공을 위한 것입니다. LeakDiag를 사용하도록 설정하거나 실행하지 않는 이상 컴퓨터에 설치되어 있는 것만으로는 Exchange Server 성능에 영향을 주지 않습니다. LeakDiag를 실행하려면 4MB 정도의 하드 디스크 공간(로그 공간은 별도)이 필요합니다.

  2. 제어판에서 프로그램 추가/제거, LeakDiag, 제거를 차례로 클릭하여 이 하드 디스크 공간을 확보할 수 있습니다.

최신 버전의 LeakDiag는 Microsoft 공용 FTP 사이트(http://go.microsoft.com/fwlink/?LinkId=41401)에서 구할 수 있습니다.


LeakDiag가 활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 LeakDiag.exe가 컴퓨터에서 사용되는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag\EnableAutoStart

Exchange Server Analyzer는 EnableAutoStart의 값이 1로 설정되어 있는 경우 경고를 표시합니다. EnableAutoStart는 LeakDiag 사용자 인터페이스를 사용하여 구성됩니다. 기본값은 0입니다. 값이 1이면 LeakDiag가 사용되고 활성화되었다는 뜻입니다.

LeakDiag는 개발자, 기술 지원 전문가 및 IT 담당자가 Microsoft Windows NT® Server 4.0, Windows® 2000 Server, Windows XP, Windows Server™ 2003 등의 컴퓨터에서 실행되는 응용 프로그램이나 서비스에 대해 메모리 누수, 조각화, 기타 메모리 관련 문제를 진단하는 데 유용한 도구의 모음입니다.

LeakDiag 도구는 메모리 누수 지점을 코드의 줄 수준까지 정확히 진단할 수 있습니다. Microsoft의 Detours 기술을 사용하여 LeakDiag는 지정된 메모리 할당 호출을 가로채고 다양한 호출 스택을 추적합니다. 또한 할당되었으나 아직 사용할 수 없는 메모리에 대해 보고합니다. 이 정보를 사용하여 메모리 누수 문제를 해결하는 사람은 메모리를 할당한 구성 요소를 정확하게 파악할 수 있습니다. 정확한 디버그 기호를 사용하여 할당을 요청한 코드 줄까지도 볼 수 있습니다.

업무 환경에 있는 Exchange 서버에서는 LeakDiag를 실행하지 않는 것이 좋습니다. LeakDiag가 사용될 경우 Exchange Server가 시작될 때마다 모든 프로세스에 대한 모든 메모리 할당을 추적합니다. 이것은 프로세서와 메모리 리소스를 아주 많이 소비하므로 적극적으로 메모리 관련 문제를 해결하는 경우가 아니면 LeakDiag를 사용하지 않는 것이 좋습니다. 메모리 관련 문제를 적극적으로 해결하는 경우가 아니면 LeakDiag를 해제해야 합니다. 프로덕션 Exchange Server 환경에서 LeakDiag를 실행하면 메모리가 조각화되고 고갈되어 결국에는 Exchange가 실패할 수 있습니다.

참고:
항상 사용량이 많지 않은 시간에 LeakDiag를 사용하여 문제를 해결해야 합니다. 사용량이 많거나 최고일 때 LeakDiag를 사용하면 Exchange Server 컴퓨터의 성능이 크게 감소합니다.

LeakDiag.exe의 자동 시작을 해제하려면 다음을 수행합니다.

  1. 시작을 클릭한 다음 LeakDiag를 클릭합니다.

  2. Tools 메뉴에서 Options를 클릭합니다.

  3. Options 페이지에서 Allow AutoStart 확인란의 선택을 해제한 다음 OK를 클릭합니다.

LeakDiag의 최신 버전은 Microsoft 공개 FTP 사이트(http://go.microsoft.com/fwlink/?LinkId=41401)를 참조하십시오.


로그 공간의 남은 시간이 7일 미만입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-13

Microsoft Exchange Server Analyzer Tool은 Exchange Server 저장소 그룹의 트랜잭션 로그 드라이브 공간이 가득 찰 때까지 남은 시간을 예상합니다. Exchange Server Analyzer는 드라이브의 트랜잭션 로그 파일에 있는 타임스탬프를 확인하여 로그 드라이브가 용량에 도달하는 시간을 예상합니다. 로그 드라이브가 가득 찰 때까지 남은 시간이 7일 미만이면 오류를 표시합니다.

Exchange Server 데이터베이스에 대한 로그 파일이 들어 있는 드라이브의 디스크 공간이 부족합니다.

로그 드라이브의 공간이 부족하면 다음 문제가 발생할 수 있습니다.

  • 데이터베이스가 시작되지 않거나 종료됩니다.

  • 데이터베이스가 부적절하게 종료되고 일관성이 없어집니다.

  • 사용자가 메일이나 공용 폴더에 액세스할 수 없습니다.

순환 로깅을 사용하지 않기 때문에 로그 드라이브 공간이 가득 찰 수 있습니다. 따라서 Exchange Server 인식 소프트웨어를 사용하는 전체 또는 증분 온라인 백업을 수행할 때까지 드라이브에 트랜잭션 로그 파일이 남아 있습니다.

Exchange 2003 이전 버전의 Exchange Server에서는 데이터베이스가 완전하게 종료된 상태에 도달하지 못한 채 중지될 수 있습니다. 예약 트랜잭션 로그 파일 Res1.log와 Res2.log는 디스크 공간 부족 시 일반 트랜잭션 로그로 변환됩니다.

Exchange Server 2003에서는 최적화가 구현되었기 때문에 예약 로그 파일이 모두 사용될 때까지 데이터베이스를 완전히 종료할 수 있습니다. 데이터베이스가 완전히 종료되지 않은 경우에는 데이터베이스와 연관된 마지막 일부 트랜잭션 로그를 삭제하지 마십시오. 이러한 트랜잭션 로그에는 데이터베이스를 일관성 있게 복원하기 위해 데이터베이스에 적용해야 하는 정보가 들어 있습니다. 이 로그 파일을 삭제한 경우 데이터베이스를 복구하거나 복원해야 데이터베이스를 다시 시작할 수 있습니다.

저장소 그룹의 모든 데이터베이스가 완전하게 종료된 상태인 경우 트랜잭션 로그를 모두 제거해도 데이터베이스를 시작할 수 있습니다. 그러나 트랜잭션 로그를 제거하면 이전 백업이 무효화됩니다. 즉, 이전 백업을 복원할 수 없는 것이 아니라 복원된 데이터베이스를 로그 파일이 삭제된 시점 이전으로 되돌릴 수 없습니다.

Exchange Server Analyzer의 로그 공간 마법사는 기존 트랜잭션 로그 파일을 분석하고 데이터베이스에 더 이상 필요하지 않은 트랜잭션 로그 파일을 이동할 수 있도록 도와 줍니다. 또한 모든 데이터베이스가 완전하게 종료된 상태이더라도 현재 로그 파일이 제거되지 않도록 해 줍니다. 현재 로그 파일을 제거하지 않은 경우 이전 백업이 여전히 유효합니다.

로그 드라이브 공간을 다시 확보하려면 불필요한 로그 파일을 제거해야 합니다. 다음 작업을 수행하십시오.

로그 드라이브 공간이 가득 차거나 용량에 근접한 경우 로그 드라이브 공간을 다시 확보하려면 다음을 수행합니다.

  • 데이터베이스에 대해 Exchange 인식 온라인 스트리밍 백업이나 VSS(볼륨 섀도 복사본 서비스) 백업을 수행합니다. VSS 백업에 대한 자세한 내용은 "Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=56571)을 참조하십시오.

    참고:
    불필요한 로그 파일을 지우는 좋은 방법은 온라인 스트리밍 백업이나 VSS 백업을 수행하는 것입니다.

  • 로그 드라이브 공간이 부족하여 데이터베이스가 종료된 경우 Exchange Server Analyzer 로그 공간 관리 마법사를 사용하여 불필요한 로그 파일을 이동할 수 있습니다. 또는 데이터베이스를 다시 탑재하기 전에 불필요한 로그 파일을 수동으로 이동할 수 있습니다.

    로그 파일을 수동으로 제거하려면 Microsoft 기술 자료 문서 240145, "Exchange Server 트랜잭션 로그 파일을 제거하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240145)의 절차 및 권장 사항을 따르십시오.


Exchange 서버의 LegacyExchangeDN이 상위 관리 그룹과 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 Active Directory의 서버 컨테이너에 있는 서버 개체의 특성을 검사하여 이를 해당 서버가 상주해 있는 조직과 관리 그룹의 실제 이름과 비교하는 방법으로 서버의 legacyExchangeDN 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 서버의 legacyExchangeDN 값이 해당 조직이나 관리 그룹과 다르면 오류가 표시됩니다.

Exchange에서는 legacyExchangeDN 값을 사용하여 Active Directory의 Exchange 개체를 식별합니다. legacyExchangeDN 값은 개체가 Exchange 조직의 어디에 적합한지를 나타내는 고유 이름입니다. 예를 들면 다음과 같습니다.

/o= organization /ou= administrative group /ou= server

사서함 저장소 및 공용 폴더 저장소 같은 개체는 서버로부터 해당 legacyExchangeDN 값의 일부를 상속받습니다. 따라서 서버 값에 문제가 있으면 다른 개체도 동일한 문제를 상속받을 수 있습니다.

일반적으로 legacyExchangeDN 관련 문제는 관리자가 이 값을 직접 수정하려고 할 때 발생합니다. ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 도구를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집이나 비슷한 도구를 사용하여 Active Directory에서 관리 그룹 개체를 찾습니다.

    legacyExchangeDN 특성은 다음 위치에 있습니다.

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=server

  2. 다음 형식으로 새 문자열 값을 입력합니다.

    /o= organization /ou= administrative group /ou= server

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 2003 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


이 Exchange Server에 대한 LegacyExchangeDN이 올바르지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 Exchange 서버의 legacyExchangeDN 값을 확인합니다. legacyExchangeDN 값에 지정된 조직이나 관리 그룹 이름이 실제 이름과 일치하지 않거나 일부 값이 없는 경우 이 오류가 표시됩니다.

Exchange에서는 legacyExchangeDN 값을 사용하여 Active Directory의 Exchange 개체를 식별합니다. legacyExchangeDN 값은 개체가 Exchange 조직의 어디에 적합한지를 나타내는 고유 이름입니다. 예를 들면 다음과 같습니다.

/o= organization /ou= administrative group

서버 및 폴더 계층 구조와 같은 개체는 관리 그룹에서 해당 legacyExchangeDN 값의 일부를 상속합니다. 따라서 관리 그룹 값에 문제가 있을 경우 다른 많은 개체가 동일한 문제를 상속할 수 있습니다.

일반적으로 관리자가 값을 직접 수정하려고 시도할 때 legacyExchangeDN 문제가 발생합니다. ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 도구를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집이나 비슷한 도구를 사용하여 Active Directory에서 관리 그룹 개체를 찾습니다.

    legacyExchangeDN 특성은 다음 위치에 있습니다.

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. 다음 형식으로 새 문자열 값을 입력합니다.

    /o= organization /ou= administrative group

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 2003 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


라이센스 로깅 서비스가 자동으로 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 라이센스 로깅 서비스(LicenseService)의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. False 값은 이 Exchange 서버에서 라이센스 로깅 서비스가 실행되고 있지 않음을 나타내며 True 값은 라이센스 로깅 서비스가 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 IsFrontEndServer 키 값을 확인할 때도 root\MicrosoftExchangeV2 네임스페이스에서 Exchange_Server WMI 클래스를 쿼리합니다. False 값은 Exchange Server 컴퓨터가 프런트 엔드 서버가 아님을 나타내고 True 값은 Exchange Server 컴퓨터가 프런트 엔드 서버임을 나타냅니다.

Exchange Server Analyzer는 OSProductSuite 키 값을 확인할 때도 Win32_OperatingSystem WMI 클래스를 쿼리합니다. 이 키에 대해 대해 반환되는 값은 해당 Exchange Server 컴퓨터에서 실행 중인 Windows 운영 체제의 버전을 나타냅니다.

또한 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열되어 있는 항목 수를 확인할 때 Active Directory 디렉터리 서비스를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다.

Exchange Server Analyzer는 다음 조건을 모두 만족하는 Exchange Server 컴퓨터에서 라이센스 로깅 서비스가 시작될 경우 경고를 표시합니다.

  • Exchange Server 컴퓨터가 프런트 엔드 서버가 아닙니다.

  • Exchange Server 컴퓨터에서 20개가 넘는 사서함을 호스팅합니다.

  • Exchange Server가 Microsoft Windows Small Business Server 2003 또는 Small Business Server 2000에서 실행되고 있지 않습니다.

라이센스 로깅 서비스는 서버 CAL(클라이언트 액세스 라이센스) 모델에서 라이센스가 허용된 Microsoft 서버 제품에 대한 라이센스를 보다 쉽게 관리할 수 있도록 도와주는 도구입니다.

기본적으로 Microsoft Windows Server™ 2003에서는 라이센스 로깅 서비스가 비활성화되어 있습니다. 원래 디자인상의 제약과 관련 라이센스 사용 약관 때문에 라이센스 로깅 서비스를 통해 단일 서버에서 또는 기업 전체에서 사용되는 총 CAL 수 및 구입된 총 CAL 수를 정확히 확인하지 못할 수 있습니다. 라이센스 로깅 서비스에서 보고하는 CAL이 EULA(최종 사용자 사용권 계약) 및 PUR(제품 사용 권한)의 내용과 충돌할 수 있습니다. 후속 버전의 Windows 운영 체제에는 라이센스 로깅 서비스가 포함되지 않을 예정입니다.

Exchange Server 컴퓨터에서 라이센스 로깅 서비스를 사용하려면 다음과 같은 사항을 준수해야 합니다.

  • SSL(Secure Sockets Layer)을 사용하는 프런트 엔드 Exchange 서버에서는 라이센스 로깅 서비스를 활성화하고 시작해야 합니다. 라이센스 로깅 서비스가 실행되고 있지 않으면 IIS(인터넷 정보 서비스)에서는 동시 인증 SSL 연결 수를 10개로 제한합니다.

  • 백 엔드 Exchange 서버에서는 라이센스 로깅 서비스를 중지한 후 사용 안 함으로 설정하는 것이 좋습니다.

  • 클러스터된 Exchange 서버에서는 라이센스 로깅 서비스를 중지한 후 사용 안 함으로 설정하는 것이 좋습니다.

  • Microsoft Windows Small Business Server 2003 또는 Small Business Server 2000에서 실행되는 Exchange Server에서는 인증된 SSL 연결이 10개보다 많이 필요할 때만 라이센스 로깅 서비스가 필요합니다.

라이센스 로깅 서비스의 상태를 설정하려면 다음을 수행합니다.

  1. 관리 도구 메뉴에서 서비스 스냅인을 시작합니다.

  2. License Logging Service를 찾아 두 번 클릭합니다.

  3. 시작 유형 드롭다운 목록에서 적절한 옵션을 선택합니다.

    • SSL을 사용하는 프런트 엔드 Exchange 서버의 경우 서비스를 자동으로 설정합니다.

    • 백 엔드 Exchange 서버와 클러스터된 Exchange 서버의 경우 서비스를 사용 안 함으로 설정합니다.

  4. 라이센스 로깅 서비스를 사용하지 않을 경우에는 중지를 클릭하여 서비스를 중지해야 합니다.

  5. 확인을 클릭하여 변경 내용을 저장하고 서비스 스냅인을 닫습니다.

라이센스 로깅 서비스에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 824196, "Description of the License Logging Service in Windows Server Operating Systems"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=824196)

  • 316631, "라이센스 로깅 서비스를 해제하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=316631)


로그 파일 이름이 로그 생성 번호와 일치하지 않음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-07

Microsoft® Exchange Server Analyzer Tool은 트랜잭션 로그 파일 헤더의 lGeneration 내부 생성 번호 값을 트랜잭션 로그 파일의 이름과 비교하여 일치 여부를 확인합니다.

트랜잭션 로그 파일의 내부 생성 번호가 트랜잭션 로그 파일 이름에 표시된 내부 생성 번호와 일치하지 않으면 Exchange Server Analyzer는 오류를 표시합니다.

로그 파일이 현재 로그가 아니면 사용 가능한 최신 로그 파일이 생성 번호와 일치하는 파일 이름을 가져야 합니다. 로그 파일이 현재 로그인 경우에는 저장소 그룹을 나타내는 로그 접두사 이외의 생성 번호를 파일 이름에 포함할 수 없습니다. 예를 들어, 일련의 이전 트랜잭션 로그 이름으로 E0154321.LOG, E0154322.LOG, E0154323.LOG 등이 사용될 수 있으며 현재 로그 이름으로는 E01.LOG 등이 사용될 수 있습니다.

Eseutil /ML LOGFILE 명령을 사용하여 로그 파일의 내부 lGeneration 값을 표시할 수 있습니다.

Exchange 서버 트랜잭션 로깅에 대한 자세한 내용은 Using Recovery Storage Groups in Exchange Server 2003(http://go.microsoft.com/fwlink/?LinkId=47589)의 "Exchange Transaction Logging in Exchange Server 2003"을 참조하십시오.


로그 시퀀스 서명 불일치
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-07

Microsoft® Exchange Server Analyzer Tool은 로그 파일의 Signature값을 이후 로그 파일의 Signature 값과 비교하여 서로 일치하는지 확인합니다.

로그 파일의 Signature 값이 이후 로그 파일의Signature 값과 일치하지 않는 경우 Exchange Server Analyzer는 오류를 표시합니다.

Exchange는 단일 대용량 파일에 모든 로그 정보를 기록하지 않고 각 파일 용량이 정확히 5 MB인 일련의 로그 파일을 사용합니다. 로그 파일이 꽉 차면 Exchange는 해당 로그 파일을 닫고 시퀀스 번호를 사용하여 이름을 변경합니다.

Exchange 저장소 그룹에 대한 트랜잭션 로그 파일의 새로운 시퀀스가 초기화되면 Signature이 첫 번째 로그 파일에 기록되며 모든 이후 로그 파일로 복사됩니다. Signature은 특정 로그 파일을 특정 로그 시퀀스의 구성원으로 고유하게 식별합니다.

서로 다른 서명을 가진 로그 파일은 절대 같은 폴더에 있을 수 없습니다. 그러한 일이 발생한 경우, 외부 로그 파일이 저장소 그룹에 복사되었거나 모든 이전 로그 파일을 먼저 삭제하지 않고 로그 파일을 다시 설정했음을 의미합니다.

명령 Eseutil /ML LOGFILE을 사용하여 로그 파일에 대한 Signature 값을 표시할 수 있습니다.

Exchange 서버 트랜잭션 로깅에 대한 자세한 내용은 Using Recovery Storage Groups in Exchange Server 2003의 "Exchange Transaction Logging in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=47589)을 참조하십시오.


로그 서명 문제
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-07

Microsoft® Exchange Server Analyzer Tool은 서버에 있는 현재 Exchange 트랜잭션 로그 파일의 헤더에 있는 서명을 저장소 그룹 데이터베이스 파일의 로그 서명과 비교합니다.

트랜잭션 로그 파일의 서명이 데이터베이스 파일의 로그 서명과 일치하지 않으면 Exchange Server Analyzer가 오류를 표시합니다.

이 오류 메시지는 다음과 같은 상황 중 하나에 해당된다는 것을 나타냅니다.

  • 현재 트랜잭션 로그 파일이 없습니다.

  • 현재 트랜잭션 로그 파일이 저장소 그룹에 있는 데이터베이스 중 하나와 일치하지 않습니다.

이런 동작은 다음과 같은 이유로 발생합니다.

  • 저장소 그룹의 트랜잭션 로그가 수동으로 삭제되었습니다.

  • 다른 저장소 그룹의 데이터베이스가 이 저장소 그룹에 복구되거나 복사되었습니다.

  • 다른 시퀀스나 저장소 그룹의 트랜잭션 로그 파일이 이 저장소 그룹에 복사되었습니다.

이런 상황으로 인한 데이터베이스 탑재 가능 여부는 데이터베이스 파일이 완전하게 종료된 상태인지 부적절한 종료 상태인지에 따라 결정됩니다.

참고:
데이터베이스가 완전하게 종료된 상태에 있더라도 저장소 그룹의 다른 데이터베이스 탑재가 불가능하기 때문에 데이터베이스를 여전히 탑재할 수 없습니다. Exchange Server Disaster Recovery Analyzer를 사용하여 이러한 경우 데이터베이스를 탑재할 수 있는 방법에 대해 진단하고 알아볼 수 있습니다.

Exchange 데이터베이스가 올바르게 종료되면 처리되지 않은 데이터는 모두 데이터베이스 파일에 기록됩니다. 정상적인 종료 후에는 데이터베이스 파일 세트(확장명 .edb와 .stm)가 일치하는 것으로 간주됩니다. 그런 다음 Exchange는 데이터베이스 파일 세트를 로그 스트림으로부터 분리합니다. 이는 이제 데이터베이스 파일이 자체 포함된 상태 즉, 완전히 최신 상태임을 의미합니다. 이전 트랜잭션 로그는 데이터베이스 파일을 시작하는 데 필요하지 않습니다.

완전하게 종료된 상태의 데이터베이스는 로그 파일에서 분리되었으며 다른 로그 스트림에 첨부할 수 있습니다. 따라서 로그 파일과 데이터베이스 간의 불일치가 반드시 문제가 되지는 않습니다.

부적절한 종료 상태의 데이터베이스는 로그 파일에서 잘못 분리되었습니다. 따라서 이러한 데이터베이스는 첨부된 로그 파일을 사용해 복구되어야 합니다. 첨부된 로그 파일을 찾을 수 없으면 데이터베이스를 탑재할 수 없습니다. 데이터베이스를 탑재할 수 있으려면 먼저 데이터 베이스를 백업에서 복원하거나 복구해야 합니다.

Eseutil /mh 명령을 입력하고 파일 헤더를 살펴보면 데이터베이스가 완전히 종료되었는지 확인할 수 있습니다. Microsoft Exchange 2000 서비스 팩 1 이상의 버전에서 헤더 줄은 "상태: 완전한 종료" 또는 "상태: 부적절한 종료"로 표시됩니다. 이전 버전의 Exchange에서는 "상태: 일치" or "상태: 불일치"로 표시됩니다.

Exchange 서버 트랜잭션 로깅에 대한 자세한 내용은 Using Recovery Storage Groups in Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589)의 "Exchange Transaction Logging in Exchange Server 2003"을 참조하십시오.


오류 임계값을 초과하는 초당 로그 레코드 바이트 수
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Server Analyzer Tool은 ExMon(Exchange Server User Monitor) 도구를 사용하여 사용자 MAPI 작업이 정상적인 Exchange 서버에서 예상되는 대로 수행되고 있는지 확인합니다.

분석 과정에서 Exchange Server Analyzer는 트랜잭션 로그 사용을 검토하여 사용자 MAPI 작업으로 인해 분당 5MB를 초과하는 데이터가 Exchange 트랜잭션 로그에 기록되는지 확인합니다.

MAPI 작업으로 인한 과도한 트랜잭션 로그 파일 증가는 서버 리소스 병목 현상, 검사점 깊이 초과, 디스크 I/O 병목 현상 및 디스크 공간 부족과 같은 오류를 일으킬 수 있습니다.

Exchange Server Analyzer는 하나 이상의 MAPI 작업으로 인해 분당 5MB를 초과하는 데이터가 Exchange 트랜잭션 로그에 기록되는 것을 확인할 경우 오류를 표시합니다.

하지만 분당 5MB를 초과하는 데이터를 Exchange 트랜잭션 로그에 기록하는 MAPI 작업이 항상 문제가 되는 것은 아닙니다. 사서함 이동이나 많은 양의 트랜잭션 로그 데이터를 생성하는 많은 메시지에 대한 기타 대량 작업과 같은 일부 작업을 수행할 경우에는 높은 속도로 기록되어야 할 수 있습니다. 그러나 이런 경우에도 높은 속도가 몇 분 이상 지속되어서는 안 됩니다.

서버에서 높은 RPC 대기 시간과 같은 기타 문제가 있는 경우 트랜잭션 로그 데이터를 생성하는 사용자에게서 높은 로그 레코드 쓰기 속도를 초래하는 사용자 작업이 무엇인지 확인합니다.

자세한 정보

자세한 내용은 다음 Exchange Server 리소스를 참조하십시오.

  • Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 Performance: 10 Things to Think About(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 기술 자료 문서 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


LogicalDisk 성능 모니터 개체를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이트 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 LogicalDisk 성능 개체의 Avg. Disk sec/Read 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. 카운터에서 올바른 데이터가 반환되지 않으면 Exchange Server Analyzer는 기본 메시지를 표시합니다.

다음과 같은 상황에서는 성능 데이터 수집 엔진에서 올바른 데이터가 반환되지 않습니다.

  • LogicalDisk 성능 개체를 사용하지 않습니다. Microsoft Windows Server™ 2003에서는 기본적으로 LogicalDisk 성능 개체를 사용합니다. 하지만 Microsoft Windows® 2000 Server에서는 기본적으로 LogicalDisk를 사용하지 않습니다.

  • LogicalDisk 성능 모니터 개체가 없거나 손상되었습니다.

  • 성능 개체에 액세스할 수 있는 적절한 권한이 Exchange Server Analyzer에 없습니다.

맨 앞의 두 가지 상황은 확장 가능한 특정 카운터가 레지스트리를 손상시키거나 Microsoft WMI(Windows Management Instrumentation) 기반 프로그램에서 레지스트리를 수정하는 경우에 발생할 수 있습니다.

다음 절차에서는 맨 앞의 두 가지 상황을 해결하는 방법을 설명합니다. 해당 절차를 수행하기 전에 Exchange Server Analyzer에 적절한 권한이 있는지 확인합니다. Exchange Server Analyzer를 실행하는 데 필요한 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말을 참조하십시오. 도움말을 보려면 Exchange Server Analyzer를 열고 F1 키를 누르십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. LogicalDisk 성능 개체를 사용하는지 확인합니다.

    1. Extensible Performance Counter List 도구(Exctrlst.exe)를 다운로드하고 설치합니다. Exctrlst.exe: Extensible Performance Counter List(http://go.microsoft.com/fwlink/?LinkId=34436)에서 Exctrlst.exe를 다운로드할 수 있습니다.

    2. Exctrlst.exe를 열고 Sort Order와 Service를 차례로 클릭합니다.

    3. 성능 개체가 보고하는 서비스를 찾아 Performance Counters Enabled 확인란이 선택되었는지 확인합니다.

      Performance Counters Enabled 확인란이 선택되지 않았으면 이 확인란을 선택한 다음 성능 카운터에 연결된 서비스를 다시 시작하여 성능 카운터가 작동하는지 확인합니다. 성능 카운터가 작동하지 않거나 Performance Counters Enabled 확인란이 이미 선택되어 있으면 2단계로 넘어갑니다.

  2. Microsoft 기술 자료 문서 300956, "성능 카운터 라이브러리 값을 수동으로 다시 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956)에 지정된 대로 누락되거나 손상된 성능 카운터를 다시 빌드합니다.

  3. 이 기술 자료 문서에 따라 수행해도 문제가 해결되지 않으면 Windows 운영 체제를 복구 모드로 다시 설치한 다음 최신 Windows 서비스 팩을 적용해야 합니다.


대기 시간이 긴 MAPI 작업을 찾았습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-11-22

Microsoft® Exchange Server Analyzer Tool은 ExMon(Exchange Server User Monitor) 도구를 사용하여 5분 동안 샘플 데이터를 수집하고 사용자 MAPI 작업이 정상적인 Exchange 서버에서 예상되는 시간보다 오래 걸리는지 여부를 확인합니다.

Exchange Server Analyzer는 데이터를 수집한 시간 동안 완료하는 데 걸리는 시간이 30초를 초과하는 MAPI 작업이 하나 이상 있었던 경우 오류를 표시하고 오류를 트리거한 사용자의 작업에 대해 추가 분석을 수행합니다.

하지만 30초를 초과하는 MAPI 작업이 항상 문제가 되는 것은 아닙니다. 많은 양의 메시지 데이터 또는 첨부 파일을 저장하면 MAPI 작업이 정상 상태일 때보다 오래 걸릴 수 있습니다.

자주 지연이 발생하는 경우 또는 메시징 작업에 나쁜 영향을 미치는 지연이 발생하는 경우 이러한 MAPI 작업 지연을 검사하여 리소스 병목 현상이나 중첩된 종속 관계 등 보다 심각한 지연 문제의 증상이 아닌지 확인합니다.

이 오류를 해결하려면 다음을 수행합니다.

  • ExMon 도구를 사용하여 Exchange Server Analyzer에서 검토할 샘플 데이터를 더 많이 캡처합니다. ExMon에 의해 대량의 데이터가 생성되므로 데이터 샘플을 수집하는 시간은 30분 이하로 설정하는 것이 좋습니다.

  • 관련된 지연 오류 및 함께 제공되는 문서를 검토하여 특정 작업 및 해결 단계를 살펴봅니다. Exchange Server Analyzer에서 보고된 관련 지연 오류가 없는 경우 사용자 작업의 추가 분석은 문제가 없음을 나타냅니다.


장기 실행 MAPI 대량 작업
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Server Analyzer Tool은 ExMon(Exchange Server User Monitor) 도구를 사용하여 사용자 MAPI 작업이 정상적인 Exchange 서버에서 예상되는 시간보다 오래 걸리는지 여부를 확인합니다.

분석하는 과정에서 Exchange Server Analyzer는 사용자가 실행한 MAPI 대량 작업 중 완료하는 데 30초 이상 걸린 작업에 대한 ExMon 데이터를 검토합니다.

MAPI 대량 작업은 두 개 이상의 객체에서 실행되는 작업으로, 대개 리소스 부담이 큽니다(많은 I/O 필요).

Exchange Server Analyzer는 사용자에게 30초가 넘게 걸린 MAPI 대량 작업이 하나 이상 있는 경우 오류를 표시합니다.

하지만 30초를 초과하는 MAPI 대량 작업이 항상 문제가 되는 것은 아닙니다. 한 번에 수천 개의 메시지에 대해 복사, 삭제, 특성 플래그 설정 등의 작업을 수행하는 경우 MAPI 대량 작업이 보통 때보다 오래 걸릴 수 있습니다.

자주 지연이 발생하는 경우 또는 메시징 작업에 나쁜 영향을 미치는 지연이 발생하는 경우 이러한 MAPI 대량 작업 지연을 검사하여 리소스 병목 현상이나 중첩된 종속 관계 등 보다 심각한 지연 문제의 증상이 아닌지 확인합니다.

이 오류를 해결하려면 다음을 수행합니다.

  • ExMon 도구를 사용하여 Exchange Server Analyzer에서 검토할 샘플 데이터를 더 많이 캡처합니다. Exchange에 의해 대량의 데이터가 생성되므로 데이터 샘플을 수집하는 시간은 30분 이하로 설정하는 것이 좋습니다.

자세한 정보

자세한 내용은 다음 Exchange Server 리소스를 참조하십시오.

  • Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Exchange Server 2003 Performance: 10 Things to Think About"(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 기술 자료 문서 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


장기 실행 MAPI 'FindRow' 작업
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-11-22

Microsoft® Exchange Server Analyzer Tool은 ExMon(Exchange Server User Monitor) 도구를 사용하여 사용자 MAPI 작업이 정상적인 Exchange 서버에서 예상되는 시간보다 오래 걸리는지 여부를 확인합니다.

분석 과정에서 Exchange Server Analyzer는 사용자가 실행한 MAPI FindRow 작업 중 완료하는 데 걸린 시간이 30초를 초과하는 작업에 대한 ExMon 데이터를 검토합니다.

각 폴더의 보기 수가 증가하면 여러 MAPI 작업에 오버헤드가 추가될 수 있습니다. 클라이언트 응용 프로그램에서는 SeekRow 또는 FindRow와 같은 MAPI 작업을 사용하여 보기의 행 간에 포인터를 이동합니다. SeekRow는 포인터를 이동할 행 수를 지정하며 CPU 시간과 관련한 리소스 소모량이 매우 낮습니다. 반면 FindRow는 제한 조건과 일치하는 구체화되지 않은, 즉, 캐시되지 않는 보기의 첫 번째 항목으로 포인터를 이동하고 클라이언트 응용 프로그램에서 작업을 마친 후 보기를 제거하므로 리소스 소모량이 매우 높습니다. FindRow의 최종 CPU 소모량은 제한의 복잡도 및 조건과 일치하는 첫 번째 항목을 발견하기 전에 저장소에서 검토해야 할 행 수에 따라 다르며 폴더의 항목 수와는 큰 연관성이 없습니다.

이와 같이 FindRow는 리소스 소모가 많으므로 서버의 부담을 줄일 수 있도록 캐시된 모드를 실행하는 것이 유용할 수 있습니다. 그러나 이 작업에서 발생하는 높은 CPU 비율이 단순히 공유 일정에 의한 것일 경우에는 캐시된 모드를 사용해도 도움이 되지 않습니다. FindRow 작업에서 높은 CPU 시간 소모율이 발생한다는 것은 보기를 만드는 작업이 많거나 리소스를 많이 소모하는 보기가 있거나 폴더 항목의 개수가 많다는 것을 의미합니다.

Exchange Server Analyzer는 사용자가 실행한 MAPI FindRow 작업 중 30초를 초과하는 작업이 확인되면 오류를 표시합니다.

하지만 30초를 초과하는 MAPI FindRow 작업이 항상 문제가 되는 것은 아닙니다. 다만 식별된 사용자에게 지연이 자주 발생하거나 해당 메시징 환경에 나쁜 영향을 주는 지연이 발생하는 경우에는 그 원인을 파악해야 합니다. 특정 사용자에게 지연이 자주 발생하는 경우 다음 사항을 확인해야 합니다.

  • 폴더 내의 항목 수가 많은지 여부

  • 실행 중인 응용 프로그램

이 문제를 해결하려면 다음을 수행합니다.

  • 폴더 내의 항목 수가 많다면 폴더당 항목 수를 줄입니다. 받은 편지함, 일정, 보낸 편지함, 연락처 및 지운 편지함 폴더의 항목 수를 5,000개 미만으로 유지하는 것이 좋습니다.

  • 리소스 부담이 큰 클라이언트 컴퓨터(특히 Restrict, SetColumns 또는 FindRow 작업에 대해 대기 시간이 긴 컴퓨터)가 캐시된 Exchange 모드를 사용하도록 구성합니다. 캐시된 Exchange 모드는 대부분의 초과 RPC 트래픽으로부터 서버를 격리합니다.

  • 모든 응용 프로그램을 종료한 다음 하나씩 다시 시작하여 문제의 원인이 되는 응용 프로그램을 찾습니다. 문제가 되는 응용 프로그램이 업무상 필요하지 않은 경우에는 해당 응용 프로그램을 영구적으로 종료하고, 이 프로그램에 대해 핫픽스가 게시된 경우에는 업데이트를 수행하여 적절한 수준으로 로드를 줄입니다.

참고:
일부 응용 프로그램은 소수의 MAPI 작업만으로도 서버 로드를 현저히 증가시킬 수 있습니다. 이는 해당 응용 프로그램에서 리소스 부담이 큰 작업을 실행하기 때문입니다. 리소스 소모가 큰 작업의 경우에는 그 수가 조금만 증가해도 서버 성능에 큰 영향을 미칠 수 있습니다. ExMon에서는 이러한 작업을 실행하는 사용자를, 실행하는 MAPI 작업 수에 비해 높은 CPU 영향을 발생시키는 사용자로 보고합니다.

또한 리소스 병목 현상(일반적으로 디스크 또는 CPU 병목 현상)이 있으면 FindRow 작업에 대한 대기 시간이 증가합니다.

자세한 정보

자세한 내용은 다음 Exchange Server 리소스를 참조하십시오.

  • Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 Performance: 10 Things to Think About(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 기술 자료 문서 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


장기 실행 MAPI 온라인 작업
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Server Analyzer Tool은 ExMon(Exchange Server User Monitor) 도구를 사용하여 사용자 MAPI 온라인 작업이 정상적인 Exchange 서버에서 예상되는 시간보다 오래 걸리는지 여부를 확인합니다.

MAPI 온라인 작업의 예로는 QueryRows 작업이 있습니다.

QueryRows 작업은 현재 보기의 행을 반환하는 데 사용됩니다. QueryRows는 사용자 요청에 적합한 테이블의 데이터를 사용합니다. SetColumns 작업은 QueryRows에 사용할 수 있는 데이터를 결정합니다. 요청된 속성 크기, 요청된 속성 수 및 요청된 데이터의 행 수에 따라 QueryRows의 리소스 부담이 증가합니다. 요청된 열 및 행 수가 많은 경우에도 QueryRows의 리소스 부담이 클 수 있습니다.

Outlook 사용자의 경우 핵심 Exchange Server 2003 폴더의 항목 수가 증가함에 따라 일부 작업을 수행하는 데 있어 물리적 디스크의 리소스 부담도 증가합니다. 받은 편지함을 크기별로 처음 정렬하는 경우 많은 디스크 I/O가 필요하므로 리소스 부담이 큽니다. 하지만 그 이후에는 받은 편지함을 크기별로 정렬할 때 리소스 부담이 매우 작습니다.

Exchange Server Analyzer는 데이터를 수집한 시간 동안 30초가 넘게 걸린 MAPI 온라인 작업을 하나 이상 확인한 경우 오류를 표시합니다.

MAPI 온라인 작업에서 대기 시간이 길면 서버 리소스 병목 현상을 나타낼 수 있습니다. QueryRows 작업의 경우 폴더에 항목 수가 많거나 내부 테이블에 많은 속성이 설정되어 있음을 나타낼 수도 있습니다.

대기 시간이 긴 온라인 작업이 동시에 많은 데이터에서 수행되는 경우 대기 시간이 길어도 서버 성능에 문제가 있는 것이 아닐 수 있습니다. 예를 들어 폴더의 모든 항목을 선택하고 단일 작업으로 이 항목들을 읽은 것으로 표시할 때 이러한 현상이 나타납니다. 특정 사용자에게 지연이 자주 발생하는 경우 다음 사항을 확인해야 합니다.

  • 폴더 내의 항목 수가 많은지 여부

  • 실행 중인 응용 프로그램

이 문제를 해결하려면 다음을 수행합니다.

  • 폴더 내의 항목 수가 많다면 폴더당 항목 수를 줄입니다. 받은 편지함, 일정, 보낸 편지함, 연락처 및 지운 편지함 폴더의 항목 수를 5,000개 미만으로 유지하는 것이 좋습니다.

  • 모든 응용 프로그램을 종료한 다음 하나씩 다시 시작하여 문제의 원인이 되는 응용 프로그램을 찾습니다. 문제가 되는 응용 프로그램이 업무상 필요하지 않은 경우에는 해당 응용 프로그램을 영구적으로 종료하고, 이 프로그램에 대해 핫픽스가 게시된 경우에는 업데이트를 수행하여 적절한 수준으로 로드를 줄입니다.

참고:
일부 응용 프로그램은 소수의 MAPI 온라인 작업만으로도 서버 로드를 현저히 증가시킬 수 있습니다. 이는 해당 응용 프로그램에서 리소스 부담이 큰 작업을 실행하기 때문입니다. 리소스 소모가 큰 작업의 경우에는 그 수가 조금만 증가해도 서버 성능에 큰 영향을 미칠 수 있습니다. ExMon에서는 이러한 작업을 실행하는 사용자를, 실행하는 MAPI 작업 수에 비해 상대적으로 높은 CPU 영향을 발생시키는 사용자로 보고합니다.

또한 리소스 병목 현상(일반적으로 디스크 또는 CPU 병목 현상)이 있으면 MAPI 온라인 작업에 대한 대기 시간이 증가합니다. 서버 리소스 병목 현상을 확인하고 서버 리소스 용량을 늘리거나 로드가 적은 서버로 사용자를 이동합니다.

자세한 정보

자세한 내용은 다음 Exchange Server 리소스를 참조하십시오.

  • Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 Performance: 10 Things to Think About(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 기술 자료 문서 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


장기 실행 MAPI 작업
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-11-22

Microsoft® Exchange Server Analyzer Tool은 ExMon(Exchange Server User Monitor) 도구를 사용하여 사용자 MAPI 작업이 정상적인 Exchange 서버에서 예상되는 시간보다 오래 걸리는지 여부를 확인합니다.

Exchange Server Analyzer는 사용자에게 30초가 넘게 걸린 MAPI 작업이 하나 이상 있는 경우 오류를 표시합니다.

각 폴더의 보기 수가 증가하면 여러 MAPI 작업에 오버헤드가 추가될 수 있습니다. 이 항목에서는 가장 일반적인 SeekRow와 FindRow에 대해 설명합니다. Exchange Server Analyzer에서 '장기 실행' 작업으로 확인하는 다른 MAPI 작업은 일반적으로 SeekRow 및 FindRow MAPI 작업과 동일한 작업으로 확인할 수 있습니다.

클라이언트 응용 프로그램에서는 SeekRow 또는 FindRow와 같은 MAPI 작업을 사용하여 보기의 행 간에 포인터를 이동합니다. SeekRow는 포인터를 이동할 행 수를 지정하며 CPU 시간과 관련한 리소스 소모량이 매우 낮습니다. 반면 FindRow는 제한 조건과 일치하는 구체화되지 않은, 즉, 캐시되지 않는 보기의 첫 번째 항목으로 포인터를 이동하고 클라이언트 응용 프로그램에서 작업을 마친 후 보기를 제거하므로 리소스 소모량이 매우 높습니다. FindRow의 최종 CPU 순위는 제한의 복잡도 및 각 메시지에 대해 액세스하는 메시지 속성 수에 따라 다르고, 조건과 일치하는 첫 번째 항목을 발견하기 전에 저장소에서 검토해야 할 행 수에 따라 다르므로 폴더의 항목 수와는 크게 관련되어 있지 않습니다.

하지만 30초를 초과하는 MAPI 작업이 항상 문제가 되는 것은 아닙니다. 다만 식별된 사용자에게 지연이 자주 발생하거나 해당 메시징 환경에 나쁜 영향을 주는 지연이 발생하는 경우에는 그 원인을 파악해야 합니다. 특정 사용자에게 지연이 자주 발생하는 경우 다음 사항을 확인해야 합니다.

  • 폴더 내의 항목 수가 많은지 여부

  • 실행 중인 응용 프로그램

이 문제를 해결하려면 다음을 수행합니다.

  • 폴더 내의 항목 수가 많다면 폴더당 항목 수를 줄입니다. 받은 편지함, 일정, 보낸 편지함, 연락처 및 지운 편지함 폴더의 항목 수를 5,000개 미만으로 유지하는 것이 좋습니다.

  • 리소스 부담이 큰 클라이언트 컴퓨터(특히 Restrict, SetColumns 또는 FindRow 작업에 대해 대기 시간이 긴 컴퓨터)가 캐시된 Exchange 모드를 사용하도록 구성합니다. 캐시된 Exchange 모드는 대부분의 초과 RPC 트래픽으로부터 서버를 격리합니다.

  • 모든 응용 프로그램을 종료한 다음 하나씩 다시 시작하여 문제의 원인이 되는 응용 프로그램을 찾습니다. 문제가 되는 응용 프로그램이 업무상 필요하지 않은 경우에는 해당 응용 프로그램을 영구적으로 종료하고, 이 프로그램에 대해 핫픽스가 게시된 경우에는 업데이트를 수행하여 적절한 수준으로 로드를 줄입니다.

참고:
일부 응용 프로그램은 소수의 MAPI 작업만으로도 서버 로드를 현저히 증가시킬 수 있습니다. 이는 해당 응용 프로그램에서 리소스 부담이 큰 작업을 실행하기 때문입니다. 리소스 소모가 큰 작업의 경우에는 그 수가 조금만 증가해도 서버 성능에 큰 영향을 미칠 수 있습니다. ExMon에서는 이러한 작업을 실행하는 사용자를, 실행하는 MAPI 작업 수에 비해 높은 CPU 영향을 발생시키는 사용자로 보고합니다.

또한 리소스 병목 현상(일반적으로 디스크 또는 CPU 병목 현상)이 있으면 MAPI 작업에 대한 대기 시간이 증가합니다. 서버 리소스 병목 현상을 확인하고 서버 리소스 용량을 늘리거나 로드가 적은 서버로 사용자를 이동합니다.

자세한 정보

자세한 내용은 다음 Exchange Server 리소스를 참조하십시오.

  • Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 Performance: 10 Things to Think About(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 기술 자료 문서 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


장기 실행 MAPI 'SaveChangesMessage' 작업
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-11-22

Microsoft® Exchange Server Analyzer Tool은 ExMon(Exchange Server User Monitor) 도구를 사용하여 사용자 MAPI 작업이 정상적인 Exchange 서버에서 예상되는 시간보다 오래 걸리는지 여부를 확인합니다.

분석 과정에서 Exchange Server Analyzer는 사용자가 실행한 MAPI SaveChangesMessage 작업 중 완료하는 데 30초 이상 걸린 작업에 대한 ExMon 데이터를 검토합니다.

응용 프로그램에서 메시지 내용이나 속성을 서버에 저장할 때 MAPI SaveChangesMessage 작업이 호출됩니다. 작업을 완료하는 데 필요한 시간은 기록되는 데이터, 기록되는 데이터베이스 및 트랜잭션 로그 디스크의 속도 및 리소스 병목 현상 발생 여부에 따라 다릅니다.

Exchange Server Analyzer는 사용자가 실행한 MAPI SaveChangesMessage 작업 중 30초를 초과하는 작업이 확인되면 오류를 표시합니다.

하지만 30초를 초과하는 MAPI SaveChangesMessage 작업이 항상 문제가 되는 것은 아닙니다. 많은 양의 메시지 데이터 또는 첨부 파일을 저장하면 MAPI SaveChangesMessage 작업이 정상 상태일 때보다 오래 걸릴 수 있습니다. 사용자에게 지연이 자주 발생하거나 메시징 환경에 나쁜 영향을 주는 지연이 발생하는 경우 대부분은 디스크 병목 현상이 그 원인입니다.

자세한 정보

  • 디스크 병목 현상에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 저장소 아키텍처를 설계하는 최상의 방법에 대한 자세한 내용은 Best Practices Common to Multiple Architectures(http://go.microsoft.com/fwlink/?LinkId=72988)를 참조하십시오.

  • 사용자 사서함을 이동하여 서버 로드를 줄이는 방법에 대한 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.

  • 디스크 크기 조정, 대기 시간, I/O 비율에 대한 자세한 내용은 Microsoft Exchange 팀 블로그 웹 사이트에서 다음 블로그를 참조하십시오.

    • "A few basic concepts in disk sizing"(http://go.microsoft.com/fwlink/?linkid=39538)을 참조하십시오.

    • "Some more thoughts on disk IO and calculations…."(http://go.microsoft.com/fwlink/?linkid=39539)

    • How to Calculate Your Disk I/O Requirements(http://go.microsoft.com/fwlink/?linkid=69747)


장기 실행 MAPI 'SetColumns' 작업
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Server Analyzer Tool은 ExMon(Exchange Server User Monitor) 도구를 사용하여 사용자 MAPI 작업이 Exchange Server를 실행하는 정상적인 서버에서 예상되는 것보다 오래 걸리는지 확인합니다.

분석 과정에서 Exchange Server Analyzer는 사용자가 실행한 MAPI SetColumns 작업 중 완료하는 데 걸린 시간이 30초를 초과하는 작업에 대한 ExMon 데이터를 검토합니다.

MAPI 호출 SetColumns를 사용하면 기본 보기가 생성됩니다. SetColumns 호출은 새 보기 테이블에서 열이 되는 속성을 정의합니다.

보기에서 처음으로 속성이 요청될 때 서버에서는 추가 작업을 통해 보기를 생성해야 합니다. 보기에서 이 속성이 요청된 이후에는 나중 보기에서도 해당 속성이 계속 유지됩니다. 이는 곧 새 속성이 처음 요청될 때는 SetColumns 호출 시간이 훨씬 더 오래 걸릴 수 있음을 의미합니다. 필요한 시간은 새로운 속성 수와 폴더 내 항목 수에 비례합니다. 예를 들어 사용자가 사서함을 이동한 후 처음 받은 편지함을 볼 때 서버에서 보기를 생성하는 데 더 오랜 시간이 걸립니다. 보기가 사서함과 함께 이동되지 않았기 때문입니다. 보기는 다시 생성됩니다.

일반적으로 보기에 속성을 추가하는 작업은 리소스 소모량이 매우 큽니다. 속성 추가에 드는 리소스 소모량은 폴더 내 항목 수와 추가하는 속성 수에 비례합니다. 일반적으로 Microsoft Office® Outlook®을 사용할 때는 많은 속성이 해당 메시지 폴더 테이블에 추가되지 않지만 수동으로는 더 많이 추가될 수 있습니다. 대체로 이런 경우는 문제가 되지 않습니다. 그러나 응용 프로그램에서 정기적으로 열을 추가하거나, 많은 열을 추가하거나, 클라이언트에서 많은 항목에 여러 열을 추가하는 경우에는 지연이 발생할 수 있습니다. 메시지 폴더 테이블에 열이 많으면 많을수록 해당 폴더 항목의 모든 다른 작업에 대한 오버헤드도 증가합니다. 열이 추가된 후에는 이를 바로 제거할 수 없습니다. Message-Folder 테이블의 각 속성은 해당 폴더에 항목을 삽입할 때 오버헤드를 추가합니다.

Exchange Server Analyzer는 사용자가 실행한 MAPI SetColumns 작업 중 30초를 초과하는 작업이 확인되면 오류를 표시합니다.

사서함이 새 데이터베이스 또는 새 서버로 이동된 후 처음으로 사서함에 액세스할 때 서버에서는 새 보기를 만들어야 합니다. 이 경우 SetColumns와 Restrict의 장기 호출이 있을 수 있습니다. 사서함을 이동한 후 며칠 동안은 이러한 오류를 안전하게 무시할 수 있습니다.

일부 응용 프로그램은 새 보기를 만들고 속성을 내부 저장소 데이터 구조로 승격시킵니다. 이로 인해 서버가 사용자의 데이터에 액세스할 때 서버 성능에 장기적인 영향을 미칠 수 있습니다. 그러나 식별된 사용자에게 지연이 자주 발생하거나 해당 메시징 환경에 나쁜 영향을 주는 지연이 발생하는 경우에는 그 원인을 파악해야 합니다. 특정 사용자에게 지연이 자주 발생하는 경우 다음 사항을 확인해야 합니다.

  • 폴더 내 항목 수가 많은지 여부

  • 실행 중인 응용 프로그램

이 문제를 해결하려면 다음 단계를 수행합니다.

  • 폴더 내의 항목 수가 많다면 폴더당 항목 수를 줄입니다. 받은 편지함, 일정, 보낸 편지함, 연락처 및 지운 편지함 폴더의 항목 수를 5,000개 미만으로 유지하는 것이 좋습니다.

  • 작업 면에서 가장 부담이 큰 클라이언트 컴퓨터에서 캐시된 Exchange 모드를 사용하도록 구성합니다. Restrict, SetColumns 또는 FindRow 작업에서 대기 시간이 긴 클라이언트 컴퓨터에 대해 특히 주의를 기울여야 합니다. 캐시된 Exchange 모드는 대부분의 초과 RPC 트래픽으로부터 서버를 격리합니다.

  • 모든 응용 프로그램을 종료한 다음 하나씩 다시 실행하여 문제의 원인이 되는 응용 프로그램을 찾습니다. 다음 조건 중 하나에 해당되는 경우 문제의 원인이 되는 응용 프로그램을 영구적으로 종료하거나 업데이트하여 로드를 적절한 수준으로 줄입니다.

    • 응용 프로그램을 업무용으로 사용하지 않는 경우

    • 응용 프로그램에 게시된 업데이트가 있는 경우

참고:
일부 응용 프로그램은 소수의 MAPI 작업만으로도 서버 로드를 현저히 증가시킬 수 있습니다. 이는 해당 응용 프로그램에서 리소스 부담이 큰 작업을 실행하기 때문입니다. 리소스 소모가 큰 작업의 경우에는 그 수가 조금만 증가해도 서버 성능에 큰 영향을 미칠 수 있습니다. ExMon에서는 이러한 사용자를, 실행하는 MAPI 작업 수에 비해 높은 CPU 영향을 발생시키는 사용자로 보고합니다.

또한 리소스 병목 현상(일반적으로 디스크 또는 CPU 병목 현상)이 있으면 SetColumns 작업에 대한 대기 시간이 증가합니다.

자세한 정보

자세한 내용은 다음 Exchange Server 리소스를 참조하십시오.

  • "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)

  • "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 Performance: 10 Things to Think About(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 기술 자료 문서 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


장기 실행 MAPI 동기화 작업
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Server Analyzer Tool은 ExMon(Exchange Server User Monitor) 도구를 사용하여 사용자 MAPI 작업이 정상적인 Exchange 서버에서 예상되는 시간보다 오래 걸리는지 여부를 확인합니다.

분석 과정에서 Exchange Server Analyzer는 사용자가 실행한 MAPI 동기화 작업 중 완료하는 데 걸린 시간이 30초를 초과하는 작업에 대한 ExMon 데이터를 검토합니다.

MAPI 동기화 작업은 Microsoft Office® Outlook® 오프라인 폴더 파일(.ost) 또는 사용자 사서함의 로컬 복사본을 서버의 사용자 사서함 데이터와 동기화하기 위해 수행됩니다.

하지만 완료하는 데 걸리는 시간이 30초를 초과하는 MAPI 동기화 작업이 항상 문제가 되는 것은 아닙니다. Outlook 2003에서 처음으로 캐시된 Exchange 모드를 사용하는 경우 Exchange Server에 저장되었거나 전체 주소 목록의 전체 복사본에 해당하는 모든 전자 메일 메시지는 기본적으로 사용자의 컴퓨터에 다운로드됩니다.

처음으로 Exchange Server와 동기화하는 동안 Outlook 2003 사용자는 응답 지연을 경험할 수 있습니다.

최초의 캐시된 모드 동기화 이후에 사용자에게 지연이 자주 발생하거나 메시징 환경에 나쁜 영향을 미치는 지연이 발생하는 경우 이러한 MAPI 동기화 작업 지연을 검사해 리소스 병목 현상과 같은 보다 심각한 지연 문제의 증상이 아닌지 확인해야 합니다.

리소스 병목 현상(일반적으로 디스크 또는 CPU 병목 현상)이 있으면 항상 MAPI 동기화 작업의 대기 시간이 증가합니다. 서버 리소스 병목 현상을 식별하고 서버 리소스 용량을 늘리거나 로드가 적은 서버로 사용자를 이동합니다.

자세한 정보

자세한 내용은 다음 Exchange Server 리소스를 참조하십시오.

  • Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Exchange Server 2003 Performance: 10 Things to Think About"(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 기술 자료 문서 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


장기 실행 MAPI 'TaskQ' 작업
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-02-20

Microsoft Exchange Analyzer Tool은 ExMon(Exchange Server User Monitor) 도구를 사용하여 사용자 MAPI 작업이 정상적인 Exchange 서버에서 예상되는 시간보다 오래 걸리는지 여부를 확인합니다.

분석하는 과정에서 Exchange Analyzer는 사용자가 실행한 MAPI TaskQ 작업 중 완료하는 데 30초 이상 걸린 작업에 대한 ExMon 데이터를 검토합니다.

TaskQ 작업은 RPC 호출 컨텍스트 외부에서 실행되는 비동기 작업입니다. TaskQ 및 TaskQ User Unknown 작업은 Exchange의 요청에 따라 실행되는 작업이며 저장소 유지 관리를 포함합니다. TaskQ User Known 작업은 직접 사용자 요청에 의해 시작되는 비동기 작업이며, 검색 폴더 채우기, 정렬 및 대량 작업(예: 여러 메시지에 대한 이동, 복사, 삭제 및 메시지를 읽은 상태로 표시)이 여기에 해당합니다.

Exchange Analyzer는 사용자가 실행한 MAPI TaskQ 작업을 완료하는 데 30초보다 오래 걸린 경우 경고를 표시합니다.

TaskQ 작업은 일반적으로 완료하는 데 시간이 오래 걸릴 수 있는 작업이므로 이러한 현상이 항상 성능 문제를 나타내는 것은 아닙니다.

이 문제를 해결하려면 다음을 수행합니다.

  • ExMon 도구를 사용하여 Exchange Server Analyzer에서 검토할 샘플 데이터를 더 많이 캡처합니다. Exchange에 의해 대량의 데이터가 생성되므로 데이터 샘플을 수집하는 시간은 30분 이하로 설정하는 것이 좋습니다.

자세한 정보

자세한 내용은 다음 Exchange Server 리소스를 참조하십시오.

  • Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)

  • Exchange Server 2003 Performance: 10 Things to Think About(http://go.microsoft.com/fwlink/?LinkId=56460)


MAPI 'Restrict' 작업으로 인한 장기 실행 작업
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-23

Microsoft® Exchange Server Analyzer Tool은 ExMon(Exchange Server User Monitor) 도구를 사용하여 사용자 MAPI 작업이 Exchange Server를 실행하는 정상적인 서버에서 예상되는 것보다 오래 걸리는지 확인합니다.

분석 과정에서 Exchange Server Analyzer는 사용자가 실행한 MAPI Restrict 작업 중 완료하는 데 걸린 시간이 30초를 초과하는 작업에 대한 ExMon 데이터를 검토합니다.

클라이언트 응용 프로그램에서는 MAPI Restrict 작업을 사용하여 특정 조건과 일치하는 항목을 선택할 수 있습니다. 서버에서는 제한이라는 관련 조건을 사용하여 보기, 즉 테이블을 만듭니다. 제한과 일치하는 보기가 있으면 서버에서는 기존 보기를 사용하여 사용자 요청을 충족합니다. 서버에서 이 보기를 사용하는 작업은 서버에서 새 보기를 만드는 것보다 부담이 덜합니다. 기본적으로 저장소에서는 각 폴더에 대해 11개 보기만 캐시합니다. 12개째 보기를 만들도록 서버에 요청하면 가장 오래된 캐시된 보기가 삭제되고 새 보기가 만들어집니다. 보기는 항목의 모든 작업에 오버헤드를 추가합니다.

Exchange Server Analyzer는 사용자가 실행한 MAPI Restrict 작업 중 30초를 초과하는 작업이 확인되면 오류를 표시합니다.

하지만 30초를 초과하는 MAPI Restrict 작업이 항상 문제가 되는 것은 아닙니다. 그러나 사용자에게 지연이 자주 발생하거나 메시징 환경에 나쁜 영향을 미치는 지연이 발생하는 경우 이러한 지연은 사용자 응용 프로그램으로 인해 새 보기가 생성됨을 나타낼 수 있습니다.

이 오류를 해결하려면 지연이 자주 발생하는 사용자로부터 다음 사항을 확인합니다.

  • 폴더 내 항목 수가 많은지 여부

  • 실행 중인 응용 프로그램

이 문제를 해결하려면 다음 단계를 수행합니다.

  • 폴더 내의 항목 수가 많다면 폴더당 항목 수를 줄입니다. 받은 편지함, 일정, 보낸 편지함, 연락처 및 지운 편지함 폴더의 항목 수를 5,000개 미만으로 유지하는 것이 좋습니다.

  • 작업 면에서 가장 부담이 큰 클라이언트 컴퓨터에서 캐시된 Exchange 모드를 사용하도록 구성합니다. Restrict, SetColumns 또는 FindRow 작업에서 대기 시간이 긴 클라이언트 컴퓨터에 대해 특히 주의를 기울여야 합니다. 캐시된 Exchange 모드는 대부분의 초과 RPC 트래픽으로부터 서버를 격리합니다.

  • 다음 섹션에서 참조된 Exchange 팀 블로그의 안내에 따라 이벤트 로그 제한 추적을 설정합니다. 그런 다음 사용자 응용 프로그램을 하나씩 실행하여 어떤 응용 프로그램으로 인해 장기 실행 제한이 발생하는지 추적합니다.

  • 모든 응용 프로그램을 종료한 다음 하나씩 다시 실행하여 문제의 원인이 되는 응용 프로그램을 찾습니다. 다음 조건 중 하나에 해당되는 경우 문제의 원인이 되는 응용 프로그램을 영구적으로 종료하거나 업데이트하여 로드를 적절한 수준으로 줄입니다.

    • 응용 프로그램을 업무용으로 사용하지 않는 경우

    • 응용 프로그램에 게시된 업데이트가 있는 경우

참고:
일부 응용 프로그램은 소수의 MAPI 작업만으로도 서버 로드를 현저히 증가시킬 수 있습니다. 이는 해당 응용 프로그램에서 리소스 부담이 큰 작업을 실행하기 때문입니다. 리소스 소모가 큰 작업의 경우에는 그 수가 조금만 증가해도 서버 성능에 큰 영향을 미칠 수 있습니다. ExMon에서는 이러한 사용자를, 실행하는 MAPI 작업 수에 비해 높은 CPU 영향을 발생시키는 사용자로 보고합니다.

또한 리소스 병목 현상(일반적으로 디스크 또는 CPU 병목 현상)이 있으면 Restrict 작업에 대한 대기 시간이 증가합니다.

자세한 정보

MAPI Restrict 작업에 대한 자세한 내용은 Microsoft Exchange 팀 블로그, "Putting the Restrictions on Restrictions"(http://go.microsoft.com/fwlink/?linkid=55098)를 참조하십시오.

참고:
블로그의 내용과 해당 URL은 예고 없이 변경될 수 있습니다.

자세한 내용은 다음 Exchange Server 리소스를 참조하십시오.

  • "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)

  • "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Exchange Server 2003 Performance: 10 Things to Think About"(http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft 기술 자료 문서 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


MAD.EXE 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더 및 \Exchsrvr\bin 폴더 모두에서 확인)

  • Mapi32.dll(System32 폴더 및 \Exchsrvr\bin 폴더 모두에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


MAD NSPI 포트 번호가 5000 미만입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange System Attendant 서비스의 TCP/IP NSPI Port 설정을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

TCP/IP NSPI Port가 5000(10진수) 미만의 값으로 설정되어 있으면 Exchange Server Analyzer에서 경고를 표시합니다.

TCP/IP NSPI Port를 정적 값으로 설정해야 하는 경우 5000 이상의 값으로 설정하는 것이 좋습니다. 정적 포트 번호를 5000 이하로 지정하면 포트가 다른 프로세스와 충돌하여 Exchange System Attendant 서비스 프로세스 오류가 발생할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP NSPI Port 레지스트리 키를 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. TCP/IP NSPI Port 키를 두 번 클릭하고 값 데이터 필드를 5000(10진수)보다 큰 정수로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. Microsoft Exchange System Attendant 서비스를 다시 시작하여 이러한 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

포트 제한에 대한 자세한 내용은 기술 자료 문서 194952, "XADM: Statically Mapped Port Limitations for Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)를 참조하십시오.


MAD RFR 포트가 수동으로 다시 정의되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange System Attendant 디렉터리 조회 포트의 포트 값이 수동으로 다시 정의되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

Exchange Server Analyzer는 TCP/IP Port가 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

일반적으로 MAPI 클라이언트가 방화벽의 다른 쪽에 있는 Exchange 서버에 연결할 수 있도록 하기 위해 이 값이 구성됩니다. 이를 위해서는 방화벽의 포트를 여러 개 열어서 Microsoft® Office Outlook®?2003 클라이언트가 MAPI를 사용하여 인터넷을 통해 Exchange 서버에 연결할 수 있도록 해야 합니다. 이 구성이 지원됩니다. 방화벽을 통해 MAPI 클라이언트를 Exchange에 연결하도록 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 270836, "Exchange 2000 정적 포트 매핑"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)을 참조하십시오. 이 시나리오를 사용하고 있지 않으면 레지스트리 키를 제거해야 합니다.

MAPI 모드에서 Outlook을 사용하여 인터넷을 통해 Exchange 서버에 연결할 때 권장되는 배포 방법은 Microsoft Windows Server™ 003, Exchange Server 003, Outlook 003 및 Windows® XP Professional에서 제공하는 RPC(원격 프로시저 호출) over HTTP(Hypertext Transfer Protocol) 기능을 사용하는 것입니다. 전에는 MAPI 모드를 회사 또는 작업 그룹 모드라고 했습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP 포트 레지스트리 값을 제거하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. TCP/IP Port라는 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange System Attendant 서비스를 다시 시작합니다.

RPC over HTTPS를 배포하려면 다음을 수행합니다.

  1. Exchange Server 2003 RPC over HTTP Deployment Scenarios(http://go.microsoft.com/fwlink/?linkid=47577)를 검토하십시오.

  2. Microsoft 기술 자료 문서 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)을 검토하십시오.

  3. 기술 자료 문서 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)을 검토하십시오.

  4. Microsoft 기술 지원 웹캐스트, "웹캐스트: Microsoft Office Outlook 2003에서 인터넷(RPC/HTTP)을 통해 Microsoft Exchange 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)을 검토하십시오.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MAD RFR 포트가 5000 미만입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange System Attendant 서비스의 TCP/IP Port 설정을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

Exchange Server Analyzer는 TCP/IP Port가 5000(10진수) 미만의 값으로 설정되어 있을 경우 경고를 표시합니다.

TCP/IP Port를 정적 값으로 설정해야 할 경우 5000보다 약간 큰 값으로 설정하는 것이 좋습니다. 5000 미만의 정적 포트 번호를 할당하면 다른 프로세스와 포트 충돌이 발생할 수 있고 Microsoft Exchange System Attendant 서비스 프로세스가 실패하게 됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP 포트 레지스트리 값을 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. TCP/IP Port 키를 두 번 클릭하고 값 데이터 필드를 5000(10진수)보다 큰 정수로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. Microsoft Exchange System Attendant 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

포트 설정에 대한 자세한 내용은 기술 자료 문서 194952, "XADM: Statically Mapped Port Limitations for Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)를 참조하십시오.


MAPI32.DLL 파일이 bin 폴더에 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


system 32 폴더에 MAPI32.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 다시 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


MAPISTUB.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더 및 \Exchsrvr\bin 폴더 모두에서 확인)

  • Mapi32.dll(System32 폴더 및 \Exchsrvr\bin 폴더 모두에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 TAG다시 설치TAG를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server 또는 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


MAPISP32.EXE 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 해결하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 다시 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


최대 ESE 캐시 크기가 1.2GB보다 큽니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 DataBase 성능 개체의 DataBase Cache Size (DBCacheSize) 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

DataBase Cache Size (DBCacheSize) 성능 카운터는 저장소에서 사용되는 현재 캐시 크기를 나타냅니다. Exchange Server Analyzer는 DataBase Cache Size (DBCacheSize) 성능 카운터 값이 307200(1.2GB)보다 클 경우 오류를 표시합니다.

이 오류는 Microsoft Exchange Information Store(MSExchangeIS) 개체의 msExchESEParamCacheSizeMax 특성 값이 최대 권장 값 307200(1.2GB)을 초과했음을 나타냅니다.

저장소 데이터베이스 캐시는 ESE(확장 가능한 저장소 엔진) 버퍼라고도 합니다. 이 캐시는 데이터베이스 트랜잭션이 데이터베이스에 커밋되기 전에 해당 트랜잭션을 캐시합니다.

Exchange 2000 Server의 경우 Store.exe에서 사용하는 가상 메모리의 많은 부분이 ESE 버퍼에 할당됩니다. Exchange 2000 Server는 이 버퍼에 대해 하드 코드된 기본값 858MB(메가바이트)를 사용합니다. Exchange Server 2003에서 ESE 버퍼는 Boot.ini 파일에 있는 /3GB 스위치의 존재 여부에 따라 할당됩니다. /3GB 스위치가 있을 경우 ESE 버퍼는 896MB로 조정됩니다. /3GB 스위치가 없을 경우에는 ESE 버퍼가 576MB로 조정됩니다. 모든 경우에 자동 조정을 사용할 수 있지만 자동 조정을 무시하고 수동으로 사용자 환경에 더 적절한 값을 설정할 수 있습니다.

실제 메모리가 할당되는 것과 같이 이 값을 8,192바이트의 배수로 조정할 수 있지만 다음 표의 값을 사용하는 것이 좋습니다.

권장 값 | 할당되는 메모리 | 설명
147456 | 576MB | 최소 권장 값입니다. 이 값보다 낮은 값으로 설정하지 마십시오. 이 값은 Microsoft Windows® 2000 Server에서 실행하는 Exchange Server 2003 컴퓨터 및 가상 메모리가 제한된 서버에 유용합니다. 이 값은 /3GB 스위치를 지원하지 않습니다. 이 값은 또한 /3GB 스위치를 사용하지 않는 시스템의 기본값에 해당합니다.
196608 | 768MB | 대용량 가상 메모리가 있고 9582 이벤트를 자주 기록하는 서버에서도 이 값이 권장됩니다.
219726 | 858MB | Exchange 2000 Server의 기본값입니다. 대용량 가상 메모리가 있는 시스템을 내부 업그레이드하는 경우 이 값을 사용하는 것이 좋습니다.
229376 | 896MB | Exchange Server 2003의 기본값입니다. 응용 프로그램 이벤트 로그에서 9582 이벤트에 대해 다르게 지정하는 경우가 아니면 새 시스템에는 이 값을 사용하는 것이 좋습니다.
307200 | 1.2GB | 설정할 수 있는 최대값입니다. 이 값은 실제 메모리가 2GB(기가바이트) 이상인 시스템에만 사용해야 합니다.

이 값을 다시 구성하기 전에 Store.exe 프로세스에서 사용하는 가상 메모리 양을 모니터링해야 합니다. Microsoft Windows에서 Process 성능 개체를 모니터링하여 이 작업을 수행할 수 있습니다. /3GB 스위치가 있는 시스템에서는 Process 개체의 Store.exe 인스턴스에 대한 Virtual Bytes 카운터가 2.8GB보다 작아야 합니다. /3GB 스위치가 없는 시스템에서는 Process 개체의 Store.exe 인스턴스에 대한 Virtual Bytes 카운터가 1.8GB보다 작아야 합니다. 값이 이보다 클 경우 msExchESEParamCacheSizeMax 값을 줄여야 할 수 있습니다. 값이 이보다 작을 경우 msExchESEParamCacheSizeMax 값을 늘려야 할 수 있습니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory® 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
msExchESEParamCacheSizeMax 특성을 조정하려면 다음을 수행합니다.

  1. ADSI 편집 같은 Active Directory 편집기를 엽니다.

  2. Configuration 컨테이너를 두 번 클릭합니다.

  3. CN=Services를 확장합니다.

  4. CN=Microsoft Exchange를 확장합니다.

  5. CN=<Exchange Organization Name>을 확장합니다.

  6. CN=Administrative Groups를 확장합니다.

  7. CN=<Administrative Group Name>을 확장합니다.

  8. CN=Servers를 확장합니다.

  9. CN=<Exchange Server Name>을 확장합니다.

  10. CN=InformationStore를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  11. 특성 필드에서 msExchESEParamCacheSizeMax가 나타날 때까지 스크롤한 다음 두 번 클릭합니다.

  12. 값 필드에 설정할 값을 입력합니다. 이 문서의 표를 사용하여 사용 중인 시스템에 가장 적합한 값을 결정합니다.

  13. 확인을 클릭한 다음 확인을 다시 클릭합니다.

  14. Active Directory 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

메모리 사용 최적화에 대한 자세한 내용은 Microsoft Exchange Server 2003 메시징 시스템 계획(http://go.microsoft.com/fwlink/?LinkId=47584)의 "Exchange Server 2003 메모리 사용 최적화"를 참조하십시오.

msExchESEParamCacheSizeMax 특성에 대한 자세한 내용은 Microsoft 기술 자료 문서 266768, "How to modify the Store Database maximum cache size in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768)를 참조하십시오.


최대 받는 사람 수 제한이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchRecipLimit 특성이 기본값에서 변경되었는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msExchRecipLimit 특성은 각 전자 메일 메시지의 받는 사람에 대한 전체 최대 수 값을 저장합니다. 기본적으로 msExchRecipLimit 특성 값은 5000입니다. Exchange Server Analyzer는 msExchRecipLimit 특성 값이 5000과 같지 않음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다.

전체 최대 받는 사람 수 제한은 전체 Exchange 조직에 적용됩니다. msExchRecipLimit 특성 값은 하나의 전자 메일 메시지에 대한 받는 사람 수를 제한합니다. 전체 최대 받는 사람 수 제한은 시스템 메시지와 비시스템 메시지에 영향을 줍니다. 시스템 메시지에는 공용 폴더 복제 메시지가 들어 있습니다.

참고:
또한 Active Directory 사용자 및 컴퓨터를 사용하여 사용자를 기반으로 하는 받는 사람 수 제한을 설정할 수 있습니다. 사용자별 설정은 전역 설정보다 우선하고 전역 설정은 무시됩니다. 기본적으로 사용자별 받는 사람 수 제한은 전체 최대 받는 사람 수 제한을 사용하도록 설정됩니다.
참고:
SMTP(Simple Mail Transfer Protocol) 가상 서버에서 인터넷 사용자로부터 받은 메시지의 경우 메시지당 받는 사람 수에 제한을 설정할 수 있습니다. 이 제한은 전체 최대 받는 사람 수 제한 및 사용자별 받는 사람 수 제한과 다릅니다. 전체 최대 받는 사람 수 제한과 사용자별 받는 사람 수 제한은 모두 Exchange 사용자가 메시지를 보낼 수 있는 받는 사람 수를 제한합니다.
전체 최대 받는 사람 수 제한을 기본값으로 변경하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 왼쪽 창에서 전역 설정을 확장합니다.

  3. 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 기본값 탭의 받는 사람 수 제한에서 최대 받는 사람 수를 클릭한 다음 5000을 입력합니다.

  5. Microsoft Exchange Information Store 서비스를 다시 시작합니다.

받는 사람 수 제한 설정 및 Microsoft Office Outlook® Web Access 클라이언트 구성에 대한 자세한 내용은 Exchange Server 2003 메시지 보안 가이드 (http://go.microsoft.com/fwlink/?LinkId=23216)의 "부록 B: Outlook Web Access S/MIME Control 관련 설정"을 참조하십시오.

전체 최대 받는 사람 수 제한 기록에 대한 자세한 내용은 Exchange 웹 로그 문서, "Me Too!"를 참조하십시오. (http://go.microsoft.com/fwlink/?LinkId=41848)


최대 받는 사람 제한이 높습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 메시지의 msExchRecipLimit 값이 7500을 초과하는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchRecipLimit 특성 값이 7500보다 큰 경우 경고를 표시합니다.

msExchRecipLimit 특성은 각 전자 메일 메시지의 받는 사람에 대한 전체 최대 수 값을 저장합니다. 이 값은 하나의 전자 메일 메시지에 대한 받는 사람 수를 제한합니다. 또한 이 값은 시스템 메시지와 비시스템 메시지에 영향을 줍니다. 시스템 메시지에는 공용 폴더 복제 메시지가 들어 있습니다. 기본적으로 msExchRecipLimit 특성 값은 5000입니다.

msExchRecipLimit 특성 값이 7500을 초과하면 받는 사람이 다수인 메시지로 인해 발생된 문제의 위험성이 커지게 됩니다.

참고:
또한 Active Directory 사용자 및 컴퓨터를 사용하여 사용자를 기반으로 하는 받는 사람 수 제한을 설정할 수 있습니다. 사용자별 설정은 전역 설정보다 우선하고 전역 설정은 무시됩니다. 기본적으로 사용자별 받는 사람 수 제한은 전체 최대 받는 사람 수 제한을 사용하도록 설정됩니다.
참고:
SMTP(Simple Mail Transfer Protocol) 가상 서버에서 인터넷 사용자로부터 받은 메시지의 경우 메시지당 받는 사람 수에 제한을 설정할 수 있습니다. 이 제한은 전체 최대 받는 사람 수 제한 및 사용자별 받는 사람 수 제한과 다릅니다. 전체 최대 받는 사람 수 제한과 사용자별 받는 사람 수 제한은 모두 Exchange 사용자가 메시지를 보낼 수 있는 받는 사람 수를 제한합니다.
전체 최대 받는 사람 수 제한을 기본값으로 변경하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 왼쪽 창에서 전역 설정을 확장합니다.

  3. 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 기본값 탭의 받는 사람 수 제한에서 최대 받는 사람 수를 클릭한 다음 5000을 입력합니다.

  5. Microsoft Exchange Information Store 서비스를 다시 시작합니다.

받는 사람 수 제한 설정 및 Microsoft Office Outlook® Web Access 클라이언트 구성에 대한 자세한 내용은 Exchange Server 2003 메시지 보안 가이드 (http://go.microsoft.com/fwlink/?LinkId=23216)의 "부록 B: Outlook Web Access S/MIME Control 관련 설정"을 참조하십시오.

전체 최대 받는 사람 수 제한 기록에 대한 자세한 내용은 Exchange 웹 로그 문서, "Me Too!"를 참조하십시오. (http://go.microsoft.com/fwlink/?LinkId=41848)


최대 받는 사람 제한이 너무 낮습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 메시지의 msExchRecipLimit 값이 Exchange 조직의 공용 폴더 저장소 수보다 작은지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchRecipLimit 특성 값이 공용 폴더 저장소의 수보다 적음을 확인하면 오류를 표시합니다.

msExchRecipLimit 특성은 각 전자 메일 메시지의 받는 사람에 대한 전체 최대 수 값을 저장합니다. 이 값은 하나의 전자 메일 메시지에 대한 받는 사람 수를 제한합니다. 또한 이 값은 시스템 메시지와 비시스템 메시지에 영향을 줍니다. 시스템 메시지에는 공용 폴더 복제 메시지가 들어 있습니다. 기본적으로 msExchRecipLimit 특성 값은 5000입니다. msExchRecipLimit 특성 값이 Exchange 조직의 공용 폴더 저장소 수보다 적은 경우 공용 폴더 계층 구조 복제에 문제가 발생됩니다.

참고:
또한 Active Directory 사용자 및 컴퓨터를 사용하여 사용자를 기반으로 하는 받는 사람 수 제한을 설정할 수 있습니다. 사용자별 설정은 전역 설정보다 우선하고 전역 설정은 무시됩니다. 기본적으로 사용자별 받는 사람 수 제한은 전체 최대 받는 사람 수 제한을 사용하도록 설정됩니다.
참고:
SMTP(Simple Mail Transfer Protocol) 가상 서버에서 인터넷 사용자로부터 받은 메시지의 경우 메시지당 받는 사람 수에 제한을 설정할 수 있습니다. 이 제한은 전체 최대 받는 사람 수 제한 및 사용자별 받는 사람 수 제한과 다릅니다. 전체 최대 받는 사람 수 제한과 사용자별 받는 사람 수 제한은 모두 Exchange 사용자가 메시지를 보낼 수 있는 받는 사람 수를 제한합니다.
전체 최대 받는 사람 수 제한을 기본값으로 변경하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 왼쪽 창에서 전역 설정을 확장합니다.

  3. 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 기본값 탭의 받는 사람 수 제한에서 최대 받는 사람 수를 클릭하여 값이 Exchange 조직의 공용 폴더 저장소의 수보다 적지 않은지 확인합니다.

  5. Microsoft Exchange Information Store 서비스를 다시 시작합니다.

받는 사람 수 제한 설정 및 Microsoft Office Outlook® Web Access 클라이언트 구성에 대한 자세한 내용은 Exchange Server 2003 메시지 보안 가이드(http://go.microsoft.com/fwlink/?LinkId=47574)의 "부록 B: Outlook Web Access S/MIME Control 관련 설정"을 참조하십시오.

전체 최대 받는 사람 수 제한 기록에 대한 자세한 내용은 Exchange 웹 로그 문서, "Me Too!"를 참조하십시오. (http://go.microsoft.com/fwlink/?LinkId=41848)


MaxUserPort 키가 없거나 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-23

Microsoft Exchange Analyzer Tool은 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인하기 위해 Active Directory 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 5.5"가 포함되어 있으면 해당 컴퓨터에서 Exchange Server 5.5를 실행하고 있는 것입니다. 문자열 값에 "Version 6.0"이 포함되어 있으면 해당 컴퓨터에서 Exchange 2000 Server를 실행하고 있는 것입니다. 문자열 값에 "Version 6.5"가 포함되어 있으면 해당 컴퓨터에서 Exchange Server 2003을 실행하고 있는 것이고, 문자열 값에 "Version 8.0"이 포함되어 있으면 컴퓨터에서 Exchange Server 2007을 실행하고 있는 것입니다.

그런 다음 Exchange Analyzer Tool은 발견된 각 Exchange Server 2007 서버에 대해 다음 레지스트리 분기를 읽고 MaxUserPort 키의 값이 기본값인 60000으로 설정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

MaxUserPort 키는 응용 프로그램이 시스템에서 사용할 수 있는 사용자 포트를 요청할 경우 TCP가 할당할 수 있는 가장 큰 포트 번호를 결정합니다.

기본적으로 Microsoft Windows Server 2003은 MaxUserPort 값을 5000으로 설정합니다. Microsoft Windows 2000은 레지스트리에 MaxUserPort 값을 추가하지 않습니다. 이 값을 수동으로 추가할 수는 있습니다. 그러나 Windows Server 2003 및 Windows 2000 Server에서 Exchange Server 2003 및 Exchange Server 2007은 기본값을 60000으로 설정합니다. Exchange 2000 Server는 값을 설정하지 않습니다.

MaxUserPort 값을 60000으로 설정하는 것이 좋습니다. MaxUserPort 값을 60000보다 낮게 설정한 경우 이벤트 9040과 같은 NSPI(Name Service Provider Interface) 프록시 경고가 발생할 수 있습니다. 이벤트 9040은 다음 표에 설명되어 있습니다.

이벤트 ID | 9040
이벤트 범주 | NSPI 프록시
이벤트 원본 | MSExchangeSA
이벤트 종류 | 경고
이벤트 설명 | 패킷을 받는 동안 NSPI 프록시에 오류가 발생했습니다. 대상 도메인 컨트롤러 또는 네트워크나 클라이언트가 종료될 수 있습니다. Winsock 하위 시스템이 [0x2746] 오류를 반환했습니다. 이 오류를 받은 회로를 닫고 있습니다.
중요:
이 항목에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 먼저 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\Tcpip\Parameters를 탐색합니다.

  3. MaxUserPort를 두 번 클릭하고 값 데이터 필드를 60000(10진수)으로 설정한 다음 확인을 클릭합니다.

  4. 이 설정을 적용하려면 레지스트리 편집기를 닫고 컴퓨터를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

이 문제는 TcpTimedWaitDelay 키가 없거나 기본값이 아닙니다. Analyzer 문제와 관련되어 있습니다.

MaxUserPort 및 TcpTimedWaitDelay 레지스트리 키의 영향에 대한 자세한 내용은 Windows 2000 Resource Kit의 "Transmission Control Protocol" 항목(http://go.microsoft.com/fwlink/?LinkId=85654)을 참조하십시오.


MaxUserPort 값이 너무 낮습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키를 읽어 TCP 사용 후 삭제 포트의 최대값을 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\MaxUserPort

사용 후 삭제 포트는 간단하게 사용되는 포트입니다.

Exchange Server Analyzer는 MaxUserPort 키 값이 50000보다 작을 경우 경고를 표시합니다.

MaxUserPort 값은 응용 프로그램이 시스템에서 사용할 수 있는 사용자 포트를 요청할 경우 TCP가 할당할 수 있는 가장 큰 포트 번호를 지정합니다. 일반적으로 사용 후 삭제 포트에는 1024에서 5000 사이의 포트 번호가 할당됩니다.

기본적으로 Microsoft Windows Server™ 2003은 MaxUserPort 값을 5000으로 설정합니다. Microsoft Windows® 2000은 레지스트리에 MaxUserPort 값을 추가하지 않습니다. MaxUserPort 값은 레지스트리에 직접 추가할 수 있습니다. 그러나 Windows Server 2003 및 Windows 2000 Server에서 Exchange Server 2003은 기본값을 60000으로 설정합니다. Exchange 2000 Server는 값을 설정하지 않습니다.

MaxUserPort 값을 60000으로 설정하는 것이 좋습니다. MaxUserPort 값을 60000보다 낮게 설정한 경우 이벤트 9040과 같은 NSPI(Name Service Provider Interface) 프록시 경고가 발생할 수 있습니다. 이벤트 9040은 다음 표에 설명되어 있습니다.

이벤트 ID | 9040
이벤트 범주 | NSPI 프록시
이벤트 원본 | MSExchangeSA
이벤트 종류 | 경고
이벤트 설명 | 패킷을 받는 동안 NSPI 프록시에 오류가 발생했습니다. 대상 도메인 컨트롤러 또는 네트워크나 클라이언트가 종료될 수 있습니다. Winsock 하위 시스템이 [0x2746] 오류를 반환했습니다. 이 오류를 받은 회로를 닫고 있습니다.

이 경고를 해결하려면 MaxUserPort 레지스트리 키 값을 60000으로 설정하십시오.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\Tcpip\Parameters를 탐색합니다.

  3. MaxUserPort를 두 번 클릭하고 값 데이터 필드를 ea60(16진수)으로 설정한 다음 확인을 클릭합니다.

  4. 이 설정을 적용하려면 레지스트리 편집기를 닫고 컴퓨터를 다시 시작합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MDBSZ.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 해결하려면 사용 중인 Exchange 버전의 롤업을 업데이트하거나 최신 서비스 팩을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server 또는 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


Memory 성능 모니터 개체를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이트 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Memory 성능 개체의 Available Mbytes 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. 카운터에서 올바른 데이터가 반환되지 않으면 Exchange Server Analyzer는 기본 메시지를 표시합니다.

다음과 같은 상황에서는 성능 데이터 수집 엔진에서 올바른 데이터가 반환되지 않습니다.

  • Memory 성능 개체를 사용하지 않습니다.

  • Memory 성능 모니터 개체가 없거나 손상되었습니다.

  • 성능 개체에 액세스할 수 있는 적절한 권한이 Exchange Server Analyzer에 없습니다.

맨 앞의 두 가지 상황은 확장 가능한 특정 카운터가 레지스트리를 손상시키거나 Microsoft WMI(Windows® Management Instrumentation) 기반 프로그램에서 레지스트리를 수정하는 경우에 발생할 수 있습니다.

해당 절차를 수행하기 전에 Exchange Server Analyzer에 적절한 권한이 있는지 확인합니다. Exchange Server Analyzer를 실행하는 데 필요한 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말을 참조하십시오. 도움말을 보려면 Exchange Server Analyzer를 열고 F1 키를 누르십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Memory 성능 개체를 사용하는지 확인합니다.

    1. Extensible Performance Counter List 도구(Exctrlst.exe)를 다운로드하고 설치합니다. Exctrlst.exe: Extensible Performance Counter List(http://go.microsoft.com/fwlink/?LinkId=34436)에서 Exctrlst.exe를 다운로드할 수 있습니다.

    2. Exctrlst.exe를 열고 Sort Order와 Service를 차례로 클릭합니다.

    3. 성능 개체가 보고하는 서비스를 찾아 Performance Counters Enabled 확인란이 선택되었는지 확인합니다.

      Performance Counters Enabled 확인란이 선택되지 않았으면 이 확인란을 선택한 다음 성능 카운터에 연결된 서비스를 다시 시작하여 성능 카운터가 작동하는지 확인합니다. 성능 카운터가 작동하지 않거나 Performance Counters Enabled 확인란이 이미 선택되어 있으면 2단계로 넘어갑니다.

  2. Microsoft 기술 자료 문서 300956, "성능 카운터 라이브러리 값을 수동으로 다시 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956)에 지정된 대로 누락되거나 손상된 성능 카운터를 다시 빌드합니다.

  3. 이 기술 자료 문서에 따라 수행해도 문제가 해결되지 않으면 Windows 운영 체제를 복구 모드로 다시 설치한 다음 최신 Windows 서비스 팩을 적용해야 합니다.


MSExchangeDSAccess Processes 성능 모니터 개체를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeDSAccess 성능 개체의 LDAP Read Time 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. 카운터에서 올바른 데이터가 반환되지 않으면 Exchange Server Analyzer는 기본 메시지를 표시합니다.

다음과 같은 상황에서는 성능 데이터 수집 엔진에서 올바른 데이터가 반환되지 않습니다.

  • MSExchangeDSAccess 성능 개체를 사용하지 않습니다.

  • MSExchangeDSAccess 성능 모니터 개체가 없거나 손상되었습니다.

  • 성능 개체에 액세스할 수 있는 적절한 권한이 Exchange Server Analyzer에 없습니다.

맨 앞의 두 가지 상황은 확장 가능한 특정 카운터가 레지스트리를 손상시키거나 Microsoft WMI(Windows® Management Instrumentation) 기반 프로그램에서 레지스트리를 수정하는 경우에 발생할 수 있습니다. 다음 절차에서는 맨 앞의 두 가지 상황을 해결하는 방법을 설명합니다. 해당 절차를 수행하기 전에 Exchange Server Analyzer에 적절한 권한이 있는지 확인합니다.

Exchange Server Analyzer를 실행하는 데 필요한 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말을 참조하십시오. 도움말을 보려면 Exchange Server Analyzer를 열고 F1 키를 누르십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. MSExchangeDSAccess 성능 개체를 사용하는지 확인합니다.

    1. Extensible Performance Counter List 도구(Exctrlst.exe)를 다운로드하고 설치합니다. Exctrlst.exe: Extensible Performance Counter List(http://go.microsoft.com/fwlink/?LinkId=34436)에서 Exctrlst.exe를 다운로드할 수 있습니다.

    2. Exctrlst.exe를 열고 Sort Order와 Service를 차례로 클릭합니다.

    3. 성능 개체가 보고하는 서비스를 찾아 Performance Counters Enabled 확인란이 선택되었는지 확인합니다.

      Performance Counters Enabled 확인란이 선택되지 않았으면 이 확인란을 선택한 다음 성능 카운터에 연결된 서비스를 다시 시작하여 성능 카운터가 작동하는지 확인합니다. 성능 카운터가 작동하지 않거나 Performance Counters Enabled 확인란이 이미 선택되어 있으면 2단계로 넘어갑니다.

  2. Microsoft 기술 자료 문서 300956, "성능 카운터 라이브러리 값을 수동으로 다시 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956)에 지정된 대로 누락되거나 손상된 성능 카운터를 다시 빌드합니다.

  3. 이 기술 자료 문서에 따라 수행해도 문제가 해결되지 않으면 Exchange Server를 복구 모드로 다시 설치한 다음 최신 Exchange Server 서비스 팩을 적용해야 합니다.


MSExchangeIS Mailbox 성능 모니터 개체를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이트 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeIS Mailbox 성능 개체의 Send Queue Size 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. 카운터에서 올바른 데이터가 반환되지 않으면 Exchange Server Analyzer는 기본 메시지를 표시합니다.

다음과 같은 상황에서는 성능 데이터 수집 엔진에서 올바른 데이터가 반환되지 않습니다.

  • MSExchangeIS Mailbox 성능 개체를 사용하지 않습니다.

  • MSExchangeIS Mailbox 성능 모니터 개체가 없거나 손상되었습니다.

  • 성능 개체에 액세스할 수 있는 적절한 권한이 Exchange Server Analyzer에 없습니다.

맨 앞의 두 가지 상황은 확장 가능한 특정 카운터가 레지스트리를 손상시키거나 Microsoft WMI(Windows® Management Instrumentation) 기반 프로그램에서 레지스트리를 수정하는 경우에 발생할 수 있습니다.

해당 절차를 수행하기 전에 Exchange Server Analyzer에 적절한 권한이 있는지 확인합니다. Exchange Server Analyzer를 실행하는 데 필요한 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말을 참조하십시오. 도움말을 보려면 Exchange Server Analyzer를 열고 F1 키를 누르십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. MSExchangeIS Mailbox 성능 개체를 사용하는지 확인합니다.

    1. Extensible Performance Counter List 도구(Exctrlst.exe)를 다운로드하고 설치합니다. Exctrlst.exe: Extensible Performance Counter List(http://go.microsoft.com/fwlink/?LinkId=34436)에서 Exctrlst.exe를 다운로드할 수 있습니다.

    2. Exctrlst.exe를 열고 Sort Order와 Service를 차례로 클릭합니다.

    3. 성능 개체가 보고하는 서비스를 찾아 Performance Counters Enabled 확인란이 선택되었는지 확인합니다.

      Performance Counters Enabled 확인란이 선택되지 않았으면 이 확인란을 선택한 다음 성능 카운터에 연결된 서비스를 다시 시작하여 성능 카운터가 작동하는지 확인합니다. 성능 카운터가 작동하지 않거나 Performance Counters Enabled 확인란이 이미 선택되어 있으면 2단계로 넘어갑니다.

  2. Microsoft 기술 자료 문서 300956, "성능 카운터 라이브러리 값을 수동으로 다시 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956)에 지정된 대로 누락되거나 손상된 성능 카운터를 다시 빌드합니다.

  3. 이 기술 자료 문서에 따라 수행해도 문제가 해결되지 않으면 Exchange Server를 복구 모드로 다시 설치한 다음 최신 Exchange Server 서비스 팩을 적용해야 합니다.


MSExchangeIS 성능 모니터 개체를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-03

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이트 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeIS 성능 개체의 RPC Operations/sec 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. 카운터에서 올바른 데이터가 반환되지 않으면 Exchange Server Analyzer는 기본 메시지를 표시합니다.

다음과 같은 상황에서는 성능 데이터 수집 엔진에서 올바른 데이터가 반환되지 않습니다.

  • MSExchangeIS 성능 개체를 사용하지 않습니다.

  • MSExchangeIS 성능 모니터 개체가 없거나 손상되었습니다.

  • 성능 개체에 액세스할 수 있는 적절한 권한이 Exchange Server Analyzer에 없습니다.

맨 앞의 두 가지 상황은 확장 가능한 특정 카운터가 레지스트리를 손상시키거나 Microsoft WMI(Windows® Management Instrumentation) 기반 프로그램에서 레지스트리를 수정하는 경우에 발생할 수 있습니다. 해당 절차를 수행하기 전에 Exchange Server Analyzer에 적절한 권한이 있는지 확인합니다. Exchange Server Analyzer를 실행하는 데 필요한 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말을 참조하십시오. 도움말을 보려면 Exchange Server Analyzer를 열고 F1 키를 누르십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. MSExchangeIS 성능 개체를 사용하는지 확인합니다.

    1. Extensible Performance Counter List 도구(Exctrlst.exe)를 다운로드하고 설치합니다. Exctrlst.exe: Extensible Performance Counter List(http://go.microsoft.com/fwlink/?LinkId=34436)에서 Exctrlst.exe를 다운로드할 수 있습니다.

    2. Exctrlst.exe를 열고 Sort Order와 Service를 차례로 클릭합니다.

    3. 성능 개체가 보고하는 서비스를 찾아 Performance Counters Enabled 확인란이 선택되었는지 확인합니다.

      Performance Counters Enabled 확인란이 선택되지 않았으면 이 확인란을 선택한 다음 성능 카운터에 연결된 서비스를 다시 시작하여 성능 카운터가 작동하는지 확인합니다. 성능 카운터가 작동하지 않거나 Performance Counters Enabled 확인란이 이미 선택되어 있으면 2단계로 넘어갑니다.

  2. Microsoft 기술 자료 문서 300956, "성능 카운터 라이브러리 값을 수동으로 다시 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956)에 지정된 대로 누락되거나 손상된 성능 카운터를 다시 빌드합니다.

  3. 이 기술 자료 문서에 따라 수행해도 문제가 해결되지 않으면 Exchange Server를 복구 모드로 다시 설치한 다음 최신 Exchange Server 서비스 팩을 적용해야 합니다.

Exchange Server Best Practices Analyzer Tool 연결 문제 해결에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?LinkId=56285)를 참조하십시오.


MSExchangeIS 공용 성능 모니터 개체를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이트 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeIS Public 성능 개체의 Send Queue Size 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. 카운터에서 올바른 데이터가 반환되지 않으면 Exchange Server Analyzer는 기본 메시지를 표시합니다.

다음과 같은 상황에서는 성능 데이터 수집 엔진에서 올바른 데이터가 반환되지 않습니다.

  • MSExchangeIS Public 성능 개체를 사용하지 않습니다.

  • MSExchangeIS Public 성능 모니터 개체가 없거나 손상되었습니다.

  • 성능 개체에 액세스할 수 있는 적절한 권한이 Exchange Server Analyzer에 없습니다.

맨 앞의 두 가지 상황은 확장 가능한 특정 카운터가 레지스트리를 손상시키거나 Microsoft WMI(Windows® Management Instrumentation) 기반 프로그램에서 레지스트리를 수정하는 경우에 발생할 수 있습니다. 해당 절차를 수행하기 전에 Exchange Server Analyzer에 적절한 권한이 있는지 확인합니다. Exchange Server Analyzer를 실행하는 데 필요한 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말을 참조하십시오. 도움말을 보려면 Exchange Server Analyzer를 열고 F1 키를 누르십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. MSExchangeIS Public 성능 개체를 사용하는지 확인합니다.

    1. Extensible Performance Counter List 도구(Exctrlst.exe)를 다운로드하고 설치합니다. Exctrlst.exe: Extensible Performance Counter List(http://go.microsoft.com/fwlink/?LinkId=34436)에서 Exctrlst.exe를 다운로드할 수 있습니다.

    2. Exctrlst.exe를 열고 Sort Order와 Service를 차례로 클릭합니다.

    3. 성능 개체가 보고하는 서비스를 찾아 Performance Counters Enabled 확인란이 선택되었는지 확인합니다.

      Performance Counters Enabled 확인란이 선택되지 않았으면 이 확인란을 선택한 다음 성능 카운터에 연결된 서비스를 다시 시작하여 성능 카운터가 작동하는지 확인합니다. 성능 카운터가 작동하지 않거나 Performance Counters Enabled 확인란이 이미 선택되어 있으면 2단계로 넘어갑니다.

  2. Microsoft 기술 자료 문서 300956, "성능 카운터 라이브러리 값을 수동으로 다시 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956)에 지정된 대로 누락되거나 손상된 성능 카운터를 다시 빌드합니다.

  3. 이 기술 자료 문서에 따라 수행해도 문제가 해결되지 않으면 Exchange Server를 복구 모드로 다시 설치한 다음 최신 Exchange Server 서비스 팩을 적용해야 합니다.


MSGINA.DLL 드라이버 업데이트를 사용할 수 있음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-08-21

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange Server를 실행하는 서버에서 실행 중인 Microsoft Windows®의 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값이 4.0이면 Exchange Server에서 Microsoft Window NT® Server 4.0을 실행하고 있습니다. 값이 5.0이면 Exchange Server에서 Window 2000 Server를 실행하고 있습니다. 값이 5.2이면 Exchange Server에서 Windows Server™ 2003을 실행하고 있습니다.

또한 Exchange Server Analyzer는 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 ServicePackMajorVersion 키 값을 확인합니다.

ServicePackMajorVersion 키 값이 1이면 서버에 서비스 팩 1(SP1)이 설치되어 있습니다.

마지막으로 Exchange Server Analyzer는 CIM_Datafile WMI 클래스를 쿼리하여 Msgina.dll 파일의 Version 키 값을 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • 서버에서 Windows Server™ 2003 SP1을 실행하고 있습니다.

  • Msgina.dll 파일의 빌드 번호가 5.2.3790.2525보다 작습니다.

이 오류는 서버에 설치된 Msgina.dll 버전으로 인해 과도한 페이지 파일 작업이 발생하고 성능이 느려질 수 있음을 나타냅니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 905865, "The sizes of the working sets of all the processes in a console session may be trimmed when you use Terminal Services to log on to or log off from a computer that is running Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905865)에서 참조된 업데이트를 구하십시오.


MTA APDU logging required 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\APDU logging required

Exchange Server Analyzer는 APDU logging required의 값이 0 이외의 값으로 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

APDU(Application Protocol Data Unit) 텍스트 로그는 여러 사이트의 Exchange 메시지 전송 에이전트(MTA) 간이나 사이트의 MTA 및 클라이언트 간의 통신을 이진 형식으로 나타낸 것입니다. APDU 로그는 MTA의 문제를 진단하는 데 사용할 수 있습니다. 그러나 APDU 로그는 X.400 프로토콜의 ASCII 변환에 익숙한 사용자에게만 유용합니다.

APDU logging required 레지스트리 매개 변수가 0으로 구성되어 있으면 MTA가 보내거나 받은 모든 APDU가 MTADATA\BF*.LOG에 이진 데이터로 기록됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 편집하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 MTA APDU 로깅 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 APDU logging required 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 0를 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

APDU 로그에 대한 자세한 내용은 기술 자료 문서 163324, "XCON: Application Protocol Data Unit (APDU) Logs (BF0.LOG)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=163324)를 참조하십시오.


MTA Call-stack diagnostics required 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Call-stack diagnostics required

Exchange Server Analyzer는 Call-stack diagnostics required 값이 있으나 1 이외의 값으로 설정되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

Call-stack diagnostics required 레지스트리 값은 고급 디버깅 목적으로 사용되며 디버그 버전의 메시지 전송 에이전트(MTA)에서만 읽힙니다. 이 매개 변수의 값 데이터는 항상 1로 설정되어야 합니다. 디버거 버전의 MTA가 사용되면 이 값은 종료 시에 각 MTA 스레드에 대한 호출 스택을 제공합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 Call-stack diagnostics required 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 1을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA Computer 이름이 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 레지스트리 항목 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 읽어서 MTA(메시지 전송 에이전트) Computer 값의 설정을 확인합니다.

또한 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스를 쿼리하여 각 Exchange 서버 개체의 name 특성 값을 확인합니다.

마지막으로 Exchange Server Analyzer는 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 클러스터 서비스(ClusSvc)의 Started 키 값을 확인합니다. 값이 True이면 클러스터 서비스가 시작되었음을 나타내고 False이면 클러스터 서비스가 실행되고 있지 않음을 나타냅니다.

MTA Computer 키 값이 Windows 클러스터 서버에서 실행하고 있지 않는 Exchange Server 컴퓨터에 대해 Active Directory에 있는 해당 서버 개체의 name 특성 값과 일치하지 않으면 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류를 해결하려면 MTA Computer 레지스트리 키를 Active Directory의 name 특성 값과 일치하도록 편집해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 편집하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. 오른쪽 창에서 MTA Computer를 두 번 클릭하고 이 컴퓨터의 올바른 이름을 입력한 후 확인을 클릭합니다.

  4. 레지스트리 편집기를 닫고 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA Concurrent connections to LAN-MTAs 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to LAN-MTAs

Exchange Server Analyzer는 Concurrent connections to LAN-MTAs의 값이 0x28(16진수) 또는 40(10진수) 이외의 값으로 설정되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

Concurrent connections to LAN-MTAs 레지스트리 값은 LAN을 통해 메시지 전송 에이전트(MTA)에 동시에 연결하는 최대 수를 결정합니다. LAN을 통해 통신하는 MTA를 LAN-MTA라고 합니다. 로컬 MTA는 해당 구성과 시스템 로드에 따라 원격 MTA에 다중 연결할 수 있습니다. 동시에 LAN 기반 MTA에 연결할 수 있는 최대 수는 240입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

기본 MTA 동시 연결 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 Concurrent connections to LAN-MTAs 값을 찾아 두 번 클릭합니다.

  4. 단위가 16진수로 설정되었는지 확인하고 값 데이터 필드에 28을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

동시 LAN 기반 MTA 연결의 최대 수에 대한 자세한 내용은 기술 자료 문서 243402, "XCON: Exchange Server MTA Event ID 9280"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=243402)을 참조하십시오.


MTA Concurrent connections to X.400 gateways 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to X.400 gateways

Exchange Server Analyzer는 Concurrent connections to X.400 gateways 값이 6이 아닌 값으로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

Concurrent connections to X.400 gateways 레지스트리 값은 원격 X.400 메시지 전송 에이전트(MTA)에 대한 최대 동시 연결 수입니다. 기본값 6은 대부분의 조직에 충분합니다. Exchange Server 버전 5.5를 실행 중인 서버에서 5개 이상의 EDK 커넥터를 사용하면 Concurrent connections to X.400 gateways 값을 0x12(16진수) 또는 18(10진수)로 늘려야 하는 문제가 발생합니다. 이 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 282115, "If more than 4 Exchange EDK connectors are installed, mail flow stops"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=282115)를 참조하십시오. 해당 문서에서 설명한 문제가 발생한 것이 아니면 6으로 설정된 Concurrent connections to X.400 gateways 레지스트리 값을 그대로 두어야 합니다.

이 문제를 수정하려면 기본 구성으로 되돌립니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 Concurrent connections to X.400 gateways 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 6을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA Concurrent MDB/delivery queue clients 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent MDB/delivery queue clients

Exchange Server Analyzer는 Concurrent MDB/delivery queue clients의 값이 3 이외의 값으로 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

동시 MDB/배달 큐 클라이언트 수 값은 MTA(Message Transger Agent)가 지원할 수 있는 MDB(Messaging Database) 및 Exchange API 메시지 액세스 배달 큐 클라이언트의 최대 수입니다. 클라이언트마다 두 개 이상의 세션이 포함될 수 있습니다. 개인 및 공용 MDB 엔터티를 지원하려면 이 값을 최소 2 이상으로 설정해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 MTA 매개 변수 동시 MDB/배달 큐 클라이언트 수 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 3을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 끝내고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


압축된 폴더에 MTA 데이터 파일을 쓰고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 MTA(메시지 전송 에이전트) 데이터 경로에 대한 Compressed 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Compressed 키 값이 True이면 오류를 표시합니다.

Microsoft는 NTFS 파일 시스템 압축 볼륨에서 Exchange 데이터 파일에 대한 저장 영역을 지원하지 않습니다. Exchange 데이터 파일을 압축 볼륨에 저장할 경우 추가적인 오버헤드가 Exchange 성능에 큰 영향을 줍니다. 또한 Exchange 저장소 데이터베이스가 특정 크기(대략 4GB)에 도달하면 더 이상 탑재할 수 없거나 손상될 수 있습니다.

Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

확장 가능한 저장소 엔진(ESE)에 의해 관리되는 파일은 압축된 드라이브에 저장하기 위한 파일이 아닙니다. ESE는 로그 기반 복구를 위한 섹터 독립에 종속되며 파일 압축은 섹터 독립을 무효화합니다. 볼륨 호스팅 ESE 데이터베이스나 미리 쓰기 로깅을 사용하는 데이터베이스의 경우 압축을 설정하지 않아야 합니다.

Exchange 2000 Server 서비스 팩 3 이전 버전에서는 압축된 정보 저장소 데이터베이스를 탑재할 수 있습니다. 그러나 NTFS 압축을 사용하여 압축된 Exchange 2000 저장소 데이터베이스 또는 로그가 손상될 수 있습니다.

Exchange 2000 Server 서비스 팩 3을 사용할 경우 128MB 이하의 압축된 정보 저장소 데이터베이스 파일은 자동으로 압축이 풀어집니다. 데이터베이스 파일이 128MB를 넘으면 데이터베이스가 탑재되지 않고 응용 프로그램 로그에 오류 메시지가 생성됩니다. Exchange 2000 Server 서비스 팩 3에서는 128MB를 초과하는 압축된 데이터베이스를 탑재할 수 없습니다.

지정한 폴더의 파일 압축을 해제하려면 다음을 수행합니다.

  1. 파일 압축을 해제할 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 내용을 압축하여 디스크 공간 절약 확인란의 선택을 해제한 다음 확인을 클릭합니다.

MTA 데이터베이스 파일 위치를 옮기려면 다음을 수행합니다.

  1. Exchange Server 5.5에서는 성능 최적화 도구를 사용하여 MTA 데이터베이스 파일을 이동할 수 있습니다. Exchange 2000 Server 또는 Exchange Server 2003에서 작업을 수행하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서, "XCON: How to change the location of the MTA Database and the MTA Run Directory in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=259896)를 참조하십시오.

Exchange 데이터 파일 및 NTFS 압축에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 170009, "XADM: NTFS Compressed Volume Causes Store to Fail"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009)

  • 327772, "XADM: Database Does Not Mount and You Receive Error 0xfffff05b After You Apply SP3"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772)


암호화된 폴더에 MTA 데이터 파일을 쓰고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 MTA(메시지 전송 에이전트) 데이터 경로의 Encrypted 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 이 키 값이 True인 경우 오류를 표시합니다.

Exchange 2000 Server 또는 Exchange Server 2003 컴퓨터에서 MTA 파일은 다음 기본 위치에 기록됩니다.

<drive> :\Program Files\Exchsrvr\MTAdata

EFS(암호화 파일 시스템) 암호화 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일을 암호화된 볼륨에 저장하면 추가 오버헤드가 발생하여 Exchange의 성능에 막대한 영향을 줍니다. Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

Exchange 데이터 파일을 보호하려면 Exchange 컴퓨터에 대한 무단 액세스를 방지하고 S/MIME 메시지 형식을 사용하여 메시지 데이터를 암호화하는 것이 좋습니다.

지정한 폴더의 파일 암호화를 해제하려면 다음을 수행합니다.

  1. 파일 압축을 풀 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 데이터 보호를 위해 내용을 암호화 확인란의 선택을 해제한 다음 확인을 클릭합니다.

Exchange Server 데이터 파일과 EFS에 대한 자세한 내용은 Microsoft 기술 자료 문서 834638, "Information about the storage of data files on an encrypted volume in Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)를 참조하십시오.

Microsoft Exchange Server 2003에서의 메시지 보안 방법에 대한 내용은 Exchange Server 2003 메시지 보안 가이드(http://go.microsoft.com/fwlink/?linkid=47574)를 참조하십시오.


NTFS가 아닌 파티션에 MTA 데이터 파일을 쓰고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 Exchange MTA(메시지 전송 에이전트) 데이터 폴더에 대한 FSName 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 FSName 키 값이 NTFS가 아닐 경우 오류를 표시합니다.

NTFS가 아닌 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일에는 아래의 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

이 오류가 표시되면 MTA 데이터 폴더를 NTFS 드라이브로 옮겨야 합니다. MTA 데이터 폴더가 저장되어 있는 드라이브가 FAT(파일 할당 테이블) 드라이브로 포맷된 경우에는 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다.

Exchange MTA 데이터 폴더를 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버를 차례로 확장하고 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 저장소 그룹 속성 페이지에서 시스템 경로 위치 필드 옆의 찾아보기를 클릭합니다.

  4. MTA 데이터 폴더에 새 경로를 입력한 다음 확인을 클릭합니다.

  5. 확인을 클릭합니다.

파일이 저장되어 있는 드라이브가 FAT 드라이브로 포맷된 경우에는 앞에서 설명한 절차 대신 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다. Convert.exe 명령줄 도구를 사용하여 FAT 파티션에서 NTFS 파티션으로 변환하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 214579, "Convert.exe를 사용하여 파티션을 NTFS 파일 시스템으로 변환하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)을 참조하십시오.


MTA DB data buffers per object 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB data buffers per object

Exchange Server Analyzer는 DB data buffers per object 값이 0보다 크지만 3 또는 6이 아니면 기본 구성이 아니라는 메시지를 표시합니다.

DB data buffers per object 값은 각 데이터베이스 개체에 대해 구성된 4KB(킬로바이트) 데이터베이스 서버 버퍼 수에 해당합니다. 버퍼가 많을수록 메모리가 더 많이 필요하지만 데이터베이스 개체가 버퍼 공간 부족으로 인해 디스크로 롤아웃될 가능성은 줄어듭니다. 메시지 전송 에이전트(MTA)가 한 사이트 내에 있거나 여러 사이트에 걸쳐 있는 여러 Exchange Server 버전 5.5 컴퓨터와 통신하는 경우 이 값을 변경하는 것이 좋습니다. 그런 다음 값을 6으로 변경하는 것이 좋습니다. 이 MTA가 이러한 기준을 충족시키지 못할 경우 값을 기본 설정인 3으로 다시 변경해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 DB data buffers per object 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 3을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA DB file handles 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB file handles

Exchange Server Analyzer는 DB file handles 값이 192가 아니면 기본 구성이 아니라는 메시지를 표시합니다.

DB file handles 값은 구성된 데이터베이스 서버 파일 핸들 수에 해당합니다. 이 값은 동시에 열 수 있는 최대 데이터베이스 파일 수를 결정합니다. 구성한 값보다 많은 개수의 파일을 열어야 할 경우에는 데이터베이스 개체가 디스크에 복사됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 DB file handles 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 192를 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 끝내고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA 진단 로깅 수준이 5보다 큽니다. MTA가 디버그 모드인 상태입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 일련의 레지스트리 키를 읽어 Exchange 서버에 설정된 MTA(메시지 전송 에이전트) 진단 로깅 수준을 확인합니다. 해당 레지스트리 키의 위치는 다음과 같습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

이러한 키의 기본값은 0입니다. Exchange Server Analyzer는 이러한 키 중 하나의 값이 5보다 클 경우 오류를 표시합니다.

이러한 레지스트리 키는 특정 서버 속성 페이지의 진단 로깅 탭에서 로깅 수준을 조정할 때 Exchange System Manager에 의해 설정됩니다. Exchange System Manager를 사용하여 관리자는 지정된 로깅 수준을 없음, 최소, 보통 및 최대로 설정할 수 있습니다. 레지스트리 키의 해당 값은 각각 0, 1, 3 또는 5입니다.

따라서 5보다 큰 값은 레지스트리를 직접 편집해서 설정할 수 있으며 아주 잠깐 디버깅이나 문제 해결을 수행하려는 때에 사용량이 최고가 아닐 경우에만 이러한 수준으로 설정해야 합니다. 이러한 키를 5보다 큰 정수로 설정하면 로깅이 디버깅 수준으로 높아져 리소스가 아주 많이 사용됩니다. 디버깅 수준 로깅 외에도 이러한 키를 5보다 높게 설정하면 몇 초마다 크기가 40MB 정도인 "call.out" 디버그 추적 파일이 출력됩니다. 이렇게 하면 1분이 채 못되어 컴퓨터의 이벤트 로그가 채워질 수 있습니다.

다음 표는 Exchange System Manager의 진단 로깅 탭에 표시되는 MTA 로깅 범주와 레지스트리에 있는 해당 키 이름을 보여 줍니다.

Exchange System Manager에 표시되는 범주 | 해당 레지스트리 키 이름
X.400 서비스 | 1 X.400 Service
리소스 | 2 Resource
보안 | 3 Security
인터페이스 | 4 Interface
필드 엔지니어링 | 5 Field Engineering
MTA 관리 | 6 MTA Administration
구성 | 7 Configuration
디렉터리 액세스 | 8 Directory Access
운영 체제 | 9 Operating System
내부 처리 | 10 Internal Processing
상호 운용성 | 11 Interoperability
APDU(Application Protocol Data Unit) | 12 APDU

이 문서의 끝에 나오는 참조에서는 각 MTA 범주 로그에 대한 자세한 내용을 제공합니다.

적극적으로 문제 해결을 수행하고 있지 않으면 각 MTA 범주에 대한 로깅을 없음(0)으로 설정하는 것이 좋습니다. 이렇게 권장하는 이유는 로깅될 이벤트 수를 관리 가능한 수준으로 유지하기 위해서입니다. 최소(1) 수준에서도 이 수준이 설정된 범주에 따라 며칠 동안 수백 개의 이벤트 로그가 생성됩니다.

현재 문제 해결 중이 아니라면 문제 해결 중에 이 값이 더 높게 설정되었다가 우연히 그 상태로 유지된 것일 수 있습니다. 이러한 값을 최대(5) 이상으로 설정해야 하지만 적극적으로 문제 해결을 수행하고 있지 않으면 각 MTA 진단 로깅 범주에 대해 로깅 수준을 없음(0)으로 설정하는 것을 고려해야 합니다.

MTA 진단 로깅 범주를 없음으로 설정하려면 다음을 수행합니다.

  1. 시작을 클릭하고 모든 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭하여 Exchange System Manager를 시작합니다.

  2. 콘솔 트리에서 서버 및 원하는 서버를 차례로 확장한 다음 속성을 클릭합니다.

  3. <서버> 속성에서 진단 로깅을 클릭합니다.

  4. 서비스에서 MSExchangeMTA를 클릭합니다.

  5. 범주 아래의 각 항목에 대해 범주를 선택한 다음 로깅 수준에서 없음을 선택하여 로깅 수준을 없음으로 설정합니다.

  6. 모든 범주를 없음으로 설정하고 적용을 클릭한 다음 확인을 클릭합니다.

Exchange 2000 Server 및 Exchange Server 2003에서 MTA 진단 로깅에 대한 자세한 내용은 Microsoft 기술 자료 문서 163033, "XCON: Description of Diagnostics Categories for MTA"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033)를 참조하십시오.

Exchange Server 버전 5.5의 MTA 진단 로깅에 대한 자세한 내용은 기술 자료 문서 163032, "XCON: Description of Diagnostics Logging for MTA"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032)를 참조하십시오.


MTA 진단 로깅 수준이 0이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 일련의 레지스트리 키를 읽어 Exchange 서버에 설정된 MTA(메시지 전송 에이전트) 진단 로깅 수준을 확인합니다. 이 레지스트리 키는 다음 위치에 있습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

이러한 키의 기본값은 0입니다. Exchange Server Analyzer는 이러한 키 값이 1보다 크지만 6보다 작을 경우 기본 구성이 아니라는 메시지를 표시합니다.

이러한 레지스트리 키는 특정 서버 속성 페이지의 진단 로깅 탭에서 로깅 수준을 조정할 때 Exchange System Manager에 의해 설정됩니다. 관리자는 Exchange System Manager를 사용하여 지정된 로깅 수준을 없음, 최소, 보통 및 최대로 설정할 수 있습니다. 해당하는 레지스트리 키 값은 각각 0, 1, 3 또는 5입니다.

다음 표에서는 Exchange 시스템 관리자의 진단 로깅 탭에 나열되어 있는 MTA 로깅 범주와 해당 레지스트리 키 이름을 보여 줍니다.

Exchange 시스템 관리자에 표시되는 범주 | 해당 레지스트리 키 이름
X.400 서비스 | 1 X.400 Service
리소스 | 2 Resource
보안 | 3 Security
인터페이스 | 4 Interface
필드 엔지니어링 | 5 Field Engineering
MTA 관리 | 6 MTA Administration
구성 | 7 Configuration
디렉터리 액세스 | 8 Directory Access
운영 체제 | 9 Operating System
내부 처리 | 10 Internal Processing
상호 운용성 | 11 Interoperability
APDU(응용 프로그램 프로토콜 데이터 단위) | 12 APDU

이 문서 맨 끝에 나오는 참조 자료는 각 MTA 범주가 기록하는 내용에 대한 보다 자세한 정보를 제공합니다.

능동적으로 문제 해결을 수행하지 않으려는 경우 진단 로깅에서 각 MTA 범주에 대한 로깅을 없음(0)으로 설정하는 것이 가장 적절합니다. 이러한 이유는 로깅되는 이벤트의 수를 관리 가능한 수준으로 유지하기 위해서 입니다. 이 수준을 최소(1)로 설정하면 해당 수준이 설정된 범주에 따라, 며칠 내에 수백 개의 이벤트 로그가 생성될 수 있습니다.

지금 당장 문제를 해결하는 중이 아니면 문제 해결을 연습하는 동안 이러한 값을 더 높게 설정하고 실수로 그대로 둔 것일 수 있습니다. 각 MTA 진단 로깅 범주에 대해 로깅 수준을 없음(0)으로 설정하는 것을 고려하십시오.

Exchange Server 2003 또는 Exchange 2000 Server에서 이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 콘솔 트리에서 서버를 확장하고 원하는 서버를 확장한 후 속성을 클릭합니다.

  3. <서버> 속성에서 진단 로깅 탭을 클릭합니다.

  4. 서비스에서 MSExchangeMTA를 선택합니다.

  5. 범주 아래의 각 항목에 대해 범주를 선택한 후 로깅 수준에서 없음을 선택하여 로깅 수준을 없음으로 설정합니다.

  6. 모든 범주를 없음으로 설정한 후 적용을 클릭하고 확인을 클릭합니다.

Exchange Server 버전 5.5에서 이 오류를 수정하려면 다음을 수행합니다.

  1. Microsoft Exchange Server 관리자 프로그램을 시작합니다.

  2. MTA 관련 문제가 있는 서버를 나타내는 개체를 엽니다.

  3. 오른쪽 창에 있는 메시지 전송 에이전트 개체를 두 번 클릭합니다.

  4. 진단 로깅 탭에서 X.400 서비스를 선택한 후 최대를 클릭합니다.

  5. 리소스를 선택합니다.

  6. Ctrl 키를 누른 채로 디버깅하려는 각 리소스를 클릭합니다.

  7. 로깅 수준 없음에 대한 옵션을 클릭합니다.

  8. 확인을 클릭합니다.

Exchange 2000 Server의 MTA 진단 로깅에 대한 자세한 내용은 Microsoft 기술 자료 문서 163033, "XCON: Description of Diagnostics Categories for MTA"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033)를 참조하십시오.

Exchange Server 5.5의 고급 로깅 롤백에 대한 자세한 내용은 기술 자료 문서 168906, "XCON: Setting up Advanced Logging on the Exchange 5.0 and 5.5 MTAs"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168906)를 참조하십시오.

Exchange 5.5 Server의 MTA 진단 로깅에 대한 자세한 내용은 Microsoft 기술 자료 문서 163032, "XCON: Description of Diagnostics Categories for MTA"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032)를 참조하십시오.


MTA Dispatcher threads 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

오류 메시지

소개

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Dispatcher threads

Exchange Server Analyzer는 Dispatcher threads 값이 있으나 0보다 크며 1 또는 2 이외의 값으로 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

Dispatcher threads 값은 메시지 전송 에이전트(MTA) 발송자 스레드의 수를 나타냅니다. 발송자 스레드의 하위 유형이 세 개이므로(Router, Fanout, Result) 이 수에 3을 곱합니다. MTA가 한 사이트 내에서나 사이트 간에 다섯 대가 넘는 Exchange Server 버전 5.5 컴퓨터와 통신할 때 또는 메일 그룹이 과도하게 사용될 때 이 값을 변경하도록 권장됩니다. 이러한 경우 해당 값을 3으로 변경하는 것이 좋습니다. MTA가 이러한 조건을 만족하지 않을 경우 이 값을 다시 기본 설정인 1로 변경해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 Dispatcher threads 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 1을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA가 LocalSystem 계정으로 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange MTA Stacks 서비스의 StartName 키 값이 설정되어 있는지 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 디렉터리에서 Exchange Server 개체의 serialNumber 특성 값을 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server 개체의 serialNumber 특성은 해당 개체가 나타내는 컴퓨터에서 실행 중인 Exchange Server 버전을 식별합니다. StartName 키 값이 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 Exchange 서버의 LocalSystem과 같지 않으면 오류가 표시됩니다.

다른 계정을 사용하여 Exchange MTA Stacks 서비스를 실행하면 지원되지 않는 구성이므로 사용 권한 및 액세스 오류가 발생합니다.

이 오류를 해결하려면 Exchange MTA Stacks 서비스를 구성하여 LocalSystem(aks SYSTEM) 계정으로 시작해야 합니다.

참고:
Exchange Server 버전 5.5에는 이 오류가 적용되지 않습니다. Exchange 2000 Server 및 Exchange Server 2003인 경우에만 LocalSystem 계정으로 Exchange MTA Stacks 서비스를 실행해야 합니다.

Exchange MTA Stacks 서비스 계정을 구성하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. Microsoft Exchange MTA Stacks 서비스를 찾아서 중지합니다.

  3. Microsoft Exchange MTA Stacks 서비스를 두 번 클릭합니다.

  4. Microsoft Exchange MTA Stacks 속성 페이지의 로그온 탭에서 다음 계정으로 로그온 아래의 LocalSytem 계정을 선택한 다음 적용을 클릭합니다.

  5. 서비스 상태에서 시작을 클릭한 다음 확인을 클릭합니다.

  6. 서비스 스냅인을 닫습니다.

LocalSystem 계정을 사용하여 Exchange 서비스를 실행하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 239762, "Exchange Services Run Under LocalSystem"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)을 참조하십시오.


MTA Kernel threads 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Kernel threads

Exchange Server Analyzer는 Kernel threads 값이 0보다 크지만 1이나 3이 아니면 기본 구성이 아니라는 메시지를 표시합니다.

Kernel threads 값은 OSI(Open Systems Interconnection) 스택의 표시 및 세션 수준을 처리하는 플랫폼 스레드 수입니다. 이들 스레드는 메시지 전송 에이전트(MTA) 메시지 처리의 핵심입니다. 이 MTA가 속도가 느리거나 지연이 심한 네트워크 연결을 통해 RPC(원격 프로시저 호출)을 사용하여 많은 수의 다른 Exchange Server 버전 5.5 서버와 통신하는 경우 아래의 표에 나와 있는 값을 사용하는 것이 좋습니다.

값 | 설명
0x3(16진수) | 표준 권장 값. 속도가 느리거나 고도 휴면 네트워크 연결을 통해 RPC를 사용하여 다른 Exchange Server 5.5 서버와 통신하는 MTA에 이 값을 사용합니다.
0x8(16진수) | Exchange Server 5.5 컴퓨터가 15대 이상이 있는 사이트에 속한 Exchange 2000 Server 또는 Exchange Server 2003 MTA에 이 값을 사용합니다.
0xC(16진수) | Exchange Server 5.5 컴퓨터가 30대 이상이 있는 사이트에 속한 Exchange 2000 Server 또는 Exchange Server 2003 MTA에 이 값을 사용합니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 편집하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Kernel threads 값을 구성하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 Kernel threads 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 해당 조직에 적절한 값을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA LAN-MTAs 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\LAN-MTAs

Exchange Server Analyzer는 LAN-MTAs의 값이 20 이외의 값으로 설정되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

LAN-MTAs 값은 메시지 전송 에이전트(MTA)가 지원하는 네트워크 MTA 수입니다. 이 레지스트리의 값으로 20을 사용하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 이 작업을 수행하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 LAN-MTAs 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 20을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA MDB users 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\MDB users

Exchange Server Analyzer는 MDB users의 값이 500 이외의 값으로 설정되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

MDB users 값은 메시지 전송 에이전트(MTA)가 지원하는 MDB(메시지 데이터베이스) 사용자의 최대 수입니다. 모든 Exchange Server 사용자는 명시적으로 달리 설정되지 않는 한 기본적으로 MDB 사용자입니다.

MDB users 레지스트리 값은 디렉터리로부터 캐시할 고유 이름 수를 정의합니다. 조직의 사용자가 1,500명을 초과할 경우 이 값을 전체 주소 목록 크기의 1/3 값으로 변경해야 합니다. 단, 최대값은 5,000입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 MDB users 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 500을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA Max RPC calls outstanding 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Max RPC Calls Outstanding

Exchange Server Analyzer는 Max RPC Calls Outstanding 값이 50이 아니면 기본 구성이 아니라는 메시지를 표시합니다.

Max RPC Calls Outstanding 값은 최대 원격 프로시저 호출(RPC) 스레드 수입니다. 이 값은 한 번에 처리할 수 있는 최대 RPC 프로시저 호출 수를 제한합니다. 이 값은 RpcServerUseAllProtSeqs() 및 RpcServerListen()에서 사용됩니다.

Exchange2000 Server 및/또는 Exchange Server2003이 Exchange Server 버전 5.5 컴퓨터와 공존하고 Store.exe 프로세스에서 게이트웨이 입력/출력 스레드 수를 늘린 혼합 시나리오에서는 값 데이터를 0x80(16진수)이나 128(10진수)로 늘리는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 Max RPC Calls Outstanding 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 50를 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA Min RPC threads 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

오류 메시지

소개

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Min RPC Threads

Exchange Server Analyzer는 Min RPC Threads 값이 4 이외의 값으로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

Min RPC Threads 값은 최소 RPC(원격 프로시저 호출) 스레드 수입니다. 이 수로 최소 호출 스레드 개수를 확인합니다. 이 값은 RpcServerListen()에 사용됩니다. 일반적으로 이 레지스트리 값을 기본값에서 변경하면 안 됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 Min RPC Threads 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 4를 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA RTS threads 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\RTS threads

Exchange Server Analyzer는 RTS threads의 값이 0보다는 크지만 1이나 3이 아닌 다른 값으로 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

RTS threads 값은 OSI(Open Systems Interconnection) 스택의 RTSE(Reliable Transfer Service Element) 수준을 처리하는 플랫폼 스레드의 수입니다. RTS 스레드는 큐에 데이터를 보내는 역할을 합니다. 이 메시지 전송 에이전트(MTA)가 한 사이트 내 또는 사이트 간에 여러 Exchange Server 버전 5.5 컴퓨터와 통신하는 경우 RTS Threads 레지스트리 값을 기본값인 1에서 3으로 조정해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

RTS threads 레지스트리 값을 최적화하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 RTS threads 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 적합한 값(1 또는 3)을 입력하고 확인을 클릭합니다.

  5. 레지스트리 편집기를 끝내고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA 서비스가 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-02-19

Microsoft® Exchange Server Analyzer Tool은 다음 서비스의 Started 키에 대해 설정된 값이 True 또는 False인지 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Microsoft Exchange MTA Stacks 서비스

  • 클러스터 서비스

False 값은 이 Exchange Server 컴퓨터에서 해당 서비스가 실행되고 있지 않음을 나타내며 True 값은 서비스가 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스에서 Exchange_Server WMI 클래스를 검토하여 IsFrontEndServer 키 값을 확인합니다. False 값은 Exchange Server 컴퓨터가 프런트 엔드 서버가 아님을 나타내고 True 값은 Exchange Server 컴퓨터가 프런트 엔드 서버임을 나타냅니다.

평가된 세 키 값이 모두 False이면 경고가 표시됩니다.

메일을 라우팅하는 모든 Exchange Server 컴퓨터에서는 Exchange MTA Stacks 서비스를 시작하는 것이 좋습니다. 특히 Exchange Server 5.5와 Exchange Server 2003 및/또는 Exchange 2000 Server 간에 메시지가 전송되는 혼합 모드 환경에서는 이 서비스를 시작하는 것이 좋습니다. 또한 모든 X.400 커넥터는 Exchange MTA Stacks 서비스를 필요로 하므로 이 서비스를 사용하지 않으면 오류가 생성되고 커넥터가 제대로 작동되지 않을 수 있습니다. 사서함을 이동하기 위해서도 MTA Stacks 서비스를 시작해야 합니다.

이 경고를 해결하려면 Exchange MTA Stacks 서비스를 시작합니다.

Exchange MTA Stacks 서비스를 시작하려면 다음을 수행합니다.

  1. 시작 메뉴에서 프로그램, 관리 도구를 차례로 선택한 다음 서비스 MMC(Microsoft Management Console) 스냅인을 선택합니다.

  2. Microsoft Exchange MTA Stacks 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. Microsoft Exchange MTA Stacks 속성 페이지의 일반 탭에서 시작 유형이 자동으로 설정되어 있는지 확인합니다. 그렇지 않은 경우 적용을 클릭한 다음 확인을 클릭합니다.

  4. Microsoft Exchange MTA Stacks 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.

혼합 모드 Exchange 환경에서 Exchange MTA Stacks 서비스를 실행하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 810489, "MTA Stacks Service Must Remain Enabled on Exchange 2000 and 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489)을 참조하십시오.


MTA 서비스가 사용 안 함으로 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange MTA Stacks 서비스 StartMode 키에 설정된 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Disabled 값은 Exchange MTA Stacks 서비스가 사용할 수 없게 설정되었으며 StartMode 값을 Manual이나 Automatic 중 하나로 변경할 때까지 서비스를 시작할 수 없음을 나타냅니다.

또한 Exchange Server Analyzer는 SMTP(Simple Mail Transfer Protocol) 서비스의 Started 키 값을 확인할 때 Win32_Service WMI 클래스를 쿼리합니다. False 값은 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 서비스가 실행되고 있음을 나타냅니다.

마지막으로 Exchange Server Analyzer는 OSProductSuite 키 값을 확인할 때도 Win32_OperatingSystem WMI 클래스를 쿼리합니다. 이 키 값은 Microsoft Windows Server™ 2003 운영 체제의 특정 버전에 해당합니다.

Exchange Server Analyzer는 SMTP 서비스를 시작한 Exchange Server 컴퓨터에서 StartMode 키 값을 Disabled로 설정한 상태에서 이 Exchange Server 컴퓨터가 Microsoft Windows Small Business Server 2003 설치의 일부가 아닐 경우 경고를 표시합니다.

서버가 Microsoft Windows Small Business Server 2003 설치의 일부가 아니거나 단순 Exchange Server 2003 전용 모드 환경에 있지 않을 경우 메일을 라우팅하는 모든 Exchange Server 컴퓨터에서 Exchange MTA Stacks 서비스를 자동으로 설정해야 합니다. Exchange MTA Stacks 서비스를 사용할 수 없게 설정한 서버에서 메일을 라우팅하면 여러 가지 오류 메시지가 표시될 수 있습니다. Exchange Server 버전 5.5도 실행되고 있는 Exchange 2000 Server 환경이나 Exchange Server 2003 환경에서 실행 중인 경우에는 오류가 기록될 경우도 있습니다. 또한 모든 X.400 커넥터를 사용하려면 Exchange MTA Stacks 서비스가 필요하므로 이 서비스를 사용할 수 없게 설정하면 오류가 생성되고 커넥터 기능이 제대로 작동하지 않을 수 있습니다.

참고:
외부 X.400 메일 시스템에 직접 연결되거나 Novell GroupWise Connector, Lotus Notes Connector 또는 타사 팩스 커넥터와 같은 EDK(Exchange 개발 키트) 커넥터를 실행하는 경우를 제외하고 MTA Stacks 서비스의 종속성은 Exchange Server 2003에서 제거되었습니다. 따라서 이제는 MTA Stacks 서비스가 사용되지 않는 단순 전용 모드 Exchange Server 2003 배포가 지원됩니다.

이 오류를 해결하려면 메일을 라우팅하는 서버에서 Exchange MTA Stacks 서비스가 자동으로 시작되도록 구성해야 합니다.

Exchange MTA Stacks 서비스가 자동으로 시작되도록 구성하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. Microsoft Exchange MTA Stacks 서비스를 두 번 클릭합니다.

  3. Microsoft Exchange MTA Stacks 속성 페이지의 일반 탭에 있는 시작 유형 드롭다운 대화 상자에서 자동을 선택한 다음 적용을 클릭합니다.

  4. 서비스 상태에서 시작을 클릭한 다음 확인을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.

Exchange에서 Exchange MTA Stacks 서비스를 계속 실행하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 810489, "MTA Stacks service supportability guidelines for Exchange 2000 Server and Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489)을 참조하십시오.


MTA Submit/deliver threads 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\ Submit/deliver threads

Exchange Server Analyzer는 Submit/deliver threads의 값이 2 이외의 값으로 설정되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

Submit/deliver threads 값은 메시지 전송 에이전트(MTA) 전송/배달 스레드의 수입니다. MTA는 이러한 스레드를 사용하여 메시지를 정보 저장소로 전달합니다. 일부 Exchange Server 버전 5.5 컴퓨터에서는 Exchange Performance Optimizer 프로그램이 이 값을 기본값 2에서 Exchange 서버에 더욱 적합한 값으로 자동 변경한 것일 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 Submit/deliver threads 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 2가 입력되었는지 확인하고 확인을 클릭합니다.

  5. 레지스트리 편집기를 끝내고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

Exchange 2000 Server 및 Exchange Server 2003 컴퓨터에서는 이 항목의 값이 3 이하로 설정되어야 합니다. Exchange Server 5.5 컴퓨터에서는 앞선 절차와 다른 방법으로 자세한 정보 표시 모드로 Exchange Performance Optimizer 프로그램을 실행perfwiz.exe -v)하고 이 유틸리티를 사용하여 값을 설정할 수 있습니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MTA Submit/deliver threads 레지스트리 값의 기본값을 변경해야 하는 상황에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 234280, "XCON: How to Increase the Ability of the MTA to Pass Mail over Slow Network Connections"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280)

  • 265186, "XCON: MTA Fanout Slows on Multiprocessor Servers and Messages Back Up in Information Store"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186)

  • 234702, "XGEN: MTA Queue to Information Store Processing Slowly"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=234702)

  • 327260, "XCON: MTA가 Exchange Server 5.5에서 느려지거나 멈추고 메시지가 개인 정보 저장소에 백업된다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260)

  • 자세한 정보 표시 모드로 Exchange Performance Optimizer 프로그램을 사용하는 방법에 대한 자세한 내용은 기술 자료 문서 246125, "XADM: Exchange Server 5.5 Performance Optimizer Verbose Mode"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246125)를 참조하십시오.


MTA TCP/IP control blocks 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

오류 메시지

소개

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP control blocks

Exchange Server Analyzer는 TCP/IP control blocks 값이 20이 아니면 기본 구성이 아니라는 메시지를 표시합니다.

TCP/IP control blocks 값은 지원되는 최대 동시 RFC1006(TCP/IP) 연결 수입니다. 이 설정은 X.400 연결에 사용할 수 있는 버퍼 수를 제어합니다. 이 메시지 전송 에이전트(MTA)가 둘 이상의 X.400 커넥터를 호스팅하는 경우에는 TCP/IP control blocks 값을 조정해야 합니다. 호스팅할 X.400 커넥터 각각에 제어 블록 10개와 수신 연결을 서비스하기 위한 제어 블록 한 개가 있어야 합니다. 따라서 시스템에 X.400 연결이 세 개 있을 경우 적절한 값은 33입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP 제어 블록 값을 구성하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 TCP/IP control blocks 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 이 MTA에 적절한 값을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA TCP/IP threads 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

오류 메시지

소개

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP threads

Exchange Server Analyzer는 TCP/IP threads의 값이 2 이외의 값으로 설정되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

TCP/IP threads 값은 RFC1006 연결을 처리하는 MTA(메시지 전송 에이전트) DMOD(동적 주소 모듈) 스레드의 최대 수입니다. RFC1006 스레드의 두 가지 하위 유형(Driver 및 Async Notify)인 경우 이 수에 2를 곱합니다. 많은 수의 연결을 처리하는 X.400 디렉터리 복제 브리지헤드 서버와 전용 공용 폴더 서버에서는 이 값을 기본값인 2에서 10으로 수정하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

TCP/IP threads 값을 구성하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 TCP/IP threads 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 적절한 값을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


MTA Transfer threads 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

오류 메시지

소개

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transfer threads

Exchange Server Analyzer는 Transfer threads 값이 0보다 크지만 1이나 2가 아니면 기본 구성이 아니라는 메시지를 표시합니다.

Transfer threads 값은 메시지 전송 에이전트(MTA) 전송 스레드의 수를 나타냅니다. 각 전송 스레드의 두 가지 하위 형식(Transfer In 및 Transfer Out)에 2를 곱합니다. 이 값은 MTA 및 정보 저장소 메시지 전송과 관련된 Submit/deliver threads 값과 같지만 게이트웨이와 MTA에 대한 값입니다. Submit/deliver threads 값에 대한 자세한 내용은 MTA Submit/deliver threads 매개 변수가 기본값이 아닙니다. 링크를 참조하십시오.

이것이 한 사이트 내에 있거나 여러 사이트에 걸쳐 있는 둘 이상의 Exchange Server 5.5 컴퓨터와 통신하는 Exchange 2000 Server 또는 Exchange Server 2003 MTA일 경우 Transfer threads 값을 3으로 조정하는 것이 좋습니다.

일부 Exchange Server 5.5 컴퓨터에서는 Exchange Performance Optimizer 프로그램이 이 값을 기본값에서 Exchange 서버에 더욱 적합한 값으로 자동 변경한 것일 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Transfer threads 값을 구성하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 Transfer threads 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 적절한 값을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

Exchange 2000 Server 및 Exchange Server 2003 컴퓨터에서는 이 항목의 값은 3 이하로 설정되어야 합니다. 위 절차와 다른 방법으로 자세한 정보 표시 모드로 Exchange Performance Optimizer를 실행(perfwiz.exe -v)하고 이 도구를 사용하여 값을 설정할 수 있습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MTA Transfer threads 레지스트리 값의 기본값을 변경해야 하는 상황에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 234280, "XCON: How to Increase the Ability of the MTA to Pass Mail over Slow Network Connections"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280)

  • 265186, "XCON: MTA Fanout Slows on Multiprocessor Servers and Messages Back Up in Information Store"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186)

  • 327260, "XCON: MTA가 Exchange Server 5.5에서 느려지거나 멈추고 메시지가 개인 정보 저장소에 백업된다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260)


MTA Transport threads 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

오류 메시지

소개

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 항목의 현재 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transport threads

Exchange Server Analyzer는 Transport threads 값이 있으나 1 이외의 값으로 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

Transport threads 값은 메시지 전송 에이전트(MTA) 전송 스레드의 수를 나타냅니다. 어떠한 조직에서도 기본값 1이면 충분합니다. Microsoft 기술 지원 서비스에서 다른 지침을 제공하지 않는 한, 이 값을 1로 두십시오.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Transport threads 값을 구성하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters를 탐색합니다.

  3. 오른쪽 창에서 Transport threads 값을 찾아 두 번 클릭합니다.

  4. 값 데이터 필드에 1을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange MTA Stacks 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


메시지 추적 사용 안 함
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-06

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 서버 개체의 messageTrackingEnabled 속성이 TRUE(사용함) 또는 FALSE(사용 안 함) 중 어느 것으로 설정되어 있는지 확인합니다.

서버 개체의 messageTrackingEnabled 속성이 False로 설정되어 있으면 Exchange Server Analyzer에서 오류를 표시합니다.

서버 개체의 messageTrackingEnabled 속성은 서버의 메시지 추적 센터의 상태를 확인합니다.

메시지 추적 센터 기능을 사용하면 보낸 사람, 메일 메시지 및 메시지 받는 사람에 대한 정보를 기록할 수 있습니다. 특히, 메시지를 보내거나 받은 시간, 메시지 크기와 우선 순위 및 메시지 받는 사람 목록 등의 통계를 살펴볼 수 있습니다. 또한 전자 메일 메시지의 제목 줄을 기록할 수도 있습니다. 메시지 추적 센터는 시스템 메시지, 공용 폴더 메시지 및 전자 메일 메시지 등의 메시지를 검색합니다.

메시지 추적을 원하는 각 서버에 대해 메시지 추적 센터를 사용 가능하게 설정해야 합니다. 이 기능이 설정되면 서버를 통해 라우팅되는 모든 메시지가 메시지 추적 로그에 추가됩니다.

Exchange Server Analyzer에서 검색을 시작하려면 메시지 추적 기능을 사용하도록 설정되어 있어야 합니다.

참고:
이 절차를 수행하려면 로컬 관리자 그룹의 구성원 및 관리 그룹 단계에서 적용된 Exchange 관리자 역할이 있는 그룹의 구성원과 같은 사용 권한이 있어야 합니다.
서버에 메시지 추적 센터를 사용하도록 설정하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버를 확장하여 메시지 추적을 사용할 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 메시지 추적 사용 확인란을 선택합니다.

  3. 서버를 통해 보내거나 받은 모든 메시지의 제목을 기록하려면 제목 로깅 및 표시 사용 확인란을 선택합니다.

    참고:
    제목 로깅을 사용하면 성능이 약간 저하될 수 있습니다.

  4. 로그 파일 유지 관리에서는 로그 파일을 제거할 수 없도록 하거나 로그 파일 보관 기간을 수정할 수 있습니다. 추적 로그를 보관하는 기본 기간은 7일입니다.

    참고:
    대량의 메일을 처리하는 서버에서는 추적 로그가 급속하게 늘어납니다. 로그 파일을 위한 디스크 공간과 해당 디스크를 사용하는 다른 서비스나 응용 프로그램에 대해 디스크 공간이 충분한지 확인합니다.

  5. 확인 또는 적용을 클릭합니다. 변경 내용을 적용하기 위해 서비스를 다시 시작하지 않아도 됩니다.

메시지 추적 센터 사용 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 262162, "XADM: Using the Message Tracking Center to Track a Message"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)를 참조하십시오.

Exchange 서버 전송 문제 해결 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 821910, "Exchange Server 2003 전송 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910)을 참조하십시오.


메시지 추적 로그가 압축된 폴더에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 메시지 추적 로그 파일 경로의 Compressed 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Compressed 키 값이 True이면 오류를 표시합니다.

Exchange 2000 Server 또는 Exchange Server 2003 컴퓨터에서 메시지 추적을 사용하는 경우 추적 로그는 다음 기본 위치에 기록됩니다.

<drive> :\Program Files\Exchsrvr\ ServerName .log

여기서 <drive>는 \Program Files\Exchsrvr 경로가 포함된 드라이브이며 ServerName은 Exchange Server 컴퓨터의 호스트 이름입니다.

Exchange 데이터 파일은 NTFS로 압축된 볼륨에 저장되지 않습니다. Exchange 데이터 파일을 압축된 볼륨에 저장하면 추가 오버헤드가 발생해 Exchange의 성능에 막대한 영향을 줍니다. 또한 정보 저장소 데이터베이스가 일정 크기(약 4GB)에 도달하면 탑재에 실패하거나 손상될 수 있습니다.

Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

확장 가능한 저장소 엔진(ESE)에 의해 관리되는 파일은 압축된 드라이브에 저장하기 위한 파일이 아닙니다. ESE는 로그 기반 복구를 위한 섹터 독립에 종속되며 파일 압축은 섹터 독립을 무효화합니다. ESE 데이터베이스나 미리 쓰기 로깅을 사용하는 데이터베이스를 호스팅하는 볼륨에 대해서는 압축을 설정하면 안 됩니다.

Exchange 2000 Server 서비스 팩 3 이전 버전에서는 압축된 정보 저장소 데이터베이스를 탑재할 수 있습니다. 그러나 Exchange 2000 Server 정보 저장소 데이터베이스 또는 NTFS 압축을 사용하여 압축된 정보 저장소 로그가 손상될 수 있습니다.

Exchange 2000 Server 서비스 팩 3을 사용할 경우 128MB 이하의 압축된 정보 저장소 데이터베이스 파일은 자동으로 압축이 풀어집니다. 데이터베이스 파일이 128MB를 넘으면 데이터베이스가 탑재되지 않고 응용 프로그램 로그에 오류 메시지가 생성됩니다. Exchange 2000 Server 서비스 팩 3에서는 128 MB를 초과하는 압축된 데이터베이스를 탑재할 수 없습니다.

지정된 폴더의 파일 압축을 해제하려면 다음을 수행합니다.

  1. 파일 압축을 풀 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 내용을 압축하여 디스크 공간 절약 확인란의 선택을 해제한 다음 확인을 클릭합니다.

위의 절차 대신 메시지 추적 로그 파일을 압축되지 않은 다른 폴더로 이동해도 됩니다. 메시지 추적 로그 파일 이동에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 84103, "How to change the location of the message tracking logs in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089)

  • 317700, "How to change the location of the message tracking logs in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)

Exchange 데이터 파일 및 NTFS 압축에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 170009, "XADM: NTFS Compressed Volume Causes Store to Fail"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009)

  • 327772, "Database does not mount, and you receive error 0xfffff05b after you apply SP3 to Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772)


메시지 추적 로그가 NTFS가 아닌 파티션에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 Exchange 메시지 추적 로그 파일 경로에 대한 FSName 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 FSName 키 값이 NTFS가 아닐 경우 오류를 표시합니다.

NTFS가 아닌 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일에는 다음 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

이 오류가 발생한 경우 메시지 추적 로그를 NTFS 드라이브의 폴더로 이동해야 합니다. 또는 메시지 추적 로그가 저장된 드라이브가 FAT 드라이브로 포맷된 경우라면 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다.

Exchange Server 2003의 메시지 추적 로그를 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버를 차례로 확장하고 사용 중인 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭에서 변경을 클릭합니다.

  4. 메시지 추적 로그에 대한 새 경로를 입력한 다음 확인을 클릭합니다.

  5. 확인을 클릭합니다.
참고:
기본적으로 추적 로그 파일 위치를 수정하면 자정 UTC(Coordinated Universal Time)에 영향을 줍니다. 이 변경 내용이 적용되면 Exchange 메시지 추적 구성 요소는 지정한 새 위치에 새 로그 파일을 만듭니다. 그러나 이전 로그 파일은 새 위치로 이동되지 않습니다. 이와 같은 이유로 새 로그 파일 위치 변경이 적용될 때까지 기다린 다음 이전 위치의 로그 파일을 새 로그 파일 위치로 수동으로 이동합니다. Microsoft Exchange System Attendant 서비스가 다시 시작되면 로그 파일 경로가 즉시 새 위치로 변경됩니다. 이 시나리오에서 Exchange 메시지 추적은 사용자가 메시지를 보낼 때 새 위치에 새 로그 파일을 만듭니다. 이 시나리오에서는 같은 이름의 로그 파일이 두 개 있을 수 있습니다. 하나는 원래 위치의 로그 파일이며 다른 하나는 지정한 새 위치의 로그 파일입니다. 이와 같은 상황이 발생하면 로그 파일을 새 로그 파일 위치로 이동하기 전에 원래 로그 파일 위치에 저장되어 있는 로그 파일의 이름을 바꾸십시오. Exchange 메시지 추적(yyyymmdd)에서 사용하는 것과 같은 명명 규칙을 사용합니다. 그러나 이 경우에는 이름을 바꾼 로그 파일이 이후 로그 파일과 상충되지 않도록 기존 로그 파일들보다 빠른 날짜를 사용합니다.

Exchange 2000 Server를 실행하는 컴퓨터에서 메시지 추적 로그 파일을 이동하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 317700, "How to change the location of the message tracking logs in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)를 참조하십시오.

파일이 저장되어 있는 드라이브가 FAT 드라이브로 포맷된 경우에는 앞에서 설명한 절차 대신 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다. Convert.exe 명령줄 도구를 사용하여 FAT 파티션을 NTFS 파티션으로 변환하는 데 대한 자세한 내용은 Microsoft 기술 자료 문서 214579, "Convert.exe를 사용하여 파티션을 NTFS 파일 시스템으로 변환하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)을 참조하십시오.


메시지 추적 로그가 암호화된 폴더에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 메시지 추적 로그 파일의 Encrypted 키 값을 확인할 때 Win32_Directory WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키 값이 True이면 오류가 표시됩니다.

Exchange 2000 Server 또는 Exchange Server 2003 컴퓨터에서 메시지 추적을 사용하는 경우 추적 로그는 다음 기본 위치에 기록됩니다.

<drive>:\Program Files\Exchsrvr\ ServerName .log

여기서 <drive>는 \Program Files\Exchsrvr 경로를 포함하는 드라이브이고, ServerName은 Exchange Server 컴퓨터의 호스트 이름입니다.

EFS(암호화 파일 시스템) 암호화 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일을 암호화된 볼륨에 저장하면 추가 오버헤드가 발생하여 Exchange의 성능에 막대한 영향을 줍니다. Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

Exchange 데이터 파일을 보호하려면 Exchange 컴퓨터에 대한 무단 액세스를 방지하고 S/MIME 메시지 형식을 사용하여 메시지 데이터를 암호화하는 것이 좋습니다.

지정한 폴더의 파일 암호화를 해제하려면 다음을 수행합니다.

  1. 파일 암호화를 해제할 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 데이터 보호를 위해 내용을 암호화 확인란의 선택을 해제한 다음 확인을 클릭합니다.

위의 절차 대신 메시지 추적 로그 파일을 암호화되지 않은 다른 폴더로 이동해도 됩니다. 메시지 추적 로그 파일 이동에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 841089, "How to change the location of the message tracking logs in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089)

  • 317700, "How to change the location of the message tracking logs in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)


메타베이스에 액세스할 수 없음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-02-13

Microsoft® Exchange Server Analyzer Tool이 SMTP(Simple Mail Transfer Protocol) 가상 서버 인스턴스의 여러 속성을 다음의 인터넷 정보 서비스(IIS) 메타베이스 경로에서 읽습니다.

/LM/SmtpSvc/<SMTP 가상 서버 인스턴스>

Exchange Server Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • 메타베이스 쿼리를 실패했습니다.

  • Exchange Server가 Microsoft Windows NT® Server 4.0에서 실행되고 있지 않습니다.

이 오류는 Exchange Server Analyzer가 IIS 메타베이스에 연결할 수 없음을 나타냅니다.

IIS 메타베이스에는 HTTP용 프로토콜 설정, 사서함과 모바일 장치 액세스를 위한 가상 디렉터리 및 HTTP 보안 설정과 같이 Exchange Server에 영향을 주는 정보가 포함됩니다.

이 문제를 해결하려면 메타베이스의 무결성과 해당 IIS가 제대로 설치되어 있는지 확인하십시오.

메타베이스가 손상되지 않았으며 IIS가 제대로 설치되어 있는지를 확인하려면 다음 리소스를 참조하십시오.

  • Microsoft 기술 자료 문서 240225, "메타베이스를 수정하는 데 사용되는 Adsutil 및 MetaEdit 유틸리티에 대한 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225)

  • Microsoft 기술 자료 문서 317678, "HOW TO: Restart Internet Information Services (IIS) on Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678)

이러한 리소스의 지침을 따라도 문제가 해결되지 않으면 IIS를 제거한 다음 다시 설치해야 할 수도 있습니다.

제어판에서 Windows 구성 요소 추가/제거를 사용하여 IIS를 제거하려면 다음을 수행하십시오.

  1. 시작을 클릭한 다음 제어판을 클릭합니다.

  2. 프로그램 추가/제거를 두 번 클릭합니다.

  3. Windows 구성 요소 추가/제거를 클릭합니다.

  4. 구성 요소 목록에서 응용 프로그램 서버 확인란을 클릭합니다.

  5. 자세히를 클릭합니다.

  6. 인터넷 정보 서비스 관리자를 클릭합니다.

  7. 다음을 클릭합니다.

  8. IIS가 제거되었으면 마침을 클릭합니다.
제어판을 사용하여 IIS를 설치하려면 다음을 수행하십시오.

  1. 시작을 클릭한 다음 제어판을 클릭합니다.

  2. 프로그램 추가/제거를 두 번 클릭합니다.

  3. Windows 구성 요소 추가/제거를 클릭합니다.

  4. 구성 요소 목록에서 응용 프로그램 서버 확인란을 클릭합니다.

  5. 자세히를 클릭합니다.

  6. 인터넷 정보 서비스 관리자 확인란을 클릭합니다.

  7. Windows 구성 요소 마법사로 돌아갈 때까지 확인을 클릭합니다.

  8. 다음을 클릭한 다음 Windows 구성 요소 마법사를 완료합니다.


MinUserDC 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 주 도메인 컨트롤러(PDC) 에뮬레이터의 역할을 하는 Active Directory® 디렉터리 서비스 도메인 컨트롤러가 Exchange에서 사용할 수 있는 도메인 컨트롤러의 목록에서 수동으로 제외되었는지를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

Exchange Server Analyzer는 MinUserDC가 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

PDC 에뮬레이터는 Microsoft Windows NT® Server 4.0 백업 도메인 컨트롤러의 복제 요청을 처리하고 Active Directory 사용이 가능한 클라이언트 소프트웨어를 실행하지 않는 클라이언트에 대한 모든 암호 업데이트를 처리하는 Active Directory 작업 마스터 역할 컴퓨터입니다. 또한 PDC 에뮬레이터는 도메인 컨트롤러이기도 하므로 Exchange와 같은 응용 프로그램에서 사용할 수 있습니다.

DSAccess(Directory Service Access)는 Exchange 2000 Server와 Exchange Server 2003의 내부 구성 요소로, 모든 Exchange 구성 요소가 Active Directory에 액세스하는 방법을 제어합니다. DSAccess의 기본 기능은 다양한 디렉터리 관련 이벤트 및 작업에 대한 정보를 유지하는 것입니다. 예를 들어 DSAccess는 Active Directory 토폴로지를 검색하고 도메인 컨트롤러 및 글로벌 카탈로그 서버가 사용 가능하고 쿼리에 응답하는지 확인합니다.

DSAccess의 사용 가능한 도메인 컨트롤러 목록에는 기본적으로 PDC 에뮬레이터 컴퓨터가 포함됩니다. Exchange 이외의 프로그램에서 PDC 에뮬레이터를 많이 사용할 경우 DSAccess를 통해 PDC 에뮬레이터를 사용하면 PDC 에뮬레이터 컴퓨터뿐만 아니라 Exchange 서버와 Exchange 이외의 프로그램 컴퓨터에서 성능 문제가 발생할 수 있습니다.

MinUserDC 레지스트리 값을 Exchange 서버의 레지스트리에 추가하여 DSAccess가 PDC 에뮬레이터 작업 마스터 역할의 도메인 컨트롤러를 쿼리하기 전에 사용 가능한 다른 모든 도메인 컨트롤러를 쿼리하도록 하면 이러한 성능 문제를 방지할 수 있습니다.

참고:
MiniUserDC 레지스트리 값으로 구성된 Exchange 서버에서는 우선 동일한 도메인의 다른 서버를 사용하려고 하므로 사이트에 Exchange 서버가 포함된 도메인에 대한 도메인 컨트롤러가 둘 이상 있는 경우에만 이 구성을 설정하는 것이 좋습니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

MinUserDC 레지스트리 값을 조사하고 편집하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default를 탐색합니다.

  3. MinUserDC 값을 찾아 필요에 따라 변경합니다. DWORD 값이 없으면 해당 값을 수동으로 만들 수 있습니다.

  4. MinUserDC 레지스트리 항목에 대해 구성되어 있는 값 데이터는 PDC 에뮬레이터에 연결하기 전에 먼저 연결할 도메인 컨트롤러의 최대 수입니다. 예를 들어 MinUserDC를 4로 설정하면 사용할 수 있는 도메인 컨트롤러가 총 4개인 경우에만 PDC 에뮬레이터를 제외하도록 DSAccess가 구성됩니다. 이 조건이 만족되면 PDC 에뮬레이터가 제외되며 DSAccess는 나머지 3개의 도메인 컨트롤러와만 통신합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MinUserDC 레지스트리 항목 사용에 대한 자세한 내용은 기술 자료 문서 298879, "XADM: Exchange 2000 May Experience Performance Problems When PDC Emulator Is Used for DSAccess"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879)를 참조하십시오.


사서함 저장소가 1000개를 넘습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-12-13

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하고 msExchPrivateMDB의 개체 클래스와 함께 Microsoft Exchange Information Store 개체의 개수를 유지 관리합니다. Exchange Server Analyzer는 조직 내에 사서함 저장소가 1,000개 이상 있을 경우 경고를 표시합니다.

사서함 저장소가 1,000개 이상 있는 조직의 프런트 엔드 서버를 통해 Microsoft Office Outlook® Web Access 2003의 사서함에 액세스할 때 사용 중인 사서함에 액세스할 수 없는 알려진 문제로 인해 경고가 표시됩니다. 프런트 엔드 Exchange 서버가 백 엔드 Exchange 서버로 인증 요청을 프록시하는 방법 때문에 이러한 문제가 발생합니다.

프런트 엔드 Exchange 서버에서 사용자가 사용 중인 사서함 저장소에 액세스할 때 이 경고가 표시되면 다음 중 한 가지 작업을 수행해야 합니다.

  • Microsoft 기술 자료 문서 899902, "Users receive a 401 error message when they try to access a mailbox that is in an Exchange Server 2003 front-end server by using Outlook Web Access"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=899902)에 설명되어 있는 Exchange Server 핫픽스를 구하여 설치합니다.

  • 가능하면 사서함을 통합하여 사서함 저장소 수를 줄입니다.

  • 기본 인증을 사용하여 백 엔드 서버를 인증하도록 프런트 엔드 서버를 설정합니다. 이 문서의 나머지 부분은 이 옵션에 대해 설명합니다.

기본적으로 Exchange Server 2003 프런트 엔드 서버는 Kerberos 인증을 사용하여 프런트 엔드 서버와 백 엔드 서버 사이의 사용자 자격 증명을 보호합니다. Kerberos 인증이 실패하면 경고 이벤트가 기록되고 프런트 엔드 서버가 NTLM을 대신 시도합니다. NTLM이 실패하면 오류가 기록됩니다. 30분 후에 Kerberos 인증을 다시 시도합니다. Exchange 2000 Server 또는 Exchange Server 2003 프런트 엔드 컴퓨터가 Exchange 2000 Server 백 엔드 컴퓨터를 인증할 경우에는 NTLM을 사용합니다. IIS(인터넷 정보 서비스)나 Exchange System Manager에는 인증 메커니즘을 선택하기 위한 사용자 인터페이스가 없습니다.

기본 인증을 사용하도록 프런트 엔드 Exchange 서버를 구성하려면 조직 내의 모든 프런트 엔드 서버에서 레지스트리 키를 설정해야 합니다. 다음 절차는 수동으로 키를 설정하는 방법을 설명합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Exchange 백 엔드 서버에 대해 기본 인증을 사용하도록 Exchange 프런트 엔드 서버를 구성하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Service\MSExchangeWeb을 탐색합니다.

  2. MSExchangeWeb을 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 다음 키를 클릭합니다. 새 키에 Dav라는 이름을 지정합니다.

  3. 새로운 Dav 키를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 다음 DWORD 값을 클릭합니다.

  4. 새 값에 UseBasicAuthToBE라는 이름을 지정한 다음 값을 1로 설정합니다.

  5. 서비스 MMC(Microsoft Management Console) 스냅인을 열고 IIS Admin Service를 마우스 오른쪽 단추로 클릭한 다음 다시 시작을 클릭합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


진행중인 store.exe 호출 대부분이 ESE로부터의 응답을 기다립니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-13

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Information Store 서비스(Store.exe)에서 Exchange ESE(확장 가능한 저장소 엔진)에 대해 진행 중인 상호 구성 요소 호출을 나타내는 이벤트를 확인하기 위해 FCL(Exchange Function Call Log), Store.fcl 파일을 검사합니다.

진행 중인 호출이란 Exchange FCL 데이터를 Store.fcl 파일에 기록하는 순간에 응답을 받지 못한 다른 구성 요소에게 Microsoft Exchange Information Store 서비스(Store.exe)에서 보내는 요청입니다.

Microsoft Exchange Information Store는 ESE 데이터베이스 상위에 위치합니다. ESE는 복잡한 트랜잭션 기반 데이터베이스 엔진입니다. 트랜잭션은 분할할 수 없는 원자 단위로 처리되는 일련의 작업입니다. 트랜잭션의 모든 작업은 완료되어 영구 저장된 것이 아니면, 작업이 수행되지 않은 것입니다.

Exchange 서버에서는 데이터베이스의 구조를 결정하고 메모리를 관리하는 포함 데이터베이스 엔진으로서 ESE를 사용합니다. 데이터베이스 엔진은 4KB 크기의 데이터(페이지)를 메모리로 보내거나 메모리에서 내보냄으로써 메모리의 데이터베이스를 캐시합니다. 이 엔진은 메모리의 페이지를 업데이트하고 디스크에 새 페이지나 업데이트된 페이지를 다시 씁니다. 요청이 시스템에 도달하면, 데이터베이스 엔진은 메모리의 데이터를 버퍼링할 수 있습니다. 그렇기 때문에 디스크에 계속적으로 액세스할 필요가 없습니다.

메모리의 데이터를 캐시하는 것이 데이터를 처리하는 가장 빠르고 효율적인 방법이긴 하지만 Exchange가 실행 중일 때 디스크 상의 정보는 완전히 최신의 것이 될 수 없음을 의미합니다. 데이터베이스의 최신 버전은 메모리에 있습니다. 그러나 메모리의 여러 가지 변경 사항이 디스크에 아직 반영되지 않았으므로 데이터베이스와 메모리는 동기화되지 않습니다. 트랜잭션 로그 디스크는 항상 각 트랜잭션에 관한 최신 정보를 보유합니다.

Exchange Server Analyzer는 Exchange Information Store 서비스(Store.exe)로부터 ESE 데이터베이스에 대한 호출의 우세를 나타내는 Store.fcl 로깅 파일 이벤트를 발견하는 경우 오류를 표시합니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

Microsoft Exchange Information Store 서비스에서 ESE로 보내는 진행 중인 호출은 다음과 같은 조건에서 발생할 수 있습니다.

  • Exchange 온라인 조각 모음

  • 데이터 백업

    참고:
    Exchange 호출 추적 로깅 수집 중 데이터 백업 또는 온라인 조각 모음이 수행되는 경우 Exchange 서버 성능 문제를 나타내는 오류 메시지를 무시해도 안전합니다.
  • 예를 들면 데이터베이스 드라이브의 병목 현상은 서버의 사용자 수에 비해 용량이 불충분함을 나타냅니다.

  • TEMP 및 TMP 드라이브의 병목 현상

이 오류를 해결하려면 다음 단계를 수행합니다.

  • 백업 Windows 또는 온라인 유지 관리를 사용자 요구가 많은 시간대와 겹치지 않도록 하는 것이 가장 좋습니다.

  • 데이터베이스 디스크 드라이브가 안정적이고 I/O 로드에 대한 처리량이 충분한지 확인하십시오.

  • Exchange Server Analyzer를 실행하여 서버를 추가적으로 분석합니다. "Microsoft Exchange Server Best Practices Analyzer Tool v2.7"(http://go.microsoft.com/fwlink/?LinkId=34705)에서 Exchange Server Analyzer를 다운로드할 수 있습니다.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

온라인 조각 모음 시간 창을 구성하는 방법에 관한 자세한 내용은 Microsoft 기술 자료 문서 244524, "XADM: How to Configure the Exchange Server Online Defragmentation Time Window"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524)를 참조하십시오.

Exchange 서버 디스크 지체 문제에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

Exchange 서버에서 디스크 크기를 설정하고 최적화하는 방법에 관한 자세한 내용은 Exchange Server 2003의 저장소 최적화 (http://go.microsoft.com/fwlink/?linkid=49324)의 "디스크 I/O 요구 사항을 계산하는 방법" 및 "여러 아키텍처에 공통적인 유용한 정보"를 참조하십시오.

ESE에 대한 자세한 내용은 "Extensible Storage Engine Architecture"(http://go.microsoft.com/fwlink/?linkid=67009)를 참조하십시오.


진행중인 store.exe 호출 대부분이 IMAIL로부터의 응답을 기다립니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-13

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Information Store 서비스(Store.exe)에서 MAPI 클라이언트의 IMAIL 구성 요소에 대해 진행 중인 상호 구성 요소 호출의 우세를 나타내는 이벤트를 확인하기 위해 Exchange 서버 FCL(Function Call Log), Store.fcl 파일을 검사합니다.

진행 중인 호출이란 Exchange FCL 데이터를 Store.fcl 파일에 기록하는 순간에 응답을 받지 못한 다른 구성 요소에게 Microsoft Exchange Information Store 서비스(Store.exe)에서 보내는 요청입니다.

Exchange 서버의 IMAIL 구성 요소는 인터넷과 MAPI 메시지 사이에서 Microsoft Exchange Information Store 서비스가 사용하는 유연한 변환 서비스입니다. 이 서비스를 통해 RFC-822 또는 인터넷 형식을 사용하는 클라이언트와 MAPI 클라이언트 또는 내부 저장소 작업과 같은 Exchange 서버 내부 저장소 형식을 사용하는 클라이언트 간에 상호 연동이 가능합니다.

Exchange에서는 IMAIL 메커니즘을 사용하여 Exchange Server Manager의 인터넷 도메인에 대해 정의되거나 또는 Microsoft Office Outlook®의 받는 사람별 사용자에 의해 지정된 내용에 따라 메시지 형식을 콘텐츠에 적용합니다. IMAIL에 전달된 서식 매개변수가 없는 경우 IMAIL은 S/TNEF(Summary TNEF) 형식으로 MAPI 메시지의 서식을 지정하여 서버 간에 전송합니다 .

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 MAPI 클라이언트의 IMAIL 구성 요소에 대해 진행 중인 호출의 우세를 나타내는 이벤트를 발견하는 경우 오류를 표시합니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

Microsoft Exchange Information Store 서비스로부터 MAPI 클라이언트의 IMAIL 구성 요소에 대해 발생한 진행 중인 호출은 다음 조건 중 하나 이상이 해당될 때 발생할 수 있습니다.

  • IMAIL의 메시지 또는 첨부 파일에 처리해야 할 데이터가 많습니다.

  • 데이터 변환을 요청하는 클라이언트가 많습니다.

  • DSAccess 요청에 대한 응답이 느립니다.

  • TEMP 및 TMP 드라이브에 병목 현상이 발생합니다.

  • 사서함 이동 작업이 진행 중입니다.

이 오류를 해결하려면 다음 단계를 수행합니다.

  • 사용량이 많지 않은 시간에 사서함 이동을 예약합니다.

  • 메시지 및 첨부 파일 크기 제한과 같은 서버 문제의 추가 분석을 위해 Exchange Server Analyzer를 실행합니다. "Microsoft Exchange Server Best Practices Analyzer Tool v2.7"(http://go.microsoft.com/fwlink/?LinkId=34705)에서 Exchange Server Analyzer를 다운로드할 수 있습니다.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

Exchange 서버의 디스크 지체 문제에 관한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

Exchange 서버에서 디스크 크기를 설정하고 최적화하는 방법에 관한 자세한 내용은 Exchange Server 2003의 저장소 최적화(http://go.microsoft.com/fwlink/?linkid=49324)의 "디스크 I/O 요구 사항을 계산하는 방법" 및 "여러 아키텍처에 공통적인 유용한 정보"를 참조하십시오.

Exchange 서버의 메시지 크기 제한에 대한 유용한 정보에 관한 자세한 내용은 보내는 메시지의 최대 크기가 설정되지 않습니다.을 참조하십시오.

DSAccess 및 Exchange 서버 성능에 관한 자세한 내용은 Exchange Server 2003의 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "DSAccess 사용자 캐시 구성 방법"을 참조하십시오.

Exchange 서버 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

정보 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.


진행 중인 store.exe 호출 대부분이 LSASS로부터의 응답을 기다립니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-11

Microsoft®Microsoft® Exchange Server Analyzer Tool은 Exchange Information Store 서비스(Store.exe)에서 Local Security Authentication Server(Lsass.exe) 프로세스에 대해 진행 중인 상호 구성 요소 호출을 나타내는 이벤트를 확인하기 위해 Exchange FCL(Function Call Log), Store.fcl 파일을 검사합니다.

진행 중인 호출이란 Exchange FCL 데이터를 Store.fcl 파일에 기록하는 순간에 응답을 받지 못한 다른 구성 요소에게 Microsoft Exchange Information Store 서비스(Store.exe)에서 보내는 요청입니다.

Local Security Authentication Server 프로세스(Lsass.exe)는 계정 정보 및 로그온 유효성을 확인하기 위해 다른 프로세스에서 호출한 보안 하위 시스템입니다.

Exchange 클라이언트에 로그온할 때마다 Exchange 서버를 실행하는 서버는 클라이언트에 대한 계정 SID(보안 식별자)를 조회하기 위한 요청을 보내고 Local Security Authentication Server(Lsass.exe) 프로세스 내에 호출을 만듭니다.

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 Local Security Authentication Server(Lsass.exe) 프로세스에 대해 진행 중인 호출의 우세을 나타내는 이벤트를 발견하는 경우 오류를 표시합니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

Microsoft Exchange Information Store 서비스에서 LSASS 프로세스로 보내는 진행 중인 호출은 다음과 같은 조건에서 발생할 수 있습니다.

  • 동시에 인증하는 사용자 수와 관련된 서버 리소스 문제

  • Exchange 서버 및 도메인 컨트롤러 또는 글로벌 카탈로그 서버 간 네트워크 대기 시간

  • 서버 리소스 지체 문제

이 오류를 해결하려면 다음 단계를 수행합니다.

  • 'NeverPing' 매개 변수 권장에서 설명된 NeverPing 매개 변수를 구현합니다.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

Lsass.exe 프로세스 및 메모리 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 308356, "Windows Server 2003 또는 Windows 2000 Server를 실행하는 도메인 컨트롤러에서 Lsass.exe 프로세스의 메모리 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)을 참조하십시오.

Exchange 클라이언트 로그온 및 LSASS 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 161938, "Slow Exchange Client Logons Due to Resource Deadlock"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938)을 참조하십시오.

Exchange 서버와 도메인 컨트롤러 또는 글로벌 카탈로그 서버 사이의 네트워크 대기 시간에 대한 자세한 내용은 다음의 Exchange Server Team Blog 문서, "Exchange Does Not Always Use Local GCs"(http://go.microsoft.com/fwlink/?LinkId=69166)를 참조하십시오.

참고:
블로그의 내용과 해당 URL은 예고 없이 변경될 수 있습니다.

서버 리소스 지체 문제에 대한 자세한 내용은 프로세서 지체를 참조하십시오.

Exchange 서버 성능에 대한 자세한 내용은 "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

Exchange 서버 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

정보 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.


진행 중인 store.exe 호출 대부분이 디렉토리로부터 응답을 기다립니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-14

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Information Store 서비스(Store.exe)에서 Active Directory® 디렉터리 서비스에 대해 진행 중인 상호 구성 요소 호출의 우세를 나타내는 이벤트를 확인하기 위해 FCL(Exchange Function Call Log), Store.fcl 파일을 검사합니다.

진행 중인 호출이란 Exchange FCL 데이터를 Store.fcl 파일에 기록하는 순간에 응답을 받지 못한 다른 구성 요소에게 Microsoft Exchange Information Store 서비스(Store.exe)에서 보내는 요청입니다.

Active Directory는 모든 사서함 정보, 주소 목록 서비스 및 기타 받는 사람 관련 정보를 제공합니다. 또한 대부분의 Exchange Server 2003 구성 정보는 Active Directory에 저장됩니다.

Exchange 서버 서비스는 Active Directory에 저장된 정보에 액세스하며 Active Directory에 정보를 기록합니다.

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 Active Directory에 대한 호출의 우세를 나타내는 이벤트를 발견하는 경우 오류를 표시합니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

Microsoft Exchange Information Store 서비스에서 Active Directory로 보내는 진행 중인 호출은 다음과 같은 조건에서 발생할 수 있습니다.

  • Exchange 서버와 도메인 컨트롤러 간 네트워크 대기 시간

  • DSAccess의 정적 또는 잘못된 구성

  • 오버로드된 컨트롤러 및 글로벌 카탈로그

  • 잘못 설계된 Active Directory 토폴로지

이 오류를 해결하려면 다음 단계를 수행합니다.

  • 메시지 및 첨부 파일 크기 제한과 같은 서버 문제의 추가 분석을 위해 Exchange Server Analyzer를 실행합니다. "Microsoft Exchange Server Best Practices Analyzer Tool v2.7"(http://go.microsoft.com/fwlink/?LinkId=34705)에서 Exchange Server Analyzer를 다운로드할 수 있습니다.

  • Active Directory 도메인 컨트롤러 서버의 성능을 확인합니다.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

Exchange 성능 및 DSAccess에 대한 자세한 내용은 Microsoft 기술 자료 문서 250570, "디렉터리 서비스 서버 감지 및 DSAccess 사용"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570)을 참조하십시오.

Exchange 서버 성능에 대한 자세한 내용은 "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

Exchange 서버 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

정보 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.

도메인 컨트롤러 성능에 대한 자세한 내용은 다음 Windows Server 리소스를 참조하십시오.

  • "Planning Domain Controller Capacity"(http://go.microsoft.com/fwlink/?LinkId=70191).

  • Windows 2000 Server Active Directory Planning and Deployment Guides의 "Active Directory Monitoring of Domain Controllers"(http://go.microsoft.com/fwlink/?LinkId=70193).


진행 중인 store.exe 호출 대부분이 바이러스 스캐너로부터 응답을 기다립니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-13

Microsoft® Exchange Server Analyzer Tool은 Exchange Information Store 서비스(Store.exe)에서 Virusscan VAPI(Virus API) 구성 요소에 대해 진행 중인 상호 구성 요소 호출의 우세을 나타내는 이벤트를 확인하기 위해 Exchange FCL(Function Call Log), Store.fcl 파일을 검사합니다.

진행 중인 호출이란 Exchange FCL 데이터를 Store.fcl 파일에 기록하는 순간에 응답을 받지 못한 다른 구성 요소에게 Microsoft Exchange Information Store 서비스(Store.exe)에서 보내는 요청입니다.

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 Virusscan VAPI 구성 요소에 대해 진행 중인 호출의 우세를 나타내는 이벤트를 발견하는 경우 오류를 표시합니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

Microsoft Exchange Information Store 서비스에서 Virusscan VAPI 구성 요소로 보내는 진행 중인 호출은 다음과 같은 조건에서 발생할 수 있습니다.

  • 정보 저장소에 있는 항목을 재검색하는 바이러스 스캐너로 업데이트합니다.

  • 구성이 잘못된 바이러스 스캐너

  • 바이러스 스캐너 소프트웨어가 대용량 메시지 또는 첨부 파일을 처리합니다.

이 오류를 해결하려면 다음 단계를 수행합니다.

  • 리소스 소모가 낮을 때, 즉, 사용량이 많지 않은 시간대에 바이러스 엔진의 업데이트를 예약합니다.

  • 바이러스 검색 소프트웨어를 재설치하는 것을 검토하여 사용량이 많지 않은 시간대에 재설치합니다.

  • 바이러스 검색 엔진의 스레드 구성, 파일 수준 제외 등이 올바른지 검사합니다. Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)를 참조하십시오.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

Microsoft Exchange Server 2003에서 일반적으로 사용되는 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 823166, "XADM: Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)를 참조하십시오.

Microsoft Exchange 2000 Server에서 일반적으로 사용되는 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 328841, "Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)를 참조하십시오.

Exchange 서버 성능에 대한 자세한 내용은 "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

Exchange 서버 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

정보 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.


진행 중인 store.exe 호출 대부분이 VSS 스냅숏으로부터의 응답을 기다립니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-13

Microsoft® Exchange Server Analyzer Tool은 Exchange Information Store 서비스(Store.exe)에서 VSS(Volume Shadow Copy Service) 스냅숏 구성 요소에 대해 진행 중인 상호 구성 요소 호출을 나타내는 이벤트를 확인하기 위해 FCL(Exchange Function Call Log), Store.fcl 파일을 검사합니다.

진행 중인 호출이란 Exchange FCL 데이터를 Store.fcl 파일에 기록하는 순간에 응답을 받지 못한 다른 구성 요소에게 Microsoft Exchange Information Store 서비스(Store.exe)에서 보내는 요청입니다.

VSS는 시스템에 있는 응용 프로그램이 계속해서 볼륨에 기록하는 동안 볼륨 백업을 수행하도록 하는 프레임워크를 구현하는 COM API 집합입니다.

Microsoft Exchange Server 2003은 Microsoft Windows Server™ 2003 운영 체제에 포함된 VSS를 사용하여 Exchange Server 2003 데이터베이스 및 트랜잭션 로그 파일의 볼륨 섀도 복사본을 만듭니다.

VSS 스냅숏은 원본 데이터와 완전히 관계가 없는 것은 아닙니다. 일반적으로 스냅숏은 시간에 마커를 정의하고 데이터가 해당 시간으로 롤백될 수 있음을 확인할 때 생성됩니다.

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 VSS 스냅숏 구성 요소에 대해 진행 중인 호출을 나타내는 이벤트를 발견하는 경우 best practices 메시지를 표시합니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에 백업함으로 인해 클라이언트에 대한 서버 응답의 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

참고:
VSS 스냅숏을 Exchange 호출 추적 로깅 수집 중 20초 이내에 의도적으로 시작한 경우라면 Exchange 서버 성능 문제를 나타내는 오류 메시지를 무시해도 안전합니다.

백업 창을 온라인 유지 관리 또는 사용자 요구가 많은 시간대와 겹치지 않도록 하는 것이 가장 좋습니다.

자세한 정보

VSS에 대한 자세한 내용은 "Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=56571)을 참조하십시오.


MOUNTMGR.SYS 파일은 잘못된 버전입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키를 읽어 Microsoft Windows® Server 2003이 설치되어 있는지 확인합니다. HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\

또한 Exchange Server Analyzer는 다음 쿼리를 수행합니다.

  • Win32_OperatingSystem Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리하여 Windows Server 2003 서비스 팩 1이 설치되어 있는지 확인합니다.

  • Win32_Service WMI 클래스를 쿼리하여 클러스터 서비스를 실행하고 있는지 확인합니다.

  • Win32_Volume WMI 클래스를 쿼리하여 볼륨 탑재 지점이 있는지 확인합니다.

  • CIM_Datafile WMI 클래스를 쿼리하여 Mountmgr.sys의 Version 키 값이 2443보다 작은지 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • Mountmgr.sys의 Version 키가 2443보다 작습니다.

  • 서버가 Windows Server 2003 서비스 팩 1을 실행하는 클러스터의 노드입니다.

  • 서버에 볼륨 탑재 지점이 있습니다.

클러스터 노드에 설치된 Mountmgr.sys 버전으로 인해 볼륨 탑재 지점 오류가 발생할 수 있습니다. 이 문제는 Mountmgr.sys 드라이버의 문제로 인해 발생할 수 있습니다. 이는 볼륨이 도착하여 탑재 지점에 탑재될 때 발생할 수 있는 일시 중단 타이밍 문제입니다.

참고:
일반적으로 클러스터되지 않은 환경에서는 이 문제가 발생하지 않습니다. 클러스터되지 않은 환경에서는 볼륨 탑재 프로세스의 타이밍이 다릅니다.

이 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 898790, "Volume mount points on disks in a server cluster may intermittently become unavailable after you install Windows Server 2003 Service Pack 1"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790)을 참조하십시오.


TEMP 및 TMP 디렉터리 이동
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-09-01

Microsoft® Exchange Server Analyzer Tool에서 서버의 TEMP 및 TMP 폴더 위치가 최적의 디스크 성능에 맞지 않을 수 있음을 확인했습니다. TEMP 및 TMP 폴더는 시스템 폴더 또는 Exchange 데이터 파일에서 공유하지 않는 디스크 하위 시스템에 저장하는 것이 좋습니다.

Microsoft Exchange Information Store 서비스는 메시지 변환, 대용량 첨부 파일에 대한 작업 및 사서함 이동 작업 같은 다양한 작업 중에 임시 저장소로 TEMP 및 TMP 폴더를 사용합니다. TEMP 및 TMP 환경 변수는 임시 작업 영역이 필요한 응용 프로그램에서 사용하는 파일 시스템의 폴더(경로)를 지정하는 데 사용됩니다. TEMP는 보통 Microsoft Exchange 같은 응용 프로그램에서, TMP는 Microsoft Visual C++® 같은 개발 도구에서 사용합니다. 각 변수의 경로는 보통 응용 프로그램이나 도구의 보안 컨텍스트와 관련이 있습니다.

클러스터되지 않은 Exchange 서버에서 Exchange 저장소는 TEMP 및 TMP 둘 모두에 대해 기본 환경 변수 설정인 %Systemroot%\Temp를 사용하는 SYSTEM(예: Local System) 폴더를 사용합니다. Microsoft Windows® 서버 클러스터에서 실행되는 Exchange 가상 서버는 특정 사용자 보안 정책 컨텍스트에서 실행되는 클러스터 서비스 계정에 대해 이 환경 변수 설정을 사용합니다. 사용자 계정의 경우 TEMP 및 TMP에 대한 기본 환경 변수는 %Userprofile%\Temp로 설정됩니다.

이 문서에서는 클러스터된 환경과 클러스터되지 않은 환경에서 TEMP 및 TMP 디렉터리를 이동하는 방법을 설명합니다. 이 문서에 있는 절차를 수행하기 전에 다음 권장 사항을 고려하십시오.

  • 최적의 성능을 위해서는 Exchange에서 사용하는 TEMP 및 TMP 폴더를 운영 체제를 포함하는 디스크가 아닌 다른 디스크에 배치하는 것이 좋습니다. 또한 이러한 환경 변수를 RAID-0+1 스핀들 세트 같은 고속 디스크 또는 디스크 하위 시스템의 경로로 설정해야 합니다.

  • 사용하는 TEMP 및 TMP 폴더에 Exchange 트랜잭션 로그를 사용하지 않는 것이 좋습니다.

클러스터되지 않은 환경에서 TEMP 또는 TMP 폴더를 이동하려면 다음을 수행합니다.

  1. 관리 권한이 있는 계정으로 Exchange Server를 실행 중인 컴퓨터에 로그온합니다.

  2. 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  3. 고급 탭을 선택합니다.

  4. 환경 변수를 클릭합니다.

  5. 시스템 변수 영역에서 TEMP를 선택하고 편집을 클릭합니다.

  6. 변수 값 필드에 TEMP 환경 변수의 새 경로를 입력한 다음 확인을 클릭합니다.

  7. 시스템 변수 영역에서 TMP를 선택하고 편집을 클릭합니다.

  8. 변수 값 필드에 TMP 환경 변수의 새 경로를 입력한 다음 확인을 클릭합니다.

  9. 확인을 클릭하여 환경 변수 대화 상자를 닫은 다음 확인을 클릭하여 시스템 속성 대화 상자를 닫습니다.

  10. 서버를 다시 부팅하여 모든 변경 내용을 적용합니다.
클러스터된 환경에서 TEMP 또는 TMP 폴더를 이동하려면 다음을 수행합니다.

  1. 클러스터 서비스 계정으로 클러스터의 노드에 로그온합니다.

  2. 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  3. 고급을 선택합니다.

  4. 환경 변수를 클릭합니다.

  5. <account name>에 대한 사용자 변수 영역에서 TEMP를 선택하고 편집을 클릭합니다.

  6. 변수 값 필드에 TEMP 환경 변수의 새 경로를 입력한 다음 확인을 클릭합니다.

  7. <account name>에 대한 사용자 변수 영역에서 TMP를 선택하고 편집을 클릭합니다.

  8. 변수 값 필드에 TMP 환경 변수의 새 경로를 입력한 다음 확인을 클릭합니다.

  9. 확인을 클릭하여 환경 변수 대화 상자를 닫은 다음 확인을 클릭하여 시스템 속성 대화 상자를 닫습니다.

  10. 노드를 다시 시작하여 변경 내용을 적용합니다.

  11. 클러스터의 각 노드에 대해 1-10단계를 반복합니다.
중요:
인증된 사용자 계정에 새 TMP 및 TEMP 폴더 경로에 대한 적절한 사용 권한을 할당해야 합니다.
인증된 사용자 그룹에 TMP 또는 TEMP 폴더에 대한 사용 권한을 할당하려면 다음을 수행합니다.

  1. Windows 탐색기를 시작하고 TEMP 변수 또는 TMP 변수가 가리키는 폴더를 찾아서 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 임시 속성 대화 상자에서 보안 탭을 클릭한 다음 추가를 클릭합니다.

  3. 사용자, 컴퓨터 또는 그룹 선택 대화 상자에서 인증된 사용자 그룹을 개체 이름 목록에 추가하고 확인을 클릭합니다.

  4. 고급을 클릭하여 고급 보안 설정에 액세스합니다.

  5. 이름 목록에서 인증된 사용자를 선택하고 편집을 클릭하여 사용 권한 항목 대화 상자를 표시합니다.

  6. 사용 권한 영역의 필드를 사용하여 다음 특정 권한을 허용합니다.

    폴더 트래버스 / 파일 실행

    파일 만들기 / 데이터 쓰기

    폴더 만들기 / 데이터 추가

  7. 확인을 세 번 클릭하여 사용 권한을 적용하고 끝냅니다.

추가 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


다른 서버로 사용자 사서함 이동
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer Tool은 서버에 현재 효율적으로 지원할 수 있는 수준 이상의 로드가 있음을 확인했습니다. 현재 사용자 로드가 성능 문제를 일으키고 있습니다. 성능 문제가 해결될 때까지 매일 밤 적은 수의 사용자(대개 총 사용자의 5%)를 다른 위치로 이동하는 것이 좋습니다.

다음 문제 중 하나가 발생하므로 이 방법을 사용하는 것이 좋습니다.

  • 일부 Exchange 데이터베이스 파일이 처리량 제한에 도달했거나 초과한 디스크에 있습니다.

  • 다른 서버 리소스(예: 메모리 또는 CPU)의 용량이 초과되었습니다.

  • 디스크 용량이 초과되었다는 것은 현재 하나 이상의 Exchange 저장소를 지원하는 디스크 하위 시스템에서 평균 디스크 I/O 대기 시간이 현재 권장 수준을 초과함을 의미합니다. 문제가 해결될 때까지 다른 디스크 하위 시스템의 데이터베이스로 사용자의 5%를 이동해야 합니다. 데이터베이스 드라이브에 병목 현상이 발생하면 다른 드라이브에 있는 데이터베이스로 사용자를 이동합니다. 저장소 그룹에 병목 현상이 발생하면 다른 데이터베이스에 있는 다른 저장소 그룹의 데이터베이스로 사용자를 이동합니다. 다른 리소스에서 드라이버를 공유하는 경우에는 해당 드라이브에서 다른 응용 프로그램의 로드를 줄여서 문제를 해결할 수 있습니다.

  • 실제 서버의 용량이 초과되었습니다. 현재 사용자가 생성하는 서버 로드를 지원할 프로세서나 메모리가 충분하지 않습니다. 성능 문제가 해결될 때까지 다른 서버로 사용자 5%를 이동해야 합니다.

참고:
사서함을 이동하는 동안 Exchange 클라이언트와 사서함의 연결을 끊을 필요는 없지만 서비스에 방해가 되지 않도록 Exchange 클라이언트 작업량이 적은 시간에 이동 작업을 수행하는 것이 좋습니다.
Exchange Server 2003에서 사서함을 이동하려면 다음을 수행합니다.

  1. 해당 프로세스를 실행할 Exchange Server 2003 컴퓨터에서 Exchange System Manager를 시작합니다.

  2. 서버를 두 번 클릭한 다음 사용자 사서함이 있는 서버 컨테이너를 찾습니다.

    예를 들어 기본 저장소 그룹과 사서함 저장소에서 사서함을 이동하려면 기본 저장소 그룹, 사서함 저장소를 차례로 두 번 클릭한 다음 사서함을 클릭합니다.

  3. 세부 정보 창에서 이동할 사서함을 클릭합니다.

  4. 선택한 사용자를 마우스 오른쪽 단추로 클릭한 다음 Exchange 작업을 클릭합니다.

  5. Exchange 작업 마법사에서 다음을 클릭합니다.

  6. 사용 가능한 작업 페이지의 수행할 작업 선택에서 사서함 이동을 클릭한 후 다음을 클릭합니다.

  7. 사서함 이동 페이지의 서버 목록에서 원하는 서버를 클릭한 다음 사서함 저장소 목록에서 원하는 사서함 저장소를 클릭합니다.

  8. 다음을 클릭합니다.

  9. 이동 작업 중에 발견된 손상 메시지의 처리 방법을 구성한 후 다음을 클릭합니다.

  10. 다음을 클릭합니다.

추가 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange 서버 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • Exchange Server 2003의 사서함 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 821829, "Moving Mailboxes in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)을 참조하십시오.

  • Exchange 2000 Server와 Exchange Server 5.5 간의 사서함 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 328810, "XADM: 서버 간에 사서함 이동"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)을 참조하십시오.


NAS 구성 문제
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 저장소 그룹 개체의 msExchESEParamLogFilePath 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성은 저장소 그룹의 데이터베이스가 사용하는 트랜잭션 로그 파일의 위치를 지정합니다.

또한 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열된 항목 개수를 확인할 때도 Active Directory를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다.

또한 Exchange Server Analyzer는 Microsoft Windows Storage Server 2003 기능 팩 서비스(wssexchmap)의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. False 값은 이 Exchange 서버에서 Windows Storage Server 2003 기능 팩 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 Windows Storage Server 2003 기능 팩 서비스가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 값이 S:\{로 시작되는 msExchESEParamLogFilePath 특성이 있고 사서함이 1500개가 넘는 Exchange Server 컴퓨터에서 Windows Storage Server 2003 기능 팩 서비스가 시작된 경우 경고를 표시합니다.

Windows Storage Server 2003은 NAS 장치에 사용되는 Microsoft 플랫폼입니다. Windows Storage Server 2003 저장소 레이아웃은 Exchange Server 2003과 함께 사용하는 것이 좋으며 표준 Exchange Server 레이아웃과는 다소 다릅니다. Windows Storage Server 2003에 Exchange Server 데이터베이스를 설치하고 트랜잭션 로그 파일을 Exchange Server 컴퓨터 내에 있는 로컬 디스크에 저장하는 것이 좋습니다.

Microsoft는 다음과 같은 세 가지 작업 부하 유형에 맞는 Windows Storage Server 2003 기능 팩을 개발했습니다.

  • 단일 Windows Storage Server 컴퓨터에 연결된 단일 Exchange Server로 호스팅되는 최대 250개의 사서함에 대한 소량의 작업 부하. 이 경우 1GHz 이상의 프로세서, 512MB의 RAM, RAID-5 볼륨으로 구성된 4개의 SCSI 또는 IDE/SATA 디스크, 2개의 네트워크 인터페이스 카드(NIC)(LAN에 연결되는 카드 및 Exchange 서버에 직접 연결하기 위한 Gigabit Ethernet 어댑터)를 사용하여 Windows Storage Server를 구성하는 것이 좋습니다. Exchange 데이터베이스는 RAID-5 볼륨에 저장되며 트랜잭션 로그는 Exchange 서버의 로컬 RAID-1에 남아 있습니다.

  • 하나의 Exchange Server와 단일 Windows Storage Server 컴퓨터로 호스팅되는 하나의 저장소 그룹에 있는 최대 750개의 사서함에 대한 중간 규모의 작업 부하. 이 구성에서는 Windows Storage Server 컴퓨터에 1GHz 이상의 프로세서 2개, 1GB의 RAM, 6개의 SCSI 디스크 및 2개의 NIC를 사용해야 합니다. 디스크는 4디스크 RAID-5 데이터베이스 배열로 구성되어야 하고 트랜잭션 로그에 사용할 별도의 디스크 미러 세트가 2개 필요합니다.

  • 2개의 저장소 그룹에 있는 최대 1,500개의 사서함을 호스팅하는 1개 또는 2개의 Exchange Server 2003 서버에 대한 큰 작업 부하. 이 경우 1GHz 이상의 프로세서 2개, 2GB의 RAM, 총 14개의 디스크(데이터베이스를 저장할 RAID 0+1 배열에 사용되는 10개와 트랜잭션 로그를 저장할 2개의 디스크 미러 세트)를 사용하여 Windows Storage Server를 구성해야 합니다.

이 경고는 저장소에 Windows Storage Server 2003을 사용하도록 Exchange Server 컴퓨터가 구성되어 있음을 나타냅니다. Exchange Server 데이터 저장소에 Windows Storage Server를 사용하는 경우 1,500명 미만의 동시 사용자가 Exchange Server에 액세스하도록 하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  • 다음 중 하나를 수행합니다.

    • 트랜잭션 로그를 Exchange Server 컴퓨터의 로컬 디스크로 이동합니다.

    • 해당 Exchange Server 컴퓨터의 사서함 중 일부를 다른 Exchange Sever 컴퓨터로 이동하여 Windows Storage Server를 사용하는 Exchange Server 컴퓨터의 사서함 수를 1,500개 미만으로 줄입니다.

Windows Storage Server 2003 기능 팩 및 Exchange Server 2003 사용에 대한 자세한 내용은 문서 "Managing Exchange Storage with the Windows Storage Server 2003 Feature Pack"(http://go.microsoft.com/fwlink/?linkid=34942)을 참조하십시오.

자세한 내용은 다음 추가 리소스를 참조하십시오.

  • Introduction to Windows Storage Server 2003 Architecture and Deployment"(http://go.microsoft.com/fwlink/?linkid=34943)

  • Building Better Protected Storage using Windows Storage Server 2003"(http://go.microsoft.com/fwlink/?linkid=34944)

  • Server Consolidation Using Exchange Server 2003(http://go.microsoft.com/fwlink/?linkid=47586)


networkAddress 특성이 올바르게 설정되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 networkAddress 특성에 ncacn_ip_tcp 문자열이 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 다음 조건 중 하나가 충족되는 경우 오류를 표시합니다.

  • ncacn_ip_tcp 문자열이 없습니다.

  • ncacn_ip_tcp 문자열이 손상되었습니다.

Exchange Server 2003용 Microsoft Office Outlook® Web Access에서 프런트 엔드 서버는 Exchange 백 엔드 서버에 연결을 시도할 때 networkaddress 특성 값을 검사합니다.

참고:
Exchange 2000 Server는 Outlook Web Access로 이 작업을 수행하지 않습니다.

프런트 엔드 서버에는 정규화된 도메인 이름(FQDN) 값이 필요합니다. 프런트 엔드 서버는 networkaddress ncacn_ip_tcp에 대해 반환된 값의 마침표를 검사합니다. 다음 조건이 존재하는 경우 특정 백 엔드 서버의 사서함에 대한 연결 요청이 실패하고 프런트 엔드 서버는 사용자에게 "HTTP 500 내부 서버 오류" 오류 메시지를 반환합니다.

  • networkaddress ncacn_ip_tcp 값은 호스트 이름이거나 네트워크 기본 입/출력 시스템(NetBIOS) 이름입니다.

  • networkaddress ncacn_ip_tcp 값이 FQDN이 아닙니다.

Active Directory에 있는 서버 개체의 networkaddress ncacn_ip_tcp 값을 업데이트하여 Outlook Web Access 2003의 해당 기능을 확인해야 합니다. 영향을 받은 서버 이름이 Exchange Server Analyzer 오류 메시지에 나타납니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
참고:
ncacn_ip_tcp 값을 업데이트하기 전에 이 문서의 나머지 부분을 읽어 보십시오. Exchange Server 서비스를 다시 시작하여 발생되는 중단 시간을 최소화하려면 추가 절차를 수행한 다음 Exchange Server 서비스를 다시 시작해야 합니다.
networkAddress 특성의 ncacn_ip_tcp 값을 업데이트하려면 다음을 수행합니다.

  1. Windows 2000 Server 지원 도구 또는 Windows Server 2003 지원 도구에서 ADSI 편집 도구를 시작합니다.

  2. 다음 노드를 확장합니다.

    • 구성 컨테이너

    • 구성

    • 서비스

    • Microsoft Exchange

    • Organization_Name

    • 관리 그룹

    • Administrative_Group_Name

    • 서버

  3. Exchange_Server_Name을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 특성 목록에서 networkaddress를 클릭한 다음 편집을 클릭합니다.

  5. ncacn_ip_tcp에 대한 새 값을 추가합니다. 서버의 NetBIOS 이름 또는 호스트 이름 대신 서버의 FQDN을 사용합니다.

    이 값에 대한 구문은 ncacn_ip_tcp:FQDN입니다. 예를 들어 Exchange 백 엔드 서버의 호스트 이름이 EXCHANGE1이고 FQDN이 EXCHANGE1.contoso.com인 경우 ncacn_ip_tcp에 ncacn_ip_tcp:EXCHANGE1.contoso.com 값을 사용합니다.

  6. 변경 내용을 적용하려면 확인을 두 번 클릭합니다.

  7. 서버에서 Exchange Server 서비스를 다시 시작합니다.

  8. 도메인 컨트롤러가 여러 개인 경우 프런트 엔드 서버에서 로그온하기 전에 복제가 실행되기를 기다립니다. 복제가 완료된 후에도 문제가 해결되지 않으면 프런트 엔드 서버의 IIS Admin 서비스를 다시 시작합니다.

짧은 호스트 이름이 있는 서버 IP 주소를 연관시키기 위해 백 엔드 서버의 호스트 파일을 유지 관리할 경우 UpdateProtocols registry 레지스트리 값도 업데이트해야 합니다. 호스트 파일이 사용되는 경우 Microsoft Exchange System Attendant를 다시 시작할 때 Exchange Server는 ncacn_ip_tcp 값을 원래대로 변경할 수도 있습니다. 백 엔드 서버가 클러스터되면 장애 조치 후에 Exchange Server는 ncacn_ip_tcp 값을 원래대로 변경할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
호스트 파일을 사용하는 백 엔드 서버의 UpdateProtocols 레지스트리 값을 수정하려면 다음을 수행합니다.

  1. 레지스트리 편집기를 사용하여 백 엔드 서버에서 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols 레지스트리 값을 구성합니다.

    참고:
    UpdateProtocols 값이 없는 경우 만들어야 합니다. 이렇게 하려면 다음 단계를 수행합니다.

  2. 레지스트리 편집기를 열고 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\ 레지스트리 하위 키를 찾습니다.

    1. 매개 변수를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 다음 DWORD 값을 클릭합니다.

    2. UpdateProtocols를 입력한 다음 Enter 키를 누릅니다.

  3. UpdateProtocols을 마우스 오른쪽 단추를 클릭하고 수정을 클릭하고 값 데이터 필드에 0을 입력한 다음 확인을 클릭합니다.

  4. 네트워크에서 백 엔드 클러스터 노드의 호스트 파일을 사용하는 경우 다음과 같이 항목의 UpdateProtocols 순서를 수정합니다.

    FQDN에 대한 IP 주소

    NetBIOS에 대한 IP 주소

    대신:

    NetBIOS에 대한 IP 주소

    FQDN에 대한 IP 주소

  5. 서버에서 Exchange Server 서비스를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


네트워크 인터페이스 성능 모니터 개체를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Network Interface 성능 개체의 Bytes Total/sec 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. 카운터에서 올바른 데이터가 반환되지 않으면 Exchange Server Analyzer는 기본 메시지를 표시합니다.

다음과 같은 상황에서는 성능 데이터 수집 엔진에서 올바른 데이터가 반환되지 않습니다.

  • Network Interface 성능 개체를 사용하지 않습니다.

  • Network Interface 성능 모니터 개체가 없거나 손상되었습니다.

  • 성능 개체에 액세스할 수 있는 적절한 권한이 Exchange Server Analyzer에 없습니다.

맨 앞의 두 가지 상황은 확장 가능한 특정 카운터가 레지스트리를 손상시키거나 Microsoft WMI(Windows® Management Instrumentation) 기반 프로그램에서 레지스트리를 수정하는 경우에 발생할 수 있습니다. 해당 절차를 수행하기 전에 Exchange Server Analyzer에 적절한 권한이 있는지 확인합니다. Exchange Server Analyzer를 실행하는 데 필요한 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말을 참조하십시오. 도움말을 보려면 Exchange Server Analyzer를 열고 F1 키를 누르십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Network Interface 성능 개체를 사용하는지 확인합니다.

    1. Extensible Performance Counter List 도구(Exctrlst.exe)를 다운로드하고 설치합니다. Exctrlst.exe: Extensible Performance Counter List(http://go.microsoft.com/fwlink/?LinkId=34436)에서 Exctrlst.exe를 다운로드할 수 있습니다.

    2. Exctrlst.exe를 열고 Sort Order와 Service를 차례로 클릭합니다.

    3. 성능 개체가 보고하는 서비스를 찾아 Performance Counters Enabled 확인란이 선택되었는지 확인합니다.

      Performance Counters Enabled 확인란이 선택되지 않았으면 이 확인란을 선택한 다음 성능 카운터에 연결된 서비스를 다시 시작하여 성능 카운터가 작동하는지 확인합니다. 성능 카운터가 작동하지 않거나 Performance Counters Enabled 확인란이 이미 선택되어 있으면 2단계로 넘어갑니다.

  2. Microsoft 기술 자료 문서 300956, "성능 카운터 라이브러리 값을 수동으로 다시 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956)에 지정된 대로 누락되거나 손상된 성능 카운터를 다시 빌드합니다.

  3. 이 기술 자료 문서에 따라 수행해도 문제가 해결되지 않으면 Windows 운영 체제를 복구 모드로 다시 설치한 다음 최신 Windows 서비스 팩을 적용해야 합니다.


최신 버전의 MSGTRACK.dll을 사용할 수 있음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-10-05

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 프로세서 성능 개체의 여러 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

또한 Exchange Server Analyzer는 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Msgtrak.dll 파일의 Version 키 값을 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고 메시지를 표시합니다.

  • 서버의 CPU 사용량이 큽니다.

  • Msgtrak.dll 파일의 Version 키 값이 6.0.6373.0보다 이전 버전입니다.

이 경고는 확인된 Msgtrack.dll 버전으로 인해 CPU 사용량이 증가할 수 있음을 의미합니다. 또한 확인된 Msgtrack.dll 버전으로 인해 Inetinfo.exe 프로세스가 메모리를 매우 많이 사용하는 것으로도 나타납니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 811409, "XADM: 메시지 추적으로 인해 Inetinfo.exe 프로세스에서 매우 많은 메모리를 사용함"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=811409)에 나와 있는 업데이트를 설치하십시오.


최신 버전의 WLDAP32.DLL을 사용할 수 있음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-10-06

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 프로세서 성능 개체의 여러 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

또한 Exchange Server Analyzer는 Exchange Server 컴퓨터에서 실행 중인 Microsoft Windows® 버전을 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 4.0은 Exchange Server 컴퓨터에 Microsoft Windows NT® 4.0이 실행되고 있음을 나타냅니다. 값 5.0은 Exchange Server 컴퓨터에 Windows 2000 Server가 실행되고 있음을 나타내고 값 5.2는 Exchange Server 컴퓨터에 Windows Server™ 2003이 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Wldap32.dll 파일의 Version 키 값을 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고 메시지를 표시합니다.

  • Exchange Server Analyzer가 분석하고 있는 서버의 CPU 사용률이 높은 것을 감지했습니다.

  • Exchange Server 컴퓨터가 Windows 2000 Server에서 실행되고 있습니다.

  • Wldap32.dll 파일의 버전 키 값은 5.0.2195.7044보다 이전 버전임을 나타냅니다.

이 경고는 확인된 Wldap32.dll 버전으로 인해 Inetinfo.exe 프로세스가 Windows 2000 Server 시스템의 CPU를 100%까지 사용할 수 있음을 나타냅니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 899019, "Inetinfo.exe 프로세스가 Exchange 2000 Server를 실행 중인 Windows 2000 Server 컴퓨터의 CPU 리소스를 100%까지 사용할 수 있음"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=899019)에 나와 있는 업데이트를 설치하십시오.


NNTP 서비스가 활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 NNTP(Network News Transfer Protocol) 서비스(NntpSvc)에 대한 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 이 Exchange 서버에서 NNTP(Network News Transfer Protocol) 서비스가 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 IIS(인터넷 정보 서비스) 메타베이스의 다음 속성을 읽어 Exchange 서버에 맞게 NNTP 공급이 구성되어 있는지 확인합니다.

/LM/NNTPSVC/1/Feeds

Exchange Server Analyzer는 NNTP 서비스가 시작되었으나 해당 서버에 대해 공급이 구성되지 않은 경우 경고를 표시합니다.

리소스를 절약하고 보안을 강화하려면 사용되지 않는 구성 요소에 대한 서비스는 실행하지 않아야 합니다. 실행되는 각 서비스는 악의적인 사용자가 이용할 수 있는 기능을 노출합니다. 따라서 사용하고 있지 않은 서비스는 모두 비활성화하는 것이 좋습니다.

NNTP 서비스를 비활성화하려면 다음을 수행합니다.

  1. 시작, 프로그램을 차례로 클릭한 후 관리 도구를 클릭하고 서비스를 클릭합니다.

  2. NNTP(Network News Transfer Protocol) 서비스를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  3. 일반 탭에서 중지를 클릭합니다.

  4. 시작 유형에서 사용 안 함을 선택하고 확인을 클릭합니다.

Exchange Server 2003 보안 유지에 대한 자세한 내용은 Exchange Server 2003 보안 강화 가이드(http://go.microsoft.com/fwlink/?linkid=47578)를 참조하십시오.


테스트에 사용할 수 있는 DNS 서버가 없음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-12-05

Microsoft® Exchange Server Analyzer Tool은 Win32_NetworkAdapterConfiguration Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Exchange Server가 메시지 전송을 위해 실행되고 있는 원격 서버의 DNSServerSearchOrder 특성을 구합니다. 이 특성은 DNS(Domain Name System) 서버 쿼리에 사용되는 서버 IP 주소의 배열입니다.

Exchange Server Analyzer는 또한 Microsoft Active Directory® 디렉터리 서비스를 쿼리하여 Exchange 2000 Server 및 Exchange Server 2003 서버 개체에 대한 protocolCfgSMTPServer 클래스의 msExchSMTPExternalDNSServers 특성 값을 확인합니다. protocolCfgSMTPServer 클래스에는 SMTP(Simple Mail Transfer Protocol) 가상 서버의 설정이 포함되어 있습니다. msExchSMTPExternalDNSServers 특성이 설정되면 SMTP 가상 서버가 외부 DNS 서버를 사용합니다.

마지막으로 Exchange Server Analyzer는 다음 Exchange 관리 셸 cmdlet를 사용해 쿼리하여 모든 대상 Exchange 2007 전송 서버 역할의 ExternalDNSServers 및 InternalDNSServers 속성 값을 확인합니다. ExternalDNSServers 속성은 원격 도메인을 확인할 때 서버가 쿼리하게 되는 외부 DNS 서버 목록을 지정합니다. InternalDNSServers 속성은 대상 서버의 로컬 도메인 이름을 확인하는 데 사용하는 DNS 서버 목록을 지정합니다.

코드 복사
get-TransportServer -Identity %ExchangeServerName% -DomainController %DomainControllerName%

Exchange Server Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • Exchange Server Analyzer가 DNSServerSearchOrder 특성 값을 제대로 검색할 수 없습니다. 또는 특성에 데이터가 없습니다.

  • Exchange 2000 Server 및 Exchange Server 2003 서버 개체의 msExchSMTPExternalDNSServers 특성이 설정되어 있지 않습니다.

  • 대상 Exchange 2007 전송 서버 역할의 ExternalDNSServers 및 InternalDNSServers 속성 값에 데이터가 없습니다.

이 오류는 Exchange Server Analyzer가 대상 Exchange 서버에서 사용하는 모든 DNS 서버를 식별할 수 없음을 나타냅니다. 게다가 이런 상태는 메일 흐름에 나쁜 영향을 줄 수 있습니다.

이 상태는 다음과 같은 원인으로 발생할 수 있습니다.

  • DNS가 대상 서버에 잘못 구성되어 있습니다.

  • WMI가 실패했거나 액세스할 수 없습니다.

이 문제를 해결하려면 다음을 수행하십시오.

  • 대상 서버의 DNS 구성을 확인합니다.

  • Exchange WMI에 액세스할 수 있는지 확인합니다.

Exchange WMI에 액세스할 수 있는지 확인하려면 다음을 수행하십시오.

  1. Exchange 서버가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. PING 명령을 사용하여 Exchange 서버에 연결할 수 있는지 확인합니다.

  3. 방화벽이 있는 경우 RPC(원격 프로시저 호출) 포트가 차단되어 있는지 확인합니다.

  4. Exchange Server Analyzer를 실행하는 계정에 대한 사용 권한을 검토합니다. Exchange Server Analyzer를 실행하는 계정에는 검색 중인 각 Exchange 서버에 대한 로컬 관리자 권한이 있어야 합니다.

    또한 Exchange Server Analyzer를 실행하는 계정에 특정 WMI 사용 권한을 부여할 수 있습니다.

    1. Exchange 서버에서 컴퓨터 관리 MMC(Microsoft Management Console) 트리를 엽니다.

    2. 서비스 및 응용 프로그램에서 WMI 컨트롤을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

    3. WMI 컨트롤 속성 페이지에서 보안 탭을 클릭한 다음 루트를 확장합니다.

    4. CIMV2 폴더를 선택하고 보안을 클릭합니다.

    5. ROOT\CIMV2에 대한 보안 페이지에서 Exchange Server Analyzer를 실행하는 계정을 추가합니다.

  5. 4단계에서 추가한 계정을 선택합니다. Selected_Account의 사용 권한에서 허용 열 아래의 원격으로부터 사용 가능 및 보안 읽기를 모두 선택한 다음 확인을 클릭합니다.

Exchange Server에서 동작하도록 DNS를 구성하는 방법은 Microsoft 기술 자료 문서 322856, "HOWTO: Exchange Server 사용을 위한 DNS 구성"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322856)을 참조하십시오.

네트워크 연결 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

Exchange Server Analyzer 연결 문제에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?LinkId=56285)를 참조하십시오.

포트 요구 사항에 대한 자세한 내용은 기술 자료 문서 832017, "Windows 서버 시스템의 서비스 개요 및 네트워크 포트 요구 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)을 참조하십시오.


마스터 계정 SID가 없음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-02-14

Microsoft Exchange Analyzer Tool은 MSExchangeIS에 대한 이벤트 9548 경고가 최근 1시간 이내 기록되었는지 여부를 확인할 때 Win32_NTLogEvent Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다.

최근 1시간 이내 이벤트 9548 경고가 기록되면 Exchange Analyzer에서 해당 시간 동안 기록된 이벤트 9548 경고의 총 수를 계산합니다.

최근 1시간 이내 이벤트 9548 경고가 20번 이상 기록되면 Exchange Analyzer에서 경고를 표시합니다.

이 경고는 Exchange Server 사서함과 연결되어 있지만 올바른 msExchMasterAccountSID 특성이 없는 사용 안 함으로 설정된 Active Directory 디렉터리 서비스 사용자 계정이 있을 수 있음을 나타냅니다.

Microsoft Exchange Server 2003 또는 Exchange 2000 Server가 실행 중인 서버의 사서함은 Active Directory 디렉터리 서비스 사용자 계정에 연결되어 있어야만 사용할 수 있습니다. 이러한 연결은 사서함에 msExchMasterAccountSid Active Directory 특성을 설정하면 부분적으로 이루어집니다. Exchange 사서함에 연결할 Active Directory 계정은 사용 또는 사용 안 함 상태일 수 있습니다. 사용 안 함 상태의 계정에만 msExchMasterAccountSid 특성을 설정할 수 있습니다.

사용할 수 없는 사용자 계정의 msExchMasterAccountSid 특성 값이 비어 있거나 손상되었으며 해당 사용자 계정을 포함하는 ACL(액세스 제어 목록)이 작성된 경우 해당 ACL을 사용하여 사서함이나 공용 폴더 리소스에 액세스할 때 성능 문제가 발생할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  • Exchange Server 2003 서비스 팩 2(SP2)가 Microsoft 기술 자료 문서 916783, "A hotfix is available to change the way that Exchange Server 2003 SP2 handles a disabled Active Directory user account that is associated with an Exchange Server 2003 mailbox"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783)에서 설명하는 핫픽스와 함께 설치되었는지 확인합니다.

  • 이벤트 9548 경고에서 참조하는 ACL 및 사용자 계정을 검토하여 msExchMasterAccountSid 특성 값이 비어 있거나 손상되었는지 확인하고 필요한 경우 Microsoft 기술 자료 문서 328880, "Exchange 2000 및 Exchange 2003에서 ACL 변환과 관련된 공용 폴더 성능 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880)의 안내에 따라 해당 계정에 대해 유효한 msExchMasterAccountSID 특성 값을 생성합니다.

  • Microsoft 기술 자료 문서 278966, "Exchange 리소스 사서함으로 이동하거나 로그온할 수 없다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966)의 안내에 따라 ACL에서 사용할 수 없게 설정된 사용자 계정을 제거합니다.

자세한 정보

이 문제에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서 및 Exchange Server 리소스를 참조하십시오.

  • 이벤트 및 오류 메시지 센터: 이벤트 세부 정보: MSExchangeIS 사서함 저장소 이벤트 9548 세부 정보(http://go.microsoft.com/fwlink/?LinkId=83135)

  • Microsoft 기술 자료 문서 916783, "A hotfix is available to change the way that Exchange Server 2003 SP2 handles a disabled Active Directory user account that is associated with an Exchange Server 2003 mailbox"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783)

  • Microsoft 기술 자료 문서 328880, "Exchange 2000 및 Exchange 2003에서 ACL 변환과 관련된 공용 폴더 성능 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880)

  • Microsoft 기술 자료 문서 278966, "Exchange 리소스 사서함으로 이동하거나 로그온할 수 없다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966)


SMTP 인스턴스가 없음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-08-08

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에서 protocolCfgSMTPServer 개체 클래스의 distingushedName 특성을 쿼리하여 SMTP(Simple Mail Transfer Protocol) 가상 서버 인스턴스가 사용자 지정 Exchange 게이트웨이 서버 이름에 대해 실행되고 있는지 확인합니다.

사용자 지정 Exchange 게이트웨이 서버에 대한 SMTP 가상 서비스 인스턴스를 찾을 수 없는 경우 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 임시 네트워킹 문제 때문일 수 있지만 Active Directory의 잘못된 정보를 나타낼 수도 있습니다.

이 문제를 해결하려면 사용자 지정 Exchange 게이트웨이 서버에 대한 SMTP 가상 서버 구성을 검토합니다.

SMTP 가상 서버 인스턴스 구성을 보려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

    시작을 클릭하고 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭합니다.

  2. 다음 컨테이너를 탐색합니다.

    \Administrative Groups\GroupName\Servers\ServerName\Protocols\SMTP\SMTP Virtual Server Instance\

  3. 원하는 SMTP 가상 서버 인스턴스를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  4. SMTP 가상 서버 인스턴스 구성이 올바른지 확인합니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

SMTP 서비스 디자인에 대한 자세한 내용은 Exchange Server 2003 기술 참조 가이드(http://go.microsoft.com/fwlink/?LinkId=58876)의 "SMTP 서비스 디자인"을 참조하십시오.

네트워크 연결 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.


NSPI 대상 서버가 수동으로 다시 정의되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 NSPI 대상 서버(Name Service Provider Interface 대상 서버) 서비스가 수동으로 다시 정의되었는지 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\NSPI Target Server

Exchange Server Analyzer는 RFR Target Server가 구성되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

종류가 다른 클라이언트는 도메인 컨트롤러와 글로벌 카탈로그 서버를 다르게 사용하여 GAL(전체 주소 목록)에 액세스합니다. Microsoft® Office Outlook® 2000 Service SR-2(서비스 릴리스 2) 이전의 Exchange 클라이언트는 Exchange 서버에서 디렉터리 서비스를 찾을 수 있습니다. Exchange 2000 Server와 Exchange Server 2003은 클라이언트 대신 가장 가까운 글로벌 카탈로그 서버에 대한 연결을 설정할 때와 Outlook과 글로벌 카탈로그 서버 사이의 프록시 통신을 설정할 때 DSProxy(Directory Service Proxi) 메커니즘을 사용합니다. 사용 중인 배포 요구 사항에 따라 DSProxy 요청을 처리하는 데 사용해야 하는 특정 글로벌 카탈로그 서버를 명시적으로 지정할 수 있습니다. Exchange 서버에서 NSPI Target Server 레지스트리 항목을 하드 코드하여 특정 글로벌 카탈로그 서버를 명시적으로 지정할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

NSPI Server를 수동으로 지정하려면 다음을 수정합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. NSPI Target Server라는 새 REG_MULTISZ 값을 만듭니다.

  4. 지정하려는 서버의 정규화된 도메인 이름으로 NSPI Target Server 값을 구성합니다.

NSPI 서버에 대한 정적 설정을 사용하지 않으려면 제거하려는 서버에 대한 정규화된 도메인 이름(FQDN) 항목을 제거합니다. 입력된 NSPI 대상 서버가 하나만 있는 경우는 NSPI Target Server 레지스트리 값을 삭제합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Outlook 2000 SR-2 이상의 클라이언트가 Active Directory® 디렉터리 서비스와 상호 작용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 302914, "XCCC: Outlook 2000이 Active Directory에 액세스하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914)

  • 256976, "XCLN: MAPI 클라이언트가 Active Directory에 액세스하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976)


Exchange Server가 아닌 MAPI 하위 시스템이 설치되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 두 폴더에 있는 MAPI32.dll 버전을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

<drive>:\Program Files\Exchsrvr\Bin

%Systemroot%\System32

두 폴더의 MAPI32.dll 버전 및 복사본이 같지 않으면 오류가 표시됩니다.

단일 MAPI 버전을 사용하기 위해 Exchange Server 설치 프로그램은 <drive>:\Program Files\Exchsrvr\Bin 및 %Systemroot%\system32 디렉터리 모두에 MAPI32.dll을 복사합니다. Microsoft Office Outlook® 2003 또는 타사 응용 프로그램 같은 다른 MAPI 응용 프로그램이 Exchange Server 컴퓨터에 설치된 경우 다른 MAPI32.dll 버전을 System32 폴더에 복사할 수 있으므로 Exchange 기능이 중단될 수 있습니다. 이러한 문제는 두 제품의 버전이 MAPI 하위 시스템 충돌을 가져오기 때문에 발생합니다. 이러한 충돌은 Exchange Server 또는 다른 MAPI 응용 프로그램을 중단하지 않고는 완전하게 조정될 수 없습니다.

Outlook 2000 이상 버전과 Exchange Server 2003, Exchange 2000 Server 또는 Exchange Server 5.5를 같은 컴퓨터에 설치하는 것이 좋습니다.

Exchange Server와 동일한 컴퓨터에 Outlook을 설치하려는 일반적인 이유는 서버쪽 프로그램에서 특정 Outlook 구성 요소를 이용하기 위한 것입니다. 대부분의 프로그램 개발 요구 사항에 따라 Exchange 컴퓨터에는 Outlook이 필요하지 않습니다. Exchange Server에는 Outlook 개체 모델과 비슷한 기능을 제공할 수 있는 CDO(Collaboration Data Objects)가 포함되어 있습니다. CDO는 서버쪽에서 사용하도록 설계되었으며 이것은 Outlook의 최신 버전에 포함되었음을 의미하지 않습니다. 자세한 내용은 Microsoft 기술 자료 문서 290500, "OL2002: 전자 메일 보안 기능에 대한 개발자 정보"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=290500)를 참조하십시오.

또 다른 일반적인 이유는 MAPI 프로필을 만들라는 요구 사항입니다. Exchange Server는 MAPI 프로필을 만드는 데 필요한 모든 기능을 포함하므로 어떤 이유로든 Outlook을 필요로 하지 않습니다. Outlook을 설치하지 않고 MAPI 프로필을 만드는 방법에 대한 자세한 내용은 기술 자료 문서 306962, "HOWTO: Create MAPI Profiles Without Installing Outlook"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306962)을 참조하십시오.

Outlook 및 Exchange Server를 데모용으로 같은 컴퓨터에 설치해야 할 경우 데모용으로 테스트된 다음 구성 중 하나를 사용하는 것이 좋습니다.

  • Exchange 2000 Server에서 Outlook 2000 사용

  • Exchange 2000 Server에서 Outlook 2002 사용

이 오류를 수정하려면 다음을 수행합니다.

  1. Microsoft Outlook 또는 타사 MAPI 응용 프로그램을 Exchange 서버에서 제거합니다.

  2. Exchange Server 설치 프로그램을 다시 실행하고 다시 설치를 클릭합니다.

같은 컴퓨터에서 Microsoft Office Outlook 2003 및 Microsoft Exchange Server 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 266418, " XCCC: Microsoft Does Not Recommend Installing Exchange 2000 Server and Outlook 2000 or Later on the Same Computer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418)를 참조하십시오.

MAPI 충돌 해결에 대한 자세한 내용은 기술 자료 문서 229700, "HOWTO: Find the Correct Path to MAPISVC.INF Under Outlook 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=229700)을 참조하십시오.

MAPI32 스텁 라이브러리에 대한 자세한 내용은 MAPI(메시징 API)(http://go.microsoft.com/fwlink/?linkid=34395)를 참조하십시오.


Microsoft 제품이 아닌 ESE 엔진이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 확장 가능한 저장소 엔진(ESE)이라고도 하는 Exchange 데이터베이스 저장소 엔진(Ese.dll)의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스에 쿼리하여 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인합니다. 문자열 값에 "Version 5.5"가 나타나 있으면 해당 컴퓨터가 Microsoft Exchange Server 5.5를 실행 중입니다. 문자열 값에 "Version 6.0"이 있으면 해당 컴퓨터에 Microsoft Exchange Server 2000 Server가 실행 중입니다. 문자열 값에 "Version 6.5"가 나타나 있으면 해당 컴퓨터가 Microsoft Exchange Server 2003을 실행 중입니다.

Exchange Server Analyzer는 Version의 버전 정보에 6이 포함되어 있지 않지만 serialNumber의 값이 Exchange 2000 Server 또는 Exchange Server 2003이 설치되어 있음을 나타내는 경우 경고를 표시합니다. 이 경고는 Microsoft 제품이 아닌 버전의 Ese.dll이 설치되어 Exchange Server 컴퓨터에 사용되고 있음을 나타냅니다. 이 문제는 가능한 빨리 수정해야 합니다.

이 문제를 일으키는 원인 중 하나는 ESE 기반 바이러스 백신 소프트웨어의 사용입니다. 일부 ESE 기반 바이러스 백신 프로그램은 Exchange 정보 저장소와 ESE 간에 지원되지 않는 인터페이스를 사용합니다. 이러한 소프트웨어를 사용하는 경우 소프트웨어 구현에 오류가 있으면 데이터베이스가 손상되고 데이터가 손실될 위험이 있습니다.

설치하는 동안 ESE 기반 검색 프로그램은 Microsoft Exchange Information Store 서비스를 ESE 기반 바이러스 검색 프로그램의 서비스에 종속하도록 변경합니다. 이로써 Microsoft Exchange Information Store 서비스가 시작되기 전에 ESE 기반 바이러스 백신 프로그램의 서비스가 시작됩니다. ESE 기반 바이러스 검색 프로그램이 시작되면 Exchange Server에 포함된 Ese.dll의 이름이 임시로 Xese.dll로 바뀌고 ESE 기반 바이러스 검색 프로그램의 Ese.dll이 원래 파일을 대체합니다. ESE 기반 바이러스 검색 프로그램의 Ese.dll이 로드되면 Exchange Server에 포함된 파일 이름이 다시 Ese.dll로 바뀌고 Microsoft Exchange Information Store 서비스는 시작 프로세스를 완료합니다.

Exchange Server 컴퓨터에서 ESE를 구현할 때는 Microsoft 제품만 사용하는 것이 좋습니다. Microsoft 기술 지원 서비스에 문의하는 고객은 문제를 쉽게 확인할 수 있도록 ESE 기반 바이러스 검색 프로그램을 비활성화하도록 요청받을 수 있으나 문제의 근본 원인을 정확하게 진단한 후에는 다시 사용할 수 있습니다.

가장 일반적으로 사용되는 ESE 기반 바이러스 백신 프로그램은 Sybari Software의 Antigen for Microsoft Exchange입니다. Microsoft와 Sybari는 문제 해결 과정에서 Sybari Antigen을 중지하는 것이 문제의 원인을 찾아내는 유효한 하나의 단계라는 점에 동의했습니다. Sybari Software에 문의하려면 Sybari Software 웹 사이트( http://www.sybari.com)를 방문하십시오.

참고:
필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 제공됩니다. URL은 예고 없이 변경될 수 있습니다.

AVAPI(AntiVirus API)라고도 하는 VSAPI(Virus Scanning Application Programming Interface)를 지원하는 바이러스 백신 프로그램을 사용하는 것도 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터를 전체 백업합니다.

  2. Exchange Server를 컴퓨터에서 제거합니다.

  3. 컴퓨터에 Exchange Server를 다시 설치합니다.

  4. Exchange Server의 최신 서비스 팩과 업데이트를 적용합니다.

Exchange Server에서 바이러스 백신 소프트웨어를 실행하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)


Microsoft 제품이 아닌 확장 가능한 저장소 엔진이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 확장 가능한 저장소 엔진(ESE)이라고도 하는 Exchange 데이터베이스 저장소 엔진(Ese.dll)의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 5.5"가 나타나 있으면 해당 컴퓨터가 Microsoft Exchange Server 5.5를 실행 중입니다. 문자열 값에 "Version 6.0"이 있으면 해당 컴퓨터에 Microsoft Exchange 2000 Server가 실행 중입니다. 문자열 값에 "Version 6.5"가 나타나 있으면 해당 컴퓨터가 Microsoft Exchange Server 2003을 실행 중입니다.

Exchange Server Analyzer는 Version의 버전 정보 하위 문자열에 5.5가 포함되어 있지 않지만 serialNumber의 값이 Exchange Server 5.5가 설치되어 있음을 나타내는 경우 경고를 표시합니다. 이 경고는 Microsoft 제품이 아닌 버전의 Ese.dll이 설치되어 Exchange Server 컴퓨터에 사용되고 있음을 나타냅니다. 이 문제는 가능한 빨리 수정해야 합니다.

이 문제를 일으키는 원인 중 하나는 ESE 기반 바이러스 백신 소프트웨어의 사용입니다. 일부 ESE 기반 바이러스 백신 프로그램은 Exchange 정보 저장소와 ESE 간에 지원되지 않는 인터페이스를 사용합니다. 이러한 소프트웨어를 사용하는 경우 소프트웨어 구현에 오류가 있으면 데이터베이스가 손상되고 데이터가 손실될 위험이 있습니다.

설치하는 동안 ESE 기반 검색 프로그램은 Microsoft Exchange Information Store 서비스를 ESE 기반 바이러스 검색 프로그램의 서비스에 종속하도록 변경합니다. 이로써 Microsoft Exchange Information Store 서비스가 시작되기 전에 ESE 기반 바이러스 백신 프로그램의 서비스가 시작됩니다. ESE 기반 바이러스 검색 프로그램이 시작되면 Exchange Server에 포함된 Ese.dll의 이름이 임시로 Xese.dll로 바뀌고 ESE 기반 바이러스 검색 프로그램의 Ese.dll이 원래 파일을 대체합니다. ESE 기반 바이러스 검색 프로그램의 Ese.dll이 로드되면 Exchange Server에 포함된 파일 이름이 다시 Ese.dll로 바뀌고 Microsoft Exchange Information Store 서비스는 시작 프로세스를 완료합니다.

Exchange Server 컴퓨터에서 ESE를 구현할 때는 Microsoft 제품만 사용하는 것이 좋습니다. Microsoft 기술 지원 서비스에 문의하는 고객은 문제를 쉽게 확인할 수 있도록 ESE 기반 바이러스 검색 프로그램을 비활성화하도록 요청받을 수 있으나 문제의 근본 원인을 정확하게 진단한 후에는 다시 사용할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터를 전체 백업합니다.

  2. 컴퓨터에 Exchange Server를 다시 설치합니다.

  3. Microsoft Exchange Server 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21573)에서 구할 수 있는 Exchange Server용 최신 서비스 팩과 업데이트를 적용합니다.
  • Exchange Server에서 바이러스 백신 소프트웨어 실행에 대한 자세한 내용은 Microsoft 기술 자료 문서 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)를 참조하십시오.

  • 동일한 컴퓨터 이름을 사용하여 Exchange Server 5.5 컴퓨터를 다시 만드는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 155216, "XADM: Exchange Server를 동일한 이름의 새 컴퓨터로 이동하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=155216)을 참조하십시오.


비페이징 풀이 경고 임계값을 초과합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 PoolNonpagedBytes 키 값을 확인할 때 Win32_PerfRawData_PerfOS_Memory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer가 수행하는 작업은 기본 운영 체제, Windows Boot.ini 파일의 \3GB 스위치 존재 여부 및 이 키의 검색된 값에 따라 다릅니다.

다음 표에는 Exchange Server Analyzer에서 이 값이 지정된 Exchange 서버의 범위를 벗어나는지 여부를 확인하는 데 사용하는 평가 매트릭스가 나와 있습니다. 다음 표에 나와 있는 조건이 충족되면 경고가 표시됩니다.

운영 체제 | Boot.ini 설정 | 현재 비페이징 풀
Microsoft Windows 2000 Server 또는 Advanced Server | /3GB | 100MB 이상
Microsoft Windows 2000 Server 또는 Advanced Server | 없음 | 200MB 이상
Microsoft Windows Server™ 2003 | /3GB | 100MB 이상
Microsoft Windows Server 2003 | 없음 | 200MB 이상

PoolNonpagedBytes 키 값은 커널 메모리 비페이징 풀의 크기(바이트)입니다. 이것은 개체의 실제 시스템 메모리 영역으로 사용되고 있지 않을 때도 디스크에 기록할 수 없습니다. 이 키에 대한 값은 가장 최근에 관찰된 값입니다. 정상 Exchange 서버에서도 백업 또는 복원이 발생하지 않는 한 사용되고 있는 비페이징 풀 메모리가 85MB를 초과하지 않아야 합니다.

Windows 2000 Server와 Windows 2000 Advanced Server의 최대 비페이징 풀 메모리 값은 256MB입니다. 비페이징 풀 메모리 한도를 위에 나와 있는 숫자 이상으로 늘릴 수 없으므로 이러한 상태가 발생하면 가능한 빨리 수정해야 합니다. 사용 중인 운영 체제나 /3GB 스위치의 존재 여부와 관계없이 그 정도 크기의 비페이징 풀 메모리만 Windows에서 액세스할 수 있습니다. Windows에서 커널 메모리가 부족하면 오류 메시지가 나타나고 시스템이 손상될 수 있습니다. 시스템의 올바른 작동을 위해서는 커널 메모리가 반드시 필요하므로 주의 깊게 커널 메모리를 모니터링해야 합니다.

Exchange Server를 다시 시작해도 이러한 문제가 지속되면 시스템이 올바르게 조정되어 있고 이 시스템에 있는 소프트웨어와 하드웨어가 모두 최신 버전인지 확인합니다. 다음 항목의 최신 버전을 설치해야 합니다.

  • Windows 운영 체제 서비스 팩

  • Exchange Server 서비스 팩

  • 하드웨어 펌웨어 및 드라이버

  • 시스템 BIOS 업데이트

  • 설치되어 있고 실행 중인 모든 타사 응용 프로그램의 업데이트

소프트웨어와 하드웨어를 업데이트해도 이 문제가 해결되지 않으면 타사 소프트웨어를 사용할 수 없게 설정하고 Exchange Server 컴퓨터를 다시 시작한 후 커널 메모리를 모니터링해야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 가능한 한 빨리 Exchange Server 컴퓨터를 다시 시작합니다.

  2. Memory | Pool Nonpaged Bytes 성능 카운터를 모니터링하여 앞에 나와 있는 시스템 임계값을 초과하지 않는지 확인합니다.

Exchange Server를 올바르게 조정하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서와 백서를 참조하십시오.

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 266096, "XGEN: 1GB 이상의 실제(Physical) RAM을 가진 Exchange 2000 서버에서 /3GB 스위치가 필요하다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • "Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Troubleshooting Exchange 2000 Server Performance"(http://go.microsoft.com/fwlink/?LinkId=18177)

  • "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)

비페이징 풀 메모리와 관련 항목에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 294418, "Comparison of 32-Bit and 64-Bit Architecture"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=294418)

  • 177415, "메모리 풀 모니터(Poolmon.exe)를 사용하여 커널 모드 메모리 누수 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=177415)

  • 268343, "Umdhtools.exe: Umdh.exe를 사용하여 메모리 누수를 찾는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268343)


사용 가능한 페이지 테이블 항목의 수가 적어 시스템 불안정이 발생할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

The Microsoft® Exchange Server Analyzer Tool은 SystemPages 레지스트리 값의 설정을 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Exchange Server Analyzer는 SystemPages의 값이 0으로 설정되어 있고 사용 가능 PTE(Page Table Entry)의 개수가 3001개 미만인 경우 경고를 표시합니다.

Microsoft Windows Server™ 2003 및 Windows® 2000 Server는 설치된 실제 RAM의 크기에 관계없이 4GB의 메모리 주소 공간에 주소를 직접 지정할 수 있습니다. 프로세스 측면에서 볼 때 가상 주소의 각 요소는 개념적으로 실제 메모리의 바이트를 말합니다. VMM(Virtual Memory Manager)은 프로세서 MMU(Memory Management Unit)와 함께 각 가상 주소를 해당 실제 주소로 변환하거나 매핑합니다. VMM은 RAM을 고정 크기의 페이지 프레임으로 분할하고 이러한 페이지 프레임에 대한 정보를 저장할 시스템 PTE를 만든 다음 매핑합니다. 시스템 PTE는 디스크 I/O 하위 시스템 및 네트워크와 통신하는 데 사용되는 메모리의 소형 커널 모드 버퍼입니다. 각 PTE는 페이지 프레임을 나타내며 VMM이 페이지를 찾는 데 필요한 정보를 포함합니다.

4KB 페이지 크기를 사용하는 x86 기반 시스템에서 2GB의 주소 공간을 매핑하는 데에는 최대 524,288(2GB/4KB)개의 PTE가 필요합니다. /3GB 스위치를 사용하는 비슷한 시스템의 경우 3GB의 주소 공간을 매핑하는 데에는 786,432(3GB/4KB)개의 PTE가 필요합니다. 일반적인 시스템에서 이 공간은 다음과 같이 사용됩니다.

  • 최대 50,000개의 PTE(약 195MB의 주소 공간)가 일반적인 용도로 예약됩니다.

  • 나머지 PTE는 시스템 캐시, 하이퍼스페이스, 페이징 풀, 비페이징 풀, 크래시 덤프 영역 등을 매핑하는 데 사용됩니다.

이 PTE 풀 크기는 시스템의 실제 메모리 양을 바탕으로 시스템 시작 시 자동으로 결정됩니다. 이 풀은 페이징 풀과 비페이징 풀 사이에서 압축되어 있으며 시스템의 실제 메모리 용량에 따라 늘어날 수 있습니다.

시스템 PTE 풀은 과다하게 사용 및 조각화될 수 있습니다. 이로 인해 드라이버가 로드되지 못할 수 있습니다. 시스템 PTE 풀이 완전히 고갈되면 시스템의 다른 부분에 대한 성능도 저하되므로 스레드가 생성되지 않으며 시스템이 중단되고 잠재적으로 시스템이 손상될 수 있습니다.

정상적인 Exchange 서버 컴퓨터의 경우 항상 최소 5,000개의 시스템 PTE를 사용할 수 있어야 합니다. 사용 가능한 시스템 PTE 수가 5,000개 아래로 떨어져도 3,001개보다 많으면 사용할 수 있는 페이지 테이블 항목(PTE) 수가 경고 임계값에 도달했습니다.에 설명된 경고가 표시됩니다. 사용 가능한 시스템 PTE 수가 3,001개 아래로 떨어지면 이 오류가 표시됩니다. 아래 절차에 따라 Exchange Server 컴퓨터의 운영 체제에 적합한 SystemPages 레지스트리 값을 구성하여 이 문제를 해결할 수 있습니다. 1GB 이상의 RAM이 있는 Windows Server 2003 시스템에서 Exchange Server 2003 서비스 팩 1(SP1)을 실행할 경우 SystemPages 레지스트리 키를 0으로 설정하는 것이 좋습니다. 이와 달리 Windows 2000 Server에서는 SystemPages 키를 24,000에서 31,000 사이의 값으로 설정하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

아래 설명한 절차를 수행한 후에 사용 가능한 시스템 PTE의 수를 모니터링해야 합니다. 이것을 수행하려면 성능 모니터라고도 하는 Windows 시스템 모니터를 사용하여 Memory | Free System Page Table Entries 성능 카운터를 모니터링합니다. 아래 설명한 대로 레지스트리를 변경한 후에도 사용 가능한 시스템 PTE의 수가 부족하면 다음을 확인하여 Exchange Server 컴퓨터 구성이 최적화되었는지 확인해야 합니다.

  • 드라이버 일반적으로 드라이버가 제대로 작동하지 않으면 시스템 PTE 수가 부족하게 됩니다. 제조업체에 문의하여 모든 하드웨어에 대해 최신 드라이버를 사용하고 있는지 확인합니다. 기본 드라이버로 다운그레이드할 수도 있습니다. 예를 들어 Exchange Server 같은 서버 기반의 응용 프로그램을 실행하는 컴퓨터는 일반적으로 모든 기능이 제공되는 최고급 비디오 드라이버를 필요로 하지 않습니다. 기본 드라이버만으로도 충분한 경우가 많습니다. 고급 비디오 드라이버에서 기본 비디오 드라이버로 전환하면 사용 가능한 시스템 PTE의 수가 증가합니다.

  • 시스템 구성 시스템에 1GB 이상의 실제 메모리가 설치되어 있는 경우 다음 Microsoft 기술 자료 문서에 설명되어 있는 것처럼 해당 Boot.ini 파일이 /3GB 및 /USERVA=3030 스위치로 제대로 구성되어 있는지 확인해야 합니다.

    • 823440, "Windows Server 2003 기반 시스템에 Exchange Server 2003을 설치한 경우 /3GB 스위치를 사용해야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

    • "XADM: Windows 2003 Server 기반 Exchange Server에서 /Userva 스위치 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)

  • 이벤트 로그Exchange Server의 응용 프로그램 이벤트 로그에서 오류 및 경고를 확인합니다. 특히 MSExchangeIS 이벤트 9582(오류 및 경고), 9665(경고) 및 12880(오류)이 표시되는지 확인합니다. 이벤트 9665가 표시되면 SystemPages가 최적의 성능으로 구성되어 있지 않은 것입니다. 이러한 이벤트에 대한 자세한 내용은 기술 자료 문서 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)을 참조하십시오.

Windows 2000 Server에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management를 탐색합니다.

  3. 오른쪽 창에서 SystemPages를 두 번 클릭합니다.

  4. 값 데이터 필드에 24000-31000(10진수) 사이의 값을 입력하고 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

Windows Server 2003에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management를 탐색합니다.

  3. 오른쪽 창에서 SystemPages를 두 번 클릭합니다.

  4. 값 데이터 필드에 0을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server의 메모리 최적화에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, "The effects of 4GT tuning on system Page Table Entries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


현재 바이러스 검색을 대기하고 있는 진행 중인 호출 수가 한계에 거의 도달했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-13

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Information Store 서비스(Store.exe)에서 VAPI(Virus API) 구성 요소에 대해 진행 중인 현재의 상호 구성 요소 호출 수를 결정하기 위해 FCL(Exchange Function Call Log), Store.fcl 파일을 검사합니다.

Exchange Server Analyzer는 또한 다음 레지스트리 항목에서 ScanningThreads 키를 쿼리하여 VAPI 구성 요소 호출에 허용되는 최대 스레드 수를 결정합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

진행 중인 호출이란 Exchange FCL 데이터를 Store.fcl 파일에 기록하는 순간에 응답을 받지 못한 다른 구성 요소에게 Microsoft Exchange Information Store 서비스(Store.exe)에서 보내는 요청입니다.

Exchange Server Analyzer가 Exchange Information Store 서비스(Store.exe)에서 VAPI 구성 요소에 대해 진행 중인 호출 수가 허용되는 최대 스레드 수에 도달했음을 발견한 경우 Exchange Server Analyzer는 오류를 표시합니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

Microsoft Exchange Information Store 서비스에서 VAPI 구성 요소에 대해 진행 중인 호출은 다음과 같은 조건에서 발생할 수 있습니다.

  • 정보 저장소에 있는 항목을 재검색하는 바이러스 스캐너로 업데이트합니다.

  • 잘못 구성된 바이러스 스캐너

  • 바이러스 스캐너 소프트웨어가 대용량 메시지 또는 첨부 파일을 처리합니다.

이 오류를 해결하려면 다음 단계를 수행합니다.

  • 리소스 소모가 낮을 때, 즉, 사용량이 많지 않은 시간대에 바이러스 엔진의 업데이트를 예약합니다.

  • 바이러스 검색 소프트웨어를 재설치하는 것을 검토하여 사용량이 많지 않은 시간대에 재설치합니다.

  • 바이러스 검색 엔진의 스레드 구성, 파일 수준 제외 등이 올바른지 검사합니다. Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)를 참조하십시오.

  • 바이러스 검색 API에 대한 스레드 개수를 다음과 같이 늘립니다.

    ScanningThreads의 최적값은 (2 * NumberOfProcessors) + 1과 같습니다. 예를 들면 프로세서가 2개인 Exchange 서버를 실행하는 서버에서 ScanningThreads의 최적값은 5입니다.

    참고:
    하이퍼 스레딩을 사용할 수 있는 경우 NumberOfProcessors 의 값은 실제 프로세서 수의 두 배가 됩니다. 위 공식에서 실제 또는 논리 프로세서가 사용되는지를 결정하려면 바이러스 백신 소프트웨어 제조업체에 문의하는 것이 좋습니다.
중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
스레드 개수를 늘리는 방법

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan을 탐색합니다.

  3. 오른쪽 창에서 ScanningThreads를 두 번 클릭합니다.

  4. 이전 공식에서 반환된 값을 입력합니다.

  5. 레지스트리 편집기를 닫은 다음 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

Microsoft Exchange Server 2003에서 일반적으로 사용되는 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 823166, "XADM: Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)를 참조하십시오.

Microsoft Exchange 2000 Server에서 일반적으로 사용되는 바이러스 검색 프로그램에 대한 자세한 내용은 기술 자료 문서 328841, "Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)를 참조하십시오.

Exchange 서버 성능에 대한 자세한 내용은 "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

Exchange 서버 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)을 참조하십시오.

정보 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.

하이퍼 스레딩 기술에 대한 자세한 내용은 Intel 웹 사이트(http://www.intel.com/technology/hyperthread)를 참조하십시오.

참고:
이 항목에 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 들어 있습니다. URL은 예고 없이 변경될 수 있습니다.


OABGEN.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


Exchange Server 5.0의 최신 서비스 팩/업데이트 롤업 구하기
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer는 각 Exchange 서버 개체의 versionNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. versionNumber 특성은 해당 컴퓨터에서 실행 중인 Exchange Server의 버전을 나타냅니다.

Exchange Server Analyzer는 STORE.EXE 프로세스의 Version 키 값을 확인할 때도 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 STORE.EXE의 Version 키에 1460보다 크거나 같고 1462보다 작은 값이 있으면 경고를 표시합니다.

이 경고는 Exchange Server 컴퓨터가 해당 컴퓨터에서 실행 중인 Exchange 버전에 사용할 수 있는 최신 코드를 실행하고 있지 않음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Microsoft 다운로드 센터(http://go.microsoft.com/fwlink/?LinkId=41361)를 방문하여 Exchange Server 5.0의 최신 업데이트(2004년 4월)를 다운로드합니다.

  2. 이 업데이트에 대한 내용을 검토하려면 Microsoft 기술 자료 문서 834130, "Microsoft Exchange Server 5.0 Update Rollup"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130)을 참조하십시오.

  3. Exchange Server 컴퓨터를 전체 백업합니다.

  4. 2004년 4월 업데이트를 적용합니다.

Exchange Server 5.0 서비스 팩 2에 대한 최신 업데이트 롤업을 얻으려면 기술 자료 문서 168858, "XGEN: How to Obtain Exchange Server 5.0 U.S. Service Pack 2"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858)를 참조하십시오.

이 Exchange Server 업데이트와 다른 Exchange Server 업데이트의 설치에 대한 자세한 내용은 기술 자료 문서 328839, "HOWTO: Exchange 서비스 팩 및 핫픽스 적용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)을 참조하십시오.


Exchange Server 5.5의 최신 서비스 팩/업데이트 롤업 구하기
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer는 각 Exchange 서버 개체의 versionNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. versionNumber 특성은 해당 컴퓨터에서 실행 중인 Exchange Server의 버전을 나타냅니다.

Exchange Server Analyzer는 STORE.EXE 프로세스의 Version 키 값을 확인할 때도 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 STORE.EXE의 Version 키 값이 2653보다 크고 2658보다 작을 때 경고를 표시합니다. 이것은 컴퓨터에서 핫픽스가 설치된 Exchange Server 서비스 팩 4 또는 Exchange Server 5.5 서비스 팩 4를 실행하고 있음을 나타냅니다.

이 경고는 Exchange Server 컴퓨터가 해당 컴퓨터에서 실행 중인 Exchange 버전에 사용할 수 있는 최신 코드를 실행하고 있지 않음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 5.5의 최신 업데이트(2004년 5월)를 다운로드하려면 "Microsoft 다운로드 센터"(http://go.microsoft.com/fwlink/?LinkId=33456)를 방문하십시오.

  2. Microsoft 기술 자료 문서 841765, "November 2004 Update Rollup for Exchange Server 5.5"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765)를 참조하여 이 업데이트에 대한 정보를 검토하십시오.

  3. Exchange Server 컴퓨터를 전체 백업합니다.

  4. 2004년 5월 업데이트를 적용합니다.

이 Exchange Server 업데이트와 다른 Exchange Server 업데이트의 설치에 대한 자세한 내용은 Microsoft 기술 자료 문서 328839, "HOWTO: Exchange 서비스 팩 및 핫픽스 적용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)을 참조하십시오.


Exchange Server 2003의 최신 서비스 팩/업데이트 롤업 구하기
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer는 각 Exchange 서버 개체의 versionNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. versionNumber 특성은 해당 컴퓨터에서 실행 중인 Exchange Server의 버전을 나타냅니다.

Exchange Server Analyzer는 STORE.EXE 프로세스의 Version 키 값을 확인할 때도 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Version 키 값 7638은 Exchange Server 2003 서비스 팩 2를 나타냅니다.

  • Version 키 값 7226은 Exchange Server 2003 서비스 팩 1을 나타냅니다.

  • Version 키 값 6944는 Exchange Server 2003의 원본 릴리스를 나타냅니다.

  • 위의 버전 간의 값은 서버가 Store.exe 프로세스의 핫픽스 업데이트 버전을 실행하고 있음을 나타냅니다.

Exchange Server Analyzer는 STORE.EXE의 Version 키 값이 7638보다 작을 경우 경고를 표시합니다.

이 경고는 Exchange Server 컴퓨터가 해당 컴퓨터에서 실행 중인 Exchange Server 버전에 사용할 수 있는 최신 코드를 실행하고 있지 않음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. "Service Pack 2 for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=54751)에서 Exchange Server 2003용 서비스 팩 2를 다운로드하거나 주문합니다.

  2. Exchange Server 2003 서비스 팩 2(SP1) 릴리즈 정보 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=52072)에서 서비스 팩 2 릴리즈 정보를 검토합니다.

  3. Exchange Server 컴퓨터를 전체 백업합니다.

  4. Exchange Server 2003 서비스 팩 2를 적용합니다.

이 Exchange Server 업데이트와 다른 Exchange Server 업데이트의 설치에 대한 자세한 내용은 Microsoft 기술 자료 문서 328839, "HOWTO: Exchange 서비스 팩 및 핫픽스 적용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)을 참조하십시오.


Exchange 2000 Server의 최신 서비스 팩/업데이트 롤업 구하기
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer는 각 Exchange 서버 개체의 versionNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. versionNumber 특성은 해당 컴퓨터에서 실행 중인 Exchange Server의 버전을 나타냅니다.

Exchange Server Analyzer는 STORE.EXE 프로세스의 Version 키 값을 확인할 때도 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 STORE.EXE의 Version 키 값이 다음 범위에 속할 경우 경고를 표시합니다.

  • 6249보다 크고 6396보다 작거나 같음

  • 6396보다 크고 6487보다 작거나 같음

  • 6487보다 크고 6556보다 작거나 같음

  • 6556보다 크고 6603보다 작거나 같음

  • 6603보다 크고 6700보다 작음

이 경고는 Exchange Server 컴퓨터가 해당 컴퓨터에서 실행 중인 Exchange 버전에 사용할 수 있는 최신 코드를 실행하고 있지 않음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 최신 업데이트(2004년 8월)는 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)에서 다운로드합니다.

  2. 최신 업데이트에 대한 정보는 Microsoft 기술 자료 문서 870540, "Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540)을 검토하십시오.

  3. Exchange Server 컴퓨터를 전체 백업합니다.

  4. 2004년 8월자 업데이트를 적용합니다.

이 Exchange Server 업데이트와 다른 Exchange Server 업데이트의 설치에 대한 자세한 내용은 기술 자료 문서 328839, "HOWTO: Exchange 서비스 팩 및 핫픽스 적용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)을 참조하십시오.


오프라인 주소록 서버가 삭제되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-12-03

Microsoft® Exchange Server Analyzer Tool은 오프라인 주소록 구성 개체의 offLineABServer 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 offLineABServer 특성 값에 DEL: 문자열이 들어 있는 경우 오류를 표시합니다.

offLineABServer 특성은 오프라인 주소록 생성을 담당하는 Exchange Server 컴퓨터의 고유 이름을 저장하는 단일값 고유 이름 특성입니다. 각 오프라인 주소록에 대해 Exchange는 지정된 서버에 있는 일련의 공용 폴더에 오프라인 주소록 파일을 생성 및 저장합니다. 이 오류는 오프라인 주소록 구성 개체의 offLineABServer 특성에 지정된 서버가 없음을 나타냅니다. 이전 오프라인 주소록 서버의 서비스가 해제되었거나 토폴로지에서 잘못 제거된 경우 이 상황이 발생할 수 있습니다. 새 서버를 지정할 때까지 Exchange에서는 오프라인 주소록이 생성되지 않습니다.

Exchange 2000 Server 및 Exchange Server 2003에서 이 오류를 해결하려면 다음을 수행하십시오.

  1. Exchange System Manager의 받는 사람에서 오프라인 주소록을 클릭합니다. 오른쪽 창에서 기본 오프라인 주소록(또는 이 메시지를 생성하는 다른 오프라인 주소록)을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭의 오프라인 주소록 서버에서 찾아보기를 클릭한 다음 사용할 서버를 클릭합니다.

Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행하십시오.

  1. Exchange 관리 콘솔을 엽니다.

  2. Microsoft Exchange와 조직 구성을 차례로 확장한 다음 사서함을 선택합니다.

  3. 결과 창에서 오프라인 주소록 탭을 클릭합니다.

  4. 오프라인 주소록 탭에서 "기본 오프라인 주소록"을 선택합니다. 작업 창에서 이동을 클릭하여 오프라인 주소록 이동 마법사를 시작합니다. 이 마법사를 통해 OAB 생성을 다른 서버로 이동할 수 있습니다. 또한 기존 OAB 파일을 지정된 서버에 복사할 수도 있습니다.

Exchange 관리 셸을 사용하여 오프라인 주소록 생성을 호스팅할 서버를 설정하려면 다음을 수행하십시오.

  • 다음 명령을 실행합니다.

    코드 복사
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    여기서 <OAB>는 OAB의 DN(고유 이름), 도메인\계정 이름 또는 GUID이며 <Server>는 선택한 작업이 수행될 Exchange 서버를 지정합니다.

    예를 들어 OAB 생성을 SERVER01.로 이동하려면 다음과 같이 입력합니다.
코드 복사
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Exchange Server 2003에서의 오프라인 주소록 작업에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 오프라인 주소록 구성"을 참조하십시오.

Exchange Server 2007에서의 오프라인 주소록 작업에 대한 자세한 내용은 "조직 구성 > 사서함 > 오프라인 주소록"(http://go.microsoft.com/fwlink/?LinkId=79247)을 참조하십시오.


프런트 엔드 서버에서 오프라인 주소록 서버를 실행하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 오프라인 주소록 구성 개체의 offLineABServer 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. offLineABServer 특성은 오프라인 주소록 생성을 담당하는 Exchange Server 컴퓨터의 고유 이름을 저장하는 단일값 고유 이름 특성입니다.

또한 Exchange Server Analyzer는 Exchange 서버의 IsFrontEndServer 키 값을 확인할 때 Exchange_Server Microsoft WMI(Windows® Management Instrumentation)를 쿼리합니다. IsFrontEndServer 키 값이 True이면 Exchange 서버는 프런트 엔드 서버로 작동합니다.

Exchange Server Analyzer는 지정된 오프라인 주소록 서버가 프런트 엔트 서버이기도 함을 확인하면 오류 메시지를 표시합니다.

이 오류는 오프라인 주소록 생성을 위해 지정한 Exchange 서버가 프런트 엔드 서버임을 나타냅니다. 지정된 오프라인 주소록 서버가 프런트 엔드 서버이기도 하면 오프라인 주소록 생성에 실패합니다. 이 작업에 대해서는 새 서버를 지정해야 합니다. Microsoft Exchange 2000 Server 서비스 팩 2 이상을 실행 중인 서버를 프런트 엔드 서버로 지정하면 다음 서비스가 더 이상 실행되지 않습니다.

  • DSProxy

  • 오프라인 주소 목록 생성

  • 받는 사람 업데이트 서비스

  • 약속 있음/없음 작업

  • 사서함 정리 에이전트

  • Exchange Event Service

  • SRS(사이트 복제 서비스)

프런트 엔드 서버는 RPC over HTTP를 사용하도록 구성된 Outlook 클라이언트, Microsoft Office Outlook® Web Access, POP3, IMAP4, Exchange ActiveSync 및 Outlook Mobile Access에서 들어오는 클라이언트 요청을 처리하는 데 사용됩니다. 또한 프런트 엔드 서버가 SMTP 메시지를 내부 Exchange 서버에 릴레이하는 데 사용되는 경우도 있습니다.

이 문제를 해결하려면 백엔드 Exchange 서버를 오프라인 주소록 서버로 지정하는 것이 좋습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람 아래에서 오프라인 주소 목록을 클릭합니다.

  3. 오른쪽 창에서 기본 오프라인 주소 목록을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

    참고:
    이 메시지를 생성하는 다른 모든 오프라인 주소 목록에 같은 절차를 사용합니다.

  4. 일반 탭의 오프라인 주소 목록 서버에서 찾아보기, 사용할 백 엔드 Exchange 서버를 차례로 클릭합니다.

오프라인 주소록 작업에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 오프라인 주소록 구성"을 참조하십시오.


오프라인 주소록 사이트 공용 폴더가 삭제되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-12-03

Microsoft® Exchange Server Analyzer Tool은 각 공용 폴더 저장소 개체의 siteFolderServer 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 siteFolderServer 특성 값에 DEL: 문자열이 들어 있는 경우 오류를 표시합니다.

siteFolderServer 특성은 오프라인 주소록 서버로 사용되는 공용 폴더 저장소를 나타냅니다. 기본적으로 Exchange Server는 관리 그룹에 설치된 첫 번째 서버인 Site Folder Server에 오프라인 주소록 파일을 생성합니다. 다른 서버를 오프라인 주소록 서버로 지정한 경우 관리 그룹의 실제 Site Folder Server의 저장소가 아니라 이 특성에 나열된 공용 폴더 저장소가 새 오프라인 주소록 서버의 저장소가 됩니다.

Exchange Server 2003은 오프라인 주소록 파일을 생성할 때 이 파일을 메일 메시지에 첨부한 다음 해당 메시지를 특별한 공용 폴더에 저장합니다. Microsoft Office Outlook® 2003은 해당 폴더에서 이 메시지를 검색하여 첨부 파일을 다운로드합니다.

오프라인 주소록 메시지는 기본 공용 폴더 트리에 있는 시스템 폴더 중 하나인 오프라인 주소록 폴더의 하위 폴더에 저장됩니다. 이 폴더에는 토폴로지의 각 관리 그룹 또는 사이트에 사용되는 하위 폴더가 포함되어 있습니다. 기본적으로 특정 관리 그룹 폴더의 콘텐츠 복제본은 관리 그룹에 설치된 첫 번째 서버인 Site Folder Server에 저장됩니다.

Exchange 조직이 Exchange Server 2007이며, 하위 단계(Outlook 2003 이전 버전) 클라이언트가 없는 경우 이 경고나 오류를 무시할 수 있습니다. Outlook 2003 이전 버전을 실행 중인 클라이언트를 Exchange Server 2007 조직이 호스팅하는 경우, 다음 절차를 수행하여 오프라인 주소록 파일의 공용 폴더 배포를 사용합니다. 공용 폴더 배포란 오프라인으로 작업하거나 전화 접속 연결을 통해 Outlook 2003 이전 버전을 실행하고 있는 클라이언트가 OAB를 액세스하는 배포 방식입니다.

이 오류를 해결하려면 다음을 수행하십시오.

  1. Site Folder Server가 있는 경우 Exchange System Manager의 서버에서 서버, 저장소 그룹을 차례로 확장한 다음 공용 폴더 저장소를 클릭합니다. 오른쪽 창에서 Exchange 저장소가 실행되고 있는지 확인합니다.

  2. 새 오프라인 주소록 서버를 지정하려면 받는 사람에서 오프라인 주소록을 클릭합니다. 그런 다음 오른쪽 창에서 기본 오프라인 주소록 또는 이 메시지를 생성하는 다른 오프라인 주소록을 클릭합니다.

    오프라인 주소록을 사용하지 않으려면 기본 오프라인 주소록을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭합니다. 그렇지 않은 경우 이 절차의 나머지 부분을 수행하여 일정을 설정합니다.

  3. 기본 오프라인 주소록을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 일반 탭의 오프라인 주소록 서버에서 찾아보기를 클릭하여 서버를 선택합니다.

Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행하십시오.

  1. Exchange 관리 콘솔을 엽니다.

  2. Microsoft Exchange와 조직 구성을 차례로 확장한 다음 사서함을 선택합니다.

  3. 결과 창에서 오프라인 주소록 탭을 클릭합니다.

  4. 오프라인 주소록 탭에서 "기본 오프라인 주소록"을 선택합니다.

    1. 오프라인 주소록의 공용 폴더 배포를 사용하려면 배포 탭에서 공용 폴더 배포 사용을 선택합니다.

    2. 변경 내용을 저장하려면 확인을 클릭합니다.

  5. 새로운 오프라인 주소록 서버를 지정하려면 작업 창에서 이동을 클릭하여 오프라인 주소록 이동 마법사를 시작합니다. 이 마법사를 통해 OAB 생성을 다른 서버로 이동할 수 있습니다. 또한 기존 OAB 파일을 지정된 서버에 복사할 수도 있습니다.

Exchange 관리 셸을 사용하여 오프라인 주소록 파일의 공용 폴더 배포를 지정하려면 다음을 수행하십시오.

  • 다음 명령을 실행합니다.

    코드 복사
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    여기서 <OAB>는 OAB의 DN(고유 이름), 도메인\계정 이름 또는 GUID입니다.

    예를 들어 기본 오프라인 주소록의 공용 폴더 배포를 사용하려면 다음과 같이 입력합니다.
코드 복사
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

Exchange 관리 셸을 사용하여 오프라인 주소록 생성을 호스팅할 서버를 설정하려면 다음을 수행하십시오.

  • 다음 명령을 실행합니다.

    코드 복사
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    여기서 <OAB>는 OAB의 DN(고유 이름), 도메인\계정 이름 또는 GUID이며 <Server>는 선택한 작업이 수행될 Exchange 서버를 지정합니다.

    예를 들어 OAB 생성을 SERVER01.로 이동하려면 다음과 같이 입력합니다.
코드 복사
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Exchange Server 2003에서의 오프라인 주소록 작업에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 오프라인 주소록 구성"을 참조하십시오.

Exchange Server 2007에서의 오프라인 주소록 작업에 대한 자세한 내용은 "조직 구성 > 사서함 > 오프라인 주소록"(http://go.microsoft.com/fwlink/?LinkId=79247)을 참조하십시오.


오래된 CDO.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 DAVEX.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 다시 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 DRVIIS.DLL 파일이 검색됨
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-10-06

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • DrvIis.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 이러한 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일이 사용되고 있음을 나타냅니다.

이 오류를 해결하려면 사용 중인 Exchange 버전의 롤업을 업데이트하거나 최신 서비스 팩을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치되며, 사용자 데이터나 구성 데이터는 제거되거나 다시 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 업데이트도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행하십시오.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작과 실행을 차례로 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD 드라이브입니다.

  3. Microsoft Exchange 설치 마법사 시작 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. 제품 ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Exchange Server 2003용 다운로드"(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Exchange 2000 Server용 다운로드" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 DSACCESS.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server 또는 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 EMSMTA.EXE 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 EPOXY.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 ESE.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-06-20

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 ESEUTIL.EXE 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 EXCDO.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치 를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server 또는 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 EXCHMEM.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 다시 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 EXCHMEM.DLL이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange Server 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이러한 파일에는 Exchmem.dll이 포함되어 있습니다. Exchange Server Analyzer는 \%systemroot%\system32 폴더의 Exchmem.dll 파일이 \%exchangeroot%\bin 폴더의 Exchmem.dll 파일보다 오래된 경우 경고를 표시합니다.

대개 Exchmem.dll 복사본 두 개가 한 서버에 있지는 않습니다. 그러나 이전 릴리스의 제품에서 현재 위치로 업그레이드를 사용하여 두 번째 Exchmem.dll 파일을 추가할 수 있습니다. 두 가지 버전의 파일이 있으면 서비스 릴리스 설치 시 설치에 실패할 수 있습니다. 문제를 방지하려면 \%systemroot%\system32 폴더의 Exchmem.dll 파일 이름을 바꾸는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 모든 Exchange 서비스를 중지합니다.

  2. \%systemroot%\system32 폴더의 Exchmem.dll 파일 이름을 Exchmem.dll.old로 바꿉니다.

  3. 모든 Exchange 서비스를 다시 시작합니다.


오래된 EXMIME.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 EXOLEDB.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 EXPOP3.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server 또는 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)을 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 EXPROX.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 다시 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 Exres.dll 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 EXSMTP.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 MAD.EXE 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 MAPI32.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server 또는 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


system32 폴더에서 오래된 MAPI32.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 MDBSZ.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 OABGEN.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 PHATCAT.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트 (http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 PHATQ.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 REAPI.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 업데이트 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server 또는 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭하고 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 RESVC.DLL 파일이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더 및 \Exchsrvr\bin 폴더 모두에서 확인)

  • Mapi32.dll(System32 폴더 및 \Exchsrvr\bin 폴더 모두에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일의 Version 값이 Exchange Server Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일을 사용하고 있음을 나타냅니다.

이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


오래된 STORE.EXE 파일이 검색됨
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-10-06

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 이러한 파일의 Version 값이 Exchange Server의 Version 값보다 작으면 경고를 표시합니다. 이전 버전 번호는 오래된 파일이 사용됨을 나타냅니다.

이 오류를 해결하려면 사용 중인 Exchange 버전의 롤업을 업데이트하거나 최신 서비스 팩을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치되며, 사용자 데이터나 구성 데이터는 제거되거나 다시 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 업데이트도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행하십시오.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴와 실행을 차례로 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD 드라이브입니다.

  3. Microsoft Exchange 설치 마법사 시작 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. 제품 ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Exchange Server 2003용 다운로드"(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Exchange 2000 Server용 다운로드" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


Active Directory에 대해 진행 중인 호출 발견
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-14

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Information Store 서비스(Store.exe)에서 Active Directory® 디렉터리 서비스에 대해 진행 중인 상호 구성 요소 호출을 나타내는 이벤트를 확인하기 위해 FCL(Exchange Function Call Log), Store.fcl 파일을 검사합니다.

진행 중인 호출이란 Exchange FCL 데이터를 Store.fcl 파일에 기록하는 순간에 응답을 받지 못한 다른 구성 요소에게 Microsoft Exchange Information Store 서비스(Store.exe)에서 보내는 요청입니다.

Active Directory는 모든 사서함 정보, 주소 목록 서비스 및 기타 받는 사람 관련 정보를 제공합니다. 또한 대부분의 Exchange Server 2003 구성 정보는 Active Directory에 저장됩니다.

Exchange 서버 서비스는 Active Directory에 저장된 정보에 액세스하며 Active Directory에 정보를 기록합니다.

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 Active Directory에 대해 진행 중인 호출을 나타내는 이벤트를 발견하는 경우 경고를 표시합니다.

이 경고는 이 서버에 성능 문제가 있을 수 있음을 나타냅니다. 간헐적으로 발생하는 진행 중인 호출은 문제가 되지 않을 수도 있지만 동일한 영역에 대해 반복되는 진행 중인 호출은 문제가 될 수 있습니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

Microsoft Exchange Information Store 서비스에서 Active Directory에 대해 진행 중인 호출은 다음과 같은 조건에서 발생할 수 있습니다.

  • Exchange 서버와 도메인 컨트롤러 간 네트워크 대기 시간

  • DSAccess의 정적 또는 잘못된 구성

  • 오버로드된 컨트롤러 및 글로벌 카탈로그

  • 잘못 설계된 Active Directory 토폴로지

이 경고를 해결하려면 다음 단계를 수행합니다.

  • Exchange Server Analyzer를 실행하여 서버 문제를 추가적으로 분석합니다. "Microsoft Exchange Server Best Practices Analyzer Tool v2.7"(http://go.microsoft.com/fwlink/?LinkId=34705)에서 Exchange Server Analyzer를 다운로드할 수 있습니다.

  • Active Directory 도메인 컨트롤러 서버의 성능을 확인합니다.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

Exchange 성능 및 DSAccess에 대한 자세한 내용은 Microsoft 기술 자료 문서 250570, "디렉터리 서비스 서버 감지 및 DSAccess 사용"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570)을 참조하십시오.

Exchange 서버 성능에 대한 자세한 내용은 "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

Exchange 서버 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)을 참조하십시오.

정보 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.

도메인 컨트롤러 성능에 대한 자세한 내용은 다음 Windows Server 리소스를 참조하십시오.

  • "Planning Domain Controller Capacity" (http://go.microsoft.com/fwlink/?LinkId=70191).

  • Windows 2000 Server Active Directory Planning and Deployment Guides의 "Active Directory Monitoring of Domain Controllers"(http://go.microsoft.com/fwlink/?LinkId=70193).


ESE에 대해 진행 중인 호출 발견
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-13

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Information Store 서비스(Store.exe)에서 Exchange ESE(확장 가능한 저장소 엔진)에 대해 진행 중인 상호 구성 요소 호출을 나타내는 이벤트를 확인하기 위해 FCL(Exchange Function Call Log), Store.fcl 파일을 검사합니다.

진행 중인 호출이란 Exchange FCL 데이터를 Store.fcl 파일에 기록하는 순간에 응답을 받지 못한 다른 구성 요소에게 Microsoft Exchange Information Store 서비스(Store.exe)에서 보내는 요청입니다.

Microsoft Exchange Information Store는 ESE(확장 가능한 저장소 엔진) 데이터베이스 상위에 위치합니다. ESE는 트랜잭션 기반의 고급 데이터베이스 엔진입니다. 트랜잭션이란 보이지 않는 원자 단위로 처리되는 일련의 작업을 말합니다. 트랜잭션의 모든 작업은 완료되어 영구 저장된 것이 아니면, 작업이 수행되지 않은 것입니다.

Exchange 서버에서는 데이터베이스 구조를 결정하고 메모리를 관리하는 포함 데이터베이스 엔진으로 ESE를 사용합니다. 데이터베이스 엔진은 데이터 청크(페이지)를 메모리 내부와 외부로 전송하여 데이터베이스를 메모리에 캐시합니다. 이 엔진은 메모리의 페이지를 업데이트하고 디스크에 새 페이지나 업데이트된 페이지를 다시 씁니다. 요청이 시스템에 도달하면 데이터베이스 엔진은 메모리의 데이터를 버퍼링할 수 있습니다. 그렇기 때문에 디스크에 지속적으로 액세스할 필요가 없습니다.

메모리의 데이터를 캐시하는 것이 데이터를 처리하는 가장 빠르고 효율적인 방법이긴 하지만 Exchange가 실행 중일 때 디스크 상의 정보는 완전히 최신의 것이 될 수 없음을 의미합니다. 데이터베이스의 최신 버전은 메모리에 있습니다. 그러나 메모리의 여러 가지 변경 사항이 디스크에 아직 반영되지 않았으므로 데이터베이스와 메모리는 동기화되지 않습니다. 트랜잭션 로그 디스크는 항상 각 트랜잭션에 관한 최신 정보를 보유합니다.

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 ESE(확장 가능한 저장소 엔진) 데이터베이스에 대해 진행 중인 호출을 나타내는 이벤트를 발견하는 경우 경고를 표시합니다.

이 경고는 이 서버에 성능 문제가 있을 수 있음을 나타냅니다. 간헐적으로 발생하는 진행 중인 호출은 문제가 되지 않을 수도 있지만 동일한 영역에 대해 반복되는 진행 중인 호출은 문제가 될 수 있습니다.

서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

Microsoft Exchange Information Store 서비스에서 ESE(확장 가능한 저장소 엔진)로 보내는 진행 중인 호출은 다음과 같은 조건에서 발생할 수 있습니다.

  • Exchange 온라인 조각 모음

  • 데이터 백업

    참고:
    데이터 백업이나 온라인 조각 모음을 Exchange 호출 추적 로깅 수집 중에 실행하는 경우라면 Exchange 서버 성능 문제를 알리는 이 경고를 무시해도 됩니다.
  • 예를 들면 데이터베이스 드라이브의 병목 현상은 서버의 사용자 수에 비해 용량이 불충분함을 나타냅니다.

  • TEMP 및 TMP 드라이브의 병목 현상

이 오류를 해결하려면 다음 단계를 수행합니다.

  • 백업 Windows 또는 온라인 유지 관리를 사용자 요구가 많은 시간대와 겹치지 않도록 하는 것이 가장 좋습니다.

  • 데이터베이스 디스크 드라이브가 안정적이고 I/O 로드에 대한 처리량이 충분한지 확인하십시오.

  • 메시지 및 첨부 파일 크기 제한과 같은 서버 문제의 추가 분석을 위해 Exchange Server Analyzer를 실행합니다. "Microsoft Exchange Server Best Practices Analyzer Tool v2.7"(http://go.microsoft.com/fwlink/?LinkId=34705)에서 Exchange Server Analyzer를 다운로드할 수 있습니다.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

온라인 조각 모음 시간 창을 구성하는 방법에 관한 자세한 내용은 Microsoft 기술 자료 문서 244524, "XADM: How to Configure the Exchange Server Online Defragmentation Time Window"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524)를 참조하십시오.

Exchange 서버 디스크 지체 문제에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

Exchange 서버에서 디스크 크기를 설정하고 최적화하는 방법에 관한 자세한 내용은 Exchange Server 2003의 저장소 최적화(http://go.microsoft.com/fwlink/?linkid=49324)의 "디스크 I/O 요구 사항을 계산하는 방법" 및 "여러 아키텍처에 공통적인 유용한 정보"를 참조하십시오.

ESE에 대한 자세한 내용은 "Extensible Storage Engine Architecture"(http://go.microsoft.com/fwlink/?linkid=67009)를 참조하십시오.


발견된 IMail에 대해 진행 중인 호출
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-13

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Information Store 서비스(Store.exe)에서 MAPI 클라이언트의 IMAIL 구성 요소에 대해 진행 중인 상호 구성 요소 호출을 나타내는 이벤트를 확인하기 위해 FCL(Exchange Function Call Log), Store.fcl 파일을 검사합니다.

진행 중인 호출이란 Exchange FCL 데이터를 Store.fcl 파일에 기록하는 순간에 응답을 받지 못한 다른 구성 요소에게 Microsoft Exchange Information Store 서비스(Store.exe)에서 보내는 요청입니다.

Exchange 서버의 IMAIL 구성 요소는 인터넷과 MAPI 메시지 사이에서 Microsoft Exchange Information Store 서비스가 사용하는 유연한 변환 서비스입니다. 이 서비스를 통해 RFC-822 또는 인터넷 형식을 사용하는 클라이언트와 MAPI 클라이언트 또는 내부 저장소 작업과 같은 Exchange 서버 내부 저장소 형식을 사용하는 클라이언트 간에 상호 연동이 가능합니다.

Exchange에서는 IMAIL 메커니즘을 사용하여 Exchange System Manager의 인터넷 도메인에 대해 정의되거나 또는 Microsoft Office Outlook®의 받는 사람별 사용자에 의해 지정된 내용에 따라 메시지 형식을 콘텐츠에 적용합니다. IMAIL에 전달된 서식 매개변수가 없는 경우 IMAIL은 S/TNEF(Summary TNEF) 형식으로 MAPI 메시지의 서식을 지정하여 서버 간에 전송합니다.

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 MAPI 클라이언트의 IMAIL 구성 요소에 대해 진행 중인 호출을 나타내는 이벤트를 발견하는 경우 경고를 표시합니다.

이 경고는 이 서버에 성능 문제가 있을 수 있음을 나타냅니다. 간헐적으로 발생하는 진행 중인 호출은 문제가 되지 않을 수도 있지만 동일한 영역에 대해 반복되는 진행 중인 호출은 문제가 될 수 있습니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

Exchange Information Store 서비스로부터 MAPI 클라이언트의 IMAIL 구성 요소에 대해 발생한 진행 중인 호출은 다음 조건 중 하나 이상이 해당될 때 발생할 수 있습니다.

  • IMAIL의 메시지 또는 첨부 파일에 처리해야 할 데이터가 많습니다.

  • 데이터 변환을 요청하는 클라이언트가 많습니다.

  • DSAccess 요청에 대한 응답이 느립니다.

  • TEMP 및 TMP 드라이브에 병목 현상이 발생합니다.

  • 사서함 이동 작업이 진행 중입니다.

이 경고를 해결하려면 다음 단계를 수행합니다.

  • 사용량이 많지 않은 시간대에 사서함 이동을 예약합니다.

  • 메시지 및 첨부 파일 크기 제한과 같은 서버 문제의 추가 분석을 위해 Exchange Server Analyzer를 실행합니다. "Microsoft Exchange Server Best Practices Analyzer Tool v2.7"(http://go.microsoft.com/fwlink/?LinkId=34705)에서 Exchange Server Analyzer를 다운로드할 수 있습니다.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

Exchange 서버의 디스크 지체 문제에 관한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

Exchange 서버에서 디스크 크기를 설정하고 최적화하는 방법에 관한 자세한 내용은 Exchange Server 2003의 저장소 최적화(http://go.microsoft.com/fwlink/?linkid=49324)의 "디스크 I/O 요구 사항을 계산하는 방법" 및 "여러 아키텍처에 공통적인 유용한 정보"를 참조하십시오.

Exchange 서버의 메시지 크기 제한에 대한 유용한 정보에 관한 자세한 내용은 보내는 메시지의 최대 크기가 설정되지 않습니다.을 참조하십시오.

DSAccess Exchange 서버 성능에 관한 자세한 내용은 Exchange Server 2003의 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "DSAccess 사용자 캐시 구성 방법"을 참조하십시오.

Exchange 서버 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)을 참조하십시오.

정보 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.


발견된 LSASS에 대해 진행 중인 호출
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-13

Microsoft® Exchange Server Analyzer Tool은 Exchange Information Store 서비스(Store.exe)에서 Local Security Authentication Server(Lsass.exe) 프로세스에 대해 진행 중인 상호 구성 요소 호출을 나타내는 이벤트를 확인하기 위해 FCL(Exchange Function Call Log), Store.fcl 파일을 검사합니다.

진행 중인 호출이란 Exchange FCL 데이터를 Store.fcl 파일에 기록하는 순간에 응답을 받지 못한 다른 구성 요소에게 Microsoft Exchange Information Store 서비스(Store.exe)에서 보내는 요청입니다.

Local Security Authentication Server 프로세스(Lsass.exe)는 계정 정보 및 로그온 유효성 검사를 확인하기 위해 다른 프로세스에서 호출되는 보안 하위 시스템입니다.

Exchange 클라이언트에 로그온할 때마다 Exchange 서버를 실행하는 서버는 클라이언트에 대한 계정 SID(보안 식별자)를 조회하기 위한 요청을 보내고 Local Security Authentication Server(Lsass.exe) 프로세스 내에 호출을 만듭니다.

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 Local Security Authentication Server(Lsass.exe) 프로세스에 대해 진행 중인 호출을 나타내는 이벤트를 발견하는 경우 경고를 표시합니다.

이 경고는 이 서버에 성능 문제가 있을 수 있음을 나타냅니다. 간헐적으로 발생하는 진행 중인 호출은 문제가 되지 않을 수도 있지만 동일한 영역에 대해 반복되는 진행 중인 호출은 문제가 될 수 있습니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에 백업함으로 인해 클라이언트에 대한 서버 응답의 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

Exchange Information Store 서비스에서 LSASS 프로세스로 보내는 진행 중인 호출은 다음과 같은 조건에서 발생할 수 있습니다.

  • 동시에 인증하는 사용자 수와 관련된 서버 리소스 문제

  • Exchange 서버 및 도메인 컨트롤러 또는 글로벌 카탈로그 서버 사이에 네트워크 대기 시간

  • 서버 리소스 지체 문제

이 경고를 해결하려면 다음 단계를 수행합니다.

  • 'NeverPing' 매개 변수 권장에서 설명된 NeverPing 매개 변수를 구현합니다.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

Lsass.exe 프로세스 및 메모리 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 308356, "Windows Server 2003 또는 Windows 2000 Server를 실행하는 도메인 컨트롤러에서 Lsass.exe 프로세스의 메모리 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)을 참조하십시오.

Exchange 클라이언트 로그온 및 LSASS 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 161938, "Slow Exchange Client Logons Due to Resource Deadlock"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938)을 참조하십시오.

Exchange 서버와 도메인 컨트롤러 또는 글로벌 카탈로그 서버 간 네트워크 대기 시간에 대한 자세한 내용은 다음의 Exchange Server Team Blog 문서, "Exchange Does Not Always Use Local GCs"(http://go.microsoft.com/fwlink/?LinkId=69166)를 참조하십시오.

참고:
블로그의 내용과 해당 URL은 예고 없이 변경될 수 있습니다.

서버 리소스 지체 문제에 대한 자세한 내용은 프로세서 지체를 참조하십시오.

Exchange 서버 성능에 대한 자세한 내용은 "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

Exchange 서버 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

정보 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.


바이러스 검색에 대해 진행 중인 호출 발견
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-13

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Information Store 서비스(Store.exe)에서 Virusscan Virus API(VAPI) 구성 요소에 대해 진행 중인 상호 구성 요소 호출을 나타내는 이벤트를 확인하기 위해 Exchange FCL(Function Call Log), Store.fcl 파일을 검사합니다.

진행 중인 호출이란 Exchange FCL 데이터를 Store.fcl 파일에 기록하는 순간에 응답을 받지 못한 다른 구성 요소에게 Microsoft Exchange Information Store 서비스(Store.exe)에서 보내는 요청입니다.

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 VAPI 구성 요소에 대해 진행 중인 호출을 나타내는 이벤트를 발견하는 경우 경고를 표시합니다.

이 경고는 이 서버에 성능 문제가 있을 수 있음을 나타냅니다. 간헐적으로 발생하는 진행 중인 호출은 문제가 되지 않을 수도 있지만 동일한 영역에 대해 반복되는 진행 중인 호출은 문제가 될 수 있습니다.

서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

Exchange Information Store 서비스에서 VAPI 구성 요소로 보내는 진행 중인 호출은 다음과 같은 조건에서 발생할 수 있습니다.

  • 정보 저장소에 있는 항목을 재검색하는 바이러스 스캐너로 업데이트합니다.

  • 잘못 구성된 바이러스 스캐너

  • 바이러스 스캐너 소프트웨어가 대용량 메시지 또는 첨부 파일을 처리합니다.

이 경고를 해결하려면 다음 단계를 수행합니다.

  • 리소스 소모가 낮을 때, 즉, 사용량이 많지 않은 시간대에 바이러스 엔진의 업데이트를 예약합니다.

  • 바이러스 검색 소프트웨어를 재설치하는 것을 검토하여 사용량이 많지 않은 시간대에 재설치합니다.

  • 바이러스 검색 엔진의 스레드 구성, 파일 수준 제외 등이 올바른지 검사합니다. Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)를 참조하십시오.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

Microsoft Exchange Server 2003에서 일반적으로 사용되는 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 823166, "XADM: Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)를 참조하십시오.

Microsoft Exchange 2000 Server에서 일반적으로 사용되는 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 328841, "Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)를 참조하십시오.

Exchange 서버 성능에 대한 자세한 내용은 "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

Exchange 서버 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

정보 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.


운영 체제 GlobalFlag가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 GlobalFlag 항목의 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager

Exchange Server Analyzer는 GlobalFlag 값이 0 또는 Null 이외의 값으로 구성되어 있는 경우 경고를 표시합니다.

  • GlobalFlag 레지스트리 값 설정은 운영 체제에 사용되는 디버깅 옵션을 결정하는 비트 마스크입니다. Microsoft 기술 지원 서비스의 도움을 받아 문제를 디버깅하거나 추적하는 경우가 아니면 GlobalFlag 값을 항상 0으로 설정하는 것이 좋습니다.

GlobalFlag 레지스트리 값은 기본적으로 0으로 설정됩니다. 이 값이 기본값인 0이 아닌 다른 값으로 변경되었으면 Microsoft Windows Server™ 2003 지원 도구에 포함된 Gflags 도구를 사용할 수 있습니다. 이 도구는 Windows Server 2003 CD-ROM의 \Support 폴더에 있습니다. 또는 레지스트리 편집기를 사용하여 직접 이 값을 0으로 설정할 수 있습니다. 두 절차에 대한 설명은 아래와 같습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

GFlags를 사용하여 이 오류를 수정하려면 다음을 수행합니다.

  1. 시작, 실행을 차례로 클릭한 다음 옵션 필드에 GFlags를 입력합니다. Global Flags 사용자 인터페이스가 나타납니다.

  2. 모든 확인란의 선택을 해제하고 Apply를 클릭합니다.

  3. OK를 클릭하여 GFlags 도구를 끝낸 후 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집기를 사용하여 이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\ System\CurrentControlSet\Control\Session Manager를 탐색합니다.

  3. GlobalFlag라는 값을 두 번 클릭하고 해당 값 데이터를 0으로 설정합니다.

  4. 레지스트리 편집기를 끝내고 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)을 참조하십시오.


운영 체제가 디버그 모드입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Debug 속성의 값이 설정되었는지 여부를 확인할 때 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server 컴퓨터에서 이 키 값이 True로 설정되어 있으면 오류가 표시됩니다.

Windows 디버그 모드는 Boot.ini 파일에 /debug 매개 변수를 추가하여 전환됩니다. Windows Server 컴퓨터의 Boot.ini 파일에 /debug가 지정되면 시작하는 동안 커널 디버거가 로드되고 메모리에 상주합니다. 따라서 지원 전문가는 시스템이 Kernel STOP 화면에서 일시 중지되어 있지 않더라도 디버깅 중인 시스템에 접속하여 디버거를 시작할 수 있습니다. /crashdebug 스위치와 달리 /debug 스위치는 디버깅 중인지에 관계없이 COM 포트를 사용합니다. 이 스위치는 정기적으로 발생할 수 있는 문제를 디버깅할 때 사용됩니다. 문제를 해결하기 위해 /debug 매개 변수가 설정되었는데 우연히 설정된 상태로 있을 수 있습니다.

그럴 경우 실행 중인 추가 프로세스 때문에 성능이 크게 저하됩니다. 따라서 Windows가 디버그 모드로 실행 중인 컴퓨터에서 Exchange Server를 실행하는 것은 바람직하지 않습니다.

이 오류를 제거하려면 Boot.ini 파일을 편집하고 /debug 매개 변수를 제거합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Windows 탐색기에서 시스템 파티션을 탐색합니다. 시스템 파티션은 Boot.ini 및 NTLDR 같은 하드웨어 고유 파일이 저장된 파티션을 말합니다.

  2. Boot.ini 파일을 볼 수 없는 경우는 폴더 옵션에서 보호된 운영 체제 파일 숨기기로 설정했기 때문일 수 있습니다. 이러한 경우에는 Windows 탐색기 창에서 도구, 폴더 옵션, 보기를 차례로 클릭합니다. 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 해제합니다. 대화 상자가 표시되면 예를 클릭합니다.

  3. 탐색기에서 Boot.ini 파일이 보이면 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램을 클릭한 다음 Notepad를 선택하여 파일을 엽니다.

  4. [Operating Systems] 섹션에서 /debug 매개 변수를 제거합니다.

  5. 파일을 저장하고 닫은 다음 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

Boot.ini 파일에서 사용할 수 있는 매개 변수에 대한 자세한 내용은 Microsoft 기술 자료 문서 833721, "Windows XP 및 Windows Server 2003 Boot.ini 파일에 사용할 수 있는 스위치 옵션"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833721)을 참조하십시오.


Outlook Web Access에 Windows Server 2003 SP1용 핫픽스가 필요합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-08-28

Microsoft® Exchange Server Analyzer Tool은 다양한 Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 다음 정보를 수집합니다.

  • Exchange Server가 설치된 Microsoft Windows Server 운영 체제 버전은 무엇입니까?

  • Exchange Server는 클러스터에서 실행 중입니까?

Exchange Server Analyzer는 다음 조건에서 경고를 표시합니다.

  • Exchange Server 2003 서비스 팩 1(SP1)이 설치되어 있습니다.

  • Microsoft Windows Server™ 2003 SP1이 설치되어 있지 않습니다.

  • 클러스터 서비스가 실행되고 있습니다.

  • Davex.dll의 Version 값은 6.5.7232보다 이전 버전입니다.

이 구성을 실행하고 Exchange Server 핫픽스를 다운로드하여 설치한 다음 Windows Server 2003 SP1을 설치해야 합니다. Exchange Server 핫픽스를 설치하지 않은 경우 Microsoft Office Outlook® Web Access for Exchange Server 2003 사용자는 해당 사서함에 로그온할 수 없습니다. 클러스터에서 호스팅된 사서함이 있는 사용자가 Outlook Web Access를 사용하여 연결하려고 할 때 다음과 같은 오류 메시지가 나타납니다.

  • "500 - 내부 서버 오류"

이 오류는 Windows Server 2003 SP1이 포함되어 있는 일부 보안 향상 기능으로 인해 나타납니다.

사용자가 Outlook Web Access를 사용하여 사서함에 로그온하려고 할 때, HTTP는 로그온한 사용자를 가장하여 클러스터링 API에 요청을 보냅니다. 그러나 Windows Server 2003 SP1에는 변경된 보안 사항이 있습니다. 원격 레지스트리 액세스를 수행하는 API의 보안 제한이 변경되었습니다. 따라서 로그온 시도가 실패합니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 841561, "'사용자가 Outlook Web Access를 사용하여 클러스터된 Exchange Server 2003 백 엔드 서버에 액세스하려고 하면 "500 - 내부 서버 오류" 오류 메시지가 나타난다 "(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561)에 설명된 Exchange Server 핫픽스를 다운로드하여 설치해야 합니다.


Outlook Web Access 템플릿 파일이 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Wmtemplates.dll 파일의 버전 번호를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 그런 다음 Exchange Server Analyzer는 관리 그룹의 모든 서버에서 Wmtemplates.dll 버전 번호를 비교합니다. Exchange Server Analyzer는 프런트 엔드 및 백 엔드 Exchange 서버 간에 Wmtemplates.dll의 버전 번호가 일치하지 않는 경우 유용한 정보 메시지를 표시합니다.

Wmtemplates.dll 파일은 Microsoft Office Outlook® Web Access 제어에서 사용됩니다. 프런트 엔드 및 백 엔드 Exchange 서버에서 Wmtemplates.dll의 버전 번호가 일치하지 않는 경우 사용자가 프런트 엔드 Exchange 서버에 액세스하여 Outlook Web Access에 로그온하려고 하면 400 수준의 오류가 발생할 수 있습니다.

Microsoft에서 릴리스된 Wmtemplates.dll을 업데이트하는 다음의 두 가지 최신 업데이트가 있습니다.

  • "Microsoft Exchange Information Store service crashes periodically after you install Exchange Server 2003 SP1"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=872963)

  • "Windows XP 서비스 팩 2 기반 컴퓨터에서 Exchange Server 2003 OWA 클라이언트를 실행하면 S/MIME 컨트롤이 OWA에서 로드되지 않는다"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=883543)

이러한 업데이트 중 하나를 최근에 설치한 경우라면 다음 조건에 해당할 수 있습니다.

  • 업데이트가 올바른 순서로 설치되지 않았습니다.

  • 업데이트가 프런트 엔드 및 백 엔드 서버 중 하나에만 설치되었습니다.

Outlook Web Access 업데이트를 설치하는 경우 프런트 엔드 서버에 업데이트를 설치하고 서버를 다시 시작한 다음 백 엔드 서버에 업데이트를 설치해야 합니다.

이러한 업데이트 중 하나를 설치하지 않은 경우 모든 서버에서 최신 Exchange Server 서비스 팩과 업데이트를 실행하고 있는지 확인하십시오.

최신 Exchange Server 서비스 팩과 업데이트에 대한 자세한 내용을 보려면 다음 웹 사이트를 방문하십시오.

  • Downloads for Exchange Server 2003(http://go.microsoft.com/fwlink/?LinkId=21236)

  • Downloads for Exchange 2000 Server(http://go.microsoft.com/fwlink/?LinkId=33457)


해결되지 않은 RPC 요청이 최대 임계값에 도달했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeIS 성능 개체의 RPC Requests 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Exchange Server Analyzer는 샘플 시간 동안 RPC 요청 수가 최고값 100에 도달한 경우 오류를 표시합니다.

RPC Requests 성능 카운터는 Microsoft Exchange Information Store 서비스가 현재 처리 중인 MAPI RPC(원격 프로시저 호출) 또는 클라이언트 요청 수를 나타냅니다. RPC Requests 성능 카운터의 평균 값은 항상 30 이하여야 합니다. 기본적으로 최대 RPC 요청 값은 100입니다. 따라서 다르게 구성된 경우가 아니면 Microsoft Exchange Information Store 서비스는 모든 새 RPC 작업이 거부되기 전에 RPC 요청 100개만 동시에 처리할 수 있고 사용자는 RPC 요청이 100 아래로 떨어질 때까지 서버에 연결할 수 없습니다. 서버는 응답하지 않고 메일 흐름이 중지될 수 있습니다. Outlook 사용자에게 RPC cancel Request 대화 상자가 표시될 수 있습니다.

이 오류는 서버에 성능 지체가 발생하거나 프로세스가 응답을 중지했음을 나타냅니다.

성능 지체는 CPU, 디스크, 네트워크 또는 메모리와 관련될 수 있고 서버 로드 증가 또는 부족한 서버 리소스로 인해 발생할 수 있습니다. 성능 모니터(Perfmon.msc) 도구를 사용하여 서버의 로드 증가로 지체가 발생했는지 또는 서버 용량이 부족한지 확인합니다. 서버 로드가 증가한 경우 로드의 원인을 확인하고 로드를 줄입니다. 서버에 리소스가 부족한 경우에는 필요한 리소스를 늘리거나 사용자를 다른 서버로 이동합니다.

저장소에서 반환되지 않는 리소스를 기다리므로 프로세스의 응답이 중지될 수 있습니다. 메시지 추적을 호스팅하는 드라이브가 누락된 클러스터나 바이러스 검색 프로그램 문제가 이런 예에 해당합니다. 프로세스가 응답을 중지하면 RPC 요청이 감소되지 않으므로 저장소를 다시 시작해야 합니다.

추가 정보

  • 프로세서 지체에 대한 자세한 내용은 프로세서 지체를 참조하십시오.

  • 디스크 지체에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • Exchange Server 성능 계획 방법에 대한 자세한 내용은 Exchange Server 2003 Performance: 10 Things to Think About(http://go.microsoft.com/fwlink/?LinkID=56460)를 참조하십시오.

  • 사용자 사서함을 이동하여 서버 로드를 줄이는 방법에 대한 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.


PHATCAT.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 해결하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 ExchangeServer 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


PHATQ.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 해결하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


페이지 파일 성능 문제
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 LogicalDisk 성능 개체의 PAGEDISK 인스턴스에 대한 Avg Disk sec/Read 및 Avg Disk sec/Write 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Exchange Server Analyzer는 샘플 시간 동안 Avg Disk sec/Read 및 Avg Disk sec/Write 카운터가 10밀리초를 초과한 경우 오류를 표시합니다.

LogicalDisk 성능 개체는 하드 디스크의 논리 파티션을 모니터링하는 Avg Disk sec/Read 및 Avg Disk sec/Write와 같은 카운터로 구성됩니다. Avg Disk sec/Read 성능 카운터는 디스크에서 데이터를 읽는 평균 시간(초)을 표시합니다. Avg Disk sec/Write 성능 카운터는 디스크에 데이터를 쓰는 평균 시간(초)을 표시합니다. Avg Disk sec/Read 및 Avg Disk sec/Write 성능 카운터의 평균 값은 10밀리초 미만이어야 합니다.

서버에서 LogicalDisk 성능 개체의 PAGEDISK 인스턴스는 페이지 파일(Pagefile.sys)을 나타냅니다. Pagefile.sys는 시스템의 RAM이 부족한 경우 임시 데이터를 저장할 수 있도록 Microsoft Windows®에서 사용되는 하드 디스크의 숨겨진 시스템 파일입니다. 페이지 파일은 페이징 파일 또는 스왑 파일이라고도 합니다.

이 오류는 페이지 파일을 호스팅하는 디스크에 지연 문제가 있음을 나타냅니다.

이 오류를 해결하려면 다음 단계를 수행합니다.

  • 지연의 원인을 확인합니다. 과도한 페이징으로 인해 이 문제가 발생하는 경우 서버 메모리 문제일 수 있습니다.

  • 전용 파티션이나 고속 디스크에 페이지 파일을 배치하는 것이 좋습니다.

  • Microsoft 기술 자료 문서 197379, "Windows Server 2003, Windows 2000 및 Windows NT에서 최적화와 복구를 위한 페이지 파일 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)에서 설명한 대로 대체 드라이브에 보조 페이지 파일을 만드는 것이 좋습니다.

  • 서버 유지 관리 작업은 사용량이 많지 않은 시간에 실행합니다. 사용량이 많은 시간에 Exchange Server 데이터베이스 유틸리티(예: Eseutil) 같은 유지 관리 도구 또는 사서함 관리 같은 작업을 실행하면 Exchange에서 사용할 수도 있는 메모리를 사용하게 됩니다. 이러한 도구와 작업은 사용량이 최고로 많은 시간을 피해 또는 사용량이 적은 시간에 실행하는 것이 좋습니다.

추가 정보

  • 디스크 지체에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

  • 페이지 파일 성능 최적화에 대한 자세한 내용은 Microsoft 기술 자료 문서 197379, "Windows Server 2003, Windows 2000 및 Windows NT에서 최적화와 복구를 위한 페이지 파일 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)을 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드 (http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 저장소 아키텍처를 설계하는 최상의 방법에 대한 자세한 내용은 여러 아키텍처에 공통적인 유용한 정보(http://go.microsoft.com/fwlink/?LinkId=72988)를 참조하십시오.

  • 디스크 크기 조정, 대기 시간, I/O 비율에 대한 자세한 내용은 Microsoft Exchange 팀 블로그 웹 사이트에서 다음 블로그를 참조하십시오.

    • A few basic concepts in disk sizing(http://go.microsoft.com/fwlink/?linkid=39538)

    • Some more thoughts on disk IO and calculations...(http://go.microsoft.com/fwlink/?linkid=39539)

    • 디스크 I/O 요구 사항을 계산하는 방법(http://go.microsoft.com/fwlink/?linkid=69747)


Page File Usage 카운터가 50%보다 큽니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-09-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Paging File 성능 개체의 % Usage 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Exchange Server Analyzer는 샘플 시간 동안 % Usage 카운터가 50%를 초과한 경우 오류를 표시합니다.

페이지 파일(Pagefile.sys)은 시스템의 RAM이 부족한 경우 임시 데이터를 저장할 수 있도록 Windows에서 사용되는 하드 디스크의 숨김 시스템 파일입니다. 페이지 파일은 페이징 파일 또는 스왑 파일이라고도 합니다. 디스크 작업이 메모리 작업보다 시간이 더 걸리므로 페이지 파일의 사용은 전체 성능에 영향을 미칩니다. 또한 디스크에서 또는 디스크로 전송되는 페이지 파일이 크게 증가하면 결국 디스크 지체가 발생하고 성능이 저하됩니다. 이 경우 실제 문제는 메모리 문제이고 디스크 지체는 증상일 뿐입니다.

메모리 컨텐션은 시스템이 실제 작업에 필요한 시간에 비해 제한된 메모리를 관리하는 데 상당한 시간이 걸리는 지점에 이를 때까지 허용됩니다. 평균 응답 시간에 대한 메모리 컨텐션을 그래프로 작성하면 0 컨텐션에서 응답 시간이 크게 증가하는 지점까지 비교적 완만한 선이 표시됩니다. 이 지점을 스래싱(thrashing) 지점이라고 합니다. 메모리 컨텐션이 이 지점을 지나쳐 증가하면 응답 시간이 급격히 증가합니다. 일부 환경에서는 임시 스레싱이 허용되지만 임시 스레싱이 발생하지 않도록 작업해야 합니다.

이 오류는 페이지 파일을 호스팅하는 디스크에 성능 문제가 있음을 나타냅니다. 이 문제는 궁극적으로 서버의 메모리 문제와 관련될 수 있습니다.

이 오류를 해결하려면 다음 단계를 수행합니다.

  • Microsoft 기술 자료 문서 197379, "Windows Server 2003, Windows 2000 및 Windows NT에서 최적화와 복구를 위한 페이지 파일 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)에서 설명한 대로 대체 드라이브에 보조 페이지 파일을 만드는 것이 좋습니다.

  • 전용 파티션 또는 고속 디스크에 페이지 파일을 배치하는 것이 좋습니다.

  • 불필요한 소프트웨어를 제거합니다. Exchange에 사용할 수 있는 메모리 리소스를 늘리려면 모니터링 기능이나 꼭 필요하지 않은 서비스를 수행하는 타사 소프트웨어 도구를 제거합니다. 성능 스냅인(http://go.microsoft.com/fwlink/?LinkId=56118)을 사용하면 응용 프로그램에서 사용하고 있는 메모리 양을 파악할 수 있습니다.

  • 서버 유지 관리 작업은 사용량이 많지 않은 시간에 실행합니다. 사용량이 많은 시간에 Exchange Server 데이터베이스 유틸리티(예: Eseutil) 같은 유지 관리 도구 또는 사서함 관리 같은 작업을 실행하면 Exchange에서 사용할 수도 있는 메모리를 사용하게 됩니다. 이러한 도구와 작업은 사용량이 최고로 많은 시간을 피해 또는 사용량이 적은 시간에 실행하는 것이 좋습니다.

  • 영향을 받는 서버에서 다른 서버로 사용자 사서함을 옮겨서 서버 로드를 줄입니다. 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.

추가 정보

  • 디스크 지체에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

  • 페이지 파일 성능 최적화에 대한 자세한 내용은 Microsoft 기술 자료 문서 197379, "Windows Server 2003, Windows 2000 및 Windows NT에서 최적화와 복구를 위한 페이지 파일 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)을 참조하십시오.

  • 메모리 성능 향상에 대한 자세한 내용은 사용자 메모리 향상을 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 저장소 아키텍처를 설계하는 최상의 방법에 대한 자세한 내용은 여러 아키텍처에 공통적인 유용한 정보(http://go.microsoft.com/fwlink/?LinkId=72988)를 참조하십시오.

  • 디스크 크기 조정, 대기 시간, I/O 비율에 대한 자세한 내용은 Microsoft Exchange 팀 블로그 웹 사이트에서 다음 블로그를 참조하십시오.

    • A few basic concepts in disk sizing(http://go.microsoft.com/fwlink/?linkid=39538)

    • Some more thoughts on disk IO and calculations...(http://go.microsoft.com/fwlink/?linkid=39539)

    • 디스크 I/O 요구 사항을 계산하는 방법(http://go.microsoft.com/fwlink/?linkid=69747)


PageHeapFlags가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 PageHeapFlags 항목의 값을 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

Exchange Server Analyzer는 PageHeapFlags의 값이 0 또는 null 이외의 값으로 구성되어 있으면 경고를 표시합니다.

PageHeapFlags 옵션은 GlobalFlag가 설정되어 있습니다.에 설명되어 있는 GlobalFlag 레지스트리 값과 함께 사용됩니다. PageHeapFlags 옵션을 사용하면 각각의 힙 할당의 끝에 채우기 패턴을 기록하고 할당이 해제되면 패턴을 검사하는 표준 힙 확인이나 전체 페이지 힙 확인을 선택할 수 있습니다. 이렇게 함으로써 액세스할 수 없는 페이지가 각 할당의 끝에 위치하게 되어 프로그램이 할당된 메모리를 초과하여 액세스할 경우 즉시 중지됩니다. 전체 페이지 힙 확인은 각각의 할당에 대해 메모리의 전체 페이지를 사용하기 때문에 방만한 사용으로 인해 시스템 메모리가 부족해질 수 있습니다.

이 경우 Exchange Server Analyzer는 특히 다음과 같은 여러 Exchange 구성 요소에 대해 PageHeapFlags 값이 사용되고 있는지 확인합니다.

  • STORE.EXE - 정보 저장소 프로세스

  • MAD.EXE - 시스템 수행자 프로세스

  • INETINFO.EXE - IIS 관리 및 부모 프로세스

  • EMSMTA.EXE - 메시지 전송 에이전트 프로세스

Microsoft 기술 지원 서비스의 안내에 따라 디버깅을 수행하거나 문제를 추적하는 경우 외에는 PageHeapFlags 값을 항상 0으로 설정하거나 완전히 삭제하는 것이 좋습니다. 두 경우의 효과는 동일합니다.

기본적으로 PageHeapFlags 레지스트리 값은 설정되어 있지 않으며 STORE.EXE 프로세스 또는 기타 프로세스를 디버그해야 할 경우에 수동으로 추가해야 합니다. Microsoft® Windows Server™ 2003 지원 도구(위치: Windows Server 2003 CD의 \Support 폴더)에 포함되어 있는 Gflags 도구를 사용할 수 있습니다. 또는 수동으로 값을 0으로 설정하거나 레지스트리 편집기를 사용하여 PageHeapFlags 값을 완전히 삭제할 수 있습니다. 이 문서에는 두 가지 절차 모두 설명되어 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

GFlags를 사용하여 이 오류를 수정하려면 다음을 수행합니다.

  1. 시작 | 실행을 클릭하고 열기 필드에서 GFlags를 실행합니다. Global Flags 사용자 인터페이스가 나타납니다.

  2. Image File Name 필드에 STORE.EXE를 입력합니다.

  3. Image File Options를 클릭합니다.

  4. 확인란의 선택을 모두 해제한 다음 적용을 클릭합니다.

  5. 위에 나열된 각각의 Exchange 프로세스에 대해 2-4단계를 반복합니다.

  6. 확인를 클릭하여 GFlags 도구를 끝내고 해당 서비스를 모두 다시 시작하여 변경 내용을 적용합니다.

  7. GFlags 도구를 사용하여 이 값을 해제하더라도 PageHeapFlags의 값은 삭제되거나 변경되지 않습니다. 대신 GlobalFlag 값을 0으로 설정하여 PageHeapFlags 항목을 통해 구성된 동작을 다시 정의하고 사용하지 않습니다.

레지스트리 편집기를 사용하여 이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE를 탐색합니다.

  3. PageHeapFlags 값을 삭제합니다.

  4. 위에 나열된 각각의 Exchange 프로세스에 대해 2단계와 3단계를 반복합니다.

  5. 레지스트리 편집기를 끝내고 해당 서비스를 모두 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


페이징 풀이 오류 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Win32_PerfRawData_PerfOS_Memory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 현재 PoolNonpagedBytes 키 값을 확인합니다. Exchange Server Analyzer가 수행하는 작업은 기본 운영 체제, Windows Boot.ini 파일의 /3GB 스위치 존재 여부 및 이 키의 검색된 값에 따라 다릅니다.

다음에는 Exchange Server Analyzer에서 이 값이 지정된 Exchange 서버의 범위를 벗어나는지 여부를 확인하는 데 사용하는 계산 매트릭스가 나와 있습니다. 다음 매트릭스에 나와 있는 조건이 충족되면 경고가 표시됩니다.

운영 체제 | Boot.ini 설정 | 현재 비페이징 풀
Windows 2000 Server 또는 Advanced Server | /3GB | 110MB 이상
Windows 2000 Server 또는 Advanced Server | 없음 | 220MB 이상
Windows Server™ 2003 | /3GB | 110MB 이상
Windows Server 2003 | 없음 | 220MB 이상

PoolNonpagedBytes 키 값은 커널 메모리 비페이징 풀의 크기(바이트)입니다. 비페이징 풀은 디스크에 쓸 수 없지만 할당된 경우 실제 메모리에 남아 있어야 하는 개체의 실제 시스템 메모리 영역입니다. 이 키에 대한 값은 가장 최근에 관찰된 값입니다. 정상 상태의 Exchange Server에서 이 값은 동일하게 유지됩니다. 이 카운터 값이 계속 증가하면 메모리 누수가 발생한 것일 수 있습니다.

비페이징 풀 메모리 제한을 위에 표시된 값보다 크게 늘릴 수 없으므로 가능한 빨리 이 상황을 해결해야 합니다. 사용 중인 운영 체제, \3GB 스위치의 존재 여부에 관계없이 Windows 운영 체제에서는 지정된 크기의 비페이징 풀 메모리에만 액세스할 수 있습니다. Windows에서 커널 메모리가 부족하면 오류 메시지가 나타나고 시스템이 손상될 수 있습니다. 커널 메모리는 시스템의 올바른 작동에 필요하므로 커널 메모리를 주의해서 모니터링해야 합니다.

Exchange Server를 다시 시작해도 이러한 문제가 지속되면 시스템이 올바르게 조정되어 있고 이 시스템에 있는 소프트웨어와 하드웨어가 모두 최신 버전인지 확인합니다. 다음 항목의 최신 버전을 설치해야 합니다.

  • Windows 운영 체제 서비스 팩

  • Exchange Server 서비스 팩

  • 하드웨어 펌웨어 및 드라이버

  • 시스템 BIOS 업데이트

  • 설치되어 실행 중인 타사 응용 프로그램의 업데이트

소프트웨어 및 하드웨어 업데이트로 이 문제를 해결할 수 없으면 모든 타사 소프트웨어를 비활성화하고 Exchange Server 컴퓨터를 다시 시작한 후 커널 메모리를 모니터링합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 가능한 빨리 Exchange Server 컴퓨터를 다시 시작합니다.

  2. Memory | Pool Nonpaged Bytes 성능 카운터를 모니터링하여 위에 표시된 시스템 임계값을 초과하지 않도록 합니다.

Exchange Server를 올바르게 조정하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서와 항목을 참조하십시오.

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 266096, "XGEN: 1GB 이상의 실제(Physical) RAM을 가진 Exchange 2000 서버에서 /3GB 스위치가 필요하다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • "Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Troubleshooting Exchange 2000 Performance"(http://go.microsoft.com/fwlink/?LinkId=18177)

  • "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)


페이징 풀이 경고 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-03-16

Microsoft® Exchange Server Analyzer Tool은 Win32_PerfRawData_PerfOS_Memory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 현재 PoolPagedBytes 키 값을 확인합니다. Exchange Server Analyzer가 수행하는 작업은 기본 운영 체제, Windows Boot.ini 파일의 \3GB 스위치 존재 여부 및 이 키의 검색된 값에 따라 다릅니다.

표에는 Exchange Server Analyzer에서 이 값이 제공된 Exchange 서버의 범위를 벗어나는지 여부를 확인하는 데 사용하는 평가 매트릭스가 나와 있습니다. 다음 표에 나와 있는 조건이 충족되면 경고가 표시됩니다.

운영 체제 | Boot.ini 설정 | 현재 페이징 풀
Windows 2000 Server 또는 Advanced Server | /3GB | 180MB 이상
Windows 2000 Server 또는 Advanced Server | 없음 | 180MB 이상
Windows Server™ 2003 | /3GB | 200MB 이상
Windows Server 2003 | 없음 | 300MB 이상

PoolPagedBytes 키 값은 커널 메모리 페이징 풀의 크기(바이트)입니다. 페이징 풀은 사용 중이 아닐 때 디스크에 기록될 수 있는 개체에 대한 실제 시스템 메모리 영역입니다. 이 키에 대한 값은 가장 최근에 관찰된 값입니다. 정상적인 Exchange Server의 경우 백업 또는 복원이 발생하지 않는 한 180MB 미만의 페이징 풀 메모리가 사용되어야 합니다.

Windows 2000 Server와 Windows 2000 Advanced Server에서 최대 페이징 풀 메모리 값은 470MB입니다. /3GB 스위치가 Windows 2000 Advanced Server를 실행하는 컴퓨터에 추가된 경우 최대 페이징 풀 메모리 값은 192MB입니다. /3GB 스위치 없이 Windows Server 2003을 실행 중인 컴퓨터에서 최대 페이징 풀 메모리 값은 491MB입니다. /3GB 스위치를 지정하여 Windows Server 2003을 실행 중인 컴퓨터에서 최대 페이징 풀 메모리 값은 256MB입니다.

위에 나열된 값을 벗어나서 페이징 풀 메모리에 대한 한도를 증가시킬 방법이 없기 때문에 이 조건을 가능한 빨리 수정해야 합니다. 사용 중인 운영 체제나 /3GB 스위치 존재 여부에 관계없이 Windows에서 상당히 많은 페이징 풀 메모리를 액세스할 수 있습니다. Windows에서 커널 메모리가 부족하면 오류 메시지가 나타나고 시스템이 손상될 수 있습니다. 커널 메모리는 시스템의 적절한 운영에 필수적이므로 커널 메모리를 주의해서 모니터링해야 합니다.

Exchange Server를 다시 시작해도 이러한 문제가 지속되면 시스템이 올바르게 조정되어 있고 이 시스템에 있는 소프트웨어와 하드웨어가 모두 최신 버전인지 확인합니다. 다음 항목의 최신 버전을 설치해야 합니다.

  • Windows 운영 체제 서비스 팩

  • Exchange Server 서비스 팩

  • 하드웨어 펌웨어 및 드라이버

  • 시스템 BIOS 업데이트

  • 설치 및 실행 중인 타사 응용 프로그램의 업데이트

소프트웨어와 하드웨어를 업데이트해도 이 문제가 해결되지 않으면 타사 소프트웨어를 사용할 수 없게 설정하고 Exchange Server 컴퓨터를 다시 시작한 후 커널 메모리를 모니터링해야 합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 가능한 한 빨리 Exchange Server 컴퓨터를 다시 시작합니다.

  2. Memory | Paged Pool Bytes 성능 카운터를 모니터링하여 사용 중인 시스템에 대해 위에 나열된 임계값 이상으로 급격히 상승하고 있지 않은지 확인합니다.

Exchange Server를 올바르게 조정하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서와 Exchange 항목을 참조하십시오.

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 266096, "XGEN: 1GB 이상의 실제(Physical) RAM을 가진 Exchange 2000 서버에서 /3GB 스위치가 필요하다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • "Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Troubleshooting Exchange 2000 Performance"(http://go.microsoft.com/fwlink/?LinkId=18177)

  • "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)

자세한 내용은 다음 Exchange 블로그 문서를 참조하십시오.

  • "Microsoft Windows Kernel Memory Management and Microsoft Exchange Server"(http://go.microsoft.com/fwlink/?LinkId=63477)

  • "Configuring Hot-Add and Large Memory for Exchange 2003"(http://go.microsoft.com/fwlink/?LinkId=63478)

  • "Large Security Tokens and Kernel Memory Exhaustion"(http://go.microsoft.com/fwlink/?LinkId=63479)

    참고:
    이 블로그에 대한 링크는 오직 정보를 제공하기 위한 것입니다. 해당 내용은 예고 없이 변경될 수 있습니다.


RPC 프록시 서버 확장의 경로가 잘못되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 인터넷 정보 서비스(IIS) 메타베이스에서 다음 속성을 읽어 값이 제대로 구성되어 있는지 확인합니다.

LM/W3SVC/Filters/RpcProxy

이 메타베이스 속성은 IIS의 웹 서비스 확장에서 RPC(원격 프로시저 호출) 프록시 서버 확장입니다. 이 속성의 올바른 값은 다음과 같습니다.

<Windows Directory>\system32\rpcproxy\rpcproxy.dll

Exchange Server Analyzer는 속성이 올바른 값이 아니면 경고를 표시합니다.

네트워킹 서비스 Microsoft Windows® 구성 요소의 RPC over HTTP 프록시 하위 구성 요소를 설치할 경우 RPC 프록시 서버 확장 속성이 설정됩니다. 속성이 잘못 설정되거나 값을 수동으로 변경할 경우 다음을 수행해야 합니다.

  1. 잘못된 RPC 프록시 서버 확장 속성을 제거합니다.

  2. RPC over HTTP 프록시 하위 구성 요소를 제거합니다.

  3. RPC over HTTP 프록시 하위 구성 요소를 다시 설치합니다.

잘못된 RPC 프록시 서버 확장 속성을 제거하려면 다음을 수행합니다.

  1. 인터넷 정보 서비스(IIS) 관리를 엽니다.

  2. 인터넷 정보 서비스(IIS) 관리 창의 왼쪽 창에서 서버 이름을 확장하고 웹 확장을 클릭합니다.

  3. IIS 관리자 창의 오른쪽 창에서 RPC 프록시 서버 확장을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  4. 필요한 파일 탭의 파일 목록에서 잘못된 파일을 선택하고 제거, 확인을 차례로 클릭합니다.

    참고:
    전체 경로를 보려면 파일 목록에서 파일 이름 열의 너비를 조절합니다.
RPC over HTTP 프록시 하위 구성 요소를 제거하려면 다음을 수행합니다.

  1. 시작, 제어판 및 프로그램 추가/제거를 차례로 클릭합니다.

  2. 왼쪽 창에서 Windows 구성 요소 추가/제거를 클릭합니다.

  3. 네트워킹 서비스를 선택한 다음 자세히를 클릭합니다.

  4. RPC over HTTP 프록시 확인란의 선택을 해제하고 확인, 다음을 차례로 클릭합니다.

  5. Windows 구성 요소 마법사가 완료되면 마침을 클릭하여 마법사를 닫습니다.
RPC over HTTP 프록시 하위 구성 요소를 다시 설치하려면 다음을 수행합니다.

  1. 시작, 제어판 및 프로그램 추가/제거를 차례로 클릭합니다.

  2. 왼쪽 창에서 Windows 구성 요소 추가/제거를 클릭합니다.

  3. 네트워킹 서비스를 선택한 다음 자세히를 클릭합니다.

  4. RPC over HTTP 프록시 확인란을 선택하고 확인, 다음을 차례로 클릭합니다.

  5. Windows 구성 요소 마법사가 완료되면 마침을 클릭하여 마법사를 닫습니다.

제대로 로드되지 않은 RPC 프록시 서버 확장 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833401)의 문제 해결 섹션을 참조하십시오.

Exchange Server 2003에 RPC over HTTP를 배포하는 방법에 대한 자세한 내용은 Exchange Server 2003 RPC over HTTP Deployment Scenarios(http://go.microsoft.com/fwlink/?LinkId=24823)를 참조하십시오.


PDC 에뮬레이터가 DSAccess 토폴로지에서 제외되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 주 도메인 컨트롤러(PDC) 에뮬레이터의 역할을 하는 Active Directory® 도메인 컨트롤러가 Exchange Server에서 사용할 수 있는 도메인 컨트롤러의 목록에서 수동으로 제외되었는지를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default\MinUserDC

Exchange Server Analyzer는 PDC 에뮬레이터의 역할을 하는 도메인 컨트롤러가 Exchange Server에서 사용할 수 있는 도메인 컨트롤러 목록에서 수동으로 제외되지 않았음을 확인하면 권장되는 유용한 정보를 표시합니다.

PDC 에뮬레이터는 Microsoft Windows NT® Server 4.0 백업 도메인 컨트롤러의 복제 요청을 처리하고 Active Directory 사용이 가능한 클라이언트 소프트웨어를 실행하지 않는 클라이언트에 대한 모든 암호 업데이트를 처리하는 Active Directory 작업 마스터 역할 컴퓨터입니다. 또한 PDC 에뮬레이터는 도메인 컨트롤러이기도 하므로 Exchange Server와 같은 응용 프로그램에서 사용할 수 있습니다.

DSAccess(Directory Service Access)는 Exchange 2000 Server와 Exchange Server 2003의 내부 구성 요소로, 모든 Exchange Server 구성 요소가 Active Directory에 액세스하는 방법을 제어합니다. DSAccess의 기본 기능은 다양한 디렉터리 관련 이벤트 및 작업에 대한 정보를 유지하는 것입니다. 예를 들어 DSAccess는 Active Directory 토폴로지를 검색하고 도메인 컨트롤러 및 글로벌 카탈로그 서버가 사용 가능하고 쿼리에 응답하는지 확인합니다.

DSAccess의 사용 가능한 도메인 컨트롤러 목록에는 기본적으로 PDC 에뮬레이터 컴퓨터가 포함됩니다. Exchange Server 이외의 프로그램에서 PDC 에뮬레이터를 많이 사용할 경우 DSAccess를 통해 PDC 에뮬레이터를 사용하면 PDC 에뮬레이터 컴퓨터 및 Exchange 서버와 Exchange Server 이외의 프로그램 컴퓨터에서도 성능 문제가 발생할 수 있습니다.

MinUserDC 레지스트리 값을 Exchange 서버의 레지스트리에 추가하여 DSAccess가 PDC 에뮬레이터 작업 마스터 역할의 도메인 컨트롤러를 쿼리하기 전에 사용 가능한 다른 모든 도메인 컨트롤러를 쿼리하도록 하면 이러한 성능 문제를 방지할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
MinUserDC 레지스트리 값을 확인하고 변경하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default를 탐색합니다.

  3. MinUserDC 값을 찾아 필요에 따라 변경합니다. 이 DWORD 값이 없으면 수동으로 값을 만들 수 있습니다.

    참고:
    MinUserDC 레지스트리 항목에 대해 구성되어 있는 값 데이터는 PDC 에뮬레이터에 연결하기 전에 먼저 연결할 도메인 컨트롤러의 최대 수입니다. 예를 들어 MinUserDC를 4로 설정하면 사용할 수 있는 도메인 컨트롤러가 총 4개인 경우에만 PDC 에뮬레이터를 제외하도록 DSAccess가 구성됩니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MinUserDC 레지스트리 항목을 사용하는 방법에 대한 자세한 내용은 기술 자료 문서 298879, "Exchange 2000 may experience performance problems when PDC emulator is used for DSAccess"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879)를 참조하십시오.


Available MBytes 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Memory 성능 개체의 Available MBytes 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 Available MBytes 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Available MBytes 성능 카운터는 프로세스나 시스템용으로 즉시 할당할 수 있는 실제 메모리의 양(MB)을 표시합니다. 사용할 수 있는 메모리 양은 대기 중(캐시 상태), 사용 가능 및 0으로 채워진 페이지 목록에 할당된 메모리 양의 합과 같습니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


LogicalDisk 성능 개체의 Average Disk sec/Read 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이트 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 LogicalDisk 성능 개체의 Avg. Disk sec/Read 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 Avg. Disk sec/Read 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Logical Disk 성능 개체는 하드 디스크의 논리 파티션을 모니터링하는 Avg. Disk sec/Read와 같은 카운터로 구성됩니다. Avg. Disk sec/Read 성능 카운터에는 디스크에서 데이터를 읽는 평균 시간(초)가 표시됩니다. Avg. Disk sec/Read 성능 카운터의 평균 값은 10밀리초 미만이어야 합니다. Avg. Disk sec/Read 성능 카운터의 최대값은 50밀리초를 초과하지 않아야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

Exchange Server 2003용 저장소 시스템을 최적화하는 방법에 대한 자세한 내용은 Exchange Server 2003의 저장소 최적화(http://go.microsoft.com/fwlink/?LinkId=49324)를 참조하십시오.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


PhysicalDisk 성능 개체의 Average Disk sec/Read 카운터 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 PhysicalDisk 성능 개체의 Avg. Disk sec/Read 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 Avg. Disk sec/Read 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Avg. Disk sec/Read 성능 카운터에는 디스크에서 데이터를 읽는 평균 시간(초)이 표시됩니다. Avg. Disk sec/Read 성능 카운터의 평균 값은 10밀리초 미만이어야 합니다. Avg. Disk sec/Read 성능 카운터의 최대값은 50밀리초를 초과하지 않아야 합니다.

Disk Reads/sec 및 Disk Writes/sec 카운터에서 결과를 수집하면 Exchange Server에서 생성된 I/O가 시간에 따라 증가하고 있는지 또는 감소하고 있는지 확인할 수 있습니다. Avg. Disk sec/Read 및 Avg. Disk sec/Write 카운터에서 결과를 수집하면 저장소 대기 시간이 시간이 지남에 따라 변화했는지 확인할 수 있습니다. 예를 들면 다음 단계를 통해 저장소 처리량으로 인해 지체가 있는지 또는 앞으로 지체가 발생할지 예측할 수 있습니다.

  1. 월별, 매월 같은 날 및 매일 같은 시간 동안 측정합니다.

  2. 수집된 데이터를 분석합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


LogicalDisk 성능 개체의 Average Disk sec/Write 카운터 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터의 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 LogicalDisk 성능 개체의 Avg. Disk sec/Write 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 Avg. Disk sec/Write 성능 카운터에서 데이터를 수집하면 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Logical Disk 성능 개체는 하드 디스크의 논리 파티션을 모니터링하는 Avg. Disk sec/Write와 같은 카운터로 구성됩니다. Avg. Disk sec/Write 성능 카운터는 데이터를 디스크에 쓰는 데 걸리는 평균 시간(초)을 보여 줍니다. Avg. Disk sec/Write 성능 카운터의 평균 값은 10밀리초 미만이어야 합니다. Avg. Disk sec/Write 성능 카운터의 최대값은 50밀리초를 초과하지 않아야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer에서 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90% 위치에 있는 값입니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

Exchange Server 2003의 저장소 시스템을 최적화하는 방법에 대한 자세한 내용은 Microsoft TechNet 웹 사이트 Exchange Server 2003의 저장소 최적화(http://go.microsoft.com/fwlink/?LinkId=34649)를 참조하십시오.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


Average Disk sec/Write 카운터에 대한 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터의 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 Physical Disk 성능 개체의 Avg. Disk sec/Write 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer가 Avg. Disk sec/Write 성능 카운터에서 데이터를 수집하면 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Avg. Disk sec/Write 성능 카운터는 데이터를 디스크에 쓰는 데 걸리는 평균 시간(초)을 보여 줍니다. Avg. Disk sec/Write 성능 카운터의 평균 값은 10밀리초 미만이어야 합니다. Avg. Disk sec/Write 성능 카운터의 최대값은 50밀리초를 초과하지 않아야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer에서 수집한 모든 값을 오름차순으로 나열한 경우 90번째 백분위수는 목록에서 90% 위치에 있는 값입니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


DSAccess(Epoxy Client Out Queue Length) 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Epoxy 성능 개체의 Client Out Queue Length (DSAccess) 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 Client Out Queue Length (DSAccess) 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Client Out Queue Length (DSAccess) 성능 카운터는 Inetinfo.exe 프로세스에서 보낸 DSAccess(디렉터리 서비스 액세스) 메시지를 포함하는 큐의 메시지 수를 나타냅니다. 큐는 항상 10 개 미만이어야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


Epoxy Client Out Queue Length(SMTP) 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이트 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Epoxy 성능 개체의 Client Out Queue Length (SMTP) 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 Client Out Queue Length (SMTP) 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Client Out Queue Length (SMTP) 성능 카운터는 Inetinfo.exe 프로세스에서 보낸 SMTP(Simple Mail Transfer Protocol) 메시지를 포함하는 큐의 메시지 수를 나타냅니다. 메일 큐가 없는 경우 이 큐는 항상 50 미만이어야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


Epoxy Store Out Queue Length(DSAccess) 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Epoxy 성능 개체의 Store Out Queue Length(DSAccess) 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 Store Out Queue Length(DSAccess) 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Store Out Queue Length(DSAccess) 성능 카운터는 Store.exe 프로세스에서 보낸 디렉터리 서비스 액세스(DSAccess) 메시지가 포함된 큐의 메시지 수를 표시합니다. 큐 수는 항상 10개 미만이어야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


Epoxy Store Out Queue Length(SMTP) 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Epoxy 성능 개체의 Store Out Queue Length(SMTP) 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 Store Out Queue Length(SMTP) 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Store Out Queue Length(SMTP) 성능 카운터는 Store.exe 프로세스에서 보낸 SMTP(Simple Mail Transfer Protocol) 메시지가 포함된 큐의 메시지 수를 표시합니다. 메일 큐가 있는 경우를 제외하고 큐 수는 항상 50개 미만이어야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


RPC Averaged Latency 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeIS 성능 개체의 RPC Averaged Latency 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 RPC Averaged Latency 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

RPC Averaged Latency 성능 카운터는 지난 1,024 패킷에 대한 평균 원격 프로시저 호출(RPC) 대기 시간(밀리초)을 보여 줍니다. RPC Averaged Latency 성능 카운터의 최대값은 항상 50밀리초보다 작아야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


RPC Operations/sec 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이트 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeIS 성능 개체의 RPC Operations/sec 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 RPC Operations/sec 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

RPC Operations/sec 성능 카운터는 원격 프로시저 호출(RPC) 작업이 수행되는 속도를 표시합니다. 모든 MAPI 기반 작업에서 RPC 프로토콜을 사용하기 때문에 RPC Operations/sec 성능 카운터는 Exchange Server의 작업 부하를 측정하기에 좋은 카운터입니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


RPC Requests 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 MSExchangeIS 성능 개체의 RPC Requests 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer가 RPC Requests 성능 카운터에서 데이터를 수집하면 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

The RPC Requests 성능 카운터는 Microsoft Exchange Information Store 서비스가 현재 처리 중인 MAPI RPC(원격 프로시저 호출) 또는 클라이언트 요청 수를 나타냅니다. RPC Requests 성능 카운터의 평균 값은 항상 30 이하여야 합니다. 기본적으로 최대 RPC 요청 값은 100입니다. 따라서 다르게 구성된 경우에는 Microsoft Exchange Information Store 서비스가 클라이언트 요청을 거부하기 전에 100개 RPC 요청만 동시에 처리할 수 있습니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer에서 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90% 위치에 있는 값입니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


SMTP Categorizer Queue Length 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 SMTP Server 성능 개체의 Categorizer Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 분류기 큐에서 찾은 총 메시지 수를 보고합니다.

SMTP Server\Categorizer Queue Length 카운터는 SMTP(Simple Mail Transfer Protocol) 분류기 큐에서 글로벌 카탈로그 서버를 사용한 디렉터리 서비스 특성 검색을 대기 중인 메시지의 수를 나타냅니다. 일반적인 지침은 최대값이 10보다 작아야 한다는 것입니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

Categorizer Queue Length 카운터는 메시지 분류기 큐의 메시지 수를 나타냅니다. 분류기가 수행하는 핵심 작업은 다음과 같습니다.

  • 모든 받는 사람을 확인하고 유효성을 확인합니다.

  • 모든 받는 사람의 한계와 제한을 확인합니다.

  • 필요한 경우 메일 그룹을 확장합니다.

  • 메시지를 로컬 배달할지 아니면 원격 배달할지 확인합니다.

Categorizer Queue Length 카운터가 증가하면 서버 성능 문제, 디렉터리 서비스 액세스(DSAccess), Active Directory® 디렉터리 서비스 또는 Exchange Server 조직의 키 서버 중지 등의 잠재적인 문제가 있을 수 있음을 나타냅니다. Categorizer Queue Length 카운터 증가는 Active Directory 참조나 로컬 배달 또는 SMTP의 메시지 처리가 느려지거나 응답하지 않음을 나타냅니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


SMTP Local Queue Length 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 SMTP Server 성능 개체의 Local Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 SMTP(Simple Mail Transfer Protocol) 로컬 큐에 있는 총 메시지 수를 보고합니다.

SMTP Server\Local Queue Length 카운터는 SMTP 큐에서 로컬로 배달할 메시지 수를 나타냅니다. 일반적으로 최대값은 1,000보다 작아야 합니다. 큐에는 분산 범위가 작은 평균에 가깝게 남아 있어야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer에서 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90% 위치에 있는 값입니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

서버에서 적시에 수신 메일을 더 이상 배달할 수 없기 때문에 로컬 배달 큐에 메시지가 누적되는 경우는 서버의 성능 문제 또는 중지를 나타냅니다. 이러한 지연은 다음과 같은 조건 때문에 발생할 수 있습니다.

  • Active Directory® 디렉터리 서비스가 즉시 참조되지 않습니다.

  • 메시지가 로컬 배달 또는 SMTP에 대해 즉시 전달되지 않습니다.

  • 데이터베이스가 분리되었습니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


SMTP Remote Queue Length 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이트 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 SMTP Server 성능 개체의 Remote Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 SMTP(Simple Mail Transfer Protocol) 원격 큐에서 찾은 메시지의 총 메시지 수를 보고합니다.

SMTP Server\Remote Queue Length 카운터는 SMTP 큐에 있는 원격 배달용 메시지의 수를 나타냅니다. 일반적인 지침에 따르면 최대값은 1,000보다 작아야 합니다. 큐는 평균 값 근처에서 큰 편차 없이 일정하게 유지해야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

원격 큐 길이가 증가하면 메일을 다른 서버로 보내지 못했음을 나타냅니다. 이러한 메일 보내기 오류는 네트워크 또는 원격 서버의 고장이나 성능 문제를 나타냅니다. 고장이나 성능 문제가 발생하면 네트워크 또는 원격 서버에서 메일을 효과적으로 받을 수 없습니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


Virus Scan Queue Length 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeIS 성능 개체의 Virus Scan Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 Virus Scan Queue Length 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Virus Scan Queue Length 성능 카운터는 바이러스 검색을 위해 대기 중인 현재 해결되지 않은 요청 수를 표시합니다 이 카운터의 권장 값은 사용자 조직에 따라 다릅니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


Log Record Stalls/sec 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Database 성능 개체의 Log Record Stalls/sec 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 Log Record Stalls/sec 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Log Record Stalls/sec 성능 카운터는 로그 버퍼가 꽉 찼기 때문에 로그 버퍼에 초당 추가할 수 없는 로그 레코드 수를 보여 줍니다. Log Record Stalls/sec 성능 카운터의 평균 값은 초당 10 미만입니다. 최대값은 초당 100을 초과해서는 안 됩니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


Log Threads Waiting 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이트 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Database 성능 개체의 Log Threads Waiting 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 Log Threads Waiting 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Log Threads Waiting 성능 카운터는 데이터를 로그에 써 데이터베이스 업데이트를 완료하려고 대기 중인 스레드 수를 표시합니다. Log Threads Waiting 성능 카운터 값이 너무 높으면 로그 때문에 다른 트랜잭션 처리가 지연될 수 있습니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


Pages/sec 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터의 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 Memory 성능 개체의 Pages/sec 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer가 Pages/sec 성능 카운터에서 데이터를 수집하면 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Pages/sec 성능 카운터는 하드 페이지 부재를 해결하기 위해 디스크에서 페이지를 읽거나 쓰는 속도를 표시합니다. 이 카운터는 시스템 전체의 지연을 초래하는 부재 유형의 기본 표시기입니다. 이 카운터에는 파일 시스템 캐시의 페이지 부재를 충족하도록 검색된 페이지가 포함됩니다. 이러한 페이지는 일반적으로 응용 프로그램에서 요청합니다. 이 카운터는 항상 1,000개 이하여야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer에서 수집한 모든 값을 오름차순으로 나열한 경우 90번째 백분위수는 목록에서 90% 위치에 있는 값입니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


% Processor Time 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 Processor 성능 개체의 % Processor Time 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer가 % Processor Time 성능 카운터에서 데이터를 수집하면 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

% Processor Time 성능 카운터는 프로세서가 유휴 상태가 아닌 스레드를 실행하는 데 걸린 시간의 백분율을 표시합니다. 이 카운터를 사용하여 프로세서의 총 사용률을 모니터링하거나 프로세서당 사용률을 모니터링할 수 있습니다. 평균 CPU 사용률은 항상 90% 이하여야 합니다.

참고:
Exchange Server Analyzer에서 표시하는 % Processor Time은 검색된 실제 및 논리 CPU 모두의 총 수를 기반으로 하여 CPU 수의 합으로 나눈 집계 값입니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer에서 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90% 위치에 있는 값입니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


Bytes Total/sec 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Network Interface 성능 개체의 Bytes Total/sec 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 Bytes Total/sec 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

Bytes Total/sec 성능 카운터에는 네트워크 어댑터가 데이터 바이트를 처리하고 있는 속도가 표시됩니다. 이 카운터에는 모든 응용 프로그램, 파일 데이터 및 패킷 헤더 같은 프로토콜 정보가 포함됩니다. 1000Mbps(메가비트/초) 네트워크 어댑터의 경우 Bytes Total/sec 성능 카운터의 값은 7메가바이트/초 이하여야 합니다. 1000Mbps 네트워크 어댑터의 경우 Bytes Total/sec 성능 카운터의 값은 70메가바이트/초보다 작아야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


LDAP Read Time 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-06

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 MSExchangeDSAccess Process 성능 개체의 LDAP Read Time 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 LDAP Read Time 성능 카운터에서 데이터를 수집하면 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

LDAP Read Time 성능 카운터는 LDAP(Lightweight Directory Access Protocol) 읽기 요청이 수행되는 데 걸리는 시간(밀리초)을 표시합니다. 평균 값은 50밀리초 이하여야 합니다. 최대값은 100밀리초를 초과하지 않아야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer에서 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90% 위치에 있는 값입니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


LDAP Search Time 카운터의 성능 데이터입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeDSAccess Processes 성능 개체의 LDAP Search Time 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. Exchange Server Analyzer는 LDAP Search Time 성능 카운터에서 데이터를 수집하는 경우 수집된 데이터에 대한 정보를 기본 정보로 표시합니다.

LDAP Search Time 성능 카운터는 LDAP(Lightweight Directory Access Protocol) 검색 요청을 만족시키는 데 걸리는 시간(밀리초)을 표시합니다. 평균 값은 50밀리초보다 작아야 합니다. 최대값은 100밀리초를 넘지 않아야 합니다.

기본적으로 Exchange Server Analyzer는 두 시간 동안 30초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 동안의 성능 카운터 최대값을 보고합니다. Exchange Server Analyzer는 수집된 모든 값 중 90번째 백분위수에 해당하는 값도 보고합니다.

참고:
Exchange Server Analyzer가 수집한 모든 값을 오름차순으로 나열하는 경우 90번째 백분위수는 목록에서 90퍼센트 위치의 값이 됩니다. 90번째 백분위수 값은 수집 기간 중 이 카운터의 높은 값을 나타냅니다.

일부 인스턴스에서는 수집 기간 중 사용량이 가장 많은 시점의 값이 최대값이 됩니다. 따라서 최대값이 해당 기간 전체를 나타내는 것은 아닙니다. 중간값은 수집 기간 중의 유휴 시간을 포함하므로 로드를 항상 정확하게 나타내지는 않습니다. 따라서 Exchange Server Analyzer는 최대값과 90번째 백분위수 값을 보고합니다.

이 기본 메시지의 내용은 정보 제공의 목적으로만 제공됩니다. 특별한 조치가 필요 없습니다.

제안된 성능 카운터 임계값에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


PhysicalDisk 성능 모니터 개체를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 PhysicalDisk 성능 개체의 Avg. Disk sec/Read 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. 카운터에서 올바른 데이터가 반환되지 않으면 Exchange Server Analyzer는 기본 메시지를 표시합니다.

다음과 같은 상황에서는 성능 데이터 수집 엔진에서 올바른 데이터가 반환되지 않습니다.

  • PhysicalDisk 성능 개체를 사용하지 않습니다.

  • PhysicalDisk 성능 모니터 개체가 없거나 손상되었습니다.

  • 성능 개체에 액세스할 수 있는 적절한 권한이 Exchange Server Analyzer에 없습니다.

맨 앞의 두 가지 상황은 확장 가능한 특정 카운터가 레지스트리를 손상시키거나 Microsoft WMI(Windows® Management Instrumentation) 기반 프로그램에서 레지스트리를 수정하는 경우에 발생할 수 있습니다. 다음 절차에서는 맨 앞의 두 가지 상황을 해결하는 방법을 설명합니다. 해당 절차를 수행하기 전에 Exchange Server Analyzer에 적절한 권한이 있는지 확인합니다. Exchange Server Analyzer를 실행하는 데 필요한 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말을 참조하십시오. 도움말을 보려면 Exchange Server Analyzer를 열고 F1 키를 누르십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. PhysicalDisk 성능 개체를 사용하는지 확인합니다.

    1. Extensible Performance Counter List 도구(Exctrlst.exe)를 다운로드하고 설치합니다. Microsoft 웹 사이트 "Exctrlst.exe: Extensible Performance Counter List"(http://go.microsoft.com/fwlink/?LinkId=34436)에서 Exctrlst.exe를 다운로드할 수 있습니다.

    2. Exctrlst.exe를 열고 Sort Order와 Service를 차례로 클릭합니다.

    3. 성능 개체가 보고하는 서비스를 찾아 Performance Counters Enabled 확인란이 선택되었는지 확인합니다.

      Performance Counters Enabled 확인란이 선택되지 않았으면 이 확인란을 선택한 다음 성능 카운터에 연결된 서비스를 다시 시작하여 성능 카운터가 작동하는지 확인합니다. 성능 카운터가 작동하지 않거나 Performance Counters Enabled 확인란이 이미 선택되어 있으면 2단계로 넘어갑니다.

  2. Microsoft 기술 자료 문서 300956, "성능 카운터 라이브러리 값을 수동으로 다시 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956)에 지정된 대로 누락되거나 손상된 성능 카운터를 다시 빌드합니다.

  3. 이 기술 자료 문서에 따라 수행해도 문제가 해결되지 않으면 Windows 운영 체제를 복구 모드로 다시 설치한 다음 최신 Windows 서비스 팩을 적용해야 합니다.


포트 충돌: 사이트 복제 서비스
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 포트 충돌이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP 값이 이 문서의 앞부분에 나열된 다른 여섯 개의 포트 레지스트리 값에 지정된 값 중 어느 하나와 일치하는 경우 오류를 표시합니다. Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP와 충돌하는 포트에 대해서도 오류를 표시합니다.

이 오류를 해결하려면 Exchange Server Analyzer 출력에 지정된 충돌 키 또는 이 키의 값을 고유한 값으로 변경해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP 레지스트리 매개 변수를 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters를 탐색합니다.

  3. TCP/IP 키를 두 번 클릭하고 값 데이터 필드를 5000(10진수)보다 큰 고유한 값으로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

RPC over HTTP를 배포하려면 다음을 수행합니다.

  1. "Exchange Server 2003 RPC over HTTP 배포 시나리오"(http://go.microsoft.com/fwlink/?linkid=47577)를 검토하십시오.

  2. Microsoft 기술 자료 문서 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)을 검토하십시오.

  3. 기술 자료 문서 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)을 검토하십시오.

  4. Microsoft 기술 지원 웹캐스트, "웹캐스트: Microsoft Office Outlook 2003에서 인터넷(RPC/HTTP)을 통해 Microsoft Exchange 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)을 검토하십시오.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange에서 사용하는 정적으로 매핑된 포트에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 194952, "XADM: Statically Mapped Port Limitations for Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)

  • 270836, "XCLN: Exchange 2000 및 Exchange 2003 정적 포트 매핑"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)


포트 충돌: 저장소 HTTP
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-21

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 포트 충돌이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

레지스트리 Rpc/HTTP Port 키는 Exchange에서 Microsoft Office Outlook® 2003 RPC/HTTP 및 Exchange Server 2007 Outlook Anywhere 기능을 지원하는 데 사용됩니다. Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port 값이 이 문서의 앞부분에 나열된 다른 여섯 개의 포트 레지스트리 값에 지정된 값 중 어느 하나와 일치하는 경우 오류를 표시합니다. Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port와 충돌하는 포트에 대해서도 오류를 표시합니다.

이 오류를 해결하려면 Exchange Server Analyzer 출력에 지정된 충돌 키 또는 이 키의 값을 고유한 값으로 변경해야 합니다.

RPC/HTTP Outlook 2003 또는 Outlook 2007 클라이언트를 지원하는 경우 Rpc/HTTP Port 키 값을 10진수 6001로 설정해야 합니다. 또한 사용 중인 환경의 RPC/HTTP 구성을 검토해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Rpc/HTTP 포트 레지스트리 값을 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters를 탐색합니다.

  3. Rpc/HTTP Port 키를 두 번 클릭하고 값 데이터 필드를 5000(10진수)보다 큰 고유한 값으로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

RPC over HTTP 구성을 검토하려면 다음을 수행합니다.

  1. "Exchange Server 2003 RPC over HTTP 배포 시나리오"(http://go.microsoft.com/fwlink/?linkid=47577)를 검토하십시오.

  2. "Deploying Outlook Anywhere"(http://go.microsoft.com/fwlink/?LinkId=80831)를 검토하십시오.

  3. Microsoft 기술 자료 문서 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)을 검토하십시오.

  4. 기술 자료 문서 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)을 검토하십시오.

  5. Microsoft 기술 지원 웹캐스트, "웹캐스트: Microsoft Office Outlook 2003에서 인터넷(RPC/HTTP)을 통해 Microsoft Exchange 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)을 검토하십시오.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


포트 충돌: 저장소 TCP
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-30

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 포트 충돌이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port 값이 이 문서의 앞부분에 나열된 다른 여섯 개의 포트 레지스트리 값에 지정된 값 중 어느 하나와 일치하는 경우 오류를 표시합니다. Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port와 충돌하는 포트에 대해서도 오류를 표시합니다.

일반적으로 MAPI 클라이언트가 방화벽의 다른 쪽에 있는 Exchange 서버에 연결할 수 있도록 하기 위해 이 값이 구성됩니다. 이를 위해서는 방화벽의 포트를 여러 개 열어서 Microsoft Office Outlook® 2003 또는 Outlook 2007 클라이언트가 MAPI를 사용하여 인터넷을 통해 Exchange 서버에 연결할 수 있도록 해야 합니다.

MAPI 모드에서 Outlook을 사용하여 인터넷을 통해 Exchange 서버에 연결할 때 권장되는 배포 방법은 Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 및 Microsoft Windows® XP Professional에서 제공하는 RPC over HTTP 기능을 사용하는 것입니다. 전에는 MAPI 모드를 "회사" 또는 "작업 그룹" 모드라고 했습니다.

이 오류를 해결하려면 Exchange Server Analyzer 출력에 지정된 충돌 키 또는 이 키의 값을 고유한 값으로 변경해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP 포트 레지스트리 값을 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. TCP/IP Port 키를 두 번 클릭하고 값 데이터 필드를 5000(10진수)보다 큰 고유한 값으로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

RPC over HTTP를 배포하려면 다음을 수행합니다.

  1. "Exchange Server 2003 RPC over HTTP 배포 시나리오"(http://go.microsoft.com/fwlink/?linkid=47577)를 검토하십시오.

  2. "Deploying Outlook Anywhere"(http://go.microsoft.com/fwlink/?LinkId=80831)를 검토하십시오.

  3. Microsoft 기술 자료 문서 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)을 검토하십시오.

  4. 기술 자료 문서 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)을 검토하십시오.

  5. Microsoft 기술 지원 웹캐스트, "웹캐스트: Microsoft Office Outlook 2003에서 인터넷(RPC/HTTP)을 통해 Microsoft Exchange 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)을 검토하십시오.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange에서 사용하는 정적으로 매핑된 포트에 대한 자세한 내용은 Microsoft 기술 자료 문서 270836, "Exchange 2000 및 Exchange 2003 정적 포트 매핑"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)을 참조하십시오.


포트 충돌: 시스템 수행자 HTTP
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-21

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 포트 충돌이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

HTTP Port 키는 Exchange에서 Microsoft Office Outlook® 2003 RPC/HTTP 및 Exchange Server 2007 Outlook Anywhere 기능을 지원하는 데 사용됩니다. Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port 값이 이 문서의 앞부분에 나열된 다른 여섯 개의 포트 레지스트리 값에 지정된 값 중 어느 하나와 일치하는 경우 오류를 표시합니다. 또한 Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port와 충돌하는 포트에 대해서도 오류를 표시합니다.

이 오류를 해결하려면 Exchange Server Analyzer 출력에 지정된 충돌 키 또는 이 키의 값을 고유한 값으로 변경해야 합니다.

RPC/HTTP Outlook 2003 또는 Outlook 2007 클라이언트를 지원하는 경우 HTTP Port 키 값을 10진수 6002로 설정해야 합니다. 또한 사용 중인 환경의 RPC/HTTP 구성을 검토해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

HTTP Port 레지스트리 값을 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. HTTP Port 키를 두 번 클릭하고 값 데이터 필드를 5000(10진수)보다 큰 고유한 값으로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

RPC over HTTP 구성을 검토하려면 다음을 수행합니다.

  1. "Exchange Server 2003 RPC over HTTP 배포 시나리오"(http://go.microsoft.com/fwlink/?linkid=47577)를 검토하십시오.

  2. "Deploying Outlook Anywhere"(http://www.microsoft.com/technet/prodtechnol/exchange/e2k7help/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx)를 검토하십시오.

  3. Microsoft 기술 자료 문서 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)을 검토하십시오.

  4. 기술 자료 문서 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)을 검토하십시오.

  5. Microsoft 기술 지원 웹캐스트, "웹캐스트: Microsoft Office Outlook 2003에서 인터넷(RPC/HTTP)을 통해 Microsoft Exchange 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)을 검토하십시오.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


포트 충돌: 시스템 수행자 HTTP NSPI
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-30

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 포트 충돌이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

레지스트리 Rpc/HTTP NSPI Port 키는 Exchange에서 Microsoft Office Outlook® 2003 RPC/HTTP 및 Exchange Server 2007 Outlook Anywhere 기능을 지원하는 데 사용됩니다. Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port 값이 이 문서의 앞부분에 나열된 다른 여섯 개의 포트 레지스트리 값에 지정된 값 중 어느 하나와 일치하는 경우 오류를 표시합니다. Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\ Rpc/HTTP NSPI Port와 충돌하는 포트에 대해서도 오류를 표시합니다.

이 오류를 해결하려면 Exchange Server Analyzer 출력에 지정된 충돌 키 또는 이 키의 값을 고유한 값으로 변경해야 합니다.

RPC/HTTP Outlook 2003 클라이언트 또는 Outlook 2007을 지원하는 경우 Rpc/HTTP NSPI Port 키 값을 10진수 값 6004로 설정해야 합니다. 또한 사용 중인 환경의 RPC/HTTP 구성을 검토해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Rpc/HTTP NSPI Port 레지스트리 값을 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. Rpc/HTTP NSPI Port 키를 두 번 클릭하고 값 데이터 필드를 5000(10진수)보다 큰 고유한 값으로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

RPC over HTTP 구성을 검토하려면 다음을 수행합니다.

  1. "Exchange Server 2003 RPC over HTTP 배포 시나리오"(http://go.microsoft.com/fwlink/?linkid=47577)를 검토하십시오.

  2. "Deploying Outlook Anywhere"(http://go.microsoft.com/fwlink/?LinkId=80831)를 검토하십시오.

  3. Microsoft 기술 자료 문서 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)을 검토하십시오.

  4. 기술 자료 문서 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)을 검토하십시오.

  5. Microsoft 기술 지원 웹캐스트, "웹캐스트: Microsoft Office Outlook 2003에서 인터넷(RPC/HTTP)을 통해 Microsoft Exchange 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)을 검토하십시오.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


포트 충돌: 시스템 수행자 NSPI
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-21

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 포트 충돌이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port 값이 이 문서의 앞부분에 나열된 다른 여섯 개의 포트 레지스트리 값에 지정된 값 중 어느 하나와 일치하는 경우 오류를 표시합니다. Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port와 충돌하는 포트에 대해서도 오류를 표시합니다.

일반적으로 MAPI 클라이언트가 방화벽의 다른 쪽에 있는 Exchange 서버에 연결할 수 있도록 하기 위해 이 값이 구성됩니다. 이를 위해서는 방화벽의 포트를 여러 개 열어서 Microsoft® Office Outlook® 2003 및 Outlook 2007 클라이언트가 MAPI를 사용하여 인터넷을 통해 Exchange 서버에 연결할 수 있도록 해야 합니다.

MAPI 모드에서 Outlook을 사용하여 인터넷을 통해 Exchange 서버에 연결할 때 권장되는 배포 방법은 Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 및 Microsoft Windows® XP Professional에서 제공하는 RPC over HTTP 기능을 사용하는 것입니다. 전에는 MAPI 모드를 "회사" 또는 "작업 그룹" 모드라고 했습니다.

이 오류를 해결하려면 Exchange Server Analyzer 출력에 지정된 충돌 키 또는 이 키의 값을 고유한 값으로 변경해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP NSPI 포트 레지스트리 값을 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. TCP/IP NSPI Port 키를 두 번 클릭하고 값 데이터 필드를 5000(10진수)보다 큰 고유한 값으로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

RPC over HTTP를 배포하려면 다음을 수행합니다.

  1. "Exchange Server 2003 RPC over HTTP 배포 시나리오"(http://go.microsoft.com/fwlink/?linkid=47577)를 검토하십시오.

  2. "Deploying Outlook Anywhere"(http://go.microsoft.com/fwlink/?LinkId=80831)를 검토하십시오.

  3. Microsoft 기술 자료 문서 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)을 검토하십시오.

  4. 기술 자료 문서 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)을 검토하십시오.

  5. Microsoft 기술 지원 웹캐스트, "웹캐스트: Microsoft Office Outlook 2003에서 인터넷(RPC/HTTP)을 통해 Microsoft Exchange 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)을 검토하십시오.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange에서 사용하는 포트를 정적으로 매핑하는 방법에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 270836, "XCLN: Exchange 2000 및 Exchange 2003 정적 포트 매핑"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)


포트 충돌: 시스템 수행자 RFR
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-30

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 포트 충돌이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port 값이 이 문서의 앞부분에 나열된 여섯 개의 다른 포트 레지스트리 값에 지정된 값 중 어느 하나와 일치하는 경우 오류를 표시합니다. Exchange Server Analyzer는 HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port와 충돌하는 포트에 대한 오류도 표시합니다.

일반적으로 MAPI 클라이언트가 방화벽의 다른 쪽에 있는 Exchange 서버에 연결할 수 있도록 하기 위해 이 값이 구성됩니다. 이를 위해서는 방화벽의 포트를 여러 개 열어서 Microsoft Office Outlook® 2003 또는 Outlook 2007 클라이언트가 MAPI를 사용하여 인터넷을 통해 Exchange 서버에 연결할 수 있도록 해야 합니다.

MAPI 모드에서 Outlook을 사용하여 인터넷을 통해 Exchange 서버에 연결할 때 권장되는 배포 방법은 Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 및 Microsoft Windows® XP Professional에서 제공하는 RPC over HTTP 기능을 사용하는 것입니다. 전에는 MAPI 모드를 "회사" 또는 "작업 그룹" 모드라고 했습니다.

이 오류를 수정하려면 Exchange Server Analyzer 출력에 명시되는 충돌 키 또는 이 키의 값을 고유한 값으로 변경해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP 포트 레지스트리 값을 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. TCP/IP Port 키를 두 번 클릭하고 값 데이터 필드를 5000(10진수)보다 큰 고유한 값으로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

RPC over HTTP를 배포하려면 다음을 수행합니다.

  1. "Exchange Server 2003 RPC over HTTP 배포 시나리오"(http://go.microsoft.com/fwlink/?linkid=47577)를 검토하십시오.

  2. "Deploying Outlook Anywhere"(http://go.microsoft.com/fwlink/?LinkId=80831)를 검토하십시오.

  3. Microsoft 기술 자료 문서 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)을 검토하십시오.

  4. 기술 자료 문서 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)을 검토하십시오.

  5. Microsoft 기술 지원 웹캐스트, "웹캐스트: Microsoft Office Outlook 2003에서 인터넷(RPC/HTTP)을 통해 Microsoft Exchange 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)을 검토하십시오.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange에서 사용하는 정적으로 매핑된 포트에 대한 자세한 내용은 Microsoft 기술 자료 문서 270836, "Exchange 2000 및 Exchange 2003 정적 포트 매핑"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)을 참조하십시오.


시험판 서비스 팩 업데이트 롤업이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer는 Active Directory® 디렉터리 서비스를 쿼리하여 각 Exchange 서버 개체의 versionNumber 특성 값을 확인합니다. versionNumber 특성은 해당 컴퓨터에서 실행 중인 Exchange Server의 버전을 나타냅니다.

또한 Exchange Server Analyzer는 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 ExCDO(Exchange Collaboration Data Object) 라이브러리 파일인 ExCDO.dll에 대한 Version 키 값을 확인합니다. ExCDO.dll의 Version 키 값이 6603.0과 같으면 Exchange Server Analyzer에서 경고를 표시합니다.

6603.0 버전의 ExCDO.dll을 실행 중인 Exchange 2000 Server 컴퓨터의 경우 2004년 8월 버전 1 Exchange 2000 Server SP3(서비스 팩 3 이후) 업데이트 롤업이 실행되고 있는 것입니다. 이제 이 업데이트 롤업의 버전 2를 사용할 수 있습니다. 2004년 8월 업데이트 롤업을 설치하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Microsoft 기술 자료 문서 870540, "Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540을 검토하여 최신 업데이트에 대해 알아보십시오.

  2. "Exchange 2000 Server용 다운로드"(http://go.microsoft.com/fwlink/?LinkId=33457)에서 최신 업데이트(2004년 8월)를 다운로드합니다.

  3. Exchange Server 컴퓨터를 백업합니다.

  4. 2004년 8월 업데이트 롤업을 적용합니다.

Exchange 2000 Server용 최신 서비스 팩을 구하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 301378, "최신 Exchange 2000 Server 서비스 팩을 구하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)을 참조하십시오.

이 Exchange Server 업데이트와 다른 Exchange Server 업데이트의 설치에 대한 자세한 내용은 기술 자료 문서 328839, "Exchange 서비스 팩 및 핫픽스를 적용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)을 참조하십시오.


페이지 파일 위치에 문제가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에서 페이지 파일이 서버 성능에 부정적인 영향을 미칠 수 있는 위치에 있음을 확인했습니다. 페이지 파일은 Exchange 데이터베이스나 Exchange 로그 파일과 같은 디스크에 있지 않아야 합니다. 또한 페이지 파일을 시스템 파일과 격리하는 것이 좋습니다.

페이지 파일은 전용 파티션이나 고속 디스크에 배치하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  • 페이지 파일을 Exchange 데이터베이스 또는 로그 파일이 없는 위치로 옮기거나 가능한 경우 시스템 파티션이 없는 위치로 옮깁니다.

추가 정보

  • 페이지 파일 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 197379, "Windows Server 2003, Windows 2000 및 Windows NT에서 최적화와 복구를 위한 페이지 파일 구성"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=197379)을 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


프로세서 지체
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-24

Microsoft® Exchange Server Analyzer Tool은 서버에 CPU 지체가 발생했음을 확인했습니다. 서버의 CPU 사용률이 권장 임계값을 초과했습니다. 프로세서 지체 또는 프로세서 사용률 문제를 식별하는 데 사용되는 카운터는 다음과 같습니다.

  • System 성능 개체의 Context Switches/sec 성능 카운터

  • Processor 성능 개체의 % Processor Time (_Total) 성능 카운터

  • System 성능 개체의 Processor Queue Length 성능 카운터

프로세서 지체 감지

다음 조건 중 하나라도 해당되는 경우 Exchange Server Analyzer가 지체를 감지한 것입니다.

  • Process 성능 개체의 평균 % Processor Time (_Total) 성능 카운터가 70%보나 큰 경우

  • Process 성능 개체의 최대 % Processor Time (_Total) 성능 카운터가 90%보나 큰 경우

  • System 성능 개체의 평균 Context Switches/second 성능 카운터가 20,000보다 큰 경우

  • System 성능 개체의 Processor Queue Length 성능 카운터가 2보다 큰 경우

  • 이러한 Process 성능 개체의 % Processor Time (_Total) 성능 카운터는 전체 프로세서 사용률을 제공합니다. 평균 CPU 사용률은 항상 80% 미만이어야 합니다. 평균 사용률이 높으면 프로세서 지체가 발생한 것입니다. 평균 프로세서 사용률이 70%보다 클 경우 경고가 표시됩니다. 프로세서 시간의 최대 사용률이 90%를 넘는 경우가 자주 발생하면 프로세서 지체가 발생한 것입니다.

  • System 성능 개체의 Processor Queue Length 성능 카운터는 프로세서 큐의 스레드 수를 나타냅니다. 프로세서가 여러 개인 컴퓨터라해도 프로세서 시간의 큐는 단일합니다. 2보다 큰 수는 스레드가 프로세서 시간을 대기 중이며 프로세서 지체가 발생했음을 의미합니다.

프로세서 로드의 소스 확인

프로세서 지체가 발생하는 경우 CPU 사용률이 가장 많이 발생하는 곳을 확인해야 합니다. Exchange 백 엔드 서버에서 CPU 사용률의 대부분은 Store.exe 프로세스에서 발생해야 합니다. CPU 사용률의 20% 이상이 Store.exe 이외의 프로세스에서 발생할 경우 CPU 사용률을 소비하고 있는 다른 프로세스를 찾아야 합니다.

아래 표에 나열된 프로세스의 CPU 사용률이 임계값보다 높을 경우 Exchange Server Analyzer는 오류를 표시합니다.

프로세스 | Process 성능 개체의 %Processor Time 성능 카운터 임계값
저장소 | 90%
Inetinfo | 20%
Emsmts | 40%
Lsass | 40%
System | 40%
Mad | 40%
ExMGMT | 20%
W3WP | 40%

또한 Exchange Server Analyzer는 Process 성능 개체의 %Processor Time 성능 카운터(Idle 인스턴스) 및 %Processor Time 성능 카운터(_Total 인스턴스)에서 측정하는 유휴 상태인 프로세서 시간 간의 차이를 측정하기도 합니다. 정상적인 Exchange 백 엔드 서버에서 사용 중인 프로세서 시간의 최소 70%는 Store.exe 프로세스에 속해야 합니다.

Exchange Server Analyzer는 다음 조건에서 오류를 표시합니다.

  • Exchange 서버(Store.exe, inetinfo.exe, emsmta.exe, lsass.exe, w3wp.exe, exmgmt.exe 또는 mad.exe processes)와 관련된 프로세스에서 사용하지 않는 프로세서 시간이 35%보다 큰 경우

  • Exchange와 관련이 없는 프로세서 시간이 20%보다 큰 경우

  • 프로세서 지체 현상이 있고 프로세서 시간의 70% 미만이 Store.exe 프로세스에 속하는 경우

위의 모든 경우에 대해 서버의 CPU 시간을 소비하는 다른 프로세스를 찾는 것이 좋습니다.

백 엔드 서버에서 프로세서 지체의 일반적인 원인

성능 지체의 원인으로는 다음을 포함하여 여러 가지 원인이 있을 수 있습니다.

  • CPU 사용률을 소비하는 서버의 다른 응용 프로그램

  • 높은 RPC 비율

  • 메일 그룹 확장

  • 작업량이 많은 시간 동안 실행하는 백업 및 유지 관리

  • 메시지에서 메시지 내용 변환의 원인:

    • 다중 프로토콜 실행(예: HTTP, POP3, IMAP4, Microsoft Office Outlook®)

    • 오프라인 폴더(.ost 파일)를 사용하는 Outlook 2000 이전 버전

프로세서 지체 문제 제거

Exchange 서버에서 프로세서 지체 문제를 제거하는 여러 가지 방법이 있습니다.

프로세서 지체 문제를 제거하려면 다음을 수행합니다.

  • 가능하면 서버에 더 많은 프로세서나 속도가 빠른 프로세서를 추가합니다. 또한 프로세서에서 하이퍼 스레딩을 지원할 경우 해당 기능을 사용합니다. 시스템 BIOS를 구성하여 하이퍼 스레딩을 사용할 수 있습니다. 자세한 내용은 컴퓨터 제조업체의 도움말을 참조하십시오.

  • 처리 성능 향상이 가능한 옵션이 아닐 경우에는 프로세서의 로드를 줄여야 합니다. 서버에 대한 전반적인 영향을 줄이려면 I/O, CPU를 많이 사용하거나 메모리를 소비하는 작업은 정상적인 작업 시간을 초과하게 됨을 주의해야 합니다.

    먼저 서버의 로드를 발생시키는 응용 프로그램이나 작업을 식별합니다. Exchange가 아닌 응용 프로그램이 해당 서버에서 중요하지 않은 경우에는 다른 서버로 이동하십시오. 가능하면 서버 역할도 다른 컴퓨터로 이동하십시오. 예를 들어 Inetinfo 프로세스가 많은 CPU 사용률을 차지하는 경우 프런트 엔드 서버를 추가하여 Inetinfo가 수행하는 프로토콜 작업을 수행하게 합니다. 공용 폴더 액세스를 전용 공용 폴더 서버로 이동할 수도 있습니다. 마지막으로 서버가 다량의 메일 그룹 확장을 수행하는 경우에는 메일 그룹 확장을 전용 메일 그룹 확장 서버로 이동하여 CPU 사용률을 줄일 수 있습니다.

  • 백업 및 유지 관리 작업과 같은 CPU를 많이 사용하는 작업은 사용량이 적은 시간에 이루어져야 합니다. 또한 이러한 작업은 단계적인 방식으로 수행해야 합니다. 작업을 단계적으로 수행하는 것은 각 작업에 대해 시작 시간 및 가능하다면 종료 시간도 다르게 설정하는 것을 의미합니다. 또한 데이터베이스 또는 저장소 그룹의 유지 관리 및 백업을 단계적으로 수행하함으로써 리소스를 많이 사용하는 이와 같은 작업의 영향을 줄입니다.

  • 로드의 모든 선택적인 소스를 제거한 경우에도 CPU 사용률이 여전히 높다면 사용자를 다른 서버로 이동시켜 로드를 줄여야 합니다. 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.

자세한 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 사용자 사서함을 이동하여 서버 로드를 줄이는 방법에 대한 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.


프로세서 성능 모니터 개체를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이트 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Processor 성능 개체의 % Processor Time 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. 카운터에서 올바른 데이터가 반환되지 않으면 Exchange Server Analyzer는 기본 메시지를 표시합니다.

다음과 같은 상황에서는 성능 데이터 수집 엔진에서 올바른 데이터가 반환되지 않습니다.

  • Processor 성능 개체를 사용하지 않습니다.

  • Processor 성능 모니터 개체가 없거나 손상되었습니다.

  • 성능 개체에 액세스할 수 있는 적절한 권한이 Exchange Server Analyzer에 없습니다.

맨 앞의 두 가지 상황은 확장 가능한 특정 카운터가 레지스트리를 손상시키거나 Microsoft WMI(Windows® Management Instrumentation) 기반 프로그램에서 레지스트리를 수정하는 경우에 발생할 수 있습니다. 다음 절차에서는 맨 앞의 두 가지 상황을 해결하는 방법을 설명합니다. 해당 절차를 수행하기 전에 Exchange Server Analyzer에 적절한 권한이 있는지 확인합니다. Exchange Server Analyzer를 실행하는 데 필요한 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말을 참조하십시오. 도움말을 보려면 Exchange Server Analyzer를 열고 F1 키를 누르십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Processor 성능 개체를 사용하는지 확인합니다.

    1. Extensible Performance Counter List 도구(Exctrlst.exe)를 다운로드하고 설치합니다. Exctrlst.exe: Extensible Performance Counter List(http://go.microsoft.com/fwlink/?LinkId=34436)에서 Exctrlst.exe를 다운로드할 수 있습니다.

    2. Exctrlst.exe를 열고 Sort Order와 Service를 차례로 클릭합니다.

    3. 성능 개체가 보고하는 서비스를 찾아 Performance Counters Enabled 확인란이 선택되었는지 확인합니다.

      Performance Counters Enabled 확인란이 선택되지 않았으면 이 확인란을 선택한 다음 성능 카운터에 연결된 서비스를 다시 시작하여 성능 카운터가 작동하는지 확인합니다. 성능 카운터가 작동하지 않거나 Performance Counters Enabled 확인란이 이미 선택되어 있으면 2단계로 넘어갑니다.

  2. Microsoft 기술 자료 문서 300956, "성능 카운터 라이브러리 값을 수동으로 다시 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956)에 지정된 대로 누락되거나 손상된 성능 카운터를 다시 빌드합니다.

  3. 이 기술 자료 문서에 따라 수행해도 문제가 해결되지 않으면 Windows 운영 체제를 복구 모드로 다시 설치한 다음 최신 Windows 서비스 팩을 적용해야 합니다.


공용 폴더 내용 복제가 일시 정지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 조직에 heuristics 특성이 설정되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 heuristics에 해당 1024비트가 설정되어 있는 경우 경고를 표시합니다.

Exchange Server 2003, SP2에는 관리자가 조직에서 모든 공용 폴더 내용 복제를 중지하는 기능이 도입되었습니다. Exchange 시스템 관리에서 조직 이름을 마우스 오른쪽 단추로 클릭하고 공용 폴더 내용 복제 중지를 클릭하면 모든 공용 폴더 복제를 중지할 수 있습니다. 공용 폴더 내용 복제 중지를 클릭하면 heuristics 특성에 1024비트가 설정됩니다. 조직 전체의 공용 폴더 또는 메일 흐름 문제를 해결하는 등의 극단적인 경우에만 모든 공용 폴더 복제를 중지해야 합니다.

다음 조건에 해당하는 경우에는 공용 폴더 내용 복제를 다시 시작해야 합니다.

  • 문제를 해결하고 있지 않습니다.

  • 모든 공용 폴더 내용 복제를 중지할 필요가 없습니다.

조직 수준에서 공용 폴더 내용 복제를 다시 시작하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. Organization_Name을 마우스 오른쪽 단추로 클릭한 다음 공용 폴더 내용 복제 다시 시작을 클릭합니다.

공용 폴더 복제에 대한 자세한 내용은 Best Practices for Exchange Server Public Folders(http://go.microsoft.com/fwlink/?LinkId=46437)를 참조하십시오.


공용 폴더 저장소가 프런트 엔드 서버에 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-09-07

Microsoft® Exchange Server Analyzer Tool은 각 Exchange 서버에 공용 폴더 저장소가 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer가 InformationStore 개체가 msExchPublicMDB 개체 클래스의 개체임을 확인하면 해당 서버는 공용 폴더 저장소를 호스팅하고 있는 것입니다.

또한 Exchange Server Analyzer는 IsFrontEndServer 키 값이 설정되어 있는지 확인할 때 MicrosoftExchangeV2 Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 값이 True이면 Exchange 서버가 프런트 엔드 서버로 구성된 것이고 False이면 Excnage 서버가 프런트 엔드 서버로 구성되어 있지 않은 것입니다. Exchange Server Analyzer는 프런트 엔드 서버로 구성된 Exchange 서버가 공용 정보 저장소를 호스팅하는 경우 경고를 표시합니다.

프런트 엔드 서버에서 공용 폴더 저장소를 실행하지 않는 것이 좋습니다. 프런트 엔드 서버는 사서함을 호스팅하지 않으므로 공용 폴더 저장소가 필요하지 않습니다. 또한 공용 폴더 저장소가 Exchange 2000 Server를 실행 중인 프런트 엔드 서버에 있는 경우 공용 폴더 복제, 공용 폴더 참조 및 메모리 부족에 알려진 문제가 있습니다. 따라서 모든 프런트 엔드 서버에서 모든 공용 폴더를 분리해야 합니다.

공용 폴더 저장소를 분리하고 나면 더 이상 프런트 엔드 서버에 대해 기능을 수행하지 않으므로 Microsoft Exchange Information Store 서비스를 사용하지 않도록 설정할 수 있습니다. 불필요한 서비스를 제거함으로써 로드를 줄이고 보안 및 성능을 향상시킵니다.

참고:
프런트 엔드 서버가 인터넷에서 SMTP(Simple Mail Transfer Protocol) 메시지도 수신하는 경우 Microsoft Exchange Information Store 서비스를 계속 실행하고 사서함 저장소는 탑재된 상태로 유지해야 합니다. 따라서 프런트 엔드 서버에 공용 폴더 저장소가 없어야 합니다.

사서함 및 공용 폴더 데이터베이스를 중지하고 사용하지 않도록 설정하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버를 확장하고 해당 서버를 확장한 다음 기본 저장소 그룹을 확장합니다.

    사서함 저장소(ServerName)를 마우스 오른쪽 단추로 클릭하고 저장소 분리, 예를 차례로 클릭하여 저장소를 분리합니다.

    중요:
    프런트 엔드 서버를 SMTP 브리지헤드 서버로 사용하는 경우 해당 서버에 사서함 저장소를 탑재해야 합니다. 이 경우 해당 저장소를 분리 및 삭제해서는 안 되며 이 서버에 저장된 사서함이 없는지 확인해야 합니다.

  2. 사서함 저장소(ServerName)을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 데이터베이스 탭을 클릭하고 시작 시 이 저장소 탑재 안 함 확인란을 선택한 다음 확인을 클릭합니다.

    공용 폴더 저장소(ServerName)를 마우스 오른쪽 단추로 클릭한 다음 저장소 분리를 클릭합니다.

    주의:
    공용 폴더 저장소를 분리하기 전에 다른 공용 폴더 저장소에 해당 공용 폴더의 복제본이 있는지 확인해야 합니다. 그렇지 않으면 정보를 잃게 됩니다.

  4. 공용 폴더 저장소를 분리하려면 예를 클릭합니다.

Microsoft Exchange Information Store 서비스를 사용하지 않도록 설정하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인의 이름 목록에서 Microsoft Exchange Information Store를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 시작 유형 목록에서 사용 안 함을 선택한 다음 중지를 클릭합니다.

사서함 및 공용 폴더 데이터베이스를 영구적으로 삭제하려면 다음을 수행합니다.

  • 자세한 내용은 Exchange Server 2003 보안 강화 가이드의 사서함 및 공용 폴더 저장소 분리 및 삭제 방법(http://go.microsoft.com/fwlink/?LinkId=25210)을 참조하십시오.

프런트 엔드 서버에서의 저장소 서비스 실행과 관련된 문제에 대한 자세한 내용을 보려면 다음의 Microsoft 기술 자료 문서를 참조하십시오.

  • 286822, "XCCC: Front-End Servers Establish Large Number of Connections to Themselves"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=286822)

  • 320298, "Large number of connections established on front-end servers that are running Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320298)

프런트 엔드 및 백 엔드 서버에 대한 자세한 내용은 Exchange Server 2003 and Exchange 2000 Server Front-End and Back-End Topology 가이드(http://go.microsoft.com/fwlink/?linkid=34216)를 참조하십시오.


REAPI.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange2000 Server 또는 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


클러스터의 Windows 2000 Server SP 4에 대한 권장 업데이트
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 Exchange Server 컴퓨터에서 실행 중인 Microsoft Windows® 운영 체제 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion

참고:
CurrentVersion 값이 4.0이면 해당 컴퓨터가 Microsoft Windows NT® Server 4.0를 실행하고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터가 Microsoft Windows 2000 Server를 실행하고 있음을 나타냅니다. 값 5.2는 해당 컴퓨터가 Microsoft Windows Server™ 2003을 실행하고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 ServicePackMajorVersion 키 값을 확인할 때 Win32_OperatingSystem WMI(Windows Management Instrumentation) 클래스를 쿼리합니다.

마지막으로 Exchange Server Analyzer는 Win32_Service WMI 클래스를 쿼리하여 ClusSvc 서비스가 시작되어 있는지 여부를 확인합니다.

Exchange Server Analyzer는 다음 조건이 존재하는 경우 유용한 정보 구성 메시지를 표시합니다.

  • Exchange 서버가 서비스 팩 4로 업그레이드된 Windows 2000 Server를 실행하고 있는 컴퓨터에 있습니다.

  • ClusSvc 서비스가 시작되었습니다.

사용 가능한 업데이트와 핫픽스를 확인하고 사용자 환경에서 문제를 해결할 수 있는지 확인하는 것이 좋습니다.

Windows Server 2000을 실행하는 서버에 사용 가능한 업데이트 목록에 대한 자세한 내용은 Microsoft 기술 자료 문서 895090, "Recommended hotfixes for Windows 2000 Service Pack 4-based server clusters"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895090)를 참조하십시오.


Remote Queue Length가 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-04-09

Microsoft Exchange Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 있습니다. 성능 데이터 수집 엔진은 SMTP Server 성능 개체의 Remote Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Exchange Analyzer는 샘플 시간 동안 Remote Queue Length 카운터가 최고값 1000을 초과한 경우 오류를 표시합니다.

SMTP Server\Remote Queue Length 카운터는 SMTP(Simple Mail Transfer Protocol) 큐에서 원격 배달을 기다리는 메시지 수를 나타냅니다. Remote Queue Length가 증가하는 것은 다른 서버로 메일을 보내지 않고 있음을 의미합니다.

이러한 메일 보내기 오류는 네트워크 또는 원격 서버의 고장이나 성능 문제로 나타납니다. 고장이나 성능 문제가 발생하면 네트워크 또는 원격 서버에서 메일을 효과적으로 받을 수 없습니다.

이 오류를 해결하려면 다음 링크의 리소스를 사용하여 문제를 발생시키는 서버 또는 네트워크 구성 요소를 확인하고 성능 문제를 해결합니다.

추가 정보

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Identifying Symptoms of Poor Performance" 섹션에서 Identifying Rising Mail Queues를 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 Performance: 10 Things to Think About(http://go.microsoft.com/fwlink/?LinkID=56460)를 참조하십시오.


Remote Retry Queue Length가 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 SMTP Server 성능 개체의 Remote Retry Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

SMTP Server\Remote Retry Queue Length 카운터는 SMTP(Simple Mail Transfer Protocol) 원격 다시 시도 큐에서 대상 서버에 보낼 수 없는 메시지 수를 나타냅니다. Exchange Server Analyzer는 샘플 시간 동안 Remote Retry Queue Length 카운터가 최고값 1000을 초과한 경우 오류를 표시합니다.

이러한 메일 보내기 오류는 네트워크 또는 원격 서버의 고장이나 성능 문제로 나타납니다. 고장이나 성능 문제가 발생하면 네트워크 또는 원격 서버에서 메일을 효과적으로 받을 수 없습니다.

이 오류를 해결하려면 다음 링크의 리소스를 사용하여 문제를 발생시키는 서버 또는 네트워크 구성 요소를 확인하고 성능 문제를 해결합니다.

추가 정보

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Identifying Symptoms of Poor Performance" 섹션에서 Identifying Rising Mail Queues를 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 Performance: 10 Things to Think About(http://go.microsoft.com/fwlink/?LinkID=56460)를 참조하십시오.


오프라인 주소록 버전 4의 복제본을 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool은 Exchange_Public_Folder Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 HasLocalReplica의 현재 값을 확인합니다. Exchange Server Analyzer는 HasLocalReplica 값이 오프라인 주소 목록의 오프라인 주소록 버전 4 인스턴스에 대해 False로 설정되어 있는 경우 오류를 표시합니다.

HasLocalReplica가 오프라인 주소 목록의 오프라인 주소록 버전 4 인스턴스에 대해 False로 설정되면 오프라인 주소 목록이 제대로 생성되지 않습니다. 따라서 Microsoft Office Outlook® 2003 사용자가 오프라인 주소 목록을 다운로드할 수 없습니다.

이 문제는 공용 폴더 저장소에 오프라인 주소록 버전 4의 복제본이 포함되도록 구성하지 않은 경우에 발생할 수 있습니다. 기본적으로 오프라인 주소록은 설치되어 있는 서버의 공용 폴더에 해당 내용을 복제합니다. 공용 폴더 저장소가 오프라인 주소록의 복제 구성에서 제거되면 이전 단락에서 설명한 문제가 발생합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹을 확장한 다음 폴더를 클릭합니다.

  3. 공용 폴더를 마우스 오른쪽 단추로 클릭한 다음 시스템 폴더 보기를 클릭합니다.

  4. OFFLINE ADDRESS BOOK 개체를 클릭하여 확장합니다.

  5. OFFLINE ADDRESS BOOK에서 o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  6. 복제 탭에서 공용 폴더 저장소가 다음 공용 저장소로 콘텐트 복제 상자에 입력되어 있는지 확인합니다. 공용 폴더 저장소가 입력되어 있지 않으면 추가를 클릭한 다음 오프라인 주소록에 적합한 공용 저장소를 입력합니다.

  7. 적용을 클릭한 다음 확인을 클릭합니다.

  8. o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List를 클릭하여 확장합니다.

  9. o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List 아래에서 Offline Address Book Version 4를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  10. 복제 탭에서 공용 폴더 저장소가 다음 공용 저장소로 콘텐트 복제 상자에 입력되어 있는지 확인합니다. 공용 폴더 저장소가 입력되어 있지 않으면 추가를 클릭한 다음 오프라인 주소록에 적합한 공용 저장소를 입력합니다.

  11. 적용을 클릭한 다음 확인을 클릭합니다.

이 문제에 관한 자세한 내용은 Microsoft 기술 자료 문서 286328, "Offline Address Book Is Missing and Cannot Be Generated in Microsoft Exchange"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328)를 참조하십시오.

Exchange Server 2003을 실행하는 첫 번째 컴퓨터를 관리 그룹에서 올바르게 제거하는 방법에 대한 자세한 내용은 기술 자료 문서 822931, "사이트에서 첫 번째 Exchange Sever 2003 컴퓨터를 제거하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931)을 참조하십시오.

오프라인 주소록 문제에 대한 자세한 내용은 다음 Exchange Server 리소스를 참조하십시오.

  • Offline Address Book - Things to Consider(http://go.microsoft.com/fwlink/?LinkId=57581)

  • How Outlook 2003 SP2 and Exchange Server 2003 SP2 OAB Version 4 Work Together(http://go.microsoft.com/fwlink/?linkid=53099)

  • OAB Version 4 in Exchange Server 2003 Service Pack 2(http://go.microsoft.com/fwlink/?linkid=53097)


Replication Receive Queue 큐 길이가 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeIS Public 성능 개체의 Replication Receive Queue Size 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Exchange Server Analyzer는 샘플 시간 동안 Replication Receive Queue Size 카운터가 최고값 1000을 초과한 경우 오류를 표시합니다.

공용 폴더 복제 메시지는 SMTP를 통해 수신되고 분류되며 로컬 SMTP 큐로 전달됩니다. 그런 다음 메시지는 공용 폴더 저장소로 전송됩니다. 공용 폴더 저장소로 전송된 메시지는 Replication Receive Queue에 배치됩니다. 그런 다음 Replication Receive Queue에서 메시지가 처리되고 해당 공용 폴더에서 변경이 수행됩니다. Replication Receive Queue Size 성능 카운터는 처리를 기다리는 공용 폴더 복제 메시지 수를 나타냅니다.

복제 큐가 커질수록 동기화되지 않는 폴더의 내용이 증가합니다. 복제 큐가 증가하면 복제 큐의 메시지가 처리됨에 따라 리소스의 로드가 증가합니다. 또한 복제 큐가 증가하는 것은 서버의 공용 폴더 내용이 오래되었음을 나타냅니다.

두 개의 인스턴스에서 Replication Receive Queue 증가가 예상되지만 계획할 수 있는 경우에는 어떠한 작업도 필요하지 않습니다.

  • 새로 도입된 공용 폴더 서버에서 예상되는 초기 백필 복제로 인해 Replication Receive Queue가 증가할 수 있습니다.

  • Exchange 토폴로지에서 사이트 통합 또는 기타 주요 변경이 발생하는 경우 내용이 이동될 때 많은 복제가 수행됩니다.

공용 폴더 복제본이 일괄 변경되지 않는 기존의 안정적 상태 서버에서는 이 오류가 다음과 같은 의미를 가집니다.

  • 디스크, CPU, 네트워크 또는 메모리와 같은 서버 리소스의 성능 지체. 서버에 리소스 지체가 있으면 Store.exe 프로세스가 복제 메시지를 빠르게 처리할 수 없으므로 큐가 증가합니다.

  • 공용 폴더 복제 간격이 너무 짧아 다음 복제 주기가 시작되기 전에 복제를 완료할 수 없습니다.

이 오류를 해결하려면 다음 단계를 수행합니다.

  • 다음 복제 주기가 시작되기 전에 복제가 완료될 때까지 복제 간격을 늘리고 MSExchangeIS Public\Replication Receive Queue Size를 모니터링합니다.

  • 다음 링크의 리소스를 사용하여 성능 지체로 인해 큐가 증가되고 있는지 확인하고 지체 문제를 해결합니다.

  • Exchange 조직에서 총 복제본 수를 줄여 필요한 복제 소통량을 줄이는 것이 좋습니다.

추가 정보

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Handling Special Exchange Roles and Performance"를 참조하십시오.

  • Exchange Server 공용 폴더 복제에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 공용 폴더 복제 제어"를 참조하십시오.

  • Exchange 공용 폴더 유용한 정보에 대한 자세한 내용은 Exchange Public Folder Best Practices: Implementing Replication(http://go.microsoft.com/fwlink/?LinkId=46440)을 참조하십시오.

  • Exchange Server 2003 서비스 팩 2에 도입된 공용 폴더 관리의 향상된 기능에 대한 자세한 내용은 Microsoft Exchange Server 2003 서비스 팩 2 릴리스 정보(http://go.microsoft.com/fwlink/?linkid=52072)를 참조하십시오.


RESVC.DLL 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 이 오류가 지속되면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


RestrictRemoteClients 레지스트리 키를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 RPC(원격 프로시저 호출) 인터페이스 제한을 사용할 수 있는지 확인합니다.

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

Exchange Server Analyzer는 RestrictRemoteClients 레지스트리 키가 구성되어 있음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다.

RPC 인터페이스 제한을 사용하면 네트워크 보호가 강화되어 네트워크를 통한 공격에 대한 시스템의 취약성이 줄어듭니다. RestrictRemoteClients 레지스트리 값은 시스템의 모든 RPC 인터페이스의 동작을 수정합니다. 일부 예외가 있지만 기본적으로 RestrictRemoteClients 레지스트리 값은 시스템의 RPC 인터페이스에 대한 원격 익명 액세스를 차단합니다.

RpcServerRegisterIf를 사용하여 인터페이스를 등록하면 서버 응용 프로그램에서는 RPC를 사용하여 일반적으로 보안 콜백을 통해 인터페이스에 대한 액세스를 제한할 수 있습니다. RestrictRemoteClients 레지스트리 값을 사용하면 인터페이스에 등록된 보안 콜백이 없는 경우에도 RPC가 모든 인터페이스에 대한 추가 보안 검사를 수행할 수 있습니다.

참고:
명명된 파이프 프로토콜 시퀀스를 사용하는 RPC 클라이언트는 모든 제한에서 제외됩니다. 이전 버전과의 호환 문제 때문에 파이프 프로토콜 시퀀스는 제한할 수 없습니다.
참고:
그룹 정책 개체 편집기를 사용하여 the RestrictRemoteClients 레지스트리 키를 구성할 수도 있습니다.

RestrictRemoteClients 레지스트리 키는 DWORD 값을 사용하여 구성합니다. 레지스트리 값이 없는 경우 없는 것으로 표시된 값은 RPC_Restrict_Remote_Client_Default 값과 동일합니다.

다음 표에는 RestrictRemoteClients 구성 설정에 대한 정보가 제공됩니다.

레지스트리 키 값(DWORD) 설명

0(기본값)

RPC_RESTRICT_REMOTE_CLIENT_NONE(0)은 Microsoft Windows Server™ 2003 서비스 팩 1의 기본값을 나타냅니다. 기본값 설정으로 인해 시스템은 RPC 인터페이스 제한을 무시합니다.

기본값 설정은 RPC_RESTRICT_REMOTE_CLIENT_NONE 값에 해당합니다. 서버 응용 프로그램은 적절한 RPC 제한을 부과합니다. 이 기본 설정은 Windows 이전 버전의 RestrictRemoteClients 설정과 동일합니다.

1

RestrictRemoteClients 레지스트리 키의 1 값은 Microsoft Windows® XP 서비스 팩 2의 기본값을 나타냅니다. 값을 1로 설정하면 모든 RPC 인터페이스에 대한 액세스가 제한됩니다. 모든 원격 익명 호출은 RPC 런타임에 의해 거부됩니다.

이 값 설정은 RPC_RESTRICT_REMOTE_CLIENT_DEFAULT 값에 해당합니다. 인터페이스에서 보안 콜백을 등록하고 RPC_IF_ALLOW_CALLBACKS_WITH_NO_AUTH 플래그를 제공하면 이 제한은 해당 인터페이스에 적용되지 않습니다.

2

RestrictRemoteClients 레지스트리 키 값이 2인 경우 모든 원격 익명 호출이 예외 없이 RPC 런타임에 의해 거부됨을 나타냅니다.

이 값 설정은 RPC_RESTRICT_REMOTE_CLIENT_HIGH 값에 해당합니다. RestrictRemoteClients 값이 2로 구성되어 있으면 시스템에서 RPC를 사용하여 원격 익명 호출을 받을 수 없습니다.

Windows XP 서비스 팩 2를 사용하여 RPC 서비스를 변경하는 방법에 대한 자세한 내용은 MSDN® 문서, "RPC Interface Restrictions"(http://go.microsoft.com/fwlink/?LinkId=47371)를 참조하십시오.


RFR 대상 서버가 수동으로 다시 정의되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange 서버에서 다음 레지스트리 항목을 읽어 DSProxy 조회(Directory Services Proxy Referral) 서비스가 수동으로 다시 정의되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\RFR Target Server

Exchange Server Analyzer는 RFR Target Server가 구성되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

Microsoft Outlook® 2000 서비스 릴리스 2(SR-2) 이상의 클라이언트는 처음으로 Exchange 2000 Server 또는 Exchange Server 2003 컴퓨터에 연결될 때 홈 Exchange 서버에서 해당 디렉터리 서비스를 찾습니다. Outlook은 처음에 첫 세션 동안 DSProxy 프로세스를 통과합니다. 클라이언트가 DSProxy 서비스에 접속한 후 DSProxy 조회는 클라이언트로 다시 전달되어 앞으로 모든 디렉터리 요청이 글로벌 카탈로그 서버를 통과해야 함을 알립니다. Outlook은 DSProxy 조회 정보를 레지스트리의 MAPI 프로필에 설정합니다.

DSProxy 조회 메커니즘은 Exchange 서버의 로드를 줄이고 주소록 검색 대기 시간을 줄여줍니다. 명시적 서버 이름이 프로필에 입력된 경우 글로벌 카탈로그 서버에 장애가 발생하면 Outlook을 다시 시작해야 합니다. 이런 상황이 발생하면 Exchange 서버는 Outlook에 새로운 조회를 보냅니다.

어떤 경우에 RFR Target Server 항목을 하드 코드하여 MAPI 클라이언트 조회 서비스에 사용되어야 하는 서버를 지정하는 것이 좋습니다. 예를 들어 글로벌 카탈로그 서버의 수준을 구성원 서버로 내리기 한 주 전에 RFR Target Server 항목을 정의된 글로벌 카탈로그 서버 그룹으로 하드 코드해야 합니다. 이렇게 하면 수준이 내려 간 글로벌 카탈로그 서버가 Outlook 클라이언트의 MAPI 프로필에서 더 이상 참조되지 않습니다. RFR Target Server 레지스트리 항목의 특정한 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 305065, "XADM: Exchange Server-Related Considerations for Demoting a Global Catalog Server to a Domain Controller"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065)를 참조하십시오.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

RFR 대상 서버 레지스트리 값을 사용하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. RFR Target Server라는 새 REG_MULTISZ 값을 만듭니다.

  4. 지정하려는 서버의 정규화된 도메인 이름을 사용하여 RFR Target Server 값을 구성합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange System Attendant 서비스를 다시 시작하여 변경 내용을 적용합니다.

RFR 서버에 대한 정적 설정을 사용하지 않으려면 제거할 서버의 정규화된 도메인 이름을 제거합니다. RFR 대상 서버를 하나만 입력한 경우 RFR Target Server 레지스트리 값을 삭제합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Outlook 2000 SR-2 이상의 클라이언트가 Active Directory® 디렉터리 서비스와 상호 작용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 302914, "XCCC: Outlook 2000이 Active Directory에 액세스하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914)

  • 256976, "XCLN: MAPI 클라이언트가 Active Directory에 액세스하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976)


RegTrace 도구가 활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터에서 고급 진단 추적 기능이 사용되고 있는지를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\MosTrace\CurrentVersion\DebugAsyncTrace\EnabledTraces

Exchange Server Analyzer는 EnabledTraces 레지스트리 항목이 0 이외의 값으로 구성되어 있으면 오류를 표시합니다.

Exchange Server 전송 및 라우팅 구성 요소의 고급 진단 추적 기능은 Regtrace 유틸리티(Regtrace.exe)를 통해 사용할 수 있습니다. Regtrace는 배달 못 함 보고서(NDR)를 진단하고 문제를 해결하는 데 특히 유용한 도구입니다. Regtrace 유틸리티는 Exchange Server CD의 \Support\Utils\I386 폴더에 있습니다.

추적 파일은 Regtrace 유틸리티의 Output 탭에 지정된 위치에 저장됩니다. 파일의 기본 위치는 C:\Trace.atf입니다. 추적 파일은 추적 중인 전송 및 라우팅 구성 요소에 대한 디버그 수준 정보를 포함하는 이진으로 인코딩된 파일입니다. 따라서 Microsoft 기술 지원 서비스에서는 내부적인 분석을 위해 고객에게 추적 파일을 보내줄 것을 요청합니다.

문제를 적극적으로 해결하고 있지 않는 경우 Regtrace를 활성화하면 서버 성능이 크게 저하되므로 반드시 Microsoft 기술 지원 서비스의 지시에 따라 짧은 시간 동안만 사용해야 합니다. 성능은 물론 추적 파일의 디스크 공간이 10MB/분 이상의 속도로 사용될 수 있습니다. 문제를 해결하고 있지 않으면 이 오류를 해결하기 위해 Regtrace를 사용하여 추적 기능을 사용하지 않도록 설정할 수 있습니다.

Regtrace를 사용하여 고급 진단 추적 기능을 사용하지 않도록 설정하려면 다음을 수행합니다.

  1. Exchange Server CD의 Regtrace.exe를 Exchange Server 컴퓨터로 복사합니다.

  2. Exchange Server 컴퓨터에서 Regtrace.exe를 실행합니다. Regtrace 사용자 인터페이스가 나타납니다.

  3. Traces 탭에서 확인란의 선택을 모두 해제합니다.

  4. Output 탭을 선택하고 No Tracing을 선택합니다.

  5. 확인을 클릭하여 변경 내용을 저장하고 Regtrace 유틸리티를 닫습니다.
  • Regtrace 도구에 대한 자세한 내용은 Microsoft 기술 자료 문서 238614, "XCON: Exchange 2000에 regtrace를 설정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=238614)을 참조하십시오.

  • 일반적인 메시징 관련 문제 해결에 대한 자세한 내용은 기술 자료 문서 281800, "XCON: Troubleshooting Message Failures in Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=281800)을 참조하십시오.


Rejection threshold not configured
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-07-30

Microsoft Exchange Analyzer Tool은 Active Directory 디렉터리 서비스를 쿼리해 클래스가 ContentFilterConfig인 모든 개체에 대해 다음 특성의 값을 확인합니다.

msExchAgentsFlags msExchAgentsFlag 특성 값은 Microsoft Exchange Server 2007 콘텐츠 필터 에이전트 및 SCL(스팸 지수) 거부 동작의 상태를 나타냅니다. 컴퓨터에서 콘텐츠 필터 에이전트를 사용하도록 설정한 경우 콘텐츠 필터 에이전트는 해당 컴퓨터의 모든 수신 커넥터를 통해 들어오는 모든 메시지를 필터링합니다. 사용하도록 설정한 경우 SCL 거부 동작은 SMTP 트랜잭션 중에 SCL 거부 임계값을 초과하는 모든 메시지에 대해 거부 응답을 보냅니다.

msExchMessageHygieneSCLRejectThreshold msExchMessageHygieneSCLRejectThreshold 특성 값은 SCL 거부 동작에 설정된 수준을 나타냅니다. 이 값은 특정 메시지가 초과할 경우 콘텐츠 필터 에이전트가 메시지를 거부하고 보낸 사람에게 NDR(배달 못 함 보고서)을 보내게 되는 SCL 등급을 나타냅니다.

또한 Exchange Analyzer는 다음 Exchange 관리 셸 cmdlet를 실행하여 스팸 방지 에이전트가 설치된 모든 허브 전송 서버 역할을 쿼리합니다.

Get-TransportServer | where { $_.AntispamAgentsEnabled -eq $True}

Exchange Analyzer는 서버에 대해 다음 조건이 모두 충족될 경우 경고를 표시합니다.

  • 콘텐츠 필터링을 사용하도록 설정함

  • SCL 거부 동작을 사용하도록 설정함

  • SCL 거부 임계값이 9로 설정되어 있음

  • 서버에서 스팸 방지 에이전트를 사용하도록 설정함

이 경고는 콘텐츠 필터링 및 SCL 거부 동작을 사용하도록 설정한 상태인데도 SCL 거부 동작 임계값이 기본값인 9로 설정되어 있음을 나타냅니다. 이 경우 올바른 사용자가 보낸 메시지까지도 거부될 수 있습니다. SCL 거부 동작의 권장 임계값은 7입니다.

이 경고를 해결하려면 Exchange 관리 콘솔의 스팸 방지 탭을 사용하거나 Exchange 관리 셸에서 Set-ContentFilterConfig cmdlet를 사용하여 SCL 거부 동작 임계값을 7로 설정하십시오.

SCL 거부 동작 임계값을 구성하려면 Exchange Server 2007 제품 설명서의 "스팸 지수 임계값을 사용하고 구성하는 방법"(http://go.microsoft.com/fwlink/?LinkId=96099) 항목의 지침을 따르십시오.

추가 정보

Exchange Server 2007의 스팸 방지 및 바이러스 백신 기능 관리에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "스팸 방지 및 바이러스 백신 기능 관리"(http://go.microsoft.com/fwlink/?LinkId=96103)를 참조하십시오.


받는 사람 업데이트 서비스가 삭제되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-20

Microsoft® Exchange Server Analyzer Tool은 디렉터리의 각 받는 사람 업데이트 서비스 개체에 대한 msExchAddressListServiceLink 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msExchAddressListServiceLink 특성은 주소 목록 서비스와 해당 서비스가 실행될 Exchange Server 컴퓨터 간의 링크입니다. Exchange Server Analyzer는 msExchAddressListServiceLink 특성 값이 DEL:로 설정되어 있으면 오류를 표시합니다.

각 받는 사람 업데이트 서비스 인스턴스는 해당 받는 사람 업데이트 서비스를 실행하는 하나의 Exchange Server 컴퓨터에 연결되어 있습니다. 받는 사람 업데이트 서비스 인스턴스가 Exchange 조직에 포함되어 있지 않은 Exchange Server 컴퓨터에 연결되어 있는 경우 이 메시지를 받게 됩니다. 서버 역할이 해제되었거나 토폴로지에서 제거되었습니다.

이 받는 사람 업데이트 서비스 인스턴스를 실행하려면 기존 Exchange 서버에 연결해야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람에서 받는 사람 업데이트 서비스를 클릭합니다. 오른쪽 창에서 해당 받는 사람 업데이트 서비스 인스턴스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭의 Exchange 서버에서 찾아보기를 클릭하고 이 인스턴스를 실행할 서버를 새로 지정합니다.

  4. 확인을 클릭한 다음 확인을 다시 클릭하여 변경 내용을 적용합니다.

  5. Exchange System Manager를 닫습니다.

받는 사람 업데이트 서비스에 대한 자세한 내용은 다음 Exchange 항목 및 Microsoft 기술 자료 문서를 참조하십시오.

  • Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?linkid=47617)의 "받는 사람 및 받는 사람 정책 관리"

  • 328738, "XADM: How the Recipient Update Service Applies Recipient Policies"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, "Recipient Update Service가 주소 목록을 생성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, "XADM: How to Check the Progress of the Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, "XADM: Tasks Performed by the Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


Recipient Update Service is missing or is not configured
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-07-11

Microsoft Exchange Analyzer Tool은 Active Directory 디렉터리 서비스를 쿼리하여 디렉터리의 각 받는 사람 업데이트 서비스 개체에 대한 msExchAddressListServiceLink 특성 값을 확인합니다. msExchAddressListServiceLink 특성은 주소 목록 서비스에서 주소 목록 서비스가 실행 중이어야 하는 Exchange Server 컴퓨터까지의 링크입니다. Exchange Analyzer는 받는 사람 업데이트 개체에 대한 msExchAddressListServiceLink 특성이 없거나 해당 개체의 msExchAddressListServiceLink 특성 값이 채워지지 않은 경우 오류를 표시합니다.

일반적으로 각 받는 사람 업데이트 서비스 인스턴스는 받는 사람 업데이트 서비스를 실행하는 하나의 Exchange Server 컴퓨터에 연결되어 있습니다. 이 메시지를 받으면 받는 사람 업데이트 인스턴스가 어떤 Exchange Server 컴퓨터와도 연결되어 있지 않은 것입니다. 이로 인해 Exchange 주소 목록 및 받는 사람이 업데이트되지 않을 수 있습니다.

받는 사람 업데이트 서비스의 이 인스턴스를 실행하려면 이것을 기존의 Exchange 서버와 연결해야 합니다.

이 오류를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람에서 받는 사람 업데이트 서비스를 클릭합니다. 오른쪽 창에서 받는 사람 업데이트 서비스의 해당 인스턴스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. Exchange Server의 일반 탭에서 찾아보기를 클릭하고 이 인스턴스를 실행할 서버를 지정합니다.

  4. 확인을 클릭한 다음 다시 확인을 클릭하여 변경 내용을 적용합니다.

  5. Exchange System Manager를 닫습니다.

받는 사람 업데이트 서비스에 대한 자세한 내용은 다음 항목 및 Microsoft 기술 자료 문서를 참조하십시오.

  • Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?linkid=47617)의 "Exchange Server 2003에서 받는 사람 및 받는 사람 정책 관리"

  • 328738, "받는 사람 업데이트 서비스에서 받는 사람 정책을 적용하는 방법(How the Recipient Update Service applies recipient policies)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, "받는 사람 업데이트 서비스에서 주소 목록을 채우는 방법(How the Recipient Update Service Populates Address Lists)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, "Exchange 받는 사람 업데이트 서비스 진행률 확인 방법(How to check the progress of the Exchange Recipient Update Service)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, "Exchange 받는 사람 업데이트 서비스에서 수행하는 작업(Tasks performed by the Exchange Recipient Update Service)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


RPC 바인딩에 FQDN이 포함되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 networkAddress 특성의 ncacn_ip_tcp 값에 정규화된 도메인 이름(FQDN)이 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 ncacn_ip_tcp 값에 마침표(.)가 없는 것을 확인하면 오류를 표시합니다.

Exchange Server 2003용 Microsoft Office Outlook® Web Access에서 프런트 엔드 서버는 Exchange 백 엔드 서버에 연결을 시도할 때 networkaddress 특성 값을 검사합니다.

참고:
Exchange 2000 Server용 Outlook Web Access는 이 작업을 수행하지 않습니다. 프런트 엔드 서버에는 FQDN 값이 필요합니다.

프런트 엔드 서버는 networkaddress ncacn_ip_tcp에 대해 반환된 값에서 마침표를 확인합니다. 다음 조건이 충족되는 경우 특정 백 엔드 서버의 사서함에 대한 연결 요청이 실패하고 프런트 엔드 서버는 사용자에게 "HTTP 500 내부 서버 오류" 오류 메시지를 반환합니다.

  • ncacn_ip_tcp 값은 호스트 이름이거나 네트워크 기본 입/출력 시스템(NetBIOS) 이름입니다.

  • ncacn_ip_tcp 값은 FQDN이 아닙니다.

Exchange Server 2003용 Outlook Web Access가 제대로 작동하는지 확인하려면 Active Directory에 있는 서버 개체의 ncacn_ip_tcp 값을 업데이트해야 합니다. Exchange Server Analyzer 출력에는 영향을 받은 서버의 이름이 표시됩니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
참고:
ncacn_ip_tcp 값을 업데이트하기 전에 이 문서의 나머지 부분을 읽어 보십시오. Exchange Server 서비스를 다시 시작하기 전에 추가 절차를 실행해야 할 수도 있습니다.
networkAddress 특성의 ncacn_ip_tcp 값을 업데이트하려면 다음을 수행합니다.

  1. Windows 2000 Server 지원 도구 또는 Windows Server 2003 지원 도구에서 ADSI 편집 도구를 시작합니다.

  2. 다음 노드를 확장합니다.

    • 구성 컨테이너

    • 구성

    • 서비스

    • Microsoft Exchange

    • Organization_Name

    • 관리 그룹

    • Administrative_Group_Name

    • 서버

  3. Exchange_Server_Name을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 특성 목록에서 networkaddress, 편집을 차례로 클릭합니다.

  5. ncacn_ip_tcp에 대한 새 값을 추가합니다. 서버의 NetBIOS 이름 또는 서버의 호스트 이름 대신 서버의 FQDN을 사용합니다.

    이 값에 대한 구문은 ncacn_ip_tcp:FQDN입니다. 예를 들어 Exchange 백 엔드 서버의 호스트 이름이 EXCHANGE1이고 FQDN이 EXCHANGE1.contoso.com인 경우 ncacn_ip_tcp에 ncacn_ip_tcp:EXCHANGE1.contoso.com 값을 사용합니다.

  6. 원본 값을 선택하고 제거를 클릭하여 NetBIOS 이름 또는 백 엔드 서버의 호스트 이름이 포함되어 있는 원래 ncacn_ip_tcp 값을 제거합니다. 변경 내용을 적용하려면 확인을 두 번 클릭합니다.

  7. 서버에서 Exchange Server 서비스를 다시 시작합니다.

  8. 도메인 컨트롤러가 여러 개인 경우 프런트 엔드 서버에서 로그온하기 전에 복제가 실행되기를 기다립니다. 복제가 완료된 후에도 문제가 해결되지 않으면 프런트 엔드 서버의 IIS Admin 서비스를 다시 시작합니다.

짧은 호스트 이름이 있는 서버 IP 주소를 연관시키기 위해 백 엔드 서버의 호스트 파일을 유지 관리할 경우 UpdateProtocols 레지스트리 값도 업데이트해야 합니다. 호스트 파일이 사용되는 경우 Microsoft Exchange System Attendant를 다시 시작할 때 Exchange Server는 ncacn_ip_tcp 값을 원래대로 변경할 수 있습니다. 백 엔드 서버가 클러스터된 경우 Exchange Server는 장애 조치 후에 ncacn_ip_tcp 값을 원래대로 변경할 수 있습니다.

Exchange Server 서비스를 다시 시작함으로 인해 발생할 수 있는 가동 중지 시간을 최소화하려면 다음 절차를 수행한 후에 앞선 절차에서 설명된 대로 networkaddress 특성의 ncacn_ip_tcp 값을 업데이트하여 Exchange Server 서비스를 다시 시작합니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
호스트 파일을 사용하는 백 엔드 서버의 UpdateProtocols 레지스트리 값을 수정하려면 다음을 수행합니다.

  1. 레지스트리 편집기를 사용하여 백 엔드 서버의 레지스트리 값인 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols를 구성합니다.

    참고:
    UpdateProtocols 값이 없는 경우 만들어야 합니다. 이렇게 하려면 다음 단계를 수행합니다.
    1. 레지스트리 편집기를 열고 레지스트리 하위 키인 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\를 찾습니다.

    2. 매개 변수를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 다음 DWORD 값을 클릭합니다.

    3. UpdateProtocols를 입력한 다음 Enter 키를 누릅니다.

  2. UpdateProtocols를 마우스 오른쪽 단추로 클릭하고 수정을 클릭하고 값 데이터 필드에 0을 입력한 다음 확인을 클릭합니다.

  3. 네트워크에서 백 엔드 클러스터 노드의 호스트 파일을 사용하는 경우 다음과 같이 항목의 UpdateProtocols 순서를 수정합니다.

    FQDN에 대한 IP 주소

    NetBIOS에 대한 IP 주소

    대신:

    NetBIOS에 대한 IP 주소

    FQDN에 대한 IP 주소

  4. 서버에서 Exchange Server 서비스를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


RPC 바인딩이 DNS에서 확인한 이름과 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-21

Microsoft® Exchange Server Analyzer Tool은 각 Exchange Server 컴퓨터의 구성된 DNS 서버에 대해 DNS(Domain Name System) 쿼리를 시도합니다. 이 연결은 이름 확인 요청을 수행하고 결과를 분석하는 사용자 지정 개체 프로세서를 사용하여 만들어집니다. 또한 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스를 쿼리하여 networkAddress 특성의 서버 ncacn_ip_tcp 값과 DNS 확인 후에 반환된 정규화된 도메인 이름(FQDN)이 서로 다른지 여부를 확인합니다. networkAddress 특성은 Active Directory에 있는 각 Exchange Server 개체의 특성입니다. Active Directory의 서버 ncacn_ip_tcp 값이 DNS 확인 후의 FQDN과 일치하지 않는다면 Exchange Server Analyzer에서 경고를 표시합니다.

서버의 FQDN이 Exchange 설치 후에 변경된 경우 이 상황이 발생합니다. Exchange Server 및 Active Directory가 올바르게 작동하려면 DNS가 제대로 구성되어 안정적으로 실행되어야 합니다. 도메인 이름 서비스 등록 및 확인 문제는 Exchange 서버 컴퓨터의 메시지를 보내고, 받고, 배달하는 기능에 큰 영향을 미칠 수 있습니다. Active Directory의 Exchange Server 개체에 대한 networkAddress 특성을 수동으로 편집하여 두 주소를 일치시키면 문제를 방지할 수 있습니다.

Active Directory의 서버 개체에 대한 ncacn_ip_tcp 값을 업데이트하여 ncacn_ip_tcp 값이 서버의 DNS FQDN과 일치하게 해야 합니다. Exchange Server Analyzer 출력에는 영향을 받는 서버의 이름이 표시됩니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
networkAddress 특성의 ncacn_ip_tcp 값을 업데이트하려면 다음을 수행합니다.

  1. Windows 2000 지원 도구 또는 Windows Server 2003 지원 도구에서 ADSI 편집 도구를 시작합니다.

  2. 다음 노드를 확장합니다.

    • 구성 컨테이너

    • 구성

    • 서비스

    • Microsoft Exchange

    • Organization_Name

    • 관리 그룹

    • Administrative_Group_Name

    • 서버

  3. Exchange_Server_Name을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 특성 목록에서 networkaddress를 클릭한 다음 편집을 클릭합니다.

  5. ncacn_ip_tcp에 대한 새 값을 추가합니다. 현재 값 대신 서버의 FQDN을 사용합니다.

    이 값에 대한 구문은 ncacn_ip_tcp:FQDN입니다. 예를 들어 Exchange 서버의 호스트 이름이 EXCHANGE1이고 FQDN이 EXCHANGE1.contoso.com인 경우 ncacn_ip_tcp에 ncacn_ip_tcp:EXCHANGE1.contoso.com 값을 사용합니다.

  6. 원본 값을 선택하고 제거를 클릭하여 잘못된 서버 이름이 포함된 원래 ncacn_ip_tcp 값을 제거합니다. 변경 내용을 적용하려면 확인을 두 번 클릭합니다.

  7. 서버에서 Exchange Server 서비스를 다시 시작합니다.

Active Directory에서 DNS를 사용하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 323418, "Windows Server 2003 제품군에서 Active Directory가 사용되는 경우 기존 DNS 인프라에 DNS를 통합하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418)을 참조하십시오.


RPC 바인딩 순서가 잘못되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터에서 사용 중인 원격 프로시저 호출(RPC) 바인딩 순서를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

Exchange Server Analyzer는 Rpc_Svr_Binding_Order의 값이 ncacn_ip_tcp로 시작되지 않는 경우 경고를 표시합니다.

Rpc_Svr_Binding_Order 레지스트리 항목은 컴퓨터에 Exchange Server를 설치할 때 만들어집니다. 이 항목은 서버 간 RPC 통신에 사용되는 프로토콜 시퀀스를 결정합니다.

기본적으로 Rpc_Svr_Binding_Order 항목은 다음 값 데이터를 포함합니다.

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

참고:
Exchange Server 컴퓨터에 다른 프로토콜이 설치되어 있으면 문자열에 값이 추가됩니다.

이 항목은 Exchange Server가 다른 서버와의 RPC 통신에 사용하기 위해 시도하는 네트워크 통신 프로토콜의 순서를 지정합니다. 예를 들어 TCP/IP가 첫 번째로 지정되어 있으므로 Exchange Server는 먼저 TCP/IP를 통해 다른 서버와의 RPC 통신을 시도한 후 다른 프로토콜을 통해 RPC 통신을 시도합니다.

RPC 바인딩 순서의 기본값은 변경하지 않는 것이 좋습니다. 기본값을 변경하면 서버 또는 서비스를 시작하는 동안이나 서버 간 통신에 문제가 발생할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\Microsoft\Exchange\Exchange Provider를 탐색합니다.

  3. 오른쪽 창에서 Rpc_Svr_Binding_Order를 두 번 클릭합니다.

  4. 값 데이터 대화 상자에 ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp를 입력합니다.

  5. 확인을 클릭한 다음 레지스트리 편집기를 닫습니다.

  6. Exchange Server 서비스를 모두 다시 시작하거나 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC 바인딩 순서에 대한 자세한 내용은 Microsoft 기술 자료 문서 325930, "XCCC: RPC 클라이언트 프로토콜 레지스트리 항목으로 인한 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930)을 참조하십시오.


Rpc_Binding_Order 레지스트리 항목이 존재합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 클라이언트에서 시작된 RPC(원격 프로시저 호출) 바인딩 순서 레지스트리 항목이 Exchange Server 컴퓨터에 존재하는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Binding_Order

Exchange Server Analyzer는 Rpc_Binding_Order가 있을 경우 경고를 표시합니다.

Rpc_Binding_Order 값이 존재할 경우 컴퓨터에 다음 중 하나 이상이 설치되어 있는 것입니다.

  • Exchange Server 버전 5.5

  • Microsoft Office Outlook® 2003

  • Windows 클러스터링

  • RPC_Binding_Order 항목은 Outlook RPC 통신이 시작될 때 사용될 프로토콜 시퀀스를 결정합니다. 이 항목은 Exchange Server 2003 또는 Exchange 2000 Server에서는 만들어지지 않으며 이 항목은 Exchange Server 5.5 및 이전 버전의 Exchange에서만 만들어지며 Exchange Server 5.5 및/또는 Microsoft Outlook이 이전에 이 컴퓨터에 설치되고 이후에 제거된 경우 이 레지스트리 항목을 수동으로 제거할 수 있습니다. 또한 구성이 지원되지 않으면 Exchange Server를 실행 중인 컴퓨터에서 Outlook을 제거해야 합니다. 같은 컴퓨터에서 Exchange 및 Outlook 실행에 대한 자세한 내용은 Microsoft 기술 자료 문서 266418, "Microsoft does not recommend installing Exchange Server and Outlook on the same computer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418)를 참조하십시오.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Rpc_Binding_Order 레지스트리 항목을 제거하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\Microsoft\Exchange\Exchange Provider를 탐색합니다.

  3. Rpc_Binding_Order 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 모든 Exchange Server 서비스를 다시 시작하거나 Exhange Server 컴퓨터를 다시 부팅하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC_Binding_Order 레지스트리 항목에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 325930, "XCCC: RPC 클라이언트 프로토콜 레지스트리 항목으로 인한 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930)

  • 326036, "XADM: Cannot Log On to Exchange 2000 Server Computer by Using the Correct Credentials"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=326036)


Rpc_Svr_Binding_Order 레지스트리 값이 기본값에서 다른 값으로 수정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터에서 사용 중인 원격 프로시저 호출(RPC) 바인딩 순서를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

Exchange Server Analyzer는 Rpc_Svr_Binding_Order의 값이 ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp로 설정되어 있지 않은 경우 경고를 표시합니다.

Rpc_Svr_Binding_Order 레지스트리 항목은 컴퓨터에 Exchange Server를 설치할 때 만들어집니다. 이 항목은 서버 간 RPC 통신에 사용되는 프로토콜 시퀀스를 결정합니다.

기본적으로 Rpc_Svr_Binding_Order 항목에는 다음 값 데이터가 들어 있습니다.

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

참고:
Exchange Server 컴퓨터에 다른 프로토콜도 설치되어 있으면 위 문자열에 값이 추가됩니다.

이 항목은 Exchange Server가 다른 서버와의 RPC 통신에 사용하기 위해 시도하는 네트워크 통신 프로토콜의 순서를 지정합니다. 예를 들어 TCP/IP가 첫 번째로 지정되어 있으므로 Exchange Server는 먼저 TCP/IP를 통해 다른 서버와의 RPC 통신을 시도한 후 다른 프로토콜을 통해 RPC 통신을 시도합니다.

RPC 바인딩 순서의 기본값은 변경하지 않는 것이 좋습니다. 기본값을 변경하면 서버 또는 서비스를 시작하는 동안이나 서버 간 통신에 문제가 발생할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\Microsoft\Exchange\Exchange Provider를 탐색합니다.

  3. 오른쪽 창에서 Rpc_Svr_Binding_Order를 두 번 클릭합니다.

  4. 값 데이터 대화 상자에 ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp를 입력합니다.

  5. 확인을 클릭한 다음 레지스트리 편집기를 닫습니다.

  6. Exchange Server 서비스를 모두 다시 시작하거나 Exchange Server 컴퓨터를 다시 부팅하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC 바인딩 순서에 대한 자세한 내용은 Microsoft 기술 자료 문서 325930, "XCCC: RPC 클라이언트 프로토콜 레지스트리 항목으로 인한 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930)을 참조하십시오.


Active Directory 서버까지의 왕복 시간은 100밀리초 이상입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-03-16

Microsoft® Exchange Server Analyzer Tool은 ResponseTime 키 값을 확인할 때 root\cimv2 네임스페이스의 WIN32_PingStatus Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 ResponseTime 키 값이 100밀리초 이상으로 설정되어 있으면 오류를 표시합니다.

ResponseTime 키는 ICMP(Internet Control Message Protocol) 에코 요청(ping)에 응답하는 데 걸리는 시간(밀리초)을 나타냅니다. Exchange Server 컴퓨터가 사용하는 도메인 컨트롤러의 응답 시간은 10밀리초 이하여야 합니다. 응답 시간이 100밀리초를 초과하면 성능 문제 또는 연결 문제가 있는 경우가 많습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 해당 도메인 컨트롤러가 오버로드되지 않았는지 확인합니다. ADTest.Exe 도구로 도메인 컨트롤러를 테스트하여 하드웨어가 예상되는 로드를 처리할 수 있는지 확인합니다.

  2. Exchange 서버와 도메인 컨트롤러에 대한 이벤트 로그를 통해 하나 이상의 문제를 나타내는 네트워크 관련 이벤트가 기록되어 있는지 확인합니다.

  3. 도메인 컨트롤러에 대해 DCDiag.exe 및 NetDiag.exe 명령을 사용하여 올바른 구성과 현재 상태를 확인하여 비교합니다.

  4. 마지막으로 Active Directory® 디렉터리 서비스 사이트 디자인을 조사합니다. Active Directory 사이트는 대역폭이 높고 대기 시간이 짧은 네트워크 섹션으로 간주됩니다. 네트워크가 이 사양에 따라 분할되지 않은 경우 네트워크를 더 많은 Active Directory 사이트로 분할합니다.
참고:
분석기 도구에서 Ping 테스트를 위한 WMI 쿼리를 실행하면 기본 패킷 크기와 시간 제한 값이 무시됩니다. 대신 분석기는 기본값 32바이트 대신 4096 ICMP 패킷 크기와 기본값 1000밀리초 대신 2000밀리초의 시간 제한 값을 사용합니다.

분석기의 Ping 동작을 수동으로 에뮬레이트하려면 다음 단계를 수행합니다.

Ping 테스트를 수동으로 수행하려면 다음을 수행합니다.

  • Exchange Server의 명령줄 창에서 다음 명령을 실행합니다. ping -L 4096 -N 6 <Active Server server name>참고 이 명령은 각각 4096바이트의 Ping 요청 여섯 개를 시작합니다.

ADTest.exe 도구에 대한 자세한 내용은 Active Directory Performance Testing Tool(ADTest.exe) 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33758)를 참조하십시오.

Win32_PingStatus WMI 클래스에 대한 자세한 내용은 MSDN® 문서, "Win32_PingStatus"(http://go.microsoft.com/fwlink/?LinkId=33549)를 참조하십시오.

Active Directory 사이트 디자인에 대한 자세한 내용은 "Designing the Site Topology"(http://go.microsoft.com/fwlink/?LinkId=33551)를 참조하십시오.


Active Directory 서버까지의 왕복 시간은 10밀리초 이상입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-03-16

Microsoft® Exchange Server Analyzer Tool은 ResponseTime 키 값을 확인할 때 root\cimv2 네임스페이스의 WIN32_PingStatus Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 ResponseTime 키 값이 10밀리초(ms)보다 크고 100밀리초보다 작을 경우 경고를 표시합니다.

ResponseTime Exchange 서버에서 도메인 컨트롤러로 전송된 ICMP(Internet Control Message Protocol) 에코 요청(ping) 패킷에 응답하는 데 걸리는 시간(밀리초)을 나타냅니다. Exchange Server 컴퓨터에서 사용하는 도메인 컨트롤러는 항상 10ms보다 작거나 같은 응답 시간을 유지해야 합니다. 응답 시간이 10ms를 초과하면 성능 또는 연결 문제가 있는 것일 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 문제의 도메인 컨트롤러가 오버로드되지 않았는지 확인합니다. ADTest.exe 도구로 도메인 컨트롤러를 테스트하여 하드웨어가 예상 로드를 처리할 수 있는지 확인합니다.

  2. Exchange 서버와 도메인 컨트롤러에 대한 이벤트 로그를 모니터링하여 하나 이상의 문제점을 나타내는 네트워크 관련 이벤트가 기록되었는지 확인합니다.

  3. 도메인 컨트롤러에서 DCDiag.exe 및 NetDiag.exe 명령을 사용하여 구성 및 상태에 문제가 없는지 확인합니다.

  4. 마지막으로 Active Directory® 디렉터리 서비스 사이트 디자인을 조사합니다. Active Directory 사이트는 대역폭이 높고 대기 시간이 짧은 네트워크 섹션으로 간주됩니다. 네트워크가 이 사양에 따라 분할되지 않은 경우 네트워크를 더 많은 Active Directory 사이트로 분할합니다.
참고:
분석기 도구에서 Ping 테스트를 위한 WMI 쿼리를 실행하면 기본 패킷 크기와 시간 제한 값이 무시됩니다. 대신 분석기는 기본값 32바이트 대신 4096 ICMP 패킷 크기와 기본값 1000밀리초 대신 2000밀리초의 시간 제한 값을 사용합니다.

분석기의 Ping 동작을 수동으로 에뮬레이트하려면 다음 단계를 수행합니다.

Ping 테스트를 수동으로 수행하려면

  • Exchange Server의 명령줄 창에서 다음 명령을 실행합니다.ping -L 4096 -N 6 <Active Server server name>참고 이 명령은 각각 4096바이트의 Ping 요청 여섯 개를 시작합니다.

ADTest.exe 도구에 대한 자세한 내용은 Active Directory Performance Testing Tool(ADTest.exe) 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33758)를 참조하십시오.

Win32_PingStatus WMI 클래스에 대한 자세한 내용은 MSDN® 문서 "Win32_PingStatus" (http://go.microsoft.com/fwlink/?LinkId=33549)를 참조하십시오.

Active Directory 사이트 디자인에 대한 자세한 내용은 "Designing the Site Topology"(http://go.microsoft.com/fwlink/?LinkId=33551)를 참조하십시오.


글로벌 카탈로그 서버에 대한 왕복 시간이 100밀리초를 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-03-16

Microsoft® Exchange Server Analyzer Tool은 ResponseTime 키 값을 확인할 때 root\cimv2 네임스페이스의 WIN32_PingStatus Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 ResponseTime 키 값이 100밀리초보다 클 경우 오류를 표시합니다.

ResponseTime 키는 Exchange Server에서 글로벌 카탈로그 서버로 보낸 ICMP(Internet Control Message Protocol) 에코 요청(ping) 패킷에 대해 응답할 때까지 경과되는 시간(밀리초)을 나타냅니다. Exchange Server 컴퓨터에서 사용하는 글로벌 카탈로그 서버의 응답 시간은 항상 10ms 이하여야 합니다. 응답 시간이 10ms를 초과할 경우 성능 또는 연결 문제가 있을 수 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 의심되는 글로벌 카탈로그 서버가 오버로드되지 않아야 합니다. ADTest.exe 도구로 글로벌 카탈로그 서버를 테스트하여 하드웨어가 예상되는 로드를 처리할 수 있는지 확인합니다.

  2. 해당 Exchange 서버와 글로벌 카탈로그 서버의 이벤트 로그를 검사하여 한 가지 이상의 문제를 나타내는 네트워크 관련 이벤트가 기록되었는지 확인합니다.

  3. 글로벌 카탈로그 서버에서 DCDiag.exe 명령과 NetDiag.exe 명령을 사용하여 구성과 상태가 올바른지 확인합니다.

  4. 마지막으로 Active Directory® 디렉터리 서비스 사이트 디자인을 조사합니다. Active Directory 사이트는 대역폭이 높고 대기 시간이 짧은 네트워크 섹션으로 간주됩니다. 네트워크가 이 사양에 따라 분할되지 않는 경우 네트워크를 더 많은 Active Directory 사이트로 분할하는 것을 고려합니다.
참고:
분석기 도구에서 Ping 테스트에 대한 WMI 쿼리를 실행할 경우 기본 패킷 크기와 시간 제한 값이 무시됩니다. 대신 분석기에서 기본값 32바이트 대신 4096 ICMP 패킷 크기를 사용하고 기본값 1000밀리초 대신 2000밀리초의 시간 제한 값을 사용합니다.

분석기의 Ping 동작을 수동으로 에뮬레이트하려면 다음 단계를 수행합니다.

Ping 테스트를 수동으로 수행하려면 다음을 수행합니다.

  • Exchange Server의 명령줄 창에서 다음 명령을 실행합니다.ping -L 4096 -N 6 <Active Server server name>참고 이 명령은 각각 4096바이트의 Ping 요청 여섯 개를 시작합니다.

ADTest.exe 도구에 대한 자세한 내용은 "Active Directory Performance Testing Tool(ADTest.exe)" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33758)를 참조하십시오.

Win32_PingStatus WMI 클래스에 대한 자세한 내용은 MSDN® 문서 "Win32_PingStatus"(http://go.microsoft.com/fwlink/?LinkId=33549)를 참조하십시오.

Active Directory 사이트 디자인에 대한 자세한 내용은 "Designing the Site Topology"(http://go.microsoft.com/fwlink/?LinkId=33551)를 참조하십시오.

Windows 2000 Server 지원 도구를 설치하는 방법은 Microsoft 기술 자료 문서 301423, "Windows 2000 지원 도구를 Windows 2000 Server 기반 컴퓨터에 설치하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301423)을 참조하십시오.

Windows Server 2003 지원 도구를 설치하는 방법은 "Install Windows Support Tools"(http://go.microsoft.com/fwlink/?LinkId=41362)를 참조하십시오.


글로벌 카탈로그 서버에 대한 왕복 시간이 10밀리초를 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-03-16

Microsoft® Exchange Server Analyzer Tool은 ResponseTime 키 값을 확인할 때 root\cimv2 네임스페이스의 WIN32_PingStatus Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 ResponseTime 키 값이 10밀리초 이상 100밀리초 미만으로 설정되어 있으면 오류를 표시합니다.

ResponseTime 키는 Exchange 서버에서 글로벌 카탈로그 서버로 전송된 ICMP(Internet Control Message Protocol) 에코 요청(ping) 패킷에 응답하는 데 걸리는 시간(밀리초)을 나타냅니다. Exchange Server 컴퓨터가 사용하는 글로벌 카탈로그 서버의 응답 시간은 항상 10밀리초 이내여야 합니다. 응답 시간이 10밀리초를 초과하면 성능이나 연결에 문제가 있는 경우가 많습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 해당 글로벌 카탈로그 서버가 오버로드되지 않았는지 확인합니다. ADTest.exe 도구로 글로벌 카탈로그 서버를 테스트하여 하드웨어가 예상되는 로드를 처리할 수 있는지 확인합니다.

  2. 해당 Exchange 서버와 글로벌 카탈로그 서버의 이벤트 로그를 검사하여 한 가지 이상의 문제를 나타내는 네트워크 관련 이벤트가 기록되었는지 확인합니다.

  3. 글로벌 카탈로그 서버에 대해 DCDiag.exe 및 NetDiag.exe 명령을 사용하여 올바른 구성과 현재 상태를 확인하여 비교합니다.

  4. 마지막으로 Active Directory® 디렉터리 서비스 사이트 디자인을 조사합니다. Active Directory 사이트는 대역폭이 높고 대기 시간이 짧은 네트워크 섹션으로 간주됩니다. 네트워크가 이 사양에 따라 분할되지 않은 경우 네트워크를 더 많은 Active Directory 사이트로 분할합니다.
참고:
분석기 도구에서 Ping 테스트를 위한 WMI 쿼리를 실행하면 기본 패킷 크기와 시간 제한 값이 무시됩니다. 대신 분석기는 기본값 32바이트 대신 4096 ICMP 패킷 크기와 기본값 1000밀리초 대신 2000밀리초의 시간 제한 값을 사용합니다.

분석기의 Ping 동작을 수동으로 에뮬레이트하려면 다음 단계를 수행합니다.

Ping 테스트를 수동으로 수행하려면

  • Exchange 서버의 명령줄 창에서 다음 명령을 실행합니다.

    ping -L 4096 -N 6 <Active Server server name>

    참고:
    이 명령은 각각 4096바이트의 Ping 요청 여섯 개를 시작합니다.

ADTest.Exe 도구에 대한 자세한 내용은 "Active Directory Performance Testing Tool (ADTest.exe)" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33758)를 참조하십시오.

Win32_PingStatus WMI 클래스에 대한 자세한 내용은 MSDN® 문서, "Win32_PingStatus"(http://go.microsoft.com/fwlink/?linkid=33549)를 참조하십시오.

Active Directory 사이트 디자인에 대한 자세한 내용은 "Designing the Site Topology"(http://go.microsoft.com/fwlink/?linkid=33551)를 참조하십시오.


받는 사람 정책에 검색 필터 변경이 필요합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-21

Microsoft® Exchange Server Analyzer Tool은 각 Exchange 받는 사람 정책 개체의 purportedSearch 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. purportedSearch 특성은 정책이 적용될 때 사용되는 검색 인수를 나타냅니다.

또한 Exchange Server Analyzer는 Active Directory에 있는 포리스트 개체의 msDS-Behavior-Version 특성 값, 즉 NTDS 설정을 확인할 때 Active Directory를 쿼리합니다. 이 값은 Active Directory 포리스트 기능 수준을 나타냅니다. msDS-Behavior-Version 특성에 유효한 값은 다음 표에 표시되어 있습니다.

값 | 포리스트 기능 수준
0 | Microsoft Windows® 2000 Server 혼합
1 | Microsoft Windows Server™ 2003 임시
2 | Windows Server 2003 전용

또한 Exchange Server Analyzer는 Windows 2003 업데이트 컨테이너의 revision 특성 값을 확인할 때 Active Directory를 쿼리합니다. 이 특성 값은 Active Directory 준비 도구(ADPrep.exe)가 실행되어 있는지 여부를 나타냅니다.

마지막으로 Exchange Server Analyzer는 OSProductSuite 키 값을 확인할 때 Win32_OperatingSystem WMI(Windows Management Instrumentation) 클래스를 쿼리합니다. OSProductSuite 키 값은 컴퓨터에서 실행 중인 Windows의 버전을 나타냅니다.

Exchange Server Analyzer에서 다음 조건이 참임을 확인하면 경고가 표시됩니다.

  • 받는 사람 정책의 purportedSearch 특성 값에 homeMdb가 들어 있습니다.

  • Active Directory 포리스트 기능 수준은 Windows Server 2003 임시 또는 Windows Server 2003 전용 모드입니다.

  • Exchange Server 컴퓨터가 Microsoft Windows Small Business Server 2003을 실행하고 있지 않습니다.

이 경고는 Active Directory 포리스트가 Windows Server 2003용으로 준비되었음을 나타냅니다. 포리스트가 Windows Server 2003 전용 기능 수준으로 업그레이드될 때 전자 메일 주소 스탬프 문제를 방지하려면 받는 사람 정책을 수정해야 합니다. 적용되는 받는 사람 정책은 Exchange Server Analyzer 출력에 지정되어 있습니다.

Windows Server 2003이 도메인 컨트롤러로 사용되고 받는 사람 정책이 업데이트되지 않으면 Windows Server 2003의 연결된 값 복제로 인해 받는 사람 업데이트 서비스가 새 사용자의 전자 메일 주소를 잘못 씁니다. 받는 사람 업데이트 서비스가 해당 사용자를 처음 확인하는 시점은 연결 값 복제로 인해 mailnickname이 복제되는 시간과 homeMDB가 복제되는 시간 사이일 수 있습니다. 따라서 사용자는 homeMDB 기반 정책을 따르지 않고 해당 시점의 기본 정책을 따릅니다. 몇 분 후 homeMDB가 복제될 때 사용자는 해당 homeMDB 정책을 따릅니다. 그러나 사용자는 이미 기본 정책과 일치하는 주소를 가지고 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람을 확장하고 받는 사람 정책을 선택하고, RecipientPolicyName을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. RecipientPolicyName Properties 페이지의 일반 탭에서 필터 규칙 아래에 있는 수정을 클릭합니다.

  4. Exchange 받는 사람 찾기 메뉴에서 사용자 지정 검색을 선택합니다. 원래 받는 사람 정책이 사용자 지정 검색으로 만들어진 경우 사용자 지정 검색 찾기 페이지는 3단계에서 수정을 클릭한 후에 표시됩니다.

  5. homeMdb 특성이 필터 조건의 일부로 사용되지 않도록 LDAP(Lightweight Directory Access Protocol) 쿼리를 변경합니다. extensionAttribute, msExchHomeServerName 또는 UPN과 같은 특성은 동일한 검색 결과를 얻는 데 도움이 되는 유효한 인수입니다.

  6. 확인을 클릭하여 변경 내용을 저장하고 Exchange System Manager를 닫습니다.


받는 사람 정책의 검색 필터를 변경해야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 Exchange 받는 사람 정책 개체의 purportedSearch 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. purportedSearch 특성은 정책이 적용될 때 사용되는 검색 인수를 나타냅니다.

또한 Exchange Server Analyzer는 Active Directory에 있는 포리스트 개체의 msDS-Behavior-Version 특성 값, 즉 NTDS 설정을 확인할 때 Active Directory를 쿼리합니다. 이 값은 Active Directory 포리스트 기능 수준을 나타냅니다. msDS-Behavior-Version 특성에 유효한 값은 다음 표에 표시되어 있습니다.

값 | 포리스트 기능 수준
0 | Windows® 2000 Server 혼합
1 | Windows Server™ 2003 임시
2 | Windows Server 2003 전용

또한 Exchange Server Analyzer는 Windows 2003 업데이트 컨테이너의 revision 특성 값을 확인할 때 Active Directory를 쿼리합니다. 이 특성 값은 Active Directory 준비 도구(ADPrep.exe)가 실행되어 있는지 여부를 나타냅니다.

마지막으로 Exchange Server Analyzer는 OSProductSuite 키 값을 확인할 때 Win32_OperatingSystem WMI(Windows Management Instrumentation) 클래스를 쿼리합니다. OSProductSuite 키 값은 컴퓨터에서 실행되고 있는 Windows의 버전을 나타냅니다.

Exchange Server Analyzer에서 다음 조건이 참임을 확인하면 경고가 표시됩니다.

  • 받는 사람 정책의 purportedSearch 특성 값에 (homeMdb=)가 들어 있습니다.

  • Active Directory 포리스트 기능 수준은 Windows 2000 Server 혼합입니다.

  • Active Directory 포리스트는 Windows Server 2003 도메인 컨트롤러용으로 준비되었습니다.

  • Exchange Server 컴퓨터가 Microsoft Windows Small Business Server 2003을 실행하고 있지 않습니다.

이 경고는 Active Directory 포리스트가 Windows Server 2003용으로 준비되었음을 나타냅니다. Active Directory 포리스트가 Windows Server 2003의 전체 기능 수준으로 업그레이드될 때 전자 메일 주소 스탬프 문제를 방지하려면 받는 사람 정책을 수정해야 합니다. 적용되는 받는 사람 정책은 Exchange Server Analyzer 출력에 지정되어 있습니다.

Windows Server 2003을 도메인 컨트롤러로 사용하고 받는 사람 정책을 업데이트하지 않는 경우 Windows Server 2003에 연결된 값 복제로 인해 받는 사람 업데이트 서비스가 새 사용자의 전자 메일 주소를 올바르게 쓰지 못합니다.

연결된 값 복제 때문에 받는 사람 업데이트 서비스는 mailnickname 복제 시간과 homeMdb 복제 시간 사이에 처음으로 사용한 새 사용자를 검색합니다. 따라서 이 기간 동안에는 사용자에게 homeMdb 기반 정책 대신 기본 정책이 적용됩니다. 몇 분 후 homeMdb가 복제되면 사용자에게 homeMdb 정책이 적용됩니다. 하지만 사용자에게 이미 기본 정책과 일치하는 주소가 있을 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람을 확장하고 받는 사람 정책을 선택하고, RecipientPolicyName을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. RecipientPolicyName Properties 페이지의 일반 탭에서 필터 규칙 아래에 있는 수정을 클릭합니다.

  4. Exchange 받는 사람 찾기 메뉴에서 사용자 지정 검색을 선택합니다. 받는 사람 정책이 원래 사용자 지정 검색으로 만들어졌으면 3단계에서 수정을 누른 후에 사용자 지정 검색 찾기 페이지가 표시됩니다.

  5. homeMdb 특성이 필터 조건의 일부로 사용되지 않도록 LDAP(Lightweight Directory Access Protocol) 쿼리를 변경합니다. extensionAttribute, msExchHomeServerName 또는 UPN과 같은 특성은 동일한 검색 결과를 얻는 데 도움이 되는 유효한 인수입니다.

  6. 확인을 두 번 눌러 변경 내용을 저장한 다음 Exchange System Manager를 닫습니다.


보낸 사람 ID가 구성되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-05-10

Microsoft Exchange Best Practices Analyzer Tool은 다음 Exchange 관리 셸 cmdlet를 사용하여 대상 Exchange Server 2007 Edge 전송 서버 역할 또는 허브 전송 서버 역할에 대해 SenderIdConfig 개체의 Enabled 및 ExternalMailEnabled 속성 값을 쿼리합니다.

코드 복사
- get-SenderIdConfig

Enabled 속성 값은 보낸 사람 ID 에이전트를 사용하도록 설정할지 여부를 지정합니다. Enabled 매개 변수에 사용할 수 있는 입력 값은 $true 또는 $false입니다. 기본 설정은 $true입니다. Enabled 매개 변수를 $true로 설정하면 보낸 사람 ID가 사용하도록 설정됩니다.

ExternalMailEnabled 속성 값은 인증되지 않은 연결을 통해 받은 모든 메시지를 보낸 사람 ID 에이전트를 통해 처리용으로 전달할지 여부를 지정합니다. ExternalMailEnabled 매개 변수에 사용할 수 있는 입력 값은 $true 또는 $false입니다. 기본 설정은 $true입니다. ExternalMailEnabled 매개 변수를 $true로 설정하면 인증되지 않은 연결을 통해 받은 모든 메시지가 보낸 사람 ID 에이전트를 통해 처리용으로 전달됩니다.

Exchange 모범 사례 분석은 SenderIdConfig 개체 사용 또는 ExternalMailEnabled 속성의 값이 $true로 설정되어 있지 않음을 확인하면 최상의 방법 메시지를 표시합니다.

이 메시지는 대상 Exchange 2007 Edge 전송 서버 역할 또는 허브 전송 서버 역할에 대해 보낸 사람 ID를 사용할 수 없음을 나타냅니다.

보낸 사람 ID는 모든 전자 메일 메시지가 해당 메시지를 보내도록 요구되는 인터넷 도메인을 통해 보내지는지를 확인합니다.

보낸 사람 ID가 컴퓨터에서 사용하도록 설정되는 경우 보낸 사람 ID는 해당 컴퓨터에서 모든 수신 커넥터를 통해 들어오는 모든 메시지를 필터링합니다. 외부 원본으로부터 받는 메시지만 필터링합니다. 외부 원본은 인증되지 않은 원본으로 정의되며 익명의 인터넷 원본으로 간주됩니다.

이 문제를 해결하려면 대상 Exchange 2007 Edge 전송 서버 역할 또는 허브 전송 서버 역할에 대해 보낸 사람 ID를 사용하도록 설정합니다.

Exchange 관리 셸을 사용하여 보낸 사람 ID 기능을 사용하도록 설정하려면 다음을 수행합니다.

  • 보낸 사람 필터링을 사용하도록 설정하려면 다음 명령을 실행합니다.

    코드 복사
    Set-SenderIdConfig -Enabled $true -ExternalMailEnabled $true

보낸 사람 ID에 대한 자세한 내용은 다음 항목을 참조하십시오.

  • 보낸 사람 ID 홈 페이지(http://go.microsoft.com/fwlink/?linkid=50977)

  • Exchange 2007 보낸 사람 ID(http://go.microsoft.com/fwlink/?LinkId=89719)

  • 보낸 사람 ID 구성(http://go.microsoft.com/fwlink/?LinkId=89720)


서버 이름의 대/소문자가 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 Active Directory에 저장된 Exchange 서버의 이름 값(CN=<ExchangeServerName>)을 확인합니다. Exchange Server Analyzer는 이 이름을 검색한 후 이름의 문자 수를 셉니다.

Exchange Server Analyzer는 다음 레지스트리 항목을 읽어 Exchange Server 컴퓨터의 레지스트리에 저장된 Exchange 서버의 호스트 이름 값도 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

또한 Exchange Server Analyzer는 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Windows® 클러스터 서비스 ClusSvc의 Started 키 값을 확인합니다.

다음 조건에 모두 해당하면 Exchange Server Analyzer에서 기본 구성이 아니라는 메시지를 표시합니다.

  • CN=<ExchangeServerName> 값의 대/소문자가 Hostname 값과 일치하지 않습니다. 예를 들어 CN=ComputerName and Hostname이 COMPUTERNAME으로 설정되어 있습니다.

    참고:
    레지스트리에서 서버 이름의 대/소문자를 변경할 수 있지만 이 방법은 좋지 않습니다.
  • Exchange 서버 이름이 15자 이하입니다.

  • Exchange 서버가 Windows 클러스터에서 실행되고 있지 않습니다.

일반적으로 Exchange 서버 이름이 레지스트리에서 수동으로 변경된 경우 이 오류가 발생합니다.


서버 이름이 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 This Server 값 설정을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

또한 Exchange Server Analyzer는 각 Exchange 서버 개체의 name 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

Exchange Server Analyzer는 ClusSvc(Cluster Service)의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Microsoft Windows® Management Instrumentation) 클래스를 쿼리합니다. TRUE 값은 Cluster Service가 시작되었음을, FALSE 값은 Cluster Service가 실행되고 있지 않음을 나타냅니다.

Exchange Server Analyzer는 This Server 키 값이 서버 클러스터에서 실행되고 있지 않은 Exchange Server 컴퓨터의 Active Directory에 포함된 해당 서버 개체의 name 특성 값과 일치하지 않을 경우 오류를 표시합니다.

이 오류를 해결하려면 DSA Computer 레지스트리 키를 Active Directory의 name 특성 값과 일치하도록 편집해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. 오른쪽 창에서 This Server를 두 번 클릭하고 이 컴퓨터의 이름을 정확히 입력한 다음 확인을 클릭합니다.

  4. 레지스트리 편집기를 닫고 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


서버 이름이 너무 깁니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-02-22

Microsoft® Exchange Server Analyzer Tool은 개체 클래스가 msExchExchangeServer인 각 디렉터리 개체의 이름(cn)을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. cn 값은 Exchange Server 컴퓨터의 약식 이름을 포함하는 문자열입니다. Exchange Server Analyzer는 cn을 검색하여 문자열의 길이를 확인합니다. 문자열의 길이는 Exchange Server 이름의 문자 수입니다. Exchange Server Analyzer는 Exchange Server 이름이 15자를 초과하는 경우에 오류를 표시합니다.

Exchange Server 2007, Exchange Server 2003 및 Exchange 2000 Server에는 네트워크 토폴로지에 따라 모든 Exchange 구성 요소를 성공적으로 작동하기 위해 여러 서브넷에서 NetBIOS 이름 확인을 필요로 하는 NetBIOS 종속성이 있습니다. NetBIOS 명명 규칙에 따라 NetBIOS 이름에는 16자를 사용할 수 있습니다. 그러나 Microsoft는 NetBIOS 이름을 15자로 제한하고 16번째 문자를 NetBIOS 접미사로 사용합니다.

Exchange Server의 NetBIOS 종속성과 15자를 초과할 수 없는 NetBIOS 이름의 규칙 때문에 Exchange 조직의 서버 이름은 15자를 초과할 수 없습니다. 또한 Exchange Server 컴퓨터의 이름을 바꾸면 전체 Active Directory와 Exchange 조직에 큰 영향을 줄 수 있기 때문에 Exchange Server 컴퓨터의 이름은 지원되지 않습니다.

이 오류를 해결하려면 다음을 수행하십시오.

  1. 제거 옵션을 사용하여 잘못 명명된 Exchange Server 컴퓨터를 제거합니다.

  2. 컴퓨터의 이름을 15자 이하의 이름으로 변경합니다.

  3. 컴퓨터에 Exchange Server를 다시 설치합니다.

Exchange Server 2007 제거에 대한 내용은 Microsoft Exchange Server 2007 배포 문서의 "How to Completely Remove Exchange 2007 from a Server" (http://go.microsoft.com/fwlink/?LinkId=79246)를 참조하십시오.

Exchange Server 2003을 제거하는 방법에 대한 자세한 내용은 Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)의 "Exchange Server 2003 제거 방법"을 참조하십시오.

자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 833396, "컴퓨터에서 Exchange 2003을 제거하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833396)

  • 260378, "XADM: 수동으로 Exchange 2000 설치를 제거하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260378)

  • 328810, "XADM: 서버 간에 사서함 이동"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)

  • 821829, "Moving Mailboxes in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)


서버 RPC 네트워크 주소가 Exchange 서버 이름과 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 디렉터리에 있는 각 Exchange Server 개체의 networkAddress 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 다중 문자열 특성에 해당하는 여러 대표적인 항목이 아래 나열되어 있습니다.

ncacn_ip_tcp:<Exchange Server의 정규화된 도메인 이름>

ncacn_np:<Exchange Server의 호스트 이름>

ncacn_spx:<Exchange Server의 호스트 이름>

ncacn_vns_spp:<Exchange Server의 호스트 이름>

ncalrpc:<Exchange Server의 호스트 이름>

netbios:<Exchange Server의 호스트 이름>

또한 Exchange Server Analyzer는 각 Exchange Server 개체의 name 특성 값을 확인할 때 Active Directory를 쿼리합니다.

Exchange Server Analyzer는 name 특성 값이 networkAddress 특성에 있는 문자열의 이름 부분과 일치하지 않을 경우 오류를 표시합니다.

이 오류는 관리자가 서버 개체의 cn 값을 수동으로 변경했을 때 발생합니다. Exchange Server가 작성 및 유지하는 networkAddress 특성에는 Exchange Server에서 사용할 수 있는 다양한 네트워크 통신 프로토콜을 지원하기 위한 다중 문자열 값이 들어 있습니다. 각 값은 특정 프로토콜에서 필요로 하는 적합한 서버 이름 양식을 해당 프로토콜과 연결합니다.

이 오류를 수정하려면 서버 이름이 변경되었는지 또는 해당 값이 잘못 설정되었는지 여부를 확인한 다음 적절한 작업을 수행합니다.

  • 서버 이름이 변경된 경우에는 이 문서 후반부의 절차를 따라 해당 값을 적절하게 수정합니다.

  • 다른 이유로 값이 잘못되어 있는 경우에는 서버에서 Exchange 설치 프로그램을 다시 실행합니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집이나 비슷한 도구를 사용하여 Active Directory에서 관리 그룹 개체를 찾습니다.

    networkAddress 특성은 다음 위치에 있습니다.

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=Administrative Group Name, CN=Servers, CN=Server Name

  2. 각 값의 형식은 목록에 나와 있습니다. 필요한 경우 값을 업데이트하고 각 값의 서버 이름 부분만 변경합니다.

    참고:
    ncacn_ip_tcp 값에 해당하는 서버 이름이 NetBIOS 이름이나 인터넷 프로토콜(IP) 주소가 아닌 정규화된 도메인 이름(FQDN)인지 확인합니다.

  3. Active Directory 편집기를 닫은 다음 Exchange Routing Engine 서비스를 다시 시작합니다.

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

Exchange 라우팅 문제에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)에서 "라우팅 문제 해결"을 참조하십시오.


SPN(서비스 사용자 이름) 누락
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-08-14

The Microsoft® Exchange Server Analyzer Tool에서는 Active Directory® 디렉터리 서비스를 쿼리하여 아래 테이블에 나열된 Exchange 리소스에 대한 Exchange 서버 컴퓨터 계정의 servicePrincipalName 특성에 대한 반환된 값을 찾습니다.

Exchange 리소스 servicePrincipalName 값 | 반환된 예상 값
exchangeMDB | 정규화된 도메인 이름(FQDN)
exchangeMDB | NetBIOS 이름
exchangeRFR | 정규화된 도메인 이름(FQDN)
exchangeRFR | NetBIOS 이름
SMTP | 정규화된 도메인 이름(FQDN)
SMTP | NetBIOS 이름
SMTPSVC | 정규화된 도메인 이름(FQDN)
SMTPSVC | NetBIOS 이름
HOST | 정규화된 도메인 이름(FQDN)
HOST | NetBIOS 이름

Exchange Server Analyzer에서 Exchange 리소스의 컴퓨터 계정에 대한 servicePrincipalName 특성에 나열된 예상 값 중 하나가 누락되었음을 발견하면 오류 메시지가 표시됩니다.

SPN(서비스 사용자 이름)은 서비스 인스턴스를 식별하는 고유한 이름이며 서비스 인스턴스를 실행하는 로그온 계정과 연결되어 있습니다. SPN이 올바르게 설정되어 있지 않으면 Exchange 서비스에서 Kerberos 인증을 사용할 수 없습니다.

  • Microsoft Office Outlook® 2003 이상을 실행하는 클라이언트와 Exchange Information Store(사서함 데이타) 간의 인증 문제는 exchangeMDB 리소스에 대해 유효한 SPN이 없을 수 있음을 나타냅니다.

  • Active Directory 인증 문제가 있는 Outlook 2003 이상의 클라이언트는 exchangeRFR 리소스에 대해 유효한 SPN이 없을 수 있음을 나타냅니다.

  • SMTP(Simple Mail Transport Protocol) 가상 서버 간의 인증 실패는 SMTPSVC 또는 HOST 리소스에 대해 유효한 SPN이 없을 수 있음을 나타냅니다.

이 문제를 해결하려면 다음 단계를 따라 영향을 받는 특성에 대해 누락된 값을 추가합니다.

누락된 값을 사용하여 SPN을 추가하려면 SETSPN.exe 도구를 사용합니다.

  1. Setspn.exe 도구를 설치합니다. Setspn.exe 도구를 얻으려면 http://go.microsoft.com/fwlink/?LinkId=28103(영문)의 "Windows 2000 Resource Kit Tool : Setspn.exe"를 참조하십시오.

    Setspn.exe 명령줄 도구의 Windows Server 2003 버전은 Windows Server 2003 CD에 포함된 Windows Server 2003 지원 도구에서 사용할 수 있습니다. Server 2003 지원 도구를 설치하려면 지원/도구 폴더 안의 Suptools.msi 파일을 두 번 클릭합니다.

  2. Exchange 서버의 Active Directory 개체에 누락된 값을 추가하려면 SETSPN.EXE Setspn_d.txt 파일의 지침을 따릅니다. 다음 예는 가상 SMTP 서버 SPN의 FQDN 값 추가에 대해 설명합니다.

    • 명령 프롬프트를 시작하고 Setspn.exe를 설치한 디렉터리로 변경합니다.

    • 명령 프롬프트에 다음 명령을 입력합니다.

      setspn.exe-a SMTPSVC/ mail.도메인 이름.com YOURSERVERNAME

      참고:
      mail.yourdomain.com을 SMTP 가상 서버 FQDN로 바꾸고 YOURSERVERNAME을 Exchange 서버 이름으로 바꿉니다.
      그런 다음 Enter 키를 누릅니다.


최근 24시간 이내 서비스가 예기치 않게 종료됨
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-02-14

Microsoft Exchange Analyzer Tool은 서비스 제어 관리자 원본에 대한 이벤트 7031 경고가 최근 24시간 이내 기록되었는지 여부를 확인할 때 Win32_NTLogEvent Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다.

이벤트 7031 경고는 지정한 서비스를 계속할 수 없음을 의미합니다. 서비스는 실패 횟수를 보고하도록 구성되어 있으며 특정 실패 횟수가 보고된 후에 서비스 제어 관리자는 지정된 서비스에 대해 구성된 복구 작업을 수행합니다.

최근 24시간 이내 이러한 이벤트 중 하나 이상이 기록되면 Exchange Analyzer에서는 정보 메시지를 표시합니다.

이 문제는 다음과 같은 가장 일반적인 경우를 포함하여 다양한 문제로 인해 발생할 수 있습니다.

  • 손상된 메시지가 처리되고 있는 경우

  • 바이러스 백신 응용 프로그램 구성에 문제가 있는 경우

이 문제를 해결하려면 다음을 수행합니다.

  • Microsoft 기술 자료 문서 286350, "ADPlus를 사용하여 "중지"와 "충돌" 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=286350)의 안내에 따라 응답하지 않거나(중단) 예기치 않게 중지(충돌)되는 프로세스의 원인을 파악합니다.

  • Microsoft Windows 2000용 최신 서비스 팩을 구합니다.

  • Microsoft Exchange Server용 최신 서비스 팩을 구합니다.

  • 바이러스 백신 응용 프로그램 공급업체에 문의하여 최신 업데이트 및 구성 정보를 구합니다.

자세한 정보

이벤트 7031 경고 정보에 대한 자세한 내용은 "이벤트 및 오류 메시지 센터: 이벤트 세부 정보"(http://go.microsoft.com/fwlink/?LinkId=83114)를 참조하십시오.

Windows 2000 Server용 최신 서비스 팩을 구하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 260910, "최신 Windows 2000 서비스 팩을 구하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260910)을 참조하십시오.

Exchange 2000 Server용 최신 서비스 팩을 구하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 301378, "최신 Exchange 2000 Server 서비스 팩을 구하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378)을 참조하십시오.

Exchange Server 2003용 최신 서비스 팩을 구하는 방법에 대한 자세한 내용은 "Why Try Service Pack 2 for Exchange Server 2003?"(http://go.microsoft.com/fwlink/?LinkId=52073)을 참조하십시오.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Services Value is Missing or Inaccessible
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-07-24

Microsoft Exchange Analyzer Tool은 다음 레지스트리 항목을 읽어 서비스 문자열 종류 값의 존재 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Setup

Exchange Analyzer는 서비스 문자열 종류 값이 없거나 액세스할 수 없는 경우 오류를 표시합니다.

이 오류는 Exchange 설치 루트 경로를 보관하는 데 사용되는 서비스 문자열 종류 값이 없거나 액세스할 수 없음을 나타냅니다. Exchange 설치 루트 경로가 없으면 중요 드라이버 및 프로토콜을 초기화하지 못하고 그 결과 Exchange 정보 저장소 및 종속된 서비스가 시작 시 실패할 수 있습니다.

이 오류를 해결하려면 Microsoft 기술 자료 문서 285116, "Exchange 저장소가 시작되지 않는다: 오류 7024, 1026, 9542 및 5000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=285116)의 안내를 따르십시오.


단일 약속 있음/없음 복제본 발견
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 각 관리 그룹에 있는 약속 있음/없음 복제본 수를 확인할 때 root\MicrosoftExchangeV2 네임스페이스의 Exchange_PublicFolder Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

Exchange Server Analyzer는 단일 약속 있음/없음 복제본이 관리 그룹에 존재할 경우 유용한 정보 메시지를 표시합니다.

일반적으로 약속 있음/없음 폴더의 복제본이 각 관리 그룹에 둘 이상 존재하는 것이 좋습니다. 경우에 따라 다수의 약속 있음/없음 복제본이 성능 및 복원을 향상시킬 수도 있습니다. 큰 Exchange 조직에서는 단일 약속 있음/없음 데이터의 복제본이 오버로드될 수 있습니다. 모든 Exchange 조직에서는 단일 약속 있음/없음 데이터의 복제본이 오류가 발생하는 단일 지점입니다.

다음 사항을 고려해야 하지만 다수의 복제본을 사용하는 것이 좋습니다.

  • 다수의 복제본은 네트워크 전반에 복제 소통량을 추가로 발생시킵니다.

  • 다수의 복제본을 사용하면 일정 충돌의 위험이 증가합니다.

사서함 10,000개마다 복제본이 하나 이상 있어야 합니다.

약속 있음/없음 폴더 및 약속 있음/없음 정보 게시에 대한 자세한 내용은 "Exchange Server 2003 저장소 작업"(http://go.microsoft.com/fwlink/?LinkId=47595)을 참조하십시오.


많은 수의 사서함에 대해 약속 있음/없음 복제본이 하나만 발견되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 root\MicrosoftExchangeV2 네임스페이스 아래의 Exchange_PublicFolder Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 ReplicaList 키의 항목 수를 확인합니다. 항목 수는 각 관리 그룹에 존재하는 약속 있음/없음 복제본 수를 나타냅니다.

또한 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스를 쿼리하여 각 사서함 저장소의 homeMDBBL 특성에 나열된 항목의 개수를 확인합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함 수를 나타냅니다.

Exchange Server Analyzer는 10,000개가 넘는 사서함이 있는 관리 그룹에 약속 있음/없음 복제본이 하나만 있으면 오류를 표시합니다.

일반적으로 각 관리 그룹에 약속 있음/없음 폴더의 복제본이 둘 이상 있는 것이 좋습니다. 약속 있음/없음 복제본이 여러 개 있으면 성능 및 복원 기능이 향상될 수도 있습니다. 대규모 Exchange 조직에 약속 있음/없음 데이터 복제본이 하나만 있으면 과부하 상태가 될 수도 있습니다. 어떠한 Exchange 조직에서도 약속 있음/없음 데이터 복제본이 하나만 있으면 한 곳에서만 오류가 발생합니다.

다음과 같은 고려 사항에도 불구하고 복제본을 여러 개 사용하는 것이 좋습니다.

  • 복제본이 여러 개 있으면 네트워크상에 복제 소통량이 추가로 발생합니다.

  • 복제본이 여러 개 있으면 일정 충돌 위험이 증가합니다.

사서함 10,000개당 복제본이 하나 이상 있어야 합니다.

약속 있음/없음 폴더 및 약속 있음/없음 정보 게시에 대한 자세한 내용은 "Exchange Server 2003 저장소 작업"(http://go.microsoft.com/fwlink/?LinkId=47595)을 참조하십시오.


토폴로지에 단일 글로벌 카탈로그가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 토폴로지에 있는 글로벌 카탈로그 서버 수를 확인할 때 root\MicrosoftExchangeV2 네임스페이스의 Exchange_DSAccess Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 글로벌 카탈로그 서버 수는 DSAccessNameGC WMI 키에 대한 항목 수를 세어 확인됩니다. Exchange Server Analyzer는 토폴로지에 글로벌 카탈로그 서버가 한 개만 있을 경우 유용한 정보 권장 사항을 표시합니다.

내결함성이 발생할 경우 Exchange Server 및 사용자에게 서비스를 제공할 수 있는 글로벌 카탈로그 서버가 두 개 이상 있는 것이 좋습니다. 단일 글로벌 카탈로그 서버는 단일 지점에서 오류가 발생했음을 의미합니다. Exchange 2000 Server와 Exchange Server 2003 및 Exchange Server 2007은 다양한 기능을 위해 여러 글로벌 카탈로그 서버에 의존합니다. 글로벌 카탈로그 서버를 사용할 수 없을 경우 메일 배달이 느려지거나 완전히 정지할 수 있습니다. 그리고 Exchange Server 서비스가 시작하지 않을 수도 있습니다. Exchange Server 서비스가 시작하지 않으면 사용자는 사서함에 액세스할 수 없습니다.

확장성과 내결함성의 경우 각 Active Directory® 디렉터리 서비스 사이트에서 두 개 이상의 글로벌 카탈로그 서버를 구성하는 것이 좋습니다. 사이트에서 여러 도메인을 사용하면 Exchange 2000 Server 컴퓨터나 Exchange Server 2003 컴퓨터 또는 Exchange Server 2007 컴퓨터와 클라이언트가 상주하는 각 도메인에 대해 글로벌 카탈로그를 구성하는 것이 좋습니다. 4개의 Exchange Server 컴퓨터 프로세스마다 한 개의 글로벌 카탈로그 서버를 배포하는 것이 좋습니다.

추가 글로벌 카탈로그 서버를 만드는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 313994, "HOWTO: Windows Server 2000에서 글로벌 카탈로그를 만들거나 이동하기"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994)를 참조하십시오.

Exchange Server와 관련된 글로벌 카탈로그 서버 배치 및 가용성에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 875427, "Global catalog server placement and ratios in an Exchange 2000 Server organization or in an Exchange Server 2003 organization"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427)

  • 322801, "Exchange System Attendant Does Not Start, and You Receive a 'Global Catalog Servers Not Responding' Error Message"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322801)

  • 829361, "Exchange Server 2003 Computer Takes Longer Than You Expect to Shut Down"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829361)

  • 304403, "Exchange Considerations for Promoting a Domain Controller to a Global Catalog Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403)

  • 305065, "Exchange Server-Related Considerations for Demoting a Global Catalog Server to a Domain Controller"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065)


사이트 폴더 서버가 삭제되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-03-01

Microsoft® Exchange Server Analyzer Tool은 각 관리 그룹 개체의 siteFolderServer 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 siteFolderServer 특성 값에 DEL:이라는 문자열이 들어 있는 경우 오류를 표시합니다.

siteFolderServer 특성은 사이트 폴더를 호스팅하는 공용 폴더 저장소(일반적으로 해당 사이트나 관리 그룹에 있는 첫 번째 서버)의 DN(고유 이름)을 나타냅니다.

기본적으로 사이트 폴더 서버는 해당 관리 그룹에 설치되어 있는 첫 번째 서버입니다. 이 서버의 공용 폴더 저장소는 해당 관리 그룹의 약속 있음/없음 폴더와 오프라인 주소록 폴더의 기본 위치에 해당합니다. 이러한 폴더를 다른 서버로 복제하지 않고 해당 서버를 오프라인 주소록 서버로 지정하지 않은 상태에서 이 서버를 제거하거나 역할을 해제하면 Microsoft Office Outlook® 2003 사용자에게 오프라인 주소록과 약속 있음/없음 데이터에 문제가 있는 것으로 나타납니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 엽니다.

  2. 구성 컨테이너에서 다음 노드를 확장하여 사이트 폴더 서버로 지정할 공용 폴더 정보 저장소를 찾습니다.

    CN=Configuration,DC=<DomainName>,DC=com, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdministrativeGroupName> CN=Servers, CN=<ServerName>, CN=InformationStore, CN=<StorageGroupName>

  3. 오른쪽 창에서 CN=<PublicFolderStoreName>을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 특성 필드에서 아래로 스크롤하여 distinguishedName 특성을 선택합니다.

  5. Edit를 클릭한 다음 전체 특성을 클립보드로 복사합니다.

  6. 구성 컨테이너를 확장한 다음 CN=Configuration,CN=<DomainName>,CN=com, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups를 확장합니다.

  7. 수정할 관리 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  8. 특성 필드에서 아래로 스크롤하여 siteFolderServer 특성을 선택합니다.

  9. Edit를 클릭한 다음 distinguishedName 특성 값을 Value 필드에 붙여 넣습니다.

  10. Value 필드의 내용을 두 번 검사하여 올바르게 붙여 넣었는지 확인한 다음 OK를 클릭하여 변경 내용을 저장합니다.

  11. 확인을 클릭하여 관리 그룹 속성을 닫습니다.

  12. Active Directory 편집기를 종료하고 해당 사이트 내의 모든 Exchange Server 컴퓨터에서 Microsoft Exchange Server Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

시스템 폴더 다시 만들기 및 사이트 폴더 서버 다시 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 822444, "How To: Exchange Server 2003에서 사이트 폴더 다시 설정"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822444)

  • 275171, "XADM: Exchange 2000 Server에서 시스템 폴더를 재설정하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=275171)

  • 284200, "Schedule+ Free/Busy System Folder Is Missing"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200)

LDP 도구 사용에 대한 자세한 내용은 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


Active Directory 디렉터리 서비스 호출 지연
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-14

Microsoft® Exchange Server Analyzer Tool은 응답 시간이 2.5초를 넘는 Active Directory® 디렉터리 서비스 구성 요소 이벤트를 확인하기 위해 Exchange FCL(함수 호출 로그), Store.fcl 파일을 검사합니다.

Exchange FCL Active Directory 구성 요소 이벤트는 Active Directory 구성 요소에 대한 Microsoft Exchange Information Store 서비스(Store.exe) 함수 호출을 나타냅니다.

Active Directory는 모든 사서함 정보, 주소 목록 서비스 및 기타 받는 사람 관련 정보를 제공합니다. 대부분의 Exchange Server 2003 구성 정보도 Active Directory에 저장됩니다.

Exchange 서버 서비스는 Active Directory에 저장된 정보에 액세스하며 Active Directory에 정보를 기록합니다.

Exchange Server Analyzer는 FCL 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 Active Directory 함수 호출에 대한 응답 시간이 2.5초를 넘는 이벤트를 발견하는 경우 오류를 표시합니다.

서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

다음과 같은 조건에서 Microsoft Exchange Information Store 서비스에서 Active Directory로의 호출에 대한 응답 시간이 2.5초를 넘게 되는 경우가 발생할 수 있습니다.

  • Exchange 서버와 도메인 컨트롤러 사이의 네트워크 대기 시간

  • DSAccess의 정적 또는 잘못된 구성

  • 오버로드된 도메인 컨트롤러 및 글로벌 카탈로그

  • 잘못 설계된 Active Directory 토폴로지

이 오류를 해결하려면 다음 단계를 수행합니다.

  • Exchange Server Analyzer를 실행하여 서버 문제를 추가적으로 분석합니다. "Microsoft Exchange Server Best Practices Analyzer Tool v2.7"(http://go.microsoft.com/fwlink/?LinkId=34705)에서 Exchange Server Analyzer를 다운로드할 수 있습니다.

  • Active Directory 도메인 컨트롤러 서버의 성능을 확인합니다.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

Exchange 성능 및 DSAccess에 대한 자세한 내용은 Microsoft 기술 자료 문서 250570, "디렉터리 서비스 서버 감지 및 DSAccess 사용"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570)을 참조하십시오.

Exchange 서버 성능에 대한 자세한 내용은 "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

Exchange 서버 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

정보 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.

도메인 컨트롤러 성능에 대한 자세한 내용은 다음 Windows Server 리소스를 참조하십시오.

  • "Planning Domain Controller Capacity" (http://go.microsoft.com/fwlink/?LinkId=70191)

  • Windows 2000 Server Active Directory Planning and Deployment Guides의 "Active Directory Monitoring of Domain Controllers"(http://go.microsoft.com/fwlink/?LinkId=70193)


ESE 호출 지연
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-13

Microsoft® Exchange Server Analyzer Tool은 응답 시간이 2.5초를 초과하는 Exchange ESE(확장 가능한 저장소 엔진) 구성 요소 이벤트를 확인하기 위해 Exchange FCL(함수 호출 로그), Store.fcl 파일을 검사합니다.

Exchange FCL ESE 구성 요소 이벤트는 ESE 구성 요소에 대한 Microsoft Exchange Information Store 서비스(Store.exe) 함수 호출을 나타냅니다.

Exchange Information Store는 ESE 데이터베이스의 맨 위에 위치합니다. ESE는 트랜잭션 기반의 고급 데이터베이스 엔진입니다. 트랜잭션이란 보이지 않는 원자 단위로 처리되는 일련의 작업을 말합니다. 트랜잭션의 모든 작업은 완료되어 영구 저장된 것이거나 작업이 수행되지 않은 것입니다.

Exchange 서버에서는 데이터베이스 구조를 결정하고 메모리를 관리하기 위해 포함된 데이터베이스 엔진으로 ESE를 사용합니다. 데이터베이스 엔진은 4KB의 데이터 청크(페이지)를 메모리 내부와 외부로 전송하여 데이터베이스를 메모리에 캐시합니다. 또한 메모리에 있는 페이지를 업데이트하고 새로운 또는 업데이트된 페이지를 다시 디스크에 씁니다. 요청이 시스템에 도달하면 데이터베이스 엔진은 데이터를 메모리에 버퍼링합니다. 따라서 디스크에 지속적으로 액세스할 필요가 없습니다.

데이터를 메모리에 캐싱하면 데이터를 가장 빠르고 효율적으로 처리할 수 있지만 Exchange가 실행 중인 동안 디스크의 정보는 완전한 최신 정보가 아닙니다. 하지만 트랜잭션 로그 디스크는 항상 각 트랜잭션에 대한 정보와 함께 현재 상태로 유지됩니다. 그러나 메모리의 여러 가지 변경 사항이 디스크에 아직 반영되지 않았으므로 데이터베이스와 메모리는 동기화되지 않습니다.

Exchange Server Analyzer는 Store.fcl 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 ESE 구성 요소 함수 호출에 대한 응답 시간이 2.5초를 넘는 이벤트를 발견하는 경우 오류를 표시합니다.

Microsoft Exchange Information Store 서비스(Store.exe)의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

ESE로부터의 진행 중인 호출은 다음과 같은 조건에서 발생할 수 있습니다.

  • Exchange 온라인 조각 모음

  • 데이터 백업

    참고:
    데이터 백업이나 온라인 조각 모음을 의도적으로 Exchange 호출 추적 로깅 수집 중에 실행하는 경우라면 Exchange 서버 성능 문제를 알리는 이 메시지를 무시해도 됩니다.
  • 데이터베이스 드라이브 상의 지체

이 오류를 해결하려면 다음 단계를 수행합니다.

  • 백업 Windows 또는 온라인 유지 관리를 사용자 요구가 많은 시간대와 겹치지 않도록 하는 것이 가장 좋습니다.

  • Exchange Server Analyzer를 실행하여 서버 문제를 추가적으로 분석합니다. "Microsoft Exchange Server Best Practices Analyzer Tool v2.7"(http://go.microsoft.com/fwlink/?LinkId=34705)에서 Exchange Server Analyzer를 다운로드할 수 있습니다.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

온라인 조각 모음 시간 창을 구성하는 방법에 관한 자세한 내용은 Microsoft 기술 자료 문서 244524, "XADM: How to Configure the Exchange Server Online Defragmentation Time Window"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524)를 참조하십시오.

Exchange 서버 디스크 지체 문제에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

Exchange 서버에서 디스크 크기를 설정하고 최적화하는 방법에 관한 자세한 내용은 Exchange Server 2003의 저장소 최적화(http://go.microsoft.com/fwlink/?linkid=49324)의 "디스크 I/O 요구 사항을 계산하는 방법" 및 "여러 아키텍처에 공통적인 유용한 정보"를 참조하십시오.

ESE에 대한 자세한 내용은 "Extensible Storage Engine Architecture"(http://go.microsoft.com/fwlink/?linkid=67009)를 참조하십시오.


IMAIL 호출 지연
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-12

Microsoft® Exchange Server Analyzer Tool은 MAPI 클라이언트의 IMAIL 구성 요소에 대한 응답 시간이 2.5초를 초과하는 이벤트를 확인하기 위해 FCL(Exchange Function Call Log), Store.fcl 파일을 검사합니다.

Exchange FCL IMAIL MAPI 구성 요소 이벤트는 메시지를 인터넷 형식으로 변환하고 인터넷 형식에서 MAPI 형식으로 변환하기 위한 Microsoft Exchange Information Store 서비스(Store.exe) 함수 호출을 나타냅니다.

Exchange 서버의 IMAIL 구성 요소는 인터넷과 MAPI 메시지 사이에서 Microsoft Exchange Information Store 서비스가 사용하는 유연한 변환 서비스입니다. 이 서비스를 통해 RFC-822 또는 인터넷 형식을 사용하는 클라이언트와 MAPI 클라이언트 또는 내부 저장소 작업과 같은 Exchange 서버 내부 저장소 형식을 사용하는 클라이언트 간에 상호 연동이 가능합니다.

Exchange에서는 IMAIL 메커니즘을 사용하여 Exchange System Manager의 인터넷 도메인에 대해 정의되거나 또는 Microsoft Office Outlook®의 받는 사람별 사용자에 의해 지정된 내용에 따라 메시지 형식을 콘텐츠에 적용합니다. IMAIL에 전달된 서식 매개변수가 없는 경우 IMAIL은 S/TNEF(Summary TNEF) 형식으로 MAPI 메시지의 서식을 지정하여 서버 간에 전송합니다 .

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 MAPI 클라이언트 구성 요소 함수 호출의 IMAIL 구성 요소에 대한 응답 시간이 2.5초를 넘는 이벤트를 발견하는 경우 오류를 표시합니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

다음과 같은 조건에서 IMAIL에 대한 Exchange Information Store 서비스(Store.exe) 함수 호출에 대한 응답 시간이 느려질 수 있습니다.

  • IMAIL의 메시지 또는 첨부 파일에 처리해야 할 데이터가 많습니다.

  • 데이터 변환을 요청하는 클라이언트가 많습니다.

  • DSAccess 요청에 대한 응답이 느립니다.

  • TEMP 및 TMP 드라이브에 병목 현상이 발생합니다.

  • 사서함 이동 작업이 진행 중입니다.

  • 이 오류를 해결하려면 다음 단계를 수행합니다.

  • 사용량이 많지 않은 시간대에 사서함 이동을 예약합니다.

  • 메시지 및 첨부 파일 크기 제한과 같은 서버 문제의 추가 분석을 위해 Exchange Server Analyzer를 실행합니다. "Microsoft Exchange Server Best Practices Analyzer Tool v2.7"(http://go.microsoft.com/fwlink/?LinkId=34705)에서 Exchange Server Analyzer를 다운로드할 수 있습니다.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

Exchange 서버 디스크 지체 문제에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

Exchange 서버에서 디스크 크기를 설정하고 최적화하는 방법에 관한 자세한 내용은 Exchange Server 2003의 저장소 최적화(http://go.microsoft.com/fwlink/?linkid=49324)의 "디스크 I/O 요구 사항을 계산하는 방법" 및 "여러 아키텍처에 공통적인 유용한 정보"를 참조하십시오.

Exchange 서버의 메시지 크기 제한에 대한 유용한 정보에 관한 자세한 내용은 보내는 메시지의 최대 크기가 설정되지 않습니다.을 참조하십시오.


LSASS 호출 지연
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-12-04

Microsoft® Exchange Server Analyzer Tool은 응답 시간이 25밀리초를 초과하는 Local Security Authentication Server(Lsass.exe) 프로세스 구성 요소 이벤트를 확인하기 위해 FCL(Exchange Function Call Log), Store.fcl 파일을 검사합니다.

Exchange FCL LSASS 프로세스 구성 요소 이벤트는 Local Security Authentication Server(Lsass.exe) 프로세스 구성 요소에 대한 Microsoft Exchange Information Store service(Store.exe) 함수 호출을 나타냅니다.

Local Security Authentication Server 프로세스(Lsass.exe)는 계정 정보 및 로그온 유효성 검사를 확인하기 위해 다른 프로세스에서 호출하는 보안 하위 시스템입니다.

Exchange 클라이언트에 로그온할 때마다 Exchange Server를 실행하는 서버는 클라이언트에 대한 계정 SID(Security identifier)를 조회하기 위한 요청을 보내고 Local Security Authentication Server(Lsass.exe) 프로세스 내에 호출을 만듭니다.

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 Local Security Authentication Server(Lsass.exe) 구성 요소 함수 호출에 대한 응답 시간이 25밀리초를 넘는 이벤트를 발견하는 경우 오류를 표시합니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange Server 성능 문제가 발생할 수 있습니다.

다음과 같은 조건에서 LSASS에 대한 Microsoft Exchange Information Store 서비스(Store.exe) 함수 호출에 대한 응답 시간이 느려질 수 있습니다.

  • 동시에 인증하는 사용자 수와 관련된 서버 리소스 문제

  • Exchange Server 및 도메인 컨트롤러 또는 글로벌 카탈로그 서버 간 네트워크 대기 시간

  • 서버 리소스 지체 문제

이 오류를 해결하려면 다음 단계를 수행하십시오.

  • 'NeverPing' 매개 변수 권장에서 설명된 NeverPing 매개 변수를 구현합니다.

  • 메시지 및 첨부 파일 크기 제한과 같은 서버 문제의 추가 분석을 위해 Exchange Server Analyzer를 실행합니다. "Microsoft Exchange Server Best Practices Analyzer Tool v2.7"(http://go.microsoft.com/fwlink/?LinkId=34705)에서 Exchange Server Analyzer를 다운로드할 수 있습니다.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

추가 정보

Lsass.exe 프로세스 및 메모리 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 308356, "Windows Server 2003 또는 Windows 2000 Server를 실행하는 도메인 컨트롤러에서 Lsass.exe 프로세스의 메모리 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)을 참조하십시오.

Exchange 클라이언트 로그온 및 LSASS 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 161938, "Slow Exchange Client Logons Due to Resource Deadlock"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938)을 참조하십시오.

Exchange 서버와 도메인 컨트롤러 또는 글로벌 카탈로그 서버 간 네트워크 대기 시간에 대한 자세한 내용은 다음의 Exchange Server 팀 블로그 기사, "Exchange Does Not Always Use Local GCs"(http://go.microsoft.com/fwlink/?LinkId=69166)를 참조하십시오.

참고:
블로그의 내용과 해당 URL은 예고 없이 변경될 수 있습니다.

서버 리소스 지체에 문제에 대한 자세한 내용은 프로세서 지체를 참조하십시오.

Exchange Server 성능에 대한 자세한 내용은 "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

Exchange Server 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

정보 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.


바이러스 스캐너 호출 지연
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-11

Microsoft® Exchange Server Analyzer Tool은 응답 시간이 2.5초를 초과하는 Virusscan Virus API(VAPI) 구성 요소 이벤트를 확인하기 위해 FCL(Exchange Function Call Log), Store.fcl 파일을 검사합니다.

Exchange FCL Virusscan VAPI 구성 요소 이벤트는 외부 바이러스 스캐너 소프트웨어에 대한 Microsoft Exchange Information Store 서비스(Store.exe) 함수 호출을 나타냅니다.

VAPI의 문제 해결 기능을 향상시키기 위해 Exchange 서버에서는 바이러스 검색 API의 성능 추적에 사용하기 위한 이벤트 로깅을 구현합니다.

다음과 같은 이벤트가 기록됩니다.

  • 공급업체 DLL의 로딩 및 언로딩

  • 성공적인 항목 검색

  • 정보 저장소에 있는 바이러스

  • 예기치 않은 VAPI 동작

Exchange Server Analyzer는 Store.fcl 로깅 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 외부 바이러스 스캐너 소프트웨어 함수 호출에 대한 응답 시간이 2.5초를 넘는 이벤트를 발견하는 경우 오류를 표시합니다.

Microsoft Exchange Information Store 서비스(Store.exe)의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

다음과 같은 조건에서 바이러스 검색 소프트웨어에 대한 Microsoft Exchange Information Store 서비스(Store.exe) 외부 함수 호출에 대한 응답 시간이 느려질 수 있습니다.

  • 정보 저장소에 있는 항목을 재검색하는 바이러스 스캐너로 업데이트합니다.

  • 잘못 구성된 바이러스 스캐너

  • 바이러스 스캐너 소프트웨어가 대용량 메시지 또는 첨부 파일을 처리합니다.

이 오류를 해결하려면 다음 단계를 수행합니다.

  • 리소스 소모가 낮을 때, 즉, 사용량이 많지 않은 시간대에 바이러스 엔진의 업데이트를 예약합니다.

  • 바이러스 검색 소프트웨어를 재설치하는 것을 검토하여 사용량이 많지 않은 시간대에 재설치합니다.

  • 바이러스 검색 엔진의 스레드 구성, 파일 수준 제외 등이 올바른지 검사합니다. Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)를 참조하십시오.

  • 본 설명서의 자세한 정보 섹션에 있는 내용을 검토합니다.

자세한 정보

Microsoft Exchange Server 2003에서 일반적으로 사용되는 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 823166, "XADM: Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)를 참조하십시오.

Microsoft Exchange 2000 Server에서 일반적으로 사용되는 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 328841, "Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)를 참조하십시오.

Exchange 서버 성능에 대한 자세한 내용은 "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

Exchange 서버 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

정보 저장소 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257725, "XADM: 정보 저장소 문제 해결을 위해 진단 데이터를 수집하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725)을 참조하십시오.


VSS 스냅숏 호출 지연
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-13

Microsoft® Exchange Server Analyzer Tool은 응답 시간이 20초를 초과하는 VSS(볼륨 섀도 복사본 서비스) 스냅숏 구성 요소 이벤트를 확인하기 위해 FCL(Exchange 함수 호출 로그), Store.fcl 파일을 검사합니다.

Exchange FCL VSS 구성 요소 이벤트는 VSS 스냅숏 구성 요소에 대한 Microsoft Exchange Information Store 서비스(Store.exe) 함수 호출을 나타냅니다.

VSS는 시스템의 응용 프로그램에서 계속하여 볼륨에 쓰는 작업을 할 때 볼륨 백업이 수행되도록 하는 프레임워크를 구현하는 일련의 COM API입니다.

Microsoft Exchange Server 2003에서는 Microsoft Windows Server(TM) 2003 운영 체제에 포함된 VSS를 사용하여 Exchange Server 2003 데이터베이스 및 트랜잭션 로그 파일의 볼륨 섀도 복사본을 만듭니다.

VSS 스냅숏은 원본 데이터와 완전히 관계가 없는 것은 아닙니다. 일반적으로 스냅숏은 시간에 마커를 정의하고 데이터가 해당 시간으로 롤백될 수 있음을 확인할 때 생성됩니다.

Exchange Sever Analyzer는 Store.fcl 파일에서 Microsoft Exchange Information Store 서비스(Store.exe)로부터 VSS 스냅숏 구성 요소 함수 호출에 대한 응답 시간이 20초를 넘는 이벤트를 발견하는 경우 오류를 표시합니다.

Microsoft Exchange Information Store 서비스(Store.exe)로부터의 상호 구성 요소 호출이 응답을 기다리는 경우 RPC(원격 프로시저 호출) 스레드가 이러한 요청 뒤에서 백업함으로 인해 클라이언트에 대한 서버 응답 지연과 같은 Exchange 서버 성능 문제가 발생할 수 있습니다.

참고:
VSS 스냅숏을 Exchange 호출 추적 로깅 수집 중 20초 이내에 의도적으로 시작한 경우라면 Exchange 서버 성능 문제를 나타내는 오류 메시지를 무시해도 안전합니다.

백업 창을 온라인 유지 관리 또는 사용자 요구가 많은 시간대와 겹치지 않도록 하는 것이 가장 좋습니다.

자세한 정보

VSS에 대한 자세한 내용은 "Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=56571)을 참조하십시오.


'SMTPSVC' 오류 이벤트(ID: 429)가 최근 24시간 이내에 기록되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-16

Microsoft Exchange Analyzer Tool은 IIS 메타데이터를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 가상 서버의 각 인스턴스에 대한 LM/SmtpSvc/%SMTPInstance%/ServerState 속성 값을 확인합니다.

ServerState 속성은 서버 인스턴스의 현재 상태를 나타냅니다. 상태 및 해당 상태 코드에는 1(시작 중), 2(시작됨), 3(중지하는 중), 4(중지됨), 5(일시 중지 중), 6(일시 중지됨), 7(계속) 등이 있습니다.

Exchange Analyzer는 SMTP 가상 서버 인스턴스의 ServerState 속성 값이 2(시작됨)와 같지 않으면 Win32_NTLogEvent Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리하여 최근 24시간 이내에 SMTP 서비스(SMTPSVC)에 대해 이벤트 429 오류가 기록되었는지 여부를 확인합니다.

Exchange Analyzer는 SMTP VSI(가상 서버 인스턴스)가 시작되지 않았으며 지난 24시간 이내에 SMTPSVC에 대해 이벤트 429가 최소한 하나 이상 기록된 경우 경고를 표시합니다.

이 경고는 SMTP 가상 서버 인스턴스에 대해 지정된 디렉터리에 문제가 있을 수 있음을 나타냅니다.

SMTP는 Exchange Server의 메일 전송을 위한 기본 메일 프로토콜입니다. 그러므로 클라이언트에서는 SMTP를 사용하여 메시지를 보내고 Exchange 서버에서는 SMTP를 사용하여 메시지와 메시지 데이터를 배달합니다.

SMTP 서비스를 통해 Exchange 컴퓨터에 해당 메시지가 도착하면 데이터는 하드 디스크에 .eml 파일로 기록됩니다. 기본적으로 이러한 파일은 Exchange가 설치된 것과 같은 파티션의 <드라이브>:\Program Files\Exchsrvr\Mailroot 폴더에 저장됩니다.

이 문제는 다음 중 한 가지에 의해 발생할 수 있습니다.

  • <드라이브>:\Program Files\Exchsrvr\Mailroot 디렉터리 경로 또는 해당 디렉터리 경로 아래의 폴더가 이동되었거나 없거나 손상되었습니다.

  • <드라이브>:\Program Files\Exchsrvr\Mailroot 또는 해당 디렉터리 경로 아래의 폴더에 대한 사용 권한이 적절하게 설정되어 있지 않습니다.

  • 바이러스 백신 응용 프로그램이 <드라이브>:\Program Files\Exchsrvr\Mailroot 디렉터리 경로 또는 해당 디렉터리 경로 아래의 폴더를 검사하고 있습니다.

이 경고를 해결하려면 다음 중 하나 이상을 수행합니다.

  • <드라이브>:\Program Files\Exchsrvr\Mailroot 디렉터리 경로 및 해당 디렉터리 경로 아래의 폴더 위치와 무결성을 확인합니다.

  • <드라이브>:\Program Files\Exchsrvr\Mailroot 디렉터리 경로 및 해당 디렉터리 경로 아래의 폴더에 대한 사용 권한을 확인합니다.

  • 바이러스 백신 응용 프로그램이 <드라이브>:\Program Files\Exchsrvr\Mailroot 디렉터리 경로에 있는 폴더를 검색하고 있지 않은지 확인합니다.

Exchange Server 2003의 Mailroot 디렉터리 경로를 확인하려면 다음을 수행합니다.

  1. Exchange 시스템 관리자를 엽니다.

  2. 서버, Exchange Server, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 중지를 클릭합니다.

  4. SMTP 가상 서버를 마우스 오른쪽 단추로 다시 클릭한 다음 속성을 클릭합니다.

  5. 메시지 탭을 클릭합니다.

  6. 큐 디렉터리 필드에서 해당 Mailroot 폴더의 전체 경로를 확인합니다. 찾아보기를 클릭하여 로컬 컴퓨터에서 해당 경로를 찾아볼 수 있습니다.

  7. 확인을 클릭하여 변경 내용을 저장합니다.

  8. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.
Exchange 2000 Server의 Mailroot 디렉터리 경로를 확인하려면 다음을 수행합니다.

  1. 해당 SMTP 가상 서버 Mailroot 폴더를 확인하려는 Exchange 2000 Server 컴퓨터의 모든 Exchange Server 및 IIS 서비스를 중지합니다.

  2. 영향을 받는 SMTP 가상 서버의 msExchSmtpQueueDirectory 값이 적절한 경로로 구성되어 있는지 확인합니다.

  3. Active Directory가 이러한 변경 내용을 해당 Exchange 서버에서 사용하는 글로벌 카탈로그 서버로 복제할 때까지 기다립니다.

  4. Microsoft Exchange System Attendant 서비스를 시작합니다.

  5. Exchange Server 컴퓨터의 응용 프로그램 이벤트 로그에서 이벤트 원본이 MSExchangeMU이고 범주가 일반인 이벤트 ID 1005의 세 인스턴스가 존재하는지 확인합니다.

  6. Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.
Exchange 2000 Server 및 Exchange Server 2003의 Mailroot 디렉터리 경로에 대한 기본 사용 권한을 확인하려면 다음을 수행합니다.

  1. Windows 탐색기를 시작하고 Exchsvr 폴더를 탐색하여 해당 폴더를 확장합니다.

  2. Mailroot 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 보안 탭을 클릭하고 다음과 같은 기본 사용 권한을 확인합니다.

계정 | 사용 권한
Administrators | 모든 권한
Authenticated Users | 읽기 및 실행, 폴더 내용 보기, 읽기
Creator Owner | 없음
Server Operators | 수정, 읽기 및 실행, 폴더 내용 보기, 읽기, 쓰기
System | 모든 권한
  1. 각 가상 서버 인스턴스의 모든 폴더에 대해 이러한 기본 사용 권한이 있는지 확인합니다.

위에서 설명한 절차에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 822933, "How to change the Exchange 2003 SMTP Mailroot folder location"http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933)

  • 318230, "XCON: How to Change the Exchange 2000 SMTP Mailroot Directory Location"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230)

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Exchange에서 사용하기 위한 바이러스 백신 검사 응용 프로그램을 구성하는 방법에 대한 자세한 내용은 바이러스 백신 폴더 제외가 구성되어 있지 않습니다.를 참조하십시오.

Symantec AntiVirus Corporate Edition의 실시간 검색에 대한 제외를 구성하는 방법에 대한 자세한 내용은 Symantec 바이러스 백신 웹 사이트(http://www.symantec.com)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결할 수 없을 수도 있습니다.

전자 메일로 전파되는 바이러스나 웜으로부터 Exchange Server 환경을 보호하는 방법에 대한 자세한 내용은 Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "바이러스 백신 소프트웨어가 설치된 Exchange Server 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 "Exchange Server 2007 Partners: Antivirus, Antispam"(http://go.microsoft.com/fwlink/?linkid=16226)을 참조하십시오.


SMTP 인스턴스의 정규화된 도메인 이름이 서버 이름과 일치하지 않음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-07

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 서버 개체의 networkAddress 특성에 있는 ncacn_ip_tcp: 문자열 값이 SMTP(Simple Mail Transfer Protocol) 가상 서버 개체의 msExchSmtpFullyQualifiedDomainName 특성에 있는 FQDN(정규화된 도메인 이름)과 일치하는지 확인합니다.

이러한 특성의 값이 일치하지 않으면 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 해당 특성 값이 수동으로 변경되었을 수 있으며 해당 서버에 메일 흐름 문제를 유발할 수 있음을 나타냅니다.

msExchSmtpFullyQualifiedDomainName 특성의 값은 SMTP 가상 서버의 FQDN을 지정하며 DNS(Domain Name System) 네트워킹 프로토콜로 해석할 수 있어야 합니다.

이 특성의 값에 대해 올바른 DNS HOST(A) 레코드가 있어야 SMTP 가상 서버의 FQDN을 해석할 메시징 서버가 올바른 IP 주소를 검색하여 메일을 제대로 라우팅할 수 있습니다.

Exchange의 DNS 역방향 조회 기능에 대한 자세한 내용은 "Add a resource record to a DNS zone"(http://go.microsoft.com/fwlink/?LinkId=63002)을 참조하십시오.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

SMTP 서비스 디자인에 대한 자세한 내용은 Technical Reference Guide for Exchange Server 2003(http://go.microsoft.com/fwlink/?LinkId=58876)의 "SMTP Service Design"을 참조하십시오.


SMTP Local Queue Length가 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-20

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 SMTP Server 성능 개체의 Local Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Exchange Server Analyzer는 Local Queue Length 카운터가 샘플 시간 동안 최고값 1000을 초과한 경우 오류를 표시합니다.

SMTP Server\Local Queue Length 카운터는 SMTP(Simple Mail Transfer Protocol) 큐에서 Microsoft Exchange Information Store 서비스에 로컬로 배달할 메시지 수를 나타냅니다. SMTP 로컬 큐 데이터(Mailroot 디렉터리)는 Exchange Server에서 처리하는 동안 저장 장치에 임시로 보관됩니다. 이런 방식은 서버에 오류가 발생하는 경우 데이터가 손실되지 않도록 합니다. 예를 들어 대상 서버에 연결할 수 없는 경우 해당 서버에 라우팅해야 하는 메시지는 배달할 수 있을 때까지 로컬 서버 큐 디렉터리에 저장됩니다.

서버에서 받는 메일을 적시에 배달할 수 없기 때문에 이 오류는 서버의 성능 문제 또는 중지를 나타냅니다. 이러한 지연은 다음과 같은 조건 때문에 발생할 수 있습니다.

  • Active Directory® 디렉터리 서비스가 즉시 참조되지 않습니다.

  • 메시지가 로컬 배달 또는 SMTP에 대해 즉시 전달되지 않습니다.

  • 데이터베이스(사서함 저장소 및 공용 폴더 저장소)가 분리되었습니다.

  • 이 문제를 해결하려면 다음 단계를 수행합니다.

  • 모든 데이터베이스(사서함 저장소 및 공용 폴더 저장소)가 탑재되었는지 확인합니다.

  • 성능 지체의 원인을 확인합니다. 성능 지체는 CPU, 디스크, 네트워크 또는 메모리와 관련될 수 있고 서버 로드 증가나 부족한 서버 리소스로 인해 발생할 수 있습니다. 성능 모니터(Perfmon.msc) 도구를 사용하여 서버의 로드 증가로 지체가 발생했는지 또는 서버 용량이 부족한지 확인합니다. 서버 로드가 증가한 경우 로드의 원인을 확인하고 로드를 줄입니다. 서버에 리소스가 부족한 경우에는 필요한 리소스를 늘리거나 사용자를 다른 서버로 이동합니다.

  • Active Directory 디렉터리 서비스와 같은 외부 종속성을 모니터링하여 성능 문제를 확인하고 필요한 경우 문제를 해결합니다.

추가 정보

  • SMTP 전송 튜닝에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "SMTP 전송 튜닝"을 참조하십시오.

  • 메일 흐름 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)을 참조하십시오.

  • 전송 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 257265, "Exchange 2000 Server 및 Exchange Server 2003 전송 시 일반 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)을 참조하십시오.

  • 프로세서 지체에 대한 자세한 내용은 프로세서 지체를 참조하십시오.

  • 디스크 지체에 대한 자세한 내용은 디스크 지체 감지됨을 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 사용자 사서함을 이동하여 서버 로드를 줄이는 방법에 대한 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.


SMTP 서버 성능 모니터 개체를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 SMTP Server 성능 개체의 Local Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다. 카운터에서 올바른 데이터를 반환하지 않으면 Exchange Server Analyzer는 기본 메시지를 표시합니다.

다음과 같은 상황에서는 성능 데이터 수집 엔진에서 올바른 데이터가 반환되지 않습니다.

  • SMTP Server 성능 개체를 사용하지 않습니다.

  • SMTP Server 성능 모니터 개체가 없거나 손상되었습니다.

  • 성능 개체에 액세스할 수 있는 적절한 권한이 Exchange Server Analyzer에 없습니다.

맨 앞의 두 가지 상황은 확장 가능한 특정 카운터가 레지스트리를 손상시키거나 Microsoft WMI(Windows® Management Instrumentation) 기반 프로그램에서 레지스트리를 수정하는 경우에 발생할 수 있습니다. 다음 절차에서는 맨 앞의 두 가지 상황을 해결하는 방법을 설명합니다. 절차를 수행하기 전에 Exchange Server Analyzer에 적절한 권한이 있는지 확인합니다. Exchange Server Analyzer 실행에 필요한 권한에 대한 자세한 내용은 Exchange Server Analyzer에 포함된 도움말을 참조하십시오. 도움말을 보려면 Exchange Server Analyzer를 열고 F1 키를 누르십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. SMTP Server 성능 개체를 사용하는지 확인합니다.

    1. Extensible Performance Counter List 도구(Exctrlst.exe)를 다운로드하고 설치합니다. Exctrlst.exe: Extensible Performance Counter List 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=34436)에서 Exctrlst.exe를 다운로드할 수 있습니다.

    2. Exctrlst.exe를 열고 Sort Order와 Service를 차례로 클릭합니다.

    3. 성능 개체가 보고하는 서비스를 찾아 Performance Counters Enabled 확인란이 선택되었는지 확인합니다.

      Performance Counters Enabled 확인란이 선택되지 않았으면 이 확인란을 선택한 다음 성능 카운터에 연결된 서비스를 다시 시작하여 성능 카운터가 작동하는지 확인합니다. 성능 카운터가 작동하지 않거나 Performance Counters Enabled 확인란이 이미 선택되어 있으면 2단계로 넘어갑니다.

  2. Microsoft 기술 자료 문서 300956, "성능 카운터 라이브러리 값을 수동으로 다시 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956)에 지정된 대로 누락되거나 손상된 성능 카운터를 다시 빌드합니다.

  3. 이 기술 자료 문서에 따라 수행해도 문제가 해결되지 않으면 Windows 운영 체제를 복구 모드로 다시 설치한 다음 최신 Windows 서비스 팩을 적용해야 합니다.


SQL Server가 Exchange Server가 설치된 Virtual Server 2005를 게스트로 실행하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Model 키 값이 Virtual Machine으로 설정되었는지 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 다음 레지스트리 값이 있는지도 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

또한 Exchange Server Analyzer는 Microsoft Virtual Server 2005를 실행 중인 실제 컴퓨터에서 Microsoft SQL Server™ 서비스(MSSQLSERVER)가 실행되고 있는지 확인할 때도 Win32_Services WMI 클래스를 쿼리합니다.

Exchange Server Analyzer는 Model 키가 Virtual Machine 문자열을 포함하고 있고 위의 레지스트리 분기가 존재하고 MSSQLSERVER가 실행 중일 경우 오류를 표시합니다.

Model 키의 Virtual Machine 값은 Exchange Server 컴퓨터가 Virtual Server 2005 또는 Microsoft Virtual PC 2004에서 게스트 가상 컴퓨터로 실행 중임을 나타냅니다. 위의 레지스트리 분기는 Virtual Server 2005에서만 만들어지므로 이러한 분기의 존재는 Exchange Server 컴퓨터가 Virtual Server 2005에서 게스트 가상 컴퓨터로 실행 중임을 나타냅니다.

Microsoft Exchange의 어떠한 버전도 가상 컴퓨터나 에뮬레이터에서 실행할 수 없습니다. 이 사항은 Microsoft Virtual Server 2005, Microsoft Virtual PC 2004 또는 타사 가상 컴퓨터 프로그램에서 실행되는 Exchange Server에 해당되는 내용입니다. Microsoft Exchange Server 플랫폼은 실제 하드웨어 특히 Windows 서버 카탈로그(http://go.microsoft.com/fwlink/?linkid=17219)에 나와 있는 하드웨어 플랫폼에서 실행하도록 설계되고 테스트되었습니다.

또한 SQL Server를 실행 중인 컴퓨터에서 Virtual Server 게스트로 Exchange를 실행하는 것은 서비스 간 적절한 중복성을 허용하지 않으므로 적합하지 않습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Virtual Server 2005에서 실행 중인 Exchange Server에서 비가상 Exchange Server 컴퓨터로 사서함을 이동합니다.

  2. 모든 공용 폴더를 옮기고 필요에 따라 가상 Exchange 서버가 보유하고 있는 모든 역할을 전송합니다.

  3. 가상 컴퓨터에서 Exchange를 제거하여 Exchange 인프라 및 Active Directory® 디렉터리 서비스에서 제거합니다.

사서함 이동에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 822892, "Exchange 2003 사서함 이동의 개선 사항"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, "XADM: Differences Between Move Mailbox Methods"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

가상 환경에서 실행되는 Exchange Server 컴퓨터 지원에 대한 자세한 내용은 Microsoft 기술 자료 문서 320220, "Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)을 참조하십시오.

Microsoft Virtual Server 2005에 대한 자세한 내용은 Microsoft Virtual Server 2005 웹 사이트(http://go.microsoft.com/fwlink/?linkid=34938)를 참조하십시오.

Microsoft Virtual PC 2004에 대한 자세한 내용은 Microsoft Virtual Server 2004 웹 사이트(http://go.microsoft.com/fwlink/?linkid=34663)를 참조하십시오.


SRS port is below 5000
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange Site Replication Service의 TCP/IP 설정을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

Exchange Server Analyzer는 TCP/IP가 5,000(10진수)보다 작은 값으로 설정된 경우 경고를 표시합니다.

TCP/IP를 고정 값으로 설정해야 하는 경우 5,000을 조금 넘는 값으로 설정하는 것이 좋습니다. 5,000보다 작은 값으로 고정 포트 번호를 지정하면 다른 프로세스와 포트 충돌이 일어나 Microsoft Exchange Site Replication Service 프로세스에서 오류가 발생하게 됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP 레지스트리 키를 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters를 탐색합니다.

  3. TCP/IP 키를 두 번 클릭하고 값 데이터 필드를 5000(10진수)보다 큰 정수로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. Microsoft Exchange Site Replication Service를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

포트 제한에 대한 자세한 내용은 기술 자료 문서 194952, "XADM: Statically Mapped Port Limitations for Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)를 참조하십시오.


SRS 포트가 수동으로 다시 정의되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange Site Replication Service의 포트 값이 수동으로 다시 정의되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

Exchange Server Analyzer는 TCP/IP 가 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

일반적으로 MAPI 클라이언트가 방화벽의 다른 쪽에 있는 Exchange 서버에 연결할 수 있도록 하기 위해 이 값이 구성됩니다. 이를 위해서는 방화벽의 포트를 여러 개 열어서 Microsoft® Office Outlook® 2003 클라이언트가 MAPI를 사용하여 인터넷을 통해 Exchange 서버에 연결할 수 있도록 해야 합니다. 이러한 구성은 지원됩니다. 방화벽을 통해 MAPI 클라이언트를 Exchange에 연결하도록 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 270836, "Exchange 2000 정적 포트 매핑"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)을 참조하십시오. 이 시나리오를 사용하고 있지 않으면 레지스트리 키를 제거해야 합니다.

MAPI 모드에서 Outlook을 사용하여 인터넷을 통해 Exchange 서버에 연결할 때 권장되는 배포 방법은 Microsoft Windows Server™?2003, Exchange Server?2003, Outlook?2003 및 Microsoft Windows®?XP Professional에서 제공하는 RPC over HTTP 기능을 사용하는 것입니다. 전에는 MAPI 모드를 "회사" 또는 "작업 그룹" 모드라고 했습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP 레지스트리 항목을 제거하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters를 탐색합니다.

  3. TCP/IP라는 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 끝내고 Microsoft Exchange Site Replication Service를 다시 시작합니다.

RPC over HTTP를 배포하려면 다음을 수행합니다.

  1. "Exchange Server 2003 RPC over HTTP 배포 시나리오"(http://go.microsoft.com/fwlink/?linkid=47577)를 검토하십시오.

  2. Microsoft 기술 자료 문서 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)을 검토하십시오.

  3. 기술 자료 문서 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)을 검토하십시오.

  4. Microsoft 기술 지원 웹캐스트, "웹캐스트: Microsoft Office Outlook 2003에서 인터넷(RPC/HTTP)을 통해 Microsoft Exchange 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)을 검토하십시오.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


System Attendant에 대해 구성된 시작 계정이 지원되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Win32_Services Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Microsoft Exchange System Attendant 서비스(MSExchangeSA)의 StartName 속성에 지정된 시작 계정이 LocalSystem 계정을 사용하고 있는지 여부를 확인합니다. Exchange 2000 Server 또는 Exchange Server 2003 컴퓨터의 StartName 속성 값이 LocalSystem 계정과 다른 경우 Exchange Server Analyzer에서 오류를 표시합니다. LocalSystem 계정은 SYSTEM 계정이라고도 합니다.

LocalSystem 보안 컨텍스트 아래의 Exchange 2000 Server 및 Exchange Server 2003에서 MSExchangeSA를 시작해야 합니다. 특정 사용자 계정을 할당하여 MSExchangeSA를 시작하면 안 됩니다. LocalSystem으로 실행되고 있는 Exchange 서비스가 원격 서버에 액세스할 경우 컴퓨터 계정의 자격 증명을 사용하여 인증을 받습니다.

암호 변경의 일반 메커니즘은 7일 간격으로 컴퓨터 계정의 암호를 변경합니다. 7일마다 암호를 변경하여 컴퓨터 계정의 보안을 향상시킵니다. 컴퓨터 계정은 다음과 같은 이유로 일반적인 사용자 계정보다 더 안전합니다.

  • 일반 사용자 계정의 암호는 자주 변경되지 않습니다.

  • 일반 사용자 계정의 암호는 임의로 생성되는 컴퓨터 계정보다 임의성이 떨어집니다.

Exchange Server 5.5에서는 서비스에 사용자 계정이 사용됩니다. ExchangeServer 5.5를 사용한 경험이 있는 일부 관리자는 Exchange 2000 Server 서비스 및 Exchange Server 2003 서비스의 시작 계정을 기본 LocalSystem 계정에서 사용자 계정으로 변경합니다.

Exchange 2000 Server 및 Exchange Server 2003에서는 기본 LocalSystem 계정 이외의 다른 계정으로 MSExchangeSA를 실행할 수 없습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 시작을 클릭하고 프로그램, 관리 도구를 차례로 가리킨 다음 서비스를 클릭합니다.

  2. 서비스 목록에서 Microsoft Exchange System Attendant를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 로그온 탭의 다음 계정으로 로그온에서 로컬 시스템 계정을 클릭한 다음 확인을 클릭합니다.

  4. Microsoft Exchange System Attendant를 마우스 오른쪽 단추로 클릭한 다음 다시 시작을 클릭합니다.

Exchange 서비스에 대한 자세한 내용은 Microsoft 기술 자료 문서 239762, "Exchange Services Run Under LocalSystem"( http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)을 참조하십시오.


STORE.EXE 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft Exchange Server Analyzer Tool은 다음과 같은 몇 가지 핵심 Exchange 이진 파일의 존재 여부를 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exres.dll

  • Gapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapi32.dll(System32 폴더와 \Exchsrvr\bin 폴더에서 확인)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Exchange Server Analyzer는 위 파일 중 하나 이상이 없을 경우 오류를 표시합니다. 이 오류를 수정하려면 사용 중인 Exchange 버전에 대한 최신 서비스 팩이나 롤업을 설치합니다. 그래도 오류가 계속 발생하면 Exchange 2000 Server 또는 Exchange Server 2003 설치 프로그램을 실행하고 다시 설치를 선택합니다. 다시 설치 모드에서 설치 프로그램을 실행하면 이진 파일만 설치됩니다. 사용자 데이터나 구성 데이터는 제거되거나 원래대로 설정되지 않습니다. Exchange Server를 다시 설치할 경우 이전에 설치한 Exchange 서비스 팩이나 핫픽스도 모두 다시 설치해야 합니다.

Exchange 2000 Server 또는 Exchange Server 2003을 다시 설치하려면 다음을 수행합니다.

  1. Exchange를 다시 설치할 서버에 로그온합니다. CD-ROM 드라이브에 Exchange 2000 Server CD나 Exchange Server 2003 CD를 넣습니다.

  2. 시작 메뉴에서 실행을 클릭한 다음 <drive>:\setup\i386\setup을 입력합니다. 여기서 <drive>는 CD-ROM 드라이브입니다.

  3. Microsoft Exchange 설치 마법사를 시작합니다. 페이지에서 다음을 클릭합니다.

  4. 사용권 계약 페이지에서 계약 내용을 읽습니다. 계약 내용에 동의하면 동의함을 클릭하고 다음을 클릭합니다.

  5. Product ID 페이지에서 25자리 제품 키를 입력하고 다음을 클릭합니다.

  6. 구성 요소 선택 페이지의 작업 열에서 Microsoft Exchange 노드 옆의 드롭다운 화살표를 사용하여 다시 설치를 선택하고 다음을 클릭합니다.

최신 Exchange Server 2003 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange Server 2003"웹 사이트(http://go.microsoft.com/fwlink/?LinkId=25097)를 참조하십시오.

최신 Exchange 2000 Server 서비스 팩, 업데이트 롤업 및 추가 기능에 대한 자세한 내용은 "Downloads for Exchange 2000 Server" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33457)를 참조하십시오.


저장소 HTTP 포트 번호가 5000 미만입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-21

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange Information Store 서비스의 Rpc/HTTP Port 설정을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

Exchange Server Analyzer는 Rpc/HTTP Port가 5000(10진수) 미만의 값으로 설정되어 있을 경우 경고를 표시합니다.

Exchange Server 2003 및 Exchange Server 2007 설치 프로그램에 의해 Rpc/HTTP Port 레지스트리 키가 6001로 설정됩니다. Rpc/HTTP Port 레지스트리 키는 Microsoft Office Outlook® 2003 및 Microsoft Office Outlook 2007의 RPC over HTTP 기능을 지원하기 위해 사용됩니다.

Microsoft Consulting Services의 도움을 받거나 Microsoft 기술 지원 서비스의 권고에 따라 RPC over HTTP 배포를 사용자 지정한 경우를 제외하고는 기본 포트 값을 사용하여 RPC over HTTP를 배포하는 것이 좋습니다.

Rpc/HTTP Port를 6001 이외의 값으로 설정해야 하는 경우 5000 이상의 값으로 설정하는 것이 좋습니다. 정적 포트 번호를 5000 이하로 지정하면 포트가 다른 프로세스와 충돌하여 Microsoft Exchange Information Store 서비스 프로세스 오류가 발생할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Rpc/HTTP 포트 레지스트리를 해당 기본값으로 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port를 탐색합니다.

  3. Rpc/HTTP Port 키를 두 번 클릭하고 값 데이터 필드를 6001(십진수) 또는 5000 이상의 정수(십진수)로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC over HTTP 구성에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


저장소: HTTP 포트가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 HTTP Port가 기본값으로 설정되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

Exchange Server Analyzer는 Rpc/HTTP Port 값이 6001(10진수)이 아닌 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server 2003 및 Exchange Server 2007 설치 프로그램에 의해 Rpc/HTTP Port 레지스트리 키가 6001로 설정됩니다. Rpc/HTTP Port 레지스트리 키는 Microsoft Office Outlook® 2003 및 Microsoft Office Outlook 2007의 RPC over HTTP 기능을 지원하기 위해 사용됩니다.

Microsoft Consulting Services의 도움을 받거나 Microsoft 기술 지원 서비스의 권고에 따라 RPC over HTTP 배포를 사용자 지정한 경우를 제외하고는 기본 포트 값을 사용하여 RPC over HTTP를 배포하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Rpc/HTTP Port 레지스트리 키를 기본값으로 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. Rpc/HTTP Port 키를 두 번 클릭하고 값 데이터 필드를 6001(10진수)로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC over HTTP 구성에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


최적이 아닌 메모리 설정
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-02-15

Microsoft Exchange Analyzer Tool은 MSExchangeIS에 대한 이벤트 9665 오류가 최근 24시간 이내 기록되었는지 여부를 확인할 때 Win32_NTLogEvent Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다.

Microsoft Exchange Server 2003에서는 저장소 프로세스가 시작되면 메모리 구성이 최적 상태인지 검사합니다. 메모리 설정이 최적 상태가 아닌 경우 이벤트 뷰어에 이벤트 9665가 표시됩니다.

지난 24시간 내에 이벤트 9665가 기록되면 Exchange Analyzer에서 이벤트의 데이터 필드를 읽어 아래 표의 태그 중에서 이벤트에 포함된 태그를 확인합니다.

이벤트 데이터 필드 플래그 | Exchange Server Analyzer 경고 표시 | Exchange Server 2003 문제
0x00000001 | /3GB 스위치가 설정되지 않았습니다. | 서버에 Microsoft Windows 2000 Advanced Server 또는 Microsoft Windows 2000 Datacenter Server가 실행 중이며 1GB 이상의 실제 메모리가 있지만 boot.ini 파일에 /3GB 스위치가 설정되어 있지 않습니다.
0x00000002 | /Userva 스위치가 올바르게 설정되지 않았습니다. | 서버에 Microsoft Windows Server 2003 Standard Edition, Microsoft Windows Server 2003 Enterprise Edition 또는 Microsoft Windows Server 2003 Datacenter Edition이 실행 중이며 1GB 이상의 실제 메모리가 있고 /3GB 스위치가 설정되어 있지만 boot.ini 파일에 /USERVA 설정이 없습니다.
0x00000004 | 'SystemPages' 설정을 지정해야 합니다. | 서버에 임의 버전의 Microsoft Windows 2000 Server가 실행 중이며 레지스트리의 SystemPages 값이 24000~31000 범위 이외의 값으로 설정되어 있습니다.
0x00000008 | 'SystemPages' 설정을 다시 지정해야 합니다. | 서버에 Microsoft Windows Server 2003 Standard, Microsoft Windows Server 2003 Enterprise 또는 Microsoft Windows Server 2003 Datacenter Edition이 실행 중이며 레지스트리의 SystemPages 값이 0 이외의 값으로 설정되어 있습니다.
0x00000010 | HeapDecommitFreeBlockThreshold 설정이 올바르게 설정되지 않았습니다. | 서버에 임의 버전의 Microsoft Windows 2000 Server 또는 Microsoft Windows Server 2003이 실행 중이며 레지스트리의 HeapDeCommitFreeBlockThreshold 값이 0x00040000 이외의 값으로 설정되어 있습니다.

이벤트 9665 데이터 필드에 있는 플래그에 따라 Exchange Analyzer에서는 위 표에 나오는 해당 경고를 표시합니다.

이러한 경고는 Exchange Server 메모리가 최적이 아닌 상태로 설정되어 있음을 나타냅니다.

이러한 경고를 해결하려면 아래 나열된 문제별 Exchange Analyzer 문서의 안내를 따르십시오.

  • Exchange 사서함 서버에는 1GB 이상의 메모리가 있지만 Boot.ini 파일에 /3GB가 설정되어 있지 않습니다.

  • USERVA가 잘못 설정되었습니다.

  • SystemPages가 너무 높게 설정되어 있습니다.

  • 이 서버에서 Windows Server 2003이 실행되고 있고 SystemPages 값이 0으로 설정되어 있지 않습니다.

  • 이 서버에 1GB 이상의 실제 메모리가 있으며 HeapDeCommitFreeBlockThreshold가 262144로 설정되어 있지 않습니다.

자세한 정보

이러한 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 325044, "HOWTO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)을 참조하십시오.

MSExchangeIS 이벤트 9665에 대한 자세한 내용은 "이벤트 및 오류 메시지 센터: 이벤트 세부 정보"를 참조하십시오.

  • 사서함 저장소 이벤트 9665의 경우 (http://go.microsoft.com/fwlink/?LinkId=83210)을 참조하십시오.

  • 공용 저장소 이벤트 9665의 경우 (http://go.microsoft.com/fwlink/?LinkId=83213)을 참조하십시오.


클라이언트에 설치되어 있는 데스크톱 검색 프로그램이 원인인 것 같습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-09-05

Microsoft® Exchange Server Analyzer Tool은 많은 사용자가 데스크톱 검색 엔진을 사용하고 있음을 확인했습니다. 데스크톱 검색 엔진은 공용 폴더 저장소의 파일 구조를 탐색할 때 공용 폴더에 상당한 소통량을 가중시킬 뿐 아니라 탑재된 사용자의 사서함에 다수의 RPC(원격 프로시저 호출)를 만들 수 있습니다. 다수의 검색 엔진은 사용자 공용 폴더의 즐겨찾기 목록에 있을 경우에만 공용 폴더를 탐색할 수 있습니다. 따라서 데스크톱 검색에서 공용 폴더 서버의 로드를 확인할 수도 있고 확인하지 못할 수도 있습니다.

이 문제를 방지하기 위해 수행할 수 있는 작업은 다음과 같습니다.

  • 사용자가 검색 프로그램의 Microsoft Office Outlook® 기능을 해제하도록 하거나 검색을 사용자의 개인 사서함으로만 제한합니다.

  • 캐시된 Exchange 모드에서 Outlook을 실행하여 검색이 서버가 아닌 로컬 워크스테이션에만 영향을 미치도록 합니다.

  • Microsoft 기술 자료 문서 889086, "You may experience unexpected behavior in a Windows XP-based computer when you try to access public folders on Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=889086)의 지시에 따라 핫픽스를 구한 다음 데스크톱 검색 사용자가 액세스하고 Exchange Server가 실행되는 컴퓨터에 MaxObjsPerMapiSession 레지스트리 키를 설정합니다.

데스크톱 검색 응용 프로그램으로 인해 특정 사용자에 대한 로드가 증가하는지 여부를 확인하려면 Microsoft ExMon(Exchange Server User Monitor)을 사용하여 RPC 작업, 검색 엔진 작업을 모니터링하고 적당한 기간(최소 5분) 동안 데이터를 수집해야 합니다. 그런 다음 검색 엔진을 제거하고 ExMon 도구를 다시 실행합니다. RPC 비율이 상당히 감소한다면 데스크톱 검색 엔진으로 인해 로드가 증가하고 있음을 확인한 것입니다. 평균 RPC 대기 시간이 감소한다면 로드가 증가하여 RPC 대기 시간도 길어졌음을 확인한 것입니다.

참고:
RPC 대기 시간 비율은 하루 동안 매우 다릅니다. 따라서 5분 테스트는 적합하지 않을 수 있습니다. 보다 긴 시간 동안 측정할 필요가 있습니다.

ExMon을 다운로드하려면 Microsoft 다운로드 센터(http://go.microsoft.com/fwlink/?linkid=54983)를 참조하십시오.

추가 정보

  • 데스크톱 검색 소프트웨어에 대한 자세한 내용은 다음을 참조하십시오.

    • Microsoft 기술 자료 문서 905184, "데스크톱 검색 엔진 소프트웨어가 Outlook 또는 기타 MAPI 클라이언트 컴퓨터에서 실행 중일 경우 Exchange 2000 Server 및 Exchange Server 2003 성능에 영향을 미칠 수 있음"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184)

    • Microsoft Exchange 팀 블로그, "Are your clients using desktop search engines that index Exchange mailboxes or public folders?" (http://go.microsoft.com/fwlink/?LinkId=54475)

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588)을 참조하십시오.


SystemPages가 너무 높게 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-03-13

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SystemPages 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Exchange Server Analyzer는 SystemPages 값이 50000보다 크면 경고를 표시합니다.

Microsoft Windows Server™ 2003 및 Microsoft Windows® 2000 Server는 설치된 실제 RAM 크기에 관계없이 최대 4GB(기가바이트)의 메모리 주소 공간에 주소를 직접 지정할 수 있습니다. 프로세스 측면에서 볼 때 가상 주소의 각 요소는 개념적으로 실제 메모리의 바이트를 말합니다. VMM(Virtual Memory Manager)은 프로세서 MMU(Memory Manager Unit)와 함께 각 가상 주소를 해당 실제 주소로 변환하거나 매핑합니다. VMM은 RAM을 고정 크기의 페이지 프레임으로 분할하고 이러한 페이지 프레임에 대한 정보를 저장할 시스템 PTE(페이지 테이블 항목)를 만든 다음 매핑합니다. 시스템 PTE는 디스크 I/O 하위 시스템 및 네트워크와 통신하는 데 사용되는 메모리의 소형 커널 모드 버퍼입니다. 각 PTE는 페이지 프레임을 나타내며 VMM이 페이지를 찾는 데 필요한 정보를 포함합니다.

4KB 페이지 크기를 사용하는 x86 기반 시스템에서 2GB의 주소 공간을 매핑하는 데는 최대 524,288(2GB/4KB)개의 PTE가 필요합니다. /3GB 스위치를 사용하는 비슷한 시스템에서는 3GB의 주소 공간을 매핑하는 데 786,432(3GB/4KB)개의 PTE가 필요합니다. 일반적인 시스템에서 이 공간은 다음과 같이 사용됩니다.

  • 최대 50,000개의 PTE(약 195MB의 주소 공간)가 일반적인 용도로 예약됩니다.

  • 나머지 PTE는 매핑 시스템 캐시, 하이퍼스페이스, 페이징 풀, 비페이징 풀, 크래시 덤프 영역 등에서 사용됩니다.

이 PTE 풀 크기는 시스템의 실제 메모리 양을 바탕으로 시스템 시작 시 자동으로 결정됩니다. 이 풀은 페이징 풀과 비페이징 풀 사이에 위치하며 시스템의 실제 메모리 양에 따라 증가합니다.

시스템 PTE 풀은 과다하게 사용 및 조각화될 수 있습니다. 이로 인해 드라이버가 로드되지 못할 수 있습니다. 또한 시스템 PTE 풀이 완전히 고갈될 경우 시스템의 다른 부분 성능이 떨어지고 스레드가 만들어지지 않으며 시스템이 중지되고 손상될 수 있습니다.

시스템 PTE 풀이 과도하게 조각화되지 않도록 하려면 사용 중인 Exchange Server 컴퓨터의 운영 체제에 적절하게 SystemPages 레지스트리 값을 구성해야 합니다. Windows Server 2003에서 Exchange Server를 실행할 경우에는 SystemPages 레지스트리 키를 0으로 설정하는 것이 좋습니다. 이와는 달리 Windows 2000 Server에서는 SystemPages 레지스트리 값을 24000에서 31000 사이의 값으로 설정하는 것이 좋습니다.

아래 설명한 절차를 수행한 후에 사용 가능한 시스템 PTE의 수를 모니터링해야 합니다. 이것을 수행하려면 시스템 모니터라고도 하는 Windows Performance Monitor를 사용하여 Memory | Free System Page Table Entries 성능 카운터를 모니터링합니다. 아래 설명한 대로 레지스트리를 변경한 후에도 사용 가능한 시스템 PTE의 수가 부족하면 다음을 확인하여 Exchange Server 컴퓨터 구성이 최적화되었는지 확인해야 합니다.

  • 드라이버 일반적으로 드라이버가 제대로 작동하지 않으면 시스템 PTE 수가 부족하게 됩니다. 또한 특정 버전의 S3 Savage 5 비디오 카드 드라이버는 SystemPages를 208896으로 설정합니다. 이 드라이버는 IBM E-Series 서버에서 주로 발견됩니다. 하드웨어 제조업체에 문의하여 모든 하드웨어에 대해 최신 드라이버를 사용하고 있는지 확인하십시오. 기본 드라이버로 다운그레이드할 수도 있습니다. 예를 들어 Exchange Server 같은 서버 기반의 응용 프로그램을 실행하는 컴퓨터는 일반적으로 모든 기능이 제공되는 최고급 비디오 드라이버를 필요로 하지 않습니다. 대부분의 경우 기본 드라이버만으로도 충분합니다. 고급 비디오 드라이버에서 기본 비디오 드라이버로 전환하면 사용 가능한 시스템 PTE의 수가 증가합니다.

  • 시스템 구성 Windows Server 2003 시스템에 1GB 이상의 실제 메모리가 설치되어 있는 경우 다음 Microsoft 기술 자료 문서에 설명되어 있는 것처럼 해당 Boot.ini 파일이 /3GB 및 /USERVA=3030 스위치로 제대로 구성되어 있는지 확인해야 합니다.

    • 823440, "Windows Server 2003 기반 시스템에 Exchange Server 2003을 설치한 경우 /3GB 스위치를 사용해야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

    • 810371, "XADM: Windows Server 2003 기반 Exchange Servers에서 /Userva 스위치 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)

  • 이벤트 로그Exchange Server의 응용 프로그램 이벤트 로그에서 오류 및 경고를 확인하십시오. 특히 MSExchangeIS 이벤트 9582(오류 및 경고), 9665(경고) 및 12880(오류)이 표시되는지 확인하십시오. 이벤트 9665가 표시되면 SystemPages가 최적의 성능으로 구성되어 있지 않은 것입니다. 이러한 이벤트에 대한 자세한 내용은 기술 자료 문서 325044, "HOWTO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)을 참조하십시오.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

SystemPages 값을 변경하여 Windows 2000 Server에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management를 탐색합니다.

  3. 오른쪽 창에서 SystemPages를 두 번 클릭합니다.

  4. 값 데이터 필드에 24000에서 31000 사이의 값(십진수)을 입력한 다음 확인을 클릭합니다. 사용할 값을 모르는 경우 31000(10진수)을 사용하는 것이 좋습니다.

  5. 레지스트리 편집기를 닫고 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

SystemPages 값을 변경하여 Windows Server 2003에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management를 탐색합니다.

  3. 오른쪽 창에서 SystemPages를 두 번 클릭합니다.

  4. 값 데이터 필드에 0을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

비디오 드라이버를 업데이트 또는 다운그레이드하여 이 경고를 해결하려면 다음을 수행합니다.

  • 다음 중 하나를 수행합니다.

    • 하드웨어 제조업체에 문의하여 SystemPages 설정을 구성하지 않는 업데이트된 비디오 드라이버를 구합니다.

    • 비디오 드라이버를 표준 VGA 드라이버로 다운그레이드하고 위에서 설명한 대로 SystemPages 값을 수정합니다.

레지스트리를 편집하기 전에 레지스트리를 편집하는 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 편집"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server의 메모리 사용 최적화에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, "The effects of 4GT tuning on System Page Table Entries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


시스템 수행자 HTTP 포트 번호가 5000 미만입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-21

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 Microsoft Exchange System Attendant의 HTTP Port 설정을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

Exchange Server Analyzer는 HTTP Port가 5000(10진수) 미만의 값으로 설정되어 있을 경우 경고를 표시합니다.

Exchange Server 2003 및 Exchange Server 2007 설치 프로그램에 의해 HTTP Port 레지스트리 키가 6002로 설정됩니다. HTTP Port 레지스트리 키는 Microsoft Office Outlook® 2003 및 Microsoft Office Outlook 2007의 RPC over HTTP 기능을 지원하기 위해 사용됩니다.

Microsoft Consulting Services의 도움을 받거나 Microsoft 기술 지원 서비스의 권고에 따라 RPC over HTTP 배포를 사용자 지정한 경우를 제외하고는 기본 포트 값을 사용하여 RPC over HTTP를 배포하는 것이 좋습니다.

HTTP Port를 6002 이외의 값으로 설정해야 하는 경우 5000 이상의 값으로 설정하는 것이 좋습니다. 정적 포트 번호를 5000 이하로 지정하면 포트가 다른 프로세스와 충돌하여 Microsoft Exchange System Attendant 프로세스 오류가 발생할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

HTTP 포트 레지스트리 키를 해당 기본값으로 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. HTTP Port 키를 두 번 클릭하고 값 데이터 필드를 6002(십진수) 또는 5000 이상의 정수(십진수)로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC over HTTP 구성에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


시스템 수행자 HTTP NSPI 포트 번호가 5000 미만입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-21

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 Microsoft Exchange System Attendant의 Rpc/HTTP NSPI Port 설정을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

Exchange Server Analyzer는 Rpc/HTTP NSPI Port가 5000(10진수) 미만의 값으로 설정되어 있을 경우 경고를 표시합니다.

Exchange Server 2003 및 Exchange Server 2007 설치 프로그램에 의해 Rpc/HTTP NSPI Port 레지스트리 키가 6004로 설정됩니다. Rpc/HTTP NSPI Port 레지스트리 키는 Microsoft Office Outlook® 2003 및 Microsoft Office Outlook 2007의 RPC over HTTP 기능을 지원하기 위해 사용됩니다.

Microsoft Consulting Services의 도움을 받거나 Microsoft 기술 지원 서비스의 권고에 따라 RPC over HTTP 배포를 사용자 지정한 경우를 제외하고는 기본 포트 값을 사용하여 RPC over HTTP를 배포하는 것이 좋습니다.

Rpc/HTTP NSPI Port를 6004 이외의 값으로 설정해야 하는 경우 5000 이상의 값으로 설정하는 것이 좋습니다. 정적 포트 번호를 5000 이하로 지정하면 포트가 다른 프로세스와 충돌하여 Microsoft Exchange System Attendant 프로세스 오류가 발생할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Rpc/HTTP NSPI 포트 레지스트리 키를 해당 기본값으로 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. Rpc/HTTP NSPI Port 키를 두 번 클릭하고 값 데이터 필드를 6004(십진수) 또는 5000 이상의 정수(십진수)로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC over HTTP 구성에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


시스템 수행자: HTTP NSPI 포트가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 HTTP Port가 기본값으로 설정되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

Exchange Server Analyzer는 Rpc/HTTP NSPI Port 값이 6004(10진수)가 아닐 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server 2003 설치에 의해 Rpc/HTTP NSPI Port 레지스트리 키가 6004로 설정됩니다. Rpc/HTTP NSPI Port 레지스트리 키는 Microsoft Office Outlook® 2003의 RPC over HTTP 기능을 지원하기 위해 사용됩니다.

Microsoft Consulting Services의 도움을 받거나 Microsoft 기술 지원 서비스의 권고에 따라 RPC over HTTP 배포를 사용자 지정한 경우를 제외하고는 기본 포트 값을 사용하여 RPC over HTTP를 배포하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Rpc/HTTP NSPI 포트 레지스트리 값을 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. Rpc/HTTP NSPI Port 키를 두 번 클릭하고 값 데이터 필드를 6004(10진수)로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC over HTTP 구성에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


시스템 수행자: HTTP 포트 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 HTTP Port가 기본값으로 설정되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

Exchange Server Analyzer는 HTTP Port 값이 6002(10진수)가 아닐 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server 2003 및 Exchange Server 2007 설치 프로그램에 의해 HTTP Port 레지스트리 키가 6002로 설정됩니다. HTTP Port 레지스트리 키는 Microsoft Office Outlook® 2003 및 Microsoft Office Outlook 2007의 RPC over HTTP 기능을 지원하기 위해 사용됩니다.

Microsoft Consulting Services의 도움을 받거나 Microsoft 기술 지원 서비스의 권고에 따라 RPC over HTTP 배포를 사용자 지정한 경우를 제외하고는 기본 포트 값을 사용하여 RPC over HTTP를 배포하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

HTTP 포트 레지스트리 키를 기본값으로 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. HTTP Port 키를 두 번 클릭하고 값 데이터 필드를 6002(10진수)로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 컴퓨터를 다시 시작하여 이 설정을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC over HTTP 구성에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


시스템 수행자 legacyExchangeDN 값이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 각 Exchange 서버 컴퓨터의 시스템 수행자(System Attendant) 개체에 대한 legacyExchangeDN 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 시스템 수행자 개체의 legacyExchangeDN 특성 값이 없는 경우 오류 메시지를 표시합니다.

오류가 발생하여 복구해야 하는 상황에서 관리자가 Active Directory를 수정하여 데이터베이스를 복구할 때 legacyExchangeDN이 사라질 수 있습니다. 이 오류를 해결하려면 LDP(ldp.exe) 도구 또는 ADSI(Active Directory Service Interfaces) 편집과 같은 Active Directory 편집기를 사용하여 legacyExchangeDN 특성을 수정해야 합니다.

legacyExchangeDN 특성이 올바른지 확인하려면 이 서버 또는 이 오류를 생성하지 않은 다른 Exchange 서버에서 다른 시스템 수행자 개체도 확인해야 합니다. 이러한 개체의 값이 legacyExchangeDN 특성 값과 비슷해야 하기 때문입니다.

데이터베이스에 legacyExchangeDN 특성이 없는 경우 다른 여러 시스템 개체에도 이 특성이 없을 수 있습니다. 따라서 LDP 또는 ADSI 편집을 사용하여 새 legacyExchangeDN 값을 추가한 경우 다른 모든 시스템 개체에도 새 legacyExchangeDN 값을 추가해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 엽니다.

  2. Configuration[DomainName], CN=Configuration, DC=DomainName, DC=DomainSuffix를 차례로 확장합니다.

  3. CN=Services, CN=Microsoft Exchange를 차례로 확장합니다.

  4. CN=OrganizationName, CN=Administrative Groups 및 CN=AdminGroupName을 차례로 확장합니다.

  5. CN=Servers, CN=ServerName을 차례로 확장합니다.

  6. CN=Microsoft System Attendant를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  7. 아래로 스크롤하여 legacyExchangeDN을 찾아 선택하고 Edit를 클릭합니다.

  8. 값 필드에 올바른 legacyExchangeDN을 입력합니다.

  9. Active Directory 편집기를 닫고 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

ADSI 편집을 사용하여 새 legacyExchangeDN 특성을 만드는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 273863, "How to Change the LegacyExchangeDN Attribute in Native Mode with ADSI Edit"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863)를 참조하십시오.


시스템 수행자(System Attendant) NSPI 포트가 수동으로 다시 정의되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 NSPI 대상 서버(Name Service Provider Interface 대상 서버) 서비스가 수동으로 다시 정의되었는지 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

Exchange Server Analyzer는 TCP/IP NSPI Port가 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

일반적으로 MAPI 클라이언트가 방화벽 너머에 있는 Exchange 서버에 연결할 수 있도록 하기 위해 이 값이 구성됩니다. 이를 위해서는 방화벽의 포트를 여러 개 열어서 Microsoft® Office Outlook® 2003 클라이언트가 MAPI를 사용하여 인터넷을 통해 Exchange 서버에 연결할 수 있도록 해야 합니다.

회사 또는 작업 그룹 모드에서 Outlook을 사용하여 인터넷을 통해 Exchange 서버에 연결할 때 권장되는 배포 방법은 Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 및 Windows® XP Professional에서 제공하는 RPC over HTTP 기능을 사용하는 것입니다.

RPC over HTTP를 사용하면 가상 사설망(VPN) 연결을 사용하거나 방화벽의 포트를 여러 개 열어서 Outlook 2003에서 Exchange Server 2003으로의 MAPI 액세스를 허용할 필요가 없습니다. Outlook 2003을 실행하는 사용자는 인터넷을 통해 Exchange 서버에 연결할 수 있습니다. RPC 클라이언트는 HTTP 프로토콜을 통해 RPC 소통량을 터널링하여 인터넷 연결을 설정합니다. RPC 클라이언트는 Internet Information Services(IIS)를 실행 중인 원격 컴퓨터에 HTTP/HTTPS 연결을 할 수 있다면 해당 원격 네트워크의 모든 서버에 연결할 수 있습니다. RPC over HTTP를 사용하여 인터넷을 통해 액세스할 수 있도록 이 원격 네트워크의 서버가 구성되어 있어야 합니다. 또한 RPC 클라이언트 프로그램과 RPC 서버 프로그램이 모두 다른 네트워크에 있는 방화벽 뒤에 있더라도 인터넷을 가로질러 연결할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP NSPI Port 레지스트리 항목을 제거하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters를 탐색합니다.

  3. TCP/IP NSPI Port라는 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 종료하고 Exchange 시스템 수행자 서비스를 다시 시작합니다.

RPC over HTTP를 배포하려면 다음을 수행합니다.

  1. "Exchange Server 2003 RPC over HTTP 배포 시나리오"(http://go.microsoft.com/fwlink/?linkid=47577)를 검토하십시오.

  2. Microsoft 기술 자료 문서 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)을 검토하십시오.

  3. 기술 자료 문서 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)을 검토하십시오.

  4. Microsoft 기술 지원 웹캐스트, "웹캐스트: Microsoft Office Outlook 2003에서 인터넷(RPC/HTTP)을 통해 Microsoft Exchange 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)을 검토하십시오.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

방화벽 환경에서 TCP/IP NSPI Port 레지스트리 값을 사용하는 방법에 대한 자세한 내용은 기술 자료 문서 270836, "XCLN: Exchange 2000 정적 포트 매핑"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)을 참조하십시오.


시스템 수행자 서비스가 데스크톱과 상호 작용하도록 구성되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange System Attendant(MSExchangeSA) 서비스의 DesktopInteract 속성 값을 확인할 때 Win32_Service WMI(Windows Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Exchange 시스템 수행자 서비스가 데스크톱과 상호 작용하도록 구성되어 있으면 오류를 표시합니다.

이 구성은 Microsoft 기술 지원 서비스의 안내에 따라서만 사용해야 합니다. Microsoft Product Support Services에서 이 구성으로 시스템 수행자 서비스를 실행하도록 지시하지 않았으면 데스크톱과 상호 작용하지 않도록 시스템 수행자 서비스 속성을 다시 구성하는 것이 좋습니다.

Exchange 시스템 수행자 서비스 계정을 구성하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. Microsoft Exchange System Attendant 서비스를 찾아서 중지합니다. 시스템 수행자 서비스를 중지하면 시스템 수행자 서비스에 종속된 모든 서비스가 중지됩니다. 여기에는 Microsoft Exchange Information Store 서비스도 포함됩니다.

  3. Microsoft Exchange System Attendant 서비스를 두 번 클릭합니다.

  4. Microsoft Exchange System Attendant 속성 페이지의 로그온 탭에서 다음 계정으로 로그온 아래의 LocalSytem 계정을 선택합니다.

  5. 서비스와 데스크톱 상호 작용 허용 확인란의 선택을 해제한 다음 적용을 클릭합니다.

  6. 서비스 상태에서 시작을 클릭한 다음 확인을 클릭합니다.

  7. 서비스 스냅인을 닫습니다.

올바른 Exchange 서비스 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 239762, "Exchange Services Run Under LocalSystem"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)을 참조하십시오.


시스템 수행자(System Attendant) 서비스가 LocalSystem으로 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-01-09

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange System Attendant(MSExchangeSA) 서비스의 StartName 속성 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 또한 Exchange Server Analyzer는 디렉터리에 있는 Exchange Server 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server 개체의 serialNumber 특성은 해당 개체가 나타내는 컴퓨터에서 실행 중인 Exchange Server 버전을 식별합니다. Exchange Server Analyzer에서 Exchange System Attendant 서비스가 Exchange 2000 Server와 Exchange Server 2003 또는 Exchange Server 2007을 실행 중인 Exchange 서버의 LocalSystem(SYSTEM) 계정 이외의 계정으로 실행 중인 경우 오류를 표시합니다.

이 오류는 시스템 수행자(System Attendant) 서비스가 지원되는 구성으로 실행되고 있지 않음을 나타냅니다. 다른 계정으로 시스템 수행자(System Attendant) 서비스를 실행 중인 경우. 사용 권한과 액세스 오류가 발생할 수 있습니다.

이 오류를 해결하려면 Exchange System Attendant 서비스를 구성하여 LocalSystem(SYSTEM) 계정으로 시작해야 합니다.

참고:
Exchange Server 버전 5.5에는 이 오류가 적용되지 않습니다. Exchange 2000 Server, Exchange Server 2003 및 Exchange Server 2007인 경우에만 LocalSystem 계정으로 Exchange System Attendant 서비스를 실행해야 합니다.
Exchange 시스템 수행자 서비스 계정을 구성하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. Microsoft Exchange System Attendant 서비스를 찾아서 중지합니다. 시스템 수행자 서비스를 중지하면 시스템 수행자 서비스에 종속된 모든 서비스가 중지됩니다. 여기에는 Microsoft Exchange Information Store 서비스도 포함됩니다.

  3. Microsoft Exchange System Attendant 서비스를 두 번 클릭합니다.

  4. Microsoft Exchange System Attendant 속성 페이지의 로그온 탭에서 다음 계정으로 로그온 아래의 LocalSytem 계정을 선택한 다음 적용을 클릭합니다.

  5. 서비스 상태에서 시작을 클릭한 다음 확인을 클릭합니다.

  6. 서비스 스냅인을 닫습니다.

LocalSystem 계정을 사용하여 Exchange 서비스를 실행하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 239762, "Exchange Services Run Under LocalSystem"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)을 참조하십시오.


TcpTimedWaitDelay 키가 없거나 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-03-13

Microsoft Exchange Analyzer Tool은 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인하기 위해 Active Directory 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 5.5"가 포함되어 있으면 해당 컴퓨터에서 Exchange Server 5.5를 실행하고 있는 것입니다. 문자열 값에 "Version 6.0"이 포함되어 있으면 해당 컴퓨터에서 Exchange 2000 Server를 실행하고 있는 것입니다. 문자열 값에 "Version 6.5"가 포함되어 있으면 해당 컴퓨터에서 Exchange Server 2003을 실행하고 있는 것이고, 문자열 값에 "Version 8.0"이 포함되어 있으면 컴퓨터에서 Exchange Server 2007을 실행하고 있는 것입니다.

그런 다음 Exchange Analyzer Tool은 발견된 각 Exchange Server 2007 서버에 대해 다음 레지스트리 분기를 읽고 TcpTimedWaitDelay 키의 값이 기본값인 60으로 설정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

TcpTimedWaitDelay 키는 TCP가 닫힌 연결을 해제하고 해당 리소스를 다시 사용할 수 있는 상태가 될 때까지 경과되어야 하는 시간을 결정합니다. 연결 닫기와 해제 간의 이 기간을 TIME_WAIT 상태 또는 2MSL 상태라고 합니다. 이 시간 동안에는 새 연결을 설정하는 것보다 훨씬 저렴한 가격으로 클라이언트와 서버에 대해 연결을 다시 열 수 있습니다.

이처럼 키 항목의 값을 줄이면 TCP가 닫힌 연결을 보다 빠르게 해제할 수 있으므로 새 연결에 대해 리소스를 더 많이 사용할 수 있습니다. 그러나 값을 너무 낮게 설정하면 연결이 완료되기 전에 TCP가 연결 리소스를 해제할 수 있으므로 서버에서는 연결을 다시 설정하는 데 리소스를 추가로 사용해야 합니다.

Exchange Analyzer는 TcpTimedWaitDelay 키 값이 없거나 기본값인 60 이외의 값이면 경고를 표시합니다.

최적의 성능을 위해서는 Exchange Server 2007 서버에 대해 TcpTimedWaitDelay 키를 기본값인 60으로 설정하는 것이 좋습니다.

중요:
이 항목에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 먼저 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.
TcpTimedWaitDelay 레지스트리 키를 해당 기본값으로 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\Tcpip\Parameters를 탐색합니다.

  3. TcpTimedWaitDelay를 두 번 클릭하고 값 데이터 필드를 60(10진수)으로 설정합니다.

  4. 레지스트리 편집기를 닫고 컴퓨터를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

이 문제는 MaxUserPort 키가 없거나 기본값이 아닙니다. Analyzer 문제와 관련되어 있습니다.

MaxUserPort 및 TcpTimedWaitDelay 레지스트리 키의 영향에 대한 자세한 내용은 Windows 2000 Resource Kit의 "Transmission Control Protocol" 항목(http://go.microsoft.com/fwlink/?LinkId=85654)을 참조하십시오.


TEMP/TMP 변수가 잘못되거나 적합하지 않은 폴더를 가리킵니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

클러스터되지 않은 Exchange Server 컴퓨터에서 Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 TEMP 및 TMP 환경 변수 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

Microsoft Exchange Information Store 서비스는 메시지 변환 및 사서함 이동 작업 같은 다양한 작업 중에 임시 저장소로 TEMP 및 TMP 폴더를 사용합니다. 클러스터되지 않은 Exchange 서버에서 Microsoft Exchange Information Store 서비스는 TEMP 및 TMP 둘 모두에 대해 기본 환경 변수 설정 %Systemroot%\Temp를 사용하는 SYSTEM(예: Local System)을 사용합니다. Exchange Server의 TEMP 또는 TMP 환경 변수 중 하나 또는 모두가 %SYSTEMROOT로 시작될 경우 경고가 표시됩니다.

TEMP 및 TMP 환경 변수는 임시 작업 영역이 필요한 응용 프로그램에서 사용해야 하는 파일 시스템의 폴더(경로)를 지정하는 데 사용됩니다. TEMP는 보통 Microsoft Exchange 같은 응용 프로그램에서, TMP는 Microsoft Visual C++® 같은 개발 도구에서 사용합니다. 각 변수에 대한 경로는 일반적으로 해당 응용 프로그램 또는 도구의 보안 컨텍스트와 관련됩니다.

Exchange Server Analyzer가 Microsoft Windows Server™ 2003 클러스터의 Exchange 가상 서버에 대해 실행되고 있으면 HKLM 레지스트리 트리를 읽지 않습니다. 대신 다음 레지스트리 항목을 읽습니다.

HKEY_USERS\<클러스터 서비스 계정 SID>\Environment\TEMP

HKEY_USERS\<클러스터 서비스 계정 SID>\Environment\TMP

Windows Server 2003 클러스터에서 실행 중인 Exchange 가상 서버는 특정 사용자 보안 규칙의 컨텍스트에서 실행되는 클러스터 서비스 계정에 대한 환경 변수 설정을 사용합니다. 사용자 계정의 경우 TEMP 및 TMP에 대한 기본 환경 변수는 %Userprofile%\temp로 설정됩니다. Exchange 가상 서버의 TEMP 또는 TMP 환경 변수 중 하나 또는 모두가 %SYSTEMROOT로 시작될 경우 경고가 표시됩니다.

성능 최적화를 위해서는 Exchange에서 사용하는 TEMP 및 TMP 폴더에 운영 체제가 포함된 디스크를 사용하지 않는 것이 좋습니다. 또한 이러한 환경 변수를 RAID 0+1 스핀들 세트 같은 고속 디스크 또는 디스크 하위 시스템의 경로로 설정해야 합니다. Exchange 또는 Exchange 가상 서버에서 사용하는 TEMP 및 TMP 폴더에 운영 체제 포함 디스크를 사용하지 않는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 관리 권한이 있는 계정으로 Exchange 서버 컴퓨터에 로그온합니다.

  2. 내 컴퓨터를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  3. 고급 탭을 선택합니다.

  4. 환경 변수 단추를 클릭합니다.

  5. 시스템 변수 영역에서 TEMP를 선택하고 편집 단추를 클릭합니다.

  6. 변수 값 필드에서 TEMP 환경 변수에 대한 새 경로를 입력하고 확인을 클릭합니다.

  7. 시스템 변수 영역에서 TMP를 선택하고 편집 단추를 클릭합니다.

  8. 변수 값 필드에서 TMP 환경 변수에 대한 새 경로를 입력하고 확인을 클릭합니다.

  9. 확인을 클릭하여 환경 변수 대화 상자를 닫고 확인을 한 번 더 클릭하여 시스템 속성 대화 상자를 닫습니다.

  10. 노드를 다시 부팅하여 변경 내용을 적용합니다.

클러스터된 Exchange 서버의 TEMP/TMP 환경 변수 변경에 대한 자세한 내용은 클러스터 TEMP/TMP 경로가 시스템 파티션이 있는 드라이브에 있습니다.를 참조하십시오.


이 서버에 1GB 이상의 실제 메모리가 있으며 HeapDeCommitFreeBlockThreshold가 262144로 설정되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-08-14

오류 메시지

소개

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange가 해당 시스템의 실제 메모리 양에 따라 최적으로 조정되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\HeapDeCommitFreeBlockThreshold

1GB 이상의 실제 메모리가 설치된 Exchange Server 컴퓨터에 HeapDeCommitFreeBlockThreshold 값이 설정되어 있지 않으면 Exchange Server Analyzer에서 경고를 표시합니다.

메모리가 주어진 주소에서 해제되면 운영 체제 힙 관리자는 해당 주소에서 해제된 연속 바이트 수를 검사합니다. 검사가 완료된 후 힙 관리자는 다음 두 가지 중 하나를 수행할 수 있습니다.

  • 연속 메모리 블록을 커밋된 상태로 유지합니다.

  • 연속 메모리 블록에 대한 커밋을 해제하고 예약용으로 표시합니다.

HeapDeCommitFreeBlockThreshold 레지스트리 키는 그 수를 초과할 때 메모리가 커밋 해제되는 연속 바이트 수를 지정합니다. 기본적으로 힙 관리자는 모든 사용 가능 블록을 결합하거나 새 할당을 지정하지는 않으므로 일부 블록은 커밋 해제되어 가상 주소 공간에서 쓸모 없는 공간이 될 수 있습니다. 이로 인해 가상 메모리 조각화 및 성능 저하가 발생하고 결과적으로 시스템 불안정을 초래할 수 있습니다.

1GB 이상의 실제 메모리가 설치된 시스템에서 커밋 해제된 메모리의 청크 크기를 조정하여 성능을 최적화할 수 있습니다. HeapDeCommitFreeBlockThreshold 레지스트리 키는 메모리 해제 시 처리 방법을 제어하는 기능을 제공합니다. 이 값을 레지스트리에 추가할 때 16진수 0x00040000(십진수 262144) 값으로 구성해야 합니다.

Microsoft는 HeapDeCommitFreeBlockThreshold 레지스트리 키 값에 대해 16진수 0x00040000(십진수 262144) 값 외에는 지원하지 않습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Control\Session Manager를 탐색합니다.

  3. HeapDeCommitFreeBlockThreshold라는 DWORD 값을 만듭니다.

  4. HeapDeCommitFreeBlockThreshold 값을 두 번 클릭하고 16진수 0x00040000(십진수 262144) 값을 입력합니다.

  5. 레지스트리 편집기를 닫고 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

HeapDeCommitFreeBlockThreshold 레지스트리 키에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 315407, "XADM: "HeapDecommitFreeBlockThreshold" 레지스트리 키(The "HeapDeCommitFreeBlockThreshold" Registry Key)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=315407)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)


이 서버에서 Windows Server 2003이 실행되고 있고 SystemPages 값이 0으로 설정되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SystemPages 값의 설정을 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

또한 Exchange Server Analyzer는 OSProductSuite 키 값을 확인할 때 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키 값은 Microsoft Windows 운영 체제의 특정 버전에 해당합니다.

Exchange Server Analyzer는 설치된 Microsoft Windows Small Business Server 2003에 속하지 않는 Microsoft Windows Server™ 2003이 실행되고 있는 Exchange Server 컴퓨터에서 SystemPages 값이 0이 아닐 경우 경고를 표시합니다.

1GB 이상의 RAM이 있는 Microsoft Windows Server 2003 시스템에서 Exchange Server 2003 서비스 팩 1(SP1)을 실행할 경우 SystemPages 레지스트리 키를 0으로 설정하는 것이 좋습니다. Microsoft Windows® 2000 Server의 경우 이와는 달리 SystemPages 키를 24000에서 31000 사이의 값으로 설정하도록 권장됩니다.

Microsoft Windows Small Business Server 2003 설치에 속하지 않는 Windows Server 2003 컴퓨터에서는 SystemPages 레지스트리 값을 반드시 0으로 설정해야 합니다. 이 값을 변경하면 시스템에서 최적의 값을 계산할 수 없으며 시스템 변경 시 이 레지스트리 값을 조정하지 못합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
주의:
Windows Server 2003을 실행 중인 컴퓨터에서 SystemPages 레지스트리 값 설정과 관련된 문제는 페이징 풀의 최대 크기가 낮아진다는 것입니다. 이로 인해 페이징 풀이 소모되고 서버가 불안정해집니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management를 탐색합니다.

  3. 오른쪽 창에서 SystemPages를 두 번 클릭합니다.

  4. 값 데이터 필드에 0을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 끝내고 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server의 메모리 최적화에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, "The effects of 4GT tuning on system Page Table Entries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


이 Exchange 서버의 Boot.ini 파일에 /PAE 시작 스위치가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SystemStartupOptions 속성에 설정되어 있는 옵션을 확인할 때 Win32_ComputerSystem WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 또한 Exchange Server Analyzer는 사서함 저장소 개체 msExchPrivateMDB의 homeMDBBL 특성의 개수를 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server 컴퓨터에 있는 사서함 수가 표시됩니다.

Exchange Server Analyzer는 /PAE 시작 스위치가 500개 미만의 사서함이 있는 Exchange 서버의 boot.ini 파일에 설정된 경우 경고를 표시합니다.

PAE(Physical Address Extensions)를 사용하면 컴퓨터가 4GB가 넘는 실제 메모리(RAM)에 액세스할 수 있습니다. Exchange Server에서는 PAE를 지원하지 않습니다. PAE를 사용하여 Windows에서는 4GB가 넘는 실제 메모리에 액세스할 수 있습니다. Exchange Server에서는 4GB 이상의 실제 메모리를 사용할 수 없으므로 Exchange Server만 전적으로 실행하는 컴퓨터에 4GB 이상의 RAM을 설치해도 소용이 없습니다. Boot.ini 파일에 /PAE 시작 스위치가 있으면 PAE가 사용됩니다.

이 경고를 해결하려면 Boot.ini 파일에서 /PAE 스위치를 제거하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Windows 탐색기에서 시스템 파티션을 탐색합니다. 시스템 파티션은 Boot.ini 및 NTLDR 같은 하드웨어 고유 파일이 저장된 파티션을 말합니다.

  2. Boot.ini 파일을 볼 수 없는 경우는 폴더 옵션에서 보호된 운영 체제 파일 숨기기로 설정했기 때문일 수 있습니다. 이러한 경우에는 탐색기 창에서 도구를 클릭하고 폴더 옵션을 클릭한 다음 보기를 클릭합니다. 숨김 파일 및 폴더 표시를 클릭합니다. 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 해제합니다. 대화 상자가 표시되면 예를 클릭합니다.

  3. 탐색기에서 Boot.ini 파일이 보이면 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램을 클릭한 다음 메모장을 클릭하여 파일을 엽니다.

  4. [Operating Systems] 섹션에서 /PAE 스위치를 제거합니다.

  5. 파일을 저장한 후 닫은 다음 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

Boot.ini의 /PAE 스위치에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 268363: "Intel Physical Addressing Extensions (PAE) in Windows 2000"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: "Exchange 메모리 사용과 /3GB 스위치"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


PAE(Physical Address Extensions)가 사용 가능한 상태로 Exchange 서버가 실행되고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-05-08

Microsoft® Exchange Server Analyzer Tool은 다음 키 값을 확인할 때 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • PAEEnabled 이 키 값은 PAE(Physical Address Extensions)가 사용되는지 여부를 나타냅니다. 값이 True이면 PAE가 사용되고 False이면 PAE가 사용되지 않음을 나타냅니다.

  • Version 이 키 값은 컴퓨터에서 실행 중인 Microsoft Windows 운영 체제의 버전을 나타냅니다. 값이 5.0.2195이면 Microsoft Windows 2000 Server 운영 체제가 실행 중이고 값이 5.2.3790이면 Microsoft Windows Server™ 2003 운영 체제가 실행 중임을 나타냅니다.

  • ServicePackMajorVersion 이 키 값은 설치된 Windows 서비스 팩의 주 버전 번호를 나타냅니다.

또한 Exchange Server Analyzer는 보안 업데이트 MS04-032가 컴퓨터에 설치되어 있는지 확인할 때 시스템에서 실행 중인 ntoskrnl.exe의 부 버전에 대해 CIM_Datafile WMI 클래스를 쿼리합니다. ntoskrnl.exe의 부 버전이 174 미만이면 MS04-032가 설치되어 있지 않음을 의미합니다. ntoskrnl.exe의 부 버전이 174보다 크면 MS04-032가 설치되어 있음을 의미합니다.

Exchange Server Analyzer는 보안 업데이트 MS04-032가 설치되지 않은 Windows Server 2003에서 실행 중인 Exchange Server의 PAEEnabled 값이 True로 설정되어 있는 경우 오류를 표시합니다. 이 오류는 컴퓨터에서 Microsoft Exchange Information Store 서비스(Store.exe)가 중지될 수 있는 알려진 문제가 발생할 수 있다는 것을 나타냅니다.

Exchange Server는 PAE를 사용하지 않습니다. PAE를 사용하여 Windows에서는 4GB가 넘는 실제 메모리에 액세스할 수 있습니다. Exchange Server에서는 4GB가 넘는 실제 메모리를 사용할 수 없으므로 Exchange Server만 전적으로 실행하는 컴퓨터에 4GB 이상의 RAM을 설치해도 소용이 없습니다. PAE는 시작 시 Boot.ini 파일에 /PAE 시작 스위치가 있는 경우 사용되거나 Windows Server 2003 운영 체제가 hot-add 메모리 장치를 감지할 경우 사용됩니다. Windows Server 2003, Enterprise Edition 및 Windows Server 2003, Datacenter Edition은 서버가 hot-add 메모리 장치를 사용하는 경우에만 자동으로 PAE를 사용할 수 있습니다.

MS04-032 업데이트를 설치하여 이 오류를 수정하려면 다음을 수행합니다.

  1. MS04-032 업데이트를 얻으려면 Microsoft 기술 자료 문서 840987, "MS04-032: Microsoft Windows용 보안 업데이트"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=840987)를 참조하십시오.

  2. 시스템 전체를 백업합니다.

  3. 업데이트를 설치한 다음 컴퓨터를 다시 시작해야 업데이트가 적용됩니다.

PAE에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 268363, "Intel Physical Addressing Extensions (PAE) in Windows 2000"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882, "Exchange 메모리 사용과 /3GB 스위치"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)

Boot.ini의 /NOPAE 스위치에 대한 자세한 내용은 MSDN 문서, "/nopae"(http://go.microsoft.com/fwlink/?LinkId=51490)를 참조하십시오.


이 Exchange Server는 실제 주소 확장을 활성화하고 /3GB 시작 스위치로 실행합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 PAEEnabled 키 값을 확인합니다. 이 키 값은 PAE(실제 주소 확장)가 사용되는지 여부를 나타냅니다. 값이 True이면 PAE가 사용되고 False이면 PAE가 사용되지 않음을 나타냅니다. 또한 Exchange Server Analyzer는 Win32_OperatingSystem WMI 클래스를 쿼리하여 MaxProcessMemorySize 키 값을 확인합니다.

PAEEnabled 값이 True이고 MaxProcessMemorySize 값이 2097024보다 크다면 Exchange Server Analyzer에서 경고를 표시합니다. 이러한 경고는 이러한 값이 기본값이 아님을 나타냅니다. Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

PAE에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 268363: "Windows 2000의 Intel PAE(Physical Addressing Extensions)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: "Exchange 메모리 사용과 /3GB 스위치"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


이 Exchange 서버는 /PAE 및 /3GB 시작 스위치로 실행 중입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SystemStartupOptions 키에 설정되어 있는 옵션을 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 또한 Exchange Server Analyzer는 MaxProcessMemorySize 키 값을 확인할 때도 Win32_OperatingSystem WMI 클래스를 쿼리합니다.

Exchange Server Analyzer는 SystemStartupOptions 키 값에 /PAE가 포함되어 있고 Win32_OperatingSystem 값이 Microsoft Windows 2000 Server를 나타내며 MaxProcessMemorySize 값이 2097024보다 큰 경우 오류를 표시합니다.

이 오류는 Boot.ini 파일에 /PAE 및 /3GB 시작 스위치가 모두 설정되었음을 나타냅니다. PAE(Physical Address Extension)를 사용하면 컴퓨터가 4GB가 넘는 실제 메모리(RAM)에 액세스할 수 있습니다. Exchange Server에서는 PAE를 지원하지 않습니다. Exchange Server에서는 4GB가 넘는 실제 메모리를 사용할 수 없으므로 Exchange Server만 전적으로 실행하는 컴퓨터에 4GB 이상의 RAM을 설치해도 소용이 없습니다. PAE는 Boot.ini 파일에 /PAE 시작 스위치가 있는 경우 시작 시에 사용됩니다.

Windows 2000 Server에서 이 문제를 해결하려면 Boot.ini 파일에서 /PAE 스위치를 제거합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Windows 탐색기에서 시스템 파티션을 탐색합니다. 시스템 파티션은 Boot.ini 및 NTLDR 같은 하드웨어 고유 파일이 저장된 파티션을 말합니다.

  2. Boot.ini 파일을 볼 수 없는 경우는 폴더 옵션에서 보호된 운영 체제 파일 숨기기로 설정했기 때문일 수 있습니다. 이러한 경우에는 Windows 탐색기 창에서 도구, 폴더 옵션, 보기를 차례로 클릭합니다. 숨김 파일 및 폴더 표시를 클릭합니다. 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 해제합니다. 대화 상자가 표시되면 예를 클릭합니다.

  3. Windows 탐색기에서 Boot.ini 파일이 표시되면 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램, Notepad를 차례로 클릭하여 파일을 엽니다.

  4. [Operating Systems] 섹션에서 /PAE 스위치를 제거합니다.

  5. 파일을 저장하고 닫은 다음 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

Boot.ini의 /PAE 스위치에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 268363, "Intel Physical Addressing Extensions (PAE) in Windows 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882, "Exchange 메모리 사용과 /3GB 스위치"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


이 프런트 엔드 서버가 받는 사람 업데이트 서비스로 구성되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 디렉터리에서 각 Recipient Update Service 개체의 msExchAddressListServiceLink 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msExchAddressListServiceLink 특성은 주소 목록 서비스와 RUS(받는 사람 업데이트 서비스)를 실행하는 Exchange Server 컴퓨터 간의 링크입니다. Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • Exchange Server가 프런트 엔드 서버로 구성되어 있습니다.

  • Exchange Server 컴퓨터가 받는 사람 업데이트 서비스를 실행 중입니다.

받는 사람 업데이트 서비스는 Exchange System Attendant 서비스의 구성 요소입니다. 받는 사람 업데이트 서비스는 Active Directory의 Exchange 관련 특성 값을 만들고 유지 관리합니다. 사용자 사서함을 만드는 경우 받는 사람 업데이트 서비스가 SMTP(Simple Mail Transfer Protocol) 주소 및 받는 사람 정책에 정의된 기타 프록시 주소를 자동으로 생성해야 합니다.

받는 사람 업데이트 서비스를 사용하도록 구성된 Exchange Server가 프런트 엔드 서버로도 구성된 경우 받는 사람 업데이트 서비스에서 새로 만든 사용자 개체를 처리하지 않습니다. 그 결과 사용자 개체가 전자 메일 메시지를 받지 못할 수 있고 받는 사람이 주소 목록에 표시되지 않게 됩니다. 오프라인 주소록 업데이트도 처리되지 않습니다.

이 메시지를 받는다면 받는 사람 업데이트 서비스가 프런트 엔드 서버로 구성된 Exchange Server에서 실행되고 있는 것입니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람에서 받는 사람 업데이트 서비스를 클릭합니다. 오른쪽 창에서 받는 사람 업데이트 서비스의 해당 인스턴스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. Exchange Server 아래의 일반 탭에서 찾아보기를 클릭한 다음 이 RUS 인스턴스를 실행할 새 서버를 지정합니다.

  4. 확인을 클릭한 다음 다시 확인을 클릭하여 변경 내용을 적용합니다.

받는 사람 업데이트 서비스에 대한 자세한 내용은 다음 항목 및 Microsoft 기술 자료 문서를 참조하십시오.

  • 328738, "How the Recipient Update Service applies recipient policies"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, "Recipient Update Service가 주소 목록을 생성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, " How to check the progress of the Exchange Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, "XADM: Tasks Performed by the Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


레지스트리와 Active Directory 간 Exchange 서버 이름에 일치하지 않는 내용이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-12-03

Microsoft® Exchange Server Analyzer Tool은 Active Directory에 저장된 Exchange Server의 이름 값(CN=<ExchangeServerName>)을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 이름을 검색한 후 Exchange Server Analyzer는 이름에 사용된 문자 수를 셉니다.

Exchange Server Analyzer는 Exchange Server 컴퓨터의 레지스트리에 저장된 Exchange Server의 호스트 이름 값을 확인할 때도 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

또한 Exchange Server Analyzer는 Windows® 클러스터 서비스 ClusSvc에 대한 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다.

Exchange Server Analyzer는 다음 기준이 모두 해당될 경우 오류를 표시합니다.

  • CN=<ExchangeServerName> 값이 Hostname 값과 일치하지 않습니다.

  • Exchange Server 이름이 15자 이하입니다.

  • Exchange Server가 Windows 클러스터에서 실행되고 있지 않습니다.

일반적으로 Exchange Server 이름이 변경된 경우 이 오류가 발생합니다. Exchange Server 이름을 변경하면 컴퓨터 레지스트리의 해당 이름과 Activie Directory의 컴퓨터 계정 이름은 변경되지만 Active Directory의 전체 Exchange 특성과 개체에 있는 Exchange Server 이름에 대한 참조는 변경되지 않습니다.

참고:
일부 타사 소프트웨어는 클러스터링 기능을 제공하기 위해 컴퓨터 이름도 변경합니다. 이러한 타사 소프트웨어를 사용 중이면 이 문제를 무시할 수 있습니다.

Exchange Server 컴퓨터의 이름은 변경이 가능하지 않으며 컴퓨터 이름이 변경되면 Microsoft Exchange System Attendant 서비스를 시작하지 못하는 등의 문제가 발생합니다. 이름이 바뀐 Exchange Server 컴퓨터의 모든 기능이 올바르게 작동하지 않으면 이 문서에서 대략 설명하는 수동 제거 프로세스를 사용하여 컴퓨터에서 수동으로 Exchange Server를 제거할 수 있습니다. 이름이 바뀐 Exchange Server 컴퓨터의 모든 기능이 올바르게 작동하지 않을 경우 이 구성은 지원되지 않는 구성이고 나중에 문제가 발생할 수 있으므로 아래의 다시 작성 절차를 사용하여 Exchange Server를 다시 작성해야 합니다.

수동으로 Exchange Server 제거 절차를 수행하여 이 오류를 해결하려면 다음을 수행하십시오.

  1. 모든 Exchange Server 서비스를 중지하고 컴퓨터를 전체 백업합니다.

  2. 실행 중인 Exchange Server 버전에 따라 다음 Microsoft 기술 자료 문서를 참조하십시오.

    • Exchange Server 2007을 실행 중인 경우 Exchange Server 2007 문서 "How to Completely Remove Exchange 2007 from a Server"(http://go.microsoft.com/fwlink/?LinkId=79246)에 설명된 절차를 따르십시오.

    • Exchange Server 2003을 실행 중인 경우 기술 자료 문서 833396, "컴퓨터에서 Exchange Server 2003을 제거하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396)에 설명된 절차를 따르십시오.

    • Exchange 2000 Server를 실행 중인 경우 기술 자료 문서 260378, "XADM: 수동으로 Exchange 2000 설치를 제거하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260378)에 설명된 절차를 따르십시오.

  3. Exchange 2000 Server 또는 Exchange Server 2003이 조직에서 실행 중인 유일한 Exchange 서버일 경우 기술 자료 문서 273478, "Active Directory에서 Exchange 2000 또는 Exchange 2003을 완전히 제거하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=273478)에 설명된 절차를 따르십시오.

Exchange Server 컴퓨터를 다시 설치하여 이 오류를 해결하려면 다음을 수행하십시오.

  1. 사서함, 공용 폴더, 커넥터 및 역할을 조직에 있는 다른 Exchagne Server 컴퓨터로 옮깁니다.

  2. 컴퓨터에서 Exchange Server를 제거합니다.

  3. Exchange Server 2003 또는 Exchange Server 2000을 실행 중인 컴퓨터에서 레지스트리를 정리하려면 다음 Microsoft 기술 자료 문서에 설명된 레지스트리 정리 섹션을 참조하십시오.

    • 833396, "컴퓨터에서 Exchange Server 2003을 제거하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833396)

    • 260378, "XADM: 수동으로 Exchange 2000 설치를 제거하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260378)

    이러한 방법 대신에 운영 체제를 다시 설치할 수도 있습니다.

  4. 컴퓨터에 Exchange Server를 설치합니다.

  5. 사서함, 공용 폴더, 커넥터 및 역할을 새로 설치한 Exchagne Server 컴퓨터로 옮깁니다

클러스터에서 Exchange Server 2003을 배포하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 810986, "Microsoft support policy for Exchange Server installations that are running with a third-party Cluster service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810986)를 참조하십시오.


Active Directory의 Exchange 서버 이름에 일치하지 않는 내용이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-12-03

Microsoft® Exchange Server Analyzer Tool은 서버의 Name 특성과 cn 특성(msExchExchangeServer 클래스의 개체)이 일치하는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 이러한 특성이 다르면 오류 메시지를 표시합니다.

Exchange는 서버를 내부적으로 식별할 때는 해당 서버 개체의 cn 값을 사용하고 Microsoft Exchange System Manager 사용자 인터페이스에서 서버를 식별할 때는 Name 값을 사용합니다.

관리자가 ADSI(Active Directory Service Interfaces) 편집이나 LDP(ldp.exe) 같은 도구를 사용하여 Name 값을 변경하면 이러한 오류가 발생할 수 있습니다. 이 작업이 사용자 인터페이스에서 서버 이름을 변경하는 동안 일치하지 않는 내용이 만들어져서 저장소와 시스템 수행자 이벤트를 생성합니다. ADSI 편집 스냅인, LDP 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 도구를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 해결하려면 다음을 수행하십시오.

  1. ADSI 편집이나 비슷한 도구를 사용하여 Active Directory에서 서버 개체를 찾습니다.

    CN 특성과 Name 특성은 아래 위치에 있습니다.

    코드 복사
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server

  2. Name 특성에 대해 CN 특성 값과 일치하는 새 문자열 값을 입력합니다.

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


Active Directory 서버와 이 Exchange 서버 사이에 네트워크가 두 개 이상 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool 은 RouteRecord 키 값을 확인할 때 root\cimv2 네임스페이스의 WIN32_PingStatus Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. RouteRecord 키에는 Exchange 서버와 도메인 컨트롤러 사이의 중간 홉 레코드(예: 라우터 수)가 포함되어 있습니다. Exchange Server Analyzer는 RouteRecord 키에 나열된 라우터의 수를 셉니다. Exchange Server Analyzer는 둘 이상의 라우터가 나열될 경우 오류를 표시합니다.

Exchange Server 컴퓨터가 서브넷상의 도메인 컨트롤러나 글로벌 카탈로그 서버와 통신할 수 있는 경우 Active Directory® 디렉터리 서비스가 최적의 상태라고 할 수 있습니다. 이 오류는 Exchange Server 컴퓨터가 두 개 이상의 홉 간격이 있는 네트워크상의 도메인 컨트롤러와 통신하고 있음을 나타냅니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 네트워크 토폴로지를 확인하고 Active Directory 서버의 배치를 다시 점검합니다.

  2. Exchange Server와 도메인 컨트롤러에 대한 이벤트 로그를 모니터링하여 잠재적인 문제점을 나타내는 네트워크 관련 이벤트가 기록되었는지 확인합니다.

  3. Active Directory 사이트 디자인을 검토하십시오. 네트워크가 이 사양에 따라 분할되어 있지 않는 경우 네트워크를 더 많은 Active Directory 사이트로 분할합니다.

Win32_PingStatus WMI 클래스에 대한 자세한 내용은 MSDN 문서, "Win32_PingStatus"(http://go.microsoft.com/fwlink/?linkid=33549)를 참조하십시오.

Active Directory 사이트 디자인에 대한 자세한 내용은 "Designing the Site Topology" 웹 사이트(http://go.microsoft.com/fwlink/?linkid=33551)를 참조하십시오.


홉이 너무 많습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-07-06

Microsoft® Exchange Server Analyzer Tool에서는 Exchange 서버에서 SMTP(Simple Mail Transfer Protocol) 도메인에 대한 전자 메일 관리자 계정 또는 사용자 정의 계정으로 테스트 메시지를 보낸 다음 서버의 메시지 추적 로그를 검색하여 테스트 메시지를 배달하는 데 문제가 있는지 확인합니다.

이 검색 과정에서 Exchange Server Analyzer는 메시지가 전달되는 각 서버에 대해 root\MicrosoftExchangeV2 네임스페이스 아래의 Exchange_MessageTrackingEntry Microsoft WMI(Windows® Management Instrumentation) 클래스의 MessageID 속성을 쿼리합니다.

메시지는 최종 대상 위치에 도달하기 전에 여러 SMTP 서버로 라우팅 될 수 있습니다. 이 경로에 있는 각 서버를 홉이라고 부릅니다.

특정 MessageID의 Exchange_MessageTrackingEntry 인스턴트 수가 30개로 늘어나면 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 테스트 메시지가 루프 상태로 이동할 수도 있음을 나타냅니다. 그러므로 Exchange Server Analyzer는 무한 루프 상황이 발생하는 것을 방지하기 위한 안전책으로 추가적인 Exchange_MessageTrackingEntry 인스턴스에 대한 쿼리를 중단합니다.

Exchange Server Analyzer 출력의 메시지 추적 로그 섹션을 추가적으로 분석하면 루프 조건이 존재하는지 여부를 결정하는 데 도움이 됩니다.


지원되지 않는 가상 컴퓨터 구성 - 클러스터된 Exchange Server가 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 Model 키 값이 "Virtual Machine"으로 설정되어 있는지 여부를 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 Windows 클러스터 서비스 ClusSvc의 Started 키 값을 확인할 때도 Win32_Service WMI 클래스를 쿼리합니다. Started 키 값이 True이면 클러스터 서비스가 시작되었음을 나타내고 False이면 클러스터 서비스가 시작되지 않았음을 나타냅니다.

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • Model 키 값이 "Virtual Machine"으로 설정되어 있습니다.

  • 클러스터 서비스의 Started 키 값이 True로 설정되어 있습니다.

이 오류는 Exchange 서버가 가상 컴퓨터 환경에서 실행되는 클러스터된 Exchange 서버임을 나타냅니다. 이 구성은 지원되지 않습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 실제 클러스터를 만들고 가상 환경에서 실행 중인 클러스터된 Exchange 서버에서 실제 클러스터로 사서함을 이동합니다.

  2. 실제 클러스터를 만들 수 없는 경우에는 다음과 같이 이 오류를 해결할 수 있습니다.

    1. 가상 환경에서 실행 중인 Exchange Server에서 비가상 독립형 Exchange Server 컴퓨터로 사서함을 이동합니다.

    2. 모든 공용 폴더를 옮기고 필요에 따라 클러스터된 Exchange 서버에서 수행하는 모든 역할을 전송합니다.

    3. 가상 컴퓨터에서 Exchange Server를 제거하여 Exchange Server 인프라 및 Active Directory에서 제거합니다.

가상 환경에서 실행되는 Exchange Server 2003 지원 정책에 대한 자세한 내용은 Microsoft 기술 자료 문서 320220, "Support policy for Exchange Server 2003 running on hardware virtualization software"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)를 참조하십시오.


지원되지 않는 가상 시스템 구성 - Exchange Server 2003 서비스 팩 2 이상을 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Model 키가 "Virtual Machine"으로 설정되어 있는지 확인합니다.

또한 Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 5.5"가 있으면 컴퓨터에서 Exchange Server 5.5를 실행하고 있는 것입니다. 문자열 값에 "Version 6.0"이 있으면 컴퓨터에서 Exchange Server 2000을 실행하고 있는 것입니다. 문자열 값에 "Version 6.5"가 있으면 컴퓨터에서 Exchange Server 2003을 실행하고 있는 것입니다. 문자열 값에 "Version 6.5" 및 "Service Pack 2"가 있으면 컴퓨터에서 Exchange Server 2003 서비스 팩 2(SP2)를 실행하고 있는 것입니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • Model 키가 "Virtual Machine"으로 설정되어 있습니다.

  • 컴퓨터에서 Exchange Server 2003용 SP2 이상 버전을 실행하고 있지 않습니다.

이 오류는 Exchange 서버가 가상 시스템이지만 Exchange Server 2003 SP2 이상 버전이 설치되어 있지 않음을 나타냅니다. 이 구성은 사용할 수 없습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange Server 2003 서비스 팩 2 이상 버전을 설치합니다.

  2. Microsoft 기술 자료 문서 320220, "Support policy for Exchange Server 2003 running on hardware virtualization software"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)를 검토합니다.

  3. 서비스 팩 2 이상 버전을 적용할 수 없는 경우 다음을 수행하여 이 오류를 수정할 수 있습니다.

    1. Virtual Server 2005에서 실행 중인 Exchange Server에서 비가상 Exchange Server 컴퓨터로 사서함을 이동합니다.

    2. 모든 공용 폴더를 옮기고 필요에 따라 가상 Exchange 서버가 수행하고 있는 모든 역할을 이전합니다.

    3. 가상 컴퓨터에서 Exchange Server를 제거하고 Exchange Server 인프라 및 Active Directory에서 제거합니다.


지원되지 않는 가상 컴퓨터 구성 - Virtual Machine Additions가 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 Model 키 값이 "Virtual Machine"으로 설정되어 있는지 여부를 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 다음 레지스트리 항목을 읽어 Virtual Machine Additions가 설치되었는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

이 레지스트리 경로가 있으면 Virtual Machine Additions가 설치되었음을 나타냅니다. 이 레지스트리 경로가 없으면 Virtual Machine Additions가 설치되지 않았음을 나타냅니다.

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • Model 키 값이 "Virtual Machine"으로 설정되어 있습니다.

  • 이 레지스트리 경로가 없습니다.

이 오류는 Exchange 서버가 가상 컴퓨터이지만 Virtual Machine Additions가 설치되어 있지 않음을 나타냅니다. 이 구성은 지원되지 않습니다.

Virtual Machine Additions를 설치하려면 다음을 수행합니다.

  1. 가상 환경에서 실행 중인 Exchange Server를 백업합니다.

  2. Virtual Server 2005 관리 콘솔이나 웹 사이트를 사용하여 Virtual Machine Additions를 설치합니다.

가상 환경에서 Exchange Server 2003을 실행하는 방법에 자세한 내용은 Microsoft 기술 자료 문서 320220, "Support policy for Exchange Server 2003 running on hardware virtualization software"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)를 참조하십시오.


일광 절약 시간제 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-07-30

Microsoft® Exchange Server Analyzer Tool은 Active Directory 디렉터리 서비스를 쿼리하여 각 Exchange Server 개체의 versionNumber 특성 값을 확인합니다. versionNumber 특성은 해당 컴퓨터에서 실행 중인 Exchange Server의 버전을 나타냅니다.

또한 Exchange Analyzer는 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Store.exe 프로세스의 Version 키 값을 확인합니다.

  • Version 키 값 7638은 Exchange Server 2003 서비스 팩 2를 나타냅니다.

  • Version 키 값 7226은 Exchange Server 2003 서비스 팩 1를 나타냅니다.

  • Version 키 값 6944는 Exchange Server 2003의 원본 릴리스를 나타냅니다.

  • 위의 버전들 사이에 해당하는 값은 서버가 Store.exe 프로세스의 핫픽스 업데이트 버전을 실행하고 있음을 나타냅니다.

Exchange Analyzer는 Exchange Server 2003 SP2를 실행 중인 서버에 있는 Store.exe의 Version 키 값이 7561보다 작거나 Exchange Server 2003 SP1을 실행 중인 서버에서 해당 값이 7234보다 작으면 경고를 표시합니다.

이 경고는 2007년에 일광 절약 시간제 변경 사항이 업데이트되지 않은 상태로 Exchange Server 컴퓨터에서 Exchange Server 2003 서비스 팩 1 또는 Exchange Server 2003 SP2가 실행되고 있음을 나타냅니다.

이와 같이 업데이트되지 않으면 CDO 기반 프로그램 및 Outlook Web Access의 일정 항목이 마치 일광 절약 시간제의 남은 주 동안 표준시가 적용되는 것처럼 동작합니다.

Exchange Server 2003 SP2에서 이 오류를 해결하려면 다음을 수행합니다.

  1. Microsoft 기술 자료 문서 926666, "Exchange 2003 서비스 팩 2의 2007년 일광 절약 시간제 변경 사항에 대한 업데이트"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=926666)를 참조하십시오.
Exchange Server 2003 SP1에서 이 오류를 해결하려면 다음을 수행합니다.

  1. Microsoft 기술 자료 문서 931978, "Exchange 2003 서비스 팩 1의 2007년 일광 절약 시간제 변경 사항에 대한 업데이트"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=931978)를 참조하십시오.


Windows 2000 SP4의 업데이트 롤업이 설치되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 ServicePackMajorVersion 키 값을 확인할 때 Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 또한 Exchange Server Analyzer는 다음 레지스트리 항목을 조사하여 대상 컴퓨터에서 실행 중인 Windows 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Exchange Server Analyzer는 대상 시스템에서 Windows 2000 Server 운영 체제가 실행되고 있지만 Windows 2000 Server 서비스 팩 4의 업데이트 롤업이 실행되고 있지 않을 경우 경고를 표시합니다.

가장 좋은 방법은 Exchange 배포의 모든 소프트웨어에 대해 최신 서비스 팩 및 롤업을 설치하는 것입니다

이 경고를 해결하려면 다음을 수행합니다.

  1. Windows 2000 Server가 실행되는 모든 도메인 컨트롤러와 글로벌 카탈로그 서버를 서비스 팩 4의 업데이트 롤업 및 Windows 업데이트 사이트에 있는 최신 핫픽스와 업데이트로 업데이트합니다.

  2. 모든 Exchange Server 컴퓨터를 최신 롤업 및 업데이트 롤업으로 업데이트합니다.

Windows 2000 SP4의 업데이트 롤업에 대한 자세한 내용은 Microsoft 기술 자료 문서 891861, "Windows 2000 SP4용 업데이트 롤업 1과 알려진 문제"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=891861)를 참조하십시오.

Exchange Server 서비스 팩 및 롤업을 구하여 설치하는 방법에 대한 자세한 내용은 Exchange Server 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21573)를 참조하십시오.


URLScan이 설치되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-20

Microsoft® Exchange Server Analyzer Tool은 다음 파일이 Exchange Server의 다음 위치에 있는지 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

%WINDOWSPATH%\\SYSTEM32\\INETSRV\URLSCAN\URLSCAN.DLL

Urlscan.dll의 존재는 URLScan 도구가 Exchange Server에 설치되어 있음을 나타냅니다. Exchange Server Analyzer는 URLScan 도구가 Exchange Server에 설치되어 있으면 유용한 정보 권장 사항을 표시합니다.

URLScan은 웹 사이트 관리자가 서버에서 처리하는 HTTP 관련 요청을 제한할 수 있게 하는 ISAP(IInternet Server Application Programming Interface) 필터입니다. URLScan 필터는 특정 HTTP 요청을 차단하여 유해할 수 있는 요청이 서버에 접근하여 손상시키지 못하도록 방지합니다.

Exchange Server에서 URLScan을 실행할 경우 Exchange Server의 역할에 대해 Urlscan.ini를 설정해야 합니다. Exchange Server의 보안을 향상시키려면 Urlscan.ini 구성 파일을 편집하여 관계 없는 기능을 제거해야 합니다. 특정 Exchange Server 2003 컴퓨터 역할에 맞게 Urlscan.ini 파일을 사용자 지정하려면 Urlscan.ini 파일의 [AllowVerbs] 섹션에서 동사를 제거해야 합니다. 그러나 적절한 기능을 수행하려면 컴퓨터의 역할에 권장되는 동사는 포함되어 있어야 합니다. 단일 컴퓨터에서 여러 웹 기반 기능이 필요할 경우 적절한 [AllowVerbs] 섹션 요구 사항을 병합해야 합니다.

Microsoft 기술 자료 문서 823175, "Fine-tuning and known issues when you use the Urlscan utility in an Exchange 2003 environment"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823175)에 포함된 Exchange Server 2003 Urlscan 템플릿의 정보를 사용하여 Exchange Server 2003 컴퓨터 역할에 기반하여 Urlscan.ini 파일을 수정할 수 있습니다.

URLScan에 대한 자세한 내용은 "UrlScan 보안 도구"(http://go.microsoft.com/fwlink/?LinkId=24490)를 참조하십시오.

Exchange Server 환경에서 URLScan을 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 309677, "XADM: Known Issues and Fine Tuning When You Use the IIS Lockdown Wizard in an Exchange 2000 Environment"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=309677)

  • 309508, "XCCC: Exchange 환경의 IIS 잠금 및 URLscan 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=309508)

  • 325965, "The URLScan tool may cause problems in Outlook Web Access"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325965)

  • 326444, "URLScan 도구를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=326444)


USERVA가 잘못 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-09-19

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터의 실제 메모리 양과 Exchange Server 컴퓨터에서 실행되는 사용자 모드 프로세스에 할당된 가상 주소 공간의 양을 확인할 때 세 개의 Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 다음 표에서는 Exchange Server Analyzer가 계산하는 클래스와 키에 대해 설명합니다.

쿼리된 클래스 | 쿼리된 키 수 | 설명
Win32_OperatingSystem | MaxProcessMemorySize | 프로세스에 할당할 수 있는 최대 메모리(킬로바이트)
Win32_ComputerSystem | TotalPhysicalMemory | 컴퓨터에 설치되어 있는 RAM의 바이트 수
Win32_Service | Started | 서비스의 상태입니다. True 값은 서비스가 실행되고 있음을 나타내고 False 값은 실행되지 않음을 나타냅니다.

또한 Exchange Server Analyzer는 Exchange Server 컴퓨터에서 실행 중인 Microsoft Windows 버전을 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 4.0은 Exchange Server 컴퓨터에 Microsoft Windows NT® Server 4.0이 실행되고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터에 Windows 2000 Server가 실행되고 있음을 나타내고 값 5.2는 해당 컴퓨터에 Windows Server™ 2003이 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 사서함 저장소 개체 msExchPrivateMDB의 homeMDBBL 특성에 나열된 항목 개수를 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server 컴퓨터에 있는 사서함 수가 표시됩니다.

Exchange Server Analyzer는 다음 조건이 모두 True로 설정되어 있으면 경고를 표시합니다.

  • Exchange Server 컴퓨터가 Windows Server 2003에서 실행되고 있습니다.

  • TotalPhysicalMemory 값이 1073741824보다 큽니다.

  • MaxProcessMemorySize 값이 3145600과 같습니다.

  • 클러스터 서비스(ClusSvc)의 Win32_Service\Started 값이 True이거나 Exchange Server 컴퓨터에 20개 이상의 사서함이 포함되어 있습니다.

이 경고는 Exchange Server 컴퓨터가 가상 메모리 사용에 적절한 상태로 구성되어 있지 않음을 나타냅니다. 구체적으로 말해서 /USERVA=3030 시작 스위치가 Exchange Server 컴퓨터의 Boot.ini 파일에 없는 것입니다. 이 스위치를 추가하면 확장성과 성능이 향상될 수 있습니다.

Windows Server 2003은 두 개의 Boot.ini 시작 스위치 /3GB 및 /USERVA를 지원합니다. 이러한 시작 스위치를 사용하여 메모리 및 메모리 주소 공간의 할당을 조정할 수 있습니다. 시스템의 실제 메모리 양과 관계없이 Windows는 4GB의 가상 주소 공간을 사용합니다. 이 중 2GB는 응용 프로그램 같은 사용자 모드 프로세스에 할당되고 나머지 2GB는 운영 체제 및 커널 모드 드라이브 같은 커널 모드 프로세스에 할당됩니다. 실제 메모리가 1GB 이상 있는 시스템에서는 이러한 시작 스위치를 사용하여 응용 프로그램에 더 많은 메모리(3GB)를 할당하고 운영 체제에 더 적은 메모리(1GB)를 할당할 수 있습니다. Exchange Server 컴퓨터에서 이러한 여분의 가상 주소 공간이 할당되면 정보 저장소 프로세스 가상 주소 공간상의 메모리 조각화를 줄이는 데 도움이 됩니다. /3GB 스위치는 이러한 할당량 변화에 영향을 미칩니다. 이 스위치는 시스템의 Boot.ini 파일에 입력되며 다시 부팅한 후에 적용됩니다. 이 스위치는 메모리가 1GB 이상이고 다음 운영 체제 중 하나를 실행 중인 Exchange 서버에서만 사용해야 합니다.

  • Microsoft Windows Server 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

중요:
Windows 2000 Server에서는 /3GB 스위치를 사용하지 않아야 합니다. 이러한 운영 체제에서는 이 스위치가 지원되지 않아 응용 프로그램이나 운영 체제가 충돌할 수 있기 때문입니다. 또한 /3GB 스위치는 위 운영 체제 중 1GB 이상의 실제 메모리가 설치되어 있는 경우에만 지원됩니다. 또한 Windows Server 2003 Standard Edition에서 실행 중인 Active Directory 서버(도메인 컨트롤러 및 글로벌 카탈로그 서버)에서 /3GB 스위치를 사용해서는 안 됩니다.

/USERVA 스위치는 Windows Server 2003에 새로 추가된 기능입니다. 이 스위치는 사용자 모드 프로세스와 커널 모드 프로세스 사이에서 가상 주소 공간을 보다 명확하게 구분하기 위해 제공됩니다. 이 스위치는 Exchange Server 2003과 같이 지원하는 응용 프로그램에서만 사용해야 하며 해당 응용 프로그램이 지원하는 특정 값을 지정해야 합니다. Exchange Server 2003 시스템에서 사용할 경우에는 항상 /USERVA 값이 3030과 같아야 합니다(/USERVA=3030). 이 값을 사용하면 운영 체제에 40MB가 추가로 할당되므로 사용 가능한 시스템 리소스를 모두 사용하지는 않으면서 더 많은 사용자를 추가할 수 있습니다.

Windows Server 2003에서 이러한 경고를 해결하려면 다음을 수행합니다.

  1. 내 컴퓨터를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다. 시스템 속성 대화 상자가 나타납니다.

  2. 고급 탭을 클릭합니다.

  3. 시작 및 복구 영역에서 설정을 클릭합니다. 시작 및 복구 대화 상자가 나타납니다.

  4. 시스템 시작 영역에서 편집을 클릭합니다. 그러면 메모장에서 Windows Boot.ini 파일이 열립니다.

  5. [Operating Systems] 섹션의 시작 줄에 /3GB /USERVA=3030 스위치를 추가합니다.

  6. 변경 내용을 저장하고 메모장을 닫습니다.

  7. 확인을 차례로 두 번 클릭하여 대화 상자를 닫은 후 Exchange Server 컴퓨터를 다시 부팅하여 변경 내용을 적용합니다.

/3GB 및 /USERVA 시작 스위치 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 297812, "How to Use the 4GT RAM Tuning Feature"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "The effects of 4GT tuning on system Page Table Entries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, "How to use the /userva switch with the /3GB switch to tune the User-mode space to a value between 2 GB and 3 GB"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739).

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


이 컴퓨터에 설치되어 있는 Tcpip.sys 파일 버전에는 핫픽스가 필요합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Tcpip.sys 파일의 Version 키에 설정되어 있는 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Version 키 값이 Tcpip.sys 파일의 특정 버전에 해당하는 경우 경고를 표시합니다.

이 경고에 대한 자세한 내용은 Microsoft 기술 자료 문서 898060, "보안 업데이트 MS05-019 또는 Windows Server 2003 서비스 팩 1을 설치한 후 클라이언트와 서버의 네트워크 연결이 실패할 수 있다"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=898060)의 권장 사항을 참조하십시오.


가상 컴퓨터 구성이 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 Model 키 값이 "Virtual Machine"으로 설정되어 있는지 여부를 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 클러스터 서비스 ClusSvc의 Started 키 값을 확인할 때도 Win32_Service WMI 클래스를 쿼리합니다. Started 키 값이 True이면 클러스터 서비스가 시작되었음을 나타냅니다. False 값은 클러스트 서비스가 시작되지 않았음을 나타냅니다.

또한 Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 6.5" 및 "Service Pack 2"가 있으면 해당 컴퓨터가 Exchange Server 2003 서비스 팩 2(SP2)를 실행 중입니다.

마지막으로 Exchange Server Analyzer는 다음 레지스트리 항목을 읽어 Virtual Machine Additions가 설치되었는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

이 레지스트리 경로가 있으면 Virtual Machine Additions가 설치되었음을 나타냅니다. 이 레지스트리 경로가 없으면 Virtual Machine Additions가 설치되지 않았음을 나타냅니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 유용한 정보 메시지를 표시합니다.

  • Exchange 서버가 Microsoft Virtual Server 2005에서 게스트로 실행 중입니다.

  • Exchange 서버가 Exchange Server 2003 서비스 팩 2 이상을 실행 중입니다.

  • Exchange 서버가 클리스터되지 않았습니다.

  • Virtual Server 2005의 Virtual Machine Additions가 Exchange 서버에 설치되었습니다.

Exchange Server Analyzer가 발견할 수 없는 이 구성을 실행하려면 몇 가지 요구 사항이 필요합니다. 따라서 Virtual Server 2005 환경에서 Exchange Server 2003을 실행하기 전에 이 구성의 지원성 및 성능 조정에 대한 다음과 같은 최신 정보 문서를 검토하는 것이 좋습니다.

Microsoft 기술 자료 문서 320220, "Support policy for Exchange Server 2003 running on hardware virtualization software"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)


가상 메모리가 조각화됨
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2007-02-15

Microsoft Exchange Analyzer Tool은 MSExchangeIS에 대한 이벤트 9582 오류가 최근 24시간 이내 기록되었는지 여부를 확인할 때 Win32_NTLogEvent Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다.

최근 24시간 이내 이벤트 9582가 기록되었으면 Exchange Analyzer에서는 오류를 표시합니다.

이 오류는 Exchange 서버 실행에 필요한 가상 메모리가 조각화되었음을 나타냅니다.

32비트 Microsoft Windows 시스템의 경우 두 가지 메모리가 있습니다.

  • 실제 메모리 시스템에 설치된 실제 메모리 양

  • 가상 메모리 주소 공간 가상화된 4GB 메모리 공간

해당 시스템에 설치되어 있는 실제 메모리 양에 관계없이 전체 가상 주소 공간 크기는 항상 4GB로 동일합니다. 모든 32비트 응용 프로그램에 적용되는 것은 아니지만 Exchange Server의 경우 가상 주소 공간은 가상 메모리와 동일합니다. 즉, 두 용어를 같은 의미로 사용할 수 있습니다.

Exchange 저장소는 정상적인 작업 중에 가상 메모리를 반복적으로 할당, 사용 및 할당 취소합니다. 가상 메모리를 할당하고 사용한 다음 할당을 취소하는 것을 자주 하면 가상 메모리가 조각화될 수 있습니다. 가상 메모리 조각화는 지속적으로 발생할 수 있는 파일 시스템 조각화와 비슷합니다. 어느 정도 시간이 지나면 할당된 가상 메모리 세그먼트가 더 이상 연속적이지 않아 성능이 저하됩니다. 파일 시스템의 경우 파일 시스템의 조각 모음을 수행하는 응용 프로그램을 실행할 수 있습니다. 대부분의 경우 파일 시스템에 온라인으로 액세스하는 중에도 조각 모음을 수행할 수 있습니다. 가상 메모리 조각화를 해결할 수 있는 조각 모음 도구는 없습니다. 대신 이 문제를 해결하려면 Microsoft Exchange Information Store 서비스를 중지했다가 시작하거나 시스템을 다시 시작해야 합니다.

이 문제를 해결하려면 다음을 수행합니다.

  • 저장소/inetinfo 프로세스에서 실행되는 타사 소프트웨어로 인해 가상 메모리 조각화가 발생할 수 있습니다. 모든 타사 응용 프로그램에 대해 최신 드라이버가 설치되어 있는지 확인하십시오.

  • 성능 로그 및 경고 도구를 사용하여 MSExchangeIS 성능 개체의 VM Total Large Free Block Bytes 카운터를 모니터링합니다. 이 카운터에서 수집한 데이터를 사용하여 36~72시간 내에 서버를 종료했다가 다시 시작하기에 가장 적절한 응용 프로그램을 확인합니다.

참고:
클러스터된 서버인 경우 클러스터 리소스를 수동 노드로 이동하기 전에 수동 노드를 중지했다가 다시 시작하여 대상 가상 메모리 주소 공간이 비워지도록 합니다.
  • 시스템을 다시 시작한 후에도 문제가 다시 발생하면 타사 소프트웨어를 비활성화합니다.

  • 사용자 사서함을 다른 서버로 이동하여 서버 로드를 줄이고 문제가 해결되었는지 여부를 확인하십시오. 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.

자세한 정보

  • MSExchangeIS 이벤트 9852에 대한 자세한 내용은 "이벤트 및 오류 메시지 센터: 이벤트 세부 정보"(http://go.microsoft.com/fwlink/?LinkId=83209)를 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • Microsoft Exchange Server 2003 및 Exchange 2000 Server의 가상 메모리 조각화 문제 해결 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 325044, "HOWTO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)을 참조하십시오.

  • 가상 메모리 사용 최적화 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)을 참조하십시오.

  • 사용자 사서함을 이동하여 서버 로드를 줄이는 방법에 대한 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.


Virtual Server 2005 R2 이상이 검색되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 Microsoft Virtual Server 2005에 포함된 가상 서버 서비스가 표시하는 프로세스인 Vssrvc.exe의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Vssrvc.exe의 Version 키 값이 1.1.465.0인 경우 오류를 표시합니다.

이 오류는 Exchange 서버가 Virtual Server 2005 R2 이상 버전을 실행하지 않는 Microsoft Virtual Server 2005 환경에서 게스트로 실행 중임을 나타냅니다. 이 구성은 지원되지 않습니다. Exchange Server 2003 서비스 팩 2 이상 버전은 Microsoft Virtual Server 2005 R2 이상 버전에서 실행되는 경우 가상 환경에서 게스트로만 지원됩니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Microsoft 기술 자료 문서 320220, "Support policy for Exchange Server 2003 running on hardware virtualization software"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)를 참조하십시오.

  2. Microsoft Virtual Server 2005 R2 이상 버전을 설치합니다. Microsoft Virtual Server 2005 R2에 대한 자세한 내용은 Microsoft Virtual Server 2005 R2 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=34938)를 참조하십시오.

  3. Virtual Server 2005 R2 이상 버전을 설치할 수 없는 경우에는 다음과 같이 이 오류를 해결할 수 있습니다.

    1. Virtual Server 2005에서 실행 중인 Exchange Server에서 비가상 Exchange Server 컴퓨터 또는 Virtual Server 2005 R2에서 실행 중인 가상 Exchange Server 컴퓨터로 사서함을 이동합니다.

    2. 모든 공용 폴더를 옮기고 필요에 따라 지원되지 않는 가상 Exchange 서버에서 수행하는 모든 역할을 전송합니다.

    3. 지원되지 않는 가상 컴퓨터에서 Exchange Server를 제거하여 Exchange Server 인프라 및 Active Directory에서 제거합니다.


Virus Scan Queue Length가 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-27

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeIS 성능 개체의 Virus Scan Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Exchange Server Analyzer는 샘플 시간 동안 Virus Scan Queue Length 카운터에 대한 90 백분위수 값이 10보다 클 경우 오류를 표시합니다.

Virus Scan Queue Length 성능 카운터는 바이러스 검색을 위해 대기 중인 현재 해결되지 않은 요청 수를 표시합니다.

이 오류는 다음과 관련된 성능 문제를 나타낼 수 있습니다.

  • 서버 성능이 저하되며 대개 CPU 지체로 인해 발생합니다.

  • 서버 로드가 정상적인 경우보다 높습니다.

  • 최신 바이러스 검색 엔진이 아닙니다.

  • 바이러스 검색 엔진이 잘못 구성되었습니다.

이 오류를 해결하려면 다음 단계를 수행합니다.

  • 바이러스 엔진의 업데이트를 찾습니다.

  • 바이러스 검색 소프트웨어를 다시 설치합니다.

  • 올바른 스레드 구성, 파일 수준 제외 등에 대한 바이러스 검색 엔진의 구성을 검사합니다. Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&k)를 참조하십시오.

  • 성능 모니터(Perfmon.msc) 도구를 사용하여 서버의 로드 증가로 지체가 발생했는지 또는 서버 용량이 부족한지 확인합니다. 서버 로드가 증가한 경우 로드의 원인을 확인하고 로드를 줄입니다. 서버에 리소스가 부족한 경우에는 필요한 리소스를 늘리거나 사용자를 다른 서버로 이동합니다.

프로세서 지체 문제 제거

Exchange 서버에서 프로세서 지체 문제를 제거하는 여러 가지 방법이 있습니다.

  • 먼저 서버의 로드를 발생시키는 응용 프로그램이나 작업을 검토합니다. 응용 프로그램에서 프로세서 시간을 그대로 사용해야 하는지 또는 프로세스에 문제가 있는지 확인합니다.

  • 해당 서버에서 Exchange가 아닌 응용 프로그램이 중요하지 않은 경우에는 다른 서버에서 실행하십시오. 다른 서버에서 해당 응용 프로그램을 실행할 수 있으면 서버 역할도 다른 컴퓨터로 이동합니다. 예를 들어 Inetinfo 프로세스가 CPU 사용률을 많이 차지하는 경우 프런트 엔드 서버를 추가하여 Inetinfo가 수행하는 프로토콜 작업을 수행하게 합니다. 공용 폴더 액세스를 전용 공용 폴더 서버로 이동할 수도 있습니다. 마지막으로 서버가 다량의 메일 그룹 확장을 수행하는 경우에는 메일 그룹 확장을 전용 메일 그룹 확장 서버로 이동하여 CPU 사용률을 줄일 수 있습니다.

  • 가능하면 서버에 더 많은 프로세서나 속도가 빠른 프로세서를 추가합니다. 또한 프로세서에서 하이퍼 스레딩을 지원할 경우 해당 기능을 사용합니다. 시스템 BIOS를 구성하여 하이퍼 스레딩을 사용할 수 있습니다. 자세한 내용은 컴퓨터 제조업체의 도움말을 참조하십시오.

  • 처리 성능 향상이 실행 가능한 옵션이 아닐 경우에는 프로세서의 로드를 줄여야 합니다. 서버에 대한 전반적인 영향을 줄이려면 I/O 또는 CPU를 많이 사용하거나 메모리를 사용하는 작업은 정규 작업 시간을 피해서 수행해야 합니다.

  • 백업 및 유지 관리 작업과 같이 CPU를 많이 사용하는 작업은 작업량이 많은 시간대를 피해 이루어져야 합니다. 또한 이러한 작업은 단계적인 방식으로 수행해야 합니다. 작업을 단계적으로 수행하는 것은 각 작업에 대해 시작 시간 및 가능하다면 종료 시간도 다르게 설정하는 것을 의미합니다. 또한 데이터베이스 또는 저장소 그룹의 유지 관리 및 백업을 단계적으로 수행함으로써 리소스를 많이 사용하는 이러한 작업의 영향을 줄입니다.

추가 정보

  • Exchange Server 및 바이러스 검색에 대한 개요는 Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)를 참조하십시오.

  • 바이러스 검색 및 Exchange Server에 대한 자세한 내용은 Microsoft 기술 자료 문서 285667, "XADM: Exchange 2000 Server SP1의 바이러스 검색 API 2.0에 대한 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667)를 참조하십시오.

  • 프로세서 지체에 대한 자세한 내용은 프로세서 지체를 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 사용자 사서함을 이동하여 서버 로드를 줄이는 방법에 대한 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.


Virus Scan Queue Length가 경고 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-04-20

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 MSExchangeIS 성능 개체의 Virus Scan Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Exchange Server Analyzer는 샘플 시간 동안 Virus Scan Queue Length 카운터에 대한 90 백분위수 값이 5보다 클 경우 경고를 표시합니다.

Virus Scan Queue Length 성능 카운터는 바이러스 검색을 위해 대기 중인 현재 해결되지 않은 요청 수를 표시합니다.

이 경고는 이 서버에 성능 문제가 있을 수 있음을 나타냅니다. 성능 문제는 다음과 관련될 수 있습니다.

  • 서버 성능이 저하되며 이는 대개 CPU 지체로 인해 발생합니다.

  • 서버 로드가 정상적인 경우보다 높습니다.

  • 최신 바이러스 검색 엔진이 아닙니다.

  • 바이러스 검색 엔진이 잘못 구성되었습니다.

이 경고를 해결하려면 다음 단계를 수행합니다.

  • 바이러스 엔진의 업데이트를 찾습니다.

  • 바이러스 검색 소프트웨어를 다시 설치합니다.

  • 올바른 스레드 구성, 파일 수준 제외 등에 대한 바이러스 검색 엔진의 구성을 검사합니다. Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)를 참조하십시오.

  • 성능 모니터(Perfmon.msc) 도구를 사용하여 서버의 로드 증가로 지체가 발생했는지 또는 서버 용량이 부족한지 확인합니다. 서버 로드가 증가한 경우 로드의 원인을 확인하고 로드를 줄입니다. 서버에 리소스가 부족한 경우에는 필요한 리소스를 늘리거나 사용자를 다른 서버로 이동합니다.

프로세서 지체 문제 제거

Exchange 서버에서 프로세서 지체 문제를 해결하는 여러 가지 방법이 있습니다.

  • 먼저 서버의 로드를 발생시키는 응용 프로그램이나 작업을 검토합니다. 응용 프로그램에서 프로세서 시간을 그대로 사용해야 하는지 또는 프로세스에 문제가 있는지 확인합니다.

  • 해당 서버에서 Exchange가 아닌 응용 프로그램이 중요하지 않은 경우에는 다른 서버에서 실행하십시오. 이렇게 실행할 수 있는 경우에는 서버 역할도 다른 컴퓨터로 이동합니다. 예를 들어 Inetinfo 프로세스가 CPU 사용률을 많이 차지하는 경우 프런트 엔드 서버를 추가하여 Inetinfo가 수행하는 프로토콜 작업을 수행하게 합니다. 공용 폴더 액세스를 전용 공용 폴더 서버로 이동할 수도 있습니다. 마지막으로 서버가 다량의 메일 그룹 확장을 수행하는 경우에는 메일 그룹 확장을 전용 메일 그룹 확장 서버로 이동하여 CPU 사용률을 줄일 수 있습니다.

  • 가능하면 서버에 더 많은 프로세서나 속도가 빠른 프로세서를 추가합니다. 또한 프로세서에서 하이퍼 스레딩을 지원할 경우 해당 기능을 사용합니다. 시스템 BIOS를 구성하여 하이퍼 스레딩을 사용할 수 있습니다. 자세한 내용은 컴퓨터 제조업체의 도움말을 참조하십시오.

  • 처리 성능 향상이 실행 가능한 옵션이 아닐 경우에는 프로세서의 로드를 줄여야 합니다. 서버에 대한 전반적인 영향을 줄이려면 I/O 또는 CPU를 많이 사용하거나 메모리를 소비하는 작업은 정규 작업 시간을 피해서 수행해야 합니다.

  • 백업 및 유지 관리 작업과 같이 CPU를 많이 사용하는 작업은 작업량이 많은 시간대를 피해 이루어져야 합니다. 또한 이러한 작업은 단계적인 방식으로 수행해야 합니다. 작업을 단계적으로 수행하는 것은 각 작업에 대해 시작 시간 및 가능하다면 종료 시간도 다르게 설정하는 것을 의미합니다. 또한 데이터베이스 또는 저장소 그룹의 유지 관리 및 백업을 단계적으로 수행함으로써 리소스를 많이 사용하는 이러한 작업의 영향을 줄입니다.

추가 정보

  • Exchange Server 및 바이러스 검색에 대한 개요는 Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)를 참조하십시오.

  • 바이러스 검색 및 Exchange Server에 대한 자세한 내용은 Microsoft 기술 자료 문서 285667, "XADM: Exchange 2000 Server SP1의 바이러스 검색 API 2.0에 대한 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667)를 참조하십시오.

  • 프로세서 지체에 대한 자세한 내용은 프로세서 지체를 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 사용자 사서함을 이동하여 서버 로드를 줄이는 방법에 대한 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.


볼륨 탑재 지점 오류: Windows Server 2003 SP1이 설치되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool은 CIM_Datafile WMI(Windows® Management Instrumentation)를 쿼리하여 Mountmgr.sys 드라이버가 있는지 확인합니다.

그런 다음 Exchange Server Analyzer는 다음 레지스트리 값을 읽어 Exchange 서버에서 실행하고 있는 Microsoft Windows® 운영 체제의 버전을 확인합니다. HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값이 5.0이면 Exchange 서버가 Microsoft Windows 2000 Server에서 실행되고 있습니다. CurrentVersion 값이 5.2이면 Exchange 서버가 Microsoft Windows Server™ 2003에서 실행되고 있습니다.

Exchange Server Analyzer는 또한 Win32_Service Microsoft WMI(Microsoft Windows® Management Instrumentation) 클래스를 쿼리하여 ClusSvc(클러스터 서비스)의 Started 키 값을 확인합니다. 값이 TRUE이면 클러스터 서비스가 시작되었음을 나타내고 FALSE이면 클러스터 서비스가 실행되고 있지 않음을 나타냅니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고를 표시합니다.

  • Exchange Server 컴퓨터가 Windows Server 2003에서 실행되고 있습니다.

  • Windows Server 2003 SP1이 설치되어 있지 않습니다.

  • Exchange Server가 클러스터된 환경에서 실행되고 있습니다.

  • 볼륨 탑재 지점이 있습니다.

이 경고는 Exchange 클러스터 노드 환경이 Windows Server 2003 SP1로 업그레이드되면 다음 섹션에서 참조하는 업데이트가 필요함을 나타냅니다. 이 업데이트를 사용하지 않으면 업그레이드 후에 볼륨 탑재 지점 오류가 발생할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  • Microsoft 기술 자료 문서 898790, "Volume mount points on disks in a server cluster may intermittently become unavailable after you install Windows Server 2003 Service Pack 1"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790)에서 참조하는 업데이트를 적용합니다.


Windows 방화벽 서비스가 Exchange Server에서 활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Windows 방화벽 서비스(SharedAccess)에 대한 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 Windows 방화벽 서비스가 Exchange Server에서 활성화되어 있음을 나타냅니다.

Exchange Server Analyzer는 Windows 방화벽 서비스가 Exchange Server 컴퓨터에서 활성화되면 경고를 표시합니다. Windows 방화벽 서비스가 활성화되면 다음 문제가 발생할 수 있습니다.

  • 메시지 추적 서비스 또는 RPC(원격 프로시저 호출) 통신과 같은 Exchange Server의 일부 구성 요소가 응답을 중지할 수 있습니다.

  • 사용 가능한 메모리가 부족하다는 오류 메시지를 받을 수 있습니다.

기본적으로 Windows 방화벽 서비스는 Microsoft Windows Server™ 2003 SP1(서비스 팩 1)이 적용되는 경우에 중지됩니다. 그러나 다음 조건 중 하나에 해당할 경우 이 서비스가 실행되도록 자동 설정됩니다.

  • 관리자가 수동으로 Windows 방화벽 서비스를 활성화합니다.

  • 보안 구성 마법사를 실행한 후 Windows 방화벽 서비스를 활성화합니다.

이 경고를 해결하려면 다음을 수행합니다.

  • 프로그램 제외를 확인합니다.

  • 포트 제외를 확인합니다.

  • 클라이언트가 Exchange Server에 연결할 수 없으면 방화벽 예외를 확인합니다.

  • Exchange System Manager 및 Microsoft Exchange Administrator가 실행될 수 있도록 수동으로 방화벽에 포트를 엽니다. Windows Firewall에 포트를 열면 다른 프로그램이 해당 포트를 통해 사용자 컴퓨터에 액세스할 수 있습니다. Windows 방화벽 서비스에서 포트를 열기 전에 네트워크 보안 요구 사항을 주의 깊게 고려하십시오.

  • Windows 방화벽 서비스를 중지합니다.


Winmgmt(Windows Management Instrumentation) 서비스가 LocalSystem으로 실행되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 ObjectName 값의 값 데이터를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winmgmt

레지스트리 분기의 ObjectName 값은 Winmgmt 서비스라고 하는 Microsoft WMI(Windows® Management Instrumentation) 서비스의 서비스 계정 설정을 나타냅니다. Exchange Server Analyzer는 ObjectName의 값 데이터가 LocalSystem과 동일하지 않음을 확인하면 오류를 표시합니다.

이 오류는 WMI 서비스가 지원되는 구성으로 실행되고 있지 않음을 나타냅니다. LocalSystem 계정이 아닌 다른 계정으로 WMI 서비스를 실행하면 사용 권한 오류와 액세스 오류가 발생할 수 있습니다.

이 오류를 해결하려면 LocalSystem(SYSTEM) 계정으로 시작하도록 WMI 서비스를 구성해야 합니다.

WMI 서비스 계정을 구성하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. Windows Management Instrumentation 서비스를 찾아서 중지합니다.

  3. Windows Management Instrumentation 서비스를 두 번 클릭합니다.

  4. Windows Management Instrumentation 속성 페이지의 로그온 탭에서 다음 계정으로 로그온 아래의 로컬 시스템 계정을 선택한 다음 적용을 클릭합니다.

  5. 서비스 상태에서 시작을 클릭한 다음 확인을 클릭합니다.

  6. 서비스 스냅인을 닫습니다.


Windows Server 2003 SP1: Outlook Web Access 핫픽스가 필요합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 정보를 수집할 때 다양한 Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exchange Server가 설치된 Microsoft Windows Server 운영 체제 버전은 무엇입니까?

  • Exchange Server는 클러스터에서 실행 중입니까?

Exchange Server Analyzer는 다음 조건에서 오류를 표시합니다.

  • Exchange Server 2003 서비스 팩 1(SP1)이 설치되어 있습니다.

  • Microsoft Windows Server™ 2003 서비스 팩 1(SP1)이 설치되어 있습니다.

  • 클러스터 서비스가 실행되고 있습니다.

  • Davex.dll의 Version 값은 6.5.7232 미만입니다.

이 구성을 실행하고 Exchange Server 핫픽스를 다운로드하여 설치한 다음 Windows Server 2003 SP1을 설치해야 합니다. Exchange Server 핫픽스를 설치하지 않은 경우 Exchange Server 2003용 Microsoft Office Outlook® Web Access 사용자는 해당 사서함에 로그온할 수 없습니다. 클러스터에서 호스팅된 사서함이 있는 사용자가 Outlook Web Access를 사용하여 연결하려고 할 때 다음과 같은 오류 메시지가 나타납니다.

  • "500 - 내부 서버 오류"

이 오류는 Windows Server 2003 SP1이 포함되어 있는 일부 보안 향상 기능으로 인해 나타납니다.

사용자가 Outlook Web Access를 사용하여 사서함에 로그온하려고 할 때, HTTP는 로그온한 사용자를 가장하여 클러스터링 API에 요청을 보냅니다. 그러나 Windows Server 2003 SP1에는 º?°æμE 보안 사항이 있습니다. 원격 레지스트리 액세스를 실행하는 API의 보안 제한이 변경되었습니다. 따라서 로그온 시도가 실패합니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 841561, "'500 - Internal server error' error message when a user tries to access a clustered Exchange Server 2003 back-end server by using Outlook Web Access"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561)에 설명된 Exchange Server 핫픽스를 다운로드하여 설치해야 합니다.


Windows Server 2003 SP1 보안 구성 마법사가 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 값을 읽어 Exchange Server에서 실행 중인 Microsoft Windows® 운영 체제의 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값이 5.0이면 Exchange Server가 Microsoft Windows 2000 Server에서 실행 중입니다. CurrentVersion 값이 5.2이면 Exchange Server가 Microsoft Windows Server™ 2003에서 실행 중입니다.

그리고 Exchange Server Analyzer는 다음 레지스트리 값을 읽어 Windows Program Files 디렉터리 경로를 확인합니다.

HKLM\Software\Microsoft\Windows\CurrentVersion\ProgramFilesDir

그러면 Exchange Server Analyzer는 Windows Program Files 디렉터리에 Exchange Server에 대한 \Exchsrvr 폴더가 있는지 확인할 때 Windows Program Files 디렉터리를 조사합니다.

마지막으로 Exchange Server Analyzer는 ServicePackMajorVersion 키 값을 확인할 때 Win32_OperatingSystem WMI(Windows Management Instrumentation) 클래스를 쿼리합니다. ServicePackMajorVersion 키 값은 Windows 서비스 팩이 컴퓨터에 설치되어 있음을 나타냅니다.

Exchange Server Analyzer는 다음 조건에서 경고 메시지를 표시합니다.

  • Exchange Server Analyzer에서 Exchange Server 컴퓨터가 Windows Server 2003 서비스 팩 1에서 실행하는지 확인한 경우

  • Exchange Server Analyzer에서 Exchange Server 2003이 기본 경로인 \Program Files\Exchsrvr에 설치되어 있지 않음을 확인한 경우

이 경고는 Exchange Server 2003이 서버의 기본 Program Files 폴더에 설치되어 있지 않고 보안 구성 마법사가 Exchange Server에 설치되어 있음을 나타냅니다. 보안 구성 마법사는 Windows Server 2003 서비스 팩 1의 선택적 구성 요소로 포함되는 도구로 Exchange Server에 보안 구성 마법사가 설치되어 있으면 네트워크 보안 섹션을 수동으로 구성해야 합니다.

참고:
보안 구성 마법사를 설치하려면 Windows Server 2003 서비스 팩 1을 먼저 설치해야 합니다. 서비스 팩 1을 설치한 후 제어판의 프로그램 추가/제거를 열어 보안 구성 마법사를 설치합니다.

보안 구성 마법사를 사용하여 서버의 기능 요구 사항을 확인하기 위해 설계된 일련의 질문을 사용자에 물어서 Windows 서버에 대한 공격을 줄일 수 있습니다. 특히 보안 구성 마법사로 다음 작업을 수행할 수 있습니다.

  • 필요 없는 서비스를 자동으로 사용하지 않도록 설정합니다.

  • 사용되지 않는 포트를 자동으로 차단합니다.

  • 열려 있는 포트에 대해 추가 주소 제한 또는 보안 제한을 적용합니다.

  • 해당 사항이 있을 경우 불필요한 인터넷 정보 서비스(IIS) 웹 확장을 방지합니다.

  • SMB(서버 메시지 블록), LanMan 및 LDAP(Lightweight Directory Access Protocol)에 대한 프로토콜 노출을 줄입니다.

  • 높은 signal-to-noise 감사 정책을 정의합니다.

보안 구성 마법사는 서버의 선택된 역할에 기반하여 보안 정책을 만들고, 편집하고, 적용하거나 롤백하는 과정을 안내합니다. 보안 구성 마법사를 사용하여 만든 보안 정책은 적용 시 서비스, 네트워크 보안, 특정 레지스트리 값 및 감사 정책을 구성하는 XML 파일입니다. 해당 사항이 있을 경우 인터넷 정보 서비스(IIS)를 구성할 수도 있습니다.

보안 구성 마법사에는 다른 기능을 수행할 뿐만 아니라 Windows 방화벽에 예외 사항을 구성하고 추가하는 네트워크 보안 기능이 들어 있습니다. Windows 방화벽은 Windows Server 2003 서비스 팩 1에 있는 새 버전의 상태 저장 패킷 필터입니다. Windows 방화벽은 Windows XP 서비스 팩 2에서 처음 소개되었습니다. Windows XP 서비스 팩 2에서는 인터넷 연결이라고 했습니다.

보안 구성 마법사의 네트워크 보안 기능이 Exchange Server가 기본 경로에 설치되어 있지 않은 Exchange Server에서 실행할 때 발생하는 알려진 문제가 있습니다. 이 구성에서 정책 결과 적용으로 인해 클라이언트에서 Exchange Server에 액세스하지 못할 수도 있습니다. Exchange Server가 기본 경로에 설치되어 있지 않은 Exchange Server에서 네트워크 보안 기능이 사용되면 보안 구성 마법사는 Windows 방화벽을 구성하여 System Attendant(Mad.exe), Microsoft Exchange Information Store(Store.exe) 또는 메시지 전송 에이전트(Emsmta.exe)와 같은 Exchange Server 프로세스의 TPC/IP 포트 액세스를 차단할 수 있습니다. 이 구성에서 보안 구성 마법사는 각 프로세스 옆에 찾을 수 없음!을 표시합니다. 옆에 찾을 수 없음!이 표시되는 프로세스를 완료할 때까지 보안 구성 마법사가 실행되면 보안 구성 마법사는 해당 프로세스에서 네트워크에 액세스하지 못하도록 차단하는 보안 정책을 Windows 방화벽에 적용합니다.

차단된 프로세스에 한 개 이상의 Exchange Server 프로세스가 포함되면 클라이언트와 다른 서버가 Exchange Server에 액세스하지 못할 수도 있습니다. 이런 상태에서는 다음 절차 중 하나를 수행하여 문제를 해결해야 합니다.

문제를 해결하려면 다음을 수행합니다.

  • 다음 절차 중 하나를 수행하여 문제를 해결합니다.

    • 보안 구성 마법사의 롤백 기능을 사용하여 보안 정책이 적용된 후에 보안 정책을 롤백합니다. 이 작업을 수행하는 방법에 대한 자세한 내용은 Windows Server 2003 서비스 팩 1에 포함된 보안 구성 마법사 도움말 파일을 참조하십시오. Windows Server 2003 서비스 팩 1 및 보안 구성 마법사에 대한 자세한 내용은 Windows Server 2003 TechCenter(http://go.microsoft.com/fwlink/?LinkId=45315)를 참조하십시오.

    • 보안 구성 마법사에서 응용 프로그램 경로 필드에 수동으로 입력하여 Exchange Server 실행 프로세스 파일 위치를 지정합니다. 이렇게 하려면 옆에 찾을 수 없음!이 표시되는 프로세스를 선택하고 편집을 클릭합니다. Exchange Server에서 보안 구성 마법사를 실행하여 각 Exchange Server 프로세스 실행 파일 경로가 정확한지 확인하는 것이 좋습니다. 각 프로세스 실행 파일이 확인되면 보안 구성 마법사의 보안 정책을 적용할 수 있으며 Exchange Server에서 네트워크에 액세스할 수 있게 됩니다. 네트워크 액세스는 작동에 필요합니다.

Windows Server 2003 서비스 팩 1 및 보안 구성 마법사에 대한 자세한 내용은 Windows Server 2003 TechCenter(http://go.microsoft.com/fwlink/?LinkId=45315)를 참조하십시오.


XESE.DLL 파일이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Xese.dll이라는 파일의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

Exchange Server Analyzer가 이 파일의 Version 값을 얻을 수 있으면 해당 파일이 존재한다는 것을 나타내므로 오류가 표시됩니다.

일부 ESE 기반 바이러스 백신 프로그램은 Exchange 정보 저장소와 확장 가능한 저장소 엔진(ESE) 사이에 지원되지 않는 인터페이스를 사용합니다. 이러한 유형의 소프트웨어를 사용하면 소프트웨어 구현에 오류가 있을 경우 데이터베이스 손상과 데이터 손실 위험이 있습니다.

설치하는 동안 ESE 기반 검색 프로그램은 Microsoft Exchange Information Store 서비스를 ESE 기반 바이러스 백신 프로그램의 서비스에 종속되도록 변경합니다. 이로써 Microsoft Exchange Information Store 서비스가 시작되기 전에 ESE 기반 바이러스 백신 프로그램의 서비스가 시작됩니다. ESE 기반 바이러스 검색 프로그램이 시작되면 Exchange Server에 포함된 Ese.dll의 이름이 임시로 Xese.dll로 바뀌고 ESE 기반 바이러스 검색 프로그램의 Ese.dll이 원래 파일을 대체합니다. ESE 기반 바이러스 검색 프로그램의 Ese.dll이 로드되면 Exchange Server에 포함된 파일 이름이 다시 Ese.dll로 바뀌고 Microsoft Exchange Information Store 서비스는 시작 프로세스를 완료합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터에서 ESE를 구현할 때는 Microsoft 제품만 사용하는 것이 좋습니다. Microsoft 기술 지원 서비스에 문의하는 고객은 문제를 쉽게 확인할 수 있도록 ESE 기반 바이러스 검색 프로그램을 비활성화하도록 요청받을 수 있으나 문제의 근본 원인을 정확하게 진단한 후에는 다시 사용할 수 있습니다.

  2. 가장 일반적으로 사용되는 ESE 기반 바이러스 백신 프로그램은 Sybari Software의 Antigen for Microsoft Exchange입니다. Microsoft와 Sybari에서는 문제의 원인을 파악하기 위해 Sybari Antigen을 비활성화하는 것이 올바른 문제 해결 단계라는 데에 동의합니다. Sybari Software에 문의하려면 Sybari Software 웹 사이트(http://www.sybari.com)를 방문하십시오.

    참고:
    필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 제공됩니다. URL은 예고 없이 변경될 수 있습니다.

  3. AVAPI(AntiVirus API)라고도 하는 VSAPI(Virus Scanning Application Programming Interface)를 지원하는 바이러스 백신 프로그램을 사용하는 것도 좋습니다.

Exchange Server에서 바이러스 백신 소프트웨어를 실행하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=)

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=)


하드웨어
Microsoft Exchange Server Analyzer - 문서 >

최근 수정된 항목: 2005-11-18

이 섹션의 문서에서는 Microsoft® Exchange Server Analyzer Tool이 평가하는 하드웨어 관련 내용에 대해 자세히 설명합니다. 또한 이 문서에서는 Exchange Server Analyzer에서 발견하는 하드웨어 관련 오류, 경고 및 기본이 아닌 구성을 해결하기 위해 사용자가 취해야 할 조치를 설명합니다.


BIOS가 이전 버전입니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SMBIOSBIOSVersion 키 및 ReleaseDate 키 값을 확인할 때 Win32_BIOS Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 반환되는 값은 컴퓨터에 설치된 BIOS의 버전 번호와 릴리스 번호를 각각 나타냅니다. 또한 Exchange Server Analyzer는 Model 키 값을 확인할 때 Win32_ComputerSystem WMI 클래스도 검사합니다.

Exchange Server Analyzer는 ReleaseDate 값이 1년보다 이전 날짜이고 Model 키에 다음 문자열 중 하나가 포함되어 있을 경우 경고를 표시합니다.

  • ProLiant DL320

  • ProLiant DL320 G2

  • ProLiant DL320 G3

  • ProLiant DL360

  • ProLiant DL360 G2

  • ProLiant DL360 G3

  • ProLiant DL360 G4

  • ProLiant DL380

  • ProLiant DL380 G2

  • ProLiant DL380 G3

  • ProLiant DL380 G4

  • ProLiant DL560

  • ProLiant DL580 G3

  • ProLiant DL580

  • ProLiant DL580 G2

  • ProLiant DL580 G3

  • ProLiant DL580 G1

  • ProLiant ML350

  • ProLiant ML350 G2

  • ProLiant ML350 G3

  • ProLiant ML350 G4

  • ProLiant ML370

  • ProLiant ML370 G2

  • ProLiant ML370 G3

  • ProLiant ML370 G4

  • ProLiant ML530

  • ProLiant ML530 G2

  • ProLiant ML570

  • ProLiant ML570 G2

  • ProLiant ML750

이 경고를 해결하기 위해 최신 BIOS 버전을 구하여 업데이트하는 방법에 대한 자세한 내용은 Hewlett-Packard 웹 사이트 "ROM-BIOS/Firmware Updates"(http://h18023.www1.hp.com/support/files/server/us/romtabl.html)를 참조하십시오.

Hewlett-Packard ProLiant 서버에 대한 자세한 내용은 Hewlett-Packard 웹 사이트(http://www.hp.com)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


Dell PowerEdge 서버의 BIOS가 오래된 것입니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SMBIOSBIOSVersion 키 값을 확인할 때 Win32_BIOS Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 반환되는 값은 컴퓨터에 설치되어 있는 BIOS의 버전 번호를 나타냅니다. 또한 Exchange Server Analyzer는 Model 키 값을 확인할 때 Win32_ComputerSystem WMI 클래스도 검사합니다.

Exchange Server Analyzer에서 Model 키에 다음 문자열 중 하나가 포함되어 있고 SMBIOSBIOSVersion이 해당 모델의 최신 버전이 아님을 확인하면 경고가 표시됩니다.

  • PowerEdge 2400

  • PowerEdge 2450

  • PowerEdge 2500

  • PowerEdge 2550

  • PowerEdge 2600

  • PowerEdge 2650

  • PowerEdge 2800

  • PowerEdge 2850

  • PowerEdge 3250

  • PowerEdge 4300

  • PowerEdge 4350

  • PowerEdge 4400

  • PowerEdge 4600

  • PowerEdge 6300

  • PowerEdge 6350

  • PowerEdge 6400

  • PowerEdge 6450

  • PowerEdge 6600

  • PowerEdge 6650

  • PowerEdge 6800

  • PowerEdge 6850

  • PowerEdge 7150

  • PowerEdge 7250

  • PowerEdge 8450

이 경고를 수정하는 방법과 새 BIOS 버전을 구하고 업데이트하는 방법은 Dell 웹 사이트에서 "Downloads"(http://support.dell.com/support/downloads)를 참조하십시오.

Dell PowerEdge 서버에 대한 자세한 내용은 Dell 웹 사이트(http://www.dell.com)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


BIOS 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Win32_BIOS Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMBIOSBIOSVersion 키 값을 확인합니다. 반환되는 값은 컴퓨터에 설치된 BIOS의 버전 번호와 릴리스 날짜를 나타냅니다. 또한 Exchange Server Analyzer는 Win32_ComputerSystem WMI 클래스를 검사하여 Model 키 값을 확인합니다. 컴퓨터가 REJT48A 이전 BIOS 버전을 가진 IBM X445 시스템이면 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류를 수정하기 위해 최신 BIOS 버전을 받아 업데이트하는 방법에 대한 자세한 내용은 IBM 웹 사이트 "Flash BIOS update (DOS update package) with RSA I and RSA II EXA support - IBM eServer xSeries 445"(http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


클러스터 네트워크 인터페이스 카드에서 DHCP를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 클러스터의 모든 네트워크 인터페이스에 대한 DHCPEnabled 키 값을 확인할 때 Win32_NetworkAdapterConfiguration Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 클러스터의 개인 네트워크 인터페이스에 대해 DHCPEnabled 값이 True로 설정되어 있으면 오류를 표시합니다.

DHCPEnabled WMI 키 값이 True이면 네트워크 인터페이스가 DHCP(Dynamic Host Configuration Protocol)을 사용하도록 구성되어 있음을 나타냅니다. Microsoft에서는 Windows 서버 클러스터의 개인 네트워크에 있는 노드에 대해 DHCP를 사용하는 것을 지원하지 않습니다. 또한 Windows 서버 클러스터의 공용 네트워크에 있는 노드에 대해서는 고정 IP 주소를 사용하는 것이 좋습니다. DHCP 임대를 갱신하지 못하면 클러스터 작업이 중단될 수 있으므로 DHCP를 통해 공용 네트워크를 동적으로 구성하는 방식은 권장되지 않습니다. 또한 DHCP를 통해 개인 네트워크를 동적으로 구성하는 방식은 지원되지 않으므로 이 작업을 수행하면 안 됩니다.

이 문제를 해결하려면 고정 IP 주소를 사용하도록 개인 네트워크의 네트워크 인터페이스를 다시 구성해야 합니다. 주소는 다음 범위 내에서 선택하는 것이 좋습니다.

  • 10.0.0.0 - 10.255.255.255(클래스 A 네트워크)

  • 172.16.0.0 - 172.31.255.255(클래스 B 네트워크)

  • 192.168.0.0 - 192.168.255.255(클래스 C 네트워크)

이 오류를 수정하려면 다음을 수행합니다.

  1. 네트워크 연결에서 개인 네트워크 어댑터에 대한 네트워크 연결을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  2. 인터넷 프로토콜(TCP/IP)을 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭에서 다른 공용 네트워크 어댑터와 동일한 서브넷 또는 네트워크상에 있지 않은 고정 IP 주소를 입력합니다. 개인 어댑터에 사용하기 좋은 IP 주소의 예로 서브넷 마스크가 255.0.0.0인 노드 1의 10.10.10.10과 노드 2의 10.10.10.11을 들 수 있습니다. 공용 네트워크에서 10.x.x.x 네트워크와 255.0.0.0 서브넷 마스크를 사용할 경우 대체 개인 네트워크 IP와 서브넷을 사용합니다.

  4. 기본 게이트웨이 상자에 설정된 값이 없는지 확인합니다.

  5. 다음 DNS 서버 주소 사용 상자에 정의된 값이 없는지 확인합니다.

  6. 고급을 클릭합니다.

  7. DNS 탭에서 정의된 값이 없는지 확인합니다. DNS에 이 연결의 주소를 등록 및 DNS 등록에 이 연결의 DNS 접미사 사용 확인란의 선택이 해제되어 있는지 확인합니다.

  8. WINS 탭에서 정의된 값이 없는지 확인합니다. NetBIOS over TCP/IP 사용 안 함을 클릭합니다.

  9. 이 대화 상자를 닫으면 다음 메시지가 표시될 수 있습니다. 다음 메시지가 표시되면 예를 클릭합니다. 현재 연결의 기본 WINS 주소가 비어 있습니다. 계속하시겠습니까?

  10. 확인을 클릭하여 변경 내용을 저장합니다.

  11. 클러스터의 다른 모든 노드에 대해 이전 단계를 완료합니다.

Windows 서버 클러스터에 대한 최적의 네트워크 구성에 대한 자세한 내용은 "Server Clusters: Network Configuration Best Practices for Windows 2000 and Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=34304)을 참조하십시오.

올바른 클러스터 하트비트 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 258750, "클러스터 서버에 권장하는 개인 "하트비트" 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)을 참조하십시오.


컴퓨터의 주 DNS 접미사가 상주하는 도메인의 FQDN과 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2006-05-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 이 Exchange Server의 주 DNS(Domain Name System) 접미사를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\NV Domain

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Domain

Exchange Server Analyzer에서 NV Domain 및 Domain 값의 불일치를 발견하면 경고가 표시됩니다.

NV Domain 레지스트리 값은 컴퓨터의 주 DNS 접미사를 포함합니다. Domain 레지스트리 값은 컴퓨터의 기본 DNS 도메인을 포함합니다. 기본적으로 컴퓨터의 정규화된 도메인 이름(FQDN)의 주 DNS 접미사 부분은 컴퓨터가 위치한 Active Directory® 디렉터리 서비스의 도메인 이름과 동일해야 합니다. 이름이 일치하지 않으면 DNS가 올바르게 등록되지 않을 수 있습니다. 컴퓨터의 DNS 도메인 이름이 Active Directory 도메인 이름과 일치하지 않으면 22분마다 컴퓨터의 시스템 이벤트 로그에 오류가 표시됩니다. 이러한 조건은 분리된 네임스페이스로 알려져 있습니다. 다른 기본 DNS 접미사를 사용하려면 도메인 개체 컨테이너에서 msDS-AllowedDNSSuffixes라고 하는 Active Directory 특성을 만들어 허용된 접미사의 제한 목록을 만들 수 있습니다.

분리된 네임스페이스를 올바르게 구성했는지 확인하는 절차는 Active Directory 도메인 컨트롤러에 사용한 운영 체제에 따라 다릅니다.

  • Active Directory 도메인 컨트롤러에서 Microsoft Windows® 2000 Server 운영 체제를 실행 중이면 Microsoft 기술 자료 문서 258503, "DNS Registration Errors 5788 and 5789 When DNS Domain and Active Directory Domain Name Differ"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258503)에 대략 설명된 절차를 따라 네임스페이스를 올바르게 구성할 수 있습니다. 이 문서에는 의도하지 않았지만 분리된 네임스페이스를 수정하는 절차와 의도적으로 분리된 네임스페이스를 올바르게 구성하는 절차가 나와 있습니다.

  • Active Directory 도메인 컨트롤러에서 Microsoft Windows Server™ 2003을 실행 중이고 분리된 네임스페이스가 의도적인 것이 아니면 아래 첫 번째 절차를 따라 의도되지 않은 분리된 네임스페이스를 수정하고 이 경고를 해결할 수 있습니다. Active Directory 도메인 컨트롤러에서 Windows Server 2003을 실행 중이고 분리된 네임스페이스가 의도적인 것이면 아래 두 번째 절차를 따라 분리된 네임스페이스를 올바르게 구성할 수 있습니다.

아래의 두 번째 절차를 수행하려면 ADSI(Active Directory Service Interfaces) 편집 또는 LDP(Ldp.exe) 도구와 같은 Active Directory 편집기를 사용해야 합니다. LDP 도구를 사용하여 Active Directory를 수정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745)를 참조하십시오.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제가 발생하면 Windows Server 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

분리된 네임스페이스가 의도적인 것이 아니면 다음을 수행합니다.

  1. 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. 시스템 속성 대화 상자가 나타납니다.

  2. 컴퓨터 이름 탭을 클릭합니다.

  3. 변경을 클릭합니다. 컴퓨터 이름 변경 대화 상자가 나타납니다.

  4. 자세히를 클릭합니다. DNS 접미사 및 NetBIOS 컴퓨터 이름 대화 상자가 나타납니다.

  5. 도메인 구성 자격이 변경되면 주 DNS 접미사 변경 확인란을 선택합니다.

  6. 확인을 클릭하여 변경 내용을 저장한 다음 확인을 클릭하여 컴퓨터 이름 변경 대화 상자를 닫습니다.

  7. 확인을 클릭하여 시스템 속성 대화 상자를 닫은 다음 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

분리된 네임스페이스가 의도적인 것이면 다음을 수행합니다.

  1. 도메인 구성 자격이 변경되면 주 DNS 접미사 변경 확인란이 해제되었는지 확인하려면 위의 절차를 따릅니다.

  2. 도메인 개체 컨테이너의 msDS-AllowedDNSSuffixes Active Directory 특성을 수정합니다. 다음 단계를 수행하여 ADSI 편집을 통해 특성을 수정할 수 있습니다.

    1. 수정하려는 도메인의 디렉터리 파티션을 두 번 클릭합니다.

    2. 도메인 컨테이너 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

    3. 특성 상자의 특성 편집기 탭에서 특성 msDS-AllowedDNSSuffixes를 두 번 클릭합니다.

    4. 다중값 문자열 편집기 대화 상자의 값 상자에 추가할 DNS 접미사를 입력하고 추가를 클릭합니다.

    5. 도메인에 대한 모든 DNS 접미사를 추가했으면 확인을 클릭합니다.

    6. 도메인에 대한 속성 대화 상자를 닫으려면 확인을 클릭합니다.

    7. 비슷하게 구성하려는 도메인이 여러 개 있으면 이러한 단계를 반복합니다.

msDS-AllowedDNSSuffixes 특성에 대한 자세한 내용은 Windows Server 2003 도움말 및 지원 센터를 참조하십시오. 이 특성의 편집 절차에 대한 자세한 내용은 "Step-by-Step Guide to Implementing Domain Rename"(http://go.microsoft.com/fwlink/?LinkId=41359)을 참조하십시오.


중요 BIOS 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2006-04-20

Microsoft® Exchange Server Analyzer Tool은 Win32_BIOS Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMBIOSBIOSVersion 키 값을 확인합니다. SMBIOSBIOSVersion 키 값은 서버에 설치된 BIOS 버전을 나타냅니다. 또한 Exchange Server Analyzer는 Win32_ComputerSystem WMI 클래스를 쿼리하여 Model 키 값을 확인합니다. Model 키 값은 하드웨어 제조업체가 제공한 하드웨어 모델 정보를 나타냅니다.

Model 키가 eserver xSeries 445로 시작하는 서버에서 Version 키 값이 42B이면 Exchange Server Analyzer에서 오류를 표시합니다. 이 오류는 이 IBM xSeries 445 서버의 BIOS를 업데이트해야 함을 나타냅니다.

42B 버전의 BIOS 펌웨어에는 데이터를 손상시킬 수 있는 알려진 문제가 있습니다. 이 문제는 BIOS 42B(버전 1.15)가 설치된 X445 시스템에서만 발생합니다. 이 문제는 BIOS 45A 버전에서 해결되었습니다. 가능한 빨리 이 서버의 BIOS를 45A 이상의 버전으로 업데이트해야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 이 문제에 대한 자세한 내용은 IBM 웹 사이트, "Flash BIOS Update (DOS update package) - IBM eServer xSeries 445"(http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089#BIOSVersion)를 참조하십시오.

  2. 자세한 내용은 BIOS 업데이트에 대한 추가 정보 파일(ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers/39y4888.txt)을 참조하십시오.

  3. IBM 웹 사이트(http://www-307.ibm.com/pc/support/site.wss/license.do?filename=pc_servers/26r0663.exe)에서 BIOS 업데이트를 다운로드합니다.

  4. 서버에서 BIOS를 업데이트합니다.

중요 BIOS 업데이트 적용에 대한 자세한 내용은 IBM 웹 사이트(http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=DSHY-3TEPF6)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


현재 프로세서 속도가 가능한 최대 속도보다 느립니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 MaxClockSpeed 및 CurrentClockSpeed의 현재 값을 확인할 때 Win32_Processor Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 CurrentClockSpeed의 값이 MaxClockSpeed 값보다 작은 경우 경고를 표시합니다.

CurrentClockSpeed 값은 각 프로세서의 현재 속도(MHz)입니다. MaxClockSpeed는 각 프로세서의 최대 속도(MHz)입니다. 이 경고 메시지가 표시되면 Exchange 서버에 있는 하나 이상의 프로세서가 최대 속도로 작동하지 않는 것입니다. 여기에 대해 알려진 몇 가지 이유는 다음과 같습니다.

  1. Exchange Server가 Windows 2000 Server 서비스 팩 3 이상이 설치되지 않은 Microsoft Windows® 2000 Server 또는 Windows 2000 Advanced Server를 실행하는 컴퓨터에 설치되어 있습니다. Windows 2000 Server 서비스 팩 3에서는 WMI가 MaxClockSpeed 또는 CurrentClockSpeed에 대한 올바른 값을 반환하지 않은 문제를 수정했습니다.

  2. Exchange 서버의 BIOS에서 절전 설정이 잘못 되면 프로세서가 절전 모드에서 느리게 실행될 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange 서버가 Windows 2000 Server 서비스 팩 3 이상이 설치되지 않은 Windows 2000 Server 또는 Windows 2000 Advanced Server를 실행하는 컴퓨터에 설치되어 있는 경우에는 최신 서비스 팩을 설치해야 합니다. 최신 Windows 2000 서비스 팩에 대한 자세한 내용은 Microsoft Windows 2000 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=18353)를 참조하십시오.

  2. Exchange 서버가 Windows 2000 Server 서비스 팩 3 이상 버전이 설치된 Windows 2000 Server 또는 Windows 2000 Advanced Server를 실행하는 컴퓨터에 설치되어 있으면 Exchange 서버의 BIOS 설정을 확인합니다. 또한 BIOS 및 제어판이나 장치 관리자에서 전원 관리 설정도 확인해야 합니다.

시스템 BIOS, 프로세서 및 전원 관리 설정을 검토하고 구성하는 방법에 대한 내용은 하드웨어 제조업체에 문의하십시오.

Windows 2000 Server의 전원 관리 기능에 대한 자세한 내용은 Microsoft 기술 자료 문서 244806, "Overview of Power Management in Windows 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=244806)을 참조하십시오.

Microsoft Windows Server™ 2003의 전원 관리 기능에 대한 자세한 내용은 Windows Server 2003을 실행하는 컴퓨터의 시작 메뉴에서 실행할 수 있는 Windows Server 2003 도움말 및 지원 센터에서 "전원 관리" 및 "전원 옵션"을 검색하십시오.

Windows 2000 Server의 전원 관리 기능에 대한 자세한 내용은 Windows 2000 Server를 실행하는 컴퓨터의 시작 메뉴에서 실행할 수 있는 Windows 2000 Server 도움말에서 "전원 관리" 및 "전원 옵션" 항목을 참조하십시오.


Windows Server 2003에서 DisableDHCPMediaSense가 잘못 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2006-10-02

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Media Sense Detection이 올바르게 설정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

또한 Exchange Server Analyzer는 다음 레지스트리 항목을 조사하여 대상 컴퓨터에서 실행 중인 Windows 버전을 확인합니다.

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 4.0은 해당 컴퓨터가 Microsoft Windows NT® Server 4.0을 실행하고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터에 Windows® 2000 Server 운영 체제가 실행되고 있음을 나타내고, 값 5.2는 해당 컴퓨터에 Windows Server™ 2003 운영 체제가 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 Microsoft Windows 클러스터 서비스 ClusSvc에 대한 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다. True 값은 Windows Cluster Service가 실행되고 있음을 나타내고 False 값은 실행되지 않음을 나타냅니다.

Exchange Server Analyzer는 Windows 클러스터 서비스가 Windows Server 2003 Enterprise Edition이나 Windows Server 2003 Datacenter Edition에서 실행 중이고 DisableDHCPMediaSense 레지스트리 키 값이 1로 설정되어 있으면 경고를 표시합니다.

Windows Server 2003 클러스터 서비스를 사용할 때 네트워크 연결이 끊어져도 Windows 2000 Server에서처럼 기본적으로 TCP/IP 스택이 언로드되지 않습니다. 따라서 더 이상 DisableDHCPMediaSense 레지스트리 키를 설정할 필요가 없습니다. Windows 2000 Server에서는 네트워크 연결이 끊어지면 TCP/IP 스택이 언로드되었습니다. 따라서 Exchange 가상 서버의 리소스를 포함하여 IP 주소에 종속적인 모든 클러스터 리소스가 오프라인 상태가 되었습니다. 네트워크가 온라인으로 복구되면 해당 네트워크 역할도 기본 설정(클라이언트 및 전용)으로 되돌려집니다. 기본적으로 Media Sense를 사용할 수 없게 설정한다는 것은 모든 IP 종속 리소스를 계속 온라인 상태로 유지할 뿐만 아니라 네트워크 역할도 그대로 유지한다는 것을 의미합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행하십시오.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. 오른쪽 창에서 마우스 오른쪽 단추로 클릭하여 DisableDHCPMediaSense 레지스트리 값을 사용하지 않도록 0으로 설정하거나 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 모든 클러스터 리소스를 다른 노드로 이동하거나 오프라인 상태로 만듭니다. 그런 다음 클러스터 노드를 다시 시작하여 변경 내용을 적용합니다.

  6. 이 경고가 생성된 클러스터의 다른 모든 노드에서도 이러한 과정을 반복합니다.

Microsoft Windows 레지스트리에 대한 자세한 내용은 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)을 참조하십시오.

Media Sense Detection과 Windows 클러스터에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 254651, "Cluster network role changes automatically"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651)

  • 239924, "Windows에서 TCP/IP에 대한 미디어 감지를 해제하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924)

  • 242430, "Network Adapter Not Available During Cluster Configuration with a Crossover Cable"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430)

  • 278007, "Windows Server 2003 클러스터에서 사용할 수 있는 기능"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=278007)


DisableDHCPMediaSense가 Windows 2000 Server에서 잘못 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 미디어 감지 검색이 제대로 구성되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

또한 Exchange Server Analyzer는 다음 레지스트리 항목을 검사하여 대상 컴퓨터에서 실행 중인 Windows 버전을 확인합니다.

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 4.0은 해당 컴퓨터가 Microsoft Windows NT® 4.0을 실행하고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터에 Microsoft Windows 2000 Server 운영 체제가 실행되고 있음을 나타내고 값 5.2는 해당 컴퓨터에 Microsoft Windows Server™ 2003 운영 체제가 실행되고 있음을 나타냅니다.

뿐만 아니라 Exchange Server Analyzer는 Win32_Service Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리하여 Microsoft Windows 클러스터 서비스 ClusSvc에 대한 Started 키 값을 확인합니다. True 값은 Windows Cluster Service가 실행되고 있음을 나타내고 False 값은 실행되지 않음을 나타냅니다.

Windows 클러스터 서비스가 Windows 2000 Advanced Server 또는 Windows 2000 Datacenter Server에서 실행 중이고 DisableDHCPMediaSense 레지스트리 키가 있지만 1로 설정되어 있지 않으면 Exchange Server Analyzer에서 경고를 표시합니다.

Windows 2000 Server 클러스터 서비스를 사용할 때 네트워크 연결이 끊어지면 TCP/IP 스택의 로드가 해제됩니다. 이는 Exchange Virtual Server를 포함해 IP 주소에 종속된 모든 클러스터 리소스가 오프라인으로 설정됨을 의미합니다. 네트워크가 온라인으로 복구되면 해당 네트워크 역할도 기본 설정(클라이언트 및 전용)으로 되돌려집니다. 이와 같은 문제가 발생하지 않도록 하려면 모든 Windows 2000 Server 기반 클러스터에서 미디어 감지 검색을 비활성화하는 것이 좋습니다. Windows Server 2003 기반 클러스터에서 미디어 감지 검색은 자동으로 비활성화되어 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Parameters를 마우스 오른쪽 단추로 클릭한 다음 새로 만들기 | DWORD 값을 클릭합니다. 이름으로 DisableDHCPMediaSense를 입력하고 Enter를 누릅니다.

  4. 오른쪽 창에서 DisableDHCPMediaSense를 두 번 클릭하고 값 데이터로 1을 입력합니다.

  5. 레지스트리 편집기를 닫습니다.

  6. 모든 클러스터 리소스를 다른 노드로 이동하거나 오프라인으로 설정합니다. 그런 다음 클러스터 노드를 다시 시작하여 변경 내용을 적용합니다.

  7. 이 경고가 발생한 클러스터의 모든 노드에 대해 이 과정을 반복합니다.

Microsoft Windows 레지스트리에 대한 자세한 내용은 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)을 참조하십시오.

미디어 감지 검색과 Windows 클러스터에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 254651, "Cluster network role changes automatically"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651)

  • 239924, "Windows에서 TCP/IP에 대한 미디어 감지를 해제하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924)

  • 242430, "Network Adapter Not Available During Cluster Configuration with a Crossover Cable"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430)

  • 278007, "Windows Server 2003 클러스터에서 사용할 수 있는 기능"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=278007)


디스크 시간 초과가 기본값으로 설정되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 디스크 시간 초과 값이 기본값에서 변경되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Disk\TimeOutValue

Exchange Server Analyzer는 TimeOutValue가 존재하고 10 이외의 값으로 구성되어 있으며 서버가 클러스터되지 않은 경우 기본 구성이 아니라는 메시지를 표시합니다. Exchange Server Analyzer는 TimeOutValue가 존재하고 20 이외의 값으로 구성되어 있으며 서버가 클러스터된 경우에도 기본 구성이 아니라는 메시지를 표시합니다.

디스크 시간 초과는 Microsoft Windows®에서 명령에 대한 하드 디스크 응답을 기다리는 시간을 정의하는 레지스트리 설정입니다. 클러스터되지 않은 시스템에서는 이 키는 없으며 모든 디스크에 기본값 10초가 사용됩니다. Windows 클러스터에서는 이 키가 존재하며 기본값 20초가 사용됩니다. 시간 초과 시간이 이 레지스트리 설정의 값보다 크면 Windows에서는 오류를 표시하고 디스크 액세스를 중지합니다. 다중 경로 디스크 액세스 소프트웨어를 실행할 경우 이 값이 더 큰 값으로 설정될 수도 있습니다. 다중 경로 소프트웨어를 사용하면 중복성을 제공하기 위해 여러 개의 실제 경로(예: 파이버)를 단일 디스크 드라이브에 연결할 수 있습니다. 다중 경로 소프트웨어가 여러 개의 실제 연결을 관리해주므로 Windows에서는 디스크에 대한 단일 핸들만 처리하면 됩니다.

HBA(호스트 버스 어댑터)나 다른 저장소 컨트롤러를 설치하면 이 키가 생성 및 구성될 수 있습니다. 이러한 드라이버를 설치하거나 다시 설치하면 해당 드라이버에서 요구하는 값으로 TimeOutValue 레지스트리 값이 덮어쓰여집니다. 하드웨어 제조업체에 문의하여 구성에 적절한 TimeOutValue 레지스트리 값을 확인해야 할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음을 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\Disk\TimeOutValue

  3. 오른쪽 창에서 TimeOutValue 항목을 삭제합니다. 또는 TimeOutValue 항목을 두 번 클릭한 후 다음 값 중 하나로 설정합니다.

    • 클러스터되지 않은 서버에서는 이 값을 10으로 설정합니다.

    • 클러스터된 서버에서는 이 값을 20으로 설정합니다.

    • 하드웨어 제조업체에서 클러스터된 시스템이나 클러스터되지 않은 시스템에 대해 다른 값을 지정하도록 권장하면 해당 값을 사용합니다.

  4. 레지스트리 편집기를 닫고 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

클러스터된 시스템에서의 TimeOutValue 항목에 대한 자세한 내용은 Microsoft 기술 자료 문서 818877, "Cluster Servers May Experience Connection Timeouts to Drives After You Install or Upgrade to the Windows Clustering Feature in Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=818877)을 참조하십시오.


DNS 찾는 순서가 비어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 DNSServerSearchOrder 키 값 설정 여부를 확인할 때 Win32_NetworkAdapterConfiguration Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange 서버에서 이 키 값이 비어 있으면 경고를 표시합니다.

이 경고는 이 컴퓨터의 네트워크 어댑터 중 하나 이상에 연결된 DNS IP 주소가 없음을 나타냅니다. 따라서 이 컴퓨터가 다른 컴퓨터에 연결을 시도할 때 IP 주소를 확인하려면 로컬 네트워크 상에서 브로드캐스트합니다. 이 때문에 이름 확인 속도가 느려지므로 Exchange 수행 속도도 느려집니다.

적어도 하나의 유효한 DNS 서버의 IP 주소를 입력하는 것이 좋습니다. 컴퓨터에 둘 이상의 어댑터가 있으면 모든 어댑터에 적어도 하나의 유효한 DNS 서버 IP 주소가 설정되어 있는지 확인합니다.

네트워크 어댑터에 DNS IP 주소를 설정하려면 다음을 수행합니다.

  1. 네트워크 연결에서 해당 로컬 영역 네트워크 어댑터를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 인터넷 프로토콜(TCP/IP)을 클릭합니다.

  3. 인터넷 프로토콜(TCP/IP) 페이지의 일반 탭에서 적어도 하나의 유효한 DNS 서버의 IP 주소를 입력한 다음 확인을 클릭합니다.

Exchange에서 동작하도록 DNS를 구성하는 방법은 Microsoft 기술 자료 문서 322856, "HOWTO: Exchange Server 사용을 위한 DNS 구성"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322856)을 참조하십시오.


하트비트 연결에 기본 게이트웨이가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 NetConnectionID 키 값을 확인할 때 Win32_NetworkAdapter Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. NetConnectionID 키 값에 Internal 또는 HEART 문자열이 포함되어 있으면 이는 인터페이스가 클러스터 개인(하트비트) 네트워크임을 나타냅니다.

또한 Exchange Server Analyzer는 DefaultIPGateway 키 값이 설정되어 있는지 알아보기 위해 Win32_NetworkAdapterConfiguration WMI 클래스를 쿼리합니다. 값이 설정되어 있으면 이 네트워크 인터페이스의 기본 게이트웨이가 구성되어 있는 것입니다.

Exchange Server Analyzer가 네트워크 인터페이스에서 클러스터 하트비트 네트워크에 사용되는 DefaultIPGateway 키 값을 찾으면 경고가 표시됩니다.

개인 클러스터 네트워크는 내부 클러스터 통신에 사용되기 때문에 기본 게이트웨이를 구성하지 않아도 됩니다. 통신 문제의 가능성을 제거하려면 클러스터 개인 네트워크 어댑터로 사용되는 네트워크 어댑터에서 필요하지 않은 네트워크 소통량을 모두 제거하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 네트워크 연결 창을 엽니다. 내 네트워크 환경을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하거나 바탕 화면에 네트워크 환경이 표시되어 있지 않을 경우 시작, 프로그램, 보조프로그램, 통신을 차례로 클릭한 다음 네트워크 연결을 클릭합니다.

  2. 네트워크 연결 창에서 개인 네트워크에 사용되는 네트워크 어댑터를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 인터넷 프로토콜(TCP/IP)을 선택한 다음 속성을 클릭합니다.

  4. 다음 IP 주소 사용 영역에서 기본 게이트웨이 IP 주소를 삭제합니다.

  5. 변경 내용을 저장하려면 확인을 두 번 클릭합니다.

  6. 클러스터의 각 노드에 대해 1단계-5단계를 반복합니다.

Windows 서버 클러스터의 개인 네트워크 관련 권장 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 258750, "클러스터 서버에 권장하는 개인 "하트비트" 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)을 참조하십시오.


하트비트 연결에 DNS 검색 주소가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 NetConnectionID 키 값을 확인할 때 Win32_NetworkAdapter Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. NetConnectionID 키 값에 Internal 또는 HEART 문자열이 포함되어 있으면 이는 인터페이스가 클러스터 개인(하트비트) 네트워크임을 나타냅니다.

Exchange Server Analyzer는 DNSServerSearchOrder 키 값이 설정되어 있는지 확인하기 위해 Win32_NetworkAdapterConfiguration WMI 클래스를 쿼리합니다. 값이 설정되어 있으면 이 네트워크 인터페이스에 대해 DNS(Domain Name System) 검색 주소가 구성되어 있는 것입니다.

Exchange Server Analyzer가 클러스터 하트비트 네트워크에 사용되는 네트워크 인터페이스에서 DNSServerSearchOrder 키 값이 설정되어 있으면 경고를 표시합니다.

개인 클러스터 네트워크는 내부 클러스터 통신에 사용되기 때문에 DNS 서버를 구성할 필요가 없습니다. 통신 문제의 가능성을 제거하려면 클러스터 개인 네트워크 어댑터로 사용되는 네트워크 어댑터에서 필요하지 않은 네트워크 소통량을 모두 제거하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 네트워크 연결 창을 엽니다. 내 네트워크 환경을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하거나 바탕 화면에 네트워크 환경이 표시되어 있지 않을 경우 시작, 프로그램, 보조프로그램, 통신을 차례로 클릭한 다음 네트워크 연결을 클릭합니다.

  2. 네트워크 연결 창에서 개인 네트워크에 사용되는 네트워크 어댑터를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 인터넷 프로토콜(TCP/IP)을 선택한 다음 속성을 클릭합니다.

  4. 고급을 클릭합니다.

  5. DNS 탭에서 DNS 서버 주소를 선택한 다음 제거를 클릭합니다. 목록에 나열된 각각의 DNS 서버 주소에 대해 이 단계를 반복합니다.

  6. DNS에 이 연결의 주소를 등록 확인란과 DNS 등록에 이 연결의 DNS 접미사 사용 확인란의 선택을 해제합니다.

  7. 확인을 세 번 클릭하여 변경 내용을 저장합니다.

  8. 클러스터의 각 노드에 대해 1-7단계를 반복합니다.

Windows 서버 클러스터의 개인 네트워크 관련 권장 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 258750, "클러스터 서버에 권장하는 개인 "하트비트" 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)을 참조하십시오.


하트비트 연결에 WINS 주소가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 NetConnectionID 키 값을 확인할 때 Win32_NetworkAdapter Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. NetConnectionID 키 값에 Internal 또는 HEART 문자열이 포함되어 있으면 인터페이스가 클러스터 개인(하트비트) 네트워크인 것입니다.

또한 Exchange Server Analyzer는 WINSPrimaryServer 키 값의 설정 여부를 확인할 때도 Win32_NetworkAdapterConfiguration WMI 클래스를 쿼리합니다. 이 값이 설정되어 있으면 해당 네트워크 인터페이스에 대해 주 WINS(Windows Internet Name Service) 주소가 구성되어 있는 것입니다.

Exchange Server Analyzer는 클러스터 하트비트 네트워크에 사용되는 네트워크 인터페이스에 대해 WINSPrimaryServer 키 값이 설정되어 있을 경우 경고를 표시합니다.

내부 클러스터 통신에 개인 클러스터 네트워크가 사용되므로 WINS 서버를 구성하거나 NetBIOS를 사용할 필요가 없습니다. 통신 문제의 가능성을 제거하려면 클러스터 개인 네트워크 어댑터로 사용되는 네트워크 어댑터에서 필요하지 않은 네트워크 소통량을 모두 제거하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 네트워크 연결 창을 엽니다. 내 네트워크 환경을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하거나 바탕 화면에 네트워크 환경이 표시되어 있지 않을 경우 시작, 프로그램, 보조프로그램, 통신을 차례로 클릭한 다음 네트워크 연결을 클릭합니다.

  2. 네트워크 연결 창에서 개인 네트워크에 사용되는 네트워크 어댑터를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  3. 인터넷 프로토콜(TCP/IP)을 선택한 다음 속성을 클릭합니다.

  4. 고급을 클릭합니다.

  5. WINS 탭에서 WINS 주소를 선택하고 제거를 클릭합니다. 나열된 각 WINS 주소에 대해 이 단계를 반복합니다.

  6. NetBIOS 설정 영역에서 NetBIOS over TCP/IP 사용 안 함을 선택합니다.

  7. 확인을 세 번 클릭하여 변경 내용을 저장합니다. 첫 번째 확인을 클릭하면 다음 메시지가 표시될 수 있습니다. 이 메시지가 표시되면 예를 클릭합니다. "현재 연결의 기본 WINS 주소가 비어 있습니다. 계속하시겠습니까?"

  8. 클러스터의 각 노드에 대해 1-7단계를 반복합니다.

Windows 서버 클러스터의 개인 네트워크 관련 권장 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 258750, "클러스터 서버에 권장하는 개인 "하트비트" 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)을 참조하십시오.


하트비트 연결이 공용 연결이 아닌 TCP/IP 바이딩 순서에 먼저 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음을 수행할 때 두 가지 Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • 클러스터의 모든 네트워크 인터페이스의 SettingID 키 값을 확인할 때 Win32_NetworkConfiguration WMI 클래스를 쿼리합니다. SettingsID 키 값은 고유 네트워크 어댑터를 나타내는 GUID입니다.

  • Exchange 클러스터에서 개인 네트워크 통신에 사용되는 네트워크 어댑터를 확인하기 위해 Win32_NetworkAdapter WMI 클래스를 쿼리합니다. 개인 네트워크는 클러스터는 하트비트를 포함한 내부 클러스터 통신에 사용됩니다.

  • 또한 Exchange Server Analyzer는 네트워크 어댑터 바인딩 순서를 확인할 때 다음 레지스트리 값을 검토합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Linkage\Bind

Bind 레지스트리 값은 바인딩 순서에 포함된 네트워크 어댑터의 목록을 포함하는 다중 문자열 값입니다. 이 목록의 첫 번째 항목은 첫 번째 바운드 네트워크 어댑터이며 두 번째 항목은 바인딩 순서에서 두 번째 네트워크 어댑터가 되는 식으로 나열됩니다.

Exchange Server Analyzer는 클러스터 하트비트 네트워크 어댑터가 바인딩 순서에서 첫 번째로 설정되어 있는 경우 경고를 표시합니다.

이 문제를 해결하려면 공용 네트워크 어댑터가 바인딩 목록의 첫 번째 바인딩이 되도록 합니다. 공용 네트워크 어댑터가 여러 개인 경우 개인 하트비트 네트워크 어댑터가 마지막에 나열되도록 합니다. 하트비트 네트워크 어댑터가 첫 번째로 나열되어 있으면 서비스 팩 및 업그레이드가 올바르게 설치되지 않을 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 네트워크 연결 창에서 고급을 클릭한 다음 고급 설정을 클릭합니다.

  2. 어댑터 및 바인딩 탭을 클릭합니다.

  3. 연결 필드에서 개인 네트워크 어댑터를 선택하고 아래쪽 화살표를 사용하여 개인 네트워크 어댑터를 목록의 맨 아래로 이동합니다.

  4. 클러스터의 각 노드에 대해 이 단계를 반복합니다.

Windows 서버 클러스터의 최적화된 네트워크 구성에 대한 자세한 내용은 "Server Clusters: Network Configuration Best Practices for Windows 2000 and Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=34304)을 참조하십시오.

올바른 클러스터 하트비트 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 258750, "클러스터 서버에 권장하는 개인 "하트비트" 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)을 참조하십시오.


하트비트 네트워크 속도가 auto sense/auto detect로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 NetConnectionID 키 값을 확인할 때 Win32_NetworkAdapter Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. NetConnectionID 키 값에 Internal 또는 HEART 문자열이 포함되어 있으면 해당 인터페이스가 클러스터 개인(하트비트) 네트워크인 것입니다.

뿐만 아니라 Exchange Server Analyzer는 다음 레지스트리 값을 읽어 클러스터 하트비트 네트워크에 사용되고 있는 네트워크 인터페이스의 연결 속도와 전이중 설정을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\<NetworkCardDeviceID>\SpeedDuplex

또한 Exchange Server Analyzer는 다음 레지스트리 값을 읽어 자동 네트워크 속도 검색이 설정되었는지 확인합니다.

HKLM\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\Ndi\Params\SpeedDuplex\enum\0

0 키 값에 문자열 AUTO가 포함되어 있으면 자동 네트워크 속도 검색이 설정된 것입니다.

Exchange Server Analyzer는 클러스터 하트비트 네트워크에 대해 SpeedDuplex가 0으로 설정되어 있고 자동 네트워크 속도 검색이 설정되어 있을 경우 경고를 표시합니다.

서버 클러스터 노드 간의 통신은 원활한 클러스터 작업에 중요합니다. 클러스터 통신을 위해 다중 속도의 이더넷 네트워크 어댑터를 사용하고 네트워크 속도를 자동으로 검색하도록 어댑터를 구성한 경우 클러스터 내에서 어댑터 문제가 발생할 수 있습니다. 검색 프로세스 중에 어댑터에서 패킷을 처리할 수 없어 패킷이 대기됩니다. 일부 어댑터에서는 실수로 자동 검색 프로세스를 반복해서 발생시킬 수 있습니다. 이로 인해 통신이 대기되며 지연됩니다. 이러한 유형의 지연이 발생하면 클러스터 노드에서 중요한 패킷을 즉시 수신하지 못할 수 있으므로 클러스터 리소스의 장애 조치가 미리 발생할 수 있습니다. 따라서 사용자가 직접 클러스터의 하트비트 네트워크를 10Mb 및 반이중으로 설정하는 것이 좋습니다. 이렇게 구성하면 충분한 대역폭이 보장되며 통신의 안정성이 향상됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  • 하트비트 네트워크 인터페이스 카드를 연결 속도 10Mb 및 반이중 설정으로 구성합니다. 각 네트워크 카드의 구성 단계가 다르므로 하드웨어 공급자의 지시에 따라 하트비트 네트워크를 올바르게 구성합니다. 이러한 옵션을 구성하려면 업데이트된 드라이버가 필요할 수 있습니다.

Windows 서버 클러스터의 개인 네트워크 관련 권장 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 258750, "클러스터 서버에 권장하는 개인 "하트비트" 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)을 참조하십시오.


호스트 버스 어댑터 큐 길이가 32로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2006-10-11

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange Server 컴퓨터에 설치된 HBA(호스트 버스 어댑터)의 큐 길이를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\elxstor\Parameters\Device\DriverParameter

Exchange Server Analyzer는 DriverParameter 값이 32로 설정되어 있을 경우 경고를 표시합니다.

HBA는 SAN(Storage Area Networks)을 위한 디스크 컨트롤러입니다. HBA 큐 길이는 처리되지 않은 큐 요청의 최대 수를 정의합니다. 일반적으로 DriverParameter의 권장 값은 128이지만 이 값이 모든 Exchange Server 컴퓨터의 모든 HBA에 대한 HBA 큐 길이 값으로는 적절하지 않을 수 있습니다. 따라서 사용하는 특정 하드웨어에 맞는 최적의 값을 알려면 HBA 제조업체에 문의해야 합니다.

이 경고를 해결하려면 다음을 수행하십시오.

  1. 하드웨어 제조업체에 문의하여 HBA에 대한 최적의 설정을 확인합니다.

  2. Microsoft Windows® System Monitor 유틸리티를 사용하여 디스크 성능을 모니터링합니다.

  3. HBA 하드웨어를 최신 펌웨어 및 드라이버로 업데이트합니다.

Exchange Server 저장소 디자인 및 최적화에 대한 자세한 내용은 "Exchange Server 2003의 저장소 최적화"(http://go.microsoft.com/fwlink/?linkid=49324)를 참조하십시오.


Hot-add 메모리 구성
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2006-02-22

Microsoft® Exchange Server Analyzer Tool은 서버의 hot-add 메모리 기능 지원 여부를 확인할 때 Win32_Computer System Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 또한 Exchange Server Analyzer는 다음을 확인할 때도 Win32_OperatingSystem WMI 클래스를 쿼리합니다.

  • Boot.ini 파일에 /3GB 옵션이 설정되어 있는지 여부

  • PAE(Physical Address Extensions) 커널이 로드되어 있는지 여부

  • 서버에서 실행 중인 운영 체제 버전

마지막으로 Exchange Server Analyzer는 DynamicMemory 구성 매개 변수가 존재하고 올바르게 설정되었는지 확인할 때 다음 레지스트리 항목을 쿼리합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Exchange Server Analyzer는 다음 조건이 모두 해당될 경우 오류를 표시합니다.

  • 컴퓨터가 hot-add 메모리를 지원하고 기본적으로 해당 기능을 사용할 수 있습니다.

  • 컴퓨터가 Microsoft Windows Server™ 2003, Enterprise Edition 또는 Windows Server 2003, Datacenter Edition을 실행하고 있습니다.

  • PAE 커널이 로드되어 있습니다.

  • Boot.ini에 /3GB 옵션이 설정되어 있습니다.

  • DynamicMemory 레지스트리 구성 매개 변수가 설정되어 있지 않거나 값이 0으로 또는 3보다 크게 설정되어 있습니다.

참고:
컴퓨터가 hot-add 메모리를 지원하지만 하드웨어 제조업체가 기본적으로 해당 기능을 사용할 수 없게 설정하는 경우 Exchange Server Analyzer가 오류 메시지 대신 경고 메시지를 표시합니다.

hot-add 메모리 기능은 시스템 관리자가 컴퓨터를 다시 시작할 필요 없이 실제 메모리를 추가할 수 있도록 Windows Server 2003, Enterprise Edition 및 Windows Server 2003, Datacenter Edition에 도입되었습니다. 이 기능은 Microsoft SQL Server와 같은 메모리를 많이 사용하는 관계형 데이터베이스 응용 프로그램을 지원하는 서버에서 유용합니다. 그러나 Exchange Server는 4GB가 넘는 실제 메모리는 사용할 수 없으므로 이 기능은 Exchange Server에 유용하지 않습니다.

모든 컴퓨터가 hot-add 메모리를 지원하지는 않습니다. hot-add 메모리를 지원하는 컴퓨터의 경우 기본적으로 이 기능을 사용할 수 있게 설정하는 하드웨어 제조업체도 있고 기본 입/출력 시스템(BIOS) 내에서 제어하는 하드웨어 제조업체도 있습니다. 부팅하는 동안 hot-add 메모리를 사용할 수 있으면 운영 체제 커널에서 공간을 사전 할당하여 컴퓨터에 추가되는 차후 메모리를 처리해야 합니다. 따라서 커널 리소스는 실제로 설치된 기능 대신 컴퓨터의 기능을 기준으로 할당됩니다. 커널 메모리는 Microsoft Exchange Server를 실행하는 컴퓨터에서 중요한 리소스입니다. 커널에서 설치할 필요가 없는 상당한 양의 리소스를 메모리에 할당할 수 있고 Exchange Server에서 사용하는 실제 메모리의 특성 때문에 hot-add 메모리 기능을 사용할 수 없게 함으로써 추가 성능 및 확장성을 얻을 수 있습니다. 이 기능을 사용할 수 있게 하면 페이징 풀의 최대 크기가 예상보다 낮아질 수 있습니다. 이로 인해 성능이 저하되고, 시스템이 잠기고, 궁극적으로는 서비스가 중지될 수 있습니다.

예상 최대 페이징 풀 크기의 예(클수록 좋음)

  • 240MB hot-add 메모리 지원 기능이 없거나 지원할 수 없는 실제 메모리가 4GB인 컴퓨터

  • 210MB 32GB의 hot-add 메모리를 지원할 수 있는 실제 메모리가 4GB인 컴퓨터

  • 160MB 최대 64GB의 hot-add 메모리를 지원할 수 있는 실제 메모리가 4GB인 컴퓨터

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
Windows Server 2003 Service Pack 1(SP1) 이상을 실행하는 컴퓨터에서 이 문제를 해결하려면 다음을 수행합니다.

  1. 다음 레지스트리 매개 변수가 hot-add 메모리 기능을 사용하지 않도록 설정합니다.

    경로

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    값

    DynamicMemory

    종류

    REG_DWORD

    데이터

    0x1
    참고:
    부팅 시에 설치된 실제 메모리가 크지 않은 경우 이 구성 매개 변수의 값이 hot-add 메모리를 포함하여 지정 가능한 최대 실제 메모리(기가바이트)로 표시됩니다. 값을 1로 설정하여 커널에서 총 1GB의 시스템 메모리에 대한 공간이나 부팅 시에 설치된 실제 메모리의 총 공간 중 큰 쪽을 예약합니다.

  2. 컴퓨터를 다시 시작합니다.
SP1이 설치되지 않은 Windows Server 2003을 실행하는 컴퓨터에서 이 문제를 해결하려면 다음을 수행합니다.

  • 하드웨어 공급업체에 문의하여 hot-add 메모리 기능을 BIOS에서 사용할 수 없게 설정할 수 있는지 확인하십시오.

  • 하드웨어를 통해 hot-add 메모리를 제어할 수 없으면 Windows Server 2003 SP1로 업그레이드하고 여기에 나와 있는 확인 단계를 수행하여 DynamicMemory 매개 변수를 구현하는 방법을 사용하는 것이 좋습니다. SP1로 업그레이드할 수 없는 경우 대신 Boot.ini 파일에 /NOPAE 옵션을 설정하는 방법을 사용할 수 있습니다. 이 옵션을 설정하면 컴퓨터가 4GB보다 큰 메모리는 인식하지 않게 합니다. Windows Server 2003 SP1 이전 버전을 실행하는 컴퓨터에서는 이 옵션을 사용할 수 있으나 SP1을 실행하는 컴퓨터에서는 DEP(데이터 실행 방지)와 같은 새 기능을 실수로 사용할 수 없게 만들 수 있으므로 이 옵션을 사용하지 않아야 합니다.

자세한 정보

Windows Server 2003에서 hot-add 메모리 지원에 대한 자세한 내용은 Hot-Add Memory Support in Windows Server 2003(http://go.microsoft.com/fwlink/?linkid=57183)을 참조하십시오.


Internet SCSI Initiator 소프트웨어가 이전 버전입니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2006-04-03

Microsoft® Exchange Server Analyzer Tool은 Win32_SCSIController Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 iScsciPrt 드라이버의 DriverName 키 값을 확인합니다. 또한 Exchange Server Analyzer는 CIM_Datafile WMI 클래스를 쿼리하여 iScsciPrt 드라이버 파일에 표시된 Version 키 값을 확인합니다. iScsciPrt 드라이버 Version 키에 1748보다 작은 부분 문자열 값이 있으면 Exchange Server Analyzer는 경고를 표시합니다.

iSCSI(Internet Small Computer System Interface)는 IP 패킷에 캡슐화된 SCSI(Small Computer Systems Interface) 명령을 TCP/IP 네트워크를 통해 보내도록 고안된 IP(인터넷 프로토콜) 기반 방법입니다. iSCSI는 IP 기반이므로 데이터가 LAN(Local Area Network), WAN(Wide Area Network) 및 인터넷을 통해 원격 저장 위치로 전송될 수 있습니다. Microsoft Windows 운영 체제에서는 Exchange Server 2003 또는 Exchange 2000 Server 같은 프로그램에 iSCSI 하드 디스크를 Exchange Server 컴퓨터에 직접 연결된 하드 디스크로 표시합니다.

iSCSI를 포함하는 Exchange Server 2003 또는 iSCSI를 포함하는 Exchange 2000 Server를 배포할 때는 주의해야 합니다. iSCSI는 SCSI 전송 프로토콜을 사용하여 TCP/IP 네트워크를 통해 데이터 블록 데이터를 전송하므로 일반적으로 고속의 입출력 경로로 인식되지 않는 구성 요소가 사용될 수 있습니다. 처리량을 최대화하려면 캐싱 작업을 최대화하도록 Exchange Server를 구성하고 테스트를 수행하여 iSCSI 트래픽에 따른 대기 시간을 최소화할 수 있도록 해야 합니다. 사용 중인 저장소 공급업체가 표시되지 않은 경우에는 사용 가능한 Microsoft iSCSI Software Initiator의 최신 빌드를 사용하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Microsoft 다운로드 센터(http://go.microsoft.com/fwlink/?LinkId=33817)에서 최신 버전의 Microsoft iSCSI Software Initiator를 다운로드합니다.

  2. Microsoft 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=40951)에서 릴리스 정보를 검토하십시오.

  3. Microsoft 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=40963)에서 사용자 안내서를 검토하십시오.

  4. 컴퓨터를 전체 백업합니다.

  5. 최신 버전 업데이트를 적용합니다.

Exchange 2000 Server 및 Exchange Server 2003의 iSCSI 지원에 대한 자세한 내용은 Microsoft 기술 자료 문서 839686, "Support for iSCSI technology components in Exchange Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839686)를 참조하십시오.

iSCSI 기술 및 Microsoft의 iSCSI 지원에 대한 자세한 내용은 Microsoft 웹 사이트, "Microsoft Storage Technologies - iSCSI"(http://go.microsoft.com/fwlink/?LinkId=27514)를 참조하십시오.


논리 및 실제 디스크 성능 카운터가 비활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 논리 및 실제 디스크 성능 카운터가 비활성화되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance\Disable Performance Counters

Exchange Server Analyzer는 Disable Performance Counters 값이 존재하고 값 1로 구성되어 있을 경우 경고를 표시합니다.

Microsoft Windows® 운영 체제를 실행하는 서버 컴퓨터에는 다음과 같은 두 가지 유형의 디스크 관련 성능 카운터가 게시됩니다.

  • Microsoft Win32® 성능 하위 시스템 및 WMI(Windows Management Instrumentation)에서 사용됩니다.

  • IOCTL_DISK_PERFORMANCE API를 호출하여 원시 카운터 정보를 검색하는 레거시 응용 프로그램에서 사용됩니다.

  • Win32 및 WMI에서 사용되는 성능 카운터는 Microsoft Windows Server™ 2003 및 Windows 2000 Server에서 기본적으로 활성화되어 있습니다. 또한 두 시스템에서 원시 카운터는 기본적으로 비활성화되어 있습니다. 이러한 운영 체제에 기본적으로 존재하지 않는 Disable Performance Counters 레지스트리 값이 추가된 후 값 1이 지정되면 Win32/WMI 성능 카운터가 비활성화되고 해당 카운터의 성능 데이터를 수집할 수 없습니다.

카운터를 비활성화하는 가장 일반적인 방법은 확장 카운터 목록 도구(ExCtrLst.exe)를 사용하는 것입니다. Windows 2000 Server 및 Windows Server 2003 Resource Kits에 제공되는 이 그래픽 도구를 사용하여 관리자는 성능 개체의 게시를 선택적으로 비활성화할 수 있습니다. ExCtrLst.exe를 사용하여 성능 개체를 비활성화하면 레지스트리에 Disable Performance Counters 항목이 추가된 후 값 1이 지정됩니다. 그런 후 ExCtrLst.exe를 사용하여 비활성화된 카운터를 다시 활성화하면 Disable Performance Counters 값이 0으로 변경됩니다. 즉 Disable Performance Counters 항목이 삭제되지는 않습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance를 탐색합니다.

  3. 오른쪽 창에서 Disable Performance Counters를 두 번 클릭하고 값을 0으로 설정합니다. Disable Performance Counters 항목을 삭제하여 카운터를 다시 활성화할 수도 있습니다.

  4. 레지스트리 편집기를 종료하고 성능 데이터를 수집하는 응용 프로그램을 다시 시작하여 변경 내용을 적용합니다.

Exctrlst.exe에 대한 자세한 내용은 "Exctrlst.exe: Extensible Performance Counter List"(http://go.microsoft.com/fwlink/?linkid=34436)를 참조하십시오.


여러 개의 기본 게이트웨이가 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 DefaultIPGateway 키의 인스턴스 수를 확인할 때 Win32_NetworkAdapterConfiguration Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 각 네트워크 어댑터는 구성된 기본 게이트웨이 주소를 이 키를 통해 WMI에 게시합니다. Exchange Server Analyzer는 DefaultIPGateway 키의 구성된 인스턴스가 두 개 이상 있을 경우 경고를 표시합니다.

이 경고는 여러 개의 네트워크 어댑터가 있으며 해당 어댑터 중 두 개 이상이 구성된 기본 게이트웨이를 갖고 있음을 나타냅니다. 여러 개의 어댑터가 사용되며 별도의 기본 게이트웨이로 구성되어 있을 경우 원격 네트워크상의 컴퓨터에 대한 연결이 끊어질 수 있습니다. 또한 다른 네트워크 서브넷으로 연결되는 여러 개의 기본 게이트웨이를 사용하면 DNS(Domain Name System) 확인, SMTP(Simple Message Transfer Protocol) 메시지 배달, LDAP(Lightweight Directory Access Protocol) 쿼리 및 Microsoft Office Outlook® 클라이언트에 대한 새 메일 알림과 관련된 문제가 발생할 수 있습니다. 이러한 문제점으로 인해 Exchange Server가 시작되지 못하거나 메시지를 주고받지 못할 수 있습니다.

Exchange Server 컴퓨터의 네트워크 인터페이스 어댑터 중 하나에서 기본 게이트웨이를 제외한 모든 게이트웨이를 제거하는 것이 좋습니다. Microsoft ISA(Internet Security and Acceleration) Server가 동일한 컴퓨터에 설치되어 있을 경우 Exchange Server 컴퓨터는 멀티홈 컴퓨터가 됩니다. Exchange Server와 ISA Server를 동일한 컴퓨터에서 실행할 경우에도 여러 개의 기본 게이트웨이를 사용하는 것은 권장되지 않습니다. Exchange Server와 ISA Server가 동일한 컴퓨터에 설치되어 있지 않을 경우에는 Exchange Server 컴퓨터를 멀티홈 컴퓨터로 사용하지 않는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 네트워크 연결 창을 엽니다. 네트워크 환경을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하거나 바탕 화면에 네트워크 환경이 표시되어 있지 않을 경우 시작, 프로그램, 보조프로그램, 통신을 차례로 클릭한 다음 네트워크 연결을 클릭합니다.

  2. 네트워크 연결 창에서 제거할 기본 게이트웨이 항목을 포함하는 네트워크 연결을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  3. 인터넷 프로토콜(TCP/IP)을 선택한 다음 속성을 클릭합니다.

  4. 기본 게이트웨이 필드에서 IP 주소를 삭제합니다.

  5. 확인을 차례로 두 번 클릭하여 변경 내용을 저장합니다.

  6. 제거하지 않을 게이트웨이 항목을 제외한 기본 게이트웨이 항목을 포함하는 다른 모든 네트워크 연결에 대해 이 단계를 반복합니다.

여러 개의 기본 게이트웨이를 사용하는 컴퓨터에서 발생하는 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 159168, "기본 게이트웨이를 여러 개 사용하면 연결 문제가 발생할 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159168)를 참조하십시오.

멀티홈 컴퓨터의 기본 게이트웨이 구성에 대한 자세한 내용은 기술 자료 문서 157025, "다중 홈 컴퓨터의 기본 게이트웨이 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=157025)을 참조하십시오.


페이지 파일 크기가 총 실제 메모리보다 큽니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2007-07-30

Microsoft Exchange Analyzer Tool은 Win32_PageFile WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 MaximumSize 키 값을 확인합니다. 이 키는 현재 구성되어 있는 최대 페이지 파일 크기를 나타냅니다.

또한 Exchange Analyzer는 Win32_ComputerSystem WMI 클래스를 쿼리하여 TotalPhysicalMemory 키 값을 확인합니다. 이 값은 컴퓨터의 RAM 양을 나타냅니다.

Exchange Analyzer는 Win32_PageFile MaximumSize 키 값이 Win32_ComputerSystem TotalPhysicalMemory 키 값보다 1.5배 크면 오류를 표시합니다.

페이지 파일(pagefile.sys)은 시스템의 RAM이 부족한 경우 Windows에서 임시 데이터를 보관하는 데 사용하는 하드 디스크의 숨김 파일입니다. 페이지 파일은 페이징 파일 또는 스왑 파일이라고도 합니다. 페이지 파일과 RAM이 가상 메모리를 구성합니다.

권장되는 페이지 파일 크기는 RAM의 1.05배로, 최대 4,095MB입니다. 즉, 설정 가능한 볼륨당 최대 페이징 파일 크기는 4,095MB입니다.

참고:
페이지 파일 조각을 방지하려면 페이징 파일 크기의 처음 및 최대값을 동일한 값으로 설정하는 것이 좋습니다. 처음 또는 최대 페이지 파일 설정 크기를 줄일 경우에는 컴퓨터를 다시 시작해야 변경 내용이 적용됩니다. 크기를 늘릴 경우에는 대개 다시 시작할 필요가 없습니다.
페이지 파일 설정을 변경하려면 다음을 수행합니다.

  1. 시작, 제어판, 시스템을 차례로 클릭합니다.

  2. 고급 탭의 성능에서 설정을 클릭합니다.

  3. 성능 옵션 대화 상자의 고급 탭에서 가상 메모리 아래에 있는 변경을 클릭합니다.

  4. 드라이브[볼륨 레이블]에서 변경할 페이징 파일이 있는 드라이브를 클릭합니다.

  5. 선택한 드라이브의 페이징 파일 크기에서 사용자 지정 크기를 클릭하고 처음 크기(MB) 및 최대 크기(MB) 필드에 권장되는 페이지 파일 크기(MB)를 입력하고 설정을 클릭합니다.

페이지 파일에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 197379, "Windows Server 2003, Windows 2000 및 Windows NT에서 최적화와 복구를 위한 페이지 파일 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)

  • 307973, "Windows에서 시스템 오류 및 복구 옵션을 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307973)

  • 254649, "Windows Server 2003, Windows XP 및 Windows 2000의 메모리 덤프 파일 옵션에 대한 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=254649)

  • 241046, "RAM이 4GB보다 큰 컴퓨터에서 Memory.dmp 파일을 만들 수 없다.(Cannot Create a Memory.dmp File on Computers with over 4 GB RAM)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=241046)


보조 WINS 서버 주소가 비어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 WINSSecondaryServer 키 값 설정 여부를 확인할 때 Win32_NetworkAdapterConfiguration Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange 서버에서 이 키 값이 비어 있으면 경고를 표시합니다.

Exchange Server 2003 및 Exchange 2000 Server에는 몇 가지 NetBIOS 종속성이 있습니다. 또한 Microsoft Office Outlook 2003 이전 버전의 Microsoft Outlook®을 실행하는 클라이언트도 NetBIOS 이름 확인이 필요합니다. 예를 들어 다음 Exchange 기능은 NetBIOS 이름 확인에 따라 달라집니다.

  • Exchange Server 2003 및 Exchange 2000 Server 설치 프로그램(특히 클러스터된 서버)

  • Exchange Server 2003 또는 Exchange 2000 Server 컴퓨터의 Exchange 사서함 병합 마법사(ExMerge)

  • Outlook Web Access를 통해 Exchange Server 2003 또는 Exchange 2000 Server 사서함 암호를 변경하는 기능

  • Exchange Server 2003 또는 Exchange 2000 Server 컴퓨터의 Exchange System Manager

조직의 네트워크 토폴로지에 따라 이 경고를 무시해도 될 수 있습니다. 단일 서브넷으로 이루어진 네트워크의 경우 NetBIOS 브로드캐스트는 일반적으로 Exchange 배포에 필요한 NetBIOS 이름 확인 사항을 처리합니다.

대규모 조직의 경우 브로드캐스트를 통한 NetBIOS 이름 확인이 제대로 동작하지 않을 수 있습니다. 일반적으로 NetBIOS 브로드캐스트는 서브넷 간에는 수행되지 않으므로 라우팅된 네트워크에서는 NetBIOS 이름 확인을 위한 대안이 필요합니다. 이에 대한 대안으로 WINS(Windows Internet Name Service)가 선호됩니다. WINS는 네트워크에 사용되는 컴퓨터 및 그룹에 대한 NetBIOS 이름의 동적 매핑을 등록 및 쿼리하기 위한 분산 데이터베이스를 제공합니다. WINS는 NetBIOS 이름을 IP 주소에 매핑하며 라우팅된 환경에서 NetBIOS 이름 확인으로 인해 발생하는 문제를 해결하도록 설계되었습니다. WINS는 TCP/IP에서 NetBIOS를 사용하는 라우팅된 네트워크에서 NetBIOS 이름 확인에 대한 최선책이라 할 수 있습니다.

WINS 기능이 없는 대규모 또는 서브넷 설정 조직에서의 Exchange Server 2003 및 Exchange 2000 Server 운영과 작동은 완전한 검증을 거치지 않았습니다. 라우팅되거나 세그먼트화된 네트워크에서 Exchange를 실행하는 기업은 NetBIOS 이름 확인을 위한 WINS를 사용해야 합니다. 라우팅되거나 세그먼트화된 환경에서는 WINS 없이 Exchange를 실행할 수 없습니다.

적어도 두 대 이상의 WINS 서버가 설정된 내결함성 WINS 환경을 구축하는 것이 좋습니다. WINS 서버는 클라이언트에 대해 주 WINS 서버 또는 보조 WINS 서버로 동작할 수 있습니다. 주 WINS와 보조 WINS 간의 차이점은 클라이언트가 먼저 접속하는 우선 순위입니다. 주 WINS 서버는 NetBIOS 이름 서비스 작업을 수행하기 위해 클라이언트가 우선적으로 접속하는 서버입니다. 클라이언트는 주 WINS 서버가 요청을 수행하지 못할 경우에만 보조 WINS 서버에 접속합니다. 클라이언트가 요청했을 때 주 WINS 서버가 사용 가능한 상태가 아니거나 사용자가 클라이언트에 대한 이름을 확인하지 못한 경우를 예로 들 수 있습니다.

주 WINS 서버가 요청을 수행하지 못한 경우 클라이언트는 같은 요청을 보조 WINS 서버에 보냅니다. 클라이언트용으로 두 대 이상의 WINS 서버가 구성되어 있으면 클라이언트는 WINS 서버 중 하나가 요청 응답에 성공할 때까지 추가 보조 WINS 서버에 요청을 보냅니다. 클라이언트가 보조 WINS 서버를 사용한 후에는 이후 이름 서비스 요청을 위해 주 WINS 서버로의 전환을 주기적으로 시도합니다.

라우팅되거나 세그먼트화된 네트워크에서는 Exchange 서버 컴퓨터에 적어도 하나 이상의 보조 WINS 서버를 구성하는 것이 가장 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 네트워크 연결을 엽니다.

  2. 구성할 네트워크 연결을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭(로컬 영역 연결의 경우) 또는 네트워킹 탭(다른 연결의 경우)에서 인터넷 프로토콜(TCP/IP)을 클릭한 다음 속성을 클릭합니다.

  4. 고급을 클릭하고 WINS 탭을 클릭한 다음 추가를 클릭합니다.

  5. TCP/IP WINS 서버에서 보조 WINS 서버의 IP 주소를 입력한 다음 추가를 클릭합니다.

  6. WINS 서버 IP 주소를 더 추가하려면 4단계와 5단계를 반복 수행한 다음 확인을 클릭합니다. 화살표 키를 사용하여 WINS 서버의 우선 순위를 변경할 수 있습니다.

  7. NetBIOS over TCP/IP 사용을 선택합니다.

  8. 확인을 클릭하여 변경 내용을 저장합니다.

Exchange에 필요한 NetBIOS 이름 확인 요구 사항에 대한 자세한 내용은 기술 자료 문서 837391, "Exchange Server 2003 and Exchange 2000 Server require NetBIOS name resolution for full functionality"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391)를 참조하십시오.


서버가 가상 PC입니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2007-03-28

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터에 대한 Model 키 값을 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키 값에 "Virtual Machine"이라는 문자열이 포함되어 있으면 오류가 표시됩니다.

"Virtual Machine"이라는 문자열이 포함되어 있으면 해당 Exchange Server 컴퓨터가 Microsoft Virtual PC 200x 가상 컴퓨터 내부에서 실행되고 있음을 나타냅니다. Virtual PC 200x는 한 워크스테이션에서 여러 개의 PC 기반 운영 체제를 동시에 실행할 수 있는 소프트웨어 가상화 솔루션입니다. Microsoft Exchange Server의 어떠한 버전도 가상 컴퓨터나 에뮬레이터에서 실행할 수 없습니다. 이 사항은 Microsoft Virtual Server 200x, Microsoft Virtual PC 200x 또는 타사 가상 컴퓨터 프로그램에서 실행되는 Exchange Server에 해당되는 내용입니다. Microsoft Exchange Server 플랫폼은 실제 하드웨어, 특히 Windows 서버 카탈로그(http://go.microsoft.com/fwlink/?linkid=17219)에 나와 있는 하드웨어 플랫폼에서만 실행하도록 설계되고 테스트되었습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Virtual PC 200x로 실행되는 Exchange Server에서 비가상 Exchange Server 컴퓨터로 사서함을 옮깁니다.

  2. 공용 폴더를 모두 옮기고 필요에 따라 가상 Exchange 서버가 보유하고 있는 모든 역할을 전송합니다.

  3. 가상 컴퓨터에서 Exchange를 제거하여 Exchange 인프라 및 Active Directory® 디렉터리 서비스에서 Exchange를 제거합니다.

가상 환경에서 실행되는 Exchange Server 컴퓨터 지원에 대한 자세한 내용은 Microsoft 기술 자료 문서 320220, "Support policy for Exchange Server 2003 running on hardware virtualization software"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320220)를 참조하십시오.

Microsoft Virtual PC에 대한 자세한 내용은 Microsoft Virtual PC 홈 페이지(http://go.microsoft.com/fwlink/?linkid=34663)를 참조하십시오.


이 디스크가 오류를 보고합니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 디스크의 Status 키 값을 확인할 때 Win32_DiskDrive Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 디스크의 Status 키 값이 정상이 아닌 경우 오류를 표시합니다.

Status 키는 디스크 개체의 현재 상태를 제공합니다. 다양한 작업 및 비작업 상태를 정의할 수 있습니다. 작업 상태에는 다음이 포함됩니다.

  • 정상

  • 저하됨

  • 실패 예상(SMART 사용 가능 하드 드라이브 같은 요소가 제대로 작동할 수 있지만 곧 오류가 예상됨)

  • 비작업 상태에는 다음이 포함됩니다.

  • 오류

  • 시작하는 중

  • 중지하는 중

  • 서비스(디스크를 다시 미러링하거나 사용자 권한 목록을 다시 로드하는 동안 또는 다른 관리 작업을 하는 동안 적용될 수 있음)

Status 키는 다음 값을 포함하는 CIM_ManagedSystemElement WMI 클래스에서 상속됩니다.

  • 정상

  • 오류

  • 저하됨

  • 알 수 없음

  • 실패 예상

  • 시작하는 중

  • 중지하는 중

  • 서비스

  • 스트레스

  • NonRecover

  • 연결 안 됨

  • 통신 손실

일반적으로 Microsoft에서는 특정 하드웨어 공급업체의 디스크 오류 해결에 대한 설명서를 제공하지 않습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 모든 디스크 및 케이블 연결을 확인하고 10분 정도 기다렸다가 Status 값을 확인합니다.

  2. 반환된 값이 유지 관리 모드 값이 아니면(예: 서비스 이외의 값) 하드 디스크 제조업체에서 권장다는 디스크 문제 해결 단계를 따라야 합니다. 일부 경우에 하드 디스크 제조업체에서 문제점 분석을 위해 설치할 수 있는 문제 해결 소프트웨어를 제공할 수도 있습니다.

Exchange와 관련된 일반 저장소 문제점에 대한 자세한 내용은 Microsoft 다운로드 센터의 "Storage Solutions for Microsoft Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=1715)를 참조하십시오.

Microsoft Windows Server™ 2003과 관련된 일반 저장소 정보에 대한 자세한 내용은 Microsoft Windows Server 2003 TechCenter의 "Windows Server 2003 Storage Services"(http://go.microsoft.com/fwlink/?LinkId=33811)를 참조하십시오.

Windows 2000 Server와 관련된 일반 저장소 정보에 대한 자세한 내용은 Windows 2000 웹 사이트의 "Windows Server 2000 Storage Services"(http://go.microsoft.com/fwlink/?LinkId=33812)를 참조하십시오.


이 Exchange 서버에서 8개 이상의 프로세서가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 NumberOfProcessors의 현재 값을 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 NumberOfProcessors 값이 8보다 클 경우 경고를 표시합니다. 그러나 이 서버가 Intel 하이퍼 스레딩 기술을 사용하도록 구성된 경우 이 경고는 무시해도 됩니다. 하이퍼 스레딩 기술을 사용하면 다중 스레드 소프트웨어 응용 프로그램에서 스레드를 병렬로 실행할 수 있습니다. 하이퍼 스레딩 기술을 사용하려면 컴퓨터 시스템이 하이퍼 스레딩 기술을 지원하는 Intel Pentium 4 프로세서와 HT Technology 사용 칩셋, BIOS 및 운영 체제를 갖추고 있어야 합니다.

Exchange 2000 Server 및 Exchange Server 2003은 컴퓨터에서 8개의 프로세서만 효과적으로 사용할 수 있습니다. 특히 Microsoft Exchange Information Store 서비스는 8개의 프로세서에서 최고 성능을 발휘하도록 최적화되었습니다.

프로세서가 8개를 초과하는 컴퓨터에서는 하드웨어 파티션을 사용하여 컴퓨터를 여러 대의 8 프로세서 컴퓨터나 4 프로세서 컴퓨터로 분할하는 것이 좋습니다. 또는 Microsoft Exchange Information Store 프로세스(Store.exe)의 CPU 선호도를 8개의 프로세서로만 구성할 수 있습니다.

Microsoft Exchange Information Store 프로세스가 CPU 선호도 또는 하드웨어 파티션을 통해 8개의 프로세서로 제한되는 즉시 사용 가능한 최신 서비스 팩과 Exchange 업데이트 롤업으로 업그레이드하는 것이 좋습니다. Exchange Server 2003을 실행하는 경우 이것은 특히 중요합니다.

이전에는 백 엔드 서버의 프로세서 수가 5개 이상일 경우 Exchange 서버의 성능이 약간 향상되었습니다. 프로세서가 8개가 넘으면 약간의 성능 향상만 있을 뿐이고 이따금 성능이 저하될 수 있습니다. 프로세서 추가에 따른 성능 저하는 최신 컴퓨터에서 사용되는 프로세서 유형으로 더욱 명확해졌습니다. Exchange Server 2003 서비스 팩 1에서는 추가 프로세서를 통한 확장성이 더욱 향상되었습니다. 하이퍼 스레딩을 사용하면 8 프로세서 서버는 4 프로세서 서버보다 성능이 50% 향상됩니다. 백 엔드 서버에 8 프로세서 컴퓨터를 사용하는 것은 현재 많은 경우에 적합합니다. 아직도 프런트 엔드 서버에는 이중 프로세서 서버를 사용하는 것이 좋습니다.

앞에서 설명했듯이 이 Exchange Server 컴퓨터가 하이퍼 스레딩 기술을 사용하는 경우 이 경고는 무시해도 됩니다.

하이퍼 스레딩 기술을 사용하지 않는 시스템에서 이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange용 최신 서비스 팩과 업데이트 롤업을 적용합니다. 이것은 "Downloads for Exchange Server 2003" 웹 사이트(http://go.microsoft.com/fwlink/?linkid=25097)에서 다운로드할 수 있습니다.

  2. Microsoft Exchange Information Store 서비스(Store.exe)의 CPU 선호도를 8개의 CPU로 설정하거나 하드웨어 파티션을 사용하여 8-프로세서 Exchange 서버를 만듭니다. 자세한 수행 방법은 하드웨어 제조업체에 문의하십시오.

Exchange Server 리소스 확장성에 대한 자세한 내용은 Microsoft 기술 자료 문서, "CPU and Memory Scalability for Exchange 2000 and Exchange 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827281)을 참조하십시오.

자세한 내용은 기술 자료 문서 271088, "XGEN: Optimizing Windows 2000 Active Directory Servers with Six or Eight Processors to Run with Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=271088)을 참조하십시오.

하이퍼 스레딩 기술에 대한 자세한 내용은 Intel 웹 사이트(http://www.intel.com/info/hyperthreading)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


Exchange 서버에 4GB 이상의 메모리가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2006-06-20

Microsoft® Exchange Server Analyzer Tool은 각 Exchange Server 컴퓨터의 TotalPhysicalMemory 키 값을 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

Exchange Server Analyzer는 TotalPhysicalMemory의 값이 4,294,967,296보다 크고 6,442,450,944보다 작은 경우 경고를 표시합니다.

Exchange Server Analyzer는 TotalPhysicalMemory의 값이 6,442,450,944로 설정되어 있으면 오류를 표시합니다.

TotalPhysicalMemory 값이 4,294,967,296보다 크면 Exchange Server 컴퓨터에 4GB가 넘는 메모리가 설치됨을 나타내지만 TotalPhysicalMemory 값이 6,442,450,944보다 크면 Exchange Server 컴퓨터에 6GB가 넘는 메모리가 설치됨을 나타냅니다. 실제 메모리가 4GB 이상인 컴퓨터에서는 Exchange Server가 3GB를 넘는 메모리를 사용하지 않습니다. 따라서 컴퓨터가 Exchange Server만 실행하도록 구성된 경우 4GB가 넘는 메모리를 설치하는 것은 손해입니다.

또한 실제 RAM이 클수록 필요한 가상 대 실제 매핑을 수행하는 데 더 많은 운영 체제 커널 주소 항목이 필요합니다. 이로 인해 시스템에서 사용할 수 있는 여유 시스템 PTE(페이지 테이블 항목)와 페이징 풀 메모리가 모두 감소하여 시스템이 불안정하게 될 수 있습니다.

예를 들어 실제 RAM이 8GB인 컴퓨터는 실제 RAM이 4GB인 컴퓨터보다 여유 시스템 PTE(페이지 테이블 항목) 3,000개가 적고 최대 페이징 풀 크기의 30MB가 감소됩니다.

다음 두 가지 해결 방법 중 하나를 따르는 것이 좋습니다.

  • 시스템의 메모리 크기를 4GB로 줄입니다.

  • 이 문서 뒤쪽에 나오는 설명대로 Boot.ini 파일의 BurnMemory 매개 변수를 실제 메모리가 4GB로 줄어들도록 설정합니다.

또한 추가 메모리를 요구하는 여러 응용 프로그램을 실행 중인 경우 Windows 핫픽스를 실행하여 사용 가능한 RAM이 4GB 이상일 경우 발생할 수 있는 Exchange 정보 저장소 실패를 방지할 수 있습니다. 컴퓨터가 Exchange Server만 실행하도록 하는 것이 좋습니다. 핫픽스에 대한 자세한 내용은 Microsoft 기술 자료 문서 834628, "Windows Server 2003 기반 컴퓨터에서 PAE를 설정하면 데이터가 손상된다"(http://go.microsoft.com/fwlink/?linkid=3052)를 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Windows 탐색기에서 시스템 파티션을 탐색합니다.

  2. Boot.ini 파일을 볼 수 없는 경우는 폴더 옵션을 보호된 운영 체제 파일 숨기기로 설정했기 때문일 수 있습니다. 이러한 경우에는 Windows 탐색기 창에서 도구, 폴더 옵션을 차례로 클릭한 다음 보기를 클릭합니다. 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 해제합니다. 경고 상자가 표시되면 예를 클릭합니다.

  3. 탐색기에서 boot.ini 파일을 볼 수 있으면 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램을 클릭하고 Notepad를 선택하여 파일을 엽니다.

  4. [Operating Systems] 섹션에서 시작 줄에 /BURNMEMORY=<Value in MB> 스위치를 추가합니다.

    예를 들면 다음과 같습니다.

    6GB의 실제 메모리가 설치되어 있으면 /BURNMEMORY=2048을 사용하여 사용 가능한 메모리를 4GB로 줄입니다. 8GB의 실제 메모리가 설치되어 있는 경우에는 /BURNMEMORY=4096을 사용합니다.

  5. 변경 내용을 저장하고 메모장을 닫습니다.

  6. Exchange Server 컴퓨터를 다시 부팅하여 변경 내용을 적용합니다.

Boot.ini 파일에 사용할 수 있는 매개 변수에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 833721: "Windows XP 및 Windows Server 2003 Boot.ini 파일에 사용할 수 있는 스위치 옵션"(http://go.microsoft.com/fwlink/?linkid=3052)

  • 102873: "BOOT.INI와 ARC 경로 명명 규약 및 사용"(http://go.microsoft.com/fwlink/?linkid=3052)


이 논리 디스크의 사용 가능한 공간이 3GB 미만입니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2007-03-14

Microsoft® Exchange Server Analyzer Tool은 Win32_LogicalDisk DriveType 키가 3(이는 로컬 디스크를 나타냄)으로 설정된 디스크의 FreeSpace 키 값을 확인할 때 Win32_LogicalDisk Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server 컴퓨터에 있는 로컬 디스크의 FreeSpace 키 값이 3GB 미만이면 경고를 표시합니다. 사서함이 있는 Exchange Server 컴퓨터의 모든 디스크에서는 50% 이상의 용량이 항상 비어 있는 것이 좋습니다.

사용 가능한 디스크 용량은 항상 충분하게 유지해야 합니다. 데이터베이스 디스크의 사용 가능한 공간이 부족하면 데이터베이스가 오프라인 상태가 됩니다. 그리고 트랜잭션 로그 디스크의 사용 가능한 공간이 부족하면 해당 저장소 그룹의 모든 데이터베이스가 오프라인 상태가 됩니다. 추가 공간을 제공하는 작업은 보통 빠른 시간 내에 수행할 수 없으며 오프라인 압축을 수행하여 공간을 다시 확보하려면 시간이 오래 걸립니다. 대부분의 경우 디스크 공간이 부족하면 보통 대부분의 RTO(목표 복구 시간)를 초과하는 시간 동안 하나 이상의 데이터베이스를 사용할 수 없게 됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 이 디스크에서 불필요한 파일을 삭제하여 사용 가능한 디스크 공간을 늘립니다.

  2. 50% 미만의 사용 가능한 공간이 있는 디스크에 사서함이나 Windows 페이지 파일 같은 다른 디스크로 안전하게 옮길 수 있는 데이터가 있으면 데이터 이동에 필요한 단계를 수행합니다.

  3. Exchange Server 컴퓨터에 디스크 용량을 추가합니다.

Exchange Server 2003에서 사서함을 이동하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 821829, "Exchange Server 2003에서 사서함 이동"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)을 참조하십시오.

Exchange 2000 Server와 Exchange Server 5.5 간의 사서함 이동에 대한 자세한 내용은 기술 자료 문서 328810, "XADM: 서버 간에 사서함 이동"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)을 참조하십시오.

Exchange Server 2003에서 시스템 정책을 사용하여 사서함 한계를 설정하는 방법에 대한 자세한 내용은 기술 자료 문서 822938, "HOW TO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938)을 참조하십시오.

Exchange 2000 Server에서 시스템 정책을 사용하여 사서함 한계를 설정하는 방법에 대한 자세한 내용은 기술 자료 문서 319130, "HOW TO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2000"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130)을 참조하십시오.

자세한 정보를 보려면 다음을 참조하십시오.


이 탑재 지점의 사용 가능한 공간이 3GB 미만입니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터가 사용하는 볼륨 탑재 지점의 FreeSpace 키 값을 확인할 때 Win32_Volume Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. FreeSpace의 값을 1,000,000,000으로 나누어 정수로 반올림한 결과가 4보다 작으면 경고가 표시됩니다.

이 경고는 볼륨 탑재 지점에 사용할 수 있는 저장 공간이 3기가바이트(GB) 미만임을 나타냅니다. Exchange Server 2003이 Windows Server™ 2003 Enterprise Edition 또는 Windows Server 2003 Datacenter Edition을 실행하는 컴퓨터에 설치되어 있는 경우 Exchange Server 2003에서 볼륨 탑재 지점(NTFS 파일 시스템 연결 지점)이 클러스터된 구성의 데이터 저장소 위치로 지원됩니다. NTFS 볼륨 탑재 지점 기능을 사용하여 26 드라이브 문자 제한을 초과할 수 있습니다. 볼륨 탑재 지점을 사용함으로써 대상 파티션을 다른 실제 디스크의 폴더에 연결 또는 탑재할 수 있습니다. 볼륨 탑재 지점은 Exchange Server 2003과 같은 프로그램에 투명하게 제공됩니다.

다음과 같은 경우에는 탑재 지점이 지원되지 않습니다.

  • Exchange Server 2003 이진 파일의 저장 위치로 사용되는 경우

  • Microsoft Exchange 2000 Server 또는 이전 버전을 실행하는 Exchange 클러스터와 함께 사용되는 경우

  • Microsoft Windows 2000 Server 또는 이전 버전을 실행하는 Windows 클러스터와 함께 사용되는 경우

Exchange Server에서 사용되는 볼륨이 로컬 실제 디스크인지 논리 볼륨인지 아니면 볼륨 탑재 지점인지에 관계없이 모든 드라이브에서 최소 50%의 디스크 공간을 사용할 수 있도록 Exchange Server를 구현하는 것이 좋습니다. 일반적으로 Eseutil, Isinteg 등의 데이터베이스 유틸리티를 사용하여 수행되는 작업과 같은 Exchange 유지 관리 작업에 사용할 수 있도록 최소 25-30%의 디스크 여유 공간을 확보하는 것이 좋습니다. 또한 오프라인 조각 모음과 같은 일부 유지 관리 작업의 경우 조각 모음을 실행하는 용량의 100%에 해당하는 여유 공간을 확보하는 것이 좋습니다. 예를 들어 1GB 데이터베이스에 대해 조각 모음을 실행하는 경우 최소 1GB의 사용 가능한 디스크 공간을 확보해야 합니다.

디스크 여유 공간을 많이 확보하면 보안 및 가용성 측면에서도 좋습니다. 메시지 루프 또는 바이러스의 형태로 널리 퍼져 있는 DoS(Denial-of-Service) 공격은 메시지 트래픽, 트랜잭션 로그 작업 등을 증가시켜 디스크 공간을 과도하게 소모하는 원인이 됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 영역을 검사하여 사용 가능한 디스크 공간을 확보합니다.

  2. 디스크 공간이 매우 적으면 데이터를 공간이 충분한 다른 Exchange Server 컴퓨터나 Exchange 가상 서버로 이동합니다. 사서함 제한을 설정하여 디스크 사용량을 관리할 수도 있습니다.

Exchange Server 2003 클러스터에서 볼륨 탑재 지점을 사용하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 "Volume Mount Point Support for an Exchange Server 2003 Cluster on a Windows Server 2003-based System"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=318458)을 참조하십시오.

Windows Server 2003 클러스터에서 볼륨 탑재 지점을 사용하는 방법에 대한 자세한 내용은 기술 자료 문서 280297, "클러스터된 서버에서 볼륨 탑재 지점을 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=280297)을 참조하십시오.


이 네트워크 카드에서 DHCP를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 DHCPEnabled 속성 값이 설정되어 있는지 확인할 때 Win32_NetworkAdapterConfiguration Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange 서버에서 이 속성의 값이 1이면 오류가 표시됩니다.

DHCP를 사용하는 네트워크 카드에서 Exchange를 실행하도록 구성할 수 있습니다. 그러나 이렇게 구성하지 않는 것이 좋습니다. DHCP를 사용하는 컴퓨터에서 Exchange를 실행하면 DHCP 서비스가 실패하거나 중단될 경우 Exchange는 메일 배달이 중지되거나 실패할 수 있으므로 바람직하지 않습니다.

Exchange를 실행하는 모든 컴퓨터가 고정 IP 주소를 사용하도록 구성하는 것이 좋습니다.

Windows TCP/IP 네트워크 설계에 대한 자세한 내용은 Microsoft TechNet Networking 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=33819)를 참조하십시오.


주 WINS 서버 주소가 비어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 WINSPrimaryServer 키 값 설정 여부를 확인할 때 Win32_NetworkAdapterConfiguration Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Exchange 서버에 대한 이 키 값이 비어 있으면 경고를 표시합니다.

Exchange Server 2003 및 Exchange 2000 Server에는 몇 가지 NetBIOS 종속성이 있습니다. 또한 Microsoft Office Outlook 2003 이전 버전의 Microsoft Outlook®을 실행하는 클라이언트는 NetBIOS 이름도 확인해야 합니다. 예를 들어 다음 Exchange 기능은 NetBIOS 이름 확인에 따라 달라집니다.

  • Exchange Server 2003 및 Exchange 2000 Server 설치 프로그램(특히 클러스터된 서버)

  • Exchange Server 2003 또는 Exchange 2000 Server 컴퓨터의 Exchange 사서함 병합 마법사(ExMerge)

  • Outlook Web Access를 통해 Exchange Server 2003 또는 Exchange 2000 Server 사서함 암호를 변경하는 기능

  • Exchange Server 2003 또는 Exchange 2000 Server 컴퓨터의 Exchange System Manager

조직의 네트워크 토폴로지에 따라 이 경고를 무시할 수 있습니다. 단일 서브넷으로 이루어진 네트워크의 경우 NetBIOS 브로드캐스트는 일반적으로 Exchange 배포에 필요한 NetBIOS 이름 확인 사항을 처리합니다.

대규모 조직의 경우 브로드캐스트를 통한 NetBIOS 이름 확인이 제대로 동작하지 않을 수 있습니다. 일반적으로 NetBIOS 브로드캐스트는 서브넷 간에는 수행되지 않으므로 라우팅된 네트워크에서는 NetBIOS 이름 확인을 위한 대안이 필요합니다. 이에 대한 대안으로 WINS(Windows Internet Name Service)가 선호됩니다. WINS는 네트워크에 사용되는 컴퓨터 및 그룹에 대한 NetBIOS 이름의 동적 매핑을 등록 및 쿼리하기 위한 분산 데이터베이스를 제공합니다. WINS는 NetBIOS 이름을 IP 주소에 매핑하며 라우팅된 환경에서 NetBIOS 이름 확인으로 인해 발생하는 문제를 해결하도록 설계되었습니다. WINS는 TCP/IP에서 NetBIOS를 사용하는 라우팅된 네트워크에서 NetBIOS 이름 확인에 대한 최선책이라 할 수 있습니다.

WINS 기능이 없는 대규모 또는 서브넷 설정 조직에서의 Exchange Server 2003 및 Exchange 2000 Server 운영과 작동은 완전한 검증을 거치지 않았습니다. 라우팅되거나 세그먼트화된 네트워크에서 Exchange를 실행하는 기업은 NetBIOS 이름 확인을 위한 WINS를 사용해야 합니다. 라우팅되거나 세그먼트화된 환경에서는 WINS 없이 Exchange를 실행할 수 없습니다.

적어도 두 대 이상의 WINS 서버가 설정된 내결함성 WINS 환경을 구축하는 것이 좋습니다. WINS 서버는 클라이언트에 대해 주 WINS 서버 또는 보조 WINS 서버로 동작할 수 있습니다. 주 WINS와 보조 WINS 간의 차이점은 클라이언트가 먼저 접속하는 우선 순위입니다. 주 WINS 서버는 NetBIOS 이름 서비스 작업을 수행하기 위해 클라이언트가 우선적으로 접속하는 서버입니다. 클라이언트는 주 WINS 서버가 요청을 수행하지 못할 경우에만 보조 WINS 서버에 접속합니다. 클라이언트가 요청했을 때 주 WINS 서버가 사용 가능한 상태가 아니거나 사용자가 클라이언트에 대한 이름을 확인하지 못한 경우를 예로 들 수 있습니다.

주 WINS 서버가 요청을 수행하지 못한 경우 클라이언트는 같은 요청을 보조 WINS 서버에 보냅니다. 클라이언트용으로 두 대 이상의 WINS 서버가 구성되어 있으면 클라이언트는 WINS 서버 중 하나가 요청 응답에 성공할 때까지 추가 보조 WINS 서버에 요청을 보냅니다. 클라이언트가 보조 WINS 서버를 사용한 후에는 이후 이름 서비스 요청을 위해 주 WINS 서버로의 전환을 주기적으로 시도합니다.

라우팅되거나 세그먼트화된 네트워크에서는 Exchange 서버 컴퓨터에 적어도 하나 이상의 보조 WINS 서버를 구성하는 것이 가장 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 네트워크 연결을 엽니다.

  2. 구성할 네트워크 연결을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭(로컬 영역 연결의 경우) 또는 네트워킹 탭(다른 연결의 경우)에서 인터넷 프로토콜(TCP/IP)을 클릭한 다음 속성을 클릭합니다.

  4. 고급을 클릭하고 WINS 탭을 클릭한 다음 추가를 클릭합니다.

  5. TCP/IP WINS 서버에서 WINS 서버의 IP 주소를 입력한 다음 추가를 클릭합니다.

  6. WINS 서버 IP 주소를 더 추가하려면 4단계와 5단계를 반복 수행한 다음 확인을 클릭합니다. 화살표 키를 사용하여 WINS 서버의 우선 순위를 변경할 수 있습니다.

  7. TCP/IP에서 NetBIOS 사용을 선택합니다.

  8. 확인을 클릭하여 변경 내용을 저장합니다.

Exchange에 필요한 NetBIOS 이름 확인 요구 사항에 대한 자세한 내용은 기술 자료 문서, 837391 "Exchange Server 2003 and Exchange 2000 Server require NetBIOS name resolution for full functionality"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391)를 참조하십시오.


가상 서버가 검색되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 하드웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Model 키 값이 Virtual Machine으로 설정되었는지 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 다음 레지스트리 값이 있는지도 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Exchange Server Analyzer는 Model 키가 Virtual Machine 문자열을 포함하고 있고 위의 레지스트리 분기가 존재할 경우 오류를 표시합니다.

Model 키의 Virtual Machine 값은 Exchange Server 컴퓨터가 Virtual Server 2005 또는 Microsoft Virtual PC 2004에서 게스트 가상 컴퓨터로 실행되고 있음을 나타냅니다. 위의 레지스트리 분기가 Virtual Server 2005에 의해서만 만들어졌기 때문에 이 분기가 존재한다는 사실은 Exchange Server가 Microsoft Virtual Server 2005에서 게스트 가상 컴퓨터로 실행되고 있음을 의미합니다.

Microsoft Exchange Server의 어떠한 버전도 가상 컴퓨터나 에뮬레이터에서 실행할 수 없습니다. 이 사항은 Microsoft Virtual Server 2005, Microsoft Virtual PC 2004 또는 타사 가상 컴퓨터 프로그램에서 실행되는 Exchange Server에 해당되는 내용입니다. Microsoft Exchange Server 플랫폼은 실제 하드웨어, 특히 Windows Server Catalog(http://go.microsoft.com/fwlink/?linkid=17219)에 나열된 하드웨어 플랫폼에서만 실행되도록 설계되고 테스트되었습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Virtual Server 2005에서 실행되는 Exchange Server에서 비가상 Exchange Server 컴퓨터로 사서함을 옮깁니다.

  2. 모든 공용 폴더를 옮기고 필요에 따라 가상 Exchange 서버가 보유하고 있는 모든 역할을 전송합니다.

  3. 가상 컴퓨터에서 Exchange를 제거하여 Exchange 인프라 및 Active Directory® 디렉터리 서비스에서 Exchange를 제거합니다.

사서함 이동에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 822892, "Exchange 2003 사서함 이동의 개선 사항"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, XADM: Differences Between Move Mailbox Methods(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Microsoft Virtual Server 2005에 대한 자세한 내용은 Microsoft Virtual Server 2005 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=34938)를 참조하십시오.

Microsoft Virtual PC 2004에 대한 자세한 내용은 Microsoft Virtual PC 2004 웹 사이트(http://go.microsoft.com/fwlink/?linkid=34663)를 참조하십시오.


네트워크
Microsoft Exchange Server Analyzer - 문서 >

최근 수정된 항목: 2005-11-18

이 섹션의 문서에서는 Microsoft® Exchange Server Analyzer Tool이 평가하는 네트워크 관련 내용에 대해 자세히 설명합니다. 또한 이 문서에서는 Exchange Server Analyzer에서 발견하는 네트워크 관련 오류, 경고 및 기본이 아닌 구성을 해결하기 위해 사용자가 취해야 할 조치를 설명합니다.


DNS '호스트' 레코드가 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2006-04-13

Microsoft® Exchange Server Analyzer Tool은 DNS(Domain Name System) 서버에서 DNS 조회를 수행하여 Exchange 서버의 호스트 (A) 레코드를 검색합니다. DNS 조회 작업에서 IP 주소를 반환하지 않으면 Exchange Server Analyzer는 호스트 (A) 레코드가 없다는 경고를 표시합니다.

다음과 같은 이유로 Exchange Server 2003 컴퓨터에서 호스트 (A) 레코드의 DNS 조회가 실패할 수 있습니다.

  • 네트워크 오류나 다른 이유 때문에 DNS 서버가 종료되었거나 응답하지 않을 수 있습니다.

  • Exchange Server 2003의 호스트 (A) 레코드를 사용할 수 없거나 잘못되었거나 또는 DNS 서버가 동적 호스트 레코드 업데이트를 허용하도록 구성되지 않았기 때문에 DNS 서버에 이 레코드가 없을 수 있습니다.

DNS 서버가 종료된 경우 메일 라우팅이 지연되고 다른 서비스가 실패할 수 있습니다.

참고:
Exchange Server 2003은 네트워크의 로컬 및 외부 SMTP 기반 메시징 시스템 모두에 대해 호스트 이름 확인을 사용합니다. 호스트 이름 확인은 주로 DNS를 기준으로 하며 DNS는 중요한 네트워크 서비스입니다. DNS 서버의 오류로 인해 다른 사용자가 사용자의 메시징 시스템을 찾지 못할 수 있습니다. Active Directory 및 Exchange Server 2003 조직은 DNS 없이 작동하지 않습니다. 메시징 클라이언트는 DNS를 쿼리하여 도메인 컨트롤러 및 사서함 서버와 같은 내부 리소스를 찾습니다. 그러나 Exchange Server 2003은 인터넷으로 메시지를 보낼 때 DNS를 사용하여 디렉터리 조회 및 외부 SMTP(Simple Mail Transfer Protocol) 호스트에 대한 도메인 컨트롤러의 IP(인터넷 프로토콜) 주소를 검색합니다.

이 문제를 해결하려면 DNS 서버가 실행 중인지 그리고 호스트 (A) 레코드가 등록되었는지 확인합니다.

DNS 서버가 온라인 상태이고 호스트 레코드가 있는지 확인하려면 다음을 수행합니다.

  1. 다음 단계 중 하나 이상을 수행하여 DNS 서버가 실행 중인지 확인합니다.

    • DNS 서버에서 DNS 관리 프로그램을 사용하여 DNS 서버 상태를 확인합니다.

    • DNS 서버를 다시 시작합니다. 자세한 내용은 "Start, stop, pause, or restart a DNS server"(http://go.microsoft.com/fwlink/?LinkId=62999)를 참조하십시오.

    • nslookup을 사용하여 DNS 서버 응답 능력을 검사합니다. 자세한 내용은 "Verify DNS server responsiveness using the nslookup command"(http://go.microsoft.com/fwlink/?LinkId=63000)를 참조하십시오.

  2. nslookup을 사용하여 DNS 서버에 호스트 (A) 레코드가 있는지 확인합니다. 자세한 내용은 "To verify A resource records exist in DNS"(http://go.microsoft.com/fwlink/?LinkId=63001)를 참조하십시오.

  3. 호스트 (A) 리소스 레코드가 없으면 A 리소스 레코드를 수동으로 추가 또는 수정하거나 동적 레코드 업데이트를 허용하도록 DNS 서버를 구성합니다.

    • A 리소스 레코드를 수동으로 추가합니다. 자세한 내용은 "Add a resource record to a DNS zone"(http://go.microsoft.com/fwlink/?LinkId=63002)을 참조하십시오.

    • A 리소스 레코드를 수동으로 수정합니다. 자세한 내용은 "Modify an existing resource record"(http://go.microsoft.com/fwlink/?LinkId=63014)를 참조하십시오.

    • DNS 서버에서 동적 호스트 레코드 업데이트를 허용하도록 합니다. 자세한 내용은 Microsoft 기술 자료 문서 816592, "Windows Server 2003에서 DNS 동적 업데이트를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)을 참조하십시오.
  • Exchange Server 2003에서 DNS를 사용하여 외부 IP 주소를 확인하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "Exchange Server 2003 전송 종속성"을 참조하십시오.

  • DNS 이름 확인에 대한 자세한 내용은 Microsoft 기술 자료 문서 322856, "HOWTO: Exchange Server 사용을 위한 DNS 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)을 참조하십시오.

  • DNS 문제 해결 방법에 대한 자세한 내용은 "Troubleshooting DNS"(http://go.microsoft.com/fwlink/?LinkId=63003)를 참조하십시오.

Exchange Server 2003 시스템 모니터링에 대한 자세한 내용은 Exchange Server 2003 Management Pack Guide for MOM 2000 SP1(http://go.microsoft.com/fwlink/?LinkId=47573)의 "System Monitoring with Exchange Server 2003 Management Pack"을 참조하십시오.

  • 호스트 (A) 리소스 레코드에 대한 자세한 내용은 "Managing resource records"(http://go.microsoft.com/fwlink/?LinkId=63004)를 참조하십시오.


UDP와 TCP 간에 DNS 응답이 다릅니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2007-03-16

Microsoft Exchange Analyzer Tool은 Win32_NetworkAdapterConfiguration Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리하여 DNSServerSearchOrder 특성을 얻습니다. 이 특성은 DNS(Domain Name System) 서버 쿼리에 사용되는 서버 IP 주소의 배열입니다.

주 DNS 서버의 주소를 검색한 후에 Exchange Analyzer는 각 Active Directory 디렉터리 서비스 서버용으로 구성된 DNS 서버에 대해 DNS 쿼리를 수행합니다. 이 연결은 TPC(Transmission Control Protocol) 및 UDP(User Datagram Protocol) 이름 확인 요청을 수행하는 사용자 지정 개체 프로세서를 사용하여 이루어집니다.

TCP 및 UDP 이름 확인 요청이 모두 성공하면 Exchange Analyzer는 성공한 요청의 반환된 응답을 서로 비교합니다. TCP 및 UDP 쿼리의 반환된 응답이 동일하지 않으면 Exchange Analyzer는 경고를 표시합니다.

이 경고는 메일 흐름 성능에 영향을 주는 DNS 서버 구성 문제가 있을 수 있음을 나타냅니다.

SMTP(Simple Mail Transfer Protocol)는 Exchange Server의 메일 전송을 위한 기본 메일 프로토콜입니다. 그러므로 클라이언트에서는 SMTP를 사용하여 메시지를 보내고 Exchange 서버에서는 SMTP를 사용하여 메시지와 메시지 데이터를 배달합니다.

Exchange Server가 SMTP 서비스를 통해 아웃바운드 인터넷 메시지를 배달할 수 있도록 다음 방법을 통해 DNS를 사용합니다.

  1. 내부 사용자가 원격 도메인에 있는 받는 사람에게 메시지를 보냅니다.

  2. 받는 사람이 로컬 도메인에 있는지 원격 도메인에 있는지를 확인하기 위해 보낸 사람의 Exchange 서버에 있는 SMTP 가상 서버는 내부 전송 함수를 사용하여 받는 사람 주소에 대해 글로벌 카탈로그 서버를 쿼리합니다. 메시지의 받는 사람 주소가 받는 사람 정책에 없으면 해당 주소가 Active Directory에 저장되지 않습니다. 그러므로 Exchange는 해당 메시지를 원격 도메인의 받는 사람에게 보내는 것으로 간주합니다.

  3. 필요한 경우 Exchange 서버가 메시지를 해당 SMTP 가상 서버로 배달합니다.

  4. SMTP 가상 서버는 해당 IIS 메타베이스 정보를 사용하여 메시지를 원격 도메인으로 배달할 방법을 결정합니다.

  5. 그런 다음 Exchange 서버의 SMTP 가상 서버가 다음 두 작업 중 하나를 수행합니다.

    • DNS를 사용하여 대상 도메인의 IP 주소를 조회한 다음 메시지를 배달합니다.

    • DNS 확인 및 메시지 배달을 담당하는 스마트 호스트로 메시지를 전달합니다.

이 경고를 해결하려면 Microsoft 기술 자료 문서 820284, "Mail may not be delivered to certain domains if Server OS is Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284)을 참조하십시오.

DNS 및 Exchange Server에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서 및 웹캐스트를 참조하십시오.

  • 322856, "Exchange Server에서 DNS를 사용할 수 있도록 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: Windows 2000 및 Exchange 2000 SMTP는 TCP DNS 쿼리를 사용한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "웹캐스트: Microsoft Exchange 2000 Server: 전송 시 DNS 문제 해결 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


DNS 서버에서 Exchange Server가 게스트로 설치된 Virtual Server 2005를 실행하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Model 키 값이 Virtual Machine으로 설정되어 있는지 여부를 확인합니다.

또한 Exchange Server Analyzer는 다음 레지스트리 값이 있는지도 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

뿐만 아니라 Exchange Server Analyzer는 Win32_Services WMI 클래스를 쿼리하여 Microsoft Virtual Server 2005를 실행 중인 실제 컴퓨터에서 DNS(Domain Name Services) 서비스를 실행하고 있는지 여부를 확인합니다.

Model 키에 Virtual Machine 문자열이 들어 있고 위 레지스트리 분기가 존재하며 DNS를 실행하고 있으면 Exchange Server Analyzer에서 오류를 표시합니다.

Model 키의 Virtual Machine 값은 Exchange Server 컴퓨터가 Virtual Server 2005 또는 Microsoft Virtual PC 2004에서 게스트 가상 컴퓨터로 실행 중임을 나타냅니다. 위의 레지스트리 분기는 Virtual Server 2005에 의해서만 만들어지므로 이러한 분기가 있으면 Exchange Server 컴퓨터가 Virtual Server 2005에서 게스트 가상 컴퓨터로 실행 중이라는 뜻입니다.

Microsoft Exchange Server의 어떠한 버전도 가상 컴퓨터나 에뮬레이터에서 실행할 수 없습니다. 이는 Virtual Server 2005, Virtual PC 2004 또는 기타 타사 가상 컴퓨터 프로그램에서 실행되는 Exchange Server에 해당되는 내용입니다. Microsoft Exchange Server 플랫폼은 실제 하드웨어, 특히 Windows Server Catalog(http://go.microsoft.com/fwlink/?linkid=17219)에 나열된 하드웨어 플랫폼에서만 실행되도록 설계되고 테스트되었습니다.

또한 DNS를 실행 중인 컴퓨터에서 Exchange를 Virtual Server 2005 게스트로 실행하면 Exchange가 전체 서비스에 충분한 중복을 허용하지 않기 때문에 권장하지 않습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Virtual Server 2005에서 실행되는 Exchange Server에서 비가상 Exchange Server 컴퓨터로 사서함을 옮깁니다.

  2. 모든 공용 폴더를 옮기고 필요에 따라 가상 Exchange 서버가 보유하고 있는 모든 역할을 전송합니다.

  3. 가상 컴퓨터에서 Exchange를 제거하여 Exchange 인프라 및 Active Directory® 디렉터리 서비스에서 Exchange를 제거합니다.

사서함 이동에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 822892, "Exchange 2003 사서함 이동의 개선 사항"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, XADM: Differences Between Move Mailbox Methods(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

가상 환경에서 실행되는 Exchange Server 컴퓨터 지원에 대한 자세한 내용은 기술 자료 문서 320220, "Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220)을 참조하십시오.

Microsoft Virtual Server 2005에 대한 자세한 내용은 Microsoft Virtual Server 2005 웹 사이트(http://go.microsoft.com/fwlink/?linkid=34938)를 참조하십시오.

Microsoft Virtual PC 2004에 대한 자세한 내용은 Microsoft Virtual PC 2004 웹 사이트(http://go.microsoft.com/fwlink/?linkid=34663)를 참조하십시오.


UDP와 TCP 간에 외부 DNS 서버 응답이 다릅니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2007-03-16

Microsoft Exchange Server Analyzer Tool은 각 Exchange Server 개체의 protocolCfgSMTPServer 클래스에서 msExchSMTPExternalDNSServers 특성 값을 확인하기 위해 Active Directory 디렉터리 서비스를 쿼리합니다. msExchSmtpExternalDNSServers 특성 값(설정되어 있는 경우)은 SMTP(Simple Mail Transfer Protocol) 가상 서버 인스턴스가 사용하는 외부 DNS(Domain Name System) 서버의 주소를 지정합니다.

주 외부 DNS 서버의 주소를 검색한 후에 Exchange Analyzer는 각 Active Directory 디렉터리 서비스 서버용으로 구성된 DNS 서버에 대해 DNS 쿼리를 수행합니다. 이 연결은 TPC(Transmission Control Protocol) 및 UDP(User Datagram Protocol) 이름 확인 요청을 수행하는 사용자 지정 개체 프로세서를 사용하여 이루어집니다.

TCP 및 UDP 이름 확인 요청이 모두 성공하면 Exchange Analyzer는 성공한 요청의 반환된 응답을 서로 비교합니다. TCP 및 UDP 쿼리의 반환된 응답이 동일하지 않으면 Exchange Analyzer는 경고를 표시합니다.

이 경고는 메일 흐름 성능에 영향을 주는 외부 DNS 서버 구성 문제가 있을 수 있음을 나타냅니다.

SMTP는 Exchange Server의 메일 전송을 위한 기본 메일 프로토콜입니다. 그러므로 클라이언트에서는 SMTP를 사용하여 메시지를 보내고 Exchange 서버에서는 SMTP를 사용하여 메시지와 메시지 데이터를 배달합니다.

Exchange Server가 SMTP 서비스를 통해 아웃바운드 인터넷 메시지를 배달할 수 있도록 다음 방법을 통해 DNS를 사용합니다.

  1. 내부 사용자가 원격 도메인에 있는 받는 사람에게 메시지를 보냅니다.

  2. 받는 사람이 로컬 도메인에 있는지 원격 도메인에 있는지를 확인하기 위해 보낸 사람의 Exchange 서버에 있는 SMTP 가상 서버는 내부 전송 함수를 사용하여 받는 사람 주소에 대해 글로벌 카탈로그 서버를 쿼리합니다. 메시지의 받는 사람 주소가 받는 사람 정책에 없으면 해당 주소가 Active Directory에 저장되지 않습니다. 그러므로 Exchange는 해당 메시지를 원격 도메인의 받는 사람에게 보내는 것으로 간주합니다.

  3. 필요한 경우 Exchange 서버가 메시지를 해당 SMTP 가상 서버로 배달합니다.

  4. SMTP 가상 서버는 해당 IIS 메타베이스 정보를 사용하여 메시지를 원격 도메인으로 배달할 방법을 결정합니다.

  5. 그런 다음 Exchange 서버의 SMTP 가상 서버가 다음 두 작업 중 하나를 수행합니다.

    • DNS를 사용하여 대상 도메인의 IP 주소를 조회한 다음 메시지를 배달합니다.

    • DNS 확인 및 메시지 배달을 담당하는 스마트 호스트로 메시지를 전달합니다.

이 경고를 해결하려면 Microsoft 기술 자료 문서 820284, "Mail may not be delivered to certain domains if Server OS is Windows Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284)을 참조하십시오.

DNS 및 Exchange Server에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서 및 웹캐스트를 참조하십시오.

  • 322856, "Exchange Server에서 DNS를 사용할 수 있도록 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: Windows 2000 및 Exchange 2000 SMTP는 TCP DNS 쿼리를 사용한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "웹캐스트: Microsoft Exchange 2000 Server: 전송 시 DNS 문제 해결 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Network Bytes Total/sec가 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Network Interface 성능 개체의 Bytes Total/sec 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Bytes Total/sec 성능 카운터는 네트워크 어댑터가 데이터 바이트를 처리하고 있는 속도를 표시합니다. 이 카운터에는 모든 응용 프로그램, 파일 데이터 및 패킷 헤더 같은 프로토콜 정보가 포함됩니다. Bytes Total/sec 성능 카운터는 Network Interface\Bytes Received/sec 및 Network Interface/Bytes Sent/sec의 합계입니다.

Exchange Server Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 100Mbps(메가비트/초) 네트워크 어댑터의 경우 Bytes Total/sec 성능 카운터의 값은 7메가바이트/초 미만이어야 합니다. 1000Mbps 네트워크 어댑터의 경우 Bytes Total/sec 성능 카운터의 값은 70메가바이트/초보다 미만이어야 합니다. Exchange Server Analyzer는 Bytes Total/sec가 네트워크 대역폭의 7%를 초과하는 경우 오류를 표시합니다.

이 오류는 일반적으로 서버가 일정 기간 동안 응답하지 않아 메일 흐름이 느려지거나 중지되었음을 나타냅니다. 또한 이 서버에 연결된 Microsoft Outlook® 클라이언트에는 RPC cancel Request 대화 상자가 표시될 수 있습니다.

이 오류는 다음과 같은 원인으로 발생할 수 있습니다.

  • 컴퓨터의 NIC(네트워크 인터페이스 카드)가 네트워크 인프라에서 지원하는 최대 대역폭을 지원할 수 없습니다.

  • 서버의 로드가 너무 큽니다.

  • 바이러스 또는 스팸으로 인해 네트워크 사용 패턴이 급격히 상승하고 있습니다.

이 오류를 해결하려면 다음을 수행합니다.

  • NIC가 네트워크의 최대 대역폭을 지원하지 않으면 더 빠른 대역폭을 지원하도록 NIC를 업그레이드합니다.

  • 서버에서 로드를 줄입니다. 사서함 수가 더 적은 서버로 사서함을 이동하여 로드를 줄일 수 있습니다. 필요한 경우 사용자 환경에 추가 Exchange 서버를 추가합니다.

  • 서버에 너무 많은 사서함이 있어서 지나치게 높은 로드가 발생하는 것이 아니라고 의심되는 경우에는 지나치게 높은 로드의 원인을 확인하고 중지해 보십시오.

  • 다음 문서의 유용한 정보를 고려하십시오.

    • 네트워크 대역폭 고려 사항에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "Exchange 성능 이해"에서 네트워크 성능을 참조하십시오.

    • 네트워크 문제 해결에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Ruling Out Network-Bound Problems"를 참조하십시오.


NIC(네트워크 인터페이스 카드) 팀 기능 사용
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2006-10-16

Microsoft® Exchange Server Analyzer Tool은 Win32_NetworkAdapter Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 TCP/IP 프로토콜에 연결되는 모든 NIC(네트워크 인터페이스 카드)를 확인합니다.

그런 다음 Exchange Server Analyzer는 해당 어댑터에 대한 TeamAdapters 키가 있는지 확인하기 위해 다음의 레지스트리 분기를 쿼리합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\

Exchange Server Analyzer는 분석 중인 서버에 있는 하나 이상의 NIC에 TeamAdapters 키가 있는 것이 확인되면 경고를 표시합니다.

이 경고는 분석 중인 Exchange 서버에서 NIC 팀 기능을 사용하고 있음을 나타냅니다. 일반적으로 NIC 팀 기능이 메일 흐름 문제를 발생시키지는 않지만 사용 가능한 최신 NIC 드라이버로 팀 기능이 올바르게 구성되어 있는지 반드시 확인해야 합니다.

이 문제를 해결하려면 다음을 수행하십시오.

  • NIC 팀 기능을 사용하고 있는 서버에 메일 흐름 문제가 발생하면 메일 흐름 문제가 해결되는지 확인할 수 있도록 팀 기능을 일시적으로 사용하지 않습니다.

  • NIC 드라이버를 NIC 제조업체에서 제공하는 최신 버전으로 업데이트합니다.

  • 팀 기능 구성에 대한 NIC 제조업체의 권장 사항을 준수합니다.

NIC 팀 기능에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 278431, "네트워크 부하 분산에 팀 어댑터를 사용할 경우 네트워크 문제가 발생할 수 있음"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=278431)

  • 814607, "Microsoft에서 서버 클러스터에 타사 시스템 구성 요소 지원"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=814607)


Network Outbound Packet이 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Network Interface 성능 개체의 Packet Outbound errors 성능 카운터에서 데이터를 수집하여 성능 데이트를 분석합니다.

Packet Outbound errors 성능 카운터는 오류로 인해 전송하지 못한 나가는 패킷 수를 나타냅니다. Packet Outbound errors 성능 카운터 값은 0이어야 합니다. Exchange Server Analyzer는 Packet Outbound errors 성능 카운터에 0보다 큰 값이 있는 경우 오류를 표시합니다.

이 오류는 일반적으로 서버가 일정 기간 동안 응답하지 않아 메일 흐름이 느려지거나 중지되었음을 나타냅니다. 또한 이 서버에 연결된 Microsoft Outlook® 클라이언트에는 RPC cancel Request 대화 상자가 표시될 수 있습니다.

이 오류는 주로 잘못되거나 손상된 NIC(네트워크 인터페이스 카드)로 인해 발생합니다.

이 오류를 해결하려면 나가는 패킷 오류의 원인을 확인한 다음 문제를 해결해야 합니다. 나가는 패킷 오류가 잘못된 NIC로 인해 발생한 경우에는 즉시 카드를 바꿉니다.

다음 문서의 유용한 정보를 고려하십시오.

  • 네트워크 대역폭 고려 사항에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "Exchange 성능 이해"에서 네트워크 성능을 참조하십시오.

  • 네트워크 문제 해결에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Ruling Out Network-Bound Problems"를 참조하십시오.


Network Output Queue Length가 임계값을 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2007-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용되는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Network Interface 성능 개체의 Output Queue Length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Output Queue Length 성능 카운터는 패킷에서 출력 패킷 큐의 길이를 표시합니다. Exchange Server Analyzer는 수집 기간 중 성능 카운터의 최대값을 보고하고 평균 값이 10을 초과하면 오류를 표시합니다.

이 오류는 일반적으로 서버가 일정 기간 동안 응답하지 않아 메일 흐름이 느려지거나 중지되었음을 나타냅니다. 또한 이 서버에 연결된 Outlook 클라이언트에는 RPC cancel Request 대화 상자가 표시될 수 있습니다.

이 오류는 다음과 같은 원인으로 발생할 수 있습니다.

참고:
Microsoft Windows 2000 Server 운영 체제를 실행하는 컴퓨터에서 Output Queue Length 성능 카운터가 지속적으로 0보다 큰 임의의 값을 표시하는 경우도 있습니다. Output Queue Length 성능 카운터가 임의의 값을 표시할 수 있는 경우 및 이 문제 해결 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 834940 "시스템 모니터는 Windows 2000에서 큰 값의 Output Queue Length 성능 카운터를 표시할 수 있음"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834940)을 참조하십시오.
  • 컴퓨터의 NIC(네트워크 인터페이스 카드)가 네트워크 인프라에서 지원하는 최대 대역폭을 지원할 수 없습니다.

  • 서버의 로드가 너무 큽니다.

  • 바이러스 또는 스팸으로 인해 네트워크 사용 패턴이 급격히 상승하고 있습니다.

이 오류를 해결하려면 다음 단계를 수행하십시오.

  • NIC가 네트워크의 최대 대역폭을 지원하지 않으면 더 빠른 대역폭을 지원하도록 NIC를 업그레이드합니다.

  • 서버에서 로드를 줄입니다. 사서함 수가 더 적은 서버로 사서함을 이동하여 로드를 줄일 수 있습니다. 필요한 경우 사용자 환경에 추가 Exchange Server를 추가합니다.

  • 서버에 너무 많은 사서함이 있어서 지나치게 높은 로드가 발생하는 것이 아니라고 의심되는 경우에는 지나치게 높은 로드의 원인을 확인하고 중지해 보십시오.

다음 문서의 유용한 정보를 고려하십시오.

  • 네트워크 대역폭 고려 사항에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)의 "Exchange 성능 이해"에서 네트워크 성능을 참조하십시오.

  • 네트워크 문제 해결에 대한 자세한 내용은 Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)의 "Ruling Out Network-Bound Problems"를 참조하십시오.


주 DNS가 UDP 연결에 응답하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2007-03-16

Microsoft Exchange Analyzer Tool은 Win32_NetworkAdapterConfiguration Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리하여 DNSServerSearchOrder 특성을 얻습니다. 이 특성은 DNS 서버 쿼리에 사용되는 서버 IP 주소의 배열입니다.

주 DNS(Domain Name System) 서버의 주소를 검색한 후에 Exchange Analyzer는 각 Active Directory 디렉터리 서비스 서버용으로 구성된 DNS 서버에 대해 DNS 쿼리를 수행합니다. 이 연결은 UDP(User Datagram Protocol) 이름 확인 요청을 수행하고 결과를 분석하는 사용자 지정 개체 프로세서를 사용하여 이루어집니다.

UDP 이름 확인 요청이 실패하면 Exchange Analyzer는 경고를 표시합니다.

이 경고는 주 DNS 서버가 TCP 쿼리만을 수락하도록 구성되어 있을 수 있음을 나타냅니다.

SMTP(Simple Mail Transfer Protocol)는 Exchange Server의 메일 전송을 위한 기본 메일 프로토콜입니다. 그러므로 클라이언트에서는 SMTP를 사용하여 메시지를 보내고 Exchange 서버에서는 SMTP를 사용하여 메시지와 메시지 데이터를 배달합니다.

Exchange Server가 SMTP 서비스를 통해 아웃바운드 인터넷 메시지를 배달할 수 있도록 다음 방법을 통해 DNS를 사용합니다.

  1. 내부 사용자가 원격 도메인에 있는 받는 사람에게 메시지를 보냅니다.

  2. 받는 사람이 로컬 도메인에 있는지 원격 도메인에 있는지를 확인하기 위해 보낸 사람의 Exchange 서버에 있는 SMTP 가상 서버는 내부 전송 함수를 사용하여 받는 사람 주소에 대해 글로벌 카탈로그 서버를 쿼리합니다. 메시지의 받는 사람 주소가 받는 사람 정책에 없으면 해당 주소가 Active Directory에 저장되지 않습니다. 그러므로 Exchange는 해당 메시지를 원격 도메인의 받는 사람에게 보내는 것으로 간주합니다.

  3. 필요한 경우 Exchange 서버가 메시지를 해당 SMTP 가상 서버로 배달합니다.

  4. SMTP 가상 서버는 해당 IIS 메타베이스 정보를 사용하여 메시지를 원격 도메인으로 배달할 방법을 결정합니다.

  5. 그런 다음 Exchange 서버의 SMTP 가상 서버가 다음 두 작업 중 하나를 수행합니다.

    • DNS를 사용하여 대상 도메인의 IP 주소를 조회한 다음 메시지를 배달합니다.

    • DNS 확인 및 메시지 배달을 담당하는 스마트 호스트로 메시지를 전달합니다.

기본적으로 DNS 서버는 이름 확인 쿼리 등의 통신을 UDP 소켓 53에서 수신합니다.

Exchange Server의 SMTP 서비스가 UDP 쿼리만을 보내도록 구성되어 있으며 주 DNS 서버가 TCP 쿼리만을 수락하도록 구성되어 있는 경우 메일 라우팅이 실패하여 메일 흐름 성능이 저하될 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. DNS 서버가 시작되었으며 네트워크에 연결되어 있는지 확인합니다.

  2. 네트워크 방화벽 또는 패킷 필터가 UDP 포트 53 등의 알려진 DNS 포트를 차단하고 있지 않은지 확인합니다.

  3. 주 DNS 서버가 UDP 이름 확인 쿼리를 지원하도록 구성되어 있는지 확인합니다.

DNS 및 Exchange Server에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서 및 웹캐스트를 참조하십시오.

  • 322856, "Exchange Server에서 DNS를 사용할 수 있도록 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: Windows 2000 및 Exchange 2000 SMTP는 TCP DNS 쿼리를 사용한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "웹캐스트: Microsoft Exchange 2000 Server: 전송 시 DNS 문제 해결 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


기본 DNS 서버에 연결할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Win32_NetworkAdapterConfiguration Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 DNSServerSearchOrder 특성을 얻습니다. 이 특성은 DNS 서버 쿼리에 사용되는 서버 IP 주소의 배열입니다. 기본 DNS 서버 주소를 검색한 후 Exchange Server Analyzer는 서버의 포트 53에 대한 TCP 소켓 연결을 엽니다. 연결이 성공적일 경우 특정 문자열을 반환하는 사용자 지정 개체 프로세서를 사용하여 이 연결이 설정됩니다. Exchange Server Analyzer에서 반환되는 문자열의 부분으로 53 Available을 받지 못하면 경고를 표시합니다.

이 경고는 서버가 TCP 포트 53에서 연결 시도에 응답하지 않음을 나타냅니다. 기본적으로 DNS 서버는 이름 확인 쿼리와 같은 통신을 TCP 소켓 53에서 수신 대기합니다.

기본 DNS 서버에 연결할 수 없고 Exchange 2000 Server를 실행할 경우 메일 배달이 느려집니다. 기본 DNS 서버를 사용할 수 없을 경우 메시지가 예상보다 느리게 외부 받는 사람에게 전달되는 문제를 해결할 수 있는 핫픽스가 Microsoft에서 지원됩니다. 이 핫픽스를 얻으려면 Microsoft 기술 지원 서비스에 문의하십시오.

그리고 기본 DNS 서버를 사용할 수 없는 원인을 해결하거나 Exchange Server에서 DNS 설정을 변경하여 다른 DNS 서버로 이름을 확인할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. DNS 서버가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. PING 명령을 사용하여 DNS 서버의 연결 상태를 확인합니다.

기본 DNS 서버를 사용할 수 없는 경우의 느린 메일 배달에 대한 자세한 내용과 이 문제에 대한 핫픽스를 얻는 방법은 Microsoft 기술 자료 문서 829722, "Mail delivery is slow in Exchange 2000 when the primary DNS server is not available"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722)을 참조하십시오.

DNS 및 Exchange Server에 대한 자세한 내용은 다음 기술 자료 문서 및 웹캐스트를 참조하십시오.

  • 322856, "How to configure DNS for use with Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: Windows 2000 and Exchange 2000 SMTP Use TCP DNS Queries"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Support WebCast: Microsoft Exchange 2000 Server: DNS Troubleshooting in Transports"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


주 외부 DNS 서버가 TCP 연결에 응답하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2007-03-16

Microsoft Exchange Analyzer Tool은 각 Exchange Server 개체의 protocolCfgSMTPServer 클래스에서 msExchSMTPExternalDNSServers 특성 값을 확인하기 위해 Active Directory 디렉터리 서비스를 쿼리합니다. msExchSmtpExternalDNSServers 특성 값(설정되어 있는 경우)은 SMTP(Simple Mail Transfer Protocol) 가상 서버 인스턴스가 사용하는 외부 DNS(Domain Name System) 서버의 주소를 지정합니다.

주 외부 DNS 서버 주소를 검색한 후 Exchange Server Analyzer는 서버의 포트 53에 대한 TCP 소켓 연결을 엽니다. 이 연결은 연결이 성공적일 경우 특정 문자열을 반환하는 사용자 지정 개체 프로세서를 사용하여 이루어집니다. Exchange Server Analyzer는 반환되는 문자열에 53 Available이 없을 경우 경고를 표시합니다.

이 경고는 서버가 TCP 포트 53에서 연결 시도에 응답하지 않음을 나타냅니다. 기본적으로 DNS 서버는 이름 확인 쿼리와 같은 통신을 TCP 소켓 53에서 수신합니다.

SMTP는 Exchange Server의 메일 전송을 위한 기본 메일 프로토콜입니다. 그러므로 클라이언트에서는 SMTP를 사용하여 메시지를 보내고 Exchange 서버에서는 SMTP를 사용하여 메시지와 메시지 데이터를 배달합니다.

Exchange Server가 SMTP 서비스를 통해 아웃바운드 인터넷 메시지를 배달할 수 있도록 다음 방법을 통해 DNS를 사용합니다.

  1. 내부 사용자가 원격 도메인에 있는 받는 사람에게 메시지를 보냅니다.

  2. 받는 사람이 로컬 도메인에 있는지 원격 도메인에 있는지를 확인하기 위해 보낸 사람의 Exchange 서버에 있는 SMTP 가상 서버는 내부 전송 함수를 사용하여 받는 사람 주소에 대해 글로벌 카탈로그 서버를 쿼리합니다. 메시지의 받는 사람 주소가 받는 사람 정책에 없으면 해당 주소가 Active Directory에 저장되지 않습니다. 그러므로 Exchange는 해당 메시지를 원격 도메인의 받는 사람에게 보내는 것으로 간주합니다.

  3. 필요한 경우 Exchange 서버가 메시지를 해당 SMTP 가상 서버로 배달합니다.

  4. SMTP 가상 서버는 해당 IIS 메타베이스 정보를 사용하여 메시지를 원격 도메인으로 배달할 방법을 결정합니다.

  5. 그런 다음 Exchange 서버의 SMTP 가상 서버가 다음 두 작업 중 하나를 수행합니다.

    • DNS를 사용하여 대상 도메인의 IP 주소를 조회한 다음 메시지를 배달합니다.

    • DNS 확인 및 메시지 배달을 담당하는 스마트 호스트로 메시지를 전달합니다.

주 외부 DNS 서버에 연결할 수 없고 Exchange 2000 Server를 실행할 경우 메일 배달이 느려집니다. 주 외부 DNS 서버를 사용할 수 없을 경우 메시지가 예상보다 느리게 외부 받는 사람에게 배달되는 문제를 해결할 수 있는 핫픽스가 Microsoft에서 지원됩니다. 이 핫픽스를 얻으려면 Microsoft 기술 지원 서비스에 문의하십시오.

그리고 주 외부 DNS 서버를 사용할 수 없는 문제를 해결하거나 Exchange 서버에서 DNS 설정을 변경하여 다른 DNS 서버로 이름을 확인할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 외부 DNS 서버가 시작되었으며 Exchange 네트워크에 연결되어 있는지 확인합니다.

  2. PING 명령을 사용하여 외부 DNS 서버의 연결 상태를 확인합니다.

기본 DNS 서버를 사용할 수 없는 경우의 느린 메일 배달에 대한 자세한 내용과 이 문제에 대한 핫픽스를 얻는 방법은 Microsoft 기술 자료 문서 829722, "Mail delivery is slow in Exchange 2000 when the primary DNS server is not available"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722)을 참조하십시오.

DNS 및 Exchange Server에 대한 자세한 내용은 다음 기술 자료 문서 및 웹캐스트를 참조하십시오.

  • 322856, "Exchange Server에서 DNS를 사용할 수 있도록 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: Windows 2000 및 Exchange 2000 SMTP는 TCP DNS 쿼리를 사용한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "웹캐스트: Microsoft Exchange 2000 Server: 전송 시 DNS 문제 해결 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


주 외부 DNS가 UDP 연결에 응답하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2007-03-16

Microsoft Exchange Server Analyzer Tool은 각 Exchange Server 개체의 protocolCfgSMTPServer 클래스에서 msExchSMTPExternalDNSServers 특성 값을 확인하기 위해 Active Directory 디렉터리 서비스를 쿼리합니다. msExchSmtpExternalDNSServers 특성 값(설정되어 있는 경우)은 SMTP(Simple Mail Transfer Protocol) 가상 서버 인스턴스가 사용하는 외부 DNS(Domain Name System) 서버의 주소를 지정합니다.

주 외부 DNS 서버의 주소를 검색한 후에 Exchange Analyzer는 각 Active Directory 디렉터리 서비스 서버용으로 구성된 외부 DNS 서버에 대해 DNS 쿼리를 수행합니다. 이 연결은 UDP(User Datagram Protocol) 이름 확인 요청을 수행하고 결과를 분석하는 사용자 지정 개체 프로세서를 사용하여 이루어집니다.

UDP 이름 확인 요청이 실패하면 Exchange Analyzer는 경고를 표시합니다.

이 경고는 주 외부 DNS 서버가 TCP 쿼리만을 수락하도록 구성되어 있을 수 있음을 나타냅니다.

SMTP는 Exchange Server의 메일 전송을 위한 기본 메일 프로토콜입니다. 그러므로 클라이언트에서는 SMTP를 사용하여 메시지를 보내고 Exchange 서버에서는 SMTP를 사용하여 메시지와 메시지 데이터를 배달합니다.

Exchange Server가 SMTP 서비스를 통해 아웃바운드 인터넷 메시지를 배달할 수 있도록 다음 방법을 통해 DNS를 사용합니다.

  1. 내부 사용자가 원격 도메인에 있는 받는 사람에게 메시지를 보냅니다.

  2. 받는 사람이 로컬 도메인에 있는지 원격 도메인에 있는지를 확인하기 위해 보낸 사람의 Exchange 서버에 있는 SMTP 가상 서버는 내부 전송 함수를 사용하여 받는 사람 주소에 대해 글로벌 카탈로그 서버를 쿼리합니다. 메시지의 받는 사람 주소가 받는 사람 정책에 없으면 해당 주소가 Active Directory에 저장되지 않습니다. 그러므로 Exchange는 해당 메시지를 원격 도메인의 받는 사람에게 보내는 것으로 간주합니다.

  3. 필요한 경우 Exchange 서버가 메시지를 해당 SMTP 가상 서버로 배달합니다.

  4. SMTP 가상 서버는 해당 IIS 메타베이스 정보를 사용하여 메시지를 원격 도메인으로 배달할 방법을 결정합니다.

  5. 그런 다음 Exchange 서버의 SMTP 가상 서버가 다음 두 작업 중 하나를 수행합니다.

    • DNS를 사용하여 대상 도메인의 IP 주소를 조회한 다음 메시지를 배달합니다.

    • DNS 확인 및 메시지 배달을 담당하는 스마트 호스트로 메시지를 전달합니다.

기본적으로 DNS 서버는 이름 확인 쿼리 등의 통신을 UDP 소켓 53에서 수신합니다.

Exchange Server의 SMTP 서비스가 UDP 쿼리만을 보내도록 구성되어 있으며 주 외부 DNS 서버가 TCP 쿼리만을 수락하도록 구성되어 있는 경우 메일 라우팅이 실패하여 메일 흐름 성능이 저하될 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 외부 DNS 서버가 시작되었으며 네트워크에 연결되어 있는지 확인합니다.

  2. 네트워크 방화벽 또는 패킷 필터가 UDP 포트 53 등의 알려진 DNS 포트를 차단하고 있지 않은지 확인합니다.

  3. 주 외부 DNS 서버가 UDP 이름 확인 쿼리를 지원하도록 구성되어 있는지 확인합니다.

DNS 및 Exchange Server에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서 및 웹캐스트를 참조하십시오.

  • 322856, "Exchange Server에서 DNS를 사용할 수 있도록 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: Windows 2000 및 Exchange 2000 SMTP는 TCP DNS 쿼리를 사용한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "웹캐스트: Microsoft Exchange 2000 Server: 전송 시 DNS 문제 해결 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


기본 WINS 서버가 응답하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 WINSPrimaryServer 특성을 얻을 때 Win32_NetworkAdapterConfiguration Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 특성은 Exchange Server 컴퓨터용 기본 WINS(Windows Internet Name Service) 서버의 IP 주소입니다. Exchange Server Analyzer는 기본 WINS 서버의 주소를 검색한 후 서버에서 포트 137에 대한 TCP 소켓 연결을 엽니다. 연결이 성공적일 경우 특정 문자열을 반환하는 사용자 지정 개체 프로세서를 사용하여 이 연결이 설정됩니다. Exchange Server Analyzer는 반환되는 문자열에 137 Available이 없을 경우 경고를 표시합니다.

이 경고는 서버가 TCP 포트 137에서 연결 시도에 응답하지 않음을 나타냅니다. 기본적으로 WINS 서버는 이름 확인 쿼리와 같은 통신을 TCP 소켓 137에서 수신 대기합니다.

기본 WINS 서버에 연결할 수 없고 Exchange Server를 실행 중일 경우 메일 배달이 느려지며 특히 조직의 규모가 클 경우 더 느려집니다. 기본 WINS 서버를 사용할 수 없는 원인을 해결하거나 Exchange Server에서 WINS 설정을 변경하여 다른 WINS 서버로 이름을 확인할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. WINS 서버가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. PING 명령을 사용하여 WINS 서버의 연결 상태를 확인합니다.

Exchange 2000 Server 및 Exchange Server 2003에 WINS가 필요한 이유에 대한 자세한 내용은 Microsoft 기술 자료 문서 837391, "Exchange Server 2003 and Exchange 2000 Server require NetBIOS name resolution for full functionality"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=837391)를 참조하십시오.


포트 389가 응답하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory에 있는 모든 도메인 컨트롤러의 dNSHostName 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 도메인 컨트롤러 이름을 검색한 후 각 도메인 컨트롤러에서 포트 389에 대한 TCP 소켓 연결을 엽니다. 연결이 성공적일 경우 특정 문자열을 반환하는 사용자 지정 개체 프로세서를 사용하여 이 연결이 설정됩니다. Exchange Server Analyzer는 반환된 문자열의 일부로 389 Available을 받지 못할 경우 경고를 표시합니다.

이 경고는 도메인 컨트롤러가 TCP 포트 389에서 연결 시도에 응답하지 않았음을 나타냅니다. TCP 포트 389는 LDAP(Lightweight Directory Access Protocol) 통신에 필요한 기본 포트입니다.

이 경고는 Exchange Server Analyzer와 도메인 컨트롤러 간 연결 문제로 인해 발생할 수 있습니다. Exchange Server Analyzer가 도메인 컨트롤러를 쿼리할 때 도메인 컨트롤러가 LDAP 요청을 올바르게 처리하지 못하는 데는 여러 가지 이유가 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 도구를 실행하는 계정에 도메인 컨트롤러를 쿼리할 수 있는 권한이 있는지 확인합니다. 도메인 컨트롤러를 실행 중인 도메인에 사용자 수준의 사용 권한이 있어야 합니다. Exchange Server Analyzer를 실행하는 데 필요한 사용 권한에 대한 자세한 내용은 도구와 함께 제공되는 도움말 파일을 참조하십시오. Exchange Server Analyzer를 열고 Help를 클릭한 다음 Microsoft Exchange Server Analyzer Tool Help를 클릭하여 도움말 파일을 엽니다.

  2. Exchange Server Analyzer를 실행하는 컴퓨터와 응답하지 않는 도메인 컨트롤러 사이에 방화벽이나 포트 제한이 없는지 확인합니다.

  3. 도메인 컨트롤러가 네트워크에 연결된 상태이고 제대로 작동되는지 확인합니다.

Active Directory 연결 문제 해결 방법은 Microsoft 기술 자료 문서 816103, "HOW TO: Use Portqry to Troubleshoot Active Directory Connectivity Issues"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103)을 참조하십시오.

도메인 컨트롤러에서 Microsoft Windows® 시간을 구성하는 방법에 대한 자세한 내용은 기술 자료 문서 816042, "Windows Server 2003에서 권한을 보유한 시간 서버를 구성하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042)을 참조하십시오.


포트 636가 응답하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory에 있는 모든 도메인 컨트롤러의 dNSHostName 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 도메인 컨트롤러 이름을 검색한 후 각 도메인 컨트롤러에서 포트 636에 대한 TCP 소켓 연결을 엽니다. 연결이 성공적일 경우 특정 문자열을 반환하는 사용자 지정 개체 프로세서를 사용하여 이 연결이 설정됩니다. Exchange Server Analyzer는 반환된 문자열의 일부로 636 Available을 받지 못할 경우 경고를 표시합니다.

이 경고는 도메인 컨트롤러가 TCP 포트 636에서 연결 시도에 응답하지 않았다는 것을 나타냅니다. TCP 포트 636은 LDAP over SSL(Secure Lightweight Directory Access Protocol) 통신을 위한 기본 포트입니다.

Exchange 2000 Server 서비스 팩 3의 도입으로 Exchange Server는 Exchange Server 컴퓨터의 로컬 인증서 저장소에 올바른 인증서가 있는 경우 LDAP over SSL을 사용하여 연결됩니다. 이러한 인증서가 없는 경우 또는 도메인 컨트롤러가 Exchange 인증서를 신뢰하지 않거나 사용될 인증서가 강력한 키 보호를 요구하는 등의 인증서 관련 오류가 반환될 경우 Exchange Server는 SSL 없이 LDAP으로 자동 변경됩니다. 이 경고는 Exchange Server Analyzer와 도메인 컨트롤러 간 연결 문제로 인해 발생할 수 있습니다. PKI(공개 키 구조) 또는 기타 인증서 문제는 이 경고로 나타나지 않습니다.

Exchange Server Analyzer가 쿼리할 때 도메인 컨트롤러에서 LDAP over SSL 요청을 제대로 처리하지 못하는 이유는 많이 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 도구를 실행하는 계정에 도메인 컨트롤러를 쿼리할 수 있는 권한이 있는지 확인합니다. 도메인 컨트롤러가 실행 중인 도메인에서 사용자 수준 권한이 있어야 합니다. Exchange Server Analyzer를 실행하는 데 필요한 사용 권한에 대한 자세한 내용은 도구와 함께 제공되는 도움말 파일을 참조하십시오. Exchange Server Analyzer를 열고 Help를 클릭한 다음 Microsoft Exchange Server Analyzer Tool Help를 클릭하여 도움말 파일을 엽니다.

  2. Exchange Server Analyzer를 실행하는 컴퓨터와 응답하지 않는 도메인 컨트롤러 사이에 방화벽이나 포트 제한이 없는지 확인합니다.

  3. 도메인 컨트롤러가 네트워크에 연결되어 제대로 작동하고 있는지 확인합니다.

  4. Exchange Server Analyzer를 실행하는 컴퓨터의 시간과 응답에 실패한 도메인 컨트롤러의 시간이 동기화되었는지 확인합니다. 도메인 컨트롤러에서 Microsoft Windows® 시간 서비스가 중지되어 있거나 사용 가능하지 않은 경우 도메인 컨트롤러 로컬 시간이 동기화되지 않을 수 있습니다. 이 경우 도메인 컨트롤러는 시계가 동기화될 때까지 LDAP over SSL 요청에 응답하지 않습니다.

LDAP over SSL에 대한 자세한 내용은 Microsoft 기술 자료 문서 321051, "How to enable LDAP over SSL with a third-party Certification Authority"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321051)를 참조하십시오.

Active Directory 연결 문제 해결 방법은 기술 자료 문서 816103, "HOW TO: Use Portqry to Troubleshoot Active Directory Connectivity Issues"( (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103)를 참조하십시오.

Windows Time Service에 대한 자세한 내용은 기술 자료 문서 816042, "Windows Server 2003에서 권한을 보유한 시간 서버를 구성하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042)을 참조하십시오.


SMTP 서버가 X-LINK2STATE 동사를 지원하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange SMTP 동사가 올바르게 나열되었는지 확인할 때 Exchange 서버에서 SMTP 세션을 시작합니다. X-LINK2STATE 동사가 나열되지 않으면 경고가 표시됩니다.

X-LINK2STATE 동사는 Exchange에서 라우팅 마스터의 링크 상태 테이블을 업데이트하는 데 사용됩니다. 링크 상태 테이블은 Exchange 조직 전체의 SMTP 링크 상태에 대한 최신 정보를 기록합니다. Exchange는 메시지를 라우팅할 때 이 정보를 사용하여 리소스 소모가 가장 적고 신뢰할 수 있는 경로를 선택합니다. 이 기능은 지능형 라우팅이라고도 합니다.

X-LINK2STATE 동사는 Exchange에서 라우팅을 효율적으로 수행하기 위해 필요하며 다른 SMTP 공급자는 이 동사를 사용하지 않습니다. 이 기능은 Exchange 설치 프로그램에 의해 설치 및 등록되는 xlsasink.dll 파일을 통해 제공됩니다.

이 경고가 반환되는 이유로는 두 가지가 알려져 있습니다. 첫째로 관리자가 xlsasink.dll 파일이 제공하는 지능형 라우팅 기능과 관련된 문제를 해결하기 위해 이 파일을 사용하지 않도록 설정하는 경우가 있습니다. 이 경우는 바람직하지 않으며 성능 및 안정성 문제가 발생할 수 있습니다. 이 경우 해당 컴퓨터에서 Exchange를 다시 설치하여 xlsasink.dll 파일을 설치 및 등록하는 것이 좋습니다.

둘째로 자체 SMTP 프로토콜 스택을 설치하고 사용하여 메시지를 검색하는 바이러스 백신 제품을 실행하는 경우 이 경고가 반환될 수 있습니다. 이 경우 바이러스 백신 소프트웨어가 실행하는 자체 SMTP 스택이 Exchange SMTP 스택에 도달하기 전에 메시지를 차단하여 검색할 수 있습니다. 이때 바이러스 백신 SMTP 스택은 X-LINK2STATE 동사를 사용하지 않습니다. Exchange 서버에 자체 SMTP 스택을 설치하지 않는 모드로 바이러스 백신 소프트웨어를 실행하는 것이 좋습니다.

Exchange에서 사용되는 X-LINK2STATE 및 기타 고유 동사에 대한 자세한 내용은 Microsoft 기술 자료 문서 812455, "두 Exchange Server 간에 사용되는 동사의 정의"( (http://go.microsoft.com/fwlink/?LinkId=3052&kbid)를 참조하십시오.

Exchange 명령 동사를 확인하고 Exchange 2000 Server를 다시 설치하는 방법에 대한 자세한 내용은 기술 자료 문서 319885, "XCON: Messages Sent in the Exchange 2000 Server Organization Are Not Delivered"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885)를 참조하십시오.

Exchange 명령 동사를 확인하고 Exchange Server 2003을 다시 설치하는 방법에 대한 자세한 내용은 기술 자료 문서 822939, "Messages That Are Sent in the Exchange Server 2003 Organization Are Not Delivered"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939)를 참조하십시오.


SMTP 서버에서 메일 수락을 테스트하지 못했습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 작업을 수행하여 SMTP(Simple Mail Transfer Protocol) 도메인에 대한 전자 메일 관리자 계정으로 메시지 전송을 시도합니다.

  • SMTP 서버에 대한 소켓 연결을 엽니다. Exchange Server Analyzer가 응답 코드 220을 받으면 이 단계를 완료한 것으로 간주합니다.

  • EHLO SMTP 명령을 전송합니다. Exchange Server Analyzer가 250-X-LINK2STATE 및 250-XEXCH50을 포함하는 응답을 비롯해 일련의 응답 코드 250을 받으면 이 단계를 완료한 것으로 간주합니다.

  • MAIL FROM: ExBPA-MailAcceptTest@Fabrikam.com SMTP 명령을 전송합니다. Exchange Server Analyzer가 응답 코드 250을 받으면 이 단계를 완료한 것으로 간주합니다.

  • RCPT TO: Postmaster@<domainname>.com SMTP 명령을 전송합니다. Exchange Server Analyzer가 응답 코드 250을 받으면 이 단계를 완료한 것으로 간주합니다.

Exchange Server Analyzer가 단계를 모두 완료할 수 없으면 오류를 표시합니다. 이 오류는 일반적인 메일 전송 문제가 있음을 나타냅니다. 다음 링크는 서버 수준부터 시작해서 네트워크 수준까지 문제를 해결해야 하는 순서대로 나열되어 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange Server 2003 Transport and Routing Guide(http://go.microsoft.com/fwlink/?linkid=47579)의 "Troubleshooting Routing"을 참조하십시오.

  2. Microsoft 기술 자료 문서 324867, "Support WebCast: Microsoft Exchange 2000 Server: Troubleshooting Mail Flow Problems (Revisited)"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867)를 참조하십시오.

  3. Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"((http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)을 참조하십시오.

  4. Microsoft 기술 자료 문서 324759, "웹캐스트: Microsoft Exchange 2000 Server: 전송 시 DNS 문제 해결 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759)을 참조하십시오.

Exchange Server의 Postmaster 계정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 223860, "XCON: SMTP Postmaster Mailbox Must Be Set Manually"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860)

  • 313832, "HOWTO: Exchange 2000 Server에서 SMTP 전자 메일 관리자 계정 설정"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832)


SMTP 서버가 오픈 릴레이를 테스트하지 못했습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2007-03-14

Microsoft® Exchange Server Analyzer Tool은 다음 작업을 수행하여 SMTP(Simple Mail Transfer Protocol) 서버를 통해 메시지를 릴레이합니다.

  • SMTP 서버에 대한 소켓 연결을 엽니다. Exchange Server Analyzer가 응답 코드 220을 받으면 이 단계가 성공적으로 완료된 것으로 간주됩니다.

  • EHLO SMTP 명령 동사를 전송합니다. Exchange Server Analyzer가 250-X-LINK2STATE 및 250-XEXCH50을 포함하는 응답을 비롯해 일련의 응답 코드 250을 받으면 이 단계가 성공적으로 완료된 것으로 간주됩니다.

  • MAIL FROM: ExBPA-OpenRelayTest@Fabrikam.com SMTP 명령 동사를 전송합니다. Exchange Server Analyzer가 응답 코드 250을 받으면 이 단계가 성공적으로 완료된 것으로 간주됩니다.

  • RCPT TO: ExBPA-OpenRelayTest@Fabrikam.com SMTP 명령 동사를 전송합니다. Exchange Server Analyzer가 응답 코드 250을 받으면 이 단계가 성공적으로 완료된 것으로 간주됩니다.

또한 Exchange Server Analyzer는 OSProductSuite 키 값을 확인할 때 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키 값은 Windows Server 운영 체제의 특정 버전에 해당합니다.

Exchange Server Analyzer가 Microsoft Small Business Server 2000이나 Microsoft Windows Small Business Server 2003이 설치된 Exchagne Server 컴퓨터에서 모든 단계를 성공적으로 완료할 수 있는 경우 오류가 표시됩니다.

이 오류는 이 서버가 오픈 릴레이로 구성되어 있음을 나타냅니다.

오픈 릴레이는 허용하지 않는 것이 좋습니다.

오픈 릴레이는 전자 메일 서버가 릴레이된 전자 메일에 대한 제어나 제한 사항 없이 전자 메일 메시지가 시스템을 통해 릴레이되도록 허용할 때 발생합니다.

참고:
Exchange 조직에서 Fabrikam.com SMTP 도메인을 사용하면 이 오류가 발생할 수 있습니다. 이 오류가 발생하면 이 오류를 안전하게 무시할 수 있습니다. Fabrikam.com 도메인은 Microsoft Corporation의 소유이며 학습, 문서화 및 비슷한 목적으로 사용됩니다.

SMTP가 릴레이를 위해 설계되었던 것을 보면 릴레이가 원래 불필요한 기능은 아닙니다. 자세한 내용은 RFC 2821 문서 2.1 및 3.7 섹션(http://ietf.org)을 참조하십시오. 그러나 릴레이가 제어되지 않으면(제어되지 않는 호스트를 오픈 릴레이 호스트라고 함) 악의적인 사용자가 릴레이를 사용하여 원치 않는 상업성 벌크 메일 메시지(스팸 또는 UCE)를 보낼 수 있습니다. 악의적인 사용자는 중간 호스트로부터 떨어져서 이러한 원치 않는 메일 메시지를 바운스하여 사용 중인 ID를 확인하기 어렵게 만듭니다. 또한 릴레이 호스트의 리소스가 이러한 악의적인 메일 전송에 사용되기 때문에 릴레이 호스트가 올바른 전자 메일 메시지를 보내지 못할 수 있습니다. 특히 이러한 원치 않는 메일 메시지를 보내는 대부분의 사용자는 사용 중인 대역폭을 사용하지 않고도 엄청난 수의 받는 사람에게 단일 메시지를 보낼 수 있습니다.

인터넷 액세스 SMTP 가상 서버에서 익명 릴레이를 허용하지 마십시오. Exchange는 기본 구성에서 인증된 사용자만 메일을 릴레이할 수 있도록 허용합니다. 인증된 사용자만 Exchange를 사용하여 외부 도메인으로 메일을 보낼 수 있습니다. 인증되지 않은 사용자가 릴레이할 수 있도록 기본 릴레이 설정을 수정하거나 커넥터를 통한 도메인으로의 오픈 릴레이를 허용하면 인증되지 않은 사용자나 악의적인 웜이 사용자 Exchange 서버를 사용하여 스팸 메일을 보낼 수 있습니다. 서버가 차단 목록에 포함되어 올바른 원격 서버로 메일을 보내지 못할 수도 있습니다. 인증되지 않은 사용자가 Exchange 서버를 사용하여 메일을 릴레이하지 못하도록 하려면 기본 릴레이 제한 사항을 사용합니다.

릴레이를 해야 할 적합한 이유가 있을 경우에는 지침에 따라 구현 시 보안을 유지해야 합니다. 모든 기본값을 거부한 후 릴레이된 메일을 받을 IP 주소만 추가하고 인증된 사용자의 액세스를 사용할 수 없도록 하면 대부분 보안을 유지할 수 있습니다.

게이트웨이 서버에 대한 기본 제공 계정(로컬 관리자) 및 다른 사용자의 사용 방법을 검토하십시오. 어떤 종류의 릴레이에도 기본 제공 계정을 사용하는 경우는 거의 없습니다. 알려진 사용자나 컴퓨터가 게이트웨이 서버를 릴레이할 수도 있습니다. 릴레이 권한을 명시적 사용자와 컴퓨터 또는 IP 주소로 제한하는 것이 좋습니다.

릴레이할 수 있는 명시적 권한을 구성하면 서버의 보안이 더욱 강화됩니다. 악의적인 사용자는 무차별 대입(brute-force attack)을 통해 인터넷에서 발견된 사용자 계정이나 기본 제공 계정의 암호를 확보하여 사용자 서버를 스팸 프록시로 사용할 수 있습니다. 따라서 인터넷에서 액세스할 수 있는 컴퓨터에서 모든 인증된 컴퓨터에 릴레이를 허용하도록 기본 설정하는 것은 좋지 않습니다. 이 설정은 사용하지 않는 것이 좋습니다.

아래의 절차에서는 SMTP 가상 서버에 대한 인터넷 액세스가 가능한지 여부에 따라 익명 릴레이를 사용할 수 없도록 설정하는 방법을 설명합니다. 앞에서 언급된 것처럼 보안 위험을 이해하고 있고 조직에 적합한 경우에만 익명 릴레이를 사용해야 합니다. 이 문서 끝 부분의 참조에서 릴레이 사용 방법에 대한 자세한 내용을 제공합니다.

인터넷에서 SMTP 가상 서버에 액세스할 수 없으면 릴레이 구성을 기본값으로 다시 설정하는 것이 좋습니다. 재설정으로 SMTP 가상 서버는 인증된 컴퓨터의 내부 릴레이만 허용합니다.

인터넷에서 액세스할 수 있는 SMTP 가상 서버의 경우 기본 릴레이 구성을 추가적으로 보안하여 명시적 사용 권한을 가진 사용자와 컴퓨터에만 릴레이를 허용하는 것이 좋습니다.

Exchange가 릴레이를 차단하도록 구성되어 있지만 Exchange Server Analyzer에 이 오류가 계속 표시되면 방화벽, 바이러스 백신 또는 스팸 차단 소프트웨어와 같은 프록시 서버나 프로세스가 익명 릴레이를 허용하고 있는 것은 아닌지 확인해야 합니다.

내부 SMTP 가상 서버에서 익명 릴레이 구성을 기본 설정으로 다시 설정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 콘솔 트리에서 서버, 원하는 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. 릴레이 제한을 적용할 SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. <SMTP 가상 서버 >속성에서 액세스 탭을 클릭한 다음 릴레이를 클릭합니다.

  5. 릴레이 제한의 이 가상 서버를 통해 릴레이할 컴퓨터를 선택하십시오. 아래에서 아래 목록만 허용 확인란, 위 목록과 상관없이 인증한 모든 컴퓨터에 릴레이 허용 확인란를 차례로 선택한 다음 확인을 클릭합니다.

Exchange Server 2003에서 인터넷 액세스 SMTP 가상 서버에 대한 명시적 릴레이 사용 권한을 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 콘솔 트리에서 서버, 원하는 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. 릴레이 제한을 적용할 SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. <SMTP 가상 서버> 속성에서 액세스 탭을 클릭한 다음 릴레이를 클릭합니다.

  5. 릴레이 제한에서 위 목록과 상관없이 인증한 모든 컴퓨터에 릴레이 허용 확인란의 선택을 해제한 다음 사용자를 클릭하여 이 SMTP 가상 서버에 대한 릴레이 사용 권한을 부여하려는 사용자의 하위 집합을 지정합니다.

  6. 전송 및 릴레이 사용 권한에서 사용자나 그룹을 제거하려면 해당 사용자나 그룹을 선택한 다음 제거를 클릭합니다.

  7. 사용자나 그룹을 추가하려면 추가를 클릭한 다음 사용 권한을 지정할 사용자나 그룹을 선택합니다. 다음 옵션 중 하나를 선택합니다.

    • Microsoft Windows Server™ 2003의 경우 사용자, 컴퓨터 또는 그룹 선택의 선택할 개체 이름을 입력하십시오. 아래에 사용자나 그룹 이름을 입력합니다. 사용자나 그룹을 검색하려면 고급을 클릭하고 사용자나 그룹 이름을 검색한 다음 이름 확인을 클릭하여 항목을 확인합니다.

      팁:
      항목에 적합한 형식을 보려면 예제 링크를 클릭합니다.
    • Windows 2000 Server의 경우 사용자, 컴퓨터 또는 그룹 선택에서 전송 사용 권한을 부여하려는 사용자나 그룹을 선택한 다음 추가를 클릭합니다.

  8. 전송 및 릴레이 사용 권한 대화 상자로 되돌아가려면 확인을 클릭합니다.

  9. 그룹 또는 사용자 이름 목록에서 방금 추가한 그룹을 선택합니다.

  10. 전송 사용 권한 옆 <선택한 그룹>의 사용 권한에서 필요한 경우 선택한 사용자나 그룹이 SMTP 가상 서버를 통해 메일을 전송하도록 허용하려면 허용 아래 확인란을 선택합니다.

  11. 릴레이 사용 권한 옆에서 선택한 개체를 이 SMTP 가상 서버를 통해 릴레이하도록 허용하려면 허용 아래 확인란을 선택하고 선택한 개체를 이 가상 서버를 통해 릴레이할 수 없도록 차단하려면 거부 아래 확인란을 선택합니다.

    참고:
    릴레이 사용 권한을 허용하려면 전송 사용 권한을 허용해야 합니다.

  12. 확인을 클릭합니다.

Exchange 2000 Server의 인터넷 액세스 SMTP 가상 서버에서 릴레이 사용 권한을 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 콘솔 트리에서 서버, 구성할 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. 릴레이 제한을 적용할 SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. <SMTP 가상 서버> 속성에서 액세스 탭을 클릭한 다음 릴레이를 클릭합니다.

  5. 릴레이 제한의 이 가상 서버를 통해 릴레이할 컴퓨터를 선택하십시오. 아래에서 아래 목록만 허용을 선택합니다.

  6. 단일 컴퓨터, 컴퓨터 그룹 또는 SMTP 도메인 이름을 추가하려면 추가를 클릭한 다음 확인을 클릭합니다. 추가할 각 추가 항목에 대해 이 단계를 반복합니다.

  7. 위 목록과 상관없이 인증한 모든 컴퓨터에 릴레이 허용 확인란을 선택한 다음 확인을 클릭합니다.

메시지 릴레이 및 보안에 대한 자세한 내용은 Exchange Server 2003 기술 라이브러리에서 다음 가이드를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?linkid=26041)

  • Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지(http://go.microsoft.com/fwlink/?linkid=47587

Exchange 및 Microsoft Windows 환경에서 오픈 릴레이 동작의 테스트 및 보안에 대한 자세한 내용은 Microsoft 기술 자료 문서 304897, "XIMS: Microsoft SMTP 서버가 타사 테스트에서 전자 메일 메시지를 받고 릴레이할 수 있다"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=304897)를 참조하십시오.


실행 중인 SMTP 버전에서 XEXCH50 동사를 지원하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 네트워크 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange SMTP 동사가 올바르게 나열되었는지 확인할 때 Exchange 서버에서 SMTP 세션을 시작합니다. XEXCH50 동사가 나열되지 않을 경우 경고를 표시합니다.

여러 동사 중에서 XEXCH50 동사는 Exchange에서 공용 폴더 복제 작업에 사용됩니다. Exchange 서버에서 XEXCH50 동사를 지원하지 않는 SMTP 버전을 실행하면 공용 폴더 복제가 중단됩니다.

XEXCH50 동사는 다른 SMTP 공급자에서 사용하지 않으므로 이 기능은 Exchange 설치 프로그램에서 설치하고 등록하는 파일(peexch50.dll)에서 제공됩니다.

메시지 검색을 위해 자체 SMTP 프로토콜 스택을 설치하고 이 스택을 사용하는 바이러스 백신 제품을 실행할 경우 Exchange Server Analyzer에서 이 경고를 반환할 수 있습니다. 이 경우 바이러스 백신 소프트웨어는 메시지가 Exchange SMTP 스택에 도달하기 전에 메시지를 차단하고 검색하기 위해 자체 SMTP 스택을 사용합니다. 이러한 경우 바이러스 백신 소프트웨어의 SMTP 스택은 XEXCH50 동사를 사용하고 있지 않습니다.

Exchange 서버에 자체 SMTP 스택을 설치하거나 SMTP 네트워크의 수신 영역 내에서 그러한 소프트웨어를 실행하지 않아도 되는 모드에서 바이러스 백신 소프트웨어를 실행하는 것이 좋습니다. 바이러스 백신 소프트웨어의 SMTP 스택을 사용할 수 없게 설정한 상태에서도 이 경고가 나타나면 Exchange를 다시 설치하여 peexch50.dll을 올바르게 설치하고 등록합니다.

Exchange에서 독점적으로 사용되는 XEXCH50 및 다른 동사에 대한 자세한 내용은 Microsoft 기술 자료 문서 812455, "두 Exchange Server 간에 사용되는 동사의 정의"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455)를 참조하십시오.

Exchange 명령 동사를 표시하고 Exchange 2000 Server를 다시 설치하는 방법에 대한 자세한 내용은 기술 자료 문서 319885, "XCON: Messages Sent in the Exchange 2000 Server Organization Are Not Delivered"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885)를 참조하십시오.

Exchange 명령 동사를 확인하고 Exchange Server 2003을 다시 설치하는 방법에 대한 자세한 내용은 기술 자료 문서 822939, "Messages That Are Sent in the Exchange Server 2003 Organization Are Not Delivered"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939)를 참조하십시오.


프로토콜
Microsoft Exchange Server Analyzer - 문서 >

최근 수정된 항목: 2005-11-18

이 섹션의 문서에서는 Microsoft® Exchange Server Analyzer 도구가 평가하는 인터넷 프로토콜 관련 내용에 대해 자세히 설명합니다. 또한 이 문서에서는 Exchange Server Analyzer에서 발견하는 인터넷 프로토콜 관련 오류, 경고 및 기본이 아닌 구성을 해결하기 위해 사용자가 취해야 할 조치를 설명합니다.


Active Directory 왕복 응답 오류
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스 서버에서 반환된 StatusCode 키 값을 확인할 때 Win32_PingStatus Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Win32_PingStatus는 해당 클래스에서 보내는 ping 패킷에 대한 광범위한 세부 정보를 제공하는 24개 속성이 포함된 개체를 반환합니다.

Exchange Server Analyzer는 이 키 값이 다음 표에 있는 값 중 하나와 일치함을 확인하면 오류를 표시합니다.

Exchange Server Analyzer는 이 오류와 함께 반환된 Active Directory 서버 이름과 해당 StatusCode 값을 표시합니다.

StatusCode 값 의미 설명

11001

버퍼가 너무 작음

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하고 있기 때문에 반환되지 않을 수 있습니다.

11002

대상 네트에 연결할 수 없음

대상 컴퓨터가 포함된 네트워크에 연결할 수 없기 때문에 요청이 실패했습니다. 대상 컴퓨터에 대한 유효한 경로가 없습니다.

자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11003

대상 호스트에 연결할 수 없음

대상 컴퓨터에 연결할 수 없기 때문에 요청이 실패했습니다.

자세한 내용은 Active Directory 서버가 다운되었거나 연결할 수 없습니다.을 참조하십시오

또는 Exchange Server Analyzer가 실행 중인 위치와 대상 도메인 컨트롤러 사이에 있는 방화벽이나 DNS 오류로 인해 이 오류가 발생할 수 있습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11004

대상 프로토콜에 연결할 수 없음

대상 컴퓨터가 패킷 프로토콜에 응답하지 않기 때문에 요청이 실패했습니다.

Exchange Server Analyzer가 실행 중인 위치와 대상 도메인 컨트롤러 사이에 있는 방화벽으로 인해 이 오류가 발생할 수 있습니다.

11005

대상 포트에 연결할 수 없음

대상 컴퓨터의 포트를 사용할 수 없기 때문에 요청이 실패했습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11006

리소스 없음

네트워크 리소스가 부족하여 요청이 실패했습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11007

잘못된 옵션

잘못된 옵션이 있기 때문에 요청이 실패했습니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하고 있기 때문에 반환되지 않을 수 있습니다.

11008

하드웨어 오류

하드웨어 오류로 인해 요청이 실패했습니다.

컴퓨터 제조업체의 하드웨어 상태 확인 도구를 실행하여 도메인 컨트롤러가 적절하게 작동하는지 확인합니다.

11009

패킷이 너무 큼

요청이 포함된 패킷이 원본과 대상 사이에 있는 노드(라우터 또는 게이트웨이)의 최대 전송 단위(MTU)보다 크기 때문에 요청이 실패했습니다. MTU는 전송할 수 있는 최대 패킷 크기를 정의합니다.

Exchange Server Analyzer가 보낸 요청이 10KB보다 작습니다. 조직의 라우터와 게이트웨이가 적절하게 구성되어 있는지 확인합니다.

자세한 내용은 기술 자료 문서 159211, "블랙 홀(Black Hole) 라우터의 진단과 취급"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)을 참조하십시오.

11010

요청 시간 초과

할당된 시간 내에 회신을 받지 못했습니다. 회신에 허용된 기본 시간은 5초입니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11011

잘못된 요청

요청이 잘못 인코딩되었기 때문에 실패했습니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하고 있기 때문에 반환되지 않을 수 있습니다.

11012

잘못된 경로

원본과 대상 컴퓨터 간의 경로가 잘못되었기 때문에 요청이 실패했습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11013

TimeToLive 만료된 통과

TTL(Time to Live) 값이 0에 도달했기 때문에 요청이 실패했습니다. 이로 인해 전달하는 노드(라우터 또는 게이트웨이)가 패킷을 무시합니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11014

TimeToLive 만료된 리어셈블리

패킷이 전송될 수 있도록 조각으로 나뉘었으나 리어셈블리에 할당된 시간 내에 모든 조각이 수신되지 않았기 때문에 요청이 실패했습니다. RFC 2460(http://www.ietf.org/rfc/rfc2460.txt)은 모든 패킷 조각이 수신되어야 하는 시간 제한을 60초로 지정하고 있습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11015

매개 변수 문제

패킷 헤더를 처리하는 동안 노드(라우터 또는 게이트웨이)에 문제가 발생했기 때문에 요청이 실패했습니다. 예를 들어 헤더에 잘못된 필드 데이터나 인식되지 않는 옵션이 있는 경우 이러한 상황이 발생합니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하고 있기 때문에 반환되지 않을 수 있습니다.

11016

원본 중지

패킷이 무시되었기 때문에 요청이 실패했습니다. 이러한 경우는 원본 컴퓨터의 출력 대기열에 저장 공간이 부족하거나 패킷이 대상에 너무 빨리 도착하여 처리될 수 없을 때 발생됩니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하고 있기 때문에 반환되지 않을 수 있습니다.

11017

옵션이 너무 큼

잘못된 옵션이 있기 때문에 요청이 실패했습니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하고 있기 때문에 반환되지 않을 수 있습니다.

11018

잘못된 대상

대상 IP 주소가 PING 요청을 받을 수 없거나 IP 데이터그램의 대상 주소 필드에 나타나지 않아야 하기 때문에 요청이 실패했습니다.

Exchange Server Analyzer가 실행 중인 위치와 대상 도메인 컨트롤러 사이에 있는 방화벽으로 인해 이 오류가 발생할 수 있습니다.

11032

IPSEC 협상

IPsec 연결을 협상할 수 없기 때문에 요청이 실패했습니다.

11050

일반 오류

알 수 없는 이유로 요청이 실패했습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.


Active Directory에서 Exchange Server로의 왕복 응답 오류
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-05-15

Microsoft® Exchange Server Analyzer Tool은 Win32_PingStatus Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Active Directory®디렉터리 서비스 서버에서 반환된 StatusCode 키 값을 확인합니다. Win32_PingStatus는 클래스가 보내는 ping 패킷에 대한 상세한 정보를 제공하는 속성 24개가 있는 개체를 반환합니다.

Exchange Server Analyzer가 이 키 값이 다음 표에 있는 값 중 하나와 일치함을 확인하면 오류가 표시됩니다.

Exchange Server Analyzer는 이 오류와 함께 반환된 Active Directory 서버 이름, Exchange 서버 이름 및 해당 StatusCode 값을 표시합니다.

StatusCode 값 의미 설명

11001

버퍼가 너무 작음

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11002

대상 네트에 연결할 수 없음

대상 컴퓨터가 포함된 네트워크에 연결할 수 없기 때문에 요청이 실패했습니다. 대상 컴퓨터에 대한 유효한 경로가 없습니다.

자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11003

대상 호스트에 연결할 수 없음

대상 컴퓨터에 연결할 수 없기 때문에 요청이 실패했습니다.

자세한 내용은 Active Directory 서버가 다운되었거나 연결할 수 없습니다.를 참조하십시오.

또는 이 오류는 다음 조건 중 하나에 의해 발생할 수 있습니다.

  • Exchange Server Analyzer가 실행 중인 위치와 대상 도메인 컨트롤러 사이의 방화벽

  • DNS 오류

자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11004

대상 프로토콜에 연결할 수 없음

대상 컴퓨터가 패킷 프로토콜에 응답하지 않기 때문에 요청이 실패했습니다.

Exchange Server Analyzer가 실행 중인 위치와 대상 도메인 컨트롤러 사이에 있는 방화벽으로 인해 이 오류가 발생할 수 있습니다.

11005

대상 포트에 연결할 수 없음

대상 컴퓨터의 포트를 사용할 수 없기 때문에 요청이 실패했습니다.

자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11006

리소스 없음

네트워크 리소스가 부족하여 요청이 실패했습니다.

자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11007

잘못된 옵션

잘못된 옵션이 있기 때문에 요청이 실패했습니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11008

하드웨어 오류

하드웨어 오류로 인해 요청이 실패했습니다.

사용자의 컴퓨터 제조업체에서 제공하는 하드웨어 상태 확인 도구를 실행하여 도메인 컨트롤러가 적절하게 작동하는지 확인합니다.

11009

패킷이 너무 큼

요청이 포함된 패킷이 원본과 대상 사이에 있는 라우터 또는 게이트웨이 노드의 최대 전송 단위(MTU)보다 크기 때문에 요청이 실패했습니다. MTU는 전송할 수 있는 최대 패킷 크기를 정의합니다.

Exchange Server Analyzer가 보낸 요청이 10KB보다 작습니다. 조직의 라우터와 게이트웨이가 적절하게 구성되어 있는지 확인합니다.

자세한 내용은 Microsoft 기술 자료 문서 159211, "블랙 홀(Black Hole) 라우터의 진단과 취급"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)을 참조하십시오.

11010

요청 시간 초과

할당된 시간 내에 회신을 받지 못했습니다. 회신에 허용된 기본 시간은 5초입니다.

자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11011

잘못된 요청

요청이 잘못 인코딩되었기 때문에 실패했습니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11012

잘못된 경로

원본과 대상 컴퓨터 간의 경로가 잘못되었기 때문에 요청이 실패했습니다.

자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11013

TimeToLive 만료된 통과

TTL(Time to Live) 값이 0에 도달했으므로 요청이 실패했습니다. 이로 인해 전달 라우터 또는 게이트웨이 노드가 패킷을 무시합니다.

자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11014

TimeToLive 만료된 리어셈블리

패킷이 전송될 수 있도록 조각으로 나뉘었으나 리어셈블리에 할당된 시간 내에 모든 조각이 수신되지 않았기 때문에 요청이 실패했습니다. RFC 2460(http://www.ietf.org/rfc/rfc2460.txt)은 모든 패킷 조각이 수신되어야 하는 시간 제한을 60초로 지정하고 있습니다.

자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11015

매개 변수 문제

패킷 헤더를 처리하는 동안 라우터 또는 게이트웨이 노드에 문제가 발생했기 때문에 요청이 실패했습니다. 헤더에 잘못된 필드 데이터나 인식되지 않는 옵션이 있는 경우 이러한 상황이 발생합니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11016

원본 중지

패킷이 무시되었기 때문에 요청이 실패했습니다. 원본 컴퓨터의 출력 큐에 저장 공간이 부족한 경우 이러한 상황이 발생합니다. 또는 패킷이 대상에 너무 빨리 도착하여 처리될 수 없을 때 발생합니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11017

옵션이 너무 큼

잘못된 옵션이 있기 때문에 요청이 실패했습니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11018

잘못된 대상

다음 이유 중 하나로 인해 요청이 실패했습니다.

  • 대상 IP 주소가 PING 요청을 받을 수 없습니다.

  • 대상 IP 주소는 IP 데이터그램의 대상 주소 필드에 나타나지 않아야 합니다.

Exchange Server Analyzer가 실행 중인 위치와 대상 도메인 컨트롤러 사이에 있는 방화벽으로 인해 이 오류가 발생할 수 있습니다.

11032

IPSEC 협상

IPsec 연결을 협상할 수 없기 때문에 요청이 실패했습니다.

11050

일반 오류

알 수 없는 이유로 요청이 실패했습니다.

자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.


SMTP 가상 서버와 IMAP 및 POP 클라이언트의 전용 SMTP 가상 서버에 익명 액세스가 허용되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 개체에 대한 protocolCfgSMTPServer 클래스의 msExchAuthenticationFlags 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. protocolCfgSMTPServer 클래스에는 SMTP 가상 서버에 대한 설정이 포함되어 있습니다. msExchAuthenticationFlags 특성은 SMTP 서버에 허용되는 인증 형식을 나타냅니다. Exchange Server Analyzer는 다음 조건이 존재하는 경우 경고 메시지를 표시합니다.

  • SMTP 서버에 대한 익명 액세스를 허용하도록 msExchAuthenticationFlags 특성에 대한 인증이 구성되었습니다.

  • 서버에서 Microsoft Small Business Server 2000 또는 Microsoft Windows® Small Business Server 2003이 실행되고 있지 않습니다.

  • Exchange Server에서 20개가 넘는 사서함을 호스팅합니다.

보안을 강화하려면 인터넷 전자 메일을 받지 않는 내부 SMTP 가상 서버에 익명 액세스를 사용하지 마십시오. 보안을 강화하기 위해 원격 IMAP 및 POP 사용자의 전용 SMTP 가상 서버에 익명 액세스를 사용하지 않도록 할 수도 있습니다.

중요:
인터넷 브리지헤드 SMTP 가상 서버에 익명 액세스를 사용하지 마십시오. 인터넷으로부터 전자 메일을 수락하는 SMTP 가상 서버에서는 익명 액세스를 허용해야 합니다.

내부 메일을 보낼 때 조직의 Exchange 서버에서 서로 인증하여 메일을 보냅니다. 따라서 내부 SMTP 가상 서버에 익명 액세스를 사용하도록 설정하지 않아도 됩니다. 내부 서버에 익명 액세스를 금지하면 메일 흐름이 중단되지 않고 내부 SMTP 가상 서버에 추가 보안 계층이 제공됩니다.

마찬가지로 IMAP 및 POP 클라이언트를 SMTP 가상 서버에서 인증한 다음 SMTP 가상 서버에 메일을 보냅니다. 따라서 IMAP 및 POP 클라이언트의 전용 SMTP 가상 서버를 사용할 경우 이러한 서버가 인증된 액세스만 허용하도록 구성할 수 있습니다. 이 서버에서 익명 액세스를 사용할 수 없게 하면 권한이 없는 사용자가 서버에 액세스하는 것을 방지할 수 있습니다.

파트너 회사에 의한 인증처럼 업무상 이유로 SMTP 가상 서버에 인증된 액세스를 사용하지 않도록 설정할 수 없는 경우 다음 단계에 따라 게이트웨이 서버의 보안을 향상시킵니다.

  • 모든 사용자 계정, 특히 관리자 계정에 강력한 암호 정책을 실행합니다.

  • 게스트 계정을 사용하지 않습니다. 게스트 계정을 사용하지 않도록 설정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 320053, "How to rename the administrator and guest account in Windows 2000"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053)을 참조하십시오. 이 문서의 내용은 Windows 2000 Server에 적용되지만 유사한 원칙이 Windows Server 2003에도 적용됩니다.

SMTP 가상 서버에 대한 익명 액세스 인증을 사용하지 않으려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, <your inbound Exchange server>, 프로토콜, SMTP를 차례로 확장합니다.

  2. 인바운드 SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 액세스 탭을 클릭한 다음 인증을 클릭합니다.

  4. 인증에서 익명 액세스 확인란의 선택을 해제합니다.

인터넷 메일을 보다 안전하게 주고받을 수 있도록 Exchange Server 2003 조직을 구성하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)를 참조하십시오.


백그라운드 바이러스 백신 검색이 활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 백그라운드 바이러스 백신 검색의 사용 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Exchange Server Analyzer는 BackgroundScanning 값이 1로 설정되어 있는 경우 경고를 표시합니다.

BackgroundScanning 레지스트리 항목이 1로 설정되어 있으면 바이러스 백신 프로그램의 서명 파일이 업데이트될 때마다 모든 메시지가 백그라운드에서 다시 검색됩니다. 이와 같은 설정은 바이러스 백신 서명 파일이 업데이트될 때마다 성능에 막대한 영향을 줄 수 있으므로 Microsoft에서는 권장하지 않습니다.

VSAPI(Virus Scanning Application Programming Interface) 2.0 기반 바이러스 백신 프로그램을 사용할 경우 클라이언트가 메시지를 열려고 하면 메시지 본문과 첨부 파일이 현재 바이러스 서명 파일에 의해 검색되었는지 확인하기 위한 비교 작업이 수행됩니다. 현재 서명 패턴 파일이 내용 검색에 사용되지 않은 경우 해당하는 메시지는 클라이언트에서 사용하기 전에 바이러스 백신 프로그램으로 먼저 전송됩니다.

설치된 바이러스 백신 프로그램에 백그라운드 검색을 해제할 수 있는 사용자 인터페이스가 없으면 다음 절차에 따라 Exchange Server 컴퓨터의 레지스트리를 수정하여 이 동작을 제어할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. 오른쪽 창에서 BackgroundScanning 값을 두 번 클릭합니다.

  4. 값 데이터 필드에서 값을 0으로 변경합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스 및 바이러스 백신 소프트웨어 서비스를 다시 시작하여 변경 내용을 적용합니다.
  • 레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

  • Exchange에서 사용하는 바이러스 백신 검색 프로그램 종류에 대한 자세한 내용은 Microsoft 기술 자료 문서 328841, Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)를 참조하십시오.


CheckPop3Tail 값이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 다음 레지스트리 값이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\CheckPop3Tail

Exchange Server Analyzer는 CheckPop3Tail 값이 1로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

IETF(Internet Engineering Task Force) RFC(Request for Comments) 1939(http://www.ietf.org/rfc/rfc1939.txt)는 POP3 메시지에 대한 CRLF의 종료 시퀀스를 지정합니다. Exchange에서 CRLF 시퀀스는 POP3Tail로 참조됩니다. Microsoft Office Outlook® 2003이나 Microsoft Outlook Express 같은 POP3 클라이언트는 잘못된 POP3Tail(예: 손실된 CRLF)이 있는 잘못된 메시지를 만나면 응답을 중지하고 받은 편지함에 있는 모든 메시지를 다운로드하지 못합니다. CheckPop3Tail 레지스트리 값은 관리자가 Microsoft Exchange POP3 서비스에 지시하여 각 POP3 메시지의 POP3Tail을 확인하고 없는 경우 올바른 종료 시퀀스를 추가하도록 구성할 수 있음을 나타냅니다.

참고:
이 설정을 사용하면 잘못된 메시지를 수정하여 POP3 클라이언트가 해당 사용자의 사서함에 있는 메시지를 모두 다운로드할 수 있지만 각 메시지에 대해 적절한 POP3Tail가 있는지 확인하므로 성능이 약간 저하됩니다.

원할 경우 아래의 절차를 따라 CheckPop3Tail 레지스트리 값을 제거할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

CheckPop3Tail 레지스트리 값을 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters를 탐색합니다.

  3. CheckPop3Tail이라는 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange POP3 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

CheckPop3Tail 레지스트리 값 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 816896, "XCCC: 메시지를 다운로드하려고 하면 POP3 클라이언트가 응답하지 않거나 시간이 초과된다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816896)를 참조하십시오.


Defense Message System을 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 heuristics 특성이 Defense Message System을 사용하도록 구성되어 있는지 여부를 확인합니다. 기본적으로 heuristics 특성은 구성되어 있지 않습니다. Exchange Server Analyzer는 heuristics 특성이 256로 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

DMS(Defense Message System) 프로그램은 기록기-판독기 요구 사항을 만족하고, 비용과 인력 수준을 줄이고, 기능, 보안, 존속성 및 가용성을 개선하는 통합 공용 사용자 메시지 시스템의 개발을 촉진하고 돕기 위해 Under Secretary of Defense(Acquisition)에 의해 만들어졌습니다.

Defense Message System에 대한 자세한 내용은 Lockheed Martin 웹 사이트(http://www.lockheedmartin.com)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


MAPI 클라이언트 경고를 사용하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2007-05-01

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 MAPI 클라이언트 차단이 설정되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable MAPI Clients

Exchange Server Analyzer는 Disabled MAPI Clients 값이 -10, -11 또는 -12로 시작하는 값으로 설정된 경우 경고를 표시합니다.

기본적으로 Disable MAPI Clients 키가 사용되지 않습니다. 따라서 관리자가 특정 버전의 Microsoft Office Outlook®이 Exchange 2000 Server, Exchange Server 2003 또는 Exchange Server 2007을 실행하는 컴퓨터에 연결되지 못하도록 차단할 수 있습니다.

Disabled MAPI Clients 키가 -10, -11 또는 -12로 시작하는 값으로 설정되어 있으면 MAPI 버전의 전체 범위가 차단됩니다. 이 범위는 Outlook 2000, Outlook 2003 및 Outlook 2007 버전과 Exchange Server 2003의 Exchange System Attendant에 해당합니다. Exchange System Attendant 서비스를 차단하면 Exchange Server가 오작동하게 됩니다.

이 경고를 해결하려면 모든 버전의 Outlook에서 서버에 액세스할 수 있습니다.에 설명된 권장 사항과 절차를 따르십시오.

특정 MAPI 클라이언트가 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에 연결하지 못하도록 하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328240, "How to put server-side restrictions on clients that are used to access Exchange 2000 mailboxes"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • 288894, "XADM: MAPI 클라이언트를 해제하는 기능"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894)

특정 MAPI 클라이언트가 Exchange Server 2007을 실행하는 컴퓨터에 연결하지 못하도록 차단하는 방법은 Exchange Server 2007 제품 설명서의 Exchange 관리 셸 "Set-CasMailbox" cmdlet(http://go.microsoft.com/fwlink/?LinkId=80698)를 참조하십시오.

이전 버전의 Outlook용 보안 업데이트 다운로드 및 다른 버전의 Outlook을 차단하는 방법에 대한 자세한 내용은 Slowing and Stopping E-Mail Viruses in an Exchange Server 2003 Environment(http://go.microsoft.com/fwlink/?LinkId=30732)를 참조하십시오.


DisableSMTPMailboxAddressing 값이 설정됨
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-08-11

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP(Simple Mail Transfer Protocol) 사서함 주소 지정을 사용하지 않도록 값이 설정되었는지 확인합니다.

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\DisableSMTPMailboxAddressing

DisableSMTPMailboxAddressing 키의 값이 1이면 SMTP 사서함 주소 지정이 사용되지 않고(true) 값이 0이면 SMTP 사서함 주소 지정이 사용됩니다(false).

DisableSMTPMailboxAddressing 키의 값이 1로 설정되어 SMTP 사서함 주소 지정을 사용하지 않는 경우 Exchange Server Analyzer에서 경고를 표시합니다.

이 오류는 SMTP 사서함 주소 지정이 사용되지 않음을 나타냅니다. 이로 인해 이 서버에 연결하는 Microsoft Exchange ActiveSync 클라이언트에 대해 동기화 오류가 발생할 수 있습니다.

이 경고를 해결하려면 DisableSMTPMailboxAddressing 키의 값을 0으로 설정합니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
DisableSMTPMailboxAddressing 키의 값을 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA

  1. 오른쪽 창에서 DisableSMTPMailboxAddressing을 찾아 두 번 클릭합니다.

  2. 1에서 0으로 값을 변경합니다.

  3. 레지스트리 편집기를 닫고 Server 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

이 경고와 관련된 동기화 오류에 대한 자세한 내용은 Microsoft 기술 자료 문서 886346, "You receive an HTTP_500 error message when you synchronize your mobile device with Microsoft Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=886346)을 참조하십시오.


사용자 로드 분산
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer Tool에서 서버의 초당 RPC 작업 수가 높음을 확인했습니다.

서버의 초당 RPC 작업 수가 높은 경우 ExMon(Exchange Server User Monitor)을 사용하여 로드가 어떻게 분산되어 있는지 확인할 수 있습니다. 해당 로드가 다음 경우 중 하나에서 발생한 것인지 확인해야 합니다.

  • 활성 사용자 수가 비교적 적습니다.

  • 많은 사용자 간에 로드가 분산되어 있습니다.

한 명의 사용자가 로드의 많은 부분을 발생시키는 경우 높은 사용의 원인이 한 명의 사용자 때문이라는 내용의 경고를 Exchange Server Analyzer에서 표시합니다. 그렇지 않은 경우 로드가 여러 사용자 간에 분산되어 있다는 내용의 메시지를 표시합니다.

참고:
시간이 경과하면서 RPC 소통량은 바뀝니다. 따라서 사용자가 Exchange를 사용하는 방법에 대한 관련 데이터를 통계적으로 얻으려면 데이터를 여러 차례 수집해야 합니다.

또한 일부 공통 사용자 작업은 일반적으로 짧은 기간 동안 많은 양의 CPU 사용률을 소비합니다. 같은 사용자가 많은 양의 CPU 사용률을 자주 또는 장시간 소비하지 않는 한 이러한 작업에 대해 염려하지 않아도 됩니다.

참고:
높은 로드의 원인이 높은 로드가 예상되며, 많은 사용자에 대한 요청을 처리하고 개별 사용자보다 높은 로드를 생성하는 알려진 서비스 또는 프로세스일 경우 이 경고를 무시해도 됩니다. 모바일 장치를 동기화하는 일부 서비스, 약속 있음/없음을 관리하는 서버 프로세스, 음성 메일 또는 통합 메시징과 관련된 서비스 및 사용자를 이동하는 서버 프로세스는 개별 사용자보다 높은 로드를 발생시킬 수 있는 서버 또는 프로세스의 예입니다.
이 문제를 해결하려면 다음을 수행합니다.

  • 단일 사용자나 모든 사용자의 RPC 비율이 높은 경우 사용자가 사용자의 사서함과 전자 메일을 동기화하는 모바일 장치, 데스크톱 검색 엔진, 또는 타사 클라이언트 플러그인을 사용하고 있는지 확인합니다. 타사 응용 프로그램 문제 해결에 대한 자세한 내용은 클라이언트에 타사 추가 기능 해제를 참조하십시오.

  • 사용자의 기본 및 사용량이 많은 폴더에 항목이 5,000개 미만 있어야 합니다.

  • 사서함 크기는 1GB 이하여야 합니다. 높은 로드를 발생시키는 사용자의 경우 사서함 항목을 .pst 파일에 보관하도록 하는 것이 좋습니다. 그런 다음 Exchange Performance(Perfmon) 도구를 다시 실행하여 해당 사용자가 계속 높은 로드를 발생시키는지 확인합니다.

  • 해당 사용자에 연락하여 클라이언트 전자 메일 프로그램에 액세스 중인 클라이언트 응용 프로그램을 확인합니다. 이러한 응용 프로그램을 제거한 다음 한 번에 하나씩 다시 설치하여 서버에 미치는 영향을 관찰합니다.

  • 사용자 로드 문제를 해결할 때는 잘못 분석하는 경우가 많습니다. 따라서 로드가 높을 때 ExMon을 다시 실행하여 분석이 일관성이 있는지 확인하는 것이 좋습니다.

추가 정보

  • ExMon(Exchange Server User Monitor)을 다운로드하려면 Microsoft 다운로드 센터(http://go.microsoft.com/fwlink/?LinkId=54983)를 방문하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)을 참조하십시오.

  • Outlook 클라이언트 성능 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)를 참조하십시오.

  • 데스크톱 검색 소프트웨어에 대한 자세한 내용은 Microsoft 기술 자료 문서 905184, "Exchange 2000 Server and Exchange Server 2003 performance may be affected when desktop search engine software is running on Outlook or other MAPI client computers"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184)를 참조하십시오.


OMA 및 EAS에 대한 Exchange 가상 디렉터리 설정이 다시 정의되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange ActiveSync®에 대한 SMTP 프록시 주소의 다시 정의 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\ExchangeVDir

Exchange Server Analyzer는 ExchangeVDir 레지스트리 항목이 존재하며 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

ExchangeVDir 레지스트리 항목은 Microsoft Outlook® Mobile Access 및 Exchange ActiveSync에서 사용합니다. 이 값은 Outlook Mobile Access 및 Exchange ActiveSync에서 Exchange Server 2003 서식 파일용 Microsoft Office Outlook Web Access 및 사용자 사서함이 위치한 Exchange Server 2003 백 엔드 서버의 WebDAV 액세스에 사용하는 가상 디렉터리를 지정합니다.

ExchangeVDir 항목이 없거나 값이 설정되어 있지 않으면 /Exchange에 대한 기본값이 사용됩니다. 그렇지 않으면 여기에 "/"를 포함한 가상 디렉터리 이름이 포함됩니다. Outlook Mobile Access 또는 Exchange ActiveSync에 대한 가상 디렉터리를 지정할 때 이 값을 구성할 수 있습니다.

Exchange Server 2003에는 단일 Exchange Server 2003 컴퓨터 토폴로지에서 폼 기반 인증을 사용할 때 Exchange 모바일 서비스가 작동하지 않는다는 알려진 문제가 있습니다. Exchange Server 2003 백 엔드 서버의 /Exchange 가상 디렉터리가 SSL(Secure Sockets Layer)을 요구하도록 구성되어 있거나 폼 기반 인증을 사용하는 경우 Outlook Mobile Access는 이 가상 디렉터리에 액세스할 수 없습니다. 이 문제는 프런트 엔드 서버의 /Exchange 가상 디렉터리에 이러한 설정이 활성화되어 있는 경우에는 발생하지 않습니다.

ExchangeVDir 레지스트리 값을 구성하여 이 문제를 해결할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. ExchangeVDir 값을 검사하고 필요한 경우 변경합니다.

  4. 레지스트리 편집기를 닫습니다. 레지스트리 내용을 변경했으면 Exchange Server 컴퓨터를 다시 시작해야 변경 내용이 적용됩니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

이 문제 해결 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 817317, "Mapping Multiple Proxy Addresses to Multiple Back-End Virtual Root Directories on the Same Server Is Not Supported"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=817317)를 참조하십시오.


Exchange 바이러스 검색 API 호환 제품이 검색되었지만 현재 활성화되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange 컴퓨터에서 바이러스 검색 응용 프로그램 인터페이스(VSAPI) 호환 소프트웨어가 사용할 수 있게 설정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

또한 Exchange Server Analyzer는 확장 가능한 저장소 엔진(ESE)이라고도 불리는 Exchange 데이터베이스 저장소 엔진(Ese.dll)의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

마지막으로 Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 5.5"가 있으면 해당 컴퓨터에 Microsoft Exchange Server 5.5가 실행 중입니다. 문자열 값에 "Version 6.0"이 있으면 해당 컴퓨터에 Microsoft Exchange Server 2000 Server가 실행 중입니다. 문자열 값에 "Version 6.5"가 있으면 해당 컴퓨터에 Microsoft Exchange Server 2003이 실행 중입니다.

Version 값에 하위 문자열 6이 해당 버전 정보의 일부로 포함되어 있지 않지만 serialNumber 값이 Exchange 2000 Server나 Exchange Server 2003이 설치되었음을 나타내면 해당 Exchange Server에 Exchange가 아닌 ESE 버전이 실행되고 있는 것입니다.

Exchange Server Analyzer는 비Exchange 버전의 ESE가 실행되지 않고 VirusScan \Enabled 레지스트리 키 값이 0이면 경고를 표시합니다. Exchange Server에서 Exchange가 아닌 ESE 버전이 실행 중이면 다른 경고를 표시합니다.

일반적으로 SMTP(Simple Mail Transfer Protocol) 게이트웨이나 사서함을 호스팅하는 Exchange Server 컴퓨터에는 메시징 시스템용으로 설계된 바이러스 백신 소프트웨어를 배포하는 것이 좋습니다. 최상의 보호를 위해 게이트웨이에는 인바운드 MIME 메시지를 검색하는 바이러스 백신 소프트웨어를 실행하고 Exchange Server 컴퓨터에는 VSAPI2.0(Exchange 2000 Server)이나 VSAPI 2.5(Exchange Server 2003)를 사용하는 검색 프로그램을 실행합니다.

또한 클라이언트 컴퓨터에는 바이러스 백신 소프트웨어를 실행해야 합니다. 게이트웨이나 Exchange 서버에서 메시징 시스템용 바이러스 백신 소프트웨어(MIME을 구문 분석 및 검색할 수 있음을 의미함)를 실행하는 경우 클라이언트 컴퓨터에서 파일 수준의 바이러스 백신 프로그램만 실행해도 충분합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 바이러스 백신 소프트웨어 프로그램 사용자 인터페이스에서 VSAPI 검색을 사용할 수 있게 설정합니다.

  2. VSAPI 검색을 사용할 수 있게 설정한 후에도 문제가 계속 발생하면 해당 바이러스 백신 소프트웨어 공급업체에 도움을 요청하십시오.

Microsoft Exchange Server 2003에서 일반적으로 사용되는 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 823166, "XADM: Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)를 참조하십시오.

Microsoft Exchange 2000 Server에서 일반적으로 사용되는 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 328841, "Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)를 참조하십시오.

전자 메일로 전송되는 바이러스 및 웜에 대비한 Exchange 환경 보안에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.


Exchange 바이러스 검색 API 호환 제품이 검색되었지만 올바르게 설치되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 컴퓨터에 실행 중인 VSAPI(Virus Scanning Application Programming Interface) 호환 소프트웨어에서 올바른 라이브러리를 참조하는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Exchange Server Analyzer는 Library 값에 올바른 VSAPI 바이러스 백신 라이브러리 파일(DLL) 경로가 없을 경우 경고를 표시합니다.

일반적으로 SMTP(Simple Mail Transfer Protocol) 게이트웨이나 사서함을 호스팅하는 Exchange Server 컴퓨터에는 메시징 시스템용으로 설계된 바이러스 백신 소프트웨어를 배포하는 것이 좋습니다. 최상의 보호를 위해 게이트웨이에는 인바운드 MIME 메시지를 검색하는 바이러스 백신 소프트웨어를 실행하고 Exchange Server 컴퓨터에는 VSAPI2.0(Exchange 2000 Server)이나 VSAPI 2.5(Exchange Server 2003)를 사용하는 검색 프로그램을 실행합니다.

또한 클라이언트 컴퓨터에는 바이러스 백신 소프트웨어를 실행해야 합니다. 게이트웨이나 Exchange 서버에서 메시징 시스템용 바이러스 백신 소프트웨어(MIME을 구문 분석 및 검색할 수 있음을 의미함)를 실행하는 경우 클라이언트 컴퓨터에서 파일 수준의 바이러스 백신 프로그램만 실행해도 충분합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 바이러스 백신 소프트웨어를 제거하고 다시 설치합니다.

  2. 소프트웨어를 다시 설치한 후에도 문제가 계속 발생하면 바이러스 백신 소프트웨어 공급업체에 도움을 요청합니다.

Microsoft Exchange Server 2003에서 일반적으로 사용되는 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 823166, "XADM: Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)를 참조하십시오.

Microsoft Exchange 2000 Server에서 일반적으로 사용되는 바이러스 검색 프로그램에 대한 자세한 내용은 기술 자료 문서 328841, "Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)를 참조하십시오.

전자 메일로 전송되는 바이러스 및 웜에 대비한 Exchange 환경 보안에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.


Exchange 바이러스 검색 API의 스레드 수가 부족합니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 ScanningThreads 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

ScanningThreads 레지스트리 값은 검색에 할당된 최대 VSAPI(바이러스 검색 API) 스레드 수를 나타냅니다.

또한 Exchange Server Analyzer는 다음 레지스트리 항목을 읽어 VSAPI 메시지 검색을 사용할 수 있는지 확인합니다.

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 값이 1이면 VSAPI 검색이 사용됨을 나타냅니다. 값 0은 VSAPI 검색이 사용되지 않음을 나타냅니다.

또한 Exchange Server Analyzer는 NumberOfProcessors 키 값을 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 값은 컴퓨터에 설치된 프로세서 수를 나타내고 실제 프로세서와 논리 프로세서를 모두 포함합니다. Intel의 하이퍼 스레딩 기술을 사용하면 실제 프로세서를 두 개의 논리 프로세서로 분할할 수 있습니다.

Exchange Server Analyzer는 VSAPI 검색이 설정된 Exchange Server 컴퓨터에서 ScanningThreads 값이 (2 x NumberOfProcessors) + 1보다 작을 경우 경고를 표시합니다. ScanningThreads의 최적 값은 (2 x NumberOfProcessors) + 1과 같습니다. 예를 들어 두 개의 프로세서가 있는 Exchange Server 컴퓨터에서 ScanningThreads의 최적 값은 5입니다.

참고:
하이퍼 스레딩을 사용할 수 있는 경우 NumberOfProcessors의 값은 실제 프로세서 수의 두 배가 됩니다. 실제 또는 논리 프로세서가 위 공식에서 사용되는 경우 바이러스 백신 소프트웨어 제조업체에 문의하는 것이 좋습니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan을 탐색합니다.

  3. 오른쪽 창에서 ScanningThreads를 두 번 클릭합니다.

  4. 위의 수식에서 반환된 값을 입력합니다.

  5. 레지스트리 편집기를 닫은 다음 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

하이퍼 스레딩 기술에 대한 자세한 내용은 Intel 웹 사이트(http://www.intel.com/technology/hyperthread)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


SMTP에 외부 DNS 서버가 사용되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 Exchange Server 개체에 대한 protocolCfgSMTPServer 클래스의 msExchSMTPExternalDNSServers 특성 값을 확인합니다. protocolCfgSMTPServer 클래스에는 SMTP 가상 서버에 대한 설정이 포함되어 있습니다. msExchSMTPExternalDNSServers 특성이 설정되면 SMTP 가상 서버가 외부 DNS 서버를 사용합니다. Exchange Server Analyzer는 msExchSMTPExternalDNSServers 특성이 설정되어 있으면 경고를 표시합니다.

외부 DNS 서버를 사용하도록 SMTP 가상 서버를 구성하면 성능이 저하될 수 있습니다. 따라서 이렇게 구성하지 않는 것이 좋습니다.

SMTP 가상 서버에서 외부 DNS 설정을 변경하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, <인바운드 Exchange 서버>, 프로토콜 및 SMTP를 차례로 확장합니다.

  2. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 배달 탭을 클릭한 다음 고급을 클릭합니다.

  4. 구성을 클릭하여 외부 DNS 서버를 구성합니다.

  5. 외부 DNS 서버를 추가하려면 추가를 클릭하고 추가 대화 상자에 외부 DNS 서버의 IP 주소를 입력한 다음 확인을 클릭합니다.

  6. 외부 DNS 서버를 제거하려면 IP 주소를 선택한 다음 제거를 클릭합니다.

  7. 확인를 클릭합니다.

Exchange Server 2003 조직에서 DNS를 구성하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "DNS 구성"을 참조하십시오.

Exchange에서 인터넷 도메인에 연결하도록 SMTP 커넥터를 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 "How To Configure the SMTP Connector to Link to Internet Domains in Exchange"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=319426)를 참조하십시오.


프런트 엔드 서버에서 기본 인증을 사용하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 프런트 엔드 서버와 백 엔드 서버 사이에 기본 인증이 구성되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\CurrentControlSet\Services\MSExchangeWeb\DAV\UseBasicAuthToBE

Exchange Server Analyzer는 UseBasicAuthToBE 키가 설정되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Exchange Server 2003 프런트 엔드 서버는 Kerberos 인증을 사용하여 프런트 엔드 서버와 백 엔드 서버 사이의 사용자 자격 증명을 보호합니다. Kerberos 인증이 실패하면 경고 이벤트가 기록되고 프런트 엔드 서버가 NTLM을 대신 시도합니다. NTLM이 실패하면 오류가 기록됩니다. 30분 후 Kerberos가 다시 시도됩니다. Exchange 2000 Server 또는 Exchange Server 2003 프런트 엔드 컴퓨터가 Exchange 2000 Server 백 엔드 컴퓨터를 사용하여 인증할 경우 NTLM이 사용됩니다.

UseBasicAuthToBE 레지스트리 키를 설정하면 이러한 기본 논리를 무시하고 Exchange 프런트 엔드 서버는 백 엔드 서버와의 모든 통신에 기본 인증을 사용합니다. Exchange 조직에 1,000개를 초과하는 사서함 저장소가 있는 경우 이 레지스트리 키를 설정해야 합니다. 사서함 저장소가 1,000개를 넘는 조직에서는 프런트 엔드 서버를 통해 Exchange Server 2003용 Microsoft Office Outlook® Web Access에서 사서함에 액세스하는 사용자가 사서함에 액세스할 수 없는 문제가 알려져 있습니다.

사서함 저장소가 1,000개 이하이고 기본 인증을 적용하지 않아도 되면 UseBasicAuthToBE 레지스트리 키를 삭제하는 것이 좋습니다.

기본 인증은 자격 증명을 일반 텍스트로 보냅니다. UseBasicAuthToBE 레지스트리 키를 설정하고 Exchange 프런트 엔드 서버를 실행 중이면 IPSec 암호화를 사용하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

UseBasicAuthToBE 레지스트리 키를 삭제하려면 다음을 수행합니다.

  1. Exchange 프런트 엔드 서버에서 Regedit.exe 또는 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Service\MSExchangeWeb\Dav\ UseBasicAuthToBE를 탐색합니다.

  3. UseBasicAuthToBE를 마우스 오른쪽 단추로 클릭하고 삭제를 클릭한 다음 예를 클릭합니다.

  4. 서비스 MMC 스냅인을 열고 IIS Admin Service를 마우스 오른쪽 단추로 클릭한 다음 다시 시작을 클릭합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


게이트웨이 서버 PING이 실패했습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 Win32_PingStatus Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 비Exchange 게이트웨이 서버에서 반환된 StatusCode 키 값을 확인합니다. Win32_PingStatus는 클래스가 보내는 ping 패킷에 대한 상세한 정보를 제공하는 속성 24개가 있는 개체를 반환합니다.

Exchange Server Analyzer가 이 키 값이 다음 표에 있는 값 중 하나와 일치함을 확인하면 오류가 표시됩니다.

Exchange Server Analyzer는 이 오류와 함께 반환된 게이트웨이 서버 이름, Exchange 서버 이름 및 해당 StatusCode 값을 표시합니다.

StatusCode 값 의미 설명

11001

버퍼가 너무 작음

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11002

대상 네트에 연결할 수 없음

대상 컴퓨터가 포함된 네트워크에 연결할 수 없기 때문에 요청이 실패했습니다. 대상 컴퓨터에 대한 유효한 경로가 없습니다.

자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11003

대상 호스트에 연결할 수 없음

대상 컴퓨터에 연결할 수 없기 때문에 요청이 실패했습니다.

자세한 내용은 Active Directory 서버가 다운되었거나 연결할 수 없습니다.를 참조하십시오.

또는 이 오류는 다음 조건 중 하나에 의해 발생할 수 있습니다.

  • Exchange Server Analyzer가 실행 중인 위치와 대상 도메인 컨트롤러 사이의 방화벽

  • DNS 오류

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11004

대상 프로토콜에 연결할 수 없음

대상 컴퓨터가 패킷 프로토콜에 응답하지 않기 때문에 요청이 실패했습니다.

Exchange Server Analyzer가 실행 중인 위치와 대상 도메인 컨트롤러 사이에 있는 방화벽으로 인해 이 오류가 발생할 수 있습니다.

11005

대상 포트에 연결할 수 없음

대상 컴퓨터의 포트를 사용할 수 없기 때문에 요청이 실패했습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11006

리소스 없음

네트워크 리소스가 부족하여 요청이 실패했습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11007

잘못된 옵션

잘못된 옵션이 있기 때문에 요청이 실패했습니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11008

하드웨어 오류

하드웨어 오류로 인해 요청이 실패했습니다.

사용자의 컴퓨터 제조업체에서 제공하는 하드웨어 상태 확인 도구를 실행하여 도메인 컨트롤러가 적절하게 작동하는지 확인합니다.

11009

패킷이 너무 큼

요청이 포함된 패킷이 원본과 대상 사이에 있는 라우터 또는 게이트웨이 노드의 최대 전송 단위(MTU)보다 크기 때문에 요청이 실패했습니다. MTU는 전송할 수 있는 최대 패킷 크기를 정의합니다.

Exchange Server Analyzer가 보낸 요청이 10KB보다 작습니다. 조직의 라우터와 게이트웨이가 적절하게 구성되어 있는지 확인합니다.

자세한 내용은 기술 자료 문서 159211, "블랙 홀(Black Hole) 라우터의 진단과 취급"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)을 참조하십시오.

11010

요청 시간 초과

할당된 시간 내에 회신을 받지 못했습니다. 회신에 허용되는 기본 시간은 5초입니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11011

잘못된 요청

요청이 잘못 인코딩되었기 때문에 실패했습니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11012

잘못된 경로

원본과 대상 컴퓨터 간의 경로가 잘못되었기 때문에 요청이 실패했습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11013

TimeToLive 만료된 통과

TTL(Time to Live) 값이 0에 도달했으므로 요청이 실패했습니다. 이로 인해 전달 라우터 또는 게이트웨이 노드가 패킷을 무시합니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11014

TimeToLive 만료된 리어셈블리

패킷이 전송될 수 있도록 조각으로 나뉘었으나 리어셈블리에 할당된 시간 내에 모든 조각이 수신되지 않았기 때문에 요청이 실패했습니다. RFC 2460(http://www.ietf.org/rfc/rfc2460.txt)은 모든 패킷 조각이 수신되어야 하는 시간 제한을 60초로 지정하고 있습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11015

매개 변수 문제

패킷 헤더를 처리하는 동안 라우터 또는 게이트웨이 노드에 문제가 발생했기 때문에 요청이 실패했습니다. 헤더에 잘못된 필드 데이터나 인식되지 않는 옵션이 있는 경우 이러한 상황이 발생합니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11016

원본 중지

패킷이 무시되었기 때문에 요청이 실패했습니다. 원본 컴퓨터의 출력 큐에 저장 공간이 부족한 경우 이러한 상황이 발생합니다. 또는 패킷이 대상에 너무 빨리 도착하여 처리될 수 없을 때 발생합니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11017

옵션이 너무 큼

잘못된 옵션이 있기 때문에 요청이 실패했습니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11018

잘못된 대상

다음 이유 중 하나로 인해 요청이 실패했습니다.

  • 대상 IP 주소가 PING 요청을 받을 수 없습니다.

  • 대상 IP 주소는 IP 데이터그램의 대상 주소 필드에 나타나지 않아야 합니다.

Exchange Server Analyzer가 실행 중인 위치와 대상 도메인 컨트롤러 사이에 있는 방화벽으로 인해 이 오류가 발생할 수 있습니다.

11032

IPSEC 협상

IPsec 연결을 협상할 수 없기 때문에 요청이 실패했습니다.

11050

일반 오류

알 수 없는 이유로 요청이 실패했습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.


IIS 6.0 MaxFieldLength 매개 변수가 잘못 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 HTTP 요청에 대한 최대 필드 길이가 레지스트리에 하드 코드되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxFieldLength

또한 Exchange Server Analyzer는 다음 레지스트리 항목을 검사하여 대상 컴퓨터에서 실행 중인 Microsoft Windows® 운영 체제 버전을 확인합니다.

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값이 4.0이면 해당 컴퓨터가 Microsoft Windows NT® Server 4.0을 실행하고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터에 Microsoft Windows 2000 Server 운영 체제가 실행되고 있음을 나타내고 값 5.2는 해당 컴퓨터에 Microsoft Windows Server™ 2003 운영 체제가 실행되고 있음을 나타냅니다.

끝으로 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스에서 Exchange_Server WMI(Windows Management Instrumentation) 클래스를 조사하여 IsFrontEndServer 키 값을 확인합니다. 값이 False이면 Exchange Server 컴퓨터가 프런트 엔드 서버가 아님을 나타냅니다. 값이 True이면 Exchange Server 컴퓨터가 프런트 엔드 서버임을 나타냅니다.

Exchange Server Analyzer는 다음 조건에 해당하는 Exchange 백 엔드 서버의 MaxFieldLength 값이 32768로 설정되어 있으면 경고를 표시합니다.

  • Exchange 백 엔드 서버에서 Windows Server 2003을 실행 중입니다.

  • Exchange 백 엔드 서버가 프런트 엔드 서버로 구성되어 있지 않습니다.

  • Exchange 백 엔드 서버에 500개가 넘는 사서함이 있습니다.

MaxFieldLength IIS 레지스트리 매개 변수는 기본적으로 존재하지 않으며 개별 HTTP 클라이언트 요청의 최대 크기를 지정합니다. 이 값은 대체로 함께 사용되는 값인 MaxRequestBytes와 연결되어 설정됩니다. 규모가 더 큰 환경에서 이 값이 32768로 설정되어 있지 않으면 Exchange Server용 Microsoft Office Outlook® Web Access 사용자는 로그온에 실패할 수 있습니다. 특히 이 값들이 존재하지 않으면 HTTP 400 - 잘못된 요청 오류가 발생할 수 있습니다. MaxFieldLength 레지스트리 값을 구성할 때 75개가 넘는 그룹의 구성원인 사용자가 Outlook Web Access에 로그온할 수 있도록 MaxRequestBytes 매개 변수를 32768로 설정해야 합니다. MaxRequestBytes 레지스트리 값에 따라 요청 라인 및 헤더의 총 최대 크기가 결정됩니다. 해당 값이 MaxFieldLength보다 낮으면 MaxFieldLength 값이 조정됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

MaxRequestBytes와 MaxFieldLength 매개 변수를 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. Parameters를 마우스 오른쪽 단추로 클릭하고 새로 만들기 | DWORD 값을 클릭한 다음 값의 이름을 MaxFieldLength로 지정합니다.

  4. Parameters를 마우스 오른쪽 단추로 클릭하고 새로 만들기 | DWORD 값을 클릭한 다음 값의 이름을 MaxRequestBytes로 지정합니다.

  5. 오른쪽 창에서 MaxFieldLength를 두 번 클릭한 다음 그 값을 32768(10진수)로 설정합니다.

  6. 오른쪽 창에서 MaxRequestBytes를 두 번 클릭한 다음 그 값을 32768(10진수)로 설정합니다.

  7. 레지스트리 편집기를 닫고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

IIS(인터넷 정보 서비스)의 HTTP 레지스트리 설정에 대한 자세한 내용은 기술 자료 문서 820129, INF: IIS에 대한 Http.sys 레지스트리 설정"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129)을 참조하십시오.


IIS 6.0 MaxRequestBytes 매개 변수가 잘못 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 HTTP 요청의 최대 크기가 레지스트리에 하드 코드되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxRequestBytes

또한 Exchange Server Analyzer는 대상 컴퓨터에서 실행 중인 Microsoft Windows® 운영 체제의 버전을 확인할 때 다음 레지스트리 항목을 검토합니다.

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

CurrentVersion 값 4.0은 해당 컴퓨터에 Microsoft Windows NT® Server 4.0이 실행되고 있음을 나타냅니다. 값 5.0은 해당 컴퓨터에 Microsoft Windows 2000 Server 운영 체제가 실행되고 있음을 나타내고 값 5.2는 해당 컴퓨터에 Microsoft Windows Server™ 2003 운영 체제가 실행되고 있음을 나타냅니다.

마지막으로 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스에서 Exchange_Server WMI(Windows Management Instrumentation) 클래스를 조사하여 IsFrontEndServer 키 값을 확인합니다. 값이 False이면 Exchange Server 컴퓨터가 프런트 엔드 서버가 아님을 나타냅니다. 값이 True이면 Exchange Server 컴퓨터가 프런트 엔드 서버임을 나타냅니다.

Exchange Server Analyzer는 다음 조건이 참인 경우 Exchange 백 엔드 서버에서 MaxRequestBytes 값이 32768로 설정되어 있으면 경고를 표시합니다.

  • Exchange 백 엔드 서버에서 Windows Server 2003을 실행 중입니다.

  • Exchange 백 엔드 서버가 프런트 엔드 서버로 구성되어 있지 않습니다.

  • Exchange 백 엔드 서버에 500개가 넘는 사서함이 있습니다.

MaxRequestBytes 레지스트리 값은 요청줄과 헤더의 최대 전체 크기를 결정하며 기본적으로 존재하지 않습니다. 이 값은 대체로 함께 사용되는 값인 MaxFieldLength와 연결되어 설정됩니다. MaxFieldLength IIS 레지스트리 매개 변수는 개별 HTTP 클라이언트 요청의 최대 크기를 지정합니다. 규모가 더 큰 환경에서 이 값이 32768로 설정되어 있지 않으면 Exchange Server용 Microsoft Office Outlook® Web Access 사용자는 로그온에 실패할 수 있습니다. 특히 이 값들이 존재하지 않으면 HTTP 400 - 잘못된 요청 오류가 발생할 수 있습니다. MaxFieldLength 레지스트리 값을 구성할 때 75개가 넘는 그룹의 구성원인 사용자가 Outlook Web Access에 로그온할 수 있도록 MaxRequestBytes 매개 변수를 32768로 설정해야 합니다. MaxRequestBytes 값이 MaxFieldLength보다 낮을 경우 MaxFieldLength 값이 조정됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

MaxRequestBytes와 MaxFieldLength 매개 변수를 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. Parameters를 마우스 오른쪽 단추로 클릭하고 새로 만들기 | DWORD 값을 선택한 다음 MaxFieldLength 값의 이름을 지정합니다.

  4. Parameters를 마우스 오른쪽 단추로 클릭하고 새로 만들기 | DWORD 값을 선택한 다음 MaxRequestBytes 값의 이름을 지정합니다.

  5. 오른쪽 창에서 MaxFieldLength를 두 번 클릭한 다음 그 값을 32768(10진수)로 설정합니다.

  6. 오른쪽 창에서 MaxRequestBytes를 두 번 클릭한 다음 그 값을 32768(10진수)로 설정합니다.

  7. 레지스트리 편집기를 닫고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

IIS(인터넷 정보 서비스)의 HTTP 레지스트리 설정에 대한 자세한 내용은 기술 자료 문서 820129, "INF: IIS에 대한 Http.sys 레지스트리 설정"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129)을 참조하십시오.


IMAP4 Compatibility 플래그가 레지스트리에 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 다음 레지스트리 값이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\Compatibility

Exchange Server Analyzer는 Compatibility 값이 0xfffffffe(16진수)로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

IMAP4 및 POP3(Post Office Protocol version 3)을 사용하는 Exchange Server 인터넷 프로토콜(IP) 클라이언트 컴퓨터는 데이터를 읽고 쓰는 데 스트리밍 저장소(.stm) 파일을 전적으로 사용합니다. IP 클라이언트가 POP3 또는 IMAP4 상에서 메시지 다운로드를 요청하면 사용자의 사서함이 들어 있는 Exchange 정보 저장소는 메시지를 전송하기 전에 받은 편지함에서 메시지의 정확한 크기를 계산하여 클라이언트에 보냅니다. 대규모 환경, 특히 호스팅되는 Exchange 환경에서는 계산하는 데 많은 시간이 걸릴 수 있습니다. 관리자는 Compatibility 값을 통해 Exchange 저장소에 메시지의 정확한 크기를 계산하는 대신 대략적인 메시지 크기를 사용하도록 설정할 수 있습니다.

Compatibility 레지스트리 값은 Exchange IMAP4 서비스에 대해서는 이 문서에 설명된 대로 사용할 수 있으며 Exchange POP3 서비스에 대해서는 레지스트리에 POP3 호환성 플래그가 설정되어 있습니다.에 설명된 대로 사용할 수 있습니다.

Compatibility 레지스트리 값은 또한 많은 사서함 또는 여러 MIME 메시지를 가진 사서함을 이동할 때도 유용하게 사용할 수 있습니다. 데이터를 이동하는 경우 해당 데이터의 수준이 스트리밍 저장소에서 MAPI 저장소(.edb 파일)로 올라갑니다. 사서함을 액세스하는 데 POP3 및 IMAP4를 사용하는 클라이언트는 데이터베이스와 서버 간에 사서함을 이동한 후에 성능 문제가 발생할 수 있습니다. 사용자 로그온 후 메시지 크기가 계산되고 서버의 메모리와 디스크에서 MAPI를 MIME으로 변환합니다. 극단적인 경우에는 이와 같은 동작이 발생할 때 Exchange Server 컴퓨터에 매우 큰 임시 파일이 생성될 수 있습니다.

일부 POP3 및 IMAP4 메일 클라이언트는 Compatibility 레지스트리 값이 설정된 대로 올바르게 작동하지 않을 수 있습니다. 이 설정을 변경하면 Fetchmail 같은 일부 구형 메일 클라이언트는 손상될 수도 있습니다. 또한 이 레지스트리 키를 설정하면 IMAP4 프로토콜용 RFC 호환성을 훼손할 수 있습니다. POP3 및 IMAP4에 메시지 다운로드 문제가 발생하는 데 Compatibility 레지스트리 값을 사용하는 경우 다음의 메시지 다운로드 문제 해결 절차에 따라 이 값을 삭제할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Compatibility 레지스트리 값을 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters를 탐색합니다.

  3. Compatibility라는 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스 및 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Compatibility 레지스트리 값 사용에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 317722, "XADM: Client Latencies Occur When Exchange 2000 Converts Mail from MAPI to MIME Format"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722)

  • 329067, "XADM: Move Mailbox Functionality Promotes Contents of .stm Files"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067)


IMAP4 MaxBufferSize 값이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2007-08-07

Microsoft® Exchange Server Analyzer Tool은 아래의 레지스트리 값이 존재하는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Exchange Server Analyzer는 MaxBufferSize 값이 0보다 큰 숫자로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

MaxBufferSize 레지스트리 값은 Exchange 프런트 엔드/백 엔드 토폴로지에서 사용됩니다. 이 값은 프런트 엔드 서버와 백 엔드 서버 사이의 TCP/IP 버퍼 크기를 정의합니다. 기본 버퍼 크기는 1KB(킬로바이트)입니다. 지연이 자주 발생하는 네트워크에서 MaxBufferSize 값을 조정하면 IMAP4 클라이언트에 대한 성능이 향상될 수 있습니다.

MaxBufferSize 레지스트리 값을 사용하여 TCP/IP 버퍼 크기를 설정할 때 버퍼 크기를 항상 1,024의 배수로 설정해야 합니다. 사용 중인 프런트 엔드/백 엔드 서버 구성 성능을 다음 버퍼 크기로 테스트하여 조직에 필요한 최적의 값을 확인하는 것이 좋습니다.

  • 8,192바이트

  • 16,384바이트

  • 32,768바이트

MaxBufferSize 레지스트리 항목을 32,768보다 큰 값으로 설정하지 않는 것이 좋습니다. 그러나 네트워크 상태에 따라 버퍼 크기 값이 65,536일 경우 성능이 향상될 수도 있습니다. 버퍼 크기를 늘리면 Exchange Server 컴퓨터의 메모리를 더 많이 사용하게 되고 프런트 엔드 서버에 액세스할 수 있는 사용자 수가 줄어듭니다. MaxBufferSize 레지스트리 값으로 사용할 수 있는 최대값에는 제한이 없지만 이 레지스트리 항목에 너무 큰 값을 할당하면 성능이 불안정해지고 메모리 문제가 발생할 수 있습니다.

참고:
MaxBufferSize 레지스트리 값을 사용하려면 Exchange 2000 Server 서비스 팩 2 이상을 실행해야 합니다.

MaxBufferSize 레지스트리 값이 너무 낮게 설정되면 성능이 향상되지 않고 Exchange Server Analyzer는 IMAP4 MaxBufferSize 값이 너무 낮습니다.의 설명대로 오류 메시지를 표시합니다. MaxBufferSize 레지스트리 값이 너무 높게 설정되면 시스템이 불안정하게 될 수 있으며 Exchange Server Analyzer는 IMAP4 MaxBufferSize 값이 너무 높습니다.의 설명대로 오류 메시지를 표시합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

MaxBufferSize 값을 구성하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters를 탐색합니다.

  3. MaxBufferSize라는 새 DWORD 값을 만듭니다.

  4. MaxBufferSize 값을 두 번 클릭하고 이 값을 새 버퍼 크기(바이트)로 설정합니다. 예를 들어 8192를 입력하여 이 값을 8,192바이트로 설정할 수 있습니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange IMAP4 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MaxBufferSize 레지스트리 값을 사용하는 시기 및 방법에 대한 자세한 내용은 기술 자료 문서 823857, "IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)를 참조하십시오.


IMAP4 MaxBufferSize 값이 너무 높습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2007-08-07

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터의 레지스트리를 읽어 다음 레지스트리 값이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Exchange Server Analyzer는 MaxBufferSize 값이 32768보다 큰 숫자로 구성되어 있는 경우 경고를 표시합니다.

MaxBufferSize 레지스트리 값은 Exchange 프런트 엔드/백 엔드 토폴로지에서 사용됩니다. 이 값은 프런트 엔드 서버와 백 엔드 서버 사이의 TCP/IP 버퍼 크기를 정의합니다. 기본 버퍼 크기는 1KB(킬로바이트)입니다. 지연이 자주 발생하는 네트워크에서 MaxBufferSize 값을 조정하면 IMAP4 클라이언트에 대한 성능이 향상될 수 있습니다.

MaxBufferSize 레지스트리 값을 사용하여 TCP/IP 버퍼 크기를 설정할 때 버퍼 크기를 항상 1,024의 배수로 설정해야 합니다. 다음 버퍼 크기를 사용하여 프런트 엔드/백 엔드 서버 구성 성능을 테스트하는 것이 좋습니다.

  • 8,192바이트

  • 16,384바이트

  • 32,768바이트

이 레지스트리 항목을 사용할 경우 1,024 이상으로 설정해야 합니다. MaxBufferSize 레지스트리 항목을 32,768보다 큰 값으로 설정하지 않는 것이 좋습니다. 그러나 네트워크 상태에 따라 버퍼 크기 값이 65,536일 경우 성능이 향상될 수도 있습니다. 버퍼 크기를 늘리면 Exchange Server 컴퓨터의 메모리를 더 많이 사용하게 되고 프런트 엔드 서버에 액세스할 수 있는 사용자 수가 줄어듭니다. MaxBufferSize 레지스트리 값으로 사용할 수 있는 최대값에는 제한이 없지만 이 레지스트리 항목에 너무 큰 값을 할당하면 성능이 불안정해지고 메모리 문제가 발생할 수 있습니다.

참고:
MaxBufferSize 레지스트리 값을 사용하려면 Exchange 2000 Server 서비스 팩 2 이상을 실행해야 합니다.

MaxBufferSize 레지스트리 값이 너무 낮게 설정되면 성능이 향상되지 않고 Exchange Server Analyzer는 IMAP4 MaxBufferSize 값이 너무 낮습니다.의 설명대로 오류 메시지를 표시합니다. MaxBufferSize 레지스트리 값이 너무 높게 설정되면 시스템이 불안정하게 될 수 있으며 Exchange Server Analyzer는 이 문서의 설명대로 메시지를 표시합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters를 탐색합니다.

  3. MaxBufferSize라는 새 DWORD 값을 만듭니다.

  4. MaxBufferSize 값을 두 번 클릭하고 이 값을 새 버퍼 크기(바이트)로 설정합니다. 예를 들어 8192를 입력하여 이 값을 8,192바이트로 설정할 수 있습니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange IMAP4 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MaxBufferSize 레지스트리 값을 사용하는 시기와 방법에 대한 자세한 내용은 기술 자료 문서 823857, "XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)를 참조하십시오.


IMAP4 MaxBufferSize 값이 너무 낮습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2007-08-07

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 다음 레지스트리 값이 존재하는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Exchange Server Analyzer는 MaxBufferSize 값이 0보다 크지만 1024보다 작은 숫자 값으로 구성되어 있는 경우 오류를 표시합니다.

MaxBufferSize 레지스트리 값은 Exchange 프런트 엔드/백 엔드 토폴로지에서 사용됩니다. 이 값은 프런트 엔드 서버와 백 엔드 서버 사이의 TCP/IP 버퍼 크기를 정의합니다. 기본 버퍼 크기는 1 KB(킬로바이트)입니다. 지연이 자주 발생하는 네트워크에서 MaxBufferSize 값을 조정하면 IMAP4 클라이언트에 대한 성능이 향상될 수 있습니다.

MaxBufferSize 레지스트리 값을 사용하여 TCP/IP 버퍼 크기를 설정할 때 버퍼 크기를 항상 1,024의 배수로 설정해야 합니다. 사용 중인 프런트 엔드/백 엔드 서버 구성 성능을 다음 버퍼 크기로 테스트하여 조직에 필요한 최적의 값을 확인하는 것이 좋습니다.

  • 8,192 바이트

  • 16,38 4바이트

  • 32,768 바이트

이 레지스트리 항목을 사용할 경우 1,024 이상으로 설정해야 합니다. MaxBufferSize 레지스트리 항목을 32,768보다 큰 값으로 설정하지 않는 것이 좋습니다. 그러나 네트워크 상태에 따라 버퍼 크기 값이 65,536일 경우 성능이 향상될 수도 있습니다. 버퍼 크기를 늘리면 Exchange Server 컴퓨터의 메모리를 더 많이 사용하게 되고 프런트 엔드 서버에 액세스할 수 있는 사용자 수가 줄어듭니다. MaxBufferSize 레지스트리 값으로 사용할 수 있는 최대값에는 제한이 없지만 이 레지스트리 항목에 너무 큰 값을 할당하면 성능이 불안정해지고 메모리 문제가 발생할 수 있습니다.

참고:
MaxBufferSize 레지스트리 값을 사용하려면 Exchange 2000 Server 서비스 팩 2 이상을 실행해야 합니다.

MaxBufferSize 레지스트리 값이 너무 낮게 설정되면 성능이 향상되지 않고 Exchange Server Analyzer는 이 문서의 설명대로 오류 메시지를 표시합니다. MaxBufferSize 레지스트리 값이 너무 높게 설정되면 시스템이 불안정하게 될 수 있으며 Exchange Server Analyzer는 IMAP4 MaxBufferSize 값이 너무 높습니다.의 설명대로 메시지를 표시합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters를 탐색합니다.

  3. MaxBufferSize라는 새 DWORD 값을 만듭니다.

  4. MaxBufferSize 값을 두 번 클릭하고 이 값을 새 버퍼 크기(바이트)로 설정합니다. 예를 들어 8192를 입력하여 이 값을 8,192바이트로 설정할 수 있습니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange IMAP4 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MaxBufferSize 레지스트리 값을 사용하는 시기와 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 823857, "XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)를 참조하십시오.


MAPI 작업 오류
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 서버에 여러 번 보고된 MAPI 오류가 있음을 확인했습니다. 일부 MAPI 작업은 때때로 오류를 반환할 것으로 예상됩니다. 그러나 클라이언트 응용 프로그램이 오류에 제대로 응답하지 않을 수 있습니다. 이로 인해 응용 프로그램은 오류를 발생시킨 RPC 요청을 다시 실행하여 서버 로드가 증가합니다.

자주 발생하는 클라이언트 오류의 예로 MAPI 클라이언트가 일괄 처리 항목 목록을 요청하고 Exchange에서 요청이 반환된 후에도 항목을 계속 요청하는 경우가 있습니다. 예를 들어 클라이언트 컴퓨터에서는 첨부 파일을 포함한 지정 폴더의 모든 항목을 요청할 수 있습니다. 또한 클라이언트는 30개 항목씩 일괄로 항목을 반환하도록 요청할 수 있습니다. 경우에 따라 Exchange 서버에서 요청의 마지막 항목을 반환한 후에도 클라이언트에서 계속 새로운 일괄 30개 항목을 요청합니다. 이 경우 Exchange에서는 "찾을 수 없음" 오류를 반환합니다. "찾을 수 없음" 오류가 반환된 후에도 클라이언트 컴퓨터에서 계속 항목을 요청하면 클라이언트 컴퓨터가 오류에 제대로 응답하지 않는 것입니다. 이 시나리오의 경우 ExMon(Exchange Server User Monitor)에서 여러 MAPI 오류를 보고합니다. 이 경우 작업 수에 대한 오류의 비율이 높지만 높은 오류 비율이 예상됩니다. 높은 오류 비율이 예상되는 MAPI 작업에는 GetPerUserGuid, ImportMsgMove 및 Logon이 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ExMon을 사용하여 MAPI 오류를 많이 발생시키는 사용자나 사용자 그룹을 확인합니다.

  2. 이 문제를 발생시키는 클라이언트 컴퓨터의 응용 프로그램을 확인합니다.

  3. 문제를 발생시키는 응용 프로그램을 수정하거나 제거합니다.

추가 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange 서버 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


MaxClientRequestBuffer기 기본값이 아닌 값으로 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키를 읽어 해당 키가 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE System\CurrentControlSet\w3svc\Parameters\MaxClientRequestBuffer

Exchange Server Analyzer는 MaxClientRequestBuffer 키가 설정되었으면 기본값이 아니라는 메시지를 표시합니다.

기본적으로 이 레지스트리 값이 없습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

MaxClientRequestBuffer 레지스트리 키에 대한 자세한 내용은 Microsoft 기술 자료 문서 260694, "MaxClientRequestBuffer 레지스트리 값의 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260694)


MaxClientRequestBuffer가 너무 낮게 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 아래의 레지스트리 항목을 읽어 MaxClientRequestBuffer 값의 값 데이터를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

Exchange Server Analyzer는 MaxClientRequestBuffer 값에 대한 값 데이터가 16,384보다 작은 경우 경고를 표시합니다.

MaxClientRequestBuffer 값이 너무 작으면 Microsoft Office Outlook® Web Access 사용자 오류를 일으킬 수 있습니다. 특히 HTTP 400 - Bad Request가 브라우저로 반환될 수 있습니다. 이 경고를 해결하려면 값을 16,384 이상의 숫자로 늘리거나 레지스트리 값을 제거하여 기본 설정으로 되돌립니다. MaxClientRequestBuffers 값은 기본적으로 표시되지 않습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
값 데이터에 대한 값을 늘려서 이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer를 탐색합니다.

  3. MaxClientRequestBuffer 값을 두 번 클릭하고 값 데이터를 편집합니다. 값 데이터를 16,384와 같거나 큰 10진수로 설정합니다.

  4. 레지스트리 편집기를 닫은 다음 Exchange 서버를 다시 시작합니다.
값을 제거하여 이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer를 탐색합니다.

  3. MaxClientRequestBuffer 값을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭합니다.

  4. 레지스트리 편집기를 닫고 Exchange 서버를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MaxClientRequestBuffer 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 260694, "MaxClientRequestBuffer 레지스트리 값의 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260694)을 참조하십시오.


여러 개의 SMTP 포트 바인딩으로 구성
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchServerBindings 특성의 구성 값이 여러 개의 포트 바인딩으로 구성되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 msExchServerBindings 특성은 TCP 포트 25에 대해 구성되어 있습니다. Exchange Server Analyzer에서 msExchServerBindings 특성이 여러 개의 포트 바인딩으로 구성되어 있음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다.

msExchServerBindings 특성은 이 SMTP(Simple Mail Transfer Protocol) 서버가 들어오는 연결을 수신 대기하는 TCP 포트를 나타냅니다. 하나 이상의 TCP 포트에서 수신 대기하도록 SMTP 가상 서버를 구성할 수 있습니다. 기본적으로 모든 SMTP 가상 서버는 TCP 포트 25에서 수신 대기하도록 구성되어 있습니다. 내부 메시징 인프라의 나머지 부분을 수정할 경우 SMTP 수신 대기 포트를 변경할 수 있습니다. 그러나 SMTP 서버는 인터넷에서 포트 25를 통해 메시지를 보내기 때문에 인터넷에서 메시지를 직접 받는 SMTP 가상 서버의 경우 일반적으로 포트 25를 사용해야 합니다.

Exchange Server Analyzer는 Exchange SMTP 프로토콜 가상 서버에 대한 값을 확인합니다. Exchange SMTP 프로토콜 가상 서버는 인터넷에서 메시지를 직접 받는 SMTP 서버일 수도 있고 아닐 수도 있습니다. 바이러스 백신 제품 및 스팸 방지 제품은 포트 25를 통해 인터넷에서 SMTP 메시지를 받아 다른 포트의 Exchange SMTP 가상 서버로 리디렉션하도록 되어 있습니다.

SMTP 가상 서버 수신 대기 포트를 확인 또는 수정하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, Exchange 서버, 프로토콜, SMTP를 차례로 확장합니다.

  2. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭을 선택한 다음 고급을 클릭합니다.

  4. IP 주소 및 포트 목록이 표시됩니다.

    • 기존 포트를 변경하려면 IP 주소를 선택한 다음 편집을 클릭합니다.

    • 기존 포트를 제거하려면 IP 주소를 선택한 다음 제거를 클릭합니다.

  5. 변경 내용을 저장하려면 확인, 확인을 차례로 클릭하여 고급 대화 상자를 끝냅니다.

  6. 확인을 클릭하여 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


PING 회신 크기가 다릅니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 특정 BufferSize 설정값을 사용하여 Win32_PingStatus Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하고 반환된 BufferSize 값과 비교하여 두 값이 동일한지 확인합니다.

반환된 BufferSize 값이 전송된 값과 다르면 경고가 표시됩니다.

이 경고는 전송 과정에서 패킷이 잘렸음을 나타냅니다. 또한 환경에 일반 네트워크 오류나 블랙 홀 라우터가 있음을 나타낼 수 있습니다.

중간 네트워크 세그먼트의 패킷 크기가 통신 호스트보다 작고, 라우터가 이 조건에 대해 적합한 ICMP 응답을 보내지 않을 경우 TCP/IP WAN(Wide Area Network)에서 일부 경로를 통한 통신이 실패할 수 있습니다. 또는 이 경로의 방화벽에 의해 이러한 응답이 끊길 수 있습니다. 이 조건을 일으키는 라우터를 블랙 홀 라우터라고도 합니다.

블랙 홀 라우터가 있으면 다양한 오류가 발생할 수 있습니다. 이러한 오류는 프로그램이 로컬 서브넷의 컴퓨터에 연결된 경우에는 발생하지 않습니다. 동작이 때때로 중단되는 것처럼 보일 수 있지만 상황을 더 면밀히 살펴보면 원격 호스트에서 보낸 큰 파일을 클라이언트에서 읽도록 하여 동작이 다시 생성될 수 있음을 알 수 있습니다.

자세한 내용은 Microsoft 기술 자료 문서 314825, "블랙 홀 라우터 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825)의 지침을 따르십시오.

자세한 정보

가능한 블랙 홀 라우터 검색 및 처리에 대한 자세한 내용은 다음 리소스를 참조하십시오.

  • Microsoft 기술 자료 문서 159211, "블랙 홀(Black Hole) 라우터의 진단과 취급"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)

  • "PMTU(경로 최대 전송 단위) 블랙 홀 라우터"(http://go.microsoft.com/fwlink/?LinkId=66963)


Ping 테스트가 실행되지 않음
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-08-09

Microsoft® Exchange Server Analyzer Tool은 Win32_PingStatus Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 다양한 메일 흐름별 구성 설정에 대해 응답 개체를 분석합니다.

Win32_PingStatus는 일반적으로 해당 클래스에서 보내는 ping 패킷에 대한 광범위한 세부 정보를 제공하는 24개 속성이 포함된 개체를 반환합니다.

6회 연속 시도 후에도 쿼리에 대한 응답으로 필요한 개체를 받지 못하면 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 Win32_PingStatus를 수행하지 못했음을 나타냅니다.

가장 가능성이 큰 이 오류의 원인은 Win32_PingStatus 명령을 실행하려는 컴퓨터가 Microsoft Windows® 2000 Server 운영 체제에서 실행되는 경우입니다. Windows 2000 Server는 Win32_PingStatus WMI 클래스를 지원하지 않습니다.

Win32_PingStatus 명령을 실행하려는 컴퓨터가 Windows 2000 Server 운영 체제에서 실행되지 않는 경우 이 문제는 일반적인 네트워킹 문제나 사용 권한 문제로 인한 것일 수 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. Exchange Server Analyzer를 실행하는 컴퓨터에서 PING 명령을 사용하여 대상 Exchange Server 컴퓨터에 연결할 수 있는지 확인합니다.

  3. 대상 Exchange Server 서버와 같은 서브넷에 있는 서버에서 PING 명령을 사용하여 대상 Exchange Server 컴퓨터에 연결할 수 있는지 확인합니다.

  4. 방화벽이 있는 경우 RPC(원격 프로시저 호출) 포트가 차단되어 있는지 확인합니다.

  5. Exchange Server Analyzer를 실행하는 계정에 대한 사용 권한을 검토합니다. Exchange Server Analyzer를 실행하는 계정에는 검색 중인 각 Exchange Server에 대한 로컬 관리자 권한이 있어야 합니다.

네트워크 연결 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제 해결 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

Exchange Server Analyzer 연결 문제에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?LinkId=56285)를 참조하십시오.

Win32_PingStatus WMI 클래스에 대한 자세한 내용은 MSDN® 문서, "Win32_PingStatus"(http://go.microsoft.com/fwlink/?linkid=33549)를 참조하십시오.


일반 텍스트 바이러스 백신 검색이 비활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 RTF(서식 있는 텍스트) 메시지 바이러스 백신 검색 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Exchange Server Analyzer는 ScanPlainText가 0으로 설정되어 있는 경우 경고를 표시합니다.

ScanPlainText 레지스트리 키는 Exchange 바이러스 검색 API(VSAPI)를 사용하는 타사 바이러스 백신 공급업체에서 설정됩니다. 일반 텍스트 메시지를 포함하여 모든 메시지 형식에 대해 바이러스 검색을 하는 것이 좋습니다. Exchange Server 컴퓨터에서 들어오거나 나가는 모든 메시지에 대해 바이러스 검색을 설정해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  • Exchange에서 인식하는 바이러스 백신 응용 프로그램에서 모든 메시지의 검색을 활성화합니다.

    - 또는 -

  • 다음 절차를 수행하여 레지스트리 항목을 수동으로 수정합니다.

    1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

    2. 다음 항목을 탐색합니다.

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    3. ScanPlainText 레지스트리 항목을 두 번 클릭하고 해당 값 데이터를 1로 설정합니다.

    4. 레지스트리 편집기를 끝내고 Exchange에서 인식하는 바이러스 백신 소프트웨어를 나타내는 서비스와 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

바이러스 퇴치에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.


레지스트리에 POP3 호환성 플래그가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 다음 레지스트리 값이 존재하는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\Compatibility

Exchange Server Analyzer는 Compatibility 값이 0xfffffffe(16진수)로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

IMAP4 및 POP3(Post Office Protocol version 3)를 사용하는 Exchange Server 인터넷 프로토콜(IP) 클라이언트 컴퓨터는 데이터를 읽고 쓰는 데 스트리밍 저장소(.stm) 파일을 전적으로 사용합니다. IP 클라이언트가 POP3 또는 IMAP4를 사용한 메시지 다운로드를 요청하면 사용자의 사서함이 포함된 Exchange 저장소는 메시지를 전송하기 전에 클라이언트로 보낼 받은 편지함 메시지의 정확한 크기를 계산합니다. 특히 호스팅된 Exchange 환경과 같은 대규모 환경에서는 이 계산에 상당한 시간이 소요됩니다. Compatibility 값은 관리자가 정확한 메시지 크기를 계산하는 대신 대략적인 메시지 크기를 사용하도록 Exchange 저장소를 구성할 수 있음을 나타냅니다.

Compatibility 레지스트리 값은 이 문서에 설명된 바와 같이 Exchange POP3 서비스에 사용할 수 있으며 IMAP4 Compatibility 플래그가 레지스트리에 설정되어 있습니다.에 설명된 것처럼 Exchange IMAP4 서비스에도 사용할 수 있습니다.

또한 Compatibility 레지스트리 값은 많은 수의 사서함을 이동하거나 많은 수의 MIME(Multipurpose Internet Mail Extension) 메시지가 포함된 사서함을 이동할 때 유용합니다. 데이터를 이동하는 경우 해당 데이터의 수준이 스트리밍 저장소에서 MAPI 저장소(.edb 파일)로 올라갑니다. POP3 및 IMAP4를 사용하여 사서함에 액세스하는 클라이언트에서는 데이터베이스 또는 서버 간에 사서함을 이동한 후 성능 문제가 발생할 수 있습니다. 사용자 로그온 후 메시지 크기가 계산되고 서버의 메모리와 디스크에서 MAPI를 MIME으로 변환합니다. 극단적인 경우 이 동작이 수행되면 Exchange Server 컴퓨터에 크기가 큰 임시 파일이 만들어질 수 있습니다.

Compatibility 레지스트리 값이 설정되어 있어도 올바르게 작동하지 않는 POP3 및 IMAP4 메일 클라이언트도 있습니다. 이 설정을 변경하면 Fetchmail과 같은 이전의 메일 클라이언트가 중단됩니다. 또한 이 레지스트리 키를 설정하면 POP3 프로토콜의 RFC 호환 기능을 사용할 수 없습니다. Compatibility 레지스트리 값을 사용하는 경우 POP3 및 IMAP4를 사용하여 메시지를 다운로드하는 데 문제가 있으면 아래 절차에 따라 해당 값을 삭제하여 메시지 다운로드 문제를 해결할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Compatibility 레지스트리 값을 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters를 탐색합니다.

  3. Compatibility 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스와 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Compatibility 레지스트리 값 사용에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 317722, "XADM: Client Latencies Occur When Exchange 2000 Converts Mail from MAPI to MIME Format"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722)

  • 329067, "XADM: Move Mailbox Functionality Promotes Contents of .stm Files"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067)


POP3 MaxBufferSize 값이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 다음 레지스트리 값이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Exchange Server Analyzer는 MaxBufferSize 값이 0보다 큰 숫자 값으로 구성되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

MaxBufferSize 레지스트리 값은 Exchange 프런트 엔드/백 엔드 토폴로지에서 사용됩니다. 이 값은 프런트 엔드 서버와 백 엔드 서버 사이의 TCP/IP 버퍼 크기를 정의합니다. 기본 버퍼 크기는 1KB(킬로바이트)입니다. 대기 시간이 긴 네트워크에서 MaxBufferSize 값을 조정하여 POP3 클라이언트의 성능을 향상시킬 수 있습니다.

MaxBufferSize 레지스트리 값을 사용하여 TCP/IP 버퍼 크기를 설정할 때 버퍼 크기를 항상 1,024의 배수로 설정해야 합니다. 다음 버퍼 크기를 사용하여 프런트 엔드/백 엔드 서버 구성 성능을 테스트하는 것이 좋습니다.

  • 8,192바이트

  • 16,384바이트

  • 32,768바이트

이 레지스트리 항목을 사용할 경우 1,024 이상으로 설정해야 합니다.MaxBufferSize 레지스트리 항목을 32,768보다 큰 값으로 설정하지 않는 것이 좋습니다. 그러나 네트워크 상태에 따라 버퍼 크기가 65,536일 경우 성능이 향상되는 경우도 있습니다. 버퍼 크기를 늘리면 Exchange Server 컴퓨터의 메모리를 더 많이 사용하게 되고 프런트 엔드 서버에 액세스할 수 있는 사용자 수가 줄어듭니다. MaxBufferSize 레지스트리 값으로 사용할 수 있는 최대값에는 제한이 없지만 이 레지스트리 항목에 너무 큰 값을 할당하면 성능이 불안정해지고 메모리 문제가 발생할 수 있습니다.

참고:
MaxBufferSize 레지스트리 값을 사용하려면 Exchange 2000 Server 서비스 팩 2 이상을 실행해야 합니다.

MaxBufferSize 레지스트리 값이 너무 낮게 설정되면 POP3 MaxBufferSize 값이 너무 낮습니다.의 설명대로 성능이 향상되지 않고 Exchange Server Analyzer가 오류 메시지를 표시합니다. MaxBufferSize 레지스트리 값이 너무 높게 설정되면 POP3 MaxBufferSize 값이 너무 높습니다.의 설명대로 시스템이 불안정하게 될 수 있으며 Exchange Server Analyzer는 오류 메시지를 표시합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters를 탐색합니다.

  3. MaxBufferSize라는 새 DWORD 값을 만듭니다.

  4. MaxBufferSize 값을 두 번 클릭하고 이 값을 새 버퍼 크기(바이트)로 설정합니다. 예를 들어 8192를 입력하여 이 값을 8,192바이트로 설정할 수 있습니다.

  5. 레지스트리 편집기를 끝내고 Microsoft Exchange POP3 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MaxBufferSize 레지스트리 값을 사용하는 시기 및 방법에 대한 자세한 내용은 기술 자료 문서 823857, "IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)를 참조하십시오.


POP3 MaxBufferSize 값이 너무 높습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 다음 레지스트리 값이 존재하는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Exchange Server Analyzer는 MaxBufferSize 값이 32768보다 큰 숫자로 구성되어 있는 경우 경고를 표시합니다.

MaxBufferSize 레지스트리 값은 Exchange 프런트 엔드/백 엔드 토폴로지에서 사용됩니다. 이 값은 프런트 엔드 서버와 백 엔드 서버 사이의 TCP/IP 버퍼 크기를 정의합니다. 기본 버퍼 크기는 1KB(킬로바이트)입니다. 대기 시간이 긴 네트워크에서 MaxBufferSize 값을 조정하여 POP3 클라이언트의 성능을 향상시킬 수 있습니다.

MaxBufferSize 레지스트리 값을 사용하여 TCP/IP 버퍼 크기를 설정할 때 버퍼 크기를 항상 1,024의 배수로 설정해야 합니다. 다음 버퍼 크기를 사용하여 프런트 엔드/백 엔드 서버 구성 성능을 테스트하는 것이 좋습니다.

  • 8,192바이트

  • 16,384바이트

  • 32,768바이트

이 레지스트리 항목을 사용할 경우 1,024 이상으로 설정해야 합니다. MaxBufferSize 레지스트리 항목을 32,768보다 큰 값으로 설정하지 않는 것이 좋습니다. 그러나 네트워크 상태에 따라 버퍼 크기가 65,535일 경우 성능이 향상될 수도 있습니다. 버퍼 크기를 늘리면 Exchange Server 컴퓨터의 메모리를 더 많이 사용하게 되고 프런트 엔드 서버에 액세스할 수 있는 사용자 수가 줄어듭니다. MaxBufferSize 레지스트리 값으로 사용할 수 있는 최대값에는 제한이 없지만 이 레지스트리 항목에 너무 큰 값을 할당하면 성능이 불안정해지고 메모리 문제가 발생할 수 있습니다.

참고:
MaxBufferSize 레지스트리 값을 사용하려면 Exchange 2000 Server 서비스 팩 2 이상을 실행해야 합니다.

MaxBufferSize 레지스트리 값이 너무 낮게 설정되면 POP3 MaxBufferSize 값이 너무 낮습니다.의 설명대로 성능이 향상되지 않고 Exchange Server Analyzer가 오류 메시지를 표시합니다. MaxBufferSize 레지스트리 값이 너무 높게 설정되면 시스템이 불안정하게 될 수 있으며 Exchange Server Analyzer는 이 문서의 설명대로 메시지를 표시합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters를 탐색합니다.

  3. MaxBufferSize라는 새 DWORD 값을 만듭니다.

  4. MaxBufferSize 값을 두 번 클릭하고 이 값을 새 버퍼 크기(바이트)로 설정합니다. 예를 들어 8192를 입력하여 이 값을 8,192바이트로 설정할 수 있습니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange POP3 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MaxBufferSize 레지스트리 값을 사용하는 시기 및 방법에 대한 자세한 내용은 기술 자료 문서 823857, "IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)를 참조하십시오.


POP3 MaxBufferSize 값이 너무 낮습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 다음 레지스트리 값이 존재하는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Exchange Server Analyzer는 MaxBufferSize 값이 존재하고 0보다 크고 1024보다 작은 숫자 값으로 구성되어 있으면 오류를 표시합니다.

MaxBufferSize 레지스트리 값은 Exchange 프런트 엔드/백 엔드 토폴로지에서 사용됩니다. 이 값은 프런트 엔드 서버와 백 엔드 서버 사이의 TCP/IP 버퍼 크기를 정의합니다. 기본 버퍼 크기는 1KB(킬로바이트)입니다. 대기 시간이 긴 네트워크에서 MaxBufferSize 값을 조정하여 POP3 클라이언트의 성능을 향상시킬 수 있습니다.

MaxBufferSize 레지스트리 값을 사용하여 TCP/IP 버퍼 크기를 설정할 때 버퍼 크기를 항상 1,024의 배수로 설정해야 합니다. 사용 중인 프런트 엔드/백 엔드 서버 구성 성능을 다음 버퍼 크기로 테스트하여 조직에 필요한 최적의 값을 확인하는 것이 좋습니다.

  • 8,192바이트

  • 16,384바이트

  • 32,768바이트

이 레지스트리 항목을 사용할 경우 1,024 이상으로 설정해야 합니다. MaxBufferSize 레지스트리 항목을 32,768보다 큰 값으로 설정하지 않는 것이 좋습니다. 그러나 네트워크 상태에 따라 버퍼 크기가 65,535일 경우 성능이 향상될 수도 있습니다. 버퍼 크기를 늘리면 Exchange Server 컴퓨터의 메모리를 더 많이 사용하게 되고 프런트 엔드 서버에 액세스할 수 있는 사용자 수가 줄어듭니다. MaxBufferSize 레지스트리 값으로 사용할 수 있는 최대값에는 제한이 없지만 이 레지스트리 항목에 너무 큰 값을 할당하면 성능이 불안정해지고 메모리 문제가 발생할 수 있습니다.

참고:
MaxBufferSize 레지스트리 값을 사용하려면 Exchange 2000 Server 서비스 팩 2 이상을 실행해야 합니다.

MaxBufferSize 레지스트리 값을 너무 낮게 설정하면 성능이 향상되지 않고 Exchange Server Analyzer에서 이 문서의 설명대로 오류 메시지를 표시합니다. MaxBufferSize 레지스트리 값을 너무 높게 설정하면 시스템이 불안정하게 될 수 있고 Exchange Server Analyzer에서 POP3 MaxBufferSize 값이 너무 높습니다.와 같은 메시지를 표시합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters를 탐색합니다.

  3. MaxBufferSize라는 새 DWORD 값을 만듭니다.

  4. MaxBufferSize 값을 두 번 클릭하고 이 값을 새 버퍼 크기(바이트)로 설정합니다. 예를 들어 8192를 입력하여 이 값을 8,192바이트로 설정할 수 있습니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange POP3 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MaxBufferSize 레지스트리 값을 사용하는 시기 및 방법에 대한 자세한 내용은 기술 자료 문서 823857, "IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857)를 참조하십시오.


포트가 응답하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-05-16

Microsoft® Exchange Server Analyzer Tool은 사용자 정의 서버를 쿼리하여 TCP 포트 25 또는 사용자 정의 포트의 기본 구성에서 지정한 서버에 대한 소켓 연결을 열려고 시도합니다. Exchange Server Analyzer에서 예상된 xx Available 사용자 정의 응답을 받지 못하면 오류가 표시됩니다. 여기에서 xx는 기본 포트 25 또는 사용자가 정의한 대체 포트 번호입니다.

이 오류는 원하는 TCP 포트를 통해 서버에 연결할 수 없으며 실패할 수 있음을 나타냅니다. 이 오류를 해결하려면 서버의 연결 문제를 해결합니다.

서버의 연결 문제를 해결하려면 다음을 수행합니다.

  1. 지정된 서버에서 원하는 포트에 텔넷을 연결할 수 있습니까? 그렇지 않으면 네트워크에는 문제가 없습니다.

  2. 모두 플러그에 꽂혀 있습니까? 모든 하드웨어가 올바르게 작동됩니까?

  3. DNS가 올바르게 작동되고 구성되어 있습니까?

  4. 라우터가 올바르게 작동됩니까?

  5. 연결을 차단하는 방화벽이 있습니까?

서버 연결 문제를 해결하는 방법은 "Microsoft Exchange Server Best Practices Analyzer Tool 연결 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=56285)을 참조하십시오.


잠재적인 블랙 홀(Black Hole) 라우터
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 다양한 특정 BufferSize 및 NoFragmentation 설정값으로 Win32_PingStatus Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 WAN 환경에 블랙 홀 라우터가 있는지 확인합니다.

BufferSize 설정 | NoFragmentation 설정
548 | True
1472 | True
1472 | False
4096 | True
4096 | False

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • BufferSize 값이 더 작고 NoFragmentation = True인 PING이 성공한 경우

  • BufferSize 값이 더 크고 NoFragmentation = True인 PING의 시간이 초과한 경우

  • BufferSize 값이 더 크고 NoFragmentation = False인 PING이 성공했지만 회신 BufferSize 크기가 보낸 BufferSize와 다른 경우

이 오류는 WAN(Wide Area Network)에 블랙 홀 라우터가 하나 이상 있을 수 있음을 나타냅니다.

다음과 같은 경우 TCP/IP WAN에서 일부 경로를 통한 통신이 실패할 수 있습니다.

  • 중간 네트워크 세그먼트의 패킷 크기가 통신하는 호스트보다 작은 경우

  • 라우터에서 이 조건에 대한 적합한 ICMP 응답을 보내지 않는 경우

또는 이 경로의 방화벽에 의해 이러한 응답이 끊길 수 있습니다. 이 조건을 일으키는 라우터를 블랙 홀(Black Hole) 라우터라고도 합니다.

블랙 홀 라우터가 있으면 다양한 오류가 발생할 수 있습니다. 이러한 오류는 프로그램이 로컬 서브넷의 컴퓨터에 연결된 경우에는 발생하지 않습니다. 동작이 때때로 중단되는 것처럼 보일 수 있지만 원격 호스트에서 보낸 대형 파일을 클라이언트에서 읽도록 하여 동작이 다시 생성될 수 있음을 알 수 있습니다.

자세한 내용은 Microsoft 기술 자료 문서 314825, "블랙 홀 라우터 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825)의 지침을 따르십시오.

자세한 정보

가능한 블랙 홀 라우터 검색 및 처리에 대한 자세한 내용은 다음 리소스를 참조하십시오.

  • Microsoft 기술 자료 문서 159211, "블랙 홀(Black Hole) 라우터의 진단과 취급"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)

  • The Cable Guy - July 2004 컬럼 "PMTU(경로 최대 전송 단위) 블랙 홀 라우터"(http://go.microsoft.com/fwlink/?LinkId=66963)


원격 호스트 PING이 실패했습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-05-03

Microsoft® Exchange Server Analyzer Tool은 다양한 BufferSize 및 NoFragmentation 설정으로 Win32_PingStatus Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 네트워크의 MTU(최대 전송 단위) 크기를 확인하고 가능한 블랙 홀 라우터를 찾습니다. Exchange Server Analyzer에서는 각 설정 조합에 대해 원격 호스트에서 반환된 StatusCode 키 값을 검사하여 이것을 확인합니다.

BufferSize 설정 | NoFragmentation 설정
548 | True
1472 | True
1472 | False
4096 | True
4096 | False

Win32_PingStatus는 해당 클래스에서 보내는 ping 패킷에 대한 광범위한 세부 정보를 제공하는 24개 속성이 포함된 개체를 반환합니다.

Exchange Server Analyzer가 이 키 값이 다음 표에 있는 값 중 하나와 일치함을 확인하면 오류가 표시됩니다.

Exchange Server Analyzer는 이 오류와 함께 반환된 원격 호스트 이름, Exchange 서버 이름 및 해당 StatusCode 값을 표시합니다.

StatusCode 값 의미 설명

11001

버퍼가 너무 작음

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11002

대상 네트에 연결할 수 없음

대상 컴퓨터가 포함된 네트워크에 연결할 수 없기 때문에 요청이 실패했습니다. 대상 컴퓨터에 대한 유효한 경로가 없습니다.

자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11003

대상 호스트에 연결할 수 없음

대상 컴퓨터에 연결할 수 없기 때문에 요청이 실패했습니다.

자세한 내용은 Active Directory 서버가 다운되었거나 연결할 수 없습니다.를 참조하십시오.

또는 이 오류는 다음 조건 중 하나에 의해 발생할 수 있습니다.

  • Exchange Server Analyzer가 실행 중인 위치와 대상 도메인 컨트롤러 사이의 방화벽

  • DNS 오류

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11004

대상 프로토콜에 연결할 수 없음

대상 컴퓨터가 패킷 프로토콜에 응답하지 않기 때문에 요청이 실패했습니다.

Exchange Server Analyzer가 실행 중인 위치와 대상 도메인 컨트롤러 사이에 있는 방화벽으로 인해 이 오류가 발생할 수 있습니다.

11005

대상 포트에 연결할 수 없음

대상 컴퓨터의 포트를 사용할 수 없기 때문에 요청이 실패했습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11006

리소스 없음

네트워크 리소스가 부족하여 요청이 실패했습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11007

잘못된 옵션

잘못된 옵션이 있기 때문에 요청이 실패했습니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11008

하드웨어 오류

하드웨어 오류로 인해 요청이 실패했습니다.

사용자의 컴퓨터 제조업체에서 제공하는 하드웨어 상태 확인 도구를 실행하여 도메인 컨트롤러가 적절하게 작동하는지 확인합니다.

11009

패킷이 너무 큼

요청이 포함된 패킷이 원본과 대상 사이에 있는 라우터 또는 게이트웨이 노드의 최대 전송 단위(MTU)보다 크기 때문에 요청이 실패했습니다. MTU는 전송할 수 있는 최대 패킷 크기를 정의합니다.

Exchange Server Analyzer가 보낸 요청이 10KB보다 작습니다. 조직의 라우터와 게이트웨이가 적절하게 구성되어 있는지 확인합니다.

자세한 내용은 기술 자료 문서 159211, "블랙 홀(Black Hole) 라우터의 진단과 취급"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211)을 참조하십시오.

11010

요청 시간 초과

할당된 시간 내에 회신을 받지 못했습니다. 회신에 허용되는 기본 시간은 5초입니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11011

잘못된 요청

요청이 잘못 인코딩되었기 때문에 실패했습니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11012

잘못된 경로

원본과 대상 컴퓨터 간의 경로가 잘못되었기 때문에 요청이 실패했습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11013

TimeToLive 만료된 통과

TTL(Time to Live) 값이 0에 도달했으므로 요청이 실패했습니다. 이로 인해 전달 라우터 또는 게이트웨이 노드가 패킷을 무시합니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11014

TimeToLive 만료된 리어셈블리

패킷이 전송될 수 있도록 조각으로 나뉘었으나 리어셈블리에 할당된 시간 내에 모든 조각이 수신되지 않았기 때문에 요청이 실패했습니다. RFC 2460(http://www.ietf.org/rfc/rfc2460.txt)은 모든 패킷 조각이 수신되어야 하는 시간 제한을 60초로 지정하고 있습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

11015

매개 변수 문제

패킷 헤더를 처리하는 동안 라우터 또는 게이트웨이 노드에 문제가 발생했기 때문에 요청이 실패했습니다. 헤더에 잘못된 필드 데이터나 인식되지 않는 옵션이 있는 경우 이러한 상황이 발생합니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11016

원본 중지

패킷이 무시되었기 때문에 요청이 실패했습니다. 원본 컴퓨터의 출력 큐에 저장 공간이 부족한 경우 이러한 상황이 발생합니다. 또는 패킷이 대상에 너무 빨리 도착하여 처리될 수 없을 때 발생합니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11017

옵션이 너무 큼

잘못된 옵션이 있기 때문에 요청이 실패했습니다.

이 오류는 Exchange Server Analyzer가 표준 요청을 생성하기 때문에 거의 발생하지 않습니다.

11018

잘못된 대상

다음 이유 중 하나로 인해 요청이 실패했습니다.

  • 대상 IP 주소가 PING 요청을 받을 수 없습니다.

  • 대상 IP 주소는 IP 데이터그램의 대상 주소 필드에 나타나지 않아야 합니다.

Exchange Server Analyzer가 실행 중인 위치와 대상 도메인 컨트롤러 사이에 있는 방화벽으로 인해 이 오류가 발생할 수 있습니다.

11032

IPSEC 협상

IPsec 연결을 협상할 수 없기 때문에 요청이 실패했습니다.

11050

일반 오류

알 수 없는 이유로 요청이 실패했습니다.

자세한 내용은 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

이 테스트에 대한 자세한 내용은 Microsoft 기술 자료 문서 314825, "블랙 홀 라우터 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825)을 참조하십시오.


라우팅 엔진이 중지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 RESvc(Microsoft Exchange Routing Engine service) 및 SMTPSVC(Simple Mail Transfer Protocol 서비스)가 실행 중인지 확인합니다. Exchange Server Analyzer는 다음 조건 중 하나가 참인 것을 확인하면 오류를 표시합니다.

  • SMTPSVC가 실행 중입니다.

  • RESvc가 실행 중입니다.

RESvc가 메시지를 릴레이하는 모든 Exchange 서버에서 실행되고 있지 않으면 라우팅 문제가 발생할 수 있습니다. RESvc를 실행하지 않고 메시지를 릴레이하는 Exchange Server 구성은 지원되지 않습니다.

Exchange 2000 Server처럼 Exchange Server 2003은 링크 상태 라우팅 알고리즘과 라우팅 프로토콜을 사용하여 링크 상태 테이블의 형태로 링크 상태 정보를 전파합니다. 링크 상태 테이블은 조직에 있는 모든 Exchange 2000 Server 및 Exchange Server 2003의 메모리에 저장됩니다.

링크 상태 알고리즘에는 다음과 같은 이점이 있습니다.

  • 각 Exchange 서버는 링크를 사용할 수 없는 경로를 따라 메시지를 보내지 않고 원본에서 최적의 메시지 경로를 선택할 수 있습니다.

  • 각 Exchange 서버에는 대체 경로 또는 예비 경로를 사용할 수 있는지에 대한 최신 정보가 있으므로 더 이상 서버 간에 메시지가 반송되지 않습니다.

  • 더 이상 메시지 루핑이 발생하지 않습니다. Exchange Server의 이전 버전에서는 때때로 메시지 루핑 문제가 있었습니다.

Exchange Server는 링크 상태 테이블에서 다음 정보를 수집합니다.

  • 링크 상태 테이블은 전체 Exchange 조직의 라우팅 토폴로지를 문서화합니다.

  • 링크 상태 테이블은 토폴로지에서 각 커넥터의 가용성을 문서화합니다. 사용 가능한 토폴로지는 "작동"이고 사용 불가능한 토폴로지는 "중지"입니다.

  • 링크 상태 테이블은 사용 가능한 각 커넥터와 연관된 비용과 주소 공간을 문서화합니다.

Exchange Server는 이 정보를 이용하여 대상 주소에 사용할 가장 적은 비용의 경로를 확인합니다. 비용이 가장 적게 드는 경로를 따라 커넥터를 사용할 수 없으면 Exchange Server는 비용과 커넥터 가용성을 기반으로 가장 적합한 대체 경로를 확인합니다. RESvc는 링크 상태 라우팅에 필요합니다.

이 오류를 해결하려면 RESvc가 자동으로 시작되도록 구성합니다. RESvc가 production 시간 중에 실행되고 있는지 확인해야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 시작을 클릭하고 프로그램, 관리 도구를 차례로 가리킨 다음 서비스를 클릭합니다.

  2. 서비스 목록에서 Microsoft Exchange Routing Engine을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭의 시작 유형 메뉴에서 자동을 선택한 다음 확인을 클릭합니다.

  4. Microsoft Exchange Routing Engine을 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

Exchange Server 2003의 메시지 라우팅에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)를 참조하십시오.


RPC Performance Counters Indicate Poor Server Performance
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-08-24

Microsoft® Exchange Server Analyzer Tool에서 서버가 최적의 성능으로 작동하고 있지 않음을 확인했습니다. Exchange Server Analyzer는 많은 RPC(원격 프로시저 호출) 성능 카운터를 확인하여 RPC 성능 카운터에 보고된 데이터가 아래 표의 수준에 미치지 않으면 경고를 표시합니다.

Exchange Server의 사용자 수 | RPC Averaged Latency 임계값
500보다 작음 | 평균 15보다 큼
500보다 크거나 같지만 3000보다 작음 | 평균 30보다 큼
3000보다 큼 | 평균 50보다 큼

이 문서에서는 다음 성능 카운터에 대해 설명하며 이 성능 카운터는 MSExchangeIS 성능 개체에서 관리됩니다.

  • RPC Averaged Latency

  • RPC Requests

RPC Averaged Latency

RPC Averaged Latency 성능 카운터는 마지막 1024개의 패킷을 처리하는 데 걸린 평균 시간(ms)을 기록합니다. 대기 시간은 Store.exe 프로세스에서 패킷을 받아서 패킷을 반환하는 데 걸린 시간을 나타냅니다. RPC Averaged Latency 성능 카운터는 네트워크 대기 시간이나 Store.exe 프로세스 이외의 프로세스로 인한 대기 시간을 포함하지 않습니다. RPC Averaged Latency 성능 카운터 데이터는 네트워크 전환 시간을 포함하지 않지만 클라이언트 컴퓨터가 서버로부터의 응답을 기다린 가장 짧은 기간에 대한 데이터를 제공합니다. RPC Averaged Latency 성능 카운터 데이터가 50ms 미만이면 서버는 적절한 시간 안에 요청을 처리할 수 있습니다. 카운터가 몇 초 이상 계속 50ms보다 큰 값을 가지면 서버에서 해당 로드를 계속 유지하는 데 문제가 있음을 나타냅니다. 따라서 사용자가 자신의 전자 메일에 액세스할 때 지연이 발생할 수도 있습니다. 평균 대기 시간이 100ms보다 크면 Microsoft Office Outlook® 클라이언트 컴퓨터에서 팝업 창에 "Retrieving data from Exchange Server" 메시지를 표시합니다.

RPC Averaged Latency 성능 카운터 해석

다음 두 가지 상황에서는 RPC Averaged Latency 카운터를 오해할 수 있습니다.

  • 우선, 일부 MAPI 작업은 오랜 시간이 걸릴 것으로 예상됩니다. 예를 들어 클라이언트 컴퓨터에서 복잡한 기준과 일치하는 모든 항목을 찾는 시도에서 수 천개의 항목이 있는 폴더를 검색할 경우 이러한 작업에 몇 초가 걸리는 것은 정상입니다. 서버에 사용자가 거의 없는 경우 이러한 진행 중인 작업으로 인해 RPC Average Latency에 스파이크를 유발할 수도 있습니다. 서버의 RPC 로드가 낮은 경우 일시적인 단기간의 동작 대신 장시간 동안(최소한 몇 분 이상) 이 값의 평균을 관찰하십시오.

  • 두 번째 상황은 서버의 RPC 로드가 매우 낮은 경우에 발생할 수 있습니다. 가장 사용량이 많은 사용자의 작업에 따라 대기 시간이 극적으로 바뀌는 경우도 있습니다. 서버 로드가 특히 강조되어 단일 사용자에 의한 집중적인 작업의 결과로 인해 RPC 평균 대기 시간 데이터가 잘못 왜곡될 수 있습니다.

RPC Requests

RPC Requests 성능 카운터는 Exchange에서 현재 처리 중인 클라이언트 컴퓨터 요청 수를 기록합니다. 카운터의 최대 값은 100입니다. Exchange 저장소에서 100개의 RPC 작업을 처리 중인 경우 새 연결을 완전히 거부합니다. 정상 서버에서는 처리 되지 않은 요청 수가 50개 미만이어야 합니다. 이 숫자가 장기간 동안 50을 초과할 경우 이는 RPC가 백업되고 처리를 기다리고 있으며 클라이언트 컴퓨터에 지연이 발생함을 나타냅니다.

RPC Requests 해석

요청 50개라는 임계값은 엄격한 임계값이 아닙니다. 로드가 낮은 서버에서는 카운터가 30에 도달하기 전부터 성능 문제가 나타나기 시작할 수 있지만 로드가 많은 서버에서는 요청이 50개인 경우에도 올바르게 작동할 수 있습니다. 각 서버에 대해 이 카운터의 기본 값을 측정하는 것이 좋습니다. Exchange Server Performance Troubleshooting Analyzer는 대부분의 대용량 서버에 적합한 임계값인 50을 사용합니다.

로드가 낮은 서버는 로드가 높은 서버에 비해 작은 RPC 요청 값을 가집니다. 이는 로드가 낮은 서버에서는 로드 보조를 맞추기 위해 스레드가 보다 적어야 하기 때문입니다. 느려지는 것을 막고 더 큰 RPC 요청 값을 가지려면 사용량이 많은 서버일수록 더 많은 동시 작업을 수행해야 합니다. 따라서 로드가 높은 서버에서는 RPC 요청 값이 크더라도 성능 문제를 의미하는 것은 아닙니다. 서버의 "느려짐"을 판단하려면 RPC Average Latency 성능 카운터도 함께 고려해야 합니다.

대기 시간의 원인

대기 시간이 증가하는 원인은 다음과 같습니다.

  • RPC 로드 증가

  • 하나 이상의 서버 리소스에서 병목 현상 발생

또한 병목 현상의 원인은 다음과 같습니다.

  • 높은 RPC 로드(또는 해당 서버의 기타 로드)

  • 하드웨어 오작동 또는 구성 오류

이 오류를 수정하려면 다음을 수행합니다.

  • 다음 Exchange Server 2003 가이드에 제공된 권장 사항과 유용한 정보를 따르십시오.

    • Exchange Server 2003 성능 및 확장성 가이드 (http://go.microsoft.com/fwlink/?LinkId=47576)

    • Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)


RPC 포트 범위가 클러스터되지 않은 서버로 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키를 읽어 포트의 값 데이터를 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

Exchange Server Analyzer는 다음 조건에서 오류를 표시합니다.

  • HKLM\Software\Microsoft\Rpc\Internet\Ports 키가 있습니다.

  • 서버가 클러스터된 Exchange 서버가 아닙니다.

  • 서버에 다른 오류가 발생했습니다.

이 레지스트리 키가 있는 경우 Exchange Server의 RPC 호출이 특정 포트 범위로 제한됩니다. Exchange 서버에 로드가 커서 현재 사용 가능한 것보다 많은 포트가 필요하면 오류가 발생할 수 있습니다.

이 문제를 해결하려면 문제가 해결될 때까지 100개의 추가 포트를 HKLM\Software\Microsoft\Rpc\Internet\Ports 키에 추가해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. 레지스트리 편집기 Regedt32.exe를 엽니다.

    참고:
    REG_MULTI_SZ 값을 편집하려면 Regedit.exe 대신 Regedt32.exe를 사용해야 합니다.

  2. HKLM\Software\Microsoft\Rpc\Internet을 탐색합니다.

  3. 오른쪽 창에서 Ports 키를 두 번 클릭합니다. 값 상자에서 포트 범위를 늘립니다.

  4. 레지스트리 편집기를 닫고 Exchange 서버를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

HKLM\Software\Microsoft\Rpc\Internet 레지스트리 키에 대한 자세한 내용은 Microsoft 기술 자료 문서 154596, "HOWTO: 방화벽에 사용할 RPC 동적 포트 할당을 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596)을 참조하십시오.


클러스터된 서버에 RPC 포트 범위가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports 레지스트리 키를 읽어 포트의 값 데이터를 확인합니다.

Exchange Server Analyzer는 다음 조건에서 오류를 표시합니다.

  • HKLM\Software\Microsoft\Rpc\Internet\Ports 키가 있습니다.

  • 서버가 클러스터된 Exchange 서버입니다.

  • 서버에 다른 오류가 있습니다.

이 레지스트리 키가 있는 경우 Exchange Server의 RPC 호출이 특정 포트 범위로 제한됩니다. Exchange 서버에 로드가 커서 현재 사용 가능한 것보다 많은 포트가 필요하면 오류가 발생할 수 있습니다.

이 문제를 해결하려면 문제가 사라질 때까지 HKLM\Software\Microsoft\Rpc\Internet\Ports 키에 다른 100개의 포트를 계속 추가해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. 레지스트리 편집기 Regedt32.exe를 엽니다.

    참고:
    REG_MULTI_SZ 값을 편집하려면 Regedit.exe 대신 Regedt32.exe를 사용해야 합니다.

  2. HKLM\Software\Microsoft\Rpc\Internet을 탐색합니다.

  3. 오른쪽 창에서 Ports 키를 두 번 클릭합니다. 값 상자에서 포트 범위를 늘립니다.

  4. 레지스트리 편집기를 닫고 Exchange 서버를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

HKLM\Software\Microsoft\Rpc\Internet 레지스트리 키에 대한 자세한 내용은 Microsoft 기술 자료 문서 154596, "방화벽에 사용할 RPC 동적 포트 할당을 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596)을 참조하십시오.


성능 카운터의 RPC 사용자 작업
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2007-02-14

Microsoft® Exchange Server Analyzer Tool은 사용 중인 서버의 RPC(원격 프로시저 호출) 로드가 증가하고 있음을 확인했습니다.

초당 RPC 작업 비율은 서버에 존재하는 RPC 로드의 양을 나타냅니다. 경우에 따라 예기치 않은 RPC 작업 로드의 증가로 인해 서버 성능이 저하될 수 있습니다. 서버에 성능 문제가 있는 경우에는 먼저 서버의 로드가 예상보다 높은지 확인하십시오. 서버의 RPC 작업에 대한 정보를 제공하는 성능 카운터가 여러 개 있습니다. 이 문서에서 설명하고 있는 다음 성능 카운터는 모두 MSExchangeIS, MSExchangeIS Public 또는 MSExchangeIS Mailbox 성능 개체에 있습니다.

  • RPC Operations/sec

  • Active User Count

  • Active Client Logons(MSExchangeIS Public)

  • Active Client Logons(MSExchangeIS Mailbox)

클라이언트 RPC 로드 확인

클라이언트 컴퓨터의 현재 작업률을 확인하는 데 사용할 수 있는 카운터에는 두 가지가 있습니다.

  • RPC Operations/sec 이 카운터는 현재 클라이언트 컴퓨터가 서버에 요청하고 있는 초당 RPC 작업 수를 제공합니다. 다음 방법으로 사용자 수를 셀 수 있습니다.

    • 서버에 있는 총 사서함 수를 셀 수 있습니다.

    • Active Client Logons(MSExchangeIS Public) 및 Active Client Logons(MSExchangeIS Mailbox)의 합계에서 총 로그온 수를 셀 수 있습니다.

    • Active User Count에서 총 로그온 수를 셀 수 있습니다.

    Exchange Server Analyzer는 마지막 방법을 사용합니다. 작업 중인 사용자당 비율을 계산하려면 평균 RPC Operations/sec를 Active User Count로 나눕니다.

  • RPC Operations/sec per user 이 카운터는 서버에서 사용자의 작업률을 표시합니다. 일반적으로 Microsoft Office Outlook®을 사용하는 지식 근로자들은 사서함 서버의 사용자별로 초당 약 0.1의 작업률을 보입니다. 서버의 사용자가 추가적인 응용 프로그램을 실행하고 있는 경우 작업률이 높아질 수 있습니다.

Exchange Server Analyzer는 사용자별로 초당 RPC 작업이 0.15보다 크고 0.25보다 작다고 판단한 경우 사용자 작업률이 적절하다고 간주하고 경고를 표시합니다.

Exchange Server Analyzer는 사용자별로 초당 RPC 작업이 0.25보다 크다고 판단한 경우 사용자 작업률이 높다고 간주하고 오류를 표시합니다.

RPC 로드가 높을 경우 수행할 작업

초당 작업이 기대치보다 높을 경우 먼저 로드를 증가시킨 원인을 확인하고 로드를 줄여야 합니다. ExMon(Exchange Server User Monitor) 도구를 사용하여 특정 사용자가 높은 RPC 작업률을 발생시키고 있는지 확인할 수 있습니다.

서버에서 로드를 줄일 수 없는 경우에는 성능 지체를 확인하고 서버 용량을 늘려야 합니다.

많은 로그온 수 확인

서버는 사용자와 커널 메모리에서 모두 로그온에 대한 몇 가지 정보를 유지해야 합니다. 따로 남겨둔 제한된 양의 메모리가 있습니다. 이 메모리를 사용하는 경우 서버에 메모리 병목 현상이 발생할 수 있습니다. 따라서 Exchange 서버에 성능 문제가 발생하는 경우에는 사용자당 총 로그온 수가 지나치게 많지 않도록 해야 합니다.

일반적인 지식 근로자는 두 세 가지 로그온을 사용하게 됩니다. 사용자가 다른 응용 프로그램을 실행하게 되면 로그온 수가 증가할 수 있습니다. Exchange Server Analyzer는 서버의 총 로그온 수를 사서함 수로 나누어 사용자당 총 로그온 수를 계산합니다. MSExchangeIS Mailbox 및 MSExchangeIS Public 성능 개체의 Active Client Logons 성능 카운터를 모두 합하여 서버의 총 로그온 수를 확인할 수 있습니다. Exchange Server Analyzer는 사서함 또는 혼합 사서함 및 공용 폴더 서버에 대해 이 비율만을 검색합니다.

참고:
다수의 사용자가 공유 일정 같은 다른 사용자의 공유 폴더를 보고 있는 경우에도 로그온 수가 증가할 수 있습니다.

사용자당 평균 로그온 수가 5 이상이고 서버에서 메모리 병목 현상이 발생할 경우에는 사용자가 다량의 로그온을 만드는 응용 프로그램을 실행하고 있는 것일 수 있습니다. 사용자가 업무용으로 필요하지 않는 응용 프로그램을 실행하는 경우에는 Exchange 서버에 과도한 로그온을 발생시키는 응용 프로그램을 실행하지 않도록 요청하십시오.

사용자가 실행하고 있는 응용 프로그램의 수를 줄일 수 없는 경우에는 사용자를 다른 서버로 이동하여 서버당 사용자 수를 줄여야 합니다. 과도한 로그온의 원인이 사용자 수가 많기 때문인지 또는 한 사용자가 지나치게 많은 로그온 수를 갖고 있기 때문인지 확인하려면 Exchange System Manager를 사용하여 사용자별로 활성 상태인 로그온을 확인합니다.

자세한 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


RTF 바이러스 백신 검색이 비활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 RTF(서식 있는 텍스트) 메시지 바이러스 백신 검색 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Exchange Server Analyzer는 ScanRTF 값이 0으로 설정되어 있을 경우 경고를 표시합니다.

ScanRTF 레지스트리 키는 Exchange VSAPI(바이러스 검색 API)를 사용하는 바이러스 백신 공급업체가 설정합니다. RTF 메시지에서 색, 글꼴, 서식을 사용할 수 있지만 RTF는 Microsoft Office Outlook® 2003에서만 읽을 수 있습니다. Exchange Server RTF 형식은 Microsoft Office Word 2003과 같은 워드 프로세서에서 RTF 형식의 파일을 읽는 것과 다릅니다.

RTF 메시지를 포함하는 모든 유형의 메시지에서 바이러스를 검색하는 것이 좋습니다. Exchange Server 컴퓨터에서 들어오거나 나가는 모든 메시지에 대해 바이러스 검색을 설정해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange에서 인식하는 바이러스 백신 응용 프로그램에서 모든 메시지의 검색을 활성화합니다.

    또는

  2. 다음 절차를 수행하여 레지스트리 항목을 수동으로 수정합니다.

    • Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

    • 다음 항목을 탐색합니다.

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    • ScanRTF 레지스트리 항목을 두 번 클릭하고 해당 값 데이터를 1로 설정합니다.

    • 레지스트리 편집기를 끝내고 Exchange에서 인식하는 바이러스 백신 소프트웨어를 나타내는 서비스와 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

바이러스 퇴치 방법에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=30732)를 참조하십시오.


SMTP 배너가 사용자 지정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 SMTP(Simple Mail Transfer Protocol) 도메인에 대한 사용자 정의 계정 또는 전자 메일 관리자 계정에 메시지를 보내려고 시도합니다. Exchange Server Analyzer는 해당 계정에서 다음 기본 응답과 다른 응답을 받으면 경고를 표시합니다.

"220 Computer Name . Domain Name .com Microsoft ESMTP MAIL Service, Version: Version Number ready at Date Time +0000"

이 경고는 Exchange SMTP 가상 서버에 프로그램을 연결하면 나타나는 기본 응답이 사용자 지정되었음을 나타냅니다.

Exchange 서버 관리자가 Microsoft 기술 자료 문서 281224, "XCON: SMTP 배너를 수정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224)에 설명된 것과 같이 의도적으로 배너를 변경한 경우에는 사용자 지정된 SMTP 배너가 문제가 되지 않을 수도 있습니다.

Exchange 서버 관리자가 기본 SMTP 배너를 의도적으로 사용자 지정하지 않은 경우, 이 경고는 Exchange 서버가 ESMTP(Exchange Server Extended SMPT) 명령을 필터링하는 SMTP 프록시 또는 방화벽을 통해 연결되어 있음을 나타낼 수 있습니다.

Exchange 서버 ESMTP 명령이 필터링된 경우, Exchange 성능에 크게 영향을 줄 수 있으며 Microsoft 기술 자료 문서 320027, "XCON: Cisco PIX 방화벽 뒤에서 전자 메일 메시지를 보내거나 받을 수 없다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027)에 설명되어 있는 동작을 유발할 수 있습니다.

사용자 지정된 SMTP 배너에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • "XCON: SMTP 배너를 수정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224)

  • "XCON: Cisco PIX 방화벽 뒤에서 전자 메일 메시지를 보내거나 받을 수 없다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027)


SMTP 인스턴스가 일시 정지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-05-16

Microsoft® Exchange Server Analyzer Tool은 IIS 메타베이스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 가상 서버의 각 인스턴스에 대한 ServerState 속성 값을 확인합니다.

ServerState 속성은 서버 인스턴스의 현재 상태를 나타냅니다. 상태 및 해당 상태 코드에는 1(시작 중), 2(시작됨), 3(중지하는 중), 4(중지됨), 5(일시 정지 중), 6(일시 정지됨), 7(계속) 등이 있습니다.

Exchange Server Analyzer는 SMTP 가상 서버 인스턴스의 ServerState 속성 값이 6(일시 정지됨)임이 확인되면 오류를 표시합니다.

SMTP는 Exchange 서버의 메일 전송을 위한 기본 메일 프로토콜입니다. 그러므로 클라이언트에서는 SMTP를 사용하여 메시지를 보내고 Exchange 서버에서는 SMTP를 사용하여 메시지와 메시지 데이터를 배달합니다.

다른 서버 프로세스와 마찬가지로 시작, 중지 및 일시 정지할 수 있는 서버 프로세스에서 가상 서버를 실행합니다. 예를 들어 가상 서버 구성을 변경하거나 다른 유지 관리 작업을 수행하는 경우 가상 서버를 중지하고 변경한 다음 다시 시작해야 합니다. 가상 서버를 중지하면 가상 서버에서 사용자의 연결 요청을 수락하지 않으며 이 가상 서버를 사용하여 메일을 배달하거나 검색할 수 없습니다.

가상 서버를 중지하는 대신 일시 정지할 수도 있습니다. 가상 서버를 일시 정지하면 새 클라이언트 연결은 수락하지 않지만 현재 연결을 끊지 않습니다. SMTP 가상 서버를 일시 정지하면 활성 클라이언트는 계속해서 메시지를 전송할 수 있으며, 서버는 배달을 위해 큐에 대기 중인 기존 메시지를 배달할 수 있습니다. 그러나 새로운 연결은 수락되지 않습니다.

일반적인 메시징 작업을 수행하려면 Exchange Server SMTP 가상 서버 인스턴스가 시작됨 상태여야 합니다.

이 오류를 해결하려면 다음 단계를 따라 SMTP 가상 서버 인스턴스를 시작합니다.

SMTP 가상 서버 인스턴스를 시작하려면 다음을 수행합니다.

  1. Exchange System Manager에서 시작할 가상 서버 인스턴스를 마우스 오른쪽 단추로 클릭합니다.

  2. 작업 메뉴에서 시작을 클릭합니다.

SMTP 가상 서버를 시작, 중지 또는 일시 정지하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

  • "XIMS: Exchange 2000 Server에서 SMTP 메일 큐를 플러시하는 방법" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087)

  • "XGEN: Exchange 2000에서 프로토콜 사용 안 함"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330)


SMTP 인스턴스가 중지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-05-16

Microsoft® Exchange Server Analyzer Tool은 IIS 메타데이터를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 가상 서버의 각 인스턴스에 대한 ServerState 속성 값을 확인합니다.

ServerState 속성은 서버 인스턴스의 현재 상태를 나타냅니다. 상태 및 해당 상태 코드에는 1(시작 중), 2(시작됨), 3(중지하는 중), 4(중지됨), 5(일시 정지 중), 6(일시 정지됨), 7(계속) 등이 있습니다.

Exchange Server Analyzer는 SMTP 가상 서버 인스턴스의 ServerState 속성 값이 4(중지됨)임이 확인되면 오류를 표시합니다.

SMTP는 Exchange Server의 메일 전송을 위한 고유 메일 프로토콜입니다. 그러므로 클라이언트에서는 SMTP를 사용하여 메시지를 보내고 Exchange 서버에서는 SMTP를 사용하여 메시지와 메시지 데이터를 배달합니다.

다른 서버 프로세스와 마찬가지로 시작, 중지 및 일시 정지할 수 있는 서버 프로세스에서 가상 서버를 실행합니다. 예를 들어 가상 서버 구성을 변경하거나 다른 유지 관리 작업을 수행하는 경우 가상 서버를 중지하고 변경한 다음 다시 시작해야 합니다. 가상 서버를 중지하면 가상 서버에서 사용자의 연결 요청을 수락하지 않으며 이 가상 서버를 사용하여 메일을 배달하거나 검색할 수 없습니다.

일반적인 메시징 작업을 수행하려면 Exchange Server SMTP 가상 서버 인스턴스가 시작됨 상태여야 합니다.

이 오류를 해결하려면 다음 단계를 따라 SMTP 가상 서버 인스턴스를 시작합니다.

SMTP 가상 서버 인스턴스를 시작하려면 다음을 수행합니다.

  1. Exchange System Manager에서 시작할 가상 서버 인스턴스를 마우스 오른쪽 단추로 클릭합니다.

  2. 동작 메뉴에서 시작을 클릭합니다.

SMTP 가상 서버를 시작, 중지 또는 일시 정지하는 방법은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

  • "XIMS: Exchange 2000 Server에서 SMTP 메일 큐를 플러시하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087)

  • "XGEN: Exchange 2000에서 프로토콜 사용 안 함"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330)


SMTP 최대 받는 사람 수가 너무 낮게 설정되어 있을 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 msExchSmtpMaxRecipients 특성의 구성 값이 250보다 작은지 확인합니다. 기본적으로 msExchSmtpMaxRecipients 특성은 받는 사람을 64,000으로 구성합니다. Exchange Server Analyzer는 msExchSmtpMaxRecipients 특성이 250보다 작은 값으로 구성되면 경고를 표시합니다.

보안 측면에서는 각 메시지의 최대 받는 사람 수를 제한하는 것이 좋습니다. msExchSmtpMaxRecipients 특성을 기본값인 64000으로 설정해 두는 것이 좋습니다.

각 조직은 자사의 비즈니스 요구에 따라 적합한 최대 받는 사람 수를 결정해야 합니다. 그러나 최대 받는 사람 수를 250 이하 값으로 설정하지 않는 것이 좋습니다. 여러 메일 그룹에 지정된 메시지의 받는 사람은 250명보다 많을 수 있습니다. 최대 받는 사람 수를 250 미만 값으로 설정하면 Exchange는 추가 메시지 복사본을 사용하여 나머지 받는 사람을 처리해야 합니다. 이러한 추가 복사본으로 인해 네트워크 소통량이 늘어날 수 있습니다.

최대 받는 사람 수를 보고 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange 서버, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  4. 메시지 탭을 선택합니다.

  5. 기본 설정인 64000으로 되돌리려면 메시지당 받는 사람 수 제한 확인란을 선택하고 64000 값을 입력합니다. 기본 설정 대신에 이 필드를 원하는 값으로 구성하거나 확인란의 선택을 해제하여 받는 사람 수를 제한하지 않을 수 있습니다.

  6. 확인을 클릭하여 변경 내용을 저장하고 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


EAS용 SMTP 프록시 주소가 다시 정의되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

오류 메시지

소개

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange ActiveSync®에 대한 SMTP 프록시 주소의 다시 정의 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\SMTPProxy

Exchange Server Analyzer는 SMTPProxy 레지스트리 항목이 존재하고 구성되면 기본 구성이 아니라는 메시지를 표시합니다.

SMTP 주소는 Exchange Server의 사서함 경로를 식별하는 데 사용되므로 고유해야 합니다. 각 주소에는 @ 기호를 중심으로 좌측(LHS) 부분과 우측(RHS) 부분이 있습니다. 예를 들어 SMTP 주소 형식은 아래와 같습니다.

Username@domain.com = 좌측@우측(또는 LHS@RHS)

Exchange ActiveSync는 WebDAV 요청을 사용하여 Exchange Server의 사서함 정보에 액세스합니다. Exchange ActiveSync는 WebDAV 요청에 사용하기 위해 SMTP 프록시 주소를 나타내는 LHS@RHS와 함께 관련 RHS 값을 선택합니다. 사용자의 기본 SMTP 주소와 다른 기본 RHS 주소를 가진 환경에서 SMTPProxy 레지스트리 값을 사용하면 Exchange ActiveSync가 대체 SMTP 프록시 주소를 사용할 수 있도록 구성할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

SMTPProxy 레지스트리 값을 보거나 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. SMTPProxy 값을 검사하고 필요한 경우 변경합니다.

  4. 레지스트리 내용을 변경했으면 레지스트리 편집기를 닫고 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange ActiveSync에 대한 자세한 내용은 "Exchange Server 2003 ActiveSync Architecture"(http://go.microsoft.com/fwlink/?linkid=34203)를 참조하십시오.

Mobile Access와 Exchange Server 2003에 대한 자세한 내용은 "Mobile Access Using Exchange 2003"(http://go.microsoft.com/fwlink/?linkid=20098)을 참조하십시오.


SMTP 서버에서 기본 인증을 수락합니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 개체에 대한 protocolCfgSMTPServer 클래스의 msExchAuthenticationFlags 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. protocolCfgSMTPServer 클래스에는 SMTP 가상 서버에 대한 설정이 포함되어 있습니다. msExchAuthenticationFlags 특성은 SMTP 서버에 허용되는 인증 형식을 나타냅니다. Exchange Server Analyzer는 기본 인증이 SMTP 서버에 구성되어 있고 이 서버가 Microsoft Small Business Server 2000 또는 Windows® Small Business Server 2003이 아니라는 것을 확인하면 경고 메시지를 표시합니다.

SMTP 서버가 기본 인증으로 구성되어 있는 경우 보안 침해 위험이 높아질 수 있습니다. 기본 인증을 사용하면 사용자 이름과 암호를 일반 텍스트로 네트워크에 보낼 수 있습니다. 암호화하지 않으면 사용자 이름과 암호를 쉽게 인터넷에서 도용할 수 있습니다.

기본 인증을 사용할 경우 보안을 강화할 수 있도록 TLS(Transport Layer Security) 암호화도 사용하는 것이 좋습니다. TLS는 사용자 이름, 암호 및 메시지 데이터를 암호화합니다. SMTP 가상 서버에 연결하는 클라이언트가 TLS 암호화를 사용하도록 요청할 수 있습니다. TLS는 보내는 메시지를 보호하도록 디자인되어 있지만 클라이언트에서 서버로 이동하는 트래픽을 보호하지는 못합니다.

TLS는 Microsoft Outlook Express에서 지원됩니다. SMTP 가상 서버에 TLS 암호화를 사용하려면 키 쌍을 만들고 키 인증서를 구성해야 합니다. 그런 다음 클라이언트는 TLS를 사용하여 SMTP 서비스의 세션을 암호화할 수 있습니다. 따라서 모든 메시지가 전송됩니다. 또한 SMTP 서비스는 TLS를 사용하여 원격 서버의 세션을 암호화할 수 있습니다.

참고:
TLS를 지원하지 않는 클라이언트는 가상 서버를 통해 전자 메일 메시지를 릴레이할 수 없습니다.

업무상 이유(예: 파트너 회사에 의한 인증)로 SMTP 가상 서버에 인증된 액세스를 하지 못하도록 설정할 수 없는 경우 이러한 단계에 따라 게이트웨이 서버의 보안을 향상시킵니다.

  • 모든 사용자 계정, 특히 관리자 계정에 강력한 암호 정책을 실행합니다.

  • 게스트 계정을 사용하지 않습니다. 게스트 계정을 사용하지 않도록 설정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 320053, "How to rename the administrator and guest account in Windows 2000"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053)을 참조하십시오. 이 문서의 내용은 Microsoft Windows 2000 Server에 적용되지만 Windows Server™ 2003에도 유사한 원칙이 적용됩니다.

기본 인증을 사용할 수 없게 하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, <인바운드 Exchange 서버>, 프로토콜 및 SMTP를 차례로 확장합니다.

  2. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 액세스 탭을 클릭한 다음 인증을 클릭합니다.

    인증 대화 상자

  4. 인증에서 기본 인증 확인란의 선택을 해제합니다.

    중요:
    기본 인증을 사용할 경우 보안을 강화하려면 TLS를 구현합니다. 디지털 인증서가 있으면 TLS 암호화 필요 확인란을 사용합니다. 고도의 보안 환경에서는 디지털 인증서가 일반적으로 사용됩니다. 이 확인란을 선택하면 해당 기본 도메인 상자에 사용자가 도메인을 지정하지 않는 경우 인증해야 하는 Windows 2000 도메인 이름이나 Windows Server 2003 도메인 이름을 입력해야 합니다. TLS 인증에 대한 자세한 내용은 Exchange 온라인 설명서를 참조하십시오.

인터넷 메일을 보다 안전하게 주고받을 수 있도록 Exchange Server 2003 조직을 구성하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드 (http://go.microsoft.com/fwlink/?LinkId=26041)를 참조하십시오.


SMTP 서비스 사용 안 함
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-05-16

Microsoft® Exchange Server Analyzer Tool은 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 서비스 StartMode 키의 값 집합을 확인합니다. 값이 Disabled로 설정되어 있으면 SMTP(Simple Mail Transfer Protocol) 서비스가 비활성화되어 있으므로 StartMode 값을 Manual 또는 Automatic으로 변경해야 시작할 수 있습니다.

또한 Exchange Server Analyzer는 Win32_Service WMI 클래스를 쿼리하여 SMTP 서비스의 Started 키 값을 확인합니다. False 값은 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 서비스가 실행되고 있음을 나타냅니다.

SMTP 서비스를 시작한 Exchange Server 컴퓨터에서 StartMode키 값이 Disabled로 설정되어 있으면 오류가 표시됩니다.

Windows SMTP 서비스는 인터넷 정보 서비스(IIS)의 구성 요소로, Inetinfo.exe의 일부로서 실행됩니다. Exchange Server는 SMTP 서비스를 고유 전송 프로토콜로 사용합니다. 그러므로 Exchange는 SMTP를 사용하여 모든 내부 메시지와 외부 메시지를 라우팅합니다.

모든 Exchange Server 컴퓨터에서 SMTP 서비스는 Automatic으로 설정해야 합니다.

이 오류를 해결하려면 메일을 라우팅하는 서버에서 SMTP 서비스가 자동으로 시작되도록 구성해야 합니다.

SMTP(Simple Mail Transfer Protocol) 서비스가 자동으로 시작되도록 구성하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. SMTP(Simple Mail Transfer Protocol) 서비스를 두 번 클릭합니다.

  3. SMTP(Simple Mail Transfer Protocol) 속성 페이지에서 일반 탭의 시작 유형 드롭다운 대화 상자에서 자동을 선택하고 적용을 클릭합니다.

  4. 서비스 상태에서 시작을 클릭한 다음 확인을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.

SMTP 서비스 및 Exchange Server에 대한 자세한 내용은 Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "SMTP 전송 아키텍처"를 참조하십시오.

Exchange용 SMTP 서비스 구성 방법에 대한 자세한 내용은 "Microsoft Exchange 2000 Server에서 SMTP 구성"(http://go.microsoft.com/fwlink/?LinkId=24866)을 참조하십시오.


SMTP 서비스가 시작되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2007-03-13

Exchange Server Analyzer Tool은 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 서비스의 Started 키 값을 확인합니다. False 값은 SMTP 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 SMTP 서비스가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 Started 키 값이 False로 설정된 경우 오류를 표시합니다.

Windows SMTP 서비스는 인터넷 정보 서비스(IIS)의 구성 요소로, Inetinfo.exe의 일부로서 실행됩니다. Exchange Server는 SMTP 서비스를 고유 전송 프로토콜로 사용합니다. 그러므로 Exchange는 SMTP를 사용하여 모든 내부 메시지와 외부 메시지를 라우팅합니다.

Exchange 서버에는 항상 SMTP 서비스가 실행되고 있어야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. 오른쪽 창에서 SMTP(Simple Mail Transfer Protocol) 서비스로 스크롤하여 두 번 클릭합니다. 그러면 SMTP(Simple Mail Transfer Protocol) 속성 대화 상자가 표시됩니다.

  3. 시작 유형 드롭다운 메뉴의 값을 자동으로 설정합니다.

  4. 시작을 클릭하여 System Attendant 서비스를 시작합니다.

  5. 확인을 클릭하여 변경 내용을 저장하고 SMTP(Simple Mail Transfer Protocol) 속성 대화 상자를 닫습니다.

  6. 서비스 스냅인을 닫습니다.

SMTP(Simple Mail Transfer Protocol) 서비스 및 Exchange Server에 대한 자세한 내용은 Exchange Server 2003 기술 참조 가이드(http://go.microsoft.com/fwlink/?LinkId=47891)의 "SMTP 전송 아키텍처"를 참조하십시오.

Exchange용 SMTP 서비스 구성 방법에 대한 자세한 내용은 "Microsoft Exchange 2000 Server에서 SMTP 구성"(http://go.microsoft.com/fwlink/?LinkId=24866)을 참조하십시오.


SMTP 서비스가 수동으로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-05-16

Microsoft® Exchange Server Analyzer Tool은 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 서비스 StartMode 키의 값 집합을 확인합니다. Manual 값은 수동으로 시작해야 하며 자동으로 시작되지 않도록 SMTP(Simple Mail Transfer Protocol) 서비스를 설정했음을 나타냅니다.

또한 Exchange Server Analyzer는 Win32_Service WMI 클래스를 쿼리하여 SMTP 서비스의 Started 키 값을 확인합니다. False 값은 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 서비스가 실행되고 있음을 나타냅니다.

SMTP 서비스를 시작한 Exchange Server 컴퓨터에서 StartMode 키 값이 Manual로 설정되어 있으면 경고가 표시됩니다.

Windows SMTP 서비스는 인터넷 정보 서비스(IIS)의 구성 요소로, Inetinfo.exe의 일부로서 실행됩니다. Exchange Server는 SMTP 서비스를 고유 전송 프로토콜로 사용합니다. 그러므로 Exchange는 SMTP를 사용하여 모든 내부 메시지와 외부 메시지를 라우팅합니다.

시작 시 SMTP 서비스가 자동으로 시작되지 않으면 그냥 지나칠 수 있습니다. 이는 심각한 메일 흐름 문제로 이어질 수 있습니다.

모든 Exchange Server 컴퓨터에서 SMTP 서비스는 Automatic으로 설정해야 합니다.

이 오류를 해결하려면 메일을 라우팅하는 서버에서 SMTP 서비스가 자동으로 시작되도록 구성해야 합니다.

SMTP(Simple Mail Transfer Protocol) 서비스가 자동으로 시작되도록 구성하려면 다음을 수행합니다.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. SMTP(Simple Mail Transfer Protocol) 서비스를 두 번 클릭합니다.

  3. SMTP(Simple Mail Transfer Protocol) 속성 페이지에서 일반 탭의 시작 유형 드롭다운 대화 상자에서 자동을 선택하고 적용을 클릭합니다.

  4. 서비스 상태에서 시작을 클릭한 다음 확인을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.

SMTP 서비스 및 Exchange Server에 대한 자세한 내용은 Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "SMTP 전송 아키텍처"를 참조하십시오.

Exchange용 SMTP 서비스 구성 방법에 대한 자세한 내용은 "Microsoft Exchange 2000 Server에서 SMTP 구성"(http://go.microsoft.com/fwlink/?LinkId=24866)을 참조하십시오.


SMTP 서비스 상태 알 수 없음
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-10-06

Exchange Server Analyzer Tool은 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 서비스의 Started 키 값을 확인합니다. False 값은 SMTP 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 SMTP 서비스가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 Started 키 값을 확인할 수 없는 경우에 오류를 표시합니다.

이 오류는 요청된 데이터를 WMI 쿼리에서 검색할 수 없음을 나타냅니다.

주로 다음과 같은 경우에 이 오류가 발생합니다.

  • Exchange Server Analyzer를 실행하는 계정에 WMI 클래스를 쿼리할 수 있는 충분한 권한이 없는 경우

  • 네트워크 문제 때문에 Exchange Server Analyzer를 컴퓨터에 연결할 수 없는 경우

  • 원인을 알 수 없는 일시적인 문제로 인해 쿼리 시간 제한에 걸린 경우

이 오류를 해결하려면 다음을 수행하십시오.

  1. Exchange Server를 실행 중인 서버가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. PING 명령을 사용하여 Exchange 서버에 연결할 수 있는지 확인합니다.

  3. 방화벽이 있는 경우 RPC(원격 프로시저 호출) 포트가 차단되어 있는지 확인합니다.

  4. Exchange Server Analyzer를 실행하는 계정에 대한 사용 권한을 검토합니다. Exchange Server Analyzer를 실행하는 계정에는 검색 중인 각 Exchange 서버에 대한 로컬 관리자 권한이 있어야 합니다.

    또는 Exchange Server Analyzer를 실행 중인 계정에 특정 WMI 사용 권한을 부여할 수 있습니다.

    1. Exchange 서버에서 컴퓨터 관리 MMC(Microsoft Management Console) 트리를 엽니다.

    2. 서비스 및 응용 프로그램에서 WMI 컨트롤을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

    3. WMI 컨트롤 속성 대화 상자에서 보안 탭을 클릭한 다음 루트를 확장합니다.

    4. CIMV2 폴더를 선택하고 보안을 클릭합니다.

    5. ROOT\CIMV2에 대한 보안 페이지에서 Exchange Server Analyzer를 실행하는 계정을 추가합니다.

  5. 5단계에서 추가한 계정을 선택합니다. Selected_Account의 사용 권한에서 허용 열 아래의 원격으로부터 사용 가능 및 보안 읽기를 모두 선택한 다음 확인을 클릭합니다.

SMTP 서비스 및 Exchange Server에 대한 자세한 내용은 Exchange Server 2003 기술 참조 가이드(http://go.microsoft.com/fwlink/?LinkId=47891)의 "SMTP 전송 아키텍처"를 참조하십시오.

Exchange용 SMTP 서비스 구성 방법에 대한 자세한 내용은 "Microsoft Exchange 2000 Server에서 SMTP 구성"(http://go.microsoft.com/fwlink/?LinkId=24866)을 참조하십시오.

네트워크 연결 문제를 해결하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

Exchange Server Analyzer 연결 문제를 해결하는 방법에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool 연결 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=56285)을 참조하십시오.


UseAltRegionalCharset 및 UseRegionalCharset 레지스트리 값이 모두 사용하도록 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 Microsoft Outlook® Web Access 클라이언트에서 사용하는 언어 설정을 확인합니다.

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

    설정을 1로 하면 UTF-8 메시지 본문이 저장소에서 UTF-8 형식 대신 국가별 문자 집합 또는 코드 페이지로 유지됩니다. 이것이 Exchange Server 2003 UseRegionalCharset 레지스트리 값의 기본 설정입니다.

  • HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

다음과 같은 경우 브라우저 수준이 메시지 인코딩을 결정합니다.

  • UseAltRegionalCharset 키가 설정되어 있지 않거나 0으로 설정되어 있습니다.

  • 마찬가지로 관련 UseRegionalCharset 키가 설정되어 있지 않거나 0으로 설정되어 있습니다.

Internet Explorer 5 이상 버전과 같은 상위 수준 브라우저는 UTF-8 형식으로 메시지를 보냅니다. 이전 브라우저나 Internet Explorer 5 이외의 다른 브라우저는 해당 브라우저에서 허용하는 언어에 적합한 인코딩으로 메시지를 보냅니다.

UseAltRegionalCharset 키만이 다음 목록에 있는 언어에 대해 구성된 브라우저의 동작을 변경합니다.

  • 한국어: KS_C_5601-1987

  • 일본어: shift_jis

  • 서유럽어: windows-1252

  • 러시아어: windows-1251

  • 중앙 유럽어: windows-1250

UseAltRegionalCharset 키가 1로 설정되어 있는 경우 상위 수준 브라우저와 이전 브라우저는 모두 다음 인코딩으로 메시지를 보냅니다.

  • 한국어: euc_kr

  • 일본어: iso-2022-jp(JIS)

  • 서유럽어: iso-8859-1

  • 러시아어: koi8-r

  • 중앙 유럽어: iso-8859-2

또한 Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

  • 문자열 값에 "Version 6.0"이 포함되어 있으면 컴퓨터에서 Exchange Server 2000을 실행하고 있는 것입니다.

  • 문자열 값에 "Version 6.5"이 포함되어 있으면 컴퓨터에서 Exchange Server 2003를 실행하고 있는 것입니다.

다음 조건에 해당하는 경우 Exchange Server Analyzer에서 경고 메시지를 표시합니다.

  • UseAltRegionalCharset과 UseRegionalCharset이 모두 존재합니다.

  • UseAltRegionalCharset과 UseRegionalCharset이 모두 Exchange 2000 서버 또는 Exchange 2003 서버에서 값 1을 사용하도록 구성되어 있습니다.

Exchange 2000 Server 및 Exchange Server 2003의 경우 다음 조건에 해당하면 대체 문자 집합이 우선권을 갖습니다.

  • 국가별 문자 사용이 켜져 있습니다 - UseRegionalCharset 레지스트리 키 REG_DWORD 값이 -1로 설정되어 있습니다.

  • 대체 문자 집합 사용이 켜져 있습니다 - UseAltRegionalCharset 레지스트리 키 REG_DWORD 값이 0x1로 설정되어 있습니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 있습니다. 레지스트리를 편집하려면 먼저 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 문제를 수정하려면 다음을 수행합니다.

  1. Exchange 컴퓨터에서 Regedit.exe 또는 RegEdt32.exe와 같은 레지스트리 편집기를 엽니다.

  2. Exchange Server 환경에 적합한 Outlook Web Access 언어 설정을 확인하고 적절하지 않은 키를 제거합니다.

    1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\를 탐색합니다.

    2. 제거할 키를 선택하고 키를 마우스 오른쪽 단추로 클릭한 다음 드롭다운 목록에서 삭제를 선택합니다.

  3. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Outlook Web Access 언어 설정에 대한 자세한 내용은 다음 Exchange Server 리소스를 참조하십시오.

"Exchange Server Client Access Guide"(http://go.microsoft.com/fwlink/?LinkId=47568).

Microsoft 기술 자료 문서 311342, "XCCC: Exchange 2000 Server SP2 Server-Side OWA Registry Keys"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342).


Exchange 2000 Server에서 UseAltRegionalCharset 레지스트리 값이 사용됩니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Outlook® Web Access의 클라이언트 언어 설정에 UseAltRegionalCharset이 사용되는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

다음 조건에 해당하는 경우 메시지 인코딩은 브라우저 수준에 따라 결정됩니다.

  • UseAltRegionalCharset 키가 설정되지 않거나 0으로 설정되어 있습니다.

  • UseRegionalCharset이 비슷하게 설정되지 않거나 0으로 설정되어 있습니다.

UseAltRegionalCharset 키는 다음 목록의 언어로 구성된 브라우저 동작만을 변경합니다.

  • 한국어: KS_C_5601-1987

  • 일본어: shift_jis

  • 서유럽어: windows-1252

  • 러시아어: windows-1251

  • 중앙 유럽어: windows-1250

UseAltRegionalCharset 키가 1로 설정되어 있는 경우 상위 수준 브라우저와 이전 브라우저는 모두 다음 인코딩으로 메시지를 보냅니다.

  • 한국어: euc_kr

  • 일본어: iso-2022-jp(JIS)

  • 서유럽어: iso-8859-1

  • 러시아어: koi8-r

  • 중앙 유럽어: iso-8859-2

또한 Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 6.0"이 포함되어 있으면 컴퓨터에서 Exchange 2000 Server가 실행되고 있는 것입니다.

Exchange Server Analyzer는 UseAltRegionalCharset이 Exchange 2000 Server를 실행하는 컴퓨터에서 0보다 큰 값을 사용하면 기본 구성이 아니라는 메시지를 표시합니다.

이 메시지는 Exchange 2000 서버에서 UseAltRegionalCharset 레지스트리 매개 변수가 사용됨을 나타냅니다. 조직에 속한 Outlook Web Access 사용자가 다양한 문자 집합을 사용하는 받는 사람에게 메일을 자주 보낼 경우에는 Internet Explorer 5 이상 버전을 실행하는 사용자가 UTF-8로 인코딩된 UNICODE 문자를 사용하여 메일을 보낼 수 있도록 레지스트리 설정을 수정할 수 있습니다. 여러 문자 집합이 필요하지 않은 경우에는 다음 절차에 따라 기본 구성을 복원할 수 있습니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
Outlook Web Access의 기본 언어 설정을 복원하려면 다음을 수행합니다.

  1. Exchange 컴퓨터에서 Regedit.exe 또는 RegEdt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\로 이동합니다.

  3. 오른쪽 창에서 UseAltRegionalCharSet 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Outlook Web Access 언어 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 311342, "XCCC: Exchange 2000 Server SP2 Server-Side OWA Registry Keys"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342)를 참조하십시오.


Exchange Server 2003에서 UseAltRegionalCharset 레지스트리 값이 사용됩니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 UseAltRegionalCharset 레지스트리 값이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\

UseAltRegionalCharset 레지스트리 값을 통해 Microsoft Outlook® Web Access 사용자는 대체 문자 집합을 사용하여 전자 메일을 인코딩할 수 있습니다.

또한 Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 6.5"가 포함되어 있으면 컴퓨터에서 Exchange Server 2003이 실행되고 있는 것입니다.

Exchange Server Analyzer는 UseAltRegionalCharset 레지스트리 값이 Exchange 2003 서버에 대해 0보다 크게 설정된 경우 기본 구성이 아니라는 메시지를 표시합니다.

이 메시지는 이 Exchange 2003 서버에 대해 UseAltRegionalCharset이 구성되었음을 나타냅니다. 이 설정으로 인해 Outlook Web Access 메시지가 의도하지 않은 문자 집합으로 인코딩되어 일부 클라이언트에서 메시지를 읽지 못할 수 있습니다. 클라이언트 언어 설정이 올바른지 확인하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
Exchange Server 2003에서 Outlook Web Access의 기본 언어 설정을 복원하려면 다음을 수행합니다.

  1. Exchange 컴퓨터에서 Regedit.exe 또는 RegEdt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\로 이동합니다.

  3. 오른쪽 창에서 UseAltRegionalCharSet 레지스트리 값을 삭제합니다.

  4. UseRegionalCharset 레지스트리 값이 없으면 다음 단계에 따라 해당 레지스트리 값을 만듭니다.

    1. 편집 메뉴에서 새로 만들기, DWORD 값을 차례로 클릭합니다.

    2. DWORD 이름으로 UseRegionalCharset을 입력한 다음 Enter 키를 누릅니다.

  5. UseRegionalCharset이 있으면 두 번 클릭하여 수정합니다.

  6. 값 데이터 상자에 1을 입력한 다음 확인을 클릭합니다.

  7. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

UseAltRegionalCharSet 및 UseRegionalCharset 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 283214, "XCCC: Outlook Web Access May Send a Japanese-Language Message in SJIS"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=283214)를 참조하십시오.


UseRegionalCharset 레지스트리 값이 Exchange 2000 Server에서 사용 가능하게 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 Microsoft Outlook® Web Access 클라이언트에서 사용하는 언어 설정을 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

UseRegionalCharset 레지스트리 값을 사용하면 UTF-8 메시지 본문이 저장소에서 UTF-8 형식 대신 국가별 문자 집합 또는 코드 페이지로 유지됩니다.

또한 Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 6.0"이 있으면 컴퓨터에서 Exchange Server 2000을 실행하고 있는 것입니다.

UseRegionalCharset이 Exchange 2000 Server를 실행 중인 컴퓨터에서 1 이상의 값을 사용하도록 구성되어 있으면 Exchange Server Analyzer에서 기본 구성이 아니라는 메시지를 표시합니다.

이 메시지는 이 Exchange 2000 서버의 UseRegionalCharset 레지스트리 매개 변수가 사용 가능하게 설정되어 있음을 나타냅니다. 조직의 Outlook Web Access 사용자가 여러 가지 문자 집합을 사용하는 받는 사람에게 자주 메일을 보낼 것으로 예상되는 경우 Internet Explorer 5 이상 버전을 실행하는 사용자가 UTF-8로 인코딩된 유니코드 문자를 사용하여 메일을 보낼 수 있도록 레지스트리 설정을 수정할 수 있습니다. 여러 문자 집합이 필요하지 않으면 다음 절차를 사용하여 기본 구성을 복원할 수 있습니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 있습니다. 레지스트리를 편집하려면 먼저 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
Outlook Web Access의 기본 언어 설정을 복원하려면 다음을 수행합니다.

  1. Exchange 컴퓨터에서 Regedit.exe 또는 RegEdt32.exe와 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\를 탐색합니다.

  3. 오른쪽 창에서 UseRegionalCharSet 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


UseRegionalCharset 레지스트리 값 사용할 수 없음
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Outlook® Web Access 클라이언트가 사용하는 언어 설정을 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

UseRegionalCharset 레지스트리 값은 UTF-8 형식 대신 UTF-8 메시지 본문을 국가별 문자 집합 또는 코드 페이지로 저장소에 보유합니다.

또한 Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 6.5"가 포함되어 있으면 컴퓨터에서 Exchange Server 2003이 실행되고 있는 것입니다.

Exchange Server Analyzer는 UseRegionalCharset이 구성되어 Exchange Server 2003을 실행 중인 컴퓨터에서 값 0을 사용하는 경우 기본 구성이 아니라는 메시지를 표시합니다.

이 메시지는 UseRegionalCharset 레지스트리 매개 변수를 Exchange 2003 서버에서 사용할 수 없음을 나타냅니다. 이 설정은 Outlook Web Access 메시지에 예기치 않은 문자 집합 인코딩을 발생시키며 이로 인해 일부 클라이언트가 메시지를 읽지 못할 수 있습니다.

Microsoft Internet Explorer 5 이상 버전을 사용하여 Outlook Web Access에 액세스하는 경우 Exchange Server 2003은 브라우저의 언어 설정을 사용하여 전자 메일 메시지 및 요청 수락과 같은 정보를 인코딩하는 데 문자 집합을 사용할지 여부를 확인하십시오.

조직의 Outlook Web Access 사용자가 다양한 문자 집합을 사용하는 받는 사람에게 메일을 자주 보내는 경우에는 레지스트리 설정을 수정하여 Internet Explorer 5 이상 버전을 실행하는 사용자가 UTF-8 인코딩된 유니코드 문자를 사용하여 메일을 보낼 수 있습니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
Outlook Web Access의 기본 언어 설정을 복구하려면 다음을 수행합니다.

  1. Exchange 컴퓨터에서 Regedit.exe 또는 RegEdt32.exe와 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\를 탐색합니다.

  3. UseRegionalCharset이 존재하지 않으면 다음 단계를 수행하여 만듭니다.

    1. 편집, 새로 만들기, DWORD 값을 차례로 클릭합니다.

    2. DWORD의 이름에 UseRegionalCharset을 입력한 다음 Enter 키를 누릅니다.

  4. UseRegionalCharset이 존재하면 두 번 클릭하여 수정합니다.

  5. 값 데이터 상자에 1을 입력한 다음 확인을 클릭합니다.

  6. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Outlook Web Access 언어 설정에 대한 자세한 내용은 "Exchange Server Client Access Guide"(http://go.microsoft.com/fwlink/?LinkId=47568)를 참조하십시오.


UseRegionalCharset 레지스트리 값이 Exchange Server 2003에서 사용되지 않거나 누락되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Outlook® Web Access 클라이언트에서 사용하는 언어 설정을 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

UseRegionalCharset 레지스트리 값으로 인해 UTF-8 메시지 본문이 UTF-8 형식이 아니라 국가별 문자 집합 또는 코드 페이지로 저장소에 보관될 수 있습니다.

또한 Exchange Server Analyzer는 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 문자열 값에 "Version 6.5"가 포함되어 있으면 컴퓨터에서 Exchange Server 2003이 실행되고 있는 것입니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고 메시지를 표시합니다.

  • Exchange 2003 서버의 UseRegionalCharset 항목이 없습니다.

  • UseRegionalCharset 항목 값이 1이 아닙니다.

이 메시지는 Exchange 2003 서버에서 UseRegionalCharset 레지스트리 매개 변수가 사용되지 않거나 누락되었음을 나타냅니다. 이 설정으로 인해 Outlook Web Access 메시지가 의도하지 않은 문자 집합으로 인코딩되어 일부 클라이언트에서 메시지를 읽지 못할 수 있습니다.

Microsoft Internet Explorer 5 이상 버전을 사용하여 Outlook Web Access에 액세스하면 Exchange Server 2003에서는 브라우저의 언어 설정을 사용하여 전자 메일 메시지 및 모임 요청과 같은 정보를 인코딩하는 데 사용할 문자 집합을 확인합니다.

조직에 속한 Outlook Web Access 사용자가 다양한 문자 집합을 사용하는 받는 사람에게 메일을 자주 보낼 경우에는 Internet Explorer 5 이상 버전을 실행하는 사용자가 UTF-8로 인코딩된 UNICODE 문자를 사용하여 메일을 보낼 수 있도록 레지스트리 설정을 수정할 수 있습니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
Outlook Web Access의 기본 언어 설정을 복원하려면 다음을 수행합니다.

  1. Exchange 컴퓨터에서 Regedit.exe 또는 RegEdt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\로 이동합니다.

  3. UseRegionalCharset이 없으면 다음 단계에 따라 해당 레지스트리 값을 만듭니다.

    1. 편집 메뉴에서 새로 만들기, DWORD 값을 차례로 클릭합니다.

    2. DWORD 이름으로 UseRegionalCharset을 입력한 다음 Enter 키를 누릅니다.

  4. UseRegionalCharset이 있으면 두 번 클릭하여 수정합니다.

  5. 값 데이터 상자에 1을 입력한 다음 확인을 클릭합니다.

  6. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Outlook Web Access 언어 설정에 대한 자세한 내용은 "Exchange Server Client Access Guide"(http://go.microsoft.com/fwlink/?LinkId=47568)를 참조하십시오.


사용자 로드 및 MAPI 작업
Microsoft Exchange Server Analyzer - 문서 > 프로토콜 >

최근 수정된 항목: 2006-10-17

Microsoft® Exchange Server Analyzer Tool은 서버의 소수 MAPI 작업이 상당한 부분의 서버 사용자 로드를 일으키고 있음을 확인했습니다. 모든 RPC 요청을 처리하는 데 사용된 총 CPU 시간에 비해 4퍼센트보다 큰 CPU 시간을 사용하는 작업을 쿼리함으로써 이를 확인했습니다.

CPU 비율이 높은 MAPI 작업의 일반적인 원인

Exchange Server의 성능이 떨어지는 이유를 조사하는 관리자는 낮은 성능을 보이는 서버에서 평균 사서함 크기가 큰지를 검토해야 합니다. 각 폴더가 지나치게 큰지, 즉 사용자의 받는 편지함, 보낸 항목, 삭제된 항목 또는 일정 폴더의 항목이 5,000개를 초과하는지 확인해야 합니다. 큰 폴더와 사서함 증가는 CPU 및 입/출력 로드를 증가시키는 원인이 될 수 있습니다. 각 폴더의 보기 수가 증가해도 여러 MAPI 작업에 오버헤드가 추가될 수 있습니다.

보기

일반적인 장기 실행 MAPI 작업은 대부분 보기와 관련됩니다. 주요 작업은 Restrict 및 FindRow입니다. 이러한 작업에는 항상 긴 시간이 걸리는 것이 아니므로 성능 문제가 발생하면 이유를 파악해야 합니다. 또한 다음과 같은 이유 외에도 리소스 병목 현상(일반적으로 디스크 또는 CPU 병목 현상)이 있을 때마다 작업 대기 시간이 증가합니다.

참고:
Restrict 또는 FindRow 작업과 함께 TaskQ User Known의 순위가 높을 수 있습니다. 이는 이러한 작업의 일부가 TaskQ로 수행되고 순위는 TaskQ User Known으로 지정되기 때문입니다.

제한

MAPI Restrict 작업을 사용하여 특정 조건과 일치하는 항목을 선택할 수 있습니다. 서버에서는 제한이라는 관련 조건을 사용하여 보기, 즉 테이블을 만듭니다. 제한과 일치하는 보기가 있으면 서버에서는 기존 보기를 사용하여 사용자 요청을 충족합니다. 이 보기를 사용하면 비교적 순위가 낮지만 새 보기를 만들면 비교적 순위가 높습니다. 기본적으로 저장소에서는 각 폴더에 대해 11개 보기만 캐시합니다. 12개째 보기를 만들도록 서버에 요청하면 가장 오래된 캐시된 보기가 삭제되고 새 보기가 만들어집니다. 보기는 보기 제한과 일치하는 항목의 모든 작업에 오버헤드를 추가합니다.

Findrow

클라이언트 응용 프로그램에서는 MAPI 작업 SeekRow 또는 FindRow를 사용하여 보기의 행 간에 커서를 이동합니다. SeekRow는 커서를 이동할 행 수를 지정하며 CPU 시간 측면에서 순위가 매우 낮습니다. FindRow는 제한 조건과 일치하는 구체화되지 않은, 즉 캐시되지 않는 보기의 첫 번째 항목으로 커서를 이동한 다음 클라이언트 응용 프로그램에서 작업을 마친 후 보기를 제거하므로 순위가 높습니다. FindRow의 최종 CPU 순위는 제한의 복잡도에 따라 다르고 조건과 일치하는 첫 번째 항목을 발견하기 전에 저장소에서 검토해야 할 행 수에 따라 다르므로 폴더의 항목 수와 느슨하게 연관됩니다.

Restrict 및 FindRow에서 발생할 수 있는 높은 순위로 인해 서버의 부담을 줄이는 캐시된 모드를 실행할 수 있는 유력한 후보가 됩니다. 이러한 작업에서 사용되는 높은 CPU 비율은 공유 일정으로 인해 발생할 수도 있습니다. 이 경우 캐시된 모드는 도움이 되지 않습니다. 이러한 작업의 높은 CPU 시간 사용 비율은 보기 만들기 작업이 많거나 보기 순위가 높거나 폴더 항목 개수가 크다는 것을 나타냅니다.

추가 정보

자세한 내용은 다음 Exchange Server 리소스를 참조하십시오.

  • Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)

  • Exchange Server 2003 Performance: 10 Things to Think About(http://go.microsoft.com/fwlink/?LinkId=56460)


저장소
Microsoft Exchange Server Analyzer - 문서 >

최근 수정된 항목: 2005-11-18

이 섹션의 문서에서는 Microsoft® Exchange Server Analyzer Tool이 저장소에 관해 평가하는 항목에 대한 자세한 내용을 설명합니다. 또한 Exchange Server Analyzer가 발견한 저장소 관련 오류, 경고 및 기본 구성이 아닌 문제를 해결하기 위해 취할 수 있는 조치에 대해 설명합니다.


사서함 저장소에 대한 Aging Clean Interval이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 사용되지 않는 데이터베이스 인덱스를 제거하려고 시도하는 간격이 기본 설정과 다르게 수정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Aging Clean Interval

Exchange Server Analyzer는 Aging Clean Interval이 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

확장 가능한 저장소 엔진(ESE)의 기능 중 하나는 다른 정렬 순서로 정보가 다시 정렬되거나 요청되면 동적으로 인덱스를 만드는 것입니다. 결과적으로 Exchange 저장소 데이터베이스의 테이블에 수천 개의 인덱스가 있을 수 있습니다. Exchange 저장소는 인덱스에 만료 시간을 지정하여 이러한 상황을 처리합니다. 인덱스에 대한 정보가 인덱스 에이징 테이블이라는 내부 테이블에 추가됩니다. 온라인 유지 관리 동안 인덱스 에이징 테이블이 검토되고 각 항목의 삭제 시간 값이 현재 시간과 비교됩니다. 인덱스가 만료되면 제거됩니다. 기본적으로 이 프로세스는 Exchange 저장소 유지 관리 주기 동안 24시간마다 실행되며 Exchange Server 5.5에서는 8일이 지난 항목이 제거되고 Exchange 2000 Server, Exchange Server 2003 및 Exchange Server 2007에서는 40일이 지난 항목이 제거됩니다. Aging Clean Interval 키는 Exchange 저장소에서 사용하지 않는 인덱스를 제거하는 간격(밀리초)입니다. 레지스트리 키를 사용하여 이 기본값을 무시하고 이 기능을 사용자 지정 간격마다 수행할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>를 탐색합니다.

  3. Aging Clean Interval 키를 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Aging Clean Interval 키에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 159197, "XADM: Controlling Folder Index Aging"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197)

  • 216076, "XADM: 정보 저장소 폴더 액세스가 느려질 수 있다"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076)


공용 폴더 저장소에 대한 Aging Clean Interval이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 사용되지 않는 데이터베이스 인덱스를 제거하려고 시도하는 간격이 기본 설정과 다르게 수정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Aging Clean Interval

Exchange Server Analyzer는 Aging Clean Interval이 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

확장 가능한 저장소 엔진(ESE)의 기능 중 하나는 다른 정렬 순서로 정보가 다시 정렬되거나 요청되면 동적으로 인덱스를 만드는 것입니다. 결과적으로 Exchange 저장소 데이터베이스의 테이블에 수천 개의 인덱스가 있을 수 있습니다. Exchange 저장소는 인덱스에 만료 시간을 지정하여 이러한 상황을 처리합니다. 인덱스에 대한 정보가 인덱스 에이징 테이블이라는 내부 테이블에 추가됩니다. 온라인 유지 관리 동안 인덱스 에이징 테이블이 검토되고 각 항목의 삭제 시간 값이 현재 시간과 비교됩니다. 인덱스가 만료되면 제거됩니다. 기본적으로 이 프로세스는 Exchange 저장소 유지 관리 주기 동안 24시간마다 실행되며 Exchange Server 5.5에서는 8일이 지난 항목이 제거되고 Exchange 2000 Server 및 Exchange Server 2003에서는 40일이 지난 항목이 제거됩니다. Aging Clean Interval 키는 Exchange 저장소에서 인덱스를 제거하는 간격(밀리초)입니다. 레지스트리 키를 사용하여 이 기본값을 무시하고 이 기능을 사용자 지정 간격마다 수행할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>를 탐색합니다.

  3. Aging Clean Interval 키를 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Aging Clean Interval 키에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 159197, "XADM: Controlling Folder Index Aging"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197)

  • 216076, "XADM: 정보 저장소 폴더 액세스가 느려질 수 있다"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076)


모든 버전의 Outlook에서 서버에 액세스할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange Server에 연결할 수 없도록 차단되는 Microsoft Office Outlook® 버전을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 Disable MAPI Clients 키가 존재하지 않을 경우 경고를 표시합니다.

관리자는 기본적으로 비활성화되어 있는 MAPI 클라이언트 사용 안 함 키를 사용하여 특정 버전의 Outlook에서 Exchange 2000 Server, Exchange Server 2003 또는 Exchange Server 2007이 실행되는 컴퓨터에 연결할 수 없도록 차단할 수 있습니다.

최신 릴리스 및 서비스 팩이 설치된 Outlook에는 다양한 보안 및 바이러스 퇴치 기능이 포함되어 있습니다. Outlook 2002 이상 버전에서는 첨부 파일 차단 및 개체 모델 가이드가 포함되어 있으며 기본적으로 사용 가능하게 설정되어 있습니다. 이러한 기능은 바이러스 퇴치 작업의 핵심 구성 요소입니다. Microsoft 기술 지원 서비스에서 지원하는 가장 오래된 Outlook 버전은 Outlook 2000 서비스 팩 3(SP3)입니다. 조직에서 이전 버전의 Outlook이 실행되고 있을 경우 Outlook 2003으로 업그레이드하거나 적어도 최신 보안 릴리스로 Outlook 클라이언트를 업데이트하십시오.

Outlook을 업데이트한 후에는 업데이트하지 않은 이전 버전의 Outlook에서 Exchange에 액세스할 수 없습니다. 첨부 파일 차단 및 개체 모델 가이드를 지원하지 않는 이전 버전의 Outlook을 차단하면 MAPI 클라이언트 연결에 대해 알려진 수준의 클라이언트 보안을 제공할 수 있습니다.

이전 버전의 Outlook(SP 3 이전의 Outlook 97, Outlook 98, Outlook 2000 및 이전 버전)에 대해 보호 기능을 제공하려면 빌드 번호가 5.3164.0.0 이하인 모든 버전의 Outlook에서 Exchange Server에 연결하지 못하도록 설정하는 것이 좋습니다.

클라이언트 자체는 클라이언트의 버전 문자열을 나타냅니다. 이 문자열은 클라이언트의 정보 대화 상자에 표시되는 버전 번호와 비슷합니다. 그러나 이 버전 번호에만 전적으로 의존하지 마십시오. 대신 Exchange System Manager를 사용하여 사서함 저장소 로그온 페이지에서 클라이언트 버전 속성을 확인하십시오.

중요:
변경하기 전에 핫픽스와 서비스 팩 릴리스가 클라이언트 버전 문자열에 영향을 줄 수 있다는 것을 알아 두십시오. 클라이언트 액세스를 제한할 때 서버 쪽 Exchange 구성 요소도 MAPI를 사용하여 로그온해야 하므로 주의하십시오. 6.0.4712.0 같은 Exchange 빌드 번호를 보고하는 구성 요소도 있지만 SMTP 또는 OLEDB 같은 구성 요소 이름으로 클라이언트 버전을 보고하는 구성 요소도 있습니다. 이런 이유로 6.<x.x>로 시작되는 버전 번호의 클라이언트를 제한하지 마십시오. 예를 들어 MAPI 액세스를 완전히 금지하려면 0.0.0-65535.65535.65535를 지정하지 않고 대신, 서버 구성 요소가 로그온할 수 있도록 0.0.0-5.9.9; 7.0.0-65535.65535.65535와 같이 두 가지 범위를 지정합니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행하십시오.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. Disable MAPI Clients라는 새 문자열 값 항목을 만듭니다.

  4. Disable MAPI Clients 레지스트리 항목을 두 번 클릭하고 값 데이터를 원하는 수준으로 설정합니다. 값 데이터 문자열의 값 목록은 특정 범위의 MAPI 클라이언트 버전을 비활성화할 수 있는 여러 가지 방법을 나타냅니다. 버전(vX)은 일반적으로 다음 형식을 갖습니다.

    • Microsoft Outlook 2003 및 Outlook 2007: Maj.Min.Build

    • Microsoft Outlook 2000: Maj.Build.Dot

    • 이전 버전의 Microsoft Outlook: Maj.Min.Build

    사용하지 않도록 설정할 모든 특정 버전이나 버전 범위를 이 문자열에 나타낼 수 있습니다. Exchange System Manager를 사용하여 Exchange Server 2003의 사서함 저장소에 연결하는 MAPI 클라이언트 버전을 확인합니다. Exchange System Manager에서 사서함 저장소의 로그온 컨테이너를 찾습니다. 클라이언트 버전 열에 사서함 저장소에 연결된 MAPI 클라이언트 버전이 표시됩니다.

    Exchange Server 2007에서는 Exchange 관리 셸 Get-LogonStatistics cmdlet를 사용하여 사서함 데이터베이스에 연결된 MAPI 클라이언트의 클라이언트 버전을 검색합니다.
중요:
MAPI 클라이언트 버전은 Exchange System Manager 및 Exchange 관리 셸에 X.0.Y.Z로 나열됩니다. 레지스트리 값에는 이 버전을 X.Y.Z로 입력해야 합니다. 예를 들어 Exchange System Manager에 MAPI 클라이언트 버전이 5.0.2819.0으로 나열되는 경우 Disable MAPI Clients 레지스트리 값에 5.2819.0을 입력합니다.
  1. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)을 참조하십시오.

특정 MAPI 클라이언트가 xchange 2000 Server 또는 Exchange Server 2003 컴퓨터에 연결하지 못하도록 하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328240, "How to put server-side restrictions on clients that are used to access Exchange 2000 mailboxes"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • 288894, "XADM: MAPI 클라이언트를 해제하는 기능"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894)

이전 버전의 Outlook용 보안 업데이트 다운로드 및 다른 버전의 Outlook 차단에 대한 자세한 내용은 Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.

Get-LogonStatistics cmdlet에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "Get-LogonStatistics"(http://go.microsoft.com/fwlink/?LinkId=80699)를 참조하십시오.


AssertOnEvent가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange Information Store에서 디버깅이 활성화되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\AssertOnEvent

Exchange Server Analyzer는 AssertOnEvent에 대한 값이 설정되어 있는 경우 경고를 표시합니다.

AssertOnEvent 레지스트리 값에는 Microsoft Exchange Information Store의 디버그 모드를 트리거해야 하는 저장소 이벤트를 지정하는 10진수 값이 들어 있습니다. AssertOnEvent 레지스트리는 store.exe의 디버그 버전이 실행 중인 경우에만 발생합니다. Microsoft Exchange Information Store는 디버그 모드에서 실행될 때 많은 리소스를 사용합니다. Production 환경에서 이 저장소를 디버깅하는 것은 좋지 않습니다.

Microsoft 기술 지원 서비스의 도움을 받아 Exchange Information Store 문제를 적극적으로 해결하지 않으면 AssertOnEvent 레지스트리 값을 삭제해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
AssertOnEvent 레지스트리 키를 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. 오른쪽 창에서 AssertOnEvent 값을 찾아 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


손상된 메시지가 하나 이상 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 PoisonIDs 값에서 항목 수를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

Exchange Server Analyzer는 PoisonIDs 값의 항목 수가 0보다 많으면 경고를 표시합니다.

Exchange Server 2003 서비스 팩 1 이후의 Exchange Server 버전은 손상되었거나 잘못된 메시지로 인해 Microsoft Exchange Information Store 서비스가 예기치 않게 중지되거나 Exchange 정보 저장소 서비스가 시작되지 않는 문제를 방지하는 기능을 구현합니다.

Exchange Server 2003 서비스 팩 1 이상의 버전에서는 MAPI 형식을 MIME 형식으로 변환하는 동안 Exchange 정보 저장소 서비스가 예기치 않게 중지되도록 하는 메시지를 추적합니다. 서비스가 중지될 경우 손상된 메시지의 메시지 ID가 레지스트리에 저장됩니다. 손상된 메시지로 인해 저장소가 예기치 않게 세 번 중지되면 이 정보를 사용하여 Exchange Information Store 서비스가 네 번째로 시작될 때 해당 메시지가 다시 처리되지 않도록 합니다.

손상된 메시지로 인해 Exchange 정보 저장소 서비스가 예기치 않게 중지되면 다음 위치에 PoisonIDs 레지스트리 값이 작성됩니다.

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

또한 관리자는 PoisonThreshold 레지스트리 항목을 만들 수 있습니다. PoisonThreshold 키는 PoisonIDs 레지스트리 키에 추가되기 전에 메시지가 Exchange 정보 저장소를 통과할 수 있는 최대 횟수를 제어합니다. 기본적으로 이 임계값은 2입니다. 이 임계값이 초과된 경우에만 동작이 발생합니다. 따라서 메시지가 차단될 때까지 손상된 메시지로 인해 Exchange 정보 저장소 서비스가 3번까지 중지될 수 있습니다. 예를 들어 한 메시지가 3번의 충돌과 관련되면 이 숫자가 임계값 2보다 크므로 메시지가 차단됩니다.

손상된 메시지 이벤트가 레지스트리에 기록되면 응용 프로그램 이벤트 로그에 오류 이벤트 메시지(이벤트 ID 9680 및 9681)가 나타납니다. Exchange 정보 저장소 서비스가 성공적으로 시작되면 Exchange는 손상된 메시지를 차단하고 이에 대한 배달 못 함 보고서(NDR)을 보냅니다. Exchange에서 배달 못 함 보고서(NDR)을 보내지 못하는 경우도 있습니다. 이러한 경우 차단된 메시지는 만료될 때까지 큐에 남아 있게 됩니다. PoisonIDs 레지스트리 키에는 메시지 ID 값이 10개까지 포함됩니다. 10개 제한을 초과하게 되면 새로운 손상된 메시지 이벤트가 추가됩니다. 그리고 충돌 날짜가 가장 오래된 손상된 메시지 이벤트는 제거합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 손상된 메시지로 인해 문제가 발생한 사서함 저장소가 있는 경우 문제를 자세히 조사해야 합니다. 손상된 Exchange 데이터베이스에서 Microsoft IT를 복구하는 방법에 대한 자세한 내용은 http://go.microsoft.com/fwlink/?LinkId=56372를 참조하십시오.

  2. 손상된 메시지로 인해 Exchange Server 2003 시스템 종료에 문제가 발생한 경우 Exchange Server 컴퓨터에서 자동 오류 보고를 사용하는 것이 유용할 수 있습니다. 오류 보고 데이터는 사용 중인 소프트웨어에서 문제를 찾아 수정하는 데 사용됩니다. Exchange 오류 보고를 사용하는 방법에 대한 자세한 내용은 Exchange 오류 보고 기능이 비활성화되어 있습니다.를 참조하십시오.

Exchange Server 2003 서비스 팩 1에 대한 자세한 내용은 "Exchange Server 2003 서비스 팩 1"(http://go.microsoft.com/fwlink/?linkid=29090)을 참조하십시오.


사서함 저장소에 대한 Background Cleanup이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Background Cleanup 레지스트리 값의 현재 값 데이터를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

Exchange Server Analyzer에서 Background Cleanup에 대한 값 데이터가 60,000(10진수) 또는 0xEA60(16진수) 이외의 다른 값으로 설정되어 있음을 확인하면 기본 구성이 아니라는 메시지가 표시됩니다. Background Cleanup을 기본값으로 설정하는 것이 좋습니다.

Background Cleanup 값이 너무 높게 설정되어 있으면 백그라운드 정리 프로세스가 자주 실행되지 않고 많은 문제가 발생할 수 있습니다. 이러한 문제는 다음과 같습니다.

  • 사서함 이동에 실패할 수 있으며 오류 코드 0x4e3의 이벤트 1205가 기록될 수 있습니다.

  • Exchange System Manager 또는 Exchange 관리 콘솔에서 표시되는 폴더 크기와 항목 수는 Microsoft Outlook®에서 표시되는 것과 매우 다를 수 있습니다. 또한 이러한 항목이 차지하는 데이터베이스 공간을 다시 확보할 수 없을 수도 있습니다.

  • 특정 상황의 경우 읽지 않고 삭제된 항목에 대한 읽지 않음 확인이 이뤄지지 않을 수도 있습니다.

  • DeliveredTo 테이블의 오래된 항목 정리가 수행되지 않습니다. DeliveredTo 테이블은 Exchange 저장소에서 중복된 메시지를 배달하지 못하도록 하는 데 사용됩니다.

Background Cleanup 값이 너무 낮게 설정되어 있으면 백그라운드 정리 프로세스로 인해 서버에서 불필요한 로드가 발생할 수 있습니다.

주의:
이 항목의 절차를 수행하여 지나치게 높은 값을 기본 구성으로 되돌리면 기본 간격으로 정상적으로 정리되었던 모든 항목에 대해 백그라운드 정리가 완료될 때까지 서버에 로드가 증가될 수 있습니다. 따라서 사용자에게 최소한으로 영향을 미치는 시간에 이러한 변경을 적용하는 것이 좋습니다. 또한 읽음 확인이 요청된 메시지를 읽지 않고 삭제하여 메시지가 정리되지 않은 경우 이 경고가 해결되면 해당 메시지마다 읽지 않음 확인이 이루어집니다.
중요:
이 문서에는 레지스트리 편집 방법에 대한 정보가 들어 있습니다. 레지스트리를 편집하기 전에 문제가 발생하는 경우 레지스트리를 복원하는 방법에 대해 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>를 탐색합니다.

  3. Background Cleanup 값을 60,000(10진수) 또는 0xEA60(16진수)으로 변경합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


사서함 저장소에 대한 백그라운드 정리 간격이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Background Cleanup 레지스트리 값이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

Exchange Server Analyzer에서 Background Cleanup 값이 없음을 확인하면 경고가 표시됩니다.

Background Cleanup 값이 없으면 백그라운드 정리 프로세스가 수행되지 않고 다음과 같은 여러 문제가 발생할 수 있습니다.

  • 사서함 이동이 실패할 수 있으며 오류 코드 0x4e3의 이벤트 1205가 기록될 수 있습니다.

  • Exchange System Manager 또는 Exchange 관리 콘솔에서 표시되는 사서함 크기와 항목 수는 Microsoft Outlook®에서 표시되는 것과 매우 다를 수 있습니다. 또한 이러한 항목이 차지하는 데이터베이스 공간을 다시 확보할 수 없을 수도 있습니다.

  • 특정 상황의 경우 읽지 않고 삭제된 항목에 대한 읽지 않음 확인이 이뤄지지 않을 수도 있습니다.

  • DeliveredTo 테이블 정리가 수행되지 않습니다. DeliveredTo 테이블은 Exchange 저장소에서 중복된 메시지를 배달하지 못하도록 하는 데 사용됩니다. Track Duplicates 값은 DeliveredTo 테이블에 있는 항목이 보관되는 시간 범위를 제어합니다. Background Cleanup 값이 있지만 Track Duplicates 값이 없는 경우 24시간 이상된 항목은 백그라운드 정리에 따라 지워집니다. Track Duplicates의 제안 값은 1(10진수 또는 16진수)입니다.

Background Cleanup은 기본값인 60,000(10진수) 또는 0xEA60(16진수)로 설정하는 것이 좋습니다.

주의:
아래 절차를 수행하여 이 경고를 해결하면 정기적이며 정상적으로 정리되었던 모든 항목에 대해 백그라운드 정리가 완료될 때까지 서버에 로드가 증가될 수 있습니다. 따라서 사용자에게 미치는 영향을 최소한도로 할 수 있는 시간에 이러한 변경을 적용하는 것이 좋습니다. 또한 읽음 확인이 요청된 메시지를 읽지 않고 삭제하여 이 문제로 인해 메시지가 정리되지 않은 경우 이 경고가 해결되면 해당 메시지마다 읽지 않음 확인이 이루어집니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>를 탐색합니다.

  3. 60000(10진수) 또는 0xEA60(16진수) 값 데이터로 Background Cleanup이라는 DWORD 값을 만듭니다.

  4. 레지스트리 편집기를 닫습니다. 변경 내용을 적용하려면 다음 중 하나를 수행합니다.

    • 영향을 받는 정보 저장소를 분리 및 탑재합니다.

    • Microsoft Exchange Information Store 서비스를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


공용 폴더 저장소에 대한 Background Cleanup 간격이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Background Cleanup 레지스트리 값의 현재 값 데이터를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>\Background Cleanup

Exchange Server Analyzer에서 Background Cleanup에 대한 값 데이터가 60,000(10진수) 또는 0xEA60(16진수) 이외의 다른 값으로 설정되어 있음을 확인하면 기본 구성이 아니라는 메시지가 표시됩니다. Background Cleanup을 기본값으로 설정하는 것이 좋습니다.

Background Cleanup 값이 너무 높게 설정되어 있으면 백그라운드 정리 프로세스가 자주 실행되지 않고 다음을 비롯하여 많은 문제가 발생할 수 있습니다.

  • Exchange System Manager에서 표시되는 폴더 크기와 항목 수는 Microsoft Outlook®에서 표시되는 것과 매우 다를 수 있습니다. 또한 이러한 항목이 차지하는 데이터베이스 공간을 다시 확보하지 못할 수도 있습니다.

  • 특정 상황의 경우 읽지 않고 삭제된 항목에 대한 읽지 않음 확인이 이뤄지지 않을 수도 있습니다.

  • DeliveredTo 테이블의 오래된 항목 정리가 수행되지 않습니다. DeliveredTo 테이블은 Exchange 저장소에서 중복된 메시지를 배달하지 못하도록 하는 데 사용됩니다.

Background Cleanup 값이 너무 낮게 설정되어 있으면 백그라운드 정리 프로세스로 인해 서버에서 불필요한 로드가 발생할 수 있습니다.

주의:
아래 절차를 수행하여 너무 높은 값을 기본 구성으로 되돌리면 기본 간격으로 정상적으로 정리되었던 모든 항목에 대해 백그라운드 정리가 완료될 때까지 서버에 로드가 증가될 수 있습니다. 따라서 사용자에게 미치는 영향을 최소한도로 할 수 있는 시간에 이러한 변경을 적용하는 것이 좋습니다. 또한 읽음 확인이 요청된 메시지를 읽지 않고 삭제하여 이 문제로 인해 메시지가 정리되지 않은 경우 이 경고가 해결되면 해당 메시지마다 읽지 않음 확인이 이루어집니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>를 탐색합니다.

  3. Background Cleanup 값을 60,000(10진수) 또는 0xEA60(16진수)으로 변경합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


공용 폴더의 백그라운드 정리 간격이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Background Cleanup 레지스트리 값이 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>\Background Cleanup

Exchange Server Analyzer에서 Background Cleanup 값이 없음을 확인하면 경고가 표시됩니다.

Background Cleanup 값이 없으면 백그라운드 정리 프로세스가 실행되지 않고 다음과 같은 여러 문제가 발생할 수 있습니다.

  • Exchange System Manager 또는 Exchange 관리 콘솔에서 표시되는 폴더 크기와 항목 수는 Microsoft Outlook®에서 표시되는 것과 매우 다를 수 있습니다. 또한 이러한 항목이 차지하는 데이터베이스 공간을 다시 확보할 수 없을 수도 있습니다.

  • 특정 상황의 경우 읽지 않고 삭제된 항목에 대한 읽지 않음 확인이 이뤄지지 않을 수도 있습니다.

  • DeliveredTo 테이블 정리가 수행되지 않습니다. DeliveredTo 테이블은 Exchange 저장소에서 중복된 메시지를 배달하지 못하도록 하는 데 사용됩니다. Track Duplicates 값은 DeliveredTo 테이블에 있는 항목이 보관되는 시간 범위를 제어합니다. Background Cleanup 값은 있지만 Track Duplicates 값이 없으면 24 시간이 지난 항목은 백그라운드 정리에 따라 지워집니다. Track Duplicates의 제안 값은 1(10진수 또는 16진수)입니다.

Background Cleanup은 기본값인 60,000(10진수) 또는 0xEA60(16진수)으로 설정하는 것이 좋습니다.

주의:
아래 절차를 수행하여 이 경고를 해결하면 정기적이며 정상적으로 정리되었던 모든 항목에 대해 백그라운드 정리가 완료될 때까지 서버에 로드가 증가될 수 있습니다. 따라서 사용자에게 가장 최소 한도로 영향을 미칠 수 있는 시간에 이러한 변경을 적용하는 것이 좋습니다. 또한 읽음 확인이 요청된 메시지가 읽지 않고 삭제되고 이 문제로 인해 정리되지 않은 경우 이 경고가 해결되면 해당 메시지마다 읽지 않음 확인이 이루어집니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>를 탐색합니다.

  3. 60000(10진수) 또는 0xEA60(16진수) 값 데이터로 Background Cleanup이라는 DWORD 값을 만듭니다.

  4. 레지스트리 편집기를 닫습니다. 변경 내용을 적용하려면 다음 중 하나를 수행합니다.

    • 영향을 받는 정보 저장소를 분리 및 탑재합니다.

    • Microsoft Exchange Information Store 서비스를 다시 시작합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


BreakOnEvent가 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange Information Store에서 디버깅이 활성화되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\BreakOnEvent

Exchange Server Analyzer는 BreakOnEvent 레지스트리 값이 설정되면 경고를 표시합니다.

BreakOnEvent 레지스트리 값에는 Microsoft Exchange Information Store의 디버그 모드를 트리거하는 저장소 이벤트를 지정하는 10진수 값이 있습니다. Microsoft Exchange Information Store는 디버그 모드에서 실행될 때 많은 리소스를 사용합니다. Production 환경에서 이 저장소를 디버깅하는 것은 좋지 않습니다.

Microsoft 기술 지원 서비스에 문의하여 Exchange Information Store의 문제점을 적극적으로 해결하지 않을 경우 BreakOnEvent 레지스트리 값을 삭제해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
BreakOnEvent 레지스트리 키를 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. 오른쪽 창에서 BreakOnEvent 값을 찾아 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


호출 추적을 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 호출 추적 로깅을 사용할 수 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

Exchange Server Analyzer는 Disable Call Tracing의 레지스트리 값이 존재하고 값 1을 사용하도록 구성되어 있으며 컴퓨터가 Exchange Server 2003을 실행하고 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

호출 추적 로깅을 사용할 수 있는 경우 Store.exe 프로세스에 대한 함수 호출 데이터가 기록됩니다. Exchange Server 2003을 실행하는 컴퓨터에서는 기본적으로 호출 추적을 사용할 수 있습니다. Exchange 2000 Server에서는 기본적으로 이 기능을 사용할 수 없습니다. 그러나 Exchange Server 2003을 실행하는 경우 Microsoft 기술 지원 서비스에서 달리 지침을 제공하지 않는 이상 호출 추적을 사용할 수 있어야 합니다. 호출 추적을 사용하면 저장소 프로세스에 발생하는 모든 문제를 해결하는 데 사용할 수 있는 중요한 정보를 수집합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성으로 되돌리려면 다음을 수행합니다.

  1. 레지스트리 편집기(Regedit.exe 또는 Regedt32.exe)를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Disable Call Tracing 레지스트리 값을 0으로 설정합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


호출 추적을 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 호출 추적 로깅을 사용할 수 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

Exchange Server Analyzer는 Disable Call Tracing 레지스트리 값이 있고 값 0으로 구성되어 있음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다.

호출 추적 로깅을 사용할 수 있는 경우 Store.exe 프로세스에 대한 함수 호출 데이터가 기록됩니다. 호출 추적 로깅으로 인해 성능이 최대 4% 정도 감소될 수 있습니다. 느리거나 응답이 없는 Store.exe 프로세스의 문제를 해결해야 할 경우에만 이 기능을 사용할 수 있게 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. Disable Call Tracing 레지스트리 값을 1로 설정합니다. RPC Requests Threshold Flush Call Traces 키, RPC Requests Threshold 키 및 Call Tracing Logging Interval 키는 호출 추적을 사용할 수 없게 설정되어 있는 경우 사용되지 않습니다.

  4. 레지스트리 편집기를 닫고 Exchange 서버를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


이 클러스터에서 검사점 깊이가 잘못 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 서버에 있는 각 저장소 그룹의 msExchESEParamCheckpointDepthMax 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 Exchange 2000 Server 클러스터의 msExchESEParamCheckpointDepthMax가 5242880이 아니면 경고를 표시합니다.

msExchESEParamCheckpointDepthMax 특성은 바이트 단위로 설정되며 최대 검사점 깊이를 제어합니다. 검사점 깊이란 Exchange 저장소에 커밋하기 위해 대기 중인 데이터 양을 말합니다. 최대 검사점 깊이란 항상 대기하고 있을 수 있는 최대 데이터 양을 말합니다. 따라서 최대 검사점 깊이를 20MB로 설정하면 Exchange 저장소에 커밋되지 않은 상태에서 언제라도 대기하고 있을 수 있는 최대 데이터 양은 20MB가 됩니다. 클러스터된 환경에서는 이 매개 변수 값이 작을수록 장애 조치(failover) 시간이 빨라집니다. Exchange Server 2003에서 이에 대해 테스트한 결과를 보면 이 매개 변수를 Exchange 2000 Server의 기본값인 20MB 대신 5MB(5242880바이트) 값으로 설정하면 장애 조치(failover) 시간이 훨씬 빨라지지만 서버의 I/O 성능에 심각한 영향을 주지 않았습니다.

Exchange 2000 Server 클러스터에서는 이 값을 항상 5242880으로 설정해야 합니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory® 디렉터리 서비스 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

ADSI 편집을 사용하여 msExchESEParamCheckpointDepthMax 특성을 설정하려면 다음을 수행합니다.

  1. ADSI(Active Directory Service Interfaces) 편집을 실행합니다. ADSI 편집은 Microsoft Windows® 2000 Server 및 Microsoft Windows Server™ 2003 지원 도구와 함께 제공됩니다.

  2. 콘솔 트리에서 ADSIEdit를 마우스 오른쪽 단추로 클릭하고 Connect To를 클릭한 다음 Configuration Naming Context에 연결합니다.

  3. 구성 컨테이너, CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Servers, CN=<ServerName>, CN=Information Store를 확장합니다.

  4. CN=<StorageGroupName>을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 속성 목록에서 msExchESEParamCheckpointDepthMax를 선택합니다.

  6. Edit를 클릭하고 5MB씩 증가하도록 설정할 크기를 입력합니다. 값을 바이트 단위로 입력해야 합니다. 예를 들어 5MB 검사점 깊이는 5242880바이트이고 10MB 검사점 깊이는 10485760바이트입니다. 최소 입력 크기는 5MB입니다. 20MB를 초과하는 값을 입력하면 Microsoft Exchange Information Store 서비스 리소스 장애 조치(failover) 시간이 늘어납니다.

  7. ADSIEdit를 닫은 다음 Microsoft Exchange Information Store 서비스를 다시 시작합니다.

Exchange 2000 Server 클러스터 배포에 대한 자세한 내용은 "Deploying Microsoft Exchange 2000 Server Clusters"(http://go.microsoft.com/fwlink/?LinkID=14578)를 참조하십시오.


검사점 파일 배치
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 Exchange 서버의 각 저장소 그룹에 대한 검사점 파일 경로(msExchESEParamSystemPath)가 해당 저장소 그룹의 트랜잭션 로그 경로(msExchESEParamLogFilePath)와 일치하는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 검사점 파일 경로가 저장소 그룹의 트랜잭션 로그 경로와 일치하지 않음을 확인하면 유용한 정보 메시지를 표시합니다.

검사점 파일 위치가 트랜잭션 로그 파일의 위치와 일치하지 않으면 디스크 오류가 발생할 때 중지 시간이 길어집니다.

Exchange 2000 Server 및 Exchange Server 2003의 Exchange 저장소 그룹 검사점 파일 위치를 변경하려면 다음을 수행합니다.

  1. Exchange System Manager에서 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭의 시스템 경로 위치에서 찾아보기를 클릭한 다음 검사점 파일 위치를 선택합니다.
Exchange 2000 Server 및 Exchange Server 2003의 Exchange 저장소 그룹 트랜잭션 로그 파일 위치를 변경하려면 다음을 수행합니다.

  1. Exchange System Manager에서 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭의 트랜잭션 로그 위치에서 찾아보기를 클릭한 다음 트랜잭션 로그 파일의 위치를 선택합니다.
Exchange Server 2007의 Exchange 저장소 그룹 트랜잭션 로그 파일 위치를 변경하려면 다음을 수행합니다.

  1. 핵심 Exchange Server 2007 설명서 "How to Set or Change the Location of Storage Group Log Files"(http://go.microsoft.com/fwlink/?LinkId=80702)의 안내를 따릅니다.

트랜잭션 로그 파일 위치에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "사서함 저장소 및 공용 폴더 저장소 관리"를 참조하십시오.

검사점 파일에 대한 자세한 내용은 Using Exchange Server 2003 Recovery Storage Groups(http://go.microsoft.com/fwlink/?LinkId=47589)의 "Transaction Log File Replay: Soft Recovery and Hard Recovery in Exchange Server 2003"을 참조하십시오.


이 프런트 엔드 서버에서 순환 로깅이 사용되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-03-27

Microsoft® Exchange Server Analyzer Tool은 순환 로깅(msExchESEParamCircularLog) 특성에 대해 구성된 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 이 특성 값이 0으로 구성된 경우 경고를 표시합니다.

msExchESEParamCircularLog 특성 값이 1이면 순환 로깅이 사용됨을 나타냅니다. msExchESEParamCircularLog 특성 값이 0이면 순환 로깅이 사용되지 않음을 나타냅니다.

Exchange Server가 사용하는 표준 트랜잭션 로깅에서 저장소 그룹에 있는 각 데이터베이스 트랜잭션은 로그 파일에 기록된 다음 데이터베이스에 기록됩니다. 로그 파일이 특정 크기에 도달하면 이름이 바뀌고 새 로그 파일이 만들어집니다. 결과적으로 시간이 지남에 따라 로그 파일 집합이 만들어집니다. 크래시가 있는 경우 이러한 로그 파일로부터 데이터베이스로 데이터를 재생하여 트랜잭션을 복구할 수 있습니다.

순환 로깅은 첫 번째 로그 파일에 포함된 데이터가 데이터베이스에 기록된 후 그 로그 파일을 덮어쓰고 다시 사용합니다. Exchange Server에서 순환 로깅은 기본적으로 사용되지 않습니다. 순환 로깅을 사용하면 필요한 드라이브 저장 공간이 감소하지만 완전한 트랜잭션 로그 파일이 없으면 마지막 전체 백업보다 최신의 항목을 하나도 복구할 수 없습니다. 따라서 사서함이나 공용 폴더 데이터를 포함하는 프로덕션 서버에서는 순환 로깅이 바람직하지 않습니다. 그러나 사서함이나 공용 폴더가 없는 프런트 엔드 Exchange 서버의 경우 커밋된 메시지만 NDR(배달 못 함 보고서)이므로 이러한 서버에 대해 트랜잭션 파일을 유지할 필요도 없고 이러한 서버를 백업할 중요한 이유도 없습니다. 프런트 엔드 서버에서 순환 로깅을 사용하면 트랜잭션 로그 파일을 덮어쓰고 데이터가 20MB를 초과하지 않습니다.

순환 로깅을 사용하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버를 확장한 다음 Exchange 서버를 확장합니다.

  2. 순환 로깅을 사용할 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. 저장소 그룹 속성 대화 상자가 나타납니다.

  3. 순환 로깅 사용 확인란을 선택한 다음 확인을 클릭하여 변경 내용을 저장합니다.

  4. Exchange System Manager를 끝내고 Microsoft Exchange Information Store를 다시 시작하여 변경 내용을 적용합니다.

순환 로깅에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 258470, "XADM: How to Modify the Circular Logging Setting"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470)

  • 147524, "XADM: How Circular Logging Affects the Use of Transaction Logs"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 296788, "XADM: Exchange 2000 Server의 오프라인 백업 및 복원 절차"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788)

  • 314605, "HOW TO: Turn On or Turn Off Circular Logging in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605)


순환 로깅이 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 각 저장소 그룹 개체의 msExchESEParamCircularLog 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 값 1은 저장소 그룹에 대해 순환 로깅이 사용됨을 나타내고 값 2는 저장소 그룹에 대해 순환 로깅이 사용되지 않음을 나타냅니다. 또한 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열된 항목 개수를 확인할 때도 Active Directory를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함 수를 나타냅니다.

또한 Exchange Server Analyzer는 IsFrontEndServer 키 값을 확인할 때 root\MicrosoftExchangeV2 네임스페이스에서 Exchange_Server Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 Exchange Server 컴퓨터가 프런트 엔드 서버임을 나타내고 False 값은 Exchange Server 컴퓨터가 프런트 엔드 서버가 아님을 나타냅니다.

Exchange Server Analyzer는 msExchESEParamCircularLog 특성 값이 1로 설정되어 있고 IsFrontEndServer 키 값이 False로 설정되어 있으며 homeMDBBL 특성 값이 20보다 클 경우 경고를 표시합니다.

이러한 값 조합은 20개가 넘는 사서함을 포함하는 사서함 서버에서 순환 로깅이 사용됨을 나타냅니다. Exchange 2000 Server, Exchange Server 2003 및 Exchange Server 2007에서 사용되는 표준 트랜잭션 로깅에서 저장소 그룹의 각 데이터베이스 트랜잭션은 로그 파일에 기록된 후 데이터베이스에 기록됩니다. 로그 파일이 특정 크기에 도달하면 이름이 바뀌고 새 로그 파일이 생성됩니다. 시간이 경과하면서 이러한 결과는 로그 파일 집합이 됩니다. 크래시가 발생하면 이러한 로그 파일의 데이터를 데이터베이스로 다시 재생하여 트랜잭션을 복구할 수 있습니다.

순환 로깅 기능은 첫 번째 로그 파일에 포함된 데이터가 데이터베이스로 기록된 후에 해당 로그 파일을 덮어쓴 후 다시 사용합니다. Exchange 2000 Server, Exchange Server 2003 및 Exchange Server 2007에서는 기본적으로 순환 로깅이 비활성화되어 있습니다. 순환 로깅을 사용하면 필요한 드라이브 저장 공간 크기가 줄어들지만 완전한 트랜잭션 로그 파일이 없으면 마지막 전체 백업보다 더 최신 버전에 해당하는 데이터는 복구할 수 없습니다. 따라서 정상적인 작업 환경에서는 순환 로깅이 권장되지 않습니다.

Exchange 2000 Server 및 Exchange Server 2003에서 이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버를 확장한 후 수정할 서버를 확장합니다.

  3. 변경할 저장소 그룹을 마우스 오른쪽 단추로 클릭한 후 속성을 클릭합니다.

  4. 속성 대화 상자에서 순환 로깅 사용 확인란의 선택을 취소합니다.

  5. 확인을 클릭하여 설정을 저장합니다.

  6. Exchange System Manager를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

Exchange 관리 콘솔을 사용하여 Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. 서버 구성을 확장하고 수정할 서버를 확장합니다.

  3. 변경할 저장소 그룹을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  4. 속성 대화 상자에서 순환 로깅 사용 확인란의 선택을 취소합니다.

  5. 확인을 클릭하여 설정을 저장합니다.

  6. Exchange 관리 콘솔을 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

Exchange 관리 셸을 사용하여 Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행합니다.

  1. 다음 코드는 'MyStorageGroup' 저장소 그룹에서 순환 로깅을 비활성화하는 Set-StorageGroup명령의 예입니다.
코드 복사
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $false
  • 순환 로깅에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 147524, "How Circular Logging affects the Use of Transaction Logs"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 240145, "Exchange Server 트랜잭션 로그 파일을 제거하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=240145)


순환 로깅을 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-03-23

Microsoft Exchange Analyzer Tool은 msExchESEParamCircularLog 특성에 대해 구성된 값을 확인하기 위해 Active Directory 디렉터리 서비스를 쿼리합니다.

msExchESEParamCircularLog 특성 값이 1이면 순환 로깅이 사용됨을 나타냅니다. msExchESEParamCircularLog 특성 값이 0이면 순환 로깅이 사용되지 않음을 나타냅니다.

또한 Exchange Analyzer는 다음 조건이 존재하는지 확인합니다.

  • Exchange Server는 프런트 엔드 서버로 구성되어 있습니다.

  • SMTP 서비스가 실행 중이며 구성된 사서함 수를 확인합니다.

Exchange Analyzer는 다음 조건이 있음을 확인하면 경고를 표시합니다.

  • msExchESEParamCircularLog 특성은 0 값으로 구성되어 있습니다.

  • 서버가 프런트 엔드 서버로 구성되어 있지 않습니다.

  • 20 미만의 사서함이 구성되어 있습니다.

Exchange Server가 사용하는 표준 트랜잭션 로깅에서 저장소 그룹에 있는 각 데이터베이스 트랜잭션은 로그 파일에 기록된 다음 데이터베이스에 기록됩니다. 로그 파일이 특정 크기에 도달하면 이름이 바뀌고 새 로그 파일이 생성됩니다. 시간이 지남에 따라 이 표준 트랜잭션 로깅은 로그 파일 집합을 만듭니다. 시스템이 작동하지 않으면 이러한 로그 파일의 데이터를 데이터베이스로 다시 재생하여 트랜잭션을 복구할 수 있습니다.

순환 로깅 기능은 첫 번째 로그 파일에 포함된 데이터가 데이터베이스로 기록된 후에 해당 로그 파일을 덮어쓴 후 다시 사용합니다. Exchange Server에서 순환 로깅은 기본적으로 사용되지 않습니다.

중요:
순환 로깅을 사용하여 드라이브 저장 공간 크기를 줄입니다. 그러나 완전한 트랜잭션 로그 파일이 없으면 마지막 전체 백업보다 최신 버전으로 복구할 수 없습니다. 따라서 사서함 데이터나 공용 폴더 데이터를 포함하는 프로덕션 서버에서 순환 로깅을 사용하는 것은 좋지 않습니다.

프런트 엔드 Exchange 서버, 메시지 라우팅 서버(인프라 서버라고도 함) 및 사용자 사서함 또는 공용 폴더가 없는 브리지헤드 서버에서는 커밋된 메시지만 배달 못 함 보고서(NDR)입니다. 따라서 이러한 서버에 대한 트랜잭션 파일을 보관할 필요가 없습니다. 또한 이러한 서버를 백업할 필요가 없습니다. 사용자 사서함을 호스팅하지 않는 서버에서 순환 로깅을 사용할 경우 트랜잭션 로그 파일을 덮어쓸 수 있으며 트랜잭션 로그 파일은 20MB의 데이터를 초과하지 않아야 합니다.

Exchange 2000 Server 및 Exchange Server 2003에 순환 로깅을 사용하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange 서버를 차례로 확장합니다.

  3. 순환 로깅을 사용할 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. 저장소 그룹 속성 대화 상자가 나타납니다.

  4. 순환 로깅 사용 확인란을 선택한 다음 확인을 클릭하여 변경 내용을 저장합니다.

  5. Exchange System Manager를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.
Exchange 관리 콘솔을 사용하여 Exchange Server 2007에 순환 로깅을 사용하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. 서버 구성을 확장하고 수정할 서버를 확장합니다.

  3. 변경할 저장소 그룹을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  4. 속성 대화 상자에서 순환 로깅 사용 확인란을 선택합니다.

  5. 확인을 클릭하여 설정을 저장합니다.

  6. Exchange 관리 콘솔을 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.
Exchange 관리 셸을 사용하여 Exchange Server 2007에 순환 로깅을 사용하려면 다음을 수행합니다.

  1. 다음 코드는 MyStorageGroup 저장소 그룹에서 순환 로깅을 사용하도록 설정하는 Set-StorageGroup 명령의 예입니다.
코드 복사
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $true

순환 로깅에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 258470, "XADM: How to Modify the Circular Logging Setting"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470)

  • 147524, "XADM: How Circular Logging Affects the Use of Transaction Logs"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 296788, "XADM: Exchange 2000 Server의 오프라인 백업 및 복원 절차"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788)

  • 314605, "How to turn on or turn off circular logging in Exchange 2000 Server and Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605)


클라이언트/서버 RPC 압축을 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 RPC(원격 프로시저 호출) 압축을 사용할 수 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Rpc Compression Enabled

Exchange Server Analyzer는 Rpc Compression Minimum Size 값이 있으며 0 값으로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Microsoft Office Outlook® 2003 또는 Outlook 2007과 Exchange Server 2003 또는 Exchange Server 2007 사이를 이동하는 모든 RPC 데이터는 크기에 관계없이 압축됩니다. 하지만 이러한 RPC 압축을 제어해야 하는 경우가 있습니다. 예를 들어 네트워크를 통해 보내는 패킷을 살펴 연결 문제를 해결하려는 경우 RPC 압축을 사용하면 추적 과정에서 압축된 상태의 데이터만 볼 수 있기 때문에 분석이 어려워집니다.

RPC 압축 설정을 구성하려면 시스템 설정에 다음 세 레지스트리 키 값을 추가합니다.

  • Rpc Compression Minimum Size

  • Rpc Compression Enabled

  • Rpc Packing Enabled

Rpc Compression Enabled 레지스트리 값은 RPC 압축 알고리즘 사용 여부를 결정합니다. 이 키가 없으면 RPC 압축이 활성화되고 사용됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. Rpc Compression Enabled 키를 삭제합니다. Rpc Compression Minimum Size 및 Rpc Packing Enabled 키가 있으면 모두 삭제합니다.

  4. 레지스트리 편집기를 닫고 Exchange Server를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC 압축을 제어하는 방법은 기술 자료 문서 825371, "Modify Remote Procedure Call Compression in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371)을 참조하십시오.


ClientMonitoringReportLevel 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키를 읽어 Exchange Server 2003이 Microsoft Office Outlook® 2003의 네트워크 성능 데이터를 모니터링하는 방법을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 ClientMonitoringReportLevel 레지스트리 키의 값이 1이 아닌 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server는 ClientMonitoringReportLevel 레지스트리 키 값을 사용하여 Outlook 2003 클라이언트의 네트워크 오류 및 대기 시간 문제를 확인합니다. ClientMonitoringReportLevel 레지스트리 키 값은 세 가지로 설정할 수 있습니다.

값 | 기능
0 | Outlook 2003 클라이언트에서 성능 데이터를 수집하지 않습니다.
1 | 고속 네트워크 연결만 가지는 Outlook 2003 클라이언트에서 성능 데이터를 수집합니다.
2 | 모든 Outlook 2003에서 성능 데이터를 수집합니다.

ClientMonitoringReportLevel 레지스트리 키를 1 또는 2 값으로 사용하도록 설정하면 Outlook 2003 클라이언트가 서버에 데이터를 보냅니다. 서버에 보낸 데이터는 네트워크 연결 상태를 나타냅니다. 서버에 보낸 데이터에는 실패한 원격 프로시저 호출(RPC)에 대한 정보도 포함됩니다. 서버는 정보를 집계하여 이벤트 로그 항목에 해당 정보를 노출합니다.

Exchange 설치 프로그램은 ClientMonitoringReportLevel 레지스트리 키를 만들지 않습니다. 그러나 Exchange 2003은 기본적으로 고속 네트워크 연결을 가지는 Outlook 2003 클라이언트의 성능 데이터만 수집합니다. 이러한 Exchange Server 2003의 기본 동작은 ClientMonitoringReportLevel 레지스트리 키 값이 1로 설정될 경우의 기능과 기능면에서 동일합니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다. 그러나 기본값을 복원하려면 ClientMonitoringReportLevel 레지스트리 키 값을 편집하면 됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성을 복원하려면 다음을 수행합니다

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. ClientMonitoringReportLevel을 두 번 클릭합니다.

  4. 값 데이터 필드에 1을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫습니다.

Microsoft Exchange Information Store 서비스는 몇 분 이내에 변경 내용을 감지합니다. 컴퓨터를 다시 시작할 필요가 없습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


저장소 할당량 구현 고려
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-03-21

Microsoft® Exchange Server Analyzer Tool은 각 private message database(MDB) 개체에 사서함 할당량이 설정되었는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 특정 개인 MDB에 21개 이상의 사서함이 있고 해당 MDB에 할당량이 설정되지 않은 경우 유용한 정보 구성 메시지를 표시합니다.

사용자 사서함을 호스팅하는 Exchange Server 컴퓨터의 모든 데이터베이스에 할당량을 적용하는 것이 좋습니다. 데이터베이스 수준에서 설정해야 하는 세 가지 제한이 있습니다. 할당량 제한은 사서함 저장소 속성 페이지의 제한 탭에서 설정합니다. 각 제한은 킬로바이트(KB) 단위로 표시됩니다.

  • 경고 Issue warning 제한은 사용자에게 경고 전자 메일을 트리거하는 사서함 크기를 정의합니다. 경고 전자 메일은 사용자에게 사서함 크기가 Prohibit send 제한에 근접하고 있음을 알려 줍니다.

  • 보내기 금지 Prohibit send 제한은 사용자가 전자 메일을 보낼 수 없게 되는 사서함 크기를 정의합니다. 사용자는 Exchange 서버로부터 사서함 크기 제한이 초과되었음을 알려 주는 전자 메일을 받게 됩니다.

  • 보내기 및 받기 금지 Prohibit send and receive 제한은 사용자가 전자 메일을 보내거나 받을 수 없게 되는 사서함 크기를 정의합니다. 사용자에게 보내진 모든 메일이 NDR(배달 못 함 보고서)로 보낸 사람에게 반환됩니다.

이러한 규칙을 설정할 때 보내기 금지 제한과 보내기 및 받기 금지 제한 사이에 충분한 변화량을 지정해야 합니다. 이러한 두 제한 사이의 변화량이 너무 적으면 사용자가 사서함을 정리하기 전에 사서함에서 메시지를 거부할 수 있습니다. 따라서 보내기 금지 제한과 보내기 및 받기 금지 제한 사이에 최소 20퍼센트의 버퍼를 지정하는 것이 좋습니다. 예를 들어 사용자가 사서함이 100MB에 도달할 때 새 메시지를 보내지 못하게 된 경우 보내기 및 받기 금지 제한은 최소 120MB가 되어야 합니다.

Exchange 2000 Server 및 Exchange Server 2003에서 사서함 제한을 설정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 이 문제와 관련하여 Exchange Server Analyzer에 표시된 사서함 저장소를 찾습니다.

  3. MailboxStore_Name을 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  4. 제한 탭을 선택합니다.

  5. 다음 크기(KB)일 때 경고 보내기, 다음 크기(KB)일 때 보내기 금지 제한 및 다음 크기(KB)일 때 보내기 및 받기 금지 제한을 수정합니다.

  6. 적용을 클릭한 다음 확인을 클릭합니다.
Exchange Server 2007에서 Exchange 관리 콘솔을 사용하여 사서함 제한을 설정하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. 이 문제와 관련하여 Exchange Server Analyzer에 표시된 사서함 저장소를 찾습니다.

  3. MailboxStore_Name을 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  4. 제한 탭을 선택합니다.

  5. 다음 크기(KB)일 때 경고 보내기, 다음 크기(KB)일 때 보내기 금지 제한 및 다음 크기(KB)일 때 보내기 및 받기 금지 제한을 수정합니다.

  6. 적용, 확인을 차례로 클릭합니다.
Exchange Server 2007에서 Exchange 관리 셸을 사용하여 사서함 제한을 설정하려면 다음을 수행합니다.

  1. 다음 예에서는 사용자에게 경고 메시지를 보내는 사서함의 크기를 설정하는 방법을 보여 줍니다. 이 특성은 이 사서함 데이터베이스에서 고유 경고 할당량 특성이 설정되지 않은 모든 사서함에 적용됩니다. 정수 또는 "무제한"을 지정해야 합니다. 기본값은 1.9GB입니다.

    코드 복사
    Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680

  2. 다음 예에서는 이 사서함 데이터베이스의 사서함과 연결된 사용자가 더 이상 메시지를 보낼 수 없는 사서함 크기를 설정하는 방법에 대해 보여 줍니다. 이 특성은 이 사서함 데이터베이스에서 고유 보내기 금지 할당량 특성이 설정되지 않은 모든 사서함에 적용됩니다. 제한값은 정수 또는 "무제한"으로 설정해야 합니다.

    코드 복사
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152

  3. 다음 예에서는 이 사서함과 연결된 사용자가 더 이상 메시지를 보내거나 받을 수 없는 사서함 크기를 설정하는 방법에 대해 보여 줍니다. 이 특성은 이 사서함 데이터베이스에서 고유 보내기 및 받기 금지 할당량 특성이 설정되지 않은 모든 사서함에 적용됩니다. 정수 또는 "무제한"을 지정해야 합니다.

    코드 복사
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

Exchange Server 2003에서 Exchange 사서함을 관리하는 방법에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)을 참조하십시오.

Exchange Server 2007에서 Exchange 사서함 제한을 관리하는 방법에 대한 자세한 내용은 "How to Configure Database Limits and Properties"(http://go.microsoft.com/fwlink/?LinkId=80746)를 참조하십시오.


이 사서함 저장소에서 콘텐츠 인덱싱을 사용합니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 콘텐츠 인덱싱 다시 작성 일정(msExchCIRebuildSchedule) 특성이 null 이외의 값으로 설정되어 있는지와 콘텐츠 인덱싱 다시 작성 스타일(msExchCIRebuildStyle) 특성이 설정되어 있는지를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이러한 특성은 각 개인 사서함 데이터베이스의 특성입니다. Exchange Server Analyzer는 이러한 특성이 인덱싱을 사용하도록 구성되어 있으면 경고를 표시합니다.

전체 텍스트 인덱싱은 리소스를 많이 사용하는 작업이며 사서함 데이터는 자주 변경되므로 사서함 저장소에 대해 콘텐츠 인덱싱(전체 텍스트 인덱싱)을 실행하지 않는 것이 좋습니다. 따라서 지정된 데이터베이스의 인덱스를 최신으로 유지하는 것은 리소스 소모가 매우 큰 프로세스라고 할 수 있습니다. 전체 텍스트 인덱싱은 공용 폴더에 더 적합합니다.

사서함 저장소에 대해 전체 텍스트 인덱싱을 실행하려면 컴퓨터의 성능을 자주 업데이트 및 모니터링하도록 인덱싱 일정을 설정하여 컴퓨터의 리소스가 과도하게 소모되지 않고 콘텐츠를 인덱싱하는 동안에도 메일을 배달하고 클라이언트 요청에 응답할 수 있는 상태를 유지하도록 해야 합니다.

그렇지 않으면 사서함 저장소의 전체 텍스트 인덱스를 삭제하여 전체 텍스트 인덱싱을 사용하지 않도록 하는 것이 좋습니다.

특정 사서함 저장소에 대해 전체 텍스트 인덱싱을 사용하지 않으려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버, 사용 중인 서버, 저장소 그룹을 차례로 확장하고 사서함 저장소를 마우스 오른쪽 단추로 클릭한 다음 전체 텍스트 인덱스 삭제를 클릭합니다.

Exchange에서 전체 텍스트 인덱싱을 구성하고 관련 문제를 해결하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서, "HOW TO: Configure Full-Text Indexing on Mailbox Stores in Exchange 2003" (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932)을 참조하십시오.


이 공용 폴더 저장소에 대해 콘텐츠 인덱싱을 사용합니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 콘텐츠 인덱싱 다시 작성 일정(msExchCIRebuildSchedule) 특성 및 콘텐츠 인덱싱 다시 작성 스타일(msExchCIRebuildStyle) 특성이 존재하는지 여부와 0이 아닌 값으로 설정되어 있는지 확인하기 위해 Active Directory® 디렉터리 서비스를 쿼리합니다. 이러한 특성은 각 공용 정보 저장소 데이터베이스의 특성입니다.

Exchange Server Analyzer는 이러한 두 가지 특성이 모두 있고 0 이외의 값으로 설정되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

이러한 두 특성이 모두 1로 설정되면 정보 저장소 데이터베이스에 대해 전체 텍스트 인덱싱이 활성화된 것입니다. 전체 텍스트 인덱싱을 설정하면 지정된 데이터베이스의 모든 단어가 인덱싱되어 검색 기능이 보다 강력해지고 빨라집니다. 전체 텍스트 인덱싱을 배포할 때는 개별 공용 폴더나 사서함 저장소가 인덱싱되도록 선택합니다. 그러면 사용자들은 공용 폴더나 사서함 저장소에 포함된 메시지 및 첨부 파일에 대해 전체 텍스트 검색을 수행할 수 있습니다.

기본적으로 인덱스에는 메시지의 제목과 본문, 보낸 사람과 받는 사람의 이름, 참조 및 숨은 참조 필드에 나타나는 이름이 포함됩니다. 또한 인덱스에는 doc, .xls, .ppt, .html, .htm, .asp, .txt, eml(포함된 MIME(Multipurpose Internet Mail Extensions) 메시지) 형식의 첨부 파일에서 가져온 텍스트도 포함됩니다. 그림 및 소리 같은 이진 첨부 파일은 인덱싱되지 않습니다.

검색 결과는 인덱스가 마지막으로 업데이트되었을 때의 상태로 제공됩니다. 공용 폴더 또는 사서함 저장소의 콘텐츠가 변경되면 인덱스를 업데이트하여 새 콘텐츠를 적용해야 합니다. 인덱스 업데이트는 수동으로 수행하거나 일정에 따라 자동으로 수행할 수 있습니다.

전체 텍스트 인덱싱 파일은 네 가지 주요 범주로 분류할 수 있습니다. 이러한 파일의 디스크 위치를 다음과 같이 정렬하여 전체 텍스트 인덱싱의 성능을 최적화할 수 있습니다.

  • 카탈로그카탈로그가 주 인덱스입니다. Exchange 저장소마다 하나의 카탈로그가 있을 수 있습니다. 카탈로그를 RAID-0+1 배열로 배치합니다. 카탈로그를 만들 때 Exchange System Manager에서 카탈로그 위치를 지정할 수 있습니다.

  • 속성 저장소 카탈로그에 인덱싱된 항목의 다양한 속성을 포함하는 데이터베이스입니다. 서버마다 속성 저장소가 하나만 있습니다. 전체 텍스트 속성 저장소를 RAID 배열에 배치합니다. 기본적으로 파일은 Exchange Server가 설치되어 있는 동일한 드라이브에 설치됩니다.

  • 임시 파일 Microsoft Search 서비스에 사용되는 임시 정보를 포함하는 파일입니다. 전체 텍스트 인덱스 임시 디렉터리를 RAID 배열에 배치합니다. 기본적으로 이러한 파일은 RAID 배열의 입출력 처리량을 포함하지 않는 시스템 드라이브에 설치됩니다.

  • 수집기 로그 인덱싱 서비스에 대한 로그 정보를 포함하는 파일입니다. 카탈로그마다 하나의 로그 집합이 존재합니다. 수집기 로그를 기본 위치에 그대로 두거나 원하는 위치로 이동할 수 있습니다.

전체 텍스트 인덱싱을 활성화하거나 비활성화하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange 서버를 차례로 확장한 후 작업할 공용 폴더 저장소가 들어 있는 저장소 그룹을 확장합니다.

  3. 공용 폴더 저장소를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  4. 전체 텍스트 인덱싱 탭을 선택합니다.

  5. 필요할 경우 업데이트 간격 필드를 편집합니다.

  6. 확인을 클릭하여 변경 내용을 저장하고 공용 폴더 저장소 속성을 닫습니다.

전체 텍스트 인덱싱 공용 폴더에 대한 자세한 내용은 Microsoft 기술 자료 문서 319433, "HOW TO: Configure Full-Text Indexing on Public Folders"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319433)를 참조하십시오.

사서함 저장소에서 전체 텍스트 인덱싱 구성 및 문제 해결에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 822932, "HOW TO: Configure Full-Text Indexing on Mailbox Stores in Exchange 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822932)

  • 319436, "HOW TO: Configure Full-Text Indexing on Mailbox Stores in Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822932)

다국어 환경의 전체 텍스트 인덱싱에 대한 자세한 내용은 Microsoft 기술 자료 문서 325624, "XGEN: Full-Text Indexing with Multiple Languages"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325624)를 참조하십시오.

적절한 전체 텍스트 인덱싱 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 326186, "XADM: White Paper - The Best Practices for Deploying Full-Text Indexing"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=326186)을 참조하십시오.


DSN이 현재 메시지로 렌더링되고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-03-21

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터의 DSN(배달 상태 알림)이 표준 메시지로 렌더링되고 있는지 확인할 때 다음 레지스트리 값을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\RenderDSNsAsMessages

Exchange Server Analyzer는 RenderDSNsAsMessages 레지스트리 항목이 0보다 큰 값으로 구성되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

RenderDSNsAsMessages 레지스트리 항목은 이름을 통해 알 수 있듯이 관리자가 Exchange 2000 Server, Exchange Server 2003 및 Exchange Server 2007 컴퓨터에서 DSN이 렌더링되는 방식을 제어할 수 있는 구성 방법을 나타냅니다.

  • RenderDSNsAsMessages 값 데이터가 0으로 설정되어 있으면 DSN(배달 보고서 및 배달 못 함 보고서 포함)은 표준 MAPI 메시지로 렌더링됩니다.

  • RenderDSNsAsMessages 값 데이터가 0보다 큰 값으로 설정되어 있으면 DSN은 multipart/혼합 MIME 메시지로 렌더링됩니다.

이 레지스트리 값은 기본적으로 제공되지 않으므로 사용하려면 수동으로 추가해야 합니다. 또한 항목이 Exchange 2000 Server에 적절하게 적용되려면 컴퓨터에 최소한 2003년 9월 Exchange 2000 Server 서비스 팩 3 이후 롤업이 실행되고 있어야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. RenderDSNsAsMessages 레지스트리 항목을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.
  • 레지스트리를 편집하기 전에 레지스트리를 편집하는 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

  • 배달 상태 알림 형식 문제에 대한 자세한 내용은 기술 자료 문서 812806, "Exchange 사용자가 예기치 않게 사용자 지정 NDR 대신 표준 NDR을 수신한다"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812806)를 참조하십시오.

  • Exchange 2000 Server 서비스 팩 3 이후 롤업에 대한 자세한 내용은 Microsoft 기술 자료 문서 824282, "2003년 9월 Exchange 2000 Server 서비스 팩 3 이후 롤업"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824282)을 참조하십시오.


데이터베이스의 Aging Keep Time 간격이 기본값이 아닌 다른 값으로 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange 클라이언트 보기 데이터베이스 인덱스에 대한 기본 에이징 값이 무시되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Private-<Private Information Store GUID>\Aging Keep Time

Exchange Server Analyzer는 Aging Keep Time 레지스트리 항목이 구성되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange 클라이언트가 Exchange 데이터베이스 테이블에 만든 보기에 사용된 인덱스 중 지정된 시간 동안 사용되지 않은 것은 이 시점에서 정리됩니다. 다음 레지스트리 항목은 인덱스 에이징을 제어하는 데 사용됩니다.

  • Aging Keep Time 삭제되기 전의 최소 인덱스 에이징입니다. 기본값은 Exchange Server 5.5의 경우 8일이고, Exchange 2000 Server, Exchange Server 2003 및 Exchange Server 2007의 경우 40일입니다.

  • Aging Clean Interval 인덱스 에이징 작업이 실행되는 최소 간격(밀리초)입니다. 기본값은 24시간입니다.

  • Reset Views 이 설정이 0이 아닌 값으로 구성되어 있으면 캐시된 인덱스는 다음 인덱스 에이징 작업이 실행되는 동안 모두 삭제됩니다. 인덱스 에이징이 완료되면 Reset Views 값은 0으로 설정됩니다.

Microsoft PSS(기술 지원 서비스)에서 다른 지침을 제공하지 않는 한 Aging Keep Time 레지스트리 값을 추가하지 않는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

Aging Keep Time 레지스트리 값을 보거나 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음을 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Private-<Private Information Store GUID>

  3. Aging Keep Time 값을 검사하고 필요한 경우 변경합니다.

  4. 레지스트리 편집기를 닫습니다. 레지스트리 내용을 변경했으면 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


데이터베이스 파일과 로그 파일이 같은 디스크 볼륨에 저장되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 이 사서함 저장소의 데이터베이스 파일이 이 저장소 그룹의 트랜잭션 로그 파일과 동일한 실제 디스크에 상주하는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 특히 Exchange Server Analyzer는 Active Directory를 쿼리하여 아래 내용을 확인합니다.

  • 사서함 저장소 개체(msExchPrivateMDB 클래스)의 homeMDBBL 특성 값을 세어 확인한 사서함 저장소의 사서함 수가 100개를 초과하는지 여부 사서함 저장소의 사서함 수가 100개 미만이면 파일 위치의 성능 영향이 제한됩니다.

  • 사서함 저장소 개체의 msExchEDBFile 값을 읽어서 확인한 사서함 저장소의 데이터베이스 파일 경로

  • 사서함 저장소 개체(msExchStorageGroup 클래스)의 msExchESEParamLogFilePath 값을 읽어서 확인한 사서함 저장소 그룹의 트랜잭션 로그 파일 경로

  • msExchESEParamLogFilePath의 경로가 msExchEDBFile의 경로와 동일한 디스크에 있는지 여부

또한 Exchange Server Analyzer는 아래 내용을 확인합니다.

  • Exchange Server Nas 확장(wssexchmap)의 Started 특성 값에 대해 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 확인한 Windows 기반 NAS용 Exchange Server 확장이 해당 서버에서 실행 중인지 여부를 결정합니다. Windows 기반 NAS의 Exchange Server 확장이 실행 중이면 해당 로그 파일과 데이터베이스 파일이 로컬 드라이브에 있지 않고 성능 고려 사항이 적용되지 않을 수 있습니다.

  • Win32_Volume WMI 클래스를 쿼리하여 확인한 해당 파일 이름이 3자보다 긴 디스크 볼륨에 있는지 여부를 결정합니다. 이 경우도 파일이 로컬 드라이브에 있지 않고 성능 고려 사항이 적용되지 않을 수 있음을 나타냅니다.

하드 디스크에 오류가 발생할 때 내결함성을 제공하려면 Exchange 트랜잭션 로그 파일과 데이터베이스 파일을 별도의 실제 하드 디스크에 보관합니다. 이러한 로그 파일과 데이터베이스 파일을 별도의 하드 디스크에 보관하면 하드 디스크 I/O 성능을 크게 향상시킬 수 있습니다.

참고:
데이터베이스를 복원해야 할 때 내결함성을 제공하려면 각 저장소 그룹에 고유의 트랜잭션 로그 파일 집합이 있어야 합니다. 트랜잭션 로그 파일은 해당 저장소 그룹의 모든 데이터베이스에 대한 변경 기록을 모두 유지합니다. 트랜잭션 로그 파일은 저장소 그룹의 모든 데이터베이스의 전체 백업이 완료된 후 삭제됩니다.

아래 예는 백업과 트랜잭션 로그 파일이 별도의 디스크에 저장된 경우 데이터베이스 파일이나 트랜잭션 로그 파일이 저장된 하드 디스크가 손실되는 것 같은 심각한 상황의 데이터 복구 방법을 설명합니다.

  • 데이터베이스 파일이 저장된 하드 디스크에 결함이 발생하면 결함이 발생한 하드 디스크를 교체하고 가장 최근 백업된 데이터베이스 파일을 복원한 다음 분리된 하드 디스크에 저장했던 현재 로그 파일을 사용하여 사용 중인 Exchange 서버에서 데이터를 복원하고 하드 디스크에 결함이 발생한 시점의 최신 데이터로 회복할 수 있습니다.

  • 트랜잭션 로그 파일이 저장된 하드 디스크에 결함이 발생했지만 데이터베이스 파일이 저장된 하드 디스크의 기능이 작동하고 데이터베이스 저장소 파일이 적절하게 닫힐 경우 오류가 발생한 트랜잭션 로그 디스크를 복구하고 데이터베이스 저장소를 다시 탑재할 수 있습니다. 데이터베이스 저장소 파일이 적절하게 닫히지 않을 경우 이 파일은 일관성 없는 상태에 있게 되고 eseutil.exe를 사용하여 하드를 복구한 후 데이터베이스 저장소를 탑재할 수 있으므로 그 결과 일부 데이터가 손실될 수 있습니다. 다른 옵션은 백업에서 데이터베이스 저장소 파일을 복원하는 것이며 이 파일에는 백업 시기 이후 작성된 새 사서함 데이터가 포함되지 않습니다.

중요:
Exchange 데이터베이스와 트랜잭션 로그 파일을 동일한 실제 하드 디스크에 저장한 상태에서 하드 디스크에 결함이 발생하면 마지막 백업 이후 작성된 데이터는 손실됩니다.

또한 데이터베이스 파일과 트랜잭션 로그 파일을 별도의 실제 디스크에 저장하면 전체적인 성능이 향상됩니다. Exchange는 우선 각 트랜잭션을 트랜잭션 로그 파일에 기록한 다음 데이터베이스 파일에 기록합니다. 또한 저장소 그룹의 모든 사서함 저장소는 트랜잭션 로그 파일을 공유합니다. 이러한 파일이 동일한 실제 디스크에 있으면 드라이브 헤드는 현재 트랜잭션 로그 파일 위치와 데이터베이스 파일 위치 사이에서 앞뒤로 움직여 기록 작업을 완료합니다. 파일이 별도의 디스크에 있으면 드라이브 헤드는 제자리에서 트랜잭션 로그 파일에 기록하기 때문에 파일이 단일 디스크에 저장될 때보다 빠르게 트랜잭션을 완료할 수 있습니다. 단일 트랜잭션의 성능 차이는 작지만 시스템 로드가 커지면 차이가 뚜렷해질 수 있습니다.

구성을 수정할 때 트랜잭션 로그 파일이나 데이터베이스 파일을 이동할 수 있습니다.

Exchange 2000 Server 또는 Exchange Server 2003에서 트랜잭션 로그 파일을 새 드라이브로 이동하려면 다음을 수행합니다.

  1. Exchange System Manager에서 해당 Exchange 서버 개체를 확장하고 이동할 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 파일에 새 위치를 지정합니다.

    예를 들어 E:\ 드라이브에 이 저장소 그룹의 로그 파일만 저장하려면 트랜잭션 로그 위치에서 찾아보기를 클릭한 다음 E:\ 드라이브를 선택합니다.

Exchange Server 2007의 Exchange 저장소 그룹 트랜잭션 로그 파일 위치를 변경하려면 다음을 수행합니다.

  1. 핵심 Exchange Server 2007 설명서 "How to Set or Change the Location of Storage Group Log Files"(http://go.microsoft.com/fwlink/?LinkId=80702)의 안내를 따릅니다.

Exchange 2000 Server 또는 Exchange Server 2003에서 데이터베이스 파일을 새 드라이브로 이동하려면 다음을 수행합니다.

  1. Exchange System Manager에서 저장소가 상주하는 Exchange 서버 개체, 해당 저장소 그룹 컨테이너를 차례로 확장하고 이동할 사서함 저장소 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 속성 대화 상자의 데이터베이스 탭에서 새 파일 위치를 지정합니다.
주의:
데이터베이스 파일을 이동하려면 데이터베이스를 임시로 분리한 다음 다시 탑재해야 합니다. 이 작업은 마법사를 통해 자동으로 실행되지만 작업이 진행되는 동안 모든 사용자가 이 데이터베이스에 액세스할 수 없습니다.

Exchange Server 2007에서 데이터베이스 경로 이동 마법사를 사용하여 데이터베이스 파일을 새 드라이브로 이동하려면 다음을 수행합니다.

  1. 저장소 그룹이 있는 서버에서 Exchange 관리 콘솔을 시작합니다.

  2. 콘솔 트리에서 서버 구성을 확장하고 사서함을 클릭합니다.

  3. 결과 창에서 해당 저장소 그룹 컨테이너를 확장하고 원하는 사서함 데이터베이스 개체를 마우스 오른쪽 단추로 클릭한 다음 데이터베이스 경로 이동을 클릭합니다. 데이터베이스 경로 이동 마법사가 표시됩니다.

  4. 소개 페이지의 데이터베이스 파일 경로 상자에 데이터베이스 파일이 현재 저장되어 있는 위치가 표시됩니다. 찾아보기를 클릭하여 이 파일을 이동할 위치를 지정합니다.

  5. 이동을 클릭합니다.

  6. 완료 페이지에서 데이터베이스 파일 경로가 변경되었는지 여부를 확인합니다. 완료 상태는 마법사에서 작업을 완료했음을 나타냅니다. 실패 상태는 작업이 완료되지 않았음을 나타냅니다. 작업이 실패한 경우 요약된 설명을 읽어 본 후 뒤로를 클릭하여 구성을 변경합니다. 마침을 클릭하여 데이터베이스 경로 이동 마법사를 완료합니다.
참고:
Exchange Server 2007에서 Exchange 관리 셸을 사용하여 데이터베이스 파일을 이동할 수도 있습니다. 자세한 내용은 Move-DatabasePath를 참조하십시오.

Exchange Server 데이터베이스 파일에 대한 자세한 내용은 다음 항목을 참조하십시오.

  • Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "사서함 저장소 및 공용 폴더 저장소 관리"

  • Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 저장소 이해"

Exchange Server 데이터베이스 파일 관리에 대한 자세한 내용은 Microsoft 기술 자료 문서 328794, "How to Protect Exchange Data from Hard Disk Failure"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328794)를 참조하십시오.

Exchange 데이터베이스 저장소의 하드 복구에 대한 자세한 내용은 기술 자료 문서 296788, "XADM: Exchange 2000 Server의 오프라인 백업 및 복원 절차"(http://go.microsoft.com/fwlink/"LinkId=3052&kbid=296788)를 참조하십시오.

Exchange 데이터베이스 저장소 파일의 하드 복구 수행에 대한 자세한 내용은 기술 자료 문서 810190, "XADM: "정보 저장소가 비정상적으로 종료되었습니다" 오류 메시지가 나타나고 이벤트 ID 447이 기록된다"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810190)를 참조하십시오.


데이터베이스에 모든 로그 파일이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 이 데이터베이스를 복구하는 데 필요한 모든 로그 파일이 복구할 수 있는 올바른 위치에 있음을 확인했습니다. 따라서 누락되거나 일치되지 않는 트랜잭션 로그 파일로 인한 복구 장애는 발생하지 않습니다.

데이터베이스나 트랜잭션 로그 파일이 손상되었거나 다른 파일이 복구 프로세스와 충돌하는 것이 원인일 수 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  • Exchange System Manager를 사용하여 저장소 그룹에 데이터베이스 중 하나를 탑재한 다음 장애의 원인을 나타내는 오류에 대한 응용 프로그램 로그를 표시합니다.

  • 격리 상태의 데이터베이스를 복구합니다. 데이터베이스를 분석한 후 Exchange Server Analyzer는 격리 상태의 데이터베이스를 복구하는 지침을 표시합니다.

  • Eseutil.exe /ML을 실행하여 필수 로그 파일의 무결성을 확인합니다. Eseutil 사용 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 248122, "How to use Eseutil to test transaction log files for damage in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=248122)을 참조하십시오.


데이터베이스가 완전하게 종료된 상태입니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange 데이터베이스가 완전하게 종료된 상태임을 확인했습니다.

완전하게 종료된 상태의 데이터베이스가 올바르게 종료되고 로그 파일 스트림에서 분리되었습니다. 따라서 데이터베이스를 다시 탑재하려면 복구 작업을 수행하지 않고 탑재해야 할 수 있습니다.

완전하게 종료된 상태의 데이터베이스를 탑재할 수 없는 경우 원인은 데이터베이스에 추가적인 트랜잭션 로그 파일 다시 재생이 필요하기 때문은 아닙니다. 그러나 동일한 저장소 그룹의 다른 데이터베이스에 필요한 트랜잭션 로그 다시 재생으로 인해 완전하게 종료된 데이터베이스가 탑재되지 못하는 것일 수 있습니다. Exchange 저장소 그룹에 있는 데이터베이스를 탑재하려면 먼저 저장소 그룹에 있는 모든 데이터베이스가 복구되고 탑재 가능한 상태여야 합니다.

완전하게 종료된 상태의 데이터베이스는 이전 트랜잭션 로그나 다른 트랜잭션 로그 집합을 사용하여 탑재할 수 있습니다. 완전하게 종료된 상태의 데이터베이스를 탑재하고 트랜잭션 로그가 하나도 없는 경우에는 새로운 트랜잭션 로그 집합이 생성됩니다.

참고:
일반적으로 저장소 그룹에 있는 모든 데이터베이스가 완전하게 종료된 상태에 있더라도 기존의 트랜잭션 로그 파일을 삭제해서는 안 됩니다. 기존의 트랜잭션 로그 파일을 삭제하면 이전 백업에서 롤 포워드할 수 없습니다. 그러나 저장소 그룹에 있는 모든 데이터베이스가 완전하게 종료된 상태에 있는 경우에는 트랜잭션 로그 파일을 삭제해도 현재 데이터베이스에 영향을 미치지 않습니다. 저장소 그룹의 모든 트랜잭션 로그 파일을 삭제하는 경우에는 즉시 저장소 그룹의 모든 데이터베이스에 대한 전체 백업을 만드는 것이 좋습니다.


데이터베이스가 부적절한 종료 상태에 있고 다른 로그가 필요하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-08-10

Microsoft® Exchange Server Analyzer Tool은 데이터베이스가 부적절한 종료 상태에 있음을 확인했습니다.

정의에 의하면 부적절한 종료 상태에 있는 데이터베이스에서 하나 이상의 트랜잭션 로그 파일을 재생해야 합니다. 데이터베이스의 부적절한 종료 상태는 탑재 가능한 상태가 아니고 일반 작업 중에 발생하면 안 됩니다.

이 오류를 해결하려면 다음을 수행하십시오.

  • 데이터베이스 및 로그 파일에 대한 고급 분석을 보려면 Microsoft 고객지원(http://go.microsoft.com/fwlink/?linkid=3052&kbid=31845)에 문의하십시오.


데이터베이스 상태를 알 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에서 데이터베이스의 상태를 알 수 없음을 발견했습니다. 일반적으로 데이터베이스 상태는 완전하게 종료된 상태이거나 부적절하게 종료된 상태여야 합니다. Exchange 2000 Server 이전에서는 이러한 상태를 각각 Consistent 또는 Inconsistent 상태라고 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 데이터베이스 상태의 고급 분석에 대해서는 Microsoft 도움말 및 지원 센터(http://go.microsoft.com/fwlink/?LinkId=31845)에 문의하십시오.


데이터베이스에 옵션 및 필수 로그 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 이 데이터베이스를 복구하는 데 필요한 로그 파일이 로그 파일 폴더에 없음을 확인했습니다. 필수 로그 파일이 없으면 로그 파일을 찾을 때까지 데이터베이스를 복구할 수 없습니다.

Exchange 데이터베이스가 제대로 종료되지 않은 경우 데이터베이스를 다시 탑재하려면 먼저 해당 데이터베이스로 로그 파일을 재생해야 합니다. 재생해야 할 로그 파일이 단 하나뿐일 경우도 있지만 대개 여러 개의 로그 파일이 있습니다.

필수 로그 파일과 함께 데이터베이스에 대해 재생할 수 있는 추가 로그 파일이 있을 수 있습니다. 데이터베이스를 탑재하기 위해 먼저 이러한 옵션 로그 파일을 재생해야 할 필요는 없지만 이러한 로그 파일을 사용하여 추가 데이터를 복구할 수 있습니다. 이러한 옵션 로그 파일을 재생하지 않으면 로그 파일에 포함된 모든 데이터가 손실됩니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 누락된 트랜잭션 로그 파일을 찾아서 해당 폴더에 추가합니다.

  • 모든 옵션 로그 파일을 찾을 수 없는 경우에는 필수 로그 파일만 격리하여 데이터베이스를 복구할 수 있습니다. 옵션 로그 파일을 사용하지 않고 데이터베이스를 복구하려면 Exchange Server Analyzer의 지침을 따릅니다. 옵션 로그 파일을 사용하지 않고 데이터베이스를 복구하면 해당 옵션 파일에 포함된 데이터가 손실될 수 있습니다.

    그러나 누락된 로그 파일에 따라 데이터베이스에 대해 일부 옵션 로그 파일을 재생할 수 있습니다. 예를 들어 다음 시나리오를 살펴봅니다. 1부터 10까지 번호가 매겨진 로그 파일이 있습니다. 10번째 로그 파일은 필수 파일이고 나머지 파일은 옵션 파일이며 6번째 로그 파일이 없습니다. 이 경우 필수 파일까지의 순서는 변하지 않으므로 7부터 10까지 번호가 매겨진 로그 파일을 재생할 수 있습니다.

  • 현재 데이터베이스를 복구합니다.

    참고:
    데이터베이스 복구가 반드시 성공할 수 있는 것은 아닙니다. 성공적 복구에도 정도의 차이는 있지만 데이터 손실이 발생할 수 있습니다. Exchange 데이터베이스 복구에 대한 자세한 내용은 Microsoft 기술 자료 문서 812357, "XADM: Eseutil /p 도구를 사용하여 복구한 후 Exchange 데이터베이스 관리"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357)를 참조하십시오.

  • 데이터베이스 복구 및 복원이 포함된 혼합형 전략을 구현합니다. 경우에 따라 추가 로그 파일로 데이터베이스를 롤 포워드할 수 없는 경우에도 데이터베이스를 복원할 수 있습니다. 이 경우 탑재할 수 없는 현재 복사본을 복구하면서 동시에 데이터베이스의 이전 복사본을 복원할 수 있습니다. 그런 다음 데이터베이스 내용을 병합하여 데이터 복구를 최대화할 수 있습니다. 이 전략은 고급 전략이므로 구현 전에 Microsoft 도움말 및 지원(http://go.microsoft.com/fwlink/?LinkId=31845)에 문의할 수 있습니다. 이 전략에 대한 자세한 내용은 Using Recovery Storage Groups in Exchange Server 2003(http://go.microsoft.com/fwlink/?LinkId=47589)을 참조하십시오.


데이터베이스에 선택적 로그 파일은 없지만 필수 로그 파일은 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에서 데이터베이스 중 하나가 올바르게 종료되지 않았음을 확인했습니다.

Exchange 데이터베이스가 제대로 종료되지 않은 경우 데이터베이스를 다시 탑재하려면 먼저 해당 데이터베이스로 로그 파일을 재생해야 합니다. 재생해야 할 로그 파일이 하나만 있을 수도 있습니다. 그러나 보통의 경우 로그 파일이 여러 개 있습니다.

필수 로그 파일 외에 데이터베이스로 재생할 수 있는 로그 파일이 추가로 있을 수 있습니다. 데이터베이스를 탑재하기 전에 이러한 선택적 로그 파일을 반드시 재생해야 할 필요는 없지만 이러한 로그 파일을 사용하면 추가 데이터를 복구할 수 있습니다. 이러한 선택적 로그 파일을 재생하지 않을 경우 여기에 포함되어 있는 데이터는 모두 손실됩니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 누락된 선택적 로그 파일을 찾아서 트랜잭션 로그 폴더에 복사합니다.

  • 선택적 로그 파일을 모두 찾을 수 없는 경우 필수 로그 파일만 가지고 별도로 데이터베이스를 복구할 수 있습니다. 선택적 로그 파일 없이 데이터베이스를 복구하려면 Exchange Server Analyzer의 지시를 따릅니다. 옵션 로그 파일을 사용하지 않고 데이터베이스를 복구하면 해당 옵션 파일에 포함된 데이터가 손실될 수 있습니다.

    그러나 누락된 로그 파일에 따라 선택적 로그 파일 중 일부를 데이터베이스로 재생할 수도 있습니다. 예를 들어 다음과 같은 시나리오를 가정해 보십시오. 1부터 10까지 번호를 매긴 로그 파일이 있습니다. 10번째 로그 파일은 필수이고 나머지 파일은 선택적인데 그 중 6번째 로그 파일이 누락되었습니다. 이 경우 필수 파일까지의 순서는 변하지 않으므로 7부터 10까지 번호가 매겨진 로그 파일을 재생할 수 있습니다.


데이터베이스에 필수 로그 파일이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 이 데이터베이스를 복구하는 데 필요한 로그 파일이 로그 파일 폴더에 없음을 확인했습니다. 필수 로그 파일이 없으면 로그 파일을 찾을 때까지 데이터베이스를 복구할 수 없습니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 누락된 트랜잭션 로그 파일을 찾아서 해당 폴더에 추가합니다.

  • 백업에서 데이터베이스를 복원합니다. 그런 다음 데이터베이스에 대해 나머지 트랜잭션 로그 파일을 재생하여 데이터베이스를 롤 포워드합니다.

    중요:
    누락된 로그 파일 및 이후 로그 파일의 데이터는 손실됩니다. 백업에서 데이터베이스를 복원하기 전에 현재 데이터베이스 복사본을 저장해야 합니다. 복원 작업에 실패하면 현재 데이터베이스를 복구할 수 있습니다.

  • 현재 데이터베이스를 복구합니다.

    참고:
    데이터베이스 복구가 반드시 성공할 수 있는 것은 아닙니다. 성공적 복구에도 정도의 차이는 있지만 데이터 손실이 발생할 수 있습니다. Exchange 데이터베이스 복구 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 812357, "XADM: Eseutil /p 도구를 사용하여 복구한 후 Exchange 데이터베이스 관리"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357)를 참조하십시오.

  • 데이터베이스 복구 및 복원이 포함된 혼합형 전략을 구현합니다. 경우에 따라 추가 로그 파일로 데이터베이스를 롤 포워드할 수 없는 경우에도 데이터베이스를 복원할 수 있습니다. 이 경우 탑재할 수 없는 현재 복사본을 복구하면서 동시에 데이터베이스의 이전 복사본을 복원할 수 있습니다. 그런 다음 데이터베이스 내용을 병합하여 데이터 복구를 최대화할 수 있습니다. 이 전략은 고급 전략이므로 구현 전에 Microsoft 도움말 및 지원(http://go.microsoft.com/fwlink/?LinkId=31845)에 문의할 수 있습니다. 이 전략에 대한 자세한 내용은 Using Recovery Storage Groups in Exchange Server 2003(http://go.microsoft.com/fwlink/?LinkId=47589)을 참조하십시오.


백업하는 동안 이 저장소 그룹의 데이터베이스가 0으로 채워진 페이지로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 서버에 있는 각 저장소 그룹의 msExchESEParamZeroDatabaseDuringBackup 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchESEParamZeroDatabaseDuringBackup 특성이 1로 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

msExchESEParamZeroDatabaseDuringBackup 특성은 백업하는 동안 0으로 이루어진 삭제된 레코드/Long 값을 덮어쓸 수 있는 구성 설정을 나타냅니다. 이러한 프로세스를 영구 삭제라고 합니다. 저장소 그룹 수준에서 데이터베이스 페이지의 영구 삭제 작업을 제어할 수 있습니다. 각 저장소 그룹은 삭제된 데이터베이스 페이지의 영구 삭제 작업에 대해 각각 다른 정책을 가질 수 있습니다.

기본적으로 영구 삭제 작업은 사용할 수 없게 설정되며 msExchESEParamZeroDatabaseDuringBackup 특성 값은 0으로 설정되어 있습니다. 특성을 1로 설정하면 해당 저장소 그룹에 있는 데이터베이스 중 하나의 온라인 백업이 종료될 때 삭제된 데이터베이스 페이지를 다른 문자로 덮어씁니다.

Exchange 2000 Server 및 Exchange Server 2003에 대한 영구 삭제 작업을 활성화하거나 비활성화하는 것은 이 문서에 설명된 것처럼 Exchange System Manager를 사용하여 수행할 수 있습니다. Exchange Server 2007에 대한 영구 삭제 작업을 활성화하거나 비활성화하는 것도 이 문서에 설명된 것처럼 Exchange 관리 셸을 사용하여 수행할 수 있습니다. 이 옵션을 사용하면 보안이 향상되지만 서버 성능에 영향을 미칩니다.

참고 Exchange 2000 Server 컴퓨터에서 영구 삭제 작업을 사용할 수 있게 설정한 경우에는 Exchange 2000 Server 서비스 팩 3 이상 버전을 설치하는 것이 좋습니다. 서비스 팩 3에서는 Exchange 정보 저장소가 응답 중지를 발생시킬 수 있는 알려진 문제가 해결되었습니다. 이 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 320883, "XADM: The Information Store Stops Responding During an Online Backup If Database Zeroing Is Turned On"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320883)을 참조하십시오.

Exchange 2000 Server 및 Exchange Server 2003에 대한 영구 삭제 작업을 활성화하거나 비활성화하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버를 확장한 다음 수정할 서버를 확장합니다.

  3. 변경할 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 속성 대화 상자에서 필요한 경우 삭제된 데이터베이스 페이지를 영구 삭제 확인란을 선택하거나 선택을 취소합니다. 확인란을 선택하면 영구 삭제 작업이 사용할 수 있게 설정되고 확인란의 선택을 취소하면 영구 삭제 작업이 사용할 수 없게 설정됩니다.

  5. 확인을 클릭하여 설정을 저장합니다.

  6. Exchange System Manager를 닫은 다음 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

Exchange Server 2007에서 삭제된 페이지에 대해 영구 삭제 작업을 활성화하거나 비활성화하려면 다음을 수행합니다.

  1. 다음 코드는 'MyStorageGroup' 저장소 그룹에서 데이터베이스에 대한 영구 삭제 작업을 활성화하거나 비활성화하는Set-StorageGroup 명령의 예입니다.
코드 복사
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $false
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $true

삭제된 데이터베이스 페이지 덮어쓰기 작업이 성능에 미치는 영향에 대한 자세한 내용은 기술 자료 문서 815068, "XADM: Online Backup Performance Decreases Over Time"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815068)을 참조하십시오.


Debug Break At Startup이 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange Information Store에서 디버깅이 활성화되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Debug Break At Startup

Exchange Server Analyzer는 Debug Break At Startup에 대한 값이 설정되어 있는 경우 경고를 표시합니다.

Debug Break At Startup 레지스트리 값은 다음 번에 Microsoft Exchange Information Store 서비스를 시작할 때 디버그 모드를 설정합니다. Microsoft Exchange Information Store는 디버그 모드에서 실행될 때 많은 리소스를 사용합니다. Production 환경에서 이 저장소를 디버깅하는 것은 좋지 않습니다.

Microsoft 기술 지원 서비스의 도움으로 저장소 문제를 해결할 수 없는 경우 Debug Break At Startup 레지스트리 값을 삭제해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
Debug Break At Startup 레지스트리 키를 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. 오른쪽 창에서 Debug Break At Startup 값을 찾아 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


기본 ESE 로그 버퍼가 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 검색하여 Exchange Server 컴퓨터에 있는 각 저장소 그룹의 msExchESEParamLogBuffers 특성 값을 확인합니다. Exchange Server Analyzer는 msExchESEParamLogBuffers 값이 512와 같으면 기본 구성이 아니라는 메시지를 표시합니다.

msExchESEParamLogBuffers 저장소 그룹 특성은 Exchange 정보 저장소에서 사용하는 확장 가능한 저장소 엔진(ESE) 로그 버퍼 수를 제어합니다. ESE는 트랜잭션 로그에 정보를 쓰기 전에 RAM에서 유지하기 위해 일련의 로그 버퍼를 사용합니다. 이러한 버퍼 사용을 통해 트랜잭션 로깅 성능이 향상됩니다. 대용량 서버의 경우 기본값 84는 너무 낮습니다. 이로 인해 트랜잭션 로그 드라이브에 과도한 디스크 I/O 작업이 발생하기 때문에 서버에 부하가 발생하거나 사용자가 대용량 메시지를 보낼 경우 심각한 성능 저하를 초래할 수 있습니다. ESE 로그 버퍼 수를 늘리면 가상 메모리 사용량도 늘지만 성능이 향상됩니다.

이 값을 올바르게 설정하려면 다음 정보를 사용합니다.

  • Exchange 2000 Server, Exchange 2000 Server 서비스 팩 1(SP1) 또는 Exchange 2000 Server 서비스 팩 2(SP2)의 경우 이 값을 9000으로 설정합니다.

  • Exchange 2000 Server SP3(서비스 팩 3)의 경우 이 값을 512로 설정합니다.

  • Exchange Server 2003의 경우 기본값 500을 사용하고 msExchESEParamLogBuffers 특성 값을 9000으로 변경해야 합니다.

참고:
이전에 로그 버퍼를 9000으로 조정한 경우에는 Exchange 2000 Server SP3을 적용한 후에 이 설정을 수동으로 낮춰야 합니다. 이 설정은 Exchange 2000 Server SP3을 설치할 때 자동으로 변경되지 않습니다.

버퍼가 너무 작아서 로그가 정지되면 이 값을 최대 9000까지 높일 수 있습니다. Database\Log Record Stalls/sec 성능 카운터를 모니터링하면 로그 정지가 발생하는지 확인할 수 있습니다. 트랜잭션 로그 파일을 손상할 수 있으므로 9000보다 큰 값을 사용하지 마십시오.

참고:
Log Record Stalls/sec는 로그 버퍼가 꽉 찼기 때문에 로그 버퍼에 초당 추가할 수 없는 로그 레코드 수입니다. 대부분의 경우 이 수가 0이 아니면 로그 버퍼 크기로 인해 지체가 생길 수 있습니다.

ADSI(Active Directory Service Interfaces) 편집 스냅인, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 도구를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. ADSI 편집을 시작합니다.

  2. Configuration 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=<ExchangeOrganizationName>을 차례로 확장합니다.

  3. CN=Administrative Groups, CN=<AdministrativeGroupName>, CN=Servers를 차례로 확장합니다.

  4. CN=<ServerName> 및 CN=InformationStore를 확장하고 CN=<StorageGroupName>을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. Attribute Editor에서 msExchESEParamLogBuffers 특성을 클릭한 다음 Edit를 클릭합니다.

  6. Edit Attribute 상자에서 값을 512(Exchange 2000 Server인 경우) 또는 9000(Exchange Server 2003인 경우)으로 설정합니다.

  7. 적용을 클릭한 다음 확인을 클릭합니다.

  8. ADSI 편집을 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

ESE 로그 버퍼에 대한 자세한 내용은 Microsoft 기술 자료 문서 328466, "XADM: ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding"(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466)을 참조하십시오.

LDP 도구 사용에 대한 자세한 내용은 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


기본 공용 폴더 저장소가 원격입니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-03

Microsoft® Exchange Server Analyzer Tool은 각 사서함 저장소의 msExchHomePublicMDB 특성이 로컬 Exchange Server를 포함하는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 로컬 Exchange Server에 사서함 저장소의 공용 폴더 저장소가 있습니다. msExchHomePublicMDB 특성에 로컬 Exchange Server가 없는 경우 사서함 저장소는 원격 기본 공용 폴더 저장소에 있습니다. Exchange Server Analyzer에서 사서함 저장소에 원격 기본 공용 폴더 저장소가 있음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다.

기본 공용 폴더 저장소를 변경하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, <your Exchange server>, <storage group>을 차례로 확장하고 사서함 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  2. 일반 탭의 기본 공용 저장소에서 찾아보기를 클릭하여 공용 폴더 저장소를 선택합니다.

사서함 저장소와 공용 폴더 저장소에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "사서함 저장소 및 공용 폴더 저장소 관리"를 참조하십시오.


사서함 저장소의 삭제 스레드 기간이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 삭제된 항목을 제거하는 간격을 기본 설정과 다르게 수정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Deletion Thread Period

Deletion Thread Period 키가 존재하고 구성되어 있으면 Exchange Server Analyzer에서 기본 구성이 아니라는 메시지를 표시합니다.

메시지를 삭제하면 Exchange는 메시지에 삭제 표시를 합니다. 또한 메시지가 Exchange 저장소에서 영구적으로 삭제될 때까지 메시지를 숨김으로 표시합니다. Exchange 저장소가 메시지 ID에서 참조하는 특정 폴더의 메시지 삭제 요청을 받으면 Exchange 저장소는 메시지를 일시 삭제해야 하는지 영구 삭제해야 하는지 결정합니다. 삭제된 해당 항목 보존 기간이 경과되면 메시지가 영구적으로 삭제됩니다. 일시 삭제를 논리적 삭제라고도 하고 영구 삭제를 물리적 삭제라고도 합니다.

기본적으로 dumpster 정리 프로세스는 24시간마다 실행되며 항목을 영구 삭제할 때가 되었는지 확인합니다. dumpster 정리 프로세스는 Exchange 저장소 온라인 유지 관리 프로세스의 일부입니다. 삭제된 항목 보존 기간이 경과되면 항목이 영구 삭제됩니다. Deletion Thread Period 레지스트리 값은 기본 24시간 간격을 무시하고 dumpster 정리 프로세스에 대한 사용자 지정 간격을 지정하는 데 사용됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>를 탐색합니다.

  3. Deletion Thread Period 키를 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

삭제된 항목 보존 및 복구에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 249680, "XADM: Understanding Deleted Item Retention and Message Deletion Process"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=249680)

  • 287544, "XADM: Public Information Store Grows Significantly When the Deleted Item Retention Functionality Is Enabled"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=287544)

  • 822938, "HOW TO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938)


공용 폴더 저장소의 Deletion Thread Period가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 삭제된 항목을 제거하는 간격을 기본 설정과 다르게 수정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Deletion Thread Period

Exchange Server Analyzer는 Deletion Thread Period이 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

메시지를 삭제하면 Exchange는 삭제할 메시지를 표시합니다. Exchange는 해당 메시지를 Exchange 저장소에서 영구적으로 삭제할 때까지 숨겨진 메시지로도 표시합니다. 정보 저장소가 메시지 ID에 의해 참조되는 특정 폴더의 메시지 삭제 요청을 받으면 Exchange 저장소는 메시지를 일시 삭제할지 아니면 영구 삭제할지 결정합니다. 일시 삭제는 논리 삭제라고도 하고 영구 삭제는 실제 삭제라고도 합니다. 삭제 항목 보존 기간이 경과한 후에 해당 메시지는 영구적으로 삭제됩니다.

기본적으로 휴지통 정리 프로세스는 24시간마다 실행되어 항목을 영구 삭제할 시간인지 결정합니다. 휴지통 정리 프로세스는 Exchange 저장소 온라인 유지 관리 프로세스의 일부입니다. 삭제 항목 보존 기간이 경과되면 항목은 영구 삭제됩니다. Deletion Thread Period 레지스트리 값은 기본 24시간 간격을 대체할 휴지통 정리 프로세스 간격을 사용자 지정하는 데 사용됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>를 탐색합니다.

  3. Deletion Thread Period 키를 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

삭제 항목 보존 및 복구에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 249680, "XADM: Understanding Deleted Item Retention and Message Deletion Process"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249680)

  • 287544, "XADM: Public Information Store Grows Significantly When the Deleted Item Retention Functionality Is Enabled"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=287544)

  • 319098, "HOW TO: Use System Policies to Configure Public Folder Storage Limits in Exchange?2000 Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319098)


디스크 지체 감지됨
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-11-14

Microsoft® Exchange Server Analyzer Tool은 사용 중인 디스크 시스템이 현재 예상되는 가능한 최대 처리량의 20% 내에서 실행 중임을 확인했습니다. 이것은 다음 계산 방법 중 하나를 사용하여 확인되었습니다.

  • 디스크 대기 시간을 측정합니다. 대기 시간을 표시하는 성능 카운터는 LogicalDisk\Avg Disk sec/Read 및 LogicalDisk\Avg Disk sec/Write입니다.

  • Perfmon(성능 모니터)가 기록한 대로 현재 디스크 구성의 최대 IOPS(초당 디스크 I/O) 및 스핀들 수를 현재 IOPS 값과 비교합니다.

적절한 대기 시간

Exchange Server는 액세스하는 데이터의 유형에 따라 허용되는 지연 시간이 다릅니다. 따라서 허용되는 최대 평균 대기 시간 임계값은 디스크에 있는 리소스의 유형을 기준으로 제공됩니다. 다음 목록에 표시된 경우를 제외한 모든 경우에서 읽기 또는 쓰기 대기 시간 값으로 사용될 수 있는 최대 값은 50밀리초입니다.

  • Transaction log drives 트랜잭션 로그를 호스팅하는 드라이브의 평균 쓰기 대기 시간은 10밀리초 미만이어야 합니다. 쓰기 대기 시간의 최대값은 50밀리초 미만이어야 합니다. 트랜잭션 로그에 쓰기는 동기적입니다. 따라서 Store.exe 프로세스의 스레드가 다른 작업을 수행할 수 있으려면 해당 스레드에서 쓰기가 완료될 때까지 기다려야 합니다. 서버 성능을 위해서는 트랜잭션 로그에 쓰기 대기 시간이 짧아야 합니다. 트랜잭션 로그 드라이브의 평균 읽기 대기 시간은 20밀리초 미만이어야 합니다. 읽기 대기 시간의 최대값은 50밀리초 미만이어야 합니다. Database Log Threads Waiting 및 초당 Database Log Record Stalls는 10보다 작아야 합니다.

    일반적으로 Exchange Server는 트랜잭션 로그에서 읽지 않습니다. 따라서 드라이브의 읽기 대기 시간은 중요하지 않습니다. 그러나 트랜잭션 로그 쓰기 대기 시간은 Exchange 성능에 매우 중요하기 때문에 대용량 서버에서는 어떠한 목적으로도 트랜잭션 로그를 호스팅하는 드라이브를 사용하지 않는 것이 좋습니다. 이러한 경우 LogicalDisk\Disk Reads/sec에서 측정한 읽기 비율이 LogicalDisk\Disk Writes/sec에서 측정한 쓰기 비율보다 매우 작아야 합니다. Exchange Server Analyzer는 트랜잭션 로그 드라이브에서 읽기 대 쓰기의 비율이 0.10(쓰기 10개당 읽기 1개)을 넘는지 확인합니다.

    쓰기당 읽기 비율이 0.10보다 클 경우 트랜잭션 로그 드라이브에서 읽고 있는 응용 프로그램을 찾아 이러한 작업이 발생되지 않도록 해야 합니다.

  • Database drives Exchange 데이터베이스 파일(*edb 및 *stm 파일)을 포함하는 드라이브의 적절한 대기 시간은 아래와 같습니다(높은 값은 디스크 지체를 나타냄).

    • Logical Disk\Avg의 최대 값 데이터베이스 드라이브의 Disk sec/Read는 50밀리초(0.050초) 미만이어야 합니다.

    • Logical Disk\Avg의 평균 값 데이터베이스 드라이브의 Disk sec/Read는 20ms(0.020초) 미만이어야 합니다.

  • TEMP and TMP drives TEMP 및 TMP 디렉터리를 포함하는 드라이브의 대기 시간은 10밀리초 미만의 읽기 및 쓰기 대기 시간을 가져야 합니다. 최대 읽기 또는 쓰기 대기 시간은 50밀리초 미만이어야 합니다.

  • Page and system drive 페이지 파일 및 Windows 시스템 파일을 포함하는 드라이브의 대기 시간은 10밀리초 미만의 읽기 및 쓰기 대기 시간을 가져야 합니다.

  • SMTP drive SMTP 서버 파일을 포함하는 드라이브의 대기 시간은 10밀리초 미만의 읽기 및 쓰기 대기 시간을 가져야 합니다.

대기 시간의 원인

디스크 하위 시스템이 지원할 수 있는 비율보다 높은 비율로 액세스되는 디스크가 가장 일반적인 디스크 대기 시간의 원인 중 하나입니다. 이러한 경우에는 해당 디스크가 지체되었다고 합니다. 이것은 또한 디스크 하위 시스템이 처리 용량에 도달하거나 이를 초과했음을 의미합니다.

디스크 IOPS의 비율(LogicalDisk\Disk Transfers/sec)이 예상 용량에 근접하거나 이를 초과할 경우에는 해당 디스크를 "처리 용량 초과" 또는 "용량 초과"로 간주합니다. 이러한 경우 서버 성능을 향상시키려면 디스크 하위 시스템의 로드를 줄이거나(사용자를 다른 서버로 이동) 더 많은 스핀들 또는 보다 빠른 스핀들을 추가하여 드라이브의 용량을 늘려야 합니다.

예상대로 하드웨어가 수행되지 않을 경우에는 I/O 비율이 예상 용량보다 상당히 작을 경우라도 대기 시간이 발생할 수 있습니다.

디스크 대기 시간 줄이기

서버에서 수행되는 작업의 일부를 줄여 디스크 하위 시스템의 로드를 줄일 수 있습니다. 특히 디스크 로드의 원인이 되는 선택적 응용 프로그램을 제거해야 합니다. Store.exe 프로세스는 데이터베이스와 트랜잭션 로그 드라이브에 액세스할 수 있는 유일한 응용 프로그램입니다.

현재 디스크 시스템의 구성에 따라 여러 가지 작업을 수행하여 이 문제의 영향을 줄일 수 있습니다.

디스크 대기 시간을 줄이려면 다음을 수행하십시오.

  • 데이터베이스 또는 트랜잭션 로그 드라이브에서 지체가 발생한 경우에는 최대 용량에 근접하지 않은 드라이브에서 호스팅되는 저장소 그룹이나 데이터베이스로 사용자를 이동하여 드라이브의 로드를 줄일 수 있습니다. 모든 데이터베이스 또는 트랜잭션 로그 드라이브가 용량에 근접한 경우 사용자를 다른 서버로 이동해야 합니다. 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.

  • 높은 I/O 비율은 부담이 큰 MAPI 작업 때문이므로 경우에 따라 이 기간이 짧을 수 있습니다. 그러한 경우에는 논리 디스크 성능 카운터와 ExMon(Exchange Server User Monitor)을 사용하여 높은 I/O 비율의 원인이 되는 사용자 또는 작업을 식별할 수 있습니다. 사용자를 분리할 수 있으면 로드를 증가시키는 클라이언트 응용 프로그램도 확인할 수 있습니다. Microsoft 다운로드 센터(http://go.microsoft.com/fwlink/?linkid=54983)에서 ExMon을 다운로드할 수 있습니다.

  • RAID-5 디스크 배열을 실행하는 경우 RAID-10 디스크 배열로 변경하여 디스크 하위 시스템에 대해 사용 가능하며 지원되는 IOPS를 향상시킬 수 있습니다.

  • 지원되는 사용 가능한 IOPS를 향상시키려면 디스크 시스템에 다른 디스크를 추가하십시오.

추가 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 저장소 아키텍처를 설계하는 최상의 방법에 대한 자세한 내용은 여러 아키텍처에 공통적인 유용한 정보(http://go.microsoft.com/fwlink/?LinkId=72988)를 참조하십시오.

  • 사용자 사서함을 이동하여 서버 로드를 줄이는 방법은 다른 서버로 사용자 사서함 이동을 참조하십시오.

  • 디스크 크기 조정, 대기 시간, I/O 비율에 대한 자세한 내용은 Microsoft Exchange 팀 블로그 웹 사이트에서 다음 블로그를 참조하십시오.

    • "A few basic concepts in disk sizing"(http://go.microsoft.com/fwlink/?linkid=39538)

    • "Some more thoughts on disk IO and calculations…." (http://go.microsoft.com/fwlink/?linkid=23456)

    • 디스크 I/O 요구 사항을 계산하는 방법(http://go.microsoft.com/fwlink/?linkid=69747)


트랜잭션 로그 파일을 포함하고 있는 디스크에서 디스크 지체 발견
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 로그 파일이 저장된 디스크 시스템의 과도한 작업으로 성능 병목 현상이 발생했음을 확인했습니다. 이것은 다음 성능 카운터 중 하나 이상을 검사하여 확인되었습니다.

  • 평균 Database\Log Record Stalls/sec가 10 이상인 경우

  • 최대 Database\Log Record Stalls/sec가 100 이상인 경우

  • 평균 Database\Log Threads Waiting이 10 이상인 경우

  • 최대 Database\Log Threads Waiting이 20 이상인 경우

이러한 임계값 중 하나라도 만족할 경우 로그 드라이브에서 디스크 병목 현상이 발생했다는 오류가 표시됩니다. 로그 파일은 쓰기 대기 시간이 짧아야 합니다. 로그 파일에 쓸 때 백업이 이루어지거나 중지되면 서버 성능 문제가 발생할 수 있습니다. 로그 지연은 로그 버퍼 설정 msExchESEParamLogBuffers가 낮거나 서버에 연결된 사용자가 너무 많을 경우 발생할 수 있습니다.

로그 디스크 대기 시간을 줄이려면 다음을 수행합니다.

  • ESE 버퍼 매개 변수 msExchESEParamLogBuffers를 9,000으로 높일 수 있습니다. 9,000보다 큰 값은 트랜잭션 로그 파일을 손상시킬 수 있으므로 사용하지 마십시오. 자세한 내용은 기본 ESE 로그 버퍼가 변경되었습니다.를 참조하십시오.

  • 데이터베이스 또는 트랜잭션 로그 드라이브에서 병목 현상이 발생한 경우에는 최대 용량에 근접하지 않은 드라이브에서 호스팅되는 데이터베이스나 저장소 그룹으로 사용자를 이동하여 드라이브의 로드를 줄일 수 있습니다. 모든 데이터베이스 또는 트랜잭션 로그 드라이브가 용량에 근접한 경우 사용자를 다른 서버로 이동해야 합니다. 자세한 정보는 다른 서버로 사용자 사서함 이동을 참조하십시오.


EnableChangeNotification이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 값을 읽어 ExIFS(Exchange Installable File System)에 대한 파일 변경 알림이 설정되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\ EnableChangeNotification

EnableChangeNotification 키가 존재하고 0보다 큰 값으로 구성되어 있으면 Exchange Server Analyzer에서 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 ExIFS에 대한 파일 변경 알림을 사용할 수 없습니다. ExIFS가 파일 또는 디렉터리에 대한 변경 알림을 보내면 파일 또는 디렉터리의 캐시된 버전을 지우지 않습니다. 따라서 Exchange Server 또는 Microsoft SharePoint® Portal Server와 같은 응용 프로그램이 변경 알림을 받고 파일이나 디렉터리를 다시 로드하면 응용 프로그램이 캐시된 버전을 가져오고 새로 수정된 파일이나 디렉터리를 가져오지 않습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\EXIFS\Parameters를 탐색합니다.

  3. EnableChangeNotification 키를 삭제합니다.

  4. 레지스트리 편집기를 닫고 Exchange Server를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Installable File System에 대한 자세한 내용은 다음을 참조하십시오.

  • Exchange 2000 Server Resource Kit의 Chapter 26 "Exchange 2000 Architecture"(http://go.microsoft.com/fwlink/?LinkId=51224)

  • Exchange Server 2003 기술 참조 가이드(http://go.microsoft.com/fwlink/?linkid=47891)


로그 디렉터리 액세스 오류
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 이 저장소 그룹의 트랜잭션 로그용으로 Exchange 서버에 정의된 경로에 액세스할 수 없음을 확인했습니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 경로가 서버에 실제로 존재하는지 확인합니다.

  • 트랜잭션 로그 경로에 저장되어 있는 파일을 읽는 데 필요한 권한이 있는지 확인합니다.


스트리밍 데이터베이스 파일 액세스 오류
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에서 Exchange 스트리밍 데이터베이스(.stm) 파일에 액세스할 수 없음을 확인했습니다.

Exchange 2000 Server와 Exchange Server 2003의 각 데이터베이스는 .edb Exchange 데이터베이스 파일과 .stm 스트리밍 데이터베이스 파일 두 가지로 구성되어 있습니다. 이 두 파일을 함께 액세스 및 처리할 수 있어야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  • .stm 파일의 경로를 찾습니다. Exchange System Manager에서 이 경로는 각 데이터베이스 개체의 데이터베이스 속성 페이지에 정의되어 있습니다.

  • 이 데이터베이스에 대한 .stm 파일이 존재하는지 확인합니다.

  • .stm 파일이 위치한 폴더에 액세스할 수 있는 권한이 있는지 확인합니다.

  • 다른 프로세스에서 파일을 독점적으로 잠그지 않았는지 확인합니다. 이를 확인하는 한 가지 방법은 파일의 이름을 바꾸어보는 것입니다. 파일 이름을 바꿀 수 있으면 파일을 독점적으로 잠그지 않은 것입니다. 반드시 파일 이름을 원래 이름으로 다시 바꾸십시오.


로그 파일을 검사하는 동안 오류가 발생했습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에서는 트랜잭션 로그 파일을 읽을 수 없습니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 트랜잭션 로그 파일 폴더에 액세스하는 데 필요한 사용 권한이 있는지 확인합니다.

  • 다른 프로세스를 통해 파일을 독점적으로 잠그지 않았는지 확인합니다. 이 잠금 여부를 확인하려면 파일 이름을 바꿔 봅니다. 파일 이름을 바꿀 수 있으면 파일이 독점적으로 잠기지 않았음을 나타냅니다. 파일 이름을 원래 이름으로 바꿀 수 있도록 기억하십시오.


이 저장소 그룹에 대한 ESE 로그 버퍼가 최대로 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 저장소 그룹의 msExchESEParamLogBuffers 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchESEParamLogBuffers 특성 값이 9,000인 경우 기본 구성이 아니라는 메시지를 표시합니다.

확장 가능한 저장소 엔진(ESE)은 트랜잭션 로그에 정보를 쓰기 전에 메모리에서 유지하기 위해 일련의 로그 버퍼를 사용합니다. 이러한 버퍼 사용을 통해 트랜잭션 로깅 성능이 향상됩니다. 대용량 서버의 경우 기본값 84는 너무 낮습니다. 이로 인해 트랜잭션 로그 드라이브에 과도한 디스크 I/O 작업이 발생하기 때문에 서버에 부하가 발생하거나 사용자가 대용량 메시지를 보낼 경우 심각한 성능 저하를 초래할 수 있습니다. ESE 로그 버퍼 수를 늘리면 가상 메모리 사용량도 늘지만 성능이 향상됩니다.

이 값을 올바르게 설정하려면 다음 정보를 사용합니다.

  • Exchange 2000 Server, Exchange 2000 Server 서비스 팩 1(SP1) 또는 Exchange 2000 Server 서비스 팩 2(SP2)의 경우 이 값을 9000으로 설정합니다.

  • Exchange 2000 Server 서비스 팩 3(SP3)의 경우 이 값을 512로 설정합니다.

  • Exchange Server 2003의 경우 기본값으로 500이 사용되며 msExchESEParamLogBuffers 특성의 값을 9000으로 변경해야 합니다.

참고:
이전에 로그 버퍼를 9000으로 조정한 경우에는 Exchange 2000 Server SP3을 적용한 후에 이 설정을 수동으로 낮춰야 합니다. 이 설정은 Exchange 2000 Server SP3을 설치할 때 자동으로 변경되지 않습니다.

버퍼가 너무 작아서 로그가 정지되면 이 값을 최대 9000까지 높일 수 있습니다. Database\Log Record Stalls/sec 성능 카운터를 모니터링하면 로그 정지가 발생하는지 확인할 수 있습니다. 트랜잭션 로그 파일을 손상할 수 있으므로 9000보다 큰 값을 사용하지 마십시오.

참고:
Log Record Stalls/sec는 로그 버퍼가 꽉 찼기 때문에 로그 버퍼에 초당 추가할 수 없는 로그 레코드 수입니다. 대부분의 경우 이 수가 0이 아니면 로그 버퍼 크기로 인해 지체가 생길 수 있습니다.

ADSI(Active Directory Service Interfaces) 편집 스냅인, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 도구를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. ADSI 편집을 시작합니다.

  2. 구성 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=<ExchangeOrganizationName>을 차례로 확장합니다.

  3. CN=Administrative Groups, CN=<AdministrativeGroupName>, CN=Servers를 차례로 확장합니다.

  4. CN=<ServerName> 및 CN=InformationStore를 확장하고 CN=<StorageGroupName>을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. Attribute Editor에서 msExchESEParamLogBuffers 특성을 클릭한 다음 Edit를 클릭합니다.

  6. Edit Attribute 상자에서 값을 512(Exchange 2000 Server) 또는 9000(Exchange Server 2003)으로 설정합니다.

  7. 적용을 클릭한 다음 확인을 클릭합니다.

  8. ADSI 편집을 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

ESE 로그 버퍼 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 328466, "XADM: ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding"(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466)을 참조하십시오.


이 저장소 그룹에 ESE 로그 버퍼가 너무 낮게 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 InformationStore 컨테이너에서 각 저장소 그룹 개체(msExchStorageGroup 클래스)의 msExchESEParamLogBuffers 값을 확인합니다. Exchange Server Analyzer는 이 특성 값이 500보다 작으면 경고를 표시합니다.

확장 가능한 저장소 엔진(ESE)은 트랜잭션 로그에 정보를 쓰기 전에 메모리에서 유지하기 위해 일련의 로그 버퍼를 사용합니다. 이러한 버퍼를 사용하면 트랜잭션 로깅 성능이 향상됩니다. 대용량 서버의 경우 기본값 84는 너무 낮습니다. 이로 인해 트랜잭션 로그 드라이브에 과도한 디스크 I/O 작업이 발생하기 때문에 서버에 부하가 발생하거나 사용자가 대용량 메시지를 보낼 경우 심각한 성능 저하를 초래할 수 있습니다. ESE 로그 버퍼 수를 늘리면 가상 메모리 사용량도 늘지만 성능이 향상됩니다.

이 값을 올바르게 설정하려면 다음 정보를 사용합니다.

  • Exchange 2000 Server, Exchange 2000 Server 서비스 팩 1(SP1) 또는 Exchange 2000 Server 서비스 팩 2(SP2)의 경우 이 값을 9000으로 설정합니다.

  • Exchange 2000 Server SP3(서비스 팩 3)의 경우 이 값을 512로 설정합니다.

  • Exchange Server 2003의 경우 기본값 500을 사용하고 msExchESEParamLogBuffers 특성 값을 9000으로 변경해야 합니다.

참고:
이전에 로그 버퍼를 9000으로 조정한 경우에는 Exchange 2000 Server SP3을 적용한 후에 이 설정을 수동으로 낮춰야 합니다. 이 설정은 Exchange 2000 Server SP3을 설치할 때 자동으로 변경되지 않습니다.

버퍼가 너무 작아서 로그가 정지되면 이 값을 최대 9000까지 높일 수 있습니다. Database\Log Record Stalls/sec 성능 카운터를 모니터링하면 로그 정지가 발생하는지 확인할 수 있습니다. 트랜잭션 로그 파일을 손상할 수 있으므로 9000보다 큰 값을 사용하지 마십시오.

참고:
Log Record Stalls/sec는 로그 버퍼가 꽉 찼기 때문에 로그 버퍼에 초당 추가할 수 없는 로그 레코드 수입니다. 대부분의 경우 이 수가 0이 아니면 로그 버퍼 크기로 인해 지체가 생길 수 있습니다.

ADSI(Active Directory Service Interfaces) 편집 스냅인, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 도구를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. ADSI 편집을 시작합니다.

  2. Configuration 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=<ExchangeOrganizationName>을 차례로 확장합니다.

  3. CN=Administrative Groups, CN=<AdministrativeGroupName>, CN=Servers를 차례로 확장합니다.

  4. CN=<ServerName> 및 CN=InformationStore를 확장하고 CN=<StorageGroupName>을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. Attribute Editor에서 msExchESEParamLogBuffers 특성을 클릭한 다음 Edit를 클릭합니다.

  6. Edit Attribute 상자에서 값을 512(Exchange 2000 Server인 경우) 또는 9000(Exchange Server 2003인 경우)으로 설정합니다.

  7. Apply를 클릭한 다음 OK를 클릭합니다.

  8. ADSI 편집을 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

ESE 로그 버퍼에 대한 자세한 내용은 Microsoft 기술 자료 문서 328466, "XADM: ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding"(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466)을 참조하십시오.

LDP 도구 사용에 대한 자세한 내용은 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ESE 로그 버퍼 설정에 대한 자세한 내용은 기술 자료 문서 328466, "XADM: ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding"(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466)을 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


ESE 로그 버퍼가 이 저장소 그룹에서 너무 높게 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 저장소 그룹의 msExchESEParamLogBuffers 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 저장소 그룹에 대한 msExchESEParamLogBuffers 특성 값이 9,000보다 크면 오류를 표시합니다.

확장 가능한 저장소 엔진(ESE)은 트랜잭션 로그에 정보를 쓰기 전에 메모리에서 유지하기 위해 일련의 로그 버퍼를 사용합니다. 이러한 버퍼 사용을 통해 트랜잭션 로깅 성능이 향상됩니다. 대용량 서버의 경우 기본값 84는 너무 낮습니다. 이로 인해 트랜잭션 로그 드라이브에 과도한 디스크 I/O 작업이 발생하기 때문에 서버에 부하가 발생하거나 사용자가 대용량 메시지를 보낼 경우 심각한 성능 저하를 초래할 수 있습니다. ESE 로그 버퍼 수를 늘리면 가상 메모리 사용량도 늘지만 성능이 향상됩니다.

이 값을 올바르게 설정하려면 다음 정보를 사용합니다.

  • Exchange 2000 Server, Exchange 2000 Server 서비스 팩 1(SP1) 또는 Exchange 2000 Server 서비스 팩 2(SP2)의 경우 이 값을 9000으로 설정합니다.

  • Exchange 2000 Server 서비스 팩(SP3)의 경우 이 값을 512로 설정합니다.

  • Exchange Server 2003의 경우 기본값으로 500이 사용되며 msExchESEParamLogBuffers 특성의 값을 9000으로 변경해야 합니다.

참고:
이전에 로그 버퍼를 9000으로 조정한 경우에는 Exchange 2000 Server 서비스 팩 3을 적용한 후에 이 설정을 수동으로 낮춰야 합니다. 이 설정은 Exchange 2000 Server 서비스 팩 3을 설치할 때 자동으로 변경되지 않습니다.

버퍼가 너무 작아서 로그가 정지되면 이 값을 최대 9000까지 높일 수 있습니다. Database\Log Record Stalls/sec성능 카운터를 모니터링하면 로그 정지가 발생하는지 확인할 수 있습니다. 트랜잭션 로그 파일을 손상할 수 있으므로 9000보다 큰 값을 사용하지 마십시오.

참고:
Log Record Stalls/sec는 로그 버퍼가 꽉 찼기 때문에 로그 버퍼에 초당 추가할 수 없는 로그 레코드 수입니다. 대부분의 경우 이 수가 0이 아니면 로그 버퍼 크기로 인해 지체가 생길 수 있습니다.

ADSI(Active Directory Service Interfaces) 편집 스냅인, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 도구를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집을 시작합니다.

  2. Configuration 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=<ExchangeOrganizationName>을 차례로 확장합니다.

  3. CN=Administrative Groups, CN=<AdministrativeGroupName>, CN=Servers를 차례로 확장합니다.

  4. CN=<ServerName> 및 CN=InformationStore를 확장하고 CN=<StorageGroupName>을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. Attribute Editor에서 msExchESEParamLogBuffers 특성을 클릭한 다음 Edit를 클릭합니다.

  6. Edit Attribute 상자에서 값을 512(Exchange 2000 Server) 또는 9000(Exchange Server 2003)으로 설정합니다.

  7. Apply를 클릭한 다음 OK를 클릭합니다.

  8. ADSI 편집을 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

LDP 도구를 사용하여 Active Directory를 수정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ESE 로그 버퍼 설정에 대한 자세한 내용은 기술 자료 문서 328466, "XADM: ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding"(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466)을 참조하십시오.


ESE 로그 파일 크기가 수동으로 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 InformationStore 컨테이너의 msExchESEParamLogFileSize 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchESEParamLogFileSize 특성 값이 5120이 아니면 오류를 표시합니다.

이 값은 서버의 모든 저장소 그룹에 적용됩니다. 이 오류는 해당 특성 값이 기본값(5120KB 또는 5MB) 이외의 값으로 변경된 경우에 발생합니다. 이 기본값 이외의 다른 값은 지원되지 않으므로 변경해서는 안 됩니다.

ADSI(Active Directory Service Interfaces) 편집 스냅인, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 유틸리티를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 열고 Active Directory에서 해당 Exchange Server 컴퓨터에 대한 InformationStore 개체를 찾습니다.

    msExchESEParamLogFileSize 특성은 다음 위치에 있습니다.

    CN=Configuration, DC=Domain, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName, CN=InformationStore

  2. msExchESEParamLogFileSize 특성을 두 번 클릭하여 값을 5120으로 설정합니다.

  3. Active Directory 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

LDP.exe를 사용하여 Active Directory 특성을 편집하는 데 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


ESE Maximum open tables가 하드 코드되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 개체의 InformationStore 개체 아래에 있는 저장소 그룹 개체 중 하나에 대해 msExchESEParamMaxOpenTables 특성이 존재하는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchESEParamMaxOpenTables 특성이 존재하고 구성되면 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Exchange 2000 Server와 Exchange Server 2003의 경우 이 특성은 존재하지만 어떤 값으로도 설정되어 있지 않습니다. Exchange Server는 현재 액세스하고 있지 않은 폴더에 대한 데이터를 캐시합니다. 이로 인해 가상 메모리가 조각화되는 경우도 있을 수 있습니다. 이를 방지하는 한 가지 방법은 동시에 열 수 있는 최대 데이터베이스 테이블 수를 줄이는 것입니다. 이 특성에 제안되는 실제 값은 설치되어 있는 Exchange Server 버전과 Exchange 서비스 팩에 따라 달라집니다. Exchange 2000 Server 서비스 팩 2의 경우 프로세서가 8개 있는 서버의 기본 설정은 저장소 그룹당 테이블이 85,000개입니다. 프로세서가 8개 있는 서버의 Exchange 2000 Server 서비스 팩 3에서는 이 값이 27,600으로 감소됩니다. 프로세서가 4개 있는 서버의 경우 이 값은 13,800입니다. 가상 메모리 조각화 문제를 줄이기 위해 이 값을 낮출 수 있습니다. 그러나 이 값을 낮추면 너무 많은 테이블이 열리므로 작업이 실패할 수 있는 상황이 발생할 수 있습니다. 동시에 열 수 있는 최대 테이블 수가 감소되어 최대값에 금방 도달하기 때문에 오류가 발생하는 것입니다.

Exchange Server 2003에서는 현재 액세스하고 있지 않은 폴더에 대해 다른 데이터 캐시 방법을 사용합니다. 따라서 최대 열린 테이블 수를 줄여도 가상 메모리 조각화 문제를 줄이는 데 효과적이지도 않으며 필요하지도 않습니다. Exchange Server 2003 서버에서는 이 특성을 설정하지 않아야 합니다.

Microsoft 기술 지원 서비스에서 여기에 값을 입력하도록 지시한 경우가 아니면 ADSI(Active Directory Service Interfaces) 편집 도구를 사용하여 이 특성에 설정한 값을 지웁니다.

주의:
ADSI 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생될 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

msExchESEParamMaxOpenTables 특성 값을 지우려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 엽니다.

  2. Configuration 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=ExchangeOrganizationName을 차례로 확장합니다.

  3. CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers를 차례로 확장합니다.

  4. CN=ExchangeServerName 및 CN=InformationStore를 확장하고 CN=StorageGroupName을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. Select a property to view 상자에서 msExchESEParamMaxOpenTables를 클릭합니다.

  6. Edit Attribute 상자에서 Clear를 클릭하여 값을 <not set>으로 변경합니다.

  7. OK를 클릭한 다음 다시 확인을 클릭합니다.

  8. Active Directory 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

이 특성에 대한 자세한 내용은 Microsoft 기술 자료 문서 325044, "HOWTO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)을 참조하십시오.

LDP 도구 사용에 대한 자세한 내용은 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.


Exchange 데이터베이스 크기가 100GB를 초과합니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 각 Exchange Information Store 데이터베이스의 FileSize 키 값을 확인할 때 CIM_DataFile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 정보 저장소의 .edb 파일과 .stm 파일의 크기를 합한 크기가 100GB를 초과하면 경고가 표시됩니다.

정보 저장소 데이터베이스가 50GB보다 커지지 않게 하는 것이 좋습니다. 적절한 유지 관리 작업을 수행한다면 50GB보다 큰 사서함 저장소를 실행해도 작동상 큰 문제는 없지만 백업 및 복원을 수행할 경우 크기가 큰 사서함 저장소는 일부 SLA(서비스 수준 계약)에 맞지 않을 수 있습니다.

50GB보다 큰 사서함 저장소를 실행할 경우 사용하는 하드웨어가 서비스 수준 계약에 적절한지 확인하여 대형 데이터베이스의 복원이 SLA에 따라 수행되도록 하십시오. 그렇지 않은 경우 여러 사서함 저장소 간에 사서함을 분산하여 단일 사서함 저장소의 크기가 50GB가 넘지 않도록 하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 큰 정보 저장소의 일부 사서함을 이 Exchange Server 컴퓨터 또는 다른 Exchange Server 컴퓨터의 새 정보 저장소로 이동합니다.

  2. 최근에 이 정보 저장소의 사서함을 다른 저장소로 이동했거나 이 정보 저장소에서 사서함을 삭제한 경우 오프라인 조각 모음을 수행하여 파일 크기를 줄일 수 있습니다.

  3. 사서함 또는 메시지 크기 제한을 설정하여 정보 저장소 데이터베이스가 무제한적으로 커지는 것을 방지합니다.

.stm 및 .edb 파일에 대한 자세한 내용은 Microsoft 기술 자료 문서 232323, "Native Content Storage in Microsoft Exchange"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)를 참조하십시오.

Exchange 2003에서의 사서함 이동에 대한 자세한 내용은 기술 자료 문서 821829, "Moving Mailboxes in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)을 참조하십시오.

Exchange 2000 Server의 사서함 이동에 대한 자세한 내용은 기술 자료 문서 328810, "XADM: 서버 간에 사서함 이동"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)을 참조하십시오.

Exchange Server 데이터베이스의 오프라인 조각 모음 수행에 대한 자세한 내용은 기술 자료 문서 328804, "Exchange 데이터베이스 조각 모음 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804)을 참조하십시오.

메시지 크기 제한 설정에 대한 자세한 내용은 기술 자료 문서 322679, "Exchange Server에서 메시지 크기 제한을 설정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)을 참조하십시오.


Exchange 데이터베이스 파일이 압축된 폴더에 기록되고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft Exchange Server Analyzer Tool은 해당 Exchange 정보 저장소 데이터베이스 파일이 포함되어 있는 폴더의 Compressed 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 폴더의 Compressed 값이 True로 설정되어 있는 경우 오류가 표시됩니다.

Exchange 2000 Server 컴퓨터나 Exchange Server 2003 컴퓨터에는 정보 저장소 데이터베이스가 아래의 기본 위치에 기록됩니다.

<drive> :\Program Files\Exchsrvr\mdbdata

Exchange Server 2007 컴퓨터에서 데이터베이스 파일은 다음의 기본 위치에 기록됩니다.

<drive> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

Exchange 데이터 파일은 NTFS로 압축된 볼륨에 저장되지 않습니다. Exchange 데이터 파일을 압축된 볼륨에 저장하면 추가 오버헤드가 발생해 Exchange의 성능에 막대한 영향을 줍니다. 또한 정보 저장소 데이터베이스가 일정 크기(약 4GB)에 도달하면 탑재에 실패하거나 손상될 수 있습니다.

Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

확장 가능한 저장소 엔진(ESE)에 의해 관리되는 파일은 압축된 드라이브에 저장하기 위한 파일이 아닙니다. ESE는 로그 기반 복구를 위한 섹터 독립에 종속되며 파일 압축은 섹터 독립을 무효화합니다. 볼륨 호스팅 ESE 데이터베이스나 미리 쓰기 로깅을 사용하는 데이터베이스의 경우 압축을 설정하지 않아야 합니다.

Exchange 2000 Server 서비스 팩 3 이전 버전에서는 압축된 정보 저장소 데이터베이스를 탑재할 수 있습니다. 그러나 Exchange 2000 Server 정보 저장소 데이터베이스 또는 NTFS 압축을 사용하여 압축된 정보 저장소 로그가 손상될 수 있습니다.

Exchange 2000 Server 서비스 팩 3을 사용할 경우 128MB 이하의 압축된 정보 저장소 데이터베이스 파일은 자동으로 압축이 풀어집니다. 데이터베이스 파일이 128MB를 넘으면 데이터베이스가 탑재되지 않고 응용 프로그램 로그에 오류 메시지가 생성됩니다. Exchange 2000 Server 서비스 팩 3에서는 128MB를 초과하는 압축된 데이터베이스를 탑재할 수 없습니다.

특정 폴더에서 파일 압축을 해제하려면 다음을 수행합니다.

  1. 파일 압축을 해제할 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 내용을 압축하여 디스크 공간 절약 확인란의 선택을 취소한 다음 확인을 클릭합니다.

Exchange 2000 Server나 Exchange Server 2003에서 데이터베이스 파일을 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버, 사용 중인 서버, 저장소 그룹을 차례로 확장하고 사서함 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 데이터베이스 탭의 Exchange 데이터베이스나 Exchange 스트리밍 데이터베이스에서 찾아보기를 클릭하고 압축을 허용하지 않는 폴더의 파일 경로를 입력한 다음 확인을 클릭합니다.

  4. 확인이나 적용을 클릭하여 변경 내용을 적용한 다음 경고 메시지가 나타나면 예를 클릭합니다.

    예를 클릭하면 저장소(데이터베이스)가 분리되고 이동된 다음 다시 탑재됩니다. 이러한 절차가 완료되면 다음과 같은 정보 메시지가 표시됩니다.

    데이터베이스 파일을 이동했습니다.

Exchange Server 2007에서 Exchange 저장소 그룹 데이터베이스 파일의 위치를 옮기려면 다음을 수행합니다.

  1. 핵심 Exchange Server 2007 설명서 "How to Move a Storage Group Path"(http://go.microsoft.com/fwlink/?LinkID=80747)의 안내를 따릅니다.

.stm 및 .edb 파일에 대한 자세한 내용은 Microsoft 기술 자료 문서 232323, "Native Content Storage in Microsoft Exchange"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)를 참조하십시오.


Exchange 데이터베이스 파일이 NTFS가 아닌 파티션에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 Exchange 데이터베이스 파일 경로의 FSName 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 FSName 키 값이 NTFS File System이 아닌 경우 오류를 표시합니다.

NTFS가 아닌 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .chk 파일

  • .eml 파일

이 오류가 발생하면 데이터베이스 파일을 NTFS 드라이브의 폴더로 이동해야 합니다. 또는 데이터베이스 파일이 FAT 드라이브로 포맷된 드라이브에 저장되어 있을 경우에는 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다.

Exchange 2000 Server나 Exchange Server 2003에서 Exchange 데이터베이스 파일을 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버, 사용 중인 서버, 저장소 그룹을 차례로 확장하고 사서함 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 데이터베이스 탭의 Exchange 데이터베이스 또는 Exchange 스트리밍 데이터베이스에서 찾아보기를 클릭하고 NTFS 볼륨에 있는 폴더의 경로 위치를 입력한 후 확인을 클릭합니다.

  4. 변경 내용을 적용하려면 확인 또는 적용을 클릭하고 변경 내용을 적용하지 않으려면 취소를 클릭합니다.

  5. 확인 또는 적용을 클릭한 경우 다음과 같은 경고 메시지가 표시됩니다.

    참고 다음 작업을 수행하려고 합니다.

    • Exchange 데이터베이스 위치 변경

    • Exchange 스트리밍 데이터베이스 위치 변경

    요청된 작업을 수행하려면 해당 저장소를 분리하여 다른 사용자가 액세스할 수 없도록 해야 합니다.

    계속하시겠습니까?

    참고:
    경고 메시지에는 사용자가 선택한 작업만 표시됩니다. 경고 메시지에는 예 및 아니오 단추가 포함되어 있습니다.

  6. 계속하려면 예를 클릭하고 그렇지 않으면 아니요를 클릭합니다.

  7. 예를 클릭하면 저장소(데이터베이스)가 분리되고 이동된 후 다시 탑재됩니다. 이러한 절차가 완료되면 다음과 같은 정보 메시지가 표시됩니다.

    데이터베이스 파일을 이동했습니다.

Exchange Server 2007에서 Exchange 저장소 그룹 데이터베이스 파일의 위치를 옮기려면 다음을 수행합니다.

  1. 핵심 Exchange Server 2007 설명서 "How to Move a Storage Group Path"(http://go.microsoft.com/fwlink/?LinkID=80747)의 안내를 따릅니다.

파일이 저장되어 있는 드라이브가 FAT 드라이브로 포맷된 경우에는 앞에서 설명한 절차 대신 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다. Convert.exe 명령줄 도구를 사용하여 FAT 파티션에서 NTFS 파티션으로 변환하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 214579, "Convert.exe를 사용하여 파티션을 NTFS 파일 시스템으로 변환하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)을 참조하십시오.


SMTP 데이터베이스 파일이 암호화된 폴더에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Information Store 데이터베이스 파일이 들어 있는 폴더의 Encrypted 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Encrypted의 값이 True로 설정되어 있는 경우 오류를 표시합니다.

Exchange 2000 Server 또는 Exchange Server 2003 컴퓨터에서 데이터베이스 파일은 다음의 기본 위치에 기록됩니다.

<drive> :\Program Files\Exchsrvr\mdbdata

Exchange Server 2007 컴퓨터에서 데이터베이스 파일은 다음의 기본 위치에 기록됩니다.

<drive> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

EFS(암호화 파일 시스템) 암호화 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일을 암호화된 볼륨에 저장하면 추가 오버헤드가 발생하여 Exchange의 성능에 막대한 영향을 줍니다. Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

Exchange 데이터 파일을 보호하려면 Exchange 컴퓨터에 대한 무단 액세스를 방지하고 S/MIME 메시지 형식을 사용하여 메시지 데이터를 암호화하는 것이 좋습니다.

이 오류를 해결하려면 데이터베이스 파일이 기록되는 폴더의 파일 암호화를 해제하거나 데이터베이스 파일을 암호화가 설정되지 않은 폴더로 이동해야 합니다.

지정한 폴더의 파일 암호화를 해제하려면 다음을 수행합니다.

  1. 파일 암호화를 해제할 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 데이터 보호를 위해 내용을 암호화 확인란의 선택을 해제한 다음 확인을 클릭합니다.

Exchange 2000 Server나 Exchange Server 2003에서 데이터베이스 파일을 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버, 사용 중인 서버, 저장소 그룹을 차례로 확장하고 사서함 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 데이터베이스 탭의 Exchange 데이터베이스 또는 Exchange 스트리밍 데이터베이스에서 찾아보기를 클릭하고 암호화가 설정되지 않은 폴더의 경로 위치를 입력한 후 확인을 클릭합니다.

  4. 확인 또는 적용을 클릭하여 변경 내용을 적용한 후 경고 메시지가 표시되면 예를 클릭합니다.

  5. 예를 클릭하면 저장소(데이터베이스)가 분리되고 이동된 후 다시 탑재됩니다. 이러한 절차가 완료되면 다음과 같은 정보 메시지가 표시됩니다.

    데이터베이스 파일을 이동했습니다.

Exchange Server 2007에서 Exchange 저장소 그룹 데이터베이스 파일의 위치를 옮기려면 다음을 수행합니다.

  1. 핵심 Exchange Server 2007 설명서 "How to Move a Storage Group Path"(http://go.microsoft.com/fwlink/?LinkId=80747)의 안내를 따릅니다.

데이터베이스 파일 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 821915, "Exchange 2003 Server의 Exchange 데이터베이스와 로그를 이동하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915)을 참조하십시오.

Exchange Server 데이터 파일과 EFS에 대한 자세한 내용은 Microsoft 기술 자료 문서 834638, "Information about the storage of data files on an encrypted volume in Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)를 참조하십시오.

Exchange Server 2003의 메시지 보안 유지 방법에 대한 자세한 내용은 Exchange Server 2003 메시지 보안 가이드"(http://go.microsoft.com/fwlink/?linkid=47574)를 참조하십시오.


Exchange 데이터베이스가 부적절한 종료 상태에 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-10-30

Microsoft® Exchange Server Analyzer Tool은 데이터베이스 중 하나가 제대로 종료되지 않았음을 확인했습니다. 따라서 데이터베이스 파일이 계속 로그 파일에 연결되어 있습니다.

부적절한 종료 상태가 데이터베이스가 손상되었음을 나타내는 것은 아닙니다. 부적절한 종료 상태는 데이터베이스 파일이 로그 스트림에서 제대로 분리되지 않았음을 나타냅니다. 따라서 데이터베이스를 다시 시작하려면 먼저 데이터베이스 파일을 복구해야 합니다.

다음 번에 데이터베이스를 탑재하면 복구가 자동으로 실행됩니다. 자동 복구에 오류가 발생하면 Microsoft Exchange Server Disaster Recovery Analyzer Tool을 사용하여 오류 원인을 분석할 수 있습니다. 분석 후에 Exchange Server Disaster Recovery Analyzer는 데이터베이스 파일을 수동으로 복구하는 권장 사항을 제공합니다.

이 오류를 해결하려면 다음을 수행하십시오.

  • 데이터베이스에 대해 필수 트랜잭션 로그 파일을 재생하여 데이터베이스를 완전하게 종료된 상태로 만듭니다. 로그 파일을 재생하려면 데이터베이스를 탑재합니다. 이 작업에 오류가 발생하면 Exchange Server Disaster Recovery Analyzer Tool을 사용하여 오류 원인을 격리할 수 있습니다.

Exchange Server Disaster Recovery Analyzer Tool에 대한 자세한 내용은 Microsoft 기술 자료 문서 922247, "Exchange Server 2003의 Exchange Server Disaster Recovery Analyzer Tool 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=922247)을 참조하십시오.


Exchange 데이터베이스 온라인 유지 관리 일정이 사용 안 함으로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 사서함 저장소 및 공용 저장소의 activationSchedule 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 activationSchedule의 값이 사용 안 함으로 확인될 경우 경고를 표시합니다.

activationSchedule 특성은 온라인 데이터베이스 유지 관리 일정에 대한 설정을 나타냅니다. Exchange Server에서 온라인 데이터베이스 유지 관리는 매우 중요합니다. 이 기간 동안 dumpster 정리(삭제된 항목 보존 날짜를 지난 메시지 삭제), 공용 폴더 만료(공용 폴더에서 특정 날짜보다 오래된 메시지가 만료됨), 삭제된 사서함 정리, 온라인 조각 모음(더 이상 사용되지 않는 데이터베이스 개체를 검색하여 제거함으로써 사용 가능한 데이터베이스 공간 확보) 등의 작업이 수행됩니다. 이러한 프로세스는 Exchange Server 컴퓨터를 정상 상태로 유지하고 성능을 안정적으로 유지합니다. 온라인 유지 관리는 매일 4시간 이상 실행되도록 설정해야 합니다. 그렇지 않으면 시간이 지남에 따라 성능이 저하될 수 있습니다.

각 데이터베이스(사서함 저장소 또는 공용 폴더 저장소)에 대해 매일 4시간 동안 온라인 데이터베이스 유지 관리가 실행되도록 구성하는 것이 좋습니다. 온라인 유지 관리 간격을 백업 일정과 엇갈리게 설정합니다. 예를 들어 백업을 자정에서 오전 2시까지 실행할 경우 온라인 유지 관리는 오전 3시에서 오전 7시까지 실행합니다.

백업 세션이 실행 중인 경우에는 온라인 유지 관리가 시작되지 않으므로 이렇게 설정해야 합니다. 겹치는 경우 백업이 유지 관리보다 우선합니다. 이 경우 Exchange는 백업이 완료되었는지 여부를 15분마다 확인합니다. 백업이 완료된 후 유지 관리가 시작됩니다.

저장소는 18단계의 작업을 거쳐 유지 관리를 실행합니다. 작업이 시작되면 유지 관리 타이밍 창에 관계없이 작업을 마무리합니다. 그러나 타이밍 창이 만료된 경우에는 유지 관리가 새 작업을 시작하지 않습니다. 따라서 지정된 유지 관리 간격으로 모든 작업이 완료되지는 않는 경우가 있습니다. 유지 관리가 중단된 경우 다음 유지 관리 주기에서는 중단된 부분부터 계속됩니다.

Exchange 2000 Server 및 Exchange Server 2003에 대한 온라인 데이터베이스 유지 관리를 사용하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버를 확장한 다음 작업할 서버를 확장합니다.

  3. 작업할 저장소 그룹을 확장합니다.

  4. 세부 정보 창의 사용 가능한 데이터 저장소 목록에서 작업할 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 저장소 속성 대화 상자에서 데이터베이스 탭을 클릭합니다.

  6. 다음 중 하나를 수행합니다.

    • 유지 관리 간격 목록에서 간격을 선택합니다.

    • 사용자 지정을 클릭하여 일정 대화 상자를 표시한 다음 사용자 지정 간격을 만듭니다.

  7. 확인을 클릭합니다.

Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. 서버 구성을 확장하고 작업할 서버를 선택합니다.

  3. 작업할 저장소 그룹을 확장합니다.

  4. 작업할 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 일반 탭에서 유지 관리 일정 드롭다운을 클릭하고 간격을 선택하거나 사용자 지정을 클릭하여 사용자 지정 일정을 만듭니다.

온라인 데이터베이스 유지 관리 작업에 대한 자세한 내용은 Microsoft 기술 자료 문서 159196, "XADM: Tasks Controlled by the IS Maintenance Schedule"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196)을 참조하십시오.


Exchange 정보 저장소 서비스가 LocalSystem으로 실행되도록 구성되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-02-27

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Information Store 서비스(MSExchangeIS)의 StartName 속성에 지정된 시작 계정이 LocalSystem 계정을 사용하고 있는지 확인할 때 Win32_Services Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Exchange 2000 Server, Exchange Server 2003 또는 Exchange Server 2007 컴퓨터에서 이 속성의 값이 LocalSystem 계정(SYSTEM 계정이라고도 함)과 다른 경우 경고를 표시합니다. Exchange Server 5.5 컴퓨터의 경우 Microsoft Exchange Information Store 서비스를 사용자 계정으로 실행해야 하므로 이러한 경고가 표시되지 않습니다.

Exchange 2000 Server, Exchange Server 2003 및 Exchange Server 2007은 특정 사용자 계정 및 암호를 연결하여 시작하지 않고 LocalSystem 보안 컨텍스트를 사용하여 시작해야 합니다. 이렇게 하면 암호가 변경되거나 사용자 계정이 삭제되더라도 Exchange가 제대로 작동합니다. LocalSystem으로 실행되는 Exchange 서비스가 원격 서버에 액세스할 경우 Microsoft Windows 2000 Server 또는 Windows Server™ 2003에서는 컴퓨터 계정의 자격 증명을 사용하여 인증합니다.

컴퓨터 계정의 암호는 표준 암호 변경 메커니즘을 사용하여 7일마다 변경됩니다. 이렇게 하여 컴퓨터 계정은 일반 사용자 계정보다 더 안전하게 됩니다. 일반 사용자 계정은 암호가 자주 변경되지 않을 뿐 아니라 임의로 생성되는 컴퓨터 계정 암호보다 임의성이 떨어집니다.

서비스에 사용자 계정이 사용되는 Exchange Server 5.5를 사용한 경험이 있는 일부 관리자는 Exchange 2000 Server, Exchange Server 2003 및 Exchange Server 2007 서비스의 시작 계정을 기본 LocalSystem 계정에서 사용자 계정으로 변경합니다.

Exchange 2000 Server, Exchange Server 2003 및 Exchange Server 2007의 경우 LocalSystem 이외의 계정을 사용하여 Microsoft Exchange Information Store 서비스를 실행할 수 없습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 시작을 클릭하고 프로그램, 관리 도구를 차례로 가리킨 다음 서비스를 클릭합니다.

  2. 서비스 목록에서 Microsoft Exchange Information Store를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 로그온 탭의 다음 계정으로 로그온에서 로컬 시스템 계정을 클릭한 다음 확인을 클릭합니다.

  4. Microsoft Exchange Information Store를 마우스 오른쪽 단추로 클릭한 다음 다시 시작을 클릭합니다.

Exchange 서비스에 대한 자세한 내용은 Microsoft 기술 자료 문서 239762, "Exchange Services Run Under LocalSystem"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)을 참조하십시오.


Exchange Information Store 서비스가 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Information Store 서비스의 Started 키에 설정된 값이 True인지 False인지 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

False 값은 이 Exchange Server 컴퓨터에서 Microsoft Exchange Information Store 서비스가 실행되고 있지 않음을 나타내며 True 값은 Microsoft Exchange Information Store 서비스가 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스에서 Exchange_Server WMI 클래스를 검토하여 IsFrontEndServer 키 값을 확인합니다. False 값은 Exchange Server 컴퓨터가 프런트 엔드 서버가 아님을 나타내고 True 값은 Exchange Server 컴퓨터가 Exchange Server 2003 또는 Exchange 2000 Server 프런트 엔드 서버임을 나타냅니다.

Exchange 2000 Server 및 Exchange Server 2003 시스템에서 평가된 두 키 값이 모두 False이면 경고가 표시됩니다.

Win32_Service Started 키에 대해 False 값이 반환되고 Exchange Server 컴퓨터에서 Exchange Server 2007을 실행 중인 경우 경고가 표시됩니다.

Microsoft Exchange Information Store 서비스 시작이 실패하면 이 Exchange Server 컴퓨터에 보다 심각한 문제가 있을 수 있습니다. 이러한 경우에는 이벤트 로그를 검사하여 이 실패에 대한 세부 정보를 확인해야 합니다. 또한 사용 중인 Exchange Server 버전의 최신 서비스 팩을 실행하고 있는지 확인해야 합니다.

Exchange Server 2003의 최신 서비스 팩은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=25097)에서 다운로드할 수 있습니다.

Microsoft Exchange Information Store 서비스 실패의 알려진 원인에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 827915, "The Information Store service may stop unexpectedly while converting a message that does not contain the PR_MESSAGE_CLASS property in Exchange 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602, "Exchange Server 2003 Information Store service stops responding"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115, "The Information Store service does not start after you upgrade to Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197, "The Information Store service stops unexpectedly when a message with a null Internet message ID is delivered locally"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130, "The Folders pane does not appear or the Information Store service quits unexpectedly when you use OWA to access your mailbox on your Exchange Server 2003 computer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163, "'Setup Cannot Locate a Qualifying Global Catalog Server' Error Message When You Try to Start the Information Store Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579, "Event ID 7024 After You Install Exchange Server 2003, and Exchange Information Store Service Does Not Start"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579)

  • 833841, "The Microsoft Exchange Information Store service unexpectedly stops responding"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

Exchange Server 2003 및 Exchange 2000 Server 프런트 엔드 서버 사용에 대한 자세한 내용은 다음 웹 사이트를 참조하십시오.

  • Using Microsoft Exchange 2000 Front-End Servers(http://go.microsoft.com/fwlink/?linkid=12055)

  • Exchange Server 2003 and Exchange 2000 Server Front-End and Back-End Topology(http://go.microsoft.com/fwlink/?linkid=47567)


이 프런트 엔드 서버에서 Exchange 정보 저장소 서비스가 실행되고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange Information Store 서비스와 SMTP(Simple Message Transfer Protocol) 서비스의 Started 키에 설정된 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. False 값은 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 서비스가 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 IsFrontEndServer 키 값을 확인할 때 root\MicrosoftExchangeV2 네임스페이스에서 Exchange_Server WMI 클래스를 검토합니다. False 값은 Exchange Server 컴퓨터가 프런트 엔드 서버가 아님을 나타냅니다. True 값은 Exchange Server 컴퓨터가 프런트 엔드 서버임을 나타냅니다.

Exchange Server Analyzer는 SMTP 서비스에 대한 Started 값이 True이고 Microsoft Exchange Information Store 서비스에 대한 Started 값이 False이며 IsFrontEndServer 값이 True일 경우 경고를 표시합니다.

Exchange 2000 Server와 Exchange Server 2003은 POP3, IMAP4 및 Microsoft Office Outlook® Web Access 클라이언트 요청을 프록시하기 위해 프런트 엔드 서버를 사용합니다. 또한 프런트 엔드 서버를 인터넷 연결 SMTP 서버로도 사용할 수 있습니다. 이 프런트 엔드 서버에서 SMTP 메시지를 받아들이고 라우팅하거나 메시지 전송에 SMTP를 사용하는 IMAP 클라이언트를 지원하거나 바이러스 검색 API(VSAPI) 호환 소프트웨어가 실행 중이면 Microsoft Exchange Information Store 서비스가 실행되고 있어야 합니다. 그렇지 않으면 프런트 엔드 서버에서 SMTP 메시지를 처리하거나 VSAPI를 사용하여 메시지를 검색하지 못할 수 있습니다.

프런트 엔드 서버에 SMTP 또는 VSAPI 호환 바이러스 백신 소프트웨어가 사용되고 있지 않으면 해당 프런트 엔드 서버에 있는 모든 공용 폴더 저장소의 연결을 끊고 삭제하여 Microsoft Exchange Information Store 서비스를 중지한 다음 Microsoft Exchange Information Store 서비스를 사용 안 함으로 설정하는 것이 좋습니다. 또한 SMTP 서비스가 사용되고 있지 않으면 이 서비스를 중지해야 합니다. SMTP 또는 VSAPI 호환 소프트웨어를 사용하는 Exchange Server 컴퓨터에서 메시지를 배달하고 메시징 클라이언트를 서비스하려면 Microsoft Exchange Information Store 서비스가 실행되고 있어야 합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. Microsoft Exchange Information Store 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. Microsoft Exchange Information Store 속성 페이지의 일반 탭에서 시작 유형이 자동으로 설정되었는지 확인합니다. 그렇지 않은 경우 자동으로 설정하고 적용을 클릭한 다음 확인을 클릭합니다.

  4. Microsoft Exchange Information Store 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.

Microsoft Exchange Information Store 서비스 시작이 실패하면 이 Exchange Server 컴퓨터에 보다 심각한 문제가 있음을 나타낼 수 있습니다. 이러한 경우에는 이벤트 로그를 검사하여 이 실패에 대한 세부 정보를 확인해야 합니다. 또한 사용 중인 Exchange Server 버전의 최신 서비스 팩을 실행하고 있는 지도 확인해야 합니다. Exchange Server의 최신 서비스 팩은 "Microsoft Exchange Server 홈 페이지" 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21573)에서 구할 수 있습니다.

Microsoft Exchange Information Store 서비스 실패의 알려진 원인에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 827915, "The Information Store service may stop unexpectedly while converting a message that does not contain the PR_MESSAGE_CLASS property in Exchange 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602, "Exchange Server 2003 Information Store service stops responding"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115, "The Information Store service does not start after you upgrade to Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197, "The Information Store service stops unexpectedly when a message with a null Internet message ID is delivered locally"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130, "The Folders pane does not appear or the Information Store service quits unexpectedly when you use OWA to access your mailbox on your Exchange Server 2003 computer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163, "'Setup Cannot Locate a Qualifying Global Catalog Server' Error Message When You Try to Start the Information Store Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579, "Event ID 7024 After You Install Exchange Server 2003, and Exchange Information Store Service Does Not Start"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579)

  • 833841, "The Microsoft Exchange Information Store service unexpectedly stops responding"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

프런트 엔드 서버에 대한 자세한 내용은 Exchange Server 2003 and Exchange 2000 Server Front-End and Back-End Topology Guide(http://go.microsoft.com/fwlink/?linkid=47567)를 참조하십시오.


Exchange IFS가 활성화되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-02-28

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange 설치 가능 파일 시스템(ExIFS 또는 IFS) 드라이브 문자 매핑이 활성화되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Exchange Server Analyzer는 드라이브 문자(예: M)로 구성된 DriveLetter 레지스트리 값을 확인할 경우 오류를 표시합니다.

Exchange 2000 Server에는 IFS라는 기능이 포함되어 있습니다. IFS는 Exchange Information Store의 데이터 일부를 Microsoft Windows® 파일 시스템으로 보내는 커널 수준 드라이버입니다. Exchange 2000 Server를 새로 설치하거나 Exchange Server 5.5에서 Exchange 2000 Server로 업그레이드할 경우 IFS가 자동으로 설치되며 드라이브 문자(기본값: 드라이브 M)가 할당된 후 정보 저장소에 매핑됩니다. 이 작업은 \\.\BackOfficeStorage\ 네임스페이스를 사용하여 수행됩니다.

Exchange Server 2003은 IFS를 지원하지만 드라이브 문자 매핑이 기본적으로 비활성화되어 있습니다. Exchange Server 2003을 새로 설치하거나 Exchange Server 5.5에서 Exchange 2000 Server로 업그레이드했을 때 DriveLetter 레지스트리 값은 존재하지 않으므로 해당 레지스트리 값 데이터와 드라이브 문자 매핑이 제거됩니다.

Exchange Server 2003에서는 IFS 드라이브 문자 매핑을 비활성화하고 Exchange 2000 Server에서는 제거하는 것이 가장 바람직합니다. IFS에 매핑된 드라이브 문자를 바이러스 백신 응용 프로그램이나 파일 시스템 기반 응용 프로그램에서 액세스하거나 검색할 경우 발생할 수 있는 알려진 문제점이 있습니다. 따라서 IFS 기능을 사용하지 않을 경우 드라이브 문자 매핑을 제거하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. 오른쪽 창에서 DriveLetter 값을 두 번 클릭합니다.

  4. 나열된 문자를 삭제하여 값 데이터 필드를 비웁니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange System Attendant 서비스 및 World Wide Web 게시 서비스를 다시 시작하여 변경 내용을 적용합니다. 시스템 수행자(System Attendant) 서비스가 다시 시작되면 Microsoft Exchange MTA Stacks 및 Microsoft Exchange Information Store 서비스를 비롯하여 시스템 수행자(System Attendant) 서비스에 의존하는 모든 서비스도 다시 시작됩니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange 2000 Server의 드라이브 M 매핑 제거에 대한 자세한 내용은 기술 자료 문서 305145, "HOWTO: XADM: M 드라이브에서 IFS 매핑 제거"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=305145)를 참조하십시오.

Exchange Server 2003의 드라이브 M 매핑 제거에 대한 자세한 내용은 기술 자료 문서 821836, "Drive M Mapping to IFS Is Not Present by Default in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821836)을 참조하십시오.


Exchange Server 구성 및 성능
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer Tool에서 Exchange 서버가 최적의 성능으로 구성되어 있지 않음을 확인했습니다.

보통 작업하는 동안 Exchange 서버는 다양한 파일에 액세스합니다. 파일 위치로 인해 성능 병목 현상이 발생할 수 있습니다. 트랜잭션 로그 드라이브 같은 상호 의존적인 파일의 그룹을 리소스라고 합니다.

이러한 리소스의 분산으로 인해 디스크 병목 현상이 발생한 경우 Exchange Server Analyzer에서 Exchange 서버의 리소스 위치에 대한 경고 또는 오류를 표시할 수 있습니다. 특정 리소스를 다른 로드 요구에서 격리하려면 해당 리소스를 전용 저장 장치에 배치하십시오. 다음 목록에서는 각 리소스의 사용 방법에 대해 설명하며 해당 리소스를 구성 방법에 대한 권장 사항이 포함되어 있습니다.

  • 트랜잭션 로그 드라이브 트랜잭션 로그 파일은 .edb 및 .stm 파일의 상태와 통합성을 유지 관리합니다. 이는 로그 파일이 실제로 데이터를 나타내는 것을 의미합니다. 각 저장소 그룹에 대해 설정된 트랜잭션 로그 파일이 있습니다. 트랜잭션 로그는 Exchange 서버 데이터베이스 파일의 데이터를 위한 중요한 백업 구성 요소이므로 Exchange 서버는 데이터에 대한 많은 트랜잭션을 마치기 전에 로그 파일에 모든 데이터를 커밋해야 합니다. 트랜잭션 로그 드라이브에 쓸 때 지연이 발생하면 서버 성능에 심각한 영향을 미칠 수 있습니다. 따라서 드라이브가 다른 서버, 응용 프로그램 또는 리소스와 공유하지 않는 자신의 디스크 하위 시스템을 갖도록 트랜잭션 로그 드라이브를 격리해야 합니다. 최적의 성능을 위해 각 트랜잭션 로그가 전용 드라이브를 갖도록 해야 합니다.

  • TEMP 드라이브의 위치 운영 체제를 처음 설치하면 운영 체제는 운영 체제에서 사용하는 것과 같은 드라이브에 임시 파일 위치를 설정합니다. 이는 TEMP 드라이브에 대한 모든 I/O가 해당 드라이브에서 실행되는 프로그램 및 페이지 파일 작업에 대한 I/O와 경쟁한다는 것을 의미합니다. 이러한 I/O 경쟁은 성능에 악영향을 미칩니다. TEMP 드라이브는 메일 배달 및 큰 메시지의 콘텐츠 변환에 사용됩니다. TEMP 드라이브에서 병목 현상이 발생하면 메일 흐름과 일부 클라이언트 응용 프로그램에 악영향을 미칩니다. 운영 체제가 TEMP 드라이브와 I/O에 대해 경쟁하는 것을 피하고 Exchange 서버에 성능 문제가 발생할 위험을 줄이려면 다음 작업을 수행하는 것이 좋습니다.

    • 다른 디스크를 가리키도록 TEMP의 전역 환경 설정을 변경합니다.

    • TEMP 드라이브를 전용 디스크로 옮깁니다.

  • .edb 및 .stm 파일 위치 Exchange 데이터베이스는 다음 두 가지 파일로 구성되어 있습니다.

    • .edb 파일(MAPI 콘텐츠) 이 파일은 Store.exe 프로세스에서 모든 메시지와 .edb 및 .stm 파일의 체크섬과 MAPI 메시지를 찾기 위해 사용하는 모든 MAPI 메시지와 테이블을 저장합니다.

    • .stm 파일(비 MAPI 콘텐츠) 이 파일에는 메시지 전용 인터넷 콘텐츠와 함께 전송되는 메시지가 들어 있습니다.

    이러한 파일 유형에 대한 액세스는 일반적으로 임의적이므로 두 가지 파일 유형을 모두 같은 디스크 볼륨에 포함할 수 있습니다. 그러나 .edb 및 .stm 파일은 트랜잭션 로그와 같은 드라이브에 배치하지 않아야 합니다. 또한 데이터베이스 파일이 있는 드라이브의 성능 병목 현상을 피해야 하므로 각 저장소 그룹에 따라 전용 드라이브에 이러한 파일을 배치하는 것이 좋습니다.

  • SMTP 디렉터리 위치 SMTP 큐는 Exchange가 데이터베이스(사서함 저장소 또는 공용 폴더 저장소)에 SMTP 메시지를 쓰거나 다른 서버 또는 커넥터로 메시지를 보낼 때까지 SMTP 메시지를 저장합니다. 일반적으로 SMTP 큐에서는 임의의 소규모 I/O가 발생합니다. Exchange Server Analyzer는 SMTP 디렉터리가 다음 중 하나와 공유되는 드라이브에 있을 경우 경고를 표시합니다.

    • 다른 Exchange 데이터 파일

    • TEMP 또는 TMP 디렉터리

    • 페이지 파일

    • 시스템 드라이브

    SMTP 디렉터리에 디스크 병목 현상이 발생하지 않은 경우 이 경고를 무시해도 됩니다. 그러나 이 드라이브에 대한 소통량이 높아서 드라이브에 성능 병목 현상이 발생하는 경우 SMTP 디렉터리를 전용 드라이브로 옮기거나 SMTP 디렉터리를 호스트하는 드라이브의 용량을 늘려야 합니다.

  • 페이지 파일 위치 페이지 파일은 실제 메모리를 늘리는 것과 같은 역할을 합니다. 특히 시스템은 사용되지 않는 페이지나 시스템에서 나중에 필요로 할 페이지를 이 페이지 파일에 저장합니다. 페이지 파일은 적절한 양의 사용 가능한 메모리를 가진 서버에서도 항상 사용됩니다. 이렇게 끊임 없이 사용되는 이유는 운영 체제가 필요한 페이지와 작업을 위한 충분한 사용 가능 공간만을 저장하려고 하기 때문입니다. 예를 들어 시작 시에만 사용되는 인쇄 도구는 해당 메모리의 일부를 디스크로 페이징하고 사용되지 않는 한 다시 가져오지 않습니다.

    실제 메모리가 과도하게 사용되는 서버에서는 페이지 파일에 대한 모든 액세스가 가능한 한 빨라야 합니다. 이 경우 페이지 파일 전용 드라이브에 두 번째 페이지 파일을 만드는 것이 좋습니다.

추가 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 저장소 아키텍처를 설계하는 최상의 방법에 대한 자세한 내용은 여러 아키텍처에 공통적인 유용한 정보(http://go.microsoft.com/fwlink/?LinkId=72988)를 참조하십시오.

  • 디스크 크기 조정, 대기 시간 및 I/O 속도에 대한 자세한 내용은 디스크 I/O 요구 사항을 계산하는 방법(http://go.microsoft.com/fwlink/?linkid=69747)을 참조하십시오.


Exchange 저장소의 TCP/IP 포트가 수동으로 다시 정의되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-03-21

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange 저장소 인터페이스의 포트 값이 수동으로 다시 정의되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Exchange Server Analyzer는 TCP/IP Port가 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

일반적으로 MAPI 클라이언트가 방화벽의 다른 쪽에 있는 Exchange 서버에 연결할 수 있도록 하기 위해 이 값이 구성됩니다. 이를 위해서는 방화벽의 포트를 여러 개 열어서 Microsoft Office Outlook® 2003 또는 Outlook 2007 클라이언트가 MAPI를 사용하여 인터넷을 통해 Exchange 서버에 연결할 수 있도록 해야 합니다. 이러한 구성은 지원됩니다. 방화벽을 통해 MAPI 클라이언트를 Exchange에 연결하도록 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 270836, "Exchange 2000 및 Exchange 2003 정적 포트 매핑"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)을 참조하십시오. 하지만 이 시나리오를 사용하지 않는 경우에는 레지스트리를 제거해야 합니다.

MAPI 모드에서 Outlook을 사용하여 인터넷을 통해 Exchange 서버에 연결할 때 권장되는 배포 방법은 Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 및 Microsoft Windows® XP Professional에서 제공하는 RPC over HTTP 기능을 사용하는 것입니다. 전에는 MAPI 모드를 "회사" 또는 "작업 그룹" 모드라고 했습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP 포트 레지스트리 키를 제거하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. TCP/IP Port라는 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC over HTTPS를 배포하려면 다음을 수행합니다.

  1. "Exchange Server 2003 RPC over HTTP Deployment Scenarios"(http://go.microsoft.com/fwlink/?linkid=47577)를 검토하십시오.

  2. 기술 자료 문서 833401, "Exchange Server 2003 단일 서버에서 RPC over HTTP를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)을 검토하십시오.

  3. 기술 자료 문서 827330, "How to troubleshoot client RPC over HTTP connection issues in Office Outlook 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)을 검토하십시오.

  4. Microsoft 기술 지원 웹캐스트, "웹캐스트: Microsoft Office Outlook 2003에서 인터넷(RPC/HTTP)을 통해 Microsoft Exchange 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134)을 검토하십시오.


Exchange 저장소 TCP/IP 포트가 5000 미만입니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-01-11

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange 저장소의 TCP/IP Port 설정을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Exchange Server Analyzer는 TCP/IP Port가 5000(10진수) 미만의 값으로 설정되어 있을 경우 경고를 표시합니다.

TCP/IP Port 설정을 정적 값으로 설정해야 하는 경우 5000 이상의 값으로 설정하는 것이 좋습니다. 값을 5000 미만으로 설정하면 Exchange 서버가 해당 포트에서 수신하지 않을 수 있습니다. Exchange 서버는 서비스가 다시 시작될 때까지 이러한 상태를 유지합니다. 다시 시작되는 서비스는 하드 코드된 Exchange 구성 요소에 따라 다릅니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

TCP/IP port 레지스트리 키를 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. TCP/IP Port 키를 두 번 클릭하고 값 데이터 필드를 5000(10진수)보다 큰 정수로 설정합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 앞서 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

포트 설정에 대한 자세한 내용은 기술 자료 문서 270836, "Exchange 2000 정적 포트 매핑"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)을 참조하십시오.


Exchange 트랜잭션 로그가 NTFS가 아닌 파티션에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-02-27

오류 메시지

소개

Microsoft Exchange Analyzer Tool은 Exchange 트랜잭션 로그 파일 경로의 FSName 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 FSName 키 값이 NTFS가 아닐 경우 오류를 표시합니다.

NTFS가 아닌 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일에는 다음 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

이 오류가 발생한 경우 트랜잭션 로그를 NTFS 드라이브의 폴더로 이동해야 합니다. 또는 해당 트랜잭션 로그 디렉터리가 저장되어 있는 드라이브가 FAT 드라이브로 포맷되어 있는 경우 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다.

Exchange 2000 Server 또는 Exchange Server 2003에서 트랜잭션 로그를 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버를 차례로 확장하고 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 트랜잭션 로그 위치의 일반 탭에서 찾아보기를 클릭합니다.

  4. 로그 파일의 새 위치에 대한 경로를 입력한 다음 확인을 클릭합니다.

  5. 확인을 클릭합니다.

Exchange Server 2007에서 Exchange 저장소 그룹의 트랜잭션 로그 파일 위치를 이동하려면 다음을 수행합니다.

  1. 핵심 Exchange Server 2007 설명서 "How to Set or Change the Location of Storage Group Log Files"(http://go.microsoft.com/fwlink/?LinkID=80702)의 안내를 따릅니다.

파일이 저장되어 있는 드라이브가 FAT 드라이브로 포맷된 경우에는 앞에서 설명한 절차 대신 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다. convert.exe 명령줄 도구를 사용하여 FAT 파티션을 NTFS 파티션으로 변환하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 214579, "Convert.exe를 사용하여 파티션을 NTFS 파일 시스템으로 변환하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579)을 참조하십시오.


Exchange 트랜잭션 로그가 압축된 폴더에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 Exchange Information Store 트랜잭션 로그를 포함하는 폴더에 대한 Compressed 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Compressed 값이 이 폴더에 대해 True로 설정되어 있으면 오류가 표시됩니다.

메시지가 Exchange로 배달되면 메시지가 저장소에 커밋되어 배달되기 전에 트랜잭션 로그에 기록됩니다. Exchange 2000 Server 또는 Exchange Server 2003 컴퓨터에서 트랜잭션 로그는 다음 기본 위치에 기록됩니다.

<drive> :\Program Files\Exchsrvr\mdbdata

Exchange Server 2007 컴퓨터에서 트랜잭션 로그는 다음 기본 위치에 기록됩니다.

<drive> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

Exchange 데이터 파일은 NTFS로 압축된 볼륨에 저장되지 않습니다. Exchange 데이터 파일을 압축된 볼륨에 저장하면 추가 오버헤드가 발생해 Exchange의 성능에 막대한 영향을 줍니다. 또한 정보 저장소 데이터베이스가 일정 크기(약 4GB)에 도달하면 탑재에 실패하거나 손상될 수 있습니다.

Exchange 데이터 파일에는 아래의 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

확장 가능한 저장소 엔진(ESE)에 의해 관리되는 파일은 압축된 드라이브에 저장하기 위한 파일이 아닙니다. ESE는 로그 기반 복구를 위한 섹터 독립에 종속되며 파일 압축은 섹터 독립을 무효화합니다. 볼륨 호스팅 ESE 데이터베이스나 미리 쓰기 로깅을 사용하는 데이터베이스의 경우 압축을 설정하지 않아야 합니다.

Exchange 2000 Server 서비스 팩 3 이전 버전에서는 압축된 정보 저장소 데이터베이스를 탑재할 수 있습니다. 그러나 Exchange 2000 Server 정보 저장소 데이터베이스 또는 NTFS 압축을 사용하여 압축된 정보 저장소 로그가 손상될 수 있습니다.

Exchange 2000 Server 서비스 팩 3을 사용할 경우 128MB 이하의 압축된 정보 저장소 데이터베이스 파일은 자동으로 압축이 풀어집니다. 데이터베이스 파일이 128MB를 넘으면 데이터베이스가 탑재되지 않고 응용 프로그램 로그에 오류 메시지가 생성됩니다. Exchange 2000 Server 서비스 팩 3에서는 128MB를 초과하는 압축된 데이터베이스를 탑재할 수 없습니다.

주어진 폴더에 대한 압축을 해제하려면 다음을 수행합니다.

  1. 파일 압축을 풀 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 내용을 압축하여 디스크 공간 절약 확인란의 선택을 해제한 다음 확인을 클릭합니다.

Exchange 2000 Server 또는 Exchange Server 2003에서 트랜잭션 로그를 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버를 차례로 확장하고 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭의 트랜잭션 로그 위치에서 찾아보기를 클릭합니다.

  4. 로그 파일의 새 위치에 대한 경로를 입력한 다음 확인을 클릭합니다.

  5. 확인을 클릭합니다.

Exchange Server 2007의 Exchange 저장소 그룹 트랜잭션 로그 파일의 위치를 이동하려면 다음을 수행합니다.

  1. 핵심 Exchange Server 2007 설명서 "How to Set or Change the Location of Storage Group Log Files"(http://go.microsoft.com/fwlink/?LinkId=80702)의 안내를 따릅니다.

Exchange Server 2003의 로그 파일 이동 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 821915, "Exchange 2003 Server의 Exchange 데이터베이스와 로그를 이동하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915)을 참조하십시오.

Exchange 2000 Server의 로그 파일 이동 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 239944, "XADM: 트랜잭션 또는 시스템 로그를 다른 위치로 이동하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944)을 참조하십시오.


Exchange 트랜잭션 로그가 암호화된 폴더에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-02-27

Microsoft Exchange Analyzer Tool은 정보 저장소 트랜잭션 로그를 포함하는 폴더의 Encrypted 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다. Encrypted의 값이 True로 설정되어 있는 경우 오류가 표시됩니다.

메시지는 Exchange로 배달될 경우 먼저 트랜잭션 로그에 기록된 다음 저장소에 커밋되고 배달됩니다. Exchange 2000 Server 또는 Exchange Server 2003 컴퓨터에서 트랜잭션 로그는 다음 기본 위치에 기록됩니다.

<drive> :\Program Files\Exchsrvr\mdbdata

Exchange Server 2007 컴퓨터에서 트랜잭션 로그는 다음 기본 위치에 기록됩니다.

<drive> :\Program Files\Microsoft\Exchange Server\Mailbox\<Storage Group Name>

EFS(암호화 파일 시스템) 암호화 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일을 암호화된 볼륨에 저장하면 추가 오버헤드가 발생하여 Exchange의 성능에 막대한 영향을 줍니다. Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

Exchange 데이터 파일을 보호하려면 Exchange 컴퓨터에 대한 무단 액세스를 방지하고 S/MIME 메시지 형식을 사용하여 메시지 데이터를 암호화하는 것이 좋습니다.

이 오류를 해결하려면 트랜잭션 로그가 기록된 폴더에서 파일 암호화를 해제하거나 암호화가 사용되지 않은 폴더로 트랜잭션 로그를 이동합니다.

지정한 폴더의 파일 암호화를 해제하려면 다음을 수행합니다.

  1. 파일 암호화를 해제할 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 데이터 보호를 위해 내용을 암호화 확인란의 선택을 해제한 다음 확인을 클릭합니다.

Exchange 2000 Server 또는 Exchange Server 2003에서 트랜잭션 로그를 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 사용 중인 관리 그룹, 서버를 차례로 확장하고 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭의 트랜잭션 로그 위치에서 찾아보기를 클릭합니다.

  4. 로그 파일의 새 위치에 대한 경로를 입력한 다음 확인을 클릭합니다.

  5. 확인을 클릭합니다.

Exchange Server 2007에서 Exchange 저장소 그룹의 트랜잭션 로그 파일 위치를 이동하려면 다음을 수행합니다.

  1. 핵심 Exchange Server 2007 설명서 "How to Set or Change the Location of Storage Group Log Files"(http://go.microsoft.com/fwlink/?LinkID=80702)의 안내를 따릅니다.

로그 파일 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 821915, "Exchange 2003 Server의 Exchange 데이터베이스와 로그를 이동하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915)을 참조하십시오.

Exchange Server 데이터 파일과 EFS에 대한 자세한 내용은 Microsoft 기술 자료 문서 834638, "Information about the storage of data files on an encrypted volume in Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)를 참조하십시오.

Exchange Server 2003의 메시지 보안 유지 방법에 대한 자세한 내용은 Exchange Server 2003 메시지 보안 가이드(http://go.microsoft.com/fwlink/?linkid=47574)를 참조하십시오.


확장 ESE 성능 카운터를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키를 읽어 Exchange 서버에 확장 가능한 저장소 엔진(ESE)의 확장된 카운터가 성능 카운터의 라이브러리에 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ESE\Performance\Show Advanced Counters

Exchange Server Analyzer는 Show Advanced Counters 레지스트리 키의 데이터 값이 1인 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
확장 ESE 성능 카운터를 사용할 수 없게 하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 레지스트리의 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ESE\Performance 키 아래에서 Show Advanced Counters를 삭제합니다.

  3. 레지스트리 편집기를 닫습니다.

  4. 성능 모니터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


확장된 저장소 성능 카운터를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키 값을 읽어 Mdbperfx.dll이 성능 카운터의 Exchange 서버 라이브러리에 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Performance

Exchange Server Analyzer는 라이브러리 값에 "mdbperfx.dll" 문자열이 있는 것을 확인하면 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

Mdbperf.dll이라는 DLL에는 기본 저장소 성능 카운터 집합이 들어 있습니다. Mdbperfx.dll이라는 DLL에는 동일한 기본 저장소 성능 카운터 집합과 확장된 저장소 성능 카운터 집합도 들어 있습니다.

기본적으로 라이브러리 값 데이터에는 DLL Mdbperf.dll이 들어 있습니다. 기본적으로 라이브러리 값 데이터에는 Mdbperfx.dll이라는 DLL이 들어 있지 않습니다. 다음 표는 DLL Mdbperfx.dll이 들어 있는 확장된 저장소 성능 카운터를 보여줍니다.

카운터 | 대상
FXGetBufferRopsCalled | 총 FXGetBuffer 원격 프로시저 호출(RPC) 작업 수
FXGetBufferRopsCalledPerSec | 초당 FXGetBuffer RPC 작업 수
FXGetBufferRopsAcceptedPerSec | 초당 수락된 FXGetBuffer RPC 작업 수
FXGetBufferRopsDenied | 거부된 총 FXGetBuffer RPC 작업 수
FXGetBufferRopsDeniedPerSec | 초당 거부된 FXGetBuffer RPC 작업 수
FXGetBufferCurrentCallerCount | 동시 FXGetBuffer RP 작업 수
FXGetBufferCurrentUsersExecuting | 실행 중인 동시 FXGetBuffer RPC 작업 수
MIME으로 검색된 메시지 | 바이러스 검색 프로그램에서 MIME으로 처리된 총 최상위 메시지 수
초당 MIME으로 검색된 메시지 | 바이러스 검색 프로그램에서 최상위 메시지가 MIME으로 처리되는 비율
MAPI로 검색된 메시지 | 바이러스 검색 프로그램에서 MAPI로 처리된 총 최상위 메시지 수
초당 MAPI로 검색된 메시지 | 바이러스 검색 프로그램에서 최상위 메시지가 MAPI로 처리되는 비율
읽은 총 바이트 수 | 바이러스 검색 프로그램에서 읽은 총 바이트 수
쓴 총 바이트 수 | 바이러스 검색 프로그램에서 쓴 총 바이트 수
큐의 길이(낮은 우선 순위) | 바이러스 검색을 위해 대기 중인 현재 해결되지 않은 낮은 우선 순위의 요청 수
스레드 | 바이러스 검색을 위해 사용되는 스레드 풀의 현재 스레드 수 이 수는 백그라운드 검색에 사용되는 스레드 수에는 포함되지 않습니다.
MFT 스탬프에 의해 충족되는 확인 수 | 메시지 폴더 테이블의 스탬프에 의해 충족되는 바이러스 검색 확인 횟수
초당 MFT 스탬프에 의해 충족되는 확인 수 | 메시지 폴더 테이블의 스탬프에 의해 충족되는 바이러스 검색 확인 비율
인스턴스 스탬프에 의해 충족되는 확인 수 | 인스턴스 스탬프에 의해 충족되는 바이러스 검색 확인 횟수
초당 인스턴스 스탬프에 의해 충족되는 확인 수 | 마스터 인스턴스 스탬프에 의해 충족되는 바이러스 검색 확인 횟수
초당 마스터 인스턴스 스탬프에 의해 충족되는 확인 수 | 마스터 인스턴스 스탬프에 의해 충족되는 바이러스 검색 확인 비율
충족되지 않는 확인 수 | 스탬프에 의해 충족되지 않는 바이러스 검색 확인 횟수
초당 충족되지 않는 확인 수 | 스탬프에 의해 충족되지 않는 바이러스 검색 확인 비율
차단된 확인 수 | 바이러스 검색 완료를 기다리는 동안 처리가 차단된 횟수
초당 차단된 확인 수 | 바이러스 검색 완료를 기다리는 동안 처리가 차단된 비율
확인 시간 초과 수 | 바이러스 검색 완료를 기다리는 작업의 시간이 초과된 횟수
초당 확인 시간 초과 수 | 바이러스 검색 완료를 기다리는 작업의 시간이 초과된 비율
중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 저장소 성능 카운터만 사용할 수 있도록 하려면

  1. Regedit.exe나 RegEdt32.exe 같은 레지스트리 편집기를 시작합니다.

  2. 다음 레지스트리 키의 라이브러리 값을 찾습니다.

    HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\Performance

  3. 편집 메뉴에서 수정을 클릭합니다.

  4. 값 데이터 상자에서 c:\Program Files\Exchsrvr\bin\mdbperfx.dll의 값을 c:\Program Files\exchsrvr\bin\mdbperf.dll로 변경합니다.

  5. 확인을 클릭한 다음 레지스트리 편집기를 닫습니다.

  6. 성능 모니터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange 저장소에 관한 성능 데이터 수집 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 821912, "How to Collect Diagnostic Data to Help Troubleshoot Information Store Issues"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821912)를 참조하십시오.


FXGetBuffer Backoff Constant 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 FXGetBuffer Backoff Constant 값이 생성되었는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 FXGetBuffer Backoff Constant 값이 ParametersSystem 레지스트리 키에 따라 생성되었음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다.

FXGetBuffer Backoff Constant 값을 사용하여 Exchange Server 2003 서버와 한 번에 동기화되는 Microsoft Office Outlook® 2003 클라이언트 수를 제어할 수 있습니다. FXGetBuffer Backoff Constant 값을 설정하여 Outlook 클라이언트가 다시 동기화를 시도하기 전에 Outlook 클라이언트가 대기하는 시간을 구성합니다. FXGetBuffer Backoff Constant의 기본값은 500밀리초입니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다. 그러나 기본 구성을 복원하려는 경우에는 FXGetBuffer Backoff Constant 레지스트리 키를 삭제할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성을 복원하려면 다음을 수행합니다

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. FXGetBuffer Backoff Constant 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

Microsoft Exchange Information Store 서비스는 몇 분 이내에 변경 내용을 감지합니다. 컴퓨터를 다시 시작할 필요가 없습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server 2003과 동기화할 수 있는 Outlook 클라이언트 수를 제어할 수 있도록 레지스트리 키를 설정하는 방법에 대한 자세한 내용은 기술 자료 문서 818484, "Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484)을 참조하십시오.


FXGetBuffer Retry Count 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 FXGetBuffer Retry Count 값이 생성되었는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 FXGetBuffer Retry Count 값이 ParametersSystem 레지스트리 키에 따라 생성되었음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다.

FXGetBuffer Retry Count 값을 사용하여 Exchange Server 2003 서버와 한 번에 동기화되는 Microsoft Office Outlook® 2003 클라이언트 수를 제어할 수 있습니다. FXGetBuffer Retry Count 값을 설정하여 Outlook 클라이언트가 액세스를 부여받기 전에 동기화를 시도하는 횟수를 구성합니다. 기본값은 10입니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다. 그러나 기본 구성을 복원하려는 경우에는 FXGetBuffer Retry Count 레지스트리 키를 삭제할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성을 복원하려면 다음을 수행합니다

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. FXGetBuffer Retry Count 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

Microsoft Exchange Information Store 서비스는 몇 분 이내에 변경 내용을 감지합니다. 컴퓨터를 다시 시작할 필요가 없습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server 2003과 동기화할 수 있는 Outlook 클라이언트 수를 제어할 수 있도록 레지스트리 키를 설정하는 방법에 대한 자세한 내용은 기술 자료 문서 818484, "Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484)을 참조하십시오.


Ignore Bad Oof Rule 레지스트리 매개 변수가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 Ignore Bad Oof Rule 레지스트리 항목이 있는지 확인할 때 Exchange Server 컴퓨터의 레지스트리를 읽습니다. 이 레지스트리 값은 다음 위치에 있습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

Exchange Server Analyzer는 Ignore Bad Oof Rule 레지스트리 항목의 값이 1 이상으로 구성되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

Ignore Bad Oof Rule 레지스트리 항목은 Exchange 2000 Server, Exchange Server 2003 및 Exchange Server 2007의 구성 설정으로 Microsoft 기술 자료 문서 828875, "Exmerge.exe 유틸리티를 사용한 후 Exchange 사서함을 이동할 수 없다"(http://go.microsoft.com/fwlink/?LinkID=3052&kbid=828875)에 설명되어 있는 핫픽스와 함께 사용하도록 설계되었습니다.

Microsoft Exchange Mailbox Merge 프로그램(Exmerge.exe)을 사용하여 특정 사서함 저장소의 사서함에서 다른 사서함 저장소의 사서함으로 메시지 및 기타 항목을 이동하는 경우 두 번째 사서함을 이동하는 후속 작업이 실패할 수 있습니다. 해당 사서함에 잘못된 부재 중(OOF) 규칙이 설정되어 있을 때 이러한 문제가 발생할 수 있습니다. 원하는 경우 아래에 설명된 절차에 따라 기본 구성으로 되돌릴 수 있습니다.

중요:
이 문서에는 레지스트리 편집 방법에 대한 정보가 들어 있습니다. 레지스트리를 편집하기 전에 문제가 발생하는 경우 레지스트리를 복원하는 방법에 대해 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate를 탐색합니다.

  3. 오른쪽 창에서 Ignore Bad Oof Rule 값을 찾아 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


Ignore Zombie Users 레지스트리 매개 변수가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터의 레지스트리를 조사하여 Ignore Zombie users 레지스트리 항목이 있는지 확인합니다. 이 레지스트리 값은 다음 위치에 있습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 Ignore Zombie users 레지스트리 항목이 1 이상의 값으로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server 5.5와 Exchange 2000 Server를 포함하는 혼합 모드 Exchange Server 조직이나 이전에 혼합되었던 환경에 다음 조건이 있으면 문제가 발생할 수 있습니다.

  • 사서함 및 공용 폴더의 ACL(액세스 제어 목록)을 Exchange Server 5.5에서 Exchange 2000 Server로 업그레이드하는 경우

  • ACL이 Active Directory® 디렉터리 서비스에 표시되지 않은 사용자 계정을 포함하는 경우

이와 같이 사용되지 않은 ACE(액세스 제어 항목)를 좀비 사용자라고도 합니다. 2003년 3월 현재 Exchange 2000 Server 서비스 팩 3 롤업 이상에서 좀비 사용자에 대한 기본 처리 동작이 변경되었습니다. 이 동작은 Ignore Zombie users 레지스트리 키를 사용하여 제어할 수 있습니다.

Ignore Zombie users 레지스트리 값은 Exchange 2000 Server 서비스 팩 3 이상이 설치된 서버에서 사용할 수 있습니다. 이 레지스트리 항목은 좀비 사용자가 발생하는 것이 대기 등 ADC(Active Directory Connector) 복제 문제로 인한 것이 아님이 확실한 경우에만 주의하여 사용해야 합니다. 이 레지스트리 값을 사용하면 Exchange Server는 좀비 사용자를 무시하고 사서함이나 공용 폴더의 ACL에서 좀비 사용자를 제거합니다. ACL이 업그레이드될 때 Active Directory에 없는 사용자는 유효하더라도 제거되므로 나중에 해당 사용자를 수동으로 각 ACL에 추가해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. 오른쪽 창에서 Ignore Zombie users 값을 찾아서 삭제합니다.

  4. 레지스트리 편집기를 닫은 다음 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Ignore Zombie Users 레지스트리 키 사용에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 812963, "Using the Ignore Zombie Users Registry Key"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963)

  • 324323, "XADM: Skipping User Accounts That Are Not Represented in Active Directory During Access Control List Conversion"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323)


IMAIL 예외 처리가 수동으로 비활성화되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 검사하여 ExceptionHandling 레지스트리 값 설정을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Exchange Server Analyzer는 ExceptionHandling 레지스트리 값이 값 0으로 구성되면 경고를 표시합니다.

ExchangeServer에서는 IMAIL exception handling이 기본적으로 설정되어 있으며 사용자 인터페이스를 통해 해제할 수 없습니다. 그러나 레지스트리를 사용하면 IMAIL exception handling을 해제할 수 있습니다.

실제로 문제를 해결하고 있는 중이 아니면 IMAIL exception handling을 사용할 수 있게 설정한 상태로 두는 것이 좋습니다. 예를 들어 잘못된 MIME(Multipurpose Internet Mail Extensions)이나 MAPI 콘텐츠를 기반으로 이벤트를 트리거하는 사용자 지정 응용 프로그램이 있으면 IMAIL exception handling을 해제할 수 있습니다. Microsoft 기술 지원 서비스 기술 지원 전문가의 권고와 지시가 있을 때만 IMAIL exception handling을 해제하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent를 탐색합니다.

  3. ExceptionHandling을 두 번 클릭합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

ExceptionHandling 레지스트리 값에 대한 자세한 내용은 기술 자료 문서 832174, "There is no option to turn off IMAIL exception handling in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832174)를 참조하십시오.


정보 저장소 서비스가 데스크톱과 상호 작용하도록 구성되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange System Attendant(MSExchangeSA) 서비스의 DesktopInteract 속성 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스가 데스크톱과 상호 작용하도록 구성되어 있으면 오류를 표시합니다.

이 구성은 Microsoft 기술 지원 서비스의 안내에 따라서만 사용되어야 합니다. Microsoft 기술 지원 서비스에서 이 구성으로 Microsoft Exchange Information Store 서비스를 실행하도록 지시하지 않았으면 데스크톱과 상호 작용하지 않도록 Microsoft Exchange Information Store 서비스 속성을 다시 구성하는 것이 좋습니다.

Exchange Information Store 서비스 계정을 구성하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. Microsoft Exchange Information Store 서비스를 찾아서 중지합니다.

  3. Microsoft Exchange Information Store 서비스를 두 번 클릭합니다.

  4. Microsoft Exchange Information Store 속성 페이지의 로그온 탭에서 다음 계정으로 로그온 아래의 로컬 시스템 계정을 선택합니다.

  5. 서비스와 데스크톱 상호 작용 허용 확인란의 선택을 해제한 다음 적용을 클릭합니다.

  6. 서비스 상태에서 시작을 클릭한 다음 확인을 클릭합니다.

  7. 서비스 스냅인을 닫습니다.

올바른 Exchange 서비스 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 239762, "Exchange Services Run Under LocalSystem"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)을 참조하십시오.


사서함 저장소의 최대 데이터베이스 크기 증가
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 정보를 확인할 때 CIM_DataFile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

  • Exchange 데이터베이스 파일의 전체 경로

  • 사서함 저장소의 현재 크기

또한 Exchange Server Analyzer는 다음과 같은 자세한 내용을 확인할 때 Win32_OperatingSystem WMI 클래스를 쿼리합니다.

  • Exchange 서버에서 실행 중인 Windows 운영 체제 버전

  • 설치된 Exchange Server 버전

  • 설치된 Exchange Server 에디션

  • Exchange Server의 서비스 팩 수준 버전

마지막으로 Exchange Server Analyzer는 다음 레지스트리 항목을 읽어서 Database Size in Gb 레지스트리 값이 설정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • 서버에서 Exchange Server 2003을 실행하고 있습니다.

  • 서비스에 Exchange Server 2003 서비스 팩 2가 설치되었습니다.

  • Exchange Server 데이터베이스 크기가 16GB를 초과합니다.

  • Database Size in Gb 레지스트리 값이 설정되지 않았습니다.

이 오류는 확인된 Exchange 데이터베이스가 크기 제한에 도달했음을 나타냅니다. Exchange Server 2003 서비스 팩 2에는 데이터베이스 저장소 제한이 16GB에서 75GB로 증가되었습니다. 그러나 새 제한을 사용하려면 Exchange Server에서 Database Size in Gb 레지스트리 값을 수동으로 추가해야 합니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
Database Size in Gb 레지스트리 값을 추가하여 이 오류를 해결하려면 다음을 수행합니다.

  1. Exchange Server를 실행하는 컴퓨터에서 Regedit.exe 또는 RegEdt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>로 이동합니다.

  3. MailboxStoreGUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  4. 새 값 이름으로 Database Size Limit in Gb를 입력합니다.

  5. Database Size Limit in Gb를 두 번 클릭합니다. 값 데이터에 최대 데이터베이스 크기(GB)에 적절한 값을 입력합니다. 확인를 클릭합니다.

  6. MailboxStoreGUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  7. 새 값 이름으로 Database Size Buffer in Percentage를 입력합니다.

  8. Database Size Buffer in Percentage를 두 번 클릭합니다. 값 데이터에 1에서 100 사이의 값을 입력하여 데이터베이스가 최대 크기에 가까워졌음을 경고하는 이벤트의 기록 시기를 지정합니다. OK를 클릭합니다.

    참고:
    기본값 10을 사용하면 해당 데이터베이스의 최대 크기까지 10% 용량이 남았을 때 경고 이벤트가 기록됩니다.

  9. MailboxStoreGUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  10. 새 이름으로 Database Size Check Start Time in Hours From Midnight를 입력합니다.

  11. Database Size Check Start Time in Hours From Midnight를 두 번 클릭합니다. 값 데이터에 0에서 23 사이의 값을 입력하여 Exchange에서 데이터베이스 크기를 확인하는 시기를 지정합니다. OK를 클릭합니다.

    참고:
    기본값 5를 사용하면 Exchange Server가 자정 이후 5시간(05:00)이 지나면 데이터베이스 크기를 확인합니다.

  12. 레지스트리 편집기를 닫습니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server 데이터베이스 크기 제한을 구성 및 관리하는 방법에 대한 자세한 내용은 "Database Size Limit Configuration and Management"(http://go.microsoft.com/fwlink/?LinkId=57029)를 참조하십시오.

Exchange Server 2003 Standard Edition 및 Exchange 2000 Server Standard Edition의 최대 데이터베이스 크기에 대한 자세한 내용은 기술 자료 문서 828070, "사서함 저장소 데이터베이스가 16GB 제한에 도달하면 Exchange Server 사서함 저장소가 탑재되지 않는다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070)를 참조하십시오.

Exchange Server 2003용 SP2에 대한 자세한 내용은 Exchange Server 2003 서비스 팩 2 웹 사이트 "Why Try Service Pack 2 for Exchange Server 2003?" (http://go.microsoft.com/fwlink/?LinkId=52073)을 참조하십시오.


공용 폴더 저장소의 최대 데이터베이스 크기를 늘리십시오.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 CIM_DataFile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 다음 정보를 확인합니다.

  • Exchange Server 데이터베이스 파일의 전체 경로.

  • 공용 폴더 저장소의 현재 크기.

또한 Exchange Server Analyzer는 Win32_OperatingSystem WMI 클래스를 쿼리하여 다음 추가 정보를 확인합니다.

  • Exchange 서버에 대해 실행 중인 Windows 운영 체제의 버전.

  • 설치되어 있는 Exchange Server의 버전.

  • 설치되어 있는 Exchange Server의 에디션.

  • Exchange Server의 서비스 팩 수준 버전.

마지막으로 Exchange Server Analyzer는 다음 레지스트리 항목을 읽어서 Database Size in Gb 값이 설정되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • 서버에서 Exchange Server 2003을 실행하고 있습니다.

  • 서비스에서 Exchange Server 2003 서비스 팩 2를 설치했습니다.

  • Exchange 데이터베이스 크기가 16GB보다 큽니다.

  • Database Size in Gb 레지스트리 값이 설정되어 있지 않습니다.

이 오류는 확인된 Exchange Server 데이터베이스가 크기 제한에 근접했음을 나타냅니다. Exchange Server 2003에 서비스 팩 2를 적용하면 데이터베이스 저장 용량 제한이 16GB에서 75GB로 늘어납니다. 그러나 새 제한을 사용하려면 수동으로 Exchange Server에서 Database Size in Gb 레지스트리 값을 추가해야 합니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 있습니다. 레지스트리를 편집하려면 먼저 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
Database Size in Gb 레지스트리 값을 추가하여 이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange Server를 실행 중인 컴퓨터에서 Regedit.exe 또는 RegEdt32.exe와 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>를 탐색합니다.

  3. PublicStoreGUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 다음 DWORD 값을 클릭합니다.

  4. 새 값 이름으로 Database Size Limit in Gb를 입력합니다.

  5. Database Size Limit in Gb를 두 번 클릭합니다. 값 데이터에 최대 데이터베이스 크기(GB)에 적절한 값을 입력합니다. 확인을 클릭합니다.

  6. PublicStoreGUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 다음 DWORD 값을 클릭합니다.

  7. 새 값 이름으로 Database Size Buffer in Percentage를 입력합니다.

  8. Database Size Buffer in Percentage를 두 번 클릭합니다. 값 데이터에 1에서 100 사이의 값을 입력하여 데이터베이스가 최대 크기에 가까워졌음을 경고하는 이벤트를 기록할 시점을 지정합니다. 확인을 클릭합니다.

    참고:
    기본값 10을 사용하면 해당 데이터베이스의 최대 크기까지 용량이 10% 남았을 때 경고 이벤트를 기록합니다.

  9. PublicStoreGUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 다음 DWORD 값을 클릭합니다.

  10. 새 이름으로 Database Size Check Start Time in Hours From Midnight를 입력합니다.

  11. Database Size Check Start Time in Hours From Midnight를 두 번 클릭합니다. 값 데이터에 0에서 23 사이의 값을 입력하여 Exchange에서 데이터베이스 크기를 확인하는 시점을 지정합니다. 확인을 클릭합니다.

    참고:
    기본값 5를 사용하면 Exchange Server가 자정 이후 5시간(05:00)이 지나면 데이터베이스 크기를 확인합니다.

  12. 레지스트리 편집기를 닫습니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange 데이터베이스 크기 제한 구성 및 관리 방법에 대한 자세한 내용은 "Database Size Limit Configuration and Management"(http://go.microsoft.com/fwlink/?LinkId=57029)를 참조하십시오.

Exchange Server 2003 Standard Edition 및 Exchange 2000 Server Standard Edition의 최대 데이터베이스 크기에 대한 자세한 내용은 기술 자료 문서 828070, "사서함 저장소 데이터베이스가 16GB 제한에 도달하면 Exchange Server 사서함 저장소가 탑재되지 않는다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070)를 참조하십시오.

Exchange Server 2003용 SP2에 대한 자세한 내용은 Exchange Server 2003 서비스 팩 2 웹 사이트, "Why Try Service Pack 2 for Exchange Server 2003?" (http://go.microsoft.com/fwlink/?LinkId=52073)을 참조하십시오.


트랜잭션 로그의 로그 버퍼 설정 증가
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 서버의 로그 버퍼 수가 너무 낮음을 확인했습니다. 또한 서버의 Database(Information Store Instance)\Log Record Stalls/sec 값이 초당 10개 지연보다 크다는 것을 확인했습니다. 10보다 큰 값은 트랜잭션 로그에 쓰고 있는 백업이 있음을 나타냅니다. 트랜잭션 로그 드라이브가 처리량을 초과하거나 로그 버퍼가 너무 낮게 설정되어 있으면 이 문제가 발생할 수 있습니다.

로그 쓰기 입/출력은 순차적이고 단일 스레드이므로 로그 입/출력 대기 시간으로 인해 시스템에 병목 현상이 자주 발생합니다. 먼저 로그 입/출력이 로그 버퍼에 쓰여진 다음 비지연 커밋이나 용량 커밋이 해당 버퍼를 지웁니다. 비지연 커밋은 로그 버퍼가 디스크에 즉시 쓰여짐을 의미합니다. 용량 커밋은 로그 버퍼가 가득찰 때 디스크에 쓰여짐을 의미합니다.

로그 버퍼 크기가 증가하면 용량 플러시 빈도가 감소하고 로그 쓰기 크기가 증가하고 순차적으로 전체 로그 쓰기 대기 시간이 줄어듭니다. 로그 입/출력 쓰기 대기 시간을 줄이면 Exchange 배포의 성능/확장성이 크게 향상됩니다.

일반적으로 Exchange Server 2003의 경우 최대 9,000까지, Exchange 2000 Server의 경우 512까지 버퍼 크기를 증가시키는 것이 좋습니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 경고를 해결하려면 다음을 수행합니다.

  1. ADSI 편집을 시작합니다.

  2. 구성 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=ExchangeOrganizationName을 차례로 확장합니다.

  3. CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers를 차례로 확장합니다.

  4. CN=ExchangeServerName, CN=InformationStore를 차례로 확장한 다음 CN=Storage Group Name을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  5. Select a property to view 상자에서 msExchESEParamLogBuffers를 클릭합니다.

  6. Edit Attribute 상자의 msExchESEParamLogBuffers에 Exchange 버전에 해당하는 값을 입력한 다음 Set을 클릭합니다.

    참고:
    Exchange 2000 Server, Exchange 2000 Server 서비스 팩 1(SP1), Exchange 2000 Server SP2 또는 Exchange 2000 SP3을 실행하는 컴퓨터의 경우 값을 512로 설정합니다. Exchange Server 2003의 원래 릴리스 버전 또는 Exchange Server 2003 SP1을 실행하는 컴퓨터의 경우에는 값을 9,000으로 설정합니다.

  7. 적용을 클릭한 다음 확인을 클릭합니다.

추가 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange 서버 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 로그 버퍼링 작업에 대한 자세한 내용은 Microsoft 기술 자료 문서 "ESE log buffers that are set too low can cause the Microsoft Exchange Information Store service to stop responding"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328466)을 참조하십시오.


Initial memory percentage가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Initial Memory Percentage 값을 설정했는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 Initial Memory Percentage 값이 0보다 큰 값으로 구성된 경우 기본 구성이 아니라는 메시지를 표시합니다.

Initial Memory Percentage 레지스트리 설정은 Exchange 정보 저장소에 할당된 초기 메모리 양을 해당 Exchange 서버의 전체 실제 메모리 중 10%까지 미세 조정하기 위한 메커니즘으로서 도입되었습니다. 이 초기 할당에서 시작하여 점점 증가시키면 가상 메모리 조각화가 자주 발생하지 않습니다. 이 레지스트리 값을 임의로 설정하지 않아야 하며 Microsoft 기술 지원 서비스(PSS)의 권고와 지시에 따라서만 사용해야 합니다.

Exchange Server 2003 이상의 Exchange Server 버전에는 가상 메모리 조각화를 줄이기 위한 Microsoft Windows® 2000 Advanced Server와 Windows Server™ 2003의 특수 시작 스위치도 지원하며 Exchange Server 클러스터의 가상 메모리 조각화를 방지하는 변경 사항이 추가되었습니다. 따라서 Exchange Server 2003 이상의 Exchange Server 버전에서는 Initial Memory Percentage 레지스트리 값이 더 이상 필요하지 않습니다.

Initial Memory Percentage 레지스트리 값은 Exchange 2000 Server를 실행하는 컴퓨터에서만 작동합니다. Exchange Server 2003 및 Exchange Server 2007에서는 이 값이 있어도 무시하며 이 값은 영향을 주지 않습니다. 따라서 이 Exchange Server를 Exchange 2000 Server에서 Exchange Server 2003으로 업그레이드하기 전에 이 레지스트리 항목을 제거해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Initial Memory Percentage 레지스트리 설정을 제거하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 오른쪽 창에서 Initial Memory Percentage 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.
  • 이 레지스트리 값을 사용할 경우의 알려진 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 810883, "'Initial Memory Percentage' Registry Value Has No Effect"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810883)를 참조하십시오.

  • 레지스트리를 편집하기 전 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=256986)을 참조하십시오.


Initial Reserve Size KB 레지스트리 항목이 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-04-27

Microsoft® Exchange Server Analyzer Tool은 Initial Reserve Size KB 레지스트리 항목이 설정되어 있는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Exchange Server Analyzer는 Initial Reserve Size KB 레지스트리 값이 0보다 큰 값으로 구성되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

Initial Reserve Size KB 레지스트리 값은 힙 공간을 위한 별도의 추가 메모리를 설정하는 데 사용됩니다. 값은 킬로바이트 단위로 지정됩니다. 대부분의 Exchange 서버에서 기본값은 655360KB이며, 이 값은 640MB와 같습니다. 이 값을 줄여 사용 가능한 메모리를 늘리고 가상 메모리 조각화를 줄일 수 있습니다. 이 값은 Microsoft 기술 지원 서비스의 기술 지원 전문가의 안내나 지시에 따라서만 설정해야 합니다. 이 메시지는 정보를 제공하기 위한 메시지이며 Microsoft 기술 지원 서비스의 기술 지원 전문가의 안내에 따라 이 레지스트리 값을 추가한 경우에는 별도의 수정 조치가 필요하지 않습니다.

이 항목을 잘못 설정한 경우에는 값을 제거하고 기본 구성으로 되돌릴 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성 설정으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem을 탐색합니다.

  3. Initial Reserve Size KB라는 값을 삭제합니다.

  4. 레지스트리 편집기를 닫은 다음 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

가상 메모리 조각화 문제 해결에 대한 자세한 내용은 기술 자료 문서, "HOWTO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)을 참조하십시오.


이 Exchange 데이터베이스에 대한 legacyExchangeDN이 Exchange 서버와 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터의 모든 사서함 저장소 데이터베이스에 대한 legacyExchangeDN 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 임의의 사서함 저장소에 대한 legacyExchangeDN 특성 값이 해당 사서함 저장소가 설치된 Exchange Server 컴퓨터와 일치하지 않을 경우 오류를 표시합니다.

관리자가 재해 복구 상황에서 데이터베이스를 복구할 때 Active Directory를 수정하면 legacyExchangeDN이 일치하지 않을 수 있습니다. 이 오류를 해결하려면 LDP(ldp.exe) 도구 또는 ADSI(Active Directory Service Interfaces) 편집과 같은 Active Directory 편집기를 사용하여 legacyExchangeDN 특성을 수정해야 합니다.

이 데이터베이스는 해당 서버의 하위 개체로서 서버와 동일한 legacyExchangeDN 특성 값을 가지므로 legacyExchangeDN 특성이 올바른지 확인할 때 데이터베이스가 포함된 서버의 legacyExchangeDN 특성을 검토해야 합니다.

이 오류를 생성하지 않았더라도 해당 Exchange Server의 다른 데이터베이스도 동일한 legacyExchangeDN 특성 값을 가지므로 함께 검토해야 합니다. 다른 여러 시스템 개체에도 이 특성이 설정되어 있습니다. legacyExchangeDN 특성이 한 데이터베이스에서 일치하지 않으면 다른 여러 시스템 개체에서도 일치하지 않을 수 있습니다. 따라서 legacyExchangeDN 값을 수정할 때 LDP나 ADSI 편집을 사용하면 모든 다른 시스템 개체에 대해서도 같은 방법으로 이 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집 같은 Active Directory 편집기를 엽니다.

  2. Configuration [DomainName]을 확장한 다음 CN=Configuration,DC=DomainName,DC=DomainSuffix를 확장합니다.

  3. CN=Services, CN=Microsoft Exchange를 차례로 확장합니다.

  4. CN=OrganizationName, CN=Administrative Groups 및 CN=AdminGroupName을 차례로 확장합니다.

  5. CN=Servers, CN=ServerName 및 CN=InformationStore를 차례로 확장합니다.

  6. CN=StorageGroupName을 선택한 다음 오른쪽 창에서 legacyExchangeDN 특성이 일치하지 않는 사서함 저장소를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  7. 아래로 스크롤하여 legacyExchangeDN을 선택하고 Edit을 클릭합니다.

  8. 값 필드에 올바른 legacyExchangeDN을 입력합니다.

  9. Active Directory 편집기를 닫고 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

ADSI 편집을 사용하여 새 legacyExchangeDN 특성 값을 만드는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서, "How to Change the LegacyExchangeDN Attribute in Native Mode with ADSI Edit"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863)를 참조하십시오.


이 Exchange 데이터베이스에 legacyExchangeDN 값이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터의 모든 사서함 저장소 데이터베이스에 대한 legacyExchangeDN 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 legacyExchangeDN 특성 값이 설정되지 않은 사서함 저장소가 있는 경우 오류를 표시합니다.

재해 복구 상황에서 관리자가 데이터베이스를 복구하기 위해 Active Directory를 수정한 경우에 legacyExchangeDN 값이 삭제될 수 있습니다. 이 오류를 해결하려면 LDP(ldp.exe) 도구 또는 ADSI(Active Directory Service Interfaces) 편집과 같은 Active Directory 편집기를 사용하여 legacyExchangeDN 특성을 수정해야 합니다.

이 데이터베이스는 해당 서버의 하위 개체로서 서버와 동일한 legacyExchangeDN 특성 값을 가지므로 legacyExchangeDN 특성이 올바른지 확인할 때 데이터베이스가 포함된 서버의 legacyExchangeDN 특성을 검토해야 합니다.

이 오류를 생성하지 않았더라도 해당 Exchange Server의 다른 데이터베이스도 동일한 legacyExchangeDN 특성 값을 가지므로 함께 검토해야 합니다. 다른 몇 가지 시스템 개체에도 이 특성이 있습니다. 데이터베이스에 legacyExchangeDN 특성이 없으면 몇 가지 다른 시스템 개체에서도 해당 특성이 누락되었을 가능성이 큽니다. 따라서 LDP 또는 ADSI 편집을 사용하여 새 legacyExchangeDN 값을 추가한 경우 다른 모든 시스템 개체에 대해서도 동일한 작업을 수행해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 엽니다.

  2. [DomainName] Configuration을 확장하고 CN=Configuration,DC=DomainName,DC=DomainSuffix를 확장합니다.

  3. CN=Services, CN=Microsoft Exchange를 차례로 확장합니다.

  4. CN=OrganizationName, CN=Administrative Groups 및 CN=AdminGroupName을 차례로 확장합니다.

  5. CN=Servers, CN=ServerName 및 CN=InformationStore를 차례로 확장합니다.

  6. CN=StorageGroupName을 선택하고 오른쪽 창에서 legacyExchangeDN 특성이 설정되어 있지 않은 사서함 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  7. 아래로 스크롤하여 legacyExchangeDN을 찾아 선택하고 Edit를 클릭합니다.

  8. 값 필드에 올바른 legacyExchangeDN을 입력합니다.

  9. Active Directory 편집기를 닫고 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

ADSI 편집을 사용하여 새 legacyExchangeDN 특성 값을 만드는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서, "How to Change the LegacyExchangeDN Attribute in Native Mode with ADSI Edit"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863)를 참조하십시오.


LimitBodyParts 매개 변수가 수동으로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 메시지 첨부 파일의 기본 제한이 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\LimitBodyParts

Exchange Server Analyzer는 LimitBodyParts 레지스트리 항목이 구성되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server에서는 설계에 따라 그리고 보안상의 이유로 첨부 파일 수(본문이라고 함)를 250으로 제한합니다. 메시지에 250개가 넘는 첨부 파일이 포함되어 있으면 MAPI_E_TOO_BIG 오류가 생성됩니다. 또한 Microsof Exchange Information Store 서비스는 많은 수의 첨부 파일이 있는 메시지를 처리하는 동안 메모리와 CPU 리소스를 과도하게 소모할 수 있습니다.

관리자가 LimitBodyParts 레지스트리 값을 추가하고 이 값이 250보다 큰 값을 사용하도록 구성할 수 있는 항목이 있습니다. 이 항목이 없으면 기본값인 250이 사용됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

LimitBodyParts 레지스트리 값을 보거나 변경하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음을 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. LimitBodyParts 값을 검사하고 필요한 경우 변경합니다. 이 레지스트리 값으로 사용할 수 있는 값은 250에서 4,294,967,295까지의 정수입니다.

  4. 레지스트리 내용을 변경했으면 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


LimitEmbeddingDepth 매개 변수가 수동으로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-30

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange의 기본 MIME 헤더 제한이 변경되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Exchange Server Analyzer는 LimitEmbeddingDepth 값이 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

Exchange 2000 Server 서비스 팩 3과 Exchange Server 2003 및 Exchange Server 2007에서는 크거나 형식이 잘못된 MIME을 처리하는 방법을 정의하는 정보 저장소 프로세스(store.exe)에 업데이트된 기능이 있습니다. 이 기능은 악의적이거나 고의가 아닌 크고 복잡한 MIME 메시지의 서비스 거부 공격(DoS)으로부터 Exchange Server를 보다 강력하게 보안하기 위해 추가되었습니다. 저장소에 전송되는 MIME 메시지에 적용되는 제한 사항으로는 받는 사람 수 제한, 포함 메시지 수 제한, 개별 MIME 헤더 크기 제한 등이 있습니다.

이러한 여러 가지 MIME 헤더 제한 사항에 대한 기본값은 저장소 프로세스에서 설정됩니다. 그러나 레지스트리 키가 이러한 제한 중 하나를 정의하도록 설정되어 있는 경우 레지스트리 키는 기본 store.exe 값을 무시합니다. MIME 메시지에서 여러 가지 제한 사항 중 하나를 초과할 경우 보낸 사람에게 배달 못 함 보고서(NDR)가 전송됩니다.

MIME의 포함 깊이 제한은 서로에 포함될 수 있는 MIME 메시지 수를 참조합니다. 예를 들어 m2 메시지가 첨부된 m1 메시지를 받는 경우를 가정해 보십시오. 첨부된 메시지(m2)를 열면 이 메시지(m2)에도 첨부된 메시지(m3)가 있음을 알게 됩니다. 따라서 원본 메시지(m1)에 3 깊이 수준까지 포함된 메시지가 있습니다. 기본적으로 Exchange에서는 메시지에 100 깊이 수준까지 포함할 수 있습니다. 100 깊이 수준을 초과하는 포함 메시지가 있는 메시지는 서버에서 해당 메시지를 "풀어(un-wrap)" 구문을 분석하고 MAPI로 변환하는 시간 동안 Exchange 서버의 메모리를 모두 사용할 수 있습니다. 전자 메일 클라이언트나 서버가 그러한 포함 메시지 깊이를 가진 메시지를 생성할 가능성은 거의 없습니다. 그보다는 악의적인 사용자가 메시징 시스템에서 DoS(Denial-Of-Service) 공격을 시도한 결과로 그러한 메시지가 생성될 가능성이 더 높습니다.

기본 구성으로 되돌리려면 다음을 수행합니다.

  • 이 경우 수행해야 할 작업은 없습니다. 이 레지스트리 항목은 Microsoft 기술 자료 문서 833607, "The Microsoft Exchange Information Store service uses 100 percent of the CPU resources on an Exchange 2000 Server or an Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=833607)의 핫픽스를 설치한 경우에만 존재합니다. 이 핫픽스는 LimitEmbeddingDepth 레지스트리 항목을 만들어서 값 10으로 설정합니다.

Exchange Server 서비스 팩과 핫픽스에 대한 자세한 내용은 기술 자료 문서 328839, "HOWTO: Exchange 서비스 팩 및 핫픽스 적용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839)을 참조하십시오.


LimitNestingLevels 매개 변수가 수동으로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 Exchange의 기본 MIME(Multipurpose Internet Mail Extensions) 헤더 제한 사항이 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Exchange Server Analyzer는 LimitNestingLevels에 대한 값이 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

한 메시지 항목 내에서 MIME 본문 부분이 여러 개 중첩될 수 있습니다. 중첩 수준이 높으면 변환 프로세스는 전체 메시지를 디코딩하는 데 더 많은 리소스을 필요로 합니다. 단일 메시지에 MIME 본문 부분이 700 수준으로 중첩되면 해당 메시지를 처리하는 데 최대 10분이 걸립니다. 인터넷에서 받은 메시지에 중첩된 MIME 본문 부분이 있으면 MIME 본문 부분의 변환 프로세스 때문에 이러한 메시지의 배달이 늦어질 수 있습니다. 메시지를 배달할 때 서버는 대용량 시스템 리소스, 특히 메모리를 필요로 합니다. 이러한 메시지를 동시에 너무 많이 받으면 시스템이 가상 메모리 부족 상태를 보고할 수 있습니다.

Exchange Server는 서로 중첩될 수 있는 MIME 콘텐츠 형식(예: multipart/mixed 또는 multipart/alternative) 수를 참조하여 MIME 중첩 수준을 제한합니다. 대부분의 전자 메일 클라이언트(Microsoft Outlook® 및 Outlook Express 포함)와 전자 메일 서버에 의해 생성된 메시지에는 중첩된 MIME 콘텐츠 형식이 거의 없습니다. 예를 들어 여러 개의 회신이 포함되더라도 일반 메시지는 MIME 메시지에 단일 콘텐츠 형식으로만 표시됩니다. 높은 중첩 수준은 보통 자동 프로세스가 워크플로 응용 프로그램 같은 특정 프로그램용으로 MIME 메시지를 작성하기 때문에 발생하거나 메일 서버의 리소스를 소비할 목적으로 만들어진 악의적인 메시지 때문에 발생합니다.

Exchange Server는 콘텐츠 형식에 따라 중첩 수준을 적용하고 레지스트리 값이나 저장소 프로세스의 기본값으로 정의된 LimitNestingLevels 값에 따라 포함 메시지에 제한을 적용합니다. LimitNestingLevels 레지스트리 값이 정의되어 있지 않으면 기본값 30 중첩 수준이 적용됩니다. 포함 메시지 한계는 LimitNestingLevels 값에 16을 곱한 값으로 정의됩니다. 따라서 기본 포함 메시지 수는 480개입니다. 예를 들어 LimitNestingLevels 값을 5로 구성하면 최대 80개의 첨부 파일을 받을 수 있습니다.

기본 구성으로 되돌리려면 다음을 수행합니다.

  • 이 경우 수행해야 할 작업은 없습니다. Exchange Server Analyzer는 정보 제공 목적으로 기본 구성이 아니라는 메시지를 표시하고 있습니다.

LimitNestingLevels 레지스트리 값에 관련된 Exchange 2000 Server 핫픽스에 대한 자세한 내용은 Microsoft 기술 자료 문서 289775, "XADM: Exchange 2000 Server Experiences Memory Leaks Because of Many Embedded Messages"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=289775)를 참조하십시오.


LimitRecipients 매개 변수가 수동으로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange의 기본 MIME 헤더 제한이 변경되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Exchange Server Analyzer는 LimitRecipients 값이 설정되어 있는 경우 기본 구성이 아니라는 경고를 표시합니다.

Exchange 2000 Server 서비스 팩 2(SP2) 및 최신 버전의 Exchange Server에서는 크거나 형식이 잘못된 MIME을 처리하는 방법을 정의하는 저장소 프로세스(store.exe)에 업데이트된 기능이 있습니다. 악의적이고 비정상적인(지나치게 크고 복잡한) MIME 메시지에 의한 DoS(Denial-of-Service) 공격 대상이 되는 Exchange를 보다 안전하게 보호하기 위해 이 기능이 추가되었습니다. 저장소로 전송된 MIME 메시지에 부과된 제한의 예로는 받는 사람 수 제한, 포함된 메시지 수 제한, 개별 MIME 헤더 크기 제한 등이 있습니다. 이전 버전의 Exchange에서는 처리할 MIME 헤더가 무제한으로 Exchange 저장소에 들어갈 수 있으므로 지나치게 크거나 복잡한 MIME 메시지의 경우 MIME을 구문 분석, 인덱싱 및 처리하기 위해 거의 모든 리소스(주로 CPU)를 소비할 수 있습니다.

이러한 여러 가지 MIME 헤더 제한 사항에 대한 기본값은 저장소 프로세스에서 설정됩니다. 그러나 레지스트리 키가 이러한 제한 중 하나를 정의하도록 설정되어 있는 경우 레지스트리 키는 기본 store.exe 값을 무시합니다. MIME 메시지에서 다양한 제한 중 하나가 초과된 경우 배달 못 함 보고서(NDR)가 보낸 사람에게 보내집니다.

LimitRecipients 레지스트리 키가 설정된 경우 이 키는 게시되지 않았으므로 Microsoft 기술 지원 서비스의 제안을 받아서 설정한 것일 가능성이 있습니다. 따라서 이 설정은 변경하지 않는 것이 좋습니다.

저장소 프로세스에서 LimitRecipients의 기본값(레지스트리 키가 없는 경우)은 MIME 메시지당 65,535명의 받는 사람입니다.


Exchange Server 2003을 실행 중인 복제된 디스크 저장소가 있는 서버의 로그 버퍼가 최적화되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 다음 조건이 참인지 확인합니다.

  • 컴퓨터에서 Exchange Server 2003을 실행하고 있습니다.

  • msExchESEParamLogBuffers 값이 0에서 8,960 사이입니다.

Exchange Server Analyzer는 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 다음 조건이 참인지 확인합니다.

  • VMLargestBlockSize 값이 150,000,000보다 큽니다.

Exchange Server Analyzer는 다음 서비스 중 하나가 실행 중인지 확인합니다.

  • GeoSpanService

  • SRDFService

위의 모든 조건이 참이면 오류가 표시됩니다.

확장 가능한 저장소 엔진(ESE)은 트랜잭션을 트랜잭션 로그에 커밋하기 전까지 로그 버퍼를 사용하여 메모리에 트랜잭션을 유지합니다. 로그 버퍼가 부족하면 트랜잭션 로그 드라이브에서 과도한 디스크 I/O가 발생하여 성능이 감소하게 됩니다.

주의:
ADSI 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생될 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI(Active Directory Service Interfaces) 편집에서 Configuration 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=ExchangeOrganizationName을 차례로 확장합니다.

  2. CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers를 차례로 확장합니다.

  3. CN=ExchangeServerName, CN=InformationStore를 차례로 확장한 다음 CN=Storage Group Name을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  4. Select a property to view 상자에서 msExchESEParamLogBuffers를 클릭합니다.

  5. msExchESEParamLogBuffers의 Edit Attribute 상자에 9000을 입력한 다음 Set을 클릭합니다.

  6. Apply를 클릭한 다음 OK를 클릭합니다.

  7. 변경 사항을 적용하려면 Microsoft Exchange Information Store 서비스를 다시 시작해야 합니다.

자세한 내용은 Microsoft 기술 자료 문서 328466, "ESE log buffers that are set too low can cause the Microsoft Exchange Information Store service to stop responding"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466)을 참조하십시오.


Exchange Server 2003을 실행하는 서버에 사서함 수가 많은 경우 로그 버퍼가 부족할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-03-27

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 다음 조건이 참인지 확인합니다.

  • 컴퓨터에서 Exchange Server 2003을 실행하고 있는지 여부

  • msExchESEParamLogBuffers 값이 0에서 8,960 사이입니다.

  • 저장소 그룹에 있는 사서함 수가 500개를 넘습니다.

Exchange Server Analyzer는 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 다음 조건이 참인지 확인합니다.

  • VMLargestBlockSize 값이 150,000,000 이상입니다.

모든 조건이 참이면 경고가 표시됩니다.

확장 가능한 저장소 엔진(ESE)은 트랜잭션을 트랜잭션 로그에 커밋하기 전까지 로그 버퍼를 사용하여 메모리에 트랜잭션을 유지합니다. 로그 버퍼가 부족하면 트랜잭션 로그 드라이브에서 과도한 디스크 I/O가 발생하여 성능이 감소하게 됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. ADSI(Active Directory Service Interfaces) 편집에서 Configuration 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=ExchangeOrganizationName을 차례로 확장합니다.

  2. CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers를 차례로 확장합니다.

  3. CN=ExchangeServerName, CN=InformationStore를 차례로 확장한 다음 CN=Storage Group Name을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  4. Select a property to view 상자에서 msExchESEParamLogBuffers를 클릭합니다.

  5. msExchESEParamLogBuffers의 Edit Attribute 상자에 9000을 입력한 다음 Set을 클릭합니다.

  6. Apply를 클릭한 다음 OK를 클릭합니다.

  7. 변경 사항을 적용하려면 Microsoft Exchange Information Store 서비스를 다시 시작해야 합니다.
주의:
ADSI 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생될 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

자세한 내용은 Microsoft 기술 자료 문서 328466, "ESE log buffers that are set too low can cause the Microsoft Exchange Information Store service to stop responding"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466)을 참조하십시오.


로그 파일이 네트워크 드라이브에 저장되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 저장소 그룹 개체의 msExchESEParamLogFilePath 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성은 저장소 그룹의 데이터베이스에 사용되는 트랜잭션 로그 파일의 위치를 지정합니다.

또한 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열된 항목 개수를 확인할 때도 Active Directory를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다.

Exchange Server Analyzer는 50개 보다 많은 사서함을 포함하는 Exchange Server에서 msExchESEParamLogFilePath 특성이 \\로 시작할 경우 오류를 표시합니다.

이 오류는 저장소 그룹에 대한 트랜잭션 로그 파일이 네트워크 공유에 저장됨을 나타냅니다. msExchESEParamLogFilePath 특성이 \\로 시작되면 로그 파일 경로에 UNC(Universal Naming Convention) 경로가 사용되는 것입니다. 이러한 방식을 사용하면 네트워크 연결이 끊어질 때 트랜잭션 로그 및 데이터베이스 오류가 발생하여 데이터가 손실되거나 데이터베이스가 손상될 수 있으므로 권장되는 방법이 아닙니다. 이 문제는 가능한 빨리 해결하는 것이 좋습니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 네트워크 공유 위치에 있는 트랜잭션 로그를 로컬 디스크로 이동합니다. 최적의 성능을 위해서는 모든 트랜잭션 로그를 별도의 드라이브에 두십시오.

트랜잭션 로그를 다른 위치로 이동하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 239944, "XADM: 트랜잭션 또는 시스템 로그를 다른 위치로 이동하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=239944)을 참조하십시오.


로그 생성 불일치
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에서 로그 파일 생성 불일치가 있음을 확인했습니다. 이 오류는 트랜잭션 로그 파일의 이름이 부적절한 시퀀스 번호를 가진 이름으로 바뀌었음을 나타냅니다.

Exchange 트랜잭션 로그 파일 이름은 EnnXXXXX.log 형식으로 지정됩니다.

  • XXXXX = 5자리 16진수 시퀀스 번호입니다. 새 트랜잭션 로그 파일 집합이 생성될 때 시퀀스의 첫 번째 로그는 00001, 다음 로그는 00002와 같이 됩니다. 각 트랜잭션 로그는 자신의 시퀀스 번호를 자신의 헤더에 기록하므로 로그 파일 이름이 변경되었는지 여부를 확인할 수 있습니다.

  • Enn = 로그 접두사로 이 저장소 그룹에 대해 모든 트랜잭션 로그에서 공유하는 세 자리 문자 시퀀스입니다. 일반적으로 접두사는 E00, E01, E02, E03 또는 R00(복구 저장소 그룹의 경우)입니다.

현재 기록 중인 로그의 이름은 로그 접두사만 사용하여 이름을 지정합니다. 이 로그가 닫히고 새로운 현재 로그가 생성될 때까지 해당 로그는 시퀀스 번호를 가져오지 않습니다. 따라서 현재 로그 파일의 이름이 E00.log로 지정될 수 있습니다. 이 로그 파일이 꽉 차면 이름이 E0012345.log로 바뀔 수 있습니다. 새 E00.log는 내부 시퀀스 번호 12346를 사용하여 생성됩니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 로그 파일 이름을 적절한 시퀀스 번호로 바꿉니다.
내부 시퀀스 번호를 보려면 다음을 수행합니다.

  • 다음 명령을 실행합니다.

    C:\Program Files\Exchsrvr\Bin\Eseutil.exe /ML [log filename]

    이 명령의 출력에서 lGeneration 값은 해당 로그 파일의 실제 시퀀스 번호를 나열합니다.


로그 쌍이 일관되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 필요한 일부 로그 파일이 일관되지 않음을 확인했습니다. 이 오류는 로그 파일이 훼손되거나, 수동으로 이동하거나, 복사되거나, 삭제되거나, 이름이 바뀌었을 수 있음을 나타냅니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 로그 파일에 대한 고급 분석을 보려면 Microsoft 고객지원(http://go.microsoft.com/fwlink/?LinkId=31845)에 문의하십시오.


로그 서명 불일치
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool에서 하나 이상의 로그 파일에 있는 로그 서명이 같은 폴더에 있는 다른 로그 파일과 일치하지 않음을 확인했습니다.

로그 파일을 수동으로 이동하거나 삭제하거나 정렬을 해제하지 않는 한 이 문제가 발생하지 않습니다.

참고:
이 시나리오는 고급 복구 시나리오이므로 구현하기 전에 Microsoft 도움말 및 지원 센터(http://go.microsoft.com/fwlink/?LinkId=31845)로 문의할 수도 있습니다.

각 Exchange 트랜잭션 로그 파일은 로그 서명이라는 서명으로 스탬프 처리되어 있습니다. 이 서명으로 같은 로그 시리즈에 속하는 개별 로그 파일을 구분할 수 있습니다. 각 Exchange 데이터베이스는 해당 데이터베이스가 마지막으로 연결되었던 트랜잭션 로그 시리즈의 로그 서명을 기록합니다.

또한 Exchange 데이터베이스에는 DB 서명이라고 하는 서명도 있습니다. DB 서명은 데이터베이스를 처음 만들 때 생성됩니다. Eseutil을 사용하여 데이터베이스를 조각 모음하거나 복구하는 경우 복구 및 조각 모음 프로세스가 트랜잭션 로그에 변경 내용을 기록하지 않고 데이터베이스 파일을 변경하므로 이 서명이 바뀝니다. 로깅 목적으로 복구 또는 조각 모음 작업 결과로 만들어진 데이터베이스는 새롭거나 다른 데이터베이스입니다.

로그 서명은 DB 서명과 달리 로그 파일 시리즈 수명 동안 결코 바뀌지 않습니다.

로그 파일은 로그가 만들어질 때 연결된 모든 데이터베이스의 DB 서명을 기록합니다. 데이터베이스는 해당 데이터베이스가 연결되었던 최신 로그 시리즈의 로그 서명을 기록합니다. 따라서 DB 및 로그 서명은 데이터베이스를 트랜잭션 로그 파일과 일치시키는 데 유용합니다.

하나의 로그 집합에서 Exchange 데이터베이스를 분리하여 다른 로그 집합에 연결할 수 있습니다. 이렇게 하려면 데이터베이스를 다른 저장소 그룹으로 옮기거나 저장소 그룹에 대한 트랜잭션 로그를 모두 제거하고 새로운 로그 시리즈를 시작합니다.

데이터베이스가 부적절하게 종료된 상태인 경우 데이터베이스 헤더의 로그 서명과 일치하는 서명을 가진 트랜잭션 로그 파일만 성공적으로 데이터베이스로 재생될 수 있습니다. 부적절하게 종료된 상태인 경우 데이터베이스는 여전히 특정 로그 스트림에 연결되어 있어 해당 로그 스트림만 가지고 복구를 수행할 수 있습니다.

데이터베이스가 완전하게 종료된 상태인 경우 데이터베이스 헤더의 현재 로그 서명과 일치하는 서명이 없는 트랜잭션 로그 파일을 재생할 수 있습니다. 이 작업은 다음과 같은 상황에서만 수행할 수 있습니다.

  1. 데이터베이스가 이전 로그 파일 시퀀스의 끝에서 올바르게 종료되었습니다.

  2. 그런 다음 데이터베이스가 새로운 트랜잭션 로그 파일의 시퀀스에 연결되었고 데이터베이스가 처음으로 연결된 새 로그 집합을 포함하는 트랜잭션 로그에 액세스할 수 있는 권한이 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 데이터베이스의 기록 및 데이터베이스에 관해 트랜잭션 로그가 생성되는 상황을 알아야 합니다.

  • 이런 상황에서는 복구를 시도하기 전에 항상 트랜잭션 로그와 데이터베이스 파일의 복사본을 만듭니다. 잘못된 복구 시도는 다른 복구 시도에서 수행할 수 없는 방식으로 트랜잭션 로그 또는 데이터베이스 파일을 변경할 수 있습니다.

  • 데이터베이스를 사용해서 한 번에 하나의 트랜잭션 로그 집합만 재생합니다. 다른 트랜잭션 로그를 복구 폴더에서 옮깁니다.

  • 데이터베이스가 부적절하게 종료된 상태인 경우 먼저 데이터베이스가 연결된 트랜잭션 로그를 재생하고 데이터베이스를 완전하게 종료된 상태로 만듭니다. 그런 다음 데이터베이스를 사용해서 두 번째 로그 파일 집합을 재생할 수 있습니다.

  • 데이터베이스가 완전하게 종료된 상태인 경우 먼저 재생할 트랜잭션 로그 집합을 명확하게 확인하기 위해 로그나 데이터베이스를 검사할 수 없습니다.


특정 사용자에 대한 로그온이 제한되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange 정보 저장소에 대한 로그온이 허용된 사용자가 제한되어 있는지 확인할 때 Exchange Server 컴퓨터에서 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Logon Only As

Exchange Server Analyzer는 Logon Only As 레지스트리 값이 있으면 경고를 표시합니다.

Logon Only As 레지스트리 값은 Exchange 정보 저장소에 대한 로그온 권한이 있는 계정의 legacyExchangeDN 특성 목록이 포함된 다중 문자열 값(REG_MULTI_SZ)입니다. 이 레지스트리 값은 기본적으로 설정되어 있지 않으며 일반적으로 문제 해결, 유지 관리 및 사서함 이동 작업을 수행하는 동안 추가됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 오른쪽 창에서 Logon Only As 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)을 참조하십시오.

Logon Only As 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 146764, "XADM: Limiting Logons to the Information Store"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=146764)를 참조하십시오.

사서함 이동 작업을 수행하는 동안 로그온을 제한하는 방법에 대한 자세한 내용은 기술 자료 문서 218920, "XADM: How to Prevent Logons During Move Mailbox"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=218920)를 참조하십시오.


Lookup SID Cache Expire 레지스트리 값이 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Lookup Sid Cache Expire 레지스트리 항목이 있는지 여부를 확인할 때 다음 레지스트리 키를 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 다음 조건이 존재하는 경우 기본 구성이 아니라는 메시지를 표시합니다.

  • Lookup Sid Cache Expire 레지스트리 항목이 있습니다.

  • Lookup Sid Cache Expire 레지스트리 항목에 3,600 이외의 값이 있습니다.

Exchange 2000 Server 서비스 팩 3 이상을 실행하는 Exchange 서버의 정보 저장소에서는 보안 식별자(SID)가 포함된 캐시를 만들고 SID가 사용자 개체 또는 그룹 개체인지 여부를 나타냅니다. 이 캐시는 공용 폴더가 처음 액세스될 때 만들어지고 채워집니다. 캐시가 채워진 후 계정 SID를 검색하는 모든 호출은 먼저 정보 저장소 캐시로 전달됩니다. 정보 저장소 캐시에 SID가 없으면 도메인 컨트롤러가 호출된 후 해당 SID의 정보가 캐시에 추가됩니다.

기본적으로 캐시는 1시간 동안 유지됩니다. 캐시 항목이 기본 8KB를 초과하면 새 항목을 만들 공간을 확보하기 위해 기존 캐시 항목이 제거됩니다. 두 레지스트리 키를 사용하면 기본 캐시 시간(Lookup Sid Cache Expire) 및 기본 캐시 크기(Lookup Sid Cache Size)를 모두 조정할 수 있습니다. 변경을 통해 성능이 향상된다고 확신할 수 있는 경우가 아니면 이러한 기본 설정을 변경하지 않는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate를 탐색합니다.

  3. 오른쪽 창에서 Lookup Sid Cache Expire 값을 찾아 삭제합니다. Lookup SID Cache Size 값이 설정되어 있으면 이 값도 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Lookup Sid Cache Expire 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 328907, "XADM: Access Control List Upgrades Cause Slow Public Folder Performance; Fix Requires Exchange 2000 SP2"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907)를 참조하십시오.


Lookup SID Cache Size 레지스트리 값이 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Lookup Sid Cache Size 레지스트리 항목이 있는지 여부를 확인할 때 다음 레지스트리 키를 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 다음 조건이 존재하는 경우 기본 구성이 아니라는 메시지를 표시합니다.

  • Lookup Sid Cache Size 레지스트리 항목이 있습니다.

  • Lookup Sid Cache Size 레지스트리 항목에 1,024 이외의 값이 있습니다.

Exchange 2000 Server 서비스 팩 3 이상을 실행하는 Exchange 서버의 정보 저장소에서는 보안 식별자(SID)가 포함된 캐시를 만들고 SID가 사용자 개체 또는 그룹 개체인지 여부를 나타냅니다. 이 캐시는 공용 폴더가 처음 액세스될 때 만들어지고 채워집니다. 캐시가 채워진 후 계정 SID를 조회하는 모든 호출은 먼저 정보 저장소 캐시로 전달됩니다. 정보 저장소 캐시에 SID가 없으면 도메인 컨트롤러가 호출된 후 해당 SID의 정보가 캐시에 추가됩니다.

기본적으로 캐시는 1시간 동안 유지됩니다. 캐시 항목이 기본 8KB를 초과하면 새 항목을 만들 공간을 확보하기 위해 기존 캐시 항목이 제거됩니다. 두 레지스트리 키를 사용하면 기본 캐시 시간(Lookup Sid Cache Expire) 및 기본 캐시 크기(Lookup Sid Cache Size)를 모두 조정할 수 있습니다. 변경을 통해 성능이 향상된다고 확신할 수 있는 경우가 아니면 이러한 기본 설정을 변경하지 않는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate를 탐색합니다.

  3. 오른쪽 창에서 Lookup Sid Cache Size 값을 찾아 삭제합니다. Lookup SID Cache Expire 값이 설정되어 있으면 이 값도 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Lookup Sid Cache Size 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 328907, "XADM: Access Control List Upgrades Cause Slow Public Folder Performance; Fix Requires Exchange 2000 SP2"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907)를 참조하십시오.


낮은 가상 메모리 오류 이벤트가 다시 정의되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 가상 메모리 조각화에 대한 이벤트 로깅 임계값이 수동으로 다시 정의되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Error Level

Exchange Server Analyzer는 VM Error Level 레지스트리 값이 존재하며 구성된 경우 기본 구성이 아니라는 메시지를 표시합니다.

32비트 Microsoft Windows® 시스템에는 실제 메모리(시스템에 설치된 실제 메모리 양)와 가상 메모리 주소 공간(가상화된 4GB 메모리 공간)이라는 두 종류의 메모리가 있습니다. 해당 시스템에 설치되어 있는 실제 메모리 양에 관계없이 전체 가상 주소 공간 크기는 항상 4GB로 동일합니다. 모든 32비트 응용 프로그램에 적용되는 것은 아니지만 Exchange Server의 경우 가상 주소 공간은 가상 메모리와 동일합니다. 즉, 두 용어를 같은 의미로 사용할 수 있습니다.

Exchange 정보 저장소는 정상적인 작업 중에 가상 메모리를 반복적으로 할당, 사용 및 할당 취소합니다. 자주 가상 메모리를 할당하고 사용한 다음 할당을 취소하면 가상 메모리가 조각화될 수 있습니다. 가상 메모리 조각화는 시간이 지나면서 발생할 수 있는 파일 시스템 조각화와 유사합니다. 어느 정도 시간이 지나면 할당된 가상 메모리 세그먼트가 더 이상 연속되지 않아 성능이 저하됩니다. 파일 시스템의 경우 파일 시스템 조각 모음을 수행하는 응용 프로그램을 실행할 수 있으며 시스템이 온라인 상태이고 액세스가 가능한 대부분의 시간 동안 이 작업을 수행할 수 있습니다. 가상 메모리 조각화가 발생할 경우 조각 모음 도구는 없습니다. 이 문제를 해결하려면 Exchange Information Store 서비스를 중지했다가 시작하거나 시스템을 다시 부팅해야 합니다.

Exchange Server 컴퓨터에 사용 가능한 연속 가상 주소 공간이 16MB 미만인 경우 다음 오류 메시지가 응용 프로그램 이벤트 로그에 기록됩니다.

원본: | MSExchangeIS
범주: | 성능
이벤트 ID: | 9582
유형: | 오류
설명: | 현재 Exchange 서버 실행에 필요한 가상 메모리가 정상 작업을 시작할 수 없도록 조각화되어 있습니다. Exchange 서비스를 모두 다시 시작하여 이 문제를 해결하는 것이 좋습니다.

VM Error Level 레지스트리 값을 사용하여 관리자는 기본 16MB 수준 경고를 무시하고 다른 값으로 설정할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음을 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 오른쪽 창에서 VM Error Level 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

Exchange Server 2003 및 Exchange 2000 Server의 가상 메모리 조각화 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)을 참조하십시오.


낮은 가상 메모리 경고 이벤트가 다시 정의되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 가상 메모리 조각화에 대한 이벤트 로깅 임계값이 수동으로 다시 정의되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Warning Level

Exchange Server Analyzer는 VM Warning Level 레지스트리 값이 제공 및 구성된 경우 기본 구성이 아니라는 메시지를 표시합니다.

32비트 Microsoft Windows® 시스템에는 실제 메모리(시스템에 설치된 실제 메모리 양)와 가상 메모리 주소 공간(가상화된 4GB 메모리 공간)이라는 두 종류의 메모리가 있습니다. 해당 시스템에 설치되어 있는 실제 메모리 양에 관계없이 전체 가상 주소 공간 크기는 항상 4GB로 동일합니다. 모든 32비트 응용 프로그램에 적용되는 것은 아니지만 Exchange Server의 경우 가상 주소 공간은 가상 메모리와 동일합니다. 즉, 두 용어를 같은 의미로 사용할 수 있습니다.

Exchange 정보 저장소는 정상적인 작업 중에 가상 메모리를 반복적으로 할당, 사용 및 할당 취소합니다. 가상 메모리를 할당하고 사용한 다음 할당을 취소하는 것을 자주 하면 가상 메모리가 조각화될 수 있습니다. 가상 메모리 조각화는 시간이 지나면서 발생할 수 있는 파일 시스템 조각화와 유사합니다. 어느 정도 시간이 지나면 할당된 가상 메모리 세그먼트가 더 이상 연속적이지 않아 성능이 저하됩니다. 파일 시스템의 경우 파일 조각 모음을 수행하는 응용 프로그램을 실행할 수 있습니다. 일반적으로 시스템이 온라인으로 액세스되고 있는 중에도 이를 수행할 수 있습니다. 가상 메모리 조각화의 경우 별도의 조각 모음 도구는 없습니다. 대신 이 문제를 해결하려면 Microsoft Exchange Information Stores 서비스를 중지했다가 시작하거나 시스템을 다시 시작해야 합니다.

기본적으로 Exchange Server에 사용 가능한 연속적인 가상 주소 공간이 32MB 미만인 경우 다음 경고 메시지가 응용 프로그램 이벤트 로그에 기록됩니다.

원본: | MSExchangeIS
범주: | 성능
ID: | 9582
종류: | 경고
설명: | Exchange 서버 실행에 필요한 가상 메모리가 조각화된 경우 성능에 영향을 줄 수 있습니다. 이 문제를 해결하려면 모든 Exchange 서비스를 다시 시작하는 것이 좋습니다.

VM Warning Level 레지스트리 값을 사용하여 관리자는 기본 32MB 수준 경고를 다시 정의하여 다른 값으로 설정할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 오른쪽 창에서 VM Warning Level 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

Exchange Server 2003 및 Exchange 2000 Server의 가상 메모리 조각화 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)을 참조하십시오.


Mailbox Cache Age Limit이 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-15

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 컴퓨터의 레지스트리를 조사하여 Mailbox Cache Age Limit 레지스트리 항목이 있는지 확인합니다. 이 레지스트리 값은 다음 위치에 있습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 Mailbox Cache Age Limit 레지스트리 항목이 존재하고 값이 1 이상일 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server에서는 사서함에 대한 크기 제한(할당량)을 설정할 수 있습니다. 할당량 설정은 Active Directory® 디렉터리 서비스에 저장되고 Exchange Server는 정기적으로 Active Directory의 정보를 읽어서 이러한 제한이 변경되었는지 여부를 확인합니다. 기본적으로 Exchange Server는 이 정보를 2시간(120분) 동안 캐시에 보관한 후 Active Directory에서 해당 정보를 다시 읽습니다.

분으로 표시되는 Mailbox Cache Age Limit 레지스트리 값은 기본 시간을 다시 정의하는 데 사용됩니다. 특히 이 값은 사서함 한도에 도달했기 때문에 사용자가 사서함에 액세스할 수 없는 경우 유용하게 사용됩니다. 기본 캐시 보존 기간이 적용되면 사용자는 최대 2시간 동안 사서함에 액세스할 수 없습니다. 권장 값은 20분입니다. 성능 문제가 발생할 수 있으므로 이 값을 너무 낮게 설정하지 마십시오.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate를 탐색합니다.

  3. 오른쪽 창에서 Mailbox Cache Age Limit 값을 찾아 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Mailbox Cache Age Limit 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 327378, "XADM: Exchange 2000 and Exchange Server 2003 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378)을 참조하십시오.


Mailbox Cache Idle Limit가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Mailbox Cache Idle Limit가 설정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 Mailbox Cache Idle Limit 레지스트리 항목이 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server에서는 사서함에 크기 제한(할당량)을 설정할 수 있습니다. 할당량 설정은 Active Directory® 디렉터리 서비스에 저장되며 Exchange 서버는 Active Directory에서 이 정보를 주기적으로 읽어 제한 설정이 변경되었는지 확인합니다. Exchange Server는 이 정보를 캐시에 저장하고 일정 시간이 지나면 Active Directory에서 해당 정보를 다시 읽습니다.

Mailbox Cache Age Limit 설정과 Mailbox Cache Idle Limit 설정은 사서함 정보 캐시의 항목을 유지하는 시간을 제어합니다. Mailbox Cache Age Limit 설정에 지정된 시간(초)보다 오래 캐시에 보관된 항목은 캐시에서 제거됩니다. 또한 Mailbox Cache Idle Limit에 설정된 시간(초) 동안 사용되지 않은 항목도 캐시에서 제거됩니다. 기본값은 Mailbox Cache Age Limit 설정의 경우 7,200초(120분)이며 Mailbox Cache Idle Limit 설정의 경우 900초(15분)입니다. Mailbox Cache Idle Limit 설정값은 Mailbox Cache Age Limit 설정값보다 클 수 없습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. 오른쪽 창에서 Mailbox Cache Idle Limit 값을 찾아 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Mailbox Cache Age Limit 레지스트리 값에 대한 자세한 내용은 기술 자료 문서 327378, "XADM: Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378)을 참조하십시오.


Mailbox Cache Size가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Mailbox Cache Size가 설정되어 있는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 Mailbox Cache Size 레지스트리 항목이 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

Mailbox Cache Size 값은 사서함 캐시의 크기를 제어합니다. 기본값은 256MB입니다. Exchange Server에서는 사서함에 크기 제한(할당량)을 설정할 수 있습니다. 할당량 설정은 Active Directory® 디렉터리 서비스에 저장되며 Exchange Server는 Active Directory에서 이 정보를 주기적으로 읽어 제한 설정이 변경되었는지 확인합니다. 기본적으로 Exchange Server는 이 정보를 Active Directory에서 다시 읽은 후 2시간(7,200초) 동안 캐시합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음을 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 오른쪽 창에서 Mailbox Cache Size 값을 찾아 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Mailbox Cache Age Limit 레지스트리 값에 대한 자세한 내용은 기술 자료 문서 327378, "XADM: Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378)을 참조하십시오.


Mailbox Cache Size가 0으로 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키를 읽어 Mailbox Cache Size 값의 설정을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 Mailbox Cache Size 레지스트리 값이 0으로 설정되어 있는 경우 오류를 표시합니다.

Exchange Server에서는 사서함에 크기 제한(할당량)을 설정할 수 있습니다. 할당량 설정은 Active Directory® 디렉터리 서비스에 저장되고 Exchange Server는 정기적으로 Active Directory의 정보를 읽어서 이러한 제한이 변경되었는지 여부를 확인합니다. Mailbox Cache Size 값은 이 사서함 캐시의 크기를 제어합니다. 기본값은 256MB입니다. 이 값을 0으로 설정하면 사서함 캐시가 해제되며 DSAccess(디렉터리 서비스 액세스) 구성 요소가 Active Directory 조회를 추가로 수행하므로 바람직하지 않습니다. 그리고 Exchange 저장소에서 장애가 발생할 수 있으며 사서함 이동이 실패할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음을 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. 오른쪽 창에서 Mailbox Cache Size 값을 찾아서 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Mailbox Cache Age Limit 레지스트리 값에 대한 자세한 내용은 기술 자료 문서 327378, "XADM: Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378)을 참조하십시오.


사서함 저장소는 정책으로 제어됩니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-06-06

Microsoft® Exchange Server Analyzer Tool은 각 사서함 저장소 개체의 msExchPolicyList 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msExchPolicyList 특성 값은 Exchange Server 사서함 정책이 작성되어 사서함 저장소에 지정되어 있는지 여부를 나타냅니다. Exchange Server Analyzer는 msExchPolicyList 특성이 설정되었으면 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로, 사서함 저장소를 만들 경우 지정된 사서함 정책이 없는 상태입니다. 하지만 대부분의 경우 관리자가 사서함 정책을 만들고 여러 사서함 저장소에 지정합니다. 이러한 정책은 저장 용량 제한, 인덱싱 업데이트, 유지 관리 간격, 공용 저장소와 오프라인 주소 목록에 대한 매핑 등과 같은 관리 설정을 적용합니다. 사서함 정책을 만들어 사서함 저장소에 지정하면 Exchange Server Analyzer는 해당 사서함 저장소가 현재 사서함 정책으로 제어되고 있다는 메시지를 표시합니다. 다른 추가 작업이 필요없습니다.

사서함 저장소에서 사서함 정책을 제거하려면 다음을 수행합니다.

  1. Exchange System Manager를 열고 콘솔 트리에서 관리 그룹을 확장합니다.

  2. 기본 관리 그룹을 확장한 다음 시스템 정책을 선택합니다.

  3. 결과 창에서 사서함 저장소를 마우스 오른쪽 단추로 클릭하고 정책에서 제거를 선택합니다.

  4. Exchange System Manager 창에서 예를 클릭하여 사서함 저장소 제거를 확인합니다.
참고:
Exchange System Manager의 콘솔 트리에 시스템 정책 노드가 표시되지 않으면 관리 그룹을 표시하도록 Exchange System Manager를 구성합니다.

사서함 저장소 정책에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 822938, "How To: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938)

  • 256141, "Exchange에서 시스템 정책을 만드는 방법" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256141).

Exchange Server 데이터베이스 파일에 대한 자세한 내용은 다음 Exchange Server 2003 항목을 참조하십시오.

  • Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "사서함 저장소 및 공용 폴더 저장소 관리"

  • Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 저장소 이해"


사서함 저장소 데이터베이스 파일이 네트워크 드라이브에 저장되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 사서함 저장소 개체의 msExchEDBFile 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성은 이 사서함 저장소에서 사용하는 데이터베이스 파일의 위치를 지정합니다.

또한 Exchange Server Analyzer는 이 서버에 있는 각 사서함 저장소의 homeMDBBL 특성에 나와 있는 값의 개수를 확인할 때도 Active Directory를 쿼리합니다. 이 특성의 개수는 사서함 저장소의 사서함 수를 나타냅니다. 그러면 Exchange Server Analyzer는 해당 서버에서 관리하는 총 사서함 수를 계산할 수 있습니다.

Exchange Server Analyzer는 사서함이 50개 이상 있는 Exchange 서버에서 msExchEDBFile 특성이 \\로 시작하면 오류를 표시합니다.

이 오류는 사서함 저장소에 대한 데이터베이스 파일이 네트워크 공유에 저장되고 있음을 나타냅니다. msExchEDBFile 특성이 \\로 시작되면 로그 파일 경로에 UNC(Universal Naming Convention) 경로가 사용되는 것입니다. 이러한 방식을 사용하면 네트워크 연결이 끊어질 때 데이터베이스 오류가 발생하여 데이터가 손실되거나 데이터베이스가 손상될 수 있으므로 권장되는 방법이 아닙니다. 이 문제는 가능한 빨리 해결하는 것이 좋습니다.

새 드라이브로 데이터베이스 파일을 옮기려면 다음을 수행합니다.

  1. Exchange System Manager에서 해당 저장소가 상주해 있는 Exchange 서버 개체, 적절한 저장소 그룹 컨테이너를 차례로 확장하고 원하는 사서함 저장소 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 속성 대화 상자의 데이터베이스 탭에서 새 파일 위치를 지정합니다.

Exchange Server 데이터베이스 파일에 대한 자세한 내용은 다음 항목을 참조하십시오.

  • Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "사서함 저장소 및 공용 폴더 저장소 관리"

  • Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 저장소 이해"

네트워크 드라이브가 있는 Exchange Server를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328879, "Using Exchange Server with Storage Attached Network and network-attached storage devices"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • 839687, "Microsoft support policy on the use of network-attached storage devices with Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • 317173, "Exchange Server and network-attached storage"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • 317172, "Exchange Server 5.5 and network-attached storage"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


사서함 저장소 데이터베이스 크기 제한이 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 사서함 저장소 데이터베이스에 대한 Database Size Limit in Gb 레지스트리 값의 존재 및 구성 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

Exchange Server Analyzer는 Database Size Limit in Gb 레지스트리 값이 있고 구성되어 있음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server 2003 서비스 팩 2(SP2)가 Exchange Server 2003 Standard Edition에 적용되면 하드 코드된 라이센스 데이터베이스 크기 제한이 16GB에서 75GB로 증가합니다. 예기치 않게 데이터베이스 크기가 커지는 것을 방지하기 위해 데이터베이스 크기 제한을 설정할 수 있습니다. SP2의 기본 크기 제한 값은 18GB이며 Database Size Limit in Gb 레지스트리 값을 만들어 이 기본값을 덮어쓸 수 있습니다.

Database Size Limit in Gb 레지스트리 값을 만들면 Exchange Server 2007 Standard Edition의 하드 코드된 라이선스 데이터베이스 크기 제한인 50GB도 늘릴 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>를 탐색합니다.

  3. Database Size Limit in Gb 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server 2003 SP2에 대한 자세한 내용은 Exchange Server 2003 서비스 팩 2 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=52073)를 참조하십시오.


사서함 저장소가 기본 공용 폴더 저장소에 연결되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchPrivateMDB 특성에 사서함 저장소에 지정된 기본 공용 폴더 저장소가 있는지 확인할 때 Active Directory® 디렉터리 서비스에 쿼리합니다.

msExchPrivateMDB 특성은 사서함 저장소 개체의 개인 데이터베이스 구성입니다. 기본적으로 msExchHomePublicMDB 특성은 사서함 저장소에 연결됩니다. msExchPrivateMDB 특성은 홈 공용 메시지 데이터베이스(MDB)입니다.

Exchange Server Analyzer는 msExchHomePublicMDB 특성이 제대로 삭제되거나 구성되지 않은 경우에 오류를 표시합니다.

각 사서함 저장소는 로컬 서버나 다른 서버에서 기본 공용 폴더 저장소와 연결되어야 합니다. 특정 사서함 저장소에서 지원하는 사서함이 사용 가능한 사용자마다 연결된 공용 폴더 저장소는 사용자의 홈 공용 폴더 저장소입니다. 가능하면 사서함 저장소와 같은 서버에서 기본 공용 폴더 저장소를 사용합니다.

참고:
사서함 저장소와 같은 서버의 기본 공용 폴더 저장소를 사용하여 사용자가 공용 폴더에 액세스하는 경우의 성능을 향상시키고 공용 폴더 액세스 문제를 간단하게 해결할 수 있습니다.
기본 공용 폴더 저장소를 사서함 저장소에 지정하려면 다음을 수행합니다.

  1. Exchange System Manager에서 사서함 저장소가 상주하는 저장소 그룹을 마우스 오른쪽 단추로 클릭합니다.

  2. 사서함 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭의 기본 공용 폴더 저장소에서 찾아보기를 클릭하고 이 사서함 저장소와 연결할 공용 폴더 저장소를 선택합니다.

    참고:
    새 사서함 저장소를 만들 경우 Exchange Server는 공용 폴더 트리와 연결된 기본 공용 저장소와 사용자가 오프라인 사용을 위해 다운로드하는 오프라인 주소록을 자동으로 선택합니다.

사서함 저장소 및 공용 폴더 저장소 관리에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?linkid=47617)를 참조하십시오.


사서함 저장소 크기가 12GB를 초과합니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-02-28

Microsoft® Exchange Server Analyzer Tool은 CIM_DataFile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 각 Exchange 사서함 저장소 데이터베이스 파일(.edb 파일) 및 스트리밍 파일(.stm 파일)의 FileSize 키 값을 확인합니다. 또한 Exchange Server Analyzer는 다음 레지스트리 분기를 읽어 설치된 Exchange Server 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

Microsoft Exchange Server 2003 Standard Edition 또는 Microsoft Exchange 2000 Server Standard Edition을 실행 중인 컴퓨터에서 한 쌍의 사서함 저장소 데이터베이스와 스트리밍 파일의 전체 크기가 12GB를 초과하면 Exchange Server Analyzer에서 경고를 표시합니다.

Exchange Server 2003 Standard Edition 및 Exchange 2000 Server Standard Edition의 Exchange 저장소 데이터베이스는 16GB보다 커질 수 없습니다. 이 한도에 도달하면 사서함 저장소가 더 이상 탑재되지 않으며 Exchange에 액세스할 수 없습니다. Exchange Server 2003 Enterprise Edition 및 Exchange 2000 Server Enterprise Edition의 Exchange 저장소 데이터베이스는 16GB로 제한되지 않으며 사용 가능한 하드웨어에 의해서만 제한됩니다. 이론적인 최대 크기는 16테라바이트입니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 사서함 중 일부를 대용량 사서함 저장소에서 이 Exchange Server 컴퓨터의 새 사서함 저장소나 다른 Exchange Server로 옮겨 보십시오.

  2. 최근 이 정보 저장소에서 다른 저장소로 사서함을 옮겼거나 이 사서함 저장소에서 사서함을 삭제했을 경우 오프라인 조각 모음을 수행하면 파일 크기를 줄일 수 있습니다.

  3. 사서함 저장소가 무한정 커지지 않도록 사서함 및 메시지 크기 제한을 설정합니다.
참고:
Exchange Server 2003 Standard Edition의 Exchange Server 2003 서비스 팩 2(SP2) 버전에서는 하드 코드된 라이센스 데이터베이스 크기 제한이 16GB에서 75GB로 증가되었습니다. 관리자는 예기치 않게 데이터베이스 크기가 커지는 것을 방지하기 위해 데이터베이스 크기 제한을 설정할 수 있습니다. Standard Edition의 SP2에서는 기본값이 18GB이며 Database Size Limit in Gb 레지스트리 키를 편집하여 기본값 18GB를 덮어쓸 수 있습니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Exchange Server 2003 SP2에서 데이터베이스 크기 제한을 구성하려면 다음을 수행합니다.

  1. Exchange Server를 실행하는 컴퓨터에서 Regedit.exe를 시작합니다.

  2. 레지스트리 키 HKLM\System\CurrentControlSet\Services\MSExchangeIS\Server name\Private-Mailbox Store GUID를 엽니다.

  3. Private Store GUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  4. 새 값 이름으로 Database Size Limit in Gb를 입력합니다.

  5. Database Size Limit in Gb를 두 번 클릭합니다. 값 데이터에 최대 데이터베이스 크기(GB)에 적절한 값을 입력합니다. Exchange Server 2003 Standard Edition의 경우 1에서 75 사이의 10진수 값을 입력합니다(기본값: 18GB). Exchange Server 2003 Enterprise Edition의 경우 1에서 8000 사이의 10진수 값을 입력합니다(기본값: 8000GB). 확인을 클릭합니다.

  6. Private Store GUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  7. 새 값 이름으로 Database Size Buffer in Percentage를 입력합니다.

  8. Database Size Buffer in Percentage를 두 번 클릭합니다. 값 데이터에 1에서 100 사이의 십진수 값을 입력하여 데이터베이스가 최대 크기에 가까워졌음을 경고하는 이벤트의 기록 시기를 지정합니다. 기본값 10을 사용하면 해당 데이터베이스의 최대 크기까지 10% 용량이 남았을 때 경고 이벤트가 기록됩니다. 확인을 클릭합니다.

  9. Private Store GUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  10. 새 이름으로 Database Size Check Start Time in Hours From Midnight를 입력합니다.

  11. Database Size Check Start Time in Hours From Midnight를 두 번 클릭합니다. 값 데이터에 0에서 23 사이의 값을 입력하여 Exchange에서 데이터베이스 크기를 확인하는 시기를 지정합니다. 기본값 5를 사용하면 Exchange Server가 자정 이후 5시간(오전 5:00)이 지나면 데이터베이스 크기를 확인합니다. 확인을 클릭합니다.

  12. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

.stm 및 .edb 파일에 대한 자세한 내용은 Microsoft 기술 자료 문서 232323, "Native Content Storage in Microsoft Exchange"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)를 참조하십시오.

Exchange 2003에서의 사서함 이동에 대한 자세한 내용은 기술 자료 문서 821829, "Moving Mailboxes in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)을 참조하십시오.

Exchange 2000 Server의 사서함 이동에 대한 자세한 내용은 기술 자료 문서 328810, "XADM: 서버 간에 사서함 이동"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)을 참조하십시오.

Exchange Server 데이터베이스의 오프라인 조각 모음 수행에 대한 자세한 내용은 기술 자료 문서 328804, "Exchange 데이터베이스 조각 모음 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804)을 참조하십시오.

메시지 크기 제한 설정에 대한 자세한 내용은 기술 자료 문서 322679, "Exchange Server에서 메시지 크기 제한을 설정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)을 참조하십시오.

최대 데이터베이스 크기 제한에 도달한 Exchange Server 2003 Standard Edition 또는 Microsoft Exchange 2000 Server Standard Edition에 대한 자세한 내용은 기술 자료 문서 828070, "사서함 저장소 데이터베이스가 16GB 제한에 도달하면 Exchange Server 사서함 저장소가 탑재되지 않는다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070)를 참조하십시오.

Exchange Server 2003 SP2에 대한 자세한 내용은 Exchange Server 2003 서비스 팩 2 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=52073)를 참조하십시오.


사서함 저장소가 15GB를 초과합니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-02-28

Microsoft® Exchange Server Analyzer Tool은 CIM_DataFile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 각 Exchange 사서함 저장소 데이터베이스 파일(.edb 파일) 및 스트리밍 파일(.stm 파일)의 FileSize 키 값을 확인합니다. 또한 Exchange Server Analyzer는 다음 레지스트리 분기를 읽어 설치된 Exchange Server 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

Exchange Server Analyzer는 Microsoft Exchange Server 2003 Standard Edition 또는 Microsoft Exchange 2000 Server Standard Edition이 실행되는 컴퓨터에서 한 쌍의 사서함 저장소 데이터베이스와 스트리밍 파일의 전체 크기가 15GB를 초과할 경우 오류를 표시합니다.

Exchange Server 2003 Standard Edition 및 Exchange 2000 Server Standard Edition의 Exchange 저장소 데이터베이스는 16GB보다 커질 수 없습니다. 이 한도에 도달하면 사서함 저장소가 더 이상 탑재되지 않으며 Exchange에 액세스할 수 없습니다. Exchange Server 2003 Enterprise Edition 및 Exchange 2000 Server Enterprise Edition의 Exchange 저장소 데이터베이스는 16GB로 제한되지 않으며 사용 가능한 하드웨어에 의해서만 제한됩니다. 이론적인 최대 크기는 16테라바이트입니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 사서함 중 일부를 대용량 사서함 저장소에서 이 Exchange Server 컴퓨터의 새 사서함 저장소나 다른 Exchange Server로 옮겨 보십시오.

  2. 최근 이 정보 저장소에서 다른 저장소로 사서함을 옮겼거나 이 사서함 저장소에서 사서함을 삭제했을 경우 오프라인 조각 모음을 수행하면 파일 크기를 줄일 수 있습니다.

  3. 사서함 저장소가 무한정 커지지 않도록 사서함 및 메시지 크기 제한을 설정합니다.
참고:
Exchange Server 2003 Standard Edition의 Exchange Server 2003 서비스 팩 2(SP2) 버전에서는 하드 코드된 라이센스 데이터베이스 크기 제한이 16GB에서 75GB로 증가되었습니다. 관리자는 예기치 않게 데이터베이스 크기가 커지는 것을 방지하기 위해 데이터베이스 크기 제한을 설정할 수 있습니다. Standard Edition의 SP2에서는 기본값이 18GB이며 Database Size Limit in GB 레지스트리 키를 편집하여 기본값 18GB를 덮어쓸 수 있습니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Exchange Server 2003 SP2에서 데이터베이스 크기 제한을 구성하려면 다음을 수행합니다.

  1. Exchange Server를 실행하는 컴퓨터에서 Regedit.exe를 시작합니다.

  2. 레지스트리 키 HKLM\System\CurrentControlSet\Services\MSExchangeIS\Server name\Private-Mailbox Store GUID를 엽니다.

  3. Private Store GUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  4. 새 값 이름으로 Database Size Limit in Gb를 입력합니다.

  5. Database Size Limit in Gb를 두 번 클릭합니다. 값 데이터에 최대 데이터베이스 크기(GB)에 적절한 값을 입력합니다. Exchange Server 2003 Standard Edition의 경우 1에서 75 사이의 십진수 값을 입력합니다(기본값 18GB). Exchange Server 2003 Enterprise Edition의 경우 1에서 8000 사이의 십진수 값을 입력합니다(기본값 8000GB). 확인을 클릭합니다.

  6. Private Store GUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  7. 새 값 이름으로 Database Size Buffer in Percentage를 입력합니다.

  8. Database Size Buffer in Percentage를 두 번 클릭합니다. 값 데이터에 1에서 100 사이의 십진수 값을 입력하여 데이터베이스가 최대 크기에 가까워졌음을 경고하는 이벤트의 기록 시기를 지정합니다. 기본값 10을 사용하면 해당 데이터베이스의 최대 크기까지 10% 용량이 남았을 때 경고 이벤트가 기록됩니다. 확인을 클릭합니다.

  9. Private Store GUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  10. 새 이름으로 Database Size Check Start Time in Hours From Midnight를 입력합니다.

  11. Database Size Check Start Time in Hours From Midnight를 두 번 클릭합니다. 값 데이터에 0에서 23 사이의 값을 입력하여 Exchange에서 데이터베이스 크기를 확인하는 시기를 지정합니다. 기본값 5를 사용하면 Exchange Server가 자정 이후 5시간(오전 5:00)이 지나면 데이터베이스 크기를 확인합니다. OK를 클릭합니다.

  12. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

.stm 및 .edb 파일에 대한 자세한 내용은 Microsoft 기술 자료 문서 232323, "Native Content Storage in Microsoft Exchange"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)를 참조하십시오.

Exchange 2003에서의 사서함 이동에 대한 자세한 내용은 기술 자료 문서 821829, "Moving Mailboxes in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)을 참조하십시오.

Exchange 2000 Server의 사서함 이동에 대한 자세한 내용은 기술 자료 문서 328810, "XADM: 서버 간에 사서함 이동"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)을 참조하십시오.

Exchange Server 데이터베이스의 오프라인 조각 모음 수행에 대한 자세한 내용은 기술 자료 문서 328804, "Exchange 데이터베이스 조각 모음 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804)을 참조하십시오.

메시지 크기 제한 설정에 대한 자세한 내용은 기술 자료 문서 322679, "Exchange Server에서 메시지 크기 제한을 설정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)을 참조하십시오.

최대 데이터베이스 크기에 도달한 Exchange Server 2003 Standard Edition 및 Exchange 2000 Server Standard Edition에 대한 자세한 내용은 기술 자료 문서 828070, "사서함 저장소 데이터베이스가 16GB 제한에 도달하면 Exchange Server 사서함 저장소가 탑재되지 않는다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070)를 참조하십시오.

Exchange Server 2003용 SP2에 대한 자세한 내용은 Exchange Server 2003 서비스 팩 2 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=52073)를 참조하십시오.


사서함 저장소를 전체 백업한지 8일 이상 경과했습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 마지막 전체 백업 날짜와 시간을 확인할 때 모든 사서함 저장소를 쿼리합니다. 또한 Exchange Server Analyzer는 각 사서함 저장소의 사서함 사용자 수를 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 다음 조건 모두가 충족되는 경우 경고 메시지를 표시합니다.

  • 사서함 저장소에 대한 마지막 전체 백업 이후로 8일 넘게 지났습니다.

  • 사서함 저장소에 11개 이상의 사서함이 있습니다.

사서함 저장소는 Microsoft Exchange Server 2003 및 Exchange Server 2007의 사서함을 저장하는 데이터베이스입니다. 사서함 저장소는 서식 있는 파일(.edb)과 스트리밍 전용 인터넷 콘텐츠 파일(.stm)로 구성되어 있습니다. .edb와 .stm 두 파일이 있지만 이 파일은 별개의 두 데이터베이스가 아니라 하나의 데이터베이스를 구성하는 두 부분을 나타냅니다.

Exchange Server 조직에서 백업해야 할 가장 중요한 데이터는 Exchange Server 데이터베이스의 사서함 저장소와 공용 폴더 저장소 데이터 및 트랜잭션 로그 파일입니다. Exchange Server 데이터베이스 백업을 사용하여 Exchange Server가 실행되며 작동 중인 서버로 손상된 사서함을 복원할 수 있습니다. 또한 Exchange Server 데이터베이스 백업을 사용하여 Exchange Server 데이터베이스를 다른 서버로 복원할 수 있습니다.

가장 좋은 방법은 매일 데이터베이스 파일과 트랜잭션 로그를 전체 백업하는 것입니다. 저장소 그룹의 전체 백업을 완료한 후에 Exchange Server 데이터베이스의 커밋된 트랜잭션 로그 파일은 서버에서 삭제됩니다. 전체 백업은 모든 데이터를 복원하도록 설정된 테이프 하나만 필요하므로 복구할 경우 속도 면에서 유리합니다.

참고:
데이터베이스 파일과 별개의 전용 디스크에 트랜잭션 로그 파일을 보관하는 것이 좋습니다. 그러면 데이터베이스 디스크가 손상된 경우 내결함성을 제공하며 경우에 따라 데이터베이스 성능이 향상될 수도 있습니다.
중요:
파일 및 폴더를 백업하거나 복원하려면 필요한 사용 권한이나 권한이 로그인한 사용자 계정에 지정되어 있어야 합니다. Exchange Server 백업을 만들려면 도메인 수준의 백업 운영자 권한이 있어야 합니다. Microsoft Windows Server™ 2003 운영 체제의 백업을 만들려면 최소한 로컬 백업 운영자 권한은 있어야 합니다.

Exchange Server 데이터에 대한 백업 전략은 저장소 크기, 백업 소프트웨어 및 하드웨어 속도, 하드웨어 용량 및 필요한 시간에 따라 다르게 선택합니다.

백업 계획 및 재해 복구 작업에 대한 자세한 내용은 다음을 참조하십시오.

  • Exchange Server 2003 재해 복구 작업 가이드(http://go.microsoft.com/fwlink/?LinkId=47570)

  • Database Backup and Restore(http://go.microsoft.com/fwlink/?LinkId=80766)


사서함 저장소를 전체 백업한지 60일 이상 경과했습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 마지막 전체 백업 날짜와 시간을 확인할 때 모든 사서함 저장소를 쿼리합니다. 또한 Exchange Server Analyzer는 각 사서함 저장소의 사서함 사용자 수를 확인할 때도 Active Directory￠c 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 다음 조건 중 모두 존재하는 경우 오류를 표시합니다.

  • 사서함 저장소의 최근 전체 백업 이후 60일을 초과했습니다.

  • 사서함 저장소에 11개 이상의 사서함이 있습니다.

사서함 저장소는 Microsoft Exchange Server 2003 및 Microsoft Exchange Server 2007의 사서함을 저장하는 데이터베이스입니다. 사서함 저장소는 서식 있는 파일(.edb)과 스트리밍 전용 인터넷 콘텐츠 파일(.stm)로 구성되어 있습니다. .edb와 .stm 두 파일이 있지만 이 파일은 별개의 두 데이터베이스가 아니라 하나의 데이터베이스를 구성하는 두 부분을 나타냅니다.

Exchange Server 조직에서 백업해야 할 가장 중요한 데이터는 Exchange Server 데이터베이스의 사서함 저장소와 공용 폴더 저장소 데이터 및 트랜잭션 로그 파일입니다. Exchange Server 데이터베이스 백업을 사용하여 Exchange Server가 실행되며 작동 중인 서버로 손상된 사서함을 복원할 수 있습니다. 또한 Exchange Server 데이터베이스 백업을 사용하여 Exchange Server 데이터베이스를 다른 서버로 복원할 수 있습니다.

가장 좋은 방법은 매일 데이터베이스 파일과 트랜잭션 로그를 전체 백업하는 것입니다. 저장소 그룹의 전체 백업을 완료한 후에 Exchange Server 데이터베이스의 커밋된 트랜잭션 로그 파일은 서버에서 삭제됩니다. 전체 백업은 모든 데이터를 복원하도록 설정된 테이프 하나만 필요하므로 복구할 경우 속도 면에서 유리합니다.

참고:
데티어베이스 파일과 별개의 전용 디스크에 트랜잭션 로그 파일을 보관하는 것이 좋습니다. 그러면 데이터베이스 디스크가 손상된 경우 내결함성을 제공하며 경우에 따라 데이터베이스 성능이 향상될 수도 있습니다.
중요:
파일 및 폴더를 백업하거나 복원하려면 필요한 사용 권한이나 권한이 로그인한 사용자 계정에 지정되어 있어야 합니다. Exchange Server 백업을 만들려면 도메인 수준의 백업 운영자 권한이 있어야 합니다. Microsoft Windows Server™ 2003 운영 체제의 백업을 만들려면 최소한 로컬 백업 운영자 권한이 있어야 합니다.

Exchange Server 데이터에 대한 백업 계획은 저장소 크기, 백업 소프트웨어 및 하드웨어 속도, 하드웨어 용량 및 필요한 시간에 따라 다르게 선택합니다.

백업 계획 및 재해 복구 작업에 대한 자세한 내용은 다음을 참조하십시오.

  • Exchange Server 2003 재해 복구 작업 가이드(http://go.microsoft.com/fwlink/?LinkId=47570)

  • Database Backup and Restore(http://go.microsoft.com/fwlink/?LinkID=80766)


사서함 저장소 온라인 유지 관리 일정이 겹칩니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 저장소 그룹의 모든 사서함 저장소가 같은 유지 관리 일정을 갖고 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 저장소 그룹 컨테이너(msExchStorageGroup 클래스)에 사서함 저장소 개체(msExchPrivMDB 클래스)가 두 개 이상 있을 경우 Exchange Server Analyzer는 각 사서함 저장소 개체의 activationSchedule 특성을 확인합니다. Exchange Server Analyzer는 8진수 문자열로 저장된 이 값이 각 사서함 저장소에 대해 같은 값이거나 겹칠 경우 경고를 표시합니다.

기본적으로 사서함 저장소 유지 관리 프로세스는 오전 1시에서 오전 5시 사이의 야간에 실행됩니다. 유지 관리 프로세스에 서버 리소스가 필요하므로 사서함 저장소 일정이 적어도 15분 이상 차이가 나도록 유지 관리 일정을 수정하는 것이 좋습니다.

Exchange 2000 Server 및 Exchange Server 2003에서 이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버를 확장한 다음 작업할 서버를 확장합니다.

  3. 작업할 저장소 그룹을 확장합니다.

  4. 작업할 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 데이터베이스 탭에서 유지 관리 간격을 클릭하고 새 간격을 클릭하거나 사용자 지정을 클릭하여 사용자 지정 일정을 만듭니다.

Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. 서버 구성을 확장하고 작업할 서버를 선택합니다.

  3. 작업할 저장소 그룹을 확장합니다.

  4. 작업할 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 일반 탭에서 유지 관리 일정 드롭다운을 클릭하고 새 간격을 선택하거나 사용자 지정을 클릭하여 사용자 지정 일정을 만듭니다.

Exchange Server 2003 저장소 유지 관리에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "저장소 유지 관리 및 백업 옵션 구성"을 참조하십시오.


사서함 저장소의 보내기 및 받기 금지 제한이 너무 비슷합니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 사서함에 설정된 사서함 크기 제한을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 Prohibit send 및 Prohibit send and receive 사서함 제한의 차이가 20%보다 작으면 유용한 정보 구성 메시지를 표시합니다.

Prohibit send 제한과 Prohibit send and receive 제한은 20% 이상 차이가 나게 설정하는 것이 좋습니다. 제한 차이가 20%보다 작으면 사서함을 시작하기 전에 사서함 사용자가 사서함을 정리할 시간이 부족해 메시지가 거부될 수 있습니다. 예를 들어 사용자가 사서함이 100MB에 도달할 때 새 메시지를 보내지 못하게 된 경우 Prohibit send and receive 제한은 최소 120MB가 되어야 합니다.

참고:
사서함에 대한 경고 제한을 설정하는 것도 중요합니다. 사서함이 경고 제한에 도달하면 사용자에게 사서함이 Prohibit send 제한에서 정의된 제한에 도달할 것임을 경고하는 전자 메일 메시지를 보냅니다.

이 문제를 해결하려면 Prohibit send 및 Prohibit send and receive 사서함 제한 차이를 20% 이상으로 늘려야 합니다.

사서함 제한을 설정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. Exchange Server Analyzer 메시지에 표시된 사서함 저장소를 찾습니다.

  3. MailboxStore_Name을 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  4. 제한 탭을 선택합니다.

  5. 다음 크기(KB)일 때 보내기 금지 제한 또는 다음 크기(KB)일 때 보내기 및 받기 금지 제한을 수정하거나 두 제한을 모두 수정합니다.

  6. 적용, 확인을 차례로 클릭합니다.
Exchange Server 2007에서 Exchange 관리 콘솔을 사용하여 사서함 제한을 설정하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. 이 문제와 관련하여 Exchange Server Analyzer에 표시된 사서함 저장소를 찾습니다.

  3. MailboxStore_Name을 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  4. 제한 탭을 선택합니다.

  5. 다음 크기(KB)일 때 경고 보내기, 다음 크기(KB)일 때 보내기 금지 제한 및 다음 크기(KB)일 때 보내기 및 받기 금지 제한을 수정합니다.

  6. 적용, 확인을 차례로 클릭합니다.
Exchange Server 2007에서 Exchange 관리 셸을 사용하여 사서함 제한을 설정하려면 다음을 수행합니다.

  1. 다음 예에서는 사용자에게 경고 메시지가 보내지는 사서함 크기를 설정하는 방법을 보여 줍니다. 이 특성은 이 사서함 데이터베이스에서 고유 경고 할당량 특성이 설정되지 않은 모든 사서함에 적용됩니다. 정수 또는 "무제한"을 지정해야 합니다. 기본값은 1.9GB입니다.
코드 복사
Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680
  1. 다음 예에서는 이 사서함 데이터베이스의 사서함과 연결된 사용자가 더 이상 메시지를 보낼 수 없는 사서함 크기를 설정하는 방법에 대해 보여 줍니다. 이 특성은 이 사서함 데이터베이스에서 고유 보내기 금지 할당량 특성이 설정되지 않은 모든 사서함에 적용됩니다. 제한값은 정수 또는 "무제한"으로 설정해야 합니다.

코드 복사
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152
  1. 다음 예에서는 이 사서함과 연결된 사용자가 더 이상 메시지를 보내거나 받을 수 없는 사서함 크기를 설정하는 방법에 대해 보여 줍니다. 이 특성은 이 사서함 데이터베이스에서 고유 보내기 및 받기 금지 할당량 특성이 설정되지 않은 모든 사서함에 적용됩니다. 정수 또는 "무제한"을 지정해야 합니다.

코드 복사
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

Exchange 사서함을 관리하는 방법에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)을 참조하십시오.

Exchange Server 2007의 Exchange 사서함 제한을 관리하는 방법에 대한 자세한 내용은 "How to Configure Database Limits and Properties"(http://go.microsoft.com/fwlink/?LinkID=80746)를 참조하십시오.


시작 시 사서함 저장소가 탑재되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool 은 개체 클래스가 msExchPrivateMDB인 모든 개체의 msExchEDBOffline 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 클래스의 개체는 사서함 저장소입니다.

msExchEDBOffline 특성의 True 값은 Microsoft Exchange Information Store 서비스가 시작할 때 사서함 저장소가 자동으로 탑재되지 않음을 나타내고 False 값은 시작 시 사서함 저장소가 탑재됨을 나타냅니다. Exchange Server Analyzer는 이 특성 값이 True일 경우 경고를 표시합니다.

이 경고는 시작 시 이 저장소 탑재 안 함 확인란이 선택되었음을 나타냅니다. 이 확인란은 사서함 저장소의 속성 대화 상자의 데이터베이스 탭에 있습니다. 이 확인란을 선택하면 Microsoft Exchange Information Store 서비스를 시작할 때 사서함 저장소가 자동으로 탑재되지 않습니다. 서버를 다시 시작한 후와 같이 Microsoft Exchange Information Store 서비스를 다음에 시작할 때 이 특성이 True로 설정된 사서함 저장소는 탑재되지 않습니다. Microsoft Exchange Information Store 서비스를 시작할 때 사서함 저장소를 자동으로 탑재하는 것이 좋습니다.

Exchange 2000 Server 또는 Exchange Server 2003의 경우 이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, 수정할 사서함 저장소가 있는 서버를 차례로 확장합니다.

  3. 수정할 사서함 저장소가 있는 저장소 그룹을 확장합니다.

  4. 사서함 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 데이터베이스 탭에서 시작 시 이 저장소 탑재 안 함 확인란의 선택을 취소합니다.

  6. 확인을 클릭하여 설정을 저장합니다.

  7. Exchange System Manager를 닫습니다.

Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. 서버 구성을 확장하고 작업할 서버를 선택합니다.

  3. 작업할 저장소 그룹을 확장합니다.

  4. 작업할 데이터베이스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 일반 탭에서 시작 시 이 데이터베이스 탑재 안 함 확인란의 선택을 취소합니다.

  6. 확인을 클릭하여 설정을 저장합니다.

  7. Exchange 관리 콘솔을 닫습니다.

이 옵션에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 314218, "HOW TO: Turn Off or Turn On Automatic Mounting of Data Stores at Startup in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314218)

  • 285169, "XADM: Information Stores Do Not Mount After You Use the "/disasterrecovery" Switch"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=285169)


Max FXGetBuffer Users 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Max FXGetBuffer Users 레지스트리 키가 만들어졌는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 ParametersSystem에 Max FXGetBuffer Users 레지스트리 키가 만들어졌으면 기본 구성이 아니라는 메시지를 표시합니다.

Max FXGetBuffer Users 레지스트리 키를 사용하여 Exchange Server 2003 서버와 동시에 동기화하는 Microsoft Office Outlook® 2003 클라이언트 수를 제어할 수 있습니다. Outlook 클라이언트에서 만든 동시 원격 프로시저 호출(RPC) 연결의 제한을 무시하도록 Max FXGetBuffer Users 레지스트리 키 값을 설정합니다. 이러한 연결은 ropFXSrcGetBuffers라고도 합니다. 서버에 있는 프로세서 수에 2를 곱한 다음 3을 더해 Max FXGetBuffer Users 레지스트리 키의 기본값을 계산합니다. 예를 들어 두 개의 프로세서가 있는 Exchange Server 2003 서버에서 기본값은 7([2*2] + 3 = 7)입니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성을 복원하려면 다음을 수행합니다

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. Max FXGetBuffer Users 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

Microsoft Exchange Information Store 서비스는 몇 분 이내에 변경 내용을 감지합니다. 컴퓨터를 다시 시작할 필요가 없습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server 2003과 동기화할 수 있는 Outlook 클라이언트 수를 제어할 수 있도록 레지스트리 키를 설정하는 방법에 대한 자세한 내용은 기술 자료 문서 818484, "Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484)을 참조하십시오.


메시지 전송당 최대 첨부 파일 수가 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 메시지 전송당 기본 최대 첨부 파일 수가 변경되었는지 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtAttachment

Exchange Server Analyzer는 objtAttachment 레지스트리 값이 아래 표에 표시된 값이 아닌 값으로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

입력 | Exchange Server 2003 RTM 기본값 | Exchange Server 2003 SP1 이상의 기본값 | Exchange Server 2007 기본값
objtAttachment | 100 | 500 | 500

수동으로 추가하고 구성한 objtAttachment 레지스트리 값은 각 MAPI 클라이언트마다 메시지 전송당 최대 첨부 수를 결정합니다. MAPI 클라이언트가 허용된 수보다 많은 첨부 파일이 포함된 메시지를 보내려고 시도하면 클라이언트의 사서함이 포함된 Exchange Server 컴퓨터의 응용 프로그램 이벤트 로그에 다음 이벤트가 기록됩니다.

이벤트 종류: | 오류
이벤트 ID: | 9646
이벤트 원본: | MSExchangeIS
이벤트 범주: | 일반
설명: | "objtAttachment" 유형의 개체 최대값인 xxx개를 초과했으므로 MAPI 세션 "/o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName"을 닫습니다.

objtAttachment 레지스트리 값을 통해 관리자는 MAPI 클라이언트에서 사용하는 Exchange Server 리소스를 더 많이 제어할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession

  3. objtAttachment 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

또는 objtAttachment 레지스트리 값을 삭제하지 않고 사용하려면 기존 값을 유지하거나 필요한 경우 조정합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)을 참조하십시오.

자세한 내용은 기술 자료 문서 830829, "Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829)를 참조하십시오.


캐시된 최대 보기 수가 수정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 데이터베이스마다 캐시된 최대 보기 개수를 수정했는지 확인하기 위해 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer에서 msExchMaxCachedViews 특성이 기본값 11과 다르게 변경된 것을 확인하면 기본 구성이 아니라는 메시지를 표시합니다. 데이터베이스별로 구성한 캐시된 보기 수는 Exchange Server Analyzer 출력에 포함되어 있습니다. 5개에서 20개 사이의 캐시된 보기가 있는 것이 좋습니다.

msExchMaxCachedViews는 msExchangePrivateMDB 개체 클래스의 특성입니다. 따라서 Active Directory의 각 사서함 데이터베이스 저장소 개체마다 msExchMaxCachedViews 특성 값이 있습니다. msExchMaxCachedViews 특성 값은 사서함에 있는 특정 폴더에 대해 캐시된 최대 보기 수를 지정합니다. 이 컨텍스트에서 "보기"는 사용자가 다른 사용자의 Microsoft Office Outlook® 2003 사서함에 액세스할 때 표시되는 폴더를 의미합니다. 사용자가 다른 사용자들과 Outlook 폴더에 대한 액세스를 공유하는 경우 Exchange Server에서는 개인 항목을 표시하지 않는 보기를 생성합니다.

Outlook 사용자가 처음으로 다른 사람의 일정, 연락처 폴더 또는 다른 데이터를 볼 때 지연이 발생할 수 있습니다. 사용자가 폴더를 본 후에 연속해서 다시 볼 경우 보다 빠르게 볼 수도 있지만 일정 기간이 지난 후에 사용자가 해당 폴더에 다시 액세스하려고 하면 지연이 발생할 수도 있습니다. 일반적으로 이러한 지연은 폴더의 항목 수가 많은 경우 매우 두드러지게 나타납니다. 많은 경우는 5,000 항목 이상입니다.

폴더에 보기를 적용하면 Outlook 폴더에 액세스하는 고유 사용자마다 Exchange 저장소에 검색 폴더를 만듭니다. 검색 폴더가 만들어지면 나중에 사용할 수 있도록 캐시됩니다. Exchange Server가 새 검색 폴더를 만들기 전에 검색 폴더가 이미 존재하는지 확인합니다. 검색 폴더가 있으면 Exchange Server는 캐시된 검색 폴더를 사용하여 다음 번에는 빠르게 폴더를 볼 수 있게 합니다.

msExchMaxCachedViews 특성은 특정 폴더에 캐시된 검색 폴더 수를 정의합니다. 예를 들어 msExchMaxCachedViews 특성은 일정 폴더에 캐시된 검색 폴더 수를 정의할 수 있습니다.

Outlook 폴더를 공유하는 사용자가 많은 경우 서버 리소스와 허용 가능한 클라이언트 성능 간에 균형을 유지하는 방법을 결정해야 합니다. 검색 폴더가 캐시된 경우 검색 폴더는 검색 폴더의 데이터가 변경될 때마다 업데이트됩니다. 이러한 업데이트의 경우 CPU와 디스크 리소스가 사용됩니다. 검색 폴더의 캐시가 여러 개 유지 관리되는 경우 CPU 성능과 디스크 성능에 더 많은 영향을 줄 수 있습니다.

한편, Exchange Server에서 검색 폴더를 처음으로 만들 경우 검색 폴더가 생성될 때 Outlook 폴더에 액세스하는 사용자는 지연을 느낄 수 있습니다.

11개의 검색 폴더로 구성된 Exchange Server로 예를 들어 봅니다. 11개는 기본 검색 폴더 수입니다. 사용자 A는 15명의 다른 사용자와 일정 폴더를 공유합니다. 사용자 B는 자신의 검색 폴더가 생성되는 동안 폴더에 액세스하면 지연을 느끼게 됩니다. 사용자 B의 검색 폴더가 만들어지면 사용자 A의 일정 폴더에 대한 액세스가 빨라집니다. 사용자 B는 하루 중 남은 시간 동안 해당 폴더에 액세스하지 않는다고 가정합니다. 한편, 11명의 다른 사용자가 해당 폴더에 액세스하는 경우에는 사용자마다 고유 검색 폴더가 만들어집니다. 11개의 검색 폴더만 캐시되므로 다음에 사용자 B가 사용자 A의 일정에 액세스할 때 사용자 B는 자신의 새 검색 폴더가 생성되는 동안 다시 지연을 느끼게 됩니다.

가장 좋은 방법은 최대 검색 폴더 캐시 수를 20개 이하로 제한하는 것입니다. 이 값을 초과하면 5,000개 이상의 항목이 있는 폴더의 경우에는 특히 서버가 캐시된 폴더를 유지 관리할 때 오버로드될 수 있습니다.

또한 캐시는 5개 정도로 유지하는 것이 좋습니다. 사용자가 여러 명의 사용자와 Outlook 폴더를 공유하는 경우 4개의 검색 폴더만 캐시하면 클라이언트 환경에 부정적인 영향을 줄 수 있고 서버에서 보다 자주 새로운 캐시를 만들 때 더 많은 리소스를 사용하게 됩니다.

msExchMaxCachedViews 특성도 공용 폴더 데이터베이스에서 설정할 수 있습니다. 공용 폴더에 대한 검색 폴더도 생성됩니다. 기본적으로 공용 폴더는 다수의 사용자가 액세스할 수 있는 공유 리소스입니다. 공용 폴더에 수신되는 게시물이 많은 경우 검색 폴더가 업데이트될 때 Exchange Server의 CPU와 디스크 사용량이 증가할 수 있으므로 검색 폴더 수를 최소화해야 합니다. 또한 서로 다른 많은 사용자가 하나의 공용 폴더에 액세스하는 경우 많은 검색 폴더 캐시를 제공하여 클라이언트 환경을 최적화하는 것은 좋지 않습니다. 새로운 사용자에 대해 새 검색 폴더가 만들어질 때 이러한 캐시는 삭제될 수 있습니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
msExchMaxCachedViews 특성을 수정하려면 다음을 수행합니다.

  1. Microsoft Windows® 2000 지원 도구 또는 Windows Server 2003 지원 도구에서 ADSI 편집 도구를 시작합니다.

  2. 다음 노드를 확장합니다.

    • 구성 컨테이너

    • 구성

    • 서비스

    • Microsoft Exchange

    • Organization_Name

    • 관리 그룹

    • Administrative_Group_Name

    • 서버

    • InformationStore

    • Storage_Group_Name

  3. 세부 정보 창에서 Database_Name을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 특성 상자에서 msExchMaxCachedViews를 두 번 클릭합니다.

  5. 정수 특성 편집기 대화 상자에서 값 필드에 5와 20 사이의 정수를 입력한 다음 확인을 클릭합니다.

  6. 적용을 클릭한 다음 ADSI 편집을 닫습니다.

  7. 적어도 15분 동안 복제되기를 기다린 다음 수정한 Exchange Server에서 Microsoft Exchange Information Store 서비스를 다시 시작합니다.


최대 캐시 보기가 너무 크게 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 데이터베이스마다 캐시된 최대 보기 개수를 수정했는지 확인하기 위해 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchMaxCachedViews 특성이 20보다 큰 값으로 설정되면 경고를 표시합니다. 데이터베이스별로 구성한 캐시된 보기 수는 Exchange Server Analyzer 출력에 포함되어 있습니다. 5개에서 20개 사이의 캐시된 보기가 있는 것이 좋습니다.

msExchMaxCachedViews는 msExchangePrivateMDB 개체 클래스의 특성입니다. 따라서 Active Directory의 각 사서함 데이터베이스 저장소 개체마다 msExchMaxCachedViews 특성 값이 있습니다. msExchMaxCachedViews 특성 값은 사서함에 있는 특정 폴더에 대해 캐시된 최대 보기 수를 지정합니다. 이 컨텍스트에서 "보기"는 사용자가 다른 사용자의 Microsoft Office Outlook® 2003 사서함에 액세스할 때 표시되는 폴더를 의미합니다. 사용자가 다른 사용자들과 Outlook 폴더에 대한 액세스를 공유하는 경우 Exchange Server에서는 개인 항목을 표시하지 않는 보기를 생성합니다.

Outlook 사용자가 처음으로 다른 사람의 일정, 연락처 폴더 또는 다른 데이터를 볼 때 지연이 발생할 수 있습니다. 사용자가 폴더를 본 후에 연속해서 다시 볼 경우 보다 빠르게 볼 수도 있지만 일정 기간이 지난 후에 사용자가 해당 폴더에 다시 액세스하려고 하면 지연이 발생할 수도 있습니다. 일반적으로 이러한 지연은 폴더의 항목 수가 많은 경우 매우 두드러지게 나타납니다. 많은 경우는 5,000 항목 이상입니다.

폴더에 보기를 적용하면 Outlook 폴더에 액세스하는 고유 사용자마다 Exchange 저장소에 검색 폴더를 만듭니다. 검색 폴더가 만들어지면 나중에 사용할 수 있도록 캐시됩니다. Exchange Server가 새 검색 폴더를 만들기 전에 검색 폴더가 이미 존재하는지 확인합니다. 검색 폴더가 있으면 Exchange Server는 캐시된 검색 폴더를 사용하여 다음 번에는 빠르게 폴더를 볼 수 있게 합니다.

msExchMaxCachedViews 특성은 특정 폴더에 캐시된 검색 폴더 수를 정의합니다. 예를 들어 msExchMaxCachedViews 특성은 일정 폴더에 캐시된 검색 폴더 수를 정의할 수 있습니다.

Outlook 폴더를 공유하는 사용자가 많은 경우 서버 리소스와 허용 가능한 클라이언트 성능 간에 균형을 유지하는 방법을 결정해야 합니다. 검색 폴더가 캐시된 경우 검색 폴더는 검색 폴더의 데이터가 변경될 때마다 업데이트됩니다. 이러한 업데이트의 경우 CPU와 디스크 리소스가 사용됩니다. 검색 폴더의 캐시가 여러 개 유지 관리되는 경우 CPU 성능과 디스크 성능에 더 많은 영향을 줄 수 있습니다.

한편, Exchange Server에서 검색 폴더를 처음으로 만들 경우 검색 폴더가 생성될 때 Outlook 폴더에 액세스하는 사용자는 지연을 느낄 수 있습니다.

11개의 검색 폴더로 구성된 Exchange Server로 예를 들어 봅니다. 11개는 기본 검색 폴더 수입니다. 사용자 A는 15명의 다른 사용자와 일정 폴더를 공유합니다. 사용자 B는 자신의 검색 폴더가 생성되는 동안 폴더에 액세스하면 지연을 느끼게 됩니다. 사용자 B의 검색 폴더가 만들어지면 사용자 A의 일정 폴더에 대한 액세스가 빨라집니다. 사용자 B는 하루 중 남은 시간 동안 해당 폴더에 액세스하지 않는다고 가정합니다. 한편, 11명의 다른 사용자가 해당 폴더에 액세스하는 경우에는 사용자마다 고유 검색 폴더가 만들어집니다. 11개의 검색 폴더만 캐시되므로 다음에 사용자 B가 사용자 A의 일정에 액세스할 때 사용자 B는 자신의 새 검색 폴더가 생성되는 동안 다시 지연을 느끼게 됩니다.

가장 좋은 방법은 최대 검색 폴더 캐시 수를 20개 이하로 제한하는 것입니다. 이 값을 초과하면 5,000개 이상의 항목이 있는 폴더의 경우에는 특히 서버가 캐시된 폴더를 유지 관리할 때 오버로드될 수 있습니다.

또한 캐시는 5개 정도로 유지하는 것이 좋습니다. 사용자가 여러 명의 사용자와 Outlook 폴더를 공유하는 경우 4개의 검색 폴더만 캐시하면 클라이언트 환경에 부정적인 영향을 줄 수 있고 서버에서 보다 자주 새로운 캐시를 만들 때 더 많은 리소스를 사용하게 됩니다.

msExchMaxCachedViews 특성도 공용 폴더 데이터베이스에서 설정할 수 있습니다. 공용 폴더에 대한 검색 폴더도 생성됩니다. 기본적으로 공용 폴더는 다수의 사용자가 액세스할 수 있는 공유 리소스입니다. 공용 폴더에 수신되는 게시물이 많은 경우 검색 폴더가 업데이트될 때 Exchange Server의 CPU와 디스크 사용량이 증가할 수 있으므로 검색 폴더 수를 최소화해야 합니다. 또한 서로 다른 많은 사용자가 하나의 공용 폴더에 액세스하는 경우 많은 검색 폴더 캐시를 제공하여 클라이언트 환경을 최적화하는 것은 좋지 않습니다. 새로운 사용자에 대해 새 검색 폴더가 만들어질 때 이러한 캐시는 삭제될 수 있습니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
msExchMaxCachedViews 특성을 수정하려면 다음을 수행합니다.

  1. Microsoft Windows® 2000 지원 도구 또는 Windows Server 2003 지원 도구에서 ADSI 편집 도구를 시작합니다.

  2. 다음 노드를 확장합니다.

    • 구성 컨테이너

    • 구성

    • 서비스

    • Microsoft Exchange

    • Organization_Name

    • 관리 그룹

    • Administrative_Group_Name

    • 서버

    • InformationStore

    • Storage_Group_Name

  3. 세부 정보 창에서 Database_Name을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 특성 상자에서 msExchMaxCachedViews를 두 번 클릭합니다.

  5. 정수 특성 편집기 대화 상자에서 값 필드에 5와 20 사이의 정수를 입력한 다음 확인을 클릭합니다.

  6. 적용을 클릭한 다음 ADSI 편집을 닫습니다.

  7. 적어도 15분 동안 복제되기를 기다린 다음 수정한 Exchange Server에서 Microsoft Exchange Information Store 서비스를 다시 시작합니다.


캐시된 최대 보기 수가 너무 낮게 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool는 데이터베이스마다 캐시된 최대 보기 개수를 수정했는지 확인하기 위해 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer에서 msExchMaxCachedViews 특성이 5보다 작은 값으로 설정되어 있음을 확인하면 경고를 표시합니다. 데이터베이스별로 구성한 캐시된 보기 수는 Exchange Server Analyzer 출력에 포함되어 있습니다. 5개에서 20개 사이의 캐시된 보기가 있는 것이 좋습니다.

msExchMaxCachedViews는 msExchangePrivateMDB 개체 클래스의 특성입니다. 따라서 Active Directory의 각 사서함 데이터베이스 저장소 개체마다 msExchMaxCachedViews 특성 값이 있습니다. msExchMaxCachedViews 특성 값은 사서함에 있는 특정 폴더에 대해 캐시된 최대 보기 수를 지정합니다.

이 컨텍스트에서 "보기"는 사용자가 다른 사용자의 Microsoft Office Outlook® 2003 사서함에 액세스할 때 표시되는 폴더를 의미합니다. 사용자가 다른 사용자들과 Outlook 폴더에 대한 액세스를 공유하는 경우 Exchange Server에서는 개인 항목을 표시하지 않는 보기를 생성합니다.

Outlook 사용자가 처음으로 다른 사람의 일정, 연락처 폴더 또는 다른 데이터를 볼 때 지연이 발생할 수 있습니다. 사용자가 폴더를 본 후에 연속해서 다시 볼 경우 보다 빠르게 볼 수도 있지만 일정 기간이 지난 후에 사용자가 해당 폴더에 다시 액세스하려고 하면 지연이 발생할 수도 있습니다. 일반적으로 이러한 지연은 폴더의 항목 수가 많은 경우 매우 두드러지게 나타납니다. 많은 경우는 5,000 항목 이상입니다.

폴더에 보기를 적용하면 Outlook 폴더에 액세스하는 고유 사용자마다 Exchange 저장소에 검색 폴더를 만듭니다. 검색 폴더가 만들어지면 나중에 사용할 수 있도록 캐시됩니다. Exchange Server가 새 검색 폴더를 만들기 전에 검색 폴더가 이미 존재하는지 확인합니다. 검색 폴더가 있으면 Exchange Server는 캐시된 검색 폴더를 사용하여 다음 번에는 빠르게 폴더를 볼 수 있게 합니다.

msExchMaxCachedViews 특성은 특정 폴더에 캐시된 검색 폴더 수를 정의합니다. 예를 들어 msExchMaxCachedViews 특성은 일정 폴더에 캐시된 검색 폴더 수를 정의할 수 있습니다.

Outlook 폴더를 공유하는 사용자가 많은 경우 서버 리소스와 허용 가능한 클라이언트 성능 간에 균형을 유지하는 방법을 결정해야 합니다. 검색 폴더가 캐시된 경우 검색 폴더는 검색 폴더의 데이터가 변경될 때마다 업데이트됩니다. 이러한 업데이트의 경우 CPU와 디스크 리소스가 사용됩니다. 검색 폴더의 캐시가 여러 개 유지 관리되는 경우 CPU 성능과 디스크 성능에 더 많은 영향을 줄 수 있습니다.

한편, Exchange Server에서 검색 폴더를 처음으로 만들 경우 검색 폴더가 생성될 때 Outlook 폴더에 액세스하는 사용자는 지연을 느낄 수 있습니다.

11개의 검색 폴더로 구성된 Exchange Server로 예를 들어 봅니다. 11개는 기본 검색 폴더 수입니다. 사용자 A는 15명의 다른 사용자와 일정 폴더를 공유합니다. 사용자 B는 자신의 검색 폴더가 생성되는 동안 폴더에 액세스하면 지연을 느끼게 됩니다. 사용자 B의 검색 폴더가 만들어지면 사용자 A의 일정 폴더에 대한 액세스가 빨라집니다. 사용자 B는 하루 중 남은 시간 동안 해당 폴더에 액세스하지 않는다고 가정합니다. 한편, 11명의 다른 사용자가 해당 폴더에 액세스하는 경우에는 사용자마다 고유 검색 폴더가 만들어집니다. 11개의 검색 폴더만 캐시되므로 다음에 사용자 B가 사용자 A의 일정에 액세스할 때 사용자 B는 자신의 새 검색 폴더가 생성되는 동안 다시 지연을 느끼게 됩니다.

가장 좋은 방법은 최대 검색 폴더 캐시 수를 20개 이하로 제한하는 것입니다. 이 값을 초과하면 5,000개 이상의 항목이 있는 폴더의 경우에는 특히 서버가 캐시된 폴더를 유지 관리할 때 오버로드될 수 있습니다.

또한 캐시는 5개 정도로 유지하는 것이 좋습니다. 사용자가 여러 명의 사용자와 Outlook 폴더를 공유하는 경우 4개의 검색 폴더만 캐시하면 클라이언트 환경에 부정적인 영향을 줄 수 있고 서버에서 보다 자주 새로운 캐시를 만들 때 더 많은 리소스를 사용하게 됩니다.

msExchMaxCachedViews 특성도 공용 폴더 데이터베이스에서 설정할 수 있습니다. 공용 폴더에 대한 검색 폴더도 생성됩니다. 기본적으로 공용 폴더는 다수의 사용자가 액세스할 수 있는 공유 리소스입니다. 공용 폴더에 수신되는 게시물이 많은 경우 검색 폴더가 업데이트될 때 Exchange Server의 CPU와 디스크 사용량이 증가할 수 있으므로 검색 폴더 수를 최소화해야 합니다. 또한 서로 다른 많은 사용자가 하나의 공용 폴더에 액세스하는 경우 많은 검색 폴더 캐시를 제공하여 클라이언트 환경을 최적화하는 것은 좋지 않습니다. 새로운 사용자에 대해 새 검색 폴더가 만들어질 때 이러한 캐시는 삭제될 수 있습니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
msExchMaxCachedViews 특성을 수정하려면 다음을 수행합니다.

  1. Microsoft Windows® 2000 지원 도구 또는 Windows Server 2003 지원 도구에서 ADSI 편집 도구를 시작합니다.

  2. 다음 노드를 확장합니다.

    • 구성 컨테이너

    • 구성

    • 서비스

    • Microsoft Exchange

    • Organization_Name

    • 관리 그룹

    • Administrative_Group_Name

    • 서버

    • InformationStore

    • Storage_Group_Name

  3. 세부 정보 창에서 Database_Name을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 특성 상자에서 msExchMaxCachedViews를 두 번 클릭합니다.

  5. 정수 특성 편집기 대화 상자에서 값 필드에 5와 20 사이의 정수를 입력한 다음 확인을 클릭합니다.

  6. 적용을 클릭한 다음 ADSI 편집을 닫습니다.

  7. 적어도 15분 동안 복제되기를 기다린 다음 수정한 Exchange 서버에서 Microsoft Exchange Information Store 서비스를 다시 시작합니다.


최대 ESE 캐시가 수동으로 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-02-21

Microsoft® Exchange Server Analyzer Tool은 모든 사서함 저장소 개체의 msExchESEParamCacheSizeMax 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 사서함 저장소에 대한 msExchESEParamCacheSizeMax 특성 값이 0보다 크지만 219727보다 작을 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange 2000 Server에서 STORE.EXE에서 사용하는 대용량 가상 메모리는 ESE 버퍼에 할당됩니다. Exchange 2000 Server는 이 버퍼에 대해 하드 코드된 기본값 858MB를 사용합니다. Exchange Server 2003에서 ESE 버퍼는 Boot.ini 파일에 있는 /3GB 스위치의 존재 여부에 따라 할당됩니다. /3GB 스위치가 있을 경우 ESE 버퍼는 896MB로 조정됩니다. /3GB 스위치가 없을 경우에는 ESE 버퍼가 576MB로 조정됩니다. 자동 조정은 모든 경우에 유용하지만 자동 조정을 다시 정의하고 수동으로 사용자 환경에 더 적절한 값을 설정할 수 있습니다. 이 값을 8192의 배수로 조정할 수 있지만 다음 표의 값을 사용하는 것이 좋습니다.

권장 값 | 할당되는 메모리 | 설명
147456 | 576MB | 최소 권장 값입니다. 이 값보다 낮은 값으로 설정하지 마십시오. 이 값은 /3GB 스위치가 지원되지 않고 가상 메모리가 제약된 서버와 /3GB 스위치가 지원되지 않고 Microsoft® Windows® 2000 Server에서 실행되는 Exchange Server 2003 컴퓨터에 유용합니다. 이 값은 또한 /3GB 스위치를 사용하지 않는 시스템의 기본값에 해당합니다.
196608 | 768MB | 대용량 가상 메모리가 있고 9582 이벤트를 자주 기록하는 서버에 이 값이 권장됩니다.
219726 | 858MB | Exchange 2000 Server에서는 이 값이 기본값이며 대용량 가상 메모리가 있는 경우 업그레이드하는 시스템에서 사용하기에 적절한 값입니다.
229376 | 896MB | Exchange Server 2003의 기본값입니다. 응용 프로그램 이벤트 로그에서 9582 이벤트에 대해 다르게 지정하지 않는 이상 새 시스템에는 이 값을 사용하는 것이 좋습니다.
311296 | 1.2GB | 설정할 수 있는 최대값입니다. 실제 메모리가 2GB 이상인 시스템에서만 사용해야 합니다.

이 값을 다시 구성하기 전에 STORE.EXE 프로세스에서 소비하는 가상 메모리 양을 모니터링해야 합니다. Windows에서 Process 성능 개체를 모니터링하면 이 작업을 할 수 있습니다. /3GB 스위치가 있는 시스템에서는 Process 개체의 STORE.EXE 인스턴스에 대한 Virtual Bytes 카운터가 2.8GB보다 작아야 합니다. /3GB 스위치가 없는 시스템에서는 1.8GB보다 작아야 합니다. 값이 이러한 값보다 크면 msExchESEParamCacheSizeMax 값을 낮춰야 할 수 있습니다. 값이 이러한 값보다 적으면 msExchESEParamCacheSizeMax 값을 높여야 할 수 있습니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

msExchESEParamCacheSizeMax 특성을 조정하려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 엽니다.

  2. Configuration 컨테이너를 두 번 클릭합니다.

  3. CN=Services를 확장합니다.

  4. CN=Microsoft Exchange를 확장합니다.

  5. CN=<Exchange Organization Name>을 확장합니다.

  6. CN=Administrative Groups를 확장합니다.

  7. CN=<Administrative Group Name>을 확장합니다.

  8. CN=Servers를 확장합니다.

  9. CN=<Exchange Server Name>을 확장합니다.

  10. CN=InformationStore를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  11. 특성 필드에서 msExchESEParamCacheSizeMax가 나타날 때까지 스크롤한 다음 두 번 클릭합니다.

  12. 값 필드에 설정할 값을 입력합니다. 이 문서의 표를 사용하여 사용 중인 시스템에 가장 적합한 값을 결정합니다. 사용할 값은 8192의 배수여야 합니다.

  13. 확인을 클릭한 다음 다시 확인을 클릭합니다.

  14. 변경 내용을 적용하려면 Active Directory 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작합니다.

메모리 사용 최적화에 대한 자세한 내용은 Microsoft 기술 자료 문서 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)을 참조하십시오.

msExchESEParamCacheSizeMax 특성에 대한 자세한 내용은 기술 자료 문서 266768, "XSTR: How to modify the Store Database maximum cache size"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768)를 참조하십시오.


최대 ESE 캐시가 너무 크게 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-02-21

Microsoft® Exchange Server Analyzer Tool은 모든 사서함 저장소 개체의 msExchESEParamCacheSizeMax 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 또한 Exchange Server Analyzer는 VMLargestBlockSize 키 값을 확인할 때 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. VMLargestBlockSize 키는 가상 메모리의 사용 가능한 최대 블록 크기(바이트)를 나타냅니다.

마지막으로 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열된 항목 개수를 확인할 때도 Active Directory를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다.

Exchange Server Analyzer는 사서함 수가 20개를 초과하는 Exchange Server 컴퓨터에서 msExchESEParamCacheSizeMax 값이 219726보다 크고 VMLargestBlockSize 값이 50000000보다 크지만 150000000보다 작을 경우 오류를 표시합니다. 이 오류는 이 Exchange Server 컴퓨터에서 msExchESEParamCacheSizeMax 특성이 너무 높게 설정되어 있음을 나타냅니다.

Exchange 2000 Server에서는 STORE.EXE에 의해 사용되는 가상 메모리의 많은 부분이 ESE 버퍼에 할당됩니다. Exchange 2000 Server는 이 버퍼에 대해 하드 코드된 기본값 858MB를 사용합니다. Exchange Server 2003에서 ESE 버퍼 할당은 Boot.ini 파일에 /3GB 스위치가 있는지에 달려 있습니다. /3GB 스위치가 있을 경우 ESE 버퍼는 896MB로 조정됩니다. /3GB 스위치가 없을 경우에는 ESE 버퍼가 576MB로 조정됩니다. 모든 경우에 자동 조정을 사용할 수 있지만 자동 조정을 무시하고 수동으로 사용자 환경에 더 적절한 값을 설정할 수 있습니다. 이 값을 8192의 배수로 조정할 수 있지만 다음 표의 값을 사용하는 것이 좋습니다.

권장 값 | 할당되는 메모리 | 설명
147456 | 576MB | 최소 권장 값입니다. 이보다 적은 값으로 설정하지 마십시오. 이 값은 /3GB 스위치가 지원되지 않고 가상 메모리가 제약된 서버와 /3GB 스위치가 지원되지 않고 Microsoft Windows 2000 Server에서 실행되는 Exchange Server 2003 컴퓨터에 유용합니다. 이 값은 또한 /3GB 스위치를 사용하지 않는 시스템의 기본값에 해당합니다.
196608 | 768MB | 대용량 가상 메모리가 있고 9582 이벤트를 자주 기록하는 서버에서도 이 값이 권장됩니다.
219726 | 858MB | Exchange 2000 Server에서는 이 값이 기본값이며 대용량 가상 메모리가 있는 시스템을 내부 업그레이드하는 경우 이 값을 사용하는 것이 좋습니다.
229376 | 896MB | Exchange Server 2003의 기본값입니다. 응용 프로그램 이벤트 로그에서 9582 이벤트에 대해 다르게 지정하지 않는 이상 새 시스템에는 이 값을 사용하는 것이 좋습니다.
311296 | 1.2GB | 설정할 수 있는 최대값입니다. 실제 메모리가 2GB 이상인 시스템에서만 사용해야 합니다.

이 값을 다시 구성하기 전에 STORE.EXE 프로세스에서 소비하는 가상 메모리 양을 모니터링해야 합니다. Windows에서 Process 성능 개체를 모니터링하면 됩니다. /3GB 스위치가 있는 시스템에서는 Process 개체의 STORE.EXE 인스턴스에 대한 Virtual Bytes 카운터가 2.8GB보다 작아야 합니다. /3GB 스위치가 없는 시스템에서는 1.8GB보다 작아야 합니다. 값이 이러한 양보다 크면 msExchESEParamCacheSizeMax 값을 낮춰야 할 수 있습니다. 값이 이러한 양보다 작으면 msExchESEParamCacheSizeMax 값을 높여야 할 수 있습니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

msExchESEParamCacheSizeMax 특성을 조정하려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 엽니다.

  2. Configuration 컨테이너를 두 번 클릭합니다.

  3. CN=Services를 확장합니다.

  4. CN=Microsoft Exchange를 확장합니다.

  5. CN=<Exchange Organization Name>을 확장합니다.

  6. CN=Administrative Groups를 확장합니다.

  7. CN=<Administrative Group Name>을 확장합니다.

  8. CN=Servers를 확장합니다.

  9. CN=<Exchange Server Name>을 확장합니다.

  10. CN=InformationStore를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  11. 특성 필드에서 msExchESEParamCacheSizeMax가 나타날 때까지 스크롤한 다음 두 번 클릭합니다.

  12. 값 필드에 설정할 값을 입력합니다. 이 문서의 표를 사용하여 사용 중인 시스템에 가장 적합한 값을 결정합니다. 사용할 값은 8192의 배수여야 합니다.

  13. 확인을 클릭한 다음 다시 확인을 클릭합니다.

  14. 변경 내용을 적용하려면 Active Directory 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작합니다.

메모리 사용 최적화에 대한 자세한 내용은 Microsoft 기술 자료 문서 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)을 참조하십시오.

msExchESEParamCacheSizeMax 특성에 대한 자세한 내용은 기술 자료 문서 266768, "XSTR: How to modify the Store Database maximum cache size"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768)를 참조하십시오.


최대 ESE 캐시 크기가 증가되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-02-21

Microsoft® Exchange Server Analyzer Tool은 모든 사서함 저장소 개체의 msExchESEParamCacheSizeMax 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

또한 Exchange Server Analyzer는 VMLargestBlockSize 키 값을 확인할 때 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. VMLargestBlockSize 키는 가상 메모리의 사용 가능한 최대 블록 크기(바이트)를 나타냅니다.

마지막으로 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열된 항목 개수를 확인할 때도 Active Directory를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다.

Exchange Server Analyzer는 사서함 수가 20개를 초과하는 Exchange Server 컴퓨터에서 msExchESEParamCacheSizeMax 값이 219726보다 크고 VMLargestBlockSize 값이 다음 값 범위에 없을 경우 경고를 표시합니다.

  • 50000000보다 크고 150000000보다 작음

  • 0보다 크고 50000001보다 작음

이 경고는 이 Exchange Server 컴퓨터에서 msExchESEParamCacheSizeMax 특성이 증가되었기 때문에 가상 메모리가 부족해질 수 있음을 나타냅니다.

Exchange 2000 Server에서는 STORE.EXE에서 사용하는 가상 메모리의 많은 부분이 EXE 버퍼에 할당됩니다. Exchange 2000 Server는 이 버퍼에 대해 하드 코드된 기본값 858MB(메가바이트)를 사용합니다. Exchange Server 2003에서 ESE 버퍼는 Boot.ini 파일에 있는 /3GB 스위치의 존재 여부에 따라 할당됩니다. /3GB 스위치가 있을 경우 EXE 버퍼는 896MB로 조정됩니다. /3GB 스위치가 없을 경우에는 ESE 버퍼가 576MB로 조정됩니다. 자동 조정이 모든 경우 유용하지만 자동 조정을 무시하고 사용 중인 환경에 더 적합한 값을 수동으로 설정할 수 있습니다. 이 값을 8192의 배수로 조정할 수 있지만 다음 표에 있는 값만 사용하는 것이 좋습니다.

권장 값 | 할당되는 메모리 | 설명
147456 | 576MB | 최소 권장 값입니다. 이 값보다 낮은 값으로 설정하지 마십시오. 이 값은 /3GB 스위치가 지원되지 않는 Microsoft Windows 2000 Server에서 실행되는 Exchange Server 2003 컴퓨터 및 가상 메모리 제한 서버에 유용합니다. 이 값은 또한 /3GB 스위치를 사용하지 않는 시스템의 기본값에 해당합니다.
196608 | 768MB | 대용량 가상 메모리가 있고 9582 이벤트를 자주 기록하는 서버에 이 값이 권장됩니다.
219726 | 858MB | Exchange 2000 Server의 기본값입니다. 대용량 가상 메모리가 있는 시스템을 내부 업그레이드하는 경우 사용하는 것이 좋습니다.
229376 | 896MB | Exchange Server 2003의 기본값입니다. 응용 프로그램 이벤트 로그에서 9582 이벤트에 대해 다르게 지정하지 않는 이상 새 시스템에는 이 값을 사용하는 것이 좋습니다.
311296 | 1.2GB | 설정할 수 있는 최대값입니다. 이 값은 실제 메모리가 2GB 이상인 시스템에서만 사용해야 합니다.

이 값을 다시 구성하기 전에 STORE.EXE 프로세스에서 소비하는 가상 메모리 양을 모니터링해야 합니다 Windows에서 Process 성능 개체를 모니터링하면 됩니다. /3GB 스위치가 있는 시스템에서는 Process 개체의 STORE.EXE 인스턴스에 대한 Virtual Bytes 카운터가 2.8GB보다 작아야 합니다. /3GB 스위치가 없는 시스템에서는 1.8GB보다 작아야 합니다. 값이 이러한 양보다 클 경우 msExchESEParamCacheSizeMax의 값을 줄여야 할 수 있습니다. 값이 이보다 작을 경우 msExchESEParamCacheSizeMax의 값을 늘려야 할 수 있습니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003이나 Exchange Server 2003을 다시 설치하거나 두 가지 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

msExchESEParamCacheSizeMax 특성을 조정하려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 엽니다.

  2. Configuration 컨테이너를 두 번 클릭합니다.

  3. CN=Services를 확장합니다.

  4. CN=Microsoft Exchange를 확장합니다.

  5. CN=<Exchange Organization Name>을 확장합니다.

  6. CN=Administrative Groups를 확장합니다.

  7. CN=<Administrative Group Name>을 확장합니다.

  8. CN=Servers를 확장합니다.

  9. CN=<Exchange Server Name>을 확장합니다.

  10. CN=InformationStore를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  11. 특성 필드에서 msExchESEParamCacheSizeMax가 나타날 때까지 스크롤한 다음 두 번 클릭합니다.

  12. 값 필드에 설정할 값을 입력합니다. 이 문서의 표를 사용하여 시스템에 가장 적합한 값을 결정합니다. 사용하는 값은 8192의 배수여야 합니다.

  13. OK를 클릭한 다음 다시 확인을 클릭합니다.

  14. 변경 내용을 적용하려면 Active Directory 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작합니다.

메모리 사용 최적화에 대한 자세한 내용은 Microsoft 기술 자료 문서 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)을 참조하십시오.

msExchESEParamCacheSizeMax 특성에 대한 자세한 내용은 기술 자료 문서 266768, "XSTR: How to modify the Store Database maximum cache size"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768)를 참조하십시오.


MaxOpenMessagesPerLogon이 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-05-14

Microsoft Exchange Analyzer Tool은 MaxOpenMessagesPerLogon 레지스트리 값의 존재 및 구성을 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Analyzer는 MaxOpenMessagesPerLogon 레지스트리 값이 0보다 큰 값으로 구성되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

MAPI 클라이언트 또는 응용 프로그램이 Exchange Server 컴퓨터에서 메시지를 열 때마다 Microsoft Exchange Information Store 서비스(store.exe)는 소량의 실제 메모리를 소비하게 됩니다. Microsoft Office Outlook 2003 또는 Outlook 2007 클라이언트에서 메시지를 닫으면 메모리는 해제됩니다. 하나 이상의 MAPI 클라이언트에서 Exchange 저장소 서비스에 연속적인 메모리 할당을 방지하기 위해 Exchange 2000 Server 서비스 팩 1(SP1)에 새 구성 기능이 도입되었습니다. 관리자는 이 기능을 통해 각 MAPI 클라이언트 로그온 세션에서 동시에 열 수 있는 메시지 수를 제한할 수 있습니다. 이와 같은 한도를 설정하면 특정 클라이언트 응용 프로그램에서 서버의 전반적인 성능에 영향을 줄 수 있을 정도로 많은 메시지를 연 경우에 유용할 수도 있습니다.

이 기능은 Exchange Server 컴퓨터의 MaxOpenMessagesPerLogon 레지스트리 값을 사용하여 구현됩니다. 한도는 1000 이하로 설정하는 것이 좋습니다. 값을 1,000으로 설정하면 각 클라이언트는 대략 4MB에서 6MB의 메모리를 사용할 수 있습니다. 일부 환경에서는 500 이하의 값이 적절할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집 방법에 대한 정보가 포함되어 있습니다. 레지스트리를 편집하기 전에 문제가 발생할 경우에는 복원 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

동시에 열 수 있는 최대 메시지 수를 구성하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음을 엽니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. ParametersSystem을 마우스 오른쪽 단추로 클릭하고 새로 만들기 | DWORD 값을 선택하고 새 값의 이름을 MaxOpenMessagesPerLogon으로 지정합니다.

  4. 오른쪽 창에서 MaxOpenMessagesPerLogon 값을 두 번 클릭한 다음 동시에 열 수 있는 최대 메시지 수(십진수)를 입력합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MaxOpenMessagesPerLogon 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 289109, "XADM: How to Limit the Number of Messages Opened for Each MAPI Logon"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=289109)을 참조하십시오.


저장소 그룹당 최대 데이터베이스 수가 수동으로 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 저장소 그룹의 msExchMaxStoresPerGroup 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 저장소 그룹의 msExchMaxStoresPerGroup 특성 값이 5가 아닐 경우 오류를 표시합니다.

이 값은 서버에 있는 모든 저장소 그룹에 적용됩니다. 이 특성 값이 기본값인 5에서 다른 값으로 변경되면 이러한 특정 오류가 발생합니다. 이 특성 값으로 5만 지정할 수 있으며 다른 값으로 변경하면 안 됩니다. 이 값을 늘리면 Exchange Server가 제대로 작동하지 않습니다.

ADSI(Active Directory Service Interfaces) 편집 스냅인, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 도구를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집을 시작합니다.

  2. Configuration 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=<ExchangeOrganizationName>을 차례로 확장합니다.

  3. CN=Administrative Groups, CN=<AdministrativeGroupName>, CN=Servers를 차례로 확장합니다.

  4. CN=<ServerName>을 확장하고 CN=InformationStore를 마우스 오른쪽 단추로 클릭한 후 속성을 클릭합니다.

  5. Attribute Editor에서 msExchMaxStoresPerGroup 특성을 클릭한 후 Edit를 클릭합니다.

  6. Edit Attribute 상자에서 값을 5로 설정합니다.

  7. 적용을 클릭한 다음 확인을 클릭합니다.

  8. ADSI 편집을 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

허용되는 최대 저장소 그룹 수에 대한 자세한 내용은 Microsoft 기술 자료 문서 251123, "XADM: 데이터베이스 용량 계획을 위한 Exchange 2000의 최대 저장소 그룹 수"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=251123)를 참조하십시오.

ADSI 편집 작업에 대한 자세한 내용은 Windows Server 도움말의 "Adsiedit.msc: ADSI 편집" 항목을 참조하십시오.


최대 저장소 그룹 수가 수동으로 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 InformationStore 컨테이너의 msExchMaxStorageGroups 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchMaxStorageGroups 특성 값이 4와 다르면 오류를 표시합니다.

msExchMaxStorageGroups 특성 값으로는 4만 지원되므로 이 값은 변경하지 않아야 합니다. 이 값을 수정하면 Exchange가 올바르게 작동하지 않습니다.

ADSI(Active Directory Service Interfaces) 편집 스냅인, LDP(ldp.exe) 도구, 기타 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트 같은 Active Directory 편집기를 사용하여 값을 수정해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집이나 비슷한 도구를 사용하여 Active Directory에서 이 서버에 대한 InformationStore 개체를 찾습니다.

    msExchMaxStorageGroups 특성은 다음 위치에 있습니다.

    CN=Configuration,DC=Domain,CN=com, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdminGroupName, CN=Servers, CN=ServerName, CN=InformationStore

  2. 새 값으로 4를 입력하여 msExchMaxStorageGroups 특성을 편집합니다.

  3. Active Directory 편집기를 닫고 Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

LDP 도구 사용에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.


로그온당 열린 최대 폴더 개체 수가 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 MAPI 세션당 열 수 있는 최대 폴더 수의 기본값이 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolder

Exchange Server Analyzer는 objtFolder 레지스트리 값이 500 이외의 값으로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

수동으로 추가 및 구성된 경우 objtFolder 레지스트리 값에 따라 MAPI 클라이언트당 열 수 있는 최대 폴더 수가 결정됩니다. 기본적으로 Exchange Server 2003 및 Exchange Server 2007은 열린 폴더 수를 500개로 제한합니다. MAPI 클라이언트가 500개가 넘는 폴더를 열려고 시도하면 클라이언트의 사서함을 포함하는 Exchange Server 컴퓨터의 응용 프로그램 이벤트 로그에 다음과 같은 이벤트가 기록됩니다.

이벤트 종류: | 오류
이벤트 ID: | 9646
이벤트 원본: | MSExchangeIS
이벤트 범주: | 일반
설명: | "objtFolder" 유형의 개체가 최대 500개를 초과했으므로 Mapi 세션 "/o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName"을 닫고 있습니다.

objtFolder 레지스트리 값을 통해 관리자는 MAPI 클라이언트에서 사용하는 Exchange Server 리소스를 더 많이 제어할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음을 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. objtFolder 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

  5. 또는 objtFolder 레지스트리 값을 삭제하지 않고 사용하려는 경우 기존의 설정값을 그대로 유지하거나 필요한 대로 조정합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)을 참조하십시오.

자세한 내용은 기술 자료 문서 830829, "Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829)를 참조하십시오.


로그온당 열린 최대 폴더의 보기 수가 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 MAPI 세션당 열 수 있는 최대 폴더 보기 수의 기본값이 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolderView

Exchange Server Analyzer는 objtFolderView 레지스트리 값이 500 이외의 값으로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

수동으로 추가 및 구성된 경우 objtFolderView 레지스트리 값에 따라 MAPI 클라이언트당 열 수 있는 최대 폴더 보기 수가 결정됩니다. 기본적으로 Exchange Server 2003 및 Exchange Server 2007은 열린 폴더 보기 수를 500개로 제한합니다. MAPI 클라이언트가 500개가 넘는 폴더 보기를 열려고 시도하면 클라이언트의 사서함을 포함하는 Exchange Server 컴퓨터의 응용 프로그램 이벤트 로그에 다음과 같은 이벤트가 기록됩니다.

이벤트 종류: 오류

이벤트 원본: MSExchangeIS

이벤트 범주: 일반

설명: MAPI 세션 "/o= OrganizationName /ou= AdministrativeGroupName /cn=Recipients/cn= UserName " "objtFolderView" 유형의 개체가 최대 500개를 초과했으므로 해당 세션을 닫고 있습니다.

objtFolderView 레지스트리 값을 통해 관리자는 MAPI 클라이언트에서 사용하는 Exchange Server 리소스를 더 많이 제어할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 방법에 대한 정보가 들어 있습니다. 레지스트리를 편집하기 전에 문제가 발생하는 경우 레지스트리를 복원하는 방법에 대해 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음을 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession

  3. objtFolderView 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

  5. 또는 objtFolderView 레지스트리 값을 삭제하지 않고 사용하려는 경우 기존의 설정값을 그대로 유지하거나 필요하면 조정합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)을 참조하십시오.

자세한 내용은 Microsoft 기술 자료 문서 830829, "Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829)를 참조하십시오.


로그온당 최대 열린 메시지 개체 수가 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 MAPI 세션당 기본 최대 열린 메시지 수가 변경되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtMessage

Exchange Server Analyzer는 objtMessage 레지스트리 값이 250 이외의 값으로 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

수동으로 추가하고 구성한 objtMessage 레지스트리 값은 MAPI 클라이언트당 최대 열린 메시지 수를 결정합니다. 기본적으로 Exchange Server 2003 및 Exchange Server 2007은 열린 메시지 수를 250개로 제한합니다. MAPI 클라이언트가 250개보다 많은 메시지를 열려고 하면 클라이언트의 사서함을 포함하는 Exchange Server 컴퓨터의 응용 프로그램 이벤트 로그에 다음과 같은 이벤트가 기록됩니다.

이벤트 종류: 오류

이벤트 ID: 9646

이벤트 원본: MSExchangeIS

이벤트 범주: 일반

설명: MAPI 세션 "/o= OrganizationName /ou= AdministrativeGroupName /cn=Recipients/cn= UserName 이 "objtMessage" 유형의 개체가 최대 250개를 초과했으므로 해당 세션을 닫고 있습니다.

objtMessage 레지스트리 값을 통해 관리자는 MAPI 클라이언트에서 사용하는 Exchange Server 리소스를 더 많이 제어할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession

  3. objtMessage 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

  5. 또는 objtMessage 레지스트리 값을 삭제하지 않고 사용하려는 경우 기존의 설정값을 그대로 유지하거나 필요하면 조정합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)을 참조하십시오.

자세한 내용은 기술 자료 문서 830829, "Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829)를 참조하십시오.


최대 폴링 빈도가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 값을 읽어 RPC over HTTP를 사용하여 Exchange Server 2003 또는 Exchange Server 2007에 액세스하는 Microsoft Office Outlook® 2003 및 Outlook 2007 클라이언트에 대한 폴링 간격이 기본값과 다르게 수정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Maximum Polling Frequency

Exchange Server Analyzer는 Maximum Polling Frequency 레지스트리 키가 0보다 큰 값으로 구성되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server에 처음으로 연결되면 Outlook은 새 메시지 알림을 받도록 등록합니다. 새 메시지가 Outlook 사용자 사서함에 수신되면 Exchange는 UDP(User Datagram Protocol)을 사용하여 Outlook에 알림을 보냅니다. Outlook이 이 알림을 받으면 Exchange 서버에서 받은 메시지를 검색하여 적절한 폴더에 표시합니다. Outlook이 새 메일 알림을 받지 못하면 Exchange 서버를 다시 폴링하기 시작합니다. 폴링이 Outlook에 의해 시작되어도 폴링 빈도는 Exchange 서버의 의해 제어됩니다.

기본적으로 Outlook 2003은 60초마다 폴링합니다. Maximum Polling Frequency 레지스트리 항목을 사용자 사서함이 있는 Exchange 서버에 추가하여 빈도를 변경할 수 있습니다. 입력하는 값은 폴링 간격 간의 최소 시간(밀리초)입니다. Maximum Polling Frequency가 없으면 기본값인 60초(60,000밀리초)가 사용됩니다. 이 기본값은 60초마다 폴링이 발생되는 것을 의미하지는 않습니다. 이 값은 폴링 빈도 간격과 그 간격의 두 배가 되는 시간 사이에 언제든지 발생하는 것을 의미합니다. 예를 들어 Maximum Polling Frequency가 90초로 설정되어 있다고 가정합시다. 이 예제에서 마지막 폴링 이후에 폴링은 90초와 180초 사이에 발생됩니다.

기본값인 60초 이하로 값을 줄이면 Exchange, Outlook 및 네트워크의 성능이 저하되므로 기본값 이하로 줄이지 않아야 합니다. 사용자의 작업이 많으면 내부 작업의 일부로 새 메시지를 확인하기 때문에 이 값을 조정할 필요가 없습니다. 예를 들어 사용자가 폴더를 전환하거나 메시지를 열면 서버의 새 항목이 표시됩니다. Outlook에서 필요한 RPC 요청을 Exchange로 보내어 사용자 작업을 적용할 때 새 메시지 플래그가 선택되고 새 메시지가 있을 경우 새 메시지 알림이 Outlook으로 다시 전송된 RPC 응답에 포함되므로 이런 결과가 나타납니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. Maximum Polling Frequency 레지스트리 값을 삭제합니다.

  4. Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC over HTTP에 대한 자세한 내용은 Exchange Server 2003 RPC over HTTP Deployment Scenarios 가이드(http://go.microsoft.com/fwlink/?LinkId=47577)를 참조하십시오.


최소 ESE 캐시가 수동으로 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-01-16

Microsoft® Exchange Server Analyzer Tool은 모든 사서함 저장소 개체의 msExchESEParamCacheSizeMin 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 사서함 저장소의 msExchESEParamCacheSizeMin 특성 값이 0보다 클 경우 기본 구성이 아니라는 메시지를 표시합니다.

Microsoft Exchange Information Store 서비스는 저장소 데이터를 디스크에 쓸 때 확장 가능한 저장소 엔진(ESE) 캐시를 버퍼로 사용합니다. Exchange 2000 Server에서 사용하는 최대 캐시 크기는 858MB입니다. Exchange Server 2003은 서버에 설치된 실제 RAM의 크기를 바탕으로 msExchESEParamCacheSizeMin 속성의 기본값을 동적으로 확인합니다.

예를 들어 Boot.ini 파일에 /3GB 스위치가 설정된 Exchange Server 2003 컴퓨터의 최대 캐시 크기는 896MB입니다. 컴퓨터에 /3GB 스위치가 설정되지 않은 경우 최대 캐시 크기는 576MB입니다.

다음 정보를 사용하여 msExchESEParamCacheSizeMin 속성을 원래 값으로 복원할 수 있습니다.

  • Exchange Server 2003이 Microsoft Windows Server™ 2003에서 실행 중이고 서버에 2GB 이상의 RAM이 있는 경우 msExchESEParamCacheSizeMin은 131072(512MB)입니다.

  • Exchange Server 2003이 Windows Server 2003에서 실행 중이고 서버에 768MB 이상 2GB 미만의 RAM이 있는 경우 msExchESEParamCacheSizeMin은 "RAM/4*(4*1024)"와 같습니다.

  • Exchange 2003이 Windows Server 2003에서 실행되고 있고 서버에 768MB 미만의 RAM이 있는 경우 msExchESEParamCacheSizeMin은 "RAM/4*(4*1024)"와 같습니다.

예를 들면 다음과 같습니다.

  • Windows Server 2003에 512MB의 RAM이 있으면 msExchESEParamCacheSizeMin의 기본값은 16,384(4KB 페이지)입니다.

  • Windows Server 2003에 1GB의 RAM이 있으면 msExchESEParamCacheSizeMin의 기본값은 65,536(4KB 페이지)입니다.

  • Windows Server 2003에 4GB의 RAM이 있으면 msExchESEParamCacheSizeMin의 기본값은 131,072(4KB 페이지)입니다.

  • Exchange Server 2003이 Microsoft Windows® 2000 Server에서 실행 중인 경우 기본값은 msExchESEParamCacheSizeMin으로 설정되어 있습니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Windows Server 2003이나 Exchange Server 2003을 다시 설치하거나 두 가지 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. ADSI 편집과 같은 Active Directory 편집기를 엽니다.

  2. Configuration 컨테이너를 두 번 클릭합니다.

  3. CN=Services를 확장합니다.

  4. CN=Microsoft Exchange를 확장합니다.

  5. CN=<Exchange Organization Name>을 확장합니다.

  6. CN=Administrative Groups를 확장합니다.

  7. CN=<Administrative Group Name>을 확장합니다.

  8. CN=Servers를 확장합니다.

  9. CN=<Exchange Server Name>을 확장합니다.

  10. CN=InformationStore를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  11. 특성 필드에서 msExchESEParamCacheSizeMin으로 스크롤한 다음 두 번 클릭합니다.

  12. 값 필드에 설정할 값을 입력합니다. 상황에 맞게 기본 공식을 사용하고 편집할 수 있습니다. 사용하는 값은 32MB의 배수여야 합니다.

  13. OK를 클릭한 다음 다시 확인을 클릭합니다.

  14. Active Directory 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

msExchESEParamCacheSizeMin 특성 조정에 대한 자세한 내용은 Microsoft 기술 자료 문서 822894, "Jet Database Does Not Work Correctly During a Backup or During a Content Indexing Operation"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822894)를 참조하십시오.


저장소 프로세스에 대한 스레드 수가 큽니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange 정보 저장소 프로세스에 대한 ThreadCount 값을 확인하기 위해 Win32_Process Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 값은 서버의 활성 저장소 스레드 수를 나타냅니다. 활성 저장소 스레드 수가 400개가 넘으면 경고 메시지가 표시됩니다.

이 문제는 동일한 시스템에서 실행되는 바이러스 백신 소프트웨어가 호환되지 않을 때 가장 일반적으로 발생합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 공급업체에 문의하여 최신 Exchange 호환 바이러스 백신 소프트웨어를 실행하고 있는지 확인합니다.

  2. 바이러스 백신 소프트웨어를 업데이트합니다.

바이러스 백신 소프트웨어 및 Exchange Server 2003에 대한 자세한 내용은 Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)를 참조하십시오.


OAB Bandwidth Threshold (KBps) 레지스트리 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키를 읽어 OAB Bandwidth Threshold (KBps) 레지스트리 키가 만들어졌는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer는 ParametersSystem에 OAB Bandwidth Threshold (KBps) 레지스트리 키가 만들어졌으면 기본 구성이 아니라는 메시지를 표시합니다.

Microsoft Exchange Server 2003 SP1(서비스 팩 1)에서 관리자는 기본 기능을 무시하고 특정 공용 저장소에서 오프라인 주소록 전체를 다운로드하는 데 사용되는 대역폭을 제한하도록 OAB Bandwidth Threshold (KBps) 레지스트리 키를 설정하고 구성할 수 있습니다.

기본적으로 모든 클라이언트는 요청만 하면 오프라인 주소록 전체를 다운로드할 수 있습니다. 그리고 공용 저장소는 오프라인 주소록 전체를 동시에 다운로드하는 수를 제한하지 않습니다. Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다. 그러나 기본 구성을 복원하려는 경우에는 OAB Bandwidth Threshold (KBps) 레지스트리 키를 삭제할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성을 복원하려면 다음을 수행합니다

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. OAB Bandwidth Threshold (KBps) 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

Microsoft Exchange Information Store 서비스는 몇 분 이내에 변경 내용을 감지합니다. 컴퓨터를 다시 시작할 필요가 없습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

오프라인 주소록을 다운로드하는 동안 사용되는 대역폭의 조절 방법에 대한 자세한 내용은 기술 자료 문서 867623, "Throttling full offline Address Book downloads to limit the effect on a LAN in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=867623)을 참조하십시오.


오프라인 주소록이 특정 사서함 저장소와 연결되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 msExchPrivateMDB 클래스의 msExchUseOAB 특성이 데이터베이스의 특정 사서함 저장소에 대해 특정 오프라인 주소록을 사용하도록 구성되어 있는지 확인합니다. msExchPrivateMDB 클래스는 개인 데이터베이스의 구성을 결정합니다. msExchUseOAB 특성은 특정 사서함 저장소에서 사용하는 특정 오프라인 주소록을 결정합니다. Exchange Server Analyzer는 데이터베이스에 사서함 저장소의 오프라인 주소록이 없으면 오류 메시지를 표시합니다.

Exchange 2000 Server 및 최신 버전에서 오프라인 주소 목록은 정보 저장소에 포함된 모든 사용자와 연결되어 있습니다. 오프라인 주소 목록을 특정 사서함과 자동으로 연결시키거나 정보 저장소 또는 저장소 그룹의 전역 오프라인 주소 목록 설정을 무시할 수 없습니다.

오프라인 주소 목록을 특정 사서함에 연결시키려면 먼저 전역 주소 목록의 필터링된 복사본이 들어 있는 오프라인 주소 목록을 만들어야 합니다. 그런 다음 Active Directory Service Interfaces(ADSI) 편집 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용하여 오프라인 주소 목록을 특정 사서함에 연결시켜 msExchUseOAB 특성을 오프라인 주소 목록의 전체 고유 이름으로 설정해야 합니다.

주의:
ADSI 편집, LDP(ldp.exe) 도구 또는 다른 LDAP 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생될 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

오프라인 주소록을 특정 사서함에 연결시키는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 275203, "Offline Address Book Cannot Be Associated with a Particular Mailbox"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=275203)를 참조하십시오.

오프라인 주소록에 대한 자세한 내용은 Offline Address Book Best Practices Guide(http://go.microsoft.com/fwlink/?LinkId=47583)를 참조하십시오.


공용 폴더의 OLD Completion Time이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 온라인 조각 모음의 시작 지연이 기본 설정에서 변경되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Completion Time

Exchange Server Analyzer는 OLD Completion Time 키가 있는 경우 기본 구성이 아니라는 메시지를 표시합니다. OLD Completion Time 키는 정보 저장소 유지 관리 창 다음에 온라인 조각 모음을 실행할 기간(초)을 지정합니다. 기본값은 1시간(3600초)입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>를 탐색합니다.

  3. OLD Completion Time 키를 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


공용 폴더 저장소의 OLD Minimum RunTime이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 온라인 조각 모음의 최소 실행 시간이 기본 설정에서 변경되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Minimum RunTime

Exchange Server Analyzer는 OLD Minimum RunTime 키가 있는 경우 기본 구성이 아니라는 메시지를 표시합니다. OLD Minimum RunTime 키는 온라인 조각 모음을 실행할 최소 기간(초)을 지정합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>를 탐색합니다.

  3. OLD Minimum RunTime 키를 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


온라인 조각 모음이 비활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 각 저장소 그룹 개체의 msExchESEParamEnableOnlineDefrag 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. True 값을 지정하면 구성된 일정에 따라 온라인 데이터베이스 유지 관리가 수행되며 False 값을 지정하면 온라인 유지 관리가 수행되지 않습니다. Exchange Server Analyzer는 msExchESEParamEnableOnlineDefrag 특성이 False로 설정되어 있으면 오류를 표시합니다.

Exchange Server에서 조각 모음을 비롯한 온라인 데이터베이스 유지 관리 작업은 매우 중요합니다. 이 기간 동안 dumpster 정리(삭제된 항목 보존 날짜를 지난 메시지 삭제), 공용 폴더 만료(공용 폴더에서 특정 날짜보다 오래된 메시지가 만료됨), 삭제된 사서함 정리, 온라인 조각 모음(더 이상 사용되지 않는 데이터베이스 개체를 검색하여 제거함으로써 사용 가능한 데이터베이스 공간 확보) 등의 작업이 수행됩니다. 이러한 프로세스는 Exchange 서버가 정상적인 상태로 작동되도록 하며 안정적인 성능을 보장하는 데 도움이 됩니다. 온라인 데이터베이스 유지 관리를 실행 안 함으로 설정하면 지속적인 성능 저하가 발생할 수 있으므로 권장되지 않습니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 시작, 실행을 차례로 클릭한 후 MMC를 입력하고 확인을 클릭합니다.

  2. Microsoft Management Console(MMC)에서 파일을 클릭한 후 스냅인 추가/제거를 클릭합니다.

  3. 사용 가능한 독립 실행형 스냅인에서 ADSI Edit를 선택하고 추가를 클릭한 후 닫기를 클릭합니다. 스냅인 추가/제거 상자에서 확인을 클릭합니다.

  4. ADSI Edit를 마우스 오른쪽 단추로 클릭한 다음 Connect to를 클릭합니다. Select a well known Naming Context 대화 상자에서 Configuration을 선택하고 OK를 클릭합니다.

  5. 구성 컨테이너 CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Servers, CN=<ServerName>, CN=Information Store를 확장합니다.

  6. CN=<StorageGroupName>을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  7. 저장소 그룹 속성 대화 상자의 특성 목록에서 msExchESEParamEnableOnlineDefrag를 선택하고 Edit를 클릭한 후 값을 True로 변경합니다.

  8. ADSI 편집을 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

온라인 데이터베이스 유지 관리에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Microsoft 기술 자료 문서 314214, "How to set maintenance intervals in data stores in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=314214)

  • Exchange Server 2007 내부 문서 "Exchange Store Maintenance"(http://go.microsoft.com/fwlink/?LinkId=80787)


기본 설정 백필 원본을 사용하도록 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Preferred Backfill Source 키가 기본값과 다르게 수정되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Preferred Backfill Source

기본적으로 Preferred Backfill Source는 존재하지 않습니다. Exchange Server Analyzer는 Preferred Backfill Source가 존재할 경우 기본 구성이 아니라는 메시지를 표시합니다.

공용 폴더 저장소가 복제된 폴더 또는 계층 구조에 대한 업데이트의 일부만 받게 되어 다른 저장소에서 누락된 업데이트를 검색해야 하는 경우 백필이 발생합니다.

백필 프로세스를 효율적으로 수행하기 위해 Exchange Server에서는 누락된 업데이트에 대한 정보를 백필 배열에 저장합니다.

백필 배열은 지정한 기간(백필 시간 제한) 동안 이 정보를 저장합니다. 이 기간 중에 누락된 업데이트가 후속 복제 메시지에 도착하면 해당 정보가 백필 배열에서 제거됩니다. 아래의 표에는 누락된 업데이트의 위치와 이전에 요청한 적이 있는지 여부에 따라 결정되는 기본 백필 시간 제한 값이 나열되어 있습니다.

요청 유형 | 콘텐츠가 로컬 사이트의 저장소에 있는 경우 | 콘텐츠가 원격 사이트의 저장소에 있는 경우
초기 백필 | 6시간 | 12시간
최초 백필 재시도 | 12시간 | 24시간
후속 백필 재시도 | 24시간 | 48시간

백필 시간 제한이 만료되고 업데이트가 아직도 없으면 Exchange Server 2003은 백필 요청을 하나 이상 만들고 백필 원본으로 사용할 서버를 결정합니다.

Exchange Server 2003은 백필 원본으로 사용할 서버를 선택하기 위해 먼저 폴더 복제본이 있는 모든 서버의 목록을 만들고 다음 순서의 기준에 따라 목록을 정렬합니다.

  • 서버 상태에 따라 정렬. 다운되거나 사용할 수 없는 서버는 목록 맨 끝으로 이동합니다.

  • 기본 설정 백필 서버에 따라 정렬. 이 기능은 Exchange Server 2003 이상에서만 사용할 수 있습니다. Exchange Server 2003은 Active Directory® 디렉터리 서비스의 공용 폴더 저장소 개체의 기본 설정 백필 서버를 확인합니다. 이 설정은 거의 사용되지 않습니다. 대부분의 경우 Exchange Server 2003이 백필 서버를 자동으로 선택할 경우에 백필 프로세스가 가장 효율적으로 작동합니다. 대부분의 Exchange Server 2003 배포에서는 기본 설정 백필 서버가 필요하지 않습니다. Microsoft 기술 지원 서비스에서는 배포에 필요한 경우 기본 설정 백필 서버를 설정하는 스크립트를 제공합니다.

  • 전송 순위에 따라 정렬(최저에서 최고 순으로 정렬) 동일한 사이트에 있는 서버가 원격 사이트에 있는 서버보다 우선 순위가 높습니다. 서버의 전송 순위는 Exchange Server 2003 라우팅 엔진에서 계산되며 메시지를 배달하기 위한 가장 효율적인 경로를 계산하는 데 사용됩니다. Exchange Server 2003 이전의 Exchange 버전에서는 전송 순위가 낮은 우선 순위를 가지며 Exchange 버전과 사용 가능한 변경 횟수 이후에 고려됩니다.

  • Exchange 버전에 따라 정렬(최신 버전에서 이전 버전 순으로 정렬)

  • 서버에서 사용 가능한 필수 변경 횟수에 따라 정렬(최대 횟수에서 최소 횟수 순으로 정렬) 변경 내용이 누락되지 않은 서버는 목록에서 제외됩니다.

한 서버에 필요한 변경 내용이 일부 없는 경우 Exchange Server 2003은 정렬된 목록에서 다음 번 서버를 선택하고 백필 요청을 이 서버에도 보냅니다. 모든 변경 내용을 요청할 때까지 이 과정을 반복합니다. 이 기능은 Exchange Server 2003 이상에서만 사용 가능합니다. 따라서 이 버전의 Exchange에서는 단일 서버에 특정 폴더에 대한 누락된 업데이트가 모두 저장되어 있지 않으면 백필 요청을 한 번에 한 서버에만 보냅니다. 이전 버전의 Exchange는 각 요청 후에 재시도 시간 제한(24 시간에서 48 시간까지)이 경과될 때까지 기다렸다가 다음 요청을 보냅니다.

선택한 서버가 백필 요청에 응답하지 않으면 저장소는 해당 서버가 다운되었다고 표시하고 선택 과정을 반복합니다. 표시된 서버는 목록 끝으로 이동합니다.

대부분의 경우 Exchange Server에서 자동으로 백필 서버를 선택할 수 있도록 설정하면 토폴로지가 효율적으로 작동됩니다. Microsoft 기술 지원 서비스에서는 문제 해결을 위해 Preferred Backfill Source를 설정하도록 권장할 수 있지만 특정 문제를 해결하는 데 필요할 경우에만 이 키를 사용합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Preferred Backfill Source 레지스트리 키를 원래대로 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>를 탐색합니다.

  3. Preferred Backfill Source 값을 확인하거나 편집합니다.

    이 레지스트리 항목의 값은 킬로바이트(KB) 단위를 사용합니다. 기본값으로 사용하려면 Preferred Backfill Source를 삭제한 다음 Microsoft Exchange Information Store 서비스를 다시 시작해야 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

공용 폴더 복제에 대한 자세한 내용은 Exchange Server 2003 저장소 작업 (http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 공용 폴더 복제 제어"를 참조하십시오.


기본 설정 공용 폴더 백필 원본을 사용하도록 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange가 공용 폴더 계층 구조에 대한 기본 설정 백필 원본으로 구성되었는지 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>\Preferred Backfill Source

Exchange Server Analyzer는 Preferred Backfill Source 레지스트리 항목이 존재하고 구성되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server 2003에 소개된 새로운 Active Directory® 디렉터리 서비스의 특성인 msexchPreferredBackfillSource 특성에는 백필 요청 메시지를 받아야 하는 Exchange Server를 지정할 수 있습니다.

공용 폴더는 콘텐츠를 복제할 때 Exchange 조직에 쿼리를 보내 백필을 요청합니다. 응답하는 첫 번째 공용 폴더 서버는 데이터를 백필하는 데 사용됩니다. 이 논리는 응답하는 첫 번째 공용 폴더 서버가 가장 가까운 위치에 있다고 가정하지만 항상 그런 것은 아닙니다. Exchange Server 2003에는 관리자가 백필용 기본 설정 서버를 지정할 수 있도록 하는 구성이 있습니다.

Exchange Server 2003에서는 공용 폴더 서버의 Active Directory 특성이나 Preferred Backfill Source 레지스트리 항목을 사용하여 공용 폴더 계층 구조와 콘텐츠를 백필하는 데 기본 설정 서버를 사용하도록 설정할 수 있습니다. Active Directory 매개 변수가 가장 먼저 확인됩니다. 이 매개 변수가 null이면 레지스트리 매개 변수가 확인됩니다. 이 매개 변수도 존재하지 않으면 공용 폴더 백필에 대한 기본 알고리즘이 사용됩니다.

Active Directory 특성을 사용하려면 공용 폴더 저장소 개체에 대한 msExchPreferredBackfillSource 특성에 필요한 백필 공용 폴더 저장소의 고유 이름(DN)을 설정합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Active Directory의 msExchPreferredBackfillSource 특성을 편집하도록 선택한 경우 ADSI(Active Directory Service Interfaces) 편집이나 LDP(ldp.exe) 도구같은 Active Directory 편집기를 사용해야 합니다.

주의:
ADSI 편집, LDP 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

레지스트리에서 기본 설정 공용 폴더 백필 원본을 지정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>를 탐색합니다.

  3. Preferred Backfill Source 값을 검토하고 필요한 경우 변경합니다. 이 값에는 기본 설정할 원본이 속한 Exchange 공용 폴더 저장소의 고유 이름(DN)을 입력해야 합니다.

  4. 레지스트리 내용을 변경했으면 공용 정보 저장소를 분리했다 다시 연결하여 변경 내용을 적용합니다.

Active Direcory에서 기본 설정 공용 폴더 백필 원본을 지정하려면 다음을 수행합니다.

  1. 영향을 받는 공용 폴더 저장소 개체의 msExchPreferredBackfillSource 값이 원하는 백필 원본을 가리키도록 수정합니다. msExchPreferredBackfillSource 특성은 CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName, CN=InformationStore, CN=StorageGroupName, CN=공용 폴더 저장소에 있습니다.

  2. 이 값에는 기본 설정할 원본이 속한 Exchange 공용 폴더 저장소의 고유 이름(DN)을 입력해야 합니다.

  3. 레지스트리 내용을 변경했으면 공용 정보 저장소를 분리했다 다시 연결하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

LDP 도구를 사용하여 Active Directory를 수정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745)를 참조하십시오.


추가 디스크 공간을 제공하십시오.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer Tool에서 Exchange Server를 실행 중인 컴퓨터의 디스크 공간이 적합한 수준 미만임을 확인했습니다. Exchange Server Analyzer는 사용 가능한 디스크 공간을 측정하여 해당 공간이 적합한 범위 내에 있는지 확인합니다. 디스크 공간이 적합한 수준 미만이면 오류 메시지를 표시합니다. Exchange Server를 실행 중인 컴퓨터의 모든 디스크에 있는 사서함에는 10% 이상의 용량을 항상 비워 두는 것이 좋습니다.

Exchange Server Analyzer는 다음 드라이브를 테스트합니다.

  • 데이터베이스 드라이브

  • 임시 드라이브

  • MailRoot 드라이브

  • STM 드라이브

  • 시스템 드라이브

  • 로그 드라이브

    참고:
    상태 테이블은 로그 드라이브 크기를 늘리고 로그를 보관하도록 요구합니다.
  • 페이지 드라이브

이 오류를 수정하려면 다음을 수행합니다.

  1. 디스크 공간을 늘리려면 디스크에서 불필요한 파일을 삭제합니다.

  2. 사용 가능한 공간이 10% 미만인 디스크에 안전하게 다른 디스크로 옮길 수 있는 데이터(예: 사서함이나 Microsoft Windows® 페이지 파일)가 있는 경우 데이터 이동에 필요한 단계를 수행합니다.

  3. Exchange Server를 실행 중인 컴퓨터에 디스크 용량을 추가합니다.

  4. 사서함 크기를 줄이거나 사용자를 다른 서버로 옮깁니다.

추가 정보

  • Exchange Server 2003의 사서함 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 821829, "Exchange Server 2003에서 사서함 이동"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)을 참조하십시오.

  • Exchange 2000 Server와 Exchange 5.5 Server 간의 사서함 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 328810, "XADM: 서버 간에 사서함 이동"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)을 참조하십시오.

  • Exchange Server 2003에서 시스템 정책을 사용하여 사서함 제한을 설정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 822938, "HOW TO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938)을 참조하십시오.

  • Exchange 2000 Server에서 시스템 정책을 사용하여 사서함 제한을 설정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 319130, "HOW TO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2000"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130)을 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 저장소 아키텍처를 설계하는 최상의 방법에 대한 자세한 내용은 여러 아키텍처에 공통적인 유용한 정보(http://go.microsoft.com/fwlink/?LinkId=72988)를 참조하십시오.

  • 디스크 크기 조정, 대기 시간 및 I/O 속도에 대한 자세한 내용은 디스크 I/O 요구 사항을 계산하는 방법(http://go.microsoft.com/fwlink/?linkid=69747)을 참조하십시오.


공용 폴더 저장소 데이터베이스 파일이 네트워크 드라이브에 저장되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 공용 폴더 저장소 개체의 msExchEDBFile 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성은 이 공용 폴더 저장소에 사용되는 데이터베이스 파일의 위치를 지정합니다.

또한 Exchange Server Analyzer는 이 서버에 있는 각 사서함 저장소의 homeMDBBL 특성에 나와 있는 값의 개수를 확인할 때도 Active Directory를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다. 그러면 Exchange Server Analyzer는 해당 서버에서 관리하는 총 사서함 수를 계산할 수 있습니다.

Exchange Server Analyzer는 50개 보다 많은 사서함을 포함하는 Exchange Server에서 msExchEDBFile 특성이 \\로 시작할 경우 오류를 표시합니다.

이 오류는 공용 폴더 저장소에 대한 데이터베이스 파일이 네트워크 공유 위치에 저장됨을 나타냅니다. msExchEDBFile 특성이 \\로 시작되면 로그 파일 경로에 UNC(Universal Naming Convention) 경로가 사용되는 것입니다. 이러한 방식을 사용하면 네트워크 연결이 끊어질 때 데이터베이스 오류가 발생하여 데이터가 손실되거나 데이터베이스가 손상될 수 있으므로 권장되는 방법이 아닙니다. 이 문제는 가능한 빨리 해결하는 것이 좋습니다.

새 드라이브로 데이터베이스 파일을 옮기려면 다음을 수행합니다.

  1. Exchange System Manager에서 저장소가 있는 Exchange 서버 개체를 확장하고 해당 저장소 그룹 컨테이너를 확장한 후 원하는 공용 폴더 저장소 개체를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  2. 속성 대화 상자의 데이터베이스 탭에서 새 파일 위치를 지정합니다.

Exchange Server 데이터베이스 파일에 대한 자세한 내용은 다음 항목을 참조하십시오.

  • Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "사서함 저장소 및 공용 폴더 저장소 관리"

  • Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 저장소 이해"

네트워크 드라이브가 있는 Exchange Server를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328879, "Using Exchange Server with Storage Attached Network and network-attached storage devices"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • 839687, "Microsoft support policy on the use of network-attached storage devices with Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • 317173, "Exchange Server and network-attached storage"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • 317172, "Exchange Server 5.5 and network-attached storage"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


공용 폴더 저장소 데이터베이스 크기 제한이 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 공용 폴더 저장소에 대한 Database Size Limit in Gb 레지스트리 값의 존재 및 구성 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server_Name>\Public-<MailboxStoreGUID>

Exchange Server Analyzer는 Database Size Limit in Gb 레지스트리 값이 있고 구성되어 있음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server 2003 서비스 팩 2(SP2)가 Exchange Server 2003 Standard Edition에 적용되면 하드 코드된 라이센스 데이터베이스 크기 제한이 16GB에서 75GB로 증가합니다. 예기치 않게 데이터베이스 크기가 커지는 것을 방지하기 위해 데이터베이스 크기 제한을 설정할 수 있습니다. SP2의 기본 크기 제한 값은 18GB이며 Database Size Limit in Gb 레지스트리 값을 만들어 이 기본값을 덮어쓸 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<MailboxStoreGUID>를 탐색합니다.

  3. Database Size Limit in Gb 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server 2003 SP2에 대한 자세한 내용은 Exchange Server 2003 서비스 팩 2 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=52073)를 참조하십시오.


공용 폴더 저장소를 8일 이상 전체 백업하지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 마지막 전체 백업 날짜와 시작을 확인할 때 모든 공용 폴더 저장소를 쿼리합니다. Exchange Server Analyzer는 공용 폴더 저장소의 최근 전체 백업 이후 8일을 초과하면 경고를 표시합니다.

공용 폴더 저장소에는 트리가 구성된 방법, 트리에 포함된 폴더 등의 특정 공용 폴더 트리와 관련된 정보가 들어 있습니다. 공용 폴더 내용도 들어 있습니다. 공용 폴더 저장소는 서식 있는 .edb 파일과 스트리밍 전용 인터넷 콘텐츠 .stm 파일로 구성되어 있습니다.

Exchange Server 조직에서 백업해야 할 가장 중요한 데이터는 Exchange Server 데이터베이스의 사서함 저장소와 공용 폴더 저장소 데이터 및 트랜잭션 로그 파일입니다. Exchange Server 데이터베이스 백업을 사용하여 Exchange Server가 실행되는 작동 중인 서버로 손상된 공용 폴더 저장소를 복원할 수 있습니다. 또한 Exchange Server 데이터베이스 백업을 사용하여 Exchange Server 데이터베이스를 다른 서버로 복원할 수 있습니다.

가장 좋은 방법은 매일 데이터베이스 파일과 트랜잭션 로그를 전체 백업하는 것입니다. 저장소 그룹의 전체 백업을 완료한 후에 Exchange Server 데이터베이스의 커밋된 트랜잭션 로그 파일은 서버에서 삭제됩니다. 전체 백업은 모든 데이터를 복원하도록 설정된 테이프 하나만 필요하므로 복구할 경우 속도 면에서 유리합니다.

참고:
데이베이스 파일과 별개의 전용 디스크에 트랜잭션 로그 파일을 보관하는 것이 좋습니다. 그러면 데이터베이스 디스크가 손상된 경우 내결함성을 제공하며 경우에 따라 데이터베이스 성능이 향상될 수도 있습니다.
중요:
파일 및 폴더를 백업하거나 복원하려면 필요한 사용 권한이나 권한이 로그인한 사용자 계정에 지정되어 있어야 합니다. Exchange Server 백업을 만들려면 도메인 수준의 백업 운영자 권한이 있어야 합니다. Microsoft Windows Server™ 2003 운영 체제의 백업을 만들려면 최소한 로컬 백업 운영자 권한이 있어야 합니다.

Exchange Server 데이터에 대해 선택하는 백업 계획은 저장소 크기, 백업 소프트웨어 및 하드웨어 속도, 하드웨어 용량 및 필요한 시간에 따라 다릅니다.

백업 방법 및 재해 복구 작업에 대한 자세한 내용은 다음을 참조하십시오.

  • Exchange Server 2003 재해 복구 작업 가이드(http://go.microsoft.com/fwlink/?linkid=47570)

  • Database Backup and Restore(http://go.microsoft.com/fwlink/?LinkID=80766)


공용 폴더 저장소를 60일 이상 전체 백업하지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 마지막 전체 백업 날짜와 시작을 확인할 때 모든 공용 폴더 저장소를 쿼리합니다. Exchange Server Analyzer는 공용 폴더 저장소의 최근 전체 백업 이후 60일을 초과하면 오류를 표시합니다.

공용 폴더 저장소에는 트리 구성 방법, 트리에 포함된 폴더 등과 같은 특정 공용 폴더 트리와 관련된 정보가 들어 있습니다. 공용 폴더 내용도 들어 있습니다. 공용 폴더 저장소는 서식 있는 .edb 파일과 스트리밍 전용 인터넷 콘텐츠 .stm 파일로 구성되어 있습니다.

Exchange Server 데이터베이스와 트랜잭션 로그 파일의 사서함 저장소 데이터와 공용 폴더 저장소 데이터는 Exchange Server 조직에서 백업해야 할 가장 중요한 데이터입니다. Exchange Server 데이터베이스 백업을 사용하여 Exchange Server가 실행되는 작동 중인 서버로 손상된 공용 폴더 저장소를 복원할 수 있습니다. 또한 Exchange Server 데이터베이스 백업을 사용하여 Exchange Server 데이터베이스를 다른 서버로 복원할 수 있습니다.

가장 좋은 방법은 매일 데이터베이스 파일과 트랜잭션 로그를 전체 백업하는 것입니다. 저장소 그룹의 전체 백업을 완료한 후에 Exchange Server 데이터베이스의 커밋된 트랜잭션 로그 파일은 서버에서 삭제됩니다. 전체 백업은 모든 데이터를 복원하도록 설정된 테이프 하나만 필요하므로 복구할 경우 속도 면에서 유리합니다.

참고:
데이베이스 파일과 별개의 전용 디스크에 트랜잭션 로그 파일을 보관하는 것이 좋습니다. 이러한 방법을 통해 데이터베이스 성능이 향상될 뿐만 아니라 데이터베이스 디스크가 손상된 경우 내결함성이 지원됩니다.
중요:
파일 및 폴더를 백업하거나 복원하려면 필요한 사용 권한이나 권한이 로그인한 사용자 계정에 지정되어 있어야 합니다. Exchange Server 백업을 만들려면 도메인 수준의 백업 운영자 권한이 있어야 합니다. Microsoft Windows Server™ 2003 운영 체제의 백업을 만들려면 최소한 로컬 백업 운영자 권한이 있어야 합니다.

Exchange Server 데이터에 대해 선택하는 백업 계획은 저장소 크기, 백업 소프트웨어 및 하드웨어 속도, 하드웨어 용량 및 필요한 시간에 따라 다릅니다.

백업 방법 및 재해 복구 작업에 대한 자세한 내용은 다음을 참조하십시오.

  • Exchange Server 2003 재해 복구 작업 가이드(http://go.microsoft.com/fwlink/?linkid=47570)

  • Database Backup and Restore(http://go.microsoft.com/fwlink/?LinkId=80766)


공용 폴더 저장소가 12GB를 초과합니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 Exchange 공용 폴더 저장소 데이터베이스 파일(.edb 파일) 및 스트리밍 파일(.stm 파일)에 대한 FileSize 키 값을 확인할 때 CIM_DataFile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 또한 Exchange Server Analyzer는 다음 레지스트리 분기를 읽어 설치된 Exchange Server 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

Exchange Server Analyzer는 Microsoft Exchange Server 2003 Standard Edition 또는 Exchange 2000 Server Standard Edition을 실행하는 컴퓨터에서 한 쌍의 공용 폴더 저장소 데이터베이스와 스트리밍 파일의 전체 크기가 12GB를 초과할 경우 경고를 표시합니다.

Exchange Server 2003 Standard Edition 및 Exchange 2000 Server Standard Edition의 Exchange 저장소 데이터베이스는 16GB보다 커질 수 없습니다. 이 한도에 도달하면 사서함 저장소가 더 이상 탑재되지 않으며 Exchange에 액세스할 수 없습니다. Exchange Server 2003 Enterprise Edition 및 Exchange 2000 Server Enterprise Edition의 Exchange 저장소 데이터베이스는 16GB로 제한되지 않으며 사용 가능한 하드웨어에 의해서만 제한됩니다. 이론적인 최대 크기는 16테라바이트입니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 공용 폴더에 만료 정책을 설정하여 특정 기간이 지난 메시지를 삭제하는 것이 좋습니다.

  2. 공용 폴더 저장소 및 개별 공용 폴더 모두에 저장 용량 제한을 설정하여 공용 폴더 저장소가 무제한으로 커지지 않도록 하는 것이 좋습니다.

  3. 최근에 메시지를 일괄 삭제했거나 공용 폴더 복제본을 이 공용 폴더 저장소에서 제거한 경우 오프라인 조각 모음을 수행하면 파일 크기가 줄어들 수 있습니다.
참고:
Exchange Server 2003 Standard Edition의 Exchange Server 2003 서비스 팩 2(SP2) 버전에서는 하드 코드된 라이센스 데이터베이스 크기 제한이 16GB에서 75GB로 증가되었습니다. 관리자는 예기치 않게 데이터베이스 크기가 커지는 것을 방지하기 위해 데이터베이스 크기 제한을 설정할 수 있습니다. Standard Edition의 SP2에서는 기본값이 18GB이며 Database Size Limit in Gb 레지스트리 키를 편집하여 기본값 18GB를 덮어쓸 수 있습니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Exchange Server 2003 SP2에서 데이터베이스 크기 제한을 구성하려면 다음을 수행합니다.

  1. Exchange Server를 실행하는 컴퓨터에서 Regedit.exe를 시작합니다.

  2. 레지스트리 키 HKLM\System\CurrentControlSet\Services\MSExchangeIS\Server name\Public-Public Store GUID를 엽니다.

  3. Public Store GUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  4. 새 값 이름으로 Database Size Limit in Gb를 입력합니다.

  5. Database Size Limit in Gb를 두 번 클릭합니다. 값 데이터에 최대 데이터베이스 크기(GB)에 적절한 값을 입력합니다. Exchange Server 2003 Standard Edition의 경우 1에서 75 사이의 값을 입력합니다(기본값 18GB). Exchange Server 2003 Enterprise Edition의 경우 1에서 8000 사이의 값을 입력합니다(기본값 8000GB). 확인을 클릭합니다.

  6. Public Store GUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  7. 새 값 이름으로 Database Size Buffer in Percentage를 입력합니다.

  8. Database Size Buffer in Percentage를 두 번 클릭합니다. 값 데이터에 1에서 100 사이의 값을 입력하여 데이터베이스가 최대 크기에 가까워졌음을 경고하는 이벤트의 기록 시기를 지정합니다. 기본값 10을 사용하면 해당 데이터베이스의 최대 크기까지 10% 용량이 남았을 때 경고 이벤트가 기록됩니다. 확인을 클릭합니다.

  9. Public Store GUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  10. 새 이름으로 Database Size Check Start Time in Hours From Midnight를 입력합니다.

  11. Database Size Check Start Time in Hours From Midnight를 두 번 클릭합니다. 값 데이터에 0에서 23 사이의 값을 입력하여 Exchange에서 데이터베이스 크기를 확인하는 시기를 지정합니다. 기본값 5를 사용하면 Exchange Server가 자정 이후 5시간(오전 5:00)이 지나면 데이터베이스 크기를 확인합니다. 확인을 클릭합니다.

  12. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

.stm 및 .edb 파일에 대한 자세한 내용은 Microsoft 기술 자료 문서 232323, "Native Content Storage in Microsoft Exchange"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)를 참조하십시오.

Exchange 2003에서의 사서함 이동에 대한 자세한 내용은 기술 자료 문서 821829, "Moving Mailboxes in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)을 참조하십시오.

Exchange 2000 Server의 사서함 이동에 대한 자세한 내용은 기술 자료 문서 328810, "XADM: 서버 간에 사서함 이동"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)을 참조하십시오.

Exchange Server 데이터베이스의 오프라인 조각 모음 수행에 대한 자세한 내용은 기술 자료 문서 328804, "Exchange 데이터베이스 조각 모음 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804)을 참조하십시오.

공용 폴더의 저장소 제한 설정에 대한 자세한 내용은 기술 자료 문서 823144, "HOW TO: Configure Storage Limits on Public Folders in Exchange 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144)을 참조하십시오.

최대 데이터베이스 크기에 도달한 Exchange Server 2003 Standard Edition 및 Exchange 2000 Server Standard Edition에 대한 자세한 내용은 기술 자료 문서 828070, "사서함 저장소 데이터베이스가 16GB 제한에 도달하면 Exchange Server 사서함 저장소가 탑재되지 않는다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070)를 참조하십시오.

Exchange Server 2003 SP2에 대한 자세한 내용은 Exchange Server 2003 서비스 팩 2 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=52073)를 참조하십시오.


공용 폴더 저장소가 15GB를 초과했습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 Exchange 공용 폴더 저장소 데이터베이스 파일(.edb 파일) 및 스트리밍 파일(.stm 파일)에 대한 FileSize 키 값을 확인할 때 CIM_DataFile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 또한 Exchange Server Analyzer는 다음 레지스트리 분기를 읽어 설치된 Exchange Server 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

Exchange Server Analyzer는 Microsoft Exchange Server 2003 Standard Edition 또는 Exchange 2000 Server Standard Edition을 실행하는 컴퓨터에서 공용 폴더 저장소 데이터베이스 및 스트리밍 파일 한 쌍의 크기가 15GB를 초과하는 경우 오류를 표시합니다.

Exchange Server 2003 Standard Edition 및 Exchange 2000 Server Standard Edition의 Exchange 저장소 데이터베이스는 16GB보다 커질 수 없습니다. 이 한도에 도달하면 사서함 저장소가 더 이상 탑재되지 않으며 Exchange에 액세스할 수 없습니다. Exchange Server 2003 Enterprise Edition 및 Exchange 2000 Server Enterprise Edition의 Exchange 저장소 데이터베이스는 16GB로 제한되지 않으며 사용 가능한 하드웨어에 의해서만 제한됩니다. 이론적인 최대 크기는 16테라바이트입니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. 공용 폴더에 만료 정책을 설정하여 특정 기간이 지난 메시지를 삭제하는 것이 좋습니다.

  2. 공용 폴더 저장소 및 개별 공용 폴더 모두에 저장 용량 제한을 설정하여 공용 폴더 저장소가 무제한으로 커지지 않도록 하는 것이 좋습니다.

  3. 최근에 메시지를 일괄 삭제했거나 공용 폴더 복제본을 이 공용 폴더 저장소에서 제거한 경우 오프라인 조각 모음을 수행하면 파일 크기가 줄어들 수 있습니다.
참고:
Exchange Server 2003 Standard Edition의 Exchange Server 2003 서비스 팩 2(SP2) 버전에서는 하드 코드된 라이센스 데이터베이스 크기 제한이 16GB에서 75GB로 증가되었습니다. 관리자는 예기치 않게 데이터베이스 크기가 커지는 것을 방지하기 위해 데이터베이스 크기 제한을 설정할 수 있습니다. Standard Edition의 SP2에서는 기본값이 18GB이며 Database Size Limit in Gb 레지스트리 키를 편집하여 기본값 18GB를 덮어쓸 수 있습니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Exchange Server 2003 SP2에서 데이터베이스 크기 제한을 구성하려면 다음을 수행합니다.

  1. Exchange Server를 실행하는 컴퓨터에서 Regedit.exe를 시작합니다.

  2. 레지스트리 키 HKLM\System\CurrentControlSet\Services\MSExchangeIS\Server name\Public-Public Store GUID를 엽니다.

  3. Public Store GUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  4. 새 값 이름으로 Database Size Limit in Gb를 입력합니다.

  5. Database Size Limit in Gb를 두 번 클릭합니다. 값 데이터에 최대 데이터베이스 크기(GB)에 적절한 값을 입력합니다. Exchange Server 2003 Standard Edition의 경우 1에서 75 사이의 값을 입력합니다(기본값 18GB). Exchange Server 2003 Enterprise Edition의 경우 1에서 8000 사이의 값을 입력합니다(기본값 8000GB). 확인을 클릭합니다.

  6. Public Store GUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  7. 새 값 이름으로 Database Size Buffer in Percentage를 입력합니다.

  8. Database Size Buffer in Percentage를 두 번 클릭합니다. 값 데이터에 1에서 100 사이의 값을 입력하여 데이터베이스가 최대 크기에 가까워졌음을 경고하는 이벤트의 기록 시기를 지정합니다. 기본값 10을 사용하면 해당 데이터베이스의 최대 크기까지 10% 용량이 남았을 때 경고 이벤트가 기록됩니다. 확인을 클릭합니다.

  9. Public Store GUID를 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  10. 새 이름으로 Database Size Check Start Time in Hours From Midnight를 입력합니다.

  11. Database Size Check Start Time in Hours From Midnight를 두 번 클릭합니다. 값 데이터에 0에서 23 사이의 값을 입력하여 Exchange에서 데이터베이스 크기를 확인하는 시기를 지정합니다. 기본값 5를 사용하면 Exchange Server가 자정 이후 5시간(오전 5:00)이 지나면 데이터베이스 크기를 확인합니다. 확인을 클릭합니다.

  12. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

.stm 및 .edb 파일에 대한 자세한 내용은 Microsoft 기술 자료 문서 232323, "Native Content Storage in Microsoft Exchange"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323)를 참조하십시오.

Exchange 2003에서의 사서함 이동에 대한 자세한 내용은 기술 자료 문서 821829, "Moving Mailboxes in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)을 참조하십시오.

Exchange 2000 Server의 사서함 이동에 대한 자세한 내용은 기술 자료 문서 328810, "XADM: 서버 간에 사서함 이동"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)을 참조하십시오.

Exchange Server 데이터베이스의 오프라인 조각 모음 수행에 대한 자세한 내용은 기술 자료 문서 328804, "Exchange 데이터베이스 조각 모음 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804)을 참조하십시오.

공용 폴더의 저장소 제한 설정에 대한 자세한 내용은 기술 자료 문서 823144, "HOW TO: Configure Storage Limits on Public Folders in Exchange 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144)을 참조하십시오.

최대 데이터베이스 크기에 도달한 Exchange Server 2003 Standard Edition 및 Exchange 2000 Server Standard Edition에 대한 자세한 내용은 기술 자료 문서 828070, "사서함 저장소 데이터베이스가 16GB 제한에 도달하면 Exchange Server 사서함 저장소가 탑재되지 않는다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070)를 참조하십시오.

Exchange Server 2003용 SP2에 대한 자세한 내용은 Exchange Server 2003 서비스 팩 2 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=52073)를 참조하십시오.


공용 폴더 저장소에 전자 메일 주소가 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-03-28

Microsoft® Exchange Server Analyzer Tool은 각 공용 폴더 저장소의 구성된 mail 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 공용 폴더 저장소에 대해 mail 특성이 구성되어 있지 않을 경우 오류를 표시합니다.

공용 폴더 저장소가 SMTP(Simple Mail Transfer Protocol) 주소로 구성되어 있지 않으면 저장소에 대해 공용 폴더 계층 복제를 제대로 수행할 수 없습니다.

기술적으로 공용 폴더 저장소는 특수한 유형의 Exchange 사서함이라고 할 수 있습니다. 다른 모든 사서함 사용 가능 개체와 마찬가지로 공용 폴더 저장소에서 메일을 주고받으려면 다음 특성이 올바르게 구성되어야 합니다.

  • legacyExchangeDN개체에 대한 Exchange 유형의 고유 이름입니다.

  • proxyAddresses이 특성은 해당 받는 사람에게 메일을 보내는 데 사용할 수 있는 모든 전자 메일 주소를 포함합니다.

  • textEncodedORAddress이 특성은 기본 X.400 주소를 포함합니다.

  • Mail 이 특성은 주소 접두사를 제외한 개체의 기본 SMTP 주소를 포함합니다.

  • mailNickname이 특성은 사서함 액세스에 필요한 URL을 생성하는 데 사용합니다.

  • displayName이 특성은 전체 주소 목록 및 해당 개체가 구성원인 다른 주소 목록에 나타나는 개체의 표시 이름을 포함합니다.

공용 폴더 저장소에 대해 mail 특성이 설정되어 있지 않으면 받는 사람 업데이트 서비스가 제대로 구성되지 않거나 작동되지 않을 수 있습니다. 받는 사람 업데이트 서비스에는 두 가지 유형이 있습니다. 하나는 구성 컨테이너에 있는 Exchange 시스템 개체를 처리하고(엔터프라이즈 받는 사람 업데이트 서비스) 다른 하나는 각 도메인의 받는 사람을 처리합니다(도메인 받는 사람 업데이트 서비스).

전체 Active Directory 포리스트에는 구성 컨테이너가 하나뿐이므로 엔터프라이즈 받는 사람 업데이트 서비스가 하나만 있습니다. 공용 폴더 저장소의 다른 항목 중에서 mail 특성을 구성하는 역할을 하는 것이 이 받는 사람 업데이트 서비스입니다. 이 받는 사람 업데이트 서비스가 비활성화되어 있거나 잘못 구성되어 있는 경우 또는 받는 사람 업데이트 서비스에서 문제가 발생하는 경우는 관련 특성이 제대로 구성되지 않은 것일 수 있으며 공용 폴더 복제가 제대로 작동되지 않게 됩니다. 엔터프라이즈 받는 사람 업데이트 서비스의 구성을 확인하여 이 문제를 해결해야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람을 확장한 다음 받는 사람 업데이트 서비스 노드를 선택합니다.

  3. 오른쪽 창에서 이름의 일부로 (Enterprise Configuration)을 포함하는 받는 사람 업데이트 서비스를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  4. 도메인 필드에 올바른 도메인 이름이 표시되는지 확인합니다.

  5. Exchange 서버 및 Windows 도메인 컨트롤러 필드에 나열된 컴퓨터가 정상적으로 작동되고 있으며 네트워크에서 사용 가능한지 확인합니다. 이러한 시스템이 작동 중지되어 있거나 사용 가능하지 않거나 받는 사람 업데이트 서비스 작업을 수행하는 데 필요한 시스템이 아닌 경우는 필드의 찾아보기 단추를 사용하여 다른 시스템을 지정할 수 있습니다.

  6. 업데이트 간격이 항상 실행으로 설정되어 있는지 확인합니다.

  7. 확인을 클릭하여 변경 내용을 저장합니다.

  8. 오른쪽 창에서 이름의 일부로 (Enterprise Configuration)을 포함하는 받는 사람 업데이트 서비스를 마우스 오른쪽 단추로 클릭하고 다시 작성을 선택합니다. 다음 메시지가 표시됩니다.

    "이 작업은 예정된 다음 업데이트 간격에 따라 주소 목록 구성원 및 'contoso.com'에 있는 모든 받는 사람의 받는 사람 정책 설정을 새로 고칩니다. 도메인에 있는 받는 사람 수에 따라 몇 시간이 소요될 수도 있습니다. 계속하시겠습니까?"라는 Exchange System Manager 프롬프트가 나타나면 예를 클릭합니다.

  9. 예를 클릭하여 받는 사람 업데이트 서비스를 다시 작성합니다.

  10. 15분 후에 Microsoft 기술 자료 문서 246127, "XADM: How to Check the Progress of the Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)에 설명된 절차에 따라 받는 사람 업데이트 서비스의 진행 과정을 모니터링합니다.

받는 사람 업데이트 서비스에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 296479, "XADM: Requirements for Disabling the Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=296479)

  • 328738, "XADM: How the Recipient Update Service Applies Recipient Policies"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253770, "XADM: Tasks Performed by the Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 288807, "받는 사람 업데이트 서비스 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=288807)

  • 319065, "HOW TO: Work with the Exchange Recipient Update Service"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065)


공용 폴더 저장소가 시작 시 탑재되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 클래스가 msExchPublicMDB인 모든 개체의 msExchEDBOffline 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 클래스의 개체는 공용 폴더 저장소입니다.

msExchEDBOffline 특성의 True 값은 Microsoft Exchange Information Store 서비스가 시작할 때 공용 폴더 저장소가 자동으로 탑재되지 않음을 나타내고 False 값은 시작 시 공용 폴더 저장소가 탑재됨을 나타냅니다. Exchange Server Analyzer는 이 특성 값이 True이면 경고를 표시합니다.

이 경고는 시작 시 이 저장소 탑재 안 함 확인란이 선택되었음을 나타냅니다. 이 확인란은 공용 폴더 저장소 속성 대화 상자의 데이터베이스 탭에 있습니다. 이 확인란을 선택하면 Microsoft Exchange Information Store 서비스를 시작할 때 공용 폴더 저장소가 자동으로 탑재되지 않습니다. 서버를 다시 부팅한 후와 같이 다음에 Microsoft Exchange Information Store 서비스를 시작할 때 이 특성이 True로 설정된 공용 폴더 저장소는 탑재되지 않습니다. Microsoft Exchange Information Store 서비스를 시작할 때 공용 폴더 저장소를 자동으로 탑재하는 것이 좋습니다.

Exchange 2000 Server 및 Exchange Server 2003에서 이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, 수정할 공용 폴더 저장소가 있는 서버를 차례로 확장합니다.

  3. 수정할 공용 폴더 저장소가 있는 저장소 그룹을 확장합니다.

  4. 공용 폴더 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 데이터베이스 탭에서 시작 시 이 저장소 탑재 안 함 확인란의 선택을 해제합니다.

  6. 확인을 클릭하여 설정을 저장합니다.

  7. Exchange System Manager를 닫습니다.

Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. 서버 구성을 확장하고 작업할 서버를 선택합니다.

  3. 작업할 저장소 그룹을 확장합니다.

  4. 작업할 공용 폴더 데이터베이스를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  5. 일반 탭에서 시작 시 이 데이터베이스 탑재 안 함 확인란의 선택을 취소합니다.

  6. 확인을 클릭하여 설정을 저장합니다.

  7. Exchange 관리 콘솔을 닫습니다.

이 옵션에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 314218, "HOW TO: Turn Off or Turn On Automatic Mounting of Data Stores at Startup in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314218)

  • 285169, "XADM: Information Stores Do Not Mount After You Use the "/disasterrecovery" Switch"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=285169)


공용 폴더 트리 데이터베이스 할당
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 각 msExchPFTree 특성 클래스에 대한 msExchOwningPFTreeBL 특성 값을 확인합니다. msExchOwningPFTreeBL 특성은 공용 폴더 트리의 복제본이 포함되어 있는 공용 폴더 저장소의 고유 이름 목록을 저장합니다. Exchange Server Analyzer는 공용 폴더 저장소 개체의 msExchOwningPFTreeBL 특성이 비어 있으면 경고를 표시합니다. 이 경고는 모든 공용 폴더 저장소에서 공용 폴더 트리를 소유하고 있지 않음을 나타냅니다.

각 공용 폴더 트리("공용 폴더 계층 구조"라고도 함)는 다시 공용 폴더 저장소에 연결됩니다. 먼저 트리를 만든 다음 저장소를 만들어야 합니다. 트리를 아직 데이터베이스에 연결하지 않은 경우 이 경고가 표시됩니다. 각 공용 폴더 트리는 특정 서버 하나에 저장소 하나만 가질 수 있습니다. 각 저장소가 별도의 서버에 존재할 경우에는 트리 하나가 저장소를 여러 개 가질 수 있습니다. 그러한 구성에서는 Exchange에서 계층 구조의 일관성을 유지하기 위해 저장소 간에 정보를 복제합니다.

Microsoft Office Outlook® Web Access 클라이언트가 한 트리 내에 있지만 연결된 공용 폴더 저장소가 없는 공용 폴더에 연결하려고 하면 "서비스를 사용할 수 없음"(HTTP 503) 오류가 발생합니다.

이 경고를 해결하려면 다음 중 한 가지 작업을 수행해야 합니다.

  • 공용 폴더 트리를 공용 폴더 데이터베이스와 연결합니다. 공용 폴더 트리를 공용 폴더 데이터베이스와 연결하려면 먼저 공용 폴더 데이터베이스를 새로 만든 다음 공용 폴더 트리를 찾아서 연결해야 합니다. 또는

  • 공용 폴더 트리를 삭제합니다. 공용 폴더 트리를 공용 폴더 데이터베이스에 아직 연결하지 않은 상태에서는 트리를 삭제해도 사용자 데이터는 손실되지 않습니다.

공용 폴더 트리를 공용 폴더 데이터베이스와 연결하려면 다음을 수행합니다.

  1. Exchange System Manager에서 공용 폴더 저장소를 추가할 서버를 확장합니다.

  2. 특정 저장소 그룹을 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 다음 공용 저장소를 클릭합니다.

  3. 이름에 새 데이터베이스의 이름을 입력합니다.

  4. 공용 폴더 트리를 데이터베이스와 연결하려면 찾아보기를 클릭한 다음 Exchange Server Analyzer 경고에 표시되어 있는 공용 폴더 트리를 선택합니다.

  5. 설정을 저장하려면 확인을 클릭합니다.

  6. 새 저장소를 탑재하려면 예를 클릭합니다.

공용 폴더 트리를 삭제하려면 다음 작업을 수행합니다.

  1. Exchange System Manager에서 해당 공용 폴더 트리가 있는 폴더 노드를 확장합니다.

  2. 삭제할 공용 폴더 트리를 마우스 오른쪽 단추로 클릭하고 삭제를 클릭한 다음 예를 클릭합니다.

공용 폴더 관리에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?linkid=47617)의 "사서함 저장소 및 공용 폴더 저장소 관리"를 참조하십시오.

자세한 내용은 Exchange Server 2003 서비스 팩 1(SP1) 온라인 도움말(http://go.microsoft.com/fwlink/?LinkId=29847)을 참조하십시오.


복구 저장소 그룹 사용
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool 은 개체 클래스가 msExchStorageGroup인 모든 개체의 msExchESEParamBaseName 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 클래스가 있는 개체는 저장소 그룹 개체입니다. msExchESEParamBaseName 특성에 대한 R00 값은 저장소 그룹 개체가 복구 저장소 그룹임을 나타냅니다. Exchange Server Analyzer에서 이 특성 값이 R00임을 확인하면 경고가 표시됩니다.

이 경고는 복구 저장소 그룹이 존재함을 나타냅니다. 복구 프로세스를 완료한 후에 복구 저장소 그룹을 제거하는 것이 좋습니다. 복구 저장소 그룹을 제거하지 않은 경우 복구 저장소 그룹에 대해 잘 모르는 관리자는 나중에 표준 복구를 수행할 때 혼동을 느낄 수 있습니다.

Exchange 2000 Server 및 Exchange Server 2003에서 이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버를 확장한 다음 삭제할 복구 저장소 그룹이 있는 서버를 확장합니다.

  3. 복구 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭합니다.

  4. Exchange System Manager를 닫습니다.

Exchange Server 2007에서 이 경고를 해결하려면 다음을 수행합니다.

  1. 핵심 Exchange Server 2007 설명서 "How to Remove a Recovery Storage Group"(http://go.microsoft.com/fwlink/?LinkId=80783)의 안내를 따릅니다.

복구 저장소 그룹 및 Exchange Server 2003에 대한 자세한 내용은 Using Exchange Server 2003 Recovery Storage Groups(http://go.microsoft.com/fwlink/?LinkId=23233) 및 Microsoft 기술 자료 문서 824126, "Exchange Server 2003에서 복구 저장소 그룹을 사용하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824126)을 참조하십시오.

복구 저장소 그룹 및 Exchange Server 2007에 대한 자세한 내용은 "Understanding Recovery Storage Groups"(http://go.microsoft.com/fwlink/?LinkId=80784)를 참조하십시오.


복구 저장소 그룹 기능을 사용하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 msExchMaxRestoreStorageGroups 특성이 수정되었는지 여부를 확인합니다. msExchMaxRestoreStorageGroups 특성이 0으로 설정되어 있으면 Exchange Server Analyzer에서 오류를 표시합니다.

msExchMaxRestoreStorageGroups 특성은 각 Exchange 컴퓨터의 정보 저장소 개체에 대한 바이너리 특성입니다. msExchMaxRestoreStorageGroups 특성이 0으로 설정되면 복구 저장소 그룹을 지정된 Exchange 컴퓨터에 대해 만들 수 없습니다.

Exchange 2000 Server SP3에서 Windows 클러스터의 Exchange Server 2003 SP1로 내부 업그레이드를 수행하면 이 오류가 발생할 수 있습니다. 이때 Exchange 가상 서버는 Exchange Server 2003으로 업그레이드되지 않습니다. 이 내부 업그레이드 시나리오로 인해 Outlook® Mobile Access가 실패할 수도 있습니다.

각 Exchange 컴퓨터의 정보 저장소 개체에 대해 msExchMaxRestoreStorageGroups 특성을 1로 설정하여 복구 저장소 그룹 오류를 수정해야 합니다. 영향을 받는 정보 저장소 개체는 Exchange Server Analyzer 출력에 표시됩니다. Outlook Mobile Access 문제 관련 도움이 필요한 경우에는 Microsoft 지원에 문의하십시오.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
복구 저장소 그룹 오류를 수정하려면 다음을 수행합니다.

  1. ADSI 편집을 시작합니다.

  2. Configuration 컨테이너를 두 번 클릭하고 CN=Services, CN=Microsoft Exchange, CN=<ExchangeOrganizationName>을 차례로 확장합니다.

  3. CN=Administrative Groups, CN=<AdministrativeGroupName>, CN=Servers를 차례로 확장합니다.

  4. 세부 정보 창에서 CN=InformationStore를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. Attribute Editor에서 msExchMaxStoresPerGroup 특성을 클릭한 후 Edit를 클릭합니다.

  6. Edit Attribute 상자에 1을 입력합니다.

  7. Apply를 클릭한 다음 OK를 클릭합니다.

  8. ADSI 편집을 닫습니다. Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

LDP 도구 사용법에 대한 자세한 내용은 Microsoft 기술 자료 문서 260745, "XADM: Using the LDP Utility to Modify Active Directory Object Attributes"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745)를 참조하십시오.

Exchange 복구 저장소 그룹에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Using Exchange Server 2003 Recovery Storage Groups http://go.microsoft.com/fwlink/?LinkId=47589)

  • Understanding Recovery Storage Groups(http://go.microsoft.com/fwlink/?LinkID=80784)


공용 폴더 서버에 대한 복제 만료가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-05-25

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 값을 읽어 보존 기간이 초과된 항목을 Exchange 저장소에서 제거하는 간격이 기본 설정과 다르게 수정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>\Replication Expiry

Exchange Server Analyzer는 Replication Expiry 레지스트리 값이 구성되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

메시지 만료는 지정된 시간 값을 초과한 공용 폴더의 메시지 만료 프로세스입니다. 기본 메시지 만료 간격은 24시간입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하기 전에 문제가 발생할 경우 레지스트리 복원 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. 다음 항목을 탐색합니다.

  3. Replication Expiry 레지스트리 값을 삭제합니다.

  4. Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

공용 폴더 복제에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)과 기술 자료 문서 273479, "Exchange 2000 Server 및 Exchange Server 2003에서 공용 폴더 조회 기능 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273479)을 참조하십시오.


공용 폴더 저장소의 복제 폴더 충돌 보존 기간이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 값을 읽어 폴더 충돌 에이징이 해당 기본 설정에서 수정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>\Replication Folder Conflict Age Limit

Exchange Server Analyzer는 Replication Folder Conflict Age Limit 레지스트리 값이 존재하고 구성되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

두 명의 사용자가 공용 폴더에 있는 같은 메시지를 편집하고 수정하면 결과 저장 메시지가 충돌하는 것으로 정의됩니다. 이러한 상황은 같은 공용 폴더 서버에서 동시 저장이 발생하거나 메시지가 폴더 복제본이 있는 두 서버에서 편집된 경우에 발생할 수 있습니다. 충돌 보존 기간에 설정된 기간 내에 공용 폴더의 소유자가 작업을 수행하지 않으면 보존 기간이 경과된 후에 공용 폴더 저장소에서 충돌이 해결됩니다. Replication Folder Conflict Age Limit 레지스트리 값이 이 보존 기간을 제어합니다. 이 값은 충돌된 해당 항목이 존재할 수 있는 일 수입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>을 탐색합니다.

  3. Replication Folder Conflict Age Limit 레지스트리 값을 삭제합니다.

  4. Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

공용 폴더 복제에 대한 자세한 내용은 기술 자료 문서 273479, "Understanding Public Folder Replication and Referrals"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=273479)를 참조하십시오.


Replication Folder Count Limit 값이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Replication Folder Count Limit 키가 기본값과 다르게 수정되었는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Folder Count Limit

Exchange Server Analyzer는 Replication Folder Count Limit가 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Replication Folder Count Limit는 설정되어 있지 않습니다. Replication Folder Count Limit 값은 공용 폴더 트리의 계층 구조와 공용 폴더의 속성을 복제하는 데 사용되는 계층 구조 복제 메시지에 포함할 최대 폴더 수를 나타냅니다. 이 값의 범위는 1-1000이며 기본값은 20입니다. 이 레지스트리 키는 Exchange Server 2003 이상의 버전에서는 유효하지 않으며 이전 버전의 Exchange Server에서만 사용됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Replication Folder Count Limit 레지스트리 키를 다시 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>를 탐색합니다.

  3. Replication Folder Count Limit의 값을 조사하거나 편집합니다.

    이 레지스트리 항목의 값은 킬로바이트(KB) 단위를 사용합니다. 기본값을 사용하려면 Replication Folder Count Limit를 삭제하고 Microsoft Exchange Information Store 서비스를 다시 시작해야 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

공용 폴더 복제에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 공용 폴더 복제 제어"를 참조하십시오.


Replication Folder Tree RMQ Timeout 값이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Replication Folder Tree RMQ Timeout 키가 기본값과 다르게 수정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Folder Tree RMQ Timeout

Exchange Server Analyzer는 Replication Folder Tree RMQ Timeout이 존재하면 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Replication Folder Tree RMQ Timeout은 없습니다. Exchange에서는 공용 폴더 트리의 계층 구조와 공용 폴더의 속성을 복제할 때 계층 구조 메시지를 사용합니다. 공용 폴더 저장소는 복제된 변경 내용을 받으면 처리를 위해 변경 사항을 메모리(복제 메시지 큐)에 로드합니다. Replication Folder Tree RMQ Timeout 값은 복제된 계층 구조 변경 사항이 메모리에 남아 있을 수 있는 최대 시간 길이를 나타냅니다. 값은 3600초에서 2592000초(30일) 사이여야 합니다. 기본값은 604800초(7일)입니다. 성공적으로 처리된 변경 사항은 메모리에서 즉시 삭제됩니다. 그렇지 않을 경우에는 변경 사항이 처리될 때까지 또는 제한 시간이 경과될 때(그 시간에 변경 사항이 삭제됨)까지 메모리에 보관됩니다.

예를 들어 폴더에 변경 사항이 복제되고 그 하위 폴더에 다른 변경 사항이 복제된다고 가정합니다. 토폴로지와 변경 사항 간의 경과된 시간에 따라 변경 사항이 순서대로 대상 공용 폴더 저장소에 도착할 수 있습니다. 하위 폴더 변경 사항이 가장 먼저 도착해도 상위 폴더 변경 사항을 적용해야 올바르게 처리되는 경우 상위 폴더 변경 사항이 도착하고 처리할 때까지 공용 폴더 저장소에서 하위 폴더 변경 사항을 메모리에 보관합니다. 상위 폴더 변경 사항을 처리하기도 전에 제한 시간이 경과하면 하위 폴더 변경 사항이 메모리에서 삭제됩니다. 나중에 상위 폴더 변경 사항을 처리한 후에 공용 폴더 저장소가 하위 폴더 변경 사항의 다른 복사본을 받은 다음 성공적으로 처리할 수 있습니다. 저장소에서 하위 폴더 변경 사항의 다른 복사본을 받지 못한 경우에는 공용 폴더 저장소가 해당 토폴로지의 다른 공용 폴더 저장소 상태를 확인할 때 공용 폴더 트리의 복사본에 하위 폴더 변경 사항이 없음을 알게 되면 해당 변경 사항의 백필 프로세스를 시작합니다.

대부분의 경우 Replication Folder Tree RMQ Timeout을 기본값에서 변경하지 않는 것이 좋습니다. 이 값이 변경된 경우 복제 소통량이 많을 동안(예를 들어 새 공용 폴더 저장소를 추가한 후) 일시적으로 증가한 것일 수도 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Replication Folder Tree RMQ Timeout 레지스트리 키를 다시 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>를 탐색합니다.

  3. Replication Folder Tree RMQ Timeout 값을 검사하거나 편집합니다.

    이 레지스트리 항목의 값은 초 단위로 되어 있습니다. 기본값으로 다시 설정하려면 Replication Folder Tree RMQ Timeout을 삭제한 다음 Microsoft Exchange Information Store 서비스를 다시 시작해야 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

공용 폴더 복제에 대한 자세한 내용은 Exchange Server 2003 저장소 작업 (http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 공용 폴더 복제 제어"를 참조하십시오.


공용 폴더 저장소의 복제 폴더 삭제 표시 보존 기간이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 공용 폴더 삭제 표시 항목 삭제 간격이 기본값에서 수정되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>\Replication Folder Tombstone Age Limit

Exchange Server Analyzer는 Replication Folder Tombstone Age Limit가 레지스트리에 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

폴더 삭제 표시 정보는 공용 폴더 복제에 사용됩니다. 에이징은 폴더 삭제 표시 목록이 무제한으로 늘어나지 않도록 하는 데 필요합니다. 기본값 180일은 Replication Folder Tombstone Age Limit 레지스트리 값으로 덮어쓸 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>을 탐색합니다.

  3. Replication Folder Tombstone Age Limit 레지스트리 값을 삭제합니다.

  4. Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Replication Folder Tombstone Age Limit 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 159196, "XADM: Tasks Controlled by the IS Maintenance Schedule"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196)을 참조하십시오.


Replication Long Backfill Request Delay 값이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Replication Long Backfill Request Delay 키가 기본값과 다르게 수정되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Long Backfill Request Delay

Exchange Server Analyzer는 Replication Long Backfill Request Delay 값이 존재할 경우 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Replication Long Backfill Request Delay는 존재하지 않습니다. 공용 폴더 저장소가 복제된 폴더 또는 계층 구조에 대한 모든 업데이트를 받지 못하여 다른 저장소에서 누락된 업데이트를 검색해야 하는 경우 백필이 발생합니다.

백필 프로세스를 효율적으로 수행하기 위해 Exchange Server에서는 누락된 업데이트에 대한 정보를 백필 배열에 저장합니다. 백필 배열은 지정한 기간(백필 시간 제한) 동안 이 정보를 저장합니다. 이 기간 중에 누락된 업데이트가 후속 복제 메시지에 도착하면 해당 정보가 백필 배열에서 제거됩니다. 아래 표에는 기본 백필 시간 제한 값이 나열되어 있으며 이 값은 누락된 업데이트의 위치와 전에 요청된 적이 있는지 여부에 따라 다릅니다.

요청 유형 | 콘텐츠가 로컬 사이트의 저장소에 있는 경우 | 콘텐츠가 원격 사이트의 저장소에 있는 경우
초기 백필 | 6시간 | 12시간
최초 백필 재시도 | 12시간 | 24시간
후속 백필 재시도 | 24시간 | 48시간

백필 시간 제한이 만료되고 업데이트가 아직도 없으면 Exchange Server 2003은 백필 요청을 하나 이상 만들고 백필 원본으로 사용할 서버를 결정합니다.

백필 원본으로 사용할 서버를 선택하기 위해 Exchange Server 2003은 먼저 폴더 복제본이 있는 모든 서버의 목록을 만들고 다음 순서의 기준에 따라 목록을 정렬합니다.

  • 서버 상태에 따라 정렬 다운되거나 사용할 수 없는 서버는 목록 맨 끝으로 이동합니다.

  • 기본 설정 백필 서버에 따라 정렬 이 기능은 Exchange Server 2003 이상에서만 사용할 수 있습니다. Exchange Server 2003은 Active Directory® 디렉터리 서비스의 공용 폴더 저장소 개체의 기본 설정 백필 서버를 확인합니다. 이 설정은 거의 사용되지 않습니다. 대부분의 경우 Exchange Server 2003이 백필 서버를 자동으로 선택할 경우에 백필 프로세스가 가장 효율적으로 작동합니다. 대부분의 Exchange Server 2003 배포에서는 기본 설정 백필 서버가 필요하지 않습니다. Microsoft 기술 지원 서비스에서는 배포에 필요한 경우 기본 설정 백필 서버를 설정하는 스크립트를 제공합니다.

  • 전송 순위에 따라 정렬(최저에서 최고 순으로 정렬) 동일한 사이트에 있는 서버가 원격 사이트에 있는 서버보다 우선 순위가 높습니다. 서버의 전송 순위는 Exchange Server 2003 라우팅 엔진에서 계산되며 메시지를 배달하기 위한 가장 효율적인 경로를 계산하는 데 사용됩니다. Exchange Server 2003 이전의 Exchange 버전에서는 전송 순위의 중요도가 낮아 Exchange 버전과 사용 가능한 변경 횟수 이후에 고려됩니다.

  • Exchange 버전에 따라 정렬(최신 버전에서 이전 버전 순으로 정렬)

  • 서버에서 사용 가능한 필수 변경 횟수에 따라 정렬(최대 횟수에서 최소 횟수 순으로 정렬) 변경 내용이 누락되지 않은 서버는 목록에서 제외됩니다.

한 서버에 필요한 변경 내용이 일부 없는 경우 Exchange Server 2003은 정렬된 목록에서 다음 번 서버를 선택하고 백필 요청을 이 서버에도 보냅니다. 모든 변경 내용을 요청할 때까지 이러한 과정을 반복합니다. 이 기능은 Exchange Server 2003 이상에서만 사용 가능합니다. 이전 버전의 Exchange에서는 단일 서버가 특정 폴더에 대한 누락된 업데이트를 모두 보유하고 있지 않을 경우 한 번에 한 서버에 백필 요청을 보냅니다. 이전 버전의 Exchange는 각 요청 후에 재시도 시간 제한(24시간에서 48시간까지)이 경과될 때까지 기다렸다가 다음 요청을 보냅니다.

선택한 서버가 백필 요청에 응답하지 않으면 저장소는 해당 서버가 다운되었다고 표시하고 선택 과정을 반복합니다. 표시된 서버는 목록 끝으로 이동합니다.

Replication Long Backfill Request Delay 값은 동일한 Exchange 사이트에서 사용할 수 없는 데이터에 대한 백필 요청을 보내기까지 저장소가 대기하는 시간을 나타냅니다. 값의 범위는 900초-2592000초(30일)이며 기본값은 43200초(12시간)입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Replication Long Backfill Request Delay 레지스트리 키를 다시 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>를 탐색합니다.

  3. Replication Long Backfill Request Delay 값을 확인하거나 편집합니다.

    이 레지스트리 항목의 값은 초 단위입니다. 기본값으로 사용하려면 Replication Long Backfill Request Delay를 삭제한 다음 Microsoft Exchange Information Store 서비스를 다시 시작해야 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

공용 폴더 복제에 대한 자세한 내용은 Exchange Server 2003 저장소 작업 (http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 공용 폴더 복제 제어"를 참조하십시오.


Replication Long Backfill Request Timeout 값이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Replication Long Backfill Request Timeout 키가 기본값과 다르게 수정되었는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Long Backfill Request Timeout

Exchange Server Analyzer는 Replication Long Backfill Request Timeout이 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Replication Long Backfill Request Timeout은 설정되어 있지 않습니다. 공용 폴더 저장소가 복제된 폴더 또는 계층 구조에 대한 모든 업데이트를 받지 못하여 다른 저장소에서 누락된 업데이트를 검색해야 하는 경우 백필이 발생합니다.

백필 프로세스를 효율적으로 수행하기 위해 Exchange Server에서는 누락된 업데이트에 대한 정보를 백필 배열에 저장합니다. 백필 배열은 지정한 기간(백필 시간 제한) 동안 이 정보를 저장합니다. 이 기간 중에 누락된 업데이트가 후속 복제 메시지에 도착하면 해당 정보가 백필 배열에서 제거됩니다. 아래 표에는 기본 백필 시간 제한 값이 나열되어 있으며 이 값은 누락된 업데이트의 위치와 전에 요청된 적이 있는지 여부에 따라 다릅니다.

요청 유형 | 콘텐츠가 로컬 사이트의 저장소에 있는 경우 | 콘텐츠가 원격 사이트의 저장소에 있는 경우
초기 백필 | 6시간 | 12시간
최초 백필 재시도 | 12시간 | 24시간
후속 백필 재시도 | 24시간 | 48시간

백필 시간 제한이 만료되고 업데이트가 아직도 없으면 Exchange Server 2003은 백필 요청을 하나 이상 만들고 백필 원본으로 사용할 서버를 결정합니다.

백필 원본으로 사용할 서버를 선택하기 위해 Exchange Server 2003은 먼저 폴더 복제본이 있는 모든 서버의 목록을 만들고 다음 순서의 기준에 따라 목록을 정렬합니다.

  • 서버 상태에 따라 정렬 다운되거나 사용할 수 없는 서버는 목록 맨 끝으로 이동합니다.

  • 기본 설정 백필 서버에 따라 정렬 이 기능은 Exchange Server 2003 이상에서만 사용할 수 있습니다. Exchange Server 2003은 Active Directory® 디렉터리 서비스의 공용 폴더 저장소 개체의 기본 설정 백필 서버를 확인합니다. 이 설정은 거의 사용되지 않습니다. 대부분의 경우 Exchange Server 2003이 백필 서버를 자동으로 선택할 경우에 백필 프로세스가 가장 효율적으로 작동합니다. 대부분의 Exchange Server 2003 배포에서는 기본 설정 백필 서버가 필요하지 않습니다. Microsoft 기술 지원 서비스에서는 배포에 필요한 경우 기본 설정 백필 서버를 설정하는 스크립트를 제공합니다.

  • 전송 순위에 따라 정렬(최저에서 최고 순으로 정렬) 동일한 사이트에 있는 서버가 원격 사이트에 있는 서버보다 우선 순위가 높습니다. 서버의 전송 순위는 Exchange Server 2003 라우팅 엔진에서 계산되며 메시지를 배달하기 위한 가장 효율적인 경로를 계산하는 데 사용됩니다. Exchange Server 2003 이전의 Exchange 버전에서는 전송 순위가 낮은 우선 순위를 가지며 Exchange 버전과 사용 가능한 변경 횟수 이후에 고려됩니다.

  • Exchange 버전에 따라 정렬(최신 버전에서 이전 버전 순으로 정렬)

  • 서버에서 사용 가능한 필수 변경 횟수에 따라 정렬(최대 횟수에서 최소 횟수 순으로 정렬) 변경 내용이 누락되지 않은 서버는 목록에서 제외됩니다.

한 서버에 필요한 변경 내용이 일부 없는 경우 Exchange Server 2003은 정렬된 목록에서 다음 번 서버를 선택하고 백필 요청을 이 서버에도 보냅니다. 모든 변경 내용을 요청할 때까지 이러한 과정을 반복합니다. 이 기능은 Exchange Server 2003 이상에서만 사용 가능합니다. 이전 버전의 Exchange에서는 단일 서버가 특정 폴더에 대한 누락된 업데이트를 모두 보유하고 있지 않을 경우 한 번에 한 서버에 백필 요청을 보냅니다. 이전 버전의 Exchange는 각 요청 후에 재시도 시간 제한(24시간에서 48시간까지)이 경과될 때까지 기다렸다가 다음 요청을 보냅니다.

선택한 서버가 백필 요청에 응답하지 않으면 저장소는 해당 서버가 다운되었다고 표시하고 선택 과정을 반복합니다. 표시된 서버는 목록 끝으로 이동합니다.

Replication Long Backfill Request Timeout 값은 동일한 Exchange 사이트에서 사용할 수 없는 데이터의 백필 요청을 보낼 때 공용 폴더 저장소가 사용하는 시간 제한 값입니다. 값의 범위는 900초-2592000초(30일)이며 기본값은 86400초(24시간)입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Replication Long Backfill Request Timeout 레지스트리 키를 다시 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>를 탐색합니다.

  3. Replication Long Backfill Request Timeout의 값을 검사하거나 편집합니다.

    이 레지스트리 항목의 값은 초 단위입니다. 기본값으로 사용하려면 Replication Short Backfill Request Timeout을 삭제한 다음 Microsoft Exchange Information Store 서비스를 다시 시작해야 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

공용 폴더 복제에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 공용 폴더 복제 제어"를 참조하십시오.


Replication Long Backfill Request Timeout Retry 값이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 Replication Long Backfill Request Timeout Retry 키가 기본값과 다르게 수정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Long Backfill Request Timeout Retry

Exchange Server Analyzer는 Replication Long Backfill Request Timeout Retry 가 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Replication Long Backfill Request Timeout Retry는 없습니다. 공용 폴더 저장소에서 복제된 폴더 또는 계층 구조에 대한 모든 업데이트를 받지 못하여 다른 저장소에서 누락된 업데이트를 검색해야 하는 경우 백필이 발생합니다.

백필 프로세스를 효율적으로 수행하기 위해 Exchange Server에서는 누락된 업데이트에 대한 정보를 백필 배열에 저장합니다. 백필 배열은 지정한 기간(백필 시간 제한) 동안 이 정보를 저장합니다. 이 기간 중에 누락된 업데이트가 후속 복제 메시지에 도착하면 해당 정보가 백필 배열에서 제거됩니다. 다음 표에는 누락된 업데이트의 위치와 이전에 요청한 적이 있는지 여부에 따라 결정되는 기본 백필 시간 제한 값이 나열되어 있습니다.

요청 유형 | 콘텐츠가 로컬 사이트의 저장소에 있는 경우 | 콘텐츠가 원격 사이트의 저장소에 있는 경우
초기 백필 | 6시간 | 12시간
최초 백필 재시도 | 12시간 | 24시간
후속 백필 재시도 | 24시간 | 48시간

백필 시간 제한이 만료되고 업데이트가 아직도 없으면 Exchange Server 2003은 백필 요청을 하나 이상 만들고 백필 원본으로 사용할 서버를 결정합니다.

백필 원본으로 사용할 서버를 선택하기 위해 Exchange Server 2003은 먼저 폴더 복제본이 있는 모든 서버의 목록을 만들고 다음 순서의 기준에 따라 목록을 정렬합니다.

  • 서버 상태에 따라 정렬 다운되거나 사용할 수 없는 서버는 목록 맨 끝으로 이동합니다.

  • 기본 설정 백필 서버에 따라 정렬 이 기능은 Exchange Server 2003 이상에서만 사용할 수 있습니다. Exchange Server 2003은 Active Directory® 디렉터리 서비스의 공용 폴더 저장소 개체의 기본 설정 백필 서버를 확인합니다. 이 설정은 거의 사용되지 않습니다. 대부분의 경우 Exchange Server 2003이 백필 서버를 자동으로 선택할 경우에 백필 프로세스가 가장 효율적으로 작동합니다. 대부분의 Exchange Server 2003 배포에서는 기본 설정 백필 서버가 필요하지 않습니다. Microsoft 기술 지원 서비스에서는 배포에 필요한 경우 기본 설정 백필 서버를 설정하는 스크립트를 제공합니다.

  • 전송 순위에 따라 정렬(최저에서 최고 순으로 정렬) 동일한 사이트에 있는 서버가 원격 사이트에 있는 서버보다 우선 순위가 높습니다. 서버의 전송 순위는 Exchange Server 2003 라우팅 엔진에서 계산되며 메시지를 배달하기 위한 가장 효율적인 경로를 계산하는 데 사용됩니다. Exchange Server 2003 이전의 Exchange 버전에서는 전송 순위가 낮은 우선 순위를 가지며 Exchange 버전과 사용 가능한 변경 횟수 이후에 고려됩니다.

  • Exchange 버전에 따라 정렬(최신 버전에서 이전 버전 순으로 정렬)

  • 서버에서 사용 가능한 필수 변경 횟수에 따라 정렬(최대 횟수에서 최소 횟수 순으로 정렬) 변경 내용이 누락되지 않은 서버는 목록에서 제외됩니다.

한 서버에 필요한 변경 내용이 일부 없는 경우 Exchange Server 2003은 정렬된 목록에서 다음 번 서버를 선택하고 백필 요청을 이 서버에도 보냅니다. 모든 변경 내용을 요청할 때까지 이러한 과정을 반복합니다. 이 기능은 Exchange Server 2003 이상에서만 사용 가능합니다. 이전 버전의 Exchange에서는 단일 서버가 특정 폴더에 대한 누락된 업데이트를 모두 보유하고 있지 않을 경우 한 번에 한 서버에 백필 요청을 보냅니다. 이전 버전의 Exchange는 각 요청 후에 재시도 시간 제한(24시간에서 48시간까지)이 경과될 때까지 기다렸다가 다음 요청을 보냅니다.

선택한 서버가 백필 요청에 응답하지 않으면 저장소는 해당 서버가 다운되었다고 표시하고 선택 과정을 반복합니다. 표시된 서버는 목록 끝으로 이동합니다.

Replication Long Backfill Request Timeout Retry 값은 같은 Exchange 사이트 내에서 사용할 수 없는 데이터에 대한 백필 요청을 보낼 때와 이 요청이 이전 백필 요청을 다시 시도한 것일 경우에 공용 폴더 저장소가 사용하는 시간 제한 값을 나타냅니다. 값의 범위는 900초-2592000초(30일)이며 기본값은 172800초(48시간)입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Replication Long Backfill Request Timeout Retry 레지스트리 키를 다시 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>를 탐색합니다.

  3. Replication Long Backfill Request Timeout Retry 값을 검사하거나 편집합니다.

    이 레지스트리 항목의 값은 초 단위입니다. 기본값으로 다시 설정하려면 Replication Long Backfill Request Timeout Retry를 삭제한 다음 Microsoft Exchange Information Store 서비스를 다시 시작해야 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

공용 폴더 복제에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 공용 폴더 복제 제어"를 참조하십시오.


시작 시 복제 메시지가 사용되도록 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 공용 폴더 계층 구조에 대한 상태 요청 메시지를 생성하도록 Exchange를 구성했는지 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>\Enable Replication Messages At Startup

Exchange Server Analyzer는 Enable Replication Messages At Startup 레지스트리 항목이 존재하고 구성되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server 5.5에서 공용 폴더 저장소가 있는 각 컴퓨터는 매일 밤 상태 요청 메시지를 보내 공용 폴더 계층 구조의 상태를 확인합니다. Exchange 2000 Server와 Exchange Server 2003은 이 작업을 수행하지 않습니다. 일반적으로 Exchange 2000 Server와 Exchange Server 2003은 공용 폴더 저장소의 수명 기간 동안 저장소를 만들 때 단 한 번 상태 요청 메시지를 보냅니다.

그러나 경우에 따라 사용자가 상태 요청 메시지를 생성해야 할 수 있습니다. 예를 들어 Exchange 2000 Server나 Exchange Server 2003 컴퓨터에서 공용 폴더 계층 구조가 복제를 수행하지 않거나 매우 느리게 복제할 경우 상태 요청 메시지를 생성하면 공용 폴더 계층 구조 복제를 계속할 수 있습니다. 공용 폴더 저장소를 만들 때 보낸 원본 상태 요청 메시지를 삭제해 인식할 수 없거나 계층 구조가 불완전한 서버로 메시지를 보낸 경우 공용 폴더 계층 구조 복제 관련 문제가 발생합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Aging Keep Time 레지스트리 값을 보거나 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>를 탐색합니다.

  3. Enable Replication Messages At Startup 값을 확인하거나 필요한 경우 변경합니다. 이 REG_DWORD 값을 1로 설정해야 합니다. 이 값을 0(기본 설정)으로 설정하면 공용 정보 저장소 시작 시 상태 요청 메시지를 보내지 않습니다.

  4. 설정을 변경했으면 레지스트리 편집기를 닫은 다음 공용 정보 저장소를 분리했다 다시 연결하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

공용 폴더 복제 상태 메시지와 Enable Replication Messages At Startup 레지스트리 값에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 321082, "XADM: How to Send Replication Status Request Messages in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=321082)

  • 842273, "How to troubleshoot public folder replication problems in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273)


Replication Short Backfill Request Delay 값이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Replication Short Backfill Request Delay 키가 기본값과 다르게 수정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Short Backfill Request Delay

Exchange Server Analyzer는 Replication Short Backfill Request Delay 값이 존재할 경우 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Replication Short Backfill Request Delay는 설정되어 있지 않습니다. 공용 폴더 저장소가 복제된 폴더 또는 계층 구조에 대한 모든 업데이트를 받지 못하여 다른 저장소에서 누락된 업데이트를 검색해야 하는 경우 백필이 발생합니다.

백필 프로세스를 효율적으로 수행하기 위해 Exchange Server에서는 누락된 업데이트에 대한 정보를 백필 배열에 저장합니다. 백필 배열은 지정한 기간(백필 시간 제한) 동안 이 정보를 저장합니다. 이 기간 중에 누락된 업데이트가 후속 복제 메시지에 도착하면 해당 정보가 백필 배열에서 제거됩니다. 아래의 표에는 누락된 업데이트의 위치와 이전에 요청한 적이 있는지 여부에 따라 결정되는 기본 백필 시간 제한 값이 나열되어 있습니다.

요청 유형 | 콘텐츠가 로컬 사이트의 저장소에 있는 경우 | 콘텐츠가 원격 사이트의 저장소에 있는 경우
초기 백필 | 6시간 | 12시간
최초 백필 재시도 | 12시간 | 24시간
후속 백필 재시도 | 24시간 | 48시간

백필 시간 제한이 만료되고 업데이트가 아직도 없으면 Exchange Server 2003은 백필 요청을 하나 이상 만들고 백필 원본으로 사용할 서버를 결정합니다.

백필 원본으로 사용할 서버를 선택하기 위해 Exchange Server 2003은 먼저 폴더 복제본이 있는 모든 서버의 목록을 만들고 다음 기준 순서에 따라 목록을 정렬합니다.

  • 서버 상태에 따라 정렬 다운되거나 사용할 수 없는 서버는 목록 맨 끝으로 이동합니다.

  • 기본 설정 백필 서버에 따라 정렬 이 기능은 Exchange Server 2003 이상에서만 사용할 수 있습니다. Exchange Server 2003은 Active Directory® 디렉터리 서비스의 공용 폴더 저장소 개체의 기본 설정 백필 서버를 확인합니다. 이 설정은 거의 사용되지 않습니다. 대부분의 경우 Exchange Server 2003이 백필 서버를 자동으로 선택할 경우에 백필 프로세스가 가장 효율적으로 작동합니다. 대부분의 Exchange Server 2003 배포에서는 기본 설정 백필 서버가 필요하지 않습니다. Microsoft 기술 지원 서비스에서는 배포에 필요한 경우 기본 설정 백필 서버를 설정하는 스크립트를 제공합니다.

  • 전송 순위에 따라 정렬(최저에서 최고 순으로 정렬) 동일한 사이트에 있는 서버가 원격 사이트에 있는 서버보다 우선 순위가 높습니다. 서버의 전송 순위는 Exchange Server 2003 라우팅 엔진에서 계산되며 메시지를 배달하기 위한 가장 효율적인 경로를 계산하는 데 사용됩니다. Exchange Server 2003 이전의 Exchange 버전에서는 전송 순위가 낮은 우선 순위를 가지며 Exchange 버전과 사용 가능한 변경 횟수 이후에 고려됩니다.

  • Exchange 버전에 따라 정렬(최신 버전에서 이전 버전 순으로 정렬)

  • 서버에서 사용 가능한 필수 변경 횟수에 따라 정렬(최대 횟수에서 최소 횟수 순으로 정렬) 변경 내용이 누락되지 않은 서버는 목록에서 제외됩니다.

한 서버에 필요한 변경 내용이 일부 없는 경우 Exchange Server 2003은 정렬된 목록에서 다음 번 서버를 선택하고 백필 요청을 이 서버에도 보냅니다. 모든 변경 내용을 요청할 때까지 이러한 과정을 반복합니다. 이 기능은 Exchange Server 2003 이상에서만 사용 가능합니다. 이전 버전의 Exchange에서는 단일 서버가 특정 폴더에 대한 누락된 업데이트를 모두 보유하고 있지 않을 경우 한 번에 한 서버에 백필 요청을 보냅니다. 이전 버전의 Exchange는 각 요청 후에 재시도 시간 제한(24시간에서 48시간까지)이 경과될 때까지 기다렸다가 다음 요청을 보냅니다.

선택한 서버가 백필 요청에 응답하지 않으면 저장소는 해당 서버가 다운되었다고 표시하고 선택 과정을 반복합니다. 표시된 서버는 목록 끝으로 이동합니다.

Replication Short Backfill Request Delay 값은 동일한 Exchange 사이트에서 사용할 수 있는 데이터의 백필 요청을 보내기 전에 공용 폴더 저장소가 대기하는 지연 시간을 나타냅니다. 값의 범위는 900초-2592000초(30일)이며 기본값은 21600초(6시간)입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Replication Short Backfill Request Delay 레지스트리 키를 다시 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>를 탐색합니다.

  3. Replication Short Backfill Request Delay의 값을 검사하거나 편집합니다.

    이 레지스트리 항목의 값은 초 단위입니다. 기본값으로 사용하려면 Replication Short Backfill Request Delay를 삭제한 다음 Microsoft Exchange Information Store 서비스를 다시 시작해야 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

공용 폴더 복제에 대한 자세한 내용은 Exchange Server 2003 저장소 작업(http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 공용 폴더 복제 제어"를 참조하십시오.


Replication Short Backfill Request Timeout 값이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 Replication Short Backfill Request Timeout 키가 기본값과 다르게 수정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Short Backfill Request Timeout

Exchange Server Analyzer는 Replication Short Backfill Request Timeout이 존재할 경우 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Replication Short Backfill Request Timeout은 없습니다. 공용 폴더 저장소가 복제된 폴더 또는 계층 구조에 대한 모든 업데이트를 받지 못하여 다른 저장소에서 누락된 업데이트를 검색해야 하는 경우 백필이 발생합니다.

백필 프로세스를 효율적으로 수행하기 위해 Exchange Server에서는 누락된 업데이트에 대한 정보를 백필 배열에 저장합니다. 백필 배열은 지정한 기간(백필 시간 제한) 동안 이 정보를 저장합니다. 이 기간 중에 누락된 업데이트가 후속 복제 메시지에 도착하면 해당 정보가 백필 배열에서 제거됩니다. 아래 표에는 기본 백필 시간 제한 값이 나열되어 있으며 이 값은 누락된 업데이트의 위치와 전에 요청된 적이 있는지 여부에 따라 다릅니다.

요청 유형 | 콘텐츠가 로컬 사이트의 저장소에 있는 경우 | 콘텐츠가 원격 사이트의 저장소에 있는 경우
초기 백필 | 6시간 | 12시간
최초 백필 재시도 | 12시간 | 24시간
후속 백필 재시도 | 24시간 | 48시간

백필 시간 제한이 만료되고 업데이트가 아직도 없으면 Exchange Server 2003은 백필 요청을 하나 이상 만들고 백필 원본으로 사용할 서버를 결정합니다.

백필 원본으로 사용할 서버를 선택하기 위해 Exchange Server 2003은 먼저 폴더 복제본이 있는 모든 서버의 목록을 만들고 다음 순서의 기준에 따라 목록을 정렬합니다.

  • 서버 상태에 따라 정렬 다운되거나 사용할 수 없는 서버는 목록 맨 끝으로 이동합니다.

  • 기본 설정 백필 서버에 따라 정렬 이 기능은 Exchange Server 2003 이상에서만 사용할 수 있습니다. Exchange Server 2003은 Active Directory® 디렉터리 서비스의 공용 폴더 저장소 개체의 기본 설정 백필 서버를 확인합니다. 이 설정은 거의 사용되지 않습니다. 대부분의 경우 Exchange Server 2003이 백필 서버를 자동으로 선택할 경우에 백필 프로세스가 가장 효율적으로 작동합니다. 대부분의 Exchange Server 2003 배포에서는 기본 설정 백필 서버가 필요하지 않습니다. Microsoft 기술 지원 서비스에서는 배포에 필요한 경우 기본 설정 백필 서버를 설정하는 스크립트를 제공합니다.

  • 전송 순위에 따라 정렬(최저에서 최고 순으로 정렬) 동일한 사이트에 있는 서버가 원격 사이트에 있는 서버보다 우선 순위가 높습니다. 서버의 전송 순위는 Exchange Server 2003 라우팅 엔진에서 계산되며 메시지를 배달하기 위한 가장 효율적인 경로를 계산하는 데 사용됩니다. Exchange Server 2003 이전의 Exchange 버전에서는 전송 순위가 낮은 우선 순위를 가지며 Exchange 버전과 사용 가능한 변경 횟수 이후에 고려됩니다.

  • Exchange 버전에 따라 정렬(최신 버전에서 이전 버전 순으로 정렬)

  • 서버에서 사용 가능한 필수 변경 횟수에 따라 정렬(최대 횟수에서 최소 횟수 순으로 정렬) 변경 내용이 누락되지 않은 서버는 목록에서 제외됩니다.

한 서버에 필요한 변경 내용이 일부 없는 경우 Exchange Server 2003은 정렬된 목록에서 다음 번 서버를 선택하고 백필 요청을 이 서버에도 보냅니다. 모든 변경 내용을 요청할 때까지 이러한 과정을 반복합니다. 이 기능은 Exchange Server 2003 이상에서만 사용 가능합니다. 이전 버전의 Exchange에서는 단일 서버가 특정 폴더에 대한 누락된 업데이트를 모두 보유하고 있지 않을 경우 한 번에 한 서버에 백필 요청을 보냅니다. 이전 버전의 Exchange는 각 요청 후에 재시도 시간 제한(24시간에서 48시간까지)이 경과될 때까지 기다렸다가 다음 요청을 보냅니다.

선택한 서버가 백필 요청에 응답하지 않으면 저장소는 해당 서버가 다운되었다고 표시하고 선택 과정을 반복합니다. 표시된 서버는 목록 끝으로 이동합니다.

Replication Short Backfill Request Timeout 값은 동일 Exchange 사이트에서 사용할 수 있는 데이터에 대한 백필 요청을 보내려고 할 때 공용 폴더 저장소가 사용하는 시간 제한 값을 나타냅니다. 값의 범위는 900초-2592000초(30일)이며 기본값은 43200초(12시간)입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Replication Short Backfill Request Timeout 레지스트리 키를 다시 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>를 탐색합니다.

  3. Replication Short Backfill Request Timeout 값을 검사하거나 편집합니다.

    이 레지스트리 항목의 값은 초 단위입니다. 기본값으로 다시 설정하려면 Replication Short Backfill Request Timeout을 삭제한 다음 Microsoft Exchange Information Store 서비스를 다시 시작해야 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

공용 폴더 복제에 대한 자세한 내용은 Exchange Server 2003 저장소 작업 (http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 공용 폴더 복제 제어"를 참조하십시오.


Replication Short Backfill Request Timeout Retry 값이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Replication Short Backfill Request Timeout Retry 키가 기본값과 다르게 수정되었는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Replication Short Backfill Request Timeout Retry

Exchange Server Analyzer는 Replication Short Backfill Request Timeout Retry가 존재할 경우 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Replication Short Backfill Request Timeout Retry는 설정되어 있지 않습니다. 공용 폴더 저장소가 복제된 폴더 또는 계층 구조에 대한 모든 업데이트를 받지 못하여 다른 저장소에서 누락된 업데이트를 검색해야 하는 경우 백필이 발생합니다.

백필 프로세스를 효율적으로 수행하기 위해 Exchange Server에서는 누락된 업데이트에 대한 정보를 백필 배열에 저장합니다. 백필 배열은 지정한 기간(백필 시간 제한) 동안 이 정보를 저장합니다. 이 기간 중에 누락된 업데이트가 후속 복제 메시지에 도착하면 해당 정보가 백필 배열에서 제거됩니다. 아래 표에는 기본 백필 시간 제한 값이 나열되어 있으며 이 값은 누락된 업데이트의 위치와 전에 요청된 적이 있는지 여부에 따라 다릅니다.

요청 유형 | 콘텐츠가 로컬 사이트의 저장소에 있는 경우 | 콘텐츠가 원격 사이트의 저장소에 있는 경우
초기 백필 | 6시간 | 12시간
최초 백필 재시도 | 12시간 | 24시간
후속 백필 재시도 | 24시간 | 48시간

백필 시간 제한이 만료되고 업데이트가 아직도 없으면 Exchange Server 2003은 백필 요청을 하나 이상 만들고 백필 원본으로 사용할 서버를 결정합니다.

백필 원본으로 사용할 서버를 선택하기 위해 Exchange Server 2003은 먼저 폴더 복제본이 있는 모든 서버의 목록을 만들고 다음 순서의 기준에 따라 목록을 정렬합니다.

  • 서버 상태에 따라 정렬 다운되거나 사용할 수 없는 서버는 목록 맨 끝으로 이동합니다.

  • 기본 설정 백필 서버에 따라 정렬 이 기능은 Exchange Server 2003 이상에서만 사용할 수 있습니다. Exchange Server 2003은 Active Directory® 디렉터리 서비스의 공용 폴더 저장소 개체의 기본 설정 백필 서버를 확인합니다. 이 설정은 거의 사용되지 않습니다. 대부분의 경우 Exchange Server 2003이 백필 서버를 자동으로 선택할 경우에 백필 프로세스가 가장 효율적으로 작동합니다. 대부분의 Exchange Server 2003 배포에서는 기본 설정 백필 서버가 필요하지 않습니다. Microsoft 기술 지원 서비스에서는 배포에 필요한 경우 기본 설정 백필 서버를 설정하는 스크립트를 제공합니다.

  • 전송 순위에 따라 정렬(최저에서 최고 순으로 정렬) 동일한 사이트에 있는 서버가 원격 사이트에 있는 서버보다 우선 순위가 높습니다. 서버의 전송 순위는 Exchange Server 2003 라우팅 엔진에서 계산되며 메시지를 배달하기 위한 가장 효율적인 경로를 계산하는 데 사용됩니다. Exchange Server 2003 이전의 Exchange 버전에서는 전송 순위가 낮은 우선 순위를 가지며 Exchange 버전과 사용 가능한 변경 횟수 이후에 고려됩니다.

  • Exchange 버전에 따라 정렬(최신 버전에서 이전 버전 순으로 정렬)

  • 서버에서 사용 가능한 필수 변경 횟수에 따라 정렬(최대 횟수에서 최소 횟수 순으로 정렬) 변경 내용이 누락되지 않은 서버는 목록에서 제외됩니다.

한 서버에 필요한 변경 내용이 일부 없는 경우 Exchange Server 2003은 정렬된 목록에서 다음 번 서버를 선택하고 백필 요청을 이 서버에도 보냅니다. 모든 변경 내용을 요청할 때까지 이러한 과정을 반복합니다. 이 기능은 Exchange Server 2003 이상에서만 사용 가능합니다. 이전 버전의 Exchange에서는 단일 서버가 특정 폴더에 대한 누락된 업데이트를 모두 보유하고 있지 않을 경우 한 번에 한 서버에 백필 요청을 보냅니다. 이전 버전의 Exchange는 각 요청 후에 재시도 시간 제한(24시간에서 48시간까지)이 경과될 때까지 기다렸다가 다음 요청을 보냅니다.

선택한 서버가 백필 요청에 응답하지 않으면 저장소는 해당 서버가 다운되었다고 표시하고 선택 과정을 반복합니다. 표시된 서버는 목록 끝으로 이동합니다.

Replication Short Backfill Request Timeout Retry 값은 동일한 Exchange 사이트에서 사용할 수 있는 데이터의 백필 요청을 보내는 경우 해당 요청이 이전 백필 요청을 다시 시도하는 것일 때 공용 폴더 저장소가 사용하는 시간 제한 값입니다. 값의 범위는 900초-2592000초(30일)이며 기본값은 86400초(24시간)입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Replication Short Backfill Request Timeout Retry 레지스트리 키를 다시 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>를 탐색합니다.

  3. Replication Short Backfill Request Timeout Retry의 값을 검사하거나 편집합니다.

    이 레지스트리 항목의 값은 초 단위입니다. 기본값을 사용하려면 Replication Short Backfill Request Timeout Retry를 삭제한 다음 Microsoft Exchange Information Store 서비스를 다시 시작해야 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

공용 폴더 복제에 대한 자세한 내용은 Exchange Server 2003 저장소 작업 (http://go.microsoft.com/fwlink/?LinkId=47595)의 "Exchange Server 2003 공용 폴더 복제 제어"를 참조하십시오.


Reserve Increment 크기가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-30

Microsoft® Exchange Server Analyzer Tool은 레지스트리 항목 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 읽어 Reserve Increment KB 값이 설정되어 있는지 확인합니다.

또한 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스를 쿼리하여 개체 클래스 msExchExchangeServer가 있는 모든 개체의 serialNumber 특성 값을 확인합니다. 문자열 값에 "Version 5.5"가 있으면 해당 컴퓨터에 Microsoft Exchange Server 5.5가 실행 중입니다. 문자열 값에 "Version 6.0"이 있으면 해당 컴퓨터에 Microsoft Exchange 2000 Server가 실행 중입니다. 문자열 값에 "Version 6.5"가 있는 경우에는 해당 컴퓨터에서 Microsoft Exchange Server 2003이 실행 중인 것이고, 문자열 값에 "Version 8.0"이 있으면 컴퓨터에서 Microsoft Exchange Server 2007이 실행 중인 것입니다.

Exchange Server 2003을 실행하는 컴퓨터에 Reserve Increment KB 레지스트리 값이 존재하면 Exchange Server Analyzer에서 기본 구성이 아니라는 메시지를 표시합니다.

Reserve Increment KB 레지스트리 값은 Microsoft Windows®의 원시 메모리 힙 값을 다시 정의합니다. Windows에는 모든 프로세스의 메모리 작동을 처리하는 프로세스 차원의 힙 관리자가 포함되어 있습니다. 프로세스가 인스턴스화할 때마다 해당 프로세스에 대해 프로세스 힙이라고 하는 기본 힙이 생성됩니다. 프로세스에 로드된 프로그램이나 모듈도 필요할 경우 추가 힙을 만들 수 있습니다. Microsoft Exchange Information Store 서비스인 Store.exe는 필요할 때 추가 힙을 만드는 프로세스에 해당합니다. 기본적으로 Store.exe는 실제 RAM의 20%가 힙 공간으로 예약된 초기 메모리를 설정합니다. Reserve Increment KB 값은 초기에 예약된 힙 메모리 크기를 실제 메모리의 10퍼센트로 변경합니다.

Reserve Increment KB 레지스트리 값은 일부 경우에만 유용합니다. 또한 이 값은 Microsoft 기술 지원 서비스의 지시가 있을 때만 설정해야 합니다. 이 값을 잘못 설정하거나 잘못 사용하면 성능이 저하되고 가상 메모리의 조각화가 가속화됩니다. Microsoft 기술 지원 서비스의 지시에 따르지 않고 이 값을 설정한 경우 다음 절차에 따라 제거하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. 오른쪽 창에서 Reserve Increment KB 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

Exchange Server 2003 조정 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372, "Exchange Server 2003에서 메모리 사용을 최적화하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)


RPC 버퍼 압축을 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 RPC(원격 프로시저 호출) 버퍼 압축이 사용할 수 없도록 되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Packing Enabled

Exchange Server Analyzer는 Rpc Packing Enabled 레지스트리 키의 값 데이터가 0으로 설정되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다. Rpc Packing Enabled 레지스트리 키는 값 데이터가 0으로 설정되어 있으면 사용할 수 없게 됩니다.

Rpc Packing Enabled 레지스트리 키의 값 데이터는 관리자가 Microsoft Office Outlook® 2003 및 Exchange Server 2003 간의 RPC 압축을 구성하도록 추가할 수 있는 세 가지 레지스트리 항목 중 하나입니다.

Outlook 2003은 96KB의 데이터 버퍼를 요청할 수 있습니다. 그러나 Exchange Server 2003이 데이터를 압축하면 데이터 버퍼가 Outlook 2003이 요청한 양보다 상당히 적을 수도 있습니다.

Exchange Server 2003은 다양한 압축율을 지원하며 효율성을 위해 항상 버퍼를 꽉 채워 두기 위해 버퍼 압축을 지원합니다.

Rpc Packing Enabled 레지스트리 키를 사용할 수 있는 경우, Exchange Server 2003은 버퍼가 꽉 찰 때까지 버퍼에 압축된 데이터를 계속 추가합니다. 데이터를 요청할 때마다 Outlook 2003은 다음과 같은 이유 때문에 Outlook의 이전 버전보다 훨씬 많은 데이터를 다운로드할 수 있습니다.

  • Outlook 2003은 보다 큰 버퍼 크기를 요청합니다.

  • Exchange Server 2003은 버퍼 압축을 지원합니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다. 그러나 기본 구성을 복원하려는 경우에는 Rpc Packing Enabled 레지스트리 키를 삭제할 수 있습니다. 또한 Rpc Packing Enabled 레지스트리 키의 데이터 값을 1로 설정하여 RPC 버퍼 압축을 사용할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성을 복원하려면 다음을 수행합니다

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

    • 항목을 삭제하려면 Rpc Packing Enabled 값을 삭제합니다.

    • 항목을 유지하고 RPC 버퍼 압축을 사용하려면 Rpc Packing Enabled를 두 번 클릭하고 값을 1로 설정한 다음 확인을 클릭합니다.

  3. 레지스트리 편집기를 닫습니다.

Microsoft Exchange Information Store 서비스는 몇 분 이내에 변경 내용을 감지합니다. 컴퓨터를 다시 시작할 필요가 없습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Outlook 클라이언트와 Exchange Server 2003 간의 RPC 비교를 구성하도록 레지스트리 키를 설정하는 방법에 대한 자세한 내용은 기술 자료 문서 825371, "Modify Remote Procedure Call Compression in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371)을 참조하십시오.


RPC Compression Minimum Size가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 RPC(원격 프로시저 호출) 압축의 최소 패킷 크기를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Compression Minimum Size

Exchange Server Analyzer는 Rpc Compression Minimum Size 값이 0보다 클 경우 기본 구성이 아니라는 메시지를 표시합니다.

기본적으로 Microsoft Office Outlook® 2003 또는 Outlook 2007과 Exchange Server 2003 또는 Exchange Server 2007 사이를 이동하는 모든 RPC 데이터는 크기에 관계없이 압축됩니다. 하지만 이러한 RPC 압축을 제어해야 하는 경우가 있습니다. 예를 들어 네트워크를 통해 보내는 패킷을 살펴 연결 문제를 해결하려는 경우 RPC 압축을 사용하면 추적 과정에서 압축된 상태의 데이터만 볼 수 있기 때문에 분석이 어려워집니다.

RPC 압축 설정을 구성하려면 시스템 설정에 다음 세 레지스트리 키 값을 추가합니다.

  • Rpc Compression Minimum Size

  • Rpc Compression Enabled

  • Rpc Packing Enabled

Rpc Compression Minimum Size 레지스트리 값은 압축이 활성화되는 데 필요한 RPC 패킷의 최소 바이트 수를 결정합니다. 이 키가 없으면 기본값인 1,024바이트가 사용됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. Rpc Compression Minimum Size 키를 삭제합니다. Rpc Compression Enabled 및 Rpc Packing Enabled 키가 있으면 모두 삭제합니다.

  4. 레지스트리 편집기를 닫고 Exchange Server를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RPC 압축을 제어하는 방법은 기술 자료 문서 825371, "Modify Remote Procedure Call Compression in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371)을 참조하십시오.


RpcEtwTracing 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 키를 읽어 값 데이터를 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\RpcEtwTracing

Exchange Server Analyzer는 RpcEtwTracing 레지스트리 키의 값 데이터가 1로 설정되어 있는 경우 기본 구성이 아니라는 메시지를 표시합니다.

RpcEtwTracing 레지스트리 키의 값 데이터는 Microsoft Office Outlook® 2003과 Exchange Server 사이의 네트워크 문제 해결에만 사용합니다. 현재 문제를 해결하고 있지 않으면 RpcEtwTracing 레지스트리 키를 사용하지 않도록 설정하는 것이 좋습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다. 그러나 기본 구성을 복원하려는 경우에는 RpcEtwTracing 레지스트리 키를 삭제할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성을 복원하려면 다음을 수행합니다

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. RpcEtwTracing 값을 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

Microsoft Exchange Information Store 서비스는 몇 분 이내에 변경 내용을 감지합니다. 컴퓨터를 다시 시작할 필요가 없습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


서버에 4개 미만의 저장소 그룹이 있지만 정의된 사서함 저장소는 5개 이상입니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server 2003을 실행하는 서버에서 StorageGroup 개체 및 MailboxGroup 개체의 수를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer에서 StorageGroup 개체의 총수가 4 미만이고 MailboxStore 개체의 총수는 5 이상임을 확인하면 오류가 표시됩니다.

Exchange Server 2003 Standard Edition을 사용하는 경우 각 Exchange Server 컴퓨터는 사서함 저장소와 공용 폴더 저장소를 각각 하나씩 지원하는 저장소 그룹을 하나 가질 수 있습니다. Exchange Server 2003 Enterprise Edition을 사용하는 경우 각 서버는 4개의 저장소 그룹을 가질 수 있습니다. 이 경우 각 저장소 그룹은 5개의 데이터베이스(사서함 저장소 또는 공용 폴더 저장소)를 지원합니다.

Exchange Server 2003 Enterprise Edition을 실행하는 컴퓨터의 저장소 그룹을 구성하려면 최대 수의 저장소 그룹이 만들어질 때까지 각각의 새 데이터베이스에 대해 저장소 그룹을 추가하는 것이 좋습니다. Exchange Server 저장소 토폴로지의 사서함 로드를 가능한 한 많은 저장소 그룹으로 분산시킬 수 있습니다. 그러한 토폴로지에는 다음과 같은 이점이 있습니다.

  • 저장소 토폴로지의 안정성이 증가됩니다.

  • 저장소 토폴로지의 복구 기능이 향상됩니다.

  • 드라이브 입/출력(I/O) 관리가 개선됩니다.

Exchange Server 2003 Enterprise Edition을 실행하는 서버에 4개 미만의 저장소 그룹과 5개 이상의 사서함 저장소가 있는 경우 다음 단계에 따라 최대한 많은 저장소 그룹에 사서함을 분산시키십시오.

이 오류를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager에서 이 오류를 보고한 서버를 선택합니다. 해당 서버에 있는 저장소 그룹 및 사서함 저장소의 수를 기록합니다. 사서함 저장소를 둘 이상 포함하는 저장소 그룹을 기록합니다.

  2. Exchange Server 2003 Enterprise Edition을 실행하는 컴퓨터에 4개의 저장소 그룹이 생길 때까지 추가 저장소 그룹을 만듭니다. 새로운 저장소 그룹을 만드는 방법에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "저장소 그룹 추가"를 참조하십시오.

  3. 새로 만든 각 저장소 그룹에 새로운 사서함 저장소를 만듭니다. 새로운 사서함 저장소를 만드는 방법에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "사서함 저장소 추가"를 참조하십시오.

  4. 사서함 저장소가 여러 개 있는 저장소 그룹의 사서함 저장소 중 하나에서 새로 만든 저장소 그룹에 있는 사서함 저장소로 사서함을 이동합니다. 사서함 이동 마법사를 사용하여 사서함을 이동합니다. 사서함 이동 마법사를 사용하는 방법에 대한 자세한 내용은 Exchange Server 2003 배포 가이드(http://go.microsoft.com/fwlink/?LinkId=47569)에서 "Exchange Server 5.5에서 Exchange Server 2003으로 마이그레이션" 장의 "Exchange 작업 마법사를 사용하여 사서함 이동"을 참조하십시오.

Exchange Server 2003에서 저장소 그룹을 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 890699, "How to configure storage groups in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=890699)을 참조하십시오.

저장소 그룹을 구성하는 방법에 대한 자세한 내용은 Exchange Server 2003 높은 수준의 가용성 가이드(http://go.microsoft.com/fwlink/?LinkId=47571)의 "안정적인 백 엔드 저장소 솔루션 계획"에서 저장소 그룹 구성 섹션을 참조하십시오.

사용 가능성, 내결함성 및 성능을 최대화하는 데 도움이 되는 전반적인 권장 사항은 Exchange Server 2003의 저장소 최적화(http://go.microsoft.com/fwlink/?LinkId=49324)를 참조하십시오.


데이터베이스와 스트리밍 파일 간 서명 불일치
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange 데이터베이스(.edb) 파일과 해당 Exchange 스트리밍 데이터베이스(.stm) 파일 간 서명이 일치하지 않음을 확인했습니다.

Exchange 2000 Server 및 Exchange Server 2003의 각 데이터베이스는 .edb MAPI 데이터베이스 파일과 .stm 스트리밍 데이터베이스 파일의 두 가지 파일로 구성됩니다. 이 파일 중 일치하는 쌍은 공통의 데이터베이스 서명을 공유합니다. 데이터베이스 서명이 일치하지 않으면 파일이 일치하지 않는 것입니다.

.edb와 .stm 파일을 단일 파일로 간주하여 항상 같이 이동하거나 복사해야 합니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 데이터베이스 파일의 기록을 검토합니다. 파일을 수동으로 복사, 이동 또는 삭제했을 가능성이 있습니다. 데이터베이스를 복구하기 전에 이 문제를 해결해야 합니다.

  • 일치하는 .edb 및 .stm 파일을 찾을 수 없는 경우에는 Eseutil.exe를 사용하여 .edb 파일만 복구하고 /createstm 스위치와 Eseutil을 사용하여 .stm 파일을 삭제할 수 있습니다. 이 방법을 사용하면 스트리밍 데이터베이스에 있는 모든 정보를 잃게 됩니다.

    참고:
    모든 데이터베이스 사용자가 Microsoft Office Outlook®과 같은 MAPI 클라이언트를 사용하여 데이터베이스에 연결하는 경우 스트리밍 데이터베이스에 저장된 정보는 거의 없습니다. 사용자가 POP3, IMAP 또는 Outlook Web Access 클라이언트를 사용하여 데이터베이스에 연결하는 경우 스트리밍 데이터베이스에는 사용자 사서함 내용의 일부 또는 모두가 포함됩니다.

Exchange 데이터베이스를 복구하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 812357, "How to maintain your Exchange database after you repair by using the Eseutil /p tool in Exchange Server 5.5, in Exchange 2000 Server, and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357)을 참조하십시오.


SMTP 주소가 기본 받는 사람 정책에 정의되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-12-03

Microsoft® Exchange Server Analyzer Tool은 SMTP 주소가 Exchange Server 조직에서 기본 받는 사람 정책의 gatewayProxy 특성에 정의되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 gatewayProxy 특성에 SMTP 주소가 없으면 오류를 표시합니다.

이 오류는 중대한 오류입니다. Exchange Server 조직에 있는 기본 받는 사람 정책의 gatewayProxy 특성에 SMTP:@contoso.com과 같은 SMTP 주소를 추가해야 합니다. 기본 받는 사람 정책에는 SMTP 주소가 있어야 합니다. 기본 받는 사람 정책에 SMTP 주소가 없으면 Microsoft Exchange Information Store 서비스가 다시 시작된 후에 초기화되지 않습니다. 이 오류는 Microsoft Exchange Information Store 서비스가 다시 시작된 다음에 Exchange Server 조직의 모든 Exchange Server에 발생합니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003이나 Exchange Server 2007 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
기본 받는 사람 정책의 gatewayProxy 특성에 SMTP 주소를 추가하려면 다음을 수행하십시오.

  1. Microsoft Windows® 2000 지원 도구 또는 Windows Server 2003 지원 도구에서 ADSI 편집 도구를 시작합니다.

  2. 다음 노드를 확장합니다.

    • 구성 컨테이너

    • 구성

    • 서비스

    • Microsoft Exchange

    • Organization_Name

    • 받는 사람 정책

  3. 세부 정보 창에서 CN=Default 정책을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 특성 상자에서 gatewayProxy를 두 번 클릭합니다.

  5. 다중값 문자열 편집기 대화 상자의 추가할 값 필드에 SMTP:@domain_name.com을 입력한 다음 추가를 클릭합니다.

    참고:
    입력한 구문은 중요합니다. Exchange Server 조직의 도메인 이름 앞에 SMTP:@를 입력해야 합니다. 이 문자열에 공백은 사용하지 않습니다.

  6. 확인, 적용을 차례로 클릭한 다음 ADSI 편집을 닫습니다.

  7. 복제될 때까지 적어도 15분 동안 기다립니다.


Store RPC prorate 레지스트리 매개 변수가 올바른 값으로 설정되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 세 가지 레지스트리 키를 읽어 해당 값이 기본값과 다른 값으로 수정되었는지 여부를 확인합니다. 이 세 가지 키는 모두 아래 위치에서 찾을 수 있는 DWORD 값입니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

키에는 다음과 같은 이름과 기본값이 포함되어 있습니다.

DWORD 값 기본 10진수 값
  • ProrateStart
  • 40
  • ProrateMax
  • 10,000
  • ProrateFactor
  • 100

Exchange Server Analyzer는 위의 기본값 중 하나가 변경되면 기본 구성이 아니라는 메시지를 표시합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본값으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle를 탐색합니다.

  3. 오른쪽 창에서 값을 변경한 항목을 두 번 클릭한 다음 기본값에 맞게 구성해야 합니다.

  4. 두 개 이상의 값이 변경된 경우에는 3단계를 반복합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

저장소 프로세스 임계값에 대한 자세한 내용은 기술 자료 문서 267255, "Store.exe Threads Use Up Available Memory"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=267255)를 참조하십시오.


저장소 작업 디렉터리가 없거나 잘못되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-30

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange Information Store 서비스의 작업 디렉터리를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Working Directory

Exchange Server Analyzer는 다음 조건이 존재하는 경우 경고 메시지를 표시합니다.

  • 작업 디렉터리로 지정된 디렉터리가 없습니다.

  • Exchange 2000 Server, Exchange Server 2003 또는 Exchange Server 2007을 실행하고 있습니다.

Exchange Server는 임시 저장소로 작업 디렉터리를 사용합니다. 예를 들어 Exchange Server는 메시지 변환 프로세스 동안 작업 디렉터리를 사용합니다. 또한 Exchange Server는 작업 디렉터리를 사용하여 조각 모음을 수행하는 동안 임시 데이터베이스를 저장합니다. 작업 디렉터리가 올바르게 지정되지 않으면 다음 문제가 발생할 수도 있습니다.

  • SMTP 로컬 배달 큐에 첨부 파일이 있는 메시지 수가 증가할 수도 있습니다.

  • 첨부 파일이 없이 메시지를 받을 수도 있습니다.

  • 메시지가 성공적으로 배달되지 않을 수 있습니다.

기본적으로 Exchange 2000 Server 및 Exchange Server 2003에서는 Exchange Server를 설치한 디렉터리 아래의 mdbdata 디렉터리를 작업 디렉터리로 설정합니다. 예를 들어 C:\Program Files\Exchsrvr 디렉터리에 Exchange Server를 설치한 경우, Exchange Server는 C:\Program Files\Exchsrvr\mdbdata로 작업 디렉터리를 설정합니다.

기본적으로 Exchange Server 2007은 Exchange Server를 설치한 디렉터리 아래의 사서함 데이터베이스 디렉터리를 작업 디렉터리로 설정합니다. 예를 들어 C:\Program Files\Exchange Server 디렉터리에 Exchange Server를 설치한 경우 Exchange Server 2007에서는 C:\ Program Files\Exchange Server\Mailbox\MDBTemp가 작업 디렉터리로 설정됩니다.

이 경고를 해결하려면 작업 디렉터리를 Exchange 서버에 있는 디렉터리로 지정합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
regedit를 사용하여 작업 디렉터리를 지정하려면 다음을 수행합니다.

  1. 레지스트리 편집기(regedit)를 시작합니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. Working Directory 레지스트리 값을 Microsoft Exchange Information Store 서비스의 올바른 작업 디렉터리(예: C:\Program Files\Exchsrvr\mdbdata)로 업데이트합니다.

    참고:
    이렇게 변경해도 Microsoft Exchange Information Store 서비스를 다시 시작할 필요가 없습니다.

  4. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Working Directory 레지스트리 값에 대한 자세한 내용은 기술 자료 문서 298415, "XCON: 첨부 파일이 메시지가 예상대로 전달되지 않고 이벤트 ID 12003 및 327 메시지가 기록된다"(http://go.microsoft.com/fwlink/?Linkid=3052&kbid=298415)를 참조하십시오.


메일 그룹에 대해 부재 중 메시지 표시 안 함이 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-02-27

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 메일 그룹에 대해 부재 중 메시지가 표시되지 않는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\SuppressOOFsToDistributionLists

Exchange Server Analyzer는 SuppressOOFsToDistributionLists 값이 0보다 큰 경우 기본 구성이 아니라는 메시지를 표시합니다.

부재 중 알림이 설정된 사서함으로 메시지가 보내지면 보낸 사람은 받는 사람 또는 참조 필드에는 주소가 없고 숨은 참조 필드에는 메일 그룹이 포함되어 있는 메시지를 받게 되며 숨은 참조 필드에 있는 메일 그룹으로 부재 중 메시지가 보내집니다.

메시지가 받는 사람에게 보내지고 받는 사람 주소가 숨은 참조 필드에만 지정되어 있고 메일 그룹에는 포함되어 있지 않으며 받는 사람이 부재 중 알림을 설정한 경우, SuppressOOFsToDistributionLists 레지스트리 값이 설정된 경우에도 받는 사람의 사서함 저장소는 부재 중 메시지를 계속 보냅니다. 이러한 제한은 받는 사람 주소가 숨은 참조 필드에 지정되어 있고 받는 사람 또는 참조 필드가 비어 있을 때만 적용됩니다. 받는 사람 또는 참조 필드에 사용자가 한 명 이상 지정되어 있는 경우 Exchange Server 컴퓨터의 해당 레지스트리 매개 변수는 숨은 참조 필드에 나열된 받는 사람이 부재 중 메시지를 생성하지 못하도록 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

부재 중 메시지 생성 동작을 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. ParametersSystem을 마우스 오른쪽 단추로 클릭하고 새로 만들기를 가리킨 후 DWORD 값을 클릭합니다.

  4. 새 값의 이름을 SuppressOOFsToDistributionLists로 지정합니다.

  5. SuppressOOFsToDistributionLists를 마우스 오른쪽 단추로 클릭한 다음 수정을 클릭합니다.

  6. 값 데이터 상자에 1을 입력한 다음 확인을 클릭합니다.

  7. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

SuppressOOFsToDistributionLists 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 825370, "Out-of-Office Messages Are Sent to Distribution Lists That Are in the BCC Field"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=825370)를 참조하십시오.


손상된 메시지가 저장소를 통과할 수 있는 횟수를 제어하는 임계값이 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-08

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 PoisonThreshold 값을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

Exchange Server Analyzer는 PoisonThreshold 값이 2가 아니면 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server 2003 서비스 팩 1 이후의 Exchange Server 버전은 손상되었거나 잘못된 메시지로 인해 Microsoft Exchange Information Store 서비스가 예기치 않게 중지되거나 Exchange 정보 저장소 서비스가 시작되지 않는 문제를 방지하는 기능을 구현합니다.

Exchange Server 2003 서비스 팩 1 이상에서는 MAPI 형식을 MIME 형식으로 변환하는 동안 Microsoft Exchange Information Store 서비스가 예기치 않게 중지되도록 하는 메시지를 추적합니다. 충돌이 발생할 경우 손상된 메시지의 메시지 ID가 레지스트리에 저장됩니다. 손상된 메시지로 인해 저장소가 예기치 않게 세 번 중지되면 이 정보를 사용하여 Microsoft Exchange Information Store 서비스가 네 번째로 시작될 때 해당 메시지가 다시 처리되지 않도록 합니다.

손상된 메시지로 인해 Microsoft Exchange Information Store 서비스가 예기치 않게 종료되면 아래 위치에 PoisonIDs 레지스트리 값이 만들어집니다.

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

또한 관리자도 PoisonThreshold 레지스트리 항목을 만들 수 있습니다. PoisonThreshold 키는 PoisonIDs 레지스트리 키에 추가되기 전에 메시지가 Exchange 정보 저장소를 통과할 수 있는 최대 횟수를 제어합니다. 기본적으로 이 임계값은 2입니다. 이 임계값이 초과된 경우에만 동작이 발생합니다. 따라서 메시지가 차단될 때까지 손상된 메시지로 인해 Microsoft Exchange Information Store 서비스가 3번까지 중지될 수 있습니다. 예를 들어 한 메시지가 3번의 충돌과 관련되면 이 숫자가 임계값 2보다 크므로 메시지가 차단됩니다.

손상된 메시지 이벤트가 레지스트리에 기록되면 응용 프로그램 이벤트 로그에 오류 이벤트 메시지(이벤트 ID 9680 및 9681)가 나타납니다. Microsoft Exchange Information Store 서비스가 성공적으로 시작되면 Exchange는 손상된 메시지를 차단하고 이에 대한 배달 못 함 보고서(NDR)를 보냅니다. Exchange가 배달 못 함 보고서(NDR)를 보내지 못할 경우도 있을 수 있습니다. 그러한 경우에 차단된 메시지는 만료될 때까지 큐에 남아 있게 됩니다. PoisonIDs 레지스트리 키는 메시지 ID 값을 10개까지 보관합니다. 10개를 초과하게 되면 새로운 손상된 메시지 이벤트가 추가됩니다. 그리고 충돌 날짜가 가장 오래된 손상된 메시지 이벤트는 제거합니다.

참고:
손상된 개별 메시지의 문제 해결 과정은 Exchange Server Analyzer로 해결할 수 없습니다. 일부 손상된 개별 메시지 문제는 Microsoft 기술 지원 서비스의 도움을 받아 해결할 수도 있습니다. 손상된 메시지로 인해 Exchange Server 2003 이상의 시스템 종료에 문제가 발생한 경우 Exchange Server 컴퓨터에서 자동 오류 보고를 사용하면 도움이 될 수 있습니다. 사용 중인 소프트웨어의 문제를 찾아서 해결하는 데 이 오류 보고서의 데이터가 사용됩니다. Exchange 오류 보고를 사용하는 방법에 대한 자세한 내용은 Exchange 오류 보고 기능이 비활성화되어 있습니다.를 참조하십시오.

PoisonThreshold 값을 기본값 2로 다시 변경하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ExchangeServerName>\Private-<PrivateInformationStoreGUID>를 탐색합니다.

  3. 오른쪽 창에서 PoisonThreshold를 두 번 클릭합니다.

  4. 값 데이터 필드에 2(10진수)를 입력하고 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


저장소 프로세스의 추적이 활성화되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Enable Tracing 레지스트리 항목이 Trace User LegacyDN 레지스트리 값과 함께 존재하는지 확인할 때 해당 레지스트리를 검토합니다. 두 레지스트리 값 모두 다음 레지스트리 키 아래 있습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Exchange Server Analyzer는 두 레지스트리 항목이 모두 존재하고 구성되어 있을 경우 경고를 표시합니다.

Enable Tracing DWORD 레지스트리 값은 Microsoft Exchange Information Store 서비스에서 추적 기능을 사용 가능하게 합니다. 추적 기능은 Exchange 저장소 시작의 문제 해결에 사용되며 성능에 심각한 영향을 미칠 수 있습니다. 문제를 해결하고 있는 경우가 아니면 이 레지스트리 설정을 사용하지 마십시오. Trace User LegacyDN 레지스트리 문자열 값을 추가하면 특정 사용자에 대한 추적(필터링된 추적)을 사용할 수 있습니다. Trace User LegacyDN 값이 존재하지 않으면 모든 사용자에 대해 추적을 사용할 수 있습니다. Trace User LegacyDN 값이 존재하면 해당 키에 나열된 특정 사용자에 대한 추적 기능을 사용하고 있는 것입니다.

Exchange Server 컴퓨터에서 문제 해결을 수행하고 있는 경우가 아니면 이러한 레지스트리 값은 존재하면 안 됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. Enable Tracing과 Trace User LegacyDN 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange 서버에서 사용자별로 추적하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 296624, "Per-User Tracing Feature Added to Exchange 2000 Server Service Pack 2 (SP2)"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624)를 참조하십시오.


모든 사용자에 대해 Microsoft Exchange Information Store 서비스의 추적이 활성화되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 다음에 Enable Tracing 항목이 설정되어 있는지 확인할 때 레지스트리를 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Exchange Server Analyzer는 Enable Tracing 레지스트리 값이 구성되어 있으면 경고를 표시합니다.

Enable Tracing DWORD 레지스트리 값을 구성하면 Microsoft Exchange Information Store 서비스를 추적할 수 있습니다. 추적은 저장소 시작 문제를 해결하는 데 사용되지만 성능에 막대한 영향을 줄 수 있습니다. 따라서 문제 해결을 위한 경우 이외에는 이 레지스트리 설정을 사용하지 않는 것이 좋습니다. Trace User LegacyDN 레지스트리 문자열 값을 추가하여 특정 사용자가 추적을 사용하도록 할 수 있습니다. 이 값이 없으면 모든 사용자가 추적을 사용할 수 있다는 의미입니다.

Exchange Server 컴퓨터에서 문제를 해결하지 않을 경우 이 값이 있으면 안 됩니다.

참고:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. Enable Tracing 레지스트리 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange 서버에서 사용자별로 추적하는 방법에 대한 자세한 내용은 기술 자료 문서 296624, "XADM: Per-User Tracing Feature Added to Exchange 2000 Server Service Pack 2 (SP2)"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624)를 참조하십시오.


트랜잭션 로그 파일 이름이 부족합니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 서버 디스크에서 로그 파일을 검토하여 각 저장소 그룹에 대한 트랜잭션 로그 파일의 상태를 확인합니다. Exchange Server Analyzer는 로그 파일의 위치를 찾을 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 각 저장소 그룹 개체(msExchStorageGroup 클래스)에 대한 로그 파일 경로는 msExchESEParamLogFilePath 특성에 저장됩니다.

트랜잭션 로그 파일 이름에는 로그 파일의 시퀀스를 식별하는 일련의 16진수 번호가 포함됩니다. 예를 들어 기본 저장소 그룹에 대한 첫 번째 로그 파일 이름은 E0000001.log, 두 번째 로그 파일 이름은 E0000002.log이고 다음 로그 파일들의 이름도 같은 방식으로 지정됩니다. 시퀀스는 E00FFFFF.log까지 지정할 수 있습니다. Exchange는 최대 1,030,000개의 고유 로그 파일을 만들 수 있습니다. 그러나 Exchange가 시퀀스의 끝에 도달한 경우 영향을 받는 저장소 그룹의 저장소는 한계에 도달한 이후 분리되면 더 이상 탑재되지 않습니다. 탑재된 상태로 남아 있으면 저장소는 Jet 작업이 발생하지 않아도 데이터베이스를 분리하지 않습니다. 일반적으로 Exchange를 실행하면서 이 한계에 도달할 때까지는 수 년이 걸립니다.

지정한 서버에서 950,000개보다 많은 트랜잭션 로그 파일을 사용한 경우 이 메시지가 경고로 표시됩니다.

지정한 서버에서 1,020,000개보다 많은 트랜잭션 로그 파일을 사용한 경우 이 메시지가 오류로 표시됩니다.

저장소가 이 제한에 도달한 경우 데이터베이스를 제대로 분리하도록 하기 위해 Exchange Server 2003 서비스 팩 1에 픽스가 포함되었습니다. Microsoft 기술 자료 문서 830408, "Exchange database stores remain mounted although all transaction logs that are available to a storage group have been used"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408)에 설명된 대로 서비스 팩 3 이후 핫픽스는 Exchange 2000 Server에 사용할 수 있습니다.

Exchange가 아직 1,030,000 트랜잭션 로그 제한에 도달하지 않은 경우에는 가능한 빨리 서버의 전체 온라인 백업을 수행합니다. Exchange 저장소의 전체 온라인 백업 수행 방법에 대한 자세한 내용은 Exchange 2003 재해 복구 작업 가이드(http://go.microsoft.com/fwlink/?LinkId=47570)를 참조하십시오.

Exchange가 이 제한에 도달한 경우에는 기존 트랜잭션 로그를 모두 다른 위치로 이동해야 합니다. 그러면 0x00001로 시작하는 로그 파일의 새 시퀀스가 생성됩니다. Exchange 저장소가 데이터베이스를 제대로 분리하도록 하려면 Exchange 버전에 적합한 픽스를 적용해야 합니다.

참고:
트랜잭션 로그를 이동하기 전에 저장소 그룹의 모든 데이터베이스가 완전하게 종료된 상태인지 확인해야 합니다.
중요:
아래 절차를 수행하면 이전의 모든 백업이 무효가 됩니다. 백업을 복원할 수 없다는 의미는 아니지만 추가 트랜잭션 로그로 백업을 더 이상 롤 포워드할 수 없습니다. 트랜잭션 로그를 제거한 후 이전 백업을 복원해야 할 경우 새 로그 생성이 만들어진 시간까지의 데이터만 복원할 수 있습니다.

이 문제를 해결하려면 다음을 수행합니다.

  1. Exchange Server 2003의 경우 Exchange Server 다운로드 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=29090)에서 사용할 수 있는 서비스 팩 1을 설치합니다.

    또는

    Exchange 2000 Server의 경우 Microsoft 기술 자료 문서 830408, "Exchange database stores remain mounted although all transaction logs that are available to a storage group have been used"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408)에서 참조한 핫픽스를 구하여 설치합니다.

  2. 트랜잭션 로그 파일이 부족한 저장소 그룹에서 모든 데이터베이스를 분리합니다. 이렇게 하려면 다음 단계를 수행합니다.

    1. Exchange System Manager를 엽니다.

    2. 관리 그룹, <AdministrativeGroupName>, 서버, <ServerName>, <StorageGroupName>을 차례로 확장합니다.

    3. 이 저장소 그룹의 첫 번째 저장소를 마우스 오른쪽 단추로 클릭하고 저장소 분리를 클릭합니다. 이 저장소 그룹의 각 저장소마다 이 단계를 반복합니다.

  3. 저장소 그룹의 각 데이터베이스가 완전하게 종료된 상태인지 확인합니다. 이렇게 하려면 다음 단계를 수행합니다.

    1. Exchange System Manager에서 트랜잭션 로그 파일이 부족한 저장소 그룹의 첫 번째 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

    2. 데이터베이스 탭을 클릭한 다음 Exchange 데이터베이스 상자와 Exchange 스트리밍 데이터베이스 상자에 데이터베이스 파일의 경로와 파일 이름을 기록합니다. 각 Exchange 데이터베이스는 .edb 파일 이름 확장명과 .stm 파일 이름 확장명을 가지는 한 쌍의 파일 집합으로 구성되어 있습니다. 저장소 그룹의 각 저장소마다 이 단계를 반복합니다.

    3. 명령 프롬프트에서 Exchange Server bin 폴더로 디렉터리를 변경합니다. 예를 들어 디렉터리를 C:\Program Files\Exchsrvr\bin으로 변경합니다.

    4. Eseutil /mh DatabaseFileName을 입력한 다음 Enter 키를 누릅니다. 저장소 그룹의 각 데이터베이스마다 이 단계를 반복합니다. 이 명령은 데이터베이스 파일 헤더를 표시합니다. 헤더에는 State: Clean Shutdown 또는 State: Dirty Shutdown 줄 중 하나가 포함됩니다.

  4. 헤더에 State: Dirty Shutdown 줄이 포함되어 있으면 로그 파일을 제거하기 전에 데이터베이스를 수동으로 복구해야 합니다. 이렇게 하려면 다음 단계를 수행합니다.

    1. Exchange System Manager에서 트랜잭션 로그 파일이 부족한 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

    2. 일반 탭을 클릭한 다음 트랜잭션 로그 위치 상자에 트랜잭션 로그 경로를 기록합니다.

    3. 시스템 경로 위치 상자에 검사점 파일 경로를 기록합니다.

    4. 명령 프롬프트에서 Exchange Server bin 폴더로 디렉터리를 변경합니다.

    5. Eseutil /r 3-CharacterLogfileBaseName /lDirectory:\LogfilePath /sDirectory:\CheckpointFilePath 명령을 입력하고 Enter 키를 누릅니다.

      참고:
      옵션 스위치와 디렉터리 경로 사이에 공백을 넣으면 안 됩니다. 명령에 나열된 경로에 철자를 잘못 입력하면 복구되지 않을 수 있습니다. 이것을 방지하기 위해 트랜잭션 로그 파일 폴더에 검사점 파일을 복사할 수 있습니다. 로그 파일 디렉터리가 기본값인 명령 프롬프트에서 Eseutil /r 3-CharacterLogfileBaseName 명령을 실행합니다. /l 스위치와 /s 스위치의 기본값은 현재 디렉터리이므로 로그 파일 경로와 검사점 파일 경로를 제공하지 않아도 됩니다.
    6. 복구가 완료되면 데이터베이스 파일이 모두 완전하게 종료된 상태에 있는지 확인한 다음 트랜잭션 로그 파일과 검사점 파일을 이동합니다. 데이터베이스가 부적절한 종료 상태에 있을 때 로그 파일을 이동하면 데이터베이스를 다시 시작할 수 없습니다. 데이터베이스를 모두 완전하게 종료된 상태로 복구할 수 없는 경우 Microsoft 기술 지원 서비스로 문의하십시오.

  5. Exchange System Manager에서 트랜잭션 로그 파일이 부족한 저장소 그룹을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  6. 일반 탭을 클릭한 다음 트랜잭션 로그 위치 상자에 트랜잭션 로그 경로를 기록합니다.

  7. 시스템 경로 위치 상자에 검사점 파일 경로를 기록합니다.

  8. 트랜잭션 로그 파일과 검사점 파일을 다른 위치로 이동합니다. 로그 파일의 파일 확장명은 .log이고 검사점 파일의 파일 확장명은 .chk입니다.

  9. Exchange System Manager에서 저장소 그룹의 처음 분리된 저장소를 마우스 오른쪽 단추로 클릭하고 저장소 탑재를 클릭합니다.

  10. 저장소 그룹의 각 저장소마다 이 단계를 반복합니다. 로그 파일 시퀀스는 저장소 그룹에 새로 다시 설정됩니다.

  11. 저장소 그룹의 모든 데이터베이스를 전체 백업합니다.

Exchange Server 서비스 팩에 대한 자세한 내용은 Exchange Server 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21573)를 참조하십시오.


가장 큰 VM 블록 크기가 작습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 VMLargestBlockSize 키 값을 확인할 때 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. VMLargestBlockSize 키는 가상 메모리의 사용 가능한 최대 블록 크기(바이트)를 나타냅니다.

또한 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열되어 있는 항목 수를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다.

Exchange Server Analyzer는 사서함을 20개 이상 포함하는 Exchange Server 컴퓨터에서 VMLargestBlockSize 값이 50000000보다 크지만 150000000보다 작을 경우 경고를 표시합니다.

Exchange Server는 MIME 및 MAPI 형식 사이에서 메시지를 변환할 경우 메시지 저장을 위해 가상 메모리를 사용하며, 트랜잭션 로그에서 메시지를 커밋할 때와 저장소로 메시지를 커밋할 때는 가상 메모리를 버퍼로 사용합니다. 이러한 작업을 빠르고 효율적으로 완료하려면 대량의 연속 가상 메모리 청크가 필요합니다. 이 경고가 표시되면 Exchange 컴퓨터의 가상 메모리가 150MB의 연속 공간 크기보다 작게 줄어듭니다. 이것을 가상 메모리 조각화라고 합니다.

가상 메모리가 너무 많이 감소되면 이벤트 로그(이벤트 ID 9582)에 가상 메모리 오류가 기록될 수 있습니다. 가상 메모리가 부족하면 이벤트 ID 12800이 기록됩니다. 이것은 메모리가 부족하여 메시지를 처리할 수 없기 때문에 메시지가 배달되지 않음을 나타냅니다.

이 경고를 해결하려면 다음 권장 사항을 제시된 순서대로 수행하십시오.

Exchange Server Analyzer 출력에 "최대 ESE 캐시 크기에 도달했습니다."라는 오류가 있는지 확인합니다.

이 가상 메모리 조각화 경고가 반환된 Exchange 컴퓨터에서 최대 ESE 캐시 크기에 도달했습니다.라는 오류가 반환되면 문서 최대 ESE 캐시가 너무 크게 설정되었습니다.의 권장 사항에 따라 작업하십시오.

이러한 두 메시지가 표시될 경우 ESE 캐시 크기의 수동 증가로 인해 가상 메모리 조각화 문제가 발생한 경우일 수 있습니다.

Exchange Information Store 서비스 다시 시작

이 오류 메시지에 대한 설명에서 Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스가 실행된 일 수를 지정합니다. 지정된 일 수가 30일보다 크면 서비스를 다시 시작하십시오.

Microsoft Exchange Information Store 서비스를 다시 시작하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. Microsoft Exchange Information Store 서비스를 마우스 오른쪽 단추로 클릭한 다음 다시 시작을 클릭합니다.

메시지 크기 제한 평가

30MB 이상의 대량 메시지를 보내는 사용자가 많이 있을 경우 그렇지 않은 경우보다 가상 메모리가 더 빠르게 조각화될 수 있습니다. 앞에 설명된 것처럼 저장 프로세스를 통해 로그 파일의 데이터가 이동되고 저장소로 커밋되면 가상 메모리가 버퍼로 사용됩니다. 이동되는 데이터가 클 경우 연속된 큰 가상 메모리 청크가 빠르게 사용됩니다.

대량의 데이터가 전자 메일을 통해 정기적으로 전송되며 해당 데이터가 내부적으로도 전송될 경우 사용자가 대량의 데이터를 게시할 수 있는 파일 서버에 공유 디렉터리를 설정하십시오.

최대 메시지 크기 제한을 30MB 미만으로 설정하는 것이 좋습니다. 그러나 Exchange 조직을 통해 큰 첨부 파일을 포함하는 메시지를 전송하고 있으며 이러한 메시지의 크기 제한을 늘려야 할 경우 보내는 메시지의 최대 크기 제한을 30MB 이상으로 늘릴 수 있습니다. 메모리 크기 제한을 30MB 이상으로 늘리면 가상 메모리 조각화가 증가할 뿐만 아니라 시스템이 악의적인 공격을 받을 가능성이 높아질 수 있습니다. 메모리 크기 제한을 30MB 이상으로 늘리는 것은 적절하지 않습니다.

메시지 크기 제한을 설정하려면 다음을 수행합니다.

  1. Exchange System Manager에서 전역 설정을 확장하고 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 메시지 배달 속성 대화 상자의 기본값 탭에서 보내는 메시지 크기 제한 옵션을 선택하고 원하는 크기 제한을 입력합니다.

바이러스 백신 소프트웨어가 최신 상태인지 확인

Exchange VSAPI(바이러스 검색 API) 모드에서 오래된 바이러스 백신 소프트웨어를 실행하면 가상 메모리 조각화가 발생할 수 있습니다. 바이러스 백신 소프트웨어를 VSAPI 모드에서 실행할 경우 바이러스 백신 공급업체에 문의하여 최신 버전의 소프트웨어 및 드라이버를 실행하고 있는지 확인하십시오.

다른 Exchange 서버로 사서함 이동

모든 절차를 수행한 후에도 Exchange Server Analyzer가 계속 이 경고를 표시할 경우 영향 받는 서버 외부로 사서함을 이동하여 서버의 로드를 줄여야 합니다. 이 서버에 너무 많은 수의 사서함이 있는 것입니다.

Exchange 2000 Server 및 Exchange Server 2003에서 사서함을 이동하려면 다음을 수행합니다.

  1. Active Directory 사용자 및 컴퓨터에서 이동할 사서함을 소유한 사용자를 선택합니다.

  2. 이전 단계에서 선택한 사용자 목록을 마우스 오른쪽 단추로 클릭한 다음 Exchange 작업을 클릭합니다.

  3. Exchange 작업 마법사의 사용 가능한 작업 페이지에서 사서함 이동을 클릭한 후 다음을 클릭합니다.

  4. 지침을 주의 깊게 읽고 마법사의 나머지 단계를 수행합니다.

Exchange Server 2003에서 사서함을 이동하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, 사서함을 이동해올 서버, 사서함을 이동해올 저장소 그룹, 이동할 사서함이 포함되어 있는 사서함 저장소를 차례로 확장한 다음 사서함을 클릭합니다.

  2. 세부 정보 창에서 이동할 사서함을 소유한 사용자를 마우스 오른쪽 단추로 클릭한 다음 Exchange 작업을 클릭합니다.

  3. Exchange 작업 마법사의 사용 가능한 작업 페이지에서 사서함 이동을 클릭한 후 다음을 클릭합니다.

  4. 지침을 주의 깊게 읽고 마법사의 나머지 단계를 수행합니다.

가상 메모리 조각화 문제 해결에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 838233, "Your computer may slow or stop responding and repeatedly log event IDs 9582 and 1160 in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233)

메시지 크기 제한 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 322679, "How To Set Size Limits for Messages In Exchange Server"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)를 참조하십시오.

사서함 이동에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 328810, "XADM: 서버 간에 사서함 이동"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810)

  • 821829, "Moving Mailboxes in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)


가장 큰 VM 블록 크기가 위험 상태에 도달하려고 합니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 VMLargestBlockSize 키 값을 확인할 때 Win32_PerfRawData_MSExchangeIS_MSExchangeIS Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. VMLargestBlockSize 키는 가상 메모리의 사용 가능한 최대 블록 크기(바이트)를 나타냅니다.

또한 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열된 항목 개수를 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다.

Exchange Server Analyzer는 사서함을 20개 이상 포함하는 Exchange Server 컴퓨터에서 VMLargestBlockSize 값이 0보다 크지만 50000001보다 작을 경우 오류를 표시합니다.

Exchange 서버는 MIME 및 MAPI 형식 사이에서 메시지를 변환할 경우 메시지 저장을 위해 가상 메모리를 사용하며, 트랜잭션 로그에서 메시지를 커밋할 때와 저장소로 메시지를 커밋할 때는 가상 메모리를 버퍼로 사용합니다. 이러한 작업을 빠르고 효율적으로 완료하려면 대량의 연속 가상 메모리 청크가 필요합니다. 이 오류가 표시되면 Exchange 컴퓨터의 가상 메모리가 50MB의 연속 공간 크기보다 작게 줄어듭니다. 이것을 가상 메모리 조각화라고 합니다. 연속 가상 메모리 공간이 50MB보다 작은 상태로 Exchange 사서함 서버가 실행되면 오류가 발생합니다.

가상 메모리가 너무 많이 감소되면 이벤트 로그(이벤트 ID 9582)에 가상 메모리 오류 경고가 기록될 수 있습니다. 가상 메모리가 부족하면 이벤트 ID 12800이 기록됩니다. 이것은 메모리가 부족하여 메시지를 처리할 수 없기 때문에 메시지가 배달되지 않음을 나타냅니다.

이 오류를 해결하려면 다음 권장 사항을 제시된 순서대로 수행합니다.

Exchange Server Analyzer 출력에 "최대 ESE 캐시 크기에 도달했습니다."라는 오류가 있는지 확인합니다.

이 가상 메모리 조각화 경고가 반환된 Exchange 컴퓨터에서 최대 ESE 캐시 크기에 도달했습니다.라는 오류가 반환되면 문서 최대 ESE 캐시가 너무 크게 설정되었습니다.의 권장 사항에 따라 작업하십시오.

이러한 두 경고가 표시될 경우 ESE 캐시 크기의 수동 증가로 인해 가상 메모리 조각화 문제가 발생한 경우일 수 있습니다.

Exchange Information Store 서비스 다시 시작

이 경고에 대한 설명에서 Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스가 실행된 일 수를 지정합니다. 지정된 일 수가 30일보다 크면 서비스를 다시 시작하십시오.

Exchange Information Store를 다시 시작하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. Microsoft Exchange Information Store 서비스를 마우스 오른쪽 단추로 클릭한 다음 다시 시작을 클릭합니다.

메시지 크기 제한 평가

30MB 이상의 대량 메시지를 보내는 사용자가 많이 있을 경우 그렇지 않은 경우보다 가상 메모리가 더 빠르게 조각화될 수 있습니다. 앞에 설명된 것처럼 저장 프로세스를 통해 로그 파일의 데이터가 이동되고 저장소로 커밋되면 가상 메모리가 버퍼로 사용됩니다. 이동되는 데이터가 클 경우 연속된 큰 가상 메모리 청크가 빠르게 사용됩니다.

대량의 데이터가 전자 메일을 통해 정기적으로 전송되며 해당 데이터가 내부적으로도 전송될 경우 사용자가 대량의 데이터를 게시할 수 있는 파일 서버에 공유 디렉터리를 설정하십시오.

최대 메시지 크기 제한을 30MB 미만으로 설정하는 것이 좋습니다. 그러나 Exchange 조직을 통해 큰 첨부 파일을 포함하는 메시지를 전송하고 있으며 이러한 메시지의 크기 제한을 늘려야 할 경우 보내는 메시지의 최대 크기 제한을 30MB 이상으로 늘릴 수 있습니다. 메모리 크기 제한을 30MB 이상으로 늘리면 가상 메모리 조각화가 증가할 뿐만 아니라 시스템이 악의적인 공격을 받을 가능성이 높아질 수 있습니다. 따라서 메모리 크기 제한을 30MB 이상으로 늘리는 것은 권장되지 않습니다.

메시지 크기 제한을 설정하려면 다음을 수행합니다.

  1. Exchange System Manager에서 전역 설정을 확장하고 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 메시지 배달 속성 대화 상자의 기본값 탭에서 보내는 메시지 크기 제한 옵션을 선택하고 원하는 크기 제한을 입력합니다.

바이러스 백신 소프트웨어가 최신 상태인지 확인

Exchange VSAPI(바이러스 검색 API) 모드에서 오래된 바이러스 백신 소프트웨어를 실행하면 가상 메모리 조각화가 발생할 수 있습니다. 바이러스 백신 소프트웨어를 VSAPI 모드에서 실행할 경우 바이러스 백신 공급업체에 문의하여 최신 버전의 소프트웨어 및 드라이버를 실행하고 있는지 확인하십시오.

다른 Exchange 서버로 사서함 이동

모든 절차를 수행한 후에도 Exchange Server Analyzer가 계속 이 경고를 표시하거나 남아 있는 연속 가상 메모리 공간 크기가 150MB 이하임을 나타내는 경고가 표시되면 영향 받는 서버 외부로 사서함을 이동하여 서버의 로드를 줄여야 합니다. 이 서버에 너무 많은 수의 사서함이 있는 것입니다.

Exchange 2000 Server 및 Exchange Server 2003에서 사서함을 이동하려면 다음을 수행합니다.

  1. Active Directory 사용자 및 컴퓨터에서 이동할 사서함을 소유한 사용자를 선택합니다.

  2. 이전 단계에서 선택한 사용자 목록을 마우스 오른쪽 단추로 클릭한 다음 Exchange 작업을 클릭합니다.

  3. Exchange 작업 마법사의 사용 가능한 작업 페이지에서 사서함 이동을 클릭한 후 다음을 클릭합니다.

  4. 지침을 주의 깊게 읽고 마법사의 나머지 단계를 수행합니다.

Exchange Server 2003에서 사서함을 이동하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, 사서함을 이동해올 서버, 사서함을 이동해올 저장소 그룹, 이동할 사서함이 포함되어 있는 사서함 저장소를 차례로 확장한 다음 사서함을 클릭합니다.

  2. 세부 정보 창에서 이동할 사서함을 소유한 사용자를 마우스 오른쪽 단추로 클릭한 다음 Exchange 작업을 클릭합니다.

  3. Exchange 작업 마법사의 사용 가능한 작업 페이지에서 사서함 이동을 클릭한 후 다음을 클릭합니다.

  4. 지침을 주의 깊게 읽고 마법사의 나머지 단계를 수행합니다.

가상 메모리 조각화 문제 해결에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 838233, "Your computer may slow or stop responding and repeatedly log event IDs 9582 and 1160 in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233)

메시지 크기 제한 설정에 대한 자세한 내용은 기술 자료 문서 322679, "Set Size Limits for Messages"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)를 참조하십시오.

사서함 이동에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 328810, "XADM: 서버 간에 사서함 이동"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810)

  • 821829, "Moving Mailboxes in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829)


VirtualReserveSize is non-default
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 값을 읽어 ExIPC(Exchange Interprocess Communication) 구성 요소의 초기 메모리 할당 기본값이 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIPC\Parameters\VirtualReserveSize

Exchange Server Analyzer는 VirtualReserveSize 키가 0보다 큰 값으로 구성되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

ExIPC는 Inetinfo.exe(인터넷 정보 서비스) 및 Store.exe (Microsoft Exchange Information Store 서비스)가 데이터를 빠르게 백업하고 복구할 수 있게 해 주는 큐 구성 요소입니다. 일반적으로 ExIPC의 기본 초기 메모리 할당으로 충분합니다. 기본적으로 VirtualReserveSize 키가 없습니다. 이 키는 Microsoft Consulting Services나 Microsoft 기술 지원 서비스의 지시에 따라서만 구성해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\EXIPC\Parameters를 탐색합니다.

  3. VirtualReserveSize 키를 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스 및 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

ExIPC에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 821879, "Definitions of key transport components in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821879)

  • 260995, "XCON: Definitions of Key Transport Components in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=260995)


가상 메모리 이벤트 간격이 다시 정의되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 가상 메모리 조각화에 대한 이벤트 로깅 임계값이 수동으로 다시 정의되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ VM Info Update Interval

Exchange Server Analyzer는 VM Info Update Interval 레지스트리 값이 있으나 3600과 다르면 기본 구성이 아니라는 메시지를 표시합니다.

32비트 Microsoft Windows® 시스템에는 실제 메모리(시스템에 설치된 실제 메모리 양)와 가상 메모리 주소 공간(가상화된 4GB 메모리 공간)이라는 두 종류의 메모리가 있습니다. 해당 시스템에 설치되어 있는 실제 메모리 양에 관계없이 전체 가상 주소 공간 크기는 항상 4GB로 동일합니다. 모든 32비트 응용 프로그램에 적용되는 것은 아니지만 Exchange Server의 경우 가상 주소 공간은 가상 메모리와 동일합니다. 즉, 두 용어를 같은 의미로 사용할 수 있습니다.

Microsoft Exchange Information Store 서비스는 정상적인 작업 중에 가상 메모리를 반복적으로 할당, 사용 및 할당 취소합니다. 가상 메모리를 할당하고 사용한 다음 할당을 취소하는 것을 자주 하면 가상 메모리가 조각화될 수 있습니다. 가상 메모리 조각화는 지속적으로 발생할 수 있는 파일 시스템 조각화와 비슷합니다. 어느 정도 시간이 지나면 할당된 가상 메모리 세그먼트가 더 이상 연속적이지 않아 성능이 저하됩니다. 파일 시스템의 경우 파일 시스템 조각 모음을 수행하는 응용 프로그램을 실행할 수 있으며 시스템이 온라인 상태이고 액세스가 가능한 대부분의 시간 동안 이 작업을 수행할 수 있습니다. 가상 메모리 조각화의 경우 조각 모음 도구가 없습니다. 이 문제를 해결하려면 Microsoft Exchange Information Store 서비스를 중지했다가 시작하거나 시스템을 다시 시작해야 합니다.

기본적으로 Microsoft Exchange Information Store 서비스는 한 시간에 한 번씩(예: 3,600초마다) 사용 가능한 가상 메모리를 확인합니다. 관리자는 VM Info Update Interval 레지스트리 값을 사용하여 기본값인 3,600초 간격을 다시 정의할 수 있습니다. 기본 수준을 다시 정의하려는 경우 5분(300초)보다 낮은 값으로는 설정하지 않는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem을 탐색합니다.

  3. 오른쪽 창에서 VM Info Update Interval 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

Exchange Server 2003 및 Exchange 2000 Server의 가상 메모리 조각화 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 325044, "HOW TO: Exchange 2003 및 Exchange 2000에서 가상 메모리 조각화 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)을 참조하십시오.


Write-Back 캐시 사용이 설정되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 저장소 >

최근 수정된 항목: 2006-08-18

Microsoft® Exchange Server Analyzer Tool이 디스크 배열 컨트롤러에서 트랜잭션 로그를 호스팅하는 드라이브에 대해 Write-Back 캐시를 올바르게 설정하지 않았음을 확인했습니다.

트랜잭션 로그를 호스팅하는 모든 드라이브에 대해 배열 컨트롤러에서 Write-Back 캐시를 100%까지 사용하도록 설정하는 것이 좋습니다. 트랜잭션 로그는 거의 읽혀지지 않습니다. 트랜잭션 로그 드라이브의 쓰기 속도가 높을수록 Exchange Server를 실행하는 서버의 성능은 더욱 향상됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  • Write-Back 캐시를 사용하도록 설정합니다.

Exchange 서버 하드 디스크를 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 188589, "Exchange DB and caching hard disks and controllers"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=188589)를 참조하십시오.


타사 소프트웨어
Microsoft Exchange Server Analyzer - 문서 >

최근 수정된 항목: 2005-11-18

이 섹션의 문서에서는 Microsoft® Exchange Server Analyzer Tool이 타사 소프트웨어에 관해 평가하는 항목에 대한 자세한 내용을 설명합니다. 또한 Exchange Server Analyzer가 발견한 타사 소프트웨어 관련 오류, 경고 및 기본 구성이 아닌 문제를 해결하기 위한 작업에 대해 설명합니다.


바이러스 백신 폴더 제외가 구성되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Symantec AntiVirus Corporate Edition(Symantec AV)이 Exchange Server에 설치되어 있고 RealTime Protection(RTP)이 사용 가능한지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Storages\Filesystem\RealTimeScan

Exchange Server Analyzer는 HaveExceptionDirs 레지스트리 값이 0으로 설정되어 있는 경우 오류를 표시합니다. HaveExceptionDirs 레지스트리 값 0은 폴더 제외를 사용할 수 없음을 나타냅니다.

폴더 제외는 실시간 바이러스 백신 검색 중 특정 폴더가 검색되지 않도록 합니다. Exchange Server에서 폴더 제외를 사용할 수 있게 설정하지 않으면 다음과 같은 문제가 발생합니다.

  • Symantec AV RTP는 일상적인 프로그램 작동 중에 액세스하는 바이러스에 감염되지 않은 특정 파일에서 바이러스가 감지되었다는 잘못된 보고서를 제공할 수도 있습니다.

  • Symantec AV RTP는 회사 보안 정책에 따라 Exchange Server에서 실행하도록 허용한 소프트웨어에 감염된 파일이 있다고 잘못 보고할 수 있습니다.

  • Symantec AV RTP는 Exchange Server 디렉터리 구조를 검색하고 바이러스 감지를 부정확하게 하거나 Exchange 서버에 예기치 않은 동작을 발생시키거나 Exchange Server 데이터베이스에 손상을 줄 수 있습니다.

중요:
Exchange Server 데이터베이스, 로그, 임시 파일, 인터넷 정보 서비스(IIS) 시스템 파일 또는 설치 가능한 파일 시스템(IFS) 드라이브(드라이브 M)에 대한 파일 기반 검색 소프트웨어를 실행하지 않아야 합니다. 이러한 파일이 포함된 폴더를 검색하지 않도록 바이러스 백신 소프트웨어를 구성합니다.

Exchange Server 컴퓨터의 운영 체제와 Exchange Server 프로그램 파일(Exchsrvr\Bin 폴더)에 대한 파일 기반 바이러스 백신 소프트웨어를 실행할 수 있습니다. 하지만 다음 파일과 폴더에 대한 파일 기반 바이러스 백신 소프트웨어를 실행하지 마십시오.

  • Exchange Server 데이터베이스(.mdb 및 .stm 파일) 및 트랜잭션 로그(.log) 파일(기본 위치: \Exchsrvr\MDBData)

  • Exchange Server .mta 파일(기본 위치: \Exchsrvr\Mtadata)

  • Exchange Server 메시지 추적 로그 파일(기본 위치: \Exchsrvr\Server_Name.log)

  • 가상 서버 파일(기본 위치: \Exchsrvr\Mailroot)

  • 사이트 복제 서비스(SRS) 파일(기본 위치: \Exchsrvr\Srsdata)

  • 인터넷 정보 서비스(IIS) 시스템 파일(기본 위치: \%SystemRoot%\System32\Inetsrv)

  • 인터넷 메일 커넥터 파일(기본 위치: \Exchsrvr\IMCData)

  • 메시지 변환에 사용되는 스트리밍 임시 파일을 저장하는 데 사용되는 작업 폴더. 기본적으로 이 작업 폴더는 \Exchsrvr\MDBData에 있습니다.

  • Eseutil.exe 같은 오프라인 유지 관리 유틸리티에서 사용되는 임시 폴더. 기본적으로 이 폴더는 .exe 파일이 실행되는 위치지만 유틸리티를 실행하면 이 위치를 구성할 수 있습니다.

다음 폴더에 대한 파일 기반 검색을 실행할 수 있습니다.

  • Exchsrvr\Address

  • Exchsrvr\Bin

  • Exchsrvr\Exchweb

  • Exchsrvr\Res

  • Exchsrvr\Schema

Symantec AntiVirus Corporate Edition의 실시간 검색에 대한 제외를 구성하는 방법에 대한 자세한 내용은 Symantec 바이러스 백신 웹 사이트(http://www.symantec.com)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결할 수 없을 수도 있습니다.

전자 메일로 전파되는 바이러스나 웜으로부터 Exchange 환경을 보호하는 방법에 대한 자세한 내용은 Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Antigen에서 공용 폴더 복제 메시지를 검색 중입니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-03-13

Microsoft® Exchange Server Analyzer Tool은 각 Exchange 서버에 공용 폴더 저장소가 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. InformationStore 개체가 msExchPublicMDB 개체 클래스의 개체인 경우 해당 서버는 공용 폴더 저장소를 호스팅합니다.

Microsoft® Exchange Server Analyzer Tool은 ANTIGENVSAPI.DLL의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. ANTIGENVSAPI.DLL의 Version 키 값이 1517 이상일 경우 Exchange Server에 Sybari Antigen for Microsoft Exchange 버전 8.0 SR3 이상 버전이 설치되어 있음을 나타냅니다.

마지막으로 Exchange Server Analyzer는 다음 레지스트리 분기를 쿼리하여 DoNotScanIPMReplicationMessages 키가 있고 값이 0보다 크지 않은지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\DoNotScanIPMReplicationMessages

DoNotScanIPMReplicationMessages 키 값은 설치된 Sybari Antigen에서 Exchange Server 공용 폴더 복제 메시지를 검색하거나 제거하는지 확인합니다. DoNotScanIPMReplicationMessages 키 값이 1보다 작으면 Antigen이 winmail.dat 파일에서 바이러스를 검색함을 의미합니다. Exchange Server는 서버 간의 공용 폴더 복제를 더 쉽게 하는 것을 비롯하여 여러 가지 목적에 Winmail.dat 파일을 사용합니다. Antigen에서 이 Winmail.dat 파일 중 하나를 수정하면 공용 폴더 복제 프로세스가 실패합니다.

Exchange Server Analyzer는 다음 조건이 있을 경우 오류를 표시합니다.

  • Exchange Server에서 하나 이상의 공용 폴더 저장소를 호스트합니다.

  • Sybari Antigen 빌드 1517 이상 버전이 서버에 설치되어 있습니다.

  • DoNotScanIPMReplicationMessages 키가 없거나, 있지만 0보다 큰 값을 갖고 있지 않습니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\Sybari Software\Antigen for Exchange를 탐색합니다.

  3. DoNotScanIPMReplicationMessages.subkey가 오른쪽 창에 있으면 이를 두 번 클릭하고 값을 1로 설정합니다.

  4. DoNotScanIPMReplicationMessages.subkey가 없으면 오른쪽 창에서 마우스 오른쪽 단추로 클릭하여 새 DWORD 값으로 만듭니다.

  5. DoNotScanIPMReplicationMessages 값을 1로 설정합니다.

    참고:
    공용 폴더 복제를 통해 바이러스가 복제된 경우 이 새 레지스트리 키를 사용하더라도 Antigen은 실시간 검색 작업에서 바이러스를 계속 검색합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)


CA eTrust: EML/LOG/EDB/STM/DAT 파일이 실시간 파일 제외 목록에 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Computer Associates의 eTrust Antivirus에서 수행되는 실시간 파일 수준 바이러스 검색에서 제외된 파일 확장명 목록을 확인합니다.

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeExtList

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeExtList

Exchange Server Analyzer는 szExcludeExtList 값에 Exchange 데이터 파일 형식(.eml, .log, .edb, .stm 또는 .dat)에 해당하는 파일 확장명이 포함되어 있지 않을 경우 경고를 표시합니다.

eTrust Antivirus는 파일 수준의 바이러스 백신 프로그램입니다. Exchange Server 컴퓨터에 설치되어 있는 eTrust Antivirus의 버전을 확인하려면 다음을 수행합니다.

  1. 시작 | 프로그램 | eTrust Antivirus를 탐색한 다음 eTrust Antivirus를 클릭하여 응용 프로그램을 시작합니다.

  2. eTrust Antivirus 응용 프로그램 메뉴에서 Help를 클릭한 다음 About eTrust Antivirus를 클릭합니다.

  3. Product Version 필드를 조사하여 eTrust Antivirus의 버전을 확인합니다.

Exchange Server 컴퓨터에서 파일 수준의 검색 프로그램을 사용하면 다음과 같은 문제가 발생할 수 있습니다.

  • 파일 수준의 검색 프로그램은 사용할 때나 예약한 간격으로 파일을 검색하는데, Exchange가 Exchange 로그 또는 데이터베이스 파일을 사용하는 동안 해당 파일을 잠그거나 격리합니다. 그 결과 Exchange Server에서 심각한 장애가 발생할 수 있으며 데이터베이스 오류가 발생할 수도 있습니다.

  • Exchange IFS(Installable File System)가 표시하는 드라이브(일반적으로 드라이브 M)를 파일 수준 검색 소프트웨어를 사용하여 검색하면 더 많은 문제가 발생할 수 있습니다.

사용 중인 파일 수준 바이러스 백신 프로그램에 관계없이 다음 파일과 폴더는 항상 파일 수준의 검색 프로그램에서 제외해야 합니다.

  • .eml, .edb, .stm, .log, .dat 및 .chk 파일

  • IFS가 표시하는 Exchange Server 드라이브. 기본적으로 이것은 M 드라이브입니다.

  • Exchange 데이터베이스 및 로그 파일. 기본적으로 이러한 파일은 Exchsrvr\Mdbdata 폴더에 있습니다.

  • Exchsrvr\Mtadata 폴더에 있는 Exchange MTA 파일

  • Exchsrvr\server_name.log 파일 같은 추가 로그 파일

  • Exchsrvr\Mailroot 가상 서버 폴더

  • 메시지 변환에 사용되는 스트리밍 임시 파일을 저장하는 데 사용되는 작업 폴더. 기본적으로 이 폴더는 \Exchsrvr\MDBData에 있지만 사용자가 해당 위치를 구성할 수 있습니다.

  • Eseutil.exe 같은 오프라인 유지 관리 도구에서 사용되는 임시 폴더. 기본적으로 이 폴더는 .exe 파일이 실행되는 위치이지만 도구를 실행하면 사용자가 해당 위치를 구성할 수 있습니다.

  • Exchsrvr\Srsdata 폴더에 있는 사이트 복제 서비스(SRS) 파일

  • %SystemRoot%\System32\Inetsrv 폴더에 있는 Microsoft Internet Information Service(IIS) 시스템 파일

  • %SystemRoot%\IIS Temporary Compressed Files 폴더에 있는 IIS 작업 파일

이 경고를 해결하려면 다음을 수행합니다.

  1. eTrust Antivirus 사용자 인터페이스를 사용하여 파일 수준 바이러스 검색에서 위에 나열된 폴더와 파일을 제외시킵니다.

  2. Exchange Server 컴퓨터에서 eTrust Antivirus를 사용하는 방법에 대한 최신 정보를 보려면 CA eTrust Antivirus 웹 사이트(http://www3.ca.com/Solutions/Product.asp?ID=156)를 방문하십시오.

    참고:
    웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

Exchange Server에서의 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.

IFS 드라이브 검색 시 발생할 수 있는 문제에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 298924, "XADM: Exchange 2000 M 드라이브를 백업하거나 검색하지 않아야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: 데이터베이스를 탑재하려고 하면 "C1041737" 오류와 이벤트 ID 470 메시지가 표시될 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: 일정 항목이 사용자 폴더에서 사라진다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: 수동 작업 검색에서 Exchange 데이터 드라이브가 제외되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Computer Associates의 eTrust Antivirus에서 수동으로 실행되는 파일 수준의 바이러스 백신 프로그램에서 제외된 디렉터리를 확인합니다.

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

또한 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스에서 Exchange 시스템 데이터 파일 위치에 해당하는 저장소 그룹 특성인 MsExchESEParamSystemPath 특성 값도 읽습니다.

Exchange Server Analyzer는 szExcludeDirs의 값에 Exchange 시스템 데이터 파일 위치에 해당하는 경로가 포함되어 있지 않으면 경고를 표시합니다.

eTrust Antivirus는 파일 수준의 바이러스 백신 프로그램입니다. Exchange Server 컴퓨터에 설치되어 있는 eTrust Antivirus의 버전을 확인하려면 다음을 수행합니다.

  1. 시작 | 프로그램 | eTrust Antivirus를 탐색한 다음 eTrust Antivirus를 클릭하여 응용 프로그램을 시작합니다.

  2. eTrust Antivirus 응용 프로그램 메뉴에서 Help를 클릭한 다음 About eTrust Antivirus를 클릭합니다.

  3. Product Version 필드를 조사하여 eTrust Antivirus의 버전을 확인합니다.

Exchange Server 컴퓨터에서 파일 수준의 검색 프로그램을 사용하면 다음과 같은 문제가 발생할 수 있습니다.

  • 파일 수준의 검색 프로그램은 사용될 때 또는 예약한 간격으로 파일을 검색하며 Exchange에서 Exchange 로그나 데이터베이스 파일을 사용하는 동안 해당 파일을 잠그거나 격리합니다. 그렇게 되면 Exchange Server에 심각한 장애가 발생할 수 있으며 데이터베이스 오류가 발생할 수도 있습니다.

  • Exchange IFS(Installable File System)가 표시하는 드라이브(일반적으로 드라이브 M)를 파일 수준 검색 소프트웨어를 사용하여 검색하면 더 많은 문제가 발생할 수 있습니다.

사용 중인 파일 수준의 바이러스 백신 프로그램에 관계없이 다음 파일과 폴더는 항상 파일 수준의 검색 프로그램에서 제외해야 합니다.

  • .eml, .edb, .stm, .log, .dat 및 .chk 파일

  • IFS가 표시하는 Exchange Server 드라이브. 기본적으로 이것은 M 드라이브입니다.

  • Exchange 데이터베이스 및 로그 파일 기본적으로 이러한 파일은 Exchsrvr\Mdbdata 폴더에 있습니다.

  • Exchsrvr\Mtadata 폴더에 있는 Exchange MTA 파일

  • Exchsrvr\server_name.log 파일 같은 추가 로그 파일

  • Exchsrvr\Mailroot 가상 서버 폴더

  • 메시지 변환에 사용되는 스트리밍 임시 파일을 저장하는 데 사용되는 작업 폴더. 기본적으로 이 폴더는 \Exchsrvr\MDBData에 있지만 사용자가 해당 위치를 구성할 수 있습니다.

  • Eseutil.exe 같은 오프라인 유지 관리 도구에서 사용되는 임시 폴더. 기본적으로 이 폴더는 .exe 파일이 실행되는 위치이지만 도구를 실행하면 사용자가 이 위치를 구성할 수 있습니다.

  • Exchsrvr\Srsdata 폴더에 있는 사이트 복제 서비스(SRS) 파일

  • %SystemRoot%\System32\Inetsrv 폴더에 있는 Microsoft Internet Information Service(IIS) 시스템 파일

  • %SystemRoot%\IIS Temporary Compressed Files 폴더에 있는 IIS 작업 파일

이 경고를 해결하려면 다음을 수행합니다.

  1. eTrust Antivirus 사용자 인터페이스를 사용하여 파일 수준의 바이러스 검색에서 위에 나열된 폴더와 파일을 제외시킵니다.

  2. Exchange Server 컴퓨터에서 eTrust Antivirus를 사용하는 방법에 대한 최신 정보를 보려면 CA eTrust Antivirus 웹 사이트(http://www3.ca.com/Solutions/Product.asp?ID=156)를 방문하십시오.

    참고:
    웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.

IFS 드라이브 검색 시 발생할 수 있는 문제에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 298924, "XADM: Exchange 2000 M 드라이브를 백업하거나 검색하지 않아야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: 데이터베이스를 탑재하려고 하면 "C1041737" 오류와 이벤트 470 메시지가 표시될 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: 일정 항목이 사용자 폴더에서 사라진다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: 실시간 검색에서 Exchange 데이터 드라이브가 제외되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Computer Associates의 eTrust Antivirus에서 수행되는 실시간 파일 수준 바이러스 검색에서 제외된 디렉터리 목록을 확인합니다.

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

또한 Microsoft® Exchange Server Analyzer Tool은 각 저장소 그룹의 MsExchESEParamSystemPath 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성은 Exchange 데이터 파일의 경로를 나타냅니다.

Exchange Server Analyzer는 szExcludeDirs의 값에 Exchange 시스템 데이터 파일 위치에 해당하는 경로가 포함되어 있지 않으면 경고를 표시합니다.

eTrust Antivirus는 파일 수준의 바이러스 검색 프로그램입니다. Exchange Server 컴퓨터에 설치되어 있는 eTrust Antivirus의 버전을 확인하려면 다음을 수행합니다.

  1. 시작 | 프로그램 | eTrust Antivirus를 탐색한 다음 eTrust Antivirus를 클릭하여 응용 프로그램을 시작합니다.

  2. eTrust Antivirus 응용 프로그램 메뉴에서 Help를 클릭한 다음 About eTrust Antivirus를 클릭합니다.

  3. Product Version 필드를 검사하여 eTrust Antivirus의 버전을 확인합니다.

Exchange Server 컴퓨터에서 파일 수준의 검색 프로그램을 사용하면 다음과 같은 문제가 발생할 수 있습니다.

  • 파일 수준의 검색 프로그램은 사용할 때나 예약한 간격으로 파일을 검색하는데, Exchange가 Exchange 로그 또는 데이터베이스 파일을 사용하는 동안 해당 파일을 잠그거나 격리합니다. 그 결과 Exchange Server에서 심각한 장애가 발생할 수 있으며 데이터베이스 오류가 발생할 수도 있습니다.

  • Exchange IFS(Installable File System)가 표시하는 드라이브(일반적으로 드라이브 M)를 파일 수준 검색 소프트웨어를 사용하여 검색하면 더 많은 문제가 발생할 수 있습니다.

사용 중인 파일 수준의 바이러스 백신 프로그램에 관계없이 다음 파일과 폴더는 파일 수준의 검색 프로그램에서 항상 제외해야 합니다.

  • .eml, .edb, .stm, .log, .dat 및 .chk 파일

  • IFS가 표시하는 Exchange Server 드라이브. 기본적으로 이것은 M 드라이브입니다.

  • Exchange 데이터베이스 및 로그 파일. 기본적으로 이러한 파일은 Exchsrvr\Mdbdata 폴더에 있습니다.

  • Exchsrvr\Mtadata 폴더에 있는 Exchange MTA 파일

  • Exchsrvr\server_name.log 파일 같은 추가 로그 파일

  • Exchsrvr\Mailroot 가상 서버 폴더

  • 메시지 변환에 사용되는 스트리밍 임시 파일을 저장하는 데 사용되는 작업 폴더. 기본적으로 이 폴더는 \Exchsrvr\MDBData에 있지만 사용자가 해당 위치를 구성할 수 있습니다.

  • Eseutil.exe 같은 오프라인 유지 관리 도구에서 사용되는 임시 폴더. 기본적으로 이 폴더는 .exe 파일이 실행되는 위치이지만 도구를 실행하면 사용자가 해당 위치를 구성할 수 있습니다.

  • Exchsrvr\Srsdata 폴더에 있는 사이트 복제 서비스(SRS) 파일

  • %SystemRoot%\System32\Inetsrv 폴더에 있는 Microsoft Internet Information Service(IIS) 시스템 파일

  • %SystemRoot%\IIS Temporary Compressed Files 폴더에 있는 IIS 작업 파일

이 경고를 해결하려면 다음을 수행합니다.

  1. eTrust Antivirus 사용자 인터페이스를 사용하여 파일 수준 바이러스 검색에서 위에 나열된 폴더와 파일을 제외시킵니다.

  2. Exchange Server 컴퓨터에서 eTrust Antivirus를 사용하는 방법에 대한 최신 정보를 보려면 CA eTrust Antivirus 웹 사이트(http://www3.ca.com/Solutions/Product.asp?ID=156)를 방문하십시오.

    참고:
    웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

Exchange Server에서 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.

IFS 드라이브 검색 시 발생할 수 있는 문제에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 298924, "XADM: Exchange 2000 M 드라이브를 백업하거나 검색하지 않아야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: 데이터베이스를 탑재하려고 하면 "C1041737" 오류와 이벤트 470 메시지가 표시될 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: 일정 항목이 사용자 폴더에서 사라진다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: 수동 작업 검색에서 Exchange IFS 경로가 제외되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Computer Associates의 eTrust Antivirus에서 수동으로 실행되는 파일 수준의 바이러스 백신 프로그램에서 제외된 디렉터리를 확인합니다.

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer는 Exchange IFS(Installable File System) 드라이브를 나타내는 드라이브 문자를 가져올 때도 다음 레지스트리 항목을 읽습니다.

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Exchange2000 Server에서는 기본 드라이브 문자가 M입니다. Exchange Server2003에서는 기본적으로 IFS 드라이브가 해제되어 있습니다.

Exchange Server Analyzer는 szExcludeDirs의 값에 IFS 드라이브에 해당하는 경로가 포함되어 있지 않을 경우 경고를 표시합니다.

eTrust Antivirus는 파일 수준의 바이러스 백신 프로그램입니다. Exchange Server 컴퓨터에 설치되어 있는 eTrust Antivirus의 버전을 확인하려면 다음을 수행합니다.

  1. 시작 | 프로그램 | eTrust Antivirus를 탐색한 다음 eTrust Antivirus를 클릭하여 응용 프로그램을 시작합니다.

  2. eTrust Antivirus 응용 프로그램 메뉴에서 Help를 클릭한 다음 About eTrust Antivirus를 클릭합니다.

  3. Product Version 필드를 검사하여 eTrust Antivirus의 버전을 확인합니다.

Exchange Server 컴퓨터에서 파일 수준의 검색 프로그램을 사용하면 다음과 같은 문제가 발생할 수 있습니다.

  • 파일 수준의 검색 프로그램은 사용될 때 또는 예약한 간격으로 파일을 검색하며 Exchange에서 Exchange 로그나 데이터베이스 파일을 사용하는 동안 해당 파일을 잠그거나 격리합니다. 그렇게 되면 Exchange Server에 심각한 장애가 발생할 수 있으며 데이터베이스 오류가 발생할 수도 있습니다.

  • IFS가 표시하는 드라이브(일반적으로 M 드라이브)를 파일 수준 검색 소프트웨어를 사용하여 검색하면 더 많은 문제가 발생할 수 있습니다.

사용 중인 파일 수준 바이러스 백신 프로그램에 관계없이 다음 파일과 폴더는 항상 파일 수준의 검색 프로그램에서 제외해야 합니다.

  • .eml, .edb, .stm, .log, .dat 및 .chk 파일

  • IFS가 표시하는 Exchange Server 드라이브. 기본적으로 이것은 M 드라이브입니다.

  • Exchange 데이터베이스 및 로그 파일. 기본적으로 이러한 파일은 Exchsrvr\Mdbdata 폴더에 있습니다.

  • Exchsrvr\Mtadata 폴더에 있는 Exchange MTA 파일

  • Exchsrvr\server_name.log 파일 같은 추가 로그 파일

  • Exchsrvr\Mailroot 가상 서버 폴더

  • 메시지 변환에 사용되는 스트리밍 임시 파일을 저장하는 데 사용되는 작업 폴더. 기본적으로 이 폴더는 \Exchsrvr\MDBData에 있지만 사용자가 해당 위치를 구성할 수 있습니다.

  • Eseutil.exe 같은 오프라인 유지 관리 도구에서 사용되는 임시 폴더. 기본적으로 이 폴더는 .exe 파일이 실행되는 위치이지만 도구를 실행하면 사용자가 해당 위치를 구성할 수 있습니다.

  • Exchsrvr\Srsdata 폴더에 있는 사이트 복제 서비스(SRS) 파일

  • %SystemRoot%\System32\Inetsrv 폴더에 있는 Microsoft Internet Information Service(IIS) 시스템 파일

  • %SystemRoot%\IIS Temporary Compressed Files 폴더에 있는 IIS 작업 파일

이 경고를 해결하려면 다음을 수행합니다.

  1. eTrust Antivirus 사용자 인터페이스를 사용하여 파일 수준의 바이러스 검색에서 위에 나열된 폴더와 파일을 제외시킵니다.

  2. Exchange Server 컴퓨터에서 eTrust Antivirus를 사용하는 방법에 대한 최신 정보를 보려면 Computer Associates eTrust Antivirus 웹 사이트(http://www3.ca.com/Solutions/Product.asp?ID=156)를 방문하십시오.

    참고:
    웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.

IFS 드라이브 검색 시 발생할 수 있는 문제에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 298924, "XADM: Exchange 2000 M 드라이브를 백업하거나 검색하지 않아야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: 데이터베이스를 탑재하려고 하면 "C1041737" 오류와 이벤트 470 메시지가 표시될 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: 일정 항목이 사용자 폴더에서 사라진다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: 실시간 검색에서 Exchange IFS 경로가 제외되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Computer Associates의 eTrust Antivirus에서 수행되는 파일 수준 바이러스 실시간 검색에서 제외된 디렉터리 목록을 확보할 때 다음 레지스트리 항목을 읽습니다.

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server Analyzer는 Exchange IFS(Installable File System) 드라이브를 나타내는 드라이브 문자를 가져올 때도 다음 레지스트리 항목을 읽습니다.

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Exchange 2000 Server에서 기본 드라이브 문자는 M입니다. Exchange Server 2003에서 IFS 드라이브는 기본적으로 해제됩니다.

Exchange Server Analyzer는 szExcludeDirs의 값에 IFS 드라이브에 해당하는 경로가 포함되어 있지 않을 경우 경고를 표시합니다.

eTrust Antivirus는 파일 수준의 바이러스 검색 프로그램입니다. Exchange Server 컴퓨터에 설치되어 있는 eTrust Antivirus의 버전을 확인하려면 다음을 수행합니다.

  1. 시작 | 프로그램 | eTrust Antivirus를 탐색한 다음 eTrust Antivirus를 클릭하여 응용 프로그램을 시작합니다.

  2. eTrust Antivirus 응용 프로그램 메뉴에서 Help를 클릭한 다음 About eTrust Antivirus를 클릭합니다.

  3. Product Version 필드를 검사하여 eTrust Antivirus의 버전을 확인합니다.

Exchange Server 컴퓨터에서 파일 수준의 검색 프로그램을 사용하면 다음과 같은 문제가 발생할 수 있습니다.

  • 파일 수준의 검색 프로그램은 사용할 때나 예약한 간격으로 파일을 검색하는데, Exchange가 Exchange 로그 또는 데이터베이스 파일을 사용하는 동안 해당 파일을 잠그거나 격리합니다. 그 결과 Exchange Server에서 심각한 장애가 발생할 수 있으며 데이터베이스 오류가 발생할 수도 있습니다.

  • IFS가 표시하는 드라이브(일반적으로 M 드라이브)를 파일 수준 검색 소프트웨어를 사용하여 검색하면 더 많은 문제가 발생할 수 있습니다.

사용 중인 파일 수준 바이러스 백신 프로그램에 관계없이 다음 파일과 폴더는 항상 파일 수준의 검색 프로그램에서 제외해야 합니다.

  • .eml, .edb, .stm, .log, .dat 및 .chk 파일

  • IFS가 표시하는 Exchange Server 드라이브. 기본적으로 이것은 M 드라이브입니다.

  • Exchange 데이터베이스 및 로그 파일. 기본적으로 이러한 파일은 Exchsrvr\Mdbdata 폴더에 있습니다.

  • Exchsrvr\Mtadata 폴더에 있는 Exchange MTA 파일

  • Exchsrvr\server_name.log 파일 같은 추가 로그 파일

  • Exchsrvr\Mailroot 가상 서버 폴더

  • 메시지 변환에 사용되는 스트리밍 임시 파일을 저장하는 데 사용되는 작업 폴더. 기본적으로 이 폴더는 \Exchsrvr\MDBData에 있지만 사용자가 해당 위치를 구성할 수 있습니다.

  • Eseutil.exe 같은 오프라인 유지 관리 도구에서 사용되는 임시 폴더. 기본적으로 이 폴더는 .exe 파일이 실행되는 위치이지만 도구를 실행하면 사용자가 해당 위치를 구성할 수 있습니다.

  • Exchsrvr\Srsdata 폴더에 있는 사이트 복제 서비스(SRS) 파일

  • %SystemRoot%\System32\Inetsrv 폴더에 있는 Microsoft Internet Information Service(IIS) 시스템 파일

  • %SystemRoot%\IIS Temporary Compressed Files 폴더에 있는 IIS 작업 파일

이 경고를 해결하려면 다음을 수행합니다.

  1. eTrust Antivirus 사용자 인터페이스를 사용하여 파일 수준 바이러스 검색에서 위에 나열된 폴더와 파일을 제외시킵니다.

  2. Exchange Server 컴퓨터에서 eTrust Antivirus를 사용하는 방법에 대한 최신 정보를 보려면 CA eTrust Antivirus 웹 사이트(http://www3.ca.com/Solutions/Product.asp?ID=156)를 방문하십시오.

    참고:
    웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

Exchange Server에서 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.

IFS 드라이브 검색 시 발생할 수 있는 문제에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 298924, "XADM: Exchange 2000 M 드라이브를 백업하거나 검색하지 않아야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: 데이터베이스를 탑재하려고 하면 "C1041737" 오류와 이벤트 470 메시지가 표시될 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: 일정 항목이 사용자 폴더에서 사라진다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: 실시간 검색이 확장명에 관계없이 모든 파일을 검색하도록 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-04-21

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Computer Associates의 eTrust Antivirus에서 수행되는 실시간 파일 수준 바이러스 검색에서 제외된 이름 확장명 목록을 확보합니다.

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\dwFileFilterType

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\dwFileFilterType

Exchange Server Analyzer는 dwFileFilterType이 파일 이름 확장명에 관계없이 모든 파일을 검색하도록 구성된 경우 경고를 표시합니다.

eTrust Antivirus는 파일 수준의 바이러스 백신 프로그램입니다. Exchange Server 컴퓨터에 설치되어 있는 eTrust Antivirus의 버전을 확인하려면 다음을 수행합니다.

  1. 시작 | 프로그램 | eTrust Antivirus를 탐색한 다음 eTrust Antivirus를 클릭하여 응용 프로그램을 시작합니다.

  2. eTrust Antivirus 응용 프로그램 메뉴에서 Help를 클릭한 다음 About eTrust Antivirus를 클릭합니다.

  3. Product Version 필드를 검토하여 eTrust Antivirus의 버전을 확인합니다.

Exchange Server 컴퓨터에서 파일 수준의 검색 프로그램을 사용하면 다음과 같은 문제가 발생할 수 있습니다.

  • 파일 수준의 검색 프로그램은 사용할 때나 예약한 간격으로 파일을 검색하는데, Exchange가 Exchange 로그 또는 데이터베이스 파일을 사용하는 동안 해당 파일을 잠그거나 격리합니다. 그 결과 Exchange Server에서 심각한 장애가 발생할 수 있으며 데이터베이스 오류가 발생할 수도 있습니다.

  • Exchange IFS(Installable File System)가 표시하는 드라이브(일반적으로 드라이브 M)를 파일 수준 검색 소프트웨어를 사용하여 검색하면 더 많은 문제가 발생할 수 있습니다.

사용 중인 파일 수준 바이러스 백신 프로그램에 관계없이 다음 파일과 폴더는 항상 파일 수준의 검색 프로그램에서 제외해야 합니다.

  • .eml, .edb, .stm, .log, .dat 및 .chk 파일

  • IFS가 표시하는 Exchange Server 드라이브. 기본적으로 이것은 M 드라이브입니다.

  • Exchange 데이터베이스 및 로그 파일. 기본적으로 이러한 파일은 Exchsrvr\Mdbdata 폴더에 있습니다.

  • Exchsrvr\Mtadata 폴더에 있는 Exchange MTA 파일

  • Exchsrvr\server_name.log 파일 같은 추가 로그 파일

  • Exchsrvr\Mailroot 가상 서버 폴더

  • 메시지 변환에 사용되는 스트리밍 임시 파일을 저장하는 데 사용되는 작업 폴더. 기본적으로 이 폴더는 \Exchsrvr\MDBData에 있지만 사용자가 해당 위치를 구성할 수 있습니다.

  • Eseutil.exe 같은 오프라인 유지 관리 도구에서 사용되는 임시 폴더. 기본적으로 이 폴더는 .exe 파일이 실행되는 위치이지만 도구를 실행하면 사용자가 해당 위치를 구성할 수 있습니다.

  • Exchsrvr\Srsdata 폴더에 있는 사이트 복제 서비스(SRS) 파일

  • %SystemRoot%\System32\Inetsrv 폴더에 있는 Microsoft Internet Information Service(IIS) 시스템 파일

  • %SystemRoot%\IIS Temporary Compressed Files 폴더에 있는 IIS 작업 파일

이 경고를 해결하려면 다음을 수행합니다.

  1. eTrust Antivirus 사용자 인터페이스를 사용하여 파일 수준 바이러스 검색에서 나열된 폴더와 파일을 제외시킵니다.

  2. Exchange Server 컴퓨터에서 eTrust Antivirus를 사용하는 방법에 대한 최신 정보를 보려면 CA eTrust Antivirus 웹 사이트(http://www3.ca.com/Solutions/Product.asp?ID=156)를 방문하십시오.

    참고:
    웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

Exchange Server에서의 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Exchange 2000용 바이러스 백신 솔루션에 대한 Microsoft의 입장"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.

IFS 드라이브 검색 시 발생할 수 있는 문제에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 298924, "XADM: Exchange 2000 M 드라이브를 백업하거나 검색하지 않아야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: 데이터베이스를 탑재하려고 하면 "C1041737" 오류와 이벤트 470 메시지가 표시될 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: 일정 항목이 사용자 폴더에서 사라진다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: 수동 작업 검색 대상에서 저장소 그룹 드라이브가 제외되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Computer Associates의 eTrust Antivirus에서 수동으로 실행되는 파일 수준의 바이러스 백신 프로그램에서 제외된 디렉터리를 확인합니다.

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer는 Active Directory® 디렉터리 서비스의 MsExchESEParamSystemPath 특성 값도 읽습니다. 이 특성은 Exchange 시스템 로그 파일 위치에 해당하는 저장소 그룹 특성입니다.

Exchange Server Analyzer는 szExcludeDirs의 값에 Exchange 시스템 로그 파일 위치에 해당하는 경로가 포함되어 있지 않을 경우 경고를 표시합니다.

eTrust Antivirus는 파일 수준의 바이러스 백신 프로그램입니다. Exchange Server 컴퓨터에 설치되어 있는 eTrust Antivirus의 버전을 확인하려면 다음을 수행합니다.

  1. 시작 | 프로그램 | eTrust Antivirus를 탐색한 다음 eTrust Antivirus를 클릭하여 응용 프로그램을 시작합니다.

  2. eTrust Antivirus 응용 프로그램 메뉴에서 Help를 클릭한 다음 About eTrust Antivirus를 클릭합니다.

  3. Product Version 필드를 검사하여 eTrust Antivirus의 버전을 확인합니다.

Exchange Server 컴퓨터에서 파일 수준의 검색 프로그램을 사용하면 다음과 같은 문제가 발생할 수 있습니다.

  • 파일 수준의 검색 프로그램은 프로그램 사용 시 또는 예약된 간격으로 파일을 검색하며, Exchange에서 Exchange 로그 또는 데이터베이스 파일을 사용하는 동안 해당 파일을 잠그거나 격리할 수도 있습니다. 그 결과 Exchange Server에서 심각한 장애가 발생할 수 있으며 데이터베이스 오류가 발생할 수도 있습니다.

  • Exchange IFS(Installable File System)가 표시하는 드라이브(일반적으로 드라이브 M)를 파일 수준 검색 소프트웨어를 사용하여 검색하면 더 많은 문제가 발생할 수 있습니다.

사용 중인 파일 수준 바이러스 백신 프로그램에 관계없이 다음 파일과 폴더는 파일 수준의 검색 프로그램에서 항상 제외해야 합니다.

  • .eml, .edb, .stm, .log, .dat 및 .chk 파일

  • IFS가 표시하는 Exchange Server 드라이브. 기본적으로 이것은 M 드라이브입니다.

  • Exchange 데이터베이스 및 로그 파일 기본적으로 이러한 파일은 Exchsrvr\Mdbdata 폴더에 있습니다.

  • Exchsrvr\Mtadata 폴더에 있는 Exchange MTA 파일

  • Exchsrvr\server_name.log 파일 같은 추가 로그 파일

  • Exchsrvr\Mailroot 가상 서버 폴더

  • 메시지 변환에 사용되는 스트리밍 임시 파일을 저장하는 데 사용되는 작업 폴더. 기본적으로 이 폴더는 \Exchsrvr\MDBData에 있지만 사용자가 해당 위치를 구성할 수 있습니다.

  • Eseutil.exe 같은 오프라인 유지 관리 도구에서 사용되는 임시 폴더. 기본적으로 이 폴더는 .exe 파일이 실행되는 위치이지만 도구를 실행하면 사용자가 해당 위치를 구성할 수 있습니다.

  • Exchsrvr\Srsdata 폴더에 있는 사이트 복제 서비스(SRS) 파일

  • %SystemRoot%\System32\Inetsrv 폴더에 있는 Microsoft Internet Information Service(IIS) 시스템 파일

  • %SystemRoot%\IIS Temporary Compressed Files 폴더에 있는 IIS 작업 파일

이 경고를 해결하려면 다음을 수행합니다.

  1. eTrust Antivirus 사용자 인터페이스를 사용하여 파일 수준 바이러스 검색에서 위에 나열된 폴더와 파일을 제외시킵니다.

  2. Exchange Server 컴퓨터에서 eTrust Antivirus를 사용하는 방법에 대한 최신 정보를 보려면 Computer Associates eTrust Antivirus 웹 사이트(http://www3.ca.com/Solutions/Product.asp?ID=156)를 방문하십시오.

    참고:
    웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

Exchange Server에서 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

  • Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.

IFS 드라이브 검색 시 발생할 수 있는 문제에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 298924, "XADM: Exchange 2000 M 드라이브를 백업하거나 검색하지 않아야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: 데이터베이스를 탑재하려고 하면 "C1041737" 오류와 이벤트 470 메시지가 표시될 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: 일정 항목이 사용자 폴더에서 사라진다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: 실시간 검색에서 저장소 그룹 드라이브가 제외되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Computer Associates의 eTrust Antivirus에서 수행되는 실시간 파일 수준 바이러스 검색에서 제외된 디렉터리 목록을 확인합니다.

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

또한 Exchange Server Analyzer는 Exchange 시스템 데이터 파일 위치에 해당하는 저장소 그룹 특성인 MsExchESEParamSystemPath 특성 값을 Active Directory® 디렉터리 서비스에서 쿼리합니다.

Exchange Server Analyzer는 szExcludeDirs의 값에 Exchange 시스템 데이터 파일 위치에 해당하는 경로가 포함되어 있지 않으면 경고를 표시합니다.

eTrust Antivirus는 파일 수준의 바이러스 백신 프로그램입니다. Exchange Server 컴퓨터에 설치되어 있는 eTrust Antivirus의 버전을 확인하려면 다음을 수행합니다.

  1. 시작 | 프로그램 | eTrust Antivirus를 탐색한 다음 eTrust Antivirus를 클릭하여 응용 프로그램을 시작합니다.

  2. eTrust Antivirus 응용 프로그램 메뉴에서 Help를 클릭한 다음 About eTrust Antivirus를 클릭합니다.

  3. Product Version 필드를 조사하여 eTrust Antivirus의 버전을 확인합니다.

Exchange Server 컴퓨터에서 파일 수준의 검색 프로그램을 사용하면 다음과 같은 문제가 발생할 수 있습니다.

  • 파일 수준의 검색 프로그램은 사용할 때나 예약한 간격으로 파일을 검색하는데, Exchange가 Exchange 로그 또는 데이터베이스 파일을 사용하는 동안 해당 파일을 잠그거나 격리합니다. 그 결과 Exchange Server에서 심각한 장애가 발생할 수 있으며 데이터베이스 오류가 발생할 수도 있습니다.

  • Exchange IFS(Installable File System)가 표시하는 드라이브(일반적으로 드라이브 M)를 파일 수준 스캐너 소프트웨어를 사용하여 검색하면 더 많은 문제가 발생할 수 있습니다.

사용 중인 파일 수준 바이러스 백신 프로그램에 관계없이 다음 파일과 폴더는 항상 파일 수준의 검색 프로그램에서 제외해야 합니다.

  • .eml, .edb, .stm, .log, .dat 및 .chk 파일

  • IFS가 표시하는 Exchange Server 드라이브. 기본적으로 이것은 M 드라이브입니다.

  • Exchange 데이터베이스 및 로그 파일. 기본적으로 이러한 파일은 Exchsrvr\Mdbdata 폴더에 있습니다.

  • Exchsrvr\Mtadata 폴더에 있는 Exchange MTA 파일

  • Exchsrvr\server_name.log 파일 같은 추가 로그 파일

  • Exchsrvr\Mailroot 가상 서버 폴더

  • 메시지 변환에 사용되는 스트리밍 임시 파일을 저장하는 데 사용되는 작업 폴더. 기본적으로 이 폴더는 \Exchsrvr\MDBData에 있지만 사용자가 해당 위치를 구성할 수 있습니다.

  • Eseutil.exe 같은 오프라인 유지 관리 도구에서 사용되는 임시 폴더. 기본적으로 이 폴더는 .exe 파일이 실행되는 위치이지만 도구를 실행하면 사용자가 해당 위치를 구성할 수 있습니다.

  • Exchsrvr\Srsdata 폴더에 있는 사이트 복제 서비스(SRS) 파일

  • %SystemRoot%\System32\Inetsrv 폴더에 있는 Microsoft Internet Information Service(IIS) 시스템 파일

  • %SystemRoot%\IIS Temporary Compressed Files 폴더에 있는 IIS 작업 파일

이 경고를 해결하려면 다음을 수행합니다.

  1. eTrust Antivirus 사용자 인터페이스를 사용하여 파일 수준 바이러스 검색에서 위에 나열된 폴더와 파일을 제외시킵니다.

  2. Exchange Server 컴퓨터에서 eTrust Antivirus를 사용하는 방법에 대한 최신 정보를 보려면 CA eTrust Antivirus 웹 사이트(http://www3.ca.com/Solutions/Product.asp?ID=156)를 방문하십시오.

    참고:
    웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결할 수 없을 수도 있습니다.

Exchange Server에서의 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.

IFS 드라이브 검색 시 발생할 수 있는 문제에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 298924, "XADM: Exchange 2000 M 드라이브를 백업하거나 검색하지 않아야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: 데이터베이스를 탑재하려고 하면 "C1041737" 오류와 이벤트 ID 470 메시지가 표시될 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: 일정 항목이 사용자 폴더에서 사라진다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: 실시간 검색에서 Exchange 프로세스가 제외되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Computer Associates의 eTrust Antivirus에서 수행되는 실시간 파일 수준 바이러스 검색에서 제외된 파일 확장명 목록을 확인합니다.

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\RealTime\szExcludeProcessNames

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeProcessNames

Exchange Server Analyzer는 szExcludeProcessNames 값에 STORE.EXE, EMSMTA.EXE 및 MAD.EXE가 포함되어 있지 않을 경우 경고를 표시합니다.

Microsoft Exchange Information Store 프로세스(Store.exe), Exchange MTA 프로세스(Emsmta.exe) 또는 시스템 수행자(System Attendant) 프로세스(Mad.exe)가 실행 중일 때는 파일 수준 기반 바이러스 검색 프로그램으로 이러한 프로세스를 검색하지 않는 것이 좋습니다.

eTrust Antivirus는 파일 수준의 바이러스 백신 프로그램입니다. Exchange Server 컴퓨터에 설치되어 있는 eTrust Antivirus의 버전을 확인하려면 다음을 수행합니다.

  1. 시작 | 프로그램 | eTrust Antivirus를 탐색한 다음 eTrust Antivirus를 클릭하여 응용 프로그램을 시작합니다.

  2. eTrust Antivirus 응용 프로그램 메뉴에서 Help를 클릭한 다음 About eTrust Antivirus를 클릭합니다.

  3. Product Version 필드를 조사하여 eTrust Antivirus의 버전을 확인합니다.

Exchange Server 컴퓨터에서 파일 수준의 검색 프로그램을 사용하면 다음과 같은 문제가 발생할 수 있습니다.

  • 파일 수준의 검색 프로그램은 사용할 때나 예약한 간격으로 파일을 검색하는데 Exchange가 Exchange 로그 또는 데이터베이스 파일을 사용하는 동안 해당 파일을 잠그거나 격리합니다. 그 결과 Exchange Server에서 심각한 장애가 발생할 수 있으며 데이터베이스 오류가 발생할 수도 있습니다.

  • IFS가 표시하는 드라이브(일반적으로 M 드라이브)를 파일 수준 검색 소프트웨어를 사용하여 검색하면 더 많은 문제가 발생할 수 있습니다.

사용 중인 파일 수준 바이러스 백신 프로그램에 관계없이 다음 파일과 폴더는 항상 파일 수준의 검색 프로그램에서 제외해야 합니다.

  • .eml, .edb, .stm, .log, .dat 및 .chk 파일

  • IFS가 표시하는 Exchange Server 드라이브. 기본적으로 이것은 M 드라이브입니다.

  • Exchange 데이터베이스 및 로그 파일. 기본적으로 이러한 파일은 Exchsrvr\Mdbdata 폴더에 있습니다.

  • Exchsrvr\Mtadata 폴더에 있는 Exchange MTA 파일

  • Exchsrvr\server_name.log 파일 같은 추가 로그 파일

  • Exchsrvr\Mailroot 가상 서버 폴더

  • 메시지 변환에 사용되는 스트리밍 임시 파일을 저장하는 데 사용되는 작업 폴더. 기본적으로 이 폴더는 \Exchsrvr\MDBData에 있지만 사용자가 해당 위치를 구성할 수 있습니다.

  • Eseutil.exe 같은 오프라인 유지 관리 도구에서 사용되는 임시 폴더. 기본적으로 이 폴더는 .exe 파일이 실행되는 위치이지만 도구를 실행하면 사용자가 해당 위치를 구성할 수 있습니다.

  • Exchsrvr\Srsdata 폴더에 있는 사이트 복제 서비스(SRS) 파일

  • %SystemRoot%\System32\Inetsrv 폴더에 있는 Microsoft Internet Information Service(IIS) 시스템 파일

  • %SystemRoot%\IIS Temporary Compressed Files 폴더에 있는 IIS 작업 파일

이 경고를 해결하려면 다음을 수행합니다.

  1. eTrust Antivirus 사용자 인터페이스를 사용하여 파일 수준 바이러스 검색에서 위에 나열된 폴더와 파일을 제외시킵니다.

  2. Exchange Server 컴퓨터에서 eTrust Antivirus를 사용하는 방법에 대한 최신 정보를 보려면 Computer Associates eTrust Antivirus 웹 사이트(http://www3.ca.com/Solutions/Product.asp?ID=156)를 방문하십시오.

    참고:
    웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

Exchange Server에서의 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.

IFS 드라이브 검색 시 발생할 수 있는 문제에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 298924, "XADM: Exchange 2000 M 드라이브를 백업하거나 검색하지 않아야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: 데이터베이스를 탑재하려고 하면 "C1041737" 오류와 이벤트 470 메시지가 표시될 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: 일정 항목이 사용자 폴더에서 사라진다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


Client Service Messaging Security for SMB v2.0 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Version 값이 6.2100이면 Trend Micro ScanMail Client Service Messaging Security for SMB v2.0이 설치되어 있음을 나타냅니다.

Microsoft® Exchange Server Analyzer는 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 설치된 Client Service Messaging Security for SMB 버전 2.0의 버전을 확인합니다. Exchange Server Analyzer는 주 빌드 번호가 1145보다 작으면 경고를 표시합니다.

이 경고는 Client Server Messaging Security for SMB v2.0이 Exchange 서버에 설치되어 있고 권장 소프트웨어 업데이트를 사용할 수 있음을 나타냅니다. 권장 업데이트는 메시징 구성 요소용 Client Server Messaging Security for SMB v2.0 패치 2입니다. 이 업데이트는 서버의 전반적인 성능과 안정성을 향상시켜 주므로 설치하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Client Server Messaging Security for SMB의 Trend Micro Update Center(http://www.trendmicro.com/download/product.asp?productid=39)를 방문하십시오.

  2. 패치 2를 다운로드하여 설치합니다.
참고:
이 항목에는 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 있습니다. 해당 URL은 예고 없이 변경될 수 있습니다.

다른 Trend Micro 제품 업데이트에 대한 자세한 내용은 Trend Micro Update Center 웹 사이트(http://www.trendmicro.com/download/)를 참조하십시오.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, Exchange 및 바이러스 백신 소프트웨어(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, Exchange Server 2003 및 바이러스 백신 소프트웨어 개요(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, 바이러스 백신 소프트웨어가 설치된 Exchange Server 컴퓨터의 문제 해결에 대한 권장 사항(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


HP Command View EVAPerf 설치를 고려하십시오.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-09

Microsoft® Exchange Server Analyzer Tool은 Win32_SCSIController Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Name 키 값을 확인합니다. Name 키 값이 Compaq HSV110CCL이면 서버에 있는 최소 하나의 디스크 볼륨이 HP EVA SAN(Storage Area Network)에서 제공되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 Win32_Service WMI 클래스를 쿼리하여 HP StorageWorks Command View EVAPerf(EVSPDCS) 서비스의 Started 키 값을 확인합니다. False 값은 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 서비스가 실행되고 있음을 나타냅니다.

다음 두 가지 조건이 모두 맞으면 Exchange Server Analyzer에서 유용한 정보 권장 사항을 표시합니다.

  • 서버에 있는 최소 하나의 디스크 볼륨이 HP EVA SAN에서 제공되고 있습니다.

  • HP StorageWorks Command View EVAPerf(EVSPDCS) 서비스가 없거나 실행되고 있지 않습니다.

HP에서는 HP StorageWorks SAN용 추가 성능 카운터를 게시하는 무료 소프트웨어 관리 응용 프로그램을 제공합니다. 관리자는 이 소프트웨어 관리 응용 프로그램을 사용하여 SAN에서 각 컨트롤러 및 실제 디스크의 성능을 모니터링할 수 있습니다.

유용한 정보 권장 사항을 따르려면 다음을 수행합니다.

  1. HP StorageWorks Command View EVAPerf Software 웹 사이트로 이동하여 HP Command View EVAPerf 응용 프로그램(http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005을 다운로드합니다.

    참고:
    필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 제공됩니다. URL은 예고 없이 변경될 수 있습니다.

  2. 다운로드한 자동 압축 풀기 실행 파일을 실행하고 지침에 따라 응용 프로그램을 설치합니다.


EMC PowerPath Service가 중지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 EMC PowerPath Service 서비스의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 EMC PowerPath Service 서비스가 실행 중임을 나타내고 False 값은 EMC PowerPath Service 서비스가 실행 중이 아님을 나타냅니다. Exchange Server Analyzer는 Started 키 값이 False일 경우 경고를 표시합니다.

EMC PowerPath는 MPIO(Multipath I/O) 소프트웨어입니다. 다중 경로는 호스트가 최대 32개의 경로를 통해 외부 저장 장치에 액세스하여 장애 조치(failover) 및 로드 균형 조정을 간편하게 수행할 수 있게 해 주는 가용성이 높은 데이터 액세스 방법입니다. 다중 경로는 운영 체제의 기능이 아니라 저장소 공급업체에 상호 운용 가능한 다중 경로 솔루션을 만드는 방법을 제공하는 MPIO DDK(드라이버 개발 키트)를 통해 지원되는 기능입니다.

MPIO 소프트웨어가 실행되면 Microsoft Windows®는 단일 드라이브만 검색하지만 MPIO 소프트웨어는 다양한 저장 장치에 대한 다중 연결을 관리합니다. MPIO 소프트웨어가 중지되면 Windows는 연결된 모든 저장소 드라이브를 독립 드라이브로 감지합니다. 그 결과 저장소 오류와 오작동이 발생할 수 있습니다.

EMC PowerPath Service 서비스를 시작하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. EMC PowerPath Service 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. EMC PowerPath Service 속성 페이지의 일반 탭에서 시작 유형이 자동으로 설정되었는지 확인합니다. 그렇지 않은 경우 적용을 클릭한 다음 확인을 클릭합니다.

  4. EMC PowerPath Service 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.

다양한 Windows 저장 기술을 배포하는 방법에 대한 일반 정보는 "Planning to Use Windows Storage Features with SANs"(http://go.microsoft.com/fwlink/?LinkId=33626)를 참조하십시오.


EMC PowerPath Version Mismatch Between Cluster Nodes
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2007-07-25

Microsoft Exchange Analyzer Tool은 다음 레지스트리 항목을 읽어 클러스터의 각 노드에 설치된 EMC PowerPath 버전을 확인합니다.

HKEY_LOCAL_MACHINE\SOFTWARE\EMC\PowerPath\Version

Exchange Analyzer는 Exchange 클러스터의 둘째 또는 후속 노드에 있는 버전 값이 Exchange 클러스터의 첫째 노드에 있는 버전 값과 다르면 오류를 표시합니다.

이 오류는 이 Exchange 클러스터의 노드가 같은 수준의 EMC PowerPath 드라이버를 실행하고 있지 않음을 나타냅니다. 모든 Exchange 클러스터의 노드가 같은 수준의 EMC PowerPath 드라이버를 실행하는 것이 좋습니다.

EMC PowerPath는 MPIO(다중 경로 I/O) 소프트웨어입니다. 다중 경로는 호스트가 최대 32개의 경로를 통해 외부 저장 장치에 액세스하여 장애 조치(failover) 및 로드 균형 조정을 간편하게 수행할 수 있게 해 주는 가용성이 높은 데이터 액세스 방법입니다. 다중 경로는 운영 체제의 기능이 아니라 저장소 공급업체에 상호 운용 가능한 다중 경로 솔루션을 만드는 방법을 제공하는 MPIO DDK(드라이버 개발 키트)를 통해 지원되는 기능입니다.

MPIO 소프트웨어가 실행되면 Microsoft Windows는 단일 드라이브만 검색하지만 MPIO 소프트웨어는 다양한 저장 장치에 대한 다중 연결을 관리합니다. MPIO 드라이버가 클러스터의 서로 다른 노드 간에 일치하지 않으면 클러스터 장애 조치(failover) 문제가 발생할 수 있습니다.

이 문제를 해결하려면 모든 노드를 같은 EMC PowerPath 드라이버 버전으로 업그레이드해야 합니다.

추가 정보

다양한 Windows 저장소 기술을 배포하는 방법에 대한 자세한 내용은 "SAN을 통해 Windows 저장소 기능 사용 계획(Planning to Use Windows Storage Features with SANs)"(http://go.microsoft.com/fwlink/?LinkId=33626)을 참조하십시오.


Emulex FC Port 드라이버가 2년이 넘도록 업데이트되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-04-19

Microsoft® Exchange Server Analyzer Tool은 DriverName 키에 값이 설정되어 있는지 확인할 때 Win32_SCSIController Microsoft® WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer Tool은 다음과 같은 조건이 존재하는지 확인합니다.

  • Emulex FC Port 드라이버가 Exchange 서버에 설치되어 있습니다.

  • Emulex FC Port 드라이버의 현재 버전이 Exchange 서버에 설치되어 있습니다.

  • Emulex FC Port 드라이버가 지난 2년 내에 업데이트되었습니다.

Exchange Server Analyzer는 DriverName 키 값이 2년 넘게 업데이트되지 않았으면 경고를 표시합니다.

Emulex FC Port 드라이버는 단일 HBA(호스트 버스 어댑터)나 여러 HBA 내에 SCSI 전용 또는 SCSI 및 IP 동시 기능을 제공합니다. FC Port 드라이버는 FC-AL(파이버 채널 조정 루프) 토폴로지, 지점 간 토폴로지 및 구조 토폴로지를 지원합니다. FC Port 드라이버는 호스트 기반 LUN(논리 단위 번호) 매핑 또는 영구 바인딩이 필요한 특수 응용 프로그램용으로 설계되었습니다.

Emulex FC Port 드라이버를 업데이트하려면 Downloads and Manuals for Windows(http://www.emulex.com/ts/docfc/winframe.htm)를 참조하십시오. 특정 OEM 드라이버가 필요한 경우에는 Emulex 소프트웨어 및 설명서 웹 사이트(http://www.emulex.com/ts/index.html)를 참조하십시오.

참고:
이 항목에는 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 있습니다. 해당 URL은 예고 없이 변경될 수 있습니다.


Emulex SCSIport 미니포트 드라이버가 2년 넘게 업데이트되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-06-14

Microsoft® Exchange Server Analyzer Tool에서는 Win32_SCSIController Microsoft Windows® Management Instrumentation (WMI) 클래스를 쿼리하여 DriverName 키에 대해 설정된 값인지 확인합니다. Exchange Server Analyzer Tool은 다음과 같은 조건이 존재하는지 확인합니다.

  • Emulex SCSIport 미니포트 드라이버가 Exchange 서버에 설치되어 있습니다.

  • 현재 버전의 Emulex SCSIport 미니포트 드라이버가 Exchange 서버에 설치되어 있습니다.

  • Emulex SCSIport 미니포트 드라이버가 2년 동안 업데이트되었습니다.

Exchange Server Analyzer는 DriverName 키 값이 2년 넘게 업데이트되지 않았으면 경고를 표시합니다.

SCSIport 미니포트 드라이버는 FC-AL(Fibre Channel arbitrated loop) 토폴로지, 지점 간 토폴로지 및 패브릭 토폴로지를 통해 SCSI 기능을 제공합니다.

Emulex SCSIport Miniport 드라이버를 업데이트하려면 http://www.emulex.com/ts/docfc/winframe.htm(영문)의 Downloads and Manuals for Windows를 참조하십시오. 특수 OEM 드라이버가 필요하면 OEM 소프트웨어 및 설명서(http://www.emulex.com/ts/index.html)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


Emulex Storport 미니포트 드라이버가 2년 넘게 업데이트되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-06-14

Microsoft® Exchange Server Analyzer Tool은 DriverName 키에 값이 설정되어 있는지 확인할 때 Win32_SCSIController Microsoft® WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer Tool은 다음과 같은 조건이 존재하는지 확인합니다.

  • Emulex Storport 미니포트 드라이버가 Exchange 서버에 설치되어 있습니다.

  • 현재 버전의 Emulex Storport 미니포트 드라이버가 Exchange 서버에 설치되어 있습니다.

  • EEmulex Storport 미니포트 드라이버가 지난 2년 동안 업데이트되었습니다.

Exchange Server Analyzer는 DriverName 키 값이 2년 넘게 업데이트되지 않았으면 경고를 표시합니다.

Emulex Stoport 미니포트 드라이버는 SAN(Storage Area Network) 및 하드웨어 기반 디스크 배열의 성능 및 관리 효율성을 최적화합니다. Emulex Storport 미니포트 드라이버는 FC-AL(Fibre Channel arbitrated loop) 토폴로지, 지점 간 토폴로지 및 패브릭 토폴로지를 지원합니다.

Emulex Storport 미니포트 드라이버를 업데이트하려면 Downloads and Manuals for Windows(http://www.emulex.com/ts/docfc/winframe.htm)를 참조하십시오. 특수 OEM 드라이버가 필요하면 OEM 소프트웨어 및 설명서(http://www.emulex.com/ts/index.html)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


Exchange가 아닌 프로세스의 CPU 사용률이 높습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

  • Microsoft® Exchange Server Analyzer Tool은 현재 서버의 사용 가능 CPU를 20% 넘게 사용하고 있는 Exchange Server가 아닌 프로세스를 확인했습니다. Exchange Server가 아닌 프로세스에서 사용 가능 CPU를 20% 넘게 사용하면 오류가 표시됩니다.

  • Exchange Server를 실행하는 서버를 항상 Exchange Server 전용으로 사용하고 Exchange 외부에서는 가능하면 적은 응용 프로그램 및 서비스를 실행하는 것이 좋습니다.

이 오류를 수정하려면 다음을 수행합니다.

  • 다른 프로세스에서 대부분의 CPU를 사용하는 경우에는 다음 옵션 중 하나를 수행합니다.

    • 해당 프로세스를 끄고 문제가 사라졌는지 확인합니다.

    • 가능한 경우 해당 프로세스를 다른 서버로 이동합니다.

    • 프로세스가 제대로 구성되어 있는지 확인하고 Microsoft 및 프로세스 공급자에서 이 문제를 해결하는 모든 업데이트를 검색합니다.

    • 필요하지 않은 프로세스를 제거합니다.

  • 해당 프로세스를 이동하거나 수정할 수 없는 경우에는 Exchange Server가 아닌 프로세스의 추가 로드를 허용하도록 서버를 다시 조정해야 합니다. 이 재조정 작업의 일부로 사용자를 다른 Exchange 서버로 이동하는 것이 좋습니다.


HP/Compaq Secure Path 서비스가 중지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 HP/Compaq Secure Path 서비스가 실행 중인지 확인하기 위해 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 HP/Compaq Secure Path 서비스가 실행되고 있지 않을 경우 경고를 표시합니다.

HP/Compaq Secure Path 서비스는 MPIO(다중 경로 입출력) 소프트웨어입니다. 다중 경로는 호스트가 최대 32개의 경로를 통해 외부 저장 장치에 액세스하여 장애 조치(failover) 및 로드 균형 조정을 간편하게 수행할 수 있게 해 주는 가용성이 높은 데이터 액세스 방법입니다. 다중 경로는 운영 체제의 기능이 아니라 저장소 공급업체에 상호 운용 가능한 다중 경로 솔루션을 만드는 방법을 제공하는 MPIO DDK(드라이버 개발 키트)를 통해 지원되는 기능입니다.

실행되는 MPIO 소프트웨어는 다양한 저장 장치에 대한 다중 연결을 관리하지만 운영 체제에서는 단일 드라이브만 감지합니다. MPIO 소프트웨어가 중지되면 Windows에서는 연결된 모든 저장 드라이브를 독립형 드라이브로 인식합니다. 이로 인해 저장소 오류 및 오작동이 발생할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. HP/Compaq Secure Path 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. HP/Compaq Secure Path 서비스 속성 페이지의 일반 탭에서 시작 유형이 자동으로 설정되어 있는지 확인합니다. 그렇지 않은 경우 적용을 클릭한 다음 확인을 클릭합니다.

  4. HP/Compaq Secure Path 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.

Windows에서 여러 다른 저장소 기술을 배포하는 방법에 대한 자세한 내용은 "Planning to Use Windows Storage Features with SANs"(http://go.microsoft.com/fwlink/?linkid=33626)를 참조하십시오.


타사 소프트웨어의 영향
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange 서버에서 타사 소프트웨어를 실행 중임을 확인했습니다. 이 타사 소프트웨어가 서버 성능 문제의 원인일 수 있습니다. 타사 소프트웨어에는 다음과 같은 소프트웨어가 있으며 이에만 국한되지는 않습니다.

  • 파일 수준의 바이러스 백신 제품

  • Exchange를 인식하는 전자 메일 바이러스 백신 제품

  • 스팸 방지 제품

  • 팩스 서버 소프트웨어

  • 외부 메일 또는 공동 작업 커넥터

  • 파일 및 인쇄 서비스

  • 모바일 장치 커넥터

이 오류를 수정하려면 다음을 수행합니다.

  • 타사 소프트웨어가 Exchange Server 성능을 저하시키는 것으로 의심되는 경우 해당 타사 소프트웨어를 제거하거나 비활성화한 다음 Exchange Server 성능을 측정합니다.

  • 타사 소프트웨어가 성능을 저하시키는 원인이지만 서버 기능에 중요한 것으로 판단되면 다른 서버를 제공하여 두 대의 서버에 로드를 분산시킵니다.

추가 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


INO_FLPY.SYS 버전 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Ino_flpy.sys Computer Associates 바이러스 백신 필터 드라이버의 버전을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

Exchange Server Analyzer는 CIM_Datafile WMI 클래스를 쿼리하여 Ino_flpy.sys의 Version 키 값을 확인하고 버전 빌드 번호를 기준으로 소프트웨어 업데이트가 필요한지 여부를 결정합니다. Ino_flpy.sys 파일의 Version 키 값이 5.00.6100.109보다 작은 경우 경고가 표시됩니다.

버전 번호가 5.00.6100.109보다 작으면 Exchange Server 컴퓨터에 최신 버전의 Ino_flpy.sys 파일이 설치되어 있지 않은 것이며 최신 버전의 필터 드라이버를 설치해야 합니다. Ino_flpy.sys 파일에 대한 바이러스 백신 소프트웨어 업데이트는 Computer Associates 웹 사이트에서 구할 수 있습니다. 이 바이러스 백신 소프트웨어 업데이트를 설치하는 것이 좋으며 이를 통해 Exchange Server 컴퓨터의 전체적인 성능과 안정성을 개선할 수 있습니다.

Exchange 2000 Server나 Exchange Server 2003 컴퓨터에 Inoculan Computer Associates eTrust Antivirus 버전 6.x 또는 7.x 및 InoculateIT 버전 6.x 바이러스 백신 소프트웨어 프로그램이 설치되어 있으면 설치 프로그램에서 Ino_flpy.sys 및 Ino_fltr.sys 바이러스 백신 필터 드라이버를 %systemroot%\system32\drivers 폴더로 복사합니다. 이 바이러스 백신 드라이버 파일은 필요한 바이러스 백신 서비스를 시작하는 데 사용되는 Windows NT® 커널 모드 드라이버입니다. 이전 버전의 필터 드라이버를 사용하면 Exchange Server 컴퓨터에 예기치 않은 결과가 발생할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. ino_flpy.sys 파일에 대한 최신 바이러스 백신 소프트웨어 업데이트를 구하려면 Computer Associates 웹 사이트(http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp)를 방문하십시오.

  2. eTrust 또는 InoculateIT의 적절한 업데이트 버전을 다운로드합니다.

  3. Ino_flpy.sys 파일 백업을 포함한 Exchange Server 컴퓨터의 전체 백업을 수행합니다.

  4. eTrust 또는 InoculateIT에 최신 업데이트를 설치합니다.
참고:
웹 주소가 변경되어 여기에 언급된 웹 사이트에 연결되지 않을 수도 있습니다.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 240309, "How to Fully Disable Antivirus Software from Filtering Files"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309)

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


INO_FLTR.SYS 버전 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Ino_fltr.sys Computer Associates 바이러스 백신 필터 드라이버의 버전을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

Exchange Server Analyzer는 Ino_fltr.sys의 Version 키 값을 확인하고 버전 빌드 번호를 기준으로 소프트웨어 업데이트가 필요한지 여부를 확인할 때 CIM_Datafile WMI 클래스를 쿼리합니다. Version 키 값에서 Ino_fltr.sys 파일의 버전 번호가 5.00.6100.142보다 작은 경우 경고가 표시됩니다.

버전 번호가 5.00.6100.142보다 작으면 Exchange Server 컴퓨터에 최신 버전의 Ino_fltr.sys 파일이 설치되어 있지 않은 것이며 최신 버전의 필터 드라이버를 설치해야 합니다. Ino_fltr.sys 파일에 대한 바이러스 백신 소프트웨어 업데이트는 Computer Associates 웹 사이트에서 구할 수 있습니다. 이 바이러스 백신 소프트웨어 업데이트를 설치하는 것이 좋으며 이를 통해 Exchange Server 컴퓨터의 전체적인 성능과 안정성을 개선할 수 있습니다.

Exchange 2000 Server나 Exchange Server 2003 컴퓨터에 Inoculan Computer Associates eTrust Antivirus 버전 6.x 또는 7.x 및 InoculateIT 버전 6.x 바이러스 백신 소프트웨어 프로그램이 설치되어 있으면 설치 프로그램에서 Ino_flpy.sys 및 Ino_fltr.sys 바이러스 백신 필터 드라이버 파일을 %systemroot%\system32\drivers 폴더로 복사합니다. 이 바이러스 백신 드라이버 필터 파일은 필요한 바이러스 백신 서비스를 시작하는 데 사용되는 Windows NT® 커널 모드 드라이버입니다. 이전 버전의 필터 드라이버를 사용하면 Exchange Server 컴퓨터에 예기치 않은 결과가 발생할 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Ino_fltr.sys 파일에 대한 최신 바이러스 백신 소프트웨어 업데이트를 구하려면 Computer Associates 웹 사이트(http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp)를 방문하십시오.

  2. eTrust 또는 InoculateIT의 적절한 업데이트 버전을 다운로드합니다.

  3. Ino_fltr.sys 파일 백업을 포함한 Exchange Server 컴퓨터의 전체 백업을 수행합니다.

  4. eTrust 또는 InoculateIT에 최신 업데이트를 설치합니다.
참고:
웹 주소가 변경되어 여기에 언급된 웹 사이트에 연결되지 않을 수도 있습니다.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 240309, "How to Fully Disable Antivirus Software from Filtering Files"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309)

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


McAfee GroupShield 5.2 for Microsoft Exchange Update for Exchange를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-04-19

Microsoft® Exchange Server Analyzer Tool은 VSAPI(Virus Scanning Application Programming Interface) 라이브러리 파일이 Microsoft Exchange Information Store 서비스에 등록되었는지 확인할 때 다음 레지스트리 값을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

McAfee GroupShield 5.2 for Microsoft Exchange를 Exchange 2000 Server나 Exchange Server 2003에 설치하면 라이브러리 레지스트리 항목 값이 GSEVS2.DLL이 됩니다. 이 라이브러리 파일은 GroupShield 5.2 for Microsoft Exchange에서 몇몇 VSAPI 관련 기능을 수행합니다.

또한 Exchange Server Analyzer는 GSEVS2.DLL에 대한 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Version 키 값에서 이 파일의 빌드 번호가 682보다 작을 경우 경고가 표시됩니다.

GSEVS2.DLL에 대한 버전 번호가 682보다 작은 경우 최신 버전의 GroupShield 5.2 for Microsoft Exchange가 설치되어 있지 않음을 나타냅니다. GroupShield 5.2 for Microsoft Exchange용 소프트웨어 업데이트는 McAfee 웹 사이트에서 구할 수 있습니다. 이 업데이트는 전반적인 성능과 안정성을 향상시켜주므로 설치하는 것이 좋습니다. 또한 GroupShield for Microsoft Exchange 5.2.682로 업그레이드하면 중요한 DLL의 최신 버전을 사용할 수 있습니다. 최신 버전의 gsevs2.dll을 사용하면 Exchange Server 메시징 배포 성능과 안정성이 상당히 개선됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. McAfee 웹 사이트의 Guided Knowledge Search 페이지(http://knowledgemap.nai.com/)를 방문하여 GroupShield 5.2 for Microsoft Exchange Server의 최신 버전을 확인합니다. 해당 사이트에 있는 다음 McAfee Solutions KnowledgeBase 문서와 기타 McAfee Solutions KnowledgeBase 문서를 사용하여 최신 버전을 결정합니다.

    • Solution ID KB40567, "Getting the latest version of GroupShield and/or SpamKiller"

    • Solution ID KB nai18117, "Product Version Information for GroupShield for Exchange 2000"

  2. McAfee 웹 사이트(https://secure.nai.com/us/forms/downloads/upgrades/login.asp)를 방문하십시오.

  3. 사용 중인 버전의 GroupShield 5.2 for Microsoft Exchange Server에 대한 최신 업데이트를 다운로드합니다.

  4. Exchange Server 컴퓨터를 전체 백업합니다.

  5. GroupShield 5.2 for Microsoft Exchange Server의 최신 업데이트를 설치합니다.
참고:
이 항목에는 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 있습니다. 해당 URL은 예고 없이 변경될 수 있습니다.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Exchange에 사용 가능한 McAfee GroupShield 6.0 for Microsoft Exchange 업데이트
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 값을 읽어 VSAPI(Virus Scanning Application Programming Interface) 라이브러리 파일이 Microsoft Exchange Information Store 서비스에 등록되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

McAfee GroupShield 6.0 for Microsoft Exchange가 Exchange 2000 Server 또는 Exchange Server 2003에 설치되면 라이브러리 레지스트리 항목이 VSAPISCANSOURCE.DLL 값을 갖게 됩니다. 이 라이브러리 파일은 GroupShield 6.0 for Microsoft Exchange에서 몇몇 VSAPI 관련 기능을 수행합니다.

또한 Exchange Server Analyzer는 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 VSAPISCANSOURCE.DLL에 대한 Version 키 값을 확인합니다. Version 키 값에서 이 파일에 대해 6.0.1148.0보다 작은 빌드 번호를 나타내면 경고를 표시합니다.

VSAPISCANSOURCE.DLL의 버전 번호가 6.0.1148.0보다 작으면 최신 버전의 GroupShield 6.0 for Microsoft Exchange가 설치되지 않은 것입니다. GroupShield 6.0 for Microsoft Exchange용 소프트웨어 업데이트는 McAfee 웹 사이트에서 구할 수 있습니다. 이 업데이트는 전반적인 성능과 안정성을 향상시켜주므로 설치하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. McAfee 웹 사이트(http://knowledgemap.nai.com/)의 Guided Knowledge Search 페이지로 이동하여 GroupShield 6.0 for Microsoft Exchange의 최신 버전을 확인합니다. 이 사이트에 있는 다음 McAfee Solutions 문서 및 기타 McAfee Solutions 문서를 참조하여 최신 버전을 확인하십시오.

    • Solution ID nai18117 "Product Version Information for GroupShield for Exchange 2000"

    • Solution ID KB37636, "Version numbers for McAfee GroupShield 6.x for Microsoft Exchange"

    • Solution ID KB40567, "Getting the latest version of GroupShield and/or SpamKiller"

  2. McAfee 웹 사이트의 Product Downloads 페이지(https://secure.nai.com/us/forms/downloads/upgrades/login.asp)를 참조하십시오.

  3. GroupShield 6.0 for Microsoft Exchange의 최신 업데이트를 다운로드합니다.

  4. Exchange Server 컴퓨터를 전체 백업합니다.

  5. GroupShield 6.0 for Microsoft Exchange 최신 업데이트를 설치합니다.
참고:
이 항목에는 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 있습니다. 해당 URL은 예고 없이 변경될 수 있습니다.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


이 Exchange 서버에 McAfee GroupShield가 설치되어 있지만 서비스가 중지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange용 McAfee GroupShield가 설치되어 있는지 여부와 Exchange 컴퓨터에서 McAfee GroupShield 서비스가 실행 중인지 여부를 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스에서 Started 키에 설정된 값이 True로 설정되었는지 아니면 False로 설정되었는지를 확인할 때도 Win32_Service WMI 클래스를 쿼리합니다.

False 값은 이 Exchange Server 컴퓨터에서 정보 저장소 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 Microsoft Exchange Information Store 서비스가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스가 실행 중이고 McAfee GroupShield가 설치되어 있지만 McAfee GroupShield 서비스가 시작되지 않을 경우 경고를 표시합니다.

McAfee GroupShield는 바이러스로부터 Exchange를 보호합니다. McAfee GroupShield 서비스가 중지될 수 있는 원인과 해결 방법이 여기 나열됩니다.

  • Exchange Server에서 실행 중인 소프트웨어가 만료된 평가판 또는 시험판일 수 있습니다. 이 경우 McAfee GroupShield를 다시 설치해야 합니다. 적어도 소프트웨어를 계속 사용하려면 활성화해야 합니다.

  • 관리자가 McAfee GroupShield 서비스를 실수로 중지했을 수 있습니다. 서비스가 자동으로 시작하도록 설정되어 있는지 확인한 다음 서비스를 시작합니다.

  • 악의적인 웜, 바이러스 또는 기타 프로그램으로 인해 서비스가 중지되었을 수 있습니다. 서비스가 자동으로 시작하도록 설정되어 있는지 확인한 다음 서비스를 시작합니다. 관련 오류 이벤트 없이 예기치 않게 서비스가 계속 중지되면 컴퓨터가 악의적인 웜에 감염되었는지 확인하고 필요한 경우 시스템을 치료합니다.

일반적으로 사서함을 호스팅하는 Exchange 서버나 SMTP(Simple Mail Transfer Protocol) 게이트웨이에는 메시징 시스템용 바이러스 백신 소프트웨어를 배포하는 것이 좋습니다. 최상의 보호를 위해 게이트웨이에서 들어오는 MIME 메시지를 검색하는 바이러스 백신 소프트웨어를 실행하고 Exchange Server에서는 VSAPI 2.5를 사용하는 검색 프로그램을 실행합니다.

McAfee GroupShield 서비스를 시작하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. McAfee GroupShield 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. McAfee GroupShield 속성 페이지의 일반 탭에서 시작 유형이 자동으로 설정되어 있는지 확인합니다. 그렇지 않은 경우 적용을 클릭한 다음 확인을 클릭합니다.

  4. McAfee GroupShield 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.

또한 사용자 데스크톱에서는 클라이언트 바이러스 백신 소프트웨어가 실행 중이어야 합니다. 게이트웨이나 Exchange 서버에서 메시징 시스템용 바이러스 백신 소프트웨어(MIME을 구문 분석하고 검색할 수 있음)를 실행 중인 경우에는 데스크톱에 파일 수준의 검색 프로그램을 실행하는 것으로 충분합니다.

  • 일반적으로 Microsoft Exchange Server 2003과 함께 사용되는 다양한 유형의 바이러스 검색 프로그램에 대한 내용은 Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)를 참조하십시오.

  • 일반적으로 Microsoft Exchange 2000 Server와 함께 사용되는 다양한 유형의 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)를 참조하십시오.

  • 바이러스 및 웜을 퍼뜨리는 전자 메일에 대비해 Exchange 환경을 강화하는 방법에 대한 자세한 내용은 Microsoft 백서 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=30732)를 참조하십시오.


Messageware Plus Pack이 설치되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange Server에 Messageware Plus Pack이 설치되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Messageware Incorporated\Core Services\PlusPack\Load

Exchange Server Analyzer는 Load 값 데이터가 1일 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

Messageware Plus Pack은 Messageware Incorporated에서 생산한 Exchange Server 2003용 Microsoft Office Outlook® Web Access 추가 기능입니다. Messageware Plus Pack은 Outlook Web Access Basic 사용자 및 Outlook Web Access Premium 사용자 모두를 위해 Outlook Web Access를 확장하고 향상시킵니다.

Messageware Plus Pack에 대한 자세한 내용은 "Messageware OWA Suite" 웹 사이트(http://www.messageware.com)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


Microsoft Antigen 데이터 실행 방지 호환성
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2007-02-19

Microsoft Exchange Analyzer Tool은 Microsoft Antigen 서비스의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리합니다. False 값은 서비스가 실행되고 있지 않음을 나타내고 True 값은 서비스가 실행되고 있음을 나타냅니다.

또한 Exchange Analyzer는 다음 레지스트리 항목을 읽어 Microsoft Antigen용 Kaspersky 검색 엔진이 Exchange Server에 설치되어 있는지 여부를 확인합니다. 이 레지스트리 항목은 Kaspersky 검색 엔진이 Exchange Server에 설치되어 있을 때만 나타납니다.

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\Scan Engines\Kaspersky

Exchange Server에서 Microsoft Windows Server 2003 서비스 팩(SP1) 이상 버전을 실행 중인 경우 Exchange Analyzer는 SystemStartupOptions 키 값에 문자열 '/NOEXECUTE=OPTOUT' 또는 '/NOEXECUTE=ALWAYSON'이 포함되어 있는지 여부를 확인할 때 Win32_ComputerSystem WMI 클래스를 쿼리합니다. 이는 서버에 DEP(데이터 실행 방지)가 사용하도록 설정되어 있음을 나타냅니다. 데이터 실행 방지는 추가적인 메모리 검사를 수행하여 시스템에서 악성 코드가 실행되지 않도록 도와주는 일련의 하드웨어 및 소프트웨어 기술입니다.

Exchange Analyzer는 다음 조건에서 경고를 표시합니다.

  • Microsoft Antigen 서비스가 서버에서 사용하도록 설정된 경우

  • Antigen용 Kaspersky 검색 엔진이 설치된 경우

  • Exchange 서버에서 Microsoft Windows Server 2003 서비스 팩(SP1) 이상을 실행 중인 경우

  • 서버에서 데이터 실행 방지가 사용하도록 설정된 경우

이 경고는 현재 서버 구성으로 인해 메시징 및 바이러스 검색 성능 문제가 발생할 수 있음을 나타냅니다.

이 경고를 해결하려면 Microsoft 기술 자료 문서 905952, "Messaging performance is slower than expected in Antigen, and the Antigen client stops responding"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=905952)의 안내에 따라 개별 프로그램에 대해 DEP를 선택적으로 사용하지 않도록 설정하십시오.

자세한 정보

데이터 실행 방지에 대한 자세한 내용은 Microsoft 기술 자료 문서 875352 "Windows XP 서비스 팩 2와 Windows XP Tablet PC Edition 2005 및 Windows Server 2003의 데이터 실행 방지 기능에 대한 상세한 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=875352)을 참조하십시오.


NSI Software Double-Take가 설치되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Double-Take 서비스의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 이 Exchange Server에서 Double-Take 서비스가 실행되고 있음을 나타냅니다. Double-Take 서비스가 Exchange Server에 감지된 경우 Exchange Server Analyzer는 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 기본이 아닌 구성을 보고합니다. 필요한 작업이 없습니다.

NSI Software, Inc.의 Double-Take는 사용자가 선택한 파일이나 전체 볼륨을 하나 이상의 원본 서버에서 표준 네트워크 연결 상의 여러 대상 서버로 복사합니다. 이러한 복사본을 사용하면 사용자의 개입 없이 재난이나 시스템 중지 이후에 빠르게 업무를 재개할 수 있습니다.

Double-Take에 대한 자세한 내용은 웹 사이트 "Double-Take"(http://www.nsisoftware.com/pro/doubletake)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

Double-Take는 데이터 복제 소프트웨어입니다. Exchange 2000 Server 및 Exchange Server 2003의 멀티 사이트 데이터 복제에 대한 자세한 내용은 Microsoft 기술 자료 문서 895847, "Exchange 2003 및 Exchange 2000의 다중 사이트 데이터 복제 기능 지원"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895847)을 참조하십시오.


Exchange가 아닌 프로세스가 Processor Time을 20% 넘게 사용하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Processor 성능 개체의 %Processor Time (_Total) 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • 프로세서 지체 현상이 있습니다.

  • Exchange가 아닌 프로세스 하나 이상이 총 평균 서버 CPU 시간을 20% 넘게 사용하고 있습니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고를 표시합니다.

  • 프로세서 지체 현상이 있습니다.

  • Exchange가 아닌 프로세스 하나 이상이 총 평균 서버 CPU 시간을 10% 넘게 사용하고 있습니다.

Process 성능 개체의 % Processor Time (_Total) 성능 카운터는 전체 프로세서 사용률을 제공합니다 평균 CPU 사용률은 항상 80% 미만이어야 합니다. 평균 사용률이 높으면 프로세서 지체가 발생한 것입니다. 프로세서 시간의 최대 사용률이 90%를 넘는 경우가 자주 발생해도 프로세서 지체가 발생한 것입니다.

프로세서 지체 문제 제거

Exchange 서버에서 프로세서 지체 문제를 제거하는 여러 가지 방법이 있습니다.

  • 먼저 서버의 로드를 발생시키는 응용 프로그램이나 작업을 검토합니다. 응용 프로그램에서 프로세서 시간을 그대로 사용해야 하는지 또는 프로세스에 문제가 있는지 확인합니다.

  • 해당 서버에서 Exchange가 아닌 응용 프로그램이 중요하지 않은 경우에는 다른 서버에서 실행하십시오. 이렇게 실행할 수 있는 경우에는 서버 역할도 다른 컴퓨터로 이동합니다. 예를 들어 Inetinfo 프로세스가 CPU 사용률을 많이 차지하는 경우 프런트 엔드 서버를 추가하여 Inetinfo가 수행하는 프로토콜 작업을 수행하게 합니다. 공용 폴더 액세스를 전용 공용 폴더 서버로 이동할 수도 있습니다. 마지막으로 서버가 다량의 메일 그룹 확장을 수행하는 경우에는 메일 그룹 확장을 전용 메일 그룹 확장 서버로 이동하여 CPU 사용률을 줄일 수 있습니다.

  • 이렇게 줄일 수 있는 경우에는 서버에 더 많은 프로세서나 속도가 빠른 프로세서를 추가합니다. 또한 프로세서에서 하이퍼 스레딩을 지원할 경우 해당 기능을 사용합니다. 시스템 BIOS를 구성하여 하이퍼 스레딩을 사용할 수 있습니다. 자세한 내용은 컴퓨터 제조업체의 도움말을 참조하십시오.

  • 처리 성능 향상이 적합한 옵션이 아닐 경우에는 프로세서의 로드를 줄여야 합니다. 서버에 대한 전반적인 영향을 줄이려면 I/O 또는 CPU를 많이 사용하거나 메모리를 소비하는 작업은 정규 작업 시간을 피해서 수행해야 합니다.

  • 백업 및 유지 관리 작업과 같이 CPU를 많이 사용하는 작업은 작업량이 많은 시간대를 피해 이루어져야 합니다. 또한 이러한 작업은 단계적인 방식으로 수행해야 합니다. 작업을 단계적으로 수행하는 것은 각 작업에 대해 시작 시간 및 가능하다면 종료 시간도 다르게 설정하는 것을 의미합니다. 또한 데이터베이스 또는 저장소 그룹의 유지 관리 및 백업을 단계적으로 수행함으로써 리소스를 많이 사용하는 이러한 작업의 영향을 줄입니다.

추가 정보

  • 프로세서 지체에 대한 자세한 내용은 프로세서 지체를 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.

  • 사용자 사서함을 이동하여 서버 로드를 줄이는 방법에 대한 자세한 내용은 다른 서버로 사용자 사서함 이동을 참조하십시오.


Exchange가 아닌 프로세스가 Processor Time을 50% 넘게 사용하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다. 성능 데이터 수집 엔진은 Processor 성능 개체의 %Processor Time (_Total) 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

이러한 Process 성능 개체의 % Processor Time (_Total) 성능 카운터는 전체 프로세서 사용률을 제공합니다. 평균 CPU 사용률은 항상 80% 미만이어야 합니다. 평균 사용률이 높으면 프로세서 지체가 발생한 것입니다. 프로세서 시간의 최대 사용률이 90%를 넘는 경우가 자주 발생해도 프로세서 지체가 발생한 것입니다.

Exchange Server Analyzer는 Exchange가 아닌 프로세스가 총 평균 서버 CPU 시간을 50% 넘게 사용하고 있으면 실제 프로세서 지체가 감지되지 않는 경우에도 경고를 표시합니다.

잠재적 프로세서 지체 문제 제거

Exchange 서버에서 잠재적 프로세서 지체 문제를 제거하는 여러 가지 방법이 있습니다.

  • 먼저 서버의 로드를 발생시키는 응용 프로그램이나 작업을 검토합니다. 응용 프로그램에서 프로세서 시간을 그대로 사용해야 하는지 또는 프로세스에 문제가 있는지 확인합니다.

  • 해당 서버에서 Exchange가 아닌 응용 프로그램이 중요하지 않은 경우에는 다른 서버에서 실행하십시오. 이렇게 실행할 수 있는 경우에는 서버 역할도 다른 컴퓨터로 이동합니다. 예를 들어 Inetinfo 프로세스가 CPU 사용률을 많이 차지하는 경우 프런트 엔드 서버를 추가하여 Inetinfo가 수행하는 프로토콜 작업을 수행하게 합니다. 공용 폴더 액세스를 전용 공용 폴더 서버로 이동할 수도 있습니다. 마지막으로 서버가 다량의 메일 그룹 확장을 수행하는 경우에는 메일 그룹 확장을 전용 메일 그룹 확장 서버로 이동하여 CPU 사용률을 줄일 수 있습니다.

  • 이렇게 줄일 수 있는 경우에는 서버에 더 많은 프로세서나 속도가 빠른 프로세서를 추가합니다. 또한 프로세서에서 하이퍼 스레딩을 지원할 경우 해당 기능을 사용합니다. 시스템 BIOS를 구성하여 하이퍼 스레딩을 사용할 수 있습니다. 자세한 내용은 컴퓨터 제조업체의 도움말을 참조하십시오.

  • 처리 성능 향상이 적합한 옵션이 아닐 경우에는 프로세서의 로드를 줄여야 합니다. 서버에 대한 전반적인 영향을 줄이려면 I/O 또는 CPU를 많이 사용하거나 메모리를 소비하는 작업은 정규 작업 시간을 피해서 수행해야 합니다.

  • 백업 및 유지 관리 작업과 같이 CPU를 많이 사용하는 작업은 작업량이 많은 시간대를 피해 이루어져야 합니다. 또한 이러한 작업은 단계적인 방식으로 수행해야 합니다. 작업을 단계적으로 수행하는 것은 각 작업에 대해 시작 시간 및 가능하다면 종료 시간도 다르게 설정하는 것을 의미합니다. 또한 데이터베이스 또는 저장소 그룹의 유지 관리 및 백업을 단계적으로 수행함으로써 리소스를 많이 사용하는 이러한 작업의 영향을 줄입니다.

추가 정보

  • 프로세서 지체에 대한 자세한 내용은 프로세서 지체를 참조하십시오.

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server Performance(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


HP/Compaq Secure Path의 오래된 버전이 설치되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-13

Microsoft® Exchange Server Analyzer Tool은 해당 Exchange 서버에 설치되어 있는 HP/Compaq Secure Path 소프트웨어의 소프트웨어 버전을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Secure Path 버전이 3.7.2.540이 아니면 경고를 표시합니다.

이 경고를 해결하려면 Secure Path 소프트웨어를 업데이트합니다. 해당 HP/Compaq 대리점에 연락하여 이 소프트웨어를 업데이트합니다.

HP/Compaq Secure Path 소프트웨어 업데이트에 대한 자세한 내용을 보려면 HP 웹 사이트, "HP StorageWorks Secure Path"(http://h18006.www1.hp.com/products/sanworks/softwaredrivers/securepath/index.html)를 방문하십시오.

참고:
이 항목에 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 들어 있습니다. URL은 예고 없이 변경될 수 있습니다.


포트 25가 차단됨
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-10-06

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 값을 읽어 Exchange Server를 실행하는 서버에 McAfee VirusScan for Microsoft Exchange가 설치되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Network Associates\TVD\VirusScan Enterprise\CurrentVersion

또한 다음 레지스트리 분기를 쿼리하여 VirusScan 제품의 포트 차단 방법을 확인합니다.

HKLM\Software\Network Associates\TVD\Shared Components\On Access Scanner\BehaviourBlocking

이 분기의 키는 VirusScan 제품의 On Access 기능을 사용해 차단 또는 허용할 프로세스 및 포트를 구성하는 데 사용됩니다.

마지막으로 Exchange Server Analyzer는 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 McAfee VirusScan 서비스가 Exchange 서버에서 실행 중인지 확인할 수 있는 Started 키 값을 확인합니다.

False 값은 이 Exchange 서버에서 McAfee VirusScan 서비스가 실행되고 있지 않음을 나타내며 True 값은 McAfee VirusScan 서비스가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고를 표시합니다.

  • McAfee VirusScan을 Exchange 서버에 설치하고 실행하는 경우

  • "Prevent mass mailing worms from sending mail" 차단 규칙을 포트 25에 사용하는 경우

  • 차단 규칙에서 Exchange SMTP(Simple Mail Transfer Protocol) 서비스가 제외되지 않는 경우

이 경고는 포트 25를 통해 합법적인 Exchange Server 통신을 차단하도록 McAfee VirusScan 응용 프로그램이 구성되어 있음을 나타내며 메일 흐름 문제가 발생할 수 있습니다.

이 문제를 해결하려면 다음을 수행하십시오.

  • "Prevent mass mailing worms from sending mail" 차단 규칙을 사용하지 않는 것을 고려합니다.

  • Exchange Server SMTP 서비스를 "Prevent mass mailing worms from sending mail" 차단 규칙의 제외 목록에 추가합니다.

추가 정보

  • McAfee VirusScan for Microsoft Exchange 구성 방법에 대한 자세한 내용은 McAfee 서비스의 포털 사이트(http://knowledge.mcafee.com/)를 참조하십시오.

    참고:
    필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 제공됩니다. URL은 예고 없이 변경될 수 있습니다.
  • 일반적으로 Microsoft Exchange Server 2003과 함께 사용되는 다양한 유형의 바이러스 검색 프로그램에 대한 내용은 Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)를 참조하십시오.

  • 일반적으로 Microsoft Exchange 2000 Server와 함께 사용되는 다양한 유형의 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)를 참조하십시오.

  • 바이러스 및 웜을 퍼뜨리는 전자 메일에 대비해 Exchange 환경을 강화하는 방법에 대한 자세한 내용은 Microsoft 백서 "Exchange 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=30732)를 참조하십시오.


Red Earth Software Policy Patrol for Exchange Server Needs Update
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2007-07-24

Microsoft Exchange Analyzer Tool은 레지스토리를 읽어 다음 두 개의 하위 키 중 하나가 있는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Red Earth Software\Policy Patrol\3.0

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Red Earth Software\Policy Patrol\3.0

이러한 분기 중 하나가 있으면 이는 로컬 컴퓨터에 Exchange Server용 Red Earth Software의 정책 패트롤 버전 3.0이 설치되어 있음을 나타냅니다.

Exchange Analyzer는 로컬 컴퓨터에 Exchange Server용 정책 패트롤 버전 3이 설치된 경우 경고를 표시합니다.

이 경고는 Exchange Server용 정책 패트롤의 권장 업데이트를 사용할 수 있음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server용 Red Earth Software 정책 패트롤 다운로드 사이트(http://www.policypatrol.com/download.htm)를 방문하십시오.

  2. Exchange Server용 Policy Patrol에 필요하거나 권장되는 모든 업데이트를 다운로드하여 설치합니다.
참고:
필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 제공됩니다. URL은 예고 없이 변경될 수 있습니다.


ScanMail for Microsoft Exchange 및 CA eTrust 함께 실행
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer는 다음 레지스트리 항목을 읽어서 Exchange 서버에 설치되어 있는 Trend Micro ScanMail for Microsoft Exchange의 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Version 값의 값 데이터가 7로 시작하면 ScanMail for Microsoft Exchange 버전 7이 설치되어 있는 것입니다.

또한 Exchange Server Analyzer는 다음 레지스트리 항목을 읽어서 Computer Associates의 eTrust가 Exchange 서버에 설치되어 있는지 확인합니다.

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\

CurrentVersion 레지스트리 값이 존재하면 Computer Associates의 eTrust Antivirus 버전 7이 Exchange 서버에 설치되어 있는 것입니다.

마지막으로 Exchange Server Analyzer는 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 eTrust Antivirus에서 eTrust Antivirus Realtime Server 서비스로 알려진 InoRT 서비스의 Started 키 값을 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 유용한 정보 메시지를 표시합니다.

  • ScanMail for Microsoft Exchange와 eTrust Antivirus가 모두 Exchange 서버에 설치되어 있습니다.

  • eTrust Antivirus Realtime Server 서비스를 시작했습니다.

Trend Micro에서는 eTrust Antivirus 같은 파일 시스템 기반 바이러스 백신 소프트웨어의 검색에서 ScanMail for Microsoft Exchange 폴더를 제외하도록 권장합니다. ScanMail for Microsoft Exchange는 검색 작업에 해당 경로에 있는 임시 폴더를 사용합니다. 파일 시스템 기반 바이러스 검색 프로그램이 이러한 임시 폴더를 검색하는 경우 검색 작업이 ScanMail for Microsoft Exchange의 일반 작업을 방해할 수 있습니다.

Computer Associates의 eTrust Antivirus 같은 파일 시스템 기반 바이러스 백신 소프트웨어의 실시간 검색에서는 ScanMail for Microsoft Exchange 폴더를 제외하는 것이 좋습니다. 파일 시스템 기반 바이러스 백신 소프트웨어가 설치되어 있는 컴퓨터에서 ScanMail for Microsoft Exchange를 사용하는 방법에 대한 자세한 내용은 Trend Micro 기술 자료 문서, "Installing another antivirus application with ScanMail for Exchange also installed on the same server"(http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=8540)를 참조하십시오.

참고:
필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보를 제공합니다. 해당 URL은 예고 없이 변경될 수 있습니다.


ScanMail for Microsoft Exchange 압축 디렉터리에 너무 많은 파일이 포함되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Trend Micro ScanMail for Microsoft Exchange 버전 7.0이 설치되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

그런 다음 Exchange Server Analyzer는 ScanMail for Microsoft Exchange에서 사용하는 압축 디렉터리의 파일 수를 확인합니다. 기본적으로 압축 디렉터리 경로는 다음과 같습니다.

C:\Program Files\Trend Micro\Smex\Storage\Archive

Exchange Server Analyzer는 다음 조건에서 경고 메시지를 표시합니다.

  • ScanMail for Microsoft Exchange 버전 7.0이 설치되어 있습니다.

  • ScanMail for Microsoft Exchange에서 사용하는 압축 디렉터리에 1,001개 이상의 파일이 있습니다.

이 경고는 ScanMail for Microsoft Exchange에서 사용하는 압축 디렉터리에 많은 파일이 있음을 나타냅니다. Trend Micro에 의하면 ScanMail for Microsoft Exchange에서 사용하는 압축 폴더를 정기적으로 검토하고 지우는 것이 좋습니다.


ScanMail for Microsoft Exchange 백업 디렉터리에 너무 많은 파일이 포함되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Trend Micro ScanMail for Microsoft Exchange 버전 7.0이 설치되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

그런 다음 Exchange Server Analyzer는 ScanMail for Microsoft Exchange에서 사용하는 백업 디렉터리의 파일 수를 확인합니다. 기본적으로 백업 디렉터리 경로는 다음과 같습니다.

C:\Program Files\Trend Micro\Smex\Storage\Backup

Exchange Server Analyzer는 다음 조건에서 경고 메시지를 표시합니다.

  • ScanMail for Microsoft Exchange 버전 7.0이 설치되어 있습니다.

  • ScanMail for Microsoft Exchange에서 사용하는 백업 디렉터리에 1,001개 이상의 파일이 있습니다.

이 경고는 ScanMail for Microsoft Exchange에서 사용하는 백업 디렉터리에 많은 파일이 있음을 나타냅니다. Trend Micro에 의하면 ScanMail for Microsoft Exchange에서 사용하는 백업 폴더를 정기적으로 검토하고 지우는 것이 좋습니다.


Microsoft Exchange 백업 제외용 ScanMail
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Windows 백업을 사용하여 백업에서 제외된 파일과 폴더를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Exchange Server Analyzer는 특히 "SMEX\DATA"을 포함하는 문자열을 검색합니다.

Exchange Server Analyzer는 FilesNotToBackup 키가 문자열 "SMEX\DATA"가 있는 값을 포함하는 경우 경고를 표시합니다.

Windows 백업을 사용하지 않는 경우에는 이 경고를 무시해도 됩니다. Windows 백업을 사용하는 경우 SMEX\DATA 디렉터리 제외는 제거하는 것이 좋습니다. Trend Micro는 이 폴더에서 파일 이름 확장명이.mdb인 모든 파일을 백업할 것을 사용자들에게 권장합니다. 백업 파일은 SMEX\DATA 폴더에 있는 .mdb 파일이 손상되거나 삭제될 경우 사용할 수 있습니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup을 탐색합니다.

  3. 왼쪽 창에서 FilesNotToBackup을 선택합니다.

  4. 오른쪽 창에서 문자열 "SMEX\DATA"가 있는 값을 마우스 오른쪽 단추로 클릭하고 삭제를 선택합니다.

  5. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


ScanMail for Microsoft Exchange 디버그 모드가 사용됩니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Trend Micro ScanMail for Microsoft Exchange에서 디버그 모드가 사용되는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\DebugModule

DebugModule 값 데이터가 다음 문자열을 포함하면 Exchange Server Analyzer는 경고를 표시합니다.

  • HOST:1

  • CONFIG:1

  • MASTER:1

  • WATCHER:1

  • STORE:1

  • INETINFO:1

  • TCHER:1

  • MON:1

  • MONITOR:1

이 경고는 ScanMail for Microsoft Exchange 모듈 하나 이상에 대해 현재 디버그 모드가 사용됨을 나타냅니다. Trend Micro에 의하면 문제 해결과 같이 필요한 경우에만 디버그 모드를 사용하는 것이 좋습니다. 이 경우가 아니면 일반적인 작업 시에는 디버그 모드를 사용하지 않는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 다음 Trend Micro 기술 자료 문서 "Enabling the ScanMail for Exchange (SMEX) 7.0 debugging through the Registry Editor"(http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=25532)를 참조하십시오.

  2. Trend Micro 기술 자료 문서의 지침에 따라 모든 모듈에 대해 디버깅을 사용하지 마십시오.
참고:
필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 제공됩니다. URL은 예고 없이 변경될 수 있습니다.


ScanMail for Microsoft Exchange 격리 디렉터리에 너무 많은 파일이 포함되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Trend Micro ScanMail for Microsoft Exchange 버전 7.0이 설치되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

그런 다음 Exchange Server Analyzer는 ScanMail for Microsoft Exchange에서 사용하는 격리 디렉터리의 파일 수를 확인합니다. 기본적으로 격리 디렉터리 경로는 다음과 같습니다.

C:\Program Files\Trend Micro\Smex\Storage\Quarantine

Exchange Server Analyzer는 다음 조건에서 경고 메시지를 표시합니다.

  • ScanMail for Microsoft Exchange 버전 7.0이 설치되어 있습니다.

  • ScanMail for Microsoft Exchange에서 사용하는 격리 디렉터리에 1,001개 이상의 파일이 있습니다.

이 경고는 ScanMail for Microsoft Exchange에서 사용하는 격리 디렉터리에 많은 파일이 있음을 나타냅니다. Trend Micro에 의하면 ScanMail for Microsoft Exchange에서 사용하는 격리 폴더를 정기적으로 검토하고 지우는 것이 좋습니다.


ScanMail for Microsoft Exchange SharedResPool 디렉터리가 기본 경로에 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2007-06-05

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Trend Micro ScanMail for Microsoft Exchange 버전이 설치되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

또한 Exchange Server Analyzer는 SharedResPool 폴더 위치를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SharedResPool

마지막으로 Exchange Server Analyzer는 다음 레지스트리 항목을 읽어 ScanMail for Microsoft Exchange가 설치된 위치를 확인합니다.

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\HomeDir

Exchange Server Analyzer는 다음 조건에 해당하는 경우 유용한 정보 메시지를 표시합니다.

  • ScanMail for Microsoft Exchange 버전 7이 설치되어 있습니다.

  • SharedResPool 폴더가 ScanMail 루트 디렉터리 경로에 있습니다.

SharedResPool 디렉터리를 ScanMail for Microsoft Exchange에서 사용하는 루트 디렉터리 드라이브보다 빠른 드라이브로 이동하는 것이 좋습니다. Trend Micro에 의하면 고객은 성능 향상을 위해 SharedResPool 폴더를 더 빠른 드라이브로 이동하는 것이 좋습니다. SharedResPool 디렉터리는 ScanMail for Microsoft Exchange 버전 7.0에 포함된 프로세스 간 공유 리소스에 대한 메모리 매핑 파일을 포함합니다. 이 디렉터리의 내용은 삭제하면 안 됩니다.

SharedResPool 폴더에 대한 자세한 내용은 "What are the ScanMail for Exchange (SMEX) 7.0 SharedResPool and Engine directories?" (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26898)를 참조하십시오.

SharedResPool 폴더 이동에 대한 자세한 내용은 "Exchange (SMEX) 7.0 SharedResPool 디렉터리의 ScanMail을 다른 위치로 이동"(http://esupport.trendmicro.com/support/viewxml.do?ContentID=EN-127549&id=EN-127549)을 참조하십시오.

참고:
필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 제공됩니다. URL은 예고 없이 변경될 수 있습니다.


ScanMail for Microsoft Exchange SMTP 검색이 사서함 서버에서 활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 Microsoft IIS(인터넷 정보 서비스) 메타베이스의 다음 속성을 읽어 Trend Micro ScanMail for Microsoft Exchange의 현재 구성 설정을 확인합니다.

LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes/{76719654-05A6-11d2-9dfd-00C04FA322BA}/Bindings/{6BA0CE4C-AC34-411E-B58A-EB715D04019D}/Enabled

또한 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스를 쿼리하여 Exchange 서버 개체의 serverRole 특성 값을 확인합니다. serverRole 특성 값이 1이면 Exchange 서버가 프런트 엔드 서버로 구성되었음을 나타냅니다. 값이 0이면 Exchange 서버가 프런트 엔드 서버로 구성되지 않았음을 나타냅니다.

또한 Exchange Server Analyzer는 Win32_OperatingSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Exchange 서버의 OSProductSuite 키 값을 확인합니다. Exchange 서버에서 특정 운영 체제가 실행되고 있는지 확인할 때 이 쿼리를 수행합니다.

뿐만 아니라 Exchange Server Analyzer는 다음 레지스트리 값을 읽어 Exchange 서버에서 실행 중인 ScanMail for Exchange 버전을 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Version 값의 값 데이터가 7로 시작하면 ScanMail for Microsoft Exchange 버전 7이 설치되어 있는 것입니다.

마지막으로 Exchange Server Analyzer는 Active Directory를 쿼리하여 homeMDBBL 특성이 구성된 개체 수를 확인합니다. homeMDBBL 특성이 구성된 개체는 사서함 사용이 가능한 개체입니다. 따라서 homeMDBBL이 구성된 개체 수는 존재하는 사서함 수와 동일합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 유용한 정보 메시지를 표시합니다.

  • ScanMail for Microsoft Exchange 버전 7이 설치되어 있습니다.

  • 프런트 엔드 서버로 구성되지 않은 Exchange 서버에서 SMTP 검색을 수행하도록 ScanMail for Microsoft Exchange가 구성되어 있습니다.

  • Exchange 서버에 20개가 넘는 사서함이 있습니다.

  • Exchange 서버에서 Microsoft Windows Small Business Server 2003 또는 Microsoft Small Business Server 2000을 실행하고 있지 않습니다.

별도의 전용 게이트웨이나 브리지헤드 서버가 있는 경우 ScanMail for Microsoft Exchange 버전 7 사용자는 사서함 서버에 대해 ScanMail 관리 콘솔을 사용하는 SMTP 검색을 비활성화하는 것이 좋습니다. 최적의 성능과 보안을 위해 SMTP 검색을 사서함 서버 대신 게이트웨이 및 브리지헤드 서버에서 활성화하는 것이 좋습니다.


Microsoft Exchange용 ScanMail TEMP 디렉터리에 파일이 많음
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange용 Trend Micro ScanMail 버전 7.0의 설치 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

그런 다음 Exchange Server Analyzer Tool은 Microsoft Exchange용 ScanMail에서 사용하는 TEMP 디렉터리의 파일 수를 확인합니다. 기본적으로 Microsoft Exchange용 ScanMail에서 사용하는 TEMP 디렉터리 경로는 다음과 같습니다.

C:\Program Files\Trend Micro\Smex\Temp

Exchange Server Analyzer는 다음 조건에서 경고 메시지를 표시합니다.

  • 버전이 7.0인 Microsoft Exchange용 ScanMail이 설치되어 있습니다.

  • Microsoft Exchange용 ScanMail에서 사용하는 TEMP 디렉터리에 100개가 넘는 파일이 있습니다.

이러한 경고는 Microsoft Exchange용 ScanMail에서 사용하는 TEMP 디렉터리에 파일 수가 많음을 나타냅니다. 이 폴더에 있는 파일은 Microsoft Exchange용 ScanMail에서 사용하는 임시 파일입니다. Microsoft Exchange용 ScanMail은 이러한 파일을 자동으로 삭제하도록 되어 있습니다.

Trend Micro는 현재 날짜 이전의 파일이 많은 경우 이전 파일을 삭제하도록 권장합니다.


ScanMail for Microsoft Exchange TEMP 디렉터리에 너무 많은 파일이 포함되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Trend Micro ScanMail for Microsoft Exchange 버전 7.0이 설치되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

ScanMail for Microsoft Exchange 버전 7이 설치되어 있으면 Exchange Server Analyzer는 다음 레지스트리 항목을 읽어 ScanMail for Microsoft Exchange에서 사용하는 TEMP 디렉터리의 위치를 확인합니다.

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

그런 다음 Exchange Server Analyzer는 ScanMail for Microsoft Exchange에서 사용하는 TEMP 디렉터리의 파일 수를 확인합니다.

Exchange Server Analyzer는 다음 조건에서 경고 메시지를 표시합니다.

  • ScanMail for Microsoft Exchange 버전 7.0이 설치되어 있습니다.

  • ScanMail for Microsoft Exchange에서 사용하는 TEMP 디렉터리에 101개 이상의 파일이 있습니다.

이 경고는 ScanMail for Microsoft Exchange에서 사용하는 TEMP 디렉터리에 많은 파일이 있음을 나타냅니다. 이 폴더의 파일은 ScanMail for Microsoft Exchange에서 사용하는 임시 파일입니다. ScanMail for Microsoft Exchange에서는 이러한 파일을 자동으로 삭제합니다.

Trend Micro에 의하면 현재 날짜 이전의 파일이 많이 있는 경우 오래된 파일을 삭제하는 것이 좋습니다.


ScanMail for Microsoft Exchange 임시 폴더 경로가 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 Trend Micro ScanMail for Microsoft Exchange 버전 7.0이 설치되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

또한 Exchange Server Analyzer는 다음 항목을 읽어서 ScanMail for Microsoft Exchange에서 사용하는 임시 폴더의 위치를 확인합니다.

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

레지스트리에 TempFolderPath 값이 존재하고 구성되어 있다면 ScanMail for Microsoft Exchange에서 사용하는 임시 폴더가 기본 위치에서 이동되었음을 나타냅니다.

마지막으로 Exchange Server Analyzer는 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 AdapterSMTP.dll의 Version 키 값을 확인합니다. AdapterSMTP.dll의 Version 키 값이 7.0.1366보다 작으면 ScanMail for Microsoft Exchange의 업데이트 버전이 필요함을 나타냅니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고 메시지를 표시합니다.

  • ScanMail for Microsoft Exchange 버전 7이 설치되어 있습니다.

  • ScanMail for Microsoft Exchange에서 사용하는 임시 폴더가 원래 위치에서 이동되었습니다.

  • adapterSMTP.dll의 파일 버전이 7.0.1366 이전입니다.

ScanMail for Microsoft Exchange의 최신 빌드에는 임시 폴더 위치를 변경하는 기능이 있습니다. 이 기능은 7.0.1366 이후의 빌드에서만 작동합니다. 이 경고는 임시 폴더의 위치가 변경되었지만 이 서버에서 임시 폴더 위치 변경을 지원하지 않는 ScanMail for Microsoft Exchange의 이전 빌드를 실행하고 있으므로 위치 변경은 영향을 미치지 않음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Trend Micro Update Center 웹 사이트(http://www.trendmicro.com/download)로 이동합니다.

  2. ScanMail for Microsoft Exchange의 필수 또는 권장 업데이트를 다운로드하고 설치합니다.
참고:
필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보를 제공합니다. 해당 URL은 예고 없이 변경될 수 있습니다.


Microsoft Exchange용 ScanMail 임시 폴더 경로 최적화
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange용 Trend Micro ScanMail 버전 7.0의 설치 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

또한 Exchange Server Analyzer는 다음 항목을 읽어 Microsoft Exchange용 ScanMail에서 사용하는 임시 폴더의 위치를 확인합니다.

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

TempFolderPath 값이 존재하고 레지스트리에 구성되어 있는 경우 이는 Microsoft Exchange용 ScanMail에서 사용하는 임시 폴더가 기본 위치로 이동되었음을 의미합니다.

마지막으로 Exchange Server Analyzer는 AdapterSMTP.dll의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 해당 모듈은 Trend Micro의 Microsoft Exchange용 ScanMail과 함께 포함되어 있습니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 유용한 정보 메시지를 표시합니다.

  • Microsoft Exchange용 ScanMail 버전 7이 설치되어 있다.

  • Microsoft Exchange용 ScanMail에서 사용하는 임시 폴더가 원래의 기본 위치에 있습니다.

  • AdapterSMTP.dll의 버전이 Microsoft Exchange용 ScanMail에서 사용하는 임시 폴더의 리디렉션을 지원하는 버전입니다.

Trend Micro는 Microsoft Exchange용 ScanMail의 최근 빌드에 있는 임시 폴더를 재배치하는 기능을 도입했습니다. 이 기능은 7.0.1366 이상의 빌드에서만 작동합니다. 버전 7.0.1366 이상의 Microsoft Exchange용 ScanMail의 빌드를 사용하는 경우 Trend Micro는 임시 폴더를 보다 빠른 드라이브에 재배치할 것을 권장합니다.

임시 폴더를 재배치하려면 다음을 수행합니다.

  1. Trend Micro 기술 자료 문서, "Can users change the location of the ScanMail for Exchange (SMEX) 7.0 temporary folder?" (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26343)를 참조하십시오.

  2. 이 문서에 나타나는 절차를 수행하여 임시 폴더를 보다 빠른 드라이브에 재배치하십시오.
참고:
필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 제공됩니다. URL은 예고 없이 변경될 수 있습니다.


ScanMail for Microsoft Exchange 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-12-15

Microsoft® Exchange Server Analyzer Tool은 adapterSMTP.dll의 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 모듈은 Trend Micro ScanMail for Microsoft Exchange에 포함되어 있습니다.

Exchange Server Analyzer는 adapterSMTP.dll의 Version 키 값이 7.0.1366보다 작을 경우 경고를 표시합니다.

이 경고는 ScanMail for Microsoft Exchange 버전 7이 Exchange 서버에 설치되어 있고 권장 소프트웨어 업데이트를 사용할 수 있음을 나타냅니다. 이 업데이트는 서버의 전반적인 성능과 안정성을 향상시켜 주므로 설치하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Trend Micro Update Center 웹 사이트(http://www.trendmicro.com/download/)를 방문하십시오.

  2. ScanMail for Microsoft Exchange에 필요하거나 권장되는 모든 업데이트를 다운로드하여 설치합니다.
참고:
필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 제공됩니다. URL은 예고 없이 변경될 수 있습니다.


SMTP 전송 바이러스 검색이 활성화되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SMSMSE(Microsoft Exchange용 Symantic Mail Security) 서비스에 대한 Started 키의 설정 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Win32_Service 클래스는 SMSMSE가 Exchange Server 2003 컴퓨터에 설치되었는지 확인합니다. True 값은 SMSMSE 서비스가 실행되고 있음을 나타냅니다. False 값은 SMSMSE 서비스가 실행되고 있지 않음을 나타냅니다. Exchange Server Analyzer는 다음 조건이 존재하는 경우 경고 메시지를 표시합니다.

  • SMSMSE는 Exchange Server 2003 컴퓨터에 설치되어 있습니다.

  • SMTP 전송 바이러스 백신 검색이 활성화되지 않았습니다.

Exchange Server 2003에서 고급 큐 엔진은 Exchange Transport AntiVirus API를 6개의 전송 이벤트 싱크 중 하나로 사용하여 메시지를 목적지에 배달합니다. Exchange Transport AntiVirus API 이벤트 싱크는 OnSubmit.dll에서 구현되고 Symantec과 같은 타사 공급업체를 사용하여 메시지가 대상에 도달하기 전에 각 메시지에서 악성 첨부 파일과 데이터 구조를 조사하는 바이러스 검색 프로그램을 구현합니다. 이 이벤트는 OnSubmission 이벤트에 등록됩니다.

전송 바이러스 백신 검색은 메시지를 SMTP 레이어에서 한 번, Exchange 저장소에서 한 번, 모두 두 번 검색하므로 기본적으로 활성화되지 않습니다. 그러나 프런트 엔드 서버를 사용하여 Exchange 조직을 인터넷에 연결할 경우 이러한 서버에서 전송 바이러스 백신 검색을 활성화할 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
전송 바이러스 백신 검색을 활성화하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI를 탐색합니다.

  3. 새 DWORD 값을 Enabled라는 값 이름으로 만듭니다. 값 데이터 1을 Enabled 값 이름에 할당합니다.

  4. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

참고:
전송 검색 기능은 VSAPI(Virus Scanning Application Programming Interface) 2.5에 기반한 Exchange 바이러스 검색 프로그램에서만 사용할 수 있습니다.

SMTP 전송 아키텍처에 대한 자세한 내용은 Exchange Server 2003 기술 참조 가이드(http://go.microsoft.com/fwlink/?LinkId=47891)를 참조하십시오.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 328841, "Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결할 수 없을 수도 있습니다.


Simpler-Webb Exchange Resource Manager를 업데이트할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-04-14

Microsoft® Exchange Server Analyzer Tool은 ERME2KAsyncSink.dll의 Version 키에 설정된 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 ERME2KAsyncSink.dll의 Version 값이 1015보다 낮을 경우 경고를 표시합니다.

ERME2KAsyncSink.dll 파일은 Simpler-Webb ERM(Exchange Resource Manager)에 필요한 핵심 이진 파일입니다. ERME2KAsyncSink.dll 버전이 1015보다 낮으면 서버에 ERM 버전 1.2 이하가 설치되어 있음을 나타냅니다. 이 경우 Exchange OLE DB가 ERM 이벤트 싱크에서 반환 호출을 기다릴 때 Exchange 로컬 배달 큐가 메시지 배달을 중지시키는 ERM 버전 1.2 관련 문제가 발생합니다. Exchange 저장소가 종료되는 동안 Microsoft Exchange OLEDB가 OnSyncSave 호출로부터 ERME2KAsyncSink.dll 이벤트 싱크가 반환되기를 기다리고 있습니다.

이 호출로부터 반환에 실패하면 Exchange 저장소가 종료되지 않을 수 있습니다. 이 문제는 ERM 버전 1.35에서 해결되었습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 프로그램 추가/제거를 사용하여 ERM 버전 1.2를 수동으로 제거합니다.

  2. Simpler-Webb 웹 사이트(http://www.swinc.com/products/ERM/upgrade/)에서 사용 가능한 ERM 버전 1.35를 설치합니다.

    참고:
    이 항목에는 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 있습니다. 해당 URL은 예고 없이 변경될 수 있습니다.


Sybari Antigen 7.5 for Microsoft Exchange Update for Exchange를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 VSAPI(Virus Scanning Application Programming Interface) 라이브러리 파일이 Microsoft Exchange Information Store 서비스에 등록되었는지 확인할 때 다음 레지스트리 값을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 7.5 for Microsoft Exchange는 Sybari 제품입니다. Antigen 7.5 for Microsoft Exchange를 Exchange 2000 Server나 Exchange Server 2003에 설치하면 Library 레지스트리 항목 값이 ANTIGENVSAPI.DLL이 됩니다. 이 라이브러리 파일은 Antigen 7.5 for Microsoft Exchange에서 다양한 VSAPI 관련 기능을 수행합니다.

또한 Exchange Server Analyzer는 ANTIGENVSAPI.DLL에 대한 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Version 키 값에서 이 파일의 빌드 번호가 1316보다 작을 경우 경고가 표시됩니다.

ANTIGENVSAPI.DLL에 대한 버전 번호가 1316보다 작은 경우 최신 버전의 Antigen 7.5 for Microsoft Exchange가 설치되어 있지 않음을 나타냅니다. Antigen 7.5 for Microsoft Exchange에 대한 소프트웨어 업데이트는 Sybari 웹 사이트에서 구할 수 있습니다. 이 업데이트는 전반적인 성능과 안정성을 향상시켜주므로 설치하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Sybari 웹 사이트를 방문하여 "Licensed Download Center"(http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx)를 참조하십시오.

    참고:
    웹 주소가 변경되어 여기에 언급된 웹 사이트에 연결되지 않을 수도 있습니다.

  2. 사용 중인 버전의 Antigen 7.5 for Microsoft Exchange에 대한 최신 업데이트를 다운로드합니다.

  3. Exchange Server 컴퓨터를 전체 백업합니다.

  4. Antigen 7.5 for Microsoft Exchange에 대한 최신 업데이트를 설치합니다.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Sybari Antigen 8.0 for Microsoft Exchange의 Exchange용 업데이트가 사용 가능합니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-01-09

Microsoft® Exchange Server Analyzer Tool은 VSAPI(Virus Scanning Application Programming Interface) 라이브러리 파일이 Microsoft Exchange Information Store 서비스에 등록되었는지 확인할 때 다음 레지스트리 값을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 8.0 for Microsoft Exchange는 Sybari 제품입니다. Antigen 8.0 for Microsoft Exchange가 Exchange 2000 Server 또는 Exchange Server 2003에 설치되어 있으면 Library 레지스트리 항목의 값은 ANTIGENVSAPIEx.DLL이 됩니다. 이 라이브러리 파일은 Antigen 8.0 for Microsoft Exchange에서 몇몇 VSAPI 관련 기능을 수행합니다.

또한 Exchange Server Analyzer는 ANTIGENVSAPI.DLL에 대한 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Version 키 값에서 이 파일의 빌드 번호가 1517보다 작을 경우 경고가 표시됩니다.

A version number of less than 1517 for ANTIGENVSAPI.DLL에 대한 버전 번호가 1517보다 작은 경우 최신 버전의 Antigen 8.0 for Microsoft Exchange가 설치되어 있지 않음을 나타냅니다. Antigen 8.0 for Microsoft Exchange에 대한 소프트웨어 업데이트는 Sybari 웹 사이트에서 구할 수 있습니다. 이 업데이트는 전반적인 성능과 안정성을 향상시켜주므로 설치하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Sybari 웹 사이트 "Licensed Download Center"(http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx)를 방문하십시오.

    참고:
    웹 주소가 변경되어 여기에 언급된 웹 사이트에 연결되지 않을 수도 있습니다.

  2. 사용 중인 버전의 Antigen 8.0 for Microsoft Exchange에 대한 최신 업데이트를 다운로드합니다.

  3. Exchange Server 컴퓨터를 전체 백업합니다.

  4. Antigen 8.0 for Microsoft Exchange에 대한 최신 업데이트를 설치합니다.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Sybari Antigen이 Exchange 서버에 설치되어 있지만 AntigenStore 서비스가 실행되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Sybari Antigen이 설치되어 있는지 그리고 Exchange Server 컴퓨터에서 AntigenStore 서비스가 실행 중인지 확인할 때 Win32_Service Microsot WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스에서 Started 키에 설정된 값이 True로 설정되었는지 아니면 False로 설정되었는지를 확인할 때도 Win32_Service WMI 클래스를 쿼리합니다.

False 값은 이 Exchange Server 컴퓨터에서 Microsoft Exchange Information Store 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 Microsoft Exchange Information Store 서비스가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스가 실행 중이며 Sybari Antigen이 설치되어 있지만 AntigenStore 서비스가 시작되지 않은 경우 경고를 표시합니다.

Sybari Antigen은 Exchange Server에 바이러스 백신 보호 기능을 제공합니다. 다음은 Sybari AntigenStore 서비스가 중지되는 몇 가지 원인과 그에 따른 해결 방법입니다.

  • Exchange Server에서 실행 중인 소프트웨어가 만료된 평가판 또는 시험판 버전일 수 있습니다. 이 경우 Sybari Antigen을 다시 설치해야 할 수 있습니다. 적어도 소프트웨어를 계속 사용하려면 활성화해야 합니다.

  • 관리자가 Sybari Antigen 서비스를 실수로 중지했을 수 있습니다. 서비스가 자동으로 시작되도록 설정되었는지 확인한 다음 서비스를 시작합니다.

  • 악의적인 웜, 바이러스 또는 기타 프로그램으로 인해 서비스가 중지되었을 수 있습니다. 서비스가 자동으로 시작되도록 설정되었는지 확인한 다음 서비스를 시작합니다. 관련 오류 이벤트 없이 예기치 않게 서비스가 계속 중지되면 컴퓨터가 악의적인 웜에 감염되었는지 확인하고 필요한 경우 시스템을 치료합니다.

일반적으로 SMTP(Simple Mail Transfer Protocol) 게이트웨이나 사서함을 호스팅하는 Exchange 서버에는 메시징 시스템용 바이러스 백신 소프트웨어를 배포하는 것이 좋습니다. 최상의 보호를 위해 게이트웨이에서 들어오는 MIME 메시지를 검색하는 바이러스 백신 소프트웨어를 실행하고 Exchange Server에서는 VSAPI 2.5를 사용하는 검색 프로그램을 실행합니다. 또한 사용자 데스크톱에는 클라이언트 바이러스 백신 소프트웨어를 실행해야 합니다. 게이트웨이나 Exchange 서버에서 메시징 시스템용 바이러스 백신 소프트웨어(MIME을 구문 분석 및 검색할 수 있음)를 실행하는 경우 데스크톱에서 파일 수준의 바이러스 백신 프로그램만 실행해도 충분합니다.

AntigenStore 서비스를 시작하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. AntigenStore 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. AntigenStore 속성 페이지의 일반 탭에서 시작 유형이 자동으로 설정되어 있는지 확인합니다. 그렇지 않은 경우 자동으로 설정하고 적용을 클릭한 다음 확인을 클릭합니다.

  4. AntigenStore 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.

전자 메일로 전송되는 바이러스 및 웜에 대비한 Exchange 환경 보안에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.

Exchange Server에서 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Sybari Antigen이 Exchange 서버에 설치되어 있지만 서비스가 중지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Sybari Antigen이 설치되어 있는지 그리고 Exchange Server 컴퓨터에서 AntigenService 서비스가 실행 중인지 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스에서 Started 키에 설정된 값이 True로 설정되었는지 아니면 False로 설정되었는지를 확인할 때도 Win32_Service WMI 클래스를 쿼리합니다.

False 값은 이 Exchange Server 컴퓨터에서 Microsoft Exchange Information Store 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 Microsoft Exchange Information Store 서비스가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스가 실행 중이며 Sybari Antigen이 설치되어 있지만 AntigenService 서비스가 시작되지 않은 경우 경고를 표시합니다.

Sybari Antigen은 Exchange Server에 바이러스 백신 보호 기능을 제공합니다. 다음은 Sybari Antigen 서비스가 중지되는 일부 원인과 해결 방법입니다.

  • Exchange Server에서 실행 중인 소프트웨어가 만료된 평가판 또는 시험판 버전일 수 있습니다. 이 경우 Sybari Antigen을 다시 설치해야 할 수 있습니다. 적어도 소프트웨어를 계속 사용하려면 활성화해야 합니다.

  • 관리자가 Sybari Antigen 서비스를 실수로 중지했을 수 있습니다. 서비스가 자동으로 시작되도록 설정되었는지 확인한 다음 서비스를 시작합니다.

  • 악의적인 웜, 바이러스 또는 기타 프로그램으로 인해 서비스가 중지되었을 수 있습니다. 서비스가 자동으로 시작되도록 설정되었는지 확인한 다음 서비스를 시작합니다. 관련 오류 이벤트 없이 예기치 않게 서비스가 계속 중지되면 컴퓨터가 악의적인 웜에 감염되었는지 확인하고 필요한 경우 시스템을 치료합니다.

일반적으로 SMTP(Simple Mail Transfer Protocol) 게이트웨이나 사서함을 호스팅하는 Exchange 서버에는 메시징 시스템용 바이러스 백신 소프트웨어를 배포하는 것이 좋습니다. 최상의 보호를 위해 게이트웨이에서 들어오는 MIME 메시지를 검색하는 바이러스 백신 소프트웨어를 실행하고 Exchange 서버에서는 VSAPI 2.5를 사용하는 검색 프로그램을 실행합니다. 또한 클라이언트 컴퓨터에서 바이러스 백신 소프트웨어를 실행해야 합니다. 게이트웨이나 Exchange 서버에서 메시징 시스템용 바이러스 백신 소프트웨어(MIME을 구문 분석 및 검색할 수 있음)를 실행하는 경우 데스크톱에서 파일 수준의 바이러스 백신 프로그램만 실행해도 충분합니다.

AntigenService 서비스를 시작하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. AntigenService 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. AntigenService 속성 페이지의 일반 탭에서 시작 유형이 자동으로 설정되어 있는지 확인합니다. 그렇지 않은 경우 자동으로 설정하고 적용을 클릭한 다음 확인을 클릭합니다.

  4. AntigenService 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.
  • 전자 메일로 전송되는 바이러스 및 웜에 대비한 Exchange 환경 보안에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.

Exchange Server에서 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Symantec Antivirus 정의가 30일 이내에 업데이트되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 다음과 같은 조건에 해당되는지 확인합니다.

  • Symantec Antivirus가 서버에 설치되어 있습니다.

  • 다음 antivirus 정의 파일이 업데이트됩니다.

    HKEY_LOCAL_MACHINE\Software\Symantec\SharedDefs\MicroDefs

Exchange Server Analyzer는 BinHubStamp 레지스트리 키에 대한 값 데이터가 30일 이내에 업데이트되지 않으면 경고를 표시합니다.

Microsoft Exchange Server용 Symantec Antivirus는 바이러스로부터 Exchange Server를 보호합니다. 최신 Symantec Antivirus 정의가 릴리스되면 즉시 다운로드하는 것이 좋습니다. 조직의 다음 레이어에 Antivirus 정의 업데이트를 배포해야 합니다.

  • 메시지 게이트웨이 서버

  • Exchange 서버

  • 클라이언트 워크스테이션

최신 바이러스 정의를 다운로드하려면 Symantec Antivirus 웹 사이트, "Symantec 홈 페이지"(http://www.symantec.com)를 참조하십시오.

전자 메일로 전송되는 바이러스 및 웜에 대비한 Exchange 환경 보안에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결할 수 없을 수도 있습니다.


이 Exchange 서버에 Symantec Antivirus가 설치되어 있지만 서비스가 중지되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 값이 Started 키 값이 설정되어 있는지 여부를 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Win32_Service 클래스는 Symantec Antivirus for Exchange Server가 설치되어 있는지 여부를 결정합니다. Started 키의 True 값은 Symantec Antivirus 서비스가 Exchange Server 컴퓨터에서 실행되고 있음을 나타냅니다. Started 키의 False 값은 Symantec Antivirus 서비스가 Exchange Server 컴퓨터에서 실행되지 않고 있음을 나타냅니다.

Exchange Server Analyzer에서 Symantec Antivirus가 이 Exchange Server 컴퓨터에 설치되어 있지만 Symantec Antivirus 서비스가 시작되지 않은 것을 확인하면 경고를 표시합니다.

Symantec Antivirus는 Exchange Server에 바이러스 백신 보호 기능을 제공합니다. 다음은 Symantec Antivirus 서비스가 중지되는 일부 원인과 해결 방법입니다.

  • Exchange 서버에서 실행 중인 소프트웨어가 만료된 평가판 또는 시험판 버전일 수 있습니다. 이 경우 Symantec Antivirus를 다시 설치해야 합니다. 적어도 소프트웨어를 계속 사용하려면 정품 인증을 받아야 합니다.

  • 관리자가 Symantec Antivirus 서비스를 실수로 중지했을 수 있습니다. 서비스가 자동으로 시작되도록 설정되어 있는지 확인한 다음 서비스를 시작합니다.

  • 악의적인 웜, 바이러스 또는 기타 프로그램으로 인해 서비스가 중지되었을 수 있습니다. 서비스가 자동으로 시작되도록 설정되어 있는지 확인한 다음 서비스를 시작합니다. 관련 오류 이벤트와 관계없이 계속 서비스가 예기치 않게 중지되면 컴퓨터가 악의적인 웜에 감염되어 있는지 확인하고 감염된 시스템을 치료합니다.

SMTP(Simple Mail Transfer Protocol) 게이트웨이나 사서함을 호스팅하는 Exchange 서버에는 메시징 시스템용 바이러스 백신 소프트웨어를 배포하는 것이 좋습니다. 최상의 보호를 위해 게이트웨이에서 들어오는 MIME 메시지를 검색하는 바이러스 백신 소프트웨어를 실행하고 Exchange Server에서는 VSAPI 2.5를 사용하는 검색 프로그램을 실행합니다.

Symantec Antivirus 서비스를 시작하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. Symantec Antivirus 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. Symantec Antivirus 속성 페이지의 일반 탭에서 시작 유형이 자동으로 설정되어 있는지 확인합니다. 그렇지 않은 경우 적용을 클릭한 다음 확인을 클릭합니다.

  4. Symantec Antivirus 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.

또한 사용자 데스크톱에서 클라이언트 바이러스 백신 소프트웨어를 실행해야 합니다. 다음 조건 중 하나가 참인 경우 데스크톱에서 파일 수준의 검색 프로그램은 시스템을 보호하기에 충분합니다.

  • 게이트웨이에서 MIME을 구문 분석하고 검색할 수 있는 메시징 시스템을 위해 디자인된 바이러스 백신 소프트웨어를 실행합니다.

  • Exchange 서버에서 MIME을 구문 분석하고 검색할 수 있는 메시징 시스템을 위해 디자인된 바이러스 백신 소프트웨어를 실행하고 있습니다.

일반적으로 Microsoft Exchange Server 2003과 함께 사용되는 다양한 유형의 바이러스 검색 프로그램에 대한 내용은 Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)를 참조하십시오.

일반적으로 Microsoft Exchange 2000 Server와 함께 사용되는 다양한 유형의 바이러스 검색 프로그램에 대한 자세한 내용은 Microsoft 기술 자료 문서 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)를 참조하십시오.

전자 메일로 전송되는 바이러스 및 웜에 대비한 Exchange 환경 보안에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.


Symantic Mail Security for Exchange 바이러스 백신 검색 구성 경고
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SMSMSE(Symantec Mail Security for Microsoft Exchange) 서비스에 대한 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

True 값은 Symantec Mail Security for Microsoft Exchange Server가 Exchange Server 컴퓨터에 설치되어 있고 SMSMSE 서비스가 실행 중임을 나타냅니다. False 값은 SMSMSE 서비스가 실행되고 있지 않음을 나타냅니다.

또한 Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스에서 Started 키에 설정된 값이 True로 설정되었는지 아니면 False로 설정되었는지를 확인할 때도 Win32_Service WMI 클래스를 쿼리합니다.

False 값은 이 Exchange Server 컴퓨터에서 Microsoft Exchange Information Store 서비스가 실행되고 있지 않음을 나타내며 True 값은 Microsoft Exchange Information Store 서비스가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스가 실행되고 있고 Symantec Mail Security for Microsoft Exchange가 설치되어 있으나 SMSMSE 서비스가 실행되고 있지 않을 경우 경고를 표시합니다.

작업 환경에 심각한 위협이 되는 요인 중 하나는 전자 메일 메시지를 통해 전송되는 바이러스입니다. 전자 메일 바이러스는 컴퓨터 시스템 자체를 공격하거나 시스템에 메시지를 과도하게 보내 오버로드 상태로 만드는 방식으로 전자 메일 환경을 공격할 수 있습니다. 작업 환경에 충분한 바이러스 보호 장치가 있는지 확인해야 합니다. 방화벽에서, SMTP 게이트웨이나 게이트웨이 외부에서, 모든 Exchange 서버 및 모든 클라이언트에서 바이러스 보호 장치를 설치해야 합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터에서 Windows 서비스 스냅인을 시작합니다.

  2. 오른쪽 창에서 Symantec Mail Security for Microsoft Exchange 서비스로 스크롤하여 두 번 클릭합니다.

  3. 시작 유형 드롭다운 상자의 값을 자동으로 설정합니다.

  4. 시작을 클릭하여 Symantec Mail Security for Microsoft Exchange 서비스를 시작합니다.

  5. 확인을 클릭하여 변경 내용을 저장하고 속성 대화 상자를 닫은 후 스냅인을 종료합니다.

전자 메일로 전송되는 바이러스 및 웜에 대비한 Exchange 환경 보안에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.

Exchange Server에서의 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Symantec Mail Security for Microsoft Exchange 4.5 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-02-14

Microsoft® Exchange Server Analyzer Tool은 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Savfmsevsapi.dll의 Version 키 값을 확인합니다. Version 키 값이 이 파일의 빌드 번호로 4.5를 나타내면 경고가 표시됩니다.

Savfmsevsapi.dll의 버전 번호가 4.5이면 Symantec Mail Security for Microsoft Exchange 4.6x의 최신 버전을 실행하고 있지 않음을 나타냅니다. Symantec Mail Security for Microsoft Exchange 4.6x용 소프트웨어 업데이트는 Symantec 웹 사이트에서 구할 수 있습니다. 버전 4.63 이상으로 업그레이드하면 전반적인 성능과 안정성이 향상되므로 업그레이드하는 것이 좋습니다.

Savfmsevsapi.dll의 버전 4.5를 실행하는 경우 다음과 같은 알려진 문제가 발생할 수 있습니다.

  • 일반 작업 중에 Exchange 서버 메일 흐름 프로세스의 성능이 저하될 수 있습니다.

  • 디렉터리 조회 큐 및 로컬 배달 큐와 같은 SMTP 큐가 백업됩니다.

  • Microsoft Exchange Information Store 서비스를 중지할 수 없습니다.

  • Microsoft Outlook® 클라이언트를 Exchange 서버에 연결할 수 없습니다.

  • Outlook 클라이언트에서 메시지를 보내는 경우 일반적으로 Exchange 서버에 메시지를 보내는 것보다 더 오랜 시간이 걸립니다. Outlook 클라이언트가 30초 동안 응답하지 않을 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Symantec 웹 사이트의 Enterprise Support 페이지(http://www.symantec.com/techsupp/enterprise/)를 방문하십시오.

  2. 버전 4.63 이상으로 업그레이드하십시오.
참고:
이 항목에는 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 있습니다. 해당 URL은 예고 없이 변경될 수 있습니다.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, Exchange 및 바이러스 백신 소프트웨어(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, Exchange Server 2003 및 바이러스 백신 소프트웨어 개요(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, 바이러스 백신 소프트웨어가 설치된 Exchange Server 컴퓨터의 문제 해결에 대한 권장 사항(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Trend Micro ScanMail for Microsoft Exchange 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-01-09

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 값을 읽어 VSAPI(Virus Scanning Application Programming Interface) 라이브러리 파일이 Microsoft Exchange Information Store에 등록되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Trend Micro 제품인 ScanMail for Microsoft Exchange가 Exchange 2000 Server 또는 Exchange Server 2003에 설치되어 있는 경우 라이브러리 레지스트리 항목의 값은 SMXS3DLL.DLL입니다. 이 라이브러리 파일은 ScanMail for Microsoft Exchange에서 몇몇 VSAPI 관련 기능을 수행합니다.

또한 Exchange Server Analyzer는 SMXS3DLL.DLL에 대한 Version 키 값을 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Version 키 값에서 이 파일의 빌드 번호가 1174보다 작을 경우 경고가 표시됩니다.

SMXS3DLL.DLL에 대한 버전 번호가 1174보다 작은 경우 최신 버전의 ScanMail for Microsoft Exchange가 설치되어 있지 않음을 나타냅니다. ScanMail for Microsoft Exchange에 대한 소프트웨어 업데이트는 Trend Micro 웹 사이트에서 구할 수 있습니다. 이 업데이트는 전반적인 성능과 안정성을 향상시켜주므로 설치하는 것이 좋습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Trend Micro 웹 사이트, "Update Center, ScanMail for Microsoft Exchange"(http://www.trendmicro.com/download/product.asp?productid=8)를 방문합니다.

  2. 사용 중인 버전의 ScanMail for Microsoft Exchange에 대한 최신 업데이트를 다운로드합니다.

  3. Exchange Server 컴퓨터를 전체 백업합니다.

  4. ScanMail for Microsoft Exchange에 대한 최신 업데이트를 설치합니다.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Trend Micro ServerProtect for Microsoft Windows가 중지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SpntSvc 서비스에 대한 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. SpntSvc 서비스는 Trend Micro 제품인 ServerProtect for Microsoft Windows에 의해 설치됩니다. Started 키의 True 값은 서비스가 실행되고 있음을 나타내고 False 값은 실행되지 않음을 나타냅니다. Exchange Server Analyzer는 SpntSvc 서비스가 시작되지 않았으면 경고를 표시합니다.

ServerProtect for Microsoft Windows는 서버에 대해 실시간 바이러스 감지 및 제거 기능을 포함한 파일 시스템 기반 바이러스 검색 기능을 제공합니다.

SpntSvc 서비스를 시작하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. ServerProtect Server 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. ServerProtect Server 속성 페이지의 일반 탭에서 시작 유형이 자동으로 설정되어 있는지 확인합니다. 그렇지 않은 경우 자동으로 설정하고 적용을 클릭한 다음 확인을 클릭합니다.

  4. ServerProtect Server 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.

Exchange Server에서 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Trend ScanMail 구성: 성능이 향상될 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-09-05

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 TempFileThreshold 값을 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

TempFileThreshold 레지스트리 값은 메시지 본문 및 첨부 파일 검색에 적용할 수 있습니다. 메시지 본문 또는 첨부 파일의 크기가 TempFileThreshold 키에 지정된 값보다 커지면 디스크에 임시 파일이 생성됩니다. 그렇지 않은 경우 임시 파일이 메모리에 생성됩니다. TempFileThreshold의 기본값은 3,072 KB(3 MB)입니다.

또한 Exchange Server Analyzer는 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 TotalPhysicalMemory 키에 설정된 값을 확인합니다. 이 값은 컴퓨터에 설치되어 있는 RAM 크기를 나타냅니다.

뿐만 아니라 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스를 쿼리하여 다음에 위치에 있는 전역 설정 delivContLength 특성 값도 확인합니다.

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganizationName , CN=Global Settings, CN=Message Delivery

이 특성은 들어오는 SMTP 메시지의 최대 크기를 나타냅니다.

Exchange Server Analyzer는 1GB 이상의 RAM이 있는 Exchange Server 컴퓨터에서 TempFileThreshold 값이 최대 받는 메시지 크기의 70%보다 작을 경우 경고를 표시합니다.

이 경고는 TempFileThreshold 레지스트리 값이 작업 환경에 맞게 최적화되지 않은 것을 나타냅니다. 이 값은 적어도 Exchange 서버에 대해 설정한 첨부 파일 크기 제한과 같아야 합니다.

참고:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption을 탐색합니다.

  3. 오른쪽 창에서 TempFileThreshold를 두 번 클릭합니다.

  4. 조직의 평균 메시지 크기와 같은 값(KB)을 입력합니다. 예를 들어 평균 메시지 크기가 10MB이면 10240을 입력합니다.
참고:
이 값을 늘리면 추가 시스템 메모리가 필요할 수도 있습니다. 예를 들어 'ScanningThreads' 값을 8로 설정하고 'TempFileThreshold' 값을 10240으로 설정하면 바어리스 검색에 필요한 최소 메모리는 80MB(ScanningThreads * TempFileThreshold)가 됩니다.
  1. 레지스트리 편집기를 닫고 ScanMail_RealTimeScan 서비스와 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


Trend ScanMail 구성: QuerySender 레지스트리 값이 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-04-20

Microsoft® Exchange Server Analyzer Tool은 Trend Micro ScanMail for Microsoft Exchange ScanMail_Action 서비스에 대한 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 ScanMail_Action 서비스가 실행되고 있음을 나타내고 False 값은 실행되지 않음을 나타냅니다.

또한 Exchange Server Analyzer는 ScanMail for Microsoft Exchange가 Active Directory® 디렉터리 서비스에 대해 와일드카드 문자 검색을 수행하도록 구성되어 있는지 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\QuerySender

QuerySender 레지스트리 항목 값이 0일 경우 와일드카드 검색을 사용할 수 없고 QuerySender 항목 값이 1일 경우 와일드카드 검색을 사용할 수 있습니다.

또한 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열된 항목 개수를 확인할 때도 Active Directory를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다.

Exchange Server Analyzer는 ScanMail_Action 서비스가 실행되고 있고 Exchange Server에 사서함이 100개 이상 포함되어 있으며 QuerySender 레지스트리 항목이 0으로 설정되어 있지 않을 경우 경고를 표시합니다.

Trend Micro ScanMail for Microsoft Exchange는 Exchange Server용 바이러스 백신 프로그램을 제공합니다. Exchange용 ScanMail은 메일 그룹으로 보내진 메시지를 검색할 때 기본적으로 Active Directory 글로벌 카탈로그에서 모든 메시지 받는 사람을 쿼리합니다. 따라서 메일 그룹에 많은 수의 받는 사람이 포함되어 있을 경우 성능 문제가 발생할 수 있습니다. 또한 이 문서에 표시된 권장 사항을 따르지 않으면 다음 성능 카운터의 값이 높아지게 됩니다.

  • MSExchangeIS/Virus Scan Queue Length

  • MSExchangeIS/RPC Requests

  • MSExchangeIS/RPC Averaged Latency

QuerySender 값을 0으로 설정하면 Microsoft Exchange용 ScanMail은 메일 그룹으로 보내진 메시지를 검색할 때 글로벌 카탈로그에서 모든 받는 사람을 쿼리하지 않습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. QuerySender 레지스트리 값 사용에 대한 자세한 내용은 Trend Micro 사이트(http://www.trendmicro.com/en/about/overview.htm)를 참조하십시오.

  2. QuerySender 레지스트리 값에 대한 자세한 내용은 Trend Micro Solution ID 120393(http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-120393)을 참조하십시오.

    참고:
    웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

전자 메일로 전송되는 바이러스 및 웜에 대비한 Exchange 환경 보안에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.

Exchange Server에서의 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.


Trend ScanMail 구성: ScanMail_Monitor 서비스가 클러스터 서비스에 종속되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool은 클러스터의 노드인 각 서버에서 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Version 값이 6.2.000이면 ScanMail for Microsoft Exchange 버전 6.2가 설치되어 있음을 나타냅니다.

또한 Exchange Server Analyzer는 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 클러스터 서비스 ClusSvc의 Started 키 값을 확인합니다. True 값은 클러스터 서비스가 실행되고 있음을 나타내고 False 값은 실행되지 않음을 나타냅니다.

Exchange Server Analyzer는 또한 클러스터의 노드인 각 서버에서 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ScanMail_Monitor

ScanMail_Monitor 키에 값이 ClusSvc인 다중값 레지스트리 항목 DependOnService가 포함되어 있지 않으면 ScanMail_Monitor 서비스가 클러스터 서비스에 종속되지 않은 것입니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고 메시지를 표시합니다.

  • 서버에서 TrendMicro ScanMail for Microsoft Exchange 버전 6.2를 실행하고 있습니다.

  • 서버에서 클러스터 서비스(ClusSvc)를 실행하고 있습니다.

  • ScanMail_Monitor 서비스가 클러스터 서비스에 종속되도록 구성되어 있지 않습니다.

ScanMail for Microsoft Exchange 6.2 빌드를 설치한 후 클러스터 서비스에 종속되도록 ScanMail_Monitor 서비스를 구성해야 합니다. 이 종속성을 구성하지 않으면 노드를 다시 시작할 때마다 클러스터 서비스가 응답을 중지합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Trend Micro 웹 사이트의 ScanMail for Exchange(SMEX) 6.2 패치 1[솔루션 ID: 21441](http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionId=21441&id=21441)을 적용한 후 Microsoft Exchange Cluster 서비스가 예기치 않게 중지되는지 확인합니다.

    참고:
    솔루션 ID 문서 21441은 특히 패치 1을 설치한 후 이 종속성을 반드시 구성해야 한다고 설명하지만 이 문서는 ScanMail for Microsoft Exchange 6.2 빌드를 실행하고 있는 서버에 적용됩니다.

  2. 솔루션 ID 문서 21441의 "Solutions" 섹션에서 설명한 대로 레지스트리에 DependOnService 다중 문자열 값을 추가합니다.
참고:
이 항목에는 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 있습니다. 해당 URL은 예고 없이 변경될 수 있습니다.

기타 Trend Micro 제품 업데이트에 대한 자세한 내용은 Trend Micro Update Center 웹 사이트(http://www.trendmicro.com/download/)를 참조하십시오.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, Exchange 및 바이러스 백신 소프트웨어(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, Exchange Server 2003 및 바이러스 백신 소프트웨어 개요(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, 바이러스 백신 소프트웨어가 설치된 Exchange Server 컴퓨터의 문제 해결에 대한 권장 사항(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Trend ScanMail 구성: SkipWildcardSearchInGC 레지스트리 값이 0으로 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Trend Micro ScanMail for Microsoft Exchange ScanMail_Action 서비스에 대한 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 ScanMail_Action 서비스가 실행되고 있음을 나타내고 False 값은 실행되지 않음을 나타냅니다.

또한 Exchange Server Analyzer는 ScanMail for Microsoft Exchange가 Active Directory® 디렉터리 서비스에 대해 와일드카드 문자 검색을 수행하도록 구성되어 있는지 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SkipWildcardSearchInGC

SkipWildcardSearchInGC 레지스트리 항목 값이 1로 설정되어 있으면 와일드카드 검색을 사용하지 않음을 나타냅니다. SkipWildcardSearchInGC 항목 값이 0으로 설정되어 있으면 와일드카드 검색을 사용함을 나타냅니다.

또한 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열된 항목 개수를 확인할 때도 Active Directory를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다.

Exchange Server Analyzer는 ScanMail_Action 서비스가 실행 중이고 Exchange 서버에 100개 이상의 사서함이 들어 있으며 SkipWildcardSearchInGC 레지스트리 항목이 0으로 설정된 경우 경고를 표시합니다.

Trend Micro ScanMail for Microsoft Exchange는 Exchange Server용 바이러스 백신 프로그램을 제공합니다. SkipWildcardSearchInGC 값을 1로 설정하면 Microsoft Exchange용 ScanMail은 이름 확인 시 와일드카드(*) 문자를 사용할 수 없습니다. 와일드카드를 사용하여 이름을 쿼리하면 Microsoft Exchange용 ScanMail이 전체 디렉터리를 검사하기 때문에 Exchange Server 컴퓨터의 성능이 크게 저하될 수 있습니다. 또한 이 문서에 표시된 권장 사항을 따르지 않으면 다음 성능 카운터의 값이 높아지게 됩니다.

  • MSExchangeIS/Virus Scan Queue Length

  • MSExchangeIS/RPC Requests

  • MSExchangeIS/RPC Averaged Latency

이 경고를 해결하려면 다음을 수행합니다.

  1. SkipWildcardSearchInGC 레지스트리 값 사용 방법에 대해서는 Trend Micro 사이트(http://www.trendmicro.com/en/about/overview.htm)를 참조하십시오.

  2. SkipWildcardSearchInGC 레지스트리 값에 대한 자세한 내용은 "Trend Micro Solution ID 20393"(http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=20393)을 참조하십시오.

    참고:
    웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

전자 메일로 전송되는 바이러스 및 웜에 대비한 Exchange 환경 보안에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.

Exchange Server에서의 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.


Trend ScanMail 구성: MaxMessageCount 레지스트리 항목에 대한 값이 500보다 작습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 MaxMessageCount 값을 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

또한 Exchange Server Analyzer는 각 사서함 저장소의 homeMDBBL 특성에 나열된 항목 수를 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. 이 특성의 개수는 사서함 저장소에 있는 사서함의 수를 나타냅니다.

Exchange Server Analyzer는 Exchange Server에 100개 이상의 사서함이 있고 MaxMessageCount 값이 500보다 작으면 경고를 표시합니다.

Trend Micro ScanMail for Microsoft Exchange는 Exchange Server용 바이러스 백신 프로그램을 제공합니다. Exchange용 ScanMail 검색 스레드가 작업을 완료한 후 검색 결과를 큐에 기록합니다. 해당 큐에 항목이 너무 많으면 검색 스레드는 큐에 기록할 수 있고 스레드를 해제할 수 있을 때까지 대기해야 합니다. 검색 결과 큐 크기 임계값은 MaxMessageCount로 조정합니다. MaxMessageCount 값을 500으로 설정하면 Exchange용 ScanMail의 성능이 최적화됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion을 탐색합니다.

  3. 오른쪽 창에서 MaxMessageCount를 두 번 클릭합니다.

  4. 500(십진수)을 입력합니다.

  5. 레지스트리 편집기를 닫고 ScanMail_RealTimeScan 서비스와 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MaxMessageCount 레지스트리 값 사용에 대한 자세한 내용은 Trend Micro 웹 사이트(http://www.trendmicro.com/en/about/overview.htm)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

전자 메일로 전송되는 바이러스 및 웜에 대비한 Exchange 환경 보안에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.

Exchange Server에서의 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.


Trend ScanMail이 모든 첨부 파일을 삭제하도록 구성되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 여러 레지스트리 항목을 읽어 ScanMail for Microsoft Exchange가 첨부 파일을 삭제하도록 구성되었는지 확인합니다. 레지스트리에서 읽은 값의 위치는 다음과 같습니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

값 | 설명
ActionType | 첨부 파일 차단을 설정한 경우 차단될 첨부 파일을 나타냅니다. 값 0은 첨부 파일이 모두 차단됨을 나타냅니다. 값 3은 관리자가 파일 확장명, 파일 이름 또는 실제 파일 형식 목록을 지정했음을 나타냅니다. ScanMail 관리 콘솔의 Attachment Blocking Settings 대화 상자에서 해당 옵션을 선택하여 이 설정을 구성할 수 있습니다.
EnableAlert | 첨부 파일 차단의 사용 여부를 나타냅니다. 값 1은 첨부 파일 차단이 사용됨을 나타냅니다. 값 0은 사용되지 않음을 나타냅니다. ScanMail 관리 콘솔의 Virus Scan | Options 페이지에서 Enable attachment blocking 확인란을 선택(사용)하거나 선택을 해제(사용 안 함)하여 이 설정을 구성할 수 있습니다.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

값 | 설명
EnableEManager | ScanMail eManager의 사용 여부를 나타냅니다. 값 1은 eManager가 사용됨을 나타냅니다. 값 0은 사용되지 않음을 나타냅니다. ScanMail 관리 콘솔에서 Enable eManager 확인란을 선택(사용)하거나 선택을 해제(사용 안 함)하여 이 설정을 구성할 수 있습니다. 별도의 자매품인 ScanMail eManager를 설치한 경우에만 이 설정을 사용할 수 있습니다.
EnableWebStoreDelMail | 인바운드 메시지에 대해 ScanMail Active Message Filter가 사용되는지 여부를 나타냅니다. 값 1은 인바운드 메시지에 대해 Active Message Filter가 사용됨을 나타냅니다. 값 0은 인바운드 메시지에 대해 사용되지 않음을 나타냅니다. ScanMail 관리 콘솔의 Active Message Filter 대화 상자에서 Inbound Messages 확인란을 선택(사용)하거나 선택을 해제(사용 안 함)하여 이 설정을 구성할 수 있습니다.

또한 Exchange Server Analyzer는 VSAPI(바이러스 검색 API) 메시지 검색을 사용하는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled에 대한 값 1은 VSAPI 검색이 사용됨을 나타냅니다. 값 0은 VSAPI 검색이 사용되지 않음을 나타냅니다. ScanMail 관리 콘솔의 Virus Scan | Options 페이지에서 Enable VS API virus scanning 확인란을 선택(사용)하거나 선택을 해제(사용 안 함)하여 이 설정을 구성할 수 있습니다.

Exchange Server Analyzer는 다음 조건이 모두 참인 경우 경고를 표시합니다.

  • ScanMail for Exchange에서 VSAPI 검색을 사용합니다.

  • EnableAlert의 값은 1입니다.

  • ActionType의 값은 0입니다.

  • EnableEManager의 값은 1입니다.

  • EnableWebStoreDelMail의 값은 1입니다.

이 경고는 ScanMail이 다음 예약 검색 또는 수동 검색 중에 모든 첨부 파일을 삭제하도록 구성되었음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 첨부 파일을 삭제해야 하는지 확인합니다.

  2. 삭제하려면 첨부 파일 차단을 사용하지 않도록 설정하거나 작업을 Delete에서 Quarantine으로 변경합니다. 이렇게 설정하면 관리자가 격리된 파일 중에서 보관해야 하는 첨부 파일이 있는지 조사할 수 있습니다.

ScanMail for Microsoft Exchange 및 ScanMail eManager에 대한 자세한 내용은 Trend Micro 웹 사이트(http://www.trend.com)를 방문하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


Trend ScanMail이 특정 파일 이름을 포함하는 첨부 파일을 삭제하도록 구성되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 몇 가지 레지스트리 항목을 읽어 ScanMail for Microsoft Exchange가 첨부 파일을 삭제하도록 구성되었는지 여부를 확인합니다. 다음 레지스트리의 값을 읽습니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

값 | 설명
ActionType | 첨부 파일 차단을 설정한 경우 차단될 첨부 파일을 나타냅니다. 값 0은 모든 첨부 파일이 차단됨을 나타냅니다. 값 3은 관리자가 파일 이름 확장명, 파일 이름 또는 실제 파일 형식 목록을 지정했음을 나타냅니다. ScanMail 관리 콘솔의 Attachment Blocking Settings 대화 상자에서 원하는 옵션을 선택하여 이 설정을 구성할 수 있습니다.
EnableAlert | 첨부 파일 차단의 사용 여부를 나타냅니다. 값 1은 첨부 파일 차단이 사용됨을 나타냅니다. 값 0은 사용되지 않음을 나타냅니다. ScanMail 관리 콘솔의 Virus Scan | Options 페이지에서 Enable attachment blocking 확인란을 선택(사용)하거나 선택을 해제(사용 안 함)하여 이 설정을 구성할 수 있습니다.
FileName | 삭제될 파일 목록이 들어 있는 세미콜론으로 구분된 문자열 값입니다. 지정된 파일이 차단될 경우 ScanMail 관리 콘솔의 Attachment Blocking Settings 대화 상자에서 원하는 파일 이름을 입력하여 이 설정을 구성할 수 있습니다.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

값 | 설명
EnableEManager | ScanMail eManager의 사용 여부를 나타냅니다. 값 1은 eManager가 사용됨을 나타냅니다. 값 0은 사용되지 않음을 나타냅니다. ScanMail 관리 콘솔에서 Enable eManager 확인란을 선택(사용)하거나 선택을 해제(사용 안 함)하여 이 설정을 구성할 수 있습니다. 별도의 자매품인 ScanMail eManager를 설치한 경우에만 이 설정을 사용할 수 있습니다.
EnableWebStoreDelMail | 인바운드 메시지에 대해 ScanMail Active Message Filter가 사용되는지 여부를 나타냅니다. 값 1은 인바운드 메시지에 대해 Active Message Filter가 사용됨을 나타냅니다. 값 0은 인바운드 메시지에 대해 사용되지 않음을 나타냅니다. ScanMail 관리 콘솔의 Active Message Filter 대화 상자에서 Inbound Messages 확인란을 선택(사용)하거나 선택을 해제(사용 안 함)하여 이 설정을 구성할 수 있습니다.

또한 Exchange Server Analyzer는 VSAPI(바이러스 검색 API) 메시지 검색을 사용하는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 값이 1이면 VSAPI 검색이 사용됨을 나타냅니다. 값 0은 VSAPI 검색이 사용되지 않음을 나타냅니다. ScanMail 관리 콘솔의 Virus Scan | Options 페이지에서 Enable VS API virus scanning 확인란을 선택(사용)하거나 선택을 해제(사용 안 함)하여 이 설정을 구성할 수 있습니다.

Exchange Server Analyzer는 다음 조건이 모두 True로 설정되어 있으면 경고를 표시합니다.

  • ScanMail for Exchange에서 VSAPI 검색을 사용합니다.

  • EnableAlert의 값은 1입니다.

  • ActionType의 값은 3입니다.

  • EnableEManager의 값은 1입니다.

  • EnableWebStoreDelMail의 값은 1입니다.

  • FileName이 Null 또는 비어 있지 않습니다.

이 경고는 ScanMail이 예약된 다음 검색 또는 수동 검색 중에 FileName 키에 나열된 이름을 포함하는 모든 첨부 파일을 삭제하도록 구성되어 있음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. FileName 키에 나열된 이름을 포함하는 첨부 파일을 삭제할지 확인합니다.

  2. 원할 경우 첨부 파일 차단을 비활성화하거나 동작을 삭제에서 격리로 변경합니다. 이렇게 설정하면 관리자가 격리된 파일 중에서 보관해야 하는 첨부 파일이 있는지 조사할 수 있습니다.

ScanMail for Microsoft Exchange 및 ScanMail eManager에 대한 자세한 내용은 Trend Micro 웹 사이트(http://www.trend.com)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


Trend ScanMail이 특정 파일 확장명을 포함하는 첨부 파일을 삭제하도록 구성되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 몇 가지 레지스트리 항목을 읽어 ScanMail for Microsoft Exchange Server가 첨부 파일을 삭제하도록 구성되었는지 여부를 확인합니다. 다음 레지스트리의 값을 읽습니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

값 | 설명
ActionType | 첨부 파일 차단을 설정한 경우 차단될 첨부 파일을 나타냅니다. 값 0은 모든 첨부 파일이 차단됨을 나타냅니다. 값 3은 관리자가 파일 확장명, 파일 이름 또는 실제 파일 형식 목록을 지정했음을 나타냅니다. ScanMail 관리 콘솔의 Attachment Blocking Settings 대화 상자에서 원하는 옵션을 선택하여 이 설정을 구성할 수 있습니다.
EnableAlert | 첨부 파일 차단의 사용 여부를 나타냅니다. 값 1은 첨부 파일 차단이 사용됨을 나타냅니다. 값 0은 사용되지 않음을 나타냅니다. ScanMail 관리 콘솔의 Virus Scan | Options 페이지에서 Enable attachment blocking 확인란을 선택(사용)하거나 선택을 해제(사용 안 함)하여 이 설정을 구성할 수 있습니다.
Extension | 삭제될 첨부 파일의 파일 확장명 목록이 들어 있는 세미콜론으로 구분된 문자열 값입니다. 지정된 첨부 파일이 차단될 경우 ScanMail 관리 콘솔의 Attachment Blocking Settings 대화 상자에서 원하는 확장명을 입력하여 이 설정을 구성할 수 있습니다.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

값 | 설명
EnableEManager | ScanMail eManager의 사용 여부를 나타냅니다. 값 1은 eManager가 사용됨을 나타냅니다. 값 0은 사용되지 않음을 나타냅니다. ScanMail 관리 콘솔에서 Enable eManager 확인란을 선택(사용)하거나 선택을 해제(사용 안 함)하여 이 설정을 구성할 수 있습니다. 별도의 자매품인 ScanMail eManager를 설치한 경우에만 이 설정을 사용할 수 있습니다.
EnableWebStoreDelMail | 인바운드 메시지에 대해 ScanMail Active Message Filter가 사용되는지 여부를 나타냅니다. 값 1은 인바운드 메시지에 대해 Active Message Filter가 사용됨을 나타냅니다. 값 0은 인바운드 메시지에 대해 사용되지 않음을 나타냅니다. ScanMail 관리 콘솔의 Active Message Filter 대화 상자에서 Inbound Messages 확인란을 선택(사용)하거나 선택을 해제(사용 안 함)하여 이 설정을 구성할 수 있습니다.

또한 Exchange Server Analyzer는 VSAPI(바이러스 검색 API) 메시지 검색을 사용하는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 값이 1이면 VSAPI 검색이 사용됨을 나타냅니다. 값 0은 VSAPI 검색이 사용되지 않음을 나타냅니다. ScanMail 관리 콘솔의 Virus Scan | Options 페이지에서 Enable VS API virus scanning 확인란을 선택(사용)하거나 선택을 해제(사용 안 함)하여 이 설정을 구성할 수 있습니다.

Exchange Server Analyzer는 다음 조건이 모두 True로 설정되어 있으면 경고를 표시합니다.

  • ScanMail for Exchange에서 VSAPI 검색을 사용합니다.

  • EnableAlert의 값은 1입니다.

  • ActionType의 값은 3입니다.

  • EnableEManager의 값은 1입니다.

  • EnableWebStoreDelMail의 값은 1입니다.

  • Extension이 Null 또는 비어 있지 않습니다.

이 경고는 ScanMail이 예약된 다음 검색 또는 수동 검색 중에 Extension 키에 나열된 확장명을 포함하는 모든 첨부 파일을 삭제하도록 구성되어 있음을 나타냅니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Extension 키에 나열된 확장명을 포함하는 첨부 파일을 삭제할지 확인합니다.

  2. 삭제하려면 첨부 파일 차단을 사용하지 않도록 설정하거나 작업을 Delete에서 Quarantine으로 변경합니다. 이렇게 설정하면 관리자가 격리된 파일 중에서 보관해야 하는 첨부 파일이 있는지 조사할 수 있습니다.

ScanMail for Microsoft Exchange Server 및 ScanMail eManager에 대한 자세한 내용을 보려면 Trend Micro 웹 사이트(http://www.trend.com)를 방문하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


Trend ScanMail이 프로세스 메시지를 두 번 처리하도록 구성되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 ScanMail_RealTimeScan 서비스의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. True 값은 ScanMail_RealTimeScan 서비스가 시작되었음을 나타내고 False 값은 ScanMail_RealTimeScan 서비스가 시작되지 않았음을 나타냅니다. ScanMail_RealTimeScan 서비스는 Microsoft Exchange 응용 프로그램용 Trend Micro ScanMail의 구성 요소입니다. Trend Micro ScanMail for Microsoft Exchange은 Exchange에 바이러스 백신 프로그램을 제공합니다.

또한 Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Enabled 값의 설정을 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI

Enabled 값이 1인 경우 SMTP(Simple Mail Transfer Protocol) 검색이라고도 하는 전송 수준 바이러스 백신 검색이 활성화되어 있는 것이고 이 값이 0인 경우 SMTP 검색이 비활성화된 것입니다.

Exchange Server Analyzer는 Enabled가 1로 설정되어 있고 ScanMail_RealTimeScan 서비스의 Started 키 값이 True로 설정되어 있을 경우 경고를 표시합니다.

이 경고는 이 Exchange Server에서 나가고 들어오는 메시지가 동일한 응용 프로그램 및 바이러스 검색 엔진에 의해 두 번 검색됨을 나타냅니다. Exchange Server의 전송 및 저장소 구성 요소를 통해 이동되는 메시지가 두 번 검색될 경우 추가적인 보호 기능이나 이점 없이 리소스만 불필요하게 사용됩니다. VSAPI(Virus Scanning API) 바이러스 검색은 활성화하고 ScanMail 관리 콘솔을 사용하여 SMTP 메일 검색은 비활성화하는 것이 좋습니다.

일반적으로 SMTP 게이트웨이나 사서함을 호스팅하는 Exchange 서버에는 메시징 시스템용 바이러스 백신 소프트웨어를 배포하는 것이 좋습니다. 최상의 보호를 위해 게이트웨이에서 인바운드 MIME 메시지를 검색하는 바이러스 백신 소프트웨어를 실행하고 Exchange Server에서는 VSAPI 2.5를 사용하는 검색 프로그램을 실행합니다. 또한 사용자 데스크톱에는 클라이언트 바이러스 백신 소프트웨어를 실행해야 합니다. 게이트웨이나 Exchange 서버에서 메시징 시스템용 바이러스 백신 소프트웨어(MIME을 구문 분석 및 검색할 수 있음)를 실행하는 경우 데스크톱에서 파일 수준의 바이러스 백신 프로그램만 실행해도 충분합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. ScanMail Management Console을 열고 로그온 자격 증명을 입력합니다.

  2. Virus Scan | Options 페이지에서 Enable VS API virus scanning 확인란을 선택합니다.

  3. 같은 페이지에서 Enable SMTP mail scanning 확인란의 선택을 해제합니다.

  4. Apply를 클릭하여 변경 내용을 저장합니다.

  5. ScanMail Management Console을 닫습니다.

Trend Micro ScanMail for Microsoft Exchange에 대한 자세한 내용은 Trend 웹 사이트(http://kb.trendmicro.com/solutions/search)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Exchange 2000용 바이러스 백신 솔루션에 대한 Microsoft의 입장"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=306105)

  • 245822, "바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=245822)


Trend ScanMail 스레드 수 부족
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 MaxScanningThreadCount 값을 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

MaxScanningThreadCount 레지스트리 값은 Exchange용 ScanMail이 검색을 만들 수 있는 스레드의 최대 수를 나타냅니다. 기본값은 12입니다.

또한 Exchange Server Analyzer는 VSAPI(바이러스 검색 API) 메시지 검색을 사용하는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 값이 1이면 VSAPI 검색이 사용됨을 나타냅니다. 값 0은 VSAPI 검색이 사용되지 않음을 나타냅니다.

또한 Exchange Server Analyzer는 NumberOfProcessors 키 값을 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 값은 컴퓨터에 설치된 프로세서 수를 나타내고 실제 프로세서와 논리 프로세서를 모두 포함합니다. Intel의 하이퍼 스레딩 기술을 사용하면 실제 프로세서를 두 개의 논리 프로세서로 분할할 수 있습니다.

또한 Exchange Server Analyzer는 개체 클래스가 msExchPrivateMDB인 개체의 수를 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. 이러한 개체의 개수는 해당 Exchange Server 컴퓨터에 있는 사서함 저장소의 수를 나타냅니다.

Exchange Server Analyzer는 VSAPI 검색이 설정된 Exchange Server 컴퓨터에서 MaxScanningThreadCount 값이 (2 × NumberOfProcessors + 1) + 3 + 사서함 저장소의 수)보다 작을 경우 경고를 표시합니다.

참고:
하이퍼 스레딩을 사용할 수 있는 경우 NumberOfProcessors의 값은 실제 프로세서 수의 두 배가 됩니다. 실제 프로세서와 논리 프로세서를 모두 가진 시스템 뿐만 아니라 실제 프로세서가 있는 시스템에 위 공식을 사용하는 것이 좋습니다.

이 경고는 MaxScanningThreadCount 레지스트리 값이 작업 환경에 맞게 최적화되지 않을 것을 나타냅니다. 이 값은 적어도 Exchange 서버에 대해 설정한 첨부 파일 크기 제한과 같아야 합니다. 관련된 레지스트리 값에 대한 자세한 내용은 Trend ScanMail 스레드 풀 수가 부족합니다.를 참조하십시오.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption을 탐색합니다.

  3. 오른쪽 창에서 MaxScanningThreadCount를 두 번 클릭합니다.

  4. Exchange Server Analyzer에서 권장하는 값을 입력합니다.

  5. 레지스트리 편집기를 닫고 ScanMail_RealTimeScan 서비스와 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MaxScanningThreadCount 레지스트리 값에 대한 자세한 내용은 Trend Micro Solution ID 13176(http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=13176)을 참조하십시오.

하이퍼 스레딩 기술에 대한 자세한 내용은 Intel 웹 사이트(http://www.intel.com/technology/hyperthread)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


Trend ScanMail 스레드 풀 수가 부족합니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-04-21

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 ScanningThreadPoolCount 값을 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

ScanningThreadPoolCount 레지스트리 값은 Exchange용 ScanMail 서비스가 시작될 때 초기화되어 사용 가능 상태가 되는 검색 스레드의 수를 나타냅니다. 기본값은 12입니다. 시작 시 만들어진 스레드가 모두 사용되면 Exchange용 ScanMail은 Trend ScanMail 스레드 수 부족에 설명된 MaxScanningThreadCount 레지스트리 값으로 제어되는 스레드 수에 도달할 때까지 사용될 추가 스레드를 만듭니다.

또한 Exchange Server Analyzer는 VSAPI(바이러스 검색 API) 메시지 검색을 사용하는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 값이 1이면 VSAPI 검색이 사용됨을 나타냅니다. 값 0은 VSAPI 검색이 사용되지 않음을 나타냅니다.

또한 Exchange Server Analyzer는 NumberOfProcessors 키 값을 확인할 때 Win32_ComputerSystem Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 값은 컴퓨터에 설치된 프로세서 수를 나타내고 실제 프로세서와 논리 프로세서를 모두 포함합니다. Intel의 하이퍼 스레딩 기술을 사용하면 실제 프로세서를 두 개의 논리 프로세서로 분할할 수 있습니다.

또한 Exchange Server Analyzer는 개체 클래스가 msExchPrivateMDB인 개체의 수를 확인할 때도 Active Directory® 디렉터리 서비스를 쿼리합니다. 이러한 개체의 개수는 해당 Exchange Server 컴퓨터에 있는 사서함 저장소의 수를 나타냅니다.

Exchange Server Analyzer는 VSAPI 검색이 설정된 Exchange Server 컴퓨터에서 ScanningThreadPoolCount 값이 (2 × NumberOfProcessors + 1) + 3 + 사서함 저장소의 수)보다 작을 경우 경고를 표시합니다.

참고:
하이퍼 스레딩을 사용할 수 있는 경우 NumberOfProcessors의 값은 실제 프로세서 수의 두 배가 됩니다. 실제 프로세서와 논리 프로세서를 모두 가진 시스템 뿐만 아니라 실제 프로세서가 있는 시스템에 위 공식을 사용하는 것이 좋습니다.

이 경고는 ScanningThreadPoolCount 레지스트리 값이 작업 환경에 맞게 최적화되지 않을 것을 나타냅니다. 이 값은 적어도 Exchange 서버에 대해 설정한 첨부 파일 크기 제한과 같아야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption을 탐색합니다.

  3. 오른쪽 창에서 ScanningThreadPoolCount를 두 번 클릭합니다.

  4. Exchange Server Analyzer에서 권장하는 값을 입력합니다.

  5. 레지스트리 편집기를 닫고 ScanMail_RealTimeScan 서비스와 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

하이퍼 스레딩 기술에 대한 자세한 내용은 Intel 웹 사이트(http://www.intel.com/technology/hyperthread)를 참조하십시오.

참고:
웹 주소가 변경되어 해당 웹 사이트나 여기에 언급된 사이트에 연결되지 않을 수도 있습니다.


Trend ScanMail이 디버그 모드입니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-06-22

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 ModuleName 값을 확인합니다.

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\Tools\Debug

ModuleName 레지스트리 값은 사용 중인 디버그 모듈 파일의 이름을 나타냅니다.

또한 Exchange Server Analyzer는 VSAPI(바이러스 검색 API) 메시지 검색을 사용하는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Enabled 값이 1이면 VSAPI 검색이 사용됨을 나타냅니다. 값 0은 VSAPI 검색이 사용되지 않음을 나타냅니다.

Exchange Server Analyzer는 VSAPI 검색을 사용할 수 있게 설정되어 있고 ModuleName 레지스트리 값이 비어 있지 않거나 Null이 아닌 경우 경고를 표시합니다.

디버그 모드에서 실행하면 백그라운드 진단 추적 때문에 성능이 저하될 수 있습니다. 디버그 모드의 ScanMail for Exchange를 실행해도 실제로 문제가 해결되지 않은 경우에는 디버그 모드를 해제해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\TrendMicro\ScanMail for Exchange\Tools\Debug를 탐색합니다.

  3. 오른쪽 창에서 ModuleName을 두 번 클릭합니다.

  4. 문자열을 빈 채로 둔 상태에서 이 항목에 대한 값 데이터를 삭제합니다. ModuleName 키를 삭제하지 않아야 합니다.

  5. 레지스트리 편집기를 닫은 다음 ScanMail_RealTimeScan 서비스와 Microsoft Exchange Information Store 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052)을 참조하십시오.

사용할 수 없는 디버그 모드 확인에 대한 자세한 내용은 http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-119149(영문)의 Trend Micro Solution ID 119149를 참조하십시오.

참고:
이 항목에 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 들어 있습니다. URL은 예고 없이 변경될 수 있습니다.


Trend ScanMail Mail Action 서비스가 이 Exchange 서버에 설치되어 있지만 서비스가 중지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Trend Micro ScanMail for Exchange가 설치되어 있는지 그리고 Exchange 컴퓨터에서 ScanMail_MailAction 서비스가 실행 중인지 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

또한 Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스에서 Started 키에 설정된 값이 True로 설정되었는지 아니면 False로 설정되었는지를 확인할 때도 Win32_Service WMI 클래스를 쿼리합니다.

False 값은 이 Exchange Server 컴퓨터에서 Microsoft Exchange Information Store 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 Microsoft Exchange Information Store 서비스가 실행되고 있음을 나타냅니다.

Exchange Server Analyzer는 Microsoft Exchange Information Store 서비스가 실행 중이며 Trend Micro ScanMail for Exchange가 설치되어 있지만 ScanMail_MailAction 서비스가 시작되지 않은 경우 경고를 표시합니다.

Trend Micro ScanMail for Exchange는 Exchange Server에 바이러스 백신 보호를 제공합니다. 다음은 Trend ScanMail 서비스가 중지되는 일부 원인과 해결 방법입니다.

  • Exchange 서버에서 실행 중인 소프트웨어가 만료된 평가판 또는 시험판 버전일 수 있습니다. 이 경우 Trend ScanMail을 다시 설치해야 합니다. 적어도 소프트웨어를 계속 사용하려면 활성화해야 합니다.

  • 관리자가 ScanMail_MailAction 서비스를 실수로 중지했을 수 있습니다. 서비스가 자동으로 시작되도록 설정되었는지 확인한 다음 서비스를 시작합니다.

  • 악의적인 웜, 바이러스 또는 기타 프로그램으로 인해 서비스가 중지되었을 수 있습니다. 서비스가 자동으로 시작되도록 설정되었는지 확인한 다음 서비스를 시작합니다. 관련 오류 이벤트 없이 예기치 않게 서비스가 계속 중지되면 컴퓨터가 악의적인 웜에 감염되었는지 확인하고 필요한 경우 시스템을 치료합니다.

일반적으로 SMTP(Simple Mail Transfer Protocol) 게이트웨이나 사서함을 호스팅하는 Exchange 서버에는 메시징 시스템용 바이러스 백신 소프트웨어를 배포하는 것이 좋습니다. 최상의 보호를 위해 게이트웨이에서 들어오는 MIME 메시지를 검색하는 바이러스 백신 소프트웨어를 실행하고 Exchange Server에서는 VSAPI 2.5를 사용하는 검색 프로그램을 실행합니다. 또한 사용자 데스크톱에는 클라이언트 바이러스 백신 소프트웨어를 실행해야 합니다. 게이트웨이나 Exchange 서버에서 메시징 시스템용 바이러스 백신 소프트웨어(MIME을 구문 분석 및 검색할 수 있음)를 실행하는 경우 데스크톱에서 파일 수준의 바이러스 백신 프로그램만 실행해도 충분합니다.

ScanMail_MailAction 서비스를 시작하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. ScanMail_MailAction 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. ScanMail_MailAction 속성 페이지의 일반 탭에서 시작 유형이 자동으로 설정되어 있는지 확인합니다. 그렇지 않은 경우 자동으로 설정하고 적용을 클릭한 다음 확인을 클릭합니다.

  4. ScanMail_MailAction 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.
  • 전자 메일로 전송되는 바이러스 및 웜에 대비한 Exchange 환경 보안에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.

Exchange Server에서 바이러스 백신 소프트웨어 사용에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?linkid=16226)를 참조하십시오.


Trend ScanMail 실시간 서비스가 이 Exchange 서버에 설치되어 있지만 서비스가 중지되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Trend Micro ScanMail for Microsoft Exchange 설치 여부와 Exchange Server 컴퓨터에서 ScanMail_RealTimeScan 서비스가 실행 중인지 여부를 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Trend Micro ScanMail for Microsoft Exchange가 설치되어 있지만 ScanMail_RealTimeScan 서비스가 시작되지 않으면 경고를 표시합니다.

Trend Micro ScanMail for Microsoft Exchange은 Exchange에 바이러스 백신 프로그램을 제공합니다. ScanMail_RealTimeScan 서비스를 중지시킨 몇 가지 이유와 해결 방법이 아래에 나와 있습니다.

  • Exchange 서버에서 실행 중인 소프트웨어가 만료된 평가판 또는 시험판 버전일 수 있습니다. 이러한 경우에는 Trend Micro ScanMail for Microsoft Exchange를 다시 설치해야 할 수도 있습니다. 최소한 이 소프트웨어를 계속 사용하려면 활성화해야 합니다.

  • 관리자가 실수로 ScanMail_RealTimeScan 서비스를 중지했을 수도 있습니다. 서비스가 자동으로 시작되도록 설정되었는지 확인한 다음 서비스를 시작합니다.

  • 악의적인 웜, 바이러스 또는 기타 프로그램으로 인해 서비스가 중지되었을 수 있습니다. 서비스가 자동으로 시작되도록 설정되었는지 확인한 다음 서비스를 시작합니다. 관련 오류 이벤트 없이 예기치 않게 서비스가 계속 중지되면 컴퓨터가 악의적인 웜에 감염되었는지 확인하고 필요한 경우 시스템을 치료합니다.

일반적으로 SMTP(Simple Mail Transfer Protocol) 게이트웨이나 사서함을 호스팅하는 Exchange 서버에는 메시징 시스템용 바이러스 백신 소프트웨어를 배포하는 것이 좋습니다. 최상의 보호를 위해 게이트웨이에서 인바운드 MIME 메시지를 검색하는 바이러스 백신 소프트웨어를 실행하고 Exchange 서버에서는 VSAPI(Virus Scanning API) 버전 2.5를 사용하는 검색 프로그램을 실행합니다. 또한 사용자 데스크톱에는 클라이언트 바이러스 백신 소프트웨어를 실행해야 합니다. 게이트웨이나 Exchange 서버에서 메시징 시스템용 바이러스 백신 소프트웨어(MIME을 구문 분석 및 검색할 수 있음)를 실행하는 경우 데스크톱에서 파일 수준의 바이러스 백신 프로그램만 실행해도 충분합니다.

ScanMail_RealTimeScan 서비스를 시작하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. ScanMail_RealTimeScan 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. ScanMail_RealTimeScan 속성 페이지의 일반 탭에서 시작 유형이 자동으로 설정되었는지 확인합니다. 그렇지 않은 경우 자동으로 설정하고 적용을 클릭한 다음 확인을 클릭합니다.

  4. ScanMail_RealTimeScan 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

  5. 서비스 스냅인을 닫습니다.
  • 전자 메일로 전송되는 바이러스 및 웜에 대비한 Exchange 환경 보안에 대한 자세한 내용은 "Exchange Server 2003 환경에서 전자 메일로 전달된 바이러스 확산 지연 및 방지"(http://go.microsoft.com/fwlink/?LinkId=47587)를 참조하십시오.

Exchange Server에서 바이러스 백신 소프트웨어를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 328841, "XADM: Exchange 및 바이러스 백신 소프트웨어"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: 바이러스 백신 소프트웨어가 설치된 Exchange 컴퓨터의 문제 해결에 대한 권장 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Exchange Server에서 사용할 수 있는 타사 바이러스 백신 소프트웨어 목록은 Exchange Server Partners: Antivirus 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=16226)를 참조하십시오.


클라이언트에 타사 추가 기능 해제
Microsoft Exchange Server Analyzer - 문서 > 타사 소프트웨어 >

최근 수정된 항목: 2006-04-21

Microsoft® Exchange Server Analyzer Tool은 사용자가 다음 타사 소프트웨어 유형 중 하나를 실행하고 있음을 확인했습니다.

  • 바이러스 백신 소프트웨어 또는 팩스 소프트웨어와 같은 Microsoft Office Outlook® 타사 추가 기능

  • Exchange 서버에 액세스하는 타사 응용 프로그램

  • 모바일 장치용 타사 동기화 소프트웨어

사용자가 어떤 유형의 타사 응용 프로그램을 실행하고 있는지 조사하고 해당 응용 프로그램을 제한하거나 완전히 제거할지 결정하는 것이 좋습니다. 타사 소프트웨어를 실행하면 서버에 과도한 로드가 발생할 수 있습니다.

Outlook에서 타사 추가 기능을 해제하려면 다음을 수행합니다.

  1. Outlook의 도구 메뉴에서 옵션을 클릭합니다.

  2. 옵션에서 기타, 고급 옵션을 차례로 클릭합니다.

  3. 고급 옵션에서 추가 기능 관리자를 클릭합니다.

  4. 타사 추가 기능 확인란의 선택을 해제합니다.

  5. 확인을 클릭합니다.

  6. Outlook을 다시 시작합니다.

자세한 정보

  • Exchange Server 성능에 대한 자세한 내용은 Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

  • Exchange Server 성능 문제 해결에 대한 자세한 내용은 Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


전송
Microsoft Exchange Server Analyzer - 문서 >

최근 수정된 항목: 2005-11-18

이 섹션의 문서에서는 Exchange 전송 구성 요소와 관련한 Microsoft® Exchange Server Analyzer Tool의 평가에 대해 자세히 설명합니다. 또한 이 문서에서는 Exchange Server Analyzer에서 발견한 전송 관련 오류, 경고 및 기본이 아닌 구성을 해결하기 위해 사용자가 취할 수 있는 작업을 설명합니다.


8BITMIME이 등록되지 않음
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-18

Microsoft® Exchange Server Analyzer Tool은 ESMTP(EHLO Extended Simple Mail Transfer Protocol) 명령 동사를 원격 서버의 포트 25로 전송하고 그 응답을 분석하여 원격 서버에서 8BITMIME ESMTP 동사를 지원하는지 확인합니다.

원격 서버로부터 받은 응답에 '250-8BITMIME' 문자열이 들어 있지 않은 경우 Exchange Server Analyzer에서 경고를 표시합니다.

Exchange Server 2003은 Exchange별 확장 SMTP 동사를 사용하여 Exchange Server를 실행하는 조직의 다른 서버와 통신합니다. 표준 SMTP보다 Exchange별 확장 SMTP 동사를 사용하여 통신하는 것이 더 효율적입니다. ESMTP 명령 집합을 지원하지 않는 경우 Exchange Server 성능이 저하될 수 있습니다.

이 오류는 원격 서버에서 ESMTP 8BITMIME 명령 동사를 지원하지 않음을 나타냅니다. 원격 서버가 Exchange Server인지 여부는 나타내지 않습니다. 두 경우 모두, 8BITMIME 확장이 필요한 메시지가 라우팅되지 않습니다.

이 문제를 해결하려면 SMTP 큐 내용에서 8BITMIME 확장이 필요한 메시지를 확인합니다.

이러한 동사에 대한 기본 지원을 제거하거나 복원하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 257569, "XFOR: Exchange 2000 Server에서 ESMTP 동사(Verb)를 해제하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569)을 참조하십시오.

Exchange Server에서 ESMTP 명령 동사를 사용하는 방법에 대한 자세한 내용은 Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=71800)의 "Exchange SMTP 적절한 로드 방법"을 참조하십시오.


ADAM LDAP Port Identified
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-07-23

Microsoft Exchange Analyzer Tool은 다음 레지스트리 항목을 읽어 Edge 전송 서버의 ADAM(Active Directory Application Mode) 디렉터리 서비스에서 사용되는 포트를 확인합니다.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\LdapPort

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\SslPort

ADAM은 디렉터리 사용 응용 프로그램에 사용하도록 특별히 디자인된 LDAP(Lightweight Directory Access Protocol) 디렉터리 서비스입니다. ADAM은 응용 프로그램 관련 정보만 저장하고 복제하며 도메인 컨트롤러에 배포할 필요가 없고 Active Directory 디렉터리 서비스를 사용하지도 않습니다. ADAM에서는 네트워크 운영 체제 인증 또는 권한 부여를 제공하지 않습니다.

Microsoft Exchange Server 2007에서 Edge 전송 서버 역할은 ADAM을 사용하여 콘텐츠 필터링에 대한 구성 정보 및 받는 사람 데이터를 저장합니다. ADAM을 Active Directory와 동기화하면 ADAM을 사용하여 메시지 보안을 위한 받는 사람 조회를 수행할 수도 있습니다.

데이터는 Active Directory에서 기본 포트가 아닌 다음과 같은 포트를 통한 LDAP 연결을 사용하여 ADAM으로 보내집니다.

  • LDAP: 포트 50389/TCP

  • 보안 LDAP: 포트 50636/UDP

Exchange Analyzer는 ADAM에서 사용되는 포트를 확인하면 모범 사례 메시지를 표시합니다.

외부 액세스에 필요하지 않은 모든 포트를 차단하는 것이 좋습니다.

이 문제를 해결하려면 ADAM에 사용되는 것으로 Exchange Analyzer에서 확인한 포트가 외부 액세스에 대해 열려 있는지 확인합니다.

주의:
포트 50636/UDP는 Exchange EdgeSync 서비스에 사용되므로 EdgeSync 기능이 필요한 경우 계속 열려 있어야 합니다.
Windows 방화벽을 사용하여 확인된 ADAM 포트를 외부 액세스에 대해 차단하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 firewall.cpl을 입력한 다음 확인을 클릭합니다.

  2. 예외 탭을 클릭합니다.

  3. 이름 상자에 나열된 프로그램 또는 서비스를 선택한 다음 편집을 클릭하여 열려 있는 포트를 검토합니다.

  4. ADAM에 사용되는 것으로 Exchange Analyzer에서 보고한 포트가 나열되어 있지 않은지 확인합니다.

  5. 확인된 포트가 나열되어 있으면 해당 포트가 다른 필요한 통신에 사용되고 있지 않음을 확인한 후 서비스 편집 창에서 해당 포트를 선택 취소하여 닫습니다.

  6. 확인을 두 번 클릭하여 Windows 방화벽 구성을 끝냅니다.

추가 정보

Exchange 2007에서 사용하는 모든 데이터 경로의 포트, 인증 및 암호화에 대한 자세한 내용은 "데이터 경로 보안 참조" (http://technet.microsoft.com/ko-kr/library/fec09455-e99e-42eb-8b32-1ddc08d9a19e.aspx)를 참조하십시오.


바이러스 백신 플러그인이 설치됨
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 검색하여 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 플러그인의 설치 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

이 레지스트리 분기가 있으면 Exchange Server를 실행하는 서버에 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 플러그인이 설치되어 있습니다.

또한 Exchange Server Analyzer는 다음 레지스트리 항목을 읽어 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 플러그인의 활성화 여부를 확인합니다.

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

OnOff 값이 1이면 Auto Protect 플러그인이 사용됩니다. 값이 0이면 Auto Protect 플러그인이 사용되지 않습니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고 메시지를 표시합니다.

  • Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 플러그인이 설치되어 있습니다.

  • Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 플러그인이 사용하지 않도록 설정되었습니다.

이 경고는 현재 공급업체의 권장 구성과 비교하여 플러그인의 설치와 구성을 검토해야 함을 나타냅니다.

이 플러그인에 대한 공급업체 권장 구성에 대한 자세한 내용은 "Best practices for Symantec AntiVirus Corporate Edition 9.x Auto-Protect on a Microsoft Exchange server"(http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam)를 참조하십시오.

참고:
이 항목에는 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 있습니다. URL은 예고 없이 변경될 수 있습니다.


바이러스 백신 플러그인이 활성화됨
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 검색하여 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 플러그인의 설치 여부를 확인합니다.

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

이 레지스트리 항목이 있으면 Exchange Server를 실행하는 서버에 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 플러그인이 설치되어 있습니다.

또한 Exchange Server Analyzer는 다음 레지스트리 항목을 읽어 Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 플러그인의 활성화 여부를 확인합니다.

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

OnOff 값이 1이면 Auto Protect 플러그인이 사용됩니다. 값이 0이면 Auto Protect 플러그인이 사용되지 않습니다.

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 플러그인이 설치되어 있습니다.

  • Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect 플러그인이 사용됩니다.

이 오류는 현재 공급업체의 권장 구성과 비교하여 플러그인의 설치와 구성을 검토해야 함을 나타냅니다.

이 플러그인에 대한 공급업체 권장 구성에 대한 자세한 내용은 "Best practices for Symantec AntiVirus Corporate Edition 9.x Auto-Protect on a Microsoft Exchange server"(http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam)를 참조하십시오.

참고:
이 항목에는 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 있습니다. URL은 예고 없이 변경될 수 있습니다.


BCC 저널링이 활성화되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 숨은 참조(Bcc) 저널링이 활성화되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\JournalBCC

Exchange Server Analyzer는 JournalBCC 값이 1로 설정되면 기본 구성이 아니라는 메시지를 표시합니다.

Bcc 저널링은 Bcc 받는 사람을 캡처하는 기능이 추가된 메시지 전용 저널링입니다. Bcc 저널링이 활성화되면 Exchange Server는 보낸 서버에서 알게 되는 Bcc 받는 사람을 포함하여 모든 받는 사람을 캡처합니다. 이 받는 사람 목록에 숨은 메일 그룹, 쿼리 기반 메일 그룹 또는 다른 서버에 확장된 메일 그룹이 있으면 이러한 그룹의 받는 사람은 저널화된 메일에 포함되지 않습니다.

Bcc 저널링 기능은 레지스트리 키를 설정하여 활성화됩니다. 이 레지스트리 키를 설정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 810999, "XADM: Bcc Information Is Lost for Journaled Messages in Exchange 2000"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810999)을 참조하십시오.

특정 서버에서 Bcc 저널링을 활성화하려면 먼저 메시지 전용 저널링을 구성해야 합니다. 다음 조건에서 JournalBCC 설정은 활성화되지 않습니다.

  • JournalBCC 레지스트리가 1로 설정되어 있습니다.

  • 메시지 전용 저널링이 같은 서버의 데이터베이스에서 활성화되지 않았습니다.

저널링 메시지는 다수의 디스크, 네트워크 및 CPU 리소스를 사용할 수 있습니다. 따라서 저널링에는 철저한 배포 계획이 필요합니다. 저널링은 전반적인 저널링 솔루션 프레임워크 컨텍스트에서만 사용할 수 있어야 합니다.

다음 조건이 충족되는 경우 기본 구성이 아니라는 메시지는 무시합니다.

  • 업무에 저널링이 필요합니다.

  • 저널링 솔루션 프레임워크를 배포했습니다.

그렇지 않은 경우 저널링 기능을 해제해야 합니다. 데이터베이스에서 저널링을 해제하면 저널링이 비활성화됩니다.

데이터베이스에서 메시지 전용 저널링을 해제하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, <your Exchange server>, <storage group>을 차례로 확장한 다음 사서함 저장소를 마우스 오른쪽 단추로 클릭합니다.

  2. 일반 탭에서 이 저장소의 사서함에서 주고받은 모든 메시지를 보관 확인란의 선택을 해제합니다.

  3. Exchange 저장소가 변경 사항을 적용할 때까지 15분 동안 기다립니다. Microsoft Exchange Information Store 서비스를 다시 시작할 필요가 없습니다.

Exchange Server Analyzer에서 이 메시지를 다시 표시하지 않도록 하려면 JournalBCC 레지스트리 키를 삭제해야 합니다. 저널링 기능을 비활성화하기 위해 JournalBCC 레지스트리 키를 삭제하지 않아도 됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
JournalBCC 레지스트리 키를 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\를 탐색합니다.

  3. 오른쪽 창에서 JournalBCC 값을 찾아 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server 2003(http://go.microsoft.com/fwlink/?LinkId=47581)을 참조하십시오.


BDAT가 등록되지 않음
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-18

Microsoft® Exchange Server Analyzer Tool은 ESMTP(EHLO Extended Simple Mail Transfer Protocol) 명령 동사를 원격 서버의 포트 25로 전송하고 그 응답을 분석하여 원격 서버에서 BDAT ESMTP 동사를 지원하는지 확인합니다.

원격 서버로부터 검색할 수 없음 오류를 나타내는 문자열이 포함된 응답을 받으면 Exchange Server Analyzer에서 오류를 표시합니다.

Exchange Server 2003은 Exchange별 확장 SMTP 동사를 사용하여 Exchange Server를 실행하는 조직의 다른 서버와 통신합니다. 표준 SMTP보다 Exchange별 확장 SMTP 동사를 사용하여 통신하는 것이 더 효율적입니다. ESMTP 명령 집합을 지원하지 않는 경우 Exchange Server 성능이 저하될 수 있습니다.

이 오류는 원격 서버에서 ESMTP BDAT 명령 동사를 지원하지 않음을 나타냅니다. 원격 서버가 Exchange Server인지 여부는 나타내지 않습니다. 두 경우 모두, BDAT 확장이 필요한 메시지가 라우팅되지 않습니다.

이 문제를 해결하려면 SMTP 큐 내용에서 BDAT 확장이 필요한 메시지를 확인합니다.

이러한 동사에 대한 기본 지원을 제거하거나 복원하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 257569, "XFOR: Exchange 2000 Server에서 ESMTP 동사(Verb)를 해제하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569)을 참조하십시오.

Exchange Server에서 ESMTP 명령 동사를 사용하는 방법에 대한 자세한 내용은 Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkID=71800)의 "Exchange SMTP 적절한 로드 방법"을 참조하십시오.


RGC에 대한 메일 그룹 배달 제한을 검사하는 브리지헤드 서버
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-09-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에서 검색된 각 라우팅 그룹 커넥터 개체(msExchRoutingGroupConnector)의 다음 특성을 쿼리하여 배달 제한이 메일 그룹 구성원을 기반으로 설정되었는지 확인합니다.

dLMemRejectPerms | 해당 구성원이 이 라우팅 그룹 커넥터를 통해 메일을 보낼 수 없는 메일 그룹(DL)의 도메인 이름(DN)을 포함합니다.
dLMemSubmitPerms | 해당 구성원이 이 라우팅 그룹 커넥터를 통해 메일을 보낼 수 있는 메일 그룹(DL)의 DN을 포함합니다.

메일 그룹 구성원을 기반으로 배달 제한이 설정된 라우팅 그룹 커넥터가 있는 경우 Exchange Server Analyzer는 검색된 라우팅 그룹 커넥터의 msExchSourceBridgeheadServersDN 특성을 쿼리하여 분석 중인 서버가 이러한 커넥터의 브리지헤드 서버로 설정되었는지 확인합니다.

마지막으로 Exchange Server Analyzer는 다음 레지스트리 키를 읽어서 CheckConnectorRestrictions 레지스트리 값이 있고 구성되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고 메시지를 표시합니다.

  • 메일 그룹 구성원을 기반으로 배달을 제한하는 데 라우팅 그룹 커넥터가 사용됩니다.

  • 분석 중인 Exchange Server가 라우팅 그룹 커넥터에 대한 브리지헤드 서버로 지정되었으며 메일 그룹 확장을 사용하여 작업이 수행됩니다.

  • CheckConnectorRestrictions 키가 있고 1로 설정되어 활성화되었습니다.

분류기의 기본 동작은 메일 그룹을 반복적으로 확장하고 시스템을 통과하는 각 메시지에 대한 제한을 검사합니다.

라우팅 그룹을 만드는 경우 서로 직접 통신할 수 있는 서버 그룹을 지정합니다. 다른 라우팅 그룹의 서버가 서로 통신하려면 라우팅 그룹을 연결해야 합니다.

이 라우팅 그룹 커넥터는 특히 라우팅 그룹 연결을 위해 디자인되었으므로 기본 연결 방법은 이 커넥터입니다.

라우팅 그룹 커넥터를 통해 메일을 보낼 수 있는 서버는 브리지헤드 서버입니다. 브리지헤드 서버는 커넥터를 통해 모든 메시지를 배달하는 Exchange 서버와 SMTP(Simple Mail Transfer Protocol) 가상 서버의 조합입니다.

라우팅 그룹 커넥터를 만드는 경우 모든 서버를 해당 커넥터의 브리지헤드 서버로 유지하도록 선택하거나 선택한 서버 집합만 해당 커넥터의 브리지헤드 서버 역할을 하도록 지정할 수 있습니다. 지정된 브리지헤드는 메일 그룹 구성원 확장을 사용하여 작업이 수행되는 서버입니다.

메일 그룹 구성원을 기반으로 배달 제한이 설정된 라우팅 그룹 커넥터를 사용하여 메일을 보내는 경우 메시지 분류기가 메일 그룹의 구성원을 확장하고 구성원의 전체 DN 목록을 가져온 다음 DN 목록을 보낸 사람의 DN 목록과 비교해야 합니다. 두 목록의 DN이 일치할 경우 액세스 작업이나 거부 작업이 수행됩니다. 메일 그룹이 다른 메일 그룹에 중첩된 경우 중첩 메일 그룹도 확장됩니다.

이 경고는 메일 그룹 구성원을 기반으로 하는 배달 제한으로 인해 분류기가 제한을 검사할 때 브리지헤드로 보낼 예정인 메시지가 큐에 들어갈 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  • Microsoft 기술 자료 문서 329171, "XADM: Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)에 지시된 대로 로컬 라우팅 그룹에 대해 라우팅 그룹 커넥터를 구성합니다.

  • 보다 강력한 전용 글로벌 카탈로그 서버를 커넥터에 대해 지정된 브리지헤드 서버로 사용합니다.

  • Microsoft 기술 자료 문서 812298, "Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)의 지시에 따라 메일 그룹이 아닌 개별 사서함에 배달 제한을 구성합니다.

  • SMTP 보낸 사람 필터링을 구현합니다.

  • Microsoft Exchange Server 2003 서비스 팩 2(SP2) 이후 버전을 실행하는 서버의 경우 비계층 제한 검사를 구현합니다. Exchange 2003 SP2 이전 버전의 Exchange를 실행하는 서버의 경우 Exchange 2003 SP2로 업그레이드합니다.

자세한 정보

비계층 제한 검사에 대한 자세한 내용은 비계층적인 제한 검사를 고려합니다.를 참조하십시오.

SMTP 보낸 사람 필터링에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=71832)의 "보낸 사람 필터링 사용 설정 방법"을 참조하십시오.

메일 그룹 제한이 Exchange 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 329171 " XADM: Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)

  • 895407 "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 839949 "Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)


SMTP 커넥터에 대한 메일 그룹 배달 제한을 검사하는 브리지헤드 서버
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-21

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에서 검색된 각 SMTP(Simple Mail Transfer Protocol) 커넥터 개체(msExchRoutingSMTPConnector)의 다음 특성을 쿼리하여 메일 그룹 구성원을 기반으로 설정된 배달 제한이 있는지 확인합니다.

dLMemRejectPerms | 해당 구성원이 이 SMTP 커넥터를 통해 메일을 보낼 수 없는 메일 그룹(DL)의 도메인 이름(DN)을 포함합니다.
dLMemSubmitPerms | 해당 구성원이 이 SMTP 커넥터를 통해 메일을 보낼 수 있는 메일 그룹(DL)의 DN을 포함합니다.

메일 그룹 구성원을 기반으로 배달 제한이 설정된 SMTP 커넥터가 있는 경우 Exchange Server Analyzer는 검색된 SMTP 커넥터의 msExchSourceBridgeheadServersDN 특성을 쿼리하여 분석 중인 서버가 이러한 커넥터의 브리지헤드 서버로 설정되었는지 확인합니다.

마지막으로 Exchange Server Analyzer는 다음 레지스트리 키를 읽어서 CheckConnectorRestrictions 레지스트리 값이 있고 구성되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고 메시지를 표시합니다.

  • 메일 그룹 구성원을 기반으로 배달을 제한하는 데 SMTP 커넥터가 사용됩니다.

  • 분석 중인 Exchange Server가 SMTP 커넥터에 대한 브리지헤드 서버로 지정되었으며 메일 그룹 확장을 사용하여 작업이 수행됩니다.

  • CheckConnectorRestrictions 키가 있고 1로 설정되어 활성화되었습니다.

분류기의 기본 동작은 메일 그룹을 반복적으로 확장하고 시스템을 통과하는 각 메시지에 대한 제한을 검사합니다.

메일 그룹의 메시지를 수락하거나 거부하는 커넥터를 사용하여 메일을 보내는 경우 메시지 분류기가 메일 그룹의 구성원을 확장하고 구성원의 전체 DN 목록을 가져온 다음 DN 목록을 보낸 사람의 DN 목록과 비교해야 합니다. 두 목록의 DN이 일치할 경우 액세스 작업이나 거부 작업이 수행됩니다. 메일 그룹이 다른 메일 그룹에 중첩된 경우 중첩 메일 그룹도 확장됩니다.

지정된 브리지헤드는 메일 그룹 구성원 확장을 사용하여 작업이 수행되는 서버입니다.

제한 검사 작업은 검사할 커넥터의 원본에 해당하는 Exchange 브리지헤드 서버에서 설정되어야 하는 CheckConnectorRestrictions 레지스트리 값에 의해 제어됩니다. 제한을 지정했지만 CheckConnectorRestrictions 레지스트리 값을 만들지 않으면 제한이 검사되지 않습니다.

기본적으로 커넥터 제한 검사는 해제되어 있습니다. 메일 그룹을 확장하고 시스템을 통과하는 각 메시지에 대한 제한 사항을 검사하는 경우 시스템 성능이 훨씬 느려집니다.

이 경고는 메일 그룹 구성원을 기반으로 하는 배달 제한으로 인해 분류기가 제한을 검사할 때 브리지헤드로 보낼 예정인 메시지가 큐에 들어갈 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  • Microsoft 기술 자료 문서 329171, "XADM: Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)의 지시에 따라 커넥터 제한의 전용 라우팅 그룹을 디자인하고 로컬 라우팅 그룹에 대해 구성합니다.

  • 보다 강력한 전용 글로벌 카탈로그 서버를 커넥터에 대해 지정된 브리지헤드 서버로 사용합니다.

  • Microsoft 기술 자료 문서 812298, "Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)의 지시에 따라 메일 그룹이 아닌 개별 사서함에 배달 제한을 구성합니다.

  • SMTP 보낸 사람 필터링을 구현합니다.

  • Microsoft Exchange Server 2003 서비스 팩 2(SP2) 이후 버전을 실행하는 서버의 경우 비계층 제한 검사를 구현합니다. Exchange 2003 SP2 이전 버전의 Exchange를 실행하는 서버의 경우 Exchange 2003 SP2로 업그레이드합니다.

자세한 정보

비계층 제한 검사에 대한 자세한 내용은 비계층적인 제한 검사를 고려합니다.를 참조하십시오.

SMTP 보낸 사람 필터링에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=71832)의 "보낸 사람 필터링 사용 설정 방법"을 참조하십시오.

메일 그룹 제한이 Exchange 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 329171 " XADM: Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)

  • 895407 "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 839949 "Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)


포트 25의 라우팅 마스터에 연결할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-24

Microsoft® Exchange Server Analyzer Tool은 현재 관리 그룹의 각 라우팅 그룹에 대한 msExchRoutingMasterDN 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 그런 다음 Exchange Server Analyzer는 TCP 포트 25의 라우팅 마스터에 대한 소켓 연결을 열려고 합니다. Exchange Server Analyzer가 25 Available이라는 예정된 사용자 지정 응답을 받지 못하면 오류가 표시됩니다.

이 오류는 TCP 포트 25에 라우팅 마스터가 액세스할 수 없으므로 결과적으로 라우팅이 실패할 수도 있음을 나타냅니다. 이 오류를 해결하려면 라우팅 마스터의 연결 문제를 해결하거나 새 라우팅 마스터를 할당하면 됩니다.

라우팅 마스터의 연결 문제를 해결하려면 다음을 수행합니다.

  1. 라우팅 마스터의 포트 25에 텔넷을 연결할 수 있습니까? 그렇지 않으면 네트워크에는 문제가 없습니다.

  2. 모두 플러그에 꽂혀 있습니까? 모든 하드웨어가 올바르게 작동됩니까?

  3. DNS가 올바르게 작동되고 구성되어 있습니까?

  4. 라우터가 올바르게 작동됩니까?

  5. 연결을 차단하는 방화벽 또는 응용 프로그램이 있습니까?
새 라우팅 마스터를 할당하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 왼쪽 창의 트리 맨 위에 있는 조직 이름(Exchange) 아이콘을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다. 여기서 조직 이름은 Exchange 2000 조직에 대해 선택한 이름입니다.

  3. 관리 그룹 표시, 라우팅 그룹 표시, 확인을 차례로 클릭합니다.

  4. 관리 그룹, <AdministrativeGroup>, 라우팅 그룹을 차례로 확장합니다.

  5. 라우팅 그룹을 확장한 다음 구성원을 클릭합니다.

  6. 오른쪽 창에서 라우팅 그룹 마스터로 구성할 Exchange 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 마스터로 설정을 클릭합니다.

라우팅 문제 해결, 라우팅 토폴로지 구성 및 고급 라우팅 개념에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)에서 "라우팅 문제 해결"을 참조하십시오.


포트 691의 라우팅 마스터에 연결할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-24

Microsoft® Exchange Server Analyzer Tool은 현재 관리 그룹의 각 라우팅 그룹에 대한 msExchRoutingMasterDN 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 그런 다음 Exchange Server Analyzer는 TCP 포트 691의 라우팅 마스터에 대한 소켓 연결을 열려고 합니다. Exchange Server Analyzer가 691 Available이라는 예정된 사용자 지정 응답을 받지 못하면 오류가 표시됩니다.

이 오류는 TCP 포트 691에 라우팅 마스터가 액세스할 수 없으므로 결과적으로 라우팅이 실패할 수도 있음을 나타냅니다. 이 오류를 해결하려면 라우팅 마스터의 연결 문제를 해결하거나 새 라우팅 마스터를 할당하면 됩니다.

라우팅 마스터의 연결 문제를 해결하려면 다음을 수행합니다.

  1. 라우팅 마스터의 포트 691에 텔넷을 연결할 수 있습니까? 그렇지 않으면 네트워크에는 문제가 없습니다.

  2. 모두 플러그에 꽂혀 있습니까? 모든 하드웨어가 올바르게 작동됩니까?

  3. DNS가 올바르게 작동되고 구성되어 있습니까?

  4. 라우터가 올바르게 작동됩니까?

  5. 연결을 차단하는 방화벽이 있습니까?
새 라우팅 마스터를 할당하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 왼쪽 창의 트리 맨 위에 있는 조직 이름(Exchange) 아이콘을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다. 여기서 조직 이름은 Exchange 2000 조직에 대해 선택한 이름입니다.

  3. 관리 그룹 표시, 라우팅 그룹 표시, 확인을 차례로 클릭합니다.

  4. 관리 그룹, <AdministrativeGroup>, 라우팅 그룹을 차례로 확장합니다.

  5. 라우팅 그룹을 확장한 다음 구성원을 클릭합니다.

  6. 오른쪽 창에서 라우팅 그룹 마스터로 구성할 Exchange 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 마스터로 설정을 클릭합니다.

라우팅 문제 해결에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "라우팅 문제 해결"을 참조하십시오.


'호스트' 또는 'MX' 레코드를 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-05-10

Microsoft Exchange Analyzer Tool은 DNS(Domain Name System) 조회를 수행하여 도메인의 메일 교환기(MX) 레코드를 검색합니다. Exchange Analyzer가 DNS 서버에서 도메인의 MX 레코드를 검색할 수 없으면 DNS 조회를 수행하여 Exchange 서버가 메시지를 보내려는 도메인의 호스트(A) 레코드를 검색합니다.

Exchange Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • Exchange Analyzer가 도메인의 MX 레코드를 검색할 수 없는 경우

  • DNS 조회 작업에서 호스트(A) 레코드 중 하나의 IP 주소를 반환하지 못하는 경우

이 오류는 도메인 및 서버의 DNS 메일 교환기(MX) 및 Host(A) 레코드가 누락되었음을 나타냅니다. 이 오류로 인해 원격 도메인에 보낼 메시지가 다른 라우팅 또는 서비스 지연과 함께 Exchange 서버 원격 배달 큐에 백업될 수 있습니다.

보내는 Exchange 서버는 메일 호스트를 확인하기 위해 MX 레코드를 확인합니다. 그런 다음 보내는 서버는 주소 레코드(A 레코드)를 확인하여 IP 주소에 대한 MX 레코드를 확인합니다.

메일 교환기(MX) 및 호스트(A) 레코드의 DNS 조회는 다음 이유로 인해 실패할 수 있습니다.

  • 네트워크 오류 또는 다른 이유 때문에 DNS 서버가 중지되거나 DNS 서버에 연결할 수 없습니다.

  • 원격 서버의 호스트(A) 레코드를 사용할 수 없거나 잘못되었기 때문에 해당 레코드가 DNS 서버에서 누락되었습니다.

  • DNS 서버가 동적 호스트 레코드 업데이트가 가능하도록 구성되지 않았습니다.

  • 시스템은 원래 도메인을 가장할 수 있는 스팸 메시지에 대한 응답으로 배달 못 함 보고서(NDR)를 보내려고 합니다. 이 경우에는 해당 메시지를 삭제해야 합니다. 이 문서의 자세한 정보 섹션에 있는 Exchange Server Badmail 삭제 및 보관 도구에 대한 링크를 참조하십시오.

DNS 서버가 온라인 상태인지와 MX 및 호스트 레코드가 있는지 확인하려면 다음을 수행합니다.

  1. 다음 확인 작업 중 하나 이상을 수행하여 DNS 서버가 실행되고 있는지 확인합니다.

    • DNS 서버의 DNS 관리 프로그램에서 DNS 서버 상태를 확인합니다.

    • DNS 서버를 다시 시작합니다. 자세한 내용은 "DNS 서버 시작, 중지, 일시 중지 및 다시 시작"(http://go.microsoft.com/fwlink/?LinkId=62999)을 참조하십시오.

    • nslookup 명령을 사용하여 DNS 서버 응답 기능을 확인합니다. 자세한 내용은 "nslookup 명령을 사용하여 DNS 서버 응답 기능 확인"(http://go.microsoft.com/fwlink/?LinkId=63000)의 설명을 참조하십시오.

  2. nslookup을 사용하여 메일 교환기(MX) 레코드가 올바르게 구성되었는지 확인합니다. 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "DNS 디자인 및 구성 확인" 섹션에 있는 "Nslookup을 사용하여 MX 레코드 구성 확인 방법"을 참조하십시오.

  3. nslookup을 사용하여 호스트(A) 레코드가 DNS 서버에 있는지 확인합니다. 자세한 내용은 "A 리소스 레코드가 DNS에 있는지 확인하려면"(http://go.microsoft.com/fwlink/?LinkId=63001)을 참조하십시오.

  4. 호스트(A) 리소스 레코드가 없으면 수동으로 A 리소스 레코드를 추가 또는 수정하거나 동적 레코드 업데이트가 가능하도록 DNS 서버를 구성합니다.

    • 수동으로 A 리소스 레코드를 추가합니다. 자세한 내용은 "DNS 영역에 리소스 레코드 추가"(http://go.microsoft.com/fwlink/?LinkId=63002)를 참조하십시오.

    • 수동으로 A 리소스 레코드를 수정합니다. "기존 리소스 레코드 수정"(http://go.microsoft.com/fwlink/?LinkId=63014)의 설명을 참조하십시오.

    • 동적 호스트 레코드 업데이트가 가능하도록 DNS 서버를 구성합니다. 자세한 내용은 Microsoft 기술 자료 문서 816592, "Windows Server 2003에서 DNS 동적 업데이트를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)을 참조하십시오.

자세한 정보

  • Exchange Server 2003이 DNS를 사용하여 외부 IP 주소를 확인하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "Exchange Server 2003 전송 종속성"을 참조하십시오.

  • DNS 이름 확인에 대한 자세한 내용은 Microsoft 기술 자료 문서 322856, "HOWTO: Exchange Server 사용을 위한 DNS 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)을 참조하십시오.

  • DNS 문제 해결에 대한 자세한 내용은 "DNS 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=63003)을 참조하십시오.

  • Exchange Server 2003 시스템 모니터링에 대한 자세한 내용은 MOM 2005용 Exchange Server 2003 관리 팩(http://go.microsoft.com/fwlink/?LinkId=47573)의 "Exchange 관리 팩을 사용하여 시스템 모니터링"을 참조하십시오.

  • 호스트(A) 리소스 레코드에 대한 자세한 내용은 "리소스 레코드 관리"(http://go.microsoft.com/fwlink/?LinkId=63004)를 참조하십시오.

  • Exchange Server Badmail 삭제 및 보관에 대한 자세한 내용은 " Exchange Server Badmail Deletion and Archiving"(http://go.microsoft.com/fwlink/?LinkId=84239)을 참조하십시오.


보낸 사람을 확인할 수 없음
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-08

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에서 모든 사용자 개체의 proxyAddress 특성 값을 쿼리하여 사용자 지정 로컬 보낸 사람 SMTP(Simple Mail Transfer Protocol) 주소에 일치하는 항목이 있는지 확인합니다.

사용자 지정 로컬 보낸 사람 SMTP 주소에 일치하는 proxyAddress를 찾을 수 없는 경우 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 다음 조건 중 하나에 해당함을 나타냅니다.

  • 로컬 Exchange Server 조직에 로컬 보낸 사람이 없습니다.

  • 사용자 지정 로컬 보낸 사람 SMTP 주소가 잘못 입력되었습니다.

이 오류를 해결하려면 지정된 로컬 보낸 사람 SMTP 주소를 확인하고 다시 작업해 보십시오.

로컬 보낸 사람의 주소를 확인하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 받는 사람, 모든 전체 주소 목록을 차례로 확장합니다.

  3. 기본 전체 주소 목록을 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  4. 미리 보기를 클릭하여 기본 전체 주소 목록에 포함된 받는 사람의 SMTP 주소를 표시합니다.

  5. 지정된 로컬 보낸 사람이 표시되는지 확인하고 SMTP 주소를 기록해 둡니다.


CatDbgSink Event Sink가 설치되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 인터넷 정보 서비스(IIS) 메타베이스의 LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes 속성에 있는 데이터를 읽어 CatDbgSink 메일 흐름 진단 응용 프로그램이 Exchange 2000 Server 또는 Exchange Server 2003을 실행 중인 컴퓨터에 설치되어 있는지 확인합니다.

CatDbgSink 응용 프로그램은 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 메일 흐름 문제를 해결하는 데 사용할 수 있는 이벤트 싱크입니다. CatDbgSink 응용 프로그램이 Exchange 서버에 설치되어 있으면 Exchange Server Analyzer는 CatDbgSink 응용 프로그램이 설치되어 있고 메일 흐름 문제를 해결할 경우에만 사용되어야 함을 나타내는 경고를 표시합니다.

Exchange 2000 Server 및 Exchange Server 2003 컴퓨터 모두의 메일 흐름 문제 해결을 위해 일반적으로 CatDbgSink 응용 프로그램을 고객에게 전송합니다. CatDbgSink 응용 프로그램은 일반적으로 Microsoft 기술 지원 서비스(PSS)의 안내에 따라 설치합니다. CatDbgSink 응용 프로그램을 설치하고 등록을 완료한 후에 고객은 CatDbgSink 응용 프로그램을 사용하여 Exchange 서버의 메일 흐름 문제에 대한 해결 방법을 수집하는 로그 파일을 작성합니다.

문제를 격리하고 해결한 후에도 프로덕션 Exchange 서버에서 CatDbgSink 응용 프로그램을 제거하지 못할 수 있습니다. CatDbgSink 응용 프로그램을 Exchange 컴퓨터에서 제거하지 않으면 CatDbgSink 응용 프로그램은 Exchange 서버에서 예기치 않은 성능 문제를 발생시키는 상당한 로드를 만듭니다. 프로덕션 Exchange 서버에서 메일 흐름 문제를 진단한 후에 CatDbgSink 응용 프로그램을 제거해야 합니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 로컬 CatDbgSink 설치 폴더를 찾습니다. 이 폴더에는 Setup.vbs, CatDbgSink.dll, CatDbgSink.pdb 및 MustReadMe.txt 설치 정보 파일이 들어 있습니다.

  2. 명령 프롬프트 창에서 디렉터리를 설치 정보 파일의 로컬 드라이브 위치(예: \CatDbgSink)로 변경합니다.

  3. 명령 프롬프트에 cscript setup.vbs uninstall 1 을 입력합니다.
참고:
명령줄 번호 1은 SMTP 가상 서버 인스턴스(1부터 시작)를 지정합니다.

CatDbgSink 응용 프로그램에 대한 자세한 내용은 Microsoft 기술 지원 서비스(http://support.microsoft.com/default.aspx?pr=cntactms)에 문의하십시오.


SMTP 인스턴스에 대해 분류기가 사용되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 인터넷 정보 서비스(IIS) 메타베이스의 LM/SmtpSvc/%SMTPInstance%/RoutingSources 속성에 있는 데이터를 읽어 Exchange 2000 Server 또는 Exchange Server 2003을 실행 중인 컴퓨터에서 각 SMTP VSI(가상 서버 인스턴스)의 메시지 분류기 상태를 확인합니다.

Exchange Server Analyzer는 IIS 메타베이스에 SMTPDSUseCat 키가 있는지 확인한 다음 결과를 보고합니다. Exchange Server Analyzer는 SMTPDSUseCat이 있고 사용 안 함(0X000000)으로 설정되어 있음을 확인하면 오류를 표시합니다. 메시지 분류기가 사용되지 않으면 Exchange 서버에는 메일 흐름 문제가 발생합니다.

기본적으로 Microsoft Windows® 2000 Server 또는 Microsoft Windows Server™ 2003을 실행하고 있는 컴퓨터에 SMTP 서비스가 설치되어 있으면 IIS 메타베이스에 SMTPDSUseCat 키가 만들어집니다. 기본적으로 SMTPDSUseCat 키는 사용되지 않습니다(0). Exchange Server를 설치하면 SMTPDSUseCat IIS 메타베이스 키가 제거됩니다. 이렇게 되면 메시지 분류기가 사용됩니다. Windows 2000 Server 또는 Windows Server 2003을 실행하고 있는 컴퓨터에 SMTP 서비스 또는 Exchange Server를 설치하면 기본 (1) STMP VSI가 만들어집니다. Exchange Server가 설치되어 있고 SMTP 서비스를 제거했다가 컴퓨터에 다시 설치한 경우 메시지 분류기가 사용 가능하지 않게 될 수 있습니다. 타사 소프트웨어가 설치되어 있거나 관리 구성 오류가 발생할 경우에도 메시지 분류기가 사용되지 않을 수 있습니다.

참고:
Exchange 서버의 각 SMTP 가상 서버 인스턴스는 메시지 분류기 상태를 독립적으로 제어합니다.

메시지 분류기는 각 SMTP VSI로 들어오는 모든 메시지를 검사하고 옵션을 확인합니다. 메시지는 로컬 저장소로 전송되거나 메시지 전송 에이전트(MTA) 또는 SMTP를 통해 원격 호스트로 전송될 수 있습니다. 메시지 분류기는 메일 그룹(DL) 확장도 처리합니다. 메시지 분류기는 SMTP 서버로 들어오는 메시지를 검사하고 메시지를 어떻게 처리할 것인지 결정합니다. 메시지 분류기는 TCP 포트 3268의 글로벌 카탈로그 서버를 대상으로 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 고급 큐 엔진에 대한 플러그 인으로, 기본적으로 고급 큐 엔진을 통과하는 모든 메시지에서 고급 주소 확인을 수행하는 이벤트 싱크 모음입니다.

참고:
SMTP 재설치 도구(Smtpreinstall.exe)는 Exchange 2000 Server SP2 CD-ROM의 \SUPPORT\UTILS\I386 폴더에 있습니다.
SMTP 재설치 도구를 사용하여 메시지 분류기를 사용 가능하도록 설정하려면 다음을 수행합니다.

  1. Smtpreinstall.exe를 \Exchsrvr\Bin 폴더에 복사합니다.

  2. \Exchsrvr\Bin 폴더에서 Smtpreinstall.exe를 두 번 클릭합니다.

  3. Microsoft Exchange SMTP 재설치 대화 상자에서 확인을 클릭하여 Exchange 서버를 다시 시작합니다.

IIS 메타베이스의 속성을 확인해야 할 경우에는 IIS 4.0/5.0용 Metaedit 2.2 유틸리티 또는 IIS 6.0의 IIS Metabase Explorer 유틸리티를 설치하면 됩니다.

주의:
메타베이스는 직접 편집하지 않는 것이 좋습니다.

메시지 분류기 또는 사용 가능한 IIS 메타베이스 유틸리티에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 290290, "XIMS: IIS SMTP 서비스를 다시 설치하면 메일을 보낼 수 없다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=290290)

  • 319885, "XCON: Messages Sent in the Exchange 2000 Server Organization Are Not Delivered"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319885)

  • 231729, "XCON: DSUseCat Key and the Message Categorizer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231729)

  • 232068, "HOWTO: IIS MetaEdit 2.1 유틸리티의 다운로드, 설치 및 제거 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232068)

IIS 6.0 Resource Kit 도구를 다운로드하려면 Internet Information Services (IIS) 6.0 Resource Kit Tools(http://go.microsoft.com/fwlink/?LinkId=33134)를 참조하십시오.


분류기 경고 이벤트(ID: 6004)가 최근 24시간 이내 기록됨
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-05

Microsoft® Exchange Server Analyzer Tool은 Win32_NTLogEvent Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 MSExchangeTransport에 대한 이벤트 6004 경고가 최근 24시간 이내 기록되었는지 확인합니다.

Exchange Server Analyzer는 MSExchangeTransport에 대한 이벤트 6004 경고가 최근 24시간 이내 기록된 것을 확인하면 경고를 표시합니다.

이 경고는 분류기가 메시지를 처리할 때 오류가 발생했음을 나타냅니다.

메시지 분류기는 SMTP(Simple Mail Transfer Protocol) 서버에 도착하는 메시지를 검토하고 메시지의 처리 방법을 결정합니다. 메시지는 로컬 정보 저장소로 보내거나 MTA(메시지 전송 에이전트) 또는 SMTP를 사용하여 원격 호스트로 보낼 수 있습니다. 또한 분류기는 메일 그룹 확장을 처리합니다. 분류기는 TCP 포트 3268의 글로벌 카탈로그 서버를 대상으로 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 고급 큐 엔진에 대한 플러그 인으로, 기본적으로 고급 큐 엔진을 통과하는 모든 메시지에서 고급 주소 확인을 수행하는 이벤트 싱크 모음입니다. 분류기는 주소 확인, 메일 전달, 콘텐츠 변환 플래그 설정, 메일 그룹 확장, 전역 설정 적용, 배달 상태 알림 생성 등의 작업을 수행합니다. 또한 대리 수신자 경로를 검색하고 분기, 저널링 등의 여러 기능을 수행합니다.

메시지 분류기에 메시지가 도착하면 분류기는 Active Directory® 디렉터리 서비스의 프록시 주소 특성에서 주소를 검색하여 봉투를 보낸 사람을 확인합니다. 또한 분류기는 Active Directory의 프록시 주소 특성에서 각 주소를 검색하여 봉투를 받는 사람을 확인합니다. 예를 들어 목록에 메일 그룹이 포함되어 있으면 분류기는 메일 그룹 확장이 서버에서 허용된 경우 해당 구성원을 포함하도록 목록을 확장합니다.

Possible causes of MSExchangeTransport 경고 이벤트 6004는 다음과 같습니다.

  • DSAccess(디렉터리 서비스 액세스) 문제

  • 디렉터리 복제 지연 또는 실패

  • 오버로드된 글로벌 카탈로그 서버

  • DNS 문제

이 경고를 해결하려면 다음을 수행하십시오.

  • Exchange Server가 하나 이상의 글로벌 카탈로그 서버에 연결되어 있는지 확인합니다. 이 작업에는 Windows의 네트워크 모니터 도구가 매우 유용합니다.

  • 생성되는 DSN(배달 상태 알림) 메시지를 모두 검토합니다. DSN에는 배달 못 함 보고서(NDR)가 포함될 수 있으며, 영구 배달 오류를 초래하기 쉬운 일시적 오류 메시지와 영구 오류 메시지에 대한 설명이 있습니다.

  • 메시지 추적을 사용하여 분류기에 정체되어 있는 메시지의 문제를 해결합니다.

  • 보관 싱크 도구를 사용하여 메시지를 보관하고 Exchange Server에 들어오고 나가는 메시지를 분석합니다.

  • 시스템 모니터를 사용하여 분류기 성능 카운터를 모니터링합니다.

Exchange Server 2003 이벤트 및 오류에 대한 자세한 내용은 "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258)를 참조하십시오.

Exchange Server 및 Microsoft Windows Small Business Server에 의해 생성된 DSN 및 NDR 목록은 Microsoft 기술 자료 문서 284204, "Exchange Server 및 Small Business Server에서 배달 상태 알림"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)을 참조하십시오.

Exchange Server에서 메시지 추적 센터를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 262162, "XADM: 메시지 추적 센터를 사용하여 메시지 추적"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Exchange 2000 Server 및 Exchange Server 2003에서 메시지 추적 기능을 사용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "Exchange Server 2003의 메시지 추적 이벤트 ID"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Exchange Server 2003의 향상된 메시지 추적 기능"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

메시지 분류기의 문제 해결 방법에 대한 자세한 내용은 Microsoft 기술 지원 웹캐스트, "Exchange 2000 Server: 메시지 분류기 및 NDR 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)을 참조하십시오.

보관 싱크 도구에 대한 자세한 내용은 Microsoft 기술 자료 문서 307798, "서비스 팩 2에서 사용할 수 있는 보관 싱크 유틸리티"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)를 참조하십시오.

전송 관련 문제 해결 방법에 대한 일반적인 내용은 다음 Microsoft 기술 자료 문서 및 리소스를 참조하십시오.

  • 821910, "HOWTO: Exchange Server 2003 전송 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "Exchange 2000 Server 및 Exchange Server 2003 전송 시 일반 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

  • 895853, "Exchange Server 2003 및 Exchange 2000 Server에서 메일 릴레이 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)

  • Exchange Server 전송 및 라우팅 가이드의 "메일 흐름 및 SMTP 문제 해결"(http://go.microsoft.com/fwlink/?LinkID=67875)

메시지 분류기 성능 카운터는 각 SMTP 가상 서버 인스턴스에 대해 별도로 게시되어 있습니다. 메시지 분류기와 관련하여 사용 가능한 성능 카운터 목록은 Microsoft 기술 자료 문서 231734, "XCON: 메시지 분류기용 성능 모니터 카운터"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)를 참조하십시오.


분류기 경고 이벤트(ID: 6006)가 최근 24시간 이내 기록됨
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-06

Microsoft® Exchange Server Analyzer Tool은 Win32_NTLogEvent Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 MSExchangeTransport에 대한 이벤트 6006 경고가 최근 24시간 이내 기록되었는지 확인합니다.

Exchange Server Analyzer는 MSExchangeTransport에 대한 이벤트 6006 경고가 최근 24시간 이내 기록된 것을 확인하면 경고를 표시합니다.

이 경고는 메시지 분류기에서 메시지가 트랩되고 있음을 나타냅니다.

메시지 분류기는 SMTP(Simple Mail Transfer Protocol) 서버에 도착하는 메시지를 검토하고 메시지의 처리 방법을 결정합니다. 메시지는 로컬 정보 저장소로 보내거나 MTA(메시지 전송 에이전트) 또는 SMTP를 사용하여 원격 호스트로 보낼 수 있습니다. 또한 분류기는 메일 그룹 확장을 처리합니다. 분류기는 TCP 포트 3268의 글로벌 카탈로그 서버를 대상으로 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 고급 큐 엔진에 대한 플러그 인으로, 기본적으로 고급 큐 엔진을 통과하는 모든 메시지에서 고급 주소 확인을 수행하는 이벤트 싱크 모음입니다. 분류기는 주소 확인, 메일 전달, 콘텐츠 변환 플래그 설정, 메일 그룹 확장, 전역 설정 적용, 배달 상태 알림 생성 등의 작업을 수행합니다. 또한 대리 수신자 경로를 검색하고 분기, 저널링 등의 여러 기능을 수행합니다.

메시지 분류기에 메시지가 도착하면 분류기는 Active Directory® 디렉터리 서비스의 프록시 주소 특성에서 주소를 검색하여 봉투를 보낸 사람을 확인합니다. 또한 분류기는 Active Directory의 프록시 주소 특성에서 각 주소를 검색하여 봉투를 받는 사람을 확인합니다. 예를 들어 목록에 메일 그룹이 포함되어 있으면 분류기는 메일 그룹 확장이 서버에서 허용된 경우 해당 구성원을 포함하도록 목록을 확장합니다.

Possible causes of MSExchangeTransport 경고 이벤트 6006은 다음과 같습니다.

  • 오래되었거나 잘못 구성된 바이러스 백신 소프트웨어

  • 과도한 메일 그룹 확장

  • 저널링 받는 사람 잘못 구성

  • Active Directory의 Exchange 개체에 대해 사용 권한 잘못 구성

이 경고를 해결하려면 다음을 수행하십시오.

  • 특정 Exchange Server 디렉터리는 제외되도록 파일 수준의 바이러스 백신 응용 프로그램이 올바르게 구성되었는지 확인합니다. Microsoft Exchange Server가 실행되는 서버를 검색할 때 제외할 폴더에 대한 설명은 Microsoft 기술 자료 문서 823166, "Exchange Server 2003 및 바이러스 백신 소프트웨어 개요"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)를 참조하십시오.

  • 최신 버전의 바이러스 백신 응용 프로그램 소프트웨어를 실행하고 있는지 확인합니다.

  • 메일 그룹 배달 제한 설정을 검토하여 필요없는 제한을 제거합니다.

  • 저널링 설정에 잘못된 구성이 있는지 확인합니다.

  • Active Directory의 Exchange 개체의 사용 권한이 잘못 구성되었는지 확인합니다.

추가 정보

비계층 제한 검사에 대한 자세한 내용은 비계층적인 제한 검사를 고려합니다.를 참조하십시오.

메일 그룹 제한이 Exchange Server 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 895407, "Exchange Server 2003에서 메일 그룹을 기반으로 배달 제한을 구성하면 로컬 사서함이나 외부 사서함으로의 메시지 배달이 예측한 것보다 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 839949, "Exchange 2000 Server 및 Exchange Server 2003의 메일 전송 및 메일 그룹 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)

  • 812298, "메일 그룹을 기반으로 배달 제한을 구성하면 메일 배달이 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)

저널링 솔루션을 배포하는 방법은 "Journaling with Exchange Server"(http://go.microsoft.com/fwlink/?LinkId=47581)를 참조하십시오.

분류기 경고 이벤트 ID 6006이 발생하게 되는 원인에 대한 자세한 내용은 Microsoft 기술 자료 문서 922256, "전자 메일 메시지가 Exchange Server 2003 조직의 "디렉터리 조회 대기 중인 메시지 수입니다" 큐에 정체되어 있음"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=922256)을 참조하십시오.

Exchange Server 2003 이벤트 및 오류에 대한 자세한 내용은 "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258)를 참조하십시오.

Exchange Server 및 Microsoft Windows Small Business Server에 의해 생성된 DSN 및 NDR 목록은 Microsoft 기술 자료 문서 284204, "Exchange Server 및 Small Business Server에서 배달 상태 알림"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)을 참조하십시오.

메시지 분류기의 문제 해결 방법에 대한 자세한 내용은 Microsoft 기술 지원 웹캐스트, "Exchange 2000 Server: 메시지 분류기 및 NDR 문제 해결" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)을 참조하십시오.

전송 관련 문제 해결 방법에 대한 일반적인 내용은 다음 Microsoft 기술 자료 문서 및 리소스를 참조하십시오.

  • 821910, "HOWTO: Exchange Server 2003 전송 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "Exchange 2000 Server 및 Exchange Server 2003 전송 시 일반 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

  • 895853, "Exchange Server 2003 및 Exchange 2000 Server에서 메일 릴레이 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)

  • Exchange Server 전송 및 라우팅 가이드의 "메일 흐름 및 SMTP 문제 해결"(http://go.microsoft.com/fwlink/?LinkID=67875)

메시지 분류기 성능 카운터는 각 SMTP 가상 서버 인스턴스에 대해 별도로 게시되어 있습니다. 메시지 분류기와 관련하여 사용 가능한 성능 카운터 목록은 Microsoft 기술 자료 문서 231734, "XCON: 메시지 분류기용 성능 모니터 카운터"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)를 참조하십시오.


분류기 경고 이벤트(ID: 6008)가 최근 24시간 이내 기록됨
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-06

Microsoft® Exchange Server Analyzer Tool은 Win32_NTLogEvent Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 MSExchangeTransport에 대한 이벤트 6008 경고가 최근 24시간 이내 기록되었는지 확인합니다.

Exchange Server Analyzer는 MSExchangeTransport에 대한 이벤트 6008 경고가 최근 24시간 이내 기록된 것을 확인하면 경고를 표시합니다.

이 경고는 분류기가 메시지를 처리할 때 오류가 발생했음을 나타냅니다.

메시지 분류기는 SMTP(Simple Mail Transfer Protocol) 서버에 도착하는 메시지를 검토하고 메시지의 처리 방법을 결정합니다. 메시지는 로컬 정보 저장소로 보내거나 MTA(메시지 전송 에이전트) 또는 SMTP를 사용하여 원격 호스트로 보낼 수 있습니다. 또한 분류기는 메일 그룹 확장을 처리합니다. 분류기는 TCP 포트 3268의 글로벌 카탈로그 서버를 대상으로 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 고급 큐 엔진에 대한 플러그 인으로, 기본적으로 고급 큐 엔진을 통과하는 모든 메시지에서 고급 주소 확인을 수행하는 이벤트 싱크 모음입니다. 분류기는 주소 확인, 메일 전달, 콘텐츠 변환 플래그 설정, 메일 그룹 확장, 전역 설정 적용, 배달 상태 알림 생성 등의 작업을 수행합니다. 또한 대리 수신자 경로를 검색하고 분기, 저널링 등의 여러 기능을 수행합니다.

메시지 분류기에 메시지가 도착하면 분류기는 Active Directory® 디렉터리 서비스의 프록시 주소 특성에서 주소를 검색하여 봉투를 보낸 사람을 확인합니다. 또한 분류기는 Active Directory의 프록시 주소 특성에서 각 주소를 검색하여 봉투를 받는 사람을 확인합니다. 예를 들어 목록에 메일 그룹이 포함되어 있으면 분류기는 메일 그룹 확장이 서버에서 허용된 경우 해당 구성원을 포함하도록 목록을 확장합니다.

Possible causes of MSExchangeTransport 경고 이벤트 6008은 다음과 같습니다.

  • DSAccess(디렉터리 서비스 액세스) 문제

  • 디렉터리 복제 지연 또는 실패

  • 오버로드된 글로벌 카탈로그 서버

  • DNS 문제

  • 과도한 메일 그룹 확장

이 경고를 해결하려면 다음을 수행하십시오.

  • Exchange Server가 하나 이상의 글로벌 카탈로그 서버에 연결되어 있는지 확인합니다. 이 작업에는 Windows의 네트워크 모니터 도구가 매우 유용합니다.

  • 생성되는 DSN(배달 상태 알림) 메시지를 모두 검사합니다. DSN에는 배달 못 함 보고서(NDR)가 포함될 수 있으며, 영구 배달 오류를 초래하기 쉬운 일시적 오류 메시지와 영구 오류 메시지에 대한 설명이 있습니다.

  • 메시지 추적을 사용하여 분류기에 정체되어 있는 메시지의 문제를 해결합니다.

  • 보관 싱크 도구를 사용하여 메시지를 보관하고 Exchange Server에 들어오고 나가는 메시지를 분석합니다.

  • 시스템 모니터를 사용하여 분류기 성능 카운터를 모니터링합니다.

  • 메일 그룹 배달 제한 설정을 검토하여 필요없는 제한을 제거합니다.

Exchange Server 2003 이벤트 및 오류에 대한 자세한 내용은 "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258)를 참조하십시오.

Exchange Server 및 Microsoft Windows Small Business Server에 의해 생성된 DSN 및 NDR 목록은 Microsoft 기술 자료 문서 284204, "Exchange Server 및 Small Business Server에서 배달 상태 알림"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)을 참조하십시오.

Exchange Server에서 메시지 추적 센터를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 262162, "XADM: 메시지 추적 센터를 사용하여 메시지 추적"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Exchange 2000 Server 및 Exchange Server 2003에서 메시지 추적 기능을 사용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "Exchange Server 2003의 메시지 추적 이벤트 ID"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Exchange Server 2003의 향상된 메시지 추적 기능"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

메시지 분류기의 문제 해결 방법에 대한 자세한 내용은 Microsoft 기술 지원 웹캐스트, "Exchange 2000 Server: 메시지 분류기 및 NDR 문제 해결" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)을 참조하십시오.

보관 싱크 도구에 대한 자세한 내용은 Microsoft 기술 자료 문서 307798, "서비스 팩 2에서 사용할 수 있는 보관 싱크 유틸리티"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)를 참조하십시오.

비계층 제한 검사에 대한 자세한 내용은 비계층적인 제한 검사를 고려합니다.를 참조하십시오.

메일 그룹 제한이 Exchange Server 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 895407, "Exchange Server 2003에서 메일 그룹을 기반으로 배달 제한을 구성하면 로컬 사서함이나 외부 사서함으로의 메시지 배달이 예측한 것보다 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 839949, "Exchange 2000 Server 및 Exchange Server 2003의 메일 전송 및 메일 그룹 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)

  • 812298, "메일 그룹을 기반으로 배달 제한을 구성하면 메일 배달이 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)

전송 관련 문제 해결 방법에 대한 일반적인 내용은 다음 Microsoft 기술 자료 문서 및 리소스를 참조하십시오.

  • 821910, "Exchange Server 2003 전송 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "Exchange 2000 Server 및 Exchange Server 2003 전송 시 일반 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

  • 895853, "Exchange Server 2003 및 Exchange 2000 Server에서 메일 릴레이 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)

  • Exchange Server 및 라우팅 가이드의 "메일 흐름 및 SMTP 문제 해결"(http://go.microsoft.com/fwlink/?LinkID=67875)

메시지 분류기 성능 카운터는 각 SMTP 가상 서버 인스턴스에 대해 별도로 게시되어 있습니다. 메시지 분류기와 관련하여 사용 가능한 성능 카운터 목록은 Microsoft 기술 자료 문서 231734, "XCON: 메시지 분류기용 성능 모니터 카운터"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)를 참조하십시오.


연결 필터링을 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 가상 서버 개체의 msExchServerBindingsFiltering 속성이 SMTP 가상 서버 인스턴스에 연결 필터링을 사용할 수 있음을 나타내는지 여부를 확인합니다.

또한 Exchange Server Analyzer는 Active Directory를 쿼리하여 msExchSmtpConnectionRulesPriority, msExchSMTPGlobalIPAcceptList 또는 msExchSMTPGlobalIPDenyList 속성이 글로벌 설정 수준에서 연결 필터링을 사용할 수 있음을 나타내는지 여부도 확인합니다.

Exchange Server Analyzer는 다음과 같은 경우 경고를 표시합니다.

  • SMTP 가상 서버 인스턴스에서 연결 필터링을 사용하는 경우

  • 글로벌 설정 수준에서 연결 필터링을 사용하는 경우

이 경고는 연결 필터링을 효과적으로 사용할 수 있음을 나타냅니다. 일반적으로 연결 필터링은 문제가 되지 않지만, 이 특정 서버와 관련된 메일 흐름 문제를 해결하려는 경우, 필터 구성을 확인하거나 연결 필터링을 일시적으로 사용할 수 없게 하여 올바른 수신자에게 메일이 잘못 차단되고 있는지 여부를 확인할 수 있습니다.

SMTP 가상 서버에서 연결 필터를 비활성화하려면 다음을 수행합니다.

  1. 시작을 클릭하고 모든 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭하여 Exchange System Manager를 시작합니다.

  2. 콘솔 트리에서 서버, 원하는 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. 필터를 비활성화할 SMTP 가상 서버를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  4. <SMTP 가상 서버> 속성의 일반 탭에서 고급을 클릭합니다.

  5. 고급에서 필터를 비활성화할 IP 주소를 선택하고 편집을 클릭합니다.

  6. 확인에서 연결 필터 적용 확인란의 선택을 해제하여 필터를 비활성화합니다.

  7. 가상 서버가 여러 개인 경우 필터를 비활성화할 가상 서버 각각에 대해 3단계부터 6단계까지 반복합니다.

연결 필터를 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 823866, "RBL(Realtime Block List)을 사용하여 연결 필터링을 구성하는 방법 및 Exchange 2003에서 받는 사람 필터링을 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866)을 참조하십시오.

지능형 메시지 필터링에 대한 자세한 내용은 Exchange Intelligent Message Filter 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21607)를 참조하십시오.


커넥터에 수락 제한이 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 라우팅 그룹의 각 SMTP 커넥터에 대한 dLMemDefault 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 또한 Exchange Server Analyzer는 각 커넥터의 authOrig 및 unauthOrig 특성 값을 확인할 때 Active Directory를 쿼리합니다. unauthOrig 및 authOrig 특성에는 계정의 고유 이름(DN) 목록이 들어 있습니다.

기본적으로 모든 SMTP 커넥터를 사용하면 사용자는 커넥터를 통해 메시지를 보낼 수 있습니다. dLMemDefault가 기본 설정인 1로 설정되어 있으면 unauthOrig 특성에 나열되어 있는 계정을 제외하고 모든 사람으로부터 받은 메시지가 수락됩니다. dLMemDefault가 0으로 설정되어 있으면 authOrig 특성에 나열되어 있는 계정을 제외하고 모든 사람으로부터 받은 메시지가 거부됩니다.

Exchange Server Analyzer는 다음 조건이 존재하는 경우 기본 구성이 아니라는 메시지를 표시합니다.

  • dLMemDefault 특성 값이 0으로 설정되어 있습니다.

  • authOrig 특성에 값이 있습니다.

Exchange Server Analyzer에서 지정된 커넥터는 일부 메시지만 수락하도록 구성되어 있습니다. 커넥터의 배달 제한 탭에서 명시적 사용 권한이 허용된 계정만 커넥터를 통해 메시지를 보낼 수 있습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 기본 구성이 아니라는 메시지를 표시합니다.

커넥터에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)를 참조하십시오.


커넥터에 거부 제한이 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 라우팅 그룹의 각 SMTP 커넥터에 대한 dLMemDefault 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 또한 Exchange Server Analyzer는 각 커넥터의 authOrig 및 unauthOrig 특성 값을 확인할 때 Active Directory를 쿼리합니다. unauthOrig 및 authOrig 특성에는 계정의 고유 이름(DN) 목록이 들어 있습니다.

기본적으로 모든 SMTP 커넥터를 사용하면 사용자는 커넥터를 통해 메시지를 보낼 수 있습니다. dLMemDefault가 기본 설정인 1로 설정되어 있으면 unauthOrig 특성에 나열되어 있는 계정을 제외하고 모든 사람으로부터 받은 메시지가 수락됩니다. dLMemDefault가 0으로 설정되어 있으면 authOrig 특성에 나열되어 있는 계정을 제외하고 모든 사람으로부터 받은 메시지가 거부됩니다.

Exchange Server Analyzer는 다음 조건이 존재하는 경우 기본 구성이 아니라는 메시지를 표시합니다.

  • dLMemDefault 특성 값이 1로 설정되어 있습니다.

  • unauthOrig 특성에 값이 있습니다.

Exchange Server Analyzer에서 지정한 커넥터가 일부 메시지를 거부하도록 구성되어 있습니다. 커넥터의 배달 제한 탭에서 사용 권한이 명시적으로 거부된 계정은 커넥터를 통해 메시지를 보낼 수 없습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 기본 구성이 아니라는 메시지를 표시합니다.

커넥터에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)를 참조하십시오.


기본적으로 커넥터가 모든 메시지를 거부합니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 커넥터의 dLMemDefault 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. dLMemDefault 특성은 메시지를 기본적으로 수락할 것인지 거부할 것인지 제어합니다.

dLMemDefault 특성의 값 0은 기본적으로 메시지를 거부함을 나타냅니다. dLMemDefault 특성의 값 1은 기본적으로 메시지를 수락함을 나타냅니다. Exchange Server Analyzer는 dLMemDefault 특성 값이 0인 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server Analyzer에서 지정된 커넥터는 기본적으로 모든 메시지를 거부하도록 구성되어 있습니다. 커넥터의 배달 제한 탭에서 명시적 사용 권한이 허용된 계정만 커넥터를 통해 메시지를 보낼 수 있습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 기본 구성이 아니라는 메시지를 표시합니다.

커넥터에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)를 참조하십시오.


커넥터 제한 검사가 활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 분기를 읽어서 CheckConnectorRestrictions 레지스트리 키가 존재하고 구성되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Exchange Server Analyzer는 CheckConnectorRestrictions 값이 1로 설정되어 있는 경우 경고를 표시합니다.

커넥터에 메일 그룹 기반 제한을 적용해야 할 경우 이 제한에 대한 검사 프로세스를 수동으로 사용할 수 있게 설정해야 합니다. 제한 검사 작업은 검사할 커넥터의 원본에 해당하는 Exchange 브리지헤드 서버에서 설정되어야 하는 CheckConnectorRestrictions 레지스트리 값에 의해 제어됩니다. 제한을 지정했지만 CheckConnectorRestrictions 레지스트리 값을 만들지 않으면 제한이 검사되지 않습니다.

메일 그룹을 확장하는 작업과 시스템을 통해 전달되는 각 메시지에 대한 제한을 검사하는 작업이 성능에 크게 영향을 미칠 수 있으므로 커넥터 제한 검사는 기본적으로 해제되어 있습니다. 가능하면 제한된 커넥터용 브리지헤드 서버 같은 필요한 곳에서만 이 설정을 사용할 수 있게 설정합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

커넥터 제한 검사를 사용할 수 없게 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\Resvc\Parameters를 탐색합니다.

  3. 오른쪽 창에서 CheckConnectorRestrictions를 찾아 삭제합니다.

  4. 레지스트리 편집기를 닫고 Microsoft Exchange Routing Engine 서비스와 SMTP(Simple Mail Transfer Protocol) 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

커넥터 제한 검사 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 277872, "XCON: Connector Delivery Restrictions May Not Work Correctly"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)를 참조하십시오.


커넥터의 범위가 로컬 라우팅으로 지정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-04-21

Microsoft® Exchange Server Analyzer Tool은 각 SMTP 커넥터의 msExchRoutingSMTPConnector 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer가 msExchRoutingSMTPConnector 특성 값에 문자열 "Local"이 있음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다. 문자열 "Local:"은 SMTP 커넥터의 범위가 로컬 라우팅으로 지정되어 있음을 의미합니다.

SMTP 커넥터는 메일의 격리된 경로를 지정합니다. SMTP 커넥터를 사용하여 인터넷 메일의 게이트웨이를 설정하거나 특정 도메인이나 메일 시스템에 연결할 수 있습니다. 커넥터를 사용하여 지정된 메일 경로에 대해 특정 옵션을 정의할 수 있습니다.

Although you can send and receive Internet mail by using an SMTP 가상 서버를 사용하여 인터넷 메일을 보내고 받을 수 있지만 대부분의 조직에서는 인터넷 메일을 라우팅하기 위해 전용 SMTP 커넥터를 구성합니다. SMTP 커넥터는 인터넷 기반 메일에 격리된 경로를 제공하므로 SMTP 커넥터를 사용하는 것이 좋습니다. 또한 SMTP 가상 서버보다 SMTP 커넥터에 사용 가능한 구성 옵션이 보다 많습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 기본 구성이 아니라는 메시지를 표시합니다.

SMTP 커넥터에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)를 참조하십시오.


비계층적인 제한 검사를 고려합니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 디렉터리에 있는 각 Exchange Server 개체의 serialNumber 특성 값을 확인합니다. Exchange Server Analyzer는 Exchange Server 2003 서버 개체의 serialNumber 특성의 문자열 값에 Service Pack 2가 있으면 다음 레지스트리 키를 읽어 CheckConnectorRestrictions 레지스트리 값이 존재하고 구성되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

이 조건은 서버가 제한 보내기와 받기를 검사한 다음 메시지를 처리할 수 있음을 나타냅니다.

Exchange Server Analyzer는 CheckConnectorRestrictions 값이 존재하고 1, 즉 사용 가능하도록 설정되어 있으면 HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod 레지스트리 키를 읽어 RestrictionMethod 레지스트리 값이 있는지 여부와 구성 방법을 확인합니다.

RestrictionMethod 레지스트리 값이 없거나 2 이외의 값으로 설정되어 있으면 Exchange Server Analyzer에서 유용한 정보 메시지를 표시합니다.

즉, Exchange Server Analyzer는 다음 조건에 해당하는 경우 유용한 정보 메시지를 표시합니다.

  • Exchange Server 2003 서버에 SP2가 설치되었습니다.

  • HKLM\System\CurrentControlSet\Services\Resvc\Parameters 의 CheckConnectorRestrictions 레지스트리 값이 로컬 컴퓨터의 커넥터에 메일 그룹을 기준으로 하는 제한을 사용하도록 구성되었습니다.

  • HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod 의 RestrictionMethod 레지스트리 값이 없거나 2 이외의 값으로 설정되었습니다.

RestrictionMethod 값은 분류기가 제한 사항을 처리하는 방법을 결정합니다. 분류기의 기본 동작은 메일 그룹을 재귀적으로 확장하고 시스템을 통과하는 각 메시지에 대한 제한 사항을 검사합니다. 이러한 기본 분류기 동작은 성능에 영향을 주므로 유용한 방법이 아닙니다.

RestrictionMethod 값을 2로 설정하는 경우 이 Exchange 서버의 전송 구성 요소는 서버가 제한 사항을 확인하면 메일 그룹 구성원을 확장하지 않습니다. 이 구성은 제한 검사에 최적의 성능을 제공합니다. 또한 RestrictionMethod 레지스트리 항목을 적용하기 위해 배달 제한이 있는 사용자가 포함된 모든 메일 그룹은 계층 구조가 없어야 합니다. 즉, 제한된 메일 그룹에는 중첩된 메일 그룹이 없어야 합니다. 이러한 확장 논리는 제한된 메일 그룹이 중첩된 경우 작동하지 않습니다.

커넥터 제한에 사용되는 메일 그룹의 경우 사서함이 없는 커넥터 브리지헤드 서버에서 RestrictionMethod 레지스트리 항목 값을 설정하는 것이 좋습니다. Active Directory 사용자 제한의 경우 제한된 메일 그룹에 확장 서버가 있으면 확장 서버에 RestrictionMethod 레지스트리 항목을 만드는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
RestrictionMethod 레지스트리 항목을 만들고 해당 값 2를 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters를 탐색합니다.

  3. 왼쪽 창에서 매개 변수를 클릭합니다.

  4. 편집 메뉴에서 새로 만들기를 가리킨 다음 DWORD 값을 클릭합니다.

  5. RestrictionMethod를 입력한 다음 Enter 키를 눌러 새 레지스트리 항목에 이름을 지정합니다.

  6. RestrictionMethod를 마우스 오른쪽 단추로 클릭한 다음 수정을 클릭합니다.

  7. 2를 입력한 다음 Enter 키를 누릅니다.

  8. 레지스트리 편집기를 종료합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RestrictionMethod 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 895407, "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)를 참조하십시오.

레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 277872, "XCON: Connector Delivery Restrictions May Not Work Correctly"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)를 참조하십시오.


ConvertDSNInternetContent 레지스트리 키가 모든 메시지의 콘텐츠 변환을 수행하도록 구성되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 ConvertDSNInternetContent 레지스트리 값이 Exchange Server 2003 컴퓨터의 Exchange Information Store에서 받은 모든 메시지의 콘텐츠 변환을 수행하도록 구성되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • ConvertDSNInternetContent 레지스트리 값이 수동으로 만들어졌습니다.

  • ConvertDSNInternetContent 레지스트리 값이 1로 설정되어 있습니다.

ConvertDSNInternetContent 레지스트리 값의 값 데이터가 0이거나 값이 없으면 Exchange Information Store에 의한 SMTP 메시지의 콘텐츠 변환이 불가능합니다. 값 데이터가 1이면 모든 SMTP VSI(가상 서버 인스턴스)의 SMTP 메시지 또는 각 VSI로의 SMTP 메시지를 포함한 모든 메시지의 콘텐츠 변환이 가능합니다.

기본적으로 ConvertDSNInternetContent 레지스트리 값은 Exchange Server 2003 설치 시 만들어지지 않습니다. ConvertDSNInternetContent 레지스트리 값은 Exchange Server 설치 후에 수동으로 만들어 Exchange Server 2003 컴퓨터의 콘텐츠 변환 동작을 변경할 수 있습니다. 일반적으로 전송된 SMTP 메시지에 대해 콘텐츠 변환을 수행하면 안 됩니다. SMTP 메시지를 포함하여 모든 메시지의 콘텐츠 변환이 가능하도록 설정하면 Exchange 서버에 처리 오버헤드가 추가됩니다. 이러한 추가적인 처리 오버헤드로 인해 성능 및 로그 파일 저장소 문제가 발생할 수 있습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 레지스트리를 편집하여 Exchange Server 2003의 콘텐츠 변환 동작을 가장 효율적인 콘텐츠 변환 방법으로 되돌립니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters 레지스트리 키를 탐색합니다.

  3. 세부 정보 창에서 ConvertDSNInternetContent 레지스트리 값을 마우스 오른쪽 단추로 클릭하고 수정을 클릭한 다음 값 데이터를 80으로 변경하고 확인을 클릭합니다.

    참고:
    ConvertDSNInternetContent 레지스트리 값을 삭제하려면 세부 정보 창에서 ConvertDSNInternetContent 레지스트리 값을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭합니다. 대화 상자에서 예를 클릭하여 레지스트리 값의 삭제를 확인합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. Exchange 서버를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Microsoft Windows 레지스트리 편집에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 322755, "Windows 2000에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Windows XP 및 Windows Server 2003에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


일반 대상으로 식별된 메일 그룹
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-04

Microsoft® Exchange Server Analyzer Tool은 Exchange_Queue WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP 가상 서버의 SMTP(Simple Mail Transfer Protocol) 큐에 대한 다음 특성 값을 확인합니다.

LinkId | 큐를 포함한 링크의 식별자를 나타냅니다.
QueueId | 큐의 식별자를 나타냅니다.
QueueName | 큐의 이름을 나타냅니다.
VirtualMachine | 큐를 포함한 가상 컴퓨터의 이름을 나타냅니다.
VirtualServerName | 큐가 있는 가상 서버의 이름을 나타냅니다.
MessageCount | 큐에 있는 메시지 수를 나타냅니다.

Exchange Server Analyzer는 여기서 얻은 정보를 사용해 Exchange_QueuedSMTPMessage WMI 클래스를 쿼리하여 큐에 있는 메시지의 다음 특성 값을 확인합니다.

Recipients | 메시지를 받는 사람을 나타냅니다.
Received | 메시지를 받은 타임 스탬프를 나타냅니다.
MessageId | 큐에 대기 중인 메시지의 식별자를 나타냅니다.
StateRetry | 제대로 배달되지 않은 메시지에 대해 다시 전송을 시도하는 상태임을 나타냅니다.

마지막으로 Exchange Server Analyzer는 여기서 얻은 데이터를 사용해 Active Directory® 디렉터리 서비스를 쿼리하여 각 Recipient 개체의 distinguishedName 값을 확인합니다. 그런 다음 Exchange Server Analyzer는 받는 사람이 사용자인지, 메일 그룹인지, 공용 폴더인지, 공용 폴더 저장소인지를 확인합니다.

Exchange Server Analyzer는 큐에 대기 중인 메시지 중 적어도 25퍼센트 이상이 To: 또는 Cc: 필드의 특정 메일 그룹에 배달되는 경우에 경고를 표시합니다.

큐에 대기 중인 메시지의 50퍼센트 이상이 To: 또는 Cc: 필드의 특정 메일 그룹에 배달되는 경우에는 오류를 표시합니다.

이러한 경고 또는 오류는 식별된 메일 그룹이 SMTP 큐에 대기 중인 메시지의 일반 대상임을 의미합니다.

이 문제를 해결하려면 메일 그룹에 구성 문제나 메시지가 큐에 대기되도록 하는 기타 예외적인 문제가 있는지 확인해야 합니다.

  • 메일 그룹 개체 특성이 올바르게 설정되어 있고 Active Directory에 올바른 값이 포함되어 있는지 확인합니다.

  • 메일 그룹 개체의 Active Directory 사용 권한이 올바르게 설정되어 있는지 확인합니다.

  • 메일 그룹에 지정한 저널링 받는 사람과 같은 특별한 용도의 사용자 개체가 포함된 경우, 사용자 개체가 연관된 서비스나 구성 요소의 구성이 올바른지 확인합니다.

  • 메일 그룹에 대한 UCE(원치 않는 상업성 전자 메일 메시지)나 스팸 또는 바이러스 공격이 있는지 확인합니다.

  • 메일 그룹의 배달 제한이 올바르게 설정되어 있는지 확인합니다.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 전송 및 라우팅 가이드의 "메일 흐름 및 SMTP 문제 해결"(http://go.microsoft.com/fwlink/?LinkID=67875)

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

메일 그룹 제한이 Exchange Server 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 895407, "Exchange Server 2003에서 메일 그룹을 기반으로 배달 제한을 구성하면 로컬 사서함이나 외부 사서함으로의 메시지 배달이 예측한 것보다 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 329171 " XADM: 그룹 구성원별로 배달 제한을 받도록 받는 사람을 구성하면 메일 배달이 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)

  • 839949, "Exchange 2000 Server 및 Exchange Server 2003의 메일 전송 및 메일 그룹 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)

  • 812298, "메일 그룹을 기반으로 배달 제한을 구성하면 메일 배달이 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)


이전 분류가 다시 시도할 수 있는 오류로 인해 실패함
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 SMTP Server 성능 개체의 Cat: Categorizations in progress 및 Categorizer Queue length 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Cat: Categorizations in progress 성능 카운터는 진행 중인 분류 수를 표시하고 Categorizer Queue length 성능 카운터는 분류기 큐에 있는 메시지 수를 표시합니다.

이 쿼리에 대해 Exchange Server Analyzer는 2분 동안 6초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 중 성능 카운터의 평균 값을 보고합니다.

Exchange Server Analyzer는 진행 중인 평균 분류 수를 검사하여 해당 개수를 큐에 있는 분류 수와 비교합니다.

Exchange Server Analyzer는 샘플 기간 동안 다음 조건에 해당하는 경우 오류를 표시합니다.

  • 진행 중인 평균 분류 수가 0개입니다.

  • 평균 분류기 큐 길이가 0보다 큽니다.

분류기가 수행하는 핵심 작업은 다음과 같습니다.

  • 모든 받는 사람을 확인하고 유효성을 검사합니다.

  • 모든 받는 사람의 한계와 제한을 확인합니다.

  • 필요한 경우 메일 그룹을 확장합니다.

  • 메시지를 로컬 배달할지 아니면 원격 배달할지 확인합니다.

이 오류는 다시 시도할 수 있는 오류로 인해 분류에 실패한 메시지가 분류기 큐에 머물러 있음을 나타냅니다.

일반적으로 고급 큐 엔진에서 분류할 수 없는 메시지가 큐에 누적됩니다. 고급 큐 엔진이 글로벌 카탈로그 서버 및 받는 사람 정보에 액세스할 수 없습니다. 글로벌 카탈로그 서버에 연결할 수 없거나 성능이 느릴 수도 있습니다. 또한 다음과 같은 이유 때문에 메시지가 누적될 수 있습니다.

  • Active Directory® 디렉터리 서비스를 사용할 수 없는 경우

    참고:
    분류기가 Active Directory를 사용하여 메시지를 분류하는 경우
  • 분류 작업 이전 큐에 대기 중인 메시지가 너무 많아서 Active Directory가 과도하게 로드되는 경우

  • 변환에 실패한 경우. 분류기가 콘텐츠 변환도 함께 처리하는 경우

  • 메시지 분류기가 사서함 저장소를 찾을 수 없는 경우

  • SMTP(Simple Mail Transfer Protocol)가 다시 설치되거나 제거되어 /smtpsvc/DsUseCat 및 /smtpsvc/vsi#/DsUseCat와 같은 IIS 메타베이스 키가 무효화된 경우

    참고:
    SMTP가 다시 설치되거나 제거되었는지 여부를 결정합니다.

큐 속성을 검사하여 오류의 원인을 확인할 수 있습니다. 예를 들어 큐 속성에 "SMTP 오류가 발생했습니다"와 비슷한 메시지가 표시되면 서버의 이벤트 로그를 검토하여 SMTP 오류를 확인해야 합니다. 로그에 이벤트가 없는 경우 SMTP 로깅 수준을 높여야 합니다.

Exchange 및 SMTP 큐 문제 해결에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkID=67875)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)

  • "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)

메시지 분류기 성능 카운터는 각 SMTP 가상 서버 인스턴스에 대해 별도로 게시되어 있습니다. 메시지 분류기와 관련하여 사용 가능한 성능 카운터 목록은 Microsoft 기술 자료 문서 231734, "XCON: Performance Monitor Counters for Message Categorizer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)를 참조하십시오.


Intelligent Message Filter 자동 업데이트 사용
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-02-13

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 디렉터리에 있는 모든 Exchange Server 개체의 serialNumber 특성 값을 확인합니다. serialNumber 특성은 Exchange Server 버전과 서비스 팩 버전이 모두 설치된 경우 해당 버전을 모두 포함하는 문자열 값입니다. serialNumber 특성 값이 Version 6.5 (Build 7638: Service Pack 2)와 같으면 서버에 Exchange Sever 2003 서비스 팩 2가 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 클러스터 서비스 ClusSvc의 Started 키 값을 확인합니다. True 값은 클러스터 서비스가 실행되고 있음을 나타내고 False 값은 실행되지 않음을 나타냅니다.

Exchange Server Analyzer는 다음 레지스트리 항목을 읽어 Microsoft Exchange Intelligent Message Filter가 서버에 설치되어 사용되고 있는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer는 ContentFilter 레지스트리 키에 ContentFilterBindings 항목이 있지만 ContentFilterBindings 값이 구성되어 있지 않으면 Intelligent Message Filter가 서버에서 사용되고 있지 않음을 나타냅니다.

마지막으로 Exchange Server Analyzer는 다음 레지스트리 항목을 쿼리하여 ContentFilterState 하위 키가 있고 Intelligent Message Filter 자동 업데이트가 서버에서 사용되고 있는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\

ContentFilterState 하위 키의 값이 1이 아닌 경우 Intelligent Message Filter 자동 업데이트가 사용되지 않음을 나타냅니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 유용한 정보 메시지를 표시합니다.

  • 서버에서 Exchange Server 2003 서비스 팩 2가 실행되고 있습니다.

  • Exchange 서버가 클리스터되지 않았습니다.

  • Intelligent Message Filter가 사용됩니다.

  • Intelligent Message Filter 자동 업데이트가 사용되지 않습니다.

기본적으로 Intelligent Message Filter 기능은 Exchange Server 2003 SP2와 함께 설치됩니다. 이 새로운 메시지 필터링 기술의 장점을 적용하려면 Intelligent Message Fileter 기능을 사용하도록 수동으로 설정해야 합니다. Intelligent Message Filter 기능을 사용하도록 설정한 후 .dat 파일 및 .dll 파일을 정기적으로 업데이트해야 필터를 유효한 최신 상태로 유지할 수 있습니다. 다음 섹션에서 참조하는 문서에서는 Intelligent Message Filter를 최신 상태로 유지하는 업데이트 프로세스에 대해 설명합니다.

Intelligent Message Filter 자동 업데이트를 사용하도록 설정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 907747, "How to update the Intelligent Message Filter version 2 in Exchange Server 2003 SP2"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=907747)를 참조하십시오.


봉투 저널링이 활성화되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-03-30

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 heuristics 특성이 봉투 저널링을 사용하도록 구성되어 있는지 확인합니다. 기본적으로 heuristics 특성은 구성되어 있지 않습니다. Exchange Server Analyzer는 heuristics 특성이 512로 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

봉투 저널링으로 P1 메시지 헤더를 보관할 수 있습니다. P1 메시지 헤더는 메일을 라우팅하는 메시지 전송 에이전트(MTA)에서 사용되는 주소 정보입니다. 이 주소 정보에는 메일 그룹의 받는 사람과 숨은 참조(Bcc) 받는 사람을 포함하여 실제로 메시지를 받는 사람에 대한 정보가 들어 있습니다. 봉투 저널링은 저널 보고서와 원본 메시지가 들어 있는 봉투 메시지를 사용하여 보관되도록 플래그가 지정된 메시지를 배달합니다. 원본 메시지는 첨부 파일로 배달됩니다. 저널 보고서의 본문에는 보관된 메시지의 전송 봉투 데이터가 포함됩니다.

지정한 서버에서 Bcc 저널링을 활성화하려면 먼저 데이터베이스 수준에서 메시지 전용 저널링을 구성해야 합니다. heuristics 특성은 다음 조건에서 활성화되지 않습니다.

  • heuristics 특성이 512로 설정되어 있습니다.

  • 메시지 전용 저널링은 데이터베이스 저장소에서 활성화되어 있지 않습니다.

저널링 메시지는 다수의 디스크, 네트워크 및 CPU 리소스를 사용할 수 있습니다. 따라서 저널링에는 철저한 배포 계획이 필요합니다. 저널링은 전반적인 저널링 솔루션 프레임워크 컨텍스트에서만 사용할 수 있어야 합니다.

다음 조건이 충족되는 경우 기본 구성이 아니라는 메시지는 무시합니다.

  • 업무에 저널링이 필요합니다.

  • 저널링 솔루션 프레임워크를 배포했습니다.

그렇지 않은 경우 저널링 기능을 해제해야 합니다.

데이터베이스에서 메시지 전용 저널링을 해제하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, <your Exchange server>, <storage group>을 차례로 확장한 다음 사서함 저장소를 마우스 오른쪽 단추로 클릭합니다.

  2. 일반 탭에서 이 저장소의 사서함에서 주고받은 모든 메시지를 보관 확인란의 선택을 해제합니다.

  3. Exchange 저장소가 변경 사항을 적용할 때까지 15분 동안 기다립니다. Microsoft Exchange Information Store 서비스를 다시 시작할 필요가 없습니다.

Exchange Server Analyzer에서 이 메시지를 다시 표시하지 않도록 하려면 heuristics 특성을 사용할 수 없게 설정합니다. 저널링 기능 비활성화를 위해 heuristics 특성을 비활성화하지 않아도 됩니다.

E-Mail Journaling Advanced Configuration 도구(Exejcfg.exe)를 사용하여 봉투 저널링을 비활성화할 수 있습니다. Active Directory에 대한 액세스 권한으로 서버에서 이 도구를 실행할 수 있지만 도메인 컨트롤러에서 이 도구를 실행하는 것이 좋습니다.

E-Mail Journaling Advanced Configuration 도구 및 문서를 구하려면 http://go.microsoft.com/fwlink/?LinkId=33122에서 도구 패키지를 다운로드합니다. E-Mail Journaling Advanced Configuration 도구는 Exchange 2000 Server 환경 및 Exchange Server 2003 환경에서 사용할 수 있습니다.

heuristics 특성을 비활성화하려면 다음을 수행합니다.

  1. E-Mail Journaling Advanced Configuration 도구를 선택한 디렉터리에 다운로드하고 압축을 풉니다.

  2. 명령 프롬프트를 엽니다.

  3. E-Mail Journaling Advanced Configuration 도구를 설치한 디렉터리로 이동합니다.

  4. 다음 명령을 입력하여 봉투 저널링을 비활성화합니다.

    코드 복사
    exejcfg -d

저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server 2003(http://go.microsoft.com/fwlink/?LinkId=47581)을 참조하십시오.


ESMTP 동사가 지원되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 가상 서버의 각 인스턴스에 대한 msExchSmtpInboundCommandSupportOptions 특성이 들어오는 연결을 위한 기본 확장 SMTP 동사를 지원하도록 구성되어 있는지 확인합니다.

이러한 확장 SMTP 동사는 아래 표에 나열되어 있습니다. Exchange Server Analyzer는 들어오는 연결에 대해 나열된 기본 확장 SMTP 동사 중 하나라도 지원되지 않는 동사가 있으면 경고를 표시합니다.

Exchange Server 2003에서는 이러한 Exchange별 확장 SMTP 동사를 사용하여 조직의 다른 Exchange 서버와 표준 SMTP를 사용하는 경우보다 더 효율적으로 통신합니다. 이러한 동사는 메타베이스 및 Exchange 서버 이벤트 싱크에서 제어됩니다. Exchange Server 2003에서 DS2MB 프로세스는 Active Directory의 값을 복사하여 메타베이스 값 업데이트를 담당합니다. 이벤트 싱크를 사용하지 않으면 Exchange 서버 성능이 저하될 수 있습니다.

확장 SMTP 동사 설명

8BITMIME

로컬 SMTP 가상 서버가 8비트 MIME 메시지를 지원함을 나타냅니다.

BDAT, CHUNKING

DATA 명령 대신 사용할 수 있습니다. 두 개의 인수가 필요합니다. SMTP 가상 서버가 EHLO 키워드에 CHUNKING로 응답하면 SMTP 서버가 BDAT 명령을 지원하고 청크에서 메시지를 받아들일 것임을 나타냅니다.

  • 첫 번째 인수는 이진 데이터 패킷의 길이를 나타내므로 SMTP 호스트는 데이터의 끝까지 연속해서 검색할 필요가 없습니다. 받는 서버에서는 메시지 바이트 수를 계산합니다. 메시지 크기가 BDAT 명령에서 보낸 값과 같으면 서버는 모든 메시지 데이터를 받은 것으로 간주합니다.

  • 두 번째 인수는 데이터 패킷이 현재 전송의 마지막 패킷인지 여부를 나타냅니다. 두 번째 인수는 선택 사항입니다.

BINARYMIME

SMTP 가상 서버가 MAIL 명령의 BINARYMIME 값으로 BODY 매개 변수를 사용하여 전송 인코딩 없이 이진 자료가 포함된 메시지를 받아들임을 나타냅니다. SMTP 서버가 BINARYMIME의 BODY 매개 변수가 있는 MAIL 명령을 받아들이면 서버는 BDAT 명령을 사용하여 전달된 각 8진수의 모든 비트를 유지하는 데 동의합니다. BINARYMIME SMTP 확장은 CHUNKING에만 사용할 수 있습니다.

DSN

RFC(Request for Comments) 1891에 정의된 것처럼 배달 상태 알림을 사용하는 ESMTP 명령입니다.

ENHANCEDSTATUSCODES

SMTP 서버가 향상된 오류 상태 코드를 제공함을 나타냅니다. 첫 인사말과 HELO 또는 EHLO에 대한 응답 이외의 모든 SMTP 상태 응답의 텍스트 부분은 RFC 1893에 정의된 상태 코드로 시작합니다.

ETRN

SMTP 서버가 ETRN 명령에 나타난 도메인의 큐에 있는 전자 메일 메시지를 보내도록 로컬 가상 서버에게 요청하기 위해 보내는 명령입니다.

TURN

원격 호스트와 로컬 호스트가 새 연결을 설정하지 않은 채 역할을 전환하고 반대 방향으로 메일을 보낼 수 있도록 합니다.

이러한 동사에 대한 기본 지원을 복원하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 257569, "XFOR: Exchange 2000 Server에서 ESMTP 동사(Verb)를 해제하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569)을 참조하십시오.


Exchange Server가 확장 동사를 보급하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 인터넷 정보 서비스(IIS) 메타베이스에서 SmtpInboundCommandSupportOptions 속성을 읽어 Exchange Server가 확장 동사를 지원하도록 구성되어 있는지 여부를 확인합니다. Exchange Server Analyzer는 SmtpInboundCommandSupportOptions 설정이 7697601로 설정되어 있지 않은 경우 경고를 표시합니다.

확장 SMTP 동사는 Exchange 2000 Server와 Exchange Server 2003에 모두 필요합니다. IIS 메타베이스의 값은 Active Directory® 디렉터리 서비스에 설정되어 있는 값과 일치해야 합니다. Exchange Server를 혼합 모드 환경에서 실행하는 경우 이 값은 7697601로 설정되어 있어야 합니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
SmtpInboundCommandSupportOptions를 기본값으로 복원하려면 다음을 수행합니다.

  1. ADSI 편집을 열고 도메인 컨트롤러에 연결합니다.

  2. 구성 컨테이너를 엽니다.

  3. 다음 위치로 이동합니다.

    Configuration/Services/Microsoft Exchange/<Your Organization>/Administrative Groups/<Your Administrative Group>/Servers/<Your Exchange Server>/Protocols/SMTP/<Your Virtual Server>

  4. 가상 서버 개체를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. Select a property to view에서 msExchSmtpInboundCommandsSupportOptions를 선택합니다.

  6. Edit Attribute에 7697601을 입력합니다.

  7. Set, Apply, OK를 차례로 클릭합니다.

  8. ADSI 편집을 닫습니다.


고정된 큐가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-03

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 서버에서 SMTP(Simple Mail Transfer Protocol) 큐의 StateFrozen 키 값을 확인합니다.

Exchange 서버에서 SMTP 큐 중 하나의 StateFrozen 키 값이 True로 설정된 경우 오류가 표시됩니다.

큐가 고정되었다는 것은 해당 큐에 대한 전송 세션이 중지되었음을 의미합니다. 고정된 큐에서는 새 메시지가 추가될 수는 있어도 메시지가 나갈 수는 없습니다. 각 링크 큐에 대한 바로 가기 메뉴를 사용하여 연결 상태를 수동으로 변경할 수 있습니다. 강제 연결 명령을 사용하여 큐 상태를 활성으로 변경하면 바로 해당 큐의 메시지를 보내는 연결을 사용할 수 있습니다.

영향을 받는 특정 SMTP 큐 및 가능한 원인에 대한 자세한 내용은 다음 Exchange Server Analyzer Tool 문서를 참조하십시오.

  • '디렉터리 조회 대기 중인 메시지 수입니다' 큐가 고정되었습니다.

  • '라우팅 대기 중인 메시지 수입니다' 큐가 고정되었습니다.

  • '전송 보류 중인 메시지 수입니다' 큐가 고정되었습니다.

  • 로컬 배달 큐가 고정되었습니다

  • '원격 배달' 큐가 고정되었습니다.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


지능형 메시지 필터 업데이트를 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange Server의 다음 경로에서 MSExchange.UceContentFilter.dll이 있는지 확인할 때 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다.

<path to Exchange server binary files>\MSCFv2\MSExchange.UceContentFilter.dll

참고:
이 경로에서 <path to Exchange server binary files>는 bin 폴더의 위치입니다.

MSExchange.UceContentFilter.dll이 이 위치에 없으면 Exchange Server Analyzer는 유용한 정보 권장 사항을 표시합니다.

Microsoft Exchange Intelligent Message Filter의 필터 업데이트는 지능형 메시지 필터가 설치되어 있는 모든 Exchange Server에 설치하는 것이 좋습니다. 지능형 메시지 필터 업데이트에서는 지능형 메시지 필터의 최신 Intelligent Message Filter SmartScreen™ 필터 업데이트를 제공합니다. SmartScreen 필터의 필터 업데이트에는 업데이트된 스팸 기능이 있습니다. 이 기능은 스팸으로 알려진 원치 않는 상업성 전자 메일 메시지를 차단하는 지능형 메시지 필터의 기능을 향상시켜 줍니다.

참고:
업데이트를 설치하기 전에 지능형 메시지 필터를 설치해야 합니다. 지능형 메시지 필터를 설치하려면 로컬 관리자 권한이 있고 Exchange Administrator 역할이 적용된 그룹의 구성원인 계정을 사용합니다.

지능형 메시지 필터를 설치한 후 다음 절차에 따라 업데이트를 설치합니다.

지능형 메시지 필터 업데이트를 얻고 설치하려면 다음을 수행합니다.

  1. http://go.microsoft.com/fwlink/?LinkId=41026에서 Exchange 지능형 메시지 필터의 최신 업데이트를 얻습니다.

  2. http://go.microsoft.com/fwlink/?LinkId=41027에서 지능형 메시지 필터 업데이트에 대한 릴리스 정보를 확인합니다.

  3. 업데이트 패키지를 실행하고 업데이트 패키지 설치 마법사의 지시를 따릅니다.

자세한 내용은 Exchange 지능형 메시지 필터 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21607)를 참조하십시오.


단일 제한 검사가 활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 디렉터리에 있는 각 Exchange Server 개체의 serialNumber 특성 값을 확인합니다. Exchange Server 2003 서버 개체의 serialNumber 특성에 대한 문자열 값에 Service Pack 2가 포함된 경우 Exchange 서버가 Exchange Server 2003 서비스 팩 2의 시험판 버전을 실행 중임을 나타냅니다.

또한 Exchange Server Analyzer는 다음 레지스트리 항목을 읽어서 RestrictionMethod 레지스트리 값이 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Exchange Server Analyzer는 다음 조건에 해당하는 경우 기본 구성이 아니라는 메시지를 표시합니다.

  • Exchange Server 2003 서비스 팩 2가 설치되어 있습니다.

  • RestrictionMethod 레지스트리 값이 있고 2 값을 갖도록 구성되었습니다.

이 구성은 이 Exchange 서버가 제한을 검사하면 이 서버의 전송 구성 요소가 메일 그룹 구성원을 확장하지 않음을 나타냅니다. 이 구성은 제한 검사에 최적의 성능을 제공합니다.

RestrictionMethod 레지스트리 값이 있고 설정에 오류가 있다고 생각되면 다음 절차대로 기본 구성으로 되돌릴 수 있습니다. 그러나 Exchange Server 2003 서비스 팩 2와 함께 이 키가 있기 때문에 제한 검사의 성능이 최적으로 지원되므로 RestrictionMethod 레지스트리 값을 해당 현재 설정 그대로 유지하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\를 탐색합니다.

  3. 오른쪽 창에서 RestrictionMethod를 마우스 오른쪽 단추로 클릭한 다음 삭제를 선택합니다.

  4. 레지스트리 편집기를 닫은 다음 IIS Admin 및 Microsoft Exchange Routing Engine 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

RestrictionMethod 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 895407, "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)를 참조하십시오.


'MX' 레코드가 아닌 '호스트' 레코드가 발견되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 Exchange가 보내는 원격 도메인의 메일 교환기(MX)에 사용되는 DNS(Domain Name System) 서버를 쿼리합니다. 그런 다음 Exchange Server Analyzer는 DNS 조회를 수행하여 원격 도메인의 호스트(A) 레코드를 검색합니다.

Exchange Server Analyzer DNS 조회 작업에서 원격 도메인에 대한 MX 레코드를 반환하지 않지만 이후에 같은 원격 도메인에 대한 호스트(A) 레코드를 검색할 수 있는 경우, Exchange Server Analyzer는 경고를 표시합니다.

이 경우, MX 레코드 검색에 실패한 후 Exchange 서버는 호스트(A) 레코드가 가리키는 서버에 메일을 보내려고 시도할 수 있습니다. 이 호스트(A) 레코드가 올바른 메일 서버를 가리키고 있다는 사실이 아주 중요합니다.

일부 도메인에는 올바른 메일 서버가 있을 수 있지만 의도한 받는 사람에 대한 권한이 있는 메일 서버가 아닐 수 있는 ISP(인터넷 서비스 공급자)를 가리키도록 도메인을 구성할 수 있습니다. 이 경우에는 메일이 거부됩니다.

네트워크 오류나 다른 이유 때문에 DNS 서버가 다운되거나 연결할 수 없는 경우, MX 레코드의 DNS 조회가 실패할 수 있습니다.

DNS 서버가 온라인 상태인지와 MX 레코드가 있는지 확인하려면 다음을 수행합니다.

  1. 다음 확인 작업 중 하나를 수행하여 DNS 서버가 실행되고 있는지 확인합니다.

    • DNS 서버의 DNS 관리 프로그램에서 DNS 서버 상태를 확인합니다.

    • DNS 서버를 다시 시작합니다. 자세한 내용은 "DNS 서버 시작, 중지, 일시 중지 및 다시 시작"(http://go.microsoft.com/fwlink/?LinkId=62999)을 참조하십시오.

    • nslookup 명령을 사용하여 DNS 서버 응답 기능을 확인합니다. 자세한 내용은 "nslookup 명령을 사용하여 DNS 서버 응답 기능 확인"(http://go.microsoft.com/fwlink/?LinkId=63000)의 설명을 참조하십시오.

  2. nslookup을 사용하여 MX 레코드가 올바르게 구성되었는지 확인합니다. 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "DNS 디자인 및 구성 확인" 섹션에 있는 "Nslookup을 사용하여 MX 레코드 구성 확인 방법"을 참조하십시오.

자세한 정보

  • Exchange Server 2003이 DNS를 사용하여 외부 IP 주소를 확인하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "Exchange Server 2003 전송 종속성"을 참조하십시오.

  • DNS 이름 확인에 대한 자세한 내용은 Microsoft 기술 자료 문서 322856, "HOWTO: Exchange Server 사용을 위한 DNS 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)을 참조하십시오.

  • DNS 문제 해결에 대한 자세한 내용은 "DNS 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=63003)을 참조하십시오.


IIS PoolThreadLimit 레지스트리 값을 수동으로 추가하고 구성하였습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어서 최대 인터넷 정보 서비스(IIS) 풀 스레드 수가 기본값과 다르게 수정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\Inetinfo\Parameters\PoolThreadLimit

Exchange Server Analyzer는 PoolThreadLimit가 존재하며 대체 값으로 구성되면 기본 구성이 아니라는 메시지를 표시합니다.

PoolThreadLimit 레지스트리 값은 Inetinfo.exe 프로세스에서 만들 수 있는 최대 입/출력(I/O) 작업자 스레드 수를 지정하고 차례로 IIS에 연결할 수 있는 최대 동시 연결 수를 제어합니다. 각 풀 스레드는 정적 파일을 돌려 보내거나 요청을 ISAPI 확장 DLL(예: ASP.DLL)이나 CGI(Common Gateway Interface) 응용 프로그램에 전달하여 네트워크 요청을 찾아서 처리합니다. ISAPI 확장은 요청을 동기적으로 처리하는 데 시간이 오래 걸릴 경우 다른 요청을 처리하도록 IIS에 적은 수의 작업자 스레드를 남기고 작업자 스레드를 독점합니다. 이러한 이유로 ASP 같은 잘 작성된 ISAPI 확장은 사용 중인 스레드 풀을 구현한 상태에서 요청을 큐에 넣고 사용 중인 스레드를 사용하여 비동기적으로 요청을 처리하므로 IIS 작업자 스레드를 독점하지 않습니다.

기본적으로 IIS는 PoolThreadLimit를 아래의 값으로 설정합니다.

2 * 해당 시스템에 존재하는 RAM의 MB 수

이 값이 256보다 크면 256으로 고정됩니다. 기본적으로 이 레지스트리 값은 없습니다. 이 값이 레지스트리에 존재하면 IIS의 기본 계산을 다시 정의합니다.

일반적으로 기본 한도인 256개의 스레드가 적절하지 않을 경우 잘못 작성된 ISAPI 확장이 IIS 작업자 스레드를 독점 사용할 가능성이 높습니다. 256은 동기적으로 활성 상태를 가지는 스레드 수이며 동기화 및 컨텍스트 전환에서 상당한 오버헤드를 발생시키는 스레드 수 입니다.

PoolThreadLimit 레지스트리 값은 HTTP, FTP, NNTP, SMTP 서비스, 모든 IIS 작업자 스레드 등을 포함하는 엄격한 한도입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters를 탐색합니다.

  3. PoolThreadLimit 값을 검사하거나 삭제하거나 수정합니다.

  4. 레지스트리 편집기를 닫고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)을 참조하십시오.


받는 메시지와 보내는 메시지 크기 제한
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-12-01

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 보내는 메시지 크기 제한 특성인 submissionContLength가 받는 메시지 크기 제한 특성인 delivContLength와 다른지 확인합니다. Exchange Server Analyzer는 보내는 메시지 크기 제한과 받는 메시지 크기 제한이 다르다는 것을 확인하면 유용한 정보 권장 메시지를 표시합니다.

보내는 메시지 크기 제한과 받는 메시지 크기 제한을 같은 값으로 설정하여 메시지 제한의 일관성을 유지하는 것이 좋습니다.

Exchange 2000 Server 및 Exchange Server 2003의 경우 보내는 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange System Manager를 시작합니다.

  2. 왼쪽 창에서 전역 설정을 확장합니다.

  3. 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 기본값 탭의 보내는 메시지 크기에서 최대 크기(KB)를 클릭한 다음 값을 입력합니다.
Exchange Server 2007의 경우 보내는 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange 관리 셸에서 다음 명령을 실행합니다. 여기서 <size>는 기본값인 "unlimited"로 입력하거나 0에서 2147483647바이트 사이의 크기를 B(바이트), KB(킬로바이트) 또는 MB(메가바이트) 단위로 입력합니다.
코드 복사
Set-TransportConfig -MaxSendSize <size>

예를 들어 Exchange 조직에서 사용자가 전송할 수 있는 최대 메시지 크기를 10MB로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxSendSize 10MB

Exchange 조직에서 사용자가 전송할 수 있는 최대 메시지 크기를 기본값인 무제한으로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxSendSize unlimited
 받는 메시지 크기 제한을 변경하려면 다음을 수행하십시오.

  1. Exchange System Manager를 시작합니다.

  2. 왼쪽 창에서 전역 설정을 확장합니다.

  3. 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 기본값 탭의 받는 메시지 크기에서 최대 크기(KB)를 클릭한 다음 값을 입력합니다.
Exchange Server 2007의 경우 받는 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange 관리 셸에서 다음 명령을 실행합니다. 여기서 <size>는 기본값인 "unlimited"로 입력하거나 0에서 2147483647바이트 사이의 크기를 B(바이트), KB(킬로바이트) 또는 MB(메가바이트) 단위로 입력합니다.
코드 복사
Set-TransportConfig -MaxReceiveSize <size>

예를 들어 Exchange 조직에서 받는 사람이 전송받을 수 있는 최대 메시지 크기를 10MB로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxReceiveSize 10MB

Exchange 조직에서 받는 사람이 전송받을 수 있는 최대 메시지 크기를 기본값인 무제한으로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxReceiveSize unlimited

Exchange 2000 Server 및 Exchange Server 2003에서 메시지의 크기 제한을 설정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 322679, "Exchange Server에서 메시지 크기 제한을 설정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)를 참조하십시오.

Exchange Server 2007의 경우 TransportConfig cmdlet에 대한 자세한 내용은 Exchange Server 2007 Technical Reference의 "Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkID=79237)를 참조하십시오.


지능형 메시지 필터 사용자 지정 응답이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 CustomRejectResponse 레지스트리 값이 있는지 확인할 때 다음 레지스트리 키를 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer는 다음 조건이 존재하는 경우 기본 구성이 아니라는 메시지를 표시합니다.

  • CustomRejectResponse 값이 있습니다.

  • 이 값은 올바른 문자열입니다.

    참고:
    응답 문자열 값은 550 5.7.1로 시작해야 올바르게 인식할 수 있습니다.

필요한 작업이 없습니다.

Exchange Server 2003 서비스 팩 2(SP2)에 지능형 메시지 필터링이 설치되어 있고 SP2를 설치할 때 사용할 준비가 되어 있습니다. Exchange Server 2003 서비스 팩(SP2)에서는 서버 응답 문자열을 사용자 지정할 수 있습니다. 이 문자열은 생성되고 배달 못 함 보고서(NDR)에 추가되어 보낸 사람에게 다시 전송됩니다. 550 5.7.1 Requested action not taken: message refused의 기본 응답을 변경하여 차단된 올바른 사용자에게 메시지 차단 이유에 대한 의미 있는 설명을 제공할 수 있습니다. 이 설명을 사용하여 잘못된 판정 조사를 줄이고 스팸 방지 처리와 연관된 지원 비용을 줄일 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
사용자 지정 응답 문자열을 변경하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\Microsoft\Exchange\ContentFilter를 탐색합니다.

  3. 오른쪽 작업 창에서 CustomRejectResponse 값을 마우스 오른쪽 단추로 클릭하고 수정을 선택합니다.

  4. 사용자 지정 응답으로 사용할 550 5.7.1로 시작하는 문자열 값을 입력()합니다. 예를 들어 550 5.7.1 Domain not an allowed sender를 입력하여 문자열을 NDR에 추가할 올바른 문자열로 설정할 수 있습니다.

  5. 변경 내용을 저장하고 레지스트리 편집기를 닫은 다음 SMTP 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

지능형 메시지 필터링에 대한 자세한 내용은 Exchange Intelligent Message Filter 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21607)를 참조하십시오.

지능형 메시지 필터링 작업을 수행하는 방법에 대한 자세한 내용은 Exchange Server 2003 SP2 온라인 도움말의 "지능형 메시지 필터링 구성"을 참조하십시오.

Exchange Server 2003 SP2에 대한 자세한 내용은 Exchange Server 2003 서비스 팩 2 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=52073)를 참조하십시오.


지능형 메시지 필터 사용자 지정 단어 목록이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange 서버에 MSExchange.UCEContentFilter.xml 파일이 있는지 확인할 때 CIM_Datafile WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Exchange 서버에 MSExchange.UCEContentFilter.xml 파일이 있음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다. 필요한 작업이 없습니다.

MSExchange.UCEContentFilter.xml 파일은 Exchange Server 2003 서비스 팩 2(SP2)의 Intelligent Message Filter에 있는 사용자 지정 가중치 지정 기능의 구성 요소입니다.

SP2에 대한 지능형 메시지 필터의 사용자 지정 가중치 지정 기능을 사용하면 관리자가 전자 메일 메시지의 본문이나 제목 줄 또는 둘 모두에 포함된 구를 기준으로 지능형 메시지 필터의 동작을 사용자 지정할 수 있습니다. 사용자 지정 가중치 지정 기능에는 사용자 인터페이스가 연결되어 있지 않습니다. 사용자 지정 가중치 지정은 지능형 메시지 필터에서 초기화 시 읽은 XML 구성 파일 MSExchange.UCEContentFilter.xml의 형태로 사용할 수 있게 된 다음 파일이 변경될 때마다 다시 로드됩니다. 지능형 메시지 필터를 시작할 때 MSExchange.UCEContentFilter.xml 파일이 없으면 SMTP 서비스를 다시 시작해야 합니다. 사용자 지정 가중치 지정 파일인 MSExchange.UceContentFilter.xml은 MSExchange.UceContentFilter.dll 및 .dat 파일과 동일한 디렉터리에 있어야 합니다.

사용자 지정 가중치 지정 파일에 대한 자세한 내용은 Exchange Server 2003 서비스 팩 2 릴리스 정보를 참조하십시오. Exchange Server 2003 서비스 팩 2의 릴리스 정보는 SP2용 CD 및 Exchange Server 2003 서비스 팩 2 릴리스 정보 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=52072)에서 사용할 수 있습니다.

Exchange Server 2003 SP2에 대한 자세한 내용은 Exchange Server 2003 서비스 팩 2 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=52073)를 참조하십시오.


지능형 메시지 필터 사용자 지정 응답이 잘못되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 CustomRejectResponse 레지스트리 값이 있는지 확인할 때 다음 레지스트리 키를 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer는 다음 조건이 존재하는 경우 경고 메시지를 표시합니다.

  • CustomRejectResponse 값이 있습니다.

  • 이 값 문자열이 550 5.7.1로 시작하지 않습니다.

    참고:
    응답 문자열 값은 550 5.7.1로 시작해야 올바르게 인식할 수 있습니다.

Exchange Server 2003 서비스 팩(SP2)에서는 서버 응답 문자열을 사용자 지정할 수 있습니다. 이 문자열은 생성되고 배달 못 함 보고서(NDR)에 추가되어 보낸 사람에게 다시 전송됩니다. 550 5.7.1 Requested action not taken: message refused의 기본 응답을 변경하여 차단된 올바른 사용자에게 메시지 차단 이유에 대한 의미 있는 설명을 제공할 수 있습니다. 이 설명을 사용하여 잘못된 판정 조사를 줄이고 스팸 방지 처리와 연관된 지원 비용을 줄일 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\Software\Microsoft\Exchange\ContentFilter를 탐색합니다.

  3. 오른쪽 작업 창에서 CustomRejectResponse 값을 마우스 오른쪽 단추로 클릭하고 수정을 선택합니다.

  4. 사용자 지정 응답으로 사용할 550 5.7.1로 시작하는 문자열 값을 입력()합니다. 예를 들어 550 5.7.1 Domain not an allowed sender를 입력하여 문자열을 NDR에 추가할 올바른 문자열로 설정할 수 있습니다.

  5. 변경 내용을 저장하고 레지스트리 편집기를 닫은 다음 SMTP 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

지능형 메시지 필터링에 대한 자세한 내용은 Exchange Intelligent Message Filter 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21607)를 참조하십시오.

지능형 메시지 필터링 작업을 수행하는 방법에 대한 자세한 내용은 Exchange Server 2003 SP2 온라인 도움말의 "지능형 메시지 필터링 구성"을 참조하십시오.


지능형 메시지 필터를 사서함 서버에서 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange Intelligent Message Filter가 서버에 설치되어 있고 사용 가능한지 확인합니다.

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer는 ContentFilter 레지스트리 키의 ContentFilterBindings 값을 읽어 지능형 메시지 필터가 서버에 설치되어 있고 사용 가능한지 확인합니다.

또한 Exchange Server Analyzer는 각 Exchange Server 개체의 msExchAuthenticationFlags 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msExchAuthenticationFlags 특성은 서버에 허용되는 인증 형식을 나타냅니다. Exchange Server Analyzer는 다음 조건이 존재하는 경우 경고 메시지를 표시합니다.

  • msExchAuthenticationFlags 특성의 인증은 서버에 대한 익명 액세스를 허용하도록 구성되었습니다.

  • 또한 서버는 서버의 사서함을 호스팅합니다.

지능형 메시지 필터는 UCE(원치 않는 상업성 전자 메일 메시지) 같은 메시지를 식별할 수 있습니다. 게이트웨이에서 Microsoft사 제품이 아닌 전자 메일 서버를 사용하는 경우 UCE를 효과적으로 필터링하려면 Exchange 게이트웨이 서버나 Exchange 브리지헤드 서버에 지능형 메시지 필터를 배포해야 합니다. 이 게이트웨이 서버는 받는 인터넷 전자 메일 메시지를 수락하고 이 메시지를 적절한 사서함 서버에 전달합니다. 일반적으로 게이트웨이 서버는 사서함을 호스팅하지 않습니다.

또한 Exchange 게이트웨이 서버에서 인터넷 전자 메일 메시지를 수락하는 각 SMTP 가상 서버에 지능형 메시지 필터를 사용 가능하게 해야 합니다.

중요:
인터넷 게이트웨이 SMTP 가상 서버에서 익명 액세스를 사용하게 하십시오. 인터넷으로부터 메일을 수락하는 이러한 SMTP 가상 서버는 익명 액세스를 허용해야 합니다.

UCE를 필터링하려면 게이트웨이와 Exchange 사서함 저장소에서 받는 메시지에 지정된 SCL(Spam Confidence Level) 등급에 대한 임계값을 설정하여 지능형 메시지 필터를 구성할 수 있습니다. 지능형 메시지 필터는 받는 메시지마다 평가하여 메시지가 UCE일 가능성 여부에 따라 SCL 등급을 지정합니다. Exchange 사서함 서버는 사서함 저장소에 지정된 SCL 임계값과 설정을 사용하여 메시지를 사용자의 받은 편지함으로 배달할 것인지 정크 메일 폴더로 배달할 것인지 결정합니다.

중요:
지능형 메시지 필터를 Exchange 사서함 서버에 설치할 필요는 없습니다. 지능형 메시지 필터가 게이트웨이 SMTP 가상 서버에 설치되어 있고 사용 가능한 경우 Exchange 사서함 서버는 각 받은 메시지의 SCL 등급을 받아 적절하게 처리합니다.

자세한 내용은 Exchange Intelligent Message Filter 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21607)를 참조하십시오. 인터넷 메일을 주고받을 수 있도록 Microsoft Exchange Server 2003 조직을 구성하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)를 참조하십시오.


서버에서 지능형 메시지 필터를 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange Intelligent Message Filter가 서버에 설치되어 있고 사용 가능한지 확인합니다.

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer는 ContentFilter 레지스트리 키에 ContentFilterBindings 값 항목이 있지만 ContentFilterBindings 값이 구성되지 않은 경우 경고 메시지를 표시합니다.

참고:
ContentFilterBindings 값이 구성되지 않은 상태에서 ContentFilter 레지스트리 키에 ContentFilterBindings 값 항목이 있으면 지능형 메시지 필터를 서버에서 사용할 수 없음을 나타냅니다.
중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Microsoft Exchange Intelligent Message Filter는 UCE(원치 않는 상업성 전자 메일 메시지) 같은 메시지를 식별할 수 있습니다. 들어오는 전자 메일을 받는 Exchange 게이트웨이 서버나 Exchange 브리지헤드 서버에서 지능형 메시지 필터를 배포한 후에 인터넷 전자 메일 메시지를 받는 각 SMTP 가상 서버에서 지능형 메시지 필터를 사용할 수 있어야 합니다.

ContentFilter 레지스트리 키를 보려면 다음을 수행합니다.

  1. 레지스트리 편집기(regedit)의 세부 정보 창에서 ContentFilter를 마우스 오른쪽 단추로 클릭하여 ContentFilterBindings에 대한 설정을 확인합니다.

    참고:
    SMTP 가상 서버에서 Exchange 지능형 메시지 필터를 구성하지 않았으면 ContentFilterBindings 값이 Null이 됩니다.

    레지스트리를 편집하기 전 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

지능형 메시지 필터가 설치되어 있는 모든 Exchange Server에서 Exchange 지능형 메시지 필터를 사용하는 것이 좋습니다. SMTP 가상 서버에 지능형 메시지 필터를 사용하려면 다음 절차를 수행합니다. 지능형 메시지 필터를 사용하도록 설정한 후에 레지스트리에서 ContentFilter 레지스트리 키 값을 확인할 수 있습니다.

지능형 메시지 필터를 사용하려면 다음을 수행합니다.

  1. 시작을 클릭하고 모든 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭합니다.

  2. Exchange System Manager에서 서버, 서버 이름, 프로토콜, SMTP를 차례로 확장하고 지능형 메시지 필터링을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭의 다음 가상 서버의 IP 주소에 지능형 메시지 필터링을 적용합니다 아래에서 지능형 메시지 필터를 사용할 수 있게 설정한 각 SMTP 가상 서버 옆의 확인란을 클릭합니다.

    지능형 메시지 필터링 속성 대화 상자

자세한 내용은 Exchange 지능형 메시지 필터 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21607)를 참조하십시오.


잘못된 받는 사람 업데이트 서비스 서버를 지정했습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-07-30

Microsoft Exchange Analyzer Tool은 Active Directory 디렉터리 서비스를 쿼리하여 디렉터리의 각 받는 사람 업데이트 서비스 개체에 대한 msExchAddressListServiceLink 특성 값을 확인합니다. msExchAddressListServiceLink 특성은 주소 목록 서비스와 RUS(받는 사람 업데이트 서비스)를 실행하는 Exchange Server 컴퓨터 간의 링크입니다.

이를 확인한 다음에는 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 식별된 Exchange Server 컴퓨터에서 Address Book View and Dynamic Groups Service(abv_dg.dll)의 Version 키 값을 확인합니다. Version WMI 키는 이 파일의 빌드 번호를 나타냅니다.

Exchange Analyzer는 식별된 컴퓨터 중 어느 컴퓨터에서라도 abv_dg.dll 파일의 빌드 번호가 08로 시작할 경우 오류를 표시합니다.

이 오류는 RUS 서버로 지정된 컴퓨터에서 Microsoft Exchange Server 2007이 실행되고 있음을 나타냅니다.

받는 사람 업데이트 서비스는 Exchange 2000 Server 및 Exchange Server 2003에 있는 Exchange System Attendant 서비스의 구성 요소입니다. Exchange 2000 및 Exchange 2003용 받는 사람 업데이트 서비스는 Active Directory에 Exchange 전용 특성 값을 만들어 유지 관리합니다. 이 기능은 Exchange 2007의 받는 사람 생성 프로세스에 의해 처리되며 레거시 받는 사람 업데이트 서비스는 Exchange 2007 서버에서 실행될 경우 업데이트를 처리하지 않습니다.

이 오류를 해결하려면 Exchange 2000 Server 또는 Exchange Server 2003이 받는 사람 업데이트 서비스를 호스팅하도록 지정합니다.

이 오류를 해결하려면 다음을 수행합니다.

  1. Exchange 시스템 관리자를 엽니다.

  2. 받는 사람에서 받는 사람 업데이트 서비스를 클릭합니다. 오른쪽 탐색 창에서 해당하는 받는 사람 업데이트 서비스 인스턴스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. Exchange Server 아래의 일반 탭에서 찾아보기를 클릭한 다음 이 RUS 인스턴스를 실행할 새 Exchange 2000 Server 또는 Exchange Server 2003 서버를 지정합니다.

  4. 확인을 클릭한 다음 다시 확인을 클릭하여 변경 내용을 적용합니다.


진행 중인 다수의 분류
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-21

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 SMTP Server 성능 개체의 Cat: Categorizations in progress 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Cat: Categorizations in progress 성능 카운터는 진행 중인 분류 수를 표시합니다.

이 쿼리에 대해 Exchange Server Analyzer는 2분 동안 6초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 중 성능 카운터의 평균 값을 보고합니다.

샘플 기간 동안 진행 중인 평균 분류 수가 800을 넘으면 Exchange Server Analyzer에서 오류를 표시합니다.

분류기가 수행하는 핵심 작업은 다음과 같습니다.

  • 모든 받는 사람을 확인하고 유효성을 검사합니다.

  • 모든 받는 사람의 한계와 제한을 확인합니다.

  • 필요한 경우 메일 그룹을 확장합니다.

  • 메시지를 로컬 배달할지 아니면 원격 배달할지 확인합니다.

이 오류는 서버의 로드가 지나치게 많거나 서버에 성능 관련 문제가 있음을 나타낼 수 있습니다.

이 오류를 해결하려면 다음을 수행합니다.

  • 분류기 스트레스가 예상된 로드에서 비롯된 것인지 일반 로드에서 비롯된 것인지 확인합니다. 분류기 스트레스가 예상된 로드에서 비롯된 경우 다음 Microsoft TechNet 문서에서 Exchange 성능 관련 내용을 검토하십시오.

    • "Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)

    • "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)

  • 분류기 스트레스가 예상된 로드에서 비롯된 경우가 아니면 로드를 생성했을 수 있는 바이러스 확산이나 스팸을 확인합니다.

메시지 분류기 성능 카운터는 각 SMTP(Simple Mail Transfer Protocol) 가상 서버 인스턴스에 대해 별도로 게시되어 있습니다. 메시지 분류기와 관련하여 사용 가능한 성능 카운터 목록은 Microsoft 기술 자료 문서 231734, "XCON: Performance Monitor Counters for Message Categorizer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)를 참조하십시오.


메일 그룹 배달 제한이 설정된 다수의 사서함
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-21

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에 있는 각 사용자 개체의 다음 특성을 쿼리하여 메일 그룹 구성원을 기반으로 배달 제한이 설정된 도메인 사서함이 있는지 확인합니다.

dLMemDefault | 메시지를 기본적으로 수락할 것인지 거부할 것인지 제어합니다. 기본 설정 1로 지정하면 모든 사용자의 메시지가 수락됩니다.
dLMemRejectPerms | 해당 구성원이 이 받는 사람에게 메일을 보낼 수 없는 메일 그룹(DL)의 DN을 포함합니다.
dLMemSubmitPerms | 해당 구성원이 이 받는 사람에게 메일을 보낼 수 있는 메일 그룹(DL)의 DN을 포함합니다.

메일 그룹 구성원을 기반으로 배달 제한이 설정된 도메인 사서함 수가 500보다 많은 경우 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 메일 그룹 구성원을 기반으로 하는 많은 사서함의 배달 제한이 Exchange 메일 흐름 성능에 영향을 줄 수 있음을 나타냅니다.

기본적으로 분류기는 메일 그룹을 반복적으로 확장하고 시스템을 통과하는 각 메시지에 대한 제한 사항을 검사합니다.

메시지 분류기는 메일 그룹의 메시지를 수락하거나 거부하는 사용자에게 메일을 보내는 경우 메일 그룹의 구성원을 확장하고 구성원의 전체 DN 목록을 가져온 다음 해당 DN 목록을 보낸 사람 DN 목록과 비교해야 합니다. DN이 두 목록에 모두 나타나는 경우 액세스 작업이나 거부 작업이 수행됩니다. 메일 그룹이 다른 메일 그룹에 중첩된 경우 중첩 메일 그룹도 확장됩니다.

이 오류를 해결하려면 다음을 수행합니다.

  • 메일 그룹 배달 제한이 설정된 사용자를 검사하고 필요 없는 제한을 제거합니다.

  • Microsoft 기술 자료 문서 812298, "Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)의 지시에 따라 메일 그룹이 아닌 개별 사서함에 배달 제한을 구성합니다.

  • Exchange Server 2003 서비스 팩 2(SP2) 이후 버전을 실행하는 서버의 경우 비계층 제한 검사를 구현합니다. Exchange Server 2003 SP2 이전 버전의 Exchange를 실행하는 서버의 경우 Exchange Server 2003 SP2로 업그레이드합니다.

자세한 정보

비계층 제한 검사에 대한 자세한 내용은 비계층적인 제한 검사를 고려합니다.를 참조하십시오.

메일 그룹 제한이 Exchange Server 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 895407, "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 839949, "Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)

  • 812298, "Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)


혼합 모드 조직에서 최소 순위의 라우팅을 사용합니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 혼합 모드 환경에서 Exchange Server 버전 5.5를 실행 중인 서버에서 최소 순위의 라우팅을 사용할 수 있는지 확인합니다. Exchange Server Analyzer는 다음 조건이 존재하는 경우 경고 메시지를 표시합니다.

  • 최소 순위의 라우팅을 사용할 수 있습니다.

  • 조직에서 Exchange Server 5.5가 있는 혼합 모드 환경에서 Exchange Server 2003을 실행하고 있습니다.

최소 순위의 라우팅을 혼합 모드 환경에서 사용 가능할 경우 메시지 루프가 생성될 수 있습니다. Exchange Server 2003은 링크 상태 라우팅을 사용합니다. 따라서 Exchange Server 2003은 링크가 다운된 경우 다른 서버로 메시지를 다시 라우팅합니다. Exchange Server 5.5 서버에서 Message Transfer Agent 속성 페이지의 Only use least cost routes 옵션을 사용하는 경우 메시지를 보낸 Exchange Server 2003 서버로 메시지를 다시 보내는 것이 최상의 경로로 결정되는 경우가 많습니다. 메시지를 Exchange Server 2003 서버로 다시 보내면 경로가 루프가 됩니다.

Exchange Server 5.5와 Exchange Server 2003을 모두 실행 중인 혼합 모드 조직에서는 Exchange Server 5.5를 실행 중인 모든 서버에서 최소 순위의 라우팅 옵션을 사용할 수 없게 하는 것이 좋습니다.

Exchange Server 5.5에서 최소 순위의 라우팅을 사용할 수 없게 하려면 다음을 수행합니다.

  1. Microsoft Exchange Server Administrator 프로그램에서 조직 컨테이너, 사이트 컨테이너, 구성 컨테이너, 서버 컨테이너를 차례로 확장한 다음 서버 개체를 클릭합니다.

  2. 오른쪽 창에서 메시지 전송 에이전트(MTA) 개체를 클릭합니다.

  3. 파일 메뉴를 클릭한 다음 속성을 클릭합니다.

  4. 메시지 전송 에이전트(MTA) 속성 대화 상자의 일반 탭에서 Only use least cost routing의 선택을 해제합니다.

  5. 확인을 클릭합니다.


SMTP에 대한 수신 대기 포트가 기본값인 25에서 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 msExchServerBindings 특성에 구성된 값이 기본값 25가 아닌 다른 값으로 변경되었는지 여부를 확인합니다. 기본적으로 msExchServerBindings 특성은 TCP 포트 25로 구성되어 있습니다. Exchange Server Analyzer는 이 특성 값이 25가 아닌 경우 기본 구성이 아니라는 메시지를 표시합니다.

msExchServerBindings 특성은 이 SMTP(Simple Mail Transfer Protocol) 서버가 들어오는 연결을 수신 대기하는 TCP 포트를 나타냅니다. 하나 이상의 TCP 포트를 수신 대기하도록 SMTP 가상 서버를 구성할 수 있습니다. 기본적으로 모든 SMTP 가상 서버는 기본 SMTP 포트인 TCP 포트 25에서 수신 대기하도록 구성됩니다. SMTP 수신 대기 포트가 기본값에서 변경되어 더 이상 수신 대기 포트 목록에 TCP 포트 25가 들어 있지 않으면 메일 흐름이 중단될 수 있습니다.

내부 메시징 인프라의 나머지 부분도 이에 맞게 변경할 경우 SMTP 수신 대기 포트를 변경하는 것도 가능합니다. 그러나 일반적으로 포트 25를 통해 인터넷으로 메시지를 보내는 SMTP 서버와 마찬가지로 인터넷에서 메시지를 직접 받는 SMTP 가상 서버에 대해서는 대체 포트를 사용할 수 없습니다.

Exchange Server Analyzer는 Exchange SMTP 프로토콜 가상 서버에 대한 값을 계속 확인합니다. 이 SMTP 프로토콜 가상 서버는 인터넷에서 메시지를 직접 받는 SMTP 서버일 수도 있고 아닐 수도 있습니다. 포트 25를 통해 인터넷에서 SMTP 메시지를 받아 다른 포트의 Exchange SMTP 가상 서버로 리디렉션하도록 설계된 바이러스 백신 및 스팸 방지 제품이 있습니다. 이 시나리오에서는 포트 25 이외의 다른 포트에서 수신을 대기하도록 Exchange SMTP 가상 서버를 구성할 수 있습니다.

SMTP 가상 서버 수신 대기 포트를 확인 또는 수정하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, Exchange 서버, 프로토콜 및 SMTP를 차례로 확장합니다.

  2. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭을 선택한 다음 고급을 클릭합니다.

  4. IP 주소 및 포트 목록이 표시됩니다.

    • 기존 포트를 변경하려면 IP 주소를 선택한 다음 편집을 클릭합니다. TCP 포트 필드를 25로 변경합니다.

    • 포트 25를 추가 수신 대기 포트로 추가하려면 추가를 클릭하고 새 IP 주소/포트 조합을 추가합니다. 연결, 보낸 사람 또는 받는 사람 필터링을 사용할 경우 해당 확인란을 선택해야 합니다.

  5. 확인을 클릭하여 변경 내용을 저장한 다음 확인을 클릭하여 고급 대화 상자를 끝냅니다. 확인을 클릭하여 SMTP 가상 서버에 대한 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


로컬 배달 큐가 고정되었습니다
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-03

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 로컬 배달 큐의 StateFrozen 키 값을 확인합니다.

Exchange Server Analyzer는 Exchange 서버에서 로컬 배달 큐의 StateFrozen 키 값이 True로 설정되어 있음을 발견하면 오류를 표시합니다.

큐가 고정되었다는 것은 해당 큐에 대한 전송 세션이 중지되었음을 의미합니다. 고정된 큐에서는 새 메시지가 추가될 수는 있어도 메시지가 나갈 수는 없습니다. 각 링크 큐에 대한 바로 가기 메뉴를 사용하여 연결 상태를 수동으로 변경할 수 있습니다. 강제 연결 명령을 사용하여 큐 상태를 활성으로 변경하면 바로 해당 큐의 메시지를 보내는 연결을 사용할 수 있습니다.

로컬 배달 큐에는 Exchange Server 사서함이나 공용 폴더 저장소로 로컬 배달을 위해 Exchange 서버에 대기 중인 메시지가 들어 있습니다.

Exchange 서버에서 로컬로 배달할 메시지를 수락하지 않는 경우 이 큐에 메시지가 누적될 수 있습니다. 메시지 배달 속도가 느리거나 제때 배달되지 않으면 메시지 루핑 또는 성능에 문제가 있는 것일 수 있습니다.

이 오류를 해결하려면 MSExchangeTransport 서비스의 진단 로깅을 증가시켜 분류기 구성 요소에 대한 정보를 수집하십시오.

로깅 설정 수정 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에서 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


'로컬 배달' 큐가 재시도 중입니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-03

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 로컬 배달 큐의 StateRetry 키 값을 확인합니다.

Exchange Server Analyzer는 Exchange 서버에서 로컬 배달 큐의 StateRetry 키 값이 True로 설정되어 있음을 발견하면 오류를 표시합니다.

큐 상태가 재시도이면 이전에 큐의 메시지를 처리하려고 시도했을 때 최소 한 번 이상 오류가 발생했음을 나타냅니다. 강제 연결 명령을 사용하여 재시도 또는 예약됨 상태의 큐를 활성 상태로 변경할 수 있습니다. 그러면 재시도 간격이 지났거나 예약된 시간에 도달한 것처럼 큐가 작동합니다. 그러나 이 방법이 제대로 작동하지 않는 경우도 있습니다. 큐의 속성이 큐가 재시도 상태에 있어야 하는 특정 이유를 나타낼 수 있습니다.

로컬 배달 큐에는 Exchange Server 사서함이나 공용 폴더 저장소로 로컬 배달을 위해 Exchange 서버에 대기 중인 메시지가 들어 있습니다.

Exchange 서버에서 로컬로 배달할 메시지를 수락하지 않는 경우 이 큐에 메시지가 누적될 수 있습니다. 메시지 배달 속도가 느리거나 제때 배달되지 않으면 메시지 루핑 또는 성능에 문제가 있는 것일 수 있습니다.

이 오류를 해결하려면 MSExchangeTransport 서비스의 진단 로깅 수준을 높여서 분류기 구성 요소에 대한 정보를 수집합니다.

로깅 설정 수정 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에서 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


메일 수락 오류
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 다음과 같이 SMTP(Simple Mail Transfer Protocol) 도메인에 대한 사용자 정의 계정 또는 전자 메일 관리자 계정에 메시지를 보내려고 시도합니다.

  • Exchange Server Analyzer가 SMTP 서버에 대한 소켓 연결을 엽니다. Exchange Server Analyzer가 응답 코드 220을 받으면 이 단계가 성공적으로 완료된 것으로 간주됩니다.

  • Exchange Server Analyzer가 EHLO SMTP 명령 동사를 전송합니다. 다음 조건에 해당되는 경우 이 단계는 성공적으로 완료되었다고 간주됩니다.

    • Exchange Server Analyzer가 250의 여러 응답 코드를 받습니다.

    • 이러한 응답 중 하나에 250-X-LINK2STATE 및 250-XEXCH50가 포함됩니다.

  • Exchange Server Analyzer가 MAIL FROM: ExMFA-MailAcceptTest@Fabrikam.com SMTP 명령 동사를 전송합니다. Exchange Server Analyzer가 응답 코드 250을 받으면 이 단계가 성공적으로 완료된 것으로 간주됩니다.

  • Exchange Server Analyzer가 RCPT TO: Postmaster(또는 사용자 정의 계정)@<domainname>.com SMTP 명령 동사를 전송합니다. Exchange Server Analyzer가 응답 코드 250을 받으면 이 단계가 성공적으로 완료된 것으로 간주됩니다.

  • Exchange Server Analyzer가 마침표로 끝나는 예제 메시지 본문과 함께 DATA SMTP 명령 동사를 전송합니다. Exchange Server Analyzer가 응답 코드 250을 받으면 이 단계가 성공적으로 완료된 것으로 간주됩니다.

Exchange Server Analyzer가 모든 단계 중 하나라도 완료하지 못하면 오류가 표시됩니다. 이 오류는 일반적인 메일 전송 문제가 있음을 나타냅니다. 다음 링크는 서버 수준부터 시작해서 네트워크 수준까지 문제를 해결해야 하는 순서대로 나열되어 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?linkid=47579)의 "라우팅 문제 해결 방법"을 참조하십시오.

  2. Microsoft 기술 자료 문서 324867, "웹캐스트: Microsoft Exchange 2000 Server: 메일 이동 문제 해결 방법(재고)"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867)을 참조하십시오.

  3. Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489)을 참조하십시오.

  4. Microsoft 기술 자료 문서 324759, "웹캐스트: Microsoft Exchange 2000 Server: 전송 시 DNS 문제 해결 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759)을 참조하십시오.

Exchange Server의 전자 메일 관리자 계정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 223860, "XCON: SMTP 전자 메일 관리자 사서함은 수동으로 설정해야 한다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860)

  • 313832, "Exchange 2000 Server에서 SMTP 전자 메일 관리자 계정을 설정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832)


메일 수락 실패, BDAT 명령
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-21

Microsoft® Exchange Server Analyzer Tool은 ESMTP(EHLO Extended Simple Mail Transfer Protocol) 명령 동사를 원격 서버의 포트 25로 전송하고 그 응답을 분석하여 원격 서버에서 BDAT ESMTP 동사를 지원하는지 확인합니다.

BDAT 명령 동사에 대한 응답으로 원격 서버로부터 받은 응답에서 검색할 수 없음 오류를 나타내지 않는 경우 Exchange Server Analyzer는 테스트 메시지를 원격 서버로 전송하고 그 응답을 분석하여 메시지 전송에 성공했는지 확인합니다.

예상 응답 문자열 '250'을 받지 못하면 Exchange Server Analyzer에서 오류를 표시합니다.

Exchange Server 2003은 Exchange별 확장 SMTP 동사를 사용하여 Exchange Server를 실행하는 조직의 다른 서버와 통신합니다. 표준 SMTP보다 Exchange별 확장 SMTP 동사를 사용하여 통신하는 것이 더 효율적입니다. ESMTP 명령 집합을 지원하지 않는 경우 Exchange Server 성능이 저하될 수 있습니다.

BDAT ESMTP 명령 동사는 DATA 명령 대신 사용됩니다. SMTP 가상 서버가 EHLO 키워드에 CHUNKING으로 응답하면 SMTP 서버에서 BDAT 명령을 지원하고 청크의 메시지를 수락합니다. 두 개의 인수가 필요합니다.

  • 첫 번째 인수는 이진 데이터 패킷의 길이를 나타내므로 SMTP 호스트가 데이터의 끝까지 연속해서 검색할 필요가 없습니다. 받는 서버에서는 메시지 바이트 수를 계산합니다. 메시지 크기가 BDAT 명령에서 보낸 값과 같으면 서버는 모든 메시지 데이터를 받은 것으로 간주합니다.

  • 두 번째 인수는 데이터 패킷이 현재 전송의 마지막 패킷인지 여부를 나타냅니다. 두 번째 인수는 선택 사항입니다.

이 오류눈 원격 서버에서 BDAT ESMTP 명령 동사를 지원하지만 후속 BDAT 메일 수락 테스트가 실패했음을 나타냅니다.

이 오류를 해결하려면 메시징 환경에서 BDAT 명령 동사를 차단할 수 있는 다음과 같은 문제나 구성을 확인합니다.

  • 일시적인 네트워크 중단

  • SMTP 프록시

  • 방화벽

  • 응용 프로그램

이러한 동사에 대한 기본 지원을 제거하거나 복원하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 257569, "XFOR: Exchange 2000 Server에서 ESMTP 동사(Verb)를 해제하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569)을 참조하십시오.

Exchange Server에서 ESMTP 명령 동사를 사용하는 방법에 대한 자세한 내용은 Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkID=71800)의 "Exchange SMTP 적절한 로드 방법"을 참조하십시오.


일반 대상으로 식별된 사서함 저장소
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-04

Microsoft® Exchange Server Analyzer Tool은 Exchange_Queue WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP 가상 서버의 SMTP(Simple Mail Transfer Protocol) 큐에 대한 다음 특성 값을 확인합니다.

LinkId | 큐를 포함한 링크의 식별자를 나타냅니다.
QueueId | 큐의 식별자를 나타냅니다.
QueueName | 큐의 이름을 나타냅니다.
VirtualMachine | 큐를 포함한 가상 컴퓨터의 이름을 나타냅니다.
VirtualServerName | 큐가 있는 가상 서버의 이름을 나타냅니다.
MessageCount | 큐에 있는 메시지 수를 나타냅니다.

Exchange Server Analyzer는 여기서 얻은 정보를 사용해 Exchange_QueuedSMTPMessage WMI 클래스를 쿼리하여 큐에 있는 메시지의 다음 특성 값을 확인합니다.

Recipients | 메시지를 받는 사람을 나타냅니다.
Received | 메시지를 받은 타임 스탬프를 나타냅니다.
MessageId | 큐에 대기 중인 메시지의 식별자를 나타냅니다.
StateRetry | 제대로 배달되지 않은 메시지에 대해 다시 전송을 시도하는 상태임을 나타냅니다.

마지막으로 Exchange Server Analyzer는 여기서 얻은 데이터를 사용해 Active Directory® 디렉터리 서비스를 쿼리하여 각 Recipient 개체의 다음 값을 확인합니다. 그런 다음 받는 사람이 사용자인지, 메일 그룹인지, 공용 폴더인지, 공용 폴더 저장소인지를 확인합니다.

distinguishedName | 개체의 고유 이름을 나타냅니다.
msExchHomeServerName | 받는 사람이 상주하고 있는 서버를 나타냅니다.
homeMDB | 받는 사람의 사서함 저장소를 나타냅니다.

Exchange Server Analyzer는 큐에 대기 중인 메시지 중 적어도 25퍼센트 이상이 To: 또는 Cc: 필드에서 동일한 사서함 저장소에 사서함을 갖고 있는 받는 사람에게 배달되는 경우에 경고를 표시합니다.

또한 큐에 대기 중인 메시지 중 적어도 50퍼센트 이상이 To: 또는 Cc: 필드에서 동일한 사서함 저장소에 사서함을 갖고 있는 받는 사람에게 배달되는 경우에는 오류를 표시합니다.

이러한 경고 또는 오류는 식별된 사서함 저장소가 SMTP 큐에 대기 중인 메시지의 일반 대상임을 의미합니다.

이 문제를 해결하려면 사서함 저장소에 구성 문제나 메시지가 큐에 대기되도록 하는 기타 예외적인 문제가 있는지 확인해야 합니다.

  • 저장소 개체 특성이 올바르게 설정되어 있고 Active Directory에 올바른 값이 포함되어 있는지 확인합니다.

  • 저장소 개체의 Active Directory 사용 권한이 올바르게 설정되어 있는지 확인합니다.

  • 사서함 저장소가 지정한 저널링 받는 사람과 같은 특별한 용도의 사용자 개체용 저장소인 경우, 사용자 개체가 연관된 서비스나 구성 요소의 구성이 올바른지 확인합니다.

  • 저장소 받는 사람에 대한 UCE(원치 않는 상업성 전자 메일 메시지)나 스팸 또는 바이러스 공격이 있는지 확인합니다.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 전송 및 라우팅 가이드의 "메일 흐름 및 SMTP 문제 해결"(http://go.microsoft.com/fwlink/?LinkID=67875)

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)


'대상에 연결할 수 없는 메시지' 큐가 메시지를 보유함
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-04

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 서버에서 SMTP(Simple Mail Transfer Protocol) 큐의 TypeCurrentlyUnreachable, LinkName 및 NumberofMessages 속성 값을 확인합니다.

TypeCurrentlyUnreachable 속성이 True면 현재 대상에 연결할 수 없는 메시지를 링크(Exchange 큐)에서 보유하게 됩니다.

기본LinkName 속성은 링크의 이름을 지정합니다.

기본 NumberOfMessages 속성은 링크 전체에서 전송 대기 중인 메시지의 수를 지정합니다.

Exchange Server Analyzer는 대상에 연결할 수 없는 메시지 SMTP 큐에 메시지가 있는 것이 확인되면 오류를 표시합니다.

이 오류는 의도한 대상 서버에 연결할 수 없는 메시지가 큐에 있음을 나타냅니다. 예를 들어 Exchange가 최종 대상의 경로나 커넥터를 확인할 수 없습니다. 또는 사용 가능한 모든 경로나 커넥터가 다운된 것으로 표시됩니다.

이 오류를 해결하려면 다음 단계를 수행하십시오.

  • 대상에 연결할 수 없는 메시지 큐의 메시지가 합법적인지 확인합니다.

  • Exchange Server Analyzer에서 제공한 오류 안내와 링크를 검토합니다.

  • 이 항목의 뒷 부분에 나오는 "추가 정보" 안내를 따릅니다.

추가 정보

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결".

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)


'대상에 연결할 수 없는 메시지' 큐가 고정됨
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-06

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 대상에 연결할 수 없는 메시지 큐의 StateFrozen 키 값을 확인합니다.

Exchange Server Analyzer는 Exchange 서버에서 대상에 연결할 수 없는 메시지 큐의 StateFrozen 키 값이 True로 설정되어 있음을 발견하면 오류를 표시합니다.

큐가 고정되었다는 것은 해당 큐에 대한 전송 세션이 중지되었음을 의미합니다. 고정된 큐에서는 새 메시지를 추가할 수는 있어도 메시지를 보낼 수 없습니다.

대상에 연결할 수 없는 메시지 큐에는 의도한 대상 서버에 연결할 수 없는 메시지가 포함됩니다. 예를 들어 Exchange가 최종 대상의 경로나 커넥터를 확인할 수 없습니다. 또는 사용 가능한 모든 경로나 커넥터가 다운된 것으로 표시됩니다. 다음과 같은 상황 중 하나에 해당하면 이 큐에 메시지가 누적됩니다.

  • 메시지 배달 경로가 없습니다.

  • Exchange 커넥터나 원격 배달 큐를 사용할 수 없습니다.

  • Exchange 커넥터나 원격 배달 큐가 재시도 상태이며 커넥터나 원격 대상의 대체 경로가 없을 때 새 메시지가 이 큐로 이동합니다.

이 오류를 해결하려면 각 링크 큐에 대한 바로 가기 메뉴를 사용하여 연결 상태를 수동으로 변경합니다. 강제 연결 명령을 사용하여 큐 상태를 활성으로 변경하면 바로 해당 큐의 메시지를 보내는 연결을 사용할 수 있습니다. 오류가 계속되면 다음에 나오는 "추가 정보"에 설명된 것처럼 큐 엔진의 진단 로깅 수준을 높입니다.

추가 정보

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결".

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


'대상에 연결할 수 없는 메시지' 큐가 재시도 중임
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-06

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 대상에 연결할 수 없는 메시지 큐의 StateRetry 키 값을 확인합니다.

Exchange Server Analyzer는 Exchange 서버에서 대상에 연결할 수 없는 메시지 큐의 StateRetry 키 값이 True로 설정되어 있음을 발견하면 오류를 표시합니다.

큐가 재시도 상태이면 이전에 큐에 있는 메시지 처리를 시도했을 때 한 번 이상 오류가 발생했음을 나타냅니다.

참고:
큐의 속성은 큐가 재시도 상태에 있어야 하는 구체적인 이유를 나타낼 수 있습니다.

대상에 연결할 수 없는 메시지 큐에는 의도한 대상 서버로 전달될 수 없는 메시지가 포함됩니다. 예를 들어 Exchange가 최종 대상의 경로나 커넥터를 확인할 수 없습니다. 또는 사용 가능한 모든 경로나 커넥터가 다운된 것으로 표시됩니다. 다음과 같은 상황 중 하나에 해당하면 이 큐에 메시지가 누적됩니다.

  • 메시지 배달 경로가 없습니다.

  • Exchange 커넥터나 원격 배달 큐를 사용할 수 없습니다.

  • Exchange 커넥터나 원격 배달 큐가 재시도 상태이며 커넥터나 원격 대상의 대체 경로가 없을 때 새 메시지가 이 큐로 이동합니다.

이 오류를 해결하려면 강제 연결 명령을 사용하여 재시도 상태를 활성 상태로 변경합니다. 그러면 큐는 재시도 간격이 지나 버린 것처럼 작동합니다. 그러나 이 방법이 제대로 작동하지 않는 경우도 있습니다. 오류가 계속되면 다음에 나오는 "추가 정보"에 설명된 것처럼 큐 엔진의 진단 로깅 수준을 높입니다.

추가 정보

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결".

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 필드 및 X.400 큐 속성 탭의 필드 설명" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


메일 그룹 배달 제한이 설정된 사서함
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-21

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에 있는 각 사용자 개체의 다음 특성을 쿼리하여 메일 그룹 구성원을 기반으로 배달 제한이 설정된 도메인 사서함이 있는지 확인합니다.

dLMemDefault | 메시지를 기본적으로 수락할 것인지 거부할 것인지 제어합니다. 기본 설정 1로 지정하면 모든 사용자의 메시지가 수락됩니다.
dLMemRejectPerms | 해당 구성원이 이 받는 사람에게 메일을 보낼 수 없는 메일 그룹(DL)의 DN을 포함합니다.
dLMemSubmitPerms | 해당 구성원이 이 받는 사람에게 메일을 보낼 수 있는 메일 그룹(DL)의 DN을 포함합니다.

메일 그룹 구성원을 기반으로 배달 제한이 설정된 도메인 사서함이 있는 경우 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 메일 그룹 구성원을 기반으로 하는 배달 제한이 Exchange Server 메일 흐름 성능에 영향을 줄 수 있음을 나타냅니다.

기본적으로 분류기는 메일 그룹을 반복적으로 확장하고 시스템을 통과하는 각 메시지에 대한 제한 사항을 검사합니다.

메시지 분류기는 메일 그룹의 메시지를 수락하거나 거부하는 사용자에게 메일을 보내는 경우 메일 그룹의 구성원을 확장하고 구성원의 전체 DN 목록을 가져온 다음 해당 DN 목록을 보낸 사람 DN 목록과 비교해야 합니다. DN이 두 목록에 모두 나타나는 경우 액세스 작업이나 거부 작업이 수행됩니다. 메일 그룹이 다른 메일 그룹에 중첩된 경우 중첩 메일 그룹도 확장됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  • 메일 그룹 배달 제한이 설정된 사용자를 검사하고 필요 없는 제한을 제거합니다.

  • Microsoft 기술 자료 문서 812298, "Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)의 지시에 따라 메일 그룹이 아닌 개별 사서함에 배달 제한을 구성합니다.

  • Exchange Server 2003 서비스 팩 2(SP2) 이후 버전을 실행하는 서버의 경우 비계층 제한 검사를 구현합니다. Exchange Server 2003 SP2 이전 버전의 Exchange를 실행하는 서버의 경우 Exchange Server 2003 SP2로 업그레이드합니다.

자세한 정보

비계층 제한 검사에 대한 자세한 내용은 비계층적인 제한 검사를 고려합니다.를 참조하십시오.

메일 그룹 제한이 Exchange Server 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 895407, "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 839949, "Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)

  • 812298, "Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)


받는 메시지의 최대 크기가 설정되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 다음 위치에 있는 전역 설정 delivContLength 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Exchange Server Analyzer는 delivContLength 특성 값이 1보다 작은 경우 오류를 표시합니다.

이 오류는 받는 메시지의 최대 크기 제한이 설정되어 있지 않음을 나타냅니다. 조직의 네트워크 대역폭 및 사용자 요구에 따라 메시지 크기를 제한할 수 있습니다. Exchange 2000 Server 및 Exchange Server 2007에는 기본 메시지 크기 제한이 없습니다. Exchange Server 2003에서 메시지를 주고 받을 때 적용되는 기본 크기 제한은 10,240KB입니다. Exchange Server 2003의 이 기본 크기 제한은 메시지 크기 제한이 설정되지 않은 Exchange 2000 Server의 업그레이드와 새로운 설치에 적용됩니다.

사용자가 대용량 전자 메일 메시지를 주고받지 못하게 하는 메시지 크기 제한을 설정하면 시스템 리소스를 절약할 수 있습니다. 메시지 크기 제한을 설정하면 네트워크 소통량을 제한하고 디스크 공간을 절약하며 전체 네트워크 성능을 향상시키는 데 도움이 됩니다. Exchange 2000 Server 및 Exchange Server 2003의 경우, 전역 설정의 메시지 배달 속성에 있는 기본값 탭을 사용하면 받는 메시지와 보내는 메시지에 대한 메시지 배달 제한 사항을 지정할 수 있습니다. 최대 개별 메시지 크기를 설정하려면 최대 크기(KB)를 선택한 다음 입력란에 최대 크기(KB)를 입력합니다. 메시지 크기를 제한하지 않으려면 제한 없음을 선택합니다. 조직의 메시지 발신자는 지정된 크기 제한을 초과하는 메시지를 사용자에게 전송하려고 할 때 NDR을 수신합니다. 인터넷 메시지 형식에서 구성한 NDR 설정에 따라 외부의 보낸 사람은 NDR을 받거나 받지 못할 수 있습니다.

Exchange Server 2007의 경우 Exchange 관리 셸을 사용하여 Exchange 조직의 TransportConfig MaxReceiveSize 매개 변수를 설정할 수 있습니다.

최대 메시지 크기 제한을 10MB 미만으로 설정하는 것이 좋습니다. 그러나 Exchange 조직을 통해 대용량 첨부 파일이 포함된 메시지를 보낼 수 있도록 충분한 메시지 크기 제한이 필요한 경우에는 받는 메시지의 최대 크기 제한을 30MB로 늘려야 할 수도 있습니다. 메시지 크기 제한을 30MB 이상으로 늘리면 네트워크 성능이 저하되고 시스템이 보안 공격에 더 취약해질 수 있습니다.

Exchange 2000 Server 및 Exchange Server 2003에서 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange System Manager에서 전역 설정을 확장하고 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 메시지 배달 속성 대화 상자의 기본값 탭에서 받는 메시지 크기 제한 옵션을 선택하고 원하는 크기 제한을 입력합니다.

Exchange Server 2007에서 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange 관리 셸에서 다음 명령을 실행합니다. 여기서 <size>는 기본값인 "unlimited"로 입력하거나 0에서 2147483647바이트 사이의 크기를 B(바이트), KB(킬로바이트) 또는 MB(메가바이트) 단위로 입력합니다.
코드 복사
Set-TransportConfig -MaxReceiveSize <size>

예를 들어 Exchange 조직에서 받는 사람이 전송받을 수 있는 최대 메시지 크기를 10MB로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxReceiveSize 10MB

Exchange 조직에서 받는 사람이 전송받을 수 있는 최대 메시지 크기를 기본값인 무제한으로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxReceiveSize unlimited
  • Exchange 2000 Server 및 Exchange Server 2003에서의 메시지 크기 제한 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서, "Exchange Server에서 메시지 크기 제한을 설정하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)을 참조하십시오.

  • Exchange Server 2007에서의 TransportConfig cmdlet에 대한 자세한 내용은 Exchange Server 2007 Technical Reference의 "Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkID=79237)를 참조하십시오.

  • 인터넷 메시지 형식에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "SMTP 정책을 사용하여 아웃바운드 메일 서식 및 자동 응답 제어"를 참조하십시오.


받는 메시지의 최대 크기가 너무 크게 설정되었습니다(>30MB).
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-02-27

Microsoft® Exchange Server Analyzer Tool은 다음 위치에 있는 전역 설정 delivContLength 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Exchange Server Analyzer는 delivContLength 특성 값이 30720보다 작으면 오류를 표시합니다.

이 오류는 받는 메시지의 최대 크기 제한이 30MB보다 큰 값으로 설정되어 있음을 나타냅니다. Exchange 2000 Server 및 Exchange Server 2007에는 기본 메시지 크기 제한이 없습니다. Exchange Server 2003에서 메시지를 주고받을 때 적용되는 기본 크기 제한은 10,240KB입니다. 이 기본 크기 제한은 새 설치 및 메시지 크기 제한이 설정되지 않은 Exchange 2000 Server의 업그레이드에 적용됩니다.

메시지 크기 제한을 설정하여 사용자가 대용량 전자 메일 메시지를 주고받을 수 없게 하면 시스템 리소스를 절약할 수 있습니다. 메시지 크기 제한을 설정하면 네트워크 소통량을 제한하고 디스크 공간을 절약하며 전체 네트워크 성능을 향상시키는 데 도움이 됩니다. Exchange 2000 Server 및 Exchange Server 2003의 경우 전역 설정의 메시지 배달 속성에 있는 기본값 탭을 사용하면 받는 메시지와 보내는 메시지에 대한 메시지 배달 제한 사항을 지정할 수 있습니다. 최대 개별 메시지 크기를 설정하려면 최대 크기(KB)를 선택한 다음 입력란에 최대 크기(KB)를 입력합니다. 메시지 크기를 제한하지 않으려면 제한 없음을 선택합니다. 조직의 보낸 사람은 지정된 크기 제한을 초과하는 메시지를 사용자에게 전송하려고 하면 배달 못 함 보고서(NDR)를 받게 됩니다. 인터넷 메시지 형식에서 구성한 NDR 설정에 따라 외부의 보낸 사람은 NDR을 받거나 받지 못할 수 있습니다.

Exchange Server 2007의 경우 Exchange 관리 셸을 사용하여 Exchange 조직의 TransportConfig MaxSendSize 매개 변수를 설정할 수 있습니다.

최대 메시지 크기 제한을 30MB 미만으로 설정하는 것이 좋습니다. 그러나 Exchange 조직을 통해 대용량 첨부 파일이 포함된 메시지를 보낼 수 있도록 충분한 메시지 크기 제한이 필요한 경우에는 받는 메시지의 최대 크기 제한이 30MB를 초과하도록 늘려야 할 수도 있습니다. 메시지 크기 제한을 30MB 이상으로 늘리면 네트워크 성능이 저하되고 시스템이 보안 공격에 더 취약해질 수 있습니다.

중요:
순수한 Exchange 2000 Server/Exchange Server 2003 환경과 Exchange Server 2007 환경에서 다음과 같이 설정하면 큰 차이가 없을 것처럼 보이지만 실제로는 상당히 다른 결과가 나타납니다.

순수한 Exchange 2000 Server/Exchange Server 2003 환경에서 사서함 사용이 가능한 사용자에 대한 전역 설정에서 보내는 메시지 및 받는 메시지의 크기 제한을 0으로 설정하면 메시지 크기 제한을 완전히 제거하는 것이 됩니다.

순수한 Exchange 2007 환경에서 TransportConfig -MaxSendSize 및 TransportConfig -MaxreceiveSize 매개 변수를 0 값으로 설정하면 모든 크기의 메시지 전송이 제한됩니다.

Exchange 2000 Server 및 Exchange Server 2003에서 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange System Manager에서 전역 설정을 확장하고 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 메시지 배달 속성 대화 상자의 기본값 탭에서 받는 메시지 크기 제한 옵션을 선택하고 원하는 크기 제한을 입력합니다.

Exchange Server 2007에서 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange 관리 셸에서 다음 명령을 실행합니다. 여기서 <size>는 기본값인 "unlimited"로 입력하거나 0에서 2147483647바이트 사이의 크기를 B(바이트), KB(킬로바이트) 또는 MB(메가바이트) 단위로 입력합니다.
코드 복사
Set-TransportConfig -MaxReceiveSize <size>

예를 들어 Exchange 조직에서 받는 사람이 전송받을 수 있는 최대 메시지 크기를 10MB로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxReceiveSize 10MB

Exchange 조직에서 받는 사람이 전송받을 수 있는 최대 메시지 크기를 기본값인 무제한으로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxReceiveSize unlimited
  • Exchange 2000 Server 및 Exchange Server 2003에서의 메시지 크기 제한 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 322679, "Exchange Server에서 메시지 크기 제한을 설정하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)을 참조하십시오.

Exchange Server 2007에서의 TransportConfig cmdlet에 대한 자세한 내용은 Exchange Server 2007 Technical Reference의 "Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkID=79237)를 참조하십시오.

  • 인터넷 메시지 형식에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "SMTP 정책을 사용하여 아웃바운드 메일 서식 및 자동 응답 제어"를 참조하십시오.


받는 메시지의 최대 크기가 너무 작게 설정된 것 같습니다(<1MB).
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-01-05

Microsoft® Exchange Server Analyzer Tool은 다음 위치에 있는 전역 설정 delivContLength 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Exchange Server Analyzer는 delivContLength 특성 값이 1,024보다 작고 0보다 큰 경우 오류를 표시합니다.

이 오류는 받는 메시지의 최대 크기 제한이 1MB보다 작은 값으로 설정되었음을 나타냅니다. 이렇게 낮은 값을 설정하면 Exchange Server에서는 사용자의 조직으로 보내지는 메시지 중 일부를 수락하지 않을 수 있습니다. Exchange 2000 Server 및 Exchange Server 2007에는 기본 메시지 크기 제한이 없습니다. Exchange Server 2003에서 메시지를 주고받을 때 적용되는 기본 크기 제한은 10,240KB입니다. 이 기본 크기 제한은 메시지 크기 제한이 설정되지 않은 Exchange 2000 Server 업그레이드와 새로운 설치에 적용됩니다.

메시지 크기 제한을 설정하여 사용자가 대용량 전자 메일 메시지를 주고받을 수 없게 하면 시스템 리소스를 절약할 수 있습니다. 메시지 크기 제한을 설정하면 네트워크 소통량이 제한되고 디스크 공간이 절약되어 전체 네트워크 성능을 향상시키는 데 도움이 됩니다. Exchange 2000 Server 및 Exchange Server 2003의 경우, 전역 설정의 메시지 배달 속성에 있는 기본값 탭을 사용하면 받는 메시지와 보내는 메시지에 대한 메시지 배달 제한 사항을 지정할 수 있습니다. 최대 개별 메시지 크기를 설정하려면 최대 크기(KB)를 선택한 다음 입력란에 최대 크기(KB)를 입력합니다. 메시지 크기를 제한하지 않으려면 제한 없음을 선택합니다. 조직에 있는 보낸 사람은 지정한 크기 제한을 초과하는 사용자에게 메시지를 보내려고 할 경우 NDR을 받습니다. 인터넷 메시지 형식에서 구성한 NDR 설정에 따라 외부의 보낸 사람은 NDR을 받거나 받지 못할 수 있습니다.

Exchange Server 2007의 경우 Exchange 관리 셸을 사용하여 Exchange 조직의 TransportConfig MaxSendSize 매개 변수를 설정할 수 있습니다.

최대 메시지 크기 제한을 10MB 미만으로 설정하는 것이 좋습니다. 그러나 Exchange 조직을 통해 대용량 첨부 파일이 포함된 메시지를 보낼 수 있도록 충분한 메시지 크기 제한이 필요한 경우에는 받는 메시지의 최대 크기 제한을 30MB로 늘려야 할 수도 있습니다. 메시지 크기 제한을 30MB 이상으로 늘리면 네트워크 성능이 저하되고 시스템이 보안 공격에 더 취약해질 수 있습니다.

Exchange 2000 Server 및 Exchange Server 2003에서 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange System Manager에서 전역 설정을 확장하고 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 메시지 배달 속성 대화 상자의 기본값 탭에서 받는 메시지 크기 제한 옵션을 선택하고 원하는 크기 제한을 입력합니다.

Exchange Server 2007에서 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange 관리 셸에서 다음 명령을 실행합니다. 여기서 <size>는 기본값인 "unlimited"로 입력하거나 0에서 2147483647바이트 사이의 크기를 B(바이트), KB(킬로바이트) 또는 MB(메가바이트) 단위로 입력합니다.
코드 복사
Set-TransportConfig -MaxReceiveSize <size>

예를 들어 Exchange 조직에서 받는 사람이 전송받을 수 있는 최대 메시지 크기를 10MB로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxReceiveSize 10MB

Exchange 조직에서 받는 사람이 전송받을 수 있는 최대 메시지 크기를 기본값인 무제한으로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxReceiveSize unlimited
  • Exchange 2000 Server 및 Exchange Server 2003에서의 메시지 크기 제한 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 322679, "Exchange Server에서 메시지 크기 제한을 설정하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)을 참조하십시오.

Exchange Server 2007에서의 TransportConfig cmdlet에 대한 자세한 내용은 Exchange Server 2007 Technical Reference의 "Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkID=79237)를 참조하십시오.

  • 인터넷 메시지 형식에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=47617)의 "SMTP 정책을 사용하여 아웃바운드 메일 서식 및 자동 응답 제어"를 참조하십시오.


MaxDSNSize가 설정되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 DSN(배달 상태 알림) 메시지의 최대 크기가 설정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

또한 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스에 쿼리하여 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인합니다. 문자열 값에 "Version 5.5"가 포함되어 있으면 시스템에서 Microsoft Exchange Server 5.5가 실행되고 있는 것입니다. 문자열 값에 "Version 6.0"이 나타나 있으면 해당 컴퓨터가 Microsoft Exchange Server 2000 Server를 실행 중입니다. 문자열 값에 "Version 6.5"가 나타나 있으면 해당 컴퓨터가 Microsoft Exchange Server 2003을 실행 중입니다.

Exchange Server Analyzer는 Exchange 2000 Server 또는 Exchange Server 2003이 실행되는 컴퓨터에 MaxDSNSize 레지스트리 값이 존재하지 않을 경우 경고를 표시합니다.

MaxDSNSize 레지스트리 값은 Exchange Server에서 DSN의 크기를 제한하는 선택적 값입니다. 이 옵션은 메시지를 배달할 수 없을 경우 첨부 파일을 제거하도록 Exchange를 구성합니다. 이 레지스트리 값을 추가할 경우 10240000바이트(10MB)를 사용하는 것이 좋습니다.

참고:
MaxDSNSize 레지스트리 값은 Exchange 2000 Server 서비스 팩 2(SP2)에 도입되었으므로 이 레지스트리 값이 작동되려면 Exchange 2000 Server SP2 이상의 버전이 필요합니다. 또한 Exchange 2000 Server SP1 이상 버전에서는 MaxDSNSize 레지스트리 값이 없을 경우 값 10MB가 사용됩니다. 원할 경우 MaxDSNSize 레지스트리 값을 추가하여 이 기본 동작을 다시 정의할 수 있습니다.

이 옵션을 설정하면 서버 및 네트워크 리소스를 절약할 수 있습니다. 그러나 이러한 방식으로 구현된 SMTP(Simple Mail Transfer Protocol) 첨부 파일 제거 방법에는 단점이 있습니다. 이 옵션을 사용하여 배달 못 함 보고서(NDR)에서 첨부 파일을 제거하면 미리 보기 창에 알림을 표시하는 데 필요한 세부 사항도 함께 제거되며 메시지 보낸 사람은 다시 보내기 옵션을 사용할 수 없습니다. 메시지 보낸 사람이 NDR에서 다시 보내기 옵션을 사용하려고 하면 다음과 같은 오류 메시지가 표시됩니다: 원본 메시지에 대한 충분한 정보가 없으므로 이 메시지를 다시 보낼 수 없습니다. 이 메시지를 다시 보내려면 보낸 편지함 폴더에서 이 메시지를 연 다음, [동작] 메뉴에서 [메시지 다시 보내기]를 클릭하십시오.

그러나 메시지 보낸 사람은 오류 메시지에 표시된 방법을 사용해도 메시지를 다시 보낼 수 없습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\SMTPSvc를 탐색합니다.

  3. SMTPSvc를 마우스 오른쪽 단추로 클릭하고 새로 만들기 | 키를 선택합니다. 새 키의 이름을 Queuing으로 지정하고 클래스는 비워 둡니다.

  4. Queuing을 마우스 오른쪽 단추로 클릭하고 새로 만들기 | DWORD 값을 선택합니다. 새 값의 이름을 MaxDSNSize로 지정합니다.

  5. 오른쪽 창에서 MaxDSNSize 레지스트리 값을 두 번 클릭하고 값 데이터 필드에 크기 제한(바이트)을 입력합니다. 이 값보다 크기가 더 크며 NDR을 생성하는 메시지는 첨부 파일 또는 전체 메시지 속성을 반환하지 않습니다.

  6. 레지스트리 편집기를 닫고 SMTP(Simple Mail Transfer Protocol) 서비스를 다시 시작하여 변경 내용을 적용합니다.

MaxDSNSize 레지스트리 값에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 308303, "XCON: Option to Strip Attachments for Messages That Generate an NDR"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303)

  • 323484, "XCON: Exchange 2000의 Multipart/Report 인터넷 메시지 형식에 대한 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484)


보내는 메시지의 최대 크기가 설정되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-12-04

Microsoft® Exchange Server Analyzer Tool은 아래에 있는 전역 설정 submissionContLength 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Exchange Server Analyzer는 submissionContLength 특성 값이 1보다 작으면 오류를 표시합니다.

이 오류는 나가는 최대 메시지 크기 제한이 설정되어 있지 않음을 나타냅니다. 네트워크 대역폭 및 조직의 사용자 요구에 따라 메시지 크기를 제한할 수 있습니다. Exchange 2000 Server 및 Exchange Server 2007에는 기본 메시지 크기 제한이 없습니다. Exchange Server 2003에서 메시지를 주고받을 때 적용되는 기본 크기 제한은 10,240KB입니다. 이 기본 크기 제한은 새 설치 및 메시지 크기 제한이 설정되지 않은 Exchange 2000 Server의 업그레이드에 적용됩니다.

메시지 크기 제한을 설정하여 사용자가 대용량 전자 메일 메시지를 주고받을 수 없게 하면 시스템 리소스를 절약할 수 있습니다. 메시지 크기 제한을 설정하면 네트워크 소통량을 제한하고 디스크 공간을 절약하며 전체 네트워크 성능을 향상시키는 데 도움이 됩니다. Exchange 2000 Server 및 Exchange Server 2003의 경우 전역 설정의 메시지 배달 속성에 있는 기본값 탭을 사용하면 받는 메시지와 보내는 메시지에 대한 메시지 배달 제한 사항을 지정할 수 있습니다. 최대 개별 메시지 크기를 설정하려면 최대 크기(KB)를 선택한 다음 입력란에 최대 크기(KB)를 입력합니다. 메시지 크기를 제한하지 않으려면 제한 없음을 선택합니다. 조직의 보낸 사람은 지정된 크기 제한을 초과하는 메시지를 사용자에게 전송하려고 하면 NDR을 받게 됩니다. 인터넷 메시지 형식에서 구성한 NDR 설정에 따라 외부의 보낸 사람이 NDR을 받거나 받지 못할 수 있습니다.

Exchange Server 2007의 경우 Exchange 관리 셸을 사용하여 Exchange 조직의 TransportConfig MaxSendSize 매개 변수를 설정할 수 있습니다.

최대 메시지 크기 제한을 10MB 미만으로 설정하는 것이 좋습니다. 그러나 Exchange 조직을 통해 대용량 첨부 파일이 포함된 메시지를 보낼 수 있도록 충분한 메시지 크기 제한이 필요한 경우에는 보내는 메시지의 최대 크기 제한을 30MB로 늘려야 할 수도 있습니다. 메시지 크기 제한을 30MB 이상으로 늘리면 네트워크 성능이 저하되고 시스템이 보안 공격에 더 취약해질 수 있습니다.

Exchange 2000 Server 및 Exchange Server 2003에서 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange System Manager에서 전역 설정을 확장하고 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 메시지 배달 속성 대화 상자의 기본값 탭에서 보내는 메시지 크기 옵션을 선택하고 원하는 크기 제한을 입력합니다.

Exchange Server 2007에서 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange 관리 셸에서 다음 명령을 실행합니다. 여기서 <size>는 기본값인 "unlimited"로 입력하거나 0에서 2147483647바이트 사이의 크기를 B(바이트), KB(킬로바이트) 또는 MB(메가바이트) 단위로 입력합니다.
코드 복사
Set-TransportConfig -MaxSendSize <size>

예를 들어 Exchange 조직에서 사용자가 전송할 수 있는 최대 메시지 크기를 10MB로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxSendSize 10MB

Exchange 조직에서 사용자가 전송할 수 있는 최대 메시지 크기를 기본값인 무제한으로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxSendSize unlimited
  • Exchange 2000 Server 및 Exchange Server 2003에서의 메시지 크기 제한 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 322679, "Exchange Server에서 메시지 크기 제한을 설정하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)을 참조하십시오.

  • Exchange Server 2007에서의 TransportConfig cmdlet에 대한 자세한 내용은 Exchange Server 2007 Technical Reference의 "Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkID=79237)를 참조하십시오.

  • 인터넷 메시지 형식에 대한 자세한 내용은 Exchange Server 2003 관리 가이드 (http://go.microsoft.com/fwlink/?LinkId=47617)의 "SMTP 정책을 사용하여 아웃바운드 메일 서식 및 자동 응답 제어"를 참조하십시오.


보내는 메시지의 최대 크기가 너무 크게(>30MB) 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-12-04

Microsoft® Exchange Server Analyzer Tool은 아래에 있는 전역 설정 submissionContLength 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Exchange Server Analyzer는 submissionContLength 특성 값이 30720보다 클 경우 오류를 표시합니다.

이 오류는 보내는 메시지의 최대 크기 제한이 30MB보다 큰 값으로 설정되었음을 나타냅니다. 사용자 조직의 네트워크 대역폭과 사용자 요구 사항에 따라 메시지 크기를 더 작은 크기의 메시지로 제한할 수 있습니다. Exchange 2000 Server 및 Exchange Server 2007에는 기본 메시지 크기 제한이 없습니다. Exchange Server 2003에서 메시지를 주고받을 때 적용되는 기본 크기 제한은 10,240KB입니다. 이 기본 크기 제한은 메시지 크기 제한이 설정되지 않은 Exchange 2000 Server 업그레이드와 새로운 설치에 적용됩니다.

메시지 크기 제한을 설정하여 사용자가 대용량 전자 메일 메시지를 주고받을 수 없게 하면 시스템 리소스를 절약할 수 있습니다. 메시지 크기 제한을 설정하면 네트워크 소통량이 제한되고 디스크 공간이 절약되어 전체 네트워크 성능을 향상시키는 데 도움이 됩니다. Exchange 2000 Server 및 Exchange Server 2003의 경우, 전역 설정의 메시지 배달 속성에 있는 기본값 탭을 사용하면 받는 메시지와 보내는 메시지에 대한 메시지 배달 제한 사항을 지정할 수 있습니다. 최대 개별 메시지 크기를 설정하려면 최대 크기(KB)를 선택한 다음 입력란에 최대 크기(KB)를 입력합니다. 메시지 크기를 제한하지 않으려면 제한 없음을 선택합니다. 조직에 있는 보낸 사람이 지정된 크기 제한을 초과한 사용자에게 메시지를 보내면 보낸 사람은 배달 못 함 보고서(NDR)를 받습니다. 인터넷 메시지 형식에서 구성한 NDR 설정에 따라 외부의 보낸 사람은 NDR을 받거나 받지 못할 수 있습니다.

Exchange Server 2007의 경우 Exchange 관리 셸을 사용하여 Exchange 조직의 TransportConfig MaxSendSize 매개 변수를 설정할 수 있습니다.

최대 메시지 크기 제한을 10MB 미만으로 설정하는 것이 좋습니다. 그러나 Exchange 조직을 통해 대용량 첨부 파일이 포함된 메시지를 보낼 수 있도록 충분한 메시지 크기 제한이 필요한 경우에는 보내는 메시지의 최대 크기 제한을 30MB로 늘려야 할 수도 있습니다. 메시지 크기 제한을 30MB 이상으로 늘리면 네트워크 성능이 저하되고 시스템이 보안 공격에 더 취약해질 수 있습니다.

Exchange 2000 Server 및 Exchange Server 2003에서 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange System Manager에서 전역 설정을 확장하고 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 메시지 배달 속성 대화 상자의 기본값 탭에서 보내는 메시지 크기 제한 옵션을 선택하고 원하는 크기 제한을 입력합니다.

Exchange Server 2007에서 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange 관리 셸에서 다음 명령을 실행합니다. 여기서 <size>는 기본값인 "unlimited"로 입력하거나 0에서 2147483647바이트 사이의 크기를 B(바이트), KB(킬로바이트) 또는 MB(메가바이트) 단위로 입력합니다.
코드 복사
Set-TransportConfig -MaxSendSize <size>

예를 들어 Exchange 조직에서 사용자가 전송받을 수 있는 최대 메시지 크기를 10MB로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxSendSize 10MB

Exchange 조직에서 사용자가 전송받을 수 있는 최대 메시지 크기를 기본값인 무제한으로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxSendSize unlimited
  • Exchange 2000 Server 및 Exchange Server 2003에서의 메시지 크기 제한 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 322679, "메시지 크기 제한을 설정하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)을 참조하십시오.

Exchange Server 2007에서의 TransportConfig cmdlet에 대한 자세한 내용은 Exchange Server 2007 Technical Reference의 "Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkID=79237)를 참조하십시오.

  • 인터넷 메시지 형식에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=21769)의 "SMTP 정책을 사용하여 아웃바운드 메일 서식 및 자동 응답 제어"를 참조하십시오.


보내는 메시지의 최대 크기가 너무 낮게 설정되었을 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-12-04

Microsoft® Exchange Server Analyzer Tool은 아래에 있는 전역 설정 submissionContLength 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganizationName , CN=Global Settings, CN=Message Delivery

Exchange Server Analyzer는 submissionContLength 특성 값이 1024보다 작거나 0보다 클 경우 경고를 표시합니다.

이 경고는 보내는 메시지의 최대 크기 제한이 1MB 미만으로 설정되었음을 나타냅니다. 사용자 조직의 네트워크 대역폭과 사용자 요구 사항에 따라 크기가 더 큰 메시지를 허용하도록 메시지 크기를 늘릴 수 있습니다. Exchange 2000 Server 및 Exchange Server 2007에는 기본 메시지 크기 제한이 없습니다. Exchange Server 2003에서 메시지를 주고받을 때 적용되는 기본 크기 제한은 10,240KB입니다. 이 기본 크기 제한은 메시지 크기 제한이 설정되지 않은 Exchange 2000 Server 업그레이드와 새로운 설치에 적용됩니다.

메시지 크기 제한을 설정하여 사용자가 대용량 전자 메일 메시지를 주고받을 수 없게 하면 시스템 리소스를 절약할 수 있습니다. 메시지 크기 제한을 설정하면 네트워크 소통량이 제한되고 디스크 공간이 절약되어 전체 네트워크 성능을 향상시키는 데 도움이 됩니다. Exchange 2000 Server 및 Exchange Server 2003의 경우, 전역 설정의 메시지 배달 속성에 있는 기본값 탭을 사용하면 받는 메시지와 보내는 메시지에 대한 메시지 배달 제한을 지정할 수 있습니다. 최대 개별 메시지 크기를 설정하려면 최대 크기(KB)를 선택한 다음 입력란에 최대 크기(KB)를 입력합니다. 메시지 크기를 제한하지 않으려면 제한 없음을 선택합니다. 조직 내의 보낸 사람이 지정된 크기 제한을 벗어난 사용자에게 메시지를 보내려고 하면 배달 못 함 보고서(NDR)를 받습니다. 인터넷 메시지 형식에서 구성한 NDR 설정에 따라 외부의 보낸 사람이 NDR을 받거나 받지 못할 수 있습니다.

Exchange Server 2007의 경우 Exchange 관리 셸을 사용하여 Exchange 조직의 TransportConfig MaxSendSize 매개 변수를 설정할 수 있습니다.

최대 메시지 크기 제한을 30MB 미만으로 설정하는 것이 좋습니다. 그러나 Exchange 조직을 통해 대용량 첨부 파일이 포함된 메시지를 보낼 수 있도록 충분한 메시지 크기 제한이 필요한 경우에는 보내는 메시지의 최대 크기 제한을 30MB로 늘려야 할 수도 있습니다. 메시지 크기 제한을 30MB 이상으로 늘리면 네트워크 성능이 저하되고 시스템이 보안 공격에 더 취약해질 수 있습니다.

Exchange 2000 Server 및 Exchange Server 2003에서 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange System Manager에서 전역 설정을 확장하고 메시지 배달을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 메시지 배달 속성 대화 상자의 기본값 탭에서 보내는 메시지 크기 제한 옵션을 선택하고 원하는 크기 제한을 입력합니다.

Exchange Server 2007에서 메시지 크기 제한을 설정하려면 다음을 수행하십시오.

  1. Exchange 관리 셸에서 다음 명령을 실행합니다. 여기서 <size>는 기본값인 "unlimited"로 입력하거나 0에서 2147483647바이트 사이의 크기를 B(바이트), KB(킬로바이트) 또는 MB(메가바이트) 단위로 입력합니다.
코드 복사
Set-TransportConfig -MaxSendSize <size>

예를 들어 Exchange 조직에서 사용자가 전송할 수 있는 최대 메시지 크기를 10MB로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxSendSize 10MB

Exchange 조직에서 사용자가 전송할 수 있는 최대 메시지 크기를 기본값인 무제한으로 설정하려면 다음과 같이 입력하십시오.

코드 복사
Set-TransportConfig -MaxSendSize unlimited
  • Exchange 2000 Server 및 Exchange Server 2003에서의 메시지 크기 제한 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 322679, "메시지 크기 제한 설정"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)을 참조하십시오.

Exchange Server 2007에서의 TransportConfig cmdlet에 대한 자세한 내용은 Exchange Server 2007 Technical Reference의 "Set-TransportConfig"(http://go.microsoft.com/fwlink/?LinkID=79237)를 참조하십시오.

  • 인터넷 메시지 형식에 대한 자세한 내용은 Exchange Server 2003 관리 가이드 (http://go.microsoft.com/fwlink/?LinkId=47617)의 "SMTP 정책을 사용하여 아웃바운드 메일 서식 및 자동 응답 제어"를 참조하십시오.


메시지 전용 저널링을 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-01-10

Microsoft® Exchange Server Analyzer Tool은 msExchMessageJournalRecipient 특성이 받는 사람 사서함에 메일을 복사할 수 있도록 구성되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msExchMessageJournalRecipient 특성은 Active Directory의 사서함 저장소 개체 특성입니다. 기본적으로 msExchMessageJournalRecipient 특성은 구성되어 있지 않습니다. Exchange Server Analyzer가 msExchMessageJournalRecipient 특성이 구성되어 있음을 확인하면 기본 구성이 아니라는 메시지를 표시합니다. 또한 Exchange Server Analyzer는 메시지 전용 저널링을 사용할 수 있는 데이터베이스 이름과 서버 이름을 표시합니다.

Exchange Server 2003 메시지 전용 저널링 또는 Exchange Server 2007 표준 저널링은 사서함 데이터베이스에 모든 메시지 사본과 사용자와 주고 받는 해당 P2 메시지 헤더 데이터를 만들고 지정된 사서함에 메시지 사본을 보냅니다. P2 메시지 헤더에는 보낸 사람이 받는 사람으로 선언한 메시지 보낸 사람 데이터만 있습니다. 인터넷에서 외부 메시지를 받는 경우 Exchange Server는 P1 메시지 헤더를 저널링합니다. P1 메시지 헤더는 메일을 라우팅하는 메시지 전송 에이전트(MTA)에서 사용되는 주소 정보입니다. 기본적으로 메시지 전용 저널링을 사용할 수 있는 경우, Exchange Server는 숨은 참조(Bcc) 받는 사람, 전송 전달 규칙으로 받는 사람, 메일 그룹 확장으로 받는 사람을 밝히지 않습니다. 또한 Exchange Server는 읽음 확인, 부재중 알림 같은 MAPI 보고서 메시지를 보관하지 않습니다.

저널링 메시지는 다수의 디스크, 네트워크 및 CPU 리소스를 사용할 수 있습니다. 따라서 저널링에는 철저한 배포 계획이 필요합니다. 저널링은 전반적인 저널링 솔루션 프레임워크 컨텍스트에서만 사용할 수 있어야 합니다.

다음 조건에 해당되는 경우 기본 구성이 아니라는 메시지는 무시합니다.

  • 업무에 저널링이 필요합니다.

  • 저널링 솔루션 프레임워크를 배포했습니다.

그렇지 않은 경우 저널링 기능을 해제해야 합니다.

Exchange 2000 Server 및 Exchange Server 2003의 데이터베이스에서 메시지 전용 저널링을 해제하려면 다음을 수행합니다.

  1. Exchange System Manager, 서버, <your Exchange server>, <storage group>을 차례로 확장한 다음 사서함 저장소를 마우스 오른쪽 단추로 클릭합니다.

  2. 일반 탭에서 이 저장소의 사서함에서 주고받은 모든 메시지를 보관 확인란의 선택을 취소합니다.

  3. Exchange 저장소가 변경 사항을 적용할 때까지 15분 동안 기다립니다. Microsoft Exchange Information Store 서비스를 다시 시작할 필요가 없습니다.
Exchange Server 2007의 데이터베이스에서 표준 저널링을 해제하려면 다음을 수행합니다.

  1. Exchange Server 2007 제품 설명서 How to Disable Per-Mailbox Database Journaling(http://go.microsoft.com/fwlink/?LinkId=80889)의 안내를 따릅니다.

Exchange Server 2003을 사용하여 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server 2003(http://go.microsoft.com/fwlink/?LinkId=47581)을 참조하십시오.

Exchange Server 2007을 사용하여 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Overview of Journaling (http://go.microsoft.com/fwlink/?LinkId=80820)을 참조하십시오.


메시지 라우팅 루프가 있을 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 각 SMTP(Simple Mail Transfer Protocol) 가상 서버의 msExchAlternateServer 특성 값을 확인합니다. Exchange Server Best Practice Analyzer는 msExchNonAuthoritativeDomains 특성이 조직의 받는 사람 정책에서 구성되어 있는지도 확인합니다. Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고를 표시합니다.

  • msExchAlternateServer 특성의 인스턴스가 설정되었습니다.

  • msExchNonAuthoritativeDomains 특성이 받는 사람 정책에서 설정되었습니다.

Exchange Server Analyzer는 앞서 설명한 구성이 메시지 루프를 발생시킬 수 있으므로 경고를 표시합니다. 메시지 루프는 다른 메시징 시스템이 단일 조직에서 함께 작동하도록 구성된 경우에 발생합니다. 이 시나리오에서 Exchange Server 받는 사람 정책 및 SMTP 구성은 서로 다른 메시징 시스템 간에 존재하는 사용자 그룹에 대한 메시지를 라우팅하고 배달하는 데 사용됩니다.

msExchAlternateServer 특성은 SMTP 가상 서버 속성 페이지의 받는 사람을 확인할 수 없는 메일은 다음 호스트로 전달 필드에 주소를 지정할 때 설정됩니다.

msExchNonAuthoritativeDomains 특성은 지정된 받는 사람 정책에 대한 SMTP 주소 속성 페이지에서 이 주소로 보내는 모든 메일 배달은 이 Exchange 조직이 담당합니다 확인란의 선택을 해제할 때 설정됩니다.

따라서 SMTP 도메인을 이 주소로 보내는 모든 메일 배달은 이 Exchange 조직이 담당합니다. 확인란의 선택을 해제하여 SMTP 도메인을 신뢰할 수 없는 도메인으로 지정하고 SMTP 가상 서버에서 확인할 수 없는 받는 사람의 주소를 지정한 경우 Exchange Server Analyzer에서 경고를 표시합니다. 그러나 이 경고의 존재는 조직에 메시지 루프가 있음을 명확하게 나타내지는 않습니다.

신뢰할 수 없는 도메인이 있고 조직에 있는 한 개 이상의 서버에 msExchAlternateServer가 설정되어 있으면 메시지 라우팅 루프가 발생할 수 있습니다. 다음 조건이 존재하는지 확인해야 합니다.

  • 조직의 모든 도메인에 대해 신뢰할 수 있는 도메인이 있습니다.

  • 신뢰할 수 있는 도메인이 확인할 수 없는 모든 메시지를 처리하도록 SMTP 가상 서버가 구성되어 있습니다.

특히 도메인 이름을 다른 조직과 공유할 경우 해당 도메인 네임스페이스에 한 개의 인바운드 경로만 있는 것이 좋습니다. 도메인에 대해 한 개의 메일 서버나 한 개의 메일 시스템을 신뢰할 수 있어야 루핑이 발생하지 않습니다. 신뢰할 수 있는 서버는 인바운드 경로에서 마지막 시스템이어야 합니다.

어느 시스템이 초기 수신기인지는 중요하지 않습니다. 3개 이상의 초기 수신기가 있어도 됩니다. 한 개의 시스템만이 최종 대상이 되기만 하면 됩니다.

msExchAlternateServer 특성을 변경하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, <Server Name>, 프로토콜, SMTP를 차례로 확장합니다.

  2. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. SMTP 가상 서버의 속성에서 메시지 탭을 클릭합니다.

  4. 확인할 수 없는 받는 사람의 모든 메시지를 호스트로 전달 상자에서 확인할 수 없는 메일을 받는 서버의 FQDN을 입력합니다. 또한 대괄호([ ])안에 서버의 IP 주소를 입력할 수 있습니다.

  5. 확인을 클릭합니다.
msExchNonAuthoritativeDomains 특성을 변경하려면 다음을 수행합니다.

  1. Exchange System Manager에서 받는 사람을 확장한 후 <Recipient Policy Name>을 두 번 클릭합니다.

  2. 전자 메일 주소(정책) 탭에서 SMTP 주소를 두 번 클릭합니다.

  3. SMTP 주소 속성 페이지에서 이 주소로 보내는 모든 메일 배달은 이 Exchange 조직이 담당합니다를 선택하면 msExchNonAuthoritativeDomains 특성의 선택이 해제됩니다. 확인란의 선택을 해제하여 주소 필드에 지정된 SMTP 주소로 msExchNonAuthoritativeDomains 특성을 설정합니다.

SMTP 주소 공간 공유에 대한 자세한 내용은 Microsoft 기술 자료 문서 321721, "Exchange 2000 및 Exchange Server 2003에서 SMTP 주소 공간 공유"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721)를 참조하십시오.

인터넷 연결의 배포 시나리오에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 6장, "인터넷 연결의 배포 시나리오"를 참조하십시오.


'디렉터리 조회 대기 중인 메시지 수입니다' 큐가 고정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 디렉터리 조회 대기 중인 메시지 수입니다 큐의 StateFrozen 키 값을 확인합니다.

Exchange Server Analyzer는 Exchange 서버에서 디렉터리 조회 대기 중인 메시지 수입니다 큐의 StateFrozen 키 값이 True로 설정되어 있음을 발견하면 오류를 표시합니다.

큐가 고정되었다는 것은 해당 큐에 대한 전송 세션이 중지되었음을 의미합니다. 고정된 큐에서는 새 메시지가 추가될 수는 있어도 메시지가 나갈 수는 없습니다. 각 링크 큐에 대한 바로 가기 메뉴를 사용하여 연결 상태를 수동으로 변경할 수 있습니다. 강제 연결 명령을 사용하여 큐 상태를 활성으로 변경하면 바로 해당 큐의 메시지를 보내는 연결을 사용할 수 있습니다.

디렉터리 조회 대기 중인 메시지 수입니다 큐에는 Active Directory® 디렉터리 서비스에 대해 아직 확인되지 않은 받는 사람에게 배달할 메시지가 포함됩니다. 메시지는 메일 그룹이 확장되는 동안에도 이 큐에 보관됩니다.

일반적으로 고급 큐 엔진에서 분류할 수 없는 메시지가 누적됩니다. 고급 큐 엔진이 글로벌 카탈로그 서버에 액세스하여 받는 사람 정보에 액세스할 수 없거나, 글로벌 카탈로그 서버 자체에 연결할 수 없거나, 글로벌 카탈로그 서버의 성능이 느린 경우 이 문제가 발생할 수 있습니다. 또한 다음과 같은 이유 때문에 메시지가 누적될 수 있습니다.

  • Active Directory를 사용할 수 없는 경우

    참고:
    분류기가 Active Directory를 사용하여 메시지를 분류하는 경우
  • 분류 작업 이전 큐에 대기 중인 메시지가 너무 많아서 Active Directory가 과도하게 로드되는 경우

  • 변환에 실패한 경우. 분류기가 콘텐츠 변환도 함께 처리하는 경우

  • 메시지 분류기가 사서함 저장소를 찾을 수 없는 경우

  • SMTP가 다시 설치되거나 제거되어 /smtpsvc/DsUseCat 및 /smtpsvc/vsi#/DsUseCat와 같은 IIS 메타베이스 키가 무효화된 경우

    참고:
    SMTP가 다시 설치되거나 제거되었는지 여부를 결정합니다.

이 오류를 해결하려면 MSExchangeDSAccess 서비스 및 MSExchangeTransport 서비스에 대한 진단 로깅 수준을 높여 분류기 구성 요소에 대한 정보를 수집합니다.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


'디렉터리 조회 대기 중인 메시지 수입니다' 큐가 재시도 중입니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 디렉터리 조회 대기 중인 메시지 수입니다 큐의 StateRetry 키 값을 확인합니다.

Exchange Server Analyzer는 Exchange 서버에서 디렉터리 조회 대기 중인 메시지 수입니다 큐의 StateRetry 키 값이 True로 설정되어 있음을 발견하면 오류를 표시합니다.

큐 상태가 재시도이면 이전에 큐의 메시지를 처리하려고 시도했을 때 최소 한 번 이상 오류가 발생했음을 나타냅니다. 강제 연결 명령을 사용하여 재시도 또는 예약됨 상태의 큐를 활성 상태로 변경할 수 있습니다. 그러면 재시도 간격이 지났거나 예약된 시간에 도달한 것처럼 큐가 작동합니다. 그러나 이 방법이 제대로 작동하지 않는 경우도 있습니다.

참고:
큐의 속성이 큐가 재시도 상태에 있어야 하는 특정 이유를 나타낼 수 있습니다.

디렉터리 조회 대기 중인 메시지 수입니다 큐에는 Active Directory® 디렉터리 서비스에 대해 아직 확인되지 않은 받는 사람에게 배달할 메시지가 포함됩니다. 메시지는 메일 그룹이 확장되는 동안에도 이 큐에 보관됩니다.

일반적으로 고급 큐 엔진에서 분류할 수 없는 메시지가 누적됩니다. 고급 큐 엔진이 글로벌 카탈로그 서버에 액세스하여 받는 사람 정보에 액세스할 수 없거나, 글로벌 카탈로그 서버 자체에 연결할 수 없거나, 글로벌 카탈로그 서버의 성능이 느린 경우 이 문제가 발생할 수 있습니다. 또한 다음과 같은 이유 때문에 메시지가 누적될 수 있습니다.

  • Active Directory를 사용할 수 없는 경우

    참고:
    분류기가 Active Directory를 사용하여 메시지를 분류하는 경우
  • 분류 작업 이전 큐에 대기 중인 메시지가 너무 많아서 Active Directory가 과도하게 로드되는 경우

  • 변환이 실패한 경우. 분류기가 콘텐츠 변환도 함께 처리하는 경우

  • 메시지 분류기가 사서함 저장소를 찾을 수 없는 경우

  • SMTP가 다시 설치되거나 제거되어 /smtpsvc/DsUseCat 및 /smtpsvc/vsi#/DsUseCat와 같은 IIS 메타베이스 키가 무효화된 경우

    참고:
    SMTP가 다시 설치되거나 제거되었는지 여부를 결정합니다.

이 오류를 해결하려면 큐의 속성을 검사하여 큐가 왜 재시도 상태인지 확인하십시오. 예를 들어, 큐 속성에 "SMTP 오류가 발생했습니다"와 비슷한 메시지가 표시되면 서버의 이벤트 로그를 검토하여 SMTP 오류를 확인해야 합니다. 로그에 이벤트가 없는 경우 SMTP 프로토콜 로깅 수준을 높여야 합니다.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


'전송 보류 중인 메시지 수입니다' 큐가 고정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-16

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 전송 보류 중인 메시지 수입니다 큐의 StateFrozen 키 값을 확인합니다.

Exchange Server Analyzer는 Exchange 서버에서 전송 보류 중인 메시지 수입니다 큐의 StateFrozen 키 값이 True로 설정되어 있음을 발견하면 오류를 표시합니다.

큐가 고정되었다는 것은 해당 큐에 대한 전송 세션이 중지되었음을 의미합니다. 고정된 큐에서는 새 메시지가 추가될 수는 있어도 메시지가 나갈 수는 없습니다. 각 링크 큐에 대한 바로 가기 메뉴를 사용하여 연결 상태를 수동으로 변경할 수 있습니다. 강제 연결 명령을 사용하여 큐 상태를 활성으로 변경하면 바로 해당 큐의 메시지를 보내는 연결을 사용할 수 있습니다.

전송 보류 중인 메시지 수입니다 큐에는 SMTP 서비스가 인식하고 받아들인 메시지가 보관됩니다.

이 큐에 있는 메시지는 처리되지 않았습니다. 메시지가 계속해서 누적되면 성능 문제가 발생할 수 있습니다. CPU 성능이 이따금씩 최대화되는 경우 이 큐에 메시지가 간헐적으로 나타날 수 있습니다. 주로, 바이러스 백신 차단 및 법적 고지 사항을 위한 사용자 지정 SMTP 처리와 같은 이벤트 싱크와 관련된 문제로 인해 큐에 메시지가 누적될 수 있습니다.

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


'전송 보류 중인 메시지 수입니다' 큐가 재시도 중입니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 전송 보류 중인 메시지 수입니다 큐의 StateRetry 키 값을 확인합니다.

Exchange Server Analyzer는 Exchange 서버에서 전송 보류 중인 메시지 수입니다 큐의 StateRetry 키 값이 True로 설정되어 있음을 발견하면 오류를 표시합니다.

큐 상태가 재시도이면 이전에 큐의 메시지를 처리하려고 시도했을 때 최소 한 번 이상 오류가 발생했음을 나타냅니다. 강제 연결 명령을 사용하여 재시도 또는 예약됨 상태의 큐를 활성 상태로 변경할 수 있습니다. 그러면 재시도 간격이 지났거나 예약된 시간에 도달한 것처럼 큐가 작동합니다. 그러나 이 방법이 제대로 작동하지 않는 경우도 있습니다.

참고:
큐의 속성이 큐가 재시도 상태에 있어야 하는 특정 이유를 나타낼 수 있습니다.

전송 보류 중인 메시지 수입니다 큐에는 SMTP 서비스가 인식하고 받아들인 메시지가 보관됩니다.

이 큐에 있는 메시지는 처리되지 않았습니다. 메시지가 계속해서 누적되면 성능 문제가 발생할 수 있습니다. CPU 성능이 이따금씩 최대화되는 경우 이 큐에 메시지가 간헐적으로 나타날 수 있습니다. 주로, 바이러스 백신 차단 및 법적 고지 사항을 위한 사용자 지정 SMTP 처리와 같은 이벤트 싱크와 관련된 문제로 인해 큐에 메시지가 누적될 수 있습니다.

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


'라우팅 대기 중인 메시지 수입니다' 큐가 고정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 라우팅 대기 중인 메시지 수입니다 큐의 StateFrozen 키 값을 확인합니다.

Exchange Server Analyzer는 Exchange 서버에서 디렉터리 조회 대기 중인 메시지 수입니다 큐의 StateFrozen 키 값이 True로 설정되어 있음을 발견하면 오류를 표시합니다.

큐가 고정되었다는 것은 해당 큐에 대한 전송 세션이 중지되었음을 의미합니다. 고정된 큐에서는 새 메시지가 추가될 수는 있어도 메시지가 나갈 수는 없습니다. 각 링크 큐에 대한 바로 가기 메뉴를 사용하여 연결 상태를 수동으로 변경할 수 있습니다. 강제 연결 명령을 사용하여 큐 상태를 활성으로 변경하면 바로 해당 큐의 메시지를 보내는 연결을 사용할 수 있습니다.

라우팅 대기 중인 메시지 수입니다 큐는 메시지를 보관하다가 다음 대상 서버가 결정되면 메시지를 해당 링크 큐로 이동합니다.

Exchange Server 라우팅에 문제가 있는 경우 이 큐에 메시지가 누적됩니다. 메시지 라우팅을 백업할 수도 있습니다.

이 오류를 해결하려면 MSExchangeDSAccess 서비스 및 MSExchangeTransport 서비스의 진단 로깅 수준을 높여서 분류기 구성 요소에 대한 정보를 수집합니다.

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


'라우팅 대기 중인 메시지 수입니다' 큐가 재시도 중입니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 ExchangeLinkWMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 라우팅 대기 중인 메시지 수입니다 큐의 StateRetry 키 값을 확인합니다.

Exchange Server Analyzer는 Exchange 서버에서 디렉터리 조회 대기 중인 메시지 수입니다 큐의 StateRetry 키 값이 True로 설정되어 있음을 발견하면 오류를 표시합니다.

큐 상태가 재시도이면 이전에 큐의 메시지를 처리하려고 시도했을 때 최소 한 번 이상 오류가 발생했음을 나타냅니다. 강제 연결 명령을 사용하여 재시도 또는 예약됨 상태의 큐를 활성 상태로 변경할 수 있습니다. 그러면 재시도 간격이 지났거나 예약된 시간에 도달한 것처럼 큐가 작동합니다. 그러나 이 방법이 제대로 작동하지 않는 경우도 있습니다.

참고:
큐의 속성이 큐가 재시도 상태에 있어야 하는 특정 이유를 나타낼 수 있습니다.

라우팅 대기 중인 메시지 수입니다 큐는 메시지를 보관하다가 다음 대상 서버가 결정되면 메시지를 해당 링크 큐로 이동합니다.

Exchange Server 라우팅에 문제가 있는 경우 이 큐에 메시지가 누적됩니다. 메시지 라우팅을 백업할 수도 있습니다.

이 오류를 해결하려면 MSExchangeTransport 서비스의 진단 로깅을 증가시켜 분류기 구성 요소에 대한 정보를 수집하십시오. 필요 없는 커넥터 제한으로 인해 서버 성능이 크게 저하될 수 있으므로 이러한 커넥터 제한은 사용하지 마십시오. 일부 제한의 경우 CheckConnectorRestrictions 레지스트리 키를 켜야 할 수 있습니다.

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


누락된 전송 이벤트 싱크 바인딩
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-01-11

Microsoft® Exchange Server Analyzer Tool은 Microsoft 인터넷 정보 서비스(IIS) 메타베이스를 쿼리하여 SMTP(Simple Mail Transport Protocol) 전송 이벤트 싱크 바인딩 목록을 열거합니다. Exchange Server Analyzer는 미리 채워진 다음 목록을 기반으로 여러 표준 이벤트 바인딩을 찾습니다.

  • Custom Exchange DSN Sink

  • EHLO Inbound Command Handler Sink for XLSA

  • EHLO Response Handler Sink for X-LSA

  • EOD Inbound Command Handler Sink

  • Exchange Categorizer

  • Exchange LoadBalancer

  • Exchange NTFS Store Driver

  • Exchange Router

  • Exchange SMTP Protocol Logging Sink

  • Exchange SMTP Protocol Security EHLO Sink

  • Exchange SMTP Protocol Security EXPS Sink

  • Exchange SMTP Protocol Security EXPS-Aux Sink

  • Exchange SMTP Protocol Security EXPS-EOD Sink

  • Exchange SMTP Protocol Security Mail Sink

  • Exchange SMTP Protocol XEXCH50 Before Data Sink

  • Exchange SMTP Protocol XEXCH50 EHLO Response Sink

  • Exchange SMTP Protocol XEXCH50 EOD Sink

  • Exchange SMTP Protocol XEXCH50 Inbound EHLO Sink

  • Exchange SMTP Protocol XEXCH50 Inbound MAIL Sink

  • Exchange SMTP Protocol XEXCH50 Inbound RCPT Sink

  • Exchange SMTP Protocol XEXCH50 Inbound XEXCH50 Sink

  • Exchange SMTP Protocol XEXCH50 per recipient event Sink

  • Exchange SMTP Protocol XEXCH50 EHLO Response Sink

  • Exchange SMTP Protocol XEXCH50 EHLO Response Sink

  • Exchange Store Driver

  • Exchange Transport AntiVirus API

  • Exchange Transport XEXCH50 Submission Sink

  • MAIL Inbound Command Handler Sink for TURF

  • Mobile Categorizer

  • MSExchange Content Filter EOD Sink

  • MsgTrackLog Sink

  • RCPT Inbound Command Handler Sink

  • SMTP Eventlog Sink

  • UmConvSink

  • X-LSA Inbound Command Handler Sink

  • X-LSA Response Handler Sink

  • X-LSA Sink

Exchange Server Analyzer는 표준 이벤트 바인딩이 하나 이상 누락된 것을 발견하면 경고를 표시합니다.

메시지 데이터가 SMTP 서비스로 전송되거나 SMTP 서비스에서 전송되는 경우 SMTP 전송 이벤트가 발생합니다. 모든 메시지는 이벤트를 거칩니다. 여기에는 X.400 및 RPC 받는 메시지 또는 보내는 메시지가 포함됩니다. 인바운드 전송 이벤트의 일반적인 예로는 네트워크를 통하거나 SMTP 픽업 디렉터리에 있는 SMTP 서비스에 메시지가 도착하는 것을 들 수 있습니다. 이러한 전송 이벤트가 발생하면 이 이벤트의 원본은 메시지의 데이터 내용을 기반으로 작업의 일부 유형을 수행할 수 있는 전송 이벤트 싱크를 알려 줍니다. 시스템에서 메시지 데이터를 싱크에 전달한 다음에는 싱크가 작업을 완료하고 메시지를 반환할 때까지 메시지 데이터에 다른 작업을 수행하지 않습니다. 싱크는 메시지 데이터 및 이러한 작업을 수행하는 동안의 상태를 독점적으로 제어합니다.

전송 이벤트 싱크 바인딩이 없어지면 메일 흐름에 문제가 생길 수 있습니다. Exchange Server에서 메시지 큐와 같은 메일 흐름 문제가 나타나는 경우 전송 이벤트 싱크를 다시 등록합니다.

전송 이벤트 싱크를 다시 등록하려면 다음을 수행합니다.

  1. Microsoft Exchange Server에서 명령 프롬프트 창을 열고 \Program Files\Exchsrvr\Bin 폴더로 변경합니다.

  2. 다음 명령을 입력하여 전송 이벤트 싱크를 다시 등록합니다.

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. Exchange Server Analyzer를 다시 실행하여 경고가 더 이상 나타나지 않는지 확인합니다. 이벤트 싱크 경고가 계속 나타나고 메일 흐름에 문제가 있으면 Microsoft 기술 지원 서비스(PSS)에 문의하십시오.

전송 이벤트 싱크 바인딩에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Microsoft 기술 자료 문서 258224, "XCON: Enumerating the Registered Transport Event Sinks"(http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224)

  • Exchange Server 2003 기술 참조 가이드(http://go.microsoft.com/fwlink/?LinkId=58876)의 "SMTP 서비스 디자인"


msExchAlternateServer 특성이 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 SMTP(Simple Mail Transfer Protocol) 가상 서버의 msExchAlternateServer 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 msExchAlternateServer 특성 값은 설정되지 않습니다. Exchange Server Analyzer는 msExchAlternateServer 특성이 설정되었으면 기본 구성이 아니라는 메시지를 표시합니다.

다음 예제 시나리오에서는 msExchAlternateServer 특성을 설정합니다. SMTP 도메인과 같은 SMTP 주소 공간을 Exchange Server 2003과 다른 전자 메일 시스템 사이에 공유합니다. 이 시나리오에서 Exchange Server 2003은 인터넷에서 들어오는 메일을 받습니다. Exchange Server 2003은 Exchange Server 조직에서 일치하는 받는 사람을 찾습니다. 일치하는 받는 사람이 없으면 Exchange Server는 해당 메일을 외부 메일 시스템으로 전달합니다. 받는 시스템도 일치하는 대상이 있는지 확인합니다. 일치하는 대상이 없으면 해당 메일을 세 번째 전자 메일 시스템으로 전달합니다. 이 고리의 마지막 시스템은 해당 도메인에 대한 권한을 가지고 있어야 합니다. 마지막 받는 시스템은 일치하는 받는 사람을 찾아야 합니다. 일치하는 받는 사람이 없으면 해당 메시지에 대해 배달 못 함 보고서(NDR)를 생성해야 합니다. 받는 시스템이 일치하는 대상을 찾지만 일치하는 대상이 없을 경우 해당 메시지를 원래 시스템으로 다시 전달하면 메시지 루핑이 발생합니다.

msExchAlternateServer 특성을 변경하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, <서버 이름>, 프로토콜, SMTP를 차례로 확장합니다.

  2. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. SMTP 가상 서버의 속성에서 메시지 탭을 클릭합니다.

  4. 확인할 수 없는 받는 사람의 모든 메시지를 호스트로 전달 상자에서 확인할 수 없는 메일을 받는 서버의 FQDN을 입력합니다. 또한 대괄호([ ])안에 서버의 IP 주소를 입력할 수 있습니다.

  5. 확인을 클릭합니다.

SMTP 주소 공간 공유에 대한 자세한 내용은 Microsoft 기술 자료 문서 321721, "XCON: Exchange 2000에서 SMTP 주소 공간 공유"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721)를 참조하십시오.

인터넷 연결의 배포 시나리오에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "인터넷 연결의 배포 시나리오"를 참조하십시오.


msExchMaxIncomingConnections 값이 기본 설정에서 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 SMTP 가상 서버의 msExchSmtpMaxIncomingConnections 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

기본적으로 Microsoft Windows® Small Business Server 2003이 설치되지 않은 Exchange Server 컴퓨터에서 msExchSmtpMaxIncomingConnections 특성은 무제한 연결 수로 구성되고 기본값은 2000000000입니다. Microsoft Windows Small Business Server 2003이 설치된 Exchange Server 컴퓨터에서 기본 최대 받는 연결 수는 500입니다.

또한 Exchange Server Analyzer는 OSProductSuite 키 값을 확인할 때도 Win32_OperatingSystem WMI(Windows Management Instrumentation) 클래스를 쿼리합니다. 이 키 값은 Windows Server 운영 체제의 특정 버전에 해당합니다.

Exchange Server Analyzer는 Microsoft Windows Small Business Server 2003이 설치되지 않은 Exchange Server 컴퓨터에서 msExchSmtpMaxIncomingConnections 특성 값이 2000000000으로 설정되어 있지 않을 경우 기본 구성이 아니라는 메시지를 표시합니다. 이 특성에 사용되는 2000000000 값은 이론적 한계이고 사용자가 이 값을 구성할 수 있게 해 주는 사용자 인터페이스 요소에 적용되는 한계이기도 합니다.

또한 Exchange Server Analyzer는 Microsoft Windows Small Business Server 2003 설치의 일부인 Exchange Server 컴퓨터에서 msExchSmtpMaxIncomingConnections 특성 값이 500으로 설정되어 있지 않을 경우 기본 구성이 아니라는 메시지를 표시합니다.

보안 측면에서 볼 때 받는 연결 수를 제한하는 것은 적절한 것이라 할 수 있습니다. 기본적으로 받는 SMTP 연결 수를 무제한 허용하는 기능은 DoS(Denial-Of-Service) 상황에 도움이 됩니다. 가상 서버에 너무 많은 동시 연결이 설정되면 네트워크가 오버로드되고 성능이 저하될 수 있습니다. 각 조직은 이 특성에 대해 자체 조직에 적합한 값을 결정해야 합니다.

최대 받는 연결 수를 보고 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange 서버, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 일반을 클릭합니다.

    • 들어오는 연결 수를 제한하려면 연결 수 제한 확인란을 선택하고 원하는 값을 입력합니다.

    • 들어오는 연결 수 제한이 없는 기본값으로 되돌리려면 연결 수 제한 확인란의 선택을 해제합니다.

  5. 확인을 클릭하여 변경 내용을 저장합니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxHopCount 값이 기본값에서 다른 값으로 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchSmtpMaxHopCount 특성의 구성된 값이 기본값과 다르게 변경되었는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

Exchange 2000 Server에서 msExchSmtpMaxHopCount 특성은 기본값인 15로 구성되어 있습니다. Exchange Server 2003에서 이 특성의 기본값은 30입니다. Exchange Server Analyzer는 이 특성이 기본 설정으로 구성되어 있지 않으면 기본 구성이 아니라는 메시지를 표시합니다.

메시지는 최종 대상 위치에 도달하기 전에 여러 SMTP 서버(홉)로 라우팅될 수 있습니다. 관리자는 허용되는 최대 홉 수를 제어하여 반복적으로 발생하는 메시지의 잘못된 라우팅(메시지 반복)을 방지할 수 있습니다. mxExchSmtpMaxHopCount 특성은 메시지가 배달할 수 없는 메시지로 간주되어 보낸 사람에게 되돌아가기 전까지 몇 개의 SMTP 서버에 전달될 수 있는지를 지정합니다.

Exchange 2000 Server와 Exchange Server 2003 SMTP 가상 서버에서는 이 값을 30으로 설정하는 것이 좋습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, Exchange 서버, 프로토콜, SMTP를 차례로 확장합니다.

  2. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  3. 배달 탭을 선택한 다음 고급을 클릭합니다.

  4. 최대 홉 수 필드에 원하는 값을 입력하고 확인을 클릭하여 변경 내용을 저장합니다.

  5. 확인을 클릭하여 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxMessageSize 값이 기본값인 0에서 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchSmtpMaxMessageSize 특성 값이 기본값 0에서 변경되었는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 msExchSmtpMaxMessageSize 특성은 무제한의 메시지 크기를 사용하도록 구성됩니다. Exchange Server Analyzer는 이 특성의 값이 0이 아니고 Exchange가 Microsoft Windows® Small Business Server 2003에서 실행되고 있지 않으면 경고 메시지를 표시합니다.

msExchSmtpMaxMessageSize 특성은 주고받을 수 있는 각 SMTP 메시지의 최대 크기를 나타냅니다. 보안 측면에서는 인터넷에서 주고받을 수 있는 SMTP 메시지의 크기를 제한하는 것이 가장 좋습니다. 그러나 같은 조직 내의 Exchange 서버 간에 주고받는 내부 SMTP 메시지의 경우 msExchSmtpMaxMessageSize 특성을 0으로 설정해 두는 것이 좋습니다.

내부적으로 Exchange는 공용 폴더 복제와 같은 작업을 처리할 때 SMTP 메시지를 사용합니다. msExchSmtpMaxMessageSize 특성이 너무 낮은 제한치로 구성되어 있으면 공용 폴더 복제 문제 및 조직 내 메시지 배달 실패가 발생할 수 있습니다.

이 Exchange 서버가 인터넷으로 SMTP 메시지를 보내거나 인터넷에서 SMTP 메시지를 가져오는 브리지헤드 서버인 경우 이 경고를 무시해도 안전합니다. 이 Exchange 서버가 내부 SMTP 메시지를 처리하는 경우 msExchSmtpMaxMessageSize 특성 값을 다시 기본값 0으로 변경해야 합니다.

참고:
메시지 크기 제한을 너무 낮게 설정하면 Exchange Server 컴퓨터 간 오프라인 주소록 복제가 수행되지 않을 수 있습니다. 이 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 326154, "XADM: The OAB Does Not Replicate If You Set a Message Size Restriction at the Transport Level"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154)을 참조하십시오.

최대 SMTP 메시지 크기를 확인 및 구성하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, Exchange 서버, 프로토콜 및 SMTP를 차례로 확장합니다.

  2. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  3. 메시지 탭을 선택합니다.

  4. 기본 설정 0으로 되돌리려면 메시지 크기 제한(KB) 확인란을 지웁니다. 또는 이 확인란을 선택된 상태로 두고 원하는 값을 구성합니다.

  5. 확인을 클릭하여 변경 내용을 저장하고 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxOutboundMsgPerDomain 값이 기본값 20과 다르게 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-07-07

Microsoft® Exchange Server Analyzer Tool은 msExchSmtpMaxOutboundMsgPerDomain 특성의 구성된 값이 기본값 20과 다르게 변경되었는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 msExchSmtpMaxOutboundMsgPerDomain 특성은 연결당 최대 20개의 아웃바운드 SMTP 메시지를 허용하도록 구성됩니다. Exchange Server Analyzer는 이 특성 값이 20이 아닐 경우 기본 구성이 아니라는 메시지를 표시합니다.

msExchSmtpMaxOutboundMsgPerDomain 특성은 Exchange Server에서 SMTP 가상 서버가 보낼 수 있는 연결당 최대 메시지 수를 나타냅니다. 예를 들어 SMTP 서버에 microsoft.com으로 보낼 메시지가 35개 있으며 msExchSmtpMaxOutboundMsgPerDomain 특성이 20으로 설정되어 있으면 microsoft.com 메시지를 처리하기 위한 메일 서버로의 연결이 두 개 설정됩니다. 첫 번째 연결은 최대 20개의 메시지를 보내며 나머지 15개의 메시지를 보내기 위해 두 번째 연결이 설정됩니다.

일반적으로 이 특성에 올바른 값을 판별할 때 권장되는 방법은 없습니다. 각 조직에서는 설정할 적절한 값을 직접 확인해야 합니다.

연결당 최대 메시지 수를 설정하려면 다음을 수행하십시오.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange Server, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 메시지를 클릭합니다.

  5. msExchSmtpMaxOutboundMsgPerDomain 특성의 현재 값이 연결 수 제한 필드에 나열됩니다. 필요한 경우 이 필드를 변경한 다음 확인을 클릭하여 변경 내용을 저장합니다. 이 필드에 적절한 값은 1-1999999999 사이의 모든 정수입니다.

  6. 확인을 클릭하여 SMTP 가상 서버에 대한 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxOutgoingConnections 값이 기본값 1000에서 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchSmtpMaxOutgoingConnections 특성의 구성된 값이 기본값 1000에서 변경되었는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 msExchSmtpMaxOutgoingConnections 특성은 최대 1000개의 아웃바운드 SMTP(Simple Mail Transfer Protocol) 연결을 허용하도록 구성됩니다. Exchange Server Analyzer는 이 특성 값이 1000이 아닐 경우 기본 구성이 아니라는 메시지를 표시합니다.

msExchSmtpMaxOutgoingConnections 특성은 Exchange Server에서 SMTP 가상 서버가 만들 수 있는 최대 아웃바운드 연결 수를 나타냅니다.

일반적으로 이 특성에 올바른 값을 판별할 때 권장되는 방법은 없습니다. 각 조직에서는 설정할 적절한 값을 직접 확인해야 합니다. 즉, 일부 조직에서는 기본값이 훨씬 더 클 수 있습니다. Exchange 서버에서 다음 성능 카운터를 수집하여 Exchange SMTP 가상 서버에서 만든 실제 SMTP 아웃바운드 연결 수를 모니터링하고 확인할 수 있습니다.

개체 | 카운터 | 설명
SMTP Server | Outbound Connections Current | 현재 아웃바운드 연결 수입니다.
SMTP Server | Outbound Connections Total | 시도된 총 아웃바운드 연결 수입니다.

조직에서 이 Exchange 서버에서 아웃바운드 SMTP를 포괄적으로 사용하지 않을 경우 이 특성 값을 낮추는 것을 고려하십시오. 특정 시점에 설정될 수 있는 동시 아웃바운드 SMTP 연결의 최대 수를 낮추면 잘못된 구성, 단순한 실수, 악의적인 동작, 메시지 루프나 기타 오작동, 바이러스 확산이나 보안 위반 등으로 인해 야기될 수 있는 SMTP 서버 활동 장애가 완화될 수 있습니다.

아웃바운드 연결 제한을 확인하고 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange 서버, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 배달을 클릭한 다음 아웃바운드 연결을 클릭합니다.

  5. msExchSmtpMaxOutgoingConnections 특성의 현재 값이 연결 수 제한 필드에 나열됩니다. 필요한 경우 이 필드를 변경한 다음 확인을 클릭하여 변경 내용을 저장합니다. 이 필드에는 1에서 1999999999 사이의 정수를 사용할 수 있습니다.

  6. 확인을 클릭하여 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxOutgoingConnectionsPerDomain 값이 기본값 100과 다른 값으로 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchSmtpMaxOutgoingConnectionsPerDomain 특성의 구성된 값이 기본 설정에서 변경되었는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. msExchSmtpMaxOutgoingConnectionsPerDomain 특성은 Microsoft Exchange 서버의 SMTP 가상 서버에서 만들 수 있는 도메인당 최대 아웃바운드 연결 수를 나타냅니다. 기본적으로 Microsoft® Windows® Small Business Server 2003 설치의 일부가 아닌 Exchange Server 컴퓨터의 msExchSmtpMaxOutgoingConnectionsPerDomain 특성은 기본값 100으로 구성됩니다. Windows Small Business Server 2003 설치의 일부인 Exchange Server 컴퓨터의 도메인당 최대 나가는 연결 수의 기본값은 10입니다.

또한 Exchange Server Analyzer는 OSProductSuite 키 값을 확인할 때 Win32_OperatingSystem WMI(Windows Management Instrumentation) 클래스를 쿼리합니다. 이 키 값은 Windows Server 운영 체제의 특정 버전에 해당합니다.

Exchange Server Analyzer는 Windows Small Business Server 2003 설치의 일부가 아닌 Exchange Server 컴퓨터에서 msExchSmtpMaxOutgoingConnectionsPerDomain 특성 값이 500이 아니면 기본 구성이 아니라는 메시지를 표시합니다.

또는 Exchange Server Analyzer는 Windows Small Business Server 2003 설치의 일부인 Exchange Server 컴퓨터에서 msExchSmtpMaxOutgoingConnectionsPerDomain 특성 값이 10이 아니면 기본 구성이 아니라는 메시지를 표시합니다.

일반적으로 이 특성에 맞는 올바른 값을 결정하기 위해 권장되는 방법은 없습니다. 각 조직에서 적절한 값을 결정하여 설정해야 합니다. 즉 어떤 조직에서는 기본값이 너무 높을 수도 있습니다. 해당 Exchange 서버에서 다음 성능 카운터를 수집하여 Exchange SMTP 가상 서버에서 연결한 실제 SMTP 아웃바운드 연결 수를 모니터링하고 확인할 수 있습니다.

개체 | 카운터 | 설명
SMTP Server | Outbound Connections Current | 현재 아웃바운드 연결 수입니다.
SMTP Server | Outbound Connections Total | 총 아웃바운드 연결 시도 수입니다.

조직에서 이 Exchange 서버에서 나가는 SMTP를 광범위하게 사용하지 않을 경우 이 특성 값을 낮추는 것을 고려합니다. 주어진 시간에 설정할 수 있는 최대 동시 아웃바운드 SMTP 연결 수를 낮추면 SMTP 서버 작업에서 잘못된 구성, 실수, 악의적인 작업, 메시지 루프 또는 기타 오작동, 바이러스 감염 또는 보안 침해로 인해 발생할 수 있는 스파이크가 잠재적으로 느려질 수 있습니다.

도메인당 나가는 연결 제한을 보고 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange 서버, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 배달을 클릭한 다음 아웃바운드 연결을 클릭합니다.

  5. msExchSmtpMaxOutgoingConnectionsPerDomain 특성의 현재 값이 도메인 당 연결 수 제한 필드에 나타납니다. 원할 경우 이 필드를 변경한 다음 확인을 클릭하여 변경 내용을 저장합니다. 이 필드에 적절한 값은 1-1999999999 사이의 모든 정수입니다.

  6. 확인을 클릭하여 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxRecipients 값이 기본값 64000에서 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchSmtpMaxRecipients 특성의 구성 값이 기본값 64000에서 변경되었는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 msExchSmtpMaxRecipients 특성은 받는 사람을 64,000으로 구성합니다. Exchange Server Analyzer는 이 특성 값이 64000이 아닐 경우 기본 구성이 아니라는 메시지를 표시합니다.

보안 측면에서 볼 때 각 메시지당 받는 사람의 최대 크기를 제한하는 것이 좋습니다. 각 조직은 자체 조직에 적합한 값을 결정해야 합니다. 이 값을 변경해야 할 특별한 이유가 없으면 msExchSmtpMaxRecipients 특성을 기본값 64000으로 설정해 두는 것이 좋습니다.

최대 받는 사람 수를 보고 구성하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, Exchange 서버, 프로토콜, SMTP를 차례로 확장합니다.

  2. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  3. 메시지 탭을 선택합니다.

  4. 기본 설정인 64000으로 되돌리려면 메시지당 받는 사람 수 제한 확인란을 선택하고 64000을 입력합니다. 기본 설정 대신에 이 필드를 원하는 값으로 구성하거나 확인란의 선택을 해제하여 받는 사람 수를 제한하지 않을 수 있습니다.

  5. 확인을 클릭하여 변경 내용을 저장하고 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpMaxSessionSize 값이 기본값인 0에서 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchSmtpMaxSessionSize 특성에 대해 구성된 값이 기본값 0이 아닌 다른 값으로 변경되었는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 msExchSmtpMaxSessionSize 특성은 무제한의 메시지 크기에 대해 구성됩니다. Exchange Server Analyzer는 이 특성 값이 0이 아닌 경우 경고 메시지를 표시합니다.

msExchSmtpMaxSessionSize 특성은 각 SMTP 세션에 허용될 최대 데이터(KB)를 나타냅니다. 보안상 인터넷에서 보내고 받는 메시지에 대해 SMTP 세션의 크기를 제한하는 것은 아주 좋습니다. 그러나 같은 조직의 Exchange 서버 간 세션과 같은 내부 SMTP 세션의 경우 msExchSmtpMaxSessionSize 특성을 0으로 설정하는 것이 좋습니다.

내부적으로 Exchange는 SMTP 메시지를 사용하여 공용 폴더 복제 등의 작업을 처리합니다. msExchSmtpMaxSessionSize 특성을 너무 낮게 구성하면 공용 폴더 복제 문제 및 기타 조직 내 메시지 배달 실패가 발생할 수 있습니다.

이 Exchange 서버가 SMTP 메시지를 인터넷에서 보내고 받는 브리지헤드 서버인 경우 이 경고를 무시해도 안전합니다. 이 Exchange 서버가 내부 SMTP 메시지를 처리할 경우 msExchSmtpMaxSessionSize 특성 값을 기본 설정인 0으로 다시 변경해야 합니다.

최대 SMTP 세션 크기를 보고 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 메시지를 클릭합니다.

  5. 기본값 0으로 되돌리려면 세션 크기 제한(KB) 확인란의 선택을 해제합니다. 또는 이 확인란을 선택된 상태로 두고 원하는 값을 구성합니다.

  6. 확인을 클릭하여 변경 내용을 저장하고 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpOutgoingPort 값이 기본값 25에서 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchSmtpOutgoingPort 특성의 구성된 값이 기본값 25에서 변경되었는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 msExchSmtpOutgoingPort 특성은 TCP 포트 25용으로 구성됩니다. Exchange Server Analyzer는 이 특성이 포트 25가 아닌 다른 포트용으로 구성되면 경고를 표시합니다.

기본적으로 SMTP(Simple Mail Transfer Protocol) 서버는 TCP 포트 25에서 인바운드 연결을 받아들이도록 구성됩니다. msExchSmtpOutgoingPort 매개 변수는 이 Exchange 서비스가 모든 원격 SMTP 서버에서 연결하려고 시도할 TCP 포트를 나타냅니다. 이 포트에서 수신하도록 원격 SMTP 서버를 구성하지 않은 경우에는 연결할 수 없습니다.

비표준 포트를 사용하도록 일부 또는 전체 내부 메시징 인프라를 수정하지 않은 한 모든 SMTP 통신에 TCP 포트 25를 사용하는 것이 좋습니다.

기본 나가는 SMTP 포트를 보거나 변경하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, Exchange 서버, 프로토콜, SMTP를 차례로 확장합니다.

  2. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 배달을 클릭한 다음 아웃바운드 연결을 클릭합니다.

  4. TCP 포트 필드에 아웃바운드 연결에 사용할 포트를 입력합니다. 통신할 모든 원격 SMTP가 지정된 포트에서 연결을 받아들이도록 구성되어 있어야 합니다. 대부분의 경우 이 값을 변경할 필요가 없습니다.

  5. 필요한 경우 이 필드를 변경한 다음 확인을 클릭하여 변경 내용을 저장합니다.

  6. 확인을 클릭하여 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


msExchSmtpRelayForAuth 값이 기본값 True에서 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchSmtpRelayForAuth 특성의 구성된 값이 기본값과 다르게 변경되었는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 msExchSmtpRelayForAuth 특성은 True 값으로 구성됩니다. Exchange Server Analyzer는 msExchSmtpRelayForAuth 특성이 True가 아닌 경우 기본 구성이 아니라는 메시지를 표시합니다.

이 값이 True로 설정되면 인증된 SMTP 연결만 이 SMTP 가상 서버를 통해 SMTP 메시지를 릴레이할 수 있습니다. 이 설정이 False로 구성되면 SMTP 가상 서버 속성 대화 상자의 릴레이 설정에서 "위 목록과 상관없이 인증한 모든 컴퓨터에 릴레이 허용" 확인란의 선택이 해제되어 있는 것입니다.

릴레이는 외부 도메인으로 전자 메일 메시지를 보내는 데 사용되는 SMTP 서버에 대한 인바운드 연결 작업입니다. 원치 않는 상업성 전자 메일 메시지를 보내야 할 경우 조직 외부의 도메인에 속하며 여러 명의 받는 사람을 포함하는 SMTP 서버로 이러한 메시지를 한 번만 보내면 릴레이가 수행됩니다. SMTP 서버의 기본 설정이 익명 인증을 사용하도록 지정되어 있으므로 원치 않는 상업성 전자 메일 메시지를 전파하는 데 사용되는 시스템은 인바운드 메시지를 일반적인 메시지로 수락합니다.

메시지가 수락되면 SMTP 서버는 해당 메시지 받는 사람이 외부 도메인에 속해 있음을 인식하고 메시지를 배달합니다. 따라서 허가되지 않은 사용자가 원치 않는 상업성 전자 메일 메시지를 보내려고 할 경우 SMTP 서버로 인바운드 메시지를 한 번만 보내면 수천 명의 받는 사람에게 메시지가 배달될 수 있습니다. 이로 인해 Exchange Server 컴퓨터의 응답 속도가 느려지고 큐가 정체되며 받은 편지함에 원치 않은 메일을 받게 되어 받는 사람의 불만이 높아질 수 있습니다.

릴레이를 제어하는 1차적인 방법은 다른 호스트에 릴레이 사용 권한을 부여하지 않는 것입니다. 그러나 경우에 따라 릴레이가 필요할 수도 있습니다. 예를 들어 SMTP를 통해 메시지를 배달하는 POP3(Post Office Protocol 3) 및 IMAP4(Internet Message Access Protocol 4) 클라이언트가 있으며 외부 도메인으로 전자 메일 메시지를 보내야 할 경우 POP3 및 IMAP4 클라이언트에서 전자 메일 메시지를 받는 일을 전담하는 또 다른 SMTP 가상 서버를 만들어 이 문제를 해결할 수 있습니다. 이러한 추가 SMTP 가상 서버는 인증 및 SSL(Secure Sockets Layer) 기반 암호화를 사용할 수 있으며 인증된 클라이언트에 대해 릴레이를 사용하도록 구성할 수 있습니다. 이 구성을 구현하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 319267, "HOW TO: Exchange 2000에서 Simple Message Transfer Protocol 클라이언트 메시지 배달 보호"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267)를 참조하십시오.

System Manager에서 msExchSmtpRelayForAuth 값을 보거나 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange 서버, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 액세스 탭을 선택한 다음 릴레이를 클릭합니다.

  5. 위 목록과 상관없이 인증한 모든 컴퓨터에 릴레이 허용 확인란을 선택하거나 선택을 해제합니다.

  6. 확인을 클릭하여 변경 내용을 저장합니다.

이 상자가 선택되면 msExchSmtpRelayForAuth 특성은 True로 설정되어야 하며 선택이 해제되면 msExchSmtpRelayForAuth 특성은 False로 설정되어야 합니다.

메시지를 릴레이할 수 있는 계정의 제어에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 818778, "Users Without Permissions to Relay Messages Can Still Send Messages Through the SMTP Virtual Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=818778)

  • 310380, "HOW TO: Windows 2000에서 Exchange 2000이 메일 릴레이로 사용되지 않도록 방지"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380)


msExchSmtpSmartHostType 값이 기본값인 0에서 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 구성된 msExchSmtpSmartHostType 특성 값이 기본값인 0에서 변경되었는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 msExchSmtpSmartHostType 특성은 0으로 설정되어 있습니다. Exchange Server Analyzer는 이 특성 값이 0이 아닐 경우 기본 구성이 아니라는 메시지를 표시합니다.

msExchSmtpSmartHostType 특성은 SMTP 가상 서버가 메시지 배달을 위해 스마트 호스트를 사용하도록 구성되어 있는지 여부를 나타냅니다. 원격 도메인의 모든 보내는 메시지를 받는 사람 도메인으로 직접 보내는 대신 스마트 호스트를 통과하도록 라우팅할 수 있습니다. Exchange가 스마트 호스트를 사용하도록 구성되면 msExchSmtpSmartHostType 특성 값은 다음 표에 설명된 대로 변경됩니다.

스마트 호스트 설정 | msExchSmtpSmartHostType 특성 값
스마트 호스트 없음 | 0
스마트 호스트 | 2
직접 배달 시도 후 스마트 호스트 | 1

Exchange Server 2003 컴퓨터에서 이 값은 0 또는 2가 되며 Exchange 2000 Server 컴퓨터에서는 0, 1 또는 2가 됩니다. 스마트 호스트에 보내기 전에 직접 배달 시도 확인란이 선택되면 값 1이 설정됩니다. 이 확인란은 Exchange 2000 Server 컴퓨터에만 표시되며 Exchange Server 2003에는 이 확인란이 없습니다.

다른 특별한 이유가 없으면 msExchSmtpSmartHostType 특성을 기본값인 0으로 유지하는 것이 좋습니다.

작업 환경에 스마트 호스트가 필요하며 두 대 이상의 Exchange Server 컴퓨터를 사용하고 있거나 사용할 예정이면 스마트 호스트 항목에 대해 SMTP 커넥터를 사용하는 것이 좋습니다. 이렇게 하면 모든 내부 메일이 Exchange Server에 의해 라우팅되며 외부 메일만 스마트 호스트를 통해 라우팅됩니다.

스마트 호스트 설정을 보고 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange 서버, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  4. 배달 탭을 선택한 후 고급을 클릭합니다.

  5. 사용할 스마트 호스트를 입력합니다. 정규화된 도메인 이름(FQDN) 또는 IP 주소로 스마트 호스트를 식별할 수 있습니다. IP 주소를 사용할 경우 대괄호([ ])로 묶어야 합니다. Exchange은 먼저 서버 이름을 확인한 후 IP 주소를 확인합니다. 대괄호로 묶여 있으면 해당 값이 IP 주소로 인식되므로 DNS 조회는 수행되지 않습니다.

  6. 사용하는 시스템이 Exchange 2000 Server 컴퓨터일 경우 선택적으로 스마트 호스트에 보내기 전에 직접 배달 시도 확인란을 선택합니다.

  7. 확인을 클릭하여 변경 내용을 저장한 다음 확인을 클릭하여 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=268163)


MTA Stacks 서비스가 데스크톱과 상호 작용하도록 구성되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Microsoft Exchange MTA Stacks(MSExchangeMTA) 서비스의 DesktopInteract 속성 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 MTA 서비스가 데스크톱과 상호 작용하도록 구성되면 오류를 표시합니다.

이 구성은 Microsoft 기술 지원 서비스의 안내에 따라서만 사용해야 합니다. PSS에서 이 구성으로 MTA 서비스를 실행하도록 지시하지 않은 경우 데스크톱과 상호작용하지 않도록 MTA Stacks 서비스 속성을 다시 구성하는 것이 좋습니다.

Exchange MTA Stacks 서비스 계정을 구성하려면 다음을 수행합니다.

  1. 서비스 MMC 스냅인을 엽니다.

  2. Microsoft Exchange MTA Stacks 서비스를 찾아서 중지합니다.

  3. Microsoft Exchange MTA Stacks 서비스를 두 번 클릭합니다.

  4. Microsoft Exchange MTA Stacks 속성 페이지의 로그온 탭에서 다음 계정으로 로그온 아래의 LocalSytem 계정을 선택합니다.

  5. 서비스와 데스크톱 상호 작용 허용 확인란의 선택을 해제한 다음 적용을 클릭합니다.

  6. 서비스 상태에서 시작을 클릭한 다음 확인을 클릭합니다.

  7. 서비스 스냅인을 닫습니다.

올바른 Exchange 서비스 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 239762, "Exchange Services Run Under LocalSystem"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762)을 참조하십시오.


'MX' 레코드에 대한 '호스트' 레코드가 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-03

Microsoft® Exchange Server Analyzer Tool은 DNS(Domain Name System) 조회를 수행하여 도메인의 메일 교환기(MX) 레코드를 검색합니다. MX 레코드를 성공적으로 검색한 경우 Exchange Server Analyzer는 DNS 조회를 수행하여 MX 레코드가 가리키는 서버의 호스트(A) 레코드를 검색합니다. DNS 조회 결과로 해당 호스트(A) 레코드에 대한 IP 주소가 반환되지 않으면 오류가 표시됩니다.

이 오류는 서버에 대한 DNS 호스트(A) 레코드가 없음을 나타냅니다. 이 오류로 인해 원격 도메인으로 전송되어야 할 메시지가 Exchange 서버의 원격 배달 큐에 백업될 수 있습니다. 또한 이 오류로 인해 다른 라우팅 또는 서비스 지연이 발생할 수 있습니다.

다음과 같은 경우 MX 레코드에 대한 호스트(A) 레코드의 DNS 조회가 실패할 수 있습니다.

  • 네트워크 오류나 기타 이유로 인해 DNS 서버가 다운되거나 응답하지 않을 경우

  • 호스트(A) 레코드를 사용할 수 없거나 잘못되었기 때문에 DNS 서버에 원격 서버의 호스트(A) 레코드가 없는 경우

  • 동적 호스트 레코드 업데이트를 사용하도록 DNS 서버가 구성되지 않은 경우

DNS 서버가 온라인 상태이고 호스트 레코드가 있는지 확인하려면 다음을 수행합니다.

  1. 다음 확인 작업 중 하나 이상을 수행하여 DNS 서버가 실행되고 있는지 확인합니다.

    • DNS 서버의 DNS 관리 프로그램에서 DNS 서버 상태를 확인합니다.

    • DNS 서버를 다시 시작합니다. 자세한 내용은 "DNS 서버 시작, 중지, 일시 중지 및 다시 시작"(http://go.microsoft.com/fwlink/?LinkId=62999)을 참조하십시오.

    • nslookup 명령을 사용하여 DNS 서버 응답 기능을 확인합니다. 자세한 내용은 "nslookup 명령을 사용하여 DNS 서버 응답 확인"(http://go.microsoft.com/fwlink/?LinkId=63000)을 참조하십시오.

  2. nslookup을 사용하여 호스트(A) 레코드가 DNS 서버에 있는지 확인합니다. 자세한 내용은 "A 리소스 레코드가 DNS에 있는지 확인하려면"(http://go.microsoft.com/fwlink/?LinkId=63001)을 참조하십시오.

  3. 호스트(A) 리소스 레코드가 없으면 수동으로 A 리소스 레코드를 추가 또는 수정하거나 동적 레코드 업데이트가 가능하도록 DNS 서버를 구성합니다.

    • 수동으로 A 리소스 레코드를 추가합니다. 자세한 내용은 "DNS 영역에 리소스 레코드 추가"(http://go.microsoft.com/fwlink/?LinkId=63002)를 참조하십시오.

    • 수동으로 A 리소스 레코드를 수정합니다. 자세한 내용은 "기존 리소스 레코드 수정"(http://go.microsoft.com/fwlink/?LinkId=63014)을 참조하십시오.

    • 동적 호스트 레코드 업데이트가 가능하도록 DNS 서버를 구성합니다. 자세한 내용은 Microsoft 기술 자료 문서 816592, "Windows Server 2003에서 DNS 동적 업데이트를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)을 참조하십시오.

자세한 정보

  • Exchange Server 2003이 DNS를 사용하여 외부 IP 주소를 확인하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "Exchange Server 2003 전송 종속성"을 참조하십시오.

  • DNS 이름 확인에 대한 자세한 내용은 Microsoft 기술 자료 문서 322856, "HOWTO: Exchange Server 사용을 위한 DNS 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)을 참조하십시오.

  • DNS 문제 해결에 대한 자세한 내용은 "DNS 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=63003)을 참조하십시오.

  • Exchange Server 2003 시스템 모니터링에 대한 자세한 내용은 MOM 2000 SP1용 Exchange Server 2003 관리 팩 가이드(http://go.microsoft.com/fwlink/?LinkId=47573)의 "3장: Exchange Server 2003 관리 팩으로 시스템 모니터링"을 참조하십시오.

  • 호스트(A) 리소스 레코드에 대한 자세한 내용은 "리소스 레코드 관리"(http://go.microsoft.com/fwlink/?LinkId=63004)를 참조하십시오.


'호스트' 레코드가 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-04

Microsoft® Exchange Server Analyzer Tool은 DNS(Domain Name System) 조회를 수행하여 Exchange가 메시지를 보내려는 원격 서버의 호스트(A) 레코드를 검색합니다. DNS 조회 결과로 IP 주소가 반환되지 않으면 오류가 표시됩니다.

이 오류는 원격 서버에 대한 DNS 호스트(A) 레코드가 없음을 나타냅니다. 이 오류로 인해 메시지가 Exchange 서버의 원격 배달 큐에 백업될 수 있습니다.

다음과 같은 경우 원격 서버에서 호스트(A) 레코드의 DNS 조회가 실패할 수 있습니다.

  • 네트워크 오류나 기타 이유로 인해 DNS 서버가 다운되거나 응답하지 않을 경우

  • 호스트(A) 레코드를 사용할 수 없거나 잘못되었기 때문에 DNS 서버에 원격 서버의 호스트(A) 레코드가 없는 경우

  • 동적 호스트 레코드 업데이트를 사용하도록 DNS 서버가 구성되지 않은 경우

DNS 서버가 온라인 상태이고 호스트 레코드가 있는지 확인하려면 다음을 수행합니다.

  1. 다음 확인 작업 중 하나 이상을 수행하여 DNS 서버가 실행되고 있는지 확인합니다.

    • DNS 서버의 DNS 관리 프로그램에서 DNS 서버 상태를 확인합니다.

    • DNS 서버를 다시 시작합니다. 자세한 내용은 "DNS 서버 시작, 중지, 일시 중지 및 다시 시작"(http://go.microsoft.com/fwlink/?LinkId=62999)을 참조하십시오.

    • nslookup 명령을 사용하여 DNS 서버 응답 기능을 확인합니다. 자세한 내용은 "nslookup 명령을 사용하여 DNS 서버 응답 기능 확인"(http://go.microsoft.com/fwlink/?LinkId=63000)을 참조하십시오.

  2. nslookup을 사용하여 호스트(A) 레코드가 DNS 서버에 있는지 확인합니다. 자세한 내용은 "A 리소스 레코드가 DNS에 있는지 확인하려면"(http://go.microsoft.com/fwlink/?LinkId=63001)을 참조하십시오.

  3. 호스트(A) 리소스 레코드가 없으면 수동으로 A 리소스 레코드를 추가 또는 수정하거나 동적 레코드 업데이트가 가능하도록 DNS 서버를 구성합니다.

    • 수동으로 A 리소스 레코드를 추가합니다. 자세한 내용은 "DNS 영역에 리소스 레코드 추가"(http://go.microsoft.com/fwlink/?LinkId=63002)를 참조하십시오.

    • 수동으로 A 리소스 레코드를 수정합니다. 자세한 내용은 "기존 리소스 레코드 수정"(http://go.microsoft.com/fwlink/?LinkId=63014)을 참조하십시오.

    • 동적 호스트 레코드 업데이트가 가능하도록 DNS 서버를 구성합니다. 자세한 내용은 Microsoft 기술 자료 문서 816592, "Windows Server 2003에서 DNS 동적 업데이트를 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592)을 참조하십시오.
  • Exchange Server 2003이 DNS를 사용하여 외부 IP 주소를 확인하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "Exchange Server 2003 전송 종속성"을 참조하십시오.

  • DNS 이름 확인에 대한 자세한 내용은 Microsoft 기술 자료 문서 322856, "HOWTO: Exchange Server 사용을 위한 DNS 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)을 참조하십시오.

  • DNS 문제 해결에 대한 자세한 내용은 "DNS 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=63003)을 참조하십시오.

  • Exchange Server 2003 시스템 모니터링에 대한 자세한 내용은 MOM 2000 SP1용 Exchange Server 2003 관리 팩 가이드(http://go.microsoft.com/fwlink/?LinkId=47573)의 "3장: Exchange Server 2003 관리 팩으로 시스템 모니터링"을 참조하십시오.

  • 호스트(A) 리소스 레코드에 대한 자세한 내용은 "리소스 레코드 관리"(http://go.microsoft.com/fwlink/?LinkId=63004)를 참조하십시오.


'MX' 레코드가 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 Exchange가 보내는 원격 도메인의 메일 교환기(MX)에 사용되는 DNS(Domain Name System) 서버를 쿼리합니다.

Exchange Server Analyzer가 사용하는 DNS 서버에서 원격 도메인에 대한 MX 레코드를 검색할 수 없는 경우 경고가 표시됩니다.

이 경고는 원격 도메인에 대한 DNS MX 레코드가 없음을 나타냅니다.

보내는 Exchange 서버는 메일 호스트를 확인하기 위해 MX 레코드를 확인합니다. 그런 다음 보내는 서버는 주소(A) 레코드를 확인하여 IP 주소에 대한 MX 레코드를 확인합니다.

원격 도메인에 대한 MX 레코드가 없을 경우 다른 라우팅 또는 서비스가 지연되는 것 외에도 원격 도메인으로 전송되는 메시지가 Exchange 서버의 원격 배달 큐에 백업될 수 있습니다.

네트워크 오류나 다른 이유 때문에 DNS 서버가 다운되거나 연결할 수 없는 경우, MX 레코드의 DNS 조회가 실패할 수 있습니다.

DNS 서버가 온라인 상태이고 MX 레코드가 있는지 확인하려면 다음을 수행합니다.

  1. 다음 확인 작업 중 하나를 수행하여 DNS 서버가 실행되고 있는지 확인합니다.

    • DNS 서버의 DNS 관리 프로그램에서 DNS 서버 상태를 확인합니다.

    • DNS 서버를 다시 시작합니다. 자세한 내용은 "DNS 서버 시작, 중지, 일시 중지 및 다시 시작"(http://go.microsoft.com/fwlink/?LinkId=62999)을 참조하십시오.

    • nslookup 명령을 사용하여 DNS 서버 응답 기능을 확인합니다. 자세한 내용은 "nslookup 명령을 사용하여 DNS 서버 응답 기능 확인"(http://go.microsoft.com/fwlink/?LinkId=63000)의 설명을 참조하십시오.

  2. nslookup을 사용하여 MX 레코드가 올바르게 구성되었는지 확인합니다. 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "DNS 디자인 및 구성 확인" 섹션에 있는 "Nslookup을 사용하여 MX 레코드 구성 확인 방법"을 참조하십시오.

자세한 정보

  • Exchange Server 2003이 DNS를 사용하여 외부 IP 주소를 확인하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "Exchange Server 2003 전송 종속성"을 참조하십시오.

  • DNS 이름 확인에 대한 자세한 내용은 Microsoft 기술 자료 문서 322856, "HOWTO: Exchange Server 사용을 위한 DNS 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)을 참조하십시오.

  • DNS 문제 해결에 대한 자세한 내용은 "DNS 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=63003)을 참조하십시오.

  • Exchange Server 2003 시스템 모니터링에 대한 자세한 내용은 MOM 2000 SP1용 Exchange Server 2003 관리 팩 가이드(http://go.microsoft.com/fwlink/?LinkId=47573)의 "3장: Exchange Server 2003 관리 팩으로 시스템 모니터링"을 참조하십시오.


배달 제한에 중첩 메일 그룹이 있음
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-21

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에 있는 모든 도메인에서 각 메일 그룹 개체의 다음 특성을 쿼리하여 그룹 구성원을 기반으로 배달 제한을 설정하는 데 그룹이 사용되는지 확인합니다.

dLMemRejectPermsBL | 이 그룹의 메시지를 수락하지 않을 받는 사람 또는 커넥터의 DN을 포함합니다.
dLMemSubmitPermsBL | 이 그룹의 메시지를 수락할 받는 사람 또는 커넥터의 DN을 포함합니다.

배달 제한을 설정하는 데 사용되는 그룹 개체가 있는 경우 Exchange Server Analyzer에서 해당 그룹을 검사하여 중첩 그룹이 포함되어 있는지 확인합니다.

또한 Exchange Server Analyzer는 다음 레지스트리 키를 읽어서 RestrictionMethod 레지스트리 값이 있는지 여부와 구성 방법을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고 메시지를 표시합니다.

  • 메일 그룹 구성원이 배달 제한을 설정하는 데 사용됩니다.

  • 배달 제한이 설정된 메일 그룹에 중첩 메일 그룹이 있습니다.

  • RestrictionMethod 레지스트리 값이 있으며 기본 제한 검사를 강제 실행하도록 설정되어 있지 않습니다.

이 오류는 메일 그룹 구성원을 기반으로 하는 배달 제한이 Exchange 메일 흐름 성능에 큰 영향을 줄 수 있음을 나타냅니다.

분류기의 기본 동작은 메일 그룹을 반복적으로 확장하고 시스템을 통과하는 각 메시지에 대한 제한을 검사합니다.

메일 그룹의 메시지를 수락하거나 거부하는 사용자에게 메일을 보내거나 메일 그룹의 메시지를 수락하거나 거부하는 커넥터를 통해 메일을 보낼 경우 메시지 분류기에서 메일 그룹의 구성원을 확장하고 구성원의 전체 DN 목록을 가져온 다음 해당 DN 목록을 보낸 사람 DN 목록과 비교해야 합니다. 두 목록의 DN이 일치할 경우 액세스 작업이나 거부 작업이 수행됩니다. 메일 그룹이 다른 메일 그룹에 중첩된 경우 중첩 메일 그룹도 확장됩니다.

RestrictionMethod 값은 분류기가 제한 사항을 처리하는 방법을 결정합니다. RestrictionMethod 값을 2로 설정하면 Exchange Server를 실행하는 이 서버의 전송 구성 요소에서 서버가 제한을 검사할 때 메일 그룹 구성원을 확장하지 않습니다. 이 구성은 제한 검사에 최적의 성능을 제공합니다. 또한 RestrictionMethod 레지스트리 항목을 적용하려면 배달 제한이 있는 사용자를 포함하는 모든 메일 그룹에 계층 구조가 없어야 합니다. 즉, 제한된 메일 그룹에는 중첩 메일 그룹이 없어야 합니다. 이러한 확장 논리는 제한된 메일 그룹이 중첩된 경우 작동하지 않습니다.

커넥터 제한에 사용되는 메일 그룹의 경우 사서함이 없는 커넥터 브리지헤드 서버에서 RestrictionMethod 레지스트리 항목 값을 설정하는 것이 좋습니다. Active Directory 사용자 제한의 경우 제한된 메일 그룹에 확장 서버가 있으면 확장 서버에 RestrictionMethod 레지스트리 항목을 만드는 것이 좋습니다.

이 오류를 해결하려면 다음을 수행합니다.

  • 메일 그룹 배달 제한이 설정된 사용자를 검사하고 필요 없는 제한을 제거합니다.

  • Microsoft 기술 자료 문서 812298, "Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)의 지시에 따라 메일 그룹이 아닌 개별 사서함에 배달 제한을 구성합니다.

  • Microsoft Exchange Server 2003 서비스 팩 2(SP2) 이후 버전을 실행하는 서버의 경우 비계층 제한 검사를 구현합니다. Exchange 2003 SP2 이전 버전의 Exchange를 실행하는 서버의 경우 Exchange 2003 SP2로 업그레이드합니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 레지스트리를 편집하려면 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
RestrictionMethod 레지스트리 항목을 만들고 해당 값을 2로 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters를 탐색합니다.

  3. 왼쪽 창에서 매개 변수를 클릭합니다.

  4. 편집 메뉴에서 새로 만들기를 가리킨 다음 DWORD 값을 클릭합니다.

  5. RestrictionMethod를 입력한 다음 Enter 키를 눌러 새 레지스트리 항목에 이름을 지정합니다.

  6. RestrictionMethod를 마우스 오른쪽 단추로 클릭한 다음 수정을 클릭합니다.

  7. 2를 입력한 다음 Enter 키를 누릅니다.

  8. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

자세한 정보

비계층 제한 검사에 대한 자세한 내용은 비계층적인 제한 검사를 고려합니다.를 참조하십시오.

메일 그룹 제한이 Exchange 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 895407 "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 839949 "Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)

  • 812298 "Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)

RestrictionMethod 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 895407, "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)를 참조하십시오.

레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 277872, "XCON: Connector Delivery Restrictions May Not Work Correctly"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)를 참조하십시오.


중첩 메일 그룹이 있지만 기본 제한 검사 사용
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-21

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에 있는 모든 도메인에서 각 메일 그룹 개체의 다음 특성을 쿼리하여 그룹 구성원을 기반으로 배달 제한을 설정하는 데 그룹이 사용되는지 확인합니다.

dLMemRejectPermsBL | 이 그룹의 메시지를 수락하지 않을 받는 사람 또는 커넥터의 DN을 포함합니다.
dLMemSubmitPermsBL | 이 그룹의 메시지를 수락할 받는 사람 또는 커넥터의 DN을 포함합니다.

배달 제한을 설정하는 데 사용되는 그룹 개체가 있는 경우 Exchange Server Analyzer에서 해당 그룹을 검사하여 중첩 그룹이 포함되어 있는지 확인합니다.

또한 Exchange Server Analyzer는 다음 레지스트리 키를 읽어서 RestrictionMethod 레지스트리 값이 있는지 여부와 구성 방법을 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고 메시지를 표시합니다.

  • 메일 그룹 구성원이 배달 제한을 설정하는 데 사용됩니다.

  • 배달 제한이 설정된 메일 그룹에 중첩 메일 그룹이 있습니다.

  • RestrictionMethod 레지스트리 값이 있으며 기본 제한 검사를 강제 실행하도록 설정되어 있습니다.

이 경고는 RestrictionMethod 레지스트리 값이 기본(비계층) 제한 검사를 강제 실행하도록 설정되어 있지만 배달 제한이 설정된 메일 그룹에 다른 메일 그룹이 포함되어 있음(중첩)을 나타냅니다. 메일 그룹에 중첩 메일 그룹이 있을 경우 기본 제한 검사에서 허용된 보낸 사람이나 거부된 보낸 사람을 제대로 확인할 수 없습니다. 기본 제한 검사를 사용하면 중첩 메일 그룹이 확장되지 않습니다.

분류기의 기본 동작은 메일 그룹을 반복적으로 확장하고 시스템을 통과하는 각 메시지에 대한 제한을 검사합니다.

메일 그룹의 메시지를 수락하거나 거부하는 사용자에게 메일을 보내거나 메일 그룹의 메시지를 수락하거나 거부하는 커넥터를 통해 메일을 보낼 경우 메시지 분류기에서 메일 그룹의 구성원을 확장하고 구성원의 전체 DN 목록을 가져온 다음 해당 DN 목록을 보낸 사람 DN 목록과 비교해야 합니다. 두 목록의 DN이 일치할 경우 액세스 작업이나 거부 작업이 수행됩니다. 메일 그룹이 다른 메일 그룹에 중첩된 경우 중첩 메일 그룹도 확장됩니다.

RestrictionMethod 값은 분류기가 제한 사항을 처리하는 방법을 결정합니다. RestrictionMethod 값을 2로 설정하면 Exchange Server를 실행하는 이 서버의 전송 구성 요소에서 서버가 제한을 검사할 때 메일 그룹 구성원을 확장하지 않습니다. 이 구성은 제한 검사에 최적의 성능을 제공합니다. 또한 RestrictionMethod 레지스트리 항목을 적용하려면 배달 제한이 있는 사용자를 포함하는 모든 메일 그룹에 계층 구조가 없어야 합니다. 즉, 제한된 메일 그룹에는 중첩 메일 그룹이 없어야 합니다.

이 경고를 해결하려면 기본 제한 검사를 사용하는 경우 배달 제한을 설정하는 데 사용되는 메일 그룹에 다른 메일 그룹을 중첩하지 마십시오.

자세한 정보

비계층 제한 검사에 대한 자세한 내용은 비계층적인 제한 검사를 고려합니다.를 참조하십시오.

메일 그룹 제한이 Exchange 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 895407 "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 839949 "Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)

  • 812298 "Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)

RestrictionMethod 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 895407, "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)를 참조하십시오.

레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 277872, "XCON: Connector Delivery Restrictions May Not Work Correctly"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)를 참조하십시오.


지정한 보낸 사람으로부터 받은 메시지 없음
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-03-07

Microsoft Exchange Server Analyzer Tool은 Active Directory 디렉터리 서비스에서 모든 사용자 개체의 proxyAddress 특성 값을 쿼리하여 사용자 지정 로컬 보낸 사람 SMTP(Simple Mail Transfer Protocol) 주소에 일치하는 항목이 있는지 확인합니다.

사용자 개체 proxyAddress에 일치하는 항목이 있으면 Exchange Server Analyzer는 Active Directory에서 해당 사용자 개체의 msExchHomeServerName 특성 값을 쿼리하여 이 값이 사용자 지정 Exchange Server 이름과 일치하는지 확인합니다.

마지막으로 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스 아래에 있는 Exchange_MessageTrackingEntry Microsoft WMI(Windows Management Instrumentation) 클래스의 SenderAddress 속성을 쿼리하여 메시지 추적 로그에서 사용자 지정 보낸 사람이 보낸 것으로 추적된 모든 메시지를 확인합니다.

legacyDN 또는 사용자 지정 보낸 사람의 SMTP 주소에 일치하는 senderAddress 속성 값을 가진 메시지 추적 로그 항목을 찾을 수 없는 경우 Exchange Server Analyzer에서 오류를 표시합니다.

  • 이 오류는 다음 조건 중 하나 이상에 해당함을 나타냅니다.

  • 사용자 지정 보낸 사람이 메시지를 보내지 않았습니다.

  • 메시지 추적 로그 보존 기간이 경과하여 해당 로그 항목이 이미 삭제되었습니다.

  • 서버에 대해 메시지 추적을 사용하지 않도록 설정되었습니다.

이 문제를 해결하려면 다음을 수행합니다.

  • 지정된 보낸 사람이 지정된 받는 사람에게 다른 메시지를 전송하도록 합니다.

  • 메시지 추적 센터를 사용하도록 설정합니다.

  • 메시지 추적 로그 보존 기간을 늘리거나 최신 메시지를 추적합니다.

메시지 추적 센터를 사용하도록 설정하는 방법에 대한 자세한 내용은 Exchange Server 및 전송 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkID=67875)의 "메일 흐름 및 SMTP 문제 해결"에 있는 "서버에서 메시지 추적 센터 활성화 방법"(http://go.microsoft.com/fwlink/?LinkId=71257)을 참조하십시오.

메시지 추적 사용 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 262162, "XADM: Using the Message Tracking Center to Track a Message"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)를 참조하십시오.


지정한 받는 사람에게 전송된 메시지 없음
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-12-07

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에서 모든 사용자 개체의 proxyAddress 특성 값을 쿼리하여 사용자 지정 로컬 보낸 사람 SMTP(Simple Mail Transfer Protocol) 주소에 일치하는 항목이 있는지 확인합니다.

사용자 개체 proxyAddress에 일치하는 항목이 있으면 Exchange Server Analyzer는 Active Directory에서 해당 사용자 개체의 msExchHomeServerName 특성 값을 쿼리하여 이 값이 사용자 지정 Exchange Server 이름과 일치하는지 확인합니다.

Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스 아래에 있는 Exchange_MessageTrackingEntry Microsoft WMI(Windows® Management Instrumentation) 클래스의 SenderAddress 속성을 쿼리하여 메시지 추적 로그에서 사용자 지정 보낸 사람이 보낸 것으로 추적된 모든 메시지를 확인합니다.

마지막으로 Exchange Server Analyzer는 Exchange_MessageTrackingEntry WMI 클래스의 RecipientAddress 속성을 쿼리하여 메시지 추적 로그에서 사용자 지정 받는 사람에게 추적된 모든 메시지를 확인합니다.

사용자 지정 받는 사람의 SMTP 주소에 일치하는 RecipientAddress 속성 값을 가진 메시지 추적 로그 항목을 찾을 수 없는 경우 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 다음 조건 중 하나 이상에 해당함을 나타냅니다.

  • 사용자 지정 보낸 사람이 사용자 지정 받는 사람에게 메시지를 보내지 않았습니다.

  • 메시지 추적 로그 보존 기간이 경과하여 해당 로그 항목이 이미 삭제되었습니다.

이 문제를 해결하려면 다음을 수행하십시오.

  • 지정된 받는 사람 주소가 올바른지 확인합니다.

  • 지정된 보낸 사람이 지정된 받는 사람에게 다른 메시지를 전송하도록 합니다.

  • 메시지 추적 로그 보존 기간을 늘리거나 최신 메시지를 추적합니다.

메시지 추적 센터 로그 보존 기간을 늘리는 방법에 대한 자세한 내용은 "How to Enable Message Tracking Center on a Server"(http://go.microsoft.com/fwlink/?LinkID=71257)를 참조하십시오.

메시지 추적 사용 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 262162, "XADM: Using the Message Tracking Center to Track a Message"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)를 참조하십시오.


사용 가능한 큐 상태가 없습니다. SMTP 큐 분석을 중단합니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-03-15

Microsoft Exchange Analyzer Tool은 ExchangeLink Microsoft WMI(Windows Management Instrumentation) 클래스를 쿼리하여 Exchange 서버에 대해 SMTP(Simple Mail Transfer Protocol) 큐의 상태를 확인합니다.

SMTP는 Exchange Server의 메일 전송을 위한 기본 메일 프로토콜입니다. 그러므로 클라이언트에서는 SMTP를 사용하여 메시지를 보내고 Exchange 서버에서는 SMTP를 사용하여 메시지와 메시지 데이터를 배달합니다.

ExchangeLink WMI 클래스의 속성은 메일 서버 간의 메시지 처리 연결(큐)에 대한 정보를 반환합니다. 각 연결에 0개 이상의 ExchangeQueue 개체가 포함될 수 있습니다. 이 개수는 연결의 현재 메시지 트래픽에 따라 달라집니다.

SMTP는 SMTP 큐를 사용하여 메일을 내부 및 외부로 배달합니다. 메시지 분류 및 배달 중에는 고급 큐 엔진이 SMTP 가상 서버의 SMTP 큐를 통해 모든 메일을 보냅니다. 프로세스의 특정 지점에서 메시지를 배달하는 데 문제가 발생하면 메시지는 문제가 발생한 큐에 남아 있습니다.

SMTP 큐 설명

SMTP 큐 설명

[로컬 도메인 이름](로컬 배달)

Exchange 사서함 또는 공용 폴더 저장소로 로컬 배달하기 위해 Exchange 서버에 대기 중인 메시지가 포함됩니다.

디렉터리 조회 대기 중인 메시지

Microsoft Active Directory 디렉터리 서비스에 대해 아직 확인하지 않은 받는 사람에게 보낼 메시지가 포함됩니다. 메일 그룹이 확장되는 동안에도 메시지는 여기에 보관됩니다.

라우팅 대기 중인 메시지

메시지의 다음 대상 서버를 확인할 때까지 메시지를 보관했다가 해당 연결 큐로 옮깁니다.

원격 배달

[커넥터 이름|

서버 이름| 원격 도메인]

원격으로 배달할 메시지를 보관합니다. 큐의 이름은 원격 배달 대상(커넥터, 서버 또는 도메인)과 일치합니다.

최종 대상 위치에 현재 연결할 수 없음

해당 메시지의 최종 대상 서버에 연결할 수 없습니다. 예를 들어 Exchange가 최종 대상 위치에 대한 네트워크 경로를 확인할 수 없습니다.

전송 전

SMTP 서비스에서 확인 및 수락된 메시지가 보관됩니다. 이러한 메시지의 처리는 아직 시작되지 않은 상태입니다.

전송 보류 중인 DSN 메시지

배달 상태 알림을 포함하며, Exchange에서 배달할 준비가 된 배달 못 함 보고서(NDR)라고도 합니다.

참고 이 큐에서는 다음 작업을 수행할 수 없습니다.

  • 모든 메시지 삭제(NDR 없음)

  • 모든 메시지 삭제(NDR 있음)

실패한 메시지 다시 시도 큐

보통 다른 처리 작업이 수행되기 전에 일부 유형의 큐 전송에 실패한 메시지가 포함됩니다. 기본적으로 이 큐의 메시지는 60분 후에 다시 처리됩니다.

지연된 배달 대기 중인 메시지

이전 버전의 Outlook에서 보낸 메시지를 비롯하여 나중에 배달하도록 대기 중인 메시지가 포함됩니다. Outlook 클라이언트 컴퓨터에서 이 옵션을 설정할 수 있습니다.

이전 버전의 Outlook은 MTA(메시지 전송 에이전트)를 사용하여 메시지를 배달합니다. 그러나 현재는 MTA가 아닌 SMTP가 메시지 배달을 처리합니다. 그러므로 이전 버전의 Outlook에서 보낸 메시지는 지연된 배달을 다른 방식으로 처리합니다.

이러한 메시지는 예약된 배달 시간까지 이 큐에 남아 있습니다.

Exchange Analyzer는 서버의 ExchangeLink WMI 클래스에 대해 쿼리를 제대로 완료하지 못하면 오류를 표시합니다.

이 오류는 요청된 데이터를 WMI 쿼리에서 검색할 수 없음을 나타냅니다.

주로 다음과 같은 경우에 이 오류가 발생합니다.

  • Exchange Analyzer를 실행하는 계정에 WMI 클래스를 쿼리할 수 있는 사용 권한이 없는 경우

  • 네트워크 문제 때문에 Exchange Analyzer를 컴퓨터에 연결할 수 없는 경우

  • 원인을 알 수 없는 일시적인 문제로 인해 쿼리 시간 제한에 걸린 경우

이 오류를 해결하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. PING 명령을 사용하여 Exchange Server 컴퓨터에 연결할 수 있는지 확인합니다.

  3. 방화벽이 있으면 RPC(원격 프로시저 호출) 포트가 차단되어 있는지 확인합니다.

  4. Exchange Analyzer를 실행하는 계정에 대한 사용 권한을 검사합니다. Exchange Analyzer를 실행하는 계정에는 검색 중인 각 Exchange 서버에 대한 로컬 관리자 권한이 있어야 합니다.

    또는 Exchange Analyzer를 실행 중인 계정에 특정 WMI 사용 권한을 부여할 수 있습니다.

    1. Exchange 컴퓨터에서 컴퓨터 관리 MMC(Microsoft Management Console) 트리를 엽니다.

    2. 서비스 및 응용 프로그램에서 WMI 컨트롤을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

    3. WMI 컨트롤 속성 페이지에서 보안 탭을 클릭한 다음 루트를 확장합니다.

    4. CIMV2 폴더를 선택하고 보안을 클릭합니다.

    5. ROOT\CIMV2에 대한 보안 페이지에서 Exchange Analyzer를 실행하는 계정을 추가합니다.

  5. 위의 5단계에서 추가한 계정을 선택합니다. Selected_Account의 사용 권한에서 허용 열 아래의 원격으로부터 사용 가능 및 보안 읽기를 모두 선택한 다음 확인을 클릭합니다.

네트워크 연결 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

Exchange 모범 사례 분석 도구 연결 문제 해결에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?LinkId=56285)를 참조하십시오.

포트 요구 사항에 대한 자세한 내용은 기술 자료 문서 832017, "Windows 서버 시스템의 서비스 개요 및 네트워크 포트 요구 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)을 참조하십시오.


DNS 레코드 테스트에 사용할 수 있는 원격 서버 또는 도메인이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-07-06

Microsoft® Exchange Server Analyzer Tool은 원격 배달 큐에 있는 메일이 전송될 원격 서버의 FQDN(정규화된 도메인 이름), IP 주소 및 도메인 이름의 목록을 식별하고 만들려고 합니다.

원격 서버의 FQDN, IP 주소 및 도메인 이름의 목록은 다음과 같이 만들어 집니다.

  • SMTP(Simple Mail Transfer Protocol) 가상 서버의 Active Directory® 디렉터리 서비스 개체에 대한 msExchSmtpFullyQualifiedDomainName 속성을 쿼리합니다.

    참고:
    msExchSmtpFullyQualifiedDomainName 속성은 지정된 대상 브리지헤드 서버에 대해 쿼리될 때 라우팅 그룹 커넥터 디렉터리 개체의 msExchTargetBridgeheadServersDN 속성으로부터 차례로 읽힙니다.
  • SMTP 커넥터 Active Directory 개체의 msExchSmtpSmartHost 속성은 SMTP 커넥터의 지정된 스마트 호스트에 대해 쿼리됩니다.

  • ExchangeLink Microsoft WMI(Windows® Management Instrumentation) 클래스의 LinkName 속성은 모든 원격 서버 직접 연결에 대해 쿼리됩니다.

이 목록을 만들 항목이 없다고 결정되는 경우 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 다음을 나타냅니다.

  • 메일 흐름에 문제를 일으키는 네트워크 중단 또는 Active Directory 연결 문제가 있을 수 있습니다.

  • Exchange Server Analyzer를 실행하는 계정에 해당 정보를 쿼리할 수 있는 충분한 권한이 없을 수 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange 서버 컴퓨터가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. Active Directory 도메인 컨트롤러에 네트워크를 통해 연결되었는지 확인합니다.

  3. Exchange Server Analyzer에서 Active Directory 도메인 컨트롤러를 지정합니다.

  4. PING 명령을 사용하여 Exchange 서버 컴퓨터에 연결할 수 있는지 확인합니다.

  5. 방화벽이 있으면 RPC 포트가 차단되어 있는지 확인합니다.

  6. Exchange Server Analyzer를 실행하는 계정에 대한 사용 권한을 검토합니다. Exchange Server Analyzer를 실행하는 계정에는 검색 중인 각 Exchange 서버 컴퓨터에 대한 로컬 관리자 권한이 있어야 합니다.

네트워크 연결 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제 해결 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

Exchange Server Analyzer 연결 문제에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?LinkId=56285)를 참조하십시오.

포트 요구 사항에 대한 자세한 내용은 기술 자료 문서 832017, "Windows 서버 시스템의 서비스 개요 및 네트워크 포트 요구 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)을 참조하십시오.


SMTP 명령 테스트에 사용할 수 있는 서버가 없음
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-16

Microsoft® Exchange Server Analyzer Tool은 원격 배달 큐에 있는 메일이 전송될 원격 서버의 FQDN(정규화된 도메인 이름), IP 주소 및 도메인 이름의 목록을 식별하고 만들려고 합니다.

원격 서버의 FQDN, IP 주소 및 도메인 이름의 목록은 다음과 같이 만들어집니다.

  • SMTP(Simple Mail Transfer Protocol) 가상 서버의 Active Directory® 디렉터리 서비스 개체에 대한 msExchSmtpFullyQualifiedDomainName 속성을 쿼리합니다.

    참고:
    msExchSmtpFullyQualifiedDomainName 속성은 지정된 대상 브리지헤드 서버에 대해 쿼리될 때 라우팅 그룹 커넥터 디렉터리 개체의 msExchTargetBridgeheadServersDN 속성으로부터 차례로 읽힙니다.
  • SMTP 커넥터 Active Directory 개체의 msExchSmtpSmartHost 속성은 SMTP 커넥터의 지정된 스마트 호스트에 대해 쿼리됩니다.

  • ExchangeLink Microsoft WMI(Windows® Management Instrumentation) 클래스의 LinkName 속성은 모든 원격 서버 직접 연결에 대해 쿼리됩니다.

이 목록을 만들 항목이 없다고 결정되는 경우 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류의 의미는 다음과 같습니다.

  • 메일 흐름에 문제를 일으키는 네트워크 중단 또는 Active Directory 연결 문제가 있을 수 있습니다.

  • Exchange Server Analyzer를 실행하는 계정에 해당 정보를 쿼리할 수 있는 충분한 권한이 없을 수 있습니다.

이 오류를 해결하려면 다음을 수행하십시오.

  1. Exchange 서버를 실행 중인 서버가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. 네트워크를 통해 Active Directory 도메인 컨트롤러에 연결되었는지 확인합니다.

  3. Exchange Server Analyzer에서 Active Directory 도메인 컨트롤러를 지정합니다.

  4. PING 명령을 사용하여 Exchange 서버에 연결할 수 있는지 확인합니다.

  5. 방화벽이 있는 경우 RPC(원격 프로시저 호출) 포트가 차단되어 있는지 확인합니다.

  6. Exchange Server Analyzer를 실행하는 계정에 대한 사용 권한을 검토합니다. Exchange Server Analyzer를 실행하는 계정에는 검색 중인 각 Exchange Server 컴퓨터에 대한 로컬 관리자 권한이 있어야 합니다.

네트워크 연결 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

Exchange Server Analyzer 연결 문제에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=56285)을 참조하십시오.

포트 요구 사항에 대한 자세한 내용은 기술 자료 문서 832017, "Windows 서버 시스템의 서비스 개요 및 네트워크 포트 요구 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)을 참조하십시오.


연결 테스트에 사용할 수 있는 서버가 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-07-07

Microsoft® Exchange Server Analyzer Tool은 원격 배달 큐에 있는 메일이 전송될 원격 서버의 FQDN(정규화된 도메인 이름), IP 주소 및 도메인 이름의 목록을 식별하고 만들려고 합니다.

  • 원격 서버의 FQDN, IP 주소 및 도메인 이름의 목록은 다음과 같이 만들어집니다.

  • SMTP(Simple Mail Transfer Protocol) 가상 서버의 Active Directory® 디렉터리 서비스 개체에 대한 msExchSmtpFullyQualifiedDomainName 속성을 쿼리합니다.

    참고:
    그 결과 msExchSmtpFullyQualifiedDomainName 속성은 지정된 대상 브리지헤드 서버에 대해 쿼리될 때 라우팅 그룹 커넥터 디렉터리 개체의 msExchTargetBridgeheadServersDN 속성에서 읽힙니다.
  • SMTP 커넥터 Active Directory 개체의 msExchSmtpSmartHost 속성은 SMTP 커넥터의 지정된 스마트 호스트에 대해 쿼리됩니다.

  • ExchangeLink Microsoft Windows® WMI(Management Instrumentation) 클래스의 LinkName 속성은 모든 원격 서버 직접 연결에 대해 쿼리됩니다.

이 목록을 만들 항목이 없다고 결정되는 경우 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 다음을 나타냅니다.

  • 메일 흐름에 문제를 일으키는 네트워크 중단 또는 Active Directory 연결 문제가 있을 수 있습니다.

  • Exchange Server Analyzer를 실행하는 계정에 해당 정보를 쿼리할 수 있는 권한이 없을 수 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange 서버 컴퓨터가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. Active Directory 도메인 컨트롤러에 네트워크를 통해 연결되었는지 확인합니다.

  3. Exchange Server Analyzer에서 Active Directory 도메인 컨트롤러를 지정합니다.

  4. PING 명령을 사용하여 Exchange 서버 컴퓨터에 연결할 수 있는지 확인합니다.

  5. 방화벽이 있으면 RPC 포트가 차단되어 있는지 확인합니다.

  6. Exchange Server Analyzer를 실행하는 계정에 대한 사용 권한을 검토합니다. Exchange Server Analyzer를 실행하는 계정에는 검색 중인 각 Exchange 서버 컴퓨터에 대한 로컬 관리자 권한이 있어야 합니다.

네트워크 연결 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

Exchange Server Analyzer 연결 문제에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?LinkId=56285)를 참조하십시오.

포트 요구 사항에 대한 자세한 내용은 기술 자료 문서 832017, "Microsoft Windows 서버 시스템의 서비스 개요 및 네트워크 포트 요구 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)을 참조하십시오.


SMTP 인스턴스 이름 확인에 사용할 수 있는 서버가 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-07-07

Microsoft® Exchange Server Analyzer Tool은 원격 배달 큐에 있는 메일이 전송될 원격 서버의 FQDN(정규화된 도메인 이름), IP 주소 및 도메인 이름의 목록을 식별하고 만들려고 합니다.

원격 서버의 FQDN, IP 주소 및 도메인 이름의 목록은 다음과 같이 만들어 집니다.

  • SMTP(Simple Mail Transfer Protocol) 가상 서버의 Active Directory® 디렉터리 서비스 개체에 대한 msExchSmtpFullyQualifiedDomainName 속성을 쿼리합니다.

    참고:
    msExchSmtpFullyQualifiedDomainName 속성은 지정된 대상 브리지헤드 서버에 대해 쿼리될 때 라우팅 그룹 커넥터 디렉터리 개체의 msExchTargetBridgeheadServersDN 속성으로부터 차례로 읽힙니다.
  • SMTP 커넥터 Active Directory 개체의 msExchSmtpSmartHost 속성은 SMTP 커넥터의 지정된 스마트 호스트에 대해 쿼리됩니다.

  • ExchangeLink Microsoft WMI(Windows® Management Instrumentation) 클래스의 LinkName 속성은 모든 원격 서버 직접 연결에 대해 쿼리됩니다.

이 목록을 만들 항목이 없다고 결정되는 경우 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 다음을 나타냅니다.

  • 메일 흐름에 문제를 발생시키는 네트워크 중단 또는 Active Directory 연결 문제가 있을 수 있습니다.

  • Exchange Server Analyzer를 실행하는 계정에 해당 정보를 쿼리할 수 있는 충분한 권한이 없을 수 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange 서버 컴퓨터가 시작되었고 네트워크에 연결되어 있는지 확인합니다.

  2. Active Directory 도메인 컨트롤러에 네트워크를 통해 연결되었는지 확인합니다.

  3. Exchange Server Analyzer에서 Active Directory 도메인 컨트롤러를 지정합니다.

  4. PING 명령을 사용하여 Exchange 서버 컴퓨터에 연결할 수 있는지 확인합니다.

  5. 방화벽이 있으면 RPC 포트가 차단되어 있는지 확인합니다.

  6. Exchange Server Analyzer를 실행하는 계정에 대한 사용 권한을 검토합니다. Exchange Server Analyzer를 실행하는 계정에는 검색 중인 각 Exchange 서버 컴퓨터에 대한 로컬 관리자 권한이 있어야 합니다.

네트워크 연결 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제 해결 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

Exchange Server Analyzer 연결 문제에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting"(http://go.microsoft.com/fwlink/?LinkId=56285)를 참조하십시오.

포트 요구 사항에 대한 자세한 내용은 기술 자료 문서 832017, "Microsoft Windows Server System의 포트 요구 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)을 참조하십시오.


라우팅 서비스의 캐시 설정이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 라우팅 서비스의 캐시 기본 설정이 변경되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\

Exchange Server Analyzer는 ServerCacheRefreshInterval 레지스트리 값이 수동으로 생성되어 기본 Exchange Server 바이너리 설정인 900이 변경된 경우 경고를 표시합니다. 기본적으로 ServerCacheRefreshInterval 레지스트리 값은 Exchange Server 설치에 의해 만들어지지 않습니다. 하지만 Exchange Server를 설치한 후에 수동으로 ServerCacheRefreshInterval 레지스트리 값을 생성하여 라우팅 서비스의 기본 캐시 설정을 변경할 수 있습니다. 레지스트리 값을 수동으로 생성하고 해당 레지스트리 값을 잘못 구성한 경우 Exchange Server에서 메일 전송 문제가 발생할 수 있습니다.

ServerCacheRefreshInterval 레지스트리 값을 만들거나 수정할 때는 충분히 고려한 후에 만들거나 수정하는 것이 좋습니다. 대부분의 Exchange Server 환경에서 최적의 성능으로 사용할 수 있도록 Exchange Server 바이너리의 기본값을 신중하게 선택했습니다. 레지스트리를 수동으로 구성하여 Exchange Server의 기본 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다. 유용한 방법을 따르기 위해 ServerCacheRefreshInterval 레지스트리 값이 있는 경우 이 레지스트리 값을 삭제하여 Exchange Server를 라우팅 서비스 캐시의 기본 바이너리 설정으로 다시 구성할 수도 있습니다. 하지만 이러한 결정은 Exchange Server 사용자 지정 구성 설정이나 Exchange 환경에 따라야 합니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 그러나 레지스트리를 편집하여 레지스트리 값을 다시 기본 설정으로 변경할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하기 전에 문제가 발생할 경우 복원 방법을 알고 있어야 합니다. 자세한 방법은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 Regedit를 입력한 다음 확인을 클릭합니다.

  2. 콘솔 트리에서 HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\RESvc\Parameters\ 레지스트리 항목을 찾아 클릭합니다.

  3. 세부 정보 창에서 ServerCacheRefreshInterval 레지스트리 값을 마우스 오른쪽 단추로 클릭합니다. 값 데이터를 900으로 변경합니다.

  4. 세부 정보 창에서 ServerCacheRefreshInterval 레지스트리 값을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭할 수도 있습니다. 대화 상자에서 예를 클릭하여 레지스트리 값의 삭제를 확인합니다.

  5. Exchange 서버를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Microsoft Windows 레지스트리 편집에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 322755, "Windows 2000에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Windows XP 및 Windows Server 2003에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


SMTP LdapRequestTimeLimit 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 기본 LdapRequestTimeLimit가 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Exchange Server Analyzer는 LdapRequestTimeLimit 레지스트리 값이 수동으로 생성되어 기본 Exchange 서버 바이너리 설정인 600초가 변경된 경우 기본값이 아니라는 경고 메시지를 표시합니다. 기본적으로 LdapRequestTimeLimit 레지스트리 값은 Exchange Server 설치에 의해 만들어지지 않습니다. 하지만 단일 LDAP 요청이 큐에서 대기하는 최대 시간(초)을 변경하기 위해 Exchange Server를 설치한 후 수동으로 LdapRequestTimeLimit 레지스트리 값을 생성할 수 있습니다. 레지스트리 값을 수동으로 만들었는데 레지스트리 값에 대한 설정이 잘못 구성된 경우 Exchange 서버에 메시지 전송 문제가 발생할 수 있습니다.

LdapRequestTimeLimit 레지스트리 값을 만들거나 수정할 때는 충분히 고려한 후에 만들거나 수정하는 것이 좋습니다. 대부분의 Exchange 서버 환경에서 최적의 성능으로 사용할 수 있도록 Exchange 서버 바이너리의 기본값을 신중하게 선택했습니다. 레지스트리를 수동으로 구성하여 Exchange Server의 기본 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다. 유용한 방법을 따르기 위해 LdapRequestTimeLimit 레지스트리 값이 있는 경우 이 레지스트리 값을 삭제하여 Exchange 서버를 다시 기본 바이너리 설정으로 구성할 수도 있습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 그러나 레지스트리를 편집하여 레지스트리 값을 다시 기본 설정으로 변경할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하기 전에 문제가 발생할 경우 복원 방법을 알고 있어야 합니다. 자세한 방법은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 Regedit를 입력한 다음 확인을 클릭합니다.

  2. 콘솔 트리에서 HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters 레지스트리 항목을 찾아 클릭합니다.

  3. 세부 정보 창에서 LdapRequestTimeLimit 레지스트리 값을 마우스 오른쪽 단추로 클릭합니다. 값 데이터를 600으로 변경합니다.

  4. 세부 정보 창에서 LdapRequestTimeLimit 레지스트리 값을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭할 수도 있습니다. 대화 상자에서 예를 클릭하여 레지스트리 값의 삭제를 확인합니다.

  5. Exchange 서버를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Microsoft Windows 레지스트리 편집에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 322755, "Windows 2000에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Windows XP 및 Windows Server 2003에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


기본값이 아닌 SMTP LdapResultTimeout 레지스트리 값입니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 기본 LdapResultTimeout가 변경되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Exchange Server Analyzer는 LdapResultTimeout 레지스트리 키가 수동으로 만들어져 기본 Exchange 서버 바이너리 설정 121초가 변경되었음을 발견하면 기본 경고가 아니라는 메시지가 표시됩니다. 기본적으로 Exchange Server를 설치하면 LdapResultTimeout 레지스트리 키가 만들어지지 않습니다. 그러나 Exchange Server 설치 후에 LdapResultTimeout 레지스트리 키를 수동으로 만들어 시간 제한 값을 변경할 수 있습니다. LdapResultTimeout은 분류기의 LDAP 연결에 대한 LDAP 완료 스레드가 처리를 기다리는 최대 시간(초)입니다. 시간 제한이 만료되고 글로벌 카탈로그 서버에서 새 결과를 받지 못하면 지연된 검색은 LDAP_SERVER_DOWN과의 연결이 끊어집니다. 그러면 이 프로세스를 통해 해당 지연 검색을 새 연결로 실행할 수 있습니다. 레지스트리 값을 수동으로 만들었는데 레지스트리 값에 대한 설정이 잘못 구성된 경우 Exchange 서버에 메시지 전송 문제가 발생할 수 있습니다.

LdapResultTimeout 레지스트리 값을 만들거나 수정할 때는 충분히 고려한 후에 만들거나 수정하는 것이 좋습니다. 대부분의 Exchange Server 환경에서 최적의 성능으로 사용할 수 있도록 Exchange Server 바이너리의 기본값을 신중하게 선택했습니다. 레지스트리를 수동으로 구성하여 Exchange의 기본 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다. 유용한 방법을 따르기 위해 LdapResultTimeout 레지스트리 값이 있는 경우 이 레지스트리 값을 삭제하여 Exchange 서버를 다시 기본 바이너리 설정으로 구성할 수도 있습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 그러나 레지스트리를 편집하여 레지스트리 값을 다시 기본 설정으로 변경할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하기 전에 문제가 발생할 경우 복원 방법을 알고 있어야 합니다. 자세한 방법은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 Regedit를 입력한 다음 확인을 클릭합니다.

  2. 콘솔 트리에서 HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters 레지스트리 항목을 찾아 클릭합니다.

  3. 세부 정보 창에서 LdapResultTimeout 레지스트리 값을 마우스 오른쪽 단추로 클릭합니다. 값 데이터를 121으로 변경합니다.

  4. 세부 정보 창에서 LdapResultTimeout 레지스트리 값을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭할 수도 있습니다. 대화 상자에서 예를 클릭하여 레지스트리 값의 삭제를 확인합니다.

  5. Exchange 서버를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Microsoft Windows 레지스트리 편집에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 322755, "Windows 2000에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Windows XP 및 Windows Server 2003에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


SMTP MaxConnectionRetries 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 기본 MaxConnectionRetries가 변경되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Exchange Server Analyzer는 기본 Exchange 서버 바이너리 설정 20을 변경하여 MaxConnectionRetries 레지스트리 값이 수동으로 만들어진 경우 기본 경고가 아니라는 메시지가 표시됩니다. 기본적으로 MaxConnectionRetries 레지스트리 값은 Exchange Server 설치에 의해 만들어지지 않습니다. 그러나 Exchange Server를 설치한 후에 수동으로 MaxConnectionRetries 레지스트리 값을 생성하여 값을 변경할 수 있습니다. MaxConnectionRetries 값은 단일 분류에서 해당 LDAP 연결이 실패하여 새 연결을 다시 요청할 수 있는 최대 횟수를 설정합니다. MaxConnectionRetries번의 연결 분류가 실패하면 분류가 다시 시도 큐에 배치됩니다. 레지스트리 값을 수동으로 만들었는데 레지스트리 값에 대한 설정이 잘못 구성된 경우 Exchange 서버에 메시지 전송 문제가 발생할 수 있습니다.

MaxConnectionRetries 레지스트리 값을 만들거나 수정할 때는 충분히 고려한 후에 만들거나 수정하는 것이 좋습니다. 대부분의 Exchange Server 환경에서 최적의 성능으로 사용할 수 있도록 Exchange Server 바이너리의 기본값을 신중하게 선택했습니다. 레지스트리를 수동으로 구성하여 Exchange Server의 기본 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다. 유용한 방법을 따르기 위해 MaxConnectionRetries 레지스트리 값이 있는 경우 이 레지스트리 값을 삭제하여 Exchange 서버를 다시 기본 바이너리 설정으로 구성할 수도 있습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 그러나 레지스트리를 편집하여 레지스트리 값을 다시 기본 설정으로 변경할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하기 전에 문제가 발생할 경우 복원 방법을 알고 있어야 합니다. 자세한 방법은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 Regedit를 입력한 다음 확인을 클릭합니다.

  2. 콘솔 트리에서 HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters 레지스트리 항목을 찾아 클릭합니다.

  3. 세부 정보 창에서 MaxConnectionRetries 레지스트리 값을 마우스 오른쪽 단추로 클릭합니다. 값을 20으로 변경합니다.

  4. 세부 정보 창에서 MaxConnectionRetries 레지스트리 값을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭할 수도 있습니다. 대화 상자에서 예를 클릭하여 레지스트리 값의 삭제를 확인합니다.

  5. Exchange Server를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Microsoft Windows 레지스트리 편집에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 322755, "Windows 2000에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Windows XP 및 Windows Server 2003에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


SMTP MaxLdapConnections 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 기본 MaxLdapConnections가 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Exchange Server Analyzer는 기본 Exchange 서버 바이너리 설정 8을 변경하여 MaxLdapConnections 레지스트리 값이 수동으로 만들어진 경우 기본 경고가 아니라는 메시지가 표시됩니다. 기본적으로 MaxLdapConnections 레지스트리 값은 Exchange 설치에 의해 만들어지지 않습니다. 하지만 Exchange 설치에서 값을 변경한 후 수동으로 MaxLdapConnections 레지스트리 값을 생성할 수 있습니다. MaxLdapConnections 값은 분류기가 단일 글로벌 카탈로그 서버로 열 수 있는 LDAP 연결의 최대 수를 설정합니다. 레지스트리 값을 수동으로 만들었는데 레지스트리 값에 대한 설정이 잘못 구성된 경우 Exchange 서버에 메시지 전송 문제가 발생할 수 있습니다.

주의:
항상 MaxLdapConnections 레지스트리 값은 HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPoolThreads 레지스트리 값 설정과 일치해야 합니다.

MaxLdapConnections 레지스트리 값을 만들거나 수정할 때는 충분히 고려한 후에 만들거나 수정하는 것이 좋습니다. 대부분의 Exchange 서버 환경에서 최적의 성능으로 사용할 수 있도록 Exchange 서버 바이너리의 기본값을 신중하게 선택했습니다. 레지스트리를 수동으로 구성하여 Exchange Server의 기본 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다. 유용한 방법을 따르기 위해 MaxLdapConnections 레지스트리 값이 있는 경우 이 레지스트리 값을 삭제하여 Exchange 서버를 다시 기본 바이너리 설정으로 구성할 수도 있습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 그러나 레지스트리를 편집하여 레지스트리 값을 다시 기본 설정으로 변경할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하기 전에 문제가 발생할 경우 복원 방법을 알고 있어야 합니다. 자세한 방법은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 Regedit를 입력한 다음 확인을 클릭합니다.

  2. 콘솔 트리에서 HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters 레지스트리 항목을 찾아 클릭합니다.

  3. 세부 정보 창에서 MaxLdapConnections 레지스트리 값을 마우스 오른쪽 단추로 클릭합니다. 값 데이터를 8으로 변경합니다.

  4. 세부 정보 창에서 MaxLdapConnections 레지스트리 값을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭할 수도 있습니다. 대화 상자에서 예를 클릭하여 레지스트리 값의 삭제를 확인합니다.

  5. Exchange 서버를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Microsoft Windows 레지스트리 편집에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 322755, "Windows 2000에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Windows XP 및 Windows Server 2003에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


SMTP MaxPendingSearches 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 기본 MaxPendingSearches가 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Exchange Server Analyzer는 기본 Exchange 서버 바이너리 설정 60을 변경하여 MaxPendingSearches 레지스트리 값이 수동으로 만들어진 경우 기본 경고가 아니라는 메시지가 표시됩니다. 기본적으로 MaxPendingSearches 레지스트리 값은 Exchange Server 설치에 의해 만들어지지 않습니다. 하지만 Exchange Server 설치에서 수동으로 MaxPendingSearches 레지스트리 값을 생성하여 값을 변경할 수 있습니다. MaxPendingSearches 값은 분류기에서 특정 글로벌 카탈로그 서버에 대해 한 번에 유지할 수 있는 대기 중인 LDAP 검색의 수를 설정합니다. SP3 이전의 Exchange 2000 Server에서는 연결당 대기 중인 검색의 최대 수가 1024입니다. Exchange 2000 Server SP3 및 Exchange Server 2003의 기본값은 60으로 설정됩니다. 예를 들어 이 값을 기본값인 60에서 30으로 변경하면 분류기가 글로벌 카탈로그 서버에 대해 유지할 수 있는 LDAP 검색의 총 수가 줄어듭니다.

레지스트리 값을 수동으로 만들었는데 레지스트리 값에 대한 설정이 잘못 구성된 경우 Exchange 서버에 메시지 전송 문제가 발생할 수 있습니다.

MaxPendingSearches 레지스트리 값을 만들거나 수정할 때는 충분히 고려한 후에 만들거나 수정하는 것이 좋습니다. 대부분의 Exchange 서버 환경에서 최적의 성능으로 사용할 수 있도록 Exchange 서버 바이너리의 기본값을 신중하게 선택했습니다. 레지스트리를 수동으로 구성하여 Exchange의 기본 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다. 유용한 방법을 따르기 위해 MaxPendingSearches 레지스트리 값이 있는 경우 이 레지스트리 값을 삭제하여 Exchange 서버를 다시 기본 바이너리 설정으로 구성할 수도 있습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 그러나 레지스트리를 편집하여 레지스트리 값을 다시 기본 설정으로 변경할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하기 전에 문제가 발생할 경우 복원 방법을 알고 있어야 합니다. 자세한 방법은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 Regedit를 입력한 다음 확인을 클릭합니다.

  2. 콘솔 트리에서 HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters 레지스트리 항목을 찾아 클릭합니다.

  3. 세부 정보 창에서 MaxPendingSearches 레지스트리 값을 마우스 오른쪽 단추로 클릭합니다. 값 데이터를 60으로 변경합니다.

  4. 세부 정보 창에서 MaxPendingSearches 레지스트리 값을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭할 수도 있습니다. 대화 상자에서 예를 클릭하여 레지스트리 값의 삭제를 확인합니다.

  5. Exchange 서버를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Microsoft Windows 레지스트리 편집에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

?322755, "Windows 2000에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

?322756, "Windows XP 및 Windows Server 2003에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


SMTP MaxSearchBlockSize 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 기본 MaxSearchBlockSize가 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Exchange Server Analyzer는 기본 Exchange 서버 바이너리 설정 20을 변경하여 MaxSearchBlockSize 레지스트리 값이 수동으로 만들어진 경우 기본 경고가 아니라는 메시지가 표시됩니다. 기본적으로 MaxSearchBlockSize 레지스트리 값은 Exchange Server 설치에 의해 만들어지지 않습니다. 하지만 Exchange Server 설치에서 값을 변경한 후 수동으로 MaxSearchBlockSize 레지스트리 값을 생성할 수 있습니다. MhelpsBlockSize 값은 한 번의 LDAP 검색으로 함께 전송할 수 있는 분류기 검색의 최대 수를 설정합니다. 분류기 검색의 최대 수를 설정하면 분류기의 검색 필터를 단순화할 수 있습니다.

이 프로세스를 사용하면 보류 중인 검색을 새 연결로 다시 실행할 수 있습니다. 레지스트리 값을 수동으로 만들었는데 레지스트리 값에 대한 설정이 잘못 구성된 경우 Exchange 서버에 메시지 전송 문제가 발생할 수 있습니다.

MaxSearchBlockSize 레지스트리 값을 만들거나 수정할 때는 충분히 고려한 후에 만들거나 수정하는 것이 좋습니다. 대부분의 Exchange 서버 환경에서 최적의 성능으로 사용할 수 있도록 Exchange Server 바이너리의 기본값을 신중하게 선택했습니다. 레지스트리를 수동으로 구성하여 Exchange Server의 기본 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다. 유용한 방법을 따르기 위해 MaxSearchBlockSize 레지스트리 값이 있는 경우 이 레지스트리 값을 삭제하여 Exchange 서버를 다시 기본 바이너리 설정으로 구성할 수도 있습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 그러나 레지스트리를 편집하여 레지스트리 값을 다시 기본 설정으로 변경할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하기 전에 문제가 발생할 경우 복원 방법을 알고 있어야 합니다. 자세한 방법은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 Regedit를 입력한 다음 확인을 클릭합니다.

  2. 콘솔 트리에서 HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters 레지스트리 항목을 찾아 클릭합니다.

  3. 세부 정보 창에서 MaxSearchBlockSize 레지스트리 값을 마우스 오른쪽 단추로 클릭합니다. 값 데이터를 20으로 변경합니다.

  4. 세부 정보 창에서 MaxSearchBlockSize 레지스트리 값을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭할 수도 있습니다. 대화 상자에서 예를 클릭하여 레지스트리 값의 삭제를 확인합니다.

  5. Exchange 서버를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Microsoft Windows 레지스트리 편집에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 322755, "Windows 2000에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Windows XP 및 Windows Server 2003에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


기본값이 아닌 SMTP TopoRecheckSecs 레지스트리 값
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 레지스트리 값이 기본값에서 변경되었는지 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\TopoRecheckSecs.

Exchange Server Analyzer는 TopoRecheckSecs 값이 기본값인 900초가 아닌 경우 기본 구성이 아니라는 메시지를 표시합니다. Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다. DSAccess가 글로벌 카탈로그 목록을 다시 작성하는 간격을 설정할 때 TopoRecheckSecs 레지스트리 값을 사용하기 때문에 부정확한 설정으로 인해 성능이 저하될 수 있습니다. 가능한 경우 Exchange Server에 대해 기본 구성 설정을 사용하는 것이 좋습니다. 그러나 이러한 레지스트리 값이 있다면 이전에 발생했던 문제를 해결하기 위해 Microsoft 기술 지원 서비스의 권장 사항에 추가되었거나 구성된 것일 수 있습니다. Microsoft PSS 권장 사항 또는 기타 전문가 지침에 추가되었거나 구성된 경우가 아니라면 이 레지스트리 값을 제거해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
TopoRecheckSecs 레지스트리 키를 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess를 탐색합니다.

  3. 오른쪽 창에서 TopoRecheckSecs 값을 찾아 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 이러한 변경 내용을 영구적으로 적용하려면 시스템 수행자를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server의 글로벌 카탈로그 배치를 최적화하는 방법에 대한 자세한 내용은 Understanding and Troubleshooting Directory Access(http://go.microsoft.com/fwlink/?LinkId=39012)를 참조하십시오.


Exchange가 아닌 게이트웨이 서버가 스마트 호스트로 설정되지 않음
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-09

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에서 protocolCfgSMTPServer 개체 클래스의 distingushedName 특성 값을 쿼리하여 사용자 지정 Exchange 게이트웨이의 모든 SMTP(Simple Mail Transfer Protocol) 가상 서버 인스턴스를 나열합니다.

그런 다음 Exchange Server Analyzer는 Active Directory에서 검색된 각 msExchRoutingSMTPConnector 개체의 msExchSourceBridgeheadServersDN 및 routingList 특성 값을 쿼리하여 검색된 SMTP 가상 서버 인스턴스 중 하나가 올바르게 SMTP 커넥터의 외부 SMTP 주소 공간에 대한 로컬 브리지헤드로 설정되어 있는지 확인합니다.

마지막으로 Exchange Server Analyzer는 Active Directory에서 검색된 모든 SMTP 커넥터(msExchRoutingSMTPConnector 개체)의 msExchSmtpSmartHost 특성 값을 쿼리하여 이러한 커넥터 중 하나가 Exchange가 아닌 사용자 지정 게이트웨이 서버의 스마트 호스트로 지정되었는지 확인합니다.

Exchange가 아닌 사용자 지정 게이트웨이 서버가 SMTP 커넥터 중 하나의 스마트 호스트로 설정되지 않은 경우 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 사용자 지정 Exchange 게이트웨이 서버와 Exchange가 아닌 사용자 지정 게이트웨이 서버 간에 명시적 경로가 설정되어 있지 않으며 Exchange가 아닌 게이트웨이 이외의 서버에서 실수로 메시지를 조직 외부로 라우팅할 수 있음을 나타냅니다.

이 문제를 해결하려면 Exchange가 아닌 게이트웨이 서버를 SMTP 커넥터의 스마트 호스트로 지정합니다.

스마트 호스트 설정을 보고 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange Server, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  4. 배달 탭을 선택하고 고급을 클릭합니다.

  5. 사용할 스마트 호스트를 입력합니다. 정규화된 도메인 이름(FQDN) 또는 IP 주소로 스마트 호스트를 식별할 수 있습니다. IP 주소를 사용할 경우 대괄호([ ])로 묶어야 합니다. Exchange는 먼저 서버 이름을 확인한 후 IP 주소를 확인합니다. 대괄호로 묶여 있으면 해당 값이 IP 주소로 인식되므로 DNS 조회는 수행되지 않습니다.

  6. Exchange 2000 Server를 실행하는 서버일 경우 선택적으로 스마트 호스트에 보내기 전에 직접 배달 시도 확인란을 선택합니다.

  7. 확인을 클릭하여 변경 내용을 저장한 다음 확인을 클릭하여 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

스마트 호스트 커넥터를 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 821911, "How to Configure Exchange Server 2003 to Use a Smart Host IP Address"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821911)를 참조하십시오.

SMTP 커넥터 사용 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 294736, "When to create SMTP connectors in Exchange 2000 and later versions"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736)를 참조하십시오.

SMTP 커넥터에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)를 참조하십시오.


가능한 분류기 오버로드
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 SMTP Server 성능 개체의 Cat: Messages submitted/sec 및 Cat: Categorizations completed/sec 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Cat: Messages submitted/sec 성능 카운터는 분류기로 초당 전송된 메시지 수를 표시하고 Cat: Categorizations completed/sec 성능 카운터는 초당 완료된 분류 속도를 표시합니다.

Exchange Server Analyzer는 두 카운터의 평균 합계를 비교하여 처리된 것보다 많은 메시지가 지속적으로 전송되었는지 확인합니다.

분류기로 초당 전송된 메시지 수의 평균 합계가 초당 완료된 메시지 수의 평균 합계보다 메시지 두 개만큼 지속적으로 크면 Exchange Server Analyzer에서 경고를 표시합니다.

분류기가 수행하는 핵심 작업은 다음과 같습니다.

  • 모든 받는 사람을 확인하고 유효성을 검사합니다.

  • 모든 받는 사람의 한계와 제한을 확인합니다.

  • 필요한 경우 메일 그룹을 확장합니다.

  • 메시지를 로컬 배달할지 아니면 원격 배달할지 확인합니다.

이 경고는 분류기가 스트레스 상태에 있을 수 있음을 나타냅니다. 가능한 원인을 검사하고 필요한 경우 수정할 수 있습니다.

분류기 스트레스는 다음으로 인해 많은 메시지를 처리해야 하기 때문일 수 있습니다.

  • UCE(원치 않는 상업성 전자 메일 메시지) 또는 스팸

  • 바이러스 확산

  • 서버 성능 문제

이 경고를 해결하려면 다음을 수행합니다.

  • 분류기 스트레스가 예상된 로드에서 비롯된 것인지 일반 로드에서 비롯된 것인지 확인합니다. 분류기 스트레스가 예상된 로드에서 비롯된 경우 다음 Microsoft TechNet 문서에서 Exchange 성능 관련 내용을 검토하십시오.

    • "Troubleshooting Exchange Server 2003 Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)

    • "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)

  • 분류기 스트레스가 예상된 로드에서 비롯된 경우가 아니면 로드를 생성했을 수 있는 바이러스 확산이나 스팸을 확인합니다.


가능한 게이트웨이 문제
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-09

Microsoft® Exchange Server Analyzer Tool은 Exchange Server를 실행하는 서버에서 사용자 정의 외부 계정으로 테스트 메시지를 보냅니다. 그런 다음 Exchange Server Analyzer는 서버의 메시지 추적 로그를 검색하여 테스트 메시지를 배달하는 동안 문제가 발생했는지 확인합니다.

이 검색 과정에서 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스 아래에 있는 Exchange_MessageTrackingEntry Microsoft WMI(Windows® Management Instrumentation) 클래스의 EntryType 속성을 쿼리하여 하나 이상의 메시지 추적 로그 항목이 생성된 원인을 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • 메시지 추적 로그를 성공적으로 검색할 수 있습니다.

  • 테스트 메시지가 큐에서 성공적으로 전송되지 않았습니다.

  • 배달 실패 보고서(NDR)가 생성되지 않았습니다.

  • EntryType 속성에 대해 1034 값이 있습니다.

  • 메시지가 지정된 로컬 Exchange 아웃바운드 게이트웨이 서버에 도달했습니다.

이 오류는 사용자 지정 로컬 Exchange 아웃바운드 게이트웨이 서버와 원격 서버 간에 연결 문제가 있음을 나타냅니다.

이 문제를 해결하려면 NSlookup 유틸리티를 사용하여 DNS(Domain Name System) 확인과 관련하여 발생할 수 있는 문제를 검토하십시오. 호스트에 도달할 수 없음 오류와 같은 연결 및 프로토콜 문제의 경우에는 Telnet.exe를 사용하여 대상 컴퓨터에 연결해 보십시오. 프로토콜 오류를 해결하려면 SMTP(Simple Mail Transfer Protocol) 구성 요소에 대한 MSExchangeTransport 서비스의 진단 로깅을 증가시키고 오류 로그를 검토하십시오. 네트워크 모니터(Netmon.exe) 도구를 사용하여 네트워크 연결 오류에 대한 정보를 얻을 수도 있습니다.

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


가능한 Inetinfo 문제
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터에서 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 들어 있습니다. 성능 데이터 수집 엔진은 SMTP Server 성능 개체의 Cat: Categorizations in progress 성능 카운터에서 데이터를 수집하여 성능 데이터를 분석합니다.

Cat: Categorizations in progress 성능 카운터는 진행 중인 분류 수를 표시합니다.

이 쿼리에 대해 Exchange Server Analyzer는 2분 동안 6초마다 샘플을 검색합니다. Exchange Server Analyzer는 수집 기간 중 성능 카운터의 평균 값을 보고합니다.

샘플 기간 동안 진행 중인 최소 분류 수가 결코 0과 같지 않은 경우 Exchange Server Analyzer에서 경고를 표시합니다.

분류기가 수행하는 핵심 작업은 다음과 같습니다.

  • 모든 받는 사람을 확인하고 유효성을 검사합니다.

  • 모든 받는 사람의 한계와 제한을 확인합니다.

  • 필요한 경우 메일 그룹을 확장합니다.

  • 메시지를 로컬 배달할지 아니면 원격 배달할지 확인합니다.

서버 작업량이 많지 않은 경우 이 경고는 Inetinfo.exe 프로세스 또는 Inetinfo.exe 프로세스에서 사용하는 리소스가 교착 상태에 있음을 나타낼 수 있습니다.

SMTP(Simple Mail Transfer Protoco) 서비스는 이 Inetinfo.exe 프로세스에서 실행되며, 메시지가 전송 하위 시스템을 통과할 때 SMTP에서 IIS(인터넷 정보 서비스) 리소스를 많이 사용합니다.

교착 상태는 두 개 이상의 프로세스(또는 스레드)가 있으며 각각 다른 프로세스가 완료되어야만 프로세스를 계속할 수 있는 경우에 발생합니다. 결과적으로 모든 프로세스(또는 스레드) 응답이 중지됩니다(중단). 교착 상태의 프로세스는 실행 완료되지 않으며 시스템 자원이 사용됩니다. 따라서 다른 작업을 시작할 수 없습니다.

이 경고를 해결하려면 다음을 수행합니다.

  • 분류기 스트레스가 예상된 로드에서 비롯된 것인지 일반 로드에서 비롯된 것인지 확인합니다. 분류기 작업량이 많지 않은 경우 "추가 정보" 섹션에서 참조하는 리소스를 사용하여 Inetinfo.exe 프로세스 또는 관련 리소스에 성능 문제가 있는지 확인합니다.

  • Inetinfo.exe 프로세스가 실행되고 있는지 확인합니다.

  • Microsoft 기술 자료 문서 919791 "How to use the Debug Diagnostics Tool to troubleshoot high CPU usage by a process in IIS"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791)의 디버그 관련 지시에 따라 Inetinfo.exe 교착 상태를 확인합니다.

자세한 정보

Inetinfo.exe에 대한 자세한 내용은 Exchange Server 2003 기술 참조 가이드(http://go.microsoft.com/fwlink/?LinkId=58876)의 "인터넷 정보 서비스"를 참조하십시오.

교착 상태 프로세스 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료 문서 919791 "How to use the Debug Diagnostics Tool to troubleshoot high CPU usage by a process in IIS"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791)를 참조하십시오.

Exchange 서버 성능에 대한 자세한 내용은 "Exchange Server 2003 성능 및 확장성 가이드"(http://go.microsoft.com/fwlink/?LinkId=47576)를 참조하십시오.

Exchange 서버 성능 문제 해결에 대한 자세한 내용은 "Troubleshooting Microsoft Exchange Server Performance"(http://go.microsoft.com/fwlink/?LinkId=47588)를 참조하십시오.


가능한 게이트웨이 이외의 문제
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-09

Microsoft® Exchange Server Analyzer Tool은 Exchange Server를 실행하는 서버에서 사용자 정의 외부 받는 사람 SMTP 주소로 테스트 메시지를 보냅니다. 그런 다음 Exchange Server Analyzer는 서버의 메시지 추적 로그를 검색하여 테스트 메시지를 배달하는 동안 문제가 발생했는지 확인합니다.

이 검색 과정에서 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스 아래에 있는 Exchange_MessageTrackingEntry Microsoft WMI(Windows® Management Instrumentation) 클래스의 EntryType 속성을 쿼리하여 하나 이상의 메시지 추적 로그 항목이 생성된 원인을 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • 메시지 추적 로그를 성공적으로 검색할 수 있습니다.

  • 테스트 메시지가 큐에서 성공적으로 전송되지 않았습니다.

  • 배달 실패 보고서(NDR)가 생성되지 않았습니다.

  • EntryType 속성에 대해 1034 값이 있습니다.

  • 메시지가 지정된 로컬 Exchange 아웃바운드 게이트웨이 서버에 도달하지 않았습니다.

이 오류는 보내는 서버에 대한 SMTP(Simple Mail Transfer Protocol) 원격 배달 큐 중 하나에 아직 테스트 메시지가 있고 큐와 관련된 문제가 있음을 나타낼 수 있습니다.

원격 배달 큐에는 원격 배달할 메시지가 들어 있습니다. 큐 이름은 원격 배달 대상과 일치합니다. 이 대상은 커넥터, 서버 또는 도메인일 수 있습니다.

프로토콜 오류를 해결하려면 SMTP 구성 요소에 대한 MSExchangeTransport 서비스의 진단 로깅을 증가시키고 오류 로그를 검토하십시오. 네트워크 모니터(Netmon.exe) 도구를 사용하여 네트워크 연결 오류에 대한 정보를 얻을 수도 있습니다. 문제를 재현하기 위해 큐를 강제로 다시 실행해야 할 수도 있습니다. 이벤트 로그를 검사하여 Microsoft Exchange Information Store 서비스에 관련된 오류가 있는지 확인하십시오.

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


가능한 SMTP 프록시가 검색됨
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-12-06

Microsoft® Exchange Server Analyzer Tool은 SMTP(Simple Mail Transfer Protocol) 도메인에 대한 사용자 정의 계정 또는 전자 메일 관리자 계정에 메시지를 보내려고 시도합니다.

다음은 Exchange Server Analyzer가 SMTP 서버에 대한 소켓 연결을 열 때 예상되는 기본 응답입니다.

"220 Computer Name . Domain Name .com Microsoft ESMTP MAIL Service, Version: Version Number ready at Date Time +0000"

기본 응답이 아닌 타사별 문자열이 포함된 응답을 받으면 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 원격 서버가 타사 SMTP 프록시 서버를 통해 연결되어 있음을 나타냅니다.

Exchange Server 관리자가 기본 SMTP 배너를 의도적으로 사용자 지정하지 않은 경우, 이 경고는 Exchange Server가 ESMTP(Exchange Server Extended Simple Mail Transfer Protocol) 명령을 필터링하는 SMTP 프록시를 통해 연결되어 있음을 나타낼 수 있습니다.

Exchange Server ESMTP 명령이 필터링된 경우, Exchange 성능에 크게 영향을 줄 수 있으며 Microsoft 기술 자료 문서 320027, "XCON: Cisco PIX 방화벽 뒤에서 전자 메일 메시지를 보내거나 받을 수 없다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027)에 설명되어 있는 동작을 유발할 수 있습니다.

사용자 지정된 SMTP 배너에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 281224: XCON: SMTP 배너를 수정하는 방법(http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224)


잠재적 분류기 성능 문제
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink Microsoft WMI(Windows® Management Instrumentation) 클래스에서 SMTP(Simple Mail Transfer Protocol) ProtocolName 인스턴스의 TypePendingCategorization 특성 값을 쿼리하여 MADL(디렉터리 조회 대기 중인 메시지) SMTP 큐의 메시지 수를 확인합니다.

ExchangeLink WMI 클래스의 속성은 메일 서버 간의 메시지 처리 연결(큐)에 대한 정보를 반환합니다. 각 연결에 0개 이상의 ExchangeQueue 개체가 포함될 수 있습니다. 이 개수는 연결의 현재 메시지 트래픽에 따라 달라집니다.

또한 Exchange Server Analyzer Tool에는 Exchange 2000 Server 또는 Exchange Server 2003을 실행하는 컴퓨터의 성능 카운터 개체를 쿼리하는 데 사용하는 성능 데이터 수집 엔진이 포함되어 있습니다.

현재 MADL 큐에 있는 메시지 수가 50개보다 많은 경우 Exchange Server Analyzer는 성능 데이터 수집 엔진이 SMTP Server 성능 개체의 Cat: Messages Categorized 및 Cat: Categorizations completed 성능 카운터에서 데이터를 수집하도록 하여 성능 데이터를 분석합니다.

Cat: Messages Categorized 성능 카운터는 분류기가 전송하여 큐에서 대기 중인 메시지 수를 표시하고 Cat: Categorizations completed 성능 카운터는 분류기로 전송된 완료된 총 메시지 수를 표시합니다.

분류기가 수행하는 핵심 작업은 다음과 같습니다.

  • 모든 받는 사람을 확인하고 유효성을 검사합니다.

  • 모든 받는 사람의 한계와 제한을 확인합니다.

  • 필요한 경우 메일 그룹을 확장합니다.

  • 메시지를 로컬 배달할지 아니면 원격 배달할지 확인합니다.

Exchange Server Analyzer는 두 카운터의 평균 합계를 검사하여 샘플 기간 동안 숫자가 증가했는지 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • MADL 큐에 있는 메시지 수가 50 이상입니다.

  • Cat: Messages Categorized 성능 카운터가 샘플 기간 동안 증가되어 전송된 메시지의 다음 프로세스로 전달이 진행되었음을 나타냅니다.

  • Cat: Categorizations completed 성능 카운터가 샘플 기간 동안 증가되어 전송된 메시지의 분류 완료가 진행되었음을 나타냅니다.

이 오류는 분류기에서 메시지를 성공적으로 처리하지만 큐 길이가 여전히 길어서 성능이 느려질 수 있음을 나타냅니다.

분류기 성능 저하는 다음으로 인해 많은 메시지를 처리해야 하기 때문일 수 있습니다.

  • UCE(원치 않는 상업성 전자 메일 메시지) 또는 스팸

  • 바이러스 확산

  • 서버 성능 문제

이 경고를 해결하려면 다음을 수행합니다.

  • 분류기 스트레스가 예상된 로드에서 비롯된 것인지 일반 로드에서 비롯된 것인지 확인합니다. 분류기 스트레스가 예상된 로드에서 비롯된 경우 다음 Exchange 리소스에서 Exchange 성능 관련 내용을 검토하십시오.

    • Troubleshooting Exchange Server 2003 Performance(http://go.microsoft.com/fwlink/?LinkId=47588)

    • Exchange Server 2003 성능 및 확장성 가이드(http://go.microsoft.com/fwlink/?LinkId=47576)

  • 분류기 스트레스가 예상된 로드에서 비롯된 경우가 아니면 로드를 생성했을 수 있는 바이러스 확산이나 스팸을 확인합니다.


메일 그룹 확장 문제가 발생할 가능성이 발견되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange 서버가 Exchange Server 2003 서비스 팩 2(SP2)를 실행하고 있고 배달 제한을 확인할 때 메일 그룹이 확장되도록 구성되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

  • 이 항목 값이 1이면 서버가 배달 제한을 확인할 때 메일 그룹이 확장되도록 구성되어 있음을 의미합니다.

  • 이 항목 값이 2이면 서버가 배달 제한을 확인할 때 메일 그룹이 확장되지 않도록 구성되어 있음을 의미합니다.

Exchange Server Analyzer는 서버가 배달 제한을 확인할 때 메일 그룹이 확장되도록 설정되어 있으면 서버 이벤트 로그를 확인하여 오류 이벤트 6004, 6006 및 6008이 모두 지난 24시간 내에 발생되었는지 여부를 확인합니다.

이 이벤트는 메시지 분류기에서 메시지가 트랩되고 있음을 나타냅니다. 메시지 분류기는 LDAP(Lightweight Directory Access Protocol) 쿼리를 글로벌 카탈로그 서버로 보내 디렉터리 조회를 수행하는 고급 큐 엔진의 구성 요소입니다.

마지막으로 Exchange Server Analyzer는 Active Directory® 디렉터리 서비스를 쿼리하여 다음 내용을 확인합니다.

  • 최소한 하나 이상의 메일 그룹이 보낸 사람을 허용하거나 금지하는 데 사용될 수 있도록 포리스트에 배달 제한이 설정된 사서함이 500개 이상 있는지 여부

  • 라우팅 그룹 커넥터에 메일 그룹 구성원 자격을 기반으로 한 배달 제한이 있는지와 브리지헤드 서버에서 커넥터 제한 검사 기능을 사용할 수 있는지 여부

  • SMTP 커넥터에 메일 그룹 구성원 자격을 기반으로 한 배달 제한이 있는지와 브리지헤드 서버에서 커넥터 제한 검사 기능을 사용할 수 있는지 여부

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • Exchange Server 2003 SP2 서버가 배달 제한을 확인할 때 메일 그룹이 확장되도록 구성되어 있는 경우

  • Exchange 서버가 지난 24시간 내에 6004, 6006, 및 6008 이벤트를 기록한 경우

  • 최소한 하나 이상의 메일 그룹이 보낸 사람을 허용하거나 금지하는 데 사용될 수 있도록 포리스트에 배달 제한이 설정된 사서함이 500개 이상 있는 경우 또는 라우팅 그룹 커넥터에 메일 그룹 구성원 자격을 기반으로 한 배달 제한이 있고 브리지헤드 서버에서 커넥터 제한 검사 기능을 사용할 수 있는 경우 또는 SMTP 커넥터에 메일 그룹 구성원 자격을 기반으로 한 배달 제한이 있고 브리지헤드 서버에서 커넥터 제한 검사 기능을 사용할 수 있는 경우

RestrictionMethod 값은 분류기가 제한을 처리하는 방법을 결정합니다. 분류기의 기본 동작은 메일 그룹을 재귀적으로 확장하고 시스템을 통과하는 각 메시지에 대한 제한을 검사합니다. 특정 메일 그룹이나 보안 그룹의 구성원이 보내는 메시지는 거부하는 제한을 가지도록 구성된 받는 사람에게 전자 메일 메시지를 보내는 경우, Exchange 서버는 해당 그룹을 확장하여 보낸 사람이 거부되는 그룹의 구성원이 아닌지 확인해야 합니다. 이 그룹 확장의 결과는 Exchange 서버에서 캐시하지 않으며 이 확장은 해당하는 모든 경우에 수행되어야 합니다. 이로 인해 메시지가 분류기 큐에 보관되고 메시지 처리가 지연될 수 있습니다.

RestrictionMethod 값을 2로 설정하면 이 Exchange 서버의 전송 구성 요소는 서버가 제한을 확인할 때 메일 그룹 구성원 자격을 확장하지 않습니다. 이 구성은 제한 검사에 최적의 성능을 제공합니다. 또한 RestrictionMethod 레지스트리 항목을 적용하려면 배달 제한이 있는 사용자가 포함된 모든 메일 그룹은 계층 구조가 없어야 합니다. 즉, 제한된 메일 그룹에는 중첩된 메일 그룹이 없어야 합니다. 이러한 확장 논리는 제한된 메일 그룹이 중첩된 경우 작동하지 않습니다.

커넥터 제한에 사용되는 메일 그룹의 경우 사서함이 없는 커넥터 브리지헤드 서버에서 RestrictionMethod 레지스트리 항목 값을 설정하는 것이 좋습니다. Active Directory 사용자 제한의 경우 제한된 메일 그룹에 확장 서버가 있으면 확장 서버에 RestrictionMethod 레지스트리 항목을 만드는 것이 좋습니다.

배달 제한이 구성되었을 때 발생하는 상황에 대한 자세한 내용은 Microsoft 기술 자료 문서 812298, "메일 그룹을 기반으로 배달 제한을 구성하면 메일 배달이 늦어진다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)를 참조하십시오.

RestrictionMethod 레지스트리 값에 대한 자세한 내용은 Microsoft 기술 자료 문서 895407, "Exchange Server 2003에서 메일 그룹을 기반으로 배달 제한을 구성하면 로컬 사서함이나 외부 사서함으로의 메시지 배달이 예측한 것보다 늦어진다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)를 참조하십시오.

Exchange Server 2003 이벤트 및 오류에 대한 자세한 내용은 "이벤트 및 오류 메시지 센터"(http://go.microsoft.com/fwlink/?LinkId=34258)를 참조하십시오.

커넥터 제한에 대한 자세한 내용은 Microsoft 기술 자료 문서 277872, "XCON: 커넥터 배달 제한이 올바르게 작동하지 않을 수 있다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)를 참조하십시오.

SMTP 큐에 대한 자세한 내용은 Microsoft 기술 자료 문서 884996, "Exchange Server 2003 또는 Exchange 2000 Server의 '디렉터리 조회 대기 중인 메시지 수입니다' SMTP 큐에 남아 있는 메시지"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=884996)를 참조하십시오.


메시지 저널링 받는 사람 문제가 발생할 가능성이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 Win32_NTLogEvent Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 다음 분류기 경고/오류 이벤트 조합 중 하나가 지난 24시간 동안 발생했는지 확인합니다.

  • 이벤트 9004 및 이벤트 9003

  • 이벤트 9035 및 이벤트 6004

이 이벤트는 메시지 분류기에서 메시지가 트랩되고 있음을 나타냅니다. 메시지 분류기는 LDAP(Lightweight Directory Access Protocol) 쿼리를 글로벌 카탈로그 서버로 보내 디렉터리 조회를 수행하는 고급 큐 엔진의 구성 요소입니다.

  • Exchange Server Analyzer는 Active Directory® 디렉터리 서비스를 쿼리하여 다음 조건 중 하나가 참인지 확인합니다.

  • 저장소에 대해 지정한 저널링 받는 사람이 삭제된 개체를 가리킵니다.

  • 저장소에 대해 지정한 저널링 받는 사람이 올바른 mailNickname이 없는 개체를 가리킵니다.

  • 저장소에 대해 지정한 저널링 받는 사람이 사용할 수 없는 계정을 가리킵니다.

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • 앞에 나열된 경고/오류 이벤트 조합 중 하나가 발생한 경우

  • 지정된 저널링 받는 사람 조건 중 하나에도 해당되는 경우

이 오류는 Exchange 환경에서 메시지를 대기하게 하는 잠재적인 저널링 문제가 있음을 나타냅니다.

이 문제의 해결 방법에 대한 자세한 내용은 해당 문제와 관련된 특정 Exchange Server Analyzer 문서를 참조하십시오.

  • 삭제한 개체에 받는 사람 지점 저널링

  • 저널링 받는 사람이 잘못되었습니다.

  • 저널링 받는 사람이 사용할 수 없는 계정을 가리킵니다.

  • Exchange Server 2003 이벤트 및 오류에 대한 자세한 내용은 "이벤트 및 오류 메시지 센터"(http://go.microsoft.com/fwlink/?LinkId=34258)를 참조하십시오.


메시지 저널링 및 저장소 서비스 문제가 발생할 가능성이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 Win32_NTLogEvent Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 분류기 경고 이벤트 9004가 지난 24시간 동안 발생했는지 확인합니다.

또한 Exchange Server Analyzer는 Win32_Service WMI 클래스를 쿼리하여 MSExchangeIS(Microsoft Exchange Information Store) 서비스가 시작되었는지 또는 중지되었는지 확인합니다. MSExchangeIS 인스턴스의 값이 Started가 아니면 MSExchangeIS 서비스가 중단된 것입니다.

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • 서버에서 지난 24시간 동안 분류기 경고 이벤트 9003가 기록되었습니다.

  • MSExchangeIS 서비스가 중지되었습니다.

이 오류는 메시징 저널링 또는 Microsoft Exchange Information Store 서비스(Store.exe)에 문제가 있음을 나타내며 이 문제로 인해 메시지가 큐에 대기할 수 있습니다.

이 문제는 다음 조건 중 하나에 해당되는 경우 발생할 수 있습니다.

  • Active Directory® 디렉터리 서비스에서 저널링 받는 사람 개체를 삭제한 경우

  • SMTP 브리지헤드 서버인 Exchange Server 컴퓨터에서 Information Store 서비스가 실행되지 않거나 비활성화된 경우

  • SMTP 브리지헤드 서버에서 하나 이상의 사서함 저장소가 분리된 경우

이 문제를 해결하려면 다음을 수행합니다.

  • SMTP 브리지헤드 서버에서 Information Store 서비스를 사용하도록 설정했고 실행 중인지 확인합니다. SMTP 브리지헤드 서버에서 사서함 저장소가 탑재되었는지 확인합니다.

  • 사서함 저장소의 저널링 받는 사람 개체가 Active Directory에서 삭제되지 않았는지 확인합니다.

사서함 저장소의 저널링 받는 사람을 확인하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 서버, <Exchange 서버>, <저장소 그룹>을 차례로 확장한 다음 사서함 저장소를 마우스 오른쪽으로 클릭하고 속성을 선택합니다.

  3. 일반 탭에서 이 저장소의 사서함에서 주고받은 모든 메시지를 보관 확인란 바로 아래에 나타나는 계정을 확인합니다. 이 계정은 저널 받는 사람으로 사용되는 계정입니다.

    참고:
    각 사서함 저장소 개체의 저널 받는 사람을 확인합니다.
새 사용자 사서함을 저널링 받는 사람으로 지정하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 서버, <Exchange 서버>, <저장소 그룹>을 차례로 확장한 다음 사서함 저장소를 마우스 오른쪽으로 클릭하고 속성을 선택합니다.

  3. 일반 탭에서 찾아보기를 클릭하여 이 저장소의 사서함에서 주고받은 모든 메시지를 보관 텍스트의 오른쪽에서 사서함을 저널링 사서함으로 지정합니다.

    참고:
    이 사서함 저장소의 보낸 사람에 대해 저널링된 모든 메시지는 지정한 사서함으로 보내집니다.

이 문제에 대한 자세한 내용은 삭제한 개체에 받는 사람 지점 저널링를 참조하십시오.

Exchange Server 2003 이벤트 및 오류에 대한 자세한 내용은 "이벤트 및 오류 메시지 센터"(http://go.microsoft.com/fwlink/?LinkId=34258)를 참조하십시오.

저널링 솔루션을 배포하는 방법은 "Exchange Server를 사용하여 저널링"(http://go.microsoft.com/fwlink/?LinkId=47581)을 참조하십시오.


사용 권한 문제가 발생할 가능성이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 Win32_NTLogEvent Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 지난 24시간 내에 다음 Exchange Server 오류 이벤트가 발생했는지 여부를 확인합니다.

  • 이벤트 929

  • 이벤트 9035

  • 이벤트 9003, 9004 및 6004의 조합

Active Directory® 디렉터리 서비스의 Exchange Server 개체에 대한 잘못된 액세스 권한 때문에 Exchange Server 오류 이벤트 929가 발생할 수 있습니다.

Exchange Server 오류 이벤트 9003, 9004 및 6004는 메시지가 메시지 분류기에 갇혀 있음을 나타냅니다. 메시지 분류기는 LDAP(Lightweight Directory Access Protocol) 쿼리를 글로벌 카탈로그 서버로 보내 디렉터리 조회를 수행하는 고급 큐 엔진의 구성 요소입니다.

또한 Exchange Server Analyzer는 Active Directory를 쿼리하여 Exchange와 관련된 개체의 특성이 해당 개체에 대한 권한 상속 문제가 있음을 나타내는지 여부도 확인합니다.

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • 디렉터리 조회 대기 중인 메시지 수입니다 큐에 대기된 메시지가 있는 서버에서 지난 24시간 내에 다음 이벤트 중 하나 또는 이벤트 조합이 기록된 경우

    • 이벤트 929

    • 이벤트 9035

    • 이벤트 9003, 9004 및 6004의 조합

  • Exchange와 관련된 개체가 없거나 잘못된 액세스 권한을 가지고 있는 경우

이 오류는 Exchange 환경에서 큐에 메일이 대기될 수 있는 권한 상속 문제가 있음을 나타냅니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 907969, "이벤트 ID 929가 기록되며 메일이 Exchange 2000 Server 조직의 한 메일 서버에서 다른 메일 서버로 전달되지 않는다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=907969)의 단계를 따르십시오.

Exchange Server 2003 이벤트 및 오류에 대한 자세한 내용은 "이벤트 및 오류 메시지 센터"(http://go.microsoft.com/fwlink/?LinkId=34258)를 참조하십시오.


일반 대상으로 식별된 공용 폴더
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-04

Microsoft® Exchange Server Analyzer Tool은 Exchange_Queue WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP 가상 서버의 SMTP(Simple Mail Transfer Protocol) 큐에 대한 다음 특성 값을 확인합니다.

LinkId | 큐를 포함한 링크의 식별자를 나타냅니다.
QueueId | 큐의 식별자를 나타냅니다.
QueueName | 큐의 이름을 나타냅니다.
VirtualMachine | 큐를 포함한 가상 컴퓨터의 이름을 나타냅니다.
VirtualServerName | 큐가 있는 가상 서버의 이름을 나타냅니다.
MessageCount | 큐에 있는 메시지 수를 나타냅니다.

Exchange Server Analyzer는 여기서 얻은 정보를 사용해 Exchange_QueuedSMTPMessage WMI 클래스를 쿼리하여 큐에 있는 메시지의 다음 특성 값을 확인합니다.

Recipients | 메시지를 받는 사람을 나타냅니다.
Received | 메시지를 받은 타임 스탬프를 나타냅니다.
MessageId | 큐에 대기 중인 메시지의 식별자를 나타냅니다.
StateRetry | 제대로 배달되지 않은 메시지에 대해 다시 전송을 시도하는 상태임을 나타냅니다.

마지막으로 Exchange Server Analyzer는 여기서 얻은 데이터를 사용해 Active Directory® 디렉터리 서비스를 쿼리하여 각 Recipient 개체의 distinguishedName 값을 확인합니다. 그런 다음 Exchange Server Analyzer는 받는 사람이 사용자인지, 메일 그룹인지, 공용 폴더인지, 공용 폴더 저장소인지를 확인합니다.

Exchange Server Analyzer는 큐에 대기 중인 메시지 중 적어도 25퍼센트 이상이 To: 또는 Cc: 필드의 특정 공용 폴더에 배달되는 경우에 경고를 표시합니다.

또한 큐에 대기 중인 메시지 중 적어도 50퍼센트 이상이 To: 또는 Cc: 필드의 특정 공용 폴더에 배달되는 경우에는 오류를 표시합니다.

이러한 경고 또는 오류는 식별된 공용 폴더가 SMTP 큐에 대기 중인 메시지의 일반 대상임을 의미합니다.

이 문제를 해결하려면 공용 폴더에 구성 문제나 메시지가 큐에 대기되도록 하는 기타 예외적인 문제가 있는지 확인해야 합니다.

  • 공용 폴더 개체 특성이 올바르게 설정되어 있고 Active Directory에 올바른 값이 포함되어 있는지 확인합니다.

  • 공용 폴더 개체의 Active Directory 사용 권한이 올바르게 설정되어 있는지 확인합니다.

  • 공용 폴더에 대한 UCE(원치 않는 상업성 전자 메일 메시지)나 스팸 또는 바이러스 공격이 있는지 확인합니다.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 전송 및 라우팅 가이드의 "메일 흐름 및 SMTP 문제 해결"(http://go.microsoft.com/fwlink/?LinkID=67875)

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)


일반 대상으로 식별된 공용 폴더 저장소
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-04

Microsoft® Exchange Server Analyzer Tool은 Exchange_Queue WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP 가상 서버의 SMTP(Simple Mail Transfer Protocol) 큐에 대한 다음 특성 값을 확인합니다.

LinkId | 큐를 포함한 링크의 식별자를 나타냅니다.
QueueId | 큐의 식별자를 나타냅니다.
QueueName | 큐의 이름을 나타냅니다.
VirtualMachine | 큐를 포함한 가상 컴퓨터의 이름을 나타냅니다.
VirtualServerName | 큐가 있는 가상 서버의 이름을 나타냅니다.
MessageCount | 큐에 있는 메시지 수를 나타냅니다.

Exchange Server Analyzer는 여기서 얻은 정보를 사용해 Exchange_QueuedSMTPMessage WMI 클래스를 쿼리하여 큐에 있는 메시지의 다음 특성 값을 확인합니다.

Recipients | 메시지를 받는 사람을 나타냅니다.
Received | 메시지를 받은 타임 스탬프를 나타냅니다.
MessageId | 큐에 대기 중인 메시지의 식별자를 나타냅니다.
StateRetry | 제대로 배달되지 않은 메시지에 대해 다시 전송을 시도하는 상태임을 나타냅니다.

마지막으로 여기서 얻은 데이터를 사용해 Active Directory® 디렉터리 서비스를 쿼리하여 각 Recipient 개체의 distinguishedName 값을 확인합니다. 그런 다음 Exchange Server Analyzer는 받는 사람이 사용자인지, 메일 그룹인지, 공용 폴더인지, 공용 폴더 저장소인지를 확인합니다.

Exchange Server Analyzer는 큐에 대기 중인 메시지 중 적어도 25퍼센트 이상이 To: 또는 Cc: 필드에서 동일한 공용 폴더 저장소에 사서함을 갖고 있는 받는 사람에게 배달되는 경우에 경고를 표시합니다.

또한 큐에 대기 중인 메시지 중 적어도 50퍼센트 이상이 To: 또는 Cc: 필드에서 동일한 공용 폴더 저장소에 사서함을 갖고 있는 받는 사람에게 배달되는 경우에는 오류를 표시합니다.

이러한 경고 또는 오류는 식별된 공용 폴더 저장소가 SMTP 큐에 대기 중인 메시지의 일반 대상임을 의미합니다.

이 문제를 해결하려면 공용 폴더 저장소에 구성 문제, 복제 폭풍 또는 메시지가 큐에 대기되도록 하는 기타 예외적인 문제가 있는지 확인해야 합니다.

  • 저장소 개체 특성이 올바르게 설정되어 있고 Active Directory에 올바른 값이 포함되어 있는지 확인합니다.

  • 저장소 개체의 Active Directory 사용 권한이 올바르게 설정되어 있는지 확인합니다.

  • 공용 폴더에 대한 UCE(원치 않는 상업성 전자 메일 메시지)나 스팸 또는 바이러스 공격이 있는지 확인합니다.

  • 공용 폴더의 계층 구조나 내용을 변경함으로써 공용 폴더 저장소 사이에 대량 복제가 발생되는지 확인합니다.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 전송 및 라우팅 가이드의 "메일 흐름 및 SMTP 문제 해결"(http://go.microsoft.com/fwlink/?LinkID=67875)

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 842273, "Exchange 2000 Server 및 Exchange Server 2003의 공용 폴더 복제 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273)


받는 사람 필터링을 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 가상 서버 개체의 msExchServerBindingsFiltering 속성이 SMTP 가상 서버 인스턴스에 받는 사람 필터링을 사용할 수 있음을 나타내는지 여부를 확인합니다.

또한 Exchange Server Analyzer는 Active Directory를 쿼리하여 msExchRecipTurfListNames 또는 msExchRecipTurfListOptions 속성이 글로벌 설정 수준에서 받는 사람 필터링을 사용할 수 있음을 나타내는지 여부도 확인합니다.

Exchange Server Analyzer Tool이 SMTP 가상 서버 인스턴스와 글로벌 설정 수준에서 받는 사람 필터링을 사용할 수 있음을 발견하면 Exchange Server Analyzer는 경고를 표시합니다.

이 경고는 받는 사람 필터링을 효과적으로 사용할 수 있음을 나타냅니다. 일반적으로 받는 사람 필터링은 문제가 되지 않지만, 이 특정 서버와 관련된 메일 흐름 문제를 해결하려는 경우, 필터 구성을 확인하거나 받는 사람 필터링을 일시적으로 사용할 수 없게 하여 올바른 수신자에게 메일이 잘못 차단되고 있는지 여부를 확인할 수 있습니다.

SMTP 가상 서버에서 받는 사람 필터를 사용하지 않으려면 다음을 수행합니다.

  1. 시작을 클릭하고 모든 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭하여 Exchange System Manager를 시작합니다.

  2. 콘솔 트리에서 서버, 원하는 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. 필터를 비활성화할 SMTP 가상 서버를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  4. <SMTP Virtual Server> 속성의 일반 탭에서 고급을 클릭합니다.

  5. 고급에서 필터를 비활성화할 IP 주소를 선택하고 편집을 클릭합니다.

확인에서 받는 사람 필터 적용 확인란의 선택을 해제하여 필터를 사용할 수 없게 합니다.

  1. 가상 서버가 여러 개인 경우 필터를 비활성화할 가상 서버 각각에 대해 3단계부터 6단계까지 반복합니다.

받는 사람 필터를 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 823866, "RBL(Realtime Block List)을 사용하여 연결 필터링을 구성하는 방법 및 Exchange 2003에서 받는 사람 필터링을 구성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866)을 참조하십시오.

지능형 메시지 필터링에 대한 자세한 내용은 Exchange Intelligent Message Filter 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21607)를 참조하십시오.


'원격 배달' 큐가 고정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 원격 배달 큐의 StateFrozen 키 값을 확인합니다.

Exchange Server Analyzer는 Exchange 서버에서 원격 배달 큐의 StateFrozen 키 값이 True로 설정되어 있음을 발견하면 오류를 표시합니다.

큐가 고정되었다는 것은 해당 큐에 대한 전송 세션이 중지되었음을 의미합니다. 고정된 큐에서는 새 메시지가 추가될 수는 있어도 메시지가 나갈 수는 없습니다. 각 링크 큐에 대한 바로 가기 메뉴를 사용하여 연결 상태를 수동으로 변경할 수 있습니다. 강제 연결 명령을 사용하여 큐 상태를 활성으로 변경하면 바로 해당 큐의 메시지를 보내는 연결을 사용할 수 있습니다.

원격 배달 큐에는 원격 배달할 메시지가 들어 있습니다. 큐 이름은 원격 배달 대상과 일치합니다. 이 대상은 커넥터, 서버 또는 도메인일 수 있습니다.

이 문제를 해결하려면 NSlookup 유틸리티를 사용하여 DNS(Domain Name System) 확인과 관련하여 발생할 수 있는 문제를 검토하십시오. 호스트에 도달할 수 없음 오류와 같은 연결 및 프로토콜 문제의 경우에는 Telnet.exe를 사용하여 대상 컴퓨터에 연결해 보십시오. 프로토콜 오류를 해결하려면 SMTP 프로토콜 구성 요소에 대한 MSExchangeTransport 서비스의 진단 로깅을 증가시키고 오류 로그를 검토하십시오. 또는 네트워크 모니터 도구(Netmon.exe)를 사용하여 네트워크 연결 오류에 대한 정보를 얻을 수도 있습니다. 문제를 재현하기 위해 큐를 강제로 다시 실행되게 해야 할 수도 있습니다. 이벤트 로그를 검사하여 Microsoft Exchange Information Store 서비스에 관련된 오류가 있는지 확인하십시오.

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


'원격 배달' 큐가 재시도 중입니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 ExchangeLink WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 원격 배달 큐의 StateRetry 키 값을 확인합니다.

Exchange Server Analyzer는 Exchange 서버에서 원격 배달 큐의 StateRetry 키 값이 True로 설정되어 있음을 발견하면 오류를 표시합니다.

큐 상태가 재시도이면 이전에 큐의 메시지를 처리하려고 시도했을 때 최소 한 번 이상 오류가 발생했음을 나타냅니다. 강제 연결 명령을 사용하여 재시도 또는 예약됨 상태의 큐를 활성 상태로 변경할 수 있습니다. 그러면 재시도 간격이 지났거나 예약된 시간에 도달한 것처럼 큐가 작동합니다. 그러나 이 방법이 제대로 작동하지 않는 경우도 있습니다.

참고:
큐의 속성이 큐가 재시도 상태에 있어야 하는 특정 이유를 나타낼 수 있습니다.

원격 배달 큐에는 원격 배달할 메시지가 들어 있습니다. 큐 이름은 원격 배달 대상과 일치합니다. 이 대상은 커넥터, 서버 또는 도메인일 수 있습니다.

이 문제를 해결하려면 NSlookup 유틸리티를 사용하여 DNS(Domain Name System) 확인과 관련하여 발생할 수 있는 문제를 검토하십시오. 호스트에 도달할 수 없음 오류와 같은 연결 및 프로토콜 문제의 경우에는 Telnet.exe를 사용하여 대상 컴퓨터에 연결해 보십시오. 프로토콜 오류를 해결하려면 SMTP 프로토콜 구성 요소에 대한 MSExchangeTransport 서비스의 진단 로깅을 증가시키고 오류 로그를 검토하십시오. 또는 네트워크 모니터(Netmon.exe) 도구를 사용하여 네트워크 연결 오류에 대한 정보를 얻을 수도 있습니다. 문제를 재현하기 위해 큐를 강제로 다시 실행되게 해야 할 수도 있습니다. 이벤트 로그를 검사하여 Microsoft Exchange Information Store 서비스에 관련된 오류가 있는지 확인하십시오.

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


'원격 배달' 큐 문제
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool에서는 Exchange 서버에서 SMTP(Simple Mail Transfer Protocol) 도메인에 대한 전자 메일 관리자 계정 또는 사용자 정의 계정으로 테스트 메시지를 보낸 다음 서버의 메시지 추적 로그를 검색하여 테스트 메시지를 배달하는 데 문제가 있는지 확인합니다.

이 검색 작업의 일부분으로 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스 아래의 Exchange_MessageTrackingEntry Microsoft WMI(Windows® Management Instrumentation) 클래스의 EntryType 속성을 쿼리하여 메시지 추적 로그 항목이 생성된 원인을 확인합니다.

Exchange Server Analyzer는 다음과 같은 경우 오류를 표시합니다.

  • 메시지 추적 로그를 성공적으로 검색할 수 있는 경우

  • 테스트 메시지가 큐에서 성공적으로 전송되지 않은 경우

  • 배달 못 함 보고서(NDR)가 생성되지 않은 경우

  • EntryType 속성에 대해 1034 값이 있는 경우

이 오류는 보내는 서버에 대한 SMTP(Simple Mail Transfer Protocol) 원격 배달 큐 중 하나에 아직 테스트 메시지가 있고 큐와 관련된 문제가 있음을 나타냅니다.

원격 배달 큐에는 원격 배달할 메시지가 들어 있습니다. 큐 이름은 원격 배달 대상과 일치합니다. 이 대상은 커넥터, 서버 또는 도메인일 수 있습니다.

이 문제를 해결하려면 NSlookup 유틸리티를 사용하여 DNS(Domain Name System) 확인과 관련하여 발생할 수 있는 문제를 검토하십시오. 호스트에 도달할 수 없음 오류와 같은 연결 및 프로토콜 문제의 경우에는 Telnet.exe를 사용하여 대상 컴퓨터에 연결해 보십시오. 프로토콜 오류를 해결하려면 SMTP 프로토콜 구성 요소에 대한 MSExchangeTransport 서비스의 진단 로깅을 증가시키고 오류 로그를 검토하십시오. 또는 네트워크 모니터(Netmon.exe) 도구를 사용하여 네트워크 연결 오류에 대한 정보를 얻을 수도 있습니다. 문제를 재현하기 위해 큐를 강제로 다시 실행되게 해야 할 수도 있습니다. 이벤트 로그를 검사하여 Microsoft Exchange Information Store 서비스에 관련된 오류가 있는지 확인하십시오.

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


분류 재시도
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool에서는 Exchange 서버에서 SMTP(Simple Mail Transfer Protocol) 도메인의 전자 메일 관리자 계정 또는 사용자 정의 계정으로 테스트 메시지를 보낸 다음 서버의 메시지 추적 로그를 검색하여 테스트 메시지를 배달하는 데 문제가 있는지 확인합니다.

이 검색 과정에서 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스 아래의 Exchange_MessageTrackingEntry Microsoft WMI(Windows® Management Instrumentation) 클래스의 EntryType 속성을 쿼리하여 메시지 추적 로그 항목의 원인을 확인합니다.

Exchange Server Analyzer는 EntryType 속성에 대한 값이 1032인 경우 경고를 표시합니다.

이 경고는 분류를 재시도하도록 예약된 테스트 메시지가 대기 중임을 나타냅니다. 큐 상태가 재시도이면 이전에 큐의 메시지를 처리하려고 시도했을 때 최소 한 번 이상 오류가 발생했음을 나타냅니다. 강제 연결 명령을 사용하여 재시도 또는 예약됨 상태의 큐를 활성 상태로 변경할 수 있습니다. 그러면 재시도 간격이 지났거나 예약된 시간에 도달한 것처럼 큐가 작동합니다. 그러나 이 방법이 제대로 작동하지 않는 경우도 있습니다.

참고:
큐의 속성이 큐가 재시도 상태에 있어야 하는 특정 이유를 나타낼 수 있습니다.

고급 큐 엔진에서 메시지를 분류할 수 없으므로 일반적으로 재시도되기를 기다리는 메시지가 큐에 누적됩니다. 고급 큐 엔진이 글로벌 카탈로그 서버에 액세스하여 받는 사람 정보에 액세스할 수 없거나, 글로벌 카탈로그 서버 자체에 연결할 수 없거나, 글로벌 카탈로그 서버의 성능이 느린 경우 이 문제가 발생할 수 있습니다. 또한 다음과 같은 이유 때문에 메시지가 누적될 수 있습니다.

  • Active Directory를 사용할 수 없는 경우

    참고:
    분류기가 Active Directory를 사용하여 메시지를 분류하는 경우
  • 분류 작업 이전 큐에 대기 중인 메시지가 너무 많아서 Active Directory가 과도하게 로드되는 경우

  • 변환이 실패한 경우. 분류기가 콘텐츠 변환도 함께 처리하는 경우

  • 메시지 분류기가 사서함 저장소를 찾을 수 없는 경우

  • SMTP가 다시 설치되거나 제거되어 /smtpsvc/DsUseCat 및 /smtpsvc/vsi#/DsUseCat와 같은 IIS 메타베이스 키가 무효화된 경우

    참고:
    SMTP가 다시 설치되거나 제거되었는지 여부를 결정합니다.

큐가 "재시도" 상태인 경우 큐의 속성을 확인하여 원인을 파악합니다. 예를 들어, 큐 속성에 "SMTP 오류가 발생했습니다"와 비슷한 메시지가 표시되면 서버의 이벤트 로그를 검토하여 SMTP 오류를 확인해야 합니다. 로그에 이벤트가 없는 경우 SMTP 프로토콜 로깅 수준을 높여야 합니다.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


로컬 배달 재시도
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-04

Microsoft® Exchange Server Analyzer Tool에서는 Exchange 서버에서 SMTP(Simple Mail Transfer Protocol) 도메인의 전자 메일 관리자 계정 또는 사용자 정의 계정으로 테스트 메시지를 보낸 다음 서버의 메시지 추적 로그를 검색하여 테스트 메시지를 배달하는 데 문제가 있는지 확인합니다.

이 검색 과정에서 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스 아래에 있는 Exchange_MessageTrackingEntry Microsoft WMI(Windows® Management Instrumentation) 클래스의 EntryType 속성을 쿼리하여 메시지 추적 로그 항목의 원인을 확인합니다.

Exchange Server Analyzer는 EntryType 속성에 대해 값 1037을 찾으면 경고를 표시합니다.

이 경고는 이전에 로컬 배달 큐에서 메시지를 처리할 때 하나 이상의 오류가 발생했음을 나타냅니다.

로컬 배달 큐에는 Exchange Server 사서함이나 공용 폴더 저장소로 로컬 배달을 위해 Exchange 서버에 대기 중인 메시지가 들어 있습니다.

Exchange 서버에서 로컬로 배달할 메시지를 수락하지 않는 경우 이 큐에 메시지가 누적될 수 있습니다. 메시지 배달 속도가 느리거나 제때 배달되지 않으면 메시지 루핑 또는 성능에 문제가 있는 것일 수 있습니다.

연결 강제 실행 명령을 사용하여 재시도 또는 예약 상태의 큐를 활성 상태로 변경할 수 있습니다. 그러면 재시도 간격이 지났거나 예약된 시간에 도달한 것처럼 큐가 작동합니다. 그러나 이 방법이 제대로 작동하지 않는 경우도 있습니다.

참고:
큐의 속성이 큐가 재시도 상태에 있어야 하는 특정 이유를 나타낼 수 있습니다.

이 오류를 해결하려면 MSExchangeIS 및 MSExchangeTransport 서비스 SMTP 저장소 드라이버 구성 요소에 대한 진단 로깅을 늘립니다.

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


라우팅 재시도
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool에서는 Exchange 서버에서 SMTP(Simple Mail Transfer Protocol) 도메인의 전자 메일 관리자 계정 또는 사용자 정의 계정으로 테스트 메시지를 보낸 다음 서버의 메시지 추적 로그를 검색하여 테스트 메시지를 배달하는 데 문제가 있는지 확인합니다.

이 검색 과정에서 Exchange Server Analyzer Tool은 root\MicrosoftExchangeV2 네임스페이스 아래의 Exchange_MessageTrackingEntry Microsoft WMI(Windows® Management Instrumentation) 클래스에 대한 EntryType 속성을 쿼리하여 메시지 추적 로그 항목의 원인을 확인합니다.

Exchange Server Analyzer는 EntryType 속성에 대한 값이 1035인 경우 경고를 표시합니다.

이 경고는 라우팅을 재시도하도록 예약된 테스트 메시지가 대기 중임을 나타냅니다. 큐 상태가 재시도이면 이전에 큐의 메시지를 처리하려고 시도했을 때 최소 한 번 이상 오류가 발생했음을 나타냅니다. 강제 연결 명령을 사용하여 재시도 또는 예약됨 상태의 큐를 활성 상태로 변경할 수 있습니다. 그러면 재시도 간격이 지났거나 예약된 시간에 도달한 것처럼 큐가 작동합니다. 그러나 이 방법이 제대로 작동하지 않는 경우도 있습니다.

참고:
큐의 속성이 큐가 재시도 상태에 있어야 하는 특정 이유를 나타낼 수 있습니다.

Exchange 서버 라우팅 문제가 있으면 큐에 재시도 대기 중인 메시지가 누적됩니다. 일시적인 오류 때문에 메시지가 라우팅되지 않았습니다. 즉, 라우팅 엔진이 성공적으로 초기화되지 않았습니다. 메시지는 재시도 또는 다시 라우팅을 위해 대기 중인 사전-라우팅 큐에 있습니다.

이 오류를 해결하려면 MSExchangeTransport 서비스의 진단 로깅을 증가시켜 라우팅 범주 구성 요소에 대한 정보를 수집하십시오. 필요 없는 커넥터 제한 사항으로 인해 서버 성능이 크게 저하될 수 있으므로 이러한 제한 사항은 사용하지 마십시오. 일부 제한 사항의 경우 CheckConnectorRestrictions 레지스트리 키를 켜야 할 수 있습니다.

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


DNS 역방향 조회가 메타베이스에서는 사용할 수 있도록 설정되었지만 Active Directory 관련 SMTP 서버에서는 설정되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 인터넷 정보 서비스(IIS) 메타베이스의 다음 속성 값이 Active Directory® 디렉터리 서비스에서 msExchSmtpPerformReverseDnsLookup 특성에 대해 구성된 값과 일치하는지 확인할 때 이 속성을 읽습니다.

/LM/SmtpSvc/<SMTP virtual server instance>/EnableReverseDnsLookup

Exchange Server Analyzer는 값이 일치하지 않을 경우 경고 메시지를 표시합니다.

Exchange에서 IIS 메타베이스의 값이 Active Directory의 값과 일치하지 않으면 Active Directory 복제 또는 Exchange의 DS2MB(Directory-service-to-Metabase) 복제 구성 요소에서 문제가 발생한 것일 수 있습니다.

DS2MB 프로세스의 기능은 구성 정보를 Active Directory에서 로컬 메타베이스로 전송하는 것입니다. 이 구성은 성능 및 확장성 이유로 레지스트리 대신 로컬 메타베이스에 저장됩니다. Exchange 2000 Server와 Exchange Server 2003에서는 모든 인터넷 프로토콜(SMTP, NNTP, POP3, IMAP4 및 HTTP)이 IIS의 구성 요소로서 실행됩니다.

DS2MB 프로세스는 15분마다 Active Directory에서 하위 트리의 모양을 바꾸지 않고 전체 하위 트리를 복사합니다. 이러한 작업은 Active Directory에서 메타베이스로 쓸 수 있지만 반대로 메타베이스에서 Active Directory로는 쓰지 못합니다.

EnableReverseDnsLookup 속성 및 msExchSmtpPerformReverseDnsLookup 특성은 모두 TRUE 또는 FALSE 값을 갖습니다. 값이 TRUE이면 SMTP 가상 서버가 모든 받는 메시지에 대해 DNS 역방향 조회를 수행합니다. 값이 FALSE이면 DNS 역방향 조회가 수행되지 않습니다. 잘못 구성된 DNS 레코드 또는 일시적인 인터넷 연결 중단으로 인해 성능이 떨어질 수도 있으므로 EnableReverseDnsLookup 속성 및 msExchSmtpPerformReverseDnsLookup 특성은 기본적으로 FALSE로 설정됩니다.

EnableReverseDnsLookup 속성이 TRUE(사용)로 설정되고 msExchSmtpPerformReverseDnsLookup 특성이 FALSE(사용 안 함)로 설정되어 있는 경우 Active Directory와 IIS 메타베이스가 동기화되지 않은 것입니다. DS2MB 프로세스의 실패로 인해 문제가 발생할 경우 아래의 절차 중 실행 중인 Exchange Server 버전에 맞는 절차를 수행하면 문제를 해결할 수 있습니다. Active Directory 복제의 부분 또는 완전 실패로 인해 문제가 발생할 경우 Active Directory Replication Monitor 유틸리티(ReplMon.exe)를 사용하여 Active Directory 복제의 상태를 확인할 수 있습니다. ReplMon.exe는 Windows Server CD-ROM의 Windows® 지원 도구에 있습니다.

Exchange Server 2003에서 이 오류를 수정하려면 다음을 수행합니다.

  1. MSExchangeMU의 원본이 있는 응용 프로그램 이벤트 로그 항목이 있는지 확인합니다. Exchange Server 2003에서 DS2MB가 실패하면 이벤트가 기록됩니다.

  2. DS2MB 실패 이벤트가 표시되지 않으면 ReplMon을 사용하여 Active Directory 복제를 진단합니다. SMTP 가상 서버에서 현재 사용 중인 글로벌 카탈로그 서버에 특히 유의하십시오.

  3. DS2MB 실패 이벤트가 나타나 있거나 Active Directory 복제의 문제를 모두 제거했거나 해결한 후에는 Exchange System Attendant 서비스를 다시 시작합니다.

Exchange 2000 Server에서 이 오류를 수정하려면 다음을 수행합니다.

  1. ReplMon을 사용하여 Active Directory 복제를 진단합니다. SMTP 가상 서버에서 현재 사용 중인 글로벌 카탈로그 서버에 특히 유의하십시오.

  2. Active Directory 복제의 문제를 모두 제거했거나 해결한 후에는 Exchange System Attendant 서비스를 다시 시작합니다.

Exchange의 DNS 역방향 조회 기능에 대한 자세한 내용은 Microsoft 기술 자료 문서 297412, "'받는 메시지에 DNS 역방향 조회 수행' 옵션은 호스트 이름 확인을 위한 것이다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)를 참조하십시오.

SMTP 가상 서버 설정에 대한 자세한 내용은 Microsoft 기술 자료 문서 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) 및 "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)를 참조하십시오.

Active Directory 복제에 대한 자세한 내용은 Microsoft 기술 자료 문서 232072, "Active Directory 직접 복제 파트너 간에 복제 시작"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)을 참조하십시오.

DS2MB 프로세스에 대한 자세한 내용은 Microsoft 기술 자료 문서 240105, "XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)을 참조하십시오.


라우팅 엔진: AttachedTimeout 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP(Simple Mail Transfer Protocol) 커넥터 라우팅 논리가 기본 설정과 다르게 수정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\AttachedTimeout

Exchange Server Analyzer는 AttachedTimeout 레지스트리 키가 300보다 큰 값으로 구성되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

AttachedTimeout 레지스트리 항목은 ORG_INFO 패킷이 전송되는 빈도를 결정하는 Exchang Server의 사용자 지정 구성 설정입니다. 라우팅 클라이언트가 라우팅 서버에 연결하지 않을 때마다 토폴로지의 사용자 버전은 증분되어 ORG_INFO 패킷이 조직 전체에 브로드캐스트됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\RESvc\Parameters를 탐색합니다.

  3. AttachedTimeout 레지스트리 키를 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. IIS Admin Service를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

AttachedTimeout 레지스트리 값에 대한 자세한 내용은 기술 자료 문서 832281, "Link state issues and routing issues in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832281)을 참조하십시오.


라우팅 엔진: BestAddressMatchOnly 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP(Simple Mail Transfer Protocol) 커넥터 라우팅 논리가 기본 설정에서 수정되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\BestAddressMatchOnly

BestAddressMatchOnly 레지스트리 키가 존재하고 0보다 큰 값으로 구성되어 있으면 Exchange Server Analyzer에서 기본 구성이 아니라는 메시지를 표시합니다.

BestAddressMatchOnly 레지스트리 항목은 기존 제한에 관계 없이 특정 커넥터를 통해 특정 도메인에 보낸 메일을 라우팅하도록 지정하는 Exchange Server에 대한 사용자 지정 구성 설정입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\RESvc\Parameters를 탐색합니다.

  3. BestAddressMatchOnly 레지스트리 키를 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


라우팅 엔진: CheckConnectorRestrictions 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP(Simple Mail Transfer Protocol) 커넥터 라우팅 논리가 기본 설정과 다르게 수정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\CheckConnectorRestrictions

Exchange Server Analyzer는 CheckConnectorRestrictions 레지스트리 키가 0보다 큰 값으로 구성되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

CheckConnectorRestrictions 레지스트리 항목은 확인 중인 커넥터의 원본인 Exchange 브리지헤드 서버에서 제한 검사를 사용할 수 있는 Exchange Server에 대한 사용자 지정 구성 설정입니다. 기본적으로 커넥터 제한 검사는 시스템에 상당히 영향을 주므로 특히 많은 메일 그룹을 사용하는 구성에서는 사용되지 않아야 합니다. 시스템을 통해 각 메일 그룹의 각 구성원에게 보내지는 메시지마다 제한을 검사합니다. 제한이 지정되어 있지만 이 레지스트리 항목이 없는 경우 제한 검사가 수행되지 않습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\RESvc\Parameters를 탐색합니다.

  3. CheckConnectorRestrictions 레지스트리 키를 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. IIS Admin 서비스를 다시 시작합니다.

  6. 커넥터의 배달 제한 탭에서 제한 옵션을 다시 사용할 수 있도록 합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

CheckConnectorRestrictions 레지스트리 값에 대한 자세한 내용은 기술 자료 문서 277872, "XCON: Connector Delivery Restrictions May Not Work Correctly"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)를 참조하십시오.


라우팅 엔진: 구성 매개 변수가 기본값이 아님
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Exchange 라우팅 엔진 설정에 대한 Active Directory® 디렉터리 서비스의 읽기 간격이 기본값과 다르게 수정되어 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RESvc\Parameters\ReloadOsInterval

Exchange Server Analyzer는 ReloadOsInterval의 값 데이터가 3600 이외의 값으로 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

ReloadOsInterval 값을 사용하여 Exchange를 실행하는 서버 간에 라우팅 링크 상태 정보가 업데이트되는 간격을 지정합니다. Exchange는 라우팅 링크 상태 정보를 이용하여 서버마다 가장 적은 비용이 드는 경로를 확인하여 메시지를 전달할 수 있고 또한 경로를 구성하는 커넥터가 작동 중인지를 확인할 수 있습니다. 기본적으로 Exchange Server는 Active Directory에서 3600초(1시간)마다 링크 상태 정보를 읽습니다.

특정 상황의 경우 라우팅 상태 정보가 Exchange 조직에 있는 모든 서버에 동적으로 올바르게 전파되지 않을 수도 있습니다. 조직의 일부 서버는 오래되고 잘못된 라우팅 상태 정보로 계속 작동될 수 있습니다. 이러한 상황으로 인해 WinRoute 도구(Winroute.exe)를 사용하여 원격 라우팅 그룹을 볼 때 새로운 커넥터가 표시되지 않을 수 있습니다. WinRoute 도구를 사용하여 링크 상태 정보가 전파되고 있는지 확인할 수 있습니다. 정보가 전파되고 있는지 확인하려면 WinRoute 도구를 사용하여 Exchange 조직에서 다양한 여러 위치의 링크 상태 정보를 확인한 다음 각 라우팅 그룹의 버전 번호를 비교합니다. WinRoute 도구는 Exchange Server 컴퓨터의 링크 상태 포트에 연결되어 Exchange 조직의 링크 상태 정보를 추출합니다. 링크 상태 정보가 일련의 GUID(글로벌 고유 식별자)지만 WinRoute는 커넥터와 브리지헤드 서버의 GUID를 Active Directory의 개체에 맞추어 읽을 수 있는 형식으로 정보를 제공합니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
기본 구성으로 되돌리려면 다음을 수행하십시오.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SYSTEM\CurrentControlSet\Services\RESvc\Parameters를 탐색합니다.

  3. 오른쪽 창에서 ReloadOsInterval을 두 번 클릭합니다.

  4. 값 데이터 상자에 3600을 입력한 다음 확인을 클릭합니다.

  5. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

라우팅 및 링크 상태 정보에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 842026, "Routing status information is not propagated correctly to all servers in Exchange 2000 Server or in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=842026)

  • 285130, "XCON: Link State Information"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=285130)

라우팅 마스터에 알려진 링크 상태 정보를 확인하는 데 유용한 도구인 WinRoute를 다운로드하려면 "Exchange Server WinRoute"(http://go.microsoft.com/fwlink/?LinkId=25049)를 참조하십시오.


라우팅 엔진: PollingInterval 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP(Simple Mail Transfer Protocol) 커넥터 라우팅 논리가 기본 설정과 다르게 수정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\PollingInterval

PollingInterval 레지스트리 키가 존재하고 300보다 큰 값으로 구성되어 있으면 Exchange Server Analyzer에서 기본 구성이 아니라는 메시지를 표시합니다.

PollingInterval 레지스트리 항목은 라우팅 그룹 간 특히 라우팅 그룹 내의 라우팅 그룹 마스터 간에 링크 상태 소통량의 빈도를 제어할 수 있게 해주는 Exchange Server에 대한 사용자 지정 구성 설정입니다. 이 설정을 증가시키면 연결은 실패하지 않지만 더 중요한 문제인 라우팅 그룹 구성원 간에 연결이 느려지는 문제는 해결할 수 없게 됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\RESvc\Parameters를 탐색합니다.

  3. PollingInterval 레지스트리 키를 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. IIS Admin Service를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


라우팅 엔진: StateChangeDelay 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP(Simple Mail Transfer Protocol) 커넥터 라우팅 논리가 기본 설정과 다르게 수정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\StateChangeDelay

Exchange Server Analyzer는 StateChangeDelay 레지스트리 키가 0보다 큰 값으로 구성되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

StateChangeDelay 레지스트리 항목은 커넥터가 사용할 수 없는 것으로 표시되는 간격과 커넥터와 서버 상태가 변경되어 발생하는 알림을 쉽게 제어할 수 있게 해 주는 Exchange Server의 사용자 지정 구성 설정입니다. StateChangeDelay가 0보다 큰 값으로 설정되어 있으면 서버는 이 값으로 설정된 시간 간격당 단 한 번만 사용할 수 있거나 사용할 수 없는 것으로 표시될 수 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\RESvc\Parameters를 탐색합니다.

  3. StateChangeDelay 레지스트리 키를 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. IIS Admin Service를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


라우팅 엔진: SuppressStateChanges 매개 변수가 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP(Simple Mail Transfer Protocol) 커넥터 라우팅 논리가 기본 설정과 다르게 수정되어 있는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\SuppressStateChanges

Exchange Server Analyzer는 SuppressStateChanges 레지스트리 키가 0보다 큰 값으로 구성되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

Exchange Server 2003에는 링크 상태의 변경 사항을 자동으로 감지하는 기능이 있습니다. 이 정보를 이용하여 최소 순위의 주 경로 대신 대체 경로를 사용해야 한다고 Exchange Server 2003을 실행 중인 다른 서버에 알릴 수 있습니다. 링크 상태 정보는 주 변경과 부 변경으로 나뉩니다. 새 커넥터 추가나 비용 변경 같이 관리자가 라우팅 토폴로지를 변경할 경우 주 변경이 이루어집니다. 시스템에서 자동으로 실패나 링크 복원을 감지하는 경우에는 부 업데이트가 이루어집니다.

이 기능은 중소 규모의 조직에서 잘 작동됩니다. 그러나 대규모의 멀티 사이트 환경에서는 대량의 네트워크 변경으로 인해 부 버전에 대한 링크 업데이트가 쇄도할 수도 있습니다. 실제로 적용되려면 링크 상태 데이터가 조직의 모든 서버에 브로드캐스트되어야 합니다. 또한 상태가 변경되면 전체 링크 상태 테이블이 다시 브로드캐스트되어 대량의 데이터가 네트워크에 전송될 수 있습니다. 이러한 상황에서는 링크 상태 부 변경을 억제하는 것이 좋습니다. SuppressStateChanges 레지스트리 항목은 링크 상태 부 변경을 억제하는 데 사용되는 사용자 지정 구성 설정입니다. SuppressStateChanges가 0보다 크게 설정되면 Exchange Server 컴퓨터의 모든 링크 상태 변경이 억제됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\RESvc\Parameters를 탐색합니다.

  3. SuppressStateChanges 레지스트리 키를 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. 변경을 적용하려면 SMTP(Simple Mail Transfer Protocol), Microsoft Exchange Routing Engine 및 Microsoft Exchange MTA Stacks 서비스를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

SuppressStateChanges 레지스트리 값에 대한 자세한 내용은 다음 Microsoft 가이드를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)

  • Exchange Server 2003 성능 및 확장성 가이드 (http://go.microsoft.com/fwlink/?LinkId=47576)


메일 그룹 배달 제한이 설정된 라우팅 그룹 커넥터
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에서 검색된 각 라우팅 그룹 커넥터 개체(msExchRoutingGroupConnector)의 다음 특성을 쿼리하여 배달 제한이 메일 그룹 구성원을 기반으로 설정되었는지 확인합니다.

dLMemRejectPerms | 해당 구성원이 이 라우팅 그룹 커넥터를 통해 메일을 보낼 수 없는 메일 그룹(DL)의 도메인 이름(DN)을 포함합니다.
dLMemSubmitPerms | 해당 구성원이 이 라우팅 그룹 커넥터를 통해 메일을 보낼 수 있는 메일 그룹(DL)의 도메인 이름(DN)을 포함합니다.

메일 그룹 구성원을 기반으로 배달 제한이 설정된 라우팅 그룹 커넥터가 있는 경우 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 메일 그룹 구성원을 기반으로 하는 배달 제한이 Exchange 메일 흐름 성능에 영향을 줄 수 있음을 나타냅니다.

메일 그룹 구성원을 기반으로 배달 제한이 설정된 라우팅 그룹 커넥터를 사용하여 메일을 보내는 경우 메시지 분류기가 메일 그룹의 구성원을 확장하고 구성원의 전체 DN 목록을 가져온 다음 DN 목록을 보낸 사람의 DN 목록과 비교해야 합니다. 두 목록의 DN이 일치할 경우 액세스 작업이나 거부 작업이 수행됩니다. 메일 그룹이 다른 메일 그룹에 중첩된 경우 중첩 메일 그룹도 확장됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  • Microsoft 기술 자료 문서 329171, "XADM: Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)의 지시에 따라 커넥터 제한의 전용 라우팅 그룹을 디자인하고 로컬 라우팅 그룹에 대해 구성합니다.

  • 보다 강력한 전용 글로벌 카탈로그 서버를 커넥터에 대해 지정된 브리지헤드 서버로 사용합니다.

  • Microsoft 기술 자료 문서 812298, "Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)의 지시에 따라 메일 그룹이 아닌 개별 사서함에 배달 제한을 구성합니다.

  • SMTP(Simple Mail Transfer Protocol) 보낸 사람 필터링을 구현합니다.

  • Exchange Server 2003 서비스 팩 2(SP2) 이후 버전을 실행하는 서버의 경우 비계층 제한 검사를 구현합니다. Exchange 2003 SP2 이전 버전의 Exchange를 실행하는 서버의 경우 Exchange 2003 SP2로 업그레이드합니다.

자세한 정보

비계층 제한 검사에 대한 자세한 내용은 비계층적인 제한 검사를 고려합니다.를 참조하십시오.

SMTP 보낸 사람 필터링에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=72967)의 "보낸 사람 필터링 사용 설정 방법"을 참조하십시오.

메일 그룹 제한이 Exchange 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 329171 " XADM: Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)

  • 895407 "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 839949 "Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)


라우팅 그룹 마스터가 삭제되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 각 라우팅 그룹 컨테이너의 msExchRoutingMasterDN 특성 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchRoutingMasterDN 특성 값에 "DEL:"이라는 문자열이 들어 있는 경우 오류를 표시합니다.

msExchRoutingMasterDN 특성은 각 라우팅 그룹의 라우팅 그룹 마스터 역할을 수행하는 Exchange Server 컴퓨터의 고유 이름을 저장하는 단일값 특성입니다. "DEL:" 문자열이 있으면 이전의 라우팅 그룹 마스터가 Active Directory 사용자 및 컴퓨터 도구를 사용하여 삭제되었다는 것을 나타낼 수 있습니다. 라우팅 그룹 마스터가 없으면 Exchange는 라우팅 토폴로지를 제대로 업데이트하거나 유지 관리할 수 없습니다.

라우팅 그룹을 만들 때 라우팅 그룹의 첫 번째 서버에는 라우팅 그룹 마스터 역할이 할당됩니다. 라우팅 그룹 마스터는 해당 라우팅 그룹에 대한 현재 링크 상태 정보를 유지하고 그 정보를 라우팅 그룹 내의 다른 서버로 전파합니다. 라우팅 그룹 마스터는 해당 라우팅 그룹에 대해 Active Directory에 기록된 라우팅 구성만 모니터링합니다. 구성원 서버는 커넥터 상태 또는 서버 가용성 정보를 라우팅 그룹 마스터로 전송할 수 있습니다. 예를 들어 구성원 서버가 커넥터를 통해 다른 라우팅 그룹에 있는 다른 서버와 접속하려고 시도하지만 이 링크를 사용할 수 없는 경우 구성원 서버는 즉시 라우팅 그룹 마스터에 알립니다. 마찬가지로 마스터가 아닌 서버는 새로운 링크 상태 정보를 받을 경우 즉시 커넥터 상태 정보를 라우팅 그룹 마스터로 전송하므로 다른 서버가 라우팅 변경에 대한 정보를 받을 수 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager의 관리 그룹에서 Administrative_Group을 확장한 다음 라우팅 그룹을 확장합니다.

  2. 라우팅 그룹을 확장한 다음 구성원을 클릭합니다.

  3. 오른쪽 창에서 라우팅 그룹 마스터로 구성할 Exchange 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 마스터로 설정을 클릭합니다.

라우팅 그룹 마스터에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?linkid=47579)의 "라우팅 토폴로지 구성"을 참조하십시오.


라우팅 그룹 구성원 오류
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-21

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에서 Routing Group 개체의 각 msExchRoutingGroupMembersBL 특성 값을 쿼리하여 백 링크 서버가 전용 Microsoft Exchange Server 2007 관리 그룹 Exchange 관리 그룹(FYDIBOHF23SPDLT)에 속하는지 확인합니다.

또한 Exchange Server Analyzer는 Routing Group 개체의 CN 특성 값을 쿼리하여 값이 Exchange 2007 라우팅 그룹 기본값 Exchange 라우팅 그룹(DWBGZMFD01QNBJR)과 같은지 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 오류를 표시합니다.

  • 백 링크 서버가 전용 Exchange Server 2007 관리 그룹 Exchange 관리 그룹(FYDIBOHF23SPDLT)에 속해 있습니다.

  • 라우팅 그룹이 Exchange 2007 라우팅 그룹 기본값 Exchange 라우팅 그룹(DWBGZMFD01QNBJR)이 아닙니다.

이 오류는 서버가 수동으로 Exchange 2007 기본 라우팅 그룹에서 이동되었을 수 있음을 나타냅니다. 이로 인해 라우팅 문제가 발생할 수 있습니다.

Microsoft Exchange Server 2003 및 Microsoft Exchange 2000 Server는 라우팅 그룹을 사용하여 Exchange별 라우팅 토폴로지를 정의합니다. Exchange 2007은 Active Directory 사이트를 사용하여 라우팅 토폴로지를 정의합니다. Exchange 2003 및 Exchange 2000은 라우팅 그룹과 커넥터를 기반으로 하는 라우팅 토폴로지를 사용합니다. 단순 Exchange 2007 조직에서는 더 이상 Exchange별 라우팅 구성이 필요하지 않습니다. 단순 Exchange 2007 조직은 Active Directory 사이트 토폴로지를 사용하여 라우팅 토폴로지를 결정합니다.

이러한 두 라우팅 토폴로지의 동시 사용을 지원하기 위해 Exchange 2007을 설치할 때 자동으로 모든 Exchange 2007 서버가 단일 라우팅 그룹에 추가됩니다. Exchange 2007 라우팅 그룹은 Exchange 2003 또는 Exchange 2000의 Exchange System Manager에서 Exchange 관리 그룹(FYDIBOHF23SPDLT) 내의 Exchange 라우팅 그룹(DWBGZMFD01QNBJR)으로 인식됩니다.

이 문제를 해결하려면 Exchange 2007 서버를 Exchange 2007 전용 라우팅 그룹으로 이동하거나 서버를 제거한 다음 다시 설치합니다.


송신 커넥터를 사용하지 않도록 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-07-30

Microsoft Exchange Analyzer Tool은 다음 Exchange 관리 셸 cmdlet를 사용하여 Exchange 환경에서 Enabled 특성 값이 False로 설정된 모든 송신 커넥터를 쿼리합니다. 송신 커넥터 Enabled 특성 값이 False이면 해당 송신 커넥터를 사용하지 않도록 설정되어 있음을 나타냅니다.

Get-SendConnector | where { $_.Enabled -eq $False}

송신 커넥터를 쿼리한 다음 Exchange Analyzer는 Active Directory 디렉터리 서비스를 쿼리해 개체 클래스가 msExchExchangeServer인 모든 개체의 serialNumber 특성 값을 확인합니다.

문자열 값에 Version 5.5가 포함되어 있으면 컴퓨터에서 Microsoft Exchange Server 5.5가 실행되고 있는 것입니다. 문자열 값에 Version 6.0이 있으면 컴퓨터에서 Exchange 2000 Server가 실행 중입니다. 문자열 값에 Version 6.5가 있으면 컴퓨터에서 Exchange Server 2003이 실행 중이며, Version 8이 있으면 Exchange Server 2007이 실행 중인 것입니다.

Exchange Analyzer는 Exchange 2000 또는 Exchange 2003 서버도 있는 Exchange 환경에서 송신 커넥터를 사용하지 않도록 설정되어 있으면 오류를 표시합니다.

이 오류는 Exchange 2007 라우팅은 사용하지 않도록 설정된 송신 커넥터를 무시하지만 Exchange 2000 및 Exchange 2003은 해당 커넥터에 대한 사용 안 함 플래그를 인식하지 못하고 해당 커넥터를 통해 계속 메시지를 라우팅하여 결국 라우팅 루프가 발생한다는 것을 의미합니다.

이 오류를 해결하려면 Exchange 2000 또는 Exchange 2003이 실행 중인 Exchange 환경에서 사용하지 않도록 설정된 모든 송신 커넥터를 삭제하십시오.

사용하지 않도록 설정된 송신 커넥터를 삭제하려면 Exchange Server 2007 제품 설명서의 "Remove-SendConnector"(http://go.microsoft.com/fwlink/?LinkId=96007) 항목에서 Exchange 관리 셸 Remove-SendConnector cmdlet 사용 지침을 따르십시오.


보낸 사람 필터링 사용
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 가상 서버 개체의 msExchServerBindingsTurflist 속성이 SMTP 가상 서버 인스턴스에 대해 보낸 사람 필터링을 사용함을 나타내는지 확인합니다.

또한 Exchange Server Analyzer는 Active Directory를 쿼리하여 msExchTurfListNames 또는 msExchTurfListOptions 속성이 전역 설정 수준에서 보낸 사람 필터링을 사용함을 나타내는지 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고를 표시합니다.

  • SMTP 가상 서버 인스턴스에서 보낸 사람 필터링을 사용하는 경우

  • 글로벌 설정 수준에서 보낸 사람 필터링을 사용하는 경우

이 경고는 보낸 사람 필터링이 사용되고 있음을 나타냅니다. 이 특정 서버와 관련된 메일 흐름 문제를 해결하는 경우가 아니면 일반적으로 보낸 사람 필터링은 문제가 되지 않습니다. 이러한 경우 필터 구성을 확인하거나 보낸 사람 필터링을 일시적으로 사용 불가능하게 하여 유효한 보낸 사람으로부터 받은 합법적 메일이 잘못 차단되고 있는지 여부를 확인합니다.

SMTP 가상 서버에서 보낸 사람 필터를 비활성화하려면 다음을 수행합니다.

  1. 시작을 클릭하고 모든 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭하여 Exchange System Manager를 시작합니다.

  2. 콘솔 트리에서 서버, 원하는 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. 필터를 비활성화할 SMTP 가상 서버를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  4. <SMTP 가상 서버> 속성의 일반 탭에서 고급을 클릭합니다.

  5. 고급에서 필터를 비활성화할 IP 주소를 선택하고 편집을 클릭합니다.

  6. 확인에서 보낸 사람 필터 적용 확인란의 선택을 취소하여 필터를 비활성화합니다.

  7. 가상 서버가 여러 개인 경우 필터를 비활성화할 가상 서버 각각에 대해 3단계부터 6단계까지 반복합니다.

지능형 메시지 필터링에 대한 자세한 내용은 Exchange Intelligent Message Filter 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21607)를 참조하십시오.

스팸 메일 필터링 및 제어 구성 방법은 Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "스팸 메일 필터링 및 제어 구성"을 참조하십시오.


보낸 사람 ID 필터링 사용
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 가상 서버 개체의 msExchServerBindingsFiltering 속성이 SMTP 가상 서버 인스턴스에 대해 보낸 사람 ID 필터링을 사용함을 나타내는지 확인합니다.

또한 Exchange Server Analyzer는 Active Directory를 쿼리하여 UCE 콘텐츠 필터 개체의 wWWHomePage 특성에 보낸 사람 ID 및 연결 필터링 항목이 포함되어 있는지 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고를 표시합니다.

  • SMTP 가상 서버 인스턴스에서 보낸 사람 필터링을 사용하는 경우

  • UCE 콘텐츠 필터 개체 수준에서 보낸 사람 필터링을 사용하는 경우

이 경고는 보낸 사람 ID 필터링이 사용되고 있음을 나타냅니다. 이 특정 서버와 관련된 메일 흐름 문제를 해결하는 경우가 아니면 일반적으로 보낸 사람 ID 필터링은 문제가 되지 않습니다. 이러한 경우 필터 구성을 확인하거나 보낸 사람 ID 필터링을 일시적으로 비활성화하여 올바른 보낸 사람이 보낸 메일을 잘못 차단하고 있는지 확인할 수 있습니다.

SMTP 가상 서버에서 보낸 사람 ID 필터를 비활성화하려면 다음을 수행합니다.

  1. 시작을 클릭하고 모든 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭하여 Exchange System Manager를 시작합니다.

  2. 콘솔 트리에서 서버, 원하는 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. 필터를 비활성화할 SMTP 가상 서버를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  4. <SMTP 가상 서버> 속성의 일반탭에서 고급을 클릭합니다.

  5. 고급에서 필터를 비활성화할 IP 주소를 선택하고 편집을 클릭합니다.

  6. 확인에서 보낸 사람 필터 적용 확인란의 선택을 취소하여 필터를 비활성화합니다.

  7. 가상 서버가 여러 개인 경우 필터를 비활성화할 가상 서버 각각에 대해 3단계부터 6단계까지 반복합니다.

지능형 메시지 필터링에 대한 자세한 내용은 Exchange Intelligent Message Filter 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21607)를 참조하십시오.


일반 대상으로 식별된 서버
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-04

Microsoft® Exchange Server Analyzer Tool은 Exchange_Queue WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP 가상 서버의 SMTP(Simple Mail Transfer Protocol) 큐에 대한 다음 특성 값을 확인합니다.

LinkId | 큐를 포함한 링크의 식별자를 나타냅니다.
QueueId | 큐의 식별자를 나타냅니다.
QueueName | 큐의 이름을 나타냅니다.
VirtualMachine | 큐를 포함한 가상 컴퓨터의 이름을 나타냅니다.
VirtualServerName | 큐가 있는 가상 서버의 이름을 나타냅니다.
MessageCount | 큐에 있는 메시지 수를 나타냅니다.

Exchange Server Analyzer는 여기서 얻은 정보를 사용해 Exchange_QueuedSMTPMessage WMI 클래스를 쿼리하여 큐에 있는 메시지의 다음 특성 값을 확인합니다.

Recipients | 메시지를 받는 사람을 나타냅니다.
Received | 메시지를 받은 타임 스탬프를 나타냅니다.
MessageId | 큐에 대기 중인 메시지의 식별자를 나타냅니다.
StateRetry | 제대로 배달되지 않은 메시지에 대해 다시 전송을 시도하는 상태임을 나타냅니다.

마지막으로 Exchange Server Analyzer는 여기서 얻은 데이터를 사용해 Active Directory® 디렉터리 서비스를 쿼리하여 각 받는 사람 개체의 다음 값을 확인합니다. 그런 다음 받는 사람이 사용자인지, 메일 그룹인지, 공용 폴더인지, 공용 폴더 저장소인지를 확인합니다.

distinguishedName | 개체의 고유 이름을 나타냅니다.
msExchHomeServerName | 받는 사람이 상주하고 있는 서버를 나타냅니다.
homeMDB | 받는 사람의 사서함 저장소를 나타냅니다.

Exchange Server Analyzer는 큐에 대기 중인 메시지 중 적어도 25퍼센트 이상이 To: 또는 Cc: 필드의 특정 서버에 있는 받는 사람에게 배달되는 경우에 경고를 표시합니다.

Exchange Server Analyzer는 큐에 대기 중인 메시지 중 적어도 50퍼센트 이상이 To: 또는 Cc: 필드의 특정 서버에 있는 받는 사람에게 배달되는 경우에는 오류를 표시합니다.

이러한 경고 또는 오류는 식별된 서버가 SMTP 큐에 대기 중인 메시지의 일반 대상임을 의미합니다.

이 문제를 해결하려면 서버에 구성 문제나 메시지가 큐에 대기되도록 하는 기타 예외적인 문제가 있는지 확인해야 합니다.

  • 서버 특성이 올바르게 설정되어 있고 Active Directory에 올바른 값이 포함되어 있는지 확인합니다.

  • 서버 개체의 Active Directory 사용 권한이 올바르게 설정되어 있는지 확인합니다.

  • 서버가 지정한 저널링 받는 사람과 같은 특별한 용도의 사용자 개체의 홈 서버인 경우, 사용자 개체가 연관된 서비스나 구성 요소의 구성이 올바른지 확인합니다.

  • 공용 폴더에 대한 UCE(원치 않는 상업성 전자 메일 메시지)나 스팸 또는 바이러스 공격이 있는지 확인합니다.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 전송 및 라우팅 가이드의 "메일 흐름 및 SMTP 문제 해결"(http://go.microsoft.com/fwlink/?LinkID=67875)

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

메일 그룹 제한이 Exchange Server 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 895407, "Exchange Server 2003에서 메일 그룹을 기반으로 배달 제한을 구성하면 로컬 사서함이나 외부 사서함으로의 메시지 배달이 예측한 것보다 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 329171 " XADM: 그룹 구성원별로 배달 제한을 받도록 받는 사람을 구성하면 메일 배달이 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)

  • 839949, "Exchange 2000 Server 및 Exchange Server 2003의 메일 전송 및 메일 그룹 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)

  • 812298, "메일 그룹을 기반으로 배달 제한을 구성하면 메일 배달이 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)


싱크 등록을 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-01-11

Microsoft® Exchange Server Analyzer Tool은 Microsoft 인터넷 정보 서비스(IIS) 메타베이스를 쿼리하여 SMTP(Simple Mail Transport Protocol) 전송 이벤트 싱크 바인딩 목록을 열거합니다. Exchange Server Analyzer는 미리 채워진 목록을 기반으로 여러 표준 이벤트 바인딩을 찾습니다. Exchange Server Analyzer는 각 바인딩에 대해 다음 분기의 레지스트리에서 COM(구성 요소 개체 모델) 등록 세부 정보를 확인합니다.

HKEY_CLASSES_ROOT\CLSID\

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고 메시지를 표시합니다.

  • 전송 이벤트 싱크 바인딩이 메타베이스에서 발견되었습니다.

  • 해당 COM 등록이 레지스트리에 없습니다.

메시지 데이터가 SMTP 서비스로 전송되거나 SMTP 서비스에서 전송되는 경우 SMTP 전송 이벤트가 발생합니다. 모든 메시지는 이벤트를 거칩니다. 여기에는 X.400와 RPC 받는 메시지 또는 보내는 메시지가 포함됩니다. 인바운드 전송 이벤트의 일반적인 예로는 네트워크를 통하거나 SMTP 픽업 디렉터리에 있는 SMTP 서비스에 메시지가 도착하는 것을 들 수 있습니다. 이러한 전송 이벤트가 발생하면 이 이벤트의 원본은 메시지의 데이터 내용을 기반으로 작업의 일부 유형을 수행할 수 있는 전송 이벤트 싱크를 알려 줍니다. 시스템에서 메시지 데이터를 싱크에 전달한 다음에는 싱크가 작업을 완료하고 메시지를 반환할 때까지 메시지 데이터에 다른 작업을 수행하지 않습니다. 싱크는 메시지 데이터 및 이러한 작업을 수행하는 동안의 상태를 독점적으로 제어합니다.

전송 이벤트 싱크 바인딩에 대한 COM 등록이 없어지면 메일 흐름에 문제가 생길 수 있습니다. Exchange Server에서 메시지 큐와 같은 메일 흐름 문제가 나타나는 경우 전송 이벤트 싱크를 다시 등록합니다.

전송 이벤트 싱크를 다시 등록하려면 다음을 수행합니다.

  1. Microsoft Exchange Server에서 명령 프롬프트 창을 열고 \Program Files\Exchsrvr\Bin 폴더로 변경합니다.

  2. 다음 명령을 입력하여 전송 이벤트 싱크를 다시 등록합니다.

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. Exchange Server Analyzer를 다시 실행하여 경고가 더 이상 표시되지 않는지 확인합니다. 이벤트 싱크 등록 경고가 계속 나타나고 메일 흐름에 문제가 있으면 Microsoft 기술 지원 서비스(PSS)에 문의하십시오.

전송 이벤트 싱크 바인딩에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Microsoft 기술 자료 문서 258224, "XCON: Enumerating the Registered Transport Event Sinks"(http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224)

  • Exchange Server 2003 기술 참조 가이드(http://go.microsoft.com/fwlink/?LinkId=58876)의 "SMTP 서비스 디자인"


SMTP 가상 서버에 스마트 호스트가 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 특정 SMTP 가상 서버에 msExchSmtpSmartHost 특성이 구성되어 있는지 여부를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 msExchSmtpSmartHost 특성이 구성되어 있는 경우 경고를 표시합니다.

SMTP 가상 서버에 스마트 호스트를 구성하는 것은 권장하지 않습니다. 대신 SMTP 커넥터를 만들고 해당 커넥터에 스마트 호스트 설정을 구성해야 합니다.

Exchange Server 2003에서 인터넷 메일 마법사를 사용하여 인터넷 메일 배달을 구성합니다. 자세한 내용은 Exchange Server Transport and Routing Guide에서 "How to Use Internet Mail Wizard"(http://go.microsoft.com/fwlink/?LinkId=50099)를 참조하십시오.

SMTP 커넥터를 만드는 방법은 Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=50100)에서 "SMTP 커넥터 생성 방법"을 참조하십시오.


SMTP AdditionalPoolThreadsPerProc 레지스트리 값이 수동으로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 추가 풀 스레드가 수동으로 구성되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\AdditionalPoolThreadsPerProc

Exchange Server Analyzer는 AdditionalPoolThreadsPerProc 값이 존재하며 구성되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

SMTP에는 ATQ 스레드로 알려진 스레드 풀을 사용하는 다섯 개의 작업 큐가 있습니다. 기본적으로 이러한 큐 중 두 개가 사용 가능한 스레드의 90% 이상을 사용합니다. 이 스레드 풀은 POP 및 IMAP 요청을 수락하는 프로세스에 의해 공유됩니다. 따라서 로드가 보통 이상인 경우 SMTP가 POP과 IMAP 서비스의 리소스를 차지하는 상황이 발생할 수 있습니다.

SMTP에서 사용할 수 있는 스레드의 비율을 제한하여 POP 및 IMAP용으로 스레드를 적절히 예약할 수 있습니다. 이렇게 변경하려면 IIS에 사용할 수 있는 전체 스레드 수를 늘립니다. 다만 이때 추가 스레드 확보를 위해 메모리 사용량이 증가한다는 문제가 있습니다.

다음 두 가지 레지스트리 값을 사용하여 스레드의 SMTP 백분율과 프로세서당 추가 스레드 수를 제어할 수 있습니다.

위치: HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

값: AdditionalPoolThreadsPerProc

종류: REG_DWORD

위치: HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

값: MaxPercentPoolThreads

종류: REG_DWORD

SMTP 작업량이 많아 POP3, IMAP4 중 하나 또는 두 리소스 모두 실패하면 클러스터된 Exchange Server 컴퓨터에서 두 레지스트리 값 모두를 조정해야 합니다. 다음 수식을 사용하여 클러스터에 대한 최적의 값을 계산할 수 있습니다.

레지스트리 값 | 수식
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * 프로토콜 가상 서버 수)

예를 들어 두 개의 프로토콜 가상 서버가 포함되어 있는 Exchange Server 클러스터에서 MaxPercentPoolThreads의 수식은 90 / (2*2) = 22입니다. MaxPercentPoolThreads 값의 계산 결과가 소수점이 포함된 값이면 결과 값에서 소수점 이하 부분을 버리고 정수로 표시합니다. AdditionalPoolThreadsPerProc 값의 계산 결과가 200보다 큰 값이면 결과 값을 추가 레지스트리 값에 할당해야 합니다.

위치: HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

값: PoolThreadLimit

종류: REG_DWORD

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Exchange 클러스터에 대한 최적의 설정을 구성하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters를 탐색합니다.

  3. AdditionalPoolThreadsPerProc라는 DWORD 레지스트리 값을 만들고 해당 값 데이터를 위의 수식에 따른 적절한 값으로 설정합니다.

  4. MaxPercentPoolThreads라는 DWORD 레지스트리 값을 만들고 해당 값 데이터를 위의 수식에 따른 적절한 값으로 설정합니다.

  5. 레지스트리 편집기를 닫고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

이 문서에서 설명하는 특정 클러스터 리소스 문제에 대한 자세한 내용은 Microsoft기술 자료 문서 281868, "XADM: POP\IMAP4 Virtual Servers Repeatedly Fail Over Under High Load"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868)를 참조하십시오.


SMTP 보관 싱크: 보관 P1 헤더가 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP 보관 싱크가 설치되어 사용되고 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Dump P1

Exchange Server Analyzer는 Dump P1 값이 0보다 클 경우 기본 구성이 아니라는 메시지를 표시합니다.

0 값은 P1 헤더 보관을 사용하지 않음을 나타냅니다. 1 값은 P1 헤더 보관을 사용함을 나타냅니다. 0 또는 1 이외의 값은 지원되지 않습니다.

SMTP 보관 싱크 도구는 Exchange 서버의 특정 폴더에서 들어오고 나가는 모든 메시지를 보관할 수 있는 사용자 지정 스크립트입니다. 기본적으로 SMTP 보관 싱크를 사용하는 경우에는 모든 메시지와 해당 받는 사람이 .eml 파일에 보관됩니다. 단, 숨은 참조의 경우는 제외됩니다.

P1 헤더를 "봉투" 데이터라고도 합니다. 봉투 데이터는 메시지가 모든 받는 사람에게 도달할 수 있도록 전송 과정에서 메시지로 생성되는 실제 받는 사람 목록입니다. 받은 메일의 일부에서 보낸 사람에 의해 선언된 받는 사람인 P2 헤더와 달리 봉투 데이터는 대상으로 전달되는 과정에서 변경됩니다. 이러한 변경은 메일 그룹 확장과 숨겨진 메일 그룹 동작 때문에 발생합니다.

SMTP 보관 싱크를 설치하고 사용할 때 기본적으로 P1 헤더가 보관되지 않습니다. 일반적으로 P1 헤더 보관은 문제 해결을 위해서만 사용합니다.

이 Exchange 컴퓨터에서 P1 헤더를 보관하지 않으려면 Dump P1 레지스트리 키를 0으로 설정하거나 SMTP 보관 싱크를 제거합니다. SMTP 보관 싱크를 제거하면 SMTP 보관 싱크에서 사용하는 모든 레지스트리 키가 삭제됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

P1 헤더 보관을 사용하지 않으려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1을 탐색합니다.

  3. Dump P1 레지스트리 키를 두 번 클릭하고 값 데이터 필드에 0을 입력한 다음 확인을 클릭합니다.

  4. 레지스트리 편집기를 닫고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

SMTP 보관 싱크를 제거하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 cmd를 입력한 다음 확인을 클릭합니다.

  2. C:\Program Files\Exchsrvr\bin 폴더에서 cscript archivesink_setup.vbs를 입력한 다음 Enter 키를 누릅니다.

  3. cscript archivesink_setup.vbs uninstall Virtual Server ID를 입력합니다. 여기서 Virtual Server ID는 SMTP 보관 싱크가 설치되어 있는 가상 서버의 가상 서버 번호입니다.

  4. 명령 프롬프트 창을 끝내고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server 2003에서 SMTP 보관 싱크를 설정하고 구성하는 방법에 대한 자세한 내용은 기술 자료 문서 871110, "How to install and use the Archive Sink utility in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)을 참조하십시오.

Exchange 2000 Server에서 SMTP 보관 싱크를 설정하고 구성하는 방법에 대한 자세한 내용은 기술 자료 문서 307798, "The Archive Sink utility is available in Service Pack 2"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)를 참조하십시오.

규정 준수 목적의 포괄적인 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581)을 참조하십시오.


SMTP 보관 싱크를 사용합니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP 보관 싱크가 설치되어 사용되고 있는지 확인합니다.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable Smtp Messages

Exchange Server Analyzer는 Enable Smtp Messages 값이 0보다 클 경우 기본 구성이 아니라는 메시지를 표시합니다.

0 값은 SMTP 보관 싱크를 사용하지 않음을 나타냅니다. 1 값은 SMTP 보관 싱크를 사용함을 나타냅니다. 0 또는 1 이외의 값은 지원되지 않습니다.

SMTP 보관 싱크 도구는 Exchange 서버의 특정 폴더에서 들어오고 나가는 모든 메시지를 보관할 수 있는 사용자 지정 스크립트입니다. 기본적으로 SMTP 보관 싱크를 사용하는 경우에는 모든 메시지와 해당 받는 사람이 .eml 파일에 보관됩니다. 단, 숨은 참조의 경우는 제외됩니다.

기본적으로 SMTP 보관 싱크의 SMTP 보관을 사용하면 SMTP(Simple Mail Transfer Protocol), Exchange 저장소 또는 이 이벤트를 트리거하는 다른 모든 싱크에 의해 모든 메시지가 전송하도록 제출됩니다. 이론적으로 이 이벤트는 각 메시지에 대해 한 번씩 발생할 수 있으며 이 이벤트를 한 번만 보관할 수 있습니다. OnMessageSubmission 이벤트는 라우팅 또는 분류기 이벤트보다 앞서 발생합니다. 따라서 이러한 메시지를 PreCat 메시지라고 합니다. 기본적으로 SMTP 보관 싱크 도구를 설치하면 이 이벤트에 대한 메시지가 보관됩니다. 이 이벤트에 대해 보관된 메시지에는 파일 이름 접두사가 붙습니다(예: ARCH_random number.xml).

이 Exchange 컴퓨터에서 메시지를 보관하지 않으려면 Enable Smtp Messages 레지스트리 키를 0으로 설정하거나 SMTP 보관 싱크를 제거합니다. SMTP 보관 싱크를 제거하면 SMTP 보관 싱크에서 사용하는 모든 레지스트리 키가 삭제됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

SMTP 보관 싱크를 사용하지 않으려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1을 탐색합니다.

  3. Enable Smtp Messages 레지스트리 키를 두 번 클릭하고 값 데이터 필드에 0을 입력한 다음 확인을 클릭합니다.

  4. 레지스트리 편집기를 닫고 IIS Admin Service를 다시 시작하여 변경 내용을 적용합니다.

SMTP 보관 싱크를 제거하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 cmd를 입력한 다음 확인을 클릭합니다.

  2. C:\Program Files\Exchsrvr\bin 폴더에서 cscript archivesink_setup.vbs를 입력한 다음 Enter 키를 누릅니다.

  3. cscript archivesink_setup.vbs uninstall Virtual Server ID를 입력합니다. 여기서 Virtual Server ID는 SMTP 보관 싱크가 설치되어 있는 가상 서버의 가상 서버 번호입니다.

  4. 명령 프롬프트 창을 끝내고 IIS Admin Service를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server 2003에서 SMTP 보관 싱크를 설정하고 구성하는 방법에 대한 자세한 내용은 기술 자료 문서 871110, "How to install and use the Archive Sink utility in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)을 참조하십시오.

Exchange 2000 Server에서 SMTP 보관 싱크를 설정하고 구성하는 방법에 대한 자세한 내용은 기술 자료 문서 307798, "The Archive Sink utility is available in Service Pack 2"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)를 참조하십시오.

규정 준수 목적의 포괄적인 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581)을 참조하십시오.


SMTP 보관 싱크: 분류 작업 이후 설정
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP 보관 싱크를 설치하여 사용하고 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PostCat

Enable PostCat 값이 0보다 크면 Exchange Server Analyzer에서 기본 구성이 아니라는 메시지를 표시합니다.

값 0은 분류 작업 이후 메시지 보관이 사용되지 않음을 나타냅니다. 값 1은 분류 작업 이후 메시지 보관이 사용됨을 나타냅니다. 0 또는 1 이외의 값은 지원되지 않습니다.

SMTP 보관 싱크 도구는 Exchange 서버의 특정 폴더에서 들어오고 나가는 모든 메시지를 보관할 수 있는 사용자 지정 스크립트입니다. 기본적으로 SMTP 보관 싱크를 사용하는 경우에는 모든 메시지와 해당 받는 사람이 .eml 파일에 보관됩니다. 단, 숨은 참조의 경우는 제외됩니다.

Enable PostCat가 1로 설정되면 메시지 분류가 수행된 후에 메시지가 보관됩니다. 메시지는 이 이벤트를 한 번 이상 트리거할 수 있지만 메시지가 분류되고 대기된 후 다시 열거된 경우에만 이 작업을 수행할 수 있습니다. 이 이벤트에 대해 보관된 메시지에는 접두사 파일 이름 ARCH_POSTCAT_random number.xml이 포함됩니다.

이 Exchange 컴퓨터에 분류 작업 이후의 메시지를 보관하지 않으려면 Enable PostCat 레지스트리 키를 0으로 설정하면 됩니다. 이 컴퓨터에 아무것도 보관하지 않으려면 SMTP 보관 싱크를 제거합니다. SMTP 보관 싱크를 제거하면 SMTP 보관 싱크에서 사용하는 모든 레지스트리 키가 삭제됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

분류 작업 이후 메시지 보관을 사용하지 않으려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1을 탐색합니다.

  3. Enable PostCat 레지스트리 키를 두 번 클릭하고 값 데이터 필드에 0을 입력한 다음 확인을 클릭합니다.

  4. 레지스트리 편집기를 끝내고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

SMTP 보관 싱크를 제거하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 cmd를 입력한 다음 확인을 클릭합니다.

  2. C:\Program Files\Exchsrvr\bin 폴더에서 cscript archivesink_setup.vbs를 입력한 다음 Enter 키를 누릅니다.

  3. cscript archivesink_setup.vbs uninstall Virtual Server ID를 입력합니다. 여기서 Virtual Server ID는 SMTP 보관 싱크가 설치되어 있는 가상 서버의 가상 서버 번호입니다.

  4. 명령 프롬프트 창을 끝내고 IIS Admin Service를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server 2003에서 SMTP 보관 싱크를 설정하고 구성하는 방법에 대한 자세한 내용은 기술 자료 문서 871110, "How to install and use the Archive Sink utility in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)을 참조하십시오.

Exchange 2000 Server에서 SMTP 보관 싱크를 설정하고 구성하는 방법에 대한 자세한 내용은 기술 자료 문서 307798, "The Archive Sink utility is available in Service Pack 2"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)를 참조하십시오.

규정 준수 목적의 포괄적인 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581)을 참조하십시오.


SMTP 보관 싱크: 분류 작업 이전 설정
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP 보관 싱크가 설치되어 사용되고 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PreCat

Exchange Server Analyzer는 Enable PreCat 값이 0보다 클 경우 기본 구성이 아니라는 메시지를 표시합니다.

값 0은 분류 작업 이전 메시지 보관이 사용되지 않음을 나타냅니다. 값 1은 분류 작업 이전 메시지 보관이 사용됨을 나타냅니다. 0 또는 1 이외의 값은 지원되지 않습니다.

SMTP 보관 싱크 도구는 Exchange 서버의 특정 폴더에서 들어오고 나가는 모든 메시지를 보관할 수 있는 사용자 지정 스크립트입니다. 기본적으로 SMTP 보관 싱크를 사용하는 경우에는 모든 메시지와 해당 받는 사람이 .eml 파일에 보관됩니다. 단, 숨은 참조의 경우는 제외됩니다.

SMTP(Simple Mail Transfer Protocol), Exchange 저장소 또는 기타 모든 싱크가 전송하려고 보낸 모든 메시지는 이 이벤트를 트리거합니다. 이론적으로 이 이벤트는 메시지마다 한 번 발생할 수 있고 한 번만 저장될 수 있습니다. OnMessageSubmission 이벤트는 라우팅 또는 분류기 이벤트 이전에 발생합니다. 따라서 이러한 메시지를 PreCat 메시지라고 합니다. 기본적으로 메시지는 SMTP 활성 싱크 유틸리티가 설치되어 있을 때 이 이벤트에 대해 저장됩니다. 이 이벤트에 대해 보관된 메시지에는 접두사 파일 이름 ARCH_random number.xml이 포함됩니다.

이 Exchange 컴퓨터에 분류 작업 이전 메시지를 보관하지 않으려면 Enable PreCat 레지스트리 키를 0으로 설정하면 됩니다. 이 컴퓨터에 아무것도 보관하지 않으려면 SMTP 보관 싱크를 제거합니다. SMTP 보관 싱크를 제거하면 SMTP 보관 싱크에서 사용하는 모든 레지스트리 키가 삭제됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

분류 작업 이전 메시지 보관을 사용하지 않으려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1을 탐색합니다.

  3. Enable PreCat 레지스트리 키를 두 번 클릭하고 값 데이터 필드에 0을 입력한 다음 확인을 클릭합니다.

  4. 레지스트리 편집기를 닫고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

SMTP 보관 싱크를 제거하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 cmd를 입력한 다음 확인을 클릭합니다.

  2. C:\Program Files\Exchsrvr\bin 폴더에서 cscript archivesink_setup.vbs를 입력한 다음 Enter 키를 누릅니다.

  3. cscript archivesink_setup.vbs uninstall Virtual Server ID를 입력합니다. 여기서 Virtual Server ID는 SMTP 보관 싱크가 설치되어 있는 가상 서버의 가상 서버 번호입니다.

  4. 명령 프롬프트 창을 끝내고 IIS Admin Service를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server 2003에서 SMTP 보관 싱크를 설정하고 구성하는 방법에 대한 자세한 내용은 기술 자료 문서 871110, "How to install and use the Archive Sink utility in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)을 참조하십시오.

Exchange 2000 Server에서 SMTP 보관 싱크를 설정하고 구성하는 방법에 대한 자세한 내용은 기술 자료 문서 307798, "The Archive Sink utility is available in Service Pack 2"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)를 참조하십시오.

규정 준수 목적의 포괄적인 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581)을 참조하십시오.


SMTP 보관 싱크: 시스템 메시지가 보관 중입니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP 보관 싱크가 설치되어 사용되고 있는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Archive System Messages

Exchange Server Analyzer는 Archive System Messages 값이 0보다 클 경우 기본 구성이 아니라는 메시지를 표시합니다.

값 0은 시스템 메시지가 보관되지 않음을 나타냅니다. 값 1은 시스템 메시지가 보관됨을 나타냅니다. 0 또는 1 이외의 값은 지원되지 않습니다.

SMTP 보관 싱크 도구는 Exchange 서버의 특정 폴더에서 들어오고 나가는 모든 메시지를 보관할 수 있는 사용자 지정 스크립트입니다. 기본적으로 SMTP 보관 싱크를 사용하는 경우에는 모든 메시지와 해당 받는 사람이 .eml 파일에 보관됩니다. 단, 숨은 참조의 경우는 제외됩니다.

이 Exchange 컴퓨터에 시스템 메시지를 보관하지 않으려면 Archive System Messages 레지스트리 키를 0으로 설정하면 됩니다. 이 컴퓨터에 아무것도 보관하지 않으려면 SMTP 보관 싱크를 제거합니다. SMTP 보관 싱크를 제거하면 SMTP 보관 싱크에서 사용하는 모든 레지스트리 키가 삭제됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

시스템 메시지 보관을 사용하지 않도록 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1을 탐색합니다.

  3. Archive System Messages 레지스트리 키를 두 번 클릭하고 값 데이터 필드에 0을 입력한 다음 확인을 클릭합니다.

  4. 레지스트리 편집기를 닫고 IIS 관리 서비스를 다시 시작하여 변경 내용을 적용합니다.

SMTP 보관 싱크를 제거하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 cmd를 입력한 다음 확인을 클릭합니다.

  2. C:\Program Files\Exchsrvr\bin 폴더에서 cscript archivesink_setup.vbs를 입력한 다음 Enter 키를 누릅니다.

  3. cscript archivesink_setup.vbs uninstall Virtual Server ID를 입력합니다. 여기서 Virtual Server ID는 SMTP 보관 싱크가 설치되어 있는 가상 서버의 가상 서버 번호입니다.

  4. 명령 프롬프트 창을 닫고 IIIIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange Server 2003에서 SMTP 보관 싱크를 설정하고 구성하는 방법에 대한 자세한 내용은 기술 자료 문서 871110, "How to install and use the Archive Sink utility in Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110)을 참조하십시오.

Exchange 2000 Server에서 SMTP 보관 싱크를 설정하고 구성하는 방법에 대한 자세한 내용은 기술 자료 문서 307798, "The Archive Sink utility is available in Service Pack 2"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798)를 참조하십시오.

규정 준수 목적의 포괄적인 저널링 솔루션을 배포하는 방법에 대한 자세한 내용은 Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581)을 참조하십시오.


SMTP BadMail 데이터가 압축된 폴더에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SMTP(Simple Mail Transfer Protocol) BadMail 폴더의 Compressed 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Compressed 값이 True로 설정되어 있을 경우 경고를 표시합니다.

SMTP 서비스를 통해 Exchange 컴퓨터에 메시지가 도착하면 해당 데이터는 하드 디스크에 .eml 파일로 기록됩니다. 기본적으로 이러한 파일은 Exchange가 설치된 것과 같은 파티션의 <drive>:\Program Files\Exchsrvr\Mailroot 폴더에 저장됩니다. SMTP badmail 데이터가 저장된 폴더에 대해 파일 압축이 설정되어 있으면 Exchange 성능이 크게 저하될 수 있습니다. 따라서 SMTP BadMail 데이터가 저장된 폴더의 압축은 지원되지 않습니다.

이 경고가 발생하면 SMTP badmail 데이터가 저장된 폴더에 대해 압축을 해제하거나 SMTP badmail 데이터를 압축되지 않은 폴더로 이동해야 합니다.

Exchange 데이터 파일은 압축된 볼륨에 저장할 수 없습니다. Exchange 데이터 파일을 압축된 볼륨에 저장하면 추가 오버헤드가 발생해 Exchange의 성능에 막대한 영향을 줍니다. Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

특정 폴더에서 파일 압축을 해제하려면 다음을 수행합니다.

  1. 파일 압축을 풀 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 내용을 압축하여 디스크 공간 절약 확인란의 선택을 해제한 다음 확인을 클릭합니다.

Exchange 2000 Server나 Exchange Server 2003에서 BadMail 폴더를 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹을 클릭하고 사용 중인 관리 그룹, 서버, 사용 중인 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 중지를 클릭합니다.

  4. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 메시지 탭에서 BadMail 디렉터리 상자 옆의 찾아보기를 클릭한 다음 Queue 폴더의 새 위치에 대한 경로를 입력합니다.

  6. 확인을 클릭합니다.

  7. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

Mailroot 폴더 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 822933, "How to change the Exchange 2003 SMTP Mailroot folder location"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)을 참조하십시오.


SMTP BadMail 데이터가 NTFS가 아닌 파티션에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange SMTP BadMail 디렉터리의 FSName 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 FSName 키 값이 NTFS와 다른 경우 경고를 표시합니다.

NTFS가 아닌 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일에는 아래의 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

이 경고가 표시되면 SMTP BadMail 디렉터리를 NTFS 파일 시스템 드라이브의 폴더로 이동해야 합니다. 또는 BadMail 디렉터리가 FAT 드라이브로 포맷된 드라이브에 저장되어 있을 경우에는 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다.

SMTP BadMail 디렉터리를 다른 폴더로 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 관리 그룹을 클릭하고 사용 중인 관리 그룹, Servers, 사용 중인 서버, Protocols, SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 중지를 클릭합니다.

  4. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 메시지 탭에서 BadMail 디렉터리 상자 옆의 찾아보기를 클릭한 다음 BadMail 폴더의 새 위치에 대한 경로를 입력합니다.

  6. 확인을 클릭합니다.

  7. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

Mailroot 폴더 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 822933, "How to change the Exchange 2003 SMTP Mailroot folder location"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)을 참조하십시오.

파일이 저장되어 있는 드라이브가 FAT 드라이브로 포맷된 경우에는 앞에서 설명한 절차 대신 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다. Convert.exe 명령줄 도구를 사용하여 FAT 파티션을 NTFS 파티션으로 변환하는 방법에 대한 자세한 내용은 기술 자료 문서 214579, "Convert.exe를 사용하여 파티션을 NTFS 파일 시스템으로 변환하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)을 참조하십시오.


SMTP BadMail 데이터가 암호화된 폴더에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SMTP BadMail 폴더의 Encrypted 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Encrypted가 True로 설정되어 있는 경우 경고를 표시합니다.

SMTP 서비스를 통해 Exchange 컴퓨터에 메시지가 도착하면 해당 데이터는 하드 디스크에 .eml 파일로 기록됩니다. 기본적으로 이러한 파일은 Exchange가 설치된 것과 같은 파티션의 <drive>:\Program Files\Exchsrvr\Mailroot 폴더에 저장됩니다. SMTP Badmail 데이터가 저장된 폴더에 대해 파일 암호화가 설정되어 있으면 Exchange 성능이 크게 저하될 수 있습니다. 따라서 SMTP BadMail 데이터가 저장된 폴더를 암호화하는 것은 지원되지 않습니다.

이 경고가 발생하면 SMTP Badmail 데이터가 저장된 폴더에 대해 암호화를 해제하거나 SMTP Badmail 데이터를 암호화되지 않은 폴더로 이동해야 합니다.

EFS(암호화 파일 시스템) 암호화 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일을 암호화된 볼륨에 저장하면 추가 오버헤드가 발생하여 Exchange의 성능에 막대한 영향을 줍니다. Exchange 데이터 파일에는 아래의 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

Exchange 데이터 파일을 보호하려면 Exchange 컴퓨터에 대한 무단 액세스를 방지하고 S/MIME 메시지 형식을 사용하여 메시지 데이터를 암호화하는 것이 좋습니다.

이 오류를 해결하려면 BadMail 폴더의 파일 암호화를 해제하거나 BadMail 폴더를 암호화가 설정되지 않은 위치로 이동해야 합니다.

지정한 폴더의 파일 암호화를 해제하려면 다음을 수행합니다.

  1. 파일 암호화를 해제할 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 데이터 보호를 위해 내용을 암호화 확인란의 선택을 해제한 다음 확인을 클릭합니다.

Exchange 2000 Server나 Exchange Server 2003에서 BadMail 폴더를 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹을 클릭하고 사용 중인 관리 그룹, 서버, 사용 중인 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 중지를 클릭합니다.

  4. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 메시지 탭에서 BadMail 디렉터리 상자 옆의 찾아보기를 클릭한 다음 Queue 폴더의 새 위치에 대한 경로를 입력합니다.

  6. 확인을 클릭합니다.

  7. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

Mailroot 폴더 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 822933, "How to change the Exchange 2003 SMTP Mailroot folder location"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)을 참조하십시오.

Exchange Server 데이터 파일과 EFS에 대한 자세한 내용은 Microsoft 기술 자료 문서 834638, "Information about the storage of data files on an encrypted volume in Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)를 참조하십시오.

Exchange Server 2003의 메시지 보안 유지 방법에 대한 자세한 내용은 Exchange Server 2003 메시지 보안 가이드(http://go.microsoft.com/fwlink/?linkid=47574)를 참조하십시오.


SMTP CatRetryMinutes 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 기본 SMTP 큐 구성이 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Exchange Server Analyzer는 CatRetryMinutes 키가 설정되었으면 기본값이 아니라는 메시지를 표시합니다.

기본 큐 값을 수정할 때는 충분히 고려한 후에 수정하는 것이 좋습니다. 대부분의 환경에서 최적의 성능을 발휘하도록 기본값을 신중하게 선택했습니다. Exchange Server의 큐 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

Exchange SMTP 큐에 대한 자세한 내용은 Microsoft Exchange 팀 블로그 항목, "Explaining the Mysterious SMTP Advanced Queuing Engine"(http://go.microsoft.com/fwlink/?LinkId=48585)을 참조하십시오.


SMTP 구성 경고
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-03

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 msExchSmtpMaxMessageSize 특성 값이 기본값 0에서 변경되었는지 여부를 확인합니다. 기본적으로 msExchSmtpMaxMessageSize 특성은 무제한의 메시지 크기를 사용하도록 구성됩니다.

Exchange Server Analyzer는 다음 조건이 존재하는 경우 경고 메시지를 표시합니다.

  • msExchSmtpMaxMessageSize 특성 값이 0이 아닙니다.

  • Exchange가 Microsoft Windows® Small Business Server 2003에서 실행되고 있지 않습니다.

msExchSmtpMaxMessageSize 특성은 주고 받을 수 있는 각 SMTP 메시지의 최대 크기를 나타냅니다. 보안 측면에서는 인터넷에서 주고 받을 수 있는 SMTP 메시지의 최대 크기를 제한하는 것이 가장 좋습니다. 그러나 같은 조직 내의 Exchange 서버 간에 주고 받는 내부 SMTP 메시지의 경우 msExchSmtpMaxMessageSize 특성을 0으로 설정해 두는 것이 좋습니다.

내부적으로 Exchange는 SMTP 메시지를 사용하여 공용 폴더 복제 등의 작업을 처리합니다. msExchSmtpMaxMessageSize 특성을 너무 낮게 구성하면 공용 폴더 복제 문제 및 기타 조직 내 메시지 배달 실패가 발생할 수 있습니다.

이 Exchange 서버가 인터넷으로 SMTP 메시지를 보내거나 인터넷에서 SMTP 메시지를 가져오는 브리지헤드 서버인 경우 이 경고를 무시해도 안전합니다. 이 Exchange 서버가 내부 SMTP 메시지를 처리하는 경우 msExchSmtpMaxMessageSize 특성 값을 다시 기본값 0으로 변경해야 합니다.

참고:
메시지 크기 제한을 너무 낮게 설정하면 Exchange Server 컴퓨터 간 오프라인 주소록 복제가 수행되지 않을 수 있습니다. 자세한 내용은 Microsoft 기술 자료 문서 326154, "Exchange 2000 Server에서 Microsoft Outlook의 오프라인 주소록을 다운로드할 수 없다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154)를 참조하십시오.
최대 SMTP 메시지 크기를 확인 및 구성하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, Exchange 서버, 프로토콜, SMTP를 차례로 확장합니다.

  2. 기본 SMTP 가상 서버 등의 SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  3. 메시지 탭을 선택합니다.

  4. 기본값 0으로 되돌리려면 메시지 크기 제한(KB) 확인란의 선택을 취소합니다. 또는 이 확인란을 선택된 상태로 두고 원하는 값을 구성합니다.

  5. 확인을 클릭하여 변경 내용을 저장하고 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686 "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


메일 그룹 배달 제한이 설정된 SMTP 커넥터
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에서 검색된 각 SMTP(Simple Mail Transfer Protocol) 커넥터 개체 msExchRoutingSMTPConnector)의 다음 특성을 쿼리하여 메일 그룹 구성원을 기반으로 설정된 배달 제한이 있는지 확인합니다.

dLMemRejectPerms | 해당 구성원이 이 SMTP 커넥터를 통해 메일을 보낼 수 없는 메일 그룹(DL)의 도메인 이름(DN)을 포함합니다.
dLMemSubmitPerms | 해당 구성원이 이 SMTP 커넥터를 통해 메일을 보낼 수 있는 메일 그룹(DL)의 도메인 이름(DN)을 포함합니다.

메일 그룹 구성원을 기반으로 배달 제한이 설정된 SMTP 커넥터가 있는 경우 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 메일 그룹 구성원을 기반으로 하는 배달 제한이 Exchange 메일 흐름 성능에 영향을 줄 수 있음을 나타냅니다.

메일 그룹 구성원을 기반으로 배달 제한이 설정된 SMTP 커넥터를 사용하여 메일을 보내는 경우 메시지 분류기가 메일 그룹의 구성원을 확장하고 구성원의 전체 DN 목록을 가져온 다음 DN 목록을 보낸 사람의 DN 목록과 비교해야 합니다. 두 목록의 DN이 일치할 경우 액세스 작업이나 거부 작업이 수행됩니다. 메일 그룹이 다른 메일 그룹에 중첩된 경우 중첩 메일 그룹도 확장됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  • Microsoft 기술 자료 문서 329171, "XADM: Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)의 지시에 따라 커넥터 제한의 전용 라우팅 그룹을 디자인하고 로컬 라우팅 그룹에 대해 구성합니다.

  • 보다 강력한 전용 글로벌 카탈로그 서버를 커넥터에 대해 지정된 브리지헤드 서버로 사용합니다.

  • Microsoft 기술 자료 문서 812298, "Mail delivery is slow after you configure delivery restrictions that are based on a distribution list"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)의 지시에 따라 메일 그룹이 아닌 개별 사서함에 배달 제한을 구성합니다.

  • SMTP 보낸 사람 필터링을 구현합니다.

  • Exchange Server 2003 서비스 팩 2(SP2) 이후 버전을 실행하는 서버의 경우 비계층 제한 검사를 구현합니다. Exchange 2003 SP2 이전 버전의 Exchange를 실행하는 서버의 경우 Exchange 2003 SP2로 업그레이드합니다.

자세한 정보

비계층 제한 검사에 대한 자세한 내용은 비계층적인 제한 검사를 고려합니다.를 참조하십시오.

SMTP 보낸 사람 필터링에 대한 자세한 내용은 Exchange Server 2003 관리 가이드(http://go.microsoft.com/fwlink/?LinkId=72967)의 "보낸 사람 필터링 사용 설정 방법"을 참조하십시오.

메일 그룹 제한이 Exchange 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 329171 " XADM: Mail Delivery Is Slow if Recipients Are Configured with Delivery Restrictions Based on Group Membership"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)

  • 895407 "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 839949 "Troubleshooting mail transport and distribution groups in Exchange 2000 Server and in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)


SMTP 도메인 다시 쓰기가 가능합니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 이 Exchange 서버의 SMTP 가상 서버 개체에 대한 heuristics 특성 값을 확인합니다. heuristics 특성 값이 기본값인 131072가 아니면 Exchange Server Analyzer에서 오류를 표시합니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

Exchange Server Address Rewrite 도구에 대한 자세한 내용은 "Exchange Server Address Rewrite"(http://go.microsoft.com/fwlink/?LinkId=25932)를 참조하십시오.


SMTP FailedMsgQRetryMinutes 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 기본 SMTP 큐 구성이 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

FailedMsgQRetryMinutes 키가 설정되어 있으면 Exchange Server Analyzer에서 기본 설정이 아니라는 메시지를 표시합니다.

기본 큐 값을 수정할 때는 충분히 고려한 후에 수정하는 것이 좋습니다. 대부분의 환경에서 최적의 성능을 발휘하도록 기본값을 신중하게 선택했습니다. Exchange Server의 큐 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

Exchange SMTP 큐에 대한 자세한 내용은 Microsoft Exchange 팀 블로그 항목, "Explaining the Mysterious SMTP Advanced Queuing Engine"(http://go.microsoft.com/fwlink/?LinkId=48585)을 참조하십시오.


SMTP LocalDeliveryMaxBatch 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 LocalDeliveryMaxBatch 레지스트리 값의 기본 설정이 변경되었는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%.

Exchange Server Analyzer는 기본 Exchange 서버 바이너리 설정인 80을 변경하여 LocalDeliveryMaxBatch 레지스트리 값이 수동으로 만들어진 경우 기본값이 아니라는 경고 메시지를 표시합니다.

기본적으로 LocalDeliveryMaxBatch 레지스트리 값은 Exchange Server 설치 시 만들어지지 않습니다. LocalDeliveryMaxBatch 레지스트리 값은 Exchange Server 설치 후 수동으로 만들어 Exchange Information Store에서 메시지를 내부적으로 처리하고 배달하는 방법을 변경할 수 있습니다. 다음 조건에 해당할 경우 Exchange 서버에 메시지 전송 및 저장소 성능 관련 문제가 발생할 수 있습니다.

  • LocalDeliveryMaxBatch 레지스트리 값이 수동으로 만들어졌습니다.

  • LocalDeliveryMaxBatch 레지스트리 값 설정이 잘못 구성되었습니다.

LocalDeliveryMaxBatch 레지스트리 값을 만들거나 수정할 때는 충분히 고려한 후에 만들거나 수정하는 것이 좋습니다. 대부분의 Exchange 서버 환경에서 최적의 성능으로 사용할 수 있도록 Exchange 서버 바이너리의 기본값을 신중하게 선택했습니다. 레지스트리를 수동으로 구성하여 Exchange Server의 기본 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다. 유용한 방법을 따르기 위해 LocalDeliveryMaxBatch 레지스트리 값이 있는 경우 이 레지스트리 값을 삭제하여 Exchange 서버를 다시 기본 바이너리 설정으로 구성할 수도 있습니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 그러나 레지스트리를 편집하여 레지스트리 값을 다시 기본 설정으로 변경할 수도 있습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
이 경고를 해결하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance% 레지스트리 키를 탐색합니다.

  3. 세부 정보 창에서 LocalDeliveryMaxBatch 레지스트리 키를 마우스 오른쪽 단추로 클릭하고 수정을 클릭한 다음 값 데이터를 80으로 변경하고 확인을 클릭합니다.

    참고:
    LocalDeliveryMaxBatch 레지스트리 값을 삭제하려면 세부 정보 창에서 LocalDeliveryMaxBatch 레지스트리 값을 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭합니다. 대화 상자에서 예를 클릭하여 레지스트리 값의 삭제를 확인합니다.

  4. 레지스트리 편집기를 닫습니다.

  5. Exchange 서버를 다시 시작합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Microsoft Windows 레지스트리 편집에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 322755, "Windows 2000에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Windows XP 및 Windows Server 2003에서 레지스트리를 백업, 편집 및 복원하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


SMTP 인스턴스의 FQDN이 DNS가 확인한 서버 이름과 다름
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-04

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 기본 SMTP(Simple Mail Transfer Protocol) 가상 서버 개체의 msExchSmtpFullyQualifiedDomainName 특성 값을 확인합니다.

또한 구성된 DNS 서버에 대해 DNS(Domain Name System) 쿼리를 시도하여 Exchange Server가 실행되고 있는 서버의 정규화된 도메인 이름(FQDN)을 확인합니다. 이 연결은 이름 확인 요청을 수행하고 결과를 분석하는 사용자 지정 개체 프로세서를 사용하여 만들어집니다.

Exchange Server Analyzer는 두 쿼리 결과를 비교하여 기본 SMTP 가상 서버 개체의 msExchSmtpFullyQualifiedDomainName 특성 값이 Exchange 서버의 DNS FQDN과 같지 않으면 경고를 표시합니다.

이 경고는 이러한 특성 값이 수동으로 변경되었음을 나타냅니다. 따라서 이렇게 변경된 값으로 인해 해당 서버에 메일 흐름 문제가 발생할 수 있습니다.

msExchSmtpFullyQualifiedDomainName 특성의 값은 SMTP 가상 서버의 FQDN을 지정하며 DNS(Domain Name System) 네트워킹 프로토콜로 해석할 수 있어야 합니다.

이 특성의 값에 대해 올바른 DNS HOST(A) 레코드가 있어야 SMTP 가상 서버의 FQDN을 해석할 메시징 서버가 올바른 IP 주소를 검색하여 메일을 제대로 라우팅할 수 있습니다.

이 경고를 해결하려면 이러한 값이 올바른 목적을 위해 의도적으로 변경된 것인지 확인해야 합니다. 만일 올바른 목적을 위해 변경된 값이라면 다음 단계 중 하나를 수행하십시오.

  • DNS FQDN과 일치하도록 msExchSmtpFullyQualifiedDomainName 특성 값을 변경합니다.

  • msExchSmtpFullyQualifiedDomainName 특성 값과 일치하도록 Exchange Server DNS FQDN을 구성합니다.

주의:
ADSI(Active Directory Service Interfaces) 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체 특성을 잘못 수정하면 심각한 문제가 발생할 수도 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
msExchSMTPFullyQualifiedDomainName 특성 값을 업데이트하려면 다음을 수행하십시오.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹, 서버, Exchange 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. 기본 SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 배달 탭을 선택한 다음 고급을 클릭합니다.

  5. 정규화된 도메인 이름 아래에 msExchSmtpFullyQualifiedDomainName 특성 값을 입력합니다.

  6. 확인을 클릭하여 변경 내용을 저장한 다음 확인을 클릭하여 SMTP 가상 서버의 속성 대화 상자를 닫습니다.
Exchange Server의 DNS FQDN을 구성하려면 다음을 수행하십시오.

  1. How to Configure Settings on the DNS Server의 안내를 따릅니다.

Exchange의 DNS 역방향 조회 기능에 대한 자세한 내용은 "Add a resource record to a DNS zone"(http://go.microsoft.com/fwlink/?LinkId=63002)을 참조하십시오.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

SMTP 서비스 디자인에 대한 자세한 내용은 Exchange Server 2003 기술 참조 가이드(http://go.microsoft.com/fwlink/?LinkId=58876)의 "SMTP Service Design" 을 참조하십시오.


아웃바운드 SMTP 커넥터가 설정되지 않은 SMTP 인스턴스
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-22

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에서 protocolCfgSMTPServer 개체 클래스의 distingushedName 특성 값을 쿼리하여 사용자 지정 Exchange 게이트웨이의 모든 SMTP(Simple Mail Transfer Protocol) 가상 서버 인스턴스를 나열합니다.

그런 다음 Exchange Server Analyzer는 Active Directory에서 검색된 각 msExchRoutingSMTPConnector 개체의 msExchSourceBridgeheadServersDN 및 routingList 특성 값을 쿼리하여 검색된 SMTP 가상 서버 인스턴스 중 하나가 SMTP 커넥터의 외부 SMTP 주소 공간에 대한 로컬 브리지헤드로 설정되어 있는지 확인합니다.

SMTP 커넥터는 메일의 격리된 경로를 지정합니다. SMTP 커넥터를 사용하여 인터넷 메일의 게이트웨이를 설정하거나 특정 도메인이나 메일 시스템에 연결할 수 있습니다. 커넥터를 사용하여 지정된 메일 경로에 대해 특정 옵션을 정의할 수 있습니다.

지정된 Exchange 게이트웨이 서버의 SMTP 가상 서버 인스턴스가 로컬 브리지헤드 서버로 설정된 SMTP 커넥터가 없는 경우 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 사용자 지정 Exchange 게이트웨이 서버 이외의 서버가 실수로 메시지를 조직 외부로 라우팅할 수 있음을 나타냅니다.

사용자 지정 Exchange 게이트웨이 서버 이외의 서버가 실수로 메시지를 조직 외부로 라우팅할 수 있는 이 상태를 방지하려면 지정된 Exchange 게이트웨이 서버의 SMTP 가상 서버 인스턴스를 브리지헤드로 지정하는 SMTP 커넥터를 만드는 것이 좋습니다.

SMTP 가상 서버만 사용하여 인터넷 메일을 보내고 받을 수도 있지만 인터넷 메일 라우팅을 위한 전용 SMTP 커넥터를 구성하는 것이 좋습니다. SMTP 커넥터는 인터넷 기반 메일에 격리된 경로를 제공하므로 SMTP 커넥터를 사용하는 것이 좋습니다. 또한 SMTP 가상 서버보다 SMTP 커넥터에 사용 가능한 구성 옵션이 더 많습니다.

SMTP 커넥터 사용 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 294736, "When to create SMTP connectors in Exchange 2000 and later"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736)를 참조하십시오.

SMTP 커넥터에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)를 참조하십시오.


SMTP LocalRetryMinutes 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 기본 SMTP 큐 구성이 변경되었는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Exchange Server Analyzer는 LocalRetryMinutes 키가 설정되어 있으면 기본값이 아니라는 메시지를 표시합니다.

기본 큐 값을 수정할 때는 충분히 고려한 후에 수정하는 것이 좋습니다. 대부분의 환경에서 최적의 성능을 발휘하도록 기본값을 신중하게 선택했습니다. Exchange의 큐 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

Exchange SMTP 큐에 대한 자세한 내용은 Microsoft Exchange 팀 블로그 항목, "Explaining the Mysterious SMTP Advanced Queuing Engine"(http://go.microsoft.com/fwlink/?LinkId=48585)을 참조하십시오.


SMTP FileCacheLifeTimeSeconds 레지스트리 값이 수동으로 추가되었지만 더 이상 필요하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 캐시에 저장된 각 인터넷 정보 서비스(IIS) 파일 핸들을 유지하는 기본 시간이 기본값 1,880초(30분)에서 수정되었는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheLifeTimeSeconds

Exchange Server Analyzer는 FileCacheLifeTimeSeconds가 존재하고 대체 값으로 구성되면 기본 구성이 아니라는 메시지를 표시합니다.

FileCacheLifeTimeSeconds 값은 캐시에 저장된 IIS 파일 핸들을 유지할 시간을 지정합니다. 파일 핸들을 캐시하면 서버가 중복 입력/출력(I/O) 및 CPU 주기를 수행하지 않아도 되므로 성능이 향상됩니다. Exchange Server 컴퓨터에서 SMTP 전송 스택이 메시지를 받을 때마다 메시지는 대상으로 라우팅되기 전에 대기할 파일 시스템으로 스트리밍됩니다. 파일 시스템에 쓰기 위해 SMTP 전송 스택은 파일 핸들을 가져와 메시지를 이 핸들에 전달합니다. 각 파일 핸들은 페이징 풀 메모리를 2KB 정도 소비합니다. 기본 IIS 캐시 파일 핸들 수는 32MB 메모리당 800개입니다.

Exchange 2000 Server 서비스 팩 2(SP2) 이상과 Exchange Server 2003은 최적의 파일 핸들 수를 캐시하도록 구성하기 때문에 기본적으로 이 레지스트리 값이 존재하지 않습니다. Exchange Server 2003에서는 SMTP 파일 핸들에 적절한 설정을 동적으로 계산하므로 이러한 설정이 더 이상 필요하지 않습니다. 따라서 이러한 설정이 있는 Exchange 2000 Server 컴퓨터를 Exchange Server 2003으로 업그레이드하기 전에 레지스트리에서 이러한 항목을 삭제해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters를 탐색합니다.

  3. 오른쪽 창에서 FileCacheLifeTimeSeconds 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


SMTP FileCacheMaxHandles 레지스트리 값을 수동으로 추가했지만 더 이상 필요하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 IIS(인터넷 정보 서비스) 파일 캐시 핸들의 최대 수가 기본값 800에서 수정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheMaxHandles

FileCacheMaxHandles가 존재하고 800이 아닌 값으로 구성되어 있으면 Exchange Server Analyzer에서 기본 구성이 아니라는 메시지를 표시합니다.

FileCacheMaxHandles 값은 Exchange에 의해 사용되는 최대 IIS 파일 핸들 수를 실제 메모리 32MB마다 지정합니다. 파일 핸들을 캐시하면 서버가 중복 입력/출력(I/O) 및 CPU 주기를 수행하지 않아도 되므로 성능이 향상됩니다. Exchange Server 컴퓨터에서 SMTP 전송 스택이 메시지를 받을 때마다 메시지는 대상으로 라우팅되기 전에 대기할 파일 시스템으로 스트리밍됩니다. 파일 시스템에 쓰기 위해 SMTP 전송 스택은 파일 핸들을 가져와 메시지를 이 핸들에 전달합니다. 각 파일 핸들은 페이징 풀 메모리를 2KB 정도 소비합니다. 기본 IIS 캐시 파일 핸들 수는 32MB 메모리당 800개입니다.

Exchange 2000 Server 서비스 팩 2(SP2) 이전 Exchange 서버에서는 SMTP 서비스에 대한 기본 최대 파일 핸들 수가 1,000개였기 때문에 대용량 SMTP 메시지 큐(예: 평균 1,000개 이상의 메시지)가 지속되면 성능 제한이 발생했습니다. Exchange 2000 Server에서는 기본적으로 최대 1,000개의 파일 핸들을 사용하므로 SMTP 서비스는 파일 시스템에 1,000개의 메시지만 동시에 쓸 수 있습니다.

이러한 대용량 시스템의 성능을 향상시키기 위해 아래의 세 가지 레지스트리 항목을 자주 동시 조정하여 더 많은 메시지를 처리할 수 있도록 SMTP 서비스가 열 수 있는 최대 파일 핸들 수를 높이고 큐 크기가 클 때 메모리 부족을 피할 수 있도록 다른 Exchange 구성 요소인 설치 가능한 파일 시스템에 대한 열린 파일 핸들 수를 낮추었습니다. 이러한 레지스트리 값은 다음과 같으며 기본적으로 존재하지 않으므로 수동으로 추가해야 합니다.

위치: HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

값: MsgHandleThreshold

종류: REG_DWORD

위치: HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

값: MsgHandleAsyncThreshold

종류: REG_DWORD

위치: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

값: FileCacheMaxHandles

종류: REG_DWORD

MsgHandleThreshold 항목과 MsgHandleAsyncThreshold 항목은 보통 같은 값(보통 1,000을 초과하는 값)으로 조정되고 FileCacheMaxHandles 값은 보통 800에서 600으로 감소됩니다.

이 레지스트리 값은 Exchange 2000 Server 서비스 팩 2(SP2) 이상에서는 사용할 최적의 값을 동적으로 결정하기 때문에 기본적으로 제공되지 않습니다. Exchange 서버에서 Exchange 2000 서비스 팩 1 이하를 실행 중이면 최신 수준의 서비스 팩과 롤업 패키지로 업그레이드하는 것이 좋습니다. 최신 코드로 업그레이드를 완료하면 이러한 레지스트리 항목을 삭제할 수 있습니다.

Exchange Server 2003에서는 SMTP 파일 핸들에 적절한 설정을 동적으로 계산하므로 이러한 설정이 더 이상 필요하지 않습니다. 따라서 이러한 설정이 있는 Exchange 2000 Server 컴퓨터를 Exchange Server 2003으로 업그레이드하기 전에 레지스트리에서 이러한 항목을 삭제해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters를 탐색합니다.

  3. FileCacheMaxHandles 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


SMTP GlitchRetrySeconds 레지스트리 값이 수동으로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 결함 다시 시도 대기 시간의 기본값이 수동으로 다시 정의되었는지 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\GlitchRetrySeconds

Exchange Server Analyzer는 GlitchRetrySeconds가 구성되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

Exchange 2000 Server 또는 Exchange Server 2003이 과다한 로드가 있는 외부 SMTP 시스템으로 메시지를 라우팅할 경우 서버 작업 중 오류가 발생할 수 있습니다. 이 경우 Exchange는 "결함 다시 시도"라는 상태가 됩니다. 이 상태에서 Exchange는 60초를 기다린 후에 메시지를 다시 보내고 이 과정을 세 번 반복한 후에 다른 작업으로 진행합니다. 외부 SMTP 서버가 계속 작업 중이면 결함 다시 시도 대기 시간을 줄여서 많은 양의 메시지가 큐에 놓이지 않도록 하는 것이 좋습니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing을 탐색합니다.

  3. 오른쪽 창에서 GlitchRetrySeconds 값을 삭제합니다. 또는 대량 메시지가 큐에서 대기할 경우 GlitchRetrySeconds 값을 줄일 수 있습니다.

  4. 레지스트리 편집기를 닫고 SMTP(Simple Mail Transfer Protocol) 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


SMTP IgnorePFTimeLimit 레지스트리 값이 수동으로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SMTP 서비스 라우팅 엔진이 새 공용 폴더 저장소를 사용하지 않는 날짜 수가 수동으로 설정되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\IgnorePFTimeLimit

Exchange Server Analyzer는 IgnorePFTimeLimit이 구성되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

새 공용 폴더 저장소가 온라인 상태가 되면 큐 뷰어에서 로컬 배달 큐가 커지는 것을 알 수 있습니다. 공용 폴더 계층 구조가 크면 로컬 큐에 있는 메시지 수가 계속 증가하므로 배달 시간이 추가로 걸릴 수 있습니다. 메시지가 배달되지 못하는 경우도 발생할 수 있습니다.

새 서버가 도입되면 Active Directory® 디렉터리 서비스에서 관리 그룹의 Folder Hierarchies Public Folder 개체의 msExchOwningPFTreeBL 특성에 고유 이름이 추가됩니다. 공용 폴더로 보내는 메시지를 받는 서버의 분류기는 msExchOwningPFTreeBL 특성을 읽을 때 로컬 공용 폴더 저장소가 있으면 먼저 이 저장소를 선택해야 합니다. 그런 다음 로드 균형 조정을 위해 목록에 표시된 순서로 공용 폴더 저장소를 선택합니다. 새 서버는 목록의 처음에 표시되므로 메시지는 해당 서버로 라우팅되고 새 서버의 로컬 배달 큐에 추가됩니다. 공용 폴더 저장소가 계층 구조의 복사본을 받지 못한 경우 서버는 대상 폴더의 복사본을 소유한 저장소로 메시지를 라우팅할 수 없습니다.

이 문제가 발생하지 않게 하려면 새 공용 폴더 서버의 레지스트리에 IgnorePFTimeLimit 값을 추가합니다. 이렇게 하면 라우팅 엔진이 새 공용 폴더 저장소를 사용하지 않는 날짜 수가 지정됩니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 레지스트리를 편집하기 전에 문제가 발생할 경우 복원 방법을 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters를 탐색합니다.

  3. 오른쪽 창에서 IgnorePFTimeLimit을 삭제합니다.

  4. 레지스트리 편집기를 닫고 IIS ADmin 서비스를 다시 시작하여 변경 내용을 적용합니다.

이 문서에서 설명한 문제와 IgnorePFTimeLimit 레지스트리 값에 대한 내용은 Microsoft 기술 자료 문서 328870, "XADM: Public Folder Routing is Enabled Before the Hierarchy is Replicated"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328870)를 참조하십시오.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


SMTP 인스턴스에 여러 포트 바인딩이 구성되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchServerBindings 특성의 구성된 값이 기본값 25와 다르게 변경되어 있는지 또는 여러 개의 값이 설정되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 msExchServerBindings 특성은 TCP 포트 25에 구성되어 있습니다. Exchange Server Analyzer에서 이 특성에 여러 개의 값이 설정되어 있음을 확인하면 여러 개의 값이 설정된 SMTP(Simple Mail Transfer Protocol) 서버의 이름과 함께 기본 구성이 아니라는 메시지가 표시됩니다.

msExchServerBindings 특성은 이 SMTP 서버가 인바운드 연결을 수신 대기하는 TCP 포트를 나타냅니다. 하나 이상의 TCP 포트를 수신 대기하도록 SMTP 가상 서버를 구성할 수 있습니다. 기본적으로 모든 SMTP 가상 서버는 기본 SMTP 포트인 TCP 포트 25에서 수신 대기하도록 구성됩니다. SMTP 수신 대기 포트가 기본값과 다르게 수정되고 여러 개의 포트 바인딩을 포함하고 있으면 메일 흐름이 중단될 수 있습니다.

내부 메시징 인프라의 나머지 부분도 이에 맞게 변경하는 한 SMTP 수신 대기 포트를 변경하는 것도 가능합니다. 그러나 일반적으로 포트 25를 통해 인터넷으로 메시지를 보내는 SMTP 서버와 마찬가지로 인터넷에서 메시지를 직접 받는 SMTP 가상 서버에 대해서는 대체 포트를 사용할 수 없습니다.

Exchange Server Analyzer는 Exchange SMTP 프로토콜 가상 서버에 대한 값을 계속 확인합니다. 이 SMTP 프로토콜 가상 서버는 인터넷에서 메시지를 직접 받는 SMTP 서버일 수도 있고 아닐 수도 있습니다. 포트 25를 통해 인터넷에서 SMTP 메시지를 받아 다른 포트의 Exchange SMTP 가상 서버로 리디렉션하도록 설계된 바이러스 백신 및 스팸 방지 제품이 있습니다. 이 시나리오에서는 여러 포트에서 수신을 대기하도록 Exchange SMTP 가상 서버를 구성할 수 있습니다.

SMTP 가상 서버 수신 대기 포트를 확인 또는 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange 서버, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 일반 탭을 선택한 다음 고급을 클릭합니다.

  5. IP 주소 및 포트 목록이 표시됩니다.

    • 기존 포트를 변경하려면 IP 주소를 선택한 다음 편집을 클릭합니다. TCP 포트 필드를 25로 변경합니다.

    • 추가 수신 포트로 포트 25를 추가하려면 추가를 클릭한 다음 새 IP 주소/포트 조합을 추가합니다. 연결, 보낸 사람 또는 받는 사람 필터링을 사용하는 경우 해당 확인란을 선택했는지 확인합니다.

  6. 확인을 클릭하여 변경 내용을 저장한 다음 확인을 클릭하여 고급 대화 상자를 끝냅니다.

  7. 확인을 클릭하여 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


SMTP 메시지 오류 경고 - BadMail 메시지 생성 오류
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 BadmailedMessagesGeneralFailure 키 값을 확인할 때 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키 값은 특정 카운터와 연관되지 않았다는 이유로 Badmail 디렉터리로 보내진 메시지의 수를 나타냅니다. Badmail 디렉터리는 배달할 수 없는 메시지를 저장하는 데 사용됩니다. 그 밖의 일부 Badmail WMI 카운터에 대한 자세한 내용은 다음 Exchange Server Analyzer 문서를 참조하십시오.

  • SMTP 메시지 오류 경고 - BadMail 메시지 홉 수 임계값

  • SMTP 메시지 오류 경고 - DSN의 BadMail 메시지 배달 못 함 보고서(NDR)

불량 픽업 파일, 받는 사람 없음 및 이벤트를 통해 트리거된 오류를 비롯한 여러 가지 이유로 Badmail 디렉터리로 메시지가 전송될 때 증가하는 카운터가 있습니다.

또한 Exchange Server Analyzer는 SystemUpTime의 값을 확인할 때 Win32_PerfRawData_PerfOS_System WMI 키를 쿼리합니다.

Exchange Server Analyzer는 SystemUpTime 키 값이 0보다 크고 BadmailedMessagesGeneralFailure의 값을 SystemUpTime의 값으로 나눈 결과가 1000보다 크면 경고를 표시합니다.

이 경고는 매일 평균 1,000개 이상의 메시지가 배달 불가능으로 표시되어 Badmail 디렉터리에 저장됨을 나타냅니다. Badmail 디렉터리의 메시지는 수동으로 삭제해야 합니다. 정기적인 Exchange Server 유지 관리 중에 Badmail 디렉터리의 메시지 삭제를 검토하는 것이 좋습니다. Badmail 디렉터리의 크기가 제한 없이 커지도록 그냥 두면 사용 가능한 디스크 공간을 모두 소비하게 되므로 결과적으로 Exchange 데이터베이스가 분리될 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Badmail 디렉터리의 메시지를 검토하여 메시지 원본이 내부 받는 사람용인지 또는 외부 받는 사람용인지 확인합니다. Badmail 디렉터리의 메시지는 ASCII 형식으로 저장되며 메모장이나 다른 텍스트 편집기에서 열고 볼 수 있습니다.

    • 메시지가 내부에서 생성된 것으로 나타나면 메시지 헤더를 검사하여 원본을 확인할 수 있습니다.

    • 메시지가 외부에서 생성된 것으로 나타나면 Exchange Server가 메일 릴레이로 사용되는 것일 수 있습니다.

릴레이 옵션의 제어 및 구성 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 310380, "HOWTO: Windows 2000에서 Exchange 2000이 메일 릴레이로 사용되지 않도록 방지"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380)

  • 313395, "HOWTO: 익명 SMTP 연결을 위한 릴레이 제한 검사 및 Exchange 2000 Server에서 원하지 않는 전자 메일 메시지 필터링"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313395)

여유 디스크 공간 부족으로 인한 데이터베이스 분리에 대한 자세한 내용은 Microsoft 기술 자료 문서 321825, "디스크 공간 부족으로 인해 데이터베이스가 탑재 해제된다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825)를 참조하십시오.


SMTP 메시지 오류 경고 - BadMail 메시지 홉 수 임계값
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 BadmailedMessagesHopCountExceeded 키 값을 확인할 때 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키 값은 최대 홉 수 초과로 인해 Badmail 디렉터리로 보낸 메시지 수를 나타냅니다. Badmail 디렉터리는 배달할 수 없는 메시지를 저장하는 데 사용됩니다. 그 밖의 Badmail WMI 카운터에 대한 자세한 내용은 Exchange Server Analyzer Tool 문서 SMTP 메시지 오류 경고 - BadMail 메시지 생성 오류 및 SMTP 메시지 오류 경고 - DSN의 BadMail 메시지 배달 못 함 보고서(NDR)를 참조하십시오.

불량 픽업 파일, 받는 사람 없음 및 이벤트를 통해 트리거된 오류를 비롯한 여러 가지 이유로 Badmail 디렉터리로 메시지가 전송될 때 증가하는 카운터가 있습니다.

또한 Exchange Server Analyzer는 SystemUpTime의 값을 확인할 때 Win32_PerfRawData_PerfOS_System WMI 키를 쿼리합니다.

Exchange Server Analyzer는 SystemUpTime 키 값이 0보다 크고 BadmailedMessagesHopCountExceeded의 값을 SystemUpTime의 값으로 나눈 결과가 100보다 크면 경고를 표시합니다.

이 경고는 매일 평균 100개 이상의 메시지가 배달 못 함으로 표시되고 최대 홉 수를 초과함으로 인해 Badmail 디렉터리에 저장되었음을 나타냅니다. 최대 홉 수는 보낸 사람에서 받는 사람까지의 경로에서 메시지가 통과할 수 있는 최대 SMTP 서버 수입니다. 메시지가 SMTP 서버를 통해 이동할 때마다 홉을 나타내는 텍스트 한 줄이 메시지 헤더에 추가됩니다.

가장 적합한 메시지 홉 수는 네트워크의 토폴로지와 메시징 요구에 따라 달라집니다. 관리자는 허용된 최대 홉 수를 제어하여 반복적으로 발생하는 메시지의 잘못된 라우팅(메시지 반복이라는 조건)을 방지할 수 있습니다. SMTP 가상 서버에 대한 최대 홉 수를 설정하여 수행할 수 있습니다. Exchange 2000 Server에서 기본 홉 수는 15이고, Exchange Server 2003에서는 30입니다. Exchange 2000 Server 및 Exchange Server 2003 SMTP 가상 서버 모두에 30을 사용하는 것이 좋습니다.

Badmail 디렉터리의 메시지는 수동으로 삭제해야 합니다. 정기적인 Exchange Server 유지 관리의 일환으로 Badmail 디렉터리에 있는 메시지를 정기적으로 검토하고 삭제하는 것이 좋습니다. Badmail 디렉터리의 크기가 제한 없이 커지도록 그냥 두면 사용 가능한 디스크 공간을 모두 소비하게 되므로 결과적으로 Exchange 데이터베이스가 분리될 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. Badmail 디렉터리의 메시지를 검토하여 메시지 원본이 내부인지 외부인지를 확인합니다. Badmail 디렉터리의 메시지는 ASCII 형식으로 저장되며 메모장이나 다른 텍스트 편집기에서 열고 볼 수 있습니다.

    • 메시지가 내부에서 생성된 것으로 나타나면 메시지 헤더를 검사하여 원본을 확인할 수 있습니다.

    • 메시지가 외부에서 생성된 것으로 나타나면 Exchange Server가 메일 릴레이로 사용되는 것일 수 있습니다.

  2. 최대 홉 수 값을 30으로 설정합니다.

    1. Exchange System Manager를 엽니다.

    2. 서버, Exchange 서버, 프로토콜 및 SMTP를 차례로 확장합니다.

    3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

    4. 배달 탭을 선택한 후 고급을 클릭합니다.

    5. 최대 홉 수 필드에 원하는 값을 입력하고 확인을 클릭하여 변경 내용을 저장합니다.

    6. 확인을 클릭하여 SMTP 가상 서버에 대한 속성 대화 상자를 닫습니다.

릴레이 옵션의 제어 및 구성 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 310380, "HOWTO: Windows 2000에서 Exchange 2000이 메일 릴레이로 사용되지 않도록 방지"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380)

  • 313395, "HOWTO: 익명 SMTP 연결을 위한 릴레이 제한 검사 및 Exchange 2000 Server에서 원하지 않는 전자 메일 메시지 필터링"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313395)

여유 디스크 공간 부족으로 인한 데이터베이스 분리에 대한 자세한 내용은 Microsoft 기술 자료 문서 321825, "디스크 공간 부족으로 인해 데이터베이스가 탑재 해제된다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825)를 참조하십시오.


SMTP 메시지 오류 경고 - DSN의 BadMail 메시지 배달 못 함 보고서(NDR)
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-23

Microsoft® Exchange Server Analyzer Tool에서는 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft Windows® Management Instrumentation(WMI) 클래스를 쿼리하여 BadmailedMessagesNDRofDSN 키 값을 확인합니다. 이 키 값은 메시지를 배달할 수 없기 때문에 Badmail 디렉터리에 전송된 배달 상태 알림(DSN)의 수를 나타냅니다. Badmail 디렉터리는 배달할 수 없는 메시지를 저장하는 데 사용됩니다. 다른 Badmai WM 카운터에 대한 자세한 내용은 Exchange Server Analyzer 기사, SMTP 메시지 오류 경고 - BadMail 메시지 생성 오류 및 SMTP 메시지 오류 경고 - BadMail 메시지 홉 수 임계값를 참조하십시오.

불량 픽업 파일, 받는 사람 없음 및 이벤트를 통해 트리거된 오류를 비롯한 여러 가지 이유로 Badmail 디렉터리로 메시지가 전송될 때 증가하는 카운터가 있습니다.

또한 Exchange Server Analyzer에서는 Win32_PerfRawData_PerfOS_System WMI 키를 쿼리하여 SystemUpTime의 값을 확인합니다.

Exchange Server Analyzer에서 SystemUpTime 키 값이 0보다 크고 SystemUpTime 값으로 나눈 BadmailedMessagesNDRofDSN 값 결과가 1000보다 큰 것으로 확인되면 경고가 표시됩니다.

이 경고는 하루에 평균 1,000개 이상의 DSN이 배달될 수 없기 때문에 Badmail 디렉터리에 저장됨을 나타냅니다. Badmail 디렉터리의 메시지는 수동으로 삭제해야 합니다. 정기적인 Exchange Server 유지 관리의 일환으로 Badmail 디렉터리에 있는 메시지를 정기적으로 검토하고 삭제하는 것이 좋습니다. Badmail 디렉터리의 크기가 제한 없이 커지도록 그냥 두면 사용 가능한 디스크 공간을 모두 소비하게 되므로 결과적으로 Exchange 데이터베이스가 분리될 수 있습니다.

이 경고를 해결하려면 다음을 수행합니다.

  • Badmail 디렉터리의 메시지를 검토하여 DSN이 내부 받는 사람용인지 외부 받는 사람용인지 확인합니다. Badmail 디렉터리의 메시지는 ASCII 형식으로 저장되며 메모장이나 다른 텍스트 편집기에서 열고 볼 수 있습니다.

    • DSN이 내부 받는 사람용인 경우에 메시지 흐름 문제를 나타냅니다. 이 문제의 해결은 DSN에서 반환되는 특정 숫자 코드에 따라 달라집니다.

    • DSN이 외부 받는 사람용인 경우에는 Exchange Server가 메일 릴레이로 사용되는 것을 나타낼 수 있습니다. 이 문제의 해결도 반환되는 숫자 코드에 따라 달라집니다.

DSN 숫자 반환 코드에 배달에 대한 자세한 내용은 Microsoft 기술 자료 문서 284204, Exchange Server 및 Small Business Server에서 배달 상태 알림을 참조하십시오.

릴레이 옵션을 제어 및 구성하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서 313395, Exchange 2000 Server에서 익명 SMTP 연결에 대한 릴레이 제한 검사 및 원치 않는 전자 메일 메시지를 필터링하는 방법을 참조하십시오.

사용 가능한 디스크 공간 부족으로 인한 데이터베이스 분리에 대한 자세한 내용은 Microsoft 기술 자료 문서 321825, 디스크 공간 부족으로 인한 데이터베이스 분리를 참조하십시오.


SMTP 메시지 오류 경고 - 분류기 주소 조회를 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-03-20

Microsoft® Exchange Server Analyzer Tool은 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 CatAddresslookupsnotfound 키 값을 확인합니다. 이 키 값은 메시지 분류기에서 디렉터리 서비스 개체를 찾지 못한 주소 조회 수를 나타냅니다. 또한 Exchange Server Analyzer는 Win32_PerfRawData_PerfOS_System WMI 키를 쿼리하여 SystemUpTime의 값을 확인합니다.

SystemUpTime 키 값이 0보다 크고 CatAddresslookupsnotfound 값을 SystemUpTime 값으로 나눈 결과가 5000보다 크면 Exchange Server Analyzer에서 경고를 표시합니다.

메시지 분류기는 SMTP 서버로 들어오는 메시지를 검사하고 메시지를 어떻게 처리할 것인지 결정합니다. 메시지는 로컬 정보 저장소로 보내거나 메시지 전송 에이전트(MTA) 또는 SMTP를 사용하여 원격 호스트로 보낼 수 있습니다. 분류기는 또한 메일 그룹 확장을 처리합니다. 분류기는 TCP 포트 3268의 글로벌 카탈로그 서버를 대상으로 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 고급 큐 엔진에 대한 플러그 인으로, 기본적으로 고급 큐 엔진을 통과하는 모든 메시지에서 고급 주소 확인을 수행하는 이벤트 싱크 모음입니다. 분류기는 주소 확인, 메일 전달, 콘텐츠 변환 플래그 설정, 메일 그룹 확장, 전역 설정 적용, 배달 상태 알림 생성, 대리 수신자 경로 검색, 분기, 저널링 등 많은 기능을 수행합니다.

메시지 분류기에 메시지가 도착하면 분류기는 Active Directory® 디렉터리 서비스의 프록시 주소 특성에서 주소를 검색하여 봉투를 보낸 사람을 확인합니다. 또한 분류기는 Active Directory의 프록시 주소 특성에서 각 주소를 검색하여 봉투를 받는 사람을 확인합니다. 예를 들어 목록에 메일 그룹이 포함되어 있으면 분류기는 메일 그룹 확장이 서버에서 허용된 경우 해당 구성원을 포함하도록 목록을 확장합니다.

이 경고는 매일 평균적으로 5,000건 이상의 분류기 주소 조회가 실패하고 있음을 나타냅니다. DSAccess(디렉터리 서비스 액세스) 문제, 디렉터리 복제 지연 또는 실패, 디렉터리에 대한 사전 공격, DNS 문제 또는 불량 주소 사용 등 몇 가지 원인으로 이런 상황이 발생합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터의 이벤트 로그에서 오류가 발생했는지 확인합니다.

  2. 문제를 해결할 수 있는 이벤트를 발견하지 못한 경우 MSExchangeTransport Categorizer에서 진단 로깅을 최대로 조정합니다. 진단 로깅이 사용되고 있는 경우에는 이벤트 로그에 오류가 있는지 다시 확인합니다. 진단 로깅을 최대로 구성해도 이벤트 로그 항목이 생성되지 않으면 레지스트리를 사용하여 진단 로깅을 수준 7로 구성합니다. 수준 7로 설정하면 메시지 분류기에 의해 생성된 이벤트 ID 9000이 기록됩니다. 이 이벤트는 기능, 실패 원인, 실패한 받는 사람 및 받는 사람 유형을 자세히 보여 줍니다. 진단 로깅을 수준 7로 설정하려면 다음을 수행합니다.

    1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

    2. 다음 항목을 탐색합니다.

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 오른쪽 창에서 2 Categorizer를 두 번 클릭하고 값 데이터를 7로 설정한 다음 확인을 클릭합니다.

    4. 레지스트리 편집기를 닫습니다.

      참고:
      문제 해결이 완료되었으면 2 Categorizer의 값 데이터를 0으로 다시 설정합니다.

  3. Exchange Server가 하나 이상의 글로벌 카탈로그 서버에 연결되어 있는지 확인합니다. 이 작업에는 Windows의 네트워크 모니터 도구가 아주 유용합니다.

  4. 생성되는 DSN(배달 상태 알림) 메시지를 모두 검사합니다. DSN에는 배달 못 함 보고서(NDR)가 포함될 수 있으며, 영구 배달 오류를 초래하기 쉬운 일시적 오류 메시지와 영구 오류 메시지에 대한 설명이 있습니다.

  5. 메시지 추적을 사용하여 분류기에 정체되어 있는 메시지의 문제를 해결합니다.

  6. 보관 싱크 도구를 사용하여 메시지를 보관하고 Exchange Server에 들어오고 나가는 메시지를 분석합니다.

  7. 시스템 모니터를 사용하여 분류기 성능 카운터를 모니터링합니다.

Exchange Server 및 Microsoft Windows Small Business Server에 의해 생성된 DSN 및 NDR 목록은 Microsoft 기술 자료 문서 284204, "Exchange Server 및 Small Business Server에서 배달 상태 알림"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)을 참조하십시오.

Exchange Server에서 메시지 추적 센터를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 262162, "XADM: Using the Message Tracking Center to Track a Message"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Exchange 2000 Server에서 메시지 추적 기능을 사용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "Message Tracking Event IDs in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Improved Message Tracking Features in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

메시지 분류기의 문제 해결에 대한 자세한 내용은 Microsoft 기술 지원 웹캐스트, "Exchange 2000 Server: Message Categorizer and NDR Troubleshooting"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)을 참조하십시오.

보관 싱크 도구에 대한 자세한 내용은 Microsoft 기술 자료 문서 307798, "The Archive Sink utility is available in Service Pack 2"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)를 참조하십시오.

전송 관련 문제 해결에 대한 일반적인 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 821910, "HOWTO: Exchange Server 2003 전송 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "XCON: Exchange 2000 전송 시 일반 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

메시지 분류기 성능 카운터는 각 SMTP 가상 서버 인스턴스에 대해 별도로 게시되어 있습니다. 메시지 분류기와 관련하여 사용 가능한 성능 카운터 목록은 Microsoft 기술 자료 문서 231734, "XCON: Performance Monitor Counters for Message Categorizer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)를 참조하십시오.

그 밖의 일부 분류기 WMI 카운터에 대한 자세한 내용은 다음 Exchange Server Analyzer 문서를 참조하십시오.

  • SMTP 메시지 오류 경고 - 분류기 디렉터리 서비스 실패

  • SMTP 메시지 오류 경고 - 분류기 디렉터리 로그온 실패

  • SMTP 메시지 오류 경고 - 분류기의 다시 시도할 수 없는 오류

  • SMTP 메시지 오류 경고 - 분류기 메모리 부족 오류

  • SMTP 메시지 오류 경고 - 분류기의 다시 시도 가능한 오류


SMTP 메시지 오류 경고 - 분류기 디렉터리 로그온 실패
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 CatCategorizationsfailedDSlogonfailure 키 값을 확인할 때 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키 값은 디렉터리 서비스 로그온 오류 때문에 실패한 분류 수를 나타냅니다. 또한 Exchange Server Analyzer는 SystemUpTime의 값을 확인할 때 Win32_PerfRawData_PerfOS_System WMI 키를 쿼리합니다.

Exchange Server Analyzer는 SystemUpTime 키 값이 0보다 크고 CatCategorizationsfailedDSlogonfailure의 값을 SystemUpTime의 값으로 나눈 결과가 50보다 크면 경고를 표시합니다.

메시지 분류기는 SMTP 서버로 들어오는 메시지를 검사하고 메시지를 어떻게 처리할 것인지 결정합니다. 메시지는 로컬 정보 저장소로 보내거나 메시지 전송 에이전트(MTA) 또는 SMTP를 사용하여 원격 호스트로 보낼 수 있습니다. 분류기는 또한 메일 그룹 확장을 처리합니다. 분류기는 TCP 포트 3268의 글로벌 카탈로그 서버를 대상으로 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 고급 큐 엔진에 대한 플러그 인으로, 기본적으로 고급 큐 엔진을 통과하는 모든 메시지에서 고급 주소 확인을 수행하는 이벤트 싱크 모음입니다. 분류기는 주소 확인, 메일 전달, 콘텐츠 변환 플래그 설정, 메일 그룹 확장, 전역 설정 적용, 배달 상태 알림 생성, 대리 수신자 경로 검색, 분기, 저널링 등 많은 기능을 수행합니다.

메시지 분류기에 메시지가 도착하면 분류기는 Active Directory® 디렉터리 서비스의 프록시 주소 특성에서 주소를 검색하여 봉투를 보낸 사람을 확인합니다. 또한 분류기는 Active Directory의 프록시 주소 특성에서 각 주소를 검색하여 봉투를 받는 사람을 확인합니다. 예를 들어 목록에 메일 그룹이 포함되어 있으면 분류기는 메일 그룹 확장이 서버에서 허용된 경우 해당 구성원을 포함하도록 목록을 확장합니다.

이 경고는 메시지 분류기가 로그온 실패 때문에 하루 평균 50번 이상 디렉터리 서비스 연결 시도에 실패했음을 나타냅니다. DSAccess(디렉터리 서비스 액세스) 문제, 디렉터리 복제 지연 또는 실패, 오버로드된 글로벌 카탈로그 서버, DNS 문제 등 여러 가지 원인으로 이런 상황이 발생합니다.

중요:
이 문서에는 레지스트리 편집 정보가 포함되어 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터의 이벤트 로그에서 오류가 발생했는지 확인합니다.

  2. 문제를 해결할 수 있는 이벤트를 발견하지 못한 경우 MSExchangeTransport Categorizer에서 진단 로깅을 최대로 조정합니다. 진단 로깅이 사용되면 즉시 이벤트 로그에서 오류를 다시 확인합니다. 진단 로깅을 최대로 구성해도 이벤트 로그 항목이 생성되지 않으면 레지스트리를 사용하여 진단 로깅을 수준 7로 구성합니다. 수준 7로 설정하면 메시지 분류기에 의해 생성된 이벤트 ID 9000이 로그에 기록되며 기능, 실패 원인, 실패한 받는 사람 이름 및 받는 사람 유형을 자세히 보여 줍니다 진단 로깅을 수준 7로 설정하려면 다음을 수행합니다.

    1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

    2. 다음 항목을 탐색합니다.

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 오른쪽 창에서 2 Categorizer를 두 번 클릭하고 값 데이터를 7로 설정한 다음 확인을 클릭합니다.

    4. 레지스트리 편집기를 닫습니다.

      참고:
      문제 해결이 완료되었으면 2 Categorizer의 값 데이터를 0으로 다시 설정합니다.

  3. Exchange Server가 하나 이상의 글로벌 카탈로그 서버에 연결되어 있는지 확인합니다. 이 작업에는 Windows의 네트워크 모니터 도구가 아주 유용합니다.

  4. 생성되는 DSN(배달 상태 알림) 메시지를 모두 검사합니다. DSN에는 배달 못 함 보고서(NDR)가 포함될 수 있으며, 영구 배달 오류를 초래하기 쉬운 일시적 오류 메시지와 영구 오류 메시지에 대한 설명이 있습니다.

  5. 메시지 추적을 사용하여 분류기에 정체되어 있는 메시지의 문제를 해결합니다.

  6. 보관 싱크 도구를 사용하여 메시지를 보관하고 Exchange Server에 들어오고 나가는 메시지를 분석합니다.

  7. 시스템 모니터를 사용하여 분류기 성능 카운터를 모니터링합니다.

Exchange Server 및 Microsoft Windows Small Business Server에 의해 생성된 DSN 및 NDR 목록은 Microsoft 기술 자료 문서 284204, "Exchange Server 및 Small Business Server에서 배달 상태 알림"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)을 참조하십시오.

Exchange Server에서 메시지 추적 센터를 사용하는 방법에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 262162, "XADM: Using the Message Tracking Center to Track a Message"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Exchange 2000 Server에서 메시지 추적 기능을 사용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "Message Tracking Event IDs in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Improved Message Tracking Features in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

메시지 분류기의 문제 해결에 대한 자세한 내용은 Microsoft 기술 지원 웹캐스트 "Exchange 2000 Server: Message Categorizer and NDR Troubleshooting"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)을 참조하십시오.

보관 싱크 도구에 대한 자세한 내용은 Microsoft 기술 자료 문서 307798, "The Archive Sink utility is available in Service Pack 2"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)를 참조하십시오.

전송 관련 문제 해결에 대한 일반적인 내용은 다음 기술 자료 문서를 참조하십시오.

  • 821910, "HOWTO: Exchange Server 2003 전송 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "XCON: Exchange 2000 전송 시 일반 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

메시지 분류기 성능 카운터는 각 SMTP 가상 서버 인스턴스에 대해 별도로 게시되어 있습니다. 메시지 분류기와 관련하여 사용 가능한 성능 카운터 목록은 Microsoft 기술 자료 문서 231734, "XCON: Performance Monitor Counters for Message Categorizer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)를 참조하십시오.

그 밖의 일부 분류기 WMI 카운터에 대한 자세한 내용은 다음 Exchange Server Analyzer 문서를 참조하십시오.

  • SMTP 메시지 오류 경고 - 분류기 디렉터리 서비스 실패

  • SMTP 메시지 오류 경고 - 분류기 주소 조회를 찾을 수 없습니다.

  • SMTP 메시지 오류 경고 - 분류기의 다시 시도할 수 없는 오류

  • SMTP 메시지 오류 경고 - 분류기 메모리 부족 오류

  • SMTP 메시지 오류 경고 - 분류기의 다시 시도 가능한 오류


SMTP 메시지 오류 경고 - 분류기 디렉터리 서비스 실패
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-03-20

Microsoft® Exchange Server Analyzer Tool은 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 CatCategorizationsfailedDSconnectionfailure 키 값을 확인합니다. 이 키 값은 디렉터리 서비스 연결의 서비스 실패 때문에 실패한 분류 수를 나타냅니다. 또한 Exchange Server Analyzer는 Win32_PerfRawData_PerfOS_System WMI 키를 쿼리하여 SystemUpTime 키 값을 확인합니다.

SystemUpTime 키 값이 0보다 크고 CatCategorizationsfailedDSconnectionfailure 값을 SystemUpTime 값으로 나눈 결과가 50보다 크면 Exchange Server Analyzer에서 경고를 표시합니다.

메시지 분류기는 SMTP 서버로 들어오는 메시지를 검사하고 메시지를 어떻게 처리할 것인지 결정합니다. 메시지는 로컬 정보 저장소로 보내거나 메시지 전송 에이전트(MTA) 또는 SMTP를 사용하여 원격 호스트로 보낼 수 있습니다. 분류기는 또한 메일 그룹 확장을 처리합니다. 분류기는 TCP 포트 3268의 글로벌 카탈로그 서버를 대상으로 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 고급 큐 엔진에 대한 플러그 인으로, 기본적으로 고급 큐 엔진을 통과하는 모든 메시지에서 고급 주소 확인을 수행하는 이벤트 싱크 모음입니다. 분류기는 주소 확인, 메일 전달, 콘텐츠 변환 플래그 설정, 메일 그룹 확장, 전역 설정 적용, 배달 상태 알림 생성, 대리 수신자 경로 검색, 분기, 저널링 등 많은 기능을 수행합니다.

메시지 분류기에 메시지가 도착하면 분류기는 Active Directory® 디렉터리 서비스의 프록시 주소 특성에서 주소를 검색하여 봉투를 보낸 사람을 확인합니다. 또한 분류기는 Active Directory의 프록시 주소 특성에서 각 주소를 검색하여 봉투를 받는 사람을 확인합니다. 예를 들어 목록에 메일 그룹이 포함되어 있으면 분류기는 메일 그룹 확장이 서버에서 허용된 경우 해당 구성원을 포함하도록 목록을 확장합니다.

이 경고는 메시지 분류기에 의해 시도되는 디렉터리 서비스 연결이 매일 50회 이상 실패하고 있음을 나타냅니다. DSAccess(디렉터리 서비스 액세스) 문제, 디렉터리 복제 지연 또는 실패, 오버로드된 글로벌 카탈로그 서버, DNS 문제 등 여러 가지 원인으로 이러한 상황이 발생합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터의 이벤트 로그에서 오류가 발생했는지 확인합니다.

  2. 문제를 해결할 수 있는 이벤트를 발견하지 못한 경우 MSExchangeTransport Categorizer에서 진단 로깅을 최대로 조정합니다. 진단 로깅이 사용되면 즉시 이벤트 로그에서 오류를 다시 확인합니다. 진단 로깅을 최대로 구성해도 이벤트 로그 항목이 생성되지 않으면 레지스트리를 사용하여 진단 로깅을 수준 7로 구성합니다. 수준 7로 설정하면 메시지 분류기에 의해 생성된 이벤트 ID 9000이 기록됩니다. 이 이벤트는 기능, 실패 원인, 실패한 받는 사람 및 받는 사람 유형을 자세히 보여 줍니다. 진단 로깅을 수준 7로 설정하려면 다음을 수행합니다.

    1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

    2. 다음 항목을 탐색합니다.

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 오른쪽 창에서 2 Categorizer를 두 번 클릭하고 값 데이터를 7로 설정한 다음 확인을 클릭합니다.

    4. 레지스트리 편집기를 닫습니다.

      참고:
      문제 해결이 완료되었으면 2 Categorizer의 값 데이터를 0으로 다시 설정합니다.

  3. Exchange Server가 하나 이상의 글로벌 카탈로그 서버에 연결되어 있는지 확인합니다. 이 작업에는 Windows의 네트워크 모니터 도구가 아주 유용합니다.

  4. 생성되는 DSN(배달 상태 알림) 메시지를 모두 검사합니다. DSN에는 배달 못 함 보고서(NDR)가 포함될 수 있으며, 영구 배달 오류를 초래하기 쉬운 일시적 오류 메시지와 영구 오류 메시지에 대한 설명이 있습니다.

  5. 메시지 추적을 사용하여 분류기에 정체되어 있는 메시지의 문제를 해결합니다.

  6. 보관 싱크 도구를 사용하여 메시지를 보관하고 Exchange Server에 들어오고 나가는 메시지를 분석합니다.

  7. 시스템 모니터를 사용하여 분류기 성능 카운터를 모니터링합니다.

Exchange Server 및 Microsoft Windows Small Business Server에 의해 생성된 DSN 및 NDR 목록은 Microsoft 기술 자료 문서 284204, "Exchange Server 및 Small Business Server에서 배달 상태 알림"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)을 참조하십시오.

Exchange Server에서 메시지 추적 센터를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 262162, "XADM: Using the Message Tracking Center to Track a Message"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Exchange 2000 Server에서 메시지 추적 기능을 사용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "Message Tracking Event IDs in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Improved Message Tracking Features in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

메시지 분류기의 문제 해결에 대한 자세한 내용은 Microsoft 기술 지원 웹캐스트, "Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)을 참조하십시오.

보관 싱크 도구에 대한 자세한 내용은 Microsoft 기술 자료 문서 307798, "The Archive Sink utility is available in Service Pack 2"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)를 참조하십시오.

전송 관련 문제 해결에 대한 일반적인 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 821910, "HOWTO: Exchange Server 2003 전송 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "XCON: Exchange 2000 전송 시 일반 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

메시지 분류기 성능 카운터는 각 SMTP 가상 서버 인스턴스에 대해 별도로 게시되어 있습니다. 메시지 분류기와 관련하여 사용 가능한 성능 카운터 목록은 Microsoft 기술 자료 문서 231734, "XCON: Performance Monitor Counters for Message Categorizer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)를 참조하십시오.

그 밖의 일부 분류기 WMI 카운터에 대한 자세한 내용은 다음 Exchange Server Analyzer 문서를 참조하십시오.

  • SMTP 메시지 오류 경고 - 분류기 주소 조회를 찾을 수 없습니다.

  • SMTP 메시지 오류 경고 - 분류기 디렉터리 로그온 실패

  • SMTP 메시지 오류 경고 - 분류기의 다시 시도할 수 없는 오류

  • SMTP 메시지 오류 경고 - 분류기 메모리 부족 오류

  • SMTP 메시지 오류 경고 - 분류기의 다시 시도 가능한 오류


SMTP 메시지 오류 경고 - 분류기의 다시 시도할 수 없는 오류
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 CatCategorizationsfailednonretryableerror 키 값을 확인합니다. 이 키 값은 다시 시도할 수 없는 심각한 오류로 인해 실패한 분류 작업 수를 나타냅니다. 또한 Exchange Server Analyzer는 Win32_PerfRawData_PerfOS_System WMI 키를 쿼리하여 SystemUpTime의 값을 확인합니다.

SystemUpTime 키 값이 0보다 크고 CatCategorizationsfailednonretryableerror 값을 SystemUpTime 값으로 나눈 결과가 50보다 크다면 Exchange Server Analyzer에서 경고를 표시합니다.

메시지 분류기는 SMTP 서버로 들어오는 메시지를 검사하고 메시지를 어떻게 처리할 것인지 결정합니다. 메시지는 로컬 정보 저장소로 보내거나 메시지 전송 에이전트(MTA) 또는 SMTP를 사용하여 원격 호스트로 보낼 수 있습니다. 분류기는 또한 메일 그룹 확장을 처리합니다. 분류기는 TCP 포트 3268의 글로벌 카탈로그 서버를 대상으로 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 고급 큐 엔진에 대한 플러그 인으로, 기본적으로 고급 큐 엔진을 통과하는 모든 메시지에서 고급 주소 확인을 수행하는 이벤트 싱크 모음입니다. 분류기는 주소 확인, 메일 전달, 콘텐츠 변환 플래그 설정, 메일 그룹 확장, 전역 설정 적용, 배달 상태 알림 생성, 대리 수신자 경로 검색, 분기, 저널링 등 많은 기능을 수행합니다.

메시지 분류기에 메시지가 도착하면 분류기는 Active Directory® 디렉터리 서비스의 프록시 주소 특성에서 주소를 검색하여 봉투를 보낸 사람을 확인합니다. 또한 분류기는 Active Directory의 프록시 주소 특성에서 각 주소를 검색하여 봉투를 받는 사람을 확인합니다. 예를 들어 목록에 메일 그룹이 포함되어 있으면 분류기는 메일 그룹 확장이 서버에서 허용된 경우 해당 구성원을 포함하도록 목록을 확장합니다.

이 경고는 매일 평균 50개 이상의 심각한 오류가 발생하고 있음을 나타냅니다. DSAccess(디렉터리 서비스 액세스) 문제, 디렉터리 복제 지연 또는 실패, 오버로드된 글로벌 카탈로그 서버, DNS 문제 등 여러 가지 원인으로 이러한 상황이 발생합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터의 이벤트 로그에서 오류가 발생했는지 확인합니다.

  2. 문제를 해결할 수 있는 이벤트를 발견하지 못한 경우 MSExchangeTransport Categorizer에서 진단 로깅을 최대로 조정합니다. 진단 로깅을 사용할 수 있게 설정한 후 이벤트 로그에서 오류가 발생했는지 다시 확인합니다. 진단 로깅을 최대로 구성해도 이벤트 로그 항목이 생성되지 않으면 레지스트리를 사용하여 진단 로깅을 수준 7로 구성합니다. 수준 7로 설정하면 메시지 분류기에 의해 생성된 이벤트 ID 9000이 로그에 기록되며 기능, 실패 원인, 실패한 받는 사람 이름 및 받는 사람 유형을 자세히 보여 줍니다. 진단 로깅을 수준 7로 설정하려면 다음을 수행합니다.

    1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

    2. 다음 항목을 탐색합니다.

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 오른쪽 창에서 2 Categorizer를 두 번 클릭하고 값 데이터를 7로 설정한 다음 확인을 클릭합니다.

    4. 레지스트리 편집기를 닫습니다.

      참고:
      문제 해결이 완료되었으면 2 Categorizer의 값 데이터를 0으로 다시 설정합니다.

  3. Exchange Server가 하나 이상의 글로벌 카탈로그 서버에 연결되어 있는지 확인합니다. 이 작업에는 Windows의 네트워크 모니터 도구가 아주 유용합니다.

  4. 생성되는 DSN(배달 상태 알림) 메시지를 모두 검사합니다. DSN에는 배달 못 함 보고서(NDR)가 포함될 수 있으며, 영구 배달 오류를 초래하기 쉬운 일시적 오류 메시지와 영구 오류 메시지에 대한 설명이 있습니다.

  5. 메시지 추적을 사용하여 분류기에 정체되어 있는 메시지의 문제를 해결합니다.

  6. 보관 싱크 도구를 사용하여 메시지를 보관하고 Exchange Server에 들어오고 나가는 메시지를 분석합니다.

  7. 시스템 모니터를 사용하여 분류기 성능 카운터를 모니터링합니다.

Exchange Server 및 Microsoft Windows Small Business Server에 의해 생성된 DSN 및 NDR 목록은 Microsoft 기술 자료 문서 284204, "Exchange Server 및 Small Business Server에서 배달 상태 알림"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)을 참조하십시오.

Exchange Server에서 메시지 추적 센터를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 262162, "XADM: 메시지 추적 센터를 사용하여 메시지 추적"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Exchange 2000 Server에서 메시지 추적 기능을 사용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "Exchange Server 2003의 메시지 추적 이벤트 ID"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Exchange Server 2003의 향상된 메시지 추적 기능"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

메시지 분류기의 문제 해결에 대한 자세한 내용은 Microsoft 기술 지원 웹캐스트, "Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)을 참조하십시오.

보관 싱크 도구에 대한 자세한 내용은 Microsoft 기술 자료 문서 307798, "The Archive Sink utility is available in Service Pack 2"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)를 참조하십시오.

전송 관련 문제 해결에 대한 일반적인 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 821910, "HOWTO: Exchange Server 2003 전송 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "XCON: Exchange 2000 전송 시 일반 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

메시지 분류기 성능 카운터는 각 SMTP 가상 서버 인스턴스에 대해 별도로 게시되어 있습니다. 메시지 분류기와 관련하여 사용 가능한 성능 카운터 목록은 Microsoft 기술 자료 문서 231734, "XCON: Performance Monitor Counters for Message Categorizer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)를 참조하십시오.

그 밖의 일부 분류기 WMI 카운터에 대한 자세한 내용은 다음 Exchange Server Analyzer 문서를 참조하십시오.

  • SMTP 메시지 오류 경고 - 분류기 주소 조회를 찾을 수 없습니다.

  • SMTP 메시지 오류 경고 - 분류기 디렉터리 로그온 실패

  • SMTP 메시지 오류 경고 - 분류기 디렉터리 서비스 실패

  • SMTP 메시지 오류 경고 - 분류기 메모리 부족 오류

  • SMTP 메시지 오류 경고 - 분류기의 다시 시도 가능한 오류


SMTP 메시지 오류 경고 - 분류기 메모리 부족 오류
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-03-28

Microsoft® Exchange Server Analyzer Tool은 CatCategorizationsfailedOutOfMemory 키 값을 확인할 때 Win32_PerfRawData_SMTPSVC_SMTPServer WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키 값은 사용 가능한 메모리의 부족으로 인해 실패한 분류 작업 수를 나타냅니다. 또한 Exchange Server Analyzer는 SystemUpTime의 값을 확인할 때 Win32_PerfRawData_PerfOS_System WMI 키를 쿼리합니다.

Exchange Server Analyzer는 SystemUpTime 키 값이 0보다 크고 CatCategorizationsfailedOutOfMemory 값을 SystemUpTime 값으로 나눈 결과가 50보다 클 경우 경고를 표시합니다.

메시지 분류기는 SMTP 서버로 들어오는 메시지를 검사하고 메시지를 어떻게 처리할 것인지 결정합니다. 메시지는 로컬 정보 저장소로 보내거나 메시지 전송 에이전트(MTA) 또는 SMTP를 사용하여 원격 호스트로 보낼 수 있습니다. 분류기는 또한 메일 그룹 확장을 처리합니다. 분류기는 TCP 포트 3268의 글로벌 카탈로그 서버를 대상으로 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 고급 큐 엔진에 대한 플러그 인으로, 기본적으로 고급 큐 엔진을 통과하는 모든 메시지에서 고급 주소 확인을 수행하는 이벤트 싱크 모음입니다. 분류기는 주소 확인, 메일 전달, 콘텐츠 변환 플래그 설정, 메일 그룹 확장, 전역 설정 적용, 배달 상태 알림 생성, 대리 수신자 경로 검색, 분기, 저널링 등 많은 기능을 수행합니다.

메시지 분류기에 메시지가 도착하면 분류기는 Active Directory® 디렉터리 서비스의 프록시 주소 특성에서 주소를 검색하여 봉투를 보낸 사람을 확인합니다. 또한 분류기는 Active Directory의 프록시 주소 특성에서 각 주소를 검색하여 봉투를 받는 사람을 확인합니다. 예를 들어 목록에 메일 그룹이 포함되어 있으면 분류기는 메일 그룹 확장이 서버에서 허용된 경우 해당 구성원을 포함하도록 목록을 확장합니다.

이 경고는 사용 가능한 메모리 부족으로 인해 매일 평균 500번 이상의 분류 작업이 실패함을 나타냅니다. DSAccess(디렉터리 서비스 액세스) 문제, 디렉터리 복제 지연 또는 실패, 오버로드된 글로벌 카탈로그 서버, DNS 문제 등 여러 가지 원인으로 이러한 상황이 발생합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터의 이벤트 로그에서 오류가 발생했는지 확인합니다.

  2. 문제를 해결할 수 있는 이벤트를 발견하지 못한 경우 MSExchangeTransport Categorizer에서 진단 로깅을 최대로 조정합니다. 진단 로깅을 사용할 수 있게 설정한 후 이벤트 로그에서 오류가 발생했는지 다시 확인합니다. 진단 로깅을 최대로 구성해도 이벤트 로그 항목이 생성되지 않으면 레지스트리를 사용하여 진단 로깅을 수준 7로 구성합니다. 수준 7로 설정하면 메시지 분류기에 의해 생성된 이벤트 ID 9000이 로그에 기록되며 기능, 실패 원인, 실패한 받는 사람 이름 및 받는 사람 유형을 자세히 보여 줍니다. 진단 로깅을 수준 7로 설정하려면 다음을 수행합니다.

    1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

    2. 다음 항목을 탐색합니다.

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 오른쪽 창에서 2 Categorizer를 두 번 클릭하고 값 데이터를 7로 설정한 다음 확인을 클릭합니다.

    4. 레지스트리 편집기를 닫습니다.

      참고:
      문제 해결이 완료되었으면 2 Categorizer의 값 데이터를 0으로 다시 설정합니다.

  3. Exchange Server가 하나 이상의 글로벌 카탈로그 서버에 연결되어 있는지 확인합니다. 이 작업에는 Windows의 네트워크 모니터 도구가 아주 유용합니다.

  4. 생성되는 DSN(배달 상태 알림) 메시지를 모두 검사합니다. DSN에는 배달 못 함 보고서(NDR)가 포함될 수 있으며, 영구 배달 오류를 초래하기 쉬운 일시적 오류 메시지와 영구 오류 메시지에 대한 설명이 있습니다.

  5. 메시지 추적을 사용하여 분류기에 정체되어 있는 메시지의 문제를 해결합니다.

  6. 보관 싱크 도구를 사용하여 메시지를 보관하고 Exchange Server에 들어오고 나가는 메시지를 분석합니다.

  7. 시스템 모니터를 사용하여 분류기 성능 카운터를 모니터링합니다.

Exchange Server 및 Microsoft Windows Small Business Server에 의해 생성된 DSN 및 NDR 목록은 Microsoft 기술 자료 문서 284204, "Exchange Server 및 Small Business Server에서 배달 상태 알림"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)을 참조하십시오.

Exchange Server에서 메시지 추적 센터를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 262162, "XADM: Using the Message Tracking Center to Track a Message"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Exchange 2000 Server 및 Exchange Server 2003에서 메시지 추적 기능을 사용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "Message Tracking Event IDs in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Improved Message Tracking Features in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

메시지 분류기의 문제 해결에 대한 자세한 내용은 Microsoft 기술 지원 웹캐스트, "Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)을 참조하십시오.

보관 싱크 도구에 대한 자세한 내용은 Microsoft 기술 자료 문서 307798, "The Archive Sink utility is available in Service Pack 2"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)를 참조하십시오.

전송 관련 문제 해결에 대한 일반적인 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 821910, "HOWTO: Exchange Server 2003 전송 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "Exchange 2000 Server 및 Exchange Server 2003에서 전송 문제의 일반적인 해결 방법"(http://go.microsoft.com/fwlink/?linkid=3052 &kbid=257265)

메시지 분류기 성능 카운터는 각 SMTP 가상 서버 인스턴스에 대해 별도로 게시되어 있습니다. 메시지 분류기와 관련하여 사용 가능한 성능 카운터 목록은 Microsoft 기술 자료 문서 231734, "XCON: Performance Monitor Counters for Message Categorizer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)를 참조하십시오.

그 밖의 일부 분류기 WMI 카운터에 대한 자세한 내용은 다음 Exchange Server Analyzer 문서를 참조하십시오.

  • SMTP 메시지 오류 경고 - 분류기 주소 조회를 찾을 수 없습니다.

  • SMTP 메시지 오류 경고 - 분류기 디렉터리 로그온 실패

  • SMTP 메시지 오류 경고 - 분류기 디렉터리 서비스 실패

  • SMTP 메시지 오류 경고 - 분류기의 다시 시도할 수 없는 오류

  • SMTP 메시지 오류 경고 - 분류기의 다시 시도 가능한 오류


SMTP 메시지 오류 경고 - 분류기의 다시 시도 가능한 오류
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-03-20

Microsoft® Exchange Server Analyzer Tool은 CatCategorizationsfailedretryableerror 키 값을 확인할 때 Win32_PerfRawData_SMTPSVC_SMTPServer Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. 이 키 값은 다시 시도 가능한 오류로 인해 실패한 분류 작업 수를 나타냅니다. 또한 Exchange Server Analyzer는 SystemUpTime의 값을 확인할 때 Win32_PerfRawData_PerfOS_System WMI 키를 쿼리합니다.

Exchange Server Analyzer는 SystemUpTime 키 값이 0보다 크고 CatCategorizationsfailedretryableerror의 값을 SystemUpTime의 값으로 나눈 결과가 500보다 크면 경고를 표시합니다.

메시지 분류기는 SMTP 서버로 들어오는 메시지를 검사하고 메시지를 어떻게 처리할 것인지 결정합니다. 메시지는 로컬 정보 저장소로 보내거나 메시지 전송 에이전트(MTA) 또는 SMTP를 사용하여 원격 호스트로 보낼 수 있습니다. 분류기는 또한 메일 그룹 확장을 처리합니다. 분류기는 TCP 포트 3268의 글로벌 카탈로그 서버를 대상으로 LDAP(Lightweight Directory Access Protocol) 쿼리를 수행하는 고급 큐 엔진에 대한 플러그 인으로, 기본적으로 고급 큐 엔진을 통과하는 모든 메시지에서 고급 주소 확인을 수행하는 이벤트 싱크 모음입니다. 분류기는 주소 확인, 메일 전달, 콘텐츠 변환 플래그 설정, 메일 그룹 확장, 전역 설정 적용, 배달 상태 알림 생성, 대리 수신자 경로 검색, 분기, 저널링 등 많은 기능을 수행합니다.

메시지 분류기에 메시지가 도착하면 분류기는 Active Directory® 디렉터리 서비스의 프록시 주소 특성에서 주소를 검색하여 봉투를 보낸 사람을 확인합니다. 또한 분류기는 Active Directory의 프록시 주소 특성에서 각 주소를 검색하여 봉투를 받는 사람을 확인합니다. 예를 들어 목록에 메일 그룹이 포함되어 있으면 분류기는 메일 그룹 확장이 서버에서 허용된 경우 해당 구성원을 포함하도록 목록을 확장합니다.

이 경고는 다시 시도 가능한 오류로 인해 매일 평균 500번 이상의 분류 작업이 실패함을 나타냅니다. DSAccess(디렉터리 서비스 액세스) 문제, 디렉터리 복제 지연 또는 실패, 오버로드된 글로벌 카탈로그 서버, DNS 문제 등 여러 가지 원인으로 이런 상황이 발생합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange Server 컴퓨터의 이벤트 로그에서 오류가 발생했는지 확인합니다.

  2. 문제를 해결할 수 있는 이벤트를 발견하지 못한 경우 MSExchangeTransport Categorizer에서 진단 로깅을 최대로 조정합니다. 진단 로깅을 사용할 수 있게 설정한 후 이벤트 로그에서 오류가 발생했는지 다시 확인합니다. 진단 로깅을 최대로 구성해도 이벤트 로그 항목이 생성되지 않으면 레지스트리를 사용하여 진단 로깅을 수준 7로 구성합니다. 수준 7로 설정하면 메시지 분류기에 의해 생성된 이벤트 ID 9000이 로그에 기록되며 기능, 실패 원인, 실패한 받는 사람 이름 및 받는 사람 유형을 자세히 보여 줍니다. 진단 로깅을 수준 7로 설정하려면 다음을 수행합니다.

    1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

    2. 다음 항목을 탐색합니다.

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. 오른쪽 창에서 2 Categorizer를 두 번 클릭하고 값 데이터를 7로 설정한 다음 확인을 클릭합니다.

    4. 레지스트리 편집기를 닫습니다.

      참고:
      문제 해결이 완료되었으면 2 Categorizer의 값 데이터를 0으로 다시 설정합니다.

  3. Exchange Server가 하나 이상의 글로벌 카탈로그 서버에 연결되어 있는지 확인합니다. 이 작업에는 Windows의 네트워크 모니터 도구가 아주 유용합니다.

  4. 생성되는 DSN(배달 상태 알림) 메시지를 모두 검사합니다. DSN에는 배달 못 함 보고서(NDR)가 포함될 수 있으며, 영구 배달 오류를 초래하기 쉬운 일시적 오류 메시지와 영구 오류 메시지에 대한 설명이 있습니다.

  5. 메시지 추적을 사용하여 분류기에 정체되어 있는 메시지의 문제를 해결합니다.

  6. 보관 싱크 도구를 사용하여 메시지를 보관하고 Exchange Server에 들어오고 나가는 메시지를 분석합니다.

  7. 시스템 모니터를 사용하여 분류기 성능 카운터를 모니터링합니다.

Exchange Server 및 Microsoft Windows Small Business Server에 의해 생성된 DSN 및 NDR 목록은 Microsoft 기술 자료 문서 284204, "Exchange Server 및 Small Business Server에서 배달 상태 알림"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204)을 참조하십시오.

Exchange Server에서 메시지 추적 센터를 사용하는 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 262162, "XADM: Using the Message Tracking Center to Track a Message"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Exchange 2000 Server에서 메시지 추적 기능을 사용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "Message Tracking Event IDs in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Improved Message Tracking Features in Exchange Server 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

메시지 분류기의 문제 해결에 대한 자세한 내용은 Microsoft 기술 지원 웹캐스트, "Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137)을 참조하십시오.

보관 싱크 도구에 대한 자세한 내용은 Microsoft 기술 자료 문서 307798, "The Archive Sink utility is available in Service Pack 2"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798)를 참조하십시오.

전송 관련 문제 해결에 대한 일반적인 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 821910, "HOWTO: Exchange Server 2003 전송 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "XCON: Exchange 2000 전송 시 일반 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

메시지 분류기 성능 카운터는 각 SMTP 가상 서버 인스턴스에 대해 별도로 게시되어 있습니다. 메시지 분류기와 관련하여 사용 가능한 성능 카운터 목록은 Microsoft 기술 자료 문서 231734, "XCON: Performance Monitor Counters for Message Categorizer"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734)를 참조하십시오.

그 밖의 일부 분류기 WMI 카운터에 대한 자세한 내용은 Exchange Server Analyzer Tool 문서를 참조하십시오.

  • SMTP 메시지 오류 경고 - 분류기 주소 조회를 찾을 수 없습니다.

  • SMTP 메시지 오류 경고 - 분류기 디렉터리 로그온 실패

  • SMTP 메시지 오류 경고 - 분류기 디렉터리 서비스 실패

  • SMTP 메시지 오류 경고 - 분류기의 다시 시도할 수 없는 오류

  • SMTP 메시지 오류 경고 - 분류기 메모리 부족 오류


SMTP 메일 큐 데이터가 압축된 폴더에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SMTP 메일 큐 폴더의 Compressed 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Compressed 값이 True로 설정되어 있을 경우 경고를 표시합니다.

SMTP 서비스를 통해 Exchange 컴퓨터에 해당 메시지가 도착하면 데이터는 하드 디스크에 .eml 파일로 기록됩니다. 기본적으로 이러한 파일은 Exchange가 설치된 것과 같은 파티션의 <drive>:\Program Files\Exchsrvr\Mailroot 폴더에 저장됩니다. SMTP 메일 큐가 저장된 폴더에 파일 압축을 설정하면 Exchange 성능이 심각하게 저하될 수 있습니다. 따라서 SMTP 메일 큐가 저장된 폴더는 파일 압축이 설정되지 않습니다.

Exchange 데이터 파일은 압축된 볼륨에 저장되지 않습니다. Exchange 데이터 파일을 압축된 볼륨에 저장하면 추가 오버헤드가 발생해 Exchange의 성능에 막대한 영향을 줍니다. Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

특정 폴더에서 파일 압축을 해제하려면 다음을 수행합니다.

  1. 파일 압축을 풀 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 내용을 압축하여 디스크 공간 절약 확인란의 선택을 해제한 다음 확인을 클릭합니다.

Exchange 2000 Server나 Exchange Server 2003에서 Mailroot 폴더를 옮기려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹을 클릭하고 사용 중인 관리 그룹, 서버, 사용 중인 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 중지를 클릭합니다.

  4. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 메시지 탭에서 큐 디렉터리 상자 옆의 찾아보기를 클릭한 다음 Queue 폴더의 새 위치에 대한 경로를 입력합니다.

  6. 확인을 클릭합니다.

  7. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

Mailroot 폴더 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 822933, "How to change the Exchange 2003 SMTP Mailroot folder location"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)을 참조하십시오.


SMTP 메일 큐 데이터가 암호화된 폴더에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SMTP(Simple Mail Transfer Protocol) 메일 큐 폴더의 Encrypted 키 값을 확인할 때 Win32_Directory WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Encrypted가 True로 설정되어 있는 경우 경고를 표시합니다.

SMTP 서비스를 통해 Exchange 컴퓨터에 메시지가 도착하면 해당 데이터는 하드 디스크에 .eml 파일로 기록됩니다. 기본적으로 이러한 파일은 Exchange가 설치된 것과 같은 파티션의 <drive>:\Program Files\Exchsrvr\Mailroot 폴더에 저장됩니다. SMTP 메일 큐가 저장되어 있는 폴더의 파일을 암호화하는 경우 Exchange 성능이 현저히 저하될 수 있습니다. 따라서 SMTP 메일 큐가 저장된 폴더에 대한 암호화는 지원되지 않습니다.

EFS(암호화 파일 시스템) 암호화 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일을 암호화된 볼륨에 저장하면 추가 오버헤드가 발생해 Exchange의 성능에 막대한 영향을 줍니다. Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

Exchange 데이터 파일을 보호하려면 Exchange 컴퓨터에 대한 무단 액세스를 방지하고 S/MIME 메시지 형식을 사용하여 메시지 데이터를 암호화하는 것이 좋습니다.

이 오류를 해결하려면 SMTP 메일 큐 폴더에 대한 파일 암호화를 해제하거나 암호화를 사용하지 않는 위치로 SMTP 메일 큐 폴더를 이동해야 합니다.

지정한 폴더의 파일 암호화를 해제하려면 다음을 수행합니다.

  1. 파일 암호화를 해제할 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 데이터 보호를 위해 내용을 암호화 확인란의 선택을 해제한 다음 확인을 클릭합니다.

Exchange 2000 Server 또는 Exchange Server 2003에서 SMTP 메일 큐 폴더를 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹을 클릭하고 사용 중인 관리 그룹, 서버, 사용 중인 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 중지를 클릭합니다.

  4. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 메시지 탭에서 BadMail 디렉터리 상자 옆의 찾아보기를 클릭한 다음 Queue 폴더의 새 위치에 대한 경로를 입력합니다.

  6. 확인을 클릭합니다.

  7. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

Mailroot 폴더 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 822933, "How to change the Exchange 2003 SMTP Mailroot folder location"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)을 참조하십시오.

Exchange Server 데이터 파일과 EFS에 대한 자세한 내용은 Microsoft 기술 자료 문서 834638, "Information about the storage of data files on an encrypted volume in Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)를 참조하십시오.

Microsoft Exchange Server 2003에서의 메시지 보안 방법에 대한 내용은 Exchange Server 2003 메시지 보안 가이드(http://go.microsoft.com/fwlink/?linkid=47574)를 참조하십시오.


SMTP 메일 큐 데이터가 NTFS가 아닌 파티션에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange SMTP 큐 디렉터리의 FSName 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 FSName 키 값이 NTFS File System이 아닌 경우 오류를 표시합니다.

NTFS가 아닌 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

이 오류가 발생한 경우 SMTP 큐 디렉터리를 NTFS 드라이브의 폴더로 이동해야 합니다. 또는 해당 큐 디렉터리가 저장되어 있는 드라이브가 FAT 드라이브로 포맷되어 있는 경우 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다.

SMTP 큐를 다른 폴더로 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 관리 그룹을 클릭하고 사용 중인 관리 그룹, 서버, 사용 중인 서버, 프로토콜, SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 중지를 클릭합니다.

  4. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 메시지 탭에서 BadMail 디렉터리 상자 옆의 찾아보기를 클릭한 다음 Queue 폴더의 새 위치에 대한 경로를 입력합니다.

  6. 확인을 클릭합니다.

  7. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.

Mailroot 폴더 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 822933, "How to change the Exchange 2003 SMTP Mailroot folder location"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)을 참조하십시오.

파일이 저장되어 있는 드라이브가 FAT 드라이브로 포맷된 경우에는 이 문서에 설명되어 있는 절차 대신 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다. convert.exe 명령줄 도구를 사용하여 FAT 파티션을 NTFS 파티션으로 변환하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 214579, "Convert.exe를 사용하여 파티션을 NTFS 파일 시스템으로 변환하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579)을 참조하십시오.


SMTP MaxDSNSize 값이 수동으로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 하위 키를 읽어서 배달 상태 알림(DSN) 메시지의 최대 크기가 수동으로 다시 정의되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

Exchange Server Analyzer는 MaxDSNSize가 존재하고 구성된 경우 기본 구성이 아니라는 메시지를 표시합니다.

MaxDSNSize 레지스트리 값을 사용할 수 있게 설정하여 Exchange 2000 Server 서비스 팩 2(SP2) 이상을 실행 중인 컴퓨터에서 메시지를 배달할 수 없는 경우 첨부 파일을 제거합니다. 이 옵션을 사용할 수 있게 설정하면 서버 및 네트워크 리소스를 절약할 수 있습니다. 그러나 이렇게 SMTP를 구현하면 첨부 파일이 제거되는 단점이 있습니다.

이 옵션을 사용할 수 있게 설정하여 배달 못 함 보고서(NDR)에서 첨부 파일을 제거하면 미리 보기 창에서 알림을 표시하는 데 필요한 세부 정보도 제거되어 메시지를 보낸 사람이 다시 보내기 옵션을 사용할 수 없습니다. 메시지를 보낸 사람이 NDR에서 다시 보내기 옵션을 사용하려고 하면 메시지를 보낸 사람에게 다음과 같은 오류 메시지가 나타납니다.

"Unable to resend the message. The nondelivery report does not contain sufficient information about the original message. To resend the message, open it in your Sent Items folder, click the Actions menu, and click Resend this message."

그러나 오류 메시지에 나와 있는 방법을 사용해도 메시지를 다시 보낼 수 없습니다. 따라서 이 옵션을 사용할 때는 주의해서 사용해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

MaxDSNSize 레지스트리 값을 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing을 탐색합니다.

  3. MaxDSNSize라는 DWORD 레지스트리 값을 만들고 값 데이터를 적절한 값(바이트)으로 설정합니다.

  4. 레지스트리 편집기를 닫고 SMTP 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

MaxDSNSize 레지스트리 값에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 308303, "XCON: Option to Strip Attachments for Messages That Generate an NDR"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303)

  • 323484, "XCON: Exchange 2000의 Multipart/Report 인터넷 메시지 형식에 대한 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484)


SMTP MaxPendingCat 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 기본 SMTP 큐 구성이 변경되었는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Exchange Server Analyzer는 MaxPendingCat 키가 설정되었으면 기본값이 아니라는 메시지를 표시합니다.

기본 큐 값을 수정할 때는 충분히 고려한 후에 수정하는 것이 좋습니다. 대부분의 환경에서 최적의 성능을 발휘하도록 기본값을 신중하게 선택했습니다. Exchange의 큐 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

Exchange SMTP 큐에 대한 자세한 내용은 Microsoft Exchange 팀 블로그 항목, "Explaining the Mysterious SMTP Advanced Queuing Engine"(http://go.microsoft.com/fwlink/?LinkId=48585)을 참조하십시오.


SMTP MaxMessageObjects가 너무 낮게 설정되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 시스템이 할당할 수 있는 최대 메일 메시지 수를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

Exchange Server Analyzer는 MaxMessageObjects 값이 30001보다 작은 경우 경고를 표시합니다.

큐에 최대 메시지 수가 들어 있으면 SMTP(Simple Mail Transfer Protocol)에서 추가 인바운드 메시지를 받지 않습니다. SMTP 큐에 들어 있는 각 메일 메시지는 적어도 4KB의 메모리를 사용하므로 큐가 너무 큰 경우 메모리 부족 상태가 발생할 수 있습니다.

MaxMessageObjects 값은 기본적으로 제공되지 않으며 최대 메시지 수는 100,000으로 설정됩니다. MaxMessageObjects를 더 낮게 설정하면 큐에 상주하는 최대 메시지 수를 줄여주므로 SMTP가 사용하는 최대 메모리 공간이 감소됩니다. 이 한도에 도달하면 서버에 설정된 각 SMTP 연결은 메모리 부족 오류를 반환합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

큐에 넣을 SMTP 메시지 수를 제한하려면 다음을 수행합니다.

  1. Regedit.exe나 RegEdt32.exe 같은 레지스트리 편집기를 시작합니다.

  2. HKLM\Software\Microsoft\Exchange를 탐색합니다.

  3. Exchange 키를 마우스 오른쪽 단추로 클릭한 다음 새 키를 클릭합니다. 새 키 이름을 MailMsg로 지정합니다.

  4. MailMsg 키를 마우스 오른쪽 단추로 클릭한 다음 새로 만들기 | DWORD 값을 클릭합니다.

  5. 새 값을 마우스 오른쪽 단추로 누르고 이름 바꾸기를 누른 다음 MaxMessageObjects를 입력합니다.

  6. MaxMessageObjects 값을 두 번 클릭한 후 큐에 항상 대기시킬 최대 메시지 수로 설정합니다. 더 많은 메시지를 처리해야 하지 않는 한, 최대값은 100,000으로 설정하는 것이 좋습니다.

  7. 레지스트리 편집기를 닫고 SMTP 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

큐의 메시지에 대한 제한 설정 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 258748, "How to set a limit on the number of SMTP messages in queues"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748)를 참조하십시오.


SMTP MaxMessageObjects 레지스트리 매개 변수가 기본값이 아닌 값으로 변경되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 시스템이 할당할 수 있는 최대 메일 메시지 수를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

Exchange Server Analyzer는 MaxMessageObjects 값이 0보다 큰 값으로 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

큐에 최대 메시지 수가 포함되어 있으면 SMTP는 추가 인바운드 메시지를 수락하지 않습니다. SMTP 큐에 있는 각 메일 메시지는 4KB 이상의 메모리를 사용하므로 큐가 클 경우 메모리 부족 현상이 발생할 수 있습니다.

MaxMessageObjects 값은 기본적으로 존재하지 않으며 최대 메시지 수는 100,000개로 설정됩니다. MaxMessageObjects를 더 작은 값으로 설정하면 큐에 있을 수 있는 최대 메시지 수가 줄어들기 때문에 SMTP에 대한 최대 메모리 공간이 줄어듭니다. 이 제한에 도달하면 서버에 대한 각 SMTP 연결은 메모리 부족 오류를 반환합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

대기될 수 있는 SMTP 메시지의 수에 대한 제한을 설정하려면 다음을 수행합니다.

  1. Regedit.exe나 RegEdt32.exe 같은 레지스트리 편집기를 시작합니다.

  2. HKLM\Software\Microsoft\Exchange를 탐색합니다.

  3. Exchange 키를 마우스 오른쪽 단추로 클릭한 다음 새로 만들기 | 키를 클릭합니다. 키 이름을 MailMsg로 지정합니다.

  4. MailMsg 키를 마우스 오른쪽 단추로 클릭한 다음 새로 만들기 | DWORD 값을 클릭합니다.

  5. 새 값을 마우스 오른쪽 단추로 클릭하고 MaxMessageObjects를 입력합니다.

  6. MaxMessageObjects 값을 두 번 클릭한 다음 큐에 넣을 최대 메시지 수를 설정합니다. 더 많은 메시지를 처리해야 하는 경우가 아니면 최대값으로 100,000개를 지정하는 것이 좋습니다.

  7. 레지스트리 편집기를 종료하고 SMTP(Simple Mail Transfer Protocol) 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986)을 참조하십시오.

대기 중인 메시지 수 제한을 설정하는 방법에 대한 자세한 내용은 기술 자료 문서 258748, "How to set a limit on the number of SMTP messages in queues"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748)를 참조하십시오.


SMTP MaxPercentPoolThreads 레지스트리 값이 수동으로 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 추가 풀 스레드가 수동으로 구성되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPercentPoolThreads

Exchange Server Analyzer는 MaxPercentPoolThreads가 구성되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

SMTP에는 ATQ 스레드로 알려진 스레드 풀을 사용하는 다섯 개의 작업 큐가 있습니다. 기본적으로 이러한 큐 중 두 개는 사용 가능한 스레드의 90%까지 사용할 수 있도록 설계되어 있습니다. 이 스레드 풀은 POP 및 IMAP 요청을 수락하는 프로세스에 의해 공유됩니다. 따라서 로드가 보통 이상인 경우 SMTP가 POP과 IMAP 서비스의 리소스를 차지하는 상황이 발생할 수 있습니다.

SMTP가 사용할 수 있는 스레드의 백분율을 제한하여 POP과 IMAP용의 적당한 스레드를 확보할 수 있습니다. 이렇게 변경하려면 IIS에 사용할 수 있는 전체 스레드 수를 늘려야 합니다. 다만 이때 추가 스레드 확보를 위해 메모리 사용량이 증가한다는 문제가 있습니다.

다음 두 가지 레지스트리 값을 사용하여 스레드의 SMTP 백분율과 프로세서당 추가 스레드 수를 제어할 수 있습니다.

위치: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

값: AdditionalPoolThreadsPerProc

종류: REG_DWORD

위치: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

값: MaxPercentPoolThreads

종류: REG_DWORD

SMTP 작업량이 많아 POP3, IMAP4 중 하나 또는 두 리소스 모두 실패하면 클러스터된 Exchange Server 컴퓨터에서 두 레지스트리 값 모두를 조정해야 합니다. 다음 공식을 사용하여 클러스터에 대한 최적값을 계산할 수 있습니다.

레지스트리 값 | 공식
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * 프로토콜 가상 서버 수)

예를 들어 두 개의 프로토콜 가상 서버가 있는 Exchange Server 클러스터의 경우 MaxPercentPoolThreads에 대한 공식은 90 / (2*2) = 22입니다. MaxPercentPoolThreads 값의 계산 결과가 소수점이 포함된 값이면 결과 값에서 소수점 이하 부분을 버리고 정수로 표시합니다. AdditionalPoolThreadsPerProc 값의 계산 결과가 200보다 큰 값이면 결과 값을 추가 레지스트리 값에 할당해야 합니다.

위치: HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

값: PoolThreadLimit

종류: REG_DWORD

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

Exchange 클러스터의 최적 설정을 구성하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters를 탐색합니다.

  3. AdditionalPoolThreadsPerProc라는 DWORD 레지스트리 값을 만들고 해당 값 데이터를 위 공식에 따라 적절한 수로 설정합니다.

  4. MaxPercentPoolThreads라는 DWORD 레지스트리 값을 만들고 해당 값 데이터를 위의 공식에 기초하여 적절한 수로 설정합니다.

  5. 레지스트리 편집기를 닫고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

이 문서에서 설명하는 특정 클러스터 리소스 문제에 대한 자세한 내용은 기술 자료 문서 281868, "XADM: POP\IMAP4 Virtual Servers Repeatedly Fail Over Under High Load"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868)를 참조하십시오.


SMTP MsgHandleAsyncThreshold 레지스트리 값을 수동으로 추가했지만 더 이상 필요하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 인터넷 정보 서비스(IIS)의 최대 비동기 파일 핸들 수가 기본값 1,000에서 수정되었는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleAsyncThreshold

Exchange Server Analyzer는 MsgHandleAsyncThreshold가 존재하고 대체 값으로 구성되어 있을 경우 경고를 표시합니다.

MsgHandleAsyncThreshold 값은 IIS가 사용할 수 있는 최대 비동기 파일 핸들 수를 지정합니다. 파일 핸들을 캐시하면 서버가 중복 입력/출력(I/O) 및 CPU 주기를 수행하지 않아도 되므로 성능이 향상됩니다. Exchange Server 컴퓨터에서 SMTP 전송 스택이 메시지를 받을 때마다 메시지는 대상으로 라우팅되기 전에 대기할 파일 시스템으로 스트리밍됩니다. 파일 시스템에 쓰기 위해 SMTP 전송 스택은 파일 핸들을 가져와 메시지를 이 핸들에 전달합니다. 각 파일 핸들은 페이징 풀 메모리를 2KB 정도 소비합니다. 기본 IIS 캐시 파일 핸들 수는 32MB 메모리당 800개입니다.

Exchange 2000 Server 서비스 팩 2(SP2) 이전 Exchange 서버에서는 SMTP 서비스에 대한 기본 최대 파일 핸들 수가 1,000개였기 때문에 대용량 SMTP 메시지 큐(예: 평균 1,000개 이상의 메시지)가 지속되면 성능 제한이 발생했습니다. Exchange 2000 Server에서는 기본적으로 최대 1,000개의 파일 핸들을 사용하므로 SMTP 서비스는 파일 시스템에 1,000개의 메시지만 동시에 쓸 수 있습니다.

이러한 큰 시스템의 성능을 향상시키기 위해 종종 세 개의 레지스트리 항목을 동시에 조정하여 SMTP 서비스가 열 수 있는 최대 파일 핸들 수를 늘려 더 많은 메시지를 처리할 수 있도록 했으며, 다른 Exchange 구성 요소인 설치 가능한 파일 시스템의 열린 파일 핸들 수를 줄여 큐가 클 때 메모리 부족을 피할 수 있도록 했습니다. 이러한 레지스트리 값은 다음과 같으며 기본적으로 존재하지 않으므로 수동으로 추가해야 합니다.

위치: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

값: MsgHandleThreshold

종류: REG_DWORD

위치: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

값: MsgHandleAsyncThreshold

종류: REG_DWORD

위치: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

값: FileCacheMaxHandles

종류: REG_DWORD

MsgHandleThreshold 항목과 MsgHandleAsyncThreshold 항목은 일반적으로 같은 값(보통 1,000을 초과하는 값)으로 조정되고 FileCacheMaxHandles 값은 일반적으로 800에서 600으로 감소됩니다.

이 레지스트리 값은 Exchange 2000 Server SP2 이상에서는 사용할 최적의 값을 동적으로 결정하기 때문에 기본적으로 제공되지 않습니다. Exchange 서버가 Exchange 2000 Server SP1(서비스 팩 1) 이하를 실행 중이면 최신 서비스 팩과 롤업 패키지로 업그레이드하는 것이 좋습니다. 최신 코드로 업그레이드를 완료하면 이러한 레지스트리 항목을 삭제할 수 있습니다.

Exchange Server 2003에서는 SMTP 파일 핸들에 적절한 설정을 동적으로 계산하므로 이러한 설정이 더 이상 필요하지 않습니다. 따라서 Microsoft 기술 지원 서비스에서 별도로 지침을 제공하지 않으면 이러한 설정값이 있는 Exchange 2000 Server 컴퓨터를 Exchange Server 2003으로 업그레이드하기 전에 레지스트리에서 이러한 항목을 삭제해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing을 탐색합니다.

  3. 오른쪽 창에서 MsgHandleAsyncThreshold 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


SMTP MsgHandleThreshold 레지스트리 값이 수동으로 추가되었으나 더 이상 필요하지 않을 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer는 다음 레지스트리 항목을 읽어 IIS(인터넷 정보 서비스) 파일 핸들의 최대 수가 기본값인 1,000에서 변경되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleThreshold

Exchange Server Analyzer는 MsgHandleThreshold가 있고 다른 값으로 구성되어 있을 경우 기본 구성이 아니라는 메시지를 표시합니다.

MsgHandleThreshold 값은 IIS가 사용할 수 있는 파일 핸들의 최대 수를 지정합니다. 파일 핸들을 캐시하면 서버가 중복 입력/출력(I/O) 및 CPU 주기를 수행하지 않아도 되므로 성능이 향상됩니다. Exchange Server 컴퓨터에서 SMTP 전송 스택이 메시지를 받을 때마다 메시지는 대상으로 라우팅되기 전에 대기할 파일 시스템으로 스트리밍됩니다. 파일 시스템에 쓰기 위해 SMTP 전송 스택은 파일 핸들을 가져와 메시지를 이 핸들에 전달합니다. 각 파일 핸들은 페이징 풀 메모리를 2KB 정도 소비합니다. 기본 IIS 캐시 파일 핸들 수는 32MB 메모리당 800개입니다.

Exchange 2000 Server 서비스 팩 2(SP2) 이전 Exchange 서버에서는 SMTP 서비스에 대한 기본 최대 파일 핸들 수가 1,000개였기 때문에 대용량 SMTP 메시지 큐(예: 평균 1,000개 이상의 메시지)가 지속되면 성능 제한이 발생했습니다. Exchange 2000 Server의 기본 최대 파일 핸들 수가 1,000개로 설정되었기 때문에 SMTP 서비스는 1,000개의 동시 메시지만 파일 시스템에 기록할 수 있었습니다.

이러한 큰 시스템의 성능을 향상시키기 위해 종종 세 개의 레지스트리 항목을 동시에 조정하여 SMTP 서비스가 열 수 있는 최대 파일 핸들 수를 늘려 더 많은 메시지를 처리할 수 있도록 했으며, 다른 Exchange 구성 요소인 설치 가능한 파일 시스템의 열린 파일 핸들 수를 줄여 큐가 클 때 메모리 부족을 피할 수 있도록 했습니다. 이러한 레지스트리 값은 다음과 같으며 기본적으로 존재하지 않으므로 수동으로 추가해야 합니다.

위치: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

값: MsgHandleThreshold

종류: REG_DWORD

위치: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

값: MsgHandleAsyncThreshold

종류: REG_DWORD

위치: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

값: FileCacheMaxHandles

종류: REG_DWORD

MsgHandleThreshold 항목과 MsgHandleAsyncThreshold 항목은 보통 같은 값(보통 1,000을 초과하는 값)으로 조정되고 FileCacheMaxHandles 값은 보통 800에서 600으로 감소됩니다.

이 Exchange 서버에서 Exchange 2000 Server를 실행하는 경우 최신 서비스 팩과 롤업 패키지로 업그레이드하는 것이 좋습니다. 최신 코드로 업그레이드한 후 MsgHandleThreshold 값을 기본값 1000으로 설정합니다.

Exchange Server 2003에 대한 기본 MsgHandleThreshold 값은 1000이므로 이러한 레지스트리 무시 설정이 더 이상 필요하지 않습니다. 따라서 Microsoft 기술 지원 서비스의 다른 지시가 없으면 이러한 설정이 있는 Exchange 2000 Server 컴퓨터를 Exchange Server 2003으로 업그레이드하기 전에 레지스트리에서 이러한 항목을 삭제해야 합니다.

중요:
이 문서에는 레지스트리 편집에 대한 내용이 포함되어 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe 또는 Regedt32.exe의 "레지스트리 복원" 도움말 항목을 참조하십시오.

이 오류를 수정하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing을 탐색합니다.

  3. MsgHandleThreshold 값을 삭제합니다.

  4. 레지스트리 편집기를 닫고 IIS Admin 서비스를 다시 시작하여 변경 내용을 적용합니다.

레지스트리 편집 방법에 대한 자세한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.


SMTP 픽업 파일이 압축된 폴더에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SMTP(Simple Mail Transfer Protocol) 픽업 폴더의 Compressed 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Compressed 값이 True로 설정되어 있을 경우 경고를 표시합니다.

메시지가 SMTP 서비스를 통해 Exchange 컴퓨터에 도착하면 해당 데이터는 하드 디스크에 .eml 파일로 기록됩니다. 기본적으로 이러한 파일은 Exchange가 설치된 것과 동일한 파티션의 <drive>:\Program Files\Exchsrvr\Mailroot 폴더에 저장됩니다. SMTP 픽업 데이터가 저장된 폴더에 파일 압축을 설정하면 Exchange 성능이 심각하게 저하될 수 있습니다. 따라서 SMTP 픽업 데이터가 저장된 폴더는 파일 압축이 설정되지 않습니다.

이 경고를 받으면 SMTP 픽업 데이터가 저장된 폴더에서 압축을 해제거나 압축되지 않은 폴더로 SMTP 픽업 데이터를 옮겨야 합니다.

Exchange 데이터 파일은 압축된 볼륨에 저장되지 않습니다. Exchange 데이터 파일을 압축된 볼륨에 저장하면 추가 오버헤드가 발생해 Exchange의 성능에 막대한 영향을 줍니다. Exchange 데이터 파일에는 다음과 같은 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

특정 폴더에서 파일 압축을 해제하려면 다음을 수행합니다.

  1. 파일 압축을 풀 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 내용을 압축하여 디스크 공간 절약 확인란의 선택을 해제한 다음 확인을 클릭합니다.

PickUp 폴더 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서, "How to change the Exchange 2003 SMTP Mailroot folder location"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)을 참조하십시오.


SMTP Pickup 파일이 암호화된 폴더에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SMTP(Simple Mail Transfer Protocol) PickUp 폴더의 Encrypted 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 Encrypted가 True로 설정되어 있는 경우 경고를 표시합니다.

SMTP 서비스를 통해 Exchange 컴퓨터에 메시지가 도착하면 해당 데이터는 하드 디스크에 .eml 파일로 기록됩니다. 기본적으로 이러한 파일은 Exchange가 설치된 것과 같은 파티션의 <drive>:\Program Files\Exchsrvr\Mailroot 폴더에 저장됩니다. SMTP PickUp 데이터가 저장된 폴더에 파일 압축을 설정하면 Exchange 성능이 심각하게 저하될 수 있습니다. 따라서 SMTP PickUp 데이터가 저장되는 폴더를 암호화하는 것은 지원되지 않습니다.

이 경고가 표시되면 SMTP PickUp 데이터가 저장된 폴더에서 암호화를 해제하거나 SMTP PickUp 데이터를 암호화되지 않은 폴더로 이동해야 합니다.

EFS(암호화 파일 시스템) 암호화 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일을 암호화된 볼륨에 저장하면 추가 오버헤드가 발생하여 Exchange의 성능에 막대한 영향을 줍니다. Exchange 데이터 파일에는 아래의 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

  • .chk 파일

Exchange 데이터 파일을 보호하려면 Exchange 컴퓨터에 대한 무단 액세스를 방지하고 S/MIME 메시지 형식을 사용하여 메시지 데이터를 암호화하는 것이 좋습니다.

이 오류를 해결하려면 PickUp 폴더에서 파일 암호화를 해제하거나 PickUp 폴더를 암호화가 사용되지 않은 위치로 이동합니다.

지정한 폴더의 파일 암호화를 해제하려면 다음을 수행합니다.

  1. 파일 암호화를 해제할 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  2. 일반 탭에서 고급을 클릭합니다.

  3. 고급 특성 대화 상자에서 데이터 보호를 위해 내용을 암호화 확인란의 선택을 해제한 다음 확인을 클릭합니다.

PickUp 폴더 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서 822933, "How to change the Exchange 2003 SMTP Mailroot folder location"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)을 참조하십시오.

Exchange Server 데이터 파일과 EFS에 대한 자세한 내용은 기술 자료 문서 834638, "Information about the storage of data files on an encrypted volume in Exchange Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638)를 참조하십시오.

Exchange Server 2003의 메시지 보안 유지 방법에 대한 자세한 내용은 Exchange Server 2003 메시지 보안 가이드(http://go.microsoft.com/fwlink/?linkid=47574)를 참조하십시오.


SMTP Pickup 파일이 NTFS가 아닌 파티션에 기록됩니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 Exchange SMTP PickUp 디렉터리의 FSName 키 값을 확인할 때 Win32_Directory Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. Exchange Server Analyzer는 FSName 키 값이 NTFS와 다른 경우 경고를 표시합니다.

NTFS가 아닌 볼륨에서는 Exchange 데이터 파일을 저장할 수 없습니다. Exchange 데이터 파일에는 아래의 파일이 모두 포함되어 있습니다.

  • .edb 파일

  • .stm 파일

  • .log 파일

  • .dat 파일

  • .eml 파일

이러한 경고가 나타나면 SMTP PickUp 디렉터리를 NTFS 파일 시스템 드라이브의 폴더로 옮겨야 합니다. 또는 PickUp 디렉터리가 FAT 드라이브로 포맷된 드라이브에 저장되어 있을 경우에는 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다.

PickUp 폴더 이동에 대한 자세한 내용은 Microsoft 기술 자료 문서, "How to change the Exchange 2003 SMTP Mailroot folder location"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933)을 참조하십시오.

또는 파일이 FAT 드라이브로 포맷된 드라이브에 저장되어 있을 경우에는 convert.exe 명령줄 도구를 사용하여 드라이브를 NTFS로 변환할 수 있습니다. convert.exe 명령줄 도구를 사용하여 FAT 파티션을 NTFS 파티션으로 변환하는 방법에 대한 자세한 내용은 기술 자료 문서 214579, "Convert.exe를 사용하여 파티션을 NTFS 파일 시스템으로 변환하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579)을 참조하십시오.


SMTP 포트 변경
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-11

Microsoft® Exchange Server Analyzer Tool은 인터넷 정보 서비스(IIS) 메타베이스에서 다음 속성을 읽어 값이 기본값 25와 일치하는지 확인합니다.

LM/SmtpSvc/<SMTP 가상 서버 인스턴스>/SMTPPORT

Exchange Server Analyzer는 SMTPPORT 속성 값이 25가 아닐 경우 경고를 표시합니다.

SMTPPORT 속성은 이 SMTP(Simple Mail Transfer Protocol) 서버가 들어오는 연결을 수신 대기하는 TCP 포트를 나타냅니다. 하나 이상의 TCP 포트를 수신 대기하도록 SMTP 가상 서버를 구성할 수 있습니다. 기본적으로 모든 SMTP 가상 서버는 기본 SMTP 포트인 TCP 포트 25에서 수신 대기하도록 구성됩니다. SMTP 수신 대기 포트가 기본값에서 변경되어 더 이상 수신 대기 포트 목록에 TCP 포트 25가 들어 있지 않으면 메일 흐름이 중단될 수 있습니다.

내부 메시징 인프라의 나머지 부분도 이에 맞게 변경할 경우 SMTP 수신 대기 포트를 변경하는 것도 가능합니다. 그러나 일반적으로 포트 25를 통해 인터넷으로 메시지를 보내는 SMTP 서버와 마찬가지로 인터넷에서 메시지를 직접 받는 SMTP 가상 서버에 대해서는 대체 포트를 사용할 수 없습니다.

참고:
Exchange Server Analyzer는 Exchange SMTP 프로토콜 가상 서버에 대한 값을 확인합니다. 이 SMTP 프로토콜 가상 서버가 인터넷에서 메시지를 직접 받는 SMTP 서버일 필요는 없습니다. 포트 25를 통해 인터넷에서 SMTP 메시지를 받아 다른 포트의 Exchange SMTP 가상 서버로 리디렉션하도록 설계된 바이러스 백신 및 스팸 방지 제품이 있습니다. 이 시나리오에서는 포트 25 이외의 다른 포트에서 수신을 대기하도록 Exchange SMTP 가상 서버를 구성할 수 있습니다.
SMTP 가상 서버 수신 대기 포트를 확인 또는 수정하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, Exchange 서버, 프로토콜, SMTP를 차례로 확장합니다.

  2. 기본 SMTP 가상 서버 등의 SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭을 선택한 다음 고급을 클릭합니다.

  4. IP 주소 및 포트 목록이 표시됩니다.

    • 기존 포트를 변경하려면 IP 주소를 선택한 다음 편집을 클릭합니다. TCP 포트 필드를 25로 변경합니다.

    • 포트 25를 추가 수신 대기 포트로 추가하려면 추가를 클릭하고 새 IP 주소/포트 조합을 추가합니다. 연결, 보낸 사람 또는 받는 사람 필터링을 사용할 경우 해당 확인란을 선택해야 합니다.

  5. 확인을 클릭하여 변경 내용을 저장한 다음 확인을 클릭하여 고급 대화 상자를 끝냅니다. 확인을 클릭하여 SMTP 가상 서버에 대한 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


SMTP 큐 폴더에 많은 파일이 들어 있음
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-06

Microsoft® Exchange Server Analyzer Tool은 인터넷 정보 서비스(IIS) 메타베이스를 쿼리하여 각 SMTP(Simple Mail Transfer Protocol) 가상 서버의 QueueDirectory 특성 값을 확인합니다.

그런 다음 각 STMP 가상 서버용으로 지정된 큐 폴더 내에 있는 파일의 수를 셉니다.

SMTP 가상 서버의 큐 폴더에 있는 파일 수가 50000개 이상이면 Exchange Server Analyzer는 경고를 표시합니다.

또한 SMTP 가상 서버의 큐 폴더에 있는 파일 수가 90,000개 이상이면 Exchange Server Analyzer는 오류를 표시합니다.

이러한 경고 또는 오류 메시지는 SMTP 가상 서버 인스턴스가 처리해야 하는 메시지가 누적되어 있음을 의미합니다. 또한, 받는 메일을 서버에서 적시에 배달할 수 없으므로 서버의 심각한 성능 문제 또는 중지가 유발될 수 있음을 나타내기도 합니다. 이러한 지연은 다음과 같은 조건 때문에 발생할 수 있습니다.

  • Active Directory® 디렉터리 서비스가 즉시 참조되지 않는 경우

  • 메시지가 로컬 배달 또는 SMTP에 대해 즉시 전달되지 않는 경우

이 문제를 해결하려면 다음을 수행하십시오.

  • 큐 폴더 내 메시지 수가 적절한지 검토하여 UCE(원치 않는 상업성 전자 메일 메시지), 스팸 또는 바이러스 공격으로 인해 서버가 비정상적으로 로드되어 있지 않은지 확인합니다.

  • STMP 서비스를 사용할 수 있으며 실행 중인지 확인합니다.

SMTP 서비스가 시작되었는지 확인하려면 다음을 수행하십시오.

  1. 서비스 MMC(Microsoft Management Console) 스냅인을 엽니다.

  2. 오른쪽 창에서 SMTP(Simple Mail Transfer Protocol) 서비스로 스크롤하여 두 번 클릭합니다. 그러면 SMTP(Simple Mail Transfer Protocol) 속성 대화 상자가 표시됩니다.

  3. 시작 유형 드롭다운 메뉴의 값이 자동으로 설정되어 있는지 확인합니다.

  4. 시작을 클릭하여 시스템 수행자 서비스를 시작합니다.

  5. 확인을 클릭하여 변경 내용을 저장하고 SMTP(Simple Mail Transfer Protocol) 속성 대화 상자를 닫습니다.

  6. 서비스 스냅인을 닫습니다.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft 기술 자료 문서 821877, "SMTP 및 X.400 큐 속성 탭의 필드 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft 기술 자료 문서 264054, "XCON: Exchange 2000 Server의 큐 상태 이해"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


SMTP 큐 폴더와 픽업 폴더가 동일합니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 메시지를 가져온 디렉터리가 특정 SMTP 가상 서버에 대해 대기 중인 메시지의 디렉터리와 다른지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 큐 디렉터리의 특성 msExchSmtpQueueDirectory와 픽업 디렉터리의 특성 msExchSmtpPickupDirectory가 같음을 확인하면 오류를 표시합니다.

이 오류는 중대한 오류입니다. msExchSmtpQueueDirectory 특성과 msExchSmtpPickupDirectory 특성이 같은 디렉터리로 설정되면 중복된 메시지가 배달됩니다. ADSI(Active Directory Service Interfaces) 편집을 사용하여 이 특성을 업데이트할 수 있습니다.

주의:
ADSI 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생될 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.
ADSI 편집을 사용하여 msExchSmtpPickupDirectory 또는 msExchSmtpQueueDirectory의 특성을 업데이트하려면 다음을 수행합니다.

  1. Windows® 2000 지원 도구 또는 Windows Server 2003 지원 도구에서 ADSI 편집 도구를 시작합니다.

  2. 다음 노드를 확장합니다.

    • 구성 컨테이너

    • 구성

    • 서비스

    • Microsoft Exchange

    • Organization_Name

    • 받는 사람 정책

    • Administrative_Group_Name

    • 서버

    • Server_Name

    • 프로토콜

    • SMTP

  3. 세부 정보 창에서 CN=1(여기서 1은 기본 SMTP 가상 서버임)을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. Select which properties to view 목록에서 Both를 클릭합니다.

  5. 더 이상 msExchSmtpQueueDirectory와 충돌하지 않도록 msExchSmtpPickupDirectory의 특성을 업데이트한 다음 완료되면 설정을 클릭합니다.

  6. 확인, 적용을 차례로 클릭한 다음 ADSI 편집을 닫습니다.

  7. 복제될 때까지 적어도 15분 동안 기다립니다.


SMTP 큐가 시스템 파티션과 동일한 드라이브에 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 msExchSmtpQueueDirectory 특성에 대해 구성된 값을 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

Exchange Server Analyzer Tool은 SMTP(Simple Mail Transfer Protocol) 서비스의 Started 키 값을 확인할 때 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리합니다. False 값은 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 서비스가 실행되고 있음을 나타냅니다. 또한 Exchange Server Analyzer는 WindowsDirectory 키 값을 확인할 때도 Win32_OperatingSystem WMI 클래스를 쿼리합니다. 이 키 값은 Windows 시스템 드라이브의 위치를 나타냅니다.

Exchange Server Analyzer에서 msExchSmtpQueueDirectory 특성이 시스템 드라이브와 동일한 드라이브를 포함하는 경로로 구성되어 있고 SMTP 서비스가 실행되고 있으며 Exchange가 Microsoft Windows Small Business Server에서 실행되고 있지 않음을 확인하면 경고가 표시됩니다.

msExchSmtpQueueDirectory 특성은 Mailroot 폴더라고도 하는 SMTP 큐 폴더의 경로를 나타냅니다. SMTP 서비스를 통해 Exchange 서버에 메시지가 도착하면 데이터는 하드 디스크에 .eml 파일로 기록됩니다. 기본적으로 이러한 파일은 Exchange가 설치된 것과 같은 파티션의 <drive>:\Program Files\Exchsrvr\Mailroot 폴더에 저장됩니다.

브리지헤드 서버를 구성할 때와 같은 일부 경우에 SMTP Mailroot 디렉터리를 다른 하드 디스크나 파티션으로 이동하여 Exchange 서버의 성능을 향상시킬 수 있습니다. SMTP Mailroot 폴더를 Windows 시스템 드라이브와 같은 드라이브에 두지 않는 것이 가장 좋습니다. 대신 이 폴더를 빠른 디스크나 빠른 디스크 하위 시스템에 배치하여 최적의 성능을 얻을 수 있습니다.

Mailroot 폴더를 Exchange Server 2003 SMTP 가상 서버의 Exchange System Manager로 이동할 수 있지만 해당 폴더를 Exchange 2000 Server SMTP 가상 서버로 이동하려면 ADSI(Active Directory Service Interfaces) 편집과 같은 간단한 Active Directory 편집기를 사용해야 합니다.

주의:
ADSI 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생될 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

Exchange Server 2003에서 이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange 서버, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 중지를 클릭합니다.

  4. SMTP 가상 서버를 마우스 오른쪽 단추로 다시 클릭한 다음 속성을 클릭합니다.

  5. 메시지 탭을 클릭합니다.

  6. 큐 디렉터리 필드에서 해당 Mailroot 폴더의 전체 경로를 지정합니다. 찾아보기를 클릭하여 로컬 컴퓨터에서 해당 경로를 찾아볼 수 있습니다.

  7. 변경 내용을 저장하려면 확인을 클릭합니다.

  8. SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다. 새 위치가 즉시 사용됩니다.

Exchange 2000 Server에서 이 오류를 수정하려면 다음을 수행합니다.

  1. 해당 SMTP 가상 서버 Mailroot 폴더를 수정하려는 Exchange 2000 Server 컴퓨터의 모든 Exchange Server 및 IIS 서비스를 중지합니다.

  2. 영향 받는 SMTP 가상 서버의 msExchSmtpQueueDirectory 값을 수정하여 적절한 경로로 구성합니다.

  3. Active Directory가 이러한 변경 내용을 해당 Exchange 서버에서 사용하는 글로벌 카탈로그 서버로 복제할 때까지 기다립니다.

  4. Microsoft Exchange System Attendant 서비스를 시작합니다.

  5. Exchange Server 컴퓨터의 응용 프로그램 이벤트 로그에서 이벤트 원본이 MSExchangeMU이고 범주가 일반인 이벤트 ID 1005의 세 인스턴스가 존재하는지 확인합니다.

  6. Exchange Server 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

이러한 두 절차에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 822933, "How to change the Exchange 2003 SMTP Mailroot folder location"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933)

  • 318230, "XCON: How to Change the Exchange 2000 SMTP Mailroot Directory Location"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230)

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


SMTP ResetMessageStatus 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 기본 SMTP 큐 구성이 변경되었는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

Exchange Server Analyzer는 다음 조건이 존재하는 경우 오류를 표시합니다.

  • ResetMessageStatus 키가 0(영)으로 설정되지 않은 경우

  • Exchange Server에서 클러스터 서비스를 실행하지 않은 경우

ResetMessageStatus 레지스트리 키가 1로 설정되어 있으면 Exchange Server를 다시 시작할 때 현재 큐에 있는 모든 메시지가 모든 내부 처리 큐를 다시 거치게 됩니다. 예를 들어 Exchange Server를 다시 시작하면 현재 큐에 있는 모든 메시지가 분류기를 다시 거치게 됩니다. 따라서 Microsoft 기술 자료 문서 279616, "XCON: Adding a Registry Key to Re-Categorize Messages"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=279616)에서 설명하는 것처럼, SMTP 설치 문제를 해결할 경우에만 ResetMessageStatus 키를 1로 설정해야 합니다. SMTP 설치 문제를 해결하는 경우가 아니라면 이 레지스트리 키를 삭제해야 합니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
ResetMessageStatus 레지스트리 키를 삭제하려면 다음을 수행합니다.

  1. Regedit.exe나 Regedt32.exe 같은 레지스트리 편집기를 엽니다.

  2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing을 탐색합니다.

  3. 오른쪽 창에서 ResetMessageStatus 값을 찾아 삭제합니다.

  4. 레지스트리 편집기를 닫습니다.

레지스트리를 편집하기 전에 레지스트리 편집 방법에 대한 내용을 보려면 Microsoft 기술 자료 문서 256986, "Microsoft Windows 레지스트리 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)을 참조하십시오.

Exchange SMTP 큐에 대한 자세한 내용은 Microsoft Exchange 팀 블로그 항목, "Explaining the Mysterious SMTP Advanced Queuing Engine"(http://go.microsoft.com/fwlink/?LinkId=48585)을 참조하십시오.


The SMTP ResetRoutesRetryMinutes registry value is non-default
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 기본 SMTP 큐 구성이 변경되었는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Exchange Server Analyzer는 ResetRoutesRetryMinutes 키가 설정되었으면 기본값이 아니라는 메시지를 표시합니다.

기본 큐 값을 수정할 때는 충분히 고려한 후에 수정하는 것이 좋습니다. 대부분의 환경에서 최적의 성능을 발휘하도록 기본값을 신중하게 선택했습니다. Exchange Server의 큐 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

Exchange SMTP 큐에 대한 자세한 내용은 Microsoft Exchange 팀 블로그 항목, "Explaining the Mysterious SMTP Advanced Queuing Engine"(http://go.microsoft.com/fwlink/?LinkId=48585)을 참조하십시오.


SMTP RoutingRetryMinutes 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 기본 SMTP 큐 구성이 변경되었는지 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Exchange Server Analyzer는 RoutingRetryMinutes 키가 설정되었으면 기본값이 아니라는 메시지를 표시합니다.

기본 큐 값을 수정할 때는 충분히 고려한 후에 수정하는 것이 좋습니다. 대부분의 환경에서 최적의 성능을 발휘하도록 기본값을 신중하게 선택했습니다. Exchange Server의 큐 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

Exchange SMTP 큐에 대한 자세한 내용은 Microsoft Exchange 팀 블로그 항목, "Explaining the Mysterious SMTP Advanced Queuing Engine"(http://go.microsoft.com/fwlink/?LinkId=48585)을 참조하십시오.


SMTP SecondsPerDSNPass 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 SecondsPerDSNPass 레지스트리 값의 설정을 확인합니다.

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Exchange Server Analyzer는 SecondsPerDSNPass 키가 있고 이 값이 10으로 설정되어 있지 않으면 기본 구성이 아니라는 메시지를 표시합니다.

이 설정은 배달 상태 알림(DSN)을 최적화하는 데 사용되고 각 DSN 처리에 소요되는 시간(초)을 지정합니다. 이 임계값이 초과되는 즉시 DSN 생성이 중지된 다음 나중에 다시 시작됩니다. 기본값을 수정할 때는 충분히 고려한 후에 수정하는 것이 좋습니다. 이 특정 설정은 Microsoft 지원 서비스에 문의한 후에만 수정하십시오. 대부분의 환경에서 최적의 성능을 발휘하도록 기본값을 신중하게 선택했습니다. Exchange Server의 큐 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다.

The Exchange Server Analyzer reports this configuration for informational purposes only. 필요한 작업이 없습니다.


SMTP 서버의 NTLM 인증이 비활성화되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-11-10

Microsoft® Exchange Server Analyzer Tool은 msExchAuthenticationFlags 속성에 NTLM 인증 프로토콜(Windows 통합 인증) 비트가 설정되어 있는지 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 해당 비트가 설정되어 있지 않고 Exchange가 Microsoft Windows® Small Business Server에서 실행되고 있지 않으면 경고를 표시합니다.

msExchAuthenticationFlags 특성은 프로토콜 가상 서버에서 허용하는 인증 유형을 나타냅니다. 이 특성은 3비트 마스크를 사용합니다.

비트 | 인증 방식
0 | 익명
1 | 기본
2 | NTLM(Windows 통합 인증)

NTLM 인증을 제어하는 비트가 설정되어 있지 않으면 SMTP 가상 서버는 NTLM 인증을 허용하지 않습니다. 이로 인해 Exchange Server 컴퓨터 간에 인증 문제가 발생할 수 있습니다.

이 경고를 해결하려면 다음을 수행하십시오.

  1. Exchange System Manager를 엽니다.

  2. 서버, 해당 서버 이름, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. Exchange SMTP 가상 서버를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 액세스 탭을 클릭하고 인증을 클릭한 다음 Windows 통합 인증 확인란을 클릭하여 선택합니다.

  5. 확인을 클릭한 다음 다시 확인을 클릭합니다.

  6. Exchange System Manager를 닫습니다.

SMTP의 인증 방식에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579) 및 Microsoft 기술 자료 문서 319267, "HOWTO: Exchange 2000에서 Simple Message Transfer Protocol 클라이언트 메시지 배달 보호"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267)를 참조하십시오.


SMTP SubmissionRetryMinutes 레지스트리 값이 기본값이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 기본 SMTP 큐 구성이 변경되었는지 여부를 확인합니다.

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

SubmissionRetryMinutes 키가 설정되어 있으면 Exchange Server Analyzer에서 기본값이 아니라는 메시지를 표시합니다.

기본 큐 값을 수정할 때는 충분히 고려한 후에 수정하는 것이 좋습니다. 대부분의 환경에서 최적의 성능을 발휘하도록 기본값을 신중하게 선택했습니다. Exchange의 큐 동작을 수정하는 대신 문제의 정확한 원인을 해결하는 것이 일반적으로 가장 좋은 방법입니다.

Exchange Server Analyzer는 정보를 제공하기 위한 목적으로만 이 구성을 보고합니다. 필요한 작업이 없습니다.

Exchange SMTP 큐에 대한 자세한 내용은 Microsoft Exchange 팀 블로그 항목, "Explaining the Mysterious SMTP Advanced Queuing Engine"(http://go.microsoft.com/fwlink/?LinkId=48585)을 참조하십시오.


SMTP 가상 서버의 메시지 크기 제한이 전역 메시지 크기 제한보다 큽니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 SMTP 가상 서버 받는 메시지 크기 제한을 받는 전역 메시지 크기 제한과 비교할 때 Active Directory® 디렉터리 서비스를 쿼리합니다.

받는 메시지와 보내는 메시지에 대한 SMTP 가상 서버 메시지 크기 제한을 나타내는 Active Directory 특성은 msExchSmtpMaxMessageSize입니다. 이 값은 Active Directory에 있는 SMTP 가상 서버 개체의 특성으로 아래 위치에 있습니다.

CN=<Virtual Server Number>, CN=SMTP, CN=Protocols, CN=<ServerName>, CN=Servers, CN=<AdministrativeGroupName>, CN=Administrative Groups, CN=<OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration, DC=<DomainName>, DC=com

전역 받는 메시지 크기 제한을 나타내는 Active Directory 특성은 delivContLength입니다. 이 값은 Active Directory에 있는 해당 조직의 전역 설정 메시지 배달 개체의 특성으로 아래 위치에 있습니다.

CN=Message Delivery, CN=Global Settings, CN=<OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration, DC=<DomainName>, DC=com

Exchange Server Analyzer는 msExchSmtpMaxMessageSize 값이 delivContLength 값보다 클 경우 경고를 표시합니다.

SMTP 가상 서버의 메시지 크기 제한이 전역 메시지 크기 제한보다 크면 대용량 메시지는 인바운드가 허용된 후 바로 배달 못 함 상태가 될 수 있습니다. 이 문제를 해결하려면 최대 메시지 크기가 전역 받는 메시지 크기 제한보다 작거나 같도록 SMTP 가상 서버를 구성합니다.

참고:
메시지 크기 제한을 너무 낮게 설정하면 Exchange Server 컴퓨터 간 오프라인 주소록 복제가 수행되지 않을 수 있습니다. 이 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 326154, "XADM: The OAB Does Not Replicate If You Set a Message Size Restriction at the Transport Level"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154)을 참조하십시오.

이 경고를 해결하려면 다음을 수행합니다.

  1. Exchange System Manager에서 서버, Exchange 서버, 프로토콜, SMTP를 차례로 확장합니다.

  2. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  3. 메시지 탭을 선택합니다.

  4. 메시지 크기 제한(KB) 필드 값이 전역 메시지 크기 제한보다 작거나 같도록 필드 값을 편집합니다.

  5. 확인을 클릭하여 변경 내용을 저장하고 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

조직 전체의 설정 보기 및 편집에 대한 자세한 내용은 기술 자료 문서 821881, "How to Modify Global Settings in Exchange System Manager"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821881)를 참조하십시오.

전역 메시지 크기 제한에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 298572, "An E-Mail Message That Is Larger Than the Sending Message Size Limit or the Receiving Message Size Limit Is Not Delivered"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=298572)

  • 322679, "Exchange Server에서 메시지 크기 제한을 설정하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)

  • 824111, "Exchange Server 2003에서 새로 추가된 보안 설정 변경 및 업데이트"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=824111).


이 SMTP 가상 서버는 받는 메시지에 대한 DNS 역방향 조회를 수행하도록 구성되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-24

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 msExchSmtpPerformReverseDnsLookup 특성 값이 기본값인 False가 아닌 값으로 구성되었는지 여부를 확인합니다. 기본적으로 msExchSmtpPerformReverseDnsLookup 특성은 받는 메시지에 대한 DNS 역방향 조회를 수행하지 않도록 구성됩니다. Exchange Server Analyzer는 이 특성이 True로 설정되어 있을 경우 경고를 표시합니다.

받는 메시지에 DNS 역방향 조회 수행 옵션에는 스팸 메일 메시지의 수신을 차단하는 기능이 없습니다. 이 옵션을 사용할 때 Exchange Server는 DNS 쿼리를 수행하여 받는 메시지의 원래 보낸 인터넷 프로토콜(IP) 주소를 호스트 이름으로 해석합니다. 그런 다음 호스트 이름은 전자 메일 메시지의 헤더에 첨부됩니다.

이 기능을 사용하면 잘못 구성된 DNS 레코드나 인터넷에 대한 잦은 연결 때문에 성능이 저하될 수 있습니다. 따라서 인터넷 메일 배달이 예상보다 늦을 경우 이 옵션을 사용하지 않도록 설정할 수 있습니다.

받는 SMTP 메시지에 DNS 역방향 조회를 사용하거나 사용하지 않으려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange 서버, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 배달 탭을 클릭한 다음 고급을 클릭합니다.

    • DNS 역방향 조회를 사용하려면 받는 메시지에 DNS 역방향 조회 수행 확인란을 선택합니다.

    • DNS 역방향 조회를 사용하지 않으려면 받는 메시지에 DNS 역방향 조회 수행 확인란의 선택을 해제합니다.

  5. 확인을 클릭하여 변경 내용을 저장하고 다시 확인을 클릭하여 SMTP 가상 서버 속성 대화 상자를 닫습니다.

Exchange의 DNS 역방향 조회 기능에 대한 자세한 내용은 Microsoft 기술 자료 문서 297412, "'받는 메시지에 DNS 역방향 조회 수행' 옵션은 호스트 이름 확인을 위한 것이다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)를 참조하십시오.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


지능형 메시지 필터링 SP1 버전을 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool은 다음 레지스트리 항목을 읽어 Microsoft Exchange Intelligent Message Filter가 서버에 설치되어 있고 사용 가능한지 확인합니다.

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer는 ContentFilter 레지스트리 키의 ContentFilterBindings 값을 읽어 지능형 메시지 필터링이 서버에 설치되어 있고 사용 가능한지 확인합니다.

그런 다음 Exchange Server Analyzer는 CIM_Datafile Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 Exchange Server 2003 서비스 팩 1(SP1) 버전의 Intelligent Message Filter MSExchange.UceContentFilter.dll이 Exchange 서버의 다음 경로에 있는지 확인합니다.

<Exchange 서버 이진 파일의 경로>\MSCFv1\MSExchange.UceContentFilter.dll

참고:
이 경로에서 <Exchange 서버 이진 파일의 경로>는 Bin 폴더의 위치입니다.

Exchange Server 2003 SP1 버전의 지능형 메시지 필터링이 서버에 설치되어 있고 사용 가능하면 Exchange Server Analyzer는 경고를 표시합니다.

이 경고는 최신 버전의 지능형 메시지 필터링이 있음을 나타냅니다. 최신 버전의 지능형 메시지 필터링을 설치하는 것이 좋습니다. 이 특정 서버와 관련된 메일 흐름 문제를 해결하려면 지능형 메시지 필터링을 일시적으로 사용 불가능하게 하여 적합한 메일이 잘못 차단되고 있는지 여부를 확인할 수 있습니다.

지능형 메시지 필터링을 사용하지 않으려면 다음을 수행합니다.

  1. 시작을 클릭하고 모든 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭합니다.

  2. Exchange System Manager에서 서버, 서버 이름, 프로토콜, SMTP를 차례로 확장하고 지능형 메시지 필터링을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭의 다음 가상 서버의 IP 주소에 지능형 메시지 필터링을 적용합니다에서 지능형 메시지 필터링을 사용하지 않을 각 SMTP 가상 서버 옆의 확인란을 해제합니다.

    지능형 메시지 필터링 속성 대화 상자

자세한 내용은 Exchange 지능형 메시지 필터링 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21607)를 참조하십시오.


지능형 메시지 필터링 SP2 버전을 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-04

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 가상 서버 개체의 msExchServerBindingsFiltering 속성이 SMTP 가상 서버 인스턴스에 대해 지능형 메시지 필터링을 사용함을 나타내는지 확인합니다.

또한 Exchange Server Analyzer는 Active Directory를 쿼리하여 전역 설정 수준에서 msExchUceEnabled를 사용하는지 여부를 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고를 표시합니다.

  • SMTP 가상 서버 인스턴스에 대해 지능형 메시지 필터링을 사용하는 경우

  • 전역 설정 수준에서 지능형 메시지 필터링을 사용할 수 있는 경우

이 경고는 지능형 메시지 필터링의 Exchange Server 2003 SP2(서비스 팩 2) 버전이 사용되고 있음을 나타냅니다. 지능형 메시지 필터링의 SP2 버전을 사용해도 이 특정 서버와 관련된 메일 흐름 문제를 해결하는 경우가 아니면 일반적으로 문제가 되지 않습니다. 이러한 경우 필터 구성을 확인하거나 지능형 메시지 필터링을 일시적으로 사용 불가능하게 하여 합법적 메일이 잘못 차단되고 있는지 여부를 확인할 수 있습니다.

지능형 메시지 필터링을 사용하지 않으려면 다음을 수행합니다.

  1. 시작을 클릭하고 모든 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭합니다.

  2. Exchange System Manager에서 서버, 서버 이름, 프로토콜, SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버 속성의 일반 탭에서 고급을 클릭합니다.

  4. 지능형 메시지 필터링을 사용하지 않을 IP 주소를 선택하고 편집을 클릭합니다.

  5. 확인에서 지능형 메시지 필터링 적용의 선택을 취소합니다.

  6. 가상 서버가 여러 개인 경우 지능형 메시지 필터링을 사용하지 않을 각 가상 서버에 대해 3단계부터 6단계까지 반복합니다.

자세한 내용은 Exchange 지능형 메시지 필터링 웹 사이트(http://go.microsoft.com/fwlink/?LinkId=21607)를 참조하십시오.


지정된 게이트웨이 서버가 사용되지 않음
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-09

Microsoft® Exchange Server Analyzer Tool은 Exchange 서버에서 사용자 정의 외부 계정으로 테스트 메시지를 보낸 다음 서버의 메시지 추적 로그를 검색하여 테스트 메시지를 배달하는 동안 문제가 발생했는지 확인합니다.

이 검색 과정에서 Exchange Server Analyzer는 외부 받는 사람에게 메시지를 라우팅하는 데 사용된 Exchange 게이트웨이 서버가 서버 이름 및 자격 증명 단계의 서버 이름 및 사용자 정보 입력 페이지에서 사용자가 지정한 서버와 같은지 확인합니다.

메시지가 Exchange 조직 외부로 라우팅되었지만 지정된 게이트웨이 서버를 사용하지 않은 경우 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 Exchange 라우팅 토폴로지에 문제가 있으며 알 수 없는 아웃바운드 게이트웨이 서버가 있음을 나타냅니다.

커넥터 수준이 아닌 가상 서버 수준에서 스마트 호스트 항목이 설정된 경우 라우팅 문제가 발생할 수도 있습니다. SMTP 가상 서버가 아닌 SMTP 커넥터에서 스마트 호스트 항목을 설정하는 것이 좋습니다.

이 경고를 해결하려면 다음 단계를 수행합니다.

  • SMTP(Simple Mail Transfer Protocol) 가상 서버 구성을 검토하여 설정된 스마트 호스트 항목이 없도록 합니다.

  • 로컬 브리지헤드 서버 구성에서 커넥터의 주소 공간과 순위가 올바른지 검토합니다.

스마트 호스트 설정을 보고 구성하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 서버, Exchange Server, 프로토콜 및 SMTP를 차례로 확장합니다.

  3. SMTP 가상 서버(예: 기본 SMTP 가상 서버)를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  4. 배달 탭을 선택하고 고급을 클릭합니다.

  5. 스마트 호스트 아래의 모든 항목을 선택 취소합니다.

  6. 확인을 클릭하여 변경 내용을 저장한 다음 확인을 클릭하여 SMTP 가상 서버의 속성 대화 상자를 닫습니다.

SMTP 커넥터를 구성하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 822941, "How to use SMTP connectors to connect routing groups in Exchange 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=822941)을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkID=67875)의 "메일 흐름 및 SMTP 문제 해결"

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)


다른 서버에서 지정된 보낸 사람
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-08-10

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스에서 모든 사용자 개체의 proxyAddress 특성 값을 쿼리하여 사용자 지정 로컬 보낸 사람 SMTP(Simple Mail Transfer Protocol) 주소에 일치하는 항목이 있는지 확인합니다.

사용자 개체 proxyAddress에 일치하는 항목이 있으면 Exchange Server Analyzer는 Active Directory에서 해당 사용자 개체의 msExchHomeServerName 특성 값을 쿼리하여 이 값이 사용자 지정 Exchange Server 이름과 일치하는지 확인합니다.

사용자 지정 보낸 사람의 msExchHomeServerName 특성 값이 사용자 지정 Exchange Server 이름과 일치하지 않는 경우 Exchange Server Analyzer에서 경고를 표시합니다.

이 경고는 잘못된 Exchange Server 이름이 제공되었거나 메일 흐름 문제가 사용자 지정 서버가 아닌 다른 서버에 영향을 주었음을 나타냅니다.

이 문제를 해결하려면 올바른 Exchange Server 이름을 입력했는지 확인합니다.

지정한 서버의 사용자 사서함을 보려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

    시작을 클릭하고 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭합니다.

  2. Exchange System Manager에서 다음 컨테이너로 이동하여 클릭합니다.

    \Administrative Groups\ GroupName \Servers\ ServerName \ StorageGroupName \Mailbox Store\Mailboxes

  3. 지정한 사용자 사서함이 지정된 Exchange Server에 표시되는지 확인합니다.


대상 서버를 식별할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-07-06

Microsoft® Exchange Server Analyzer Tool은 원격 배달 큐에 있는 메일이 전송될 원격 서버의 FQDN(정규화된 도메인 이름), IP 주소 및 도메인 이름의 목록을 식별하고 만들려고 합니다.

원격 서버의 FQDN, IP 주소 및 도메인 이름의 목록은 다음과 같이 만들어집니다.

  • SMTP(Simple Mail Transfer Protocol) 가상 서버의 Active Directory® 디렉터리 서비스 개체에 대한 msExchSmtpFullyQualifiedDomainName 속성을 쿼리합니다.

    참고:
    그 결과 msExchSmtpFullyQualifiedDomainName 속성은 지정된 대상 브리지헤드 서버에 대해 쿼리될 때 라우팅 그룹 커넥터 디렉터리 개체의 msExchTargetBridgeheadServersDN 속성에서 읽힙니다.
  • SMTP 커넥터 Active Directory 개체의 msExchSmtpSmartHost 속성은 SMTP 커넥터의 지정된 스마트 호스트에 대해 쿼리됩니다.

  • ExchangeLink Microsoft WMI(Windows® Management Instrumentation) 클래스의 LinkName 속성은 모든 원격 서버 직접 연결에 대해 쿼리됩니다.

이 목록을 만들 항목이 없다고 결정되는 경우 Exchange Server Analyzer에서 오류를 표시합니다.

이 오류는 다음을 나타냅니다.

  • 메일 흐름에 문제를 일으키는 네트워크 중단 또는 Active Directory 연결 문제가 있을 수 있습니다.

  • Exchange Server Analyzer를 실행하는 계정에 해당 정보를 쿼리할 수 있는 권한이 없을 수 있습니다.

이 오류를 수정하려면 다음을 수행합니다.

  1. Exchange 서버 컴퓨터가 시작되고 네트워크에 연결되었는지 확인합니다.

  2. Active Directory 도메인 컨트롤러에 네트워크를 통해 연결되었는지 확인합니다.

  3. Exchange Server Analyzer에서 Active Directory 도메인 컨트롤러를 지정합니다.

  4. PING 명령을 사용하여 Exchange 서버 컴퓨터에 연결할 수 있는지 확인합니다.

  5. 방화벽이 있으면 RPC 포트가 차단되어 있는지 확인합니다.

  6. Exchange Server Analyzer를 실행하는 계정에 대한 사용 권한을 검토합니다. Exchange Server Analyzer를 실행하는 계정에는 검색 중인 각 Exchange 서버 컴퓨터에 대한 로컬 관리자 권한이 있어야 합니다.

네트워크 연결 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 325487, "네트워크 연결 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)을 참조하십시오.

Exchange Server Analyzer 연결 문제에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?LinkId=56285)를 참조하십시오.

포트 요구 사항에 대한 자세한 내용은 기술 자료 문서 832017, "Microsoft Windows 서버 시스템의 서비스 개요 및 네트워크 포트 요구 사항"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017)을 참조하십시오.


TarpitTime이 구현되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-02-21

Microsoft® Exchange Server Analyzer Tool은 받는 사람 필터링의 타르핏 기능이 설정되어 있는지 여부를 확인할 때 다음 레지스트리 항목을 읽습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\TarpitTime

Exchange Server Analyzer는 TarpitTime 값이 0보다 크면 기본 설정이 아니라는 메시지를 표시합니다.

타르핏은 비합법적인 연결 속도를 의도적으로 저하시키거나 지연시켜 자동 스팸을 보내거나 사전 하비스트 공격을 수행할 수 있는 속도를 줄이는 방법입니다.

Microsoft 기술 자료 문서 842851, "Microsoft Windows Server 2003의 SMTP 타르핏 기능"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851)에 설명된 대로 Microsoft Windows Server™ 2003 SP1(서비스 팩 1)에서 사용할 수 있는 타르핏 기능을 추가하여 받는 사람 필터링 기능과 함께 사용할 수 있습니다. 특히 타르핏 기능을 사용하면 전역 설정의 받는 사람 필터링 탭에서 디렉터리에 없는 받는 사람 필터링 확인란을 선택하면 받는 사람 필터링을 광범위하게 사용할 수 있습니다.

타르핏 기능은 TarpitTime 레지스트리 하위 키를 설정하여 구현합니다. TarpitTime 레지스트리 하위 키는 10진수 값을 갖습니다. 10진수 값은 받는 사람이 대상 Exchange Server 조직에 없는 경우 SMTP 세션이 보낸 사람에게 응답할 때까지 기다리는 시간(초)으로 변환됩니다.

타르핏 기능은 원치 않는 메일을 보낸 스패머가 사전 하비스트 공격을 더욱 자동화하기 어렵게 합니다. 사전 하비스트 공격은 특정 조직에서 알려져 있는 유효한 전자 메일 주소 목록을 검색하려는 시도입니다.

SMTP 프로토콜은 "2.1.5 받는 사람 확인"을 반환하여 SMTP 세션 중에 적합한 받는 사람을 승인합니다. 이 경우 알 수 없는 받는 사람에게 메일을 보내면 SMTP 프로토콜은 "5.x.x" 오류를 반환합니다. 따라서 스패머가 일반 이름이나 사전 용어를 사용하여 특정 도메인에 대한 전자 메일 주소를 구성하는 자동 프로그램을 작성할 수 있습니다. 이 프로그램이 "2.1.5 받는 사람 확인"을 반환한 전자 메일 주소를 모두 수집하고 "5.x.x" 오류를 일으킨 전자 메일 주소를 모두 무시할 수 있습니다. 그러면 스패머가 "유효한" 전자 메일 주소를 팔거나 그러한 전자 메일 주소를 원치 않는 메일 수신자로 사용할 수 있습니다.

디렉터리에 없는 받는 사람 필터링 확인란을 선택했지만 TarpitTime 레지스트리 하위 키를 설정하지 않은 경우 받는 사람이 대상 Active Directory® 디렉터리 서비스에 없으면 Exchange Server가 SMTP 세션 중에 보낸 사람에게 "5.x.x" 오류를 즉시 반환합니다.

또는 TarpitTime 레지스트리 하위 키를 설정하고 디렉터리에 없는 받는 사람 필터링 확인란을 선택한 경우 SMTP는 "5.x.x" 오류를 반환할 때까지 기다립니다. TarpitTime 레지스트리 하위 키에 대해 입력한 10진수 값은 SMTP가 오류를 반환할 때까지 기다릴 시간(초)입니다. SMTP 세션에서 이러한 일시 중지는 사전 하비스트 공격 자동화를 더욱 어렵게 만듭니다.

앞에서 설명한 대로 Exchange Server Analyzer는 TarpitTime 레지스트리 하위 키를 설정한 경우 기본 설정이 아니라는 메시지를 표시합니다. 이 메시지는 정보 제공을 위한 것입니다.

중요:
이 문서에는 레지스트리 편집 정보가 나와 있습니다. 문제가 발생할 경우에는 레지스트리를 어떻게 복원하는지 레지스트리를 편집하기 전에 알고 있어야 합니다. 레지스트리를 복원하는 방법에 대한 자세한 내용은 Regedit.exe나 Regedt32.exe의 도움말 항목에서 "레지스트리 복원"을 참조하십시오.
TarpitTime 레지스트리 하위 키를 보거나 변경하려면 다음을 수행합니다.

  1. 시작, 실행을 차례로 클릭하고 열기 상자에 regedit를 입력한 다음 확인을 클릭합니다.

  2. 아래 레지스트리 하위 키를 찾은 다음 클릭합니다.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Parameters\TarpitTime

  3. 값 데이터 상자에 10진수가 표시됩니다. 이 값은 Active Directory에 없는 각 주소에 대한 SMTP 주소 확인 응답을 지연시킬 시간(초)을 나타냅니다.

  4. 값을 변경하거나 TarpitTime 레지스트리 하위 키를 삭제한 경우 SMTP(Simple Mail Transport Protocol) 서비스를 다시 시작해야 합니다.

자세한 내용은 Microsoft 기술 자료 문서 842851, "Microsoft Windows Server 2003의 SMTP 타르핏 기능"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851)을 참조하십시오.


테스트 메일로 인해 NDR이 생성되었습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool에서는 Exchange 서버에서 SMTP(Simple Mail Transfer Protocol) 도메인에 대한 전자 메일 관리자 계정 또는 사용자 정의 계정으로 테스트 메시지를 보낸 다음 서버의 메시지 추적 로그를 검색하여 테스트 메시지를 배달하는 데 문제가 있는지 확인합니다.

이 검색 과정에서 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스 아래에 있는 Exchange_MessageTrackingEntry Microsoft WMI(Windows® Management Instrumentation) 클래스의 EntryType 속성을 쿼리하여 메시지 추적 로그 항목이 생성된 원인을 확인합니다.

Exchange Server Analyzer는 EntryType 속성에 대해 값 1030를 찾으면 경고를 표시합니다.

이 경고는 테스트 메시지로 인해 NDR(배달 못 함 보고서)이 생성되었으며 서버의 SMTP(Simple Mail Transfer Protocol) 구성에 문제가 있을 수 있음을 나타냅니다. 대상 받는 사람이 없을 경우 NDR이 생성되지만 이 경우에는 테스트 메시지가 적합한 받는 사람에게 전송되었는지가 문제입니다.

문제를 해결하기 위해 동일한 받는 사람에게 다른 메시지를 보낸 후 NDR을 검토하여 원인을 확인할 수 있습니다.

NDR 문제 해결 방법에 대한 자세한 내용은 Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "배달 못 함 보고서(NDR) 메시지 문제 해결"을 참조하십시오.


Badmail 디렉터리로 테스트 메일을 보냈습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-05-17

Microsoft® Exchange Server Analyzer Tool에서는 Exchange 서버에서 SMTP(Simple Mail Transfer Protocol) 도메인에 대한 전자 메일 관리자 계정 또는 사용자 정의 계정으로 테스트 메시지를 보낸 다음 서버의 메시지 추적 로그를 검색하여 테스트 메시지를 배달하는 데 문제가 있는지 확인합니다.

이 검색 과정에서 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스 아래에 있는 Exchange_MessageTrackingEntry Microsoft WMI(Windows® Management Instrumentation) 클래스의 EntryType 속성을 쿼리하여 메시지 추적 로그 항목의 원인을 확인합니다.

Exchange Server Analyzer는 EntryType 속성에 대한 값이 1021인 경우 경고를 표시합니다.

이 경고는 Exchange 서버의 Badmail 디렉터리로 테스트 메시지를 보냈으며 서버의 SMTP(Simple Mail Transfer Protocol) 구성에 문제가 있음을 나타냅니다.

다음과 같은 경우 메시지가 Badmail 디렉터리로 보내집니다.

  • 메시지를 배달할 수 없는 경우

  • 최대 재시도 수를 초과한 경우

  • 보낸 사람에게 배달할 수 없는 메시지로 돌려보낼 수 없는 경우

나가는 메일 흐름을 테스트하는 방법은 Microsoft 기술 자료 문서 297700, "Pickup 폴더의 파일을 사용하여 아웃바운드 메일 흐름을 테스트하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297700)을 참조하십시오.

메일 흐름 및 SMTP 문제 해결 방법은 Exchange Server 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결"을 참조하십시오.


SMTP 큐에 있는 테스트 메시지
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-07-06

Microsoft® Exchange Server Analyzer Tool에서는 Exchange 서버에서 SMTP(Simple Mail Transfer Protocol) 도메인에 대한 전자 메일 관리자 계정 또는 사용자 정의 계정으로 테스트 메시지를 보낸 다음 서버의 메시지 추적 로그를 검색하여 테스트 메시지를 배달하는 데 문제가 있는지 확인합니다.

이 검색 작업의 일부분으로 Exchange Server Analyzer는 root\MicrosoftExchangeV2 네임스페이스 아래의 Exchange_MessageTrackingEntry Microsoft WMI(Windows® Management Instrumentation) 클래스의 EntryType 속성을 쿼리하여 메시지 추적 로그 항목이 생성된 원인을 확인합니다.

다음 표에서는 가능한 EntryType 반환된 값을 나열합니다.

값 이름 | 값
X400을 통해 받은 메시지 | 0
보고서 받음 | 2
메시지 제출됨 | 4
메시지 보냄 | 7
보고서 보냄 | 8
메시지 배달됨 | 9
보고서 배달됨 | 10
메일 그룹 확장 | 26
메시지 리디렉션됨 | 28
다시 라우팅된 메시지 | 29
MTA에 의해 다운그레이드된 서버 | 31
보고서 병합됨 | 33
보고서 생성됨 | 34
라우팅할 수 없는 보고서 삭제됨 | 43
관리자에 의해 삭제된 메시지 | 50
관리자에 의해 삭제된 검색 | 51
관리자에 의해 삭제된 보고서 | 52
로컬에 배달된 메시지 | 1000
백본을 통해 들어온 메시지 | 1001
백본을 통해 보낸 메시지 | 1002
게이트웨이를 통해 보낸 메시지 | 1003
게이트웨이를 통해 들어온 메시지 | 1004
게이트웨이를 통해 들어온 보고서 | 1005
게이트웨이를 통해 보낸 보고서 | 1006
보고서 생성됨 | 1007
SMTP: 메시지 큐 아웃바운드 | 1010
SMTP: 메시지 보냄 | 1011
SMTP: 인바운드 메시지 받음 | 1012
SMTP: 인바운드 메시지 보냄 | 1013
SMTP: 다시 라우팅된 메시지 | 1014
SMTP: 들어온 보고서 | 1015
SMTP: 보낸 보고서 | 1016
SMTP: 보고서 생성됨 | 1017
SMTP: 보고서 병합됨 | 1018
SMTP: 고급 큐로 제출된 메시지 | 1019
SMTP: 메시지의 아웃바운드 전송 시작 | 1020
SMTP: Badmail 디렉터리로 전송된 메시지 | 1021
SMTP: 고급 큐 실패 | 1022
SMTP: 로컬에 배달된 메시지 | 1023
SMTP: 분류기로 제출된 메시지 | 1024
SMTP: 고급 큐로 메시지 제출 시작 | 1025
SMTP: 고급 큐에서 메시지를 전달할 수 없습니다. | 1026
SMTP 저장소 드라이버: 저장소에서 제출된 메시지 | 1027
SMTP 저장소 드라이버: 저장소에 로컬로 배달된 메시지 | 1028
SMTP 저장소 드라이버: MTA에 제출된 메시지 | 1029
SMTP: NDR(배달 못 함 보고서) 생성 | 1030
SMTP: 메시지 보냄 | 1031

Exchange Server Analyzer는 EntryType의 반환된 값이 다음 조건에 해당하는 경우 오류를 표시합니다.

  • 테스트 메시지 추적 로그를 성공적으로 검색할 수 있는 경우

  • 테스트 메시지가 큐에서 성공적으로 전송되지 않은 경우

  • 테스트 메시지에 대해 NDR(배달 못 함 보고서)가 생성되지 않은 경우

  • 테스트 메시지가 Badmail 디렉터리에 전송되지 않은 경우

  • 테스트 메시지가 원격 배달에 대해 대기하지 않는 경우

  • 테스트 메시지가 로컬 저장소에 성공적으로 배달되지 않은 경우

  • 테스트 메시지가 분류 재시도를 위해 예약되지 않은 경우

  • 테스트 메시지가 라우팅 재시도를 위해 예약되지 않은 경우

  • 테스트 메시지가 로컬 배달 재시도를 위해 예약되지 않은 경우

이러한 오류는 테스트 메시지가 SMTP 큐 중 하나에 있고 그 곳에 갇혀 있는 이유를 결정하기 위해 추가 분석이 필요합니다.

이 문제를 해결하려면 NSlookup 유틸리티를 사용하여 DNS(Domain Name System) 확인과 관련하여 발생할 수 있는 문제를 검토하십시오. 호스트에 도달할 수 없음 오류와 같은 연결 및 프로토콜 문제의 경우에는 Telnet.exe를 사용하여 대상 컴퓨터에 연결해 보십시오. 프로토콜 오류를 해결하려면 SMTP 구성 요소에 대한 MSExchangeTransport 서비스의 진단 로깅을 증가시키고 오류 로그를 검토하십시오. 또는 네트워크 모니터(Netmon.exe) 도구를 사용하여 네트워크 연결 오류에 대한 정보를 얻을 수도 있습니다. 문제를 재현하기 위해 큐를 강제로 다시 실행되게 해야 할 수도 있습니다. 이벤트 로그를 검사하여 Microsoft Exchange Information Store 서비스에 관련된 오류가 있는지 확인하십시오.

로깅 설정을 수정하는 방법에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결" 섹션에 있는 "MSExchangeTransport에 대한 로깅 설정 수정 방법"을 참조하십시오.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)의 "메일 흐름 및 SMTP 문제 해결".

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft 기술 자료 문서 821877, "Description of Fields on the SMTP and X.400 Queue Properties Tabs"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft 기술 자료 문서 264054, "XCON: Understanding Queue States in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


라우팅 그룹의 커넥터가 900개가 넘습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 지정된 라우팅 그룹에 포함된 커넥터(SMTP 커넥터, 라우팅 그룹 커넥터, X.400 커넥터, EDK 커넥터 등)의 수를 확인할 때 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer는 하나의 라우팅 그룹의 커넥터 수가 900개를 넘으면 경고를 표시합니다.

단일 Exchange 개체 유형에 대해서는 최대 900개의 인스턴스만 사용하는 것이 좋습니다. 지정된 요청에 대해 Active Directory가 반환하는 최대 페이지 크기가 기본적으로 1,000이기 때문입니다. 따라서 개체에 대해 LDAP(Lightweight Directory Access Protocol) 요청이 있고 Active Directory에 있는 해당 개체의 인스턴스가 1,000개를 초과하면 최대 페이지 크기를 초과하므로 결과가 반환되지 않습니다.

Exchange Server의 경우 여러 프로세스에서 특정 개체 유형의 인스턴스화를 요청합니다. 예를 들어 Exchange System Manager는 LDAP에서 Active Directory에 라우팅 그룹의 모든 커넥터에 대한 목록 보기를 만들도록 요청하게 합니다. 하나의 라우팅 그룹에 1,000개가 넘는 커넥터가 있는 경우 Active Directory는 쿼리 결과를 반환하지 않습니다. 이 경우 Exchange System Manager에 오류가 표시됩니다.

Active Directory의 최대 페이지 크기 값을 늘릴 수 있지만 Exchange Server에는 바람직하지 않거나 지원되지 않습니다. 최대 페이지 크기 값이 증가된 Exchange 환경에서는 이상 동작이나 실패가 발생합니다.

Exchange Server에서는 단일 개체 유형을 900개 이하로 유지하는 것이 좋지만 최대 1,000개의 개체 유형이 지원됩니다.

이 경고를 해결하려면 다음을 수행합니다.

  1. 커넥터를 통합하거나 라우팅 그룹을 더 만들고 기존 커넥터 간의 로드 균형을 조정합니다.

  2. Active Directory에서 연결되지 않은 커넥터를 검사하여 제거합니다.

  3. 조직의 Exchange 서버를 통합합니다.

라우팅 그룹 디자인 및 커넥터에 대한 자세한 내용은 Exchange Server 2003 전송 및 라우팅 가이드(http://go.microsoft.com/fwlink/?LinkId=47579)를 참조하십시오.

Exchange 서버 통합에 대한 자세한 내용은 Server Consolidation Using Exchange Server 2003(http://go.microsoft.com/fwlink/?linkid=47586)을 참조하십시오.


Active Directory 및 메타베이스 간에 정규화된 도메인 이름(FQDN) 설정이 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2007-01-17

Microsoft® Exchange Server Analyzer Tool은 인터넷 정보 서비스(IIS) 메타베이스의 다음 속성을 읽어 속성 값이 Active Directory® 디렉터리 서비스의 msExchSmtpFullyQualifiedDomainName 특성에 대해 구성된 값과 일치하는지 확인합니다.

/LM/SmtpSvc/<SMTP virtual server instance>/FullyQualifiedDomainName

두 특성 값이 일치하지 않으면 Exchange Server Analyzer에서 경고 메시지를 표시합니다.

Exchange에서 IIS 메타베이스의 값이 Active Directory의 값과 일치하지 않으면 Active Directory 복제 또는 Exchange의 DS2MB(Directory-service-to-Metabase) 복제 구성 요소에서 문제가 발생한 것일 수 있습니다.

DS2MB 프로세스의 기능은 구성 정보를 Active Directory에서 로컬 메타베이스로 전송하는 것입니다. 이 구성은 성능 및 확장성 이유로 레지스트리 대신 로컬 메타베이스에 저장됩니다. Exchange 2000 Server와 Exchange Server 2003에서는 모든 인터넷 프로토콜(SMTP, NNTP, POP3, IMAP4 및 HTTP)이 IIS의 구성 요소로서 실행됩니다.

DS2MB 프로세스는 15분마다 Active Directory에서 하위 트리의 모양을 바꾸지 않고 전체 하위 트리를 복사합니다. 이러한 작업은 Active Directory에서 메타베이스로 쓸 수 있지만 반대로 메타베이스에서 Active Directory로는 쓰지 못합니다.

FullyQualifiedDomainName 속성 및 msExchSmtpFullyQualifiedDomainName 특성은 Exchange 서버의 정규화된 도메인 이름(예: server.domain.com)에 해당하는 기본 서버 이름을 사용합니다. FullyQualifiedDomainName 속성 및 msExchSmtpFullyQualifiedDomainName 특성이 정규화된 도메인 이름 값을 가지지 않는 경우 Active Directory 및 IIS 메타베이스는 동기화 상태가 아님을 의미합니다. DS2MB 프로세스의 실패로 인해 문제가 발생할 경우 아래의 절차 중 실행 중인 Exchange Server 버전에 맞는 절차를 수행하면 문제를 해결할 수 있습니다. Active Directory 복제의 부분 또는 완전 실패로 인해 문제가 발생할 경우 Active Directory Replication Monitor 유틸리티(ReplMon.exe)를 사용하여 Active Directory 복제의 상태를 확인할 수 있습니다. Windows Server™ 2003 CD-ROM의 Microsoft Windows® 지원 도구에서 ReplMon.exe를 찾을 수 있습니다.

Exchange Server 2003에서 이 경고를 해결하려면 다음을 수행합니다.

  1. MSExchangeMU의 원본이 있는 응용 프로그램 이벤트 로그 항목이 있는지 확인합니다. Exchange Server 2003에서 DS2MB가 실패하면 이벤트가 기록됩니다.

  2. DS2MB 실패 이벤트가 표시되지 않으면 ReplMon을 사용하여 Active Directory 복제를 진단합니다. SMTP 가상 서버에서 현재 사용 중인 글로벌 카탈로그 서버에 특히 유의하십시오.

  3. DS2MB 실패 이벤트가 나타나 있거나 Active Directory 복제의 문제를 모두 제거했거나 해결한 후에는 Exchange System Attendant 서비스를 다시 시작합니다.

Exchange 2000 Server에서 이 경고를 해결하려면 다음을 수행합니다.

  1. ReplMon을 사용하여 Active Directory 복제를 진단합니다. SMTP 가상 서버에서 현재 사용 중인 글로벌 카탈로그 서버에 특히 유의하십시오.

  2. Active Directory 복제의 문제를 모두 제거했거나 해결한 후에는 Exchange System Attendant 서비스를 다시 시작합니다.

Exchange의 DNS 역방향 조회 기능에 대한 자세한 내용은 Microsoft 기술 자료 문서 297412, "'받는 메시지에 DNS 역방향 조회 수행' 옵션은 호스트 이름 확인을 위한 것이다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)를 참조하십시오.

SMTP 가상 서버 설정에 대한 자세한 내용은 기술 자료 문서 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)과 "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)를 참조하십시오.

Active Directory 복제에 대한 자세한 내용은 기술 자료 문서 232072, "Active Directory 직접 복제 파트너 간에 복제 시작"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)을 참조하십시오.

DS2MB 프로세스에 대한 자세한 내용은 기술 자료 문서 240105, "XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)를 참조하십시오.


Active Directory와 메타베이스 간에 최대 홉 수 설정이 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 IIS(인터넷 정보 서비스) 메타베이스의 다음 속성을 읽어 속성 값이 Active Directory® 디렉터리 서비스의msExchSmtpMaxHopCount 특성에 대해 구성된 값과 일치하는지 확인합니다.

/LM/SmtpSvc/<SMTP virtual server instance>/HopCount

값이 일치하지 않으면 Exchange Server Analyzer에서 경고를 표시합니다.

Exchange에서 IIS 메타베이스의 값이 Active Directory의 값과 일치하지 않으면 Active Directory 복제 또는 Exchange의 DS2MB(Directory-service-to-Metabase) 복제 구성 요소에서 문제가 발생한 것일 수 있습니다.

DS2MB 프로세스의 기능은 구성 정보를 Active Directory에서 로컬 메타베이스로 전송하는 것입니다. 이 구성은 성능 및 확장성 이유로 레지스트리 대신 로컬 메타베이스에 저장됩니다. Exchange 2000 Server와 Exchange Server 2003에서는 모든 인터넷 프로토콜(SMTP, NNTP, POP3, IMAP4 및 HTTP)이 IIS의 구성 요소로서 실행됩니다.

DS2MB 프로세스는 15분마다 Active Directory에서 하위 트리의 모양을 바꾸지 않고 전체 하위 트리를 복사합니다. 이러한 작업은 Active Directory에서 메타베이스로 쓸 수 있지만 반대로 메타베이스에서 Active Directory로는 쓰지 못합니다.

Exchange 2000 Server SMTP 가상 서버에서 기본 홉 수는 15입니다. Exchange Server 2003 SMTP 가상 서버에서 기본 홉 수는 30입니다. 구성된 값에 관계없이 HopCount 속성과 msExchSmtpMaxHopCount 특성이 일치하지 않으면 Active Directory와 IIS 메타베이스가 동기화 상태가 아님을 의미합니다. DS2MB 프로세스의 실패로 인해 문제가 발생할 경우 아래의 절차 중 실행 중인 Exchange Server 버전에 맞는 절차를 수행하면 문제를 해결할 수 있습니다. Active Directory 복제의 부분 또는 완전 실패로 인해 문제가 발생할 경우 Active Directory Replication Monitor 유틸리티(ReplMon.exe)를 사용하여 Active Directory 복제의 상태를 확인할 수 있습니다. Windows Server™ 2003 CD-ROM의 Microsoft Windows® 지원 도구에서 ReplMon.exe를 찾을 수 있습니다.

Exchange Server 2003에서 이 오류를 수정하려면 다음을 수행합니다.

  1. MSExchangeMU의 원본이 있는 응용 프로그램 이벤트 로그 항목이 있는지 확인합니다. Exchange Server 2003에서 DS2MB가 실패하면 이벤트가 기록됩니다.

  2. DS2MB 실패 이벤트가 표시되지 않으면 ReplMon을 사용하여 Active Directory 복제를 진단합니다. SMTP 가상 서버에서 현재 사용 중인 글로벌 카탈로그 서버에 특히 유의하십시오.

  3. DS2MB 실패 이벤트가 나타나 있거나 Active Directory 복제의 문제를 모두 제거했거나 해결한 후에는 Exchange System Attendant 서비스를 다시 시작합니다.

Exchange 2000 Server에서 이 오류를 수정하려면 다음을 수행합니다.

  1. ReplMon을 사용하여 Active Directory 복제를 진단합니다. SMTP 가상 서버에서 현재 사용 중인 글로벌 카탈로그 서버에 특히 유의하십시오.

  2. Active Directory 복제의 문제를 모두 제거했거나 해결한 후에는 Exchange System Attendant 서비스를 다시 시작합니다.

Exchange의 DNS 역방향 조회 기능에 대한 자세한 내용은 Microsoft 기술 자료 문서 297412, "'받는 메시지에 DNS 역방향 조회 수행' 옵션은 호스트 이름 확인을 위한 것이다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)를 참조하십시오.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Active Directory 복제에 대한 자세한 내용은 기술 자료 문서 232072, "Active Directory 직접 복제 파트너 간에 복제 시작"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)을 참조하십시오.

DS2MB 프로세스에 대한 자세한 내용은 Microsoft 기술 자료 문서 240105, "XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)를 참조하십시오.


Active Directory와 메타베이스 간에 최대 메시지 크기 설정이 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 인터넷 정보 서비스(IIS) 메타베이스의 다음 속성 값이 Active Directory® 디렉터리 서비스에서 msExchSmtpMaxMessageSize 특성에 대해 구성된 값과 일치하는지 확인할 때 이 속성을 읽습니다.

/LM/SmtpSvc/<SMTP virtual server instance>/MaxMessageSize

Exchange Server Analyzer는 값이 일치하지 않을 경우 경고를 표시합니다.

Exchange에서 IIS 메타베이스의 값이 Active Directory의 값과 일치하지 않으면 Active Directory 복제 또는 Exchange의 DS2MB(Directory-service-to-Metabase) 복제 구성 요소에서 문제가 발생한 것일 수 있습니다.

DS2MB 프로세스의 기능은 구성 정보를 Active Directory에서 로컬 메타베이스로 전송하는 것입니다. 이 구성은 성능 및 확장성 이유로 레지스트리 대신 로컬 메타베이스에 저장됩니다. Exchange 2000 Server와 Exchange Server 2003에서는 모든 인터넷 프로토콜(SMTP, NNTP, POP3, IMAP4 및 HTTP)이 IIS의 구성 요소로서 실행됩니다.

DS2MB 프로세스는 15분마다 Active Directory에서 하위 트리의 모양을 바꾸지 않고 전체 하위 트리를 복사합니다. 이러한 작업은 Active Directory에서 메타베이스로 쓸 수 있지만 반대로 메타베이스에서 Active Directory로는 쓰지 못합니다.

MaxMessageSize 속성과 msExchSmtpMaxMessageSize 특성은 모두 기본값인 0을 사용합니다. 이 값은 메시지 크기 제한이 지정되어 있지 않음을 의미합니다. MaxMessageSize 속성과 msExchSmtpMaxMessageSize 특성 값이 같지 않으면 Active Directory와 IIS 메타베이스가 동기화되지 않은 것입니다. DS2MB 프로세스의 실패로 인해 문제가 발생할 경우 아래의 절차 중 실행 중인 Exchange Server 버전에 맞는 절차를 수행하면 문제를 해결할 수 있습니다. Active Directory 복제의 부분 또는 완전 실패로 인해 문제가 발생할 경우 Active Directory Replication Monitor 유틸리티(ReplMon.exe)를 사용하여 Active Directory 복제의 상태를 확인할 수 있습니다. Windows Server™ 2003 CD-ROM의 Microsoft Windows® 지원 도구에서 ReplMon.exe를 찾을 수 있습니다.

Exchange Server 2003에서 이 오류를 수정하려면 다음을 수행합니다.

  1. MSExchangeMU의 원본이 있는 응용 프로그램 이벤트 로그 항목이 있는지 확인합니다. Exchange Server 2003에서 DS2MB가 실패하면 이벤트가 기록됩니다.

  2. DS2MB 실패 이벤트가 표시되지 않으면 ReplMon을 사용하여 Active Directory 복제를 진단합니다. SMTP 가상 서버에서 현재 사용 중인 글로벌 카탈로그 서버에 특히 유의하십시오.

  3. DS2MB 실패 이벤트가 나타나 있거나 Active Directory 복제의 문제를 모두 제거했거나 해결한 후에는 Exchange System Attendant 서비스를 다시 시작합니다.

Exchange 2000 Server에서 이 오류를 수정하려면 다음을 수행합니다.

  1. ReplMon을 사용하여 Active Directory 복제를 진단합니다. SMTP 가상 서버에서 현재 사용 중인 글로벌 카탈로그 서버에 특히 유의하십시오.

  2. Active Directory 복제의 문제를 모두 제거했거나 해결한 후에는 Exchange System Attendant 서비스를 다시 시작합니다.

Exchange의 DNS 역방향 조회 기능에 대한 자세한 내용은 Microsoft 기술 자료 문서 297412, "'받는 메시지에 DNS 역방향 조회 수행' 옵션은 호스트 이름 확인을 위한 것이다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)를 참조하십시오.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Active Directory 복제에 대한 자세한 내용은 기술 자료 문서 232072, "Active Directory 직접 복제 파트너 간에 복제 시작"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)을 참조하십시오.

DS2MB 프로세스에 대한 자세한 내용은 기술 자료 문서 240105, "XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)를 참조하십시오.


Active Directory와 메타베이스 간에 최대 세션 크기 설정이 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 인터넷 정보 서비스(IIS) 메타베이스의 /LM/SmtpSvc/<SMTP virtual server instance>/MaxSessionSize 속성을 읽어 Active Directory® 디렉터리 서비스의 msExchSmtpMaxSessionSize 특성에 대해 구성된 값과 일치하는지 여부를 확인합니다.

Exchange Server Analyzer는 값이 일치하지 않을 경우 경고 메시지를 표시합니다.

Exchange에서 IIS 메타베이스의 값이 Active Directory의 값과 일치하지 않으면 Active Directory 복제 또는 Exchange의 DS2MB(Directory-service-to-Metabase) 복제 구성 요소에서 문제가 발생한 것일 수 있습니다.

DS2MB 프로세스의 기능은 구성 정보를 Active Directory에서 로컬 메타베이스로 전송하는 것입니다. 이 구성은 성능 및 확장성 이유로 레지스트리 대신 로컬 메타베이스에 저장됩니다. Exchange 2000 Server와 Exchange Server 2003에서는 모든 인터넷 프로토콜(SMTP, NNTP, POP3, IMAP4 및 HTTP)이 IIS의 구성 요소로서 실행됩니다.

DS2MB 프로세스는 15분마다 Active Directory에서 하위 트리의 모양을 바꾸지 않고 전체 하위 트리를 복사합니다. 이러한 작업은 Active Directory에서 메타베이스로 쓸 수 있지만 반대로 메타베이스에서 Active Directory로는 쓰지 못합니다.

MaxSessionSize 속성과 msExchSmtpMaxSessionSize 특성은 모두 기본값인 0을 사용합니다. 이 값은 세션 크기 제한이 지정되어 있지 않음을 의미합니다. MaxSessionSize 속성과 msExchSmtpMaxSessionSize 특성 값이 같지 않으면 Active Directory와 IIS 메타베이스가 동기화되지 않은 것입니다. DS2MB 프로세스의 실패로 인해 문제가 발생할 경우 아래의 절차 중 실행 중인 Exchange Server 버전에 맞는 절차를 수행하면 문제를 해결할 수 있습니다. Active Directory 복제의 부분 또는 완전 실패로 인해 문제가 발생할 경우 Active Directory 복제 모니터 유틸리티(ReplMon.exe)를 사용하여 Active Directory 복제의 상태를 확인할 수 있습니다. ReplMon은 Windows Server™ 2003 CD-ROM의 Microsoft Windows® 지원 도구에 포함되어 있습니다.

Exchange Server 2003에서 이 오류를 수정하려면 다음을 수행합니다.

  1. MSExchangeMU의 원본이 있는 응용 프로그램 이벤트 로그 항목이 있는지 확인합니다. Exchange Server 2003에서 DS2MB가 실패하면 이벤트가 기록됩니다.

  2. DS2MB 실패 이벤트가 표시되지 않으면 ReplMon을 사용하여 Active Directory 복제를 진단합니다. SMTP 가상 서버에서 현재 사용 중인 글로벌 카탈로그 서버에 특히 유의하십시오.

  3. DS2MB 실패 이벤트가 나타나 있거나 Active Directory 복제의 문제를 모두 제거했거나 해결한 후에는 Exchange System Attendant 서비스를 다시 시작합니다.

Exchange 2000 Server에서 이 오류를 수정하려면 다음을 수행합니다.

  1. ReplMon을 사용하여 Active Directory 복제를 진단합니다. SMTP 가상 서버에서 현재 사용 중인 글로벌 카탈로그 서버에 특히 유의하십시오.

  2. Active Directory 복제의 문제를 모두 제거했거나 해결한 후에는 Exchange System Attendant 서비스를 다시 시작합니다.

Exchange의 DNS 역방향 조회 기능에 대한 자세한 내용은 Microsoft 기술 자료 문서 297412, "'받는 메시지에 DNS 역방향 조회 수행' 옵션은 호스트 이름 확인을 위한 것이다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412)를 참조하십시오.

SMTP 가상 서버 설정에 대한 자세한 내용은 다음 기술 자료 문서를 참조하십시오.

  • 266686, "XCON: SMTP 가상 서버를 구성하는 방법(1)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: SMTP 가상 서버를 구성하는 방법(2)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Active Directory 복제에 대한 자세한 내용은 기술 자료 문서 232072, "Active Directory 직접 복제 파트너 간에 복제 시작"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072)을 참조하십시오.

DS2MB 프로세스에 대한 자세한 내용은 기술 자료 문서 240105, "XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105)를 참조하십시오.


전송 연결 관리자 경고 이벤트는 최근 24시간 내에 기록됨
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-07-07

Microsoft® Exchange Server Analyzer Tool은 Win32_NTLogEvent Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 MSExchangeTransport에 대한 이벤트 4006 경고가 최근 24시간 이내 기록되었는지 확인합니다.

Exchange Server Analyzer는 MSExchangeTransport에 대한 이벤트 4006 경고가 최근 24시간 이내 기록된 것을 확인하면 경고를 표시합니다.

대개 이 경고는 원격 서버로의 메일 전송이 실패했음을 나타냅니다.

MSExchangeTransport 이벤트 4006 경고는 다음과 같은 상황에서 발생합니다.

  • 원격 호스트에 의해 연결이 차단되었습니다.

  • 원격 SMTP(Simple Mail Transfer Protocol) 서비스가 AUTH 협상을 거부했습니다.

  • 메시지를 배달할 서버가 해당 메시지의 메시지 배달 정보를 액세스할 수 없습니다.

  • SMTP 오류가 발생했습니다.

  • 메시지를 배달할 서버가 원격 서버에 연결되지 않습니다.

  • 어떤 이유로 인해 SMTP 가상 서버의 속성에 지정되어 있는 스마트 호스트에 연결할 수 없습니다.

MSExchangeTransport 이벤트 4006 경고에 대한 자세한 내용은 이벤트 및 오류 메시지 센터(http://go.microsoft.com/fwlink/?LinkId=34258)에 있는 이벤트 세부 정보를 참조하십시오.

Exchange 서버에서의 메일 릴레이 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 895853, "How to troubleshoot mail relay issues in Exchange Server 2003 and in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)를 참조하십시오.

메일 흐름 및 SMTP 문제에 대한 자세한 내용은 Exchange Server and Transport Routing Guide의 "Troubleshooting Mail Flow and SMTP"(http://go.microsoft.com/fwlink/?LinkId=67875)를 참조하십시오.


전송 연결 관리자 경고 이벤트는 최근 24시간 내에 기록됨
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-07-07

Microsoft® Exchange Server Analyzer Tool은 Win32_NTLogEvent Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 MSExchangeTransport에 대한 이벤트 4001 경고가 최근 24시간 이내 기록되었는지 확인합니다.

Exchange Server Analyzer는 MSExchangeTransport에 대한 이벤트 4001 경고가 최근 24시간 이내 기록된 것을 확인하면 경고를 표시합니다.

대개 이 경고는 원격 서버로의 메일 전송이 실패했음을 나타냅니다.

MSExchangeTransport 이벤트 4001 경고는 Exchange 2000 Server 또는 Exchange Server 2003의 SMTP(Simple Mail Transfer Protocol)에 하나 이상의 메일 배달 문제가 있을 경우에 발생합니다. 메일 배달 문제의 원인으로는 DNS(Domain Name System) 또는 IP 구성 관련 문제나 잘못된 DLL 파일 설치 등이 포함됩니다.

Event 4001 경고에 대한 자세한 내용은 이벤트 및 오류 메시지 센터(http://go.microsoft.com/fwlink/?LinkId=34258)에 있는 이벤트 세부 정보를 참조하십시오.

Exchange 서버에서의 메일 릴레이 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 895853, "How to troubleshoot mail relay issues in Exchange Server 2003 and in Exchange 2000 Server"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853)를 참조하십시오.

메일 흐름 및 SMTP 문제에 대한 자세한 내용은 Exchange Server and Transport Routing Guide의 "Troubleshooting Mail Flow and SMTP"(http://go.microsoft.com/fwlink/?LinkId=67875)를 참조하십시오.


전송 이벤트 싱크 파일을 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-01-10

Microsoft® Exchange Server Analyzer Tool은 Microsoft 인터넷 정보 서비스(IIS) 메타베이스를 쿼리하여 SMTP(Simple Mail Transport Protocol) 전송 이벤트 싱크 바인딩 목록을 열거합니다. Exchange Server Analyzer는 미리 채워진 목록을 기반으로 여러 표준 이벤트 바인딩을 찾습니다. Exchange Server Analyzer는 각 바인딩에 대해 다음 분기의 레지스트리에서 COM(구성 요소 개체 모델) 등록 세부 정보를 확인합니다.

HKEY_CLASSES_ROOT\CLSID\

COM 등록 세부 정보에는 관련 .dll 파일의 전체 경로가 포함되어 있습니다. Exchange Server Analyzer는 Microsoft WMI(Windows® Management Instrumentation)를 사용하여 .dll 파일을 찾고 해당 버전 번호를 표시합니다. Exchange Server Analyzer가 .dll 파일을 찾지 못한 경우에는 누락된 .dll 파일의 이름과 경로를 자세히 알려 주는 경고를 표시합니다.

Exchange Server Analyzer는 표준 이벤트 바인딩이 하나 이상 누락된 것을 발견하면 경고를 표시합니다.

메시지 데이터가 SMTP 서비스로 전송되거나 SMTP 서비스에서 전송되는 경우 SMTP 전송 이벤트가 발생합니다. 모든 메시지는 이벤트를 거칩니다. 여기에는 X.400와 RPC 받는 메시지 또는 보내는 메시지가 포함됩니다. 인바운드 전송 이벤트의 일반적인 예로는 네트워크를 통하거나 SMTP 픽업 디렉터리에 있는 SMTP 서비스에 메시지가 도착하는 것을 들 수 있습니다. 이러한 전송 이벤트가 발생하면 이 이벤트의 원본은 메시지의 데이터 내용을 기반으로 작업의 일부 유형을 수행할 수 있는 전송 이벤트 싱크를 알려 줍니다. 시스템에서 메시지 데이터를 싱크에 전달한 다음에는 싱크가 작업을 완료하고 메시지를 반환할 때까지 메시지 데이터에 다른 작업을 수행하지 않습니다. 싱크는 메시지 데이터 및 이러한 작업을 수행하는 동안의 상태를 독점적으로 제어합니다.

전송 이벤트 싱크 COM 등록에 대한 .dll 파일이 없어지면 메일 흐름에 문제가 생길 수 있습니다. Exchange Server에서 메시지 큐와 같은 메일 흐름 문제가 나타나는 경우 확인된 .dll 파일이 있는지 확인한 다음 필요한 경우 해당 파일을 다시 설치하십시오.

이 문제를 해결하려면 다음을 수행합니다.

  1. 탐색기를 사용하여 확인된 .dll 파일을 수동으로 찾습니다. 일반적으로 이 파일은 \Program Files\Exchsrvr\Bin 폴더에 있습니다.

  2. 다음 조건에 해당하는 경우 Exchange Server Analyzer에서 표시하는 경고를 무시해도 괜찮습니다.

    • 나열된 폴더에 .dll 파일이 있는 경우

    • 서버에 메일 흐름 문제가 있다는 메시지가 표시되지 않는 경우

  3. 다음 조건에 해당하는 경우 원본 Exchange Server 설치 미디어에서 누락된 .dll 파일을 복사합니다.

    • Exchange Server Analyzer에서 나열한 폴더에 .dll 파일이 없는 경우

    • 서버에 메일 흐름 문제가 있다는 메시지가 표시되는 경우

    또는 최신 Exchange 서비스 팩을 다시 적용합니다.

  4. Exchange Server Analyzer를 다시 실행하여 경고가 더 이상 표시되지 않는지 확인합니다.


링크 상태 정보의 사용자 버전 변경이 억제됩니다.
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2005-11-18

Microsoft® Exchange Server Analyzer Tool은 heuristics 특성이 링크 상태 정보의 사용자 버전 변경을 억제하도록 구성되었는지 여부를 확인할 때 Active® Directory® 디렉터리 서비스를 쿼리합니다. 기본적으로 heuristics 특성은 구성되어 있지 않습니다. Exchange Server Analyzer는 heuristics 특성이 2048로 설정되어 있으면 기본 구성이 아니라는 메시지를 표시합니다.

링크 상태 테이블을 사용하면 효율적이고 안정적인 메시지 라우팅이 보장됩니다. 링크 상태 테이블에는 주 버전 번호, 부 버전 번호 및 사용자 버전 번호의 형식으로 각 라우팅 그룹의 버전 정보가 들어 있습니다. 변경 우선 순위는 주 버전, 부 버전 및 사용자 버전 번호의 순입니다.

기본 수준의 디렉터리 서비스 업데이트가 있는 경우 사용자 버전 변경이 발생합니다. 최소한의 변경 정보로는 라우팅 그룹 마스터 변경 내용, Exchange 서버에서 서비스 시작 또는 중지 시간, 라우팅 그룹에 다른 서버를 추가한 시간 또는 라우팅 그룹 마스터에 대한 멤버 서버의 연결 손실 시간 등이 있습니다.

Exchange Server 관리자가 라우팅 그룹 수준에서 변경을 수행하면 기본 수준 디렉터리 서비스 업데이트가 발생할 수 있습니다. 예를 들어 관리자가 라우팅 그룹 이름을 변경하거나 서버를 추가 또는 제거하면 사용자 버전 변경이 발생합니다. 하지만 사용자 버전 변경은 주로 각 서버에 있는 Microsoft WMI(Windows® Management Instrumentation) 데이터 때문에 발생합니다. 이 데이터는 실행 중인 서비스를 나타냅니다. 서비스를 중지하고 시작하면 링크 상태 테이블의 사용자 버전 변경이 조직의 모든 Exchange Server 컴퓨터로 복제됩니다.

사용자 버전 업데이트가 자주 발생하여 필요 없는 네트워크 소통량이 많이 발생하는 경우 우선 Microsoft 기술 지원 서비스에서 핫픽스를 다운로드한 다음 heuristics 특성을 2048(16진수, 0x800)로 설정하여 이러한 업데이트를 억제할 수 있습니다.

사용자 버전 업데이트 때문에 발생하는 네트워크 소통량이 적당한 수준이면 이런 업데이트를 억제하지 않는 것이 좋습니다.

기본 구성으로 되돌리려면 다음을 수행합니다.

  1. ADSI(Active Directory Service Interfaces) 편집을 엽니다.

  2. ADSI 편집에서 Configuration Container, CN=Configuration, DC=DomainName, DC=com, CN=Services, CN=Microsoft Exchange를 차례로 확장합니다.

  3. CN=OrganizationName을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. Select a property to view 상자에서 Heuristics를 클릭합니다.

  5. Edit Attribute 상자에서 0x800 값을 지웁니다.

  6. Set을 클릭한 다음 OK를 클릭합니다.

  7. ADSI 편집을 닫습니다.
주의:
ADSI 편집, LDP(ldp.exe) 도구 또는 다른 LDAP(Lightweight Directory Access Protocol) 버전 3 클라이언트를 사용할 때 Active Directory 개체의 특성을 잘못 수정하면 심각한 문제가 발생될 수 있습니다. 이러한 문제가 발생하면 Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 또는 둘 모두를 다시 설치해야 할 수 있습니다. Active Directory 개체 특성을 수정하여 발생하는 모든 문제에 대한 책임은 사용자에게 있습니다.

링크 상태와 사용자 버전 번호에 대한 자세한 내용은 Technical Reference Guide for Exchange Server 2003(http://go.microsoft.com/fwlink/?LinkId=49367)의 "Link State Propagation"을 참조하십시오.


일반 대상으로 식별된 사용자
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-09-06

Microsoft® Exchange Server Analyzer Tool은 Exchange_Queue Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP 가상 서버의 SMTP(Simple Mail Transfer Protocol) 큐에 대한 다음 특성 값을 확인합니다.

LinkId | 큐를 포함한 링크의 식별자를 나타냅니다.
QueueId | 큐의 식별자를 나타냅니다.
QueueName | 큐의 이름을 나타냅니다.
VirtualMachine | 큐를 포함한 가상 컴퓨터의 이름을 나타냅니다.
VirtualServerName | 큐가 있는 가상 서버의 이름을 나타냅니다.
MessageCount | 큐에 있는 메시지 수를 나타냅니다.

Exchange Server Analyzer는 위에서 얻은 정보를 사용해 Exchange_QueuedSMTPMessage WMI 클래스를 쿼리하여 큐에 있는 메시지의 다음 특성 값을 확인합니다.

받는 사람 | 메시지를 받는 사람을 나타냅니다.
Received | 메시지를 받은 타임 스탬프를 나타냅니다.
MessageId | 큐에 대기 중인 메시지의 식별자를 나타냅니다.
StateRetry | 제대로 배달되지 않은 메시지에 대해 다시 전송을 시도하는 상태임을 나타냅니다.

마지막으로 Exchange Server Analyzer는 이전 쿼리에서 얻은 데이터를 사용해 Active Directory® 디렉터리 서비스를 쿼리하여 각 Recipient 개체의 다음 값을 알아봄으로써 받는 사람이 사용자인지, 메일 그룹인지, 공용 폴더인지, 공용 폴더 저장소인지 확인합니다.

distinguishedName | 개체의 고유 이름을 나타냅니다.
msExchHomeServerName | 받는 사람이 상주하고 있는 서버를 나타냅니다.
homeMDB | 받는 사람의 사서함 저장소를 나타냅니다.

Exchange Server Analyzer는 큐에 대기 중인 메시지의 25퍼센트 이상이 받는 사람 또는 참조 필드의 특정 사용자에게 배달되는 경우에 경고를 표시합니다.

큐에 대기 중인 메시지의 50퍼센트 이상이 받는 사람 또는 참조 필드의 특정 사용자에게 배달되는 경우에는 오류를 표시합니다.

이러한 경고 또는 오류는 식별된 사용자가 SMTP 큐에 대기 중인 메시지의 일반 대상임을 의미합니다.

이 문제를 해결하려면 사용자에게 구성 문제나 메시지가 큐에 대기되도록 하는 기타 예외적인 문제가 있는지 확인해야 합니다.

확인할 부분은 다음과 같습니다.

  • 사용자 개체 특성이 제대로 설정되어 있고 Active Directory에 올바른 값이 포함되어 있는지 확인합니다.

  • 사용자 개체의 Active Directory 사용 권한이 올바르게 설정되어 있는지 검토합니다.

  • 사용자에 대한 UCE(원치 않는 상업성 전자 메일 메시지)나 스팸 또는 바이러스 공격이 있는지 확인합니다.

  • 배달 제한을 잘못 설정한 메일 그룹에 사용자가 속하는지 확인합니다.

  • 사용자 개체가 지정한 저널링 받는 사람과 같이 특별하게 사용된 경우, 사용자 개체가 연관된 서비스나 구성 요소의 구성이 올바른지 검토합니다.

SMTP 큐 문제를 해결하는 방법에 대한 자세한 내용은 다음 Exchange 리소스를 참조하십시오.

  • Exchange Server 전송 및 라우팅 가이드의 "메일 흐름 및 SMTP 문제 해결"(http://go.microsoft.com/fwlink/?LinkID=67875)

  • Microsoft 기술 자료 문서 823489, "Exchange Server 2003에서 큐 뷰어를 사용하여 메일 이동 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

메일 그룹 제한이 Exchange Server 메일 흐름에 미치는 영향에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 895407, "Exchange Server 2003에서 메일 그룹을 기반으로 배달 제한을 구성하면 로컬 사서함이나 외부 사서함으로의 메시지 배달이 예측한 것보다 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 329171 " XADM: 그룹 구성원별로 배달 제한을 받도록 받는 사람을 구성하면 메일 배달이 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)

  • 839949, "Exchange 2000 Server 및 Exchange Server 2003의 메일 전송 및 메일 그룹 문제 해결"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949)

  • 812298, "메일 그룹을 기반으로 배달 제한을 구성하면 메일 배달이 늦어짐"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)


알 수 없는 SMTP 문제
Microsoft Exchange Server Analyzer - 문서 > 전송 >

최근 수정된 항목: 2006-10-06

Microsoft® Exchange Server Analyzer Tool은 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 클래스를 쿼리하여 SMTP(Simple Mail Transfer Protocol) 서비스의 Started 키 값을 확인합니다. False 값은 SMTP 서비스가 실행되고 있지 않음을 나타냅니다. True 값은 SMTP 서비스가 실행되고 있음을 나타냅니다.

또한 Exchange Server Analyzer는 인터넷 정보 서비스(IIS) 메타베이스를 쿼리하여 SMTP 가상 서버 인스턴스의 ServerState 속성 값을 확인합니다.

ServerState 속성은 서버 인스턴스의 현재 상태를 나타냅니다. 상태 코드와 해당 상태는 다음과 같습니다.

상태 코드 | 상태
1 | 시작 중
2 | 시작됨
3 | 중지하는 중
4 | 중지됨
5 | 일시 정지 중
6 | 일시 정지됨
7 | 계속

Exchange Server Analyzer는 다음 조건에 해당하는 경우 경고를 표시합니다.

  • SMTP 서비스가 실행되고 있습니다.

  • 서버에서 모든 SMTP 가상 서버 인스턴스가 시작되었습니다.

이 경고는 SMTP 서비스와 SMTP 가상 서버 인스턴스가 작동하는 것처럼 보이지만, SMTP 포트가 올바르게 응답하는 것을 방해하는 추가적인 조사가 필요한 문제를 나타냅니다.

이 문제의 원인은 다음과 같습니다.

  • SMTP 서비스가 응답이 없는 상태입니다.

  • 방화벽이나 바이러스 백신 응용 프로그램이 SMTP 포트로의 통신을 차단하고 있습니다.

이 문제를 해결하려면 다음을 수행하십시오.

  • SMTP 서비스를 다시 시작합니다.

  • 방화벽이나 바이러스 백신 응용 프로그램의 SMTP 포트 관련 구성을 검토합니다.

  • Exchange Server Analyzer에서 제공한 특정 오류 안내와 링크를 검토합니다.

SMTP 서비스를 시작, 중지 또는 일시 중지하려면 다음을 수행하십시오.

  1. 시작을 클릭하고 관리 도구를 가리킨 다음 구성 요소 서비스를 클릭합니다.

  2. 콘솔 트리에서 서비스(로컬)를 클릭합니다.

  3. 결과 창에서 SMTP(Simple Mail Transfer Protocol)를 마우스 오른쪽 단추로 클릭한 다음 시작, 중지 또는 일시 중지를 클릭합니다.


Exchange Server 2007 준비
Microsoft Exchange Server Analyzer - 문서 >

최근 수정된 항목: 2006-07-18

이 섹션의 문서에는 Exchange Server 2007 준비와 관련된 Microsoft® Exchange Server Analyzer Tool의 평가 기능에 대한 자세한 내용이 나와 있습니다. 또한 이러한 문서는 Exchange Server Analyzer가 발견한 선행 조건 관련 오류, 경고 및 기본 구성이 아닌 문제를 해결하기 위해 수행할 수 있는 작업을 설명합니다.


ACL(액세스 제어 목록) 상속이 차단되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-06-19

필요한 사용 권한을 전파하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange를 설치하려면 공용 폴더 트리 개체에서 사용 권한 상속을 사용하도록 설정해야 합니다.

이 문제를 해결하려면 "이 개체 및 하위 개체를 따르도록 사용 권한 전파 허용" 설정이 사용하도록 설정되어 있는지 확인한 다음 Exchange Server 2007 설치 프로그램을 다시 실행합니다.

공용 폴더 트리 상속을 다시 사용하도록 설정하려면 다음을 수행합니다.

  1. Exchange Server 2003 System Manager를 엽니다.

  2. 공용 폴더 저장소를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 보안 탭을 클릭한 다음 상속 가능한 사용 권한을 이 개체로 전파하도록 허용 확인란을 클릭하여 선택합니다.


Active Directory 스키마 확장을 사용하려면 Ldifde.exe를 설치해야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-06-19

로컬 컴퓨터에서 Active Directory 스키마를 업데이트할 수 없으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange를 설치하려면 로컬 컴퓨터에 Ldifde.exe를 설치하여 필요에 맞게 Active Directory 스키마를 확장해야 합니다.

이 문제를 해결하려면 로컬 컴퓨터에 Ldifde.exe를 설치한 후에 Exchange Server 2007 설치 프로그램을 다시 실행하거나 Exchange Server 2007 설치 프로그램을 도메인 컨트롤러에서 시작합니다.

참고:
Active Directory 스키마가 확장되면 Ldifde.exe를 설치하지 않아도 Exchange 2007 서버 역할을 로컬 컴퓨터에 설치할 수 있습니다.
로컬 컴퓨터에 Ldifde.exe를 설치하려면 다음을 수행합니다.

  1. 시작, 실행을 차례로 클릭하고 열기 필드에서 'ServerManagerCmd -i RSAT-ADDS'를 실행합니다.


ADAM 설치 경로가 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-26

ADAM(Active Directory Application Mode)을 설치하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

ADAM이 기본 위치에 이미 설치되어 있습니다. 기존 ADAM 디렉터리 구조에 ADAM을 새로 설치할 수는 없습니다.

이 문제를 해결하려면 기존 ADAM 폴더를 제거한 후에 Exchange 설치 프로그램을 다시 실행합니다.


로컬 컴퓨터에 ADAM이 설치되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-22

이 컴퓨터에 ADAM(Active Directory Application Mode)이 설치되어 있지 않으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

ADAM은 디렉터리 사용 응용 프로그램에 사용하도록 특별히 디자인된 LDAP(Lightweight Directory Access Protocol) 디렉터리 서비스입니다. ADAM은 응용 프로그램 관련 정보만 저장하고 복제하며 도메인 컨트롤러에 배포할 필요가 없고 Active Directory 디렉터리 서비스를 사용하지도 않습니다. ADAM에서는 네트워크 운영 체제 인증 또는 권한 부여를 제공하지 않습니다.

Exchange 2007에서 Exchange 전송 서버 역할은 ADAM을 사용하여 구성 정보를 저장합니다. ADAM을 Active Directory와 동기화하면 ADAM을 사용하여 메시지 보안을 위한 받는 사람 조회를 수행할 수도 있습니다.

Microsoft Exchange를 설치하려면 로컬 컴퓨터에 ADAM 서비스를 설치해야 합니다.

이 문제를 해결하려면 "Active Directory Application Mode (ADAM)"(http://go.microsoft.com/fwlink/?linkid=71063)에서 ADAM 서비스 팩 1(SP1)을 다운로드하여 설치한 후에 설치 프로그램을 다시 실행합니다.


ADAM이 로컬 컴퓨터(Longhorn)에 설치되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-08-13

이 Windows Server 2008 기반 컴퓨터에 ADAM(Active Directory Application Mode)이 설치되어 있지 않으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

ADAM은 디렉터리 사용 응용 프로그램에 사용하도록 특별히 디자인된 LDAP(Lightweight Directory Access Protocol) 디렉터리 서비스입니다. ADAM은 응용 프로그램 관련 정보만 저장하고 복제하며 도메인 컨트롤러에 배포할 필요가 없고 Active Directory 디렉터리 서비스를 사용하지도 않습니다. ADAM에서는 네트워크 운영 체제 인증 또는 권한 부여를 제공하지 않습니다.

Exchange 2007에서 Exchange 전송 서버 역할은 ADAM을 사용하여 구성 정보를 저장합니다. ADAM을 Active Directory와 동기화하면 ADAM을 사용하여 메시지 보안을 위한 받는 사람 조회를 수행할 수도 있습니다.

Microsoft Exchange를 설치하려면 로컬 컴퓨터에 ADAM 서비스를 설치해야 합니다.

이 문제를 해결하려면 Windows Server 2008 운영 체제를 실행 중인 로컬 컴퓨터에 ADAM을 설치한 후에 설치 프로그램을 다시 실행합니다.

Windows Server 2008 운영 체제에 ADAM을 설치하려면 다음을 수행합니다.

  1. 시작을 클릭하고 실행을 선택한 후에 다음 명령을 입력합니다.

  2. cmd.exe /c start /w pkgmgr.exe /iu:"DirectoryServices-ADAM"

  3. Exchange 2007 설치 프로그램을 다시 실행합니다.


Analyzer 검색 경고
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-08-09

이 항목은 Exchange Server Analyzer Tool에서 발생한 특정 문제를 해결하기 위한 내용을 담고 있습니다. 이 내용은 Exchange Server Analyzer Tool을 실행했을 때 특정 문제가 발생한 시스템에만 적용해야 합니다.

무료로 다운로드할 수 있는 Exchange Server Analyzer Tool은 토폴로지의 각 서버로부터 구성 데이터를 원격으로 수집하여 자동으로 분석합니다. 분석 결과 보고서에는 중요한 구성 문제, 잠재적인 문제 및 기본값 이외의 제품 설정에 관한 내용이 자세히 나타납니다. 이러한 권장 사항에 따라 성능, 확장성, 안정성 및 작동 시간을 향상시킬 수 있습니다.

이 도구에 대한 자세한 정보를 보고 최신 버전을 다운로드하려면 "Microsoft Exchange Analyzers"(http://go.microsoft.com/fwlink/?linkid=34707)를 참조하십시오.


32비트 호환성 경고
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-08-13

32비트 버전의 Microsoft Exchange를 설치하려고 하기 때문에 Microsoft Exchange Server 2007 설치 프로그램이 이 경고를 표시합니다.

Exchange 2007은 두 가지 플랫폼 버전으로 사용할 수 있는데, 그 중 한 가지 플랫폼 버전(64비트 버전)은 라이브 프로덕션 환경용이고 다른 한 가지 플랫폼 버전(32비트 버전)은 실험실, 교육 기관, 데모, 평가 환경 등의 비프로덕션 환경용입니다. 32비트 Exchange 2007 서버는 프로덕션 환경에서 실행할 수 없으므로 64비트 버전만을 구입할 수 있습니다.

그러나 Microsoft에서는 프로덕션 환경에서도 최소한의 32비트 버전 사용을 지원하고 있으며, 이에 따라 프로덕션 및 비프로덕션 환경의 32비트 플랫폼 사용에는 두 가지 예외가 있습니다.

  • 프로덕션 환경에서 32비트 버전의 Exchange 관리 도구를 사용하여 Windows Server 2003 또는 Windows XP에서 Exchange 2007 서버를 관리할 수 있습니다. 그러나 Windows Vista 또는 Windows Server 2008 에서는 32비트 버전이나 64비트 버전을 모두 사용할 수 없습니다. Windows Vista 및 Windows Server 2008 지원은 Exchange 2007용 서비스 팩 1에서 제공될 예정입니다.

  • 프로덕션 환경에서 32비트 버전의 설치 프로그램을 사용하여 Active Directory 디렉터리 서비스 스키마를 확장할 수 있습니다. Exchange 2007에 대해 Active Directory를 준비하는 단계에 대한 자세한 내용은 Active Directory 및 도메인을 준비하는 방법을 참조하십시오.

이 두 가지 용도 이외에는 생산 환경에서 32비트 버전의 Exchange 2007을 사용할 수 없습니다.

32비트 버전의 Exchange 관리 도구를 다운로드하려면 "Microsoft Exchange Server 2007 Management Tools (32-Bit)"(http://go.microsoft.com/fwlink/?LinkId=82335)를 참조하십시오. Exchange 2007 플랫폼 버전에 대한 자세한 내용은 Exchange 2007 제품 설명서의 "Exchange Server 2007: 플랫폼, 에디션 및 버전(http://go.microsoft.com/fwlink/?LinkId=88051)을 참조하십시오.


Microsoft Windows 운영 체제에 대한 2007 표준 시간대 업데이트 설치가 필요함
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-02-20

이 컴퓨터의 표준 시간대 정보 설정을 수정하기 위해 업데이트가 필요하므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 Microsoft 기술 자료 문서 931836에서 설명하는 Windows 운영 체제에 대한 표준 시간대 업데이트가 설치되어 있어야 합니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 931836, "February 2007 cumulative time zone update for Microsoft Windows operating systems"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=931836)에서 설명하는 업데이트를 설치한 다음 Exchange 2007 설치 프로그램을 다시 실행합니다.


Active Directory가 없거나 연결할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-04-18

올바른 Active Directory 디렉터리 서비스 사이트에 연결할 수 없으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange를 설치하려면 Microsoft Exchange 설치에 사용되는 서버가 Active Directory에서 구성 명명 컨텍스트를 찾을 수 있어야 합니다.

이 문제를 해결하려면 Microsoft Exchange 설치 프로그램을 실행하는 사용자 계정으로 Active Directory에 로그온했는지 확인한 후 설치 프로그램을 다시 실행하십시오. 이렇게 해도 문제가 해결되지 않으면 아래 항목의 NETDIAG.Exe 및 DCDIAG.Exe 지원 도구 사용 안내에 따라 문제를 추가로 진단하십시오.

Active Directory 문제 해결 및 Microsoft Exchange 구성에 대한 자세한 내용은 다음을 참조하십시오.

  • Windows Server 2003: 작업(http://go.microsoft.com/fwlink/?LinkId=68099)의 "Active Directory 작업 문제 해결"

  • Active Directory 작업 가이드(http://go.microsoft.com/fwlink/?LinkId=68100)의 "Active Directory 문제 해결 도구"

  • "Exchange Server에서의 Active Directory 사용 권한 작업"(http://go.microsoft.com/fwlink/?LinkId=47592)의 "구성 명명 컨텍스트"

  • "Exchange Server에서의 Active Directory 사용 권한 작업"(http://go.microsoft.com/fwlink/?LinkId=47592)

  • "Netdiag Overview"(http://go.microsoft.com/fwlink/?LinkID=69481).

  • "Dcdiag Overview"(http://go.microsoft.com/fwlink/?LinkID=68936).


Active Directory 도메인이 혼합 모드임
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-08-10

기존 Active Directory 도메인이 조직이 Microsoft Windows® 2000 Server 기본 모드 이상으로 설정되어 있지 않으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007 설치 프로그램은 Windows 2000 Server 기본 모드 이상의 도메인에만 있을 수 있는 유니버설 보안 그룹을 만듭니다.

이 문제를 해결하려면 다음 단계에 따라 도메인 기능 수준을 Windows 2000 Server 기본 수준 이상으로 올린 다음 Exchange 2007 설치 프로그램을 다시 실행하십시오.

도메인 기능 수준을 올리려면 다음을 수행합니다.

  1. Active Directory 도메인 및 트러스트를 엽니다.

  2. 콘솔 트리에서 기능을 올릴 도메인을 마우스 오른쪽 단추로 클릭하고 도메인 기능 수준 올리기를 클릭합니다.

  3. 사용 가능한 도메인 기능 수준 선택에서 다음 절차 중 하나를 사용합니다.

    • 도메인 기능 수준을 Windows 2000 Server 기본으로 올리려면 Windows 2000 전용을 클릭한 다음 올리기를 클릭합니다.

    • 도메인 기능 수준을 Windows Server® 2003으로 올리려면 Windows Server 2003을 클릭한 다음 올리기를 클릭합니다.
주의:

Windows NT® 4.0 이전 버전을 실행하는 도메인 컨트롤러가 있는 경우 도메인 기능 수준을 Windows 2000 Server 기본으로 올리지 마십시오. 도메인 기능 수준을 Windows 2000 Server 기본으로 설정한 후에는 다시 Windows 2000 Server 혼합으로 변경할 수 없습니다.

Windows NT 4.0 이전이나 Windows 2000 Server를 실행하는 도메인 컨트롤러가 있는 경우 도메인 기능 수준을 Windows Server 2003으로 올리지 마십시오. 도메인 기능 수준을 Windows Server 2003으로 설정한 후에는 다시 Windows 2000 Server 혼합이나 Windows 2000 Server 기본으로 변경할 수 없습니다.


Active Directory를 준비해야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-26

도메인을 준비할 수 없으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange를 설치하려면 Exchange Server 2007용으로 Active Directory 디렉터리 서비스를 수정하여 Active Directory의 도메인을 준비해야 합니다.

이 문제를 해결하려면 Setup /PrepareAD 명령을 사용하여 Active Directory를 준비한 후에 도메인을 준비합니다.

PrepareAD 프로세스를 수행하는 방법에 대한 자세한 내용은 "Active Directory 및 도메인을 준비하는 방법"(http://go.microsoft.com/fwlink/?LinkId=78453)을 참조하십시오.


ADAM 포트가 이미 사용 중입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

Gateway Server 역할을 설치하려고 했으나 ADAM(Active Directory® Application Mode) 동기화에 할당된 포트가 이미 사용 중이므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

ADAM은 디렉터리 사용 응용 프로그램에 사용하도록 특별히 디자인된 LDAP(Lightweight Directory Access Protocol) 디렉터리 서비스입니다. ADAM은 응용 프로그램 관련 정보만 저장하고 복제하며 도메인 컨트롤러에 배포할 필요가 없고 Active Directory 서비스에 의존하지도 않습니다. ADAM에서는 네트워크 운영 체제 인증 또는 권한 부여를 제공하지 않습니다.

Exchange 2007에서 게이트웨이 서버는 ADAM을 사용하여 구성 정보를 저장합니다. Active Directory 디렉터리 서비스와 동기화되는 ADAM을 사용하여 메시지 보안을 위해 받는 사람 조회를 실행할 수도 있습니다.

Microsoft Exchange를 설치하려면 게이트웨이 서버 역할이 설치된 경우 ADAM 동기화 프로세스에 할당할 수 있도록 특정 포트를 사용할 수 있어야 합니다.

이 문제를 해결하려면 ADAM에 필요한 포트를 사용 중인 프로세스를 확인하고 중지하거나 명령줄 스위치를 사용하여 Exchange 2007을 실행하여 기본 ADAM 포트 할당을 재지정합니다.

기본 ADAM 포트 할당을 재지정하여 설치 프로그램을 실행하려면 다음을 수행합니다.

  1. 명령 프롬프트에서 다음 명령을 입력합니다.

    Setup.exe /adamport:xxxx /adamsslport:yyyy

    • /adamport:<ADAM에 할당할 포트 번호>

    • /adamsslport:<ADAM에 할당할 포트 번호>


응용 프로그램 공용 폴더 계층 구조 존재
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-05

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스 도메인에서 응용 프로그램 공용 폴더 계층 구조를 검색합니다. Exchange Server Analyzer에서 MAPI가 아닌 공용 폴더 트리를 찾은 경우 Exchange Server Analyzer는 경고를 표시합니다. 경고는 MAPI가 아닌 공용 폴더 트리가 Exchange 조직에 존재함을 나타냅니다. 이러한 사용자 지정 응용 프로그램 트리는 Exchange Server 2007에서 지원되지 않습니다.

MAPI가 아닌 공용 폴더 트리는 사용자 지정 응용 프로그램 개발에 사용됩니다. 이러한 트리는 Microsoft Exchange 2000 Server 및 Microsoft Exchange Server 2003에서 발생하지만 Exchange 2007에서는 지원되지 않습니다. Exchange 2007을 배포하기 전에 다음을 수행하는 것이 좋습니다.

  • MAPI가 아닌 공용 폴더 트리를 SharePoint Portal Server로 옮깁니다.

  • Exchange 2003 Server의 데이터를 유지합니다.

다양한 공용 폴더 계층 구조에 대한 자세한 내용은 "Selecting the Appropriate Client for Exchange Public Folder Access"(http:// go.microsoft.com/fwlink/?LinkId =46439)를 참조하십시오.


Active Directory 사이트의 이름을 확인할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

이 서버가 올바른 Active Directory® 디렉터리 서비스 사이트에 속하지 않은 것 같기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange를 설치하려면 Exchange 2007 설치에 사용되는 서버가 올바른 Active Directory 사이트에 속해 있어야 합니다.

이 문제를 해결하려면 로컬 서버가 올바른 Active Directory 사이트에 있는지 확인한 다음 Exchange Server 2007 설치 프로그램을 다시 실행하십시오.

Nltest.exe 명령줄 도구의 /DsGetSite 옵션을 사용하여 사이트 구성원 자격을 확인하고 표시할 수 있습니다. 자세한 내용은 Windows Server 2003 기술 참조(http://go.microsoft.com/fwlink/?LinkId=27734)의 "도구 및 설정 모음"에 있는 "Nltest.exe: NLTest 개요"를 참조하십시오.

Active Directory 문제 해결에 대한 자세한 내용은 Windows Server 2003: 작업(http://go.microsoft.com/fwlink/?linkid=68099)의 "Active Directory 작업 문제 해결"을 참조하십시오.


Recipient Update Service를 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-05-16

기존 Exchange 조직에서 도메인에 대한 RUS(Recipient Update Service)를 찾을 수 없으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange를 설치하려면 기존 Exchange 조직의 각 도메인에 Recipient Update Service 인스턴스가 있어야 합니다.

도메인에 대한 Recipient Update Service 인스턴스가 없을 경우 이 도메인에 생성된 새 사용자 개체는 자신에게 발행된 전자 메일 주소를 받지 못합니다.

이 문제를 해결하려면 각 도메인에 대한 Recipient Update Service 인스턴스가 있는지 확인하고 없을 경우 해당 도메인에 대한 Recipient Update Service 인스턴스를 만든 다음 Microsoft Exchange 설치 프로그램을 다시 실행합니다.

도메인에 대한 Recipient Update Service 인스턴스를 만들려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람을 확장합니다.

  3. Recipient Update Service 노드를 마우스 오른쪽 단추로 클릭하고 새로 만들기, Recipient Update Service를 차례로 클릭합니다.

  4. 새 개체 창에서 찾아보기를 클릭하여 도메인의 이름을 찾습니다.

  5. 도메인의 이름을 선택한 다음 확인을 클릭합니다.

  6. 새 개체 창에서 다음을 클릭한 다음 마침을 클릭합니다.

Recipient Update Service에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • "Recipient Update Service에서 받는 사람 정책을 적용하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • "Recipient Update Service가 주소 목록을 생성하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • "Exchange Recipient Update Service의 진행 상황 확인 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • "Exchange Recipient Update Service에서 수행하는 작업"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


사서함 데이터베이스를 제거할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-06-20

사서함 서버 역할 제거 프로세스를 통해 데이터 손실 없이 로컬 서버에서 사용자 사서함 데이터베이스(저장소)를 제거할 수 없으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007 설치 프로그램은 사서함 서버 역할을 제거하기 전에 서버에서 모든 사서함 저장소가 제거되었는지 확인합니다. 그러나 사용자 사서함이 서버에 남아 있을 수 있습니다.

이 문제를 해결하려면 서버에서 모든 사용자 사서함을 이동 또는 사용하지 않도록 설정한 후 Exchange 2007 설치 프로그램을 다시 실행합니다.

데이터베이스에서 사서함을 식별하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "Get-Mailbox" cmdlet(http://go.microsoft.com/fwlink/?LinkId=93470)를 참조하십시오.

사서함을 사용하지 않도록 설정하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "사서함을 사용하지 않도록 설정하는 방법"(http://go.microsoft.com/fwlink/?LinkId=93471)을 참조하십시오.

Exchange Server 2007에서 사서함 데이터베이스를 제거하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "사서함 데이터베이스를 제거하는 방법"(http://go.microsoft.com/fwlink/?LinkId=93473)을 참조하십시오.

사용자 사서함 데이터베이스 저장소 또는 복제본을 관리하는 방법에 대한 자세한 내용은 "Exchange Server 2003 관리 가이드"(http://go.microsoft.com/fwlink/?LinkId=47617)의 사서함 저장소 및 공용 폴더 저장소 관리를 참조하십시오.


공용 폴더 데이터베이스를 제거할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-01-23

사서함 서버 역할 제거 프로세스가 데이터 손실 가능성 없이 로컬 서버에서 공용 폴더 데이터베이스를 제거할 수 없기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 사서함 서버 역할을 제거하기 전에 서버에서 공용 폴더 데이터베이스를 제거해야 합니다.

공용 폴더 복제본이 서버에 남아 있거나 공용 폴더 데이터베이스가 Exchange 조직의 마지막에 있을 수 있습니다.

이 문제를 해결하려면 서버의 공용 폴더 데이터베이스를 이동하거나 삭제하고 Exchange Server 2007 설치 프로그램을 다시 실행하십시오.

Exchange Server 2007에서 공용 폴더 데이터베이스를 제거하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "How to Remove a Public Folder Database"(http://go.microsoft.com/fwlink/?LinkId=81409)를 참조하십시오.

공용 폴더 데이터베이스 저장소 또는 복제본을 관리하는 방법에 대한 자세한 내용은 "Exchange Server 2003 관리 가이드"(http://go.microsoft.com/fwlink/?LinkId=47617)의 사서함 저장소 및 공용 폴더 저장소 관리를 참조하십시오.


통합 메시징 서버 역할을 제거할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-26

통합 메시징 서버 역할을 제거하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007 설치 프로그램은 제거할 통합 메시징 서버 역할이 다이얼 플랜의 음성 안내 게시 지점을 호스트하고 있는지 여부 및 해당 다이얼 플랜에 다른 서버가 연결되어 있는지 여부를 확인합니다.

통합 메시징 서버 역할이 다이얼 플랜의 음성 안내 게시 지점을 호스트하고 있으면 제거 프로세스가 실패합니다.

이 문제를 해결하려면 음성 안내 게시 지점을 다른 서버로 이동한 다음 Exchange 2007 설치 프로그램을 다시 실행합니다.

다이얼 플랜의 음성 안내 게시 지점을 이동하는 방법에 대한 자세한 내용은 "음성 안내 게시 지점을 변경하는 방법"(http://go.microsoft.com/fwlink/?LinkId=82356)을 참조하십시오.


CMS 데이터 경로에 쓸 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-26

클러스터된 사서함 서버 역할을 공유 클러스터 드라이브에 설치하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 설치 프로그램이 /CMSDataPath 매개 변수에 대해 전송된 대상 설치 경로에 쓸 수 없습니다. Exchange를 설치하려면 클러스터된 사서함 서버 데이터의 대상 경로가 쓸 수 있는 볼륨이어야 합니다.

이 문제를 해결하려면 /CMSDataPath에 대해 쓸 수 있는 저장소 미디어의 대상 경로를 지정합니다.

클러스터된 사서함 서버를 설치하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "활성 노드에 사서함 서버 역할을 설치하는 방법"(http://go.microsoft.com/fwlink/?LinkId=86624)을 참조하십시오.


Exchange 조직 컨테이너에 쓸 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-05-04

로그온한 사용자의 계정에는 Active Directory 디렉터리 서비스의 조직 컨테이너에 쓸 수 있는 사용 권한이 없기 때문에 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange를 설치하려면 Exchange 2007을 설치할 때 로그온한 사용자에게 엔터프라이즈 관리자 또는 Exchange 조직 관리 자격 증명이 있어야 합니다.

설치 과정의 일부로서 Microsoft Exchange 조직 컨테이너에 개체를 만들어야 할 수 있습니다.

이 문제를 해결하려면 로그온한 사용자에게 엔터프라이즈 관리자 또는 Exchange 조직 관리자 권한을 부여하거나 이러한 권한이 있는 계정으로 로그온하여 Exchange 2007 설치 프로그램을 다시 실행합니다.

중요:
Exchange 2007의 포리스트 간 설치는 지원되지 않습니다. Exchange 2007을 설치할 때는 Active Directory 포리스트의 구성원인 계정을 사용하십시오.

Microsoft Exchange를 실행하는 데 필요한 Active Directory 권한에 대한 자세한 내용은 "Exchange Server에서의 Active Directory 사용 권한 작업"(http://go.microsoft.com/fwlink/?LinkId=47592)을 참조하십시오.


로컬 사이트에서 클라이언트 액세스 역할을 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

로컬 Active Directory® 디렉터리 서비스 사이트에서 기존 클라이언트 액세스 역할을 찾을 수 없으므로 Microsoft® Exchange Server 2007 설치 프로그램에서 이 경고를 표시합니다.

클라이언트 액세스 역할 인스턴스를 Active Directory 사이트에 설치하기 전에 사서함 서버 역할을 설치하도록 선택해야 합니다.

클라이언트 액세스 서버 역할은 Exchange 2007 서버에서 다양한 클라이언트로의 연결을 수락합니다. Microsoft Outlook Express 및 Eudora 등의 소프트웨어 클라이언트는 POP3 또는 IMAP4 연결을 사용하여 Exchange 서버와 통신합니다. 모바일 장치 등의 하드웨어 클라이언트는 ActiveSync, POP3 또는 IMAP4를 사용하여 Exchange 서버와 통신합니다.

Microsoft Office Outlook® 이외의 클라이언트를 사용하여 받은 편지함에 액세스하는 경우 Exchange 조직에 클라이언트 액세스 서버 역할을 설치해야 합니다.

사용자는 Outlook을 사용하여 자신의 사서함에 로그온할 수 있지만 로컬 Active Directory 사이트에 클라이언트 액세스 역할이 없으면 Outlook Web Access 또는 모바일 장치를 사용하여 같은 사서함에 로그온할 수 없습니다.


클러스터 관리 리소스를 이동하거나 오프라인 상태로 만들어야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-04-09

새 활성 클러스터 사서함 서버 역할을 설치하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange Server 2007을 설치하려면 설치가 실행 중인 클러스터 노드에서 클러스터 관리 리소스를 비활성 상태로 전환해야 합니다.

이 문제를 해결하려면 Exchange Server와 관련되지 않은 클러스터 리소스를 포함하여 해당 노드가 소유하는 모든 클러스터 관리 리소스를 클러스터의 다른 노드로 이동합니다. 또는 해당 리소스를 오프라인 상태로 만든 후에 설치 프로그램을 다시 실행합니다.

Exchange 관련 클러스터 관리 서비스를 이동하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서에서 "Move-ClusteredMailboxServer"(http://go.microsoft.com/fwlink/?LinkId=86627) cmdlet 항목을 참조하십시오.

Exchange 관련 클러스터 관리 서비스를 오프라인 상태로 만드는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서에서 "Stop-ClusteredMailboxServer"(http://go.microsoft.com/fwlink/?LinkId=86635) cmdlet 항목을 참조하십시오.

Exchange와 관련되지 않은 클러스터 리소스를 관리하는 방법에 대한 자세한 내용은 Windows Server 2003 제품 도움말에서 "Manage Resources"(http://go.microsoft.com/fwlink/?LinkId=86637)를 참조하십시오.


클러스터 서비스가 시작되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-26

Microsoft Windows Server 클러스터 서비스가 시작되지 않았으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 클러스터 서비스를 로컬 컴퓨터에 설치할 때 시작해야 합니다.

이 문제를 해결하려면 로컬 컴퓨터에서 클러스터 서비스를 시작하고 Exchange 설치 프로그램을 다시 실행합니다.

클러스터 서비스를 시작하려면 Windows Server 2003 기술 라이브러리에서 "Start the Cluster service"(http://go.microsoft.com/fwlink/?LinkId=86638)를 참조하십시오.


클러스터 업데이트 필요(KB921181)
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-08-11

클러스터 노드를 업데이트해야 하므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 클러스터 노드에 Microsoft 기술 자료 문서 921181에서 참조하는 업데이트가 설치되어 있어야 합니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 921181, "An update is available that adds a file share witness feature and a configurable cluster heartbeats feature to Windows Server 2003 Service Pack 1-based server clusters"(http://go.microsoft.com/fwlink/?LinkId=69785)에서 참조된 업데이트를 설치한 다음 Exchange 2007 설치 프로그램을 다시 실행하십시오.


CMS 데이터 경로는 NTFS 볼륨이어야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-26

클러스터된 사서함 서버 역할을 공유 클러스터 드라이브에 설치하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

/CMSDataPath 매개 변수에 대해 전송한 대상 설치 경로가 NTFS 볼륨이 아닙니다. Exchange를 설치하려면 클러스터된 사서함 서버 데이터의 대상 경로가 NTFS 볼륨이어야 합니다.

이 문제를 해결하려면 /CMSDataPath에 대해 다른 대상 경로를 선택하거나 대상 볼륨을 NTFS로 변환한 후에 Exchange 2007 설치 프로그램을 다시 실행합니다.

볼륨을 NTFS로 변환하는 방법에 대한 자세한 내용은 Windows XP Professional 제품 설명서의 "Convert"(http://go.microsoft.com/fwlink/?LinkId=86642) 항목을 참조하십시오.


현재 클러스터 노드가 클러스터 관리 서비스를 소유하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-04-09

클러스터 수동 노드를 제거하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 클러스터 관리 서비스가 이 클러스터 노드에 소유되어 있습니다. Exchange 2007을 설치하려면 Exchange 클러스터 관리 서비스를 이 노드로부터 다른 위치로 이동하고 Exchange 파일을 제거해야 합니다.

이 문제를 해결하려면 Exchange Server와 관련되지 않은 클러스터 리소스를 포함하여 해당 노드가 소유하는 모든 클러스터 관리 리소스를 클러스터의 다른 노드로 이동하거나 오프라인 상태로 만든 후에 설치 프로그램을 다시 실행합니다.

Exchange 관련 클러스터 관리 서비스를 이동하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서에서 "Move-ClusteredMailboxServer"(http://go.microsoft.com/fwlink/?LinkId=86627) cmdlet 항목을 참조하십시오.

Exchange 관련 클러스터 관리 서비스를 오프라인 상태로 만드는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서에서 "Stop-ClusteredMailboxServer"(http://go.microsoft.com/fwlink/?LinkId=86635) cmdlet 항목을 참조하십시오.

Exchange와 관련되지 않은 클러스터 리소스를 관리하는 방법에 대한 자세한 내용은 Windows Server 2003 제품 도움말에서 "Manage Resources"(http://go.microsoft.com/fwlink/?LinkId=86637)를 참조하십시오.


Com+ Event System 서비스를 시작해야 설치를 계속할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-16

대상 컴퓨터에서 Com+ Event System 서비스를 시작하지 않아 클라이언트 액세스 서버 또는 Edge 전송 서버 역할을 설치하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 Microsoft Exchange를 설치하는 컴퓨터의 Com+ Event System 서비스 상태가 시작됨으로 설정되어 있어야 합니다.

Com+ Event System 서비스는 구독하는 COM 구성 요소에 대해 이벤트를 자동으로 배포하는 COM+ 구성 요소에 대한 시스템 이벤트 알림을 지원합니다.

클라이언트 액세스 서버 및 Edge 전송 서버 역할은 모두 Com+ Event System 서비스를 구독하는 COM+ 구성 요소를 사용합니다.

이 문제를 해결하려면 로컬 컴퓨터에서 Com+ Event System 서비스의 상태가 시작됨으로 설정되어 있는지 확인한 후에 Microsoft Exchange 설치 프로그램을 다시 실행합니다.

Com+ Event System 서비스의 상태를 '시작됨'으로 설정하려면 다음을 수행합니다.

  1. 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 관리를 클릭합니다.

  2. 서비스 및 응용 프로그램 노드를 확장한 다음 서비스 노드를 클릭합니다.

  3. 오른쪽 창에서 Com+ Event System을 찾습니다.

  4. Com+ Event System을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  5. 시작 유형을 자동으로 설정하고 서비스 상태를 시작됨으로 설정합니다.

  6. 적용을 클릭한 다음 확인을 클릭합니다.


복합 Exchange 조직 모델 검색됨
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-08-10

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 Exchange Server 조직의 라우팅 그룹 수를 확인합니다. 또한 Exchange Server Analyzer는 Active Directory를 쿼리하여 Microsoft Exchange 2000 Server 또는 Microsoft Exchange Server 2003을 실행하는 Exchange Server가 포함된 Active Directory 사이트 수를 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 Exchange 조직을 복합 Exchange 조직으로 분류합니다.

  • 여러 개의 Active Directory 포리스트가 있습니다.

  • 하나 이상의 포리스트에 MIIS(Microsoft Identity Integration Server)가 설치되어 있습니다.

Microsoft Exchange Server 2007에 대해 정의된 네 가지 조직 모델 중에서 복합 Exchange 조직은 여러 개의 Active Directory 포리스트나 동기화 기술 사용을 포함하는 유일한 모델입니다.

복합 Exchange 조직을 Exchange 2007로 전환하려면 다음을 수행합니다.

  1. Exchange 2007 온라인 제품 설명서(http://go.microsoft.com/fwlink/?LinkId=69434)를 봅니다.

  2. "복합 Exchange 조직을 위한 계획" 항목(http://go.microsoft.com/fwlink/?LinkId=70505)을 검토합니다.


로컬 컴퓨터에서 '기본 웹 사이트'를 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

Microsoft® Exchange Server 2007 설치 프로그램이 이 서버의 기본 웹 사이트에 액세스할 수 없기 때문에 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 클라이언트 액세스 역할 설치가 Microsoft 인터넷 정보 서비스(IIS)에서 만든 기본 웹 사이트에 액세스할 수 있어야 합니다.

클라이언트 액세스 서버 역할은 Microsoft Office Outlook®(HTTP를 통해 연결되는 경우), Outlook Web Access, Exchange ActiveSync® 및 POP3 또는 IMAP4 프로토콜을 사용하는 클라이언트와 같은 클라이언트 액세스 기능을 제공합니다.

IIS는 HTTP, POP3, IMAP4, SMTP(Simple Mail Transfer Protocol) 및 NNTP(Network News Transfer Protocol) 프로토콜의 프로토콜 엔진 역할을 합니다.

IIS 기본 웹 사이트가 더 이상 존재하지 않는 상황이 발생할 수 있습니다. 기본 웹 사이트 이외의 사이트로 이름이 바뀌거나 삭제되었을 수 있습니다.

이 문제를 해결하려면 먼저 이 서버에서 IIS를 제거한 다음 다시 설치하십시오. 그런 다음 Exchange 2007 설치 프로그램을 다시 실행하십시오.

중요:
이 문제를 해결하려면 IIS를 제거한 다음 다시 설치해야 합니다. 디렉터리를 다시 만들거나 이름을 바꾸는 것만으로는 부족합니다.
제어판에서 Windows 구성 요소 추가/제거를 사용하여 IIS를 제거하려면 다음을 수행합니다.

  1. 시작 메뉴에서 제어판을 클릭합니다.

  2. 프로그램 추가/제거를 두 번 클릭합니다.

  3. Windows 구성 요소 추가/제거를 클릭합니다.

  4. 구성 요소 목록에서 응용 프로그램 서버 확인란을 클릭합니다.

  5. 자세히를 클릭합니다.

  6. 인터넷 정보 서비스 관리자를 클릭합니다.

  7. 다음을 클릭합니다.

  8. IIS 제거를 완료했으면 마침을 클릭합니다.
제어판을 사용하여 IIS를 설치하려면 다음을 수행합니다.

  1. 시작 메뉴에서 제어판을 클릭합니다.

  2. 프로그램 추가/제거를 두 번 클릭합니다.

  3. Windows 구성 요소 추가/제거를 클릭합니다.

  4. 구성 요소 목록에서 응용 프로그램 서버 확인란을 클릭합니다.

  5. 자세히를 클릭합니다.

  6. 인터넷 정보 서비스 관리자 확인란을 클릭합니다.

  7. Windows 구성 요소 마법사로 돌아갈 때까지 확인을 클릭합니다.

  8. 다음을 클릭하고 Windows 구성 요소 마법사를 완료합니다.


Distributed Transaction Coordinator 서비스를 시작해야 설치를 계속할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-16

대상 컴퓨터에서 Distributed Transaction Coordinator 서비스를 시작하지 않아 클라이언트 액세스 서버 또는 통합 메시징 서버 역할을 설치하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 Microsoft Exchange를 설치하는 컴퓨터의 Distributed Transaction Coordinator 서비스 상태가 시작됨으로 설정되어 있어야 합니다.

Distributed Transaction Coordinator 서비스는 시스템 오류, 프로세스 오류, 통신 오류 등이 발생하는 경우에도 트랜잭션을 완전하게 성공적으로 수행할 수 있도록 하는 서비스를 제공합니다.

분산 트랜잭션에 참가하는 각 컴퓨터는 해당 리소스 및 데이터를 관리하며 트랜잭션에 포함된 다른 컴퓨터와 함께 작업을 수행합니다. 그러므로 분산 트랜잭션은 모든 참여 컴퓨터에 대해 해당 작업을 전체적으로 커밋하거나 중단해야 합니다. Distributed Transaction Coordinator는 참여 구성 요소에 대해 트랜잭션 조정 역할을 수행하며 트랜잭션을 관리하는 각 컴퓨터에 대해 트랜잭션 관리자 역할을 합니다.

클라이언트 액세스 서버 및 통합 메시징 서버 역할은 모두 Distributed Transaction Coordinator 서비스를 사용합니다.

이 문제를 해결하려면 로컬 컴퓨터에서 Distributed Transaction Coordinator 서비스의 상태가 시작됨으로 설정되어 있는지 확인한 후에 Microsoft Exchange 설치 프로그램을 다시 실행합니다.

Distributed Transaction Coordinator 서비스의 상태를 '시작됨'으로 설정하려면 다음을 수행합니다.

  1. 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 관리를 클릭합니다.

  2. 서비스 및 응용 프로그램 노드를 확장한 다음 서비스 노드를 클릭합니다.

  3. 오른쪽 창에서 Distributed Transaction Coordinator를 찾습니다.

  4. Distributed Transaction Coordinator를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

  5. 시작 유형을 자동으로 설정하고 서비스 상태를 시작됨으로 설정합니다.

  6. 적용을 클릭한 다음 확인을 클릭합니다.


로컬 컴퓨터에서 DNS 접미사가 설정되지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-05

로컬 컴퓨터의 FQDN(정규화된 도메인 이름)이 설정되지 않았으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 로컬 컴퓨터에서 유효한 DNS(Domain Name System) 접미사가 설정되어 있어야 합니다.

이 문제를 해결하려면 로컬 컴퓨터의 DNS 접미사를 설정하고 컴퓨터를 다시 시작한 후 Exchange 2007 설치 프로그램을 다시 실행합니다.

로컬 컴퓨터의 기본 DNS 접미사를 설정하려면 다음을 수행합니다.

  1. 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. 시스템 속성 대화 상자가 나타납니다.

  2. 컴퓨터 이름 탭을 클릭합니다.

  3. 변경을 클릭합니다. 컴퓨터 이름 변경 대화 상자가 나타납니다.

  4. 자세히를 클릭합니다. DNS 접미사 및 NetBIOS 컴퓨터 이름 대화 상자가 나타납니다.

  5. 도메인에 적합한 DNS 접미사를 입력합니다.

  6. 도메인 구성 자격이 변경되면 주 DNS 접미사 변경 확인란을 선택합니다.

  7. 확인을 클릭하여 변경 내용을 저장한 다음 확인을 클릭하여 컴퓨터 이름 변경 대화 상자를 닫습니다.

  8. 확인을 클릭하여 시스템 속성 대화 상자를 닫은 다음 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

DNS 이름에 대한 자세한 내용은 Microsoft 기술 자료 문서 909264, "Active Directory에서 컴퓨터, 도메인, 사이트 및 OU에 대한 명명 규칙"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264)을 참조하십시오.


레지스트리에 도메인 컨트롤러 다시 정의가 설정되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

지정된 도메인 컨트롤러를 사용할 수 없으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다. 도메인 컨트롤러가 레지스트리에 정적으로 매핑되었습니다.

Exchange 2007을 설치하려면 설치 명령에 지정되어 있는 도메인 컨트롤러가 레지스트리 다시 정의를 사용하여 정적으로 매핑된 도메인 컨트롤러와 일치해야 합니다.

이 문제를 해결하려면 /DomainController: <정적으로 매핑된 도메인 컨트롤러의 FQDN> 매개 변수에 대해 정적으로 매핑된 도메인 컨트롤러를 지정하여 설치 프로그램을 다시 실행합니다.

DSAccess와 디렉터리 서비스 검색에 대한 자세한 내용은 Microsoft 기술 자료 문서 250570, "디렉터리 서비스 서버 감지 및 DSAccess 사용"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)을 참조하십시오.


도메인을 준비해야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

서버 역할을 설치하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange를 설치하려면 Exchange Server 2007용으로 로컬 도메인을 준비하여 특정 서버 역할을 설치해야 합니다.

Exchange Server 2007용 도메인 준비는 다음과 같은 작업으로 구성됩니다.

  • Exchange Servers, Exchange Organization Administrators, Authenticated Users 및 Exchange Mailbox Administrators에 대해 도메인 컨테이너에 사용 권한을 설정합니다.

  • Microsoft Exchange System Objects 컨테이너가 없는 경우 만들고 Exchange Servers, Exchange Organization Administrators 및 Authenticated Users에 대해 이 컨테이너에 사용 권한을 설정합니다.

  • 현재 도메인(Exchange Install Domain Servers)에 새 도메인 글로벌 그룹을 만듭니다.

  • Exchange Install Domain Servers 그룹을 루트 도메인의 Exchange Servers USG에 추가합니다.

이 문제를 해결하려면 setup /PrepareDomain을 실행하여 로컬 도메인을 준비한 후에 서버 역할 설치를 다시 시도합니다.

PrepareDomain 프로세스를 수행하는 방법에 대한 자세한 내용은 "Active Directory 및 도메인을 준비하는 방법"(http://go.microsoft.com/fwlink/?LinkId=78453)을 참조하십시오.


로컬 컴퓨터에 Edge 전송 역할을 설치할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-01-03

Edge 서버 역할을 설치하려고 시도했으나 이 서버에 이미 다른 Microsoft Exchange 역할이 설치되어 있으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

다른 Microsoft Exchange 역할이 설치되어 있는 서버에는 Edge 서버 역할을 설치할 수 없습니다.

Microsoft Exchange Edge 서버 역할이 조직의 주변 네트워크에 배포되며 모든 인터넷 메일 흐름을 처리합니다. 또한 트러스트된 Microsoft Exchange 조직 간에 보낸 메시지의 암호화 및 암호 해독 기능과 스팸 메일 방지 기능을 제공합니다.

이 문제를 해결하려면 다른 Microsoft Exchange 역할이 설치되지 않은 컴퓨터에 Edge 서버 역할을 설치합니다.


토폴로지 내 EDK 커넥터 발견
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-04

Microsoft® Exchange Server Analyzer Tool은 Exchange 조직의 EDK(Exchange 개발 키트) 커넥터에 대한 Active Directory® 디렉터리 서비스를 확인합니다. Active Directory에 EDK 커넥터가 있으면 Exchange Server Analyzer는 경고를 표시합니다. 이 경고는 EDK 커넥터가 Microsoft Exchange Server 2007에서 지원되지 않음을 알립니다.

Exchange 2007에서 사용할 수 있는 대체 커넥터 제품을 알아보려면 타사 공급업체에 문의하는 것이 좋습니다. 또는 EDK 커넥터를 지원하는 Exchange 2003 또는 Microsoft Exchange 2000 Server를 유지합니다.

참고:
EDK 커넥터는 팩스, SMS(Short Message Service), 텔렉스, 또는 게이트웨이 커넥터를 사용하는 Lotus Notes와 같은 기타 메시징 시스템에 연결할 수 있도록 만들어진 타사 응용 프로그램입니다. Microsoft 공급업체가 아닌 경우 EDK(Exchange 개발 키트)를 사용하여 고유 커넥터를 개발합니다.


하나 이상의 프로세스에서 Esm.dll을 사용하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-28

모듈 액세스에 문제가 발생하여 서버를 업그레이드하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 업그레이드 과정에서 이진 파일을 수정할 수 있도록 특정 모듈을 실행하지 않아야 합니다. Esm.dll 파일도 이러한 모듈 중 하나입니다.

이 문제를 해결하려면 Esm.dll을 열고 있는 프로세스를 언로드한 후에 Exchange 2007 설치 프로그램을 다시 실행합니다.

Esm.dll을 열고 있는 프로세스를 중지하려면 다음을 수행합니다.

  1. Exchange 관리 셸을 시작합니다.

  2. Get-Process cmdlet를 사용하여 Exchange Analyzer가 식별한 프로세스의 프로세스 ID를 찾습니다.

  3. Get-Process < 프로세스 이름 >

  4. Stop-Process cmdlet를 사용하여 프로세스를 중지합니다.

  5. Stop-Process < 프로세스 ID >

  6. 여기서 <process ID>는 2단계에서 Get-Process cmdlet을 통해 반환된 프로세스 ID 값입니다.

Get-Process cmdlet에 대한 자세한 내용은 "What Can I Do With Windows PowerShell?" 항목의 Using the Get-Process Cmdlet를 참조하십시오.


'ExchHelp.chm'이 열려 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-16

파일 액세스에 문제가 발생하여 서버를 업그레이드하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 업그레이드 프로세스에서 특정 파일 또는 파일에 액세스하는 프로세스를 수정할 수 있도록 해당 파일을 닫아야 합니다. 로컬 Exchange 도움말(ExchHelp.chm) 파일도 이러한 파일 중 하나입니다.

이 문제를 해결하려면 ExchHelp.chm 파일을 닫은 후에 Exchange 2007 설치 프로그램을 다시 실행합니다.


Exchange 2000 Server 컴퓨터를 SP3으로 업그레이드해야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

기존 조직에 있는 하나 이상의 서버가 서비스 팩 3 이상 버전이 없는 Exchange 2000 Server를 실행 중이므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 조직에 있는 모든 기존 Exchange 2000 Server 컴퓨터에서 Exchange 2000 Server 서비스 팩 3(SP3)을 실행해야 합니다.

이 문제를 해결하려면 조직에 있는 모든 기존 Exchange 2000 Server 컴퓨터를 Exchange 2000 Server SP3 이상 버전으로 업그레이드한 후에 Exchange 2007 설치 프로그램을 다시 실행합니다.

Exchange 2000 Server 컴퓨터를 Exchange 2000 Server SP3 이상 버전으로 업그레이드하는 방법에 대한 자세한 내용은 "Downloads for Exchange 2000 Server"(http://go.microsoft.com/fwlink/?LinkId=86647)를 참조하십시오.


혼합 모드를 사용하는 Exchange 조직
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-05

Microsoft® Exchange Server Analyzer Tool은 Exchange 조직의 모드를 확인하기 위해 Exchange 조직 컨테이너를 쿼리합니다. Exchange Server Analyzer는 msExchangeMixedMode 특성 값을 확인합니다. msExchangeMixedMode 특성 값이 True인 경우 Exchange Server Analyzer는 오류를 표시합니다. 오류 메시지는 Exchange 조직이 혼합 모드에서 실행되고 있음을 나타냅니다. Microsoft Exchange Server 2007은 전용 모드인 조직에만 설치할 수 있습니다. 따라서 Exchange 2007 배포를 위해서는 혼합 모드에서 실행되는 조직을 전용 모드로 전환해야 합니다.

참고:
전용 모드에서 실행되는 조직은 Exchange 2000 Server 이상 버전만 포함할 수 있습니다.

Exchange 2007을 배포하려면 다음 단계를 수행하여 Exchange 조직을 전용 모드로 전환해야 합니다.

  1. 남아 있는 Exchange 5.5 서버를 모두 제거하거나 역할을 해제합니다.

  2. Exchange System Manager에서 Exchange 조직 개체의 속성을 열고 전용 모드로 전환합니다.

Exchange 조직을 전용 모드로 전환하는 방법에 대한 자세한 내용은 Exchange Server 2003 Deployment Guide의 "How to Convert from Mixed Mode to Native Mode in Exchange"(http://go.microsoft.com/fwlink/?LinkId=56642)를 참조하십시오.

Microsoft Exchange의 혼합 모드와 전용 모드에 대한 자세한 내용은 다음의 Microsoft 기술 자료 문서를 참조하십시오.

  • 270143, "혼합 모드와 기본 모드 비교"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=270143)

  • 327779, "HOWTO: Exchange에서 혼합 모드에서 기본 모드로 변환"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779)

  • 272314, "XADM: 혼합 모드 조직을 기본 모드로 변환하기 위한 준비"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=272314)


Exchange Server 2003 컴퓨터를 SP2로 업그레이드해야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

기존 조직에 있는 하나 이상의 서버가 서비스 팩 2 이상 버전이 없는 Exchange Server 2003을 실행 중이므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 조직에 있는 모든 기존 Exchange Server 2003 컴퓨터에서 Exchange Server 2003 서비스 팩 2(SP2)를 실행해야 합니다.

이 문제를 해결하려면 조직에 있는 모든 기존 Exchange Server 2003 컴퓨터를 Exchange Server 2003 SP2 이상 버전으로 업그레이드한 후에 Exchange 2007 설치 프로그램을 다시 실행합니다.

Exchange Server 2003 컴퓨터를 Exchange Server 2003 SP2 이상 버전으로 업그레이드하는 방법에 대한 자세한 내용은 "Downloads for Exchange Server 2003"(http://go.microsoft.com/fwlink/?LinkId=21030)을 참조하십시오.


현재 버전의 Windows에서는 Exchange Server 2007을 사용할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

로컬 컴퓨터에서 Exchange Server 2007이 지원하는 Microsoft Windows Server 운영 체제를 실행하고 있지 않으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 로컬 컴퓨터의 Windows Server 버전이 Exchange Server 2007 시스템 요구 사항에서 지정하는 대로 Exchange Server 2007을 실행하도록 지원해야 합니다.

이 문제를 해결하려면 Exchange Server 2007을 지원하는 버전의 Windows Server 운영 체제를 로컬 컴퓨터에 설치하거나 지원되는 버전의 Windows Server를 실행 중인 컴퓨터에 Exchange Server 2007을 설치합니다.

Exchange Server 2007 시스템 사양에 대한 자세한 내용은 "Exchange Server 2007 System Requirements"(http://go.microsoft.com/fwlink/?LinkId=86651)를 참조하십시오.


파일 공유 감시를 구성하지 않았습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-23

CCR(클러스터 연속 복제) 클러스터에 대해 파일 공유 감시를 구성하지 않았으므로 Microsoft Exchange 2007 설치를 계속할 수 없습니다.

MNS(주 노드 집합) 쿼럼 클러스터에 있는 노드 하나에서 발생한 오류를 유지하려면 사용 가능한 것으로 간주되는 장치가 최소한 세 개 이상 있어야 합니다. 파일 공유 감시 기능을 사용하면 외부 파일 공유를 감시 항목으로 사용할 수 있습니다. 이 감시 항목은 노드가 두 개인 MNS 쿼럼 클러스터에서 사용 가능한 세 번째 장치 역할을 합니다.

Exchange 2007을 설치하려면 CCR 환경에서 클러스터된 사서함 서버 역할을 설치하기 위해 파일 공유 감시 기능을 구성해야 합니다.

이 문제를 해결하려면 "파일 공유 감시를 구성하는 방법"(http://go.microsoft.com/fwlink/?LinkId=78278)에 나와 있는 절차에 따라 파일 공유 감시용 파일 공유를 만들어 보안을 적용합니다. 그런 다음 MNSFileShare 값을 설정하고 클러스터 그룹을 두 번 이동한 후에 Microsoft Exchange 설치 프로그램을 다시 실행하십시오.


첫 번째 역할 설치는 위임할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

로그온한 사용자가 토폴로지의 첫 번째 서버 역할을 설치하는 데 필요한 계정 권한을 가지고 있지 않기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange 설치 프로그램에서는 후속 서버 역할을 설치할 때 위임을 사용할 수 있도록 허용하지만, 토폴로지의 첫 번째 Exchange 2007 서버 역할이 설치되어 있을 경우 로그온한 사용자가 Exchange 조직 관리 자격 증명을 가지고 있어야만 Exchange를 설치할 수 있습니다.

첫 번째 서버 역할 설치의 일부분으로 Exchange 2007 설치 프로그램에서 Exchange 조직 컨테이너에 개체를 만들어야 할 수 있습니다.

이 문제를 해결하려면 로그온한 사용자에게 Exchange 조직 관리자 권한을 부여하거나 해당 권한을 가진 계정을 사용하여 로그온한 다음 Exchange 2007 설치 프로그램을 다시 실행하십시오.


Forefront Security for Exchange Server 서비스를 사용하지 않도록 설정해야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-06-20

로컬 컴퓨터에서 Microsoft Forefront Security for Exchange Server 서비스가 실행되고 있기 때문에 Microsoft Exchange Server 2007 설치 프로그램에서 Exchange Server 2007 업그레이드를 계속할 수 없습니다.

Exchange를 설치하려면 Exchange Server 2007 업그레이드를 계속하려면 먼저 Forefront Security for Exchange Server 서비스를 사용하지 않도록 설정해야 합니다.

이 문제를 해결하려면 Forefront Security for Exchange Server 서비스를 사용하지 않도록 설정한 다음 Exchange Server를 다시 업그레이드합니다.

Forefront Security를 실행 중인 Exchange Server에 서비스 팩이나 소프트웨어 업데이트를 설치하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 929080 Forefront Security를 실행 중인 Exchange Server 컴퓨터에 서비스 팩 또는 소프트웨어 업데이트를 설치하는 방법(How to install a service pack or a software update on an Exchange Server computer that is running Forefront Security)을 참조하십시오.


Forefront Security for Exchange Server 업그레이드가 필요합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

적용 대상: Exchange Server 2007, Exchange Server 2007 SP1
최근 수정된 항목: 2007-08-08

Exchange Server 2007 SP1(서비스 팩 1)에서 지원하지 않는 Microsoft Forefront Security for Exchange Server 버전을 로컬 컴퓨터에서 실행하고 있으므로 Microsoft Exchange Server 2007 설치 프로그램이 Exchange 2007 업그레이드를 계속할 수 없습니다.

Exchange Server 2007 업그레이드를 계속하려면 Microsoft Forefront Security for Exchange Server 버전을 업그레이드하고 그 서비스를 사용하지 않도록 설정해야 합니다.

이 문제를 해결하려면 Exchange Server 업그레이드를 계속하기 전에 Microsoft Forefront Security for Exchange Server 버전 10.0을 Microsoft Forefront Security for Exchange Server SP1으로 업그레이드한 다음 Microsoft Forefront Security for Exchange Server 서비스를 사용하지 않도록 설정하십시오.

추가 정보

Forefront Security를 실행 중인 Exchange Server에 서비스 팩이나 소프트웨어 업데이트를 설치하는 방법에 대한 자세한 내용은 Microsoft 기술 자료 문서 929080 "Forefront Security를 실행 중인 Exchange Server 컴퓨터에 서비스 팩 또는 소프트웨어 업데이트를 설치하는 방법(How to install a service pack or a software update on an Exchange Server computer that is running Forefront Security)"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=929080)을 참조하십시오.


컴퓨터의 정규화된 도메인 이름이 받는 사람 정책과 일치합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-05-16

로컬 컴퓨터의 정규화된 도메인 이름(FQDN)이 받는 사람 정책의 SMTP(Simple Mail Transfer Protocol) 주소와 일치하기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange를 설치하려면 Exchange 조직에 있는 서버의 FQDN이 같은 Exchange 조직에 있는 받는 사람 정책의 SMTP 주소와 일치하지 않아야 합니다.

컴퓨터의 FQDN이 받는 사람 정책의 SMTP 주소와 일치하면 SMTP를 통한 메일이 실패하고 MTA 큐에서 중단이 발생할 수 있습니다.

이 문제를 해결하려면 로컬 컴퓨터의 이름을 바꾸거나 받는 사람 정책을 제거하거나 이름을 바꾸고 Microsoft Exchange 설치 프로그램을 다시 실행하십시오.

로컬 컴퓨터의 이름을 바꾸려면 다음을 수행합니다.

  1. 제어판에서 시스템을 엽니다.

  2. 컴퓨터 이름 탭에서 변경을 클릭합니다.

  3. 컴퓨터 이름에서 컴퓨터의 새 이름을 입력한 다음 확인을 클릭합니다. 도메인에서 컴퓨터의 이름을 바꾸기 위해 사용자 이름과 사용자 암호를 묻는 메시지가 표시됩니다.

  4. 확인을 클릭하여 시스템 속성 대화 상자를 닫습니다. 변경 사항을 적용하려면 컴퓨터를 다시 시작하라는 메시지가 표시됩니다.
중요:
이름을 바꿀 컴퓨터가 도메인 컨트롤러인 경우 "도메인 컨트롤러 이름 바꾸기"(http://go.microsoft.com/fwlink/?LinkId=66828)를 참조하십시오.
받는 사람 정책 SMTP 주소를 수정하려면 다음을 수행합니다.

  1. Exchange System Manager를 시작합니다.

  2. 조직, 받는 사람, 받는 사람 정책을 차례로 클릭합니다.

  3. 변경할 정책을 두 번 클릭합니다.

  4. 전자 메일 주소 탭을 클릭한 다음 해당 SMTP 주소를 변경합니다.

받는 사람 정책 명명 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 288175, "XCON: 받는 사람 정책이 조직에 있는 서버의 FQDN과 일치하여 5.4.8 NDR가 반환된다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=288175)를 참조하십시오.


로컬 사이트에 글로벌 카탈로그 서버가 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

Microsoft Exchange를 설치하려는 사이트에 글로벌 카탈로그 서버가 없기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange를 설치하려면 설치 프로그램을 실행하는 컴퓨터의 Active Directory® 디렉터리 서비스 사이트에 글로벌 카탈로그 역할을 하는 서버가 포함되어 있어야 합니다.

이 문제를 해결하려면 다음 단계 중 하나를 수행합니다.

  • 사이트의 기존 도메인 컨트롤러를 글로벌 카탈로그 서버로 설정합니다.

  • 글로벌 카탈로그 서버 역할에 새 서버를 설치합니다.

기존 도메인 컨트롤러를 글로벌 카탈로그 서버로 설정하려면 다음을 수행합니다.

  1. Active Directory 사이트 및 서비스를 엽니다.

  2. 사이트, 사이트 및 서버를 차례로 확장합니다.

  3. 글로벌 카탈로그 서버로 지정하려는 도메인 컨트롤러를 선택합니다.

  4. 오른쪽 창에서 NTDS 설정을 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  5. 일반 탭에서 글로벌 카탈로그 확인란을 선택합니다. 서버를 다시 시작하지 않고도 변경 내용이 동적으로 적용됩니다.
  • 글로벌 카탈로그 서버를 만드는 방법은 Microsoft 기술 자료 문서 313994, "HOWTO: Windows 2000에서 글로벌 카탈로그를 만들거나 이동"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994)을 참조하십시오.

  • Exchange Server와 관련하여 글로벌 카탈로그 서버 배치 및 가용성에 대한 자세한 내용은 Microsoft 기술 자료 문서 875427, "Exchange 2000 Server 조직 또는 Exchange Server 2003 조직에서 글로벌 카탈로그 서버 배치 및 비율" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427)을 참조하십시오.


글로벌 업데이트 필요
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-09-19

로그온한 사용자의 계정에는 Active Directory® 디렉터리 서비스의 글로벌 업데이트를 수행하는 데 필요한 권한이 없기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange를 설치하려면 Exchange 2007을 설치할 때 로그온한 사용자에게 엔터프라이즈 관리자 관리 자격 증명이 있어야 합니다.

설치 프로세스의 일부로서 Exchange 2007 설치 시 다음을 수행해야 합니다.

  • Active Directory 디렉터리 서비스에 Exchange 조직 개체를 만들거나 수정합니다.

  • Exchange 2007용 Active Directory 포리스트에서 모든 도메인을 준비합니다.

  • Exchange 2007용 기존 Exchange 2000 Server 및 Exchange Server 2003 도메인을 준비합니다.

이 문제를 해결하려면 로그온한 사용자에게 엔터프라이즈 관리자 권한을 부여하거나 해당 권한을 가진 계정으로 로그온한 다음 Exchange 2007 설치 프로그램을 다시 실행하십시오.

Exchange를 실행하는 데 필요한 Active Directory 사용 권한에 대한 자세한 내용은 "Exchange 서버에서의 Active Directory 사용 권한 작업"(http://go.microsoft.com/fwlink/?LinkId=47592)을 참조하십시오.


DNS 데이터베이스에서 로컬 컴퓨터의 호스트 레코드를 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-05

DNS(Domain Name System) 데이터베이스에서 이 컴퓨터의 호스트(A) 레코드를 찾을 수 없기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 로컬 컴퓨터에 도메인에 대해 신뢰할 수 있는 DNS 데이터베이스에 등록된 올바른 호스트(A) 레코드가 있어야 합니다.

Microsoft Exchange는 다음 내부 또는 외부 대상 서버의 IP 주소에 대한 DNS 호스트(A) 레코드에 의존합니다.

이 문제를 해결하려면 다음을 수행합니다.

  • 로컬 TCP/IP 구성이 올바른 DNS 서버를 가리키는지 확인합니다.

    로컬 TCP/IP 구성을 확인하려면 다음을 수행합니다.

    1. 로컬 TCP/IP 구성을 검토합니다. 자세한 내용은 "DNS를 사용하도록 TCP/IP 구성"(http://go.microsoft.com/fwlink/?LinkId=68094)를 참조하십시오.
  • Nslookup.exe를 사용하여 호스트(A) 레코드가 DNS 서버에 있는지 확인합니다. 자세한 내용은 "A 리소스 레코드가 DNS에 있는지 확인하려면"(http://go.microsoft.com/fwlink/?LinkId=63001)을 참조하십시오.

DNS 이름 확인, 문제 해결 및 호스트(A) 레코드에 대한 자세한 내용은 다음 문서를 참조하십시오.

  • Microsoft 기술 자료 문서 322856, "HOWTO: Exchange Server 사용을 위한 DNS 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • "DNS 문제 해결"(http://go.microsoft.com/fwlink/?LinkId=63003)

  • "리소스 레코드 관리"(http://go.microsoft.com/fwlink/?LinkId=63004)


로컬 사이트에서 Hub 전송 역할을 찾을 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

로컬 Active Directory® 디렉터리 서비스 사이트에서 기존 Hub 전송 서버 역할을 찾을 수 없으므로 Microsoft® Exchange Server 2007 설치 프로그램에서 이 경고를 표시합니다.

Hub 전송 역할 인스턴스를 Active Directory 사이트에 설치하기 전에 사서함 서버 역할을 설치하도록 선택해야 합니다.

조직의 Active Directory 내에 Exchange 2007 Hub 전송 서비스가 배포됩니다. Hub 전송 서비스에서는 조직 내의 모든 메일 흐름을 처리하고, 조직의 메일 흐름 라우팅 규칙을 적용하고, 메시지를 받는 사람의 사서함에 배달합니다.

사용자는 자신의 사서함에 로그온할 수 있지만 Hub 전송 역할을 설치해야 이 사서함 서버에서 메일을 보내거나 받을 수 있습니다.


Hub Transport Server Not Present in Active Directory Site
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-07-25

Microsoft Exchange Analyzer Tool은 Exchange Server 2007 특정 관리 그룹 식별자인 FYDIBOHF23SPDLT를 포함하는 Exchange 조직의 msExchAdminGroupContainer 클래스 개체 값을 Active Directory 디렉터리 서비스에서 쿼리합니다.

Exchange Analyzer는 Exchange 조직에 Exchange Server 2007 관리 그룹이 있는 경우 사이트에 설치된 사서함 서버 역할이 설치되어 있는지 여부를 확인할 때 각 msExchExchangeServer 개체의 msExchCurrentServerRoles 특성 값을 조직의 모든 Active Directory 사이트에서 쿼리합니다.

마지막으로 Exchange Analyzer는 사이트에 설치된 사서함 서버 역할이 있는 경우 허브 전송 서버 역할도 동일한 사이트에 설치되어 있는지 여부를 확인할 때 해당 사이트의 각 msExchExchangeServer 개체의 msExchCurrentServerRoles 특성을 쿼리합니다.

Exchange Analyzer는 Active Directory 사이트에 사서함 서버 역할은 설치되어 있으나 허브 전송 서버 역할은 설치되어 있지 않은 경우 오류를 표시합니다.

이 오류는 Active Directory 사이트에 사서함 서버 역할이 설치되어 있지만 사이트에 적어도 하나 이상의 허브 전송 서버 역할이 설치될 때까지는 사서함이 같은 서버에 있더라도 사서함 간에 메일이 전송되지 않음을 나타냅니다.

허브 전송 서버 역할은 조직의 Active Directory 디렉터리 서비스 내에 배포됩니다. 허브 전송 서버 역할은 조직 내의 모든 메일 흐름을 처리하고 조직 메시지 정책을 적용하며 받는 사람 사서함으로 메시지를 배달합니다. 허브 전송 서버는 다음 기능을 제공합니다.

메일 흐름 허브 전송 서버 역할은 Exchange 2007 조직 내부에서 보내는 모든 메시지가 조직 내 받는 사람의 받은 편지함에 배달되거나 조직 외부의 사용자에게 라우팅되기 전에 처리합니다. 이 동작은 예외 없이 수행됩니다.

분류 분류기는 Exchange 2007 전송 파이프라인을 통해 이동하는 모든 메시지에 대해 받는 사람 확인, 라우팅 확인 및 콘텐츠 변환을 수행합니다.

라우팅 허브 전송 서버 역할은 조직 내에서 보내고 받은 모든 메시지의 라우팅 경로를 확인합니다.

배달 메시지는 저장소 드라이버를 통해 받는 사람 사서함으로 배달됩니다. 조직의 사용자가 보낸 메시지는 보낸 사람의 보낼 편지함에서 저장소 드라이버에 의해 선택된 다음 허브 전송 서버의 전송 큐에 배치됩니다.

이 오류를 해결하려면 사서함 서버 역할이 설치된 사이트에 허브 전송 서버 역할을 설치합니다.

추가 정보

사이트에 허브 전송 서버 역할을 배포하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "서버 역할 배포"(http://go.microsoft.com/fwlink/?LinkId=83282)를 참조하십시오.


IIS 6 호환성 구성 요소가 설치되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-08-13

IIS(인터넷 정보 서비스) 6 메타베이스 호환성 및 IIS 6 관리 콘솔 구성 요소가 설치되어 있지 않으므로 Microsoft Exchange Server 2007 설치 프로그램이 클라이언트 액세스 서버 역할, 사서함 서버 역할 또는 Exchange 2007 관리 도구를 Windows Server 2008 기반 대상 컴퓨터에 계속 설치할 수 없습니다.

Exchange 2007을 설치하려면 Exchange 2007 클라이언트 액세스 서버 역할, 사서함 서버 역할 또는 Exchange 2007 관리 도구를 설치 중인 Windows Server 2008 기반 컴퓨터에 IIS 6 메타베이스 호환성 및 IIS 6 관리 콘솔 구성 요소가 설치되어 있어야 합니다.

이 문제를 해결하려면 IIS 6 메타베이스 호환성 구성 요소를 대상 컴퓨터에 설치한 다음 Microsoft Exchange 설치 프로그램을 다시 실행합니다.

Windows Server 2008 서버 관리자를 사용하여 IIS 6.0 관리 호환성 구성 요소를 설치하려면 다음을 수행합니다.

  1. 시작을 클릭하고 관리 도구를 클릭한 다음 서버 관리자를 클릭합니다.

  2. 왼쪽 탐색 창에서 역할을 확장한 다음 웹 서버(IIS)를 마우스 오른쪽 단추로 클릭하고 역할 서비스 추가를 선택합니다.

  3. 역할 서비스 선택 창에서 아래로 스크롤하여 IIS 6 관리 호환성을 선택합니다.

  4. IIS 6 메타베이스 호환성 및 IIS 6 관리 콘솔의 확인란을 선택합니다.

  5. 역할 서비스 선택 창에서 다음을 클릭한 다음 선택 항목 설치 확인 창에서 설치를 클릭합니다.

  6. 닫기를 클릭하여 역할 서비스 추가 마법사를 끝냅니다.


IIS 7 구성 요소가 설치되어 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-08-09

필요한 IIS(Internet Information Server) 7 구성 요소가 설치되어 있지 않으므로 Microsoft Exchange Server 2007 설치 프로그램이 클라이언트 액세스 서버 역할을 Microsoft Windows Server 2008 기반 시스템에 계속 설치할 수 없습니다.

클라이언트 액세스 서버 역할을 설치하려면 클라이언트 액세스 서버 역할을 설치 중인 Windows Server 2008 기반 컴퓨터에 다음 IIS 7 구성 요소가 설치되어 있어야 합니다.

필요한 IIS 7 구성 요소

동적 콘텐츠 압축

정적 콘텐츠 압축

기본 인증

Windows 인증

이 문제를 해결하려면 필요한 IIS 7 구성 요소를 대상 컴퓨터에 설치한 다음 Microsoft Exchange 설치 프로그램을 다시 실행합니다.

Windows Server 2008 서버 관리자를 사용하여 IIS 7 구성 요소를 설치하려면 다음을 수행합니다.

  1. 시작을 클릭하고 관리 도구를 클릭한 다음 서버 관리자를 클릭합니다.

  2. 왼쪽 탐색 창에서 역할을 확장한 다음 웹 서버(IIS)를 마우스 오른쪽 단추로 클릭하고 역할 서비스 추가를 선택합니다.

  3. 역할 서비스 선택 창에서 IIS가 있는 아래로 스크롤합니다.

  4. 보안 아래에서 기본 인증 및 Windows 인증 확인란을 선택합니다.

  5. 성능 아래에서 정적 압축 및 동적 압축 확인란을 선택합니다.

  6. 역할 서비스 선택 창에서 다음을 클릭한 다음 선택 항목 설치 확인 창에서 설치를 클릭합니다.

  7. 닫기를 클릭하여 역할 서비스 추가 마법사를 끝냅니다.


IIS 공용 파일 필요
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-08-14

Microsoft Internet Information Services(IIS) 공용 파일이 이 서버에 설치되어 있지 않으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange Management Shell을 사용하려면 원격 IIS 메타베이스에 액세스해야 할 수도 있습니다. 메타베이스는 대부분의 IIS 구성 값이 저장되는 저장소입니다. 원격으로 메타베이스에 액세스하려면 로컬 컴퓨터에 적절한 COM+ DLL이 설치되어 있어야 합니다.

이 문제를 해결하려면 이 서버에 IIS 공용 파일을 설치한 다음 Exchange 2007 설치 프로그램을 다시 실행하십시오.

Windows Server™ 2003에서 제어판을 사용하여 IIS 공용 파일을 설치하려면 다음을 수행합니다.

  1. 시작 메뉴에서 제어판을 클릭합니다.

  2. 프로그램 추가/제거를 두 번 클릭합니다.

  3. Windows 구성 요소 추가/제거를 클릭합니다.

  4. 구성 요소 목록에서 응용 프로그램 서버 확인란을 클릭합니다.

  5. 자세히를 클릭합니다.

  6. 응용 프로그램 서버의 하위 구성 요소 목록에서 인터넷 정보 서비스(IIS) 확인란을 클릭합니다.

  7. 자세히를 클릭합니다.

  8. 공용 파일 확인란을 클릭합니다.

  9. Windows 구성 요소 마법사로 돌아갈 때까지 확인을 클릭합니다.

  10. 다음을 클릭하고 Windows 구성 요소 마법사를 완료합니다.
Windows® XP에서 제어판을 사용하여 IIS 공용 파일을 설치하려면 다음을 수행합니다.

  1. 시작 메뉴에서 제어판을 클릭합니다.

  2. 프로그램 추가/제거를 두 번 클릭합니다.

  3. Windows 구성 요소 추가/제거를 클릭합니다.

  4. 구성 요소 목록에서 인터넷 정보 서비스(IIS) 확인란을 클릭합니다.

  5. 자세히를 클릭합니다.

  6. 공용 파일 확인란을 클릭합니다.

  7. Windows 구성 요소 마법사로 돌아갈 때까지 확인을 클릭합니다.

  8. 다음을 클릭하고 Windows 구성 요소 마법사를 완료합니다.


IIS가 32비트 호환 모드에 있음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-08-11

이 64비트 컴퓨터에서 Microsoft Internet Information Service(IIS)가 32비트 모드로 실행되고 있으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 사용하려면 IIS가 64비트 컴퓨터에서 실행될 때 전체 64비트 모드여야 합니다.

이 문제를 해결하려면 IIS를 64비트 모드로 전환한 다음 Microsoft Exchange 설치 프로그램을 다시 실행하십시오.

IIS를 64비트 모드로 전환하려면 다음을 수행합니다.

  1. 명령 프롬프트를 엽니다.

  2. 다음을 입력합니다.

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. Enter 키를 누릅니다.


Active Directory를 준비할 수 있는 사용 권한이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-21

도메인을 준비할 수 없으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange를 설치하려면 Exchange Server 2007용으로 Active Directory 디렉터리 서비스를 수정하여 Active Directory의 도메인을 준비해야 합니다.

setup /PrepareAD 명령을 실행하는 데 사용하는 계정이 Enterprise Admins 그룹에 속해 있지만 해당 계정에 이 명령을 실행할 수 있는 사용 권한이 없습니다. 계정이 만료되었을 수 있습니다.

이 문제를 해결하려면 로그온한 사용자 계정이 유효하며 Enterprise Admins 그룹에 속해 있는지 확인하거나, 해당 사용 권한이 있는 계정으로 로그온한 후에 setup /PrepareAD를 다시 실행합니다.

PrepareAD 프로세스를 수행하는 방법에 대한 자세한 내용은 "Active Directory 및 도메인을 준비하는 방법"(http://go.microsoft.com/fwlink/?LinkId=78453)을 참조하십시오.

Microsoft Exchange를 실행하는 데 필요한 Active Directory 권한에 대한 자세한 내용은 "Exchange Server에서의 Active Directory 사용 권한 작업"(http://go.microsoft.com/fwlink/?LinkId=47592)을 참조하십시오.


모든 서버 역할을 제거할 수 있는 사용 권한이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

모든 서버 역할을 제거하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 모든 서버 역할을 제거할 때 로그온되어 있는 사용자가 Exchange Organization Administrators 그룹 또는 Enterprise Admins 그룹의 구성원이어야 합니다.

이 문제를 해결하려면 로그온한 사용자에게 Exchange Organization Administrator 권한을 부여하거나 해당 사용자를 Enterprise Admins 그룹에 등록합니다. 또는 해당 사용 권한이 있는 계정으로 로그온하여 Exchange 2007 설치 프로그램을 다시 실행합니다.

Microsoft Exchange를 실행하는 데 필요한 Active Directory 사용 권한에 대한 자세한 내용은 "Working with Active Directory Permissions in Exchange Server"(http://go.microsoft.com/fwlink/?LinkId=47592)를 참조하십시오.


/PrepareDomain을 실행할 수 있는 사용 권한이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

/PrepareDomain 프로세스를 실행하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다. 로그온한 사용자에게 /PrepareDomain 프로세스를 수행할 수 있는 사용 권한이 없습니다.

Exchange 2007을 설치하려면 /PrepareDomain 프로세스를 실행할 때 로그온되어 있는 사용자가 준비할 도메인의 Domain Admins 그룹 구성원이어야 하며, Exchange Organization Administrators 그룹 또는 Enterprise Admins 그룹의 구성원이어야 합니다.

이 문제를 해결하려면 로그온한 사용자에게 준비 중인 도메인의 Domain Admins 그룹 권한을 부여하고 해당 사용자를 Exchange Organization Administrators 또는 Enterprise Admins 그룹에 등록합니다. 또는 해당 사용 권한이 있는 계정으로 로그온하여 Exchange 2007 설치 프로그램을 다시 실행합니다.

Microsoft Exchange를 실행하는 데 필요한 Active Directory 권한에 대한 자세한 내용은 "Exchange Server에서의 Active Directory 사용 권한 작업"(http://go.microsoft.com/fwlink/?LinkId=47592)을 참조하십시오.


Domain Name System 도메인 이름이 잘못되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-04-13

로컬 컴퓨터에 설정되어 있는 DNS(Domain Name System) 도메인 이름이 잘못되었으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 DNS 도메인 이름에 'A-Z', 'a-z','0-9', '.' 및 '-' 이외의 문자를 사용해서는 안 됩니다.

이 문제를 해결하려면 로컬 컴퓨터의 컴퓨터 이름 또는 실제 DNS 도메인 이름에 잘못된 문자가 있는지 확인합니다.

  • 로컬 컴퓨터의 컴퓨터 이름에 잘못된 문자가 있는 경우 'A-Z', 'a-z','0-9', '.' 및 '-'에 속하는 유효한 문자만을 사용하여 로컬 컴퓨터의 도메인에 대해 DNS 도메인 이름을 다시 설정하고 컴퓨터를 다시 시작한 후에 Exchange 2007 설치 프로그램을 다시 실행합니다.

  • 조직의 DNS 도메인 이름에 잘못된 문자가 있는 경우에는 DNS 도메인의 이름을 바꾸거나 Exchange 2007을 새 도메인 트리에 설치하는 것이 좋습니다.

주의:
DNS 도메인 이름을 변경하는 작업은 전체 네트워크에 큰 영향을 줄 수 있습니다. 그러므로 DNS 도메인 이름을 변경하기 전에 네트워크 관리자와 상의하십시오.
로컬 컴퓨터의 DNS 도메인 이름을 확인하려면 다음을 수행합니다.

  1. 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다. 시스템 속성 대화 상자가 나타납니다.

  2. 컴퓨터 이름 탭을 클릭합니다.

  3. 변경을 클릭합니다. 컴퓨터 이름 변경 대화 상자가 나타납니다.

  4. 자세히를 클릭합니다. DNS 접미사 및 NetBIOS 컴퓨터 이름 대화 상자가 나타납니다.

  5. 'A-Z', 'a-z','0-9', '.' 및 '-'에 속하는 문자만 사용되었는지 확인합니다.

  6. 도메인 구성 자격이 변경되면 주 DNS 접미사 변경 확인란을 선택합니다.

  7. 확인을 클릭하여 변경 내용을 저장한 다음 확인을 클릭하여 컴퓨터 이름 변경 대화 상자를 닫습니다.

  8. 확인을 클릭하여 시스템 속성 대화 상자를 닫은 다음 컴퓨터를 다시 시작하여 변경 내용을 적용합니다.

DNS 이름에 대한 자세한 내용은 Microsoft 기술 자료 문서 909264, "Naming conventions in Active Directory for computers, domains, sites, and OUs"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264)를 참조하십시오.


설치 경로가 잘못되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

사서함 서버 또는 클러스터 사서함 서버 역할을 공유 클러스터 드라이브에 설치하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange를 설치하려면 공유 클러스터 리소스가 아닌 드라이브에 Exchange Server 역할을 설치해야 합니다.

이 문제를 해결하려면 공유 클러스터 드라이브로 지정되지 않은 경로에 사서함 서버 역할 또는 클러스터 사서함 서버를 설치합니다.

클러스터링 구성에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "고가용성"(http://go.microsoft.com/fwlink/?linkid=68190)을 참조하십시오.


CMS 대상 경로 형식이 잘못되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

클러스터된 사서함 서버 역할을 공유 클러스터 드라이브에 설치하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

전송된 /CMSDataPath: <PathToTheDatabase> 매개 변수가 잘못된 UNC(범용 명명 규칙) 형식으로 되어 있습니다. Exchange를 설치하려면 UNC 형식이 아니라 /CMSDataPath: s:\<PathToTheDatabase>와 같이 올바른 드라이브 문자를 사용하여 /CMSDataPath: <PathToTheDatabase> 매개 변수를 지정해야 합니다.

이 문제를 해결하려면 /CMSDataPath: <PathToTheDatabase> 매개 변수에 올바른 드라이브 문자를 사용합니다.

클러스터된 사서함 서버를 설치하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "활성 노드에 사서함 서버 역할을 설치하는 방법"(http://go.microsoft.com/fwlink/?LinkId=86624)을 참조하십시오.


설치된 MOUNTMGR.SYS 버전이 Exchange Server와 호환되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

설치된 Mountmgr.sys 버전이 Microsoft Exchange와 호환되지 않으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 클러스터 노드에 Microsoft 기술 자료 문서 898790에서 참조하는 업데이트가 설치되어 있어야 합니다.

클러스터 노드에 현재 설치되어 있는 Mountmgr.sys 버전으로 인해 볼륨 탑재 지점 오류가 발생할 수 있습니다. 이 문제는 Mountmgr.sys 드라이버의 문제로 인해 발생할 수 있습니다. 이는 볼륨이 도착하여 탑재 지점에 탑재될 때 발생할 수 있는 일시 중단 타이밍 문제입니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 898790(http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790)에서 참조하는 업데이트를 설치한 다음 Exchange 2007 설치 프로그램을 다시 실행하십시오.

이 문제에 대한 자세한 내용은 Microsoft 기술 자료 문서 898790, "Windows Server 2003 서비스 팩 1을 설치한 다음 서버 클러스터의 디스크 볼륨 탑재 지점이 일시적으로 사용할 수 없습니다"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790)를 참조하십시오.


설치된 TCPIP.SYS 버전이 Exchange 서버와 호환되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

설치된 Tcpip.sys 버전이 Microsoft Exchange와 호환되지 않기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 로컬 컴퓨터에 Microsoft 기술 자료 문서 898060에서 참조하는 업데이트가 설치되어 있어야 합니다.

이 컴퓨터에서는 현재 Windows Server™ 2003 서비스 팩 1의 Tcpip.sys 드라이버를 실행하고 있습니다. 이 드라이버로 인해 WAN에서 연결 문제가 발생할 수 있습니다.

이 문제를 해결하려면 Microsoft 기술 자료 문서 898060, "Windows Server x64 Edition에 대한 업데이트(KB898060)"(http://go.microsoft.com/fwlink/?linkid=59272)에서 참조하는 업데이트를 설치한 다음 Exchange 2007 설치 프로그램을 다시 실행하십시오.

이 경고에 대한 자세한 내용은 Microsoft 기술 자료 문서 898060, "보안 업데이트 MS05-019 또는 Windows Server 2003 서비스 팩 1을 설치한 후 클라이언트와 서버의 네트워크 연결이 실패할 수 있다"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=898060)를 참조하십시오.


Large Exchange 조직 모델 검색됨
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-08-10

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 Exchange Server 조직의 라우팅 그룹 수를 확인합니다. 또한 Exchange Server Analyzer는 Active Directory를 쿼리하여 Microsoft Exchange 2000 Server 또는 Microsoft Exchange Server 2003을 실행하는 Exchange Server가 포함된 Active Directory 사이트 수를 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 Exchange 조직을 Large Exchange 조직으로 분류합니다.

  • Exchange 조직에 있는 라우팅 그룹 수가 5개보다 많습니다.

  • Exchange 2000 또는 Exchange 2003을 실행하는 서버가 5개보다 많은 Active Directory 사이트에 설치되어 있습니다.

Large Exchange 조직을 Exchange 2007로 전환하려면 다음을 수행합니다.

  1. Microsoft Exchange Server 2007 온라인 제품 설명서(http://go.microsoft.com/fwlink/?LinkId=69434)를 봅니다.

  2. "대형 Exchange 조직을 위한 계획" 항목(http://go.microsoft.com/fwlink/?LinkId=70504)을 검토합니다.


로컬 컴퓨터가 자식 도메인의 도메인 컨트롤러입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-12-29

로컬 컴퓨터가 자식 도메인의 도메인 컨트롤러이기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

도메인 컨트롤러가 글로벌 카탈로그 서버가 아니면 Exchange 2007이 자식 도메인의 도메인 컨트롤러에 설치되지 않습니다.

이 문제를 해결하려면 도메인 컨트롤러 수준을 글로벌 카탈로그 서버로 올리거나 Exchange 2007을 비도메인 컨트롤러, 즉 자식 도메인의 구성원 서버에 설치한 다음 Microsoft Exchange 설치 프로그램을 다시 실행하십시오.

Exchange 서버를 글로벌 카탈로그 서버로 만들어 이 경고를 해결하려면 다음을 수행합니다.

  1. 도메인 컨트롤러에서 시작을 클릭하고 프로그램을 가리킨 다음 관리 도구를 클릭하고 Active Directory 사이트 및 서비스를 클릭합니다.

  2. 콘솔 트리에서 사이트를 두 번 클릭하고 사이트 이름을 두 번 클릭한 다음 서버를 두 번 클릭합니다.

  3. 대상 도메인 컨트롤러를 두 번 클릭합니다.

  4. 결과 창에서 NTDS 설정을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  5. 일반 탭에서 글로벌 카탈로그 확인란을 클릭하여 선택합니다.

  6. 도메인 컨트롤러를 다시 시작합니다.


로컬 컴퓨터가 이미 Exchange 서버를 실행 중입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-01-15

로컬 컴퓨터에 이전 Microsoft Exchange 구성 요소가 설치되어 있기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 로컬 컴퓨터에 기존 Microsoft Exchange 구성 요소가 설치되어 있지 않아야 합니다.

이 문제를 해결하려면 Microsoft Exchange 2000 Server 또는 Microsoft Exchange Server 2003 구성 요소를 제거한 다음 Microsoft Exchange 설치 프로그램을 다시 실행하십시오.

Microsoft Exchange 구성 요소를 제거하려면 다음을 수행합니다.

  1. 시작을 클릭하고 설정을 가리킨 다음 제어판을 클릭합니다.

  2. 프로그램 추가/제거를 두 번 클릭합니다.

  3. 현재 설치된 프로그램 목록에서 Microsoft Exchange를 클릭한 다음 변경/제거를 클릭합니다.

  4. Microsoft Exchange 설치 마법사에서 다음을 클릭합니다.

  5. 구성 요소 선택 페이지의 작업 목록에서 설치된 각 구성 요소 옆의 아래쪽 화살표를 클릭한 다음 제거를 클릭합니다.

    참고:
    작업 목록에서 설치된 구성 요소에는 확인 표시가 있습니다. 제거를 클릭하면 확인 표시가 제거라는 단어로 바뀝니다.

  6. 다음을 두 번 클릭합니다.

  7. 마침을 클릭합니다.


로컬 컴퓨터에서 Windows Server 2003 서비스 팩 1 이상을 실행하고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-05

로컬 컴퓨터에서 Microsoft Windows Server™ 2003 SP1(서비스 팩 1) 이상을 실행하고 있지 않으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 Microsoft Exchange를 실행할 컴퓨터에서 Windows Server 2003 SP1 이상 버전을 실행해야 합니다.

이 문제를 해결하려면 다음을 수행합니다.

  • Windows Server 2003 SP1 이상 버전을 실행하고 있는 컴퓨터에서 Exchange 2007 설치 프로그램을 실행합니다.

  • Exchange 2007 설치 프로그램을 실행할 컴퓨터를 Windows Server 2003 SP1 이상 버전으로 업그레이드합니다.

Windows Server 2003으로 업그레이드하는 방법은 Microsoft 기술 자료 문서 810613, "Windows Server 2003 또는 Windows Small Business Server 2003으로 업그레이드할 수 있도록 지원되는 경로"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613)를 참조하십시오.

Windows Server 2003용 최신 서비스 팩을 얻으려면 Windows Server TechCenter(http://go.microsoft.com/fwlink/?LinkId=45315)를 참조하십시오.


로컬 컴퓨터가 그룹 구성원 확장을 담당합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

Microsoft® Exchange Server 2007 설치 프로그램이 그룹 구성원의 확장을 담당하는 Hub 전송 역할을 제거하지 못했기 때문에 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 Hub 전송을 제거하기 전에 현재 브리지헤드 서버에서 메일 그룹 확장을 제거해야 합니다.

메일 그룹 확장을 사용하면 확인할 메일 그룹에 속한 각각의 받는 사람을 식별하거나 확장할 추가 메일 그룹을 식별할 수 있습니다. 확장된 메일 그룹은 필요한 DSN(배달 상태 알림)의 경로를 반환할 수 있습니다. DSN은 Microsoft Exchange 관리자나 전자 메일을 보내는 사람에게 특정 전자 메일 메시지의 상태를 알려줍니다. 또한 메일 그룹 확장을 사용하면 부재 중 메시지 또는 자동으로 생성된 답장을 원본 메시지를 보낸 사람에게 보내야 하는지 여부를 확인할 수 있습니다.

이 문제를 해결하려면 메일 그룹 확장을 다른 서버로 이동하고 Microsoft Exchange 설치 프로그램을 다시 실행하십시오.

메일 그룹 또는 동적 메일 그룹의 확장 서버를 변경하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. 콘솔 트리에서 받는 사람 구성을 확장합니다.

  3. 콘솔 트리에서 메일 그룹을 클릭합니다.

  4. 현재 브리지헤드 서버를 확장 서버로 사용하는 동적 메일 그룹 및 모든 메일 그룹을 볼 수 있는 필터를 만듭니다.

    1. 작업 창에서 필터 만들기를 클릭합니다.

    2. 속성 드롭다운 목록에서 확장 서버를 클릭합니다.

    3. 연산자 드롭다운 목록에서 같음을 클릭합니다.

    4. 값 상자에서 찾아보기 단추를 클릭하여 현재 확장 서버로 사용되고 있는 브리지헤드 서버를 선택합니다.
참고:
다음 단계는 선택 사항입니다.
  1. 식 추가를 클릭하여 추가 필터 조건을 지정합니다. 모든 필터 조건에 맞는 메시지만 표시됩니다.

  2. 필터 적용을 클릭합니다. 필터 조건에 맞는 결과가 표시됩니다.

  1. 결과 창에서 확장 서버를 변경하려는 메일 그룹을 클릭한 다음, 작업 창에서 속성을 클릭합니다.

  2. 속성에서 고급 탭을 클릭합니다.

  3. 확장 서버 드롭다운 목록에서 특정 서버를 선택하거나 조직의 모든 서버를 선택합니다.

  4. 브리지헤드 서버를 확장 서버로 사용하고 있는 동적 메일 그룹 또는 모든 메일 그룹에 대해 5단계부터 7단계까지 반복합니다.


로컬 컴퓨터가 오프라인 주소록 생성을 담당합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

Microsoft® Exchange Server 2007 설치 프로그램이 오프라인 주소록의 생성을 담당하는 사서함 역할을 제거하지 못했기 때문에 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 사서함 역할이 Exchange 조직의 마지막 역할인 경우를 제외하고 사서함 역할을 제거하기 전에 현재 사서함 서버에서 오프라인 주소록 생성을 제거해야 합니다.

이 문제를 해결하려면 오프라인 주소록 생성을 다른 서버로 이동하고 Microsoft Exchange 설치 프로그램을 다시 실행하십시오.

Exchange System Manager를 사용하여 오프라인 주소록 생성을 이동하려면 다음을 수행합니다.

  1. Exchange System Manager를 엽니다.

  2. 받는 사람에서 오프라인 주소 목록을 클릭합니다.

  3. 오른쪽 창에서 기본 오프라인 주소 목록을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.

    참고:
    이 메시지를 생성하는 다른 모든 오프라인 주소 목록에 같은 절차를 사용합니다.

  4. 일반 탭의 오프라인 주소 목록 서버에서 찾아보기를 클릭한 다음 사용할 Exchange 서버를 클릭합니다.
Exchange 관리 콘솔을 사용하여 오프라인 주소록 생성을 이동하려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. Microsoft Exchange와 조직 구성을 차례로 확장한 다음 사서함을 선택합니다.

  3. 결과 창에서 오프라인 주소 목록 탭을 클릭합니다.

  4. 오프라인 주소 목록 탭에서 이동할 오프라인 주소록을 선택합니다. 작업 창에서 이동을 클릭합니다.

  5. 오프라인 주소 목록 이동 마법사가 나타나면 찾아보기 단추를 사용하여 오프라인 주소록 생성을 호스팅할 새 서버를 선택한 다음 이동을 클릭합니다.

  6. 마법사를 닫으려면 마침을 클릭합니다.
Exchange 관리 셸을 사용하여 오프라인 주소록 생성을 이동하려면 다음을 수행합니다.

  • 다음 명령을 실행합니다.

    코드 복사
    Move-OfflineAddressBook -Identity <OfflineAddressBookIdParameter> -Server <ServerIdParameter> [-DomainController <String>]


로컬 컴퓨터가 Edge 전송 역할을 실행하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

Microsoft® Exchange Server 2007 설치 프로그램이 Exchange 2007 역할을 설치하려고 시도하는 도중에 이 서버에 이미 설치되어 있는 게이트웨이 서버 역할을 발견했기 때문에 설치를 계속할 수 없습니다.

Exchange 2007 설치 프로그램은 Microsoft Exchange 게이트웨어 서버 역할이 설치되어 있는 서버에 다른 서버 역할을 설치할 수 없습니다.

Microsoft Exchange 게이트 서버 역할은 조직의 주변 네트워크에 배포되며, 모든 인터넷 메일 흐름을 처리하고, 신뢰할 수 있는 Microsoft Exchange 조직 간에 보내진 메시지의 암호화 및 암호 해독 기능을 제공할 뿐 아니라 스팸으로부터 보호합니다.

이 문제를 해결하려면 게이트웨이 서버 역할이 설치되지 않은 컴퓨터에 다른 Microsoft Exchange 2007 역할을 설치하십시오.


로컬 컴퓨터가 Windows Server 2003 Web Edition을 실행하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

로컬 컴퓨터가 Microsoft Windows Server ™ 2003 Web Edition을 실행하고 있기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 지원되는 운영 체제에서 실행되는 컴퓨터에 Microsoft Exchange를 설치해야 합니다.

이 문제를 해결하려면 Microsoft Exchange를 Web Edition이 아닌 Windows Server 2003 서비스 팩 1(SP1) 이상에 설치하십시오.


로컬 도메인을 업데이트해야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

로그온한 사용자의 계정에 도메인 준비에 필요한 사용 권한이 없으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange를 설치하려면 Setup /PrepareDomain을 실행할 때 로그온되어 있는 사용자가 Domain Administrators 및 Exchange Organization Administrators 그룹이나 Enterprise Admins 그룹의 구성원이어야 합니다.

이 문제를 해결하려면 로그온한 사용자에게 Domain Admins 및 Exchange Organization Administrator 권한을 부여하거나 해당 사용자를 Enterprise Admins 그룹에 등록합니다. 또는 해당 사용 권한이 있는 계정으로 로그온하여 Exchange 2007 설치 프로그램을 다시 실행합니다.

Microsoft Exchange를 실행하는 데 필요한 Active Directory 권한에 대한 자세한 내용은 "Exchange Server에서의 Active Directory 사용 권한 작업"(http://go.microsoft.com/fwlink/?LinkId=47592)을 참조하십시오.


로컬 메타베이스에 액세스할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

Microsoft® Exchange Server 2007 설치 프로그램이 로컬 메타베이스의 데이터를 읽을 수 없기 때문에 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 사서함 서버 또는 클라이언트 액세스 역할 설치를 Microsoft 인터넷 정보 서비스(IIS) 메타베이스에서 읽을 수 있어야 합니다.

IIS 메타베이스에는 HTTP용 프로토콜 설정, 사서함과 모바일 장치 액세스를 위한 가상 디렉터리 및 HTTP 보안 설정과 같이 Microsoft Exchange에 영향을 주는 정보가 포함됩니다.

이 문제를 해결하려면 IIS가 올바르게 설치되어 있는지 확인한 다음 Microsoft Exchange 설치 프로그램을 다시 실행하십시오.

IIS가 올바르게 설치되어 있는지 확인하려면 다음 리소스를 참조하십시오.

  • Microsoft 기술 자료 문서 843093, "Exchange 2000 Server 또는 Exchange Server 2003을 실행 중인 Windows 2000 Server 기반 컴퓨터에서 IIS 메타베이스 손상 문제를 해결하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=843093)

  • Microsoft 기술 자료 문서 240225, "메타베이스를 수정하는 데 사용되는 Adsutil 및 MetaEdit 유틸리티에 대한 설명"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225)

  • Microsoft 기술 자료 문서 317678, "HOW TO: Exchange 2000 Server에서 인터넷 정보 서비스(IIS) 다시 시작"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678)

이러한 리소스의 지침을 따라도 문제가 해결되지 않으면 IIS를 제거한 다음 다시 설치해야 할 수 있습니다.

제어판에서 Windows 구성 요소 추가/제거를 사용하여 IIS를 제거하려면 다음을 수행합니다.

  1. 시작 메뉴에서 제어판을 클릭합니다.

  2. 프로그램 추가/제거를 두 번 클릭합니다.

  3. Windows 구성 요소 추가/제거를 클릭합니다.

  4. 구성 요소 목록에서 응용 프로그램 서버 확인란을 클릭합니다.

  5. 자세히를 클릭합니다.

  6. 인터넷 정보 서비스 관리자를 클릭합니다.

  7. 다음을 클릭합니다.

  8. IIS가 제거되었으면 마침을 클릭합니다.
제어판을 사용하여 IIS를 설치하려면 다음을 수행합니다.

  1. 시작 메뉴에서 제어판을 클릭합니다.

  2. 프로그램 추가/제거를 두 번 클릭합니다.

  3. Windows 구성 요소 추가/제거를 클릭합니다.

  4. 구성 요소 목록에서 응용 프로그램 서버 확인란을 클릭합니다.

  5. 자세히를 클릭합니다.

  6. 인터넷 정보 서비스 관리자 확인란을 클릭합니다.

  7. Windows 구성 요소 마법사로 돌아갈 때까지 확인을 클릭합니다.

  8. 다음을 클릭하고 Windows 구성 요소 마법사를 완료합니다.


로그온한 사용자가 로컬 관리자 그룹 구성원이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

로그온한 사용자가 로컬 컴퓨터의 관리자 그룹 구성원이 아니므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 Microsoft Exchange를 설치하기 위해 로그온한 사용자에게 로컬 컴퓨터에 대한 모든 권한이 있어야 합니다.

이 문제를 해결하려면 로컬 관리자 권한이 있는 계정을 사용하여 컴퓨터에 로그온한 다음 Microsoft Exchange 설치 프로그램을 다시 실행합니다.


로그온한 사용자가 Schema Admins 그룹 구성원이 아닙니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-09-06

스키마 업데이트 프로세스에 Active Directory® 디렉터리 서비스의 스키마 관리 및 엔터프라이즈 관리 자격 증명이 없기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 Microsoft Exchange를 설치하기 위해 로그온한 사용자에게 Active Directory 포리스트에 대한 스키마 관리및 엔터프라이즈 관리 자격 증명이 있어야 합니다.

설치 과정의 일부로서 Microsoft Exchange 설치 프로그램은 Active Directory 스키마를 확장하여 Exchange 2007 특정 클래스 및 특성을 추가합니다.

로그온한 사용자에게 스키마 관리자 및 엔터프라이즈 관리자 권한이 없을 경우 스키마 업데이트 프로세스가 실패합니다.

이 문제를 해결하려면 로그온한 사용자를 Schema Admins 및 Enterprise Admins 그룹에 추가하고 로그오프한 다음 다시 로그온하거나, 로그오프한 다음 Active Directory 포리스트에 대한 스키마 관리 및 엔터프라이즈 관리 자격 증명이 있는 계정을 사용하여 로그온합니다.


활성 노드가 너무 많습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-23

새 활성 클러스터 사서함 서버 역할을 만들지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange Server 2007에는 오류 복구를 지원하도록 클러스터에서 최소한 하나의 노드를 수동 노드로 지정해야 합니다.

이 문제를 해결하려면 먼저 환경에 클러스터된 수동 사서함 서버 역할을 하나 더 설치한 후에 설치 프로그램을 다시 실행합니다.

활성 노드 및 수동 노드 설치에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "고가용성"(http://go.microsoft.com/fwlink/?LinkId=68190)을 참조하십시오.


사서함 데이터베이스 드라이브 사양이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-05-15

Microsoft® Exchange Server 2007 Disaster Recovery 설치 프로그램에서 이 서버의 이전 설치에 사용된 사서함 데이터베이스 드라이브 사양에 액세스할 수 없기 때문에 Disaster Recovery 설치를 계속할 수 없습니다.

Microsoft Exchange Disaster Recovery를 설치하려면 이전에 이 서버에 사용된 사서함 데이터베이스 드라이브 사양과 동일한 사양을 복원하는 동안 사용할 수 있어야 합니다.

이 상황을 해결하려면 드라이브를 원래 논리 드라이브 구성과 일치되게 구성하고 Microsoft Exchange Disaster Recovery 설치 프로그램을 다시 실행하십시오.

드라이브 문자 할당 또는 변경

  1. 컴퓨터 관리(로컬)를 엽니다.

  2. 콘솔 트리에서 컴퓨터 관리(로컬)를 클릭하고 저장소를 클릭한 다음 디스크 관리를 클릭합니다.

  3. 파티션, 논리 드라이브 또는 볼륨을 마우스 오른쪽 단추로 클릭한 다음 드라이브 문자 및 경로 변경을 클릭합니다.

  4. 다음 절차 중 하나를 수행합니다.

    • 드라이브 문자를 할당하려면 추가를 클릭하고 사용할 드라이브 문자를 클릭한 다음 확인을 클릭합니다.

    • 드라이브 문자를 수정하려면 드라이브 문자를 클릭하고, 변경을 클릭하고 사용할 드라이브 문자를 클릭한 다음 확인을 클릭합니다.

드라이브 문자를 할당하는 방법에 대한 자세한 내용은 "드라이브 문자 할당, 변경 또는 제거"(http://go.microsoft.com/fwlink/?LinkId=66764)를 참조하십시오.


메시지가 현재 하나 이상의 큐에 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-05

Microsoft® Exchange Server 2007 설치 프로그램이 전송 역할을 제거하려고 시도하면 전송 큐에서 데이터 손실이 발생할 수 있기 때문에 이 경고를 표시합니다.

Exchange 2007 설치 프로그램은 전송 큐 관리와 관련된 역할을 제거하기 전에 해당 큐가 비어 있는지 확인합니다.

아직 전송 큐에 있는 메시지를 배달하기 전에 전송 역할을 제거하면 해당 메시지는 무기한으로 보관될 수 있습니다.

이 문제를 해결하려면 설치를 계속하기 전에 참조된 큐를 검사하여 해당 큐에 메시지가 없는지 확인하십시오.

큐의 내용을 보려면 다음을 수행합니다.

  1. Exchange 관리 콘솔을 엽니다.

  2. 콘솔 트리에서 도구 상자를 클릭합니다.

  3. 결과 창에서 Exchange 큐 뷰어를 클릭합니다.

  4. 작업 창에서 도구 열기를 클릭합니다.

  5. 큐 뷰어에서 큐 탭을 클릭합니다. 연결되어 있는 서버의 모든 큐 목록이 표시됩니다.

  6. 원하는 큐를 마우스 오른쪽 단추로 클릭하고 속성을 선택하여 큐 속성을 확인합니다.
큐에 있는 메시지를 보려면 다음을 수행합니다.

  1. 1단계부터 4단계까지 수행합니다.

  2. 큐 뷰어에서 메시지 탭을 클릭합니다. 연결되어 있는 서버의 모든 메시지 목록이 표시됩니다. 단일 큐 보기로 조정하려면 큐 탭을 클릭하고 큐 이름을 두 번 클릭한 다음 표시되는 서버\큐 탭을 클릭합니다.

  3. 메시지에 대한 자세한 정보를 보려면 메시지를 선택한 다음 작업 창에서 속성을 클릭합니다.


Microsoft .NET Framework 업데이트 필요
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-02-26

로컬 컴퓨터의 소프트웨어를 업데이트해야 하므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 여기에서 설명하는 적절한 Microsoft .NET Framework 업데이트를 로컬 컴퓨터에 설치해야 합니다.

이 문제를 해결하려면 Exchange 2007 설치 프로그램을 끝내고 다음 URL에서 적절한 업데이트(32비트 또는 64비트)를 다운로드하여 설치한 다음 Exchange 2007 설치 프로그램을 다시 실행합니다.

참고:
아래 링크를 클릭하면 파일을 바로 다운로드할 수 있습니다.
  • 64비트 다운로드, http://go.microsoft.com/fwlink/?linkid=74465

  • 32비트 다운로드, http://go.microsoft.com/fwlink/?linkid=74469


Microsoft Core XML Services(MSXML) 6.0 필요
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-08-21

Microsoft Core XML Services(MSXML) 6.0이 이 서버에 설치되어 있지 않으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

모든 통합 메시징 서버 역할 설치의 경우 Exchange 2007을 설치하려면 Microsoft 음성 서비스를 지원하도록 컴퓨터에 MSXML 6.0이 설치되어 있어야 합니다.

이 문제를 해결하려면 http://go.microsoft.com/fwlink/?LinkId=70796에서 MSXML 6.0 소프트웨어를 설치한 다음 Exchange 2007 설치 프로그램을 다시 실행하십시오.


MNSFileShare 경로가 잘못되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

MNSFileShare 경로가 잘못되었으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

MNSFileShare 값은 \\server\sharename과 같은 클러스터의 외부에 있는 파일 공유의 UNC(범용 명명 규칙) 경로를 포함하는 문자열 값으로 설정해야 합니다.

이 문제를 해결하려면 MNSFileShare 속성에 대해 올바른 UNC 경로가 포함된 값을 지정합니다.

MNSFileShare 속성을 구성하는 방법에 대한 자세한 내용은 "파일 공유 감시를 구성하는 방법"(http://go.microsoft.com/fwlink/?LinkId=78278)을 참조하십시오.


MSDAPS.DLL 업데이트가 필요함
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-12-05

로컬 컴퓨터의 소프트웨어를 업데이트해야 하므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 아래의 링크 정보를 참조하여 MSDAPS.DLL 업데이트를 로컬 컴퓨터에 설치해야 합니다.

이 문제를 해결하려면 아래 링크된 업데이트를 다운로드하여 설치한 다음 Exchange 2007 설치 프로그램을 다시 실행하십시오.

  • http://go.microsoft.com/fwlink/?linkid=74467


Network News Transport Service가 현재 설치되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-01-22

이 컴퓨터에 Microsoft Windows® Server™ 2003 NNTP(Network News Transport Protocol) 서비스가 설치되어 있으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange를 설치하려면 Exchange 2007에 사용할 서버에 NNTP 서비스를 설치하지 말아야 합니다.

이 문제를 해결하려면 NNTP 서비스를 제거하고 Microsoft Exchange 설치 프로그램을 다시 실행하십시오.

제어판의 Windows 구성 요소 추가/제거를 사용하여 NNTP서비스를 제거하려면 다음을 수행합니다.

  1. 시작 메뉴에서 제어판을 클릭합니다.

  2. 프로그램 추가/제거를 두 번 클릭합니다.

  3. Windows 구성 요소 추가/제거를 클릭합니다.

  4. 구성 요소 목록에서 응용 프로그램 서버 확인란을 선택한 다음 자세히를 클릭합니다.

  5. 인터넷 정보 서비스 관리자를 선택한 다음 자세히를 클릭합니다.

  6. NNTP 서비스를 선택한 다음 클릭하여 확인란의 선택을 취소합니다.

  7. 확인을 두 번 클릭하여 구성 요소 목록으로 돌아간 후 다음을 클릭합니다.

  8. NNTP 서비스가 제거되었으면 마침을 클릭합니다.


클라이언트 액세스 서버 역할이 없음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-02-16

Microsoft Exchange Analyzer Tool은 Exchange Server 2007 특정 관리 그룹 식별자인 FYDIBOHF23SPDLT를 포함하는 Exchange 조직의 msExchAdminGroupContainer 클래스 개체 값을 Active Directory 디렉터리 서비스에서 쿼리합니다.

Exchange Analyzer는 Exchange 조직에 Exchange Server 2007 관리 그룹이 있는 경우 사이트에 설치된 사서함 서버 역할이 있는지 여부를 확인할 때 각 msExchExchangeServer 개체의 msExchCurrentServerRoles 특성 값을 조직의 모든 Active Directory 사이트에서 쿼리합니다.

마지막으로 Exchange Analyzer는 사이트에 설치된 사서함 서버 역할이 있는 경우 클라이언트 액세스 서버 역할도 동일한 사이트에 설치되어 있는지 여부를 확인할 때 해당 사이트의 각 msExchExchangeServer 개체의 msExchCurrentServerRoles 특성을 쿼리합니다.

Exchange Analyzer는 Active Directory 사이트에 사서함 서버 역할은 설치되어 있으나 클라이언트 액세스 서버 역할은 설치되어 있지 않은 경우 경고를 표시합니다.

이 경고는 Active Directory 사이트에 사서함 서버 역할이 설치되어 있지만 하나 이상의 클라이언트 액세스 서버 역할을 설치하지 않으면 Microsoft Office Outlook Web Access 및 Exchange ActiveSync 모바일 장치 액세스 클라이언트가 해당 사서함 서버에 있는 메일에 액세스할 수 없음을 나타냅니다.

클라이언트 액세스 서버 역할은 Exchange 2007 서버에서 다양한 클라이언트로의 연결을 수락합니다. Microsoft Outlook Express 및 Eudora 등의 소프트웨어 클라이언트는 POP3 또는 IMAP4 연결을 사용하여 Exchange 서버와 통신합니다. 모바일 장치 등의 하드웨어 클라이언트는 ActiveSync, POP3 또는 IMAP4를 사용하여 Exchange 서버와 통신합니다.

Microsoft Outlook 이외의 클라이언트를 사용하여 받은 편지함에 액세스하는 경우 Exchange 조직에 클라이언트 액세스 서버 역할을 설치해야 합니다.

이 경고를 해결하려면 Microsoft Outlook을 사용하는 클라이언트 이외에 사서함에 액세스해야 하는 클라이언트가 있는 경우 사서함 서버 역할이 설치된 사이트에 클라이언트 액세스 서버 역할을 설치합니다.

자세한 정보

사이트에 클라이언트 액세스 서버 역할을 설치하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "Deploying Server Roles"(http://go.microsoft.com/fwlink/?LinkId=83282)를 참조하십시오.


비표준 주소 공간을 찾았습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-08-21

하나 이상의 받는 사람 정책에 비표준 주소 공간이 있으면 Microsoft® Exchange Server Analyzer Tool에서 이 경고를 표시합니다.

비표준, 즉 프록시 주소 공간은 Exchange Server 받는 사람 개체가 외부 메시징 시스템에서 인식되는 주소입니다.

이전 버전의 Exchange Server에서는 받는 사람 업데이트 서비스가 비표준 주소 공간을 지원했습니다.

Microsoft Exchange Server 2007에는 받는 사람 업데이트 서비스가 구현되어 있지 않습니다. 대신 Exchange 2007 관리 콘솔에서 프록시 주소를 생성합니다.

관리 콘솔에는 검색된 각 비표준 주소 공간에 대해 하나의 프록시 생성기 DLL이 로드되어 있어야 합니다.

중요:
관리 콘솔이 64비트 컴퓨터에서 실행되는 경우 64비트 버전의 프록시 생성기 DLL이 필요합니다.

이 경고를 해결하려면 외부 주소 공간을 지원하는 공급업체에 문의하여 Exchange 2007 호환 프록시 생성기 DLL을 구하십시오.


스키마 마스터 사이트/도메인에 없음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-08-10

설치 프로그램을 실행하는 컴퓨터가 FSMO(Flexible Single Master Operation)라고도 하는 도메인 스키마 마스터 역할이 할당된 서버와 같은 Active Directory® 디렉터리 서비스 사이트 또는 도메인에 있지 않으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 도메인 스키마 마스터 역할을 하는 도메인 컨트롤러가 Exchange 설치 프로그램을 실행하는 로컬 컴퓨터와 같은 사이트 및 도메인에 있어야 합니다.

도메인 스키마 마스터는 Active Directory 스키마에 대한 모든 업데이트와 수정을 제어합니다.

이 문제를 해결하려면 도메인 스키마 마스터와 같은 사이트 및 도메인에서 Exchange Server 2007 설치 프로그램을 실행합니다.

스키마 마스터 도구를 사용하여 역할을 식별할 수 있습니다. 하지만 스키마 도구를 MMC 스냅인으로 사용할 수 있으려면 Schmmgmt.dll DLL을 등록해야 합니다.

현재 스키마 마스터를 보려면 다음을 수행합니다.

  1. 명령 프롬프트에 regsvr32 schmmgmt.dll을 입력합니다.

    참고:
    다음 대화 상자가 표시되면 RegSvr32가 등록된 것입니다.

    schmmgmt.dll의 DllRegisterServer에 성공했습니다.

  2. 새 관리 콘솔을 열려면 시작, 실행을 차례로 클릭하고 mmc를 입력합니다.

  3. 콘솔 메뉴에서 스냅인 추가/제거를 클릭합니다.

  4. 추가를 클릭하여 독립 실행형 스냅인 추가 대화 상자를 엽니다.

  5. Active Directory 스키마를 선택하고 추가를 클릭합니다.

  6. 스냅인 추가/제거에 "Active Directory 스키마"가 표시됩니다. 닫기를 클릭한 다음 확인을 클릭하여 콘솔로 돌아갑니다.

  7. Active Directory 스키마를 선택합니다. 오른쪽에 클래스 및 특성 섹션이 표시됩니다.

  8. Active Directory 스키마를 마우스 오른쪽 단추로 클릭하고 작업 마스터를 클릭합니다.

  9. 현재 스키마 마스터가 표시됩니다.


도메인에 Windows Server 2003 SP1 도메인 컨트롤러가 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

setup /PrepareLegacyExchangePermissions 프로세스가 준비 중인 도메인에서 Microsoft Windows Server 2003 서비스 팩 1(SP1) 이상 버전을 실행 중인 도메인 컨트롤러를 찾지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

설치 프로그램은 setup /PrepareLegacyExchangePermissions를 실행할 각 도메인에서 Windows Server 2003 SP1 도메인 컨트롤러에 연결할 수 있어야 합니다. Setup /PrepareLegacyExchangePermissions는 Windows Server 2003 SP1 도메인 컨트롤러를 최소한 하나 이상 찾지 못하면 제대로 완료되지 않습니다.

setup /PrepareLegacyExchangePermissions 명령을 실행하면 레거시 받는 사람 업데이트 서비스가 제대로 작동하도록 할 수 있습니다. 새 Exchange 2007 스키마를 가져오려면 Exchange 2007이 Exchange Server 2003 또는 Exchange 2000 Server DomainPrep를 실행했던 각 도메인에서 새로운 사용 권한을 부여해야 합니다. setup /PrepareLegacyExchangePermissions 명령을 실행하면 이러한 새로운 사용 권한이 부여됩니다.

이 문제를 해결하려면 setup /PrepareLegacyExchangePermissions를 실행할 각 도메인에서 최소한 하나 이상의 도메인 컨트롤러를 Windows Server 2003 SP1 이상 버전으로 업그레이드한 후에 설치 프로그램을 다시 실행합니다.

레거시 Exchange 권한을 준비하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서에서 "레거시 Exchange 권한 준비"(http://go.microsoft.com/fwlink/?linkid=81776)를 참조하십시오.


OAB 서버가 삭제되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-21

클라이언트 액세스 서버 역할을 설치하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다. OAB(오프라인 주소록)를 호스트하도록 지정된 Exchange 사서함 서버가 삭제되었습니다.

Exchange 2007을 설치하기 위해 클라이언트 액세스 서버 역할을 계속 설치하려면 OAB 생성을 호스트하는 유효한 Exchange 사서함 서버가 있어야 합니다.

이 문제를 해결하려면 유효한 Exchange 사서함 서버를 OAB 생성 호스트로 지정한 후에 Exchange 2007 설치 프로그램을 다시 실행합니다.

Exchange 서버를 오프라인 주소록 생성용 호스트로 지정하는 방법에 대한 자세한 내용은 Exchange 2007 제품 설명서의 "오프라인 주소록을 만드는 방법"(http://go.microsoft.com/fwlink/?LinkId=86314)을 참조하십시오.


이전 데이터베이스 파일이 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

대상 설치 경로에 기존 Microsoft Exchange 데이터베이스 파일이 있기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 Microsoft Exchange 데이터베이스 파일의 대상 설치 경로가 비어 있어야 합니다.

이 문제를 해결하려면 대상 설치 경로에서 기존 파일을 모두 제거하고 설치 프로그램을 다시 실행하십시오.

대상 설치 경로에서 기존 Exchange Server 데이터베이스 파일을 삭제하려면 다음을 수행합니다.

  1. 내 컴퓨터 또는 Windows 탐색기에서 대상 설치 경로를 찾습니다.

    참고:
    기본적으로 데이터베이스 파일은 다음 위치에 있습니다.

    <systemDrive>:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group.

  2. 제거할 파일을 마우스 오른쪽 단추로 클릭하고 삭제를 선택합니다.

  3. 파일 삭제 확인 대화 상자에서 예를 클릭합니다.

  4. 대상 설치 경로에 있는 모든 파일에 대해 2단계와 3단계를 반복합니다.


이전 버전의 ADAM이 발견되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

Microsoft® Exchange Server 2007 설치 프로그램이 게이트웨이 서버 역할을 설치하려고 시도했는데 현재 서버에서 이전 버전의 ADAM(Active Directory® 응용 프로그램 모드)을 발견했기 때문에 이 경고를 표시합니다.

ADAM은 디렉터리 사용 응용 프로그램에 사용하도록 특별히 디자인된 LDAP(Lightweight Directory Access Protocol) 디렉터리 서비스입니다. ADAM은 응용 프로그램 관련 정보만 저장하고 복제하며 도메인 컨트롤러에 배포할 필요가 없고 Active Directory 서비스에 의존하지도 않습니다. ADAM에서는 네트워크 운영 체제 인증 또는 권한 부여를 제공하지 않습니다.

Exchange 2007에서 게이트웨이 서버는 ADAM을 사용하여 구성 정보를 저장합니다. ADAM을 Active Directory와 동기화하면 ADAM을 사용하여 메시지 보안을 위한 받는 사람 조회를 수행할 수도 있습니다.

Exchange 2007을 설치하면 ADAM 설치가 서비스 팩 1(SP1) 버전으로 자동 업그레이드됩니다.

따라서 ADAM을 업그레이드하지 않으려는 경우를 제외하면 별도의 작업이 필요 없습니다. ADAM을 업그레이드하지 않으려는 경우에는 로컬 컴퓨터에 게이트웨이 서버 역할을 설치하면 안 됩니다.


하나 이상의 Active Directory Connector 서버가 발견되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

현재 Microsoft Exchange 환경에서 하나 이상의 ADC(Active Directory Connector)가 발견되었기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

ADC는 Microsoft Exchange 혼합 모드 환경에서 Exchange Server 버전 5.5의 개체를 Active Directory® 디렉터리 서비스로 복제하며 Exchange 2007에서는 지원되지 않습니다.

Exchange 2007을 설치하려면 모든 ADC 구성 요소를 제거해야 합니다.

이 문제를 해결하려면 모든 ADC 구성 요소를 제거하고 Exchange 2007 설치 프로그램을 다시 실행하십시오.

Active Directory Connector 구성 요소를 제거하려면 다음을 수행합니다.

  1. ADC 서비스를 실행 중인 서버에서 ADC 서비스를 사용하지 않으려면 바탕 화면에서 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 관리를 클릭합니다.

  2. 서비스 및 응용 프로그램 노드를 확장한 다음 서비스 노드를 클릭합니다.

  3. 오른쪽 창에서 Microsoft Active Directory Connector를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  4. 시작 유형을 사용 안 함으로 변경합니다. 컴퓨터를 다시 시작하면 ADC 서비스가 시작되지 않습니다.

  5. 적용을 클릭한 다음 확인을 클릭합니다.

  6. ADC 서비스를 제거하려면 Microsoft Exchange 2000 Server 또는 Microsoft Exchange Server 2003 CD의 Active Directory 설치 마법사를 사용합니다. \ADC\I386 폴더를 열고 Setup.exe 프로그램을 두 번 클릭합니다. 표시되는 지시에 따라 ADC 서비스 구성 요소를 모두 제거합니다.

    중요:
    이 문제를 해결하려면 6단계를 완료하고 ADC 구성 요소를 모두 제거해야 합니다. ADC 서비스를 사용하지 않는 것만으로는 부족합니다.

ADC에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • 325300, "웹캐스트: Active Directory Connector 소개"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300)

  • 325221, "웹캐스트: Microsoft 고급 Active Directory Connector"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221)

  • 312632, "HOWTO: Exchange 2000 Server에서 Active Directory Connector 설치 및 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632)


CCR 서버는 하나만 사용할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

새 클러스터 사서함 서버를 만들지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange Server 2007을 설치하려면 CCR(클러스터 연속 복제) 클러스터에 클러스터 연속 복제 클러스터 사서함 서버가 하나만 있어야 합니다. 이 CCR 클러스터에는 클러스터 사서함 서버가 이미 있습니다.

이 문제를 해결하려면 이 클러스터에 클러스터 연속 복제 클러스터 사서함 서버를 추가로 설치하지 않습니다.

CCR 환경에서 클러스터 사서함 서버를 설치하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "활성 노드에 사서함 서버 역할을 설치하는 방법"(http://go.microsoft.com/fwlink/?LinkId=86624)을 참조하십시오.


클러스터 서버에 사서함 역할만 설치할 수 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-07

이 클러스터 서버에 사서함 서버 역할 이외의 다른 역할을 설치하려고 시도했으나 실패했으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange는 클러스터 서비스가 설치된 서버에서 사서함 서버 역할 이외의 Exchange 2007 역할을 지원하지 않습니다.

이 문제를 해결하려면 Exchange Server 2007 작업 가이드의 "Exchange 2007의 높은 수준의 가용성"(http://go.microsoft.com/fwlink/?LinkId=68190)을 참조하십시오.


조직이 혼합 모드에 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-05-15

기존 Microsoft Exchange 조직이 전용 모드에 있지 않기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 기존 Exchange 조직이 전용 모드에 있어야 합니다.

이 문제를 해결하려면 기존 조직의 마지막 Exchange Server 버전 5.5를 업그레이드한 후 또는 마지막 Exchange 5.5 서버의 역할을 해제하기 전에 다음 단계를 수행합니다. 그런 다음 Exchange 2007 설치 프로그램을 다시 실행합니다.

참고:
전용 모드로 전환한 후에는 다시 혼합 모드로 되돌릴 수 없습니다.
전용 모드로 전환하려면 다음을 수행합니다.

  1. 시작을 클릭하고 모든 프로그램, Microsoft Exchange를 차례로 가리킨 다음 System Manager를 클릭하여 Exchange System Manager를 시작합니다.

  2. 콘솔 트리에서 전용 모드로 전환할 조직을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. <조직 이름> 속성에서 작동 모드 변경 아래의 모드 변경을 클릭합니다.

  4. 경고 대화 상자에서 전용 모드로 영구적으로 전환하려면 예를 클릭합니다. 새 Exchange 모드를 적용하려면 적용을 클릭합니다.

Exchange 전용 모드를 최대한 활용하려면 Microsoft Exchange Information Store 서비스를 조직의 모든 Exchange 서버에서 다시 시작해야 합니다. 동시에 모든 Microsoft Exchange Information Store 서비스를 다시 시작해야 할 필요는 없지만 모든 Exchange 전용 모드 기능을 사용하려면 각 서버에서 서비스를 다시 시작해야 합니다. 전용 모드에 대한 변경 내용이 로컬 Microsoft Windows® 도메인 컨트롤러에 복제된 후에 서버에서 서비스를 다시 시작합니다.

Microsoft Exchange Information Store 서비스를 다시 시작하려면 다음을 수행합니다.

  1. 시작 및 실행을 차례로 클릭하고 services.msc를 입력한 다음 확인을 클릭합니다.

  2. 서비스(로컬) 창에서 Microsoft Exchange Information Store 서비스를 찾습니다.

  3. 서비스를 마우스 오른쪽 단추로 클릭한 다음 다시 시작을 클릭합니다.

혼합 모드에서 전용 모드로 전환하는 방법은 Microsoft 기술 자료 문서 32779, "HOWTO: Exchange에서 혼합 모드에서 기본 모드로 변환"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779)을 참조하십시오.


기본 DNS 서버에 연결할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-05

기본 DNS(Domain Name System) 서버와 통신을 설정할 수 없기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 로컬 컴퓨터가 해당 도메인에서 신뢰할 수 있는 DNS 데이터베이스와 통신할 수 있어야 합니다.

Microsoft Exchange에서는 DNS를 사용하여 다음 내부 또는 외부 대상 서버의 IP 주소를 확인합니다.

다음과 같은 이유로 기본 DNS 서버와의 통신이 실패할 수 있습니다.

  • 로컬 TCP/IP 구성이 올바른 DNS 서버를 가리키지 않습니다.

  • 네트워크 오류 또는 다른 이유 때문에 DNS 서버가 중지되거나 DNS 서버에 연결할 수 없습니다.

이 문제를 해결하려면 다음을 수행합니다.

  • 로컬 TCP/IP 구성이 올바른 DNS 서버를 가리키는지 확인합니다.

로컬 TCP/IP 구성을 확인하려면 다음을 수행합니다.

  1. 로컬 TCP/IP 구성을 검토합니다.

    자세한 내용은 "DNS를 사용하도록 TCP/IP 구성"(http://go.microsoft.com/fwlink/?LinkId=68094)을 참조하십시오.
  • DNS 서버가 실행 중이고 DNS 서버에 연결할 수 있는지 확인합니다.

DNS 서버가 실행 중이고 DNS 서버에 연결할 수 있는지 확인하려면 다음을 수행합니다.

  1. 다음 확인 작업 중 하나를 수행하여 DNS 서버가 실행되고 있는지 확인합니다.

    • DNS 서버의 DNS 관리 프로그램에서 DNS 서버 상태를 확인합니다.

    • DNS 서버를 다시 시작합니다.

      자세한 내용은 "DNS 서버 시작, 중지, 일시 중지 및 다시 시작"(http://go.microsoft.com/fwlink/?LinkId=62999)을 참조하십시오.

    • nslookup 명령을 사용하여 DNS 서버 응답 기능을 확인합니다.

      자세한 내용은 "nslookup 명령을 사용하여 DNS 서버 응답 기능 확인"(http://go.microsoft.com/fwlink/?LinkId=63000)의 설명을 참조하십시오.


공용 폴더 데이터베이스 드라이브 사양이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-05-15

Microsoft® Exchange Server 2007 Disaster Recovery 설치 프로그램에서 이 서버의 이전 설치에 사용된 공용 폴더 데이터베이스 드라이브 사양에 액세스할 수 없기 때문에 Disaster Recovery 설치를 계속할 수 없습니다.

Microsoft Exchange Disaster Recovery를 설치하려면 이전에 이 서버에 사용된 공용 폴더 데이터베이스 드라이브 사양과 동일한 사양을 복원하는 동안 사용할 수 있어야 합니다.

이 상황을 해결하려면 드라이브를 원래 논리 드라이브 구성과 일치되게 구성하고 Microsoft Exchange Disaster Recovery 설치 프로그램을 다시 실행하십시오.

드라이브 문자 할당 또는 변경

  1. 컴퓨터 관리(로컬)를 엽니다.

  2. 콘솔 트리에서 컴퓨터 관리(로컬)를 클릭하고 저장소를 클릭한 다음 디스크 관리를 클릭합니다.

  3. 파티션, 논리 드라이브 또는 볼륨을 마우스 오른쪽 단추로 클릭한 다음 드라이브 문자 및 경로 변경을 클릭합니다.

  4. 다음 절차 중 하나를 수행합니다.

    • 드라이브 문자를 할당하려면 추가를 클릭하고 사용할 드라이브 문자를 클릭한 다음 확인을 클릭합니다.

    • 드라이브 문자를 수정하려면 드라이브 문자를 클릭하고, 변경을 클릭하고 사용할 드라이브 문자를 클릭한 다음 확인을 클릭합니다.

드라이브 문자를 할당하는 방법에 대한 자세한 내용은 "드라이브 문자 할당, 변경 또는 제거"(http://go.microsoft.com/fwlink/?LinkId=66764)를 참조하십시오.


클러스터된 노드의 레지스트리에 원격으로 액세스할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-04-13

클러스터 노드의 레지스트리에 액세스할 수 없으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 클러스터에 있는 모든 노드의 레지스트리에 액세스하여 다양한 설정을 검색할 수 있어야 합니다.

이 문제를 해결하려면 다음을 수행합니다.

  • 클러스터의 모든 노드에서 원격 레지스트리 서비스가 실행 중인지 확인합니다.

  • Microsoft Networks의 파일 및 프린터 공유가 바인딩 순서 목록의 첫 번째 네트워크 어댑터에 대해 사용하도록 설정되어 있는지 확인합니다.

  • 다음 레지스트리 키의 값이 클러스터의 각 노드에서 동일하며 관련 그룹 정책에 대해 유효한지 확인합니다.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanmanworkstation\parameters\RequireSecuritySignature

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rdr\Parameters\EnableSecuritySignature

레지스트리 연결 문제 해결에 대한 자세한 내용은 "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems"(http://go.microsoft.com/fwlink/?linkid=56285)의 Troubleshooting Registry Connectivity Issues 섹션을 참조하십시오.


서버 역할을 제거하기 전에 Edge 구독을 제거하십시오.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-21

서버 역할에 Edge 구독이 있어 Edge 또는 허브 전송 서버 역할 제거 프로세스가 실패했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Active Directory 사이트에 대해 Edge 전송 서버를 구독하여 해당 Edge 전송 서버를 Exchange 조직에 연결합니다. 구독된 Edge 전송 서버는 Active Directory 사이트 특성으로 스탬프 처리됩니다. 이와 같은 연결을 사용하는 경우의 가장 큰 이점은 Edge 구독을 Exchange 조직에서 만들어지는 송신 커넥터의 원본 서버로 구성할 수 있다는 것입니다. Exchange 조직의 허브 전송 서버는 암시적인 조직 내 송신 커넥터를 사용하여 전자 메일 메시지를 구독된 Edge 전송 서버를 통해 인터넷으로 라우팅합니다. Active Directory 사이트와의 연결을 사용하면 허브 전송 서버는 라우팅용으로 Edge 전송 서버를 찾을 수 있습니다.

Exchange 2007을 설치하려면 대상 Edge 전송 서버 역할 또는 사이트의 마지막 허브 전송 서버 역할에 대한 모든 Edge 구독을 제거한 후에 Edge 또는 허브 전송 서버 역할 제거를 수행해야 합니다.

이 오류를 해결하려면 Get-EdgeSubscription cmdlet를 사용하여 Edge 구독에 대한 정보를 검색하고 Remove-EdgeSubscription cmdlet를 사용하여 대상 서버에서 Edge 구독을 제거한 후에 Exchange 2007 설치 프로그램을 다시 실행하십시오.

Edge 구독을 식별 및 제거하려면 다음을 수행합니다.

  1. Get-EdgeSubscription(http://go.microsoft.com/fwlink/?LinkId=86320) cmdlet 항목의 안내에 따라 대상 서버의 Edge 구독을 식별합니다.

  2. Remove-EdgeSubscription(http://go.microsoft.com/fwlink/?LinkId=86321) cmdlet 항목의 안내에 따라 대상 서버에서 Edge 구독을 제거합니다.


스키마 FSMO가 Windows Server 2003 서비스 팩 1(SP1) 이상을 실행 안 함
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-05

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스 포리스트를 점검하여 Active Directory 도메인 컨트롤러 스키마 마스터에서 실행 중인 서버 운영 체제 버전에 대해 확인합니다. FSMO(Flexible Single Master Operation)라고도 하는 Active Directory 작업 스키마 마스터 도메인 컨트롤러가 Microsoft Windows Server(TM) 2003 서비스 팩 1(SP1) 이상을 실행하고 있지 않음이 확인되면 Exchange Server Analyzer는 오류를 표시합니다.

오류 메시지는 Microsoft Exchange Server 2007을 설치하려면 Windows Server 2003 SP1 이상 버전이 필요함을 알립니다. Windows Server 2003 SP1 이상 버전이 있어야 새로운 Exchange 2007 권한 구조가 지원됩니다.

Active Directory 스키마 FSMO 도메인 컨트롤러에서 Windows Server 2003 SP1 이상 버전이 실행되고 있지 않으면 Exchange 2007 설치 작업이 실패합니다.

이 메시지는 Exchange 2007 배포 이전의 선행 조건에 대한 확인입니다. Exchange 2007을 설치하려 한다면 포리스트 전반의 Active Directory 도메인 컨트롤러 스키마 마스터에서 Windows Server 2003 SP1 이상 버전을 실행하는 것이 좋습니다.


스키마 마스터가 Windows 2000 Server를 실행하고 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-01-08

FSMO(Flexible Single Master Operation)라고도 하는 Active Directory® 디렉터리 서비스 스키마 마스터 역할이 할당된 도메인 컨트롤러가 Microsoft Windows® 2000 Server를 실행하고 있기 때문에 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 스키마 FSMO 역할을 하는 도메인 컨트롤러가 Microsoft Windows Server™ 2003 서비스 팩 1(SP1) 이상 버전을 실행해야 합니다.

FSMO는 Active Directory 스키마에 대한 모든 업데이트와 수정을 제어합니다.

이 문제를 해결하려면 FSMO 도메인 컨트롤러를 Windows Server 2003 SP1 이상의 서버 버전으로 업그레이드 또는 이동하고 Microsoft Exchange 설치 프로그램을 다시 실행하십시오.

자세한 내용은 Microsoft 기술 자료 문서 325379, "Windows 2000 도메인 컨트롤러를 Windows Server 2003으로 업그레이드하는 방법"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=325379)을 참조하십시오.

한 도메인에서 다른 도메인으로 인프라 마스터 역할을 옮기는 것에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하십시오.

  • Microsoft Windows Server™ 2003의 경우 324801, "Windows Server 2003에서 FSMO 역할을 보고 전송하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)을 참조하십시오.

  • Microsoft Windows 2000 Server의 경우 255690, "그래픽 사용자 인터페이스에서 FSMO 역할을 보고 전송하는 방법"(http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)을 참조하십시오.


스키마 마스터에서 Windows Server 2003 서비스 팩 1 이상을 실행하고 있지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

FSMO(Flexible Single Master Operations)라고도 하는 Active Directory 디렉터리 서비스 스키마 마스터 역할이 할당된 도메인 컨트롤러에서 Microsoft Windows Server 2003 서비스 팩 1(SP1) 이상 버전을 실행하고 있지 않으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 스키마 FSMO 역할을 하는 도메인 컨트롤러에서 Windows Server 2003 SP1 이상 버전을 실행해야 합니다.

FSMO는 Active Directory 스키마에 대한 모든 업데이트와 수정을 제어합니다.

이 문제를 해결하려면 다음 중 하나 이상을 수행합니다.

  • FSMO 도메인 컨트롤러를 Windows Server 2003 SP1 이상 버전으로 업그레이드하고 Microsoft Exchange 설치 프로그램을 다시 실행하십시오.

  • Exchange 조직에 Microsoft Windows Server 2003 서비스 팩 1(SP1) 이상 버전을 실행 중인 FSMO 도메인 컨트롤러가 있는 경우 해당 FSMO 도메인 컨트롤러를 가리키는 /domaincontroller 매개 변수를 사용하여 Exchange 2007 설치 프로그램을 다시 실행하십시오.

    [/DomainController 또는 /dc <도메인 컨트롤러의 FQDN>]

    /DomainController 매개 변수를 사용하여 설치 중에 Active Directory 에 대해 읽기 및 쓰기 작업을 수행하는 데 사용할 도메인 컨트롤러를 지정합니다. NetBIOS 또는 FQDN(정규화된 도메인 이름) 형식을 사용할 수 있습니다.

최신 Windows Server 2003 서비스 팩을 얻으려면 "Windows Server TechCenter"(http://go.microsoft.com/fwlink/?LinkId=45315)를 참조하십시오.

Exchange Server 2007 설치 프로그램 매개 변수에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "Exchange 2007을 무인 모드로 설치하는 방법"(http://go.microsoft.com/fwlink/?LinkId=86476)을 참조하십시오.


Setup Cannot Install Exchange to a Read-Only Domain Controller
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-07-23

대상 컴퓨터가 RODC(읽기 전용 도메인 컨트롤러)이기 때문에 Microsoft Exchange Server 2007 설치 프로그램에서 설치를 계속할 수 없습니다.

읽기 전용 도메인 컨트롤러는 Windows Server 2008 Active Directory의 기능입니다. RODC는 실제 보안 수준이 낮을 수 있는 원격 사이트에 설치 가능한 도메일 컨트롤러 설치 옵션의 유형입니다.

Exchange를 설치하려면 대상 설치 컴퓨터에 대한 쓰기 권한이 있어야 합니다.

이 문제를 해결하려면 RODC로 지정되지 않은 대상 설치 컴퓨터를 선택한 다음 설치 프로그램을 다시 실행합니다.


서버 역할을 설치하는 중에 설치 프로그램에 오류가 발생했습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-04-12

서버 역할을 설치하는 중에 이전 설치 프로그램에 오류가 발생하여 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 오류가 발생한 서버 역할 설치 작업을 제대로 다시 수행하거나 설치 프로세스에서 제거한 후에 다른 설치 작업을 계속해야 합니다.

이 문제를 해결하려면 설치에 실패한 서버 역할만 다시 설치하거나 해당 서버 역할을 제거합니다.

설치에 실패한 서버 역할을 명령줄에서 다시 설치하려면 다음을 수행합니다.

  1. 명령 프롬프트 창을 열고 설치 파일을 탐색합니다.

  2. 다음 명령을 실행합니다.

    코드 복사
    Setup /roles:<Failed Server Role>

    쉼표로 구분된 목록에서 다음 역할 중 하나 이상을 선택합니다.

    ClientAccess(CA 또는 C)

    EdgeTransport(ET 또는 E)

    참고:
    Edge 전송 서버 역할은 다른 서버 역할이 설치된 컴퓨터에 설치할 수 없습니다.
    참고:
    즉, Edge 전송 서버 역할을 경계 네트워크 내부 및 Active Directory 포리스트 외부에 배포해야 합니다.

    HubTransport(HT 또는 H)

    Mailbox(MB 또는 M)

    UnifiedMessaging(UM 또는 U)

    ManagementTools(MT 또는 T)

    참고:
    ManagementTools를 지정하는 경우 Exchange 관리 콘솔, Exchange 관리 셸의 Exchange cmdlet, Exchange 도움말 파일, Exchange 모범 사례 분석 도구 및 Exchange Troubleshooting Assistant가 설치됩니다. 다른 서버 역할을 설치하는 경우에는 관리 도구가 자동으로 설치됩니다.

    예를 들어 기존 사서함 서버에 허브 전송 서버 역할을 추가하는 경우에는 %LocalExchangeInstallationDir%\bin\Setup.com /role:HubTransport /Mode:Install을 입력합니다.

참고:
이전에 Exchange Server 2007 서버 역할을 제대로 설치한 경우 설치 마법사가 유지 관리 모드에서 실행됩니다. 이전에 Exchange 2007 서버 역할을 제대로 설치한 적이 없는 경우에는 설치 마법사가 중지된 위치에서부터 시작됩니다.
유지 관리 모드에서 Exchange Server 2007 설치 마법사를 사용하여 설치에 실패한 서버 역할을 다시 설치하려면 다음을 수행합니다.

  1. 서버 역할을 다시 설치할 서버에 로그온합니다.

  2. 제어판을 열고 프로그램 추가/제거를 두 번 클릭합니다.

  3. 프로그램 변경/제거 페이지에서 Microsoft Exchange Server를 선택하고 변경을 클릭합니다.

  4. Exchange Server 2007 설치 마법사의 Exchange 유지 관리 모드 페이지에서 다음을 클릭합니다.

  5. 서버 역할 선택 페이지에서 설치할 서버 역할의 확인란을 선택하고 다음을 클릭합니다.

    참고:
    Edge 전송 서버 역할은 다른 서버 역할이 설치된 컴퓨터에 설치할 수 없습니다.
    참고:
    즉, Edge 전송 서버 역할을 경계 네트워크 및 Active Directory 포리스트 외부에 배포해야 합니다.
    참고:
    관리 도구를 선택하면 Exchange 관리 콘솔, Exchange 관리 셸의 Exchange cmdlet 및 Exchange 도움말 파일이 설치됩니다. 그리고 다른 서버 역할을 설치하는 경우에는 관리 도구가 자동으로 설치됩니다.

  6. 허브 전송 역할을 선택하고 기존 Exchange Server 2003 또는 Exchange 2000 Server 조직이 있는 포리스트에 Exchange 2007 을 설치하는 경우 메일 흐름 설정 페이지에서 라우팅 그룹 커넥터를 만들 Exchange 2003 또는 Exchange 2000 라우팅 그룹의 구성원인 기존 조직에 있는 브리지헤드 서버를 선택합니다.

  7. 준비 검사 페이지에서 상태를 보고 조직 및 서버 역할 선행 조건 검사가 제대로 완료되었는지 확인합니다. 해당 검사가 제대로 완료된 경우 설치를 클릭하여 Exchange 2007 을 설치합니다.

  8. 완료 페이지에서 마침을 클릭합니다.
이전에 다른 서버 역할을 제대로 설치한 적이 없는 경우 Exchange Server 2007 설치 마법사를 사용하여 설치에 실패한 서버 역할을 다시 설치하려면 다음을 수행합니다.

  1. Exchange Server 2007 제품 설명서의 "Exchange Server 2007 설치 프로그램을 사용하여 사용자 지정 설치를 수행하는 방법"(http://go.microsoft.com/fwlink/?LinkId=86648)에 나와 있는 안내를 따릅니다.
설치에 실패한 서버 역할을 제거하려면 다음을 수행합니다.

  1. Exchange Server 2007 제품 설명서의 "Exchange 2007 서버 역할을 제거하는 방법"(http://go.microsoft.com/fwlink/?LinkId=86649)에 나와 있는 안내를 따릅니다.

추가 정보

무인 모드로 Exchange 2007을 설치하는 방법에 대한 자세한 내용은 "Exchange 2007을 무인 모드로 설치하는 방법"(http://go.microsoft.com/fwlink/?LinkId=86476)을 참조하십시오.


이 서버는 라우팅 그룹 커넥터의 원본입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

허브 전송 서버 역할을 제거하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다. 로컬 컴퓨터가 Exchange 조직에 있는 라우팅 그룹 커넥터 하나 이상의 원본입니다.

라우팅 그룹 커넥터는 Exchange 2007 허브 전송 서버와 Exchange Server 2003 또는 Exchange 2000 Server 브리지헤드 서버 간에 메시지를 주고 받는 데 사용됩니다. 기존 Exchange Server 2003 및 Exchange 2000 Server 조직에 Exchange Server 2007을 설치하면 설치 과정에서 필요한 라우팅 그룹 커넥터가 만들어집니다.

Exchange 2007을 설치하려면 Exchange 조직의 모든 라우팅 그룹 커넥터를 허브 전송 서버 컴퓨터에서 이동하거나 삭제하여 해당 서버 역할을 삭제해야 합니다.

이 문제를 해결하려면 로컬 컴퓨터에서 모든 라우팅 그룹 커넥터를 이동하거나 삭제한 후에 설치 프로그램을 다시 실행합니다.

Exchange 관리 셸을 사용하여 라우팅 그룹 커넥터를 이동하려면 다음을 수행합니다.

  1. Set-RoutingGroupConnector cmdlet를 사용하여 Microsoft Exchange Server 2007 라우팅 그룹과 Exchange Server 2003 또는 Exchange 2000 Server 라우팅 그룹 간의 기존 라우팅 그룹 커넥터 속성을 수정합니다.

  2. 이 항목의 예제에서는 Set-RoutingGroupConnector cmdlet를 사용하여 라우팅 그룹 커넥터의 원본을 수정합니다.
코드 복사
Set-RoutingGroupConnector -Identity "[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name" -SourceTransportServers [FQDN of desired Hub Transport Server]
 Exchange 관리 셸을 사용하여 라우팅 그룹 커넥터를 제거하려면 다음을 수행합니다.

  1. Remove-RoutingGroupConnector cmdlet를 사용하여 Microsoft Exchange Server 2007 라우팅 그룹과 Exchange Server 2003 또는 Exchange 2000 Server 라우팅 그룹 간의 라우팅 그룹 커넥터를 제거합니다.

  2. 다음 예제에서는 Remove-RoutingGroupConnector cmdlet를 사용하여 지정된 라우팅 그룹 커넥터를 제거하는 방법을 보여줍니다.
코드 복사
Remove-RoutingGroupConnector -Identity"[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name"

라우팅 그룹 커넥터를 수정 또는 제거하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서에서 다음 항목을 참조하십시오.

  • Set-RoutingGroupConnector(http://go.microsoft.com/fwlink/?LinkId=86659).

  • Remove-RoutingGroupConnector(http://go.microsoft.com/fwlink/?LinkId=86660).


이 서버는 송신 커넥터의 원본입니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

허브 전송 서버 역할을 제거하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다. 로컬 컴퓨터가 Exchange 조직에 있는 송신 커넥터 하나 이상의 원본입니다.

송신 커넥터는 아웃바운드 메시지를 보내는 데 사용되는 논리 게이트웨이입니다.

Exchange 2007을 설치하려면 Exchange 조직의 모든 송신 커넥터를 허브 전송 서버 컴퓨터에서 이동하거나 삭제하여 해당 서버 역할을 삭제해야 합니다.

이 문제를 해결하려면 로컬 컴퓨터에서 모든 송신 커넥터를 이동하거나 삭제한 후에 설치 프로그램을 다시 실행합니다.

송신 커넥터를 수정 또는 제거하는 방법에 대한 자세한 내용은 Exchange Server 2007 제품 설명서에서 다음 항목을 참조하십시오.

  • "송신 커넥터를 제거하는 방법"(http://go.microsoft.com/fwlink/?LinkId=86655).

  • "송신 커넥터의 구성을 수정하는 방법"(http://go.microsoft.com/fwlink/?LinkId=86656).


단순 Exchange 조직 모델 검색됨
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-08-18

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 서버의 사서함 수를 확인합니다. 각 사서함 저장소 개체(msExchPrivateMDB 클래스)에는 저장소에 있는 모든 사서함을 나열하는 다중 값 특성 homeMDBBL이 있습니다. Exchange Server Analyzer Tool은 이러한 값을 계산하여 서버에 있는 총 사서함 수를 구합니다.

또한 Exchange Server Analyzer는 Active Directory를 쿼리하여 Exchange Server가 포함된 Active Directory 사이트 수를 확인합니다. Exchange Server Analyzer는 Active Directory를 쿼리하여 Microsoft Exchange 2000 Server 또는 Microsoft Exchange Server 2003을 실행하는 서버 수를 확인합니다. 마지막으로 Exchange Server Analyzer는 Win32_Service Microsoft WMI(Windows® Management Instrumentation) 개체를 쿼리하여 Windows 클러스터 서비스가 있으며 실행되고 있는지 확인합니다.

Exchange Server Analyzer는 다음 조건에 해당하는 경우 Exchange 조직을 단순 Exchange 조직으로 분류합니다.

  • 조직의 총 사서함 수가 1,000개 미만입니다.

  • Exchange Server가 하나의 Active Directory 사이트에만 설치되어 있습니다.

  • Exchange 2000 또는 Exchange 2003을 실행하는 컴퓨터 수가 3대 미만입니다.

  • 클러스터형 Exchange Server가 배포되지 않습니다.

Microsoft Exchange Server 2007에 대해 정의된 네 가지 조직 모델 중에서 단순 Exchange 조직은 Exchange 2007이 배포될 수 있는 가장 기본적인 토폴로지를 나타냅니다. 단순 Exchange 조직에는 다음 중 하나가 포함됩니다.

  • 모든 Exchange 서비스를 제공하고 전체 조직의 모든 Exchange 데이터를 저장하는 단일 Exchange Server

  • 경계 네트워크에 중복 디렉터리 서버와 Edge 전송 서버가 포함된 토폴로지에 있는 여러 개의 Exchange Server

단순 Exchange 조직을 Exchange 2007로 전환하려면 다음을 수행합니다.

  1. Exchange 2007 온라인 제품 설명서(http://go.microsoft.com/fwlink/?LinkId=69434)를 봅니다.

  2. "계획 및 아키텍처", "배포 계획"을 차례로 확장하고 "단순 Exchange 조직을 위한 계획"을 클릭합니다.


SMTP(Simple Mail Transport Protocol)가 현재 설치되어 있습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-01-22

이 컴퓨터에 Microsoft Windows Server™ 2003 SMTP(Simple Mail Transport Protocol) 서비스가 설치되어 있으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Microsoft Exchange를 설치하려면 Exchange 2007에 사용할 서버에 SMTP 서비스를 설치하지 말아야 합니다.

이 문제를 해결하려면 SMTP 서비스를 제거한 후 Microsoft Exchange 설치 프로그램을 다시 실행합니다.

제어판의 Windows 구성 요소 추가/제거를 사용하여 SMTP 서비스를 제거하려면 다음을 수행합니다.

  1. 시작 메뉴에서 제어판을 클릭합니다.

  2. 프로그램 추가/제거를 두 번 클릭합니다.

  3. Windows 구성 요소 추가/제거를 클릭합니다.

  4. 구성 요소 목록에서 응용 프로그램 서버 확인란을 선택한 다음 자세히를 클릭합니다.

  5. 인터넷 정보 서비스 관리자를 선택한 다음 자세히를 클릭합니다.

  6. SMTP 서비스를 선택한 다음 클릭하여 확인란의 선택을 취소합니다.

  7. 확인을 두 번 클릭하여 구성 요소 목록으로 돌아간 후 다음을 클릭합니다.

  8. SMTP 서비스가 제거되었으면 마침을 클릭합니다.


사이트에서 Exchange 2007 서버를 지원할 수 없음
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-08-11

Active Directory 디렉터리 서비스 포리스트에 Microsoft Windows Server™ 2003 서비스 팩 1(SP1) 이후 버전에서 실행되는 글로벌 카탈로그 서버가 하나도 없는 사이트가 있으므로 Microsoft® Exchange Server Analyzer Tool에서 이 경고를 표시했습니다.

Microsoft Exchange Server 2007을 설치하려면 Exchange 2007이 실행되는 서버를 호스팅할 각 Active Directory 사이트에 Windows Server 2003 SP1 이후 버전에서 실행되는 글로벌 카탈로그 서버가 하나 이상 있어야 합니다.

이 문제를 해결하려면 각 Active Directory 사이트에서 하나 이상의 글로벌 카탈로그 서버를 Windows Server 2003 SP1 이후 버전으로 업그레이드합니다.

Windows Server 2003으로 업그레이드하는 방법은 Microsoft 기술 자료 문서 810613, "Windows Server 2003 또는 Windows Small Business Server 2003으로 업그레이드할 수 있도록 지원되는 경로"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613)를 참조하십시오.

Windows Server 2003용 최신 서비스 팩을 얻으려면 Windows Server TechCenter(http://go.microsoft.com/fwlink/?LinkId=45315)를 참조하십시오.


표준 Exchange 조직 모델 검색됨
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-08-10

Microsoft® Exchange Server Analyzer Tool은 Active Directory® 디렉터리 서비스를 쿼리하여 다음 내용을 확인합니다.

  • 조직의 사서함 수

  • 조직의 라우팅 그룹 수

  • 조직의 Active Directory 사이트 수

  • 조직의 Active Directory 포리스트 수

  • MIIS(Microsoft Identity Integration Server) 설치 여부

각 항목 수에 따라 Exchange 조직 모델이 단순, 표준, 대형 또는 복합인지 결정됩니다. 단순, 대형 또는 복합으로 분류되지 않은 모든 조직은 자동으로 표준 Exchange 조직으로 분류됩니다.

Microsoft Exchange Server 2007에 대해 정의된 네 가지 조직 모델 중에서 표준 Exchange 조직은 Exchange 2007이 배포되는 가장 일반적인 토폴로지를 나타냅니다. 메시징 서비스의 수요가 단일 컴퓨터의 리소스 제한 이상으로 증가함에 따라 Exchange 2007 서비스를 여러 대의 컴퓨터로 분리하는 것이 표준 Exchange 조직이라는 다음 토폴로지 영역이 되었습니다. 표준 Exchange 조직은 단순 Exchange 조직을 기반으로 하며, Exchange를 실행하는 여러 대의 컴퓨터를 배포하여 구성됩니다.

표준 Exchange 조직을 Exchange 2007로 전환하려면 다음을 수행합니다.

  1. Exchange 2007 온라인 제품 설명서(http://go.microsoft.com/fwlink/?LinkId=69434)를 봅니다.

  2. "계획 및 아키텍처", "배포 계획"을 차례로 확장하고 "표준 Exchange 조직을 위한 계획"을 클릭합니다.


클러스터에 정적 IP 주소가 권장됩니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-05

하나 이상의 네트워크 인터페이스가 DHCP(Dynamic Host Configuration Protocol)를 사용하도록 구성되어 있기 때문에 Microsoft® Exchange Server 2007 설치 프로그램이 이 경고를 표시했습니다.

Microsoft Windows 서버 클러스터의 하트비트 링크 및 클라이언트 연결을 관리하는 네트워크 인터페이스에는 정적 IP 주소를 사용하는 것이 가장 좋습니다. DHCP 임대를 갱신하지 못하면 클러스터 작업이 중단될 수 있으므로 DHCP를 통해 동적 구성을 사용하는 것은 권장되지 않습니다.

이 경고를 해결하려면 클라이언트 연결 또는 하트비트 링크를 관리하는 각 네트워크 인터페이스를 정적 IP 주소를 사용하도록 구성하십시오.

네트워크 연결에 대한 정적 IP 주소를 구성하려면 다음을 수행합니다.

  1. 시작 메뉴에서 설정을 클릭한 다음 네트워크 설정을 클릭합니다.

  2. 구성할 연결을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  3. 일반 탭의 이 연결에 다음 항목을 사용에서 인터넷 프로토콜(TCP/IP)를 클릭한 다음 속성을 클릭합니다.

  4. 다음 IP 주소 사용을 클릭하고 IP 주소에 IP 주소를 입력합니다.

  5. 확인을 두 번 클릭하여 작업을 마칩니다.

Windows 서버 클러스터에 대한 최적의 네트워크 구성에 대한 자세한 내용은 "서버 클러스터: Windows 2000 및 Windows Server 2003의 네트워크 구성을 위한 유용한 정보"(http://go.microsoft.com/fwlink/?linkid=34304)를 참조하십시오.

올바른 클러스터 하트비트 구성에 대한 자세한 내용은 Microsoft 기술 자료 문서 258750, "클러스터 서버에 권장하는 개인 '하트비트' 구성"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)을 참조하십시오.


단일 복사본 클러스터의 저장소 경로는 클러스터된 디스크여야 합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

단일 복사본 클러스터의 저장소 경로는 클러스터된 디스크여야 하므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange Server 2007에서 SCC(단일 복사본 클러스터)는 클러스터의 노드 간에 공유되는 저장소의 저장소 그룹 단일 복사본을 사용하는 클러스터된 솔루션입니다.

이 문제를 해결하려면 데이터 경로에 대해 클러스터된 드라이브를 지정한 후에 Exchange 2007 설치 프로그램을 다시 실행합니다.

단일 복사본 클러스터에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "단일 복사본 클러스터 설치"(http://go.microsoft.com/fwlink/?LinkId=76162)를 참조하십시오.


SMTP 주소 형식이 지원되지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

지정된 받는 사람 정책이 지원되지 않는 SMTP(Simple Mail Transfer Protocol) 주소 형식을 사용하므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 전자 메일 주소 정책에 사용되는 모든 SMTP 주소에 user@[10.10.1.1]과 같이 IP 주소 리터럴이 포함되어서는 안 됩니다.

이 문제를 해결하려면 IP 주소 리터럴이 포함되지 않도록 받는 사람 정책의 SMTP 주소 값을 변경하십시오. 즉, IP 주소 리터럴의 괄호([])와 숫자(10.10.1.1)를 DNS(Domain Name System) 명명 형식, 즉 user@contoso.com 등으로 바꾸고 Exchange 설치 프로그램을 다시 실행합니다.

Exchange Server 2007에서 받는 사람 정책을 관리하는 방법에 대한 자세한 내용은 "전자 메일 주소 정책 관리"(http://go.microsoft.com/fwlink/?LinkId=86653)를 참조하십시오.


SMTP 사이트 링크 발견
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-12-07

Active Directory® 디렉터리 서비스에 SMTP(Simple Mail Transfer Protocol) 기반 사이트 링크가 있으면 Microsoft® Exchange Server Analyzer Tool에서 이 경고를 표시합니다.

Microsoft Exchange Server 2007 라우팅은 SMTP 사이트 링크로 연결된 Active Directory 사이트를 무시합니다. SMTP 사이트 링크로만 연결된 사이트에 Exchange 2007이 설치되어 있으면 라우팅 오류가 발생합니다.

이 문제를 해결하려면 SMTP 사이트 링크를 IP 기반 사이트 링크로 바꿉니다.

Active Directory IP 사이트 링크에 대한 자세한 내용은 "메일 라우팅에 대해 Active Directory 사이트 사용 계획"(http://go.microsoft.com/fwlink/?LinkId=71803)을 참조하십시오.


저장소 그룹 드라이브 사양이 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-05-15

Microsoft® Exchange Server 2007 Disaster Recovery 설치 프로그램에서 이 서버의 이전 설치에 사용된 저장소 그룹 데이터베이스 드라이브 사양에 액세스할 수 없기 때문에 Disaster Recovery 설치를 계속할 수 없습니다.

Microsoft Exchange Disaster Recovery를 설치하려면 이전에 이 서버에 사용된 저장소 그룹 데이터베이스 드라이브 사양과 동일한 사양을 복원하는 동안 사용할 수 있어야 합니다.

이 상황을 해결하려면 드라이브를 원래 논리 드라이브 구성과 일치되게 구성하고 Microsoft Exchange Disaster Recovery 설치 프로그램을 다시 실행하십시오.

드라이브 문자 할당 또는 변경

  1. 컴퓨터 관리(로컬)를 엽니다.

  2. 콘솔 트리에서 컴퓨터 관리(로컬)를 클릭하고 저장소를 클릭한 다음 디스크 관리를 클릭합니다.

  3. 파티션, 논리 드라이브 또는 볼륨을 마우스 오른쪽 단추로 클릭한 다음 드라이브 문자 및 경로 변경을 클릭합니다.

  4. 다음 절차 중 하나를 수행합니다.

    • 드라이브 문자를 할당하려면 추가를 클릭하고 사용할 드라이브 문자를 클릭한 다음 확인을 클릭합니다.

    • 드라이브 문자를 수정하려면 드라이브 문자를 클릭하고, 변경을 클릭하고 사용할 드라이브 문자를 클릭한 다음 확인을 클릭합니다.

드라이브 문자를 할당하는 방법에 대한 자세한 내용은 "드라이브 문자 할당, 변경 또는 제거"(http://go.microsoft.com/fwlink/?LinkId=66764)를 참조하십시오.


대상 설치 경로가 일치하지 않습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

Exchange 이진 파일의 대상 경로가 다른 클러스터 노드에 있는 기존 Exchange 설치 경로와 일치하지 않으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange Server 2007을 설치하려면 동일한 클러스터의 노드에 대해 동일한 Exchange 이진 파일 대상 설치 경로를 사용해야 합니다.

이 문제를 해결하려면 Exchange 이진 파일의 대상 설치 경로를 클러스터의 모든 노드에 대해 동일하게 적용합니다.

고가용성 Exchange Server 2007 설치에 대한 자세한 내용은 Exchange Server 2007 제품 설명서의 "고가용성"(http://go.microsoft.com/fwlink/?linkid=68190)을 참조하십시오.


대상 경로가 압축되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-06

Microsoft Exchange 설치 대상 폴더 경로가 압축되었기 때문에 Microsoft® Exchange Server 2007을 설치할 수 없습니다.

Microsoft Exchange를 설치하려면 설치 대상 경로의 첫 번째 폴더가 압축되어 있지 않아야 합니다. 기본적으로 설치 대상 경로의 첫 번째 폴더는 C:\Program Files입니다.

이 문제를 해결하려면 대상 경로의 첫 번째 폴더를 압축할 수 없게 설정하고 Exchange 2007 설치 프로그램을 다시 실행하십시오.

대상 경로를 압축할 수 없게 하려면 다음을 수행합니다.

  1. 내 컴퓨터 또는 Windows 탐색기에서 압축을 풀려는 폴더를 마우스 오른쪽 단추로 클릭합니다.

  2. 속성을 클릭하여 속성 대화 상자를 표시합니다.

  3. 일반 탭에서 고급을 클릭합니다.

  4. 고급 특성 대화 상자에서 내용을 압축하여 디스크 공간 절약 확인란의 선택을 해제한 다음 확인을 클릭합니다.

  5. 속성 대화 상자에서 확인을 클릭합니다.

  6. 폴더의 압축 상태가 변경되었으면 특성 변경 확인 대화 상자에서 변경 내용을 이 폴더, 하위 폴더 및 파일에 적용을 선택합니다.

  7. 작업이 완료되었으면 확인을 클릭합니다.


클러스터에 네트워크 인터페이스가 두 개 이상인 것이 좋습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-05

현재 Microsoft Windows 클러스터 환경에 정의된 네트워크 인터페이스가 한 개만 있으므로 Microsoft® Exchange Server 2007 설치 프로그램이 이 경고를 표시합니다.

한 곳에서만 오류가 발생하는 것을 방지하려면 적어도 공용 네트워크(클라이언트 연결)를 위한 네트워크 인터페이스 하나와 개인 네트워크(관리/하트비트)를 위한 네트워크 인터페이스 하나를 구현하는 것이 가장 좋습니다.

이 경고를 해결하려면 Microsoft Windows 클러스터용 네트워크 인터페이스를 하나 이상 추가로 구현합니다.

Windows 서버 클러스터에 대한 최적의 네트워크 구성에 대한 자세한 내용은 "서버 클러스터: Windows 2000 및 Windows Server 2003용 네트워크 구성에 대한 유용한 정보"(http://go.microsoft.com/fwlink/?linkid=34304)를 참조하십시오.


원격 레지스트리 서비스에 연결할 수 없습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-01-23

로컬 컴퓨터의 레지스트리에 액세스할 수 없으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 로컬 레지스트리에 액세스하여 다양한 설정을 검색해야 합니다.

Exchange 설치 프로그램은 DNS(Domain Name System)를 사용하여 로컬 컴퓨터의 FQDN(정규화된 도메인 이름)을 얻어서 레지스트리에 액세스하려고 시도합니다.

설치 프로그램이 네트워크 오류로 인해 DNS에서 FQDN을 검색할 수 없거나 레지스트리에 액세스할 수 없습니다.

이 문제를 해결하려면 로컬 컴퓨터에서 원격 레지스트리 서비스를 실행하고 있는지 확인하고, 첫 번째 네트워크 어댑터에서 파일 및 인쇄 공유가 바인딩 순서로 활성화되어 있는지 확인합니다. 그런 다음 Exchange 설치 프로그램을 다시 실행합니다.

원격 레지스트리 서비스가 실행 중인지 확인하려면 다음을 수행합니다.

  1. 시작을 클릭하고 설정, 제어판, 관리 도구를 차례로 가리킨 다음 서비스를 두 번 클릭합니다.

  2. 원격 레지스트리 서비스가 시작됨 상태인지 확인합니다.
주 네트워크 어댑터에서 파일 및 인쇄 공유를 사용하도록 설정하려면 다음을 수행합니다.

  1. 시작을 클릭하고 설정, 제어판, 네트워크 연결, 로컬 영역 연결을 차례로 가리킵니다.

  2. Microsoft 네트워크용 파일 및 프린터 공유가 활성화되었는지, 즉, 확인란이 선택되었는지 확인합니다.
참고:
클러스터된 서버의 경우 클러스터의 모든 노드에서 원격 레지스트리 서비스가 실행 중인지 확인하고, 바인딩 순서에서 첫 번째로 나열된 네트워크 어댑터에 대해 Microsoft 네트워크용 파일 및 프린터 공유가 활성화되었는지 확인해야 합니다.


Windows Media Audio Voice Codec 업데이트 필요
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-07-13

Microsoft Windows Media Audio Voice Codec이 설치되지 않았거나 Windows Media Audio Voice Codec의 보다 최신 버전이 발매되었으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 서버에 Windows Media Audio Voice Codec의 최신 버전을 설치해야 합니다. Windows Media Audio Voice Codec은 Exchange Server 2007 통합 메시징 서버 역할을 지원하기 위해 필요합니다.

이 문제를 해결하려면 http://go.microsoft.com/fwlink/?LinkId=67407에서 Windows Media Audio Voice Codec의 최신 버전을 설치한 다음 Exchange 2007 설치 프로그램을 다시 실행하십시오.


Windows Media Encoder 업데이트 필요
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-07-13

Microsoft Windows Media Encoder가 설치되지 않았거나 Windows Media Encoder의 보다 최신 버전이 발매되었으므로 Microsoft® Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 서버에 Windows Media Encoder의 최신 버전을 설치해야 합니다. Windows Media Encoder는 Exchange Server 2007 통합 메시징 서버 역할을 지원하기 위해 필요합니다.

이 문제를 해결하려면 http://go.microsoft.com/fwlink/?LinkId=67406에서 Windows Media Encoder의 최신 버전을 설치한 다음 Exchange 2007 설치 프로그램을 다시 실행하십시오.


World Wide Web 게시 서비스를 사용할 수 없거나 누락되었습니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-02-14

Microsoft® Exchange Server 2007 설치 프로그램이 사서함 서버 또는 클라이언트 액세스 역할을 설치하려고 시도했으나 이 컴퓨터에서 World Wide Web 게시 서비스를 사용할 수 없거나 설치되어 있지 않음을 발견했기 때문에 설치를 계속할 수 없습니다.

Exchange 2007을 설치하려면 Microsoft Exchange를 설치할 컴퓨터에 World Wide Web 게시 서비스가 설치되어 있고 사용할 수 없는 상태 이외의 상태로 설정되어 있어야 합니다.

이 문제를 해결하려면 로컬 컴퓨터에 World Wide Web 게시 서비스가 설치되어 있는지와 사용할 수 없는 상태 이외의 상태인지 확인한 다음, Microsoft Exchange 설치 프로그램을 다시 실행하십시오.

World Wide Web 게시 서비스가 설치되어 있고 사용할 수 없는 상태 이외의 상태인지 확인하려면 다음을 수행합니다.

  1. 바탕 화면에서 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 관리를 클릭합니다.

  2. 서비스 및 응용 프로그램 노드를 확장한 다음 서비스 노드를 클릭합니다.

  3. 오른쪽 창에서 World Wide Web 게시 서비스를 찾습니다.

    설치된 서비스 목록에 World Wide Web 게시 서비스가 표시되지 않으면 아래 절차의 단계에 따라 설치합니다.

  4. World Wide Web 게시 서비스가 표시되지만 상태가 Started가 아니면 아래 단계에 따라 시작합니다.

  5. World Wide Web 게시 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.

  6. 시작 유형이 자동이고 서비스 상태가 Started로 설정되어 있는지 확인합니다.

  7. 적용을 클릭한 다음 확인을 클릭합니다.
World Wide Web 게시 서비스를 설치하려면 다음을 수행합니다.

  1. 시작 메뉴에서 설정, 제어판을 차례로 선택한 후 프로그램 추가/제거를 클릭합니다.

  2. Windows 구성 요소 추가/제거를 클릭합니다.

  3. 구성 요소 목록에서 응용 프로그램 서버 확인란을 선택한 다음 자세히를 클릭합니다.

  4. 인터넷 정보 서비스 관리자를 선택한 다음 자세히를 클릭합니다.

  5. World Wide Web 서비스를 선택한 다음 확인란을 선택합니다.

  6. 확인을 두 번 클릭하여 구성 요소 목록으로 돌아간 후 다음을 클릭합니다.

  7. IIS 서비스가 설치되었으면 마침을 클릭합니다.


통합 메시징 언어 팩을 제거하십시오.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-16

통합 메시징 서버 역할을 업그레이드하지 못했으므로 Microsoft Exchange Server 2007 설치를 계속할 수 없습니다.

Exchange를 설치하려면 한국어(한국) 언어 팩을 제외한 모든 통합 메시징 서버 역할 언어 팩을 제거하고 통합 메시징 서버 역할 업그레이드를 계속해야 합니다.

Exchange 2007에 포함된 UM(통합 메시징) 언어 팩에는 해당 언어에 대한 사전 녹음 음성 안내인 TTS(텍스트 음성 변환) 변환 지원이 포함되어 있습니다.

Exchange 2007 UM 언어 팩을 사용하면 호출자 및 Outlook Voice Access 사용자가 여러 언어로 통합 메시징 시스템과 상호 작용할 수 있습니다.

기존의 한국어(한국)가 아닌 언어 팩을 제거해야 새 언어 팩을 설치할 수 있습니다.

이 문제를 해결하려면 한국어(한국) 언어 팩을 제외한 통합 메시징 서버 역할 언어 팩을 모두 제거한 후에 Exchange 2007 설치 프로그램을 다시 실행합니다.

통합 메시지 서버 역할 언어 팩을 제거하는 방법에 대한 자세한 내용은 Exchange 2007 제품 설명서의 통합 메시징 서버에서 통합 메시징 언어 팩을 제거하는 방법을 참조하십시오.


재해 복구용 업데이트가 필요합니다.
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2007-03-27

처음에 최신 버전의 Exchange Server 2007을 사용하여 이 컴퓨터에 Exchange Server를 설치했으므로 Microsoft Exchange Server 2007 재해 복구를 계속할 수 없습니다.

Microsoft Exchange 재해 복구를 수행하려면 Exchange Server 복구를 수행하는 데 사용한 Exchange Server 2007 버전이 원래 Exchange Server를 설치하는 데 사용했던 버전 이상이어야 합니다.

이 문제를 해결하려면 원래 Exchange Server를 설치하는 데 사용한 버전 이상의 Exchange Server 2007 버전에서 Exchange Server 2007 재해 복구를 시작합니다.


토폴로지 내 X.400 커넥터 발견
Microsoft Exchange Server Analyzer - 문서 > Exchange Server 2007 준비 >

최근 수정된 항목: 2006-06-05

Microsoft® Exchange Server Analyzer Tool은 X.400 커넥터에 대해 Active Directory® 디렉터리 서비스를 쿼리합니다. Exchange Server Analyzer가 Microsoft Exchange 조직에 X.400 커넥터가 있는 것을 확인하면 경고를 표시합니다. 경고는 이전 메시징 시스템 간의 메시지 전송에 사용된 프로토콜인 X.400 커넥터가 Microsoft Exchange Server 2007에서는 지원되지 않음을 나타냅니다.

Microsoft Exchange 2000 Server와 Microsoft Exchange Server 2003에서는 SMTP(Simple Mail Transfer Protocol)가 기본 전송 프로토콜로 만들어졌습니다. X.400 커넥터는 Exchange 2000과 Exchange 2003에서 지원되지만 지난 수 년간 그 사용이 쇠퇴함에 따라 Exchange 2007에서는 지원되지 않습니다. X.400 지원이 필요하다면 Exchange 2000 또는 Exchange 2003 서버를 유지하는 것이 좋습니다. 그렇지 않은 경우에는 X.400 커넥터를 SMTP로 대치할 수 있습니다.

Exchange 2003에서의 X.400 전송 아키텍처에 대한 자세한 내용은 "Exchange Server 2003 Message Routing"(http://go.microsoft.com/fwlink/?LinkId=65578)을 참조하십시오.

Exchange 2003에서의 X.400 커넥터 구현 방법에 대한 자세한 내용은 "Implementing the X.400 Connector - Is It Worth Using with Exchange Server 2003?" (http://www.msexchange.org/tutorials/X400-Connector-Exchange-Server-2003.html)을 참조하십시오.

참고:
이 항목에는 필요한 기술 정보를 찾는 데 도움이 되는 타사 웹 사이트 정보가 들어 있습니다. URL은 예고 없이 변경될 수 있습니다.


법적 정보

최근 수정된 항목: 2007-04-06

URL 및 기타 인터넷 웹 사이트 참조를 포함하여 설명서의 내용은 예고 없이 변경될 수 있습니다. 다른 설명이 없는 한, 용례에 사용된 회사, 기관, 제품, 도메인 이름, 전자 메일 주소, 로고, 사람, 장소 및 이벤트 등은 실제 데이터가 아닙니다. 어떠한 실제 회사, 기관, 제품, 도메인 이름, 전자 메일 주소, 로고, 사람, 장소 또는 이벤트와도 연관시킬 의도가 없으며 그렇게 유추해서도 안 됩니다. 해당 저작권법을 준수하는 것은 사용자의 책임입니다. 저작권에서의 권리와는 별도로 이 설명서의 어떠한 부분도 Microsoft의 명시적인 서면 승인 없이는 어떠한 형식이나 수단(전자적, 기계적, 복사기에 의한 복사, 디스크 복사 또는 다른 방법) 또는 목적으로도 복제되거나 검색 시스템에 저장 또는 도입되거나 전송될 수 없습니다.

Microsoft가 이 설명서 본안에 관련된 특허권, 상표권, 저작권 또는 기타 지적 재산권 등을 보유할 수도 있습니다. 서면 사용권 계약에 따라 Microsoft로부터 귀하에게 명시적으로 제공된 권리 이외에, 이 설명서의 제공은 귀하에게 이러한 특허권, 상표권, 저작권 또는 기타 지적 재산권 등에 대한 어떠한 사용권도 허여하지 않습니다.

ⓒ 2004-2006 Microsoft Corporation. All rights reserved.

Microsoft, Active Directory, ActiveSync, ActiveX, MSDN, Outlook, SharePoint, Visual C++, Win32, Windows, Windows NT, Windows Server, 및 Windows Server System은 미국, 대한민국 및/또는 기타 국가에서의 Microsoft Corporation 등록 상표 또는 상표입니다.

여기에 인용된 실제 회사와 제품 이름은 해당 소유자의 상표일 수 있습니다.