Visão geral do Assistente para Solução de Problemas do Microsoft Exchange

Última modificação do tópico: 2007-02-15

As tarefas a seguir são acessadas por meio do Assistente para Solução de Problemas do Microsoft® Exchange:

  • Solução de Problemas de Desempenho do Exchange

  • Solução de Problemas de Bancos de Dados do Exchange

  • Gerenciamento de Recuperação de Banco de Dados do Exchange

  • Solução de Problemas de Fluxo de Mensagens do Exchange

A primeira tela do Assistente para Solução de Problemas do Exchange tem duas seções:

  • um conjunto de seleções orientadas por sintomas

  • um conjunto de seleções de funcionalidades relacionadas

A seção orientada por sintomas destina-se à solução de problemas de desempenho, de fluxo de mensagens ou de bancos de dados, como problemas de montagem de armazenamento. As funções relacionadas contêm itens, como controle de rastreio, pesquisa de controle de mensagens e gerenciamento de recuperação de banco de dados.

Observação:
Alguns itens podem estar disponíveis somente para servidores Exchange 2007.
Observação:
O Assistente para Solução de Problemas do Exchange precisará ser instalado em uma estação de trabalho ou servidor que execute uma versão do sistema operacional Microsoft Windows® em inglês dos Estados Unidos.


Instalando o Assistente para Solução de Problemas do Microsoft Exchange
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange >

Última modificação do tópico: 2007-02-16

Para instalar o Microsoft® Exchange Troubleshooting Assistant, execute o arquivo do Microsoft Installer, ExTRA.msi, no computador em que você executará a ferramenta Analisador. Por padrão, o instalador cria um diretório chamado ExTRA na <unidade do sistema>\Arquivos de Programas\ e copia os arquivos necessários para esse novo diretório.

Selecionando um computador para instalação

Você pode instalar o Exchange Troubleshooting Assistant no servidor que será analisado ou em outro servidor que tenha acesso a ele. Alguma funcionalidade pode ser desabilitada quando você o executar remotamente.

Para obter informações sobre como instalar e usar uma estação de gerenciamento dedicada, consulte o Guia de Administração do Exchange Server 2003 em http://go.microsoft.com/fwlink/?linkid=21769.

Observação:
Instale o Exchange Troubleshooting Assistant em uma estação de trabalho ou servidor que execute uma versão do sistema operacional Microsoft Windows® em inglês dos Estados Unidos.

Para instalar a ferramenta em um computador que está fora da organização do Exchange, você deve definir explicitamente os nomes de usuários e senhas para fazer logon no serviço de diretório do Active Directory® e nos servidores Exchange.

Verificando se há atualizações

Quando você inicia o Exchange Troubleshooting Assistant, ele pode verificar se há atualizações para a ferramenta ou para os vários arquivos de configuração do analisador, por exemplo, ExTRA.config.xml, ExPTA.config.xml ou ExDRA.config.xml. Todas as combinações desses arquivos serão atualizadas e liberadas como um pacote de atualização em ciclos de liberação da Web ou outras liberações específicas. Se houver uma nova versão, você poderá baixar o novo arquivo da página mencionada no procedimento a seguir. Você deve estar conectado no computador como um administrador para baixar os arquivos. Se você decidir não baixar um novo arquivo ou se a ferramenta não puder acessar a Internet, a ferramenta usará a cópia do arquivo que está no computador em que ela está sendo executada.

Para copiar manualmente as novas versões dos arquivos de configuração

  1. Localize a página Atualizações da Ferramenta para Solução de Problemas do Microsoft Exchange V1.0 em http://go.microsoft.com/fwlink/?linkid=50424 em seu navegador da Web.

  2. Baixe o pacote de auto-extração e extraia os novos arquivos para um diretório diferente daquele em que a ferramenta está instalada (normalmente C:\Arquivos de Programas\ExTRA).

  3. Observe quais arquivos estão incluídos no pacote de atualização.

  4. Renomeie os arquivos existentes que serão afetados pela atualização.

  5. Copie os arquivos extraídos para o diretório em que a ferramenta está instalada (geralmente C:\Arquivos de Programas\ExTRA).

Funções exclusivas quando o Computador Local do Exchange está sendo analisado

Esta tabela lista funções exclusivas quando o Assistente para Solução de Problemas do Exchange é usado para analisar o computador local em que o Exchange Server está instalado.

Tarefa | Sintoma ou função
Solução de Problemas de Desempenho do Exchange | Sintoma: O número de operações RPC por segundo é maior do que o esperado.
Solução de Problemas de Fluxo de Mensagens do Exchange | Todos os sintomas ao analisar a função de servidor Transporte de Borda do Exchange Server 2007 que não está configurado para usar o processo de inscrição do EdgeSync.
Gerenciamento de Recuperação de Banco de Dados do Exchange | A tarefa para reparar o banco de dados.


Como exibir um relatório anterior do Assistente para Solução de Problemas do Microsoft Exchange
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange >

Última modificação do tópico: 2007-02-16

Em vez de iniciar uma nova análise, talvez você deseje usar o Assistente para Solução de Problemas do Microsoft® Exchange para exibir um relatório de uma análise anterior.

Procedimento

Para exibir uma relatório anterior do Assistente para Solução de Problemas do Exchange

  1. Inicie o Assistente para Solução de Problemas do Exchange executando ExTrA.exe ou clicando no link apropriado no menu Iniciar.

  2. Decida se deseja fazer download das atualizações mais recentes, se houver.

  3. Na página Bem-vindo, selecione Selecione um arquivo de resultados para exibição.

  4. Selecione o relatório que deseja exibir na lista de relatórios armazenados localmente. A ferramenta cria a lista a partir dos arquivos armazenados em <unidade de sistema>\Documents and Settings\<usuário>\Application Data\Microsoft\ExTRA. Quando você clica em um relatório, a ferramenta exibe mais informações sobre o tamanho e o nome do arquivo do relatório, o rótulo de identificação e a versão da ferramenta que foi usada para coletar os dados. Você pode também importar um relatório de outro local clicando em Importar um arquivo de resultados no canto superior direito da página.

  5. Clique em Exibir um Relatório para exibir o relatório.


Como o Assistente para Solução de Problemas do Microsoft Exchange Server soluciona problemas
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange >

Última modificação do tópico: 2007-02-16

Geralmente, os artigos na Ajuda do Assistente para Solução de Problemas do Microsoft® Exchange Server, na seção denominada Microsoft Exchange Server Analyzer - Artigos, contêm as informações detalhadas sobre como uma ferramenta específica soluciona problemas do Exchange Server. Os artigos são agrupados de acordo com as seguintes áreas principais do ambiente do Exchange:

  • Active Directory

  • Cluster do Exchange

  • Exchange Server

  • Hardware

  • Rede

  • Protocolos

  • Armazenamento

  • Software de terceiros

  • Transporte

  • Preparação do Exchange Server 2007

Exemplos de artigos e seus conteúdos

A seguir, há dois exemplos de artigos do analisador e uma breve explicação de seus métodos para documentar em detalhes como a solução de problemas é realizada para um problema identificado.

Exemplo 1: Mecanismo de Roteamento: O parâmetro Configuration é padrão

Na categoria Transporte, para o artigo "Mecanismo de Roteamento: O parâmetro Configuration é diferente do padrão", as informações de solução de problemas iniciam com a ferramenta Microsoft Exchange Server Analyzer Tool lendo uma entrada do Registro para determinar se a configuração foi modificada a partir do padrão. O artigo contém uma explicação das possíveis causas da mensagem gerada e fornece a orientação corretiva. Isso inclui a recomendação do uso da ferramenta WinRoute para exibir informações de estado do link.

Os artigos do analisador também incluem indicadores de onde você pode ir para obter informações adicionais básicas e complementares sobre o problema.

Exemplo 2: Usuário identificado como um destino comum

O "Usuário identificado como um destino comum" está na categoria Transporte e é um dos artigos para solução de problemas de fluxo de mensagens. No artigo, é mostrado que o Assistente para Solução de Problemas do Exchange usa consultas específicas do WMI para obter informações sobre uma fila e aplica determinados limites para exibir um erro ou um aviso.

De maneira semelhante, em outros artigos, você pode obter detalhes sobre a lógica subjacente de cada erro e aviso que o Assistente para Solução de Problemas do Exchange exibe quando ele executa as etapas de solução de problemas.


Visão geral da ferramenta Microsoft Exchange Performance Troubleshooting Analyzer
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange >

Última modificação do tópico: 2007-02-16

A ferramenta Solução de Problemas de Desempenho do Microsoft® Exchange localiza e identifica os problemas relacionados ao desempenho que poderiam afetar os servidores executando o Exchange Server. Para descobrir esses problemas, a ferramenta examina várias configurações, logs e captura de dados ativos. Os tópicos a seguir fornecem mais informações sobre a Solução de Problemas de Desempenho do Exchange:

  • Instalando o Assistente para Solução de Problemas do Microsoft Exchange

  • Pré-requisitos para executar a Solução de Problemas de Desempenho do Microsoft Exchange

  • Permissões para a ferramenta Solução de Problemas de Desempenho do Microsoft Exchange

  • Iniciando a análise com a ferramenta Solução de Problemas de Desempenho do Microsoft Exchange

  • Compreendendo a saída da ferramenta Solução de Problemas de Desempenho do Microsoft Exchange

Seus comentários, sugestões e feedback sobre a ferramenta Solução de Problemas de Desempenho do Microsoft Exchange são bem-vindos.


Pré-requisitos para executar a Solução de Problemas de Desempenho do Microsoft Exchange
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange > Visão geral da ferramenta Microsoft Exchange Performance Troubleshooting Analyzer >

Última modificação do tópico: 2007-02-16

A ferramenta Solução de Problemas de Desempenho do Microsoft Exchange é executada em um modo baseado em servidor ou baseado em cliente.

Pré-requisitos

Para que a Solução de Problemas de Desempenho do Microsoft Exchange seja executada corretamente, o Microsoft .NET Framework 1.1 deve ser instalado no computador em que a ferramenta será executada.

Ambientes com suporte

A Solução de Problemas de Desempenho do Exchange pode ser executada nos seguintes ambientes:

  • Exchange Server 2003 (todos os service packs) no Microsoft Windows Server 2003

  • Exchange Server 2003 (todos os service packs) no Windows 2000 Service Pack (SP) 3 e versões posteriores

  • Exchange 2000 Server SP3 e versões posteriores no Windows 2000 SP3 e versões posteriores

Para obter mais informações

Para obter mais informações sobre como instalar a Solução de Problemas de Desempenho do Exchange, consulte Instalando o Assistente para Solução de Problemas do Microsoft Exchange.


Permissões para a ferramenta Solução de Problemas de Desempenho do Microsoft Exchange
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange > Visão geral da ferramenta Microsoft Exchange Performance Troubleshooting Analyzer >

Última modificação do tópico: 2007-02-15

A Solução de Problemas de Desempenho do Microsoft® Exchange só pode acessar o serviço de diretório do Active Directory® e o servidor que está executando o se você executar a ferramenta usando as credenciais que têm todas as permissões necessárias.

Para executar com êxito a Solução de Problemas de Desempenho do Exchange, você deve ter as seguintes permissões:

  • Usuário do Domínio ou permissões superiores no servidor de catálogo global especificado na etapa de conexões.

  • Membro do grupo Administradores local em cada servidor que está executando o Exchange a ser analisado. Essas permissões são necessárias para acessar o WMI (Instrumentação de Gerenciamento do Microsoft Windows®), o Registro e os dados de desempenho.

Se as credenciais de usuário conectado atualmente não possuírem todas as permissões para acessar o Active Directory e o servidor que está executando o Exchange, o nome do usuário, o domínio e a senha podem ser substituídos na ferramenta.

Para obter mais informações

Para obter mais informações sobre como instalar a Solução de Problemas de Desempenho do Exchange, consulte Instalando a Solução de Problemas de Desempenho do Microsoft Exchange.

Para obter mais informações sobre os pré-requisitos para executar a ferramenta, consulte Pré-requisitos para executar a Solução de Problemas de Desempenho do Microsoft Exchange.


Iniciando a análise com a ferramenta Solução de Problemas de Desempenho do Microsoft Exchange
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange > Visão geral da ferramenta Microsoft Exchange Performance Troubleshooting Analyzer >

Última modificação do tópico: 2007-02-16

A ferramenta Solução de Problemas de Desempenho do Microsoft® Exchange coleta dados de diversas fontes para produzir um aviso remediador recomendado. Os dados são coletados em etapas específicas e, em seguida, analisados. Dependendo dos resultados de cada etapa, uma outra coleta de dados pode ser necessária. Alguns dos dados, como o sintoma, exigem entrada do usuário. Outros dados são coletados automaticamente do servidor com problema.

Selecionando o sintoma

Como primeira etapa no processo de análise, a ferramenta Solução de Problemas de Desempenho do Exchange solicita o sintoma. Com base no sintoma, são executadas diferentes etapas de solução de problemas.

Sintomas

  • O número de operações RPC por segundo é maior do que o esperado.

    Selecione esse sintoma se o servidor que está executando o Exchange parecer mais ocupado do que o esperado. Como parte da solução do problema, a ferramenta Microsoft Exchange User Monitor (ExMon) controla as RPCs (chamadas de procedimento remoto) no Microsoft Office® Outlook e outros clientes MAPI. Ao detectar uma carga de usuário anormalmente alta, a ferramenta Solução de Problemas de Desempenho do Exchange isolará a origem do problema, como o usuário individual, que está causando o problema de desempenho do servidor.

  • Vários usuários estão reclamando de atrasos ao usar o Outlook ou estão vendo com freqüência a caixa de diálogo de RPC cancelável do Outlook.

    Selecione esse sintoma se os usuários estiverem vendo atrasos de tempo inaceitáveis ao executar operações com o cliente Outlook. Por exemplo, se existirem atrasos graves quando os usuários estiverem alternando de uma pasta para outra, como da Caixa de Entrada para o Calendário. Algumas versões do cliente Outlook mostram uma janela Solicitando dados se o servidor não responder a uma solicitação do cliente em tempo hábil. Esses problemas são normalmente atribuídos à carga do servidor ou a um afunilamento no próprio servidor. A ferramenta Solução de Problemas de Desempenho do Exchange isola a origem do afunilamento.

Uma lista de recomendações será mostrada na página de resultados quando a ferramenta Solução de Problemas de Desempenho do Exchange tiver concluído sua análise.

Coleta de Dados

Os repositórios de dados a seguir são usados para obter definições de configuração:

  • Serviço de diretório do Active Directory®

  • WMI (Instrumentação de Gerenciamento do Microsoft Windows®)

  • Registro

Além disso, a ferramenta captura dados atualizados para isolar a causa raiz dos problemas de desempenho. Os repositórios de dados a seguir são usados para exemplificar dados em tempo real:

  • Biblioteca PDH (Performance Data Helper)

  • Controla dados da ferramenta Microsoft Exchange Server User Monitor (ExMon) Tool

Para dados em tempo real, são feitas amostras dos contadores e logs com período de tempo determinado. Esse tipo de coleta pode demorar vários minutos para ser concluído.

Para obter mais informações

Para obter mais informações sobre a ferramenta Solução de Problemas de Desempenho do Exchange, consulte Visão geral da ferramenta Microsoft Exchange Performance Troubleshooting Analyzer.

Para obter mais informações sobre a saída da ferramenta, consulte Compreendendo a saída da ferramenta Solução de Problemas de Desempenho do Microsoft Exchange.


Compreendendo a saída da ferramenta Solução de Problemas de Desempenho do Microsoft Exchange
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange > Visão geral da ferramenta Microsoft Exchange Performance Troubleshooting Analyzer >

Última modificação do tópico: 2007-02-16

A ferramenta Solução de Problemas de Desempenho do Microsoft® Exchange produz um relatório que exibe os resultados dos dados reunidos por ela durante a análise do servidor. Você pode selecionar entre cinco tipos de exibições:

  • Lista de Problemas Críticos Exibe a causa raiz dos problemas e outros fatores que podem afetar o desempenho

  • Exibição Detalhada Exibe uma estrutura em árvore que contém todos os dados coletados durante a análise

  • Lista Completa de Problemas Exibe as causas raiz e outras sugestões para resolver os problemas de desempenho

  • Log do Tempo de Execução Exibe o status de processamento interno da ferramenta

  • Exibição Resumida Exibe uma estrutura em árvore que contém todas as recomendações

Na Lista de Problemas Críticos e na Lista Completa de Problemas, você pode clicar em um erro ou aviso de problema para obter uma explicação. Em seguida, você pode clicar em Mais informações sobre este problema e como resolvê-lo para obter informações mais detalhadas.

Na janela de relatório, você pode escolher imprimir ou exportar os dados coletados. Os formatos de exportação com suporte são XML, HTML e CSV (valor separado por vírgula).

Observação:
Todos os dados reunidos são mantidos em um arquivo de saída XML localizado na <unidade do sistema>\Documents and Settings\<usuário>\Application Data\Microsoft\ExPTA.

Em alguns casos, você poderá visualizar o relatório a partir de uma análise anterior em vez de iniciar uma nova análise. Para aprender a exibir um relatório anterior, consulte Como exibir um relatório anterior do Assistente para Solução de Problemas do Microsoft Exchange.


Visão geral da ferramenta Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange >

Última modificação do tópico: 2007-02-16

A Solução de Problemas de Fluxo de Mensagens do Microsoft® Exchange é uma ferramenta de diagnóstico que ajuda os clientes a executarem as seguintes funções:

  • Iniciar com os sintomas de fluxo de mensagens e direcionar os clientes para o caminho correto da solução dos problemas.

  • Fornecer fácil acesso às várias fontes de dados necessárias para solucionar problemas com fluxo de mensagens.

  • Diagnosticar automaticamente os dados recuperados e apresentar uma análise das possíveis causas raiz.

  • Sugerir ações corretivas.

  • Fornecer orientação para ajudar os usuários a diagnosticar manualmente os dados onde e quando a automação não for possível.

Seus comentários, sugestões e feedback são bem-vindos na Solução de Problemas de Fluxo de Mensagens do Microsoft® Exchange. Envie-nos seus comentários da seguinte maneira:

  • Grupos de notícias públicos da Microsoft Membros da equipe de desenvolvimento da Solução de Problemas de Fluxo de Mensagens do Exchange monitoram freqüentemente Grupos de Notícias no Exchange Server e no site do Outlook, em http://go.microsoft.com/fwlink/?linkid=14926.

  • Para obter mais informações sobre como participar neste e em outros grupos de notícias da Microsoft, consulte o site de Microsoft Exchange Analyzers na web, em http://go.microsoft.com/fwlink/?linkid=33938, e o site Microsoft Product Support Newsgroups (em inglês) na Web, em http://go.microsoft.com/fwlink/?LinkId=50219.


Pré-requisitos para executar a ferramenta de Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange

Pré-requisitos para executar a ferramenta de Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange |
 | Consulte também
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange > Visão geral da ferramenta Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange >

Última modificação do tópico: 2006-08-11

A ferramenta Solução de Problemas de Fluxo de Mensagens do Microsoft® Exchange pode ser executada em um modo baseado em cliente ou em servidor.

Os computadores na organização do Exchange precisam atender a diversos pré-requisitos para executar corretamente a Solução de Problemas de Fluxo de Mensagens do Microsoft® Exchange. Se esses requisitos não forem atendidos, a ferramenta ainda funcionará em muitos casos, mas poderá não executar com funcionalidade total ou executar em um nível de desempenho redizido.

Este tópico contém informações sobre os pré-requisitos e os ambientes aceitos para a execução da ferramenta Solução de Problemas de Fluxo de Mensagens do Microsoft® Exchange.

Pré-requisitos

Para a execução correta da Solução de Problemas de Fluxo de Mensagens do Exchange, o Microsoft .NET Framework 1.1 deve estar instalado no computador onde a ferramenta será executada.

Ambientes com suporte

Importante:
Se a topologia do seu Exchange Server englobar o Exchange Server 2007 (incluindo versões de pré-lançamento), talvez a Solução de Problemas de Fluxo de Mensagens do Exchange não funcione corretamente ou algumas funções não estejam disponíveis.

A Solução de Problemas de Fluxo de Mensagens do Exchange pode ser executada nos seguintes ambientes:

  • Exchange Server 2003 (todos os service packs) no Microsoft Windows Server 2003

  • Exchange Server 2003 (todos os service packs) no Windows 2000 Server Service Pack SP3 e versões posteriores

  • Exchange 2000 Server SP3 e versões posteriores, no Windows 2000 Server SP3 e versões posteriores

Observação:
Algumas funções da Solução de Problemas de Fluxo de Mensagens do Exchange poderão estar disponíveis somente com o Exchange Server 2003. Isso ocorre porque o Exchange 2000 Server e o Windows Server 2000 têm menos interfaces para recuperação de dados do que o Exchange Server 2003 e o Windows Server 2003.

Consulte também

Conceitos

Permissões para a ferramenta Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange

© 2007 Microsoft Corporation. Todos os direitos reservados.


Permissões para a ferramenta Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange

Permissões para a ferramenta Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange |
 | Consulte também
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange > Visão geral da ferramenta Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange >

Última modificação do tópico: 2007-02-15

A Solução de Problemas de Fluxo de Mensagens do Microsoft® Exchange só pode acessar o serviço de diretório do Active Directory® e os servidores Exchange se você executar a ferramenta com credenciais que tenham todas as permissões necessárias.

Permissões

Você deve ter as seguintes permissões para executar com êxito a Solução de Problemas de Fluxo de Mensagens do Exchange:

  • Administrador de Domínio ou um membro do grupo Builtin\Administrators no servidor do Active Directory, para enumerar informações do Active Directory e chamar os provedores de WMI (Instrumentação de Gerenciamento do Microsoft Windows®) em servidores de controladores de domínio e de catálogos globais.

  • Grupo Membro de Administradores Local em cada servidor Exchange para chamar os provedores de WMI e acessar o Registro e a metabase.

  • Delegadas pelo menos as permissões do Exchange Somente para Exibição na organização do Exchange.

Se você fizer o logon no computador onde vai executar a Solução de Problemas de Fluxo de Mensagens do Exchange com uma conta que não tenha permissões suficientes, deverá definir credenciais para as contas que usará, na página Inserir Informações do Servidor e do Usuário da ferramenta. Clique em Mostrar opções avançadas de logon para expandir as opções. Você pode entrar em apenas uma conta. Portanto, verifique se a conta tem todas as permissões necessárias.

Consulte também

Conceitos

Pré-requisitos para executar a ferramenta de Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange

© 2007 Microsoft Corporation. Todos os direitos reservados.


Iniciando a análise com a Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange

Iniciando a análise com a Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange |
 | Consulte também
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange > Visão geral da ferramenta Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange >

Última modificação do tópico: 2006-08-10

A ferramenta Solução de Problemas de Fluxo de Mensagens do Microsoft® Exchange coleta dados de diferentes fontes para gerar a orientação para o aviso remediador recomendado. Os dados são coletados em etapas específicas e, em seguida, analisados. Dependendo dos resultados de cada etapa, pode ser necessário coletar dados adicionais. Alguns dos dados, como o sintoma, exigem entrada do usuário. Outros dados são coletados automaticamente do servidor com problema.

Selecionando o sintoma

Como primeira etapa no processo de análise, Solução de Problemas de Fluxo de Mensagens do Exchange pergunta qual é o sintoma que está sendo detectado. Com base no sintoma, são executadas diferentes etapas de solução de problemas.

Sintomas

  • Os usuários estão reclamando que recebem notificações de falha na entrega ao enviar mensagens.

    Selecione esse sintoma se repercussão de mensagens e notificações de falha na entrega forem retornadas aos remetentes. As notificações de falha na entrega podem ser retornadas de fora da organização corporativa do Exchange ou de dentro da organização do Exchange. A Solução de Problemas de Fluxo de Mensagens do Exchange tentará orientar os usuários, determinando as etapas corretas de solução de problemas desse sintoma. Saiba que, como é possível que as causas principais estejam fora do Exchange Server, a orientação para solucionar o problema é muito importante.

  • As mensagens procedentes de remetentes externos por meio da Internet são atrasadas ou não são recebidas por alguns destinatários.

    Esse e o próximo sintoma são semelhantes. Selecione esse sintoma se as mensagens não estiverem chegando na organização corporativa do Exchange Server ou se não estiverem chegando por meio dos servidores de gateway não-Exchange no limite. A Solução de Problemas de Fluxo de Mensagens do Exchange examinará tanto a parte interna da organização do Exchange Server, quanto o gateway.

  • As mensagens destinadas a destinatários externos por meio da Internet são atrasadas ou não são enviadas a alguns destinatários.

    Selecione esse sintoma se as mensagens que supostamente deveriam ser entregues fora da organização corporativa do Exchange Server permanecerem nessa organização ou se elas não atravessarem os servidores de gateway não-Exchange no limite. A Solução de Problemas de Fluxo de Mensagens do Exchange examinará tanto a parte interna da organização do Exchange Server, quanto o gateway (como ocorreu no sintoma anterior).

  • As mensagens estão sendo copiadas em backup em uma ou mais filas em um servidor

    Selecione esse sintoma se as mensagens continuarem nas filas do Exchange Server, principalmente nas Filas de Entrega Remota, Aguardando Pesquisa de Diretório e Entrega Local. O backup afeta as mensagens roteadas na mesma organização do Exchange Server e as mensagens vindas de e enviadas para a Internet, dependendo do caminho por onde as mensagens forem roteadas. Trabalhar nesse sintoma pode solucionar o segundo e o terceiro problemas nessa lista de sintomas.

  • Os usuários estão relatando que o backup das mensagens é feito em suas Caixas de Saída (somente no Exchange Server 2007).

    Selecione esse sintoma se as mensagens permanecerem no servidor de caixa de correio do usuário e não estiverem sendo transferidas para outros servidores. A Solução de Problemas de Fluxo de Mensagens do Exchange tentará verificar as funções Caixa de Correio e Transport de Hub.

Depois de escolher um sintoma, você será solicitado a informar o servidor e o usuário, e, em seguida, a análise começará. Quando a Solução de Problemas de Fluxo de Mensagens do Exchange concluir a análise, será apresentada uma lista de recomendações na página de resultados.

Coleta de Dados

A Solução de Problemas de Fluxo de Mensagens do Exchange coleta dados de várias fontes. Os repositórios de dados a seguir são usados para obter definições de configuração:

  • Serviço de diretório do Active Directory®

  • WMI (Instrumentação de Gerenciamento do Microsoft Windows®)

  • Registro

Além disso, a ferramenta obtém dados reais para isolar a causa principal dos problemas de fluxo de mensagens. A biblioteca PDH (Auxiliar de Dados de Desempenho) do repositório de dados é usada para obter amostras de dados em tempo real.

Para dados em tempo real, são feitas amostras dos contadores e logs com período de tempo determinado. Esse tipo de coleta pode demorar vários minutos para ser concluído.

Consulte também

Conceitos

Visão geral da ferramenta Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange
Noções básicas sobre a saída da Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange

© 2007 Microsoft Corporation. Todos os direitos reservados.


Noções básicas sobre a saída da Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange

Noções básicas sobre a saída da Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange |
 | Consulte também
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange > Visão geral da ferramenta Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange >

Última modificação do tópico: 2007-02-16

A Solução de Problemas de Fluxo de Mensagens do Microsoft® Exchange gera relatórios que exibem os resultados dos dados coletados pela ferramenta durante a análise do servidor. Você pode selecionar três tipos de relatórios:

  • Relatórios de Lista incluem:

    • Visão Geral Exibe o status geral dos servidores investigados

    • Causas Raiz Exibe as possíveis causas raiz dos problemas identificados

    • Problemas no Fluxo de Mensagens Exibe os problemas críticos que podem afetar o fluxo de mensagens

    • Outros Erros Exibe os problemas de fluxo não relacionados a mensagens

    • Aviso Exibe questões geralmente não recomendadas

    • Recomendações Exibe as recomendações conhecidas

    • Itens Informativos Exibe itens não relacionados a problemas

  • Relatórios em Árvore incluem:

    • Exibição Detalhada Exibe uma estrutura em árvore contendo todos os dados coletados durante a análise

    • Exibição Resumida Exibe uma estrutura em árvore contendo todas as causas raiz, erros, avisos, itens de interesse e recomendações

  • Outros Relatórios incluem:

    • Log do Tempo de Execução Exibe o status de processamento interno da ferramenta

No tipo de relatório Relatórios de Lista, você pode clicar em qualquer erro ou problema do aviso para ver uma explicação. Em seguida, clique em Mais informações sobre este problema e como resolvê-lopara obter informações mais detalhadas.

Na janela de relatório, você pode escolher imprimir ou exportar os dados coletados. Os formatos de exportação com suporte são XML, HTML e CSV (valor separado por vírgula).

Observação:
Todos os dados coletados são mantidos em um arquivo XML de saída, localizado em <unidade do sistema>\Documents and Settings\<usuário>\Application Data\Microsoft\ExMFA.

Consulte também

Conceitos

Iniciando a análise com a Solução de Problemas de Fluxo de Mensagens do Microsoft Exchange

© 2007 Microsoft Corporation. Todos os direitos reservados.


Visão geral do Gerenciamento de Recuperação de Banco de Dados do Microsoft Exchange
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange >

Última modificação do tópico: 2007-02-16

O Gerenciamento de Recuperação de Banco de Dados do Microsoft® Exchange procura nos arquivos de log de transações e de banco de dados do Exchange Server problemas que afetem a recuperação do banco de dados. A ferramenta relata arquivos de log ausentes ou danificados e recomenda etapas que você pode seguir para colocar o banco de dados em um estado montável e normal.

O Gerenciamento de Recuperação de Banco de Dados do Exchange contém estes recursos:

  • Um solucionador de problemas de montagem de bancos de dados causados por condições que impedem a repetição bem-sucedida do log de transações.

  • Um assistente para mover arquivos excessivos do log de transações com segurança para resolver condições de "unidade de log cheia".

  • Um filtro e visualizador do log de eventos que permite visualizar e classificar com facilidade eventos relacionados com bancos de dados do Exchange.

  • Apenas para o Exchange 2007, um gerenciador de Grupo de Armazenamento de Recuperação para criação e remoção de Grupos de Armazenamento de Recuperação. O gerenciador pode também mesclar o conteúdo de caixas de correio de volta para caixas de correio originais ou de arquivamento.

Seus comentários, perguntas e sugestões sobre o Gerenciamento de Recuperação de Banco de Dados do Exchange são bem-vindos. Envie-nos seu feedback, como descrito a seguir:

  • Grupos de notícias públicos da Microsoft Membros da equipe de desenvolvimento do Gerenciamento de Recuperação de Banco de Dados do Exchange geralmente monitoram o grupo de notícias microsoft.public.exchange.tools em news.microsoft.com. Para obter informações sobre como participar deste e de outros grupos de notícias da Microsoft, consulte o site Microsoft Product Support Newsgroups (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=50219).

  • Comentários da documentação do Gerenciamento de Recuperação de Banco de Dados do Exchange Se você tiver algum comentário ou pergunta sobre a documentação e os artigos incluídos com o Gerenciamento de Recuperação de Banco de Dados do Exchange, envie seus comentários para extoolfb@microsoft.com.


Pré-requisitos para executar o Gerenciamento de Recuperação de Banco de Dados do Microsoft Exchange
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange > Visão geral do Gerenciamento de Recuperação de Banco de Dados do Microsoft Exchange >

Última modificação do tópico: 2007-02-16

O Gerenciamento de Recuperação de Banco de Dados do Microsoft® Exchange é executado em dois modos: Detecção Automática ou Entrada Manual. No modo Detecção Automática, o Gerenciamento de Recuperação de Banco de Dados do Exchange pode acessar as informações de configuração do serviço de diretório do Microsoft Active Directory® de um servidor Exchange e localizar automaticamente arquivos de bancos de dados e de log de transações nos locais dos caminhos configurados. No modo Entrada Manual, é possível especificar caminhos de arquivos diretos para os arquivos de bancos de dados e de log de transações.

Pré-requisitos

  • No modo Detecção Automática, você deve ter as permissões necessárias no Active Directory para ler informações de configuração do Exchange e deve ter permissões de leitura e gravação no servidor Exchange para as pastas onde estão armazenados os dados do Exchange.

  • Para que o Gerenciamento de Recuperação de Banco de Dados do Exchange seja executado corretamente, será necessário que o .NET Framework 1.1 esteja instalado no computador em que este componente será executado.

  • Você pode executar o Gerenciamento de Recuperação de Banco de Dados do Exchange em computadores que estão executando o Microsoft Windows® 2000 Server, Microsoft Windows Server® 2003 e Microsoft Windows XP.

Ambientes com suporte

Você pode executar o Gerenciamento de Recuperação de Banco de Dados do Exchange Server nos seguintes ambientes:

  • Exchange 2000 Server SP3 e posterior no Windows 2000 Server SP3 e posterior

  • Exchange Server 2003 (todos os service packs) no Windows 2000 Server SP3 e posterior

  • Exchange Server 2003 (todos os service packs) no Windows Server 2003


Efeito sobre o Desempenho da Ferramenta Microsoft Exchange Disaster Recovery Analyzer
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange > Visão geral do Gerenciamento de Recuperação de Banco de Dados do Microsoft Exchange >

Última modificação do tópico: 2007-02-16

O Gerenciamento de Recuperação de Banco de Dados do Microsoft® Exchange tem um efeito mínimo sobre o desempenho do serviço de diretório do Active Directory® ou sobre o desempenho de um servidor Exchange. O Gerenciamento de Recuperação de Banco de Dados do Exchange lê as informações de cabeçalho no início do banco de dados e os arquivos de log de transações e verifica a integridade dos arquivos de log. O Gerenciamento de Recuperação de Banco de Dados do Exchange opera exclusivamente em modo somente leitura e não altera arquivos de log de transações ou do banco de dados.


O Centro de Tarefas
Visão geral do Assistente para Solução de Problemas do Microsoft Exchange > Visão geral do Gerenciamento de Recuperação de Banco de Dados do Microsoft Exchange >

Última modificação do tópico: 2007-02-16

A página Centro de Tarefas é o núcleo do Microsoft® Exchange Database Recovery Management. O Centro de Tarefas é o local onde você seleciona o sintoma ou a tarefa que deseja tratar. Para acessar a página Centro de Tarefas, escolha um servidor no qual trabalhar ou selecione o modo manual.

As opções exibidas no Centro de Tarefas dependem do servidor escolhido. As opções que não são relevantes não são exibidas. Por exemplo, se você decidir trabalhar com um servidor Exchange Server 2003, as funções exclusivas do Exchange Server 2007 ficarão ocultas.

As funções a seguir estão disponíveis no Centro de Tarefas:

  • Solucionar Problemas de Montagem de Banco de Dados

    Esse solucionador de problemas lê um log de aplicativo do servidor Exchange para fazer um diagnóstico inicial dos problemas no servidor. Se vários problemas forem encontrados, você poderá selecionar o problema que deseja tratar primeiro. É feita uma análise adicional em seguida para confirmar o problema e ajudar a corrigi-lo.

  • Analisar Espaço de Unidade de Log

    Este assistente verifica o espaço disponível para arquivos de log de transações em cada grupo de armazenamento de um servidor, e ajudará a mover logs para um local de backup, se o sistema tiver pouco espaço.

    Se um grupo de armazenamento do Exchange Server estiver sem espaço em disco para arquivos de log de transações, os bancos de dados serão encerrados. Não será possível iniciar os bancos de dados novamente enquanto você não corrigir o problema de espaço em disco. No caso de exclusão de arquivos de log incorretos, talvez não seja mais possível inicializar os bancos de dados. O Gerenciamento de Recuperação de Banco de Dados do Exchange determinará quais arquivos de log podem ser movidos com segurança e os moverá para um local de backup, em outra unidade ou servidor. Não exclua os logs movidos enquanto não fizer com êxito um novo backup completo de todos os bancos de dados no grupo de armazenamento.

  • Mostrar Logs de Eventos Relacionados ao Banco de Dados

    Vários eventos de aviso e erro no log de aplicativo podem estar associados a um problema de banco de dados. Pode ser difícil descobrir se os eventos relacionados procedem de acordo com o que revelam. Essa função do analisador filtra os eventos relacionados ao banco de dados do Exchange e os apresenta em um formato fácil de ser verificado e classificado.

  • Gerenciador de Grupo de Armazenamento de Recuperação do Exchange 2007

    O Console de Gerenciamento do Exchange 2007 não inclui os recursos de gerenciamento do Grupo de Armazenamento de Recuperação. Em vez disso, o Gerenciamento do Grupo de Armazenamento de Recuperação pode ser executado na linha de comando do Windows PowerShell ou no Gerenciador de Grupo de Armazenamento de Recuperação, nesta ferramenta.

    O Gerenciador de Grupo de Armazenamento de Recuperação é aperfeiçoado na interface do Exchange 2003 para gerenciamento dos Grupos de Armazenamento de Recuperação, unificando todas as tarefas de gerenciamento em um único local. Além disso, oferece suporte para cópia de conteúdo de caixa de correio do Grupo de Armazenamento de Recuperação novamente na caixa de correio original ou em uma caixa de correio diferente, sem exigir o uso de um arquivo .pst intermediário. A função de mesclagem também pode ser usada para copiar o conteúdo de várias caixas de correio em uma única caixa de correio de arquivamento.

  • Reparo do Banco de Dados

    Este assistente executa automaticamente o reparo do banco de dados, a desfragmentação do banco de dados e o Isinteg em um banco de dados danificado, e tenta restaurá-lo a um estado consistente. Este recurso só estará disponível quando a ferramenta for executada em relação ao computador local.

  • Redefinir Número de Geração de Logs

    Este assistente move os arquivos de log de transações existentes para um local de backup, o que permite a montagem dos bancos de dados com novos números de geração de logs. Este assistente exige que todos os bancos de dados no grupo de armazenamento sejam desmontados, e está disponível somente para o Exchange 2000 Server e Exchange Server 2003.


Microsoft Exchange Server Analyzer - Artigos

Última modificação do tópico: 2006-10-06

Os artigos desta seção correspondem às regras e mensagens resultantes geradas pelos seguintes Microsoft® Exchange Analyzers:

  • Exchange Best Practices Analyzer

  • Assistente para Solução de Problemas do Exchange

O Assistente para Solução de Problemas do Exchange fornece acesso às seguintes funcionalidades:

  • Solução de Problemas de Desempenho do Exchange

  • Solução de Problemas de Bancos de Dados do Exchange

  • Gerenciamento de Recuperação de Banco de Dados do Exchange

  • Solução de Problemas de Fluxo de Mensagens do Exchange

Cada artigo descreve uma única mensagem de erro, aviso ou configuração não padrão, que pode ser detectada pelo Exchange Server Analyzer.

A página da Web dos Microsoft Exchange Analyzers em http://go.microsoft.com/fwlink/?linkid=34707 contém downloads para as versões atuais do Exchange Best Practice Analyzer e do Assistente para Solução de Problemas do Exchange. Além disso, a página contém informações sobre requisitos do sistema e um link a um grupo de notícias para discussão sobre os analisadores.

Se estiver executando em um ambiente em que não possa usar o recurso de atualização automática do Exchange Best Practices, você poderá acessar a página da Web do Microsoft Exchange Best Practices Analyzer Web Update Pack em http://go.microsoft.com/fwlink/?linkid=34290. Nessa página você poderá baixar os arquivos de Ajuda e configuração mais recentes.

Observação:
Se as atualizações estiverem sendo aplicadas automaticamente, não será necessário usar esse download.


Active Directory
Microsoft Exchange Server Analyzer - Artigos >

Última modificação do tópico: 2005-11-17

Os artigos desta seção fornecem detalhes sobre o que a ferramenta Microsoft® Exchange Server Analyzer está avaliando em relação ao serviço de diretório do Active Directory®. Além disso, esses artigos descrevem as ações que podem ser executadas no Active Directory para resolver erros, avisos e configurações não padrão detectados pelo Exchange Server Analyzer.


O servidor do Active Directory Connector está desativado ou inacessível.
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer usa RPCs (chamadas de procedimento remoto) para ler o valor da cadeia de caracteres CurrentVersion da seguinte chave de Registro no servidor ADC (Active Directory Connector):

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Em um computador executando o Microsoft Windows® 2000 Server, o valor esperado para a cadeia de caracteres CurrentVersion é 5.0. Em um computador que executa o Microsoft Windows Server™ 2003, o valor esperado é 5.2.

Se o Exchange Server Analyzer não conseguir ler esse valor de Registro por alguma razão, um erro será exibido.

Para corrigir esse erro

  1. Verifique se o servidor ADC foi iniciado e está conectado à rede.

  2. Use o comando PING para verificar se o servidor ADC está acessível.

  3. Se houver um firewall, verifique se as portas RPC estão bloqueadas.

  4. Verifique se o serviço de Registro Remoto do servidor ADC foi iniciado.

  5. Verifique as permissões da conta na qual o Exchange Server Analyzer está sendo executado para garantir que ela tenha permissões suficientes para ler o Registro do servidor ADC.

Para obter mais informações sobre como solucionar problemas de conectividade de rede, consulte o seguinte:

  • artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56285)


O servidor Active Directory Connector não está executando nenhuma licença de conexão e é candidato à remoção.
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchChildSyncAgreements, que representa as licenças de conexão que estão sendo executadas no servidor ADC (Active Directory Connector). Esse atributo é uma cadeia de caracteres de vários valores e é definido no seguinte objeto do Active Directory: CN=Active Directory Connector (ServerName),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com

O Analisador do Exchange Server recupera o número de entradas (contagem) nesse atributo. Se a contagem for 0, isso indica que nenhuma licença de conexão está sendo executada e um aviso será exibido.

Se for determinado que todas as licenças de conexão necessárias estão sendo executadas em outros servidores ADC, o serviço ADC deste servidor deverá ser removido ou desabilitado. Executar o serviço ADC sem nenhuma licença de conexão não causa problemas. No entanto, é recomendável que não sejam executados serviços desnecessários. Portanto, você deve desabilitar o serviço ADC ou desinstalá-lo desse servidor ADC.

Para corrigir esse aviso

  1. Para desabilitar o serviço ADC no servidor executando o serviço ADC, clique com o botão direito em Meu Computador na área de trabalho e clique em Gerenciar.

  2. Expanda o nó Serviços e Aplicativos e clique no nó Serviços.

  3. No painel da direita, clique com o botão direito em Microsoft Active Directory Connector e clique em Propriedades.

  4. Altere o Tipo de Inicialização para Desabilitado. Na próxima inicialização do computador, o serviço ADC não será iniciado.

  5. Clique em Aplicar e em OK.

Se você decidir desinstalar o serviço ADC, poderá usar o CD do Microsoft Exchange 2000 Server ou do Exchange Server 2003. Vá para a pasta \ADC\I386 e clique duas vezes no programa Setup.exe. Siga as instruções para desinstalar o serviço ADC.

Para obter mais informações sobre o Active Directory Connector, consulte os seguintes webcasts de Suporte da Microsoft:

  • " Webcast de Suporte: Introdução ao Active Directory Connector" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300)

  • " Webcast de Suporte: Microsoft Advanced Active Directory Connector" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221)

  • Para obter mais informações sobre como instalar e configurar o Active Directory Connector, consulte o artigo 312632 da Base de Dados de Conhecimento da Microsoft, "COMO: Instalar e configurar o Active Directory Connector no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632).


O servidor Active Directory Connector não está executando o Service Pack mais recente para Windows 2000 Server
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_OperatingSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave ServicePackMajorVersion no servidor ADC (Active Directory Connector). O Exchange Server Analyzer também examina a seguinte entrada do Registro para conhecer a versão do Windows em execução no servidor ADC:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se o Exchange Server Analyzer detectar que o servidor ADC está executando um sistema operacional Microsoft Windows 2000 Server mas não o Service Pack 4 (SP4) para Windows 2000 Server, será exibido um aviso.

Como prática recomendada, a Microsoft recomenda executar os service packs mais recentes de todo o software na implantação do Exchange, inclusive nos servidores ADC.

Para corrigir esse erro

  1. Atualize este servidor ADC e todos os outros que estiverem executando um sistema operacional Windows 2000 Server para o SP4, mais hotfixes e atualizações mais recentes do Windows Update.

  2. Atualize todos os outros computadores do Exchange Server executando um sistema operacional Windows 2000 Server com o service pack e as distribuições mais recentes.

Para obter mais informações sobre como obter e instalar service packs dos sistemas operacionais Windows Server 2000, consulte http://go.microsoft.com/fwlink/?LinkId=18353.

Para obter mais informações sobre como obter e instalar service packs e distribuições do Exchange Server, consulte http://go.microsoft.com/fwlink/?LinkId=21573.


O servidor do Conector do Active Directory pode estar sobrecarregado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchChildSyncAgreements, que representa as licenças de conexão que estão sendo executadas no servidor ADC (Conector do Active Directory). Esse atributo é uma cadeia de caracteres de vários valores e é definido no seguinte objeto do Active Directory: CN=Active Directory Connector (ServerName),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com

O Analisador do Exchange Server recupera o número de entradas (contagem) nesse atributo. Se a contagem for superior a 80, será exibido um aviso.

Recomenda-se executar menos de 80 licenças de conexão por servidor ADC. Se houver servidores ADC adicionais que não estejam hospedando o número máximo recomendado de licenças de conexão, mova algumas das licenças de conexão desse servidor para o outro servidor ADC. Se você não tiver outros servidores ADC, instale o programa do ADC incluído no Microsoft Exchange 2000 Server ou no Exchange Server 2003 em outro computador que esteja executando o Microsoft Windows® 2000 Server ou o Windows Server™ 2003.

Observe que quando você move uma licença de conexão de um servidor ADC para outro, os atributos essenciais da licenção de conexão específica não se alteram. Por exemplo, os contêineres de origem e de destino usados para replicação, bem como os dados configurados para replicar, permanecem inalterados. Quando você move uma licença de conexão, somente o servidor ADC pode executar as alterações da licença de conexão.

Para corrigir esse aviso

  1. Clique em Iniciar, em Programas, aponte para Ferramentas Administrativas e clique em Gerenciamento do Conector do Active Directory para abrir o Console de Gerenciamento do ADC.

  2. O painel esquerdo do console MMC mostra uma lista de servidores que executam o serviço ADC. Selecione o ADC para o servidor em que a licença de conexão que você deseja mover está localizada.

  3. O painel de detalhes do console MMC mostra as licenças de conexão hospedadas no servidor ADC selecionado.

  4. Clique com o botão direito na licença de conexão que você deseja mover e clique em Propriedades.

  5. Na guia Geral, na lista suspensa Selecionar um servidor para executar a Licença de Conexão, selecione o servidor no qual deseja que a licença de conexão seja executada e clique em OK.

  6. Em Conectar como (Windows Server), digite o nome da conta do serviço ADC e senha e clique em OK.

  7. Em Conectar como (Exchange Server), digite a conta do serviço ADC e senha e clique em OK.

Para obter mais informações sobre a movimentação de licenças de conexão, consulte o artigo 326060 da Base de Dados de Conhecimento da Microsoft, "XADM: Como mover uma licença de conexão para outro servidor" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=326060).

Para obter mais informações sobre a instalação do programa Exchange 2000 Server ADC em outro servidor, consulte o artigo 312632 da Base de Dados de Conhecimento da Miscrosoft "Como instalar e configurar o Conector do Active Directory no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312632).

Para obter mais informações sobre a instalação do programa Exchange Server 2003 ADC em outro servidor, consulte o Guia de Implantação do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).


Atualização do software Active Directory Connector necessária
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-10-10

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version para o arquivo do ADC (Active Directory Connector), Adc.exe. A chave Version do WMI indica o número de compilação deste arquivo.

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msDS-Behavior-Version do objeto de floresta no Active Directory, Configurações NTDS. Esse valor indica o nível funcional de floresta do Active Directory. Os valores válidos para o atributo msDS-Behavior-Version são mostrados na tabela a seguir.

Valor | Nível funcional de floresta
0 | Microsoft Windows 2000 Server misto
1 | Windows Server™ 2003 provisório
2 | Windows Server 2003 nativo

Se o Exchange Server Analyzer considerar que o número de compilação para Adc.exe é inferior a 6.0.6615.0 em um computador que executa o Exchange Server em uma floresta do Active Directory no modo nativo ou provisório do Windows Server 2003, será exibido um erro. Esse erro indica que uma versão do Exchange 2000 Server do programa ADC está sendo executada em um nível de floresta incompatível do Active Directory do Windows Server 2003. Para que esse problema seja resolvido, é necessário atualizar o programa ADC (Active Directory Connection) do Exchange.

Executar uma versão mais antiga do ADC em um nível de funcionalidade de floresta nativo ou misto pode ocasionar atualizações incompletas de diretório e perda de dados. É recomendável que você faça a atualização para a última versão do ADC do Exchange Server 2003 em todos os computadores da organização.

Você pode baixar a versão mais recente do ADC, juntamente com o Exchange Server 2003 Service Pack mais recente, da página Downloads para o Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097). Pode também instalar a versão final do Exchange Server 2003 do ADC do CD do Exchange Server.

Para atualizar para a versão mais recente do ADC

  1. No seu servidor que está executando a versão mais antiga do ADC, clique em Iniciar, Executar e digite E:\setup\adc\i386\setup.exe, onde E é o local do download do service pack do Exchange Server.

  2. Na página Bem-vindo ao Assistente para Instalação do Conector do Active Directory, clique em Avançar.

  3. Na página Instalação Anterior Detectada, clique em Reinstalar para atualizar o ADC.

  4. Na página Concluindo o Assistente para Instalação do Conector do Active Directory, clique em Avançar.

Para obter mais informações sobre como o nível funcional de floresta afeta o ADC, consulte o artigo 825916 da Base de Dados de Conhecimento Microsoft, "O Exchange 2000 Active Directory Connector não replica com êxito as alterações feitas na associação de grupo no Windows Server 2003 Active Directory nos níveis funcionais de floresta 1 ou 2" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=825916) (página em inglês).

Para obter mais informações sobre níveis funcionais de domínio e de floresta, consulte o artigo 322692 da Base de Dados de Conhecimento, "Como aumentar os níveis funcionais de domínio e de floresta no Windows Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322692) (página em inglês).


Esta floresta do Active Directory foi configurada para Hosted Exchange
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo LinkID no objeto de atributo do esquema Global-Address-List . O objeto Global-Address-List é usado em um contêiner do Exchange para armazenar o nome distinto de uma GAL (lista de endereços globais) recém-criada.

Se o Analisador do Exchange Server detectar que o valor do atributo LinkID do objeto da Global-Address-List está definido como um valor de 4.048, exibirá uma mensagem de configuração não padrão. Um valor igual a 4.048 indica que a floresta do Active Directory está configurada para um ambiente Hosted Exchange.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre ambientes do Hosted Exchange, consulte os seguintes artigos:

  • "Informações para Hosters" (http://go.microsoft.com/fwlink/?LinkId=46307)

  • "Chapter 23 - Hosted Service Environments" no Exchange Server 2000 Resource Kit (em inglês) (http://go.microsoft.com/fwlink/?LinkId=46326)


Servidor do Active Directory desativado ou inacessível
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer usa as chamadas de procedimento remoto (RPCs) para ler o valor da cadeia de caracteres CurrentVersion da seguinte chave do Registro no servidor de diretório do Active Directory®:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Em um computador executando o Microsoft Windows® 2000 Server, o valor esperado para a cadeia de caracteres CurrentVersion é 5.0. Em um computador executando o Windows Server™ 2003, o valor esperado é 5.2.

Se o Exchange Server Analyzer não conseguir ler esse valor de Registro por alguma razão, um erro será exibido.

Para corrigir esse erro

  1. Verifique se o servidor de diretório foi iniciado e está conectado à rede.

  2. Use o comando PING para determinar se o servidor de diretório está acessível.

  3. Se houver um firewall, verifique se as portas RPC estão bloqueadas.

  4. Verifique se o serviço Registro Remoto do servidor de diretório foi iniciado.

  5. Verifique as permissões da conta com a qual o Exchange Server Analyzer está sendo executado para garantir que ele possui permissões suficientes para ler o Registro no servidor do Active Directory.

Para obter mais informações sobre como solucionar problemas de conectividade de rede, consulte o seguinte:

  • artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56285)


O servidor do Active Directory tem menos de 1 GB de memória, mas tem as opções /3GB e /USERVA=3030 definidas no arquivo Boot.ini.
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A Ferramenta Microsoft® Exchange Server Analyzer consulta duas classes do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar a quantidade de memória física no servidor de diretório Active Directory® e a quantidade de espaço de endereçamento virtual alocado para processos do modo de usuário. A tabela descreve as classes e chaves avaliadas pelo Analisador do Exchange Server.

Classe | Chave | Descrição
Win32_OperatingSystem | MaxProcessMemorySize | Número máximo de kilobytes de memória que pode ser alocado em um processo.
Win32_OperatingSystem | OSProductSuite | Inclusões de produtos de sistema instaladas e licenciadas para o sistema operacional.
Win32_ComputerSystem | TotalPhysicalMemory | Quantidade de memória RAM instalada no computador.

Se o Exchange Server Analyzer determinar que o servidor de diretório tem menos de 950 MB de RAM e que o valor de MaxProcessMemorySize é superior a 2097024 mas inferior a 3104640, um aviso será exibido.

Esse aviso indica que o servidor de diretório não está configurado corretamente para o uso ideal da memória em dois aspectos:

  • A opção de inicialização /USERVA=3030 foi definida. Essa opção só é exigida em computadores do Exchange Server com 1 GB ou mais de memória que estejam sendo executados em um sistema operacional Microsoft Windows Server™ 2003.

  • A opção de inicialização /3GB foi definida. Esse comando só deve ser usado em servidores Exchange com 1 GB ou mais de memória executando qualquer um dos seguintes sistemas operacionais:

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

Importante:
A opção /3GB não deve ser usada no Windows 2000 Server porque não é suportada e pode ocasionar falhas em aplicativos e no sistema operacional. Além disso, a opção /3GB só é suportada nos sistemas operacionais citados anteriormente, quando existir 1 GB de memória física instalada.

Se você encontrar esse aviso em um sistema que tenha 1 GB de memória física instalada, isso poderá significar que outro componente, como uma placa de vídeo, utiliza parte dessa memória física no nível de hardware, fazendo com que a memória física alocada não fique disponível para o sistema operacional. Nesses casos, a quantidade de memória instalada fisicamente de acordo com o Windows será menor do que a quantidade real de memória física instalada no computador. Se você passar por essa situação, deverá comparar a quantidade de memória instalada informada pelo BIOS com a quantidade de memória instalada relatada pelo Windows.

Para corrigir esse aviso no Windows Server 2003

  1. Clique com o botão direito em Meu Computador e selecione Propriedades. A caixa de diálogo Propriedades do Sistema é exibida.

  2. Clique em Avançado.

  3. Na área de Inicialização e Recuperação, clique em Configurações. A caixa de diálogo Inicialização e Recuperação é exibida.

  4. Na área de inicialização do Sistema, clique em Editar. Isso abrirá o arquivo Boot.ini do Windows no Bloco de Notas.

  5. Na seção [Sistemas Operacionais] , exclua as opções a seguir de todas as linhas de inicialização: /3GB /USERVA=3030

  6. Salve as alterações e feche o Bloco de Notas.

  7. Clique em OK duas vezes para fechar as caixas de diálogo abertas e reinicie o computador para que a alteração entre em vigor.

Para corrigir esse aviso no Windows 2000 Server

  1. No Windows Explorer, localize a partição do sistema.

  2. Se você não encontrar o arquivo Boot.ini, é possível que as Opções de Pasta estejam definidas com Ocultar arquivos protegidos do sistema operacional. Nesse caso, no Explorer, clique em Ferramentas, clique emOpções de Pasta e clique na guia Exibir. Desmarque a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado). Quando a caixa de aviso aparecer, clique em Sim.

  3. Assim que o arquivo Boot.ini ficar visível no Explorer, clique com o botão direito do mouse no arquivo, clique em Abrir com e, em seguida, clique em Bloco de Notas para abrir o arquivo.

  4. Na seção [Sistemas Operacionais] , exclua as opções a seguir das linhas de inicialização: /3GB /USERVA=3030

  5. Salve as alterações e feche o Bloco de Notas.

  6. Reinicie o computador para que a alteração entre em vigor.

Para obter detalhes adicionais sobre como usar as opções de inicialização /3GB e /USERVA, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 308356, "Uso de memória pelo processo Lsass.exe nos controladores de domínio que estão em execução no Windows Server 2003 ou Windows 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812, "How to Use the 4GT RAM Tuning Feature" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "The effects of 4GT tuning on system Page Table Entries" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, "Como usar a opção /userva com a opção /3GB para ajustar o espaço Modo usuário para um valor entre 2GB e 3GB" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


O servidor Active Directory tem menos de 1 GB de memória, mas tem a opção /3GB definido no arquivo Boot.ini.
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A Ferramenta Microsoft® Exchange Server Analyzer consulta duas classes do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar a quantidade de memória física no servidor de diretório Active Directory® e a quantidade de espaço de endereçamento virtual alocado para processos do modo de usuário. A tabela a seguir descreve as classes e chaves sendo avaliadas pelo Exchange Server Analyzer.

Classe | Chave | Descrição
Win32_OperatingSystem | MaxProcessMemorySize | Número máximo de kilobytes de memória que pode ser alocado em um processo.
Win32_OperatingSystem | OSProductSuite | Inclusões de produtos de sistema instaladas e licenciadas para o sistema operacional.
Win32_ComputerSystem | TotalPhysicalMemory | Número de bytes da memória RAM (random access memory) instalada no computador.

Se o Exchange Server Analyzer determinar que o servidor de diretório tem menos de 950 MB de RAM, e que o valor de MaxProcessMemorySize é maior que 2097024 e menor que 3104640, um aviso será exibido.

Esse aviso indica que o servidor de diretório não está configurado corretamente para o uso ideal de memória. A opção de inicialização /3GB foi definida nesse computador e deve ser removida. Essa opção só deve ser usada em servidores do Active Directory com 1 GB ou mais de memória que estão executando qualquer um dos seguintes sistemas operacionais:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server™ 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Importante:
A opção /3GB não deve ser usada no Windows 2000 Server porque não é suportada e pode ocasionar falhas em aplicativos e no sistema operacional. Além disso, a opção /3GB só é suportada nos sistemas operacionais citados anteriormente, quando existir 1 GB de memória física instalada.

Se você encontrar esse aviso em um sistema que tenha 1 GB de memória física instalada, isso poderá significar que outro componente, como uma placa de vídeo, utiliza parte dessa memória física no nível de hardware, fazendo com que a memória física alocada não fique disponível para o sistema operacional. Nesses casos, a quantidade de memória instalada fisicamente de acordo com o Windows será menor do que a quantidade real de memória física instalada no computador. Se você passar por essa situação, deverá comparar a quantidade de memória instalada informada pelo BIOS com a quantidade de memória instalada relatada pelo Windows.

Para corrigir esse aviso no Windows Server 2003

  1. Clique com o botão direito em Meu Computador e clique em Propriedades. A caixa de diálogo Propriedades do Sistema é exibida.

  2. Clique em Avançado.

  3. Na área de Inicialização e Recuperação, clique em Configurações. A caixa de diálogo Inicialização e Recuperação é exibida.

  4. Na área de inicialização do Sistema, clique em Editar. Isso abrirá o arquivo Boot.ini do Windows no Bloco de Notas.

  5. Na seção [Operating Systems], exclua o seguinte comando de todas as linhas de inicialização: /3GB

  6. Salve as alterações e feche o Bloco de Notas.

  7. Clique em OK duas vezes para fechar as caixas de diálogo abertas e reinicie o computador para que a alteração entre em vigor.

Para corrigir esse aviso no Windows 2000 Server

  1. No Windows Explorer, navegue para a partição do sistema.

  2. Se você não encontrar o arquivo Boot.ini, é possível que as Opções de Pasta estejam definidas com Ocultar arquivos protegidos do sistema operacional. Se esse for o caso, no Explorer, clique em Ferramentas, clique emOpções de Pasta e clique em Exibir. Desmarque a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado). Quando a caixa de aviso aparecer, clique em Sim.

  3. Quando o arquivo Boot.ini estiver visível no Explorer, clique com o botão direito no arquivo, clique em Abrir com e clique em Bloco de Notas para abrir o arquivo.

  4. Na seção [Operating Systems], exclua o seguinte comando de todas as linhas de inicialização: /3GB

  5. Salve as alterações e feche o Bloco de Notas.

  6. Reinicie o computador para que a alteração entre em vigor.

Para obter mais detalhes sobre como usar a opção de inicialização /3GB, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 308356, "Uso de memória pelo processo Lsass.exe nos controladores de domínio que estão em execução no Windows Server 2003 ou Windows 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812, "How to Use the 4GT RAM Tuning Feature" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "The effects of 4GT tuning on system Page Table Entries" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, "Como usar a opção /userva com a opção /3GB para ajustar o espaço Modo usuário para um valor entre 2GB e 3GB" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


O servidor Active Directory está executando o Windows 2000 Server e tem a opção /3GB definida
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_OperatingSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar a quantidade de espaço de endereço virtual alocado para os processos de modo do usuário (MaxProcessMemorySize) e a versão do Windows (OSProductSuite) executados no servidor do serviço de diretório do Active Directory®. A tabela a seguir descreve as classes e chaves sendo avaliadas pelo Exchange Server Analyzer.

Se o Exchange Server Analyzer determinar que o valor de MaxProcessMemorySize é 3104640 e que o valor de OSProductSuite resolve no Windows 2000 Server, um erro será exibido.

Esse erro indica que a opção de inicialização /3GB está definida no arquivo Boot.ini em um servidor de diretório executando o Microsoft Windows 2000 Server. O Windows 2000 Server não oferece suporte para essa opção, e ela só deve ser usada em computadores com 1 GB ou mais de memória que estejam executando um dos seguintes sistemas operacionais:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Para remover a opção /3GB do arquivo Boot.ini

  1. No Windows Explorer, navegue para a partição do sistema.

  2. Se você não consegue ver o arquivo Boot.ini, pode ser devido às Opções de Pasta estarem definidas como Ocultar arquivos protegidos do sistema operacional. Nesse caso, no Explorer, clique em Ferramentas, clique emOpções de Pasta e clique na guia Exibir. Desmarque a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado). Quando a caixa de aviso aparecer, clique em Sim.

  3. Quando o arquivo Boot.ini estiver visível no Explorer, clique com o botão direito no arquivo, clique em Abrir com e escolha Bloco de Notas para abrir o arquivo.

  4. Na seção [Sistemas Operacionais] , exclua as opções a seguir de todas as linhas de inicialização: /3GB /USERVA=3030

  5. Salve as alterações e feche o Bloco de Notas.

  6. Reinicie o servidor de diretório para que a alteração tenha efeito.

Para obter mais informações sobre como usar a opção de inicialização /3GB, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 297812, "How to Use the 4GT RAM Tuning Feature" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "The effects of 4GT tuning on system Page Table Entries" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, "Como usar a opção /userva com a opção /3GB para ajustar o espaço Modo usuário para um valor entre 2GB e 3GB" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


O Registro do Active Directory Server não pôde ser acessado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion\CurrentVersion

Se o Analisador do Exchange Server não puder ler o valor desse Registro por qualquer motivo, um erro será exibido.

Para corrigir esse erro

  1. Verifique se o controlador de domínio foi iniciado e está conectado à rede.

  2. Use o comando PING para ver se o controlador de domínio está acessível.

  3. Se houver um firewall, verifique se as portas RPC estão bloqueadas.

  4. Verifique se o serviço Remote Registry do controlador de domínio foi iniciado.

  5. Examine as permissões da conta na qual o Exchange Server Analyzer está sendo executado. A conta na qual o Analisador do Exchange Server está sendo executado deve ter permissões de Administrador em cada controlador de domínio que ele verifica.

Para obter mais informações sobre como solucionar problemas de conectividade de rede, consulte o seguinte:

  • artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56285)

Para obter mais informações sobre requisitos de portas, consulte o artigo 832017 da Base de Dados de Conhecimento da Microsoft, "Visão geral de serviço e requisitos de porta de rede para o sistema do Windows Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Atualização disponível para o software do servidor do Active Directory
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2007-02-20

A ferramenta Microsoft Exchange Analyzer consulta a classe Exchange_DSAccessDC do WMI (Instrumentação de Gerenciamento do Microsoft Windows) no namespace ROOT\MicrosoftExchangeV2 para determinar o valor da propriedade Name. A propriedade Name especifica o nome do computador do controlador de domínio usado pelo servidor Exchange para as consultas do serviço de diretório do Active Directory.

O Exchange Analyzer consulta o Active Directory em busca dos valores de atributos específicos desse controlador de domínio para determinar o seguinte:

  • Se o controlador de domínio do Active Directory está executando o sistema operacional Windows Server 2003

  • Se o controlador de domínio do Active Directory está executando uma versão que não seja em inglês do sistema operacional Microsoft Windows Server 2003

  • Se existe um servidor Microsoft Exchange Server 2007 na organização do Exchange

  • Se o valor da chave Version para o arquivo ntdsa.dll no servidor é inferior a 2700

Se detectar que todas essas condições são verdadeiras, o Exchange Analyzer exibirá um aviso.

Esse aviso indica que os clientes Exchange Outlook Web Access podem ter problemas com a indexação do catálogo de endereços do Exchange.

O Outlook Web Access permite que os usuários selecionem o idioma desejado para suas UIs (interfaces de usuário). O idioma selecionado pelos usuários determina a configuração de local. O Outlook Web Access usa também esse idioma para classificar os resultados do Active Directory, como o catálogo de endereços. Quando o Exchange executa uma consulta de VLV (Exibições de Lista Virtual) e especifica um idioma não disponível no controlador de domínio, um erro ocorre. Esse problema ocorre por não haver no momento nenhum mecanismo de indexação padrão que permita que o Exchange use um idioma diferente quando o idioma especificado em uma consulta VLV não corresponde ao idioma do controlador de domínio.

Para resolver esse aviso, obtenha e instale a atualização de arquivo mencionada no artigo 919166 da Base de Dados de Conhecimento Microsoft, "A função de catálogo de endereços no Exchange 2007 é interrompida quando um cliente Exchange OWA e um controlador de domínio com base no Windows Server 2003 não têm a mesma configuração de local" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=919166). (página em inglês)


O WMI do Active Directory Server não pôde ser acessado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se há um valor definido para a chave Name no controlador de domínio. Se a consulta do WMI falhar, o Exchange Server Analyzer exibirá um erro.

Existem duas causas possíveis para esse erro:

  • A conta que executa o Exchange Server Analyzer não tem permissões suficientes para consultar as informações do WMI.

  • Um problema de rede está impedindo que o Analisador do Exchange Server entre em contato com o computador.

Para corrigir esse erro

  1. Verifique se o computador do Exchange Server foi iniciado e está conectado à rede.

  2. Use o comando PING para ver se o computador do Exchange Server está acessível.

  3. Se houver um firewall, verifique se as portas RPC estão bloqueadas.

  4. Examine as permissões da conta na qual o Exchange Server Analyzer está sendo executado. A conta com que o Exchange Server Analyzer está sendo executado deve ter permissões de Administrador local em cada computador do Exchange Server que ele verifica.

    Como alternativa, você pode conceder permissão específica de WMI para a conta na qual o Exchange Server Analyzer está sendo executado.

    1. No computador do Exchange, abra a árvore do console MMC Gerenciamento do Computador.

    2. Em Serviços e Aplicativos, clique com o botão direito em Controle WMI e clique em Propriedades.

    3. Na página Propriedade dos Controles WMI, clique na guia Segurança e expanda Raiz.

    4. Selecione a pasta CIMV2 e clique em Segurança.

    5. Na página Segurança para ROOT\CIMV2, adicione a conta sob a qual o Analisador do Exchange Server está sendo executado.

    6. Selecione a conta adicionada na etapa e. Em Permissões para Conta_Selecionada, na coluna Permitir, marque Habilitação Remota e Ler Segurança e clique em OK.

Para obter mais informações sobre como solucionar problemas de conectividade de rede, consulte o seguinte:

  • artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56285)

Para obter mais informações sobre requisitos de portas, consulte o artigo 832017 da Base de Dados de Conhecimento da Microsoft, "Visão geral de serviço e requisitos de porta de rede para o sistema do Windows Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Atributo ADCDisabledMail detectado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer solicita que o serviço de diretório do Active Directory® determine se a organização do Exchange está no modo misto ou modo nativo. Caso a organização do Exchange esteja no modo nativo, o Exchange Server Analyzer consulta o Active Directory para determinar se algum objeto habilitado para email nos domínios da organização possui o valor do atributo legacyExchangeDN definido como ADCDisabledMail. Se os objetos habilitados para email forem encontrados com o valor do atributo legacyExchangeDN definido como ADCDisabledMail, será exibido um aviso que lista os objetos e seu domínio.

Esse problema pode ocorrer nos ambientes do Exchange 2000 Server e do Exchange Server 2003 quando uma caixa de correio for excluída. Quando a caixa de correio é excluída, o valor do atributo legacyExchangeDN da conta é carimbado com ADCDisabledMail. Esse valor é usado para instruir o ADC (Conector do Active Directory) a excluir objetos do serviço de diretório do Exchange Server 5.5 quando o objeto associado tiver sido desabilitado para email no Active Directory. Caso haja várias caixas de correio em um grande grupo de distribuição que foi excluído, a mensagem será atrasada enquanto o Active Directory for pesquisado em busco de um atributo legacyExchangeDN exclusivo de ADCDisabledMail. Como várias caixas de correio podem ter esse mesmo legacyExchangeDN attribute value, a pesquisa será demorada. Isso causará atrasos nas mensagens. Esses atrasos também ocorrerão quando o grupo de distribuição for expandido nas linhas "Para:/Cc:/Cco:" da mensagem de um cliente Microsoft Office Outlook® 2003.

A resolução é excluir os objetos ou usar a ferramenta ADSI (Active Directory Service Interfaces) Edit, a ferramenta ldp.exe, ou outro cliente LDAP (Lightweight Directory Access Protocol) versão 3 para remover o conteúdo do atributo legacyExchangeDn. Se o valor do atributo legacyExchangeDN estiver definido como NULL, então a pesquisa no Active Directory será definida como "/O=NT5/ou=<objectGUID do Domínio>/cn=<objectGUID do usuário>" e a notificação de falha na entrega ocorrerá muito mais rapidamente.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para remover o valor ADCDisabledMail no atributo legacyExchangeDN

  1. Inicie a ferramenta ADSI Edit nas Ferramentas de Suporte do Windows 2000 ou nas Ferramentas de Suporte do Windows Server 2003.

  2. Expanda os seguintes nós:

    • Contêiner de Domínio

    • DC=Nome_Domínio

    • Contêiner de Usuários

  3. Clique com o botão direito em Nome_Usuário e clique em Propriedades.

  4. Clique em legacyExchangeDN na lista Atributos e clique em Editar.

  5. Remova o valor legacyExchangeDN original que contém ADCDisabledMail selecionando o valor original e clicando em Limpar.

  6. Clique em OK duas vezes para aplicar a alteração.

Para obter mais informações sobre como trabalhar com o ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda online do Windows Server.

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


A configuração de filtro da Lista de Endereços pode fazer com que novos destinatários não sejam exibidos nas listas de endereços
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar os atributos definidos para para o atributo purportedSearch de cada objeto de Lista de Endereços. Se o Exchange Server Analyzer veriicar que o atributo purportedSearch contém a cadeia de caracteres "proxyAddresses=*", um erro será exibido.

Depois de criar um novo objeto de usuário, o Serviço de Atualização do Destinatário define atributos específicos para esse objeto de destinatário, como endereços proxy. No entanto, o Serviço de Atualização do Destinatário pode falhar ao designar o atributo ShowInAddressBook. O atributo ShowInAddressBook de um objeto de destinatário indica as listas de endereços das quais o destinatário é membro. Objetos de destinatário que não têm esse atributo definido não são exibidos na lista de endereços global nem em nenhuma outra lista, mesmo que o objeto se ajuste aos critérios do filtro da Lista de Endereços.

Essa situação pode ocorrer se um ou mais filtros da Lista de Endereço tiverem o atributo proxyAddresses. Você pode determinar se é esse o caso, verificando as propriedades de cada Lista de Endereços e procurando a seguinte cadeia de caracteres na caixa de diálogo Regras do filtro. "proxyAddresses=*".

Execute o procedimento a seguir para habilitar o Serviço de Atualização do Destinatário para definir corretamente atributos para objetos de destinatário, para que eles sejam exibidos na lista de endereços global ou em qualquer outra lista de endereços.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse erro

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Destinatário, expanda Todas as Listas de Endereços Globais e selecione Propriedades do Destinatário.

  3. No painel direito, clique com o botão direito na Lista de Endereços que deseja editar e selecione Propriedades.

  4. Na página Propriedades, na guia Geral, em Regras de filtro, clique em Modificar.

  5. No menu suspenso Localizar Destinatários do Exchange , selecione Pesquisa Personalizada. Se a Lista de endereços tiver sido criada originalmente por uma pesquisa personalizada, a página Localizar Pesquisa Personalizada será exibida depois que você clicar em Modificar, na etapa 3.

  6. Selecione a entrada Endereços proxy são (exatamente) * na lista de critérios e clique em Remover.

  7. Clique em OK para fechar as caixas de diálogo.

  8. Clique com o botão direito na diretiva de destinatário e clique em Aplicar esta diretiva agora.

Para obter mais informações sobre o Serviço de Atualização de Destinatário, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328738, "XADM: Como o Serviço de Atualização de Destinatário aplica as diretivas de destinatário" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328738)

  • 319065, "Como trabalhar com o Serviço de Atualização de Destinatário do Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319065)


O modo do grupo administrativo é desconhecido
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A Ferramenta do Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para verificar o modo do grupo administrativo, analisando o atributo msExchAdminGroupMode do objeto do grupo administrativo no contêiner Grupos Administrativos no Active Directory. Se o Exchange Server Analyzer determinar que o valor do atributo msExchAdminGroupMode não é igual a 0, 1 ou 2, será exibido um erro.

O Exchange usa o modo do grupo administrativo para indicar se o grupo administrativo pode incluir os servidores Exchange Server 5.5 ou Exchange Server 2003 (ou os servidores Exchange 2000). Se um valor diferente de 0, 1 ou 2 estiver presente nesse atributo, é provável que um administrador o tenha alterado manualmente. A Instalação do Exchange ou o Gerenciador do Sistema do Exchange não definiria esse valor incorretamente.

Você deve corrigir o valor usando uma ferramenta como a snap-in Active Directory Service Interfaces (ADSI) Edit, LDP (ldp.exe) ou qualquer outro cliente de protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para modificar o atributo MSExchAdminGroupMode

  1. Use um editor do Active Directory, como o ADSI Edit, para localizar o objeto do grupo administrativo no Active Directory.

    O atributo MSExchAdminGroupMode pode ser encontrado em:

    CN=Configuração, CN=Serviços, CN=Microsoft Exchange, CN=Organização, CN=Grupos Administrativos, CN= Grupo administrativo

  2. Digite um dos seguintes valores inteiros:

    0=modo nativo (o grupo administrativo foi criado com o Exchange 2000 Server ou Exchange Server 2003)

    1=modo Exchange Server 5.5 (o grupo administrativo foi criado com o Exchange Server 5.5 e inclui somente servidores Exchange Server 5.5)

    2=modo misto (o grupo administrativo pode incluir servidores Exchange Server 5.5 e Exchange 2000 Server ou servidores Exchange Server 2003)

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como funciona o ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda online do Windows Server.


A configuração de Usuários Autenticados está incorreta para o Hosted Exchange
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar se o ambiente do Exchange Server está configurado como um ambiente do Hosted Exchange. Se o ambiente do Exchange Server for um ambiente Hosted Exchange, o Exchange Server Analyzer consultará o Active Directory para determinar se o grupo Usuários Autenticados faz parte do grupo de Acesso Compatível Anterior ao Windows® 2000 no domínio.

Se o grupo Usuários Autenticados for membro do grupo de Acesso Compatível Anterior ao Windows 2000, o Exchange Server Analyzer exibirá um aviso. Essa não é a configuração recomendada para uma solução Hosted Exchange.

Para corrigir esse aviso, remova Usuários Autenticados do grupo de segurança Acesso Compatível Anterior ao Windows 2000

  1. Abra Usuários e Computadores do Active Directory.

  2. Expanda o nó de domínio e clique no contêiner Builtin.

  3. Clique como botão direito do mouse no grupo de segurança Acesso Compatível Anterior ao Windows 2000 e selecione Propriedades.

  4. Clique na guia Membros.

  5. Selecione Usuários Autenticados.

  6. Clique em Remover.

  7. Clique em OK.

Para obter mais informações sobre ambientes do Hosted Exchange, consulte os seguintes artigos:

  • "Information for Hosters" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=46307)

  • "Chapter 23 - Hosted Service Environments" no Exchange Server 2000 Resource Kit (em inglês) (http://go.microsoft.com/fwlink/?LinkId=46326)


Incompatibilidade de entidade de certificado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2007-01-09

A Ferramenta Microsoft® Exchange Server Analyzer consulta o objeto Server Certificate no sistema do servidor Exchange para recuperar várias propriedades nos certificados X509. Em cada certificado SSL encontrado, o Exchange Server Analyzer avalia o atributo Principal para identificar o FQDN (nome de domínio totalmente qualificado) atribuído ao certificado; por exemplo, www.microsoft.com.

O Microsoft Exchange Server Analyzer emite um aviso quando o nome FQDN Principal não coincide com o endereço ou URL do host. O aviso de incompatibilidade do certificado Principal significa que os usuários podem não conseguir se conectar às suas respectivas caixas de correio usando o Microsoft Office Outlook® Web Access para Exchange Server 2003, o Outlook em Qualquer Lugar para Exchange Server 2007, o Exchange Server ActiveSync e o RPC sobre HTTP.

Observação:
Um servidor deve ter um certificado de servidor quando executa um protocolo SSL. Como alternativa, o servidor pode pedir o certificado do cliente. O certificado de servidor contém o nome do site. O navegador verifica se o site é o nome que foi inserido. Por exemplo, se houver um site como https://www.example.com, o nome do certificado deverá ser www.example.com.

Pode haver incompatibilidade se ocorrer uma das condições a seguir:

  • O certificado for acidentalmente aplicado ao servidor errado

  • O cliente acessar dados em um servidor através da um URL de host errado quando há servidores com mais de um nome de host

Para resolver a imcompatibilidade de nome de certificado

  • Verifique se o certificado SSL foi atribuído e aplicado ao hosto correto.

Para obter mais informações

  • Para obter informações sobre como usar certificados com servidores virtuais no Exchange Server 2003, consulte o artigo 823024 da Base de Dados de Conhecimento Microsoft, "Como usar certificados com servidores virtuais no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024) (em inglês).

  • Para obter informações sobre como usar o SSL e como obter e instalar certificados de servidor, consulte "Configurando o Exchange Server 2003 para Acesso para Cliente" no Guia de Acesso para Cliente do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47568) (em inglês).

  • Para obter informações sobre como usar o SSL e como obter e instalar certificados de servidor no Exchange Server 2007, consulte "Como configurar o SSL no Outlook em Qualquer Lugar" (em inglês) (http:// go.microsoft.com/fwlink/?LinkId =80875).


O agendamento de ativação de licença de conexão foi definido como Nunca
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo activationStyle em cada objeto de licença de conexão. O atributo activationStyle representa a configuração de agendamento da licença de conexão. Se o agendamento estiver definido como Nunca, um aviso será exibido.

Se você tiver determinado que essa licença de conexão não é mais necessária, você deverá excluí-la. Se essa licença de conexão for necessária, você deverá configurá-la para ser executada em um agendamento adequado.

Para corrigir esse aviso

  1. Clique em Iniciar, Programas, Ferramentas Administrativas, e Active Directory Connector.

  2. No painel da esquerda, clique no servidor ADC (Active Directory Connector) que hospeda a licença de conexão que você deseja modificar.

  3. No painel da direita, clique com o botão direito no acordo de conexão que você deseja modificar e clique em Propriedades.

  4. Clique na guia Agendamento.

  5. Defina o agendamento como Sempre ou Vezes selecionadas. Se você selecionar a segunda opção, clique nas áreas apropriadas da grade para que a licença de conexão seja executada nesses horários.

Para obter mais informações sobre como configurar uma licença de conexão de destinatário bidirecional, consulte o artigo 296260 da Base de Dados de Conhecimento Microsoft, "XGEN: Como configurar uma licença de conexão de destinatário bidirecional para usuários do Exchange 5.5" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260).


A licença de conexão está órfã
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se cada licença de conexão tem um valor válido para msExchHomeSyncService. Se o Exchange Server Analyzer localizar uma licença de conexão que não tenha um valor válido para esse atributo, será exibido um aviso.

O atributo msExchHomeSyncService contém o servidor ADC (Active Directory Connector) no qual a licença de conexão está localizada.

Você verá esse aviso se remover um servidor ADC sem antes remover o ADC ou remover as licenças de conexão do servidor ADC. Ao remover o servidor ADC, a conexão entre as licenças de conexão e o servidor ADC é interrompida. Como resultado, os objetos pelos quais essas licenças de conexão são responsáveis não mais serão replicados. Se você usar o snap-in do Gerenciador do ADC em outro servidor ADC, as licenças de conexão que estavam localizadas no servidor ADC que foi removido não serão exibidas. Entretanto, essas licenças de conexão ainda existem no Active Directory.

Para resolver esse problema, associe novamente as antigas licenças de conexão ao novo servidor ADC. Uma forma de fazer isso é criar uma nova licença de conexão no novo servidor ADC e depois copiar e colar o atributo msExchHomeSyncService da nova licença de conexão para a antiga.

Para associar novamente uma licença de conexão a um servidor ADC

  1. Inicie o snap-in do Gerenciador do ADC.

  2. Crie uma nova licença de conexão.

  3. Inicie o ADSI (Interfaces do Serviço Active Directory) Edit

  4. Expanda Configuração, Serviços, Microsoft Exchange e clique em Conexões do Active Directory.

  5. No painel direito, abra as propriedades da licença de conexão que acabou de ser criada.

  6. Na lista suspensa Selecionar uma propriedade a ser exibida, clique em msExchHomeSyncService.

  7. Copie todo o atributo da caixa Valor(es) e clique em OK.

  8. Abra as propriedades da licença de conexão que você deve associar novamente.

  9. Clique na lista suspensa Selecionar uma propriedade a ser exibida e no atributo msExchHomeSyncService.

  10. Cole o valor copiado na caixa Editar Atributo.

  11. Clique em Definir, Aplicar e em OK.

Para obter mais informações sobre licenças de conexão órfãs, consulte o artigo 319486 da Base de Dados de Conhecimento Microsoft, "XADM: Licenças de conexão desaparecem depois de removido o Active Directory Connector" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319486).


Nome para exibição padrão modificado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo createDialog de objetos que tenham a classe displaySpecifier. Os objetos com classe displaySpecifier descrevem os menus de contexto e as páginas de propriedades a serem usadas com objetos do Active Directory. Se o Exchange Server Analyzer determinar que o atributo createDialog foi definido, uma mensagem de configuração não padrão será exibida.

Quando um novo objeto de usuário ou de contato é criado no Active Directory, o campo Nome Completo sempre é gerado no formato FirstName LastName. Por sua vez, esse campo define o campo Nome para Exibição ao ser criado, portanto, você obtém uma lista de endereços globais no formato FirstName LastName.

Se desejar, você pode usar um editor do Active Directory, como o ADSI (Active Directory Service Interfaces) Edit para modificar o modo como o campo Nome de Exibição é criado. O ADSI Edit não altera apenas o modo como esse campo é criado, mas, também, o campo Nome Completo; portanto, os usuários aparecem no formato escolhido exibido em Usuários e Computadores do Active Directory.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP (ldp.exe) ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Antes de fazer essas alterações, lembre-se de que elas podem ter efeitos adversos. Para obter mais informações sobre as possíveis conseqüências desta alteração, consulte o artigo 276266 da Base de Dados de Conhecimento da Microsoft, "Alterações do Grupo para Usuários com Caracteres Restritos a LDAP" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=276266).

Para alterar o formato de exibição padrão para objetos de usuário e de contato

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Clique com o botão direito no nó superior e clique em Conectar a.

  3. Altere o Contexto de Atribuição de Nome para "Contêiner de Configuração" e clique em OK para ligar e autenticar.

  4. Expanda o nó Contêiner de Configuração e expanda o nó Configuração.

  5. Expanda o nó cn=DisplaySpecifiers e clique duas vezes em CN=409. Observação: 409 é a Identificação de Localidade para inglês dos Estados Unidos. Se você estiver em um ambiente multilíngüe, talvez seja necessário fazer alterações em outros códigos.

  6. No painel direito, abra as propriedades de CN=user-Display.

  7. Role para o atributo opcional createDialog.

  8. Defina o atributo como %<sn>.%<givenName> e clique em Definir. Observação: Os únicos tokens que podem ser formatados são %<sn>, %<givenName> e %<initials>.

  9. Clique em OK para fechar a caixa de diálogo.

  10. Crie um novo usuário no Active Directory para verificar se o Nome Completo e o Nome para Exibição estão sendo criados conforme o esperado. Observação: Em um ambiente de vários domínios, talvez seja necessário aguardar até que a replicação termine para que a ferramenta Usuários e Computadores do Active Directory atualize as alterações.

As etapas acima resultam na exibição do nome para exibição no formato LastName.FirstName. Além disso, o procedimento acima é para objetos do usuário. Para objetos de contato, altere a etapa 6 para contact-Display.

Para obter mais informações sobre como usar um script ADSI para executar esta tarefa, consulte o artigo 277717 da Base de Dados de Conhecimento da Microsoft, "Como Alterar os Nomes de Exibição dos Usuários do Active Directory pelo Script do Active Directory Services Interface" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277717).

A ITU (International Telecommunication Union) e a ISO (International Organization for Standardization) definem as páginas de códigos. Para obter mais informações, visite as seguintes páginas da ITU e da ISO na Web:

  • http://www.itu.int

  • http://www.iso.ch/iso/en/ISOOnline.openerpage

    Observação:
    Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como oferecer suporte a Clientes localizados do Exchange, consulte o artigo 150977 da Base de Dados de Conhecimento da Microsoft, "XADM: Oferencendo Suporte para Clientes Exchange Traduzidos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=150977).


A retenção de item excluído está desabilitada para o armazenamento de caixa de correio
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo garbageCollPeriod de cada armazenamento de caixa de correio. Se o Exchange Server Analyzer detectar que o atributo garbageCollPeriod está definido como 0 para qualquer armazenamento de caixa de correio, uma mensagem de prática recomendada será exibida.

A coleta de lixo é um processo de manutenção interna do Exchange que libera espaço no banco de dados de armazenamento de caixa de correio. Por padrão, os itens excluídos ficam armazenados no banco de dados de armazenamento de caixa de correio por um determinado número de dias antes de serem excluídos permanentemente pelo Exchange. Você pode definir a duração do período de retenção de item excluído usando os padrões de armazenamento de caixa de correio ou selecionando o número de dias que um item excluído deve ser mantido antes da exclusão permanente.

Você pode selecionar um número de 0 a 24.855 para especificar o número de dias para reter um item excluído. É recomendável configurar essa definição como 7 dias. Se o período de retenção de item excluído for definido como 0, os itens excluídos serão excluídos permanentemente do servidor imediatamente. A menos que o espaço em disco seja um problema, é recomendável que você não desabilite o recurso de retenção de item excluído. Siga os procedimentos a seguir para especificar quantos dias os itens excluídos devem ficar armazenados antes de serem excluídos permanentemente.

Para configurar a retenção de item excluído no Gerenciador do Sistema do Exchange

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupo Administrativo ou Organização, clique em Servidores e clique em Armazenamento da Caixa de Correio.

  3. Clique com o botão direito no armazenamento de caixa de correio e clique em Propriedades.

  4. Na guia Limites, defina o período de retenção de itens excluídos fazendo o seguinte:

    • Para definir um período de retenção de itens excluídos, clique em Manter itens excluídos por (dias) e digite um valor.

    • Para preservar os itens até o backup, clique em Não excluir permanentemente caixas de correio e itens enquanto não for feito o backup do armazenamento.

Para configurar a retenção de item excluído em Usuários e Computadores do Active Directory.

  1. Abra Usuários e Computadores do Active Directory.

  2. Na árvore do console, expanda o domínio.

  3. Clique duas vezes em Usuários, ou clique duas vezes no nó que contém as informações do destinatário que você deseja modificar.

  4. No painel de detalhes, clique duas vezes no destinatário que você está modificando.

  5. Na guia Geral do Exchange, clique em Limites de Armazenamento.

  6. Na caixa de diálogo Limites de Armazenamento, em Retenção de item excluído, desmarque a caixa de seleção Usar padrões de armazenamento de caixa de correio; em seguida, digite um valor em Manter itens excluídos por (dias).

    Para evitar que os itens excluídos sejam excluídos permanentemente antes do backup, marque a caixa de seleção Não excluir permanentemente os itens enquanto não for feito o backup do armazenamento.

Para obter mais informações sobre como definir limites de armazenamento de caixa de correio, consulte o artigo 319583 da Base de Dados de Conhecimento da Microsoft, "COMO: Configurar limites de armazenamento em caixas de correio no Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319583).


A retenção de item excluído está desabilitada para o armazenamento de pasta pública
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo garbageCollPeriod de cada armazenamento de pasta pública. Se o Exchange Server Analyzer verificar que o atributo garbageCollPeriod configurado para 0 para qualquer armazenamento de pasta pública, uma mensagem de prática recomendada será exibida.

A coleta de lixo é um processo interno de manutenção de rotina do Exchange que libera espaço no banco de dados de armazenamento de pastas públicas. Por padrão, os itens excluídos são armazenados no banco de dados de armazenamento de pastas públicas por um determinado número de dias antes de serem excluídos permanentemente pelo Exchange. Você pode definir a duração do período de retenção de item excluído usando os padrões de armazenamento de pastas públicas, ou selecionando o número de dias que um item excluído deve ser mantido antes de ser permanentemente excluído.

Você pode selecionar um número de 0 a 24.855 para especificar o número de dias para reter um item excluído. É recomendável configurar essa definição como 7 dias. Se o período de retenção de item excluído for definido como 0, os itens excluídos serão excluídos permanentemente do servidor imediatamente. A menos que o espaço em disco seja um problema, é recomendável que você não desabilite o recurso de retenção de item excluído.

Para configurar a retenção de itens excluídos no Gerenciador do Sistema do Exchange

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda o Grupo administrativo ou Servidores, clique em Servidores e clique em Armazenamento de Pastas Públicas.

  3. Clique com o botão direito em armazenamento de pastas públicas e clique em Propriedades.

  4. Na guia Limites, defina o período de retenção de itens excluídos fazendo o seguinte:

    • Para definir um período de retenção para itens excluídos, clique em Manter itens excluídos por (dias) e digite um valor.

    • Para preservar os itens até o próximo backup, clique em Não excluir os itens permanentemente até que tenha sido feito um backup de armazenamento.

Para obter mais informações sobre como definir limites de armazenamento para pastas públicas, consulte o artigo 319439 da Base de Dados de Conhecimento Microsoft, "COMO FAZER: Configurar limites de armazenamento nas pastas públicas no Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319439).


A retenção de caixa de correio excluída está desabilitada
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchMailboxRetentionPeriod de cada armazenamento de caixa de correio. Se o Exchange Server Analyzer detectar que o valor do atributo msExchMailboxRetentionPeriod de qualquer armazenamento de caixa de correio está definido como 0, será exibida uma recomendação de prática recomendada.

O atributo msExchMailboxRetentionPeriod indica o número de dias durante os quais as caixas de correio excluídas devem ser mantidas, antes de sua exclusão. Você pode selecionar um número de 0 a 24.855 para especificar o número de dias para reter uma caixa de correio excluída. A configuração padrão de retenção da caixa de correio excluída é de 30 dias. Se o período de retenção de caixa de correio estiver definido como 0, as caixas de correio excluídas serão permanentemente removidas do servidor de maneira imediata. A menos que o espaço em disco seja um problema, é recomendável que você não desabilite o recurso de retenção de caixa de correio excluída.

Para configurar a retenção de caixa de correio excluída

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos, expanda seu grupo administrativo, expanda Servidores e expanda o seu grupo de armazenamento. Se o nó Grupos Administrativos não estiver exibido no Gerenciador do Sistema do Exchange, expanda Servidores e expanda o seu grupo de armazenamento.

  3. Clique com o botão direito no armazenamento de caixa de correio que você deseja configurar e selecione Propriedades.

  4. Na guia Limites, defina o período de retenção de caixa de correio no campo Manter caixas de correio excluídas por (dias).

  5. Clique em OK para salvar as alterações.
Observação:
Talvez você consiga recuperar uma caixa de correio se o respectivo período de retenção não tiver expirado e o objeto do usuário associado não estiver excluído.

Para obter mais informações sobre como recuperar uma caixa de correio excluída, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 274343, "Como recuperar uma caixa de correio excluída no Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=274343)

  • 813337, "Como recuperar ou restaurar uma única caixa de correio no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=813337)

  • 823176, "Como recuperar ou restaurar uma única caixa de correio no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823176)


O domínio tem uma assinatura desconhecida do Exchange
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-12-04

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar que versão de DomainPrep foi executada por último em um determinado domínio. O número da versão de DomainPrep atua como a assinatura do Exchange para o domínio. O Exchange Server Analyzer examina o atributo objectVersion do objeto Objetos do Sistema do Exchange do domínio em questão. Há dois inteiros válidos:

  • Para o Exchange 2000 Server, o valor de objectVersion é 4406.

  • Para o Exchange Server 2003, o valor de objectVersion é 6936.

  • Para o Exchange Server 2007, o valor de objectVersion é 10628.

Se o Exchange Server Analyzer não localizar um dos valores acima para o atributo objectVersion, um erro será exibido.

Esse valor provavelmente será incorreto se você tiver instalado no domínio determinado uma versão de pré-lançamento do Exchange 2000 Server ou do Exchange Server 2003, mas não tiver executado a versão de lançamento do DomainPrep.

Observação:
No Microsoft Exchange 2000 Server e Exchange Server 2003, você realizou as etapas de preparação do Active Directory executando setup /forestprep e setup /domainprep. O Exchange 2007 não tem as opções /forestprep e /domainprep. Para o Exchange Server 2007, você executou o processo setup /PrepareDomain ou o Assistente para Instalação com uma conta com as permissões necessárias para preparar o Active Directory e o domínio.

Para corrigir esse erro do Exchange 2000 Server ou do Exchange Server 2003, execute a versão de lançamento final do DomainPrep do Exchange 2000 Server, DomainPrep do Exchange Server 2003 ou a versão de lançamento final do processo PrepareDomain ou o Assistente para Instalação do Exchange Server 2007. A conta usada para executar o DomainPrep, o PrepareDomain ou o Assistente para Instalação deve ser um membro do grupo de segurança Administradores de Domínio no domínio local e um administrador do computador local.

  • O domínio raiz.

  • Todos os domínios que conterão computadores com Exchange 2000 Server ou Exchange Server 2003.

  • Todos os domínios que conterão objetos habilitados para caixas de correio (como usuários e grupos) do Exchange 2000 Server ou Exchange Server 2003, mesmo que nenhum servidor Exchange vá ser instalado nesses domínios.

  • Todos os domínios que conterão servidores de catálogo global que os componentes de acesso de diretório do Exchange possam vir a usar.

  • Todos os domínios que conterão usuários e grupos do Exchange 2000 Server ou Exchange Server 2003 e grupos que você usará para gerenciar sua organização do Exchange.

Para executar DomainPrep para Exchange 2000 Server ou para Exchange Server 2003

  1. Insira o CD do Exchange na unidade de CD-ROM. Você pode executar o DomainPrep em qualquer computador do domínio.

  2. Em um prompt de comando, digite <unidade>:\setup\i386\setup /DomainPrep, em que <unidade> é a unidade de CD-ROM.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção do Componente, verifique se Ação está definido como DomainPrep. Caso contrário, clique na seta suspensa e clique em DomainPrep. Clique em Avançar.

  7. Na página Conclusão do Assistente do Microsoft Exchange, clique em Concluir.

Para executar PrepareDomain para Exchange Server 2007

  1. Siga a orientação passo a passo em "Como preparar o Active Directory e os domínios" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=78453).

Para obter mais informações sobre como executar o DomainPrep do Exchange Server 2003, consulte o Guia de Implantação do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47569).

Para obter mais informações sobre como executar o DomainPrep do Exchange 2000 Server, consulte "Microsoft Exchange 2000 Server Installation and Setup" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=5906).

Para obter mais informações sobre a preparação do Active Directory e dos domínios do Exchange Server 2007, consulte "Como preparar o Active Directory e os domínios" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=78453).


O Controlador de Domínio está executando o Virtual Server 2005 com o Exchange Server instalado como um Convidado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_ComputerSystem de Instrumentação de Gerenciamento do Microsoft Windows® para determinar se o valor da chave Model está definido como Virtual Machine.

O Exchange Server Analyzer também verifica a presença do seguinte valor do Registro:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Além disso, o Exchange Server Analyzer lê a chave Domain Role da classe Win32_ComputerSystem no computador físico que está executando o Microsoft Virtual Server 2005. Um valor superior a 3 indica que o computador físico é um controlador de domínio.

Se o Exchange Server Analyzer verificar que a chave Model contém a cadeia de caracteres Virtual Machine, a ramificação de Registro anterior existe, e Domain Role é maior que 3, um erro será exibido.

Um valor Virtual Machine para a chave Model indica que o computador do Exchange Server está sendo executado como máquina virtual convidada no Virtual Server 2005 ou no Microsoft Virtual PC 2004. Como a ramificação do Registro acima só é criada pelo Virtual Server 2005, sua existência significa que o computador do Exchange Server está sendo executado como máquina virtual convidada no Virtual Server 2005.

A Microsoft não oferece suporte para execução de nenhuma versão do Exchange Server em uma máquina virtual ou um emulador. Isso é verdadeiro para o Exchange Server em execução no Virtual Server 2005, no Virtual PC 2004 ou em qualquer programa de máquina virtual de terceiros. As plataformas Exchange Server foram projetadas e testadas para execução apenas em hardware físico, especialmente naquelas plataformas de hardware listadas no Windows Server Catalog em http://go.microsoft.com/fwlink/?linkid=17219.

Além disso, a execução do Exchange como convidado do Virtual Server em um controlador de domínio não é uma prática recomendada, no sentido em que não permite a redundância adequada em todos os serviços.

Para corrigir esse erro

  1. Mova as caixas de correio do servidor Exchange que está sendo executado no Virtual Server 2005 para um computador não virtual do Exchange Server.

  2. Relocalize quaisquer pastas públicas e transfira todas as funções mantidas pelo servidor virtual Exchange conforme necessário.

  3. Desinstale o Exchange da máquina virtual para descomissionar e remover da sua infra-estrutura do Exchange e do serviço de diretório Active Directory®.

Para obter mais informações sobre como mover caixas de correio, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 822892, "Aprimoramento de Mover Caixa de Correio no Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892) (em inglês)

  • 224975, "XADM: Differences Between Move Mailbox Methods" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Para obter mais informações sobre suporte para computadores do Exchange Server sendo executados em ambientes virtuais, consulte o artigo 320220 da Base de Dados de Conhecimento Microsoft (página em inglês), "Limites de suporte do Exchange Server em uma máquina virtual ou de emulação" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Para obter mais informações sobre o Microsoft Virtual Server 2005, visite http://go.microsoft.com/fwlink/?linkid=34938.

Para obter mais informações sobre o Microsoft Virtual PC 2004, visite http://go.microsoft.com/fwlink/?linkid=34663.


A função FSMO de Nomenclatura de Domínio não respondeu
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo fSMORoleOwner do mestre de operações de nomeação de domínios no Contexto de Nomenclatura de Configuração. Por exemplo, em um domínio chamado contoso.com, fSMORoleOwner para o mestre de operações de nomeação de domínios é um atributo de CN=Partitions,CN=Configuration,DC=contoso,DC=com. O Analisador do Exchange Server tenta abrir uma conexão LDAP (Lightweight Directory Access Protocol) com a porta TCP 389 no controlador de domínio que armazena atualmente essa função. Se o Analisador do Exchange Server não puder se conectar a esse controlador de domínio, um erro será exibido.

O mestre de nomeação de domínios é uma função de mestre de operações em toda a floresta porque gerencia a adição e remoção de todas as partições do diretório, independentemente do domínio, na hierarquia da floresta. O controlador do domínio, que tem a função de mestre de nomeação de domínios, é o único que pode fazer o seguinte:

  • Adicionar novos domínios à floresta.

  • Remover os domínios existentes da floresta.

  • Adicionar ou remover objetos de referência cruzada de diretórios externos.

Pode haver somente um controlador de nomenclatura de domínio em toda a floresta.

Para corrigir esse erro

  1. Verifique se o servidor de diretório especificado no erro está online e acessível pelos servidores Exchange em sua organização.

  2. Se esse servidor de diretórios foi descomissionado, você deverá atribuir a função de mestre de nomeação de domínios a outro controlador de domínio.

Para obter mais informações sobre a transferência da função de mestre de operações de nomeação de domínios de um controlador de domínio para outro, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • Para obter informações sobre o Microsoft Windows Server™ 2003, consulte o artigo 324801, "Como exibir e transferir funções FSMO no Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801).

  • Para o Microsoft Windows® 2000 Server, consulte 255690, "COMO: Exibir e transferir funções FSMO na interface gráfica de usuário" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Função FSMO de Nomenclatura de Domínio não encontrada
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o atributo fSMORoleOwner do mestre de operações de nomeação de domínios no Contexto de Nomeação de Configuração. Por exemplo, em um domínio chamado contoso.com, fSMORoleOwner para o mestre de nomeação de domínios é um atributo de CN=Partições, CN=Configuração, DC=contoso, DC=com. O Exchange Server Analyzer tenta abrir uma conexão de Protocolo LDAP com o controlador de domínio. Se o Exchange Server Analyzer verificar que o controlador de domínio especificado no atributo fSMORoleOwner não responde, será exibido um erro.

O controlador de domínio do mestre de nomeação de domínios controla a adição ou remoção de domínios na floresta. Pode haver somente um controlador de nomenclatura de domínio em toda a floresta.

Você deve ter um mestre de nomeação de domínios definido para a floresta do Active Directory. A Instalação do Exchange e a Instalação do Exchange Service Pack falhará se um controlador de domínio do mestre de nomeação de domínios não estiver online durante a instalação. Se o controlador de domínio listado como o mestre de nomeação de domínios estiver offline, ele deverá ser colocado novamente online.

Para corrigir esse erro

  1. Verifique se o servidor do Active Directory designado está fisicamente presente.

  2. Se esse servidor de diretório foi descomissionado, atribua a função de mestre de nomeação de domínios a outro controlador de domínio.

Para obter mais informações sobre como atribuir a função de mestre de nomeação de domínio a outro controlador de domínio, consulte os artigos da Base de Dados de Conhecimento Microsoft a seguir:

  • Para obter informações sobre o Microsoft Windows Server™ 2003, consulte o artigo 324801, "Como exibir e transferir funções FSMO no Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801).

  • Para o Microsoft Windows® 2000 Server, consulte 255690, "COMO: Exibir e transferir funções FSMO na interface gráfica de usuário" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Falha na resolução de nome DNS do Servidor de Diretório
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool tenta uma consulta do DNS (Sistema de Nome de Domínio) nos servidores DNS configurados para cada servidor de serviço de diretório do Active Directory®. Essa conexão é estabelecida usando um processador de objeto personalizado que executa uma solicitação de resolução de nome e analisa os resultados. Se o Exchange Server Analyzer não receber um endereço IP como parte dos resultados da consulta, será exibido um erro.

Esse erro indica que o servidor de diretório não foi encontrado no DNS. Tanto o Exchange Server quanto o Active Directory exigem configuração correta e integridade do DNS para operarem corretamente. Os problemas de registro e resolução de DNS podem ter efeitos abrangentes na capacidade de enviar, receber e entregar mensagens.

Você deve configurar o DNS corretamente para certificar-se de que o Active Directory e o Exchange Server funcionarão corretamente. Para obter um tratamento mais detalhado da configuração do DNS para o Active Directory, consulte o artigo 237675 da Base de Dados de Conhecimento Microsoft, "Configurando o sistema de nomes de domínio para o Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675) (em inglês).

Para corrigir esse erro

  1. Examine os seguintes itens de configuração para certificar-se de que o DNS está íntegro e de que as entradas DNS do Active Directory serão registradas corretamente:

    • Configuração de IP do DNS

    • Atualizações de zona dinâmica

    • Encaminhadores do DNS

  2. Verifique a existência de uma entrada de Zona Raiz. Exiba as zonas de Pesquisa Direta no console de Gerenciamento do DNS. Deve haver uma entrada para o domínio. Podem existir outras entradas de zona. Não deve ser uma zona ponto ("."). Exclua a zona ponto ("."), caso ela exista. A zona ponto (".") identifica o servidor DNS como um servidor raiz. Normalmente, um domínio do Active Directory que precisa de acesso externo (Internet) não deve ser configurado como um servidor DNS raiz. Registre novamente o endereço IP do servidor de diretório de forma manual, usando Ipconfig /registerdns no servidor de diretório após excluir o ponto ("."). O serviço Netlogon também pode precisar ser reiniciado.

  3. Preencha de novo manualmente as entradas DNS do Active Directory, usando netdiag /fix no servidor de diretório.

Para obter mais informações sobre o uso do DNS com o Active Directory, consulte o artigo 323418 da Base de Dados de Conhecimento Microsoft, "Como integrar o DNS com uma infra-estrutura DNS existente se o Active Directory estiver habilitado no Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418) (em inglês).

Para obter mais informações sobre como solucionar problemas do DNS e do Active Directory, consulte o artigo 260371 da Base de Dados de Conhecimento Microsoft, "Como solucionar problemas comuns de instalação do Active Directory no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371).


dSHeuristics não está definido corretamente para o Hosted Exchange
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se a implantação é a do Hosted Exchange. Se a implantação do Exchange estiver sendo executada em um ambiente hospedado, o Exchange Server Analyzer consultará o Active Directory para determinar se o atributo dSHeuristics no contêiner do Directory Service está definido corretamente para a implantação do Hosted Exchange.

Se o valor de dSHeuristics não for igual a 1, o Exchange Server Analyzer exibirá um aviso. Em um ambiente do Hosted Exchange, o atributo dSHeuristics deve ser definido como 1.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse aviso

  1. Use um editor do Active Directory, como o ADSI Edit, para localizar o objeto do Serviço de Diretório no Active Directory.

    É possível encontrar o atributo dSHeuristics em

    CN=Configuration, CN=Services, CN=Windows NT, CN=Directory Service

  2. Insira um valor igual a 1 para dSHeuristics.

Para obter mais informações sobre ambientes do Hosted Exchange, consulte os seguintes artigos:

  • "Information for Hosters" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=46307)

  • "Ambientes Hosted Service" no Kit de recursos do Exchange Server 2000 (http://go.microsoft.com/fwlink/?LinkId=46326)


O contêiner Objetos Duplicados do Sistema Microsoft Exchange existe no Active Directory
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o contêiner Objetos do Sistema do Microsoft Exchange existe no Contexto de Atribuição de Nomes de Domínio.

Se o Exchange Server Analyzer detectar a existência de um contêiner Objetos do Sistema do Microsoft Exchange duplicado no Active Directory, exibirá um erro: "O domínio do Active Directory está preparado para o Exchange, mas existem vários contêineres 'Objetos do Sistema do Microsoft Exchange'. Uma limpeza pode ser necessária."

Esse problema pode ocorrer nos ambientes do Exchange Server em que:

  • Uma licença de conexão de servidor ADC (Conector do Active Directory) bidirecional do Active Directory para o Exchange Server 5.5 foi excluída e substituída.

  • Uma licença de conexão de servidor ADC (Conector do Active Directory) unidirecional do Exchange Server 5.5 para o Active Directory está em vigor.

  • Um ambiente do modo misto executando o Exchange Server 5.5 migrou para um ambiente do Exchange Server 2003.

  • Foi executada uma migração para o Exchange Server 2003 a partir de um servidor de mensagens externo.

Quando o Exchange Server Analyzer exibir esse erro, exclua o contêiner duplicado e incorreto Objetos do Sistema do Microsoft Exchange ou a unidade organizacional (UO). Quando existir um contêiner Objetos do Sistema do Microsoft Exchange duplicado, não será possível solucionar o problema executando novamente o DomainPrep. Identifique e exclua o contêiner duplicado incorreto Objetos do Sistema do Microsoft Exchange System.

Para remover o contêiner duplicado Objeto do Sistema do Microsoft Exchange

  1. Faça logon no controlador de domínio com credenciais administrativas.

  2. Clique em Iniciar, Programas, Ferramentas Administrativas e, em seguida, em Usuários e Computadores do Active Directory.

  3. No painel do console de gerenciamento de Usuários e Computadores do Active Directory, clique em Exibir no menu da barra de ferramentas e selecione Recursos Avançados.

  4. No painel do console de gerenciamento de Usuários e Computadores do Active Directory, localize o contêiner duplicado e incorreto Objetos do Sistema do Microsoft Exchange ou a unidade organizacional (UO).

  5. Certifique-se de que o contêiner duplicado e incorreto Objetos do Sistema do Microsoft Exchange ou a UO não contenha objetos válidos do Active Directory.

  6. Clique com o botão direito no contêiner duplicado incorreto Objetos do Sistema do Microsoft Exchange ou na UO e clique em Excluir.

  7. Confirme a exclusão, clicando em Sim na caixa de diálogo Active Directory.

    Observação:
    Para replicar a alteração imediatamente, inicie a replicação manualmente entre os controladores de domínio.

Para obter mais informações sobre esse problema do Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 316280, "XADM: Uma descrição do atributo 'Nomes Globais ADC'" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=316280)

  • 252228, "XADM: O ADC parece criar objetos duplicados" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=252228)

  • 253800, "XADM: ADC pode criar objetos duplicados no Active Directory" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253800)

  • 274480, "XADM: Objeto duplicado é criado ao replicar objetos do Exchange Server 5.5 para o Active Directory do Windows 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=274480)

  • 288578, "XADM: O ADC cria contas duplicadas no Exchange Server 5.5 e Active Directory" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288578)


Erro ao acessar o Active Directory
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool determinou que um controlador de domínio do serviço de diretório do Active Directory® pode não estar disponível. Verifique se você tem conectividade de rede para um controlador de domínio do Active Directory.

Para corrigir esse erro

  • Se você tiver especificado um controlador de domínio do Active Directory no Exchange Server Analyzer, tente conectar sem especificar um controlador de domínio.

  • Se você não tiver especificado um controlador de domínio, especifique um que esteja em execução e disponível para você.


Erro ao acessar os Grupos administrativos do Exchange
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer determinou que uma organização do Exchange foi instalada na floresta do serviço de diretório do Active Directory® e que o acesso às informações de configuração da organização do Exchange no Active Directory foi bem-sucedido. No entanto, não foram encontrados grupos administrativos que contenham servidores Exchange.

Para corrigir esse erro:

  • Verifique se você tem as permissões adequadas no Active Directory para acessar o contêiner dos grupos administrativos do Exchange.

  • Se a estação de trabalho a partir da qual você está executando o Exchange Server Analyzer pertencer a outra floresta do Active Directory, ou se você não tiver feito logon com uma conta de domínio, talvez você tenha que se conectar a um controlador de domínio do Active Directory em uma floresta que hospede servidores Exchange.


Erro ao Acessar o Contêiner de Configuração do Exchange
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer determinou que o contêiner de configuração do Exchange está inacessível. As informações da organização do Exchange, do grupo administrativo e da configuração do servidor estão armazenadas no contexto de atribuição de nome Configuração no serviço de diretório do Active Directory®. Para acessar qualquer informação na configuração do Exchange, você precisa ler a ramificação do Microsoft Exchange do contêiner Configuração do Active Directory.

Para corrigir esse erro:

  • Verifique se você tem as permissões necessárias para ler o contêiner Configuração do Active Directory.

  • Verifique se você tem conectividade de rede para um controlador de domínio do Active Directory.


Nem todos os grupos de segurança tiveram o direito negado para criar pastas públicas de nível superior
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-12-04

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o SID (identificador de segurança) para o grupo de segurança Todos está listado no ntSecurityDescriptor do objeto da Organização do Exchange. Se o Exchange Server Analyzer verificar que o SID do grupo Todos está presente no ntSecurityDescriptor do objeto da Organização, será exibido um aviso. Esse aviso indica que o grupo Todos ainda não teve negado o direito de criar pastas públicas de nível superior.

No Exchange 2000 Server, o direito de criar pastas públicas de nível superior é permitido por padrão. No entanto, quando a versão do ForestPrep do Exchange Server 2003 ou do PrepareAD do Exchange Server 2007 é executada, é negado o acesso ao grupo de segurança Todos para criação de pastas públicas de nível superior. A funcionalidade de negar foi implementada como medida de segurança. A permissão para que o grupo de segurança Todos crie pastas públicas de nível superior pode deixar sua organização vulnerável a ataques de negação de serviço.

Portanto, é uma prática recomendada negar ao grupo de segurança Todos o direito à criação de pastas públicas de nível superior. Se você tiver o Exchange Server 2003 ou Exchange Server 2007, execute a versão do ForestPrep do Exchange Server 2003 ou a versão do PrepareAD do Exchange Server 2007, respectivamente. É possível executar a versão do ForestPrep do Exchange Server 2003 em um ambiente do Exchange 2000 Server. No entanto, instalações subseqüentes do Exchange 2000 Server redefinirão as permissões do grupo de segurança Todos para criar pastas públicas de nível superior.

Se você não tiver o Exchange Server 2003 nem o Exchange Server 2007, será possível definir essa permissão manualmente. Lembre-se de que instalações subseqüentes do Exchange 2000 Server redefinirão essa permissão. Portanto, você deve configurar manualmente essa permissão depois de cada instalação do Exchange 2000 Server. Antes de definir a permissão, é necessário habilitar a exibição da guia Segurança no Gerenciador de Sistema do Exchange, o que pode ser feito adicionando a entrada ShowSecurityPage ao Registro no computador do Exchange Server.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para adicionar a entrada ShowSecurityPage ao Registro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKEY_CURRENT_USER\Software\Microsoft\Exchange\ExAdmin

  3. Clique em Editar, clique em Novo e clique em Valor DWORD.

  4. Para o novo nome do valor, digite ShowSecurityPage e pressione ENTER.

  5. Clique duas vezes em ShowSecurityPage, tipo 1 no campo Dados do valor e clique em OK.

Para negar manualmente ao grupo de segurança Todos o direito à criação de pastas públicas em um ambiente do Exchange 2000 Server.

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Clique com o botão direito em Nome_da_Organização e clique em Propriedades.

  3. Na página Propriedades de Nome_da_Organização, clique na guia Segurança.

  4. Na guia Segurança em Nomes de grupo ou usuários, selecione Todos. Na caixa de diálogo Permissões para Todos, role para baixo até a permissão Criar pasta pública de nível superior, desmarque a caixa de seleção na coluna Permitir e clique em Aplicar.

Antes de editar o Registro e para obter informações sobre como editar o Registro, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (em inglês).

Para obter mais informações sobre como executar ForestPrep do Exchange 2003, consulte Guia de Implantação do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47569).

Para obter mais informações sobre a execução de PrepareAD do Exchange Server 2007, consulte "Como preparar o Active Directory e os domínios" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=78453).

Para obter mais informações sobre como negar ao grupo Todos o direito de criar uma pasta pública de nível superior no Exchange 2000 Server, consulte o artigo 328808 da Base de Dados de Conhecimento, "COMO FAZER: Remover a permissão de usuário da pasta pública superior de criação no Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328808).


Problema no contêiner de domínio do Exchange
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar se o contêiner Objetos do Sistema do Microsoft Exchange no Contexto de Atribuição de Nome de Domínio existe. Se o Exchange Server Analyzer verificar que o contêiner Objetos do Sistema do Microsoft Exchange não existe, que está mal formado ou é inválido, um erro será exibido.

O contêiner Objetos do Sistema Microsoft Exchange é criado em cada domínio quando o DomainPrep do Exchange é executado.

É necessário executar o DomainPrep no domínio em que o erro foi encontrado. O nome de domínio no qual o contêiner Objetos do Sistema do Microsoft Exchange está ausente é relacionado na saída do Exchange Server Analyzer.

A conta que você usar para executar o DomainPrep deve ser membro do grupo de segurança Administradores do Domínio no domínio local e um administrador de computador local.

Geralmente, você deve executar o DomainPrep nos seguintes domínios:

  • O domínio raiz.

  • Todos os domínios que conterão computadores com Exchange 2000 Server ou Exchange Server 2003.

  • Todos os domínios que conterão objetos habilitados para caixas de correio (como usuários e grupos) do Exchange 2000 Server ou Exchange Server 2003, mesmo que nenhum servidor Exchange vá ser instalado nesses domínios.

  • Todos os domínios que conterão servidores de catálogo global que os componentes de acesso de diretório do Exchange possam vir a usar.

  • Todos os domínios que conterão usuários e grupos do Exchange 2000 Server ou Exchange Server 2003 e grupos que você usará para gerenciar sua organização do Exchange.

Para executar o DomainPrep

  1. Insira o CD do Exchange na unidade de CD-ROM. Você pode executar o DomainPrep em qualquer computador do domínio.

  2. Em um prompt de comando, digite <unidade>:\setup\i386\setup /DomainPrep, em que <unidade> é a unidade de CD-ROM.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção do Componente, verifique se Ação está definido como DomainPrep. Caso contrário, clique na seta suspensa e clique em DomainPrep. Clique em Avançar.

  7. Na página Conclusão do Assistente do Microsoft Exchange, clique em Concluir.

Para obter mais informações sobre como executar o DomainPrep do Exchange Server 2003, consulte o Exchange 2003 Server Deployment Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47569).

Para obter mais informações sobre como executar o DomainPrep do Exchange 2000 Server, consulte "Instalação e configuração do Microsoft Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=5906) (em inglês).


Grupo de servidores de domínio do Exchange não encontrado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar o valor do atributo ntSecurityDescriptor dos Objetos do Sistema do Microsoft Exchange para determinar qual versão de DomainPrep foi executada no domínio.

Há dois inteiros válidos:

  • Para o Exchange 2000 Server, o valor de ntSecurityDescriptor é 4406.

  • Para o Exchange Server 2003, o valor de ntSecurityDescriptor é 6936.

Se for determinado que qualquer uma das versões acima do DomainPrep foram usadas, o Exchange Server Analyzer consultará o Active Directory para determinar o valor do atributo objectGuid do objeto Objetos do Sistema do Microsoft Exchange para determinar se o grupo Servidores de Domínio do Exchange existe. Se o Exchange Server Analyzer determinar que esse grupo não existe, um erro será exibido.

Para resolver esse erro, execute a versão final do DomainPrep do Exchange 2000 Server ou do DomainPrep do Exchange Server 2003. A conta que você usar para executar o DomainPrep deve ser membro do grupo de segurança Administradores do Domínio no domínio local e um administrador de computador local.

Você deve executar o DomainPrep nos seguintes domínios:

  • O domínio raiz.

  • Todos os domínios que conterão computadores com Exchange 2000 Server ou Exchange Server 2003.

  • Todos os domínios que conterão objetos habilitados para caixas de correio (como usuários e grupos) do Exchange 2000 Server ou Exchange Server 2003, mesmo que nenhum servidor Exchange vá ser instalado nesses domínios.

  • Todos os domínios que conterão servidores de catálogo global que os componentes de acesso de diretório do Exchange possam vir a usar.

  • Todos os domínios que conterão usuários e grupos do Exchange 2000 Server ou Exchange Server 2003 e grupos que você usará para gerenciar sua organização do Exchange.

Para executar o DomainPrep

  1. Insira o CD do Exchange em sua unidade de CD. Você pode executar o DomainPrep em qualquer computador do domínio.

  2. Em um prompt de comando, digite <unidade>:\setup\i386\setup /DomainPrep, onde <unidade> é sua unidade de CD.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção do Componente, verifique se Ação está definido como DomainPrep. Caso contrário, clique na seta suspensa e clique em DomainPrep. Clique em Avançar.

  7. Na página Conclusão do Assistente do Microsoft Exchange, clique em Concluir.

Para obter mais informações sobre como executar o DomainPrep do Exchange Server 2003, consulte o Exchange 2003 Server Deployment Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47569).

Para obter mais informações sobre como executar o DomainPrep do Exchange 2000 Server, consulte "Microsoft Exchange 2000 Server Installation and Setup" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=5906).


O grupo Exchange Enterprise Servers não foi encontrado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar o valor do atributo ntSecurityDescriptor dos Objetos do Sistema do Microsoft Exchange para determinar qual versão de DomainPrep foi executada no domínio.

Há dois inteiros válidos:

  • Para o Exchange 2000 Server, o valor de ntSecurityDescriptor é 4406.

  • Para o Exchange Server 2003, o valor de ntSecurityDescriptor é 6936.

Se for determinado que qualquer uma das versões acima do DomainPrep foi usada, o Exchange Server Analyzer consulta o Active Directory pra determinar o valor do atributo objectGuid do objeto Objetos do Sistema do Microsoft Exchange para determinar se o grupo Exchange Enterprise Servers existe. Se o Exchange Server Analyzer determinar que esse grupo não existe, um erro será exibido.

Para resolver esse erro, execute a versão final do DomainPrep do Exchange 2000 Server ou do DomainPrep do Exchange Server 2003. A conta que você usar para executar o DomainPrep deve ser membro do grupo de segurança Administradores do Domínio no domínio local e um administrador de computador local.

Você deve executar o DomainPrep nos seguintes domínios:

  • O domínio raiz.

  • Todos os domínios que conterão computadores com Exchange 2000 Server ou Exchange Server 2003.

  • Todos os domínios que conterão objetos habilitados para caixas de correio (como usuários e grupos) do Exchange 2000 Server ou Exchange Server 2003, mesmo que nenhum servidor Exchange vá ser instalado nesses domínios.

  • Todos os domínios que conterão servidores de catálogo global que os componentes de acesso de diretório do Exchange possam vir a usar.

  • Todos os domínios que conterão usuários e grupos do Exchange 2000 Server ou Exchange Server 2003 e grupos que você usará para gerenciar sua organização do Exchange.

Para executar o DomainPrep

  1. Insira o CD do Exchange em sua unidade de CD. Você pode executar o DomainPrep em qualquer computador do domínio.

  2. Em um prompt de comando, digite <unidade>:\setup\i386\setup /DomainPrep, onde <unidade> é sua unidade de CD.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção do Componente, verifique se Ação está definido como DomainPrep. Caso contrário, clique na seta suspensa e clique em DomainPrep. Clique em Avançar.

  7. Na página Conclusão do Assistente do Microsoft Exchange, clique em Concluir.

Para obter mais informações sobre como executar o DomainPrep do Exchange Server 2003, consulte o Exchange 2003 Server Deployment Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47569).

Para obter mais informações sobre como executar o DomainPrep do Exchange 2000 Server, consulte "Microsoft Exchange 2000 Server Installation and Setup" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=5906).


Objeto do Exchange no contêiner Achados e Perdidos
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-12-01

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se existe algum objeto no contêiner LostAndFoundConfig sob o contêiner Configuration. Se o Exchange Server Analyzer detectar a presença de objetos no contêiner LostAndFoundConfig, será exibido um erro juntamente com o objeto e a classe da qual o objeto deriva.

O contêiner LostAndFoundConfig armazena objetos que não podem ser reconciliados pelo Active Directory. Verifique se você incluiu todos os objetos existentes no contêiner LostAndFoundConfig, porque o Exchange tentará usá-los. Por exemplo, quando o Exchange consulta o Active Directory por classe de objeto (por exemplo, Servers), todos os objetos, independentemente de estarem incluídos no contêiner LostAndFoundConfig, são retornados como objetos válidos. Conseqüentemente, o Exchange pode tentar se conectar ao objeto Server que estiver sob o contêiner the LostAndFoundConfig, em vez do objeto real. Isso poderá gerar um comportamento imprevisível do Exchange e, inclusive, uma falha do servidor. A presença desses objetos também pode impedir a criação de objetos da mesma classe.

Para resolver este problema, remova as entradas do contêiner LostAndFoundConfig do Active Directory usando o recurso ADSI (Active Directory Service Interfaces) Edit.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP (ldp.exe) ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou do Exchange Server 2007 (ou de ambos). Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Observação:
ADSI Edit é uma ferramenta incluída nas ferramentas de Suporte do Windows 2000 Server e Windows Server 2003.

Para corrigir esse erro

  1. Abra o snap-in MMC de ADSI Edit.

  2. No menu Ação, clique em Conectar a.

  3. Na caixa de diálogo Configurações de Conexão, no campo Nome, digite um nome para a conexão ADSI. Em Ponto de Conexão, selecione Selecione um contexto de nomenclatura conhecido e, em seguida, selecione Configuração no menu suspenso. Clique em OK.

  4. No painel da esquerda, clique duas vezes no objeto Configuração e depois clique duas vezes em LostAndFoundConfig.

  5. No painel da direita, exclua todos os objetos e contêineres. Clique com o botão direito no objeto ou contêiner, clique em Excluir e depois em Sim.

  6. Saia do ADSI Edit.


A organização do Exchange não possui nenhuma diretiva de destinatário
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo Name no objeto Diretivas de Destinatário para cada organização do Exchange. Se o Exchange Server Analyzer determinar que não existe nenhum objeto de diretiva de destinatário ou que ele não contém diretivas, um erro será exibido.

Na instalação do Exchange Server, é criada uma diretiva de destinatário padrão que aplica os endereços SMTP e X.400 a todos os destinatários da organização do Exchange. Você pode modificar a diretiva padrão ou criar novas. Entretanto, a diretiva padrão não deverá ser excluída. Todos os destinatários de uma organização do Exchange devem ter endereços X.400 e SMTP. Caso não tenha diretivas de destinatário, a organização do Exchange terá problemas de confiabilidade.

Para criar uma diretiva de destinatário

  1. Clique em Iniciar, Todos os Programas, Microsoft Exchange e Gerenciador do Sistema.

  2. No painel esquerdo do Gerenciador do Sistema do Exchange, expanda a organização e depois Destinatários, clique com o botão direito em Diretivas de Destinatário, aponte para Novo e clique em Diretiva de Destinatário.

  3. Na caixa de diálogo Nova Diretiva, escolha o tipo de diretiva que você deseja criar, marcando a caixa de seleção Endereços de Email ou Configurações do Gerenciador de Caixa de Correio, ou ambas, e clique em OK.

  4. Na caixa de diálogo Propriedades, digite um nome para a nova diretiva de destinatário e clique em Modificar para criar um filtro para a diretiva de destinatário.

    Observação:
    Se você não criar um filtro, a diretiva não será aplicada a todos os destinatários.

  5. Para personalizar a diretiva de destinatário, vá para a guia Endereços de Email (Diretiva) ou Configurações do Gerenciador de Caixas de Correio (Diretiva) na caixa de diálogo Propriedades. Use as definições dessas guias para configurar a diretiva de destinatário e clique em OK para criar a diretiva.

  6. Clique com o botão direito na diretiva de destinatário do Gerenciador do Sistema do Exchange e clique em Aplicar Diretiva Agora.

Para obter mais informações sobre destinatários e diretivas de destinatário, consulte "Gerenciando destinatários e diretivas de destinatário" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

Para obter mais informações sobre como criar e configurar diretivas de destinatário, consulte o artigo 249299 da Base de Dados de Conhecimento da Microsoft, "COMO: Configurar Diretivas de Destinatário no Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249299).


A organização do Exchange não possui nenhuma diretiva de sistema
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o nome de cada diretiva de sistema no objeto Diretivas do Sistema para cada organização do Exchange. Se o Exchange Server Analyzer determina que não existe um objeto de diretivas do sistema ou que o objeto de diretivas de sistema não contém diretivas de sistema, um erro será exibido.

Você pode usar objetos de diretivas do sistema para simplificar a administração do sistema, configurando parâmetros para vários servidores Exchange através de um único objeto de configuração, como armazenamento de caixa de correio, armazenamento de pasta pública ou configurações do servidor. Por padrão, as seguintes diretivas de sistema são criadas quando você executa o ForestPrep em sua organização:

  • Associação oculta da DL

  • Destinatários Habilitados para Mensagens

  • Usuário Habilitado para Caixa de Correio

Se essas diretivas de sistema padrão não existirem em sua organização do Exchange, você terá problemas de confiabilidade. Para recriar as diretivas de sistema padrão, você deve executar o ForestPrep.

Para executar o ForestPrep do Exchange Server 2003

  1. Insira o CD do Exchange em sua unidade de CD.

  2. No menu Iniciar, clique em Executar e digite unidade:\setup\i386\setup /ForestPrep, em que unidade é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componente, verifique se Ação está definida como ForestPrep. Caso contrário, clique na seta suspensa e clique em ForestPrep. Clique em Avançar.

    Importante:
    Se ForestPrep não aparecer em Ação, talvez você tenha digitado errado o comando do ForestPrep na etapa 2. Se houver um erro de ortografia, volte para a etapa 2 e digite o comando novamente.

  7. Na página Conta do Administrador do Microsoft Exchange Server, na caixa Conta, digite o nome da conta ou grupo responsável por instalar o Exchange.

    Observação:
    A conta especificada também terá permissão para usar o Assistente de Delegação de Administração do Exchange para criar outras contas de administrador do Exchange. Para obter mais informações sobre o Assistente de Delegação de Administração do Exchange, consulte o Guia de Administração do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?linkid=47617).

  8. Clique em Avançar para iniciar o ForestPrep. Depois que o ForestPrep for iniciado, não será possível cancelar o processo.

    Observação:
    Dependendo de sua topologia de rede e da velocidade do controlador de domínio do Microsoft Windows® 2000 Server ou Microsoft Windows Server™ 2003, a conclusão do ForestPrep pode demorar.

  9. Na página Conclusão do Assistente do Microsoft Exchange, clique em Concluir.

Para obter informações sobre como as diretivas de sistema são usadas no Exchange, consulte o artigo 253838 da Base de Dados de Conhecimento Microsoft, "XADM: Como o Serviço de Atualização de Destinatário aplica diretivas de sistema" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253838).

Para obter mais informações sobre diretivas de sistema, consulte "Arquitetura do Gerenciador do Sistema do Exchange" no Guia de Referência Técnica do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47891).

Para obter informações sobre como criar diretivas de sistema não padrão no Exchange, consulte o artigo 256141 da Base de Dados de Conhecimento Microsoft, "Como criar diretivas de sistema no Exchange" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256141).


A porta NSPI de Catálogo Global foi substituída
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2007-01-15

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro nos servidores de catálogo global para determinar se a chave de Registro TCP/IP Port está definida:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters\TCP/IP Port

Se o Exchange Server Analyzer detectar que a chave de Registro TCP/IP Port foi criada e está definida, uma mensagem de configuração não-padrão será exibida.

A chave de Registro da Porta TCP/IP é exigida quando um servidor de catálogo global precisa usar uma porta específica para atender clientes MAPI. Se você não tiver tal requisito em seu ambiente Exchange, poderá remover essa chave.

.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para excluir a porta TCP/IP no servidor de catálogo global

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

  3. Clique com o botão direito na chave TCP/IP Port e clique em Excluir.

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar RPC sobre HTTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 833401, "Como configurar RPC sobre HTTP em um único servidor no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "Como solucionar problemas de conexões cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)

  • 298369, "Como configurar um servidor de catálogo global para utilizar uma porta específica ao atender clientes MAPI" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298369) (página em inglês).

  • 24823, "Cenários de implantação de RPC sobre HTTP no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=24823) (página em inglês).


A porta do catálogo global 3268 não está respondendo
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo isGlobalCatalogReady do servidor. Um valor True nesse atributo indica que o servidor de diretório também é um servidor de catálogo global em funcionamento, e um valor False indica que o servidor de diretório não é um servidor de catálogo global.

Em seguida, o Exchange Server Analyzer se conecta à porta 3268 no servidor Exchange para verificar se essa porta está respondendo.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O servidor for um servidor de catálogo global.

  • A porta 3268 não estiver respondendo.

Observação:
Esta mensagem poderá ser exibida em uma condição de erro se existir um firewall entre o computador que está executando o Exchange Server Analyzer e o servidor de catálogo global.

Geralmente, esse problema ocorre quando a caixa de seleção do servidor de catálogo global foi marcada, mas o servidor não foi reinicializado.

Para corrigir esse problema

  • Reinicie o serviço.

Para obter mais informações sobre como promover controladores de domínio, consulte o artigo 304403 da Base de Dados de Conhecimento Microsoft, "XADM: Considerações do Exchange para promover um controlador de domínio a um servidor de catálogo global" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403).


Erro no esquema de classes do grupo
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-12-01

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se a classe msExchBaseClass aparece no atributo auxiliaryClass de objetos do Grupo no esquema do Active Directory.

O Active Directory possui classes predefinidas, que definem todos os tipos de objetos diferentes que o diretório deve possuir para funcionar corretamente. As definições dos objetos são criadas através do aninhamento de classes entre si. O aninhamento de classes produz um relacionamento de pai/filho entre elas.

A classe msExchBaseClass é adicionada ao Active Directory quando você instala o Exchange 2000 Server, o Exchange Server 2003 e o Exchange Server 2007. A classe msExchBaseClass é a classe auxiliar base aplicada a todas as classes estendidas por CDO para Exchange 2000 Server, Exchange Server 2003 e Exchange Server 2007 (CDOEX). O CDOEX fornece classes e interfaces fundamentais do COM (Component Object Model), utilizadas para gerenciar a maioria dos tipos de informações no armazenamento do Exchange.

A modificação incorreta do esquema do Active Directory pode romper o relacionamento entre a classe msExchBaseClass e o atributo auxiliaryClass dos objetos do Grupo. Esse rompimento pode causar instabilidade no servidor Exchange, como erros de processamento de Serviços de Atualização de Destinatários ou impedir a instalação de novos servidores Exchange Server 200x na organização.

Se o Exchange Server Analyzer verificar que a classe msExchBaseClass não aparece no atributo auxiliaryClass dos objetos do Grupo no esquema do Active Directory, isso indica que esse relacionamento está rompido. Se a classe msExchBaseClass não aparecer no atributo auxiliaryClass dos objetos do Grupo no esquema do Active Directory, o Exchange Server Analyzer exibirá um erro.

Para corrigir este erro, entre em contato com Atendimento Microsoft (http://go.microsoft.com/fwlink/?LinkId=41364).


O Hosted Exchange exige uma organização do Exchange em modo nativo
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar se o ambiente do Exchange Server está configurado como um ambiente do Hosted Exchange. Se o ambiente do Exchange Server for um ambiente do Hosted Exchange, o Exchange Server Analyzer consulta o Active Directory para determinar se a organização do Exchange está sendo executada em modo misto.

Se a organização do Exchange estiver sendo executada em modo misto, um aviso será exibido. Soluções Hosted Exchange exigem uma organização em modo nativo.

Após alternar para o modo nativo, não é possível retornar para o modo misto.

Para alternar para o modo nativo

  1. Inicie o Gerenciador do Sistema do Exchange: Clique em Iniciar, aponte para Todos os Programas, aponte para Microsoft Exchange e clique em Gerenciador do Sistema.

  2. Na árvore do console, clique com o botão direito na organização que você deseja alternar para o modo nativo e clique em Propriedades.

  3. Em Propriedades<do Nome da Organização>, em Alterar modo de operação, clique em Alterar Modo.

  4. Na caixa de diálogo de aviso, clique em Sim se tiver certeza de que deseja mudar permanentemente para o modo nativo. Clique em Aplicar para aceitar o novo modo do Exchange.

Para tirar o máximo proveito do modo nativo do Exchange, você deve reiniciar o serviço Armazenamento de Informações do Microsoft Exchange em todos os servidores Exchange de sua organização. Não é necessário reiniciar todos os serviços Armazenamento de Informações do Microsoft Exchange ao mesmo tempo, mas você deve reiniciar o serviço em cada servidor para que ele possa aproveitar ao máximo os recursos do modo nativo do Exchange. Reinicie o serviço em seus servidores após a alteração para o modo nativo ter sido replicada para o controlador de domínio do Microsoft Windows® local.

Para reiniciar o serviço de Armazenamento de Informações do Microsoft Exchange

  1. Clique em Iniciar, clique em Executar, digite services.msc e clique em OK.

  2. No painel Serviços (Local), localize o serviço Armazenamento de Informações do Microsoft Exchange.

  3. Clique com o botão direito no serviço e clique em Reiniciar.

Para obter mais informações sobre ambientes do Hosted Exchange, consulte os seguintes artigos:

  • "Information for Hosters" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=46307)

  • "Chapter 23 - Hosted Service Environments" no Exchange Server 2000 Resource Kit (em inglês) (http://go.microsoft.com/fwlink/?LinkId=46326)

Para obter mais informações sobre como alternar do modo misto para o nativo, consulte o artigo 32779 da Base de Dados de Conhecimento Microsoft, "COMO FAZER: Converter do modo misto para o modo nativo no Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779).


A função do servidor FSMO de Infra-estrutura não respondeu
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo fSMORoleOwner do mestre de infra-estrutura no Contexto de Nomeação de Configuração. Por exemplo, em um domínio denominado contoso.com, fSMORoleOwner para o mestre de infra-estrutura é um atributo de CN=Infra-estrutura,DC=contoso,DC=com. O Analisador do Exchange Server tenta abrir uma conexão LDAP (Lightweight Directory Access Protocol) com a porta TCP 389 no controlador de domínio que armazena atualmente essa função. Se o Analisador do Exchange Server não puder se conectar a esse controlador de domínio, um erro será exibido.

O mestre de infra-estrutura atualiza as referências de grupo de acordo com o usuário, sempre que os membros de grupos forem renomeados ou alterados em um domínio. O controlador de domíno que contém a função de mestre de infra-estrutura para o domínio do grupo atualiza a referência de grupo para usuários entre domínios para refletir o novo nome do usuário. Periodicamente, o mestre de infra-estrutura verifica as contas de domínio e a associação dos grupos. Se uma conta de usuário for movida para um novo domínio, o mestre de infra-estrutura identifica o novo domínio da conta do usuário e atualiza o grupo. Depois que o mestre de infra-estrutura atualiza essas referências localmente, ele usa a replicação para atualizar todas as outras réplicas do domínio. Se o mestre de infra-estrutura não estiver disponível, essas atualizações serão atrasadas. A qualquer momento, pode haver somente um controlador de domínio agindo como mestre de infra-estrutura em cada domínio.

Para corrigir esse erro

  1. Verifique se o servidor de diretório especificado no erro está online e acessível pelos servidores Exchange em sua organização.

  2. Se esse servidor de diretório tiver sido descomissionado, você deve atribuir a função de mestre de infra-estrutura a outro controlador de domínio.

Para obter mais informações sobre a transferência da função de mestre de infra-estrutura de um controlador de domínio para outro, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • Para o Microsoft Windows Server™ 2003, consulte 324801, "Como exibir e transferir as funções FSMO no Windows Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Para o Microsoft Windows 2000 Server, consulte 255690, "COMO: Exibir e transferir as funções FSMO na interface gráfica do usuário" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)


Atributo de versão inválida no objeto da organização do Exchange
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2007-02-28

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar as informações de versão de esquema do Exchange. Mais especificamente, o Exchange Server Analyzer examina o seguinte objeto do Active Directory para determinar o valor atual do atributo rangeUpper:

CN=ms-Exch-Schema-Version-Pt,CN=Esquema,CN=Configuração,DC=<DN-de-domínio-raiz-da-floresta>

O valor 4397 de rangeUpper indica que o Exchange 2000 Server está instalado.

O valor 6870 de rangeUpper indica que o Exchange Server 2003 está instalado.

O valor 10637 de rangeUpper indica que o Exchange Server 2007 está instalado.

Se o Exchange Server Analyzer encontrar qualquer outro valor para rangeUpper, um erro será exibido.

O valor de rangeUpper é inserido pelo Exchange 2000 Server ou Exchange Server 2003 durante o processo ForestPrep. Um valor diferente de 4397, 6870 ou 10637 geralmente indica que uma versão beta ou de pré-lançamento do Exchange foi usada para a execução de ForestPrep ou, no caso do Exchange Server 2007, PrepareDomain.

Para resolver esse problema para o Exchange 2000 Server ou Exchange Server 2003, execute o processo ForestPrep novamente usando a versão de lançamento do Exchange instalada em seu ambiente. Para o Exchange Server 2007, execute o processo PrepareSchema novamente usando a versão de lançamento do Exchange que está instalada em seu ambiente. Execute ForestPrep ou PrepareSchema depois de fazer logon em uma conta que tenha o mínimo dos seguintes direitos:

  • Administrador de Empresas

  • Administrador do Esquema

  • Administrador de Domínio

  • Administrador da Máquina Local (se estiver sendo executado apenas no servidor membro)

Para corrigir esse erro no Exchange 2000 Server ou no Exchange Server 2003

  1. Execute setup.exe /forestprep.

  2. Verifique se o processo ForestPrep foi concluído com êxito.

Para corrigir esse erro no Exchange Server 2007

  1. Execute setup.exe /PrepareSchema.

  2. Verifique se o processo PrepareSchema foi concluído com êxito.

Para obter detalhes sobre como instalar o Exchange e executar o processo PrepareSchema, consulte a seguinte documentação do produto:

  • "Como preparar o Active Directory e os domínios" http://go.microsoft.com/fwlink/?LinkId=78453 (página em inglês)

Para obter detalhes sobre como instalar o Exchange e executar o processo ForestPrep, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 312371, "COMO FAZER PARA: Preparar a floresta usando o processo ForestPrep no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371). Esse artigo se aplica ao Exchange 2000 Server e ao Exchange Server 2003.

  • 274737, "Como verificar se o ForestPrep e o DomainPrep foram concluídos com êxito no Exchange 2000 Server ou no Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=274737)

  • 828765, "Permissões que você deve ter para instalar componentes no Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828765)


Informações sobre a conta herdada presentes no grupo administrativo de modo nativo
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o atributo msExchLegacyAccount em cada objeto de grupo administrativo do Exchange contém dados.

O Exchange Server Analyzer também consulta o Active Directory para determinar o valor do atributo msExchAdminGroupMode de cada grupo administrativo. Um valor 0 para o atributo msExchAdminGroupMode indica que o grupo administrativo está no modo nativo do Exchange. Um valor 1 indica um ambiente puro do Exchange Server 5.5 e um valor 2 indica o Exchange em modo misto.

Se o Exchange Server Analyzer detectar que o atributo msExchLegacyAccount contém dados e que o valor do atributo msExchAdminGroupMode é 0, um erro será exibido.

Quando você alterna para o modo nativo do Exchange, o atributo msExchLegacyAccount é excluído. Esse atributo só é usado em organizações do Exchange em modo misto nas quais o Exchange Server 5.5 ainda esteja presente. Os dados reais do atributo são a conta de serviço do Exchange Server 5.5 e sua presença no atributo msExchLegacyAccount em uma organização do Exchange no modo nativo acarretará mau funcionamento durante as atualizações e instalações de service packs. Na verdade, apenas a presença do atributo, mesmo sem conter dados, causará mau funcionamento. Isso ocorre porque a Instalação do Exchange usa esse atributo como um meio de descobrir se uma organização do Exchange está no modo misto ou nativo. Se esse atributo existir, a instalação do Exchange será executada em uma configuração de modo misto para uma instalação que está, na verdade, em modo nativo.

É provável que o atributo msExchLegacyAccount ainda exista se você removeu manualmente dados do Active Directory usando o snap-in do ADSI (Active Directory Service Interfaces) Edit.

Você deve remover os dados do atributo msExchLegacyAccount editando-o manualmente com a ferramenta LDP (ldp.exe). Você deve usar a ferramenta LDP ou outro cliente de protocolo LDAP versão 3 para remover completamente os dados e o atributo do diretório. O snap-in ADSI Edit não basta neste caso, porque ele só remove os dados, mas deixa o atributo. LDP.exe faz parte do pacote de Ferramentas de Suporte do Windows®.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para remover o atributo msExchLegacyAccount

  1. Inicie LDP.exe.

  2. No menu Conexão, clique em Conectar; na caixa de diálogo Conectar, digite o nome do Controlador de Domínio na mesma floresta do Active Directory de sua Organização do Exchange e clique em OK.

  3. No menu Conexão, clique em Ligar; na caixa de diálogo Ligar, digite as credenciais que tenham pelo menos direitos Administrativos Completos do Exchange no nível do Grupo Administrativo e clique em OK.

  4. No menu Exibir, clique em Árvore; na caixa de diálogo Exibição em Árvore, deixe o campo vazio se você estiver se conectando a partir de um domínio raiz; caso contrário, digite CN=Configuração,DC=Nome_de_domínio, DC=Sufixo_de_domínio onde Nome_de_domínio é o domínio raiz na floresta do Active Directory e Sufixo_de_domínio é o sufixo do domínio, por exemplo, com, net e org. Clique em OK.

  5. Expanda a exibição da hierarquia no painel da esquerda de LDP até abrir seu grupo administrativo. Para fazer isso, clique duas vezes nos nós na seguinte ordem (observe que cada nó de LDP é seguido pelo DN, Nome Distinto, completo; apenas os CNs localizados mais à esquerda são mencionados aqui com fins de clareza):

    1. DC=Nome_de_domínio

    2. CN=Configuração

    3. CN=Serviços

    4. CN=Microsoft Exchange

    5. CN=Nome_da_organização

    6. CN=Grupos Administrativos

    7. CN=Nome_do_grupo_administrativo

    No painel de detalhes (direita) da ferramenta LDP, role a tela para baixo para exibir os atributos do seu grupo administrativo. Se o atributo msExchLegacyAccount estiver lá, exclua-o. Se o atributo msExchLegacyAccount estiver lá, será provável que os atributos msExchLegacyDomain e msExchEncryptedPassword também estejam presentes. Se eles forem, você deverá excluí-los também.

  6. No painel de hierarquia (esquerda) da ferramenta LDP, clique com o botão direito em Nome_do_grupo_administrativo e clique em Modificar.

  7. Na caixa de diálogo Modificar, verifique se o DN completo listado no campo Dn está identificando corretamente o grupo administrativo que você precisa modificar. Ele deve ser assim: CN=Nome_do_grupo_administrativo,CN=Grupos Administrativos,CN=Nome_da_Organização,CN=Microsoft Exchange,CN=Serviços,CN=Configuração,DC=Nome_do_domínio.

  8. Na caixa de diálogo Modificar, em Operações, selecione Excluir; na entrada Editar entrada, digite msExchLegacyAccount no campo Atributo e clique em Inserir. Isso adiciona msExchLegacyAccount à Lista de Entradas. A Lista de Entradas define os atributos que serão excluídos quando você clicar em Executar.

  9. Se os atributos msExchLegacyDomain ou msExchEncryptedPassword existirem no grupo administrativo, adicione-os à Lista de Entradas, como descrito na Etapa 8.

  10. Quando a Lista de Entradas contiver os atributos que você deve excluir, clique em Executar. Uma mensagem de status será exibida no painel de detalhes da LDP.

  11. No menu Conexão, clique em Novo para limpar o painel de detalhes da LDP.

  12. Navegue até CN=Nome_do_grupo_administrativo e clique duas vezes no objeto. Revise o conteúdo do painel da direita para verificar se os atributos foram excluídos.

Para obter mais informações sobre como modificar o Active Directory com a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


O atributo legacyExchangeDN da organização do Exchange é inválido
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2007-02-01

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o formato do atributo legacyExchangeDN no objeto da organização do Exchange. Se o Exchange Server Analyzer detectar que o atributo legacyExchangeDN é inválido ou malformado, será exibido um erro.

O valor desse atributo deve ser expresso na forma /o=Organization, onde Organization é o nome da organização do Exchange. Se o valor iniciar com algo diferente de /o= ou /O=, será considerado malformado. Esse problema deve ser corrigido o mais rapidamente possível.

Para corrigir esse erro no Exchange 2000 Server ou no Exchange Server 2003

  1. Execute o processo ForestPrep do Exchange Server. Durante esse processo, se o programa de instalação determinar que legacyExchangeDN está no formato incorreto, o problema será corrigido automaticamente.

Para corrigir esse erro no Exchange Server 2007

  1. Execute o processo PrepareAD do Exchange Server. Durante esse processo, se o programa de instalação determinar que legacyExchangeDN está no formato incorreto, o problema será corrigido automaticamente.

Para obter mais informações sobre o processo ForestPrep, consulte o artigo 312371 da Base de Dados de Conhecimento Microsoft, "COMO: Preparar a floresta usando o processo ForestPrep no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371) (em inglês).

Para obter mais informações sobre o processo PrepareAD, consulte "Como preparar o Active Directory e os domínios" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=78453).

Para obter mais informações sobre o atributo legacyExchangeDN e sobre como alterá-lo, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 324606, "XADM: Como usar o Legacydn.exe para corrigir nomes de organizações e grupos administrativos do Exchange" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324606).

  • 286783, "XADM: Mensagem de erro ao atualizar dados de disponibilidade no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286783).

  • 301585, "XADM: Soluções alternativas para problemas no MBconn.exe" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301585).


Informações de domínio herdado presentes no grupo administrativo de modo nativo
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o atributo msExchLegacyDomain em cada objeto do Grupo Administrativo do Exchange contém dados.

O Exchange Server Analyzer também consulta o Active Directory para determinar o valor do atributo msExchAdminGroupMode de cada grupo administrativo. Um valor 0 para o atributo msExchAdminGroupMode indica que o grupo administrativo está no modo nativo do Exchange. Um valor 1 indica um ambiente puro do Exchange Server 5.5 e um valor 2 indica o Exchange em modo misto.

Se o Exchange Server Analyzer detectar que o atributo msExchLegacyDomain contém dados e que o valor do atributo msExchAdminGroupMode é 0, um erro será exibido.

Ao mudar o Exchange para o modo nativo, o atributo msExchLegacyDomain é excluído. Esse atributo só é usado em organizações do Exchange em modo misto nas quais o Exchange Server 5.5 ainda esteja presente. Os dados reais do atributo representam o domínio de conta de serviço do Exchange Server 5.5 e sua presença no atributo msExchLegacyDomain em uma organização do Exchange em modo nativo causará mau funcionamento durante atualizações e instalações de service pack. Na verdade, apenas a presença do atributo, mesmo sem conter dados, causará mau funcionamento. Isso se deve ao fato de que o programa de instalação do Exchange usa esse atributo como forma de descobrir se uma organização do Exchange está em modo misto ou nativo. Se esse atributo existir, a instalação do Exchange será executada em uma configuração de modo misto para uma instalação que está, na verdade, em modo nativo.

Provavelmente, o atributo msExchLegacyDomain ainda existirá, se você tiver removido os dados manualmente do Active Directory usando o snap-in ADSI Edit.

É necessário remover esses dados do atributo msExchLegacyDomain editando-o manualmente com a ferramenta LDP (ldp.exe). Você deve usar a ferramenta LDP ou outro cliente de protocolo LDAP versão 3 para remover completamente os dados e o atributo do diretório. O snap-in ADSI Edit não é suficiente nesse caso, pois ele só remove os dados, deixando o atributo. LDP.exe faz parte do pacote de Ferramentas de Suporte do Windows®.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para remover o atributo msExchLegacyDomain

  1. Inicie LDP.exe.

  2. No menu Conexão, clique em Conectar; na caixa de diálogo Conectar, digite o nome do Controlador de Domínio na mesma floresta do Active Directory de sua Organização do Exchange e clique em OK.

  3. No menu Conexão, clique em Ligar; na caixa de diálogo Ligar, digite as credenciais que tenham pelo menos direitos Administrativos Completos do Exchange no nível do Grupo Administrativo e clique em OK.

  4. No menu Exibir, clique em Árvore; na caixa de diálogo Exibição em Árvore, deixe o campo vazio se você estiver conectando a partir do domínio raiz; caso contrário, digite CN=Configuration,DC=Nome_de_domínio, DC=Sufixo_de_domínio, em que Nome_de_domínio é o domínio raiz na floresta do Active Directory e Sufixo_de_domínio é o sufixo do domínio, por exemplo, com, net ou org. Clique em OK.

  5. Expanda a exibição da hierarquia no painel da esquerda de LDP até abrir seu grupo administrativo. Para fazer isso, clique duas vezes nos nós na seguinte ordem (observe que cada nó de LDP é seguido pelo DN, Nome Distinto, completo; apenas os CNs localizados mais à esquerda são mencionados aqui com fins de clareza):

    • DC=Nome_de_domínio

    • CN=Configuração

    • CN=Serviços

    • CN=Microsoft Exchange

    • CN=Nome_da_organização

    • CN=Grupos Administrativos

    • CN=Nome_do_grupo_administrativo

    No painel de detalhes (direita) da ferramenta LDP, role a tela para baixo para exibir os atributos do seu grupo administrativo. Se o atributo msExchLegacyDomain estiver presente, você deverá excluí-lo. Se o atributo msExchLegacyDomain estiver presente, os atributos msExchLegacyDomain e msExchEncryptedPassword provavelmente também estarão. Se eles forem, você deverá excluí-los também.

  6. No painel de hierarquia (esquerda) da ferramenta LDP, clique com o botão direito em Nome_do_grupo_administrativo e clique em Modificar.

  7. Na caixa de diálogo Modificar, verifique se o DN completo listado no campo Dn está identificando corretamente o grupo administrativo que você precisa modificar. Ele deve ser assim: CN=Nome_do_grupo_administrativo,CN=Grupos Administrativos,CN=Nome_da_Organização,CN=Microsoft Exchange,CN=Serviços,CN=Configuração,DC=Nome_do_domínio.

  8. Na caixa de diálogo Modificar, em Operações, selecione Excluir; na entrada Editar entrada, digite msExchLegacyAccount no campo Atributo e clique em Inserir. Isso adiciona msExchLegacyAccount à Lista de Entradas. A Lista de Entradas define os atributos que serão excluídos quando você clicar em Executar.

  9. Se o atributo msExchLegacyAccount ou msExchEncryptedPassword existir no grupo administrativo, adicione-o à Lista de Entradas, conforme descrito na etapa 8.

  10. Quando a Lista de Entradas contiver os atributos que você deve excluir, clique em Executar. Uma mensagem de status será exibida no painel de detalhes da LDP.

  11. No menu Conexão, clique em Novo para limpar o painel de detalhes da LDP.

  12. Navegue até CN=Nome_do_grupo_administrativo e clique duas vezes no objeto. Revise o conteúdo do painel da direita para verificar se os atributos foram excluídos.

Para obter mais informações sobre como modificar o Active Directory com a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


O LegacyExchangeDN para esse grupo administrativo não corresponde à organização pai
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-11-30

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o formato do atributo legacyExchangeDN no objeto do contêiner do grupo administrativo. Se o Exchange Server Analyzer verificar que o atributo legacyExchangeDN no grupo administrativo não corresponde a legacyExchangeDN para a organização do Exchange, um erro será exibido.

O Exchange usa o valor de legacyExchangeDN para identificar objetos do Exchange no Active Directory. O valor de legacyExchangeDN é um nome distinto, que indica onde o objeto se enquadra na organização do Exchange, por exemplo:

/o= organização /ou= grupo administrativo

Objetos como servidores e hierarquias de pastas herdam parte dos respectivos valores de legacyExchangeDN do grupo administrativo. Isso significa que se ocorrer um problema no valor do grupo administrativo, vários outros objetos poderão herdar o mesmo problema.

Normalmente, problemas com o legacyExchangeDN ocorrem quando um administrador tentou modificar o valor diretamente. Você deve corrigir o valor usando uma ferramenta como a snap-in Active Directory Service Interfaces (ADSI) Edit, LDP (ldp.exe) ou qualquer outro cliente de protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou do Exchange Server 2007 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro

  1. Use um editor do Active Directory, como o ADSI Edit, para localizar o objeto do grupo administrativo no Active Directory.

    É possível encontrar o atributo legacyExchangeDN em:

    CN=Configuração, CN=Serviços, CN=Microsoft Exchange, CN=Organização, CN=Grupos Administrativos, CN= Grupo administrativo

  2. Digite um novo valor de cadeia de caracteres do formulário:

    /o= organização /ou= grupo administrativo

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como trabalhar com ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda do Windows Server.


O legacyExchangeDN para esse grupo administrativo é inválido
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para verificar o valor de legacyExchangeDN de um grupo administrativo. Esse erro será exibido se a organização ou grupo administrativo nomeado no valor de legacyExchangeDN não corresponder ao nome real da organização ou grupo administrativo, ou se estiver faltando integralmente uma parte do valor.

O Exchange usa o valor de legacyExchangeDN para identificar objetos do Exchange no Active Directory. O valor de legacyExchangeDN é um nome distinto, que indica onde o objeto se enquadra na organização do Exchange, por exemplo:

/o= organização /ou= grupo administrativo

Objetos como servidores e hierarquias de pastas herdam parte dos respectivos valores de legacyExchangeDN do grupo administrativo. Isso significa que se ocorrer um problema no valor do grupo administrativo, vários outros objetos poderão herdar o mesmo problema.

Geralmente, problemas com legacyExchangeDN ocorrem quando um administrador tentou modificar o valor diretamente. Você deve corrigir o valor usando uma ferramenta como a snap-in Active Directory Service Interfaces (ADSI) Edit, LDP (ldp.exe) ou qualquer outro cliente de protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável por estas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro

  1. Use um editor do Active Directory, como o ADSI Edit, para localizar o objeto do grupo administrativo no Active Directory.

    É possível encontrar o atributo legacyExchangeDN em:

    CN=Configuração, CN=Serviços, CN=Microsoft Exchange, CN=Organização, CN=Grupos Administrativos, CN= Grupo administrativo

  2. Digite um novo valor de cadeia de caracteres do formulário:

    /o= organização /ou= grupo administrativo

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como trabalhar com ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda online do Windows Server.


Grupos não universais habilitados para mensagens presentes
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o número de domínios existentes no ambiente. Se o Exchange Server Analyzer encontrar vários domínios discretos do Active Directory na floresta, cada domínio será consultado para determinar se existe um ou mais grupos não universais habilitados para email nesses domínios.

Se o Exchange Server Analyzer determinar que grupos não universais habilitados para email existem na floresta de vários domínios, o Exchange Server Analyzer exibirá um aviso.

Se você usar grupos de distribuição globais ou locais de domínio em uma floresta de vários domínios, poderão ocorrer problemas na entrega de email pelo seguinte motivo:

  • Para expandir grupos de distribuição para destinatários individuais, o Exchange entra em contato com um servidor de catálogo global.

  • Mesmo tendo uma lista de grupos de todos os tipos de cada domínio, o servidor de catálogo global não contém a lista de associações de grupos locais e globais de domínio, criados em domínios remotos.

  • Se uma mensagem for enviada para um grupo de distribuição global, mas expandido em um domínio primário, o Exchange não poderá entregar corretamente a mensagem aos membros do grupo.

  • Como o categorizador não pode expandir a lista de distribuição, quando um usuário enviar uma mensagem para um grupo de distribuição global ou grupo de segurança habilitado para email em uma floresta de vários domínios, será possível que os usuários no grupo de distribuição global não recebam a mensagem.

  • A última entrada nos logs de controle é um envio ao categorizador. O remetente da mensagem não recebe uma notificação de falha na entrega.

Para resolver esse problema e garantir a entrega do email, use grupos de distribuição universais em um ambiente de vários domínios. A associação dos grupos de distribuição universais é replicada para cada servidor de catálogo global em cada domínio.

Para obter mais informações sobre esse problema específico e sobre os grupos de distribuição universais em geral, consulte os seguintes tópicos:

  • "Usando grupos habilitados para email em ambientes de vários domínios" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617) (em inglês).

  • A seção "Escopo do grupo" de "Compreendendo os grupos" no Active Directory (http://go.microsoft.com/fwlink/?LinkId=51276) (em inglês).

  • "Diretrizes para criar grupos de distribuição com base em consulta" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617) (em inglês).

Além disso, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 231273, "XADM: A entrega de mensagens para grupos globais não funciona" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=271930) (em inglês).

  • 283051, "XCON: Um email enviado para um grupo global habilitado para email pode desaparecer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=283051) (em inglês).

  • 231273, "Tipo de grupo e uso do escopo no Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231273) (em inglês).


A alteração da diretiva do sistema Usuário Habilitado de Caixa de Correio é necessária
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-08-10

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo purportedSearch de cada objeto de diretiva do sistema do Exchange. O atributo purportedSearch indica o argumento de pesquisa usado quando a diretiva é aplicada.

O Exchange Server Analyzer também consulta o Active Directory para determinar o valor do atributo msDS-Behavior-Version do objeto de floresta no Active Directory, Configurações NTDS. Esse valor indica o nível funcional de floresta do Active Directory. Os valores válidos para o atributo msDS-Behavior-Version são mostrados na tabela a seguir.

Valor | Nível funcional de floresta
0 | Misto do Microsoft Windows® 2000 Server
1 | Provisório do Microsoft Windows Server™ 2003
2 | Nativo do Microsoft Windows Server 2003

O Exchange Server Analyzer também consulta o Active Directory para determinar o valor para o atributo revision do contêiner Windows2003Update. O valor desse atributo indica se o utilitário de preparação do Active Directory (ADPrep.exe) foi executado.

Finalmente, o Exchange Server Analyzer consulta a classe Win32_OperatingSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar o valor da chave OSProductSuite. O valor da chave OSProductSuite indica a versão do Windows que está sendo executada no computador.

Se o Exchange Server Analyzer detectar que os seguintes critérios são verdadeiros, um aviso será exibido:

  • O valor do atributo purportedSearch da diretiva do sistema Habilitar Usuário da Caixa de Correio não é igual a (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

  • O nível funcional de floresta do Active Directory é o modo provisório ou nativo do Windows Server 2003.

  • O computador do Exchange Server não está executando o Windows Small Business Server 2003.

Para evitar problemas de nova hospedagem da caixa de correio, é necessária uma modificação nas diretivas do sistema. Essa atualização pode ser feita com o ADSI Edit (ADSIEdit.msc), a ferramenta LDP (ldp.exe) ou outra ferramenta de edição do Active Directory.

Se o Windows Server 2003 for usado como controlador de domínio e a diretiva Usuário Habilitado de Caixa de Correio não estiver atualizada, a replicação de valor vinculada no Windows Server 2003 fará com que o Serviço de Atualização de Destinatário substitua o valor do atributo homeMDB de novos usuários, fazendo com que suas caixas de correio sejam removidas para o primeiro armazenamento do servidor.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir que você reinstale o Windows Server 2003, o Exchange Server 2003, ou ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse erro

  1. Inicie o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração, expanda CN=Serviços, CN=Microsoft Exchange e CN=<ExchangeOrganizationName>.

  3. Selecione CN=Diretivas do Sistema.

  4. No painel da direita, clique com o botão direito em CN=Habilitar Usuário da Caixa de Correio e selecione Propriedades.

  5. Role para baixo para selecionar o atributo purportedSearch e clique em Editar.

  6. Limpe o atributo e configure-o com o seguinte filtro:

    (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

    Observação:
    O filtro mostrado na Etapa 6 foi agrupado para maior facilidade de leitura. Verifique se você digita o filtro sem nenhum espaço ou marca de parágrafo.

  7. Clique em OK novamente para salvar a alteração e feche o ADSI Edit.

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o utilitário LDP para modificar os atributos de objeto do Active Directory" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745) (pode estar em inglês).

Para obter mais informações sobre este problema e o respectivo impacto, consulte o artigo 903291 da Base de Dados de Conhecimento Microsoft, "O Serviço de Atualização de Destinatário pode substituir o valor do atributo homeMDB para os novos usuários do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=903291) (em inglês).


Interface MAPI desabilitada no catálogo global
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a chave de Registro existe:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

Se o Analisador do Exchange Server detectar que a chave Initialize MAPI interface está presente e configurada para qualquer valor numérico, um erro será exibido.

Quando a chave de Registro Initialize MAPI interface estiver presente, os clientes do Microsoft Office Outlook® não poderão entrar em contato com o catálogo de endereços neste servidor. Para corrigir esse problema, você deve remover a chave de Registro Initialize MAPI interface.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

  3. Clique com o botão direito na chave Inicializar a interface MAPI e selecione Excluir.

  4. Feche o editor de Registro e reinicie o servidor Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a chave de Registro Initialize MAPI interface, consulte o artigo 275127 da Base de Dados de Conhecimento da Microsoft, "XADM:Como configurar o Exchange Server 5.5 para ser executado em um controlador de domínio que seja um catálogo global" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=275127)


MaxActiveQueries foi modificado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o número máximo de consultas LDAP que podem ser processadas ao mesmo tempo. Esse valor é obtido examinando as diretivas administrativas de LDAP. O Exchange Server Analyzer verifica especificamente a presença de MaxActiveQueries. Se o Exchange Server Analyzer determinar que MaxActiveQueries existe e está configurado com um valor diferente de 20, será exibida uma mensagem de configuração não padrão.

Os limites administrativos do LDAP equilibram as capacidades operacionais do Active Directory e seu desempenho. Esses limites impedem que operações específicas afetem adversamente o desempenho do servidor. O aumento dessa configuração além do seu valor padrão pode ter um efeito desfavorável na infra-estrutura do Active Directory.

O valor MaxActiveQueries do atributo LDAPAdminLimits controla o número máximo de consultas LDAP simultâneas para a diretiva padrão de consulta. Por padrão, é imposto um limite de 20 consultas ativas. Se esse limite for atingido, o Active Directory retornará "LDAP_ADMIN_LIMIT_EXCEEDED" e não processará consultas LDAP adicionais.

Para iniciar o Ntdsutil.exe

  1. Clique em Iniciar e, em seguida, em Executar.

  2. Na caixa de texto Abrir, digite ntdsutil e pressione Enter. Para exibir a Ajuda a qualquer momento, digite ? no prompt de comando.

Para exibir configurações de diretiva

  1. No prompt de comando do Ntdsutil.exe, digite LDAP policies e pressione Enter.

  2. No prompt de comando da diretiva LDAP, digite conexões e pressione Enter.

  3. No prompt de comando da conexão de servidor, digite conectar ao servidor nome DNS do servidor e pressione Enter. Você deseja conectar-se ao servidor com o qual está trabalhando no momento.

  4. No prompt de comando da conexão de servidor, digite q e, em seguida, pressione Enter para retornar ao menu anterior.

  5. No prompt de comando da diretiva LDAP, digite Exibir Valores e pressione Enter.

    Aparece uma exibição das diretivas conforme elas existem.
Observação:
Esse procedimento mostra apenas as configurações da Diretiva de Domínio Padrão. Se você aplicar sua própria configuração de diretiva, não poderá vê-la.

Para alterar configurações de diretiva

  1. No prompt de comando do Ntdsutil.exe, digite LDAP policies e pressione Enter.

  2. No prompt de comando da diretiva LDAP, digite Set MaxActiveQueries to 20 e pressione Enter.

    Você pode usar o comando Mostrar Valores para verificar suas alterações.

  3. Para salvar as alterações, use Confirmar Alterações.

  4. Ao concluir, digite q e pressione Enter.

  5. Para sair de Ntdsutil.exe, no prompt de comando, digite q e pressione Enter.

Para obter mais informações sobre como configurar diretivas LDAP, consulte a Base de Dados de Conhecimento Microsoft, artigo 315071, "Como exibir e definir diretivas LDAP utilizando Ntdsutil.exe no Windows 2000" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071).


MaxPageSize é não padrão
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer verifica a configuração do LDAP de um controlador de domínio conferindo os atributos do objeto Diretiva de Consulta Padrão no contêiner Query-Policies do serviço de diretório do Active Directory®. Se o Exchange Server Analyzer determinar que o valor MaxPageSize do atributo LDAPAdminLimits foi alterado de seu padrão 1000, uma mensagem de configuração não-padrão será exibida.

Os limites administrativos do LDAP equilibram as capacidades operacionais do Active Directory e seu desempenho. Esses limites impedem que operações específicas afetem adversamente o desempenho do servidor, além de tornarem o servidor propenso à negação de ataques de serviço. O aumento dessa configuração acima do seu valor padrão poderá ter um impacto adverso na infra-estrutura do Active Directory.

As diretivas do LDAP são implementadas usando objetos da classe queryPolicy. Os objetos de diretiva de consulta podem ser criados no contêiner Query-Policies, que é um filho do contêiner Serviço de Diretório no contexto de nomenclatura de configuração.

O valor MaxPageSize do atributo LDAPAdminLimits controla o número de registros que podem ser retornados para uma consulta de LDAP. O padrão é 1000 registros. Se houver mais de 1000 itens retornados, o Active Directory verá esse valor máximo e não retornará nada.

Esse limite controla os números suportáveis de vários tipos de objetos do Active Directory. Por exemplo, cada organização pode ter até 1000 servidores, até 1000 grupos administrativos e até 1000 listas de endereços; cada grupo administrativo pode ter até 1000 grupos de roteamento; e cada grupo de roteamento pode ter até 1000 conectores.

A não ser que você seja instruído pelo Atendimento Microsoft para usar um valor diferente, redefina esse valor para 1000.

Para iniciar o Ntdsutil.exe

  1. Clique em Iniciar e, em seguida, em Executar.

  2. Na caixa de texto Abrir, digite ntdsutil e pressione ENTER. Para exibir a Ajuda a qualquer momento, digite ? no prompt de comando.

Para exibir configurações de diretiva

  1. No prompt de comando do Ntdsutil.exe, digite LDAP policies e pressione ENTER.

  2. No prompt de comando da diretiva LDAP, digite conexões e, em seguida, pressione ENTER.

  3. No prompt de comando da conexão do servidor, digite conectar ao servidor nome do servidor DNS e pressione ENTER. Você deseja conectar-se ao servidor com o qual está trabalhando no momento.

  4. No prompt de comando da conexão do servidor, digite q e pressione ENTER para retornar ao menu anterior.

  5. No prompt de comando da diretiva LDAP, digite Mostrar Valores e, em seguida, pressione ENTER.

    Aparece uma exibição das diretivas conforme elas existem.

    Observação:
    Esse procedimento mostra apenas as configurações da Diretiva de Domínio Padrão. Se você aplicar sua própria configuração de diretiva, não poderá vê-la.

Para alterar configurações de diretiva

  1. No prompt de comando do Ntdsutil.exe, digite LDAP policies e pressione ENTER.

  2. No prompt de comando da diretiva LDAP, digite Definir MaxPageSize como 1000 e pressione ENTER.

    Você pode usar o comando Mostrar Valores para verificar suas alterações.

  3. Para salvar as alterações, use Confirmar Alterações.

  4. Quando terminar, digite q e pressione ENTER.

  5. Para sair do Ntdsutil.exe, no prompt de comando, digite q e pressione ENTER.

Para obter mais informações sobre como configurar as diretivas LDAP, consulte o artigo 315071 da Base de Dados de Conhecimento Microsoft, "Como visualizar e definir diretivas LDAP usando o Ntdsutil.exe no Windows 2000" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071).


MaxPageSize está definido muito alto
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor de MaxPageSize para o atributo LDAPAdminLimits do objeto Diretiva de Consulta Padrão no contêiner Diretivas de Consulta. Se o Exchange Server Analyzer determinar que o valor para MaxPageSize é maior que 2500, será exibido um erro.

Os limites administrativos do protocolo LDAP equilibram a capacidade operacional e o desempenho do Active Directory. Esses limites impedem que operações específicas afetem adversamente o desempenho do servidor. Os limites também tornam o servidor resiliente a ataques de negação de serviço. O aumento dessa configuração acima do seu valor padrão poderá ter um impacto adverso na infra-estrutura do Active Directory.

As diretivas LDAP são implementada com objetos da classe queryPolicy. Os objetos de diretiva de consulta podem ser criados no contêiner Query-Policies, que é um filho do contêiner Serviço de Diretório no contexto de nomenclatura de configuração.

O valor MaxPageSize do atributo LDAPAdminLimits controla o número de registros que podem ser retornados para uma consulta do LDAP. O número padrão é 1.000 registros. Se mais de 1.000 itens forem retornados, o Active Directory vê esse valor máximo e não retornará nada.

Esse limite controla os números suportáveis de vários tipos de objetos do Active Directory. Por exemplo, cada organização pode ter até 1.000 servidores, até 1.000 grupos administrativos e até 1.000 listas de endereços. Cada grupo administrativo pode ter até 1.000 grupos de roteamento e cada grupo de roteamento pode ter até 1.000 conectores.

A menos que tenha sido instruído pelo Atendimento da Microsoft a utilizar um valor diferente, você deve configurar esse valor como 1.000.

Para iniciar o Ntdsutil.exe

  1. Clique em Iniciar e, em seguida, em Executar.

  2. Na caixa de texto Abrir, digite ntdsutil e pressione ENTER. Para exibir a Ajuda a qualquer momento, digite ? no prompt de comando.
Para exibir configurações de diretiva

  1. No prompt do comando Ntdsutil.exe, digite diretivas LDAP e pressione Enter.

  2. No prompt de comando da diretiva LDAP, digite conexões e pressione ENTER.

  3. No prompt de comando da conexão do servidor, digite conectar ao servidor <nome DNS do servidor> e, em seguida, pressione ENTER. Conecte-se ao servidor com o qual está trabalhando no momento.

  4. No prompt de comando da conexão do servidor, digite q e pressione ENTER para retornar ao menu anterior.

  5. No prompt de comando da diretiva LDAP, digite Mostrar Valores e pressione ENTER.

    Aparece uma exibição das diretivas conforme elas existem.

    Observação:
    Esse procedimento mostra apenas as configurações da Diretiva de Domínio Padrão. Se você aplicar sua própria configuração de diretiva, não poderá vê-la.
Para alterar configurações de diretiva

  1. No prompt de comandos Ntdsutil.exe, digite diretivas LDAP e pressione Enter.

  2. No prompt de comandos da diretiva LDAP, digite Set MaxPageSize to 1000 e pressione ENTER.

    Você pode usar o comando Mostrar Valores para verificar suas alterações.

  3. Para salvar as alterações, use Confirmar Alterações.

  4. Ao finalizar, digite q e pressione ENTER.

  5. Para sair do prompt de comandos Ntdsutil.exe, digite q e pressione ENTER.

Para obter mais informações sobre a configuração de diretivas LDAP, consulte o artigo 315071 da Base da Dados de Conhecimento da Microsoft, "Como exibir e definir a diretiva LDAP no Active Directory usando Ntdsutil.exe" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071).


Existem mais de 800 listas de endereços
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o número de listas de endereços do grupo Todas as Listas de Endereços, no Active Directory, é superior a 800. Se o Exchange Server Analyzer detectar a presença de mais de 800 listas de endereços na organização do Exchange Server, exibirá um aviso.

É recomendável reduzir o número de listas de endereços no grupo Todas as Listas de Endereços para menos de 800, a fim de evitar latências graves durante as operações do Serviço de Atualização de Destinatário. Se houver mais de 800 listas de endereços na organização do Exchange Server, o Serviço de Atualização de Destinatário estará sujeito a latências graves à medida que ele identifica objetos habilitados para email.

Como alternativa, é possível desabilitar o Serviço de Atualização de Destinatário e usar scripts para manipular as tarefas executadas por esse serviço.

Para obter mais informações sobre como desabilitar o Serviço de Atualização de Destinatário, consulte o artigo 296479 da Base de Dados de Conhecimento da Microsoft, "Requisitos para desabilitar o Serviço de Atualização de Destinatário" (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479).

Para obter mais informações sobre listas de endereços e sobre o Serviço de Atualização de Destinatário, consulte "Gerenciando destinatários e diretivas de destinatário" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


Existem mais de 800 listas de endereços globais
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para saber se o número de listas de endereços no grupo Todas as Listas de Endereços Globais no Active Directory é maior que 800. Ao detectar a presença de mais de 800 listas de endereços globais na organização do Exchange Server, o Analisador do Exchange Server exibirá um aviso.

É recomendável que você reduza o número de listas de endereços no grupo Todas as Listas de Endereços Globais para menos de 800, para evitar latências drásticas durante as operações do Serviço de Atualização de Destinatário. Se existirem mais de 800 listas de endereços globais na organização do Exchange Server, o Serviço de Atualização de Destinatário incorrerá em latências drásticas ao carimbar objetos habilitados para email.

Como alternativa, é possível desabilitar o Serviço de Atualização de Destinatário e usar scripts para manipular as tarefas executadas por esse serviço.

Para obter mais informações sobre como desabilitar o Serviço de Atualização de Destinatário, consulte o artigo 296479 da Base de Dados de Conhecimento da Microsoft, "Requisitos para desabilitar o Serviço de Atualização de Destinatário" (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479).

Para obter mais informações sobre listas de endereços e sobre o Serviço de Atualização de Destinatário, consulte "Gerenciando destinatários e diretivas de destinatário" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


O atributo msExchHomeMDB está indexado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o atributo Routing Group Back-Link foi configurado para indexação no Active Directory. Especificamente, o Exchange Server Analyzer consulta o Active Directory para determinar o valor de indexação atual do atributo msExchHomeMDB, que é um atributo de objetos habilitados para caixa de correio no Active Directory. Por padrão, esse atributo não está indexado. Se o Analisador do Exchange Server achar que esse atributo está configurado para indexação, uma mensagem de configuração não padrão será exibida.

O efeito de ter o atributo msExchHomeMDB indexado é mínimo. Ocorrerá um pequeno aumento na quantidade de memória usada nos servidores de catálogo global devido à manutenção do índice na memória.

Se alguma das seguintes situações se aplicar à sua organização, você poderá se beneficiar da indexação desse atributo:

  • Você tem vários objetos habilitados para email. Em ambientes muito grandes, aqueles com 100.000 objetos habilitados para email ou mais, a indexação desse atributo também pode melhorar o desempenho do Gerenciador do Sistema do Exchange, assim como tarefas específicas do Exchange que podem ser executadas com Usuários e Computadores do Active Directory.

  • Se você usa freqüentemente o Programa Exchange Mailbox Merge (ExMerge), detectou-se que a indexação do atributo msExchHomeMDB é ocasionalmente necessária nos ambientes de médio a grande porte que usam o ExMerge. A indexação do atributo msExchHomeMDB aumenta comprovadamente a velocidade e o desempenho do ExMerge.

Se nenhuma dessas situações se aplicar, será recomendável que a configuração seja restaurada ao valor padrão de não indexado.

Para corrigir esse erro

  • Nenhuma ação é necessária, porque a mensagem gerada pelo Analisador do Exchange Server tem uma finalidade apenas informativa.


O atributo msExchRoutingGroupMembersBL está indexado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o atributo Routing Group Back-Link foi configurado para indexação no Active Directory. Especificamente, o Exchange Server Analyzer examina o seguinte objeto do Active Directory para determinar o valor de indexação atual para o atributo msExchRoutingGroupMembersBL:

CN=Configuração,DC=domínio,DC=com, CN=Serviços, CN=Microsoft Exchange, CN=Nome da Organização, CN=Grupos Administrativos, CN=Nome do Grupo Administrativo, CN=Grupos de Roteamento, CN=Nome do Grupo de Roteamento

Por padrão, esse atributo não está indexado. Se o Analisador do Exchange Server achar que esse atributo está configurado para indexação, uma mensagem de configuração não padrão será exibida.

Em uma implantação distribuída ou de filial do Exchange que contenha um grande número de grupos de roteamento, deixar esse atributo como não indexado pode causar degradação no desempenho. Por exemplo, se houver centenas de grupos de roteamento na organização do Exchange, você poderá perceber um aumento da atividade em um ou mais servidores de catálogo global a cada 15 minutos. Esse aumento de atividade ocorre porque o componente DSAccess no Exchange relê a configuração do grupo de roteamento. Nos casos mais graves, o catálogo global pode ser consumido por essa atividade.

Para minimizar este inconveniente no catálogo global, o atributo Routing Group Back-Link pode ser indexado, reduzindo assim o tempo que ele leva para que o DSAccess leia as informações do grupo de roteamento, e também reduzindo a carga no catálogo global gerada por essa atividade.

Para corrigir esse erro

  • Nenhuma ação é necessária, porque a mensagem gerada pelo Analisador do Exchange Server tem uma finalidade apenas informativa.

Para obter mais informações sobre como ajustar o Exchange para um melhor desempenho, consulte o Guia de Desempenho e Escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47576) (em inglês).


Encontradas várias hierarquias de pastas públicas
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o número de hierarquias de pasta pública que tenham um valor igual a 1 para o atributo msExchPFTreeType. Um valor de 1 para o atributo msExchPFTreeType indica que a hierarquia da pasta pública é aquela designada para clientes MAPI. Se o Exchange Server Analyzer determinar que mais de uma hierarquia de pasta pública na organização do Exchange tem um valor de 1 para o atributo msExchPFTreeType, o Exchange Server Analyzer exibirá um erro.

Esse erro indica que mais de uma hierarquia de pasta pública para clientes MAPI foi encontrada na organização do Exchange. A presença de várias hierarquias de pasta pública para clientes MAPI pode causar problemas.

Para resolver esse problema, você pode usar uma ferramenta de edição do Active Directory para definir o valor do atributo msExchPFTreeType de todas as hierarquias de pastas públicas, exceto a hierarquia da pasta pública MAPI, como 0. Se necessário, reconfigure armazenamentos de caixas de correio nos servidores Exchange para que apontem para a hierarquia de pasta pública MAPI como armazenamento padrão para clientes MAPI.

As ferramentas a seguir são ferramentas de edição do Active Directory:

  • Ferramenta ADSI (Active Directory Service Interfaces) Edit (AdsiEdit.msc)

  • Ferramenta LDP (ldp.exe)

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse erro

  1. Use uma ferramenta de edição do Active Directory para localizar os objetos de pasta pública no Active Directory. Os objetos de pasta pública podem ser encontrados em: CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies

  2. Altere o atributo msExchPFTreeType para todos os objetos de hierarquia de pasta pública exceto a hierarquia de pasta pública MAPI inserindo 0 como o novo valor.

  3. Feche o editor do Active Directory.

  4. Abra o Gerenciador do Sistema do Exchange.

  5. Para acessar as Propriedades de cada armazenamento de caixa de correio, clique em Grupos Administrativos, expanda seu grupo administrativo, expanda Servidores, expanda seu servidor e expanda seu grupo de armazenamento. Em seguida, clique com o botão direito no armazenamento de caixa de correio cujas Propriedades você deseja alterar e selecione Propriedades.

  6. Na guia Geral, do campo Armazenamento público padrão, clique em Procurar.

  7. Selecione a hierarquia de pasta pública MAPI e clique em OK duas vezes para salvar as alterações.

  8. Repita as etapas de 5 a 7 para cada armazenamento de caixa de correio.

Para obter mais informações sobre como modificar o Active Directory com a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre hierarquias de pastas públicas para MAPI e aplicativos, consulte os seguintes recursos:

  • artigo 258509 da Base de Dados de Conhecimento da Microsoft, "Descrição dos três tipos de pastas públicas no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • Entrada do Blog de Equipe do Exchange, "Como funcionam as Pastas Públicas habilitadas para mensagens" (http://go.microsoft.com/fwlink/?LinkId=41913)


Parâmetro 'NeverPing' Recomendado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-03-16

A ferramenta Microsoft® Exchange Server Anayzer consulta o serviço de diretório do Active Directory® para determinar o número de confianças estabelecidas para cada domínio. Se ao menos um controlador de domínio em cada domínio tiver o conjunto de valor NeverPing, a ferramenta exibirá uma mensagem de prática recomendada.

O Exchange Server Analyzer exibe um aviso quando as seguintes condições sao verdadeiras para cada domínio no ambiente do Exchange Server 2003:

  • O domínio tem mais de 50 confianças estabelecidas

  • Os controladores de domínio no domínio possuem o valor da subchave de Registro NeverPing configurado como nulo (0)

Este aviso indica que o processo LSASS.exe ou o processo de autenticação de usuários no domínio pode ser atrasado. O LSASS (Local Security Authority Subsystem Service) é um processo em sistemas operacionais Microsoft Windows que verifica o logon do usuário em um computador ou servidor com base em Windows.

Para corrigir o problema, configure o valor de subchave de registro NeverPing para os controladores de domínio com o valor 1, como a seguir.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para configurar o parâmetro NeverPing para os controladores de domínio em seu ambiente Exchange 2003

  1. Clique em Iniciar, clique em Executar, digite regedit e clique em OK.

  2. Localize a seguinte subchave de Registro: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters.

  3. Clique com o botão direito do mouse nesta subchave, aponde para Novo, clique em Valor DWORD, digite NeverPing e pressione ENTER.

  4. Clique com o botão direito em NeverPing, clique em Modificar, digite 1 na caixa de dados Valor e clique em OK.

  5. Saia do Editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre este problema e sobre como definir o valor de parâmetro NeverPing para o seu controlador de domínio, consulte o artigo 825107 da Base de Dados de Conhecimento Microsoft, "O processo Lsass.exe pode parar de responder se existirem muitas confianças externas em um controlador de domínio com base em Windows 2000 Server" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825107).

Observação:
Ainda que o artigo descreva o Microsoft Windows 2000 Server, a informação se aplica também ao Windows Server™ 2003. A atualização mencionada no artigo não é necessária para o Windows Server 2003.


Uma versão mais recente do Active Directory Connector está disponível
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo versionNumber em cada objeto de licença de conexão. O atributo versionNumber representa a versão do Active Directory Connector (ADC) em execução no computador.

A ferramenta Exchange Server Analyzer também consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version para Adc.exe, o arquivo do Active Directory Connector (ADC). A chave Version do WMI indica o número de compilação deste arquivo.

O Exchange Server Analyzer exibirá um aviso se as seguintes condições forem verdadeiras:

  • O atributo versionNumber no objeto de licença de conexão está definido como 16973842.

  • O atributo versionNumber no objeto de licença de conexão está definido como 16973843 e o valor da chave Version para Adc.exe é menor que 7250.0.

Um valor 16973842 indica que o computador está executando a versão comercial original do ADC a partir do CD do Exchange Server 2003 e um valor 16973843 com a chave Version para Adc.exe menor do que 7250.0 indica que o computador está executando a versão Exchange Server 2003 Service Pack 1 (SP1) do ADC.

Uma versão mais recente do ADC está disponível com o Service Pack 2 para Exchange Server 2003. É recomendável que você use a versão mais recente do ADC.

Para corrigir esse aviso

  1. Vá para Service Pack 2 para Exchange Server 2003 http://go.microsoft.com/fwlink/?LinkId=54751 para fazer download da versão mais recente do ADC.

  2. Desinstale a versão existente do ADC e instale a versão atualizada.

Para obter mais informações sobre licenças de conexão ADC, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 823601, "Requisitos e Implicações de Conector do Active Directory na Organização Inteira" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180, "Requisitos de licença de conexão para conector do Active Directory para grupos administrativos mistos " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721, "XADM: Os direitos de proprietário de Caixa de Correio do Exchange Server 5.5 são removidos quando você altera a licença de conexão ADC de uma licença de conexão unidirecional para uma licença de conexão bidirecional " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


O servidor Exchange indicado para licença de conexão não existe na organização
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchServer2NetworkAddress em cada objeto de licença de conexão. O atributo msExchServer2NetworkAddress representa o endereço de rede para o servidor que está participando nessa licença de conexão. O Exchange Server Analyzer enumera os grupos administrativos no Active Directory para ver se esse nome de servidor é listado para membros da licença de conexão de um Grupo Administrativo. Se esse nome de servidor não estiver listado em um grupo administrativo, será exibido um erro.

Esse erro indica uma licença de conexão órfã. Isso pode ocorrer se um computador do Exchange Server tiver sido descomissionado. Se o computador do Exchange Server tiver sido removido da organização, altere o nome do servidor Exchange na guia Conexões das propriedades da licença de conexão na ferramenta administrativa Active Directory Connector (ADC). Se o Exchange Server em questão estiver offline para manutenção ou por algum outro motivo conhecido, você poderá ignorar esse erro.

Para corrigir esse erro

  1. Clique em Iniciar, Programas, Ferramentas Administrativas, e Active Directory Connector.

  2. No painel da esquerda, clique no servidor do ADC hospeda a licença de conexão que deseja modificar.

  3. No painel da direita, clique com o botão direito no acordo de conexão que você deseja modificar e clique em Propriedades.

  4. Clique na guia Conexões.

  5. Altere o nome do servidor usado para conexões com um nome que exista.

Para obter mais informações sobre licenças de conexão ADC, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 823601, "Requisitos e Implicações de Conector do Active Directory na Organização Inteira" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180, "Requisitos de conexão do Active Director Connector para grupos administrativos mistos" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)


O servidor do catálogo de endereços offline indicado não existe na organização
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-12-03

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo offLineABServer do objeto de configuração do catálogo de endereços offline. O atributo offLineABServer é um atributo de nome distinto de valor único que armazena o nome distinto do computador do Exchange Server que é responsável por gerar um catálogo de endereços offline.

O Exchange Server Analyzer também examina o valor do atributo distinguishedName de objetos do Exchange Server no Active Directory.

Se o Exchange Server Analyzer verificar que o servidor listado no atributo offLineABServer não corresponde aos atributos distinguishedName de objetos do Exchange Server, e que o atributo offLineABServer não contém a cadeia de caracteres DEL:, um erro será exibido.

Para cada catálogo de endereços offline, o Exchange gera e armazena os arquivos do catálogo de endereços offline em um conjunto de pastas públicas em um servidor especificado. Se essa mensagem for exibida, isso significa que o servidor especificado no objeto da lista de endereços offline não existe. Essa situação pode ocorrer se o servidor antigo do catálogo de endereços offline tiver sido descomissionado ou removido incorretamente da topologia. O Exchange não gerará o catálogo de endereços offline até que você especifique um novo servidor.

Para corrigir esse erro no Exchange 2000 Server e no Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, em Destinatários, clique em Listas de Endereços Offline. No painel da direita, clique com o botão direito em Lista de Endereços Offline Padrão (ou em qualquer outra lista de endereços offline que produza essa mensagem) e clique em Propriedades.

  2. Na guia Geral, em Servidor da lista de endereços offline, clique em Procurar e no servidor que deseja usar.

Para corrigir esse aviso no Exchange Server 2007

  1. Abra o Console de Gerenciamento do Exchange.

  2. Expanda Microsoft Exchange, expanda Configuração da Organização e selecione Caixa de Correio.

  3. No painel de resultados, clique na guia Catálogo de Endereços Offline.

  4. Na guia Catálogo de Endereços Offline, selecione "Catálogo de Endereços Offline Padrão". No painel de ações, clique em Mover para iniciar o assistente para Mover Catálogo de Endereços Offline. Esse assistente permite mover a geração do OAB para um servidor diferente. Ele também copia os arquivos do OAB existente para o servidor especificado.

Para usar o Shell de Gerenciamento do Exchange para definir o servidor que hospedará a geração do Catálogo de Endereços Offline

  • Execute o seguinte comando:

    Código da Cópia
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Em que: <OAB> é o DN (nome distinto), o Domínio\Nome da conta ou a GUID do OAB e <Servidor> especifica o servidor Exchange no qual a operação selecionada é executada.

    Por exemplo, para mover a geração do OAB para SERVER01., digite:
Código da Cópia
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Para obter mais informações sobre como trabalhar com catálogos de endereços offline no Exchange Server 2003, consulte "Configurando catálogos de endereços offline do Exchange Server 2003" em Trabalhando com o armazenamento do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).

Para obter mais informações sobre como trabalhar com catálogos de endereços offline no Exchange Server 2007, consulte "Catálogo de endereços offline da > caixa de correio > da configuração da organização" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=79247).


O servidor Exchange do Serviço de Atualização de Destinatário indicado não existe na organização
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-03-29

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo distinguishedName para todos os objetos do Exchange Server no diretório. O Exchange Server Analyzer também consulta o Active Directory para determinar o valor do atributo msExchAddressListServiceLink para cada objeto Serviço de Atualização de Destinatário do diretório. O atributo msExchAddressListServiceLink é um link do serviço de lista de endereços para o computador do Exchange Server em que ele deve estar em execução. Se o Exchange Server Analyzer detectar que o valor para o atributo msExchAddressListServiceLink não contém a cadeia de caracteres, DEL:, e o atributo não for correspondente ao atributo distinguishedName de qualquer objeto do Exchange Server no diretório, um erro será exibido.

Cada instância do Serviço de Atualização de Destinatário está associada a um computador do Exchange Server que executa o Serviço de Atualização de Destinatário. Se você receber esta mensagem, a instância do Serviço de Atualização de Destinatário estará associada a um computador do Exchange Server que não existe na organização do Exchange. O servidor pode ter sido descomissionado ou removido da topologia.

Para que essa instância do Serviço de Atualização de Destinatário seja executada, você deve associá-la a um servidor Exchange existente.

Para corrigir esse erro

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Em Destinatários, clique em Serviços de Atualização de Destinatário. No painel direito, clique com o botão direito na instância apropriada do Serviço de Atualização de Destinatário e clique em Propriedades.

  3. Na guia Geral, em Exchange Server, clique em Procurar e especifique um novo servidor para executar essa instância.

  4. Clique em OK e clique em OK novamente para que a alteração entre em vigor.

  5. Feche o Gerenciador do Sistema Exchange.

Para obter mais informações sobre o Serviço de Atualização de Destinatário, consulte o tópico e os artigos da Base de Dados de Conhecimento Microsoft a seguir:

  • "Gerenciando destinatários e diretivas de destinatário no Exchange Server 2003" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617) (em inglês)

  • 328738, "XADM: Como o Serviço de Atualização de Destinatário aplica as diretivas de destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, "Como o Serviço de Atualização de Destinatário preenche as listas de endereços" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, "XADM: Como Verificar o Progresso do Serviço de Atualização de Destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, "XADM: Tarefas Executadas pelo Serviço de Atualização de Destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


O servidor mestre de grupo de roteamento indicado não foi detectado no grupo administrativo
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar o valor do atributo msExchRoutingMasterDN de cada contêiner do Grupo de Roteamento. Se o Exchange Server Analyzer verificar que o valor do atributo msExchRoutingMasterDN não contém um nome de servidor válido e o atributo não contém a cadeia de caracteres "DEL:", será exibido um aviso.

Esse problema pode ocorrer se o mestre de grupo de roteamento anterior foi descomissionado ou removido incorretamente da topologia. Sem o mestre do grupo de roteamento, o Exchange não poderá atualizar ou manter corretamente a topologia de roteamento.

Quando você cria um grupo de roteamento, ao primeiro servidor desse grupo é atribuída a função de mestre do grupo de roteamento. O mestre do grupo de roteamento mantém informações do status do link atuais para o seu grupo de roteamento e as propaga para os outros servidores do grupo de roteamento. O mestre do grupo de roteamento monitora a configuração de roteamento que é gravada no Active Directory apenas para o seu grupo de roteamento. Servidores membros podem comunicar quaisquer informações sobre disponibilidade do servidor ou estado do conector para o mestre do grupo de roteamento. Por exemplo, se um servidor membro tentar contactar outro servidor em um grupo de roteamento diferente através de um conector, e esse vínculo não estiver disponível, o servidor membro notifica imediatamente o mestre do grupo de roteamento. O mesmo ocorre quando um servidor não mestre recebe novas informações de estado do link, ele imediatamente transfere as informações do estado do conector para o mestre do grupo de roteamento, de forma que outros servidores possam receber as informações sobre a alteração do roteamento.

Para corrigir esse aviso

  1. No Gerenciador do Sistema do Exchange, em Grupos Administrativos, expanda GrupoAdministrativo e expanda Grupos de Roteamento.

  2. Expanda o grupo de roteamento e clique em Membros.

  3. No painel da direita, clique com o botão direito no computador do Exchange que você deseja configurar como mestre do grupo de roteamento e clique em Definir como Mestre.

Para obter mais informações sobre mestres de grupo de roteamento, consulte "Configuring a Routing Topology" no Exchange Server 2003 Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?linkid=47579).


O número de licenças de conexão de pasta pública é menor do que o número de licenças de conexão de configuração
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se existe uma licença de conexão de pasta pública entre o Active Directory e cada site do Exchange Server 5.5. Para isso, ela verifica o número de licenças de conexão de pasta pública e o número de licenças de conexão de configuração. Se o Exchange Server Analyzer determinar que o número de licenças de conexão de pasta pública é menor do que o número de licenças de conexão de configuração, será exibido um aviso.

Esse aviso indica que pelo menos um site do Exchange Server 5.5 não possui uma licença de conexão de pasta pública com o Active Directory e não pode replicar objetos do diretório de pastas públicas para o Active Directory. Portanto, é possível que a mensagem não flua das caixas de correio do Exchange 2000 Server ou do Exchange Server 2003 para as pastas públicas do Exchange Server 5.5, nem das caixas de correio do Exchange Server 5.5 para as pastas públicas do Exchange 2000 Server ou Exchange Server 2003 habilitadas para email.

As licenças de conexão de configuração são geradas automaticamente quando você instala um computador do Exchange 2000 Server ou do Exchange Server 2003 em um site puro do Exchange Server 5.5. As licenças de conexão de pasta pública são definidas pelo usuário. Se existir uma licença de conexão de pasta pública entre cada site do Exchange Server 5.5 e o Active Directory, haverá pelo menos o mesmo número de licenças de conexão de pasta pública e de configuração.

Para criar uma licença de conexão de pasta pública

  1. Em um servidor ADC (Active Directory Connector), inicie o Gerenciador do Active Directory Connector. (No menu Iniciar, aponte para Programas ou Todos os Programas, aponte para Microsoft Exchange e clique em Active Directory Connector).

  2. Na árvore do console, clique em Active Directory Connector. A janela direita lista as licenças de conexão. Use essa lista para determinar qual(is) site(s) não possui(em) licenças de conexão de Pasta Pública.

  3. No menu Ação, aponte para Nova e clique em Licença de Conexão de Pasta pública para exibir a caixa de diálogo Propriedades.

  4. Na guia Geral, em Nome, digite um nome para a licença de conexão.

  5. Na caixa Serviço Active Directory Connector, selecione um servidor para executar a licença de conexão.

  6. Na guia Conexões, selecione o servidor do Active Directory e o servidor do Exchange Server 5.5 em que os objetos de pastas públicas serão replicados, especificando a conta adequada e as credenciais de cada um.

  7. Na guia Agenda, selecione o agendamento de replicação.

  8. Clique em OK.

Para obter mais informações sobre licenças de conexão de pasta pública e de configuração, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 264889, "XADM: Licenças de conexão de pasta pública" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=264889)

  • 281223, "Compreendendo as licenças de conexão no Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=281223).


A geração de Catálogo de Endereços Offline está definida para atualizar continuamente
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-12-04

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo offLineABSchedule na classe msExchOAB foi configurado para uma geração de catálogo de endereços offline. O atributo offLineABSchedule determina o agendamento para a lista de endereços offline. Se o Exchange Server Analyzer perceber que o agendamento da geração de catálogo de endereços offline para a lista de endereços offline foi definido para atualizar continuamente, o Exchange Server Analyzer exibirá um erro.

Um catálogo de endereços offline é um contêiner que armazena uma coleção de listas de endereços offline. Administradores configuram catálogos de endereços offline disponíveis. Os usuários do Microsoft Office Outlook® 2003 e do Outlook 2007 podem escolher quais listas de endereços offline desejam baixar. Clientes MAPI, como Outlook 2003 e Outlook 2007, podem baixar listas de endereços offline. Entretanto, os usuários podem redigir mensagens de email mesmo quando estiverem desconectados do servidor Exchange.

Você pode agendar quando as listas de endereços offline serão atualizadas. Porém, verifique se você pode configurar um agendamento de atualização que disponibilize tempo suficiente para que a geração da lista de endereços offline seja concluída antes do início da próxima atualização. Por exemplo, deverá haver pelo menos quatro horas entre cada intervalo de atualização caso existam as seguintes condições:

  • Você especificar três atualizações em um período de 24 horas.

  • Demorar quatro horas para atualizar as listas de endereços offline.

A atualização freqüente geralmente não é recomendada, pois pode afetar o desempenho do cliente e do servidor das seguintes maneiras:

  • O servidor precisa gerar o catálogo de endereços offline mais freqüentemente. Isso pode levar horas para ser concluído, dependendo do tamanho do Active Directory.

  • Para cada atualização, o Outlook deve fazer uma cópia do catálogo de endereços offline no computador local e aplicar as alterações incrementais que são buscadas no servidor. Se o catálogo de endereços offline no computador local tiver 150 MB, o Outlook deverá criar uma cópia dessa mesma quantidade de dados com cada atualização.

  • O Outlook possui um mecanismo de "otimização" que torna mais lenta a atualização do catálogo de endereços offline quando é detectada a atividade do usuário. Quando houver atividade contínua de usuário, o tamanho do catálogo de endereços offline afetará o tempo necessário para atualizações. Esse período de tempo pode variar entre uma e oito horas.

Se você desejar aumentar a freqüência das atualizações, verifique se o catálogo de endereços offline é razoavelmente pequeno. Um tamanho não zipado razoável é de 1 MB a 25 MB.

Para agendar um horário para atualizar listas de endereços offline no Exchange 2000 Server e no Exchange Server 2003

  1. Em Gerenciador do Sistema, clique duas vezes em Destinatários e clique em Listas de Endereços Offline.

  2. No painel de detalhes, clique duas vezes na lista de endereços offline para a qual deseja definir um agendamento de atualização.

    1. Para escolher um intervalo de atualização pré-configurado, na guia Geral, selecione um dos intervalos fornecidos na lista suspensa Intervalo de atualização.

      Importante:
      Se você selecionar Nunca executar na lista suspensa, a lista de endereços offline não será atualizada.
    2. Para definir o agendamento de uma atualização específica, clique em Personalizar. Na caixa de diálogo Agendar, defina o agendamento de atualização na grade de dia e hora exibida e clique em OK.

Para corrigir esse aviso no Exchange Server 2007

  1. Abra o Console de Gerenciamento do Exchange.

  2. Expanda Microsoft Exchange, expanda Configuração da Organização e selecione Caixa de Correio.

  3. No painel de resultados, clique na guia Catálogo de Endereços Offline.

  4. Na guia Catálogo de Endereços Offline, selecione "Catálogo de Endereços Offline Padrão". No painel de ações, clique em Propriedades.

  5. Na guia Geral, selecione o tempo de execução na lista suspensa Atualizar Agendamento ou clique em Personalizar para definir um agendamento personalizado.

  6. Clique em OK para salvar as alterações.
Para usar o Shell de Gerenciamento do Exchange para definir o agendamento de geração do Catálogo de Endereços Offline

  • Execute o seguinte comando:

    Código da Cópia
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    Em que: <OAB> é o DN (nome distinto), o Domínio\Nome da conta ou a GUID do OAB e <Agendar> especifica os horários agendados para iniciar a geração do OAB e o formato é StartDay.Hour:Minute [AM/PM]. É possível usar os seguintes valores para os dias:

    • Nome completo do dia

    • Nome abreviado do dia

    • Inteiro de 0 a 6, em que 0 = Domingo

    Se preferir usar o horário no formato 24 horas, omita AM/PM.

    Por exemplo, para definir o agendamento de geração do Catálogo de Endereços Offline Padrão para diariamente entre 1AM e 3AM, insira:
Código da Cópia
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

Para obter mais informações, consulte o Guia de Práticas Recomendadas do Catálogo de Endereços Offline (http://go.microsoft.com/fwlink/?LinkId=47583) (em inglês).

Para obter mais informações sobre como trabalhar com catálogos de endereços offline no Exchange Server 2003, consulte "Configurando catálogos de endereços offline do Exchange Server 2003" em Trabalhando com o armazenamento do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).

Para obter mais informações sobre como trabalhar com catálogos de endereços offline no Exchange Server 2007, consulte "Catálogo de endereços offline da >caixa de correio> da configuração da organização" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=79247).


O agendamento da geração de Catálogo de Endereços Offline foi definido como Nunca.
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-12-04

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory para determinar o valor do atributo offLineABSchedule do objeto de configuração do catálogo de endereços offline. O atributo offLineABSchedule representa a programação de geração de catálogos de endereços offline para o objeto Lista de Endereços Offline Padrão no contêiner de Listas de Endereços no Active Directory. Se o Exchange Server Analyzer encontrar o atributo offLineABSchedule definido como Nunca, será exibido um aviso.

Por padrão, o Enchange mantém um único catálogo de endereços offline. O Exchange atualiza esse catálogo de endereços offline (ou gera uma nova versão dele) todas as noites, durante o ciclo de manutenção. Você pode gerar catálogos de endereços affline adicionais e usar o procedimento a seguir para verificar a programação de geração.

Esse aviso indica que a programação foi alterada para Nunca. O Exchange não atualizará o catálogo de endereços offline existente até que você defina uma nova programação. Isso significa que, se por um lado os usuários poderão fazer o download do catálogo de endereços offline existente, eles não receberão nenhuma atualização.

Para corrigir esse aviso no Exchange 2000 Server e no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Em Destinatários, clique em Listas de Endereços Offline.

  3. No painel direito, clique com o botão direito em Lista de Endereços Offline Padrão e clique em Propriedades. Se você não quiser usar um catálogo de endereços offline, clique com o botão direito em Catálogo de Endereços Offline Padrão e clique em Excluir. Caso contrário, use o restante desse procedimento para definir um agendamento.

  4. Na guia Geral, selecione o tempo de execução na lista suspensa Intervalo de atualização ou clique em Personalizar para definir uma programação personalizada.

  5. Clique em OK para salvar as alterações.

Para corrigir esse aviso no Exchange Server 2007

  1. Abra o Console de Gerenciamento do Exchange.

  2. Expanda Microsoft Exchange, expanda Configuração da Organização e selecione Caixa de Correio.

  3. No painel de resultados, clique na guia Catálogo de Endereços Offline.

  4. Na guia Catálogo de Endereços Offline, selecione "Catálogo de Endereços Offline Padrão". No painel de ações, clique em Propriedades.

  5. Na guia Geral, selecione o tempo de execução na lista suspensa Atualizar Agendamento ou clique em Personalizar para definir um agendamento personalizado.

  6. Clique em OK para salvar as alterações.

Para usar o Shell de Gerenciamento do Exchange para definir o agendamento de geração do Catálogo de Endereços Offline

  • Execute o seguinte comando:

    Código da Cópia
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    Onde: <OAB> é o nome distinto, o Domínio\Nome da conta ou a GUID do OAB e <Agendar> especifica os horários agendados para iniciar a geração do OAB, e o formato é StartDay.Hour:Minute [AM/PM]. É possível usar os seguintes valores para os dias:

    • Nome completo do dia

    • Nome abreviado do dia

    • Número inteiro de 0 a 6, onde 0 = Domingo

    Se preferir usar o horário no formato de 24 horas, omita AM/PM.

    Por exemplo, para definir o agendamento de geração do Catálogo de Endereços Offline Padrão para diariamente entre 1AM e 3AM, insira:
Código da Cópia
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

Para obter mais informações sobre como trabalhar com catálogos de endereços offline no Exchange Server 2003, consulte "Configurando catálogos de endereços offline do Exchange Server 2003" em Trabalhando com o armazenamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595) (pode estar em inglês).

Para obter mais informações sobre como trabalhar com catálogos de endereços offline no Exchange Server 2007, consulte "Configuração da Organização > Caixa de Correio > Catálogos de Endereço Offline" (http://go.microsoft.com/fwlink?LinkId=79247) (pode estar em inglês).


Foi detectada a versão antiga da licença de conexão
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange consulta o serviço de diretório do Active Directory® para determinar o valor do atributo versionNumber para cada licença de conexão do ADC (Conector do Active Directory).

Se o Analisador do Exchange Server detectar que o valor do atributo versionNumber de alguma licença de conexão é inferior a 16.973.842 em uma organização do Exchange que contenha um ou mais computadores do Exchange Server 2003, será exibido um aviso.

Um valor inferior a 16.973.842 indica que a licença de conexão foi criada e está sendo gerenciada por um Exchange 2000 Server ADC. Se você estiver executando algumas instâncias do Exchange Server 2003 em sua organização onde o Exchange 2000 Server ou o Exchange Server 5.5 estão sendo executado, deverá atualizar todas as instâncias do ADC para a versão incluída no Exchange Server 2003. Depois de atualizar para o Exchange Server 2003 ou para a versão Exchange Server 2003 Service Pack 1 (SP1) do ADC, as licenças de conexão pertencentes àquela versão do ADC também serão atualizadas. O atributo versionNumber de cada licença de conexão será atualizado com o valor mais recente.

Para corrigir esse aviso

  1. Baixe o Exchange Server 2003 SP1 no endereço http://go.microsoft.com/fwlink/?LinkId=29090.

  2. Execute um backup completo do computador do Exchange Server.

  3. No servidor que está executando o Exchange 2000 Server ADC, clique em Iniciar, em Executar e digite <path>\adc\i386\setup.exe, em que <path> é a local para baixar o Exchange Server 2003 SP1.

  4. Na página Bem-vindo ao Assistente para Instalação do Conector do Active Directory, clique em Avançar.

  5. Na página Instalação Anterior Detectada, clique em Reinstalar para atualizar o Exchange 2000 Server ADC para o Exchange Server 2003 ADC.

  6. Na página Concluindo o Assistente para Instalação do Conector do Active Directory, clique em Avançar.

Para obter mais informações sobre a instalação e atualização do ADC, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 823601, "Requisitos e implicações de Conector do Active Directory em toda a organização " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 822942, "Considerações ao atualizar o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822942)


A função FSMO do Emulador de PDC não respondeu
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo fSMORoleOwner da raiz da partição do diretório de domínio no Contexto de Atribuição de Nomes de Domínio. Por exemplo, em um domínio chamado contoso.com, o fSMORoleOwner do emulador de PCD (controlador de domínio primário) é um atributo de DC=contoso,DC=com. O Analisador do Exchange Server tenta abrir uma conexão LDAP (Lightweight Directory Access Protocol) com a porta TCP 389 no controlador de domínio que armazena atualmente essa função. Se o Analisador do Exchange Server não puder se conectar a esse controlador de domínio, um erro será exibido.

O emulador de PDC atua como um controlador de domínio primário para compatibilidade com os sistemas operacionais Microsoft Windows® anteriores. O Microsoft Windows 2000 Server e o Microsoft Windows Server™ 2003 interoperam com estações de trabalho, servidores membros e controladores de domínio de backup do Microsoft Windows NT®. O PDC em um domínio do Microsoft Windows NT 3.51 ou Microsoft Windows NT 4.0 é responsável por:

  • Processar as alterações de senhas de usuários e computadores

  • Replicar atualizações em controladores de domínio de backup

  • Executar o Localizador de Domínio Mestre

É possível atribuir a qualquer momento a função principal de emulador de PDC a um único controlador de domínio em cada domínio.

Para corrigir esse erro

  1. Verifique se o servidor de diretório especificado no erro está online e acessível pelos servidores Exchange em sua organização.

  2. Se esse servidor de diretórios foi descomissionado, atribua a função de emulador de PDC a outro controlador de domínio.

Para obter mais informações sobre como transferir a função de emulador de PDC de um controlador de domínio para outro, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • Para o Windows Server 2003, consulte 324801, "Como exibir e transferir as funções FSMO no Windows Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Para o Windows 2000 Server, consulte 255690, "COMO: Exibir e transferir as funções FSMO na interface gráfica do usuário" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)


Bloqueio de herança de permissões no objeto de configuração
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-04-13

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta cada objeto de configuração do Exchange contido no banco de dados do Active Directory® para determinar se algum objeto tem permissões de herança bloqueadas. Se a herança de permissões estiver bloqueada para um objeto de configuração do Exchange, o Exchange Server Analyzer exibirá um erro.

O Exchange Server Analyzer identifica o objeto de configuração cuja herança de permissões está bloqueada.

O Exchange Server Analyzer recupera as DACLs (listas de controle de acesso condicionais) do Active Directory para objetos de configuração do Exchange. Por padrão, os objetos de configuração, como servidores Exchange e protocolos do Exchange Server, são definidos para herdar as permissões quando o Exchange é instalado. Quando as permissões são desmarcadas ou modificadas acidentalmente, um objeto de configuração pode ter a herança de permissões bloqueada. Nessa condição, problemas de fluxo de mensagens, como mensagens estacionadas nas filas, e problemas de montagem de armazenamentos podem retardar a capacidade de resposta do Exchange Server.

Observação:
A ACL (lista de controle de acesso) é uma lista de proteções de segurança que se aplicam a todas as propriedades de um objeto, a um conjunto de propriedades do objeto ou a uma propriedade individual de um objeto. Existem dois tipos de listas de controle de acesso: condicional e do sistema.

Para corrigir o problema, basta reabilitar a herança de permissões no objeto.

Para reabilitar a herança de permissões em um objeto de configuração do Exchange

  1. Habilite a guia Segurança da caixa de propriedades do objeto do Gerenciador do Sistema do Exchange, definindo um parâmetro do Registro. Para obter as etapas detalhadas, consulte o artigo 264733 da Base de Dados de Conhecimento Microsoft, "Como habilitar a guia Segurança do objeto da organização no Exchange 2000 e Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264733) (página em inglês).

    Observação:
    Por padrão, a guia Segurança não está habilitada na caixa de propriedades do objeto de configuração.

  2. Abra o Gerenciador do Sistema do Exchange, localize o objeto em questão e reabilite a herança de permissões.

  3. Reinicie o Exchange Server.

Para obter mais informações sobre as listas de controle de acesso condicionais no Active Directory do Windows Server 2003, consulte "Como funcionam os descritores de segurança e as listas de controle de acesso"

(http://go.microsoft.com/fwlink/?LinkId=64193) (página em inglês).

Para obter mais informações sobre herança de permissões, consulte "Como as permissões funcionam" (http://go.microsoft.com/fwlink/?LinkId=64195) (em inglês).


Bloqueio de herança de permissões no objeto de domínio
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-04-13

A ferramenta Microsoft® Exchange Server Analyzer Tool verifica objetos de domínio do Active Directory®, como contêineres e unidades organizacionais. Se a herança de permissões estiver bloqueada nos contêineres ou nas unidades organizacionais, o Exchange Server Analyzer exibirá um erro.

O Exchange Server Analyzer identifica o objeto específico.

Quando são feitas alterações em um objeto de domínio do Active Directory, as alterações na ACL (lista de controle de acesso) são substituídas. Mesmo que 'Herdar do pai' seja habilitado manualmente, a herança aplicada será desabilitada quando as alterações forem aplicadas à ACL. Essa condição causa problemas no RUS (Serviço de Atualização de Destinatário), pois ele não tem as permissões necessárias em uma unidade organizacional do Active Directory na qual as contas residem.

Esse comportamento poderá ocorrer se você tiver desabilitado a caixa de seleção Permitir que permissões herdáveis do pai se propaguem para este objeto na unidade organizacional do Active Directory na qual as contas residem.

Para resolver o problema, use o snap-in Usuários e Computadores do Active Directory ou o ADSI (Active Directory Service Interfaces) Edit para restabelecer as permissões herdáveis da unidade organizacional. Siga as etapas detalhadas no cenário dois do artigo 254030 da Base de Dados de Conhecimento Microsoft, "Permissões ausentes fazem com que o Serviço de Atualização de Destinatário não processe contas no Exchange 2000 Server e Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254030).

Para obter mais informações sobre ACLs no Active Directory do Microsoft Windows Server 2003™, consulte "Como funcionam os descritores de segurança e as listas de controle de acesso" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=64193).

Para obter mais informações sobre herança de permissões, consulte "Como as permissões funcionam" (http://go.microsoft.com/fwlink/?LinkId=64195) (em inglês).


Hierarquia de pasta pública não encontrada
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o número de hierarquias de pasta pública que tenham um valor igual a 1 para o atributo msExchPFTreeType. Um valor de 1 para o atributo msExchPFTreeType indica que uma determinada hierarquia de pasta pública é a hierarquia designada para clientes MAPI. Se o Exchange Server Analyzer verificar que nenhuma das hierarquias de pasta pública da organização do Exchange tem um valor de 1 para o atributo msExchPFTreeType, será exibido um erro.

Esse erro indica que não existe nenhuma hierarquia de pasta pública para clientes MAPI na organização. A ausência de uma hierarquia de pasta pública para clientes MAPI pode causar problemas. Por exemplo, a ausência de uma hierarquia de pasta pública para clientes MAPI pode causar uma falha na atualização de um Servidor Virtual do Exchange que está sendo executado em um cluster de servidores do Microsoft Windows®.

Para resolver esse problema, você pode usar uma ferramenta de edição do Active Directory para definir como 1 o valor para o atributo msExchPFTreeType da hierarquia de pasta pública para clientes MAPI. As ferramentas a seguir são ferramentas de edição do Active Directory:

  • Ferramenta ADSI (Active Directory Service Interfaces) Edit (AdsiEdit.msc)

  • Ferramenta LDP (ldp.exe)

Você deve modificar apenas a hierarquia de pasta pública MAPI. Se sua organização do Exchange inclui hierarquias de pasta pública de aplicativos, verifique se você pode modificar o atributo apenas para a hierarquia de pasta pública MAPI.

Depois de definir como 1 o valor do atributo msExchPFTreeType, você configura os armazenamentos de caixa de correio em seus servidores Exchange para que apontem para a hierarquia de posta pública MAPI como o armazenamento de pasta pública padrão.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir que você reinstale o Windows Server™ 2003, o Exchange Server 2003, ou ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse erro

  1. Use uma ferramenta de edição do Active Directory para localizar objetos de hierarquia de pasta pública no Active Directory. Os objetos de pasta pública podem ser encontrados em CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies

  2. Altere o atributo msExchPFTreeType inserindo 1 como o novo valor.

  3. Feche o editor do Active Directory.

  4. Abra o Gerenciador do Sistema do Exchange.

  5. Para acessar as Propriedades de cada armazenamento de caixa de correio, clique em Grupos Administrativos, expanda seu grupo administrativo, expanda Servidores, expanda seu servidor e expanda seu grupo de armazenamento. Em seguida, clique com o botão direito no armazenamento de caixa de correio cujas Propriedades você deseja alterar e selecione Propriedades.

  6. Na guia Geral, do campo Armazenamento público padrão, clique em Procurar.

  7. Selecione a hierarquia de pasta pública MAPI e clique em OK duas vezes para salvar as alterações.

  8. Repita as etapas de 5 a 7 para cada armazenamento de caixa de correio.

Para obter mais informações sobre como modificar o Active Directory com a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre hierarquias de pastas públicas para MAPI e aplicativos, consulte os seguintes recursos:

  • artigo 258509 da Base de Dados de Conhecimento da Microsoft, "Descrição dos três tipos de pastas públicas no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • Entrada do Blog de Equipe do Exchange, "Como funcionam as Pastas Públicas habilitadas para mensagens" (http://go.microsoft.com/fwlink/?LinkId=41913)


O agendamento de replicação da licença de conexão do destinatário não está definido como 'Sempre'
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o atributo activationStyle em cada licença de conexão do ADC (Active Directory Connector). O atributo activationStyle corresponde à freqüência com que uma licença de conexão ADC é executada. Um valor igual a 0 indica que o agendamento da replicação está definido como Nunca. Um valor igual a 1 indica que o agendamento está definido como Vezes Selecionadas. Um valor igual a 2 indica que o agendamento está definido como Sempre.

O Exchange Server Analyzer também consulta o Active Directory para determinar o valor do atributo msExchServer2SearchFilter em cada objeto de licença de conexão ADC. O atributo msExchServer2SearchFilter representa o filtro de pesquisa que será usado quando você pesquisar o diretório.

Se o Exchange Server Analyzer detectar que o atributo activationStyle não está definido como Sempre, e que o atributo msExchServer2SearchFilter está replicando as informações dos destinatários, um aviso será exibido.

Em geral, é uma prática recomendada definir o agendamento de replicação da licença de conexão de um destinatário como replicar sempre. Em alguns casos, a definição da licença de conexão com outro agendamento poderá resultar em notificações de falha na entrega depois que as caixas de correio são movidas de sites do Exchange Server 5.5 para organizações do Exchange Server 2003.

Para corrigir esse aviso

  1. Abra o snap-in de MMC de Serviços do Active Directory Connector.

  2. Abra a Licença de Conexão.

  3. Na página Propriedades de Licença_Conexão, selecione a guia Agendar, escolha Sempre e clique em OK.

Para obter mais informações sobre implantação do ADC e configuração das licenças de conexão, consulte o Guia de Implantação do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569) (em inglês).


A diretiva de destinatário contém variáveis
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo gatewayProxy de cada objeto de diretiva de destinatário. Se o Exchange Server Analyzer localizar um objeto de diretiva de destinatário que contenha a cadeia de caracteres SMTP:% no atributo gatewayProxy, uma mensagem de configuração não padrão será exibida.

Se você tiver modificado uma diretiva de destinatário para gerar endereços SMTP usando cadeias de caracteres de substituição, a diretiva de destinatário incluirá variáveis. O uso de variáveis na diretiva de destinatário padrão poderá causar problemas de replicação no Exchange 2000 Server anterior ao Service Pack 2 (SP2). Portanto, é recomendável que você não use variáveis em diretivas de destinatário ou que atualize o Exchange 2000 Server para o service pack mais recente. O Exchange 2000 Server SP2 e posteriores oferecem suporte a variáveis na diretiva de destinatário padrão.

Para modificar diretivas de destinatário

  1. Inicie o Gerenciador do Sistema Exchange.

  2. Clique em Organização, clique em Destinatários e em Diretivas de Destinatário.

  3. Clique duas vezes na diretiva que você deseja alterar.

  4. Clique na guia Endereços de Email e edite o endereço SMTP apropriado ou a regra de geração.

Para obter mais informações sobre como configurar diretivas de destinatário, consulte artigo 249299 da Base de Dados de Conhecimento Microsoft, "HOW TO: Configurar Diretivas de Destinatário no Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249299).

Para obter mais informações sobre como usar regras de geração para personalizar endereços SMTP, consulte o artigo 822447 da Base de Dados de Conhecimento, "Como modificar um endereço de email SMTP usando diretivas de destinatário" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822447).

Para obter mais informações sobre os problemas que poderão ocorrer no Exchange 2000 Server se a diretiva de recipiente padrão incluir varáveis, consulte o artigo 271339 da Base de Dados de Conhecimento, "XADM: Não é possível montar banco de dados e o evento com ID 9546 ocorre" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=271339).

Para obter os service packs mais recentes do Exchange 2000 Server, consulte "Downloads do Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=33457).


O Serviço de Atualização de Destinatário parece estar paralisado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchServer1HighestUSN de cada objeto do Serviço de Atualização de Destinatário no Active Directory. O Exchange Server Analyzer também consulta o Active Directory para determinar o valor do atributo activationStyle de cada objeto do Serviço de Atualização de Destinatário no Active Directory. O atributo activationStyle indica o intervalo de atualização do Serviço de Atualização de Destinatário.

O Exchange Server Analyzer também consulta o Active Directory para determinar o valor do atributo highestCommittedUSN para o atributo RootDSE do controlador de domínio sendo usado pelo Serviço de Atualização de Destinatário. O atributo highestCommittedUSN é o maior USN (número de seqüência de atualização) para qualquer objeto no servidor que tenha sido confirmado no banco de dados desse controlador de domínio.

O Exchange Server Analyzer também consulta o Active Directory para determinar o valor do atributo msExchServer1LastUpdateTime de cada objeto do Serviço de Atualização de Destinatário. O atributo msExchServer1LastUpdateTime indica a data e a hora da atualização mais recente da última sincronização bem-sucedida desse diretório.

Se o Exchange Server Analyzer encontrar as três condições a seguir, um aviso será exibido:

  • O atributo activationStyle está definido como 2, o que indica que o agendamento para esse Serviço de Atualização de Destinatário está definido como Sempre.

  • O número de seqüência listado no valor msExchServer1HighestUSN está 5.000 ou mais abaixo do número de seqüência listado em highestCommittedUSN.

  • Seis horas ou mais se passaram desde que o carimbo de data/hora foi gravado no atributo msExchServer1LastUpdateTime.

Esse aviso indica que o Serviço de Atualização de Destinatário especificado não é executado há várias horas e pode estar paralisado.

Para corrigir esse aviso

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Destinatários e selecione Serviços de Atualização de Destinatário.

  3. Clique com o botão direito no Serviço de Atualização de Destinatário especificado e selecione Atualizar Agora.

  4. Aguarde 30 minutos e, então, execute novamente o Exchange Server Analyzer para verificar se essa condição de aviso ainda existe. Em caso afirmativo, prossiga para a etapa 5. Se ela não existir mais, não é necessária nenhuma ação adicional.

  5. Reinicie o serviço Atendedor do Sistema do Microsoft Exchange.

Para obter mais informações sobre o Serviço de Atualização de Destinatário, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 253770, "Tarefas executadas pelo Serviço de Atualização de Destinatário" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828, "Como o Serviço de Atualização de Destinatário preenche as listas de endereços" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, "XADM: Como o Serviço de Atualização de Destinatário aplica as diretivas do sistema" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, "XADM: Como o Serviço de Atualização de Destinatário aplica as diretivas de destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


O Serviço de Atualização de Destinatário não processou todas as alterações
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-03-16

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar se existem valores para o atributo gatewayProxy de qualquer objeto do Serviço de Atualização de Destinatário no Active Directory. Se o Exchange Server Analyzer encontrar valores definidos para o atributo gatewayProxy de qualquer objeto do Serviço de Atualização do Destinatário, será exibido um aviso.

Esse aviso indica que o atributo gatewayProxy do objeto de Serviço de Atualização de Destinatário contém dados antigos que não foram completamente processados. Esses dados devem ser removidos manualmente.

Dados antigos do atributo gatewayProxy precisam ser removidos, senão esses endereços ficarão em estado 'aplicado'. Se o administrador escolher alterar uma diretiva usando as opções 'Reconstruir' ou 'Atualizar agora', endereços de usuários válidos podem ser substituídos por engano, fazendo com que endereços SMTP sejam alterados para os usuários. Para obter mais informações, consulte o artigo do blog do Exchange Diretivas de destinatário e sites puros do Exchange 2000/2003.

Observação:
O link para esse blog é fornecido para fins de informação. O conteúdo pode ser alterado sem prévio aviso.

O atributo gatewayProxy de um objeto de Serviço de Atualização de Destinatário pode conter dados antigos que não foram completamente processados se alguma das condições a seguir for verdadeira:

  • Há problemas com a replicação do Active Directory. Se o Gerenciador do Sistema do Exchange usar um controlador de domínio diferente do controlador usado pelo servidor Exchange que executa o Serviço de Atualização de Destinatário, pode haver problemas de latência ou outros problemas com a replicação do Active Directory.

  • Há problemas de horário que não são de transação que faz com que as alterações sejam perdidas. Esse comportamento pode ocorrer quando o Gerenciador de Sistema do Exchange e o Atendedor do Sistema acessam o atributo gatewayProxy ao mesmo tempo. O Gerenciador de Sistema do Exchange e o Atendedor do Sistema tentam ler o atributo, fazer alterações e, em seguida, gravar no atributo.

Remova os dados antigos usando uma ferramenta como a snap-in Active Directory Service Interfaces (ADSI) Edit (AdsiEdit.msc), a LDP (ldp.exe) ou qualquer outro cliente de protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse aviso

  1. Defina o intervalo de atualização do Serviço de Atualização de Destinatário como Nunca, como segue:

    1. Abra o Gerenciador do Sistema do Exchange.

    2. Expanda Destinatários e expanda Serviços de Atualização de Destinatário.

    3. Clique com o botão direito no Serviço de Atualização de Destinatários que deseja modificar e selecione Propriedades.

    4. Na guia Geral, usando a lista Intervalo de atualização, defina a programação como Nunca executar.

  2. Aguarde de um a dois minutos.

  3. Em seguida, use ADSI Edit ou uma ferramenta similar para localizar o objeto de Serviço de Atualização de Destinatário cujo atributo gatewayProxy contém os dados antigos. Os objetos do Serviço de Atualização de Destinatário estão localizados em:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

    1. Clique com o botão direito no objeto Serviço de Atualização de Destinatários que contém os dados antigos e selecione Propriedades.

    2. Na guia Editor de Atributo, role para baixo e selecione o atributo msExchDoFullReplication.

    3. Clique em Editar para editar esse atributo.

    4. Na caixa de diálogo Valores, selecione o endereço tipo de endereço herdado a ser removido, clique em Remover e clique em OK. Repita essa etapa até que todos os tipos de endereços tenham sido removidos.

    5. Clique em OK novamente para salvar as alterações e feche o ADSI Edit.

  4. Force a execução de uma replicação de diretório depois de limpar o atributo gatewayProxy. Verifique se a replicação ocorre antes de você permitir que o Serviço de Atualização de Destinatário seja executado novamente.

  5. Reconfigure o Serviço de Atualização de Destinatário com o agendamento original.

  6. Se necessário, reaplique as diretivas de destinatário específicas. Use o snap-in dos Sites e Serviços do Active Directory para executar uma replicação manual do Active Directory.

Para obter mais informações sobre esse problema, consulte o artigo 821743 da Base de Dados de Conhecimento da Microsoft, "O atributo gatewayProxy no objeto Serviço de Atualização de Destinatário não está limpo" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821743).

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como forçar a replicação de diretório, consulte o artigo 232072 da Base de Dados de Conhecimento da Microsoft, "Iniciando a Replicação Entre o Active Directory e os Parceiros de Replicação Direta" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Para obter mais informações sobre como usar ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda do Windows Server 2003.


Reconstrução completa do Serviço de Atualização de Destinatário
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msDS-ReplAttributeMetaData do objeto do Serviço de Atualização de Destinatário do controlador de domínio de configuração usado pelo Exchange Server. O atributo msDS-ReplAttributeMetaData contém a data e a hora em que a última alteração foi feita no atributo, além de outras informações. Se o Exchange Server Analyzer verificar que se passaram menos de cinco dias desde a data e hora listadas no atributo msDS-ReplAttributeMetaData, um aviso será exibido.

Esse aviso indica que uma reconstrução completa desse Serviço de Atualização de Destinatário foi agendada recentemente. Quando uma reconstrução completa é configurada, na próxima vez em que o Serviço de Atualização de Destinatário for iniciado pelo agendamento ou pelo comando Atualizar Agora, o Serviço de Atualização de Destinatário examinará cada objeto, em vez de consultar apenas objetos novos. Esse processo pode levar muito tempo e causar atraso no sistema.

Se a intenção for fazer uma reconstrução completa, você poderá ignorar este aviso com segurança. Se você não pretender fazer uma reconstrução completa, poderá resolver este problema usando o ADSI (Active Directory Service Interfaces) Edit (AdsiEdit.msc) e o seguinte procedimento para alterar o valor do atributo msExchDoFullReplication no Active Directory de True para False.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP (ldp.exe) ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse aviso

  1. Use o ADSI Edit ou uma ferramenta similar para localizar o atributo msExchDoFullReplication do objeto de Serviço de Atualização de Destinatário especificado. Os objetos do Serviço de Atualização de Destinatário estão localizados em: CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

  2. Clique com o botão direito no Serviço de Atualização de Destinatário especificado e selecione Propriedades.

  3. Na guia Editor de Atributo, role para baixo e selecione o atributo msExchDoFullReplication.

  4. Clique em Editar para editar esse atributo.

  5. Na caixa de diálogo Editor de Atributo Booleano, mude a seleção de True para False e clique em OK.

  6. Clique em OK novamente para salvar as alterações e feche o ADSI Edit.

Para obter mais informações sobre o Serviço de Atualização de Destinatário, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 253770, "Tarefas executadas pelo Serviço de Atualização de Destinatário" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828, "Como o Serviço de Atualização de Destinatário preenche as listas de endereços" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, "XADM: Como o Serviço de Atualização de Destinatário aplica as diretivas do sistema" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, "XADM: Como o Serviço de Atualização de Destinatário aplica as diretivas de destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


O Serviço de Atualização de Destinatário está configurado para reconstrução completa
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchDoFullReplication de cada objeto do Serviço de Atualização de Destinatário no Active Directory. Se o Exchange Server Analyzer detectar que o valor do atributo msExchDoFullReplication de qualquer objeto do Serviço de Atualização de Destinatário está definido como True, será exibido um aviso.

Esse aviso indica que o Serviço de Atualização de Destinatário está configurado para executar uma reconstrução completa no próximo ciclo de processamento. Quando o atributo msExchDoFullReplication está definido como True, na próxima vez em que o Serviço de Atualização de Destinatário for iniciado pelo agendamento ou pelo comando Atualizar Agora, esse serviço examinará todos os objetos, em vez de consultar apenas os novos objetos. Esse processo pode levar muito tempo e causar atraso no sistema.

Se a intenção for fazer uma reconstrução completa, você poderá ignorar este aviso com segurança. Se você não pretender fazer uma reconstrução completa, poderá resolver este problema usando o ADSI (Active Directory Service Interfaces) Edit (AdsiEdit.msc) e o seguinte procedimento para alterar o valor do atributo msExchDoFullReplication no Active Directory de True para False.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP (ldp.exe) ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse aviso

  1. Use o ADSI Edit ou uma ferramenta similar para localizar o atributo msExchDoFullReplication do objeto de Serviço de Atualização de Destinatário especificado. Os objetos do Serviço de Atualização de Destinatário estão localizados em: CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

  2. Clique com o botão direito no Serviço de Atualização de Destinatário especificado e selecione Propriedades.

  3. Na guia Editor de Atributo, role para baixo e selecione o atributo msExchDoFullReplication.

  4. Clique em Editar para editar esse atributo.

  5. Na caixa de diálogo Editor de Atributo Booleano, mude a seleção de True para False e clique em OK.

  6. Clique em OK novamente para salvar as alterações e feche o ADSI Edit.

Para obter mais informações sobre o Serviço de Atualização de Destinatário, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 253770, "Tarefas executadas pelo Serviço de Atualização de Destinatário" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828, "Como o Serviço de Atualização de Destinatário preenche as listas de endereços" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, "XADM: Como o Serviço de Atualização de Destinatário aplica as diretivas do sistema" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, "XADM: Como o Serviço de Atualização de Destinatário aplica as diretivas de destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


O Serviço de Atualização de Destinatário está inativo
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo activationStyle de cada objeto do Serviço de Atualização de Destinatário no Active Directory. Se o Exchange Server Analyzer verificar que o valor do atributo activationStyle de qualquer objeto do Serviço de Atualização de Destinatário está definido como 0, será exibido um aviso.

Esse aviso indica que o agendamento para esse objeto de Serviço de Atualização de Destinatário está definido como Nunca. Quando o agendamento para um Serviço de Atualização de Destinatário estiver definido como Nunca, novos objetos não são processados.

Se você não precisar mais desse objeto de Serviço de Atualização de Destinatário, recomenda-se excluí-lo. Se você precisar desse objeto de Serviço de Atualização de Destinatário, é recomendável que você configure o agendamento.

Para corrigir esse aviso configurando um agendamento

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Destinatários e selecione Serviços de Atualização de Destinatário.

  3. Clique com o botão direito no Serviço de Atualização de Destinatário para o qual o agendamento foi definido como Nunca e selecione Propriedades.

  4. Selecione um agendamento predefinido usando a lista Intervalo de atualização ou clique em Personalizar para criar um agendamento personalizado.

  5. Clique em OK para salvar as alterações.

  6. Clique com o botão direito nesse Serviço de Atualização de Destinatário e selecione Atualizar Agora.

Para obter mais informações sobre o Serviço de Atualização de Destinatário, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 253770, "Tarefas executadas pelo Serviço de Atualização de Destinatário" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828, "Como o Serviço de Atualização de Destinatário preenche as listas de endereços" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, "XADM: Como o Serviço de Atualização de Destinatário aplica as diretivas do sistema" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, "XADM: Como o Serviço de Atualização de Destinatário aplica as diretivas de destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


Atualização do software do Serviço de Atualização de Destinatário necessária
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version para o Serviço de Grupos Dinâmicos e Exibição de Catálogo de Endereços (abv_dg.dll), também conhecido como Serviço de Atualização de Destinatário. A chave Version do WMI indica o número de compilação deste arquivo.

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msDS-Behavior-Version do objeto Configurações NTDS. Esse valor indica o nível funcional de floresta do Active Directory. Os valores válidos para o atributo msDS-Behavior-Version são mostrados na tabela a seguir.

Valor | Nível funcional de floresta
0 | Microsoft Windows 2000 Server misto
1 | Provisório do Microsoft Windows Server™ 2003
2 | Nativo do Microsoft Windows Server 2003

Se o Exchange Server Analyzer verificar que o número de compilação de abv_dg.dll é menor que 6.0.6615.0 em um servidor Exchange em uma floresta do Active Directory no Windows Server 2003 interim ou modo nativo, um erro será exibido. Esse erro indica que uma versão do Exchange 2000 Server do Serviço de Atualização de Destinatário está sendo executada em um nível de floresta do Active Directory do Windows Server 2003 incompatível. É necessária uma atualização do Serviço de Atualização de Destinatário para resolver o problema.

Quando você usa o Serviço de Atualização de Destinatário no Exchange 2000 Server para atualizar objetos de destinatários em uma floresta do Windows Server 2003, o Serviço de Atualização de Destinatário não atualiza os objetos corretamente. Por exemplo, ele não reconhece as alterações feitas na associação de grupo. Além disso, se você usar o Active Directory Connector (ADC) do Exchange 2000 Server, o ADC poderá não replicar as alterações na associação de grupo do Active Directory para o diretório do Exchange Server 5.5.

Para fazer a atualização para a versão mais recente do Serviço de Atualização de Destinatário

  1. Obtenha a atualização necessária, seguindo as instruções do artigo 873059 da Base de Dados de Conhecimento da Microsoft, "O Serviço de Atualização de Destinatário não atualiza os objetos corretamente quando o Exchange 2000 Server está sendo executado em uma floresta do Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=873059).

  2. Aplique a atualização. Não é necessário reiniciar o computador depois da aplicação dessa atualização. No entanto, os serviços relacionados ao Exchange são reiniciados automaticamente quando você aplica essa atualização.


A instância RUS não existe para esse domínio
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para retornar a lista dos domínios da floresta. O Exchange Server Analyzer também consulta o atributo msExchangeDomainLink de uma lista de instâncias do RUS (Serviço de Atualização de Destinatário) de domínios existentes. O Exchange Server Analyzer em seguida compara a lista de domínios retornada à lista de instâncias do RUS retornada e determina se há alguma correspondência. O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • Existe um domínio

  • Uma instância RUS não existe para o domínio

O Exchange Server Analyzer exibe esse erro se o domínio tiver sido preparado usando o DomainPrep mas não existir uma instância RUS para o domínio. Uma incompatibilidade pode ocorrer em cenários onde um administrador adiciona um novo domínio do Active Directory à floresta, prepara o domínio para o Exchange usando o DomainPrep, mas esquece de adicionar uma instância RUS para o domínio. Se esse comportamento ocorrer, os novos objetos de usuário criados no domínio não receberão os endereços de e-mail emitidos para eles. Se você receber essa mensagem de erro, crie um novo Serviço de Atualização de Destinatário para o domínio.

Para corrigir esse erro

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Destinatários.

  3. Clique com o botão direito no nó Serviços de Atualização de Destinatário , clique em Novo e, em seguida, clique em Serviço de Atualização de Destinatário.

  4. Na janela Novo Objeto, clique em Procurar para localizar o nome do domínio.

  5. Selecione o nome de domínio e clique em OK.

  6. Em Novo Objeto, clique na janelaAvançar e em Concluir.

Para obter mais informações sobre o Serviço de atualização de destinatário, consulte os seguintes arquivos da Base de dados de conhecimento Microsoft:

  • 328738, "Como o Serviço de Atualização de Destinatário aplica as diretivas de destinatário" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, "Como o Serviço de Atualização de Destinatário preenche as listas de endereços" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, " Como verificar o andamento do Serviço de Atualização de Destinatário do Exchange" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, "Tarefas executadas pelo Serviço de Atualização de Destinatário do Exchange" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


Alteração da época de replicação
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo ms-DS-ReplicationEpoch do objeto NTDS Settings de qualquer controlador de domínio foi definido.

A época é o período durante o qual um domínio tem um nome específico. Uma nova época começa quando o domínio é criado pela primeira vez e quando o nome do domínio é alterado.

O atributo ms-DS-ReplicationEpoch é aplicado à época em que todos os controladores de domínio estão sendo replicados. Se o Exchange Server Analyzer perceber que um valor foi definido para esse atributo, uma mensagem de configuração não-padrão será exibida.

A presença de um valor para o atributo ms-DS-ReplicationEpoch geralmente indica que o domínio em que o servidor afetado reside foi renomeado. O Microsoft Windows Server™ 2003, Standard Edition, o Windows Server 2003, Enterprise Edition, e o Windows Server 2003, Datacenter Edition, permitem que os administradores renomeiem domínios em uma floresta do Active Directory depois que a estrutura da floresta é estabelecida. O sistema operacional Windows® 2000 Server não permite que os administradores renomeiem domínios de uma floresta do Active Directory depois que a estrutura da floresta é estabelecida.

A estrutura das florestas do Active Directory é determinada pela ordem em que você cria os domínios e os nomes hierárquicos desses domínios. Você começa pelo domínio raiz da floresta. Os nomes distintos e os nomes DNS padrão de todos os domínios filho derivam do nome do domínio raiz da floresta. Repita o mesmo procedimento para todas as árvores adicionais da floresta.

Para alterar a estrutura hierárquica de uma árvore de domínio existente, renomeie os domínios. Por exemplo, você pode renomear um domínio filho para que ele tenha um pai diferente ou para transformá-lo no novo domínio raiz da árvore. Nos dois exemplos, você reposiciona um domínio existente para criar um estrutura de árvore de domínio diferente.

Também é possível renomear domínios sem afetar a estrutura. Por exemplo, se renomear um domínio raiz, você alterará os nomes de todos os domínios filho abaixo desse domínio raiz. Entretanto, você não terá criado uma estrutura de árvore de domínio diferente.

Florestas que contenham o Exchange 2000 Server ou o Exchange Server 5.5 não oferecem suporte para renomeação de domínio. As ferramentas de renomeação de domínio do Windows Server 2003 foram projetadas para a renomeação de domínios em florestas do Active Directory que não contêm servidores Exchange 2000 Server ou servidores Exchange Server 5.5. As ferramentas de renomeação de domínio do Windows Server 2003 possuem essa limitação devido às seguintes condições:

  • A renomeação de um domínio afeta diversos atributos do Exchange.

  • As ferramentas de renomeação de domínio do Windows Server 2003 não têm funcionalidade para corrigir esses atributos.

As florestas que contêm o Exchange Server 2003 oferecem suporte para renomeação de domínios. A ferramenta Exchange Domain Rename Fix-Up (XDR-fixup.exe) corrige os atributos do Exchange Server depois que você renomeia um domínio que contêm servidores Exchange 2003 Server. Você pode usar a ferramenta Exchange Domain Rename Fix-Up com a ferramenta de renomeação de diretório do Windows Server 2003 (Rendom.exe).

Para obter mais informações sobre as ferramentas de renomeação de domínio do Active Directory do Windows Server 2003 e para baixar as ferramentas de renomeação de domínio do Active Directory do Windows Server 2003, consulte "Ferramentas de renomeação de domínio do Active Directory do Windows Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=40992).

Para renomear um domínio, execute a ferramenta XDR-fixup. A ferramenta XDR-fixup modifica os atributos do Active Directory no Exchange Server para que reflitam o novo nome de domínio. A ferramenta XDR-fixup não substitui as ferramentas de renomeação de domínio do Windows Server 2003. A ferramenta XDR-fixup também não estende a funcionalidade das ferramentas de renomeação de domínio do Windows Server 2003. Você deve executar o ferramenta XDR-fixup sempre que executar o arquivo Rendom.exe.

Para obter mais informações sobre o processo de renomeação de domínios e sobre como esse processo afeta o Exchange Server, consulte as seguintes ferramentas e documentos:

  • "Ferramentas de renomeação de domínio do Active Directory do Windows Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=40992)

  • "Compreendendo como a renomeação de domínios funciona" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=41906)

  • "Guia passo-a-passo para implementar a renomeação de domínios" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=41359)

  • "Exchange Server Domain Rename Fixup" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=34171)

  • "O Exchange e as operações de renomeação de domínio" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=41908)


Réplica da versão 2 do Catálogo de Endereços Offline não encontrada
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2007-01-29

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Exchange_Public_Folder do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor atual de HasLocalReplica. Se o Analisador do Exchange Server detectar que o valor de HasLocalReplica está definido como Falso para a instância do catálogo de endereços offline versão 2 de uma lista de endereços offline, um erro será exibido.

Quando HasLocalReplica estiver definido como Falso para a instância de catálogo de endereços offline versão 2 de uma lista de endereços offline, listas de endereços offline não serão geradas corretamente. Como resultado, os usuários do Microsoft Outlook® 2002 e anteriores não poderão baixar listas de endereços offline.

Esse problema pode ocorrer se você não tiver configurado nenhum armazenamento de pasta pública para conter réplicas da versão 2 do catálogo de endereços offline. Por padrão, o catálogo de endereços offline replica seu conteúdo para o armazenamento de pasta pública do servidor em que ele está instalado. Se o armazenamento de pasta pública for removido da configuração de replicação do catálogo de endereços offline, ocorre o problema descrito no parágrafo anterior.

Para corrigir esse erro

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos e clique em Pastas.

  3. Clique com o botão direito em Pastas Públicas e clique em Exibir Pastas do Sistema.

  4. Clique para expandir o objeto CATÁLOGO DE ENDEREÇOS OFFLINE.

  5. Em CATÁLOGO DE ENDEREÇOS OFFLINE, clique com o botão direito em o=org/cn=addrlists/cn=oabs/cn=Lista de Endereços Offline Padrão e clique em Propriedades.

  6. Na guia Replicação, verifique se um armazenamento de pasta pública foi inserido na caixa Replicar conteúdo para estes armazenamentos públicos. Se o armazenamento de uma pasta pública não for inserido, clique em Adicionar e insira o armazenamento público apropriado para o catálogo de endereços offline.

  7. Clique em Aplicar e em OK.

  8. Clique para expandir a o=org/cn=addrlists/cn=oabs/cn=Lista de Endereços Offline Padrão.

  9. Na o=org/cn=addrlists/cn=oabs/cn=Lista de Endereços Offline Padrão, clique com o botão direito em Versão 2 do Catálogo de Endereços Offline e clique em Propriedades.

  10. Na guia Replicação, verifique se um armazenamento de pasta pública foi inserido na caixa Replicar conteúdo para estes armazenamentos públicos. Se um armazenamento de pasta pública não tiver sido inserido, clique em Adicionar e insira o armazenamento público apropriado para o catálogo de endereços offline.

  11. Clique em Aplicar e em OK.

Para obter mais informações sobre esse problema, consulte o artigo 286328 da Base de Dados de Conhecimento Microsoft, "Não há Catálogo de Endereços Off-line e ele não pode ser Gerado no Microsoft Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).

Para obter mais informações sobre a criação de listas de Catálogos de Endereços Offline, consulte "Visão geral sobre a criação de listas de endereços offline" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=82242).

Para obter mais informações sobre como remover corretamente o primeiro computador executando o Exchange Server 2003 de um grupo administrativo, consulte o artigo 822931 da Base de Dados de Conhecimento Microsoft, "Como remover o primeiro computador com Exchange Server 2003 do grupo administrativo" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931).


Réplica do Catálogo de Endereços Offline versão 3a não encontrada
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Exchange_Public_Folder do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor atual de HasLocalReplica. Se o Exchange Server Analyzer detectar que o valor de HasLocalReplica está definido como False para a instância do catálogo de endereços offline versão 3a de uma lista de endereços offline, será exibido um erro.

Quando HasLocalReplica é definido como False para a instância do catálogo de endereços offline versão 3a para uma lista de endereços offline, as listas de endereços offline não são geradas corretamente. Conseqüentemente, os usuários do Microsoft Office Outlook® 2003 não podem baixar nenhuma lista de endereços offline.

Esse problema poderá ocorrer se você não tiver configurado armazenamentos de pasta pública para conter réplicas do catálogo de endereços offline versão 3a. Por padrão, o catálogo de endereços offline replica seu conteúdo para o armazenamento de pasta pública do servidor em que está instalado. Se o armazenamento de pasta pública for removido da configuração de replicação do catálogo de endereços offline, ocorre o problema descrito no parágrafo anterior.

Para corrigir esse erro

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos e clique em Pastas.

  3. Clique com o botão direito em Pastas Públicas e clique em Exibir Pastas do Sistema.

  4. Clique para expandir o objeto CATÁLOGO DE ENDEREÇOS OFFLINE.

  5. Em CATÁLOGO DE ENDEREÇOS OFFLINE, clique com o botão direito em o=org/cn=addrlists/cn=oabs/cn=Lista de Endereços Offline Padrão e clique em Propriedades.

  6. Na guia Replicação, verifique se um armazenamento de pasta pública foi inserido na caixa Replicar conteúdo para estes armazenamentos públicos. Se um armazenamento de pasta pública não tiver sido inserido, clique em Adicionar e insira o armazenamento público apropriado para o catálogo de endereços offline.

  7. Clique em Aplicar e em OK.

  8. Clique para expandir a o=org/cn=addrlists/cn=oabs/cn=Lista de Endereços Offline Padrão.

  9. Na o=org/cn=addrlists/cn=oabs/cn=Lista de Endereços Offline Padrão, clique com o botão direito em Versão 3a do Catálogo de Endereços Offline e clique em Propriedades.

  10. Na guia Replicação, verifique se um armazenamento de pasta pública foi inserido na caixa Replicar conteúdo para estes armazenamentos públicos. Se um armazenamento de pasta pública não tiver sido inserido, clique em Adicionar e insira o armazenamento público apropriado para o catálogo de endereços offline.

  11. Clique em Aplicar e em OK.

Para obter mais informações sobre esse problema, consulte o artigo 286328 da Base de Dados de Conhecimento Microsoft, "Não há Catálogo de Endereços Off-line e ele não pode ser Gerado no Microsoft Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).

Para obter mais informações sobre como remover corretamente o primeiro computador executando o Exchange Server 2003 de um grupo administrativo, consulte o artigo 822931 da Base de Dados de Conhecimento Microsoft, "Como remover o primeiro computador com Exchange Server 2003 do grupo administrativo" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931).


Agendamento do Conector de Replicação de Diretório
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar qual é o valor para o atributo activationSchedule de cada objeto de licença de conexão do ADC (Active Directory Connector). O atributo activationSchedule corresponde à freqüência com que uma licença de conexão ADC é executada. Um valor igual a 0 indica que o agendamento da replicação está definido como Nunca. Um valor igual a 1 indica que o agendamento está definido como Vezes Selecionadas. Um valor igual a 2 indica que o agendamento está definido como Sempre.

O Exchange Server Analyzer também consulta o Active Directory para determinar o valor do atributo msExchServer2SearchFilter em cada objeto de licença de conexão ADC. O atributo msExchServer2SearchFilter representa o filtro de pesquisa que será usado quando você pesquisar o diretório.

Se o Exchange Server Analyzer detectar que o atributo activationSchedule está definido como Vezes Selecionadas, com um intervalo de replicação acima de 6 horas, e que o atributo msExchServer2SearchFilter está replicando informações do destinatário, será exibido um aviso.

Em geral, é uma prática recomendada definir o agendamento da replicação de licença de conexão de destinatário para replicar sempre (Sempre). Em alguns casos, definir a licença de conexão para qualquer outro agendamento pode gerar notificações de falha na entrega depois que caixas de correio forem movidas de sites do Exchange Server 5.5 para o Exchange 2000 Server ou Exchange Server 2003.

Para corrigir esse aviso

  1. Abra o snap-in de MMC de Serviços do Active Directory Connector.

  2. Abra a Licença de Conexão.

  3. Na página Propriedades de Licença_Conexão, clique na guia Agenda, em Sempre e em OK.

Para obter mais informações sobre implantação do ADC e configuração das licenças de conexão, consulte o Guia de Implantação do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569) (em inglês).


A função de servidor FSMO do RID não respondeu
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo fSMORoleOwner da operação principal de ID relativa (RID) no Contexto de Atribuição de Nome do Domínio. Por exemplo, em um domínio denominado contoso.com, o fSMORoleOwner para o mestre de operações RID é um atributo do CN=RID Manager$, CN=System, DC=contoso, DC=com. O Analisador do Exchange Server tenta abrir uma conexão LDAP (Lightweight Directory Access Protocol) com a porta TCP 389 no controlador de domínio que armazena atualmente essa função. Se o Analisador do Exchange Server não puder se conectar a esse controlador de domínio, um erro será exibido.

O mestre RID aloca IDs relativas para todos os controladores de domínio para garantir que todos os objetos de segurança tenham um identificador único. Você pode criar um novo objeto de segurança (usuário, grupo ou computador) em qualquer controlador de domínio. Quando você cria um objeto de segurança, o controlador de domínio anexa um identificador de segurança (SID) ao objeto. Existem quatro elementos de um domínio SID, um dos quais é o RID para o domínio. O mestre de operações RID é responsável pelo processamento das solicitações de pool RID de todos os controladores de domínio em um domínio específico. A qualquer hora, pode haver apenas um controlador de domínio atuando como o mestre RID no domínio.

Para corrigir esse erro

  1. Verifique se o servidor de diretório especificado no erro está online e acessível pelos servidores Exchange em sua organização.

  2. Se esse servidor de diretório tiver sido descomissionado, você deve atribuir a função de mestre RID a outro controlador de domínio.

Para obter mais informações sobre como transferir a função de mestre de operações RID de um controlador de domínio para outro controlador de domínio, consulte os seguintes artigos na Base de Dados de Conhecimento Microsoft:

  • Para o Microsoft Windows Server™ 2003, consulte 324801, "Como exibir e transferir as funções FSMO no Windows Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Para o Microsoft Windows® 2000 Server, consulte 255690, "COMO: Exibir e transferir as funções FSMO na interface gráfica do usuário" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)


Função FSMO do Esquema não encontrada
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o controlador de domínio especificado como o FSMO do esquema (fSMORoleOwner no Contexto de Nomenclatura do Esquema). Se o Exchange Server Analyzer detectar que o controlador de domínios especificado no atributo fSMORoleOwner não existe na floresta, será exibido um erro.

O atributo fSMORoleOwner no Contexto de Nomenclatura do Esquema (CN=Schema,CN=Configuration,DC=domain,DC=com) define o controlador de domínio que é o controlador de esquemas da floresta. O controlador de domínio do controlador de esquemas controla todas as atualizações e modificações do esquema. Para atualizar o esquema de uma floresta, é necessário ter acesso ao controlador de esquemas. Pode haver somente um controlador de esquemas na floresta inteira.

Você deve ter um controlador de esquemas definido para a floresta do Active Directory. A Instalação do Exchange 2000 Server e a Instalação do Exchange 2000 Server Service Pack falharão (mesmo se você não estiver atualizando o esquema) se o controlador de domínio do controlador de esquemas não estiver online durante a instalação. Se o controlador de domínio listado como o controlador de esquemas estiver offline, ele deverá ser colocado novamente online. Isso não se aplica ao Exchange Server 2003. A Instalação do Exchange Server 2003 contata o controlador de esquemas apenas se ele determinar que o esquema não foi estendido.

Para corrigir esse erro

  1. Verifique se o servidor do Active Directory designado está fisicamente presente.

  2. Se esse servidor de diretório foi descomissionado, atribua a função de controlador de esquemas a outro controlador de domínio.

Para obter mais informações sobre como atribuir a função de controlador de esquemas a outro controlador de domínio, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 280178, "XADM: A instalação do Exchange 2000 exige acesso ao controlador de esquemas" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=280178)

  • Para o Microsoft Windows Server™ 2003, consulte 324801, "Como exibir e transferir as funções FSMO no Windows Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Para o Microsoft Windows® 2000 Server, consulte 255690, "COMO: Exibir e transferir as funções FSMO na interface gráfica do usuário" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)


A função FSMO do esquema não respondeu
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo fSMORoleOwner do controlador de operações do esquema no Contexto de Atribuição de Nomes de Esquema. Por exemplo, em um domínio chamado contoso.com, o fSMORoleOwner do controlador de operações do esquema é um atributo de CN=Schema,CN=System,DC=contoso,DC=com. O Analisador do Exchange Server tenta abrir uma conexão LDAP (Lightweight Directory Access Protocol) com a porta TCP 389 no controlador de domínio que armazena atualmente essa função. Se o Analisador do Exchange Server não puder se conectar a esse controlador de domínio, um erro será exibido.

O controlador do domínio que tem a função de controlador de esquemas é o único controlador de domínio que pode executar operações de gravação no esquema de diretório. Essas atualizações de esquema são replicadas do controlador de esquemas para todos os outros controladores de domínio na floresta. O controlador de esquemas é uma função de controlador de operações por floresta, porque independentemente do número de domínios, existe apenas um esquema na floresta. Para atualizar o esquema de uma floresta, é necessário ter acesso ao controlador de esquemas. Pode haver somente um controlador de esquemas na floresta inteira.

Para corrigir esse erro

  1. Verifique se o servidor de diretório especificado no erro está online e acessível pelos servidores Exchange em sua organização.

  2. Se esse servidor de diretórios foi descomissionado, atribua a função de controlador de esquemas a outro controlador de domínio.

Para obter mais informações sobre como transferir a função de controlador de operações do esquema de um controlador de domínio para outro, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • Para obter informações sobre o Microsoft Windows Server™ 2003, consulte o artigo 324801, "Como exibir e transferir funções FSMO no Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801).

  • Para o Microsoft Windows® 2000 Server, consulte 255690, "COMO: Exibir e transferir funções FSMO na interface gráfica de usuário" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Um certificado Secure Sockets Layer expirará em breve
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2007-01-09

A Ferramenta Microsoft® Exchange Server Analyzer consulta o objeto Server Certificate no sistema do servidor Exchange para recuperar várias propriedades nos certificados X509. Para cada certificado SSL encontrado, o Exchange Server Analyzer avalia o atributo ExpirationDate para identificar a data de expiração do certificado.

Observação:
Um servidor deve ter um certificado de servidor quando executa um protocolo SSL. O certificado de servidor contém o nome do site. O navegador verifica se o site é o nome que foi inserido. Por exemplo, se houver um site como https://www.example.com, o nome do certificado deverá ser www.example.com.

O Exchange Server Analyzer exibe um aviso quando ExpirationDate está entre 3 e 20 dias para terminar. O Exchange Server Analyzer exibe um erro quando ExpirationDate está com menos de 3 dias para terminar.

Se o certificado tiver expirado, as conexões SSL com a URL especificada nessa mensagem falharão. Da mesma forma, conexões RPC sobre HTTP e Exchange Server ActiveSync que usarem essa URL falharão.

Para resolver esse aviso ou erro de expiração de certificado, renove o certificado especificado nesta mensagem. As etapas que você deve seguir para renovar um certificado dependem da autoridade de certificação usada.

Para obter mais informações

Para obter mais informações sobre SSL e o uso de certificados com servidores virtuais no Exchange Server, consulte os seguintes recursos do Exchange:

  • Para obter informações sobre como usar certificados com servidores virtuais no Exchange Server 2003, consulte o artigo 823024 da Base de Dados de Conhecimento Microsoft, "Como usar certificados com servidores virtuais no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024) (em inglês).

  • Para obter informações sobre como usar o SSL e como obter e instalar certificados de servidor, consulte "Configurando o Exchange Server 2003 para Acesso para Cliente" no Guia de Acesso para Cliente do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47568) (em inglês).

  • Para obter informações sobre como usar o SSL e como obter e instalar certificados de servidor no Exchange Server 2007, consulte "Como configurar o SSL no Outlook em Qualquer Lugar" (em inglês) (http:// go.microsoft.com/fwlink/?LinkId =80875).


O contêiner Servidores está ausente
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-08-21

A ferramenta Microsoft® Exchange Server Analyzer consulta no serviço de diretório do Active Directory® o valor do atributo distingushedName de cada objeto Routing Group descoberto no grupo administrativo atual.

O Exchange Server Analyzer também consulta o Active Directory para saber se o contêiner Servidores está presente no grupo administrativo atual.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O grupo administrativo atual contém um ou mais grupos de roteamento.

  • Não existe um contêiner Servidores.

Este erro indica que não existem servidores instalados no grupo administrativo e que as informações de roteamento podem ser propagadas dinamicamente pelos servidores na organização inteira do Exchange.

Para solucionar este erro, certifique-se de que a organização Exchange está no modo nativo e siga estas etapas.

Etapas de Solução

  1. Criar um novo grupo administrativo.

  2. Criar um novo contêiner Grupos de Roteamento no novo grupo administrativo.

  3. Arrastar os grupos de roteamento existentes do antigo contêiner Grupos de Roteamento para o novo.

  4. Reiniciar todos os serviços do Exchange.

Para obter mais informações sobre esse erro, consulte o artigo 318491 da Base de Dados de Conhecimento Microsoft, "XADM: As informações de roteamento não são propagadas em uma organização do Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318491) (em inglês).


Nome da entidade de serviço ausente do servidor de catálogo global
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-05-12

A ferramenta Microsoft® Exchange Server Analyzer consulta o servidor de catálogo global do serviço de diretório do Active Directory® para encontrar os valores retornados para os nomes FQDN (Nome de Domínio Totalmente Qualificado) e NetBIOS do atributo servicePrincipalName dos recursos exchangeAB e HOST.

O Exchange Server Analyzer exibirá um erro se uma das seguintes condições for verdadeira:

  • Um dos valores esperados de nome FQDN e NetBIOS no atributo servicePrincipalName do recurso exchangeAB está ausente.

  • Um dos valores esperados de nome FQDN ou NetBIOS no atributo servicePrincipalName do recurso HOST do Exchange está ausente.

Um SPN (Nome da Entidade de Serviço) é um nome exclusivo que identifica uma instância de um serviço e está associado à conta de logon na qual a instância do serviço é executada. A autenticação Kerberos não é possível para os serviços do Exchange, sem definir corretamente os SPNs.

  • Se os clientes que executam o Microsoft Outlook® 2003 ou versão posterior enfrentarem problemas de autenticação do Active Directory, esses problemas poderão indicar a falta de um SPN válido para o recurso exchangeAB.

  • As falhas de autenticação entre servidores podem indicar a falta de um SPN válido para o recurso HOST.

Para resolver esse problema, siga estas etapas para adicionar os valores ausentes do atributo servicePrincipalName.

Use a ferramenta SETSPN.exe para adicionar um SPN com os valores ausentes

  1. Instale a ferramenta Setspn.exe. Para obter a ferramenta Setspn.exe, consulte "Windows 2000 Resource Kit Tool: Setspn.exe" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=28103).

    A versão do Windows Server 2003 da ferramenta de linha de comando Setspn.exe está disponível nas Ferramentas de Suporte do Windows Server 2003, incluídas no CD do Windows Server 2003. Para instalar as Ferramentas de Suporte do Server 2003, clique duas vezes no arquivo Suptools.msi na pasta Support/Tools.

  2. Siga as orientações no arquivo SETSPN.EXE Setspn_d.txt para adicionar o valor ausente ao objeto do Active Directory em seu servidor Exchange. O exemplo a seguir demonstra como adicionar o valor FQDN a um SPN do servidor virtual SMTP:

    • Inicie um prompt de comando e vá para o diretório em que você instalou o Setspn.exe.

    • No prompt de comando, digite o seguinte:

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      Observação:
      Substitua mail.yourdomain.com pelo FQDN de seu servidor virtual SMTP e YOURSERVERNAME pelo nome do servidor Exchange.
      Em seguida, pressione Enter.


O armazenamento de pasta pública do Servidor de Pastas do Site deste grupo administrativo não existe nesse grupo
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor para o distinguishedName de cada armazenamento de pasta pública. Além disso, o Exchange Server Analyzer consulta o Active Directory para determinar os valores para os atributos siteFolderServer e msExchAdminGroupMode de cada grupo administrativo. O atributo siteFolderServer representa o nome do servidor que é responsável por hospedar as pastas do site (normalmente o primeiro servidor no site ou grupo administrativo). O atributo msExchAdminGroupMode representa o modo para o grupo administrativo, que pode ser:

  • Modo puro do ExchangeServer5.5

  • Modo misto do Exchange Server 5.5, Exchange 2000 Server e Exchange Server 2003 Server

  • Modo nativo do Exchange 2000 Server ou Exchange Server 2003

Se o Exchange Server Analyzer determinar que o grupo administrativo não está no modo nativo e o valor de siteFolderServer não corresponde ao valor de distinguishedName de nenhum armazenamento de pasta pública e o valor do atributo siteFolderServer não contiver a cadeia de caracteres, DEL:, um aviso será exibido.

Por padrão, o Servidor de Pastas do Site é o primeiro servidor que é instalado no grupo administrativo. O armazenamento de pasta pública desse servidor é o local padrão das pastas de disponibilidade e do catálogo de endereços offline para o grupo administrativo. Se você remover ou descomissionar o Servidor de Pastas do Site sem replicar essas pastas para outro servidor e designar esse servidor como um servidor de catálogo de endereços, os usuários do Outlook verão os problemas existentes com o catálogo de endereços e os dados de disponibilidade.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse aviso

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Localize o armazenamento de informações de pasta pública que você deseja designar como o Servidor de Pastas do Site, expandindo o seguinte: CN=<PublicFolderStoreName>, CN=<StorageGroupName>, CN=InformationStore, CN=<ServerName>, CN=Servers, CN=<AdministrativeGroupName> ,CN=Administrative Groups, CN=<OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration,DC=<DomainName>,DC=com.

  3. No painel direito, clique com o botão direito em CN=<PublicFolderStoreName> e selecione Propriedades.

  4. No campo Atributos, role a tela para baixo e selecione o atributo distinguishedName.

  5. Clique no botão Editar e copie o atributo inteiro para a Área de Transferência.

  6. Expanda o contêiner Configuração e expanda CN=Administrative Groups,CN=<OrganizationName>,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<DomainName>,DC=com.

  7. Clique com o botão direito no grupo administrativo que você deseja modificar e selecione Propriedades.

  8. No campo Atributos, role a tela para baixo e selecione o atributo siteFolderServer.

  9. Clique no botão Editar e cole o valor do atributo distinguishedName no campo Valor.

  10. Verifique duas vezes o conteúdo do campo Valor para garantir que a pasta foi criada corretamente e clique em OK para salvar a alteração.

  11. Clique em OK para fechar a caixa de diálogo de propriedades do grupo administrativo.

  12. Saia do ADSI Edit e reinicie o serviço de Armazenamento de Informações do Microsoft Exchange em todos os computadores do Exchange Server no site para que a alteração entre em vigor.

Para obter mais informações sobre como recriar pastas do sistema e redefinindo o Servidor de Pastas do Site, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 275171, "Como redefinir as pastas do sistema em um Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=275171)

  • 284200, "A pasta do sistema Schedule+ Free/Busy não foi encontrada" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200)

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como trabalhar com ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda do Windows Server 2003.


O armazenamento de pasta pública do Servidor de Pastas do Site usado pelo catálogo de endereços offline não foi detectado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2007-02-01

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo siteFolderServer em todos os armazenamentos de pasta pública do Exchange (armazenamentos com objectClass de objectClass=msExchPublicMDB). O atributo siteFolderServer representa o armazenamento de pasta pública usado para o servidor de catálogo de endereços offline.

Se o Exchange Server Analyzer verificar que um servidor não está listado, que o servidor listado está desativado ou que ele não existe, será exibido um aviso. Se o atributo siteFolderServer contiver a cadeia de caracteres, DEL, o Exchange Server Analyzer exibirá uma mensagem de erro.

Por padrão, o Exchange Server 2003 gera arquivos do catálogo de endereços offline no Servidor de Pastas do Site (o primeiro servidor instalado no grupo administrativo). Se você tiver designado um servidor diferente para funcionar como servidor do catálogo de endereços offline, o armazenamento de pastas públicas listado nesse atributo será o armazenamento no novo servidor do catálogo de endereços offline e não o armazenamento no Servidor de Pastas de Site real do grupo administrativo.

Quando o Exchange Server 2003 gera arquivos do catálogo de endereços offline, ele anexa os arquivos a mensagens de email e coloca as mensagens em pastas públicas especiais. O Microsoft Office Outlook® 2003 recupera as mensagens da pasta e baixa os arquivos anexados.

No Exchange Server 2003, as mensagens do catálogo de endereços offline são armazenadas em subpastas da pasta OFFLINE ADDRESS BOOK, que é uma das pastas do sistema na árvore Pastas Públicas padrão. Essa pasta contém uma subpasta para cada grupo administrativo ou site em sua topologia. Por padrão, uma réplica de conteúdo de uma pasta específica do grupo administrativo reside no primeiro servidor que é instalado no grupo administrativo (chamado Servidor de Pastas do Site).

Se sua organização do Exchange for Exchange Server 2007, sem clientes de nível inferior (Outlook 2003 ou anterior), você poderá desconsiderar este aviso ou erro. Se sua organização do Exchange Server 2007 estiver hospedando clientes que executem o Outlook 2003 ou anterior, siga o procedimento abaixo para habilitar a distribuição de pasta pública dos arquivos do catálogo de endereços offline. A distribuição de pasta pública é o método de distribuição pelo qual clientes que executam o Outlook 2003 ou anterior que estiverem trabalhando offline ou por uma conexão dial-up acessam o OAB.

Para corrigir esse aviso no Exchange Server 2003

  1. Se você souber que o servidor não existe, no Gerenciador de Sistema do Exchange, em Servidores, expanda o servidor, expanda o grupo de armazenamento e clique em Armazenamento de Pasta Pública. Confira o painel da direita para verificar se o armazenamento está sendo executado.

  2. Para designar um novo servidor de catálogo de endereços offline, em Destinatários, clique em Listas de Endereços Offline. Em seguida, no painel da direita, clique em Lista de Endereços Offline Padrão (ou em qualquer outra lista de endereços offline que gere essa mensagem).

    Se você não quiser usar um catálogo de endereços offline, clique com o botão direito em Catálogo de Endereços Offline Padrão e clique em Excluir. Caso contrário, use o restante desse procedimento para definir um agendamento.

  3. Clique com o botão direito em Padrão, Lista de Endereços Offline e clique em Propriedades.

  4. Na guia Geral, no servidor do Catálogo de Endereços Offline, clique em Procurar para selecionar um servidor.

Para corrigir esse aviso no Exchange Server 2007

  1. Abra o Console de Gerenciamento do Exchange.

  2. Expanda Microsoft Exchange, expanda Configuração da Organização e selecione Caixa de Correio.

  3. No painel de resultados, clique na guia Catálogo de Endereços Offline.

  4. Na guia Catálogo de Endereços Offline, selecione "Catálogo de Endereços Offline Padrão".

    1. Para habilitar a distribuição de pasta pública do catálogo de endereços offline, na guia Distribuição, selecione Habilitar distribuição de pasta pública.

    2. Clique em OK para salvar as alterações.

  5. Para designar um novo servidor de catálogo de endereços offline, no painel de ações, clique em Mover para iniciar o assistente para Mover Catálogo de Endereços Offline. Esse assistente permite mover a geração do OAB para um servidor diferente. Ele também copia os arquivos do OAB existentes para o servidor especificado.

Para usar o Shell de Gerenciamento do Exchange para habilitar a distribuição de pasta pública dos arquivos do catálogo de endereços offline.

  • Execute o seguinte comando:

    Código da Cópia
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    Onde: <OAB> é o nome distinto, o Domínio\Nome da conta ou a GUID do OAB.

    Por exemplo, para habilitar a distribuição de pasta pública do catálogo de endereços offline, digite:
Código da Cópia
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

Para usar o Shell de Gerenciamento do Exchange para definir o servidor que hospedará a geração do Catálogo de Endereços Offline

  • Execute o seguinte comando:

    Código da Cópia
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Onde: <OAB> é o nome distinto, o Domínio\Nome da conta ou a GUID do OAB e <Servidor> especifica o servidor Exchange no qual a operação selecionada é executada.

    Por exemplo, para mover a geração do OAB para SERVER01., digite:
Código da Cópia
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Para obter mais informações sobre como trabalhar com catálogos de endereços offline no Exchange Server 2003, consulte "Configurando catálogos de endereços offline do Exchange Server 2003" em Trabalhando com o armazenamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595) (pode estar em inglês).

Para obter mais informações sobre como trabalhar com catálogos de endereços offline no Exchange Server 2007, consulte "Configuração da Organização > Caixa de Correio > Catálogos de Endereço Offline" (http:// go.microsoft.com/fwlink/?LinkId =79247) (pode estar em inglês).


O SiteName é codificado
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar se o valor do Registro SiteName está presente no servidor Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netlogon\Parameters\SiteName

Se o Analisador do Exchange Server detectar que o valor do Registro SiteName está presente, será exibido um aviso.

Esse aviso indica que a associação do site de serviço do diretório Active Directory® foi codificada no computador que está executando o sistema operacional Microsoft Windows®. Essa configuração não é recomendada para o Exchange Server.

Quando você codifica um site do Windows, pode provocar falhas no serviço Atendedor do Sistema do Microsoft Exchange e falhas gerais no Exchange Server. Tente remover o valor do Registro SiteName. Se você remover o valor do Registro SiteName, o Windows ingressará automaticamente no site apropriado do Active Directory.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para remover o valor do Registro SiteName

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\Netlogon\Parameters

  3. No painel direito, localize e exclua o valor SiteName .

  4. Feche o editor de Registro e reinicie o servidor para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro SiteName, consulte o artigo 322834 da Base de Dados de Conhecimento, "XADM: Evento 1005, o Atendedor do Sistema não inicia" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322834).


Existem mais de 900 Grupos Administrativos em sua organização do Exchange
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-04-21

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o número de grupos administrativos presentes na organização do Exchange. Se o Exchange Server Analyzer detectar mais de 900 grupos administrativos, um aviso será exibido.

É recomendável que você tenha no máximo 900 instâncias de qualquer tipo de objeto único do Exchange. Isso ocorre porque o Active Directory usa 1.000 como o padrão de tamanho máximo de página que ele retorna para qualquer solicitação fornecida. Significa que se for feita uma solicitação LDAP (Lightweight Directory Access Protocol) para um objeto e existirem mais de 1.000 instâncias desse objeto no Active Directory, nenhum resultado será retornado porque o tamanho máximo de página foi excedido.

No caso do Exchange, vários processos solicitam a instanciação de tipos específicos de objeto. Por exemplo, o Gerenciador do Sistema do Exchange faz uma solicitação LDAP ao Active Directory para criar uma exibição de lista de todos os grupos administrativos da organização do Exchange. Se existirem mais de 1.000 grupos administrativos, o Active Directory não retornará nenhum resultado. Como resultado, será exibido um erro no Gerenciador do Sistema do Exchange e nenhum grupo administrativo será mostrado.

Embora o valor máximo do tamanho de página do Active Directory possa ser aumentado, isso não é recomendado nem tem suporte do Exchange. Comportamento estranho e falhas são evidentes em ambientes do Exchange em que o valor do tamanho máximo de página foi aumentado.

Embora a recomendação seja manter no máximo 900 objetos únicos no Exchange, há suporte para até 1.000 tipos de objetos.

Para remediar esse problema, consolide os grupos administrativos.

Para obter mais informações sobre como consolidar sites e grupos administrativos do Exchange, consulte:

  • Implantando uma solução de consolidação de site mundial para o Exchange Server 2003 na Microsoft (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33531)


Existem mais de 900 servidores Exchange em sua organização do Exchange
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-03-30

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para obter a contagem de objetos no diretório que possuem um objectCategory de msExchExchangeServer. A contagem representa o número de computadores do Exchange Server encontrados no Active Directory. Se o Exchange Server Analyzer encontrar mais de 900 computadores do Exchange Server, será exibido um aviso.

É recomendável que você use um máximo de 900 instâncias de qualquer tipo de objeto exclusivo do Exchange. Isso ocorre porque o Active Directory usa 1.000 como o padrão de tamanho máximo de página que ele retorna para qualquer solicitação fornecida. Significa que se for feita uma solicitação LDAP (Lightweight Directory Access Protocol) para um objeto e existirem mais de 1.000 instâncias desse objeto no Active Directory, nenhum resultado será retornado porque o tamanho máximo de página foi excedido.

No caso do Exchange Server, vários processos solicitam instanciação de tipos de objeto específico. Por exemplo, o Gerenciador do Sistema do Exchange faz uma solicitação LDAP para o Active Directory criar uma exibição da lista de todos os servidores Exchange existentes na organização do Exchange. Se houver mais de 1.000 servidores Exchange, o Active Directory não retornará resultados. Sendo assim, um erro será exibido no Gerenciador do Sistema do Exchange e nenhum computador do Exchange Server será exibido.

Embora o valor máximo do tamanho de página do Active Directory possa ser aumentado, isso não é recomendado nem tem suporte do Exchange. Comportamento estranho e falhas são evidentes em ambientes do Exchange em que o valor do tamanho máximo de página foi aumentado.

Embora a recomendação seja permanecer em 900 ou abaixo disso para qualquer tipo de objeto exclusivo do Exchange Server, há suporte para até 1.000 tipos de objetos.

Para corrigir esse aviso

  1. Experimente consolidar os servidores Exchange em sua organização.

  2. Verifique se há computadores órfãos do Exchange Server no Active Directory e remova-os.

Para obter mais informações sobre como consolidar os servidores Exchange, consulte "Consolidação do servidor usando o Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=47586) (página em inglês).


Há mais de dez administradores delegados no nível da organização
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-12-03

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o número de usuários com permissões como Administradores do Exchange ou Administradores completos do Exchange. O Analisador do Exchange Server conta o número de entradas listadas no atributo msExchAdmins, o que representa uma ligação a todos os administradores do Exchange dentro da organização junto com as permissões apropriadas. Se o Analisador do Exchange Server detectar que existem mais de 10 usuários com permissões Administrador do Exchange e/ou Administrador completo do Exchange, um aviso será exibido.

O msExchAdmins é um atributo de vários valores do contêiner da organização raiz do Exchange. Ele contém uma lista de SIDs (identificadores de segurança) que representam as contas de usuários com permissões delegadas do Exchange.

É uma prática recomendada limitar o número de usuários com acesso de gravação à organização do Exchange. Tente reduzir o número de Administradores do Exchange e de Administradores completos do Exchange no nível da organização. Examinando as funções administrativas em relação aos requisitos da infra-estrutura de mensagens, você verá que pode converter muitos desses usuários em Administradores Somente para Exibição do Exchange no nível organizacional, enquanto delega a eles a função de Administrador do Exchange no nível Grupo de Administração.

Para corrigir esse aviso

  1. Tente diminuir o número de usuários com permissões Administrador do Exchange e/ou Administrador completo do Exchange.

  2. Tente executar uma auditoria das permissões do Exchange Server em sua organização para garantir que elas estejam corretas.

Para obter mais informações sobre o planejamento e a configuração de permissões no Exchange, consulte:

  • "Trabalhando com as permissões do Active Directory no Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=47592).

  • Microsoft Exchange Server 2007, Operações "Configurando permissões" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=78432).

  • Microsoft Exchange Server 2007, Planejamento e arquitetura, Planejando "Considerações sobre permissão" do Active Directory (em inglês) (http://go.microsoft.com/fwlink/?LinkId=78433).

Para obter mais informações sobre funções administrativas no Exchange Server 2003, consulte o artigo 823018 da Base de Dados de Conhecimento da Microsoft, "Visão geral das permissões de função administrativa do Exchange no Exchange 2003" (http://go.microsoft.com/fwlink/?Linkld=3052&kbid=821829).

Para obter mais informações sobre funções administrativas no Exchange Server 2003, consulte o artigo 289811 da Base de Dados de Conhecimento, "XGEN: Permissões de função do Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=289811).


Essa licença de conexão não está definida para criar contas desabilitadas quando nenhuma correspondência é feita
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchServer1AlwaysCreateAs em cada objeto de licença de conexão. Se o Exchange Server Analyzer verificar que o atributo msExchServer1AlwaysCreateAs não está definido como 1, será exibido um aviso.

O atributo msExchServer1AlwaysCreateAs determina como objetos X.500 são sincronizados com o Active Directory. Um valor de 0 indica que a licença de conexão foi configurada para criar contatos do Microsoft Windows®. Um valor de 1 para esse atributo indica que a licença de conexão foi configurada para criar contas de usuário do Windows desabilitadas no Active Directory. Um valor de 2 indica que a licença de conexão foi configurada para criar novas contas do Windows.

O Exchange Server Analyzer emite um aviso porque em uma situação em que o Exchange Server 5.5 precisa coexistir com o Active Directory e se planeja uma migração total para o Exchange Server 2003, é importante que o Active Directory Connector (ADC) crie contas de usuário do Windows desabilitadas. Essas contas de usuário do Windows desabilitadas são "habilitadas para caixa de correio", o que significa que elas estão logicamente anexadas a uma caixa de correio que existe no computador do Exchange Server 5.5. É necessário criar contas de usuário do Windows desabilitadas para o objeto de usuário que representa essa conta do Windows desabilitada, para que depois tenha acesso a pastas públicas e outros objetos protegidos do Active Directory.

Na interface de usuário do ACD, há três opções para criação de novos objetos quando não é encontrado um objeto correspondente para uma caixa de correio do Exchange Server 5.5 no Active Directory. Elas estão listadas na guia Avançado nas propriedades da licença de coneção, assim:

  • Criar um Contato do Windows Isso não é recomendado, porque um objeto Contato não tem contexto de segurança.

  • Criar uma nova conta de usuário do Windows Isso não é recomendado porque a nova conta criada terá um novo SID e, portanto, o histórico do SID da conta de usuário do Microsoft Windows NT® Server 4.0 não será carregado para essa nova conta durante a migração (porque os SIDs são diferentes).

  • Criar uma conta de usuário do Windows desabilitada Isso é recomendado, porque permite que o usuário do Windows NT Server 4.0 coexista (com o acesso correto aos recursos) até que a migração total esteja concluída.

Para corrigir esse aviso

  1. Configure a Licença de Conexão de Destinatário do Active Directory para criar contas desabilitadas de usuários do Windows, habilitadas para caixas de correio.

  2. Use a Ferramenta de Migração do Active Directory, que faz a migração do usuário do Windows NT Server 4.0 para o Active Directory e cria contas de usuário do Windows habilitadas. Essas contas de usuário do Windows habilitadas terão o mesmo SID que as contas do Windows desabilitadas criadas pelo ADC.

  3. Use o Assistente de Limpeza do Active Directory (ADClean), que mescla as informações da conta criada pela Ferramenta de Migração do Active Directory na conta criada pelo ADC.

Para obter mais informações sobre licenças de conexão de destinatário do Active Directory Connector, consulte os artigos a seguir na Base de Dados de Conhecimento da Microsoft:

  • 823601, "Requisitos e Implicações de Conector do Active Directory na Organização Inteira" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180, "Requisitos do Active Directory Connector para Grupos Administrativos Mistos" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 296260, "XGEN: Como configurar uma licença de conexão para destinatário com duas vias para usuários do Exchange 5.5" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260)

  • Para obter mais informações sobre o Assistente de Limpeza do Active Directory, consulte o seguinte artigo da Base de Dados de Conhecimento:

  • 270652, "Usos possíveis para o Assistente de Limpeza de Conta do Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270652)

  • Para obter mais informações sobre a Ferramenta de Migração do Active Directory, consulte o seguinte artigo da Base de Dados de Conhecimento:

  • 260871, "Como configurar ADMT para a migração do Windows NT 4.0 para o Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260871)


Essa é uma licença de conexão unidirecional do Exchange
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchSynchronizationDirection em cada objeto de licença de conexão. O atributo msExchSynchronizationDirection representa a direção na qual os diretórios serão sincronizados. Se esse atributo estiver definido como 2, um aviso será exibido.

O atributo msExchSynchronizationDirection pode ter valor 0 ou 2. Se estiver definido como 0, indica uma licença de conexão bidirecional. Se estiver definido como 2, é uma licença de conexão unidirecional do computador do Exchange Server.

É recomendável que você use licenças de conexão bidirecionais. Os ambientes do Exchange no modo misto (aqueles em que o Exchange Server 5.5 coexiste com o Exchange 2000 Server e/ou Exchange Server 2003) requerem uma licença de conexão bidirecional.

Para corrigir esse aviso

  1. Remova a licença de conexão unidirecional existente.

  2. Crie uma licença de conexão bidirecional de substituição.

Para obter mais informações sobre licenças de conexão ADC (Active Directory Connector), consulte os artigos a seguir na Base de Dados de Conhecimento da Microsoft:

  • 823601, "Requisitos e Implicações de Conector do Active Directory na Organização Inteira" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180, "Requisitos de licença de conexão para conector do Active Directory para grupos administrativos mistos " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721, "XADM: Os direitos de proprietário de Caixa de Correio do Exchange Server 5.5 são removidos quando você altera a licença de conexão ADC de uma licença de conexão unidirecional para uma licença de conexão bidirecional " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


Essa é uma licença de conexão unidirecional do Windows
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchSynchronizationDirection em cada objeto de licença de conexão. O atributo msExchSynchronizationDirection representa a direção na qual os diretórios serão sincronizados. Se esse atributo estiver definido como 1, um aviso será exibido.

O atributo msExchSynchronizationDirection pode ter um valor igual a 0, 1 ou 2. Um valor igual a 0 indica uma licença de conexão bidirecional, um valor igual a 1 indica uma conexão unidirecional do Active Directory e um valor igual a 2 indica uma licença de conexão unidirecional do computador do Exchange Server.

É recomendável usar licenças de conexão bidirecional. Os ambientes do Exchange no modo misto (aqueles em que o Exchange Server 5.5 coexiste com o Exchange 2000 Server e/ou Exchange Server 2003) requerem uma licença de conexão bidirecional.

Para corrigir esse aviso

  1. Remova a licença de conexão unidirecional existente.

  2. Crie uma licença de conexão bidirecional de substituição.

Para obter mais informações sobre licenças de conexão ADC (Active Directory Connector), consulte os artigos a seguir na Base de Dados de Conhecimento da Microsoft:

  • 823601, "Requisitos e Implicações de Conector do Active Directory na Organização Inteira" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180, "Requisitos de licença de conexão para conector do Active Directory para grupos administrativos mistos " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721, "XADM: Os direitos de proprietário de Caixa de Correio do Exchange Server 5.5 são removidos quando você altera a licença de conexão ADC de uma licença de conexão unidirecional para uma licença de conexão bidirecional " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


Comparação de carimbo de data e hora entre o Exchange e o Active Directory excede 5 minutos
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_UTCTime do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar a data e hora em cada servidor Exchange. O Exchange Server Analyzer também recupera a data e a hora atuais no controlador de domínio padrão. Se o Exchange Server Analyzer determinar que existe uma diferença de cinco minutos ou mais entre os dois servidores, um erro será exibido.

O Microsoft Windows 2000 Server e o Windows Server™ 2003 usam o serviço de tempo do Windows para sincronizar a data e a hora de computadores que estejam sendo executados em uma rede baseada em Windows. O horário sincronizado é essencial no Windows 2000 Server e no Windows Server 2003 porque o protocolo de autenticação padrão usa o horário da estação de trabalho como parte do processo de geração da permissão de autenticação. O MIT Kerberos version 5 é o protocolo de autenticação padrão.

Para todos os servidores baseados no Windows em um domínio de serviço de diretório do Active Directory®, o serviço de tempo do Windows é automaticamente configurado, usando esse mesmo serviço disponível nos controladores de domínio. O serviço de tempo do Windows configura um controlador de domínio em seu domínio como uma fonte de tempo confiável e se sincroniza periodicamente usando essa fonte.

Para corrigir esse erro, sincronize o relógio no servidor Exchange com o servidor de diretório.

Para sincronizar o relógio em um servidor de um domínio do Active Directory

  1. Abra um prompt de comando.

  2. Digite w32tm /resync e pressione ENTER.

Se esse erro persistir ou se muitos computadores de sua organização gerarem esse erro, verifique como o serviço de tempo do Windows foi implantado e configurado na sua floresta do Active Directory. Para obter mais informações sobre o serviço de tempo do Windows, consulte "Windows Time Service Technical Reference" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=40648).

Quando os servidores front-end Exchange estão fora de sincronização com o tempo do Active Directory, os clientes podem receber erros do tipo "Servidor interno HTTP 500" ao tentarem se conectar ao Microsoft Office Outlook® Web Access. Para obter mais informações sobre esta situação, consulte o artigo 841546 da Base de Dados de Conhecimento Microsoft, "Problemas conhecidos que geram a mensagem de erro 'Erro interno do servidor HTTP 500' no Exchange 2000 Outlook Web Access" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841546) (página em inglês).


A comparação entre o carimbo de hora do servidor Active Directory Connector e do Active Directory excede 5 minutos
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_UTCTime para determinar a data e a hora em cada servidor ADC (Active Directory Connector). O Exchange Server Analyzer também recupera a data e a hora atuais no controlador de domínio padrão. Se o Exchange Server Analyzer determinar que existe uma diferença de cinco minutos ou mais entre os dois servidores, um erro será exibido.

O Microsoft Windows 2000 Server e o Windows Server™ 2003 usam o serviço de tempo do Windows para sincronizar a data e a hora de computadores que estejam sendo executados em uma rede baseada em Windows. O horário sincronizado é essencial no Windows 2000 Server e no Windows Server 2003 porque o protocolo de autenticação padrão usa o horário da estação de trabalho como parte do processo de geração da permissão de autenticação. O MIT Kerberos version 5 é o protocolo de autenticação padrão.

Para todos os servidores em um domínio do serviço de diretório Active Directory®, o serviço de tempo do Windows se configura automaticamente usando o serviço de tempo do Windows que está disponível nos controladores de domínio. O serviço de tempo do Windows configura um controlador de domínio em seu domínio como uma fonte de tempo confiável e se sincroniza periodicamente usando essa fonte.

Para corrigir esse erro, sincronize o relógio no servidor ADC com o servidor de diretório.

Para sincronizar o relógio de um servidor em um domínio do Windows 2000 Server ou Windows Server 2003

  1. Abra um prompt de comando.

  2. Digite w32tm /resync e pressione ENTER.

Se esse erro persistir ou se muitos computadores de sua organização gerarem esse erro, verifique como o serviço de tempo do Windows foi implantado e configurado na sua floresta do Active Directory. Para obter mais informações sobre o serviço de tempo do Windows, consulte "Windows Time Service Technical Reference" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=40648).


O Windows Server 2003 não está executando a compilação final liberada
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows® ) Win32_OperatingSystem para determinar o valor da chave Version dos servidores ADC (Active Directory Connector) da organização do Exchange. O Analisador do Exchange Server examina também a seguinte entrada de Registro para determinar a versão do Windows que está em execução nos servidores ADC:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se o Analisador do Exchange Server detectar que o valor da segunda instância da CurrentVersion é 5.2 e que o valor da Version não é igual a 5.2.3790, será exibido um erro.

Um valor de CurrentVersion de 5.2 indica que o computador está executando um sistema operacional Windows Server 2003. O valor de Version para a versão lançada de todos os sistemas operacionais Windows Server 2003 é 5.2.3790. Qualquer outro valor da chave Version indica que uma versão de pré-lançamento do Windows Server 2003 está em uso.

A menos que você faça parte de um TAP (Programa de Adoção de Tecnologia) ou de um programa semelhante patrocinado pela Microsoft, a Microsoft não oferece suporte nem recomenda o uso de software de pré-lançamento em ambientes de produção.

Para corrigir esse erro

  1. Atualize todos os servidores da infra-estrutura do Exchange, inclusive os controladores de domínio, servidores de catálogos globais, servidores ADC e computadores do Exchange Server com o último software liberado.

  2. Se a opção de atualização estiver disponível ou se for suportada, reconstrua o sistema operacional e restaure as configurações e dados do Exchange Server.

Atualize todos os servidores da infra-estrutura do Exchange, inclusive os controladores de domínio, servidores de catálogos globais, servidores ADC e computadores do Exchange Server com o último software liberado.

Para obter mais informações sobre as atualizações do software Windows Server 2003, consulte o site de Atualizações do Software Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=33760).


O Windows Server 2003 está executando um software de pré-lançamento
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool examina a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_OperatingSystem para determinar o valor da chave ServicePackMajorVersion. O Exchange Server Analyzer também examina a seguinte entrada do Registro para determinar a versão do Windows que está sendo executada no computador de destino:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se o valor da segunda instância de CurrentVersion for 5.2, e o valor de ServicePackMajorVersion for maior do que 1, o Exchange Server Analyzer exibirá uma mensagem de aviso.

Um valor igual a 5.2 para CurrentVersion indica que o computador está executando um sistema operacional Microsoft Windows Server™ 2003. Um valor maior do que 1 para ServicePackMajorVersion indica que um service pack posterior ao Service Pack 1 (SP1) foi instalado. Como o SP1 é o único service pack lançado para o Windows Server 2003, todo Windows Server 2003 Service Pack 2 ou posterior que estiver instalado deverá ser software de pré-lançamento.

A menos que você faça parte de um programa de adoção de tecnologia ou um programa semelhante patrocinado pela Microsoft, recomenda-se não executar software de pré-lançamento em ambientes de produção.

Para corrigir esse aviso

  1. Desinstale todo software de pré-lançamento que foi instalado.

  2. Se a opção de desinstalação estiver disponível, reconstrua o sistema operacional e restaure as configurações e dados do Exchange Server.

Para obter mais informações sobre as atualizações do software Windows Server 2003, consulte o site de Atualizações do Software Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=33760).


O Windows 2000 Server não está executando o Service Pack 4
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer Tool examina a classe Win32_OperatingSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave ServicePackMajorVersion. O Analisador do Exchange Server também examina a seguinte entrada de Registro para determinar a versão do Windows que está em execução no computador de destino:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se o Exchange Server Analyzer determinar que o sistema de destino está executando um sistema operacional Windows 2000 Server, mas não está usando o Service Pack 4 para Windows 2000 Server, um aviso será exibido.

Como prática recomendada, é indicado instalar os service packs mais atualizados para todos os softwares na implantação do Exchange.

Para corrigir esse aviso

  1. Atualize todos os controladores de domínio e servidores de catálogo global que estejam executando o sistema operacional Windows 2000 Server para o Service Pack 4, além dos hotfixes e das atualizações do Windows Update.

  2. Atualize todos os computadores do Exchange Server com os service packs e os pacotes cumulativos mais recentes.

Para obter mais informações sobre como obter e instalar service packs para sistemas operacionais Windows 2000 Server, consulte o site "Windows 2000 Service Packs" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=18353).

Para obter mais informações sobre como obter e instalar service packs e pacotes cumulativos do Exchange Server, consulte o site "Microsoft Exchange Server" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=21573).


O Windows 2000 Server não está executando a compilação final lançada
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2005-11-17

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_OperatingSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version.

O Exchange Server Analyzer também examina a seguinte entrada de Registro para determinar a versão do Windows que está sendo executada no computador:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor CurrentVersion 5.0 indica que o computador está executando um sistema operacional Microsoft Windows 2000 Server. O valor Version para a versão de lançamento de todos os sistemas operacionais Windows 2000 Server é 5.0.2195. Qualquer outro valor para a chave Version indica que uma versão de pré-lançamento do Windows 2000 Server está sendo usada.

Se o Exchange Server Analyzer verificar que o valor para a segunda instância de CurrentVersion é 5.0 e o valor para Version não é igual a 5.0.2195, um erro será exibido.

A menos que você faça parte de um Programa de Adoção de Tecnologias (TAP) ou algum programa similar patrocinado pela Microsoft, a Microsoft não apóia ou recomenda o uso de software de pré-lançamento em ambientes de produção.

Para corrigir esse erro

  1. Atualize todos os servidores de infra-estrutura do Exchange, incluindo controladores de domínio, servidores de catálogo global, servidores de ADC (Active Directory Connector) e computadores do Exchange Server para o software de lançamento mais recente.

  2. Se a opção de atualização estiver disponível ou se for suportada, reconstrua o sistema operacional e restaure as configurações e dados do Exchange Server.

Para obter informações sobre como obter e instalar o Windows 2000 Service Pack 4, consulte o site do Windows 2000 Service Pack 4 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=33241).


O endereço X.400 tem um caractere de encerramento inválido
Microsoft Exchange Server Analyzer - Artigos > Active Directory >

Última modificação do tópico: 2006-12-03

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor de gatewayProxy em suas diretivas de destinatário e verificar se o endereço X.400 termina com um ponto-e-vírgula.

O formato correto de um endereço X.400 em uma diretiva de destinatário indica que o endereço termina com ponto-e-vírgula. A falta do ponto-e-vírgula fará com que o roteamento de mensagem para o endereço X.400 seja interrompido.

Para corrigir esse problema, será necessário adicionar um ponto-e-vírgula ao final do endereço usando a ferramenta ADSI (Active Directory Service Interfaces) Edit ou LDP.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP (ldp.exe) ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou do Exchange Server 2007 (ou de ambos). Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse erro

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Expanda Configuração [Nome_de_domínio], CN=Configuração, DC=Nome_de_domínio, DC=Sufixo_de_domínio.

  3. Expanda a entrada CN=Services e expanda CN=Microsoft Exchange.

  4. Expanda CN=Nome_da_organização, CN=Grupos Administrativos e CN=Diretivas de Destinatário.

  5. Clique com o botão direito em CN=Nome_da_diretiva e selecione Propriedades.

  6. Role para baixo para localizar gatewayProxy, selecione-o e clique em Editar.

  7. No campo Valor, digite o gatewayProxy correto.

  8. Feche o editor do Active Directory e reinicie o computador com o Exchange Server para que a alteração entre em vigor.


Recuperação de Banco de Dados
Microsoft Exchange Server Analyzer - Artigos >

Última modificação do tópico: 2007-01-22

Os artigos desta seção fornecem detalhes sobre erros de banco de dados e eventos de aviso detectados pela Ferramenta Solucionador de Problemas de Banco de Dados do Microsoft® Exchange no log de eventos do aplicativo. O Solucionador de Problemas de Bancos de Dados usa o mesmo mecanismo do Assistente para Solução de Problemas do Microsoft Exchange para executar programaticamente um conjunto de etapas de solução de problemas a fim de determinar as causas principais dos problemas de montagem de bancos de dados. Além disso, esses artigos fornecem as etapas que poderão ser executadas para determinar sintomas e resolver problemas relacionados a banco de dados.

Para obter mais informações e fazer download da ferramenta, consulte Assistente para Solução de problemas do Microsoft Exchange v1.0 (em inglês) .


ESE 428 (0xfffff8f0): Espaço livre insuficiente restante na unidade do log de transações
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-04-02

A ferramenta Microsoft® Exchange Database Troubleshooter Tool detectou um ou mais eventos ESE 428 no log de Aplicativos. Esse evento indica que não há espaço livre suficiente na unidade do log de transações. Quando esse erro for gerado, o Exchange Server conseguirá criar um novo arquivo de log de transações. Isso fará com que todos os bancos de dados do grupo de armazenamento afetado fiquem offline, pois as atualizações nos bancos de dados devem ser gravadas no log de transações.

Explicação

O Exchange Server fornece dois mecanismos para impedir o enchimento da unidade do log de transações.

  • Log circular. Os logs de transações são automaticamente excluídos depois que o ponto de verificação do banco de dados os aprovou antecipadamente. O espaço em disco usado para os arquivos do log de transações permanecerá abaixo de 50 MB na maioria das condições. Durante o backup, a remoção de logs de transações pode ficar suspensa até a conclusão do backup.

    Observação:
    Por padrão, o log circular não está habilitado no Microsoft Exchange 2000 Server nem em versões posteriores.
  • Backup de grupo de armazenamento. O Exchange Server remove os logs em excesso depois que um backup online completo ou incremental de todos os bancos de dados em um grupo de armazenamento é executado usando um método de backup que implementa o VSS (Serviço de Cópias de Sombra de Volume) ou as APIs de backup de streaming online para Exchange Server.

Se o log circular não estiver habilitado e qualquer uma das seguintes condições for verdadeira, o número de arquivos de log de transações aumentá até o espaço na unidade de disco rígido ser excedido.

  • O programa de backup não remove os arquivos de log de transações.

  • A execução do programa de backup foi interrompida.

  • Os arquivos do log de transações não são limpos com nenhum outro método.

Ocasionalmente, talvez seja necessário remover os arquivos de log de transações manualmente se tiver sem espaço no disco rígido. Ou talvez seja necessário remover manualmente esses arquivos, caso suponha que ficará sem espaço no disco rígido, para que possa executar um backup online completo ou incremental de todos os bancos de dados em um grupo de armazenamento específico. Se você remover logs que ainda estejam à frente de algum ponto de verificação de banco de dados e o banco de dados for interrompido de maneira anormal, o banco de dados não poderá ser montado até que os logs necessários sejam restaurados. Dessa forma, você deverá determinar quais logs podem realmente ser removidos antes de remover manualmente quaisquer arquivos do log de transações do Exchange Server.

O erro também pode ser relatado como JET_errDiskFull ou código de erro 0xfffff8f0. Esse erro se aplica às seguintes versões do Exchange Server:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Ação do usuário

Para resolver o erro, selecione qualquer uma das seguintes soluções:

  • Execute a ferramenta Gerenciamento de Recuperação de Banco de Dados. No Microsoft Exchange Server 2007, a ferramenta está listada em ferramentas de Recuperação de banco de dados na Caixa de ferramentas no Console de Gerenciamento do Exchange. O Exchange Server Analyzer pode determinar automaticamente quais arquivos de log podem ser removidos com segurança e os copiará para um local de backup para você. Recomendamos que você use o Exchange Server Analyzer para mover arquivos de log.

    Observação:
    O Exchange Server Analyzer não funcionará no Exchange 2007 se o grupo de armazenamento que contém o banco de dados estiver habilitado para CCR (replicação contínua em cluster).
  • Verifique os valores de Estado e Log Necessário em cada cabeçalho de banco de dados para determinar quais arquivos do log de transações podem ser removidos manualmente.

    Observação:
    De acordo com os objetivos deste artigo, a remoção de um arquivo de log de transações significa mover esse arquivo para outro local onde possa ser feito backup do arquivo, bem como ele possa ser armazenado ou excluído. A ação dependerá de suas necessidades. De acordo com os objetivos deste artigo, a exclusão de um arquivo de log de transações se refere ao tipo de remoção que não permite fazer backup nem restaurar esse arquivo do log de transações.

Siga estas etapas detalhadas para determinar quais arquivos do log de transações podem ser removidos manualmente.

Para examinar o cabeçalho do banco de dados e remover os arquivos de log desnecessários

  1. Desmonte o banco de dados cujo cabeçalho você deseja examinar.

  2. Clique em Iniciar, Executar e digite cmd para abrir a janela Prompt de Comandos.

  3. Em um prompt de comandos, vá para o caminho de diretório em que o arquivo de bancos de dados está localizado.

    Observação:
    No Exchange 2000 Server e no Exchange Server 2003, para determinar o caminho e o nome de arquivo dos arquivos .edb e .stm de um banco de dados, use o Gerenciador do Sistema do Exchange para exibir a guia Banco de Dados da caixa de diálogo de propriedades de cada objeto do banco de dados. No Exchange Server 2007, para determinar o nome e o caminho do arquivo de banco de dados, expanda o Console de Gerenciamento do Exchange em Configuração de Servidor, clique em Caixa de Correio e exiba a guia Gerenciamento de Banco de Dados.

  4. Digite o seguinte comando Eseutil junto com a opção /MH em um prompt de comandos:

    Código da Cópia
    "eseutil /MH databasefilename.edb"
    Observação:
    Na sintaxe, databasefilename é o nome do banco de dados que você deseja examinar.

  5. Examine os valores de Estado e Log Necessário nas informações de cabeçalho que são exibidas.

    O valor de Estado fornece as seguintes informações sobre se o banco de dados foi corretamente desanexado:

    • Se o banco de dados tiver sido corretamente desanexado, o valor de Estado será Desligamento Normal ou Consistente. Esse valor depende da versão do Exchange Server que está sendo executada. Você pode remover todos os arquivos do log de transações, exceto o arquivo atual.

      Observação:
      Se remover o arquivo de log de transações atual quando todos os bancos de dados estiverem em um estado Desligamento Normal, você provocará uma redefinição da seqüência dos arquivos de log. Isso não impede o início dos bancos de dados. No entanto, uma redefinição da seqüência dos arquivos de log afeta a capacidade de avançar um banco de dados de um backup anterior se a situação ocorrer.
    • Se o banco de dados tiver sido desanexado incorretamente, o valor de Estado será Desligamento Anormal ou Inconsistente. Determine quais arquivos do log de transações podem ser removidos, verificando o campo Log Necessário no cabeçalho do banco de dados.

      Observação:
      Quando o banco de dados está em um estado Desligamento Anormal ou Inconsistente, significa que alguns dos arquivos do log de transações existentes contêm transações pendentes que são exigidas pelo banco de dados. Se você remover os arquivos do log de transações nessa situação, o banco de dados não poderá ser iniciado novamente, a menos que você restaure o banco de dados a partir de um backup. Ou então, você pode reparar o banco de dados usando os comandos Eseutil e Isinteg.
      Você deve examinar os valores de Log Necessário referentes a cada banco de dados em um grupo de armazenamento antes de remover quaisquer logs desse grupo.

      O campo Log Necessário lista o intervalo de arquivos de log numerados que são necessários para iniciar esse banco de dados. Se o intervalo for 0 - 0, nenhum arquivo de log será necessário para iniciar esse banco de dados. Isso indica que o banco de dados está em um estado Desligamento Normal ou Consistente. Se houver arquivos de log mais antigos que o log de ponto de verificação, você poderá remover aqueles arquivos de log que excluem o log de ponto de verificação.

      Se você estiver executando uma versão do Exchange Server anterior ao Exchange Server 2003 Service Pack 1 (SP1), converta em valores hexadecimais o intervalo decimal listado no campo Log Necessário. Por exemplo, se o valor de Log Necessário for 28217 - 28221, os arquivos de log de 06E39 a 06E3D serão exigidos por esse banco de dados. No Exchange 2003 SP1, o campo Log Necessário foi aprimorado para relatar valores decimais e hexadecimais.

      Observação:
      Você pode usar o modo Científico do Windows Calculator para converter de decimal em hexadecimal. Inicie o Calculator e clique em Científico no menu Exibir. Insira o número decimal e clique em Hex.
      Como você pode ter até quatro grupos de armazenamento no Exchange 2000 e no Exchange 2003, com cada grupo tendo um conjunto específico de arquivos de log, o prefixo Edb não é exibido nos nomes dos arquivos de log de transações. No Exchange 2000 e no Exchange 2003, o prefixo Edb é substituído por E00, E01, E02 ou E03. Para um Grupo de Armazenamento de Recuperação, o prefixo Edb será substituído por R00. O prefixo do nome do arquivo de log de grupo de armazenamento é exibido no Gerenciador do Sistema do Exchange na guia Geral da caixa de diálogo de propriedades para o objeto específico do grupo de armazenamento. Portanto, se o prefixo do grupo de armazenamento for E01 e se a entrada de Log Necessário for 28217 - 28221 (0x06E39 - 0x06E3D), os logs reais necessários serão E0106E39.log a E0106E3D.log.

  6. Você pode remover com segurança todos os arquivos de log numerados que são menores que a entrada mais baixa em qualquer campo Log Necessário de qualquer banco de dados do grupo de armazenamento.

    Observação:
    Lembre-se de mover, não de excluir, os arquivos de log.
    Observação:
    Como prática recomendada, você não deve remover o arquivo de log de transações mais recente. Esse é o arquivo de log que tem o carimbo de hora mais recente e ainda não tem um número de seqüência em seu nome de arquivo. Mesmo se você tiver determinado que não é seguro remover esse arquivo, mantenha-o para evitar que a seqüência de arquivos de log seja redefinida novamente como 0. Se você redefinir a seqüência, os ciclos de backup serão afetados. Talvez você não consiga avançar o banco de dados de um backup obtido antes da redefinição.


ESE 454 -515: Arquivo de Log de Transações Necessário Ausente
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-23

O Microsoft® Exchange Server Analyzer Tool encontrou um evento ESE 454 com código de erro -515. Esse erro indica que o banco de dados do Exchange não pôde ser montado porque um arquivo de log de transações necessário estava ausente

Explicação

Um evento ESE 454 com um erro -515 pode ocorrer se o ESE (Mecanismo de Armazenamento Extensível) tentar colocar todos os bancos de dados de um grupo de armazenamento em um estado consistente durante o processo de recuperação. Se algum arquivo de log de transações necessário estiver ausente, o processo de recuperação falha e o banco de dados não pode ser montado com o erro -515.

Ação do usuário

Para resolver esse problema, execute um ou mais dos seguintes procedimentos:

  • Usando os procedimentos descritos aqui, determine quais arquivos de log de transações estão ausentes e onde estão localizados. Então, mova-os de volta para o diretório de log de transações do grupo de armazenamento.

  • Restaure o(s) banco(s) de dados afetado(s) a partir do backup.

Cuidado:
Você não deve tentar restaurar o banco de dados, a menos que a solução anterior de localização e restauração dos arquivos de log de transações ausentes específicos tenha falhado. Fazer isso substituirá todos os dados adicionados desde o último backup.
Observação:
Antes de restaurar o(s) banco(s) de dados, mova ou exclua quaisquer arquivos de log de transações associados ao grupo de armazenamento afetado do caminho de destino.
Para identificar arquivos de log de transações ausentes utilizando o Assistente para Solução de Problemas do Microsoft Exchange no Exchange Server 2003 e no Exchange Server 2007

  1. Na janela Exibir Resultados de Exame de Log de Eventos do Assistente para Solução de Problemas do Microsoft Exchange, clique no link Use a tarefa relacionada de Gerenciamento de Recuperação de Banco de Dados para verificar e resolver esse problema para identificar os arquivos de log de transações necessários ausentes.

  2. Registre os nomes dos arquivos de log relatados na etapa 1.

  3. Determine o local atual dos arquivos de log e mova-os de volta para o local esperado.
Observação:
Lembre-se de pesquisar na Lixeira e nas pastas de quarentena do antivírus ao determinar o local atual dos arquivos de log de transações ausentes.
  1. Tente montar o banco de dados afetado do Exchange.

 Para identificar e restaurar manualmente logs de transações ausentes no Exchange 2000 Server ou Exchange Server 2003

  1. Inicie o Gerenciador do Sistema do Exchange.

  2. Expanda os Grupos Administrativos, expanda seu grupo administrativo, expanda Servidores, clique com o botão direito em seu grupo de armazenamento e clique em Propriedades.

  3. Na guia Geral, em Local de log de transações, registre o caminho do local dos arquivos de log de transações.

  4. Em um prompt de comando, abra o diretório no qual o Eseutil.exe está localizado. O caminho padrão para o Eseutil.exe no Exchange 2000 Server e no Exchange Server 2003 é C:\arquivos de programas\exchsrvr\bin.

  5. No prompt de comando, digite o seguinte comando:

    Código da Cópia
    eseutil /ml "logpath\logprefix"

    Onde logpath é o caminho dos arquivos de log de transações registrados na etapa 3 e logprefix é o prefixo dos arquivos de log de transações, normalmente e00.

    Um exemplo desse comando utilizando os padrões seria o seguinte:

    eseutil /ml "c:\program files\exchsrvr\mdbdata\e00".

  6. Os arquivos de log de transações que estão ausentes serão relatados em um dos dois formatos a seguir, dependendo do arquivo de log que estiver ausente:

    • Arquivo de log ausente: c:\arquivos de programas\exchsrvr\mdbdata\E0002BE2.log

    • ERRO: Arquivo(s) de log ausente(s). O arquivo de log é da geração 11.235 (0x2BE3), mas a geração esperada é a 11.234 (0x2BE2).

    Onde 0x2BE2 seria o arquivo de log ausente, E0002BE2.log.

  7. Registre os nomes dos arquivos de log relatados na etapa 6.

  8. Determine o local atual dos arquivos de log e mova-os de volta para o local esperado na etapa 3.
Observação:
Lembre-se de pesquisar na Lixeira e nas pastas de quarentena do antivírus ao determinar o local atual dos arquivos de log de transações ausentes.
  1. Tente montar o banco de dados afetado do Exchange.

 Para identificar e restaurar manualmente logs de transações ausentes no Exchange Server 2007

  1. Inicie o Console de Gerenciamento do Exchange no servidor em que o grupo de armazenamento está localizado.

  2. Na árvore do console, expanda Configuração do Servidor e clique em Caixa de Correio.

  3. No painel de resultados, clique no servidor de Caixa de Correio que contém o grupo de armazenamento cujos arquivos de log de transações ausentes você deseja restaurar.

  4. Clique com o botão direito no grupo de armazenamento e clique em Propriedades.

  5. . Na guia Geral, em Caminho de log, registre o caminho do local dos arquivos de log de transações.

  6. Em um prompt de comando, abra o diretório no qual o Eseutil.exe está localizado. No Exchange Server 2007, o Eseutil está localizado na pasta de instalação padrão do Exchange. Essa pasta é <Unidade_do_Sistema>:\Arquivos de Programas\Microsoft\Exchange Server\Bin.

  7. No prompt de comando, digite o seguinte comando:

    Código da Cópia
    eseutil /ml "logpath\logprefix"

    Onde logpath é o caminho dos arquivos de log de transações registrados na etapa 5 e logprefix é o prefixo dos arquivos de log de transações, normalmente e00.

    Um exemplo desse comando utilizando os padrões seria o seguinte:

    eseutil /ml "c:\Program Files\Microsoft\Exchange Server\Bin\e00".

  8. Os arquivos de log de transações que estão ausentes serão relatados em um dos dois formatos a seguir, dependendo do arquivo de log que estiver ausente:

    • Arquivo de log ausente: c:\Arquivos de Programas\Microsoft\Exchange Server\Bin\E000000049A.log

    • ERRO: Arquivo(s) de log ausente(s). O arquivo de log é da geração 11.235 (0x2BE3), mas a geração esperada é a 11.234 (0x2BE2).

    Onde 0x2BE2 seria o arquivo de log ausente, E0002BE2.log.

  9. Registre os nomes dos arquivos de log relatados na etapa 8.

  10. Determine o local atual dos arquivos de log e mova-os de volta para o local esperado na etapa 5.
Observação:
Lembre-se de pesquisar na Lixeira e nas pastas de quarentena do antivírus ao determinar o local atual dos arquivos de log de transações ausentes.
  1. Tente montar o banco de dados afetado do Exchange.

Para obter mais informações sobre o Evento ESE 454, consulte "Centro de mensagens de erros e eventos" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=81883).


ESE 455 -1811 (0xfffff8ed): Arquivo de log de transações atual (Exx.log) ausente
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-05-31

A ferramenta Microsoft Exchange Database Troubleshooter Tool detectou um ou mais eventos ESE 455 com código de erro -1811 (0xfffff8ed) no log de aplicativos. Esse evento indica que o log de transações atual (exx.log) está ausente, inacessível ou possui uma assinatura incompatível.

Explicação

Esse erro pode ser causado por:

  • Erro 1811 que corresponde a JET_errFileNotFound. Esse problema pode ocorrer em um arquivo de log do Exchange que possua uma assinatura incompatível e um número de geração de log interno (LGeneration). Normalmente, o arquivo de log do Exchange é o arquivo E00.log. Se o arquivo E00.log tiver uma assinatura incompatível, o armazenamento de informações poderá não ser montado mesmo que o banco de dados seja consistente.

  • Um programa antivírus coloca em quarentena ou exclui o arquivo de log do Exchange atual.

  • O comando de correção eseutil /p foi executado nos bancos de dados afetados e os arquivos de log não foram removidos.

  • O comando de recuperação eseutil /r foi executado com um nome base do arquivo de log incorreto, como no exemplo, eseutil /r Exx.log, em que Exx.log é um nome base de arquivo de log com três caracteres.

Esse erro também pode ser identificado como o erro -1811, JET_errFileNotFound. Esse erro se aplica às seguintes versões do servidor Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Ação do usuário

Para resolver o erro, execute um ou mais dos seguintes procedimentos:

  • Se o arquivo de log tiver uma assinatura e um número de geração de log incompatíveis, entre em contato com o Atendimento Microsoft. Para obter mais informações, visite a página Contato do site de Ajuda e Suporte da Microsoft.

  • Se um programa antivírus colocar em quarentena ou excluir o arquivo de log atual do Exchange, siga estas etapas:

    • Examine a configuração do programa antivírus.

    • Certifique-se de que o programa antivírus não esteja configurado para verificar os diretórios do Exchange Server.

    • Por padrão, alguns programas antivírus são definidos para verificar unidades e diretórios semanalmente, em modo manual ou automático. Essa definição pode ser facilmente ignorada. Certifique-se de adicionar os diretórios do Exchange Server aos locais excluídos do programa antivírus. Para obter mais informações sobre como configurar programas antivírus para funcionar com o Exchange, consulte o artigo 823166 da Base de Dados de Conhecimento Microsoft, Visão geral do Exchange Server 2003 e software antivírus (em inglês).

    • Confira os arquivos de log do programa antivírus para verificar se o arquivo de log do Exchange foi excluído ou colocado em quarentena.

    Use um dos seguintes métodos para recuperar o arquivo de log do Exchange:

Método 1: Se o arquivo de log do Exchange tiver sido colocado em quarentena

  1. Recupere o log do Exchange para a pasta que contém os arquivos de log de produção.

  2. Inicie o serviço Armazenamento de Informações do Microsoft Exchange. Se nenhum outro arquivo de log estiver faltando, o banco de dados será montado. Se outros arquivos de log estiverem faltando, verifique se os arquivos ausentes estão na pasta de quarentena do programa antivírus. Se os arquivos de log não estiverem na pasta de quarentena, consulte o Método 2.

Se o arquivo de log do Exchange tiver sido excluído, restaure de um backup o banco de dados do grupo de armazenamento. Em seguida, reproduza os arquivos de log. Para restaurar um banco de dados disponível, siga estas etapas:

Método 2: Se o arquivo de log do Exchange tiver sido excluído

  1. Mova todos os bancos de dados inconsistentes para uma pasta de backup.

  2. Se um novo arquivo E00.log tiver sido criado, mova-o para a pasta de backup. Além disso, mova o arquivo E00.chk para a pasta de backup.

  3. Copie na pasta de backup todos os arquivos de log existentes. Observação Os arquivos de log deverão ser copiados. Não mova os arquivos de log.

  4. Renomeie o último arquivo E00*.log para E00.log.

  5. Restaure o banco de dados de um backup. Em seguida, reproduza os arquivos de log. Isso coloca o banco de dados em um estado consistente. Entretanto, o banco de dados não inclui o arquivo E00.log que foi copiado na pasta de backup. Embora haja alguma perda de dados, agora será possível montar um banco de dados.

    Observação:
    Se não for possível restaurar o banco de dados de um backup, execute utilitários de reparo no banco de dados para colocá-lo em um estado consistente.

  6. Inicie o serviço Armazenamento de Informações do Microsoft Exchange.

Se o comando de reparo eseutil /p tiver sido executado nos bancos de dados afetados e os arquivos de log não tiverem sido removidos, siga estas etapas:

Para determinar se o comando eseutil /p foi executado

  1. Clique em Iniciar, Executar, digite cmd e clique em OK.

  2. Digite o seguinte no prompt de comando:

    Código da Cópia
    c:\program files\exchsrvr\bin\eseutil /mh "c:\program files\exchsrvr\mdbdata\<name of Exchange database.edb>"

    Essa sintaxe assume antecipadamente o seguinte:

    • Os arquivos de programa do Exchange Server foram instalados na pasta c:\arquivos de programas\exchsrvr.

    • O seu banco de dados está na pasta c:\arquivos de programas\exchsrvr\mdbdata.

  3. Leia o atributo de contagem de reparo. Se o atributo de contagem de reparo for 0 (zero), o comando eseutil /p não terá sido executado. Se o atributo de contagem de reparo for um número diferente de 0, isso significará que o comando eseutil /p foi executado no banco de dados.

Se os bancos de dados públicos e privados estiverem em um estado consistente ou de desligamento normal, você poderá mover os arquivos de log de transação para outra pasta. Para determinar se os bancos de dados estão em um estado consistente ou de desligamento normal, siga estas etapas:

Para determinar se os bancos de dados estão em um estado consistente ou de desligamento normal

  1. Clique em Iniciar, Executar, digite cmd e clique em OK.

  2. Para examinar o armazenamento de informações privadas, digite o seguinte:

    Código da Cópia
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\priv1.edb"

  3. Para examinar o armazenamento de informações públicas, digite o seguinte:

    Código da Cópia
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\pub1.edb"

    A sintaxe nas etapas 2 e 3 assume o seguinte:

    • Os arquivos de programa do Exchange Server foram instalados na pasta c:\arquivos de programas\exchsrvr.

    • O seu banco de dados está na pasta c:\arquivos de programas\exchsrvr\mdbdata.

  4. Reveja os resultados da verificação de consistência. Se um banco de dados estiver consistente (estado = desligamento normal), todos os arquivos de log terão sido confirmados no armazenamento de informações. Se o banco de dados não estiver consistente (estado = desligamento anormal), ele pode não estar corrompido. Os arquivos de log podem não ter sido confirmados ainda no banco de dados.

  5. Se o estado relatar desligamento normal, mova todos os arquivos de log de todos os diretórios mdbdata para uma pasta de backup.

  6. Monte os bancos de dados.
  • Se o comando de recuperação eseutil /r tiver sido executado com um nome base de arquivo de log incorreto, use a opção correta para executar o comando com êxito. Os nomes base comuns de arquivos de log são e00, e01, e02 e e03. Por exemplo, o comando a seguir contém um nome base de arquivo de log correto:

    Código da Cópia
    eseutil /r e00
  • Se o problema persistir, entre em contato com o Atendimento Microsoft. Para obter mais informações, visite a página Contato do site de Ajuda e Suporte da Microsoft.


ESE 474 -1018: Erro irrecuperável detectado no banco de dados
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-03-28

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft Exchange detectou um ou mais eventos ESE 474 com código de erro -1018 no log de Aplicativos. Esse erro será gerado se o componente de verificação de integridade do Microsoft Exchange determinar que o Exchange Server não poderá armazenar nem recuperar corretamente os dados do arquivo de banco de dados do Exchange do subsistema do disco rígido.

Explicação

Um evento ESE 474 com um erro -1018 pode ocorrer por causa de um componente de hardware do subsistema de disco rígido com defeito ou de drivers e/ou firmware incompatíveis ou desatualizados no subsistema de disco rígido.

Depois de encontrar um erro -1018, os testes de hardware de diagnóstico executados no servidor podem relatar que não existem problemas de hardware no subsistema de disco e a suposição pode ser que o Exchange Server seja responsável pelo problema.

A extensa investigação pela Microsoft e por fornecedores de hardware determinou que problemas sutis com os componentes de hardware do subsistema de disco, os drivers de suporte e o firmware são responsáveis pela maioria dos erros -1018.

O Exchange relata um erro -1018 quando uma página inicializada no arquivo de banco de dados encontra-se em uma das seguintes condições:

  • A soma de verificação armazenada na página não corresponde ao resultado do novo cálculo de soma de verificação executado conforme a página é lida.

  • O número de página que está armazenado na página não corresponde ao número que deveria estar especificado, considerando o local físico da página no arquivo de banco de dados.

O Exchange poderá ser responsável pela auto-geração de um erro -1018 se ocorrer um dos seguintes cenários:

  • O Exchange cria uma página com a soma de verificação incorreta.

  • O Exchange cria uma página corretamente, mas informa ao sistema operacional para gravar a página no local incorreto.

O Exchange gera uma soma de verificação para uma página que está prestes a ser gravada em disco depois que todos os dados tiverem sido gravados na página. Isso inclui o próprio número de página. Depois que o Exchange adicionar a soma de verificação à página, o Exchange instruirá o sistema operacional Windows a gravar a página em disco usando as APIs baseadas em Windows padrão publicadas.

Erros transitórios de memória podem fazer com que a página seja gravada no local incorreto do disco rígido.

Embora a soma de verificação da página seja correta, o Exchange relatará um erro -1018, pois o número de página lógico não corresponde ao número de página físico.

Um único erro -1018 relatado em um banco de dados do Exchange geralmente não faz com que o banco de dados do Exchange seja interrompido ou resulte em um sintoma diferente da presença do próprio erro -1018. A página afetada pode estar em uma pasta não acessada com freqüência, como as pastas Itens Enviados ou Itens Excluídos, ou em um anexo que seja raramente aberto ou, até mesmo, vazio.

Embora seja pouco provável que um único erro -1018 provoque a perda extensiva de dados, os erros -1018 são um problema porque podem indicar que o sistema de armazenamento não armazenou nem recuperou os dados de maneira confiável pelo menos uma vez. O erro -1018 é um aviso antecipado de um problema que provavelmente se tornará progressivamente pior. Mesmo se o primeiro erro -1018 for relatado para uma página vazia no banco de dados, não se saberá qual a próxima página que poderá ser danificada. Se uma tabela crítica global estiver danificada, o banco de dados do Exchange poderá não iniciar e o reparo do banco de dados poderá não ser bem-sucedido ou ser parcialmente bem-sucedido.

Após o registro de um erro -1018, considere e planeje a possibilidade de ocorrer uma falha iminente ou um dano aleatório adicional ao banco de dados antes de você localizar a principal causa do erro.

Ação do usuário

Antes de tentar corrigir os erros -1018 do ESE 474 registrados no log de Aplicativos, verifique se o subsistema de disco do servidor está estável.

Para solucionar o problema do subsistema de disco, proceda da seguinte forma:

  1. Abra o log de Aplicativos e procure eventos ESE 474. Em cada evento, anote o caminho completo do banco de dados afetado. Depois que você compilar uma lista de bancos de dados afetados, anote as letras de unidade mencionadas nos caminhos do banco de dados. Essas informações permitirão que você destine seus esforços para solucionar o problema diretamente para esses discos físicos.

  2. Reveja o log do Sistema e verifique se não há erros de leitura, gravação ou tempo limite registrados.

  3. Use os utilitários de diagnóstico do subsistema de disco fornecido pelo fabricante e entre em contato com o fornecedor de hardware do subsistema de disco para obter mais ajuda na verificação da integridade do subsistema de disco.

Depois de corrigir todos os problemas com o subsistema de disco ou de ter verificado sua estabilidade, use os métodos a seguir para se recuperar do erro -1018. Estes métodos estão listados em ordem de preferência ou de uso:

Primeiro Método Mova caixas de correio dos bancos de dados mencionados nos eventos ESE 474 do log de Aplicativos. Mova as caixas de correio para um armazenamento válido conhecido existente ou crie um novo Armazenamento de Caixa de Correio especificamente para esta finalidade. Quando todas as caixas de correio tiverem sido movidas, exclua os Armazenamentos de Caixa de Correio danificados.

Para mover caixas de correio (Exchange 2000 Server ou Exchange Server 2003)

  1. Em Usuários e Computadores do Active Directory, selecione o usuário ou usuários cujas caixas de correio você deseja mover.

  2. Clique com o botão direito do mouse na lista de usuário que você selecionou na etapa anterior e clique em Tarefas do Exchange.

  3. No Assistente de Tarefas do Exchange, na página Tarefas Disponíveis, clique em Mover Caixa de Correio e clique em Avançar.

  4. Leia cuidadosamente e siga as etapas restantes do assistente.
Para mover caixas de correio (Exchange Server 2003 somente)

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda o servidor do qual você deseja mover as caixas de correio, expanda o Grupo de Armazenamento do qual deseja mover as caixas de correio, expanda o Armazenamento de Caixa de Correio que contém as caixas de correio que deseja mover e, em seguida, clique em Caixas de correio.

  2. No painel de detalhes, clique com o botão direito no usuário ou usuários cujas caixas de correio você deseja mover e clique em Tarefas do Exchange.

  3. No Assistente de Tarefas do Exchange, na página Tarefas Disponíveis, clique em Mover Caixa de Correio e clique em Avançar.

  4. Leia cuidadosamente e siga as etapas restantes do assistente.
Para mover caixas de correio usando o Console de Gerenciamento do Exchange somente para o Exchange Server 2007

  1. Inicie o Console de Gerenciamento do Exchange.

  2. Na árvore do console, expanda Configuração de Destinatário e clique em Caixa de Correio.

  3. No painel de resultados, clique em uma ou mais caixas de correio que você deseja mover.

  4. No painel de ações, clique em Mover Caixa de Correio.

  5. No Assistente para Mover Caixa de Correio, na página Introdução, selecione o servidor, o grupo de armazenamento e o banco de dados de caixa de correio para onde você deseja mover a caixa de correio e, em seguida, clique em Avançar.

  6. Na página Opções de Movimentação, selecione uma opção para manipular mensagens danificadas em uma caixa de correio e clique em Avançar.

  7. Na página Agenda da Movimentação, especifique quando a movimentação deve ocorrer e clique em Avançar.

  8. Na página Mover Caixa de Correio, analise o resumo para confirmar as movimentações da caixa de correio e clique em Mover.

  9. Na página Conclusão, clique em Concluir.

Para obter mais informações sobre cenários aceitos para usar o assistente para Mover Caixa de Correio e o cmdlet Move-Mailbox, consulte "Movendo Caixas de Correio" (http://go.microsoft.com/fwlink/?LinkId=85754) na documentação do produto Exchange Server 2007.

Segundo Método Restaure os bancos de dados de um backup válido conhecido. Para obter mais informações sobre como restaurar bancos de dados do Exchange Server, consulte os seguintes artigos:

  • "Recuperação de Desastres" do Exchange Server 2007 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=85802)

  • "Guia de Operações de Recuperação de Desastres do Exchange 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=30250)

Terceiro Método Use o Eseutil para executar um reparo complexo dos bancos de dados afetados. Esse método deverá ser executado somente se os dois métodos anteriores tiverem falhado. Depois de executar o reparo complexo, você também deverá executar uma desfragmentação offline do banco de dados reparado e executar a ferramenta Isinteg para reparar o dano lógico. Essas etapas podem ser executadas usando a Tarefa de Correção do Solucionador de Problemas de Banco de Dados do Exchange. Isso executará automaticamente o regime Eseutil /P, Eseutil /D e Isinteg para você.

Para obter mais informações

Para obter mais informações sobre esse problema, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft e os recursos do Exchange:

  • 314917, "Compreendendo e analisando os erros -1018, -1019 e -1022 de banco de dados do Exchange" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314917)

  • 867626, "Novo código de correção de erro está incluído no Exchange Server 2003 SP1" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=867626)

  • 259851, "Ramificações de execução do comando eseutil /p ou edbutil /d /r no Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259851)

  • "Erro -1018 do Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=85807)


MSExchangeIS 1003: Espaço Livre Restante na Unidade de Banco de Dados do Exchange Insuficiente
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-22

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft® Exchange detectou um ou mais eventos MSExchangeIS 1003 no log de Aplicativos. Esse erro pode ocorrer se houver quantidade insuficiente de espaço livre em disco na unidade que contém os bancos de dados que você está tentando montar.

Explicação

Quando o disco que contém os bancos de dados do Exchange fica sem espaço livre, o serviço de Armazenamento de Informações do Microsoft Exchange registra um evento MSExchangeIS 1003 e os bancos de dados afetados são desmontados. Depois que isso ocorre, você pode não conseguir montar os bancos de dados relativos ao grupo de armazenamento afetado. Esse erro se aplica às seguintes versões do servidor Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Ação do usuário

Para resolver esse problema, libere espaço em disco na unidade do banco de dados e, em seguida, tente montar os bancos de dados novamente. Para fazer isso, execute um ou mais dos seguintes procedimentos:

  • Se os arquivos de banco de dados do Exchange forem os únicos no disco rígido, talvez seja necessário executar uma desfragmentação offline dos bancos de dados para liberar espaço no disco.

    Observação:
    Dependendo da quantidade de espaço livre disponível no banco de dados, essa etapa pode não resolver seu problema.
    Para obter mais informações sobre a execução dessa etapa, consulte o artigo 328804 da Base de Dados de Conhecimento da Microsoft, Como desfragmentar bancos de dados do Exchange (em inglês).

    Além disso, consulte Como executar o Eseutil /D (Desfragmentação) (em inglês).

  • Se os arquivos de log de transações do Exchange estiverem nessa unidade também, talvez seja possível liberar espaço no disco removendo arquivos de log desnecessários.

    Para obter mais informações sobre a execução dessa etapa, consulte o artigo 240145 da Base de Dados de Conhecimento da Microsoft, Como remover arquivos de log de transações do Exchange Server (em inglês).


MSExchangeIS 1088: Não é possível montar o banco de dados, devido a legacyExchangeDN inválido
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-23

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft® Exchange detectou um evento MSExchangeIS 1088. Esse evento indica que o banco de dados do Exchange não pôde ser montado por ter um valor de atributo legacyExchangeDN diferente do que está armazenado no Active Directory.

Explicação

Um evento MSExchangeIS 1088 poderá ocorrer se um banco de dados do Exchange for restaurado para um Grupo Administrativo que tenha um valor para o atributo legacyExchangeDN diferente de seu Grupo Administrativo original. Esse comportamento é devido ao design. Para montar armazenamentos em um Exchange Server, o valor do atributo legacyExchangeDN da Organização e do Grupo Administrativo dos bancos de dados do Exchange deve corresponder ao valor do atributo legacyExchangeDN da Organização e do Grupo Administrativo no Active Directory.

Ação do usuário

Para resolver esse problema, proceda da seguinte forma:

  • Restaure o banco de dados do Exchange ao seu Grupo Administrativo original.

  • Se o banco de dados do Exchange não puder ser restaurado ao seu Grupo Administrativo original, renomeie os objetos do Active Directory do destino pretendido, de modo que eles tenham o mesmo valor para o atributo legacyExchangeDN do banco de dados do Exchange. Você pode corrigir o valor usando uma ferramenta como ADSI (Active Directory Service Interfaces) Edit, LDP (ldp.exe) ou qualquer outro cliente do protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003, do Exchange Server 2007, ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse erro

  1. Usando a ADSI Edit ou em uma ferramenta semelhante, localize o objeto de grupo administrativo no Active Directory.

    É possível encontrar o atributo legacyExchangeDN em:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. Digite um novo valor de cadeia de caracteres do formulário:

    /o= organização /ou= grupo administrativo

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o utilitário LDP para modificar os atributos de objeto do Active Directory" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como funciona o ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda do Windows Server 2003.

Para obter mais informações sobre o evento MSExchangeIS 1088, consulte os seguintes recursos:

  • Centro de Mensagens de Erros e Eventos

  • Artigo 280652 da Base de Dados de Conhecimento da Microsoft, "XADM: "ID de Evento 1088" é registrada e a montagem do armazenamento falha" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=280652)


MSExchangeIS 5000 (0x3f5): Conta de Serviço Inválida Configurada para o Serviço de Armazenamento de Informações
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-02-27

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft® Exchange detectou um ou mais eventos MSExchangeIS 5000 com código de erro 0x3f5 no log de Aplicativos. Esse erro ocorre quando o serviço de Armazenamento de Informações do Microsoft Exchange está configurado para ser iniciado com uma conta diferente de Sistema Local.

Explicação

Esse problema pode ocorrer se o serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe) estiver usando uma conta diferente de Sistema Local, ou caso o controlador de domínio, o domínio ou a Diretiva de Segurança de Máquina Local não inclua a conta Serviço Local na diretiva Gerar Auditorias de Segurança. Quando esse problema ocorre, a inicialização do serviço de Armazenamento de Informações do Exchange falha. O erro se aplica às seguintes versões do servidor Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Ação do usuário

Para resolver esse problema, execute um ou mais dos seguintes procedimentos:

  • Por padrão, o serviço de Armazenamento de Informações do Exchange usa a conta Sistema Local para iniciar o serviço de Armazenamento de Informações (MACHINENAME$). Use o snap-in Services.msc para verificar qual conta está sendo usada para iniciar o serviço de Armazenamento de Informações. Se a conta for a de Sistema Local, conceda a ela o direito Gerar Auditorias de Segurança. Para fazer isso, use um dos seguintes métodos:

    • Execute novamente o comando /domainprep de instalação do Exchange nesse computador.

    • Conceda manualmente à conta Sistema Local o direito Gerar Auditorias de Segurança em uma das seguintes diretivas:

    1. A diretiva do controlador de domínio

    2. A diretiva do domínio

    3. A Diretiva de Segurança da Máquina Local

      Para conceder novamente esse direito à Diretiva de Segurança da Máquina Local de um servidor membro, siga estas etapas.

      Observação:
      Essa é a solução recomendável se esse problema estiver ocorrendo em apenas um servidor.
      Para conceder novamente o direito de auditoria à Diretiva de Segurança da Máquina Local de um servidor membro

      1. Clique em Iniciar, Ferramentas Administrativas e, em seguida, em Diretiva de Segurança Local.

      2. Expanda Configurações de Segurança, clique em Diretivas Locais e, em seguida, clique em Atribuição de Direitos do Usuário.

      3. No painel direito, clique duas vezes em Gerar Auditorias de Segurança, clique em Adicionar, insira MACHINENAME$ e clique em OK duas vezes.

      4. Saia do snap-in Diretiva de Grupo.
  • Se você iniciar o serviço de Armazenamento de Informações com uma conta que não seja Sistema Local, altere-a para a conta Sistema Local (MACHINENAME$). Em seguida, tente iniciar o serviço de Armazenamento de Informações. Para obter mais informações sobre por que o Exchange 2000 Server e o Exchange Server 2003 usam a conta Sistema Local para iniciar os serviços do Exchange, consulte o artigo 239762 da Base de Dados de Conhecimento da Microsoft, Serviços do Exchange executados na conta Sistema Local (em inglês).

Para obter mais informações

Para obter mais informações, consulte o artigo 281850 da Base de Dados de Conhecimento da Microsoft, O armazenamento de informações não é iniciado com as mensagens de ID de evento 9530 e 5000 no Exchange 2000 Server e no Exchange Server 2003 (em inglês).


MSExchangeIS 5000 (0x80004005): Não é possível montar o banco de dados devido à conta de serviço incorreta ou permissões SeSecurityPrivilege ausentes ou associação de grupos incorreta
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-02-19

A ferramenta Microsoft Exchange Database Troubleshooter Tool detectou um ou mais eventos MSExchangeIS 5000 com código de erro 0x80004005 no log de aplicativos. O evento indica que um ou mais bancos de dados no servidor Exchange não podem ser montados devido a uma conta de serviço incorreta, permissões SeSecurityPrivilege ausentes ou associação de grupos incorreta.

Explicação

O evento pode ocorrer se alguma das seguintes condições for verdadeira:

  • A permissão Gerenciar Auditoria e Log de Segurança (SeSecurityPrivilege) foi removida do grupo Servidores Corporativos do Exchange em um ou mais controladores de domínio. O grupo Servidores Corporativos do Exchange deve ter a permissão Gerenciar Auditoria e Log de Segurança em todos os controladores de domínio do domínio. Quando essa condição for verdadeira, um ou mais serviços relacionados ao Exchange Server não serão iniciados.

  • O serviço de Armazenamento de Informações do Microsoft Exchange está sendo iniciado com uma conta diferente de Sistema Local, ou o controlador de domínio, o domínio ou a Diretiva de Segurança de Máquina Local não inclui a conta Serviço Local na diretiva Gerar Auditorias de Segurança. Quando essa condição for verdadeira, o serviço Armazenamento de Informações do Exchange não será iniciado.

  • O grupo Servidores Corporativos do Exchange do domínio pai não contém o grupo Servidores de Domínio do Exchange do domínio filho.

O evento também pode ser identificado como MAPI_E_CALL_FAILED. O evento se aplica às seguintes versões do servidor Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Ação do usuário

Para resolver o problema, execute um ou mais dos seguintes procedimentos:

  • Se a permissão Gerenciar auditoria e log de segurança (SeSecurityPrivilege) for removida do grupo Exchange Enterprise Servers em um ou mais controladores de domínio, siga estas etapas:

    Para adicionar permissões em um ou mais controladores de domínio

    1. Use Policytest.exe para solucionar problemas de permissões. Policytest.exe está localizado na pasta Support\Utils\I386 do CD do Exchange 2000 Server, ou na pasta Support\ExDeploy, do CD do Exchange Server 2003. Use o Policytest.exe para determinar se a permissão "Gerenciar auditoria e log de segurança" do grupo Exchange Enterprise Servers está faltando em um controlador de domínio. Um resultado com êxito retorna informações semelhantes às seguintes:

      O domínio local é "<contoso.com>" (contoso) A conta é "CONTOSO\Exchange Enterprise Servers" DC = "<ComputerName>" No site = "<Default-First-Site-Name>" Direito encontrado: "SeSecurityPrivilege"

      Observação Um resultado com êxito mostra que existe a permissão "Gerenciar auditoria e log de segurança". É necessário que você tenha direitos de administrador de domínio para executar o Policytest.exe. Para obter mais informações sobre o utilitário Policytest.exe, consulte o artigo 281537 da Base de Dados de Conhecimento Microsoft, XADM: Descrição do utilitário Policytest.exe.

    2. Redefina as permissões padrão de Exchange Enterprise Server no nível de domínio. Para fazer isso, siga essas etapas:

      1. Execute o comando setup /domainprep a partir do CD do Exchange Server ou do ponto de instalação na rede. O comando setup /domainprep adiciona o grupo Exchange Enterprise Servers ao domínio que tem permissões padrão. Ao executar o comando setup /domainprep, as permissões são adicionadas imediatamente a um controlador de domínio. Em seguida, a alteração é replicada nos outros controladores de domínio.

      2. Restaure a herança de permissões em outras unidades organizacionais. Em seguida, aguarde os controladores de domínio replicarem as alterações em todo o domínio.

      3. Execute o Policytest.exe. Observe quais controladores de domínio retornam o seguinte resultado com êxito:

        Direito encontrado: "SeSecurityPrivilege"

        Se todos os controladores de domínio tiverem as permissões corretas, reinicie os serviços do Exchange Server. Se nenhum controlador de domínio tiver as permissões corretas, consulte a etapa 3.

    3. Verifique a diretiva do controlador de domínio padrão. Para fazer isso, siga essas etapas:

      1. Inicie o snap-in Usuários e Computadores do Active Directory.

      2. Clique com o botão direito no contêiner Controladores de Domínio e em Propriedades.

      3. Clique na guia Diretiva de Grupo e verifique se Diretiva de Controladores de Domínio Padrão está listada na caixa de diálogo Links de Objetos de Diretiva de Grupo. Observação Se Diretiva de Controladores de Domínio Padrão não estiver na lista, clique em Adicionar, Diretiva de Controladores de Domínio Padrão e clique em OK. Em seguida, aguarde a replicação dessa alteração em todos os demais controladores de domínio.

      4. Execute o comando setup /domainprep a partir do CD do Exchange Server ou do ponto de instalação na rede. O comando setup /domainprep adiciona o grupo Exchange Enterprise Servers ao domínio que tem permissões padrão.

      5. Execute o Policytest.exe. Observe quais controladores de domínio retornam o seguinte resultado com êxito:

      Direito encontrado: "SeSecurityPrivilege"

      Se todos os controladores de domínio tiverem as permissões corretas, reinicie os serviços do Exchange Server. Se algum controlador de domínio não tiver as permissões corretas, consulte a etapa 4.

    4. Adicione manualmente as permissões ao controlador de domínio. O FRS (Serviço de Replicação de Arquivo) pode não replicar a diretiva de segurança atualizada em um ou mais controladores de domínio após a execução do comando setup /domainprep. Se esse problema ocorrer, atribua manualmente as permissões corretas ao grupo Exchange Enterprise Servers. Se alguns ou todos os controladores de domínio não tiverem as permissões corretas, atribua a permissão "Gerenciar auditoria e log de segurança" ao grupo Exchange Enterprise Servers. Em seguida, aguarde a replicação da definição nos demais controladores de domínio. Para fazer isso, siga essas etapas:

      1. Inicie o snap-in Usuários e Computadores do Active Directory.

      2. Clique com o botão direito no contêiner Controladores de Domínio e em Propriedades.

      3. Clique na guia Diretiva de Grupo, clique em Diretiva de Controladores de Domínio Padrão na caixa de diálogo Links de Objetos de Diretiva de Grupo e clique em Editar.

      4. Expanda Configuração do Computador, Configurações do Windows, Configurações de Segurança, Diretivas Locais e clique em Atribuição de Direitos do Usuário.

      5. No painel direito, clique duas vezes em Gerenciar auditoria e log de segurança, clique em Adicionar, Procurar e adicione o grupo Exchange Enterprise Servers.

      6. Na caixa de diálogo Adicionar usuário ou grupo, clique em OK. Em seguida, clique em OK novamente.

      7. Saia do snap-in Diretiva de Grupo e clique em OK na caixa de diálogo Propriedades de Controladores de Domínio. Observação Algumas vezes, o grupo Exchange Enterprise Servers pode não ser exibido quando você clica em Procurar na caixa de diálogo Adicionar usuário ou grupo. Se esse comportamento ocorrer, adicione o grupo Exchange Domain Servers. Em seguida, execute o comando setup /domainprep novamente. Esse processo torna permanente a adição do grupo Exchange Enterprise Servers em todos os controladores de domínio.
  • Se o serviço Armazenamento de Informações do Exchange estiver sendo iniciado com uma conta diferente de Sistema Local, ou se o controlador de domínio, o domínio ou a Diretiva de Segurança de Máquina Local não incluir a conta Serviço Local na diretiva Gerar Auditorias de Segurança, siga a resolução aqui indicada.

    Por padrão, o serviço de Armazenamento de Informações do Exchange usa a conta Sistema Local para iniciar o serviço de Armazenamento de Informações (MACHINENAME$). Use o snap-in Services.msc para verificar qual conta está sendo usada para iniciar o serviço de Armazenamento de Informações. Se a conta for a de Sistema Local, conceda novamente a ela o direito Gerar auditorias de segurança. Para fazer isso, use um dos seguintes métodos:

    Para conceder novamente o direito Gerar auditorias de segurança à conta Sistema Local

    1. Execute novamente o comando Setup /domainprep do Exchange nesse computador.

    2. Conceda manualmente à conta Sistema Local o direito Gerar auditorias de segurança em uma das seguintes diretivas:

      • A diretiva do controlador de domínio

      • A diretiva do domínio

      • A diretiva de Segurança da Máquina Local

    Para conceder novamente o direito Gerar auditorias de segurança à diretiva de Segurança da Máquina Local de um servidor membro

    1. Clique em Iniciar, Ferramentas Administrativas e em Diretiva de Segurança Local.

    2. Expanda Configurações de Segurança, clique em Diretivas Locais e clique em Atribuição de Direitos do Usuário.

    3. No painel direito, clique duas vezes em Gerar Auditorias de Segurança, clique em Adicionar, insira MACHINENAME$ e clique em OK duas vezes.

    4. Saia do snap-in Diretiva de Grupo.
    Se você iniciar o serviço de Armazenamento de Informações com uma conta que não seja Sistema Local, altere-a para a conta Sistema Local (MACHINENAME$). Em seguida, tente iniciar o serviço de Armazenamento de Informações. Para obter mais informações sobre por que o Exchange 2000 Server e o Exchange Server 2003 usam a conta Sistema Local para iniciar os serviços do Exchange, consulte o artigo 239762 da Base de Dados de Conhecimento Microsoft, Serviços do Exchange executados na conta Sistema Local (em inglês).

  • Se o grupo Servidores Corporativos do Exchange do domínio pai não contiver o grupo Servidores de Domínio do Exchange do domínio filho, adicione o grupo Servidores de Domínio do Exchange do domínio filho ao grupo Servidores Corporativos do Exchange no domínio pai. Também é possível resolver esse problema criando o Serviço de Atualização de Destinatário no domínio raiz.

    Para resolver esse problema, execute a instalação do Exchange com a opção /domainprep em um servidor no domínio remoto do Windows. Em seguida, no servidor Exchange, use o Gerenciador de Sistema do Exchange para criar um Serviço de Atualização de Destinatário para o domínio remoto. Para fazer isso, siga essas etapas:

    Para criar um Serviço de Atualização de Destinatário para o domínio remoto

    1. Clique em Iniciar, Programas, Microsoft Exchange e Gerenciador do Sistema.

    2. Expanda o objeto Organização e expanda o contêiner Destinatários.

    3. Clique em Serviço de Atualização de Destinatário.

    4. No painel direito, clique com o botão direito em Novo e clique em Serviço de Atualização de Destinatário.

    5. Clique no domínio que não tenha uma instância do Serviço de Atualização de Destinatário e tenha usuários que devam ser atualizados pelo Exchange.

    6. Clique em Avançar.

    7. Selecione o servidor no qual você deseja executar o Serviço de Atualização de Destinatário e processar todos os usuários necessários com os atributos do Exchange.

    8. Clique em Avançar.

    9. Clique em Concluir.

    10. Para iniciar manualmente uma atualização dos destinatários desse domínio, clique com o botão direito em Serviço de Atualização de Destinatário e clique em Atualizar Agora para forçar uma atualização.
    Para obter mais informações, consulte o artigo 253770 da Base de Dados de Conhecimento Microsoft, Tarefas executadas pelo Serviço de Atualização de Destinatário do Exchange (em inglês).


MSExchangeIS 5000 (0x80040154): Extensões de Serviço SMTP Ausentes ou Danificadas
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-02-19

A ferramenta Microsoft Exchange Database Troubleshooter Tool detectou um ou mais eventos MSExchangeIS 5000 com código de erro 0x80040154 no log de aplicativos. Esse erro pode ocorrer se as extensões de Serviço SMTP do Exchange Server estiverem ausentes ou danificadas.

Explicação

Esse problema ocorre porque as extensões do Serviço SMTP do Exchange estão ausentes ou danificadas. Esse comportamento causa perda de funcionalidade entre o Exchange e o Serviço SMTP. O Serviço SMTP é um serviço necessário que é instalado como subcomponente do Microsoft IIS (Internet Information Services).

O erro pode ocorrer pelas seguintes razões:

  • O IIS foi removido.

  • O subcomponente Serviço SMTP foi removido do IIS.

  • O IIS foi removido e depois reinstalado como um componente do Windows que não tem o subcomponente Serviço SMTP exigido.

  • O IIS foi removido e depois reinstalado como um componente do Windows que tem a lista apropriada de subcomponentes. Entretanto, as extensões do serviço SMTP do Exchange não foram reinstaladas.

Esse erro se aplica às seguintes versões do servidor Exchange:

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Ação do usuário

Para resolver esse erro, consulte o artigo 326305 da Base de Dados de Conhecimento Microsoft, O Armazenamento de Informações não é iniciado e as mensagens de ID de Evento 5000 e 9538 do MSExchangeIS ocorrem no Exchange 2000 Server e no Exchange Server 2003.

Para restaurar as extensões do serviço SMTP

  1. Confirme se as extensões do Serviço SMTP do Exchange estão faltando. Para fazer isso, siga essas etapas:

    1. Faça logon no computador que está executando o Microsoft Exchange, usando uma conta que tenha credenciais administrativas.

    2. Clique em Iniciar, Executar, digite cmd e clique em OK.

    3. Digite telnet 127.0.0.1 25 no prompt de comando para exibir a entrada "220 server.domain.com Microsoft ESMTP Mail Service".

    4. Digite EHLO e pressione Enter para exibir uma lista de 250 verbos de comandos. Se não houver verbos cujos nomes começam com "X", as Extensões do Serviço SMTP estarão ausentes.

  2. Faça o backup completo da partição do sistema. Inclua o estado do sistema e os arquivos de banco de dados do Exchange. Para obter mais informações sobre como fazer isso, consulte o artigo 258243 da Base de Dados de Conhecimento Microsoft, Como fazer backup e restaurar um computador do Exchange usando o programa de backup do Windows.

  3. Confirme se o IIS foi reinstalado corretamente para incluir os subcomponentes dependentes do Exchange necessários.

    IIS 6.0

    1. Clique em Iniciar, aponte para Configurações e clique em Painel de Controle.

    2. Clique duas vezes em Adicionar/Remover Programas.

    3. No painel esquerdo, clique em Adicionar/Remover Componentes do Windows.

    4. No assistente para Componentes do Windows, localize o Servidor de Aplicativos na lista de componentes e clique em Detalhes.

    5. Se algum dos seguintes componentes não estiver instalado, instale-os:

      ASP.NET

      Habilitar acesso à rede COM+

      IIS (Serviços de Informações da Internet)

    6. Clique em Internet IIS (Serviços de Informações) e clique em Detalhes.

    7. Se algum dos seguintes componentes não estiver instalado, instale-os:

      Arquivos Comuns

      Gerenciador de Serviços de Informações da Internet

      Serviço NNTP

      Serviço SMTP

      Serviço Web

    8. Clique em OK duas vezes. Na página principal Componentes do Windows, clique em Avançar e Concluir.

    IIS 5.0

    1. Clique em Iniciar, aponte para Configurações e clique em Painel de Controle.

    2. Clique duas vezes em Adicionar/Remover Programas.

    3. No painel esquerdo, clique em Adicionar/Remover Componentes do Windows.

    4. Na caixa de diálogo Assistente de Componentes do Windows, localize o IIS na lista de componentes. Se a caixa de seleção IIS (Serviços de Informações da Internet) estiver marcada, o IIS estará instalado. Para exibir os subcomponentes do IIS que estão instalados, clique em IIS (Serviços de Informações da Internet) e clique em Detalhes.

    5. Se o IIS não estiver instalado, clique para marcar a caixa de seleção IIS (Serviços de Informações da Internet) e clique em Detalhes. Instale os subcomponentes do IIS 5.0 e clique em OK. Os subcomponentes mínimos do IIS 5.0 que são exigidos antes de instalar o Exchange 2000 são os seguintes:

      Arquivos comuns

      Snap-in de Serviços de Informações da Internet

      Serviço SMTP

      Protocolo NNTP (para grupos de notícias)

      Serviço Web

    6. Clique em Avançar e em Concluir.

  4. Restaure as extensões do Serviço SMTP do Exchange.

    Exchange Server 2003

    Se você reinstalar o Exchange 2003 sobre uma instalação existente do Exchange 2003, os arquivos e as permissões do banco de dados permanecerão intactos. Para fazer isso, siga essas etapas:

    1. Insira o CD do Exchange 2003.

    2. Na pasta \SETUP\I386, clique duas vezes no arquivo Setup.exe.

    3. Na página Bem-vindo, clique em Avançar até acessar a página Seleção de Componentes.

    4. Na página Seleção de Componentes, clique em Reinstalar na coluna Ação e clique em Avançar.

    5. Verifique a seleção na página Resumo da Instalação e clique em Avançar para continuar a instalação do Exchange 2003.

    Exchange 2000 Server

    Os métodos que você pode utilizar para restaurar as extensões do Serviço SMTP do Exchange 2000 dependem de quantos subcomponentes do IIS foram removidos. Se o Serviço SMTP for o único subcomponente do IIS removido e o Exchange 2000 Server Service Pack 2 (SP2) ou um service pack mais recente tiver sido instalado, use o utilitário de linha de comando Smtpreinstall.exe. O utilitário de linha de comando Smtpreinstall.exe está na pasta Server\Support\Utils\I386.

    Para usar o utilitário Smtpreinstall.exe

    1. Copie o arquivo Smtpreinstall.exe na pasta Exchsrvr\Bin.

    2. No prompt de comando, vá para a pasta Exchsrvr\Bin e digite o seguinte comando:

      smtpreinstall.exe

    3. Reinicie o computador quando solicitado.

    Se o IIS 5.0 tiver sido removido como componente ou se mais que o subcomponente de Serviço SMTP tiver sido removido do IIS 5.0, reinstale o Exchange 2000 sobre a instalação existente como parte da instalação integrada do Microsoft Small Business Server 2000.

    Para reinstalar o Exchange 2000 Server

    Observação:
    Se você reinstalar o Exchange 2000 sobre uma instalação existente do Exchange 2000, os arquivos e as permissões do banco de dados permanecerão intactos.
    1. Insira o CD do Exchange 2000 Server.

    2. Na pasta \SETUP\I386, clique duas vezes no arquivo Setup.exe.

    3. Na página Bem-vindo, clique em Avançar.

    4. Digite a chave do CD, se solicitada, e clique em Avançar.

    5. Na página Seleção de Componente, clique em Reinstalar na coluna Ação e clique em Avançar.

    6. Verifique a seleção na página Resumo da Instalação e clique em Avançar para continuar a instalação do Exchange 2000.

  5. Reinstale os service packs e os hotfix do Exchange.

    Para obter mais informações, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

    836993 Como obter os service packs mais recentes do Exchange Server 2003.

    301378 Como obter o service pack mais recente do Exchange 2000 Server.


MSExchangeIS 5000 (0xc004038a): Não é possível montar o banco de dados devido a permissões incorretas ou grupo de roteamento excluído
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-05-31

A ferramenta Microsoft Exchange Database Troubleshooter Tool detectou um ou mais eventos MSExchangeIS 5000 com código de erro 0xc004038a no log de aplicativos. Quando esse erro ocorre, o serviço de Armazenamento de Informações do Microsoft Exchange não é inicializado e os bancos de dados não são montados.

Explicação

O evento MSExchangeIS 5000 com código de erro 0xc004038a pode ocorrer devido a permissões incorretas ou um grupo de roteamento excluído. Esse evento pode ser causado por um ou mais dos seguintes motivos:

  • O Exchange Server não é mais membro de um grupo de roteamento, ou seu grupo de roteamento foi excluído do Active Directory.

  • O grupo Exchange Domain Servers não tem as permissões apropriadas no Active Directory.

Esse evento se aplica às seguintes versões do servidor Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Ação do usuário

Para resolver o erro, execute um ou mais dos seguintes procedimentos:

  • Se o grupo Exchange Domain Servers não tiver as permissões apropriadas, use o utilitário ADSI Edit para se certificar de que o grupo tenha as permissões exigidas no Active Directory. Certifique-se de que a caixa de seleção Permitir que permissões herdadas do pai se propaguem para este objeto esteja selecionada na guia Segurança, nos grupos Administradores e Servidores de Domínio do Exchange, e em qualquer outro grupo relevante à sua configuração.

    Observação:
    Se for necessário, force a replicação entre os controladores de domínio para verificar se as alterações são propagadas por todo o domínio.
    Observação:
    A ferramenta ADSI Edit está incluída nas Ferramentas de Suporte do Microsoft Windows 2000 e nas Ferramentas de Suporte do Microsoft Windows Server 2003, disponíveis no CD de instalação do Windows 2000 e do Windows 2003.
  • Se o servidor Exchange não for mais membro de um grupo de roteamento, ou seu grupo tiver sido excluído do Active Directory, adicione ou restaure o grupo de roteamento. Siga estas resoluções de acordo com o problema que melhor corresponde ao seu caso:

Resolução 1: Adicione o servidor ao grupo de roteamento. Verifique se o servidor não é mais membro de um grupo de roteamento seguindo estas etapas:

  1. Inicie o Gerenciador do Sistema do Exchange.

  2. Expanda Organização, Grupos Administrativos, AdministrativeGroupName e Grupos de Roteamento.

    Observação:
    Nesta etapa, AdministrativeGroupName é o nome do grupo administrativo.
  3. Percorra todos os grupos de roteamento disponíveis e verifique se esse servidor não está listado.

    Observação:
    Se nenhum grupo de roteamento estiver visível, consulte Resolução 2.
  4. Depois de confirmar que esse servidor não é membro de um grupo de roteamento, adicione-o novamente a um grupo de roteamento existente. Para fazer isso, siga essas etapas:

    Importante:
    Se você usar o snap-in ADSI Edit, o utilitário LDAP ou qualquer outro cliente da versão 3 do LDAP e modificar incorretamente os atributos de objetos do Active Directory, poderá causar sérios problemas. Esses problemas podem exigir a reinstalação do Microsoft Windows 2000 Server, do Microsoft Windows Server 2003, do Microsoft Exchange 2000 Server, do Microsoft Exchange Server 2003 ou do Windows e do Exchange. A Microsoft não garante que os problemas que ocorrerão se você modificar incorretamente os atributos de objetos do Active Directory possam ser resolvidos. Você é responsável pela modificação desses atributos.
Para adicionar o servidor novamente ao grupo de roteamento

  1. Clique em Iniciar, Executar, digite adsiedit.msc e clique em OK.

    Observação:
    A ferramenta ADSI Edit está incluída nas Ferramentas de Suporte do Microsoft Windows 2000 e nas Ferramentas de Suporte do Microsoft Windows Server 2003. Para instalar essas ferramentas de suporte, siga estas etapas:
    • Em computadores Windows 2000 Server, clique duas vezes em Setup.exe na pasta Suporte\Ferramentas do CD do Windows 2000 e siga as etapas do Assistente para Instalar as Ferramentas de Suporte do Windows para concluir a instalação das Ferramentas de Suporte do Windows 2000.

    • Em computadores baseados no Windows Server 2003, clique com o botão direito em Suptools.msi na pasta Suporte\Ferramentas no CD do Windows Server 2003, clique em Instalar,e siga as etapas no Assistente para Instalação das Ferramentas de Suporte do Windows para concluir a instalação das Ferramentas de Suporte do Windows Server 2003.

  2. Expanda Configuração [ servername.domain_name.com ], expanda CN=Configuração, DC= domain_name, DC= com, expanda CN=Serviços, CN=Microsoft Exchange, CN= OrganizationName, CN=Grupos Administrativos, CN= AdministrativeGroupName e clique em CN=Grupos de Roteamento.

    Observação:
    Nesta etapa, servername é o nome do servidor, domain_name.com é o nome do domínio, OrganizationName é o nome da organização do Exchange Server e AdministrativeGroupName é o nome do grupo administrativo.

  3. Clique com o botão direito no grupo de roteamento do qual esse servidor deverá ser membro e clique em Propriedades.

  4. Clique no atributo distinguishedName e em Editar

  5. Copie o valor do atributo distinguishedName no Bloco de notas.

  6. Clique em Cancelar duas vezes para fechar as propriedades.

  7. Na ferramenta ADSIEdit, expanda Configuração [ servername.domain_name.com ], CN=Configuração, DC= domain_name ,DC= com, expanda CN=Serviços, CN=Microsoft Exchange, CN= OrganizationName, CN=Grupos Administrativos, CN= AdministrativeGroupName e CN=Servidores.

  8. Clique com o botão direito em servername e clique em Propriedades.

  9. Clique no atributo msExchHomeRoutingGroup e em Editar

  10. Cole o valor copiado no Bloco de notas, na etapa 5, e clique em OK duas vezes para salvar o novo valor.

  11. No Gerenciador de Sistema do Exchange, localize o grupo de roteamento ao qual você adicionou esse servidor.

  12. Atualize o Gerenciador de Sistema do Exchange para exibir esse servidor.

    Observação:
    Se o servidor Exchange não for exibido imediatamente, aguarde a replicação do Active Directory.

  13. Se nenhum outro servidor Exchange nesse grupo de roteamento tiver o Tipo de Servidor definido como Mestre, clique com o botão direito nesse servidor Exchange e clique em Definir como Mestre.

  14. Inicie os serviços Armazenamento de Informações e Pilhas MTA.

Resolução 2: Restaure o grupo de roteamento. Se você remover acidentalmente um grupo de roteamento, restaure-o com o backup mais recente dos dados do Estado do Sistema. Se você não tiver um backup recente dos dados do Estado do Sistema e tiver mais de um controlador de domínio, execute uma operação de restauração autorizada do grupo de roteamento removido.

Para restaurar o grupo de roteamento

  1. Inicie o Gerenciador de Sistema do Exchange e crie um novo grupo de roteamento que tenha o mesmo nome do que você removeu. Para fazer isso, siga essas etapas:

    1. Expanda Grupos Administrativos, AdministrativeGroupName e Grupos de Roteamento.

      Nesta etapa, AdministrativeGroupName é o nome do grupo administrativo.

    2. Clique com o botão direito em Grupos de Roteamento, aponte para Novo e clique em Grupo de Roteamento.

    3. Na caixa de diálogo Nome, digite o nome do grupo de roteamento e clique em OK.

      Use o mesmo nome usado para o grupo de roteamento removido acidentalmente.

    4. Saia do Gerenciador de Sistema do Exchange.

  2. Inicie o ADSI Edit. Para fazer isso, clique em Iniciar, Executar, digite adsiedit.msc na caixa de diálogo Abrir e clique em OK.

    Observação:
    A ferramenta ADSI Edit está incluída nas Ferramentas de Suporte do Microsoft Windows 2000 e nas Ferramentas de Suporte do Microsoft Windows Server 2003. Para instalar essas ferramentas de suporte:
    • Em computadores Windows 2000 Server, clique duas vezes em Setup.exe na pasta Suporte\Ferramentas do CD do Windows 2000 e siga as etapas do Assistente para Instalar as Ferramentas de Suporte do Windows para concluir a instalação das Ferramentas de Suporte do Windows 2000.

    • Em computadores baseados no Windows Server 2003, clique com o botão direito em Suptools.msi na pasta Suporte\Ferramentas no CD do Windows Server 2003, clique em Instalar,e siga as etapas no Assistente para Instalação das Ferramentas de Suporte do Windows para concluir a instalação das Ferramentas de Suporte do Windows Server 2003.

  3. Expanda Configuração [ servername.domain_name.com ], expanda CN=Configuração, DC=domain_name, DC=com, expanda CN=Serviços, CN=Microsoft Exchange, CN= OrganizationName, CN=Grupos Administrativos, CN=AdministrativeGroupName e clique em CN=Grupos de Roteamento.

    Nesta etapa, servername é o nome do servidor, domain_name.com é o nome do domínio, OrganizationName é o nome da organização do Exchange Server e AdministrativeGroupName é o nome do grupo administrativo.

  4. No painel direito, clique com o botão direito no novo grupo de roteamento criado e clique em Propriedades.

  5. Clique para marcar as caixas de seleção Mostrar atributos obrigatórios e Mostrar atributos opcionais, se elas estiverem desmarcadas.

  6. Na lista Atributos, clique em msExchRoutingGroupMembersBL e em Editar.

    A lista Valores está em branco.

  7. Clique em Cancelar.

  8. Na lista Atributos, clique duas vezes em distinguishedName.

  9. Clique com o botão direito no nome distinto, na caixa de diálogo Valor, e clique em Copiar.

  10. Inicie um editor de texto, como o Bloco de notas, e clique em Colar no menu Editar para colar o nome distinto.

  11. Na caixa de diálogo Editor de Atributo Cadeia de Caracteres, clique em Cancelar e feche a caixa de diálogo Cancelar para fechar a caixa de diálogo CN=RoutingGroupName.

    Nesta etapa, RoutingGroupName é o nome do grupo de roteamento.

  12. No ADSI Edit, em CN=AdministrativeGroupName, clique em CN=Servidores.

  13. No painel direito, clique com o botão direito em CN=ServerName e clique em Propriedades.

    Nesta etapa, ServerName é um dos computadores do Exchange nesse grupo de roteamento.

  14. Na lista Atributos, clique em msExchHomeRoutingGroup e em Editar.

  15. Na caixa de diálogo Valor, cole o nome distinto copiado nas etapas 9 e 10 e clique em OK.

  16. Clique em Aplicar e em OK.

  17. Repita as etapas de 13 a 15 para cada servidor que tiver sido membro do grupo de roteamento removido por acidente.

  18. Em CN=AdministrativeGroupName, clique em CN=Grupos de Roteamento.

  19. No painel direito, clique com o botão direito no novo grupo de roteamento criado e clique em Propriedades.

  20. Na lista Atributos, clique em msExchRoutingGroupMembersBL e em Editar.

    A lista Valores não está mais em branco.

  21. Clique em Cancelar duas vezes.

  22. Saia do ADSI Edit.

  23. Defina o mestre de grupo de roteamento usando o Gerenciador de Sistema do Exchange. Para fazer isso, siga essas etapas:

    1. Inicie o Gerenciador de Sistema do Exchange.

    2. Expanda Grupos Administrativos, AdministrativeGroupName e Grupos de Roteamento.

    3. Expanda o novo grupo de roteamento criado e clique em Membros.

    4. No painel direito, clique com o botão direito no computador do Exchange que você deseja configurar como mestre do grupo de roteamento e clique em Definir como Mestre.

    5. Saia do Gerenciador de Sistema do Exchange.

  24. Aguarde a propagação das alterações em todo o domínio.

  25. Inicie os serviços do Microsoft Exchange que foram parados.


MSExchangeIS 5000 (0x8004010f): Não é possível montar o banco de dados devido a permissões incorretas ou caracteres inválidos no nome da organização
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-23

A ferramenta Microsoft® Exchange Database Troubleshooter Tool detectou um ou mais eventos MSExchangeIS 5000 com código de erro 0x8004010f no log de Aplicativos. O evento indica que um banco de dados ou bancos de dados no servidor Exchange não podem ser montados por causa de permissões incorretas ou caracteres inválidos no nome da organização do Exchange.

Explicação

O evento MSExchangeIS 5000 com código de erro 0x8004010f pode ocorrer se uma das condições a seguir for verdadeira:

  • Os usuários autenticados não possuem acesso de leitura nos contêineres de Domínio ou Configuração do Active Directory. Quando essa condição for verdadeira, se você tentar instalar um segundo servidor Exchange em um grupo administrativo que já contenha um servidor Exchange, talvez não consiga instalar o segundo servidor. Além disso, o serviço de Armazenamento de Informações do Microsoft Exchange pode não ser iniciado.

  • A permissão de acesso de leitura para a conta Todos está ausente no contêiner Entidades de Segurança Conhecidas pertencente ao contêiner Configuração do Active Directory. Quando essa condição for verdadeira, o serviço de Armazenamento de Informações do Exchange não será iniciado em um servidor membro.

  • O nome da organização do Exchange contém caracteres inválidos. Quando essa condição for verdadeira, depois de instalar o Exchange 2000 Server ou o Exchange Server 2003, o serviço de Armazenamento de Informações do Exchange poderá não ser iniciado e você poderá notar que os eventos MSExchangeIS 5000 e MSExchangeIS 1121 estarão registrados no log de Aplicativos.

O evento pode também ser identificado como MAPI_E_NOT_FOUND. O evento se aplica às seguintes versões do servidor Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Ação do usuário

Para resolver o problema, execute um ou mais dos seguintes procedimentos.

Importante:
Se você usar o snap-in Active Directory Service Interfaces (ADSI) Edit, o utilitário LDP, ou qualquer outro cliente da versão 3 do LDAP, e modificar incorretamente os atributos de objetos do Active Directory, poderá causar sérios problemas. Esses problemas podem exigir que você reinstale o Microsoft Windows® 2000 Server, o Microsoft Windows Server™ 2003, o Microsoft Exchange 2000 Server, o Microsoft Exchange Server 2003, ou tanto o Windows como o Exchange. A Microsoft não pode garantir que problemas causados pela modificação incorreta de atributos de objetos do Active Directory possam ser resolvidos. Você é responsável pela modificação desses atributos.
  • Se usuários autenticados não possuírem acesso de leitura aos contêineres de Domínio ou Configuração do Active Directory, use a ferramenta ADSI Edit no Exchange Server 2003 e no Exchange 2000 Server para conceder a usuários autenticados o acesso de leitura no contêiner de Domínio e no contêiner de Configuração do Active Directory. Siga estas etapas:

    Observação:
    A ferramenta ADSI Edit está localizada nas Ferramentas de Suporte do Microsoft Windows 2000 e do Microsoft Windows Server 2003. Para instalar as Ferramentas de Suporte do Windows, execute a Instalação na pasta Suporte\Ferramentas do CD do Windows. Para obter mais informações sobre as Ferramentas de Suporte do Windows, consulte o arquivo Sreadme.doc na pasta Suporte\Ferramentas do CD do Windows.
Para conceder, a usuários autenticados, acesso aos contêineres de Domínio ou Configuração do Active Directory

  1. Clique em Iniciar, Executar, digite adsiedit.msc e clique em OK.

  2. Expanda o contêiner NC de Domínio, clique com botão direito na pasta do domínio (DC=domínio,DC=com), e clique em Propriedades para abrir as propriedades da pasta.

  3. Clique na guia Segurança e certifique-se de que o grupo Usuários Autenticados tenha acesso de Leitura selecionado na coluna Permissão. Se Leitura não estiver selecionado, clique para selecionar Leitura e clique em OK.

  4. Expanda o Contêiner de Configuração, clique com o botão direito na pasta para configuração (CN=Configuração,DC=domínio,DC=com) e clique em Propriedades para abrir as propriedades da pasta.

  5. Clique na guia Segurança e certifique-se de que o grupo Usuários Autenticados tenha acesso de Leitura selecionado na coluna Permissão. Se Leitura não estiver selecionado, clique para selecionar Leitura e clique em OK.

  6. Saia do ADSI Edit.

  7. Aguarde um momento para que a alteração se replique entre os controladores de domínio.

  8. Inicie o serviço de Armazenamento de Informações.
  • Se a permissão de acesso de leitura para a conta Todos estiver ausente do contêiner Entidades de Segurança Conhecidas pertencente ao contêiner Configuração do Active Directory, siga as seguintes etapas para resolver o problema.

Para conceder a permissão de acesso de leitura à conta Todos no contêiner Entidades de Segurança Conhecidas do Active Directory

  1. Efetue logon como administrador do domínio e inicie a ferramenta ADSI Edit.

  2. Expanda o contêiner Configuração e clique no contêiner CN=Entidades de Segurança Conhecidas.

  3. Clique com o botão direito em Propriedades e localize a guia Segurança.

  4. Clique em Adicionar, digite todos e clique em OK.

  5. Na coluna Permitir, clique para marcar a caixa de seleção Leitura.
  • Se houver caracteres inválidos no nome da organização do Exchange, remova-os. Para obter mais informações sobre quais caracteres são inválidos, consulte o artigo 329599 da Base de Dados de Conhecimento Microsoft, O armazenamento de informações do Exchange não é iniciado e os eventos 1121 e 5000 estão registrados.


MSExchangeIS 9518 (0xfffffddc): Foi excedido o número máximo de logs de transações disponíveis para esse grupo de armazenamento
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-22

A ferramenta Microsoft® Exchange Server Database Troubleshooter Tool detectou um ou mais eventos MSExchangeIS 9518 com código de erro 0xfffffddc no log de Aplicativos. Isso indica que o número máximo de logs de transações disponíveis para esse grupo de armazenamento foi excedido.

Explicação

Um evento MSExchangeIS 9518 com código de erro 0xfffffddc é registrado quando ele tenta montar os bancos de dados de um grupo de armazenamento e ambas as condições a seguir forem verdadeiras:

  • O número máximo de logs de transações disponíveis para esse grupo de armazenamento foi excedido.

  • Todos os bancos de dados nesse grupo de armazenamento estão em um estado de Desligamento Normal

Além disso, o evento MSExchangeIS 1159 com código de erro 0xfffffdf9 deve ser registrado no log de Aplicativos antes de os bancos de dados afetados serem encerrados. Esse evento identifica que o Exchange Server usou todos arquivos de log de transações disponíveis para esse grupo de armazenamento. Quando o último log de transações estiver preenchido, todos os bancos de dados desse grupo de armazenamento serão desmontados e não poderão ser reiniciados.

O Exchange usa arquivos de log de transações que são numerados em seqüência. No Exchange 2000 Server e no Exchange Server 2003, os arquivos de log de transações começam com Exx00001.log e são incrementados em seqüência para ExxFFFF0.log. O número máximo de arquivos de log de transações que podem ser gerados em uma única seqüência é 1.048.560 (0xFFFF0). Normalmente, levará anos de operação para que todos esses arquivos de log sejam gerados.

No Exchange Server 2007, os arquivos de log de transações são maiores. Podem existir até 2.147.483.647 arquivos de log (0x7FFFFFFF em notação hexadecimal, porque os nomes de arquivos de log são expressos em hexadecimal) em um fluxo de log. Cada arquivo de log de transações tem 1 MB (megabyte). É muito provável que esse erro não ocorra no Exchange Server 2007.

Ação do usuário

Para resolver esse erro, você deve remover todos os arquivos de log de transações e reiniciar a seqüência de arquivos de log de transações para 1. Depois de reiniciar a seqüência, o nome do arquivo de log é Exx00001.log no Exchange Server 2003 ou versões anteriores e Exx00000001.log no Exchange Server 2007.

Use a tarefa Redefinir número de geração de log na ferramenta Gerenciamento de Recuperação de Banco de Dados, que é parte do Assistente para Solução de Problemas do Microsoft Exchange, para executar essa operação. A ferramenta verificará se todos os bancos de dados foram encerrados corretamente e, então, moverá com segurança todos os arquivos de log de transações para um local de backup.

Observação:
Os arquivos de log de transações também podem ser removidos manualmente, mas a remoção manual poderá fazer com que um banco de dados do grupo de armazenamento não seja encerrado corretamente e não seja montável novamente. Para evitar essas falhas, é recomendável que você utilize a ferramenta Gerenciamento de Recuperação de Banco de Dados.

Para obter mais informações e fazer download da ferramenta, consulte Assistente para Solução de problemas do Microsoft Exchange v1.0 (em inglês) .


MSExchangeIS 9518 0xfffffbc4: Caminho do arquivo de log já está em uso
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-05-14

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft Exchange detectou um ou mais eventos MSExchangeIS 9518 com código de erro 0xfffffbc4 no log de Aplicativos. Esse código de erro indica que um ou mais Grupos de Armazenamento estão configurados para usar o mesmo caminho de arquivos de Log ou de Sistema.

Explicação

Esse erro poderá ocorrer se vários Grupos de Armazenamento tiverem sido configurados para usar o mesmo caminho de arquivos de Log ou de Sistema. O Exchange exige que cada Grupo de Armazenamento tenha um caminho exclusivo para arquivos de log e de sistema.

Ação do usuário

Para resolver esse problema, verifique se cada Grupo de Armazenamento está configurado com um caminho exclusivo de arquivos de Log e de Sistema.

Observação:
Um Grupo de Armazenamento específico pode compartilhar o mesmo caminho de arquivos de Log e de Sistema. Porém, esse mesmo caminho não pode ser usado como um caminho de arquivos de Log ou de Sistema para outro Grupo de Armazenamento.
Para verificar ou definir o caminho de arquivos de Log e de Sistema no Exchange 2000 Server ou Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda os Grupos Administrativos, expanda seu grupo administrativo, expanda Servidores, clique com o botão direito em seu grupo de armazenamento e clique em Propriedades.

  3. Na guia Geral, em Local de log de transações, clique em Procurar.

  4. Verifique se o Caminho de arquivos de Log e o Caminho de arquivos de Sistema são exclusivos para o Grupo de Armazenamento.

  5. Se o Caminho de arquivos de Log e o Caminho de arquivos de Sistema não forem exclusivos para o Grupo de Armazenamento, digite o caminho do novo local dos arquivos de log e de sistema e clique em OK.

  6. Clique em OK.
Para verificar ou definir o caminho de arquivos de Log e de Sistema para um Grupo de Armazenamento do Exchange Server 2007

  1. Abra o Console de Gerenciamento do Exchange.

  2. Expanda Configuração do Servidor e realce Caixa de Correio.

  3. No painel Caixa de Correio, selecione o servidor com o qual deseja trabalhar.

  4. No painel Gerenciamento do Banco de Dados, clique com o botão direito no Grupo de Armazenamento com o qual você deseja trabalhar e selecione Propriedades.

  5. Verifique se o Caminho de arquivos de Log e o Caminho de arquivos de Sistema são exclusivos para o Grupo de Armazenamento.

  6. Se o Caminho de arquivos de Log e o Caminho de arquivos de Sistema não forem exclusivos para o Grupo de Armazenamento, siga a orientação na documentação do Exchange Server 2007, "Como definir ou alterar o local de arquivos de log do grupo de armazenamento" (http://go.microsoft.com/fwlink/?LinkId=80702) para definir um local exclusivo para os caminhos de arquivos de cada Grupo de Armazenamento.

Para obter mais informações sobre como mover arquivos de log no Exchange Server 2003, consulte o artigo 821915 da Base de Dados de Conhecimento Microsoft, "Como mover bancos de dados e logs do Exchange no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915).

Para obter mais informações sobre como mover arquivos de log no Exchange 2000 Server, consulte o artigo 239944 da Base de Dados de Conhecimento Microsoft, "XADM: Como mover os logs de transações ou do sistema para outro local" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944).


MSExchangeIS 9518 (0xfffff745): Não É Possível Criar ou Acessar Arquivos TMP
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-23

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft® Exchange detectou um ou mais eventos MSExchangeIS 9518 com código de erro 0xfffff745 no log de Aplicativos. Esse erro ocorre se o Exchange não conseguir criar ou acessar arquivos nas pastas especificadas nas variáveis de ambiente de sistema TMP ou TEMP.

Explicação

Esse problema pode ser causado se alguma das seguintes condições for verdadeira:

  • O caminho para o qual a variável de ambiente TMP ou TEMP aponta está indisponível ou é somente leitura. Por exemplo, esse problema ocorre se a variável de ambiente TMP estiver mapeada para uma unidade remota ou para uma rede de armazenamento (SAN) e essa unidade mapeada ou SAN não estiver mais disponível.

  • A variável de ambiente TMP ou TEMP tem uma definição de registro incorreta.

  • O Exchange não tem permissões de controle total da raiz da unidade até os logs de transações e bancos de dados.

Ação do usuário

Para resolver esse problema, você pode executar um ou mais dos seguintes procedimentos:

Nota Pelo fato de haver diversas versões do Microsoft Windows, as etapas a seguir poderão ser diferentes em seu computador. Se forem, consulte a documentação do produto para concluí-las.

  • Verifique se as duas variáveis de ambiente, TMP e TEMP, apontam para um local válido no Windows. Para fazer isso, siga essas etapas:

    Para definir um caminho válido para as variáveis Temp e TMP

    1. Clique em Iniciar, Configurações e Painel de Controle.

    2. Clique duas vezes em Sistema, clique na guia Avançado e, em seguida, clique em Variáveis de Ambiente.

    3. Em Variáveis do sistema, clique em TEMP e depois clique em Editar.

    4. Se um caminho válido não for exibido na caixa de diálogo Valor da Variável, digite um caminho válido para a variável TEMP e, em seguida, clique em OK. Por exemplo, digite %systemroot%\Temp e clique em OK.

    5. Em Variáveis do sistema, clique em TMP e depois clique em Editar.

    6. Se um caminho válido não for exibido na caixa de diálogo Valor da Variável, digite um caminho válido para a variável TMP e, em seguida, clique em OK. Por exemplo, digite %systemroot%\Temp e clique em OK.

    7. Clique em OK duas vezes para fechar a caixa de diálogo Propriedades do Sistema.

    8. Reinicie o computador.
  • Verifique e atribua as permissões de Controle Total do grupo Administradores local ou da conta SYSTEM à pasta Temp. Não basta atribuir permissões de Controle Total ao grupo Administradores de Domínio. Por padrão, o seguinte caminho é especificado para as duas variáveis de ambiente do sistema, TMP e TEMP:

    %SYSTEMROOT%\Temp

    O Exchange deve acessar o local dessa pasta usando a conta SYSTEM. Para exibir essas permissões, siga estas etapas:

    Para verificar as permissões para a pasta Temp

    1. Clique com o botão direito do mouse em Iniciar e, em seguida, clique em Explorar.

    2. Clique com o botão direito na pasta Temp, especificada na variável de ambiente do sistema, e, em seguida, clique em Propriedades. Normalmente, será %systemroot%\Temp.

    3. Clique na guia Segurança.

    4. Na lista Nome, clique em SYSTEM e exiba as permissões atribuídas que aparecem na lista Permissões.
    Se as permissões para a pasta Temp estiverem corretas, verifique as permissões em cada unidade que contém os arquivos de log e de banco de dados do Exchange. A conta SYSTEM deve ter permissões de Controle Total na raiz da unidade e em cada pasta que contém arquivos de banco de dados ou arquivos de log de transações do Exchange. Por exemplo, se você tiver logs de transação na pasta C:\Exchsrvr\Mdbdata, a conta SYSTEM deverá ter permissões de Controle Total para o diretório raiz da unidade C e para as pastas Exchsrvr e Mdbdata.

  • Verifique se o problema é causado por configurações de registro incorretas. Siga estas etapas:

    Para verificar as configurações do Registro

    1. Clique em Iniciar, Executar, digite Regedt32.exe e clique em OK.

    2. Localize a seguinte chave do Registro:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

    3. Localize o nome TMP (ou TEMP). Essa chave deverá ser do tipo REG_EXPAND_SZ.

    4. Se alguma chave estiver incorreta, faça backup da subchave Ambiente e, em seguida, exclua o valor TMP ou TEMP à direita.

    5. Clique em Iniciar, Executar, digite Sysdm.cpl e, em seguida, clique em OK.

    6. Na guia Avançado, clique em Variáveis de Ambiente.

    7. Na lista Variáveis do sistema, verifique se os valores excluídos na etapa 4 não estão presentes na lista.

      Observação:
      Talvez você tenha de rolar a tela para baixo para ver as variáveis TEMP ou TMP.

    8. Clique em Novo. Na caixa de diálogo Nome da Variável, digite os nomes excluídos na etapa 4. Por exemplo, digite C:\Winnt\TEMP.

    9. Clique em OK três vezes e, em seguida, reinicie o computador.


MSExchangeIS 9518 (0xfffffd9a): Arquivo de Ponto de Verificação Ausente e Mais de 1.008 Arquivos de Log de Transações Existentes
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-23

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft® Exchange detectou um ou mais eventos MSExchangeIS 9518 com código de erro 0xfffffd9a no log de Aplicativos. Esse erro indica que o arquivo de ponto de verificação (Exx.chk) desse grupo de armazenamento está ausente ou foi excluído e há mais de 1.008 arquivos de log de transações a serem reproduzidos no banco de dados.

Explicação

Esse problema pode ocorrer se as condições a seguir forem verdadeiras:

  • Os arquivos de log e os bancos de dados são encerrados corretamente. Portanto, não há falha da qual se recuperar.

  • Você renomeia ou exclui o arquivo de ponto de verificação Exx.chk.

  • Há mais de 1.008 arquivos de log entre os pontos de verificação a serem reproduzidos no servidor.

  • Em uma recuperação com "rolagem para frente", um ou mais bancos de dados no grupo de armazenamento são perdidos, mas os arquivos de log permanecem intactos no servidor no momento da recuperação. A operação de recuperação com "rolagem para frente" não é concluída com êxito.

Nesse caso, o serviço de Armazenamento de Informações do Microsoft Exchange executa uma recuperação simples e reproduz todos os arquivos de log durante a inicialização. Como os arquivos de log e o banco de dados foram encerrados corretamente, não há recuperação a ser executada. Por não haver ponto de verificação, o Exchange processa todos os logs até atingir um registro de desligamento normal. Como há mais de 1.008 arquivos de log, o Exchange atinge o limite de 1.008 arquivos de log antes de poder localizar o registro de um estado de Desligamento Normal.

Observação:
Os sintomas descritos poderão ocorrer também se as condições listadas anteriormente forem verdadeiras e você reproduzir os arquivos de log usando o comando eseutil /r. O comando eseutil /r também executa uma recuperação simples no armazenamento de caixas de correio.

O erro também pode ser identificado como JET_errCheckpointDepthTooDeep, -614. Esse erro se aplica apenas ao Microsoft Exchange Server 2003.

Ação do usuário

Para resolver esse problema no Exchange Server 2003, aplique o hotfix indicado no artigo 836611 da Base de Dados de Conhecimento da Microsoft, Os bancos de dados de Armazenamento de Informações não são montados e você recebe uma mensagem de erro "Operação finalizada com erro -614" quando você inicia um computador que está executando o Exchange Server 2003 (em inglês).


MSExchangeIS 9518 0xfffffb40: Arquivo de banco de dados ausente
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-05-23

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft Exchange detectou um ou mais eventos MSExchangeIS 9518 com código de erro 0xfffffb40 no log de Aplicativos. Isso indica que um ou mais arquivos de banco de dados para o Grupo de Armazenamento estão faltando.

Explicação

Esse erro pode ocorrer quando o ESE (Mecanismo de Armazenamento Extensível) tenta colocar todos os bancos de dados de um grupo de armazenamento em um estado consistente durante a recuperação, mas detecta que esses arquivos de banco de dados estão faltando ou foram substituídos por versões diferentes.

Se algum arquivo de banco de dados do Grupo de Armazenamento estiver faltando ou tiver sido substituído por versões diferentes, o ESE retornará o erro -1216, interromperá a recuperação e não iniciará o grupo de armazenamento.

Ação do usuário

Para resolver esse problema, execute um ou mais dos seguintes procedimentos:

  • Método um: Se o arquivo de banco de dados ausente tiver sido movido ou renomeado, localize quaisquer eventos ESE 494 no log de aplicativos que ocorreram depois que se tentou montar o banco de dados. Para cada evento, anote o arquivo de banco de dados específico relatado como ausente, encontre o local atual do arquivo e mova-o para o local adequado.

Observação:
Se o software antivírus de nível de arquivo estiver instalado nesse servidor e as exclusões não tiverem sido configuradas corretamente, será possível que o banco de dados tenha sido excluído ou colocado em quarentena pelo software antivírus. Verifique o log de exclusão e quarentena do antivírus para ver se isso ocorreu.
  • Método dois:

    • Método dois A: Se o arquivo de banco de dados ausente tiver sido excluído ou perdido, restaure o arquivo a partir de um backup para o grupo de armazenamento de produção. Você pode usar a tarefa Verificar arquivos de log de bancos de dados e de transações das ferramentas de Gerenciamento de Recuperação de Banco de Dados do Exchange para verificar se o arquivo de banco de dados restaurado está disponível para executar uma restauração.

      Enquanto você está restaurando esse arquivo de banco de dados, também pode montar e acessar os outros bancos de dados não afetados no grupo de armazenamento concluindo as etapas a seguir:

Para permitir o acesso da caixa de correio do usuário a bancos de dados não afetados

  1. Execute eseutil /R /L <Caminho para Arquivos de Log> /S <Path to System Files> Log Base Name /I (em que o Nome Base do Log são os três primeiros caracteres dos arquivos de log para esse grupo de armazenamento, isto é, E00, E01, etc.). Isso permite que o ESE coloque os arquivos de banco de dados em um estado consistente enquanto ignora os arquivos de banco de dados ausentes. Depois de executar esse comando, será necessário restaurar do backup todos os arquivos de banco de dados ausentes.
Observação:
As opções /L e /S são opcionais e não precisarão ser usadas se o eseutil estiver sendo executado do mesmo local que os arquivos de log e de sistema.
  1. Monte os arquivos de banco de dados no grupo de armazenamento que agora estejam presentes e sejam consistentes.

  2. Os usuários com caixas de correio hospedadas pelo banco de dados montado atualmente agora podem acessar suas mensagens.
  • Método dois B: Restaure o arquivo de banco de dados do backup para um Grupo de Armazenamento de Recuperação. Você pode fornecer a funcionalidade de envio/recebimento imediatamente, começando com um novo banco de dados o mais rápido possível (conhecido como recuperação de sinal de linha). Os clientes vêem uma caixa de correio vazia, mas eles têm a capacidade de enviar e receber mais rapidamente do que se precisassem aguardar a conclusão da restauração ou da correção.

Observação:
A opção de sinal de linha exigirá a eventual mesclagem de qualquer novo dado (após o sinal de linha) com os dados restaurados.

Para obter mais informações sobre a recuperação de sinal de linha, consulte "Portabilidade de Sinal de Linha" () no tópico Recuperação de Desastres da documentação do produto Exchange 2007.

Para obter mais informações sobre os Grupos de Armazenamento de Recuperação, consulte "Compreendendo os grupos de armazenamento de recuperação" () no tópico Recuperação de Desastres na documentação do produto Exchange 2007.
  • Método três: Se um reparo permanente tiver sido executado, manualmente ou a partir da tarefa Reparar Banco de Dados do Assistente para Solução de Problemas do Exchange, em relação a um ou mais bancos de dados no Grupo de Armazenamento e os bancos de dados estiverem em um estado consistente, talvez os arquivos de log para o Grupo de Armazenamento não tenham sido removidos. Se todos os bancos de dados do Grupo de Armazenamento estiverem em seus locais corretos, verifique se todos os bancos de dados estão em estado consistente executando o comando a seguir.

Para verificar manualmente o estado de consistência do arquivo de banco de dados:

  1. Execute eseutil /mh <path to database .edb file>

  2. Na saída desse comando, procure o campo Estado: e verifique se seu valor é Desligamento Normal.

  3. Se todos os bancos de dados do Grupo de Armazenamento estiverem em um estado Desligamento Normal, mova todos os logs de transação e de sistema do Grupo de Armazenamento para um local de backup e tente montar o armazenamento. Se você conseguir montar todos os bancos de dados corretamente, recomendamos que faça um backup do Grupo de Armazenamento imediatamente.

Para obter mais informações

Para obter mais informações sobre o evento MSExchangeIS 9518 com código de erro 0xfffffb40, consulte "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=91705) (em inglês).

Para obter mais informações sobre a recuperação desse erro, consulte o artigo 296843 da Base de Dados de Conhecimento Microsoft, "Como recuperar um banco de dados do Exchange 2000 Server após o erro -1216" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296843).

Para obter mais informações sobre o Planejamento de Recuperação de Desastres do Exchange, consulte "Um guia para o Planejamento de Recuperação de Desastres do Exchange" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=91706).

Para obter mais informações sobre os assistentes de gerenciamento de recuperação de banco de dados e do solucionador de problemas do banco de dados, consulte "Ferramenta de Gerenciamento de Recuperação de Banco de Dados e Solucionador de Problemas de Bancos de Dados" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=91707).

Para obter mais informações sobre a recuperação de sinal de linha, consulte "Portabilidade de Sinal de Linha" (http://go.microsoft.com/fwlink/?LinkId=91703) no tópico Recuperação de Desastres da documentação do produto Exchange 2007.

Para obter mais informações sobre os Grupos de Armazenamento de Recuperação, consulte "Compreendendo os grupos de armazenamento de recuperação" (http://go.microsoft.com/fwlink/?LinkID=80784) no tópico Recuperação de Desastres da documentação do produto Exchange 2007.


MSExchangeIS 9518 (0xfffffea8): Incompatibilidade do Carimbo de Hora do Banco de Dados no Arquivo de Banco de Dados
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-23

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft® Exchange detectou um ou mais eventos MSExchangeIS 9518 com código de erro 0xfffffea8 no log de Aplicativos. Esse erro ocorre se o dbtime na página atual do banco de dados afetado for maior que o dbtime global do banco de dados.

Explicação

Quando esse erro ocorre, a caixa de correio ou os bancos de dados de pasta pública afetados não são montados. O erro também é identificado como JET_errDbTimeCorrupted.

O erro se aplica às seguintes versões do servidor Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Ação do usuário

Para resolver a incompatibilidade do carimbo de hora do banco de dados, execute o comando eseutil /d para desfragmentar o banco de dados que está com esse problema; em seguida, monte o banco de dados. Para obter mais informações sobre como executar o eseutil /d, consulte Como Executar o Eseutil /D (Desfragmentação). Além disso, consulte o artigo 328804 da Base de Dados de Conhecimento da Microsoft, Como desfragmentar os bancos de dados do Exchange (em inglês).


MSExchangeIS 9518 (0xfffff764): Arquivo de Streaming Ausente ou Inacessível
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-23

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft® Exchange detectou um ou mais eventos MSExchangeIS 9518 com código de erro 0xfffff764 no log de Aplicativos. Esse erro pode ocorrer se o Exchange não conseguir acessar o arquivo de streaming (.stm) associado a um banco de dados.

Explicação

Esse erro pode ocorrer se o arquivo de streaming (.stm) associado a um banco de dados tiver sido excluído, movido ou não puder ser acessado pelo Exchange devido a uma alteração nas permissões.

Observação:
Em alguns casos, programas antivírus poderão excluir ou alterar as permissões nos arquivos do Exchange, incluindo o arquivo .stm, se você não tiver excluído os diretórios do Exchange da verificação, de acordo com as práticas recomendadas do Microsoft Exchange. Para obter mais informações sobre esse tópico, consulte o artigo 823166 da Base de Dados de Conhecimento da Microsoft, Visão geral do Exchange Server 2003 e software antivírus (em inglês).

Esse erro, que também pode ser identificado como -2204, se aplica às seguintes versões do servidor Exchange:

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Ação do usuário

Para resolver esse problema, execute um ou mais dos seguintes procedimentos:

  • Restaure o arquivo de streaming a partir de uma cópia de backup do banco de dados.

  • Verifique se o seu software antivírus moveu o arquivo de streaming para a pasta Quarentena. Se o arquivo estiver na pasta Quarentena, coloque-o novamente no local original e, em seguida, configure o programa antivírus para não verificar as pastas do Exchange Server 2003.

    Observação:
    Alguns programas antivírus alteram as propriedades de arquivo para Somente leitura quando os arquivos são movidos para a pasta Quarentena. Se você encontrar o arquivo de streaming na pasta Quarentena, clique nele com o botão direito e, em seguida, clique em Propriedades. Clique para desmarcar a caixa de seleção Somente leitura antes de tentar montar o banco de dados.
  • Você pode executar a Ferramenta de Gerenciamento de Recuperação de Banco de Dados do Microsoft Exchange que faz parte do Assistente para Solução de Problemas do Microsoft Exchange. A Ferramenta de Gerenciamento de Recuperação de Banco de Dados pode analisar os arquivos de log de transações e banco de dados relativos a esse grupo de armazenamento e oferecer detalhes adicionais sobre o problema. Para obter mais informações e fazer download da ferramenta, consulte Assistente para Solução de problemas do Microsoft Exchange v1.0 (em inglês) .


MSExchangeIS 9518 (0xfffffbf8): Permissões necessárias ausentes na unidade ou na pasta de banco de dados do Exchange
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-03-15

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft Exchange detectou um ou mais eventos MSExchangeIS 9518 com código de erro 0xfffffbf8 no log de Aplicativos. Isso indica que a pasta ou a unidade que contém os bancos de dados do Exchange não tem as permissões adequadas.

Explicação

Esse erro indica que a pasta ou a unidade que hospeda os arquivos de banco de dados do Exchange não tem as permissões necessárias para a execução das funções mínimas. Você pode ter dificuldades para acessar ou montar os armazenamentos de caixa de correio ou de pasta pública.

Ação do usuário

Para resolver o problema, conceda as permissões padrão à pasta que contém os bancos de dados do Exchange e à unidade em que essa pasta reside.

Para conceder as permissões padrão à pasta que contém os bancos de dados do Exchange no Exchange 2007

  1. Inicie o Windows Explorer e navegue para a pasta que contém os bancos de dados do Exchange. Por padrão, o caminho é C:\Arquivos de Programas\Microsoft\Exchange\Mailbox\Nome do Grupo de Armazenamento\

  2. Clique com o botão direito na pasta e, em seguida, clique em Propriedades.

  3. Clique na guia Segurança e conceda as seguintes permissões padrão

Conta | Permissões
Administradores | Controle Total
Sistema | Controle Total
 Para conceder as permissões padrão à unidade que contém os bancos de dados do Exchange no Exchange 2007

  1. Inicie o Windows Explorer.

  2. Clique com o botão direito no objeto Disco Local que contém a pasta de banco de dados do Exchange e, em seguida, clique em Propriedades.

  3. Selecione a guia Segurança e conceda as seguintes permissões padrão, dependendo do sistema operacional instalado:

Para o Windows 2000 Server:

Conta | Permissões
Todos | Controle Total

Para o Windows Server 2003:

Conta | Permissões
Administradores | Controle Total
Proprietário Criador | Nenhum
Todos | Nenhum
Sistema | Controle Total
Usuários | Ler e Executar, Listar Conteúdo da Pasta, Ler
 Para conceder as permissões padrão à pasta Mdbdata do Exchange 2000 Server e do Exchange Server 2003

  1. Inicie o Windows Explorer, navegue para Exchsvr e expanda essa pasta.

  2. Clique com o botão direito na pasta Mdbdata e, em seguida, clique em Propriedades.

  3. Clique na guia Segurança e conceda as seguintes permissões padrão:

Conta | Permissões
Administradores | Controle Total
Usuários Autenticados | Ler e Executar, Listar Conteúdo da Pasta, Ler
Proprietário Criador | Nenhum
Operadores do Servidor | Modificar, Ler e Executar, Listar Conteúdo da Pasta, Ler, Gravar
Sistema | Controle Total
 Para conceder as permissões padrão à unidade que contém a pasta Mdbdata no Exchange 2000 Server e no Exchange Server 2003

  1. Inicie o Windows Explorer.

  2. Clique com o botão direito no objeto Disco Local que contém a pasta Mdbdata e, em seguida, clique em Propriedades.

  3. Selecione a guia Segurança e conceda as seguintes permissões padrão, dependendo do sistema operacional instalado:

Para o Windows 2000 Server:

Conta | Permissões
Todos | Controle Total

Para o Windows Server 2003:

Conta | Permissões
Administradores | Controle Total
Proprietário Criador | Nenhum
Todos | Nenhum
Sistema | Controle Total
Usuários | Ler e Executar, Listar Conteúdo da Pasta, Ler

Para obter mais informações

Para obter mais informações sobre esse problema, consulte o artigo 823022 da Base de Dados de Conhecimento Microsoft, "A Identificação do Evento 490 está registrada em log e você recebe a seguinte mensagem de erro ao tentar montar o armazenamento de caixa de correio ou o armazenamento público no Exchange Server: "ID No: c1041724"" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823022).


MSExchangeIS 9518 (0xfffff743): excesso de arquivos temporários
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-03-14

A ferramenta Solução de Problemas do Banco de Dados do Microsoft Exchange detectou um ou mais eventos MSExchangeIS 9518 com o código de erro 0xfffff743 no log de Aplicativos. Isso indica que o namespace de arquivo temporário de um servidor se esgotou ou que não há espaço disponível para gravação na pasta temporária.

Explicação

O Exchange 2000 Server e o Exchange Server 2003 criam arquivos temporários na pasta Temp quando um objeto grande, como uma mensagem ou um arquivo, é transmitido para o armazenamento e o arquivo .stm está muito fragmentado para que o objeto inteiro seja gravado nele.

Durante a operação normal, quando os serviços do Exchange são interrompidos, esses arquivos são removidos da pasta Temp. Se o servidor Exchange for desligado inesperadamente ou se os serviços do Exchange forem encerrados repentinamente, esses arquivos não serão removidos. Quando os serviços do Exchange forem reiniciados posteriormente, novos arquivos temporários serão criados. Isso resultará na redução do desempenho. Quando o namespace de 64.000 arquivos temporários for esgotado, os serviços do Exchange não poderão ser iniciados e os 9.518 eventos com o código de erro 0xfffff743 serão registrados no log de Aplicativos de Visualizar Eventos.

Ação do usuário

Para resolver o problema, proceda da seguinte forma:

  • Verifique se há arquivos lb*.tmp na pasta Temp do Windows. Se esses arquivos existirem, siga as etapas no procedimento abaixo para removê-los.

  • Verifique se há espaço livre em disco na unidade que hospeda a pasta Temp. Se não houver espaço livre em disco, utilize o procedimento a seguir para mover as pastas Temp e Tmp para outra unidade.

Para remover os arquivos lb*.tmp da pasta Temp do Windows

  1. Clique em Iniciar, selecione Programas, selecione Ferramentas Administrativas e clique em Serviços.

  2. Role para baixo até Armazenamento de Informações do Microsoft Exchange.

  3. Se o status do serviço for Started, clique com o botão direito no serviço e, em seguida, clique em Parar.
Observação:
Todos os usuários serão desconectados de suas caixas de correio.
  1. Navegue até a pasta %windir%\temp, onde %windir% é a pasta raiz do sistema Windows, por padrão, C:\Windows\Temp.

  2. Exclua todos os arquivos lb*.tmp.

  3. No console de gerenciamento Serviços, clique com o botão direito em Armazenamento de Informações do Microsoft Exchange e, em seguida, clique em Iniciar.

 Para mover as pastas Temp e Tmp para outra unidade

  1. No computador com o Exchange Server, clique em Iniciar, clique em Painel de Controle e, em seguida, clique duas vezes em Sistema.

  2. Clique na guia Avançado e em Variáveis de Ambiente.

  3. Em Variáveis do Sistema, clique na linha que inclui a variável TEMP e a unidade, clique em Editar e digite o novo local da unidade.

  4. Em Variáveis do Sistema, clique na linha que inclui a variável TMP e a unidade, clique em Editar e digite o novo local da unidade.
Observação:
Verifique se a alteração foi aplicada às Variáveis do Sistema e não às Variáveis de Usuário.
Observação:
Se os procedimentos descritos aqui não resolverem o problema, consulte as informações contidas no artigo 307242 da Base de Dados de Conhecimento Microsoft, "Armazenamento de informações não é montado com os erros 0xfffff745 e -2235" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242).

Para obter mais informações

Para obter mais informações sobre esse problema, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 294462, "Arquivos lb*.tmp do Exchange na pasta Temp do Windows causam o erro -2237 do ESE" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294462)

  • 307242, "Armazenamento de informações não é montado com os erros 0xfffff745 e -2235" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242)


MSExchangeIS 9519 (0xfffffb3a): Vários Bancos de Dados Detectados com a Mesma Assinatura em Uso
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-23

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft® Exchange detectou um ou mais eventos MSExchangeIS 9519 com código de erro 0xfffffb3a no log de Aplicativos. Esse erro indica que outra cópia do mesmo banco de dados já está em execução.

Explicação

Cada banco de dados do Exchange tem sua própria assinatura exclusiva. Se o serviço de Armazenamento de Informações do Microsoft Exchange detectar vários bancos de dados com a mesma assinatura, ele impedirá a montagem do banco de dados duplicado.

Esse evento também pode ser identificado como erro -1222, JET_errDatabaseSignInUse.

Ação do usuário

Você pode verificar se duas cópias do mesmo banco de dados estão presentes em um único grupo de armazenamento seguindo estas etapas:

  1. Desmonte todos os outros bancos de dados do grupo de armazenamento e tente montar aquele que causou essa mensagem de erro.

  2. Se o banco de dados puder ser montado, tente montar em seguida todos os demais do grupo de armazenamento.

  3. Se outro banco de dados contido no grupo de armazenamento apresentar o mesmo erro no log de Aplicativos, isso significará que dois bancos de dados possuem a mesma assinatura; portanto, são cópias do mesmo banco de dados.

Para resolver esse problema, certifique-se de que apenas uma cópia do banco de dados esteja presente nesse grupo de armazenamento específico.


MSExchangeIS 9519 (0xfffffe07): Não é possível montar o banco de dados devido à execução do processo de backup
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-02-27

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft® Exchange detectou um ou mais eventos 9519 do MSExchangeIS com código de erro 0xfffffe07 no log de aplicativos. Esse erro indica que o banco de dados especificado não pôde ser montado devido a um processo de backup em execução.

Explicação

Esse erro poderá ocorrer se o grupo de armazenamento ao qual esse banco de dados pertence tiver muitos bancos de dados, seja de caixa de correio ou de pasta pública, e se estiver sendo feito o backup de um desses bancos de dados no momento em que você tentar montar esse banco de dados. Esse comportamento é devido ao design. Não é possível montar um banco de dados em um grupo de armazenamento enquanto você estiver fazendo backup de outro banco de dados no mesmo grupo de armazenamento.

Esse erro também pode ser identificado como erro -505, JET_errBackupInProgress.

Ação do usuário

Certifique-se de que não está sendo realizado o backup de nenhum outro banco de dados no grupo de armazenamento e tente montar o banco de dados. Como alternativa, aguarde a conclusão do backup do outro banco de dados no grupo de armazenamento antes de tentar montar o banco de dados.


MSExchangeIS 9519 (0x3f3): Desmarque a Caixa de Seleção "Este banco de dados pode ser substituído por uma restauração" Após a Restauração
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-23

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft® Exchange detectou um ou mais eventos MSExchangeIS 9519 com código de erro 0x3f3 no log de Aplicativos. Esse erro indica que uma restauração foi executada no banco de dados sem que a caixa de seleção "Este banco de dados pode ser substituído por uma restauração" estivesse marcada.

Explicação

Esse evento ocorre quando uma operação de restauração de banco de dados foi realizada e o Exchange detecta que a caixa de seleção "Este banco de dados pode ser substituído por uma restauração" nas propriedades do armazenamento não estava marcada.

Ação do usuário

Para resolver esse problema, certifique-se de que o banco de dados possa ser substituído por uma restauração executando as seguintes ações.

Para habilitar a opção no Exchange Server 2003 e no Exchange 2000 Server

  1. Inicie o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos (se aplicável)

  3. Expanda Servidores, <Nome do Servidor>, <Grupo de Armazenamento> e, em seguida, clique no banco de dados que foi restaurado.

  4. Clique com o botão direito do mouse no banco de dados e clique em Propriedades.

  5. Clique na guia Banco de Dados.

  6. Clique para marcar a caixa de seleção Este banco de dados pode ser substituído por uma restauração.

  7. Clique em OK.

  8. Para montar o banco de dados, clique com o botão direito no banco de dados e, em seguida, clique em Montar Armazenamento.
Para habilitar a opção no Exchange Server 2007

  1. Inicie o Console de Gerenciamento do Exchange

  2. Em Configuração do Servidor, selecione Caixa de Correio

  3. No painel Gerenciamento de Banco de Dados, clique com o botão direito no banco de dados que foi restaurado.

  4. Clique em Propriedades

  5. Selecione a guia Geral

  6. Clique para marcar a caixa de seleção Este banco de dados pode ser substituído por uma restauração.

  7. Clique em OK.

  8. Para montar o banco de dados, clique com o botão direito no banco de dados e, em seguida, clique em Montar Banco de Dados.


MSExchangeIS 9518 (0xfffffc01): Banco de dados ou unidade de log de transações ou diretório incorreto
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-23

A ferramenta Microsoft® Exchange Database Troubleshooter Tool detectou um ou mais eventos MSExchangeIS 9518 com código de erro 0xfffffc01 no log de Aplicativos. Isso indica que uma letra de unidade ou caminho incorretos foram definidos para o banco de dados ou os arquivos de log do Exchange.

Explicação

Esse erro indica que o banco de dados ou o caminho do arquivo de log no grupo de armazenamento afetado aponta para uma letra de unidade inválida ou que o caminho do arquivo está incorreto. Quando esse erro ocorrer, nenhum banco de dados do grupo de armazenamento afetado poderá ser montado.

Esse problema também pode ocorrer se um software antivírus estiver bloqueando o acesso de gravação a unidades que contêm o banco de dados ou os arquivos de log de transações do Exchange.

O evento também pode ser identificado como erro -1023, JET_errInvalidPath.

Ação do usuário

Para resolver o problema, execute um ou mais dos seguintes procedimentos:

  • Para determinar se seu software antivírus está causando esse problema, desabilite-o temporariamente no console Serviços. Em seguida, tente montar os bancos de dados afetados. Se os bancos de dados forem montados com êxito, entre em contato com o fornecedor do antivírus para obter a última compilação do software.

  • Verifique e configure os caminhos corretos do arquivo de log de transações, do banco de dados e do sistema de cada grupo de armazenamento e banco de dados afetado por esse erro. Siga estas etapas.

Para verificar e configurar caminhos de arquivos corretos no Exchange Server 2003 ou no Exchange 2000 Server

  1. Inicie o Gerenciador do Sistema Exchange. Clique em Iniciar, Programas, Microsoft Exchange e clique em Gerenciador do Sistema.

  2. Se os grupos administrativos forem exibidos no Gerenciador do Sistema do Exchange, expanda Grupos Administrativos e expanda o grupo administrativo no qual tenha ocorrido o problema.

  3. Expanda Servidores e expanda o servidor no qual ocorreu o problema.

  4. Clique com o botão direito no grupo de armazenamento que contém o armazenamento que não é possível montar e clique em Propriedades.

  5. Na guia Geral, examine o caminho que é exibido na caixa Local de log de transação. Examine o caminho da caixa Local de caminho do sistema.

    Se esses caminhos estiverem incorretos, entre em contato com o Atendimento Microsoft para obter ajuda sobre como resolver esse problema.

  6. Siga as etapas de 3 a 5 para cada grupo de armazenamento que possa estar presente para verificar o caminho do banco de dados e o caminho do arquivo de log de transações.

  7. Depois de verificar o caminho do sistema e do arquivo de log de transações de cada grupo de armazenamento, verifique os caminhos de banco de dados de cada armazenamento em cada grupo de armazenamento. Para fazer isso, siga essas etapas:

    1. Expanda um grupo de armazenamento. Por exemplo, expanda Primeiro Grupo de Armazenamento.

    2. Clique com o botão direito em StoreName (ServerName) e clique em Propriedades.

    3. Clique na guia Banco de dados e verifique o caminho que é exibido na caixa Banco de Dados do Exchange. Em seguida, verifique o caminho que é exibido na caixa Banco de dados de streaming do Exchange.

      Se um determinado caminho estiver incorreto, entre em contato com o Atendimento Microsoft para obter ajuda sobre como resolver esse problema.

    4. Repita as etapas 7b e 7c para verificar os caminhos de cada armazenamento de caixa de correio ou armazenamento de pasta pública presentes em cada grupo de armazenamento.

  8. Monte o armazenamento de caixa de correio ou o armazenamento de pasta pública.

Para verificar e configurar os caminhos de arquivo corretos no Exchange Server 2007

  1. Inicie o Console de Gerenciamento do Exchange. Clique em Iniciar, aponte para Programas, Microsoft Exchange e clique em Console de Gerenciamento do Exchange.

  2. Expanda Configuração do Servidor, selecione Caixa de Correio.

  3. Na painel Gerenciamento de Banco de Dados, selecione o grupo de armazenamento que contém os bancos de dados que você não conseguiu montar.

  4. Clique com o botão direito no grupo de armazenamento e clique em Propriedades.

  5. Na guia Geral, examine o caminho listado nos locais Caminho do log e Caminho do sistema.

    Se esses caminhos estiverem incorretos, clique com o botão direito no grupo de armazenamento e selecione Mover Caminho do Grupo de Armazenamento. Em Caminho de arquivos de log e Caminho de arquivos do sistema, clique em Procurar para localizar a pasta que contém os arquivos de log de transações ou os arquivos de banco de dados. Por padrão, os arquivos de log de transações e de banco de dados estão localizados na seguinte pasta:

    %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<nome do grupo de armazenamento>

  6. Clique em OK.

  7. Siga as etapas de 3 a 5 para cada grupo de armazenamento que possa estar presente para verificar o caminho do sistema e do arquivo de log de transações.

  8. Depois de verificar o caminho do sistema e do arquivo de log de transações de cada grupo de armazenamento, verifique os caminhos de banco de dados de cada banco de dados em cada grupo de armazenamento. Para fazer isso, siga essas etapas:

    1. Expanda um grupo de armazenamento. Por exemplo, expanda Primeiro Grupo de Armazenamento.

    2. Verifique o caminho que é exibido em Caminho do Arquivo de Banco de Dados no painel Gerenciamento de Banco de Dados.

    3. Se um determinado caminho estiver incorreto, clique com o botão direito no banco de dados e clique em Mover Caminho do Banco de Dados.

    4. Clique em Procurar para localizar a pasta correta de um arquivo de banco de dados. Por padrão, o arquivo de banco de dados do Exchange (.edb) está localizado na seguinte pasta:

      %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<nome do grupo de armazenamento>\<nome do banco de dados.edb>

    5. Clique em OK.

    6. Siga as etapas de 8b a 8e para verificar os caminhos de cada banco de dados de caixa de correio ou de pasta pública que estejam presentes em cada grupo de armazenamento.

  9. Monte o banco de dados de caixa de correio ou de pasta pública.


MSExchangeIS 9519 (0xfffffbda): Código do idioma do conjunto de caracteres de duplo byte ausente configurado como o código de idioma do sistema padrão
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-23

A ferramenta Microsoft® Exchange Database Troubleshooter Tool detectou um ou mais eventos MSExchangeIS 9519 com código de erro 0xfffffbda no log de Aplicativos. O evento indica que um código de idioma do sistema padrão diferente do inglês foi instalado. Após a instalação do Exchange Server, o código do idioma do sistema padrão foi desinstalado.

Explicação

Se o evento MSExchangeIS 9519 com o código de erro 0xfffffbda causar a reinicialização do servidor Exchange, os bancos de dados do Exchange não serão montados. Além disso, os eventos de erro ESE 604 e MSExchangeIS 9519 serão registrados no log de eventos do Aplicativo.

Esse comportamento pode ocorrer se, anteriormente, você possuía um código de idioma diferente do inglês definido como o código do idioma do sistema padrão. Se você escolheu outro código de idioma como o código de idioma do sistema padrão, removeu o código de idioma diferente do inglês e reiniciou o Exchange 2000 Server ou o Exchange Server 2003, você enfrentou esse evento.

O evento também pode ser identificado como -1062, JET_errInvalidLanguageId. O evento se aplica às seguintes versões do servidor Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Ação do usuário

Para resolver esse problema, reinstale o código de idioma diferente do inglês e crie novos bancos de dados. Se você reinstalar o código de idioma diferente do inglês, ele não precisará ser definido como o código de idioma do sistema padrão.


MSExchangeIS 9519 (0xfffff05b): Banco de Dados ou Logs Compactados em um Servidor que Está Executando o Exchange Server 2000 SP3 ou superior
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-02-19

A ferramenta Microsoft Exchange Database Troubleshooter Tool detectou um ou mais eventos MSExchangeIS 9519 com código de erro 0xfffff05b no log de aplicativos. Esse erro indica que o banco de dados ou os arquivos de log de transações do Exchange estão em uma unidade que tem a compactação do sistema de arquivo habilitada.

Explicação

Esse evento pode ocorrer na aplicação do Exchange 2000 Server Service Pack 3 (SP3) a um Exchange 2000 Server que contém um banco de dados de armazenamento de informações que foi compactado com a compactação do sistema de arquivo NTFS. Esse problema pode ocorrer também na atualização de um computador Exchange 2000 Server para o Exchange Server 2003. O Exchange 2000 Server SP3, o Exchange Server 2003 e o Exchange Server 2007 impedem a montagem de bancos de dados de armazenamento de informações compactados.

Esse erro também é identificado como -4005, JET_errFileCompressed. Esse erro se aplica às seguintes versões do servidor Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server SP3

Ação do usuário

Para resolver esse problema, descompacte as pastas nas quais estão os bancos de dados de armazenamento de informações e os logs, desfragmente os bancos de dados e, em seguida, execute um backup online, com detecção do Exchange, dos grupos de Armazenamento de Informações nos quais residem os bancos de dados e os logs. Para fazer isso, consulte o artigo 327772 da Base de Dados de Conhecimento Microsoft, O banco de dados não é montado e você recebe o erro 0xfffff05b depois de aplicar o SP3 ao Exchange 2000.


MSExchangeIS 9519 (0xfffffa84): Índices de Banco de Dados Ausentes ou Danificados
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-01-22

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft® Exchange detectou um ou mais eventos MSExchangeIS 9519 com código de erro 0xfffffa84 no log de Aplicativos. Esse evento indica que os índices deste banco de dados estão ausentes ou danificados.

Explicação

As situações a seguir podem resultar em um índice de banco de dados ausente ou danificado:

  • Isso pode ocorrer durante a limpeza de índice de um banco de dados do Exchange após a aplicação de um novo service pack do Microsoft Windows . Após a aplicação do service pack, não é possível montar os bancos de dados de caixa de correio ou de pasta pública no servidor do Exchange. Além disso, os eventos ESE 609 e ESE 611 são registrados no log de eventos do Aplicativo.

  • Isso pode ocorrer após a execução de uma operação de reparo de banco de dados (eseutil /p). Isso pode remover um índice que é gerado quando o banco de dados é criado. A execução do comando de reparo Eseutil remove o índice.

Esse erro também pode ser identificado como -1404, JET_errIndexNotFound. Esse erro se aplica às seguintes versões do servidor Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Ação do usuário

Para resolver esse problema, siga a resolução correspondente ao cenário de problema descrito anteriormente:

  • Se um índice for danificado durante uma limpeza de índice de um banco de dados do Exchange após a aplicação de um novo service pack do Windows, siga estas etapas:

    1. Restaure o banco de dados de caixa de correio ou de pasta pública afetado a partir de um backup adequado.

    2. Realize uma desfragmentação offline dos bancos de dados afetados, executando eseutil /d. Para obter informações sobre como desfragmentar o banco de dados afetado offline, consulte os seguintes tópicos:

      Bancos de dados do Exchange 2000 Server e do Exchange Server 2003: Como executar o Eseutil /D (Desfragmentação)

      Bancos de dados do Exchange Server 2007: Como executar o Eseutil /D (Desfragmentação)

  • Se um índice estiver ausente após a execução de uma operação de reparo de banco de dados (eseutil /p), aplique o hotfix recomendado no artigo 924627 da Base de Dados de Conhecimento da Microsoft, A ID de evento 9519, que inclui o erro 0xfffffa84, é registrada quando você tenta montar um banco de dados após utilizar os utilitários Eseutil e Isinteg para recuperar o banco de dados no Exchange 2003.


MSExchangeIS 9519 0x972: Contêiner de Pastas Públicas Excluído ou Atributos Necessários Ausentes
Microsoft Exchange Server Analyzer - Artigos > Recuperação de Banco de Dados >

Última modificação do tópico: 2007-08-30

A ferramenta Solucionador de Problemas de Banco de Dados do Microsoft Exchange detectou um ou mais eventos MSExchangeIS 9519 com código de erro 0x972 no log de Aplicativos. Isso indica uma falha ao montar os bancos de dados de Pasta Pública porque o contêiner de Pastas Públicas foi excluído ou atributos necessários estão ausentes.

Explicação

Este erro pode ocorrer quando o contêiner de Pastas Públicas é excluído do Active Directory ou se o Armazenamento Público não está configurado para usar o contêiner de Pastas Públicas, isto é, se o valor do atributo msExchOwningPFTreeBL dos Contêineres de Pastas Públicas não apontar para o Armazenamento Público. A causa mais provável desse erro é o Grupo Administrativo que continha as pastas públicas ter sido excluído sem antes mover o contêiner de pastas públicas para um novo Grupo Administrativo.

Ação do usuário

Para resolver esse problema, use o ADSI Edit ou uma ferramenta semelhante para determinar se o contêiner de pastas públicas existe e se o atributo msExchOwningPFTreeBL está configurado corretamente para apontar para o Armazenamento Público relevante.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003, do Exchange Server 2007, ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para determinar a causa do erro

  1. Usando o ADSI Edit ou uma ferramenta semelhante, localize cada objeto de grupo administrativo do Active Directory.

    O objeto do Grupo Administrativo pode ser encontrado em:

    CN=Configuração,CN=Serviços,CN=Microsoft Exchange,CN=Organização,CN=Grupos Administrativos,CN=Grupo administrativo

  2. Expanda cada Grupo Administrativo e verifique a existência de um contêiner CN=Hierarquias de Pastas. Caso o contêiner CN=Hierarquias de Pastas exista, realce-o e verifique se existe um objeto CN=Pastas Públicas no painel da direita. Caso não exista nenhum objeto CN=Pastas Públicas sob nenhum Grupo Admnistrativo, passe para a Solução 1, Recriar Hierarquias de Pastas e contêineres de Pastas Públicas. Caso você encontre um contêiner CN=Pastas Públicas, prossiga para a etapa 3.

  3. Clique com o botão direito no objeto CN=Pastas Públicas e clique em Propriedades.

  4. Na lista Atributos, selecione o atributo msExchOwningPFTreeBL e clique em Editar.

  5. Certifique-se de que o Armazenamento de Pasta Pública é exibido na lista Valores. Caso ele não esteja listado, prossiga para a Solução 2.
Solução 1: Recriar Hierarquias de Pastas e contêineres de Pastas Públicas

  1. Usando o ADSI Edit ou uma ferramenta semelhante, localize e expanda o Grupo Administrativo do Exchange (FYDIBOHF23SPDLT).

    O objeto do Grupo Administrativo do Exchange (FYDIBOHF23SPDLT) pode ser encontrado em:

    CN=Configuração,CN=Serviços,CN=Microsoft Exchange,CN=Organização,CN=Grupos Administrativos

  2. Clique com o botão direito no objeto do Grupo Administrativo do Exchange (FYDIBOHF23SPDLT), clique em Novo e depois em Objeto.

  3. Na lista Selecionar uma classe, selecione msExchPublicFolderTreeContainer e clique em Avançar.

  4. Na caixa Valor, digite Hierarquias de Pastas, clique em Avançar, depois em Concluir.

  5. Clique com o botão direito no objeto recém-criado Hierarquias de Pastas, clique em Novo, e depois em Objeto.

  6. Na lista Selecionar uma classe, selecione msExchPFTree e clique em Avançar.

  7. Na caixa Valor, digite Pastas Públicas e clique em Avançar.

  8. Clique em Mais Atributos.

  9. No menu suspenso Selecionar uma propriedade a ser exibida, selecione msExchPFTree.

  10. Na caixa Editar Atributo, digite 1, clique em Definir, clique em OK e, depois, em Concluir.

  11. Para atribuir o contêiner de Pastas Públicas a cada Armazenamento Público, clique com o botão direito no contêiner Pastas Públicas e selecione Propriedades.

  12. Na lista Atributos, selecione distinguishedName e clique em Editar.

  13. Copie o conteúdo da caixa Valor para a área de transferência e clique em Cancelar.

  14. Para cada servidor que esteja exibindo o evento MSExchangeIS 9519 com código de erro 0x972, navegue até o objeto de Armazenamento de Pasta Pública. O local padrão deste objeto é:

    CN=Configuração,CN=Serviços,CN=Microsoft Exchange,CN=Organização,CN=Grupos Administrativos, CN=Grupo Administrativo do Exchange (FYDIBOHF23SPDLT), CN=Servidores, CN= ServerName , CN= Armazenamento de Informações , CN=Segundo Grupo de Armazenamento.

  15. Clique com o botão direito no objeto de Armazenamento de Pasta Pública e, em seguida, clique em Propriedades.

  16. Na lista Atributos, selecione msExchOwningPFTree e clique em Editar.

  17. Cole o valor copiado para a área de transferência na etapa 13 na caixa Valor e clique em OK duas vezes para concluir.

  18. Repita as etapas de 15 a 17 para cada servidor que esteja exibindo o evento MSExchangeIS 9519 com código de erro 0x972.

  19. Reinicie o serviço Armazenamento de Informações do Microsoft Exchange nos servidores afetados.

Solução 2: Preencher novamente o valor do atributo msExchOwningPFTreeBL para o objeto do contêiner de Pastas Públicas

  1. No ADSI Edit ou em uma ferramenta semelhante, localize o objeto Pastas Públicas no Active Directory.

    O objeto Pastas Públicas pode ser encontrado em:

    CN=Configuração,CN=Serviços,CN=Microsoft Exchange,CN=Organização,CN=Grupos Administrativos,CN=Grupo administrativo,CN=Hierarquias de Pastas,CN=Pastas Públicas

  2. Clique com o botão direito no contêiner Pastas Públicas e selecione Propriedades.

  3. Na lista Atributos, selecione distinguishedName e clique em Editar.

  4. Copie o conteúdo da caixa Valor para a área de transferência e clique em Cancelar.

  5. Para cada servidor que esteja exibindo o evento MSExchangeIS 9519 com código de erro 0x972, navegue até o objeto de Armazenamento de Pasta Pública. O local padrão deste objeto é:

    CN=Configuração,CN=Serviços,CN=Microsoft Exchange,CN=Organização,CN=Grupos Administrativos, CN=Grupo Administrativo do Exchange (FYDIBOHF23SPDLT), CN=Servidores, CN= ServerName , CN= Armazenamento de Informações , CN=Segundo Grupo de Armazenamento.

  6. Clique com o botão direito no objeto de Armazenamento de Pasta Pública e, em seguida, clique em Propriedades.

  7. Na lista Atributos, selecione msExchOwningPFTree e clique em Editar.

  8. Cole o valor copiado para a área de transferência na etapa 4 na caixa Valor e clique em OK duas vezes para concluir.

  9. Repita as etapas de 6 a 8 para cada servidor que esteja exibindo o evento MSExchangeIS 9519 com código de erro 0x972.

  10. Reinicie o serviço Armazenamento de Informações do Microsoft Exchange nos servidores afetados.


Cluster do Exchange
Microsoft Exchange Server Analyzer - Artigos >

Última modificação do tópico: 2005-11-18

Os artigos desta seção fornecem detalhes sobre o que a ferramenta Microsoft® Exchange Server Analyzer Tool está avaliando em relação aos clusters do Exchange. Além disso, esses artigos descrevem as ações que você pode tomar para resolver erros, avisos e configurações não padrão relacionadas a clusters do Exchange que são encontradas pelo Exchange Server Analyzer.


A depuração de cluster está habilitada
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar se a depuração de cluster está habilitada no servidor:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Cluster\Debug

Se o Exchange Server Analyzer verificar que o valor de Debug é equivalente a 1, ele exibirá um aviso.

A depuração de cluster com esse valor de Registro evita falha dos recursos de cluster entre os nós. Você só deve usar esse valor de Registro quando estiver depurando um problema que exija a prevenção de falha dos recursos.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para desabilitar a chave de Registro da depuração de cluster

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para HKLM\Software\Microsoft\Exchange\Cluster.

  3. Altere o valor de Debug para 0.

  4. Saia do editor do Registro.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft , "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre clusters do Exchange, consulte o tópico "Gerenciando clusters do Exchange no Exchange Server 2003" no Guia de administração do Exchange 2003 Server (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47617).


Prioridade da rede de pulsação dedicada no cluster definida incorretamente
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar a ordem de prioridade de cada recurso da interface de rede no cluster de servidores Exchange:

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Prioridade

O valor de Prioridade indica a prioridade da rede configurada para o recurso da interface de rede. O recurso de interface de rede com a maior prioridade possui um valor 1, a prioridade seguinte possui um valor 2 e assim por diante.

A ferramenta Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar a função definida para cada rede no cluster de servidores Exchange:

HKLM\Cluster\Networks\<NetworkInterfaceGUID>\Role

O valor 1 indica que o recurso da rede foi configurado como uma rede (pulsação) privada dedicada. O valor 2 indica que o recurso da rede foi configurado como uma rede pública dedicada (acesso para cliente). O valor 3 indica que o recurso da rede foi configurado como uma rede mista que permite os tráfegos de pulsação e acesso para cliente.

Se o Exchange Server Analyzer determinar que um recurso da interface de rede com um valor de Função 1 possui um valor de Prioridade maior que 1, um aviso será exibido. Esse aviso indica que uma rede de pulsação dedicada foi encontrada, mas a prioridade de rede não está definida corretamente.

É uma prática recomendada configurar uma rede privada dedicada para usar na pulsação de todos os clusters do Exchange Server. A comunicação entre os nós é fundamental para as operações normais dos clusters. Utilize as seguintes instruções para configurar corretamente a prioridade para a rede de pulsação dedicada.

Para corrigir esse aviso

  1. Abra o Administrador de Cluster e conecte ao cluster de servidores Exchange.

  2. Na área de janela à esquerda, clique com o botão direito no objeto Cluster na parte superior da hierarquia e, em seguida, clique em Propriedades.

  3. Clique em Prioridade de Rede.

  4. Selecione o recurso da rede de pulsação dedicada.

  5. Clique em Mover Para Cima até que o recurso da rede de pulsação dedicada esteja na parte superior dos recursos de rede listados.

  6. Clique em OK.

Para obter mais informações sobre as redes de pulsação de cluster, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 258750, "Configuração de uma "pulsação" privada recomendada em um servidor de clusters" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)

  • 307962, "Suporte ao Multicast habilitado para a pulsação de cluster" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

Para obter detalhes adicionais, consulte a Lista de Verificação da Configuração de Cluster do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=36083).


O número de compilação do nó do cluster do Windows não corresponde ao primeiro nó
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2005-11-18

O Exchange Server Analyzer lê a seguinte entrada do Registro para determinar a versão do núcleo do sistema operacional do Microsoft Windows® que está sendo executada em cada nó do cluster:

HKEY_LOCAL_MACHINE\Cluster\Nodes\ <Número do nó> \BuildNumber

Se o Exchange Server Analyzer verificar que o valor de BuildNumber no segundo nó ou no nó subseqüente do cluster do Exchange é diferente do valor de BuildNumber no primeiro nó do cluster do Exchange, será exibido um erro.

Se um cluster do Exchange estiver sendo executado em versões diferentes do Windows, o failover pode não ocorrer como esperado ou configurado. Em um ambiente Windows misto típico, o failover pode ocorrer apenas de um sistema operacional anterior para um posterior (por exemplo, do Windows 2000 Advanced Server para o Windows Server™ 2003, Enterprise Edition). O failover não ocorrerá de um sistema operacional posterior para um anterior (por exemplo, do Windows Server 2003 para o Windows 2000 Server).

Para resolver esse problema, você deve atualizar todos os nós para o mesmo sistema operacional e o mesmo service pack. Para minimizar a inatividade, você pode executar uma atualização sem interrupção de seu cluster.

Para corrigir esse erro

  1. Consulte as instruções sobre como realizar uma atualização sem interrupção de um cluster, lendo o artigo 811272 da Base de Dados de Conhecimento Microsoft, "How to Perform a Rolling Upgrade of Windows Server 2003 Server Clusters" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272).

  2. Consulte o artigo, "Cluster do Windows 2000: Executando um pacote cumulativo de atualizações" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=1718).

  3. Execute um pacote cumulativo de atualizações para cada nó cujo valor BuildNumber não seja o mesmo do primeiro nó do cluster.

Para obter informações sobre procedimentos alternativos, consulte "Alternativas para um pacote cumulativo de atualizações" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=41363).


A versão do service pack do Windows do Nó do Cluster não coincide com o primeiro nó
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar qual versão de service pack do Microsoft Windows® está instalada em cada nó do cluster:

HKEY_LOCAL_MACHINE\Cluster\Nodes\<Número do Nó>\CSDVersion

Se o Exchange Server Analyzer verificar que o valor de CSDVersion no segundo nó ou no nó subseqüente do cluster do Exchange é diferente do valor de CSDVersion no primeiro nó do cluster do Exchange, será exibido um erro.

Esse erro indica que os nós nesse cluster do Exchange não estão sendo executado no mesmo nível do service pack do Windows. É recomendável que todos os nós em um cluster do Exchange executem o mesmo nível de sistema operacional e service pack.

Para resolver esse problema, você deve atualizar todos os nós para o mesmo sistema operacional e o mesmo service pack. Para minimizar a inatividade, você pode executar uma atualização sem interrupção de seu cluster.

Para corrigir esse aviso

  1. Consulte as instruções sobre como realizar uma atualização sem interrupção de um cluster, lendo o artigo 811272 da Base de Dados de Conhecimento Microsoft, "How to Perform a Rolling Upgrade of Windows Server 2003 Server Clusters" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272).

  2. Consulte o artigo, "Cluster do Windows 2000: Executando uma atualização sem interrupção" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=34288).

  3. Execute uma atualização sem interrupção em cada nó cujo valor CSDVersion seja diferente do primeiro nó do cluster.

Para obter informações sobre procedimentos alternativos, consulte "Alternativas para atualizações de sobreposição" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=34289).


O caminho TEMP/TMP de cluster está localizado na mesma unidade que a partição do sistema
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2005-11-18

Em um computador do Exchange Server sem cluster, a ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas de Registro para determinar o valor das variáveis de ambiente TEMP e TMP:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

Quando executado contra um EVS (Servidor Virtual do Exchange) em um cluster de servidor do Microsoft Windows®, o Exchange Server Analyzer não lê a seção do Registro HKLM. Em vez disso, ele lê as seguintes entradas de Registro:

HKEY_USERS \<SID da conta de serviço do cluster> \Environment\TEMP

HKEY_USERS \<SID da conta de serviço do cluster> \Environment\TMP

Se o Exchange Server Analyzer detectar que uma ou ambas as variáveis do ambiente, TEMP e/ou TMP, inicia com %SYSTEMROOT, será exibido um aviso.

O processo do serviço Armazenamento de Informações do Microsoft Exchange usa as pastas TEMP e TMP como armazenamento temporário em várias operações, como as operações de conversão de mensagens e deslocamento de caixas de correio. Em um servidor Exchange sem cluster, o serviço Armazenamento de Informações do Microsoft Exchange usa o SISTEMA (por exemplo, Sistema Local), que usa uma configuração de variável de ambiente padrão %Systemroot%\Temp para TEMP e TMP.

Os EVS em execução em um cluster do Windows Server 2003 usam as configurações de variáveis do ambiente para a Conta do serviço de cluster, administradas sob o contexto de um princípio de segurança de usuário específico. Para contas de usuários, a variável de ambiente padrão para TEMP e TMP é definida como %Userprofile%\temp.

As variáveis de ambiente TEMP e TMP são usadas para designar quais pastas no sistema de arquivos (por exemplo, que caminho) devem ser usadas pelos aplicativos que exigem um espaço de trabalho temporário. TEMP é geralmente usada por aplicativos, como o Microsoft Exchange, e TMP é freqüentemente usada por ferramentas de desenvolvimento, como o Microsoft Visual C++®. O caminho para cada variável geralmente é relativo ao contexto de segurança do aplicativo ou ferramenta.

Para obter o desempenho ideal, é recomendável que você não use o disco que contenha o sistema operacional das pastas TEMP e TMP usadas pelo Exchange. Além disso, você deve certificar-se de que essas variáveis de ambiente são definidas para caminhos em um disco ou subsistema de disco rápidos, como um conjunto de eixos RAID 0+1. Também é recomendável que você não utilize o disco contendo o sistema operacional para as pastas TEMP e TMP usadas pelo Exchange ou pelos EVS.

Para corrigir esse aviso

  1. Faça logon em um nó do cluster como a conta de serviço do Cluster.

  2. Clique com o botão direito em Meu Computador e selecione Propriedades.

  3. Selecione Avançado.

  4. Clique em Variáveis de Ambiente.

  5. Na área Variáveis de usuário para <nome de conta>, selecione TEMP e clique em Editar.

  6. No campo Valor da variável, digite o novo caminho para a variável de ambiente TEMP e clique em OK.

  7. Na área Variáveis de usuário para <nome de conta>, selecione TMP e clique em Editar.

  8. No campo Valor da variável, digite o novo caminho para a variável de ambiente TMP e clique em OK.

  9. Clique em OK para fechar a caixa de diálogo Variáveis de Ambiente e clique em OK mais uma vez para fechar a caixa de diálogo Propriedades do Sistema.

  10. Reinicie o nó para aplicar a alteração.

  11. Repita as etapas de 1 a 10 para cada nó do cluster.

Para obter mais informações sobre como alterar as variáveis do ambiente TEMP/TMP em um servidor não agrupado do Exchange Server, consulte A variável TEMP/TMP parece apontar para uma pasta inválida ou inadequada.


Pulsação dedicada de cluster não encontrada
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a entrada de Registro a seguir para determinar a função definida de cada recurso de interface de rede no cluster do servidor Exchange:

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Role

O valor 1 indica que o recurso da rede foi configurado como uma rede (pulsação) privada dedicada. O valor 2 indica que o recurso da rede foi configurado como uma rede pública dedicada (acesso para cliente). O valor 3 indica que o recurso da rede foi configurado como uma rede mista que permite os tráfegos de pulsação e acesso para cliente.

O Exchange Server Analyzer consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar o valor da chave Started do ClusSvc (Serviço de Cluster). Um valor True indica que o serviço de Cluster está iniciado e um valor False indica que esse serviço não está em execução.

Se o Exchange Server Analyzer não encontrar um recurso de rede, em um cluster do Exchange, configurado como rede privada dedicada, um aviso será exibido.

É uma prática recomendada configurar uma rede privada dedicada para usar na pulsação de todos os clusters do Exchange Server. A comunicação entre os nós é fundamental para as operações normais dos clusters. É necessário configurar da maneira mais eficiente possível as redes que você usa na comunicação de cluster e seguir todos os requisitos da lista de compatibilidade de hardware. Na configuração de rede, duas ou mais redes independentes devem conectar os nós de um cluster para evitar um ponto de falha único. O uso de duas redes locais é o mais comum. O Atendimento Microsoft não oferece suporte para a configuração de um cluster com nós conectados por apenas uma rede.

Para corrigir esse aviso

  1. Caso não estejam presentes ainda, adicione placas de interface de rede a cada nó do cluster do Exchange e configure-as como rede privada no Administrador de Cluster.

  2. Se placas de rede adicionais estiverem presentes, mas sendo usadas em redes mistas, modifique a configuração reconfigurando as redes apropriadas para atuarem como rede privada dedicada.

Para obter mais informações sobre as redes de pulsação de cluster, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 258750, "Configuração de uma "pulsação" privada recomendada em um servidor de clusters" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)

  • 307962, "Suporte ao Multicast habilitado para a pulsação de cluster" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

Para obter detalhes adicionais, consulte o documento Lista de verificação para configurar o cluster do Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=36083).


O tamanho de arquivo padrão para cluster.log deve ser elevado para 32
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar se o parâmetro ClusterLogSize foi definido:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment\

Se o Exchange Server Analyzer verificar que o valor de ClusterLogSize não está presente, ou que o valor de ClusterLogSize é igual ou menor que 8, um aviso será exibido. Em um cluster ocupado, o arquivo cluster.log retorna ao início tão rapidamente que entradas podem ser perdidas quando você solucionar problemas de situações de failover nas seguintes condições:

  • A solução de problemas exige uma consulta detalhada ao arquivo de log do cluster.

  • O cluster está gerenciando muitos recursos.

Por isso, quando a solução de problemas exigir o uso do arquivo cluster.log, crie o parâmetro ClusterLogSize, se ele ainda não estiver presente, e aumente o tamanho padrão para pelo menos 32, 64 ou 96.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para criar o parâmetro ClusterLogSize e definir seu valor

  1. Abra um editor do Registro, como o Regedit.exe ou Regedit32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. No painel da esquerda, clique em Ambiente.

  4. No menu Editar, aponte para Novo e clique em Valor DWORD.

  5. Digite ClusterLogSize e pressione ENTER para nomear a nova entrada de Registro.

  6. Clique com o botão direito em ClusterLogSize e clique em Modificar.

  7. Modifique os ClusterLogSize Dados do valor para o novo tamanho de arquivo de log. Por exemplo, modifique o valor ClusterLogSize para 32, 64 ou 96 e pressione ENTER.

  8. Saia do Editor do Registro
Para modificar o tamanho padrão do arquivo cluster.log

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. Clique com o botão direito em ClusterLogSize e clique em Modificar.

  4. Modifique os ClusterLogSize Dados do valor para o novo tamanho de arquivo de log. Por exemplo, modifique o valor ClusterLogSize para 32, 64 ou 96 e pressione ENTER.

  5. Saia do editor de Registro.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre log de cluster no Microsoft Cluster Server, consulte o artigo 168801 da Base de Dados de Conhecimento Microsoft, "Como ativar o log de cluster no Microsoft Cluster Server" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=168801)


Habilitar Autenticação Kerberos para SMTP
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2006-05-12

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se um servidor Microsoft Exchange Server 2003 instalado em um serviço de Cluster do Windows™ Server 2003 tem um FQDN (Nome de Domínio Totalmente Qualificado) do servidor como um valor para o recurso SMTPSVC no atributo servicePrincipalName.

Se o Exchange Server Analyzer detectar que o atributo servicePrincipalName do recurso SMTPSVC do Exchange no serviço de cluster não contém o FQDN do servidor como um valor, o Exchange Server Analyzer exibirá uma mensagem de prática recomendada.

É uma prática recomendada habilitar a autenticação Kerberos para os serviços SMTP em servidores de cluster do Windows Server 2003 que estão executando o Exchange Server 2003. É possível habilitar a autenticação Kerberos, definindo manualmente um novo valor de SPN (Nome da Entidade de Serviço) para o recurso SMTPSVC do Exchange.

Por padrão, o Windows Server 2003 usa a autenticação NTLM. O protocolo Kerberos é mais flexível, eficiente e mais seguro do que o NTLM. Os benefícios obtidos com a autenticação Kerberos são os seguintes:

  • Conexões mais rápidas. Com a autenticação NTLM, um servidor de aplicativos deve ser conectado a um controlador de domínio para autenticar cada cliente. Com a autenticação Kerberos, o servidor não precisa localizar um controlador de domínio. O servidor pode autenticar o cliente, examinando as credenciais por ele apresentadas. Os clientes podem obter credenciais para um servidor específico uma vez e reutilizá-las em toda a sessão de logon na rede.

  • Autenticação Mútua. NTLM permite que os servidores verifiquem as identidades de seus clientes. A NTLM não permite que os clientes verifiquem a identidade de um servidor nem que um servidor verifique a identidade de outro servidor. A autenticação NTLM foi projetada para um ambiente de rede em que supostamente os servidores sejam autênticos. O protocolo Kerberos não faz essa pressuposição. As partes em ambas as extremidades de uma conexão de rede podem saber que a parte na outra extremidade é exatamente quem diz ser.

  • Autenticação Delegada. Os serviços do Windows representam os clientes quando eles acessam os recursos em nome dos clientes. Freqüentemente, um serviço pode concluir seu trabalho para o cliente acessando recursos no computador local. Tanto NTLM quanto Kerberos fornecem as informações que um serviço precisa ter para representar seu cliente localmente. Contudo, alguns aplicativos distribuídos são projetados para que um serviço front-end represente clientes ao se conectar a serviços back-end em outros computadores. O protocolo Kerberos tem um mecanismo de proxy que permite que um serviço represente seu cliente ao se conectar a outros serviços. Nada equivalente está disponível com NTLM.

Para resolver esse problema, siga essas etapas para adicionar os valores ausentes dos atributos afetados.

Use a ferramenta SETSPN.exe para adicionar um SPN com os valores ausentes

  1. Instale a ferramenta Setspn.exe. Para obter a ferramenta Setspn.exe, consulte "Windows 2000 Resource Kit Tool: Setspn.exe" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=28103).

    A versão do Windows Server 2003 da ferramenta de linha de comando Setspn.exe está disponível nas Ferramentas de Suporte do Windows Server 2003, incluídas no CD do Windows Server 2003. Para instalar as Ferramentas de Suporte do Server 2003, clique duas vezes no arquivo Suptools.msi na pasta Support/Tools.

  2. Siga as orientações no arquivo SETSPN.EXE Setspn_d.txt para adicionar o valor ausente ao objeto do Active Directory em seu servidor Exchange. O exemplo a seguir demonstra como adicionar o valor FQDN a um SPN do servidor virtual SMTP:

    • Inicie um prompt de comando e vá para o diretório em que você instalou o Setspn.exe.

    • No prompt de comando, digite o seguinte:

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      Observação:
      Substitua mail.yourdomain.com pelo FQDN de seu servidor virtual SMTP e YOURSERVERNAME pelo nome do servidor Exchange.
    • Em seguida, pressione Enter.


Não foi possível entrar em contato com o nó de cluster do Exchange
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started para o serviço de Cluster (ClusSvc). Um valor True indica que o serviço de Cluster está iniciado e um valor False indica que esse serviço não está em execução.

O Exchange Server Analyzer também lê a seguinte entrada do Registro para determinar a versão do Windows que está em execução no computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor CurrentVersion 4.0 indica que o computador está executando o Microsoft Windows NT® Server 4.0. Um valor igual a 5.0 indica que o computador está executando o Windows 2000 Server e um valor igual a 5.2 revela que o computador está executando o Windows Server™ 2003.

Se o Exchange Server Analyzer não puder especificar a versão do Windows em execução no cluster ou não puder determinar se o serviço de Cluster está em execução, um erro será exibido. Esse erro indica que o Exchange Server Analyzer não pôde contatar um nó em um cluster do Exchange Server.

Para corrigir esse erro

  1. Verifique se o computador do Exchange Server foi iniciado e está conectado à rede.

  2. Use o comando ping para ver se o computador do Exchange Server está acessível.

  3. Se houver um firewall, verifique se as portas de RPC (chamada de procedimento remoto) estão bloqueadas.

  4. Verifique se o serviço de Registro Remoto no computador do Exchange Server foi iniciado.

  5. Verifique as permissões da conta com a qual o Exchange Server Analyzer está sendo executado para garantir que a conta possua permissões suficientes para ler o Registro no computador do Exchange Server.

Para obter mais informações sobre como solucionar problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


O caminho de dados do Exchange no Active Directory não corresponde ao Registro de cluster
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2006-04-28

A ferramenta Microsoft® Exchange Server Analyzer consulta o Registro de cluster (HKEY_LOCAL_MACHINE\Cluster) e o serviço de diretório do Active Directory® para determinar se os caminhos dos arquivos de dados do Exchange (por exemplo, arquivos de log de controle de mensagens) são os mesmos nos dois locais. O Exchange Server configura esses valores no Registro e no Active Directory quando o programa de Instalação do Exchange é usado para instalar o Exchange em um nó de um cluster de servidores Microsoft Windows®.

O valor de Registro criado pela Instalação do Exchange e lido pelo Exchange Server Analyzer é:

HKLM\Cluster\Resources\<Resource GUID of Information Store resource>\Parameters\DestPath

O valor do Active Directory criado pela Instalação do Exchange e lido pelo Exchange Server Analyzer é: msExchDataPath. Esse valor é um atributo do objeto de computador do Exchange Server no Active Directory, que foi encontrado em:

CN=Configuração, CN=Serviços, CN=Microsoft Exchange, CN= OrganizationName =Grupos Administrativos, CN= AdministrativeGroupName , CN=Servidores, CN= ServerName

Se o Exchange Server Analyzer detectar que os valores de DestPath e msExchDataPath não correspondem, um erro será exibido.

Uma causa comum da diferença nesses valores é quando o local de alguns ou de todos os arquivos de dados do Exchange é alterado depois que o Exchange foi colocado em produção. Por exemplo, se o hardware for atualizado, os arquivos de log de controle de mensagens forem movidos e a letra de uma unidade for alterada, a alteração será refletida no Registro de cluster, mas não no Active Directory. Depois que uma alteração desse tipo é feita, erros de inicialização de serviços, problemas de montagem de banco de dados e outros problemas podem surgir, especialmente ao aplicar um service pack do Exchange ou instalar um pacote cumulativo de atualizações.

Observação:
Solucione essa discrepância o quanto antes. Não instale nenhum service pack ou atualização no Exchange Server enquanto esse problema não for corrigido.

Para executar o procedimento a seguir, será necessário usar um editor do Active Directory, como o ADSI (Active Directory Service Interfaces) Edit, ou a ferramenta LDP (ldp.exe).

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro

  1. Modifique o valor do EVS (Servidor Virtual do Exchange) afetado de msExchDataPath para que ele corresponda ao valor de DestPath no Registro do cluster. O atributo msExchDataPath pode ser encontrado em: CN=Configuração, CN=Serviços, CN=Microsoft Exchange, CN=NomeOrganização=Grupos Administrativos, CN=NomeGrupoAdministrativo, CN=Servidores, CN=NomeServidor

  2. Reinicie o recurso Atendedor do Sistema do Exchange do servidor virtual para que a alteração entre em vigor.

Para obter mais informações sobre como modificar o Active Directory com a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento Microsoft, "XADM: Usando o utilitário LDP para modificar os atributos de objeto do Active Directory" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745) (em inglês).

Para obter mais informações sobre como usar o ADSI Edit para modificar o atributo msExchDataPath, consulte o artigo 288362 da Base de Dados de Conhecimento, "XADM: A mensagem ID de Evento 5007, "O sistema não pode encontrar o caminho especificado", é registrada pelo Atendedor do Sistema do Microsoft Exchange" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288362).


Replicação do log de eventos está habilitada
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool lê a entrada do Registro a seguir em cada servidor que é um nó do cluster:

HKEY_LOCAL_MACHINE\Cluster\Nodes\X\EnableEventLogReplication

Observação:
X é o número do nó, iniciando com 1.

Se o Exchange Server Analyzer detectar que o valor de EnableEventLogReplication é 1, ele exibirá uma mensagem de prática recomendada.

Se a entrada do Registro EnableEventLogReplication estiver definida como 1, o nó do cluster replicará os eventos do log de eventos para outros nós do cluster. Se a replicação de log de eventos estiver habilitada, as ferramentas que monitoram vários servidores, como MOM (Microsoft Operations Manager), relatarão um único evento várias vezes, uma vez de cada nó. Se você usar monitoramento automatizado, é recomendável que desabilite a replicação de log de eventos nos nós de cluster.

Para desabilitar a replicação de log de eventos em todos os nós de um cluster

  1. Faça logon em qualquer nó do cluster com uma conta que seja uma conta de usuário do domínio ou um membro de um grupo global.

  2. Clique em Iniciar, em Executar e digite

    cluster /prop EnableEventLogReplication=0

Para desabilitar a replicação de log de eventos em um único nó de cluster

  1. Faça logon em qualquer nó do cluster com uma conta que seja uma conta de usuário do domínio ou um membro de um grupo global.

  2. Clique em Iniciar, em Executar e digite

    Nome do nó de Cluster < a ser desabilitado> /prop EnableEventLogReplication=0

Para obter mais informações sobre como configurar a replicação de log de eventos, consulte o artigo 224969 da Base de Dados de Conhecimento da Microsoft, "COMO: Configurar a replicação de log de eventos nos servidores de cluster do Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052& kbid=224969)

Para obter mais informações sobre como administrar clusters de servidores, consulte Administrando clusters de servidores (http://go.microsoft.com/fwlink/?LinkId=45971).


Kerberos desabilitado no recurso Nome de Rede
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar a versão do sistema operacional Microsoft Windows® que está sendo executada no servidor:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor CurrentVersion de 4.0 indica que o computador está executando o Windows NT® Server 4.0. Um valor de 5.0 indica que o computador está executando o sistema operacional Windows 2000 Server e um valor de 5.2 indica que o computador está executando o sistema operacional Windows Server™ 2003.

O Exchange Server Analyzer também consulta o serviço de diretório Active Directory® para determinar o valor do atributo serialNumber para todos os objetos com uma classe de objeto msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 5.5", o computador está executando o Exchange Server 5.5. Se o valor da cadeia de caracteres incluir "Version 6.0", o computador está executando o Exchange 2000 Server. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador está executando o Exchange Server 2003.

Finalmente, o Analisador do Exchange Server lê o seguinte valor de Registro para determinar se o Exchange Server está executando em um cluster com um recurso de cluster de Nome de Rede habilitado para Kerberos.

HKLM\Cluster\Resources\<Resource GUID for Network Name resource>\Parameters\RequireKerberos

Um valor igual a 0 para RequireKerberos indica que o recurso Nome de Rede não está habilitado para Kerberos e um valor igual a 1 indica que o recurso Nome de Rede está habilitado para Kerberos.

Se o Analisador do Exchange Server detectar o valor de RequireKerberos definido como 0 em um servidor virtual Exchange Server 2003 que está executando em um cluster com base no servidor Windows Server 2003, será exibido um aviso.

Esse aviso indica que um recurso de cluster de Nome de Rede habilitado para Kerberos não está sendo usado para um servidor virtual Exchange Server 2003. Essa não é uma configuração aceita e deve ser corrigida o mais rápido possível.

Para corrigir esse aviso

  1. Abra o programa Administrador de Cluster.

  2. Coloque o recurso Nome de Rede offline. Isso colocará todos os recursos que dependem do Nome de Rede offline, incluindo o recurso Atendedor do Sistema do Microsoft Exchange.

  3. Clique com o botão direito no recurso Nome de Rede e clique em Propriedades.

  4. Na guia Parâmetros, clique na opção Habilitar a Autenticação Kerberos e clique em OK.

  5. Coloque o recurso Nome de Rede online e coloque online os recursos restantes que estão offline.

Para obter mais informações sobre o uso de recursos de Nome de Rede habilitados para Kerberos em um cluster Windows Server 2003, consulte o artigo 302389 da Base de Dados de Conhecimento da Microsoft, "Descrição das propriedades do recurso Nome de Rede do Cluster no Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302389).

Para obter mais informações sobre agrupamentos, consulte os seguintes tópicos:

  • "Implantando o Exchange Server 2003 em um Cluster" no Guia de Implantação do Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47569)

  • "Implantando o Exchange Server 2003 em um Cluster" no Guia de Implantação do Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47569)


Kerberos habilitado no recurso de Nome de Rede
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar a versão do sistema operacional Microsoft Windows® que está sendo executada no servidor:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor CurrentVersion de 4.0 indica que o computador está executando o Windows NT® Server 4.0. Um valor de 5.0 indica que o computador está executando o sistema operacional Windows 2000 Server e um valor de 5.2 indica que o computador está executando o sistema operacional Windows Server™ 2003.

O Exchange Server Analyzer também consulta o serviço de diretório Active Directory® para determinar o valor do atributo serialNumber para todos os objetos com uma classe de objeto msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 5.5", o computador está executando o Exchange Server 5.5. Se o valor da cadeia de caracteres incluir "Version 6.0", o computador está executando o Exchange 2000 Server. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador está executando o Exchange Server 2003.

Finalmente, o Exchange Server Analyzer lê o valor de Registro a seguir para determinar se o Exchange está sendo executado em um cluster com um recurso de cluster Nome de Rede habilitado para Kerberos:

HKLM\Cluster\Resources\<GUID de Recurso para o recurso Nome de Rede>\RequireKerberos

Um valor 0 para RequireKerberos indica que o recurso Nome de Rede não está habilitado para Kerberos e um valor 1 indica que o recurso Nome de Rede está habilitado para Kerberos.

Se o Exchange Server Analyzer detectar o valor para RequireKerberos definido como 1 em um servidor virtual Exchange 2000 Server que está sendo executado em um cluster com base no servidor Windows 2000 Server, será exibido um aviso.

Esse aviso indica que um recurso de cluster Nome de Rede habilitado para Kerberos está sendo usado por um servidor virtual Exchange 2000 Server. Essa não é uma configuração aceita e deve ser corrigida o mais rápido possível. Conforme declarado no artigo 235529 da Base de Dados de Conhecimento Microsoft, "Suporte de Kerberos em clusters de servidores baseados no Windows 2000" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529), a autenticação do Kerberos para um recurso Nome de Rede do Exchange 2000 Server não é aceita. O Exchange 2000 Server não foi testado para garantir que um servidor virtual Exchange 2000 Server em cluster oferece suporta para autenticação Kerberos.

Para corrigir esse aviso

  1. Abra um prompt de comando em qualquer nó no cluster.

  2. Execute o seguinte comando: cluster res "Nome do Recurso Nome de Rede" /priv requirekerberos=0:dword

    Observação:
    O nome do recurso deve estar entre aspas.

  3. Coloque o recurso Nome de Rede offline e exclua-o.

  4. Abra Usuários e Computadores do Active Directory.

  5. Localize o objeto de conta do computador para o recurso Nome de Rede excluído e exclua-o do Active Directory.

  6. Crie um novo recurso Nome de Rede para esse EVS (Exchange Virtual Server) e não o habilite para Kerberos. Você pode usar o mesmo nome e configuração que o recurso Nome de Rede excluído na etapa 3.

  7. Coloque o recurso Nome de Rede online e coloque online os recursos restantes no EVS.

Para obter mais informações sobre como usar os recursos Nome de Rede habilitados para Kerberos em um cluster do Windows 2000 Server, consulte o artigo 235529 da Base de Dados de Conhecimento Microsoft, "Suporte de Kerberos nos clusters de servidores baseados no Windows 2000" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529).


MSDTC parece estar ausente em um Cluster
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2006-04-20

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o recurso MSDTC (Microsoft Distributed Transaction Coordinator) existe em um cluster:

HKEY_LOCAL_MACHINE\Cluster\Resources\

O Exchange Server Analyzer exibirá um aviso se o valor de ClusterMSDTCInstance for 0.

O recurso MSDTC precisa estar presente em um cluster do Exchange Server para dar suporte à instalação inicial e a atualizações de service packs. No entanto, ele não é um componente crítico e não é necessário enquanto o Exchange está em execução.

Você ou outro administrador da organização pode ter removido o recurso MSDTC porque sabe que ele não é necessário quando o Exchange está em execução.

No entanto, é recomendável não remover o recurso MSDTC após a configuração inicial do Exchange Server 2003. Se você mantiver o MSDTC no cluster, poderá executar configurações de Service Packs e ooutras atualizações.

Para resolver esse aviso, crie um novo recurso MSDTC. Para obter etapas específicas sobre como criar um recurso MSDTC, consulte "How to Install the Microsoft Distributed Transaction Coordinator in a Windows Server 2003 Server Cluster" em "Deploying Exchange Server 2003 in a Cluster", no Exchange Server 2003 Deployment Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47569).

Para obter mais informações

Para obter mais informações sobre o MSDTC e o Exchange, consulte "Grupos de Cluster" em "Compreendendo o cluster do Exchange Server 2003" no Exchange Server 2003 High Availability Guide (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47571).

Para obter mais informações sobre como adicionar o recurso MSDTC no Microsoft Windows Server™ 2003, consulte o artigo 301600 da Base de Dados de Conhecimento da Microsoft, "Como configurar o Microsoft Distributed Transaction Coordinator em um cluster do Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600).

Observação:
O artigo 301600 da Base de Dados de Conhecimento inclui referência ao artigo 817064, "Como habilitar o acesso de rede DTC no Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064). É uma prática recomendada de segurança do Exchange Server não ativar o acesso ao DTC de rede para um cluster do Exchange. Se você estiver configurando o recurso Distributed Transaction Coordinator para um cluster do Exchange, não habilite o acesso ao DTC de rede.


As interrupções de MSDTC afetarão o grupo de clusters
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2006-03-16

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se você configurou uma falha do recurso MSDTC (Coordenador de Transações Distribuídas da Microsoft) para afetar o grupo:

HKEY_LOCAL_MACHINE\Cluster\Resources\

Se o valor de ClusterMSDTCInstance for 2, o Exchange Server Analyser exibirá um aviso.

O recurso MSDTC deve estar presente em um cluster do Exchange para dar suporte à instalação inicial e às atualizações de service packs. Porém, ele não é necessário quando o Exchange está em execução.

Por padrão, uma falha no recurso MSDTC afetará o grupo. Veja a seguir dois exemplos de falha no recurso:

  • O tamanho do arquivo de log excede a capacidade do disco.

  • Falha no no disco físico para o recurso MSDTC.

Especificamente, uma falha no recurso MSDTC causará um failover de todos os serviços do Exchange que estão em execução nesse nó do cluster para um nó diferente no cluster. Porém, visto que o recurso MSDTC não é um recurso necessário, ele não precisa ser configurado para afetar o grupo.

Para resolver esse aviso, configure o Exchange Cluster de forma que uma falha no recurso MSDTC não afete o grupo.

Para configurar o Exchange de forma que uma falha no recurso MSDTC não afete o grupo

  1. Faça logon em qualquer nó do cluster.

  2. Clique em Iniciar, aponte para Todos os Programas, aponte para Ferramentas Administrativas e clique em Administrador de Cluster.

  3. Em Grupos, clique com o botão direito no grupo de clusters que inclui o recurso MSDTC.

  4. Clique com o botão direito no recurso MSDTC e clique em Propriedades.

  5. Na guia Avançado, desmarque a caixa de seleção Afetar o grupo e clique em OK.

Para obter mais informações

Para obter etapas específicas sobre como criar um recurso MSDTC, consulte "How to Install the Microsoft Distributed Transaction Coordinator in a Windows Server 2003 Server Cluster" em "Deploying Exchange Server 2003 in a Cluster", no Exchange Server 2003 Deployment Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47569).

Para obter mais informações sobre MSDTC e Exchange, consulte "Grupos de cluster" em "Compreendendo clusters do Exchange Server 2003" no Guia de Alta Disponibilidade do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47571).

Para obter mais informações sobre como adicionar o recurso MSDTC no Microsoft Windows Server™ 2003, consulte o artigo 301600 da Base de Dados de Conhecimento da Microsoft, "Como configurar o Microsoft Distributed Transaction Coordinator em um cluster do Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600).

Observação:
O artigo 301600 da Base de Dados de Conhecimento inclui referência ao artigo 817064, "Como habilitar o acesso de rede DTC no Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064). É uma prática recomendada de segurança do Exchange Server não ativar o acesso ao DTC de rede para um cluster do Exchange. Se você estiver configurando o recurso Distributed Transaction Coordinator para um cluster do Exchange, não habilite o acesso ao DTC de rede.


As interrupções de MTA afetarão o grupo de clusters
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2006-03-16

A ferramenta Microsoft® Exchange Server Analyzer Tool examina as configurações do Registro Cluster\Resources do sistema do servidor Exchange.

HKEY_LOCAL_MACHINE\Cluster\Resources

Se o Exchange Server Analyzer detectar que os recursos do serviço MTA Stacks estão sendo executados no cluster do Exchange Server 2003 em uma organização do modo nativo, o Exchange Server Analyzer exibirá uma mensagem de prática recomendada.

Como uma prática recomendada, o Administrador do Exchange deve configurar o recurso MTA, para que o MTA não provoque um possível failover do Exchange Virtual Server quando o MTA parar ou falhar.

Observação:
O serviço MTA Stack no Microsoft Exchange 2000 Server e Microsoft Exchange Server 2003 é usado com freqüência para fornecer serviços de transferência de mensagens compatíveis com versões anteriores entre servidores Exchange 2000 Server ou Exchange Server 2003 e os servidores Microsoft Exchange Server 5.5, em um ambiente de modo misto. Quando a transição é feita para um ambiente puro do modo nativo do Exchange 2000 Server ou Exchange Server 2003, o MTA não é um recurso crítico para os serviços do Exchange executarem.

Se o serviço MTA Stacks parar de executar ou falhar, um possível failover do Exchange Virtual Server poderá estar desativado. Para evitar um possível failover do EVS (Exchange Virtual Server), é uma prática recomendada configurar o serviço MTA Stacks para evitar um failover fazendo o seguinte.

Para configurar o serviço MTA Stacks para um estado não afetado em um cluster de servidor Exchange

  1. Abra o Cluster Administrator

  2. Desmarque a opção Affect this Group do recurso do serviço MTA Stacks.

Para obter mais informações

Para obter informações sobre as diretrizes para o suporte do serviço MTA Stacks para o Exchange Server 2003, consulte o artigo 810489 da Base de Dados de Conhecimento Microsoft, "Diretrizes para o suporte do serviço MTA Stacks no Exchange 2000 Server e Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810489).

Para obter mais informações sobre o MTA na arquitetura do Exchange Server 2003, consulte MTA do Exchange na arquitetura do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=63496).

Para obter informações sobre como implantar o Exchange Server 2003 em um cluster, consulte Implantando o Exchange Server 2003 em um cluster (http://go.microsoft.com/fwlink/?LinkId=63495).

Para obter informações sobre como usar o Administrador do Cluster, consulte Usando o Administrador do Cluster para gerenciar clusters do Exchange (http://go.microsoft.com/fwlink/?LinkId=63493).


Esse é um cluster Ativo/Ativo com 2 nós
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2006-04-28

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave Started para CLusSvc, o serviço de Cluster. Um valor Verdadeiro indica que o serviço de Cluster está em execução, e um valor Falso indica que não está em execução.

O Exchange Server Analyzer também lê a seguinte entrada do Registro para determinar o número de nós no cluster:

HKEY_LOCAL_MACHINE\Cluster\Nodes\ <Número do nó> \NodeName

O número de instâncias de NodeName representa o número de nós no cluster. Além disso, o Exchange Server Analyzer lê a seguinte entrada do Registro para determinar o número de recursos do Exchange Server no cluster:

HKLM\Cluster\Resources\ <GUID de Recursos do Cluster> \Parameters\DestPath

Os recursos a seguir em um cluster do Exchange Server terão um valor DestPath:

  • Agente de Transferência de Mensagens do Microsoft Exchange

  • Armazenamento de Informações do Microsoft Exchange

O número de instâncias de DestPath indica o número de servidores que executam o Servidor Virtual do Exchange (EVS) no cluster.

Se o Exchange Server Analyzer determinar que há 3 instâncias de DestPath em um cluster com 2 instâncias de NodeName, será exibido um aviso. Esse aviso indica que esse é um cluster de dois nós com dois servidores executando EVS, conhecido como cluster Ativo/Ativo.

  • No modelo de cluster Ativo/Ativo, o número de servidores virtuais Exchange no cluster é igual ou maior do que o número de nós físicos do cluster.

Observação:
Clusters Ativo/Ativo do Exchange só podem ser criados em clusters formados por dois nós. Se você tiver três ou mais nós em seu cluster, será necessário usar o modelo Ativo/Passivo.
  • No modelo de cluster Ativo/Passivo, o número de servidores virtuais Exchange no cluster é menor do que o número de nós físicos do cluster.

Embora a Microsoft ofereça suporte para cluster Ativo/Ativo do Exchange Server, é altamente recomendado que sejam usadas implementações Ativo/Passivo em clusters do Exchange. A Microsoft oferece suporte apenas para clusters Ativo/Ativo que estejam de acordo com os seguintes limites de escala:

  • O número de conexões de usuário simultâneas por servidor virtual Exchange por nó físico nunca deverá ser maior do que 1.900. Se um nó do cluster não estiver disponível e se todos os servidores virtuais Exchange estiverem online em um único nó, os limites de escala permanecerão em 3.800 conexões para os dois servidores virtuais Exchange. Como cada usuário pode fazer várias conexões, o número de caixas de correio não é uma maneira precisa de estimar o número de conexões.

  • A utilização média de CPU por processo de armazenamento do Exchange não deve ser mais do que 40 por cento. Se a utilização total de CPU pelo processo STORE.EXE em um nó for maior do que 40 por cento por um período de 10 minutos ou mais, será necessário mover usuários para outro servidor virtual Exchange ou servidor Exchange. Essa carga não inclui a utilização de CPU consumida devido a tarefas administrativas.

A migração de um configuração de cluster Ativo/Ativo para uma configuração Ativo/Passivo envolve a movimentação de recursos do segundo EVS e depois descomissioná-lo.

Para migrar de um cluster Ativo/Ativo para um cluster Ativo/Passivo

  1. Mova as caixas de correio hospedadas no segundo EVS para o primeiro EVS do cluster. O primeiro EVS do cluster sempre contém o único recurso de MTA (agente de transferência de mensagens) do Microsoft Exchange no cluster.

  2. Depois de mover todas as caixas de correio para o primeiro EVS, coloque o segundo EVS offline.

  3. Remova o segundo EVS, executando uma das seguintes opções:

    • Em um cluster do Exchange Server 2003, clique com o botão direito no recurso Atendedor do Sistema do Microsoft Exchange e clique em Remover Servidor Virtual do Exchange.

    • Em um cluster do Exchange 2000 Server, clique com o botão direito no recurso Atendedor do Sistema do Microsoft Exchange e clique em Excluir.

  4. Verifique se o objeto EVS foi removido do serviço de diretório do Active Directory®. Devido às alterações na permissão de conta de serviço de Cluster no Exchange Server 2003, sua conta deve ter permissão para remover objetos do Active Directory.

  5. Coloque os recursos restantes do segundo EVS (por exemplo, Disco Físico, Nome da Rede e Endereço IP) offline e exclua-os.

  6. Exclua o grupo de recursos que continha o segundo EVS.

Para obter mais informações sobre como remover um EVS, consulte a seção "Removendo um servidor virtual do Exchange de um Cluster" em Implantando clusters do Microsoft Exchange 2000 Server (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=9393).

Para obter mais informações sobre práticas recomendadas e recomendações para clusters do Exchange, consulte Guia de Implantação do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47569).

Para obter mais informações sobre como implantar o Exchange em um cluster de servidor Windows, consulte a Base de Dados de Conhecimento Microsoft, "Considerações ao implantar o Exchange em um cluster Ativo/Ativo" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815180).


Log de quorum muito pequeno
Microsoft Exchange Server Analyzer - Artigos > Cluster do Exchange >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar o tamanho do log de quorum configurado para o cluster:

HKEY_LOCAL_MACHINE\Cluster\Quorum\MaxQuorumLogSize

Se o Exchange Server Analyzer verificar que o valor de MaxQuorumLogSize é menor do que 4194304 decimal (0x400000 hexadecimal), será exibido um aviso.

O valor do Registro MaxQuorumLogSize representa o valor atualmente configurado para o parâmetro de quorum do cluster Redefinir o log de quorum em. Esse aviso será gerado se MaxQuorumLogSize for inferior a 4096 KB (quilobytes).

O cluster registra todas as alterações no seu banco de dados no arquivo de log de quorum. Quando o log de quorum atinge o tamanho especificado, o cluster salva o banco de dados e redefine o arquivo de log. Nos clusters baseados no Microsoft Windows® 2000 Server, o limite padrão do tamanho de quorum é 64 KB. Nos clusters baseados no Windows Server™ 2003, o limite padrão do tamanho de quorum é 4096 KB. Nos clusters do Exchange Server, recomenda-se que a propriedade Redefinir log de quorum em seja configurada como 4096 KB. Isso garante que haverá espaço suficiente para conter as informações de configuração do cluster, como quais servidores fazem parte do cluster, quais recursos estão instalados no cluster e qual é o estado desses recursos (por exemplo, online ou offline).

Para corrigir esse aviso

  1. Abra o Administrador do Cluster.

  2. No painel esquerdo, clique com o botão direito no objeto que representa o cluster e clique em Propriedades.

  3. Na guia Quorum, configure Redefinir log de quorum em com um valor de 4096.

  4. Clique em OK para salvar as alterações.

Para obter mais informações sobre o limite padrão do tamanho do log de quorum, consulte o artigo 225081 da Base de Dados de Conhecimento Microsoft, "O padrão do tamanho de log de quorum de recursos do cluster é 64 KB" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=225081).


Exchange Server
Microsoft Exchange Server Analyzer - Artigos >

Última modificação do tópico: 2005-11-18

Os artigos desta seção fornecem detalhes sobre o que a ferramenta Microsoft® Exchange Server Analyzer Tool está avaliando em relação aos computadores do Exchange Server. Além disso, esses artigos descrevem as ações que você pode tomar para resolver erros, avisos e configurações não-padrão relacionadas ao Exchange que são encontradas pelo Exchange Server Analyzer.


Bloqueio de Conta instalado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-08-28

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se existe um arquivo ALockout.dll na pasta System32 do servidor Exchange. O ALockout.dll faz parte das Ferramentas de Gerenciamento e Bloqueio de Conta (ALTools.exe). Essas ferramentas ajudam os administradores a gerenciar contas e a solucionar problemas de bloqueio de conta.

Se o Exchange Server Analyzer detectar a presença do arquivo ALockout.dll em um servidor Exchange, o Exchange Server Analyzer exibirá um erro.

As Ferramentas de Gerenciamento e Bloqueio de Conta não devem ser usadas em servidores que hospedam aplicativos ou serviços de rede, incluindo servidores Exchange. Se estiverem instaladas em um servidor Exchange, as Ferramentas de Gerenciamento e Bloqueio de Conta poderão impedir o início dos serviços do Exchange. Sendo assim, é altamente recomendável que você desinstale as Ferramentas de Gerenciamento e Bloqueio de Conta desse servidor Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse erro

  1. Em um prompt de comando, digite regsvr32 /u alockout.dll.

  2. Exclua o valor de ALockout.dll existente na seguinte chave de Registro: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs
Observação:
Após excluir o valor de ALockout.dll, a entrada do Registro AppInit_DLLs ficará vazia. Reinicie o computador.
  1. Exclua o arquivo ALockout.dll da pasta System32.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre as Ferramentas de Gerenciamento e Bloqueio de Conta, consulte "Ferramentas de bloqueio de conta" em Senhas e diretivas de conta (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=52465).


Incompatibilidade de site do Active Directory
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-03-16

A ferramenta Microsoft® Exchange Server Analyzer Tool implementa a função DsGetSiteName da API Win32 para consultar o nome do controlador de domínio do site do serviço de diretório do Active Directory® e o nome do Exchange Server local do site do Active Directory.

Se o Exchange Server Analyzer detectar que o nome do controlador de domínio do site do Active Directory e o nome do Exchange Server local do site do Active Directory não coincidem, será exibido um aviso.

Esse aviso indica que o processo DSAccess (Directory Service Access) está saindo o site local do Active Directory para suas solicitações do protocolo LDAP (Lightweight Directory Access Protocol), o que pode ocasionar uma drástica degradação no desempenho do Exchange Server.

Essa situação pode ser causada pela configuração estática de um controlador de domínio off-site, pela interrupção de uma rede ou do computador do controlador de domínio que torna inalcançável o controlador de domínio residente no site, ou por uma topologia do Active Directory elaborada incorretamente, que não contém um controlador de domínio do Active Directory no mesmo site que o Exchange Server.

O DSAccess é um componente compartilhado do Exchange Server, que acessa e armazena informações de diretórios em um cache. O DSAccess detecta dinamicamente os servidores de diretório que outros componentes do Exchange devem contatar, com base em critérios, como a configuração do site do Active Directory e a disponibilidade do servidor do Active Directory. Os servidores front-end do Exchange usam o DSAccess para determinar qual servidor contém a caixa de correio de um usuário específico, os endereços SMTP existentes para um objeto usuário, e os servidores que contêm armazenamentos de pastas públicas.

No decorrer da inicialização, se o DSAccess não encontrar um conjunto de controladores de domínio configurados estaticamente ou catálogos globais no Registro, ele usará um processo de descoberta para identificar a topologia da rede e avaliar a disponibilidade e adequação de servidores de diretórios. Parte da determinação da adequação de um controlador de domínio é se esse controlador está no mesmo site do Active Directory que o Exchange Server.

Para reduzir a latência introduzida por solicitações LDAP entre sites, os Exchange Servers devem estar localizados em um site do Active Directory que possua um controlador de domínio residente.

Para resolver esse problema:

  • Avalie as definições dos sites na topologia do Active Directory para verificar se todos os Exchange Servers têm acesso a um controlador de domínio no mesmo site do Active Directory.

  • Verifique se existe algum controlador de domínio configurado estaticamente residindo no mesmo site do Active Directory que o Exchange Server.

Para obter mais informações

Para obter mais informações sobre como configurar e solucionar problemas do DSAccess, consulte os seguintes recursos do Exchange:

  • Integração de diretórios e Exchange Server (http://go.microsoft.com/fwlink/?LinkId=63447)

  • Compreendendo e solucionando problemas de acesso a diretórios (http://go.microsoft.com/fwlink/?LinkId=39012)

  • Artigo 250570 da Base de Dados de Conhecimento da Microsoft, "Detecção do servidor de serviço de diretórios e uso do DSAccess" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)


Compartilhamentos de arquivos administrativos desabilitados
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se os compartilhamentos administrativos padrão foram desabilitados:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters\AutoShareServer

Se o Exchange Server Analyzer verificar que o valor de AutoShareServer está definido como 0, um erro será exibido.

Esse erro indica que os compartilhamentos administrativos padrão criados pelo servidor foram desabilitados nesse servidor. Um backup ou restauração online do Exchange Server pode não funcionar quando os compartilhamentos administrativos padrão estiverem desabilitados. Dependendo do programa de backup, você pode receber mensagens de erro ao tentar restaurar dados. Você também pode ver mensagens de erro no log de backup de fita.

Além disso, quando os compartilhamentos administrativos tiverem sido removidos, você poderá receber a seguinte mensagem durante um backup online do Exchange Server: Erro inesperado, 0xc0040000, o computador do Microsoft Exchange Server não está disponível. Para resolver esse problema, é recomendável que os compartilhamentos administrativos padrão sejam reabilitados, editando o Registro e reiniciando o serviço do Servidor.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

  3. No painel da direita, localize e clique duas vezes em AutoShareServer.

  4. Altere o valor de 0 para 1.

  5. Feche o editor de Registro e reinicie o serviço do Servidor para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como restaurar os compartilhamentos administrativos padrão no Microsoft Windows Server™ 2003, consulte o artigo 816113 da Base de Dados de Conhecimento, "COMO: Usar o editor de Registro para restaurar compartilhamentos administrativos no Windows Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816113).


Interoperabilidade entre conector X.400 e driver AFD.SYS
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar a versão do Microsoft Windows® que está executando no computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor de CurrentVersion igual a 4.0 indica que o computador do Exchange Server está executando no Microsoft Windows NT® Server 4.0. Um valor igual a 5.0 indica que o computador do Exchange Server está executando o Windows 2000 Server e um valor igual a 5.2 indica que o computador do Exchange Server está executando o Windows Server™ 2003.

O Exchange Server Analyzer também consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor definido para a chave NumberOfProcessors. Esse valor representa o número de processadores instalados no computador. Esses processadores abrangem processadores físicos e lógicos. É possível dividir um processador físico em dois processadores lógicos, usando a tecnologia hyper-threading da Intel.

O Exchange Server Analyzer também lê a seguinte entrada do Registro para determinar se o Exchange Server é um bridgehead para um conector X.400:

HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeMTA

Finalmente, o Exchange Server Analyzer consulta a classe CIM_Datafile do WMI para determinar o valor da chave Version para um arquivo denominado Afd.sys.

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • O computador do Exchange Server está executando no Windows Server 2000.

  • O valor de NumberOfProcessors é maior que 1.

  • O Exchange Server é um bridgehead para um conector X.400.

  • O valor da chave Version de WINDOWSPATH%\\system32\\drivers\\afd.sys está no intervalo de 5.0.2195.7036 e 5.0.2195.7060.

Esse aviso indica que a versão do Afd.sys instalada no servidor pode acarretar problemas de fluxo de mensagens nos conectores X.400 alojados nesse servidor.

Para resolver esse problema, obtenha a atualização citada no artigo 904712 da Base de Dados de Conhecimento Microsoft, "A entrega de mensagens é mais lenta do que o previsto ou a entrega de mensagens é interrompida em um conector X.400 para um site remoto no Exchange Server 5.5" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=904712) (em inglês).


O intervalo de tempo de duração de armazenamento para banco de dados é não padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-08

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar se o atributo msExchAgingKeepTime foi definido. Esse atributo representa o valor de horário usado para determinar quando remover índices, exibições e categorizações. Se o Analisador do Exchange Server detectar que esse atributo está definido, uma mensagem de configuração não padrão será exibida.

Os índices usados para exibições que são criados nas tabelas de bancos de dados do Exchange por um cliente do Exchange que não foram usados para um horário específico são eliminados nesse momento. O atributo msExchAgingKeepTime especifica o tempo mínimo do índice antes que seja excluído. O valor padrão na versão original do Exchange 2000 Server era de oito dias. No Service Pack 1 (SP1) para Exchange 2000 Server, e em todas as versões subseqüentes do Exchange Server, incluindo o Exchange Server 2003 e o Exchange Server 2007, o valor padrão é 40 dias.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou do Exchange Server 2007, ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para exibir ou modificar o valor Tempo de Duração de Armazenamento

  1. Inicie o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração, expanda CN=Serviços, CN=Microsoft Exchange e CN=<ExchangeOrganizationName>.

  3. Expanda CN=Grupos Administrativos, expanda CN=<AdministrativeGroupName> e CN=Servidores.

  4. Expanda CN=<ServerName>, expanda CN=InformationStore e selecioneCN=<StorageGroupName>.

  5. No painel de detalhes, clique com o botão direito em CN=<MailboxStoreName> e em Propriedades.

  6. No Editor de Atributos, clique no atributo msExchAgingKeepTime e clique em Editar.

  7. Na caixa Editar Atributo, clique em Limpar para limpar o valor.

  8. Clique em Aplicar e em OK.

  9. Fechar ADSI Edit. Se for feita uma alteração, reinicie o serviço de Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o utilitário LDP para modificar os atributos de objeto do Active Directory (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre possíveis problemas ao acessar pastas de armazenamento de informações no Exchange Server, consulte o artigo 216076 da Base de Dados de Conhecimento Microsoft, "O acesso a pastas de armazenamento de informações pode se tornar lento no Exchange" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=216076).


Atualização do Antigen disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-06-20

A ferramenta Microsoft Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft® Windows®) para determinar o valor da chave Version para MimeNavigator.dll. Esse módulo está incluído no Microsoft Antigen versões 8 e 9.

Se o Exchange Analyzer encontrar um valor da chave Version de MimeNavigator.dll menor que 8.00.1517.0 para a versão 8 e menor que 9.00.1055.0 para a versão 9, o Exchange Analyzer exibirá um aviso.

Esse aviso indica que o Microsoft Antigen versão 8 ou 9 está instalado no servidor Exchange e que uma atualização de software está disponível. Essa atualização é altamente recomendável e pode melhorar o desempenho e a confiabilidade gerais do servidor.

Para resolver esse problema, revise e aplique as recomendações encontradas no artigo 928082 da Base de Dados de Conhecimento Microsoft, O tamanho das mensagens SMTP pode aumentar durante o processo de verificação no Antigen (em inglês).


Tamanho do log do aplicativo
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-11-09

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar o tamanho máximo do arquivo de log do Aplicativo:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application\MaxSize

Se o Exchange Server Analyzer verificar que o valor de MaxSize é menor que 41.943.040 bytes (40 megabytes), o Exchange Server Analyzer exibirá uma mensagem de prática recomendada.

Por padrão, o tamanho máximo do arquivo de log do Aplicativo é de 16.777.216 bytes (16384 KB) para o Windows Server 2003 e de 524288 (512 KB) para o Windows 2000 Server. Para computadores que estejam executando o Exchange Server, a prática recomendada é definir o tamanho máximo do arquivo de log do Aplicativo com 40 MB (digitados como 40960KB) ou mais. Aumentando o tamanho do arquivo de log do Aplicativo, você preserva mais eventos do aplicativo. As informações de evento adicionais ajudam no momento de solucionar problemas.

Para aumentar o tamanho máximo do log do aplicativo

  1. Abra o snap-in Visualizar Eventos do MMC (Console de Gerenciamento Microsoft).

  2. Clique com o botão direito no log do Aplicativo e clique em Propriedades.

  3. Na guia Geral, em Tamanho do log, digite 40960 ou mais na caixa Tamanho máximo do log e clique em OK.


O Rootver do ASP.NET está danificado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar o valor definido na chave Rootver para ASP.NET:

HKEY_LOCAL_MACHINE\Software\Microsoft\ASP.NET

O Exchange Server Analyzer exibe um erro se existirem as seguintes condições:

  • O Exchange Server Analyzer descobre que o valor Rootver está definido como 0.0.0.0.

  • O serviço de Cluster está sendo executado.

Às vezes, a Instalação do ASP.NET falha sem fornecer uma notificação. Nesses casos, a chave Rootver é definida como 0.0.0.0. Definir o valor de Rootver como 0.0.0.0 faz com que o serviço Atendedor do Sistema do Microsoft Exchange ou outros serviços do Exchange Server não sejam iniciados em clusters do Exchange Server 2003 e do Exchange Server 2007. Você deve corrigir esse erro definindo o valor de Rootver como um dos seguintes:

  • Chave Rootver do Exchange Server 2003 = 1.1.4322.0.

  • Chave Rootver do Exchange Server 2007 = 2.0.50727.0

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para definir Rootver como 1.1.4322.0

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\Software\Microsoft\ASP.NET\

  3. No painel de detalhes, clique duas vezes na chave RootVer.

  4. Na caixa de diálogo Editar Cadeia de Caracteres, defina Dados do valor com o valor adequado mencionado no artigo acima e clique em OK.

  5. Saia do editor do Registro.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


A depuração automática do Sistema Operacional foi desabilitada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar se a depuração do sistema operacional foi desabilitada:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se o Analisador do Exchange Server detectar que o valor de Auto está definido como 0, será exibido um aviso.

Por padrão, um depurador de aplicativos denominado Dr. Watson é instalado com os sistemas operacionais Microsoft Windows® 2000 Server e Windows Server™ 2003. Um depurador é um programa que ajuda a detectar, localizar e corrigir erros em outro programa por meio da habilitação de um programador para acompanhar as etapas do programa, examinar os dados e monitorar condições como os valores de variáveis.

As opções padrão são configuradas na primeira vez em que o Dr. Watson é executado, o que pode ser quando ocorrer um erro de programa ou quando você mesmo iniciar o Dr. Watson.

Quando ocorrer um erro de aplicativo, o Windows procurará um identificador de erros de programas. Um identificador de erros de programas trata os erros à medida que ocorrem durante a execução de um programa. Se o Windows não encontrar um identificador de erros de programas, verificará que o programa não está sendo depurado no momento e considerará o erro não identificado. O Windows processará, então, erros não identificados procurando um depurador de erros de programas no Registro.

O comportamento do Windows depende das configurações de dois valores de Registro em: HKLM\Software\Microsoft\Windows NT\CurrentVersion\AeDebug

As entradas têm os nomes Debugger e Auto. O valor da entrada Debugger especifica o comando para o depurador que será usado para analisar erros de programa. Se o valor da entrada Debugger for encontrado, o Windows verificará se o valor da entrada Auto está definido como 0 ou 1:

  • Se o valor da entrada Auto estiver definido como 0, o Windows gerará uma caixa de mensagens que o notificará que ocorreu um erro de programa. Se o valor da entrada Debugger especificar o comando para um depurador válido, a caixa de mensagens exibirá dois botões: OK e Cancelar. Se você clicar em OK, o programa será interrompido. Se clicar em Cancelar, o depurador especificado será iniciado. Se o valor da entrada Debugger estiver vazio, a caixa de mensagens exibirá somente OK e nenhum depurador será iniciado.

  • Se o valor da entrada Auto estiver definido como 1 e o valor da entrada Debugger especificar o comando para um depurador válido, o sistema iniciará o depurador automaticamente e não gerará uma caixa de mensagens.

Quando o Windows é instalado, o valor da entrada Auto é definido, por padrão, como 1 e o valor da entrada Debugger especifica o comando para iniciar o Dr. Watson (drwtsn32 -p %ld -e %ld -g). Isso significa que quando ocorrer um erro de programa, o Dr. Watson diagnosticará automaticamente o erro e registrará as informações apropriadas de diagnóstico.

Recomenda-se que um depurador de erros de programa seja usado em computadores do Exchange Server. Se você utiliza um programa que não seja o Dr. Watson como seu depurador padrão e deseja começar a usar o Dr. Watson, vá para o prompt de comando e digite o comando drwtsn32 -i para iniciar o Dr. Watson. A digitação de -i faz com que as alterações necessárias sejam feitas no Registro.

Para registrar o Dr. Watson como o depurador padrão, no prompt de comando

  1. Abra uma janela de prompt de comando.

  2. Execute o seguinte comando: drwtsn32 -i

  3. Você receberá uma mensagem que diz "O Dr. Watson foi instalado como depurador padrão de aplicativos". Clique em OK para confirmar essa mensagem.

Para registrar o Dr. Watson como o depurador padrão, na interface de usuário

  1. Clique em Iniciar, clique em Executar, digite drwtsn32 e pressione ENTER. A interface de usuário Dr. Watson para Windows será exibida.

  2. Marque a caixa de seleção Criar Arquivo de Dumpster Rápido.

  3. Clique em OK para salvar as alterações e fechar a interface de usuário do Dr. Watson para Windows.

Para obter mais informações sobre o Dr. Watson para Windows, consulte o arquivo de Ajuda do Dr. Watson pressionando F1 na interface de usuário.

Se você pretende usar um depurador de erros de programas que não seja o Dr. Watson, poderá desabilitá-lo usando o procedimento do artigo 188296 da Base de Dados de Conhecimento da Microsoft, "Como desabilitar o Dr. Watson para Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296).


A latência média de leitura do LDAP excedeu 50 milissegundos
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-14

A ferramenta Microsoft Exchange Analyzer dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho LDAP Read Time do objeto de desempenho do MSExchangeDSAccess Process para analisar os dados do desempenho.

O contador de desempenho LDAP Read Time mostra o tempo em milissegundos que uma solicitação de leitura do LDAP (Lightweight Directory Access Protocol) demora para ser preenchida. O Exchange Analyzer recupera um exemplo a cada 5 segundos por 5 minutos. Em seguida, o Exchange Analyzer reporta o valor máximo do contador de desempenho durante o intervalo de coleta. Se o valor médio exceder 50 milissegundos, o Exchange Analyzer exibirá um aviso.

As latências altas de leitura do LDAP podem ser causadas pelas latências altas de RPC (chamada de procedimento remoto) e pelo aumento das filas. As latências altas de leitura do LDAP geralmente indicam um dos problemas a seguir:

  • Um problema de desempenho na conexão de rede com o controlador de domínio.

  • Problemas de desempenho no próprio controlador de domínio.

Observação:
As latências do LDAP normalmente são mais altas quando os usuários conectam-se a controladores de domínio localizados em locais físicos diferentes. No entanto, as latências máximas recomendadas citadas nesse artigo geralmente devem ser respeitadas.

Se o controlador de domínio que registrou em log esse aviso estiver localizado em um site físico diferente, você poderá ignorar esse erro com segurança, se puder determinar que o controlador de domínio que relata o aviso não será usado pelo servidor Exchange. Uma forma de determinar se um controlador de domínio é usado pelo Exchange é aumentar o log de diagnóstico do componente de Topologia do serviço MSExchangeDSAccess como Mínimo. Se você não vir o evento 2080 da ID do evento MSExchangeDSAccess, poderá ignorar esse aviso com segurança.

Para resolver esse aviso, proceda da seguinte forma:

  • Verifique se todas as conexões de rede com o controlador de domínio são funcionais e oferecem suporte ao tráfego do ICMP (Internet Control Monitoring Protocol).

  • Experimente as práticas recomendadas nos seguintes artigos:

    • Para obter informações sobre o contador de desempenho do LDAP Read Time e outros contadores que você pode usar para solucionar problemas relativos ao Active Directory, consulte o tópico "Evitando problemas ligados ao Active Directory" em Solucionando problemas de desempenho do Microsoft Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588). Esse artigo também contém informações sobre como melhorar o desempenho do Active Directory.

    • Para obter mais informações sobre como maximizar o desempenho do Active Directory, consulte o tópico "Active Directory Integration Tuning" no Performance and Scalability Guide for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Para obter informações sobre como verificar a alta disponibilidade de seus servidores do Active Directory, consulte as seções em Garantindo acesso confiável ao Active Directory e ao Sistema de Nome de Domínio no tópico "Medidas com tolerância a falhas no nível do sistema" no Guia de Alta Disponibilidade do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47571).

    • Para obter informações sobre considerações de largura de banda de rede, consulte a seção Network Performance no tópico "Understanding Exchange Performance" no Performance and Scalability Guide for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).


A latência de leitura LDAP máxima excedeu a 100 milessegundos
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-14

A ferramenta Microsoft Exchange Analyzer dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho LDAP Read Time do objeto de desempenho do MSExchangeDSAccess Process para analisar os dados do desempenho.

O contador de desempenho LDAP Read Time mostra o tempo em milissegundos que uma solicitação de leitura do LDAP (Lightweight Directory Access Protocol) demora para ser preenchida. O Exchange Analyzer recupera um exemplo a cada 5 segundos por 5 minutos. Em seguida, o Exchange Analyzer reporta o valor máximo do contador de desempenho durante o intervalo de coleta. Se o valor máximo exceder 100 milissegundos, o Exchange Analyzer exibirá um erro.

As latências altas de leitura do LDAP podem ser causadas pelas latências altas de RPC (chamada de procedimento remoto) e pelo aumento das filas. As latências altas de leitura do LDAP geralmente indicam um dos problemas a seguir:

  • Um problema de desempenho na conexão de rede com o controlador de domínio.

  • Problemas de desempenho no próprio controlador de domínio.

Observação:
As latências do LDAP normalmente são mais altas quando os usuários conectam-se a controladores de domínio localizados em locais físicos diferentes. No entanto, as latências máximas recomendadas citadas nesse artigo geralmente devem ser respeitadas.

Os servidores Exchange consultarão servidores de catálogo global fora do domínio a cada 15 minutos para manter uma lista atualizada de servidores de catálogo global e Controladores de Domínio. Como alguns desses servidores de diretório podem ser remotos, as latências nessas consultas podem ser altas. Isso é aceitável, desde que as solicitações não sejam freqüentes, ou seja, a taxa seja menor que 0,5 solicitação por segundo.

Se o controlador de domínio que registrou esse erro estiver localizado em um local físico diferente, talvez você possa ignorar esse erro com segurança se for possível determinar que o controlador de domínio que relata esse erro não é usado pelo servidor Exchange. Uma forma de determinar se um controlador de domínio é usado pelo Exchange é aumentar o log de diagnóstico do componente de Topologia do serviço do MSExchangeDSAccess para Mínimo. Se você não vir ID de evento 2080 do evento MSExchangeDSAccess, poderá ignorar esse erro com segurança.

Importante:
Apenas para ambientes de modo misto, o comportamento foi introduzido no intervalo de tempo do Exchange 2000 SP2 para certos atributos de usuário específicos relacionados à segurança, como tokenGroups e tokengroupsGlobalandUniversal, usados para determinar de quais grupos de segurança um usuário é membro e, portanto, quais permissões ele tem para recursos de segurança, como pastas públicas, que exigem que o servidor Exchange consulte um controlador de domínio que é autoritativo para o domínio local do usuário. O controlador de domínio autoritativo pode estar em um local remoto, e consultas de um grande número de usuários do domínio hospedado remotamente acessando pastas públicas locais poderiam contribuir para latências altas de RPC.

Para obter mais informações sobre esse comportamento, consulte o seguinte do blog do Exchange Server:

  • Exchange Does Not Always Use Local GCs (em inglês)

    Observação:
    São fornecidos links para blogs para ajudar você a achar as informações técnicas de que você precisa. O conteúdo de cada blog e sua URL estão sujeitos a alterações sem aviso.

Para resolver esse erro, proceda da seguinte forma:

  • Verifique se todas as conexões de rede com o controlador de domínio estão funcionando e se oferecem suporte ao tráfego do protocolo ICMP.

  • Experimente as práticas recomendadas nos seguintes artigos:

    • Para obter informações sobre o contador de desempenho do LDAP Read Time e sobre outros contadores que você pode usar para solucionar problemas relativos ao Active Directory, consulte o tópico "Evitando problemas ligados ao Active Directory" em Solucionando problemas de desempenho do Microsoft Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588). Esse artigo também contém informações sobre como melhorar o desempenho do Active Directory.

    • Para obter mais informações sobre como maximizar o desempenho do Active Directory, consulte o tópico "Active Directory Integration Tuning" no Performance and Scalability Guide for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Para obter informações sobre como verificar a alta disponibilidade de seus servidores do Active Directory, consulte as seções em Garantindo acesso confiável ao Active Directory e ao Sistema de Nome de Domínio no tópico "Medidas com tolerância a falhas no nível do sistema" no Guia de Alta Disponibilidade do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47571).

    • Para obter informações sobre considerações de largura de banda de rede, consulte a seção Network Performance no tópico "Understanding Exchange Performance" no Performance and Scalability Guide for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).


A latência média de pesquisa LDAP excedeu 50 milissegundos.
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-14

A ferramenta Microsoft Exchange Analyzer dispõe de um mecanismo de coleta de dados de desempenho usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho LDAP Search Time do objeto de desempenho do MSExchangeDSAccess Process para analisar os dados do desempenho.

O contador de desempenho LDAP Search Time mostra o tempo em milissegundos que uma solicitação de pesquisa do protocolo LDAP leva para ser concluída. O Exchange Analyzer recupera um exemplo a cada 5 segundos por 5 minutos. Em seguida, o Exchange Analyzer reporta o valor máximo do contador de desempenho durante o intervalo de coleta. Se o valor médio exceder 50 milissegundos, o Exchange Analyzer exibirá um aviso.

Latências de pesquisa do LDAP altas podem ser causadas por latências de RPC (chamada de procedimento remoto) altas e por filas crescentes. Latências de pesquisa do LDAP altas normalmente indicam um dos seguintes problemas:

  • Um problema de desempenho na conexão de rede com o controlador de domínio.

  • Problemas de desempenho no próprio controlador de domínio.

Observação:
As latências do LDAP normalmente são mais altas quando os usuários conectam-se a controladores de domínio localizados em locais físicos diferentes. No entanto, as latências máximas recomendadas citadas nesse artigo geralmente devem ser respeitadas.

Se o controlador de domínio que registrou em log esse aviso estiver localizado em um site físico diferente, você poderá ignorar esse erro com segurança, se puder determinar se o controlador de domínio que relata o aviso não será usado pelo servidor Exchange. Uma forma de determinar se um controlador de domínio é usado pelo Exchange é aumentar o log de diagnóstico do componente de Topologia do serviço do MSExchangeDSAccess para Mínimo. Se você não vir o evento 2080 da ID do evento MSExchangeDSAccess, poderá ignorar esse aviso com segurança.

Para resolver esse aviso, proceda da seguinte forma:

  • Verifique se todas as conexões de rede com o controlador de domínio estão funcionando e se suportam o tráfego do protocolo ICMP.

  • Experimente as práticas recomendadas nos seguintes artigos:

    • Para obter informações sobre o contador de desempenho do LDAP Read Time e sobre outros contadores que você pode usar para solucionar problemas relativos ao Active Directory, consulte o tópico "Evitando problemas ligados ao Active Directory" em Solucionando problemas de desempenho do Microsoft Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588). Esse artigo também contém informações sobre como melhorar o desempenho do Active Directory.

    • Para obter mais informações sobre como maximizar o desempenho do Active Directory, consulte o tópico "Active Directory Integration Tuning" no Performance and Scalability Guide for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Para obter informações sobre como verificar a alta disponibilidade de seus servidores do Active Directory, consulte as seções em Garantindo acesso confiável ao Active Directory e ao Sistema de Nome de Domínio no tópico "Medidas com tolerância a falhas no nível do sistema" no Guia de Alta Disponibilidade do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47571).

    • Para obter informações sobre considerações de largura de banda de rede, consulte a seção Network Performance no tópico "Understanding Exchange Performance" no Performance and Scalability Guide for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).


A latência de pesquisa máxima do LDAP excedeu 100 milissegundos
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-14

A ferramenta Microsoft Exchange Analyzer dispõe de um mecanismo de coleta de dados de desempenho usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho LDAP Search Time do objeto de desempenho do MSExchangeDSAccess Process para analisar os dados do desempenho.

O contador de desempenho LDAP Search Time mostra o tempo em milissegundos que uma solicitação de pesquisa do protocolo LDAP leva para ser concluída. O Exchange Analyzer recupera um exemplo a cada 5 segundos por 5 minutos. Em seguida, o Exchange Analyzer reporta o valor máximo do contador de desempenho durante o intervalo de coleta. Se o valor máximo exceder 100 milissegundos, o Exchange Analyzer exibirá um erro.

Latências de pesquisa do LDAP altas podem ser causadas por latências de RPC (chamada de procedimento remoto) altas e por filas crescentes. Latências de pesquisa do LDAP altas normalmente indicam um dos seguintes problemas:

  • Um problema de desempenho na conexão de rede com o controlador de domínio.

  • Problemas de desempenho no próprio controlador de domínio.

Observação:
As latências do LDAP normalmente são mais altas quando os usuários conectam-se a controladores de domínio localizados em locais físicos diferentes. No entanto, as latências máximas recomendadas citadas nesse artigo geralmente devem ser respeitadas.

Os servidores Exchange consultarão servidores de catálogo global fora do domínio a cada 15 minutos para manter uma lista atualizada de servidores de catálogo global e controladores de domínio. Como alguns desses servidores de diretório podem ser remotos, as latências nessas consultas podem ser altas. Isso é aceitável, desde que as solicitações não sejam freqüentes, ou seja, a taxa seja menor que 0,5 solicitação por segundo.

Se o controlador de domínio que registrou esse erro estiver localizado em um local físico diferente, talvez você possa ignorar esse erro com segurança se for possível determinar que o controlador de domínio que relata esse erro não é usado pelo servidor Exchange. Uma forma de determinar se um controlador de domínio é usado pelo Exchange é aumentar o log de diagnóstico do componente de Topologia do serviço do MSExchangeDSAccess para Mínimo. Se você não vir ID de evento 2080 do evento MSExchangeDSAccess, poderá ignorar esse erro com segurança.

Importante:
Apenas para ambientes de modo misto, o comportamento foi introduzido no intervalo de tempo do Exchange 2000 SP2 para determinados atributos de usuário específicos relacionados à segurança, como tokenGroups e tokengroupsGlobalandUniversal. Esses atributos foram usados para determinar de quais grupos de segurança um usuário é membro e, portanto, quais permissões ele tem para recursos de segurança, como pastas públicas que exigem que o servidor Exchange consulte um controlador de domínio que seja autoritativo para o domínio local do usuário. O controlador de domínio autoritativo pode estar em um local remoto e consultas de um grande número de usuários do domínio hospedado remotamente acessando pastas públicas locais podem contribuir para latências altas de RPC.

Para obter mais informações sobre esse comportamento, consulte o seguinte artigo do blog do Exchange Server:

  • Exchange Does Not Always Use Local GCs (em inglês)

    Observação:
    São fornecidos links para blogs para ajudar você a achar as informações técnicas de que você precisa. O conteúdo de cada blog e sua URL estão sujeitos a alterações sem aviso.

Para resolver esse erro, proceda da seguinte forma:

  • Verifique se todas as conexões de rede com o controlador de domínio estão funcionando e se suportam o tráfego do protocolo ICMP.

  • Experimente as práticas recomendadas nos seguintes artigos:

    • Para obter informações sobre o contador de desempenho do LDAP Read Time e sobre outros contadores que você pode usar para solucionar problemas relativos ao Active Directory, consulte o tópico "Evitando problemas ligados ao Active Directory" em Solucionando problemas de desempenho do Microsoft Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588). Esse artigo também contém informações sobre como melhorar o desempenho do Active Directory.

    • Para obter mais informações sobre como maximizar o desempenho do Active Directory, consulte o tópico "Active Directory Integration Tuning" no Performance and Scalability Guide for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Para obter informações sobre como verificar a alta disponibilidade de seus servidores do Active Directory, consulte as seções em Garantindo acesso confiável ao Active Directory e ao Sistema de Nome de Domínio no tópico "Medidas com tolerância a falhas no nível do sistema" no Guia de Alta Disponibilidade do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47571).

    • Para obter informações sobre considerações de largura de banda de rede, consulte a seção Network Performance no tópico "Understanding Exchange Performance" no Performance and Scalability Guide for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).


Não é possível identificar o gateway do Exchange especificado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-08-08

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para obter o nome (cn) de cada objeto de diretório com uma classe de objeto de msExchExchangeServer, para determinar se existe uma correspondência para o servidor gateway do Exchange, especificado pelo usuário.

O valor cn é uma cadeia de caracteres que contém o nome curto do computador do Exchange Server.

Se o Exchange Server Analyzer não encontrar uma correspondência do valor do cn para o servidor gateway do Exchange, especificado pelo usuário, será exibido um erro.

Esse processo indica que uma das condições a seguir é verdadeira:

  • O servidor gateway do Exchange, especificado pelo usuário não existe na organização local do Exchange Server.

  • O servidor gateway do Exchange, especificado pelo usuário foi digitado incorretamente.

Para resolver esse erro, certifique-se de que o servidor gateway especificado do Exchange foi digitado corretamente e repita a operação.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar a ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você pode causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para verificar o valor do nome do servidor (cn)

  1. No ADSI Edit ou em uma ferramenta semelhante, localize o objeto servidor no Active Directory.

    É possível encontrar o atributo CN em:

    Código da Cópia
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server.


O comprimento da fila do categorizador está acima do limite
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Categorizer Queue Length do objeto de desempenho de SMTP Server para analisar os dados do desempenho.

Ao determinar que o contador de Categorizer Queue Length excedeu o valor de pico de 10 durante o intervalo de tempo de amostragem, o Analisador do Exchange Server exibirá um erro.

O contador SMTP Server\Categorizer Queue Length indica o número de mensagens na fila do Categorizador SMTP aguardando pesquisas do atributo do serviço de diretório usando servidores de catálogo global.

O categorizador executa as seguintes operações principais:

  • Resolve e valida todos os destinatários.

  • Determina limites e restrições para todos os destinatários.

  • Expande listas de distribuição, caso necessário.

  • Determina se a mensagem é para entrega local ou remota

Esse erro indica que pode haver problemas no desempenho do servidor ou da rede, no Directory Service Access (DSAccess), no serviço de diretório do Active Directory®, ou interrupções em servidores principais na organização do Exchange Server. Um aumento no contador Categorizer Queue Length pode indicar uma resposta lenta ou ausência de resposta na consulta ao Active Directory ou na liberação de mensagens para entrega local ou SMTP. Isso pode gerar um atraso na entrega de mensagens.

Para corrigir esse erro:

  • Verifique se há recursos suficientes do Active Directory disponíveis para o servidor Exchange. Isso inclui controladores de domínio e servidores de catálogo global. A prática recomendada é manter uma proporção de 4:1 entre processadores do servidor Exchange e processadores do servidor de catálogo global com velocidade semelhante.

  • A partir do Gerenciador do Sistema do Exchange, verifique se todos os controladores de domínio listados na guia DSAccess do servidor Exchange estão funcionando corretamente. Isso inclui os servidores listados nas funções do ConfigDC, controlador de domínio e servidor de catálogo global.

  • Monitore o desempenho de rede entre o servidor Exchange e seus controladores de domínio e servidores de catálogo global escolhidos para determinar se existe um afunilamento de desempenho de rede.

  • Monitore a utilização do processador no servidor Exchange e também a utilização do processador do processo Inetinfo.exe. Isso inclui o componente do categorizador.

  • Verifique a integridade de objetos de grupo e de usuário relacionados ao Exchange, usando o objeto de configuração e2kdsinteg da ferramenta ConfigDSInteg em Ferramentas de Implantação do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21231). Objetos com endereços mal formados ou informações incompletas podem gerar atrasos na determinação do destinatário e atrasar a categorização.

Para obter mais informações

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).


O arquivo CDO.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, onde <unidade> é a unidade de CD-ROM.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


Atualização do CimWin32.dll disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-09-19

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar a versão do Microsoft Windows® que está executando no computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor de CurrentVersion igual a 4.0 indica que o computador do Exchange Server está executando no Microsoft Windows NT® Server 4.0. Um valor igual a 5.0 indica que o computador do Exchange Server está executando o Windows 2000 Server e um valor igual a 5.2 indica que o computador do Exchange Server está executando o Windows Server™ 2003.

O Exchange Server Analyzer também consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar o valor definido para a chave Version do arquivo Cimwin32.dll.

O Exchange Server Analyzer exibe uma mensagem de prática recomendada se as seguintes condições forem verdadeiras:

  • O computador Exchange Server está executando no Windows 2000 Server.

  • O valor da chave Version corresponde a uma versão específica do arquivo Cimwin32.dll.

Há uma atualização do arquivo Cimwin32.dll que permitirá que o Exchange Server Analyzer funcione com mais eficiência.

Para resolver este problema, examine e aplique as recomendações contidas no artigo 820608 da Base de Dados de Conhecimento Microsoft, "CIM_DataFile class returns an incorrect or null value for files that are larger than 2 GB in Windows 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=820608) (em inglês).


O impacto de aplicativos cliente no desempenho do servidor
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer determinou que você possui tipos específicos de computadores clientes ou aplicativos de cliente que podem estar aumentando a carga do servidor em sua organização do Exchange.

Muitos aplicativos podem aumentar a carga no servidor. Se a carga tiver aumentado, você deve investigar quais aplicativos os usuários estão executando e decidir se deseja restringir a execução de certos aplicativos pelos usuários. Alguns aplicativos que acessam email (aplicativos de terceiros ou plug-ins do Microsoft Office Outlook®) podem aumentar a carga no servidor. Se o servidor sofrer um aumento nas latências de RPC (chamada de procedimento remoto) ou um aumento na carga, é recomendável que você investigue a origem.

Você pode usar o ExMon (Monitor de Usuários do Exchange Server) para identificar usuários que estejam enfrentando altas latências ou aumentando a carga no servidor. Para baixar o ExMon, consulte o Centro de Download da Microsoft (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=54983).

Procedimento

Para corrigir esse aviso

  • Use o ExMon para identificar quais usuários estão causando um aumento na carga do servidor. Depois que os usuários forem identificados, entre em contato com eles e determine se os seguintes aplicativos estão causando a carga adicional:

    • Plug-ins de computadores clientes de terceiros

    • Dispositivos de sincronização de área de trabalho, como Exchange ActiveSync® ou Blackberry

    • Outros aplicativos MAPI, como mecanismos de pesquisa de área de trabalho

    Se esses aplicativos não forem usados para fins comerciais, ou se tiverem um hotfix publicado, desative os aplicativos ou os atualize para reduzir a carga para um nível adequado.

  • Configure os computadores clientes com a operação mais dispendiosa (especialmente aqueles com latências longas em operações Restrict, SetColumns ou FindRow) para usar o modo do Exchange em cache. O modo do Exchange em cache isola o servidor da maior parte do excesso de tráfego RPC.

    Além disso, encoraja os usuários que possuem muitos itens em suas pastas a arquivar dados mais antigos em um arquivo .pst. Ou, se esses usuários quiserem manter seus dados no servidor, os encoraja a mover os itens mais antigos para pastas criadas recentemente.

    Por fim, é recomendável que você mantenha os itens das pastas Caixa de Entrada, Calendário, Itens Enviados, Contatos e Itens Excluídos abaixo de 5.000.
Observação:
Alguns aplicativos podem aumentar significativamente a carga no servidor sem emitir um grande número de operações MAPI. Isso ocorre porque algumas operações são mais dispendiosas que outras. Pode ser necessário apenas um pequeno aumento no número de operações dispensiosas para que haja um impacto perceptível no desempenho do servidor. No ExMon, esses usuários são relatados como tendo um impacto relativamente alto na CPU, sem necessariamente emitirem um grande número de operações MAPI.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Para obter mais informações sobre solução de problemas de desempenho do cliente Outlook, consulte "Usuários do Outlook enfrentam desempenho inadequado quando trabalham com uma pasta que contém muitos itens em um servidor que esteja executando o Exchange Server 2003 ou o Exchange 2000 Server" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)

  • Para obter mais informações sobre o software de pesquisa de área de trabalho, consulte o artigo 905184 da Base de Dados de Conhecimento da Microsoft, "Exchange 2000 Server and Exchange Server 2003 performance may be affected when desktop search engine software is running on Outlook or other MAPI client computers" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184).


O caminho TEMP do cluster é inválido ou não padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

Em um computador do Exchange Server sem cluster, a ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas de Registro para determinar o valor da variável de ambiente TEMP:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

Quando o Exchange Server Analyzer é executado no EVS (Servidor Virtual do Exchange) em um cluster do servidor Microsoft Windows®, ele não lê a seção de Registro do HKLM. Em vez disso, o Exchange Server Analyzer lê a seguinte entrada de Registro:

HKEY_USERS\< SID da conta de serviço do cluster >\Environment\TEMP

Se o Exchange Server Analyzer verificar que a variável de ambiente TEMP não está definida para um caminho disponível no sistema atual, um aviso será exibido. Se esse caminho for inválido, sua organização pode sofrer falha na entrega de mensagens. Por padrão, o Exchange Server Analyzer em sua configuração padrão espera localizar esse caminho definido como %USERPROFILE%\Local Settings\Temp. Embora esse caminho possa ser modificado para apontar para outros locais, após a aplicação de um hotfix ou atualização e a reinicialização do nó do cluster, o sistema pode esperar localizar o caminho com a definição padrão.

A variável de ambiente TEMP é usada para designar a pasta no sistema de arquivos que deve ser usada por aplicativos que exigem espaço de trabalho temporário. TEMP normalmente é usada por aplicativos, como o Exchange Server. O caminho para cada variável geralmente é relativo ao contexto do aplicativo. Por exemplo, os processos do serviço Armazenamento de Informações do Microsoft Exchange usam a pasta TEMP como armazenamento temporário durante várias operações, como conversão de mensagem e movimentação de caixa de correio.

Para corrigir esse aviso

  1. Faça logon em um nó do cluster como a conta de serviço do Cluster.

  2. Clique com o botão direito em Meu Computador e selecione Propriedades.

  3. Selecione Avançado.

  4. Clique em Variáveis de Ambiente.

  5. Na área Variáveis de usuário para área <nome de conta>, selecione TEMP e clique em Editar.

  6. No campo de valor Variável, digite o caminho padrão para a variável de ambiente TEMP e clique em OK.

  7. Clique em OK para fechar a caixa de diálogo Variáveis de Ambiente e clique em OK novamente para fechar a caixa de diálogo Propriedades do Sistema.

  8. Reinicie o nó para aplicar a alteração.

  9. Repita as etapas de 1 a 8 para cada nó do cluster que tiver a configuração não padrão.


Considere usar várias réplicas do catálogo de endereços offline
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-08-14

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Exchange_PublicFolder de WMI (Instrumentação de Gerenciamento do Microsoft Windows®) no namespace root\MicrosoftExchangeV2 para determinar o número de entradas na chave ReplicaList. O número de entradas representa o número de réplicas de catálogo de endereços offline presentes em cada grupo administrativo.

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o número de objetos de banco de dados de pasta pública como o atributo legacyExchangeDN definido. O número de objetos com esse atributo definido representa o número de armazenamentos de pasta pública existentes na organização.

Se o Exchange Server Analyzer determinar que existe apenas uma réplica de um catálogo de endereços offline em uma organização do Exchange com vários armazenamentos de pasta pública, será exibida uma mensagem de prática recomendada.

Para disponibilidade e desempenho, recomendamos que você considere a implementação de várias réplicas para cada catálogo de endereços offline. Em algumas situações, várias réplicas de catálogos de endereços offline podem aumentar o desempenho e a resiliência. Em organizações grandes do Exchange, uma única réplica de um catálogo de endereços offline pode ficar sobrecarregada. Em todas as organizações do Exchange, uma única réplica de um catálogo de endereços offline é um ponto de falha único.

Apesar de várias réplicas causarem tráfego adicional de replicação na rede, é recomendável usá-las. Deve haver, no mínimo, duas réplicas de cada catálogo de endereços offline.

Para adicionar réplicas de um catálogo de endereços offline a uma organização do Exchange

  1. Abra o Gerenciador do Sistema do Exchange

  2. Expanda Pastas, clique com o botão direito em Pastas Públicas e selecione Exibir Pastas do Sistema. Observação Se o nó Pastas não estiver visível, expanda Grupos Administrativos e expanda o grupo administrativo que contém as pastas do sistema que você deseja exibir. Em seguida, clique com o botão direito em Pastas Públicas e selecione Exibir Pastas do Sistema.

  3. Expanda o contêiner OFFLINE ADDRESS BOOK e clique com o botão direito no Catálogo de Endereços Offline para o qual deseja adicionar uma réplica, selecionando Propriedades na lista suspensa.

  4. Selecione a guia Replicação e clique em Adicionar para selecionar o Armazenamento Público ao qual deseja adicionar a réplica. Clique em OK para terminar.

  5. Repita as etapas 3 e 4 para todos os objetos filho no contêiner de Catálogos de Endereços Offline para o qual deseja uma réplica. Essa repetição garantirá que todos os formatos com suporte sejam incluídos na réplica, isto é, especificamente Adicionar os objetos filho OAB Versão 2, OAB Versão 3a e assim por diante.

Para obter mais informações sobre como gerenciar e configurar catálogos de endereços offline, consulte os seguintes artigos do Microsoft Exchange Server TechCenter:

  • "Catálogo de Endereços Offline - Aspectos a serem considerados" (http://go.microsoft.com/fwlink/?LinkId=57581)

  • "Trabalhando com Armazenamentos do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47595).

  • O "Guia de práticas recomendadas do Catálogo de Endereços Offline" (http://go.microsoft.com/fwlink/?LinkId=47583).

  • "OAB versão 4 no Exchange Server 2003 Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=53097).

  • "Como o Outlook 2003 SP2 e o Exchange Server 2003 SP2 OAB Versão 4 trabalham juntos" (http://go.microsoft.com/fwlink/?linkid=53099).


Conexão com o controlador de domínio do Serviço de Atualização de Destinatário
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-05-18

A ferramenta Microsoft® Exchange Server Analyzer Tools abre uma conexão do soquete TCP para a porta 389 em cada controlador de domínio. Essa conexão é feita com um processador de objetos personalizado que retorna uma cadeia de caracteres específica se a conexão é bem-sucedida.

Se o Exchange Server Analyzer não receber 389 Available como parte da cadeia de caracteres retornada, é exibido um aviso.

Esse aviso indica que o controlador de domínio não respondeu a uma tentativa de conexão na porta TCP 389. A porta TCP 389 é a porta padrão para comunicações de protocolo LDAP. Se você receber esse aviso, alguma das seguintes condições pode existir:

  • Podem estar ocorrendo problemas de conectividade entre o Exchange Server Analyzer e o controlador de domínio.

  • O servidor pode estar inativo.

  • O servidor pode ter sido descomissionado.

Há vários motivos pelos quais as solicitações LDAP podem não ser corretamente atendidas por um controlador de domínio quando o Exchange Server Analyzer consulta esse controlador.

Para corrigir esse aviso

  1. Verifique se a conta que está executando o Exchange Server Analyzer está autorizada a consultar o controlador de domínio. Você deve ter permissões de nível de Usuário no domínio em que o controlador de domínio está sendo executado. Você pode localizar mais informações sobre as permissões necessárias para executar o Exchange Server Analyzer no arquivo da Ajuda incluído no Exchange Server Analyzer. Para abrir o arquivo da Ajuda, no Exchange Server Analyzer, clique em Ajuda e em Ajuda da ferramenta Microsoft Exchange Server Analyzer Tool.

  2. Verifique se não há firewalls ou restrições de porta entre o computador que está executando o Exchange Server Analyzer e o controlador de domínio que não respondeu.

  3. Verifique se o controlador de domínio está conectado à rede e funcionando corretamente.

  4. Verifique se o servidor não foi descomissionado e ainda está listado como um controlador de domínio disponível para o Exchange Server.

Para obter mais informações, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 319065, "Como trabalhar com o Serviço de Atualização de Destinatário do Exchange" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065)

  • 816103, "COMO FAZER PARA: Usar o Portqry para solucionar problemas de conectividade do Active Directory" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103).


A indexação de conteúdo está habilitada para este armazenamento de pasta pública, mas as atualizações não estão agendadas
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo garbageCollPeriod de cada armazenamento de pasta pública. O valor desse atributo indica se a indexação de conteúdo foi habilitada para o armazenamento de pasta pública. Um valor True indica que existe um índice de conteúdo para armazenamento de uma pasta pública e que a configuração do Gerenciador do Sistema do Exchange Este índice está disponível atualmente para os clientes pesquisarem está selecionada. Um valor False indica que existe um índice de conteúdo para armazenamento de uma pasta pública, mas que a configuração do Gerenciador do Sistema do Exchange Este índice está disponível atualmente para os clientes pesquisarem não está selecionada. Um valor <Not Set> indica que não existe um índice de conteúdo para o armazenamento de pasta pública.

O Analisador do Exchange Server também consulta o Active Directory para determinar o valor do atributo msExchCIRebuildSchedule do armazenamento de cada pasta pública. O valor desse atributo indica as configurações do agendamento de reconstrução para o índice de conteúdo. Esse atributo é armazenado como uma seqüência de octeto com 82 pares de valores hexadecimais.

Se o Analisador do Exchange Server detectar o valor do atributo msExchCIAvailable definido como True, mas o valor da cadeia de caracteres do octeto do atributo msExchCIRebuildSchedule se traduzir como Nunca executar, um aviso será exibido.

A prática recomendada para definição do intervalo de atualização é agendar atualizações incrementais pelo menos uma vez ao dia. Você pode querer agendar atualizações mais freqüentes, porque o índice só é atualizado quando é preenchido. Índices sem atualizações regulares podem produzir resultados imprecisos e desatualizados.

Você deve considerar também o tempo necessário para concluir um preenchimento incremental. Por exemplo, um agendamento típico define atualizações incrementais no início de cada hora. No entanto, se a atualização demorar mais de uma hora, o próximo preenchimento incremental será iniciado no começo da próxima hora.

Geralmente, se o armazenamento de pasta pública for de 6 GB (gigabytes) ou menos, será possível executar atualizações incrementais a cada hora. Se o armazenamento tiver mais do que 6 GB, ou se o servidor estiver com alto uso de memória, você poderá querer atualizar o índice com menos freqüência.

Para configurar o Intervalo de Atualização da indexação do texto completo no armazenamento de uma pasta pública específica

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos, expanda o seu grupo administrativo, expanda Servidores, expanda o seu servidor, expanda o seu grupo de armazenamento, clique com o botão direito no armazenamento de pasta pública e clique em Propriedades. Se o nó Grupos Administrativos não for exibido no Gerenciador do Sistema do Exchange, expanda Servidores, clique com o botão direito em seu servidor e clique em Propriedades.

  3. Na guia Indexação de Texto Completo, selecione uma opção que não seja Nunca executar.

  4. Se você escolher Usar agenda personalizada, clique em Personalizar, defina sua própria agenda personalizada e clique em OK.

  5. Clique em Aplicar.

Para obter mais informações sobre a indexação do texto completo para o Exchange Server, consulte Práticas recomendadas para implantação de indexação de texto completo (http://go.microsoft.com/fwlink/?linkid=5223).


A indexação de conteúdo está habilitada para este armazenamento de caixa de correio, mas as atualizações não estão agendadas
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchCIAvailable de cada armazenamento de caixa de correio. O valor desse atributo indica se a indexação do conteúdo foi habilitada para o armazenamento da caixa de correio. Um valor igual a VERDADEIRO indica que existe um índice de conteúdo para o armazenamento de uma caixa de correio e que a configuração "Este índice está disponível atualmente para os clientes pesquisarem" do Gerenciador de Sistema do Exchange está selecionada. Um valor igual a FALSO indica que existe um índice de conteúdo para o armazenamento de caixa de correio, mas a configuração "Este índice está disponível atualmente para os clientes pesquisarem" está desmarcada. Um valor igual a <Não Definido> indica que um índice de conteúdo não existe para o armazenamento de caixa de correio.

O Exchange Server Analyzer solicita também que o Active Directory determine o valor do atributo msExchCIRebuildSchedule de cada armazenamento de caixa de correio. O valor desse atributo indica as configurações do agendamento de reconstrução para o índice de conteúdo. Esse atributo é armazenado como uma seqüência de octeto com 82 pares de valores hexadecimais.

Se o Exchange Server Analyzer detectar o valor do atributo msExchCIAvailable definido como VERDADEIRO, mas o valor da cadeia de caracteres em octeto para o atributo msExchCIRebuildSchedule converter para "Nunca executar", um aviso será exibido.

A prática recomendada para definição do intervalo de atualização é agendar atualizações incrementais pelo menos uma vez ao dia. Você pode querer agendar atualizações mais freqüentes, porque o índice só é atualizado quando é preenchido. Índices sem atualizações regulares podem produzir resultados imprecisos e desatualizados.

Você também deve considerar o tempo necessario para concluir um preenchimento incremental. Por exemplo, um agendamento típico define atualizações incrementais no início de cada hora. No entanto, se a atualização demorar mais de uma hora, o próximo preenchimento incremental será iniciado no começo da próxima hora.

Geralmente, se o armazenamento da caixa de correio for de 6 GB ou menor, você poderá executar atualizações incrementais a cada hora. Se o armazenamento tiver mais do que 6 GB, ou se o servidor estiver com alto uso de memória, você poderá querer atualizar o índice com menos freqüência.

Para definir o Intervalo de Atualização de indexação de texto completo em um determinado armazenamento de caixa de correio

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos, expanda o seu grupo administrativo, expanda Servidores, expanda o seu servidor, expanda o seu grupo de armazenamento, clique com o botão direito no armazenamento de caixa de correio e clique em Propriedades. Se o nó Grupos Administrativos não for exibido no Gerenciador do Sistema do Exchange, expanda Servidores, clique com o botão direito em seu servidor e clique em Propriedades.

  3. Na guia Indexação de Texto Completo, escolha uma opção diferente de Nunca executar.

  4. Se você escolher Usar agenda personalizada, clique em Personalizar, defina sua própria agenda personalizada e clique em OK.

  5. Clique em Aplicar.

Para obter mais informações sobre como configurar e solucionar problemas com indexação de texto completo, consulte o artigo 822932 da Base de Dados de Conhecimento da Microsoft, "COMO: Configurar indexação de texto completo em armazenamentos de caixa de correio no Exchange 2003" (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932) e o artigo 319436, "Como configurar indexação de texto completo em armazenamentos de caixa de correio no Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436).

Para obter mais informações sobre a indexação de texto completo no Exchange Server, consulte Práticas recomendadas para implantação de indexação de texto completo (http://go.microsoft.com/fwlink/?LinkId=5223).


Atualização de Conteúdo Disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-06-21

Para obter mais informações, consulte a página Download da documentação do Exchange Server 2007.


Atualização do driver CQPCIDRV.SYS disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-08-14

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar a versão do Microsoft Windows® em execução no servidor do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor de CurrentVersion igual a 4.0 indica que o servidor Exchange está executando o Microsoft Windows NT® Server 4.0. Um valor 5.0 indica que o servidor Exchange está executando o Windows 2000 Server. Um valor 5.2 indica que o computador do Exchange Server está executando o Windows Server™ 2003.

O Exchange Server Analyzer também examina a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®), Win32_Processor, para conhecer o valor da chave DataWidth.

Uma chave DataWidth com o valor 32 indica que o servidor está executando uma versão de 32 bits do sistema operacional Windows, enquanto uma DataWidth com o valor 64 indica que o servidor está executando uma versão de 32 bits do sistema operacional Windows.

Por último, o Exchange Server Analyzer consulta a classe WMI CIM_Datafile para determinar o valor da chave Version para um arquivo CpqCiDrv.sys.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O servidor Exchange está executando o Windows Server 2003.

  • O servidor Exchange está executando uma versão de 64 bits do sistema operacional Windows.

  • A versão do driver Integrated Lights-Out Management Interface da HP, CPQCIDRV.sys, é anterior à 1.8.

Este erro indica que a versão do CpqCiDrv.sys instalada no servidor pode ocasionar erros de alocação de memória do kernel.

Para resolver este problema, siga a orientação do fornecedor contida na Identificação do Documento: c00688313 (http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00688313).

Observação:
As informações sobre sites da Web de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


CrashOnAuditFail em vigor
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar se o parâmetro CrashOnAuditFail foi definido:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA\CrashOnAuditFail

Se o Exchange Server Analyzer verificar que o valor de CrashOnAuditFail for igual a 2, será exibido um erro.

O objetivo da chave do Registro CrashonAuditFail é configurar um servidor para que os usuários finais não tenham acesso permitido ao computador quando os logs de segurança atingirem o limite de tamanho configurado. Não permitir o acesso ao computador garante que não sejam perdidas informações de auditoria que de outra forma seriam registradas.

Quando habilitada, a chave do Registro CrashonAuditFail é definida com o valor 1. No entanto, quando o limite do log de Segurança é atingido, o servidor configura a chave do Registro com o valor 2, que por sua vez, pára o processamento no servidor. Às vezes, esse processo causa uma falha total, ou STOP 0xC0000244, também conhecido como erro de Parada. No mínimo, os usuários não poderão acessar recursos do servidor e o desempenho diminuirá muito. Além disso, quando o servidor está nesse estado, apenas usuários com permissões de administrador podem acessar o computador.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Control\LSA.

  3. Exclua o valor chamado CrashOnAuditFail (é necessário excluir o valor inteiro, não apenas os dados do valor).

  4. Copie os logs de evento de segurança em um local separado. Por padrão, os logs de evento de segurança (SecEvent.Evt) estão localizados em %SystemRoot% \System32\Config, onde %SystemRoot% é o caminho no qual o sistema operacional Microsoft Windows® está instalado.

  5. Abra Visualizar Eventos, clique com o botão direito em Segurança e clique em Propriedades.

  6. Na página Propriedades de Segurança, clique em Limpar Log. Ao ser solicitado a salvar o log, clique em Sim e especifique um local para salvar o arquivo de log.

    Observação Na página Propriedades de Segurança, você também pode aumentar o tamanho do log, editando o campo Tamanho máximo do log e clicando em Aplicar.

  7. Reinicie o serviço.

  8. Verifique se os usuários podem acessar os recursos do servidor fazendo logon em uma caixa de correio do Exchange.

  9. Recrie a chave do Registro CrashonAuditFail e defina os dados do valor como 1.

  10. Reinicie o servidor para que as configurações de CrashonAuditFail entrem em vigor.

  11. Limpe e salve periodicamente os Logs de Segurança do servidor, para que o tamanho máximo de log não seja excedido. Para obter mais informações, consulte o artigo 312571 da Base de Dados de Conhecimento Microsoft, "O log de eventos pára de registrar eventos antes de atingir o tamanho máximo de log" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312571).

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre recuperação de falhas do CrashOnAuditFail, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 232564, "STOP 0xC000024 quando o log de segurança está cheio" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232564)

  • 829082, "Você recebe uma mensagem de erro "Erro de Parada 0xC0000244 {Auditoria Falhou}" quando a chave do Registro crashonauditfail está definida como 1 em um computador com o Windows Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=829082)


Lista de referência de pasta pública personalizada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo msExchFolderAffinityCustom contém algum nome de servidor Exchange. Se o Exchange Server Analyzer verificar que o atributo msExchFolderAffinityCustom lista os nomes dos servidores, o Exchange Server Analyzer exibirá uma mensagem de configuração não padrão.

Por padrão, o Exchange Server 2003 usa grupos de roteamento para determinar referências de pasta pública.

O padrão do Exchange Server 2007 é utilizar os custos entre sites do serviço de diretório do Active Directory para determinar o roteamento de referências de pasta pública.

Se o atributo msExchFolderAffinityCustom listar os nomes dos servidores, referências personalizadas foram configuradas no servidor Exchange. O atributo msExchFolderAffinityCustom é um atributo por servidor.

Como prática recomendada geral, você deve usar o comportamento padrão para referências de pasta pública. No entanto, talvez você tenha que criar uma lista de referência personalizada. A mensagem de configuração não padrão é uma mensagem informativa. Nenhuma ação é necessária.

Para retornar para a configuração padrão no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Localize o objeto do servidor em que as referências de pasta pública estão configuradas. O nome do servidor Exchange em que as referências de pasta pública estão configuradas é especificado na mensagem do Exchange Server Analyzer.

  3. Clique com o botão direito em Nome_do_Servidor e clique em Propriedades.

  4. Na guia Referências de Pasta Pública, selecione Usar Grupos de Roteamento, na caixa suspensa Opções de referência de Pasta Pública.

  5. Clique em Aplicar e em OK.
Para retornar para a configuração padrão no Exchange Server 2007

  1. O código a seguir é um exemplo do comando Set-PublicFolderDatabase do Shell de Gerenciamento do Exchange que desabilita o uso de PublicFolderRefferalServerList do banco de dados de pasta pública 'MyServer\First Storage Group\Public Folder Database'.
Código da Cópia
Set-PublicFolderDatabase -Identity "MyServer\First Storage Group\Public Folder Database" -UseCustomReferralServerList $false

O parâmetro UseCustomReferralServerList especifica se os custos do servidor especificados pelo parâmetro PublicFolderReferralServerList devem ser usados. Se estiver definido como $true, o servidor usará os custos do parâmetro PublicFolderReferralServerList para fazer referências de pasta pública. Se estiver definido como $false, o servidor usará os custos entre sites do Active Directory para fazer referências de pasta pública.

Observação:
A definição desse parâmetro como $false também limpa o parâmetro PublicFolderReferralServerList.

Para obter mais informações sobre o comando Set-PublicFolderDatabase do Shell de Gerenciamento do Exchange, consulte a documentação de referência técnica de produto do Exchange Server 2007 "Set-PublicFolderDatabase" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80813).

Para obter mais informações sobre replicação de pasta pública, consulte Práticas recomendadas para pastas públicas do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=46437).


O objeto de monitor de desempenho de banco de dados não está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Log Record Stalls/sec do objeto de desempenho de Database para analisar os dados do desempenho. Se o contador não retornar dados válidos, o Analisador do Exchange Server exibirá uma mensagem de linha de base.

Se o mecanismo de coleta de dados de desempenho não retornar dados válidos, qualquer combinação das seguintes condições será verdadeira:

  • O objeto do desempenho do Database está desabilitado.

  • O objeto do monitor de desempenho do Database está ausente ou danificado.

  • O Analisador do Exchange Server não tem permissões adequadas para acessar os objetos de desempenho.

As duas primeiras condições poderão ocorrer se alguns contadores extensíveis danificarem o Registro ou se programas baseados na WMI (Instrumentação de Gerenciamento do Microsoft Windows®) modificarem o Registro.

O procedimento a seguir explica como corrigir as duas primeiras condições. Antes de executar o procedimento, verifique se o Analisador do Exchange Server tem as permissões adequadas. Para obter mais informações sobre as permissões necessárias para executar o Analisador do Exchange Server, consulte a documentação da Ajuda incluída no Analisador do Exchange Server. Para obter Ajuda, abra o Analisador do Exchange Server e pressione a tecla F1.

Para corrigir esse erro

  1. Verifique se o objeto de desempenho do Database está habilitado.

    1. Baixe e instale a ferramenta Lista de Contadores de Desempenho Extensíveis (Exctrlst.exe). Você pode baixar o Exctrlst.exe em Exctrlst.exe: Lista de Contadores de Desempenho Extensíveis (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Abra o Exctrlst.exe, clique em Ordem de classificação, e clique em Serviço.

    3. Localize o serviço ao qual o objeto de desempenho relata e verifique se a caixa de seleção Contadores de Desempenho Habilitados está marcada.

      Se a caixa de seleção Contadores de Desempenho Habilitados não estiver marcada, marque a caixa de seleção e reinicie o serviço que está associado aos contadores de desempenho para verificar se os contadores de desempenho estão em operação. Se os contadores de desempenho não estiverem funcionando ou se a caixa de seleção Contadores de desempenho habilitados já estava marcada, continue na etapa 2.

  2. Reconstrua os contadores de desempenho ausentes ou danificados, conforme descrito no artigo 300965 da Base de Dados de Conhecimento da Microsoft, "Como reconstruir manualmente os valores de biblioteca do contador de desempenho" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Se você seguir as instruções desse artigo da Base de Dados de Conhecimento e o problema não for solucionado, será necessário reinstalar o sistema operacional Exchange Server no modo Reparo e então aplicar os service packs mais recentes do Exchange Server.


O arquivo DAVEX.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O serviço Cliente DHCP não está sendo executado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®), Win32_Service para determinar o valor da chave Started do serviço DHCP (Dynamic Host Configuration Protocol). Se o Exchange Server Analyzer detectar que o valor da chave Started para o serviço Cliente DHCP em um servidor Exchange está definido como Falso, ele exibirá um aviso.

Esse aviso indica que o serviço Cliente DHCP não está em execução. O serviço Cliente DHCP executa atualizações dinâmicas de DNS (Sistema de Nome de Domínio). Se o serviço Cliente DHCP não estiver em execução, ocorrerão falhas na atualização dinâmica. Se um servidor Exchange não estiver executando este serviço, a ocorrência mais comum será a de problemas no fluxo de mensagens.

Para corrigir esse problema, defina o serviço Cliente DHCP com inicialização automática e inicie o serviço.

Observação:
O serviço Cliente DHCP deve estar em execução, mesmo que o servidor esteja configurado para usar endereços IP estáticos em vez do DHCP.
Para habilitar o serviço Cliente DHCP

  1. Abra o snap-in Serviços.

  2. No painel de detalhes, clique com o botão direito em Serviço Cliente DHCP e clique em Propriedades.

  3. Na guia Geral, clique em Tipo de inicialização e selecione Automática.

  4. Clique em Iniciar e em OK.

Para obter mais informações sobre o serviço Cliente DHCP, consulte o artigo 264539 da Base de Dados de Conhecimento da Microsoft, "Atualizações dinâmicas de DNS não funcionarão se o serviço Cliente DHCP parar" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264539).

Para obter mais informações sobre o protocolo de atualização dinâmica DNS, consulte o artigo 816592 da Base de Dados de Conhecimento da Microsoft, "Como configurar atualizações dinâmicas de DNS no Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).


Dr. Watson não habilitado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê o valor da seguinte chave do Registro para determinar se o Dr. Watson está configurado como depurador de aplicativos padrão no sistema operacional Microsoft Windows®:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

Se o Exchange Server Analyzer descobrir que o valor de Debugger não começa com drwtsn32, uma mensagem de configuração não padrão será exibida.

Essa mensagem indica que o Dr. Watson não está habilitado. Se o Windows NT® for usado, um depurador de modo de aplicativo conhecido como Dr. Watson foi incluído no Windows. Quando um aplicativo falha, essa falha pode ser interceptada pelo Dr. Watson, que registra várias informações, como dados sobre a plataforma, uma lista de processos em execução, a identificação do processo com falha, um despejo de memória do processo com falha, uma ou mais pilhas de chamadas, e um ponteiro para a falha propriamente dita. A maioria das informações coletadas são informações de depuração de nível inferior, direcionadas ao desenvolvedor do processo que apresentou falha.

A prática recomendada é executar o Windows com um depurador de modo de aplicativo habilitado. Se o Dr. Watson não estiver habilitado e você não estiver utilizando um depurador de aplicativos alternativo, é recomendável que você habilite o Dr. Watson usando o procedimento a seguir.

Para habilitar o Dr. Watson

  1. Abra uma janela de prompt de comando.

  2. No prompt de comando, digite drwtsn32 -i.

Para obter mais informações sobre como habilitar e desabilitar o Dr. Watson, consulte o artigo 188296 da Base de Dados de Conhecimento Microsoft, "Como desabilitar o Dr. Watson para Windows" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296).


Incompatibilidade de nome de Computador DSA
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar a configuração do valor de DSA Computer:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor do atributo name para cada objeto do servidor Exchange.

Por último, o Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar o valor da chave Started para o serviço de Cluster (ClusSvc). Um valor True indica que o serviço de Cluster foi iniciado e um valor False indica que o serviço de Cluster não está em execução.

Se o Exchange Server Analyzer verificar que o valor da chave DSA Computer não corresponde ao valor do atributo name do objeto de servidor no Active Directory para qualquer computador do Exchange Server que não esteja sendo executado em um cluster do Windows Server, será exibido um erro.

Para corrigir esse erro, edite a chave de Registro DSA Computer para que corresponda ao valor do atributo name no Active Directory.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como editar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel direito, clique duas vezes em Computador DSA, digite o nome correto desse computador e clique em OK.

  4. Feche o editor do Registro e reinicie o computador do Exchange Server para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O arquivo DSACCESS.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O cache de configuração do DSAccess está cheio
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-05-24

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches para determinar o valor para TotalEntriesMemoryConfigurationData. Se a ferramenta Analisador do Exchange Server detectar que o valor para TotalEntriesMemoryConfigurationData é igual ao tamanho total do cache de configuração do DSAccess (Directory Service Access) (MaxMemoryConfig), um aviso será exibido.

O DSAccess é um componente interno do Exchange 2000 Server e do Exchange Server 2003 que controla como todos os componentes do Exchange acessam o serviço de diretório Active Directory®. A principal função do DSAccess é manter informações sobre vários eventos e operações relacionados a diretórios. Por exemplo, o DSAccess descobre a topologia do Active Directory e detecta se controladores de domínio e servidores de catálogo global estão disponíveis e respondendo a consultas. Além disso, todas as consultas de diretório feitas por componentes internos do Exchange, como o armazenamento do Microsoft Exchange, são roteadas por meio do DSAccess, como resolução de destinatário, pesquisas de definição de configuração e outros. Como parte de seu trabalho, o DSAccess mantém um cache de memória com os resultados de algumas dessas consultas para que, se a mesma informação for solicitada novamente, ela possa ser recuperada do cache do DSAccess em vez de através de outra consulta do protocolo LDAP ao Active Directory.

Como o tamanho máximo da configuração padrão para o cache de configuração do DSAccess foi reduzido de um valor de 25 MB (megabytes) no Exchange 2000 Server para um valor de 5 MB no Exchange Server 2003, essa mensagem de aviso poderá ser gerada em qualquer uma das versões do Exchange. Independentemente da versão do Exchange que gera essa mensagem de aviso, o problema deve ser corrigido o mais rápido possível.

O valor MaxMemoryConfig é normalmente usado com o valor MaxMemoryUser, que controla a quantidade máxima de memória que os objetos de dados do usuário no cache do DSAccess têm permissão para consumir. Se você editar ou remover o valor MaxMemoryConfig, conforme descrito no procedimento a seguir, deve editar ou remover, da mesma forma, o valor MaxMemoryUser, conforme descrito em O valor de cache do usuário do DSAccess é não padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Aumente o valor de MaxMemoryConfig. Se a chave Instance0 ou o valor DWORD MaxMemoryConfig não existir, você poderá criá-lo manualmente. Os dados do valor para a entrada do Registro MaxMemoryConfig está em KB (kilobytes); portanto uma entrada decimal de 15.000 é igual a 15 MB. Se o valor existir, aumente-o em 10 por cento. Se o valor não existir, recomenda-se um ponto de partida inicial de 10 MB.

  4. Feche o editor do Registro e reinicie o Atendedor do Sistema do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O valor do cache de configuração DSAccess é não padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-17

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar se o tamanho do cache do objeto de configuração do DSAccess (Directory Service Access) foi modificado da sua configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryConfig

Se o Exchange Server Analyzer verificar que o MaxMemoryConfig está presente e configurado, uma mensagem de configuração não padrão será exibida.

MaxMemoryConfig é um parâmetro de Registro do Exchange 2000 Server que, normalmente, não é mais necessário no Exchange Server 2003. MaxMemoryConfig controla a quantidade máxima de memória que os objetos de dados de configuração do cache de configuração do DSAccess têm permissão para consumir. O DSAccess é um componente interno do Exchange 2000 Server e do Exchange Server 2003 que controla como todos os componentes do Exchange acessam o serviço de diretório do Active Directory®. A principal função do DSAccess é manter informações sobre vários eventos e operações relacionados a diretórios. Por exemplo, o DSAccess descobre a topologia do Active Directory e detecta se controladores de domínio e servidores de catálogo global estão disponíveis e respondendo a consultas. Além disso, todas as consultas de diretório feitas por componentes internos do Exchange, como o armazenamento do Microsoft Exchange, são roteadas por meio do DSAccess, como resolução de destinatário, pesquisas de definição de configuração e outros. Como parte de seu trabalho, o DSAccess mantém um cache de memória com os resultados de algumas dessas consultas para que, se a mesma informação for solicitada novamente, ela possa ser recuperada do cache do DSAccess em vez de através de outra consulta do protocolo LDAP ao Active Directory.

No Exchange 2000 Server, o cache de configuração era inicialmente definido com o tamanho de 25 megabytes (MB). Na maioria dos servidores Exchange, essa definição era muito maior do que o necessário. A definição de MaxMemoryConfig era usada para recuperar e relocar parte da memória usada pelo cache de configuração do DSAccess. Normalmente, era configurada como 5 MB. Com base em testes internos e comentários de clientes, a Microsoft concluiu que 3 MB é o tamanho ideal, que o Exchange Server 2003 usa como definição pronta para uso. Ao atualizar do Exchange 2000 Server para o Exchange Server 2003, as definições manuais serão preservadas. Se o servidor Exchange foi atualizado do Exchange 2000 Server para o Exchange Server 2003, verifique se o valor de MaxMemoryConfig é inferior a 5 MB.

O valor MaxMemoryConfig é normalmente usado com o valor MaxMemoryUser, que controla a quantidade máxima de memória que os objetos de dados do usuário no cache do DSAccess têm permissão para consumir. Se você editar ou remover o valor MaxMemoryConfig, conforme descrito no procedimento a seguir, deverá editar ou remover, da mesma forma, o valor MaxMemoryUser, conforme descrito em O valor de cache do usuário do DSAccess é não padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para usar o valor de Registro MaxMemoryConfig

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Examine ou edite o valor de MaxMemoryConfig.
Observação:
O valor para essa entrada de Registro está em quilobytes (KB). Se o valor estiver definido em 3000 ou menos, exclua MaxMemoryConfig e reinicie o serviço Atendedor do Sistema do Microsoft Exchange para o padrão da configuração do Exchange Server 2003.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre DSAccess, consulte o artigo 250570 da Base de Dados de Conhecimento, "Directory Service Server Detection and DSAccess Usage" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


O parâmetro de Registro DisableNetLogonCheck do DSAccess é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o DSAccess (Directory Service Access) foi configurado para usar um protocolo de ping diferente do padrão:

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\DisableNetLogonCheck

Se o Exchange Server Analyzer verificar que a chave DisableNetLogonCheck está presente e configurada com um valor superior a 0, será exibida uma mensagem de configuração não padrão.

Depois que o DSAccess descobrir a topologia do serviço de diretório do Active Directory®, ele determinará se os controladores de domínio e os servidores de catálogo global descobertos são apropriados para uso. Durante a descoberta inicial e a redescoberta em andamento, o DSAccess determina a adequação do servidor, executando uma série de testes. Um dos testes envia um RPC (Chamada de Procedimento Remoto) ao servidor de diretório para testar sua adequação geral. Em uma rede de perímetro, na qual o tráfego de RPCs normalmente não é permitido, a solicitação de RPC do DSAccess falha. Entretanto, o DSAccess continua a emitir RPCs até que ocorra a falha, o que pode levar um longo tempo. Essas verificações freqüentes podem afetar desfavoravelmente o desempenho dos computadores que estão executando o Exchange Server. Por esse motivo, os administradores muitas vezes adicionam a chave de Registro DisableNetLogonCheck e a configuram com um valor 1 nos servidores Exchange localizados em uma rede de perímetro.

Se o servidor Exchange que gerou a mensagem de configuração não padrão estiver em uma rede de perímetro na qual o RPC está desabilitado, ou você tiver decidido que não deseja que o DSAccess execute esse teste de adequação, defina a chave DisableNetLogonCheck como 1. Caso contrário, exclua a chave DisableNetLogonCheck.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para usar a chave DisableNetLogonCheck

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Clique duas vezes na chave DisableNetLogonCheck e defina o valor DWORD como 1.

  4. Feche o editor de Registro. Você não precisa reiniciar nenhum serviço para que a alteração tenha efeito.

Para excluir a chave DisableNetLogonCheck

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Excluir o valor chamado DisableNetLogonCheck.

  4. Feche o editor de Registro. Você não precisa reiniciar nenhum serviço para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a chave de Registro DisableNetLogonCheck, consulte o artigo 320228 da Base de Dados de Conhecimento, "XGEN: O valor de Registro DisableNetLogonCheck e como usá-lo" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320228).


DSAccess foi codificado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Exchange_DSAccessDC no namespace ROOT\MicrosoftExchangeV2 para determinar o valor da chave ConfigurationType. Se o valor dessa chave for 0, uma mensagem de configuração não padrão será exibida.

A propriedade ConfigurationType indica se a instância descreve um controlador de domínio detectado automaticamente ou especificado manualmente. Fora da caixa, o componente Directory Service Access (DSAccess) do Exchange Server detecta dinamicamente a topologia do serviço de diretório do Active Directory® e localiza controladores de domínio e servidores de catálogo global automaticamente. Em computadores que estejam executando o Exchange Server 2000 Service Pack 2 ou versões posteriores, ou o Exchange Server 2003, o Gerenciador do Sistema do Exchange inclui a habilidade de inserir uma lista codificada de servidores do Active Directory para serem usados pelo DSAccess.

A menos que a codificação de servidores de diretório para o DSAccess tenha sido feita por uma razão específica, você deve remover a lista de servidores e reverter para a configuração padrão de detecção automática. É recomendável que você use a detecção de topologia automática para aproveitar o failover do catálogo global.

Para reverter para a configuração padrão

  1. Clique em Iniciar, Programas, Microsoft Exchange e clique em Gerenciador do Sistema.

  2. Expanda Grupos Administrativos, <AdminGroupName>, Servidores, <ServerName> (em que AdminGroupName é o nome do grupo administrativo que contém o servidor Exchange e ServerName é o nome do servidor Exchange que você deseja configurar).

  3. Clique com o botão direito no servidor Exchange e clique em Propriedades.

  4. Clique na guia Directory Access.

  5. Na caixa de listagem Mostrar, selecione Controlador de Domínio de Configuração.

  6. Marque a caixa de seleção Descobrir servidores automaticamente.

  7. Clique em Sim quando o prompt do Gerenciador do Sistema do Exchange aparecer: "Os servidores selecionados manualmente que foram especificados serão desmarcados. Deseja continuar?"

  8. Na caixa de listagem Mostrar, selecione Controladores de Domínio.

  9. Marque a caixa de seleção Descobrir servidores automaticamente.

  10. Clique em Sim quando o prompt do Gerenciador do Sistema do Exchange aparecer: "Os servidores selecionados manualmente que foram especificados serão desmarcados. Deseja continuar?"

  11. Na caixa de listagem Mostrar, selecione Servidores de Catálogo Global.

  12. Marque a caixa de seleção Descobrir servidores automaticamente.

  13. Clique em Sim quando o prompt do Gerenciador do Sistema do Exchange aparecer: "Os servidores selecionados manualmente que foram especificados serão desmarcados. Deseja continuar?"

  14. Clique em OK para salvar as alterações.

Para obter mais informações sobre DSAccess e detecção de serviços de diretório, consulte o artigo 250570 da Base de Dados de Conhecimento da Microsoft, "Directory Service Server Detection and DSAccess Usage" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


O DSAccess não está usando a porta 389 para solicitações do controlador de domínio LDAP
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Exchange_DSAccessDC no namespace ROOT\MicrosoftExchangeV2 para determinar o valor para a chave LDAPPort. Se o valor para a chave LDAPPort não estiver definido como 389, uma mensagem de configuração não padrão será exibida.

A chave LDAPPort representa o número da porta TCP na qual o controlador de domínio escuta solicitações do protocolo LDAP. Os administradores podem usar o LDAP sobre protocolo SSL na porta TCP 636 (controlador de domínio) ou na porta TCP 3269 (catálogo global) como medida de segurança.

Por padrão, um servidor de catálogo global escuta a porta 3268 para comunicações de protocolo LDAP. No entanto, se uma autoridade de certificação do Enterprise estiver instalada, todos os controladores de domínio automaticamente solicitam um certificado e podem oferecer suporte a comunicações do protocolo LDAP sobre SSL na porta TCP 636. Se o controlador de domínio também estiver configurado como um catálogo global, ele também poderá suportar comunicações do protocolo LDAP sobre SSL na porta TCP 3269.

Para corrigir esse erro

  • Nenhuma ação é necessária. O Analisador do Exchange Server está identificando uma configuração não padrão.

Para obter mais informações sobre DSAccess e portas LDAP, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 247078, "Como habilitar a comunicação SSL (Secure Sockets Layer) sobre LDAP em controladores de domínio do Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=247078)

  • 246228, "XGEN: DSAccess Profiles" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228)


O DSAccess não está usando a porta 3268 para solicitações do catálogo global do LDAP
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Exchange_DSAccessDC do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) no namespace ROOT\MicrosoftExchangeV2 para determinar o valor da chave LDAPPort. Se o valor para a chave LDAPPort não estiver definido como 3268, uma mensagem de configuração não padrão será exibida.

A chave LDAPPort representa o número da porta TCP na qual o controlador de domínio escuta solicitações do protocolo LDAP. Os administradores podem usar o LDAP sobre protocolo SSL na porta TCP 636 (controlador de domínio) ou na porta TCP 3269 (catálogo global) como medida de segurança.

Por padrão, um servidor de catálogo global escuta a porta 3268 para comunicações de protocolo LDAP. No entanto, se uma autoridade de certificação do Enterprise estiver instalada, todos os controladores de domínio automaticamente solicitam um certificado e podem oferecer suporte a comunicações do protocolo LDAP sobre SSL na porta TCP 636. Se o controlador de domínio também estiver configurado como um catálogo global, ele também poderá suportar comunicações do protocolo LDAP sobre SSL na porta TCP 3269.

Para obter mais informações sobre DSAccess e portas LDAP, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 247078, "Como habilitar a comunicação SSL (Secure Sockets Layer) sobre LDAP em controladores de domínio do Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=247078)

  • 246228, "XGEN: DSAccess Profiles" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228)


O parâmetro do Registro LdapKeepAliveSecs do DSAccess é não-padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool lê a entrada do Registro a seguir para determinar se o DSAccess (Directory Service Access) foi configurado para usar o protocolo wLDAP de implementação do sistema operacional Microsoft Windows®:

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

Se o Exchange Server Analyzer detectar que LdapKeepAliveSecs está presente e configurado com um valor 0, uma mensagem de configuração não padrão será exibida.

Depois que o DSAccess descobre a topologia do serviço de diretório do Active Directory®, ele determina se a lista encontrada de controladores de domínio ativos e de servidores de catálogo global é adequada para uso. Durante a descoberta inicial e a redescoberta em andamento, o DSAccess determina a adequação do servidor, executando uma série de testes. Por padrão, um dos testes de adequação usa o protocolo ICMP para executar ping nos controladores de domínio e verificar se os servidores estão disponíveis.

Pode ser que nem todas as conexões de sua rede tenham suporte para ICMP. Um exemplo específico dessa situação está em uma rede de perímetro onde a conectividade ICMP entre o servidor Exchange e os controladores de domínio não é permitida. Nesses casos, configurar o parâmetro de Registro LdapKeepAliveSecs como 0 forçará o DSAccess a usar a Implementação do Windows de LDAP (wLDAP) para testes de adequação.

Se o servidor Exchange que gerou a mensagem de configuração não padrão estiver em uma rede de perímetro em que a RPC (chamada de procedimento remoto) está desativada ou em uma rede em que o ICMP não é permitido, você deverá manter a chave LdapKeepAliveSecs configurada como está. De outra forma, você deve excluir a chave.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para excluir a chave LdapKeepAliveSecs

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Excluir o valor chamado LdapKeepAliveSecs.

  4. Feche o editor de Registro. Você não precisa reiniciar nenhum serviço para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a chave do Registro LdapKeepAliveSecs, consulte o artigo 320529, da Base de Dados de Conhecimento, "XADM: O uso do DSAccess em um cenário de firewall de rede de perímetro exige uma configuração de chave do Registro" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529).


O parâmetro de Registro LdapKeepAliveSecs do DSAccess está definido como valor não aceito
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool lê a entrada do Registro a seguir para determinar se o DSAccess (Directory Service Access) foi configurado para usar o protocolo wLDAP de implementação do sistema operacional Microsoft Windows®:

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

Se o Exchange Server Analyzer verificar que LdapKeepAliveSecs está presente e configurado com um valor diferente de 0, será exibido um aviso.

Depois que o DSAccess descobre a topologia do serviço de diretório do Active Directory®, ele determina se a lista encontrada de controladores de domínio ativos e de servidores de catálogo global é adequada para uso. Durante a descoberta inicial e a redescoberta em andamento, o DSAccess determina a adequação do servidor, executando uma série de testes. Por padrão, um dos testes de adequação usa o protocolo ICMP para executar ping nos controladores de domínio e verificar se os servidores estão disponíveis.

Pode ser que nem todas as conexões de sua rede tenham suporte para ICMP. Um exemplo específico dessa situação está em uma rede de perímetro onde a conectividade ICMP entre o servidor Exchange e os controladores de domínio não é permitida. Nesses casos, configurar o parâmetro do Registro LdapKeepAliveSecs como 0 forçará o DSAccess a usar o wLDAP para testes de adequação.

Se o servidor Exchange que gerou esse aviso estiver em uma rede de perímetro com RPC (chamada de procedimento remoto) desabilitada ou em uma rede onde ICMP não é permitido, defina a chave LdapKeepAliveSecs como 0. De outra forma, você deve excluir a chave. Qualquer valor diferente de zero não tem suporte nessa chave de registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para modificar a chave LdapKeepAliveSecs.

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Clique duas vezes na chave LdapKeepAliveSecs e defina o valor DWORD como 0 (zero).

  4. Feche o editor de Registro. Você não precisa reiniciar nenhum serviço para que a alteração tenha efeito.

Para excluir a chave LdapKeepAliveSecs

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Excluir o valor chamado LdapKeepAliveSecs.

  4. Feche o editor de Registro. Você não precisa reiniciar nenhum serviço para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a chave do Registro LdapKeepAliveSecs, consulte o artigo 320529, da Base de Dados de Conhecimento, "XADM: O uso do DSAccess em um cenário de firewall de rede de perímetro exige uma configuração de chave do Registro" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529).


O parâmetro de Registro PreloadBaseDNs do DSAccess é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar se a funcionalidade de pré-carga de pesquisa do DSAccess (Directory Service Access) foi alterada da sua configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadBaseDNs

Os dados do valor padrão para PreloadBaseDNs são:

'"'

'"'

'"'

'"'

'"'

Se o Exchange Server Analyzer detectar que o valor de PreloadBaseDNs foi modificado desses valores padrões, será exibida uma mensagem de aviso. O Exchange Server Analyzer informa essa configuração porque se trata de uma definição que só deverá ser alterada sob orientação do Atendimento Microsoft.

O cache do DSAccess reside no servidor Exchange e coleta configurações e registros de usuário que são recuperados do serviço de diretório do Active Directory®. Os registros no cache do DSAccess são acessados utilizando um nome distinto de objeto, uma GUID (Identificador Globalmente Exclusivo), ou uma chave construída do escopo, BaseDN, e o filtro de pesquisa usado para localizar o objeto no Active Directory. Os acessos subseqüentes que usam o mesmo nome distinto, GUID ou chave encontram o registro no cache. Portanto, impede-se carga desnecessária no Active Directory para pesquisas idênticas. Entretanto, o DSAccess não impede a carga no Active Directory quando o filtro de pesquisa é diferente do filtro de pesquisa que está contido no cache, embora o DSAccess solicite o mesmo conjunto de atributos para o objeto de usuário.

O pré-carregamento de pesquisa é uma forma de evitar os muitos problemas de pesquisa do Active Directory que podem ocorrer quando vários filtros de pesquisa são emitidos no mesmo objeto de usuário. A pré-carga de pesquisa funciona por meio da construção da chave mencionada anteriormente em que uma entrada de pesquisa é criada pelo escopo, BaseDN e o filtro de pesquisa.

Para obter mais informações sobre como configurar a pré-carga de pesquisa do DSAccess, consulte o artigo 250572 da Base de Dados de Conhecimento da Microsoft, "XCON: Pré-carga e Cache do DSAccess" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572).


O parâmetro do Registro DSAccess PreloadFilters é não padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar se a funcionalidade de pré-carga de pesquisa do DSAccess (Directory Service Access) foi alterada da sua configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadFilters

Os dados do valor padrão para PreloadFilters são:

(&(|(msExchMasterAccountSID=%)(objectSid=%))(!(objectClass=foreignSecurityPrincipal)))(|(msExchMailboxGUID=%)(objectGUID=%))(legacyExchangeDN=%)(msExchMailboxGUID=%)(&(proxyAddresses=%)(|(objectClass=user)(objectClass=contact)))

Se o Exchange Server Analyzer verificar que o valor de PreloadFilters foi modificado desses padrões, um aviso será exibido. O Exchange Server Analyzer informa sobre esta configuração porque a configuração de Registro PreloadFilters só deve ser alterada após consulta ao Atendimento Microsoft.

O cache do DSAccess reside no servidor Exchange e coleta configurações e registros de usuário que são recuperados do serviço de diretório do Active Directory®. Os registros no cache são acessados usando um nome distinto de objeto, uma GUID (identificador globalmente exclusivo) ou uma chave construída pelo escopo, BaseDN, e o filtro de pesquisa usado para localizar esse objeto no Active Directory. Os acessos subseqüentes que usam o mesmo nome distinto, GUID ou chave encontram o registro no cache. Portanto, impede-se carga desnecessária no Active Directory para pesquisas idênticas. Entretanto, o DSAccess não impede a carga no Active Directory quando o filtro de pesquisa é diferente do filtro de pesquisa que está contido no cache, embora o DSAccess solicite o mesmo conjunto de atributos para o objeto de usuário.

O pré-carregamento da pesquisa é uma forma de evitar vários problemas de pesquisa com o Active Directory, que podem ocorrer quando vários filtros de pesquisa são emitidos no mesmo objeto de usuário. A pré-carga de pesquisa funciona por meio da construção da chave mencionada anteriormente em que uma entrada de pesquisa é criada pelo escopo, BaseDN e o filtro de pesquisa.

Para obter mais informações sobre como configurar a pré-carga de pesquisa do DSAccess, consulte o artigo 250572 da Base de Dados de Conhecimento da Microsoft, "XCON: Pré-carga e Cache do DSAccess" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572).


DSAccess relata que este servidor do Active Directory não é funcional
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Exchange_DSAccessDC do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) no namespace ROOT\MicrosoftExchangeV2 para determinar o valor da chave IsUp. Se a chave IsUp estiver definida como False, será exibido um erro.

Se a chave IsUp estiver definida como True, isso indica que o controlador de domínio respondeu na última vez em que o servidor Exchange tentou estabelecer uma conexão. Se IsUp estiver definido como False, isso indicará que o controlador de domínio não respondeu a tentativas de conexão.

A falta de resposta nem sempre significa que o controlador de domínio ou o catálogo global está desativado ou com mau funcionamento. Às vezes, pode haver problemas de conectividade de rede entre o servidor Exchange e o controlador de domínio, que podem causar essa falha. Essa falha também pode ser resultado de um firewall entre o servidor Exchange e o controlador de domínio no qual não foram abertas as portas apropriadas.

Para corrigir esse erro

  1. Verifique se o controlador de domínio está em execução tentando executar ping nele.

  2. Se houver um firewall, verifique se as portas corretas do firewall estão abertas. Os firewalls também podem ser configurados para eliminar pacotes de PING. Verifique a documentação do firewall em busca de detalhes sobre como abrir ou fechar portas específicas.

  3. Verifique se não há outros problemas relacionados à rede, como opções, roteadores e cabos com mau funcionamento.

Para obter mais informações sobre DSAccess e detecção de serviços de diretório, consulte o artigo 250570 da Base de Dados de Conhecimento da Microsoft, "Directory Service Server Detection and DSAccess Usage" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).

Para obter mais informações sobre resolução de problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


O DSAccess reporta que esse servidor do Active Directory não está sincronizado com o restante da topologia
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-21

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Exchange_DSAccessDC do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) no namespace ROOT\MicrosoftExchangeV2 para conhecer os valores da chave IsInSync. Se o valor da chave IsInSync for False, será exibido um erro.

A chave IsInSync indica se o controlador de domínio está sincronizado com o servidor de catálogo global e com o controlador de domínio de configuração. Um valor True indica que o servidor está sincronizado, e um valor False indica que o controlador de domínio não está sincronizado.

Para corrigir esse erro

  1. Examine o tempo no controlador de domínio ou controlador global. Certifique-se de que o Serviço de Tempo seja iniciado ou sincronize manualmente o tempo no servidor Exchange com o servidor de catálogo global ou controlador de domínio de configuração.

  2. Use a ferramenta Replmn (Replication Monitor) para verificar e, se necessário, corrigir problemas de replicação do controlador de domínio. O Replmon faz parte das Ferramentas de Suporte do Microsoft Windows 2000 Server e Microsoft Windows Server™ 2003, localizadas na pasta Support\Tools do CD do Windows Server.

Para obter mais informações sobre a detecção do DSAccess e dos Serviços de Diretório, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 316300, "ID do Evento 2080 de MSExchangeDSAccess" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316300)

  • 250570, "Detecção do servidor do serviço de Diretório e uso do DSAccess" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)


O DSAccess relata que o servidor do Active Directory está levando mais de 2 segundos para responder às solicitações do LDAP
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Exchange_DSAccessDC do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) no namespace ROOT\MicrosoftExchangeV2 para determinar os valores das chaves IsFast e IsUp. Se o valor da chave IsUp for True, o servidor de diretórios usado pelo componente DSAccess (Directory Service Access) no Exchange Server estará conectado à rede e respondendo. O valor False indica que o servidor de diretórios não está respondendo. Se o valor IsFast for True, o tempo de resposta desse servidor de diretórios será inferior a dois segundos. O valor False indica que o tempo de resposta é superior a dois segundos. Se o valor de IsUp for True, mas o valor de IsFast for False, um erro será exibido.

Para corrigir esse erro

  1. Examine a carga no controlador de domínio e no catálogo global. Se o controlador de domínio e o catálogo global forem sobrecarregados, as respostas a chamadas LDAP poderão ficar lentas.

  2. Verifique se há pelo menos um catálogo global no site do serviço de diretório do Active Directory® para otimizar o desempenho.

Para obter mais informações sobre DSAccess e detecção de serviços de diretório, consulte o artigo 250570 da Base de Dados de Conhecimento da Microsoft, "Directory Service Server Detection and DSAccess Usage" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


O parâmetro do Registro DSAccess TopoCreateTimeoutSecs é não padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada de Registro a seguir para determinar se o tempo limite de inicialização padrão do DSAccess foi alterado:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess\TopoCreateTimeoutSecs

Se o Analisador do Exchange Server detectar que o valor da chave TopoCreateTimeoutSecs existe e tem um valor maior que 0, uma mensagem de configuração não padrão será exibida.

Na inicialização, o DSAccess usa um processo de descoberta para identificar a topologia do serviço de diretório do Active Directory® e avalia a disponibilidade dos controladores de domínio e servidores de catálogo global. Depois que a inicialização for concluída e a cada 15 minutos depois disso, o DSAccess usa quase o mesmo processo para redescobrir a topologia e verificar as alterações na disponibilidade do servidor. Por padrão, a inicialização do DSAccess durante a inicialização deve terminar em um minuto. Caso contrário, o DSAccess pára. Um minuto é geralmente tempo suficiente para o DSAccess inicializar.

Observação:
Se você codificar os servidores de diretório que são usados pelo DSAccess, o DSAccess ignorará o processo de descoberta e verificará apenas o ajuste do servidor.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. Excluir o valor chamado TopoCreateTimeoutSecs.

  4. Feche o editor de Registro.

Se a chave do Registro estiver presente, tente avaliar sua topologia de rede. Se for necessário um tempo adicional de inicialização do DSAccess na sua organização, isso poderá indicar um problema de projeto ou de rede. É necessário um acesso rápido e confiável aos controladores de domínio, especialmente aos servidores de catálogo global, para que haja uma operação ideal do Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre acesso a diretórios, consulte Compreendendo e solucionando problemas de acesso a diretórios (http://go.microsoft.com/fwlink/?LinkId=39012).


O cache de usuário do DSAccess está cheio
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-20

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor atual de TotalEntriesMemoryUserData. Se a ferramenta Exchange Server Analyzer Tool detectar que o valor de TotalEntriesMemoryUserData é igual ao tamanho total do cache do usuário DSAccess (Directory Service Access) (MaxMemoryUser), será exibido um aviso.

O DSAccess é um componente interno do Exchange 2000 Server e do Exchange Server 2003 que controla como todos os componentes do Exchange acessam o serviço de diretório Active Directory®. A principal função do DSAccess é manter informações sobre vários eventos e operações relacionados a diretórios. Por exemplo, o DSAccess descobre a topologia do Active Directory e detecta se controladores de domínio e servidores de catálogo global estão disponíveis e respondendo a consultas. Além disso, todas as consultas de diretório feitas por componentes internos do Exchange, como o armazenamento do Exchange, são roteadas por meio do DSAccess, como resolução de destinatário, pesquisas de definição de configuração e outros. Como parte de seu trabalho, o DSAccess mantém um cache de memória com os resultados de algumas dessas consultas para que, se a mesma informação for solicitada novamente, ela possa ser recuperada do cache do DSAccess em vez de através de outra consulta do protocolo LDAP ao Active Directory.

No Exchange 2000 Server, o cache do usuário era definido inicialmente em 25 MB. Em computadores do Exchange 2000 Server que atendem a um grande número de clientes Microsoft Office Outlook® 2003, o tamanho padrão de cache do usuário do DSAccess não foi suficiente. Para melhorar o desempenho, o valor padrão do cache do usuário foi otimizado e definido como 140 MB no Exchange Server 2003.

Como o tamanho máximo da configuração padrão do cache do usuário do DSAccess foi aumentado de um valor de 25 MB no Exchange 2000 Server para 140 MB no Exchange Server 2003, provavelmente esta mensagem de aviso será gerada nos computadores do Exchange 2000 Server. Independentemente da versão do Exchange que gera essa mensagem de aviso, o problema deve ser corrigido o mais rápido possível. Nos sistemas com um cache do DSAccess de tamanho menor, a entrega de mensagens locais e a resolução de nomes do catálogo de endereços podem ficar mais lentas do que o previsto.

É possível configurar manualmente o tamanho máximo do cache do usuário com uma entrada do Registro no servidor Exchange. MaxMemoryUser é um parâmetro do Registro do Exchange 2000 Server que permite que o administrador do Exchange controle a quantidade máxima de memória que os objetos de dados do usuário no cache do DSAccess têm permissão para consumir.

O valor de MaxMemoryUser é freqüentemente usado junto com o valor de MaxMemoryConfig, que controla a quantidade máxima de memória que os objetos de dados de configuração no cache do DSAccess podem consumir. Se você editar ou remover o valor de MaxMemoryUser conforme descrito no procedimento a seguir, deverá similarmente editar ou remover o valor de MaxMemoryConfig como descrito em O valor do cache de configuração DSAccess é não padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir este problema em um computador do Exchange 2000 Server

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Aumente o valor de MaxMemoryUser. Se esse valor DWORD não existir, você poderá criá-lo manualmente. Os dados de valor dessa entrada do Registro estão expressos em quilobytes (KB); portanto, uma entrada em notação decimal de 140000 equivale a 140 MB.

  4. Diminua o valor de MaxMemoryConfig. Se esse valor DWORD não existir, você poderá criá-lo manualmente. Os dados de valor dessa entrada do Registro também estão em quilobytes (KB). Um valor de 5000 em notação decimal, que equivale a 5 MB, é recomendado.

  5. Saia do editor do Registro e reinicie o Atendedor do Sistema do Microsoft Exchange para que a alteração entre em vigor.

Para corrigir esse problema em um computador do Exchange Server 2003

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Se MaxMemoryUser existir e estiver configurado com um valor inferior a 140 MB, exclua o valor de MaxMemoryUser. Se MaxMemoryUser existir e estiver configurado com um valor superior a 140 MB, aumente seu valor em 10%.

  4. Se MaxMemoryConfig existir, exclua-o.

  5. Saia do editor do Registro e reinicie o Atendedor do Sistema do Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" em (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (página em inglês).

Para obter mais informações sobre o DSAccess, consulte o artigo 250570 da Base de Dados de Conhecimento, "Detecção do servidor de serviço de diretório e utilização do DSAccess" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).


O valor de cache do usuário do DSAccess é não padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê as entradas do Registro a seguir para determinar se valor padrão do tamanho do cache do objeto do usário DSAccess foi modificado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryUser

Se o Analisador do Exchange Server detectar que o parâmetro MaxMemoryUser MaxDSNSize está presente e configurado, uma mensagem de configuração não padrão será exibida.

MaxMemoryUser é um parâmetro de Registro do servidor Exchange que permite a um administrador do Exchange controlar a quantidade máxima de memória permitida aos objetos de dados do usuário no cache DSAccess para consumo.

O DSAccess é um componente interno do Exchange 2000 Server e do Exchange Server 2003 que controla como todos os componentes do Exchange acessam o serviço de diretório Active Directory®. A principal função do DSAccess é manter informações sobre vários eventos e operações relacionados a diretórios. Por exemplo, o DSAccess descobre a topologia do Active Directory e detecta se controladores de domínio e servidores de catálogo global estão disponíveis e respondendo a consultas. Além disso, todas as consultas de diretório feitas por componentes internos do Exchange, como o armazenamento do Exchange, são roteadas por meio do DSAccess, como resolução de destinatário, pesquisas de definição de configuração e outros. Como parte de seu trabalho, o DSAccess mantém um cache de memória com os resultados de algumas dessas consultas para que, se a mesma informação for solicitada novamente, ela possa ser recuperada do cache do DSAccess em vez de através de outra consulta do protocolo LDAP ao Active Directory.

No Exchange 2000 Server, o cache de usuário foi inicialmente definido como 25 MB (megabytes) de tamanho. Em computadores do Exchange 2000 Server que atendem a um grande número de clientes Microsoft Office Outlook® 2003, o tamanho padrão de cache do usuário do DSAccess não foi suficiente. Em sistemas com um cache DSAccess subdimensionado, a entrega de mensagens locais e a resolução de nomes do catálogo de endereços podem ser mais lentas que o desejável.

Para melhorar o desempenho, o valor padrão do cache do usuário foi otimizado e definido como 140 MB no Exchange Server 2003. Ao atualizar do Exchange 2000 Server para o Exchange Server 2003, toda a configuração manual será preservada. Se esse servidor Exchange foi atualizado do Exchange 2000 Server para o Exchange Server 2003, você deverá se certificar de que o valor de MaxMemoryUser é de pelo menos 140 MB.

O valor MaxMemoryUser era muito usado junto com o valor MaxMemoryConfig, que controla a quantidade máxima de memória que os objetos de dados do usuário no cache do DSAccess têm permissão para consumir. Se você editar ou remover o valor MaxMemoryUser, conforme descrito no procedimento a seguir, deverá, da mesma forma, editar ou remover o valor MaxMemoryConfig, conforme descrito em O valor do cache de configuração DSAccess é não padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para usar a chave do Registro MaxMemoryUser

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Examine ou edite o valor de MaxMemoryUser.

    O valor para essa entrada de Registro está em quilobytes (KB). Se o valor estiver definido como 140.000 ou menos, você deverá excluir MaxMemoryUser e reiniciar o Atendedor do Sistema Microsoft Exchange para padronizar a configuração do Exchange Server 2003.

Antes de editar o Registro e para obter informações sobre como editar o Registro, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre DSAccess, consulte o artigo 250570 da Base de Dados de Conhecimento, "Directory Service Server Detection and DSAccess Usage" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


O serviço RFR do DSProxy foi desabilitado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas de Registro para determinar se o serviço de referência Proxy de Serviços de Diretório (DSProxy RFR) foi desabilitado:

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\MSExchangeSA\Parameters\ No RFR Service

Se o Exchange Server Analyzer verificar que No RFR Service está presente e definido como 1, uma mensagem de configuração não padrão será exibida.

O componente DSProxy no Exchange 2000 Server e no Exchange Server 2003 fornece acesso de diretório a um controlador de domínio ou catálogo global para clientes Microsoft Outlook® 98 e Outlook 97 O Outlook 2000 Service Release 2 (SR-2) e versões posteriores podem consultar diretamente um servidor de catálogo global.

Na primeira vez em que um cliente Outlook 2000 SR-2 ou versão posterior se conecta a um computador servidor do Exchange 2000 server ou versão posterior, ele procura pelo serviço de diretório no servidor Exchange primário. Em primeiro lugar, o Outlook passa pelo processo DSProxy na primeira sessão. Depois que o cliente entra em contato com o serviço DSProxy (ele tenta todos os protocolos de transporte disponíveis), é passada uma referência para o cliente, informando que todas as solicitações de diretório no futuro devem ir para o servidor de catálogo global. O Outlook define a referência no perfil MAPI no Registro. O mecanismo de referência DSProxy reduz a carga no servidor Exchange e reduz a latência para pesquisas de catálogos de endereços. Se for inserido um nome de servidor explícito no perfil, o Outlook deve ser reiniciado se esse serviço de diretório do Active Directory® falhar. Se isto ocorrer, o servidor Exchange enviará uma nova referência ao Outlook.

Em algumas situações, você pode preferir forçar os clientes Outlook, mesmo nas versões mais recentes, a passar sempre pelo processo DSProxy, sem a referência. Por exemplo, isso pode ser necessário se houver um firewall entre o Outlook e o servidor Exchange.

Adicionando a entrada do Registro No RFR Service e definindo-a como 1, o servidor Exchange se comportará como um proxy para clientes Outlook, ao invés de dar referência aos clientes do servidor de catálogo global adequado para comunicação direta. Definir o parâmetro do Registro No RFR Service como 1 diminuirá o desempenho do servidor Exchange, porque ele estará agindo como um proxy para todos os clientes Outlook, inclusive o Outlook 2000 SR-2 e clientes mais novos que se comunicam diretamente com o Active Directory.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para habilitar o serviço RFR DSProxy

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Criar um novo valor de DWORD chamado No RFR Service.

  4. Configure o valor No RFR Service como 1.

Para desabilitar o serviço DSProxy RFR, exclua o valor do Registro No RFR Service ou defina-o como 0.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como o Outlook 2000 SR-2 e clientes mais novos interagem com o Active Directory, consulte o artigo 256976 da Base de Dados de Conhecimento, "XCCC: Como o Outlook 2000 acessa o Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914).

Para obter informações sobre como os clientes MAPI acessam o Active Directory, consulte o artigo 256976 da Base de Dados de Conhecimento, "XCLN: Como os clientes MAPI Acessam o Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976).


O arquivo EMSMTA.EXE está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


A chave do Registro EnableAuthEpResolution está habilitada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar se a chave do Registro Restrições da Interface de RPC (chamada de procedimento remoto) está habilitada.

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

Se o Exchange Server Analyzer verificar que o valor do Registro EnableAuthEpResolution existe, o Exchange Server Analyzer exibirá uma mensagem de configuração não padrão.

Restrições de Interface RPC fornecem maior proteção de rede, que tornará os sistemas menos vulneráveis a ataques na rede.

Uma interface RPC remota e anonimamente disponível e registrada por padrão no Microsoft Windows® XP apresenta uma superfície de ataque significativa. O próprio RPC deve registrar essa interface para fornecer resolução de ponto de extremidade para chamadas que usem pontos de extremidade dinâmicos. A chave do Registro RestrictRemoteClients modifica o comportamento de todas as interfaces RPC no sistema. Por padrão, a chave do Registro RestrictRemoteClients impede o acesso remoto anônimo a interfaces RPC no sistema, com algumas exceções. Portanto, a interface Mapeador de Ponto de Extremidade de RPC não está mais disponível anonimamente.

Um cliente RPC que tenta fazer uma chamada usando um ponto de extremidade dinâmico consultará primeiro o Mapeador de Ponto de Extremidade de RPC para determinar a qual ponto de extremidade dinâmico o cliente de RPC deve se conectar. Essa consulta é realizada anonimamente, mesmo se a própria chamada do cliente de RPC seja executada usando a segurança de RPC. Por padrão, chamadas anônimas para a interface Mapeador de Ponto de Extremidade de RPC falham no Microsoft Windows XP Service Pack 2, porque a funcionalidade RestrictRemoteClients padrão impede o acesso remoto anônimo a interfaces RPC no sistema. Em razão dessa Restrição de Interface RPC, o tempo de execução do cliente de RPC é modificado para executar uma consulta autenticada ao Mapeador de Ponto de Extremidade. Essa Restrição de Interface RPC é o comportamento padrão no Windows XP Service Pack 2. O tempo de execução do cliente de RPC então usa a autenticação Integrada do Windows, anteriormente chamada NTLM, para autenticação com o Mapeador de Ponto de Extremidade. A autenticação Integrada do Windows ocorre se a chamada do cliente de RPC atual usar esse tipo de autenticação. Existe uma configuração não padrão se as seguintes condições existirem:

  • A chave do Registro de RPC e o valor EnableAuthEpResolution descrito foram criados.

  • O valor do Registro EnableAuthEpResolution foi definido como 0.

Para obter mais informações sobre alterações no serviço de RPC com o Windows XP Service Pack 2, consulte "Restrições de Interface RPC" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47371).


Comprimento da fila de saída do cliente Epoxy (IMAP) acima do limite
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Client Out Queue Length (IMAP) do objeto de desempenho de Epoxy para analisar os dados do desempenho.

O contador de desempenho Client Out Queue Length (IMAP) indica o número de mensagens na fila que contêm mensagens IMAP4 enviadas pelo processo Inetinfo.exe ao processo Store.exe. As filas devem permanecer sempre abaixo de 50. Ao determinar que o contador de Client Out Queue Length (IMAP) excedeu o valor de pico de 50 durante o intervalo de tempo da amostragem, o Analisador do Exchange Server exibirá um erro.

Epoxy (ExIPC) é um mecanismo de memória compartilhada que permite que os processos do Microsoft IIS (Serviços de Informações da Internet — Inetinfo.exe) e os Serviços de Armazenamento de Informações do Microsoft Exchange (Store.exe) transfiram dados de um lado para outro, rapidamente. Isso permite a comunicação interprocessual bidirecional entre os processos Inetinfo.exe e Store.exe.

Observação:
O Inetinfo.exe aceita solicitações de protocolos da Internet, como o WebDAV, IMAP4, NNTP, POP3 e SMTP.

Essa memória também é usada pelo DSAccess, componente do Exchange que armazena informações do Active Directory® em cache.

Esse erro indica que existem problemas de desempenho no processo Store.exe ou nos recursos dos quais o processo Store.exe depende, que estão causando o aumento da fila. Isso provocará um aumento no tempo de resposta do servidor.

Para resolver esse problema, use os recursos mencionados na seção "Mais informações" para identificar o afunilamento de desempenho ocorrendo no processo Store.exe ou nos recursos relacionados. Esse afunilamento pode estar relacionado a um desempenho de disco insuficiente ou à intensa utilização da CPU.

Para obter mais informações

  • Para obter mais informações sobre como identificar as filas crescentes no Epoxy, consulte "Identificando filas crescentes no Epoxy" em Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre os afunilamentos do processador, consulte Afunilamento do processador.

  • Para obter mais informações sobre os afunilamentos de disco, consulte Afunilamento de disco detectado.

  • Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento, consulte o artigo 257725 da Base de Dados de Conhecimento da Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


Comprimento da Fila de Saída do Cliente Epoxy (POP) acima do limite
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Client Out Queue Length (POP) do objeto de desempenho de Epoxy para analisar os dados do desempenho.

O contador de desempenho Client Out Queue Length (POP) indica o número de mensagens na fila que contêm mensagens POP3 enviadas pelo processo Inetinfo.exe ao processo Store.exe. As filas devem permanecer sempre abaixo de 50. O Analisador do Exchange Server recupera uma amostra desse contador a cada 5 segundos, por um período de 5 minutos. Ao determinar que o contador de Client Out Queue Length (POP) excedeu o valor de pico de 50 durante o intervalo de tempo da amostragem, o Analisador do Exchange Server exibirá um erro.

Epoxy (ExIPC) é um mecanismo de memória compartilhada que permite que os processos do Microsoft IIS (Serviços de Informações da Internet — Inetinfo.exe) e os Serviços de Armazenamento de Informações do Microsoft Exchange (Store.exe) transfiram dados de um lado para outro, rapidamente. Isso permite a comunicação interprocessual bidirecional entre os processos Inetinfo.exe e Store.exe.

Observação:
O Inetinfo.exe aceita solicitações de protocolos da Internet, como o WebDAV, IMAP4, NNTP, POP3 e SMTP.

Essa memória também é usada pelo DSAccess, componente do Exchange que armazena informações do Active Directory® em cache.

Esse erro indica que existem problemas de desempenho no processo Store.exe ou nos recursos dos quais o processo Store.exe depende, que estão causando o aumento da fila. Isso provocará um aumento no tempo de resposta do servidor.

Para resolver esse problema, use os recursos mencionados na seção "Mais informações" para identificar o afunilamento de desempenho ocorrendo no processo Store.exe ou nos recursos relacionados. Esse afunilamento pode estar relacionado a um desempenho de disco insuficiente ou à intensa utilização da CPU.

Para obter mais informações

  • Para obter mais informações sobre como identificar as filas crescentes no Epoxy, consulte "Identificando filas crescentes no Epoxy" em Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre os afunilamentos do processador, consulte Afunilamento do processador.

  • Para obter mais informações sobre os afunilamentos de disco, consulte Afunilamento de disco detectado.

  • Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento, consulte o artigo 257725 da Base de Dados de Conhecimento da Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


O arquivo EPOXY.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução do programa de Instalação no modo Reinstalar instala apenas arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 em sua unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O objeto monitor de desempenho Epoxy não está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Client Out Queue Length do objeto de desempenho de Epoxy para analisar os dados do desempenho. Se o contador não retornar dados válidos, o Analisador do Exchange Server exibirá uma mensagem de linha de base.

Se não forem retornados dados válidos pelo mecanismo de coleta de dados de desempenho, qualquer combinação das condições a seguir é verdadeira:

  • O objeto do monitor de desempenho do Epoxy está desabilitado.

  • O objeto do monitor de desempenho do Epoxy está ausente ou danificado.

  • O Analisador do Exchange Server não tem permissões adequadas para acessar os objetos de desempenho.

As duas primeiras condições poderão ocorrer se alguns contadores extensíveis danificarem o Registro ou se programas baseados na WMI (Instrumentação de Gerenciamento do Microsoft Windows®) modificarem o Registro. O procedimento a seguir explica como corrigir as duas primeiras condições. Antes de executar o procedimento, verifique se o Analisador do Exchange Server tem as permissões adequadas. Para obter mais informações sobre as permissões necessárias para executar o Analisador do Exchange Server, consulte a documentação da Ajuda incluída no Analisador do Exchange Server. Para obter Ajuda, abra o Analisador do Exchange Server e pressione a tecla F1.

Para corrigir esse erro

  1. Verifique se o objeto de desempenho do Epoxy está habilitado:

    1. Baixe e instale a ferramenta Lista de Contadores de Desempenho Extensíveis (Exctrlst.exe). Você pode baixar o Exctrlst.exe no site "Exctrlst.exe: Lista de Contadores de Desempenho Extensíveis" (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Abra o Exctrlst.exe, clique em Ordem de classificação, e clique em Serviço.

    3. Localize o serviço ao qual o objeto de desempenho relata e verifique se a caixa de seleção Contadores de Desempenho Habilitados está marcada.

      Se a caixa de seleção Contadores de Desempenho Habilitados não estiver marcada, marque a caixa de seleção e reinicie o serviço que está associado aos contadores de desempenho para verificar se os contadores de desempenho estão em operação. Se os contadores de desempenho não estiverem funcionando ou se a caixa de seleção Contadores de desempenho habilitados já estava marcada, continue na etapa 2.

  2. Reconstrua os contadores de desempenho ausentes ou danificados, conforme descrito no artigo 300956 da Base de Dados de Conhecimento da Microsoft, "Como reconstruir manualmente os valores de biblioteca do contador de desempenho" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Se você seguir as instruções desse artigo da Base de Dados de Conhecimento e o problema não for solucionado, será necessário reinstalar o sistema operacional Exchange Server no modo Reparo e então aplicar os service packs mais recentes do Exchange Server.


Comprimento da Fila de Saída do Armazenamento Epoxy (IMAPI) acima do limite
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Store Out Queue Length (IMAP) do objeto de desempenho de Epoxy para analisar os dados do desempenho.

O contador de desempenho Store Out Queue Length (IMAP) indica o número de mensagens na fila que contêm mensagens IMAP4 enviadas pelo processo Store.exe ao processo Inetinfo.exe. A fila deve permanecer sempre abaixo de 50. O Analisador do Exchange Server recupera uma amostra desse contador a cada 5 segundos, por um período de 5 minutos. Ao determinar que o contador de Store Out Queue Length (IMAP) excedeu o valor de pico de 50 durante o intervalo de tempo da amostragem, o Analisador do Exchange Server exibirá um erro.

Epoxy (ExIPC) é um mecanismo de memória compartilhada que permite que os processos do Microsoft IIS (Serviços de Informações da Internet — Inetinfo.exe) e os Serviços de Armazenamento de Informações do Microsoft Exchange (Store.exe) transfiram dados de um lado para outro, rapidamente. Isso permite a comunicação interprocessual bidirecional entre os processos Inetinfo.exe e Store.exe.

Observação:
O Inetinfo.exe aceita solicitações de protocolos da Internet, como o WebDAV, IMAP4, NNTP, POP3 e SMTP.

Essa memória também é usada pelo DSAccess, componente do Exchange que armazena informações do Active Directory® em cache.

Esse erro indica que existem problemas de desempenho no processo Inetinfo.exe ou nos recursos dos quais o Inetinfo.exe depende, que estão causando o aumento da fila. Isso pode aumentar o tempo de resposta do servidor. Como conseqüência, os usuários enfrentarão atrasos na resposta do servidor.

Para resolver esse problema, use os recursos citados na seção "Mais informações" para identificar o afunilamento de desempenho ocorrendo no Inetinfo.exe ou em recursos relacionados. Esse afunilamento pode estar relacionado a um desempenho de disco insuficiente ou à intensa utilização da CPU.

Para obter mais informações

  • Para obter mais informações sobre como identificar as filas crescentes no Epoxy, consulte "Identificando filas crescentes no Epoxy" em Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre os afunilamentos do processador, consulte Afunilamento do processador.

  • Para obter mais informações sobre os afunilamentos de disco, consulte Afunilamento de disco detectado.

  • Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento, consulte o artigo 257725 da Base de Dados de Conhecimento da Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


Comprimento da Fila de Saída do Armazenamento Epoxy (POP) acima do limite
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Store Out Queue Length (POP) do objeto de desempenho de Epoxy para analisar os dados do desempenho.

O contador de desempenho Store Out Queue Length (POP) indica o número de mensagens na fila que contêm mensagens POP3 enviadas pelo processo Store.exe para o processo Inetinfo.exe. A fila deve permanecer sempre abaixo de 50. O Analisador do Exchange Server recupera uma amostra desse contador a cada 5 segundos, por um período de 5 minutos. Ao determinar que o contador de Store Out Queue Length (POP) excedeu o valor de pico de 50 durante o intervalo de tempo da amostragem, o Analisador do Exchange Server exibirá um erro.

Epoxy (ExIPC) é um mecanismo de memória compartilhada que permite que os processos do Microsoft IIS (Serviços de Informações da Internet — Inetinfo.exe) e os Serviços de Armazenamento de Informações do Microsoft Exchange (Store.exe) transfiram dados de um lado para outro, rapidamente. Isso permite a comunicação interprocessual bidirecional entre os processos Inetinfo.exe e Store.exe.

Observação:
O Inetinfo.exe aceita solicitações de protocolos da Internet, como o WebDAV, IMAP4, NNTP, POP3 e SMTP.

Essa memória também é usada pelo DSAccess, componente do Exchange que armazena informações do Active Directory® em cache.

Esse erro indica que existem problemas de desempenho no processo Inetinfo.exe ou nos recursos dos quais o Inetinfo.exe depende, que estão causando o aumento da fila. Isso pode aumentar o tempo de resposta do servidor. Como conseqüência, os usuários enfrentarão atrasos na resposta do servidor.

Para resolver esse problema, use os recursos citados na seção "Mais informações" para identificar o afunilamento de desempenho ocorrendo no Inetinfo.exe ou em recursos relacionados. Esse afunilamento pode estar relacionado a um desempenho de disco insuficiente ou à intensa utilização da CPU.

Para obter mais informações

  • Para obter mais informações sobre como identificar as filas crescentes no Epoxy, consulte "Identificando filas crescentes no Epoxy" em Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre os afunilamentos do processador, consulte Afunilamento do processador.

  • Para obter mais informações sobre os afunilamentos de disco, consulte Afunilamento de disco detectado.

  • Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento, consulte o artigo 257725 da Base de Dados de Conhecimento da Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


Erro ao acessar o Exchange Server
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer não pode acessar o servidor Exchange. Este erro indica que as informações de configuração especificadas do servidor Exchange não foram encontradas no serviço de diretório do Active Directory®.

Para corrigir esse erro

  • Verifique se você digitou o nome do servidor corretamente.

  • Digite apenas o nome do host ou NetBIOS do servidor (por exemplo, Server1) em vez do nome de domínio totalmente qualificado (por exemplo, Server1.example.com).

  • Verifique se você tem as permissões necessárias para acessar as informações da configuração do Active Directory desse servidor.


Erro ao acessar informações do Exchange Server
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool está com problemas para acessar as informações de configuração do serviço de diretório do Active Directory® no servidor Exchange.

Para corrigir esse erro:

  • Verifique se a conta de logon atual possui as permissões apropriadas para ler as informações de configuração do Exchange Server no Active Directory.

  • Verifique se você tem conectividade de rede para um controlador de domínio do Active Directory.

  • Insira as credenciais explícitas da conta na ferramenta Exchange Server Analyzer Tool para acessar o Active Directory.

  • Especifique um controlador de domínio do Active Directory no Exchange Server Analyzer.

  • Verifique se o servidor Exchange especificado existe e se você digitou o nome do servidor corretamente.


Erro ao acessar o log de controle de mensagens
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-06

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a propriedade MessageID de cada instância da classe Exchange_MessageTrackingEntry do WMI (Instrumentação de Gerenciamento do Microsoft Windows®).

Se o Exchange Server Analyzer não receber um resultado da consulta, o Exchange Server Analyzer exibirá um erro.

A causa mais provável desse erro é que a Central de Controle de Mensagens está desabilitada.

O Centro de Controle de Mensagens, quando está habilitado, registra informações sobre o remetente, a mensagem e os destinatários da mensagem. Especificamente, você pode revisar as estatísticas, como a hora em que a mensagem foi enviada ou recebida, o tamanho e a prioridade da mensagem e a lista de destinatários da mensagem. Você pode também registrar a linha de assunto das mensagens de email. O Centro de Controle de Mensagens procura mensagens, como mensagens do sistema, mensagens de pastas públicas e mensagens de email.

Você deve habilitar a Central de Controle de Mensagens em todos os servidores dos quais você deseja rastrear mensagens. Quando está habilitado, todas as mensagens que são roteadas por meio de um servidor são adicionadas aos logs de controle de mensagem.

O Analisador do Exchange Server requer que o controle de mensagens esteja habilitado para iniciar sua verificação.

Observação:
As permissões a seguir são necessárias para executar este procedimento: Membro do grupo de administradores locais e membro de um grupo que teve a função Administradores do Exchange aplicada no nível do grupo administrativo
Para habilitar o Centro de Controle de Mensagens em um servidor

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, clique com o botão direito no servidor em que deseja habilitar o controle de mensagens e clique em Propriedades.

  2. Na guia Geral, marque a caixa de seleção Habilitar controle de mensagens .

  3. Para registrar o assunto de qualquer mensagem enviada para, recebida do ou por meio do servidor, marque a caixa de seleção Habilitar log e exibição de assunto.

    Observação:
    Se você habilitar o log de assunto, pode provocar perda de desempenho.

  4. Em Manutenção de arquivo de log, você pode impedir a remoção dos arquivos de log ou modificar o tempo que os arquivos de log são mantidos. O período padrão que os logs de controle são mantidos é de sete dias.

    Observação:
    Em servidores que processam grandes quantidades de correio, os logs de controle crescem rapidamente. Certifique-se de que tenha espaço suficiente em disco para os arquivos de log e para outros serviços ou aplicativos que usam esse disco.

  5. Clique em OK ou em Aplicar. Você não precisa reiniciar os serviços para que essa alteração entre em vigor.

Para obter mais informações sobre como usar o Centro de Controle de Mensagens, consulte o artigo 262162 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o centro de controle de mensagens para controlar uma mensagem (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162).

Para obter mais informações sobre como solucionar problemas de transporte do Exchange Server, consulte o artigo 821910 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de transporte do Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).


Erro ao atualizar as ACLs
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-02-15

A ferramenta Microsoft Exchange Analyzer consulta a classe Win32_NTLogEvent de WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar se um erro de Evento 9551 foi registrado para o MSExchangeIS na última hora.

Se o Exchange Analyzer detectar que um erro de Evento 9551 foi registrado na última hora, ele contará o número total de erros de Evento 9551 durante essa hora.

Por fim, se o Exchange Analyzer detectar que um erro de Evento 9551 foi registrado 20 vezes ou mais na última hora, ele exibirá um aviso.

Esse erro indica que pode haver contas de usuário em uma ACL para um recurso de caixa de correio ou pasta pública que não estejam associadas a objetos válidos do serviço de diretório do Active Directory.

Para estar acessível, uma caixa de correio em um servidor que executa o Microsoft Exchange Server 2003 ou o Exchange 2000 Server deve estar representada no Active Directory por uma conta de usuário válida do serviço de diretório do Active Directory.

Uma conta sem representação válida no Active Directory poderá ser criada se o recurso de caixa de correio ou a pasta pública do Exchange 2000 Server ou Exchange Server 2003 não for atualizado após a exclusão de uma caixa de correio no computador do Exchange Server 5.5.

Se a conta de caixa de correio excluída permanecer na ACL de um recurso de caixa de correio ou uma pasta pública, sempre que esse recurso ou pasta pública for acessado e o Exchange tentar resolver as contas listadas, a conta sem representação válida no Active Directory não poderá ser resolvida. Esse processo pode se manifestar como problema de desempenho.

Para resolver esse problema:

  • Verifique se o Exchange 2000 Server Service Pack 3 (SP3) ou uma versão posterior está instalado. Para obter o Service Pack mais recente do Exchange 2000 Server, consulte o artigo 301378 da Base de Dados de Conhecimento Microsoft, "Como obter o service pack mais recente do Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378). (página em inglês)

  • Use o Gerenciador de Sistema do Exchange para remover manualmente as contas de caixa de correio inválidas da ACL.

  • Se o ambiente do Exchange estiver em modo misto, execute o verificador de consistência DS/IS no armazenamento de informações.

  • Se o ambiente do Exchange estiver no modo nativo, siga a orientação do artigo 324323 da Base de Dados de Conhecimento Microsoft, "XADM: Ignorando contas de usuário não representadas no Active Directory durante a conversão da lista de controle de acesso" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323).

Para usar o Gerenciador de Sistema do Exchange para remover manualmente as contas inválidas da ACL

  1. Inicie o Gerenciador de Sistema do Exchange e localize a pasta identificada pelo erro 9551.

  2. Clique com o botão direito na pasta e selecione Propriedades.

  3. Selecione a guia Permissões e clique em Permissões do cliente.

  4. No painel Nome, selecione a conta de usuário identificada pelo erro 9551 e clique no botão Remover para remover a conta da ACL.
Para executar o verificador de consistência DS/IS no armazenamento de informações no Modo Misto do Exchange

  1. No programa Administrador do Exchange Server 5.5, clique no computador do Exchange 5.5 Server que contém o armazenamento de informações.

  2. No menu Arquivo, clique em Propriedades e, em seguida, clique na guia Avançado.

  3. Clique em Ajuste de Consistência.

  4. Clique para marcar as caixas de seleção Remover contas de usuário desconhecidas das permissões de pasta pública e Remover contas de usuário desconhecidas das permissões de caixa de correio e clique em Todas as Inconsistências.

  5. Clique para desmarcar as outras caixas de seleção e depois clique em OK

Para obter mais informações

Para obter mais informações sobre esse problema, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft e os recursos do Exchange Server:

  • Centro de mensagem de erros e eventos: Detalhes do evento: Detalhes do Evento 9551 de Armazenamento de Caixa de Correio do MSExchangeIS (http://go.microsoft.com/fwlink/?LinkId=83189) (página em inglês)

  • Artigo 301378 da Base de Dados de Conhecimento Microsoft, "Como obter o service pack mais recente do Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378). (página em inglês)

  • Artigo 324323 da Base de Dados de Conhecimento Microsoft, "XADM: Ignorando contas de usuário não representadas no Active Directory durante a conversão da lista de controle de acesso" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323).


O arquivo ESE.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-21

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, pacotes cumulativos de atualizações e suplementos mais recentes do Exchange Server 2003, consulte "Downloads para o Exchange 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, pacotes cumulativos de atualizações e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads para o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=33457).


O arquivo ESEUTIL.EXE está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre service packs, pacote cumulativo de atualizações e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads para o Exchange 2000 Server" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O arquivo EXCDO.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo EXCHMEM.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para corrigir esse erro, instale o service pack ou o pacote cumulativo de atualizações mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O arquivo EXMIME.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução do programa de Instalação no modo Reinstalar instala apenas arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 em sua unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, pacote cumulativo de atualizações e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O arquivo EXOLEDB.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O arquivo EXPOP3.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução do programa de Instalação no modo Reinstalar instala apenas arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 em sua unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O arquivo EXPROX.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para corrigir esse erro, instale o service pack mais recente ou distribua sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O arquivo EXRES.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para corrigir esse erro, instale o service pack mais recente ou distribua sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O arquivo EXSMTP.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


A versão do arquivo EXSMTP.DLL está desatualizada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

Mensagem de Erro

Introdução

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft® Windows) para determinar o valor da chave Version de EXSMTP.DLL. Se o Exchange Server Analyzer verificar que a chave Version de EXSMTP.DLL não é igual a 6556.0, será exibido um aviso.

Esse aviso indica que a versão de EXSMTP.DLL nesse computador do Exchange Server faz parte da Versão 1, de Maio de 2004, da Distribuição do Exchange 2000 Server Pós-Service Pack 3. Uma distribuição de atualização mais recente está disponível para download.

Para corrigir esse aviso

  1. Baixe a atualização mais recente (agosto de 2004) de "Downloads para o Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=33457).

  2. Leia sobre a atualização mais recente, consultando o artigo 870540 da Base de Dados de Conhecimento Microsoft, "Disponibilidade da Distribuição de Atualização do Exchange 2000 Server Pós-Service Pack 3, de agosto de 2004" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540).

  3. Execute um backup completo do computador do Exchange Server.

  4. Aplique a atualização de agosto de 2004.

Para obter mais informações sobre como instalar essa e outras atualizações do Exchange Server, consulte o artigo 328839 da Base de Dados de Conhecimento da Microsoft, "Como aplicar os service packs e hotfixes do Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


O rastreamento do Exchange ActiveSync está habilitado no momento
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar se o rastreamento foi habilitado para o Exchange ActiveSync®:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync\Enabled

Se o Analisador do Exchange Server detectar a presença do valor Habilitado configurado com um valor maior que 0, um aviso será exibido.

O Exchange ActiveSync é implantado como uma extensão ISAPI (Internet Server Applications Programming Interface) com IIS (Serviço de Informações da Internet). O IIS, o Exchange ActiveSync e muitos dos dispositivos cliente que usam o Exchange ActiveSync incluem recursos de rastreamento, tornando-se óbvia a necessidade do uso de recursos de rastreamento nativos do Microsoft Windows Server™ 2003.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync

  3. Exclua o valor Habilitado.

  4. Feche o editor do Registro e reinicie o computador do Exchange Server para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editar o Registro, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como rastrear e registrar os clientes do Exchange ActiveSync e do Exchange ActiveSync, consulte os artigos a seguir da Base de Dados de Conhecimento:

  • 330463, "XCCC: Como solucionar problemas de códigos de erro HTTP do servidor ActiveSync (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330463).

  • 330461, "COMO FAZER PARA: Solucionar problemas do servidor ActiveSync" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330461)

  • 822176, "Solucionar problemas de notificação sempre atualizada do Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822176)


A versão do arquivo binário do Exchange é mais nova do que a versão instalada do Exchange Server
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server detectar o valor de Versão de qualquer um dos arquivos citados anteriormente maior do que o valor de Versão do Exchange Server, será exibido um aviso. Um número de versão posterior indica que um arquivo é mais recente do que era esperado. Isso poderá ocorrer se um a hotfix estiver instalado.

Para resolver este aviso

  1. Não é necessário executar nenhuma ação. O aviso só indica a presença de arquivos mais recentes, o que provavelmente é o resultado da instalação de um hotfix ou outra atualização.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


Esse nó de cluster do Exchange é também um controlador de domínio
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta o objeto da Instrumentação de Gerenciamento do Microsoft Windows® (classe Win32_ComputerSystem) para determinar o valor de DomainRole para o servidor. O valor DomainRole representa a função do computador em um domínio. A tabela a seguir lista os valores válidos para DomainRole.

Valor | Significado
0 | Estação de trabalho autônoma
1 | Estação de trabalho do membro
2 | Servidor autônomo
3 | Servidor membro
4 | Controlador de domínio de backup
5 | Controlador de domínio principal

Além disso, o Exchange Server Analyzer consulta o objeto ClusSvc do WMI (objeto do Serviço de Cluster do Windows, classe Win32_Service) para determinar o valor Iniciado. Um valor Verdadeiro indica que o serviço de Cluster foi iniciado, e um valor Falso indica que não foi iniciado.

Se o Exchange Server Analyzer determinar que o valor para DomainRole é maior do que 3 em um computador do Exchange Server onde o serviço de Cluster está iniciado, será exibido um erro. Esse erro indica que o servidor do Exchange está executado em um cluster de servidores do Windows cujos nós são controladores de domínio.

A execução de um nó de cluster do Exchange Server como controlador de domínio não é uma configuração com suporte.

Para corrigir esse erro

  1. Escolha um servidor que não é de cluster para agir como controlador de domínio e execute o Assistente de Instalação do Active Directory (dcpromo) para promover esse servidor.

  2. Depois que o serviço de diretório do Active Directory tiver sido configurado no novo controlador de domínio, aguarde a replicação do conteúdo do Active Directory existente para o novo servidor.

    Dependendo do tamanho do Active Directory, essa operação pode levar várias horas.

  3. Execute o Assistente de Instalação do Active Directory (dcpromo) no servidor de cluster para rebaixar o servidor e remover o Active Directory.

Para obter mais informações sobre como promover e rebaixar controladores de domínio, consulte o artigo 238369 da Base de Dados de Conhecimento Microsoft, "Como promover e rebaixar controladores de domínio no Windows 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=238369).


Relatório de Erros do Exchange está desabilitado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-21

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o Relatório de Erros do Exchange está habilitado:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\DisableErrorReporting

Se o Exchange Server Analyzer detectar que o valor para DisableErrorReporting é 1, será exibido um aviso. O valor 1 indica que o Relatório de Erros do Exchange está desabilitado.

O Suporte para Relatório de Erros da Microsoft, também conhecido como Relatório de Erros do Windows, Relatório de Eventos da Microsoft e Relatório de Erros Automático, foi incluído pela primeira vez no Exchange 2000 Server Service Pack 2. O Exchange Server 2003 contém uma versão aprimorada do Relatório de Erros da Microsoft, denominada Relatório de Erros do Exchange, que simplifica o processo de geração de relatórios de erros para os administradores, integra-se ao Relatório de Erros Corporativo e fornece relatórios avançados para o Serviço de Atualização de Destinatário do Exchange Server 2003.

O Relatório de Erros do Exchange permite que os administradores do Exchange Server transmitam as falhas e outros erros fatais por meio do HTTPS na Internet para um servidor de relatórios de erros da Microsoft. É recomendável que você envie os relatórios de erros para a Análise de Falhas Online da Microsoft. A coleta dos dados de erros fatais de servidores Exchange ajuda a equipe do produto Exchange a localizar e corrigir os erros no software que você utiliza.

Se ocorrer um erro fatal ao utilizar o Gerenciador do Sistema do Exchange ou ao executar uma tarefa relacionada ao Exchange com Usuários e Computadores do Active Directory em um computador em que o Gerenciador do Sistema do Exchange foi instalado, o Relatório de Erros do Exchange notificará esse erro ao administrador e perguntará se ele deseja relatar o erro à Microsoft. Além disso, o Relatório de Erros do Exchange também intercepta e relata os erros detectados pelo Atendedor do Sistema do Microsoft Exchange, Armazenamento de Informações do Microsoft Exchange e por outros serviços do Exchange. Adicionalmente, como os erros detectados pelo Serviço de Atualização de Destinatário podem deixar o componente Atendedor do Sistema em um estado inválido, o Relatório de Erros do Exchange também informa as violações de acesso e outras falhas internas ocorridas no Serviço de Atualização de Destinatário.

É possível configurar cada servidor Exchange para enviar informações de erros fatais, selecionando a respectiva caixa na página de propriedades do servidor no Gerenciador do Sistema do Exchange.

Para configurar o Exchange 2000 Server ou Exchange Server 2003 para enviar os dados de erros fatais do servidor para a Microsoft

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos, expanda seu grupo administrativo, Servidores, clique com o botão direito em seu servidor e clique em Propriedades. Se o nó Grupos Administrativos não estiver exibido no Gerenciador do Sistema do Exchange, expanda Servidores, clique com o botão direito em seu servidor e clique em Propriedades.

  3. Na guia Geral da página <Propriedades do> Nome do Servidor, marque a caixa Enviar automaticamente informações de erro fatal do serviço à Microsoft e clique em Aplicar.

  4. Clique em Sim para confirmar que deseja habilitar o Relatório de Erros do Exchange.

  5. Clique em OK.

Quando um erro fatal for detectado, será criado um arquivo de relatório de erros compactado (geralmente, com 10-50 quilobytes). Esse relatório contém um arquivo de despejo, entre outros itens. Um arquivo de despejo contém informações sobre o processo submetido à falha. Embora as falhas possam ocorrer em vários níveis de programação (por exemplo, no nível do thread, da interface e do método ou da função), todos eles ocorrem dentro do contexto de um único processo. Geralmente, o arquivo de despejo contém informações sobre o processo com falha, como detalhes do que cada thread estava fazendo, as diversas áreas da memória usadas pelo processo, informações do sistema e outras informações relevantes sobre a depuração. Com o Exchange Server, os relatórios de erros também contêm informações sobre o estado do Exchange Server, informações de versão do sistema operacional, detalhes sobre o hardware do computador, o endereço IP do computador e uma ID de produto digital usada para identificar a licença do produto.

Embora a Microsoft não tenha a intenção de coletar informações pessoais, confirmamos que algumas das informações coletadas poderão conter informações a serem usadas para identificar exclusivamente seu sistema. Contudo, a Microsoft não usa os dados coletados dessa maneira, só os utiliza para relatórios de falhas e correção de erros. Para obter mais informações, consulte a diretiva de relatório de erros, "Diretiva de Coleta de Dados" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33818).


Esse servidor front-end Exchange tem a opção de inicialização /3GB definida no arquivo Boot.ini
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows) Win32_OperatingSystem para determinar a quantidade de espaço de endereçamento virtual alocada para os processos de modo do usuário (MaxProcessMemorySize) no computador do Exchange Server. O Analisador do Exchange Server também examina a classe WMI Exchange_Server no namespace root\MicrosoftExchangeV2 para determinar o valor da chave IsFrontEndServer. Um valor Falso indica que o computador do Exchange Server não é um servidor front-end. Um valor Verdadeiro indica que o computador do Exchange Server é um servidor front-end.

Se o Analisador do Exchange Server determinar que o valor para a chave MaxProcessMemorySize não é igual a 2097024 e que a chave IsFrontEndServer está definida como Verdadeira, um aviso será exibido.

Esse aviso indica que o computador do Exchange Server não está configurado corretamente para um uso de memória ideal porque a opção de inicialização /3GB foi definida no arquivo Boot.ini. Essa opção só deve ser usada em Exchange Servers com 1 GB (gigabyte) ou mais de memória que estejam executando qualquer um dos seguintes sistemas operacionais:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Importante:
A opção /3GB não deve ser usada no Windows 2000 Server porque não é suportada e pode ocasionar falhas em aplicativos e no sistema operacional. Além disso, a opção /3GB só tem suporte nos sistemas operacionais listados anteriormente quando houver 1 GB ou mais de memória física instalada.

Quando o parâmetro /3GB estiver incluído no arquivo Boot.ini de um servidor que executa o Microsoft Windows 2000 Server ou Windows Server 2003, o Windows aloca 3 GB além de um máximo de 4 GB de espaço de endereçamento virtual para o processo do usuário e 1 GB para o kernel. Normalmente (quando o parâmetro /3GB não é usado), o Windows aloca 2 GB para o processo do usuário e 2 GB para o kernel. Portanto, com a opção /3GB, os aplicativos que fazem uso intenso da memória têm um espaço de memória virtual maior no qual operar e um desempenho melhor.

O uso da opção /3GB ajuda principalmente a aplicativos com uso intenso de memória, como o processo Store.exe em um servidor Exchange que hospeda caixas de correio de usuário. Um servidor front-end não hospeda caixas de correio de usuário e, portanto, não há benefício derivado de usar a opção /3GB em um servidor front-end.

Para corrigir esse aviso

  1. No Windows Explorer, navegue para a partição do sistema.

  2. Se você não consegue ver o arquivo Boot.ini, pode ser devido às Opções de Pasta estarem definidas como Ocultar arquivos protegidos do sistema operacional. Nesse caso, na janela do Windows Explorer, clique em Ferramentas, clique em Opções de Pasta e clique na guia Exibir. Desmarque a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado). Quando a caixa de aviso aparecer, clique em Sim.

  3. Quando o arquivo Boot.ini estiver visível no Explorer, clique com o botão direito no arquivo, clique em Abrir com e escolha Bloco de Notas para abrir o arquivo.

  4. Na seção [Sistemas Operacionais] , exclua as opções a seguir das linhas de inicialização: /3GB

  5. Salve as alterações e feche o Bloco de Notas.

  6. Reinicie o computador para que a alteração entre em vigor.

Para obter detalhes adicionais referentes ao uso da opção de inicialização /3GB, consulte os seguintes arquivos da Base de Dados de Conhecimento da Microsoft:

  • 297812, "How to Use the 4GT RAM Tuning Feature" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "The effects of 4GT tuning on system Page Table Entries" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 31679, "Como usar a opção /userva com a opção /3GB para ajustar o espaço Modo usuário para um valor entre 2GB e 3GB" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


A unidade IFS do Exchange não foi excluída explicitamente do backup do Windows
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar que arquivos e pastas foram excluídos dos backups usando Backup:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

O Analisador do Exchange Server procura especificamente um valor de cadeia de caracteres chamado IFS do Exchange.

O Analisador do Exchange Server também lê a seguinte entrada do Registro para obter a letra da unidade que representa a unidade IFS (Sistema de Arquivos Instalável) do Exchange:

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

No Exchange 2000 Server, a letra da unidade padrão é M. Por padrão, a unidade IFS está desativada no Exchange Server 2003.

Se o Analisador do Exchange Server detectar que a chave FilesNotToBackup não contém um valor de cadeia de caracteres chamado IFS do Exchange ou contém IFS do Exchange, mas os dados do valor para IFS do Exchange não correspondem a M:\* /s (em que M é a letra da unidade que representa o IFS), um aviso será exibido.

Por padrão, quando o mapeamento da letra da unidade IFS está habilitado, IFS do Exchange é adicionado à chave do Registro FilesNotToBackup. A unidade M:\ é uma exibição lógica do armazenamento do Exchange e não uma unidade verdadeira, e fazer backup dela pode provocar problemas significativos como perda de anexos. Além disso, o software de backup pode não truncar os arquivos de log corretamente, o que pode resultar em uma falta de espaço em disco inesperada no servidor.

Se você não estiver usando Backup, poderá ignorar esse aviso com segurança. Se estiver usando Backup, é recomendável que exclua a unidade IFS de todos os trabalhos de backup. Se você fizer backup da unidade IFS com Backup ou qualquer outro programa de backup, poderá corromper as informações do banco de dados de armazenamento, perder dados e não conseguir restaurá-los de um backup da unidade IFS.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. Clique com o botão direito em FilesNotToBackup e clique em Novo | Valor de várias cadeias de caracteres . Digite IFS do Exchange como o nome e pressione Enter.

  4. No painel direito, clique duas vezes em IFS do Exchange e insira Dados de Valor de M:\* /s. Certifique-se de usar a letra da unidade correta caso seu sistema não use a letra de unidade M padrão.

  5. Feche o editor de Registro.

Para obter mais informações sobre o Registro do Microsoft Windows®, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Para obter mais informações sobre como fazer backup e restaurar o Exchange, consulte o Guia de Operações de Recuperação de Desastres do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47570). Para obter informações adicionais, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 258243, "Como fazer backup e restaurar um computador do Exchange com o programa Backup do Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258243)

  • 233427, "Arquivos e pastas dos quais não foram feitos backup quando a ferramenta Ntbackup.exe era usada no Windows Server 2003, Windows XP e Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=233427)

Para obter mais informações sobre os problemas que podem ocorrer se você verificar a unidade IFS com software antivírus, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 298924, "XADM: Não faça backup nem verificação na unidade M do Exchange 2000 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM:C1041737 Err Msg Displayed When You Mount Databases" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: Itens do calendário desaparecem das pastas do usuário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


Esse servidor de caixa de correio do Exchange tem 1 GB ou mais de memória, mas não tem /3GB definido no arquivo Boot.ini.
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta duas classes do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar a quantidade de memória física no servidor Exchange e a quantidade de espaço de endereçamento virtual alocado para processos do modo de usuário. A tabela a seguir descreve as classes e chaves sendo avaliadas pelo Exchange Server Analyzer.

Classe consultada | Chaves consultadas | Descrição
Win32_OperatingSystem | MaxProcessMemorySize | Número máximo de kilobytes de memória que pode ser alocado em um processo.
Win32_OperatingSystem | OSProductSuite | Inclusões de produtos de sistema instaladas e licenciadas para o sistema operacional.
Win32_ComputerSystem | TotalPhysicalMemory | Número de bytes da memória RAM (random access memory) instalada no computador.

Se o Exchange Server Analyzer determinar que o computador do Exchange Server não está executando o Windows 2000 Server e tem 1 gigabyte (GB) ou mais de memória física instalada, e o valor de MaxProcessMemorySizeé superior a 2097024, mas inferior a 3104640, será exibido um aviso.

Esse aviso indica que o servidor Exchange não atende aos requisitos estabelecidos no artigo 266096 da Base de Dados de Conhecimento Microsoft, "Exchange 2000 exige a opção /3GB com mais de 1 gigabyte de RAM física" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096) (em inglês). Esta não é uma configuração de produção recomendada.

O Microsoft Windows Server™ 2003 inclui suporte para duas opções de inicialização, /3GB e /USERVA, que lhe permite ajustar a alocação do uso da memória e do espaço de endereçamento de memória. Seja qual for a quantidade de memória física existente no sistema, o Windows usará um espaço de endereçamento virtual de 4 GB, com 2 GB alocados para os processos do modo de usuário (por exemplo, aplicativos) e 2 GB alocados para os processos do modo kernel (por exemplo, os drivers do sistema operacional e do modo kernel). Nos sistemas com 1 GB ou mais de memória física, essas duas opções de inicialização podem ser usadas para alocar mais memória para os aplicativos (3 GB) e menos memória para o sistema operacional (1 GB). Esse espaço de endereçamento virtual adicional ajuda a reduzir a quantidade de fragmentação da memória no espaço de endereçamento virtual do processo de armazenamento de informações do Exchange.

A opção /3GB é usada para efetivar essa alteração de alocação. A opção é inserida no arquivo Boot.ini do sistema e é aplicada após a reinicialização. Esse comando só deve ser usado em servidores Exchange com 1 GB ou mais de memória executando qualquer um dos seguintes sistemas operacionais:

  • Microsoft Windows Server 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Importante:
A opção /3GB não deve ser usada no Windows 2000 Server porque não é suportada e pode ocasionar falhas em aplicativos e no sistema operacional. Além disso, a opção /3GB só tem suporte nos sistemas operacionais listados anteriormente quando houver 1 GB ou mais de memória física instalada.

A opção /USERVA é novo no Windows Server 2003. O seu objetivo é fornecer um controle mais preciso sobre a divisão do espaço de endereçamento virtual entre processos de modo de usuário e modo kernel. Essa opção só deve ser usada para aplicativos ao quais ele oferece suporte, como o Exchange 2000 Server e Exchange Server 2003, e com os valores específicos aceitos por esses aplicativos.

Observação:
O Atendimento Microsoft não oferece suporte a configurações arbitrárias da opção /USERVA. Os clientes devem adicionar essa configuração ao arquivo Boot.ini com base apenas em uma recomendação do fabricante.

Quando utilizada em sistemas do Exchange Server 2003, o único valor aceito para a opção /USERVA é 3030 (por exemplo, /USERVA=3030). Esse valor faz com que 40 megabytes (MB) adicionais sejam alocados para o sistema operacional e permite que você adicione mais usuários sem consumir todos os recursos disponíveis do sistema.

Para corrigir esse aviso

  1. Clique com o botão direito em Meu Computador e selecione Propriedades. A caixa de diálogo Propriedades do Sistema será exibida.

  2. Clique na guia Avançado.

  3. Na área de Inicialização e Recuperação, clique em Configurações. A caixa de diálogo Inicialização e Recuperação será exibida.

  4. Na área de inicialização do Sistema, clique em Editar. Isso abrirá o arquivo Boot.ini do Windows no Bloco de Notas.

  5. Na seção [Sistemas Operacionais], adicione as seguintes opções ao fim da linha de inicialização que contém a opção /fastdetect: /3GB /USERVA=3030

  6. Salve as alterações e feche o Bloco de Notas.

  7. Clique em OK duas vezes para fechar as caixas de diálogo abertas e reinicie o computador do Exchange Server para que a alteração seja aplicada.

Para obter mais informações sobre como otimizar o uso da memória e o desempenho no Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266096, "Exchange 2000 exige a opção /3GB com mais de 1 gigabyte de RAM física" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096) (em inglês)

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • 810371, "XADM: Usando a opção /Userva em computadores com base no Windows Server 2003 que estão executando o Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)

  • 823440, "Uso da opção /3GB no Exchange Server 2003 em um sistema com o Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

  • 822178, "Visão geral de dependências e requisitos para recursos do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822178) (em inglês)


O serviço de Gerenciamento do Exchange não está sendo executado como LocalSystem
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da propriedade StartName para o serviço MSExchangeIS (Gerenciamento do Microsoft Exchange). Se o Exchange Server Analyzer detectar que o serviço Gerenciamento do Exchange está sendo executado em qualquer conta que não seja a LocalSystem (SYSTEM), o Exchange Server Analyzer exibirá um erro.

Esse erro indica que o serviço Gerenciamento do Exchange não está sendo executado em uma configuração aceita. Se você executar o serviço Gerenciamento do Exchange em outra conta, serão gerados erros de permissão e acesso.

Para resolver esse erro, você deve configurar esse serviço para ser iniciado na conta LocalSystem (SYSTEM).

Para configurar a conta do serviço Gerenciamento do Exchange

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. Localize e pare o serviço Gerenciamento do Microsoft Exchange.

  3. Clique duas vezes no serviço Gerenciamento do Microsoft Exchange.

  4. Na guia Logon da página Propriedades do Gerenciamento do Microsoft Exchange, selecione Conta Sistema Local em Fazer Logon como e clique em Aplicar.

  5. Em Status do Serviço, clique em Iniciar e clique em OK.

  6. Feche o snap-in Serviços.

Para obter mais informações sobre como executar os serviços do Exchange na conta LocalSystem, consulte o artigo 239762 da Base de Dados de Conhecimento da Microsoft, "Serviços do Exchange Executam no LocalSystem" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


O serviço Gerenciamento do Exchange está parado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Process do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started da instância MSExchangeMGMT que representa o serviço Gerenciamento do Microsoft Exchange. Se o Exchange Server Analyzer perceber que o valor da chave Started da instância MSExchangeMGMT não está definido como True, será exibido um aviso.

O serviço Gerenciamento do Exchange foi introduzido no Exchange 2000 Server Service Pack 2. Entre outros aspectos, a funcionalidade do Centro de Controle de Mensagens do Exchange Server e determinadas funções do Gerenciador do Sistema do Exchange dependem do funcionamento desse serviço.

O serviço Gerenciamento do Exchange permite especificar, através da interface do usuário, que o controlador de domínio ou servidor de catálogo global o Exchange Server 2003 ou Exchange 2000 Server usa para acessar o serviço de diretório do Active Directory®. Esse serviço também é necessário para o controle de mensagens. É possível desabilitar esse serviço sem afetar a funcionalidade central do Exchange. Contudo, ao auditar a funcionalidade do Exchange Server, você pode exigir recursos de controle de mensagens em todos os computadores do Exchange Server que roteiam emails.

Observação:
Como os servidores front-end são usados com maior freqüência para acessar email, em vez de para rotear emails, provavelmente você não precisará executar o serviço Gerenciamento do Exchange em seus servidores front-end.

Para configurar o serviço Gerenciamento do Exchange para iniciar automaticamente

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. Clique duas vezes no serviço Gerenciamento do Microsoft Exchange.

  3. Na guia Geral da página de propriedade do Gerenciamento do Microsoft Exchange, selecione Automático na caixa de diálogo Tipo de inicialização e clique em Aplicar.

  4. Em Status do serviço, clique em Iniciar e clique em OK.

Para obter mais informações sobre o serviço Gerenciamento do Exchange, consulte o artigo 307413 da Base de Dados de Conhecimento Microsoft, "XGEN: Informações gerais sobre o serviço Gerenciamento do Exchange" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307413).

Para obter informações mais gerais sobre como gerenciar o Exchange, consulte o Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


O rastreamento do provedor do Exchange está habilitado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-06-20

A ferramenta Microsoft Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory para determinar o valor do atributo serialNumber para todos os objetos que tenham a classe msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 5.5", o computador estará executando o Microsoft Exchange Server 5.5. Se o valor da cadeia de caracteres incluir "Version 6.0", o computador estará executando o Microsoft Exchange 2000 Server. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador estará executando o Microsoft Exchange Server 2003; se incluir "Version 8.0", estará executando o Microsoft Exchange Server 2007.

O Exchange Analyzer também consulta a classe CIM_Datafile do Microsoft® WMI (Instrumentação de Gerenciamento do Windows®) para determinar o valor da chave Version para Emsmdb32.dll, o Provedor de Transporte do Exchange. A chave Version do WMI indica o número de compilação do arquivo.

Por fim, o Exchange Analyzer consulta a entrada do Registro a seguir para determinar se o rastreamento do provedor do Exchange foi configurado e habilitado.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing

O Exchange Analyzer exibirá uma mensagem de erro se as seguintes condições forem verdadeiras:

  • O servidor não estiver executando o Exchange Server 2007.

  • A chave Version do Emsmdb32.dll for 6.5.7233.47 ou versões posteriores.

  • A entrada HKML\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing existir e estiver definida como um valor diferente de 0.

Esse erro indica que o Rastreamento do Provedor de Transporte do Exchange está habilitado no computador.

O Rastreador de Transporte do Exchange na versão 6.5.7233.47 e em versões posteriores possui recursos de rastreamento internos. Um arquivo .ttd permite o rastreamento dos seguintes programas:

  • Qualquer programa que use MAPI no servidor que está executando o Exchange Server 2003.

  • Qualquer programa que seja instalado com as Ferramentas de Gerenciamento do Sistema do Microsoft Exchange.

O Rastreamento do Provedor de Transporte do Exchange só deve ser habilitado para a solução de problemas ativa; caso contrário, pode afetar adversamente o desempenho típico do servidor.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para desabilitar o rastreamento do provedor do Exchange no Exchange Server 2003

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Procurar: HKML\Software\Microsoft\Exchange\Exchange Provider\

  3. No painel de navegação à direita:

    1. Clique com o botão direito e exclua a subchave Enable Tracing ou

    2. Clique duas vezes em Enable Tracing.

  4. Configure a subchave Enable Tracing com um valor igual a 0.

  5. Feche o editor de Registro.

  6. Reinicie o serviço Armazenamento de Informações do Exchange para que essas alterações entrem em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft (em inglês), Descrição do Registro do Microsoft Windows.


O Exchange 2000 Server não está executando o Service Pack mais recente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo versionNumber de cada objeto do Exchange Server. O atributo versionNumber representa a versão do Exchange Server que está sendo executada no computador.

O Analisador do Exchange Server também consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile para determinar o valor da chave Version do processo STORE.EXE. Se o Exchange Server Analyzer determinar que a chave Version para STORE.EXE possui um valor maior que 4416 e menor ou igual a 6249, um aviso será exibido.

Esse aviso indica que o computador do Exchange Server não está executando o código mais recente disponível para versão do Exchange em execução no computador.

Para corrigir esse aviso

  1. Baixe o Exchange 2000 Server Service Pack 3 (http://go.microsoft.com/fwlink/?LinkId=17058).

  2. Consulte o Guia de Implantação do Exchange 2000 Server Service Pack 3 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=12337).

  3. Baixe a atualização mais recente (agosto de 2004) (http://go.microsoft.com/fwlink/?LinkId=33457).

  4. Consulte as informações de atualização mais recentes no artigo 870540 da Base de Dados de Conhecimento Microsoft, "Disponiblidade do pacote cumulativo de atualizações do Exchange 2000 Server Post-Service Pack 3 de agosto de 2004" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540).

  5. Execute um backup completo do computador do Exchange Server.

  6. Aplique o Exchange 2000 Server Service Pack 3.

  7. Aplique a atualização de agosto de 2004.

Para obter mais informações sobre como obter o service pack mais recente do Exchange 2000 Server, consulte o artigo 301378 da Base de Dados de Conhecimento Microsoft, "Como obter o service pack mais recente do Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

Para obter mais informações sobre a instalação desta e de outras atualizações do Exchange Server, consulte o artigo 328839 da Base de Dados de Conhecimento, "Como aplicar service packs e hotfixes do Exchange" ( http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Não há suporte para o Exchange Server 2000 no Windows Server 2003.
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar a versão do sistema operacional Microsoft Windows® que está sendo executada no computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor igual a 4.0 em CurrentVersion indica que o computador está executando o Microsoft Windows NT® Server 4.0. Um valor igual a 5.0 indica que o computador está executando o Windows 2000 Server e um valor igual a 5.2 revela que o computador está executando o Windows Server™ 2003.

O Analisador do Exchange Server também consulta o serviço Active Directory® para conhecer o valor do atributo serialNumber de todos os objetos da classe msExchExchangeServer. Se o valor da cadeia de caracteres contiver Versão 5.5, o computador estará executando o Microsoft Exchange Server versão 5.5. Se o valor da cadeia de caracteres contiver Versão 6.0, o computador estará executando o Exchange 2000 Server. Se o valor da cadeia de caracteres contiver Versão 6.5, o computador estará executando o Exchange Server 2003.

Se o Analisador do Exchange Server encontrar um valor 5.2 em CurrentVersion e o valor Versão 6.0 em serialNumber, será exibido um erro. Não há suporte para esta configuração e você deve corrigir este erro o mais rapidamente possível.

Para corrigir esse erro

  1. Siga um destes procedimentos:

    • Instale o Exchange 2000 Server em um servidor que esteja executando um sistema operacional aceito e mova as caixas de correio para ele.

    • Atualize o Exchange 2000 Server para Exchange Server 2003.

Para obter mais informações sobre configurações aceitas, consulte o Guia de Implantação do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Para obter mais informações sobre o Exchange Server e Windows Server 2003, consulte o artigo 810591 da Base de Dados de Conhecimento da Microsoft, "Compatibilidade do Exchange Server com o Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591).


A versão de pré-lançamento do Exchange 2007 está instalada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-02-20

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para todos os objetos do Exchange Server contidos no diretório. O atributo serialNumber é um valor de cadeia de caracteres que inclui a versão do Exchange Server e a versão do service pack, se estiver instalado. Por exemplo, em um computador do Exchange Server 2007 que não tenha Service Pack instalado, o atributo serialNumber será igual a Versão 8.0 (Build 0685).

Se o Exchange Server Analyzer detectar que o valor do atributo serialNumber contém 8.0 em sua cadeia de caracteres, mas contém um número de build inferior a 0685 na cadeia de caracteres, um erro será exibido.

Esse erro indica que o computador do Exchange Server 2007 está executando uma versão de pré-lançamento do Exchange Server 2007.

Instalações de pré-lançamento do Exchange Server 2007 não são aceitas em ambientes de produção.

Para tratar esse erro, instale uma versão de produção do Exchange Server 2007.


O objeto servidor Exchange 2007 foi movido para um grupo administrativo diferente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-08-11

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para todos os objetos do Exchange Server no diretório.

O Exchange Server Analyzer também consulta o valor do atributo cn do grupo administrativo em que reside o servidor executando o Exchange Server, para detectar se é o grupo administrativo dedicado do Exchange 2007, Grupo Administrativo do Exchange (FYDIBOHF23SPDLT).

Ao detectar que o servidor está executando o Microsoft Exchange Server 2007, mas resideo em um grupo administrativo diferente do Grupo Administrativo do Exchange (FYDIBOHF23SPDLT), o Exchange Server Analyzer exibirá um erro.

Esse erro indica que o servidor pode ter sido movido manualmente do grupo administrativo dedicado do Exchange 2007 e pode estar ocasionando problemas no fluxo de mensagens.

O atributo serialNumber é um valor de cadeia de caracteres que inclui a versão do Exchange Server e a versão do service pack, se instalado. Um valor no atributo serialNumber igual a Versão 8.0 indica que o servidor está executando o Exchange 2007.

O Microsoft Exchange Server 2003 e o Microsoft Exchange 2000 Server usam Grupos Administrativos para agrupar objetos do Exchange para fins de atribuir permissão para gerenciar esses objetos. O Exchange 2007 não usa Grupos Administrativos como uma unidade lógica de gerenciamento. Para oferecer suporte para a coexistência entre o Exchange Server 2003 ou Exchange 2000 Server e o Exchange 2007, todos os servidores Exchange 2007 são automaticamente adicionados a um único Grupo Administrativo durante a instalação do Exchange 2007. Este Grupo Administrativo é reconhecido no Gerenciador do Sistema Exchange, no Exchange Server 2003, como Grupo Administrativo do Exchange (FYDIBOHF23SPDLT).

Para resolver esse problema, remova e reinstale o servidor.


Exchange residente no controlador do domínio que não é um servidor de catálogo global
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave DomainRole. Os valores válidos para essa chave são mostrados na tabela a seguir.

Valor | Significado
0 | Estação de trabalho autônoma
1 | Estação de trabalho do membro
2 | Servidor autônomo
3 | Servidor membro
4 | Controlador de domínio de backup
5 | Controlador de domínio principal

O Exchange Server Analyzer também consulta a classe Win32_Service do WMI para determinar o valor da chave Started para ClusSvc, o serviço de Cluster. Além disso, o Exchange Server Analyzer consulta a classe Win32_OperatingSystem do WMI para determinar o valor da chave OSProductSuite. O valor da chave OSProductSuite indica a versão do Windows que está sendo executada no computador.

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber de todos os objetos de diretório com categoria de objeto msExchExchangeServer. O valor do atributo serialNumber indica a versão do Exchange Server que está sendo usada.

Por fim, o Exchange Server Analyzer consulta o Active Directory para determinar o valor do atributo isGlobalCatalogReady deste servidor. Um valor True para este atributo indica que o servidor do diretório é também um servidor de catálogo global funcional, e um valor False indica que o servidor de diretório não é um servidor de catálogo global.

Se o Exchange Server Analyzer determinar que o valor para a chave DomainRole é maior que 3 em um computador do Exchange Server; que o computador do Exchange Server não está executando o Windows Small Business Server ou o Exchange Server versão 5.5, nem está sendo executado em um cluster do Windows; e que o atributo isGlobalCatalogReady está definido como False, um aviso será exibido.

Este aviso indica que o Exchange Server está sendo executado em um servidor de diretório que não é também um servidor de catálogo global em funcionamento. Essa não é uma configuração aceita, e pode causar falha de serviços do Exchange.

Se o Exchange Server estiver sendo executado em um controlador de domínio sem o Small Business Server, considere as seguintes questões:

  • Exchange Server e Active Directory são aplicativos que utilizam muitos recursos. Existem implicações de desempenho a serem consideradas quando os dois aplicativos estão sendo executados no mesmo computador.

  • Se o Exchange Server estiver em execução em um controlador de domínio, você deverá tornar esse controlador de domínio um servidor de catálogo global.

  • Vários componentes de diretório do Exchange Server, como o DSAccess (Directory Service Access), o DSProxy (Directory Service Proxy) e o Categorizador de Mensagens não farão failover para nenhum outro controlador de domínio ou servidor de catálogo global.

  • Você não deve aproveitar a opção de inicialização /3GB do Windows porque ela pode fazer com que o Exchange Server consuma toda a memória, portanto reduzindo a memória disponível para o Active Directory.

  • O desligamento do sistema será muito mais longo se os serviços do Exchange Server não forem parados antes de desligar ou reiniciar o servidor.

  • Essa configuração é menos segura porque os administradores do Exchange terão acesso administrativo local ao Active Directory. Isso permite que eles aumentem seus próprios privilégios. Além disso, vulnerabilidades de segurança encontrada no Exchange Server ou no Active Directory podem comprometer um ao outro.

  • Se estiver executando o Exchange Server 2003 ou o Exchange Server 2007 em um controlador de domínio, não há suporte para o uso da DCPromo (ferramenta de promoção do controlador de domínio) para alterar a função do computador; além disso, ela pode interromper componentes, como o Microsoft Outlook® Mobile Access.

  • Não há suporte para a execução do Exchange Server 2003 ou do Exchange Server 2007 em um nó de cluster que seja também um controlador de domínio do Active Directory, e isso nunca deverá ser feito. Em outras palavras, se você estiver executando o Exchange 2000 Server em um nó de um cluster que seja também um controlador de domínio, é preciso rebaixar o servidor para um servidor membro antes de atualizar o Exchange 2000 Server para o Exchange Server 2003.

Se o computador estiver executando o Exchange 2000 Server, é recomendável que você rebaixe o servidor para um servidor membro, utilizando a DCPromo, assim que possível. Se o computador estiver executando o Exchange Server 2003 ou o Exchange Server 2007, use um dos procedimentos a seguir para corrigir esse aviso.

Para corrigir este aviso movendo o Exchange para outro computador

  1. Instale o Exchange Server em um computador diferente.

  2. Use Mover Caixa de Correio no Assistente de Tarefas do Exchange para mover todas as caixas de correio existentes do controlador de domínio para o novo servidor Exchange.

  3. Relocalize todas as pastas públicas e funções mantidas pelo antigo computador do Exchange Server para o novo computador do Exchange Server.

  4. Desinstale o Exchange Server do controlador de domínio.
Para corrigir esse aviso fazendo do servidor Exchange um servidor de catálogo global

  1. Abra sites e serviços do Active Directory.

  2. Expanda Sites, expanda o Site e expanda Servidores.

  3. Selecione o controlador de domínio que você deseja especificar como um servidor de catálogo global.

  4. No painel direito, clique com o botão direito em Configurações NTDS e selecione Propriedades.

  5. Na guia Geral, marque a caixa de seleção Catálogo Global. Se o servidor de diretório estiver executando o Windows 2000 Server com o Service Pack 2 ou anterior, reinicie o servidor para que as alterações entrem em vigor. Se o servidor de diretório estiver executando o Windows 2000 Server com o Service Pack 3 ou posterior, ou executando o Windows Server™ 2003, a alteração ocorrerá de forma dinâmica sem reiniciar o servidor.

Para obter mais informações sobre como instalar o Exchange Server em um controlador de domínio, consulte o artigo 250989 da Base de Dados de Conhecimento da Microsoft, "XADM: Instalando o ADC em um controlador de domínio Windows 2000 que também execute o Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989).


Exchange Server 5.5 detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para todos os objetos que têm uma classe de objeto msExchExchangeServer. Se o valor da cadeia de caracteres contiver Versão 5.5, o computador estará executando o Microsoft Exchange Server versão 5.5. Se o valor da cadeia de caracteres contiver Versão 6.0, o computador estará executando o Exchange 2000 Server. Se o valor da cadeia de caracteres contiver Versão 6.5, o computador estará executando o Exchange Server 2003.

Se o Exchange Server Analyzer verificar que o valor de serialNumber contém Versão 5.5, será exibido um erro.

Esse erro indica que a versão do Exchange Server detectada não poderá ser analisada posteriormente por essa versão do Exchange Server Analyzer.

O Exchange Server Analyzer depende de várias interfaces específicas do programa que não estão disponíveis na versão detectada do Exchange Server.

Para determinar esse erro, especifique um Exchange Server que esteja sendo executado no Exchange 2000 ou em uma versão posterior.

Se você achar que essa regra provocou um erro, verifique se o valor do atributo serialNumber do objeto do Exchange Server no Active Directory está definido corretamente.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar a ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para exibir o valor do atributo serialNumber

  1. Inicie o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração, expanda CN=Serviços, CN=Microsoft Exchange e CN=<ExchangeOrganizationName>.

  3. Expanda CN=Grupos Administrativos, expanda CN=<AdministrativeGroupName> e CN=Servidores.

  4. Clique com o botão direito no objeto do servidor e clique em Propriedades.

  5. Clique duas vezes no atributo serialNumber para exibir seu valor atual.

Para obter mais informações sobre como implantar o Exchange Server 2003, consulte o "Guia de Implantação do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47569).

Para obter mais informações sobre como migrar do Exchange Server 5.5 para o Exchange Server 2003, consulte o artigo 259912 da Base de Dados de Conhecimento, "Pré-requisitos para atualizar o Exchange Server 5.5 para Exchange 2000 Server ou para Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912).

Para obter informações sobre como migrar e atualizar para o Exchange Server 2003, consulte "Atualização para o Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34186).


Exchange Server 5.5 não está executando o Service Pack mais recente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo versionNumber de cada objeto do Exchange Server. O atributo versionNumber representa a versão do Exchange Server que está sendo executada no computador.

O Analisador do Exchange Server também consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile para determinar o valor da chave Version do processo STORE.EXE. Se o Exchange Server Analyzer determinar que a chave Versão de STORE.EXE tem um valor superior a 1.959, mas inferior a 2.653, um aviso será exibido. Isso indica que o computador está executando o Exchange Server 5.5 pre-Service Pack 4.

Esse aviso indica que o computador do Exchange Server não está executando o código mais recente disponível para versão do Exchange em execução no computador.

Para corrigir esse aviso

  1. Baixe o Exchange Server 5.5 Service Pack 4 (http://go.microsoft.com/fwlink/?LinkId=33456).

  2. Baixe a atualização mais recente (maio de 2004) do Exchange Server 5.5 a partir do Centro de Download da Microsoft (http://go.microsoft.com/fwlink/?LinkId=33456).

  3. Revise as informações sobre essa atualização lendo o artigo 841765 da Base de Dados de Conhecimento da Microsoft, "Maio 2004 Distribuição de atualização do Exchange Server 5.5" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765).

  4. Execute um backup completo do computador do Exchange Server.

  5. Aplique o Exchange Server 5.5 Service Pack 4.

  6. Aplique a atualização de maio de 2004.

Para obter mais informações sobre como instalar essa e outras atualizações do Exchange Server, consulte o artigo 328839 da Base de Dados de Conhecimento da Microsoft, "Como aplicar os service packs e hotfixes do Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


O Exchange Server 5.5 não tem suporte no Windows 2003
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar a versão do sistema operacional Microsoft Windows® que está executando no computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor igual a 4.0 em CurrentVersion indica que o computador está executando o Microsoft Windows NT® Server 4.0. Um valor igual a 5.0 indica que o computador está executando o Windows 2000 Server e um valor igual a 5.2 revela que o computador está executando o Windows Server™ 2003.

O Analisador do Exchange Server também consulta o serviço Active Directory® para conhecer o valor do atributo serialNumber de todos os objetos da classe msExchExchangeServer. Se o valor da cadeia de caracteres contiver Versão 5.5, o computador estará executando o Microsoft Exchange Server versão 5.5. Se o valor da cadeia de caracteres contiver Versão 6.0, o computador estará executando o Exchange 2000 Server. Se o valor da cadeia de caracteres contiver Versão 6.5, o computador estará executando o Exchange Server 2003.

Se o Analisador do Exchange Server encontrar um valor 5.2 em CurrentVersion e o valor Versão 5.5 em serialNumber, será exibido um erro. Não há suporte para esta configuração e você deve corrigir este erro o mais rapidamente possível.

Para corrigir esse erro

  • Siga um destes procedimentos:

    • Instale o Exchange Server 5.5 em um servidor que esteja executando um sistema operacional aceito e mova as caixas de correio para esse servidor.

    • Migre do Exchange Server 5.5 para o Exchange Server 2003.

Para obter mais informações sobre a implantação do Exchange Server 2003, consulte o Guia de Implantação do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47569).

Para obter mais informações sobre o Exchange Server e Windows Server 2003, consulte o artigo 810591 da Base de Dados de Conhecimento da Microsoft, "Compatibilidade do Exchange Server com o Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591).

Para obter mais informações sobre a migração do Exchange Server 5.5 para o Exchange Server 2003, consulte o artigo 259912 da Base de Dados de Conhecimento, "Pré-requisitos para atualização do Exchange Server 5.5 para o Exchange 2000 Server ou para o Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912).

Para obter informações sobre a migração e atualização para o Exchange Server 2003, consulte a página de migração e atualização, "Atualização para o Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=34186).


Exchange Server 5.0 não está executando o Service Pack ou a Distribuição de Atualização mais recente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo versionNumber de cada objeto do Exchange Server. O atributo versionNumber representa a versão do Exchange Server que está sendo executada no computador.

O Analisador do Exchange Server também consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile para determinar o valor da chave Version do processo STORE.EXE. Se o Exchange Server Analyzer determinar que a chave Version para STORE.EXE possui um valor maior que 1456 e menor que 1460, um aviso será exibido.

Esse aviso indica que o computador do Exchange Server não está executando o código mais recente disponível para versão do Exchange em execução no computador.

Para corrigir esse aviso

  1. Baixe o Service Pack 2 para Exchange Server 5.0 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858).

  2. Leia o arquivo README.TXT do Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168735).

  3. Visite o Centro de Download da Microsoft (http://go.microsoft.com/fwlink/?LinkId=41361) para baixar a atualização mais recente (abril de 2004) para o Exchange Server 5.0.

  4. Consulte as informações sobre essa atualização lendo o artigo 834130 da Base de Dados de Conhecimento Microsoft, "Pacote cumulativo de atualizações do Microsoft Exchange Server 5.0" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130).

  5. Execute um backup completo do computador do Exchange Server.

  6. Aplique o Service Pack 2 para o Exchange Server 5.0.

  7. Aplique a atualização de abril de 2004.

Para obter mais informações sobre como instalar essa e outras atualizações do Exchange Server, consulte o artigo 328839 da Base de Dados de Conhecimento da Microsoft, "Como aplicar os service packs e hotfixes do Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Exchange Server 5.5 residente no controlador de domínio do Active Directory
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_ComputerSystem da Instrumentação de Gerenciamento do Microsoft Windows® para determinar o valor da chave DomainRole. Os valores válidos para essa chave são mostrados na tabela a seguir.

Valor | Significado
0 | Estação de trabalho autônoma
1 | Estação de trabalho do membro
2 | Servidor autônomo
3 | Servidor membro
4 | Controlador de domínio de backup
5 | Controlador de domínio principal

O Exchange Server Analyzer também consulta a classe Win32_Service do WMI para determinar o valor da chave Started para ClusSvc, o serviço de Cluster.

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber de todos os objetos de diretório com categoria de objeto msExchExchangeServer. O valor do atributo serialNumber indica a versão do Exchange Server que está sendo usada.

Se o Exchange Server Analyzer determinar que o valor da chave DomainRole é maior que 3 em um computador do Exchange Server, que o computador do Exchange Server não está em execução em um cluster do Windows e que a versão do Exchange em execução é o Exchange Server versão 5.5, será exibido um aviso.

Este aviso indica que o Exchange Server 5.5 está em execução em um servidor do Active Directory. Esta situação pode causar problemas com o ADC (Active Directory Connector), devido a um conflito de porta potencial. Se o ADC utilizar esse servidor como um destino, você deve certificar-se de que o número de porta correto do protocolo LDAP do Exchange é utilizado. Por padrão, o servidor de diretório escuta solicitações LDAP na porta TCP 389. A menos que a porta para o Exchange seja alterada e o ADC seja configurado para utilizar a porta do Exchange, o ADC não poderá se comunicar com o Exchange.

O Active Directory utiliza a porta 389 LDAP padrão para o acesso LDAP. No entanto, utilizar o número de porta padrão substitui o servidor Exchange que reside no mesmo servidor que também está tentando ouvir à porta LDAP 389. Atribua novamente a porta LDAP do Exchange para conceder acesso ao LDAP do servidor Exchange a esse diretório.

Para corrigir esse aviso

  1. Abra o Administrador do Exchange.

  2. Expanda o Nome do Site, expanda Configuração, Protocolos e, em seguida, expanda Padrões de Site LDAP (Diretório).

  3. Altere a atribuição de porta de 389 para uma porta que não esteja sendo usada atualmente.

  4. Clique em OK para salvar a alteração.

  5. Reinicie o Serviço de Diretório do Microsoft Exchange para que a alteração entre em vigor.

  6. Conforme necessário, reconfigure o ADC que utiliza esse servidor como destino para utilizar a nova porta.

Para obter mais informações sobre como alterar a atribuição de porta LDAP no Exchange Server 5.5, consulte o artigo 224447 da Base de Dados de Conhecimento da Microsoft, "XADM: Como alterar as designações de porta LDAP no Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=224447).


Falha na resolução de nome DNS do Exchange Server
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server tenta uma consulta no DNS (Domain Name System) em relação aos servidores DNS configurados para cada computador do Exchange Server. Essa conexão é estabelecida usando um processador de objeto personalizado que executa uma solicitação de resolução de nome e analisa os resultados. Se o Analisador do Exchange Server não receber um endereço IP (Internet Protocol) nos resultados da consulta, um erro será exibido.

Esse erro indica que um computador do Exchange Server não foi encontrado no DNS. Tanto o Exchange Server quanto o serviço de diretório do Active Directory® precisam estar corretamente configurados e com o DNS íntegro para operar de maneira adequada. Os problemas de registro e resolução de DNS podem ter efeitos abrangentes na capacidade de enviar, receber e entregar mensagens.

Você deve configurar o DNS corretamente para certificar-se de que o Active Directory e o Exchange Server funcionarão corretamente. Para obter um tratamento mais detalhado da configuração do DNS para o Active Directory, consulte o artigo 237675 da Base de Dados de Conhecimento Microsoft, "Configurando o sistema de nomes de domínio para o Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675) (em inglês).

Para corrigir esse erro

  1. Examine os seguintes itens de configuração para certificar-se de que o DNS está íntegro e de que as entradas DNS do Exchange Server serão registradas corretamente:

    • Configuração de IP do DNS

    • Atualizações de zona dinâmica

    • Encaminhadores do DNS

  2. Verifique a existência de uma entrada de Zona Raiz. Exiba as zonas de Pesquisa Direta no console de Gerenciamento do DNS. Deve haver uma entrada para o domínio. Podem existir outras entradas de zona. Não deve ser uma zona ponto ("."). Exclua a zona ponto ("."), caso ela exista. A zona ponto (".") identifica o servidor DNS como um servidor raiz. Normalmente, um domínio do Active Directory que precisa de acesso externo (Internet) não deve ser configurado como um servidor DNS raiz. Registre outra vez manualmente o endereço IP do Exchange, usando Ipconfig /registerdns no servidor de diretórios depois de excluir o ponto ("."). O serviço Netlogon também pode precisar ser reiniciado.

  3. Mais uma vez, preencha manualmente as entradas DNS do Exchange Server, usando netdiag /fix no computador do Exchange Server.

Para obter mais informações sobre o uso do DNS com o Active Directory, consulte o artigo 323418 da Base de Dados de Conhecimento Microsoft, "Como integrar o DNS com uma infra-estrutura DNS existente se o Active Directory estiver habilitado no Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418) (em inglês).

Para obter mais informações sobre como solucionar problemas do DNS e do Active Directory, consulte o artigo 260371 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas comuns de instalação do Active Directory no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371).


O servidor Exchange foi designado como um servidor front-end e parece hospedar caixas de correio
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta o objeto do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) do Exchange Server (classe Exchange_Server) para determinar o valor IsFrontEndServer do servidor. Se o valor for True, o servidor Exchange está agindo como um servidor front-end. Se o servidor tiver armazenamentos de caixas de correio, o Exchange Server Analyzer consultará o serviço de diretório do Active Directory® para determinar quantas caixas de correio estão no servidor. Cada objeto de armazenamento de caixa de correio (classe msExchPrivateMDB) tem um atributo homeMDBBL com diversos valores que lista todas as caixas de correio do armazenamento. Com a contagem desses valores, o Exchange Server Analyzer obtém o número total de caixas de correio do servidor.

Se o servidor Exchange estiver designado como um servidor front-end e, além disso, tiver mais de 20 caixas de correio configuradas, um aviso será exibido.

Dependendo da configuração, o Exchange talvez precise colocar caixas de correio de serviço no servidor front-end. Por exemplo, se o servidor front-end aceitar mensagens SMTP da Internet, o serviço SMTP do Exchange poderá precisar de uma caixa de correio dedicada no servidor. O Exchange Server Analyzer contará essas caixas de correio de serviço apenas exibindo um aviso se houver mais de 20 caixas de correio configuradas no servidor Exchange.

Não coloque caixas de correio de usuário no servidor front-end. Não há suporte para essa configuração.

Se houver caixas de correio de usuário no servidor front-end, use a opção Gerenciador do Sistema do Exchange (Exchange Server 2003 somente) ou Usuários e Computadores do Active Directory para movê-las para um servidor back-end apropriado.

Para mover caixas de correio (Exchange 2000 Server ou Exchange Server 2003)

  1. Em Usuários e Computadores do Active Directory, selecione o usuário ou usuários cujas caixas de correio você deseja mover.

  2. Clique com o botão direito na lista de usuários que você selecionou na etapa anterior e clique em Tarefas do Exchange.

  3. No Assistente de Tarefas do Exchange, na página Tarefas Disponíveis, clique em Mover Caixa de Correio e clique em Avançar.

  4. Leia cuidadosamente e siga as etapas restantes do assistente.

Para mover caixas de correio (Exchange Server 2003 somente)

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda o servidor do qual você deseja mover as caixas de correio, expanda o Grupo de Armazenamento do qual deseja mover as caixas de correio, expanda o Armazenamento de Caixa de Correio que contém as caixas de correio que deseja mover e clique em Caixas de Correio.

  2. No painel de detalhes, clique com o botão direito no usuário ou usuários cujas caixas de correio você deseja mover e clique em Tarefas do Exchange.

  3. No Assistente de Tarefas do Exchange, na página Tarefas Disponíveis, clique em Mover Caixa de Correio e clique em Avançar.

  4. Leia cuidadosamente e siga as etapas restantes do assistente.

Para obter mais informações sobre as configurações corretas dos servidores front-end Exchange, consulte o artigo 822443 da Base de Dados de Conhecimento Microsoft, "Considerações sobre servidores front-end no Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822443).

Para obter recomendações gerais sobre implantação e configuração dos servidores front-end Exchange, consulte o Guia de Implantação do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569) (em inglês).

Para obter mais informações sobre erros que podem ocorrer na execução de caixas de correio de usuário em um servidor front-end Exchange, consulte o artigo 273296 da Base de Dados de Conhecimento, "XCON: Usuários não podem recuperar email em um servidor front-end" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273296).

Para obter mais informações sobre como mover caixas de correio no Exchange Server 2003, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 821829, "Movendo caixas de correio no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829) (em inglês)

  • 822892, "Mover aprimoramentos de caixa de correio no Exchange 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)


Esse servidor Exchange é também um controlador de domínio, o qual não é uma configuração recomendada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-28

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave DomainRole. Os valores válidos para essa chave são mostrados na tabela a seguir.

Valor | Significado
0 | Estação de trabalho autônoma
1 | Estação de trabalho do membro
2 | Servidor autônomo
3 | Servidor membro
4 | Controlador de domínio de backup
5 | Controlador de domínio principal

Além disso, o Exchange Server Analyzer também consulta a classe Win32_Service do WMI para determinar o valor da chave Started do ClusSvc, o serviço de Cluster.

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber de todos os objetos de diretório com categoria de objeto msExchExchangeServer. O valor do atributo serialNumber indica a versão do Exchange Server em uso.

Se o Exchange Server Analyzer determinar que o valor da chave DomainRole é maior que 3 em um computador do Exchange Server, e que o computador do Exchange Server não está executando o Exchange Server versão 5.5 ou sendo executado em um cluster do Windows, um aviso será exibido.

Se você estiver executando o Exchange Server como parte do Microsoft Small Business Server 2000 ou Windows Small Business Server 2003, você poderá instalar o Exchange Server em um controlador de domínio. No entanto, se você não estiver executando o Exchange Server como parte do Small Business Server, é recomendável que você evite executar o Exchange Server em um controlador de domínio.

Se você estiver executando o Exchange Server em um controlador de domínio sem Small Business Server, esteja ciente dos problemas a seguir:

  • Exchange Server e Active Directory são aplicativos que utilizam muitos recursos. Há implicações de desempenho a serem consideradas quando ambos estiverem sendo executados no mesmo computador.

  • Se o Exchange Server estiver executando em um controlador de domínio, você deverá tornar esse controlador de domínio um servidor de catálogo global. Para obter mais informações sobre como criar um servidor de catálogo global, consulte o artigo 313994 da Base de Dados de Conhecimento Microsoft, "Como criar ou mover um catálogo global no Windows Server 2003, Windows 2000 ou Small Business Server 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994).

  • Vários componentes de diretório do Exchange Server, como o Directory Service Access (DSAccess), o Proxy do Serviço de Diretório (DSProxy) e o Categorizador de Mensagens não falharão para nenhum outro controlador de domínio ou servidor de catálogo global.

  • Você não deve aproveitar a opção de inicialização /3GB no Windows, pois isso poderia fazer com que o Exchange Server consumisse toda a memória, reduzindo a memória disponível para o Active Directory.

  • O desligamento do sistema será consideravelmente mais longo se os serviços do Exchange Server não forem parados antes de desligar ou reiniciar o servidor.

  • Essa configuração é menos segura porque os administradores do Exchange terão acesso administrativo local ao Active Directory, permitindo que eles elevem seus próprios privilégios. Além disso, qualquer vulnerabilidade de segurança encontrada no Exchange Server ou no Active Directory compromete os outros.

  • Se você estiver executando o Exchange Server 2003 ou o Exchange Server 2007 em um controlador de domínio, não haverá suporte para o uso da ferramenta de promoção (DCPromo) do controlador de domínio para alterar a função do computador. Ela é conhecida por interromper componentes como o Microsoft Outlook® Mobile Access.

  • Não é possível executar o Exchange Server 2003 ou o Exchange Server 2007 em um nó do cluster que também seja um controlador de domínio do Active Directory; isso nunca deve ser feito. Isso significa que, se você estiver executando o Exchange 2000 Server em um nó de cluster que também seja um controlador de domínio, você deverá rebaixar o servidor para um servidor membro antes de fazer a atualização do Exchange 2000 Server para o Exchange Server 2003.

Se o computador estiver executando o Exchange 2000 Server, é recomendável que você rebaixe o servidor para um servidor membro usando DCPromo na primeira oportunidade. Se o computador estiver executando o Exchange Server 2003, use o procedimento a seguir para corrigir esse aviso.

Para corrigir esse aviso

  1. Instale o Exchange Server em um computador diferente.

  2. Use Mover Caixa de Correio no Assistente de Tarefas do Exchange para mover todas as caixas de correio existentes do controlador de domínio para o novo servidor Exchange.

  3. Relocalize todas as pastas públicas e funções mantidas pelo antigo computador do Exchange Server para o novo computador do Exchange Server.

  4. Desinstale o Exchange Server do controlador de domínio.

Para obter mais informações sobre como instalar o Exchange Server em um controlador de domínio, consulte o artigo 250989 da Base de Dados de Conhecimento da Microsoft, "XADM: Instalando o ADC em um controlador de domínio Windows 2000 que também execute o Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989).


O servidor Exchange está desativado ou inacessível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-20

A ferramenta Microsoft® Exchange Server Analyzer Tool usa RPCs (chamadas de procedimento remoto) para ler o valor da cadeia de caracteres CurrentVersion da seguinte chave de Registro no computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se o Exchange Server Analyzer não conseguir ler esse valor de Registro por alguma razão, um erro será exibido.

Para corrigir esse erro

  1. Verifique se o computador do Exchange Server foi iniciado e está conectado à rede.

  2. Use o comando Ping para ver se o computador do Exchange Server está acessível.

  3. Se houver um firewall, verifique se as portas RPC estão bloqueadas.

  4. Verifique se o serviço Registro Remoto no computador do Exchange Server foi iniciado.

  5. Verifique as permissões da conta na qual a ferramenta Exchange Server Analyzer Tool está sendo executada para garantir que ela possui permissões suficientes para ler o Registro no computador do Exchange Server.

Para obter mais informações sobre como solucionar problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Para obter mais informações sobre como solucionar problemas de conectividade da ferramenta Exchange Server Best Practices Analyzer Tool, consulte "Solucionando problemas de conectividade da ferramenta Microsoft Exchange Server Best Practices Analyzer Tool" (http://go.microsoft.com/fwlink/?linkid=56285).


Esse servidor Exchange está em execução no Windows NT 4.0; informações de diagnóstico limitado estão disponíveis
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar a versão do sistema operacional Microsoft Windows® que está executando no computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor igual a 4.0 em CurrentVersion indica que o computador está executando o Microsoft Windows NT® Server 4.0. Um valor igual a 5.0 indica que o computador está executando o Windows 2000 Server e um valor igual a 5.2 revela que o computador está executando o Windows Server™ 2003.

Se o Exchange Server Analyzer verificar que o valor de CurrentVersion é igual a 4.0, um aviso será exibido.

Esse aviso indica que o computador do Exchange Server está executando Windows NT Server 4.0. O Windows NT Server 4.0 não fornece tantas informações de diagnóstico quanto as versões anteriores do Windows Server. Como resultado, o Exchange Server Analyzer só poderá reunir e analisar uma quantidade limitada de informações.

Para corrigir esse aviso

  1. Não existe ação imediata a ser tomada. Esse aviso tem propósito informativo.

  2. Como o Windows NT Server 4.0 e o Exchange Server versão 5.5 estão chegando ao fim de seu ciclo de vida de produto, experimente fazer uma atualização para Windows Server 2003 e Exchange Server 2003.

Para obter mais informações sobre o ciclo de vida dos produtos Windows NT Server 4.0 e Exchange Server 5.5, consulte o site Ciclo de Vida do Atendimento Microsoft (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=21759).

Para obter mais informações sobre o Windows Server 2003, consulte a página principal do produto, "Microsoft Windows Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=26095).

Para obter mais informações sobre o Exchange Server 2003, consulte a página principal do produto, "Microsoft Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=21573).


Esse Exchange Server 2003 não está executando a compilação final do Service Pack 2
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para todos os objetos do Exchange Server contidos no diretório. O atributo serialNumber é um valor de cadeia de caracteres que inclui a versão do Exchange Server e a versão do service pack, se instalado. Por exemplo, em um computador do Exchange Server 2003 que tenha o Service Pack 1 instalado, o atributo serialNumber é igual a Versão 6.5 (Compilação 7638: Service Pack 2).

Se o Exchange Server Analyzer detectar que o valor do atributo serialNumber contém 6.5 e Service Pack 2 em sua cadeia de caracteres, mas não contém 7638, ele exibirá um aviso.

Esse aviso indica que o computador do Exchange Server 2003 está executando uma versão de pré-lançamento do Exchange Server 2003 Service Pack 2.

Observação:
Pelo fato de service packs do Exchange Server não poderem ser desinstalados, é altamente recomendável que você faça um backup completo do computador que estiver executando o Exchange Server antes de aplicar quaisquer service packs.
Para corrigir esse aviso

  1. Adquira a versão final do Exchange Server 2003 Service Pack 2 no site do Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).

  2. Consulte as Notas de Versão do Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52072).

  3. Faça backup completo do computador do Exchange Server.

  4. Aplique o Service Pack 2 para o Exchange Server 2003.

  5. Faça outro backup completo do computador que estiver executando o Exchange Server.

Para obter mais informações sobre como instalar um service pack do Exchange Server, consulte o artigo 328839 da Base de Dados de Conhecimento da Microsoft, "Como aplicar service packs e hotfixes do Exchange" ( http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


O Exchange Server está executando o SharePoint Portal Server
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started para o Microsoft Windows SharePoint® Portal Server (MSDMSERV). Um valor True indica que o SharePoint Portal Server está sendo executado neste servidor Exchange.

Se o Exchange Server Analyzer detectar que o SharePoint Portal Server está em execução em um computador do Exchange Server, será exibido um aviso.

O SharePoint Portal Server não é compatível com o Exchange Server e deve ser removido. O SharePoint Portal Server e o Exchange Server são projetados para trabalhar em conjunto e desempenham uma função no ambiente de colaboração de sua organização. Contudo, o SharePoint Portal Server e o Exchange Server foram criados para trabalhar um ao lado do outro e não foram projetados para coexistirem no mesmo hardware.

Para corrigir esse aviso

  • Mova o Exchange Server ou o SharePoint Portal Server para outro computador. É recomendável que você remova um desses programas do computador.

Para obter mais informações sobre como mover caixas de correio no Exchange Server, consulte o artigo 821829 da Base de Dados de Conhecimento Microsoft, "Como mover caixas de correio no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Para obter mais informações sobre a compatibilidade entre o Exchange Server e o SharePoint Portal Server, consulte o artigo 277567 da Base de Dados de Conhecimento Microsoft, "Não é possível instalar o SharePoint Portal Server em um computador executando o Exchange Server" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=277567).


O Exchange Server está executando o Virtual Server 2005 com outro Exchange Server instalado como Convidado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê os valores na seguinte chave de Registro para determinar se o servidor é um servidor virtual:

HKEY_LOCAL_MACHINE\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1

O Exchange Server Analyzer também verifica o seguinte valor de Registro:

HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters

Além disso, o Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o serviço Armazenamento de Informações do Microsoft Exchange (MSExchangeIS) está sendo executado no computador físico que executa o Microsoft Virtual Server 2005.

Se o Exchange Server Analyzer descobrir que o servidor é um servidor virtual, que a ramificação de Registro anteriormente descrita existe, e que o MSExchangeIS está sendo executado em um computador físico, um erro será exibido.

A presença da chave HKLM\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1 indica que o computador do Exchange Server tem Adições de Máquina Virtual instaladas. Isso, e a existência da chave HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters, significa que o computador do Microsoft Exchange Server está sendo executado como um computador convidado virtual no Virtual Server 2005.

A Microsoft não oferece suporte para execução de qualquer versão do Exchange Server em um computador virtual ou em um emulador. Isso se aplica quando o Exchange Server está sendo executado no Virtual Server 2005, no Microsoft Virtual PC 2004, ou em qualquer programa de computador virtual de terceiros. As plataformas do Exchange Server são projetadas e testadas para serem executadas apenas em hardware físico, principalmente em plataformas de hardware que estejam listadas no Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219).

Além disso, a execução do Exchange como convidado de servidor virtual em um computador que esteja executando o Exchange Server não é uma prática recomendada porque não permite uma redundância adequada entre os serviços.

Para corrigir esse erro

  1. Mova as caixas de correio do Exchange Server que está sendo executado no Virtual Server 2005 para um computador não virtual do Exchange Server.

  2. Reiniciar todas as pastas públicas e transferir todas as funções mantidas pelo servidor Exchange virtual conforme necessário.

  3. Desinstale o Exchange do computador virtual para descomissionar e remover da sua infra-estrutura do Exchange e do serviço de diretório Active Directory®.

Para obter mais informações sobre como mover caixas de correio, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 822892, "Aprimoramento de Mover Caixa de Correio no Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892) (em inglês)

  • 224975, "XADM: Differences Between Move Mailbox Methods" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Para obter mais informações sobre suporte para os computadores do Exchange Server que estejam sendo executados em ambientes virtuais, consulte o artigo 320220 da Base de Dados de Conhecimento, "Limites de suporte para o Exchange Server em uma máquina virtual ou uma máquina de emulação" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Para obter mais informações sobre o Virtual Server 2005, consulte o "Microsoft Virtual Server 2005" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=34938).

Para obter mais informações sobre o Virtual PC 2004, consulte o "Microsoft Virtual PC 2004" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=34663).


O servidor Exchange está executando serviços DNS
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started do serviço DNS Server (DNS). Um valor True indica que o serviço DNS Server está sendo executado nesse servidor Exchange.

O Exchange Server Analyzer também consulta a classe Win32_OperatingSystem do WMI para determinar o valor da chave OSProductSuite. O valor retornado para essa chave indica a versão do sistema operacional Windows executado no computador do Exchange Server.

Além disso, o Exchange Server Analyzer também consulta o serviço de diretório Active Directory® para determinar a contagem das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Se o Exchange Server Analyzer determinar que o serviço DNS Server foi iniciado em um computador do Exchange Server que atenda aos seguintes critérios, um aviso será exibido:

  • O computador do Exchange Server hospeda mais de 100 caixas de correio.

  • O computador do Exchange Server não está sendo executado no Windows Small Business Server 2003 ou Small Business Server 2000.

Não é recomendável executar o DNS Server no mesmo computador de um servidor de produção de caixa de correio do Exchange. A hospedagem conjunta do serviço DNS Server e do Exchange Server no mesmo computador em um ambiente de produção provavelmente causará um desempenho inadequado para um ou os dois servidores.

Para corrigir esse aviso

  1. Você deve considerar uma das seguintes opções para corrigir esse aviso:

    • Mova o Exchange Server ou o DNS Server do computador. É recomendável remover completamente um dos aplicativos de servidor do computador.

    • Mover as caixas de correio do Exchange do servidor. No mínimo, você deve remover as caixas de correio e converter o servidor Exchange em um servidor de infra-estrutura ou protocolo. Isso irá reduzir a carga consideravelmente para a E/S de disco e ligeiramente para a CPU (esta última depende da função de infra-estrutura do Exchange).

    • Experimente instalar o Small Business Server em vez disso. Se você estiver executando o Exchange em um ambiente pequeno com menos de 75 usuários, em que não seja necessário mais de um servidor Exchange, pode ser vantajoso instalar o Small Business Server. O Small Business Server inclui o Microsoft SQL Server™ e o Exchange Server, além de outros aplicativos de servidor principais da Microsoft e foi projetado, testado e otimizado para instalação em um único computador.

Para obter mais informações sobre como mover caixas de correio e servidores Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 822892, "Aprimoramento de Mover Caixa de Correio no Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892) (em inglês)

  • 224975, "XADM: Differences Between Move Mailbox Methods" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

  • 297289, "XADM: Como Mover o Exchange 2000 para um Novo Hardware e Manter o Mesmo Nome do Servidor" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=297289)

Para obter mais informações sobre o Small Business Server, consulte "Microsoft Windows Small Business Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=23456).


Servidor Exchange executando SQL Server
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started para o serviço Microsoft SQL Server™ (MSSQLSERVER). Um valor True indica que o serviço SQL Server está sendo executado nesse servidor Exchange.

O Exchange Server Analyzer também consulta a classe Win32_OperatingSystem do WMI para determinar o valor da chave OSProductSuite. O valor retornado para essa chave indica a versão do sistema operacional Windows executado no computador do Exchange Server.

Além disso, o Exchange Server Analyzer também consulta o serviço de diretório Active Directory® para determinar a contagem das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Se o Exchange Server Analyzer determinar que o serviço SQL Server for iniciado em um computador do Exchange Server que atenda aos seguintes critérios, um aviso será exibido:

  • O computador do Exchange Server hospeda mais de 100 caixas de correio.

  • O computador do Exchange Server não está sendo executado no Windows Small Business Server 2003 ou Small Business Server 2000.

Não é recomendável executar o SQL Server no mesmo computador de um servidor de produção de caixa de correio do Exchange. O SQL Server e os servidores de caixa de correio do Exchange consomem uma grande quantidade de memória e recursos de disco para operar de forma ideal. A hospedagem conjunta do SQL Server e do Exchange Server no mesmo computador em um ambiente de produção provavelmente causará um desempenho inadequado para um ou ambos os servidores. Além disso, a solução de problemas e a proteção desse tipo de instalação não são bem compreendidos.

Por fim, existem alguns problemas de interoperabilidade conhecidos que você pode encontrar se estiver executando o SQL Server e o Exchange Server no mesmo computador. A maioria desses problemas é causada por inconsistências de versões de arquivos ou programas comuns aos dois servidores, como MSDTC (Microsoft Distributed Transaction Coordinator), ADO (Microsoft ActiveX® Data Objects) e OLE DB (OLE Database).

Para corrigir esse aviso

  • Você deve considerar uma das seguintes opções para corrigir esse aviso:

    • Mova o Exchange Server ou o SQL Server do computador. É recomendável remover completamente um desses programas do computador.

    • Mover as caixas de correio do Exchange do servidor. No mínimo, você deve remover as caixas de correio e converter o servidor Exchange em um servidor de infra-estrutura ou protocolo. Isso reduzirá a carga consideravelmente para a E/S de disco e ligeiramente para a CPU (esta última depende da função de infra-estrutura do Exchange).

    • Experimente instalar o Small Business Server em vez disso. Se você estiver executando o Exchange em um ambiente pequeno, em que não seja necessário mais de um servidor Exchange, poderá ser vantajoso instalar o Small Business Server. O Small Business Server inclui o SQL Server e o Exchange Server, além de outros aplicativos de servidor principais da Microsoft e foi projetado, testado e otimizado para instalação em um único computador.

Para obter mais informações sobre como mover caixas de correio e servidores Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 822892, "Aprimoramento de Mover Caixa de Correio no Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892) (em inglês)

  • 224975, "XADM: Differences Between Move Mailbox Methods" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

  • 297289, "XADM: Como Mover o Exchange 2000 para um Novo Hardware e Manter o Mesmo Nome do Servidor" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=297289)

Para obter mais informações sobre o Small Business Server, consulte "Microsoft Windows Small Business Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=23456).


Servidor Exchange em execução em VMware
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-10-26

Para obter mais informações sobre suporte para computadores do Exchange Server em execução em ambientes virtuais, consulte o artigo 897615 da Base de Dados de Conhecimento, "Diretiva de suporte para software Microsoft em execução em software de virtualização de hardware não-Microsoft" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=897615).


O servidor Exchange tem menos de 1 GB de memória e tem as opções /3GB e /USERVA=3030 no arquivo Boot.ini.
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta duas classes do Instrumentação de Gerenciamento do Microsoft Windows® (WMI) para determinar a quantidade de memória física no computador com o Exchange Server e a quantidade de espaço de endereçamento virtual alocado aos processos do modo de usuário. A tabela a seguir descreve as classes e chaves sendo avaliadas pelo Exchange Server Analyzer.

Classe | Chave | Descrição
Win32_OperatingSystem | MaxProcessMemorySize | Número máximo de kilobytes de memória que pode ser alocado em um processo.
Win32_OperatingSystem | OSProductSuite | Inclusões de produtos de sistema instaladas e licenciadas para o sistema operacional.
Win32_ComputerSystem | TotalPhysicalMemory | Número de bytes da memória RAM (random access memory) instalada no computador.

Se o Exchange Server Analyzer determinar que o computador com o Exchange Server possui menos de 950 megabytes (MB) de RAM e que o valor de MaxProcessMemorySize é maior que 2097024 e menor que 3104640, um aviso será exibido.

Esse aviso indica que o computador com o Exchange Server não está configurado corretamente para o uso otimizado da memória nestes dois aspectos:

  • A opção de inicialização /USERVA=3030 foi definida. Essa opção só é necessária em computadores com o Exchange Server que tenham 1 gigabyte (GB) ou mais de memória e que estejam executando um sistema operacional Microsoft Windows Server™ 2003.

  • A opção de inicialização /3GB foi definida. Essa opção só deve ser usada em Exchange Servers com 1 GB (gigabyte) ou mais de memória que estejam executando qualquer um dos seguintes sistemas operacionais:

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

Importante:
A opção /3GB não deve ser usada no Windows 2000 Server porque não é suportada e pode ocasionar falhas em aplicativos e no sistema operacional. Além disso, a opção /3GB só tem suporte nos sistemas operacionais listados anteriormente quando houver 1 GB ou mais de memória física instalada.

Se você encontrar esse aviso em um sistema que tenha 1 GB de memória física instalada, isso poderá significar que outro componente, como uma placa de vídeo, utiliza parte dessa memória física no nível de hardware, fazendo com que a memória física alocada não fique disponível para o sistema operacional. Nesses casos, a quantidade de memória instalada fisicamente de acordo com o Windows será menor do que a quantidade real de memória física instalada no computador. Se você passar por essa situação, deverá comparar a quantidade de memória instalada informada pelo BIOS com a quantidade de memória instalada relatada pelo Windows.

Para corrigir esse aviso no Windows Server 2003

  1. Clique com o botão direito em Meu Computador e clique em Propriedades. A caixa de diálogo Propriedades do Sistema será exibida.

  2. Clique em Avançado.

  3. Na área Inicialização e Recuperação, clique em Configurações. A caixa de diálogo Inicialização e Recuperação será exibida.

  4. Na área Inicialização do sistema, clique em Editar. Isso abrirá o arquivo Boot.ini do Windows no Bloco de Notas.

  5. Na seção [Sistemas Operacionais] , exclua as opções a seguir de todas as linhas de inicialização: /3GB /USERVA=3030

  6. Salve as alterações e feche o Bloco de Notas.

  7. Clique em OK duas vezes para fechar as caixas de diálogo abertas e reinicie o computador para que as alterações entrem em vigor.

Para corrigir esse aviso no Windows 2000 Server

  1. No Windows Explorer, navegue para a partição do sistema.

  2. Se você não encontrar o arquivo Boot.ini, é possível que as Opções de Pasta estejam definidas com Ocultar arquivos protegidos do sistema operacional. Se for o caso, na janela do Windows Explorer, clique em Ferramentas, clique em Opções de Pasta e em Exibir. Desmarque a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado). Quando a caixa de aviso aparecer, clique em Sim.

  3. Quando o arquivo Boot.ini estiver visível no Windows Explorer, clique com o botão direito no arquivo, clique em Abrir com e clique em Bloco de Notas para abri-lo.

  4. Remova /3GB e, se estiver presente, /USERVA=3030.

  5. Salve as alterações e feche o Bloco de Notas.

  6. Reinicie o computador para que a alteração entre em vigor.

Para obter mais informações sobre como usar as opções de inicialização /3GB e /USERVA, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft (páginas em inglês):

  • 308356, "Uso de memória pelo processo Lsass.exe nos controladores de domínio que estão em execução no Windows Server 2003 ou Windows 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812, "How to Use the 4GT RAM Tuning Feature" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "The effects of 4GT tuning on system Page Table Entries" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, "Como usar a opção /userva com a opção /3GB para ajustar o espaço Modo usuário para um valor entre 2GB e 3GB" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Esse servidor Exchange tem menos de 1 GB de memória, mas tem a opção /3GB definida no arquivo Boot.ini
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta duas classes WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar a quantidade de memória física existente no computador do Exchange Server, e a quantidade de espaço de endereçamento virtual alocado para os processos em execução nesse computador. A tabela a seguir descreve as classes e chaves sendo avaliadas pelo Exchange Server Analyzer.

Classe consultada | Chaves consultadas | Descrição
Win32_OperatingSystem | MaxProcessMemorySize | Número máximo de kilobytes de memória que pode ser alocado em um processo.
Win32_ComputerSystem | TotalPhysicalMemory | Número de bytes de memória RAM instalados no computador.

Se o Exchange Server Analyzer detectar que o valor de TotalPhysicalMemory é menor que 1073741824 e que o valor de MaxProcessMemorySize é igual a 3145600, será exibido um aviso.

Esse aviso indica que o sistema tem menos de 950 MB (megabytes) de memória física, mas foi configurado com a opção de inicialização /3GB, no arquivo Boot.ini. Essa opção só deve ser usada em Exchange Servers com 1 GB (gigabyte) ou mais de memória que estejam executando qualquer um dos seguintes sistemas operacionais:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Importante:
A opção /3GB não deve ser usada no Windows 2000 Server porque não é suportada e pode ocasionar falhas em aplicativos e no sistema operacional. Além disso, a opção /3GB só tem suporte nos sistemas operacionais listados anteriormente quando houver 1 GB ou mais de memória física instalada.

Se você encontrar esse aviso em um sistema que tenha 1 GB de memória física instalada, isso poderá significar que outro componente, como uma placa de vídeo, utiliza parte dessa memória física no nível de hardware, fazendo com que a memória física alocada não fique disponível para o sistema operacional. Nesses casos, a quantidade de memória instalada fisicamente de acordo com o Windows será menor do que a quantidade real de memória física instalada no computador. Se você passar por essa situação, deverá comparar a quantidade de memória instalada informada pelo BIOS com a quantidade de memória instalada relatada pelo Windows.

Para corrigir esse aviso no Windows Server 2003

  1. Clique com o botão direito em Meu Computador e clique em Propriedades. A caixa de diálogo Propriedades do Sistema é exibida.

  2. Clique em Avançado.

  3. Na área de Inicialização e Recuperação, clique em Configurações. A caixa de diálogo Inicialização e Recuperação é exibida.

  4. Na área de inicialização do Sistema, clique em Editar. Isso abrirá o arquivo Boot.ini do Windows no Bloco de Notas.

  5. Na seção [Sistemas Operacionais] , exclua as opções a seguir de todas as linhas de inicialização: /3GB

  6. Salve as alterações e feche o Bloco de Notas.

  7. Clique em OK duas vezes para fechar as caixas de diálogo abertas e reinicie o computador para que as alterações entrem em vigor.

Para corrigir esse aviso no Windows 2000 Server

  1. No Windows Explorer, navegue até a Partição do Sistema. Essa é a partição que armazena arquivos específicos do hardware, como o Boot.ini e o NTLDR.

  2. Se você não encontrar o arquivo Boot.ini, é provável que as Opções de Pasta estejam definidas com Ocultar arquivos protegidos do sistema operacional. Se for o caso, na janela do Windows Explorer, clique em Ferramentas, clique em Opções de Pasta e em Exibir. Desmarque a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado). Quando solicitado, clique em Sim.

  3. Quando o arquivo Boot.ini estiver visível no Windows Explorer, clique com o botão direito no arquivo, clique em Abrir com e clique em Bloco de Notas para abri-lo.

  4. Na seção [Sistemas Operacionais] , exclua as opções a seguir de todas as linhas de inicialização: /3GB

  5. Salve as alterações e feche o Bloco de Notas.

  6. Reinicie o computador para que a alteração entre em vigor.

Para obter mais informações sobre como otimizar o uso da memória no Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Esse servidor Exchange tem a opção de inicialização /3GB definida no arquivo Boot.ini
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows) Win32_OperatingSystem para determinar a quantidade de espaço de endereçamento virtual alocada para os processos de modo do usuário (MaxProcessMemorySize) no computador do Exchange Server.

O Analisador do Exchange Server também examina a classe WMI Exchange_Server no namespace root\MicrosoftExchangeV2 para determinar o valor da chave IsFrontEndServer. Um valor Falso indica que o computador do Exchange Server não é um servidor front-end. Um valor Verdadeiro indica que o computador do Exchange Server é um servidor front-end.

O Exchange Server Analyzer também consulta a classe Win32_Service do WMI para determinar se o serviço de Cluster (ClusSvc) está presente e foi iniciado.

Finalmente, o Analisador do Exchange Server consulta o serviço de diretório do Active Directory® para determinar a conta do atributo homeMDBBL do objeto de armazenamento de caixa de correio (msExchPrivateMDB). A conta resultante é o número de caixas de correio encontradas no computador do Exchange Server.

Se o Exchange Server Analyzer determinar que o valor da chave MaxProcessMemorySize não é igual a 2097024, que a chave IsFrontEndServer está definida como False, que o serviço de Cluster não está em execução, que o armazenamento de caixas de correio do Exchange Server contém menos de 20 caixas de correio e que o Exchange não está executando o Microsoft Windows Small Business Server 2003, será exibido um aviso.

Este aviso indica que o servidor de diretório não está configurado corretamente para uso de memória ideal porque a opção de inicialização /3GB foi definida no arquivo Boot.ini. Essa opção só deve ser usada em servidores Exchange com 1 GB (gigabyte) ou mais de memória que estejam executando qualquer um dos sistemas operacionais a seguir:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Importante:
A opção /3GB não deve ser usada no Windows 2000 Server porque não é suportada e pode ocasionar falhas em aplicativos e no sistema operacional. Além disso, a opção /3GB só tem suporte nos sistemas operacionais listados anteriormente quando houver 1 GB ou mais de memória física instalada.

Quando o parâmetro /3GB estiver incluído no arquivo Boot.ini de um sistema operacional com suporte, o Windows alocará 3 GB de um máximo de 4 GB de espaço de endereçamento virtual para o processo do usuário e 1 GB para o kernel. Normalmente (quando o parâmetro /3GB não é usado), o Windows aloca 2 GB para o processo do usuário e 2 GB para o kernel. Portanto, com a opção /3GB, aplicativos com uso intenso de memória têm um espaço de endereçamento de memória virtual maior para operar e o desempenho melhora.

O uso da opção /3GB ajuda principalmente a aplicativos com uso intenso de memória, como o processo Store.exe em um servidor Exchange que hospeda caixas de correio de usuário. Um servidor front-end não hospeda caixas de correio de usuário e, portanto, não há benefício derivado de usar a opção /3GB em um servidor front-end.

Para corrigir esse aviso

  1. No Windows Explorer, navegue para a partição do sistema.

  2. Se você não consegue ver o arquivo Boot.ini, pode ser devido às Opções de Pasta estarem definidas como Ocultar arquivos protegidos do sistema operacional. Nesse caso, na janela do Windows Explorer, clique em Ferramentas, clique em Opções de Pasta e clique na guia Exibir. Desmarque a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado). Quando a caixa de aviso aparecer, clique em Sim.

  3. Quando o arquivo Boot.ini estiver visível no Windows Explorer, clique com o botão direito no arquivo, clique em Abrir com e escolha Bloco de Notas para abrir o arquivo.

  4. Na seção [Sistemas Operacionais] , exclua as opções a seguir das linhas de inicialização: /3GB

  5. Salve as alterações e feche o Bloco de Notas.

  6. Reinicie o computador para que a alteração entre em vigor.

Para obter mais informações sobre o uso das opções de inicialização /3GB, consulte os seguintes artigos na Base de Dados de Conhecimento Microsoft:

  • 325044, "COMO FAZER PARA: Solucionar problemas de fragmentação de memória virtual no Exchange 2003 e Exchange 2000"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372) (página em inglês)


O servidor Exchange 2003 não está executando a compilação final do Service Pack 1 (7226.6).
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-21

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para todos os objetos do Exchange Server contidos no diretório. O atributo serialNumber é um valor de cadeia de caracteres que inclui a versão do Exchange Server e a versão do service pack, se instalado. Por exemplo, em um computador do Exchange Server 2003 que tenha o Service Pack 1 instalado, o atributo serialNumber é igual a Versão 6.5 (Build 7226.6: Service Pack 1).

Se o Exchange Server Analyzer determinar que o valor do atributo serialNumber contém 6.5 e Service Pack 1 na cadeia de caracteres, mas não contém 7226.6 na mesma, será exibido um aviso.

Esse aviso indica que o computador do Exchange Server 2003 está executando uma versão de pré-lançamento do Exchange Server 2003 Service Pack 1.

Observação:
Pelo fato de service packs do Exchange não poderem ser desinstalados, é altamente recomendável que você faça um backup completo do computador com Exchange Server antes de aplicar quaisquer service packs.

Para corrigir esse aviso

  1. Obtenha a versão final do Exchange Server 2003 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=29090).

  2. Leia as Notas de Versão do Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=23235).

  3. Revise as atualizações incluídas no Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=34272).

  4. Faça backup completo do computador do Exchange Server.

  5. Aplique o Service Pack 1 para o Exchange Server 2003.

  6. Execute outro backup completo do computador do Exchange Server.

Para obter mais informações sobre como instalar um service pack do Exchange Server, consulte o artigo 328839 da Base de Dados de Conhecimento da Microsoft, "Como aplicar service packs e hotfixes do Exchange" ( http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Esse servidor Exchange está executando o Windows 2000 Server, mas tem a opção de /3GB definida no arquivo boot.ini.
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta duas classes WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar a quantidade de memória física existente no computador do Exchange Server e a quantidade de espaço de endereçamento virtual alocado para os processos do modo do usuário. A tabela a seguir descreve as classes e chaves sendo avaliadas pelo Exchange Server Analyzer.

Classe | Chave | Descrição
Win32_OperatingSystem | MaxProcessMemorySize | Número máximo de kilobytes de memória que pode ser alocado em um processo.
Win32_OperatingSystem | OSProductSuite | Inclusões de produtos de sistema instaladas e licenciadas para o sistema operacional.
Win32_ComputerSystem | TotalPhysicalMemory | Número de bytes da memória RAM (random access memory) instalada no computador.

Se o Exchange Server Analyzer determinar que o valor da chave MaxProcessMemorySize não é igual a 2097024 e que o valor da chave OSProductSuite resolve para o Windows 2000 Server, será exibido um erro.

Este aviso indica que o servidor de diretório não está configurado corretamente para uso de memória ideal porque a opção de inicialização /3GB foi definida no arquivo Boot.ini. Essa opção só deve ser usada em servidores Exchange com 1 GB (gigabyte) ou mais de memória que estejam executando qualquer um dos sistemas operacionais a seguir:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Importante:
A opção /3GB não deve ser usada no Windows 2000 Server porque não é suportada e pode ocasionar falhas em aplicativos e no sistema operacional. Além disso, a opção /3GB só tem suporte nos sistemas operacionais listados anteriormente quando houver 1 GB ou mais de memória física instalada.

Para corrigir esse erro no Windows Server 2003

  1. Clique com o botão direito em Meu Computador e selecione Propriedades. A caixa de diálogo Propriedades do Sistema será exibida.

  2. Clique na guia Avançado.

  3. Na área de Inicialização e Recuperação, clique no botão Configurações. A caixa de diálogo Inicialização e Recuperação será exibida.

  4. Na área de Inicialização do sistema, clique no botão Editar. Isso abrirá o arquivo Boot.ini do Windows no Bloco de Notas.

  5. Na seção [Sistemas Operacionais] , exclua as opções a seguir de todas as linhas de inicialização: /3GB.

  6. Salve as alterações e feche o Bloco de Notas.

  7. Clique em OK duas vezes para fechar as caixas de diálogo abertas e reinicie o computador para que as alterações entrem em vigor.

Para corrigir esse aviso no Windows 2000 Server

  1. No Windows Explorer, navegue para a partição do sistema.

  2. Se você não consegue ver o arquivo Boot.ini, pode ser devido às Opções de Pasta estarem definidas como Ocultar arquivos protegidos do sistema operacional. Nesse caso, na janela do Windows Explorer, clique em Ferramentas, clique em Opções de Pasta e clique na guia Exibir. Desmarque a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado). Quando a caixa de aviso aparecer, clique em Sim.

  3. Quando o arquivo Boot.ini estiver visível no Windows Explorer, clique com o botão direito no arquivo, clique em Abrir com e escolha Bloco de Notas para abrir o arquivo.

  4. Remova a opção /3GB e salve o arquivo.

  5. Reinicie o servidor de diretório para que a alteração tenha efeito.

Para obter mais detalhes sobre o uso das opções de inicialização /3GB e /USERVA, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 297812, "How to Use the 4GT RAM Tuning Feature" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "The effects of 4GT tuning on system Page Table Entries" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, "Como usar a opção /userva com a opção /3GB para ajustar o espaço Modo usuário para um valor entre 2GB e 3GB" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Não foi possível acessar o WMI do Exchange Server
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-08-24

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se há um valor definido para a chave Name. Se a consulta ao WMI falhar e o Exchange Server não estiver sendo executado no Microsoft Windows NT® Server°4.0, o Exchange Server Analyzer exibirá um erro.

Existem duas causas possíveis para esse erro:

  • A conta que executa o Exchange Server Analyzer não tem permissões suficientes para consultar classes WMI.

  • Um problema de rede está impedindo que o Exchange Server Analyzer entre em contato com o computador.

Para corrigir esse erro

  1. Verifique se o computador do Exchange Server foi iniciado e está conectado à rede.

  2. Use o comando PING para ver se o computador do Exchange Server está acessível.

  3. Se houver um firewall, verifique se as portas de RPC (chamada de procedimento remoto) estão bloqueadas.

  4. Examine as permissões da conta na qual o Exchange Server Analyzer está sendo executado. A conta na qual o Exchange Server Analyzer está sendo executado deve ter permissões de Administrador local em cada servidor Exchange que ele verifica.

    Como alternativa, você pode conceder permissão específica de WMI para a conta na qual o Exchange Server Analyzer está sendo executado:

    1. No computador do Exchange, abra a árvore do MMC (Console de Gerenciamento Microsoft) Gerenciamento do Computador.

    2. Em Serviços e Aplicativos, clique com o botão direito em Controle WMI e clique em Propriedades.

    3. Na página Propriedade dos Controles WMI, clique na guia Segurança e expanda Raiz.

    4. Selecione a pasta CIMV2 e clique em Segurança.

    5. Na página Segurança para ROOT\CIMV2, adicione a conta sob a qual o Exchange Server Analyzer está sendo executado.

  5. Selecione a conta adicionada na Etapa 5 acima. Em Permissões para Conta_Selecionada, na coluna Permitir, selecione Habilitação Remota e Ler Segurança e clique em OK.

Para obter mais informações sobre como solucionar problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Para obter mais informações sobre como solucionar problemas de conectividade da ferramenta Exchange Best Practices Analyzer, consulte "Solucionando problemas de conectividade da ferramenta Microsoft Exchange Best Practices Analyzer " (http://go.microsoft.com/fwlink/?LinkId=56285).

Para obter mais informações sobre requisitos de portas, consulte o artigo 832017 da Base de Dados de Conhecimento Microsoft, "Visão geral de serviço e requisitos de porta de rede para o sistema do Windows Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


O serviço de Atendedor do Sistema do Exchange não está executando nesse servidor front-end
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave Iniciado para o serviço Atendedor do Sistema do Microsoft Exchange. Um valor Falso indica que o serviço Atendedor do Sistema do Exchange não está sendo executado. Um valor Verdadeiro indica que o serviço Atendedor do Sistema do Exchange está sendo executado.

O Exchange Server Analyzer também examina a classe Exchange_Server do WMI no namespace root\MicrosoftExchangeV2 para determinar o valor da chave IsFrontEndServer. Um valor Falso indica que o computador do Exchange Server não é um servidor front-end. Um valor Verdadeiro indica que o computador do Exchange Server é um servidor front-end.

Se o Exchange Server Analyzer verificar que o valor da chave Iniciado em um servidor front-end do Exchange está definido como Falso, um aviso será exibido.

Geralmente, a maior parte dos servidores Exchange executa o serviço Atendedor do Sistema o tempo todo. No entanto, às vezes não é necessário executar o serviço Atendedor do Sistema. Por exemplo, em um servidor front-end, o serviço Atendedor do Sistema é necessário apenas para fazer alterações de configuração no servidor.

O Exchange Server armazena todas as suas informações de configuração no serviço de diretório do Active Directory®, inclusive informações sobre diretivas de destinatários, configuração de servidor virtual SMTP, configurações de RPC (chamada de procedimento remoto) por HTTP e caixas de correio de usuários. No entanto, o protocolo SMTP lê suas configurações a partir da metabase dos Serviços de Informação da Internet (IIS). Para preencher a metabase do IIS com as informações de que o Exchange necessita para as funcionalidades SMTP e RPC por HTTP, o componente DS2MB (serviço de diretório da metabase) do Atendedor do Sistema replica as informações de configuração do Active Directory para a metabase do IIS. Se o Atendedor do Sistema não estiver em execução, as alterações feitas à configuração do Exchange Server e armazenadas no Active Directory não serão copiadas para a metabase do IIS do Exchange Server. Se não estiverem sendo feitas alterações de configuração, e se as mensagens SMTP não estiverem sendo processadas, o serviço Atendedor do Sistema poderá permanecer parado.

Se houver alterações de configuração a serem feitas, inicie o serviço Atendedor do Sistema, faça as alterações de configuração e espere que essas alterações sejam replicadas para a metabase do IIS. Para determinar se as alterações foram replicadas do Active Directory para a metabase do IIS, verifique a presença de três entradas no log de eventos de aplicativos do servidor Exchange que tenham MSExchangeMU como origem do evento e ID de evento igual a 1005. Esses eventos serão registrados depois de uma replicação de DS2BM bem-sucedida. Assim que esses eventos forem registrados, você poderá parar o serviço Atendedor do Sistema.

A menos que o SMTP esteja sendo usado em um servidor front-end, a configuração recomendada é parar o Atendedor do Sistema e, em seguida, defini-lo como desabilitado. Em servidores front-end que usam SMTP e em todos os outros computadores do Exchange Server, o serviço Atendedor do Sistema do Exchange deve estar sendo executado para entregar mensagens, transações de armazenamento de caixa de correio e serviço SMTP e executar replicação DS2MB.

O serviço Atendedor do Sistema do Exchange deve estar sempre em execução em servidores back-end e qualquer outro servidor Exchange que contenha caixas de correio ou pastas públicas.

Para corrigir esse aviso

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. No painel da direita, role para baixo até o serviço Atendedor do Sistema do Microsoft Exchange e clique duas vezes nele. Isso exibirá a caixa de diálogo Propriedades do Serviço Atendedor do Sistema.

  3. Defina o valor na lista suspensa Tipo de inicialização como Automático.

  4. Clique em Iniciar para iniciar o serviço Atendedor do Sistema.

  5. Clique em OK para salvar as alterações e fechar a caixa de diálogo Propriedades do Serviço Atendedor do Sistema.

  6. Feche o snap-in Serviços.

Para obter mais informações sobre como desabilitar o serviço Atendedor do Sistema e proteger servidores Exchange, consulte os seguintes tópicos do Exchange Server:

  • "Protegendo servidores Exchange 2000 com base em função" (http://go.microsoft.com/fwlink/?LinkId=35585)

  • "Exchange Server 2003 Security Hardening Guide" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47578)


O Atendedor do Sistema do Microsoft Exchange não está em execução
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave Iniciado para o serviço Atendedor do Sistema do Microsoft Exchange. Um valor Falso indica que o serviço Atendedor do Sistema do Exchange não está sendo executado. Um valor Verdadeiro indica que o serviço Atendedor do Sistema do Exchange está sendo executado.

O Analisador do Exchange Server também examina a classe WMI Exchange_Server no namespace root\MicrosoftExchangeV2 para determinar o valor da chave IsFrontEndServer. Um valor Falso indica que o computador do Exchange Server não é um servidor front-end. Um valor Verdadeiro indica que o computador do Exchange Server é um servidor front-end.

Se o Analisador do Exchange Server detectar que o valor da chave Iniciado está definido como Falso em um computador do Exchange Server que não seja um servidor front-end, será exibido um aviso.

Geralmente, a maior parte dos servidores Exchange executa o serviço Atendedor do Sistema o tempo todo. No entanto, às vezes não é necessário executar o serviço Atendedor do Sistema. Por exemplo, em um servidor front-end do Exchange 2000 Server ou do Exchange Server 2003, o serviço Atendedor do Sistema é necessário apenas para fazer alterações na configuração do servidor.

O Exchange Server armazena todas as suas informações de configuração no serviço de diretório do Active Directory®, inclusive informações sobre diretivas de destinatários, configuração de servidor virtual SMTP, configurações de RPC (chamada de procedimento remoto) por HTTP e caixas de correio de usuários. No entanto, o protocolo SMTP lê suas configurações a partir da metabase dos Serviços de Informação da Internet (IIS). Para preencher a metabase do IIS com as informações de que o Exchange necessita para as funcionalidades SMTP e RPC por HTTP, o componente DS2MB (serviço de diretório da metabase) do Atendedor do Sistema replica as informações de configuração do Active Directory para a metabase do IIS. Se o Atendedor do Sistema não estiver em execução, alterações feitas nas definições de configuração do Exchange Server que estão armazenadas no Active Directory não serão copiadas na metabase do IIS do Exchange Server. Se não estiverem sendo feitas alterações de configuração, e se as mensagens SMTP não estiverem sendo processadas, o serviço Atendedor do Sistema poderá permanecer parado.

Se houver alterações de configuração a serem feitas, inicie o serviço Atendedor do Sistema, faça as alterações de configuração e espere que essas alterações sejam replicadas para a metabase do IIS. Para determinar se as alterações foram replicadas do Active Directory para a metabase do IIS, verifique a presença de três entradas no log de eventos de aplicativos do servidor Exchange que tenham MSExchangeMU como origem do evento e ID de evento igual a 1005. Esses eventos serão registrados depois de uma replicação de DS2BM bem-sucedida. Assim que esses eventos forem registrados, você poderá parar o serviço Atendedor do Sistema.

A menos que o SMTP esteja sendo usado em um servidor front-end do Exchange 2000 Server ou do Exchange Server 2003, a configuração recomendada é parar o serviço Atendedor do Sistema e defini-lo como desabilitado. Em servidores front-end do Exchange 2000 Server ou do Exchange Server 2003 que usam SMTP, e em todos os outros computadores do Exchange Server, o serviço Atendedor do Sistema do Exchange deve estar em execução para poder entregar mensagens, realizar transações de SMTP e de armazenamento de caixas de correio e executar a replicação DS2MB.

O serviço Atendedor do Sistema do Exchange deve estar sempre em execução em servidores back-end e qualquer outro servidor Exchange que contenha caixas de correio ou pastas públicas.

Para corrigir esse aviso

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. No painel da direita, role para baixo até o serviço Atendedor do Sistema do Microsoft Exchange e clique duas vezes nele. Isso exibirá a caixa de diálogo Propriedades do Serviço Atendedor do Sistema.

  3. Defina o valor no menu suspenso Tipo de inicialização como Automático.

  4. Clique em Iniciar para iniciar o serviço Atendedor do Sistema.

  5. Clique em OK para salvar as alterações e fechar a caixa de diálogo Propriedades do Serviço Atendedor do Sistema.

  6. Feche o snap-in Serviços.

Para obter mais informações sobre como desabilitar o serviço Atendedor do Sistema e a proteção dos Exchange Servers, consulte "Protegendo Exchange 2000 Servers com base na função" (http://go.microsoft.com/fwlink/?linkid=35585).


Heaps Exchmem indicando problema de desempenho
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta do Microsoft® Exchange Server Analyzer analisou os contadores de desempenho Exchmem Heap no objeto de desempenho MSExchangeIS para determinar se o desempenho no servidor Exchange diminuiu. A ferramenta do Exchange Server Analyzer relata sobre os contadores Exchmem da seguinte maneira:

  • Se o número do Exchmem: O número de heaps com erros de memória for maior que zero, o Exchange Server Analyzer relatará um aviso. Se este valor for maior que cinco, o Exchange Server Analyzer relatará um erro.

  • Se o número do Exchmem: O número de heaps com erros de memória for maior que 500, o Exchange Server Analyzer relatará um erro.

  • Se o número do Exchmem: O número de heaps com erros de memória for maior que 500, o Exchange Server Analyzer relatará um erro.

O processo Store.exe utiliza seu próprio mecanismo e estruturas de alocação de heap. Eles são chamados Exchmem. Na inicialização, o processo Store.exe cria vários heaps Exchmem. O Store.exe não aumenta o número de heaps a não ser que o número existente esteja sendo totalmente usado ou fragmentado em um ponto em que a alocação não pode localizar memória contígua suficiente para obter sucesso.

Se houver um problema de utilização da memória ou fragmentação interna (ou seja, fragmentação nos heaps Exchmem, que residem dentro do espaço de memória virtual do armazenamento do Exchange), o processo Store.exe cria novos heaps Exchmem.

Geralmente, se o processo Store.exe deve criar heaps adicionais repetidamente, a memória virtual de armazenamento geral do Exchange torna-se fragmentada ou vazia. Rastreando os contadores listados acima é possível determinar se os heaps Exchmem são a fonte do problema ou se seu desempenho diminui conforme os heaps se tornam fragmentados.

Para corrigir o aviso ou erro

  • Baixe e instale as atualizações de armazenamento do Exchange mais recentes.

    • Para obter os downloads mais recentes do Exchange Server 2003, consulte o site Downloads para o Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

    • Para obter os downloads mais recentes do Exchange 2000 Server, consulte o site Downloads para o Exchange 2000 Server (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).

  • Baixe e instale as atualizações mais recentes de todos os aplicativos que estejam sendo executados no processo Store.exe. Às vezes, aplicativos de terceiros sendo executado no processo Store.exe podem causar a fragmentação de heap.

  • tente mover as caixas de correio do usuário do servidor afetado para outro servidor para reduzir a carga do servidor. Para obter mais informações, consulte Mover Caixas de Correio de Usuário para Outro Servidor.

  • Até que a causa do problema seja identificada, você pode reiniciar conforme for necessário para reconfigurar a memória.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).


EXCHMEM.DLL presente na pasta do Windows System32
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-12-15

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se ele pode ler o valor da chave Version para \Windows\System32\Exchmem.dll. Se o Exchange Server Analyzer puder ler a chave Versiono, o Exchmem.dll estará presente na pasta System32.

O Analisador do Exchange Server também consulta o serviço de diretórios do Active Directory® para determinar o valor do atributo serialNumber de todos os objetos que tenham a classe msExchExchangeServer. Se a cadeia de caracteres incluir "Version 6", o computador estará executando o Exchange 2000 Server ou Exchange Server 2003.

O Exchange Server Analyzer exibe uma mensagem de prática recomendada se as seguintes condições forem verdadeiras:

  • O Exchmem.dll está presente na pasta System32.

  • O computador está executando o Exchange 2000 Server ou Exchange Server 2003.

Normalmente, não existem duas cópias do Exchmem.dll em um servidor do Exchange. Porém, às vezes, um segundo arquivo Exchmem.dll é adicionado usando uma atualização no local de versões anteriores do produto. A presença de duas versões do arquivo pode ocasionar falha durante a instalação de service packs. Para evitar problemas, é recomendável renomear ou remover o arquivo Exchmem.dll da pasta \Windows\System32.

Para remover ou renomear uma segunda versão do Exchmem.dll

  1. Parar todos os serviços do Exchange.

  2. Renomeie ou remova o arquivo Exchmem.dll na pasta \Windows\System32.

  3. Reiniciar todos os serviços do Exchange.


Erro fatal encontrado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer Tool tenta acessar vários recursos específicos para executar sua análise.

  • Serviço de diretório do Microsoft Active Directory®

  • Central de Controle de Mensagens do Exchange Server

  • Registro do Microsoft Windows®

  • WMI (Instrumentação de Gerenciamento do Microsoft Windows®)

  • Metabase do IIS (Serviços de Informações da Internet)

Se não puder acessar um ou mais dos recursos necessários, o Exchange Server Analyzer exibirá um erro.

Esse erro indica que, como um ou mais desses recursos básicos não podem ser acessados, não é possível realizar uma análise adicional.

Para resolver esse erro, consulte a orientação de erro específico do recurso e os links fornecidos pelo Exchange Server Analyzer.


O log FCL (Log de Chamadas de Função) não está habilitado para este servidor
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-20

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber de todos os objetos que tenham uma classe de objeto msExchExchangeServer. Se o valor da cadeia de caracteres incluir Versão 5.5, o computador estará executando o Microsoft Exchange Server versão 5.5. Se o valor da cadeia de caracteres incluir Versão 6.0, o computador estará executando o Exchange 2000 Server. Se o valor da cadeia de caracteres incluir Versão 6.5, o computador estará executando o Exchange Server 2003.

O Exchange Server Analyzer também consulta a presença da subchave Disable Call Tracing na seguinte entrada do Registro para determinar se o recurso FCL (Log de Chamadas de Função) do Microsoft Exchange está habilitado para o servidor Exchange:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

O Exchange Server pode rastrear o desempenho das chamadas internas feitas pelo serviço Armazenamento de Informações (Store.exe) do Microsoft Exchange. É possível usar o FCL para isolar o componente e a chamada de função que podem ser a principal causa do problema de desempenho.

A funcionalidade FCL no serviço Armazenamento de Informações do Microsoft Exchange rastreia as chamadas relevantes para os seguintes componentes:

  • Local Security Authentication Server (Lsass.exe)

  • DSAccess

  • ESE (Mecanismo de Armazenamento Extensível)

  • IMAIL

  • Virusscan

O FCL é um log de baixa sobrecarga que reúne dados sobre cenários de problemas, como problemas de encerramento no Exchange Server ou situações em que o serviço Armazenamento de Informações (Store.exe) do Exchange apresenta uma degradação do desempenho ou em que o serviço não está respondendo.

Assim que habilitado, o FCL registra automaticamente em log os dados da chamada de função. Não é necessária a intervenção do usuário ou uma configuração específica, como obter um arquivo de despejo do usuário do servidor de produção ou usar um depurador.

Por padrão, o FCL está habilitado no Exchange Server 2003, mas deve ser especificamente habilitado no Exchange 2000 Server.

O Analisador do Exchange Server exibirá uma mensagem de práticas recomendadas, se as seguintes condições forem verdadeiras:

  • O servidor está executando o Exchange 2000 Server e a subchave Disable Call Tracing não está presente ou a subchave Disable Call Tracing existe, mas contém um valor diferente de 0.

  • O servidor está executando o Exchange Server 2003 e a subchave Disable Call Tracing está presente e contém um valor diferente de 0.

Essa mensagem de práticas recomendadas indica que o FCL está desabilitado.

É uma prática recomendada habilitar o FCL em todos os servidores Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para habilitar o Log de Chamadas de Função em um Exchange 2000 Server

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing

  3. No painel direito, clique duas vezes em Desabilitar Rastreamento de Chamadas. Se a subchave Disable Call Tracing não estiver presente, crie-a como um novo valor DWORD.

  4. Configure a subchave Desabilitar o Rastreamento de Chamadas com um valor igual a 0.
Observação:
Por padrão, o FCL está desativado no Exchange 2000 Server e este valor está definido como 1.
  1. Feche o editor de Registro.

  2. Reinicie o serviço Armazenamento de Informações do Exchange para que essas alterações entrem em vigor.

 Para habilitar o Log de Chamadas de Função em um Exchange Server 2003

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing.

  3. No painel direito, clique duas vezes em Desabilitar Rastreamento de Chamadas.

  4. Configure a subchave Desabilitar o Rastreamento de Chamadas com um valor igual a 0.
Observação:
Por padrão, o FCL está ativado no Exchange Server 2003, a subchave Disable Call Tracing foi criada e seu valor foi definido com algo diferente de 0 para desativá-lo.
  1. Feche o editor de Registro.

  2. Reinicie o serviço Armazenamento de Informações do Exchange para que essas alterações entrem em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


As Entradas de Tabela de Página Livres estão no limite crítico
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows) Win32_PerfRawData_PerfOS_Memory para determinar o valor atual do objeto FreeSystemPageTableEntries. Se o valor de FreeSystemPageTableEntries for menor ou igual a 5000, será exibido um erro.

O Microsoft Windows Server™ 2003 e o Windows 2000 Server podem especificar diretamente até 4 gigabytes (GB) de espaço de endereçamento de memória, independentemente da quantidade de RAM física que está instalada. Do ponto de vista do processo, cada elemento do endereço virtual conceitualmente refere-se a um byte de memória física. É responsabilidade do VMM (Gerenciador de Memória Virtual), em conjunto com a MMU (unidade do gerenciador de memória) do processador, converter ou mapear cada endereço virtual em um endereço físico correspondente. O VMM executa o mapeamento dividindo a RAM em quadros de página de tamanho fixo, criando PTEs para armazenar informações sobre esses quadros de página e mapeando-os. As PTEs do sistema são pequenos buffers de memória no modo kernel que são usados para fazer a comunicação com o subsistema de E/S e a rede. Cada PTE representa um quadro de página e contém as informações necessárias para o VMM localizar uma página.

Em um sistema baseado em x86 que usa um tamanho de página igual a 4 KB, o número máximo de PTEs necessárias para mapear 2 GB de espaço de endereçamento é 524.288 (2 GB/4 KB). Em um sistema similar usando a opção de /3GB, o número de PTEs necessários para mapear 3 GB de espaço de endereçamento é 786.432 (3 GB/4 KB). Em um sistema típico, esse espaço é usado como a seguir:

  • Um máximo de 50.000 PTEs (aproximadamente 195 MB de espaço de endereçamento) são reservadas para uso geral.

  • O restante é usado para mapear o cache de sistema, hiperespaço, pool paginado, pool não paginado, área de despejo de memória e assim por diante.

Esse tamanho de pool da PTE é automaticamente determinado na inicialização do sistema baseado na quantidade de memória física do sistema. Esta sondagem é espremida entre a sondagem paginada e a não paginada, que também cresce com a quantidade de memória física no sistema.

O pool da PTE do sistema pode tornar-se muito usado e muito fragmentado. Isso pode levar a situações em que um driver não pode ser carregado. Além disso, se o pool da PTE do sistema for reduzido completamente, outras partes do sistema serão prejudicadas, resultando na não criação de threads, em paralisações do sistema e possíveis falhas do sistema.

Um computador do Exchange Server íntegro deve ter ao menos 8,000 PTEs de sistema disponíveis o tempo todo. Se o número de PTEs livres no sistema cair abaixo de 8.000 mas permanecer superior a 5.000, o aviso descrito em As PTEs (entradas de tabela de página) livres estão no limite de aviso será exibido. Quando o número de PTEs livres do sistema cai abaixo de 5.000, esse erro é exibido.

Para resolver esse problema, você pode usar o procedimento a seguir para configurar o valor do Registro SystemPages corretamente para o sistema operacional do computador do Exchange Server. Quando você está executando o Exchange Server 2003 Service Pack 1 (SP1) no Windows Server 2003 com 1 GB ou mais de RAM, é recomendável que você defina a chave de Registro SystemPages como zero. Essa recomendação contrasta com a recomendação para o Windows 2000 Server, que é definir SystemPages como um valor decimal 31000.

Depois de executar o procedimento a seguir, você deverá monitorar o número de PTEs do sistema livres. Isso é possível por meio do monitoramento do contador de desempenho das Entradas de Tabela de Página Livres | Memória com o Monitor do Sistema Windows (também conhecido como Monitor de Desempenho). Se depois de executar a mudança do Registro, o número de PTEs do sistema livres permanecer baixo, você deve verificar o seguinte para garantir que seu computador do Exchange Server esteja com a configuração ideal:

  • Drivers Um driver que não funciona corretamente é uma das causas mais comuns de PTEs de sistema baixas. Verifique com o fabricante do hardware para garantir que você está usando os drivers mais recentes em todo o seu hardware. Além disso, pode haver oportunidades para rebaixar para um driver mais básico. Por exemplo, os computadores que executam aplicativos baseados em servidor como o Exchange Server geralmente não precisam de drivers de vídeo muito avançados com todos os recursos. Em vez disso, um driver mais básico geralmente é suficiente. A troca de um driver de vídeo avançado por um driver de vídeo básico deve aumentar o número de PETs de sistema livres.

  • Configuração do sistema Se seu sistema Windows Server 2003 tem 1 GB ou mais de memória física instalada, você deve verificar se o arquivo Boot.ini está configurado corretamente com as opções /3GB e /USERVA=3030 como descrito no artigo 823440 da Base de Dados de Conhecimento da Microsoft, "Uso da opção /3GB no Exchange Server 2003 em um sistema com o Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440) e o artigo 810371 da Base de Dados de Conhecimento, "XADM: Usando a Opção /Userva nos Servidores Exchange com base em Windows Server 2003 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371).

  • Logs de eventos Marque o log de eventos do aplicativo no servidor Exchange para obter erros e avisos, especialmente os eventos 9582 (erros e avisos), 9665 (aviso) e 12880 (erro) do MSExchangeIS. A presença do evento 9665 também pode indicar que SystemPages não está configurado para um desempenho ideal. Para obter mais informações sobre esses eventos, consulte o artigo 325044 da Base de Dados de Conhecimento, "COMO: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro em um computador que executa o Windows 2000 Server

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. No painel direito, clique duas vezes em SystemPages.

  4. No campo Dados do valor, digite o valor decimal 31.000 (31.000 é a representação decimal do hexadecimal 7918. Regedit.exe usa como padrão os valores hexadecimais) e clique em OK.

  5. Feche o editor de Registro e reinicie o computador para que a alteração entre em vigor.

Para corrigir esse erro em um computador que executa a versão de lançamento original do Windows Server 2003

  • Revise as informações no artigo 894067 da Base de Dados de Conhecimento da Microsoft, "A ferramenta Desempenho não mostra precisamente as PTEs livres do sistema disponíveis no Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067), para determinar as PTEs livres do sistema.

Para corrigir esse erro em um computador que executa o Windows Server 2003 SP1

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. No painel direito, clique duas vezes em SystemPages.

  4. No campo Dados do valor, digite 0 e clique em OK.

  5. Feche o editor de Registro.

  6. Clique com o botão direito em Meu Computador e clique em Propriedades. A caixa de diálogo Propriedades do Sistema será exibida.

  7. Clique em Avançado.

  8. Na área Inicialização e Recuperação, clique em Configurações. A caixa de diálogo Inicialização e Recuperação será exibida.

  9. Na área Inicialização do sistema, clique em Editar. Isso abrirá o arquivo Boot.ini do Windows no Bloco de Notas.

  10. Revise a seção [Sistemas Operacionais].

    1. Se a opção /3GB existir mas não a opção /USERVA=3030, adicione a opção /USERVA=3030 à linha de inicialização para que ela seja configurada como /3GB /USERVA=3030.

    2. Se as opções /3GB /USERVA=3030 já estiverem configuradas, altere o valor da opção /USERVA para /USERVA=2970.

  11. Salve as alterações e feche o Bloco de Notas.

  12. Clique em OK duas vezes para fechar as caixas de diálogo abertas e reinicie o computador para que as alterações entrem em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como otimizar a memória do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento:

  • 894067, "A ferramenta Desempenho não mostra precisamente as PTEs livres do sistema no Windows Server 2003" http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 823150, "Como reunir dados para solucionar problemas de memória virtual do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, "Os efeitos do ajuste do 4GT nas Entradas de Tabela de Página do Sistema" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


As PTEs (entradas de tabela de página) livres estão no limite de aviso
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows) Win32_PerfRawData_PerfOS_Memory para determinar o valor atual do objeto FreeSystemPageTableEntries. Se o valor de FreeSystemPageTableEntries for maior que 5000, mas menor ou igual a 8000, será exibido um aviso.

O Microsoft Windows Server™ 2003 e o Windows 2000 Server podem especificar diretamente até 4 gigabytes (GB) de espaço de endereçamento de memória, independentemente da quantidade de RAM física que está instalada. Do ponto de vista do processo, cada elemento do endereço virtual conceitualmente refere-se a um byte de memória física. É responsabilidade do VMM (Gerenciador da Memória Virtual) juntamente com a MMU (Unidade do Gerenciador de Memória ) do processador converter ou mapear cada endereço virtual para um endereço físico correspondente. O VMM executa o mapeamento dividindo a RAM em quadros de página de tamanho fixo, criando PTEs para armazenar informações sobre esses quadros de página e mapeando-os. As PTEs do sistema são pequenos buffers de memória no modo kernel que são usados para fazer a comunicação com o subsistema de E/S e a rede. Cada PTE representa um quadro de página e contém as informações necessárias para que a VMM localize uma página.

Em um sistema baseado em x86 que usa um tamanho de página igual a 4 KB, o número máximo de PTEs necessárias para mapear 2 GB de espaço de endereçamento é 524.288 (2 GB/4 KB). Em um sistema semelhante usando a opção de /3GB, o número de PTEs necessárias para mapear 3 GB de espaço de endereçamento é 786.432 (3 GB/4 KB). Em um sistema típico, esse espaço é usado como a seguir:

  • Um máximo de 50.000 PTEs (aproximadamente 195 MB de espaço de endereçamento) são reservadas para uso geral.

  • O restante é usado no mapeamento do cache do sistema, hiperespaço, pool paginado, pool não paginado, área de despejo de memória e assim por diante.

Esse tamanho de pool da PTE é automaticamente determinado na inicialização do sistema baseado na quantidade de memória física do sistema. Esse pool é pressionado entre os pools paginado e não paginado, o que também aumenta a quantidade de memória física no sistema.

O pool da PTE do sistema pode tornar-se muito usado e muito fragmentado. Isso pode gerar situações em que um driver não seja carregado. Além disso, se o pool da PTE do sistema estiver completamente vazio, outras partes do sistema serão prejudicadas, resultando em segmentos que não são criados, paralizações do sistema e falhas potenciais do sistema.

Um computador do Exchange Server íntegro deve ter ao menos 8,000 PTEs de sistema disponíveis o tempo todo. Se o número de PTEs livres do sistema cair abaixo de 5.000, será exibido o erro descrito em As Entradas de Tabela de Página Livres estão no limite crítico. Quando o número de PTEs livres do sistema estiver abaixo de 8.000, mas permanecer acima de 5.000, esse aviso será exibido.

Para resolver esse problema, você pode usar o procedimento a seguir para configurar o valor do Registro SystemPages corretamente para o sistema operacional do computador do Exchange Server. Quando você está executando o Exchange Server 2003 Service Pack 1 (SP1) no Windows Server 2003 com 1 GB ou mais de RAM, é recomendável que você defina a chave de Registro SystemPages como zero. Essa recomendação contrasta com a recomendação para o Windows 2000 Server, que é definir SystemPages como um valor decimal 31.000.

Após executar o procedimento a seguir, monitore o número de PTEs do sistema livres. Isso é possível por meio do monitoramento do contador de desempenho das Entradas de Tabela de Página Livres | Memória com o Monitor do Sistema Windows (também conhecido como Monitor de Desempenho). Se, após fazer a alteração de Registro descrita neste artigo, o número de PTEs de sistema livres permanecer baixo, verifique o seguinte para garantir que o computador do Exchange Server esteja configurado adequadamente:

  • Drivers Um driver que não funciona corretamente é uma das causas mais comuns de PTEs de sistema baixas. Entre em contato com o fabricante do hardware para verificar se você está usando os drivers mais recentes para todos os seus hardwares. Além disso, pode haver oportunidades para rebaixar para um driver mais básico. Por exemplo, os computadores que executam aplicativos baseados em servidor como o Exchange Server geralmente não precisam de drivers de vídeo muito avançados com todos os recursos. Em vez disso, um driver mais básico geralmente é suficiente. A troca de um driver de vídeo avançado por um driver de vídeo básico deve aumentar o número de PETs de sistema livres.

  • Configuração do sistema Se seu sistema Windows Server 2003 tiver 1 GB ou mais de memória física instalada, verifique se o arquivo Boot.ini está corretamente configurado com as opções /3GB e /USERVA=3030, como descrito no artigo 823440 da Base de Dados de Conhecimento Microsoft, "Você deve usar a opção /3GB ao instalar o Exchange Server 2003 em um sistema baseado no Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440) e no artigo 810371 da Base de Dados de Conhecimento, "XADM: Usando a Opção /Userva nos Servidores Exchange com base em Windows Server 2003 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371).

  • Logs de eventos Marque o log de eventos do aplicativo no servidor Exchange para obter erros e avisos, especialmente os eventos 9582 (erros e avisos), 9665 (aviso) e 12880 (erro) do MSExchangeIS. O evento 9665 também pode indicar que SystemPages não esteja configurado para o desempenho ideal. Para obter mais informações sobre esses eventos, consulte o artigo 324044 da Base de Dados de Conhecimento, "COMO: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir este aviso em um computador que está executando o Windows 2000 Server

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. No painel direito, clique duas vezes em SystemPages.

  4. No campo Dados do valor, digite o valor decimal 31.000 (31.000 é a representação decimal do hexadecimal 7918. Regedit.exe usa como padrão os valores hexadecimais) e clique em OK.

  5. Feche o editor de Registro e reinicie o computador para que a alteração entre em vigor.

Para corrigir este aviso em um computador que está executando a versão original do Windows Server 2003

  • Revise as informações no artigo 894067 da Base de Dados de Conhecimento da Microsoft, "A ferramenta Desempenho não mostra precisamente as PTEs livres do sistema disponíveis no Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067), para determinar as PTEs livres do sistema.

Para corrigir este aviso em um computador que está executando o Windows Server 2003 SP1

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. No painel direito, clique duas vezes em SystemPages.

  4. No campo Dados do valor, digite 0 e clique em OK.

  5. Feche o editor de Registro.

  6. Clique com o botão direito em Meu Computador e clique em Propriedades. A caixa de diálogo Propriedades do Sistema será exibida.

  7. Clique em Avançado.

  8. Na área Inicialização e Recuperação, clique em Configurações. A caixa de diálogo Inicialização e Recuperação será exibida.

  9. Na área Inicialização do sistema, clique em Editar. Isso abrirá o arquivo Boot.ini do Windows no Bloco de Notas.

  10. Revise a seção [Sistemas Operacionais].

    1. Se a opção /3GB existir mas não a opção /USERVA=3030, adicione a opção /USERVA=3030 à linha de inicialização para que ela seja configurada como /3GB /USERVA=3030.

    2. Se as opções /3GB /USERVA=3030 já estiverem configuradas, altere o valor da opção /USERVA para /USERVA=2970.

  11. Salve as alterações e feche o Bloco de Notas.

  12. Clique em OK duas vezes para fechar as caixas de diálogo abertas e reinicie o computador para que as alterações entrem em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como otimizar a memória do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento:

  • 894067, "A ferramenta Desempenho não mostra precisamente as PTEs livres do sistema no Windows Server 2003" http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 823150, "Como reunir dados para solucionar problemas de memória virtual do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, "Os efeitos do ajuste do 4GT nas Entradas de Tabela de Página do Sistema" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


O servidor front-end está executando o Serviço de Replicação de Site
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta o objeto do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) do Exchange Server (classe Exchange_Server) para determinar o valor IsFrontEndServer do servidor. Se o valor for True, o servidor Exchange está agindo como um servidor front-end. O Exchange Server Analyzer também consulta o objeto MSExchangeSRS do WMI (classe Win32_Service) para determinar o valor da propriedadeIniciado desse objeto. Se o valor for Verdadeiro, o Serviço de Replicação de Site está sendo executado nesse servidor.

Se o servidor Exchange estiver designado como um servidor front-end e também tiver uma instância de execução no Serviço de Replicação de Site, será exibido um aviso.

O Exchange usa o Serviço de Replicação de Site se sua topologia incluir servidores que executam o Exchange Server versão 5.5 e Exchange 2000 Server ou Exchange Server 2003. Com esse serviço, versões posteriores do Exchange podem replicar informações de configuração do servidor para os servidores Exchange Server 5.5 em um formato compatível com o diretório do Exchange Server 5.5 e podem também processar corretamente as informações de configuração replicadas do diretório do Exchange Server 5.5 de modo que possam ser armazenadas no serviço de diretório do Active Directory®. Se a sua topologia estiver configurada para usar servidores front-end e back-end, o Serviço de Replicação de Site deve ser executado somente em servidores back-end. Até o Exchange 2000 Server Service Pack 2, o Serviço de Replicação de Site não funciona corretamente em servidores front-end e pode causar problemas.

Para corrigir esse problema, converta o servidor front-end em um servidor back-end e configure um novo servidor front-end. Não é recomendável tentar remover o Serviço de Replicação de Site do servidor.

Para corrigir esse erro

  1. Configure um novo servidor front-end.

  2. No servidor front-end com problemas, no Gerenciador de Sistema do Exchange, em Servidores, clique com o botão direito no servidor com problemas e clique em Propriedades.

  3. Desmarque a caixa de seleção Este é um servidor front-end.

Para obter mais informações sobre o servidor front-end e o Serviço de Replicação de Site, consulte o artigo 313646 na Base de Dados de Conhecimento da Microsoft, "Os serviços são desabilitados em servidores front-end após uma atualização do Exchange 2000 Server SP2" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313646).


O arquivo GAPI32.DLL está ausente na pasta bin
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O arquivo GAPI32.DLL está ausente na pasta system32
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para corrigir esse erro, instale o service pack mais recente ou distribua sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


GlobalFlag foi definido
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar o valor da entrada GlobalFlag:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

Se o Exchange Server Analyzer perceber que o valor GlobalFlag está presente e configurado com qualquer valor diferente de 0 ou nulo, será exibido um aviso.

A configuração de valor do Registro GlobalFlag é um bitmask que determina quais opções de depuração foram habilitadas para um processo específico. Nesse caso, o Exchange Server Analyzer está verificando especificamente se alguma opção de depuração foi habilitada para diversos componentes do Exchange:

  • STORE.EXE (o processo de armazenamento de informações)

  • MAD.EXE (o processo de atendedor do sistema)

  • INETINFO.EXE (o Admin. do IIS e processo pai)

  • EMSMTA.EXE (o processo do agente de transferência de mensagens)

A menos que você participe ativamente na depuração ou no rastreamento de um problema com a ajuda do Atendimento Microsoft, é recomendável que o valor de GlobalFlag esteja sempre definido como 0 ou seja totalmente excluído, o que surte o mesmo efeito.

Por padrão, o valor do Registro GlobalFlag não está presente e deve ser adicionado manualmente se for necessária a depuração do processo STORE.EXE (ou de qualquer outro processo). Você pode usar a ferramenta Gflags incluída nas Ferramentas de Suporte do Microsoft Windows Server™ 2003, no CD do Windows, na pasta \Support. Como alternativa, defina manualmente o valor como 0 ou exclua totalmente o valor de GlobalFlag, usando um editor de Registro. Ambos os procedimentos estão descritos neste artigo.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir este problema usando Gflags

  1. Clique em Iniciar, clique em Executar e no campo Abrir, execute a ferramenta GFlags. A interface de usuário Global Flags será exibida.

  2. No campo Nome do Arquivo de Imagem, digite STORE.EXE.

  3. Selecione as Opções do Arquivo de Imagem.

  4. Desmarque todas as caixas de seleção e clique em Aplicar.

  5. Repita as etapas 2 a 4 para cada processo do Exchange listado neste artigo.

  6. Clique em OK para sair da ferramenta GFlags e reinicie os serviços afetados para que a alteração entre em vigor.

Para corrigir esse erro usando um editor de Registro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. Exclua o valor chamado GlobalFlag.

  4. Repita as etapas 2 e 3 de cada processo do Exchange listado neste artigo.

  5. Saia do editor de Registro e reinicie os serviços afetados para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Está ocorrendo um número alto de falhas de atualização de ACL
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_PerfRawData_MSExchangeIS_MSExchangeIS da Instrumentação de Gerenciamento do Microsoft Windows® para determinar o valor atual da chave ACLUpgradefailures. A chave ACLUpgradefailures representa o contador de desempenho ACL Upgrade: failures no objeto de desempenho MSExchangeIS.

Se o Exchange Server Analyzer verificar que o valor da chave ACLUpgradefailures é maior do que 500, será exibido um aviso.

Esse aviso indica que o servidor Exchange relatou muitas falhas de atualização da ACL (lista de controle de acesso). Um excesso de falhas de atualização da ACL pode causar problemas sérios de desempenho, inclusive interrupções aleatórias no processo de Armazenamento de Informações (store.exe).

As falhas de atualização da ACL podem ocorrer por diversas razões, e sabe-se que elas ocorrem na presença das seguintes condições:

  • Em uma organização do Exchange em modo misto, o ajustador de consistência do Exchange Server versão 5.5 não foi executado antes da implementação do servidor do ADC (Active Directory Connector). O ajustador de consistência do Exchange Server 5.5 remove ACLs órfãs.

  • A replicação do Active Directory não está funcionando corretamente.

  • A replicação do Active Directory Connector não está replicando corretamente as contas do Exchange Server 5.5 para o Active Directory.

  • Houve uma migração incorreta de contas de usuário.

Para corrigir esse aviso

  1. Examine 812963 da Base de Dados de Conhecimento Microsoft, "Usando a chave do Registro Ignore Zombie Users" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963).

  2. Depois de compreender as implicações de usar a chave do Registro Ignore Zombie Users, adicione a chave conforme considerar adequado.

  3. Execute o Exchange Server Analyzer ou monitore o contador de desempenho ACL Upgrade: failures para procurar excessos de falhas de atualização da ACL.


Usuário Exmon altamente ativo
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-21

A ferramenta Analisador do Microsoft® Exchange Server usa a ferramenta ExMon (Monitor de Usuários do Exchange Server) para descobrir se um usuário ou processo (ou um grupo de usuários ou de processos) é o causador de uma porcentagem extremamente grande da carga do servidor atual.

O ExMon avalia diversas situações:

  • Restrições do cliente

  • Altas operações RPC (chamada de procedimento remoto) em massa

  • Altas operações de sincronização RPC

  • Alto número de operações online do cliente

  • Operações de exibição do usuário

As seções a seguir apresentam detalhes sobre cada situação e as ações recomendadas para cada uma delas.

Restrições do cliente

Nesta situação, os dados RPC do ExMon (Monitor de Usuários do Exchange Server) indicam que as restrições do computador cliente estão causando alta carga neste servidor. No contexto MAPI, uma restrição está relacionada à operação MAPI chamada Restrict. Essa operação é usada para selecionar itens que atendem a determinados critérios. A operação Restrict faz parte do processo que solicita ao Exchange a criação de uma exibição em uma pasta ou conjunto de pastas (na realidade, uma tabela de bancos de dados com critérios associados). Se a exibição na pasta ou no conjunto de pastas já tiver uma restrição correspondente, o Exchange usará a exibição existente para atender à solicitação do usuário. Se uma exibição não tiver uma restrição correspondente, o Exchange criará uma nova exibição. Criar uma exibição é mais dispendioso do que usar uma já existente.

Após alguns deslocamentos de caixas de correio, as restrições do cliente serão mais dispendiosas por um curto período de tempo. A operação move-mailbox faz com que um servidor reconstrua índices nas pastas. Portanto, quando os clientes exibirem as pastas pela primeira vez no novo servidor, todas as restrições deverão ser recriadas e, conseqüentemente, o desempenho poderá ser inadequado. Se você não deslocou caixas de correio recentemente, investigue o seguinte:

  • Outro aplicativo MAPI não está instalado nos computadores clientes. Geralmente, os suplementos do Microsoft Office Outlook® ou outros aplicativos MAPI podem acarretar a criação de um número excessivo de restrições.

  • As caixas de correio estão dimensionadas e os limites estão adequadamente definidos na organização inteira.

Para obter mais informações sobre tamanho de caixa de correio e números de itens, consulte o blog Equipe do Microsoft Exchange, "Limites recomendados de tamanho de caixa de correio" (http://go.microsoft.com/fwlink/?linkid=55097) (em inglês).

Altas operações RPC em massa

Exemplos de altas operações RPC em massa são mover, excluir ou definir propriedades (por exemplo, o sinalizador de leitura) em centenas ou milhares de itens em uma única operação. Esses tipos de operações podem degradar o desempenho no servidor durante algum tempo. Se você executar altas operações RPC em massa com freqüência, e ocorrer um afunilamento de disco ou do processador no servidor, o desempenho do Outlook para os outros usuários no mesmo servidor será afetado.

Para corrigir esse erro

  1. Verifique se os limites de caixa de correio estão definidos.

  2. Recomende aos usuários que arquivem itens em arquivos .pst.

    Observação:
    Como prática recomendada geral, as pastas usadas com freqüência devem conter menos de 5.000 itens.

Altas operações de sincronização RPC

As altas operações de sincromização RPC indicam que muitos usuários estão sincronizando itens, no momento. Conseqüentemente, a carga do servidor é aumentada.

Para corrigir esse erro

  • Verifique se você escalou os servidores Exchange de acordo com a quantidade de computadores clientes executando o Outlook no modo Cache do Exchange. Para obter mais informações, consulte Situações de implantação de RPC sobre HTTP do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47577).

  • Retardar as solicitações do cliente no modo Cache do Exchange pode ajudar a impedir que as altas operações de sincronização RPC se transformem em um problema de desempenho. Para obter mais informações, consulte o artigo 818484 da Base de Dados de Conhecimento da Microsoft, "Valores do Registro e contadores que você pode usar para configurar e monitorar a sincronização de clientes do Outlook" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=818484).

Alto número de operações online do cliente

Ocasionalmente, o Exchange pode enfrentar um pico incomum de problemas de desempenho causados por alta carga distribuída entre os usuários. Pode ser o resultado de um planejamento inadequado com a expansão de uma organização. Se você seguiu as práticas recomendadas da Microsoft ao escalar sua organização, mas ainda enfrenta desempenho inadequado, ocasionado por muitas operações online de clientes, isso pode ser um indício de que os usuários estão usando aplicativos MAPI de terceiros ou plug-ins do Outlook.

Operações de exibição do usuário

Os dados RPC do ExMon (Monitor de Usuários do Exchange Server) indicam que um usuário está criando novas exibições, o que está causando alta carga no servidor. Nesse cenário, um único usuário é responsável por uma porcentagem considerável de utilização da CPU com RPC.

Para investigar esse problema, considere as seguintes situações:

  • O usuário pode estar executando operações em uma pasta que contém muitos itens. Para corrigir este problema, aconselhe os usuários a reduzirem o número de itens contidos em uma única pasta. Como prática recomendada geral, as pastas devem conter menos de 2.000 itens.

  • O usuário pode estar executando um aplicativo criado inadequadamente, que está gerando uma carga excessiva. Para corrigir esse problema, remova o aplicativo.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre tamanho de caixa de correio e números de itens, consulte o blog Equipe do Microsoft Exchange, "Limites recomendados de tamanho de caixa de correio" (http://go.microsoft.com/fwlink/?linkid=55097) (em inglês).

  • Para obter mais informações sobre as restrições impostas às caixas de correio, consulte o blog da Equipe do Microsoft Exchange, "Colocando as restrições sobre restrições" (http://go.microsoft.com/fwlink/?LinkId=55098).

  • Para obter mais informações sobre o ExMon, consulte o site de download do ExMon (http://go.microsoft.com/fwlink/?LinkId=54983).


O IIS está criando processos de 32 bits em uma máquina de 64 bits
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-05-03

A ferramenta Microsoft Exchange Server Analyzer consulta a metabase do IIS (Serviços de Informações da Internet) em relação ao valor da propriedade de metabase w3svc/AppPools/Enable32BitAppOnWin64 em todos os servidores Windows Server 2003 Service Pack 1 (SP1) de 64 bits que estão sendo executados no Exchange Server 2007 para determinar se o IIS está configurado para criar processos de trabalho de 32 bits.

Um valor 1 (true) indica que o IIS está configurado para criar processos de trabalho de 32 bits. Um valor 0 (false) indica que o IIS está configurado para criar processos de trabalho de 64 bits.

Se o Exchange Analyzer determinar que o valor para a propriedade de metabase w3svc/AppPools/Enable32BitAppOnWin64 seja definida como 1 (true), o Exchange Analyzer exibirá um erro. Esse erro indica se o IIS está configurado para criar processos de trabalho de 32 bits em um servidor Windows de 64 bits que está executando o Exchange 2007. Essa configuração fará com que as funções dos diretórios virtuais do Exchange 2007 não sejam adequadas.

Para resolver esse erro, configure o IIS para criar processos de trabalho de 64 bits no servidor Windows Server 2003 (SP1) de 64 bits que está executando o Exchange 2007.

Para alternar o IIS para o modo de 64 bits

  1. Abra um prompt de comando.

  2. Digite o seguinte:

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. Pressione Enter

Para obter mais informações sobre a execução de processos de trabalho de 32 bits do IIS 6.0 no servidor Windows Server 2003 SP1 de 64 bits, consulte o artigo 895976 da Base de Dados de Conhecimento Microsoft, "O Windows Server 2003 SP1 permite compatibilidade WOW64 para aplicativos da Web de 32 bits no IIS 6.0" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=895976).


Aprimorar Memória do Kernel
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer testa os níveis de memória do sistema para verificar se estão em um intervalo aceitável. Se descobrir que um dos contadores de memória do kernel do Monitor de Desempenho (Perfmon) está abaixo dos níveis apropriados, o Exchange Server Analyzer exibirá uma mensagem de solução de problemas.

A memória do kernel do Microsoft Windows® consiste em várias estruturas de memória, incluindo reserva de memória paginável e não paginável e entradas de tabela de páginas do sistema. Essas estruturas de memória, também chamadas de memória do kernel, são usadas pelo sistema operacional para fornecer um ambiente para aplicativos como o Exchange. Para manter a integridade da implantação do Exchange, monitore a memória do kernel.

A otimização da memória do kernel pode ser uma tarefa complexa. Para obter informações detalhadas sobre o uso de memória do kernel, incluindo informações sobre solução de problemas, consulte Solucionando problemas de desempenho do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588). Para liberar recursos do servidor, examine a carga da caixa de correio de usuário no servidor. Mova as caixas de correio de usuário para outro servidor para reduzir a carga do servidor e observe se o problema foi solucionado. Para obter mais informações, consulte Mover Caixas de Correio de Usuário para Outro Servidor.

Para obter mais informações

Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como mover caixas de correio de usuários para reduzir a carga no servidor, consulte Mover Caixas de Correio de Usuário para Outro Servidor


Melhorar memória do usuário
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-28

A ferramenta Microsoft® Exchange Server Analyzer Tool determinou que os contadores de desempenho da memória do usuário estão acima do limite considerado ideal para o servidor Exchange. O Exchange Server Analyzer consulta o contador de desempenho Mbytes Disponíveis e o contador Páginas de Memória/s no objeto de desempenho Memória. Quando o servidor está com pouca memória ou alta paginação, ele indica um afunilamento de memória.

O contador de desempenhoMBytes Disponíveis mostra a quantidade de memória física em megabytes disponível de imediato para alocação a um processo ou para uso do sistema. A quantidade de memória disponível é igual à soma da memória atribuída às listas de página em espera (armazenadas em cache), livres e às listas sem nenhuma página.

O contador de desempenho Páginas de Memória/s indica a taxa na qual as páginas são lidas ou gravadas no disco para resolver falhas graves de página. À medida que o servidor usa memória e a memória livre se torna escassa, o sistema operacional começa a ajustar o conjunto de trabalho do processo e a usar o arquivo de página mais ativamente. O uso do arquivo de página afeta o desempenho geral porque as operações de disco levam mais tempo que as operações de memória. Esse contador é um indicador principal dos tipos de falhas que causam atrasos em todo o sistema. Ele inclui páginas recuperadas para atender às falhas de página no cache do sistema de arquivos. Essas páginas normalmente são solicitadas pelos aplicativos. Esse contador deve estar sempre abaixo de 1.000.

Se o Exchange Server Analyzer detectar que o contador de desempenho Mbytes Disponíveis indica que menos de 50 MB está disponível ou que a taxa na qual as páginas de memória estão sendo gravadas ou lidas no disco é superior a 1.000 páginas por segundo, o Exchange Server Analyzer exibirá um erro.

A lista a seguir descreve como você pode melhorar o desempenho da memória de espaço do usuário.

Para tratar esse problema

  1. Use a ferramenta Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=34705) para verificar se as configurações de memória do servidor estão definidas adequadamente.

  2. Remova software supérfluo. Para disponibilizar mais recursos de memória para o Exchange, remova todas as ferramentas de software de terceiros que executem funções de monitoramento ou todo tipo de serviço não essencial. O snap-in Desempenho (Perfmon.msc) pode ajudar você a saber a quantidade de memória que os aplicativos estão consumindo.

  3. Execute as tarefas de manutenção do servidor fora do horário de pico. A execução de ferramentas de manutenção (como Eseutil) ou de tarefas (como gerenciamento de caixa de correio) durante horários de pico pode consumir memória que seria usada pelo Exchange em outra circunstância. Como uma prática recomendada, execute essas ferramentas e tarefas durante horários que não sejam de pico ou durante períodos de pouco uso.

  4. tente mover as caixas de correio do usuário do servidor afetado para outro servidor para reduzir a carga do servidor. Para obter mais informações, consulte Mover Caixas de Correio de Usuário para Outro Servidor.

Para obter mais informações

Para obter mais informações, consulte os seguintes recursos Microsoft:

  • Mover Caixas de Correio de Usuário para Outro Servidor

  • Solucionando problemas de desempenho do Microsoft Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Otimizando o uso de memória no Exchange Server 2003" no Guia de Escalabilidade e Desempenho do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Ferramenta Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=34705) (página em inglês)

  • Artigo 815372 da Base de Dados de Conhecimento Microsoft, "Como otimizar o uso de memória no Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • "Alteração da configuração de memória do Exchange 2003 no Windows 2003 (suporte a PAE)" (http://go.microsoft.com/fwlink/?LinkId=54979) (página em inglês)

    Observação:
    O conteúdo de cada blog e sua URL estão sujeitos a alterações sem aviso.


Melhorar Memória Virtual
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool detectou problemas de fragmentação da memória virtual no servidor.

Em sistemas do Microsoft Windows® de 32 bits, há dois tipos de memória:

  • Memória física Quantidade de memória real instalada no sistema

  • Espaço de endereçamento da memória virtual Um espaço de memória virtualizada de 4 GB

Independentemente de quanta memória física esteja instalada no sistema, o tamanho total do espaço do endereço virtual é sempre o mesmo: 4 GB. Mesmo que isso não ocorra em todos os aplicativos de 32 bits, no Exchange Server, o espaço de endereçamento virtual é igual à memória virtual. Os termos são usados alternadamente.

No decorrer normal de suas operações, o armazenamento do Exchange alocará, usará e desalocará a memória virtual várias vezes. Quando a memória virtual é alocada, usada e desalocada freqüentemente, pode acontecer uma fragmentação de memória virtual. A fragmentação da memória virtual é análoga à fragmentação do sistema de arquivos que pode ocorrer com o passar do tempo. Depois de um tempo, segmentos alocados da memória virtual não estão mais contíguos e o desempenho começa a diminuir. No caso do sistema de arquivos, é possível executar um aplicativo que realize a desfragmentação do sistema de arquivos. Na maioria dos casos, é possível fazer a desfragmentação enquanto o sistema está online e sendo acessado. No caso da fragmentação da memória virtual, não há uma ferramenta de desfragmentação. Em vez disso, para corrigir o problema, é necessário parar e inicializar o serviço Armazenamento de Informações do Microsoft Exchange ou reinicializar o sistema.

A fragmentação da memória virtual pode ser causada por software de terceiros que estão sendo executados nos processos store/inetinfo. Verifique se você tem os drivers mais recentes dos aplicativos de terceiros. Se o problema se repetir depois da reinicialização, experimente desabilitar o software de terceiros ou mover caixas de correio do usuário para outro servidor para reduzir a carga e verificar se o problema é solucionado. Para obter mais informações, consulte Mover Caixas de Correio de Usuário para Outro Servidor.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre como solucionar problemas de framentação da memória virtual no Microsoft Exchange Server 2003 e Exchange 2000 Server, consulte o artigo 325044 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de fragmentação da memória virtual no Exchange Server 2003 e Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).

  • Para obter mais informações sobre como otimizar o uso da memória virtual, consulte o artigo 815372 da Base de Dados de Conhecimento, "Como otimizar o uso da memória no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

  • Para obter mais informações sobre como mover caixas de correio do usuário para reduzir a carga do servidor, consulte Mover Caixas de Correio de Usuário para Outro Servidor.


O Intelligent Message Filter não está instalado em um ou mais servidores que executam o Exchange Server 2003
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchExchangeServer de cada objeto do Exchange Server existente na organização. O Exchange Server Analyzer usa os resultados dessa consulta para determinar o número total de servidores na organização que estão executando o Exchange Server 2003. O Exchange Server Analyzer também consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para detectar se o Intelligent Message Filter do Microsoft Exchange está instalado em todos os servidores Exchange Server 2003 na organização. Se o Exchange Server Analyzer verificar que a Intelligent Message Filter não está instalada em um ou mais servidores que executam o Exchange Server 2003, o Exchange Server Analyzer exibirá uma mensagem de prática recomendada.

O Intelligent Message Filter identifica as mensagens que provavelmente serão emails comerciais não solicitados (UCE). Em uma topologia comum do Exchange Server 2003, o Intelligent Message Filter é instalado em servidores gateway para filtrar as mensagens de email recebidas da Internet. Se você usar um sistema de email não-Microsoft como servidor de gateway da Internet, instale o Intelligent Message Filter no servidor bridgehead do Exchange que aceita mensagens de email recebidas da Internet de servidores de gateway.

Para instalar o Intelligent Message Filter, use uma conta que tenha direitos administrativos locais e um membro de um grupo a quem foi atribuída a função de Administrador do Exchange.

Para obter mais informações, consulte "Exchange Intelligent Message Filter" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=21607).


A atualização do ISA Server 2000 está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_Datafile do Microsoft Windows® Management Instrumentation (WMI) para determinar a versão do arquivo smtpfltr.dll, utilizado pelo recurso Microsoft Internet Security and Acceleration (ISA) Server 2000 SMTP Message Screener. Se o Exchange Server Analyzer verificar que o valor do número da versão é maior que 2004, será exibido um aviso.

Esse aviso indica que uma versão mais recente do ISA Server 2000 está disponível. É recomendável instalar o ISA Server 2000 Service Pack 2. Fazer o upgrade ao Service Pack 2 é especialmente importante se você estiver executando o recurso SMTP Message Screener. As versões anteriores do SMTP Message Screener causam um afunilamento e, em seguida, degradam o desempenho geral de transferência de mensagens.

Para corrigir esse aviso

  1. Faça download do ISA Server 2000 Service Pack 2 a partir do Microsoft Download Center (http://go.microsoft.com/fwlink/?linkid=37592).

  2. Leia as Notas de Versão do Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=37584).

  3. Instale o Service Pack 2, utilizando as instruções nas Notas de Versão.

Para obter mais informações sobre os downloads do ISA Server, incluindo o ISA Server 2000 Service Pack 2, consulte "ISA Server 2000 Downloads" (http://go.microsoft.com/fwlink/?LinkId=18919).


O destinatário do diário não é válido
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-27

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor do atributo mailNickname do objeto de destinatário do registro no diário é válido. O apelido deve ser definido para que o atributo mailNickname seja válido. Se o atributo mailNickname do objeto de destinatário do diário indicado não for válido, as mensagens de registro no diário serão enfileiradas. Além disso, o mailNickname inválido pode indicar que o registro no diário foi configurado para copiar mensagens para um objeto de destinatário desabilitado para caixa de correio. Se descobrir que o valor do atributo mailNickname para o objeto de destinatário de registro no diário não é válido, o Exchange Server Analyzer exibirá um erro.

Para corrigir esse erro no Exchange Server 2003, use Usuários e Computadores do Active Directory e o Gerenciador do Sistema do Exchange para executar o seguinte, conforme for necessário:

  • Habilite o objeto de destinatário de diário para caixa de correio.

  • Indique uma nova caixa de correio de usuário como o destinatário do registro no diário.

Para corrigir esse erro no Exchange Server 2003, use Usuários e Computadores do Active Directory e o Gerenciador do Sistema do Exchange para executar o seguinte, conforme for necessário

Para habilitar o objeto de destinatário do diário para caixa de correio no Exchange Server 2003

  1. Abra Usuários e Computadores do Active Directory.

  2. Na árvore do console, expanda o domínio.

  3. Navegue até o contêiner pai do destinatário que você deseja modificar.

  4. No painel de detalhes, clique com o botão direito no destinatário que deseja modificar e selecione Tarefas do Exchange.

  5. No Assistente de Tarefas do Exchange, na caixa de diálogo Tarefas Disponíveis, selecione Criar Caixa de Correio e, em seguida, clique em Avançar.

  6. Na caixa de diálogo Criar Caixa de Correio, verifique as informações dos campos Alias, Armazenamento e Servidor de Caixa de Correio e, em seguida, clique em Avançar.

  7. Clique em Concluir para fechar o Assistente de Tarefas do Exchange.
Para indicar uma nova caixa de correio de usuário como o destinatário do Registro no diário no Exchange Server 2003

  1. Inicie o Gerenciador do Sistema Exchange.

  2. Expanda Servidores, <seu servidor Exchange>, <grupo de armazenamento>, clique com o botão direito no armazenamento de caixa de correio e selecione Propriedades.

  3. Clique em Procurar, à direita do texto Arquivar todas as mensagens enviadas ou recebidas pelas caixas de correio neste armazenamento, para especificar uma caixa de correio como a caixa de correio de diário.

    Observação:
    Todas as mensagens de diário para remetentes deste armazenamento de caixa de correio são enviadas para a caixa de correio que você especificar.

Para corrigir esse erro no Exchange Server 2007, use o Console de Gerenciamento do Exchange ou o Shell de Gerenciamento do Exchange para executar o seguinte, conforme for necessário:

  • Crie uma caixa de correio para o objeto de destinatário de diário.

  • Indique uma nova caixa de correio de usuário como o destinatário do Registro no diário.

Para habilitar o objeto de destinatário de diário para caixa de correio no Exchange Server 2007 usando o Console de Gerenciamento do Exchange

  1. No Console de Gerenciamento do Exchange, expanda Configuração do Destinatário, clique com o botão direito no objeto Caixa de Correio e selecione Nova Caixa de Correio para iniciar o Assistente de Nova Caixa de Correio.

  2. Na janela Introdução, selecione Caixa de Correio do Usuário e clique em Avançar.

  3. Na janela Tipo de Usuário, selecione Usuário existente e use o botão Procurar para selecionar o objeto de destinatário de diário para o qual criar uma caixa de correio.

  4. Na janela Configurações de Caixa de Correio, verifique as informações dos campos Alias, Servidor, Grupo de Armazenamento e Banco de Dados de Caixa de Correio e clique em Avançar.

  5. Na janela Nova Caixa de Correio, clique em Nova para criar a caixa de correio do objeto de destinatário de diário.

  6. Clique em Concluir para fechar o assistente de Nova Caixa de Correio
Para habilitar o objeto de destinatário de diário para caixa de correio no Exchange Server 2007 usando o Shell de Gerenciamento do Exchange

  1. Siga a orientação contida na documentação do produto Exchange Server 2007, "Habilitar caixa de correio" (http://go.microsoft.com/fwlink/?LinkID=80827)

Para indicar uma nova caixa de correio de usuário como o destinatário do Registro no diário no Exchange Server 2007

  1. No Console de Gerenciamento do Exchange, expanda Configuração do Servidor, <seu servidor Exchange>, <grupo de armazenamento>, clique com o botão direito no banco de dados de caixa de correio e selecione Propriedades.

  2. Na guia Geral, em Destinatário do Diário, clique em Procurar para especificar uma caixa de correio como a caixa de correio de Registro no diário.

Para obter mais informações sobre como implantar uma solução de Registro no diário com o Exchange Server 2003, consulte Registro no diário com Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47581).

Para obter mais informações sobre como implantar uma solução de Registro em diário com o Exchange Server 2007, consulte Visão geral do Registro no diário (em inglês) http://go.microsoft.com/fwlink/?LinkId=80820).


O destinatário do diário aponta para um objeto excluído
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-02-01

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o valor do atributo msExchMessageJournalRecipient contém a cadeia de caracteres DEL:. Esse atributo indica que o diário foi configurado para copiar mensagens em uma caixa de correio excluída. Para que o diário funcione corretamente, deve existir uma caixa de correio do destinatário do diário válida para onde as mensagens copiadas são enviadas. O atributo msExchMessageJournalRecipient é definido quando o diário está habilitado em um banco de dados de caixa de correio. Ele é um atributo do banco de dados de caixa de correio e contém o nome distinto da caixa de correio de diário.

Se a caixa de correio do destinatário do diário tiver sido excluída, as mensagens de diário começarão a ser colocadas na fila. Se o Exchange Server Analyzer detectar que o valor do atributo msExchMessageJournalRecipient contém a cadeia de caracteres DEL:, ele exibirá um erro.

Para corrigir esse erro, use o Gerenciador do Sistema do Exchange ou o Console de Gerenciamento do Exchange para indicar uma nova caixa de correio como o destinatário no Registro do diário.

Para indicar uma nova caixa de correio de usuário como o destinatário do Registro no diário no Exchange Server 2003

  1. Inicie o Gerenciador do Sistema Exchange.

  2. Expanda Servidores, expanda <seu servidor Exchange>, expanda <grupo de armazenamento> e clique com o botão direito no armazenamento de caixa de correio e selecione Propriedades.

  3. Clique em Procurar, à direita do texto Arquivar todas as mensagens enviadas ou recebidas pelas caixas de correio neste armazenamento, para especificar uma caixa de correio como a caixa de correio de diário.

    Observação:
    Todas as mensagens de diário para remetentes deste armazenamento de caixa de correio são enviadas para a caixa de correio que você especificar.
Para indicar uma nova caixa de correio de usuário como o destinatário do Registro no diário no Exchange Server 2007

  1. No Console de Gerenciamento do Exchange, expanda Configuração do Servidor, <seu servidor Exchange>, <grupo de armazenamento>, clique com o botão direito no banco de dados de caixa de correio e selecione Propriedades.

  2. Na guia Geral, em Destinatário do Diário, clique em Procurar para especificar uma caixa de correio como a caixa de correio de Registro no diário.

Para obter mais informações sobre como implantar uma solução de Registro em diário para o Exchange Server 2003, consulte Registro no diário com Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47581).

Para obter mais informações sobre como implantar uma solução de Registro em diário com o Exchange Server 2007, consulte Visão geral do Registro no diário (em inglês) http://go.microsoft.com/fwlink/?LinkId=80820).


O destinatário do diário aponta para uma conta desabilitada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o valor do atributo msExchUserAccountControl no objeto de destinatário do registro no diário está definido para indicar uma conta de usuário desabilitada. Se o valor do atributo msExchUserAccountControl do objeto de destinatário do registro no diário for 2, isso significa que o registro no diário foi configurado para copiar as mensagens de registro no diário para uma conta de usuário desabilitada. Essa configuração faz com que as mensagens de registro no diário sejam colocadas na fila ou enviadas para a pasta Mensagens Inválidas. Se o Exchange Server Analyzer detectar que o valor do atributo msExchUserAccountControl do destinatário do registro no diário está definido para indicar uma conta de usuário desabilitada do destinatário de registro no diário, o Exchange Server Analyzer exibirá um erro.

Para corrigir esse erro no Exchange Server 2003, use Usuários e Computadores do Active Directory e o Gerenciador do Sistema do Exchange para executar o seguinte, conforme for necessário:

  • Habilite a conta do usuário do destinatário de registro no diário atual.

  • Indique uma nova caixa de correio de usuário como o destinatário do registro no diário.

Para habilitar a conta de destinatário do diário no Exchange Server 2003

  1. Abra Usuários e Computadores do Active Directory.

  2. Na árvore do console, expanda o domínio.

  3. Navegue até o contêiner pai do destinatário do diárioque você deseja modificar.

  4. No painel de detalhes, clique com o botão direito no destinatário a ser modificado e selecione Habilitar Conta.
Para indicar uma nova caixa de correio de usuário como o destinatário do registro no diário no Exchange Server 2003

  1. Inicie o Gerenciador do Sistema Exchange.

  2. Expanda Servidores, <seu servidor Exchange>, <grupo de armazenamento>, clique com o botão direito no armazenamento de caixa de correio e selecione Propriedades.

  3. Clique em Procurar, à direita do texto Arquivar todas as mensagens enviadas ou recebidas pelas caixas de correio neste armazenamento, para especificar uma caixa de correio como a caixa de correio de registro no diário.

    Observação:
    Todas as mensagens de diário para remetentes deste armazenamento de caixa de correio são enviadas para a caixa de correio que você especificar.

Para corrigir esse erro no Exchange Server 2007, use o Console de Gerenciamento do Exchange ou o Shell de Gerenciamento do Exchange para executar o seguinte, conforme for necessário:

  • Crie uma caixa de correio para o objeto de destinatário de diário.

  • Indique uma nova caixa de correio de usuário como o destinatário do registro no diário.

Para habilitar o objeto de destinatário de diário para caixa de correio no Exchange Server 2007 usando o Console de Gerenciamento do Exchange

  1. No Console de Gerenciamento do Exchange, expanda Configuração do Destinatário, clique com o botão direito no objeto Caixa de Correio e selecione Nova Caixa de Correio para iniciar o Assistente de Nova Caixa de Correio.

  2. Na janela Introdução, selecione Caixa de Correio do Usuário e clique em Avançar.

  3. Na janela Tipo de Usuário, selecione Usuário existente e use o botão Procurar para selecionar o objeto do destinatário do diário para criar a caixa de correio.

  4. Na janela Configurações de Caixa de Correio, verifique as informações dos campos Alias, Servidor, Grupo de Armazenamento e Banco de Dados de Caixa de Correio e clique em Avançar.

  5. Na janela Nova Caixa de Correio, clique em Nova para criar a caixa de correio do objeto de destinatário de diário.

  6. Clique em Concluir para fechar o assistente de Nova Caixa de Correio
Para habilitar o objeto de destinatário de diário para caixa de correio no Exchange Server 2007 usando o Shell de Gerenciamento do Exchange

  1. Siga as orientações contidas na documentação do produto do Exchange Server 2007, "Habilitar caixa de correio" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80827).

Para indicar uma nova caixa de correio de usuário como o destinatário do registro no diário no Exchange Server 2007

  1. No Console de Gerenciamento do Exchange, expanda Configuração do Servidor, <seu servidor Exchange>, <grupo de armazenamento>, clique com o botão direito no banco de dados de caixa de correio e selecione Propriedades.

  2. Na guia Geral, em Destinatário do Diário, clique em Procurar para especificar uma caixa de correio como a caixa de correio de registro no diário.

Para obter mais informações sobre como implantar uma solução de registro em diário com o Exchange Server 2003, consulte Registro no Diário com o Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47581).

Para obter mais informações sobre como implantar uma solução de diário com o Exchange Server 2007, consulte Visão Geral do Registro em Diário (em inglês) http://go.microsoft.com/fwlink/?LinkId=80820).


O destinatário do diário aponta para o servidor local
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor do atributo msExchHomeServerName no objeto de destinatário do diário para um armazenamento de caixa de correio corresponde ao valor do atributo legacyExchangeDN do servidor local. Se os valores desses atributos coincidirem, isso indicará que mensagens de diário são copiadas em uma caixa de correio no servidor que tem o diário ativo em execução. Como pode ser gerado um alto volume de tráfego de diário, é recomendável que a caixa de correio do destinatário do diário resida em um servidor de diário dedicado.

Se o Exchange Server Analyzer verificar que os valores do atributo msExchHomeServerName do objeto de destinatário do diário correspondem ao valor de legacyExchangeDN do servidor local, o Exchange Server Analyzer exibirá uma mensagem de prática recomendada.

Para obter mais informações sobre como implantar uma solução de registro no diário com o Exchange Server 2003, consulte Registro no diário com Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47581).

Para obter mais informações sobre como implantar uma solução de registro no diário com o Exchange Server 2007, consulte Visão geral do registro no diário (em inglês) http://go.microsoft.com/fwlink/?LinkId=80820).


O destinatário do diário deve ser ocultado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor do atributo msExchHideFromAddressLists do objeto de destinatário do diário está definido como True. Um valor diferente de True nesse atributo indica que o destinatário do diário no armazenamento de caixa de correio não está oculto nas listas de endereços do Exchange Server e pode se tornar o destinatário de mensagens não relacionadas ao diário. Se o Exchange Server Analyzer verificar que o valor do atributo msExchHideFromAddressLists do objeto de destinatário do diário não estiver definido com True, o Exchange Server Analyzer exibirá uma mensagem de prática recomendada.

Para resolver esse problema no Exchange Server 2003, use a ferramenta Usuários e Computadores do Active Directory para ocultar a caixa de correio do destinatário do registro no diário das listas de endereços do Exchange Server.

Para resolver esse problema no Exchange Server 2007, use o Console de Gerenciamento do Exchange para ocultar a caixa de correio do destinatário do registro no diário das listas de endereços do Exchange Server.

Para ocultar a caixa de correio do destinatário do diário indicado das listas de endereços do Exchange Server com o Exchange Server 2003

  1. Abra Usuários e Computadores do Active Directory.

  2. Na árvore do console, expanda o domínio.

  3. Navegue até o contêiner pai do destinatário que você deseja modificar.

  4. No painel de detalhes, clique duas vezes no destinatário que você deseja modificar.

  5. Na guia Avançado do Exchange, marque a caixa de seleção Ocultar das listas de endereços do Exchange.

  6. Clique em OK.
Para ocultar a caixa de correio do destinatário do diário indicado das listas de endereços do Exchange Server com o Exchange Server 2007

  1. Abra o Console de Gerenciamento do Exchange

  2. Na árvore do console, navegue até o contêiner pai do destinatário que você deseja modificar.

  3. No painel de detalhes, clique duas vezes no objeto de caixa de correio do destinatário designado do registro no diário para exibir suas propriedades.

  4. Na guia Geral, marque a caixa de seleção Ocultar das listas de endereços do Exchange.

  5. Clique em OK.

Para obter mais informações sobre como implantar uma solução de registro em diário com o Exchange Server 2003, consulte Registro no Diário com o Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47581).

Para obter mais informações sobre como implantar uma solução de registro em diário com o Exchange Server 2007, consulte Visão Geral do Registro no Diário (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80820).


Junk store threshold not configured
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-07-30

A ferramenta Microsoft Exchange Analyzer Tool consulta o ambiente do Exchange para detectar a presença das funções de servidor Caixa de Correio ou Transporte de Hub do Exchange Server 2007.

Caso a função de servidor Caixa de Correio ou Transporte de Hub do Exchange Server 2007 seja encontrada, o Exchange Analyzer executará o seguinte cmdlet do Shell de Gerenciamento do Exchange para consultar o valor do parâmetro SCLJunkThreshold na organização do Exchange.

Get-OrganizationConfig

O parâmetro SCLJunkThreshold em uma organização epecifica o SCL (nível de confiança de spam) em que uma mensagem é movida para a pasta Lixo Eletrônico.

Caso o Exchange Analyzer determine que o parâmetro SCLJunkThreshold em uma organização está definido como o valor padrão 8, um aviso será exibido.

Esse aviso indica que o limite do nível de confiança de spam para mover mensagens para a pasta Lixo Eletrônico está definido de modo que as mensagens de usuários legítimos possam ser filtradas e movidas para a pasta Lixo Eletrônico como se fossem classificadas como tal. O valor recomendado do parâmetro SCLJunkThreshold é 4.

Para solucionar o aviso, use o cmdlet Set-OrganizationConfig do Shell de Gerenciamento do Exchange para definir o valor do parâmetro SCLJunkThreshold como 4.

Para definir o valor do parâmetro SCLJunkThreshold como 4 usando o cmdlet Set-OrganizationConfig

  1. O código a seguir é um exemplo do comando Set-OrganizationConfig que define o valor do parâmetro SCLJunkThreshold como 4.

  2. Set-OrganizationConfig -SCLJunkThreshold 4


Degradação da memória do kernel
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-02-15

A ferramenta Microsoft Exchange Analyzer Tool consulta a classe Win32_NTLogEvent de WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar se um erro Evento 2000, Evento 2019 ou Evento 2020 foi registrado na origem do SRV (servidor) ou do NCP Server nas últimas 24 horas.

  • Um ID do Evento 2000 do SRV (servidor) indica que uma chamada do servidor para um serviço do sistema falhou inesperadamente devido a uma redução geral da memória kernel do sistema.

  • Um ID do Evento 2019 do SRV indica uma redução da memória pool não paginada do sistema.

  • Um ID do evento 2020 do SRV indica uma redução da memória pool paginada do sistema.

Se o Exchange Analyzer detectar que um ou mais desses eventos foram registrados nas últimas 24 horas, ele exibirá um erro.

Esse aviso indica que a memória kernel do servidor foi reduzida e o servidor pode estar tendo problemas de desempenho.

A memória kernel do Microsoft Windows consiste em várias estruturas de memória, incluindo memória pool paginada e não paginada e as entradas da tabela de páginas do sistema. Essas estruturas de memória, também conhecidas como memória kernel, são usadas pelo sistema operacional para fornecer um ambiente para aplicativos como o Exchange.

Para tratar esse problema, siga a orientação dos artigos do Exchange Analyzer específicos do problema listados a seguir:

  • Aprimorar Memória do Kernel

  • O pool paginado está acima do limite de aviso

  • Pool Não Paginado está acima do limite de aviso

  • Pool Não Paginado está acima do limite de erro

Em geral, para manter uma implantação íntegra do Exchange, monitore regularmente a memória kernel do Exchange Server.

Para obter mais informações

Para obter mais informações sobre os Eventos 2000, 2019 e 2020 do SRV, consulte o "Events and Errors Message Center: detalhes do evento"

  • ID do Evento 2000 do SRV (em inglês) http://go.microsoft.com/fwlink/?LinkId=83250

  • ID do Evento 2019 do SRV (em inglês) http://go.microsoft.com/fwlink/?LinkId=83251

  • ID do Evento 2020 do SRV (em inglês) http://go.microsoft.com/fwlink/?LinkId=83252

Para obter mais informações sobre como otimizar a memória no Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 912376, "Como monitorar e o uso de memória pool paginada em Exchange Server 2003 e Exchange 2000 Server - solucionar problemas" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 894067, "A ferramenta Desempenho não mostra com precisão as Entradas livres da tabela de paginação do sistema disponíveis no Windows Server 2003" http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 311901, "Os efeitos do ajuste do 4GT nas entradas da tabela de paginação do sistema" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901).

  • 912376, "Como monitor e o uso de memória pool paginada em Exchange Server 2003 ou Exchange 2000 Server - solucionar problemas" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376)


Degradação de Recursos do Kernel: Atualização de serviço de cópias de sombra de volume
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar se o arquivo Vssvc.exe existe.

No Registro, o Exchange Server Analyzer faz uma consulta para determinar se o serviço VSS (Serviço de Cópias de Sombra de Volume) ou o serviço VDS (serviço de Disco Virtual) está em execução no Windows Server:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS

Além disso, o Microsoft® Exchange Server Analyzer lê o valor do Registro a seguir para determinar a versão do sistema operacional Microsoft Windows® em execução no servidor Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se o valor de CurrentVersion for 5.0, o servidor do Exchange estará em execução no Microsoft Windows 2000 Server. Se o valor de CurrentVersion for 5.2, o servidor do Exchange estará em execução no Microsoft Windows Server™ 2003.

Finalmente, o Exchange Server Analyzer consulta a classe Win32_OperatingSystem do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave ServicePackMajorVersion. O valor da chave ServicePackMajorVersion indica qual service pack do Windows está instalado no computador.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O Exchange Server está instalado no Windows Server 2003 Service Pack 1 (SP1).

  • O Serviço de Cópias de Sombra de Volume ou o serviço de Disco Virtual está em execução no Windows Server 2003 SP 1.

  • A atualização do VSS não está instalada nesta configuração do Exchange Server.

Se você aplicar a atualização do VSS, problemas como a degradação de recursos do kernel serão resolvidos.

Para corrigir o erro

  • Aplique a atualização do VSS, cujo download pode ser feito a partir do artigo 891957 da Base de Dados de Conhecimento Microsoft, "Uma atualização que corrige diversos problemas do Serviço de cópias de sombra de volume no Windows Server 2003 está disponível" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=891957).

Para obter mais informações sobre as práticas recomendadas para o uso do VSS com o Exchange Server 2003, consulte Práticas Recomendadas para uso do Serviço de Cópias de Volume de Sombra com o Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=56571).


O LeakDiag está instalado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar se LeakDiag.exe está instalado no computador:

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag

Se o Exchange Server Analyzer verificar a presença dessa ramificação do Registro, será exibida uma mensagem de configuração não padrão.

O LeakDiag é um conjunto de ferramentas que ajuda os desenvolvedores, dá suporte a profissionais e à equipe de TI (tecnologia da informação) diagnosticando vazamentos de memória, fragmentação e outros problemas relacionados à memória em aplicativos ou serviços que estão em computadores executando o Microsoft Windows NT® Server 4.0, Windows® 2000 Server, Windows XP e Windows Server™ 2003.

As ferramentas do LeakDiag podem ser usadas para indicar vazamentos de memória na linha de código. Usando a tecnologia Detours da Microsoft, LeakDiag intercepta chamadas para alocações de memória especificadas e controla as várias pilhas de chamada. Ele relata a memória que foi alocada, mas ainda não foi liberada. Essa informação nos permite solucionar um problema de vazamentos de memória para ver exatamente quais componentes fizeram as alocações. Com os símbolos de depuração corretos, até mesmo a linha de código que solicitou as alocações pode ser vista.

É recomendável que você não execute o LeakDiag em servidores Exchange que estão em um ambiente de produção. Quando habilitado, o LeakDiag controlará todas as alocações de memória de todos os processos cada vez que o servidor Exchange for iniciado. Isso consumirá uma grande quantidade de recursos do processador e da memória e não é recomendado a menos que você esteja solucionando ativamente um problema relacionado à memória. Se você não estiver solucionando ativamente um problema relacionado à memória, deverá desativar o LeakDiag. A execução do LeakDiag em um ambiente de produção do Exchange Server pode levar à fragmentação e esvaziamento da memória e, por último, à falha do Exchange.

Observação:
Você sempre deve solucionar problemas com o LeakDiag nas horas que não sejam de pico. O uso do LeakDiag durante os períodos de pico e o uso intenso podem causar uma redução significativa do desempenho do computador do Exchange Server.

Informações sobre essa mensagem

  1. Essa mensagem tem uma finalidade apenas informativa. Desde que LeakDiag não esteja habilitado e em execução, só o fato de estar instalado não afeta o desempenho do Exchange Server. O LeakDiag exige quase 4 MB (megabytes) de espaço em disco (não incluindo logs).

  2. Para liberar esse espaço em disco, você pode remover LeakDiag.exe acessando o Painel de Controle, clicando em Adicionar/Remover Programas, em LeakDiag e Remover.

Para obter a versão mais recente do LeakDiag, consulte o site FTP público da Microsoft (http://go.microsoft.com/fwlink/?LinkId=41401).


O LeakDiag está habilitado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a entrada do Registro a seguir para determinar se LeakDiag.exe está habilitado no computador:

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag\EnableAutoStart

Se o Exchange Server Analyzer perceber que o valor para EnableAutoStart está definido como 1, um aviso será exibido. O EnableAutoStart é configurado usando a interface de usuário do LeakDiag. O valor padrão é 0. Um valor 1 indica que o LeakDiag está habilitado e ativo.

O LeakDiag é um conjunto de ferramentas que ajuda os desenvolvedores, dá suporte a profissionais e à equipe de TI (tecnologia da informação) diagnosticando vazamentos de memória, fragmentação e outros problemas relacionados à memória em aplicativos ou serviços que estão em computadores executando o Microsoft Windows NT® Server 4.0, Windows® 2000 Server, Windows XP e Windows Server™ 2003.

As ferramentas do LeakDiag podem ser usadas para indicar vazamentos de memória na linha de código. Com a tecnologia Detours da Microsoft, o LeakDiag intercepta chamadas para as alocações de memória especificadas e controla as diversas pilhas de chamadas. Ele relata a memória que foi alocada, mas ainda não foi liberada. Estas informações permitem que uma pessoa que estejam solucionando um problema de perda de memória veja exatamente quais componentes fizeram as alocações. Com os símbolos de depuração corretos, até mesmo a linha de código que solicitou as alocações pode ser vista.

É recomendável que você não execute o LeakDiag em servidores Exchange que estão em um ambiente de produção. Quando habilitado, o LeakDiag controlará todas as alocações de memória de todos os processos cada vez que o servidor Exchange for iniciado. Isso consumirá uma grande quantidade de recursos do processador e da memória e não é recomendado a menos que você esteja solucionando ativamente um problema relacionado à memória. Se você não estiver solucionando ativamente um problema relacionado à memória, deverá desativar o LeakDiag. A execução do LeakDiag em um ambiente de produção do Exchange Server pode levar à fragmentação e esvaziamento da memória e, por último, à falha do Exchange.

Observação:
Você sempre deve solucionar problemas com o LeakDiag nas horas que não sejam de pico. O uso do LeakDiag durante os períodos de pico e o uso intenso podem causar uma redução significativa do desempenho do computador do Exchange Server.

Para desativar o recurso Início Automático no LeakDiag.exe

  1. Clique em Iniciar e em LeakDiag.

  2. No menu Ferramentas, clique em Opções.

  3. Na página Opções, desmarque a caixa de seleção Permitir Início Automático e clique em OK.

Para obter a versão mais recente do LeakDiag, consulte o site FTP público da Microsoft (http://go.microsoft.com/fwlink/?LinkId=41401).


Menos de Sete Dias de Espaço em Log Restante
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-13

A ferramenta Analisador do Microsoft Exchange Server estima o tempo restante antes que o espaço da unidade de log de transações em um grupo de armazenamento do Exchange Server seja completado. O Analisador do Exchange Server estima o tempo para que a unidade de log alcance sua capacidade verificando os carimbos de hora nos arquivos de log de transações na unidade. Quando o Analisador do Exchange Server detectar que restam menos de sete dias para que a unidade de log fique cheia, exibirá um erro.

A unidade que hospeda os arquivos de log dos bancos de dados do Exchange Server está ficando sem espaço em disco.

Quando a unidade de log ficar sem espaço em disco, os seguintes problemas poderão ocorrer:

  • O banco de dados não iniciará ou será encerrado.

  • O banco de dados fará um desligamento anormal e se tornará inconsistente.

  • Os usuários não conseguirão acessar as pastas públicas e/ou de emails.

O espaço da unidade de log poderá ficar cheio, pois o log circular está desativado. Portanto, os arquivos de log de transações são deixados na unidade até que um backup completo ou incremental online que usa backup sensível ao Exchange Server seja executado.

Nas versões do Exchange Server anteriores ao Exchange 2003, os bancos de dados não conseguem alcançar o estado Desligamento Normal antes de pararem. Dois arquivos de log de transações de reserva, Res1.log e Res2.log, são convertidos em logs de transações comuns em uma emergência de espaço em disco.

No Exchange Server 2003, as otimizações foram implementadas para que os bancos de dados possam ser desligados normalmente até que os arquivos de log de reserva sejam esgotados. Quando um banco de dados não for desligado normalmente, é muito importante que vários logs de transações mais recentes associados ao banco de dados não sejam excluídos. Esses logs de transações ainda contêm informações que devem ser aplicadas ao banco de dados para restaurar sua consistência. Se você excluir esses arquivos de log, o banco de dados não poderá ser iniciado novamente até que você o tenha reparado ou restaurado.

Se todos os bancos de dados em um grupo de armazenamento estiverem em um estado Desligamento Normal, a remoção de todos os logs de transações não impedirá os bancos de dados de iniciar. Entretanto, se você remover os logs de transações, isso invalidará os backups anteriores. Essa remoção não significa que os backups anteriores não possam ser restaurados. Nem que você não conseguirá rolar o banco de dados restaurado para a frente passando o ponto no qual os arquivos de log foram excluídos.

O assistente de espaço de log do Analisador do Exchange Server analisará os arquivos de log de transações existentes e ajudará a mover aqueles que não são mais necessários no banco de dados. O assistente de espaço de log garantirá também que mesmo que todos os bancos de dados estejam em um estado Desligamento Normal, o arquivo de log atual não será removido. Se o arquivo de log atual não for removido, os backups anteriores permanecerão válidos.

Para conseguir mais espaço na unidade de log, você deverá remover os arquivos de log desnecessários. As ações a seguir são recomendadas.

Para obter espaço na unidade de log quando esse espaço estiver cheio ou se aproximando da capacidade máxima

  • Faça um backup de streaming online sensível ao Exchange ou um backup VSS (Serviço de Cópias de Sombra de Volume) do banco de dados. Para obter mais informações sobre backup VSS, consulte "Práticas recomendadas para usar o serviço de cópias de volume de sombra com o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=56571).

    Observação:
    O método preferido para limpar arquivos de log desnecessários é fazer um backup de streaming online ou um backup VSS.

  • Se o banco de dados desligar porque está prestes a ficar sem espaço em disco, você poderá usar o assistente de gerenciamento de espaço em log do Analisador do Exchange Server. Você pode usar o assistente para mover os arquivos de log em excesso. Como alternativa, você pode mover manualmente os arquivos de log em excesso antes de remontar o banco de dados.

    Para remover os arquivos de log manualmente, siga os procedimentos e recomendações do artigo 240145 da Base de Dados de Conhecimento da Microsoft, "Como remover os arquivos de log de transações do Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240145).


O LegacyExchangeDN desse servidor Exchange não corresponde ao grupo administrativo pai
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para verificar o valor legacyExchangeDN de um servidor, verificando os atributos do objeto do servidor no contêiner Servidores do Active Directory, comparando-o ao nome real do grupo administrativo e da organização em que o servidor reside. Se o valor legacyExchangeDN do Exchange Server for diferente do grupo administrativo ou da organização, será exibido um erro.

O Exchange usa o valor de legacyExchangeDN para identificar objetos do Exchange no Active Directory. O valor de legacyExchangeDN é um nome distinto, que indica onde o objeto se enquadra na organização do Exchange, por exemplo:

/o= organização /ou= grupo administrativo /ou= servidor

Objetos como armazenamentos de caixa de correio e de pastas públicas herdam parte de seus valores legacyExchangeDN do servidor. Isso significa que, se houver um problema com o valor do servidor, outros objetos podem herdar o mesmo problema.

Geralmente, problemas com o legacyExchangeDN ocorrem quando um administrador tenta modificar o valor diretamente. Você deve corrigir o valor, usando uma feramenta como ADSI (Interfaces do Serviço Active Directory) Edit, a ferramente LDP (ldp.exe) ou qualquer outro cliente do protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, Exchange Server 2003 ou Exchange Server 2007, ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro

  1. No ADSI Edit ou em uma ferramenta semelhante, localize o objeto grupo administrativo no Active Directory.

    É possível encontrar o atributo legacyExchangeDN em:

    CN=Configuração,CN=Serviços,CN=Microsoft Exchange,CN=Organização,CN=Grupos Administrativos, CN=Grupo administrativo,CN=Servidores,CN=servidor

  2. Digite um novo valor de cadeia de caracteres do formulário:

    /o= organização /ou= grupo administrativo /ou= servidor

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o utilitário LDP para modificar os atributos de objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como funciona o ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda do Windows Server 2003.


O atributo LegacyExchangeDN deste servidor Exchange é inválido
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para verificar o valor legacyExchangeDN do servidor Exchange. Esse erro será exibido se a organização ou grupo administrativo nomeado no valor de legacyExchangeDN não corresponder ao nome real da organização ou grupo administrativo, ou se estiver faltando integralmente uma parte do valor.

O Exchange usa o valor de legacyExchangeDN para identificar objetos do Exchange no Active Directory. O valor de legacyExchangeDN é um nome distinto, que indica onde o objeto se enquadra na organização do Exchange, por exemplo:

/o= organização /ou= grupo administrativo

Objetos como servidores e hierarquias de pastas herdam parte dos respectivos valores de legacyExchangeDN do grupo administrativo. Isso significa que se ocorrer um problema no valor do grupo administrativo, vários outros objetos poderão herdar o mesmo problema.

Normalmente, problemas com o legacyExchangeDN surgem quando um administrador tenta modificar o valor diretamente. Você deve corrigir o valor usando uma ferramenta como ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe) ou qualquer outro cliente do protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou do Exchange Server 2007, ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro

  1. No ADSI Edit ou em uma ferramenta semelhante, localize o objeto grupo administrativo no Active Directory.

    É possível encontrar o atributo legacyExchangeDN em:

    CN=Configuração,CN=Serviços,CN=Microsoft Exchange,CN=Organização,CN=Grupos Administrativos, CN=Grupo administrativo

  2. Digite um novo valor de cadeia de caracteres do formulário:

    /o= organização /ou= grupo administrativo

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como funciona o ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda do Windows Server 2003.


O serviço de log de licença está definido como Automático
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar o valor da chave Started para o serviço Log de Licença (LicenseService). Um valor Falso indica que o serviço Log de Licença não está sendo executado nesse servidor Exchange. Um valor Verdadeiro indica que o serviço de Log de Licença está sendo executado.

O Analisador do Exchange Server também consulta a classe WMI Exchange_Server no namespace root\MicrosoftExchangeV2 para determinar o valor da chave IsFrontEndServer. Um valor Falso indica que o computador do Exchange Server não é um servidor front-end. Um valor Verdadeiro indica que o computador do Exchange Server é um servidor front-end.

O Exchange Server Analyzer também consulta a classe Win32_OperatingSystem do WMI para determinar o valor da chave OSProductSuite. O valor retornado para essa chave indica a versão do sistema operacional Windows executado no computador do Exchange Server.

Além disso, o Exchange Server Analyzer também consulta o serviço de diretório Active Directory® para determinar a contagem das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Se o Analisador do Exchange Server determinar que o serviço Log de Licença foi iniciado em um computador do Exchange Server que satisfaça todos os critérios a seguir, um aviso será exibido:

  • O computador do Exchange Server não é um servidor front-end.

  • O computador do Exchange Server hospeda mais de 20 caixas de correio.

  • O computador do Exchange Server não está sendo executado no Microsoft Windows Small Business Server 2003 ou no Small Business Server 2000.

O serviço Log de Licença é uma ferramenta que foi originalmente desenvolvida para ajudar os clientes a gerenciarem licenças para produtos do servidor Microsoft licenciadas no modelo CAL (Licença de Acesso para Cliente do Servidor).

Por padrão, o serviço Log de Licença está desabilitado no Microsoft Windows Server™ 2003. Devido a restrições no design original e aos termos e condições de licença em desenvolvimento, o serviço Log de Licenção não pode fornecer uma visão precisa do número total de CALs compradas comparado com o número total de CALs usadas em um único servidor ou em toda a empresa. As CALs informadas no serviço Log de Licença podem estar em conflito com a interpretação do EULA (Acordo de Licença de Usuário Final) e do PUR (Direitos de Uso de Produtos). O serviço Log de Licença não estará incluído em versões futuras do sistema operacional Windows.

A Microsoft tem requisitos e recomendações específicos para o uso do serviço Log de Licença em computadores do Exchange Server:

  • Em servidores Exchange front-end que usam SSL (Secure Sockets Layer), você deve habilitar e iniciar o serviço Log de Licença. Se o serviço Log de Licença não estiver sendo executado, o IIS (Serviços de Informações da Internet) limitará em 10 o número de conexões SSL autenticadas simultâneas.

  • Em servidores Exchange back-end, recomenda-se que o serviço Log de Licença seja parado e definido como Desabilitado.

  • Em servidores Exchange agrupados, recomenda-se que o serviço Log de Licença seja parado e definido como Desabilitado.

  • Em servidores Exchange que estejam executando o Microsoft Windows Small Business Server 2003 ou o Small Business Server 2000, o serviço Log de Licença é necessário somente quando mais de 10 conexões SSL autenticadas são necessárias.

Para definir o estado do serviço Log de Licença

  1. Inicie o snap-in Serviços no menu Ferramentas Administrativas.

  2. Localize e clique duas vezes em Serviço Log de Licença.

  3. Na lista suspensa Tipo de inicialização, selecione a opção apropriada:

    • Defina o serviço como Automático nos servidores Exchange front-end que usam SSL.

    • Defina o serviço como Desabilitado em servidores Exchange back-end e servidores Exchange agrupados.

  4. Se você estiver desabilitando o serviço Log de Licença, clique também em Parar para parar o serviço.

  5. Clique em OK para salvar as alterações e fechar o snap-in Serviços.

Para obter mais informações sobre o Serviço Log de Licença, consulte os artigos da Base de Dados de Conhecimento da Microsoft:

  • 824196, "Descrição do serviço Log de Licença em sistemas operacionais Windows Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=824196)

  • 316631, "Como desativar o serviço Log de Licença" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316631)


Nome de Arquivo de Log não corresponde a Número de Geração de Log
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-07

A ferramenta Microsoft® Exchange Server Analyzer compara o valor do número de geração interna lGeneration do cabeçalho do arquivo de log de transações ao nome do arquivo de log de transações para determinar se correspondem.

Se o número de geração interna do arquivo de log de transações não corresponder à representação do número de geração interna do nome do arquivo de log de transações, o Exchange Server Analyzer exibirá um erro.

Se um arquivo de log não for o log atual, o arquivo de log mais recente disponível precisará ter um nome que corresponda a seu número de geração. Se um arquivo de log for o log atual, seu nome não poderá conter o número de geração, mas apenas o prefixo de log do grupo de armazenamento. Por exemplo, logs de transações anteriores em série podem ser denominados E0154321.LOG, E0154322.LOG, E0154323.LOG, e assim por diante, sendo o log atual denominado E01.LOG.

Use o comando Eseutil /ML LOGFILE para exibir o valor interno de lGeneration para um arquivo de log.

Para obter mais informações sobre logs de transações do Exchange Server, consulte "Logs de transações do Exchange no Exchange Server 2003" em Usando grupos de armazenamento de recuperação no Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589) (em inglês).


Incompatibilidade de Assinatura de Seqüência de Log
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-07

A ferramenta Microsoft® Exchange Server Analyzer Tool compara o valor de uma Signature do arquivo de log em relação ao valor de uma Signature do arquivo de log subseqüente, para determinar se correspondem.

Se o valor de uma Signature do arquivo de log não corresponder ao valor de uma Signature do arquivo de log subseqüente, o Exchange Server Analyzer exibirá um erro.

O Exchange usa uma série de arquivos de log, cada um com exatamente cinco megabytes, em vez de gravar todas as informações de log em um único arquivo grande. Quando um arquivo de log estiver cheio, o Exchange fechará e o renomeará com um número de seqüência.

Quando uma nova seqüência de arquivos de log de transações de um grupo de armazenamento do Exchange for inicializada, uma Signature será gravada no primeiro arquivo de log e copiado em todos os arquivos de log subseqüentes. A Signature identifica exclusivamente um arquivo de log particular como um membro de uma seqüência de log particular.

Nunca há um caso em que os arquivos de log que possuem assinaturas diferentes deveriam ser encontrados nas mesmas pastas. Se isso ocorrer, indica que os arquivos de log externos foram copiados no grupo de armazenamento ou que os arquivos de log foram reconfigurados sem antes excluir todos os arquivos de log anteriores.

Você pode usar o comando Eseutil /ML LOGFILE para exibir o valor de Signature para um arquivo de log.

Para obter mais informações sobre logs de transações do Exchange Server, consulte "Logs de transações do Exchange no Exchange Server 2003" em Usando grupos de armazenamento de recuperação no Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589) (em inglês).


Problema de Assinatura de Log
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-07

A ferramenta Analisador do Microsoft® Exchange Server compara a assinatura no cabeçalho do arquivo de log de transações atual do Exchange em um servidor com a assinatura do log no arquivo de banco de dados do grupo de armazenamento.

Se a assinatura do arquivo de log de transações não corresponder à assinatura do log em algum dos arquivos de banco de dados, a ferramenta exibirá um erro.

Esse processo indica que uma das condições a seguir é verdadeira:

  • O arquivo de log de transações atual não existe.

  • O arquivo de log de transações atual não corresponde a um dos bancos de dados do grupo de armazenamento.

Esse comportamento pode ocorrer pelas seguintes razões:

  • Os logs de transações do grupo de armazenamento foram excluídos manualmente.

  • Um banco de dados de outro grupo de armazenamento foi restaurado ou copiado nesse grupo de armazenamento.

  • Os arquivos de log de transações de uma seqüência ou grupo de armazenamento diferente foram copiados nesse grupo de armazenamento.

Se essa condição impedirá um banco de dados de ser montado depende do arquivo de banco de dados estar em um estado de Desligamento Normal ou Desligamento Anormal.

Observação:
Um banco de dados pode estar em um estado de Desligamento Normal, mas ainda não conseguir ser montado porque outros bancos de dados no grupo de armazenamento estão desmontados. Use o Analisador de Recuperação de Desastres do Exchange para diagnosticar e avisá-lo sobre como montar os bancos de dados nesses casos.

Quando um banco de dados do Exchange desliga corretamente, todos os dados pendentes são gravados nos arquivos de bancos de dados. Depois do desligamento comum, o conjunto de arquivos de bancos de dados (extensões .edb e .stm) é considerado consistente. O Exchange desanexa então o arquivo de banco de dados do seu fluxo de log. Isso significa que os arquivos de bancos de dados agora são auto-contidos, ou seja, eles estão completamente atualizados. Os logs de transações anteriores não são necessários para iniciar os arquivos de bancos de dados.

Os bancos de dados em um estado de Desligamento Normal foram desanexados de seus arquivos de log e podem ser anexados em um fluxo de log diferente. Portanto, a incompatibilidade entre os arquivos de log e o banco de dados não é necessariamente um problema.

Os bancos de dados em um estado de Desligamento Anormal foram incorretamente desanexados de seus arquivos de log. Esses bancos de dados devem ser recuperados com seus arquivos de log anexados. Se os arquivos de log anexados não puderem ser localizados, o banco de dados não poderá ser montado. Você deve restaurá-lo a partir de um backup ou repará-lo antes de montá-lo.

Você pode dizer se um banco de dados foi desligado normalmente se inserir o comando Eseutil /mh e examinar os cabeçalhos do arquivo. No Microsoft Exchange 2000 Service Pack 1 e versões posteriores, uma linha no cabeçalho mostra "Estado: Desligamento Normal" ou "Estado: Desligamento Anormal". Nas versões anteriores do Exchange, o mesmo estado era relatado como "Estado: Consistente" ou "Estado: Inconsistente".

Para obter mais informações sobre logs de transações do Exchange Server, consulte "Logs de transações do Exchange no Exchange Server 2003" em Usando grupos de armazenamento de recuperação no Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589) (em inglês).


Bytes de registro de log/s além do limite de erro
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-23

O Microsoft® Exchange Server Analyzer Tool utiliza a ferramenta ExMon (Monitor de Usuários do Exchange Server) para determinar se as operações MAPI do usuário estão sendo executadas de modo esperado em um servidor Exchange íntegro.

O Exchange Server Analyzer, como parte de sua análise, revê o uso do log de transações para determinar se as operações MAPI do usuário produzem mais de 5 MB de dados por minuto para gravação nos logs de transações do Exchange.

O aumento excessivo do arquivo de log de transações devido às operações MAPI pode causar afunilamentos nos recursos do servidor e erros como profundidade do ponto de verificação excedida, afunilamentos de E/S de disco e espaço insuficiente em disco.

Se o Exchange Server Analyzer determinar que uma ou mais operações MAPI do usuário produzem mais de 5 MB de dados por minuto para gravação nos logs de transações do Exchange, o Exchange Server Analyzer exibirá um erro.

As operações MAPI que gravam mais de 5 MB de dados por minuto nos logs de transações do Exchange não são sempre um problema. A gravação a uma taxa alta é esperada em algumas ações, como movimentações de caixas de correio ou outras operações em massa em muitas mensagens que geram grandes quantidades de dados no log de transações. Nesse caso, taxas altas não devem ser sustentadas por mais que alguns minutos.

Se o servidor estiver tendo outros problemas, como alta latência de RPC, trabalhe com o usuário gerando os dados de log de transações para descobrir qual atividade do usuário está causando a alta taxa de gravação de registro no log.

Para obter mais informações

Para obter mais informações, consulte os seguintes recursos do Exchange Server:

  • Guia de Desempenho e Escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (em inglês)

  • Solucionando problemas de desempenho do Microsoft Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Desempenho do Exchange Server 2003: 10 Aspectos a Serem Considerados (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Artigo 905803 da Base de Dados de Conhecimento da Microsoft, "Usuários do Outlook enfrentam desempenho inadequado quando trabalham com uma pasta que contém muitos itens em um servidor que esteja executando o Exchange Server 2003 ou o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


O objeto de monitor de desempenho LogicalDisk não está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Avg. Disk sec/Read do objeto de desempenho de LogicalDisk para analisar os dados do desempenho. Se o contador não retornar dados válidos, o Analisador do Exchange Server exibirá uma mensagem de linha de base.

Se não forem retornados dados válidos pelo mecanismo de coleta de dados de desempenho, qualquer combinação das condições a seguir é verdadeira:

  • O objeto do desempenho do LogicalDisk está desabilitado. Por padrão, no Microsoft Windows Server™ 2003, o objeto de desempenho LogicalDisk está habilitado. No entanto, no Microsoft Windows® 2000 Server, LogicalDisk não é habilitado por padrão.

  • O objeto do monitor de desempenho do LogicalDisk está ausente ou danificado.

  • O Analisador do Exchange Server não tem permissões adequadas para acessar os objetos de desempenho.

As duas primeiras condições poderão ocorrer se certos contadores extensíveis danificarem o Registro ou se programas baseados no WMI (Instrumentação de Gerenciamento do Microsoft Windows) modificarem o Registro.

O procedimento a seguir explica como corrigir as duas primeiras condições. Antes de executar o procedimento, verifique se o Analisador do Exchange Server tem as permissões adequadas. Para obter mais informações sobre as permissões necessárias para executar o Analisador do Exchange Server, consulte a documentação da Ajuda incluída no Analisador do Exchange Server. Para obter Ajuda, abra o Analisador do Exchange Server e pressione a tecla F1.

Para corrigir esse erro

  1. Verifique se o objeto de desempenho do LogicalDisk está habilitado:

    1. Baixe e instale a ferramenta Lista de Contadores de Desempenho Extensíveis (Exctrlst.exe). Você pode baixar o Exctrlst.exe em Exctrlst.exe: Lista de Contadores de Desempenho Extensíveis (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Abra o Exctrlst.exe, clique em Ordem de classificação, e clique em Serviço.

    3. Localize o serviço ao qual o objeto de desempenho relata e verifique se a caixa de seleção Contadores de Desempenho Habilitados está marcada.

      Se a caixa de seleção Contadores de Desempenho Habilitados não estiver marcada, marque a caixa de seleção e reinicie o serviço que está associado aos contadores de desempenho para verificar se os contadores de desempenho estão em operação. Se os contadores de desempenho não estiverem funcionando ou se a caixa de seleção Contadores de desempenho habilitados já estava marcada, continue na etapa 2.

  2. Reconstrua os contadores de desempenho ausentes ou danificados, conforme descrito no artigo 300956 da Base de Dados de Conhecimento da Microsoft, "Como reconstruir manualmente os valores de biblioteca do contador de desempenho" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Se você seguir as instruções desse artigo da Base de Dados de Conhecimento e o problema não for solucionado, será necessário reinstalar o sistema operacional Windows no modo Reparo e então aplicar os service packs mais recentes do Windows.


Foram encontradas operações MAPI de latência longa
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-11-22

O Microsoft® Exchange Server Analyzer Tool usa a ferramenta ExMon (Monitor de Usuários do Exchange Server) para coletar dados, em 5 minutos de amostragem, para determinar se as operações MAPI do usuário estão levando mais tempo do que o esperado para serem executadas em um servidor Exchange íntegro.

Se o Exchange Server Analyzer determinar que, no período em que os dados foram coletados, um usuário teve uma ou mais operações MAPI que levaram mais de 30 segundos, o Exchange Server Analyzer exibirá um erro e executará análise adicional nas ações dos usuários que acionaram o erro.

As operações MAPI que demoram mais de 30 segundos nem sempre podem ser um problema. Salvar grandes quantidades de dados de mensagem ou anexos de arquivo pode fazer com que as operações MAPI levem mais tempo que o normal.

Se o usuário ou usuários estiverem enfrentando atrasos freqüentes, ou atrasos que prejudicam a experiência de mensagens, esses atrasos de operação MAPI devem ser investigados com mais detalhes para garantir que eles não sejam sintomas de problemas de latência mais sérios, como afunilamentos de recursos ou dependências aninhadas.

Para corrigir esse erro:

  • Considere utilizar a ferramenta ExMon para capturar uma amostra de dados maior para ser verificada pelo Exchange Server Analyzer. Devido ao grande volume de dados gerado pelo ExMon, é recomendável que a amostra de coleta de dados seja mantida como 30 minutos ou menos.

  • Reveja todos os erros de latência relacionados e os artigos de acompanhamento que descrevem a operação específica e as etapas para solucioná-los. Se nenhum erro de latência relacionado for reportado pelo Exchange Server Analyzer, a análise adicional das ações do usuário não terá revelado nenhum problema.


Operação MAPI em massa de execução demorada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-23

A ferramenta Microsoft® Exchange Server Analyzer Tool utiliza a ferramenta ExMon (Monitor de Usuários do Exchange Server) para determinar se as operações MAPI do usuário estão levando mais tempo do que o esperado para serem executadas em um servidor Exchange íntegro.

Como parte dessa análise, o Exchange Server Analyzer confere os dados do ExMon para operações MAPI em massa emitidas por usuários que levaram mais de 30 segundos para serem concluídas.

Operações MAPI em massa são operações que agem em mais de um objeto e que normalmente são dispendiosas (exigem muitas E/Ss).

Se o Exchange Server Analyzer determinar que um usuário teve uma ou mais operações MAPI em massa que durou mais de 30 segundos, ele exibirá um erro.

As operações MAPI em massa que demoram mais de 30 segundos nem sempre podem ser um problema. Se o usuário estiver atuando (copiando, excluindo, definindo sinalizadores de atributos, etc.) em mil mensagens ou mais de uma só vez, poderá fazer com que as operações MAPI em massa levem mais tempo que o normal.

Se o usuário ou usuários estiverem enfrentando atrasos freqüentes, ou atrasos que prejudicam a experiência de mensagens, esses atrasos de operação MAPI em massa devem ser investigados com mais detalhes para garantir que eles não sejam sintomas de problemas de latência mais sérios, como afunilamentos de recursos ou dependências aninhadas.

Para corrigir esse erro:

  • Considere utilizar a ferramenta ExMon para capturar uma amostra de dados maior para ser verificada pelo Exchange Server Analyzer. Devido ao grande volume de dados gerado pelo Exchange, é recomendável que a amostra de coleta de dados seja mantida como 30 minutos ou menos.

Para obter mais informações

Para obter mais informações, consulte os seguintes recursos do Exchange Server:

  • Guia de desempenho e escalabilidade do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Solucionando problemas de desempenho do Microsoft Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Desempenho do Exchange Server 2003: 10 aspectos a serem considerados" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Artigo 905803 da Base de Dados de Conhecimento Microsoft, "Usuários do Outlook enfrentam desempenho inadequado quando trabalham com uma pasta que contém muitos itens em um servidor que esteja executando o Exchange Server 2003 ou o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Operação MAPI 'FindRow' de execução demorada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-11-22

O Microsoft® Exchange Server Analyzer Tool utiliza a ferramenta ExMon (Monitor de Usuários do Exchange Server) para determinar se as operações MAPI do usuário estão levando mais tempo do que o esperado para serem executadas em um servidor Exchange íntegro.

Como parte de sua análise, o Exchange Server Analyzer revê os dados do ExMon relativos às operações MAPI FindRow emitidas pelo usuário que levaram mais de 30 segundos para serem concluídas.

Um aumento no número de exibições de cada pasta pode adicionar uma sobrecarga a várias operações MAPI. Os aplicativos clientes usam as operações MAPI SeekRow ou FindRow para mover o ponteiro entre linhas em uma exibição. SeekRow especifica a quantidade de linhas para mover o ponteiro e tem um custo muito baixo em relação ao tempo de CPU. FindRow é bastante dispendiosa, pois move o ponteiro para o primeiro item em uma exibição não materializada (não será armazenada em cache) que corresponde aos critérios de restrição e, em seguida, descarta a exibição depois que o aplicativo cliente conclui a ação. O custo máximo de FindRow na CPU depende da complexidade da restrição e da quantidade de linhas que o armazenamento deve examinar antes de encontrar o primeiro item que corresponde aos critérios e, dessa forma, tem pouca relação com o número de itens na pasta.

O alto custo que pode ocorrer com FindRow a torna uma boa candidata para executar o modo de cache, o que reduziria o custo do servidor. Saiba que, às vezes, a alta porcentagem da CPU consumida por essa operação pode ser ocasionada meramente por calendários compartilhados, caso em que o modo de cache não ajudará em nada. O alto consumo da porcentagem do tempo da CPU pelas operações FindRow poderá indicar a criação de muitas exibições, exibições dispendiosas ou contagens de itens em pastas grandes.

O Exchange Server Analyzer exibirá um erro, se determinar que a operação MAPI FindRow emitida pelo usuário levou mais de 30 segundos.

As operações MAPI FindRow que demoram mais de 30 segundos nem sempre podem ser um problema. Se os usuários identificados estiverem enfrentando atrasos freqüentes ou atrasos que podem afetar desfavoravelmente a experiência de mensagens, você deverá entender o porquê. Trabalhe com o usuário enfrentando a alta latência para determinar:

  • Se as contagens de itens em pastas são altas.

  • Quais aplicativos o usuário está executando.

Para resolver esse problema:

  • Encoraje os usuários que possuam muitos itens em suas pastas a reduzir o número de itens por pasta. É recomendável que você mantenha os itens das pastas Caixa de Entrada, Calendário, Itens Enviados, Contatos e Itens Excluídos abaixo de 5.000.

  • Configure os computadores clientes com a operação mais dispendiosa (especialmente aqueles com latências longas em operações Restrict, SetColumns ou FindRow) para usar o modo do Exchange em cache. O modo do Exchange em cache isola o servidor da maior parte do excesso de tráfego RPC.

  • Tente desativar todos os aplicativos e ativá-los um por um para descobrir qual deles pode estar causando o problema. Se esses aplicativos não forem usados para fins comerciais, ou se tiverem um hotfix publicado, desative permanentemente os aplicativos ou os atualize para reduzir a carga para um nível adequado.

Observação:
Alguns aplicativos podem aumentar significativamente a carga no servidor sem emitir várias operações MAPI. Isso ocorre porque algumas operações são mais dispendiosas que outras. Pode ser necessário apenas um pequeno aumento no número de operações dispendiosas para haver um impacto perceptível no desempenho do servidor. No ExMon, esses usuários são relatados como tendo um efeito alto na CPU, sem necessariamente emitirem várias operações MAPI.

Além disso, esteja ciente de que quando houver um afunilamento nos recursos, em geral afunilamento de disco ou CPU, as latências nas operações FindRow aumentarão.

Para obter mais informações

Para obter mais informações, consulte os seguintes recursos do Exchange Server:

  • Guia de Desempenho e Escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (em inglês)

  • Solucionando Problemas de Desempenho do Microsoft Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Desempenho do Exchange Server 2003: 10 Aspectos a Serem Considerados (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Artigo 905803 da Base de Dados de Conhecimento da Microsoft, "Usuários do Outlook enfrentam desempenho inadequado quando trabalham com uma pasta que contém muitos itens em um servidor que esteja executando o Exchange Server 2003 ou o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Operação MAPI online de execução demorada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-23

A ferramenta Microsoft® Exchange Server Analyzer utiliza a ferramenta ExMon (Monitor de Usuários do Exchange Server) para determinar se as operações MAPI Online do usuário estão levando mais tempo do que o esperado para serem executadas em um servidor Exchange íntegro.

Um exemplo de operação MAPI online é QueryRows.

A operação QueryRows é utilizada para retornar linhas na exibição atual. QueryRows utiliza os dados em uma tabela para atender à solicitação do usuário. A operação SetColumns determina os dados disponíveis para QueryRows. O custo de QueryRows aumenta de acordo com o tamanho das propriedades solicitadas, o número de propriedades solicitadas e o número de linhas de dados solicitadas. QueryRows também pode ser cara se muitas colunas e linhas forem solicitadas.

Conforme o número de itens nas principais pastas do Exchange Server 2003 aumentar, o custo de disco físico para executar algumas operações também irá aumentar para usuários do Outlook. Classificar a Caixa de Entrada por tamanho pela primeira vez é muito caro (exige muitas E/S de disco). Futuras classificações da Caixa de Entrada por tamanho serão muito baratas.

Se o Exchange Server Analyzer determinar que, durante o período de coleta de dados, um usuário teve uma ou mais operações MAPI Online que duraram mais de 30 segundos, ele exibirá um erro.

Latência longa em Operações MAPI Online pode indicar um afunilamento de recursos do servidor. Para a operação QueryRows, ela pode também indicar uma alta contagem de itens em uma pasta ou muitas propriedades definidas nas tabelas internas.

Se a operação Online de alta latência estiver operando em muitos dados ao mesmo tempo, a alta latência pode não indicar um problema de desempenho do servidor. Um exemplo dessa situação é quando um usuário seleciona todos os itens de uma pasta e os marca como lidos em uma única operação. Trabalhe com o usuário enfrentando a alta latência para determinar:

  • Se as contagens de itens em pastas são altas.

  • Quais aplicativos o usuário está executando.

Para resolver esse problema:

  • Encoraje os usuários que possuam muitos itens em suas pastas a reduzir o número de itens por pasta. É recomendável que você mantenha os itens das pastas Caixa de Entrada, Calendário, Itens Enviados, Contatos e Itens Excluídos abaixo de 5.000.

  • Tente desativar todos os aplicativos e ativá-los um por um para descobrir qual deles pode estar causando o problema. Se esses aplicativos não forem usados para fins comerciais, ou se tiverem um hotfix publicado, desative permanentemente os aplicativos ou os atualize para reduzir a carga para um nível adequado.

Observação:
Alguns aplicativos podem aumentar significativamente a carga no servidor sem emitir várias operações MAPI Online. Isso ocorre porque algumas operações são mais caras que outras. Pode ser necessário apenas um pequeno aumento no número de operações dispendiosas para haver um impacto perceptível no desempenho do servidor. No ExMon, esses usuários são relatados como tendo um impacto relativamente alto na CPU, sem necessariamente emitirem várias operações MAPI.

Além disso, fique ciente de que sempre que ocorrer um afunilamento de recursos (normalmente um afunilamento de disco ou CPU), as latências das operações MAPI Online irão aumentar. Identifique os afunilamentos de recursos do servidor e aumente a capacidade de recursos do servidor ou mova usuários para um servidor menos sobrecarregado.

Para obter mais informações

Para obter mais informações, consulte os seguintes recursos do Exchange Server:

  • Guia de Desempenho e Escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (em inglês)

  • Solucionando problemas de desempenho do Microsoft Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Desempenho do Exchange Server 2003: 10 aspectos a serem considerados (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Artigo 905803 da Base de Dados de Conhecimento da Microsoft, "Usuários do Outlook enfrentam desempenho inadequado quando trabalham com uma pasta que contém muitos itens em um servidor que esteja executando o Exchange Server 2003 ou o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Operação MAPI de execução demorada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-11-22

A ferramenta Microsoft® Exchange Server Analyzer Tool utiliza a ferramenta ExMon (Monitor de Usuários do Exchange Server) para determinar se as operações MAPI do usuário estão levando mais tempo do que o esperado para serem executadas em um servidor Exchange íntegro.

Se o Exchange Server Analyzer determinar que um usuário teve uma ou mais operações MAPI que durou mais de 30 segundos, exibirá um erro.

Um aumento no número de exibições de cada pasta pode adicionar uma sobrecarga a várias operações MAPI. As duas mais comuns, SeekRow e FindRow, são discutidas neste tópico. Outras operações MAPI identificadas pelo Exchange Server Analyzer como de 'execução demorada', normalmente podem ser resolvidas pelas mesmas ações das operações MAPI SeekRow e FindRow.

Os aplicativos clientes usam as operações MAPI SeekRow ou FindRow para mover o ponteiro entre linhas em uma exibição. SeekRow especifica a quantidade de linhas para mover o ponteiro e tem um custo muito baixo em relação ao tempo de CPU. FindRow é bastante dispendiosa, pois move o ponteiro para o primeiro item em uma exibição não materializada (não será armazenada em cache) que corresponde aos critérios de restrição e, em seguida, descarta a exibição depois que o aplicativo cliente conclui a ação. O custo máximo de FindRow na CPU depende da complexidade da restrição e da quantidade de propriedades de mensagens acessadas em cada mensagem, e do número de linhas que o armazenamento deve examinar antes de encontrar o primeiro item que corresponde aos critérios e, dessa forma, tem pouca relação com o número de itens na pasta.

As operações MAPI que demoram mais de 30 segundos nem sempre podem ser um problema. Se os usuários identificados estiverem enfrentando atrasos freqüentes ou atrasos que podem afetar desfavoravelmente a experiência de mensagens, você deverá entender o porquê. Trabalhe com o usuário enfrentando a alta latência para determinar:

  • Se as contagens de itens em pastas são altas.

  • Quais aplicativos o usuário está executando.

Para resolver esse problema:

  • Encoraje os usuários que possuam muitos itens em suas pastas a reduzir o número de itens por pasta. É recomendável que você mantenha os itens das pastas Caixa de Entrada, Calendário, Itens Enviados, Contatos e Itens Excluídos abaixo de 5.000.

  • Configure os computadores clientes com a operação mais dispendiosa (especialmente aqueles com latências longas em operações Restrict, SetColumns ou FindRow) para usar o modo do Exchange em cache. O modo do Exchange em cache isola o servidor da maior parte do excesso de tráfego RPC.

  • Tente desativar todos os aplicativos e ativá-los um por um para descobrir qual deles pode estar causando o problema. Se esses aplicativos não forem usados para fins comerciais, ou se tiverem um hotfix publicado, desative permanentemente os aplicativos ou os atualize para reduzir a carga para um nível adequado.

Observação:
Alguns aplicativos podem aumentar significativamente a carga no servidor sem emitir várias operações MAPI. Isso ocorre porque algumas operações são mais dispendiosas que outras. Pode ser necessário apenas um pequeno aumento no número de operações dispendiosas para haver um impacto perceptível no desempenho do servidor. No ExMon, esses usuários são relatados como tendo um efeito alto na CPU, sem necessariamente emitirem várias operações MAPI.

Além disso, fique ciente de que quando ocorre um afunilamento de recursos (normalmente um afunilamento de disco ou CPU), as latências das operações MAPI aumentam. Determine os afunilamentos de recursos do servidor e aumente a capacidade de recursos do servidor ou mova usuários para um servidor menos sobrecarregado.

Para obter mais informações

Para obter mais informações, consulte os seguintes recursos do Exchange Server:

  • Guia de desempenho e escalabilidade do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Solucionando problemas de desempenho do Microsoft Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Desempenho do Exchange Server 2003: 10 aspectos a serem considerados (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Artigo 905803 da Base de Dados de Conhecimento Microsoft, "Usuários do Outlook enfrentam desempenho inadequado quando trabalham com uma pasta que contém muitos itens em um servidor que esteja executando o Exchange Server 2003 ou o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Operação MAPI 'SaveChangesMessage' de execução demorada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-11-22

O Microsoft® Exchange Server Analyzer Tool utiliza a ferramenta ExMon (Monitor de Usuários do Exchange Server) para determinar se as operações MAPI do usuário estão levando mais tempo do que o esperado para serem executadas em um servidor Exchange íntegro.

Como parte de sua análise, o Exchange Server Analyzer revê os dados do ExMon relativos às operações MAPI SaveChangesMessage emitidas pelo usuário que levaram mais de 30 segundos para serem concluídas.

A operação MAPI SaveChangesMessage é chamada quando um aplicativo está salvando o conteúdo ou as propriedades de uma mensagem no servidor. O tempo exigido para concluir a operação depende dos dados gravados, da velocidade do banco de dados, dos discos de log de transações nos quais estão sendo gravados os dados e, ainda, se existe um afunilamento nos recursos.

O Exchange Server Analyzer exibirá um erro, se determinar que uma operação MAPI SaveChangesMessage emitida pelo usuário levou mais de 30 segundos.

As operações MAPI SaveChangesMessage que demoram mais de 30 segundos nem sempre podem ser um problema. Salvar grandes quantidades de dados de mensagem ou anexos de arquivo pode fazer com que a operação MAPI SaveChangesMessage leve mais tempo que o normal. Se o usuário ou usuários estiverem enfrentando atrasos freqüentes, ou atrasos que prejudicam a experiência de mensagens, a causa mais provável é um afunilamento de disco.

Para obter mais informações

  • Para obter mais informações sobre afunilamentos de disco, consulte Afunilamento de disco detectado

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de Desempenho e Escalabilidade do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solução de problemas de desempenho do Microsoft Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre as práticas recomendadas para projetar arquiteturas de armazenamento, consulte Práticas recomendadas comuns a diversas arquiteturas (http://go.microsoft.com/fwlink/?LinkId=72988) (em inglês).

  • Para obter mais informações sobre como mover caixas de correio do usuário para reduzir a carga do servidor, consulte Mover Caixas de Correio de Usuário para Outro Servidor.

  • Para obter mais informações sobre tamanho de disco, latência e taxas de E/S, consulte os seguintes blogs no site Blog de Equipe do Microsoft Exchange:

    • "Alguns conceitos básicos sobre dimensionamento de discos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=39538)

    • "Considerações adicionais sobre a E/S de disco e cálculos…." (em inglês) (http://go.microsoft.com/fwlink/?linkid=39539)

    • Como calcular os requisitos de E/S do disco (http://go.microsoft.com/fwlink/?linkid=69747) (em inglês)


Operação MAPI 'SetColumns' de execução demorada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-23

O Microsoft® Exchange Server Analyzer Tool utiliza a ferramenta ExMon (Monitor de Usuários do Exchange Server) para determinar se as operações MAPI do usuário estão levando mais tempo do que o esperado para serem executadas em um servidor íntegro que esteja executando o Exchange Server.

Como parte de sua análise, o Exchange Server Analyzer revê os dados do ExMon relativos às operações MAPI SetColumns emitidas pelo usuário que levaram mais de 30 segundos para serem concluídas.

Uma exibição básica é criada com o uso da chamada MAPI SetColumns. A chamada para SetColumns define as propriedades que serão colunas na nova tabela de exibições.

Na primeira vez que uma propriedade é solicitada em uma exibição, o servidor precisa de trabalho extra para gerar a exibição. Após a solicitação dessa propriedade em uma exibição, ela sempre estará presente nas exibições futuras. Isso significa que na primeira solicitação de novas propriedades, a chamada para SetColumns poderá levar muito mais tempo. O tempo necessário é proporcional ao número de novas propriedades e ao número de itens na pasta. Por exemplo, na primeira vez que um usuário exibe sua caixa de entrada após uma movimentação de caixas de correio, o servidor leva muito mais tempo para gerar a exibição. Isso se deve ao fato de que as exibições não são movidas com uma movimentação de caixas de correio. As exibições serão recriadas.

Em geral, é muito dispendioso adicionar propriedades à exibição. O custo de adicionar propriedades é proporcional ao número de itens na pasta e ao número de propriedades que estão sendo adicionadas. O uso geral do Microsoft Office® Outlook® não causará a adição de muitas propriedades na tabela de pastas de mensagens, mas é possível adicionar mais manualmente. Isso, de um modo geral, não indica um problema. Entretanto, você poderá observar atrasos se um aplicativo adicionar colunas regularmente, adicionar muitas colunas, ou se algum cliente adicionar muitas colunas sobre muitos itens. Quanto mais colunas na tabela de pasta de mensagens, maior sobrecarga haverá para as demais ações nos itens dessa pasta. Quando uma coluna é adicionada, não é possível removê-la. Cada propriedade na tabela Pasta de Mensagens aumenta a sobrecarga na inserção de itens nessa tabela.

O Exchange Server Analyzer exibirá um erro, se determinar que a operação MAPI SetColumns emitida por um usuário levou mais de 30 segundos.

O servidor terá de criar novas exibições quando o usuário acessar pela primeira vez sua caixa de correio após ela ter sido movida para um novo banco de dados ou para um novo servidor. Nesse caso, chamadas demoradas de SetColumns e Restrict são esperadas. Você pode ignorar esses erros com segurança por vários dias após a movimentação de uma caixa de correio.

Alguns aplicativos criarão novas exibições e farão com que as propriedades sejam promovidas para estruturas de dados de armazenamento interno. Isso poderá ter um efeito em longo prazo sobre o servidor quanto ao desempenho, quando o servidor acessar os dados do usuário. Se os usuários identificados estiverem observando atrasos freqüentes ou atrasos que prejudicam a experiência de mensagens, você deverá entender o porquê. Trabalhe com o usuário que está observando a alta latência para determinar o seguinte:

  • Se as contagens de itens em pastas são altas.

  • Quais aplicativos o usuário está executando.

Para resolver esse problema, siga essas etapas:

  • Encoraje os usuários que possuam muitos itens em suas pastas a reduzir o número de itens por pasta. É recomendável que você mantenha os itens das pastas Caixa de Entrada, Calendário, Itens Enviados, Contatos e Itens Excluídos abaixo de 5.000.

  • Configure os computadores clientes mais caros operacionalmente para usar o Modo Cache do Exchange. Dê atenção especial aos computadores clientes que tenham latências longas nas operações Restrict, SetColumns ou FindRow. O modo do Exchange em cache isola o servidor da maior parte do excesso de tráfego RPC.

  • Tente desativar todos os aplicativos. Em seguida, ative-os um por um para descobrir qual deles pode estar causando o problema. Desative permanentemente todos os aplicativos com problemas ou atualize-os para reduzir a carga para um nível adequado se alguma das seguintes condições for verdadeira:

    • O aplicativo não é necessário para fins comerciais.

    • O aplicativo tem uma atualização publicada.

Observação:
Alguns aplicativos podem aumentar significativamente a carga no servidor sem emitir várias operações MAPI. Isso ocorre porque algumas operações são mais dispendiosas que outras. Pode ser necessário apenas um pequeno aumento no número de operações dispendiosas para haver um impacto perceptível no desempenho do servidor. No ExMon, os usuários são relatados como tendo um efeito alto na CPU, sem necessariamente emitirem várias operações MAPI.

Além disso, esteja ciente de que quando houver um afunilamento nos recursos, em geral afunilamento de disco ou CPU, as latências nas operações SetColumns aumentarão.

Para obter mais informações

Para obter mais informações, consulte os seguintes recursos do Exchange Server:

  • "Guia de Desempenho e Escalabilidade do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • "Solucionando Problemas de Desempenho do Microsoft Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Desempenho do Exchange Server 2003: 10 Aspectos a Serem Considerados (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Artigo 905803 da Base de Dados de Conhecimento da Microsoft, "Usuários do Outlook enfrentam desempenho inadequado quando trabalham com uma pasta que contém muitos itens em um servidor que esteja executando o Exchange Server 2003 ou o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Operação de sincronização MAPI de execução demorada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-23

O Microsoft® Exchange Server Analyzer Tool utiliza a ferramenta ExMon (Monitor de Usuários do Exchange Server) para determinar se as operações MAPI do usuário estão levando mais tempo do que o esperado para serem executadas em um servidor Exchange íntegro.

Como parte de sua análise, o Exchange Server Analyzer revê os dados do ExMon relativos às operações de Sincronização MAPI emitidas pelo usuário que levaram mais de 30 segundos para serem concluídas.

As operações de Sincronização MAPI são executadas para manter o arquivo de Pasta Offline (.ost) do Microsoft Office® Outlook® ou a cópia local da caixa de correio do usuário em sincronia com os dados da caixa de correio do usuário no servidor.

As operações de Sincronização MAPI que demoram mais de 30 segundos nem sempre podem ser um problema. Por padrão, todas as mensagens de e-mail armazenadas no Exchange Server e que são cópias completas da Lista de Endereços Global são baixadas no computador do usuário quando o Modo de Cache do Exchange é habilitado pela primeira vez no Outlook 2003.

Durante uma sincronização inicial com o Exchange Server, os usuários do Outlook 2003 podem observar respostas atrasadas.

Se o usuário estiver observando atrasos freqüentes, ou atrasos que prejudicam a experiência de mensagens, logo em seguida à sincronização do modo de cache inicial, esses atrasos nas operações de Sincronização MAPI deverão ser melhor investigados para verificar se não são indicativos de problemas mais graves de latência, como afunilamentos nos recursos.

Toda vez que houver um afunilamento nos recursos, em geral afunilamento de disco ou CPU, as latências nas operações de sincronização MAPI aumentarão. Identifique os afunilamentos de recursos do servidor e aumente a capacidade de recursos do servidor ou mova usuários para um servidor menos sobrecarregado.

Para obter mais informações

Para obter mais informações, consulte os seguintes recursos do Exchange Server:

  • Guia de Desempenho e Escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (em inglês)

  • Solucionando problemas de desempenho do Microsoft Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Desempenho do Exchange Server 2003: 10 Aspectos a Serem Considerados" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Artigo 905803 da Base de Dados de Conhecimento da Microsoft, "Usuários do Outlook enfrentam desempenho inadequado quando trabalham com uma pasta que contém muitos itens em um servidor que esteja executando o Exchange Server 2003 ou o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Operação MAPI 'TaskQ' de execução demorada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-02-20

A ferramenta Microsoft Exchange Analyzer Tool usa a ferramenta ExMon (Monitor de Usuários do Exchange Server) para determinar se as operações MAPI do usuário estão levando mais tempo do que o esperado para serem executadas em um servidor Exchange íntegro.

Como parte de sua análise, o Exchange Analyzer confere os dados do ExMon relativos às operações MAPI TaskQ emitidas pelo usuário que levaram mais de 30 segundos para serem concluídas.

Operações TaskQ são tarefas assíncronas executadas fora do contexto de uma chamada RPC. Operações TaskQ e TaskQ Usuário Desconhecido são tarefas executadas à pedido do Exchange e incluem manutenção de armazenamento. TaskQ Usuário Desconhecido são tarefas assíncronas iniciadas por um pedido direto do usuário e incluem preenchimento, classificação e operações em massa na pasta de pesquisa, por exemplo, mover, copiar, excluir e marcar mensagens como lidas em várias mensagens.

Se o Exchange Analyzer determinar que as operações MAPI TaskQ emitidas pelo usuário levaram mais de 30 segundos para serem concluídas, ele exibirá um aviso.

Isso nem sempre pode indicar um problema de desempenho, já que operações TaskQ em geral podem levar um longo tempo para serem concluídas.

Para resolver esse problema, faça o seguinte:

  • Considere utilizar a ferramenta ExMon para capturar uma amostra de dados maior para ser verificada pelo Exchange Server Analyzer. Devido ao grande volume de dados gerado pelo Exchange, é recomendável que a amostra de coleta de dados seja mantida como 30 minutos ou menos.

Para obter mais informações

Para obter mais informações, consulte os seguintes recursos do Exchange Server:

  • Guia de desempenho e escalabilidade do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Solucionando problemas de desempenho do Microsoft Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Desempenho do Exchange Server 2003: 10 aspectos a serem considerados (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56460)


Operação de execução demorada devido à operação MAPI 'Restrict'
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-23

O Microsoft® Exchange Server Analyzer Tool utiliza a ferramenta ExMon (Monitor de Usuários do Exchange Server) para determinar se as operações MAPI do usuário estão levando mais tempo do que o esperado para serem executadas em um servidor íntegro que esteja executando o Exchange Server.

Como parte de sua análise, o Exchange Server Analyzer revê os dados do ExMon relativos às operações MAPI Restrict emitidas pelo usuário que levaram mais de 30 segundos para serem concluídas.

A operação MAPI Restrict é usada pelos aplicativos cliente para selecionar itens que correspondem a determinados critérios. O servidor cria uma exibição que, na realidade, é uma tabela com critérios associados, denominada uma restrição. Se a exibição que possui uma restrição correspondente já existir, o servidor usará a exibição existente para atender à solicitação do usuário. Quando o servidor usa essa exibição, essa é uma operação menos dispendiosa do que quando o servidor cria uma nova exibição. Por padrão, o armazenamento guarda em cache apenas 11 exibições de cada pasta. Se for solicitado que o servidor crie uma décima segunda exibição, ele excluirá a exibição em cache mais antiga e criará uma nova. As exibições aumentam a sobrecarga em todas as ações nos itens.

O Exchange Server Analyzer exibirá um erro, se determinar que uma operação MAPI Restrict emitida pelo usuário levou mais de 30 segundos.

As operações MAPI Restrict que levam mais de 30 segundos nem sempre podem ser um problema. Entretanto, se o usuário observar atrasos freqüentes, ou os atrasos prejudicarem a experiência de mensagens, esses atrasos poderão indicar que um aplicativo do usuário está fazendo com que novas exibições sejam criadas.

Para resolver esse erro, trabalhe com o usuário que está observando a alta latência para determinar o seguinte:

  • Se as contagens de itens em pastas são altas.

  • Quais aplicativos o usuário está executando.

Para resolver esse problema, siga essas etapas:

  • Encoraje os usuários que possuam muitos itens em suas pastas a reduzir o número de itens por pasta. É recomendável que você mantenha os itens das pastas Caixa de Entrada, Calendário, Itens Enviados, Contatos e Itens Excluídos abaixo de 5.000.

  • Configure os computadores clientes mais caros operacionalmente para usar o Modo Cache do Exchange. Dê atenção especial aos computadores clientes que tenham latências longas nas operações Restrict, SetColumns ou FindRow. O modo do Exchange em cache isola o servidor da maior parte do excesso de tráfego RPC.

  • Siga a orientação do Blog da Equipe do Exchange, mencionado na seção a seguir, para ativar o rastreamento de restrição de log de eventos. Em seguida, ative os aplicativos do usuário, um por um, para rastrear qual aplicativo pode estar causando a restrição de execução demorada.

  • Tente desativar todos os aplicativos. Em seguida, ative-os um por um para descobrir qual deles pode estar causando o problema. Desative permanentemente todos os aplicativos com problemas ou atualize-os para reduzir a carga para um nível adequado se alguma das seguintes condições for verdadeira:

    • O aplicativo não é necessário para fins comerciais.

    • O aplicativo tem uma atualização publicada.

Observação:
Alguns aplicativos podem aumentar significativamente a carga no servidor sem emitir várias operações MAPI. Isso ocorre porque algumas operações são mais dispendiosas que outras. Pode ser necessário apenas um pequeno aumento no número de operações dispendiosas para haver um impacto perceptível no desempenho do servidor. No ExMon, os usuários são relatados como tendo um efeito alto na CPU, sem necessariamente emitirem várias operações MAPI.

Além disso, esteja ciente de que quando houver um afunilamento nos recursos, em geral um afunilamento de disco ou CPU, as latências nas operações Restrict aumentarão.

Para obter mais informações

Para obter mais informações sobre a operação MAPI Restrict, consulte o Blog da Equipe do Microsoft Exchange, "Colocando as Restrições sobre Restrições" (em inglês) (http://go.microsoft.com/fwlink/?linkid=55098).

Observação:
O conteúdo de cada blog e sua URL estão sujeitos a alterações sem aviso.

Para obter mais informações, consulte os seguintes recursos do Exchange Server:

  • "Guia de Desempenho e Escalabilidade do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576)

  • "Solucionando Problemas de Desempenho do Microsoft Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Desempenho do Exchange Server 2003: 10 Aspectos a Serem Considerados" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Artigo 905803 da Base de Dados de Conhecimento da Microsoft, "Usuários do Outlook enfrentam desempenho inadequado quando trabalham com uma pasta que contém muitos itens em um servidor que esteja executando o Exchange Server 2003 ou o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


O arquivo MAD.EXE está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


Porta MAD NSPI é inferior a 5000
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar a configuração TCP/IP NSPI Port para o serviço Atendedor do Sistema do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

Se o Analisador do Exchange Server achar que o valor de TCP/IP NSPI Port está definido como um valor abaixo de 5000 (decimal), um aviso será exibido.

Se você definir o TCP/IP NSPI Port como um valor estático, será recomendável defini-lo como um valor um pouco acima de 5000. A atribuição de números de porta estáticos abaixo de 5000 pode ocasionar um conflito de porta com outro processo e resultar em falha do processo do serviço Atendendor do Sistema do Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir a chave de Registro da porta NSPI do TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Clique duas vezes na chave TCP/IP NSPI Port e defina o campo Dados do valor para um inteiro acima de 5000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o serviço Atendedor do Sistema do Microsoft Exchange para que essa alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre limites de portas, consulte o artigo 194952 da Base de Dados de Conhecimento Microsoft, "XADM: Statically Mapped Port Limitations for Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952).


A porta MAD RFR foi substituída manualmente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a entrada de Registro a seguir para determinar se o valor da porta para o diretório do Atendedor do Sistema do Microsoft Exchange refere-se à porta que foi substituída manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

Se o Analisador do Exchange Server detectar a presença e configuração da TCP/IP Port , será exibida uma mensagem de configuração não padrão.

O motivo mais comum para a configuração desse valor é habilitar clientes MAPI para se conectarem a um servidor Exchange existente no outro lado de um firewall. Esse cenário requer a abertura de várias portas em um firewall para habilitar clientes do Microsoft Office Outlook® 2003 a se conectarem por meio do MAPI com um servidor Exchange, geralmente pela Internet. Há suporte para essa configuração. Para obter mais informações sobre como configurar clientes MAPI para se conectarem ao Exchange por meio de um firewall, consulte o artigo 270836 da Base de Dados de Conhecimento da Microsoft, "Mapeamentos de portas estáticas do Exchange 2000 e Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836). Se você não estiver usando este cenário, deverá remover a chave do Registro.

A implantação recomendada para usar o Outlook no Modo MAPI para se conectar a um servidor Exchange pela Internet é o uso de recursos RPC sobre HTTP, encontrados no Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 e Microsoft Windows® XP Professional. O Modo MAPI era conhecido anteriormente como modo Corporativo ou Grupo de trabalho.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para remover o valor de Registro da porta TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Exclua o valor do Registro chamado TCP/IP Port.

  4. Feche o editor de Registro e reinicie o serviço Atendedor do Sistema do Microsoft Exchange.

Para implantar o RPC sobre HTTPS

  1. Consulte Cenários de implantação RPC sobre HTTP do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Revise o artigo 833401 da Base de Dados de Conhecimento, "Como configurar RPC sobre HTTP em um único servidor no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  3. Revise o artigo 827330 da Base de Dados de Conhecimento, "Como solucionar problemas de conexão cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  4. Consulte o Microsoft Support WebCast, "Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


A porta MAD RFR é inferior a 5000
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar a configuração TCP/IP Port para o serviço Atendedor do Sistema do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

Se o Analisador do Exchange Server achar que o valor de TCP/IP Port está definido como um valor abaixo de 5000 (decimal), um aviso será exibido.

Caso precise definir TCP/IP Port como um valor estático, é recomendável que você determine um valor um pouco superior a 5000. Atribuir números de porta estáticos menores que 5000 pode causar um conflito de porta com outro processo e resultar em falha no processo do serviço Atendedor do Sistema do Microsoft Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir a chave de Registro da porta TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Clique duas vezes na chave TCP/IP Port e defina o campo Dados do valor para um inteiro acima de 5000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o serviço Atendedor do Sistema do Microsoft Exchange para que essa alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre configurações de porta, consulte o artigo 194952 da Base de Dados de Conhecimento, "XADM: Statically Mapped Port Limitations for Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952).


O arquivo MAPI32.DLL está ausente da pasta bin
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O arquivo MAPI32.DLL está ausente da pasta system32
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O arquivo MAPISTUB.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O arquivo MAPISP32.EXE está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para corrigir esse erro, instale o service pack mais recente ou distribua sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


Tamanho do cache do ESE máximo maior do que 1,2 GB
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de DataBase Cache Size (DBCacheSize) do objeto de desempenho de DataBase para analisar os dados do desempenho.

O contador de desempenho DataBase Cache Size (DBCacheSize) representa o tamanho atual do cache usado pelo armazenamento. Se o Exchange Server Analyzer verificar que o valor do contador de desempenho DataBase Cache Size (DBCacheSize) for maior que 307200 (1,2 GB), o Exchange Server Analyzer exibirá um erro.

Esse erro indica que o valor do atributo msExchESEParamCacheSizeMax do objeto do Armazenamento de Informações do Microsoft Exchange (MSExchangeIS) aumentou além do valor máximo recomendado de 307200 (1,2 GB).

O cache do banco de dados de armazenamento é também chamado buffer de ESE (Mecanismo de Armazenamento Extensível). Ele armazena em cache as transações do banco de dados antes que elas sejam confirmadas no banco de dados.

No Exchange 2000 Server, uma grande área da memória virtual usada por Store.exe é alocada para o Buffer de ESE. O Exchange 2000 Server usa um padrão codificado de 858 megabytes (MB) para esse buffer. No Exchange Server 2003, a alocação do buffer do ESE é baseada na presença do comando /3GB no arquivo Boot.ini. Se o comando /3GB estiver presente, o buffer do ESE é ajustado para 896 MB. Se /3GB não estiver presente, o buffer do ESE é ajustado para 576 MB. Embora o ajuste automático seja útil em todos os casos, talvez você deseja substituí-lo e definir manualmente um valor mais apropriado para seu ambiente.

Você pode ajustar esse valor como qualquer número, de modo que a memória realmente alocada seja um múltiplo de 8.192 bytes, é recomendável usar apenas um dos valores da tabela a seguir.

Valor recomendado | Memória alocada | Comentários
147456 | 576 MB | Esse é o mínimo recomendado. Não defina nenhum valor inferior. Esse valor é útil em servidores com restrição de memória e em computadores do Exchange Server 2003 que executam o Microsoft Windows® 2000 Server. Ele não tem suporte para a opção /3GB. Esse também é o valor padrão em sistemas que não usam a opção /3GB.
196608 | 768 MB | Esse valor é recomendado em servidores com grandes quantidades de memória virtual que registram o evento 9582 com freqüência.
219726 | 858 MB | Esse é o valor padrão no Exchange 2000 Server. É um bom valor para ser usado em sistemas que estejam sendo atualizados no local e que tenham muita memória virtual.
229376 | 896 MB | Esse é o valor padrão no Exchange Server 2003 e um bom valor para ser usado em sistemas novos, a não ser que o log de eventos do Aplicativo indique o contrário, com a presença de eventos 9582.
307200 | 1.2 GB | Esse é o valor máximo que você pode definir. Esse valor deve ser usado apenas em sistemas com 2 gigabytes (GB) ou mais de memória física.

Antes de reconfigurar esse valor, você deve monitorar a quantidade de memória virtual consumida pelo processo Store.exe. Você pode fazer isso monitorando o objeto de desempenho do Processo no Microsoft Windows. Em sistemas com a opção /3GB, o contador Virtual Bytes para a instância Store.exe do objeto Process deve ser menor do que 2,8 GB. Em sistemas sem a opção /3GB, o contador Virtual Bytes para a instância Store.exe do objeto Process deve ser menor que 1,8 GB. Se os valores forem maiores que essas quantidades, você pode precisar diminuir o valor de msExchESEParamCacheSizeMax. Se os valores forem menores do que isso, talvez você prefira aumentar o valor de msExchESEParamCacheSizeMax.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory® ao usar a ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você pode causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para ajustar o atributo msExchESEParamCacheSizeMax

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração.

  3. Expanda CN=Serviços.

  4. Expanda CN=Microsoft Exchange.

  5. Expanda CN=<Nome da Organização do Exchange>.

  6. Expanda CN=Grupos Administrativos.

  7. Expanda CN=<Nome do Grupo Administrativo>.

  8. Expanda CN=Servidores.

  9. Expanda CN=<Nome do Servidor Exchange>.

  10. Clique com o botão direito em CN=Armazenamento de Informações e clique em Propriedades.

  11. No campo atributos, role até msExchESEParamCacheSizeMax e clique duas vezes.

  12. No campo Valor, digite o valor que você deseja definir. Use a tabela para determinar o valor ideal para seu sistema.

  13. Clique em OK e em OK novamente.

  14. Feche o editor do Active Directory e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre como otimizar o uso da memória, consulte "Otimizando o uso da memória no Exchange Server 2003" em Planejando um sistema de mensagens para o Microsoft Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47584).

Para obter mais informações sobre o atributo msExchESEParamCacheSizeMax, consulte o artigo 266768 da Base de Dados de Conhecimento Microsoft, "Como modificar o tamanho máximo do cache do Banco de Dados de Armazenamento no Exchange 2000 Server" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


O limite máximo do destinatário foi alterado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar se o atributomsExchRecipLimit teve seu valor padrão alterado. O atributo msExchRecipLimit armazena o valor do número máximo de destinatários global para cada mensagem de email. Por padrão, o valor do atributo msExchRecipLimit é 5000. Se o Analisador do Exchange Server detectar que o valor do atributo msExchRecipLimit é diferente de 5000, exibirá uma mensagem de configuração não padrão.

O limite de destinatário máximo global se aplica a toda organização do Exchange. O valor do atributo msExchRecipLimit limita o número de destinatários para uma única mensagem de email. O limite de destinatários máximo global afeta as mensagens do sistema e as mensagens que não são do sistema. Mensagens do sistema incluem mensagens de replicação de pasta pública.

Observação:
Você também pode definir limites de destinatários para cada usuário usando Usuários e Computadores do Active Directory. A configuração para cada usuário tem precedência sobre a configuração global e substituirá a configuração global. Por padrão, o limite de destinatários por usuário é definido para usar o limite máximo de destinatários global.
Observação:
Em um servidor virtual SMTP, você pode definir um limite de número de destinatários por mensagem para mensagens recebidas de usuários da Internet. Esse limite é diferente do limite máximo de destinatários global e do limite de destinatários por usuário. O limite máximo de destinatários global e o limite de destinatários por usuário restringem o número de destinatários para os quais um usuário do Exchange pode enviar uma mensagem.
Para alterar o limite máximo de destinatários global para o valor padrão

  1. Inicie o Gerenciador do Sistema Exchange.

  2. No painel da esquerda, expanda Configurações Globais.

  3. Clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  4. Na guia Padrões, em Limites de Destinatário , clique em Máximo de Destinatários e digite 5000.

  5. Reinicie o serviço Armazenamento de Informações do Microsoft Exchange.

Para obter mais informações sobre como definir limites de destinatários e configurar clientes Microsoft Office Outlook® Web Access, consulte "Outlook Web Access S/MIME Control-Related Settings" no Exchange Server 2003 Message Security Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47574).

Para obter mais informações sobre o histórico do limite máximo de destinatários, consulte o artigo do blog do Exchange, "Eu Também!" (http://go.microsoft.com/fwlink/?LinkId=41848).


O limite máximo de destinatário está alto
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar se o valor msExchRecipLimit para mensagens excede 7.500. Se o Analisador do Exchange Server detectar que o valor do atributo msExchRecipLimit é maior que 7.500, um aviso será exibido.

O atributo msExchRecipLimit armazena o valor do número máximo de destinatários global para cada mensagem de email. O valor limita o número de destinatários para uma única mensagem de email. O valor também afeta mensagens que são ou não do sistema. Mensagens do sistema incluem mensagens de replicação de pasta pública. Por padrão, o valor do atributo msExchRecipLimit é 5000.

Se o valor do atributo msExchRecipLimit exceder 7.500, o risco de problemas causados pelas mensagens com muitos destinatários aumentará.

Observação:
Você também pode definir limites de destinatários para cada usuário usando Usuários e Computadores do Active Directory. A configuração para cada usuário tem precedência sobre a configuração global e substituirá a configuração global. Por padrão, o limite de destinatários por usuário é definido para usar o limite máximo de destinatários global.
Observação:
Em um servidor virtual SMTP, você pode definir um limite de número de destinatários por mensagem para mensagens recebidas de usuários da Internet. Esse limite é diferente do limite máximo de destinatários global e do limite de destinatários por usuário. O limite máximo de destinatários global e o limite de destinatários por usuário restringem o número de destinatários para os quais um usuário do Exchange pode enviar uma mensagem.
Para alterar o limite máximo de destinatários global para o valor padrão

  1. Inicie o Gerenciador do Sistema Exchange.

  2. No painel da esquerda, expanda Configurações Globais.

  3. Clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  4. Na guia Padrões, em Limites de Destinatário , clique em Máximo de Destinatários e digite 5000.

  5. Reinicie o serviço Armazenamento de Informações do Microsoft Exchange.

Para obter mais informações sobre como definir limites de destinatários e configurar clientes Microsoft Office Outlook® Web Access, consulte "Outlook Web Access S/MIME Control-Related Settings" no Exchange Server 2003 Message Security Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47574).

Para obter mais informações sobre a história do limite máximo de destinatários global, consulte o artigo do blog do Exchange, "Me Too!" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=41848).


O limite máximo de destinatários é muito baixo
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor msExchRecipLimit das mensagens é inferior ao número dos armazenamentos de pastas públicas na organização do Exchange. Se o Exchange Server Analyzer descobrir que o valor do atributo msExchRecipLimit é inferior ao número dos armazenamentos de pastas públicas, o Exchange Server Analyzer exibirá um erro.

O atributo msExchRecipLimit armazena o valor do número máximo de destinatários global para cada mensagem de email. O valor limita o número de destinatários para uma única mensagem de email. O valor também afeta mensagens que são ou não do sistema. Mensagens do sistema incluem mensagens de replicação de pasta pública. Por padrão, o valor do atributo msExchRecipLimit é 5000. Se o valor do atributo msExchRecipLimit for inferior ao número dos armazenamentos de pastas públicas na organização do Exchange, você terá problemas com a replicação da hierarquia de pastas públicas.

Observação:
Você também pode definir limites de destinatários para cada usuário usando Usuários e Computadores do Active Directory. A configuração para cada usuário tem precedência sobre a configuração global e substituirá a configuração global. Por padrão, o limite de destinatários por usuário é definido para usar o limite máximo de destinatários global.
Observação:
Em um servidor virtual SMTP, você pode definir um limite de número de destinatários por mensagem para mensagens recebidas de usuários da Internet. Esse limite é diferente do limite máximo de destinatários global e do limite de destinatários por usuário. O limite máximo de destinatários global e o limite de destinatários por usuário restringem o número de destinatários para os quais um usuário do Exchange pode enviar uma mensagem.
Para alterar o limite máximo de destinatários global para o valor padrão

  1. Inicie o Gerenciador do Sistema Exchange.

  2. No painel da esquerda, expanda Configurações Globais.

  3. Clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  4. Na guia Padrões, em Limites de Destinatários, clique em Máximo de Destinatários, e certifique-se de que os valores não são inferiores ao número de armazenamentos de pastas públicas na organização do Exchange.

  5. Reinicie o serviço Armazenamento de Informações do Microsoft Exchange.

Para obter mais informações sobre como definir limites de destinatários e configurar clientes Microsoft Office Outlook® Web Access, consulte "Outlook Web Access S/MIME Control-Related Settings" no Exchange Server 2003 Message Security Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47574).

Para obter mais informações sobre a história do limite máximo de destinatários global, consulte o artigo do blog do Exchange, "Me Too!" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=41848).


A chave MaxUserPort está ausente ou não é padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-23

A ferramenta Microsoft Exchange Analyzer Tool consulta o serviço de diretório do Active Directory para determinar o valor do atributo serialNumber para todos os objetos que tenham a classe msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 5.5", o computador estará executando o Exchange Server 5.5. Se o valor da cadeia de caracteres incluir "Version 6.0", o computador estará executando o Exchange 2000 Server. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador estará executando o Exchange Server 2003 e se incluir "Version 8.0", o computador estará executando o Exchange Server 2007.

Em seguida, a ferramenta Exchange Analyzer Tool lerá a ramificação do Registro mostrada abaixo para cada servidor do Exchange Server 2007 encontrado para determinar se o valor da chave MaxUserPort está definido como o padrão 60000.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

A chave MaxUserPort determina o número de porta mais alto que o TCP pode atribuir quando um aplicativo solicita uma porta de usuário disponível do sistema.

Por padrão, o Microsoft Windows Server 2003 define o valor de MaxUserPort como 5000. O Microsoft Windows 2000 não adiciona o valor de MaxUserPort ao Registro. No entanto, ele pode ser manualmente adicionado. Porém, no Windows Server 2003 e no Windows 2000 Server, o Exchange Server 2003 e o Exchange Server 2007 definem o valor padrão como 60000. O Exchange 2000 Server não define um valor.

Recomendamos que você defina o valor de MaxUserPort como 60000. Se definir MaxUserPort como um valor inferior a 60000, você poderá causar avisos de proxy NSPI (interface de provedor de serviço de nomes), como Event 9040. Event 9040 está documentado na seguinte tabela:

ID do evento | 9040
Categoria do Evento | Proxy NSPI
Origem do Evento | MSExchangeSA
Tipo de Evento | Aviso
Descrição do Evento | O Proxy NSPI encontrou um erro ao receber um pacote. O controlador de domínio de destino, a rede ou um cliente podem estar inativos. O subsistema Winsock retornou o erro:[0x2746]. O circuito que recebeu esse erro está sendo fechado.
Importante:
Este tópico contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. Clique duas vezes em MaxUserPort, defina o campo Dados do valor como 60000 (Decimal) e clique em OK.

  4. Feche o editor do Registro e reinicie o computador para que a configuração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Esse problema está relacionado ao problema do Analyzer A chave TcpTimedWaitDelay está ausente ou não é padrão.

Para obter mais informações sobre o efeito das chaves de Registro MaxUserPort e TcpTimedWaitDelay, consulte o tópico "Protocolo TCP" no Windows 2000 Resource Kit (em inglês) (http://go.microsoft.com/fwlink/?LinkId=85654).


O valor MaxUserPort é muito baixo
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte chave do Registro para determinar o valor máximo da porta TCP efêmera:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\MaxUserPort

Uma porta efêmera é uma porta usada por um breve período.

Se detectar que o valor da chave do Registro MaxUserPort é inferior a 50000, o Exchange Server Analyzer exibirá um aviso.

O valor MaxUserPort especifica o número de porta mais alto que o TCP pode atribuir quando um aplicativo solicita uma porta de usuário disponível do sistema. Em geral, o intervalo entre o número de porta 1024 e o número de porta 5000 é alocado para portas efêmeras.

Por padrão, o Microsoft Windows Server™ 2003 define o valor MaxUserPort como 5000. O Microsoft Windows® 2000 não adiciona o valor MaxUserPort ao Registro. Você pode adicionar o valor MaxUserPort manualmente ao Registro. No entanto, no Windows Server 2003 e no Windows 2000 Server, o Exchange Server 2003 define o valor padrão como 60000. O Exchange 2000 Server não define um valor.

É recomendável que você defina o valor MaxUserPort como 60000. Se definir MaxUserPort como um valor inferior a 60000, você poderá causar avisos de proxy NSPI (interface de provedor de serviço de nomes), como Event 9040. Event 9040 está documentado na tabela a seguir.

ID do Evento | 9040
Categoria do Evento | Proxy NSPI
Origem do Evento | MSExchangeSA
Tipo de Evento | Aviso
Descrição do Evento | O Proxy NSPI encontrou um erro ao receber um pacote. O controlador de domínio de destino, a rede ou um cliente podem estar inativos. O subsistema Winsock retornou o erro:[0x2746]. O circuito que recebeu esse erro está sendo fechado.

Para corrigir esse aviso, defina o valor da chave do Registro MaxUserPort como 60000.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. Clique duas vezes em MaxUserPort, defina o campo Dados do valor como ea60 (Hexadecimal) e, em seguida, clique em OK.

  4. Feche o editor do Registro e reinicie o computador para que a configuração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O arquivo MDBSZ.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para corrigir esse erro, instale o service pack ou o pacote cumulativo de atualizações mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou do Exchange Server 2003 na unidade de CD.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte "Downloads for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads for Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


O objeto do monitor de desempenho de memória não está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Available Mbytes do objeto de desempenho de Memory para analisar os dados do desempenho. Se o contador não retornar dados válidos, o Analisador do Exchange Server exibirá uma mensagem de linha de base.

Se o mecanismo de coleta de dados de desempenho não retornar dados válidos, qualquer combinação das seguintes condições será verdadeira:

  • O objeto do desempenho do Memory está desabilitado.

  • O objeto do monitor de desempenho do Memory está ausente ou danificado.

  • O Analisador do Exchange Server não tem permissões adequadas para acessar os objetos de desempenho.

As duas primeiras condições poderão ocorrer se alguns contadores extensíveis danificarem o Registro ou se programas baseados na WMI (Instrumentação de Gerenciamento do Microsoft Windows®) modificarem o Registro.

Antes de executar o procedimento, verifique se o Analisador do Exchange Server tem as permissões adequadas. Para obter mais informações sobre as permissões necessárias para executar o Analisador do Exchange Server, consulte a documentação da Ajuda incluída no Analisador do Exchange Server. Para obter Ajuda, abra o Analisador do Exchange Server e pressione a tecla F1.

Para corrigir esse erro

  1. Verifique se o objeto de desempenho do Memory está habilitado:

    1. Baixe e instale a ferramenta Lista de Contadores de Desempenho Extensíveis (Exctrlst.exe). Você pode baixar o Exctrlst.exe em Exctrlst.exe: Lista de Contadores de Desempenho Extensíveis (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Abra o Exctrlst.exe, clique em Ordem de classificação, e clique em Serviço.

    3. Localize o serviço ao qual o objeto de desempenho relata e verifique se a caixa de seleção Contadores de Desempenho Habilitados está marcada.

      Se a caixa de seleção Contadores de Desempenho Habilitados não estiver marcada, marque a caixa de seleção e reinicie o serviço que está associado aos contadores de desempenho para verificar se os contadores de desempenho estão em operação. Se os contadores de desempenho não estiverem funcionando ou se a caixa de seleção Contadores de desempenho habilitados já estava marcada, continue na etapa 2.

  2. Reconstrua os contadores de desempenho ausentes ou danificados, conforme descrito no artigo 300956 da Base de Dados de Conhecimento da Microsoft, "Como reconstruir manualmente os valores de biblioteca do contador de desempenho" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Se você seguir as instruções desse artigo da Base de Dados de Conhecimento e o problema não for solucionado, será necessário reinstalar o sistema operacional Windows no modo Reparo e então aplicar os service packs mais recentes do Windows.


O objeto do monitor de desempenho dos processos MSExchangeDSAccess não está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de LDAP Read Time do objeto de desempenho de MSExchangeDSAccess para analisar os dados do desempenho. Se o contador não retornar dados válidos, o Analisador do Exchange Server exibirá uma mensagem de linha de base.

Se o mecanismo de coleta de dados de desempenho não retornar dados válidos, qualquer combinação das seguintes condições será verdadeira:

  • O objeto do desempenho do MSExchangeDSAccess está desabilitado.

  • O objeto do monitor de desempenho do MSExchangeDSAccess está ausente ou danificado.

  • O Analisador do Exchange Server não tem permissões adequadas para acessar os objetos de desempenho.

As duas primeiras condições poderão ocorrer se alguns contadores extensíveis danificarem o Registro ou se programas baseados na WMI (Instrumentação de Gerenciamento do Microsoft Windows®) modificarem o Registro. O procedimento a seguir explica como corrigir as duas primeiras condições. Antes de executar o procedimento, verifique se o Analisador do Exchange Server tem as permissões adequadas.

Para obter mais informações sobre as permissões necessárias para executar o Analisador do Exchange Server, consulte a documentação da Ajuda incluída no Analisador do Exchange Server. Para obter Ajuda, abra o Analisador do Exchange Server e pressione a tecla F1.

Para corrigir esse erro

  1. Verifique se o objeto de desempenho do MSExchangeDSAccess está habilitado:

    1. Baixe e instale a ferramenta Lista de Contadores de Desempenho Extensíveis (Exctrlst.exe). Você pode baixar o Exctrlst.exe em Exctrlst.exe: Lista de Contadores de Desempenho Extensíveis (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Abra o Exctrlst.exe, clique em Ordem de classificação, e clique em Serviço.

    3. Localize o serviço ao qual o objeto de desempenho relata e verifique se a caixa de seleção Contadores de Desempenho Habilitados está marcada.

      Se a caixa de seleção Contadores de Desempenho Habilitados não estiver marcada, marque a caixa de seleção e reinicie o serviço que está associado aos contadores de desempenho para verificar se os contadores de desempenho estão em operação. Se os contadores de desempenho não estiverem funcionando ou se a caixa de seleção Contadores de desempenho habilitados já estava marcada, continue na etapa 2.

  2. Reconstrua os contadores de desempenho ausentes ou danificados, conforme descrito no artigo 300956 da Base de Dados de Conhecimento da Microsoft, "Como reconstruir manualmente os valores de biblioteca do contador de desempenho" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Se você seguir as instruções desse artigo da Base de Dados de Conhecimento e o problema não for solucionado, será necessário reinstalar o sistema operacional Exchange Server no modo Reparo e então aplicar os service packs mais recentes do Exchange Server.


O objeto do monitor de desempenho da Caixa de Correio MSExchangeIS não está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Send Queue Size do objeto de desempenho de MSExchangeIS Mailbox para analisar os dados do desempenho. Se o contador não retornar dados válidos, o Analisador do Exchange Server exibirá uma mensagem de linha de base.

Se o mecanismo de coleta de dados de desempenho não retornar dados válidos, qualquer combinação das seguintes condições será verdadeira:

  • O objeto do desempenho do MSExchangeIS Mailbox está desabilitado.

  • O objeto do monitor de desempenho do MSExchangeIS Mailbox está ausente ou danificado.

  • O Analisador do Exchange Server não tem permissões adequadas para acessar os objetos de desempenho.

As duas primeiras condições poderão ocorrer se alguns contadores extensíveis danificarem o Registro ou se programas baseados na WMI (Instrumentação de Gerenciamento do Microsoft Windows®) modificarem o Registro.

Antes de executar o procedimento, verifique se o Analisador do Exchange Server tem as permissões adequadas. Para obter mais informações sobre as permissões necessárias para executar o Analisador do Exchange Server, consulte a documentação da Ajuda incluída no Analisador do Exchange Server. Para obter Ajuda, abra o Analisador do Exchange Server e pressione a tecla F1.

Para corrigir esse erro

  1. Verifique se o objeto de desempenho do MSExchangeIS Mailbox está habilitado:

    1. Baixe e instale a ferramenta Lista de Contadores de Desempenho Extensíveis (Exctrlst.exe). Você pode baixar o Exctrlst.exe em Exctrlst.exe: Lista de Contadores de Desempenho Extensíveis (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Abra o Exctrlst.exe, clique em Ordem de classificação, e clique em Serviço.

    3. Localize o serviço ao qual o objeto de desempenho relata e verifique se a caixa de seleção Contadores de Desempenho Habilitados está marcada.

      Se a caixa de seleção Contadores de Desempenho Habilitados não estiver marcada, marque a caixa de seleção e reinicie o serviço que está associado aos contadores de desempenho para verificar se os contadores de desempenho estão em operação. Se os contadores de desempenho não estiverem funcionando ou se a caixa de seleção Contadores de desempenho habilitados já estava marcada, continue na etapa 2.

  2. Reconstrua os contadores de desempenho ausentes ou danificados, conforme descrito no artigo 300956 da Base de Dados de Conhecimento da Microsoft, "Como reconstruir manualmente os valores de biblioteca do contador de desempenho" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Se você seguir as instruções desse artigo da Base de Dados de Conhecimento e o problema não for solucionado, será necessário reinstalar o sistema operacional Exchange Server no modo Reparo e então aplicar os service packs mais recentes do Exchange Server.


O objeto do monitor de desempenho do MSExchangeIS não está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-03

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de RPC Operations/sec do objeto de desempenho de MSExchangeIS para analisar os dados do desempenho. Se o contador não retornar dados válidos, o Analisador do Exchange Server exibirá uma mensagem de linha de base.

Se o mecanismo de coleta de dados de desempenho não retornar dados válidos, qualquer combinação das seguintes condições será verdadeira:

  • O objeto do desempenho do MSExchangeIS está desabilitado.

  • O objeto do monitor de desempenho do MSExchangeIS está ausente ou danificado.

  • O Analisador do Exchange Server não tem permissões adequadas para acessar os objetos de desempenho.

As duas primeiras condições poderão ocorrer se alguns contadores extensíveis danificarem o Registro ou se programas baseados na WMI (Instrumentação de Gerenciamento do Microsoft Windows®) modificarem o Registro. Antes de executar o procedimento, verifique se o Analisador do Exchange Server tem as permissões adequadas. Para obter mais informações sobre as permissões necessárias para executar o Analisador do Exchange Server, consulte a documentação da Ajuda incluída no Analisador do Exchange Server. Para obter Ajuda, abra o Analisador do Exchange Server e pressione a tecla F1.

Para corrigir esse erro

  1. Verifique se o objeto de desempenho do MSExchangeIS está habilitado:

    1. Baixe e instale a ferramenta Lista de Contadores de Desempenho Extensíveis (Exctrlst.exe). Você pode baixar o Exctrlst.exe em Exctrlst.exe: Lista de Contadores de Desempenho Extensíveis (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Abra o Exctrlst.exe, clique em Ordem de classificação, e clique em Serviço.

    3. Localize o serviço ao qual o objeto de desempenho relata e verifique se a caixa de seleção Contadores de Desempenho Habilitados está marcada.

      Se a caixa de seleção Contadores de Desempenho Habilitados não estiver marcada, marque-a e reinicie o serviço associado aos contadores de desempenho, para verificar se eles estão funcionando. Se os contadores de desempenho não estiverem funcionando ou se a caixa de seleção Contadores de desempenho habilitados já estava marcada, continue na etapa 2.

  2. Reconstrua os contadores de desempenho ausentes ou danificados, conforme descrito no artigo 300956 da Base de Dados de Conhecimento da Microsoft, "Como reconstruir manualmente os valores de biblioteca do contador de desempenho" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Se você seguir as instruções desse artigo da Base de Dados de Conhecimento e o problema não for solucionado, será necessário reinstalar o sistema operacional Exchange Server no modo Reparo e então aplicar os service packs mais recentes do Exchange Server.

Para obter mais informações sobre como solucionar problemas de conectividade da ferramenta Exchange Best Practices Analyzer, consulte "Solucionando problemas de conectividade da ferramenta Microsoft Exchange Best Practices Analyzer " (http://go.microsoft.com/fwlink/?LinkId=56285).


O objeto do monitor de desempenho do MSExchangeIS Public não está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Send Queue Size do objeto de desempenho de MSExchangeIS Public para analisar os dados do desempenho. Se o contador não retornar dados válidos, o Analisador do Exchange Server exibirá uma mensagem de linha de base.

Se o mecanismo de coleta de dados de desempenho não retornar dados válidos, qualquer combinação das seguintes condições será verdadeira:

  • O objeto do desempenho do MSExchangeIS Public está desabilitado.

  • O objeto do monitor de desempenho do MSExchangeIS Public está ausente ou danificado.

  • O Analisador do Exchange Server não tem permissões adequadas para acessar os objetos de desempenho.

As duas primeiras condições poderão ocorrer se alguns contadores extensíveis danificarem o Registro ou se programas baseados na WMI (Instrumentação de Gerenciamento do Microsoft Windows®) modificarem o Registro. Antes de executar o procedimento, verifique se o Analisador do Exchange Server tem as permissões adequadas. Para obter mais informações sobre as permissões necessárias para executar o Analisador do Exchange Server, consulte a documentação da Ajuda incluída no Analisador do Exchange Server. Para obter Ajuda, abra o Analisador do Exchange Server e pressione a tecla F1.

Para corrigir esse erro

  1. Verifique se o objeto de desempenho do MSExchangeIS Public está habilitado:

    1. Baixe e instale a ferramenta Lista de Contadores de Desempenho Extensíveis (Exctrlst.exe). Você pode baixar o Exctrlst.exe em Exctrlst.exe: Lista de Contadores de Desempenho Extensíveis (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Abra o Exctrlst.exe, clique em Ordem de classificação, e clique em Serviço.

    3. Localize o serviço ao qual o objeto de desempenho relata e verifique se a caixa de seleção Contadores de Desempenho Habilitados está marcada.

      Se a caixa de seleção Contadores de Desempenho Habilitados não estiver marcada, marque a caixa de seleção e reinicie o serviço que está associado aos contadores de desempenho para verificar se os contadores de desempenho estão em operação. Se os contadores de desempenho não estiverem funcionando ou se a caixa de seleção Contadores de desempenho habilitados já estava marcada, continue na etapa 2.

  2. Reconstrua os contadores de desempenho ausentes ou danificados, conforme descrito no artigo 300956 da Base de Dados de Conhecimento da Microsoft, "Como reconstruir manualmente os valores de biblioteca do contador de desempenho" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Se você seguir as instruções desse artigo da Base de Dados de Conhecimento e o problema não for solucionado, será necessário reinstalar o sistema operacional Exchange Server no modo Reparo e então aplicar os service packs mais recentes do Exchange Server.


Atualização do driver MSGINA.DLL disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-08-21

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar a versão do Microsoft Windows® em execução no servidor do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor de CurrentVersion igual a 4.0 indica que o servidor Exchange está executando o Microsoft Windows NT® Server 4.0. Um valor 5.0 indica que o servidor Exchange está executando o Windows 2000 Server. Um valor 5.2 indica que o servidor Exchange está executando o Windows Server™ 2003.

O Exchange Server Analyzer também examina a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®), Win32_OperatingSystem, para conhecer o valor da chave ServicePackMajorVersion.

Uma chave ServicePackMajorVersion com o valor 1 indica que o servidor tem o Service Pack 1 (SP1) instalado.

Por último, o Exchange Server Analyzer consulta a classe WMI CIM_Datafile para determinar o valor da chave Version para o arquivo Msgina.dll.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O servidor está executando o Windows Server™ 2003 SP1.

  • O número da compilação do arquivo Msgina.dll é inferior a 5.2.3790.2525.

Esse erro indica que a versão do Msgina.dll instalada no servidor pode ocasionar uma atividade excessiva do arquivo de paginação e prejudicar o desempenho.

Para resolver esse problema, obtenha a atualização citada no artigo 905865 da Base de Dados de Conhecimento Microsoft, "Os tamanhos dos conjuntos de trabalho de todos os processos em uma sessão do console podem ser ajustados quando se utiliza o Terminal Services para fazer logon em ou logoff de um computador executando o Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905865) (em inglês).


Parâmetro solicitado de log MTA APDU é não padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\APDU logging required

Se o Exchange Server Analyzer encontrar o valor para Log APDU necessário presente e configurado com qualquer valor diferente de 0, será exibida uma mensagem de configuração não padrão.

Logs de texto de APDU (Unidade de Dados de Protocolo do Aplicativo) são representações binárias de comunicação entre MTAs (agentes de transferência de mensagens) do Exchange em sites diferentes e entre aplicativos cliente e MTAs dentro de um site. Logs de APDU podem sem úteis para diagnosticar problemas com o MTA. No entanto, eles são úteis apenas para os que são familiarizados com conversões ASCII do protocolo X.400.

Quando o parâmetro de Registro Log de APDU necessário está presente e configurado com um valor de 0, todos os APDUs enviados ou recebidos pelo MTA são registrados como dados binários em MTADATA\BF*.LOG.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como editar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão de log de APDU MTA

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel da direita, localize e clique duas vezes no valor Log de APDU necessário.

  4. No campo de dados Valor, digite 0 e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre logs de APDU, consulte o artigo 163324 da Base de Dados de Conhecimento, "XCOM: Logs (BF0.LOG) de APDU (Unidade de Dados de Protocolo do Aplicativo)" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=163324).


O parâmetro de diagnóstico de pilha de chamadas do MTA necessário é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Call-stack diagnostics required

Se o Exchange Server Analyzer detectar que o valor de Call-stack diagnostics required está presente e definido como diferente de 1, uma mensagem de configuração não-padrão será exibida.

O valor de registro Call-stack diagnostics required é usado somente para fins de depuração avançada e é lido apenas por uma versão de depuração do MTA (agente de transferência de mensagens). Seus dados de valor devem ser definidos sempre como 1. Quando uma versão de depuração do MTA for usada, esse valor fornecerá uma pilha de chamadas para cada thread do MTA no momento do encerramento.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel da direita, localize e clique duas vezes no valor Call-stack diagnostics required.

  4. No campo de dados Valor, digite 1 e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Incompatibilidade de nome do Computador MTA
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar a configuração do valor do Computador MTA (agente de transferência de mensagens): HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor do atributo name para cada objeto do servidor Exchange.

Finalmente, o Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started do serviço de Cluster (ClusSvc). Um valor True indica que o serviço de Cluster foi inicializado e um valor False indica que o serviço de Cluster não está em execução.

Se o Exchange Server Analyzer verificar que o valor da chave do Computador MTA não corresponde ao valor do atributo name do objeto de servidor no Active Directory em qualquer computador do Exchange Server que não esteja em execução em um cluster do Windows Server, será exibido um erro.

Para corrigir esse erro, edite a chave de Registro MTA Computer para que corresponda ao valor do atributo name no Active Directory.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como editar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel da direita, clique duas vezes no Computador MTA, digite o nome correto desse computador e clique em OK.

  4. Feche o editor do Registro e reinicie o computador do Exchange Server para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Conexões simultâneas do MTA para parâmetro LAN-MTAs é não-padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to LAN-MTAs

Se o Exchange Server Analyzer detectar o valor de Conexões simultâneas para LAN-MTAs presente e definido como qualquer valor que não seja 0x28 (hex) ou 40 (decimal), uma mensagem de configuração não padrão será exibida.

O valor de Registro de Conexões simultâneas para LAN-MTAs determina o número máximo de conexões simultâneas para os agentes de transferência de mensagens (MTAs) pela rede local (LAN). Os MTAs que se comunicam por uma LAN são conhecidos como LAN-MTAS. O MTA local pode ter várias conexões com um MTA remoto, dependendo da configuração e da carga do sistema. O número máximo de conexões MTAs baseadas em LAN simultâneas é 240.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão de Conexões simultâneas de MTAs

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique duas vezes no valor de Conexões simultâneas para LAN-MTAs.

  4. Verifique se Base está definido como hexadecimal e, no campo Dados do valor, digite 28 e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o número máximo de conexões MTA simultâneas baseadas em LAN, consulte o artigo 243402 da Base de Dados de Conhecimento, "XCON: Exchange Server MTA - Identificação do evento 9280" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=243402).


O parâmetro de Conexões simultâneas do MTA para gateways X.400 é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent conexões com gateways X.400

Se o Exchange Server Analyzer verificar que o valor para Conexões Simultâneas com Gateways X.400 está presente e definido como qualquer número diferente de 6, uma mensagem de configuração não padrão será exibida.

O valor do Registro Conexões Simultâneas com Gateways X.400 é o número máximo de conexões simultâneas com MTAs (agentes de transferência de mensagens) X.400 remotos. O valor padrão de 6 é suficiente para maior parte das organizações. Há um problema conhecido quando você usa mais de 4 Conectores EDK em um servidor que está executando o Exchange Server versão 5.5 que requer que o valor de Conexões Simultâneas com Gateways X.400 seja aumentado para 0x12 (hexadecimal) ou 18 (decimal). Para obter mais informações sobre esse problema, consulte o artigo 282115 da Base de Dados de Conhecimento Microsoft, "Se houver mais de 4 conectores EDK instalados, o fluxo de mensagens é interrompido" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=282115). A não ser que o problema descrito nesse artigo esteja ocorrendo, deixe o valor do Registro Conexões Simultâneas com Gateways X.400 definido como 6.

Para corrigir isso, reverta para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel da direita, localize e clique duas vezes sobre o valor Conexões Simultâneas com Gateways X.400.

  4. No campo de dados Valor, digite 6 e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O parâmetro clientes da fila de entrega/MDB simultâneos de MTA é não padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent MDB/delivery queue clients

Se o Exchange Server Analyzer detectar o valor Clientes de fila de entrega MDB/simultâneos presente e definido como algo diferente de 3, uma mensagem de configuração não padrão será exibida.

O valor de Clientes de fila de entrega MDB/simultâneos é o número máximo de MDB (banco de dados de mensagens) e dos clientes da fila de entrega de acesso às mensagens da API do Exchange que o MTA (agente de transferência de mensagens) pode ter suporte. Cada cliente pode ter mais de uma sessão. Esse valor deve ser definido como pelo menos dois, para dar suporte às entidades MDB particulares e públicas.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique duas vezes no valor Clientes de fila de entrega MDB/simultâneos.

  4. No campo de dados Valor, digite 3 e clique em OK.

  5. Saia do editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Os arquivos de dados do MTA estão sendo gravados em uma pasta compactada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Directory do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave Compactado para o caminho dos dados do MTA (agente de transferência de mensagens). Se o Exchange Server Analyzer determinar que o valor para a chave Compressed é True, um erro será exibido.

A Microsoft não oferece suporte para o armazenamento de arquivos de dados do Exchange em um volume de sistema de arquivos NTFS compactado. Quando você armazena seus arquivos de dados do Exchange em um volume compactado, a sobrecarga adicional afeta significativamente o desempenho do Exchange. Além disso, quando um banco de dados de armazenamento do Exchange atinge um determinado tamanho (aproximadamente 4 GB), a sua montagem poderá falhar ou ele poderá ficar danificado.

Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Arquivos que são gerenciados pelo ESE (Mecanismo de Armazenamento Extensível) não devem ser armazenados em uma unidade compactada. O Mecanismo de Armazenamento Extensível (ESE) depende da independência de setor para a recuperação baseada em log, e a compactação de arquivos invalida essa independência. A compactação não deve ser ativada para os volumes que hospedam bancos de dados ESE, ou qualquer banco de dados que usa o log de write-ahead.

Antes do Exchange 2000 Server Service Pack 3, era possível montar bancos de dados compactados de armazenamento do Exchange. Contudo, podem ocorrer danos em bancos de dados ou logs de armazenamento do Exchange do Exchange 2000 compactados por meio da compactação NTFS.

Com o Exchange 2000 Server Service Pack 3, arquivos do banco de dados de armazenamento de informações compactados de 128 megabytes (MB) ou menos são descompactados automaticamente. Quando os arquivos de banco de dados atingem um tamanho acima de 128 MB, o banco de dados não é montado e são geradas mensagens de erro no log do aplicativo. O Exchange 2000 Server Service Pack 3 impede a montagem de bancos de dados compactados com mais de 128 MB.

Para desligar a compactação de arquivos em uma pasta especificada

  1. Clique com o botão direito na pasta em que você deseja desativar a compactação de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Compactar o conteúdo para economizar espaço em disco e clique em OK.

Para mover o local dos arquivos de banco de dados do MTA

  1. No Exchange Server versão 5.5, é possível mover os arquivos de bancos de dados do MTA usando a ferramenta Otimizador de Desempenho. Para obter mais informações sobre fazer isso no Exchange 2000 Server ou no Exchange Server 2003, consulte o artigo 259896 da Base de Dados de Conhecimento da Microsoft, "XCON: Como alterar o local dos diretórios Banco de Dados e Execução do MTA" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259896).

Para obter mais informações sobre compressão de NTFS e arquivos de dados do Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 170009, "XADM: NTFS Compressed Volume Causes Store to Fail" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009)

  • 327772, "XADM: Database Does Not Mount and You Receive Error 0xfffff05b After You Apply SP3" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772)


Os arquivos de dados do MTA estão sendo gravados em uma pasta criptografada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-17

O Microsoft® Exchange Server Analyzer consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Directory para determinar o valor da chave Criptografado para o caminho dos dados do MTA (agente de transferência de mensagens). Se o Exchange Server Analyzer detectar que o valor dessa chave é Verdadeiro, um erro será exibido.

Em um computador do Exchange 2000 Server ou do Exchange Server 2003, os arquivos MTA são gravados no seguinte local padrão:

<unidade> :\Arquivos de Programas\Exchsrvr\MTAdata

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em um volume criptografado com EFS (Sistema de Criptografia de Arquivos). Quando você armazena seus arquivos de dados do Exchange em um volume criptografado, a sobrecarga afeta significativamente o desempenho do Exchange. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Para ajudar a proteger seus arquivos de dados do Exchange, é recomendável que você impeça o acesso não autorizado ao computador do Exchange e que você use o formato de mensagem S/MIME para criptografar dados de mensagens.

Para desativar a criptografia de arquivos em uma pasta especificada

  1. Clique com o botão direito na pasta em que deseja desativar a compactação de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Criptografar o conteúdo para proteger dados e clique em OK.

Para obter mais informações sobre arquivos de dados do Exchange Server e EFS, consulte o artigo 834638 da Base de Dados de Conhecimento Microsoft, "Informações sobre o armazenamento de arquivos de dados em um volume criptografado no Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Para obter informações sobre como proteger mensagens no Microsoft Exchange Server 2003, consulte o Guia de Segurança de Mensagens do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=47574).


Os arquivos de dados do MTA estão sendo gravados em uma partição não-NTFS
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Directory para determinar o valor da chave FSName da pasta de dados do MTA (agente de transferência de mensagens) do Exchange: Se o Exchange Server Analyzer determinar que o valor FSName para a chave não é igual a NTFS, será exibido um erro.

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em volumes não-NTFS. Os arquivos de dados do Exchange incluem todos os arquivos a seguir:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Se você encontrar esse erro, deverá mover a pasta de dados do MTA para uma unidade NTFS. Como alternativa, se a unidade em que a pasta de dados do MTA está armazenada estiver formatada como FAT (File Allocation Table), você poderá usar a ferramenta de linha de comando convert.exe para converter a unidade em NTFS.

Para mover a pasta mtadata do Exchange

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda os Grupos Administrativos, expanda seu grupo administrativo, expanda Servidores, clique com o botão direito em seu grupo de armazenamento e clique em Propriedades.

  3. Na página de propriedades do grupo de armazenamento, ao lado do campo Local do caminho do sistema, clique em Procurar.

  4. Digite o novo caminho para a pasta mtadata e clique em OK.

  5. Clique em OK.

Como alternativa para esse procedimento, se a unidade na qual os arquivos estão armazenados estiver formatada como uma unidade FAT, você poderá usar a ferramenta de linha de comando convert.exe para converter a unidade em NTFS. Para obter mais informações sobre como usar a ferramenta de linha de comando convert.exe para converter uma partição FAT em uma partição NTFS, consulte o artigo 214579 da Base de Dados de Conhecimento da Microsoft, "Como usar o convert.exe para converter uma partição no sistema de arquivo NTFS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


O parâmetro do MTA Buffers de dados de BD por objeto não é padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB data buffers per object

Se o Exchange Server Analyzer localizar o valor de Buffers de dados de BD por objeto presente e maior que zero mas definido com um valor diferente de 3 ou 6, uma mensagem de configuração não padrão será exibida.

O Valor de buffers de dados de BD por objeto é o número de buffers de banco de dados de 4 quilobytes (KB) que estão configurados para cada objeto de banco de dados. Mais buffers exigem mais memória, mas torna menos provável que um objeto de banco de dados seja revertida para o disco devido a uma falta de espaço em buffer. Uma razão recomendada para a alteração desse valor é no caso em que um MTA (agente de transferência de mensagem) se comunica com vários computadores do Exchange Server version 5.5 dentro de um site, ou entre sites. É recomendado que você altere o valor para 6. Se esse MTA não atender a esses critérios, você deverá alterar o valor de volta à configuração padrão de 3.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique duas vezes no valor Buffers de dados do BD por objeto.

  4. No campo de dados Valor, digite 3 e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O parâmetro do MTA Manipuladores de Arquivos de BD não é padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB file handles

Se o Exchange Server Analyzer encontrar o valor de Identificadores de arquivos de BD presente e definido com qualquer outro valor diferente de 192, uma mensagem de configuração não padrão será exibida.

O valor de Identificadores de arquivos de BD é o número de identificadores de arquivo de servidor de banco de dados configurados. Isso determina o número máximo de arquivos de banco de dados que podem ser abertos simultaneamente. Se mais arquivos abertos forem necessários que o valor configurado, os objetos de banco de dados serão copiados no disco.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel da direita, localize e clique duas vezes no valor Identificadores de arquivos de BD.

  4. No campo de dados Valor, digite 192 e clique em OK.

  5. Saia do editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Nível de Log de Diagnóstico do MTA é maior que 5 (o MTA está no modo de depuração)
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool lê uma série de chaves do Registro para determinar o nível de log de diagnóstico do MTA (agente de transferência de mensagens) definido no servidor Exchange. As chaves de Registro residem em:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

O valor padrão para essas chaves é 0. Se o Exchange Server Analyzer verificar que o valor de qualquer uma dessas chaves é maior que 5, um erro será exibido.

Essas chaves de Registro são definidas pelo Gerenciador do Sistema do Exchange quando você ajusta os níveis de log na guia Log de Diagnóstico da página de propriedades de um servidor específico. O Gerenciador do Sistema do Exchange permite que um administrador defina um nível de log especificado como Nenhum, Mínimo, Médio e Máximo. Os valores correspondentes das chaves de registro são, respectivamente, 0, 1, 3 ou 5.

Portanto, um valor maior que 5 só pode ser definido editando manualmente o Registro, e só deve ser definido com esse nível nas horas que não sejam de pico para depuração e solução de problemas de curto prazo. Definir essas chaves para inteiros maiores que 5 aumenta o log para níveis de depuração, que utilizam muitos recursos. Além do log do nível de depuração, definir essas chaves com valor maior de 5 resultará em um arquivo de rastreamento de depuração "call.out" a cada período de alguns segundos, de poucos em poucos segundos, que tem cerca de 40 megabytes (MB) de tamanho. Isso pode preencher o log de eventos do computador em menos de um minuto.

A tabela a seguir mostra as categorias de log do MTA como são listadas na guia Log de Diagnóstico no Gerenciador do Sistema do Exchange e seus nomes de chave correspondentes no Registro.

Categoria como exibida no Gerenciador do Sistema do Exchange | Nome correspondente de chave de Registro
Serviço X.400 | Serviço 1 X.400
Recurso | 2 Recurso
Segurança | 3 Segurança
Interface | 4 Interface
Engenharia de Campo | 5 Engenharia de Campo
Administração do MTA | 6 Administração do MTA
Configuração | 7 Configuração
Acesso ao Diretório | 8 Acesso ao Diretório
Sistema operacional | 9 Sistema Operacional
Processamento Interno | 10 Processamento Interno
Interoperabilidade | 11 Interoperabilidade
APDU (Unidade de Dados de Protocolo do Aplicativo) | 12 APDU

A referência no final deste artigo fornece mais informações sobre o que cada categoria do MTA registra no log.

É recomendável que você defina o log para cada categoria de MTA como Nenhum (0), a menos que você esteja solucionando problemas ativamente. O motivo desta recomendação é manter um número de eventos gerenciável sendo registrados em log. Mesmo o nível Mínimo (1) provavelmente produzirá centenas de logs de eventos em alguns dias, dependendo da categoria em que esse nível está definido.

Se você não estiver solucionando problemas no momento, é provável que esses valores tenham sido definidos com valores mais altos durante um exercício de solução de problemas e deixados assim inadvertidamente. Você deve definir esses valores pelo menos como Máximo (5), mas você deve experimentar definir o nível de log como Nenhum (0) para cada categoria de log de diagnóstico MTA, a menos que esteja solucionando problemas ativamente.

Para definir as categorias do Log de Diagnóstico MTA como nenhum

  1. Iniciar o Gerenciador do Sistema do Exchange: Clique em Iniciar, aponte para Todos os Programas, aponte para Microsoft Exchange e clique em Gerenciador do Sistema.

  2. Na árvore do console, expanda Servidores, expanda o servidor desejado e clique em Propriedades.

  3. Em <> Propriedades do Servidor, clique em Log de Diagnóstico.

  4. Em Serviços, clique em MSExchangeMTA.

  5. Para cada entrada em Categorias, defina o nível de log como nenhum, selecionando a categoria e, em seguida, selecionando Nenhum em Nível de log.

  6. Quando você tiver definido todas as categorias como Nenhum, clique em Aplicar e em OK.

Para obter mais informações sobre o log de diagnóstico MTA no Exchange 2000 Server e Exchange Server 2003, consulte o artigo 163033 da Base de Dados de Conhecimento Microsoft, "XCON: Descrição de categorias de diagnóstico para o MTA" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033) (em inglês).

Para obter mais informações sobre o log de diagnóstico MTA no Exchange Server versão 5.5, consulte o artigo 163032 da Base de Dados de Conhecimento, "XCON: Descrição de Log de diagnóstico para o MTA" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032) (em inglês).


Nível de log de Diagnóstico do MTA é diferente de zero
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool lê uma série de chaves do Registro para determinar o nível de log de diagnóstico do MTA (agente de transferência de mensagens) definido no servidor Exchange. As chaves de Registro residem em:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

O valor padrão para essas chaves é 0. Se o Exchange Server Analyzer verificar que o valor de alguma dessas chaves é superior a 1, mas inferior a 6, uma mensagem de configuração não padrão será exibida.

Essas chaves de Registro são definidas pelo Gerenciador do Sistema do Exchange quando você ajusta os níveis de log na guia Log de Diagnóstico da página de propriedades de um servidor especificado. O Gerenciador do Sistema do Exchange permite que um administrador defina um determinado nível de log como Nenhum, Mínimo, Médio e Máximo. Os valores correspondentes das chaves de Registro são, respectivamente, 0, 1, 3 ou 5.

A tabela a seguir mostra as categorias de log do MTA como são listadas na guia Log de Diagnóstico no Gerenciador do Sistema do Exchange e seus nomes de chave correspondentes no Registro.

Categoria como exibida no Gerenciador do Sistema do Exchange | Nome correspondente de chave de Registro
Serviço X.400 | Serviço 1 X.400
Recurso | 2 Recurso
Segurança | 3 Segurança
Interface | 4 Interface
Engenharia de Campo | 5 Engenharia de Campo
Administração do MTA | 6 Administração do MTA
Configuração | 7 Configuração
Acesso ao Diretório | 8 Acesso ao Diretório
Sistema operacional | 9 Sistema Operacional
Processamento Interno | 10 Processamento Interno
Interoperabilidade | 11 Interoperabilidade
APDU (Unidade de Dados de Protocolo do Aplicativo) | 12 APDU

A referência no final deste artigo fornece mais informações sobre o que cada categoria do MTA registra no log.

A prática recomendada geral para log de diagnóstico é definir o log de cada categoria do MTA como Nenhum (0), a menos que você esteja solucionando problemas ativamente. O motivo desta recomendação é manter um número de eventos gerenciável sendo registrados em log. Mesmo o nível Mínimo (1) provavelmente produzirá centenas de logs de eventos em alguns dias, dependendo da categoria em que esse nível está definido.

Se você não estiver solucionando problemas no momento, é provável que esses valores tenham sido definidos com valores mais altos durante um exercício de solução de problemas e deixados assim de forma não intencional. Considere a definição do nível de log como Nenhum (0) para cada categoria de log de diagnóstico do MTA.

Para corrigir esse erro no Exchange Server 2003 ou no Exchange 2000 Server

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Na árvore do console, expanda Servidores, expanda o servidor desejado e clique em Propriedades.

  3. Em <> Propriedades doServidor, clique na guia Log de Diagnóstico.

  4. Em Serviços, selecione MSExchangeMTA.

  5. Para cada entrada em Categorias, defina o nível de log como nenhum, selecionando a categoria e, em seguida, selecionando Nenhum em Nível de log.

  6. Quando você tiver definido todas as categorias como Nenhum, clique em Aplicar e em OK.

Para corrigir esse erro no Exchange Server versão 5.5

  1. Inicie o programa Administrador do Microsoft Exchange Server.

  2. Abra o objeto que representa o servidor que está tendo dificuldades com o MTA.

  3. Clique duas vezes no objeto do Agente de Transferência de Mensagens no painel direito.

  4. Na guia Log de Diagnóstico, selecione o Serviço X.400 e clique em Máximo.

  5. Selecione Recurso.

  6. Mantenha pressionada a tecla CTRL e clique em cada recurso que você deseja depurar.

  7. Clique em Opção para obter o nível de log Nenhum.

  8. Clique em OK.

Para obter mais informações sobre log de diagnóstico do MTA no Exchange 2000 Server, consulte a Base de Dados de Conhecimento Microsoft, artigo 163033, "XCON: Descrição de categorias de diagnóstico para o MTA" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033) (em inglês).

Para obter mais informações sobre como reverter o log de diagnóstico do MTA no Exchange Server 5.5, consulte a Base de Dados de Conhecimento Microsoft, artigo 168906, "XCON: Configuração de log avançado nos MTAs do Exchange 5.0 e 5.5" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168906).

Para obter mais informações sobre log de diagnóstico do MTA no Exchange Server 5.5, consulte a Base de Dados de Conhecimento, artigo 163032, "XCON: Descrição das categorias de diagnóstico para o MTA" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032).


O parâmetro de threads de Distribuidor do MTA é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

Mensagem de Erro

Introdução

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Dispatcher threads

Se o Exchange Server Analyzer detectar que o valor de Dispatcher threads está presente e é maior do que 0, mas está definido como um valor diferente de 1 ou 2, será exibida uma mensagem de configuração não-padrão.

O valor de Dispatcher threads é o número de threads de Distribuidor do MTA (agente de transferência de mensagem). Esse valor é multiplicado por 3 para os três subtipos (Router, Fanout, Result) do thread de Distribuidor. Um motivo recomendado para alterar esse valor é quando um MTA se comunica com mais de cinco computadores do Exchange Server versão 5.5 dentro de um site, ou entre sites, ou se as listas de distribuição tiverem uma alta utilização. Nesse caso, é recomendável alterar o valor para 3. Se esse MTA não atender a esse critério, restaure o valor para sua configuração padrão de 1.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel da direita, localize e clique duas vezes no valor de Dispatcher threads.

  4. No campo de dados Valor, digite 1 e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O MTA não está sendo executa na conta LocalSystem
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave StartName para o serviço Pilhas MTA do Microsoft Exchange. O Exchange Server Analyzer consulta também o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber do objeto do Exchange Server no diretório. O atributo serialNumber do objeto do Exchange Server identifica a versão do Exchange Server que está sendo executada no computador representado pelo objeto. Se o valor da chave StartName for diferente de LocalSystem em um servidor Exchange que executa o Exchange 2000 Server ou o Exchange Server 2003, um erro será exibido.

A execução do serviço Pilhas MTA do Exchange em qualquer outra conta causará erros de permissão e de acesso, e não há suporte para essa configuração.

Para resolver o erro, configure o serviço Pilhas MTA do Exchange para ser iniciado na conta LocalSystem (conhecida também como SYSTEM).

Observação:
Esse erro não se aplica ao Exchange Server versão 5.5. Somente o Exchange 2000 Server e o Exchange Server 2003 exigem a execução do serviço Pilha MTA do Exchange na conta LocalSystem.

Para configurar a conta de serviço do Exchange MTA Stacks

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. Localize e pare o serviço Pilhas MTA do Microsoft Exchange.

  3. Clique duas vezes no serviço Microsoft Exchange MTA Stacks.

  4. Na guia Fazer logon da página Propriedades de Pilhas MTA do Microsoft Exchange, selecione Conta LocalSystem em Fazer logon como e clique em Aplicar.

  5. Em Status do Serviço, clique em Iniciar e clique em OK.

  6. Feche o snap-in Serviços.

Para obter mais informações sobre como executar os serviços do Exchange na conta LocalSystem, consulte o artigo 239762 da Base de Dados de Conhecimento da Microsoft, "Serviços do Exchange Executam no LocalSystem" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


O parâmetro de threads do Kernel do MTA é não padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Kernel threads

Se o Analisador do Exchange Server detectar que o valor de Threads do kernel está presente e é maior que 0, mas está definido como algo diferente de 1 ou 3, uma mensagem de configuração não padrão será exibida.

O valor de Threads do kernel é o número de threads da plataforma que manipulam o nível Apresentação e Sessão da pilha OSI (Interconexão de Sistemas Abertos). Esses threads são o núcleo do processamento de mensagens do MTA (agente de transferência de mensagens). Se esse MTA se comunica com muitos outros servidores Exchange Server versão 5.5 usando RPC (chamada de procedimento remoto) sobre conexões de rede altamente latentes ou lentas, é recomendável que você use um valor listado na tabela a seguir.

Valor | Descrição
0x3 (hex) | Recomendação padrão. Use isso para qualquer MTA que se comunica com outros servidores Exchange Server 5.5 que usam RPC sobre conexões de rede lentas ou altamente latentes.
0x8 (hex) | Use isso para MTAs do Exchange 2000 Server ou Exchange Server 2003 que pertençam a um site contendo mais de 15 computadores do Exchange Server 5.5.
0xC (hex) | Use isso para MTAs do Exchange 2000 Server ou Exchange Server 2003 que pertençam a um site contendo mais de 30 computadores do Exchange Server 5.5.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como editar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar o valor de Threads do kernel

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique duas vezes no valor Threads do kernel.

  4. No campo de dados Valor, insira o valor apropriado para sua organização e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O parâmetro LAN-MTAs do MTA é não-padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\LAN-MTAs

Se o Analisador do Exchange Server detectar a presença do valor LAN-MTAs e defini-lo para algo diferente de 20, uma mensagem de configuração não padrão será exibida.

O valor LAN-MTAs é o número de agentes de transferência de mensagens com suporte no MTA. É recomendável usar um valor igual a 20 para esse valor do Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique duas vezes no valor LAN-MTAs.

  4. No campo de dados Valor, digite 20 e clique em OK.

  5. Saia do editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O parâmetro de usuários MDB do MTA é não-padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\MDB users

Se o Exchange Server Analyzer encontrar o valor de Usuários do MDB presente e definido como qualquer valor diferente de 500, será exibida uma mensagem de configuração não padrão.

O valor Usuários do MDB é o número máximo de usuários do MDB (banco de dados de mensagens) que têm suporte no MTA (agente de transferência de mensagens). Todos os usuários do Exchange Server são usuários do MDB por padrão, a menos que tenham sido definidos de outro modo explicitamente.

O valor do Registro Usuários do MDB define o número de nomes distintos a serem armazenados em cache do diretório. Se sua organização contiver mais de 1500 usuários, você deverá alterar o valor para um terço do tamanho da lista de endereços global, mas apenas até um máximo de 5000.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel da direita, localize e clique duas vezes no valor Usuários do MDB.

  4. No campo de dados Valor, digite 500 e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O parâmetro do máximo de chamadas RPC pendentes do MTA não é padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Max RPC Calls Outstanding

Se o Exchange Server Analyzer verificar que o valor Máximo de Chamadas RPC Pendentes está presente e definido com um valor diferente de 50, uma mensagem de configuração não padrão será exibida.

O valor de Máximo de Chamadas RPC Pendentes é o número máximo de threads de RPC (chamada de procedimento remoto). Isso limita o número máximo de RPCs com garantia de processamento simultâneo. Esse valor é usado por RpcServerUseAllProtSeqs() e RpcServerListen().

Em ambientes mistos típicos onde o Exchange 2000 Server e/ou o Exchange Server 2003 coexistem com computadores do Exchange Server versão 5.5 e se você aumentou o número de threads de Entrada/Saída de Gateway no processo Store.exe, recomenda-se que você aumente os dados de valor para 0x80 (hex) ou 128 (decimal).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique duas vezes no valor Máximo de Chamadas RPC Pendentes.

  4. No campo de dados Valor, digite 50 e clique em OK.

  5. Saia do editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O parâmetro de threads de RPC Mín. do MTA é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

Mensagem de Erro

Introdução

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Min RPC Threads

Se o Exchange Server Analyzer detectar o valor de Mín. de threads de RPCs presente e definido como qualquer outro valor diferente de 4, uma mensagem de configuração não padrão será exibida.

O valor de Mín. de threads de RPCs é o número mínimo de threads de RPCs (chamadas de procedimento remoto). Isso identifica o número mínimo de threads de chamadas. Esse valor é usado pelo RpcServerListen(). Em geral, você não deve modificar esse valor do Registro da configuração padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique duas vezes no valor de Mín. de threads de RPCs.

  4. No campo de dados Valor, digite 4 e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O parâmetro MTA RTS threads é não-padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\RTS threads

Se o Analisador do Exchange Server detectar o valor de Threads do RTS presente e maior que 0, mas definido como algo diferente de 1 ou 3, uma mensagem de configuração não padrão será exibida.

O valor de Threads do RTS é o número de threads da plataforma que manipulam o nível RTSE (Elemento de Serviço de Transferência Confiável) da pilha OSI (Interconexão de Sistemas Abertos). Os threads do RTS são responsáveis por colocar os dados nas filas. Você deve ajustar o valor do registro Threads do RTS do padrão igual a 1 até um valor igual a 3, se esse MTA (agente de transferência de mensagens) se comunicar com vários computadores do Exchange Server versão 5.5 em um site ou entre sites.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para otimizar o valor do Registro Threads do RTS

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique duas vezes no valor Threads do RTS.

  4. No campo de dados Valor, insira o valor apropriado (1 ou 3) e clique em OK.

  5. Saia do editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O serviço do MTA não está sendo executado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-02-19

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o valor das chaves Started dos seguintes serviços está definido como True ou False:

  • Serviço Microsoft Exchange MTA Stacks

  • Serviço de Cluster

Um valor False indica que o serviço não está sendo executado no computador do Exchange Server. Um valor Verdadeiro indica que o serviço está sendo executado.

O Analisador do Exchange Server também examina a classe WMI Exchange_Server no namespace root\MicrosoftExchangeV2 para determinar o valor da chave IsFrontEndServer. Um valor Falso indica que o computador do Exchange Server não é um servidor front-end. Um valor Verdadeiro indica que o computador do Exchange Server é um servidor front-end.

Se o valor das três chaves avaliadas for False, será exibido um aviso.

É recomendável iniciar o serviço Exchange MTA Stacks em todos os computadores do Exchange Server que roteiam emails. Isso é importante especialmente em um ambiente de modo misto, no qual há transferência de mensagens entre o Exchange Server versão 5.5 e o Exchange Server 2003 e/ou Exchange 2000 Server. Além disso, todos os conectores X.400 exigem o serviço Exchange MTA Stacks, portanto a desabilitação do serviço causará erros e a funcionalidade poderá falhar. Movimentações de caixas de correio também exigem o início do serviço Exchange MTA Stacks.

Para solucionar esse aviso, inicie o serviço Exchange MTA Stacks.

Para iniciar o serviço Exchange MTA Stacks

  1. No menu Iniciar, selecione Programas, Ferramentas Administrativas e Serviços Snap-in do MMC (Console de Gerenciamento Microsoft).

  2. Clique com o botão direito no serviço Microsoft Exchange MTA Stacks e clique em Propriedades.

  3. Na guia Geral da página de propriedades do Microsoft Exchange MTA Stacks, verifique se o Tipo de Inicialização está definido como Automático. Se não estiver, clique em Aplicar e clique em OK.

  4. Clique com o botão direito no serviço Microsoft Exchange MTA Stacks e clique em Iniciar.

  5. Feche o snap-in Serviços.

Para obter mais informações sobre como manter o serviço Exchange MTA Stacks em execução em um ambiente Exchange de código misto, consulte o artigo 810489 da Base de Dados de Conhecimento Microsoft, "O serviço MTA Stacks deve permanecer ativado no Exchange 2000 e 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489).


O serviço MTA está definido como Desabilitado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor definido para a chave StartMode do serviço Microsoft Exchange MTA Stacks. Um valor Desabilitado indica que o serviço Exchange MTA Stacks foi desabilitado e não pode ser iniciado até que o valor StartMode seja alterado para Manual ou Automatic.

O Exchange Server Analyzer também consulta a classe Win32_Service do WMI para determinar o valor da chave Started para o serviço SMTP. Um valor Falso indica que o serviço não está sendo executado. Um valor Verdadeiro indica que o serviço está sendo executado.

Por último, o Exchange Server Analyzer consulta a classe Win32_OperatingSystem do WMI para determinar o valor da chave OSProductSuite. O valor dessa chave corresponde a uma versão específica do sistema operacional Microsoft Windows Server™ 2003.

Se o Exchange Server Analyzer detectar que o valor da chave StartMode está definido como Desabilitado em um computador do Exchange Server que possui o serviço SMTP iniciado, e que o computador do Exchange Server não faz parte de uma instalação do Microsoft Windows Small Business Server 2003, será exibido um aviso.

A menos que o servidor faça parte de uma instalação do Microsoft Windows Small Business Server 2003 ou esteja em um puro ambiente do modo nativo do Exchange Server 2003, todos os computadores do Exchange Server que roteiam e-mail deverão ter o serviço Exchange MTA Stacks definido como Automático. Rotear email em um servidor em que o serviço Exchange MTA Stacks está desabilitado pode gerar diversas mensagens de erro. Em alguns casos, os erros poderão ser registrados em log se você estiver executando em um ambiente do Exchange 2000 Server ou Exchange Server 2003 em que o Exchange Server versão 5.5 ainda estiver em execução. Além disso, todos os conectores X.400 exigem o serviço Exchange MTA Stacks, portanto a desabilitação do serviço causará erros e a funcionalidade poderá falhar.

Observação:
Exceto para a conectividade direta com sistemas de email X.400 externos ou executando os conectores EDK (Exchange Development Kit), como o Novell GroupWise Connector, o Lotus Notes Connector ou um conector de Fax de terceiros, as dependências no serviço MTA Stacks foram removidas no Exchange Server 2003. Portanto, a Microsoft agora oferece suporte a implantações puras do Exchange Server 2003 do modo nativo, em que o serviço MTA Stacks está desabilitado.

Para solucionar este erro, configure o serviço Exchange MTA Stacks para iniciar automaticamente em servidores que roteiam emails.

Para configurar o serviço Exchange MTA Stacks para inicialização automática

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. Clique duas vezes no serviço Microsoft Exchange MTA Stacks.

  3. Na guia Geral da página Propriedades de Microsoft Exchange MTA Stacks, selecione Automática na caixa de diálogo suspensa Tipo de inicialização e clique em Aplicar.

  4. Em Status do serviço, clique em Iniciar e clique em OK.

  5. Feche o snap-in Serviços.

Para obter mais informações sobre como manter o serviço Exchange MTA Stacks em execução no Exchange, consulte o artigo 810489 da Base de Dados de Conhecimento Microsoft, "Diretrizes para ajuste de suporte ao serviço MTA Stacks para Exchange 2000 Server e Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489) (em inglês).


Parâmetro de threads de envio/entrega do MTA é não-padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\ Submit/deliver threads

Se o Exchange Server Analyzer detectar que o valor Threads de envio/entrega presentes e definidos como algo diferente de 2, uma mensagem de configuração não padrão será exibida.

O valor Threads de envio/entrega é o número de threads de Envio/Entrega do MTA (agente de transferência de mensagem). O MTA usa esses threads para passar mensagens para o armazenamento de informações. Em alguns computadores DO Exchange Server versão 5.5, é possível que esse valor tenha sido alterado automaticamente pelo Otimizador de Desempenho do Microsoft Exchange do seu valor padrão 2 para um valor mais apropriado para o servidor Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como editar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique duas vezes no valor Threads de envio/entrega.

  4. No campo Dados do valor, verifique se um valor igual a 2 está inserido e clique em OK.

  5. Saia do editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Em computadores do Exchange 2000 Server e do Exchange Server 2003, o valor para essa entrada não deve ser maior do que 3. Para computadores do Exchange Server 5.5, como uma alternativa ao procedimento anterior, você pode executar o Otimizador de Desempenho do Exchange no modo verbose (perfwiz.exe -v) e definir o valor com essa ferramenta.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre situações nas quais o valor do registro de Threads de envio/entrega do MTA deve ter seu valor padrão alterado, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 234280, "XCON: How to Increase the Ability of the MTA to Pass Mail over Slow Network Connections" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280)

  • 265186, "XCON: MTA fanout slows on multiprocessor servers and messages back up in information store" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186)

  • 234702, "XGEN: Fila MTA para processamento de armazenamento de informações mais lento" http://go.microsoft.com/fwlink/?linkid=3052&kbid=234702.

  • 327260, "MTA slows down or stalls in Exchange Server 5.5 and messages back up in the private information store" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260)

  • Para obter mais informações sobre como usar o Otimizador de Desempenho do Exchange no modo verbose, consulte o artigo 246125 da Base de Dados de Conhecimento, "XADM: Otimizador de desempenho do Exchange Server 5.5 modo verbose" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246125).


O parâmetro de bloqueios de controle de TCP/IP do MTA não é padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

Mensagem de Erro

Introdução

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP control blocks

Se o Analisador do Exchange Server detectar o valor dos bloqueios de controle de TCP/IP presentes e definidos como um valor diferente de 20, uma mensagem de configuração não padrão será exibida.

O valor de bloqueios de controle de TCP/IP é o número máximo de conexões RFC1006 (TCP/IP) simultâneas suportadas. Essa configuração controla o número de buffers disponíveis para conexões X.400. Se esse MTA (agente de transferência de mensagens) hospedar mais de um conector X.400, o valor de bloqueios de controle de TCP/IP deverá ser ajustado. Deve haver 10 bloqueios de controle para cada conector X.400 que está sendo hospedado e um bloqueio de controle para servir a conexões de entrada. Portanto, para um sistema com três conexões X.400, o valor apropriado deveria ser 33.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar o valor dos bloqueios de controle de TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique duas vezes no valor dos bloqueios de controle de TCP/IP.

  4. No campo de dados Valor, insira o valor apropriado para esse MTA e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O parâmetro de threads de TCP/IP do MTA é não-padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

Mensagem de Erro

Introdução

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP threads

Se o Analisador do Exchange Server detectar o valor Threads TCP/IP presentes e definidos como um valor diferente de 2, uma mensagem de configuração não padrão será exibida.

O valor Threads TCP/IP é o número máximo de threads de DMOD (módulo de endereço dinâmico) do MTA (agente de transferência de mensagens) que controlam conexões RFC1006. Esse número é multiplicado por dois para os dois subtipos (Driver e Async Notify) de threads RFC1006. Em servidores bridgehead de replicação de diretório X.400 e servidores dedicados de pasta pública que controlam um grande número de conexões, recomenda-se que esse valor seja modificado do padrão 2 para um valor de 10.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como editar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar o valor dos threads TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique duas vezes no valor Threads TCP/IP.

  4. No campo Dados do valor, insira o valor apropriado e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O parâmetro de threads de Transferência do MTA é não padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

Mensagem de Erro

Introdução

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transfer threads

Se o Exchange Server Analyzer encontrar o valor de Threads de Transferência presente e maior do que 0, mas definido como qualquer número diferente de 1 ou 2, uma mensagem de configuração não padrão será exibida.

O valor dos Threads de transferência é o número de threads de Transferência do MTA (agente de transferência de mensagens). Ele é multiplicado por dois nos dois subtipos (Transfer In e Transfer Out) de cada thread de Transferência. Ele é equivalente ao valor dos Threads de envio/entrega (que se relaciona à transferência de armazenamento de informações e MTA), mas para gateways e MTAs. Para obter mais informações sobre o valor de Threads de envio/entrega , consulteParâmetro de threads de envio/entrega do MTA é não-padrão.

Se esse for um MTA do Exchange Server 2000 ou do Exchange Server 2003 que se comunique com mais de um computador do Exchange Server versão 5.5 dentro de um site ou entre sites, é recomendável que o valor dos Threads de transferência seja ajustados para 3.

Em alguns computadores Exchange Server 5.5, é possível que esse valor tenha sido alterado automaticamente pelo Otimizador de Desempenho do Exchange do seu valor valor padrão de 2 para um valor mais adequado para o computador do Exchange Server.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar o valor dos threads de Transferência

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique com o botão direito no valor dos Threads de transferência.

  4. No campo Dados do valor, insira o valor apropriado e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Em computadores do Exchange Server 2000 e do Exchange Server 2003, o valor dessa entrada deve ser definido no máximo como 3. Como alternativa ao procedimento anterior, você pode executar o Otimizador de Desempenho do Exchange no modo detalhado (perfwiz.exe -v) e definir o valor usando essa ferramenta.

Antes de editar o Registro e para obter informações sobre como editar o Registro, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre situações em que o valor do Registro Threads de transferência do MTA deve ser alterado do seu valor padrão, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 234280, "XCON: How to Increase the Ability of the MTA to Pass Mail over Slow Network Connections" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280)

  • 265186, "XCON: MTA fanout slows on multiprocessor servers and messages back up in information store" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186)

  • 327260, "MTA slows down or stalls in Exchange Server 5.5 and messages back up in the private information store" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260)


O parâmetro de threads de Transporte do MTA é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

Mensagem de Erro

Introdução

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor atual:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transport threads

Se o Exchange Server Analyzer detectar que o valor de Threads de transporte está presente e configurado com algo diferente de 1, será exibida uma mensagem de configuração não padrão.

O valor de Threads de transporte é o número de Threads de transporte do MTA (Agente de Transferência de Mensagens). Geralmente, o valor padrão igual a 1 é suficiente para todas as organizações. A menos que instruído de outra forma pelo Atendimento Microsoft, deixe esse valor definido como 1.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar o valor de Threads de transporte

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. No painel direito, localize e clique duas vezes no valor Threads de transporte.

  4. No campo de dados Valor, digite 1 e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Pilhas do Microsoft Exchange MTA para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Controle de mensagens Desabilitado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-06

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se a propriedade messageTrackingEnabled do objeto do servidor está definida como TRUE (habilitada) ou FALSE (desabilitada).

Se o Exchange Server Analyzer determinar que a propriedade messageTrackingEnabled do objeto do servidor está definida como False, o Exchange Server Analyzer exibirá um erro.

A propriedade messageTrackingEnabled do objeto do servidor determina o estado da Centro de Controle de Mensagens para o servidor.

O Centro de Controle de Mensagens, quando está habilitado, registra informações sobre o remetente, a mensagem e os destinatários da mensagem. Especificamente, você pode revisar as estatísticas, como a hora em que a mensagem foi enviada ou recebida, o tamanho e a prioridade da mensagem e a lista de destinatários da mensagem. Você pode também registrar a linha de assunto das mensagens de email. O Centro de Controle de Mensagens procura mensagens, como mensagens do sistema, mensagens de pastas públicas e mensagens de email.

Você deve habilitar o Centro de Controle de Mensagens em cada servidor para o qual deseja controlar mensagens. Quando está habilitado, todas as mensagens que são roteadas por meio de um servidor são adicionadas aos logs de controle de mensagem.

O Analisador do Exchange Server requer que o controle de mensagens esteja habilitado para iniciar sua verificação.

Observação:
As permissões a seguir são necessárias para executar este procedimento: Membro do grupo de administradores locais e membro de um grupo que teve a função Administradores do Exchange aplicada no nível do grupo administrativo
Para habilitar o Centro de Controle de Mensagens em um servidor

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, clique com o botão direito no servidor em que deseja habilitar o controle de mensagens e clique em Propriedades.

  2. Na guia Geral, marque a caixa de seleção Habilitar controle de mensagens .

  3. Para registrar o assunto de qualquer mensagem enviada para, recebida do ou por meio do servidor, marque a caixa de seleção Habilitar log e exibição de assunto.

    Observação:
    Se você habilitar o log de assunto, pode provocar perda de desempenho.

  4. Em Manutenção de arquivo de log, você pode impedir a remoção dos arquivos de log ou modificar o tempo que os arquivos de log são mantidos. O período padrão que os logs de controle são mantidos é de sete dias.

    Observação:
    Em servidores que processam grandes quantidades de correio, os logs de controle crescem rapidamente. Certifique-se de que tenha espaço suficiente em disco para os arquivos de log e para outros serviços ou aplicativos que usam esse disco.

  5. Clique em OK ou em Aplicar. Você não precisa reiniciar os serviços para que essa alteração entre em vigor.

Para obter mais informações sobre como usar o Centro de Controle de Mensagens, consulte o artigo 262162 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o centro de controle de mensagens para controlar uma mensagem (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162).

Para obter mais informações sobre como solucionar problemas de transporte do Exchange Server, consulte o artigo 821910 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de transporte do Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).


Os logs de controle de mensagens estão sendo gravados em uma pasta compactada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Directory do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave Compressed para o caminho de arquivo de log de controle de mensagens. Se o Exchange Server Analyzer determinar que o valor para a chave Compressed é True, um erro será exibido.

Quando o controle de mensagens está habilitado em um computador do Exchange 2000 Server ou Exchange Server 2003, os logs de controle são gravados no seguinte local padrão:

<unidade> :\Arquivos de Programas\Exchsrvr\ ServerName .log

onde <drive> é a unidade que contém o caminho \Arquivos de Programas\Exchsrvr e ServerName é o nome do host do computador do Exchange Server.

A Microsoft não oferece suporte para o armazenamento de arquivos de dados do Exchange em um volume NTFS compactado. Quando você armazenar seus arquivos de dados do Exchange em um volume compactado, a sobrecarga adicional impactará significativamente o desempenho do Exchange. Além disso, depois que um banco de dados de armazenamento de informações atinge um determinado tamanho, aproximadamente 4 GB, a sua montagem poderá falhar ou ele poderá ficar danificado.

Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Arquivos que são gerenciados pelo ESE (Mecanismo de Armazenamento Extensível) não devem ser armazenados em uma unidade compactada. O Mecanismo de Armazenamento Extensível (ESE) depende da independência de setor para a recuperação baseada em log, e a compactação de arquivos invalida essa independência. A compactação não deve ser ativada para os volumes que hospedam bancos de dados ESE, ou qualquer banco de dados que usa o log de write-ahead.

Antes do Exchange 2000 Server Service Pack 3, era possível montar bancos de dados compactados de armazenamento de informações. Contudo, podem ocorrer danos em bancos de dados ou logs de armazenamento de informações do Exchange 2000 Server compactados por meio da compactação NTFS.

Com o Exchange 2000 Server Service Pack 3, arquivos do banco de dados de armazenamento de informações compactados de 128 megabytes (MB) ou menos são descompactados automaticamente. Quando os arquivos de banco de dados atingem um tamanho acima de 128 MB, o banco de dados não é montado e são geradas mensagens de erro no log do aplicativo. O Exchange 2000 Server Service Pack 3 impede a montagem de bancos de dados compactados com mais de 128 MB.

Para desativar a compactação de arquivos em uma pasta especificada

  1. Clique com o botão direito na pasta em que você deseja desativar a compactação de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Compactar o conteúdo para economizar espaço em disco e clique em OK.

Como alternativa ao procedimento anterior, você pode mover os arquivos de log de controle de mensagens para uma outra pasta descompactada. Para obter mais informações sobre como mover os arquivos de log de controle de mensagens, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 84103, "Como alterar o local dos logs de rastreamento de mensagens no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089)

  • 317700, "Como alterar o local dos logs de rastreamento de mensagens no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)

Para obter mais informações sobre arquivos de dados do Exchange e compactação NTFS, consulte os seguintes artigos na Base de Dados de Conhecimento:

  • 170009, "XADM: O volume NTFS compactado causa falha no armazenamento" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009)

  • 327772, "XADM: O banco de dados não é montado e você recebe o erro 0xfffff05b após aplicar o SP3" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772)


Os logs de controle de mensagens estão sendo gravados em uma partição não-NTFS
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-17

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Directory do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave FSName para o caminho do arquivo dos logs de rastreamento de mensagens do Exchange. Se o Exchange Server Analyzer determinar que o valor FSName para a chave não é igual a NTFS, será exibido um erro.

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em volumes não-NTFS. Os arquivos de dados do Exchange incluem todos os arquivos a seguir:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Se você encontrar esse erro, remova os logs de rastreamento de mensagens para uma pasta em uma unidade NTFS. Uma alternativa, se a unidade na qual os logs de rastreamento de mensagens estão armazenados estiver formatada como uma unidade FAT, você pode usar a ferramenta de linha de comando convert.exe para converter a unidade para NTFS.

Para mover os logs de rastreamento de mensagens para o Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos, expanda seu grupo administrativo, Servidores, clique com o botão direito em seu servidor e clique em Propriedades.

  3. Na guia Geral, clique em Alterar.

  4. Digite o novo caminho dos logs de rastreamento de mensagens e clique em OK.

  5. Clique em OK.
Observação:
Por padrão, a modificação dos arquivos de log de rastreamento age na meia noite do horário universal coordenado (UTC). Depois dessa alteração ser efetuada, o componente de rastreamento de mensagens do Exchange cria novos arquivos de log no novo local especificado. No entanto, arquivos de log anteriores não são movidos para o novo local. Por isso, aguarde até que a alteração de local do novo arquivo de log seja efetuada e, depois, mova manualmente os arquivos de log do local anterior para o novo local. Se o serviço Atendedor do Sistema do Microsoft Exchange for reiniciado, o caminho do arquivo de log é imediatamente alterado para o novo local. Nessa situação, o rastreamento de mensagens do Exchange cria um novo arquivo de log no novo local quando um usuário envia uma mensagem. Nesse caso, você pode ter dois arquivos de log com o mesmo nome: o arquivo de log no local original e um arquivo de log no novo local que você especificou. Se esse comportamento ocorrer, renomeie o arquivo de log armazenado no local original do arquivo de log antes de movê-lo para o novo local. Use a mesma convenção de nomeação usada pelo rastreamento de mensagens do Exchange (aaaammdd). No entanto, neste caso, use uma data anterior a todas as datas dos arquivos de log existentes, para que esse arquivo de log renomeado não interfira com um arquivo de log futuro.

Para obter mais informações sobre como mover os arquivos de log de rastreamento de mensagens em um computador que execute o Exchange 2000 Server, consulte o artigo 317700 da Base de Dados de Conhecimento da Microsoft, "Como alterar o local dos logs de rastreamento de mensagens no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700).

Como alternativa para o procedimento anterior, se a unidade na qual os arquivos estão armazenados estiver formatada como uma unidade FAT, você pode usar a ferramenta de linha de comando convert.exe para converter a unidade para NTFS. Para obter mais informações sobre como usar a ferramenta de linha de comando convert.exe para converter uma partição FAT em uma partição NTFS, consulte o artigo 214579 da Base de Dados de Conhecimento da Microsoft, "Como usar o convert.exe para converter uma partição em um sistema de arquivo NTFS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Os logs de controle de mensagens estão sendo gravados em uma pasta criptografada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-17

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe de WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Directory para determinar o valor da chave Encrypted dos arquivos de log de controle de mensagens. Se o valor dessa chave for True, será exibido um erro.

Quando o controle de mensagens está habilitado em um computador do Exchange 2000 Server ou Exchange Server 2003, os logs de controle são gravados no seguinte local padrão:

<drive>:\Arquivos de Programas\Exchsrvr\ ServerName .log

onde <drive> é a unidade que contém o caminho \Arquivos de Programas\Exchsrvr e ServerName é o nome do host do computador do Exchange Server.

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em um volume criptografado com EFS (Sistema de Criptografia de Arquivos). Quando você armazena seus arquivos de dados do Exchange em um volume criptografado, a sobrecarga adicional impacta significativamente o desempenho do Exchange. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Para ajudar a proteger seus arquivos de dados do Exchange, é recomendável que você impeça o acesso não autorizado ao computador do Exchange e que você use o formato de mensagem S/MIME para criptografar dados de mensagens.

Para desligar a criptografia de arquivos de uma pasta especificada

  1. Clique com o botão direito na pasta em que deseja desativar a criptografia de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Criptografar o conteúdo para proteger dados e clique em OK.

Como alternativa para o procedimento anterior, você pode mover os arquivos de log de controle de mensagens para uma pasta diferente, não criptografada. Para obter mais informações sobre como mover os arquivos de log de controle de mensagens, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 841089, "Como alterar o local dos logs de rastreamento de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089)

  • 317700, "Como alterar o local dos logs de rastreamento de mensagens no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)


Não é possível acessar a metabase
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-02-13

A ferramenta Microsoft® Exchange Server Analyzer Tool tenta ler as várias propriedades da instância do servidor virtual SMTP no seguinte caminho da metabase do IIS (Serviços de Informações da Internet):

/LM/SmtpSvc/<instância do servidor virtual SMTP>

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • A consulta da metabase falha.

  • O Exchange Server não está executando no Microsoft Windows NT® Server 4.0.

Esse erro indica que o Exchange Server Analyzer não pode ser conectar à metabase do IIS.

A metabase do IIS inclui informações que afetam o Exchange Server, como configurações de protocolo para HTTP, diretórios virtuais para acesso a caixas de correio e dispositivos móveis e configurações de segurança HTTP.

Para resolver esse problema, verifique a integridade da metabase e se o IIS está instalado corretamente.

Para verificar se a metabase não está corrompida e se o IIS está instalado corretamente, consulte os seguintes recursos:

  • Artigo 240225 da Base de Dados de Conhecimento Microsoft, "Descrição dos utilitários Adsutil e MetaEdit usados para modificar a metabase" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225).

  • Artigo 317678 da Base de Dados de Conhecimento Microsoft, "COMO: Reiniciar o IIS (Serviços de Informações da Internet) no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678).

Se a orientação desses recursos não resolver o problema, talvez você precise desinstalar e reinstalar o IIS.

Para desinstalar o IIS usando Adicionar ou Remover um Componente do Windows no Painel de Controle

  1. Clique em Iniciar e clique em Painel de Controle.

  2. Clique duas vezes em Adicionar ou Remover Programas.

  3. Clique em Adicionar/Remover Componentes do Windows.

  4. Na lista Componentes, clique na caixa de seleção Servidor de Aplicativos.

  5. Clique em Detalhes.

  6. Clique em Gerenciador de Serviços de Informações da Internet.

  7. Clique em Avançar.

  8. Clique em Concluir quando o IIS estiver desinstalado.
Para instalar o IIS usando o Painel de Controle

  1. Clique em Iniciar e clique em Painel de Controle.

  2. Clique duas vezes em Adicionar ou Remover Programas.

  3. Clique em Adicionar/Remover Componentes do Windows.

  4. Na lista Componentes, clique na caixa de seleção Servidor de Aplicativos.

  5. Clique em Detalhes.

  6. Clique na caixa de seleção Gerenciador de Serviços de Informações da Internet.

  7. Clique em OK até retornar ao Assistente de Componentes do Windows.

  8. Clique em Avançar e conclua o Assistente de Componente do Windows.


O valor do MinUserDC é não padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-08

A ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas de Registro para determinar se o controlador de domínio do serviço de diretório do Active Directory® que funciona como emulador do PDC (controlador de domínio primário) foi excluído manualmente da lista de controladores de domínio disponíveis para uso pelo Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

Se o Exchange Server Analyzer verificar que o MinUserDC está presente e configurado, uma mensagem de configuração não padrão será exibida.

Um emulador de PDC é um computador de função principal das operações do Active Directory que processa as solicitações de replicação dos controladores de domínio de backup do Microsoft Windows NT® Server 4.0 e processa todas as atualizações de senhas de clientes que não estão executando o software cliente habilitado para o Active Directory. Emuladores de PDC são também controladores de domínio e, portanto, estão disponíveis para uso por aplicativos como o Exchange.

O DSAccess (Directory Service Access) é um componente interno do Exchange 2000 Server e do Exchange Server 2003 que controla como todos os componentes do Exchange acessam o Active Directory. A principal função do DSAccess é manter informações sobre vários eventos e operações relacionados a diretórios. Por exemplo, o DSAccess descobre a topologia do Active Directory e detecta se controladores de domínio e servidores de catálogo global estão disponíveis e respondendo a consultas.

Por padrão, o DSAccess inclui o computador emulador de PDC na sua lista de controladores de domínio disponíveis e utilizáveis. Se programas não pertencentes ao Exchange estiverem fazendo uso intenso do emulador de PDC, o uso dele pelo DSAccess poderia provocar problemas de desempenho no computador do emulador de PDC, assim como no servidor Exchange e no computador com programa não pertencente ao Exchange.

Para evitar esses problemas de desempenho, o valor do Registro MinUserDC pode ser adicionado ao Registro em um servidor Exchange para forçar o DSAccess a consultar todos os outros controladores de domínio disponíveis antes de consultar o controlador que mantém a função de mestre de operações do emulador de PDC.

Observação:
Um servidor Exchange configurado com o valor de Registro MiniUserDC tentará usar outros servidores do mesmo domínio primeiro, portanto, é recomendável que essa configuração seja definida somente se o site contiver pelo menos dois controladores de domínio para o domínio que contém os servidores Exchange.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para examinar e editar o valor de Registro MinUserDC

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. Localize o valor de MinUserDC e faça as alterações necessárias. Se esse valor DWORD não existir, você poderá criá-lo manualmente.

  4. Os dados de valor configurados para a entrada de Registro MinUserDC são o número máximo de controladores de domínio a entrar em contato antes de entrar em contato com o emulador de PDC. Por exemplo, a definição de MinUserDC em 4 configura o DSAccess para excluir o emulador de PDC somente quando um total de 4 controladores de domínio estão disponíveis. Quando essa condição é atendida, o emulador de PDC é excluído do uso e o DSAccess se comunica somente com os 3 controladores de domínio restantes.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o uso da entrada de Registro MinUserDC, consulte o artigo 298879 da Base de Dados de Conhecimento, "XADM: Exchange 2000 pode apresentar problemas de desempenho quando o emulador de PDC é usado para DSAccess" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879).


Mais de 1000 armazenamentos de caixas de correio estão presentes
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-12-13

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® e mantém uma conta dos objetos do Armazenamento de Informações do Microsoft Exchange, com a classe de objeto do msExchPrivateMDB. Se a ferramenta Analisador do Exchange Server determinar que há mais de 1.000 armazenamentos de caixas de correio em uma organização, um aviso será exibido.

Um aviso é exibido porque existe um problema conhecido em que os usuários que acessam as caixas de correio do Microsoft Office Outlook® Web Access 2003 por meio de servidores front-end em organizações com mais de 1.000 armazenamentos de caixa de correio, não podem acessar suas caixas de correio. Esse problema é causado pelo modo como o servidor Exchange front-end faz proxy na solicitação de autenticação para o servidor back-end do Exchange.

Se você tem usuários que estão acessando seus armazenamentos de caixas de correio dos servidores front-end do Exchange e estão recebendo esse aviso, deverá executar um dos seguintes procedimentos:

  • Obter e instalar o hotfix do Exchange Server descrito no artigo 899902 da Base de Dados de Conhecimento da Microsoft, "Usuários que recebem uma mensagem de erro 401 quando tentam acessar uma caixa de correio que está em um servidor front-end do Exchange Server 2003 usando o Outlook Web Access" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=899902).

  • Se puder, consolide as caixas de correio em menos armazenamentos de caixa de correio.

  • Configure os servidores front-end para autenticar os servidores back-end com Autenticação básica. O restante desse artigo descreve essa opção.

Por padrão, os servidores front-end do Exchange Server 2003 usarão a autenticação Kerberos para ajudar a proteger as credenciais do usuário entre os servidores front-end e back-end. Se a autenticação Kerberos falhar, um evento de Aviso será registrado em log e o servidor front-end tentará usar NTLM em seu lugar. Se NTLM falhar, um erro será registrado em log. A autenticação Kerberos é tentada novamente em 30 minutos. Quando os computadores front-end do Exchange 2000 Server ou Exchange Server 2003 fazem autenticação com computadores back-end do Exchange 2000 Server, a NTLM é usada. Não há interface de usuário no IIS ou no Gerenciador do Sistema Exchange para selecionar mecanismos de autenticação.

A configuração do servidor front-end do Exchange para usar Autenticação básica requer que você defina uma chave de Registro em todos os servidores front-end em sua organização. O procedimento a seguir explica como definir a chave manualmente.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar servidores front-end do Exchange para usar Autenticação básica em relação aos servidores back-end do Exchange

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

    Navegue para:= HKEY_LOCAL_MACHINE\System\CurrentControlSet\Service\MSExchangeWeb

  2. Clique com o botão direito em MSExchangeWeb, aponte para Novo e clique em Chave. Nomeie a nova chave como Dav.

  3. Clique com o botão direito na nova Dav, aponte para Novo e clique em Valor DWORD.

  4. Nomeie o novo valor UseBasicAuthToBE e defina o valor como 1.

  5. Abra o snap-in Serviços no MMC (Console de Gerenciamento Microsoft), clique com o botão direito em Serviço de Administração do IIS e clique em Reiniciar.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


A maioria das chamadas store.exe em andamento estão esperando uma resposta do ESE
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-13

A ferramenta Analisador do Microsoft® Exchange Server examina o FCL (Log de Chamadas de Função) do Exchange, o arquivo Store.fcl, para eventos que indicam chamadas em andamento entre componentes do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe) para o Mecanismo de Armazenamento Extensível do Exchange (ESE).

Chamadas em andamento são solicitações do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para outros componentes que não receberam uma resposta no momento em que os dados do FCL do Exchange foram gravados no arquivo Store.fcl.

O Armazenamento de Informações do Microsoft Exchange está na parte superior de um banco de dados do ESE. O ESE é um mecanismo de banco de dados sofisticado, baseado em transações. Uma transação é uma série de operações que são tratadas como uma unidade atômica (indivisível). Todas as operações em uma transação são concluídas e salvas permanentemente ou, então, nenhuma operação é realizada.

O Exchange Server usa o ESE como um mecanismo de banco de dados incorporado que determina a estrutura dos bancos de dados e gerencia a memória. O mecanismo de banco de dados coloca os bancos de dados da memória em caches transferindo 4 quilobytes (KB) de blocos de dados (páginas) para dentro e para fora da memória. Isso atualiza as páginas da memória e grava páginas novas ou atualizadas no disco novamente. Quando o sistema recebe solicitações, o mecanismo de banco de dados pode armazenar dados em buffer na memória. Por isso, ele não precisa acessar o disco constantemente.

Embora os dados em cache na memória sejam a maneira mais rápida e eficiente de processar dados, significa que quando o Exchange está em execução, as informações no disco nunca são completamente atualizadas. A versão mais recente do banco de dados está na memória. No entanto, como muitas alterações na memória ainda não estão no disco, o banco de dados e a memória não estão sincronizados. O disco de log de transações é sempre mantido com informações sobre cada transação.

Se o Exchange Server Analyzer detectar que os eventos no arquivo de log Store.fcl refletem uma predominância de chamadas do serviço Armazenamento de Informações do Exchange (Store.exe) para o banco de dados do ESE, ele exibirá um erro.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

As chamadas em andamento do serviço Armazenamento de Informações do Microsoft Exchange para o ESE podem ser causadas pelas seguintes condições:

  • Desfragmentação online do Exchange.

  • Backups de dados.

    Observação:
    Se a desfragmentação online ou o backup de dados estiver em andamento durante a coleta de log de Rastreamento de Chamadas do Exchange, você poderá ignorar a mensagem de erro com segurança, pois ela não representará um indicador de problema de desempenho do Exchange Server.
  • Os afunilamentos nas unidades de bancos de dados, por exemplo, capacidade insuficiente para o número de usuários no servidor.

  • Afunilamentos nas unidades TEMP e TMP.

Para resolver esse erro, execute as seguintes etapas:

  • Recomendamos que você não sobreponha janelas de backup ou a manutenção online com intervalos de pico de demanda de usuários.

  • Certifique-se de que as unidades de disco do banco de dados estejam íntegras e tenham taxa de transferência de carga de E/S.

  • Execute o Exchange Server Analyzer para obter uma análise adicional do servidor. Você pode baixar o Exchange Server Analyzer em "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre como configurar as janelas de horário da desfragmentação online, consulte o artigo 244524 da Base de Dados de Conhecimento Microsoft, "XADM: How to Configure the Exchange Server Online Defragmentation Time Window" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524).

Para obter mais informações sobre problemas de Afunilamento de Disco do Exchange Server, consulte Afunilamento de disco detectado.

Para obter mais informações sobre como medir e otimizar discos para o Exchange Server, consulte "How to Calculate Your Disk I/O Requirements" e "Best Practices Common to Multiple Architectures" em Optimizing Storage for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=49324).

Para obter mais informações sobre o ESE, consulte "Extensible Storage Engine Architecture" (em inglês) (http://go.microsoft.com/fwlink/?linkid=67009).


A maioria das chamadas store.exe em andamento estão esperando uma resposta do IMAIL
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-13

A ferramenta Microsoft® Exchange Server Analyzer examina o Log de Chamada de Função (FCL) do Exchange, o arquivo Store.fcl, para eventos que indicam uma predominância de chamadas em andamento entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para o componente IMAIL do cliente MAPI.

Chamadas em andamento são solicitações do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para outros componentes que não receberam uma resposta no momento em que os dados do FCL do Exchange foram gravados no arquivo Store.fcl.

O componente IMAIL do Exchange Server é um serviço de conversão flexível que é usado pelo serviço Armazenamento do Microsoft Exchange entre mensagens da Internet e MAPI. Isso permite a interoperabilidade entre clientes que usam o formato Internet ou RFC-822 e clientes que usam o formato de armazenamento interno do Exchange Server, como clientes MAPI ou tarefas STORE internas.

O Exchange usa o mecanismo IMAIL para aplicar formatos de mensagem ao conteúdo, conforme definido para domínios da Internet no Gerenciador do Sistema do Exchange ou conforme especificado pelo usuário por destinatário do Microsoft Office Outlook®. Se nenhum parâmetro de formatação for passado para o IMAIL, o IMAIL formatará as mensagens MAPI no formato S/TNEF (Summary TNEF) para transferência entre servidores.

Se o Exchange Server Analyzer encontrar eventos no arquivo de log Store.fcl que reflitam a predominância de chamadas em andamento do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para o componente IMAIL do cliente MAPI, o Exchange Server Analyzer exibirá um erro.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

Chamadas em andamento do serviço Armazenamento de Informações do Microsoft Exchange para o componente IMAIL do cliente MAPI podem ocorrer quando uma ou mais das condições a seguir forem verdadeiras:

  • O IMAIL tenta processar muitos dados em uma mensagem ou anexo.

  • Muitos clientes solicitam conversão de dados.

  • As solicitações do DSAccess encontram uma resposta lenta.

  • Existem afunilamentos nas unidades TEMP e TMP.

  • Existem movimentações de caixas de correio em andamento.

Para resolver esse erro, execute as seguintes etapas:

  • Agende todas as movimentações de caixa de correio para horários que não sejam de pico.

  • Execute o Analisador do Exchange Server para obter uma análise adicional dos problemas do servidor, como limites de tamanho de mensagens e anexos. Você pode baixar o Exchange Server Analyzer em "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre problemas de afunilamento de disco com o Exchange Server, consulte Afunilamento de disco detectado.

Para obter mais informações sobre como medir e otimizar discos para o Exchange Server, consulte "How to Calculate Your Disk I/O Requirements" e "Best Practices Common to Multiple Architectures" em Optimizing Storage for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=49324).

Para obter mais informações sobre as práticas recomendadas para limites de tamanho de mensagem no Exchange Server, consulte O tamanho máximo da mensagem de saída não foi definido.

Para obter mais informações sobre o desempenho do DSAccess e do Exchange Server, consulte "Como configura o cache de usuário do DSAccess" no Guia de Desempenho e Escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Troubleshooting Microsoft Exchange Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento de informações, consulte o artigo 257725 da Base de Dados de Conhecimento Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


A maioria das chamadas store.exe em andamento estão aguardando uma resposta do LSASS
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-11

A Ferramenta Microsoft® Exchange Server Analyzer examina o FCL (Log de Chamada de Função) do Exchange Server, o arquivo Store.fcl, em busca de eventos que indiquem uma predominância de chamadas em andamento entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para o processo LSASS (Lsass.exe).

Chamadas em andamento são solicitações do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para outros componentes que não receberam uma resposta no momento em que os dados do FCL do Exchange foram gravados no arquivo Store.fcl.

O processo do Servidor de Autenticação de Segurança Local (Lsass.exe) é um subsistema de segurança invocado por outros processos para verificar informações de contas e validação de logon.

Cada logon de cliente Exchange faz com que o servidor que está executando o Exchange Server envie uma solicitação para pesquisar o SID (identificador de segurança) da conta do cliente e crie uma chamada dentro do processo do Servidor de Autenticação de Segurança Local (Lsass.exe).

Se o Exchange Server Analyzer perceber que os eventos no arquivo de log Store.fcl refletem uma predominância de chamadas em andamento no serviço Armazenamento de Informações Microsoft Exchange (Store.exe) para o processo LSASS (Lsass.exe), o Exchange Server Analyzer exibirá um erro.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

As chamadas em andamento do serviço Armazenamento de Informações do Microsoft Exchange para o processo LSASSS podem ser causadas pelas seguintes condições:

  • Problemas de recurso do servidor relacionados ao número de usuários que autenticam ao mesmo tempo.

  • Latência de rede entre o servidor Exchange e o Controlador de Domínio ou o servidor de catálogo global.

  • Problemas de afunilamento no recurso do servidor.

Para resolver esse erro, execute as seguintes etapas:

  • Experimente implementar o parâmetro NeverPing como descrito em Parâmetro 'NeverPing' Recomendado

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre o processo e uso de memória do Lsass.exe, consulte o artigo 308356 da Base de Dados de Conhecimento da Microsoft, "Uso de memória pelo processo Lsass.exe em controladores de domínio executando o Windows Server 2003 ou o Windows 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356).

Para obter mais informações sobre logons de cliente Exchange e problemas do LSASS, consulte o artigo 161938 da Base de Dados de Conhecimento da Microsoft, "Slow Exchange Client Logons Due to Resource Deadlock" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938).

Para obter mais informações sobre a latência de rede entre o servidor Exchange e o Controlador de Domínio ou o servidor de catálogo global, consulte o seguinte artigo no Blog da Equipe do Exchange Server, "Exchange Does Not Always Use Local GCs" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=69166).

Observação:
O conteúdo de cada blog e sua URL estão sujeitos a alterações sem aviso.

Para obter mais informações sobre problemas de afunilamento no recurso do servidor, consulte Afunilamento do processador.

Para obter mais informações sobre o desempenho do Exchange Server, consulte "Performance and Scalability Guide for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Troubleshooting Microsoft Exchange Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento de informações, consulte o artigo 257725 da Base de Dados de Conhecimento Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


A maioria das chamadas de store.exe em andamento estão esperando uma resposta do diretório
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-14

A ferramenta Microsoft® Exchange Server Analyzer examina o FCL (Log de Chamadas de Função) do Exchange, arquivo Store.fcl, eventos que indiquem uma predominância de chamadas contínuas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para o serviço de diretório do Active Directory®.

Chamadas em andamento são solicitações do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para outros componentes que não receberam uma resposta no momento em que os dados do FCL do Exchange foram gravados no arquivo Store.fcl.

O Active Directory fornece todas as informações sobre caixa de correio, serviços de lista de endereços e outras informações relacionadas a destinatários. A maioria das informações de configuração do Exchange Server 2003 também está armazenada no Active Directory.

Os serviços do Exchange Server acessam informações que estão armazenadas no Active Directory e gravam as informações no Active Directory.

Se o Exchange Server Analyzer localizar eventos no arquivo de log Store.fcl que reflitam uma predominância de chamadas do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para o Active Directory, o Exchange Server Analyzer exibirá um erro.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

Chamadas em andamento do serviço Armazenamento de Informações do Microsoft Exchange para o Active Directory podem ser causadas pelas seguintes condições:

  • Latência de rede entre o servidor Exchange e o Controlador de Domínio.

  • Configuração estática ou de outra forma incorreta do DSAccess.

  • Um controlador de domínio sobrecarregado e catálogo global.

  • Uma topologia do Active Directory designada incorretamente.

Para resolver esse erro, execute as seguintes etapas:

  • Execute o Analisador do Exchange Server para obter uma análise adicional dos problemas do servidor, como limites de tamanho de mensagens e anexos. Você pode baixar o Exchange Server Analyzer em "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Verifique o desempenho dos servidores do Controlador de Domínio do Active Directory.

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre o desempenho do Exchange e o DSAccess, consulte o artigo 250570 da Base de Dados de Conhecimento da Microsoft, "Directory service server detection and DSAccess usage" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).

Para obter mais informações sobre o desempenho do Exchange Server, consulte "Performance and Scalability Guide for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Troubleshooting Microsoft Exchange Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento de informações, consulte o artigo 257725 da Base de Dados de Conhecimento Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Para obter mais informações sobre o desempenho do Controlador de Domínio, consulte os seguintes recursos do Windows Server:

  • "Planning Domain Controller Capacity" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=70191).

  • "Active Directory Monitoring of Domain Controllers" em Windows 2000 Server Active Directory Planning and Deployment Guides (em inglês) (http://go.microsoft.com/fwlink/?LinkId=70193).


A maioria das chamadas store.exe em andamento estão aguardando uma resposta do Verificador de Vírus
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-13

A ferramenta Analisador do Microsoft® Exchange Server examina o FCL (Log de Chamada de Função) do Exchange, o arquivo Store.fcl, em busca de eventos que indiquem uma predominância de chamadas em andamento entre componentes do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe) para o componente de VAPI (API de Vírus) Virusscan.

Chamadas em andamento são solicitações do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para outros componentes que não receberam uma resposta no momento em que os dados do FCL do Exchange foram gravados no arquivo Store.fcl.

Se o Analisador do Exchange Server detectar eventos no arquivo de log Store.fcl que reflitam uma predominância de chamadas em andamento no serviço de Armazenamento de Informações Microsoft Exchange (Store.exe) para o componente de VAPI Virusscan, exibirá um erro.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

As chamadas em andamento do serviço de Armazenamento de Informações do Microsoft Exchange para o componente de VAPI Virusscan podem ser causadas pelas seguintes condições:

  • Atualizações para verificador de vírus que causam uma nova verificação de itens no armazenamento de informações.

  • Um verificador de vírus configurado incorretamente

  • O software verificador de vírus processa uma mensagem ou anexo grande

Para resolver esse erro, execute as seguintes etapas:

  • Agende as atualizações do seu verificador de vírus para épocas de baixo consumo, ou seja, horas de demanda que não sejam de pico.

  • Experimente reinstalar o software verificador de vírus, mas reinstale em intervalos de demanda que não sejam de pico.

  • Examine a configuração do seu mecanismo antivírus em relação à configuração correta de threads, a exclusões de nível de arquivo e assim por diante. Consulte o artigo 823166 da Base de Dados de Conhecimento Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre os programas de verificação de vírus geralmente usados com o Microsoft Exchange Server 2003, consulte o artigo 823166 da Base de Dados de Conhecimento da Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Para obter mais informações sobre os programas de verificação de vírus geralmente usados com o Microsoft Exchange 2000 Server, consulte o artigo 328841 da Base de Dados de Conhecimento da Microsoft, "Exchange e o software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Para obter mais informações sobre o desempenho do Exchange Server, consulte "Performance and Scalability Guide for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Troubleshooting Microsoft Exchange Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento de informações, consulte o artigo 257725 da Base de Dados de Conhecimento Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


A maioria das chamadas de store.exe em andamento estão esperando uma resposta do VSS Snapshot
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-13

A ferramenta Microsoft® Exchange Server Analyzer Tool examina o FCL (Log de Chamada de Função) do Exchange, o arquivo Store.fcl, para eventos que indicam chamadas em andamento entre componentes do serviço de Armazenamento de Informações do Exchange (Store.exe) para o componente de instantâneo VSS (Serviço de Cópias de Sombra de Volume).

Chamadas em andamento são solicitações do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para outros componentes que não receberam uma resposta no momento em que os dados do FCL do Exchange foram gravados no arquivo Store.fcl.

O VSS é um conjunto de APIs do COM que implementa uma estrutura que permite que os backups de volume sejam executados enquanto os aplicativos do sistema continuam a gravar nos volumes.

O Microsoft Exchange Server 2003 usa o VSS incluído no sistema operacional Microsoft Windows Server™ 2003 para fazer cópias de sombra de volume dos bancos de dados e arquivos de log de transações do Exchange Server 2003.

Um instantâneo VSS não é totalmente independente dos dados originais. Geralmente, os instantâneos são criados quando você define um marcador em um momento e verifica se os dados podem ser revertidos para esse momento.

Se o Exchange Server Analyzer detectar que eventos do arquivo de log Store.fcl refletem chamadas em andamento do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para o componente de instantâneo VSS, ele exibirá uma mensagem de prática recomendada.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

Observação:
Se um instantâneo VSS da coleta de logs de Rastreamento de Chamadas do Exchange foi intencionalmente iniciado em 20 segundos, você poderá seguramente ignorar essa mensagem como um indicador de um problema de desempenho do Exchange Server.

Como prática recomendada, aconselhamos você a não sobrepor janelas de backup com manutenção online nem com intervalos de pico de demanda de usuário.

Para obter mais informações

Para obter mais informações sobre VSS, consulte "Práticas recomendadas para usar o serviço de cópia de sombra de volume com o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=56571) (em inglês).


O arquivo MOUNTMGR.SYS é uma versão incorreta
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte chave de Registro para determinar se o Microsoft Windows® Server 2003 está instalado: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\

O Exchange Server Analyzer também executa as seguintes consultas:

  • A classe Win32_OperatingSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o Windows Server 2003 Service Pack 1 está instalado.

  • A classe Win32_Service do WMI para determinar se o serviço de Cluster está em execução.

  • A classe Win32_Volume do WMI para determinar se há Pontos de Montagem de Volume presentes.

  • A classe CIM_Datafile do WMI para determinar se o valor da chave Version para Mountmgr.sys e menor do que 2443.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • A chave Versão de Mountmgr.sys é menor do que 2443.

  • O servidor é um nó de um Cluster que está executando o Windows Server 2003 Service Pack 1.

  • O servidor tem pontos de montagem de volume.

A versão de Mountmgr.sys instalada no nó de cluster pode causar falhas de ponto de montagem de volume. Esse problema acontece por causa de um problema no driver Mountmgr.sys. Esse é um problema de tempo intermitente que pode ocorrer quando um volume chega para ser montado em um ponto de montagem.

Observação:
Geralmente, esse problema não ocorre em um ambiente sem clusters. Em um ambiente sem clusters, o tempo do processo de montagem de volume é diferente.

Para obter mais informações sobre esse problema, consulte o artigo 898790 da Base de Dados de Conhecimento Microsoft, "Volume mount points on disks in a server cluster may intermittently become unavailable after you install Windows Server 2003 Service Pack 1" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790).


Mover Diretórios Temp e TMP
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-09-01

A Ferramenta Microsoft® Exchange Server Analyzer verificou que as pastas TEMP e TMP do servidor podem não estar localizadas de modo a proporcionar o melhor desempenho de disco. É uma prática recomendada armazenar as pastas TEMP e TMP em um subsistema do disco que não seja compartilhado pela pasta do sistema ou pelos arquivos de dados do Exchange.

O Armazenamento de Informações do Microsoft Exchange usa as pastas TEMP e TMP como armazenamento temporário durante diversas operações, como conversão de mensagens, trabalho com anexos grandes e operações para mover caixas de correio. As variáveis de ambiente TEMP e TMP são usadas para designar quais pastas no sistema de arquivos (por exemplo, que caminho) devem ser usadas pelos aplicativos que exigem um espaço de trabalho temporário. A pasta TEMP é tipicamente usada por aplicativos, como o Microsoft Exchange, e a pasta TMP é normalmente usada por ferramentas de desenvolvimento, como o Microsoft Visual C++®. O caminho para cada variável geralmente é relativo ao contexto de segurança do aplicativo ou ferramenta.

Em um servidor Exchange sem cluster, o armazenamento do Exchange usa a pasta SYSTEM (por exemplo, Sistema Local), que usa uma configuração de variável de ambiente padrão de %Systemroot%\Temp para TEMP e TMP. Servidores Virtuais do Exchange sendo executados em um cluster de servidores do Microsoft Windows® usam as configurações de variável de ambiente para a conta de serviço do Cluster, que é executada no contexto de um princípio de segurança de um usuário específico. Para contas de usuários, a variável de ambiente padrão para TEMP e TMP é definida como %Userprofile%\Temp.

Este artigo explica como mover os diretórios TEMP e TMP em ambientes com e sem clusters. Antes de executar os procedimentos deste artigo, considere as seguintes recomendações:

  • Para obter o desempenho ideal, é recomendável que você não use o disco que contenha o sistema operacional das pastas TEMP e TMP usadas pelo Exchange. Além disso, você deve certificar-se de que essas variáveis de ambiente são definidas para caminhos em um disco ou subsistema de disco rápidos, como um conjunto de eixos RAID-0+1.

  • Recomendamos que você não use os logs de transação do Exchange em disco para as pastas TEMP e TMP usadas.

Para mover as pastas TEMP ou TMP em um ambiente sem clusters.

  1. Faça logon no computador que está executando o Exchange Server, com uma conta que tenha direitos administrativos.

  2. Clique com o botão direito em Meu Computador e selecione Propriedades.

  3. Selecione a guia Avançado.

  4. Clique em Variáveis de Ambiente.

  5. Na área Variáveis do sistema, selecione TEMP e clique em Editar.

  6. No campo Valor da variável, digite o novo caminho para a variável de ambiente TEMP e clique em OK.

  7. Na área Variáveis do sistema, selecione TMP e clique em Editar.

  8. No campo Valor da variável, digite o novo caminho para a variável de ambiente TMP e clique em OK.

  9. Clique em OK para fechar a caixa de diálogo Variáveis de Ambiente. Em seguida, clique em OK para fechar a caixa de diálogo Propriedades do Sistema.

  10. Reinicie o servidor para aplicar as alterações.
Para mover as pastas TEMP ou TMP em um ambiente com clusters.

  1. Faça logon em um nó do cluster como a conta de serviço do Cluster.

  2. Clique com o botão direito em Meu Computador e selecione Propriedades.

  3. Selecione Avançado.

  4. Clique em Variáveis de Ambiente.

  5. Na área Variáveis de usuário para área <nome de conta>, selecione TEMP e clique em Editar.

  6. No campo Valor da variável, digite o novo caminho para a variável de ambiente TEMP e clique em OK.

  7. Na área Variáveis de usuário para<account name>, selecione TEP e clique em Editar.

  8. No campo Valor da variável, digite o novo caminho para a variável de ambiente TMP e clique em OK.

  9. Clique em OK para fechar a caixa de diálogo Variáveis de Ambiente. Em seguida, clique em OK para fechar a caixa de diálogo Propriedades do Sistema.

  10. Reinicie o nó para aplicar a alteração.

  11. Repita as etapas de 1 a 10 para cada nó do cluster.
Importante:
Atribua à conta Usuários Autenticados as permissões adequadas ao novo caminho para as pastas TMP e TEMP.
Para atribuir ao grupo Usuários Autenticados permissões para as pastas TMP ou TEMP

  1. Inicie o Windows Explorer, localize e clique com o botão direito na pasta para a qual a variável TEMP ou TMP aponta e clique em Propriedades.

  2. Na caixa de diálogo Propriedades de Temp, clique na guia Segurança e depois em Adicionar.

  3. Na caixa de diálogo Selecionar Usuários, Computadores ou Grupos, adicione o grupo Usuários Autenticados à lista de nomes de objetos e clique em OK.

  4. Clique em Avançado para acessar as configurações de segurança avançadas.

  5. Selecione Usuários Autenticados na lista Nome e clique em Editar para exibir a caixa de diálogo Entrada de Permissão.

  6. Use os campos da área Permissões para conceder as seguintes permissões especiais:

    Desviar Pasta / Executar Arquivo

    Criar Arquivos / Gravar Dados

    Criar Pastas / Acrescentar Dados

  7. Clique em OK três vezes para aplicar as permissões e sair.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).


Mover Caixas de Correio de Usuário para Outro Servidor
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer determinou que o servidor apresenta atualmente uma carga de usuários mais alta do que pode suportar com eficiência. A carga de usuários atual está provocando problemas de desempenho. Recomenda-se mover usuários para outro local, movendo um pequeno número deles (normalmente, cinco por cento do total de usuários) a cada noite, até que os problemas de desempenho estejam resolvidos.

Essa abordagem é recomendada porque ocorreu um dos seguinte problemas:

  • Alguns arquivos do banco de dados do Exchange estão em disco que estão no limite, ou além, da capacidade de transferência.

  • Outros recursos do servidor (como memória ou CPU) estão acima da capacidade.

  • Um disco está acima da capacidade, o que significa que o subsistema do disco que atualmente suporta um ou mais armazenamentos do Exchange tem uma latência média de E/S do disco que excede os níveis atuais recomendados. Você deve mover cinco por cento dos usuários para um banco de dados de um subsistema de disco diferente até que o problema seja resolvido. Se as unidades de banco de dados estiverem congestionadas, mova os usuários para um banco de dados localizado em uma unidade diferente. Se uma unidade do grupo de armazenamento for o afunilamento, mova os usuários para um banco de dados de outro grupo de armazenamento localizado em outro banco de dados. Se as unidades forem compartilhadas por outro recurso, outra solução possível é reduzir a carga de outros aplicativos nessas unidades.

  • Seu servidor físico está acima da capacidade. Você não tem atualmente um processador ou memória suficiente para suportar a carga do servidor que os usuários estão gerando. Mova cinco por cento dos usuários para outro servidor até que os problemas de desempenho sejam resolvidos.

Observação:
Embora não seja necessário desconectar os clientes Exchange de suas caixas de correio durante uma operação de mover caixa de correio, é recomendável que essa operação ocorra no período de pouca atividade do cliente Exchange, como fora dos horários de pico, para evitar uma possível interrupção do serviço.
Para mover as caixas de correio no Exchange Server 2003

  1. Inicie o Gerenciador do Sistema do Exchange do computador do Exchange Server 2003 em que deseja executar o processo.

  2. Clique duas vezes em Servidores e localize o contêiner do servidor em que estão localizadas as caixas de correio dos usuários.

    Por exemplo, se você deseja mover as caixas de correio do grupo de armazenamento e do armazenamento de caixa de correio padrão, clique duas vezes em Primeiro Grupo de Armazenamento, clique duas vezes em Armazenamento da Caixa de Correio e clique em Caixas de Correio.

  3. No painel de detalhes, clique na caixa de correio que você deseja mover.

  4. Clique com o botão direito nos usuários selecionados e clique em Tarefas do Exchange.

  5. No Assistente de Tarefas do Exchange, clique em Avançar.

  6. Na página Tarefas Disponíveis, clique em Mover Caixa de Correio em Selecionar uma tarefa a ser executada e clique em Avançar.

  7. Na página Mover Caixa de Correio, na lista Servidor, clique no servidor desejado e na lista Armazenamento de Caixa de Correio, clique no armazenamento de caixa de correio desejado.

  8. Clique em Avançar.

  9. Configure como deseja que as mensagens danificadas encontradas durante a mudança sejam tratadas e clique em Avançar.

  10. Clique em Avançar.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre a movimentação de caixas de correio no Exchange Server 2003, consulte o artigo 821829 da Base de Dados de Conhecimento da Microsoft, "Movendo caixas de correio no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

  • Para obter mais informações sobre a movimentação de caixas de correio no Exchange 2000 Server e no Exchange Server 5.5, consulte o artigo 328810 da Base de Dados de Conhecimento da Microsoft, "Movendo caixas de correio entre servidores" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).


Problema de configuração de NAS
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchESEParamLogFilePath de cada objeto de grupo de armazenamento. Esse atributo especifica o local dos arquivos de log de transações usados por bancos de dados no grupo de armazenamento.

O Exchange Server Analyzer também consulta o Active Directory para determinar a contagem das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Além disso, o Exchange Server Analyzer também consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started para o serviço de pacote de recursos Microsoft Windows Storage Server 2003 (wssexchmap). Um valor False indica que o serviço do pacote de recursos Windows Storage Server 2003 não está em execução nesse servidor do Exchange. Um valor True indica que o serviço do pacote de recursos Windows Storage Server 2003 está em execução.

Se o Exchange Server Analyzer determinar que o valor de algum atributo msExchESEParamLogFilePath inicia por S:\{ e que o serviço do pacote de recursos Windows Storage Server 2003 foi iniciado em um computador do Exchange Server com mais de 1500 caixas de correio, será exibido um aviso.

O Windows Storage Server 2003 é a plataforma da Microsoft para dispositivos NAS. O layout do armazenamento do Windows Storage Server 2003 é recomendado para uso com o Exchange Server 2003 e é um pouco diferente do layout padrão do Exchange Server. A configuração recomendada é colocar os bancos de dados do Exchange Server no Windows Storage Server 2003 e colocar os arquivos de log de transações em um disco local no computador do Exchange Server.

A Microsoft desenvolveu o pacote de recursos Windows Storage Server 2003 para três tipos específicos de carga de trabalho:

  • Cargas de trabalho pequenas, de até 250 caixas de correio hospedadas por um Exchange Server conectado a um computador do Windows Storage Server. Nessa situação, a configuração do Windows Storage Server recomendada é um processador de 1 gigahertz (GHz) ou mais rápido, 512 megabytes (MB) de RAM, quatro discos SCSI ou IDE/SATA configurados como um volume RAID-5, e duas placas de interface de rede (NICs): uma para conexão com a LAN e um adaptador Gigabit Ethernet particular para conexão direta com o servidor Exchange. Os bancos de dados do Exchange são armazenados no volume RAID-5; os logs de transações permanecem no RAID-1 local do servidor Exchange.

  • Cargas de trabalho médias, de até 750 caixas de correio em um grupo de armazenamento, hospedadas por um Exchange Server e um único computador do Windows Storage Server. Nessa configuração, o computador do Windows Storage Server deve ter um par de processadores de 1 GHz ou mais rápidos, 1 gigabyte (GB) de RAM, seis discos SCSI e um par de NICs. Os discos devem estar configurados como uma matriz RAID-5 de 4 discos para bancos de dados e um conjunto separado de espelhos de dois discos para logs de transações.

  • Cargas de trabalho grandes, com um ou mais servidores Exchange Server 2003 hospedando até 1.500 caixas de correio em dois grupos de armazenamento. Nessa configuração, o Windows Storage Server deve ter dois processadores de 1 GHz ou mais rápidos, 2 GB de RAM, e um total de 14 discos. 10 para que uma matriz RAID 0+1 contenha os bancos de dados e dois conjuntos de discos espelhados para logs de transações.

Esse aviso indica que o computador Exchange Server foi configurado para usar o Windows Storage Server 2003 para armazenamento. Ao usar o Windows Storage Server para armazenamento de dados do Exchange Server, é recomendável que menos de 1.500 usuários acessem o Exchange Server ao mesmo tempo.

Para corrigir esse aviso

  • Siga um destes procedimentos:

    • Mova os logs de transação para um disco local no computador do Exchange Server

    • Mova algumas das caixas de correio deste computador do Exchange Server para outro, de modo que haja 1.500 caixas de correio ou menos no computador do Exchange Server que usa o Windows Storage Server.

Para obter mais informações sobre como usar o pacote de recursos Windows Storage Server 2003 com o Exchange Server 2003, consulte o documento Gerenciando o armazenamento do Exchange com o pacote de recursos Windows Storage Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?linkid=34942).

Para obter mais informações, consulte os seguintes recursos adicionais:

  • Introdução à arquitetura e implantação do Windows Storage Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?linkid=34943)

  • Criando um armazenamento mais bem protegido usando o Windows Storage Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?linkid=34944)

  • Consolidação de servidor usando o Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?linkid=47586)


O atributo networkAddress não está definido corretamente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo networkAddress contém a cadeia de caracteres ncacn_ip_tcp. O Exchange Server Analyzer exibe um erro se uma das seguintes condições existir:

  • A cadeia de caracteres ncacn_ip_tcp não existe.

  • A cadeia de caracteres ncacn_ip_tcp está danificada.

No Microsoft Office Outlook® Web Access para Exchange Server 2003, o servidor front-end examina o valor do atributo networkaddress quando ele tenta se conectar a um servidor back-end Exchange.

Observação:
O Exchange 2000 Server não faz isso com o Outlook Web Access.

O servidor front-end exige um valor FQDN (nome de domínio totalmente qualificado). O servidor front-end verifica se há um ponto no valor que é retornado para networkaddress ncacn_ip_tcp. A solicitação de conexão da caixa de correio no servidor back-end específico falhará e o servidor front-end retornará uma mensagem de erro "HTTP 500 Erro Interno do Servidor" para o usuário se existirem as seguintes condições:

  • O valor networkaddress ncacn_ip_tcp é apenas um nome de host ou um nome de sistema básico de entrada/saída de rede (NetBIOS).

  • O valor networkaddress ncacn_ip_tcp não é um FQDN.

Você deve atualizar o valor de networkaddress ncacn_ip_tcp do objeto do servidor no Active Directory para garantir a funcionalidade do Outlook Web Access 2003. O nome do servidor afetado é fornecido na mensagem de erro do Exchange Server Analyzer.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Observação:
Antes de atualizar o valor ncacn_ip_tcp, leia o restante deste artigo. Para minimizar a inatividade quando ao reiniciar os serviços do Exchange Server, você deve executar um procedimento adicional antes de reiniciar os serviços do Exchange Server.
Para atualizar o valor ncacn_ip_tcp no atributo networkAddress

  1. Inicie a ferramenta ADSI Edit nas ferramentas de suporte do Windows 2000 Server ou do Windows Server 2003.

  2. Expanda os seguintes nós:

    • Contêiner de Configuração

    • Configuração

    • Serviços

    • Microsoft Exchange

    • Nome_da_Organização

    • Grupos Administrativos

    • Nome_do_Grupo_Administrativo

    • Servidores

  3. Clique com o botão direito em Exchange_Server_Name e clique em Propriedades.

  4. Clique em networkaddress na lista Atributos e clique em Editar.

  5. Adicione um novo valor para ncacn_ip_tcp. Use o FQDN do servidor em vez do nome NetBIOS ou o nome do host do servidor.

    A sintaxe desse valor é ncacn_ip_tcp:FQDN. Por exemplo, se o seu servidor back-end Exchange possuir o nome de host EXCHANGE1 e o FQDN for EXCHANGE1.contoso.com, use o seguinte valor para ncacn_ip_tcp: ncacn_ip_tcp:EXCHANGE1.contoso.com

  6. Clique em OK duas vezes para aplicar a alteração.

  7. Reinicie todos os serviços do Exchange Server no servidor.

  8. Se houver vários controladores de domínio, aguarde que a replicação ocorra antes de tentar fazer logon a partir do servidor front-end. Se o problema não for resolvido após a conclusão da replicação, reinicie o Serviço de Administração do IIS no servidor front-end.

Se você mantiver arquivos host em servidores back-end para correlacionar um endereço IP de servidor com um nome de host curto, deve também atualizar o valor de UpdateProtocols registry. Se for usado um arquivo host, o Exchange Server pode retornar o valor de ncacn_ip_tcp quando o Atendente do Sistema do Microsoft Exchange for reiniciado. Se o servidor back-end estiver agrupado, o Exchange Server pode retornar o valor de ncacn_ip_tcp após o failover.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para modificar o valor do Registro UpdateProtocols para servidores back-end que usam arquivos de host

  1. Use um editor do Registro para configurar o seguinte valor do Registro no servidor ou servidores back-end: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    Observação:
    Se o valor UpdateProtocols não estiver presente, você deverá criá-lo. Para fazer isso, siga essas etapas:

  2. Abra um editor de Registro e localize a seguinte subchave do Registro: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    1. Clique com o botão direito em Parâmetros, aponte para Novo e clique em Valor DWORD.

    2. Digite UpdateProtocols e pressione ENTER.

  3. Clique com o botão direito em UpdateProtocols, clique em Modificar, digite 0 no campo Dados do valor e depois clique em OK.

  4. Se a rede usar um arquivo Hosts no nó do cluster back-end, modifique a ordem de entrada de UpdateProtocols da seguinte forma:

    IPAddress para FQDN

    IPAddress para NetBIOS

    em vez de:

    IPAddress para NetBIOS

    IPAddress para FQDN

  5. Reinicie todos os serviços do Exchange Server no servidor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O objeto do monitor de desempenho de Interface de Rede não está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Bytes Total/sec do objeto de desempenho de Network Interface para analisar os dados do desempenho. Se o contador não retornar dados válidos, o Analisador do Exchange Server exibirá uma mensagem de linha de base.

Se o mecanismo de coleta de dados de desempenho não retornar dados válidos, qualquer combinação das seguintes condições será verdadeira:

  • O objeto do desempenho do Network Interface está desabilitado.

  • O objeto do monitor de desempenho do Network Interface está ausente ou danificado.

  • O Analisador do Exchange Server não tem permissões adequadas para acessar os objetos de desempenho.

As duas primeiras condições poderão ocorrer se alguns contadores extensíveis danificarem o Registro ou se programas baseados na WMI (Instrumentação de Gerenciamento do Microsoft Windows®) modificarem o Registro. Antes de executar o procedimento, verifique se o Analisador do Exchange Server tem as permissões adequadas. Para obter mais informações sobre as permissões necessárias para executar o Analisador do Exchange Server, consulte a documentação da Ajuda incluída no Analisador do Exchange Server. Para obter Ajuda, abra o Analisador do Exchange Server e pressione a tecla F1.

Para corrigir esse erro

  1. Verifique se o objeto de desempenho do Network Interface está habilitado.

    1. Baixe e instale a ferramenta Lista de Contadores de Desempenho Extensíveis (Exctrlst.exe). Você pode baixar o Exctrlst.exe em "Exctrlst.exe: Lista de Contadores de Desempenho Extensíveis" (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Abra o Exctrlst.exe, clique em Ordem de classificação, e clique em Serviço.

    3. Localize o serviço ao qual o objeto de desempenho relata e verifique se a caixa de seleção Contadores de Desempenho Habilitados está marcada.

      Se a caixa de seleção Contadores de Desempenho Habilitados não estiver marcada, marque a caixa de seleção e reinicie o serviço que está associado aos contadores de desempenho para verificar se os contadores de desempenho estão em operação. Se os contadores de desempenho não estiverem funcionando ou se a caixa de seleção Contadores de desempenho habilitados já estava marcada, continue na etapa 2.

  2. Reconstrua os contadores de desempenho ausentes ou danificados, conforme descrito no artigo 300956 da Base de Dados de Conhecimento da Microsoft, "Como reconstruir manualmente os valores de biblioteca do contador de desempenho" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Se você seguir as instruções desse artigo da Base de Dados de Conhecimento e o problema não for solucionado, será necessário reinstalar o sistema operacional Windows no modo Reparo e, em seguida, aplicar os service packs mais recentes do Windows.


MSGTRACK.dll disponível mais recente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-10-05

A ferramenta Microsoft® Exchange Server Analyzer Tool dispõe de um mecanismo de coleta de dados de desempenho usado para consultar objetos do contador de desempenho em computadores que estejam executando o Exchange 2000 Server ou o Exchange Server 2003. Esse mecanismo coleta dados de vários contadores do objeto de desempenho do processador para analisá-los.

O Exchange Server Analyzer também consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor definido para a chave Version do arquivo Msgtrak.dll.

O Exchange Server Analyzer exibirá um aviso se as seguintes condições forem verdadeiras:

  • O servidor está detectando alto uso da CPU.

  • O valor da chave Version para o arquivo Msgtrak.dll é anterior a 6.0.6373.0.

Esse aviso indica que a versão do Msgtrack.dll encontrada pode causar o alto uso da CPU. O aviso também indica que a versão do Msgtrack.dll encontrada pode fazer com que o processo Inetinfo.exe mostre um uso de memória muito alto.

Para resolver esse problema, obtenha a atualização mencionada no artigo 811409 da Base de Dados de Conhecimento Microsoft, "XADM: O controle de mensagens pode fazer com que o processo Inetinfo.exe mostre um uso de memória muito alto" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=811409) (pode estar em inglês).


WLDAP32.DLL mais recente disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer Tool dispõe de um mecanismo de coleta de dados de desempenho usado para consultar objetos do contador de desempenho em computadores que estejam executando o Exchange 2000 Server ou o Exchange Server 2003. Esse mecanismo coleta dados de vários contadores do objeto de desempenho do processador para analisá-los.

O Exchange Server Analyzer lê também a entrada do Registro a seguir para determinar a versão do Microsoft Windows® que está sendo executada no computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor de CurrentVersion igual a 4.0 indica que o computador do Exchange Server está executando o Microsoft Windows NT® 4.0. Um valor igual a 5.0 indica que o computador do Exchange Server está executando o Windows 2000 Server e um valor igual a 5.2 indica que o computador do Exchange Server está executando o Windows Server™ 2003.

Por fim, o Exchange Server Analyzer também consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar o valor definido para a chave Version do arquivo Wldap32.dll.

O Exchange Server Analyzer exibirá um aviso se as seguintes condições forem verdadeiras:

  • O Exchange Server Analyzer detectou alta utilização da CPU no servidor que está sendo analisado.

  • O computador do Exchange Server está executando o Windows 2000 Server.

  • O valor da chave version do arquivo Wldap32.dll indica uma versão anterior à versão 5.0.2195.7044.

Este aviso indica que a versão do Wldap32.dll encontrada pode fazer com que o processo Inetinfo.exe consuma 100% da CPU em sistemas Windows 2000 Server.

Para resolver esse problema, obtenha a atualização mencionada no artigo 899019 da Base de Dados de Conhecimento Microsoft, "O processo Inetinfo.exe pode usar 100% dos recursos da CPU em um computador do Windows 2000 Server que esteja executando o Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=899019) (pode estar em inglês).


Serviço NNTP habilitado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave Started para o serviço do protocolo NNTP (NntpSvc). Um valor True indica que o serviço do protocolo NNTP está sendo executado nesse servidor Exchange.

O Exchange Server Analyzer também lê a seguinte propriedade na metabase do IIS (Serviços de Informações da Internet) para determinar se há uma alimentação de NNTP configurada para o servidor Exchange:

/LM/NNTPSVC/1/Feeds

Se o Exchange Server Analyzer verificar que o serviço NNTP foi iniciado, mas não houver alimentações configuradas para o servidor, será exibido um aviso.

Para salvar recursos e como precaução geral de segurança, você não deve executar serviços para componentes que não estão sendo usados. Cada serviço que é executado expõe funcionalidades que usuários mal-intencionados podem explorar. É recomendável desabilitar todos os serviços que não estão sendo usados.

Para desabilitar o Serviço NNTP

  1. Clique em Iniciar, clique em Programas, Ferramentas Administrativas e clique em Serviços.

  2. Clique com o botão direito no serviço Protocolo NNTP e clique em Propriedades.

  3. Na guia Geral clique em Parar.

  4. Em Tipo de Inicialização, selecione Desativado e clique em OK.

Para obter mais informações sobre como proteger o Exchange Server 2003, consulte Guia de Fortalecimento de Segurança do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?linkid=47578).


Não há servidores DNS disponíveis para testes
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-12-05

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_NetworkAdapterConfiguration do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para obter o atributo DNSServerSearchOrder para servidores remotos para os quais o servidor que está executando o Exchange Server tenta enviar mensagens. Esse atributo é uma matriz de endereços IP do servidor que são usados para consultar servidores DNS (Sistema de Nome de Domínio).

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchSMTPExternalDNSServers na classe protocolCfgSMTPServer para os objetos de servidor Exchange 2000 Server e Exchange Server 2003. A classe protocolCfgSMTPServer contém as configurações de um servidor virtual SMTP. Se o atributo msExchSMTPExternalDNSServers estiver definido, o servidor virtual SMTP usará um servidor DNS externo.

Finalmente, o Exchange Server Analyzer usa o seguinte cmdlet do Shell de Gerenciamento do Exchange para consultar os valores das propriedades ExternalDNSServers e InternalDNSServers de quaisquer funções de servidor Transporte do Exchange 2007 de destino. A propriedade ExternalDNSServers especifica a lista de servidores DNS externos que o servidor consulta ao resolver um domínio remoto. A propriedade InternalDNSServers especifica a lista de servidores DNS que devem ser usados para resolver um nome de domínio local para o servidor de destino.

Código da Cópia
get-TransportServer -Identity %ExchangeServerName% -DomainController %DomainControllerName%

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O Exchange Server Analyzer não pode recuperar com êxito o valor do atributo DNSServerSearchOrder. Ou então, o atributo não contém dados.

  • O atributo msExchSMTPExternalDNSServers dos objetos de servidor Exchange 2000 Server e Exchange Server 2003 não está definido.

  • Os valores das propriedades ExternalDNSServers e InternalDNSServers para as funções de servidor Transporte do Exchange 2007 de destino não contêm dados.

Esse erro indica que o Exchange Server Analyzer não pode identificar nenhum servidor DNS que seja usado pelo servidor Exchange de destino. Além disso, o fluxo de mensagens pode ser prejudicado por essa condição.

As possíveis causas dessa condição podem incluir o seguinte:

  • O DNS está configurado incorretamente no servidor de destino.

  • O WMI está falhando ou não pode ser acessado.

Para resolver esse problema:

  • Reveja a configuração de DNS no servidor de destino.

  • Verifique se o WMI do Exchange pode ser acessado.

Para verificar se o WMI do Exchange pode ser acessado

  1. Verifique se o servidor Exchange foi iniciado e está conectado à rede.

  2. Use o comando PING para verificar se o servidor Exchange está acessível.

  3. Se houver um firewall, verifique se as portas de RPC (chamada de procedimento remoto) estão bloqueadas.

  4. Examine as permissões da conta na qual o Exchange Server Analyzer está sendo executado. A conta na qual o Exchange Server Analyzer está sendo executado deve ter permissões de Administrador local em cada servidor Exchange que ele verifica.

    Ou então, você pode conceder permissão específica de WMI para a conta na qual o Exchange Server Analyzer é executado:

    1. No servidor Exchange, abra a árvore do MMC (Console de Gerenciamento Microsoft) Gerenciamento do Computador.

    2. Em Serviços e Aplicativos, clique com o botão direito em Controle WMI e clique em Propriedades.

    3. Na página Propriedade dos Controles WMI, clique na guia Segurança e expanda Raiz.

    4. Selecione a pasta CIMV2 e clique em Segurança.

    5. Na página Segurança para ROOT\CIMV2, adicione a conta sob a qual o Exchange Server Analyzer está sendo executado.

  5. Selecione a conta adicionada na etapa 4. Em Permissões para Conta_Selecionada, na coluna Permitir, selecione Habilitação Remota e Ler Segurança e clique em OK.

Para obter mais informações sobre como configurar o DNS para trabalhar com o Exchange Server, consulte o artigo 322856 da Base de Dados de Conhecimento Microsoft, "Como configurar o DNS para usar com o Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

Para obter mais informações sobre problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento Microsoft , "Como solucionar problemas de conectividade de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Para obter mais informações sobre problemas de conectividade do Exchange Server Analyzer, consulte "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56285).

Para obter mais informações sobre requisitos de portas, consulte o artigo 832017 da Base de Dados de Conhecimento Microsoft, "Visão geral de serviço e requisitos de porta de rede para o sistema do Windows Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Nenhum SID de conta principal
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-02-14

A ferramenta Microsoft Exchange Analyzer Tool consulta a classe Win32_NTLogEvent de WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar se um aviso Evento 9548 foi registrado para o MSExchangeIS na última hora.

Se o Exchange Analyzer detectar que um aviso Evento 9548 foi registrado na última hora, ele contará o número total de avisos registrados durante essa hora.

Por último, se o Exchange Analyzer detectar que um aviso Evento 9548 foi registrado 20 vezes ou mais na última hora, ele exibirá um aviso.

Esse aviso indica que pode haver contas de usuário do serviço de diretório do Active Directory desabilitadas, as quais estão associadas às caixas de correio do Exchange Server e não têm atributos msExchMasterAccountSID válidos.

Para estar disponível, uma caixa de correio em um servidor que executa o Microsoft Exchange Server 2003 ou o Exchange 2000 Server deve estar vinculada a uma conta de usuário do serviço de diretório do Active Directory. Esse link é estabelecido, em parte, pela definição do atributo msExchMasterAccountSid do Active Directory na caixa de correio. A conta do Active Directory à qual a caixa de correio do Exchange está vinculada pode estar em um estado habilitado ou desabilitado. Somente contas desabilitadas deverão ter um usuário que possua o atributo msExchMasterAccountSid.

Se o valor do atributo msExchMasterAccountSid em uma conta de usuário desabilitada estiver em branco ou for danificado, e uma ACL (Lista de Controle de Acesso) que inclui a conta do usuário for criada, poderão ocorrer problemas de desempenho quando essa ACL for usada para acessar recursos de pasta pública ou caixa de correio.

Para tratar desse aviso:

  • Verifique se o Exchange Server 2003 Service Pack 2 (SP2) está instalado com o hotfix mencionado no artigo 916783 da Base de Dados de Conhecimento Microsoft, "Um hotfix está disponível para alterar a maneira como o Exchange Server 2003 SP2 trata uma conta de usuário do Active Directory desabilitada que está associada a uma caixa de correio do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783)

  • Examine a ACL e a conta do usuário indicadas no aviso Evento 9548 para descobrir se o valor de atributo msExchMasterAccountSid está em branco ou foi danificado e, se for necessário, gere um valor de atributo msExchMasterAccountSID válido para a conta, seguindo a orientação do artigo 328880 da Base de Dados de Conhecimento Microsoft, "Como solucionar problemas de desempenho de pasta pública relacionados às conversões da ACL no Exchange 2000 e no Exchange 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880)

  • Remova da ACL a conta de usuário desabilitada, seguindo a orientação do artigo 278966 da Base de Dados de Conhecimento Microsoft, "Não é possível mover ou efetuar logon em uma caixa de correio de recursos do Exchange" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966)

Para obter mais informações

Para obter mais informações sobre esse problema, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft e os recursos do Exchange Server:

  • Events and Errors Message Center: detalhes do evento: Detalhes do Evento 9548 de armazenamento de caixa de correio do MSExchangeIS (em inglês) (http://go.microsoft.com/fwlink/?LinkId=83135)

  • Artigo 916783 da Base de Dados de Conhecimento Microsoft, "Um hotfix está disponível para alterar a maneira como o Exchange Server 2003 SP2 trata uma conta de usuário do Active Directory desabilitada que está associada a uma caixa de correio do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783)

  • Artigo 328880 da Base de Dados de Conhecimento Microsoft, "Como solucionar problemas de desempenho de pasta pública relacionados às conversões da ACL no Exchange 2000 e no Exchange 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880)

  • Artigo 278966 da Base de Dados de Conhecimento Microsoft, "Não é possível mover ou efetuar logon em uma caixa de correio de recursos do Exchange" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966)


Nenhuma instância de SMTP encontrada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-08-08

A ferramenta Microsoft® Exchange Server Analyzer consulta no serviço de diretório do Active Directory® o atributo distingushedName da classe de objeto protocolCfgSMTPServer para saber se a instância de servidor virtual SMTP (Simple Mail Transfer Protocol) está executando para o nome de servidor do gateway do Exchange especificado pelo usuário.

Se o Exchange Server Analyzer não encontrar uma instância de serviço virtual SMTP para o servidor gateway do Exchange especificado pelo usuário, será exibido um erro.

Esse erro pode ser ocasionado por problemas temporários na rede mas também pode indicar informações incorretas no Active Directory.

Para resolver esse problema, examine se o servidor gateway do Exchange especificado pelo usuário consta na configuração do servidor virtual SMTP.

Para exibir a configuração da instância do servidor virtual SMTP

  1. Inicie o Gerenciador do Sistema do Exchange:

    Clique em Iniciar, aponte para Programas, Microsoft Exchange e clique em Gerenciador do Sistema.

  2. Navegue para o seguinte contêiner:

    \Administrative Groups\GroupName\Servers\ServerName\Protocols\SMTP\SMTP Virtual Server Instance\

  3. Clique com o botão direito na instância do servidor virtual SMTP e selecione Propriedades.

  4. Verifique se a configuração da instância do servidor virtual SMTP está correta.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 266686, "XCON: How to Configure a SMTP Virtual Server Part 1" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, "XCON: How to Configure a SMTP Virtual Server Part 2" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Para obter mais informações sobre o design do serviço SMTP, consulte "Design do serviço SMTP" no Guia de Referência Técnica do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876) (em inglês).

Para obter mais informações sobre problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento Microsoft , "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487) (em inglês).


O servidor de destino NSPI foi substituído manualmente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas de Registro para determinar se o serviço do servidor de destino NSPI(Interface de Provedor de Serviço de Nome) foi substituído manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\NSPI Target Server

Se o Exchange Server Analyzer detectar que Servidor de Destino NSPI está presente e configurado, será exibida uma mensagem de configuração não padrão.

Tipos diferentes de clientes usam controladores de domínios e servidores de catálogo globais de formas diferentes para obter o acesso à GAL (lista global de endereços). Os clientes do Exchange anteriores ao Microsoft Outlook® 2000 Service Release 2 (SR-2) esperam encontrar um serviço de diretório no servidor Exchange. O Exchange 2000 Server e o Exchange Server 2003 usam um mecanismo chamado DSProxy (Directory Service Proxy) para estabelecer uma conexão com o servidor de catálogo global mais próximo em nome do cliente e comunicações de proxy entre o Outlook e o servidor de catálogos global. Dependendo dos requisitos de implantação, você pode especificar explicitamente um servidor de catálogos global particular, que deve ser usado para manipular as solicitações do DSProxy. Você pode fazer isso codificando a entrada Servidor de Destino NSPI do Registro no servidor Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para especificar manualmente um NSPI Server

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Crie um novo valor REG_MULTISZ chamado Servidor de Destino NSPI.

  4. Configure o valor Servidor de Destino NSPI com o nome de domínio completo para os servidores que deseja especificar.

Para desabilitar uma configuração estática para o servidor NSPI, remova a entrada de nome de domínio totalmente qualificada do servidor que deseja remover. Se houver somente um servidor de destino NSPI inserido, exclua o valor de Registro Servidor de Destino NSPI.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como o Outlook 2000 SR-2 e os clientes mais recentes interagem com o serviço de diretório do Active Directory®, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 302914, "XCCC: Como o Outlook 2000 acessa o Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914) (em inglês)

  • 256976, "XCLN: Como os clientes MAPI acessam o Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976) (em inglês)


Um subsistema MAPI não pertencente ao Exchange Server está instalado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar a versão de MAPI32.dll que está nestas duas pastas:

<unidade>:\Arquivos de Programas\Exchsrvr\Bin

%Systemroot%\System32

Se a mesma versão e a mesma cópia de MAPI32.dll não for encontrada em ambas as pastas, será exibido um erro.

Para garantir que uma única versão do MAPI está em uso, a Instalação do Exchange Server copia MAPI32.dll para os diretórios <unidade>:\Arquivos de Programas\Exchsrvr\Bin e %Systemroot%\system32. Se outro aplicativo de MAPI, como o Microsoft Office Outlook® 2003 ou um programa de terceiros, estiver instalado no computador do Exchange Server, ele poderá copiar uma versão diferente de MAPI32.dll na pasta System32 e possivelmente interromper a funcionalidade do Exchange. Esses problemas ocorrem porque versões desses dois produtos produzem um conflito do subsistema MAPI que não pode ser solucionado facilmente sem interromper o Exchange Server ou outro aplicativo MAPI.

É altamente recomendável que você não instale o Outlook 2000 ou uma versão posterior do Outlook e o Exchange Server 2003, o Exchange 2000 Server ou o Exchange Server 5.5 no mesmo computador.

Um motivo comum para instalar o Outlook no mesmo computador que o Exchange Server é aproveitar certos componentes do Outlook em programas de servidor. Para a maioria dos requisitos de desenvolvimento de programa, o Outlook não é necessário em um computador do Exchange. O Exchange Server inclui CDO (Objetos de Dados de Colaboração), que podem fornecer funcionalidade similar ao modelo de objeto do Outlook. O CDO foi criado para uso de servidores e também evita as implicações incluídas em versões posteriores do Outlook. Para obter mais informações, consulte o artigo 290500 da Base de Dados de Conhecimento Microsoft, " Descrição dos recursos de segurança de email relacionados ao desenvolvedor no Outlook 2002" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=290500).

Outro motivo comum é a necessidade de criar perfis MAPI. O Exchange Server inclui toda a funcionalidade necessária para criar perfis MAPI e não exige o Outlook por nenhum motivo. Para obter mais informações sobre como criar perfis MAPI sem instalar o Outlook, consulte o artigo 306962 da Base de Dados de Conhecimento, "COMO FAZER: Criar perfis MAPI sem instalar o Outlook" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306962).

Se você precisar instalar o Outlook e o Exchange Server no mesmo computador com fins de demonstração, é recomendável utilizar somente uma das configurações a seguir, que foram testadas com fins de demonstração:

  • Exchange 2000 Server usado com o Outlook 2000

  • Exchange 2000 Server usado com o Outlook 2002

Para corrigir esse erro

  1. Desinstale o Microsoft Outlook ou o aplicativo de MAPI de terceiros do servidor Exchange.

  2. Execute novamente a Instalação do Exchange Server e clique em Reinstalar.

Para obter mais informações sobre como usar o Microsoft Office Outlook 2003 e o Microsoft Exchange Server no mesmo computador, consulte o artigo 266418 da Base de Dados de Conhecimento Microsoft, "XCCC: A Microsoft não suporta a instalação de componentes do Exchange Server e do Outlook no mesmo computador" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418).

Para obter mais informações sobre resolução de conflitos de MAPI, consulte o artigo 229700 da Base de Dados de Conhecimento, "COMO FAZER: Encontrar o caminho correto para MAPISVC.INF no Outlook 2000" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=229700).

Para obter mais informações sobre a biblioteca de stubs de MAPI32, consulte API de Mensagens (MAPI) (página em inglês) (http://go.microsoft.com/fwlink/?linkid=34395).


Mecanismo ESE não-Microsoft detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version do Ese.dll, o Mecanismo de Armazenamento de Banco de Dados do Exchange, também conhecido como ESE (Mecanismo de Armazenamento Extensível).

O Analisador do Exchange Server também consulta o serviço Active Directory® para conhecer o valor do atributo serialNumber de todos os objetos da classe msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 5.5", o computador está executando o Microsoft Exchange Server 5.5. Se o valor da cadeia de caracteres incluir "Version 6.0", o computador está executando o Microsoft Exchange 2000 Server. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador está executando o Microsoft Exchange Server 2003.

Se o Exchange Server Analyzer detectar que o valor de Version não contém uma subcadeia de caracteres de 6 como parte da informação da versão, mas o valor de serialNumber indicar que o Exchange 2000 Server ou Exchange Server 2003 está instalado, será exibido um aviso. Esse aviso indica que uma versão não-Microsoft do Ese.dll está instalada e sendo usada neste computador do Exchange Server. Você deve corrigir esse problema o mais rápido possível.

Uma possível causa dessa ocorrência é o uso de software antivírus baseado no ESE. Alguns programas antivírus com base no ESE usam uma interface sem suporte entre o armazenamento de informações do Exchange e o ESE. Ao usar esse tipo de software, você corre o risco de danos e perda de dados no banco de dados caso haja ocorrência de erros na implantação do software.

Durante a instalação, o verificador baseado no ESE altera o serviço de Armazenamento de Informações do Microsoft Exchange para que ele dependa do serviço do programa antivírus com base no ESE. Isso garante que o serviço do programa antivírus com base no ESE será iniciado antes de o serviço do Armazenamento de Informações do Microsoft Exchange iniciar. Quando o programa antivírus com base no ESE for iniciado, a versão do Ese.dll incluída no Exchange Server será temporariamente renomeada como Xese.dll e a versão do programa antivírus com base no ESE do Ese.dll substituirá o arquivo original. Depois que a versão do Ese.dll do programa antivírus com base no ESE for carregada, a versão incluída no Exchange Server será novamente renomeada para Ese.dll e o serviço de Armazenamento de Informações do Microsoft Exchange Information concluirá o processo de inicialização.

É recomendável que você não use implementações não-Microsoft do ESE em computadores do Exchange Server. Clientes que entram em contato com o Atendimento Microsoft podem ser solicitados a desabilitar o programa antivírus com base no ESE para ajudar a identificar problemas, mas estão livres para habilitar novamente o software depois que a causa raiz do problema for diagnosticada corretamente.

O programa antivírus com base no ESE mais amplamente usado é o Antigen para Microsoft Exchange da Sybari Software. A Microsoft e a Sybari concordam que a desabilitação do Sybari Antigen é uma etapa de solução de problemas válida para determinar a causa de problemas. Para entrar em contato com a Sybari Software, visite o site dessa empresa ( http://www.sybari.com).

Observação:
As informações sobre sites de terceiros são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.

Também é recomendável utilizar programas antivírus que ofereçam suporte para VSAPI (Virus Scanning Application Programming Interface), também conhecida como AVAPI (Antivirus API).

Para corrigir esse aviso

  1. Execute um backup completo do computador do Exchange Server.

  2. Desinstalar o Exchange Server do computador.

  3. Reinstale o Exchange Server no computador.

  4. Aplique o service pack e as atualizações mais recentes para o Exchange Server.

Para obter mais informações sobre como executar o software antivírus no Exchange Server, consulte os seguintes artigos na Base de Dados de Conhecimento da Microsoft:

  • 823166, "Visão geral do Exchange Server 2003 e software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)

  • 328841, "XADM: Exchange e Software Antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)


Mecanismo de Armazenamento Extensível que não é da Microsoft detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version para Ese.dll, o Mecanismo de Armazenamento de Banco de Dados do Exchange, também conhecido como ESE (Mecanismo de Armazenamento Extensível).

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para todos os objetos com a classe de objeto msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 5.5", o computador está executando o Microsoft Exchange Server 5.5. Se o valor da cadeia de caracteres incluir "Version 6.0", o computador está executando o Microsoft Exchange 2000 Server. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador está executando o Microsoft Exchange Server 2003.

Se o Exchange Server Analyzer verificar que o valor de Version não contém uma subcadeia de caracteres 5.5 como parte de suas informações de versão, mas que o valor de serialNumber indica que o Exchange Server 5.5 está instalado, será exibido um aviso. Esse aviso indica que uma versão não-Microsoft do Ese.dll está instalada e sendo usada neste computador do Exchange Server. Você deve corrigir esse problema o mais rápido possível.

Uma possível causa disso é o uso de software antivírus com base no ESE. Alguns programas antivírus com base no ESE usam uma interface sem suporte entre o armazenamento de informações do Exchange e o ESE. Ao usar esse tipo de software, você corre o risco de danos e perda de dados no banco de dados caso haja ocorrência de erros na implantação do software.

Durante a instalação, o verificador baseado no ESE altera o serviço de Armazenamento de Informações do Microsoft Exchange para que ele dependa do serviço do programa antivírus com base no ESE. Isso garante que o serviço do programa antivírus com base no ESE será iniciado antes de o serviço do Armazenamento de Informações do Microsoft Exchange iniciar. Quando o programa antivírus com base no ESE for iniciado, a versão do Ese.dll incluída no Exchange Server será temporariamente renomeada como Xese.dll e a versão do programa antivírus com base no ESE do Ese.dll substituirá o arquivo original. Depois que a versão do Ese.dll do programa antivírus baseado no ESE for carregada, a versão incluída no Exchange Server será renomeada como Ese.dll, e o serviço Armazenamento de Informações do Microsoft Exchange finalizará o processo de inicialização.

É recomendável que você não use implementações não-Microsoft do ESE em computadores do Exchange Server. Clientes que entram em contato com o Atendimento Microsoft podem ser solicitados a desabilitar o programa antivírus com base no ESE para ajudar a identificar problemas, mas estão livres para habilitar novamente o software depois que a causa raiz do problema for diagnosticada corretamente.

Para corrigir esse aviso

  1. Execute um backup completo do computador do Exchange Server.

  2. Reinstale o Exchange Server no computador.

  3. Aplique o service pack e as atualizações mais recentes no Exchange Server, os quais podem ser obtidos no site do Microsoft Exchange Server (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=21573).
  • Para obter mais informações sobre como executar software antivírus no Exchange Server, consulte o artigo 328841 da Base de Dados de Conhecimento Microsoft, "XADM: Exchange e software antivírus" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

  • Para obter mais informações sobre como reconstruir um computador do Exchange Server 5.5 usando o mesmo nome de computador, consulte o artigo 155216 da Base de Dados de Conhecimento, "XADM: Como mover o Exchange Server para um novo computador com o mesmo nome" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=155216).


Pool Não Paginado está acima do limite de aviso
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_PerfRawData_PerfOS_Memory do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor atual da chave PoolNonpagedBytes. As ações tomadas pelo Exchange Server Analyzer dependem do sistema operacional subjacente, da presença ou ausência da opção /3GB no arquivo Boot.ini do Windows e do valor descoberto para essa chave.

A tabela a seguir exibe a matriz de avaliações usada pelo Exchange Server Analyzer para descobrir se esse valor está fora dos limites para um servidor especificado do Exchange. Se as condições da tabela a seguir se confirmarem, será exibido um aviso.

Sistema operacional | Configuração do boot.ini | O pool atual não paginado é
Microsoft Windows 2000 Server ou Advanced Server | /3GB | 100 MB ou mais
Microsoft Windows 2000 Server ou Advanced Server | Nenhum | 200 MB ou mais
Microsoft Windows Server™ 2003 | /3GB | 100 MB ou mais
Microsoft Windows Server 2003 | Nenhum | 200 MB ou mais

O valor da chave PoolNonpagedBytes é o tamanho, em bytes, do pool não paginado da memória do kernel. Essa é uma área da memória física do sistema para os objetos que não puderem ser gravados em disco quando não estiverem em uso. O valor para essa chave é o ultimo valor observado. Em um servidor Exchange íntegro, a menos que esteja ocorrendo uma operação de backup ou restauração, não deverão existir mais de 85 MB da memória de pool não paginado sendo usados.

No Windows 2000 Server e Windows 2000 Advanced Server, o valor máximo da memória de pool não paginado é de 256 MB. Como não é possível aumentar o limite da memória de pool não paginado além dos valores listados anteriormente, essa condição deverá ser corrigida o mais rapidamente possível. Independentemente do sistema operacional em uso ou da presença ou ausência da opção /3GB, somente esse limite de memória de pool não paginado pode ser acessado pelo Windows. Se o Windows ficar sem memória do kernel, ele poderá exibir mensagens de erro e falhar. A memória do kernel é fundamental para o funcionamento correto do sistema e, portanto, você deve monitorá-la com muita atenção.

Se depois do reinício do Exchange Server, essa condição se repetir, a próxima etapa é verificar se o sistema está corretamente ajustado e se todos os itens do software e hardware existentes no sistema estão atualizados. Isso inclui a instalação mais recente de:

  • Service pack do sistema operacional Windows

  • Service pack do Exchange Server

  • Firmware e drivers do hardware

  • Atualizações de BIOS do sistema

  • Atualizações de quaisquer aplicativos de terceiros que estejam instalados e em execução

Se as atualizações do software e hardware não resolverem esse problema, desabilite todo o software de terceiros, reinicie o computador do Exchange Server e monitore a memória do kernel.

Para corrigir esse erro

  1. Reinicie o computador do Exchange Server o mais rápido possível.

  2. Monitor o contador de desempenho Memória | Bytes do Pool Não Paginado para ter certeza de que ele não está ultrapassando o limite listado anteriormente para seu sistema.

Para obter mais informações sobre como ajustar corretamente o Exchange Server, consulte os seguintes artigos e informes oficiais da Base de Dados de Conhecimento da Microsoft:

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • 266096, "XGEN: O Exchange 2000 exige a opção /3GB com mais de 1 gigabyte de RAM física" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • "Troubleshooting Exchange Server 2003 Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Troubleshooting Exchange 2000 Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=18177)

  • "Exchange Server 2003 Performance and Scalability Guide" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576)

Para obter mais informações sobre a memória de pool não paginado e tópicos relacionados, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 294418, "Comparação entre as arquiteturas de 32 e 64 bits" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294418)

  • 177415, "Como usar o monitor do pool de memória (poolmon.exe) para solucionar problemas de perdas de memória no modo kernel" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=177415)

  • 268343, "Umdhtools.exe: Como usar o umdh.exe para detectar perdas de memória" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268343)


O número de entradas de tabela de página livres é baixo, o que causa instabilidade do sistema
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar a configuração do valor do Registro SystemPages:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Se o Analisador do Exchange Server detectar que o valor de SystemPages foi definido como 0 e que o número de PTEs (entradas de tabela de página) livres no sistema é inferior a 3001, será exibido um aviso.

O Microsoft Windows Server™ 2003 e o Windows® 2000 Server podem atender diretamente até 4 GB (gigabytes) de espaço de endereçamento na memória, independentemente da quantidade física de RAM instalada. Do ponto de vista do processo, cada elemento do endereço virtual conceitualmente refere-se a um byte de memória física. É responsabilidade do VMM (Gerenciador de Memória Virtual), em conjunto com a MMU (unidade de gerenciamento de memória) do processador, converter ou mapear cada endereço virtual em um endereço físico correspondente. O VMM executa o mapeamento dividindo a RAM em quadros de páginas de tamanho fixo, criando PTEs de sistema para armazenar informações sobre esses quadros de páginas e mapeá-los. As PTEs do sistema são pequenos buffers de memória no modo kernel que são usados para fazer a comunicação com o subsistema de E/S e a rede. Cada PTE representa um quadro de página e contém as informações necessárias para o VMM localizar uma página.

Em um sistema baseado em x86 que usa um tamanho de página igual a 4 KB, o número máximo de PTEs necessárias para mapear 2 GB de espaço de endereçamento é 524.288 (2 GB/4 KB). Em um sistema semelhante usando a opção de /3GB, o número de PTEs necessárias para mapear 3 GB de espaço de endereçamento é 786.432 (3 GB/4 KB). Em um sistema típico, esse espaço é usado como a seguir:

  • Um máximo de 50.000 PTEs (aproximadamente 195 MB de espaço de endereçamento) são reservadas para uso geral.

  • O restante é usado para mapear o cache de sistema, hiperespaço, pool paginado, pool não paginado, área de despejo de memória e assim por diante.

Esse tamanho de pool da PTE é automaticamente determinado na inicialização do sistema baseado na quantidade de memória física do sistema. Esse pool é comprimido entre o pool paginado e o pool não paginado, que também cresce com a quantidade de memória física no sistema.

O pool da PTE do sistema pode tornar-se muito usado e muito fragmentado. Isso pode levar a situações em que um driver não pode ser carregado. Além disso, se o pool da PTE do sistema estiver completamente vazio, outras partes do sistema serão prejudicadas, resultando em segmentos que não são criados, paralisações do sistema e falhas potenciais do sistema.

Um computador do Exchange Server íntegro deve ter ao menos 5.000 PTEs de sistema disponíveis o tempo todo. Se o número de PTEs livres no sistema cair para menos de 5.000, mas permanecer acima de 3.001, o aviso descrito em As PTEs (entradas de tabela de página) livres estão no limite de aviso será exibido. Quando o número de PTEs livres do sistema cai abaixo de 3,001, esse erro é exibido. Para resolver esse problema, você pode usar o procedimento abaixo para configurar o valor do Registro SystemPages de forma apropriada para o sistema operacional do computador do Exchange Server. Quando você estiver executando o Exchange Server 2003 Service Pack 1 (SP1) no Windows Server 2003 com 1 GB ou mais de RAM, recomenda-se definir a chave de Registro SystemPages como 0. Essa recomendação contrasta com a recomendação para o Windows 2000 Server, que é definir SystemPages para um valor entre 24.000 e 31.000.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Depois de executar o procedimento descrito abaixo, você deve monitorar o número de PTEs de sistema livres. Isso é possível por meio do monitoramento do contador de desempenho das Entradas de Tabela de Página Livres | Memória com o Monitor do Sistema Windows (também conhecido como Monitor de Desempenho). Se, depois de fazer a alteração de Registro descrita abaixo, o número de PTEs de sistema livres permanecer baixo, você deve verificar o seguinte para garantir que o computador do Exchange Server está configurado corretamente:

  • Drivers Um driver que não funciona corretamente é uma das causas mais comuns de PTEs de sistema baixas. Consulte o fabricante do hardware para verificar se você está usando os drivers mais recentes para todos os seus hardwares. Além disso, pode haver oportunidades para rebaixar para um driver mais básico. Por exemplo, os computadores que executam aplicativos baseados em servidor como o Exchange Server geralmente não precisam de drivers de vídeo muito avançados com todos os recursos. Em vez disso, um driver mais básico geralmente é suficiente. A troca de um driver de vídeo avançado por um driver de vídeo básico deve aumentar o número de PETs de sistema livres.

  • Configuração do sistema Se o sistema tiver 1 GB ou mais de memória física instalada, verifique se o arquivo Boot.ini está configurado de forma adequada com as opções /3GB e /USERVA=3030, conforme descrito nos seguintes artigos da Base de Dados de Conhecimento da Microsoft:

    • 823440, "Uso da opção /3GB no Exchange Server 2003 em um sistema com o Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

    • 810371, "XADM: Usando a opção /Userva em computadores com base no Windows Server 2003 que estão executando o Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371)

  • Logs de Eventos Verifique o log de eventos do aplicativo do Exchange Server em busca de erros e avisos, especialmente os eventos 9582 (erros e avisos), 9665 (avisos) e 12880 (erros) do MSExchangeIS. A presença do evento 9665 também pode indicar que SystemPages não está configurado para um desempenho ideal. Para obter mais informações sobre esses eventos, consulte o artigo 325044 da Base de Dados de Conhecimento, "COMO: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Para corrigir esse aviso no Windows 2000 Server

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. No painel direito, clique duas vezes em SystemPages.

  4. No campo Dados do valor, digite um valor entre 24.000 e 31.000 (decimal) e clique em OK.

  5. Feche o editor de Registro e reinicie o computador para que a alteração entre em vigor.

Para corrigir esse aviso no Windows Server 2003

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. No painel direito, clique duas vezes em SystemPages.

  4. No campo Dados do valor, digite 0 e clique em OK.

  5. Feche o editor de Registro e reinicie o computador para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como otimizar a memória do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento:

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, "Os efeitos do ajuste do 4GT nas Entradas de Tabela de Página do Sistema" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


O número de Chamadas em Andamento esperando atualmente pela verificação de vírus está perto do limite.
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-13

A ferramenta Microsoft® Exchange Server Analyzer Tool examina o FCL (Log de Chamada de Função) do Exchange, arquivo Store.fcl, para determinar o número de chamadas atuais e contínuas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para o componente VAPI (API de Vírus).

O Exchange Server Analyzer também consulta também a chave ScanningThreads da seguinte entrada do Registro, para obter o número máximo de threads permitidos para as chamadas a componentes VAPI:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Chamadas em andamento são solicitações do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para outros componentes que não receberam uma resposta no momento em que os dados do FCL do Exchange foram gravados no arquivo Store.fcl.

Se o Exchange Server Analyzer detectar que o número de chamadas contínuas do serviço Armazenamento de Informações do Exchange (Store.exe) para o componente VAPI está próximo ao número máximo de threads permitidos, será exibido um erro.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

As chamadas em andamento do serviço Armazenamento de Informações do Microsoft Exchange para o componente VAPI podem ser causadas pelas seguintes condições:

  • Atualizações para um verificador de vírus que causam uma nova verificação de itens no armazenamento de informações.

  • Um verificador de vírus configurado incorretamente

  • O software verificador de vírus processa uma mensagem ou anexo grande

Para resolver esse erro, execute as seguintes etapas:

  • Agende as atualizações do seu antivírus para épocas de baixo consumo, ou seja, intervalos de demanda que não sejam de pico.

  • Experimente reinstalar o software verificador de vírus, mas reinstale em intervalos de demanda que não sejam de pico.

  • Examine a configuração do seu mecanismo antivírus em relação à configuração correta de threads, a exclusões de nível de arquivo e assim por diante. Consulte o artigo 823166 da Base de Dados de Conhecimento Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Aumente a contagem de threads para a API de verificação de vírus:

    O valor ideal de ScanningThreads é igual a (2 * NumberOfProcessors) + 1. Por exemplo, em um servidor executando o Exchange Server, que possui dois processadores, o valor ideal de ScanningThreads é 5.

    Observação:
    Se a tecnologia Hyper-Threading estiver habilitada, o valor de NumberOfProcessors será o dobro do número de processadores físicos. É recomendável que você consulte o fabricante de seu software antivírus, para saber se é necessário usar nessa fórmula os processadores físicos ou lógicos.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para aumentar a contagem de threads

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. No painel direito, clique duas vezes em ScanningThreads.

  4. Digite o valor retornado na fórmula anterior.

  5. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre os programas de verificação de vírus geralmente usados com o Microsoft Exchange Server 2003, consulte o artigo 823166 da Base de Dados de Conhecimento da Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Para obter mais informações sobre os programas de verificação de vírus geralmente usados com o Microsoft Exchange 2000 Server, consulte o artigo 328841 da Base de Dados de Conhecimento da Microsoft, "Exchange e o software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Para obter mais informações sobre o desempenho do Exchange Server, consulte "Performance and Scalability Guide for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Troubleshooting Microsoft Exchange Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento de informações, consulte o artigo 257725 da Base de Dados de Conhecimento Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Para obter mais informações sobre a tecnologia Hyper-Threading, consulte o site da Intel (http://www.intel.com/technology/hyperthread).

Observação:
As informações sobre sites da Web de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


O arquivo OABGEN.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais dos arquivos acima está ausente, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Obtendo o service pack/distribuição de atualização mais recente para o Exchange Server 5.0
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo versionNumber de cada objeto do Exchange Server. O atributo versionNumber representa a versão do Exchange Server que está sendo executada no computador.

O Analisador do Exchange Server também consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile para determinar o valor da chave Version do processo STORE.EXE. Se o Exchange Server Analyzer determinar que a chave Version para STORE.EXE tem valor maior ou igual a 1460 e menor do que 1462, será exibido um aviso.

Esse aviso indica que o computador do Exchange Server não está executando o código mais recente disponível para versão do Exchange em execução no computador.

Para corrigir esse aviso

  1. Visite o Centro de Download da Microsoft (http://go.microsoft.com/fwlink/?LinkId=41361) para baixar a atualização mais recente (abril de 2004) para o Exchange Server 5.0.

  2. Consulte as informações sobre essa atualização lendo o artigo 834130 da Base de Dados de Conhecimento Microsoft, "Pacote cumulativo de atualizações do Microsoft Exchange Server 5.0" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130).

  3. Execute um backup completo do computador do Exchange Server.

  4. Aplique a atualização de abril de 2004.

Para obter o pacote cumulativo de atualizações mais recente para o Exchange Server 5.0 Service Pack 2, consulte o artigo 168858 da Base de Dados de Conhecimento, "XGEN: Como obter o Exchange Server 5.0 U.S. Service Pack 2" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858).

Para obter mais informações sobre a instalação desta e de outras atualizações do Exchange Server, consulte o artigo 328839 da Base de Dados de Conhecimento, "Como aplicar service packs e hotfixes do Exchange" ( http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Obtendo o service pack/distribuição de atualização mais recente para o Exchange Server 5.5
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo versionNumber de cada objeto do Exchange Server. O atributo versionNumber representa a versão do Exchange Server que está sendo executada no computador.

O Analisador do Exchange Server também consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile para determinar o valor da chave Version do processo STORE.EXE. Se o Exchange Server Analyzer detectar que a chave de Versão do STORE.EXE tem um valor maior ou igual a 2653, mas menor que 2658, um aviso será exibido. Isso indica que o computador está executando o Exchange Server 5.5 Service Pack 4 ou o Exchange Server 5.5 Service Pack 4 com hotfixes.

Esse aviso indica que o computador do Exchange Server não está executando o código mais recente disponível para versão do Exchange em execução no computador.

Para corrigir esse aviso

  1. Visite a Central de Download da Microsoft (http://go.microsoft.com/fwlink/?LinkId=33456) para baixar a atualização mais recente (maio de 2004) do Exchange Server 5.5.

  2. Revise as informações sobre essa atualização lendo o artigo 841765 da Base de Dados de Conhecimento da Microsoft, "Maio 2004 Distribuição de atualização do Exchange Server 5.5" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765).

  3. Execute um backup completo do computador do Exchange Server.

  4. Aplique a atualização de maio de 2004.

Para obter mais informações sobre como instalar essa e outras atualizações do Exchange Server, consulte o artigo 328839 da Base de Dados de Conhecimento da Microsoft, "Como aplicar os service packs e hotfixes do Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Obtendo o service pack/distribuição de atualização mais recente para o Exchange Server 2003
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo versionNumber de cada objeto do Exchange Server. O atributo versionNumber representa a versão do Exchange Server que está sendo executada no computador.

O Analisador do Exchange Server também consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile para determinar o valor da chave Version do processo STORE.EXE.

  • Um valor igual a 7638 para a chave Version indica o Exchange Server 2003 Service Pack 2

  • Um valor igual a 7226 para a chave Version indica o Exchange Server 2003 Service Pack 1

  • Um valor de 6944 para a chave Version indica a versão original do Exchange Server 2003

  • Um valor entre as versões acima indica que o servidor está executando uma versão atualizada do hotfix do processo Store.exe.

Se o Exchange Server Analyzer determinar que a chave Version do Store.exe tem um valor inferior a 7638, será exibido um aviso.

Esse aviso indica que o computador do Exchange Server não está executando o código mais recente disponível para versão do Exchange Server em execução no computador.

Para corrigir esse aviso

  1. Faça o download ou peça o Service Pack 2 para Exchange Server 2003 no site "Service Pack 2 para Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=54751).

  2. Consulte as notas de versão do Service Pack 2 no site Exchange Server 2003 Service Pack 2 (SP2) Release Notes (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=52072).

  3. Execute um backup completo do computador do Exchange Server.

  4. Aplique o Service Pack 2 para o Exchange Server 2003.

Para obter mais informações sobre como instalar essa e outras atualizações do Exchange Server, consulte o artigo 328839 da Base de Dados de Conhecimento da Microsoft, "Como aplicar os service packs e hotfixes do Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Obtendo o último service pack/distribuição de atualização para o Exchange 2000 Server
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo versionNumber de cada objeto do Exchange Server. O atributo versionNumber representa a versão do Exchange Server que está sendo executada no computador.

O Analisador do Exchange Server também consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile para determinar o valor da chave Version do processo STORE.EXE. Se o Exchange Server Analyzer determinar que a chave Version do STORE.EXE tem um valor em um dos seguintes intervalos, será exibido um aviso:

  • Maior que 6249 e menor ou igual a 6396

  • Maior que 6396 e menor ou igual a 6487

  • Maior que 6487 e menor ou igual a 6556

  • Maior que 6556 e menor ou igual a 6603

  • Maior que 6603 e menor que 6700

Esse aviso indica que o computador do Exchange Server não está executando o código mais recente disponível para versão do Exchange em execução no computador.

Para corrigir esse aviso

  1. Baixe a atualização mais recente (agosto de 2004) do site "Downloads para o Exchange 2000 Server" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).

  2. Consulte as informações sobre as de atualizações mais recentes no artigo 870540 da Base de Dados de Conhecimento Microsoft, "Disponiblidade do pacote cumulativo de atualizações do Exchange 2000 Server Post-Service Pack 3 de agosto de 2004" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540).

  3. Execute um backup completo do computador do Exchange Server.

  4. Aplique a atualização de agosto de 2004.

Para obter mais informações sobre a instalação desta e de outras atualizações do Exchange Server, consulte o artigo 328839 da Base de Dados de Conhecimento, "Como aplicar service packs e hotfixes do Exchange" ( http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


O servidor do catálogo de endereços offline foi excluído
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-12-03

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo offLineABServer do objeto de configuração de catálogo de endereços offline. Se o Exchange Server Analyzer perceber que o valor do atributo offLineABServer contém a cadeia de caracteres DEL:, um erro será exibido.

O atributo offLineABServer é um atributo de nome distinto de valor único que armazena o nome distinto do computador do Exchange Server que é responsável pela geração de um catálogo de endereços offline. Para cada catálogo de endereços offline, o Exchange gera e armazena os arquivos do catálogo de endereços offline em um conjunto de pastas públicas em um servidor especificado. Esse erro indica que o servidor especificado no atributo offLineABServer do objeto de configuração do catálogo de endereços offline não existe. Esta situação pode ocorrer se o servidor do catálogo de endereços offline foi descomissionado ou removido incorretamente da topologia. O Exchange não gerará o catálogo de endereços offline até que você especifique um novo servidor.

Para corrigir esse erro no Exchange 2000 Server e no Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, em Destinatários, clique em Listas de Endereços Offline. No painel da direita, clique com o botão direito em Lista de Endereços Offline Padrão (ou em qualquer outra lista de endereços offline que produza essa mensagem) e clique em Propriedades.

  2. Na guia Geral, em Servidor da lista de endereços offline, clique em Procurar e no servidor que deseja usar.

Para corrigir esse aviso no Exchange Server 2007

  1. Abra o Console de Gerenciamento do Exchange.

  2. Expanda Microsoft Exchange, expanda Configuração da Organização e selecione Caixa de Correio.

  3. No painel de resultados, clique na guia Catálogo de Endereços Offline.

  4. Na guia Catálogo de Endereços Offline, selecione "Catálogo de Endereços Offline Padrão". No painel de ações, clique em Mover para iniciar o assistente para Mover Catálogo de Endereços Offline. Esse assistente permite mover a geração do OAB para um servidor diferente. Ele também copia os arquivos do OAB existente para o servidor especificado.

Para usar o Shell de Gerenciamento do Exchange para definir o servidor que hospedará a geração do Catálogo de Endereços Offline

  • Execute o seguinte comando:

    Código da Cópia
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Em que: <OAB> é o DN (nome distinto), o Domínio\Nome da conta ou a GUID do OAB e <Servidor> especifica o servidor Exchange no qual a operação selecionada é executada.

    Por exemplo, para mover a geração do OAB para SERVER01., digite:
Código da Cópia
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Para obter mais informações sobre como trabalhar com catálogos de endereços offline no Exchange Server 2003, consulte "Configurando catálogos de endereços offline do Exchange Server 2003" em Trabalhando com o armazenamento do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).

Para obter mais informações sobre como trabalhar com catálogos de endereços offline no Exchange Server 2007, consulte "Catálogo de endereços offline da > caixa de correio > da configuração da organização" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=79247).


O servidor do catálogo de endereços offline está em execução em um servidor front-end
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo offLineABServer do objeto de configuração de catálogo de endereços offline. O atributo offLineABServer é um atributo de nome distinto de valor único que armazena o nome distinto do computador do Exchange Server que é responsável pela geração de um catálogo de endereços offline.

O Analisador do Exchange Server consulta também a classe WMI (Instrumentação de Gerenciamento do Windows®) Exchange_Server Microsoft para determinar o valor da chave IsFrontEndServer para o servidor Exchange. Se o valor da chave IsFrontEndServer for True, o servidor Exchange estará agindo como um servidor front-end.

O Analisador do Exchange Server exibirá uma mensagem de erro se determinar que um catálogo de endereços offline também é um servidor front-end.

Esse erro indica que o servidor Exchange indicado para gerar catálogos de endereços offline é um servidor front-end. Se o servidor de catálogos de endereços offline designado também for um servidor front-end, a geração do catálogo de endereço offline falhará. Um novo servidor deve ser indicado para esta tarefa. Quando um servidor que executa o Microsoft Exchange 2000 Server e usa o Service Pack 2 ou posterior for designado como um servidor front-end, os serviços a seguir não serão mais executados:

  • DSProxy

  • Geração de Lista de Endereços Offline

  • Serviço de Atualização de Destinatário

  • Tarefas de Disponibilidade

  • Agente de Limpeza de Caixa de Correio

  • Serviço de Eventos do Exchange

  • SRS (Serviço de Replicação de Site)

Os servidores front-end são designados para manipular as solicitações de cliente de entrada de clientes do Microsoft Office Outlook® Web Access, POP3, IMAP4, Exchange ActiveSync, Outlook Mobile Access e Outlook que estão configurados para usar RPC sobre HTTP. Às vezes, os servidores front-end também são usados para retransmitir mensagens SMTP para servidores Exchange internos.

Para resolver esse problema, é recomendável que você designe um servidor back-end do Exchange como um servidor de catálogo de endereços offline.

Para corrigir esse erro

  1. Abra o Gerenciador do Sistema do Exchange

  2. Em Destinatários, clique em Listas de Endereços Offline.

  3. No painel direito, clique com o botão direito em Lista de Endereços Offline Padrão e clique em Propriedades.

    Observação:
    Use o mesmo procedimento para qualquer outra lista de endereços offline que produza esta mensagem.

  4. Na guia Geral, em Servidor da lista de endereços offline, clique em Procurar e clique no servidor back-end do Exchange que deseja usar.

Para obter mais informações sobre como trabalhar com catálogos de endereços offline, consulte "Configurando catálogos de endereços offline do Exchange Server 2003" em Trabalhando com o armazenamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


A pasta pública do site do catálogo de endereços offline foi excluída
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-12-03

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo siteFolderServer de cada objeto de armazenamento de pasta pública. Se o Exchange Server Analyzer perceber que o valor do atributo siteFolderServer contém a cadeia de caracteres DEL:, um erro será exibido.

O atributo siteFolderServer representa o armazenamento de pastas públicas usadas do servidor de catálogo de endereços offline. Por padrão, o Exchange Server gera arquivos do catálogo de endereços offline no Servidor de Pastas do Site (o primeiro servidor que é instalado no grupo administrativo). Se você tiver designado um servidor diferente para funcionar como servidor do catálogo de endereços offline, o armazenamento de pastas públicas listado nesse atributo será o armazenamento no novo servidor do catálogo de endereços offline e não o armazenamento no Servidor de Pastas de Site real do grupo administrativo.

Quando o Exchange Server 2003 gera arquivos do catálogo de endereços offline, ele anexa os arquivos a mensagens de email e coloca as mensagens em pastas públicas especiais. O Microsoft Office Outlook® 2003 recupera as mensagens da pasta e baixa os arquivos anexados.

As mensagens do catálogo de endereços offline são armazenadas em subpastas da pasta Catálogo de Endereços Offline, que é uma das pastas de sistema na árvore padrão Pastas Públicas. Essa pasta contém uma subpasta para cada grupo administrativo ou site em sua topologia. Por padrão, uma réplica de conteúdo de uma pasta específica do grupo administrativo reside no primeiro servidor que é instalado no grupo administrativo (chamado Servidor de Pastas do Site).

Se sua organização do Exchange for Exchange Server 2007, sem clientes de nível inferior (Outlook 2003 ou anterior), certamente você poderá desconsiderar este aviso ou erro. Se sua organização do Exchange Server 2007 estiver hospedando clientes que executem o Outlook 2003 ou anterior, siga o procedimento abaixo para habilitar a distribuição de pasta pública dos arquivos do catálogo de endereços offline. A distribuição de pasta pública é o método de distribuição pelo qual clientes que executam o Outlook 2003 ou anterior que estiverem trabalhando offline ou por uma conexão dial-up acessam o OAB.

Para corrigir esse erro

  1. Se você souber que o servidor existe, no Gerenciador de Sistema do Exchange, em Servidores, expanda o servidor, expanda o grupo de armazenamento e clique em Armazenamento de Pasta Pública. Verifique o painel direito para certificar-se de que o armazenamento do Exchange está sendo executado.

  2. Para designar um novo servidor de catálogo de endereços offline, em Destinatários, clique em Listas de Endereços Offline. Em seguida, no painel da direita, clique em Lista de Endereços Offline Padrão (ou em qualquer outra lista de endereços offline que gere essa mensagem).

    Se você não quiser usar um catálogo de endereços offline, clique com o botão direito em Catálogo de Endereços Offline Padrão e clique em Excluir. Caso contrário, use o restante desse procedimento para definir um agendamento.

  3. Clique com o botão direito em Listas de Endereços Offline Padrão e clique em Propriedades.

  4. Na guia Geral, no servidor do Catálogo de Endereços Offline, clique em Procurar para selecionar um servidor.

Para corrigir esse aviso no Exchange Server 2007

  1. Abra o Console de Gerenciamento do Exchange.

  2. Expanda Microsoft Exchange, expanda Configuração da Organização e selecione Caixa de Correio.

  3. No painel de resultados, clique na guia Catálogo de Endereços Offline.

  4. Na guia Catálogo de Endereços Offline, selecione "Catálogo de Endereços Offline Padrão".

    1. Para habilitar a distribuição de pasta pública do catálogo de endereços offline, na guia Distribuição, selecione Habilitar distribuição de pasta pública.

    2. Clique em OK para salvar as alterações.

  5. Para designar um novo servidor de catálogo de endereços offline, no painel de ações, clique em Mover para iniciar o assistente para Mover Catálogo de Endereços Offline. Esse assistente permite mover a geração do OAB para um servidor diferente. Ele também copia os arquivos do OAB existentes para o servidor especificado.

Para usar o Shell de Gerenciamento do Exchange para habilitar a distribuição de pasta pública dos arquivos do catálogo de endereços offline.

  • Execute o seguinte comando:

    Código da Cópia
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    Em que: <OAB> é o DN (nome distinto), o Domínio\Nome da conta ou a GUID do OAB.

    Por exemplo, para habilitar a distribuição de pasta pública do catálogo de endereços offline, digite:
Código da Cópia
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

Para usar o Shell de Gerenciamento do Exchange para definir o servidor que hospedará a geração do Catálogo de Endereços Offline

  • Execute o seguinte comando:

    Código da Cópia
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Em que: <OAB> é o DN (nome distinto), o Domínio\Nome da conta ou a GUID do OAB e <Servidor> especifica o servidor Exchange no qual a operação selecionada é executada.

    Por exemplo, para mover a geração do OAB para SERVER01., digite:
Código da Cópia
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Para obter mais informações sobre como trabalhar com catálogos de endereços offline no Exchange Server 2003, consulte "Configurando catálogos de endereços offline do Exchange Server 2003" em Trabalhando com o armazenamento do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).

Para obter mais informações sobre como trabalhar com catálogos de endereços offline no Exchange Server 2007, consulte "Catálogo de endereços offline da > caixa de correio > da configuração da organização" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=79247).


Arquivo CDO.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo DAVEX.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Detectado arquivo DRVIIS.DLL antigo
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • DrvIis.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer detectar que o valor de Version de qualquer um desses arquivos citados é menor que o valor de Version do Exchange Server, será exibido um aviso. Um número de versão anterior indica o possível uso de arquivos desatualizados.

Para corrigir esse erro, instale o service pack ou o pacote cumulativo de atualizações mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou do Exchange Server 2003 e selecione Reinstalar. Se executar a instalação no modo de reinstalação, você instalará apenas arquivos binários. O modo de reinstalação não remove nem redefine dados de usuário ou de configuração. Se reinstalar o Exchange Server, você deverá reinstalar também todos os service packs ou atualizações do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou o Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou do Exchange Server 2003 na unidade de CD.

  2. Clique em Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, onde <unidade> é a unidade de CD.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange, clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e, em seguida, clique em Avançar.

  5. Na página Identificação do Produto, digite a chave do produto (Product Key) de 25 dígitos e clique em Avançar.

  6. Na página Seleção do Componente, na coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange, selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, os pacotes cumulativos de atualizações e os suplementos mais recentes do Exchange Server 2003, consulte "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097) (pode estar em inglês).

Para obter mais informações sobre os service packs, ps pacotes cumulativos de atualizações e os suplementos mais recentes do Exchange 2000 Server, consulte "Downloads para o Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=33457) (pode estar em inglês).


Arquivo DSACCESS.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo EXSMTA.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo EPOXY.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo ESE.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-06-20

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo ESEUTIL.EXE mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo EXCDO.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Detectado o arquivo EXCHMEM.DLL anterior
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


EXCHMEM.DLL mais antigo presente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version de vários arquivos binários essenciais do Exchange Server. Esses arquivos incluem o Exchmem.dll. Se o Exchange Server Analyzer determinar que o arquivo Exchmem.dll contido na pasta \%systemroot%\system32 é mais antigo do que o arquivo Exchmem.dll da pasta \%exchangeroot%\bin, ele exibirá uma mensagem.

Normalmente, não existirão em um servidor duas cópias do Exchmem.dll. Contudo, às vezes, um segundo arquivo Exchmem.dll é adicionado com uma atualização no local de versões anteriores do produto. A presença de duas versões do arquivo pode ocasionar uma falha durante a instalação de versões de serviços. Para evitar problemas, é recomendável renomear o arquivo Exchmem.dll na pasta \%systemroot%\system32.

Para corrigir esse aviso

  1. Parar todos os serviços do Exchange.

  2. Renomeie o arquivo Exchmem.dll na pasta \%systemroot%\system32 para Exchmem.dll.old.

  3. Reiniciar todos os serviços do Exchange.


Arquivo EXMIME.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Detectado o arquivo EXOLEDB.DLL mais antigo
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo EXPOP3.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo EXPROX.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo EXRES.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre service packs, pacote cumulativo de atualizações e suplementos mais recentes do Exchange 2000 Server, consulte o site "Downloads para o Exchange Server 2000" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo EXSMTP.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo MAD.EXE mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo MAPI32.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo MAPI32.DLL mais antigo detectado na pasta system32
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo MDBSZ.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo OABGEN.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo PHATCAT.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo PHATQ.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo REAPI.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para corrigir esse erro, instale o service pack ou a distribuição de atualização mais recente para a sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo RESVC.DLL mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe CIM_Datafile WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Versão de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Analisador do Exchange Server encontrar um valor de Versão de qualquer um dos arquivos citados anteriormente inferior ao valor de Versão do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem estar em uso.

Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo STORE.EXE mais antigo detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version de vários arquivos binários essenciais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer detectar que o valor de Version de qualquer um desses arquivos citados for menor que o valor de Version do Exchange Server, será exibido um aviso. Um número de versão anterior indica que arquivos desatualizados podem ser usados.

Para corrigir esse erro, instale o service pack ou o pacote cumulativo de atualizações mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou do Exchange Server 2003 e selecione Reinstalar. Se você executar a instalação no modo de reinstalação, instale apenas os arquivos binários. O modo de reinstalação não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou atualizações do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou o Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou do Exchange Server 2003 na unidade de CD.

  2. Clique em Iniciar e em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange, clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange, selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, pacotes cumulativos de atualizações e suplementos mais recentes do Exchange Server 2003, consulte "Downloads para o Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, pacotes cumulativos de atualizações e suplementos mais recentes do Exchange 2000 Server, consulte "Downloads para o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


Chamadas em andamento para o Active Directory encontradas
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-14

A ferramenta Analisador do Microsoft® Exchange Server procura no FCL (Log de Chamada de Função) do Exchange, arquivo Store.fcl, eventos que indiquem chamadas contínuas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para o serviço de diretório do Active Directory®.

Chamadas em andamento são solicitações do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para outros componentes que não receberam uma resposta no momento em que os dados do FCL do Exchange foram gravados no arquivo Store.fcl.

O Active Directory fornece todas as informações sobre caixa de correio, serviços de lista de endereços e outras informações relacionadas a destinatários. A maioria das informações de configuração do Exchange Server 2003 também está armazenada no Active Directory.

Os serviços do Exchange Server acessam informações que estão armazenadas no Active Directory e gravam as informações no Active Directory.

Ao encontrar eventos no arquivo de log Store.fcl que reflitam chamadas contínuas do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para o Active Directory, o Analisador do Exchange Server exibirá um aviso.

Esse aviso indica que o desempenho pode tornar-se um problema para esse servidor. Chamadas em andamento ocasionais não necessariamente indicam um problema, mas chamadas em andamento repetidas para a mesma área podem ser um problema.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

As chamadas em andamento do serviço Armazenamento de Informações do Microsoft Exchange para o Active Directory podem ser causadas pelas seguintes condições:

  • Latência de rede entre o servidor Exchange e o Controlador de Domínio.

  • Configuração estática ou de outra forma incorreta do DSAccess.

  • Um controlador de domínio sobrecarregado e catálogo global.

  • Uma topologia do Active Directory designada incorretamente.

Para resolver esse aviso, siga as seguintes etapas:

  • Execute o Exchange Server Analyzer para obter uma análise adicional de problemas do servidor. Você pode baixar o Exchange Server Analyzer em "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Verifique o desempenho dos servidores do Controlador de Domínio do Active Directory.

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre o desempenho do Exchange e o DSAccess, consulte o artigo 250570 da Base de Dados de Conhecimento da Microsoft, "Directory service server detection and DSAccess usage" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).

Para obter mais informações sobre o desempenho do Exchange Server, consulte "Performance and Scalability Guide for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Troubleshooting Microsoft Exchange Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento de informações, consulte o artigo 257725 da Base de Dados de Conhecimento Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Para obter mais informações sobre o desempenho do Controlador de Domínio, consulte os seguintes recursos do Windows Server:

  • "Planning Domain Controller Capacity" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=70191).

  • "Active Directory Monitoring of Domain Controllers" em Windows 2000 Server Active Directory Planning and Deployment Guides (em inglês) (http://go.microsoft.com/fwlink/?LinkId=70193).


Chamadas em andamento encontradas para ESE
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-13

A ferramenta Analisador do Microsoft® Exchange Server examina o FCL (Log de Chamadas de Função) do Exchange, o arquivo Store.fcl, para eventos que indicam chamadas em andamento entre componentes do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe) para o Mecanismo de Armazenamento Extensível do Exchange (ESE).

Chamadas em andamento são solicitações do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para outros componentes que não receberam uma resposta no momento em que os dados do FCL do Exchange foram gravados no arquivo Store.fcl.

O Armazenamento de Informações do Microsoft Exchange está na parte superior de um banco de dados do Mecanismo de Armazenamento Extensível (ESE). O ESE é um mecanismo de banco de dados sofisticado, baseado em transações. Uma transação é uma série de operações que são tratadas como uma unidade atômica (indivisível). Todas as operações em uma transação são concluídas e salvas permanentemente; caso contrário, nenhuma operação é realizada.

O Exchange Server usa o ESE como um mecanismo de banco de dados incorporado que determina a estrutura dos bancos de dados e gerencia a memória. O mecanismo de banco de dados armazena os bancos de dados na memória transferindo blocos de dados (páginas) para dentro e para fora da memória. Isso atualiza as páginas da memória e grava páginas novas ou atualizadas no disco novamente. Quando o sistema recebe solicitações, o mecanismo de banco de dados pode armazenar dados em buffer na memória. Por isso, ele não precisa acessar o disco constantemente.

Embora os dados em cache na memória sejam a maneira mais rápida e eficiente de processar dados, significa que quando o Exchange está em execução, as informações no disco nunca são completamente atualizadas. A versão mais recente do banco de dados está na memória. No entanto, como muitas alterações na memória ainda não estão no disco, o banco de dados e a memória não estão sincronizados. O disco de log de transações é sempre mantido com informações sobre cada transação.

Se descobrir que os eventos do arquivo de log Store.fcl refletem chamadas em andamento do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe) para o banco de dados de Mecanismo de Armazenamento Extensível (ESE), o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que o desempenho pode tornar-se um problema para esse servidor. Chamadas em andamento ocasionais não necessariamente indicam um problema, mas chamadas em andamento repetidas para a mesma área podem ser um problema.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

As chamadas em andamento do serviço de Armazenamento de Informações do Microsoft Exchange para o Mecanismo de Armazenamento Extensível (ESE) podem ser causadas pelas seguintes condições:

  • Desfragmentação online do Exchange.

  • Backups de dados.

    Observação:
    Se a desfragmentação online ou o backup de dados estiver sendo processado durante a coleta de log de Rastreamento de Chamadas do Exchange, você poderá ignorar este aviso com segurança, pois ele não representará um indicador de problema de desempenho do Exchange Server.
  • Os afunilamentos nas unidades de bancos de dados, por exemplo, capacidade insuficiente para o número de usuários no servidor.

  • Afunilamentos nas unidades TEMP e TMP.

Para resolver esse erro, execute as seguintes etapas:

  • Recomendamos que você não sobreponha janelas de backup ou a manutenção online com intervalos de pico de demanda de usuários.

  • Certifique-se de que as unidades de disco do banco de dados estejam íntegras e tenham taxa de transferência de carga de E/S.

  • Execute o Analisador do Exchange Server para obter uma análise adicional dos problemas do servidor, como limites de tamanho de mensagens e anexos. Você pode baixar o Exchange Server Analyzer em "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre como configurar as janelas de horário da desfragmentação online, consulte o artigo 244524 da Base de Dados de Conhecimento Microsoft, "XADM: How to Configure the Exchange Server Online Defragmentation Time Window" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524).

Para obter mais informações sobre problemas de Afunilamento de Disco do Exchange Server, consulte Afunilamento de disco detectado.

Para obter mais informações sobre como medir e otimizar discos para o Exchange Server, consulte "How to Calculate Your Disk I/O Requirements" e "Best Practices Common to Multiple Architectures" em Optimizing Storage for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=49324).

Para obter mais informações sobre o ESE, consulte "Extensible Storage Engine Architecture" (em inglês) (http://go.microsoft.com/fwlink/?linkid=67009).


Chamadas em andamento encontradas para IMail
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-13

A ferramenta Microsoft® Exchange Server Analyzer examina o FCL (log de chamada de função) do Exchange, arquivo Store.fcl, em busca de eventos que indiquem chamadas em andamento entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para o componente IMAIL do cliente MAPI.

Chamadas em andamento são solicitações do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para outros componentes que não receberam uma resposta no momento em que os dados do FCL do Exchange foram gravados no arquivo Store.fcl.

O componente IMAIL do Exchange Server é um serviço de conversão flexível que é usado pelo serviço Armazenamento do Microsoft Exchange entre mensagens da Internet e MAPI. Isso permite a interoperabilidade entre clientes que usam o formato Internet ou RFC-822 e clientes que usam o formato de armazenamento interno do Exchange Server, como clientes MAPI ou tarefas de armazenamento interno.

O Exchange usa o mecanismo IMAIL para aplicar formatos de mensagem ao conteúdo, conforme definido para domínios da Internet no Gerenciador do Sistema do Exchange ou conforme especificado pelo usuário por destinatário do Microsoft Office Outlook®. Se nenhum parâmetro de formatação for passado para o IMAIL, o IMAIL formatará as mensagens MAPI no formato S/TNEF (Summary TNEF) para transferência entre servidores.

Se detectar eventos no arquivo de log Store.fcl que reflitam chamadas em andamento do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para o componente IMAIL do cliente MAPI, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que o desempenho pode tornar-se um problema para esse servidor. Chamadas em andamento ocasionais não necessariamente indicam um problema, mas chamadas em andamento repetidas para a mesma área podem ser um problema.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

Chamadas em andamento do serviço Armazenamento de Informações do Exchange para o componente IMAIL do cliente MAPI poderão ocorrer quando uma ou mais das condições a seguir forem verdadeiras:

  • O IMAIL tenta processar muitos dados em uma mensagem ou anexo.

  • Muitos clientes solicitam conversão de dados

  • As solicitações do DSAccess encontram uma resposta lenta.

  • Existem afunilamentos nas unidades TEMP e TMP.

  • Existem movimentações de caixas de correio em andamento.

Para resolver esse aviso, siga as seguintes etapas:

  • Agende todas as movimentações de caixa de correio para intervalos de demanda que não sejam de pico.

  • Execute o Analisador do Exchange Server para obter uma análise adicional dos problemas do servidor, como limites de tamanho de mensagens e anexos. Você pode baixar o Exchange Server Analyzer em "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre problemas de afunilamento de disco com o Exchange Server, consulte Afunilamento de disco detectado.

Para obter mais informações sobre como medir e otimizar discos para o Exchange Server, consulte "How to Calculate Your Disk I/O Requirements" e "Best Practices Common to Multiple Architectures" em Optimizing Storage for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=49324).

Para obter mais informações sobre as práticas recomendadas para limites de tamanho de mensagem no Exchange Server, consulte O tamanho máximo da mensagem de saída não foi definido.

Para obter mais informações sobre o desempenho do DSAccess e do Exchange Server, consulte "Como configura o cache de usuário do DSAccess" no Guia de Desempenho e Escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Troubleshooting Microsoft Exchange Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento de informações, consulte o artigo 257725 da Base de Dados de Conhecimento Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Chamadas em Andamento para LSASS encontradas
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-13

A ferramenta Microsoft® Exchange Server Analyzer examina o FCL (log de chamada de função) do Exchange, o arquivo Store.fcl, para eventos que indicam chamadas em andamento entre componentes do serviço Armazenamento de Informações do Exchange (Store.exe) para o processo Servidor de Autenticação de Segurança Local (Lsass.exe).

Chamadas em andamento são solicitações do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para outros componentes que não receberam uma resposta no momento em que os dados do FCL do Exchange foram gravados no arquivo Store.fcl.

O processo do Servidor de Autenticação de Segurança Local (Lsass.exe) é um subsistema de segurança invocado por outros processos para verificar informações de contas e validação de logon.

Cada logon de cliente Exchange faz com que o servidor que está executando o Exchange Server envie uma solicitação para pesquisar o SID (identificador de segurança) da conta do cliente e crie uma chamada dentro do processo do Servidor de Autenticação de Segurança Local (Lsass.exe).

Se o Exchange Server Analyzer localizar eventos no arquivo de log Store.fcl que refletem as chamadas de saída do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe) para o processo Servidor de Autenticação de Segurança Local (Lsass.exe), o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que o desempenho pode tornar-se um problema para esse servidor. Chamadas em andamento ocasionais não necessariamente indicam um problema, mas chamadas em andamento repetidas para a mesma área podem ser um problema.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

As chamadas em andamento do serviço de Armazenamento de Informações do Exchange para o processo LSASS podem ser causadas pelas seguintes condições:

  • Problemas de recurso do servidor relacionados ao número de usuários que autenticam ao mesmo tempo.

  • Latência de rede entre o servidor Exchange e o Controlador de Domínio ou o servidor de catálogo global.

  • Problemas de afunilamento no recurso do servidor.

Para resolver esse aviso, siga as seguintes etapas:

  • Considere a implementação do parâmetro NeverPing como descrito em Parâmetro 'NeverPing' Recomendado

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre o processo e uso de memória do Lsass.exe, consulte o artigo 308356 da Base de Dados de Conhecimento da Microsoft, "Uso de memória pelo processo Lsass.exe em controladores de domínio executando o Windows Server 2003 ou o Windows 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356).

Para obter mais informações sobre logons de cliente Exchange e problemas do LSASS, consulte o artigo 161938 da Base de Dados de Conhecimento da Microsoft, "Slow Exchange Client Logons Due to Resource Deadlock" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938).

Para obter mais informações sobre a latência de rede entre o servidor Exchange e o Controlador de Domínio ou o servidor de catálogo global, consulte o seguinte artigo no Blog da Equipe do Exchange Server, "Exchange Does Not Always Use Local GCs" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=69166).

Observação:
O conteúdo de cada blog e sua URL estão sujeitos a alterações sem aviso.

Para obter mais informações sobre problemas de afunilamento no recurso do servidor, consulte Afunilamento do processador.

Para obter mais informações sobre o desempenho do Exchange Server, consulte "Performance and Scalability Guide for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Troubleshooting Microsoft Exchange Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento de informações, consulte o artigo 257725 da Base de Dados de Conhecimento Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Foram encontradas chamadas em andamento para a Verificação de Vírus
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-13

A ferramenta Analisador do Microsoft® Exchange Server examina o FCL (Log de Chamada de Função) do Exchange, arquivo Store.fcl em busca de eventos que indiquem chamadas em andamento entre componentes do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe) para o componente de VAPI (API de vírus) Virusscan.

Chamadas em andamento são solicitações do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para outros componentes que não receberam uma resposta no momento em que os dados do FCL do Exchange foram gravados no arquivo Store.fcl.

Se o Analisador do Exchange Server detectar eventos no arquivo de log Store.fcl que reflitam chamadas em andamento do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe) para o componente de VAPI, o Analisador do Exchange Server exibirá um aviso.

Esse aviso indica que o desempenho pode tornar-se um problema para esse servidor. Chamadas em andamento ocasionais não necessariamente indicam um problema, mas chamadas em andamento repetidas para a mesma área podem ser um problema.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

Chamadas em andamento do serviço de Armazenamento de Informações do Exchange para o componente de VAPI podem ser causadas pelas seguintes condições:

  • Atualizações para scanner de vírus que causam uma nova verificação de itens no armazenamento de informações.

  • Um scanner de vírus configurado incorretamente

  • O software antivírus processa uma mensagem ou anexo grande.

Para resolver esse aviso, siga as seguintes etapas:

  • Agende as atualizações do seu antivírus para épocas de baixo consumo, ou seja, intervalos de demanda que não sejam de pico.

  • Experimente reinstalar o software scanner de vírus, mas reinstale em intervalos de demanda que não sejam de pico.

  • Examine a configuração do seu mecanismo antivírus em relação à configuração correta de threads, a exclusões de nível de arquivo e assim por diante. Consulte o artigo 823166 da Base de Dados de Conhecimento Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre os programas de verificação de vírus geralmente usados com o Microsoft Exchange Server 2003, consulte o artigo 823166 da Base de Dados de Conhecimento da Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Para obter mais informações sobre os programas de verificação de vírus geralmente usados com o Microsoft Exchange 2000 Server, consulte o artigo 328841 da Base de Dados de Conhecimento da Microsoft, "Exchange e o software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Para obter mais informações sobre o desempenho do Exchange Server, consulte "Performance and Scalability Guide for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Troubleshooting Microsoft Exchange Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento de informações, consulte o artigo 257725 da Base de Dados de Conhecimento Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


GlobalFlag do Sistema Operacional foi definido
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar o valor da entrada do GlobalFlag:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager

Se o Exchange Server Analyzer perceber que o valor GlobalFlag está presente e configurado com qualquer valor diferente de 0 ou nulo, será exibido um aviso.

  • A configuração do valor do Registro GlobalFlag é um bitmask que determina quais opções de depuração foram habilitadas para o sistema operacional. A menos que você esteja ativamente engajado em depurar ou rastrear um problema com a ajuda do Atendimento Microsoft, é recomendável definir sempre o valor GlobalFlag como 0.

O valor do Registro GlobalFlag é definido como 0 por padrão. Se esse valor tiver sido alterado do valor padrão de 0, você poderá usar a ferramenta Gflags fornecida junto com as ferramentas de suporte do Microsoft Windows Server™ 2003. Essas ferramentas podem ser encontradas no CD-ROM do Windows Server 2003 na pasta \Support. Como alternativa, você pode definir manualmente o valor como 0 usando o editor do Registro. A seguir, serão descritos ambos os procedimentos.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro usando GFlags

  1. Clique em Iniciar, Executar e no campo Abrir digite GFlags. A interface de usuário Global Flags será exibida.

  2. Desmarque todas as caixas de seleção e clique em Aplicar.

  3. Clique em OK para sair da ferramenta GFlags e reinicie o computador para que a alteração entre em vigor.

Para corrigir esse erro usando um editor de Registro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\ System\CurrentControlSet\Control\Session Manager

  3. Clique duas vezes no valor chamado GlobalFlag e defina os dados do Valor como 0.

  4. Saia do editor do Registro e reinicie o computador para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).


O sistema operacional está no modo de depuração
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_OperatingSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se há um valor definido para a propriedade Debug. Se o valor dessa chave em um computador do Exchange Server estiver definido como True, um erro será exibido.

O modo de depuração do Windows é alternado ao adicionar o parâmetro /debug no arquivo Boot.ini. Quando /debug estiver especificado no arquivo Boot.ini de um computador do Windows Server, o depurador de kernel será carregado durante a inicialização e mantido sempre na memória. Isso permite que um analista de suporte disque para o sistema que está sendo depurado e entre no depurador, mesmo quando o sistema não estiver suspenso em uma tela PARAR do kernel. Diferente da opção /crashdebug, a opção /debug usa a porta COM, independentemente de você estar fazendo uma depuração ou não. Essa opção é usada ao depurar problemas que geralmente se reproduzem. É provável que o parâmetro /debug tenha sido definido como um meio de solucionar um problema e foi deixado com essa definição sem nenhum intenção.

Devido aos processos adicionais que estão sendo executados, o desempenho é altamente afetado. Entretanto, não é recomendável executar o Exchange Server em um computador no qual o Windows está sendo executado no modo de depuração.

Para eliminar esse erro, edite o arquivo Boot.ini e remova o parâmetro /debug.

Para corrigir esse erro

  1. No Windows Explorer, navegue até a Partição do Sistema. Essa é a partição que armazena arquivos específicos do hardware, como o Boot.ini e o NTLDR.

  2. Se você não encontrar o arquivo Boot.ini, é provável que as Opções de Pasta estejam definidas com Ocultar arquivos protegidos do sistema operacional. Se for o caso, na janela do Windows Explorer, clique em Ferramentas, clique em Opções de Pasta e em Exibir. Desmarque a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado). Quando solicitado, clique em Sim.

  3. Quando o arquivo Boot.ini estiver visível no Windows Explorer, clique com o botão direito no arquivo, clique em Abrir com e selecione Bloco de Notas para abrir o arquivo.

  4. Na seção [Operating Systems], remova o parâmetro /debug.

  5. Salve e feche o arquivo, e reinicie o computador do Exchange Server para que a alteração entre em vigor.

Para obter informações sobre os parâmetros que podem ser usados pelo arquivo Boot.ini, consulte o artigo 833721 da Base de Dados de Conhecimento Microsoft, "Opções de alternância disponíveis para os arquivos Boot.ini do Windows XP e Windows Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833721).


O Outlook Web Access exige hotfix for Windows Server 2003 SP1
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-08-28

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta várias classes do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para coletar as seguintes informações:

  • Em qual versão do sistema operacional Microsoft Windows Server o Exchange Server está instalado?

  • O servidor Exchange está sendo executado em um cluster?

Se o Exchange Server Analyzer determinar que as seguintes condições são verdadeiras, o Exchange Server Analyzer exibirá um aviso:

  • O Exchange Server 2003 Service Pack 1 (SP1) está instalado.

  • O Microsoft Windows Server™ 2003 SP1 não está instalado.

  • O serviço de cluster está sendo executado.

  • O valor de Version do Davex.dll é menor que 6.5.7232.

Se você estiver executando essa configuração, deverá baixar e instalar um hotfix do Exchange Server antes de instalar o Windows Server 2003 SP1. Se você não instalar o hotfix do Exchange Server, os usuários do Microsoft Office Outlook® Web Access para Exchange Server 2003 não poderão fazer logon em suas caixas de correio. Os usuários que têm caixas de correio hospedadas nos clusters receberão a mensagem de erro a seguir quando tentarem se conectar usando o Outlook Web Access:

  • "500 Erros Internos do Servidor"

Esse erro é causado por alguns dos aprimoramentos de segurança que estão incluídos no Windows Server 2003 SP1.

Quando um usuário tenta fazer logon em uma caixa de correio usando o Outlook Web Access, o HTTP envia solicitações à API do cluster, representando o usuário conectado. Entretanto, foram feitas alterações de segurança no Windows Server 2003 SP1. As restrições de segurança para as APIs que executam acesso de Registro remoto foram alteradas. Portanto, a tentativa de logon não foi bem-sucedida.

Para corrigir esse erro, baixe e instale o hotfix do Exchange Server que está descrito no artigo 841561 da Base de Dados de Conhecimento Microsoft, "Mensagem de erro '500 - Erro interno do servidor' quando um usuário tenta acessar um servidor back-end Exchange Server 2003 agrupado usando o Outlook Web Access" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561) (pode estar em inglês).


Incompatibilidade de arquivo de modelo do Outlook Web Access
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o número de versão do arquivo Wmtemplates.dll. O Exchange Server Analyzer compara o número de versão de Wmtemplates.dll em todos os servidores no grupo de administração. Se o Exchange Server Analyzer verificar que o número de versão de Wmtemplates.dll não é correspondente nos servidores front-end e back-end, o Exchange Server Analyzer exibirá uma mensagem de Prática Recomendada.

O arquivo Wmtemplates.dll é usado pelos controles do Microsoft Office Outlook® Web Access. Versões incompatíveis de Wmtemplates.dll nos servidores Exchange front-end e back-end podem causar erros de nível 400 quando os usuários tentarem fazer logon no Outlook Web Access acessando o servidor Exchange front-end.

Houve duas atualizações recentes lançadas pela Microsoft que atualizam Wmtemplates.dll:

  • "O serviço Armazenamento de Informações do Microsoft Exchange falha periodicamente depois de instalado o Exchange Server 2003 SP1" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=872963)

  • "O controle S/MIME não carrega no OWA ao executar o cliente OWA do Exchange Server 2003 em um computador com Windows XP Service Pack 2" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=883543)

Se você instalou alguma dessas atualizações recentemente, é possível que uma dessas condições seja verdadeira:

  • As atualizações não foram instaladas na ordem correta.

  • As atualizações não foram instaladas nos servidores front-end e back-end.

Ao instalar atualizações no Outlook Web Acess, você deve instalar a atualização no servidor front-end, reiniciar o servidor e instalar a atualização no servidor back-end.

Se você não instalou nenhuma dessas atualizações, verifique se todos os servidores estão executando os service packs e as atualizações mais recentes do Exchange Server.

Para obter informações sobre service packs e atualizações mais recentes do Exchange Server, visite os seguintes sites:

  • Downloads para o Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=21236).

  • Downloads para o Exchange 2000 Server (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=33457).


As solicitações RPC pendentes atingiram o limite máximo
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de RPC Requests do objeto de desempenho de MSExchangeIS para analisar os dados do desempenho.

Se o Exchange Server Analyzer determinar que o número de solicitações RPC atingiu o valor de pico de 100 durante o intervalo de tempo de amostragem, o Exchange Server Analyzer exibirá um erro.

O contador de desempenho RPC Requests indica o número de solicitações de chamada de procedimento remoto do MAPI (RPC), ou cliente, que estão atualmente sendo processadas pelo serviço de Armazenamento de Informações do Microsoft Exchange. O valor médio do contador de desempenho RPC Requests deve estar abaixo de 30 todas as vezes. Por padrão, o valor máximo para solicitações RPC é 100. Portanto, a menos que esteja configurado de outra forma, o serviço Armazenameno de Informações do Microsoft Exchange pode atender a apenas 100 solicitações RPC ao mesmo tempo antes que todas as novas operações de RPC sejam rejeitadas e os usuários não possam se conectar ao servidor até que as solicitações RPC sejam inferiores a 100. O servidor não responderá e o fluxo de mensagens poderá parar. Os usuários do Outlook podem receber a caixa de diálogo Solicitação de Cancelamento RPC.

Esse erro indica que o servidor está tendo um afunilamento de desempenho ou que um processo parou de responder.

Um afunilamento de desempenho pode estar relacionado a CPU, disco, rede ou memória e pode ser causado por um aumento na carga do servidor ou recursos de servidor insuficientes. Use a ferramenta Monitor de Desempenho (Perfmon.msc) para determinar se o afunilamento é causado por um aumento da carga no servidor ou se o servidor está com tamanho menor. Se a carga do servidor aumentou, identifique a origem da carga e reduza-a. Se o servidor tiver recursos insuficientes, aumente os recursos necessários ou mova usuários do servidor.

Um processo pode parar de responder porque o armazenamento está aguardando um recurso que nunca retorna. Exemplos seriam um cluster que perde a unidade que hospeda o controle de mensagens ou um problema de verificador de vírus. Quando um processo pára de responder, as solicitações RPC nunca são suspensas e o armazenamento deve ser reiniciado.

Para obter mais informações

  • Para obter mais informações sobre os afunilamentos do processador, consulte Afunilamento do processador.

  • Para obter mais informações sobre os afunilamentos de disco, consulte Afunilamento de disco detectado.

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre como planejar o desempenho do Exchange Server, consulte Desempenho do Exchange Server 2003: 10 aspectos a serem considerados (http://go.microsoft.com/fwlink/?LinkID=56460).

  • Para obter mais informações sobre como mover caixas de correio do usuário para reduzir a carga do servidor, consulte Mover Caixas de Correio de Usuário para Outro Servidor.


Arquivo PHATCAT.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais dos arquivos acima está ausente, um erro será exibido. Para corrigir esse erro, instale o service pack mais recente ou distribua sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Arquivo PHATQ.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais arquivos estão ausentes, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução do programa de Instalação no modo Reinstalar instala apenas arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 em sua unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Problema de desempenho do arquivo de paginação
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer inclui um mecanismo de coleta de dados de desempenho, utilizado para consultar objetos de contador de desempenho em computadores que executam o Exchange 2000 Server ou o Exchange Server 2003. Esse mecanismo reúne dados dos contadores Avg Disk sec/Read e Avg Disk sec/Write para a instância PAGEDISK do objeto de desempenho LogicalDisk para analisar os dados de desempenho.

Se o Exchange Server Analyzer determinar que os contadores Avg Disk sec/Read e Avg Disk sec/Write excederam 10 milissegundos durante o intervalo de tempo de amostragem, o Exchange Server Analyzer exibirá um erro.

O objeto de desempenho LogicalDisk é formado por contadores, como Avg Disk sec/Read e Avg Disk sec/Write, que monitoram as partições lógicas de discos rígidos. O contador de desempenho Avg Disk sec/Read mostra o tempo médio, em segundos, de uma leitura de dados do disco. O contador de desempenho Avg Disk sec/Write mostra o tempo médio, em segundos, de uma gravação de dados no disco. O valor médio dos contadores de desempenho Avg Disk sec/Read e Avg Disk sec/Write devem ser inferiores a 10 milissegundos.

A instância PAGEDISK do objeto de desempenho LogicalDisk em um servidor representa o arquivo de paginação (Pagefile.sys). O Pagefile.sys é um arquivo oculto do sistema no disco rígido, usado pelo Microsoft Windows® para armazenar os dados temporários quando seu sistema possuir pouca RAM. O arquivo de página também é conhecido como arquivo de paginação ou arquivo de troca.

Esse erro indica a presença de um problema de latência relacionado à hospedagem do arquivo de paginação no disco.

Para resolver esse erro, execute as seguintes etapas:

  • Identifique a causa da latência. Se esse problema for causado por paginação excessiva, ele pode ser causado por problemas de memória no servidor.

  • Considere localizar o arquivo de paginação em uma partição dedicada ou disco de alta velocidade.

  • Considere criar um arquivo de paginação secundário em uma unidade alternativa, conforme descrito no a artigo 197379 da Base de Dados de Conhecimento Microsoft, "Configurando arquivos de paginação para otimização e recuperação no Windows Server 2003, Windows 2000 e Windows NT" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379) (em inglês).

  • Execute as tarefas de manutenção do servidor durante horários que não sejam de pico. Se você executar ferramentas de manutenção, como o Exchange Server Database Utilities (Eseutil.exe), ou tarefas, como o gerenciamento de caixa de correio, durante horários de pico, poderá usar a memória que, do contrário, seria usada pelo Exchange. Como uma prática recomendada, execute essas ferramentas e tarefas durante horários que não sejam de pico ou durante períodos de pouco uso.

Para obter mais informações

  • Para obter mais informações sobre afunilamentos de disco, consulte Afunilamento de disco detectado

  • Para obter mais informações sobre como otimizar o desempenho de arquivo de paginação, consulte o artigo 197379 da Base de Dados de Conhecimento Microsoft, "Configurando arquivos de paginação para otimização e recuperação no Windows Server 2003, Windows 2000 e Windows NT" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379) (em inglês).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre as práticas recomendadas para projetar arquiteturas de armazenamento, consulte Práticas recomendadas comuns a diversas arquiteturas (http://go.microsoft.com/fwlink/?LinkId=72988) (em inglês).

  • Para obter mais informações sobre tamanho de disco, latência e taxas de E/S, consulte os seguintes blogs no site Blog de Equipe do Microsoft Exchange:

    • Alguns conceitos básicos sobre dimensionamento de disco (http://go.microsoft.com/fwlink/?linkid=39538) (em inglês)

    • Alguns conceitos adicionais sobre E/S de disco e cálculos... (http://go.microsoft.com/fwlink/?linkid=39539)

    • Como calcular os requisitos de E/S do disco (http://go.microsoft.com/fwlink/?linkid=69747) (em inglês)


Contador Uso de Arquivo de Paginação maior que 50%
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-09-18

A ferramenta Microsoft® Exchange Server Analyzer dispõe de um mecanismo de coleta de dados de desempenho, usada para consultar os objetos contadores de desempenho em computadores executando o Exchange 2000 Server ou Exchange Server 2003. Esse mecanismo coleta dados do contador de % Usage do objeto de desempenho do Paging File para analisar os dados de desempenho.

Se o Exchange Server Analyzer determinar que o contador % Usage excedeu 50% durante o intervalo de tempo da amostragem, ele exibirá um erro.

O arquivo de paginação (Pagefile.sys) é um arquivo de sistema oculto no disco rígido usado pelo Windows para armazenar dados temporários quando seu sistema fica com pouca RAM. O arquivo de página também é conhecido como arquivo de paginação ou arquivo de troca. O uso do arquivo de paginação afeta o desempenho geral porque as operações de disco levam muito mais tempo do que operações de memória. Além disso, quando a paginação de e para o disco fica muito alta, geralmente ocorre um afunilamento de disco e o desempenho fica comprometido. Nesse caso, o problema real é memória, e o afunilamento de disco é apenas um sintoma.

O conflito de memória é tolerável até que o sistema chegue a um ponto em que o sistema gaste um tempo significativo gerenciando a memória limitada em relação ao tempo que é necessário para o trabalho real. Se você fizer um gráfico de conflito de memória comparado aos tempos de resposta médios, verá uma linha tênue do conflito zero até o ponto em que os tempos de resposta aumentam significativamente. Isso é conhecido como ponto de esgotamento. Conforme o conflito de memória aumenta a partir desse ponto, os tempos de resposta aumentam exponencialmente. O esgotamento temporátio é tolerável em alguns ambientes, mas você deve evitá-lo.

Esse erro indica que há um problema de desempenho no disco que hospeda o arquivo de paginação. Esse problema pode estar relacionado a um problema de memória no servidor.

Para resolver esse erro, execute as seguintes etapas:

  • Considere criar um arquivo de paginação secundário em uma unidade alternativa, conforme descrito no a artigo 197379 da Base de Dados de Conhecimento Microsoft, "Configurando arquivos de paginação para otimização e recuperação no Windows Server 2003, Windows 2000 e Windows NT" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379) (em inglês).

  • Considere localizar o arquivo de paginação em uma partição dedicada ou disco de alta velocidade.

  • Remova software supérfluo. Para liberar mais recursos de memória para o Exchange, remova ferramentas de software de terceiros que executem funções de monitoramento ou qualquer tipo de serviço não essencial. O snap-in de Desempenho (http://go.microsoft.com/fwlink/?LinkId=56118) pode ajudá-lo a entender a quantidade de memória que os aplicativos estão usando.

  • Execute as tarefas de manutenção do servidor durante horários que não sejam de pico. Se você executar ferramentas de manutenção, como o Exchange Server Database Utilities (Eseutil.exe), ou tarefas, como o gerenciamento de caixa de correio, durante horários de pico, poderá usar a memória que, do contrário, seria usada pelo Exchange. Como uma prática recomendada, execute essas ferramentas e tarefas durante horários que não sejam de pico ou durante períodos de pouco uso.

  • tente mover as caixas de correio do usuário do servidor afetado para outro servidor para reduzir a carga do servidor. Para obter mais informações, consulte Mover Caixas de Correio de Usuário para Outro Servidor.

Para obter mais informações

  • Para obter mais informações sobre afunilamentos de disco, consulte Afunilamento de disco detectado.

  • Para obter mais informações sobre como otimizar o desempenho de arquivo de paginação, consulte o artigo 197379 da Base de Dados de Conhecimento Microsoft, "Configurando arquivos de paginação para otimização e recuperação no Windows Server 2003, Windows 2000 e Windows NT" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379) (em inglês).

  • Para obter mais informações sobre como melhorar o desempenho da memória, consulte Melhorar memória do usuário.

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (em inglês).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre as práticas recomendadas para projetar arquiteturas de armazenamento, consulte Práticas recomendadas comuns a diversas arquiteturas (http://go.microsoft.com/fwlink/?LinkId=72988) (em inglês).

  • Para obter mais informações sobre tamanho de disco, latência e taxas de E/S, consulte os seguintes blogs no site Blog de Equipe do Microsoft Exchange:

    • Alguns conceitos básicos sobre dimensionamento de disco (http://go.microsoft.com/fwlink/?linkid=39538) (em inglês).

    • Alguns conceitos adicionais sobre E/S de disco e cálculos... (http://go.microsoft.com/fwlink/?linkid=39539).

    • Como calcular os requisitos de E/S do disco (http://go.microsoft.com/fwlink/?linkid=69747) (em inglês).


PageHeapFlags foi definido
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar o valor de PageHeapFlags:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

Se o Analisador do Exchange Server detectar que o valor GlobalFlag está presente e configurado com qualquer valor diferente de 0 ou nulo, será exibido um aviso.

A opção PageHeapFlags é usada junto com o valor do Registro GlobalFlag, descrito em GlobalFlag foi definido. A opção PageHeapFlags permite que você selecione a verificação de pilha padrão, que grava padrões de preenchimento no final de cada alocação de pilha e examina os padrões quando as alocações são liberadas, ou uma verificação de pilha de página completa. Isso coloca uma página inacessível no final de cada alocação para que o programa pare imediatamente se ele acessar a memória além da alocação. Como a verificação de pilha de página completa usa uma página de memória completa para cada alocação, seu uso abrangente pode causar insuficiências de memória do sistema.

Nesse caso, a ferramenta Analisador do Exchange Server está especificamente procurando ver se algum valor de PageHeapFlags foi habilitado para vários componentes do Exchange:

  • STORE.EXE - o processo de armazenamento de informações

  • MAD.EXE - o processo do atendedor do sistema

  • INETINFO.EXE - o processo pai e admin do IIS

  • EMSMTA.EXE - o processo do agente de transferência de mensagens

A menos que você esteja ativamente engajado na depuração ou rastreamento de um problema com a ajuda do Atendimento Microsoft, é recomendável que o valor de PageHeapFlags seja definido como 0 sempre ou excluído completamente, o que tem o mesmo efeito.

O valor do Registro PageHeapFlags não está presente por padrão e deve ser adicionado manualmente se a depuração do processo STORE.EXE (ou de qualquer outro processo) for necessária. Você pode usar a ferramenta Gflags incluída com as ferramentas de suporte do Microsoft Windows Server™ 2003, que estão no CD do Windows Server 2003 CD na pasta \Support. Como alternativa, você pode definir manualmente o valor como 0 ou excluir totalmente o valor de PageHeapFlags usando um editor do Registro. Ambos os procedimentos estão descritos neste artigo.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro usando GFlags

  1. Clique em Iniciar | Executar e, no campo Abrir, execute GFlags. A interface de usuário Global Flags será exibida.

  2. No campo Nome do Arquivo de Imagem, insira STORE.EXE.

  3. Clique em Opções do Arquivo de Imagem.

  4. Desmarque todas as caixas de seleção e clique em Aplicar.

  5. Repita as etapas de 2 a 4 de cada um dos processos do Exchange listados acima.

  6. Clique em OK para sair da ferramenta GFlags e reinicie os serviços afetados para que a alteração entre em vigor.

  7. Quando usar a ferramenta GFlags para limpar esse valor, ela não excluirá ou alterará o valor de PageHeapFlags. Em vez disso, ela definirá o valor de GlobalFlag como 0, o que substituirá e desabilitará o comportamento configurado com a entrada PageHeapFlags.

Para corrigir esse erro usando um editor de Registro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. Exclua o valor chamado PageHeapFlags.

  4. Repita as etapas de 2 a 3 de cada um dos processos do Exchange listados.

  5. Saia do editor de Registro e reinicie os serviços afetados para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Pool Não Paginado está acima do limite de erro
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_PerfRawData_PerfOS_Memory do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor atual da chave PoolNonpagedBytes. As ações tomadas pelo Exchange Server Analyzer dependem do sistema operacional subjacente, da presença ou ausência do comando /3GB no arquivo Boot.ini do Windows e do valor descoberto para essa chave.

A seguir há uma matriz de avaliações usada pelo Exchange Server Analyzer para determinar se esse valor está fora dos limites para um determinado servidor Exchange. Se as condições na matriz forem correspondentes, será exibido um erro.

Sistema operacional | Configuração Boot.ini | O pool não paginado atual é
Windows 2000 Server ou Advanced Server | /3GB | 110 MB ou mais
Windows 2000 Server ou Advanced Server | Nenhum | 220 MB ou mais
Windows Server™ 2003 | /3GB | 110 MB ou mais
Windows Server 2003 | Nenhum | 220 MB ou mais

O valor da chave PoolNonpagedBytes é o tamanho, em bytes, do pool não paginado da memória do kernel. O pool não paginado é uma área da memória física do sistema para os objetos que não podem ser gravados em disco mas devem permanecer na memória física enquanto estiverem alocados. O valor para essa chave é o ultimo valor observado. Em um servidor íntegro do Exchange, esse valor deve permanecer nivelado. Se o valor desse contador estiver aumentando constantemente, isso pode indicar uma perda de memória.

Como não é possível aumentar o limite da memória de pool não paginado além dos valores listados anteriormente, essa condição deve ser corrigida o mais rapidamente possível. Independentemente do sistema operacional em uso ou da presença ou ausência da opção /3GB, somente esse limite de memória de pool não paginado pode ser acessado pelo sistema operacional Windows. Se o Windows ficar sem memória do kernel, ele poderá exibir mensagens de erro e falhar. A memória do kernel é necessária para o funcionamento correto do sistema e, portanto, você deve monitorá-la com muita atenção.

Se depois da reinicialização do servidor do Exchange, essa condição se repetir, a próxima etapa será verificar se o sistema está corretamente ajustado e se todo o software e hardware existentes nesse sistema estão atualizados. Isso inclui a instalação mais recente de:

  • Service pack do sistema operacional Windows

  • Service pack do Exchange Server

  • Firmware e drivers do hardware

  • Atualizações de BIOS do sistema

  • Atualizações para todos os aplicativos de terceiros instalados e em execução

Se as atualizações do software e hardware não solucionarem esse problema, desabilite todo o software de terceiros, reinicialize o computador do Exchange Server e monitore a memória do kernel.

Para corrigir esse erro

  1. Reinicie o computador do Exchange Server o mais rápido possível.

  2. Monitore o contador de desempenho Memória | Bytes do Pool Não Paginado para ter certeza de que ele não ultrapassa o limite listado anteriormente para seu sistema.

Para obter mais informações sobre como ajustar corretamente o Exchange Server, consulte os seguintes artigos e tópicos da Base de Dados de Conhecimento Microsoft:

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • 266096, "XGEN: O Exchange 2000 exige a opção /3GB com mais de 1 gigabyte de RAM física" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • "Troubleshooting Exchange Server 2003 Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Troubleshooting Exchange 2000 Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=18177)

  • "Exchange Server 2003 Performance and Scalability Guide" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576)


O pool paginado está acima do limite de aviso
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-03-16

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_PerfRawData_PerfOS_Memory do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor atual da chave PoolPagedBytes. As ações tomadas pelo Exchange Server Analyzer dependem do sistema operacional subjacente, da presença ou ausência da opção /3GB no arquivo Boot.ini do Windows e do valor descoberto para essa chave.

A tabela exibe a matriz de avaliações usadas pelo Exchange Server Analyzer para determinar se esse valor está fora dos limites de um determinado servidor Exchange. Se as condições da tabela forem atendidas, será exibido um aviso.

Sistema operacional | Configuração Boot.ini | O pool da página atual é
Windows 2000 Server ou Advanced Server | /3GB | 180 MB ou mais
Windows 2000 Server ou Advanced Server | Nenhum | 180 MB ou mais
Windows Server™ 2003 | /3GB | 200 MB ou mais
Windows Server 2003 | Nenhum | 300 MB ou mais

O valor da chave PoolPagedBytes é o tamanho, em bytes, do pool paginado da memória do kernel. O pool paginado é uma área de memória física do sistema para objetos que podem ser gravados no disco quando não estão sendo usados. O valor para essa chave é o ultimo valor observado. Em um Exchange Server íntegro, a menos que esteja ocorrendo um backup ou restauração, não deve haver mais de 180 MB de memória de pool paginado em uso.

No Windows 2000 Server e no Windows 2000 Advanced Server, o valor máximo da memória de pool paginado é 470 MB. Quando a opção /3GB é adicionada a um computador que executa o Windows 2000 Advanced Server, o valor máximo para memória de pool paginado é 192 MB. Em um computador que executa o Windows Server 2003 sem a opção /3GB, o valor máximo para memória de pool paginado é 491 MB. Em um computador que executa o Windows Server 2003 com a opção /3GB, o valor máximo para memória de pool paginado é 256 MB.

Como não há um modo de aumentar o limite para a memória de pool paginado além dos valores listados acima, esse problema deve ser corrigido assim que possível. Independentemente do sistema operacional em uso ou da presença ou ausência da opção /3GB, somente uma determinada quantidade de memória de pool paginado pode ser acessada pelo Windows. Se o Windows ficar sem memória do kernel, ele poderá exibir mensagens de erro e falhar. A memória do kernel é essencial para a operação adequada do sistema e, portanto, você deve monitorá-la com cuidado.

Se, depois de reiniciar o servidor Exchange, esse problema continuar, a próxima etapa é verificar se seu sistema está ajustado adequadamente e que todo o software e hardware estejam atualizados. Isso inclui a instalação mais recente de:

  • Service pack do sistema operacional Windows

  • Service pack do Exchange Server

  • Firmware e drivers do hardware

  • Atualizações de BIOS do sistema

  • Atualizações de quaisquer aplicativos de terceiros que estejam instalados e em execução

Se atualizações de software e hardware não resolverem o problema, você deve desabilitar todos os softwares de terceiros, reiniciar o computador do Exchange Server e monitorar a memória do kernel.

Para corrigir esse aviso

  1. Reinicie o computador do Exchange Server o mais rápido possível.

  2. Monitore o contador de desempenho Memória | Bytes do Pool Paginado para verificar se ele não está ultrapassando o limite listado acima para o seu sistema.

Para obter mais informações sobre como ajustar o Exchange Server adequadamente, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft e o tópico do Exchange:

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • 266096, "XGEN: O Exchange 2000 exige a opção /3GB com mais de 1 gigabyte de RAM física" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096)

  • "Troubleshooting Exchange Server 2003 Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

  • "Troubleshooting Exchange 2000 Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=18177)

  • "Exchange Server 2003 Performance and Scalability Guide" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576)

Para obter mais informações, consulte os seguintes artigos do blog do Exchange:

  • "Gerenciamento da memória do kernel do Microsoft Windows e o Microsoft Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=63477)

  • "Configurando inclusão de memória a quente e memória extensa no Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=63478)

  • "Tokens de segurança grandes e exaustão da memória do kernel" (http://go.microsoft.com/fwlink/?LinkId=63479)

    Observação:
    Os links para esses blogs são fornecidos para fins de informação. O conteúdo pode ser alterado sem prévio aviso.


O caminho para extensão do servidor proxy RPC está incorreto
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte propriedade na metabase so IIS (Internet Information Services) para detectar se o valor dessa propriedade foi configurado corretamente:

LM/W3SVC/Filters/RpcProxy

Essa propriedade de metabase é a propriedade da extensão do servidor proxy RPC (chamada de procedimento remoto) na extensão do serviço da Web no IIS. O valor correto dessa propriedade é o seguinte:

<Diretório do Windows>\system32\rpcproxy\rpcproxy.dll

Se o Exchange Server Analyzer detectar que a propriedade não possui o valor correto, será exibido um aviso.

A propriedade da extensão do servidor proxy RPC é definida durante a instalação do subcomponente Proxy RPC sobre HTTP do componente Serviços de Rede do Microsoft Windows®. Se a propriedade estiver definida incorretamente ou se você alterar o valor manualmente, faça o seguinte:

  1. Remova a propriedade da extensão do servidor proxy RPC incorreta.

  2. Remova o subcomponente Proxy RPC sobre HTTP.

  3. Reinstale o subcomponente Proxy RPC sobre HTTP.

Para remover a propriedade da extensão do servidor proxy RPC incorreta

  1. Abra o Gerenciador do IIS (Serviços de Informações da Internet).

  2. No painel esquerdo da janela Gerenciador do IIS (Serviços de Informações da Internet), expanda o nome do servidor e clique em Extensões da Web.

  3. No painel direitoda janela Gerenciador do IIS, clique com o botão direito em Extensão do Servidor Proxy RPC e clique em Propriedades.

  4. Na guia Arquivos Necessários, selecione o arquivo incorreto na lista de arquivos, clique em Remover e em OK.

    Observação:
    Para ver o caminho completo, ajuste a largura da coluna Nome do Arquivo na lista de arquivos.
Para remover o subcomponente Proxy RPC sobre HTTP

  1. Clique em Iniciar, Painel de Controle e Adicionar ou Remover Programas.

  2. No painel esquerdo, clique em Adicionar/Remover Componentes do Windows.

  3. Selecione Serviços de Rede e clique em Detalhes.

  4. Desmarque a caixa de seleção de Proxy RPC sobre HTTP, clique em OK e em Avançar.

  5. Quando o Assistente de Componentes do Windows tiver terminado, clique em Concluir para fechar o assistente.
Para reinstalar o subcomponente Proxy RPC sobre HTTP

  1. Clique em Iniciar, Painel de Controle e Adicionar ou Remover Programas.

  2. No painel esquerdo, clique em Adicionar/Remover Componentes do Windows.

  3. Selecione Serviços de Rede e clique em Detalhes.

  4. Marque a caixa de seleção de Proxy RPC sobre HTTP, clique em OK e em Avançar.

  5. Quando o Assistente de Componentes do Windows tiver terminado, clique em Concluir para fechar o assistente.

Para obter mais informações sobre problemas de carregamento incorreto da extensão do servidor proxy RPC, consulte o artigo 833401 da Base de Dados de Conhecimento da Microsoft, "Como configurar RPC sobre HTTP em um único servidor do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

Para obter mais informações sobre como implantar RPC sobre HTTP no Exchange Server 2003, consulte Situações da implantação de RPC sobre HTTP no Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=24823).


O emulador de PDC não está excluído da topologia do DSAccess
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê as seguintes entradas do Registro para determinar se o controlador de domínio do Active Directory® que está atuando como o emulador de PDC (controlador de domínio primário) foi excluído manualmente da lista de controladores de domínio disponíveis para uso pelo Exchange Server:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default\MinUserDC

Se o Exchange Server Analyzer detectar que o controlador de domínio que está agindo como emulador de PDC não foi excluído manualmente da lista de controladores de domínio disponíveis para uso pelo Exchange Server, o Exchange Server Analyzer exibirá uma prática recomendada.

Um emulador de PDC é um computador de função principal das operações do Active Directory que processa as solicitações de replicação dos controladores de domínio de backup do Microsoft Windows NT® Server 4.0 e processa todas as atualizações de senhas de clientes que não estão executando o software cliente habilitado para o Active Directory. Os emuladores de PDC também são controladores de domínio e, portanto, estão disponíveis para serem usados por aplicativos, como o Exchange Server.

O DSAccess (Directory Service Access) é um componente interno do Exchange 2000 Server e do Exchange Server 2003 que controla como todos os componentes do Exchange Server acessam o Active Directory®. A principal função do DSAccess é manter informações sobre vários eventos e operações relacionados a diretórios. Por exemplo, o DSAccess descobre a topologia do Active Directory e detecta se controladores de domínio e servidores de catálogo global estão disponíveis e respondendo a consultas.

Por padrão, o DSAccess inclui o computador emulador de PDC na sua lista de controladores de domínio disponíveis e utilizáveis. Se programas que não pertencem ao Exchange Server estiverem usando intensamente o emulador de PDC, o uso desse emulador pelo DSAccess poderá acarretar problemas de desempenho no computador do emulador de PDC, no servidor Exchange e no computador que não pertence ao Exchange Server.

Para evitar esses problemas de desempenho, o valor do Registro MinUserDC pode ser adicionado ao Registro em um servidor Exchange para instruir o DSAccess a consultar todos os outros controladores de domínio disponíveis, antes de consultar o controlador de domínio que armazena a função principal das operações do emulador de PDC.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para examinar e alterar o valor do Registro MinUserDC

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. Localize o valor de MinUserDC e faça as alterações necessárias. Se esse valor de DWORD não existir, você poderá criá-lo manualmente.

    Observação:
    Os dados de valor configurados para a entrada do Registro MinUserDC são o número máximo de controladores de domínio a serem contatados, antes de procurar o emulador de PDC. Por exemplo, definir MinUserDC como 4 configura o DSAccess para excluir o emulador de PDC somente quando um total de 4 controladores de domínio estiverem disponíveis.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como usar a entrada do Registro MinUserDC, consulte o artigo 298879 da Base de Dados de Conhecimento, "O Exchange 2000 pode enfrentar problemas de desempenho quando o emulador de PDC é usado no DSAccess" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879) (página em inglês).


Dados de desempenho para contador MBytes Disponíveis
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Available MBytes do objeto de desempenho de Memory para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de Available MBytes, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho Available MBytes mostra a quantidade de memória física em megabytes (MB) disponível de imediato para alocação a um processo ou para uso do sistema. A quantidade de memória disponível é igual à soma da memória atribuída às listas de página em espera (armazenadas em cache), livres e às listas sem nenhuma página.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador de Média de Leitura de Disco/s do objeto de desempenho LogicalDisk
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Avg. Disk sec/Read do objeto de desempenho de LogicalDisk para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de Avg. Disk sec/Read, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O objeto de desempenho Logical Disk é composto de contadores, como o Avg. Disk sec/Read que monitoram as partições lógicas de discos rígidos. O contador de desempenho Avg. Disk sec/Read mostra o tempo médio, em segundos, de uma leitura de dados do disco. O valor médio do contador de desempenho Avg. Disk sec/Read deve permanecer abaixo de 10 milissegundos. O valor máximo do contador de desempenho Avg. Disk sec/Read não deve exceder 50 milissegundos.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre como otimizar o sistema de armazenamento do Exchange Server 2003, consulte Otimizando o armazenamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=49324).

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador de Média de Leitura de Disco/s do objeto de desempenho PhysicalDisk
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Avg. Disk sec/Read do objeto de desempenho de PhysicalDisk para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de Avg. Disk sec/Read, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho Avg. Disk sec/Read indica o tempo médio, em segundos, de uma leitura de dados do disco. O valor médio do contador de desempenho Avg. Disk sec/Read deve permanecer abaixo de 10 milissegundos. O valor máximo do contador de desempenho Avg. Disk sec/Read não deve exceder 50 milissegundos.

Se você coletar resultados dos contadores Disk Reads/sec e Disk Writes/sec, poderá determinar se a E/S gerada pelo Exchange Server estará aumentando ou diminuindo com o passar do tempo. Se você coletar resultados dos contadores Avg. Disk sec/Read e Avg. Disk sec/Write, poderá determinar se a latência de armazenamento mudou com o passar do tempo. Por exemplo, as seguintes etapas ajudam a prever se a taxa de transferência do armazenamento está se tornando ou se tornará um afunilamento:

  1. Faça medições mensais, de preferência no mesmo dia de cada mês e durante as mesmas horas de cada dia.

  2. Analise os dados coletados.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador de Média de Gravação de Disco/seg. do objeto de desempenho LogicalDisk
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Avg. Disk sec/Write do objeto de desempenho de LogicalDisk para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de Avg. Disk sec/Write, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O objeto de desempenho Logical Disk é composto de contadores, como o Avg. Disk sec/Write que monitoram as partições lógicas de discos rígidos. O contador de desempenho Avg. Disk sec/Write exibe o tempo médio em segundos que ele leva para gravar dados no disco. O valor médio do contador de desempenho Avg. Disk sec/Write deve permanecer abaixo de 10 milissegundos. O valor máximo do contador de desempenho Avg. Disk sec/Write não deve exceder 50 milissegundos.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre como otimizar o seu sistema de armazenamento do Exchange Server 2003, consulte o site Microsoft TechNet Otimizando o armazenamento do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34649).

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho para o contador Média de seg. de Disco/Gravação
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Avg. Disk sec/Write do objeto de desempenho de Physical Disk para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de Avg. Disk sec/Write, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho Avg. Disk sec/Write mostra o tempo médio, em segundos, usados para gravar dados no disco. O valor médio do contador de desempenho Avg. Disk sec/Write deve permanecer abaixo de 10 milissegundos. O valor máximo do contador de desempenho Avg. Disk sec/Write não deve exceder 50 milissegundos.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador Comprimento da Fila de Saída do Cliente Epoxy (DSAccess).
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Client Out Queue Length (DSAccess) do objeto de desempenho de Epoxy para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de Client Out Queue Length (DSAccess) , o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho Client Out Queue Length (DSAccess) indica o número de mensagens na fila que contém mensagens do DSAccess (Directory Service Access) enviadas pelo processo Inetinfo.exe. As filas devem permanecer sempre abaixo de 10.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador do Comprimento da Fila de Saída do Cliente Epoxy (SMTP)
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Client Out Queue Length (SMTP) do objeto de desempenho de Epoxy para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de Client Out Queue Length (SMTP), o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho Client Out Queue Length (SMTP) indica o número de mensagens da fila que contém mensagens SMTP enviadas pelo processo Inetinfo.exe. As filas devem sempre estar abaixo de 50, a menos que haja uma fila de mensagens.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador Comprimento da Fila de Saída do Armazenamento Epoxy (DSAccess)
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer inclui um mecanismo de coleta de dados de desempenho que é usado para consultar objetos do contador de desempenho em computadores que estejam executando o Exchange 2000 Server ou Exchange Server 2003. O mecanismo de coleta de dados de desempenho coleta dados do contador de desempenho Store Out Queue Length (DSAccess) do objeto de desempenho Epoxy para analisar dados de desempenho. Se o Exchange Server Analyzer coletar quaisquer dados do contador de desempenho Store Out Queue Length (DSAccess), ele exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho Store Out Queue Length (DSAccess) indica o número de mensagens na fila que contém as mensagens do Directory Service Access (DSAccess) enviadas pelo processo Store.exe. As filas devem permanecer sempre abaixo de 10.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador Comprimento da Fila de Saída do Armazenamento Epoxy (SMTP)
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool inclui um mecanismo de coleta de dados de desempenho que é usado para consultar objetos do contador de desempenho em computadores que estejam executando o Exchange 2000 Server ou Exchange Server 2003. O mecanismo de coleta de dados de desempenho coleta dados do contador de desempenho Store Out Queue Length (SMTP) do objeto de desempenho Epoxy para analisar dados de desempenho. Se o Exchange Server Analyzer coletar quaisquer dados do contador de desempenho Store Out Queue Length (SMTP), o Exchange Server Analyzer exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho Store Out Queue Length (SMTP) indica a quantidade de mensagens na fila que contêm mensagens SMTP enviadas pelo processo Store.exe. As filas devem sempre estar abaixo de 50, a menos que haja uma fila de mensagens.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador de Latência Média de RPC
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de RPC Averaged Latency do objeto de desempenho de MSExchangeIS para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de RPC Averaged Latency, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho RPC Averaged Latency mostra a latência de RPC (chamada de procedimento remoto), em milissegundos, em média para os últimos 1.024 pacotes. O valor máximo do contador de desempenho RPC Averaged Latency deve ser menor que 50 milissegundos em todos os momentos.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador de operações RPC/s
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de RPC Operations/sec do objeto de desempenho de MSExchangeIS para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de RPC Operations/sec, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho RPC Operations/sec mostra a taxa em que as operações de chamada de procedimento remoto (RPC) ocorrem. O contador de desempenho RPC Operations/sec é um bom contador de taxas para medir a carga de trabalho do Exchange Server, pois todas as ações baseadas em MAPI usam o protocolo RPC.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador Solicitações RPC
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de RPC Requests do objeto de desempenho de MSExchangeIS para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de RPC Requests, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho RPC Requests indica o número de solicitações de chamada de procedimento remoto do MAPI (RPC), ou cliente, que estão atualmente sendo processadas pelo serviço de Armazenamento de Informações do Microsoft Exchange. O valor médio do contador de desempenho RPC Requests deve estar abaixo de 30 todas as vezes. Por padrão, o valor máximo de solicitações RPC é de 100. Sendo assim, a menos que configurado de outra forma, o serviço Armazenamento de Informações do Microsoft Exchange pode atender a apenas 100 solicitações RPC ao mesmo tempo, antes de recusar solicitações de cliente.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador Comprimento da Fila do Categorizador SMTP
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Categorizer Queue Length do objeto de desempenho de SMTP Server para analisar os dados do desempenho. O Exchange Server Analyzer relata o número total de mensagens encontradas na fila do Categorizador.

O contador SMTP Server\Categorizer Queue Length indica o número de mensagens na fila do Categorizador SMTP aguardando as pesquisas de atributo do serviço de diretório com servidores de catálogo globais. Como diretriz geral, o valor máximo deve ser menor que 10.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

O contador Categorizer Queue Length indica o número de mensagens na fila do categorizador de mensagens. O categorizador executa as seguintes operações principais:

  • Resolve e valida todos os destinatários.

  • Determina limites e restrições para todos os destinatários.

  • Expande listas de distribuição se necessário.

  • Determina se a mensagem é para entrega local ou remota.

Um aumento no contador Categorizer Queue Length indica que talvez haja problemas potenciais com o desempenho do servidor, o DSAccess (Directory Service Access), o serviço de diretório do Active Directory® ou interrupções nos servidores principais da organização do Exchange Server. Um aumento no contador Categorizer Queue Length indicaria lentidão ou ausência de resposta ao consultar o Active Directory ou ao manipular mensagens para entrega local ou via SMTP.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador Comprimento da Fila Local de SMTP
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Local Queue Length do objeto de desempenho de SMTP Server para analisar os dados do desempenho. O Exchange Server Analyzer relata o número total de mensagens encontradas na fila SMTP local.

O contador SMTP Server\Local Queue Length indica o número de mensagens na fila SMTP para entrega local. Como regra geral, o valor máximo deve ser inferior a 1.000. A fila deve permanecer constante, próxima à sua média, com poucas variações.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

Um acúmulo de mensagens na fila Entrega Local indica um problema de desempenho ou interrupções do servidor, pois o servidor não pode mais entregar as mensagens de entrada a tempo. As seguintes condições podem causar esse atraso:

  • O serviço de diretório Active Directory® não está sendo consultado prontamente.

  • As mensagens não estão sendo liberadas prontamente para entrega local ou SMTP.

  • Os bancos de dados foram desmontados.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador Comprimento da Fila Remota SMTP
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Remote Queue Length do objeto de desempenho de SMTP Server para analisar os dados do desempenho. O Exchange Server Analyzer relata o número total de mensagens encontradas na fila remota SMTP.

O contador SMTP Server\Remote Queue Length indica o número de mensagens na fila SMTP para entrega remota. Como diretriz geral, o valor máximo deve ser menor que 1.000. A fila deve permanecer constantemente próxima à média, com pouca variação.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

Um aumento no tamanho da fila remota indica que as mensagens não estão sendo enviado a outros servidores. Essa falha no envio de e-mails pode ser explicada pelas interrupções ou problemas de desempenho ocorridos na rede ou nos servidores remotos. Essas interrupções ou problemas de desempenho impedem que a rede ou os servidores remotos recebam os e-mails de modo eficiente.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador Comprimento de Fila de Verificação de Vírus
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Virus Scan Queue Length do objeto de desempenho de MSExchangeIS para analisar os dados do desempenho. Se o Exchange Server Analyzer coletar quaisquer dados do contador de desempenho Virus Scan Queue Length, ele exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho do Virus Scan Queue Length indica o número atual de solicitações de verificação de vírus pendentes enfileiradas. O valor recomendado para esse contador é específico para sua organização.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador Paralisações de Registros de Log/s
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Log Record Stalls/sec do objeto de desempenho de Database para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de Log Record Stalls/sec, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho Log Record Stalls/sec mostra o número de registros do log que não podem ser adicionados aos buffers de log por segundo porque estes estão cheios. O valor médio do contador de desempenho Log Record Stalls/sec deve estar abaixo de 10 por segundo. O valor máximo não deve exceder a 100 por segundo.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador de Threads de Log Aguardando
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Log Threads Waiting do objeto de desempenho de Database para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de Log Threads Waiting, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho Log Threads Waiting mostra o número de threads aguardando para concluir uma atualização do banco de dados através da gravação dos dados no log. Se o valor do contador de desempenho Log Threads Waiting for muito alto, o log pode ser um afunilamento para outras transações.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho para o contador Páginas/s
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Pages/sec do objeto de desempenho de Memory para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de Pages/sec, o Exchange Server Analyzer exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho Pages/sec informa a velocidade na qual as páginas são lidas ou gravadas no disco, para resolver falhas graves de página. Esse contador é um indicador principal dos tipos de falhas que causam atrasos em todo o sistema. A contagem inclui as páginas recuperadas para satisfazer às falhas de página no cache do sistema de arquivos. Essas páginas são solicitadas comumente pelos aplicativos. Este contador deve permanecer sempre abaixo de 1.000.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho para o contador % Tempo do Processador
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de % Processor Time do objeto de desempenho de Processor para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de % Processor Time, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho % Processor Time apresenta a porcentagem do tempo em que o processador está executando threads não ociosos. Você pode usar esse contador para monitorar o uso geral dos processadores ou pode monitorar a utilização por processador. A utilização média da CPU deve estar sempre abaixo de 90 por cento.

Observação:
O % Processor Time exibido pelo Exchange Server Analyzer é um valor agregado com base no número total de CPUs detectadas, tanto físicas quanto lógicas, dividido pela soma da contagem da CPU.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho para contador de Total de Bytes/s
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Bytes Total/sec do objeto de desempenho de Network Interface para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de Bytes Total/sec, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho de Bytes Total/sec mostra a taxa na qual o adaptador de rede está processando os bytes de dados. Esse contador inclui todos os dados de arquivo e aplicativo, além das informações de protocolo, como cabeçalhos de pacote. Para um adaptador de rede de 100 Mbps (megabits por segundo), o valor do contador de desempenho de Bytes Total/sec deve estar abaixo de 7 megabytes/segundo. Para um adaptador de rede de 1000 Mbps, o valor do contador de desempenho Total de Bytes/s deve estar abaixo de 70 megabytes/segundo.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador Tempo de Leitura LDAP
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-06

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de LDAP Read Time do objeto de desempenho de MSExchangeDSAccess Process para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de LDAP Read Time, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho LDAP Read Time mostra o tempo, em milissegundos, que uma solicitação de leitura do LDAP (Lightweight Directory Access Protocol) demora para ser preenchida. O valor médio deve estar abaixo de 50 milissegundos. Os valores máximos não devem exceder 100 milissegundos.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Dados de desempenho do contador Tempo de Pesquisa LDAP
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de LDAP Search Time do objeto de desempenho de MSExchangeDSAccess Processes para analisar os dados do desempenho. Ao coletar quaisquer dados do contador de desempenho de LDAP Search Time, o Analisador do Exchange Server exibirá as informações sobre os dados coletados como informações de linha de base.

O contador de desempenho LDAP Search Time mostra o tempo em milissegundos que uma solicitação de pesquisa LDAP leva para ser concluída. O valor médio deve estar abaixo de 50 milissegundos. Os valores máximos não devem exceder 100 milissegundos.

Por padrão, o Analisador do Exchange Server recupera uma amostra a cada 30 segundos, por um período de 2 horas. O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. O Analisador do Exchange Server informa também o valor do 90º percentil de todos os valores coletados.

Observação:
Se você listar em ordem crescente todos os valores coletados pelo Analisador do Exchange Server, o 90º percentil será o valor na posição de 90% da lista. O valor do 90º percentil indica os valores altos desse contador durante o intervalo de coleta.

Em algumas instâncias, o valor máximo será aquele em um ponto de pico no intervalo. Sendo assim, o valor máximo não é representativo do intervalo todo. Nem sempre o valor médio indica a carga com exatidão porque esse valor inclui o tempo de ociosidade decorrido durante o intervalo de coleta. Portanto, o Analisador do Exchange Server informa o valor máximo e o valor do 90º percentil.

As informações contidas nessa mensagem de linha de base são apenas para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre os limites sugeridos de contadores de desempenho, consulte Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


O objeto de monitor de desempenho PhysicalDisk não está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Avg. Disk sec/Read do objeto de desempenho de PhysicalDisk para analisar os dados do desempenho. Se o contador não retornar dados válidos, o Analisador do Exchange Server exibirá uma mensagem de linha de base.

Se o mecanismo de coleta de dados de desempenho não retornar dados válidos, qualquer combinação das seguintes condições será verdadeira:

  • O objeto do desempenho do PhysicalDisk está desabilitado.

  • O objeto do monitor de desempenho do PhysicalDisk está ausente ou danificado.

  • O Analisador do Exchange Server não tem permissões adequadas para acessar os objetos de desempenho.

As duas primeiras condições poderão ocorrer se alguns contadores extensíveis danificarem o Registro ou se programas baseados na WMI (Instrumentação de Gerenciamento do Microsoft Windows®) modificarem o Registro. O procedimento a seguir explica como corrigir as duas primeiras condições. Antes de executar o procedimento, verifique se o Analisador do Exchange Server tem as permissões adequadas. Para obter mais informações sobre as permissões necessárias para executar o Analisador do Exchange Server, consulte a documentação da Ajuda incluída no Analisador do Exchange Server. Para obter Ajuda, abra o Analisador do Exchange Server e pressione a tecla F1.

Para corrigir esse erro

  1. Verifique se o objeto de desempenho do PhysicalDisk está habilitado.

    1. Baixe e instale a ferramenta Lista de Contadores de Desempenho Extensíveis (Exctrlst.exe). Você pode fazer download do Exctrlst.exe no site da Microsoft na Web, "Exctrlst.exe: Lista de Contadores de Desempenho Extensíveis" (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Abra o Exctrlst.exe, clique em Ordem de classificação, e clique em Serviço.

    3. Localize o serviço ao qual o objeto de desempenho relata e verifique se a caixa de seleção Contadores de Desempenho Habilitados está marcada.

      Se a caixa de seleção Contadores de Desempenho Habilitados não estiver marcada, marque a caixa de seleção e reinicie o serviço que está associado aos contadores de desempenho para verificar se os contadores de desempenho estão em operação. Se os contadores de desempenho não estiverem funcionando ou se a caixa de seleção Contadores de desempenho habilitados já estava marcada, continue na etapa 2.

  2. Reconstrua os contadores de desempenho ausentes ou danificados, conforme descrito no artigo 300956 da Base de Dados de Conhecimento da Microsoft, "Como reconstruir manualmente os valores de biblioteca do contador de desempenho" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Se você seguir as instruções desse artigo da Base de Dados de Conhecimento e o problema não for solucionado, será necessário reinstalar o sistema operacional Windows no modo Reparo e então aplicar os service packs mais recentes do Windows.


Conflito de porta:Serviço de replicação de site
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas do Registro para determinar se existem conflitos de porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Se o Exchange Server Analyzer perceber que o valor de HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP corresponde a qualquer um dos valores especificados nos outros seis valores do Registro da porta listados anteriormente nesse artigo, um erro será exibido. O Exchange Server Analyzer também exibirá um erro para a porta que estiver em conflito com HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP.

Para corrigir esse erro, você deve alterar o valor dessa chave ou da chave conflitante para um valor único, conforme especificado pela saída do Exchange Server Analyzer.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir o parâmetro de Registro TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Clique duas vezes na chave TCP/IP e defina o campo Dados do valor como um valor único acima de 5000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Para implantar RPC sobre HTTP

  1. Consulte "Cenários de Implantação de RPC sobre HTTP do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=47577 ).

  2. Consulte o artigo 833401 da Base de Dados de Conhecimento Microsoft, "Como configurar RPC sobre HTTP no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  3. Revise o artigo 827330 da Base de Dados de Conhecimento, "Como solucionar problemas de conexão cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  4. Consulte o Microsoft Support WebCast, "Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre portas de mapeamento estáticas usadas pelo Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 194952, "XADM: Limitações de portas mapeadas estaticamente para o Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)

  • 270836, "Mapeamentos de porta estática do Exchange 2000 e do Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


Conflito de porta: HTTP de Armazenamento
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-21

A Ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas do Registro para determinar se existem conflitos de porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

A chave de Registro Rpc/HTTP Port é utilizada pelo Exchange para oferecer suporte aos recursos RPC/HTTP do Microsoft Office Outlook® 2003 e Outlook em Qualquer Lugar do Exchange Server 2007. Se o Exchange Server Analyzer perceber que o valor de HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port corresponde a qualquer um dos valores especificados nos outros seis valores do Registro da porta listados anteriormente nesse artigo, um erro será exibido. O Exchange Server Analyzer também exibirá um erro para a porta que estiver em conflito com HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port.

Para corrigir esse erro, você deve alterar o valor dessa chave ou da chave conflitante para um valor único, conforme especificado pela saída do Exchange Server Analyzer.

Se você estiver oferecendo suporte a clientes RPC/HTTP Outlook 2003 ou Outlook 2007, defina a chave Rpc/HTTP Port com o valor decimal de 6001. Além disso, você deve revisar as configurações de RPC/HTTP de seu ambiente.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir o valor de Registro da porta Rpc/HTTP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters

  3. Clique duas vezes na chave Rpc/HTTP Port e defina o campo Dados do valor como um valor único acima de 5000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Para revisar as configurações de RPC sobre HTTP

  1. Consulte "Cenários de implantação de RPC sobre HTTP do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consulte "Implantando o Outlook em Qualquer Lugar" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Consulte o artigo 833401 da Base de Dados de Conhecimento da Microsoft, "Como configurar RPC sobre HTTP em um servidor único no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Revise o artigo 827330 da Base de Dados de Conhecimento, "Como solucionar problemas de conexão de cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Consulte o Microsoft Support WebCast, "Usando Microsoft Exchange pela Internet (RPC/HTTP) com Microsoft Office Outlook 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Conflito de porta:Armazenar TCP
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-30

A Ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas do Registro para determinar se existem conflitos de porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Se o Exchange Server Analyzer perceber que o valor de HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port corresponde a qualquer um dos valores especificados nos outros seis valores do Registro da porta listados anteriormente nesse artigo, um erro será exibido. O Exchange Server Analyzer também exibirá um erro para a porta que estiver em conflito com HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port.

O motivo mais comum para a configuração desse valor é habilitar clientes MAPI para se conectarem a um servidor Exchange existente no outro lado de um firewall. Esse cenário requer a abertura de várias portas em um firewall para habilitar clientes do Microsoft Office Outlook® 2003 ou do Outlook 2007 a se conectarem por meio do MAPI com um servidor Exchange, geralmente pela Internet.

A implantação recomendada para usar o Outlook no Modo MAPI para se conectar a um servidor Exchange pela Internet é o uso de recursos RPC sobre HTTP, encontrados no Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 e Microsoft Windows® XP Professional. O Modo MAPI era conhecido anteriormente como modo "Corporativo" ou de "Grupo de trabalho".

Para corrigir esse erro, você deve alterar o valor dessa chave ou da chave conflitante para um valor único, conforme especificado pela saída do Exchange Server Analyzer.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir o valor do Registro da Porta TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Clique duas vezes na chave TCP/IP Port e defina o campo Dados do valor como um valor único acima de 5000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Para implantar RPC sobre HTTP

  1. Consulte "Exchange Server 2003 RPC over HTTP Deployment Scenarios" (em inglês) (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consulte "Implantando o Outlook em Qualquer Lugar" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Consulte o artigo 833401 da Base de Dados de Conhecimento Microsoft, "Como configurar RPC sobre HTTP no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Revise o artigo 827330 da Base de Dados de Conhecimento, "Como solucionar problemas de conexão cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Consulte o Microsoft Support WebCast, "Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre portas de mapeamento estático usadas pelo Exchange, consulte o artigo 270836 da Base de Dados de Conhecimento Microsoft, "Mapeamentos de porta estáticos do Exchange 2000 e do Exchange 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)


Conflito de porta: HTTP do Atendedor do Sistema
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-21

A ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas do Registro para determinar se existe algum conflito de porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

A chave HTTP Port é utilizada pelo Exchange para oferecer suporte aos recursos RPC/HTTP do Microsoft Office Outlook® 2003 e Outlook em Qualquer Lugar do Exchange Server 2007. Se o Exchange Server Analyzer detectar que o valor de HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port corresponde a um dos valores especificados nos outros seis valores de Registro da porta listados anteriormente nesse artigo, um erro será exibido. O Exchange Server Analyzer também exibirá um erro para a porta que estiver em conflito com HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port.

Para corrigir esse erro, você deve alterar o valor dessa chave ou da chave conflitante para um valor exclusivo, conforme especificado pela saída do Exchange Server Analyzer.

Se você estiver oferecendo suporte a clientes RPC/HTTP Outlook 2003 ou Outlook 2007, defina a chave HTTP Port como o valor decimal de 6002. Além disso, verifique as configurações de RPC/HTTP de seu ambiente.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir o valor do Registro da porta HTTP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Clique duas vezes na chave HTTP Port e defina o campo Dados do valor como um valor exclusivo acima de 5000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Para revisar as configurações do RPC sobre HTTP

  1. Consulte "Exchange Server 2003 RPC over HTTP Deployment Scenarios" (em inglês) (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Reveja "Implantando o Outlook em Qualquer Lugar" (em inglês) (http://www.microsoft.com/technet/prodtechnol/exchange/e2k7help/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx).

  3. Consulte o artigo 833401 da Base de Dados de Conhecimento da Microsoft, "Como configurar RPC sobre HTTP em um único servidor no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Reveja o artigo 827330 da Base de Dados de Conhecimento, "Como solucionar problemas de conexão cliente RPC sobre HTTP no Office Outlook 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Consulte o Microsoft Support WebCast, "Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Conflito de porta:HTTP NSPI do Atendedor do Sistema
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-30

A Ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas do Registro para determinar se existem conflitos de porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

A chave de Registro Rpc/HTTP NSPI Port é usada pelo Exchange para oferecer suporte aos recursos RPC/HTTP do Microsoft Office Outlook® 2003 e do Outook em Qualquer Lugar do Exchange Server 2007. Se o Analisador do Exchange Server detectar que o valor de HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port corresponde a qualquer um dos valores especificados nos outros seis valores do Registro da porta listados anteriormente nesse artigo, um erro será exibido. O Exchange Server Analyzer também exibirá um erro para a porta que estiver em conflito com HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\ Rpc/HTTP NSPI Port.

Para corrigir esse erro, você deve alterar o valor dessa chave ou da chave conflitante para um valor único, conforme especificado pela saída do Exchange Server Analyzer.

Se você estiver oferecendo suporte a clientes RPC/HTTP Outlook 2003 ou Outlook 2007, defina a chave Rpc/HTTP NSPI Port como o valor decimal de 6004. Além disso, confira as configurações de RPC/HTTP de seu ambiente.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir o valor do Registro da Porta Rpc/HTTP NSPI

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Clique duas vezes na chave Rpc/HTTP NSPI Port e defina o campo Dados do valor como um valor único acima de 5000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Para revisar as configurações do RPC sobre HTTP

  1. Consulte "Exchange Server 2003 RPC over HTTP Deployment Scenarios" (em inglês) (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consulte "Implantando o Outlook em Qualquer Lugar" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Consulte o artigo 833401 da Base de Dados de Conhecimento Microsoft, "Como configurar RPC sobre HTTP no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Revise o artigo 827330 da Base de Dados de Conhecimento, "Como solucionar problemas de conexão cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Consulte o Microsoft Support WebCast, "Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Conflito de porta: NSPI do Atendedor do Sistema
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-21

A Ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas do Registro para determinar se existem conflitos de porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Se o Exchange Server Analyzer perceber que o valor de HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port corresponde a qualquer um dos valores especificados nos outros seis valores do Registro da porta listados anteriormente nesse artigo, um erro será exibido. O Exchange Server Analyzer também exibirá um erro para a porta que estiver em conflito com HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port.

O motivo mais comum para a configuração desse valor é habilitar clientes MAPI para se conectarem a um servidor Exchange existente no outro lado de um firewall. Esse cenário requer a abertura de várias portas em um firewall para habilitar clientes do Microsoft Office Outlook® 2003 e do Outlook 2007 a se conectarem por meio do MAPI com um servidor Exchange, geralmente pela da Internet.

A implantação recomendada para usar o Outlook no Modo MAPI para se conectar a um servidor Exchange pela Internet é o uso de recursos RPC sobre HTTP, encontrados no Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 e Microsoft Windows® XP Professional. O Modo MAPI era conhecido anteriormente como modo "Corporativo" ou de "Grupo de trabalho".

Para corrigir esse erro, você deve alterar o valor dessa chave ou da chave conflitante para um valor único, conforme especificado pela saída do Exchange Server Analyzer.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir o valor do Registro da Porta TCP/IP NSPI

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Clique duas vezes na chave TCP/IP NSPI Port e defina o campo Dados do valor como um valor único acima de 5000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Para implantar RPC sobre HTTP

  1. Consulte "Exchange Server 2003 RPC over HTTP Deployment Scenarios" (em inglês) (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consulte "Implantando o Outlook em Qualquer Lugar" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Consulte o artigo 833401 da Base de Dados de Conhecimento Microsoft, "Como configurar RPC sobre HTTP no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Revise o artigo 827330 da Base de Dados de Conhecimento, "Como solucionar problemas de conexão cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Consulte o Microsoft Support WebCast, "Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre portas de mapeamento estáticas usadas pelo Exchange, consulte o seguinte artigo da Base de Dados de Conhecimento:

  • 270836, "Mapeamentos de porta estática do Exchange 2000 e Exchange 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


Conflito de porta:RFR de Atendedor do Sistema
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-30

A Ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas do Registro para determinar se existem conflitos de porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Se o Exchange Server Analyzer detectar que o valor de HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port corresponde a qualquer um dos valores especificados nos outros seis valores do Registro da porta listados anteriormente nesse artigo, um erro será exibido. O Exchange Server Analyzer também exibirá um erro para a porta que estiver em conflito com HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port.

O motivo mais comum para a configuração desse valor é habilitar clientes MAPI para se conectarem a um servidor Exchange existente no outro lado de um firewall. Esse cenário requer a abertura de várias portas em um firewall para permitir que clientes Microsoft Office Outlook® 2003 ou Outlook 2007 se conectem, utilizando MAPI, a um servidor Exchange, geralmente através da Internet.

A implantação recomendada para utilizar o Outlook no Modo MAPI para se conectar a um servidor Exchange através da Internet é o uso de recursos RPC sobre HTTP, encontrados no Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 e Microsoft Windows® XP Professional. O Modo MAPI era conhecido anteriormente como modo "Corporativo" ou de "Grupo de trabalho".

Para corrigir esse erro, você deve alterar o valor dessa chave ou da chave conflitante para um valor exclusivo, conforme especificado pela saída do Exchange Server Analyzer.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir o valor do Registro da Porta TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Clique duas vezes na chave TCP/IP Port e defina o campo Dados do valor como um valor exclusivo acima de 5000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Para implantar RPC sobre HTTP

  1. Consulte "Exchange Server 2003 RPC over HTTP Deployment Scenarios" (em inglês) (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consulte "Implantando o Outlook em Qualquer Lugar" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Consulte o artigo 833401 da Base de Dados de Conhecimento da Microsoft, "Como configurar RPC sobre HTTP em um único servidor no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Reveja o artigo 827330 da Base de Dados de Conhecimento, "Como solucionar problemas de conexão cliente RPC sobre HTTP no Office Outlook 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Consulte o Microsoft Support WebCast, "Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre portas de mapeamento estático utilizadas pelo Exchange, consulte o artigo 270836 da Base de Dados de Conhecimento da Microsoft, "Mapeamentos de porta estáticos do Exchange 2000 e do Exchange 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)


Distribuição de atualização do service pack de pré-lançamento detectada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo versionNumber de cada objeto do Exchange Server. O atributo versionNumber representa a versão do Exchange Server que está sendo executada no computador.

O Exchange Server Analyzer também consulta a classe CIM_Datafile do WMI (Intrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version para o arquivo de biblioteca ExCDO (Objeto de Dados de Colaboração do Exchange), o ExCDO.dll. Se o Exchange Server Analyzer determinar que a chave Version para o ExCDO.dll tem um valor igual a 6603.0, será exibido um aviso.

Um computador do Exchange 2000 Server que está executando a versão 6603.0 do ExCDO.dll indica que o servidor está executando o pacote cumulativo de atualizações do Exchange 2000 Server Post-Service Pack 3 (SP3), Versão 1, de agosto de 2004. A versão 2 desse pacote cumulativo de atualizações já está disponível. É recomendável instalar o pacote cumulativo de atualizações de agosto de 2004.

Para corrigir esse aviso

  1. Obtenha informações sobre a atualização mais recente, consultando o artigo 870540 da Base de Dados de Conhecimento Microsoft, "Disponibilidade do pacote cumulativo de atualizações do Exchange 2000 Server Post-Service Pack 3 de agosto de 2004" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540) (página em inglês).

  2. Baixe a atualização mais recente (agosto de 2004) de "Downloads para o Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=33457).

  3. Faça backup do computador do Exchange Server.

  4. Aplique o pacote cumulativo de atualizações de agosto de 2004.

Para obter mais informações sobre como obter o service pack mais recente do Exchange 2000 Server, consulte o artigo 301378 da Base de Dados de Conhecimento Microsoft, "Como obter o service pack mais recente do Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

Para obter mais informações sobre a instalação desta e de outras atualizações do Exchange Server, consulte o artigo 328839 da Base de Dados de Conhecimento, "Como aplicar service packs e hotfixes do Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839) (página em inglês).


Problema com o Local do Arquivo de Paginação
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool verificou que o arquivo de paginação está em um local que pode afetar negativamente o desempenho do servidor. O arquivo de paginação não pode estar localizado no mesmo disco que os bancos de dados do Exchange ou os arquivos de log do Exchange. Também é uma boa idéia isolar o arquivo de paginação dos arquivos do sistema.

É recomendável que o arquivo de paginação seja localizado em uma partição dedicada ou disco de alta velocidade.

Para corrigir esse aviso

  • Mova o arquivo de paginação para um local que não contém arquivos de log ou bancos de dados do Exchange e, se possível, um local que não contenha a partição do sistema.

Para obter mais informações

  • Para obter mais informações sobre como configurar o arquivo de paginação, consulte o artigo 197379 da Base de Dados de Conhecimento da Microsoft, "Configurando arquivos de paginação para otimização e recuperação no Windows Server 2003, no Windows 2000, e no Windows NT" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=197379).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).


Afunilamento do processador
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-24

A ferramenta Microsoft® Exchange Server Analyzer Tool identificou que o servidor está enfrentando um afunilamento na CPU. A utilização da CPU do servidor excedeu um limite recomendado. Os contadores utilizados para identificar afunilamentos no processador ou problemas com a utilização do processador são:

  • Contador de desempenho Opções de Contexto/s no objeto de desempenho Sistema.

  • Contador de desempenho % Tempo do Processador (_Total) no objeto de desempenho Processador.

  • Contador de desempenho Comprimento da Fila do Processador no objeto de desempenho Sistema.

Detectando um afunilamento no processador

Se uma das seguintes condições for atendida, o Exchange Server Analyzer detectará um afunilamento:

  • O valor médio do contador de desempenho % Tempo do Processador (_Total) no objeto de desempenho Processo é maior que 70%.

  • O valor máximo do contador de desempenho % Tempo do Processador (_Total) no objeto de desempenho Processo é maior que 90%.

  • O valor médio do contador de desempenho Opções de Contexto/s no objeto de desempenho Sistema é maior que 20.000.

  • O contador de desempenho Comprimento da Fila do Processador no objeto de desempenho Sistema é maior que dois.

  • O contador de desempenho % Tempo do Processador (_Total) no objeto de desempenho Processo proporciona a utilização geral dos processadores. A utilização média da CPU deve ser sempre abaixo de 80 por cento. Médias mais altas indicam um afunilamento no processador. Se a utilização média do processador estiver acima de 70%, será exibido um aviso. Picos freqüentes no tempo do processador acima de 90% também revelam um afunilamento no processador.

  • O contador de desempenho Comprimento da Fila do Processador no objeto de desempenho Sistema indica o número de threads na fila do processador. Existe uma única fila de tempo do processador, mesmo em computadores com vários processadores. Um número acima de 2 indica que existem threads aguardando o tempo do processador e que há um afunilamento no processador.

Determinando fontes de carga do processador

Se for localizado um afunilamento no processador, você deverá determinar a origem da maior parte da utilização da CPU. Em um servidor back-end Exchange, a maior parte da utilização da CPU deve ter origem no processo Store.exe. Se mais de 20% da utilização da CPU se originar de um processo diferente de Store.exe, será importante descobrir que outros processos estão consumindo a CPU.

Se a utilização da CPU para os processos listados na tabela a seguir exceder o limite, o Exchange Server Analyzer exibirá um erro.

Processo | Limite do contador de desempenho % Tempo do Processador (_Total) no objeto de desempenho Processo
Armazenamento | 90%
Inetinfo | 20%
Emsmts | 40%
Lsass | 40%
Sistema | 40%
Mad | 40%
ExMGMT | 20%
W3WP | 40%

O Exchange Server Analyzer também mede a diferença entre o tempo ocioso do processador, que é medido pelo contador de desempenho %Tempo do Processador (instância Idle), e o contador de desempenho %Tempo do Processador (instância _Total) no objeto de desempenho Processo. Em um servidor back-end Exchange íntegro, pelo menos 70% do tempo do processador em uso devem estar alocados no processo Store.exe.

O Exchange Server Analyzer exibe um erro sob as seguintes condições:

  • Se a quantidade de tempo do processador que não é gasto nos processos relacionados ao servidor Exchange (Store.exe, inetinfo.exe, emsmta.exe, lsass.exe, w3wp.exe, exmgmt.exe ou mad.exe) for maior que 35%.

  • Se o tempo do processador não relacionado ao Exchange for maior que 20%.

  • Se ocorrer um afunilamento no processador e menos de 70% do tempo do processador estiver alocado no processo Store.exe.

Em todos esses casos, é recomendável descobrir que outros processos estão consumindo o tempo da CPU do servidor.

Causas comuns de afunilamentos no processador em servidores back-end

Há várias causas possíveis para um afunilamento de desempenho, incluindo:

  • Outros aplicativos no servidor que estão consumindo a CPU

  • Altas taxas de RPC

  • Expansão de lista de distribuição

  • Backup e manutenção em execução durante horários de expediente de pico

  • Conversão do conteúdo da mensagem em mensagens causadas por:

    • Vários protocolos em execução (por exemplo, HTTP, POP3, IMAP4, Microsoft Office Outlook®)

    • Outlook 2000 ou versões anteriores que usam pastas offline (arquivos .ost)

Removendo afunilamentos do processador

Há várias maneiras de remover afunilamentos do processador no servidor Exchange.

Para remover afunilamentos do processador

  • Se possível, adicione mais processadores ou processadores mais velozes ao servidor. Além disso, habilite a hyper-threading se houver suporte para essa tecnologia nos processadores. Você pode habilitar a hyper-threading configurando a BIOS do sistema. Para obter mais informações, consulte a documentação da Ajuda do fabricante do computador.

  • Se o aumento da força de processamento não for uma opção viável, reduza a carga sobre os processadores. Para reduzir o impacto global sobre o servidor, é importante verificar se tarefas de alta utilização de E/S, da CPU ou devoradoras de memória ocorrem fora do horário normal de expediente.

    Primeiro, identifique quais aplicativos ou tarefas estão causando carga no servidor. Se um aplicativo não-Exchange não for importante para esse servidor, execute-o em outro servidor. Se possível, mova funções do servidor para outros computadores também. Por exemplo, se o processo Inetinfo estiver utilizando intensamente a CPU, experimente adicionar servidores front-end para se encarregar do trabalho de protocolo realizado pelo Inetinfo. Também é possível mover o acesso às pastas públicas para um servidor de pastas públicas dedicado. Por último, se um servidor executa muitas expansões da lista de distribuição, você pode reduzir o uso da CPU, deslocando a expansão da lista de distribuição para um servidor de expansão de lista de distribuição dedicado.

  • Verifique se as tarefas de alta utilização da CPU (como backup e manutenção) ocorrem fora do horário de pico. Certifique-se de que essas tarefas sejam realizadas em etapas. Estabelecer etapas para uma tarefa significa definir diferentes horários de início e, preferencialmente, horários de término para cada tarefa. Preparar a manutenção e o backup de bancos de dados ou de grupos de armazenamento também reduz o efeito das tarefas de alta utilização de recursos.

  • Se você removeu todas as fontes de carga opcionais e a utilização da CPU ainda for muito alta, mova usuários para outro servidor para reduzir a carga. Para obter mais informações, consulte Mover Caixas de Correio de Usuário para Outro Servidor

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre como mover caixas de correio de usuários para reduzir a carga no servidor, consulte Mover Caixas de Correio de Usuário para Outro Servidor


O objeto do monitor de desempenho do processador não está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de % Processor Time do objeto de desempenho de Processor para analisar os dados do desempenho. Se o contador não retornar dados válidos, o Analisador do Exchange Server exibirá uma mensagem de linha de base.

Se o mecanismo de coleta de dados de desempenho não retornar dados válidos, qualquer combinação das seguintes condições será verdadeira:

  • O objeto do desempenho do Processor está desabilitado.

  • O objeto do monitor de desempenho do Processor está ausente ou danificado.

  • O Analisador do Exchange Server não tem permissões adequadas para acessar os objetos de desempenho.

As duas primeiras condições poderão ocorrer se alguns contadores extensíveis danificarem o Registro ou se programas baseados na WMI (Instrumentação de Gerenciamento do Microsoft Windows®) modificarem o Registro. O procedimento a seguir explica como corrigir as duas primeiras condições. Antes de executar o procedimento, verifique se o Analisador do Exchange Server tem as permissões adequadas. Para obter mais informações sobre as permissões necessárias para executar o Analisador do Exchange Server, consulte a documentação da Ajuda incluída no Analisador do Exchange Server. Para obter Ajuda, abra o Analisador do Exchange Server e pressione a tecla F1.

Para corrigir esse erro

  1. Verifique se o objeto de desempenho do Processor está habilitado.

    1. Baixe e instale a ferramenta Lista de Contadores de Desempenho Extensíveis (Exctrlst.exe). Você pode baixar o Exctrlst.exe em "Exctrlst.exe: Lista de Contadores de Desempenho Extensíveis" (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Abra o Exctrlst.exe, clique em Ordem de classificação, e clique em Serviço.

    3. Localize o serviço ao qual o objeto de desempenho relata e verifique se a caixa de seleção Contadores de Desempenho Habilitados está marcada.

      Se a caixa de seleção Contadores de Desempenho Habilitados não estiver marcada, marque-a e reinicie o serviço associado aos contadores de desempenho, para verificar se eles estão funcionando. Se os contadores de desempenho não estiverem funcionando ou se a caixa de seleção Contadores de desempenho habilitados já estava marcada, continue na etapa 2.

  2. Reconstrua os contadores de desempenho ausentes ou danificados, conforme descrito no artigo 300956 da Base de Dados de Conhecimento da Microsoft, "Como reconstruir manualmente os valores de biblioteca do contador de desempenho" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Se você seguir as instruções desse artigo da Base de Dados de Conhecimento e o problema não for solucionado, será necessário reinstalar o sistema operacional Windows no modo Reparo e então aplicar os service packs mais recentes do Windows.


A replicação do conteúdo da pasta pública está em pausa
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo heuristics foi definido na organização do Exchange Server. Se o Exchange Server Analyzer verificar que o bit 1024 está definido em heuristics, ele exibirá um aviso.

O Exchange Server 2003 SP2 introduziu o recurso para que um administrador pare toda a replicação de conteúdo de pasta pública na organização. Você pode parar toda a replicação de pasta pública, clicando com o botão direito no nome da Organização no Gerenciamento do Sistema do Exchange e clicando em Parar Replicação de Conteúdo de Pasta Pública. Quando você clica em Parar Replicação de Conteúdo de Pasta Pública, o bit 1024 é definido no atributo heuristics. Você só deve parar toda a replicação de pasta pública em casos extremos, como solução de problemas em uma pasta pública de toda a organização ou problema de fluxo de mensagens.

Você deve continuar a replicação de conteúdo de pasta pública se as seguintes condições forem verdadeiras:

  • Você não está solucionando problemas.

  • Você não precisa, por nenhum outro motivo, parar toda a replicação de conteúdo de pasta pública.

Para continuar a replicação de conteúdo de pasta pública no nível da organização

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Clique com o botão direito em Nome_da_Organização e clique em Continuar Replicação de Conteúdo de Pasta Pública.

Para obter mais informações sobre replicação de pasta pública, consulte Práticas recomendadas para pastas públicas do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=46437).


Armazenamento de pasta pública presente no servidor front-end
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-09-07

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se uma pasta pública está presente em cada servidor Exchange. Se o Exchange Server Analyzer perceber que o objeto InformationStore pertence à classe msExchPublicMDB, o servidor estará hospedando um armazenamento de pasta pública.

O Exchange Server Analyzer também consulta a classe MicrosoftExchangeV2 do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se há valor definido para a chave IsFrontEndServer. Um valor True indica que o servidor Exchange está configurado como um servidor front-end e um valor False indica que o servidor Exchange não está configurado como um servidor front-end. Se o Exchange Server Analyzer detectar que um servidor Exchange configurado como um servidor front-end está hospedando um armazenamento de informações públicas, será exibido um aviso.

É recomendável não executar armazenamentos de pastas públicas em servidores front-end. Não são necessários armazenamentos de pastas públicas em servidores front-end, porque esses servidores não hospedam caixas de correio. Além disso, ocorrem problemas já conhecidos de replicação de pastas públicas, referências de pastas públicas e perdas de memória quando os armazenamentos de pastas públicas estão localizados em servidores front-end que estão executando o Exchange 2000 Server. Portanto, desmonte todos os armazenamentos de pastas públicas em todos os servidores front-end.

Depois de desmontar os armazenamentos de pastas públicas, você pode desabilitar o serviço Armazenamento de Informações do Microsoft Exchange porque ele não executa mais nenhuma função nos servidores front-end. Ao remover os serviços desnecessários, você reduz a carga e aumenta a segurança e o desempenho.

Observação:
Se o servidor front-end também receber mensagens SMTP da Internet, o serviço Armazenamento de Informações do Microsoft Exchange deverá continuar em execução e um armazenamento de caixa de correio deverá continuar montado. Contudo, nunca deverá existir um armazenamento de pasta pública em um servidor front-end.

Para parar e desabilitar os bancos de dados de caixas de correio e pastas públicas

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda seu servidor e depois expanda Primeiro Grupo de Armazenamento.

    Clique com o botão direito em Armazenamento de Caixa de Correio (ServerName), clique em Desmontar Armazenamento e em Sim para desmontar o armazenamento.

    Importante:
    Se você usar o servidor front-end como um servidor bridgehead SMTP, deverá ter um armazenamento de caixa de correio montado no servidor. Nesse caso, não desmonte nem exclua esse armazenamento, mas verifique se você não tem caixas de correio armazenadas nesse servidor.

  2. Clique com o botão direito em Armazenamento de Caixa de Correio (ServerName) e clique em Propriedades.

  3. Clique na guia Banco de dados, marque a caixa de seleção Não montar o armazenamento na inicialização e clique em OK.

    Clique com o botão direito em Armazenamento de Pasta Pública (ServerName) e clique em Desmontar Armazenamento.

    Cuidado:
    Antes de desmontar o armazenamento de pasta pública, verifique se as pastas públicas têm uma réplica em outro armazenamento de pasta pública. Caso contrário, você poderá perder informações.

  4. Clique em Sim para desmontar o armazenamento de pasta pública.

Para desabilitar o serviço Armazenamento de Informações do Microsoft Exchange

  1. No snap-in de Serviços do MMC (Console de Gerenciamento Microsoft), clique com o botão direito em Armazenamento de Informações do Microsoft Exchange na lista Nome e clique em Propriedades.

  2. Na lista Tipo de inicialização, selecione Desabilitado e clique em Parar.

Para excluir definitivamente os bancos de dados de caixa de correio e pasta pública

  • Siga a orientação contida no Exchange Server Security Hardening Guide, Como desmontar e excluir os armazenamentos de caixa de correio e pasta pública (http://go.microsoft.com/fwlink/?LinkId=25210) (em inglês)

Para obter mais informações sobre problemas relacionados à execução de serviços de armazenamento em servidores front-end, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 286822, "XCCC: Servidores front-end estabelecem um grande número de conexões com eles mesmos" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=286822).

  • 320298, "Grande número de conexões estabelecidas em servidores front-end que estão executando o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320298).

Para obter mais informações sobre os servidores front-end e back-end, consulte o guia Topologia front-end e back-end do Exchange Server 2003 e Exchange 2000 Server (em inglês) (http://go.microsoft.com/fwlink/?linkid=34216).


O arquivo REAPI.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais dos arquivos acima está ausente, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Atualizações recomendadas para Windows 2000 Server SP 4 em um cluster
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar a versão do sistema operacional Microsoft Windows® que está sendo executada no servidor Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion

Observação:
Um valor CurrentVersion 4.0 indica que o computador está executando o Microsoft Windows NT® Server 4.0. Um valor igual a 5.0 indica que o computador está executando o Windows NT® Server 2000. Um valor igual a 5.2 indica que o computador está executando o Windows NT® Server 2003.

O Analisador do Exchange Server consulta também a classe WMI (Instrumentação de Gerenciamento do Windows) Win32_OperatingSystem para determinar o valor da chave ServicePackMajorVersion.

Finalmente, o Analisador do Exchange Server consulta a classe WMI Win32_Service para determinar se o serviço ClusSvc foi iniciado.

O Analisador do Exchange Server exibe uma mensagem de configuração de prática recomendada, se as seguintes condições existirem:

  • O servidor Exchange está em um computador que executa o Windows 2000 Server que foi atualizado com o Service Pack 4.

  • O serviço ClusSvc está iniciado.

É recomendável que você avalie as atualizações e hotfixes que estão disponíveis e determine se elas podem resolver os problemas do seu ambiente.

Para obter mais informações e obter a lista de atualizações disponíveis para servidores que executam o Windows 2000 Server, consulte o artigo 895090 da Base de Dados de Conhecimento da Microsoft, "Hotfixes recomendados para os clusters de servidor com base no Windows 2000 Service Pack 4" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895090).


Comprimento da Fila Remota além do limite
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-04-09

A ferramenta Microsoft Exchange Analyzer Tool dispõe de um mecanismo de coleta de dados de desempenho usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho Remote Queue Length do objeto de desempenho do SMTP Server para analisar os dados do desempenho.

Se determinar que o contador de Remote Queue Length excedeu o valor de pico de 1.000 durante o intervalo de tempo de amostragem, o Exchange Analyzer exibirá um erro.

O contador SMTP Server\Remote Queue Length indica o número de mensagens na fila SMTP aguardando entrega remota. Um aumento em Remote Queue Length significa que as mensagens não estão sendo enviadas a outros servidores.

Essa falha no envio de e-mails pode ser explicada pelas interrupções ou problemas de desempenho ocorridos na rede ou nos servidores remotos. Essas interrupções ou problemas de desempenho impedem que a rede ou os servidores remotos recebam os e-mails de modo eficiente.

Para resolver esse erro, use os recursos dos links a seguir, para identificar o servidor ou o componente da rede problemático e solucionar os problemas de desempenho.

Para obter mais informações

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Identificando as filas de e-mails crescentes, na seção "Identificando os sintomas de desempenho inadequado" de Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (em inglês).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte Desempenho do Exchange Server 2003: 10 aspectos a serem considerados (http://go.microsoft.com/fwlink/?LinkID=56460).


O comprimento da Fila de Repetição Remota excedeu o limite
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Remote Retry Queue Length do objeto de desempenho de SMTP Server para analisar os dados do desempenho.

O contador SMTP Server\Remote Retry Queue Length indica o número de mensagens na fila de repetição remota do SMTP (Simple Mail Transfer Protocol), que não podem ser enviadas a um servidor de destino. Ao determinar que o contador de Remote Retry Queue Length excedeu o valor de pico de 1.000 durante o intervalo de tempo de amostragem, o Analisador do Exchange Server exibirá um erro.

Essa falha no envio de e-mails pode ser explicada pelas interrupções ou problemas de desempenho ocorridos na rede ou nos servidores remotos. Essas interrupções ou problemas de desempenho impedem que a rede ou os servidores remotos recebam os e-mails de modo eficiente.

Para resolver esse erro, use os recursos dos links a seguir, para identificar o servidor ou o componente da rede problemático e solucionar os problemas de desempenho.

Para obter mais informações

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Identificando as filas de e-mails crescentes, na seção "Identificando os sintomas de desempenho inadequado" de Solucionando problemas de desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte Desempenho do Exchange Server 2003: 10 aspectos a serem considerados (http://go.microsoft.com/fwlink/?LinkID=56460).


Réplica da versão 4 do Catálogo de Endereços Offline não encontrada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Exchange_Public_Folder do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor atual de HasLocalReplica. Se descobrir que o valor de HasLocalReplica está definido como False para a instância da versão 4 do catálogo de endereços offline de uma lista de endereços offline, o Exchange Server Analyzer exibirá um erro.

Quando o HasLocalReplica está definido como False para a instância da versão 4 do catálogo de endereços offline de uma lista de endereços offline, as listas de endereços offline não são geradas corretamente. Como resultado, os usuários do Microsoft Office Outlook® 2003 não podem baixar listas de endereços offline.

Esse problema pode ocorrer se você não tiver configurado nenhum armazenamento de pasta pública para conter réplicas da versão 4 do catálogo de endereços offline. Por padrão, o catálogo de endereços offline replica seu conteúdo para o armazenamento de pasta pública do servidor em que ele está instalado. Se o armazenamento de pasta pública for removido da configuração de replicação do catálogo de endereços offline, ocorre o problema descrito no parágrafo anterior.

Para corrigir esse erro

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos e clique em Pastas.

  3. Clique com o botão direito em Pastas Públicas e clique em Exibir Pastas do Sistema.

  4. Clique para expandir o objeto CATÁLOGO DE ENDEREÇOS OFFLINE.

  5. Em CATÁLOGO DE ENDEREÇOS OFFLINE, clique com o botão direito em o=org/cn=addrlists/cn=oabs/cn=Lista de Endereços Offline Padrão e clique em Propriedades.

  6. Na guia Replicação, verifique se um armazenamento de pasta pública foi inserido na caixa Replicar conteúdo para estes armazenamentos públicos. Se um armazenamento de pasta pública não tiver sido inserido, clique em Adicionar e insira o armazenamento público apropriado para o catálogo de endereços offline.

  7. Clique em Aplicar e em OK.

  8. Clique para expandir a o=org/cn=addrlists/cn=oabs/cn=Lista de Endereços Offline Padrão.

  9. Na o=org/cn=addrlists/cn=oabs/cn=Lista de Endereços Offline Padrão, clique com o botão direito em Versão 4 do Catálogo de Endereços Offline e clique em Propriedades.

  10. Na guia Replicação, verifique se um armazenamento de pasta pública foi inserido na caixa Replicar conteúdo para estes armazenamentos públicos. Se um armazenamento de pasta pública não tiver sido inserido, clique em Adicionar e insira o armazenamento público apropriado para o catálogo de endereços offline.

  11. Clique em Aplicar e em OK.

Para obter mais informações sobre esse problema, consulte o artigo 286328 da Base de Dados de Conhecimento Microsoft, "Não há Catálogo de Endereços Off-line e ele não pode ser Gerado no Microsoft Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).

Para obter mais informações sobre como remover corretamente o primeiro computador executando o Exchange Server 2003 de um grupo administrativo, consulte o artigo 822931 da Base de Dados de Conhecimento Microsoft, "Como remover o primeiro computador com Exchange Server 2003 do grupo administrativo" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931).

Para obter mais informações sobre problemas com Catálogo de endereços Offline, consulte os seguintes Recursos do Exchange Server:

  • Catálogo de Endereços Offline - Questões a serem consideradas (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=57581)

  • Como o Outlook 2003 SP2 e o Exchange Server 2003 SP2 OAB Versão 4 funcionam juntos (página em inglês) (http://go.microsoft.com/fwlink/?linkid=53099)

  • OAB Versão 4 no Exchange Server 2003 Service Pack 2 (página em inglês) (http://go.microsoft.com/fwlink/?linkid=53097)


Comprimento da Fila de Recebimento de Replicação acima do limite
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Replication Receive Queue Size do objeto de desempenho de MSExchangeIS Public para analisar os dados do desempenho.

Ao determinar que o contador de Replication Receive Queue Size excedeu o valor de pico de 1.000 durante o intervalo de tempo de amostragem, o Analisador do Exchange Server exibirá um erro.

Mensagens de replicação de pasta pública são recebidas por SMTP, categorizadas e entregues à fila SMTP local. Em seguida, as mensagens são enviadas ao armazenamento de Pasta Pública. Quando tiverem sido enviadas ao armazenamento de Pasta Pública, as mensagens são colocadas na Fila de Recebimento de Replicação. Mensagens na Fila de Recebimento de Replicação são processadas e alterações são executadas na pasta pública apropriada. O contador de desempenho Replication Receive Queue Size indica o número de mensagens de replicação de pasta pública que aguardam para serem processadas.

Quanto maior ficar a fila de replicação, mais fora de sincronização ficará o conteúdo das pastas. Quando as filas de replicação crescem, aumenta a carga sobre os recursos à medida que as mensagens na fila de replicação são processadas. Além disso, as filas de replicação crescentes indicam que o conteúdo da pasta pública no servidor está desatualizado.

Não é necessária nenhuma ação nas duas instâncias em que o crescimento da Fila de Recebimento de Replicação é esperado e pode ser planejado:

  • Em um servidor de pasta pública introduzido recentemente, o crescimento da Fila de Recebimento de Replicação pode ser causado pela replicação esperada do aterramento inicial.

  • Se estiver ocorrendo consolidação do site ou outras alterações importantes na topologia do Exchange, é esperado que haja muita replicação à medida que o conteúdo é movido.

Para servidores existentes e estáveis onde as réplicas de pasta pública não estão sendo alteradas em massa, esse erro pode indicar:

  • Afunilamentos de desempenho dos recursos do servidor, como disco, CPU, rede ou memória. Se houver um afunilamento de recursos no servidor, o processo Store.exe não poderá processar as mensagens de replicação com rapidez suficiente, e a fila crescerá.

  • O intervalo para replicação de pastas públicas é muito curto para que a replicação seja concluída antes do início do próximo ciclo de replicação.

Para resolver esse erro, execute as seguintes etapas:

  • Aumente o tempo do intervalo de replicação e monitore MSExchangeIS Public\Replication Receive Queue Size até que seja exibida a informação de que a replicação está concluída antes do início do próximo ciclo de replicação.

  • Use os recursos nos links a seguir para determinar se um afunilamento de desempenho está causando o crescimento da fila e para tratar o afunilamento.

  • Experimente reduzir o número total de réplicas na organização do Exchange para reduzir a quantidade de tráfego de replicação necessária.

Para obter mais informações

  • Para obter mais informações sobre como solucionar problemas de desempenho no Exchange Server, consulte "Lidando com funções especiais e desempenho do Exchange" em Solucão de problemas de desempenho do Microsoft Exchange Server (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre a replicação de pasta pública no Exchange Server, consulte "Controlando a replicação de pasta pública no Exchange Server 2003" em Trabalhando com o Armazenamento do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).

  • Para obter mais informações sobre práticas recomendadas de pasta pública do Exchange, consulte Práticas recomendadas de pasta pública do Exchange: Implementando a Replicação (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=46440).

  • Para obter mais informações sobre aprimoramentos do gerenciamento de pastas públicas apresentados com o Exchange Server 2003 Service Pack 2, consulte Notas de Versão do Microsoft Exchange Server 2003 Service Pack 2 (página em inglês) (http://go.microsoft.com/fwlink/?linkid=52072).


Arquivo RESVC.DLL está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais dos arquivos acima está ausente, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


A chave do Registro RestrictRemoteClients está habilitada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se estão habilitadas restrições de interface para RPC (chamadas de procedimento remoto):

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

Se o Exchange Server Analyzer verificar que a chave de Registro RestrictRemoteClients está configurada, o Exchange Server Analyzer exibirá uma mensagem de configuração não padrão.

Restrições de Interface RPC fornecem maior proteção de rede, que tornará os sistemas menos vulneráveis a ataques na rede. O valor de Registro RestrictRemoteClients modifica o comportamento de todas as interfaces de RPC no sistema. Por padrão, o valor de Registro RestrictRemoteClients impedirá o acesso anônimo remoto a interfaces de RPC no sistema, com algumas exceções.

Quando uma interface é registrada usando RpcServerRegisterIf, o RPC permite que o aplicativo do servidor restrinja o acesso à interface, normalmente através de um retorno de chamada de segurança. O valor de Registro RestrictRemoteClients habilita o RPC a realizar verificações de segurança adicionais em todas as interfaces, mesmo que a interface não tenha um retorno de chamada de segurança registrado.

Observação:
Clientes de RPC que usam a seqüência de protocolo canalizada nomeada ficam isentos de todas as restrições. A seqüência de protocolo canalizada não pode ser restrita por causa de problemas significativos de compatibilidade de retorno de chamada.
Observação:
Você pode também configurar a chave de Registro the RestrictRemoteClients usando o Editor de Objetos de Diretiva de Grupos.

A chave de Registro RestrictRemoteClients é configurada usando valores DWORD. Se o valor de Registro não estiver presente, o valor ausente é equivalente ao valor de RPC_Restrict_Remote_Client_Default.

A tabela a seguir fornece informações sobre as definições de configuração de RestrictRemoteClients.

Valor de Chave de Registro (DWORD) Descrição

0 (Padrão)

RPC_RESTRICT_REMOTE_CLIENT_NONE (0) representa o valor padrão no Microsoft Windows Server™ 2003 Service Pack 1. A definição do valor padrão faz com que o sistema ignore a restrição de interface de RPC.

A configuração do valor padrão corresponde ao valor de RPC_RESTRICT_REMOTE_CLIENT_NONE. O aplicativo do servidor é responsável pela imposição das restrições de RPC apropriadas. Essa definição padrão é equivalente à definição de RestrictRemoteClients em versões anteriores do Windows.

1

Um valor de 1 na chave de Registro RestrictRemoteClients representa o valor padrão no Microsoft Windows® XP Service Pack 2. A definição do valor de 1 restringe o acesso a todas as interfaces de RPC. Todas as chamadas anônimas remotas são rejeitadas pelo tempo de execução de RPC.

Essa configuração de valor corresponde ao valor de RPC_RESTRICT_REMOTE_CLIENT_DEFAULT. Se uma interface registrar um retorno de chamada de segurança e fornecer o sinalizador RPC_IF_ALLOW_CALLBACKS_WITH_NO_AUTH, essa restrição não se aplicará àquela interface.

2

Um valor de 2 na chave de Registro RestrictRemoteClients indica que todas as chamadas anônimas remotas são rejeitadas pelo tempo de execução de RPC, sem exceção.

Essa configuração de valor corresponde ao valor de RPC_RESTRICT_REMOTE_CLIENT_HIGH. Quando o valor RestrictRemoteClients estiver configurado como 2, um sistema não pode receber chamadas anônimas remotas usando RPC.

Para obter mais informações sobre alterações no serviço de RPC com o Windows XP Service Pack 2, consulte "Restrições de Interface RPC" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47371).


O servidor de destino RFR foi substituído manualmente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro no servidor Exchange para determinar se o serviço Referência Proxy de Serviços de Diretório ( referência de DSProxy) foi substituído manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\RFR Target Server

Se o Analisador do Exchange Server detectar que o Servidor de Destino RFR está presente e configurado, uma mensagem de configuração não padrão será exibida.

Na primeira vez em que um cliente do Microsoft Outlook® 2000 Service Release 2 (SR-2) ou posterior se conectar a um computador do Exchange 2000 Server ou do Exchange Server 2003, ele procurará o serviço de diretório no servidor primário do Exchange. O Outlook inicialmente passa pelo processo do DSProxy na primeira sessão. Depois que o cliente contata o serviço DSProxy, uma referência do DSProxy é passada de volta para o cliente informando-o que todas as futuras solicitações de diretório devem ir para o servidor de catálogo global. O Outlook define as informações de referência do DSProxy no perfil MAPI do Registro.

O mecanismo de referência DSProxy reduz a carga no servidor Exchange e reduz a latência para pesquisas de catálogos de endereços. Se um nome de servidor explícito for inserido no perfil, o Outlook deverá ser reiniciado, caso o servidor de catálogo global falhar. Se isto ocorrer, o servidor Exchange enviará uma nova referência ao Outlook.

Em algumas situações, é preferível codificar a entrada do Servidor de Destino RFR para especificar os servidores que devem ser usados para o serviço de referência de clientes MAPI. Por exemplo, uma semana antes da demoção de um servidor de catálogo global para um servidor membro, você deve codificar a entrada do Servidor de Destino RFR para um grupo definido de servidores de catálogos globais. Isso garante que o servidor de catálogo global que está sendo demovido não apareça mais como referência em perfis MAPI de clientes do Outlook. Para obter mais informações sobre esse uso específico da entrada de Registro do Servidor de Destino RFR, consulte o artigo 305065 na Base de Dados de Conhecimento da Microsoft, "XADM: Considerações relacionadas ao Exchange Server para rebaixar o servidor de catálogo global para um controlador de domínio" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para usar o valor de Registro do Servidor de Destino RFR

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Crie um novo valor REG_MULTISZ chamado Servidor de Destino RFR.

  4. Configure o valor do Servidor de Destino RFR com um nome de domínio totalmente qualificado para o servidor (ou servidores) que deseja especificar.

  5. Feche o editor do Registro e reinicie o serviço IMAP4 do Microsoft Exchange para que a alteração entre em vigor.

Para desabilitar uma configuração estática do servidor RFR, remova a entrada de nome de domínio totalmente qualificada do servidor que deseja remover. Se houver somente um servidor de destino RFR inserido, exclua o valor de Registro Servidor de Destino RFR.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como clientes do Outlook 2000 SR-2 e mais recentes interagem com o serviço de diretório do Active Directory®, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 302914, "XCCC: Como o Outlook 2000 acessa o Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914) (em inglês)

  • 256976, "XCLN: Como os clientes MAPI acessam o Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976) (em inglês)


O RegTrace está habilitado no momento
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar se o rastreamento de diagnóstico avançado foi habilitado no computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\MosTrace\CurrentVersion\DebugAsyncTrace\EnabledTraces

Se o Exchange Server Analyzer localizar a entrada de Registro EnabledTraces configurada com qualquer valor diferente de 0, um erro será exibido.

O rastreamento de diagnóstico avançado dos componentes de roteamento e transporte do Exchange Server pode ser realizado usando-se o utilitário Regtrace (Regtrace.exe). O Regtrace é uma ferramenta especialmente útil para realizar diagnósticos e solucionar problemas de notificações de falha na entrega. O utilitário Regtrace pode ser encontrado no CD do Exchange Server na pasta \Support\Utils\I386.

O arquivo de rastreamento está disponível no local especificado na guia Saída do utilitário Regtrace. O local padrão do arquivo é C:\Trace.atf. O arquivo de rastreamento é um arquivo binário codificado que contém informações no nível da depuração sobre os componentes de roteamento e transporte que estão sendo rastreados. Devido a isso, o Atendimento Microsoft exige que os clientes enviem os arquivos de rastreamento para análise interna.

A menos que você esteja solucionando um problema ativamente, a Microsoft alerta que a habilitação do Regtrace causa uma forte redução do desempenho do servidor e só deve ser usado por curtos períodos de tempo, sob orientação estrita do Atendimento Microsoft. Além do desempenho, o espaço em disco para o arquivo de rastreamento pode ser consumido em uma velocidade de 10 ou mais megabytes (MB) por minuto. Para resolver esse erro, se não estiver solucionando um problema, você poderá usar o Regtrace para desabilitar o rastreamento.

Para desabilitar o rastreamento de diagnóstico avançado com o Regtrace

  1. Copie Regtrace.exe do CD do Exchange Server para o computador do Exchange Server.

  2. Execute o Regtrace.exe no computador do Exchange Server. A interface de usuário de Regtrace será exibido.

  3. Na guia Rastreamentos, desmarque todas as caixas de seleção.

  4. Selecione a guia Saída e, em seguida, Sem Rastreamento.

  5. Clique em OK para salvar as alterações e fechar o utilitário Regtrace.
  • Para obter mais informações sobre a ferramenta Regtrace, consulte o artigo 238614 da Base de Dados de Conhecimento Microsoft, "XCON: Como configurar o Regtrace para Exchange 2000" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=238614).

  • Para obter mais informações sobre solução de problemas de mensagens em geral, consulte o artigo 281800 da Base de Dados de Conhecimento, "XCON: Solucionando problemas de falha de mensagens no Exchange 2000" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281800).


Rejection threshold not configured
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-07-30

A ferramenta Microsoft Exchange Analyzer consulta o serviço de diretório do Active Directory para saber o valor dos seguintes atributos em todos os objetos com a classe ContentFilterConfig

msExchAgentsFlags O valor do atributo msExchAgentsFlag indica o status do agente de Filtro de Conteúdo do Microsoft Exchange Server 2007 e a ação de rejeição de SCL (nível de confiança de spam). Quando o agente do Filtro de Conteúdo está habilitado no computador, o agente filtra todas as mensagens vindas através dos Conectores de recebimento do computador. A ação de Rejeição de SCL, quando habilitada, envia uma resposta de rejeição durante a transação de SMTP de todas as mensagens que excedam o limite de rejeição de SCL.

msExchMessageHygieneSCLRejectThreshold O valor do atributo msExchMessageHygieneSCLRejectThreshold indica o nível que está definido para a ação de Rejeição de SCL. Esse valor representa a classificação SCL que uma determinada mensagem deve exceder para que o agente do Filtro de Conteúdo rejeite a mensagem e envie uma notificação de falha na entrega ao remetente.

O Exchange Analyzer também executa o seguinte cmdlet do Shell de Gerenciamento do Exchange para consultar todas as funções de servidor de Transporte de Hub que tenham agentes anti-spam instalados.

Get-TransportServer | where { $_.AntispamAgentsEnabled -eq $True}

Caso o Exchange Analyzer descubra que todas as condições a seguir existem em um servidor, um aviso é exibido:

  • A Filtragem de Conteúdo está habilitada

  • A ação de Rejeição de SCL está habilitada

  • O limite de Rejeição de SCL está definido com o valor 9

  • O servidor tem os agentes anti-spam habilitados.

Esse aviso indica que, apesar da Filtragem de Conteúdo e da ação de Rejeição de SCL estarem habilitadas, o limite da ação de Rejeição de SCL está definido com o valor padrão 9. Isto pode causar rejeição de mensagens recebidas de usuários legítimos. A definição recomendada para o valor do limite da ação de Rejeição de SCL é 7.

Para solucionar este aviso, defina o valor do limite da ação de Rejeição de SCL como 7 usando a guia Anti-spam do Console de Gerenciamento do Exchange ou usando o cmdlet Set-ContentFilterConfig do Shell de Gerenciamento do Exchange.

Para configurar o limite da ação de Rejeição de SCL, siga as orientações do tópico "Como habilitar e configurar os limites do nível de confiança de spam" (http://go.microsoft.com/fwlink/?LinkId=96099) da documentação do produto do Exchange Server 2007.

Para obter mais informações

Para obter mais informações sobre como gerenciar os recursos anti-spam e antivírus do Exchange Server 2007, consulte "Gerenciando recursos anti-spam e antivírus" (http://go.microsoft.com/fwlink/?LinkId=96103) na documentação do produto do Exchange Server 2007.


Serviço de Atualização de Destinatário excluído
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-20

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchAddressListServiceLink para cada objeto do Serviço de Atualização de Destinatário no diretório. O atributo msExchAddressListServiceLink é um link do serviço de lista de endereços para o computador do Exchange Server no qual ele deve estar sendo executado. Se o Exchange Server Analyzer verificar que o valor do atributo msExchAddressListServiceLink está definido como DEL:, um erro será exibido.

Cada instância do Serviço de Atualização de Destinatário está associada a um computador do Exchange Server que executa o Serviço de Atualização de Destinatário. Se você receber esta mensagem, a instância do Serviço de Atualização de Destinatário estará associada a um computador do Exchange Server que não existe na organização do Exchange. O servidor pode ter sido descomissionado ou removido da topologia.

Para que essa instância do Serviço de Atualização de Destinatário seja executada, você deve associá-la a um servidor Exchange existente.

Para corrigir esse erro

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Em Destinatários, clique em Serviços de Atualização de Destinatário. No painel direito, clique com o botão direito na instância apropriada do Serviço de Atualização de Destinatário e clique em Propriedades.

  3. Na guia Geral, em Exchange Server, clique em Procurar e especifique um novo servidor para executar essa instância.

  4. Clique em OK e clique em OK novamente para que a alteração entre em vigor.

  5. Feche o Gerenciador do Sistema Exchange.

Para obter mais informações sobre o Serviço de Atualização de Destinatário, consulte o tópico e os artigos da Base de Dados de Conhecimento Microsoft a seguir:

  • "Gerenciando destinatários e diretivas de destinatários" no Guia de Administração do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?linkid=47617)

  • 328738, "XADM: Como o Serviço de Atualização de Destinatário aplica as diretivas de destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, "Como o Serviço de Atualização de Destinatário preenche as listas de endereços" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, "XADM: Como Verificar o Progresso do Serviço de Atualização de Destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, "XADM: Tarefas Executadas pelo Serviço de Atualização de Destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


Recipient Update Service is missing or is not configured
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-07-11

A ferramenta Microsoft Exchange Server Analyzer consulta o serviço de diretório do Active Directory para determinar o valor do atributo msExchAddressListServiceLinkpara cada objeto do Serviço de Atualização de Destinatário no diretório. O atributo msExchAddressListServiceLink é um link do serviço de lista de endereços para o computador do Exchange Server em que ele deve estar em execução. Se o Exchange Analyzer detectar que não há nenhum atributo msExchAddressListServiceLink para um objeto do Serviço de Atualização de Destinatário ou que o valor do atributo msExchAddressListServiceLink para o objeto não está preenchido, será exibido um erro.

Cada instância do Serviço de Atualização de Destinatário geralmente está associada a um computador do Exchange Server que executa o Serviço de Atualização de Destinatário. Se você receber essa mensagem, a instãncia do Serviço de Atualização de Destinatário não estará associada a nenhum computador do Exchange Server. Isso pode fazer com que as listas de endereços e os destinatários do Exchange não sejam atualizadas.

Para que essa instância do Serviço de Atualização de Destinatário seja executada, você deve associá-la a um servidor Exchange existente.

Para corrigir esse erro

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Em Destinatários, clique em Serviços de Atualização de Destinatário. No painel direito, clique com o botão direito na instância apropriada do Serviço de Atualização de Destinatário e clique em Propriedades.

  3. Na guia Geral, em Exchange Server, clique em Procurar e especifique um servidor para executar essa instância.

  4. Clique em OK e clique em OK novamente para que a alteração entre em vigor.

  5. Feche o Gerenciador do Sistema Exchange.

Para obter mais informações sobre o Serviço de Atualização de Destinatário, consulte o tópico e os artigos da Base de Dados de Conhecimento Microsoft a seguir:

  • "Managing Recipients and Recipient Policies in Exchange Server 2003" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617) (em inglês)

  • 328738, "Como o Serviço de Atualização de Destinatário aplica as diretivas de destinatário" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, "Como o Serviço de Atualização de Destinatário preenche as listas de endereços" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, "How to Check the Progress of the Exchange Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, "Tasks Performed by the Exchange Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


A ligação RPC não contém FQDN
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o valor ncacn_ip_tcp do atributo networkAddress contém um FQDN (Nome de Domínio Totalmente Qualificado). Se o Exchange Server Analyzer detectar que o atributo ncacn_ip_tcp não contém um ponto (.), ele exibirá um erro.

No Microsoft Office Outlook® Web Access para Exchange Server 2003, o servidor front-end examina o valor do atributo networkaddress quando ele tenta se conectar a um servidor back-end Exchange.

Observação:
O Outlook Web Access para Exchange 2000 Server não faz isso. O servidor front-end exige um valor de nome de domínio totalmente qualificado.

O servidor front-end verifica se há um ponto no valor retornado de networkaddress ncacn_ip_tcp. A solicitação de conexão da caixa de correio no servidor back-end específico falhará e o servidor front-end retornará uma mensagem de erro "HTTP 500 Erro Interno do Servidor" para o usuário se existirem as seguintes condições:

  • O valor ncacn_ip_tcp é apenas um nome de host ou um nome de sistema básico de entrada/saída de rede (NetBIOS).

  • O valor ncacn_ip_tcp não é um FQDN.

É necessário atualizar o valor ncacn_ip_tcp do objeto de servidor no Active Directory para garantir o funcionamento correto do Outlook Web Access para Exchange Server 2003. A saída do Analisador do Exchange Server fornece o nome do servidor afetado.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Observação:
Antes de atualizar o valor ncacn_ip_tcp, leia o restante deste artigo. Convém executar um procedimento adicional antes de reiniciar os serviços do Exchange Server.
Para atualizar o valor ncacn_ip_tcp no atributo networkAddress

  1. Inicie a ferramenta ADSI Edit nas ferramentas de suporte do Windows 2000 Server ou do Windows Server 2003.

  2. Expanda os seguintes nós:

    • Contêiner de Configuração

    • Configuração

    • Serviços

    • Microsoft Exchange

    • Nome_da_Organização

    • Grupos Administrativos

    • Nome_do_Grupo_Administrativo

    • Servidores

  3. Clique com o botão direito em Exchange_Server_Name e clique em Propriedades.

  4. Clique em networkaddress na lista Atributos e clique em Editar.

  5. Adicione um novo valor para ncacn_ip_tcp. Use o FQDN do servidor em vez do nome NetBIOS ou do host do servidor.

    A sintaxe para esse valor é ncacn_ip_tcp:FQDN. Por exemplo, se o seu servidor back-end Exchange possuir o nome de host EXCHANGE1 e o FQDN for EXCHANGE1.contoso.com, use o seguinte valor para ncacn_ip_tcp: ncacn_ip_tcp:EXCHANGE1.contoso.com.

  6. Remova o valor ncacn_ip_tcp original que contém o nome NetBIOS ou do host do servidor back-end selecionando o valor original e clicando em Remover. Clique em OK duas vezes para aplicar a alteração.

  7. Reinicie todos os serviços do Exchange Server no servidor.

  8. Se houver vários controladores de domínio, aguarde que a replicação ocorra antes de tentar fazer logon a partir do servidor front-end. Se o problema não for resolvido após a conclusão da replicação, reinicie o Serviço de Administração do IIS no servidor front-end.

Se você mantiver arquivos de host nos servidores back-end para correlacionar um endereço IP de servidor que tenha um nome abreviado, será necessário atualizar também o valor do Registro UpdateProtocols. Se um arquivo host for usado, o Exchange Server poderá alterar o valor ncacn_ip_tcp novamente quando o Atendedor do Sistema do Microsoft Exchange for reiniciado. Se o servidor back-end estiver agrupado, o Exchange Server poderá alterar o valor ncacn_ip_tcp novamente após failover.

Para reduzir o tempo de inatividade que pode ser causado pelo reinício dos serviços do Exchange Server, execute o seguinte procedimento antes de reiniciá-los, atualizando o valor ncacn_ip_tcp do atributo networkaddress, conforme descrito no procedimento anterior.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para modificar o valor do Registro UpdateProtocols para servidores back-end que usam arquivos de host

  1. Com um editor de Registro, configure o seguinte valor nos servidores back-end: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    Observação:
    Se o valor UpdateProtocols não estiver presente, você deverá criá-lo. Para fazer isso, siga essas etapas:
    1. Abra um editor de Registro e localize a seguinte subchave do Registro: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    2. Clique com o botão direito em Parâmetros, aponte para Novo e clique em Valor DWORD.

    3. Digite UpdateProtocols e pressione ENTER.

  2. Clique com o botão direito em UpdateProtocols, clique em Modificar, digite 0 no campo Dados do valor e clique em OK.

  3. Se a sua rede usar um arquivo Hosts no nó do cluster back-end, modifique a ordem de entrada de UpdateProtocols da seguinte forma:

    IPAddress para FQDN

    IPAddress para NetBIOS

    em vez de:

    IPAddress para NetBIOS

    IPAddress para FQDN

  4. Reinicie todos os serviços do Exchange Server no servidor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


A ligação RPC não corresponde ao nome resolvido DNS
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-21

A ferramenta Microsoft® Exchange Server Analyzer Tool procura no DNS (Domain Name System) os servidores DNS configurados para cada computador do Exchange Server. Essa conexão é estabelecida usando um processador de objeto personalizado que executa uma solicitação de resolução de nome e analisa os resultados. A ferramenta Exchange Server Analyzer consulta também o serviço de diretório do Active Directory® para saber se o valor de ncacn_ip_tcp do servidor no atributo networkAddress e o nome FQDN (Nome de Domínio Totalmente Qualificado) retornado após a resolução do DNS são diferentes. O atributo networkAddress existe em cada objeto do Exchange Server no Active Directory. Se o Exchange Server Analyzer detectar que o valor de ncacn_ip_tcp do servidor do Active Directory não coincide com o nome FQDN após a resolução do DNS, exibirá um aviso.

Essa situação ocorrerá se o FQDN do servidor for alterado após a instalação do Exchange. Tanto o Exchange Server quanto o Active Directory exigem configuração correta e integridade do DNS para operarem corretamente. Os problemas de registro e resolução de Serviços de Atribuição de Nomes de Domínio podem ter efeitos abrangentes na capacidade de enviar, receber e entregar mensagens do computador do Exchange Server. É possível evitar problemas se você coincidir os dois endereços, editando manualmente o atributo networkAddress no objeto do Exchange Server no Active Directory.

Você deve atualizar o valor de ncacn_ip_tcp no objeto do servidor no Active Directory, para garantir que o valor de ncacn_ip_tcp coincida com o FQDN DNS do servidor. A saída do Analisador do Exchange Server fornece o nome do servidor afetado.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003, do Exchange Server 2007, ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para atualizar o valor ncacn_ip_tcp no atributo networkAddress

  1. Inicie a ferramenta ADSI Edit nas Ferramentas de Suporte do Windows® 2000 ou nas Ferramentas de Suporte do Windows Server 2003.

  2. Expanda os seguintes nós:

    • Contêiner de Configuração

    • Configuração

    • Serviços

    • Microsoft Exchange

    • Nome_da_Organização

    • Grupos Administrativos

    • Nome_do_Grupo_Administrativo

    • Servidores

  3. Clique com o botão direito em Exchange_Server_Name e clique em Propriedades.

  4. Clique em networkaddress na lista Atributos e clique em Editar.

  5. Adicione um novo valor para ncacn_ip_tcp. Use o FQDN do servidor, em vez do valor atual.

    A sintaxe para esse valor é ncacn_ip_tcp:FQDN. Por exemplo, se o servidor Exchange possuir um nome de host EXCHANGE1 e o FQDN for EXCHANGE1.contoso.com, use o seguinte valor para ncacn_ip_tcp: ncacn_ip_tcp:EXCHANGE1.contoso.com.

  6. Remova o valor original de ncacn_ip_tcp, que contém o nome incorreto do servidor, selecionando o valor original e clicando em Remover. Clique em OK duas vezes para aplicar a alteração.

  7. Reinicie todos os serviços do Exchange Server no servidor.

Para obter mais informações sobre o uso do DNS com o Active Directory, consulte o artigo 323418 da Base de Dados de Conhecimento da Microsoft, "Como integrar o DNS com uma infra-estrutura DNS existente se o Active Directory estiver habilitado no Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418).


A ordem de ligação RPC não está correta
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar a ordem de ligação da RPC (chamada de procedimento remoto) em uso pelo computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

Se o Exchange Server Analyzer detectar que o valor para Rpc_Svr_Binding_Order não inicia com ncacn_ip_tcp, um erro será exibido.

A entrada de Registro Rpc_Svr_Binding_Order é criada quando você instala o Exchange Server em um computador. Essa entrada determina a seqüência de protocolo que é usada para comunicações RPC servidor a servidor.

Por padrão, a entrada Rpc_Svr_Binding_Order contém os seguintes dados de valor:

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

Observação:
Valores adicionais podem estar na cadeia de caracteres se outros protocolos também estiverem instalados no computador do Exchange Server.

Essa entrada especifica a ordem na qual o Exchange Server tenta os protocolos de comunicação de rede para comunicações RPC com outros servidores. Por exemplo, como o TCP/IP é especificado em primeiro lugar, o Exchange Server tenta se comunicar com outros servidores usando primeiramente o RPC sobre TCP/IP, antes de tentar o RPC sobre outros protocolos.

É recomendável que você não altere o valor padrão da ordem da ligação RPC. Se o valor padrão for alterado, talvez você tenha problemas durante a inicialização do servidor ou do serviço, ou com as comunicações servidor a servidor.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como Regedit.exe ou Regedt32.exe.

  2. Navegue para: HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. No painel direito, clique com o botão direito em Rpc_Svr_Binding_Order.

  4. Na caixa de diálogo Dados do valor, digite ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp.

  5. Clique em OK e feche o editor de Registro:

  6. Reinicie todos os serviços do Exchange Server ou reinicie o computador do Exchange Server para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a ordem de ligação de RPC, consulte o artigo 325930 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade causados pelas entradas de Registro do protocolo cliente RPC" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930).


A entrada do Registro Rpc_Binding_Order está presente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para verificar a presença de uma entrada de Registro de ordem de ligação de RPC (chamada de procedimento remoto) orientada para cliente no computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Binding_Order

Se o Analisador do Exchange Server detectar que o Rpc_Binding_Order está presente, um aviso será exibido.

Se o valor Rpc_Binding_Order estiver presente indicará que um ou mais dos programas a seguir estão instalados no computador:

  • Exchange Server versão 5.5

  • Microsoft Office Outlook® 2003

  • Cluster do Windows

  • A entrada RPC_Binding_Order determina a seqüência de protocolo que é usada quando as comunicações de RPC do Outlook são iniciadas. Essa entrada não é criada no Exchange Server 2003 ou no Exchange 2000 Server. Essa entrada só é criada no Exchange Server 5.5 e em versões anteriores do Exchange. Se o Exchange Server 5.5 ou o Microsoft Outlook foi instalado anteriormente neste computador e depois removido, você poderá remover manualmente essa entrada do Registro. Além disso, você deve remover o Outlook de todos os computadores que estão executando o Exchange Server, visto que é uma configuração que não tem suporte. Para obter mais informações sobre como executar o Exchange e o Outlook no mesmo computador, consulte o artigo 266418 da Base de Dados de Conhecimento da Microsoft, "A Microsoft não recomenda a instalação do Exchange Server e do Outlook no mesmo computador" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para remover a entrada do Registro Rpc_Binding_Order

  1. Abra um editor de Registro, como Regedit.exe ou Regedt32.exe.

  2. Navegue para: HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. Exclua o valor Rpc_Binding_Order.

  4. Feche o editor do Registro e reinicie os serviços do Exchange Server ou reinicie o computador do Exchange Server para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a entrada do Registro RPC_Binding_Order, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 325930, "Como solucionar problemas de conectividade que são causados pelas entradas do Registro de protocolo de cliente RPC" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930)

  • 326036, "XADM: Não é possível fazer logon no computador do Exchange 2000 Server com as credenciais corretas" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326036)


O valor de Registro Rpc_Svr_Binding_Order foi modificado de seu valor padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar a ordem de ligação da RPC (chamada de procedimento remoto) em uso pelo computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

Se o Exchange Server Analyzer verificar que o valor de Rpc_Svr_Binding_Order não estiver definido como ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp, um aviso será exibido.

A entrada de Registro Rpc_Svr_Binding_Order é criada quando você instala o Exchange Server em um computador. Essa entrada determina a seqüência de protocolo que é usada para comunicações RPC servidor a servidor.

Por padrão, a entrada Rpc_Svr_Binding_Order contém os seguintes dados de valor:

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

Observação:
Valores adicionais podem estar na cadeia de caracteres acima se outros protocolos também estiverem instalados no computador do Exchange Server.

Essa entrada especifica a ordem na qual o Exchange Server tenta os protocolos de comunicação de rede para comunicações RPC com outros servidores. Por exemplo, como o TCP/IP é especificado em primeiro lugar, o Exchange Server tenta se comunicar com outros servidores usando primeiramente o RPC sobre TCP/IP, antes de tentar o RPC sobre outros protocolos.

A Microsoft recomenda que você não altere o valor padrão da ordem da ligação RPC. Se o valor padrão for alterado, talvez você tenha problemas durante a inicialização do servidor ou do serviço, ou com as comunicações servidor a servidor.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como Regedit.exe ou Regedt32.exe.

  2. Navegue para: HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. No painel direito, clique com o botão direito em Rpc_Svr_Binding_Order.

  4. Na caixa de diálogo Dados do valor, digite ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp.

  5. Clique em OK e feche o editor de Registro:

  6. Reinicie todos os serviços do Exchange Server ou reinicialize o computador do Exchange Server para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a ordem de ligação de RPC, consulte o artigo 325930 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade causados pelas entradas de Registro do protocolo cliente RPC" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930).


Os tempos de resposta do servidor do Active Directory estão levando mais de 100 ms
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-03-16

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) WIN32_PingStatus no namespace root\cimv2 para obter o valor da chave ResponseTime. Se o Exchange Server Analyzer verificar que o valor da chave ResponseTime é maior que 100 milissegundos (ms), um erro será exibido.

A chave ResponseTime representa o tempo decorrido (em milissegundos) para resposta à solicitação de eco (ping) do protocolo ICMP. Os controladores de domínio usados pelo computador do Exchange Server devem ter sempre um tempo de resposta inferior ou igual a 10 ms. Se o tempo de resposta exceder 100 ms, isso poderia indicar problemas de desempenho ou de conectividade.

Para corrigir esse erro

  1. Verifique se o controlador de domínio em questão não está sobrecarregado. Use a ferramenta ADTest.exe para executar testes no controlador de domínio para verificar se o hardware pode manipular a carga antecipada.

  2. Consulte os logs de evento do servidor Exchange e do controlador de domínio para verificar se foram registrados em log eventos relacionados à rede que indiquem um ou mais problemas.

  3. Use os comandos DCDiag.exe e NetDiag.exe no controlador de domínio para verificar a integridade e a configuração correta.

  4. Por último, investigue o design do site do serviço de diretório do Active Directory®. Um site do Active Directory é considerado uma seção da rede, que possui alta largura de banda e baixa latência. Se a rede não estiver particionada de acordo com esta especificação, experimente particioná-las em mais sites do Active Directory.
Observação:
Quando a ferramenta Analisador executar a consulta do WMI para o teste de ping, os valores padrão do tamanho do pacote e de tempo limite serão substituídos. Em vez desses valores padrão, o Analisador usará um tamanho de pacote de ICMP de 4096 (no lugar dos 32 bytes padrão) e um valor de tempo limite de 2000 ms (no lugar dos 1000 ms padrão).

Siga estas etapas para emular manualmente o comportamento do ping do Analisador.

Para executar o teste de ping manualmente:

  • Execute o seguinte comando na janela da linha de comando do servidor Exchange:ping -L 4096 -N 6 <Active Server server name>Observação O comando inicia seis solicitações de ping de 4096 bytes cada.

Para obter mais informações sobre a ferramenta ADTest.exe, consulte o site Active Directory Performance Testing Tool (ADTest.exe) (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33758).

Para obter mais informações sobre a classe Win32_PingStatus do WMI, consulte o artigo do MSDN® "Win32_PingStatus" (http://go.microsoft.com/fwlink/?LinkId=33549).

Para obter mais informações sobre o design de site do Active Directory, consulte "Designing the Site Topology" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33551).


Os tempos de resposta do servidor do Active Directory estão levando mais de 10 ms
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-03-16

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) WIN32_PingStatus no namespace root\cimv2 para obter o valor da chave ResponseTime. Se o Exchange Server Analyzer descobrir que o valor da chave ResponseTime é maior que 10 milissegundos (ms), mas menor que 100 ms, um aviso será exibido.

A chave ResponseTime representa o tempo decorrido (em milissegundos) até que seja enviada uma resposta aos pacotes de solicitação de eco (ping) do protocolo ICMP enviados do Exchange Server para o controlador de domínio. Os controladores de domínio usados pelo computador do Exchange Server devem ter sempre um tempo de resposta inferior ou igual a 10 ms. Se o tempo de resposta exceder 10 ms, isso poderia indicar problemas de desempenho ou de conectividade.

Para corrigir esse aviso

  1. Verifique se o controlador de domínio em questão não está sobrecarregado. Use a ferramenta ADTest.exe para executar testes no controlador de domínio para verificar se o hardware pode manipular a carga antecipada.

  2. Consulte os logs de evento do servidor Exchange e do controlador de domínio para verificar se foram registrados em log eventos relacionados à rede que indiquem um ou mais problemas.

  3. Use os comandos DCDiag.exe e NetDiag.exe no controlador de domínio para verificar a integridade e a configuração correta.

  4. Por último, investigue o design do site do serviço de diretório do Active Directory®. Um site do Active Directory é considerado uma seção da rede, que possui alta largura de banda e baixa latência. Se a rede não estiver particionada de acordo com esta especificação, experimente particioná-las em mais sites do Active Directory.
Observação:
Quando a ferramenta Analisador executar a consulta do WMI para o teste de ping, os valores padrão do tamanho do pacote e de tempo limite serão substituídos. Em vez desses valores padrão, o Analisador usará um tamanho de pacote de ICMP de 4096 (no lugar dos 32 bytes padrão) e um valor de tempo limite de 2000 ms (no lugar dos 1000 ms padrão).

Siga estas etapas para emular manualmente o comportamento do ping do Analisador.

Para executar o teste de ping manualmente:

  • Execute o seguinte comando na janela da linha de comando do servidor Exchange:ping -L 4096 -N 6 <Active Server server name>Observação O comando inicia seis solicitações de ping de 4096 bytes cada.

Para obter mais informações sobre a ferramenta ADTest.exe, consulte o site Active Directory Performance Testing Tool (ADTest.exe) (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33758).

Para obter mais informações sobre a classe Win32_PingStatus do WMI, consulte o artigo do MSDN® "Win32_PingStatus" (http://go.microsoft.com/fwlink/?LinkId=33549).

Para obter mais informações sobre o design de site do Active Directory, consulte "Designing the Site Topology" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33551).


Os tempos de resposta para o servidor de catálogo global estão demorando mais de 100 ms
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-03-16

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) WIN32_PingStatus no namespace root\cimv2 para obter o valor da chave ResponseTime. Se o Exchange Server Analyzer perceber que o valor da chave ResponseTime é maior que 100 milissegundos (ms), será exibido um erro.

A chave ResponseTime representa o tempo decorrido (em milissegundos) para a resposta aos pacotes de solicitação de eco (ping) do ICMP, enviados do Exchange Server para o servidor de catálogo global. Os servidores de catálogo global usados por um computador do Exchange Server devem ter sempre um tempo de resposta inferior ou igual a 10 ms. Se o tempo de resposta for superior a 10 ms, poderão ocorrer problemas de desempenho ou de conectividade.

Para corrigir esse erro

  1. Certifique-se de que o servidor de catálogo global em questão não está sobrecarregado. Use a ferramenta ADTest.exe para testar o servidor de catálogo global, para saber se o hardware pode manipular a carga prevista.

  2. Examine os logs de eventos no servidor Exchange e no servidor de catálogo global para verificar se foram registrados em log eventos relacionados à rede que indiquem um ou mais problemas.

  3. Use os comandos DCDiag.exe e NetDiag.exe no servidor de catálogo global para confirmar a configuração e integridade corretas.

  4. Por último, investigue o design do site do serviço de diretório do Active Directory®. Um site do Active Directory é considerado uma seção da rede, que possui alta largura de banda e baixa latência. Se a rede não estiver particionada de acordo com esta especificação, experimente particioná-las em mais sites do Active Directory.
Observação:
Quando a ferramenta Analisador executar a consulta do WMI para o teste de ping, os valores padrão do tamanho do pacote e de tempo limite serão substituídos. Em vez desses valores padrão, o Analisador usará um tamanho de pacote de ICMP de 4096 (no lugar dos 32 bytes padrão) e um valor de tempo limite de 2000 ms (no lugar dos 1000 ms padrão).

Siga estas etapas para emular manualmente o comportamento do ping do Analisador.

Para executar o teste de ping manualmente:

  • Execute o seguinte comando na janela da linha de comando do servidor Exchange:ping -L 4096 -N 6 <Active Server server name>Observação O comando inicia seis solicitações de ping de 4096 bytes cada.

Para obter mais informações sobre a ferramenta ADTest.exe, consulte o site da "Ferramenta de teste de desempenho do Active Directory (ADTest.exe)" (http://go.microsoft.com/fwlink/?LinkId=33758).

Para obter mais informações sobre a classe Win32_PingStatus do WMI, consulte o artigo do MSDN®, "Win32_PingStatus" (http://go.microsoft.com/fwlink/?LinkId=33549).

Para obter mais informações sobre o design do site do Active Directory, consulte "Projetando a topologia do site" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=33551).

Para obter informações sobre como instalar as ferramentas de suporte do Windows 2000 Server, consulte o artigo 301423 da Base de Dados de Conhecimento Microsoft, "Como instalar as ferramentas de suporte do Windows 2000 em um computador baseado no Windows 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301423).

Para obter informações sobre como instalar as ferramentas de suporte do Windows Server 2003, consulte "Instalação das ferramentas de suporte do Windows" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=41362).


Os tempos de resposta para o servidor de catálogo global estão demorando mais de 10 ms
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-03-16

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) WIN32_PingStatus no namespace root\cimv2 para obter o valor da chave ResponseTime. Se o Exchange Server Analyzer detectar que o valor da chave ResponseTime é maior que 10 milissegundos (ms) mas menor que 100 ms, um aviso será exibido.

A chave ResponseTime representa o tempo decorrido (em milissegundos) para a resposta aos pacotes (ping) de solicitação echo do ICMP (Internet Control Message Protocol) enviados do servidor Exchange para o servidor de catálogo global. Os servidores de catálogo global usados por um computador Exchange Server devem sempre ter um tempo de resposta menor ou igual a 10 milissegundos. Se o tempo de resposta exceder a 10 milissegundos, pode haver problema de desempenho ou de conectividade.

Para corrigir esse aviso

  1. Certifique-se de que o servidor de catálogo global em questão não está sobrecarregado. Use a ferramenta ADTest.exe para testar o servidor de catálogo global, para saber se o hardware pode manipular a carga prevista.

  2. Verifique os logs de eventos do servidor Exchange e do servidor de catálogo global para verificar se foram registrados em log eventos relacionados à rede que indiquem um ou mais problemas.

  3. Use os comandos DCDiag.exe e NetDiag.exe no servidor de catálogo global para confirmar a configuração e integridade corretas.

  4. Por último, investigue o design do site do serviço de diretório do Active Directory®. Um site do Active Directory é considerado uma seção da rede, que possui alta largura de banda e baixa latência. Se a rede não estiver particionada de acordo com esta especificação, experimente particioná-las em mais sites do Active Directory.
Observação:
Quando a ferramenta Analisador executar a consulta do WMI para o teste de ping, os valores padrão do tamanho do pacote e de tempo limite serão substituídos. Em vez desses valores padrão, o Analisador usará um tamanho de pacote de ICMP de 4096 (no lugar dos 32 bytes padrão) e um valor de tempo limite de 2000 ms (no lugar dos 1000 ms padrão).

Siga estas etapas para emular manualmente o comportamento do ping do Analisador.

Para executar o teste de ping manualmente:

  • Execute o seguinte comando na janela de linha de comando do servidor Exchange:

    ping -L 4096 -N 6 <Active Server server name>

    Observação:
    O comando inicia seis solicitações de ping de 4.096 bytes cada.

Para obter mais informações sobre a ferramenta ADTest.exe, consulte o site da "Ferramenta de teste de desempenho do Active Directory (ADTest.exe)" (http://go.microsoft.com/fwlink/?LinkId=33758).

Para obter mais informações sobre a classe Win32_PingStatus do WMI, consulte o artigo do MSDN® "Win32_PingStatus" (http://go.microsoft.com/fwlink/?linkId=33549).

Para obter mais informações sobre o design do site do Active Directory, consulte "Projetando a Topologia do Site" em http://go.microsoft.com/fwlink/? linkid=33551.


A alteração do filtro de pesquisa é necessária para Diretiva de Destinatário
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-21

A ferramenta Analisador do Microsoft® Exchange consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo purportedSearch de cada objeto de diretiva de destinatário do Exchange. O atributo purportedSearch indica o argumento de pesquisa que é usado quando a diretiva é aplicada.

O Analisador do Exchange Server também consulta o Active Directory para determinar o valor do atributo msDS-Behavior-Version do objeto de floresta no Active Directory, Configurações NTDS. Esse valor indica o nível funcional de floresta do Active Directory. Os valores válidos para o atributo msDS-Behavior-Version são mostrados na tabela a seguir.

Valor | Nível funcional de floresta
0 | Misto do Microsoft Windows® 2000 Server
1 | Provisório do Microsoft Windows Server™ 2003
2 | Windows Server 2003 nativo

O Analisador do Exchange Server também consulta o Active Directory para determinar o valor para o atributo revision do contêiner Windows2003Update. O valor desse atributo indica se a ferramenta de preparação do Active Directory (ADPrep.exe) foi executada.

Finalmente, o Analisador do Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Windows) Win32_OperatingSystem para determinar o valor da chave OSProductSuite. O valor da chave OSProductSuite indica a versão do Windows que está sendo executada no computador.

Se o Exchange Server Analyzer detectar que os seguintes critérios são verdadeiros, o Exchange Server Analyzer exibirá um aviso:

  • O valor do atributo purportedSearch da diretiva de destinatário contém homeMdb.

  • O nível funcional de floresta do Active Directory é o modo provisório ou nativo do Windows Server 2003.

  • O computador do Exchange Server não está executando o Microsoft Windows Small Business Server 2003.

Esse aviso indica que a floresta do Active Directory foi preparada para o Windows Server 2003. Para evitar problemas de carimbo do endereço de email quando a floresta for atualizada para o nível de funcionalidade completa do Windows Server 2003, é necessária uma modificação nas diretivas de destinatário. A diretiva de destinatário afetada é especificada na saída do Analisador do Exchange Server.

Se o Windows Server 2003 for usado como um controlador de domínio e a diretiva de destinatário não estiver atualizada, a replicação dos valores vinculados no Windows Server 2003 fará com que o Serviço de Atualização de Destinatário grave incorretamente os endereços de email dos novos usuários. O Serviço de Atualização de Destinatário detectará o usuário pela primeira vez provavelmente entre o momento da replicação do mailnickname e o momento da replicação do homeMDB, devido à replicação dos valores vinculados. Portanto, o usuário se enquadraria nesse momento na diretiva padrão, e não na diretiva com base no homeMDB. Alguns minutos depois, quando o homeMDB for replicado, o usuário seria enquadrado na diretiva do homeMDB. Entretanto, o usuário já teria os endereços que correspondem à diretiva padrão.

Para corrigir esse aviso

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Destinatários, selecione Diretivas de Destinatários, clique com o botão direito em RecipientPolicyName e clique em Propriedades.

  3. Na página Propriedades do RecipientPolicyName , na guia Geral, em Regras de filtro , clique em Modificar.

  4. No menu Localizar Destinatários do Exchange , selecione Pesquisa Personalizada. Se a diretiva de destinatário foi criada originalmente por uma pesquisa personalizada, a página Procurar Pesquisa Personalizada será exibida depois que você clicar em Modificar na etapa 3.

  5. Altere a consulta do LDAP para que o atributo homeMdb não seja usado como parte da condição do filtro. Atributos como extensionAttribute, msExchHomeServerName ou UPN são argumentos válidos que podem ajudá-lo a conseguir o mesmo resultado de pesquisa.

  6. Clique em OK para salvar a alteração e feche o Gerenciador do Sistema do Exchange.


Alteração do filtro de pesquisa exigida para Diretiva de Destinatário
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo purportedSearch de cada objeto de diretiva de destinatário do Exchange. O atributo purportedSearch indica o argumento de pesquisa que é usado quando a diretiva é aplicada.

O Analisador do Exchange Server também consulta o Active Directory para determinar o valor do atributo msDS-Behavior-Version do objeto de floresta no Active Directory, Configurações NTDS. Esse valor indica o nível funcional de floresta do Active Directory. Os valores válidos para o atributo msDS-Behavior-Version são mostrados na tabela a seguir.

Valor | Nível funcional de floresta
0 | Windows® 2000 Server misto
1 | Windows Server™ 2003 provisório
2 | Windows Server 2003 nativo

O Analisador do Exchange Server também consulta o Active Directory para determinar o valor para o atributo revision do contêiner Windows2003Update. O valor desse atributo indica se a ferramenta de preparação do Active Directory (ADPrep.exe) foi executada.

Finalmente, o Analisador do Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Windows) Win32_OperatingSystem para determinar o valor da chave OSProductSuite. O valor da chave OSProductSuite indica a versão do Windows que está sendo executada no computador.

Se o Exchange Server Analyzer detectar que os seguintes critérios são verdadeiros, um aviso será exibido:

  • O valor do atributo purportedSearch da diretiva de destinatário contém (homeMdb=).

  • O nível funcional da floresta do Active Directory é Windows 2000 Server misto.

  • A floresta do Active Directory foi preparada para controladores de domínio do Windows Server 2003.

  • O computador do Exchange Server não está executando o Microsoft Windows Small Business Server 2003.

Esse aviso indica que a floresta do Active Directory foi preparada para o Windows Server 2003. Para evitar problemas de carimbo de endereço de email quando a floresta do Active Directory for atualizada para o nível funcional completo do Windows Server 2003, será necessário modificar as diretivas de destinatário. A diretiva de destinatário afetada é especificada na saída do Analisador do Exchange Server.

Se você usar o Windows Server 2003 como um controlador de domínio e não atualizar a diretiva de destinatário, a replicação de valor vinculado no Windows Server 2003 fará com que o Serviço de Atualização de Destinatário grave incorretamente endereços de email de novos usuários.

Devido à replicação de valores vinculados, o Serviço de Atualização de Destinatário pode detectar um novo usuário pela primeira vez entre o momento em que o mailnickname se replica e o momento em que o homeMdb se replica. Assim, o usuário ficaria sob a diretiva padrão desta vez, em vez de sob a diretiva baseada em homeMdb. Alguns minutos depois, quando o homeMdb se replicar, o usuário ficará sob a diretiva homeMdb. Entretanto, o usuário já teria os endereços que correspondem à diretiva padrão.

Para corrigir esse aviso

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Destinatários, selecione Diretivas de Destinatários, clique com o botão direito em RecipientPolicyName e clique em Propriedades.

  3. Na página Propriedades do RecipientPolicyName , na guia Geral, em Regras de filtro , clique em Modificar.

  4. No menu Localizar Destinatários do Exchange , selecione Pesquisa Personalizada. Se a diretiva de destinatário tiver sido criada originalmente por uma pesquisa personalizada, a página Localizar Pesquisa Personalizada será exibida quando você clicar em Modificar na Etapa 3.

  5. Altere a consulta do LDAP para que o atributo homeMdb não seja usado como parte da condição do filtro. Atributos como extensionAttribute, msExchHomeServerName ou UPN são argumentos válidos que podem ajudá-lo a conseguir o mesmo resultado de pesquisa.

  6. Clique em OK duas vezes para salvar a alteração e feche o Gerenciador do Sistema do Exchange.


ID do Remetente não configurada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-05-10

A ferramenta Microsoft Exchange Best Practices Analyzer Tool utiliza o cmdlet a seguir do Shell de Gerenciamento do Exchange para consultar os valores das propriedades Enabled e ExternalMailEnabled do objeto SenderIdConfig de quaisquer funções de servidor Transporte de Hub ou Transporte de Borda do Exchange Server 2007 de destino.

Código da Cópia
- get-SenderIdConfig

O valor da propriedade Enabled especifica se o agente ID do Remetente está habilitado. As entradas válidas para o parâmetro Enabled são $true ou $false. A configuração padrão é $true. Quando o parâmetro Enabled está definido como $true, o agente ID do Remetente está habilitado.

O valor da propriedade ExternalMailEnabled especifica se as mensagens de conexões não autenticadas serão passadas ao agente ID do Remetente para serem processadas. As entradas válidas para o parâmetro ExternalMailEnabled são $true ou $false. A configuração padrão é $true. Quando o parâmetro ExternalMailEnabled é definido como $true, todas as mensagens de conexões não autenticadas são passadas para o agente ID do Remetente para serem processadas.

Se determinar que os valores das propriedades Enabled ou ExternalMailEnabled do objeto SenderIdConfig não serão definidos como $true, a ferramenta Exchange Best Practices Analyzer Tool exibirá uma mensagem de práticas recomendadas.

Essa mensagem indica que a ID do Remetente não está habilitada nas funções de servidor Transporte de Hub ou Transporte de Borda do Exchange 2007 de destino.

A ID do Remetente verifica se as mensagens de email são originadas no domínio da Internet do qual afirmam ser enviadas.

Quando a ID de Remetente está habilitada em um computador, ela filtra todas as mensagens recebidas através dos Conectores de Recebimento nesse computador. Somente mensagens provenientes de fontes externas são filtradas. Fontes externas são definidas como fontes não autenticadas. Essas fontes são consideradas fontes anônimas da Internet.

Para resolver esse problema, habilite a ID do Remetente nas funções de servidor Transporte de Hub ou Transporte de Borda do Exchange 2007 de destino.

Para usar o Shell de Gerenciamento do Exchange para habilitar a funcionalidade ID do Remetente

  • Para habilitar a filtragem por remetente, execute o seguinte comando:

    Código da Cópia
    Set-SenderIdConfig -Enabled $true -ExternalMailEnabled $true

Para obter mais informações sobre ID de Remetente, consulte os seguintes tópicos:

  • Página inicial da ID do Remetente (em inglês) (http://go.microsoft.com/fwlink/?linkid=50977)

  • ID do Remetente do Exchange 2007 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=89719)

  • Configurando a ID do Remetente (em inglês) (http://go.microsoft.com/fwlink/?LinkId=89720)


Incompatibilidade de maiúsculas e minúsculas no nome de servidor
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor armazenado no Active Directory para o nome do servidor do Exchange (CN=<ExchangeServerName>). Depois de recuperar esse nome, o Exchange Server Analyzer conta o número de caracteres contidos no nome.

O Exchange Server Analyzer também lê a seguinte entrada do Registro para determinar o valor armazenado no Registro do computador do Exchange Server para o nome de host do servidor Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

O Exchange Server Analyzer consulta também a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar o valor da chave Started de ClusSvc, o serviço Cluster do Windows®.

O Exchange Server Analyzer exibirá uma mensagem de configuração não padrão, se todas as seguintes condições forem verdadeiras:

  • O valor de CN=<ExchangeServerName> não corresponder ao tamanho de letra do valor contido em Hostname. Por exemplo, CN=ComputerName e Hostname está definido como COMPUTERNAME.

    Observação:
    Embora seja aceita a alteração do tamanho de letra no nome do servidor no Registro, essa ação não é recomendada.
  • O nome do servidor Exchange contém 15 caracteres ou menos.

  • O servidor Exchange não está sendo executado em um cluster do Windows.

A causa mais comum desse erro é que o nome do servidor Exchange foi alterado manualmente no Registro.


Incompatibilidade de nome de servidor
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar a configuração do valor de This Server:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor do atributo name para cada objeto do servidor Exchange.

Por fim, o Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Iniciado para o serviço de Cluster (ClusSvc). Um valor TRUE indica que o serviço de Cluster está iniciado e um valor FALSE indica que esse serviço não está em execução.

Se o Exchange Server Analyzer verificar que o valor para a chave This Server não corresponde ao valor do atributo name do objeto do servidor no Active Directory de qualquer computador do Exchange Server que não esteja sendo executado em um cluster de servidor, será exibido um erro.

Para corrigir esse erro, edite a chave de Registro This Server para que corresponda ao valor do atributo name no Active Directory.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. No painel da direita, clique duas vezes em Este Servidor, insira o nome correto para esse computador e clique em OK.

  4. Feche o editor do Registro e reinicie o computador do Exchange Server para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Nome do servidor longo muito
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-02-22

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o nome (cn) de cada objeto de diretório com uma classe de objeto de msExchExchangeServer. O valor cn é uma cadeia de caracteres que contém o nome curto do computador do Exchange Server. O Exchange Server Analyzer recupera o cn e determina o comprimento da cadeia de caracteres. O comprimento da cadeia de caracteres é o número de caracteres no nome de servidor Exchange. Se o Exchange Server Analyzer determinar que um nome de servidor Exchange excede a 15 caracteres, um erro será exibido.

O Exchange Server 2007, o Exchange Server 2003 e o Exchange 2000 Server têm várias dependências de NetBIOS que podem exigir o uso da resolução de nome NetBIOS por diferentes sub-redes para a operação bem-sucedida de todos os componentes do Exchange, dependendo da topologia da rede. A convenção de nomenclatura do NetBIOS permite 16 caracteres em um nome NetBIOS. A Microsoft, entretanto, limita os nomes NetBIOS a 15 caracteres e usa o 16º caractere como um sufixo NetBIOS.

Como o Exchange Server tem dependências do NetBIOS e os nomes NetBIOS não podem exceder a 15 caracteres, os nomes de servidores que excedem a 15 caracteres não têm suporte em uma organização do Exchange. Além disso, devido aos efeitos abrangentes que a renomeação de um computador do Exchange Server pode causar em todo Active Directory e na organização do Exchange, não há suporte para renomeação de um computador do Exchange Server.

Para corrigir esse erro

  1. Remova o computador do Exchange Server nomeado incorretamente com a opção Remover.

  2. Renomeie o computador com um nome que tenha 15 caracteres ou menos.

  3. Reinstale o Exchange Server no computador.

Para obter informações sobre como remover o Exchange Server 2007, consulte "Como remover completamente o Exchange 2007 de um servidor" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=79246) na documentação de Implantação do Microsoft Exchange Server 2007.

Para obter informações sobre como remover o Exchange Server 2003, consulte "Como desinstalar o Exchange Server 2003," no Guia de Implantação do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Para obter mais informações, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 833396, "Como remover manualmente o Exchange Server 2003 do seu computador" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396)

  • 260378, "Como remover manualmente uma instalação do Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260378)

  • 328810, "Movendo caixas de correio entre servidores" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)

  • 821829, "Movendo caixas de correio no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829) (em inglês)


O endereço de rede RPC do servidor não corresponde ao nome do servidor Exchange
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo networkAddress de cada objeto do Exchange Server no diretório. Há normalmente várias entradas listadas para esse atributo com várias cadeias de caracteres, conforme ilustrado nos seguintes exemplos:

ncacn_ip_tcp :<nome de domínio totalmente qualificado do Exchange Server>

ncacn_np: <nome de host do Exchange Server>

ncacn_spx: <nome de host do Exchange Server>

ncacn_vns_spp: <nome de host do Exchange Server>

ncalrpc: <nome de host do Exchange Server>

netbios: <nome de host do Exchange Server>

O Exchange Server Analyzer consulta também o Active Directory para determinar o valor do atributo nome de cada objeto do Exchange Server.

Se o Exchange Server Analyzer detectar que o valor do atributo nome não corresponde à parte do nome de qualquer das cadeias de caracteres encontradas no atributo networkAddress, será exibido um erro.

Esse erro poderá ocorrer se um administrador tiver alterado manualmente o valor cn do objeto do servidor. O atributo networkAddress é criado e mantido pelo Exchange Server e contém valores com várias cadeias de caracteres para oferecer suporte a diferentes protocolos de comunicação de rede aceitos pelo Exchange Server. Cada valor associa um protocolo com a forma apropriada do nome do servidor, conforme exigido pelo protocolo particular.

Para corrigir esse erro, verifique se o nome do servidor foi alterado ou se o valor é inválido e, então, tome as medidas apropriadas:

  • Se o nome do servidor foi alterado, use o procedimento descrito mais adiante neste artigo para corrigir os valores de forma apropriada.

  • Se os valores forem inválidos por alguma outra razão, execute novamente a Instalação do Exchange no servidor.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Modifique os atributos do objeto do Active Directory a seu próprio risco.

Para corrigir esse erro

  1. No ADSI Edit ou em uma ferramenta semelhante, localize o objeto grupo administrativo no Active Directory.

    É possível encontrar o atributo networkAddress em:

    CN=Configuração, CN=Serviços, CN=Microsoft Exchange, CN= OrganizationName , CN=Grupos Administrativos, CN= Nome do Grupo Administrativo , CN=Servidores, CN= Nome do Servidor

  2. Observe o formato de cada um dos valores da lista. Atualize os valores conforme for necessário, alterando somente a parte do nome do servidor de cada valor.

    Observação:
    Verifique se para o valor de ncacn_ip_tcp, o nome do servidor tem a forma de um nome de domínio totalmente qualificado, não um nome NetBIOS ou um endereço de Protocolo de Internet.

  3. Feche o editor do Active Directory e, então, reinicie o serviço de Mecanismo de Roteamento do Exchange.

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre problemas de roteamento do Exchange, consulte "Roteamento de solução de problemas" no Guia de Transporte e Roteamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47579).


Nome da Entidade de Serviço ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-08-14

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para localizar os valores retornados para o atributo servicePrincipalName das contas do computador do servidor Exchange para os recursos do Exchange listados na tabela abaixo.

Valor servicePrincipalName de recursos do Exchange | Valor Retornado Esperado
exchangeMDB | Nome de Domínio Totalmente Qualificado (FQDN)
exchangeMDB | Nome do NetBIOS
exchangeRFR | Nome de Domínio Totalmente Qualificado (FQDN)
exchangeRFR | Nome do NetBIOS
SMTP | Nome de Domínio Totalmente Qualificado (FQDN)
SMTP | Nome do NetBIOS
SMTPSVC | Nome de Domínio Totalmente Qualificado (FQDN)
SMTPSVC | Nome do NetBIOS
HOST | Nome de Domínio Totalmente Qualificado (FQDN)
HOST | Nome do NetBIOS

Se o Exchange Server Analyzer verificar que o atributo servicePrincipalName para a conta do computador de um recurso do Exchange não tem um dos valores esperados listados aqui, o Exchange Server Analyzer exibirá um erro.

Um SPN (Nome da Entidade de Serviço) é um nome exclusivo que identifica uma instância de um serviço e está associado à conta de logon na qual a instância do serviço é executada. A autenticação Kerberos não é possível para os serviços do Exchange sem uma definição correta dos SPNs.

  • Os problemas de autenticação entre clientes que executam o Microsoft Office Outlook® 2003 ou posterior e o Armazenamento de Informações do Exchange (dados de caixa de correio) podem indicar a falta de um SPN válido para o recurso exchangeMDB.

  • Os clientes Outlook 2003 ou posteriores que têm problemas de autenticação no Active Directory podem indicar a falta de um SPN válido para o recurso exchangeRFR.

  • As falhas de autenticação entre os servidores virtuais SMTP podem indicar a falta de um SPN válido para o recurso SMTPSVC ou HOST.

Para resolver esse problema, siga essas etapas para adicionar os valores ausentes dos atributos afetados.

Use a ferramenta SETSPN.exe para adicionar um SPN com os valores ausentes

  1. Instale a ferramenta Setspn.exe. Para obter a ferramenta Setspn.exe, consulte "Windows 2000 Resource Kit Tool: Setspn.exe" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=28103).

    A versão do Windows Server 2003 da ferramenta de linha de comando Setspn.exe está disponível nas Ferramentas de Suporte do Windows Server 2003, incluídas no CD do Windows Server 2003. Para instalar as Ferramentas de Suporte do Server 2003, clique duas vezes no arquivo Suptools.msi na pasta Support/Tools.

  2. Siga as orientações no arquivo SETSPN.EXE Setspn_d.txt para adicionar o valor ausente ao objeto do Active Directory em seu servidor Exchange. O exemplo a seguir demonstra como adicionar o valor FQDN a um SPN do servidor virtual SMTP:

    • Inicie um prompt de comando e vá para o diretório em que você instalou o Setspn.exe.

    • No prompt de comando, digite o seguinte:

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      Observação:
      Substitua mail.yourdomain.com pelo FQDN de seu servidor virtual SMTP e YOURSERVERNAME pelo nome do servidor Exchange.
      Em seguida, pressione Enter.


Um serviço foi encerrado inesperadamente nas últimas 24 horas
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-02-14

A ferramenta Microsoft Exchange Analyzer consulta a classe Win32_NTLogEvent de WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar se um aviso de Evento 7031 foi registrado para a origem do Gerenciador de Controle de Serviços nas últimas 24 horas.

Um aviso de Evento 7031 significa que o serviço especificado não pôde continuar. O serviço está configurado para relatar o número de falhas e, após um número específico de falhas ser relatado, o Gerenciador de Controle de Serviços executará a ação de recuperação configurada para o serviço especificado.

Se o Exchange Analyzer detectar que um ou mais desses eventos foram registrados nas últimas 24 horas, ele exibirá uma mensagem informativa.

Esse problema pode ser causado por vários outros, entre eles, sem limitação, os seguintes problemas mais comuns:

  • Uma mensagem danificada em processamento.

  • Problemas de configuração de aplicativo antivírus.

Para resolver esse problema:

  • Siga a orientação do artigo 286350 da Base de Dados de Conhecimento Microsoft, "Como usar o ADPlus para solucionar problemas de suspensão ou falha" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286350) (página em inglês), para isolar a causa de um processo que passa a não responder (suspenso) ou pára inesperadamente (falha).

  • Obtenha o service pack mais recente para o Microsoft Windows 2000.

  • Obtenha o service pack mais recente para o Microsoft Exchange Server.

  • Entre em contato com o fornecedor do aplicativo antivírus para obter as atualizações mais recentes e informações de configuração.

Para obter mais informações

Para obter mais informações sobre detalhes do aviso de Evento 7031, consulte o "Centro de mensagens de eventos e erros: detalhes do evento" (http://go.microsoft.com/fwlink/?LinkId=83114) (página em inglês)

Para obter mais informações sobre como obter o service pack mais recente do Windows 2000 Server, consulte o artigo 260910 da Base de Dados de Conhecimento Microsoft, "Como obter o service pack mais recente do Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260910) (página em inglês)

Para obter mais informações sobre como obter o service pack mais recente do Exchange 2000 Server, consulte o artigo 301378 da Base de Dados de Conhecimento Microsoft, "Como obter o service pack mais recente do Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378). (página em inglês)

Para obter mais informações sobre como obter o service pack mais recente do Exchange Server 2003, consulte "Por que testar o Service Pack 2 do Exchange Server 2003?" (http://go.microsoft.com/fwlink/?LinkId=52073) (em inglês)

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 328841, "Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841) (página em inglês)

  • 823166, "Visão geral do Exchange Server 2003 e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166) (página em inglês)

  • 306105, "XGEN: posição da Microsoft sobre soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105) (página em inglês)

  • 245822, "Recomendações para solucionar problemas em um computador do Exchange Server com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822) (página em inglês)

Para obter uma lista de softwares antivírus de terceiros disponíveis para o Exchange Server, consulte os Parceiros do Exchange Server: Site do antivírus (http://go.microsoft.com/fwlink/?linkid=16226) (página em inglês).


Services Value is Missing or Inaccessible
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-07-24

A ferramenta Microsoft Exchange Analyzer lê a seguinte entrada de Registro para verificar a existência do valor de tipo de cadeia de caracteres Serviços:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Setup

Se o Exchange Analyzer detectar que o valor do tipo de cadeia de caracteres Serviços está ausente ou inacessível, ele exibirá um erro.

Esse erro indica que o valor do tipo de cadeia de caracteres Serviços, usado para manter o caminho para a raiz da instalação do Exchange, está ausente ou inacessível. A ausência do caminho para a raiz da instalação do Exchange pode causar uma falha na inicialização dos drivers e protocolos críticos que, por sua vez, fará com que os serviços dependentes e de armazenamento de informações do Exchange falhem na inicialização.

Para resolver esse erro, siga as orientações do artigo 285116 da Base de Dados de Conhecimento Microsoft, "Exchange Store Does Not Start: Errors 7024, 1026, 9542, and 5000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285116).


Encontrada uma única réplica de disponibilidade
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-12-15

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Exchange_PublicFolder do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) no namespace root\MicrosoftExchangeV2 para determinar o número de réplicas de disponibilidade presentes em cada grupo administrativo.

Se o Exchange Server Analyzer verificar que existe uma única réplica de disponibilidade em um grupo administrativo, ele exibirá uma mensagem de prática recomendada.

Geralmente é recomendado que exista mais de uma réplica da pasta de disponibilidade em cada grupo administrativo. Em algumas situações, várias réplicas de disponibilidade podem aumentar o desempenho e a resiliência. Em organizações grandes do Exchange, uma única réplica dos dados de disponibilidade pode ficar sobrecarregada. Em todas as organizações do Exchange, uma única réplica dos dados de disponibilidade é um ponto de falha único.

É recomendável que sejam usadas várias réplicas independentemente das considerações a seguir:

  • Várias réplicas causam tráfego de replicação adicional na rede.

  • O risco de conflitos de agendamento aumenta com várias réplicas.

Deve haver, no mínimo, uma réplica para cada 10.000 caixas de correio.

Para obter mais informações sobre pastas de disponibilidade e publicação de informações de disponibilidade, consulte "Working with Exchange Server 2003 Stores" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).


Encontrada uma única réplica de disponibilidade para um grande número de caixas de correio
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-12-15

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Exchange_PublicFolder de WMI (Instrumentação de Gerenciamento do Microsoft Windows®) no namespace root\MicrosoftExchangeV2 para determinar o número de entradas na chave ReplicaList. O número de entradas representa o número de réplicas de disponibilidade presentes em cada grupo administrativo.

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar a contagem das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Se o Exchange Server Analyzer verificar que existe apenas uma réplica de disponibilidade em um grupo administrativo que contém mais de 10.000 caixas de correio, será exibido um erro.

Geralmente é recomendado que exista mais de uma réplica da pasta de disponibilidade em cada grupo administrativo. Em algumas situações, várias réplicas de disponibilidade podem aumentar o desempenho e a resiliência. Em organizações grandes do Exchange, uma única réplica dos dados de disponibilidade pode ficar sobrecarregada. Em todas as organizações do Exchange, uma única réplica dos dados de disponibilidade é um ponto de falha único.

É recomendável que sejam usadas várias réplicas independentemente das considerações a seguir:

  • Várias réplicas causam tráfego de replicação adicional na rede.

  • O risco de conflitos de agendamento aumenta com várias réplicas.

Deve haver, no mínimo, uma réplica para cada 10.000 caixas de correio.

Para obter mais informações sobre pastas de disponibilidade e publicação de informações de disponibilidade, consulte "Working with Exchange Server 2003 Stores" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).


O catálogo global único está presente na topologia
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Exchange_DSAccess no namespace root\MicrosoftExchangeV2 para determinar o número de servidores do catálogo global presentes na topologia. O número de servidores do catálogo global é determinado pela contagem do número de entradas da chave WMI DSAccessNameGC. Se o Exchange Server Analyzer detectar que existe apenas um servidor de catálogo global na topologia, exibirá uma prática recomendada.

Para tolerância a falhas, é uma prática recomendada ter pelo menos dois servidores de catálogo global disponíveis para atender aos servidores e usuários do Exchange. Um único servidor de catálogo global representa um único ponto de falha. O Exchange 2000 Server, o Exchange Server 2003 e o Exchange Server 2007 dependem de servidores de catálogo global para diversas funções. Se um servidor de catálogo global não estiver disponível, a entrega de mensagens pode ficar lenta ou parar totalmente. Além disso, se os servidores de catálogo global não estiverem disponíveis, os serviços do Exchange Server podem não inicializar. Se os serviços do Exchange Server não iniciarem, os usuários não poderão acessar suas caixas de coreio.

Para a escalabilidade e tolerância a falhas, é recomendável configurar pelo menos dois servidores de catálogo global em cada site de serviço de diretório do Active Directory®. Se um site abranger vários domínios, é recomendável configurar um catálogo global para cada domínio onde residem computadores e clientes do Exchange 2000 Server, do Exchange Server 2003 ou do Exchange Server 2007. Além disso, é recomendável implantar um único servidor de catálogo global para cada quatro processadores do computador do Exchange Server.

Para obter detalhes sobre como criar servidores de catálogo global adicionais, consulte o artigo 313994 da Base de Dados de Conhecimento da Microsoft, "Como criar ou mover um catálogo global no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994).

Para obter mais informações sobre a disposição e disponibilidade dos servidores de catálogo global relacionados ao Exchanger Server, consulte os artigos a seguir na Base de Dados de Conhecimento:

  • 875427, "Disposição e proporções de servidores de catálogo global em uma organização do Exchange 2000 ou do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427)

  • 322801, "O Atendedor do sistema do Exchange não é iniciado e você recebe uma mensagem de erro 'Os servidores de catálogo global não estão respondendo'" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322801)

  • 829361, "O desligamento do computador do Exchange Server 2003 demora mais tempo do que o previsto" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829361)

  • 304403, "Considerações do Exchange para promover um controlador de domínio a um servidor de catálogo global" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403)

  • 305065, "Considerações do Exchange Server para rebaixar um servidor de catálogo global a um controlador de domínio" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065)


Servidor de pasta do site excluído
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-03-01

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo siteFolderServer para cada objeto de grupo administrativo. Se a ferramenta determinar que o valor do atributo siteFolderServer contém a cadeia de caracteres DEL:, um erro será exibido.

O atributo siteFolderServer representa o DN (nome distinto) do armazenamento Pasta Pública que é responsável por hospedar as pastas do site (normalmente o primeiro servidor no site ou grupo administrativo).

Por padrão, o Servidor de Pastas do Site é o primeiro servidor que é instalado no grupo administrativo. O armazenamento de pasta pública desse servidor é o local padrão das pastas de disponibilidade e do catálogo de endereços offline para o grupo administrativo. Se você remover ou decomissionar esse servidor sem replicar essas pastas para outro servidor e designar esse servidor como um servidor de catálogo de endereços offline, os usuários do Microsoft Office Outlook® 2003 verão os problemas existentes com o catálogo de endereços e os dados de disponibilidade.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Modifique os atributos do objeto do Active Directory a seu próprio risco.

Para corrigir esse erro

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Localize o armazenamento de informações de pasta pública que você deseja designar como o Servidor de Pastas do Site, expandindo os seguintes nós no contêiner Configuração:

    CN=Configuration,DC=<DomainName>,DC=com, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdministrativeGroupName> CN=Servers, CN=<ServerName>, CN=InformationStore, CN=<StorageGroupName>

  3. No painel direito, clique com o botão direito em CN=<PublicFolderStoreName>, e selecione Propriedades.

  4. No campo Atributos, role a tela para baixo e selecione o atributo distinguishedName.

  5. Clique em Editar e copie o atributo inteiro para a Área de Transferência.

  6. Expanda o contêiner Configuração e expanda CN=Configuration,CN=<DomainName>,CN=com, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups

  7. Clique com o botão direito no grupo administrativo que você deseja modificar e selecione Propriedades.

  8. No campo Atributos, role a tela para baixo e selecione o atributo siteFolderServer.

  9. Clique em Editar e cole o valor do atributo distinguishedName no campo Valor.

  10. Verifique duas vezes o conteúdo do campo Valor para garantir que a colagem foi executada corretamente e clique em OK para salvar a alteração.

  11. Clique em OK para fechar as Propriedades do Grupo Administrativo.

  12. Saia do editor do Active Directory e reinicie o serviço Armazenamento de Informações do Microsoft Exchange em todos os computadores do Exchange Server no site para que a alteração entre em vigor.

Para obter mais informações sobre como recriar pastas do sistema e redefinindo o Servidor de Pastas do Site, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 822444, "Como redefinir a pasta do site no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822444)

  • 275171, "Como redefinir as pastas do sistema em um Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=275171)

  • 284200, "A pasta do sistema Schedule+ Free/Busy não foi encontrada" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200)

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como funciona o ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda do Windows Server.


Chamadas lentas do serviço de diretório Active Directory
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-14

A ferramenta Analisador do Microsoft® Exchange Server examina o FCL (Log de Chamada de Função) do Exchange, o arquivo Store.fcl, em busca de eventos de componentes de serviço do diretório Active Directory® que excedam um tempo de resposta de 2,5 segundos.

Os eventos de componentes do Active Directory do FCL do Exchange representam chamadas da função do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe) para o componente Active Directory.

O Active Directory fornece todas as informações sobre caixa de correio, serviços de lista de endereços e outras informações relacionadas a destinatários. A maioria das informações de configuração do Exchange Server 2003 também está armazenada no Active Directory.

Os serviços do Exchange Server acessam informações que estão armazenadas no Active Directory e gravam as informações no Active Directory.

Se o Analisador do Exchange Server detectar eventos no arquivo FCL que reflitam um tempo de resposta de mais de 2,5 segundos para chamadas de função do Active Directory do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe), o Analisador do Exchange Server exibirá um erro.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

Chamadas do serviço de Armazenamento de Informações do Microsoft Exchange para o Active Directory que demorem mais de 2,5 segundos podem ser provocada pelas seguintes condições:

  • Latência de rede entre o servidor Exchange e o Controlador de Domínio.

  • Configuração estática ou de outra forma incorreta do DSAccess.

  • Um controlador de domínio sobrecarregado e catálogo global.

  • Uma topologia do Active Directory designada incorretamente.

Para resolver esse erro, execute as seguintes etapas:

  • Execute o Exchange Server Analyzer para obter uma análise adicional de problemas do servidor. Você pode baixar o Exchange Server Analyzer em "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Verifique o desempenho dos servidores do Controlador de Domínio do Active Directory.

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre o desempenho do Exchange e o DSAccess, consulte o artigo 250570 da Base de Dados de Conhecimento da Microsoft, "Directory service server detection and DSAccess usage" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).

Para obter mais informações sobre o desempenho do Exchange Server, consulte "Performance and Scalability Guide for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Troubleshooting Microsoft Exchange Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento de informações, consulte o artigo 257725 da Base de Dados de Conhecimento Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Para obter mais informações sobre o desempenho do Controlador de Domínio, consulte os seguintes recursos do Windows Server:

  • "Planning Domain Controller Capacity" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=70191).

  • "Active Directory Monitoring of Domain Controllers" em Windows 2000 Server Active Directory Planning and Deployment Guides (em inglês) (http://go.microsoft.com/fwlink/?LinkId=70193).


Chamadas lentas do ESE
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-13

A ferramenta Microsoft® Exchange Server Analyzer examina o FCL (log de chamadas de função) do Exchange, arquivo Store.fcl, dos eventos do componente de mecanismo de armazenamento extensível (ESE) do Exchange que excedem um tempo de resposta de 2,5 segundos.

Os eventos do componente FCL do ESE do Exchange são representações das chamadas da função do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para o componente ESE.

O Armazenamento de Informações do Exchange está na parte superior de um banco de dados do ESE. O ESE é um mecanismo de banco de dados sofisticado, baseado em transações. Uma transação é uma série de operações que são tratadas como uma unidade atômica (indivisível). Todas as operações em uma transação são concluídas e salvas permanentemente ou, então, nenhuma operação é realizada.

O Exchange Server usa o ESE como um mecanismo de banco de dados incorporado que determina a estrutura dos bancos de dados e gerencia a memória. O mecanismo de banco de dados coloca os bancos de dados da memória em caches transferindo 4 quilobytes (KB) de blocos de dados (páginas) para dentro e para fora da memória. Isso atualiza as páginas da memória e grava páginas novas ou atualizadas no disco novamente. Quando o sistema recebe solicitações, o mecanismo de banco de dados pode armazenar dados em buffer na memória. Por isso, ele não precisa acessar o disco constantemente.

Embora o armazenamento de dados em cache na memória seja a forma mais rápida e eficiente de processar dados, as informações do disco nunca são completamente atualizadas quando o Exchange está em execução; porém, o disco de log de transações é sempre mantido atualizado com informações sobre cada transação. No entanto, como muitas alterações na memória ainda não estão no disco, o banco de dados e a memória não estão sincronizados.

Se descobrir que os eventos do arquivo Store.fcl refletem um tempo de resposta superior a 2,5 segundos para as chamadas de função do componente ESE do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe), o Exchange Server Analyzer exibirá um erro.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

As chamadas em andamento do ESE podem ser causadas pelas seguintes condições:

  • Desfragmentação online do Exchange.

  • Backups de dados.

    Observação:
    Se a desfragmentação online ou o backup de dados tiver sido intencionalmente processado durante a coleta de log de Rastreamento de Chamadas do Exchange, você poderá ignorar esta mensagem com segurança, pois ela não representará um indicador de problema de desempenho do Exchange Server.
  • Afunilamentos em uma unidade de banco de dados.

Para resolver esse erro, execute as seguintes etapas:

  • Recomendamos que você não sobreponha janelas de backup ou a manutenção online com intervalos de pico de demanda de usuários.

  • Execute o Exchange Server Analyzer para obter uma análise adicional do servidor. Você pode baixar o Exchange Server Analyzer em "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre como configurar as janelas de horário da desfragmentação online, consulte o artigo 244524 da Base de Dados de Conhecimento Microsoft, "XADM: How to Configure the Exchange Server Online Defragmentation Time Window" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524).

Para obter mais informações sobre problemas de Afunilamento de Disco do Exchange Server, consulte Afunilamento de disco detectado.

Para obter mais informações sobre como medir e otimizar discos para o Exchange Server, consulte "How to Calculate Your Disk I/O Requirements" e "Best Practices Common to Multiple Architectures" em Optimizing Storage for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=49324).

Para obter mais informações sobre o ESE, consulte "Extensible Storage Engine Architecture" (em inglês) (http://go.microsoft.com/fwlink/?linkid=67009).


Chamadas lentas de IMAIL
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-12

A ferramenta Microsoft® Exchange Server Analyzer examina o FCL (log de chamada de função) do Exchange, o arquivo Store.fcl, de eventos que excedem o tempo de resposta de 2,5 segundos para o componente IMAIL do cliente MAPI.

Os eventos do componente MAPI do IMAIL do FCL do Exchange representam as chamadas de função do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) usadas para converter as mensagens em formato Internet e de formato Internet em formato MAPI.

O componente IMAIL do Exchange Server é um serviço de conversão flexível que é usado pelo serviço Armazenamento do Microsoft Exchange entre mensagens da Internet e MAPI. Isso permite a interoperabilidade entre clientes que usam o formato RFC-822 ou Internet e clientes que usam o formato de armazenamento interno do Exchange Server, como clientes MAPI ou tarefas internas STORE.

O Exchange usa o mecanismo IMAIL para aplicar formatos de mensagem ao conteúdo, conforme definido para domínios da Internet no Gerenciador do Sistema do Exchange ou conforme especificado pelo usuário por destinatário do Microsoft Office Outlook®. Se nenhum parâmetro de formatação for passado para o IMAIL, o IMAIL formatará as mensagens MAPI no formato S/TNEF (Summary TNEF) para transferência entre servidores.

Se o Exchange Server Analyzer detectar eventos no arquivo de log Store.fcl que reflitam um tempo de resposta superior a 2,5 segundos para o componente IMAIL das chamadas de função do componente do cliente MAPI do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe), ele exibirá um erro.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

Tempos de resposta lentos para as chamadas de função do serviço Armazenamento de Informações Exchange (Store.exe) para IMAIL podem ser causados pelas seguintes condições:

  • O IMAIL tenta processar muitos dados em uma mensagem ou anexo.

  • Muitos clientes solicitam conversão de dados.

  • As solicitações do DSAccess encontram uma resposta lenta.

  • Existem afunilamentos nas unidades TEMP e TMP.

  • Existem movimentações de caixas de correio em andamento.

  • Para resolver esse erro, execute as seguintes etapas:

  • Agende todas as movimentações de caixa de correio para intervalos de demanda que não sejam de pico.

  • Execute o Analisador do Exchange Server para obter uma análise adicional dos problemas do servidor, como limites de tamanho de mensagens e anexos. Você pode baixar o Exchange Server Analyzer em "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre problemas de Afunilamento de Disco do Exchange Server, consulte Afunilamento de disco detectado.

Para obter mais informações sobre como medir e otimizar discos para o Exchange Server, consulte "How to Calculate Your Disk I/O Requirements" e "Best Practices Common to Multiple Architectures" em Optimizing Storage for Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=49324).

Para obter mais informações sobre as práticas recomendadas para limites de tamanho de mensagem no Exchange Server, consulte O tamanho máximo da mensagem de saída não foi definido.


Chamadas lentas de LSASS
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-12-04

A ferramenta Microsoft® Exchange Server Analyzer Tool examina o FCL (Log de Chamada de Função) do Exchange, o arquivo Store.fcl, em busca de eventos de componentes do processo do Servidor de Autenticação de Segurança Local (Lsass.exe) que excedam um tempo de resposta de 25 milissegundos.

Os eventos de componentes do processo LSASS FCL do Exchange representam chamadas da função do serviço Armazenamento de informações do Microsoft Exchange (Store.exe) para o componente do proocesso Local Security Authentication Server (Lsass.exe).

O processo do Servidor de Autenticação de Segurança Local (Lsass.exe) é um subsistema de segurança invocado por outros processos para verificar informações de contas e validação de logon.

Cada logon de cliente Exchange faz com que o servidor que está executando o Exchange Server envie uma solicitação para pesquisar o SID (identificador de segurança) da conta do cliente e crie uma chamada dentro do processo do Servidor de Autenticação de Segurança Local (Lsass.exe).

Se o Exchange Server Analyzer detectar eventos no arquivo de log Store.fcl que reflitam um tempo de resposta de mais de 25 milissegundos para chamadas de função do componente Servidor de Autenticação de Segurança Local (Lsass.exe) do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe), o Exchange Server Analyzer exibirá um erro.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

Tempos de resposta lentos para as chamadas de função do serviço Armazenamento de Informações Microsoft Exchange (Store.exe) para LSASS podem ser causados pelas seguintes condições:

  • Problemas de recurso do servidor relacionados ao número de usuários que autenticam ao mesmo tempo.

  • Latência de rede entre o servidor Exchange e o Controlador de Domínio ou o servidor de catálogo global.

  • Problemas de afunilamento no recurso do servidor.

Para resolver esse erro, execute as seguintes etapas:

  • Considere a implementação do parâmetro NeverPing como descrito em Parâmetro 'NeverPing' Recomendado

  • Execute o Analisador do Exchange Server para obter uma análise adicional dos problemas do servidor, como limites de tamanho de mensagens e anexos. Você pode baixar o Exchange Server Analyzer em "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre o processo e uso de memória do Lsass.exe, consulte o artigo 308356 da Base de Dados de Conhecimento da Microsoft, "Uso de memória pelo processo Lsass.exe em controladores de domínio executando o Windows Server 2003 ou o Windows 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356).

Para obter mais informações sobre logons de cliente Exchange e problemas do LSASS, consulte o artigo 161938 da Base de Dados de Conhecimento da Microsoft, "Slow Exchange Client Logons Due to Resource Deadlock" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938).

Para obter mais informações sobre a latência de rede entre o servidor Exchange e o Controlador de Domínio ou o servidor de catálogo global, consulte o seguinte artigo no Blog da Equipe do Exchange Server, "Exchange Does Not Always Use Local GCs" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=69166).

Observação:
O conteúdo de cada blog e sua URL estão sujeitos a alterações sem aviso.

Para obter mais informações sobre problemas de afunilamento no recurso do servidor, consulte Afunilamento do processador.

Para obter mais informações sobre o desempenho do Exchange Server, consulte "Performance and Scalability Guide for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Troubleshooting Microsoft Exchange Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento de informações, consulte o artigo 257725 da Base de Dados de Conhecimento Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Chamadas lentas do antivírus
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-11

A ferramenta do Analisador do Microsoft® Exchange Server examina o FCL (Log de Chamada de Função) do Exchange, o arquivo Store.fcl, em busca de eventos de componentes VAPI (API de vírus) Virusscan que excedam um tempo de resposta de 2,5 segundos.

Os eventos de componentes VAPI Virusscan do FCL do Exchange representam chamadas da função do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe) para software de verificador de vírus externo.

Para aprimorar a solução de problemas da VAPI, o Exchange Server implementa logs de eventos que podem ser usados para controlar o desempenho da API de verificação de vírus.

Os eventos registrados no log incluem o seguinte:

  • Carregamento e descarregamento de DLLs de fornecedores.

  • Verificação bem-sucedida de itens.

  • Vírus localizados no armazenamento de informações.

  • Comportamento inesperado na VAPI.

Se o Analisador do Exchange Server detectar eventos no arquivo de log Store.fcl que reflitam um tempo de resposta de mais de 2,5 segundos para chamadas de função do software verificador de vírus externo do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe), o Analisador do Exchange Server exibirá um erro.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

Tempos de resposta lentos para as chamadas de função externa do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe) para o software de verificação de vírus podem ser causados pelas seguintes condições:

  • Atualizações para scanner de vírus que causam uma nova verificação de itens no armazenamento de informações.

  • Um scanner de vírus configurado incorretamente

  • O software antivírus processa uma mensagem ou anexo grande.

Para resolver esse erro, execute as seguintes etapas:

  • Agende as atualizações do seu antivírus para épocas de baixo consumo, ou seja, intervalos de demanda que não sejam de pico.

  • Considere a reinstalação do software de verificação de vírus, mas reinstale em intervalos de demanda que não sejam de pico.

  • Examine a configuração do seu mecanismo antivírus em relação à configuração correta de threads, a exclusões de nível de arquivo e assim por diante. Consulte o artigo 823166 da Base de Dados de Conhecimento Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Consulte os artigos na seção Para obter mais informações deste documento.

Para obter mais informações

Para obter mais informações sobre os programas de verificação de vírus geralmente usados com o Microsoft Exchange Server 2003, consulte o artigo 823166 da Base de Dados de Conhecimento da Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Para obter mais informações sobre os programas de verificação de vírus geralmente usados com o Microsoft Exchange 2000 Server, consulte o artigo 328841 da Base de Dados de Conhecimento da Microsoft, "Exchange e o software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Para obter mais informações sobre o desempenho do Exchange Server, consulte "Performance and Scalability Guide for Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Troubleshooting Microsoft Exchange Server Performance" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

Para obter mais informações sobre como solucionar problemas de desempenho do armazenamento de informações, consulte o artigo 257725 da Base de Dados de Conhecimento Microsoft, "XADM: Como coletar dados de diagnóstico para solucionar problemas do armazenamento de informações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Chamadas lentas de instantâneo VSS
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-13

A ferramenta Microsoft® Exchange Server Analyzer Tool examina o Exchange FCL (Log de Chamada de Função), o arquivo Store.fcl, para localizar os eventos de componente de instantâneo VSS (Serviço de Cópias de Sombra de Volume) cujos tempos de resposta excedem a 20 segundos.

Os eventos dos componentes de VSS do Exchange FCL representam as chamadas de função do serviço (Store.exe) de Armazenamento de Informações do Microsoft Exchange para o componente de instantâneo VSS.

O VSS é um conjunto de APIs do COM que implementa uma estrutura que permite que os backups de volume sejam executados enquanto os aplicativos do sistema continuam a gravar nos volumes.

O Microsoft Exchange Server 2003 usa o VSS incluído no sistema operacional Microsoft Windows Server™ 2003 para fazer cópias de sombra de volume dos bancos de dados e arquivos de log de transações do Exchange Server 2003.

Um instantâneo VSS não é totalmente independente dos dados originais. Geralmente, os instantâneos são criados quando você define um marcador em um momento e verifica se os dados podem ser revertidos para esse momento.

Se o Exchange Server Analyzer detectar que os eventos do arquivo Store.fcl refletem um tempo de resposta superior a 20 segundos para as chamadas de função do componente de instantâneo VSS do serviço de Armazenamento de Informações do Microsoft Exchange (Store.exe), ele exibirá um erro.

Quando chamadas entre componentes do serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) aguardam uma resposta, threads de RPC (chamada de procedimento remoto) pode fazer backup dessas solicitações e causar problemas de desempenho do Exchange Server, como atrasos nas respostas do servidor para os clientes.

Observação:
Se um instantâneo VSS da coleta de logs de Rastreamento de Chamadas do Exchange foi intencionalmente iniciado em 20 segundos, você poderá seguramente ignorar essa mensagem de erro como um indicador de um problema de desempenho do Exchange Server.

Como prática recomendada, aconselhamos você a não sobrepor janelas de backup com manutenção online nem com intervalos de pico de demanda de usuário.

Para obter mais informações

Para obter mais informações sobre VSS, consulte "Práticas recomendadas para usar o serviço de cópia de sombra de volume com o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=56571) (em inglês).


Um evento de erro 'SMTPSVC' (ID: 429) foi registrado em log nas últimas 24 horas
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-16

A ferramenta Microsoft Exchange Analyzer consulta a metabase IIS para determinar o valor da propriedade LM/SmtpSvc/%SMTPInstance%/ServerState para cada instância de um Servidor Virtual SMTP.

A propriedade ServerState apresenta o estado atual da instância do servidor. Os estados e os códigos de estado correspondentes são os seguintes: 1 (iniciando), 2 (iniciado), 3 (parando), 4 (parado), 5 (pausando), 6 (pausado) ou 7 (continuando).

Se o Exchange Analyzer determinar que o valor da propriedade ServerState de uma instância do Servidor Virtual SMTP não seja igual a 2 (iniciado), o Exchange Analyzer consultará a classe Win32_NTLogEvent do WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar se um erro Evento 429 foi registrado em log para o Serviço SMTP (SMTPSVC) nas últimas 24 horas.

Se o Exchange Analyzer detectar que a VSI (Instância do Servidor Virtual) SMTP não foi iniciada e que há pelo menos um erro Evento 429 registrado em log para o SMTPSVC nas 24 horas que se passaram, ele exibirá um aviso.

Esse aviso indica que pode haver problemas com os diretórios designados para a Instância do Servidor Virtual SMTP.

SMTP é o protocolo de mensagens nativo para envio e transporte de mensagens no Exchange Server. Isso significa que os clientes usam SMTP para enviar mensagens e os servidores Exchange usam SMTP para entregar mensagens e dados de mensagens.

Quando chegam mensagens ao computador do Exchange através do serviço SMTP, os dados são gravados no disco rígido como um arquivo .eml. Por padrão, esses arquivos são armazenados na pasta <unidade>:\Arquivos de Programas\Exchsrvr\Mailroot da mesma partição em que o Exchange está instalado.

Esse problema pode ser causado por um dos seguintes motivos:

  • O caminho de diretório <unidade>:\Arquivos de Programas\Exchsrvr\Mailroot ou as pastas sob esse caminho de diretório foram movidas, estão ausentes ou foram danificadas.

  • As permissões para <unidade>:\Arquivos de Programas\Exchsrvr\Mailroot ou as pastas desse caminho de diretório não estão definidas corretamente.

  • Verificação de aplicativo antivírus do caminho de diretório <unidade>:\Arquivos de Programas\Exchsrvr\Mailroot ou as pastas desse caminho de diretório.

Para abordar esse aviso, execute um ou mais dos seguintes procedimentos:

  • Verifique o local e a integridade do caminho de diretório <unidade>:\Arquivos de Programas\Exchsrvr\Mailroot e das pastas desse caminho de diretório.

  • Verifique as permissões no caminho de diretório <unidade>:\Arquivos de Programas\Exchsrvr\Mailroot e das pastas desse caminho de diretório.

  • Verifique se os aplicativos antivírus não estão verificando as pastas no caminho de diretório <unidade>:\Arquivos de Programas\Exchsrvr\Mailroot.

Para verificar o caminho de diretório Mailroot no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e clique em Parar.

  4. Clique novamente com o botão direito no servidor virtual SMTP e clique em Propriedades.

  5. Clique na guia Mensagens.

  6. No campo Diretório de filas, verifique o caminho completo da pasta Mailroot apropriada. Você pode clicar em Procurar para procurar o computador local para o caminho.

  7. Clique em OK para salvar as alterações.

  8. Clique com o botão direito no servidor virtual SMTP e clique em Iniciar.
Para verificar o caminho de diretório Mailroot no Exchange 2000 Server

  1. Pare todos os serviços do Exchange Server e do IIS no computador do Exchange 2000 Server cuja pasta Mailroot do servidor virtual SMTP você deseja verificar.

  2. Verifique se o valor do servidor virtual SMTP afetado para msExchSmtpQueueDirectory está configurado para o caminho apropriado.

  3. Espere o Active Directory replicar essa alteração para os servidores de catálogo globais usados por esse servidor Exchange.

  4. Inicie o serviço Atendedor do Sistema Microsoft Exchange.

  5. No computador do Exchange Server, verifique a presença de três instâncias de ID de Evento 1005 no log de eventos do Aplicativo que tem uma Origem de Evento igual a MSExchangeMU e a Categoria igual a Geral.

  6. Reinicie o computador do Exchange Server para que as alterações entrem em vigor.
Para verificar as permissões padrão para o caminho de diretório Mailroot no Exchange 2000 Server e no Exchange Server 2003

  1. Inicie o Windows Explorer e navegue e expanda a pasta Exchsvr.

  2. Clique com o botão direito na pasta Mailroot e clique em Propriedades.

  3. Clique na guia Segurança e verifique as seguintes permissões padrão:

Conta | Permissões
Administradores | Controle Total
Usuários Autenticados | Ler e Executar, Listar Conteúdo da Pasta, Ler
Proprietário Criador | Nenhum
Operadores do Servidor | Modificar, Ler e Executar, Listar Conteúdo da Pasta, Ler, Gravar
Sistema | Controle Total
  1. Verifique essas permissões padrão de todas as pastas para cada Instância de Servidor Virtual presente.

Para obter mais informações sobre os procedimentos descritos, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 822933, "Como alterar o local da pasta Mailroot do SMTP do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933)

  • 318230, "XCON: Como alterar o local do diretório Mailroot do SMTP do Exchange Server 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230)

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)

Para obter mais informações sobre como configurar aplicativos de verificação antivírus para utilizar com o Exchange, consulte As exclusões da pasta do antivírus não foram configuradas.

Para obter informações detalhadas sobre como configurar exclusões na verificação RealTime no Symantec AntiVirus Corporate Edition, consulte o site do antivírus Symantec (http://www.symantec.com).

Observação:
Endereços da Web podem mudar, por isso, talvez você não consiga se conectar ao site ou sites mencionados aqui.

Para obter mais informações sobre como fortificar um ambiente do Exchange Server contra worms e vírus transmitidos por email, consulte "Reduzindo e erradicando vírus de email em um ambiente do Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47587).

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 328841, "Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841) (página em inglês)

  • 823166, "Visão geral do Exchange Server 2003 e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166) (página em inglês)

  • 306105, "XGEN: posição da Microsoft sobre soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105) (página em inglês)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange Server com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros disponíveis para o Exchange Server, consulte "Parceiros do Exchange Server 2007: Antivírus, Antispam" (http://go.microsoft.com/fwlink/?linkid=16226).


O nome de domínio totalmente qualificado da instância de SMTP não corresponde ao nome do servidor
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-07

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para saber se o valor da cadeia de caracteres ncacn_ip_tcp: do atributo networkAddress do objeto do servidor corresponde ao nome FQDN (Nome de Domínio Totalmente Qualificado) no atributo msExchSmtpFullyQualifiedDomainName do objeto do servidor virtual SMTP (Simple Mail Transfer Protocol).

Se o Exchange Server Analyzer determinar que os valores desses atributos não coincidem, ele exibirá um aviso.

Esse aviso indica que os valores desses atributos podem ter sido alterados manualmente e podem estar contribuindo para gerar problemas de fluxo de mensagens neste servidor.

O valor do atributo msExchSmtpFullyQualifiedDomainName especifica o FQDN para o servidor virtual SMTP e deve ser determinado pelo protocolo de rede DNS (Domain Name System).

Deve existir um registro válido HOST DNS (A) para o valor desse atributo, para permitir que os servidores de mensagens que tentarem resolver o FQDN do servidor virtual SMTP possam recuperar o endereço IP correto e rotear emails corretamente.

Para obter mais informações sobre o recurso de pesquisa reversa de DNS no Exchange, consulte "Adicionar um registro de recurso a uma zona do DNS" (http://go.microsoft.com/fwlink/?LinkId=63002).

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 266686, "XCON: How to Configure a SMTP Virtual Server Part 1" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, "XCON: How to Configure a SMTP Virtual Server Part 2" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Para obter mais informações sobre o design do serviço SMTP, consulte "Design do serviço SMTP" no Guia de Referência Técnica do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876).


Comprimento da fila local do SMTP acima do limite
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-20

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Local Queue Length do objeto de desempenho de SMTP Server para analisar os dados do desempenho.

Ao determinar que o contador de Local Queue Length excedeu o valor de pico de 1.000 durante o intervalo de tempo de amostragem, o Analisador do Exchange Server exibirá um erro.

O contador de SMTP Server\Local Queue Length indica o número de mensagens na fila do SMTP para entrega local ao serviço de Armazenamento de Informações do Microsoft Exchange. Os dados da fila local do SMTP (diretório Mailroot) são mantidos temporariamente no dispositivo de armazenamento enquanto está sendo processado pelo Exchange Server. Esse design impede que os dados sejam perdidos se ocorrer falha no servidor. Por exemplo, quando um servidor de destino estiver inacessível, as mensagens que deveriam ser roteadas para o servidor serão armazenadas no diretório de fila do servidor local até que elas possam ser entregues.

Esse erro indica um problema de desempenho ou interrupções no servidor, pois o servidor não pode mais entregar emails de entrada em tempo hábil. As seguintes condições podem causar esse atraso:

  • O serviço de diretório Active Directory® não está sendo consultado prontamente.

  • As mensagens não estão sendo liberadas prontamente para entrega local ou SMTP.

  • Os bancos de dados (armazenamentos de caixas de correio e armazenamentos de pastas públicas) foram desmontados.

  • Para resolver esse erro, realize as seguintes etapas:

  • Verifique se todos os bancos de dados (armazenamentos de caixas de correio e armazenamentos de pastas públicas) estão montados.

  • Identifique a origem do afunilamento do desempenho. Um afunilamento de desempenho pode estar relacionado a CPU, disco, rede ou memória e pode ser causado por um aumento na carga do servidor ou recursos de servidor insuficientes. Use a ferramenta Monitor de Desempenho (Perfmon.msc) para descobrir se o afunilamento é causado por um aumento da carga no servidor ou se o servidor está subdimensionado. Se a carga do servidor aumentou, identifique a origem da carga e reduza-a. Se o servidor tiver recursos insuficientes, aumente os recursos necessários ou mova usuários do servidor.

  • Monitore dependências externas, como o serviço de diretório do Active Directory, em relação a problemas de desempenho e os solucione e corrija conforme necessário.

Para obter mais informações

  • Para obter mais informações sobre o ajuste de transporte SMTP, consulte o "Ajuste de transporte SMTP" no Guia de desempenho e escalabilidade do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de fluxo de mensagens, consulte o artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489) (página em inglês).

  • Para obter mais informações sobre como solucionar problemas de transporte, consulte o artigo 257265 da Base de Dados de Conhecimento Microsoft, "Solução geral de problemas de transporte no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265) (página em inglês).

  • Para obter mais informações sobre os afunilamentos do processador, consulte Afunilamento do processador.

  • Para obter mais informações sobre os Afunilamentos de disco, consulte Afunilamento de disco detectado.

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre como mover caixas de correio do usuário para reduzir a carga do servidor, consulte Mover Caixas de Correio de Usuário para Outro Servidor.


O objeto de monitor de desempenho do Servidor SMTP não está disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Local Queue Length do objeto de desempenho de SMTP Server para analisar os dados do desempenho. Se o contador não retornar dados válidos, o Analisador do Exchange Server exibirá uma mensagem de linha de base.

Se o mecanismo de coleta de dados de desempenho não retornar dados válidos, qualquer combinação das seguintes condições poderá ser verdadeira:

  • O objeto do desempenho do SMTP Server está desabilitado.

  • O objeto do monitor de desempenho do SMTP Server está ausente ou danificado.

  • O Analisador do Exchange Server não tem permissões adequadas para acessar os objetos de desempenho.

As duas primeiras condições poderão ocorrer se alguns contadores extensíveis danificarem o Registro ou se programas baseados na WMI (Instrumentação de Gerenciamento do Microsoft Windows®) modificarem o Registro. O procedimento a seguir explica como corrigir as duas primeiras condições. Antes de executar o procedimento, verifique se o Analisador do Exchange Server tem as permissões adequadas. Para obter mais informações sobre as permissões necessárias para executar o Analisador do Exchange Server, consulte a documentação da Ajuda incluída no Analisador do Exchange Server. Para obter Ajuda, abra o Analisador do Exchange Server e pressione a tecla F1.

Para corrigir esse erro

  1. Verifique se o objeto de desempenho do SMTP Server está habilitado.

    1. Baixe e instale a ferramenta Lista de Contadores de Desempenho Extensíveis (Exctrlst.exe). Você pode baixar o Exctrlst.exe no site "Exctrlst.exe: Lista de Contadores de Desempenho Extensíveis" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Abra o Exctrlst.exe, clique em Ordem de classificação, e clique em Serviço.

    3. Localize o serviço ao qual o objeto de desempenho relata e verifique se a caixa de seleção Contadores de Desempenho Habilitados está marcada.

      Se a caixa de seleção Contadores de Desempenho Habilitados não estiver marcada, marque a caixa de seleção e reinicie o serviço que está associado aos contadores de desempenho para verificar se os contadores de desempenho estão em operação. Se os contadores de desempenho não estiverem funcionando ou se a caixa de seleção Contadores de desempenho habilitados já estava marcada, continue na etapa 2.

  2. Reconstrua os contadores de desempenho ausentes ou danificados, conforme descrito no artigo 300956 da Base de Dados de Conhecimento da Microsoft, "Como reconstruir manualmente os valores de biblioteca do contador de desempenho" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Se você seguir as instruções desse artigo da Base de Dados de Conhecimento e o problema não for solucionado, será necessário reinstalar o sistema operacional Windows no modo Reparo e então aplicar os service packs mais recentes do Windows.


O Servidor SQL está executando o Virtual Server 2005 com o Exchange Server instalado como Convidado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Windows) para determinar se o valor da chave Model está definido como Virtual Machine.

O Exchange Server Analyzer também verifica a presença do seguinte valor do Registro:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Além disso, o Exchange Server Analyzer consulta a classe Win32_Services do WMI para determinar se o serviço Microsoft SQL Server™ (MSSQLSERVER) está em execução no computador físico que está executando o Microsoft Virtual Server 2005.

Se o Exchange Server Analyzer detectar que a chave Model contém a cadeia de caracteres Virtual Machine, que a ramificação do Registro acima existe e que MSSQLSERVER está em execução, será exibido um erro.

Um valor Virtual Machine para a chave Model indica que o computador do Exchange Server está sendo executado como máquina virtual convidada no Virtual Server 2005 ou no Microsoft Virtual PC 2004. Como a ramificação do Registro acima só é criada pelo Virtual Server 2005, sua existência significa que o computador do Exchange Server está sendo executado como máquina virtual convidada no Virtual Server 2005.

A Microsoft não oferece suporte para execução de nenhuma versão do Microsoft Exchange em uma máquina virtual ou um emulador. O mesmo vale para execução do Exchange Server no Microsoft Virtual Server 2005, no Microsoft Virtual PC 2004 ou em qualquer programa de máquina virtual de terceiros. As plataformas do Microsoft Exchange Server são criadas e testadas para serem executadas apenas em hardware físico, especialmente naquelas plataformas de hardware listadas no Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219).

Além disso, executar o Exchange como um servidor virtual convidado em um computador que está executando o SQL Server não é uma prática recomendada porque não permite a redundância adequada em todos os serviços.

Para corrigir esse erro

  1. Mova as caixas de correio do Exchange Server que está sendo executado no Virtual Server 2005 para um computador do Exchange Server que não seja virtual.

  2. Relocalize quaisquer pastas públicas e transfira todas as funções mantidas pelo servidor virtual Exchange conforme necessário.

  3. Desinstale o Exchange da máquina virtual para descomissioná-la e removê-la da infra-estrutura do Exchange e do serviço de diretório do Active Directory®.

Para obter mais informações sobre como mover caixas de correio, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 822892, "Aprimoramento de Mover Caixa de Correio no Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892) (em inglês)

  • 224975, "XADM: Differences Between Move Mailbox Methods" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Para obter mais informações sobre suporte para computadores do Exchange Server que estão sendo executados em ambientes virtuais, consulte o artigo 320220 da Base de Dados de Conhecimento, "Limites de suporte para o Exchange Server em uma máquina virtual ou uma máquina de emulação" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220) (em inglês).

Para obter mais informações sobre o Microsoft Virtual Server 2005, consulte o site do Microsoft Virtual Server 2005 (http://go.microsoft.com/fwlink/?linkid=34938).

Para obter mais informações sobre o Microsoft Virtual PC 2004, consulte o site do Microsoft Virtual PC 2004 (http://go.microsoft.com/fwlink/?linkid=34663).


A porta SRS é inferior a 5000
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar a configuração TCP/IP para o serviço de Replicação de Site do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

Se o Analisador do Exchange Server detectar que o valor para TCP/IP está definido como um valor abaixo de 5.000 (decimal), um aviso será exibido.

No caso em que você deve definir TCP/IP como um valor estático, é recomendável defini-lo como um valor que esteja logo acima de 5.000. A atribuição de números de porta estática abaixo de 5.000 pode causar um conflito de porta com outro processo e levar à falha do processo Serviço de Replicação de Site do Microsoft Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir a chave do Registro TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Clique duas vezes na chave TCP/IP e defina o campo Dados do valor para um inteiro acima de 5000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o Serviço de Replicação de Site do Microsoft Exchange para que essa alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre limitações de porta, consulte o artigo 194952 da Base de Dados de Conhecimento, "XADM: Statically Mapped Port Limitations for Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952).


A porta SRS foi substituída manualmente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o valor da porta para o Serviço de Replicação do Site do Microsoft Exchange foi substituído manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

Se o Analisador do Exchange Server detectar a presença e configuração da TCP/IP , será exibida uma mensagem de configuração não padrão.

O motivo mais comum para a configuração desse valor é habilitar clientes MAPI para se conectarem a um servidor Exchange existente no outro lado de um firewall. Esse cenário requer a abertura de várias portas em um firewall para habilitar clientes do Microsoft Office Outlook® 2003 a se conectarem por meio do MAPI com um servidor Exchange, geralmente pela Internet. Há suporte para essa configuração. Para obter mais informações sobre como configurar clientes MAPI para se conectarem ao Exchange por meio de um firewall, consulte o artigo 270836 da Base de Dados de Conhecimento da Microsoft, "Mapeamentos de portas estáticas do Exchange 2000 e Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836). Se você não estiver usando este cenário, deverá remover a chave do Registro.

A implantação recomendada para usar o Outlook no Modo MAPI para se conectar a um servidor Exchange pela Internet é o uso de recursos RPC sobre HTTP, encontrados no Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 e Microsoft Windows® XP Professional. O Modo MAPI era conhecido anteriormente como modo "Corporativo" ou de "Grupo de trabalho".

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para remover a entrada do Registro TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Exclua o valor do Registro chamado TCP/IP.

  4. Saia do editor do Registro e reinicie o Serviço de Replicação de Site do Microsoft Exchange.

Para implantar RPC sobre HTTP

  1. Consulte "Exchange Server 2003 RPC over HTTP Deployment Scenarios" (em inglês) (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consulte o artigo 833401 da Base de Dados de Conhecimento Microsoft, "Como configurar RPC sobre HTTP no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  3. Revise o artigo 827330 da Base de Dados de Conhecimento, "Como solucionar problemas de conexão cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  4. Consulte o Microsoft Support WebCast, "Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


A conta de inicialização configurada para o Atendedor do Sistema não tem suporte
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Services para determinar se a conta de inicialização especificada na propriedade StartName do serviço MSExchangeSA (Atendedor do Sistema do Microsoft Exchange) está usando a conta LocalSystem. Se o Exchange Server Analyzer detectar que o valor da propriedade StartName em um computador do Exchange 2000 Server ou do Exchange Server 2003 é uma conta diferente da LocalSystem, exibirá um erro. A conta LocalSystem também é conhecida como a conta SYSTEM.

Você deve iniciar o MSExchangeSA no Exchange 2000 Server e no Exchange Server 2003 sob o contexto de segurança do LocalSystem. Não inicie o MSExchangeSA associando a conta de um usuário específico. Quando um serviço do Exchange que está sendo executado como LocalSystem acessa um servidor remoto, esse serviço será autenticado por meio das credenciais da conta do computador.

O mecanismo padrão de alteração de senhas altera a senha na conta do computador a cada sete dias. Ao alterar a senha a cada sete dias, você aumenta a segurança da conta do computador. A conta do coputador é mais segura do que a conta do usuário típico, pelos seguintes motivos:

  • A senha em uma conta de usuário típico é alterada com menos freqüência.

  • A senha em uma conta de usuário típico é menos aleatória do que em uma conta de computador, que é gerada aleatoriamente.

No Exchange Server 5.5, as contas de usuários são usadas para serviços. Alguns administradores com experiência no Exchange Server 5.5 alteram a conta de inicialização nos serviços do Exchange 2000 Server e do Exchange Server 2003, da conta padrão LocalSystem para uma conta de usuário.

No Exchange 2000 Server e no Exchange Server 2003, a Microsoft não oferece suporte para a execução do MSExchangeSA em qualquer outra conta, exceto a conta padrão LocalSystem.

Para corrigir esse erro

  1. Clique em Iniciar, aponte para Programas, aponte para Ferramentas Administrativas e clique em Serviços.

  2. Na lista de serviços, clique com o botão direito em Atendedor do Sistema do Microsoft Exchange e clique em Propriedades.

  3. Na guia Logon, em Fazer logon como, clique em Conta Sistema Local e clique em OK.

  4. Clique com o botão direito em Atendedor do Sistema do Microsoft Exchange e clique em Reiniciar.

Para obter mais informações sobre serviços do Exchange, consulte o artigo 239762 da Base de Dados de Conhecimento Microsoft, "Serviços do Exchange executados em LocalSystem" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


O arquivo STORE.EXE está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar a presença de vários arquivos binários centrais do Exchange:

  • Exres.dll

  • Gapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapi32.dll (verificado nas pastas System32 e \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se o Exchange Server Analyzer perceber que um ou mais dos arquivos acima está ausente, um erro será exibido. Para resolver esse erro, instale o service pack ou distribuição mais recente para sua versão do Exchange. Se o erro persistir, execute a Instalação do Exchange 2000 Server ou Exchange Server 2003 e selecione Reinstalar. A execução da Instalação no modo de reinstalação instala apenas os arquivos binários. Não remove nem redefine quaisquer dados do usuário ou da configuração. Se você reinstalar o Exchange Server, deverá reinstalar também todos os service packs ou hotfixes do Exchange que estavam instalados.

Para reinstalar o Exchange 2000 Server ou Exchange Server 2003

  1. Faça logon no servidor no qual deseja reinstalar o Exchange. Insira o CD do Exchange 2000 Server ou Exchange Server 2003 na unidade de CD-ROM.

  2. No menu Iniciar, clique em Executar e digite <unidade>:\setup\i386\setup, em que <unidade> é a unidade de CD-ROM de seu sistema.

  3. Na página Bem-vindo ao Assistente para Instalação do Microsoft Exchange , clique em Avançar.

  4. Na página Contrato de Licença, leia o contrato. Se você concordar com os termos, clique em Aceito e clique em Avançar.

  5. Na página Identificação do Produto, digite a chave de 25 dígitos do produto e clique em Avançar.

  6. Na página Seleção de Componentes, coluna Ação, use a seta suspensa ao lado do nó Microsoft Exchange e selecione Reinstalar e clique em Avançar.

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2003, consulte o site "Downloads para o Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre os service packs, distribuições de atualização e suplementos mais recentes do Exchange Server 2000, consulte o site "Downloads para o Exchange Server 2000" (http://go.microsoft.com/fwlink/?LinkId=33457).


Porta HTTP de armazenamento está abaixo de 5000
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-21

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada de Registro para determinar a configuração Rpc/HTTP Port para o serviço Armazenamento de Informações do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

Se o Exchange Server Analyzer detectar que o valor de Rpc/HTTP Port está definido como um valor abaixo de 5000 (decimal), um aviso será exibido.

A chave de Registro Rpc/HTTP Port é definida como 6001 pela Instalação do Exchange Server 2003 e do Exchange Server 2007. A chave de Registro Rpc/HTTP Port é utilizada para oferecer suporte à funcionalidade RPC sobre HTTP para o Microsoft Office Outlook® 2003 e o Microsoft Office Outlook 2007.

A menos que você tenha personalizado sua implantação RPC sobre HTTP com o auxílio dos Serviços de Consultoria da Microsoft ou por sugestão do Atendimento Microsoft, é recomendável implantar o RPC sobre HTTP com os valores de porta padrão.

Se você precisar definir Rpc/HTTP Port como um valor diferente de 6.001, é recomendável definir um valor superior a 5.000. Atribuir números de portas estáticas inferiores a 5.000 poderá causar um conflito de porta com outro processo e levar à falha do processo do serviço Armazenamento de Informações do Microsoft Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir o Registro da porta Rpc/HTTP para seu valor padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

  3. Clique duas vezes na chave Rpc/HTTP Port e defina o campo Dados do valor como 6.001 (decimal) ou um inteiro acima de 5.000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar RPC sobre HTTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 833401, "Como configurar RPC sobre HTTP em um único servidor no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "Como solucionar problemas de conexões cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Armazenamento:A porta HTTP não é padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se a HTTP Port está definida com o valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

Se o Analisador do Exchange Server detectar que o valor de Rpc/HTTP Port não é 6001 (decimal), uma mensagem de configuração não padrão será exibida.

A chave de Registro Rpc/HTTP Port é definida como 6001 pela Instalação do Exchange Server 2003 e do Exchange Server 2007. A chave de Registro Rpc/HTTP Port é utilizada para oferecer suporte à funcionalidade RPC sobre HTTP para o Microsoft Office Outlook® 2003 e o Microsoft Office Outlook 2007.

A menos que você tenha personalizado sua implantação RPC sobre HTTP com o auxílio dos Serviços de Consultoria da Microsoft ou por sugestão do Atendimento Microsoft, é recomendável implantar o RPC sobre HTTP com os valores de porta padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar a chave do Registro da porta Rpc/HTTP para seu valor padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Clique duas vezes na chave Rpc/ HTTP Port e defina o campo Dados do valor como 6001 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar RPC sobre HTTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 833401, "Como configurar RPC sobre HTTP em um único servidor no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "Como solucionar problemas de conexões cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Configurações de memória quase ideais
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-02-15

A ferramenta Microsoft Exchange Analyzer Tool consulta a classe Win32_NTLogEvent de WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar se um erro Evento 9665 foi registrado para o MSExchangeIS nas últimas 24 horas.

O Microsoft Exchange Server 2003 executa uma verificação da configuração de memória ideal quando o processo de armazenamento é iniciado. Se as configurações de memória não forem ideais, você verá um evento 9665 no Visualizador de Eventos.

Se o Exchange Analyzer detectar que um Evento 9665 foi registrado nas últimas 24 horas, ele lerá o campo de dados do evento para determinar qual dos possíveis sinalizadores da tabela a seguir está presente no evento.

Sinalizador de campo de dados do evento | Aviso exibido pelo Exchange Server Analyzer | Problema do Exchange Server 2003
0x00000001 | A opção /3GB não está definida | O servidor está executando o Microsoft Windows 2000 Advanced Server ou o Microsoft Windows 2000 Datacenter Server, tem 1 GB ou mais de memória física, mas não tem a opção /3GB definida no arquivo boot.ini.
0x00000002 | A opção /Userva não está definida corretamente | O servidor está executando o Microsoft Windows Server 2003 Standard Edition, o Microsoft Windows Server 2003 Enterprise Edition ou o Microsoft Windows Server 2003 Datacenter Edition, tem 1 GB ou mais de memória física e a opção /3GB está definida, mas a definição /USERVA não está presente no arquivo boot.ini.
0x00000004 | A opção 'SystemPages' precisa ser definida. | O servidor está executando alguma edição do Microsoft Windows 2000 Server e o valor SystemPages do Registro está definido fora da faixa de 24000 a 31000.
0x00000008 | A opção 'SystemPages' precisa ser redefinida. | O servidor está executando o Microsoft Windows Server 2003 Standard, o Microsoft Windows Server 2003 Enterprise ou o Microsoft Windows Server 2003 Datacenter Edition, e a definição do valor SystemPages no Registro é diferente de 0.
0x00000010 | A opção HeapDecommitFreeBlockThreshold não está definida corretamente | O servidor está executando alguma edição do Microsoft Windows 2000 Server ou do Microsoft Windows Server 2003, e a definição do valor HeapDeCommitFreeBlockThreshold no Registro é diferente de 0x00040000

Dependendo do sinalizador que estiver presente no campo de dados do Evento 9665, o Exchange Analyzer exibirá o aviso correspondente da tabela acima.

Esses avisos indicam que a memória do Exchange Server está definida como um estado quase ideal.

Para tratar esses avisos, siga a orientação dos artigos do Exchange Analyzer específicos do problema listados a seguir:

  • Esse servidor de caixa de correio do Exchange tem 1 GB ou mais de memória, mas não tem /3GB definido no arquivo Boot.ini.

  • USERVA definido incorretamente

  • SystemPages definido muito alto

  • Este servidor está executando o Windows Server 2003 e o valor SystemPages não é igual a 0

  • Esse servidor tem 1 GB ou mais de memória física e o HeapDeCommitFreeBlockThreshold não foi definido como 262144

Para obter mais informações

Para obter mais informações sobre esses problemas, consulte o artigo 325044 da Base de Dados de Conhecimento Microsoft, "Como solucionar problemas de fragmentação de memória virtual no Exchange Server 2003 e no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Para obter mais informações sobre o Evento 9665 do MSExchangeIS, consulte o "Events and Errors Message Center: detalhes do evento".

  • Para o evento 9665 de Armazenamento de Caixa de Correio, consulte (http://go.microsoft.com/fwlink/?LinkId=83210) (em inglês)

  • Para o evento 9665 de Armazenamento Público, consulte (http://go.microsoft.com/fwlink/?LinkId=83213) (em inglês)


Pesquisa de Área de Trabalho suspeita instalada em clientes
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-09-05

A ferramenta Microsoft® Exchange Server Analyzer Tool determinou a presença de muitos usuários usando um mecanismo de pesquisa de área de trabalho. Os mecanismos de pesquisa de área de trabalho podem gerar muitas RPCs (chamadas de procedimento remoto) contra as caixas de correio montadas pelo usuário, assim como um tráfego considerável contra as pastas públicas, uma vez que esses mecanismos de pesquisa rastreiam a estrutura de arquivos do armazenamento de pastas públicas. Alguns mecanismos de pesquisa só rastreiam as pastas públicas se elas estiverem incluídas na lista Favoritos de pastas públicas do usuário. Sendo assim, você pode ver ou não a carga imposta aos servidores de pastas públicas na pesquisa de área de trabalho.

As ações a serem tomadas para minimizar esse problema são:

  • Instruir os usuários a desativarem os recursos do Microsoft Office Outlook® no antivírus ou restringir a verificação somente à caixa de correio pessoal.

  • Executar o Outlook no modo cache do Exchange, para que os antivírus atinjam apenas a estação de trabalho local e não o servidor.

  • Siga a orientação do artigo 889086 da Base de Dados de Conhecimento Microsoft, "Você pode se deparar com um comportamento imprevisto em um computador baseado no Windows XP, ao tentar acessar pastas públicas no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=889086) para obter o hotfix e definir a chave de Registro MaxObjsPerMapiSession em computadores executando o Exchange Server, acessados por usuários de pesquisa de área de trabalho.

Para verificar se o aplicativo de pesquisa da área de trabalho é a causa de alta carga para um usuário específico, use o ExMon (Monitor de usuários do Microsoft Exchange) para monitorar as operações RPC nas ações do mecanismo de pesquisa, certifique-se de coletar dados durante um intervalo de tempo adequado (pelo menos cinco minutos). Em seguida, remova o mecanismo de pesquisa e execute novamente a ferramenta ExMon. Se ocorrer uma redução considerável na taxa de RPC, estará confirmado que o mecanismo de pesquisa da área de trabalho está causando o aumento na carga. Se você observar que a latência média de RPC diminui, estará confirmado que a alta carga resultou latências de RPC superiores.

Observação:
As taxas de latência de RPC variam bastante durante o dia todo. Portanto, um teste de cinco minutos talvez seja inadequado. Talvez seja necessário medir durante um intervalo de tempo maior.

Para baixar o ExMon, consulte o Centro de Download da Microsoft (http://go.microsoft.com/fwlink/?linkid=54983).

Para obter mais informações

  • Para obter mais informações sobre o software de pesquisa de área de trabalho, consulte:

    • Artigo 905184 da Base de Dados de Conhecimento Microsoft, "O desempenho do Exchange 2000 Server e do Exchange Server 2003 pode ser afetado durante a execução de software de mecanismo de pesquisa de área de trabalho no Outlook ou em outros computadores cliente MAPI" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184).

    • Blog da equipe do Microsoft Exchange, "Seus clientes estão usando mecanismos de pesquisa de área de trabalho que indexam caixas de correio ou pastas públicas do Exchange?" (http://go.microsoft.com/fwlink/?LinkId=54475).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).


SystemPages definido muito alto
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-03-13

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor de SystemPages:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Se o Exchange Server Analyzer verificar que o valor de SystemPages é maior do que 50000, o Exchange Server Analyzer exibirá um aviso.

O Microsoft Windows Server™ 2003 e o Microsoft Windows® 2000 Server podem atender diretamente até 4 GB (gigabytes) de espaço de endereçamento na memória, independentemente da quantidade física de RAM instalada. Do ponto de vista do processo, cada elemento do endereço virtual conceitualmente refere-se a um byte de memória física. É responsabilidade do VMM (Gerenciador de Memória Virtual), em conjunto com a MMU (unidade do gerenciador de memória) do processador, converter ou mapear cada endereço virtual em um endereço físico correspondente. O VMM executa o mapeamento dividindo a RAM em quadros de página de tamanho fixo, criando PTEs para armazenar informações sobre esses quadros de página e mapeando-os. As PTEs do sistema são pequenos buffers de memória no modo kernel que são usados para fazer a comunicação com o subsistema de E/S e a rede. Cada PTE representa um quadro de página e contém as informações necessárias para o VMM localizar uma página.

Em um sistema baseado em x86 que usa um tamanho de página igual a 4 KB, o número máximo de PTEs necessárias para mapear 2 GB de espaço de endereçamento é 524.288 (2 GB/4 KB). Em um sistema semelhante usando a opção de /3GB, o número de PTEs necessárias para mapear 3 GB de espaço de endereçamento é 786.432 (3 GB/4 KB). Em um sistema típico, esse espaço é usado como a seguir:

  • Um máximo de 50.000 PTEs (aproximadamente 195 MB de espaço de endereçamento) são reservadas para uso geral.

  • O restante é usado para mapear o cache de sistema, hiperespaço, pool paginado, pool não paginado, área de despejo de memória e assim por diante.

Esse tamanho de pool da PTE é automaticamente determinado na inicialização do sistema baseado na quantidade de memória física do sistema. Esta sondagem é espremida entre a sondagem paginada e a não paginada, que também cresce com a quantidade de memória física no sistema.

O pool da PTE do sistema pode tornar-se muito usado e muito fragmentado. Isso pode levar a situações em que uma unidade pode não ser carregada, e assim por diante. Além disso, se o pool da PTE do sistema estiver completamente vazio, outras partes do sistema serão prejudicadas, resultando em segmentos que não são criados, paralisações do sistema e falhas potenciais do sistema.

Para impedir que o pool da PTE do sistema se torne muito fragmentado, você deve sempre configurar o valor do Registro SystemPages adequadamente para o sistema operacional do computador do Exchange Server. Quando você está executando o Exchange Server no Windows Server 2003, é recomendável que você defina a chave do Registro SystemPages como 0. Essa recomendação contrasta com a recomendação para o Windows 2000 Server, que é a definição de SystemPages com um valor entre 24000 e 31000.

Depois de executar o procedimento descrito abaixo, você deve monitorar o número de PTEs de sistema livres. Isso é possível por meio do monitoramento do contador de desempenho Memória | Entradas de Tabela de Página Livres do Sistema com o Monitor de Desempenho do Windows (também conhecido como Monitor do Sistema). Se, depois de fazer a alteração de Registro descrita abaixo, o número de PTEs de sistema livres permanecer baixo, você deve verificar o seguinte para garantir que o computador do Exchange Server está configurado corretamente:

  • Drivers Um driver que não funciona corretamente é uma das causas mais comuns de PTEs de sistema baixas. Além disso, certas versões de drivers de placa de vídeo S3 Savage 4 são conhecidas por definirSystemPages como 208896. Esse driver é encontrado freqüentemente em servidores IBM E-Series. Consulte o fabricante do hardware para verificar se você está usando os drivers mais recentes para todos os seus hardwares. Além disso, pode haver oportunidades para rebaixar para um driver mais básico. Por exemplo, os computadores que executam aplicativos baseados em servidor como o Exchange Server geralmente não precisam de drivers de vídeo muito avançados com todos os recursos. Em vez disso, um driver mais básico geralmente é suficiente. A troca de um driver de vídeo avançado por um driver de vídeo básico deve aumentar o número de PETs de sistema livres.

  • Configuração do sistema Se seu sistema do Windows Server 2003 tiver 1 GB ou mais de memória física instalada, verifique se o arquivo Boot.ini está configurado corretamente com as opções /3GB e /USERVA=3030, como descrito nestes artigos da Base de Dados de Conhecimento Microsoft:

    • 823440, "Uso da opção /3GB no Exchange Server 2003 em um sistema com o Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

    • 810371, "XADM: Usando a Opção /Userva nos Servidores Exchange com base em Windows Server 2003 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371).

  • Logs de Eventos Verifique o log de eventos do aplicativo do Exchange Server em busca de erros e avisos, especialmente os eventos 9582 (erros e avisos), 9665 (avisos) e 12880 (erros) do MSExchangeIS. A presença do evento 9665 também pode indicar que SystemPages não está configurado para um desempenho ideal. Para obter mais informações sobre esses eventos, consulte o artigo 325044 da Base de Dados de Conhecimento, "COMO: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso no Windows 2000 Server alterando o valor de SystemPages

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. No painel da direita, clique duas vezes em SystemPages.

  4. No campo Dados do valor, digite um valor entre 24000 e 31000 (decimal) e clique em OK. Se você não tiver certeza de que valor usar, recomendamos usar 31000 (decimal).

  5. Feche o editor de Registro e reinicie o computador para que a alteração entre em vigor.

Para corrigir esse aviso no Windows Server 2003 alterando o valor de SystemPages

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. No painel da direita, clique duas vezes em SystemPages.

  4. No campo Dados do valor, digite 0 e clique em OK.

  5. Feche o editor de Registro e reinicie o computador para que a alteração entre em vigor.

Para corrigir esse aviso atualizando ou rebaixando o driver de vídeo

  • Siga um destes procedimentos:

    • Entre em contato com o fabricante do hardware para obter um driver de vídeo atualizado que não defina a configuração de SystemPages.

    • Rebaixe o driver de vídeo para uma driver VGA padrão e corrija o valor de SystemPages conforme descrito acima.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como otimizar a memória do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento:

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, "Os efeitos do ajuste do 4GT nas Entradas de Tabela de Página do Sistema" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


Porta HTTP do Atendedor do Sistema está abaixo de 5000
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-21

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a entrada do Registro a seguir para determinar a configuração HTTP Port para o Atendedor do Sistema do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

Se o Exchange Server Analyzer detectar que o valor de HTTP Port está definido com um valor abaixo de 5000 (decimal), um aviso será exibido.

A chave de Registro HTTP Port é definida como 6002 pela Instalação do Exchange Server 2003 e do Exchange Server 2007. A chave de Registro HTTP Port é utilizada para oferecer suporte à funcionalidade RPC sobre HTTP para o Microsoft Office Outlook® 2003 e o Microsoft Office Outlook 2007.

A menos que você tenha personalizado sua implantação RPC sobre HTTP com o auxílio dos Serviços de Consultoria da Microsoft ou por sugestão do Atendimento Microsoft, é recomendável implantar o RPC sobre HTTP com os valores de porta padrão.

Se for necessário definir HTTP Port como um valor diferente de 6002, recomenda-se defini-lo como um valor superior a 5000. A atribuição de números de porta estática em 5000 pode causar conflito de porta com outro processo e levar à falha do processo do Atendedor do Sistema do Microsoft Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir a chave de Registro da porta HTTP como seu valor padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Clique duas vezes na chave HTTP Port e defina o campo Dados do valor como 6002 (decimal) ou como um valor inteiro superior a 5.000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar RPC sobre HTTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 833401, "Como configurar RPC sobre HTTP em um único servidor no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "Como solucionar problemas de conexões cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Porta NSPI HTTP do Atendedor do Sistema está abaixo de 5000
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-21

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar a configuração Rpc/HTTP NSPI Port do serviço Atendedor do Sistema do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

Se o Exchange Server Analyzer detectar que o valor de Rpc/HTTP NSPI Port está definido como um valor abaixo de 5000 (decimal), um aviso será exibido.

A chave de Registro Rpc/HTTP NSPI Port é definida como 6004 pela Instalação do Exchange Server 2003 e do Exchange Server 2007. A chave de Registro Rpc/HTTP NSPI Port é utilizada para oferecer suporte à funcionalidade RPC sobre HTTP para o Microsoft Office Outlook® 2003 e o Microsoft Office Outlook 2007.

A menos que você tenha personalizado sua implantação de RPC sobre HTTP com o auxílio dos Serviços de Consultoria da Microsoft ou por recomendação do Atendimento Microsoft, é recomendável implantar o RPC sobre HTTP com os valores de porta padrão.

Se você precisar definir Rpc/HTTP NSPI Port como um valor diferente de 6004, é recomendável definir um valor superior a 5.000. Atribuir números de portas estáticas inferiores a 5.000 poderá causar um conflito de porta com outro processo e levar à falha do processo do Atendedor do Sistema do Microsoft Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir a chave do Registro da porta Rpc/HTTP NSPI para seu valor padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Clique duas vezes na chave Rpc/HTTP NSPI Port e defina o campo Dados do valor como 6.004 (decimal) ou um inteiro acima de 5.000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar RPC sobre HTTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 833401, "Como configurar RPC sobre HTTP em um único servidor no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "Como solucionar problemas de conexões cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Atendedor do Sistema:A porta HTTP NSPI é não-padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se a HTTP Port está definida com o valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

Se o Exchange Server Analyzer perceber que o valor de Rpc/HTTP NSPI Port não é 6004 (decimal), uma mensagem de configuração não-padrão será exibida.

A chave de Registro Rpc/HTTP NSPI Port é definida como 6004 pela Instalação do Exchange Server 2003. A chave de Registro Rpc/HTTP NSPI Port é usada para suportar RPC sobre a funcionalidade HTTP para o Microsoft Office Outlook® 2003.

A menos que você tenha personalizado sua implantação RPC sobre HTTP com o auxílio dos Serviços de Consultoria da Microsoft ou por sugestão do Atendimento Microsoft, é recomendável implantar o RPC sobre HTTP com os valores de porta padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir o valor do Registro da Porta Rpc/HTTP NSPI

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Clique duas vezes na chave Rpc/HTTP NSPI Port e defina o campo Dados do valor como 6004 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar RPC sobre HTTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 833401, "Como configurar RPC sobre HTTP em um único servidor no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "Como solucionar problemas de conexões cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Atendedor do Sistema:O valor da porta HTTP não é padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se a HTTP Port está definida com o valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

Se o Exchange Server Analyzer perceber que o valor de HTTP Port não é 6002 (decimal), uma mensagem de configuração não-padrão será exibida.

A chave de Registro HTTP Port é definida como 6002 pela Instalação do Exchange Server 2003 e do Exchange Server 2007. A chave de Registro HTTP Port é utilizada para oferecer suporte à funcionalidade RPC sobre HTTP para o Microsoft Office Outlook® 2003 e o Microsoft Office Outlook 2007.

A menos que você tenha personalizado sua implantação RPC sobre HTTP com o auxílio dos Serviços de Consultoria da Microsoft ou por sugestão do Atendimento Microsoft, é recomendável implantar o RPC sobre HTTP com os valores de porta padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir a chave de Registro da porta HTTP para seu valor padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Clique duas vezes na chave HTTP Port e defina o campo Dados do valor como 6002 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o computador para que esta configuração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar RPC sobre HTTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 833401, "Como configurar RPC sobre HTTP em um único servidor no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "Como solucionar problemas de conexões cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


O valor de legacyExchangeDN do atendedor do sistema está ausente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo legacyExchangeDN do objeto do Atendedor do Sistema em cada computador do Exchange Server. Se o Exchange Server Analyzer não detectar um valor para o atributo legacyExchangeDN de algum objeto do Atendedor do Sistema, exibirá uma mensagem de erro.

A ausência de um legacyExchangeDN pode ocorrer quando um administrador modifica o Active Directory para recuperar um banco de dados em uma situação de recuperação de falha. Para resolver esse erro, modifique o atributo legacyExchangeDN usando um editor do Active Directory, como a ferramenta LDP (ldp.exe) ou ADSI (Active Directory Service Interfaces) Edit.

Para ter certeza de que o atributo legacyExchangeDN está correto, examine também outros objetos do Atendedor do Sistema desse servidor ou de outro servidor do Exchange que não gera esse erro, pois devem ter um valor semelhante ao do atributo legacyExchangeDN.

Quando o atributo legacyExchangeDN estiver ausente em um banco de dados, provavelmente também estará ausente em outros objetos do sistema. Portanto, se você usar a ferramenta LDP ou o ADSI Edit para adicionar um novo valor igual a legacyExchangeDN, deverá adicionar também um novo valor igual a legacyExchangeDN em todos os outros objetos do sistema.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003, do Exchange Server 2007, ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse erro

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Expanda Configuração [DomainName], expanda CN=Configuration, DC=DomainName, DC=DomainSuffix.

  3. Expanda a entrada CN=Services e expanda CN=Microsoft Exchange.

  4. Expanda CN=OrganizationName, expanda CN=Administrative Groups e expanda CN=AdminGroupName.

  5. Expanda CN=Servers, expanda CN=ServerName.

  6. Clique com o botão direito em CN=Atendedor do Sistema Microsoft e selecione Propriedades.

  7. Role para localizar legacyExchangeDN, selecione-o e clique em Editar.

  8. No campo Valor, digite o legacyExchangeDN correto.

  9. Feche o editor do Active Directory e reinicie o computador com o Exchange Server para que a alteração entre em vigor.

Para obter mais informações sobre como usar o ADSI Edit para criar um novo atributo legacyExchangeDN, consulte o artigo 273863 da Base de Dados de Conhecimento da Microsoft, "Como alterar o atributo LegacyExchangeDN no modo nativo com o ADSI Edit" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863).


A porta NSPI do Atendedor do Sistema foi substituída manualmente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-17

A Ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas de Registro para determinar se o serviço do servidor de destino NSPI(Interface de Provedor de Serviço de Nome) foi substituído manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

Se o Exchange Server Analyzer verificar que TCP/IP NSPI Port está presente e configurado, uma mensagem de configuração não padrão será exibida.

O motivo mais comum desse valor estar configurado é habilitar clientes MAPI para conectarem-se a um servidor Exchange que está do outro lado de um firewall. Esse cenário requer a abertura de várias portas em um firewall para habilitar clientes do Microsoft Office Outlook® 2003 a se conectarem por meio do MAPI com um servidor Exchange, geralmente pela Internet.

A implantação recomendada para uso do Outlook no Modo Corporativo ou de Grupo de Trabalho para conexão com um servidor Exchange pela Internet é usar recursos de RPC (chamada de procedimento remoto) sobre HTTP encontrados no Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 e no Windows® XP Professional.

RPC sobre HTTP elimina a necessidade de usar uma conexão VPN (rede virtual privada) ou de abrir várias portas no firewall para permitir acesso MAPI do Outlook 2003 para o Exchange Server 2003. Um usuário que executa o Outlook 2003 pode se conectar a um servidor Exchange pela Internet. O cliente RPC estabelece a conexão da Internet canalizando o tráfego RPC através do protocolo HTTP. Se o cliente RPC puder fazer uma conexão HTTP/HTTPS com um computador remoto que esteja executando IIS (Serviços de Informação da Internet), esse cliente RPC poderá se conectar a qualquer servidor na rede remota. O servidor na rede remota deve estar configurado para ser acessível pela Internet, usando RPC sobre HTTP. Além disso, o cliente RPC e os programas de servidor RPC podem se conectar pela Internet, mesmo se ambos os programas estiverem atrás de firewalls em redes diferentes.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para remover a entrada do Registro da Porta NSPI TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Exclua o valor do Registro chamado TCP/IP NSPI Port.

  4. Saia do editor do Registro e reinicie o Serviço Atendedor do Sistema do Exchange.

Para implantar RPC sobre HTTP

  1. Consulte "Cenários de implantação de RPC sobre HTTP no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consulte o artigo 833401 da Base de Dados de Conhecimento da Microsoft, "Como configurar RPC sobre HTTP no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  3. Revise o artigo 827330 da Base de Dados de Conhecimento, "Como solucionar problemas de conexão cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  4. Consulte o Web Cast do Atendimento da Microsoft, "Usando o Microsoft Exchange na Internet (RPC/HTTP) com o Microsoft Outlook 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como usar o valor do Registro da Porta NSPI TCP/IP em um ambiente de firewall, consulte o artigo 270836 da Base de Dados de Conhecimento, "Mapeamentos de porta estática do Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


O serviço Atendedor do Sistema está configurado para interagir com a área de trabalho
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar o valor da propriedade DesktopInteract para o serviço de Atendedor do Sistema do Microsoft Exchange (MSExchangeSA). Se o Exchange Server Analyzer verificar que o serviço Atendedor do Sistema do Exchange está configurado para interagir com a área de trabalho, será exibido um erro.

Essa configuração deve ser usada somente sob orientação do Atendimento Microsoft. A menos que o Atendimento da Microsoft tenha instruído você a executar o serviço Atendedor do Sistema com essa configuração, recomendamos que você reconfigure as propriedades do serviço Atendedor do sistema para que ele não interaja com a área de trabalho.

Para configurar a conta de serviço do Atendedor do Sistema Exchange

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. Localize e interrompa o serviço Atendedor do Sistema do Microsoft Exchange. Observe que parar o serviço Atendedor do Sistema pára também todos os serviços que dependem dele. Isso inclui o serviço Armazenamento de Informações do Microsoft Exchange.

  3. Clique duas vezes no serviço Atendedor do Sistema do Microsoft Exchange.

  4. Na guia Logon da página Propriedades do Atendedor do Sistema do Microsoft Exchange, selecione Conta do Sistema Local em Fazer logon como.

  5. Desmarque a caixa de seleção Permitir que o serviço interaja com a área de trabalho e clique em Aplicar.

  6. Em Status do Serviço, clique em Iniciar e clique em OK.

  7. Feche o snap-in Serviços.

Para obter mais informações sobre a configuração correta do serviço do Exchange, consulte o artigo 239762 da Base de Dados de Conhecimento Microsoft, "Serviços do Exchange executados em LocalSystem" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


O serviço Atendedor do Sistema não está executando como LocalSystem
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-01-09

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar o valor da propriedade StartName para o serviço de Atendedor do Sistema do Microsoft Exchange (MSExchangeSA). A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para cada objeto do Exchange Server no diretório. O atributo serialNumber do objeto Exchange Server identifica a versão do Exchange Server em execução no computador representada pelo objeto. Se o Exchange Server Analyzer detectar que o serviço Atendedor do Sistema do Exchange está sendo executado em alguma conta que não a conta LocalSystem (SYSTEM) no servidor Exchange executando o Exchange 2000 Server, o Exchange Server 2003 ou o Exchange Server 2007, ele exibirá um erro.

Esse erro indica que o serviço do Atendedor do Sistema não está em execução em uma configuração com suporte. Se você executar o serviço Atendedor do Sistema em qualquer outra conta, provocará erros de permissão e de acesso.

Para resolver esse erro, configure o serviço Atendedor do Sistema do Exchange para iniciar na conta LocalSystem (SYSTEM).

Observação:
Esse erro não se aplica ao Exchange Server versão 5.5. Somente o Exchange 2000 Server, o Exchange Server 2003 e o Exchange Server 2007 exigem a execução do serviço Atendedor do Sistema do Exchange na conta LocalSystem.
Para configurar a conta de serviço do Atendedor do Sistema Exchange

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. Localize e pare o serviço Atendedor do Sistema do Microsoft Exchange. Observe que parar o serviço Atendedor do Sistema pára também todos os serviços que dependem dele. Isso inclui o serviço Armazenamento de Informações do Microsoft Exchange.

  3. Clique duas vezes no serviço Atendedor do Sistema do Microsoft Exchange.

  4. Na guia Logon da página Propriedades do Atendedor do Sistema do Microsoft Exchange, selecione Conta Sistema Local em Fazer logon como e clique em Aplicar.

  5. Em Status do Serviço, clique em Iniciar e clique em OK.

  6. Feche o snap-in Serviços.

Para obter mais informações sobre como executar os serviços do Exchange na conta LocalSystem, consulte o artigo 239762 da Base de Dados de Conhecimento Microsoft, "Serviços do Exchange Executam no LocalSystem" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


A chave TcpTimedWaitDelay está ausente ou não é padrão
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-03-13

A ferramenta Microsoft Exchange Analyzer Tool consulta o serviço de diretório do Active Directory para determinar o valor do atributo serialNumber para todos os objetos que tenham a classe msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 5.5", o computador estará executando o Exchange Server 5.5. Se o valor da cadeia de caracteres incluir "Version 6.0", o computador estará executando o Exchange 2000 Server. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador estará executando o Exchange Server 2003 e se incluir "Version 8.0", o computador estará executando o Exchange Server 2007.

Em seguida, a ferramenta Exchange Analyzer Tool lerá a ramificação do Registro mostrada abaixo para cada servidor do Exchange Server 2007 encontrado para determinar se o valor da chave TcpTimedWaitDelay está definido como o padrão 60.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

A chave TcpTimedWaitDelay determina quanto tempo é preciso esperar antes que o TCP possa liberar uma conexão fechada e reutilizar seus recursos. Esse intervalo entre o fechamento e a liberação é conhecido como estado TIME_WAIT ou 2MSL. Durante esse tempo, o custo da reabertura da conexão é muito mais baixo para o cliente e o servidor do que o custo do estabelecimento de uma nova conexão.

A redução do valor dessa entrada permite que o TCP libere conexões fechadas com mais rapidez, fornecendo mais recursos para novas conexões. No entanto, se o valor for muito baixo, o TCP poderá liberar os recursos da conexão antes de ela ser concluída. Isso exigirá que o servidor use recursos adicionais para restabelecer a conexão.

Se determinar que o valor da chave TcpTimedWaitDelay está ausente ou não é igual ao valor padrão 60, o Exchange Analyzer exibirá um aviso.

Para otimizar o desempenho, recomendamos que você defina o valor da chave TcpTimedWaitDelay como o padrão 60 nos servidores do Exchange Server 2007.

Importante:
Este tópico contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para definir a chave de Registro TcpTimedWaitDelay para seu valor padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Clique duas vezes na chave TcpTimedWaitDelay e defina o campo Dados do valor como 60 (decimal).

  4. Feche o editor de Registro e reinicie o computador.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Esse problema está relacionado ao problema do Analyzer A chave MaxUserPort está ausente ou não é padrão.

Para obter mais informações sobre o efeito das chaves de Registro MaxUserPort e TcpTimedWaitDelay, consulte o tópico "Protocolo TCP" no Windows 2000 Resource Kit (em inglês) (http://go.microsoft.com/fwlink/?LinkId=85654).


A variável TEMP/TMP parece apontar para uma pasta inválida ou inadequada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

Em um computador do Exchange Server sem cluster, a ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas de Registro para determinar o valor das variáveis de ambiente TEMP e TMP:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

O serviço Armazenamento de Informações do Microsoft Exchange usa as pastas TEMP e TMP como armazenamento temporário durante várias operações, como as operações de conversão de mensagens e de movimentação de caixas de correio. Em um servidor Exchange sem cluster, o serviço Armazenamento de Informações do Microsoft Exchange usa o SISTEMA (por exemplo, Sistema Local), que usa uma configuração de variável de ambiente padrão %Systemroot%\Temp para TEMP e TMP. Se uma ou ambas as variáveis de ambiente, TEMP ou TMP, do Exchange Server iniciarem com %SYSTEMROOT, será exibido um aviso.

As variáveis de ambiente TEMP e TMP são usadas para designar que pastas no sistema de arquivos (qual caminho) devem ser usadas pelos aplicativos que exigem um espaço de trabalho temporário. TEMP é geralmente usada pelos aplicativos, como o Microsoft Exchange, e TMP é freqüentemente usada por ferramentas de desenvolvimento, como o Microsoft Visual C++®. O caminho para cada variável geralmente é relativo ao contexto de segurança do aplicativo ou ferramenta.

Quando o Exchange Server Analyzer é executado em relação a um Servidor Virtual do Exchange em um cluster do Microsoft Windows Server™ 2003, o Exchange Server Analyzer não lê a árvore do Registro HKLM. Em vez disso, ele lê as seguintes entradas de Registro:

HKEY_USERS\<SID da conta de serviço de cluster>\Environment\TEMP

HKEY_USERS\<SID da conta de serviço de cluster>\Environment\TMP

Os Servidores Virtuais do Exchange em execução em um cluster do Windows Server 2003 usam as configurações de variáveis de ambiente para a conta de Serviço de Cluster, administradas sob o contexto de um princípio de segurança de usuário específico. Para contas de usuários, a variável de ambiente padrão para TEMP e TMP é definida como %Userprofile%\temp. Se uma ou ambas as variáveis de ambiente, TEMP ou TMP, do Servidor Virtual do Exchange iniciarem com %SYSTEMROOT, será exibido um aviso.

Para obter o desempenho ideal, é recomendável que você não use o disco que contenha o sistema operacional das pastas TEMP e TMP usadas pelo Exchange. Além disso, você deve certificar-se de que essas variáveis de ambiente são definidas para caminhos em um disco ou subsistema de disco rápidos, como um conjunto de eixos RAID 0+1. Também é recomendável que você não use o disco que contém o sistema operacional para as pastas TEMP e TMP usadas pelo Exchange ou pelos Servidores Virtuais do Exchange.

Para corrigir esse aviso

  1. Faça logon no computador do servidor Exchange com uma conta que possui direitos administrativos.

  2. Clique com o botão direito em Meu Computador e selecione Propriedades.

  3. Selecione a guia Avançado.

  4. Clique no botão Variáveis de Ambiente.

  5. Na área Variáveis do sistema, selecione TEMP e clique no botão Editar.

  6. No campo Valor da variável, digite o novo caminho para a variável de ambiente TEMP e clique em OK.

  7. Na área Variáveis do sistema, selecione TMP e clique no botão Editar.

  8. No campo Valor da variável, digite o novo caminho para a variável de ambiente TMP e clique em OK.

  9. Clique em OK para fechar a caixa de diálogo Variáveis de Ambiente e novamente em OK para fechar a caixa de diálogo Propriedades do Sistema.

  10. Reinicialize o nó para aplicar a alteração.

Para obter mais informações sobre como alterar as variáveis de ambiente TEMP/TMP em um servidor Exchange agrupado, consulte O caminho TEMP/TMP de cluster está localizado na mesma unidade que a partição do sistema.


Esse servidor tem 1 GB ou mais de memória física e o HeapDeCommitFreeBlockThreshold não foi definido como 262144
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-08-14

Mensagem de Erro

Introdução

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o Exchange foi ajustado de modo ideal, com base na quantidade de memória física existente no sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\HeapDeCommitFreeBlockThreshold

Se o Exchange Server Analyzer detectar que o valor de HeapDeCommitFreeBlockThreshold não foi definido em um computador do Exchange Server com 1 gigabyte (GB) ou mais de memória física instalada, será exibido um aviso.

Quando a memória é liberada em determinado endereço, o gerenciador de heap do sistema operacional verifica quantos bytes contíguos estão livres ao redor desse endereço. Após o término da verificação, o gerenciador de heap pode executar uma das duas ações a seguir:

  • Manter o bloco de memória contíguo confirmado.

  • Anular a confirmação do bloco de memória contíguo e marcá-lo apenas como reservado.

A chave de Registro HeapDeCommitFreeBlockThreshold especifica o número de bytes contíguos acima do qual a memória terá a confirmação anulada. Por padrão, o gerenciador de heap não combina necessariamente todos os blocos livres ou faz novas alocações; portanto, os blocos podem ter a confirmação anulada e se tornarem buracos inúteis no espaço de endereçamento virtual. Isso pode resultar na fragmentação da memória virtual, degradação do desempenho e, por último, na instabilidade do sistema.

Nos sistemas com 1 GB ou mais de memória física instalada, o desempenho é otimizado controlando o tamanho dos blocos de memória com confirmação anulada. A chave de Registro HeapDeCommitFreeBlockThreshold permite controlar o modo como a memória é manipulada quando liberada. Ao adicionar esse valor ao Registro, configure-o com um valor hexadecimal de 0x00040000 (262144 em notação decimal).

A Microsoft não aceita nenhum outro valor na chave de Registro HeapDeCommitFreeBlockThreshold, exceto um valor hexadecimal de 0x00040000 (262144 em notação decimal).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Control\Session Manager

  3. Crie um novo valor DWORD chamado HeapDeCommitFreeBlockThreshold.

  4. Clique duas vezes no valor de HeapDeCommitFreeBlockThreshold e digite um valor hexadecimal de 0x00040000 (262144 em notação decimal).

  5. Feche o editor do Registro e reinicie o computador do Exchange Server para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a chave de Registro HeapDeCommitFreeBlockThreshold, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 315407, "XADM: A chave de Registro "HeapDeCommitFreeBlockThreshold"" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=315407)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • 325044, "COMO FAZER PARA: Solucionar problemas de fragmentação da memória virtual no Exchange 2003 e no Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)


Este servidor está executando o Windows Server 2003 e o valor SystemPages não é igual a 0
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar a configuração do valor de SystemPages:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

O Exchange Server Analyzer também consulta a classe do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_OperatingSystem para determinar o valor da chave OSProductSuite. O valor dessa chave corresponde a uma versão específica de um sistema operacional Microsoft Windows.

Se o Exchange Server Analyzer descobrir que o valor de SystemPages não está definido como 0 em um computador com o Exchange Server que está executando o Microsoft Windows Server™ 2003 que não faz parte de uma instalação do Microsoft Windows Small Business Server 2003, um aviso será exibido.

Quando você estiver executando o Exchange Server 2003 Service Pack 1 (SP1) no Microsoft Windows Server 2003 com 1 GB ou mais de RAM, recomenda-se definir a chave de Registro SystemPages como 0. Essa recomendação contrasta com a recomendação para o Windows 2000 Server, que é definir SystemPages como um valor entre 24000 e 31000.

Em computadores com o Windows Server 2003 que não fazem parte de uma instalação do Microsoft Windows Small Business Server 2003, sempre defina o valor de Registro de SystemPages como 0. Alterar esse valor impede que o sistema calcule o valor ideal para seu sistema e ajuste esse valor quando o sistema é alterado.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Cuidado:
Se o valor de Registro de SystemPages for definido em computadores que estejam executando o Windows Server 2003, o tamanho máximo da reserva de memória paginável será menor. Isso pode resultar no esgotamento da reserva de memória paginável e na instabilidade do servidor.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. No painel direito, clique duas vezes em SystemPages.

  4. No campo Dados do valor, digite 0 e clique em OK.

  5. Saia do editor do Registro e reinicie o computador para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como otimizar a memória do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento:

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901, "Os efeitos do ajuste do 4GT nas Entradas de Tabela de Página do Sistema" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


Esse servidor Exchange tem a opção de inicialização /PAE definida no arquivo Boot.ini
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar quais opções estão definidas na propriedade SystemStartupOptions. O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar a contagem do atributo homeMDBBL do objeto de armazenamento de caixa de correio (msExchPrivateMDB). A conta resultante é o número de caixas de correio encontradas no computador do Exchange Server.

Se o Exchange Server Analyzer verificar que a opção de inicialização /PAE foi definida no arquivo boot.ini em um servidor Exchange com menos de 500 caixas de correio e está em execução no Windows 2000 Server, será exibido um aviso.

As PAE (Extensões de Endereço Físico) habilitam um computador a acessar mais de 4 GB de memória física (RAM). Não há suporte para PAE no Exchange Server. PAE permite que o Windows acesse mais de 4 GB (gigabytes) de memória física. O Exchange Server não pode usar mais de 4 GB de memória física e não há vantagem alguma em instalar mais de 4 GB de RAM em um computador dedicado à execução do Exchange Server. O PAE é habilitado quando a opção de inicialização /PAE está presente no arquivo Boot.ini.

Para corrigir esse aviso apenas no Windows 2000, é recomendável que você remova a opção /PAE do arquivo Boot.ini.

Para corrigir esse aviso

  1. No Windows Explorer, navegue até a partição Sistema. Essa é a partição que armazena arquivos específicos do hardware, como o Boot.ini e o NTLDR.

  2. Se você não encontrar o arquivo Boot.ini, é provável que as Opções de Pasta estejam definidas com Ocultar arquivos protegidos do sistema operacional. Se for esse o caso, clique em Ferramentas na janela do Explorer, clique em Opções de Pasta e clique em Exibir. Clique em Mostrar pastas e arquivos ocultos. Desmarque a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado). Quando solicitado, clique em Sim.

  3. Quando o arquivo Boot.ini estiver visível no Windows Explorer, clique com o botão direito no arquivo, clique em Abrir com e clique em Bloco de Notas para abri-lo.

  4. Na seção [Sistemas Operacionais], remova a opção /PAE.

  5. Salve e feche o arquivo, e reinicie o computador do Exchange Server para que a alteração entre em vigor.

Para obter mais informações sobre a opção /PAE em Boot.ini, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 268363: "PAE (Extensões de Endereço Físico) da Intel no Windows 2000"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: "Uso de Memória do Exchange e Opção /3GB"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)


Este servidor Exchange está em execução com Extensões de Endereço Físico habilitadas
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-05-08

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_OperatingSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar os valores para as seguintes chaves:

  • PAEEnabled O valor desta chave indica se a PAE (Extensão de Endereço Físico) está habilitada. O valor True indica que a PAE está habilitada e o valor False indica que a PAE não está habilitada.

  • Version O valor desta chave indica a versão do sistema operacional Microsoft Windows em execução no computador. Um valor 5.0.2195 indica que o sistema operacional Microsoft Windows 2000 Server está sendo executado e um valor 5.2.3790 indica que o sistema operacional Microsoft Windows Server™ 2003 está sendo executado.

  • ServicePackMajorVersion O valor desta chave indica o número da versão principal do service pack do Windows instalado.

O Exchange Server Analyzer também consulta a classe CIM_Datafile do WMI em busca da menor versão do ntoskrnl.exe em execução no sistema a fim de determinar se a atualização de segurança MS04-032 está instalada no computador. Se a menor versão do ntoskrnl.exe for 174 ou inferior, ela indicará que a MS04-032 não está instalada. Se a menor versão do ntoskrnl.exe for superior a 174, ela indicará que a MS04-032 está instalada.

Se o Exchange Server Analyzer encontrar o valor de PAEEnabled definido como True para um Exchange Server em execução no Windows Server 2003 que não possui a atualização de segurança MS04-032 instalada, será exibido um erro. Esse erro indica que o computador está suscetível a um problema conhecido que pode causar falha no serviço Armazenamento de Informações do Microsoft Exchange (Store.exe).

O Exchange Server não utiliza a PAE. PAE permite que o Windows acesse mais de 4 GB (gigabytes) de memória física. O Exchange Server não pode usar mais de 4 GB de memória física e não há vantagem alguma em instalar mais de 4 GB de RAM em um computador dedicado à execução do Exchange Server. A PAE está habilitada quando a opção de inicialização /PAE está presente no arquivo Boot.ini durante a inicialização ou quando o sistema operacional Windows Server 2003 detecta dispositivos de inclusão de memória a quente. O Windows Server 2003, Enterprise Edition, e o Windows Server 2003, Datacenter Edition, habilitam automaticamente a PAE somente se o servidor estiver usando dispositivos de inclusão de memória a quente.

Para corrigir esse erro instalando a atualização MS04-032

  1. Para obter a atualização MS04-032, consulte o artigo 840987 da Base de Dados de Conhecimento Microsoft, "MS04-032: Atualização de segurança para Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=840987) (página em inglês).

  2. Faça o backup completo do sistema.

  3. Aplique a atualização e reinicie o computador para que a atualização tenha efeito.

Para obter mais informações sobre a PAE, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 268363: "PAE (Extensões de Endereço Físico) da Intel no Windows 2000"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: "Uso de Memória do Exchange e Opção /3GB"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

Para obter mais informações sobre a opção /NOPAE no Boot.ini, consulte o artigo do MSDN, "/nopae" (http://go.microsoft.com/fwlink/?LinkId=51490).


Esse servidor Exchange está executando com Extensões de Endereço Físico habilitadas e Opção de Inicialização /3GB
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_OperatingSystem para determinar o valor da chave PAEEnabled. O valor dessa chave indica se a PAE (Extensão de Endereço Físico) está habilitada. O valor True indica que a PAE está habilitada e o valor False indica que a PAE não está habilitada. O Analisador do Exchange Server também consulta a classe WMI Win32_OperatingSystem (Instrumentação de Gerenciamento do Microsoft Windows®) para conhecer o valor da chave MaxProcessMemorySize.

Se o Exchange Server Analyzer detectar o valor de PAEEnabled igual a True e o valor de MaxProcessMemorySize acima de 2097024, será exibido um aviso. Esse aviso indica que esses não são os valores padrão. O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre a PAE, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 268363: "PAE (Extensões de Endereço Físico) da Intel no Windows 2000" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: "Uso da memória no Exchange e a opção /3GB" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


Esse servidor Exchange está em execução com as opções de Inicialização /PAE e /3GB
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_ComputerSystem para determinar quais opções estão definidas na chave SystemStartupOptions. O Analisador do Exchange Server também consulta a classe WMI Win32_OperatingSystem (Instrumentação de Gerenciamento do Microsoft Windows®) para conhecer o valor da chave MaxProcessMemorySize.

Se o Analisador do Exchange Server detectar que o valor da chave SystemStartupOptions inclui/PAE, o valor Win32_OperatingSystem indicará Microsoft Windows 2000 Server e o valor de MaxProcessMemorySize for maior do que 2.097.024, será exibido um erro.

Esse erro indica que as opções de inicialização /PAE e /3GB foram definidas no arquivo Boot.ini. PAE (Extensões de Endereço Físico) habilita um computador a acessar mais de 4 GB (gigabytes) de memória física (RAM). Não há suporte para PAE no Exchange Server. O Exchange Server não pode usar mais de 4 GB de memória física e não há vantagem alguma em instalar mais de 4 GB de RAM em um computador dedicado à execução do Exchange Server. O PAE é habilitado quando a opção de inicialização /PAE está presente no arquivo Boot.ini na inicialização.

Para corrigir esse erro somente no Windows 2000 Server, recomenda-se remover a opção /PAE do arquivo Boot.ini.

Para corrigir esse erro

  1. No Windows Explorer, navegue até a Partição do Sistema. Essa é a partição que armazena arquivos específicos do hardware, como o Boot.ini e o NTLDR.

  2. Se você não encontrar o arquivo Boot.ini, é provável que as Opções de Pasta estejam definidas com Ocultar arquivos protegidos do sistema operacional. Se for o caso, na janela do Windows Explorer, clique em Ferramentas, clique em Opções de Pasta e em Exibir. Clique em Mostrar pastas e arquivos ocultos. Desmarque a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado). Quando solicitado, clique em Sim.

  3. Quando o arquivo Boot.ini estiver visível no Windows Explorer, clique com o botão direito no arquivo, clique em Abrir com e clique em Bloco de Notas para abri-lo.

  4. Na seção [Sistemas Operacionais], remova a opção /PAE.

  5. Salve e feche o arquivo, e reinicie o computador do Exchange Server para que a alteração entre em vigor.

Para obter mais informações sobre a opção /PAE do arquivo Boot.ini, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 268363, "PAE (Extenções de Endereço Físico) Intel no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363).

  • 328882, "Uso da memória no Exchange e a opção /3GB" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).


Esse servidor front-end está configurado com o serviço de atualização de destinatário
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchAddressListServiceLink de cada objeto Recipient Update Service no diretório. O atributo msExchAddressListServiceLink é um link do serviço de lista de endereços para um computador do Exchange Server que está executando o RUS (Serviço de Atualização de Destinatário). O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O Exchange Server está configurado como servidor front-end.

  • O computador do Exchange Server está executando o Serviço de Atualização de Destinatário.

O Serviço de Atualização de Destinatário é um componente do serviço Atendedor do Sistema do Exchange. O Serviço de Atualização de Destinatário cria e mantém valores de atributo específicos do Exchange no Active Directory. Se você criar uma caixa de correio para um usuário, o Serviço de Atualização de Destinatário será responsável por gerar automaticamente o endereço SMTP e qualquer outro endereço de proxy que tiver sido definido nas diretivas de destinatário.

Quando um servidor Exchange configurado para usar o Serviço de Atualização de Destinatário também está configurado como front-end, os objetos recém-criados do usuário não são processados pelo Serviço de Atualização de Destinatário. O resultado é que os objetos do usuário podem não receber emails e os destinatários não são exibidos na lista de endereços). Além disso, atualizações no catálogo de endereços offline não são processadas.

Se você receber essa mensagem, significará que o Serviço de Atualização de Destinatário está sendo executado em um servidor Exchange configurado como front-end.

Para corrigir esse erro

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Em Destinatários, clique em Serviços de Atualização de Destinatário. No painel direito, clique com o botão direito na instância apropriada do Serviço de Atualização de Destinatário e clique em Propriedades.

  3. Na guia Geral, em Exchange Server, clique em Procurar e especifique um novo servidor para executar essa instância do RUS.

  4. Clique em OK e clique em OK novamente para que a alteração entre em vigor.

Para obter mais informações sobre o Serviço de Atualização de Destinatário, consulte o tópico e os artigos da Base de Dados de Conhecimento Microsoft a seguir:

  • 328738, "Como o Serviço de Atualização de Destinatário aplica as diretivas de destinatário" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738).

  • 253828, "Como o Serviço de Atualização de Destinatário preenche as listas de endereços" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828).

  • 246127, "Como verificar o progresso do Serviço de Atualização de Destinatário do Exchange" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127).

  • 253770, "XADM: Tarefas executadas pelo Serviço de Atualização de Destinatário" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770).


Há uma discrepância com o nome do servidor Exchange entre o Registro e o Active Directory
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-12-03

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço do diretório Active Directory® para determinar o valor armazenado no Active Directory para o nome do servidor Exchange (CN=<ExchangeServerName>). Depois de recuperar esse nome, o Analisador do Exchange Server conta o número de caracteres no nome.

O Exchange Server Analyzer também lê a seguinte entrada do Registro para determinar o valor armazenado no Registro do computador do Exchange Server para o nome de host do servidor Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

Além disso, o Analisador do Exchange Server consulta também a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar o valor da chave Started para ClusSvc, o serviço de Cluster.

Se o Analisador do Exchange Server determinar que os seguintes critérios são todos verdadeiros, será exibido um erro:

  • O valor de CN=<ExchangeServerName> não corresponde ao valor de Hostname.

  • O nome do servidor Exchange contém 15 caracteres ou menos.

  • O servidor Exchange não está sendo executado em um cluster do Windows.

A causa mais comum desse erro é que o nome do servidor Exchange foi alterado. A alteração do nome dessa forma altera o nome no Registro do computador e altera o nome da conta do computador no Active Directory, mas não altera as muitas referências ao nome do servidor Exchange encontradas nos atributos e objetos do Exchange no Active Directory.

Observação:
Alguns softwares de terceiros também alteram o nome do computador para fornecer funcionalidade de agrupamento. Se você estiver usando esses softwares, talvez tenha que ignorar esse problema.

A renomeação de um computador do Exchange Server não tem suporte e sabe-se que causa problemas, como falha ao iniciar o serviço de Atendedor do Sistema do Microsoft Exchange depois da alteração do nome. Se o computador do Exchange Server renomeado parecer não estar funcionando corretamente em todos os aspectos, é possível remover manualmente o Exchange Server do computador usando o processo de remoção manual descrito neste artigo. Se o computador do Exchange Server renomeado parece estar funcionando corretamente em todos os aspectos, reconstrua o servidor Exchange usando o procedimento de reconstrução abaixo, pois esta é uma configuração que não tem suporte e pode causar problemas no futuro.

Para corrigir esse erro executando uma remoção manual do Exchange Server

  1. Pare todos os serviços do Exchange Server e faça o backup completo do computador.

  2. Dependendo da versão do Exchange Server que estiver sendo executada, consulte o seguinte artigo da Base de Dados de Conhecimento da Microsoft:

    • Se você estiver executando o Exchange Server 2007, siga o procedimento descrito na documentação do Exchange Server 2007, "Como remover completamente o Exchange 2007 de um servidor" (http://go.microsoft.com/fwlink/?LinkId=79246).

    • Se você estiver executando o Exchange Server 2003, siga o procedimento descrito no artigo 833396 da Base de Dados de Conhecimento, "Como remover o Exchange Server 2003 do computador" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396).

    • Se estiver executando o Exchange Server 2000, siga o procedimento descrito no artigo 260378 da Base de Dados de Conhecimento, "Como remover o Exchange Server 2000 do computador" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396).

  3. Se estiver executando o Exchange 2000 Server ou o Exchange Server 2003 e este for o único servidor Exchange da organização, siga o procedimento descrito no artigo 273478 da Base de Dados de Conhecimento, "Como remover completamente o Exchange 2000 ou o Exchange 2003 do Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273478).

Para corrigir esse erro por meio da reconstrução do computador do Exchange Server

  1. Mova caixas de correio, pastas públicas, conectores e funções para outro computador do Exchange Serve da organização.

  2. Desinstalar o Exchange Server do computador.

  3. Para limpar o Registro de um computador que esteja executando o Exchange Server 2003 ou Exchange Server 2000, siga as seções de limpeza de Registro dos procedimentos descritos nos seguintes artigos da Base de Dados de Conhecimento Microsoft:

    • 833396, "COMO FAZER: Solucionar problemas de transporte do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

    • 260378, "COMO FAZER: Solucionar problemas de transporte do Exchange Server 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

    Como alternativa, você pode reconstruir o sistema operacional.

  4. Instale o Exchange Server no computador.

  5. Mova caixas de correio, pastas públicas, conectores e funções para o computador recém-construído do Exchange Server.

Para obter mais informações sobre como implantar o Exchange Server 2003 em clusters, consulte o artigo 810986 da Base de Dados de Conhecimento da Microsoft, "Diretiva de suporte da Microsoft para instalações do Exchange Server que estão executando com um serviço de Cluster de terceiros" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810986).


Há uma discrepância com o nome do servidor Exchange no Active Directory
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-12-03

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo Name e o atributo cn de um servidor (objeto de classe msExchExchangeServer) são correspondentes. Se a ferramenta verificar que esses atributos são diferentes, uma mensagem de erro será exibida.

O Exchange usa o valor cn do objeto do servidor para identificar o servidor internamente. Ele usa o valor Name para identificar o servidor na interface do usuário do Gerenciador do Sistema do Microsoft Exchange.

Esse erro pode ocorrer se um administrador tiver alterado o valor Name usando uma ferramenta como a ADSI Edit ou LDP (ldp.exe). Embora essa ação não altere o nome do servidor na interface do usuário, ela cria uma discrepância que gera eventos do atendedor do sistema e de armazenamento. Você deve corrigir o valor usando uma ferramenta como o snap-in ADSI Edit, LDP (ldp.exe) ou qualquer outro cliente do protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou do Exchange Server 2007 ou de ambos. Modifique os atributos do objeto do Active Directory a seu próprio risco.

Para corrigir esse erro

  1. No ADSI Edit ou em uma ferramenta semelhante, localize o objeto do servidor no Active Directory.

    É possível encontrar os atributos CN e Name em:

    Código da Cópia
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server

  2. Para o atributo Name, digite um novo valor de cadeia de caracteres que corresponda ao valor do atributo CN.

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como funciona o ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda do Windows Server.


Existe mais de uma rede entre o servidor do Active Directory e esse servidor Exchange
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) WIN32_PingStatus no namespace root\cimv2 para obter o valor da chave RouteRecord. A chave RouteRecord contém um registro de saltos intermediários (por exemplo, o número de roteadores) entre o servidor Exchange e o controlador de domínio. O Analisador do Exchange Server obtém uma contagem do número de roteadores listados na chave RouteRecord. Se o Analisador do Exchange Server detectar mais de um roteador listado, será exibido um erro.

Um serviço de diretório perfeito do Active Directory® é aquele cujo design assegura que o computador do Exchange Server possa se comunicar com um controlador de domínio ou servidor de catálogo global em sua sub-rede. Esse erro indica que o computador do Exchange Server está se comunicando com os controladores de domínio em redes que se encontram a mais de um salto de distância.

Para corrigir esse erro

  1. Verifique a topologia de sua rede e reavalie a disposição dos servidores do Active Directory.

  2. Monitore os logs de evento no Exchange Server e no controlador de domínio para verificar se foram registrados em log eventos relacionados à rede que indiquem possíveis problemas.

  3. Investigue o design do site do Active Directory. Se a rede não estiver particionada de acordo com esta especificação, experimente particioná-la em mais sites do Active Directory.

Para obter mais detalhes sobre a classe WMI Win32_PingStatus, consulte o artigo da MSDN, "Win32_PingStatus" (http://go.microsoft.com/fwlink/?linkid=33549).

Para obter mais informações sobre o design do site do Active Directory, consulte "Projetando a Topologia do Site" em http://go.microsoft.com/fwlink/? linkid=33551.


Excesso de saltos
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-07-06

A Ferramenta Microsoft® Exchange Server Analyzer envia uma mensagem de teste a partir do servidor Exchange para a conta do Postmaster ou uma conta definida por usuário no domínio do protocolo SMTP e verifica os logs de controle de mensagens do servidor para determinar se ocorreu algum problema na entrega da mensagem de teste.

Como parte desta verificação, o Exchange Server Analyzer consulta a propriedade MessageID para a classe Exchange_MessageTrackingEntry do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) sob o namespace root\MicrosoftExchangeV2 para cada servidor por onde a mensagem passa.

Uma mensagem pode ser roteada por meio de diversos servidores SMTP diferentes antes de chegar ao seu destino final. Cada servidor nesta rota é chamado de salto.

Se o número de ocorrências de Exchange_MessageTrackingEntry para uma MessageID específica aumentar para 30, o Exchange Server Analyzer exibirá uma mensagem de erro.

Este erro indica que a mensagem de teste pode estar percorrendo um loop. No entanto, o Exchange Server Analyzer parou de consultar ocorrências de Exchange_MessageTrackingEntry adicionais como uma medida de precaução contra uma possível situação de loop infinito.

Uma análise adicional da seção Log de Controle de Mensagens da saída do Exchange Server Analyzer pode ajudar a determinar se existe uma condição de loop.


Configuração de máquina virtual sem suporte - Exchange Server agrupado detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-12-15

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o valor da chave Model está definido como "Virtual Machine".

O Exchange Server Analyzer consulta também a classe Win32_Service WMI para determinar o valor da chave Started para ClusSvc, o serviço de Cluster do Windows. Um valor de Verdadeiro para a chave Started indica que o serviço de Cluster está iniciado e um valor de Falso indica que o serviço de Cluster não está iniciado.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O valor da chave Model está definido como "Virtual Machine".

  • O valor da chave Started do serviço de Cluster está definido como Verdadeiro.

Esse erro indica que o servidor Exchange é um servidor Exchange agrupado que está executando em um ambiente de máquina virtual. Não há suporte para essa configuração.

Para corrigir esse erro

  1. Construa um cluster físico e mova as caixas de correio para o cluster físico a partir do servidor Exchange agrupado que está executando no ambiente virtual.

  2. Se você não puder construir um cluster físico, poderá corrigir esse erro da seguinte maneira:

    1. Mova as caixas de correio do Exchange Server que está executando no ambiente virtual para um computador Exchange Server autônomo e não virtual.

    2. Relocalize quaisquer pastas públicas e transfira todas as funções executadas pelo servidor Exchange agrupado, conforme for necessário.

    3. Desinstale o Exchange Server da máquina virtual para descomissioná-la e removê-la da infra-estrutura do Exchange Server e do Active Directory.

Para obter mais informações sobre a diretiva de suporte da Microsoft para executar o Exchange Server 2003 em ambientes virtuais, consulte o artigo 320220 da Base de Dados de Conhecimento da Microsoft, "Diretiva de suporte para o Exchange Server 2003 executando no software de virtualização de hardware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).


Configuração de máquina virtual sem suporte - Exchange Server 2003 Service Pack 2 ou posterior não detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-12-15

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o valor da chave Model está definido como "Virtual Machine".

O Analisador do Exchange Server também consulta o serviço de diretórios do Active Directory® para determinar o valor do atributo serialNumber de todos os objetos que tenham a classe msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 5.5", o computador está executando o Exchange Server 5.5. Se o valor da cadeia de caracteres contiver "Versão 6.0", o computador estará executando o Exchange 2000 Server. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador estará executando o Exchange Server 2003. Se esse valor contiver "Version 6.5" e "Service Pack 2", o computador estará executando o Exchange Server 2003 com Service Pack 2 (SP2).

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • A chave Model está definida como "Virtual Machine ".

  • O computador não está executando o Exchange Server 2003 with SP2 ou versão posterior.

Esse erro indica que o servidor Exchange é uma máquina virtual, mas que o Exchange Server 2003 SP2 ou uma versão posterior não estão instalada. Não há suporte para essa configuração.

Para corrigir esse erro

  1. Instale o Service Pack 2 ou uma versão posterior do Exchange Server 2003.

  2. Revise o artigo 320220 da Base de Dados de Conhecimento da Microsoft, "Diretiva de suporte para o Exchange Server 2003 executando em software de virtualização de hardware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

  3. Se não for possível aplicar o Service Pack 2 ou uma versão posterior, corrija esse erro como descrito a seguir:

    1. Mova as caixas de correio do Exchange Server que está sendo executado no Virtual Server 2005 para um computador do Exchange Server que não seja virtual.

    2. Realoque todas as pastas públicas e transfira todas as funções executadas pelo servidor virtual Exchange conforme necessário.

    3. Desinstale o Exchange Server da máquina virtual para descomissioná-la e removê-la da infra-estrutura do Exchange Server e do Active Directory.


Configuração de máquina virtual sem suporte - não foram detectadas adições à máquina virtual
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-12-15

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o valor da chave Model está definido como "Virtual Machine".

O Exchange Server Analyzer lê também a entrada de Registro a seguir para determinar se foram instaladas adições de máquina virtual:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

A presença desse caminho de Registro indica que foram instaladas adições de máquina virtual. Se esse caminho de Registro não estiver presente, significará que não foram instaladas adições de máquina virtual.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O valor da chave Model está definido como "Virtual Machine".

  • O caminho de Registro não está presente.

Esse erro indica que o servidor Exchange é uma máquina virtual, mas não foram instaladas adições. Não há suporte para essa configuração.

Para instalar adições de máquina virtual

  1. Faça backup do Exchange Server que está sendo executado no ambiente virtual.

  2. Instale as Adições de Máquina Virtual usando o console administrativo ou o site do Virtual Server 2005.

Para obter mais informações sobre como executar o Exchange Server 2003 em um ambiente virtual, consulte o artigo 320220 da Base de Dados de Conhecimento da Microsoft, "Diretiva de suporte do Exchange Server 2003 sendo executado em software de virtualização de hardware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).


Atualização para Horário de Verão Disponível
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-07-30

A ferramenta Microsoft Exchange Analyzer Tool consulta o serviço de diretório do Active Directory para determinar o valor do atributo versionNumber de cada objeto do Exchange Server. O atributo versionNumber representa a versão do Exchange Server que está sendo executada no computador.

O Exchange Analyzer também consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile para determinar o valor da chave Version do processo Store.exe.

  • Um valor igual a 7638 para a chave Version indica o Exchange Server 2003 Service Pack 2

  • Um valor igual a 7226 para a chave Version indica o Exchange Server 2003 Service Pack 1

  • Um valor de 6944 para a chave Version indica a versão original do Exchange Server 2003

  • Um valor entre as versões acima indica que o servidor está executando uma versão atualizada do hotfix do processo Store.exe.

Se o Exchange Analyzer determinar que a chave Version para Store.exe em um servidor executando o Exchange Server 2003 SP2 tem valor menor que 7561 ou que um servidor executando o Exchange Server 2003 SP1 tem valor menor que 7234, um aviso é exibido.

Esse aviso indica que o computador do Exchange Server está executando o Exchange Server 2003 Service Pack 1 ou o Exchange Server 2003 SP2 sem a atualização para as alterações de horário de verão em 2007.

Sem esta atualização, os itens de calendário em programas baseados em CDO e no Outlook Web Access irão operar como se a hora oficial estivesse em vigor durante as semanas extras de horário de verão.

Para corrigir isto no Exchange Server 2003 SP2

  1. Siga as orientações do artigo 926666 da Base de Dados de Conhecimento Microsoft, "Atualização para alterações de horário de verão em 2007 para Exchange 2003 Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=926666)).
Para corrigir isto no Exchange Server 2003 SP1

  1. Siga as orientações do artigo 931978 da Base de Dados de Conhecimento Microsoft, "Atualização para alterações de horário de verão em 2007 para Exchange 2003 Service Pack 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=931978).


Atualização da Distribuição para Windows 2000 SP4 não instalada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave ServicePackMajorVersion. O Exchange Server Analyzer também examina a seguinte entrada do Registro para determinar a versão do Windows que está sendo executada no computador de destino:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se o Analisador do Exchange Server detectar que o sistema de destino está executando um sistema operacional Windows 2000 Server, mas não a Distribuição de Atualização para o o Windows 2000 Server Service Pack 4, será exibido um aviso.

Como prática recomendada, instale os últimos service packs e atualizações de todos os itens de software na implantação do Exchange.

Para corrigir esse aviso

  1. Atualize todos os controladores de domínio e servidores de catálogo global que estejam executando o Windows 2000 Server para a Distribuição de Atualização para Service Pack 4 e os últimos hotfixes e atualizações do Windows Update.

  2. Atualize todos os computadores do Exchange Server com a última distribuição e distribuição de atualização.

Para obter mais informações sobre a Distribuição de Atualização para Windows 2000 SP4, consulte o artigo 891861 da Base de Dados de Conhecimento da Microsoft, "Distribuição de atualização 1 para Windows 2000 SP4" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=891861).

Para mais informações sobre como obter e instalar o service packs e distribuições do Exchange Server, consulte o site do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21573).


O URLScan está instalado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-20

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o seguinte arquivo existe no local especificado do servidor Exchange:

%WINDOWSPATH%\\SYSTEM32\\INETSRV\URLSCAN\URLSCAN.DLL

A presença de Urlscan.dll indica que a ferramenta URLScan está instalada no servidor Exchange. Se o Exchange Server Analyzer detectar que a ferramenta URLScan está instalada em um servidor Exchange, será exibida uma prática recomendada.

URLScan é um filtro ISAPI que permite que administradores de sites da Web restrinjam o tipo de solicitações HTTP que o servidor processa. Ao bloquear solicitações HTTP específicas, o filtro URLScan impede consideravelmente que solicitações nocivas alcancem o servidor e ocasionem danos.

Ao executar o URLScan em um servidor Exchange, você deve se certificar de que o Urlscan.ini está ajustado para uma função do servidor Exchange. Para ajudar a aprimorar a segurança do servidor Exchange, edite o arquivo de configuração Urlscan.ini para remover qualquer funcionalidade irrelevante. Para personalizar o arquivo Urlscan.ini para uma função específica do seu computador do Exchange Server 2003, remova os verbos na seção [AllowVerbs] do arquivo Urlscan.ini. Porém, verifique se os verbos recomendados para a função do computador estão incluídos para se obter uma funcionalidade adequada. Se vários recursos baseados na Web forem exigidos em um único computador, você deverá mesclar os requisitos adequados da seção [AllowVerbs].

Você pode modificar o arquivo Urlscan.ini com base na função do computador do Exchange Server 2003 usando as informações do modelo Urlscan do Exchange Server 2003 incluído no artigo 823175 da Base de Dados de Conhecimento Microsoft, "Ajuste e problemas conhecidos durante o uso do utilitário Urlscan em um ambiente do Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823175) (página em inglês).

Para obter mais informações sobre o URLScan, consulte "Ferramenta de segurança do UrlScan" (http://go.microsoft.com/fwlink/?LinkId=24490) (página em inglês).

Para obter mais informações sobre como usar o URLScan em um ambiente do Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 309677, "XADM: Problemas conhecidos e ajustes ao usar o Assistente de Bloqueio do IIS em um ambiente do Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=309677) (página em inglês)

  • 309508, "Bloqueio do IIS e configurações do URLscan em um ambiente do Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=309508) (página em inglês)

  • 325965, "A ferramenta URLScan pode causar problemas no Outlook Web Access" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325965) (página em inglês)

  • 326444, "Como configurar a ferramenta URLScan" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326444) (página em inglês)


USERVA definido incorretamente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-09-19

A ferramenta Microsoft® Exchange Server Analyzer consulta três classes WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar a quantidade de memória física no computador do Exchange Server e a quantidade de espaço de endereçamento virtual alocado para os processos em modo de usuário em execução no computador do Exchange Server. A tabela a seguir descreve as classes e chaves que estão sendo calculadas pelo Exchange Server Analyzer.

Classe consultada | Chaves consultadas | Descrição
Win32_OperatingSystem | MaxProcessMemorySize | Número máximo de kilobytes de memória que pode ser alocado em um processo.
Win32_ComputerSystem | TotalPhysicalMemory | Número de bytes de memória RAM instalados no computador.
Win32_Service | Iniciado | Estado do serviço. Um valor Verdadeiro indica que o serviço está em execução e um valor Falso indica que ele não está em execução.

O Microsoft® Exchange Server Analyzer lê também a entrada do Registro a seguir para determinar a versão do Microsoft Windows em execução no computador do Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor CurrentVersion igual a 4.0 indica que o computador do Exchange Server está executando no Microsoft Windows NT® Server 4.0. Um valor igual a 5.0 indica que o computador do Exchange Server está executando o Windows 2000 Server e um valor igual a 5.2 indica que o computador do Exchange Server está executando o Windows Server™ 2003.

Finalmente, o Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar a conta do atributo homeMDBBL do objeto de armazenamento de caixa de correio (msExchPrivateMDB). A conta resultante é o número de caixas de correio encontradas no computador do Exchange Server.

Se o Exchange Server Analyzer determinar que todos os critérios a seguir são verdadeiros, um aviso será exibido:

  • O computador do Exchange Server está executando no Windows Server 2003.

  • O valor para TotalPhysicalMemory é maior que 1073741824.

  • O valor para MaxProcessMemorySize é igual a 3145600.

  • O serviço de Cluster (ClusSvc) tem um valor Win32_Service\Started igual a Verdadeiro ou o computador do Exchange Server contém mais de 20 caixas de correio.

Esse aviso indica que o computador do Exchange Server não está configurado da maneira ideal para o uso de memória virtual. Especificamente, o opção de inicialização /USERVA=3030 não está presente no arquivo Boot.ini do computador do Exchange Server. A adição dessa opção pode fornecer maior escalabilidade e melhor desempenho.

O Windows Server 2003 inclui suporte para duas opções de inicialização Boot.ini — /3GB e /USERVA — que permitem que você ajuste a alocação e uso da memória e o espaço de endereçamento de memória. Independentemente da quantidade de memória física do seu sistema, o Windows usa um espaço de endereçamento virtual de 4 GB (gigabytes), com 2 GB alocados para processos em modo de usuário (por exemplo, aplicativos) e 2 GB alocados para processos em modo kernel (por exemplo, drivers do sistema operacional e do modo kernel). Em sistemas com 1 GB ou mais de memória física, essas opções de inicialização podem ser usadas para alocar mais memória para aplicativos (3 GB) e menos memória para o sistema operacional (1 GB). Em um computador do Exchange Server, esse espaço de endereçamento virtual extra ajuda a reduzir a quantidade de fragmentação de memória no espaço de endereçamento virtual do processo de armazenamento de informações. A opção /3GB é usada para afetar essa alteração de alocação. A opção é inserida no arquivo Boot.ini no sistema e entra em vigor após uma reinicialização. Essa opção só deve ser usada em Exchange Servers com 1 GB (gigabyte) ou mais de memória que estejam executando qualquer um dos seguintes sistemas operacionais:

  • Microsoft Windows Server 2003, Standard Edition

  • Microsoft Windows Server 2003, Enterprise Edition

  • Microsoft Windows Server 2003, Datacenter Edition

Importante:
A opção /3GB não deve ser usada no Windows 2000 Server porque não é suportada e pode ocasionar falhas em aplicativos e no sistema operacional. Além disso, a opção /3GB só é suportada nos sistemas operacionais citados anteriormente, quando existir 1 GB de memória física instalada. Também, a opção /3GB não deve ser usada nos servidores Active Directory (controladores de domínio e servidores de catálogo global) em execução no Windows Server 2003, Standard Edition.

A opção /USERVA é novo no Windows Server 2003. O seu objetivo é fornecer um controle mais preciso sobre a divisão do espaço de endereçamento virtual entre processos de modo de usuário e modo kernel. Essa opção deve ser usada somente em aplicativos com suporte, como o Exchange Server 2003, e com valores específicos com suporte nesses aplicativos. Quando usado em sistemas Exchange Server 2003, a opção /USERVA sempre deve ser igual a 3030 (ou seja, /USERVA=3030). Esse valor proporciona um adicional de 40 MB a ser alocado para o sistema operacional e permite adicionar mais usuários sem consumir todos os recursos disponíveis do sistema.

Para corrigir esse aviso no Windows Server 2003

  1. Clique com o botão direito em Meu Computador e selecione Propriedades. A caixa de diálogo Propriedades do Sistema será exibida.

  2. Clique na guia Avançado.

  3. Na área Inicialização e Recuperação, clique em Configurações. A caixa de diálogo Inicialização e Recuperação será exibida.

  4. Na área Inicialização do sistema, clique em Editar. Isso abrirá o arquivo Boot.ini do Windows no Bloco de Notas.

  5. Na seção [Operating Systems] , adicione as seguintes opções na linha de inicialização: /3GB /USERVA=3030

  6. Salve as alterações e feche o Bloco de Notas.

  7. Clique em OK duas vezes para fechar as caixas de diálogo abertas e reinicie o computador para que as alterações entrem em vigor.

Para obter mais informações sobre o uso das opções de inicialização /3GB e /USERVA, consulte os seguintes artigos na Base de Dados de Conhecimento da Microsoft:

  • 297812, "Como usar o recurso de sintonização de RAM do 4GT" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812).

  • 311901, "Os efeitos do ajuste do 4GT nas Entradas de Tabela de Página do Sistema" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901) (em inglês).

  • 316739, "Como usar a opção /userva com a opção /3GB para ajustar o espaço Modo usuário para um valor entre 2GB e 3GB" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739).

  • 325044, "COMO FAZER PARA: Solucionar problemas de fragmentação da memória virtual no Exchange Server 2003 e Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372).


A versão do arquivo Tcpip.sys instalada nesse computador pode exigir um hotfix
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se há um valor definido para a chave Version do arquivo Tcpip.sys. Se o Exchange Server Analyzer considerar que o valor para a chave Version não corresponde a uma versão específica do arquivo Tcpip.sys, o Exchange Server Analyzer exibirá um aviso.

Para obter mais informações sobre este aviso, siga as recomendações do artigo 898060 da Base de Dados de Conhecimento Microsoft, "A instalação da atualização de segurança MS05-019 ou o Windows Server 2003 Service Pack 1 pode causar falhas na conectividade de rede entre clientes e servidores" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=898060).


Configuração de máquina virtual detectada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-12-15

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o valor da chave Model está definido como "Virtual Machine".

O Analisador do Exchange Server consulta também a classe Win32_Service para determinar o valor da chave Started para ClusSvc, o serviço do Windows Cluster. Um valor igual a Verdadeiro para a chave Started indica que o serviço do Cluster está iniciado. Um valor igual a Falso indica que o serviço do Cluster não está iniciado.

O Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para todos os objetos que tenham uma classe de objeto msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Versão 6.5" e "Service Pack 2", o computador estará executando o Exchange Server 2003 com Service Pack 2 (SP2).

Finalmente, o Analisador do Exchange Server lê a entrada do Registro a seguir para determinar se as adições da máquina virtual foram instaladas:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

A presença desse caminho de Registro indica que foram instaladas adições de máquina virtual. A ausência desse caminho do Registro indica que não foram instaladas as adições de máquina virtual.

O Exchange Server Analyzer exibe uma mensagem de prática recomendada se as seguintes condições forem verdadeiras:

  • O servidor Exchange está executando como um convidado no Microsoft Virtual Server 2005.

  • O servidor Exchange está executando o Exchange Server 2003 com Service Pack 2 ou uma versão posterior.

  • O servidor Exchange não está agrupado.

  • As adições de máquina virtual para o Virtual Server 2005 foram instaladas no servidor Exchange.

O Analisador do Exchange Server não pode detectar alguns requisitos existentes para executar nessa configuração. Portanto, recomendamos que você consulte o artigo a seguir para obter informações mais recentes sobre o ajuste de suporte e desempenho para essa configuração antes de executar o Exchange Server 2003 em um ambiente Virtual Server 2005:

artigo 320220 da Base de Dados de Conhecimento da Microsoft, "Diretiva de suporte para o Exchange Server 2003 em execução em software de virtualização de hardware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).


A memória virtual está fragmentada
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2007-02-15

A ferramenta Microsoft Exchange Analyzer Tool consulta a classe Win32_NTLogEvent de WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar se um erro Evento 9582 foi registrado para o MSExchangeIS nas últimas 24 horas.

Se o Exchange Analyzer detectar que um Evento 9582 foi registrado nas últimas 24 horas, ele exibirá um erro.

Esse erro indica que a memória virtual exigida para executar o servidor Exchange está fragmentada.

Em sistemas Microsoft Windows de 32 bits, há dois tipos de memória:

  • Memória física Quantidade de memória real instalada no sistema

  • Espaço de endereçamento da memória virtual Um espaço de memória virtualizada de 4 GB

Independentemente de quanta memória física esteja instalada no sistema, o tamanho total do espaço do endereço virtual é sempre o mesmo: 4 GB. Embora esse não seja o caso em todos os aplicativos de 32 bits, no Exchange Server, o espaço de endereçamento virtual é igual à memória virtual. Os termos são usados alternadamente.

No decorrer normal de suas operações, o armazenamento do Exchange alocará, usará e desalocará a memória virtual várias vezes. Quando a memória virtual é alocada, usada e desalocada freqüentemente, pode acontecer uma fragmentação de memória virtual. A fragmentação da memória virtual é semelhante à fragmentação do sistema de arquivos que pode ocorrer com o passar do tempo. Depois de um tempo, segmentos alocados da memória virtual não estão mais contíguos, e o desempenho começa a diminuir. No sistema de arquivos, você pode executar um aplicativo que execute a desfragmentação do sistema de arquivos. Na maioria dos casos, é possível fazer a desfragmentação enquanto o sistema está online e sendo acessado. Com a fragmentação de memória virtual, não há ferramenta de desfragmentação. Em vez disso, para corrigir o problema, é necessário parar e iniciar o serviço Armazenamento de Informações do Microsoft Exchange ou reiniciar o sistema.

Para tratar esse problema:

  • A fragmentação da memória virtual pode ser causada por software de terceiros que estão sendo executados nos processos store/inetinfo. Verifique se você tem os drivers mais recentes dos aplicativos de terceiros.

  • Use a ferramenta Alertas e Logs de Desempenho para monitorar o contador Total de bytes de bloco livre grande de MV para o objeto de desempenho do MSExchangeIS. Use a coleta de dados desse contador para determinar o melhor momento, durante as próximas 36 a 72 horas, para encerrar e reiniciar o servidor.

Observação:
Se esse for um servidor em cluster, pare e reinicie o nó passivo antes de mover os recursos do cluster para ele, a fim de se certificar de que o espaço de endereçamento de memória virtual de destino esteja limpo.
  • Se o problema tornar a ocorrer após o reinício, considere desabilitar o software de terceiros.

  • Considere mover as caixas de correio do usuário para outro servidor para reduzir a carga do servidor e ver se o problema desaparece. Para obter mais informações, consulte Mover Caixas de Correio de Usuário para Outro Servidor.

Para obter mais informações

  • Para obter mais informações sobre o Evento 9852 do MSExchangeIS, consulte o "Events and Errors Message Center: detalhes do evento" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=83209).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de Desempenho e Escalabilidade do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solução de problemas de desempenho do Microsoft Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre como solucionar problemas de fragmentação de memória virtual no Microsoft Exchange Server 2003 e no Exchange 2000 Server, consulte o artigo 325044 da Base de Dados de Conhecimento Microsoft, "Como solucionar problemas de fragmentação de memória virtual no Exchange Server 2003 e no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).

  • Para obter mais informações sobre como otimizar o uso de memória virtual, consulte o artigo 815372 da Base de Dados de Conhecimento Microsoft, "Como otimizar o uso de memória no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

  • Para obter mais informações sobre como mover caixas de correio do usuário para reduzir a carga do servidor, consulte Mover Caixas de Correio de Usuário para Outro Servidor.


Virtual Server 2005 R2 ou posterior não detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-12-15

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version para Vssrvc.exe, o processo representado pelo serviço de Servidor Virtual incluído no Microsoft Virtual Server 2005. Se o Exchange Server Analyzer verificar que o valor da chave Version para Vssrvc.exe é igual a 1.1.465.0, o Exchange Server Analyzer exibirá um erro.

Esse erro indica que esse servidor Exchange está sendo executado como convidado em um ambiente do Microsoft Virtual Server 2005 que não está executando o Virtual Server 2005 R2 ou versão posterior. Não há suporte para essa configuração. O Exchange Server 2003 com Service Pack 2 ou uma versão posterior só é suportado como convidado em um ambiente virtual quando ele é executado no Microsoft Virtual Server 2005 R2 ou versão posterior.

Para corrigir esse erro

  1. Revise o artigo 320220 da Base de Dados de Conhecimento da Microsoft, "Diretiva de suporte para o Exchange Server 2003 executando em software de virtualização de hardware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

  2. Instale o Microsoft Virtual Server 2005 R2 ou versão posterior. Para obter informações sobre o Microsoft Virtual Server 2005 R2, consulte o site do Microsoft Virtual Server 2005 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=34938).

  3. Se você não conseguir instalar o Virtual Server 2005 R2 ou versão posterior, você poderá corrigir esse erro da seguinte forma:

    1. Mova as caixas de correio do Exchange Server que estiver sendo executado no Virtual Server 2005 para um computador não virtual do Exchange Server ou para um computador virtual do Exchange Server que esteja sendo executado no Virtual Server 2005 R2.

    2. Relocalize quaisquer pastas públicas e transfira todas as funções executadas pelo servidor virtual Exchange sem suporte, conforme necessário.

    3. Desinstale o Exchange Server da máquina virtual sem suporte para descomissioná-la e removê-la da infra-estrutura do Exchange Server e do Active Directory.


O comprimento da fila de verificação de vírus excedeu o limite
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-27

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Virus Scan Queue Length do objeto de desempenho de MSExchangeIS para analisar os dados do desempenho.

Se o Exchange Server Analyzer determinar que o valor do 90º percentil para o contador Virus Scan Queue Length é maior que 10 durante o intervalo de tempo de amostragem, o Exchange Server Analyzer exibirá um erro.

O contador de desempenho do Virus Scan Queue Length indica o número atual de solicitações de verificação de vírus pendentes enfileiradas.

Esse erro pode indicar problemas de desempenho relacionados ao seguinte:

  • Desempenho reduzido do servidor, geralmente causado por um afunilamento da CPU.

  • Carga do servidor maior que a normal.

  • Um mecanismo de verificação de vírus desatualizado.

  • Um mecanismo de verificação de vírus configurado de maneira incorreta.

Para resolver esse erro, execute as seguintes etapas:

  • Procure atualizações para o mecanismo de vírus.

  • Considere a reinstalação do software de verificação de vírus.

  • Examine o mecanismo de verificação de vírus para a configuração correta de threads, exclusões de nível de arquivos etc. Consulte o artigo 823166 da Base de Dados de Conhecimento Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Use a ferramenta Monitor de Desempenho (Perfmon.msc) para descobrir se o afunilamento é causado por um aumento da carga no servidor ou se o servidor está subdimensionado. Se a carga do servidor aumentou, identifique a origem da carga e reduza-a. Se o servidor possui recursos insuficientes, aumente os recursos necessários ou mova usuários do servidor.

Removendo afunilamentos do processador

Há várias maneiras de remover afunilamentos do processador no servidor Exchange.

  • Primeiro, revise os aplicativos ou as tarefas que estão causando carga ao servidor. Determine se o aplicativo deve utilizar o tempo do processador que está usando ou se pode haver um problema com o processo.

  • Se um aplicativo não-Exchange não for importante para esse servidor, execute-o em outro servidor. Se você puder executar esse aplicativo em outro servidor, mova as funções do servidor para outros computadores também. Por exemplo, se o processo Inetinfo estiver usando intensamente a CPU, experimente adicionar servidores front-end para se encarregar do trabalho de protocolo realizado pelo Inetinfo. Também é possível mover o acesso às pastas públicas para um servidor de pastas públicas dedicado. Por último, se um servidor executa muitas expansões da lista de distribuição, você pode reduzir o uso da CPU, deslocando a expansão da lista de distribuição para um servidor de expansão de lista de distribuição dedicado.

  • Se possível, adicione mais processadores ou processadores mais rápidos ao servidor. Além disso, habilite a hyper-threading se houver suporte para essa tecnologia nos processadores. Você pode habilitar a hyper-threading configurando a BIOS do sistema. Para obter mais informações, consulte a documentação da Ajuda do fabricante do computador.

  • Se o aumento da força de processamento não for uma opção viável, reduza a carga sobre os processadores. Para reduzir o impacto global sobre o servidor, certifique-se de que as tarefas de alta utilização de E/S, da CPU ou que usam muita memória ocorram fora do horário do expediente normal.

  • Assegure-se de que as tarefas de alta utilização da CPU, como backup e manutenção, ocorram fora do horário de pico. Além disso, certifique-se de que essas tarefas são executadas em etapas. Preparar uma tarefa significa definir diferentes horas de início e, de preferência, horas de término para cada tarefa. Preparar a manutenção e o backup de bancos de dados ou de grupos de armazenamento também reduz o efeito das tarefas de alta utilização de recursos.

Para obter mais informações

  • Para obter uma visão geral do Exchange Server e da verificação de vírus, consulte o artigo 823166 da Base de Dados de Conhecimento da Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Para obter mais informações sobre a verificação de vírus e o Exchange Server, consulte o artigo 285667 da Base de Dados de Conhecimento da Microsoft, "XADM: Compreendendo a VSAPI 2.0 (Virus Scanning API 2.0) no Exchange 2000 Server SP1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667).

  • Para obter mais informações sobre os afunilamentos do processador, consulte Afunilamento do processador.

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre como mover caixas de correio do usuário para reduzir a carga do servidor, consulte Mover Caixas de Correio de Usuário para Outro Servidor.


O comprimento da fila da Verificação de Vírus está além do limite de aviso
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-04-20

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Virus Scan Queue Length do objeto de desempenho de MSExchangeIS para analisar os dados do desempenho.

Se o Exchange Server Analyzer determinar que o valor do 90º percentil do contador Virus Scan Queue Length é maior que 5 durante o intervalo de tempo de amostragem, o Exchange Server Analyzer exibirá um aviso.

O contador de desempenho do Virus Scan Queue Length indica o número atual de solicitações de verificação de vírus pendentes enfileiradas.

Esse aviso indica que o desempenho pode tornar-se um problema para esse servidor. Os problemas de desempenho poderão estar relacionados a:

  • Degradação do desempenho no servidor, geralmente causada por um afunilamento emergente na CPU.

  • Carga no servidor mais alta do que o normal.

  • Um mecanismo de verificação de vírus desatualizado.

  • Um mecanismo de verificação de vírus configurado de maneira incorreta.

Para resolver esse aviso, siga as seguintes etapas:

  • Procure atualizações para seu antivírus.

  • Considere a reinstalação do software de verificação de vírus.

  • Examine a configuração de seu mecanismo de verificação de vírus em relação à configuração correta de thread, às exclusões do nível de arquivo, etc. Consulte o artigo 823166 da Base de Dados de Conhecimento Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166) (em inglês).

  • Use a ferramenta Monitor de Desempenho (Perfmon.msc) para identificar se o afunilamento emergente é causado por um aumento de carga no servidor ou se o servidor está subdimensionado. Se a carga do servidor aumentou, identifique a origem da carga e reduza-a. Se o servidor tiver recursos insuficientes, aumente os recursos necessários ou mova usuários do servidor.

Removendo afunilamentos do processador

Há várias maneiras de determinar afunilamentos do processador no servidor Exchange.

  • Primeiro, revise os aplicativos ou as tarefas que estão causando carga ao servidor. Determine se o aplicativo deve estar usando o tempo do processador que ele está ou se pode estar ocorrendo um problema no processo.

  • Se um aplicativo não-Exchange não for importante para esse servidor, execute-o em outro servidor. Se possível, mova funções do servidor para outros computadores também. Por exemplo, se o processo Inetinfo estiver utilizando intensamente a CPU, experimente adicionar servidores front-end para se encarregar do trabalho de protocolo realizado pelo Inetinfo. Também é possível mover o acesso às pastas públicas para um servidor de pastas públicas dedicado. Por último, se um servidor executa muitas expansões da lista de distribuição, você pode reduzir o uso da CPU, deslocando a expansão da lista de distribuição para um servidor de expansão de lista de distribuição dedicado.

  • Se possível, adicione mais processadores ou processadores mais rápidos ao servidor. Além disso, habilite a hyper-threading se houver suporte para essa tecnologia nos processadores. Você pode habilitar a hyper-threading configurando a BIOS do sistema. Para obter mais informações, consulte a documentação da Ajuda do fabricante do computador.

  • Se o aumento da força de processamento não for uma opção viável, reduza a carga sobre os processadores. Para reduzir o impacto global sobre o servidor, certifique-se de que as tarefas de alta utilização de E/S, da CPU ou devoradoras de memória ocorram fora do horário do expediente normal.

  • Assegure-se de que as tarefas de alta utilização da CPU, como backup e manutenção, ocorram fora do horário de pico. Certifique-se de que essas tarefas sejam realizadas em etapas. Estabelecer etapas para uma tarefa significa definir diferentes horários de início e, preferencialmente, horários de término para cada tarefa. Preparar a manutenção e o backup de bancos de dados ou de grupos de armazenamento também reduz o efeito das tarefas de alta utilização de recursos.

Para obter mais informações

  • Para obter uma visão geral do Exchange Server e da verificação de vírus, consulte o artigo 823166 da Base de Dados de Conhecimento da Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Para obter mais informações sobre a verificação de vírus e o Exchange Server, consulte o artigo 285667 da Base de Dados de Conhecimento da Microsoft, "XADM: Compreendendo a VSAPI 2.0 (Virus Scanning API 2.0) no Exchange 2000 Server SP1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667).

  • Para obter mais informações sobre os afunilamentos do processador, consulte Afunilamento do processador.

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre como mover caixas de correio do usuário para reduzir a carga do servidor, consulte Mover Caixas de Correio de Usuário para Outro Servidor.


Falha no Ponto de Montagem do Volume: Windows Server 2003 SP1 não instalado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2006-02-13

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para verificar se o driver Mountmgr.sys existe.

Em seguida, o Exchange Server Analyzer lê o valor do Registro a seguir para determinar qual versão do sistema operacional Microsoft Windows® está sendo executada no servidor Exchange: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se o valor de CurrentVersion for 5.0, o servidor Exchange estará em execução no Microsoft Windows 2000 Server. Se o valor de CurrentVersion for 5.2, o servidor Exchange estará em execução no Microsoft Windows Server™ 2003.

O Exchange Server Analyzer também consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started para o serviço de Cluster (ClusSvc). Um valor TRUE indica que o serviço de Cluster está iniciado e um valor FALSE revela que esse serviço não está em execução.

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • O computador do Exchange Server está executando no Windows Server 2003.

  • O Windows Server 2003 SP1 não estiver instalado.

  • O Exchange Server estiver sendo executado em um ambiente em cluster.

  • Os pontos de montagem do volume existirem.

O aviso indica que se o ambiente de nós de cluster do Exchange for atualizado para o Windows Server 2003 SP1, será necessária a atualização citada na seção a seguir. Sem essa atualização, você poderá detectar falhas no ponto de montagem de volume, após a atualização.

Para corrigir esse aviso

  • Aplique a atualização citada no artigo 898790 da Base de Dados de Conhecimento Microsoft, "Os pontos de montagem de volume em discos em um cluster do servidor podem ficar indisponíveis após a instalação do Windows Server 2003 Service Pack 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790) (página em inglês).


O serviço de firewall do Windows está habilitado no Exchange Server
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar o valor da chave Started para o serviço Windows Firewall (SharedAccess). Um valor Verdadeiro indica que o serviço Windows Firewall esta habilitado nesse servidor Exchange.

Se o Analisador do Exchange Server determinar que o serviço WIndows Firewall está habilitado em um computador do Exchange Server, será exibido um aviso. Quando o serviço Windows Firewall estiver habilitado, os seguintes problemas poderão ocorrer:

  • Alguns componentes do Exchange Server, como o Serviço de Controle de Mensagens ou comunicação RPC (chamada de procedimento remoto), podem parar de responder.

  • Você pode receber uma mensagem de erro que informa insuficiência de memória disponível.

Por padrão, o serviço Windows Firewall pára quando o Microsoft Windows Server™ 2003 Service Pack 1 (SP1) é aplicado. Entretanto, o serviço é automaticamente configurado para ser executado se uma das seguintes condições for verdadeira:

  • Um administrador habilita manualmente o serviço Windows Firewall.

  • Você habilita o serviço Windows Firewall depois de executar o Assistente de Configuração de Segurança.

Para corrigir esse aviso

  • Verifique as exclusões do programa.

  • Verifique as exclusões da porta.

  • Verifique exceções de firewall se os clientes não conseguirem conexão com o servidor Exchange.

  • Abra as portas do firewall manualmente para que o Gerenciador do Sistema do Exchange e o Administrador do Microsoft Exchange possam ser executados. Ao abrir portas no serviço Windows Firewall, aumentam as possibilidades de outros programas conseguirem acesso ao seu computador por meio delas. Considere com cuidado os requisitos de segurança da rede antes de abrir portas no serviço Windows Firewall.

  • Pare o serviço Windows Firewall.


O serviço de Instrumentação de Gerenciamento do Windows não está em execução como LocalSystem
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar os dados de valor para o valor ObjectName:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winmgmt

O valor ObjectName nesta filial do Registro indica as configurações da conta de serviço do serviço WMI (Instrumentação de Gerenciamento do Windows), conhecido como serviço Winmgmt. Se o Exchange Server Analyzer verificar que os dados de valor de ObjectName não são iguais a LocalSystem, o Exchange Server Analyzer exibirá um erro.

Esse erro indica que o serviço WMI não está sendo executado em uma configuração com suporte. Se você executar o serviço WMI em alguma conta que não seja a conta LocalSystem, você poderá causar erros de permissão e de acesso.

Para resolver esse erro, você deve configurar o serviço WMI para iniciar na conta LocalSystem (SYSTEM).

Para configurar a conta do serviço WMI

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. Localize e pare o serviço Instrumentação de Gerenciamento do Windows.

  3. Clique duas vezes no serviço Instrumentação de Gerenciamento do Windows.

  4. Na guia Logon da página Propriedades da Instrumentação de Gerenciamento do Windows, selecione Conta Sistema Local em Fazer logon como e clique em Aplicar.

  5. Em Status do Serviço, clique em Iniciar e clique em OK.

  6. Feche o snap-in Serviços.


Windows Server 2003 SP1: Hotfix do Outlook Web Access necessário
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta as várias classes de WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para coletar as informações a seguir:

  • Em qual versão do sistema operacional Microsoft Windows Server o Exchange Server está instalado?

  • O Exchange Server está sendo executado em um cluster?

Se o Exchange Server Analyzer determinar que as seguintes condições são verdadeiras, o Exchange Server Analyzer exibirá um erro:

  • O Exchange Server 2003 Service Pack 1 (SP1) está instalado.

  • O Microsoft Windows Server™ 2003 Service Pack 1 (SP1) está instalado.

  • O serviço de cluster está sendo executado.

  • O valor de Version do Davex.dll é menor que 6.5.7232.

Se você estiver executando essa configuração, deverá baixar e instalar um hotfix do Exchange Server antes de instalar o Windows Server 2003 SP1. Se você não instalar o hotfix do Exchange Server, os usuários do Microsoft Office Outlook® Web Access para Exchange Server 2003 não poderão fazer logon em suas caixas de correio. Os usuários que têm caixas de correio hospedadas nos clusters receberão a mensagem de erro a seguir quando tentarem se conectar usando o Outlook Web Access:

  • "500 Erros Internos do Servidor"

Esse erro é causado por alguns dos aprimoramentos de segurança que estão incluídos no Windows Server 2003 SP1.

Quando um usuário tenta fazer logon em uma caixa de correio usando o Outlook Web Access, o HTTP envia solicitações à API do cluster, representando o usuário conectado. Entretanto, foram feitas alterações de segurança no Windows Server 2003 SP1. As restrições de segurança para as APIs que executam acesso de Registro remoto foram alteradas. Portanto, a tentativa de logon não foi bem-sucedida.

Para corrigir esse erro, baixe e instale o hotfix do Exchange Server que está descrito no artigo 841561 da Base de Dados de Conhecimento Microsoft, "mensagem de erro '500 - Erro interno do servidor' quando um usuário tenta acessar um servidor back-end Exchange Server 2003 em cluster usando o Outlook Web Access" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561) (em inglês).


Assistente de Configuração de Segurança do Windows Server 2003 SP1 foi detectado
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A Ferramenta do Microsoft® Exchange Server Analyzer lê o seguinte valor do Registro para determinar a versão do sistema operacional Microsoft Windows® em execução no servidor Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se o valor CurrentVersion for igual a 5.0, o servidor do Exchange está sendo executado no Microsoft Windows 2000 Server. Se o valor CurrentVersion for 5.2, o servidor do Exchange está sendo executado no Microsoft Windows Server™ 2003.

Além disso, o Exchange Server Analyzer lê o seguinte valor do Registro para determinar o caminho para o diretório Arquivos de Programas do Windows:

HKLM\Software\Microsoft\Windows\CurrentVersion\ProgramFilesDir

Em seguida, ele examina o diretório Arquivos de Programas do Windows para determinar se esse diretório contém a pasta \Exchsrvr para o Exchange Server.

Finalmente, o Exchange Server Analyzer consulta a classe Win32_OperatingSystem do WMI para determinar o valor da chave ServicePackMajorVersion. O valor da chave ServicePackMajorVersion indica qual service pack do Windows está instalado no computador.

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • O Exchange Server Analyzer determina que o computador do Exchange Server está sendo executado no Windows Server 2003 Service Pack 1.

  • O Exchange Server Analyzer determina que o Exchange Server 2003 não está instalado no caminho padrão de \Arquivos de Programas\Exchsrvr.

Esse aviso indica que o Exchange Server 2003 não está instalado na pasta Arquivos de Programas padrão no servidor e que o Assistente de Configuração de Segurança está instalado no servidor Exchange. O Assistente de Configuração de Segurança é uma ferramenta incluída como componente opcional do Windows Server 2003 Service Pack 1. Se ele estiver instalado em um servidor Exchange, será necessária a configuração manual da seção Segurança de Rede.

Observação:
Para instalar o Assistente de Configuração de Segurança, primeiro você deve instalar o Windows Server 2003 Service Pack 1. Depois que o Service Pack 1 estiver instalado, abra Adicionar/Remover Programas no Painel de Controle para instalar o Assistente de Configuração de Segurança.

O assistente ajuda a reduzir a superfície de ataque dos servidores do Windows fazendo uma série de perguntas ao usuário. Essas perguntas foram elaboradas para determinar os requisitos funcionais de um servidor. Especificamente, o Assistente de Configuração de Segurança ajuda você a desempenhar as seguintes tarefas:

  • Ele desabilita automaticamente os serviços desnecessários.

  • Ele boqueia automaticamente portas não utilizadas.

  • Ajuda você a aplicar restrições para endereços adicionais ou restrições de segurança para portas que são deixadas abertas.

  • Impede extensões IIS (Serviços de Informações da Internet) da Web desnecessárias, quando aplicável.

  • Ele reduz a exposição de protocolo a SMB (Bloco de Mensagens do Servidor), LanMan e LDAP (Lightweight Directory Access Protocol).

  • Define uma alta diretiva de auditoria de sinal.

O Assistente de Configuração de Segurança orienta você no processo de criação, edição, aplicação ou reversão de uma diretiva de segurança baseada nas funções selecionadas do servidor. As diretivas de segurança criadas com o Assistente de Configuração de Segurança são arquivos XML que configuram serviços, segurança de rede, valores específicos do Registro e diretivas de auditoria quando aplicável. Se aplicável, o IIS também pode ser configurado.

O Assistente de Configuração de Segurança inclui um recurso de Segurança de Rede que configura e adiciona exceções ao Windows Firewall, além de desempenhar outras funções. O Windows Firewall é a nova versão do filtro de pacotes com monitoração de estado no Windows Server 2003 Service Pack 1. O Windows Firewall foi introduzido primeiramente no Windows XP Service Pack 2. Ele foi denominado de Internet Connection Firewall no Windows XP Service Pack 2.

Há um problema conhecido que ocorre quando o recurso de Segurança de Rede no Assistente de Configuração de Segurança é executado no servidor Exchange no qual o Exchange Server não está instalado no caminho padrão. Nessa configuração, o aplicativo da diretiva resultante pode fazer com que o Exchange Server fique inacessível para clientes. Quando o recurso de Segurança de Rede é usado em um servidor do Exchange no qual o Exchange Server não está instalado no caminho padrão, o Assistente de Configuração de Segurança pode configurar o Windows Firewall para bloquear o acesso à porta TCP/IP por processos do Exchange Server, como o Atendedor do Sistema (Mad.exe), o Armazenamento de Informações do Microsoft Exchange (Store.exe) ou o agente de transferência de mensagens (Emsmta.exe). Nessa configuração, o Assistente de Configuração de Segurança exibe Não Encontrado! ao lado de cada processo. Se o Assistente de Configuração de Segurança permanecer em execução até ser concluído, com um processo que tenha Não Encontrado! ao lado, o assistente aplicará uma diretiva de segurança ao Windows Firewall que bloqueará o acesso à rede por esse processo.

Se os processos bloqueados incluírem um ou mais processos do Exchange Server, o Exchange Server poderá ficar inacessível para clientes e outros servidores. Caso essa situação esteja presente, você deve executar um dos procedimentos a seguir para corrigir o problema.

Para corrigir o problema

  • Execute um dos procedimentos a seguir para corrigir o problema:

    • Use o recurso de reversão do Assistente de Configuração de Segurança para reverter uma diretiva de segurança após ela ter sido aplicada. Para obter mais informações sobre como fazer isso, consulte o arquivo da Ajuda do Assistente de Configuração de Segurança incluído no Windows Server 2003 Service Pack 1. Para obter mais informações sobre o Windows Server 2003 Service Pack 1 e o Assistente de Configuração de Segurança, consulte o Windows Server 2003 TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315).

    • No Assistente de Configuração de Segurança, preencha manualmente o campo de caminho do Aplicativo para especificar a localização dos arquivos de processos executáveis do Exchange Server. Para isso, selecione o processo marcado como Não Encontrado! e clique em Editar. É recomendável que você execute o Assistente de Configuração de Segurança no servidor Exchange para verificar se o caminho de cada processo executável do Exchange Server está correto. Depois da aprovação de todos os processos, a diretiva de segurança do Assistente de Configuração de Segurança poderá ser aplicada e o Exchange Server terá o acesso de rede necessário para funcionar.

Para obter mais informações sobre o Windows Server 2003 Service Pack 1 e o Assistente de Configuração de Segurança, consulte o Windows Server 2003 TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315).


O arquivo XESE.DLL está presente
Microsoft Exchange Server Analyzer - Artigos > Exchange Server >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version de um arquivo chamado Xese.dll.

Se o Exchange Server Analyzer não puder obter um valor de Version para esse arquivo, ele indicará que o arquivo existe, e um erro será exibido.

Alguns programas antivírus baseados no ESE usam uma interface sem suporte entre o armazenamento de informações do Exchange e o ESE (Mecanismo de Armazenamento Extensível). Ao usar esse tipo de software, você correrá o risco de danificar o banco de dados e perder dados se houver erros na implementação do software.

Durante a instalação, o scanner com base em ESE altera o serviço de Armazenamento de Informações do Microsoft Exchange para que ele dependa do serviço de programa antivírus baseado no ESE. Isso garante que o serviço do programa antivírus com base no ESE será iniciado antes de o serviço do Armazenamento de Informações do Microsoft Exchange iniciar. Quando o programa antivírus com base no ESE for iniciado, a versão do Ese.dll incluída no Exchange Server será temporariamente renomeada como Xese.dll e a versão do programa antivírus com base no ESE do Ese.dll substituirá o arquivo original. Depois que a versão do Ese.dll do programa antivírus com base no ESE for carregada, a versão incluída no Exchange Server será novamente renomeada para Ese.dll e o serviço de Armazenamento de Informações do Microsoft Exchange Information concluirá o processo de inicialização.

Para resolver este aviso

  1. É recomendável que você não use implementações não-Microsoft do ESE em computadores do Exchange Server. Clientes que entram em contato com o Atendimento Microsoft podem ser solicitados a desabilitar o programa antivírus com base no ESE para ajudar a identificar problemas, mas estão livres para habilitar novamente o software depois que a causa raiz do problema for diagnosticada corretamente.

  2. O programa antivírus com base no ESE mais amplamente usado é o Antigen para Microsoft Exchange da Sybari Software. A Microsoft e a Sybari concordam que a desabilitação do Sybari Antigen é uma etapa de solução de problemas válida para determinar a causa de problemas. Para entrar em contato com a Sybari Software, consulte o site da empresa (http://www.sybari.com).

    Observação:
    As informações sobre sites de terceiros são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.

  3. Recomenda-se o uso de programas antivírus que ofereçam suporte ao VSAPI (Virus Scanning Application Programming Interface), também conhecido como AVAPI (API Antivírus).

Para obter mais informações sobre como executar o software antivírus no Exchange Server, consulte os seguintes artigos na Base de Dados de Conhecimento da Microsoft:

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=).

  • 328841, "XADM: Exchange e software antivírus" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=).


Hardware
Microsoft Exchange Server Analyzer - Artigos >

Última modificação do tópico: 2005-11-18

Os artigos desta seção fornecem detalhes sobre o que a Ferramenta Microsoft® Exchange Server Analyzer está avaliando em relação a hardware. Além disso, esses artigos descrevem ações que podem ser executadas para resolver erros relacionados a hardware, avisos e configurações não padrão encontrados pelo Exchange Server Analyzer.


O BIOS está desatualizado
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_BIOS do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor das chaves SMBIOSBIOSVersion e ReleaseDate. O valor retornado representa o número de versão e data de lançamento do BIOS instalado no computador, respectivamente. O Exchange Server Analyzer também examina a classe Win32_ComputerSystem do WMI para determinar o valor da chave Modelo.

Se o Exchange Server Analyzer verificar que o valor de ReleaseDate indica que ele está desatualizado há mais de um ano, e que a chave Model contém alguma das cadeias de caracteres a seguir, será exibido um aviso:

  • ProLiant DL320

  • ProLiant DL320 G2

  • ProLiant DL320 G3

  • ProLiant DL320

  • ProLiant DL360 G2

  • ProLiant DL360 G3

  • ProLiant DL360 G4

  • ProLiant DL380

  • ProLiant DL380 G2

  • ProLiant DL380 G3

  • ProLiant DL380 G4

  • ProLiant DL560

  • ProLiant DL570 G3

  • ProLiant DL580

  • ProLiant DL580 G2

  • ProLiant DL580 G3

  • ProLiant DL585 G1

  • ProLiant ML350

  • ProLiant ML350 G2

  • ProLiant ML350 G3

  • ProLiant ML350 G4

  • ProLiant ML370

  • ProLiant ML370 G2

  • ProLiant ML370 G3

  • ProLiant ML370 G4

  • ProLiant ML530

  • ProLiant ML530 G2

  • ProLiant ML570

  • ProLiant ML570 G2

  • ProLiant ML750

Para corrigir esse aviso e obter mais informações sobre como obter e atualizar uma versão mais nova do BIOS, consulte o site da Hewlett-Packard, "Atualizações de ROM-BIOS/Firmware" (página em inglês) (http://h18023.www1.hp.com/support/files/server/us/romtabl.html).

Para obter mais informações sobre os servidores ProLiant da Hewlett-Packard, consulte o site da Hewlett_Packard (http://www.hp.com).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


O BIOS está desatualizado no servidor Dell PowerEdge
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_BIOS da instrumentação de gerenciamento do Microsoft Windows® (WMI) para determinar o valor da chave SMBIOSBIOSVersion. O valor retornado representa o número da versão do BIOS instalado no computador. O Exchange Server Analyzer também examina a classe Win32_ComputerSystem do WMI para determinar o valor da chave Modelo.

Se o Exchange Server Analyzer descobrir que a chave Modelo contém uma das seguintes cadeias de caracteres e que SMBIOSBIOSVersion não é a versão mais recente do modelo, um aviso será exibido:

  • PowerEdge 2400

  • PowerEdge 2450

  • PowerEdge 2500

  • PowerEdge 2550

  • PowerEdge 2600

  • PowerEdge 2650

  • PowerEdge 2800

  • PowerEdge 2850

  • PowerEdge 3250

  • PowerEdge 4300

  • PowerEdge 4350

  • PowerEdge 4400

  • PowerEdge 4600

  • PowerEdge 6300

  • PowerEdge 6350

  • PowerEdge 6400

  • PowerEdge 6450

  • PowerEdge 6600

  • PowerEdge 6650

  • PowerEdge 6800

  • PowerEdge 6850

  • PowerEdge 7150

  • PowerEdge 7250

  • PowerEdge 8450

Para corrigir esse aviso e obter mais informações sobre como adquirir e atualizar uma versão mais recente do BIOS, consulte o site "Downloads" da Dell (http://support.dell.com/support/downloads).

Para obter mais informações sobre os servidores Dell PowerEdge, consulte o site da Dell (http://www.dell.com.br).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


A atualização de BIOS está disponível
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_BIOS da Instrumentação de Gerenciamento do Microsoft Windows® para determinar o valor da chave SMBIOSBIOSVersion. O valor retornado representa o número da versão e a data de versão do BIOS instalado no computador. O Exchange Server Analyzer também consulta a classe Win32_ComputerSystem do WMI para conhecer o valor da chave Model. Se o Exchange Server Analyzer determinar que o computador é um sistema IBM X445 com uma versão do BIOS anterior a REJT48A, o Exchange Server Analyzer exibirá um erro.

Para corrigir esse erro e para mais informações sobre como obter e atualizar para uma versão mais recente do BIOS, consulte no site da IBM "Atualização do BIOS Flash (pacote de atualização do DOS) com suporte para RSA I e RSA II EXA - IBM eServer xSeries 445" (página em inglês) (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


A placa de interface de rede do cluster está habilitada para DHCP
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_NetworkAdapterConfiguration para determinar o valor da chave DHCPEnabled para todas as interfaces de rede no cluster. Se o Exchange Server Analyzer detectar que o valor de DHCPEnabled está definido como Verdadeiro para qualquer interface de rede privada no cluster, será exibido um erro.

Um valor igual a Verdadeiro na chave WMI DHCPEnabled indica que uma interface de rede está configurada para usar o DHCP (Dynamic Host Configuration Protocol). A Microsoft não oferece suporte para o uso de DHCP em nós da rede privada, em um cluster do servidor do Windows. Além disso, é recomendável o uso de endereços IP estáticos em nós das redes públicas em um cluster de servidor do Windows. Não é recomendável o uso de configuração dinâmica de redes públicas por meio do DHCP, porque a inobservância na renovação de uma concessão do DHCP pode interromper as operações do cluster. Além disso, o uso de configuração dinâmica de redes privadas por meio do DHCP não tem suporte e nunca deve ser executado.

Para resolver esse problema, reconfigure as interfaces das redes privadas de modo a usar um endereço IP estático. É recomendável selecionar os endereços dentro dos seguintes intervalos:

  • 10.0.0.0 - 10.255.255.255 (rede da Classe A)

  • 172.16.0.0 - 172.31.255.255 (rede da Classe B)

  • 192.168.0.0 - 192.168.255.255 (rede da Classe C)

Para corrigir esse erro

  1. Na janela Conexões de Rede, clique com o botão direito na conexão de rede de sua rede privada e clique em Propriedades.

  2. Clique em Protocolo TCP/IP e clique em Propriedades.

  3. Na guia Geral, digite um endereço IP que não esteja na mesma sub-rede ou rede de um dos adaptadores de rede pública. Um exemplo de endereços IP eficientes para serem usados para adaptadores privados é 10.10.10.10 no nó 1 e 10.10.10.11 no nó 2 com uma máscara de sub-rede de 255.0.0.0. Se sua rede pública usar uma rede 10.x.x.x e uma máscara de sub-rede 255.0.0.0, use um IP e uma sub-rede da rede privada alternativos.

  4. Certifique-se de que não haja um valor definido na caixa Gateway Padrão.

  5. Certifique-se de que não haja valores definidos na caixa Usar os seguintes endereços de servidor DNS.

  6. Clique em Avançado.

  7. Na guia DNS, certifique-se de que não haja valores definidos. As caixas de seleção Registrar os endereços desta conexão no DNS e Usar o sufixo DNS desta conexão no registro do DNS devem estar desmarcadas.

  8. Na guia WINS, certifique-se de que não haja valores definidos. Clique em Desabilitar NetBIOS sobre TCP/IP.

  9. Quando você fechar a caixa de diálogo, deverá receber o aviso a seguir. Se você receber este prompt, clique em Sim: Esta conexão tem um endereço WINS principal vazio. Deseja continuar?

  10. Clique em OK para salvar suas alterações.

  11. Conclua as etapas anteriores em todos os outros nós do cluster.

Para obter mais informações sobre a configuração ideal de rede para os clusters de servidor Windows, consulte " Clusters de Servidor: Práticas recomendadas de configuração de rede para Windows 2000 e Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=34304) (em inglês).

Para obter mais informações sobre configuração correta da pulsação de cluster, consulte o artigo 258750 da Base de Dados de Conhecimento da Microsoft, "Configuração de 'pulsação' particular recomendada em um servidor cluster http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750.


O sufixo do DNS primário do computador não corresponde ao FQDN do domínio onde ele reside
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2006-05-18

A Ferramenta Microsoft® Exchange Server Analyzer lê as entradas do Registro a seguir para determinar o sufixo DNS (Sistema de Nome de Domínio) para esse Exchange Server:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\NV Domain

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Domain

Se o Exchange Server Analyzer detectar que os valores de NV Domain e Domain não coincidem, será exibido um aviso.

O valor do Registro NV Domain contém o sufixo DNS primário do computador. O valor do Registro Domain contém o domínio DNS primário do computador. Por padrão, a porção do sufixo DNS primário do FQDN (nome de domínio totalmente qualificado) de um computador precisa ser o mesmo que o nome do domínio do serviço de diretório do Active Directory onde o computador está localizado. Nomes incompatíveis podem impedir que o registro DNS ocorra corretamente. Se o nome de domínio DNS do coputador não coincidir com o nome de domínio do Active Directory, você verá erros no log de eventos do Sistema do computador a cada 22 minutos. Essa condição é conhecida como namespace separado. Para permitir sufixos primários de DNS diferentes, você pode criar uma lista restrita de sufixos permitidos, criando um atributo do Active Directory chamado msDS-AllowedDNSSuffixes no contêine de objetos de domínio.

O procedimento para garantir um namespace separado configurado corretamente depende do sistema operaciona usado para os controladores de domínio do Active Directory.

  • Se você estiver executando o sistema operacional Microsoft Windows® 2000 Server com controladores de domínio do Active Directory, você pode usar o procedimento descrito no artigo 258503 da Base de Dados de Conhecimento da Microsoft, "Erros 5788 e 5789 no registro de DNS quando os nomes de domínio de DNS e do Active Directory são diferentes" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258503) para configurar seu namespace corretamente. Esse artigo inclui procedimentos para corrigir um namespace separado sem intenção e para configurar corretamente um namespace separado, se se quiser um.

  • Se você estiver executando o Microsoft Windows Server™ 2003 em seus controladores de domínio do Active Directory e o namespace separado for não intencional, você pode usar o primeiro procedimento abaixo para corrigir o namespace separado não intencional e resolver esse aviso. Se estiver executando o Microsoft Windows Server™ 2003 em seus controladores de domínio do Active Directory e o namespace separado for intencional, você pode usar o segundo procedimento abaixo para configurá-lo corretamente.

Para executar o segundo procedimento abaixo, você precisará usar um editor do Active Directory como a ferramenta ADSI Edit ou LDP (Ldp.exe). Para obter mais informações sobre como modificar o Active Directory com a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento Microsoft, "XADM: Usando o utilitário LDP para modificar os atributos de objeto do Active Directory" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745) (em inglês).

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir que você reinstale o Windows Server 2003, o Exchange Server 2003, ou ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Se o namespace separado for não intencional

  1. Clique com o botão direito em Meu Computador e clique em Propriedades. A caixa de diálogo Propriedades do Sistema será exibida.

  2. Clique na guia Nome do Computador.

  3. Clique em Alterar. A caixa de diálogo Alterações no Nome do Computador será exibida.

  4. Clique em Mais. A caixa de diálogo Sufixo DNS e Nome NetBIOS do Computador será exibida.

  5. Marque a caixa de seleção Alterar sufixo de DNS primário quando a associação do domínio for alterada.

  6. Clique em OK para salvar as alterações e clique em OK novamente para sair da caixa de diálogo Alterações no Nome do Computador.

  7. Clique em OK para fechar a caixa de diálogo Propriedades do Sistema e reinicie o computador para que a alteração entre em vigor.

Se o namespace separado for intencional

  1. Use o procedimento acima para verificar se a caixa de seleção Alterar sufixo de DNS primário quando a associação do domínio for alterada está limpa.

  2. Modifique o atributo msDS-AllowedDNSSuffixes do Active Directory no contêiner do objeto de domínio. Isso pode ser feito com ADSI Edit, executando-se as seguintes etapas:

    1. Clique duas vezes na partição de diretório do domínio que deseja modificar.

    2. Clique com o botão direito no objeto de contêiner de domínio e clique em Propriedades.

    3. Na guia Editor de Atributo, na caixa de diálogo Atributos, clique duas vezes no atributo msDS-AllowedDNSSuffixes.

    4. Na caixa de diálogo Multi-valued String Editor, na caixa de diálogo Valor a adicionar, digite um sufixo DNS e clique em Adicionar.

    5. Quando tiver adicionado todos os sufixos DNS para o domínio, clique em OK.

    6. Clique em OK para fechar a caixa de diálogo Propriedades do domínio.

    7. Repita essas etapas se desejar configurar vários domínios.

Para obter mais informações sobre o atributo msDS-AllowedDNSSuffixes, consulte a Centro de Ajuda e Suporte do Windows Server 2003. Para obter informações adicionais sobre o procedimento usado para editar esse atributo, consulte o "Guia passo-a-passo para implementação de renomeação de domínio" (http://go.microsoft.com/fwlink/?LinkId=41359).


A atualização crítica de BIOS está disponível
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2006-04-20

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_BIOS para determinar o valor da chave SMBIOSBIOSVersion. O valor da chave SMBIOSBIOSVersion representa o número da versão do BIOS instalado no servidor. O Analisador do Exchange Server também consulta a classe WMI Win32_ComputerSystem (Instrumentação de Gerenciamento do Microsoft Windows®) para conhecer o valor da chave Model. O valor da chave Model representa as informações do modelo de hardware fornecido pelo fabricante.

Se o Exchange Server Analyzer determinar que o valor da chave Version é 42B em um servidor cuja chave Model começa por eserver xSeries 445, será exibido um erro. Esse erro indica que o BIOS deste servidor IBM xSeries 445 deve ser atualizado.

Há uma questão conhecida com a versão 42B do firmware do BIOS que pode causar danos aos dados. O problema se limita a sistemas X445 com BIOS 42B (versão 1.15) instalado e foi corrigido com o BIOS 45A. Atualize o BIOS deste servidor para 45A ou posterior assim que possível.

Para corrigir esse erro

  1. Para obter mais informações sobre essa questão, consulte o site da IBM, "Flash BIOS Update (DOS update package) - IBM eServer xSeries 445" (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089#BIOSVersion).

  2. Para obter informações, consulte o arquivo Leiame da atualização do BIOS (ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers/39y4888.txt).

  3. Baixe a atualização do BIOS a partir do site da IBM (http://www-307.ibm.com/pc/support/site.wss/license.do?filename=pc_servers/26r0663.exe).

  4. Atualize o BIOS no servidor.

Para obter mais informações sobre como aplicar essa atualização de BIOS crítica, consulte o site da IBM (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=DSHY-3TEPF6).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


A velocidade atual do processador é inferior à velocidade máxima possível
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Processor para determinar os valores atuais de MaxClockSpeed e CurrentClockSpeed. Se o Exchange Server Analyzer detectar que o valor de CurrentClockSpeed é inferior ao valor de MaxClockSpeed, um aviso será exibido.

O valor CurrentClockSpeed é a velocidade atual em MHz (megahertz) de cada processador. O valor MaxClockSpeed é a velocidade máxima de cada processador em megahertz. Se essa mensagem de aviso for exibida, isso indicará que um ou mais processadores no servidor Exchange não estão operando na velocidade máxima. Há algumas causas conhecidas para isso:

  1. O Exchange Server está instalado em um computador que executa o Microsoft Windows® 2000 Server ou o Windows 2000 Advanced Server, mas não tem no mínimo o Windows 2000 Server Service Pack 3 instalado. O Windows 2000 Server Service Pack 3 corrigiu um problema no qual o WMI não retornava os valores corretos de MaxClockSpeed ou CurrentClockSpeed.

  2. Uma definição incorreta de economia de energia no BIOS do servidor Exchange pode estar forçando o processador a ser executado a uma velocidade reduzida em um modo de economia de energia.

Para corrigir esse aviso

  1. Se o Exchange Server estiver instalado em um computador que executa o Microsoft Windows® 2000 Server ou o Windows 2000 Advanced Server, mas não tem no mínimo o Windows 2000 Server Service Pack 3 instalado, você deverá instalar o service pack mais recente. Para obter mais informações sobre os service packs mais recentes do Windows 2000, consulte o site do Microsoft Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=18353).

  2. Se o Exchange Server estiver instalado em um computador que executa o Windows 2000 Server ou o Windows 2000 Advanced Server, mas não tem o Windows 2000 Server Service Pack 3 ou uma versão mais recente instalada, verifique as configurações de BIOS do servidor Exchange. Verifique também as configurações de gerenciamento de energia no BIOS, bem como no Painel de Controle ou no Gerenciador de Dispositivos.

Consulte o fabricante do hardware para obter informações sobre como exibir e configurar as definições de gerenciamento de energia, processador e BIOS do sistema.

Para obter mais informações sobre os recursos de gerenciamento de energia do Windows 2000 Server, consulte o artigo 244806 da Base de Dados de Conhecimento da Microsoft, "Visão geral do gerenciamento de energia no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244806).

Para obter mais informações sobre os recursos de gerenciamento de energia no Microsoft Windows Server™ 2003, pesquise em "Gerenciamento de energia" e "Opções de energia" no Centro de ajuda e suporte do Windows Server 2003, o qual pode ser acessado no menu Iniciar em um computador executando o Windows Server 2003.

Para obter mais informações sobre os recursos de gerenciamento de energia no Windows 2000 Server, consulte os tópicos "Gerenciamento de energia" e "Opções de energia" na Ajuda do Windows 2000 Server, o qual pode ser acessado no menu Iniciar em um computador executando o Windows 2000 Server.


DisableDHCPMediaSense não está definido corretamente no Windows Server 2003
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2006-10-02

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para saber se a Detecção do Media Sense está configurada corretamente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

O Exchange Server Analyzer também examina a seguinte entrada do Registro para determinar a versão do Windows que está sendo executada no computador de destino:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor igual a 4.0 em CurrentVersion indica que o computador está executando o Microsoft Windows NT® Server 4.0. Um valor igual a 5.0 indica que o computador está executando um sistema operacional Windows® 2000 Server, e um valor igual a 5.2 indica que o computador está executando um sistema operacional Windows Server™ 2003.

Além disso, o Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar o valor da chave Iniciado do ClusSvc, o serviço de Cluster do Microsoft Windows. Um valor Verdadeiro indica que o serviço de Cluster do Windows está em execução, e um valor Falso indica que não está em execução.

Se o Exchange Server Analyzer detectar que o serviço Cluster do Windows está em execução no Windows Server 2003, no Enterprise Edition ou Windows Server 2003, no Datacenter Edition e o valor da chave do Registro DisableDHCPMediaSense estiver definido como 1, será exibido um aviso.

Quando você usar o serviço Cluster do Windows Server 2003, se a conectividade da rede se perder, a pilha TCP/IP não será descarregada por padrão, como acontecia no Windows 2000 Server. Conseqüentemente, não é mais necessário definir a chave do Registro DisableDHCPMediaSense. No Windows 2000 Server, se a conectividade da rede se perdesse, a pilha TCP/IP era descarregada, o que significava que todos os recursos do cluster, inclusive recursos em um Servidor Virtual do Exchange, que dependiam de endereços IP, ficavam offline. Quando as redes retornavam online, a respectiva função da rede era revertida à configuração padrão (ou seja, cliente e privada). Ao desabilitar o recurso Media Sense por padrão, a função da rede é preservada, bem como a manutenção online de todos os recursos que dependem de endereços IP.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. No painel direito, clique com o botão direito para modificar (definir como 0 para desabilitar) ou excluir o valor do Registro DisableDHCPMediaSense.

  4. Feche o editor de Registro.

  5. Mova todos os recursos de cluster para outro nó ou coloque-os offline. Em seguida, reinicie o nó do cluster para que a alteração entre em vigor.

  6. Repita esse processo em todos os outros nós do cluster que gerou esse aviso.

Para obter mais informações sobre o Registro do Microsoft Windows, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Para obter mais informações sobre detecção do Media Sense e clusters do Windows, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 254651, "Cluster network role changes automatically" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651)

  • 239924, "Como desabilitar o 'Media Sensing' para TCP/IP no Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924)

  • 242430, "Network Adapter Not Available During Cluster Configuration with a Crossover Cable" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430)

  • 278007, "Available Features in Windows Server 2003 Clusters" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278007)


DisableDHCPMediaSense não está definido corretamente no Windows 2000 Server
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a detecção do Media Sense está configurada corretamente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

O Analisador do Exchange Server também examina a seguinte entrada de Registro para determinar a versão do Windows que está em execução no computador de destino:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor igual a 4.0 em CurrentVersion indica que o computador está executando o Microsoft Windows NT® Server 4.0. Um valor 5.0 indica que o computador está executando um sistema operacional Microsoft Windows® 2000 Server, e um valor 5.2 indica que o computador está executando um sistema operacional Microsoft Windows Server™ 2003.

Além disso, o Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows) para determinar o valor da chave Iniciado do ClusSvc, o serviço de Cluster do Microsoft Windows. Um valor Verdadeiro indica que o serviço de Cluster do Windows está em execução, e um valor Falso indica que não está em execução.

Se o Exchange Server Analyzer verificar que o serviço Windows Cluster está sendo executado em um Windows 2000 Advanced Server ou em um Windows 2000 Datacenter Server e se a chave do Registro DisableDHCPMediaSense estiver presente e vaor não estiver definido como 1, será exibido um aviso.

Ao usar o serviço Windows 2000 Server Cluster, se a conectividade de rede for perdida, a pilha TCP/IP é descarregada. Isso significa que todos os recursos de cluster, inclusive recursos em um Servidor Virtual do Exchange, que dependiam de endereços IP ficaram offline. Quando as redes voltaram a ficar online, a função de rede reverteu para a configuração padrão (cliente e particular). Para impedir que isso aconteça, recomendamos que você desabilite a Detecção do Media Sense em todos os custers com base no Windows 2000 Server. A Detecção do Media Sense é desabilitada automaticamente em clusters baseados no Windows Server 2003.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Clique com o botão direito em Parâmetros e clique em Novo | Valor DWORD. Digite DisableDHCPMediaSense no nome e pressione Enter.

  4. No painel da direita, clique duas vezes em DisableDHCPMediaSense e insira um dado de Valor de 1.

  5. Feche o editor de Registro.

  6. Mova todos os recursos de cluster para outro nó ou coloque-os offline. Em seguida, reinicie o nó do cluster para que a alteração entre em vigor.

  7. Repita esse processo em todos os nós do cluster que geraram esse aviso.

Para obter mais informações sobre o Registro do Microsoft Windows, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Para obter mais informações sobre detecção do Media Sense e clusters do Windows, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 254651, "Cluster network role changes automatically" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651)

  • 239924, "Como desabilitar o 'Media Sensing' para TCP/IP no Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924)

  • 242430, "Network Adapter Not Available During Cluster Configuration with a Crossover Cable" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430)

  • 278007, "Available Features in Windows Server 2003 Clusters" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278007)


O tempo limite do disco não está definido no padrão
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o valor de tempo limite do disco foi alterado do valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Disk\TimeOutValue

Se o Exchange Server Analyzer encontrar o TimeOutValue presente e configurado com qualquer valor diferente de 10 e o servidor não tiver cluster, uma mensagem de configuração não-padrão será exibida. Se o Exchange Server Analyzer encontrar o TimeOutValue presente e configurado com qualquer valor diferente de 20 e o servidor tiver cluster, uma mensagem de configuração não-padrão será exibida.

O tempo limite do disco é uma configuração de Registro que define o tempo que o Microsoft Windows® aguardará para que uma unidade de disco rígido responda a um comando. Em um sistema sem cluster, esta chave não está presente e um valor padrão de 10 segundos é usado para todos os discos. Em um cluster do Windows, essa chave está presente e usa um valor padrão de 20 segundos. Se o tempo limite for maior que o valor nesta configuração de Registro, o Windows exibirá um erro e o acesso ao disco será interrompido. Algumas vezes, um valor maior poderá ser configurado, se você estiver executando um software de acesso a disco de vários caminhos. O software de vários caminhos permite conectar múltiplos caminhos físicos (como a fibra) a uma unidade de disco única para redundância. O software de vários caminhos gerencia as múltiplas conexões físicas para que o Windows manipule apenas um identificador único no disco.

A instalação de HBAs (adaptadores de barramento de host) ou de outros controladores de armazenamento pode resultar na criação e configuração desta chave. Quando você instalar ou reinstalar esses drivers, o valor de Registro TimeOutValue será substituído pelo valor exigido por estes drivers. Talvez seja preciso entrar em contato com o fornecedor do hardware para determinar o valor de Registro TimeOutValue correto para a sua configuração.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\Disk\TimeOutValue

  3. No painel da direita, exclua a entrada TimeOutValue. Como alternativa, clique duas vezes na entrada TimeOutValue e defina-a como um dos seguintes valores:

    • Em um servidor sem cluster, defina o valor como 10.

    • Em um servidor com cluster, defina o valor como 20.

    • Se o fabricante do hardware recomendar um valor diferente para um sistema com ou sem cluster, use o valor por ele indicado.

  4. Feche o editor de Registro e reinicie o computador para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a entrada TimeOutValue em sistemas com cluster, consulte o artigo 818877 da Base de Dados de Conhecimento, "Servidores de cluster podem se deparar com tempos limites de conexão para unidades após a instalação ou atualização no recurso de agrupamento do Windows no Windows Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818877).


A ordem de pesquisa DNS está em branco
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_NetworkAdapterConfiguration para determinar se há um valor definido para a chave DNSServerSearchOrder. Se o valor para essa chave em um servidor Exchange estiver em branco, um aviso será exibido.

Esse aviso indica que um ou mais adaptadores de rede nesse computador não tem endereços IP DNS associados a eles. Portanto, quando esse computador tenta se conectar a outro, ele é difundido na rede local por endereços IP. A resolução de nome será lenta, o que tornará lento também o Exchange.

É recomendável que seja inserido ao menos um endereço IP de servidor DNS válido. Se houver mais de um adaptador no computador, verifique se todos os adaptadores têm ao menos um endereço IP de servidor DNS válido.

Para definir o endereço IP DNS em um adaptador de rede

  1. Em Conexões de Rede, clique com o botão direito no adaptador de Rede Local apropriado e clique em Propriedades.

  2. Na guia Geral, clique duas vezes em Protocolo Internet (TCP/IP).

  3. Na guia Geral da página Protocolo Internet (TCP/IP), digite ao menos um endereço IP de um servidor DNS válido e clique em OK.

Para obter mais informações sobre como configurar o DNS para trabalhar com o Exchange, consulte o artigo 322856 da Base de Dados de Conhecimento da Microsoft, "Como configurar o DNS para usar com o Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).


A conexão de pulsação tem gateway padrão
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_NetworkAdapter do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave NetConnectionID. Se o valor da chave NetConnectionID contiver as cadeias de caracteres Internal ou HEART, isso significa que a interface é a rede privada de cluster (pulsação).

O Exchange Server Analyzer também consulta a classe Win32_NetworkAdapterConfiguration do WMI para determinar se há um valor definido para a chave DefaultIPGateway. Se houver um valor definido, isso indicará que um gateway padrão foi configurado para essa interface de rede.

Se o Exchange Server Analyzer verificar que há um valor definido para a chave DefaultIPGateway na interface de rede usada na rede de pulsação do cluster, um aviso será exibido.

Como as redes de cluster privadas são usadas para comunicações de cluster internas, não é necessário configurar um gateway padrão. Para eliminar possíveis problemas de comunicação, é recomendável que você remova todo tráfego de rede desnecessário do adaptador de rede que é usado como adaptador da rede privada de cluster.

Para corrigir esse aviso

  1. Abra a janela Conexões de Rede. Clique com o botão direito em Meus Locais de Rede e clique em Propriedades ou, se Meus Locais de Rede não aparecer na área de trabalho, clique em Iniciar, Programas, Acessórios, Comunicações e Conexões de Rede.

  2. Na janela Conexões de Rede, clique com o botão direito no adaptador de rede que está sendo usado para a rede particular e clique em Propriedades.

  3. Selecione TCP/IP (Protocolo Internet) e clique em Propriedades.

  4. Na área Use o seguinte endereço IP, exclua o endereço iP do gateway padrão.

  5. Clique em OK duas vezes para salvar as alterações.

  6. Repita as etapas de 1 a 5 para cada nó do cluster.

Para obter mais informações sobre configurações recomendadas para a rede privada em um cluster de servidor Windows, consulte o artigo 258750 da Base de Dados de Conhecimento da Microsoft, "Recommended Private 'Heartbeat' Configuration on a Cluster Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


A conexão de pulsação tem endereço de pesquisa DNS
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_NetworkAdapter do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave NetConnectionID. Se o valor da chave NetConnectionID contiver as cadeias de caracteres Internal ou HEART, isso significa que a interface é a rede privada de cluster (pulsação).

O Analisador do Exchange Server consulta também a classe WMI Win32_NetworkAdapterConfiguration para determinar se um valor está definido para a chave DNSServerSearchOrder. Se um valor estiver definido, isso indica que um endereço de pesquisa DNS foi configurado para essa interface de rede.

Se o Analisador do Exchange Server detectar um valor definido para a chave DNSServerSearchOrder na interface de rede usada pela rede de pulsação de cluster, um aviso será exibido.

Como as redes privadas de cluster são usadas para comunicações internas de cluster, não é necessário configurar nenhum servidor DNS. Para eliminar possíveis problemas de comunicação, é recomendável que você remova todo tráfego de rede desnecessário do adaptador de rede que é usado como adaptador da rede privada de cluster.

Para corrigir esse aviso

  1. Abra a janela Conexões de Rede. Clique com o botão direito em Meus Locais de Rede e clique em Propriedades ou, se Meus Locais de Rede não aparecer na área de trabalho, clique em Iniciar, Programas, Acessórios, Comunicações e Conexões de Rede.

  2. Na janela Conexões de Rede, clique com o botão direito no adaptador de rede que está sendo usado para a rede particular e clique em Propriedades.

  3. Selecione TCP/IP (Protocolo Internet) e clique em Propriedades.

  4. Clique em Avançado.

  5. Na guia DNS, selecione um endereço de servidor DNS e clique em Remover. Repita essa etapa para cada endereço de servidor DNS listado.

  6. Desmarque as caixas de seleção Registrar os endereços desta conexão no DNS e Usar esse sufixo DNS de conexão no Registro do DNS.

  7. Clique em OK três vezes para salvar as alterações.

  8. Repita as etapas de 1 a 7 para cada nó do cluster.

Para obter mais informações sobre configurações recomendadas para a rede privada em um cluster de servidor Windows, consulte o artigo 258750 da Base de Dados de Conhecimento da Microsoft, "Recommended Private 'Heartbeat' Configuration on a Cluster Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


A conexão da pulsação tem endereço WINS
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_NetworkAdapter do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave NetConnectionID. Se o valor da chave NetConnectionID contiver as cadeias de caracteres Internal ou HEART, isso significa que a interface é a rede privada de cluster (pulsação).

O Exchange Server Analyzer consulta também a classe Win32_NetworkAdapterConfiguration do WMI para determinar se um valor está definido para a chave WINSPrimaryServer. Se um valor estiver definido, indicará que um endereço WINS primário foi configurado nessa interface de rede.

Se o Exchange Server Analyzer encontrar um valor definido para a chave WINSPrimaryServer na interface de rede usada na rede de pulsação do cluster, um aviso será exibido.

Como redes de cluster privadas são usadas em comunicações internas do cluster, não será necessário configurar nenhum servidor WINS ou usar o NetBIOS. Para eliminar possíveis problemas de comunicação, é recomendável que você remova todo tráfego de rede desnecessário do adaptador de rede que é usado como adaptador da rede privada de cluster.

Para corrigir esse aviso

  1. Abra a janela Conexões de Rede. Clique com o botão direito em Meus Locais de Rede e clique em Propriedades ou, se Meus Locais de Rede não aparecer na área de trabalho, clique em Iniciar, Programas, Acessórios, Comunicações e Conexões de Rede.

  2. Na janela Conexões de Rede, clique com o botão direito no adaptador de rede que está sendo usado para a rede particular e clique em Propriedades.

  3. Selecione TCP/IP (Protocolo Internet) e clique em Propriedades.

  4. Clique em Avançado.

  5. Na guia WINS, selecione um endereço WINS e clique em Remover. Repita esta etapa para cada endereço WINS listado.

  6. Na área de configuração do NetBIOS, selecione Desabilitar NetBIOS sobre TCP/IP.

  7. Clique em OK três vezes para salvar as alterações. Depois de clicar em OK pela primeira vez, você poderá receber o prompt a seguir. Se você receber este prompt, clique em Sim: "Esta conexão tem um endereço WINS principal vazio. Deseja continuar?"

  8. Repita as etapas de 1 a 7 para cada nó do cluster.

Para obter mais informações sobre configurações recomendadas para a rede privada em um cluster de servidor Windows, consulte o artigo 258750 da Base de Dados de Conhecimento da Microsoft, "Recommended Private 'Heartbeat' Configuration on a Cluster Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


A conexão de pulsação é a primeira na ordem de ligação TCP/IP e não na conexão pública.
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta duas classes WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para fazer o seguinte:

  • A classe WMI Win32_NetworkConfiguration é consultada para determinar o valor da chave SettingID para todas as interfaces de rede do cluster. O valor da chave SettingsID é uma GUID que representa um adaptador de rede exclusivo.

  • A classe WMI Win32_NetworkAdapter é consultada para determinar quais adaptadores de rede estão sendo usados para comunicações de rede privada em um cluster do Exchange. A rede privada é usada para comunicações internas do cluster, incluindo a pulsação de cluster.

  • O Analisador do Exchange Server também examina o seguinte valor de Registro para determinar a ordem da ligação dos adaptadores de rede:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Linkage\Bind

O valor do Registro Bind é um valor com várias cadeias de caracteres que contém uma lista de adaptadores de rede em ordem de ligação. A primeira entrada da lista é um adaptador de rede da primeira ligação; a segunda entrada é o segundo adaptador de rede na ordem de ligação e assim por diante.

Se o Analisador do Exchange Server determinar que o adaptador de rede de pulsação do cluster será o primeiro na ordem de ligação, será exibido um aviso.

Para resolver esse problema, certifique-se de que o adaptador de rede pública é a primeira ligação no início da lista. Se você tiver vários adaptadores de rede pública, certifique-se de que o adaptador de rede de pulsação privada seja o último da lista. Se o adaptador de rede de pulsação for o primeiro da lista, poderá impedir a instalação correta de service packs e atualizações.

Para corrigir esse aviso

  1. Na janela Conexões de Rede, clique em Avançada e clique em Configurações Avançadas.

  2. Clique na guia Adaptadores e Ligações.

  3. No campo Conexões, selecione o adaptador de rede privada e use a seta para baixo para mover o adaptador de rede privada para o final da lista.

  4. Repita essas etapas para cada nó do cluster.

Para obter mais informações sobre a configuração ideal de rede para os clusters de servidor Windows, consulte " Clusters de Servidor: Práticas recomendadas de configuração de rede para o Windows 2000 e o Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=34304)

Para obter mais informações sobre configuração correta da pulsação de cluster, consulte o artigo 258750 da Base de Dados de Conhecimento da Microsoft, "Configuração de 'pulsação' particular recomendada em um servidor cluster http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750.


Velocidade de rede de pulsação definida como auto sense/detecção automática
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_NetworkAdapter do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave NetConnectionID. Se o valor da chave NetConnectionID contiver as cadeias de caracteres Internal ou HEART, isso significa que a interface é a rede privada de cluster (pulsação).

O Exchange Server Analyzer também lê o seguinte valor de Registro para determinar as configurações de velocidade de link e dúplex da placa de interface de rede usada na rede de pulsação de cluster:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\ <NetworkCardDeviceID> \SpeedDuplex

Além disso, o Exchange Server Analyzer lê o seguinte valor de Registro para determinar se a detecção automática de velocidade da rede está habilitada:

HKLM\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\Ndi\Params\SpeedDuplex\enum\0

Se o valor da chave 0 contiver a cadeia de caracteres AUTO, isso indicará que a detecção automática de velocidade da rede está habilitada.

Se o Exchange Server Analyzer determinar que SpeedDuplex está definido como 0 e a detecção automática de velocidade da rede está habilitada na rede de pulsação de cluster, um aviso será exibido.

A comunicação entre os nós de cluster de servidores é fundamental para a operação normal do cluster. Se você usar um adaptador de rede Ethernet de velocidade múltipla nas comunicações de cluster e configurar o adaptador para detectar automaticamente a velocidade da rede, ele poderá causar problemas no cluster. Durante o processo de detecção, os pacotes não podem ser identificados pelo adaptador e devem ser colocados na fila. Alguns adaptadores podem acionar involuntariamente nova ocorrência do processo de detecção ocasionalmente. Por essa razão, as comunicações são enfileiradas e sofrem atraso. Atrasos desse tipo podem fazer com que os nós de cluster não recebam prontamente os pacotes críticos, podendo causar failover prematuro dos recursos do cluster. É recomendável que a rede de pulsação de um cluster seja definida manualmente como 10 megabits e half-duplex. Essa configuração fornecerá uma largura de banda suficiente e comunicação confiável.

Para corrigir esse aviso

  • Configure a placa de interface de rede de pulsação com uma velocidade de link de 10 megabits e half-duplex. Como as etapas de configuração de cada placa de rede são diferentes, siga as instruções do seu fornecedor de hardware para configurar corretamente a rede de pulsação. A configuração dessas opções pode exigir um driver atualizado.

Para obter mais informações sobre configurações recomendadas para a rede privada em um cluster de servidor Windows, consulte o artigo 258750 da Base de Dados de Conhecimento da Microsoft, "Recommended Private 'Heartbeat' Configuration on a Cluster Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


A profundidade da fila do Adaptador de Barramento de Host está definida como 32
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2006-10-11

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar a profundidade da fila dos HBAs (adaptadores de barramento de host) instalados no computador do Exchange Server:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\elxstor\Parameters\Device\DriverParameter

Se o Exchange Server Analyzer verificar que o valor de DriverParameter está definido como 32, um aviso será exibido.

Um HBA é um controlador de disco para SANs (redes de área de armazenamento). A profundidade da fila do HBA define o número máximo de solicitações de fila pendentes. Em geral, o valor recomendado para DriverParameter é 128. No entanto, esse pode não ser o valor ideal para a profundidade da fila do HBA para todos os HBAs em todos os computadores do Exchange Server. Por isso, consulte o fabricante do HBA para obter o valor ideal do seu hardware específico.

Para corrigir esse aviso

  1. Entre em contato com o fabricante do hardware para determinar a configuração ideal dos HBAs.

  2. Monitore o desempenho do disco usando o utilitário Monitor do Sistema do Microsoft Windows®.

  3. Atualize o hardware do HBA para os níveis de firmware e drivers mais recentes.

Para obter mais informações sobre o design do armazenamento e otimização do Exchange Server, consulte "Otimização do Armazenamento no Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=49324).


Configuração de inclusão de memória a quente
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2006-02-22

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Computer System do WMI (Instrumentação de Gerenciamento do Windows®) para determinar se o servidor tem suporte para recursos de inclusão de memória a quente. O Exchange Server Analyzer também consulta a classe Win32_OperatingSystem do WMI para determinar o seguinte:

  • A opção /3GB está definida no arquivo Boot.ini.

  • O kernel PAE (Extensões de Endereço Físico) está carregado.

  • Qual a edição do sistema operacional que está em execução no servidor.

Finalmente, o Exchange Server Analyzer consulta a seguinte entrada do Registro para determinar se o parâmetro de configuração DynamicMemory existe e está definido corretamente:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Se o Exchange Server Analyzer determinar que todos os critérios a seguir são verdadeiros, ele exibirá uma mensagem de erro:

  • O computador tem suporte para inclusão de memória a quente e, por padrão, o recurso está habilitado.

  • O computador está executando o Microsoft Windows Server™ 2003, Enterprise Edition, ou o Windows Server 2003, Datacenter Edition.

  • O kernel PAE está carregado.

  • A opção /3GB está definida no Boot.ini.

  • O parâmetro de configuração do Registro DynamicMemory não está definido, está definido como um valor 0 ou está definido como um valor maior que 3.

Observação:
Se o computador tiver suporte para a inclusão de memória a quente, mas o fabricante do hardware desabilitar o recurso por padrão, o Exchange Server Analyzer exibirá uma mensagem de aviso, em vez de uma mensagem de erro.

O recurso de inclusão de memória a quente foi introduzido no Windows Server 2003, Enterprise Edition, e Windows Server 2003, Datacenter Edition, para que os administradores de sistema adicionassem mais memória física a um computador sem reiniciá-lo. Esse recurso é útil nos servidores que oferecem suporte a aplicativos de banco de dados relacional que utilizam muita memória, como o Microsoft SQL Server. Contudo, como o Exchange Server não pode usar mais de 4 GB de memória física, esse recurso não é útil para o Exchange Server.

Nem todos os computadores têm suporte para a inclusão de memória a quente. Para os computadores que oferecem suporte, alguns fabricantes de hardware habilitam o recurso por padrão e outros fornecem controles no BIOS (Sistema Básico de Entrada/Saída). Se, durante o processo de inicialização, a inclusão de memória a quente estiver habilitada, o kernel do sistema operacional deverá pré-alocar espaço para lidar com qualquer memória futura adicionada ao computador. Portanto, os recursos do kernel são alocados com base nas capacidades do computador, e não em que está realmente instalado. A memória do kernel é um recurso precioso nos computadores que executam o Microsoft Exchange Server. Como o kernel pode alocar quantidades significativas de recurso na memória que talvez nunca seja instalada e, devido à natureza da memória física usada pelo Exchange Server, é possível alcançar desempenho e escalabilidade adicionais, desabilitando o recurso de inclusão de memória a quente. Deixar o recurso habilitado pode fazer com que o tamanho máximo do pool paginado seja muito menor do que o esperado. Isso pode degradar bastante o desempenho, causar bloqueios do sistema e, por último, provocar uma paralisação do serviço.

Exemplos de tamanhos máximos esperados de pool paginado (quanto maior, melhor):

  • 240 MB Um computador que possui 4 GB de memória física sem suporte para inclusão de memória a quente ou com esse suporte desabilitado.

  • 210 MB Um computador que possui 4 GB de memória física, mas pode suportar a inclusão de até 32 GB de memória a quente

  • 160 MB Um computador que possui 4 GB de memória física, mas pode suportar a inclusão de até 64 GB de memória a quente

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse problema em computadores que executam o Windows Server 2003 Service Pack 1 (SP1) ou posterior

  1. Defina o seguinte parâmetro do Registro para desabilitar o recurso de inclusão de memória a quente:

    Path

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    Valor

    DynamicMemory

    Tipo

    REG_DWORD

    Data

    0x1
    Observação:
    O valor deste parâmetro de configuração é expresso como o número, em gigabytes, da memória física endereçável máxima, com a inclusão de memória a quente, se a memória física instalada durante a inicialização não for superior. Ao definir o valor como 1, o kernel reserva espaço para um total de 1 GB de memória do sistema ou a quantidade total de memória física instalada durante a inicialização, o que for maior.

  2. Reiniciar o computador
Para corrigir esse problema em computadores que executam o Windows Server 2003 sem o SP1 instalado

  • Entre em contato com o fornecedor do hardware para determinar se o recurso de inclusão de memória a quente pode ser desabilitado no BIOS.

  • Se a inclusão de memória a quente não puder ser controlada através do hardware, o método recomendado é atualizar o Windows Server 2003 SP1 e seguir as etapas de resolução aqui apresentadas para implementar o parâmetro DynamicMemory. Se não for possível atualizar para o SP1, a alternativa será definir a opção /NOPAE no arquivo Boot.ini. Definir essa opção instruirá o computador a não reconhecer nenhuma memória acima do limite de 4 GB. Use essa opção em computadores que executam o Windows Server 2003 anterior ao SP1, mas não a utilize nos computadores que executam o SP1, porque ela pode desabilitar sem intenção os novos recursos, incluindo o suporte para DEP (Prevenção de Execução de Dados).

Para obter mais informações

Para obter mais informações sobre o suporte de inclusão de memória a quente no Windows Server 2003, consulte Suporte de inclusão de memória a quente no Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=57183).


O software Internet SCSI Initiator está desatualizado
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2006-04-03

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_SCSIController para determinar o valor da chave DriverName para o driver iScsciPrt. O Analisador do Exchange Server consulta também a classe WMI CIM_Datafile para determinar o valor da chave Versão listada no arquivo do driver iScsciPrt. Se o Analisador do Exchange Server detectar um valor de subcadeia de caracteres na chave Versão do driver iScsciPrt, inferior a 1.748, será exibido um aviso.

iSCSI (Internet small computer system interface) é um método (baseado em IP) com base em Protocolo de Internet, elaborado para enviar comandos SCSI (small computer system interface) encapsulados em pacotes IP por meio de redes TCP/IP. Como o iSCSI é baseado em IP, os dados podem ser transmitidos por meio de LANs (redes de área local), WANs (redes de longa distância) e pela Internet para locais de armazenamento remoto. Os sistemas operacionais Microsoft Windows exibem os discos rígidos iSCSI para programas, como o Exchange Server 2003 ou Exchange 2000 Server, como discos rígidos conectados diretamente ao computador do Exchange Server.

A Microsoft recomenda cuidado ao implantar o Exchange Server 2003 ou o Exchange 2000 Server com iSCSI. Como a iSCSI usa o protocolo de transporte SCSI para transmitir dados de bloqueio por meio de redes TCP/IP, o ambiente de uma rede pode introduzir componentes normalmente considerados caminhos de entrada/saída de alta velocidade. Para maximizar a taxa de transferência, configure o Exchange Server para maximizar as atividade de armazenamento em cache, e verifique se a latência relacionada ao tráfego de iSCSI é minimizada. A menos que especificado de outra forma pelo fornecedor de seu armazenamento, também é altamente recomendável usar a última compilação disponível do Microsoft iSCSI Software Initiator.

Para corrigir esse aviso

  1. Baixe a última versão do Microsoft iSCSI Software Initiator da Centro de Download da Microsoft (http://go.microsoft.com/fwlink/?LinkId=33817).

  2. Consulte novamente as notas da versão no site da Microsoft (http://go.microsoft.com/fwlink/?LinkId=40951).

  3. Consulte novamente o Guia do Usuário no site da Microsoft (http://go.microsoft.com/fwlink/?LinkId=40963).

  4. Faça um backup completo do computador.

  5. Aplique a última atualização de versão.

Para obter mais informações sobre o suporte para iSCSI no Exchange 2000 Server e Exchange Server 2003, consulte o artigo 839686 da Base de Dados de Conhecimento da Microsoft, "Suporte para os componentes da tecnologia iSCSI no Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839686).

Para obter mais informações sobre a tecnologia iSCSI e o suporte da Microsoft para iSCSI, consulte o site da Microsoft, "Tecnologias de Armazenamento da Microsoft - iSCSI" (http://go.microsoft.com/fwlink/?LinkId=27514).


Os contadores de desempenho de disco Lógico e Físico estão desabilitados
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se os contadores de desempenho do disco físico e lógico estão desabilitados:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance\Disable Performance Counters

Se o Exchange Server Analyzer detectar que o valor de Desabilitar Contadores de Desempenho está presente e configurado como 1, será exibido um aviso.

Há dois tipos de contadores de desempenho relacionados a disco, publicados em um computador servidor executando um sistema operacional Microsoft Windows®:

  • Aqueles usados pelo subsistema de desempenho do Microsoft Win32® e pela WMI (Instrumentação de Gerenciamento do Windows).

  • Aqueles usados pelos aplicativos herdados que chamam a API IOCTL_DISK_PERFORMANCE para recuperar informações não processadas do contador.

  • Os contadores de desempenho usados pelo Win32 e WMI são habilitados, por padrão, no Microsoft Windows Server™ 2003 e no Windows 2000 Server. Os contadores não processados são desabilitados, por padrão, em ambos os sistemas operacionais. Se o valor do Registro de Desabilitar Contadores de Desempenho, que não está presente por padrão em nenhum dos dois sistemas operacionais, for adicionado e configurado como 1, os contadores de desempenho do Win32/WMI serão desabilitados e a coleta de dados desses contadores não poderá ser executada.

O modo mais comum de desabilitar os contadores do Win32/WMI é com a ferramenta ExCtrLst.exe (Lista de Contadores de Desempenho Extensíveis). Essa ferramenta gráfica, disponível nos Kits de Recursos do Windows 2000 Server e do Windows Server 2003, permite que um administrador habilite ou desabilite seletivamente a publicação de objetos de desempenho. Quando usada para desabilitar um objeto de desempenho, a ferramenta ExCtrLst.exe adiciona a entrada Desabilitar Contadores de Desempenho ao Registro e a configura com um valor igual a 1. Se usada para reabilitar um contador desabilitado, a ferramenta ExCtrLst.exe alterará o valor de Desabilitar Contadores de Desempenho para 0. (Convém observar que a ferramenta não exclui a entrada Desabilitar Contadores de Desempenho.)

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance

  3. No painel direito, clique duas vezes em Desabilitar Contadores de Desempenho e defina essa entrada como um valor igual a 0. Como alternativa, é possível excluir a entrada Desabilitar Contadores de Desempenho para reabilitar os contadores.

  4. Saia do Editor do Registro e reinicie qualquer aplicativo que coleta dados de desempenho, para que a alteração entre em vigor.

Para obter mais informações sobre a ferramenta ExCtrLst.exe, consulte "Exctrlst.exe: Lista de contadores de desempenho extensíveis" (http://go.microsoft.com/fwlink/?linkid=34436).


Vários gateways padrão detectados
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer solicita que a classe Win32_NetworkAdapterConfiguration do WMI (Instrumentação de Gerenciamento do Windows) determine a contagem de instâncias da chave DefaultIPGateway. Cada adaptador de rede publica o endereço de gateway padrão configurado para WMI através dessa chave. Se o Exchange Server Analyzer determinar que há mais de uma instância configurada da chave DefaultIPGateway, será exibido um aviso.

Esse aviso indica que foram encontrados vários adaptadores de rede e mais de um possui um gateway padrão configurado. Quando vários adaptadores são usados e configurados com gateways padrão separados, talvez se perca a conectividade com computadores nas redes remotas. Além disso, o uso de vários gateways padrão que conectam diferentes sub-redes é conhecido por causar problemas com resolução DNS, entrega de mensagem SMTP, consultas LDAP e nova notificação de email para clientes Microsoft Office Outlook® 2003. Muitos desses problemas podem impedir a inicialização do Exchange Server ou o processo de envio e recebimento de mensagens.

É recomendável deixar apenas um gateway padrão e remover todos os outros de um dos adaptadores de interface de rede no computador do Exchange Server. Os computadores do Exchange Server muitas vezes têm diversas bases quando o Microsoft Internet Security and Acceleration (ISA) Server tiver sido instalado no mesmo computador. Até mesmo quando você executa o Exchange Server e o ISA Server no mesmo computador, não é recomendável o uso de vários gateways padrão. Se o Exchange Server e o ISA Server não estiverem instalados no mesmo computador é recomendável que você não torne o computador do Exchange Server um computador multihomed.

Para corrigir esse aviso

  1. Abra a janela Conexões de Rede. Clique com o botão direito em Meus Locais de Rede e clique em Propriedades ou, se Meus Locais de Rede não aparecer na área de trabalho, clique em Iniciar, Programas, Acessórios, Comunicações e Conexões de Rede.

  2. Na janela Conexões de Rede, clique com o botão direito na conexão de rede que contém a entrada de gateway padrão a ser removida e clique em Propriedades.

  3. Selecione TCP/IP (Protocolo Internet) e clique em Propriedades.

  4. Exclua o endereço IP do campo Gateway padrão.

  5. Clique em OK duas vezes para salvar as alterações.

  6. Repita esse processo para todas as outras conexões de rede que contêm uma entrada de gateway padrão, exceto para a entrada que você deseja manter.

Para obter mais informações sobre problemas encontrados em computadores que usam vários gateways padrão, consulte o artigo 159168, "Vários gateways padrão podem causar problemas de conectividade" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159168) da Base de Dados de Conhecimento Microsoft.

Para obter mais informações sobre a configuração de gateways padrão em computadores com diversas bases, consulte o artigo 157025, "Configuração de gateway padrão para computadores com diversas bases" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=157025) da Base de Dados de Conhecimento Microsoft.


Tamanho do Arquivo de Paginação Maior que a Memória Física Total
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2007-07-30

A ferramenta Microsoft Exchange Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_PageFile para determinar o valor da chave MaximumSize. Essa chave representa o tamanho máximo do arquivo de paginação configurado atualmente.

O Exchange Analyzer também consulta a classe Win32_ComputerSystem do WMI para determinar o valor da chave TotalPhysicalMemory. Esse valor representa a quantidade de RAM instalada no computador.

Caso o Exchange Analyzer determine que o valor da chave MaximumSize do Win32_PageFile é maior do que 1,5 vezes o valor da chave Win32_ComputerSystem TotalPhysicalMemory, um erro é exibido.

O arquivo de paginação (pagefile.sys) é um arquivo oculto no disco rígido usado pelo Windows para reter dados temporários quando o sistema fica com pouca RAM. O arquivo de paginação também é conhecido como arquivo de paging ou arquivo de troca. A memória virtual é formada pelo arquivo de paginação e pela RAM.

O tamanho de arquivo de paginação recomendado é o equivalente a 1,05 vezes a quantidade de memória RAM, até o máximo de 4.095 MB. Isso significa que o maior tamanho de arquivo de paginação por volume que você pode definir é 4.095 MB.

Observação:
Para impedir a fragmentação do arquivo de paginação, é recomendável definir os valores inicial e máximo do tamanho do arquivo de paginação como um mesmo valor. Se você reduzir o tamanho da definição do tamanho inicial ou máximo do arquivo de paginação, será necessário reiniciar o computador para verificar os efeitos dessas alterações. Os aumentos normalmente não exigem uma reinicialização.
Para alterar as configurações do arquivo de paginação

  1. Clique em Iniciar, Painel de Controle e, em seguida, clique em Sistema.

  2. Na guia Avançado, em Desempenho, clique em Configurações.

  3. Na caixa de diálogo Opções de Desempenho, na guia Avançado, em Memória Virtual, clique em Alterar.

  4. Em Unidade [Rótulo do Volume], clique na unidade que contém o arquivo de paginação que você deseja alterar.

  5. Em Tamanho do arquivo de paginação para a unidade selecionada, clique em Tamanho personalizado e digite o tamanho de arquivo de paginação recomendado, em megabytes, nos campos Tamanho inicial (MB) e Tamanho máximo (MB) e clique em Definir.

Para obter mais informações sobre arquivos de paginação, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 197379, "Configurando arquivos de paginação para otimização e recuperação no Windows Server 2003, no Windows 2000 e no Windows NT" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)

  • 307973, "Como configurar opções de falha de sistema e recuperação no Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307973)

  • 254649, "Visão Geral das opções de memória e arquivo de reciclagem para Windows Server 2003, Windows XP e Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254649)

  • 241046, "Não é possível criar um Arquivo Memory.dmp no Computador com mais de 4 GB de RAM" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=241046)


O endereço de servidor WINS secundário está em branco
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_NetworkAdapterConfiguration do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se há um valor definido para a chave WINSSecondaryServer. Se o valor para essa chave em um servidor Exchange estiver em branco, um aviso será exibido.

O Exchange Server 2003 e Exchange 2000 Server têm várias dependências de NetBIOS. Além disso, os clientes que estiverem executando versões do Microsoft Outlook® anteriores ao Microsoft Office Outlook 2003 também precisam de resolução de nome NetBIOS. Por exemplo, a funcionalidade do Exchange a seguir depende da resolução de nome NetBIOS:

  • O programas de Instalação do Exchange Server 2003 e Exchange 2000 Server, especialmente em servidores em cluster.

  • Exchange Mailbox Merge Wizard (ExMerge) em um computador do Exchange Server 2003 ou Exchange 2000 Server.

  • Alterando uma senha para uma caixa de correio do Exchange Server 2003 ou Exchange 2000 Server por meio do Outlook Web Access.

  • Gerenciador do Sistema Exchange em um computador Exchange Server 2003 ou Exchange 2000 Server.

Dependendo da topologia de rede da sua organização, você poderá ignorar esse aviso com segurança. Em redes compostas por uma única NetBIOS de sub-rede, as difusões normalmente são capazes de lidar com requisitos de resolução de nome NetBIOS de uma implantação do Exchange.

Em grandes organizações, a resolução de nome NetBIOS por meio de difusões pode não funcionar corretamente. Como as difusões NetBIOS normalmente não atravessam sub-redes, as redes roteadas precisam de um método alternativo para resolver os nomes NetBIOS. O método preferido para fazer isso é o WINS (Windows Internet Name Service). O WINS fornece um banco de dados distribuído para registrar e consultar mapeamentos dinâmicos dos nomes NetBIOS para computadores e grupos usados na rede. O WINS mapeia nomes NetBIOS para endereços IP e foi criado para resolver os problemas resultantes da resolução de nome NetBIOS em ambientes roteados. O WINS é a melhor opção para resolução de nome NetBIOS em redes roteadas que usam NetBIOS sobre TCP/IP.

As operações e funções do Exchange Server 2003 e Exchange 2000 Server em uma organização grande ou com sub-redes sem WINS não foram totalmente testadas. A Microsoft exige que as empresas que executam o Exchange em redes roteadas ou segmentadas usem o WINS para resolução de nome NetBIOS. A execução do Exchange em um ambiente roteado ou segmentado sem WINS não tem suporte.

Recomendamos que você implemente um ambiente WINS com tolerância a falhas que possua pelo menos dois servidores WINS. Os servidores WINS podem atuar como um servidor WINS primário ou secundário para um cliente. A diferença entre servidores WINS primários ou secundários é a prioridade com que os clientes entram em contato com eles. Um servidor WINS primário é o primeiro servidor que um cliente entra em contato para executar suas operações de serviço de nome NetBIOS. Um cliente entra em contato com um servidor WINS secundário somente quando um servidor WINS primário não pode preencher a solicitação; por exemplo, se ele estiver inacessível quando o cliente fizer a solicitação ou você não puder resolver um nome para o cliente.

Se um servidor WINS primário não preencher uma solicitação, o cliente fará a mesma solicitação do seu servidor WINS secundário. Se mais de dois servidores WINS estiverem configurados para o cliente, o cliente tentará os servidores WINS secundários adicionais até que a lista se esgote ou que um dos servidores WINS responda à solicitação com êxito. Depois que um cliente usa um servidor WINS secundário, ele tenta periodicamente voltar ao servidor WINS primário correspondente para futuras solicitações de serviço de nome.

É uma prática recomendada configurar pelo menos um servidor WINS secundário nos computadores servidores Exchange em uma rede roteada ou segmentada.

Para corrigir esse aviso

  1. Abra Conexões de Rede.

  2. Clique com o botão direito na conexão de rede que você deseja configurar e, em seguida, selecione Propriedades.

  3. Na guia Geral (para uma conexão local) ou na guia Rede (para todas as outras conexões), clique em Protocolo (TCP/IP) e clique em Propriedades.

  4. Clique em Avançado, clique na guia WINS e em Adicionar.

  5. Em Servidor WINS TCP/IP, digite o endereço IP de um servidor WINS secundário e, em seguida, clique em Adicionar.

  6. Repita as etapas 4 e 5 para cada endereço IP de servidor WINS adicional que você deseja incluir e clique em OK. Você pode alterar a ordem de preferência dos servidores WINS usando as teclas de setas.

  7. Verifique se Habilitar NetBIOS sobre TCP/IP está selecionada.

  8. Clique em OK para salvar suas alterações.

Para obter mais informações sobre requisitos de resolução de nome NetBIOS para Exchange, consulte o artigo 837391 da Base de Dados de Conhecimento da Microsoft, "O Exchange Server 2003 e o Exchange 2000 Server precisam de resolução de nome NetBIOS para funcionalidade completa" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391).


O Servidor é um PC Virtual
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2007-03-28

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Model do computador do Exchange Server. Se o valor dessa chave contiver a cadeia de caracteres "Virtual Machine", será exibido um erro.

A presença da cadeia de caracteres "Virtual Machine" indica que o computador do Exchange Server está sendo executado dentro de um computador virtual Microsoft Virtual PC 200x. Virtual PC 200x é uma solução de virtualização de software que permite executar vários sistemas operacionais baseados em PC simultaneamente em uma estação de trabalho. A Microsoft não oferece suporte para execução de nenhuma versão do Microsoft Exchange Server em uma máquina virtual ou um emulador. O mesmo vale para execução do Exchange Server no Microsoft Virtual Server 200x, no Microsoft Virtual PC 200x ou em qualquer programa de máquina virtual de terceiros. As plataformas do Microsoft Exchange Server são criadas e testadas para serem executadas apenas em hardware físico, especialmente naquelas plataformas de hardware listadas no Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219).

Para corrigir esse erro

  1. Mova as caixas de correio do Exchange Server que está sendo executado no Virtual PC 200x para um computador não virtual do Exchange Server.

  2. Relocalize quaisquer pastas públicas e transfira todas as funções mantidas pelo servidor virtual Exchange conforme necessário.

  3. Desinstale o Exchange da máquina virtual para descomissionar e remover da sua infra-estrutura do Exchange e do serviço de diretório do Active Directory®.

Para obter mais informações sobre suporte a computadores do Exchange Server em execução em ambientes virtuais, consulte o artigo 320220 da Base de Dados de Conhecimento Microsoft, "Diretiva de suporte para o Exchange Server 2003 em execução no software de virtualização de hardware" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320220).

Para obter mais informações sobre o Microsoft Virtual PC, consulte a home page do Microsoft Virtual PC (http://go.microsoft.com/fwlink/?linkid=34663).


Esse disco está reportando um erro
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_DiskDrive para determinar o valor da chave Status de cada disco. Se o Analisador do Exchange Server detectar que o valor da chave Status de qualquer disco não é igual a OK, será exibido um erro.

A chave Status informa o status atual do objeto de disco. Podem ser definidos vários status operacionais e não operacionais. Os status operacionais são:

  • OK

  • Degradado

  • Falha Prev (um elemento, como um disco rígido com SMART ativado, pode estar funcionando corretamente, mas prevendo uma falha no futuro próximo).

  • Os status não operacionais são:

  • Erro

  • Iniciando

  • Parando

  • Serviço (isso pode ser aplicado durante a re-prateação de um disco, o recarregamento de uma lista de permisssões do usuário ou outra tarefa administrativa).

A chave Status é herdada da classe WMI CIM_ManagedSystemElement, que contém os seguintes valores:

  • OK

  • Erro

  • Degradado

  • Desconhecido

  • Falha Prev

  • Iniciando

  • Parando

  • Serviço

  • Analisado

  • NonRecover

  • Nenhum contato

  • Comm perdido

Geralmente, a Microsoft não fornece documentação sobre como solucionar problemas de falhas de disco para fornecedores de hardware específicos.

Para corrigir esse erro

  1. Verifique todas as conexões de disco e de cabos, aguarde 10 minutos e, então, verifique o valor da chave Status.

  2. Se o valor retornado não for um valor do modo manutenção (por exemplo, o valor não for igual a Serviço, siga as etapas para solução de problemas de disco, recomendadas pelo fabricante do disco rígido de seu sistema. Em alguns casos, é possível que o fabricante do disco rígido tenha um software para solução de problemas, que você pode instalar para analisar o problema.

Para obter informações genérica sobre armazenamento, relacionadas ao Exchange, consulte "Soluções de armazenamento para o Microsoft Exchange 2000 Server" no Centro de Download da Microsoft (http://go.microsoft.com/fwlink/?LinkId=1715).

Para obter informações genéricas sobre armazenamento, relacionadas ao Microsoft Windows Server™ 2003, consulte "Serviços de armazenamento do Windows Server 2003" no TechCenter do Microsoft Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=33811).

Para obter informações genéricas sobre armazenamento, relacionadas ao Windows 2000 Server, consulte "Serviços de armazenamento do Windows 2000" no site do Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=33812).


Esse servidor Exchange tem mais de oito processadores
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor atual de NumberOfProcessors. Se o Exchange Server Analyzer detectar que o valor de NumberOfProcessors é maior que 8, será exibido um aviso. Porém, se esse servidor estiver configurado para usar a Tecnologia Hyper-Threading da Intel, esse aviso seguramente poderá ser ignorado. A Tecnologia Hyper-Threading permite que aplicativos de software com multithreads executem threads em paralelo. A Tecnologia Hyper-Threading exige um sistema de computador com um processador Intel Pentium 4 com suporte à tecnologia Hyper-Threading e um conjunto de chips habilitado para tecnologia HT, BIOS e sistema operacional.

O Exchange 2000 Server e o Exchange Server 2003 podem usar efetivamente apenas oito processadores em um computador. Especificamente, o serviço Armazenamento de Informações do Microsoft Exchange está otimizado para o máximo de oito processadores.

Em computadores que possuem mais de oito processadores, é recomendável o uso de particionamento de hardware para particionar o computador em vários computadores de oito processadores ou em vários computadores de quatro processadores. Como alternativa, você pode configurar a afinidade da CPU para o processo de Armazenamento de Informações do Microsoft Exchange (Store.exe) para apenas oito processadores.

Assim que o processo de Armazenamento de Informações do Microsoft Exchange tiver sido limitado para oito processadores, seja por afinidade da CPU ou através de particionamento de hardware, é recomendável que você faça a atualização para o service pack disponível mais recente e adquira os pacotes cumulativos de atualizações do Exchange. Isso será especialmente importante se você estiver executando o Exchange Server 2003.

Anteriormente, o desempenho dos servidores Exchange mostravam aperfeiçoamentos marginais quando o número de processadores em servidores back-end aumentava para mais de quatro. Com mais de oito processadores, o aumento do desempenho marginal é máximo e, às vezes, ele pode piorar. A queda no desempenho com o ganho de processadores adicionais se tornou mais evidente com os tipos de processadores usados nos computadores mais modernos. Com o Exchange Server 2003 Service Pack 1, a escalabilidade com processadores adicionais é muito melhor. Quando a tecnologia hyper-threading está habilitada, os servidores de oito processadores fornecem um aumento de 50 porcento no desempenho em relação aos servidores de quatro processadores. Atualmente, o uso de computadores com oito processadores para servidores back-end é apropriado em muitos cenários. Servidores de processador duplo ainda são muito recomendados para servidores front-end.

Conforme declarado, se o computador do Exchange Server estiver usando a Tecnologia Hyper-Threading, este aviso seguramente poderá ser ignorado.

Para corrigir esse aviso em sistemas que não usam a Tecnologia Hyper-Threading

  1. Aplique o service pack e os pacotes cumulativos de atualizações mais recentes para o Exchange, que podem ser baixados do site Downloads para o Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=25097).

  2. Defina a afinidade da CPU para o serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) para oito CPUs, ou use o particionamento de hardware para criar um servidor Exchange com oito processadores. Entre em contato com o fabricante do hardware para obter detalhes sobre como fazer isso.

Para obter mais informações sobre a escalabilidade do recurso do Exchange Server, consulte o artigo 827281 da Base de Dados de Conhecimento Microsoft, "Escalabilidade de CPU e memória para o Exchange 2000 e Exchange 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827281).

Para obter mais informações, consulte também o artigo 271088 da Base de Dados de Conhecimento, "XGEN: Otimizando os servidores do Active Directory do Windows 2000 com seis ou oito processadores a serem executados com o Exchange 2000" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=271088).

Para obter mais informações sobre a Tecnologia Hyper-Threading, consulte o site da Intel (http://www.intel.com/info/hyperthreading).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


Este servidor Exchange tem mais de 4 GB de memória
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2006-06-20

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave TotalPhysicalMemory para cada computador do Exchange Server.

Se o Exchange Server Analyzer detectar que o valor para TotalPhysicalMemory é maior que 4294967296, mas menor que 6442450944, um aviso será exibido.

Se o Exchange Server Analyzer detectar que o valor para TotalPhysicalMemory é maior que 6442450944, um erro será exibido.

Um valor para TotalPhysicalMemory maior que 4294967296 indica que o computador do Exchange Server possui mais de 4 GB de memória instalada, enquanto um valor para TotalPhysicalMemory maior que 6442450944 indica que o computador do Exchange Server possui mais que 6 GB de memória instalada. Em um computador com 4 GB ou mais de memória física, o Exchange Server não usará mais que 3 GB. No entanto, se o computador está dedicado a executar apenas o Exchange Server, não há necessidade de instalar mais de 4 GB de memória.

O mais importante é que quanto mais RAM física houver, mais entradas de endereço de kernel do sistema operacional serão necessárias para executar o mapeamento virtual para físico necessário. Isso reduz as PTEs (entradas de tabela de página) livres do sistema e a memória de pool paginado disponível para o sistema, o que poderá causar instabilidade.

Como exemplo, um computador com 8 GB de RAM física terá 3.000 PTEs de sistema livres a menos e 30 MB de redução no tamanho máximo de pool paginado em relação a um computador com somente 4 GB de RAM física.

É recomendável seguir uma destas duas soluções:

  • Reduza a quantidade de memória no sistema para 4 GB.

  • Defina o parâmetro BurnMemory no arquivo Boot.ini para reduzir a memória física para 4 GB, conforme descrito posteriormente neste artigo.

Além disso, se você estiver executando vários aplicativos que exigem memória adicional, poderá executar um hotfix do Windows que ajudará a impedir falhas no armazenamento de informações do Exchange que poderão ocorrer quando houver mais de 4 GB de RAM disponível. Observe que a prática recomendada é dedicar um computador para executar apenas o Exchange Server. Para obter detalhes sobre o hotfix, consulte o artigo 834628 da Base de Dados de Conhecimento Microsoft, "Dados são danificados quando o PAE está habilitado em um computador baseado em Windows Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052).

Para corrigir esse aviso

  1. No Windows Explorer, navegue para a partição do sistema.

  2. Se não for possível ver o arquivo boot.ini, talvez seja porque as Opções de Pasta estão definidas como Ocultar arquivos protegidos do sistema operacional. Se esse for o caso, no Windows Explorer, clique em Ferramentas, Opções de Pasta e clique na guia Exibir. Desmarque a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado). Quando a caixa de aviso aparecer, clique em Sim.

  3. Depois que o arquivo boot.ini estiver visível no Explorer, clique com o botão direito no arquivo, clique em Abrir com e escolha Bloco de Notas para abrir o arquivo.

  4. Na seção [Operating Systems], adicione a seguinte opção à linha de inicialização: /BURNMEMORY=<Valor em MB>

    Por exemplo:

    Se houver 6 GB de memória física instalada, use /BURNMEMORY=2048 para reduzir a memória disponível para 4 GB. Se houver 8 GB de memória física instalada, use /BURNMEMORY=4096.

  5. Salve as alterações e feche o Bloco de Notas.

  6. Reinicialize o computador do Exchange Server para que a alteração tenha efeito.

Para obter mais informações sobre os parâmetros que podem ser usados no arquivo Boot.ini, consulte os seguintes arquivos da Base de Dados de Conhecimento Microsoft:

  • 833721: "Opções de alternância disponíveis para os arquivos Boot.ini do Windows XP e Windows Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052)

  • 102873: "Uso e convenções de nomenclatura de caminho do ARC e do BOOT.INI" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052)


Esse disco lógico tem menos de 3 GB de espaço disponível
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2007-03-14

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_LogicalDisk do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave FreeSpace em discos que tenham a chave Win32_LogicalDisk DriveType definida como 3 (o que indica um disco local). Se o valor da chave FreeSpace de um disco local do computador do Exchange Server for inferior a 3 GB, um aviso será exibido. É recomendável que todos os discos dos computadores do Exchange Server tenham sempre caixas de correio com pelo menos 50 por cento de capacidade livre.

Ter capacidade em disco suficiente é essencial. Quando um disco de banco de dados ficar sem espaço o banco de dados ficará offline. Quando um disco de log de transações ficar sem espaço, ele fará com que todos os bancos de dados nesse grupo de armazenamento fiquem offline. A configuração de espaço adicional é muitas vezes difícil de ser feita rapidamente e executar a compactação offline para recuperar espaço pode levar muito tempo. Na maior parte dos casos, ficar sem espaço em disco resulta em uma interrupção de disponibilidade de um ou mais bancos de dados por um período de tempo que geralmente excede a maior parte dos RTOs (objetivos de tempo de recuperação).

Para corrigir esse aviso

  1. Exclua os arquivos desnecessários do disco para liberar espaço em disco.

  2. Se o disco que tem menos de 50 por cento de espaço livre contiver dados que possam ser transferidos seguramente para outros discos (como caixas de correio ou arquivo de páginas do Windows), execute as etapas necessárias para mover os dados.

  3. Adicione a capacidade de disco ao computador do Exchange Server.

Para obter mais informações sobre a movimentação de caixas de correio no Exchange Server 2003, consulte o artigo 821829 da Base de Dados de Conhecimento Microsoft, "Movendo caixas de correio no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Para obter mais informações sobre a movimentação de caixas de correio no Exchange 2000 Server e no Exchange Server 5.5, consulte o artigo 328810 da Base de Dados de Conhecimento, "Movendo caixas de correio entre servidores" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Para obter mais informações sobre como configurar os limites de caixa de correio com a diretiva do sistema no Exchange Server 2003, consulte o artigo 822938 da Base de Dados de Conhecimento, "COMO FAZER: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938).

Para obter mais informações sobre como configurar os limites de caixa de correio com a diretiva do sistema no Exchange Server 2000, consulte o artigo 319130 da Base de Dados de Conhecimento, "COMO FAZER: Use System Policies to Configure Mailbox Storage Limits in Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130).

Para obter mais informações sobre


Este ponto de montagem tem menos de 3 GB de espaço disponível
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Volume do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave FreeSpace para pontos de montagem de volume usados pelo computador do Exchange Server. Se o valor de FreeSpace, dividido por 1.000.000.000 e arredondado para o número inteiro mais próximo for menor que 4, será exibido um aviso.

Esse aviso indica que estão disponíveis menos que 3 gigabytes (GB) de espaço de armazenamento para um ponto de montagem de volume. No Exchange Server 2003, os pontos de montagem de volume (também conhecidos como pontos de junção de sistema de arquivos NTFS) têm suporte como um local para armazenamento de dados em uma configuração de cluster quando o Exchange Server 2003 está instalado em um computador que executa o Microsoft Windows Server™ 2003, Enterprise Edition ou o Windows Server 2003, Datacenter Edition. Com o recurso de Pontos de Montagem de Volume NTFS, é possível superar a limitação de 26 letras de unidade. Ao usar os pontos de montagem de volume, você pode transplantar ou montar uma partição de destino em uma pasta ou em outro disco físico. Os pontos de montagem de volume são transparentes para programas como o Exchange Server 2003.

Pontos de montagem não têm suporte nas seguintes situações:

  • Quando são usados como local de armazenamento para os binários do Exchange Server 2003.

  • Quando são usados com os clusters do Exchange que estão executando o Microsoft Exchange 2000 Server ou anterior.

  • Quando são usados com os clusters do Windows que estão executando o Microsoft Windows 2000 Server ou anterior.

Seja o volume usado pelo Exchange Server um disco físico local, um volume lógico ou um ponto de montagem de volume, as práticas recomendadas para implantações do Exchange Server são ter pelo menos 50 por cento de espaço em disco livre disponível em todas as unidades. Como regra geral, a Microsoft recomenda um mínimo de 25 a 30 por cento de espaço em disco livre para a manutenção do Exchange, como tarefas executadas usando utilitários de bancos de dados como Eseutil e Isinteg. Além disso, para algumas operações de manutenção, como desfragmentação offline, a Microsoft recomenda que você tenha 100 por cento a mais de espaço livre que o espaço que está sendo desfragmentado. Por exemplo, se você estiver desfragmentando um banco de dados de 1 GB, você deve ter pelo menos 1 GB de espaço em disco disponível.

Ter bastante espaço livre em disco também traz vantagens do ponto de vista da segurança e da disponibilidade. Um ataque de negação de serviço, um loop de mensagens ou uma epidemia de vírus podem causar consumo excessivo de espaço em disco por causa de aumento do tráfego de mensagens, atividade do log de transações e assim por diante.

Para corrigir esse aviso

  1. Investigue áreas para reclamar espaço em disco e aumentar o espaço disponível.

  2. Se o espaço em disco for extremamente baixo, você deverá considerar a possibilidade de mover dados para outro computador do Exchange Server ou para o Servidor Virtual do Exchange que não esteja com espaço restrito. Se isso ainda não tiver sido feito, a definição de limites de caixa de correio também pode ser útil para gerenciar a utilização do disco.

Para obter mais informações sobre como usar pontos de montagem de volume em um cluster do Exchange Server 2003, consulte o artigo 318458 da Base de Dados de Conhecimento da Microsoft, "Ponto de montagem de volume para um cluster do Exchange Server 2003 em um Sistema baseado no Windows Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318458).

Para obter mais informações sobre o uso de pontos de montagem de volume em um cluster do Windows Server 2003, consulte o artigo 280297 da Base de Dados de Conhecimento, "Como configurar pontos de montagem de volume em um servidor de cluster" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=280297).


Essa placa de rede está habilitada para DHCP
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_NetworkAdapterConfiguration do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se há um valor definido para a propriedade DHCPEnabled. Se o valor dessa propriedade em um servidor Exchange for um (1), será exibido um erro.

A execução do Exchange em uma placa de rede habilitada para DHCP é uma configuração com suporte. No entanto, não é uma configuração recomendada. A execução do Exchange em computadores habilitados para DHCP não é uma prática recomendada porque, caso o serviço DHCP falhe ou seja interrompido, o Exchange pode parar de entregar mensagens ou falhar.

É recomendável que você configure todos os computadores que executam o Exchange para que usem endereços IP estáticos.

Para obter mais informações sobre como projetar redes TCP/IP do Windows, consulte o site Microsoft Technet Networking (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=33819).


O endereço de servidor WINS principal está em branco
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_NetworkAdapterConfiguration para determinar se há um valor definido para a chave WINSPrimaryServer. Se o Exchange Server Analyzer detectar que o valor dessa chave em um servidor Exchange está em branco, exibirá um aviso.

O Exchange Server 2003 e Exchange 2000 Server têm várias dependências de NetBIOS. Além disso, os clientes que executam versões do Microsoft Outlook® anteriores ao Microsoft Office Outlook 2003 também exigem a resolução de nomes NetBIOS. Por exemplo, a funcionalidade do Exchange a seguir depende da resolução de nome NetBIOS:

  • O programas de Instalação do Exchange Server 2003 e Exchange 2000 Server, especialmente em servidores em cluster.

  • Exchange Mailbox Merge Wizard (ExMerge) em um computador do Exchange Server 2003 ou Exchange 2000 Server.

  • Alterando uma senha para uma caixa de correio do Exchange Server 2003 ou Exchange 2000 Server por meio do Outlook Web Access.

  • Gerenciador do Sistema Exchange em um computador Exchange Server 2003 ou Exchange 2000 Server.

Dependendo da topologia de rede da sua organização, você poderá ignorar esse aviso com segurança. Em redes com uma única sub-rede, geralmente as difusões do NetBIOS podem lidar com as exigências de resolução de nomes NetBIOS de uma implantação do Exchange.

Em grandes organizações, a resolução de nome NetBIOS por meio de difusões pode não funcionar corretamente. Como as difusões NetBIOS normalmente não atravessam sub-redes, as redes roteadas precisam de um método alternativo para resolver os nomes NetBIOS. O método preferido para fazer isso é o WINS (Windows Internet Name Service). O WINS fornece um banco de dados distribuído para registrar e consultar mapeamentos dinâmicos dos nomes NetBIOS para computadores e grupos usados na rede. O WINS mapeia os nomes NetBIOS em endereços IP e foi projetado para solucionar os problemas decorrentes da resolução de nomes NetBIOS em ambientes roteados. O WINS é a melhor opção para resolução de nome NetBIOS em redes roteadas que usam NetBIOS sobre TCP/IP.

As operações e funções do Exchange Server 2003 e Exchange 2000 Server em uma organização grande ou com sub-redes sem WINS não foram totalmente testadas. A Microsoft exige que as empresas que executam o Exchange em redes roteadas ou segmentadas usem o WINS para resolução de nome NetBIOS. A execução do Exchange em um ambiente roteado ou segmentado sem WINS não tem suporte.

É recomendável implantar um ambiente do WINS com tolerância a falhas, que contenha pelo menos dois servidores WINS. Os servidores WINS podem atuar como um servidor WINS primário ou secundário para um cliente. A diferença entre os servidores WINS primário e secundário reside apenas na prioridade pela qual os clientes fazem contato com eles. Um servidor WINS primário é o primeiro servidor que um cliente entra em contato para executar suas operações de serviço de nome NetBIOS. Um cliente entra em contato com um servidor WINS secundário somente quando um servidor WINS primário não pode preencher a solicitação; por exemplo, se ele estiver inacessível quando o cliente fizer a solicitação ou você não puder resolver um nome para o cliente.

Se um servidor WINS primário não preencher uma solicitação, o cliente fará a mesma solicitação do seu servidor WINS secundário. Se mais de dois servidores WINS estiverem configurados para o cliente, o cliente tentará os servidores WINS secundários adicionais até que a lista se esgote ou que um dos servidores WINS responda à solicitação com êxito. Depois que um cliente usa um servidor WINS secundário, ele tenta periodicamente voltar ao servidor WINS primário correspondente para futuras solicitações de serviço de nome.

É uma prática recomendada configurar pelo menos um servidor WINS secundário nos computadores servidores Exchange em uma rede roteada ou segmentada.

Para corrigir esse aviso

  1. Abra Conexões de Rede.

  2. Clique com o botão direito na conexão de rede que você deseja configurar e, em seguida, selecione Propriedades.

  3. Na guia Geral (para uma conexão local) ou na guia Rede (para todas as outras conexões), clique em Protocolo (TCP/IP) e clique em Propriedades.

  4. Clique em Avançado, clique na guia WINS e em Adicionar.

  5. Em Servidor WINS TCP/IP, digite o endereço IP do servidor WINS e clique em Adicionar.

  6. Repita as etapas 4 e 5 para cada endereço IP de servidor WINS adicional que você deseja incluir e clique em OK. Você pode alterar a ordem de preferência dos servidores WINS usando as teclas de setas.

  7. Verifique se Habilitar NetBIOS sobre TCP/IP está selecionada.

  8. Clique em OK para salvar suas alterações.

Para obter mais informações sobre as exigências de resolução de nomes NetBIOS no Exchange, consulte o artigo 837391 da Base de Dados de Conhecimento, "O Exchange Server 2003 e o Exchange 2000 Server exigem resolução de nomes NetBIOS para obter a funcionalidade total" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391).


Servidor Virtual detectado
Microsoft Exchange Server Analyzer - Artigos > Hardware >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Windows) para determinar se o valor da chave Model está definido como Virtual Machine.

O Exchange Server Analyzer também verifica a presença do seguinte valor do Registro:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Se o Exchange Server Analyzer verificar que a chave Model contém a cadeia de caracteres Máquina Virtual e que a ramificação do Registro acima existe, será exibido um erro.

Um valor Máquina Virtual para a chave Model indica que o computador do Exchange Server está sendo executado como máquina virtual convidada no Microsoft Virtual Server 2005 ou no Microsoft Virtual PC 2004. Como a ramificação do Registro acima só é criada pelo Virtual Server 2005, sua existência significa que o computador do Exchange Server está sendo executado como máquina convidada no Virtual Server 2005.

A Microsoft não oferece suporte para execução de nenhuma versão do Microsoft Exchange Server em uma máquina virtual ou um emulador. O mesmo vale para execução do Exchange Server no Microsoft Virtual Server 2005, no Microsoft Virtual PC 2004 ou em qualquer programa de máquina virtual de terceiros. As plataformas do Microsoft Exchange Server são criadas e testadas para serem executadas apenas em hardware físico, especialmente naquelas plataformas de hardware listadas no Microsoft Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219).

Para corrigir esse erro

  1. Mova as caixas de correio do Exchange Server que está sendo executado no Virtual Server 2005 para um computador não virtual do Exchange Server.

  2. Relocalize quaisquer pastas públicas e transfira todas as funções mantidas pelo servidor virtual Exchange conforme necessário.

  3. Desinstale o Exchange da máquina virtual para descomissionar e remover da sua infra-estrutura do Exchange e do serviço de diretório Active Directory®.

Para obter mais informações sobre como mover caixas de correio, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 822892, "Aprimoramento de Mover Caixa de Correio no Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892) (em inglês)

  • 224975, "XADM: Differences Between Move Mailbox Methods" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Para obter mais informações sobre o Microsoft Virtual Server 2005, consulte o site do Microsoft Virtual Server 2005 (http://go.microsoft.com/fwlink/?LinkId=34938).

Para obter mais informações sobre o Microsoft Virtual PC 2004, consulte o site do Microsoft Virtual PC 2004 (http://go.microsoft.com/fwlink/?linkid=34663).


Rede
Microsoft Exchange Server Analyzer - Artigos >

Última modificação do tópico: 2005-11-18

Os artigos desta seção fornecem detalhes sobre o que a ferramenta Analisador do Microsoft® Exchange Server está avaliando em relação à rede. Além disso, esses artigos descrevem as ações que podem ser tomadas para resolver erros, avisos e configurações não padrão relacionados à rede, detectados pelo Analisador do Exchange Server.


O Registro 'Host' do DNS Parece Estar Ausente
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2006-04-13

A ferramenta Microsoft® Exchange Server Analyzer realiza uma pesquisa de DNS (Sistema de Nome de Domínio) no servidor DNS para recuperar o Registro Host (A) do servidor Exchange. Se a operação de pesquisa DNS não retornar um endereço IP, o Exchange Server Analyzer exibirá um aviso de que o Registro Host (A) parece estar ausente.

A pesquisa DNS do Registro Host (A) no computador Exchange Server 2003 pode falhar pelas seguintes razões:

  • O servidor DNS está desativado ou não está respondendo devido a uma falha de rede ou outros motivos.

  • O Registro Host (A) do Exchange Server 2003 pode estar ausente no servidor DNS porque não está disponível, pode estar incorreto ou o servidor DNS pode não estar configurado para permitir atualizações de Registro host dinâmicas.

Quando o servidor DNS está desativado, pode haver atrasos de roteamento de mensagens e outras falhas de serviço.

Observação:
O Exchange Server 2003 conta com a resolução de nome de host para os sistemas de mensagens baseados em SMTP local e externo na rede. A resolução de nome de host é baseada principalmente no DNS e o DNS é um serviço de rede crítico. A falha de um servidor DNS pode impedir que os usuários localizem seus sistemas de mensagens. O Active Directory e a organização do Exchange Server 2003 não podem funcionar sem DNS. Os clientes das mensagens consultarão o DNS para localizar os recursos internos, como controladores de domínio e servidores de caixa de correio. O Exchange Server 2003, por outro lado, depende do DNS para recuperar os endereços IP (Internet Protocol) dos controladores de domínio para pesquisas de diretório e hosts SMTP externos quando o Exchange Server 2003 envia mensagens para a Internet.

Para corrigir o problema, verifique se o servidor DNS está em execução e se o Registro Host (A) está registrado.

Para verificar se o servidor DNS está online e se o Registro de host está presente

  1. Verifique se o servidor DNS está em execução realizando uma ou mais das etapas a seguir:

    • Examine o status do servidor DNS usando o programa de Administração do DNS no servidor DNS.

    • Reinicie o servidor DNS. Para obter mais informações, consulte "Start, stop, pause, or restart a DNS server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Examine a capacidade de resposta do servidor DNS usando nslookup. Para obter mais informações, consulte "Verificar a capacidade de resposta do servidor DNS usando o comando nslookup" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Use nslookup para verificar se o registro Host (A) existe no servidor DNS. Para obter mais informações, consulte "To verify A resource records exist in DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63001).

  3. Se o registro de recurso Host (A) não existir, adicione ou modifique manualmente o registro de recurso A ou configure o servidor DNS para permitir atualizações dinâmicas de registro:

    • Adicione manualmente um registro de recurso A. Para obter mais informações, consulte "Add a resource record to a DNS zone" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Modifique manualmente um registro de recurso A. Para obter mais informações, consulte "Modify an existing resource record" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Habilite o servidor DNS para permitir atualizações de Registro de host dinâmico. Para obter mais informações, consulte o artigo 816592 da Base de Dados de Conhecimento Microsoft, "How to configure DNS dynamic updates in Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).
  • Para obter informações sobre como o Exchange Server 2003 usa o DNS para resolver endereços IP externos, consulte "Dependências de Transporte para o Exchange Server 2003" no Guia de Roteamento e Transporte do Exchange Server (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Para obter informações sobre resolução de nomes do DNS, consulte o artigo 322856 da Base de Dados de Conhecimento Microsoft, "COMO FAZER: Configure DNS para Ser Usado com o Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Para obter informações sobre como solucionar problemas do DNS, consulte "Solucionando problemas de DNS" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=63003).

Para obter informações sobre o monitoramento do sistema Exchange Server 2003, consulte "Monitoramento do Sistema com o Exchange Server 2003 Management Pack" no Guia do Exchange Server 2003 Management Pack para MOM 2000 SP1 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Para obter informações sobre os registros de recursos Host (A), consulte "Gerenciando os registros de recurso" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=63004).


As respostas de DNS são diferentes entre UDP e TCP
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2007-03-16

A ferramenta Microsoft Exchange Server Analyzer consulta a classe Win32_NetworkAdapterConfiguration do WMI (Instrumentação de Gerenciamento do Microsoft Windows) para obter o atributo DNSServerSearchOrder. Esse atributo é uma matriz de endereços IP do servidor a serem usados na consulta de servidores DNS (Sistema de Nome de Domínio).

Depois de recuperar o endereço do servidor DNS primário, o Exchange Analyzer tentará uma consulta de DNS nos servidores DNS configurados para cada servidor de serviço de diretório do Active Directory. Essa conexão é feita usando um processador de objeto personalizado que executa uma solicitação de resolução de nome de protocolo TCP e UDP.

Se as duas solicitações de resolução de nome TCP e UDP forem bem-sucedidas, o Exchange Analyzer comparará as respostas retornadas das solicitações bem-sucedidas. Se as respostas retornadas das consultas TCP e UDP não forem as mesmas, o Exchange Analyzer exibirá um aviso.

Esse aviso indica que pode haver problemas de configuração de servidor DNS que estejam afetando o desempenho do fluxo de mensagens.

SMTP é o protocolo de mensagens nativo para envio e transporte de mensagens no Exchange Server. Isso significa que os clientes usam SMTP para enviar mensagens e os servidores Exchange usam SMTP para entregar mensagens e dados de mensagens.

Para o Exchange Server entregar uma mensagem da Internet de saída por meio do serviço SMTP, o DNS é usado pelo seguinte método:

  1. Um usuário interno envia uma mensagem a um destinatário em um domínio remoto.

  2. Para determinar se o destinatário é local ou remoto, o servidor virtual SMTP no servidor Exchange do remetente usará as funções de transporte internas para consultar o servidor de catálogo global para o endereço do destinatário. Se o endereço do destinatário na mensagem não estiver em uma diretiva de destinatário, ele não será armazenado no Active Directory. Portanto, o Exchange determina que a mensagem se destine para um domínio remoto.

  3. Se necessário, o servidor Exchange entrega a mensagem para o servidor virtual SMTP adequado.

  4. O servidor virtual SMTP usa suas informações de metabase do IIS para determinar o método para entregar uma mensagem a um domínio remoto.

  5. Em seguida, o servidor virtual SMTP no servidor Exchange executa uma das duas ações:

    • Usa o DNS para procurar o endereço IP do domínio de destino e tenta entregar a mensagem.

    • Encaminha a mensagem para um host inteligente que assume a responsabilidade pela resolução do DNS e a entrega da mensagem.

Para resolver esse aviso, considere a orientação no artigo 820284 da Base de Dados de Conhecimento Microsoft, "A mensagem poderá não ser entregue para determinados domínios se o SO do Server for Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284).

Para obter mais informações sobre DNS e Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft e WebCast:

  • 322856, "COMO FAZER: Configure DNS para Ser Usado com o Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: O SMTP do Windows 2000 e Exchange 2000 usam consultas de DNS do TCP" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Suporte WebCast: Microsoft Exchange 2000 Server: Solucionando problemas de DNS em transportes" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


O servidor DNS está executando o Virtual Server 2005 com Exchange Server instalado como um Convidado
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_ComputerSystem de Instrumentação de Gerenciamento do Microsoft Windows® para determinar se o valor da chave Model está definido como Virtual Machine.

O Exchange Server Analyzer também verifica a presença do seguinte valor do Registro:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Além disso, o Exchange Server Analyzer consulta a classe WMI Win32_Services para determinar se o serviço de Sistema de Nome de Domínio (DNS) está em execução no computador físico que está executando o Microsoft Virtual Server 2005.

Se o Exchange Server Analyzer detectar que a chave Modelo contém a cadeia de caracteres Máquina Virtual, que a ramificação do Registro acima existe e que o DNS está em execução, um erro será exibido.

Um valor Virtual Machine para a chave Model indica que o computador do Exchange Server está sendo executado como máquina virtual convidada no Virtual Server 2005 ou no Microsoft Virtual PC 2004. Como a ramificação do Registro acima só é criada pelo Virtual Server 2005, sua existência significa que o computador do Exchange Server está sendo executado como máquina virtual convidada no Virtual Server 2005.

A Microsoft não oferece suporte para execução de nenhuma versão do Microsoft Exchange Server em uma máquina virtual ou um emulador. Isso é verdadeiro para o Exchange Server em execução no Virtual Server 2005, no Virtual PC 2004 ou em qualquer programa de máquina virtual de terceiros. As plataformas do Microsoft Exchange Server são criadas e testadas para serem executadas apenas em hardware físico, especialmente naquelas plataformas de hardware listadas no Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219).

Além disso, executar o Exchange como um convidado do Virtual Server 2005 em um computador executando DNS não é uma prática recomendada, pois isso não permite redundância adequada entre os serviços.

Para corrigir esse erro

  1. Mova as caixas de correio do Exchange Server que está sendo executado no Virtual Server 2005 para um computador não virtual do Exchange Server.

  2. Relocalize quaisquer pastas públicas e transfira todas as funções mantidas pelo servidor virtual Exchange conforme necessário.

  3. Desinstale o Exchange da máquina virtual para descomissionar e remover da sua infra-estrutura do Exchange e do serviço de diretório Active Directory®.

Para obter mais informações sobre como mover caixas de correio, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 822892, "Aprimoramento de Mover Caixa de Correio no Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892) (em inglês)

  • 224975, "XADM: Differences Between Move Mailbox Methods" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Para obter mais informações sobre suporte para computadores do Exchange Server que estão sendo executados em ambientes virtuais, consulte o artigo 320220 da Base de Dados de Conhecimento, "Limites de suporte para o Exchange Server em uma máquina virtual ou uma máquina de emulação" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220) (em inglês).

Para obter mais informações sobre o Microsoft Virtual Server 2005, consulte o site do Microsoft Virtual Server 2005 (http://go.microsoft.com/fwlink/?linkid=34938).

Para obter mais informações sobre o Microsoft Virtual PC 2004, consulte o site do Microsoft Virtual PC 2004 (http://go.microsoft.com/fwlink/?linkid=34663).


As respostas do servidor DNS externo são diferentes para UDP e TCP
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2007-03-16

A Microsoft Exchange Analyzer Tool consulta o serviço de diretório do Active Directory para determinar o valor do atributo msExchSmtpExternalDNSServers na classe protocolCfgSMTPServer de cada objeto do Exchange Server. O valor do atributo msExchSmtpExternalDNSServers, se definido, especificará o endereço do servidor DNS (sistema de nome de domínio) externo usado pela Instância do Servidor Virtual SMTP.

Depois de recuperar o endereço do servidor DNS externo primário, o Exchange Analyzer tenta realizar uma consulta de DNS nos servidores DNS externos configurados para cada servidor do serviço de diretório do Active Directory. Para fazer essa conexão, use um processador de objeto personalizado que execute solicitações de resolução de nome de protocolo TCP e protocolo UDP.

Se ambas as solicitações de resolução de nome (TCP e UDP) forem bem-sucedidas, o Exchange Analyzer comparará as respostas retornadas. Se as respostas retornadas das consultas TCP e UDP não forem iguais, o Exchange Analyzer exibirá um aviso.

Esse aviso indica que talvez algum problema de configuração de servidor DNS externo esteja afetando o desempenho do fluxo de mensagens.

SMTP é o protocolo de mensagens nativo para envio e transporte de mensagens no Exchange Server. Isso significa que os clientes usam SMTP para enviar mensagens e os servidores Exchange usam SMTP para entregar mensagens e dados de mensagens.

Para o Exchange Server entregar uma mensagem da Internet de saída por meio do serviço SMTP, o DNS é usado da seguinte maneira:

  1. Um usuário interno envia uma mensagem a um destinatário em um domínio remoto.

  2. Para determinar se o destinatário é local ou remoto, o servidor virtual SMTP localizado no servidor Exchange do remetente usa as funções de transporte internas para consultar o endereço do destinatário no servidor de catálogo global. Se o endereço do destinatário da mensagem não estiver em uma diretiva de destinatário, é porque ele não está armazenado no Active Directory. Portanto, o Exchange determina que a mensagem se destina a um domínio remoto.

  3. Se necessário, o servidor Exchange entregará a mensagem ao servidor virtual SMTP adequado.

  4. O servidor virtual SMTP usa as informações de metabase do IIS para determinar o método de entrega da mensagem a um domínio remoto.

  5. Em seguida, o servidor virtual SMTP do servidor Exchange executa uma destas duas ações:

    • Usa o DNS para procurar o endereço IP do domínio de destino e tenta entregar a mensagem.

    • Encaminha a mensagem para um host inteligente, que assume a responsabilidade pela resolução do DNS e pela entrega da mensagem.

Para resolver esse aviso, consulte o artigo 820284 da Base de Dados de Conhecimento Microsoft, "A mensagem poderá não ser entregue para determinados domínios se o sistema operacional do servidor for Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284).

Para obter mais informações sobre o DNS e o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft e o WebCast:

  • 322856, "COMO FAZER: Configure DNS para Ser Usado com o Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: O SMTP do Windows 2000 e Exchange 2000 usam consultas de DNS do TCP" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Suporte WebCast: Microsoft Exchange 2000 Server: Solucionando problemas de DNS em transportes" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Média total de bytes da rede por segundo acima do limite
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho de Bytes Total/sec do objeto de desempenho de Network Interface para analisar os dados do desempenho.

O contador de desempenho Bytes Total/sec mostra a taxa em que o adaptador de rede está processando bytes de dados. Esse contador inclui todos os dados de arquivo e aplicativo, além das informações de protocolo, como cabeçalhos de pacote. O contador de desempenho Bytes Total/sec é a soma de Network Interface\Bytes Received/sec e Network Interface/Bytes Sent/sec.

O Analisador do Exchange Server informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. Para um adaptador de rede de 100 Mbps, o valor do contador de desempenho Bytes Total/sec deve ser abaixo de 7 megabytes/segundo. Para um adaptador de rede de 1000 Mbps, o valor do contador de desempenho Bytes Total/sec deve ser abaixo de 70 megabytes/segundo. Se o contador de desempenho Bytes Total/sec exceder 7% da largura de banda da rede, o Exchange Server Analyzer exibirá um erro.

Esse erro normalmente indica que o servidor está experimentando períodos não responsivos, provocando a lentidão ou parada do fluxo de mensagens. Além disso, os clientes Microsoft Outlook® que se conectam a esse servidor podem receber a caixa de diálogo Solicitação de Cancelamento RPC.

A seguir estão algumas causas possíveis desse erro:

  • Uma placa de interface de rede (NIC) no computador não pode dar suporte à largura de banda máxima suportada pela infra-estrutura de sua rede.

  • Há excesso de carga no servidor.

  • Vírus ou SPAMs estão causando aumentos repentinos nos padrões de uso da rede.

Para resolver este erro

  • Se uma NIC não oferecer suporte à largura de banda máxima da rede, atualize a NIC para que ofereça suporte a uma largura de banda mais veloz.

  • Reduza a carga no servidor. Você pode fazer isso movendo as caixas de correio para um servidor que tenha menos caixas de correio. Se for necessário, adicione outro servidor Exchange ao seu ambiente.

  • Se você suspeita de que a carga alta anormal não é causada pelo excesso de caixas de correio em um servidor, tente identificar a origem da alta carga anormal e elimine-a.

  • Experimente as práticas recomendadas nos seguintes artigos:

    • Para obter informações sobre considerações de largura de banda da rede, consulte Desempenho de Rede em "Compreendendo o Desempenho do Exchange" no Guia de Desempenho e Escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Para obter informações sobre como solucionar problemas de rede, consulte "Ruling Out Network-Bound Problems" em Solução de Problemas de Desempenho do Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


A equipe da NIC (placa da interface de rede) está habilitada
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2006-10-16

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_NetworkAdapter do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) de todas as NICs (placas de interface de rede) que estão ligadas ao protocolo TCP/IP.

O Exchange Server Analyzer consulta a seguinte ramificação de Registro para determinar se a chave TeamAdapters existe para essas placas adaptadoras:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\

Se o Exchange Server Analyzer determinar que a chave TeamAdapters existe para uma ou mais NICs no servidor que está sendo analisado, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que o agrupamento de NICs está habilitado no servidor Exchange que está sendo analisado. Embora o agrupamento de NICs não seja geralmente um problema de fluxo de mensagens, deve-se tomar cuidado para verificar se o agrupamento está configurado com os drivers das NICs mais recentes disponíveis.

Para resolver esse problema:

  • Se ocorrerem problemas de fluxo de mensagens no servidor que tem o Agrupamento de NICs habilitado, desabilite temporariamente o Agrupamento para ver se o problema de fluxo de mensagens está resolvido.

  • Atualize os drivers das NICs para a versão mais recente disponível no fabricante das NICs.

  • Siga rigorosamente as recomendações de configuração de Agrupamento do fabricante das NICs.

Para obter mais informações sobre o agrupamento de NICs, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 278431, "O uso de placas adaptadoras de agrupamento com o balanceamento de carga da rede pode causar problemas de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278431).

  • 814607, "Suporte Microsoft para clusters de servidor com componentes de sistema de terceiros" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=814607).


Pacotes de Saída de Rede acima do limite
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2006-02-13

A ferramenta Microsoft® Exchange Server Analyzer inclui um mecanismo de coleta de dados de desempenho que é usado para consultar objetos do contador de desempenho. O mecanismo de coleta de dados de desempenho coleta dados do contador de desempenho Packet Outbound errors do objeto de desempenho Network Interface para analisar dados de desempenho.

O contador de desempenho Packet Outbound errors indica o número de pacotes de saída que não puderam ser transmitidos devido a erros. O valor do contador de desempenho Packet Outbound errors deve ser zero. Se o Exchange Server Analyzer determinar que o contador de desempenho Packet Outbound errors tem um valor maior que zero, ele exibirá um erro.

Esse erro normalmente indica que o servidor está experimentando períodos não responsivos, provocando a lentidão ou parada do fluxo de mensagens. Além disso, os clientes Microsoft Outlook® que se conectam a esse servidor podem receber a caixa de diálogo Solicitação de Cancelamento RPC.

Esse erro normalmente é causado por uma NIC (placa de interface de rede) defeituosa ou danificada.

Para resolver esse erro, você deve determinar a causa dos erros dos pacotes de saída e corrigir o problema. Se os erros dos pacotes de saída forem causados por uma NIC defeituosa, substitua a placa imediatamente.

Experimente as práticas recomendadas nos seguintes artigos:

  • Para obter informações sobre considerações de largura de banda da rede, consulte Desempenho de Rede em "Compreendendo o Desempenho do Exchange" no Guia de Desempenho e Escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter informações sobre como solucionar problemas de rede, consulte "Ruling Out Network-Bound Problems" em Solução de Problemas de Desempenho do Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Comprimento da Fila de Saída de Rede acima do limite
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2007-02-13

A ferramenta Microsoft® Exchange Server Analyzer dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos do contador de desempenho nos computadores que estão executando o Exchange 2000 Server ou o Exchange Server 2003. O mecanismo de coleta de dados de desempenho reúne os dados do contador de desempenho Output Queue Length do objeto de desempenho Network Interface para analisar os dados do desempenho.

O contador de desempenho Output Queue Length exibe o comprimento da fila de pacotes de saída, em pacotes. O Exchange Server Analyzer informa o valor máximo do contador de desempenho no decorrer do intervalo de coleta. Se o valor médio exceder 10, o Exchange Server Analyzer exibirá um erro.

Esse erro normalmente indica que o servidor está experimentando períodos sem resposta, provocando lentidão ou a parada do fluxo de mensagens. Além disso, os clientes Outlook que se conectam a esse servidor podem receber a caixa de diálogo Solicitação de Cancelamento RPC.

A seguir estão algumas causas possíveis desse erro:

Observação:
Em determinadas circunstâncias, em uma máquina executando o sistema operacional Microsoft Windows 2000 Server, o contador de desempenho Output Queue Length pode mostrar consistentemente um valor aleatório maior que zero. Para obter mais informações sobre as circunstâncias nas quais o desempenho de Output Queue Length pode exibir um valor aleatório e sobre como corrigir isso, consulte o artigo 834940 da Base de Dados de Conhecimento Microsoft, "O Monitor do Sistema pode exibir valores altos para o contador de desempenho Comprimento da Fila de Saída no Windows 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834940).
  • Uma placa de interface de rede (NIC) no computador não pode dar suporte à largura de banda máxima aceita por sua infra-estrutura de rede.

  • Há excesso de carga no servidor.

  • Vírus ou SPAM estão causando aumentos repentinos nos padrões de uso da rede.

Siga as seguintes etapas para resolver esse erro:

  • Se a NIC não oferecer suporte à largura de banda máxima de sua rede, atualize a NIC para oferecer suporte a uma largura de banda mais rápida.

  • Reduza a carga no servidor. Você pode fazer isso movendo as caixas de correio para um servidor que tenha menos caixas de correio. Se for necessário, adicione outro servidor Exchange ao seu ambiente.

  • Se você suspeita que a carga alta anormal não é causada pelo excesso de caixas de correio em um servidor, tente identificar a origem da alta carga anormal e elimine-a.

Experimente as práticas recomendadas nos seguintes artigos:

  • Para obter informações sobre considerações de largura de banda da rede, consulte Desempenho de Rede em "Compreendendo o desempenho do Exchange" no Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (página em inglês).

  • Para obter informações sobre como solucionar problemas de rede, consulte "Evitando problemas ligados à rede" em Solução de Problemas de Desempenho do Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588) (página em inglês).


Falha do DNS primário ao responder a uma conexão UDP
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2007-03-16

A ferramenta Microsoft Exchange Server Analyzer Tool consulta a classe Win32_NetworkAdapterConfiguration do Microsoft WMI (Instrumentação de Gerenciamento do Windows) para obter o atributo DNSServerSearchOrder. Esse atributo é uma matriz de endereços IP do servidor a ser usada ao consultar servidores DNS.

Depois de recuperar o endereço do servidor DNS primário, o Exchange Analyzer tenta realizar uma consulta de DNS nos servidores DNS configurados para cada servidor do serviço de diretório do Active Directory. Essa conexão é estabelecida por meio de um processador de objeto personalizado que executa uma solicitação de resolução de nome UDP e analisa os resultados.

Se a solicitação de resolução de nome UDP falhar, o Exchange Analyzer exibirá um aviso.

Esse aviso indica que o servidor DNS primário pode ser configurado para aceitar apenas consultas de TCP.

O protocolo SMTP é o protocolo nativo para envio e transporte de mensagens no Exchange Server. Isso significa que os clientes usam SMTP para enviar mensagens e os servidores Exchange usam SMTP para entregar mensagens e dados de mensagens.

Para o Exchange Server entregar uma mensagem da Internet de saída por meio do serviço SMTP, o DNS é usado da seguinte maneira:

  1. Um usuário interno envia uma mensagem a um destinatário em um domínio remoto.

  2. Para determinar se o destinatário é local ou remoto, o servidor virtual SMTP localizado no servidor Exchange do remetente usa as funções de transporte internas para consultar o endereço do destinatário no servidor de catálogo global. Se o endereço do destinatário da mensagem não estiver em uma diretiva de destinatário, é porque ele não está armazenado no Active Directory. Portanto, o Exchange determina que a mensagem se destina a um domínio remoto.

  3. Se necessário, o servidor Exchange entregará a mensagem ao servidor virtual SMTP adequado.

  4. O servidor virtual SMTP usa as informações de metabase do IIS para determinar o método de entrega da mensagem a um domínio remoto.

  5. Em seguida, o servidor virtual SMTP do servidor Exchange executa uma destas duas ações:

    • Usa o DNS para procurar o endereço IP do domínio de destino e tenta entregar a mensagem.

    • Encaminha a mensagem para um host inteligente, que assume a responsabilidade pela resolução do DNS e pela entrega da mensagem.

Por padrão, os servidores DNS escutam no soquete 53 do UDP para comunicação, como consultas de resolução de nomes.

Se os serviços SMTP do Exchange Server estiverem configurados para enviar somente consultas UDP e o servidor DNS Primário estiver configurado para aceitar apenas consultas de TCP, talvez ocorram falhas de roteamento de mensagens que poderão afetar adversamente o desempenho do fluxo de mensagens.

Para resolver esse aviso, proceda da seguinte forma:

  1. Verifique se o servidor DNS foi inicializado e se está conectado à rede.

  2. Verifique se um firewall de rede ou um filtro de pacotes está bloqueando inadvertidamente as portas DNS conhecidas, como a porta 53 de UDP.

  3. Verifique se o servidor DNS primário está configurado para oferecer suporte às consultas de resolução de nome UDP.

Para obter mais informações sobre o DNS e o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft e o WebCast:

  • 322856, "COMO FAZER: Configure DNS para Ser Usado com o Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: O SMTP do Windows 2000 e Exchange 2000 usam consultas de DNS do TCP" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Suporte WebCast: Microsoft Exchange 2000 Server: Solucionando problemas de DNS em transportes" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


O servidor DNS primário está inacessível
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_NetworkAdapterConfiguration da Instrumentação de Gerenciamento do Microsoft Windows® (WMI) para obter o atributo DNSServerSearchOrder. Esse atributo é uma matriz de endereços IP do servidor a ser usada ao consultar servidores DNS. Após a recuperação do endereço do servidor DNS primário, o Exchange Server Analyzer abre uma conexão do soquete TCP com a porta 53 no servidor. Essa conexão é feita com um processador de objetos personalizado que retorna uma cadeia de caracteres específica se a conexão é bem-sucedida. Se o Exchange Server Analyzer não receber 53 Available como parte da cadeia de caracteres retornada, é exibido um aviso.

Esse aviso indica que o servidor não respondeu a uma tentativa de conexão na porta 53 do TCP. Por padrão, os servidores DNS escutam o soquete 53 do TCP em busca de comunicações como consultas de resolução de nome.

Se o servidor DNS primário estiver inacessível e o Exchange 2000 Server estiver em execução, a entrega de mensagens será lenta. Um hotfix com suporte está disponível na Microsoft para corrigir o problema de lentidão de entrega de mensagens a destinatários externos maior que o esperada quando o servidor DNS primário não está disponível. Entre em contato com o Atendimento Microsoft para obter esse hotfix.

Além disso, convém solucionar o problema da causa do servidor DNS primário não estar disponível, ou alterar as configurações de DNS no servidor Exchange para usar um servidor DNS diferente para a resolução de nomes.

Para corrigir esse aviso

  1. Verifique se o servidor DNS foi inicializado e se está conectado à rede.

  2. Use o comando PING para descobrir se o servidor DNS é acessível.

Para obter mais informações sobre a entrega lenta de mensagens quando o servidor DNS primário não está disponível, assim como para obter um hotfix para esse problema, consulte o artigo 829722 da Base de Dados de Conhecimento Microsoft, "Lentidão na entrega de mensagens no Exchange 2000 quando o servidor DNS primário não está disponível" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722).

Para obter mais informações sobre DNS e o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento e WebCast:

  • 322856, "COMO FAZER: Configure DNS para Ser Usado com o Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: O SMTP do Windows 2000 e Exchange 2000 usam consultas de DNS do TCP" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Suporte WebCast: Microsoft Exchange 2000 Server: Solucionando problemas de DNS em transportes" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Falha do servidor DNS externo primário ao responder a uma conexão TCP
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2007-03-16

A Microsoft Exchange Analyzer Tool consulta o serviço de diretório do Active Directory para determinar o valor do atributo msExchSmtpExternalDNSServers na classe protocolCfgSMTPServer de cada objeto do Exchange Server. O valor do atributo msExchSmtpExternalDNSServers, se definido, especificará o endereço do servidor DNS (sistema de nome de domínio) externo usado pela Instância do Servidor Virtual SMTP.

Após a recuperação do endereço do servidor DNS externo primário, o Exchange Server Analyzer abre uma conexão do soquete TCP com a porta 53 no servidor. Essa conexão é feita com um processador de objetos personalizado que retornará uma cadeia de caracteres específica se a conexão for bem-sucedida. Se o Exchange Server Analyzer não receber 53 Available como parte da cadeia de caracteres retornada, será exibido um aviso.

Esse aviso indica que o servidor não respondeu a uma tentativa de conexão na porta 53 do TCP. Por padrão, os servidores DNS escutam o soquete 53 do TCP em busca de comunicações como consultas de resolução de nome.

SMTP é o protocolo de mensagens nativo para envio e transporte de mensagens no Exchange Server. Isso significa que os clientes usam SMTP para enviar mensagens e os servidores Exchange usam SMTP para entregar mensagens e dados de mensagens.

Para o Exchange Server entregar uma mensagem da Internet de saída por meio do serviço SMTP, o DNS é usado da seguinte maneira:

  1. Um usuário interno envia uma mensagem a um destinatário em um domínio remoto.

  2. Para determinar se o destinatário é local ou remoto, o servidor virtual SMTP localizado no servidor Exchange do remetente usa as funções de transporte internas para consultar o endereço do destinatário no servidor de catálogo global. Se o endereço do destinatário da mensagem não estiver em uma diretiva de destinatário, é porque ele não está armazenado no Active Directory. Portanto, o Exchange determina que a mensagem se destina a um domínio remoto.

  3. Se necessário, o servidor Exchange entregará a mensagem ao servidor virtual SMTP adequado.

  4. O servidor virtual SMTP usa as informações de metabase do IIS para determinar o método de entrega da mensagem a um domínio remoto.

  5. Em seguida, o servidor virtual SMTP do servidor Exchange executa uma destas duas ações:

    • Usa o DNS para procurar o endereço IP do domínio de destino e tenta entregar a mensagem.

    • Encaminha a mensagem para um host inteligente, que assume a responsabilidade pela resolução do DNS e pela entrega da mensagem.

Se o servidor DNS externo primário estiver inacessível e o Exchange 2000 Server estiver em execução, a entrega de mensagens será lenta. A Microsoft disponibiliza um hotfix com suporte para corrigir o problema de lentidão de entrega de mensagens a destinatários externos quando o servidor DNS externo primário não está disponível. Entre em contato com o Atendimento Microsoft para obter esse hotfix.

Além disso, convém solucionar o problema que causa a indisponibilidade do servidor DNS externo primário, ou alterar as configurações de DNS no servidor Exchange para usar um servidor DNS diferente para a resolução de nomes.

Para corrigir esse aviso, faça o seguinte:

  1. Verifique se o servidor DNS externo foi iniciado e se há conectividade entre ele e a rede do Exchange.

  2. Use o comando PING para descobrir se o servidor DNS externo é acessível.

Para obter mais informações sobre a entrega lenta de mensagens quando o servidor DNS primário não está disponível, assim como para obter um hotfix para esse problema, consulte o artigo 829722 da Base de Dados de Conhecimento Microsoft, "Lentidão na entrega de mensagens no Exchange 2000 quando o servidor DNS primário não está disponível" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722).

Para obter mais informações sobre DNS e o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento e WebCast:

  • 322856, "COMO FAZER: Configure DNS para Ser Usado com o Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: O SMTP do Windows 2000 e Exchange 2000 usam consultas de DNS do TCP" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Suporte WebCast: Microsoft Exchange 2000 Server: Solucionando problemas de DNS em transportes" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Falha do DNS externo primário ao responder a uma conexão UDP
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2007-03-16

A Microsoft Exchange Analyzer Tool consulta o serviço de diretório do Active Directory para determinar o valor do atributo msExchSmtpExternalDNSServers na classe protocolCfgSMTPServer de cada objeto do Exchange Server. O valor do atributo msExchSmtpExternalDNSServers, se definido, especificará o endereço do servidor DNS (sistema de nome de domínio) externo usado pela Instância do Servidor Virtual SMTP.

Depois de recuperar o endereço do servidor DNS primário, o Exchange Analyzer tenta realizar uma consulta de DNS nos servidores DNS externos configurados para cada servidor do serviço de diretório do Active Directory. Essa conexão é estabelecida por meio de um processador de objeto personalizado que executa uma solicitação de resolução de nome UDP e analisa os resultados.

Se a solicitação de resolução de nome UDP falhar, o Exchange Analyzer exibirá um aviso.

Esse aviso indica que o servidor DNS externo primário pode ser configurado para aceitar apenas consultas de TCP.

SMTP é o protocolo de mensagens nativo para envio e transporte de mensagens no Exchange Server. Isso significa que os clientes usam SMTP para enviar mensagens e os servidores Exchange usam SMTP para entregar mensagens e dados de mensagens.

Para o Exchange Server entregar uma mensagem da Internet de saída por meio do serviço SMTP, o DNS é usado da seguinte maneira:

  1. Um usuário interno envia uma mensagem a um destinatário em um domínio remoto.

  2. Para determinar se o destinatário é local ou remoto, o servidor virtual SMTP localizado no servidor Exchange do remetente usa as funções de transporte internas para consultar o endereço do destinatário no servidor de catálogo global. Se o endereço do destinatário da mensagem não estiver em uma diretiva de destinatário, é porque ele não está armazenado no Active Directory. Portanto, o Exchange determina que a mensagem se destina a um domínio remoto.

  3. Se necessário, o servidor Exchange entregará a mensagem ao servidor virtual SMTP adequado.

  4. O servidor virtual SMTP usa as informações de metabase do IIS para determinar o método de entrega da mensagem a um domínio remoto.

  5. Em seguida, o servidor virtual SMTP do servidor Exchange executa uma destas duas ações:

    • Usa o DNS para procurar o endereço IP do domínio de destino e tenta entregar a mensagem.

    • Encaminha a mensagem para um host inteligente, que assume a responsabilidade pela resolução do DNS e pela entrega da mensagem.

Por padrão, os servidores DNS escutam no soquete 53 do UDP para comunicação, como consultas de resolução de nomes.

Se os serviços SMTP do servidor Exchange estiverem configurados para enviar somente consultas UDP e o servidor DNS externo primário estiver configurado para aceitar apenas consultas de TCP, talvez ocorram falhas de roteamento de mensagens que poderão afetar adversamente o desempenho do fluxo de mensagens.

Para resolver esse aviso, proceda da seguinte forma:

  1. Verifique se o servidor DNS externo foi iniciado e se há conectividade entre ele e a rede.

  2. Verifique se um firewall de rede ou um filtro de pacotes está bloqueando inadvertidamente as portas DNS conhecidas, como a porta 53 de UDP.

  3. Verifique se o servidor DNS externo primário está configurado para oferecer suporte às consultas de resolução de nome UDP.

Para obter mais informações sobre o DNS e o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft e o WebCast:

  • 322856, "COMO FAZER: Configure DNS para Ser Usado com o Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: O SMTP do Windows 2000 e Exchange 2000 usam consultas de DNS do TCP" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Suporte WebCast: Microsoft Exchange 2000 Server: Solucionando problemas de DNS em transportes" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


O servidor WINS primário falhou ao responder
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_NetworkAdapterConfiguration do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para obter o atributo WINSPrimaryServer Esse atributo é o endereço IP do servidor primário WINS (Windows Internet Name Service) do computador do Exchange Server. Depois de recuperar o endereço do servidor WINS primário, o Exchange Server Analyzer abre uma conexão de soquete TCP com a porta 137 no servidor. Essa conexão é feita com um processador de objetos personalizado que retorna uma cadeia de caracteres específica se a conexão é bem-sucedida. Se o Exchange Server Analyzer não receber 137 Disponível como parte da cadeia de caracteres retornada, ele exibirá um aviso.

Esse aviso indica que o servidor não respondeu a uma tentativa de conexão na porta TCP 137. Por padrão, servidores WINS escutam o soquete TCP 137 para comunicações como consultas de resolução de nome.

Se o servidor WINS primário estiver indisponível e você estiver executando o Exchange Server, a entrega de mensagens será lenta, principalmente em organizações maiores. Você deve descobrir por que o servidor WINS primário não está disponível, ou alterar as configurações de WINS no servidor Exchange para usar um outro servidor WINS para resolução de nome.

Para corrigir esse aviso

  1. Verifique se o servidor WINS foi iniciado e está conectado à rede.

  2. Use o comando PING para verificar se o servidor WINS está acessível.

Para obter informações sobre por que o WINS é necessário para o Exchange 2000 Server e Exchange Server 2003, consulte o artigo 837391 da Base de Dados de Conhecimento Microsoft, "O Exchange Server 2003 e o Exchange 2000 Server requerem resolução de nomes NetBIOS para funcionalidade plena" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=837391).


A porta 389 não respondeu
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo dNSHostName para todos os controladores de domínio no Active Directory. Depois de recuperar os nomes dos controladores de domínio, o Exchange Server Analyzer abre uma conexão de soquete TCP para a porta 389 em cada controlador de domínio. Essa conexão é feita com um processador de objetos personalizado que retorna uma cadeia de caracteres específica se a conexão é bem-sucedida. Se o Exchange Server Analyzer não receber 389 Disponível como parte da cadeia de caracteres retornada, será exibido um aviso.

Esse aviso indica que o controlador de domínio não respondeu a uma tentativa de conexão na porta TCP 389. A porta TCP 389 é a porta padrão para comunicações de protocolo LDAP.

Se você estiver recebendo esse aviso, isso poderá estar acontecendo por causa de problemas de conectividade entre o Exchange Server Analyzer e o controlador de domínio. Há vários motivos para as solicitações LDAP não poderem ser atendidas adequadamente por um controlador de domínio quando o Exchange Server Analyzer o consulta.

Para corrigir esse aviso

  1. Verifique se a conta que está executando a ferramenta está autorizada a consultar o controlador de domínio. Você precisará de permissões de nível de Usuário no domínio onde o controlador de domínio está sendo executado. Mais informações sobre as permissões exigidas para executar o Exchange Server Analyzer podem ser encontradas no arquivo de Ajuda incluído com a ferramenta. Abra o arquivo de Ajuda, abrindo o Exchange Server Analyzer, clicando em Ajuda e em Ajuda do Microsoft Exchange Server Analyzer Tool.

  2. Verifique se não há firewalls ou restrições de porta entre o computador que está executando o Exchange Server Analyzer e o controlador de domínio que não respondeu.

  3. Verifique se o controlador de domínio está conectado à rede e funcionando corretamente.

Para obter mais informações sobre como resolver problemas de conectividade do Active Directory, consulte o artigo 816103 da Base de Dados de Conhecimento da Microsoft, "HOW TO: Usar Portqry para resolver problemas de conectividaded do Active Directory" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103).

Para obter mais informações sobre como configurar o Microsoft Windows® Time nos controladores de domínio, consulte o artigo 816042 da Base de Dados de Conhecimento, "Como configurar um servidor de tempo autorizado no Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042).


A porta 636 não respondeu
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo dNSHostName para todos os controladores de domínio no Active Directory. Depois de recuperar os nomes dos controladores de domínio, o Exchange Server Analyzer abre uma conexão de soquete TCP para a porta 636 em cada controlador de domínio. Essa conexão é feita com um processador de objetos personalizado que retorna uma cadeia de caracteres específica se a conexão é bem-sucedida. Se o Exchange Server Analyzer não receber 636 Disponível como parte da cadeia de caracteres retornada, será exibido um aviso.

Esse aviso indica que o controlador de domínio não respondeu a uma tentativa de conexão na porta TCP 636. A porta TCP 636 é a porta padrão para comunicações por protocolo LDAP por SSL.

Com a introdução do Exchange 2000 Server Service Pack 3, o Exchange Server se conectará ao LDAP por SSL se existir um certificado inválido no armazenamento de certificados local no computador do Exchange Server. Se não houver um certificado, ou se um erro relacionado ao certificado for retornado (por exemplo, o controlador de domínio não confiar no certificado do Exchange ou o certificado utilizado exigir proteção de chaves), o Exchange Server automaticamente usará o LDAP sem SSL. Se você estiver recebendo esse aviso, isso poderá estar acontecendo por causa de problemas de conectividade entre o Exchange Server Analyzer e o controlador de domínio. PKI (Public Key Infrastructure) ou outros problemas de certificado não serão expostos pelo aviso.

Há vários motivos para que as solicitações LDAP por SSL não sejam atendidas adequadamente por um controlador de domínio quando o Exchange Server Analyzer o consulta.

Para corrigir esse aviso

  1. Verifique se a conta que está executando a ferramenta está autorizada a consultar o controlador de domínio. Você precisará de permissões de nível de Usuário no domínio onde o controlador de domínio está sendo executado. Mais informações sobre as permissões exigidas para executar o Exchange Server Analyzer podem ser encontradas no arquivo de Ajuda incluído com a ferramenta. Abra o arquivo de Ajuda, abrindo o Exchange Server Analyzer, clicando em Ajuda e em Ajuda do Microsoft Exchange Server Analyzer Tool.

  2. Verifique se não há firewalls ou restrições de porta entre o computador que está executando o Exchange Server Analyzer e o controlador de domínio que não respondeu.

  3. Verifique se o controlador de domínio está conectado à rede e funcionando corretamente.

  4. Verifique se o horário no computador que está executando o Exchange Server Analyzer e no controlador de domínio que falhou ao responder estão sincronizados. Se o Microsoft Windows® Time Service no controlador de domínio estiver parado ou desabilitado, o horário local do controlador de domínio pode estar fora de sincronização. Nesse caso, o controlador de domínio não responderá às solicitações LDAP por SSL até que o relógio esteja sincronizado.

Para obter mais informações sobre o uso de LDAP por SSL, consulte o artigo 321051 da Base de Dados de Conhecimento da Microsoft, "Como ativar o LDAP por SSL com uma Autoridade de Certificação de terceiros" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321051).

Para obter mais informações sobre como resolver problemas de conectividade do Active Directory, consulte o artigo 816103 da Base de Dados de Conhecimento da Microsoft, "COMO: Utilizar o Portqry para Resolver Problemas de Conectividade do Active Directory" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103).

Para obter mais informações sobre o Windows Time Service, consulte o artigo 816042 da Base de Dados de Conhecimento da Microsoft, "Como configurar um servidor de horário autoritário no Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042).


O servidor SMTP não dá suporte ao verbo X-LINK2STATE
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer inicia uma sessão SMTP com um servidor Exchange para validar que os verbos SMTP adequados do Exchange estão listados. Se o verbo X-LINK2STATE não estiver na lista, será exibido um aviso.

O verbo X-LINK2STATE é usado pelo Exchange para atualizar as tabelas de estados de link nos controladores de roteamento. Essas tabelas gravam informações atualizadas sobre o status dos links SMTP em toda a organização do Exchange. O Exchange usa essas informações para conseguir as rotas de custo mais baixo e mais confiáveis ao rotear mensagens. Esta funcionalidade também é chamada de "Roteamento Inteligente".

O verbo X-LINK2STATE é exigido pelo Exchange para roteamento eficiente e não é usado por outros provedores SMTP. Dessa forma, a funcionalidade é fornecida em um arquivo (xlsasink.dll) que é instalado e registrado pelo Programa de Instalação do Exchange.

Existem dois motivos pelos quais este aviso pode ser retornado. Primeiro, alguns administradores podem ter desabilitado xlsasink.dll como forma de trabalhar na funcionalidade de roteamento inteligente fornecida. Essa não é uma prática recomendada e provavelmente gerará problemas de desempenho e confiabilidade. Nesse caso, é recomendável que você reinstale o Exchange no computador afetado a fim de instalar e registrar o xlsasink.dll.

Segundo, este aviso poderá ser retornado se você estiver executando um produto antivírus que instale e use a sua própria pilha de protocolo SMTP para verificação de mensagens. Nesse caso, o software antivírus pode executar a sua própria pilha SMTP que intercepta e verifica mensagens antes que elas alcancem a pilha SMTP do Exchange, Neste caso, a pilha SMTP do antivírus não está usando o verbo X-LINK2STATE. É recomendável executar o software antivírus em um modo que não o necessite para instalar a sua própria pilha SMTP no servidor Exchange.

Para obter mais informações sobre o X-LINK2STATE e outros verbos proprietários usados pelo Exchange, consulte o artigo 812455 da Base de Dados de Conhecimento Microsoft, "Definições de verbos usados entre dois servidores Exchange" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455).

Para obter mais informações sobre como exibir os verbos de comando do Exchange e reinstalar o Exchange 2000 Server, consulte o artigo 319885 da Base de Dados de Conhecimento, "XCON: Messages Sent in the Exchange 2000 Server Organization Are Not Delivered" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885).

Para obter mais informações sobre como exibir os verbos de comando do Exchange e reinstalar o Exchange Server 2003, consulte o artigo 822939 da Base de Dados de Conhecimento Microsoft, "Messages That Are Sent in the Exchange Server 2003 Organization Are Not Delivered" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939).


Falha do servidor SMTP no teste de aceitação de mensagens
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool tenta enviar uma mensagem para a conta Postmaster do domínio SMTP, executando as seguintes tarefas.

  • Abrindo uma conexão do soquete para o servidor SMTP. Se o Exchange Server Analyzer receber o código de resposta 220, considera-se que essa etapa foi concluída com êxito.

  • Transmitindo o verbo de comando EHLO do SMTP. Se o Exchange Server Analyzer receber uma série de códigos de resposta 250, incluindo uma resposta que contenha 250-X-LINK2STATE e 250-XEXCH50, considera-se que essa etapa foi concluída com êxito.

  • Transmitindo o verbo de comando MAIL FROM: ExBPA-MailAcceptTest@Fabrikam.com. Se o Exchange Server Analyzer receber o código de resposta 250, considera-se que essa etapa foi concluída com êxito.

  • Transmitindo o RCPT TO: Postmaster@<nome_de_domínio>.com. Se o Exchange Server Analyzer receber o código de resposta 250, considera-se que essa etapa foi concluída com êxito.

Se o Exchange Server Analyzer não puder concluir com êxito todas as etapas, um erro será exibido. O erro indica que pode haver um problema geral de fluxo de mensagens. Os links a seguir estão listados na ordem em que você deve solucionar o problema, iniciando no nível de servidor e continuando até o nível de rede.

Para corrigir esse erro

  1. Consulte "Solucionar problemas de roteamento" no Guia de Transporte e Roteamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579) (em inglês).

  2. Consulte o artigo 324867da Base de Dados de Conhecimento Microsoft, "Suporte WebCast: Microsoft Exchange 2000 Server: Solucionando problemas de fluxo de mensagens (visitado novamente)" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867) (em inglês).

  3. Consulte o artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489).

  4. Consulte a Base de Dados de Conhecimento Microsoft artigo 324759, "Suporte WebCast: Microsoft Exchange 2000 Server: Solução de problemas de DNS em transportes " (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759) (em inglês).

Para obter mais informações sobre a conta Postmaster no Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 223860, "XCON: Caixa de correio de Postmaster SMTP deve ser definida manualmente" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860)

  • 313832, "COMO FAZER PARA: Definir uma conta Postmaster SMTP no Exchange 2000 Server" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832)


O servidor SMTP falhou no teste de retransmissão aberta
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2007-03-14

A ferramenta Microsoft® Exchange Server Analyzer tenta retransmitir uma mensagem através de um servidor SMTP, executando as seguintes tarefas:

  • Abrindo uma conexão do soquete para o servidor SMTP. Se o Exchange Server Analyzer receber o código de resposta 220, considera-se que essa etapa foi concluída com êxito.

  • Transmitindo o verbo de comando EHLO do SMTP. Se o Exchange Server Analyzer receber uma série de códigos de resposta 250, incluindo uma resposta que contenha 250-X-LINK2STATE e 250-XEXCH50, considera-se que essa etapa foi concluída com êxito.

  • Transmitindo o verbo de comando MAIL FROM: ExBPA-OpenRelayTest@Fabrikam.com do SMTP. Se o Exchange Server Analyzer receber o código de resposta 250, considera-se que essa etapa foi concluída com êxito.

  • Transmitindo o RCPT TO: ExBPA-OpenRelayTest@Fabrikam.com do SMTP. Se o Exchange Server Analyzer receber o código de resposta 250, considera-se que essa etapa foi concluída com êxito.

O Exchange Server Analyzer também consulta a classe do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_OperatingSystem para determinar o valor da chave OSProductSuite. O valor dessa chave corresponde a uma versão específica de um sistema operacional Windows Server.

Se o Exchange Server Analyzer puder concluir com êxito todas as etapas em um computador do Exchange Server que seja parte de uma instalação do Microsoft Small Business Server 2000 ou do Microsoft Windows Small Business Server 2003, será exibido um erro.

O erro indica que esse servidor está configurado como uma retransmissão aberta.

Não é uma prática recomendada permitir retransmissão aberta.

A retransmissão aberta ocorre quando um servidor de email permite que mensagens de email sejam retransmitidas pelo sistema sem exercer nenhuma restrição ou controle sobre o email retransmitido.

Observação:
Se, por algum motivo, sua organização do Exchange utilizar um nome de domínio SMTP chamado Fabrikam.com, esse erro poderá ser encontrado. Nesse caso, será possível ignorar esse erro com segurança. O domínio Fabrikam.com pertence à Microsoft Corporation e é usado para treinamento, documentação e outros fins similares.

A retransmissão não é necessariamente ruim, porque o protocolo SMTP foi criado com esse fim (para obter mais informações, consulte o documento RFC 2821, seções 2.1 e 3.7 (http://ietf.org)). No entanto, se a retransmissão não for controlada (um host não controlado é conhecido como host de retransmissão aberta), um usuário mal-intencionado poderá usar a retransmissão para enviar mensagens de email em massa e mensagens de email comerciais não solicitadas (spam ou UCE). Repercutindo essas mensagens de email não solicitadas de um host intermediário, o usuário mal-intencionado tenta ocultar sua identidade. Isso também vincula recursos no host de retransmissão e pode impedir que o host de retransmissão envie mensagens de email válidas. Em particular, a maioria dos usuários que enviam mensagens de email não solicitadas desse tipo podem enviar uma única mensagem para um número extraordinário de destinatários, sem usar sua própria largura de banda para isso.

Verifique se você não está permitindo retransmissão anônima em seus servidores virtuais SMTP voltados para a Internet. Na configuração padrão, o Exchange permite a retransmissão de email apenas a usuários autenticados. Apenas usuários autenticados podem usar o Exchange para enviar mensagens para um domínio externo. Se você modificar as configurações padrão de retransmissão para permitir que usuários não autenticados façam a retransmissão, ou se permitir a retransmissão aberta para um domínio através de um conector, usuários não autorizados ou worms mal-intencionados podem usar seu servidor Exchange para enviar spam. Seu servidor pode entrar em listas de bloqueio e ser impedido de enviar emails para servidores remotos legítimos. Para impedir que usuários não autorizados usem o servidor Exchange para retransmitir mensagens, use, no mínimo, as restrições padrão de retransmissão.

Se você tiver motivos legítimos para retransmissão, siga as diretrizes para garantir que a segurança seja preservada em sua implementação. Isso é feito principalmente mantendo os padrões de negação a todos e adicionando apenas os endereços IP dos quais você aceitará mensagens retrasmitidas, e desabilitando o acesso para usuários autenticados.

Revise como as contas internas (Administrador local) e outros usuários são usados em seus servidores de gateway. É improvável que você use as contas internas para qualquer tipo de retransmissão. Se você estiver retransmitindo, a retransmissão é feita, provavelmente, por um conjunto conhecido de usuários ou computadores. A restrição dos direitos de retransmissão a usuários e computadores explícitos ou a um endereço IP é recomendável.

A configuração de permissão explícita para retransmissão ajudará a fortificar seu servidor. Usuários mal intencionados podem usar um ataque de força bruta para tentar obter as senhas de contas internas ou contas de usuários encontradas na Internet, de modo que possam usar seu servidor como um proxy de spam. Portanto, a configuração padrão que permite que qualquer computador autenticado faça retransmissão não é recomendável para computadores que são acessíveis a partir da Internet. É recomendável desabilitar essa configuração.

Os procedimentos a seguir explicam como desabilitar a retransmissão anônima com base em se o servidor virtual SMTP está ou não voltado para a Internet. Como mencionado anteriormente neste artigo, a habilitação de qualquer forma de retransmissão anônima deve ser feita apenas nos casos em que o risco à segurança seja compreendido e aceitável para sua organização. As referências no final deste artigo fornecem mais informações sobre como usar a retransmissão.

Se um servidor virtual SMTP não estiver acessível a partir da Internet, é recomendável que você redefina as configurações de retransmissão com os valores padrão. Isso fará com que os servidores virtuais SMTP permitam apenas retransmissão interna de computadores autenticados.

Para servidores virtuais SMTP que são acessíveis a partir da Internet, recomendamos que você aumente a proteção das configurações de retransmissão padrão para que apenas usuários e computadores com permissão explícita tenham permissão para retransmitir.

Se você verificou que o Exchange está configurado para bloquear a retransmissão, mas continua recebendo esse erro no Exchange Server Analyzer, verifique se algum servidor ou processo de proxy, como software de firewall, antivírus ou antispam, não está permitindo a retransmissão anônima.

Para redefinir as configurações de retransmissão anônima com as configurações padrão em servidores virtuais SMTP internos.

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Na árvore do console, expanda Servidores, expanda o servidor desejado e, em seguida, Protocolos e SMTP.

  3. Clique com o botão direito no servidor virtual SMTP ao qual você deseja aplicar restrições de retransmissão e clique em Propriedades.

  4. Em >Propriedades< do servidor virtual SMTP, clique na guia Acesso e clique em Retransmissão.

  5. Em Restrições de Retransmissão, em Selecione qual computador pode retransmitir através desse servidor virtual, selecione Somente a lista abaixo, marque a caixa de seleção Permitir a retransmissão por todos os computadores que autenticam com êxito, independentemente da lista abaixo, e clique em OK.

Para configurar a permissão para retransmissão explícita em Servidores Virtuais SMTP voltados para a Internet no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Na árvore do console, expanda Servidores, expanda o servidor desejado e, em seguida, Protocolos e SMTP.

  3. Clique com o botão direito no servidor virtual SMTP ao qual você deseja aplicar restrições de retransmissão e clique em Propriedades.

  4. Em >Propriedades< do servidor virtual SMTP, clique na guia Acesso e clique em Retransmissão.

  5. Em Restrições de Retransmissão, desmarque a caixa de seleção Permitir a retransmissão por todos os computadores que autenticam com êxito, independentemente da lista abaixo, e clique em Usuários para especificar um subconjunto de usuários aos quais deseja conceder permissões de retransmissão nesse servidor virtual SMTP.

  6. Em Permissões de Envio e Retransmissão, para remover um usuário ou grupo, selecione o grupo ou usuário e clique em Remover.

  7. Para adicionar um grupo ou usuário, clique em Adicionar e selecione os usuários ou o grupo para os quais deseja especificar permissões. Selecione uma das opções a seguir:

    • No Microsoft Windows Server™ 2003, em Selecionar Usuários, Computadores ou Grupos, em Digite o nome do objeto a ser selecionado, digite o nome do usuário ou do grupo. Se você desejar buscar o usuário ou grupo, clique em Avançado, pesquise o nome do usuário ou do grupo, e clique em Verificar Nomes para validar sua entrada.

      Dica:
      Clique no link exemplos para exibir os formatos aceitáveis para as entradas.
    • No Windows 2000 Server, em Selecionar Usuários, Computadores ou Grupos, selecione o grupo ou o usuário para o qual deseja conceder permissões de envio e clique em Adicionar.

  8. Clique em OK para retornar à caixa de diálogo Permissões para Envio e Retransmissão.

  9. Em Lista de nomes de grupos ou usuários, selecione o grupo que você acaba de adicionar.

  10. Em Permissões para <grupo selecionado>, ao lado de Permissão de Envio, se necessário, marque a caixa de seleção em Permitir para permitir que o usuário ou grupo selecionado envie mensagens através desse servidor virtual SMTP.

  11. Ao lado de Permissões de Retransmissão, marque a caixa de seleção em Permitir para permitir que o objeto selecionado retransmita através desse servidor virtual SMTP, ou marque a caixa de seleção em Negar para impedir que o objeto selecionado retransmita através desse servidor virtual.

    Observação:
    Você deve autorizar Permissões de Envio se desejar autorizar Permissões de Retransmissão.

  12. Clique em OK.

Para configurar permissões para retransmissão em Servidores Virtuais SMTP voltados para a Internet no Exchange Server 2000

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Na árvore do console, expanda Servidores, expanda o servidor a ser configurado e, em seguida, Protocolos e SMTP.

  3. Clique com o botão direito no servidor virtual SMTP ao qual você deseja aplicar restrições de retransmissão e clique em Propriedades.

  4. Em >Propriedades< do servidor virtual SMTP, clique na guia Acesso e clique em Retransmissão.

  5. Em Restrições de Retransmissão, em Selecione qual computador pode retransmitir através desse servidor virtual, selecione Apenas a lista abaixo.

  6. Clique em Adicionar para adicionar um único computador, um grupo de computadores ou um nome de domínio SMTP e clique em OK. Repita essa etapa para cada entrada que desejar adicionar.

  7. Marque a caixa de seleção Permitir a retransmissão por todos os computadores que autenticam com êxito, independentemente da lista acima e clique em OK duas vezes.

Para obter mais informações sobre retransmissão de mensagens e segurança, consulte os seguintes guias da Biblioteca Técnica do Exchange Server 2003.

  • Guia de Transporte e Roteamento do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?linkid=47579).

  • Retardando e parando vírus transmitidos por email em um ambiente do Exchange 2003 (página em inglês) (http://go.microsoft.com/fwlink/?linkid=47587)

Para obter mais informações sobre como testar e proteger o comportamento de retransmissão aberta no ambiente do Exchange e do Microsoft Windows, consulte o artigo 304897 da Base de Dados de Conhecimento Microsoft, "Comportamento de retransmissão SMTP no Windows 2000, no Windows XP e no Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=304897).


A versão do SMTP em execução não suporta o verbo XEXCH50
Microsoft Exchange Server Analyzer - Artigos > Rede >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer inicia uma sessão SMTP com um servidor Exchange para validar que os verbos SMTP adequados do Exchange estão listados. Se o verbo XEXCH50 não estiver listado, um aviso será exibido.

Entre outras coisas, o verbo XEXCH50 é usado pelo Exchange para replicação de pastas públicas. A execução de uma versão do SMTP em um servidor Exchange que não oferece suporte para o verbo XEXCH50 causará uma interrupção na replicação de pastas públicas.

O verbo XEXCH50 não é usado por outros provedores de SMTP; portanto, a funcionalidade é fornecida em um arquivo (peexch50.dll) que é registrado e instalado pela Instalação do Exchange.

O Exchange Server Analyzer pode retornar esse aviso se você estiver executando um produto antivírus que instale e use sua própria pilha de protocolo SMTP para verificar mensagens. Nesse caso, o software de antivírus usa sua própria pilha SMTP para interceptar e verificar mensagens antes que elas cheguem na pilha SMTP do Exchange. Nesse caso, a pilha SMTP do software antivírus não está usando o verbo XEXCH50.

É recomendável que você execute o software antivírus em um modo que não exija a instalação de sua própria pilha SMTP no servidor Exchange ou execute esse software no perímetro de entrada da sua rede SMTP. Se você tiver desabilitado a pilha SMTP do software antivírus e continuar recebendo esse aviso, reinstale o Exchange para instalar e registrar peexch50.dll corretamente.

Para obter mais informações sobre o XEXCH50 e outros verbos proprietários usados pelo Exchange, consulte o artigo 812455 da Base de Dados de Conhecimento Microsoft, "Definições de verbos usados entre 2 servidores Exchange" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455).

Para obter mais informações sobre como exibir os verbos de comando do Exchange e reinstalar o Exchange 2000 Server, consulte o artigo 319885 da Base de Dados de Conhecimento, "XCON: Messages Sent in the Exchange 2000 Server Organization Are Not Delivered" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885).

Para obter mais informações sobre como exibir os verbos de comando do Exchange e reinstalar o Exchange Server 2003, consulte o artigo 822939 da Base de Dados de Conhecimento Microsoft, "Messages That Are Sent in the Exchange Server 2003 Organization Are Not Delivered" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939).


Protocolos
Microsoft Exchange Server Analyzer - Artigos >

Última modificação do tópico: 2005-11-18

Os artigos desta seção fornecem detalhes sobre o que a ferramenta Microsoft® Exchange Server Analyzer Tool está avaliando em relação aos protocolos de Internet. Além disso, esses artigos descrevem as ações que podem ser tomadas para resolver erros, avisos e configurações não padrão relacionados aos protocolos de Internet, detectados pelo Exchange Server Analyzer.


Erro de resposta de ponta a ponta do Active Directory
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_PingStatus do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor (chave StatusCode) retornada do servidor do serviço de diretório do Active Directory®. Win32_PingStatus retorna um objeto com 24 propriedades que fornecem detalhes completos sobre os pacotes de ping enviados pela classe.

Se o Exchange Server Analyzer determinar que o valor dessa chave corresponde a um dos valores na tabela a seguir, será exibido um erro.

O Exchange Server Analyzer exibe o nome de servidor do Active Directory e o valor StatusCode correspondente retornado com esse erro.

Valor de StatusCode Significado Descrição

11001

Buffer Muito Pequeno

É pouco provável que esse erro seja retornado porque o Analisador do Exchange Server está gerando uma solicitação padrão.

11002

Rede de Destino Inacessível

A solicitação falhou porque a rede que contém o computador de destino não está disponível; não existe uma rota válida para o computador de destino.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Host de Destino Inacessível

A solicitação falhou porque o computador de destino está inacessível.

Para obter informações, consulte o servidor do Active Directory Servidor do Active Directory desativado ou inacessível.

Esse erro também pode ser causado por um firewall entre o local onde o Exchange Server Analyzer está sendo executado e o controlador de domínio de destino, ou mesmo por um erro de DNS.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Protocolo de Destino Inacessível

A solicitação falhou porque o computador de destino não responde ao protocolo de pacote.

Esse erro pode ser causado por um firewall entre o local onde o Exchange Server Analyzer está sendo executado e o controlador de domínio de destino.

11005

Porta de Destino Inacessível

A solicitação falhou porque a porta no computador de destino não está disponível.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Não Há Recursos

A solicitação falhou por causa de recursos de rede insuficientes.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Opção Inválida

A solicitação falhou porque contém uma opção inválida.

É pouco provável que esse erro seja retornado porque o Analisador do Exchange Server está gerando uma solicitação padrão.

11008

Erro de Hardware

A solicitação falhou por causa de um erro de hardware.

Confirme se o controlador de domínio está em operação adequada executando a ferramenta de verificação de integridade de hardware do fabricante de seu computador.

11009

Pacote Muito Grande

A solicitação falhou porque o pacote que a contém é maior do que a MTU (unidade máxima de transmissão) de um nó (roteador ou gateway) localizado entre a origem e o destino. A MTU define o tamanho máximo de um pacote para transmissão.

A solicitação enviada pelo Exchange Server Analyzer não tem mais de 10 KB de tamanho. Verifique se os roteadores e os gateways da sua organização estão configurados corretamente.

Para obter informações, consulte o artigo 159211 da Base de Dados de Conhecimento, "Diagnóstico e tratamento de roteadores de buraco negro" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Tempo Limite da Solicitação Atingido

A resposta não foi recebida dentro do tempo alocado. O tempo padrão permitido para respostas é de cinco segundos.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Solicitação Incorreta

A solicitação falhou porque foi codificada incorretamente.

É pouco provável que isso seja retornado porque o Analisador do Exchange Server está gerando uma solicitação padrão.

11012

Rota Inválida

A solicitação falhou porque não existe nenhuma rota válida entre os computadores de origem e de destino.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

Trânsito TimeToLive Expirado

A solicitação falhou porque ser valor de TTL (Tempo de Vida) atingiu zero, o que faz com que o nó de encaminhamento (roteador ou gateway) descarte o pacote.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Reagrupamento TimeToLive Expirado

A solicitação falhou porque o pacote foi dividido em fragmentos para transmissão e nem todos os fragmentos foram recebidos dentro do tempo alocado para reagrupamento. O RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) especifica 60 segundos como o limite de tempo no qual todos os fragmentos do pacote devem ser recebidos.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Problema de Parâmetro

A solicitação falhou porque um nó (roteador ou gateway) encontrou problemas ao processar o cabeçalho do pacote. Esse status ocorre se, por exemplo, o cabeçalho contiver dados de campo inválidos ou uma opção não reconhecida.

É pouco provável que isso seja retornado porque o Analisador do Exchange Server está gerando uma solicitação padrão.

11016

Retardamento de Origem

A solicitação falhou porque o pacote foi descartado. Isso ocorre quando a fila de saída do computador de origem tem espaço de armazenamento insuficiente, ou quando os pacotes chegam ao destino rápido demais para serem processados.

É pouco provável que isso seja retornado porque o Analisador do Exchange Server está gerando uma solicitação padrão.

11017

Opção Grande Demais

A solicitação falhou porque contém uma opção inválida.

É pouco provável que isso seja retornado porque o Analisador do Exchange Server está gerando uma solicitação padrão.

11018

Destino Inválido

A solicitação falhou porque o endereço IP de destino não pode receber solicitações de PING ou não deve nunca aparecer no campo de endereço de destino de nenhum datagrama de IP.

Isso pode ser causado por um firewall entre o local onde o Exchange Server Analyzer está sendo executado e o controlador de domínio de destino.

11032

Negociando IPSEC

Falha na solicitação porque uma conexão IPsec não pôde ser negociada.

11050

Falha Geral

A solicitação falhou por razão desconhecida.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Erro de resposta de ponta a ponta do Active Directory para o Exchange Server
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-05-15

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_PingStatus do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave StatusCode retornada do servidor de serviço de diretório do Active Directory®. Win32_PingStatus retorna um objeto que tem 24 propriedades que fornecem detalhes abrangentes sobre os pacotes de ping que a classe envia.

Se o Exchange Server Analyzer perceber que o valor para essa chave corresponde a um dos valores da tabela a seguir, ele exibirá um erro.

O Exchange Server Analyzer exibe o nome de servidor do Active Directory, o nome do Exchange Server e o valor de StatusCode correspondente que é retornado com esse erro.

Valor de StatusCode Significado Descrição

11001

Buffer Muito Pequeno

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11002

Rede de Destino Inacessível

A solicitação falhou porque a rede que contém o computador de destino está inacessível. Não existe uma rota válida para o computador de destino.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Host de Destino Inacessível

A solicitação falhou porque o computador de destino está inacessível.

Para obter mais informações, consulte Servidor do Active Directory desativado ou inacessível (em inglês).

Esse erro também pode ser causado por uma das seguintes condições:

  • Um firewall entre o local onde o Exchange Server Analyzer está sendo executado e o controlador de domínio de destino.

  • Um erro de DNS.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Protocolo de Destino Inacessível

A solicitação falhou porque o computador de destino não responde ao protocolo de pacote.

Esse erro pode ser causado por um firewall entre o local onde o Exchange Server Analyzer está sendo executado e o controlador de domínio de destino.

11005

Porta de Destino Inacessível

A solicitação falhou porque a porta no computador de destino não está disponível.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Não Há Recursos

A solicitação falhou por causa de recursos de rede insuficientes.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Opção Inválida

A solicitação falhou porque contém uma opção inválida.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11008

Erro de Hardware

A solicitação falhou por causa de um erro de hardware.

Verifique se o controlador de domínio está em operação adequadamente, executando a ferramenta de verificação de integridade de hardware fornecida pelo fabricante do computador.

11009

Pacote Muito Grande

A solicitação falhou porque o pacote que contém a solicitação é maior do que a MTU (unidade máxima de transmissão) de um roteador ou nó de gateway localizado entre a origem e o destino. A MTU define o tamanho máximo de um pacote para transmissão.

A solicitação enviada pelo Exchange Server Analyzer não é maior do que 10 KB. Verifique se os roteadores e os gateways da sua organização estão configurados corretamente.

Para obter mais informações, consulte o artigo 159211 da Base de Dados de Conhecimento Microsoft, "Diagnóstico e tratamento de roteadores de buraco negro" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Tempo Limite da Solicitação Atingido

Não houve resposta no tempo alocado. O tempo padrão permitido para respostas é de cinco segundos.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Solicitação Incorreta

A solicitação falhou porque foi codificada incorretamente.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11012

Rota Inválida

A solicitação falhou porque não existe nenhuma rota válida entre os computadores de origem e de destino.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

Trânsito TimeToLive Expirado

A solicitação falhou porque o valor de Vida Útil (TTL) chegou a zero. Isso faz com que o nó do gateway ou roteador de encaminhamento descarte o pacote.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Reagrupamento TimeToLive Expirado

A solicitação falhou porque o pacote foi dividido em fragmentos para transmissão e nem todos os fragmentos foram recebidos no tempo alocado para o reagrupamento. O RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) especifica 60 segundos como o limite de tempo no qual todos os fragmentos do pacote devem ser recebidos.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Problema de Parâmetro

A solicitação falhou porque um nó do gateway ou roteador encontrou problemas ao processar o cabeçalho do pacote. Isso pode ocorrer se o cabeçalho contiver dados de campo inválidos ou uma opção não reconhecida.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11016

Retardamento de Origem

A solicitação falhou porque o pacote foi descartado. Isso ocorre quando a fila de saída do computador de origem não possui espaço de armazenamento insuficiente. Também pode ocorrer quando os pacotes chegam ao destino muito rapidamente para serem processados.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11017

Opção Grande Demais

A solicitação falhou porque contém uma opção inválida.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11018

Destino Inválido

A solicitação falhou porque:

  • O endereço IP de destino não pode receber solicitações PING.

  • O endereço IP de destino nunca deve aparecer no campo de endereço de destino de nenhum datagrama IP.

Isso pode ser causado por um firewall entre o local onde o Exchange Server Analyzer está sendo executado e o controlador de domínio de destino.

11032

Negociando IPSEC

A solicitação falhou porque uma conexão IPsec não pôde ser negociada.

11050

Falha Geral

A solicitação falhou por razão desconhecida.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


O acesso anônimo é permitido em servidores virtuais SMTP internos e servidores virtuais SMTP dedicados a clientes IMAP e POP
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchAuthenticationFlags na classe protocolCfgSMTPServer para o objeto do Exchange Server. A classe protocolCfgSMTPServer contém as configurações para um servidor virtual SMTP. O atributo msExchAuthenticationFlags representa o tipo de autenticação permitida no servidor SMTP. O Exchange Server Analyzer exibe uma mensagem de aviso se existirem as seguintes condições:

  • A autenticação no atributo msExchAuthenticationFlags foi configurado para permitir acesso anônimo ao servidor SMTP.

  • O servidor não está executando o Microsoft Small Business Server 2000 ou Microsoft Windows® Small Business Server 2003.

  • O Exchange Server hospeda mais de 20 caixas de correio.

Para aumentar a segurança, desabilite o acesso anônimo em servidores virtuais SMTP internos que não aceitam email de entrada da Internet. Para aumentar a segurança, você pode também desabilitar o acesso anônimo em servidores SMTP virtuais dedicados para usuários IMAP e POP.

Importante:
Não desabilite o acesso anônimo nos seus servidores SMTP bridgehead virtuais. Os servidores SMTP virtuais que aceitam email da Internet devem permitir acesso anônimo.

Quando você envia um email interno, os servidores Exchange na sua organização autenticam-se entre si para enviar email. Portanto, você não tem que habilitar o acesso anônimo nos servidores SMTP virtuais internos. Impedindo o acesso anônimo nos seus servidores internos, o fluxo de mensagens não é interrompido e uma camada adicional de segurança é fornecido no servidor SMTP virtual interno.

Da mesma maneira, os clientes IMAP e POP autenticam com seus servidores SMTP virtuais antes de enviar email para os servidores SMTP virtuais. Portanto, se você usar servidores SMTP virtuais dedicados para seus clientes IMAP e POP, pode configurar esses servidores para permitir somente acesso autenticado. Se você desabilitar o acesso anônimo nesses servidores, poderá ajudar a impedir que usuarios não autorizados os acessem.

Se você não puder desabilitar o acesso autenticado no seu servidor virtual SMTP por motivos comerciais, como a autenticação por uma empresa parceira, siga estas etapas para ajudar a melhorar a segurança em seu servidor gateway:

  • Aplique uma diretiva de senhas de alta segurança a todas as contas de usuário, especialmente à conta do administrador.

  • Desabilite a conta de convidado. Para obter mais informações sobre como desabilitar a conta de convidado, consulte o artigo 320053 da Base de Dados de Conhecimento da Microsoft, "How to rename the administrator and guest account in Windows 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053). Embora esse artigo se aplique ao Windows 2000 Server, princípios similares se aplicam ao Windows Server 2003.

Para desabilitar a autenticação com acesso anônimo para um Servidor SMTP Virtual

  1. No Gerenciador do Sistema Exchange, expanda Servidores, expanda <your inbound Exchange server>, expanda Protocolos e expanda SMTP.

  2. Clique com o botão direito em seu servidor virtual SMTP de entrada e clique em Propriedades.

  3. Clique na guia Acesso e clique em Autenticação.

  4. Em Autenticação, desmarque a caixa de seleção Acesso Anônimo.

Para obter mais informações sobre como configurar sua organização do Exchange Server 2003 para enviar e receber mensagens da Internet com mais segurança, consulte o Guia de Transporte e Roteamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


A verificação antivírus em segundo plano foi habilitada
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada de Registro para determinar se a verificação de antivírus em segundo plano está habilitada:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Se o Exchange Server Analyzer detectar que o valor para a entrada BackgroundScanning está definido como 1, um aviso será exibido.

Quando a entrada de Registro BackgroundScanning estiver presente e definida como 1, todas as mensagens são verificadas novamente em segundo plano sempre que o arquivo de assinatura do programa antivírus for atualizado. Esse comportamento impacta significativamente o desempenho sempre que um arquivo de assinatura do programa antivírus é atualizado e, portanto, não é recomendado pela Microsoft.

Quando você usa um programa antivírus com base em VSAPI (Virus Scanning Application Programming Interface) 2.0 e um cliente tenta abrir uma mensagem, é feita uma comparação para confirmar que o corpo e o anexo da mensagem foram verificados pelo arquivo de assinatura de vírus atual. Se o arquivo padrão de assinatura atual não tiver sido usado para verificar o conteúdo, a mensagem correspondente será enviada para o programa antivírus antes que ela fique disponível para o cliente.

Se o programa antivírus instalado não incluir uma interface de usuário que permita que você desabilite a verificação em segundo plano, você poderá usar o seguinte procedimento para controlar esse comportamento, modificando o Registro no computador do Exchange Server.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. No painel direito, clique duas vezes no valor BackgroundScanning.

  4. No campo Dados do Valor, altere o valor para 0.

  5. Feche o editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange e os serviços de seu software antivírus para que a alteração entre em vigor.
  • Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

  • Para obter mais informações sobre os diferentes tipos de programas de verificação antivírus usados pelo Exchange, consulte o artigo 328841 da Base de Dados de Conhecimento, "Exchange e o software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).


O valor de CheckPop3Tail foi alterado
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o seguinte valor de Registro existe:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\CheckPop3Tail

Se Exchange Server Analyzer encontrar o valor de CheckPop3Tail presente e configurado com um valor 1, uma mensagem de configuração não padrão será exibida.

O RFC (Request for Comments) 1939 do IETF (Internet Engineering Task Force (IETF) (http://www.ietf.org/rfc/rfc1939.txt) especifica a seqüência de término de CRLF para mensagens POP3. No Exchange, a seqüência CRLF é conhecida como POP3Tail. Se um cliente POP3, como o Microsoft Office Outlook® 2003 ou Microsoft Outlook Express, encontrar uma mensagem mal formada com um POP3Tail errado (por exemplo: sem o CRLF), isso pode impedir a resposta e causar falha no download de todas as mensagens da Caixa de entrada. O valor de Registro CheckPop3Tail representa uma oportunidade de configuração para os administradores instruírem o serviço POP3 do Microsoft Exchange para verificar o POP3Tail de todas as mensagens POP3, e adicionar a seqüência de terminação correta, se ela estiver faltando.

Observação:
Essa configuração corrigirá as mensagens mal formadas e permitirá que o cliente POP3 baixe todas as mensagens da Caixa de entrada do usuário, ela também causará uma pequena redução do desempenho, já que todas as mensagens serão verificadas com relação a um POP3Tail adequado.

Se você desejar, é possível usar o procedimento abaixo para remover o valor de Registro CheckPop3Tail .

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para excluir o valor de Registro CheckPop3Tail

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Exclua o valor chamado CheckPop3Tail.

  4. Feche o editor de Registro e reinicie o serviço POP3 do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o uso do valor de Registro CheckPop3Tail, consulte o artigo 816896 da Base de Dados de Conhecimento, "XCCC: O cliente POP3 pára de responder (desliga) ou o tempo limite se esgota quando você tenta baixar mensagens" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816896).


O Defense Message System está habilitado
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo heuristics foi configurado para habilitar o Defense Message System. Por padrão, o atributo heuristics não é configurado. Se o Exchange Server Analyzer perceber que o atributo heuristics está definido como 256, o Exchange Server Analyzer exibe uma mensagem de configuração não padrão.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

O Programa DMS (Defense Message System) foi estabelecido pela Subsecretaria de Defesa dos EUA (Aquisições) para facilitar e coordenar o desenvolvimento de um sistema integrado de mensagens para o usuário comum que atenda aos requisitos do autor ao leitor, reduza os níveis de custo e pessoal, e aumente a funcionalidade, a segurança, a durabilidade e a disponibilidade.

Para obter mais informações sobre o Defense Message System, consulte o site da Lockheed Martin (http://www.lockheedmartin.com).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


Desabilitar aviso de clientes MAPI
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2007-05-01

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar se o bloqueio do cliente MAPI foi definido:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable MAPI Clients

Se o Exchange Server Analyzer detectar que o valor de Disabled MAPI Clients está definido como um valor que começa com -10, -11 ou -12, ele exibirá um aviso.

Por padrão, a chave Disable MAPI Clients não está habilitada. Portanto, um administrador pode impedir que versões específicas do Microsoft Office Outlook® se conectem a um computador que esteja executando o Exchange 2000 Server, o Exchange Server 2003 ou o Exchange Server 2007.

Quando a chave Disabled MAPI Clients for definida de modo que o valor inicie com -10, -11 ou -12, os intervalos inteiros das versões MAPI serão bloqueados. Esses intervalos correspondem às versões do Outlook 2000, Outlook 2003 e Outlook 2007 e ao Atendedor do Sistema do Exchange no Exchange Server 2003. É provável que o bloqueio do serviço do Atendedor do Sistema do Exchange resulte no mau funcionamento do Exchange Server.

Para corrigir esse aviso, siga as recomendações e os procedimentos descritos em Todas as versões do Outlook têm permissão para acessar o servidor.

Para obter mais informações sobre como impedir que clientes MAPI específicos se conectem a um computador que esteja executando o Exchange 2000 Server ou o Exchange Server 2003, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 328240, "Como aplicar restrições de servidor a clientes usados para acessar as caixas de correio do Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • 288894, "Como desabilitar o acesso de cliente MAPI a um computador com o Exchange Server 2003 ou com o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894).

Para obter mais informações sobre como impedir que clientes MAPI específicos se conectem a um computador que esteja executando o Exchange Server 2007, consulte o cmdlet "Set-CasMailbox" do Shell de Gerenciamento do Exchange na documentação do produto do Exchange Server 2007 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80698).

Para obter mais informações sobre como fazer download de atualizações de segurança para versões mais antigas do Outlook e sobre como bloquear outras versões do Outlook, consulte Reduzindo e erradicando vírus de email em um ambiente do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=30732).


O valor de DisableSMTPMailboxAddressing está definido
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-08-11

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se está definido o valor para desabilitar o endereçamento de caixa de correio SMTP (Simple Mail Transfer Protocol):

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\DisableSMTPMailboxAddressing

O valor 1 na chave DisableSMTPMailboxAddressing indicates que o Endereçamento de Caixa de Correio SMTP está desabilitado (true) enquanto um valor 0 indica que esse endereçamento não está desabilitado (false).

Ao detectar que o valor da chave DisableSMTPMailboxAddressing está definido para desabilitar o endereçamento de caixa de correio SMTP com o valor 1, o Exchange Server Analyzer exibe um aviso.

Esse erro indica que o endereçamento de caixa de correio SMTP está desabilitado. Isso pode ocasionar erros de sincronização para clientes do Microsoft Exchange ActiveSync que se conectarem com este servidor.

Para corrigir esse aviso, defina o valor da chave DisableSMTPMailboxAddressing como 0.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para modificar o valor da chave DisableSMTPMailboxAddressing

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA

  1. No painel da direita, localize e clique duas vezes em DisableSMTPMailboxAddressing

  2. Altere o valor de 1 para 0.

  3. Feche o editor de Registro e reinicie o serviço do Servidor para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (em inglês).

Para obter mais informações sobre o erro de sincronização associado a este aviso, consulte o artigo 886346 da Base de Dados de Conhecimento Microsoft, "You receive an HTTP_500 error message when you synchronize your mobile device with Microsoft Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=886346) (em inglês).


Distribuição de carga do usuário
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer determinou que o servidor tem uma alta contagem de operações RPC por segundo.

Se o servidor tiver uma alta contagem de operações RPC por segundo, use o ExMon (Monitor de Usuários do Exchange Server) para identificar como a carga está distribuída. É importante descobrir se a carga é causada por uma das seguintes circunstâncias:

  • Há um número relativamente baixo de usuários ativos.

  • A carga está distribuída entre muitos usuários.

Se for identificado um único usuário como causador de uma alta porcentagem da carga, o Exchange Server Analyzer exibirá um aviso informando que a alta utilização pode estar associada a um único usuário. Se não for o caso, o Exchange Server Analyzer exibirá uma mensagem informando que a carga está distribuída entre muitos usuários.

Observação:
O tráfego de RPC muda com o passar do tempo. Portanto, para capturar dados relevantes em termos estatísticos sobre como os usuários utilizam o Exchange, talvez seja necessário coletar dados várias vezes.

Além disso, algumas operações comuns do usuário costumam utilizar muito a CPU por um curto período de tempo. Não se preocupe com essa atividade, a menos que o mesmo usuário esteja usando quantidades significativas de CPU de modo freqüente ou por longos períodos de tempo.

Observação:
Certamente, você pode desconsiderar este aviso se a fonte de alta carga for um serviço ou processo conhecido, previsto para ter uma carga alta, e que processa solicitações de muitos usuários e gera uma carga mais alta do que os usuários individualmente. Alguns serviços que sincronizam dispositivos móveis, processos de servidor que gerenciam disponibilidade, serviços relacionados a mensagem de voz ou unificação de mensagens, e processos de servidor que movem usuários são exemplos de serviços ou processos que podem ocasionar carga mais alta do que os usuários individuais.
Para corrigir esse problema

  • Se a taxa de RPC for alta (para um único usuário ou para todos), descubra se os usuários têm mecanismos de pesquisa de área de trabalho, plug-ins cliente de terceiros ou dispositivos móveis que sincronizam e-mail com a caixa de correio do usuário. Para obter mais informações sobre como solucionar problemas de aplicativos de terceiros, consulte Desativar suplementos de terceiros no cliente.

  • Os usuários devem ter menos de 5.000 itens nas pastas padrão e nas pastas muitos utilizadas.

  • Como prática recomendada, o tamanho das caixas de correio deve ser de 1 GB ou menos. Para os usuários que causam alta carga, é recomendável que eles arquivem seus itens de caixa de correio em um arquivo .pst. Depois disso, você poderá executar novamente a ferramenta de Desempenho do Exchange (Perfmon) para verificar se o usuário é um causador contínuo de alta carga.

  • Entre em contato com o usuário para identificar os aplicativos cliente que possam estar acessando o programa de e-mail cliente. Remova esses aplicativos e reinstale um de cada vez, observando o impacto no servidor.

  • Falsos positivos são comuns ao solucionar problemas de carga do usuário. Portanto, é recomendável que você execute novamente o ExMon durante um período de carga alta, para verificar se a análise é consistente.

Para obter mais informações

  • Para baixar o ExMon (Monitor de Usuários do Exchange Server), consulte a Centro de Download da Microsoft (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=54983).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre como solucionar problemas de desempenho do cliente Outlook, consulte o artigo 905803 da Base de Dados de Conhecimento Microsoft, "Usuários do Outlook experimentam um desempenho inadequado ao trabalharem com uma pasta que contém muitos itens em um servidor que executa o Exchange Server 2003 ou Exchange 2000 Server" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803).

  • Para obter mais informações sobre o software de pesquisa de área de trabalho, consulte o artigo 905184 da Base de Dados de Conhecimento da Microsoft, "Exchange 2000 Server and Exchange Server 2003 performance may be affected when desktop search engine software is running on Outlook or other MAPI client computers" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184).


O Diretório Virtual do Exchange para OMA e EAS foi substituído
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para detectar se o endereço do proxy SMTP para o Exchange ActiveSync® foi substituído:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\ExchangeVDir

Se o Exchange Server Analyzer detectar que a entrada do Registro ExchangeVDir está presente e configurada, uma mensagem de configuração não padrão será exibida.

A entrada do Registro ExchangeVDir é usada pelo Microsoft Outlook® Mobile Access e pelo Exchange ActiveSync. Essa entrada especifica o diretório virtual que o Outlook Mobile Access e o Exchange ActiveSync usarão para acessar os modelos do Microsoft Office Outlook Web Access para Exchange Server 2003 e o WebDAV nos servidores back-end do Exchange Server 2003, onde as caixas de correio do usuário estão localizadas.

Se a entrada ExchangeVDir não existir ou se não houver um valor definido para ela, será usado o valor padrão /Exchange. Caso contrário, ela conterá o nome do diretório virtual (inclusive o caractere barra "/"). É possível configurar esse valor para especificar um diretório virtual para o Outlook Mobile Access ou Exchange ActiveSync.

Há um problema conhecido no Exchange Server 2003, onde os serviços móveis do Exchange não funcionam ao usar a autenticação baseada em formulários em uma única topologia de computador do Exchange Server 2003. Quando o diretório virtual /Exchange em um servidor back-end do Exchange Server 2003 estiver configurado para exigir SSL (Secure Sockets Layer), ou quando a autenticação baseada em formulários estiver habilitada, o Outlook Mobile Access não poderá acessar esse diretório virtual. Esse problema não ocorre quando você habilita esses parâmetros no diretório virtual /Exchange em um servidor front-end.

Há uma oportunidade de configuração para resolver esse problema, que envolve a criação do valor do Registro ExchangeVDir.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. Examine e, se desejado, altere o valor de ExchangeVDir.

  4. Feche o editor de Registro. Se for feita uma alteração, reinicie o computador do Exchange Server para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como resolver esse problema, consulte o artigo 817317 da Base de Dados de Conhecimento Microsoft, "Não há suporte para o mapeamento de vários endereços Proxy para vários diretórios raiz virtuais back-end no mesmo servidor" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817317).


Um produto compatível com a API de Verificação de Vírus do Exchange foi detectado, mas ele não está habilitado no momento.
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o software compatível com VSAPI (Virus Scanning Application Programming Interface) está habilitado no computador com o Exchange Server:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

O Microsoft® Exchange Server Analyzer Tool também consulta a classe do WMI (Instrumentação de Gerenciamento do Microsoft® Windows) do CIM_Datafile para determinar o valor da chave Versão para Ese.dll, o Mecanismo de Armazenamento do Exchange, também conhecido por ESE (Mecanismo de Armazenamento Extensível).

Finalmente, o Exchange Server Analyzer consulta também o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para todos os objetos com classe de objeto de msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 5.5", o computador está executando o Microsoft Exchange Server 5.5. Se o valor da cadeia de caracteres incluir "Version 6.0", o computador está executando o Microsoft Exchange 2000 Server. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador está executando o Microsoft Exchange Server 2003.

Se o Exchange Analyzer verificar que o valor para Versão não contém uma subcadeia de caracteres de 6 como parte de suas informações de versão, mas que o valor de serialNumber indica que o Exchange 2000 Server ou o Exchange Server 2003 estão instalados, uma versão não-Exchange do ESE está sendo executada no Exchange Server.

Se o Exchange Server Analyzer verificar que uma versão do ESE que não é do Exchange não está sendo executada, e que o valor para a chave do Registro VirusScan \Habilitado é igual a 0, é exibido um aviso. Se o Exchange Server Analyzer determinar que uma versão do ESE que não é do Exchange está sendo executada no Exchange Server, é exibido um aviso separado.

Em geral, é recomendável implantar o software antivírus desenvolvido para os sistemas de mensagens, no gateway do SMTP (Simple Mail Transfer Protocol) ou nos computadores do Exchange Server que hospedam caixas de correio. Para obter o máximo de proteção, execute o software antivírus no gateway que verifica as mensagens MIME de entrada e um verificador de vírus no computador do Exchange Server, que usa o VSAPI 2.0 (Exchange 2000 Server) ou VSAPI 2.5 (Exchange Server 2003).

Além disso, você deve executar o software antivírus nos computadores clientes. Se você executar o software antivírus para sistemas de mensagens (significando que ele pode analisar e verificar MIME) no gateway ou no servidor Exchange, basta executar um verificador de vírus de nível de arquivo nos computadores clientes.

Para corrigir esse aviso

  1. Na interface de usuário do software antivírus, habilite a verificação VSAPI.

  2. Se o problema persistir depois de habilitação da verificação VSAPI, entre em contato com o fornecedor de seu software antivírus para obter assistência.

Para obter mais informações sobre os programas de verificação de vírus geralmente usados com o Microsoft Exchange Server 2003, consulte o artigo 823166 da Base de Dados de Conhecimento da Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Para obter mais informações sobre os programas de verificação de vírus geralmente usados com o Microsoft Exchange 2000 Server, consulte o artigo 328841 da Base de Dados de Conhecimento da Microsoft, "Exchange e o software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Para obter mais informações sobre como proteger o ambiente do Exchange contra vírus e worms transmitidos por email, consulte "Retardando e interceptando os vírus de email em um ambiente do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47587).


Um produto compatível com a API de verificação de vírus do Exchange foi detectado, mas ele não está instalado corretamente.
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se um software compatível com VSAPI (Virus Scanning Application Programming Interface) está sendo executado no computador e que ele tem uma biblioteca válida como referência:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Se o Exchange Server Analyzer verificar que o valor de Biblioteca não contém um caminho válido para um arquivo de biblioteca (DLL) antivírus VSAPI, será exibido um aviso.

Em geral, é recomendável implantar o software antivírus desenvolvido para os sistemas de mensagens, no gateway do SMTP (Simple Mail Transfer Protocol) ou nos computadores do Exchange Server que hospedam caixas de correio. Para obter o máximo de proteção, execute o software antivírus no gateway que verifica as mensagens MIME de entrada e um verificador de vírus no computador do Exchange Server, que usa o VSAPI 2.0 (Exchange 2000 Server) ou VSAPI 2.5 (Exchange Server 2003).

Além disso, você deve executar o software antivírus nos computadores clientes. Se você executar o software antivírus para sistemas de mensagens (significando que ele pode analisar e verificar MIME) no gateway ou no servidor Exchange, basta executar um verificador de vírus de nível de arquivo nos computadores clientes.

Para corrigir esse aviso

  1. Desinstale e reinstale o software antivírus.

  2. Se o problema persistir depois da reinstalação do software, entre em contato com o fornecedor do software antivírus para obter ajuda.

Para obter mais informações sobre os programas de verificação de vírus geralmente usados com o Microsoft Exchange Server 2003, consulte o artigo 823166 da Base de Dados de Conhecimento da Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Para obter mais informações sobre os programas de verificação de vírus geralmente usados com o Microsoft Exchange 2000 Server, consulte o artigo 328841 da Base de Dados de Conhecimento da Microsoft, "Exchange e o software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Para obter mais informações sobre como proteger o ambiente do Exchange contra vírus e worms transmitidos por email, consulte "Retardando e interceptando os vírus de email em um ambiente do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47587).


A API de Verificação de Vírus do Exchange tem baixa contagem de threads
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar o valor de ScanningThreads:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

O valor de Registro ScanningThreads representa o número máximo de threads VSAPI (API de Verificação de Vírus) alocados para verificação.

O Exchange Server Analyzer também lê a entrada de Registro a seguir para determinar se a verificação de mensagens do VSAPI está habilitada:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Um valor 1 para Habilitado indica que a verificação VSAPI está habilitada. Um valor 0 indica que a verificação VSAPI não está habilitada.

Além disso, o Exchange Server Analyzer também consulta a classe Win32_ComputerSystem do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor definido para a chave NumberOfProcessors. Esse valor representa o número de processadores instalados no computador, incluindo tanto processadores físicos quanto processadores lógicos. Usando a tecnologia Hyper-Threading da Intel, um processador físico pode ser dividido em dois processadores lógicos.

Se o Exchange Server Analyzer descobrir que o valor de ScanningThreads é menor que (2 × NumberOfProcessors) + 1 em um computador do Exchange Server que possui a verificação VSAPI habilitada, um aviso será exibido. O valor ideal de ScanningThreads é igual a (2 × NumberOfProcessors) + 1. Por exemplo, em um computador do Exchange Server com dois processadores, o valor ideal de ScanningThreads é 5.

Observação:
Se o Hyper-Threading estiver habilitado, o valor de NumberOfProcessors será o dobro do número de processadores físicos. É recomendável que você verifique com o fabricante de seu software de antivírus para determinar se processadores físicos ou lógicos devem ser usados na fórmula acima.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. No painel direito, clique duas vezes em ScanningThreads.

  4. Insira o valor retornado da fórmula acima.

  5. Feche o ADSI Edit e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a tecnologia Hyper-Threading, consulte o site da Intel (http://www.intel.com/technology/hyperthread).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


Servidor DNS externo é usado para SMTP
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchAuthenticationFlags na classe protocolCfgSMTPServer para o objeto do Exchange Server. A classe protocolCfgSMTPServer contém as configurações para um servidor virtual SMTP. Se o atributo msExchSMTPExternalDNSServers estiver definido, o servidor virtual SMTP usará um servidor DNS externo. Se o Exchange Server Analyzer determinar que o atributo msExchSMTPExternalDNSServers está definido, será exibido um aviso.

Se você configurar o servidor virtual SMTP para usar um servidor DNS externo, poderão ocorrer problemas de desempenho. Portanto, essa configuração não é recomendada.

Para alterar a configuração do DNS externo em um servidor virtual SMTP

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, <seu servidor Exchange de entrada>, Protocolos e SMTP.

  2. Clique com o botão direito no seu servidor virtual SMTP e clique em Propriedades.

  3. Clique na guia Entrega e clique em Avançado.

  4. Clique em Configurar para configurar servidores DNS externos.

  5. Para adicionar um servidor DNS externo, clique em Adicionar, digite o endereço IP do servidor DNS externo na caixa de diálogo Adicionar e clique em OK.

  6. Para remover um servidor DNS externo, selecione um endereço IP e clique em Remover.

  7. Clique em OK.

Para obter mais informações sobre como configurar o DNS em sua organização do Exchange Server 2003, consulte "Configurando o DNS" no Guia de Transporte e Roteamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579) (em inglês).

Para obter mais informações sobre como configurar conectores SMTP para vincular a domínios da Internet no Exchange, consulte o artigo 319426 da Base de Dados de Conhecimento Microsoft, "Como configurar o conector SMTP para vincular a domínios da Internet no Exchange" (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=319426) (página em inglês).


O servidor front-end está usando autenticação básica
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se a autenticação básica está configurada entre um servidor front-end e um servidor back-end:

HKEY_LOCAL_MACHINE\CurrentControlSet\Services\MSExchangeWeb\DAV\UseBasicAuthToBE

Se o Exchange Server Analyzer perceber que a chave UseBasicAuthToBE foi definida, será exibida uma mensagem de configuração não-padrão.

Por padrão, os servidores front-end do Exchange Server 2003 usarão a autenticação Kerberos para ajudar a proteger as credenciais do usuário entre os servidores front-end e back-end. Se a autenticação Kerberos falhar, um evento de Aviso será registrado em log e o servidor front-end tentará usar NTLM em seu lugar. Se NTLM falhar, um erro será registrado em log. Uma nova tentativa com o Kerberos é feita após 30 minutos. Quando os computadores front-end do Exchange 2000 Server ou Exchange Server 2003 fazem autenticação com computadores back-end do Exchange 2000 Server, a NTLM é usada.

Definir a chave do Registro UseBasicAuthToBE substitui esta lógica padrão e força os servidores front-end do Exchange a usar a autenticação básica para todas as comunicações com servidores back-end. Se você tiver mais de 1.000 armazenamentos de caixa de correio na organização do Exchange, deverá definir essa chave do Registro. Um problema conhecido existe, em que os usuários que acessam as caixas de correio do Microsoft Office Outlook® Web Access para Exchange Server 2003 por meio de servidores front-end em organizações com mais de 1.000 armazenamentos de caixa de correio não podem acessar suas caixas de correio.

Se você não tiver mais de 1.000 armazenamentos de caixa de correio e não tiver um motivo para forçar a autenticação básica, considere excluir a chave do Registro UseBasicAuthToBE.

Autenticação básica envia credenciais em texto não criptografado. Se você estiver executando um servidor front-end do Exchange com o conjunto de chaves do Registro UseBasicAuthToBE, será altamente recomendável usar a criptografia IPSec.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para excluir a chave do Registro UseBasicAuthToBE

  1. No servidor front-end do Exchange, abra um editor do Registro, como Regedit.exe ou Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Service\MSExchangeWeb\Dav\ UseBasicAuthToBE.

  3. Clique com o botão direito em UseBasicAuthToBE, clique em Excluir e em Sim.

  4. Abra o snap-in MMC de Serviços, clique com o botão direito em Serviço de Administração do IIS e clique em Reiniciar.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


PING de servidor gateway malsucedido
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_PingStatus do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave StatusCode retornada de um servidor de gateway. Win32_PingStatus retorna um objeto que tem 24 propriedades que fornecem detalhes completos sobre os pacotes de ping que a classe envia.

Se o Exchange Server Analyzer perceber que o valor para essa chave corresponde a um dos valores da tabela a seguir, ele exibirá um erro.

O Exchange Server Analyzer exibe o nome de servidor de gateway, o novo do Exchange Server e o valor do StatusCode correspondente que é retornado com esse erro.

Valor de StatusCode Significado Descrição

11001

Buffer Muito Pequeno

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11002

Rede de Destino Inacessível

A solicitação falhou porque a rede que contém o computador de destino está inacessível. Não existe uma rota válida para o computador de destino.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento Microsoft, "Como solucionar problemas de conectividade de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Host de Destino Inacessível

A solicitação falhou porque o computador de destino está inacessível.

Para obter informações, consulte o servidor do Active Directory Servidor do Active Directory desativado ou inacessível.

Esse erro também pode ser causado por uma das seguintes condições:

  • Um firewall entre o local onde o Exchange Server Analyzer está sendo executado e o controlador de domínio de destino.

  • Um erro de DNS.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Protocolo de Destino Inacessível

A solicitação falhou porque o computador de destino não responde ao protocolo de pacote.

Esse erro pode ser causado por um firewall entre o local onde o Exchange Server Analyzer está sendo executado e o controlador de domínio de destino.

11005

Porta de Destino Inacessível

A solicitação falhou porque a porta no computador de destino não está disponível.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Não Há Recursos

A solicitação falhou por causa de recursos de rede insuficientes.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Opção Inválida

A solicitação falhou porque contém uma opção inválida.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11008

Erro de Hardware

A solicitação falhou por causa de um erro de hardware.

Verifique se o controlador de domínio está em operação adequadamente, executando a ferramenta de verificação de integridade de hardware fornecida pelo fabricante do computador.

11009

Pacote Muito Grande

A solicitação falhou porque o pacote que contém a solicitação é maior do que a MTU (unidade máxima de transmissão) de um roteador ou nó de gateway localizado entre a origem e o destino. A MTU define o tamanho máximo de um pacote para transmissão.

A solicitação enviada pelo Exchange Server Analyzer não é maior do que 10 KB. Verifique se os roteadores e os gateways da sua organização estão configurados corretamente.

Para obter informações, consulte o artigo 159211 da Base de Dados de Conhecimento Microsoft, "Diagnósticos e tratamento de roteadores de buraco negro" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Tempo Limite da Solicitação Atingido

Não houve resposta no tempo alocado. O tempo padrão permitia respostas em 5 segundos.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Solicitação Incorreta

A solicitação falhou porque foi codificada incorretamente.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11012

Rota Inválida

A solicitação falhou porque não existe nenhuma rota válida entre os computadores de origem e de destino.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

Trânsito TimeToLive Expirado

A solicitação falhou porque o seu valor de TTL (vida útil) chegou a zero. Isso faz com que o nó do gateway ou roteador de encaminhamento descarte o pacote.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Reagrupamento TimeToLive Expirado

A solicitação falhou porque o pacote foi dividido em fragmentos para transmissão e nem todos os fragmentos foram recebidos no tempo alocado para o reagrupamento. O RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) especifica 60 segundos como o limite de tempo no qual todos os fragmentos do pacote devem ser recebidos.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Problema de Parâmetro

A solicitação falhou porque um nó do gateway ou roteador encontrou problemas ao processar o cabeçalho do pacote. Isso pode ocorrer se o cabeçalho contiver dados de campo inválidos ou uma opção não reconhecida.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11016

Retardamento de Origem

A solicitação falhou porque o pacote foi descartado. Isso ocorre quando a fila de saída do computador de origem não possui espaço de armazenamento insuficiente. Também pode ocorrer quando os pacotes chegam ao destino muito rapidamente para serem processados.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11017

Opção Grande Demais

A solicitação falhou porque contém uma opção inválida.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11018

Destino Inválido

A solicitação falhou por causa de uma das seguintes razões:

  • O endereço IP de destino não pode receber solicitações PING.

  • O endereço IP de destino nunca deve aparecer no campo de endereço de destino de nenhum datagrama IP.

Isso pode ser causado por um firewall entre o local onde o Exchange Server Analyzer está sendo executado e o controlador de domínio de destino.

11032

Negociando IPSEC

Falha na solicitação porque uma conexão IPsec não pôde ser negociada.

11050

Falha Geral

A solicitação falhou por razão desconhecida.

Para obter informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Parâmetro MaxFieldLength do IIS 6.0 não definido corretamente
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a entrada de Registro a seguir para determinar se o comprimento de campo máximo para as solicitações HTTP foi codificado no Registro.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxFieldLength

O Exchange Server Analyzer também examina a seguinte entrada do Registro para determinar qual versão do sistema operacional do Microsoft Windows® está sendo executada no computador de destino.

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor CurrentVersion 4.0 indica que o computador está executando o Microsoft Windows NT® Server 4.0. Um valor 5.0 indica que o computador está executando um sistema operacional Microsoft Windows 2000 Server e um valor 5.2 indica que o computador está executando um sistema operacional Microsoft Windows Server™ 2003.

Finalmente, o Analisador do Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Windows) Exchange_Server no namespace root\MicrosoftExchangeV2 para determinar o valor da chave IsFrontEndServer. Um valor Falso indica que o computador do Exchange Server não é um servidor front-end. Um valor Verdadeiro indica que o computador do Exchange Server é um servidor front-end.

O Analisador do Exchange Server exibe um aviso se detectar que o valor para MaxFieldLength não está definido como 32.768 em um servidor back-end do Exchange no qual as seguintes condições são verdadeiras:

  • O servidor back-end Exchange está executando o Windows Server 2003.

  • O servidor back-end Exchange não está configurado como um servidor front-end.

  • O servidor Exchange back-end tem mais de 500 caixas de correio.

O parâmetro de Registro do IIS MaxFieldLength, que não está presente por padrão, especifica o tamanho máximo de uma solicitação de cliente HTTP individual. Esse valor é normalmente definido junto com um valor de acompanhamento, MaxRequestBytes. Em ambientes maiores, se esses valores não forem definidos como 32768, usuários do Microsoft Office Outlook® Web Access para Exchange Server poderão enfrentar falhas de logon. Especificamente, a ausência desses valores pode causar erros HTTP 400 - Solicitação Inválida. Ao configurar o valor de Registro MaxFieldLength, você deverá definir também o parâmetro MaxRequestBytes como 32.768 para habilitar os usuários que são membros de mais de 75 grupos para fazerem logon no Outlook Web Access. O valor de Registro MaxRequestBytes determina o limite superior para o tamanho total da linha Solicitação e os cabeçalhos. Se seu valor for menor que MaxFieldLength, o valor MaxFieldLength será ajustado.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir os parâmetros MaxRequestBytes e MaxFieldLength

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. Clique com o botão direito em Parâmetros, clique em Novo | valor DWORD e nomeie o valor MaxFieldLength.

  4. Clique com o botão direito em Parâmetros, clique em Novo | valor DWORD e nomeie o valor MaxFieldLength.

  5. No painel direito, clique duas vezes em MaxFieldLength e defina seu valor como 32.768 (decimal).

  6. No painel direito, clique duas vezes em MaxRequestBytes e defina seu valor como 32.768 (decimal).

  7. Feche o editor de Registro e reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre as configurações de Registro HTTP para o IIS, consulte o artigo 820129 da Base de Dados de Conhecimento, INF: Configurações de Registro Http.sys para IIS" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129).


Parâmetro MaxRequestBytes do IIS 6.0 não definido corretamente
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2007-01-05

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar se o tamanho máximo para as solicitações HTTP foram codificadas no Registro:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxRequestBytes

O Exchange Server Analyzer também examina a seguinte entrada do Registro para determinar qual versão do sistema operacional Microsoft Windows® está sendo executada no computador de destino:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Um valor CurrentVersion 4.0 indica que o computador está executando o Microsoft Windows NT® Server 4.0. Um valor 5.0 indica que o computador está executando um sistema operacional Microsoft Windows 2000 Server e um valor 5.2 indica que o computador está executando um sistema operacional Microsoft Windows Server™ 2003.

Finalmente, o Exchange Server Analyzer examina a classe WMI (Instrumentação de Gerenciamento do Windows) Exchange_Server no namespace root\MicrosoftExchangeV2 para determinar o valor da chave IsFrontEndServer. Um valor Falso indica que o computador do Exchange Server não é um servidor front-end. Um valor Verdadeiro indica que o computador do Exchange Server é um servidor front-end.

O Exchange Server Analyzer exibirá um aviso se detectar que o valor de MaxRequestBytes está configurado como 32768 em um servidor back-end do Exchange, no qual as seguintes condições são verdadeiras:

  • O servidor back-end Exchange está executando o Windows Server 2003.

  • O servidor back-end Exchange não está configurado como um servidor front-end.

  • O servidor back-end Exchange tem mais de 500 caixas de correio.

O valor do Registro MaxRequestBytes, que não está presente por padrão, determina o limite superior para o tamanho total da linha Solicitação e os cabeçalhos. Esse valor é normalmente definido junto com um valor de acompanhamento, MaxFieldLength. O parâmetro do Registro do MaxFieldLength IIS especifica o tamanho máximo de qualquer solicitação HTTP individual. Em ambientes maiores, se esses valores não forem definidos como 32768, usuários do Microsoft Office Outlook® Web Access para Exchange Server poderão enfrentar falhas de logon. Especificamente, a ausência desses valores pode causar erros HTTP 400 - Solicitação Inválida. Ao configurar o valor do Registro MaxFieldLength, você deve também configurar o parâmetro MaxRequestBytes como 32768 para permitir que os usuários que são membros de mais de 75 grupos efetuem logon no Outlook Web Access. Se esse valor for inferior ao MaxFieldLength, o valor de MaxFieldLength será ajustado.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir os parâmetros MaxRequestBytes e MaxFieldLength

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. Clique com o botão direito em Parâmetros, selecione Novo | Valor de DWORD e nomeie o valor MaxFieldLength.

  4. Clique com o botão direito em Parâmetros, selecione Novo | Valor de DWORD e nomeie o valor MaxRequestBytes.

  5. No painel direito, clique duas vezes em MaxFieldLength e defina o valor como 32.768 (decimal).

  6. No painel direito, clique duas vezes em MaxRequestBytes e defina o valor como 32.768 (decimal).

  7. Feche o editor de Registro e reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre as configurações do Registro HTTP para o Internet Information Services (IIS), consulte o artigo 820129 da Base de Dados de Conhecimento, "INF: Configurações de Registro Http.sys para IIS" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129).


O sinalizador de Compatibilidade do IMAP4 foi definido no Registro
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o seguinte valor de Registro existe:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\Compatibility

Se o Exchange Server Analyzer encontrar o valor Compatibility presente e configurado com o valor 0xfffffffe (em hexadecimais), uma mensagem de configuração não padrão é exibida.

Os computadores cliente com IP do Exchange Server que usam IMAP4 e POP3, usam totalmente o arquivo de armazenamento de streaming (.stm) para ler e gravar dados. Quando um cliente IP solicita um download de mensagens com POP3 ou IMAP4, o armazenamento de informações do Exchange que contém a caixa de correio do usuário irá calcular o tamanho exato das mensagens da caixa de correio a serem enviadas ao cliente, antes de transmiti-las. Em ambientes grandes, especialmente em ambientes hospedados do Exchange, esse cálculo pode ser muito demorado. O valor Compatibility representa uma oportunidade de configuração para que administradores instruam o armazenamento do Exchange a usar um tamanho de mensagem aproximado, em vez de cálculos exatos de tamanhos de mensagem.

O valor do Registro Compatibility está disponível para o serviço IMAP4 do Exchange, como descrito neste artigo, e para o serviço POP3 do Exchange, como descrito em O sinalizador de Compatibilidade do POP3 foi definido no Registro..

O valor do Registro Compatibility também é útil durante a movimentação de várias caixas de correio ou de caixas de correio com muitas mensagens MIME. Ao mover dados, eles são promovidos do armazenamento de streaming para o armazenamento MAPI (arquivo .edb). Os clientes que usam POP3 e IMAP4 para acessar suas caixas de correio, podem ter problemas de desempenho depois que você mover suas caixas de correio entre bancos de dados ou servidores. Após o usuário fazer logon, os tamanhos de mensagem devem ser calculados e a conversão de MAPI em MIME ocorre na memória e no disco do servidor. Em casos extremos, arquivos temporários muito grandes podem ser criados no computador do Exchange Server quando ocorrer esse comportamento.

Talvez nem todos os clientes de email POP3 e IMAP4 funcionem corretamente com o valor de Registro Compatibility definido. Mudar essa configuração faz com que clientes de email mais antigos, como o Fetchmail, sejam interrompidos. Definir essa chave do Registro também interrompe a compatibilidade RFC para o protocolo IMAP4. Se estiver tendo problemas para fazer download de mensagens com POP3 e IMAP4 e estiver usando o valor do Registro Compatibility, você pode exclui-lo, usando o procedimento a seguir como uma etapa de resolução para os problemas de download de mensagens.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para excluir o valor de Registro Compatibility

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Exclua o valor chamado Compatibility.

  4. Saia do editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange e o serviço de Administração do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o uso do valor de Registro Compatibility, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 317722, "XADM: Client Latencies Occur When Exchange 2000 Converts Mail from MAPI to MIME Format" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722)

  • 329067, "XADM: Move Mailbox Functionality Promotes Contents of .stm Files" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067)


O valor de MaxBufferSize do IMAP4 foi alterado
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2007-08-07

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o seguinte valor de Registro existe:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Se o Exchange Server Analyzer encontrar o valor MaxBufferSize presente e configurado com um valor numérico maior que 0, uma mensagem de configuração não padrão será exibida.

O valor de Registro MaxBufferSize é usado em uma topologia front-end/back-end do Exchange. Ele define o tamanho do buffer do TCP/IP entre servidores front-end e back-end. O tamanho padrão do buffer é 1 quilobyte (KB). Em redes com alta latência, ajustar o valor MaxBufferSize pode melhorar o desempenho para clientes IMAP4.

Ao definir o tamanho de buffer de TCP/IP com o valor de Registro MaxBufferSize, você deve sempre definir o tamanho do buffer em múltiplos de 1.024. É recomendável testar o desempenho da configuração de seu servidor front-end/back-end com os seguintes tamanhos de buffer para determinar o melhor valor para sua organização:

  • 8,192 bytes

  • 16,384 bytes

  • 32.768 bytes

É recomendável que a entrada de Registro MaxBufferSize não seja configurada com um valor maior que 32.768. No entanto, você poderá observar um aumento de desempenho se usar um tamanho de buffer de 65.536, dependendo das condições da rede. Um tamanho de buffer maior usa mais memória no computador do Exchange Server e pode diminuir o número de usuários que podem acessar o servidor front-end. Enquanto não houver nenhum limite para o valor máximo que você possa usar para o valor de Registro MaxBufferSize, talvez você experimente desempenho instável e problemas de memória se atribuir um valor muito alto para essa entrada de Registro.

Observação:
Para usar o valor de Registro MaxBufferSize, você deve estar executando o Exchange 2000 Server Service Pack 2 ou posterior.

Se o valor de Registro MaxBufferSize for muito baixo, o desempenho não será melhorado e o Exchange Server Analyzer exibirá uma mensagem de erro, conforme descrito em O valor de MaxBufferSize do IMAP4 é muito baixo. Se o valor de Registro MaxBufferSize for muito alto, poderá ocorrer instabilidade no sistema e o Exchange Server Analyzer exibirá uma mensagem de erro, conforme descrito em O valor de MaxBufferSize do IMAP4 é muito alto.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar o valor de MaxBufferSize

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Criar um novo valor de DWORD chamado MaxBufferSize.

  4. Clique duas vezes no valor MaxBufferSize e defina-o como novo tamanho de buffer (em bytes). Por exemplo, você pode inserir 8192 para defini-lo como 8.192 bytes.

  5. Feche o editor do Registro e reinicie o serviço de IMAP4 do Microsoft Exchange para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre quando e como usar o valor do Registro MaxBufferSize, consulte o artigo 823857 da Base de Dados de Conhecimento, "XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


O valor de MaxBufferSize do IMAP4 é muito alto
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2007-08-07

A ferramenta Analisador do Microsoft® Exchange Server lê o Registro no computador do Exchange Server para determinar se o seguinte valor do Registro existe:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Se o Analisador do Exchange Server detectar o valor MaxBufferSize presente e configurado com um valor numérico maior que 32.768, será exibido um erro.

O valor de Registro MaxBufferSize é usado em uma topologia front-end/back-end do Exchange. Ele define o tamanho do buffer do TCP/IP entre servidores front-end e back-end. O tamanho padrão do buffer é 1 quilobyte (KB). Em redes com alta latência, ajustar o valor MaxBufferSize pode melhorar o desempenho para clientes IMAP4.

Ao configurar o tamanho do buffer do TCP/IP com o valor de Registro MaxBufferSize, você deve sempre definir o tamanho do buffer como múltiplos de 1.024. É recomendável que você teste o desempenho da configuração de seu servidor front-end/back-end com os seguintes tamanhos de buffer:

  • 8,192 bytes

  • 16,384 bytes

  • 32.768 bytes

Ao usar essa entrada de Registro, ela deve ser definida como, pelo menos, 1.024. É recomendável que você não defina a entrada de Registro MaxBufferSize com um valor maior do que 32.768. No entanto, talvez você perceba um melhor desempenho com um tamanho de buffer de 65536, dependendo de suas condições de rede. Um tamanho de buffer maior usa mais memória no computador do Exchange Server e pode diminuir o número de usuários que podem acessar o servidor front-end. Enquanto não houver nenhum limite para o valor máximo que você possa usar para o valor de Registro MaxBufferSize, talvez você experimente desempenho instável e problemas de memória se atribuir um valor muito alto para essa entrada de Registro.

Observação:
Para usar o valor de Registro MaxBufferSize, você deve estar executando o Exchange 2000 Server Service Pack 2 ou posterior.

Se o valor do Registro MaxBufferSize estiver definido muito baixo, o desempenho não irá melhorar e o Analisador do Exchange Server exibirá uma mensagem de erro, conforme descrito em O valor de MaxBufferSize do IMAP4 é muito baixo. Se o valor de Registro MaxBufferSize estiver definido muito alto, isso poderá resultar em instabilidade do sistema e o Exchange Server Analyzer exibirá uma mensagem, conforme descrito nesse artigo.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Criar um novo valor de DWORD chamado MaxBufferSize.

  4. Clique duas vezes no valor MaxBufferSize e defina-o como novo tamanho de buffer (em bytes). Por exemplo, você pode inserir 8192 para defini-lo como 8.192 bytes.

  5. Feche o editor do Registro e reinicie o serviço de IMAP4 do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre quando e como usar o valor do Registro MaxBufferSize, consulte o artigo 823857 da Base de Dados de Conhecimento, "XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


O valor de MaxBufferSize do IMAP4 é muito baixo
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2007-08-07

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o seguinte valor de Registro existe:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Se o Exchange Server Analyzer encontrar o valor MaxBufferSize presente e configurado com um valor numérico maior que 0 mas menor que 1024, será exibido um erro.

O valor de Registro MaxBufferSize é usado em uma topologia front-end/back-end do Exchange. Ele define o tamanho do buffer do TCP/IP entre servidores front-end e back-end. O tamanho padrão do buffer é 1 quilobyte (KB). Em redes com alta latência, ajustar o valor MaxBufferSize pode melhorar o desempenho para clientes IMAP4.

Ao definir o tamanho de buffer de TCP/IP com o valor de Registro MaxBufferSize, você deve sempre definir o tamanho do buffer em múltiplos de 1.024. É recomendável testar o desempenho da configuração de seu servidor front-end/back-end com os seguintes tamanhos de buffer para determinar o melhor valor para sua organização:

  • 8,192 bytes

  • 16,384 bytes

  • 32.768 bytes

Ao usar essa entrada de Registro, ela deve ser definida como, pelo menos, 1.024. É recomendável que você não defina a entrada de Registro MaxBufferSize com um valor maior do que 32.768. No entanto, talvez você perceba um melhor desempenho com um tamanho de buffer de 65.536, dependendo de suas condições de rede. Um tamanho de buffer maior usa mais memória no computador do Exchange Server e pode diminuir o número de usuários que podem acessar o servidor front-end. Enquanto não houver nenhum limite para o valor máximo que você possa usar para o valor de Registro MaxBufferSize, talvez você experimente desempenho instável e problemas de memória se atribuir um valor muito alto para essa entrada de Registro.

Observação:
Para usar o valor de Registro MaxBufferSize, você deve estar executando o Exchange 2000 Server Service Pack 2 ou posterior.

Se o valor do Registro MaxBufferSize definido for baixo demais, o desempenho não melhorará e o Exchange Server Analyzer exibirá uma mensagem de erro, como descrito neste artigo. Se o valor do Registro MaxBufferSize estiver definido muito alto, isso poderá resultar em instabilidade do sistema e o Analisador do Exchange Server exibirá uma mensagem, conforme descrito em O valor de MaxBufferSize do IMAP4 é muito alto.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Criar um novo valor de DWORD chamado MaxBufferSize.

  4. Clique duas vezes no valor MaxBufferSize e defina-o como novo tamanho de buffer (em bytes). Por exemplo, você pode inserir 8192 para defini-lo como 8.192 bytes.

  5. Feche o editor do Registro e reinicie o serviço de IMAP4 do Microsoft Exchange para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre quando e como usar o valor do Registro MaxBufferSize, consulte o artigo 823857 da Base de Dados de Conhecimento, "XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Falhas da operação MAPI
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server determinou que o servidor tem muitas falhas de MAPI relatadas. Algumas operações MAPI estão previstas para retornarem erros ocasionais. Entretanto, às vezes um aplicativo cliente pode não responder ao erro corretamente. Como resultado, o aplicativo pode emitir novamente a solicitação RPC que causou o erro, aumentando a carga no servidor.

Um exemplo de erro de cliente freqüente é quando um cliente MAPI solicita uma lista de itens em lotes e continua a solicitar os itens depois que a solicitação foi retornada pelo Exchange. Por exemplo, um computador cliente pode solicitar todos os itens de uma determinada pasta que contém um anexo. O cliente pode solicitar que os itens sejam retornados em lotes de 30 itens cada. Em alguns casos, depois que o servidor Exchange tiver retornado o último item da solicitação, o cliente continuará a solicitar um novo lote de 30 itens. Nesses casos, o Exchange retorna um erro "Não Encontrado". Se o computador cliente continuar a solicitar itens mesmo depois que o erro "Não Encontrado" for retornado, ele não está respondendo ao erro corretamente. Nessa situação, o ExMon relatará várias falhas MAPI. Nesse caso, embora a taxa de falhas para o número de operações seja alta, a taxa de falha alta é esperada. As operações MAPI com altas taxas de falha incluem, GetPerUserGuid, ImportMsgMove e Logon.

Para corrigir esse erro

  1. Use ExMon para determinar qual usuário ou grupo de usuários está causando o alto número de falhas MAPI.

  2. Determine qual aplicativo no computador cliente está causando esse problema.

  3. Corrija ou remova o aplicativo que está causando o problema.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).


MaxClientRequestBuffer está definido com um valor não padrão
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte chave do Registro para determinar se a chave está presente:

HKEY_LOCAL_MACHINE System\CurrentControlSet\w3svc\Parameters\MaxClientRequestBuffer

Se o Exchange Server Analyzer perceber que a chave MaxClientRequestBuffer foi definida, o Exchange Server Analyzer exibirá uma mensagem não padrão.

Por padrão, esse valor do Registro não existe.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre a chave do Registro MaxClientRequestBuffer, consulte o artigo 260694 da Base de Dados de Conhecimento Microsoft, "Descrição do valor de Registro MaxClientRequestBuffer" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260694).


MaxClientRequestBuffer foi definido muito baixo
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte chave de Registro para determinar os dados do valor MaxClientRequestBuffer:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

Se o Exchange Server Analyzer verificar que os dados do valor MaxClientRequestBuffer são menores do que 16.384, será exibido um aviso.

Se o valor de MaxClientRequestBuffer for baixo demais, podem ocorrer erros para os usuários do Microsoft Office Outlook® Web Access. Especificamente, isso pode fazer com que HTTP 400 - Bad Request seja retornado ao navegador. Para corrigir esse aviso, recomendamos que você aumente o valor para um número maior do que 16.384 ou remova o valor do Registro para reverter para as configurações padrão. O valor MaxClientRequestBuffers não está presente por padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso, aumentando o valor dos dados do valor

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. Clique duas vezes no valor MaxClientRequestBuffer e edite os dados do valor. Defina os dados do valor como um número decimal igual ou maior que 16.384.

  4. Feche o editor de Registro e reinicie o servidor Exchange.
Para corrigir esse aviso, removendo o valor

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. Clique com o botão direito no valor de MaxClientRequestBuffer e clique em Excluir.

  4. Feche o editor de Registro e reinicie o servidor Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro MaxClientRequestBuffer, consulte o artigo 260694 da Base de Dados de Conhecimento Microsoft, "Descrição do valor do Registro MaxClientRequestBuffer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260694).


Várias ligações de porta SMTP configuradas
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o valor do atributomsExchServerBindings foi configurado com várias ligações de porta. Por padrão, o atributo msExchServerBindings é configurado para a porta TCP 25. Se o Exchange Server Analyzer detectar que o atributo msExchServerBindings foi configurado com várias ligações de porta, ele exibirá uma mensagem de configuração não padrão.

O atributo msExchServerBindings representa a porta TCP na qual o servidor SMTP atende às conexões de entrada. É possível configurar servidores virtuais SMTP para atender em uma ou mais portas TCP. Por padrão, todos os servidores virtuais SMTP são configurados para atenderem na porta TCP 25. Você poderá alterar a porta de escuta SMTP se modificar o restante de sua infra-estrutura de mensagens internas da forma apropriada. Entretanto, em servidores virtuais SMTP que aceitam mensagens diretamente da Internet, você geralmente usará a porta 25, visto que os servidores SMTP da Internet enviam as mensagens pela porta 25.

Observe que o Exchange Server Analyzer examina o valor do servidor virtual do protocolo SMTP do Exchange. Esse pode ou não ser o servidor SMTP que recebe mensagens diretamente da Internet. Alguns produtos antivírus e anti-spam foram projetados para receber mensagens SMTP da Internet na porta 25 e redirecioná-las para um servidor virtual SMTP do Exchange em outra porta.

Para exibir ou modificar a porta de escuta do servidor virtual SMTP

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  2. Clique com o botão direito em um servidor virtual SMTP, por exemplo, Servidor Virtual SMTP Padrão, e clique em Propriedades.

  3. Selecione a guia Geral e clique em Avançado.

  4. Uma lista de portas e endereços IP é exibida.

    • Para alterar a porta existente, selecione o endereço IP e clique em Editar.

    • Para remover uma porta existente, selecione o endereço IP e clique em Remover.

  5. Para salvar suas alterações, clique em OK e em OK novamente para sair da caixa de diálogo Avançado.

  6. Clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


A resposta PING tem um tamanho diferente
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_PingStatus do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) usando valores específicos da configuração BufferSize e os compara com os valores de BufferSize retornados para determinar se são os mesmos.

Se o valor de BufferSize retornado for diferente do enviado, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que o pacote foi truncado em algum ponto em trânsito. Isso pode indicar uma falha geral da rede ou a presença de um roteador de buraco negro no ambiente.

Em uma WAN (rede remota) TCP/IP, a comunicação através de algumas rotas poderá falhar se os segmentos intermediários da rede tiverem tamanhos de pacotes menores do que os hosts em comunicação e se os roteadores não enviarem respostas ICMP corretas para essa condição. Como alternativa, o firewall no caminho pode abandonar essas respostas. Um roteador que causa essa condição talvez seja conhecido como um roteador de buraco negro.

A presença de um roteador de buraco negro pode causar vários erros que não ocorrerão se um programa se conectar a um computador em uma sub-rede local. O comportamento pode parecer intermitente, mas quando você examinar as circunstâncias mais detalhadamente, poderá descobrir que o comportamento pode ser reproduzido, por exemplo, instruindo um cliente a ler um arquivo grande enviado de um host remoto.

Para obter mais informações, siga as orientações do artigo 314825 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de roteador de buraco negro " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825).

Para obter mais informações

Para obter mais informações sobre como detectar e tratar possíveis roteadores de buraco negro, consulte os seguintes recursos:

  • Artigo 159211 da Base de Dados de Conhecimento da Microsoft, "Diagnósticos e tratamento de roteadores de buraco negro " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

  • "Roteadores de buraco negro da PMTU (Unidade de Transmissão Máxima do Caminho)" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=66963).


Teste de ping não executado
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-08-09

A ferramenta Microsoft® Exchange Server Analyzer tenta consultar a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®), Win32_PingStatus, para analisar o objeto resposta de vários parâmetros de configuração específicos do fluxo de mensagens.

Geralmente a classe Win32_PingStatus retorna um objeto com 24 propriedades que fornecem detalhes completos sobre os pacotes de ping enviados pela classe.

Se o Exchange Server Analyzer não receber o objeto esperado em resposta à sua consulta depois de seis tentativas consecutivas, ele exibirá um aviso.

Este aviso indica que não foi possível executar o Win32_PingStatus.

A causa mais provável dessa falha é que o computador que tenta executar o comando Win32_PingStatus está em execução no sistema operacional Microsoft Windows® 2000 Server. O Windows 2000 Server não oferece suporte para a classe WMI, Win32_PingStatus.

Se o computador que tenta executar o comando Win32_PingStatus não estiver em execução no sistema operacional Windows 2000 Server, a falha pode estar associada a problemas gerais de rede ou a um problema de permissões.

Para corrigir esse erro

  1. Verifique se o computador do Exchange Server foi iniciado e está conectado à rede.

  2. Use o comando PING no computador executando o Exchange Server Analyzer para detectar se o computador do Exchange Server de destino está alcançável.

  3. Use o comando PING a partir de um servidor pertencente à mesma sub-rede com o servidor Exchange de destino, para detectar se o computador Exchange Server de destino está alcançável.

  4. Se houver um firewall, verifique se as portas de RPC (chamada de procedimento remoto) estão bloqueadas.

  5. Examine as permissões da conta na qual o Exchange Server Analyzer está sendo executado. A conta na qual o Exchange Server Analyzer está sendo executado deve ter permissões de Administrador local em cada servidor Exchange que ele verifica.

Para obter mais informações sobre problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento Microsoft , "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487) (em inglês).

Para obter mais informações sobre como os problemas de conectividade da ferramenta Exchange Best Practices Analyzer, consulte "Solucionando problemas de conectividade da ferramenta Microsoft Exchange Best Practices Analyzer" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56285).

Para obter mais informações sobre a classe WMI, Win32_PingStatus, consulte o artigo do MSDN® "Win32_PingStatus" (http://go.microsoft.com/fwlink/?linkid=33549) (em inglês).


A verificação antivírus de texto simples foi desabilitada
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar o valor da verificação antivírus da mensagem em formato RTF (Rich Text Format):

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Se o Exchange Server Analyzer encontrar o valor ScanPlainText definido como 0, será exibido um erro.

A chave de Registro ScanPlainText é definida por fornecedores de antivírus de terceiros que usam o VSAPI (API de Verificação de Vírus) do Exchange. Recomendamos que você verifique todas as mensagens em busca de vírus, inclusive mensagens de texto sem formatação. Você deve habilitar a verificação de vírus de todas as mensagens que fluem por um computador do Exchange Server.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  • No seu aplicativo antivírus sensível ao Exchange, habilite a verificação de todas as mensagens.

    -ou-

  • Modifique manualmente a entrada do Registro, executando o seguinte procedimento:

    1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

    2. Navegue para:

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    3. Clique duas vezes na entrada do Registro ScanPlainText e defina o Dados do Valor como 1.

    4. Saia do editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange e os serviços que representam o software antivírus sensível ao Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o combate a vírus, consulte o site "Retardando e parando vírus transmitidos por email em um ambiente do Exchange 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47587).


O sinalizador de Compatibilidade do POP3 foi definido no Registro.
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o seguinte valor de Registro existe:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\Compatibility

Se o Exchange Server Analyzer encontrar o valor Compatibility presente e configurado com o valor 0xfffffffe (em hexadecimais), uma mensagem de configuração não padrão é exibida.

Os computadores cliente com IP do Exchange Server que usam IMAP4 e POP3, usam totalmente o arquivo de armazenamento de streaming (.stm) para ler e gravar dados. Quando um cliente IP solicita um download de mensagens usando POP3 ou IMAP4, o armazenamento do Exchange que contém a caixa de correio do usuário calculará o tamanho exato das mensagens na Caixa de Entrada para enviar para o cliente antes de transmitir as mensagens. Em grandes ambientes, especialmente ambientes do Exchange hospedado, esse cálculo pode demorar um período de tempo considerável. O valor Compatibility representa uma oportunidade de configuração para que administradores instruam o armazenamento do Exchange a usar um tamanho de mensagem aproximado, em vez de cálculos exatos de tamanhos de mensagem.

O valor de Registro Compatibilidade está disponível para o serviço Exchange POP3, como descrito neste artigo, e para o serviço Exchange IMAP4, como descrito em O sinalizador de Compatibilidade do IMAP4 foi definido no Registro.

O valor de Registro Compatibilidade também é útil durante a movimentação de um grande número de caixas de correio, ou caixas de correio com um grande número de mensagens MIME (Multipurpose Internet Mail Extensions). Ao mover dados, eles são promovidos do armazenamento de streaming para o armazenamento MAPI (arquivo .edb). Os clientes que usam POP3 e IMAP4 para acessar suas caixas de correio, podem ter problemas de desempenho depois que você mover suas caixas de correio entre bancos de dados ou servidores. Após o usuário fazer logon, os tamanhos de mensagem devem ser calculados e a conversão de MAPI em MIME ocorre na memória e no disco do servidor. Em casos extremos, arquivos temporários muito grandes podem ser criados no computador do Exchange Server quando ocorrer esse comportamento.

Talvez nem todos os clientes de email POP3 e IMAP4 funcionem corretamente com o valor de Registro Compatibility definido. Alterar essa configuração faz com que alguns clientes de email antigos (como Fetchmail) sejam interrompidos. A definição dessa chave de Registro também interrompe a compatibilidade com RFC do protocolo POP3. Se você estiver enfrentando problemas para fazer download de mensagens com POP3 e IMAP4 e você estiver usando o valor de Registro Compatibilidade, você pode excluí-lo usando o procedimento abaixo como uma etapa da solução de problemas de download de mensagens.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para excluir o valor de Registro Compatibility

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Exclua o valor chamado Compatibility.

  4. Saia do editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange e o serviço de Administração do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o uso do valor de Registro Compatibility, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 317722, "XADM: Client Latencies Occur When Exchange 2000 Converts Mail from MAPI to MIME Format" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722)

  • 329067, "XADM: Move Mailbox Functionality Promotes Contents of .stm Files" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067)


O valor de MaxBufferSize do POP3 foi alterado
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o seguinte valor de Registro existe:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Se o Exchange Server Analyzer detectar que o valor MaxBufferSize existe e está configurado com qualquer valor numérico maior que 0, será exibida uma mensagem de configuração diferente do padrão.

O valor de Registro MaxBufferSize é usado em uma topologia front-end/back-end do Exchange. Ele define o tamanho do buffer do TCP/IP entre servidores front-end e back-end. O tamanho padrão do buffer é 1 quilobyte (KB). Em redes com altas latências, ajustar o valor MaxBufferSize pode melhorar o desempenho de clientes POP3.

Ao configurar o tamanho do buffer do TCP/IP com o valor de Registro MaxBufferSize, você deve sempre definir o tamanho do buffer como múltiplos de 1.024. É recomendável que você teste o desempenho da configuração de seu servidor front-end/back-end com os seguintes tamanhos de buffer:

  • 8,192 bytes

  • 16,384 bytes

  • 32.768 bytes

Quando você usa essa entrada de Registro, ela deve ser definida como, pelo menos, 1.024. É recomendável que você não defina a entrada de Registro MaxBufferSize com um valor maior do que 32.768. No entanto, talvez você perceba um melhor desempenho com um tamanho de buffer de 65.536, dependendo de suas condições de rede. Um tamanho de buffer maior usa mais memória no computador do Exchange Server e pode diminuir o número de usuários que podem acessar o servidor front-end. Enquanto não houver nenhum limite para o valor máximo que você possa usar para o valor de Registro MaxBufferSize, talvez você experimente desempenho instável e problemas de memória se atribuir um valor muito alto para essa entrada de Registro.

Observação:
Para usar o valor de Registro MaxBufferSize, você deve executar o Exchange 2000 Server Service Pack 2 ou uma versão posterior.

Se o valor de Registro MaxBufferSize estiver definido muito baixo, o desempenho não irá melhorar e o Exchange Server Analyzer exibirá uma mensagem de erro, como descrito em O valor de MaxBufferSize do POP3 é muito baixo. Se o valor do Registro MaxBufferSize for definido com um valor muito alto, poderá resultar em instabilidade do sistema e o Exchange Server Analyzer exibirá uma mensagem de erro, como descrito em O valor de MaxBufferSize do POP3 é muito alto.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Criar um novo valor de DWORD chamado MaxBufferSize.

  4. Clique duas vezes no valor MaxBufferSize e defina-o como novo tamanho de buffer (em bytes). Por exemplo, você pode inserir 8192 para defini-lo como 8.192 bytes.

  5. Saia do editor do Registro e reinicie o serviço Microsoft Exchange POP3 para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre quando e como usar o valor do Registro MaxBufferSize, consulte o artigo 823857 da Base de Dados de Conhecimento, "XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


O valor de MaxBufferSize do POP3 é muito alto
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o seguinte valor de Registro existe:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Se o Exchange Server Analyzer localizar o valor MaxBufferSize presente e configurado com um valor numérico maior que 32768, será exibido um aviso.

O valor de Registro MaxBufferSize é usado em uma topologia front-end/back-end do Exchange. Ele define o tamanho do buffer do TCP/IP entre servidores front-end e back-end. O tamanho padrão do buffer é 1 quilobyte (KB). Em redes com altas latências, ajustar o valor MaxBufferSize pode melhorar o desempenho de clientes POP3.

Ao configurar o tamanho do buffer do TCP/IP com o valor de Registro MaxBufferSize, você deve sempre definir o tamanho do buffer como múltiplos de 1.024. É recomendável que você teste o desempenho da configuração de seu servidor front-end/back-end com os seguintes tamanhos de buffer:

  • 8,192 bytes

  • 16,384 bytes

  • 32.768 bytes

Ao usar essa entrada de Registro, ela deve ser definida como, pelo menos, 1.024. É recomendável que você não defina a entrada de Registro MaxBufferSize com um valor maior do que 32.768. No entanto, talvez você perceba um melhor desempenho com um tamanho de buffer de 65.535, dependendo de suas condições de rede. Um tamanho de buffer maior usa mais memória no computador do Exchange Server e pode diminuir o número de usuários que podem acessar o servidor front-end. Enquanto não houver nenhum limite para o valor máximo que você possa usar para o valor de Registro MaxBufferSize, talvez você experimente desempenho instável e problemas de memória se atribuir um valor muito alto para essa entrada de Registro.

Observação:
Para usar o valor de Registro MaxBufferSize, você deve executar o Exchange 2000 Server Service Pack 2 ou posterior.

Se o valor de Registro MaxBufferSize estiver definido muito baixo, o desempenho não irá melhorar e o Exchange Server Analyzer exibirá uma mensagem de erro, como descrito em O valor de MaxBufferSize do POP3 é muito baixo. Se o valor de Registro MaxBufferSize estiver definido muito alto, isso poderá resultar em instabilidade do sistema e o Exchange Server Analyzer exibirá uma mensagem, conforme descrito nesse artigo.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Criar um novo valor de DWORD chamado MaxBufferSize.

  4. Clique duas vezes no valor MaxBufferSize e defina-o como novo tamanho de buffer (em bytes). Por exemplo, você pode inserir 8192 para defini-lo como 8.192 bytes.

  5. Saia do editor do Registro e reinicie o serviço Microsoft Exchange POP3 para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre quando e como usar o valor do Registro MaxBufferSize, consulte o artigo 823857 da Base de Dados de Conhecimento, "XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


O valor de MaxBufferSize do POP3 é muito baixo
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o seguinte valor de Registro existe:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Se o Exchange Server Analyzer encontrar o valor MaxBufferSize presente e configurado com qualquer valor numérico maior que 0, mas menor que 1024, será exibido um erro.

O valor de Registro MaxBufferSize é usado em uma topologia front-end/back-end do Exchange. Ele define o tamanho do buffer do TCP/IP entre servidores front-end e back-end. O tamanho padrão do buffer é 1 quilobyte (KB). Em redes com altas latências, ajustar o valor MaxBufferSize pode melhorar o desempenho de clientes POP3.

Ao definir o tamanho de buffer TCP/IP com o valor de Registro MaxBufferSize, você deve sempre definir o tamanho do buffer em múltiplos de 1.024. É recomendável testar o desempenho da configuração de seu servidor front-end/back-end com os seguintes tamanhos de buffer para determinar o melhor valor para sua organização:

  • 8,192 bytes

  • 16,384 bytes

  • 32.768 bytes

Ao usar essa entrada de Registro, ela deve ser definida como, pelo menos, 1.024. É recomendável que você não defina a entrada de Registro MaxBufferSize com um valor maior do que 32.768. No entanto, talvez você perceba um melhor desempenho com um tamanho de buffer de 65.535, dependendo de suas condições de rede. Um tamanho de buffer maior usa mais memória no computador do Exchange Server e pode diminuir o número de usuários que podem acessar o servidor front-end. Enquanto não houver nenhum limite para o valor máximo que você possa usar para o valor de Registro MaxBufferSize, talvez você experimente desempenho instável e problemas de memória se atribuir um valor muito alto para essa entrada de Registro.

Observação:
Para usar o valor de Registro MaxBufferSize, você deve executar o Exchange 2000 Server Service Pack 2 ou posterior.

Se o valor do Registro MaxBufferSize estiver definido muito baixo, o desempenho não melhorará e o Exchange Server Analyzer exibirá uma mensagem de erro, como descrito neste artigo. Se o valor do Registro MaxBufferSize estiver definido muito alto, poderá resultar em instabilidade do sistema e o Exchange Server Analyzer irá exibir uma mensagem, como descrito em O valor de MaxBufferSize do POP3 é muito alto.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Criar um novo valor de DWORD chamado MaxBufferSize.

  4. Clique duas vezes no valor MaxBufferSize e defina-o como novo tamanho de buffer (em bytes). Por exemplo, você pode inserir 8192 para defini-lo como 8.192 bytes.

  5. Feche o editor do Registro e reinicie o serviço de Microsoft Exchange POP3 para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre quando e como usar o valor do Registro MaxBufferSize, consulte o artigo 823857 da Base de Dados de Conhecimento, "XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


A porta não respondeu
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-05-16

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o servidor definido pelo usuário e tenta abrir uma conexão de soquete com o servidor especificado na configuração padrão da porta TCP 25 ou de uma porta definida pelo usuário. Se o Exchange Server Analyzer não receber uma resposta personalizada esperada de xx Disponível, em que xx é a porta padrão 25 ou o número de porta alternativo definido pelo usuário, ele exibirá um erro.

Esse erro indica que o servidor não pode ser acessado na porta TCP desejada e que poderão ocorrer falhas. Para corrigir esse erro, você pode solucionar o problema de conectividade com o servidor.

Para solucionar o problema de conectividade com o servidor

  1. É possível conexão telnet com a porta desejada no próprio servidor designado? Caso não, o problema não é na rede.

  2. Está tudo conectado? Todo seu hardware está funcionando corretamente?

  3. O DNS está funcionando e configurado corretamente?

  4. Seu roteador está funcionando corretamente?

  5. Há algum firewall impedindo que você se conecte?

Para obter mais informações sobre como solucionar problemas de conectividade do servidor, consulte "Solução de problemas de conectividade com a ferramenta Microsoft Exchange Server Best Practices Analyzer Tool" (http://go.microsoft.com/fwlink/?LinkId=56285).


Possíveis roteadores de buraco negro
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_PingStatus do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) usando vários valores de configuração BufferSize e NoFragmentation específicos para determinar se os roteadores de buraco negro podem estar presentes no ambiente WAN.

Configuração BufferSize | Configuração NoFragmentation
548 | True
1472 | True
1472 | Falso
4096 | True
4096 | Falso

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • PING com BufferSize menor e NoFragmentation = True é bem-sucedido

  • PING com BufferSize maior e NoFragmentation = True ultrapassa o tempo limite

  • PING com BufferSize maior e NoFragmentation = False é bem-sucedido, mas o tamanho do BufferSize de resposta difere do BufferSize enviado.

Esse erro indica a possível presença de um ou mais roteadores de buraco negro na rede de longa distância (WAN).

Em uma WAN TCP/IP, a comunicação em algumas rotas poderá falhar se as seguintes condições forem verdadeiras:

  • Os pacotes dos segmentos de rede intermediários são menores do que os hosts de comunicação.

  • Os roteadores não enviam respostas ICMP apropriadas para essa condição.

Como alternativa, o firewall no caminho pode abandonar essas respostas. Um roteador que causa essa condição talvez seja conhecido como um roteador de buraco negro.

A presença de um roteador de buraco negro pode causar vários erros que não ocorrerão se um programa se conectar a um computador em uma sub-rede local. O comportamento pode parecer intermitente, mas você perceberá que ele pode ser reproduzido, por exemplo, quando um cliente lê um arquivo grande enviado a partir de um host remoto.

Para obter mais informações, siga as orientações do artigo 314825 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de roteador de buraco negro " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825).

Para obter mais informações

Para obter mais informações sobre como detectar e tratar possíveis roteadores de buraco negro, consulte os seguintes recursos:

  • Artigo 159211 da Base de Dados de Conhecimento da Microsoft, "Diagnósticos e tratamento de roteadores de buraco negro " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

  • "Roteadores de Buraco Negro da PMTU" (em inglês) na coluna The Cable Guy - julho de 2004 (http://go.microsoft.com/fwlink/?LinkId=66963).


PING do Host Remoto Malsucedido
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-05-03

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_PingStatus do WMI (Instrumentação de Gerenciamento do Microsoft Windows®), usando várias configurações de BufferSize e NoFragmentation para determinar o tamanho da MTU (Unidade Máxima de Transmissão) para a rede e localizar possíveis roteadores de buraco negro. O Exchange Server Analyzer determina isso examinando o valor da chave StatusCode retornado de um host remoto para cada combinação de configurações.

Configuração de BufferSize: | Configuração de NoFragmentation:
548 | True
1472 | True
1472 | Falso
4096 | True
4096 | Falso

Win32_PingStatus retorna um objeto com 24 propriedades que fornecem detalhes completos sobre os pacotes de ping enviados pela classe.

Se o Exchange Server Analyzer perceber que o valor para essa chave corresponde a um dos valores da tabela a seguir, ele exibirá um erro.

O Exchange Server Analyzer exibe o nome do host remoto, o nome do Exchange Server e o valor de StatusCode correspondente que é retornado com esse erro.

Valor de StatusCode Significado Descrição

11001

Buffer Muito Pequeno

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11002

Rede de Destino Inacessível

A solicitação falhou porque a rede que contém o computador de destino está inacessível. Não existe uma rota válida para o computador de destino.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Host de Destino Inacessível

A solicitação falhou porque o computador de destino está inacessível.

Para obter mais informações, consulte Servidor do Active Directory desativado ou inacessível (em inglês).

Esse erro também pode ser causado por uma das seguintes condições:

  • Um firewall entre o local onde o Exchange Server Analyzer está sendo executado e o controlador de domínio de destino.

  • Um erro de DNS.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Protocolo de Destino Inacessível

A solicitação falhou porque o computador de destino não responde ao protocolo de pacote.

Esse erro pode ser causado por um firewall entre o local onde o Exchange Server Analyzer está sendo executado e o controlador de domínio de destino.

11005

Porta de Destino Inacessível

A solicitação falhou porque a porta no computador de destino não está disponível.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Não Há Recursos

A solicitação falhou por causa de recursos de rede insuficientes.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Opção Inválida

A solicitação falhou porque contém uma opção inválida.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11008

Erro de Hardware

A solicitação falhou por causa de um erro de hardware.

Verifique se o controlador de domínio está em operação adequadamente, executando a ferramenta de verificação de integridade de hardware fornecida pelo fabricante do computador.

11009

Pacote Muito Grande

A solicitação falhou porque o pacote que contém a solicitação é maior do que a MTU (unidade máxima de transmissão) de um roteador ou nó de gateway localizado entre a origem e o destino. A MTU define o tamanho máximo de um pacote para transmissão.

A solicitação enviada pelo Exchange Server Analyzer não é maior do que 10 KB. Verifique se os roteadores e os gateways da sua organização estão configurados corretamente.

Para obter mais informações, consulte o artigo 159211 da Base de Dados de Conhecimento, "Diagnóstico e tratamento de roteadores de buraco negro" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Tempo Limite da Solicitação Atingido

Não houve resposta no tempo alocado. O tempo padrão permitia respostas em 5 segundos.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Solicitação Incorreta

A solicitação falhou porque foi codificada incorretamente.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11012

Rota Inválida

A solicitação falhou porque não existe nenhuma rota válida entre os computadores de origem e de destino.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

Trânsito TimeToLive Expirado

A solicitação falhou porque o seu valor de TTL (vida útil) chegou a zero. Isso faz com que o nó do gateway ou roteador de encaminhamento descarte o pacote.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Reagrupamento TimeToLive Expirado

A solicitação falhou porque o pacote foi dividido em fragmentos para transmissão e nem todos os fragmentos foram recebidos no tempo alocado para o reagrupamento. O RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) especifica 60 segundos como o limite de tempo no qual todos os fragmentos do pacote devem ser recebidos.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Problema de Parâmetro

A solicitação falhou porque um nó do gateway ou roteador encontrou problemas ao processar o cabeçalho do pacote. Isso pode ocorrer se o cabeçalho contiver dados de campo inválidos ou uma opção não reconhecida.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11016

Retardamento de Origem

A solicitação falhou porque o pacote foi descartado. Isso ocorre quando a fila de saída do computador de origem não possui espaço de armazenamento insuficiente. Também pode ocorrer quando os pacotes chegam ao destino muito rapidamente para serem processados.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11017

Opção Grande Demais

A solicitação falhou porque contém uma opção inválida.

Esse erro é improvável porque o Exchange Server Analyzer gera uma solicitação padrão.

11018

Destino Inválido

A solicitação falhou por causa de uma das seguintes razões:

  • O endereço IP de destino não pode receber solicitações PING.

  • O endereço IP de destino nunca deve aparecer no campo de endereço de destino de nenhum datagrama IP.

Isso pode ser causado por um firewall entre o local onde o Exchange Server Analyzer está sendo executado e o controlador de domínio de destino.

11032

Negociando IPSEC

A solicitação falhou porque uma conexão IPsec não pôde ser negociada.

11050

Falha Geral

A solicitação falhou por razão desconhecida.

Para obter mais informações, consulte o artigo 325487 da Base de Dados de Conhecimento, "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Para obter mais informações sobre esses testes, consulte o artigo 314825 da Base de Dados de Conhecimento, "Como solucionar problemas com o roteador de buraco negro" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825).


O Mecanismo de Roteamento está parado
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar se o serviço RESvc (Mecanismo de Roteamento do Microsoft Exchange) e o serviço SMTP (SMTPSVC) estão sendo executados. O Analisador do Exchange Server exibirá um erro se verificar que uma das seguintes condições é verdadeira:

  • SMTPSVC está sendo executado.

  • RESvc não está sendo executado.

Se o RESvc não estiver sendo executado em todos os servidores Exchange que retransmitem mensagens, poderão ocorrer problemas de roteamento. A configuração de um Exchange Server que retransmite mensagens sem que RESvc esteja sendo executado não é uma configuração aceita.

Assim como o Exchange 2000 Server, o Exchange Server 2003 usa um algoritmo de roteamento sobre o estado do link e um protocolo de roteamento para propagar informações sobre o estado do link em forma de tabela. A tabela de estado do link é armazenada na memória em todos os servidores Exchange 2000 Server e Exchange Server 2003 da organização.

Um algoritmo de estado do link oferece as seguintes vantagens:

  • Cada servidor Exchange pode selecionar o roteamento ideal de mensagens na origem em vez de enviar mensagens por um roteamento no qual o link não está disponível.

  • As mensagens não mais são devolvidas para frente e para trás entre servidores, pois cada servidor Exchange tem as informações atuais sobre a disponibilidade de roteamentos alternativos ou redundantes.

  • Não ocorre mais o loop de mensagens. Esse era um problema que ocorria eventualmente nas versões anteriores do Exchange Server.

O Exchange Server coleta as seguintes informações da tabela de estado do link:

  • A tabela de estado do link documenta a topologia de roteamento de toda organização do Exchange.

  • A tabela do estado do link documenta a disponibilidade de cada conector na topologia. Uma topologia disponível está "ativa". Uma topologia disponível está "inativa".

  • A tabela de estado do link documenta os custos e os espaços de endereçamento associados a cada conector disponível.

O Exchange Server usa essas informações para determinar o roteamento com o custo mais baixo para o endereço de destino. Se um conector ao longo do roteamento com o custo mais baixo não estiver disponível, o Exchange Server determinará a melhor rota alternativa com base nos custos e na disponibilidade dos conectores. O RESvc é necessário para o roteamento do estado do link.

Para corrigir esse erro, você deve configurar o RESvc para iniciar automaticamente. Você deve verificar também se o RESvc está sendo executado durante as horas de produção.

Para corrigir esse erro

  1. Clique em Iniciar, aponte para Programas, aponte para Ferramentas Administrativas e clique em Serviços.

  2. Na lista de serviços, clique com o botão direito em Mecanismo de Roteamento do Microsoft Exchange e clique em Propriedades.

  3. Na guia Geral, no menu Tipo de inicialização, selecione Automático e clique em OK.

  4. Clique com o botão direito em Mecanismo de Roteamento do Microsoft Exchange e clique em Iniciar.

Para obter mais informações sobre o roteamento de mensagens, consulte o Guia de Transporte e Roteamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Contadores de desempenho RPC indicam fraco desempenho do servidor
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-08-24

A ferramenta Microsoft® Exchange Server Analyzer Tool determinou que o servidor não está funcionando com o desempenho ideal. O Exchange Server Analyzer avalia vários contadores de desempenho RPC (chamada de procedimento remoto). Se os dados informados nos contadores de desempenho RPC não corresponderem favoravelmente aos níveis contidos na tabela a seguir, será exibido um aviso.

Número de Usuários no Exchange Server | Limite de Latência Média de RPC
Menor que 500 | Média maior que 15
Maior ou igual a 500, mas menor que 3000 | Média maior que 30
Maior que 3000 | Média maior que 50

Os seguintes contadores de desempenho são discutidos neste artigo e gerenciados pelo objeto de desempenho MSExchangeIS:

  • Latência Média de RPC

  • Solicitações RPC

Latência Média de RPC

O contador de desempenho Latência Média de RPC grava o tempo médio, em milisegundos (ms), necessário para o processamento dos 1024 últimos pacotes. A latência representa o tempo decorrido desde o momento em que o processo Store.exe recebeu o pacote até o momento em que ele o devolveu. O contador de desempenho Latência Média de RPC não inclui nenhuma latência da rede nem a latência introduzida por qualquer item que não seja o processo Store.exe. Embora o contador de desempenho Latência Média de RPC não inclua o tempo de trânsito da rede, ele fornece os dados sobre o menor período de tempo durante o qual os computadores clientes aguardaram uma resposta do servidor. Se os dados do contador de desempenho Latência Média de RPC forem inferiores a 50 ms, o servidor poderá processar as solicitações em um período de tempo razoável. Se o contador permanecer acima de 50 ms por mais do que alguns segundos, isso indicará que o servidor está enfrentando dificuldades de sustentar a carga. Conseqüentemente, os usuários podem ter atrasos acessar os respectivos emails. Se a latência média for maior que 100 ms, os usuários receberão a seguinte janela pop-up de seus computadores clientes do Microsoft Office Outlook®: "Recuperando dados do Exchange Server".

Interpretando o contador de desempenho Latência Média de RPC

O contador Latência Média de RPC pode ficar confuso nas duas situações a seguir:

  • Primeiro, espera-se que algumas operações MAPI demorem muito tempo. Por exemplo, se o computador cliente pesquisar uma pasta que contém milhares de itens, na tentativa de localizar todos os itens que correspondam a critérios complexos, será comum que uma operação desse tipo demore vários segundos. Se poucos usuários estiverem no servidor, essa operação contínua poderá gerar um pico na Latência Média de RPC. Se a carga de RPC no servidor estiver baixa, observe a média desse valor durante um período de tempo mais longo (pelo menos alguns minutos), em vez de agir com base em um comportamento mais volátil, no curto prazo.

  • A segunda situação que pode ocorrer é quando a carga de RPC no servidor está muito baixa. Às vezes, dependendo da atividade do usuário mais ocupado, a latência pode mudar drasticamente. Como a carga do servidor é particularmente analisada, o resultado da operação intensa por um único usuário pode alterar inadvertidamente os dados da latência média de RPC.

Solicitações RPC

O contador de desempenho Solicitações RPC grava o número de solicitações do computador cliente que estão sendo processadas atualmente pelo Exchange. O contador tem um valor máximo de 100. Depois que o armazenamento do Exchange tiver 100 operações RPC em processamento, ele recusará regularmente todas as novas conexões. Em um servidor íntegro, o número de solicitações pendentes deve ser inferior a 50. Se o número ficar acima de 50 por um longo tempo, isso indicará que será feito backup das RPCs e que elas ficarão aguardando para serem processadas, e provavelmente os computadores cliente estarão enfrentando atrasos.

Interpretando solicitações RPC

O limite de 50 solicitações não é rigoroso. Um servidor levemente carregado pode começar a apresentar problemas de desempenho antes que o contador atinja 30; contudo, um servidor com uma carga alta pode funcionar corretamente com 50 solicitações. Em termos ideais, para cada servidor, deve ser avaliado um valor de linha de base para esse contador. O Exchange Server Performance Troubleshooting Analyzer usa o limite de 50, que é adequado para a maioria dos servidores grandes.

Em comparação a um servidor com carga intensa, um servidor levemente carregado tem um valor reduzido de solicitações RPC. Isso ocorre porque um servidor levemente carregado exige menos threads para sustentar a carga. Para não ficar para trás e obter um valor mais alto de solicitações RPC, um usuário mais ocupado deve executar mais trabalho simultaneamente. Portanto, em um servidor de carga intensa, um valor mais alto de solicitações RPC não implica necessariamente em um problema de desempenho. Para avaliar a "lentidão" do servidor, considere também o contador de desempenho Latência Média de RPC.

Causas da latência

Um aumento na latência pode ser causado por:

  • Aumento na carga de RPC

  • Afunilamento em um ou mais recursos do servidor

Além disso, um afunilamento pode ser causado por:

  • Alta carga de RPC (ou qualquer outra carga no servidor)

  • Mau funcionamento do hardware ou erro de configuração

Para corrigir esse erro

  • Siga as orientações e as práticas recomendadas que são fornecidas nos seguintes guias do Exchange Server 2003:

    • Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576)

    • Solucionando Problemas de Desempenho do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588) (em inglês)


Intervalo de porta RPC definido em um servidor sem cluster
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte chave de Registro para determinar os dados de valor das portas:

HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

Ao detectar que as seguintes condições são verdadeiras, o Analisador do Exchange Server exibirá um erro:

  • A chave HKLM\Software\Microsoft\Rpc\Internet\Ports está presente.

  • O servidor não é um servidor de cluster do Exchange.

  • O servidor está apresentando outros erros.

Quando a chave de Registro estiver presente, o Exchange Server fica restrito a um intervalo específico de portas para chamadas RPC. Se o servidor Exchange estiver com carga inferior e precisar de mais portas do que as disponíveis no momento, poderão ocorrer erros.

Para corrigir esse problema, adicione mais 100 portas à chave HKLM\Software\Microsoft\Rpc\Internet\Ports até que os problemas estejam resolvidos.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Abra o editor de Registro, Regedt32.exe.

    Observação:
    Para editar um valor igual a REG_MULTI_SZ, use o Regedt32.exe em vez do Regedit.exe.

  2. Navegue para: HKLM\Software\Microsoft\Rpc\Internet.

  3. No painel direito, clique duas vezes na chave Portas. Na caixa de valor, aumente o Intervalo da Porta.

  4. Feche o editor de Registro e reinicie o servidor Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre as chaves de Registro HKLM\Software\Microsoft\Rpc\Internet, consulte o artigo 154596 da Base de Dados de Conhecimento Microsoft, "Como configurar a alocação de portas dinâmicas RPC para funcionar com firewalls" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596).


Intervalo de portas RPC definido em um servidor agrupado
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte chave de Registro para determinar os dados de valor das portas: HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

Ao detectar que as seguintes condições são verdadeiras, o Analisador do Exchange Server exibirá um erro:

  • A chave HKLM\Software\Microsoft\Rpc\Internet\Ports está presente.

  • O servidor é um servidor Exchange agrupado.

  • O servidor está apresentando outros erros.

Quando a chave de Registro estiver presente, o Exchange Server fica restrito a um intervalo específico de portas para chamadas RPC. Se o servidor Exchange estiver com carga inferior e precisar de mais portas do que as disponíveis no momento, poderão ocorrer erros.

Para corrigir esse problema, adicione mais 100 portas à chave HKLM\Software\Microsoft\Rpc\Internet\Ports até que os problemas estejam resolvidos.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Abra o editor de Registro, Regedt32.exe.

    Observação:
    Para editar um valor igual a REG_MULTI_SZ, use o Regedt32.exe em vez do Regedit.exe.

  2. Navegue para: HKLM\Software\Microsoft\Rpc\Internet.

  3. No painel direito, clique duas vezes na chave Portas. Na caixa de valor, aumente o Intervalo da Porta.

  4. Feche o editor de Registro e reinicie o servidor Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre as chaves de Registro HKLM\Software\Microsoft\Rpc\Internet, consulte o artigo 154596 da Base de Dados de Conhecimento da Microsoft, "Como configurar a alocação de portas dinâmicas RPC para funcionar como firewalls" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596).


Atividade do usuário RPC nos contadores de desempenho
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2007-02-14

A ferramenta Microsoft® Exchange Server Analyzer determinou que o servidor está sofrendo uma alta carga de RPC (chamadas de procedimento remoto).

A velocidade de operações por segundo de RPC é uma indicação da carga de RPC presente no servidor. Às vezes, um aumento inesperado na carga operacional de RPC pode resultar em fraco desempenho do servidor. Se o servidor estiver sofrendo um problema de desempenho, você deverá primeiro identificar se a carga no servidor é mais alta do que o esperado. Existem vários contadores de desempenho que fornecem informações sobre a atividade RPC no servidor. Os contadores de desempenho a seguir discutidos neste artigo estão todos nos objetos de desempenho MSExchangeIS, MSExchangeIS Public ou MSExchangeIS Mailbox:

  • Operações RPC/s

  • Contagem de Usuários Ativos

  • Logons de Clientes Ativos (MSExchangeIS Public)

  • Logons de Clientes Ativos (MSExchangeIS Mailbox)

Identificando carga de cliente RPC

Existem dois contadores que podem ser usados para identificar a taxa de atividade atual de computadores clientes.

  • Operações RPC/s Esse contador fornece o número de operações de RPC por segundo que os computadores clientes estão solicitando do servidor atualmente. Você pode contar usuários das seguintes formas:

    • Você pode contar o total de caixas de correio no servidor.

    • Você pode contar o número total de logons (da soma de Logons de Clientes Ativos para MSExchangeIS Public e Logons de Clientes Ativos para MSExchangeIS Mailbox).

    • Você pode contar o número total de logons na Contagem de Usuários Ativos.

    O Exchange Server Analyzer usa o último método. Para calcular a taxa por usuário ativo, divida a média de Operações RPC/s pela Contagem de Usuários Ativos.

  • Operações RPC/s por usuário Esse contador fornece uma indicação do quanto os usuários estão ativos no servidor. Normalmente, os trabalhadores qualificados que usam o Microsoft Office Outlook® apresentam uma taxa de aproximadamente 0,1 operações por segundo, por usuário em um servidor de caixas de correio. Se os usuários do servidor estiverem executando aplicativos adicionais, o número poderá aumentar.

Se o Exchange Server Analyzer determinar que as operações RPC por segundo por usuário são superiores a 0,15 mas inferiores a 0,25, os usuários serão considerados moderadamente ativos e o Exchange Server Analyzer exibirá um aviso.

Se o Exchange Server Analyzer determinar que as operações RPC por segundo por usuário são superiores a 0,25, os usuários serão considerados excepcionalmente ativos e o Exchange Server Analyzer exibirá um erro.

O que fazer se a carga de RPC for alta

Se as operações por segundo forem mais altas do que o esperado, você deverá primeiro tentar identificar a causa da alta carga e depois reduzi-la. Você pode usar a ferramenta ExMon (Monitor de Usuários do Exchange Server) para identificar se um usuário determinado está emitindo uma alta taxa de operações RPC.

Se não conseguir reduzir a carga no servidor, você deverá identificar os afunilamentos de desempenho e aumentar a capacidade do servidor.

Identificando um alto número de logons

É necessário que o servidor mantenha algumas informações sobre logons na memória (na memória do usuário e do kernel). Existe uma quantidade limitada de memória reservada. Se essa memória for usada, o servidor poderá encontrar um afunilamento de memória. Por esse motivo, se você encontrar um problema de desempenho em um servidor Exchange, verifique se o número total de logons por usuário não é excessivo.

Um trabalhador qualificado típico terá dois ou três logons. Se os usuários estiverem executando outros aplicativos, o número de logons poderá aumentar. O Exchange Server Analyzer calcula o número de logons por usuário dividindo o número total de logons no servidor pelo número de caixas de correio do servidor. Você pode determinar o número total de logons no servidor somando os contadores de desempenho Logons de Clientes Ativos nos objetos de desempenho MSExchangeIS Mailbox e MSExchangeIS Public. Para servidores de caixas de correio ou caixas de correio mistas e pastas públicas, o Exchange Server Analyzer verifica apenas essa proporção.

Observação:
Se um grande número de usuários estiver exibindo pastas compartilhadas de outros usuários (como calendários compartilhados), o número de logons poderá também ser mais alto.

Se o número médio de logons por usuário for mais de cinco e o servidor estiver sofrendo um afunilamento de memória, isso poderá indicar que os usuários estão executando aplicativos que estão criando um grande número de logons. Se os usuários estiverem executando aplicativos que não são necessários para uso comercial, solicite que não executem os aplicativos que estão provocando logons excessivos no servidor Exchange.

Se não for possível reduzir o número de aplicativos que os usuários estão executando, reduza o número de usuários por servidor movendo usuários para outro servidor. Para determinar se os logons são provocados por muitos usuários ou se um único usuário tem um número alto desproporcional de logons, você pode usar o Gerenciador do Sistema Exchange para exibir os logons ativos de cada usuário.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).


A verificação antivírus de RTF foi desabilitada
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar o valor da verificação antivírus da mensagem em formato RTF (Rich Text Format):

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Se o Exchange Server Analyzer verificar que o valor ScanRTF está definido como 0, será exibido um aviso.

A chave de Registro ScanRTF é definida por fornecedores de antivírus de terceiros, que usam a VSAPI (API de Verificação de Vírus do Exchange). As mensagens RTF permitem usar cores, fontes e formatação, mas o RTF só é legível pelo Microsoft Office Outlook® 2003. O formato RTF do Exchange Server é diferente do formato de arquivo RTF lido em um processador de texto, como o Microsoft Office Word 2003.

É recomendável que você verifique a presença de vírus em todos os tipos de mensagens, inclusive as mensagens RTF. Você deve habilitar a verificação de vírus de todas as mensagens que fluem por um computador do Exchange Server.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. No seu aplicativo antivírus sensível ao Exchange, habilite a verificação de todas as mensagens.

    ou

  2. Modifique manualmente a entrada do Registro, executando o seguinte procedimento:

    • Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

    • Navegue para:

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    • Clique duas vezes na entrada do registro ScanRTF e defina seus Dados de Valor como 1.

    • Saia do editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange e os serviços que representam o software antivírus sensível ao Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o combate a vírus, consulte o site "Retardando e parando vírus transmitidos por email em um ambiente do Exchange 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47587).


Banner SMTP foi personalizado
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer tenta enviar uma mensagem para uma conta de Postmaster ou uma conta definida pelo usuário para o domínio SMTP. O Exchange Server Analyzer exibirá um aviso se receber dessa conta uma resposta diferente da seguinte resposta padrão:

"220 Nome do computador . Nome do domínio .com Microsoft ESMTP MAIL Service, Versão: Número da versão pronta em Data Hora +0000"

Esse aviso indica que a resposta padrão exibida quando o programa se conecta a um servidor virtual SMTP do Exchange foi personalizada.

Um banner SMTP personalizado pode não representar um problema se o administrador do Exchange Server tiver alterado intencionalmente esse banner, como descreve o artigo 281224 da Base de Dados de Conhecimento Microsoft, "XCON: Como modificar o banner SMTP" (http://go.microsoft.com/fwlink/?linkID=3052&kbid=281224) (em inglês).

Se o banner SMTP padrão não foi personalizado propositalmente pelo administrador do Exchange Server, esse aviso poderá indicar que o Exchange Server está por trás de um Firewall ou Proxy SMTP filtrando os comandos ESMTP (SMTP Estendidos) do Exchange Server.

Se os comandos ESMTP do Exchange Server forem filtrados, isso poderá afetar significativamente o desempenho do Exchange e gerar o comportamento descrito no artigo 320027 da Base de Dados de Conhecimento Microsoft, "Não é possível enviar ou receber emails atrás de um firewall Cisco PIX" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027).

Para obter mais informações sobre os banners SMTP personalizados, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • "XCON: Como modificar o banner SMTP" (http://go.microsoft.com/fwlink/?linkID=3052&kbid=281224) (em inglês).

  • "Não é possível enviar ou receber emails atrás de um firewall Cisco PIX" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027).


Instância do SMTP pausada
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-05-16

O Microsoft® Exchange Server Analyzer Tool consulta a metabase do IIS para determinar o valor da propriedade ServerState de cada instância de um Servidor Virtual SMTP.

A propriedade ServerStateapresenta o estado atual da instância do servidor. Os estados e os códigos de estado correspondentes são os seguintes: 1 (iniciando), 2 (iniciado), 3 (parando), 4 (parado), 5 (pausando), 6 (pausado) ou 7 (continuando).

Se o Exchange Server Analyzer determinar que o valor da propriedade ServerState de uma instância do Servidor Virtual SMTP é 6 (parada), exibirá um erro.

SMTP é o protocolo de mensagens nativo para envio e transporte de mensagens no Exchange Server. Isso significa que os clientes usam SMTP para enviar mensagens e os servidores Exchange usam SMTP para entregar mensagens e dados de mensagens.

Servidores virtuais são executados sob um processo de servidor que você pode iniciar, parar e pausar - de modo parecido com muitos outros processos de servidor. Por exemplo, se você estiver alterando a configuração de um servidor virtual ou executando outras tarefas de manutenção, talvez você precise parar o servidor virtual, fazer as alterações e, em seguida, reiniciá-lo. Quando você para um servidor virtual, ele não aceita conexões de usuários e você não pode usá-lo para entregar ou recuperar mensagens.

Uma alternativa à paralisação de um servidor virtual é fazer uma pausa nesse servidor. Uma pausa em um servidor virtual impede novas conexões de cliente, mas não desconecta as conexões atuais. Ao fazer uma pausa em um servidor virtual SMTP, os clientes ativos podem continuar a enviar mensagens e o servidor virtual pode entregar as mensagens existentes na fila de entrega. Contudo, nenhuma conexão nova será aceita.

Para operações de mensagem comuns, as instâncias do servidor virtual SMTP do Exchange Server devem estar iniciadas.

Para resolver esse erro, siga estas etapas para iniciar a instância do servidor virtual SMTP.

Para iniciar a instância do servidor virtual SMTP

  1. No Gerenciador do Sistema do Exchange, clique com o botão direito na instância do servidor virtual que deseja iniciar.

  2. No menu Ação, clique em Iniciar.

Para obter informações sobre como iniciar, parar ou pausar servidores virtuais SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • "XCON: How to Configure a SMTP Virtual Server Part 1" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • "XCON: How to Configure a SMTP Virtual Server Part 2" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

  • "XIMS: Como liberar a Fila de Mensagens SMTP no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087).

  • "XGEN: Desabilitando Protocolos no Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330).


Instância de SMTP Parada
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-05-16

O Microsoft® Exchange Server Analyzer Tool consulta a metabase do IIS para determinar o valor da propriedade ServerState de cada instância de um Servidor Virtual SMTP.

A propriedade ServerState apresenta o estado atual da instância do servidor. Os estados e os códigos de estado correspondentes são os seguintes: 1 (iniciando), 2 (iniciado), 3 (parando), 4 (parado), 5 (pausando), 6 (pausado) ou 7 (continuando).

Se a ferramenta Exchange Server Analyzer Tool determinar que o valor da propriedade ServerState de uma instância de Servidor Virtual SMTP é igual a 4 (parada), o Exchange Server Analyzer exibirá um erro.

SMTP é o protocolo de mensagens nativo para envio e transporte de mensagens no Exchange Server. Isso significa que os clientes usam SMTP para enviar mensagens e os servidores Exchange usam SMTP para entregar mensagens e dados de mensagens.

Servidores virtuais são executados sob um processo de servidor que você pode iniciar, parar e pausar - de modo parecido com muitos outros processos de servidor. Por exemplo, se você estiver alterando a configuração de um servidor virtual ou executando outras tarefas de manutenção, talvez você precise parar o servidor virtual, fazer as alterações e, em seguida, reiniciá-lo. Quando você para um servidor virtual, ele não aceita conexões de usuários e você não pode usá-lo para entregar ou recuperar mensagens.

Para operações de mensagem comuns, as instâncias do servidor virtual SMTP do Exchange Server devem estar iniciadas.

Para resolver esse erro, siga estas etapas para iniciar a instância do servidor virtual SMTP.

Para iniciar a instância do servidor virtual SMTP

  1. No Gerenciador do Sistema do Exchange, clique com o botão direito na instância do servidor virtual que deseja iniciar.

  2. No menu Ação, clique em Iniciar.

Para obter informações sobre como iniciar, parar ou pausar servidores virtuais SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • "XCON: Como configurar um Servidor Virtual SMTP Parte 1" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • "XCON: Como configurar um Servidor Virtual SMTP Parte 2" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

  • "XIMS: Como liberar a Fila de Mensagens SMTP no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087).

  • "XGEN: Desabilitando Protocolos no Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330).


O número máximo de destinatários de SMTP pode estar definido muito baixo
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchSmtpMaxRecipients é menor que 250. Por padrão, o atributo msExchSmtpMaxRecipients é configurado para 64.000 destinatários. Se o Exchange Server Analyzer verificar que o atributo msExchSmtpMaxRecipients está configurado com um valor menor que 250, será exibido um um aviso.

Do ponto de vista da segurança, a prática recomendável é limitar o número máximo de destinatários para cada mensagem. É recomendável que você deixe o atributo msExchSmtpMaxRecipients definido com o valor padrão de 64000.

Cada organização deve determinar seu número máximo aceitável de destinatários de acordo com seus próprios requisitos de trabalho. Porém, recomendamos que você não configure o número máximo de destinatários com um valor inferior a 250. As mensagens endereçadas a várias listas de distribuição provavelmente terão mais de 250 destinatários. Se você definir um número máximo de destinatários abaixo de 250, o Exchange terá que processar o restante dos destinatários usando cópias adicionais da mensagem. Essas cópias adicionais causam aumento no tráfego de rede.

Para exibir e configurar o número máximo de destinatários

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP, como o Servidor Virtual SMTP Padrão, e selecione Propriedades.

  4. Selecione a guia Mensagens.

  5. Para reverter para a configuração padrão de 64000, verifique se a caixa de seleção Limitar número de destinatários por mensagem está marcada e digite o valor 64000. Como alternativa, você pode configurar esse campo com qualquer valor ou limpar a caixa de seleção para permitir um número ilimitado de destinatários.

  6. Clique em OK para salvar as alterações e fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


O Endereço de Proxy SMTP para EAS foi substituído
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

Mensagem de Erro

Introdução

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se o endereço do proxy do SMTP para o Exchange ActiveSync® foi substituído:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\SMTPProxy

Se o Analisador do Exchange Server detectar que o valor do Registro SMTPProxy está presente e configurado, uma mensagem de configuração não padrão será exibida.

Os endereços SMTP são usados para identificar o caminho de uma caixa de correio no Exchange Server e devem ser exclusivos. Cada endereço tem uma parte esquerda (LHS) e uma parte direita (RHS) que são separadas por um símbolo @. Por exemplo, o formato para um endereço SMTP é o seguinte:

Username@domain.com = lado-direito@lado-esquerdo (ou LHS@RHS)

O Exchange ActiveSync usa uma solicitação WebDAV para acessar as informações de caixa de correio no servidor Exchange. O Exchange ActiveSync seleciona um valor RHS associado, com o LHS@RHS representando um endereço do proxy do SMTP, para ser usado na solicitação WebDAV. Em ambientes com um endereço RHS padrão diferente de um endereço SMTP principal do usuário, o valor do registro SMTPProxy fornece uma oportunidade de configuração para permitir ao Exchange ActiveSync usar um endereço de proxy SMTP alternativo.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para visualizar ou modificar o valor do Registro SMTPProxy

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. Examine e, se desejar, altere o valor SMTPProxy.

  4. Se for feita uma alteração, feche o editor do Registro e reinicie o computador do Exchange Server para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o Exchange ActiveSync, consulte "Arquitetura do ActiveSync do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=67009).

Para obter mais informações sobre o acesso móvel e o Exchange Server 2003, consulte "Acesso móvel usando o Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=20098).


O servidor SMTP aceita autenticação básica
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchAuthenticationFlags na classe protocolCfgSMTPServer para o objeto do Exchange Server. A classe protocolCfgSMTPServer contém as configurações para um servidor virtual SMTP. O atributo msExchAuthenticationFlags representa o tipo de autenticação permitida no servidor SMTP. Se o Exchange Server Analyzer determinar que a autenticação básica foi configurada no servidor SMTP e o servidor não for o Microsoft Small Business Server 2000 nem o Microsoft Windows® Small Business Server 2003, o Exchange Server Analyzer exibirá uma mensagem de aviso.

Se a autenticação básica for configurada no servidor SMTP, o risco de uma violação de segurança aumentará. A autenticação básica permite que nomes de usuário e senhas sejam enviados pela rede em texto não criptografado. Sem criptografia, os nomes de usuário e senhas podem ser interceptados facilmente na Internet.

Se você usar a autenticação básica, é altamente recomendável utilizar também a criptografia TLS para obter mais segurança. O TLS criptografa nomes de usuário, senhas e dados de mensagens. Você pode exigir que clientes que se conectem ao servidor virtual SMTP usem criptografia TLS. O TLS foi projetado para ajudar a proteger mensagens de saída, mas não ajuda a proteger o tráfego que vem de clientes para o servidor.

O Microsoft Outlook Express oferece suporte para TLS. Para usar criptografia TLS para o servidor virtual SMTP, você deve criar pares de chaves e configurar certificados de chaves. Os clientes podem então usar TLS para criptografar a sessão com o serviço SMTP. Assim, todas as mensagens são enviadas. O serviço SMTP também pode usar TLS para criptografar sessões com servidores remotos.

Observação:
Clientes que não têm suporte para TLS não podem retransmitir mensagens de email através do servidor virtual.

Se você não puder desabilitar o acesso autenticado no seu servidor virtual SMTP por motivos comerciais, como a autenticação por uma empresa parceira, siga estas etapas para ajudar a melhorar a segurança em seu servidor gateway:

  • Aplique uma diretiva de senhas de alta segurança a todas as contas de usuário, especialmente à conta do administrador.

  • Desabilite a conta de convidado. Para obter mais informações sobre como desabilitar a conta de convidado, consulte o artigo 320053 da Base de Dados de Conhecimento da Microsoft, "How to rename the administrator and guest account in Windows 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053). Apesar desse artigo ser indicado para o Microsoft Windows 2000 Server, princípios similares se aplicam ao Windows Server™ 2003.

Para desabilitar a autenticação básica

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, <seu servidor Exchange de entrada>, Protocolos e SMTP.

  2. Clique com o botão direito em seu servidor virtual SMTP de entrada e clique em Propriedades.

  3. Clique na guia Acesso e clique em Autenticação.

    Caixa de diálogo Autenticação

  4. Em Autenticação, desmarque a caixa de seleção Autenticação Básica.

    Importante:
    Se você usar autenticação básica, considere a possibilidade de implementar TLS para aumentar a segurança. Use a caixa de seleção Requer criptografia TLS se você tiver um certificado digital. Certificados digitais são comuns em ambientes de alta segurança. Se você marcar essa caixa de seleção, na caixa Domínio padrão você deverá digitar o nome de domínio do Windows 2000 Server ou do Windows Server 2003 com o qual o usuário deverá ser autenticado se ele não especificar um domínio. Para obter mais informações sobre criptografia TLS, consulte a documentação online do Exchange.

Para obter mais informações sobre como configurar a organização do Exchange Server 2003 para enviar e receber emails da Internet com mais segurança, consulte o Guia de Transporte e Roteamento do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=26041).


Serviço SMTP Desabilitado
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-05-16

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor definido para a chave StartMode do serviço do Protocolo SMTP. Um valor Disabled indica que o serviço SMTP foi desabilitado e não pode ser iniciado até que o valor StartMode seja alterado para Manual ou Automatic.

O Exchange Server Analyzer consulta a classe do WMI Win32_Service para determinar o valor da chave Started para o serviço SMTP. Um valor False indica que o serviço não está sendo executado. Um valor True indica que o serviço está sendo executado.

Se o Exchange Server Analyzer verificar que o valor da chave StartMode está definida como Disabled em um computador do Exchange Server com o serviço SMTP iniciado, será exibido um erro.

O serviço SMTP do Windows é um componente do IIS (Serviço de Informações da Internet) e é executado como parte do Inetinfo.exe. O Exchange Server conta com o serviço SMTP como seu protocolo de transporte nativo. Portanto, o Exchange usa o SMTP para rotear todas as mensagens internas e externas.

Todos os computadores do Exchange Server devem ter seu serviço SMTP definido como Automatic.

Para resolver esse erro, você deve configurar o serviço SMTP para iniciar automaticamente em servidores que roteiam emails.

Para configurar o serviço do protocolo SMTP para inicialização automática

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. Clique duas vezes no serviço Protocolo SMTP.

  3. Na guia Geral da página Propriedades do Protocolo SMTP, selecione Automático na caixa de diálogo suspensa Tipo de inicialização e clique em Aplicar.

  4. Em Status do serviço, clique em Iniciar e clique em OK.

  5. Feche o snap-in Serviços.

Para obter mais informações sobre o serviço SMTP e Servidores Exchange, consulte "SMTP Transport Architecture" no Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como configurar o serviço SMTP para Exchange, consulte "Configuring SMTP in Microsoft Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=24866).


O serviço SMTP não iniciou
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2007-03-13

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started para o serviço de protocolo SMTP. Um valor False indica que o serviço SMTP não está sendo executado. Um valor True indica que o serviço SMTP está sendo executado.

Se o Exchange Server Analyzer verificar que o valor da chave Started estiver definido como False, o Exchange Server Analyzer exibirá um aviso.

O serviço SMTP do Windows é um componente do IIS (Serviço de Informações da Internet) e é executado como parte do Inetinfo.exe. O Exchange Server conta com o serviço SMTP como seu protocolo de transporte nativo. Portanto, o Exchange usa o SMTP para rotear todas as mensagens internas e externas.

O serviço SMTP deve estar sempre em execução em servidores Exchange.

Para corrigir esse erro

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. No painel da direita, role para baixo até o serviço SMTP e clique nele duas vezes. Isso exibirá a caixa de diálogo Propriedades do protocolo SMTP.

  3. Defina o valor no menu suspenso Tipo de inicialização como Automático.

  4. Clique em Iniciar para iniciar o serviço Atendedor do Sistema.

  5. Clique em OK para salvar as alterações e feche a caixa de diálogo Propriedades do protocolo SMTP.

  6. Feche o snap-in Serviços.

Para obter mais informações sobre o serviço protocolo SMTP e Servidores Exchange, consulte "Arquitetura de transporte SMTP" no Guia de Referência Técnica para o Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47891).

Para obter mais informações sobre como configurar o serviço SMTP para Exchange, consulte "Configuring SMTP in Microsoft Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=24866).


Serviço SMTP definido como manual
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-05-16

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor definido para a chave StartMode do serviço do Protocolo SMTP. Um valor Manual indica que o serviço SMTP foi definido para exigir um início manual e não iniciará automaticamente.

O Exchange Server Analyzer consulta também a classe WMI Win32_Service para determinar o valor da chave Started para o serviço SMTP. Um valor False indica que o serviço não está sendo executado. Um valor True indica que o serviço está sendo executado.

Se o Exchange Server Analyzer detectar que o valor para a chave StartMode está definido como Manual em um computador do Exchange Server que tenha o serviço SMTP iniciado, exibirá um aviso.

O serviço SMTP do Windows é um componente do IIS (Serviço de Informações da Internet) e é executado como parte do Inetinfo.exe. O Exchange Server conta com o serviço SMTP como seu protocolo de transporte nativo. Portanto, o Exchange usa o SMTP para rotear todas as mensagens internas e externas.

Se o serviço SMTP não iniciar automaticamente na inicialização, ele poderá ser ignorado. Isso pode levar a sérios problemas de fluxo de mensagens.

Todos os computadores do Exchange Server devem ter seu serviço SMTP definido como Automatic.

Para resolver esse erro, você deve configurar o serviço SMTP para iniciar automaticamente em servidores que roteiam emails.

Para configurar o serviço do protocolo SMTP para inicialização automática

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. Clique duas vezes no serviço Protocolo SMTP.

  3. Na guia Geral da página Propriedades do Protocolo SMTP, selecione Automático na caixa de diálogo suspensa Tipo de inicialização e clique em Aplicar.

  4. Em Status do serviço, clique em Iniciar e clique em OK.

  5. Feche o snap-in Serviços.

Para obter mais informações sobre o serviço SMTP e Servidores Exchange, consulte "SMTP Transport Architecture" no Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como configurar o serviço SMTP para Exchange, consulte "Configuring SMTP in Microsoft Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=24866).


Status desconhecido do serviço SMTP
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started para o serviço de protocolo SMTP. Um valor False indica que o serviço SMTP não está sendo executado. Um valor True indica que o serviço SMTP está sendo executado.

Se o Exchange Server Analyzer não puder determinar o valor da chave Started, o Exchange Server Analyzer exibirá um erro.

Esse erro indica que a consulta WMI não conseguiu recuperar os dados solicitados.

As causas prováveis desse erro são:

  • A conta que executa o Exchange Server Analyzer não tem permissões suficientes para consultar classes WMI.

  • Um problema de rede impede que o Exchange Server Analyzer entre em contato com o computador.

  • Uma condição transitória de origem desconhecida provocou um tempo limite para a consulta.

Para corrigir esse erro

  1. Verifique se o servidor que está executando o Exchange Server foi iniciado e está conectado à rede.

  2. Use o comando PING para verificar se o servidor Exchange está acessível.

  3. Se houver um firewall, verifique se as portas de RPC (chamada de procedimento remoto) estão bloqueadas.

  4. Examine as permissões da conta na qual o Exchange Server Analyzer está sendo executado. A conta na qual o Exchange Server Analyzer está sendo executado deve ter permissões de Administrador local em cada servidor Exchange que ele verifica.

    Como alternativa, você pode conceder permissão específica de WMI para a conta na qual o Exchange Server Analyzer está sendo executado:

    1. No servidor Exchange, abra a árvore do MMC (Console de Gerenciamento Microsoft) Gerenciamento do Computador.

    2. Em Serviços e Aplicativos, clique com o botão direito em Controle WMI e clique em Propriedades.

    3. Na caixa de diálogo Propriedade dos Controles WMI, clique na guia Segurança e expanda Raiz.

    4. Selecione a pasta CIMV2 e clique em Segurança.

    5. Na página Segurança para ROOT\CIMV2, adicione a conta sob a qual o Exchange Server Analyzer está sendo executado.

  5. Selecione a conta adicionada na etapa 5. Em Permissões para Conta_Selecionada, na coluna Permitir, selecione Habilitação Remota e Ler Segurança e clique em OK.

Para obter mais informações sobre o serviço SMTP e Servidores Exchange, consulte "Arquitetura de transporte SMTP" no Guia de Referência Técnica para o Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47891).

Para obter mais informações sobre como configurar o serviço SMTP para Exchange, consulte "Configurando SMTP no Microsoft Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=24866).

Para obter mais informações sobre como solucionar problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento Microsoft , "Como solucionar problemas de conectividade de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Para obter mais informações sobre solucionar problemas de conectividade do Exchange Server Analyzer, consulte "Solução de problemas de conectividade da ferramenta Microsoft Exchange Server Best Practices Analyzer" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56285).


Os valores de Registro UseAltRegionalCharset e UseRegionalCharset estão habilitados
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-12-15

A ferramenta Microsoft® Exchange Server Analyzer Tool lê as seguintes entradas do Registro para determinar as configurações de idiomas usadas pelos clientes do Microsoft® Outlook Web Access:

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

    Uma configuração de valor igual a 1 faz com que os corpos de mensagens UTF-8 continuem no armazenamento do conjunto de caracteres regionais ou na página de códigos, em vez de em formato UTF-8. Essa é a configuração padrão do valor do Registro UseRegionalCharset do Exchange Server 2003.

  • HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

O nível do navegador determinará a codificação da mensagem se as seguintes condições forem verdadeiras:

  • A chave UseAltRegionalCharset não está definida ou está definida como 0.

  • A chave UseRegionalCharset relacionada não está similarmente definida ou está definida como 0.

Um navegador de nível superior, o Internet Explorer 5 ou uma versão posterior, envia mensagens em UTF-8. Um navegador anterior ou diferente do Internet Explorer 5, envia mensagens na codificação adequada ao idioma de aceitação desse navegador.

A chave UseAltRegionalCharset só altera o comportamento dos navegadores configurados para os idiomas na lista a seguir:

  • Coreano: KS_C_5601-1987

  • Japonês: shift_jis:

  • Europa Ocidental: windows-1252

  • Russo: windows-1251

  • Europa Central: windows-1250

Se a chave UseAltRegionalCharset estiver definida como 1, tanto os navegadores de nível superior quanto os anteriores enviam mensagens nas codificações a seguir:

  • Coreano: euc_kr

  • Japonês: iso-2022-jp (JIS)

  • Europa Ocidental: iso-8859-1

  • Russo: koi8-r

  • Europa Central: iso-8859-2

O Analisador do Exchange Server também consulta o serviço de diretórios do Active Directory® para determinar o valor do atributo serialNumber de todos os objetos que tenham a classe msExchExchangeServer.

  • Se o valor da cadeia de caracteres contiver "Versão 6.0", o computador estará executando o Exchange 2000 Server.

  • Se o valor da cadeia de caracteres incluir "Version 6.5", o computador está executando o Exchange Server 2003.

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • O UseAltRegionalCharset e o UseRegionalCharset estão presentes.

  • O UseAltRegionalCharset e o UseRegionalCharset estão configurados para usar um valor igual a 1 em um servidor do Exchange 2000 ou do Exchange 2003.

Para o Exchange 2000 Server e o Exchange Server 2003, os conjuntos de caracteres alternativos têm prioridade quando as seguintes condições são verdadeiras:

  • O uso de caracteres regionais é ativado - O valor de REG_WORD da chave do Registro UseRegionalCharset está definido como -1.

  • O uso de conjuntos de caracteres alternativos é ativado - o valor de REG_WORD da chave do Registro UseAltRegionalCharset está definido como 0x1.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse problema

  1. No computador com o Exchange, abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Determine quais configurações de idioma do Outlook Web Access são adequadas ao ambiente do Exchange Server e remova a chave inadequada.

    1. Navegue para: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

    2. Escolha a chave a ser removida, clique com o botão direito na chave e selecione Excluir na lista suspensa.

  3. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre as configurações de idioma do Outlook Web Access, consulte os seguintes recursos do Exchange Server:

O "Guia do Exchange Server Client Access" (http://go.microsoft.com/fwlink/?LinkId=47568).

Artigo 311342 da Base de Dados de Conhecimento da Microsoft, "XCON: Chaves de Registro do OWA do Servidor Exchange 2000 Server SP2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342) (em inglês).


O valor do Registro UseAltRegionalCharset está habilitado no Exchange 2000 Server
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-12-15

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada de Registro a seguir para determinar se UseAltRegionalCharset está sendo usado para a configuração do idioma do cliente no Microsoft Outlook® Web Access:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

O nível do navegador determinará a codificação da mensagem se as seguintes condições forem verdadeiras:

  • A chave UseAltRegionalCharset não está definida ou está definida como 0.

  • A chave UseRegionalCharset relacionada não está similarmente definida ou está definida como 0.

A chave UseAltRegionalCharset só altera o comportamento dos navegadores configurados para os idiomas na lista a seguir:

  • Coreano: KS_C_5601-1987

  • Japonês: shift_jis:

  • Europa Ocidental: windows-1252

  • Russo: windows-1251

  • Europa Central: windows-1250

Se a chave UseAltRegionalCharset estiver definida como 1, tanto os navegadores de nível superior quanto os anteriores enviam mensagens nas codificações a seguir:

  • Coreano: euc_kr

  • Japonês: iso-2022-jp (JIS)

  • Europa Ocidental: iso-8859-1

  • Russo: koi8-r

  • Europa Central: iso-8859-2

O Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para todos os objetos que tenham uma classe de objeto msExchExchangeServer. Se o valor da cadeia de caracteres contiver "Versão 6.0", o computador estará executando o Exchange 2000 Server.

Se o Analisador do Exchange Server detectar que UseAltRegionalCharset está configurado para usar um valor maior que 0 em um computador que está executando o Exchange 2000 Server, exibirá uma mensagem de configuração não padrão.

Essa mensagem indica que o parâmetro de Registro UseAltRegionalCharset nesse servidor Exchange 2000 está habilitado. Se você espera que usuários do Outlook Web Access em sua organização enviem emails com freqüência para destinatários que usam vários conjuntos de caracteres, você poderá modificar as configurações do Registro para que os usuários que estejam executando o Internet Explorer 5 ou versões posteriores possam usar caracteres UNICODE codificados em UTF-8 para enviar emails. Se você não precisa de vários conjuntos de caracteres, use o procedimento a seguir para restaurar a configuração padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para restaurar a configuração do idioma padrão do Outlook Web Access

  1. No computador com o Exchange, abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. No painel da direita, exclua o valor do Registro UseAltRegionalCharSet.

  4. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre as configurações de idioma do Outlook Web Access, consulte o artigo 311342 da Base de Dados de Conhecimento da Microsoft, "XCCC: Chaves de Registro do OWA do Servidor Exchange 2000 Server SP2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342) (em inglês).


O valor do Registro UseAltRegionalCharset está habilitado no Exchange Server 2003
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-12-15

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para procurar se há o valor do Registro UseAltRegionalCharset:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\

O valor do Registro UseAltRegionalCharset permite que os usuários do Microsoft Outlook® Web Access codifiquem o email usando um conjunto de caracteres alternativo.

O Analisador do Exchange Server também consulta o serviço de diretórios do Active Directory® para determinar o valor do atributo serialNumber de todos os objetos que tenham a classe msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador está executando o Exchange Server 2003.

Se o Exchange Server Analyzer detectar que o valor do Registro UseAltRegionalCharset está definido acima de 0 em um servidor Exchange 2003, o Exchange Server Analyzer exibirá uma mensagem de configuração diferente do padrão.

Essa mensagem indica que UseAltRegionalCharset foi configurado nesse servidor Exchange 2003. Essa configuração pode causar codificação em conjunto de caracteres não intencionado para mensagens do Outlook Web Access, na qual algumas mensagens podem ser ilegíveis para alguns clientes. É recomendável que você verifique se as configurações de idioma do cliente estão corretas.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para restaurar a configuração do idioma padrão do Outlook Web Access no Exchange Server 2003

  1. No computador com o Exchange, abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. No painel da direita, exclua o valor do Registro UseAltRegionalCharSet.

  4. Se o valor do Registro UseRegionalCharset não existir, siga estas etapas para criá-lo:

    1. No menu Editar, clique em Novo e clique em Valor DWORD.

    2. Digite UseRegionalCharset como nome do DWORD e pressione Enter.

  5. Se UseRegionalCharset existir, clique duas vezes nele para modificá-lo.

  6. Na caixa Dados do valor, digite 1 e clique em OK.

  7. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre os valores de Registro UseAltRegionalCharSet e UseRegionalCharset, consulte o artigo 283214 da Base de Dados de Conhecimento da Microsoft, "XCCC: O Outlook Web Access pode enviar uma mensagem em japonês no SJIS" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=283214) (em inglês).


O valor do Registro UseRegionalCharset é habilitado no Exchange 2000 Server
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-12-15

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar as configurações de idioma usadas pelos clientes do Microsoft® Outlook Web Access:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

O valor do Registro UseRegionalCharset faz com que os corpos de mensagens UTF-8 continuem a ser armazenados no conjunto de caracteres regionais ou na página de códigos, em vez de em formato UTF-8.

O Analisador do Exchange Server também consulta o serviço de diretórios do Active Directory® para determinar o valor do atributo serialNumber de todos os objetos que tenham a classe msExchExchangeServer. Se o valor da cadeia de caracteres contiver "Versão 6.0", o computador estará executando o Exchange 2000 Server.

Se o Exchange Server Analyzer verificar que UseRegionalCharset está configurado para utilizar o valor 1 ou um valor maior em um computador que está executando o Exchange 2000 Server, o Exchange Server Analyzer exibirá uma mensagem de configuração não padrão.

Esta mensagem indica que o parâmetro de registro UseRegionalCharset no servidor Exchange 2000 está habilitado. Se os usuários do Outlook Web Access de sua organização costumam enviar mensagens com freqüência para destinatários que usam diversos conjuntos de caracteres, é possível modificar algumas configurações do Registro, para que os usuários executando o Internet Explorer 5 ou versões superiores usem os caracteres UNICODE codificados por UTF-8 para enviar mensagens. Se você não precisa de vários conjuntos de caracteres, use o procedimento a seguir para restaurar a configuração padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para restaurar a configuração do idioma padrão do Outlook Web Access

  1. No computador com o Exchange, abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. No painel da direita, exclua o valor do Registro UseRegionalCharSet.

  4. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O valor do Registro UseRegionalCharset está desativado
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-12-15

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar as configurações de idioma usadas pelos clientes do Microsoft® Outlook Web Access:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

O valor do Registro UseRegionalCharset faz com que os corpos de mensagens UTF-8 continuem a ser armazenados no conjunto de caracteres regionais ou na página de códigos, em vez de em formato UTF-8.

O Analisador do Exchange Server também consulta o serviço de diretórios do Active Directory® para determinar o valor do atributo serialNumber de todos os objetos que tenham a classe msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador está executando o Exchange Server 2003.

Se o Exchange Server Analyzer detectar que UseRegionalCharset está configurado para usar um valor maior que 0 em um computador que está executando o Exchange 2003 Server, exibirá uma mensagem de configuração não padrão.

Essa mensagem indica que o parâmetro de Registro UseRegionalCharset nesse servidor Exchange 2003 está desabilitado. Essa configuração pode causar codificação em conjunto de caracteres não intencionado para mensagens do Outlook Web Access, na qual algumas mensagens podem ser ilegíveis para alguns clientes.

Quando você usa o Microsoft Internet Explorer 5 ou versões posteriores para acessar o Outlook Web Access, o Exchange Server 2003 usa as configurações de idioma do navegador para determinar qual conjunto de caracteres usar para codificar informações como mensagens de email e solicitações de reunião.

Se você espera que usuários do Outlook Web Access em sua organização enviem emails com freqüência para destinatários que usam vários conjuntos de caracteres, você poderá modificar as configurações do Registro para que os usuários que estejam executando o Internet Explorer 5 ou versões posteriores possam usar caracteres UNICODE codificados em UTF-8 para enviar emails.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para restaurar a configuração do idioma padrão do Outlook Web Access

  1. No computador com o Exchange, abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Se UseRegionalCharset não existir, siga estas etapas para criá-lo:

    1. No menu Editar, clique em Novo e clique em Valor DWORD.

    2. Digite UseRegionalCharset como nome do DWORD e pressione Enter.

  4. Se UseRegionalCharset existir, clique duas vezes nele para modificá-lo.

  5. Na caixa Dados do valor, digite 1 e clique em OK.

  6. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre configurações de idioma do Outlook Web Access, consulte "Exchange Server Client Access Guide" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47568).


O valor do Registro UseRegionalCharset está desabilitado ou ausente no Exchange Server 2003
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2005-12-15

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar as configurações de idioma usadas pelos clientes do Microsoft® Outlook Web Access:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

O valor do Registro UseRegionalCharset faz com que os corpos de mensagens UTF-8 continuem a ser armazenados no conjunto de caracteres regionais ou na página de códigos, em vez de em formato UTF-8.

O Analisador do Exchange Server também consulta o serviço de diretórios do Active Directory® para determinar o valor do atributo serialNumber de todos os objetos que tenham a classe msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador está executando o Exchange Server 2003.

O Exchange Server Analyzer exibe uma mensagem de aviso se alguma das seguintes condições for verdadeira:

  • A entrada UseRegionalCharset de um servidor Exchange 2003 não está presente.

  • A entrada UseRegionalCharset tem um valor qualquer diferente de 1.

Esta mensagem indica que o parâmetro de Registro UseRegionalCharset neste servidor Exchange 2003 está desabilitado ou ausente. Essa configuração pode causar codificação em conjunto de caracteres não intencionado para mensagens do Outlook Web Access, na qual algumas mensagens podem ser ilegíveis para alguns clientes.

Quando você usa o Microsoft Internet Explorer 5 ou versões posteriores para acessar o Outlook Web Access, o Exchange Server 2003 usa as configurações de idioma do navegador para determinar qual conjunto de caracteres usar para codificar informações como mensagens de email e solicitações de reunião.

Se os usuários do Outlook Web Access de sua organização costumam enviar mensagens com freqüência para destinatários que usam diversos conjuntos de caracteres, é possível modificar algumas configurações do Registro, para que os usuários executando o Internet Explorer 5 ou versões superiores usem os caracteres UNICODE codificados por UTF-8 para enviar mensagens.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para restaurar a configuração do idioma padrão do Outlook Web Access

  1. No computador com o Exchange, abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Se UseRegionalCharset não existir, siga estas etapas para criá-lo:

    1. No menu Editar, clique em Novo e clique em Valor DWORD.

    2. Digite UseRegionalCharset como nome do DWORD e pressione Enter.

  4. Se UseRegionalCharset existir, clique duas vezes nele para modificá-lo.

  5. Na caixa Dados do valor, digite 1 e clique em OK.

  6. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre configurações de idioma do Outlook Web Access, consulte "Exchange Server Client Access Guide" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47568).


Carga do usuário e operações MAPI
Microsoft Exchange Server Analyzer - Artigos > Protocolos >

Última modificação do tópico: 2006-10-17

A ferramenta Microsoft® Exchange Server Analyzer Tool determinou que algumas operações MAPI no servidor estão contribuindo para uma considerável porcentagem da carga do usuário do servidor. Essa determinação é efetuada consultando as operações que estão consumindo mais de 4% do tempo da CPU em relação ao tempo total da CPU utilizado no processamento de todas as solicitações RPC.

Causas comuns de operações MAPI de alta porcentagem de uso da CPU

Um administrador que investiga o desempenho ruim do Exchange Server deve examinar se o tamanho médio da caixa de correio está alto nos servidores que estão apresentando um mau desempenho. Será necessário determinar se as pastas individuais estão excessivamente grandes (mais de 5.000 itens na pasta Caixa de Entrada, Itens Enviados, Itens Excluídos ou Calendário de um usuário). Pastas grandes e o aumento da caixa de correio podem gerar aumento da carga da CPI e de E/S. O aumento no número de exibições de cada pasta também pode adicionar uma sobrecarga a várias operações MAPI.

Exibições

Muitas das operações MAPI comuns, de execução demorada, estão relacionadas às exibições. Duas das mais proeminentes são Restrict e FindRow. Nem sempre essas operações demoram muito tempo e se o desempenho delas for um problema, investigue o motivo. Observe também que, além dos seguintes motivos, sempre que ocorrer um afunilamento de recursos (geralmente, um afunilamento de disco ou na CPU), as latências das operações aumentarão.

Observação:
Às vezes, pode ser gerado um alto custo em TaskQ User Known em conjunto com as operações Restrict ou FindRow; isso ocorre porque uma parte do trabalho dessas operações é executado em uma TaskQ e o custo é atribuído a TaskQ User Known.

Restrições

A operação MAPI Restrict é usada para selecionar itens que correspondem a determinados critérios. O servidor cria uma exibição que, na realidade, é uma tabela com critérios associados, denominada uma restrição. Se a exibição que possui uma restrição correspondente já existir, o servidor usará a exibição existente para atender à solicitação do usuário. O uso dessa exibição é relativamente barato; entretanto, criar uma nova exibição é relativamente dispendioso. Por padrão, o armazenamento guarda em cache apenas 11 exibições de cada pasta. Se for solicitado que o servidor crie uma décima segunda exibição, ele excluirá a exibição em cache mais antiga e criará uma nova. As exibições adicionam uma sobrecarga a todas as ações sobre itens que correspondem à restrição de exibições.

Findrow

Os aplicativos clientes usam as operações MAPI SeekRow ou FindRow para mover o cursor entre linhas em uma exibição. SeekRow especifica a quantidade de linhas para mover o cursor e tem um custo muito baixo em termos de tempo de CPU. FindRow é bastante dispendiosa, porque move o cursor para o primeiro item em uma exibição não materializada (não será armazenada em cache) que corresponde aos critérios de restrição e, em seguida, descarta a exibição depois que o aplicativo cliente concluir a ação. O custo máximo de FindRow na CPU depende da complexidade da restrição e da quantidade de linhas que o armazenamento deve examinar antes de encontrar o primeiro item que corresponde aos critérios e, dessa forma, tem pouca relação com o número de itens na pasta.

O alto custo que pode ocorrer com Restrict e FindRow as torna as candidatas adequadas para executar o modo de cache, o que reduziria o custo do servidor. Saiba que, ocasionalmente, a alta porcentagem da CPU consumida por essas operações só pode ser acarretada por calendários compartilhados, caso em que o modo de cache nada ajudará. O alto consumo da porcentagem do tempo da CPU por essas operações poderá indicar a criação de muitas exibições, de exibições dispendiosas ou de altas contagens de itens em pasta.

Para obter mais informações

Para obter mais informações, consulte os seguintes recursos do Exchange Server:

  • Guia de Desempenho e Escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (em inglês)

  • Desempenho do Exchange Server 2003: 10 aspectos a serem considerados (http://go.microsoft.com/fwlink/?LinkId=56460) (em inglês)


Armazenamento
Microsoft Exchange Server Analyzer - Artigos >

Última modificação do tópico: 2005-11-18

Os artigos dessa seção fornecem detalhes sobre o que a ferramenta Analisador do Microsoft® Exchange Server está avaliando com relação a armazenamento. Além disso, esses artigos descrevem ações que podem ser tomadas para resolver erros relacionados com armazenamento, avisos e configurações não-padrão encontradas pelo Analisador do Exchange Server.


Intervalo de Limpeza de Envelhecimento para o armazenamento de caixa de correio é não-padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o intervalo para remoção de índices de bancos de dados não utilizados foi modificado da configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Aging Clean Interval

Se o Exchange Server Analyzer perceber que a chave Aging Clean Interval está presente e configurada, uma mensagem de configuração não padrão será exibida.

Uma das funções do Mecanismo de Armazenamento Extensível é criar índices dinamicamente quando informações são reclassificadas ou solicitadas em uma ordem de classificação diferente. Como resultado, o banco de dados de armazenamento do Exchange poderia ter milhares de índices em uma tabela. O armazenamento do Exchange resolve essa situação atribuindo uma hora de expiração aos índices. Informações sobre o índice são adicionadas a uma tabela interna chamada tabela de envelhecimento de índice. Durante a manutenção online, a tabela de envelhecimento de índice é consultada e o valor da hora de exclusão de cada entrada é comparado à hora atual. Se o índice tiver expirado, ele será removido. Por padrão, esse processo é executado a cada 24 horas durante o ciclo de manutenção de armazenamento do Exchange e remove as entradas com mais de 8 dias do Exchange Server 5.5 e com mais de 40 dias do Exchange 2000 Server, do Exchange Server 2003 e do Exchange Server 2007. A chave Aging Clean Interval é o intervalo em milissegundos no qual o armazenamento do Exchange tenta remover os índices não utilizados. A chave de Registro pode ser usada para substituir esse padrão e executar essa função em um intervalo personalizado.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Exclua a chave Aging Clean Interval.

  4. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a chave Aging Clean Interval, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 159197, "XADM: Controlling Folder Index Aging" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197)

  • 216076, "Accessing information store folders may become slow in Exchange" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076)


O Intervalo de Limpeza de Envelhecimento para um armazenamento de pasta pública não é padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o intervalo para remoção de índices de bancos de dados não utilizados foi modificado da configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Aging Clean Interval

Se o Exchange Server Analyzer perceber que a chave Aging Clean Interval está presente e configurada, uma mensagem de configuração não padrão será exibida.

Uma das funções do Mecanismo de Armazenamento Extensível é criar índices dinamicamente quando informações são reclassificadas ou solicitadas em uma ordem de classificação diferente. Como resultado, o banco de dados de armazenamento do Exchange poderia ter milhares de índices em uma tabela. O armazenamento do Exchange resolve essa situação atribuindo uma hora de expiração aos índices. Informações sobre o índice são adicionadas a uma tabela interna chamada tabela de envelhecimento de índice. Durante a manutenção online, a tabela de envelhecimento de índice é consultada e o valor da hora de exclusão de cada entrada é comparado à hora atual. Se o índice tiver expirado, ele será removido. Por padrão, esse processo é executado a cada 24 horas durante o ciclo de manutenção de armazenamento do Exchange e remove entradas com mais de 8 dias no Exchange Server 5.5 e 40 dias no Exchange 2000 Server e no Exchange Server 2003. A chave Aging Clean Interval é o intervalo em milissegundos no qual o armazenamento do Exchange tenta remover índices. A chave de Registro pode ser usada para substituir esse padrão e executar essa função em um intervalo personalizado.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Exclua a chave Aging Clean Interval.

  4. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a chave Aging Clean Interval, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 159197, "XADM: Controlling Folder Index Aging" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197)

  • 216076, "Accessing information store folders may become slow in Exchange" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076)


Todas as versões do Outlook têm permissão para acessar o servidor
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar se alguma versão do Microsoft Office Outlook® está bloqueada para conexão com o Exchange Server:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se o Exchange Server Analyzer verificar que a chave Desabilitar Clientes MAPI não existe, será exibido um aviso.

A chave Desabilitar Clientes MAPI, que não é habilitada por padrão, permite que um administrador bloqueie versões específicas do Outlook para conexão com um computador que esteja executando o Exchange 2000 Server, o Exchange Server 2003 ou o Exchange Server 2007.

As versões e service packs recentes para o Outlook incluem muitos aprimoramentos de segurança e combate a vírus. Começando com o Outlook 2002, o bloqueio de anexos e a Proteção de Modelo de Objeto estão incluídos e habilitados por padrão. Esses recursos são um componente essencial do combate geral a vírus. A versão mais antiga do Outlook com suporte do Atendimento Microsoft é Outlook 2000 Service Pack 3 (SP3). Se você estiver executando versões anteriores do Outlook em sua organização, faça a atualização para Outlook 2003 ou, no mínimo, atualize o cliente Outlook com as versões de segurança mais recentes.

Depois de atualizar o Outlook, você poderá bloquear o acesso ao Exchange de versões anteriores do Outlook que ainda não tenham sido atualizadas. O bloqueio de versões anteriores do Outlook que não têm suporte para bloqueio de anexos e Proteção de Modelo de Objeto ajuda a oferecer um nível conhecido de segurança de cliente para conexões de clientes MAPI.

Para ajudar a proteção em todas as versões anteriores do Outlook (Outlook 97, Outlook 98, Outlook 2000 antes do SP3 e versões anteriores), é altamente recomendável que você não permita que nenhuma versão do Outlook com número de compilação igual ou anterior a 5.3164.0.0 conecte-se ao Exchange Server.

O próprio cliente dita a cadeia de caracteres de versão do cliente. Essa cadeia de caracteres é similar ao número de versão relatado na caixa de diálogo Sobre do cliente. No entanto, não confie nesse número de versão. Em vez disso, use o Gerenciador de Sistema do Exchange para exibir a propriedade Versão do Cliente na página Logons de Armazenamento de Caixa de Correio.

Importante:
Antes de fazer alguma alteração, observe que hotfixes e versões de service packs podem afetar a cadeia de caracteres de versão do cliente. Tenha cuidado ao restringir o acesso ao cliente, porque os componentes de servidor do Exchange também precisam usar MAPI para fazer logon. Alguns componentes relatam sua versão de cliente com o nome de componente, como SMTP ou OLEDB, embora outros relatem o número de compilação do Exchange, como 6.0.4712.0. Por esse motivo, evite restringir clientes que tenham números de versão que começam com 6.<x.x>. Por exemplo, para impedir o acesso MAPI completamente, em vez de especificar 0.0.0-65535.65535.65535", especifique dois intervalos, para que os componentes de servidor possam fazer logon, da seguinte maneira: 0.0.0-5.9.9; 7.0.0-65535.65535.65535.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Crie uma nova entrada do Valor da Cadeia de Caracteres chamado Desabilitar Clientes MAPI.

  4. Clique duas vezes na entrada do Registro Desabilitar Clientes MAPI e defina os dados do valor no nível desejado. A lista de valores na cadeia de caracteres dos Dados do Valor representa as diferentes maneiras pelas quais você pode desabilitar os intervalos de versões de cliente MAPI. As versões (vX) estão geralmente nos seguintes formatos:

    • Para Microsoft Outlook 2003 e Outlook 2007: Maj.Min.Build

    • Para o Microsoft Outlook 2000: Maj.Build.Dot

    • Para versões anteriores do Microsoft Outlook: Maj.Min.Build

    Nesta cadeia de caracteres, você pode indicar todas as versões ou intervalos de versões específicos que você deseja desabilitar. Use o Gerenciador do Sistema do Exchange para determinar a versão de clientes MAPI que conectam-se ao armazenamento de caixa de correio do Exchange Server 2003. No Gerenciador do Sistema do Exchange, localize o contêiner Logons do armazenamento de caixa de correio. A coluna Versão do Cliente exibe a versão dos clientes MAPI conectados com o armazenamento de caixa de correio.

    No Exchange Server 2007, use o cmdlet Get-LogonStatistics do Shell de Gerenciamento do Exchange para recuperar a versão de clientes MAPI conectados ao banco de dados de caixa de correio.
Importante:
A versão do cliente MAPI está listada no Gerenciador do Sistema do Exchange e Shell de Gerenciamento do Exchange como X.0.Y.Z. Esta versão deve ser inserida como X.Y.Z no valor do Registro. Por exemplo, se o Gerenciador do Sistema do Exchange listar a versão do cliente MAPI como 5.0.2819.0, digite 5.2819.0 no valor de Registro, Desabilitar Clientes MAPI.
  1. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter mais informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Para obter mais informações sobre como bloquear clientes MAPI específicos para conexão com um computador do Exchange 2000 Server ou do Exchange Server 2003, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328240, "Como aplicar restrições de servidor a clientes usados para acessar as caixas de correio do Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • 288894, "XADM: Recurso para desabilitar acesso a clientes MAPI" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894)

Para obter mais informações sobre como baixar atualizações de segurança para versões anteriores do Outlook e bloquear outras versões do Outlook, consulte "Retardando e parando vírus transmitidos por email em um ambiente do Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47587).

Para obter mais informações sobre o cmdlet Get-LogonStatistics, consulte "Get-LogonStatistics" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80699) na documentação de produto do Exchange Server 2007.


AssertOnEvent está definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se a depuração foi habilitada no Armazenamento de Informações do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\AssertOnEvent

Se o Exchange Server Analyzer considerar que foi definido um valor para Debug Break At Startup, o Exchange Server Analyzer exibirá um aviso.

O valor do Registro AssertOnEvent armazena valores decimais que especificam quais eventos do armazenamento devem disparar o modo de depuração do Armazenamento de Informações do Microsoft Exchange. O Registro AssertOnEvent dispara somente quando a versão de depuração do store.exe está em execução. O Armazenamento de Informações do Microsoft Exchange usa muitos recursos quando é executado no modo de depuração. Depurar o armazenamento em um ambiente de produção não é uma prática recomendada.

A menos que você esteja ativamente solucionando um problema de Armazenamento de Informações do Exchange com o auxílio do Atendimento Microsoft, exclua o valor do Registro AssertOnEvent.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para excluir a chave do Registro AssertOnEvent

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel da direita, localize e exclua o valor de AssertOnEvent .

  4. Feche o Editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Pelo menos uma mensagem corrompida foi identificada
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar a contagem do número de entradas no valor PoisonIDs:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

Se o Exchange Server Analyzer determinar que o número de entradas no valor PoisonIDs é maior que 0, um aviso será exibido.

As versões do Exchange Server posteriores ao Exchange Server 2003 Service Pack 1 implementam um comportamento que ajuda a evitar que mensagens danificadas ou inválidas interrompam o serviço de Armazenamento de Informações do Microsoft Exchange inesperadamente ou impeçam que ele seja iniciado com êxito.

No Exchange Server 2003 Service Pack 1 ou versões posteriores, mensagens que causam a interrupção inesperada do serviço de Armazenamento de Informações do Exchange durante a conversão do formato MAPI para o formato MIME são controladas. A ID da mensagem corrompida é armazenada no Registro quando a falha ocorre. Se uma mensagem corrompida fizer com que o armazenamento pare inesperadamente três vezes, essa informação será usada para evitar que a mensagem seja processada novamente quando o serviço Armazenamento de Informações do Exchange for reiniciado pela quarta vez.

Quando o serviço Armazenamento de Informações do Exchange pára inesperadamente devido a uma mensagem danificada, o valor de Registro PoisonIDs é criado em:

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <PrivateInformationStoreGUID>

Além disso, um administrador pode criar a entrada do Registro PoisonThreshold. A chave PoisonThreshold controla o número máximo de vezes que uma mensagem pode passar pelo armazenamento de informações do Exchange antes de ser adicionada à chave de Registro PoisonIDs. Por padrão, esse valor limite é 2. Para acionar o comportamento, o limite deve ser excedido. Portanto, o serviço Armazenamento de Informações do Exchange pode ser parado até 3 vezes devido a uma mensagem danificada, antes que ela seja bloqueada. Por exemplo, se uma mensagem estiver envolvida em 3 falhas, será bloqueada porque 3 é maior que o valor limite de 2.

Quando um evento de mensagem danificada é gravado no Registro, aparecerão mensagens de erro (IDs de evento 9680 e 9681) no log de eventos do aplicativo. Após a inicialização bem-sucedida do serviço de Armazenamento de Informações do Exchange, o Exchange bloqueia a mensagem e tenta enviar uma notificação de falha na entrega da mensagem. Em alguns casos, o Exchange pode não conseguir enviar uma notificação de falha na entrega. Nestes casos, as mensagens bloqueadas podem permanecer na fila até expirar. A chave de Registro PoisonIDs contém até dez valores de ID de mensagem. Quando o limite de dez é excedido, um novo evento de mensagem danificada é adicionado. O evento de mensagem danificada que contém a data da falha mais antiga é removido.

Para corrigir esse aviso

  1. Se você tiver um armazenamento de caixa de correio que esteja tendo problemas com uma mensagem danificada, você deverá investigar mais o problema. Para obter mais informações sobre como a MICROSOFT IT se recupera de bancos de dados danificados do Exchange, consulte http://go.microsoft.com/fwlink/?LinkId=56372.

  2. Se estiver enfrentando problemas com o encerramento do Exchange Server 2003 por causa de mensagens danificadas, talvez seja útil habilitar a criação automática de relatórios de erros no computador do Exchange Server. Os dados do relatório de erros são usados para localizar e corrigir problemas ocorridos no software usado. Para obter mais informações sobre como habilitar o Relatório de Erros do Exchange, consulte Relatório de Erros do Exchange está desabilitado.

Para obter mais informações sobre o Exchange Server 2003 Service Pack 1, consulte "Service Pack 1 para Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=29090).


Limpeza em Segundo Plano de um armazenamento de caixa de correio é não-padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar os dados do valor atual para o valor do Registro Background Cleanup:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

Se o Exchange Server Analyzer verificar que os dados do valor para Background Cleanup estão definidos como qualquer valor diferente de 60.000 (decimal) ou 0xEA60 (hexadecimal), uma mensagem de configuração não padrão será exibida. É recomendável que Background Cleanup seja definido com o valor padrão.

Se o valor de Background Cleanup for definido com um valor muito alto, o processo de limpeza em segundo plano poderá não ser executado com a freqüência necessária e muitos problemas poderão ocorrer. Entre eles os seguintes:

  • A movimentação da caixa de correio pode falhar e pode ser registrado um evento 1205 com código de erro 0x4e3.

  • Os tamanhos de pasta e as contagens de itens mostrados no Gerenciador do Sistema do Exchange ou no Console de Gerenciamento do Exchange podem diferir muito daqueles mostrados pelo Microsoft Outlook®. Além disso, o espaço de banco de dados ocupado por esses itens não pode ser recuperado.

  • Confirmações de mensagens não lidas para itens que foram excluídos sem serem lidos não são geradas sob determinadas circunstâncias.

  • Não ocorrerá limpeza de entradas antigas na tabela DeliveredTo. A tabela DeliveredTo é usada pelo armazenamento do Exchange para impedir a entrega de mensagens duplicadas.

Se o valor Background Cleanup estiver definido muito baixo, o processo de limpeza poderá causar carga desnecessária no servidor.

Cuidado:
Seguir o procedimento deste tópico para reverter para a configuração padrão de um valor que está muito alto pode resultar em um aumento de carga no servidor até que a limpeza em segundo plano seja concluída para todos os itens que normalmente seriam limpos no intervalo padrão. Portanto, é recomendável que você faça essas alterações em um momento que tenha o menor impacto possível para os usuários. Além disso, se as mensagens cujas confirmações de leitura foram solicitadas tiverem sido excluídas sem serem lidas e não tiverem sido limpas devido a esse problema, as confirmações de mensagens não lidas serão geradas para cada uma dessas mensagens depois que você corrigir esse aviso.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Altere o valor de Background Cleanup para 60.000 (decimal) ou 0xEA60 (hexadecimal).

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O intervalo de Limpeza em Segundo Plano para um armazenamento de caixa de correio está ausente
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

O Microsoft® Exchange Server Analyzer Tool lê a entrada do Registro a seguir para determinar se o valor do Registro Background Cleanup está presente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

Se o Exchange Server Analyzer descobrir que o valor de Background Cleanup está ausente, um aviso será exibido.

Se o valor de Background Cleanup estiver ausente, o processo de limpeza em segundo plano não será executado e podem ser detectados diversos problemas, inclusive:

  • A movimentação da caixa de correio pode falhar e pode ser registrado em log um evento 1205 com código de erro 0x4e3.

  • Os tamanhos de caixa de correio e as contagens de itens mostrados no Gerenciador do Sistema do Exchange ou no Console de Gerenciamento do Exchange podem diferir muito daqueles mostrados pelo Microsoft Outlook®. Além disso, o espaço de banco de dados ocupado por esses itens não pode ser recuperado.

  • Confirmações de não lidas para itens que foram excluídos sem serem lidos não são geradas sob determinadas circunstâncias.

  • A limpeza da tabela DeliveredTo não ocorrerá. A tabela DeliveredTo é usada pelo armazenamento do Exchange para impedir a entrega de mensagens duplicadas. O valor de Track Duplicates controla o intervalo de tempo durante o qual as entradas da tabela DeliveredTo são mantidas. Se o valor de Background Cleanup estiver presente, mas o valor de Track Duplicates estiver ausente, as entradas com mais de 24 horas serão removidas pela limpeza em segundo plano. O valor sugerido para Track Duplicates é 1 (decimal ou hexadecimal).

É recomendável que o Background Cleanup seja definido como o valor padrão de 60.000 (decimal) ou 0xEA60 (hexadecimal).

Cuidado:
Seguir o procedimento abaixo para corrigir esse aviso pode resultar em aumento de carga em seu servidor até que a limpeza em segundo plano seja concluída para todos os itens que normalmente seriam limpos regularmente. Portanto, é recomendável que você faça essas alterações em um momento com o menor impacto possível para os usuários. Além disso, se as mensagens para as quais as confirmações de leitura foram solicitadas tenham sido excluídas sem serem lidas e não tenham sido limpas devido a esse problema, as confirmações de não lidas serão geradas para cada uma daquelas mensagens depois que você corrigir esse aviso.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Crie um valor DWORD chamado Background Cleanup com dados de valor de 60000 (decimal) ou 0xEA60 (hexadecimal).

  4. Feche o editor de Registro. Para que as alterações tenham efeito, execute um dos seguintes procedimentos:

    • Desmonte e monte os armazenamentos de informações afetados.

    • Reinicie o serviço Armazenamento de Informações do Microsoft Exchange.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Intervalo de limpeza em segundo plano para um armazenamento de pasta pública é não padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada do Registro a seguir para determinar os dados do valor atual para o valor do Registro Background Cleanup:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>\Background Cleanup

Se o Analisador do Exchange Server achar que os dados do valor para Background Cleanup estão definidos como qualquer valor diferente de 60.000 (decimal) ou 0xEA60 (hexadecimal), uma mensagem de configuração não padrão será exibida. É recomendável que Background Cleanup seja definido como o valor padrão.

Se o valor de Background Cleanup for definido muito alto, o processo de limpeza de segundo plano poderá não executar com a freqüência suficiente e vários problemas podem ser encontrados, inclusive:

  • Os tamanhos de pasta e as contagens de itens mostrados no Gerenciador do Sistema do Exchange pode diferir muito daqueles mostrados pelo Microsoft Outlook®. Além disso, o espaço de banco de dados ocupado por esses itens não pode ser recuperado.

  • Confirmações de não lidas para itens que foram excluídos sem serem lidos não são geradas sob determinadas circunstâncias.

  • Não ocorrerá limpeza de entradas antigas na tabela DeliveredTo. A tabela DeliveredTo é usada pelo armazenamento do Exchange para impedir a entrega de mensagens duplicadas.

Se o valor Background Cleanup estiver definido muito baixo, o processo de limpeza poderá causar carga desnecessária no servidor.

Cuidado:
Seguir o procedimento abaixo para reverter para a configuração padrão de um valor que está muito alto pode resultar em um aumento de carga no seu servidor até que a limpeza de segundo plano seja concluída para todos os itens que normalmente seriam limpos no intervalo padrão. Portanto, é recomendável que você faça essas alterações em um momento com o menor impacto possível para os usuários. Além disso, se as mensagens para as quais as confirmações de leitura foram solicitadas tenham sido excluídas sem serem lidas e não tenham sido limpas devido a esse problema, as confirmações de não lidas serão geradas para cada uma daquelas mensagens depois que você corrigir esse aviso.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>

  3. Altere os dados de valor de Background Cleanup para 60.000 (decimal) ou 0xEA60 (hexadecimal).

  4. Feche o editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O intervalo de Limpeza em Segundo Plano para um armazenamento de pasta pública está ausente
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

O Microsoft® Exchange Server Analyzer Tool lê a entrada do Registro a seguir para determinar se o valor do Registro Background Cleanup está presente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>\Background Cleanup

Se o Exchange Server Analyzer descobrir que o valor de Limpeza em Segundo Plano está ausente, um aviso será exibido.

Se o valor Background Cleanup estiver ausente, o processo de limpeza em segundo plano não ocorrerá e vários problemas poderão ser encontrados, incluindo:

  • Os tamanhos de pasta e as contagens de itens mostrados no Gerenciador do Sistema do Exchange ou no Console de Gerenciamento do Exchange podem diferir muito daqueles mostrados pelo Microsoft Outlook®. Além disso, o espaço de banco de dados ocupado por esses itens não pode ser recuperado.

  • Confirmações de não lidas para itens que foram excluídos sem serem lidos não são geradas sob determinadas circunstâncias.

  • A limpeza da tabela DeliveredTo não ocorrerá. A tabela DeliveredTo é usada pelo armazenamento do Exchange para impedir a entrega de mensagens duplicadas. O valor Track Duplicates controla o intervalo de tempo no qual as entradas da tabela DeliveredTo são mantidas. Se o valor de Limpeza em Segundo Plano estiver presente, mas o valor de Rastrear Duplicatas estiver ausente, as entradas com mais de 24 horas serão removidas pela limpeza em segundo plano. O valor sugerido para Rastrear Duplicatas é 1 (decimal ou hexadecimal).

É recomendável que Background Cleanup seja definido como o valor padrão de 60.000 (decimal) ou 0xEA60 (hexadecimal).

Cuidado:
Seguir o procedimento abaixo para corrigir esse aviso pode resultar em aumento de carga em seu servidor até que a limpeza em segundo plano seja concluída para todos os itens que normalmente seriam limpos regularmente. Portanto, é recomendável que você faça essas alterações em um momento com o menor impacto possível para os usuários. Além disso, se as mensagens para as quais as confirmações de leitura foram solicitadas tenham sido excluídas sem serem lidas e não tenham sido limpas devido a esse problema, as confirmações de não lidas serão geradas para cada uma daquelas mensagens depois que você corrigir esse aviso.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

  3. Crie um valor DWORD chamado Limpeza em Segundo Plano com dados de valor de 60000 (decimal) ou 0xEA60 (hexadecimal).

  4. Feche o editor de Registro. Para que as alterações tenham efeito, execute um dos seguintes procedimentos:

    • Desmonte e monte os armazenamentos de informações afetados.

    • Reinicie o serviço Armazenamento de Informações do Microsoft Exchange.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


BreakOnEvent está definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se a depuração foi habilitada no Armazenamento de Informações do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\BreakOnEvent

Se o Exchange Server Analyzer detectar que um valor foi definido para o valor do Registro BreakOnEvent, o Exchange Server Analyzer exibirá um aviso.

O valor do Registro BreakOnEvent contém valores decimais que especificam quais eventos de armazenamento acionam o modo de depuração do Armazenamento de Informações do Microsoft Exchange. O Armazenamento de Informações do Microsoft Exchange usa muitos recursos quando é executado no modo de depuração. Depurar o armazenamento em um ambiente de produção não é uma prática recomendada.

A menos que você esteja ativamente solucionando um problema de Armazenamento de Informações do Exchange com o auxílio do Atendimento Microsoft, exclua o valor do Registro BreakOnEvent.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para excluir a chave do Registro BreakOnEvent

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel da direita, localize e exclua o valor de BreakOnEvent .

  4. Feche o editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O rastreamento de chamadas está desabilitado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar se o log de Rastreamento de Chamadas está habilitado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

Se o Exchange Server Analyzer considerar que o valor do Registro de Disable Call Tracing está presente e configurado para usar o valor 1, e que o computador está executando o Exchange Server 2003, ele exibirá uma mensagem de configuração não padrão.

Quando o log de Rastreamento de Chamadas está habilitado, os dados da chamada de função dos processos Store.exe são registrados. Por padrão, o rastreamento de chamadas está habilitado em computadores que executam o Exchange Server 2003. Observe que essa função está desabilitada por padrão no Exchange 2000 Server. No entanto, se estiver executando o Exchange Server 2003, você deve habilitar o rastreamento de chamadas, a menos que tenha sido instruído a não fazê-lo sob orientação do Atendimento da Microsoft. Se o rastreamento de chamadas estiver habilitado, ele coletará informações importantes que podem ser usadas para solucionar problemas que ocorrem com o processo de armazenamento.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para reverter para a configuração padrão

  1. Abra o Editor do Registro (Regedit.exe ou Regedt32.exe).

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Defina o valor do Registro Disable Call Tracing como 0.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O rastreamento de chamadas está habilitado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar se o log de Rastreamento de Chamadas está habilitado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

Se o Exchange Server Analyzer verificar que o valor de Regsitro de Disable Call Tracing está presente e configurado com o valor 0, ele exibirá uma mensagem de configuração não padrão.

Quando o log de Rastreamento de Chamadas está habilitado, os dados da chamada de função dos processos Store.exe são registrados. O log de Rastreamento de Chamada pode causar uma redução de até 4 por cento no desempenho. Você só deve habilitá-lo quando precisar dele para solucionar problemas de processos Store.exe lentos ou que não estejam respondendo.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Defina o valor do Registro Disable Call Tracing como 1. A chave Flush Call Traces , a chave RPC Requests Threshold e as chaves Call Tracing Logging Interval não são usadas quando o Rastreamento de Chamada está desabilitado.

  4. Feche o editor de Registro e reinicie o servidor Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


A profundidade do ponto de verificação não está definida corretamente nesse cluster
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchESEParamCheckpointDepthMax em cada grupo de armazenamento. Se o Exchange Server Analyzer verificar que msExchESEParamCheckpointDepthMax não é igual a 5242880 em um cluster do Exchange 2000 Server, será exibido um aviso.

O atributo msExchESEParamCheckpointDepthMax é definido em bytes e governa a profundidade máxima do ponto de verificação. A profundidade do ponto de verificação é a quantidade de dados que esperam para serem confirmados no armazenamento do Exchange. A profundidade máxima do ponto de verificação é a quantidade máxima de dados que podem estar pendentes a qualquer momento. Portanto, se a profundidade máxima do ponto de verificação estiver definida como 20 MB, essa é a quantidade máxima de dados que podem estar pendentes (não confirmados no armazenamento do Exchange) a qualquer momento. Em um ambiente de clusters, um valor menor para esse parâmetro causa tempos de failover mais rápidos. Testes no Exchange Server 2003 demonstraram que um valor de 5 MB (5242880 bytes) para esse parâmetro (em vez de 20 MB, que era o padrão no Exchange 2000 Server) causa tempos de failover muito mais rápidos, sem afetar seriamente o desempenho de E/S no servidor.

Em clusters do Exchange 2000 Server, esse valor deve ser definido sempre como 5242880.

Cuidado:
Se você modificar incorretamente os atributos de objetos do serviço de direório do Active Directory® ao usar a ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você pode causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para definir o atributo msExchESEParamCheckpointDepthMax usando ADSI Edit

  1. Execute o ADSI (Interfaces do Serviço Active Directory) Edit O ADSI Edit é fornecido com as Ferramentas de Suporte de Servidor do Microsoft Windows® 2000 Server e do Microsoft Windows Server™ 2003.

  2. Na árvore do console, clique com o botão direito em ADSIEdit, clique em Conectar a e conecte-se ao Contexto de Atribuição de Nome de Configuração.

  3. Expanda o contêiner de configuração, CN=Configuração, CN=Serviços, CN=Microsoft Exchange, CN=<Nome da Organização>, CN=Grupos Administrativos, CN=<Nome do Grupo Administrativo>, CN=Servidores, CN=<Nome do Servidor>, CN=Armazenamento de Informações.

  4. Clique com o botão direito em CN=<Nome do Grupo de Armazenamento> e clique em Propriedades.

  5. Na lista de propriedades, selecione msExchESEParamCheckpointDepthMax.

  6. Clique em Editar e digite o tamanho que deseja definir em incrementos de 5 MB. O valor deve ser inserido em bytes. Por exemplo, uma profundidade de ponto de verificação de 5 MB corresponde a 5242880 bytes, e uma profundidade de ponto de verificação de 10 MB é igual a 10485760 bytes. O tamanho mínimo que pode ser inserido é 5 MB. Se você inserir um valor acima de 20 MB, haverá um aumento nos tempos de failover do recurso do serviço Armazenamento de Informações do Microsoft Exchange.

  7. Feche ADSIEdit e reinice o serviço Armazenamento de Informações do Microsoft Exchange.

Para obter mais informações sobre como implantar clusters do Exchange 2000 Server, consulte "Implantando clusters do Microsoft Exchange 2000 Server" (página em inglês) (http://go.microsoft.com/fwlink/?LinkID=14578).


Localização do arquivo de ponto de verificação
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

A ferramenta Microsoft® Exchange Server Analyzer Tool solicita que o serviço de diretório do Active Directory® determine se o caminho do arquivo de ponto de verificação (msExchESEParamSystemPath) para cada grupo de armazenamento em um servidor Exchange corresponde ao caminho de log da transação (msExchESEParamLogFilePath) desse grupo de armazenamento. Se o Exchange Server Analyzer detectar que o caminho do arquivo de ponto de verificação não corresponde ao caminho de log da transação do grupo de armazenamento, ele exibirá uma mensagem de prática recomendada.

Se a localização do arquivo de ponto de verificação não corresponder à localização dos arquivos de log de transações, você terá uma inatividade prolongada quando ocorrerem falhas de disco.

Para alterar o local de um arquivo de ponto de verificação do grupo de armazenamento do Exchange, no Exchange 2000 Server e no Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, clique com o botão direito no grupo de armazenamento e clique em Propriedades.

  2. Na guia Geral, em Local de caminho do sistema, clique em Procurar e escolha uma localização para o arquivo de ponto de verificação.
Para alterar o local dos arquivos de log de transações do grupo de armazenamento do Exchange, no Exchange 2000 Server e no Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, clique com o botão direito no grupo de armazenamento e clique em Propriedades.

  2. Na guia Geral, em Localização do log de transações, clique em Procurar e escolha uma localização para o arquivo de log de transações.
Para alterar o local de arquivos de log de transações do grupo de armazenamento do Exchange para o Exchange Server 2007

  1. Siga as orientações contidas na documentação principal do Exchange Server 2007, "Como Definir ou Alterar o Local de Arquivos de Log do Grupo de Armazenamento" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80702).

Para obter mais informações sobre localização dos arquivos de log de transações, consulte "Gerenciando armazenamento de caixa de correio e pasta pública" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

Para obter mais informações sobre o arquivo de ponto de verificação, consulte "Reprodução do log de transações: recuperação temporária e recuperação efetiva no Exchange Server 2003" em Usando grupos de armazenamento de recuperação do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Log Circular desabilitado neste servidor front-end
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-03-27

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor configurado para o atributo do log circular (msExchESEParamCircularLog). Se o Analisador do Exchange Server detectar que esse atributo está configurado com um valor igual a 0, um aviso será exibido.

Um valor igual a 1 para o atributo msExchESEParamCircularLog indica que o log circular está habilitado. Um valor igual a 0 para o atributo msExchESEParamCircularLog indica que o log circular está desabilitado.

No log de transações padrão usado pelo Exchange Server, cada transação de banco de dados em um grupo de armazenamento é gravado em um arquivo de log e, depois, no banco de dados. Quando um arquivo de log atinge determinado tamanho, ele é renomeado e um novo arquivo de log é criado. Com o tempo, isso resultará em um conjunto de arquivos de log. Se houver uma falha, você poderá recuperar as transações repetindo os dados desses arquivos de log no banco de dados.

O log circular substitui e reutiliza o primeiro arquivo de log depois que os dados contidos nele foram gravados no banco de dados. No Exchange Server, o log circular está desabilitado por padrão. Ao habilitá-lo, você reduz os requisitos de espaço de armazenamento da unidade, mas sem arquivos completos de log de transações, você não poderá recuperar nada que seja mais recente que o último backup completo. Portanto, em servidores de produção que contêm dados de caixa de correio ou de pasta pública, o log circular não é recomendado. Entretanto, nos servidores front-end do Exchange que não têm caixas de correio nem pastas públicas, as únicas mensagens que são confirmadas são as notificações de falha na entrega; portanto, não há necessidade de manter os arquivos de transações para esses servidores, nem há muita razão para fazer backup desses servidores. A habilitação do log circular em servidores front-end permite que os arquivos de log de transações sejam substituídos e nunca excedam 20 MB de dados.

Para habilitar log circular

  1. No Gerenciador de Sistema do Exchange, expanda Servidores e expanda um servidor Exchange.

  2. Clique com o botão direito no grupo de armazenamento no qual você deseja habilitar log circular e selecione Propriedades. A caixa de diálogo de propriedades do grupo de armazenamento será exibida.

  3. Marque a caixa de seleção Habilitar log circular e clique em OK para salvar as alterações.

  4. Feche o Gerenciador de Sistema do Exchange e reinicie o Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre log circular, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 258470, "XADM: Como modificar a configuração de Log Circular" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470) (em inglês)

  • 147524, "XADM: Como o log circular afeta o uso de logs de transações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524) (em inglês).

  • 296788, "Procedimentos de restauração e backup offline para o Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788) (em inglês)

  • 314605, "COMO FAZER PARA: Ativar ou desativar o log circular no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605) (em inglês)


Log circular está habilitado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchESEParamCircularLog de cada grupo de armazenamento existente no servidor Exchange. Um valor 1 indica que o log circular está habilitado para o grupo de armazenamento. Um valor 2 indica que o log circular não está habilitado para o grupo de armazenamento. Além disso, o Exchange Server Analyzer também consulta o Active Directory para determinar o número das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

O Exchange Server Analyzer também consulta a classe Exchange_Server do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) no namespace root\MicrosoftExchangeV2 para determinar o valor da chave IsFrontEndServer. Um valor True indica que o computador do Exchange Server é um servidor front-end. Um valor Falso indica que o computador do Exchange Server não é um servidor front-end.

Se o Exchange Server Analyzer detectar que o valor do atributo msExchESEParamCircularLog está definido como 1, o valor da chave IsFrontEndServer está definido como False e o valor do atributo homeMDBBL é maior que 20, será exibido um aviso.

Essa combinação de valores indica que o log circular está habilitado em um servidor de caixa de correio que contém mais de 20 caixas de correio. No log de transações padrão usado pelo Exchange 2000 Server, Exchange Server 2003 e Exchange Server 2007, cada transação de banco de dados em um grupo de armazenamento é gravada em um arquivo de log e, em seguida, no banco de dados. Quando um arquivo de log atinge determinado tamanho, ele é renomeado e um novo arquivo de log é criado. Com o tempo, isso resultará em um conjunto de arquivos de log. Se houver uma falha, você poderá recuperar as transações repetindo os dados desses arquivos de log no banco de dados.

O log circular substitui e reutiliza o primeiro arquivo de log depois que os dados contidos nele foram gravados no banco de dados. No Exchange 2000 Server, Exchange Server 2003 e Exchange Server 2007, o log circular está desabilitado, por padrão. Ao habilitá-lo, você reduz os requisitos de espaço de armazenamento da unidade, mas sem arquivos completos de log de transações, você não poderá recuperar nada que seja mais recente que o último backup completo. Portanto, em um ambiente de produção normal, o log circular não é recomendável.

Para corrigir esse aviso no Exchange 2000 Server e no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores e expanda o servidor a ser modificado.

  3. Clique com o botão direito no grupo que deseja modificar e clique em Propriedades.

  4. Na caixa de diálogo Propriedades, desmarque a caixa de seleção Habilitar log circular.

  5. Clique em OK para salvar a configuração.

  6. Feche o Gerenciador de Sistema do Exchange e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração tenha efeito.

Para corrigir esse aviso do Exchange Server 2007 usando o Console de Gerenciamento do Exchange

  1. Abra o Console de Gerenciamento do Exchange.

  2. Expanda Configuração do Servidor e expanda o servidor a ser modificado.

  3. Clique com o botão direito no grupo de armazenamento que deseja alterar e clique em Propriedades.

  4. Na caixa de diálogo Propriedades, desmarque a caixa de seleção Habilitar log circular.

  5. Clique em OK para salvar a configuração.

  6. Feche o Console de Gerenciamento do Exchange e reinicie o serviço de Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para corrigir esse aviso do Exchange Server 2007 usando o Shell de Gerenciamento do Exchange

  1. O código a seguir é um exemplo do comando Set-StorageGroup que desabilita o log circular do grupo de armazenamento 'MyStorageGroup'.
Código da Cópia
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $false
  • Para obter mais informações sobre log circular, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 147524, "Como o log circular afeta o uso de logs de transações" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 240145, "Como saber quais arquivos do log de transações podem ser removidos com segurança" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=240145) (em inglês)


Log circular desabilitado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-03-23

A ferramenta Microsoft Exchange Analyzer Tool consulta o serviço de diretório do Active Directory para determinar o valor configurado para o atributo msExchESEParamCircularLog.

Um valor igual a 1 para o atributo msExchESEParamCircularLog indica que o log circular está habilitado. Um valor igual a 0 para o atributo msExchESEParamCircularLog indica que o log circular está desabilitado.

O Exchange Analyzer determina também se as seguintes condições estão presentes:

  • O Exchange Server está configurado como servidor front-end.

  • O serviço SMTP está em execução e quantas caixas de correio estão configuradas.

Se detectar a presença das seguintes condições, o Exchange Analyzer exibirá um aviso:

  • O atributo msExchESEParamCircularLog está configurado com um valor igual a 0.

  • O servidor não está configurado como servidor front-end.

  • Menos de 20 caixas de correio estão configuradas.

No log de transações padrão usado pelo Exchange Server, cada transação de banco de dados em um grupo de armazenamento é gravada em um arquivo de log e, depois, no banco de dados. Quando um arquivo de log atinge determinado tamanho, ele é renomeado e um novo arquivo de log é criado. Com o tempo, esse log de transações padrão cria um conjunto de arquivos de log. Se o sistema falhar, você poderá recuperar as transações reproduzindo os dados desses arquivos de log no banco de dados.

O log circular substitui e reutiliza o primeiro arquivo de log depois que os dados contidos nele foram gravados no banco de dados. No Exchange Server, o log circular está desabilitado por padrão.

Importante:
A habilitação do log circular reduz os requisitos de espaço de armazenamento em unidades. Entretanto, se você não tiver arquivos de log de transações concluídas, não será possível recuperar nenhum dado mais recente do que o último backup completo. Por isso, em servidores de produção que contêm dados de caixa de correio ou de pasta pública, o log circular não é recomendado.

Em servidores front-end Exchange, servidores de roteamento de mensagens (também chamados de servidores de infra-estrutura) e servidores bridgehead que não têm caixas de correio nem pastas públicas de usuários, as únicas mensagens confirmadas são as notificações de falha na entrega. Portanto, não é necessário manter os arquivos de transações nesses servidores. Além disso, não há necessidade de fazer backup desses servidores. Se você habilitar o log circular em servidores que não hospedam caixas de correio do usuário, será possível substituir os arquivos de log de transações, e eles nunca excederão 20 MB de dados.

Para habilitar o log circular no Exchange 2000 Server e no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores e expanda um servidor Exchange.

  3. Clique com o botão direito no grupo de armazenamento no qual você deseja habilitar log circular e selecione Propriedades. A caixa de diálogo de propriedades do grupo de armazenamento será exibida.

  4. Marque a caixa de seleção Habilitar log circular e clique em OK para salvar as alterações.

  5. Feche o Gerenciador de Sistema do Exchange e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.
Para habilitar o log circular no Exchange Server 2007 utilizando o Console de Gerenciamento do Exchange

  1. Abra o Console de Gerenciamento do Exchange.

  2. Expanda Configuração do Servidor e expanda o servidor a ser modificado.

  3. Clique com o botão direito no grupo de armazenamento que deseja alterar e clique em Propriedades.

  4. Na caixa de diálogo Propriedades, marque a caixa de seleção Habilitar log circular.

  5. Clique em OK para salvar a configuração.

  6. Feche o Console de Gerenciamento do Exchange e reinicie o serviço de Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.
Para habilitar o log circular no Exchange Server 2007 utilizando o Shell de Gerenciamento do Exchange

  1. O código a seguir é um exemplo do comando Set-StorageGroup que habilita o log circular do grupo de armazenamento MyStorageGroup.
Código da Cópia
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $true

Para obter mais informações sobre log circular, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 258470, "XADM: Como modificar a configuração de log circular" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470) (em inglês)

  • 147524, "XADM: Como o log circular afeta o uso de logs de transações" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524) (em inglês)

  • 296788, "Procedimentos de restauração e backup offline para o Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788) (em inglês)

  • 314605, "Como ativar ou desativar o log circular no Exchange 2000 Server e no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605)


A compactação RPC de Cliente/Servidor está desabilitada.
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se a compactação RPC (chamada de procedimento remoto) está habilitada:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Rpc Compression Enabled

Se o Exchange Server Analyzer detectar que o valor de Rpc Compression Minimum Size está presente e configurado com um valor 0, será exibida uma mensagem de configuração não-padrão.

Por padrão, todos os dados RPC movidos entre o Microsoft Office Outlook® 2003 ou o Outlook 2007 e o Exchange Server 2003 ou o Exchange Server 2007 são compactados, independentemente do seu tamanho. Em alguns cenários, convém controlar a compactação RPC. Por exemplo, se você estiver tentando solucionar problemas de conectividade, exibindo os pacotes enviados pela rede, a compactação RPC pode dificultar o processo de análise, uma vez que você só vê os dados compactados no rastreamento.

Para configurar definições de compactação RPC, você pode adicionar três valores de chave de Registro às definições do sistema:

  • Tamanho Mínimo da Compactação RPC

  • Compactação RPC Habilitada

  • Empacotamento RPC Habilitado

O valor do Registro Rpc Compression Enabled determina se os algoritmos de compactação RPC são utilizados. Se esta chave não estiver presente, a compactação RPC será habilitada e utilizada.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Exclua a chave Rpc Compression Enabled. Se as chaves Rpc Compression Minimum Size e Rpc Packing Enabled estiverem presentes, exclua-as também.

  4. Feche o editor de Registro e reinicie o servidor Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como controlar a compactação RPC, consulte o artigo 825371 da Base de Dados de Conhecimento, "Modificar a compactação de chamada de procedimento remoto no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371).


O parâmetro ClientMonitoringReportLevel é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte chave do Registro para determinar como o Exchange Server 2003 monitora os dados de desempenho de rede para o Microsoft Office Outlook® 2003:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se o Exchange Server Analyzer detectar que o valor para a chave do Registro ClientMonitoringReportLevel não é 1, o Exchange Server Analyzer exibirá uma mensagem de configuração não-padrão.

O Exchange Server usa o valor da chave do Registro ClientMonitoringReportLevel para identificar os erros de rede e problemas de latência com os clientes do Outlook 2003. O valor da chave do Registro ClientMonitoringReportLevel tem três configurações possíveis.

Valor | Função
0 | Não coletar dados de desempenho de nenhum cliente do Outlook 2003.
1 | Coletar dados de desempenho apenas de clientes do Outlook 2003 que possuem conectividade de rede de alta velocidade.
2 | Coletar dados de desempenho de todos os Outlook 2003.

Quando você habilita a chave do Registro ClientMonitoringReportLevel com um valor de 1 ou 2, os clientes do Outlook 2003 enviam dados ao servidor. Os dados enviados para o servidor indicam o status e o estado da conexão de rede. Os dados enviados ao servidor incluem informações sobre as solicitações de RPC (chamada de procedimento remoto) com falha e condições do erro. O servidor agrega as informações e as expõe nas entradas do log de eventos.

A Instalação do Exchange não cria a chave do Registro ClientMonitoringReportLevel. Porém, o comportamento padrão no Exchange Server 2003 é coletar dados de desempenho somente de clientes do Outlook 2003 que possuem conectividade de rede de alta velocidade. Esse comportamento padrão do Exchange Server 2003 é funcionalmente o mesmo que quando o valor da chave do Registro ClientMonitoringReportLevel está definida como 1.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária. Porém, você pode editar o valor da chave do Registro ClientMonitoringReportLevel se desejar restaurar o valor padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, consulte o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para restaurar a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Clique duas vezes em ClientMonitoringReportLevel.

  4. No campo Dados do valor, digite 1 e clique em OK.

  5. Feche o editor de Registro.

O serviço Armazenamento de Informações do Microsoft Exchange detecta as alterações em minutos. Não é necessário reiniciar o computador.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Considere a implementação de cotas de armazenamento
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-03-21

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar se as quotas de caixa de correio foram definidas em cada objeto de banco de dados de mensagens private (MDB). Se o Analisador do Exchange Server detectar que um MDB privado particular contém mais de 20 caixas de correio e que as quotas não estão definidas no MDB, exibirá uma mensagem de configuração de Prática Recomendada.

É uma prática recomendada aplicar quotas a todos os bancos de dados nos computadores do Exchange Server que hospedam caixas de correio de usuário. Existem três limites que você deve configurar no nível de banco de dados. Os limites são configurados na guia Limites da página de propriedades de armazenamento de caixa de correio. Cada limite é expresso em KB (kilobytes)

  • Aviso O limite Issue warning define o tamanho da caixa de correio que aciona um email de aviso para o usuário. O email de aviso informa ao usuário que o tamanho da caixa de correio está se aproximando do limite Prohibit send.

  • Proibir envio O limite Prohibit send define o tamanho da caixa de correio que impede que um usuário envie emails. O usuário receberá um email do servidor Exchange explicando que o limite de tamanho da caixa de correio foi excedido.

  • Proibir envio e recebimento O limite Prohibit send and receive define o tamanho da caixa de correio que impede que um usuário envie e receba emails. Todo email enviado pra o usuário é retornado para o remetente com uma notificação de falha na entrega.

Ao configurar essas regras, verifique se está fornecendo um delta suficientemente amplo entre o limite de envio Proibido e o limite de envio e recebimento Proibidos. Se o delta entre os dois limites for muito pequeno, a caixa de correio poderá rejeitar as mensagens antes que o usuário tenha a oportunidade de limpá-la. Portanto, a prática recomendada é fornecer um buffer de pelo menos 20% entre o limite de envio Proibido e o limite de envio e recebimento Proibidos. Por exemplo, se os usuários forem proibidos de enviar novas mensagens quando suas caixas de correio atingirem 100 MB, o limite de envio e recebimento Proibidos deverá ser de pelo menos 120 MB.

Para definir os limites de caixa de correio para o Exchange 2000 Server e o Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Localize o armazenamento de caixa de correio no Analisador do Exchange Server referente a esse problema.

  3. Clique com o botão direito em MailboxStore_Name e selecione Propriedades.

  4. Selecione a guia Limites.

  5. Modifique o Aviso de problema em (KB), o limite Proibir envio em (KB) e o limite Proibir envio e recebimento em (KB).

  6. Clique em Aplicar e em OK.
Para definir limites de caixa de correio no Exchange Server 2007 usando o Console de Gerenciamento do Exchange

  1. Abra o Console de Gerenciamento do Exchange

  2. Localize o armazenamento de caixa de correio no Analisador do Exchange Server referente a esse problema.

  3. Clique com o botão direito em MailboxStore_Name e selecione Propriedades.

  4. Selecione a guia Limites.

  5. Modifique o Aviso de problema em (KB), o limite Proibir envio em (KB) e o limite Proibir envio e recebimento em (KB).

  6. Clique em Aplicar e em OK
Para definir limites de caixa de correio no Exchange Server 2007 usando o Shell de Gerenciamento do Exchange

  1. O exemplo a seguir mostra como definir o tamanho de caixa de correio no qual uma mensagem de aviso é enviada ao usuário. O atributo se aplica a todas as caixas de correio desse banco de dados de caixa de correio que não possuam seu próprio conjunto de atributos de cota de avisos. Você deve especificar um inteiro ou "ilimitado." O valor padrão é 1,9 GB (gigabytes).

    Código da Cópia
    Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680

  2. O exemplo a seguir mostra como definir o tamanho da caixa de correio a partir do qual usuários associados a caixas de correio desse banco de dados de caixa de correio não poderão mais enviar mensagens. Esse atributo se aplica a todas as caixas de correio desse banco de dados de caixa de correio que não possuam seu próprio conjunto de atributos de cota de proibição de envio. O valor de limite definido deve ser um inteiro ou "ilimitado".

    Código da Cópia
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152

  3. O exemplo a seguir mostra como definir o tamanho de caixa de correio a partir do qual o usuário associado a essa caixa de correio não poderá mais enviar ou receber mensagens. O atributo se aplica a todas as caixas de correio desse banco de dados de caixa de correio que não possuam seu próprio conjunto de atributos de cota de proibição de envio e recebimento. Você deve especificar um inteiro ou "ilimitado."

    Código da Cópia
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

Para obter mais informações sobre como gerenciar as caixas de correio do Exchange no Exchange Server 2003, consulte Trabalhando com armazenamentos do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).

Para obter mais informações sobre como gerenciar os limites de caixa de correio do Exchange no Exchange Server 2007, consulte "Como configurar limites e propriedades de bancos de dados" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80746)


A Indexação de Conteúdo foi habilitada nesse armazenamento de caixa de correio
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo Agendamento de Reconstrução da Indexação de Conteúdo (msExchCIRebuildSchedule) foi definido como algum valor não-nulo e se o atributo Estilo de Reconstrução da Indexação de Conteúdo (msExchCIRebuildStyle) foi definido. Esses atributos estão presentes em bancos de dados de caixa de correio particular. Se o Exchange Server Analyzer detectar que esses dois atributos estão configurados para indexação, um aviso será exibido.

Não é recomendável realizar a execução da indexação de conteúdo, também conhecida como "indexação de texto completo", em um armazenamento de caixa de correio, pois consome muitos recursos e os dados da caixa de correio são alterados com freqüência. Portanto, manter um índice atualizado em um determinado banco de dados é um processo que utiliza muitos recursos. A indexação de texto completo é mais compatível com pastas públicas.

Se você quiser executar a indexação de texto completo em um armazenamento de caixa de correio, é recomendável que defina o agendamento da indexação para atualizar e monitorar freqüentemente o desempenho do computador. Isso garante que ele não ficará sobrecarregado e que continuará sendo capaz de entregar emails e responder a solicitações de clientes durante a indexação de conteúdo.

Se não fizer isso, é recomendável que você desabilite a indexação de texto completo excluindo o índice de texto completo do armazenamento de caixa de correio.

Para desabilitar a indexação de texto completo em um determinado armazenamento de caixa de correio

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos, expanda seu grupo administrativo, expanda Servidores, expanda seu servidor, expanda seu grupo de armazenamento, clique com o botão direito em Armazenamento de Caixa de Correio e, em seguida, clique em Excluir Indexação de Texto Completo.

Para obter mais informações sobre como configurar e solucionar problemas de indexação de texto completo no Exchange, consulte o artigo da Base de Dados de Conhecimento Microsoft, "COMO: Configurar a Indexação de Texto Completo em Armazenamentos de Caixa de Correio no Exchange 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932).


Indexação de Conteúdo foi habilitada nesse armazenamento de Pasta Pública
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o atributo do Agendamento de Reconstrução de Indexação de Conteúdo (msExchCIRebuildSchedule) e o atributo do Estilo de Reconstrução de Indexação de Conteúdo (msExchCIRebuildStyle) estão presentes e definidos como um valor diferente de 0. Esses são atributos de cada banco de dados do armazenamento de informações públicas.

Se o Exchange Server Analyzer confirmar a presença desses dois atributos e sua configuração com um valor diferente de 0, será exibida uma mensagem de configuração não-padrão.

Quando esses dois atributos estiverem definidos como 1, isso indicará que a indexação de texto completo foi habilitada para o banco de dados de armazenamento de informações. A indexação de texto completo permite pesquisas avançadas e rápidas, indexando cada palavra em um banco de dados especificado. Ao implantar a indexação de texto completo, você seleciona um armazenamento individual de pasta pública ou de caixa de correio para indexação. Em seguida, os usuários podem conduzir pesquisas de texto completo nas mensagens e nos anexos contidos no armazenamento de pasta pública ou de caixa de correio.

Por padrão, o índice contém o assunto e o corpo de uma mensagem, juntamente com os nomes do remetente e destinatário, e todos os nomes que constarem nos campos Cc e Cco. O índice também contém texto dos seguintes tipos de anexos: arquivos .doc, .xls, .ppt, .html, .htm, .asp, .txt e .eml (mensagens MIME [Multipurpose Internet Mail Extensions] internas). Anexos binários, como imagens e sons, não são indexados.

A precisão dos resultados da pesquisa está relacionada à última atualização do índice. À medida que o conteúdo dos armazenamentos de pastas públicas ou de caixas de correio é alterado, o índice deve ser atualizado para incluir o novo conteúdo. As atualizações do índice podem ser executadas manual ou automaticamente em uma agenda.

Há quatro categorias principais de arquivos de indexação de texto completo. É possível otimizar o desempenho da indexação de texto completo, organizando o local desses arquivos no disco, como a seguir:

  • Catálogos Os catálogos são os índices principais. Pode haver somente um catálogo para cada armazenamento do Exchange. Coloque seu catálogo em uma matriz de RAID-0+1. Você pode especificar o local do catálogo no Gerenciador do Sistema do Exchange ao criar o catálogo.

  • Armazenamento de propriedades É o banco de dados que contém diversas propriedades de itens indexados no catálogo. Existe apenas um armazenamento de propriedades por servidor. Coloque o armazenamento de propriedades de texto completo em uma matriz RAID. Por padrão, os arquivos são instalados na mesma unidade que o Exchange Server.

  • Arquivos temporários Esses arquivos contêm informações temporárias usadas pelo serviço Pesquisa da Microsoft. Coloque o diretório temporário de índice de texto completo na matriz RAID. Por padrão, esses arquivos são instalados na unidade do sistema, que geralmente não dispõe da taxa de transferência de E/S da matriz RAID.

  • Logs coletores Esses arquivos contêm informações do log para o serviço de indexação. Existe um conjunto de logs para cada catálogo. Os logs coletores podem permanecer no local padrão ou você pode movê-los, se preferir.

Para habilitar ou desabilitar a indexação de texto completo

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange e depois expanda o grupo de armazenamento que contém o armazenamento de pasta pública com o qual você está trabalhando.

  3. Clique com o botão direito no armazenamento de pasta pública e selecione Propriedades.

  4. Selecione a guia Indexação de Texto Completo.

  5. Edite o campo Intervalo de atualização como desejar.

  6. Clique em OK para salvar as alterações e saia das Propriedades do armazenamento de pasta pública.

Para obter mais informações sobre as pastas públicas de indexação de texto completo, consulte o artigo 319433 da Base de Dados de Conhecimento Microsoft, "COMO: Configurar indexação de texto completo em pastas públicas" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319433) (página em inglês).

Para obter mais informações sobre como configurar e solucionar problemas de indexação de texto completo em armazenamentos de caixa de correio, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 822932, "COMO FAZER PARA: Configurar indexação de texto completo em armazenamentos de caixas de correio no Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822932) (página em inglês).

  • 319436, "COMO FAZER PARA: Configurar indexação de texto completo em armazenamentos de caixas de correio no Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436) (página em inglês).

Para obter informações sobre a indexação de texto completo em um ambientes de vários idiomas, consulte o artigo 325624 da Base de Dados de Conhecimento Microsoft, "XGEN: Indexação de texto completo com vários idiomas" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325624) (página em inglês).

Para obter mais informações sobre as práticas recomendadas de indexação de texto completo, consulte o artigo 326186 da Base de Dados de Conhecimento Microsoft, "XADM: Informe oficial - Práticas recomendadas para implantar a indexação de texto completo" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326186) (página em inglês).


As notificações de status de entrega estão sendo processadas como mensagens
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-03-21

A Ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar se as DSNs (notificações de status de entrega) no computador do Exchange Server estão sendo processadas como mensagens padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\RenderDSNsAsMessages

Se o Exchange Server Analyzer verificar que a entrada do Registro RenderDSNsAsMessages está presente e configurada com um valor maior que 0, uma mensagem de configuração não padrão será exibida.

Como o nome indica, a entrada do Registro RenderDSNsAsMessages representa uma oportunidade de configuração que permite aos administradores controlar como as DSNs são processadas em computadores do Exchange 2000 Server, Exchange Server 2003 e Exchange Server 2007:

  • Se os dados do valor em RenderDSNsAsMessages estiverem definidos como 0, as DSNs (que incluem notificações de entrega e falhas de entrega) são processadas como mensagens MAPI padrão.

  • Se os dados do valor de RenderDSNsAsMessages estiverem definidor como um valor maior que 0, as DSNs são processadas como mensagens MIME com diversas partes ou mistas.

Esse valor do registro não está presente por padrão e precisa ser adicionado manualmente para ser usado. Além disso, para que a entrada tenha o efeito adequado em um Exchange 2000 Server, o computador deve estar executando no mínimo a Distribuição Pós-Service Pack 3 de setembro de 2003 do Exchange 2000 Server.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. Exclua a entrada do Registro RenderDSNsAsMessages .

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.
  • Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

  • Para obter mais informações sobre problemas de formato de notificações de status de entrega, consulte o artigo 812806 da Base de Dados de Conhecimento, "Inesperadamente, o usuário do Exchange recebe uma notificação de falha na entrega padrão, em vez de uma notificação de falha na entrega personalizada" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812806).

  • Para obter mais informações sobre a Distribuição Pós-Service Pack 3 de setembro de 2003 do Exchange 2000 Server, consulte o artigo 824282 da Base de Dados de Conhecimento, "Distribuição Pós-Service Pack 3 de setembro de 2003 do Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824282).


Intervalo de Tempo de Manutenção de Envelhecimento do Banco de Dados foi modificado em relação ao padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar se o valor de envelhecimento padrão dos índices de banco de dados de exibição do cliente do Exchange foi substituído:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nome do servidor>\Private-<GUID de Armazenamento de Informações Particulares>\Aging Keep Time

Se o Exchange Server Analyzer descobrir que a entrada do Registro Tempo de Duração de Armazenamento está presente e configurada, uma mensagem de configuração não padrão será exibida.

Os índices usados para exibições criadas por cliente nas tabelas de bancos de dados do Exchange que não tenham sido utilizados por um determinado período serão limpos neste momento. As seguintes entradas do Registro são usadas para controlar o envelhecimento de índices:

  • Tempo de Duração de Armazenamento O envelhecimento mínimo do índice antes que ele seja excluído. O padrão é 8 dias para o Exchange Server 5.5 e 40 dias para o Exchange 2000 Server, o Exchange Server 2003 e o Exchange Server 2007.

  • Intervalo de Limpeza de Envelhecimento O intervalo de tempo mínimo (milissegundos) entre as execuções de tarefas de envelhecimento de índice. O padrão é 24 horas.

  • Visualizações de Redefinição Se essa configuração existir e for diferente de zero, todos os índices armazenados em cache serão excluídos durante a execução seguinte de tarefas de envelhecimento de índice. Quando o envelhecimento do índice for concluído, o valor de Visualizações de Redefinição será definido como 0.

Não é recomendável que você adicione o valor do Registro Tempo de Duração de Armazenamento, a não ser que seja orientado a fazer isso pelo Atendimento Microsoft.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para exibir ou modificar o valor do Registro Aging Keep Time

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nome do servidor>\Private-<GUID de Armazenamento de Informações Particulares>

  3. Examine e, se desejar, altere o valor de Tempo de Duração de Armazenamento.

  4. Feche o editor de Registro. Se for feita uma alteração, reinicie o computador do Exchange Server para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Arquivos de banco de dados e de log armazenados no mesmo volume de disco
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se os arquivos do banco de dados para esse armazenamento de caixa de correio residem no mesmo disco físico que os arquivos de log de transações para esse grupo de armazenamento. Especificamente, o Exchange Server Analyzer consulta o Active Directory para que ele determine o seguinte:

  • Se o armazenamento de caixa de correio tiver mais de 100 caixas de correio, determinado pela contagem dos valores do atributo homeMDBBL do objeto de armazenamento de caixa de correio (classe msExchPrivateMDB). Se o armazenamento de caixa de correio tiver menos de 100 caixas de correio, o impacto de desempenho do local do arquivo será limitado.

  • O caminho dos arquivos do banco de dados para o armazenamento de caixa de correio, determinados pela leitura do valor de msExchEDBFile do objeto de armazenamento da caixa de correio.

  • O caminho dos arquivos de log de transações do grupo de armazenamento, determinados pela leitura do valor de msExchESEParamLogFilePath do objeto de grupo de armazenamento (classe msExchStorageGroup).

  • Se esse caminho em msExchESEParamLogFilePath está no mesmo disco que o caminho em msExchEDBFile.

Além disso, o Exchange Server Analyzer determina o seguinte:

  • Se as extensões do Exchange Server para o NAS com Windows estão sendo executadas no servidor, determinadas ao consultar a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) em busca do valor do atributo Started para as extensões NAS do Exchange Server (wssexchmap). Se as extensões do Exchange Server para o NAS com Windows estiverem sendo executadas, isso significa que os arquivos que estão sendo considerados podem não estar em uma unidade local e que considerações sobre desempenho podem não se aplicar.

  • É possível que os arquivos estejam em um volume de disco com nome mais longo do que três caracteres, determinado consultando a classe Win32_Volume do WMI. Novamente, isso pode significar que os arquivos podem não estar em uma unidade local e que considerações sobre desempenho podem não se aplicar.

Para fornecer tolerância a falhas em caso de falhas no disco rígido, mantenha os arquivos de log de transações do Exchange e arquivos de banco de dados em discos rígidos físicos separados. Quando você mantém esses arquivos de log e arquivos de banco de dados em discos rígidos separados, você pode aumentar significativamente o desempenho de E/S do disco rígido.

Observação:
Para fornecer tolerância a falhas em caso de um banco de dados precisar ser restaurado, cada grupo de armazenamento tem seu próprio conjunto de arquivos de log de transações. Arquivos de log de transações mantêm um registro de todas as alterações feitas em todos os bancos de dados desse grupo de armazenamento. Arquivos de log de armazenamento não são excluídos até que seja feito um backup completo de todos os bancos de dados em um grupo de armazenamento.

Os exemplos a seguir ilustram como recuperar dados mesmo em circunstâncias extremas (como perda de um disco rígido que contenha seus arquivos de bancos de dados ou seus arquivos de log de transações) se você tiver um backup e seus arquivos de log de transações estiverem em um disco separado.

  • Se o disco rígido que contém seus arquivos de bancos de dados falhar, você poderá substituir o disco rígido com falha, restaurar o backup mais recente dos arquivos do banco de dados e usar os arquivos de log atuais que foram armazenados em um disco rígido separado para restaurar os dados em seu servidor Exchange e atualizá-lo para o momento em que o disco rígido falhou.

  • Se o disco rígido que contém seus logs de transações falhar mas o disco rígido que contém seus arquivos de banco de dados estiver funcional, e se o arquivo de armazenamento de banco de dados for encerrado normalmente, você poderá reparar o disco de log de transações com falha e remontar o armazenamento de banco de dados. Se o arquivo de armazenamento do banco de dados não for encerrado normalmente, ele ficará em um estado inconsistente e poderá ser montado apenas depois de um reparo usando eseutil.exe, o que poderá resultar em perda de alguns dados. A outra opção é restaurar o arquivo de armazenamento do banco de dados que não incluirão novos dados de caixa de correio criados depois do momento do backup.

Importante:
Se você mantiver os bancos de dados e os arquivos de log de transações do Exchange no mesmo disco rígido físico e esse disco rígido falhar, você perderá os dados criados depois do seu último backup.

Além disso, colocar arquivos de banco de dados e arquivos de log de transações em discos físicos separados aumenta o desempenho geral. O Exchange grava cada transação no arquivo de log de transações em primeiro lugar, e depois no arquivo de banco de dados. Além disso, os arquivos de log de transações são compartilhados por todos os armazenamentos de caixa de correio no grupo de armazenamento. Quando esses arquivos estão no mesmo disco físico, o cabeçote da unidade precisa se mover em vaivém entre o local do arquivo do log de transações atual e os locais dos arquivos de banco de dados para realizar as operações de gravação. Quando os arquivos estão em discos separados, o cabeçote de uma unidade fica em posição para gravação no arquivo de log de transações, de modo que as transações possam ser realizadas mais rapidamente do que quando os arquivos estão em um único disco. A diferença de desempenho para uma única transação é pequena, mas pode se tornar perceptível quando a carga do sistema é alta.

Para corrigir a configuração, você pode mover os arquivos de log de transações ou os arquivos de banco de dados.

Para mover os arquivos de log de transações para uma nova unidade no Exchange 2000 Server ou Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, expanda o objeto de servidor do Exchange adequado, clique com o botão direito no grupo de armazenamento desejado e clique em Propriedades.

  2. Na guia Geral especifique um novo local para os arquivos.

    Por exemplo, se a unidade E:\ contiver apenas arquivos de log para esse grupo de armazenamento, em Local do log de transações, clique em Procurar e selecione a unidade E:\.

Para alterar o local de arquivos de log de transações do grupo de armazenamento do Exchange para o Exchange Server 2007

  1. Siga as orientações contidas na documentação principal do Exchange Server 2007, "Como definir ou alterar o local de arquivos de log do Grupo de Armazenamento" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80702).

Para mover os arquivos de banco de dados para uma nova unidade no Exchange 2000 Server ou Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, expanda o objeto do servidor Exchange no qual reside o armazenamento, expanda o contêiner do grupo de armazenamento apropriado, clique com o botão direito no objeto do armazenamento desejado e clique em Propriedades.

  2. Especifique novos locais de arquivo na guia Banco de dados da caixa de diálogo Propriedades.
Cuidado:
Para mover um arquivo de banco de dados, o banco de dados deverá ser temporariamente desmontado e então remontado. Isso é feito automaticamente pelo assistente, mas o banco de dados fica inacessível para todos os usuários durante o processo.

Para mover os arquivos de banco de dados para uma nova unidade no Exchange Server 2007 usando o assistente para Mover Caminho do Banco de Dados

  1. Inicie o Console de Gerenciamento do Exchange no servidor em que o grupo de armazenamento está localizado.

  2. Na árvore do console, expanda Configuração do Servidor e clique em Caixa de Correio.

  3. No painel de resultados, expanda o contêiner do grupo de armazenamento apropriado, clique com o botão direito no objeto de banco de dados de caixa de correio desejado e clique em Mover Caminho do Banco de Dados. O assistente para Mover Caminho do Banco de Dados é exibido.

  4. Na página Introdução, a caixa Caminho dos arquivos de banco de dados exibe o local em que os arquivos de banco de dados estão armazenados atualmente. Clique em Procurar para especificar um local para o qual deseja mover esses arquivos.

  5. Clique em Mover.

  6. Na página Conclusão, confirme se o caminho do arquivo de banco de dados foi alterado com sucesso. Um status de Concluído indica que o assistente concluiu a tarefa com êxito. Um status de Falha indica que a tarefa não foi concluída. Se a tarefa falhar, reveja o resumo para obter uma explicação e, em seguida, clique em Voltar para fazer quaisquer alterações na configuração. Clique em Concluir para finalizar o assistente para Mover Caminho do Banco de Dados.
Observação:
Também é possível utilizar o Shell de Gerenciamento do Exchange para mover arquivos de banco de dados no Exchange Server 2007. Para obter mais informações, consulte Move-DatabasePath.

Para obter mais informações sobre arquivos de banco de dados do Exchange Server, consulte os seguintes tópicos:

  • "Gerenciando armazenamentos de caixas de correio e de pastas públicas" no Guia da Administração do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47617)

  • "Compreendendo o armazenamento do Exchange Server 2003" em Trabalhando com o armazenamento do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595)

Para obter mais informações sobre como gerenciar arquivos de banco de dados do Exchange Server, consulte o artigo 328794 da Base de Dados de Conhecimento da Microsoft, "Como proteger os dados do Exchange de falhas no disco rígido" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328794)

Para obter mais informações sobre como reparar armazenamentos de banco de dados do Exchange, consulte o artigo 296788 da Base de Dados de Conhecimento, "Procedimentos de backup e restauração offline para o Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788).

Para obter mais informações sobre como executar um reparo em um arquivo de armazenamento de banco de dados do Exchange, consulte o artigo 810190 da Base de Dados de Conhecimento, "XADM: a mensagem de erro 'o armazenamento de informações foi encerrado de forma anormal' e o evento 447 foi registrado" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810190).


Banco de dados possui todos os arquivos de log
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool determinou que todos os arquivos de log necessários para recuperar esse banco de dados existem e estão no local correto para a recuperação. Portanto, a falha na recuperação não é causada por um arquivo de log de transações ausente ou não correspondente.

É possível que os bancos de dados ou arquivos de log de transações estejam danificados ou que outros arquivos estejam interferindo no processo de recuperação.

Para corrigir esse erro

  • Use o Gerenciador do Sistema do Exchange para montar um dos bancos de dados no grupo de armazenamento e exiba o log de aplicativos para erros que possam indicar o motivo da falha.

  • Recupere o banco de dados isoladamente. Após a análise do banco de dados, o Exchange Server Analyzer exibirá as instruções para a recuperação isolada do banco de dados.

  • Execute o Eseutil.exe /ML para verificar a integridade dos arquivos de log necessários. Para obter mais informações sobre como usar o Eseutil, consulte o artigo 248122 da Base de Dados de Conhecimento da Microsoft, "Como usar o Eseutil para testar os arquivos de transação de teste em caso de danos no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=248122).


O banco de dados está em um estado de desligamento normal
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer determinou que seu Banco de Dados do Exchange está em um estado de Desligamento Normal.

Um banco de dados que está em um estado de Desligamento Normal foi encerrado corretamente e desanexado do fluxo de arquivo de log. Como resultado, se você quiser montar o banco de dados novamente, você poderá fazê-lo sem executar nenhuma operação de recuperação.

Se você não conseguir montar um banco de dados que está em estado de Desligamento Normal, o motivo é porque o banco de dados exige repetição adicional do arquivo de log de transações. No entanto, é possível que a repetição de log de transações necessária para outros bancos de dados no mesmo grupo de armazenamento impeça a montagem de um banco de dados em estado de Desligamento Normal. Antes de montar qualquer banco de dados em um grupo de armazenamento do Exchange, todos os bancos de dados nesse grupo de armazenamento devem ser recuperados e colocados em estado montável.

Um banco de dados em estado de Desligamento Normal pode ser montado com seus logs de transações anteriores ou com um conjunto diferente de logs de transações. Se você montar um banco de dados em estado de Desligamento Normal e não houver logs de transações, um novo conjunto de logs de transações será gerado.

Observação:
Normalmente, você não deve excluir arquivos de log de transações existentes, mesmo que todos os bancos de dados em um grupo de armazenamento estejam em um estado de Desligamento Normal. Se você excluir arquivos de log de transações existentes, não será possível rolar para frente a partir de backups anteriores. No entanto, a exclusão de arquivos de log de transações, quando todos os bancos de dados em um grupo de armazenamento estiverem em um estado de Desligamento Normal, não afeta os bancos de dados atuais. Como prática recomendada, se você excluir todos os arquivos de log de transações de um grupo de armazenamento, você deverá criar imediatamente um backup completo de todos os bancos de dados no grupo de armazenamento.


O banco de dados está em um estado de 'Desligamento Anormal' e nenhum log é necessário
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-08-10

A ferramenta Microsoft® Exchange Server Analyzer determinou que seu banco de dados está em um estado de Desligamento Anormal.

Por definição, um banco de dados em um estado de Desligamento Anormal exige a repetição de pelo menos um arquivo de log de transações. O Desligamento Anormal não é um estado montável para o banco de dados e não deve ocorrer durante a operação geral.

Para corrigir esse erro

  • Para obter uma análise avançada dos arquivos do banco de dados e de log, entre em contato com o Centro de Ajuda e Suporte da Microsoft (http://go.microsoft.com/fwlink/?linkid=3052&kbid=31845).


O banco de dados está em estado desconhecido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server detectou um estado desconhecido em seu banco de dados. Normalmente, os bancos de dados devem estar em um estado de Desligamento Normal ou de Desligamento Anormal. (No Exchange 2000 Server e versões anteriores, esses estados são chamados Consistentes ou Inconsistentes, respectivamente.)

Para corrigir esse erro

  • Para obter uma análise avançada do estado do banco de dados, entre em contato com a Ajuda e Suporte da Microsoft (http://go.microsoft.com/fwlink/?LinkId=31845).


Arquivos de log opcionais e necessários ausentes no banco de dados
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool determinou que os arquivos de log necessários para recuperar esse banco de dados não foram encontrados na pasta de arquivos de log. Se um arquivo de log necessário estiver ausente, o banco de dados não poderá ser recuperado até que o arquivo de log seja encontrado.

Se um banco de dados do Exchange não tiver sido encerrado corretamente, sempre há arquivos de log que precisam ser repetidos no banco de dados antes que ele possa ser montado novamente. No mínimo, pode haver apenas um arquivo de log que precisará ser repetido. No entanto, geralmente há vários arquivos de log.

Além dos arquivos de log necessários, pode haver outros arquivos de log que podem ser executados no banco de dados. Embora, não seja necessário que esses arquivos de log opcionais sejam reexecutados antes que o banco de dados possa ser montado, você poderá usar esses arquivos de log para recuperar dados adicionais. Se você não repetir esses arquivos de log opcionais, todos os dados contidos neles serão perdidos.

Para corrigir esse erro

  • Localize os arquivos de log de transações ausentes e adicione-os à pasta apropriada.

  • Se não for possível localizar todos os arquivos de log opcionais, você poderá recuperar o banco de dados em isolamento com apenas os arquivos de log necessários. Para recuperar o banco de dados sem os arquivos de log opcionais, siga as instruções no Exchange Server Analyzer. Lembre-se, se você recuperar o banco de dados sem os arquivos de log opcionais, perderá os dados que estavam nesses arquivos opcionais.

    Entretanto, dependendo do arquivo de log que está ausente, você pode repetir alguns dos arquivos de log opcionais no banco de dados. Por exemplo, considere a situação a seguir. Você tem arquivos de log numerados de um a dez. O décimo arquivo de log é obrigatório (os arquivos restantes são opcionais), o sexto arquivo de log está ausente. Nesse caso, você conseguirá repetir os arquivos de log numerados de sete a dez, porque a ordem seqüencial até o arquivo obrigatório é constante.

  • Repare o banco de dados atual.

    Observação:
    Embora o reparo do banco de dados provavelmente resulte em sucesso, isso não é garantido. Mesmo um reparo com êxito pode resultar em uma maior ou menor perda de dados. Para obter mais informações sobre como reparar um banco de dados do Exchange, consulte o artigo 812357 da Base de Dados de Conhecimento Microsoft, "Como atualizar seu banco de dados do Exchange após repará-lo usando a ferramenta Eseutil /p no Exchange Server 5.5, no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357).

  • Implemente uma estratégia híbrida que inclua o reparo e a restauração do banco de dados. Algumas vezes, você pode restaurar um banco de dados, mesmo que ele não possa ser rolado para frente com arquivos de log adicionais. Nesses casos, você pode restaurar uma cópia anterior do banco de dados enquanto repara simultaneamente a cópia atual que não é montável. Em seguida, você pode mesclar o conteúdo dos bancos de dados para maximizar a recuperação dos dados. Essa é uma estratégia avançada e você pode entrar em contato com o Centro de Ajuda e Suporte da Microsoft (http://go.microsoft.com/fwlink/?LinkId=31845) antes da implementação. Para obter mais informações sobre essa estratégia, consulte Usando grupos de armazenamento de recuperação no Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589) (em inglês).


Arquivos de log opcionais estão ausentes no banco de dados, mas não possui os arquivos de log necessários
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer verificou que um de seus bancos de dados não foi encerrado corretamente.

Se um banco de dados do Exchange não tiver sido encerrado corretamente, sempre há arquivos de log que precisam ser repetidos no banco de dados antes que ele possa ser montado novamente. No mínimo, pode haver apenas um arquivo de log que precisará ser repetido. No entanto, geralmente há vários arquivos de log.

Além dos arquivos de log necessários, pode haver outros arquivos de log que podem ser executados no banco de dados. Apesar de não ser necessário repetir esses arquivos de log opcionais antes do banco de dados ser montado, você pode usá-los para recuperar dados adicionais. Se você não repetir esses arquivos de log opcionais, todos os dados contidos neles serão perdidos.

Para corrigir esse erro

  • Localize os arquivos de log opcionais ausentes e copie-os para a pasta de log de transação.

  • Se não for possível localizar todos os arquivos de log opcionais, você poderá recuperar o banco de dados em isolamento com apenas os arquivos de log necessários. Para recuperar o banco de dados sem os arquivos de log opcionais, siga as instruções no Exchange Server Analyzer. Lembre-se, se você recuperar o banco de dados sem os arquivos de log opcionais, perderá os dados que estavam nesses arquivos opcionais.

    Entretanto, dependendo do arquivo de log que está ausente, você pode repetir alguns dos arquivos de log opcionais no banco de dados. Por exemplo, considere a situação a seguir. Você tem arquivos de log numerados de um a dez. O décimo arquivo de log é obrigatório (os arquivos restantes são opcionais), o sexto arquivo de log está ausente. Nesse caso, você conseguirá repetir os arquivos de log numerados de sete a dez, porque a ordem seqüencial até o arquivo obrigatório é constante.


Arquivos de log necessários ausentes do banco de dados
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer determinou que arquivos de log necessários para a recuperação deste banco de dados não foram encontrados na pasta do arquivo de log. Se um arquivo de log necessário estiver ausente, o banco de dados não poderá ser recuperado até que o arquivo de log seja encontrado.

Para corrigir esse erro

  • Localize os arquivos de log de transações ausentes e adicione-os à pasta apropriada.

  • Restaure o banco de dados a partir do backup. Em seguida, reverta o banco de dados reproduzindo os arquivos de log de transações restantes no banco de dados.

    Importante:
    Os dados no arquivo de log ausente e nos arquivos de log subseqüentes serão perdidos. Antes de restaurar um banco de dados a partir do backup, você deve salvar uma cópia do banco de dados atual. Se a restauração não for bem-sucedida, você poderá reparar o banco de dados atual.

  • Repare o banco de dados atual.

    Observação:
    Embora o reparo do banco de dados provavelmente resulte em sucesso, isso não é garantido. Mesmo um reparo com êxito pode resultar em uma maior ou menor perda de dados. Para obter mais informações sobre como reparar um banco de dados do Exchange, consulte o artigo 812357 da Base de Dados de Conhecimento Microsoft, "How to maintain your Exchange database after you repair by using the Eseutil /p tool in Exchange Server 5.5, in Exchange 2000 Server, and in Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357).

  • Implemente uma estratégia híbrida que inclua o reparo e a restauração do banco de dados. Algumas vezes, você pode restaurar um banco de dados, mesmo que ele não possa ser rolado para frente com arquivos de log adicionais. Nesses casos, você pode restaurar uma cópia anterior do banco de dados enquanto repara simultaneamente a cópia atual que não é montável. Em seguida, você pode mesclar o conteúdo dos bancos de dados para maximizar a recuperação dos dados. Essa é uma estratégia avançada e você pode entrar em contato com o Centro de Ajuda e Suporte da Microsoft (http://go.microsoft.com/fwlink/?LinkId=31845) antes da implementação. Para obter mais informações sobre essa estratégia, consulte Usando grupos de armazenamento de recuperação no Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589) (em inglês).


Os bancos de dados desse grupo de armazenamento são definidos como zero páginas durante o backup
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchESEParamZeroDatabaseDuringBackup de cada grupo de armazenamento no servidor. Se o Exchange Server Analyzer detectar que o atributo msExchESEParamZeroDatabaseDuringBackup está definido como 1, a ferramenta Exchange Server Analyzer Tool exibirá uma mensagem de configuração não-padrão.

O atributo msExchESEParamZeroDatabaseDuringBackup representa uma definição de configuração que permite a substituição dos registros/valores longos excluídos com zeros durante o backup. Este é um processo conhecido como zerar. Você pode controlar o processo de zerar páginas do banco de dados no nível de grupo de armazenamento. Cada grupo de armazenamento pode ter uma diretiva distinta para zerar as páginas excluídas do banco de dados.

Por padrão, o processo de zerar está desabilitado e o valor do atributo msExchESEParamZeroDatabaseDuringBackup está definido como 0. Quando o atributo está definido como 1, as páginas excluídas do banco de dados são substituídas por outros caracteres no final dos backups online de qualquer um dos bancos de dados desse grupo de armazenamento.

É possível habilitar e desabilitar o processo de zerar no Exchange 2000 Server e no Exchange Server 2003 usando o Gerenciador do Sistema do Exchange, como descrito neste artigo. É possível habilitar e desabilitar o processo de zerar no Exchange Server 2007 usando o Shell de Gerenciamento do Exchange, como descrito neste artigo. Embora essa opção proporcione mais segurança, ela afeta o desempenho do servidor.

Observação Se você habilitar o processo de zerar em um computador do Exchange 2000 Server, será recomendável instalar o Exchange 2000 Server Service Pack 3 ou uma versão posterior. O Service Pack 3 corrige um problema conhecido que pode fazer com que o Armazenamento de Informações do Exchange pare de responder. Para obter mais informações sobre esse problema, consulte o artigo 320883 da Base de Dados de Conhecimento da Microsoft, "XADM: O Armazenamento de Informações não responderá mais durante o backup online se o processo de zerar do banco de dados estiver habilitado" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320883).

Para habilitar ou desabilitar o processo de zerar no Exchange 2000 Server e no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores e expanda o servidor a ser modificado.

  3. Clique com o botão direito no grupo que deseja modificar e clique em Propriedades.

  4. Na caixa de diálogo Propriedades, marque ou desmarque a caixa de seleção Zerar páginas excluídas do banco de dados, conforme for necessário. Marcar a caixa de seleção habilita o processo de zerar e desmarcá-la desabilita esse processo.

  5. Clique em OK para salvar a configuração.

  6. Feche o Gerenciador do Sistema do Exchange e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração seja aplicada.

Para habilitar ou desabilitar o processo de zerar de páginas excluídas do Exchange Server 2007

  1. O código a seguir é um exemplo do comando Set-StorageGroup, que habilita ou desabilita o processo de zerar dos bancos de dados no grupo de armazenamento 'MyStorageGroup'.
Código da Cópia
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $false
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $true

Para obter mais informações sobre o impacto no desempenho com a substituição das páginas excluídas do banco de dados, consulte o artigo 815068 da Base de Dados de Conhecimento, "XADM: O desempenho do backup online é degradado com o tempo" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815068).


Entrar em Depuração na Inicialização está definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se a depuração foi habilitada no Armazenamento de Informações do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Debug Break At Startup

Se o Exchange Server Analyzer considerar que foi definido um valor para Debug Break At Startup, o Exchange Server Analyzer exibirá um aviso.

O valor do Registro Debug Break At Startup ativa o modo de depuração na próxima vez que o serviço Armazenamento de Informações do Microsoft Exchange for iniciado. O Armazenamento de Informações do Microsoft Exchange usa muitos recursos quando é executado no modo de depuração. Depurar o armazenamento em um ambiente de produção não é uma prática recomendada.

A menos que você esteja solucionando ativamente um problema de armazenamento com ajuda do Atendimento Microsoft, você deve excluir o valor do Registro Debug Break At Startup.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para excluir a chave do Registro Entrar em Depuração na Inicialização

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel da direita, localize e exclua o valor de Debug Break At Startup .

  4. Feche o editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Os buffers de log ESE padrão foram alterados
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchESEParamLogBuffers de cada grupo de armazenamento no computador do Exchange Server. Se o Exchange Server Analyzer detectar que o valor de msExchESEParamLogBuffers é igual a 512, uma mensagem de configuração não padrão será exibida.

O atributo do grupo de armazenamento msExchESEParamLogBuffers controla o número de buffers de log ESE (Mecanismo de Armazenamento Extensível), usado pelo armazenamento de informações do Exchange. O ESE usa um conjunto de buffers de log para armazenar informações na RAM antes de gravar nos logs de transações. O uso desses buffers melhora o desempenho do log de transações. Para servidores grandes, o valor padrão de 84 é muito baixo. Isso pode causar um excesso de operações de E/S na unidade de log de transações, significando uma redução de desempenho se o servidor estiver sob carga ou se os usuários estiverem enviando mensagens grandes. O aumento do número de buffers de log ESE melhora o desempenho, embora provoque mais uso de memória virtual.

Para definir corretamente esse valor, use as informações a seguir:

  • Para o Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1) ou Exchange 2000 Server Service Pack 2 (SP2), defina esse valor como 9000.

  • Para o Exchange 2000 Server Service Pack 3 (SP3), defina esse valor como 512.

  • Para o Exchange Server 2003, é usado um valor padrão 500, e você deve alterar o valor do atributo msExchESEParamLogBuffers para 9000.

Observação:
Se você ajustou anteriormente os buffers de log para 9000, certifique-se de reduzir manualmente essa configuração depois de aplicar o Exchange 2000 Server SP3. Essa alteração não é feita automaticamente quando você instala o Exchange 2000 Server SP3.

Se ocorrerem paralisações de log, isso poderá ser causado por um buffer muito baixo e você pode aumentar esse valor até 9000. O contador de desempenho Database\Log Record Stalls/s pode ser monitorado para determinar se estão ocorrendo paralisações de log. Não use um valor maior que 9000, pois pode corromper os arquivos do log de transações.

Observação:
Paralisações de registros de log/s é o número de registros de log que não podem ser adicionados aos buffers de log por segundo porque eles estão cheios. Se esse número for diferente de zero na maior parte do tempo, o tamanho do buffer de log poderá ser um afunilamento.

Você deve corrigir o valor usando uma ferramenta como a snap-in Active Directory Service Interfaces (ADSI) Edit, LDP (ldp.exe) ou qualquer outro cliente de protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para reverter para a configuração padrão

  1. Inicie o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração, expanda CN=Serviços, CN=Microsoft Exchange e CN=<ExchangeOrganizationName>.

  3. Expanda CN=Grupos Administrativos, expanda CN=<AdministrativeGroupName> e CN=Servidores.

  4. Expanda CN=<ServerName>, expanda CN=InformationStore, clique com o botão direito em CN=<StorageGroupName> e clique em Propriedades.

  5. No Editor de Atributos, clique no atributo msExchESEParamLogBuffers e clique em Editar.

  6. Na caixa Editar Atributo, defina o valor como 512 para o Exchange 200 Server ou como 9.000 para o Exchange Server 2003.

  7. Clique em Aplicar e em OK.

  8. Feche o ADSI Edit e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre buffers de log ESE, consulte o artigo 328466 da Base de Dados de Conhecimento Microsoft, "XADM: Buffers de log ESE definidos muito baixos podem fazer com que o armazenamento pare de responder" (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466) (em inglês).

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como funciona o ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda do Windows Server.


O armazenamento de pasta pública padrão é remoto
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-03

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo msExchHomePublicMDB de cada armazenamento de caixa de correio contém o Exchange Server local. Por padrão, o armazenamento de pasta pública de um armazenamento de caixa de correio está no Exchange Server local. Se o atributo msExchHomePublicMDB não contiver o Exchange Server local, o armazenamento de caixa de correio tem um armazenamento de pasta pública padrão remoto. Se o Exchange Server Analyzer verificar que um armazenamento de caixa de correio tem um armazenamento de pasta pública padrão remoto, o Exchange Server Analyzer exibirá uma mensagem de configuração não padrão.

Para alterar o armazenamento de pasta pública padrão

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, <seu servidor Exchange>, <grupo de armazenamento>, clique com o botão direito no armazenamento de caixa de correio e selecione Propriedades.

  2. Na guia Geral, em Armazenamento público padrão, clique em Procurar para selecionar um armazenamento de pasta pública.

Para obter informações sobre armazenamentos de caixa de correio e armazenamentos de pasta pública, consulte "Gerenciando armazenamentos de caixa de correio e armazenamentos de pasta pública" no Guia de administração do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47617).


Período de Thread de Exclusão para um armazenamento da caixa de correio é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

O Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o intervalo para a remoção de itens excluídos foi modificado da configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Deletion Thread Period

Se o Exchange Server Analyzer detectar que a chave Deletion Thread Period está presente e configurada, uma mensagem de configuração não padrão será exibida.

Quando você exclui uma mensagem, o Exchange marca a mensagem para exclusão. O Exchange também marca a mensagem como oculta até que ela seja excluída permanentemente do armazenamento do Exchange. Quando o armazenamento do Exchange recebe uma solicitação para excluir uma mensagem em uma pasta referenciada pelo ID de Mensagem, ele determina se a mensagem deve ser excluída temporariamente ou efetivamente. A mensagem é excluída permanentemente depois de decorrido o período de retenção de item excluído. A exclusão temporária também é chamada de exclusão lógica. A exclusão efetiva também é chamada de exclusão física.

Por padrão, um processo de limpeza de dumpster é executado a cada 24 horas e determina se é o momento de excluir efetivamente um item. O processo de limpeza do dumpster é parte do processo de manutenção online do armazenamento do Exchange. Se o período de retenção de item excluído tiver decorrido, o item será excluído efetivamente. O valor do Registro Deletion Thread Period é usado para substituir o intervalo padrão de 24 horas e especificar um intervalo personalizado para o processo de limpeza do dumpster.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Exclua a chave Deletion Thread Period.

  4. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre retenção e recuperação de itens excluídos, consulte os artigos a seguir na Base de Dados de Conhecimento:

  • 249680, "XADM: Noções básicas sobre a retenção de itens excluídos e o processo de exclusão de mensagens" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=249680)

  • 287544, "XADM: O armazenamento de informações públicas cresce significativamente quando a funcionalidade de retenção de itens excluídos está habilitada" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=287544)

  • 822938, "COMO FAZER PARA: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938)


Período de thread de exclusão para um armazenamento de pasta pública é não padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar se o intervalo para a remoção de itens excluídos foi modificado da configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Deletion Thread Period

Se o Exchange Server Analyzer perceber que a chave Deletion Thread Period está presente e configurada, uma mensagem de configuração não padrão será exibida.

Quando você exclui uma mensagem, o Exchange marca a mensagem para exclusão. O Exchange também marca a mensagem como oculta até que ela seja excluída permanentemente do armazenamento do Exchange. Quando o armazenamento de informações recebe uma solicitação para excluir uma mensagem em uma determinada pasta mencionada pelo ID de mensagem, o armazenamento do Exchange determina se a mensagem deve ser excluída temporariamente ou efetivamente. A exclusão temporária também é conhecida como exclusão lógica e a exclusão efetiva também é conhecida como exclusão física. A mensagem é excluída permanentemente depois de decorrido o período de retenção de item excluído.

Por padrão, um processo de limpeza de dumpster é executado a cada 24 horas o que determina se é o momento de excluir efetivamente um item. O processo de limpeza do dumpster é parte do processo de manutenção online do armazenamento do Exchange. Se o período de retenção de item excluído tiver decorrido, o item será excluído efetivamente. O valor do Registro Deletion Thread Period é usado para substituir o intervalo padrão de 24 horas e especificar um intervalo personalizado para o processo de limpeza do dumpster.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Exclua a chave Deletion Thread Period.

  4. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre retenção e recuperação de itens excluídos, consulte os artigos a seguir na Base de Dados de Conhecimento:

  • 249680, "XADM: Compreendendo a retenção de item excluído e o processo de exclusão de mensagem" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249680)

  • 287544, "XADM: O armazenamento de informações públicas aumenta significativamente quando a funcionalidade de retenção de item excluído é habilitada" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=287544)

  • 319098, "COMO FAZER PARA: Usar Políticas de Sistema para Configurar Limites de Armazenamento de Pasta Pública no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319098)


Afunilamento de disco detectado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-11-14

A ferramenta Microsoft® Exchange Server Analyzer Tool determinou que seu sistema de disco está executando atualmente dentro dos 20% da taxa de transferência máxima prevista disponível. Essa determinação é feita por meio de um dos seguintes cálculos:

  • Medindo as latências do disco. Os contadores de desempenho que indicam a latência são LogicalDisk\Avg. Seg. de Disco/Leitura e LogicalDisk\Avg. Seg. de Disco/Gravação.

  • Comparando a E/S por segundo (IOPS) máxima do disco possível da atual configuração do disco e contagem de eixos em relação ao valor atual da IOPS, conforme registrado pelo Monitor de Desempenho (Perfmon).

Latências aceitáveis

Dependendo do tipo de dado que está sendo acessado, o servidor Exchange tem uma tolerância diferente para os retardos. Por isso, o limite máximo aceitável da latência média é expresso com base no tipo de recurso existente no disco. Em todos casos, exceto onde indicado na lista a seguir, o valor máximo aceitável para as latências de leitura ou gravação é 50 milissegundos (ms).

  • Unidades de log de transações A unidade que hospeda o log de transações deve ter latências médias de gravação abaixo de 10 ms. Os picos nas latências de gravação devem ficar abaixo de 50 ms. As gravações no log de transações são síncronas. Isto significa que, para executar outra tarefa no processo Store.exe, um thread deve esperar o término da gravação. Ter latências de gravação baixas para os logs de transações é importante para o desempenho do servidor. A latência média de Leitura para as unidades de log de transações deve ser abaixo de 20 ms. Os picos na latência de leitura devem ficar abaixo de 50 ms. As Paralisações de Registros de Log do Banco de Dados por segundo devem ser inferiores a 10. Os Threads de Log de Banco de Dados Aguardando devem ser inferiores a 10.

    Geralmente, os servidores Exchange não lêem do log de transações. Portanto, as latências de leitura nessa unidade não têm importância. Contudo, como as latências de gravação do log de transações são muito importantes para o desempenho do Exchange, é recomendável que, nos servidores grandes, as unidades que hospedam logs de transações não sejam usadas para nenhuma outra finalidade. Nesse caso, a taxa de leituras (medida por LogicalDisk\Leituras de Disco/s) deve ser mínima em comparação à taxa de gravações (LogicalDisk\Gravações em Disco/s). O Exchange Server Analyzer detectará se a proporção entre leituras e gravações na unidade de log de transações é maior que 0,10 (mais de 1 leitura para cada 10 gravações).

    Se ocorrer mais de 0,10 leitura para cada gravação, identifique que aplicativo está lendo da unidade de log de transações e impeça a ocorrência desta ação.

  • Unidades de banco de dados A latência aceitável das unidades que contêm arquivos de banco de dados (arquivos *edb e *stm) do Exchange é expressa a seguir (os valores mais altos indicam um afunilamento de disco):

    • O valor máximo para Disco Lógico\Média de segundos de Disco/Leitura em uma unidade de banco de dados deve ser menor que 50 ms (0,050 segundos).

    • O valor médio para Disco Lógico\Média de segundos de Disco/Leitura em uma unidade de banco de dados deve ser menor que 20 ms (0,020 segundos).

  • Unidades TEMP e TMP A latência das unidades que contêm os diretórios TEMP e TMP deve ter as latências de leitura e gravação abaixo de 10 ms. O valor máximo da latência de leitura ou gravação deve ser abaixo de 50 ms.

  • Unidade de página e do sistema A latência das unidades que contêm arquivos de páginas e arquivos do sistema Windows deve ter as latências de leitura e gravação abaixo de 10 ms.

  • Unidade SMTP A latência das unidades que contêm arquivos de servidores SMTP deve ter as latências de leitura e gravação abaixo de 10 ms.

Causas da latência

Discos acessados a uma taxa superior à que o subsistema de disco pode oferecer suporte é uma das causas mais comuns de latência de disco. Nesse caso, diz-se que existe um afunilamento de disco. Também significa que o subsistema de disco está operando em ou acima de sua capacidade de taxa de transferência.

Se a taxa de IOPS de disco (LogicalDisk\Transferências de Disco/s) se aproximar ou estiver acima da capacidade prevista, diz-se que o disco está "além da capacidade da taxa de transferência" ou "além da capacidade". Nesses casos, para aumentar o desempenho do servidor, reduza a carga no subsistema de disco (mova usuários para outro servidor) ou aumente a capacidade da unidade (adicionando mais eixos ou eixos mais velozes).

Se o desempenho do hardware estiver aquém do esperado, você poderá ver as latências até mesmo quando a taxa de E/S estiver muito abaixo da capacidade estimada.

Reduzindo a latência do disco

Para diminuir a carga no subsistema de disco, reduza algumas das tarefas executadas pelo servidor. Especificamente, remova todos os aplicativos opcionais que estejam contribuindo para a carga do disco. O processo Store.exe é o único aplicativo que deve estar acessando as unidades de banco de dados e de log de transações.

Dependendo da configuração atual do sistema de disco, você pode tomar várias ações para reduzir o efeito desse problema.

Para reduzir a latência do disco

  • Se estiver ocorrendo um afunilamento em uma unidade de banco de dados ou de log de transações, você poderá reduzir a carga nessa unidade, movendo usuários para um banco de dados ou grupo de armazenamento hospedado em uma unidade que não esteja se aproximando de sua capacidade máxima. Se todos os bancos de dados ou unidades de log de transações estiverem se aproximando da capacidade máxima, talvez seja preciso mover usuários para outro servidor. Para obter mais informações, consulte Mover Caixas de Correio de Usuário para Outro Servidor

  • Ocasionalmente, a duração de uma alta taxa de E/S é rápida porque ela é causada por uma operação MAPI dispendiosa. Nesse caso, para determinar qual usuário ou ação está ocasionando as altas taxas de E/S, você pode usar a ferramenta ExMon (Monitor de Usuários do Exchange Server) em conjunto com os contadores de desempenho do disco lógico. Se for possível isolar o usuário, talvez você consiga identificar qual aplicativo cliente está gerando a carga mais alta. Você pode baixar o ExMon do Centro de Download da Microsoft (http://go.microsoft.com/fwlink/?LinkId=54983).

  • Se você estiver executando uma matriz de disco RAID-5, poderá desejar alterar para uma matriz de disco RAID-10 para melhorar a IOPS aceita disponível do subsistema de disco.

  • Para melhorar a IOPS aceita disponível, experimente adicionar mais discos ao sistema de disco.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre as práticas recomendadas para projetar arquiteturas de armazenamento, consulte Práticas recomendadas comuns a diversas arquiteturas (http://go.microsoft.com/fwlink/?LinkId=72988) (em inglês).

  • Para obter mais informações sobre como mover caixas de correio de usuários para reduzir a carga no servidor, consulte Mover Caixas de Correio de Usuário para Outro Servidor.

  • Para obter mais informações sobre tamanho de disco, latência e taxas de E/S, consulte os seguintes blogs no site Blog de Equipe do Microsoft Exchange:

    • "Alguns conceitos básicos sobre dimensionamento de discos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=39538)

    • "Considerações adicionais sobre a E/S de disco e cálculos…." (em inglês) (http://go.microsoft.com/fwlink/?linkid=39539)

    • Como calcular os requisitos de E/S do disco (http://go.microsoft.com/fwlink/?linkid=69747) (em inglês)


Afunilamento de disco encontrado no disco que contém os arquivos de log de transações
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server determinou que o sistema do disco que contém os arquivos de log do Exchange Server está com sobrecarga de tarefas, provocando um afunilamento no desempenho. Essa determinação é feita com a verificação de um ou mais dos seguintes contadores de desempenho:

  • A média de Banco de dados\Paralisações de Registro de log/s é superior a 10.

  • O máximo de Banco de dados\Paralisações de Registro de log/s é superior a 100.

  • A média de Banco de dados\Threads de log aguardando é superior a 10.

  • A média de Banco de dados\Threads de log aguardando é superior a 20.

Se algum desses limites for atingido, será exibido um erro informando que a unidade de log é um afunilamento de disco. Arquivos de log exigem uma latência de baixa gravação. Qualquer backup ou paralisação na gravação de um arquivo de log pode provocar problemas de desempenho do servidor. Paralisações de log podem ser provocadas por uma configuração baixa de buffers de log, msExchESEParamLogBuffers, ou por excesso de usuários conectando-se ao servidor.

Para reduzir uma latência de disco de log

  • Você pode elevar o parâmetro de buffers ESE, msExchESEParamLogBuffers, para 9.000. Não use um valor superior a 9.000, que pode danificar os arquivos de log de transações. Para obter mais informações, consulte Os buffers de log ESE padrão foram alterados.

  • Se uma unidade de banco de dados ou de log de transações estiver afunilada, você poderá reduzir a carga daquela unidade movendo usuários para um banco de dados ou grupo de armazenamento que esteja em uma unidade host que não esteja próxima da capacidade máxima. Se todos os bancos de dados ou unidades de log de transações estiverem se aproximando da capacidade máxima, talvez seja preciso mover usuários para outro servidor. Para obter mais informações, consulte Mover Caixas de Correio de Usuário para Outro Servidor.


EnableChangeNotification é não padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê o seguinte valor do Registro para determinar se a notificação de alteração de arquivo do Sistema de Arquivos Instalável do Exchange (ExIFS) está habilitada:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\ EnableChangeNotification

Se o Exchange Server Analyzer perceber que a chave EnableChangeNotification está presente e configurada com um valor maior que 0, uma mensagem de configuração não padrão é exibida.

Por padrão, a notificação de alteração de arquivo está desabilitada no ExIFS. Quando o ExIFS envia notificações de alteração para um arquivo ou diretório, ele não limpa a versão em cache do arquivo ou diretório. Conseqüentemente, quando um aplicativo como o Exchange Server ou o Microsoft SharePoint® Portal Server recebe uma notificação de alteração e recarrega o arquivo ou diretório, o aplicativo pega a versão em cache e não o arquivo ou diretório recém-modificado.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. Exclua a chave EnableChangeNotification.

  4. Feche o editor de Registro e reinicie o servidor Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o Sistema de Arquivos Instalável do Exchange, consulte o seguinte:

  • Capítulo 26 "Arquitetura do Exchange 2000", Kit de recursos do Exchange Server 2000 (http://go.microsoft.com/fwlink/?LinkId=51224)

  • Guia de Referência Técnica do Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47891)


Erro ao acessar o diretório de log
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server determinou que o caminho definido no servidor Exchange desse log de transações do grupo de armazenamento está inacessível.

Para corrigir esse erro

  • Verifique se o caminho realmente existe no servidor.

  • Verifique se você tem as permissões necessárias para ler arquivos armazenados no caminho do log de transações.


Erro ao acessar o arquivo de banco de dados de streaming
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer verificou que o arquivo .stm do banco de dados de streaming não está acessível.

Cada banco de dados do Exchange 2000 Server e do Exchange Server 2003 é composto de dois arquivos: o arquivo .edb do banco de dados do Exchange e o arquivo .stm do banco de dados de streaming. Esses arquivos devem ser acessados e processados em conjunto.

Para corrigir esse erro:

  • Localize o caminho para o arquivo .stm. No Gerenciado de Sistema do Exchange, esse caminho é definido na página de propriedades do banco de dados para cada objeto de banco de dados.

  • Verifique se o arquivo .stm desse banco de dados existe.

  • Verifique se você tem permissões para acessar a pasta onde o arquivo .stm está localizado.

  • Verifique se o arquivo não foi exclusivamente bloqueado por outro processo. Uma maneira de verificar isso é tentar renomear o arquivo. Se você conseguir renomear o arquivo com êxito, isso indica que o arquivo não está exclusivamente bloqueado. (Lembre-se de renomear o arquivo novamente para seu nome original.)


Erro ao verificar arquivos de log
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer não conseguiu ler os arquivos de log de transações.

Para corrigir esse erro

  • Verifique se você possui as permissões exigidas para acessar a pasta de arquivos de log de transações.

  • Verifique se o arquivo não foi exclusivamente bloqueado por outro processo. Uma maneira de verificar isso é tentar renomear o arquivo. Se você conseguir renomear o arquivo com êxito, isso indica que o arquivo não está exclusivamente bloqueado. (Lembre-se de renomear o arquivo novamente para seu nome original.)


Os buffers de log ESE estão no máximo neste grupo de armazenamento
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchESEParamLogBuffers para cada grupo de armazenamento. Se o Exchange Server Analyzer perceber que o valor do atributo msExchESEParamLogBuffers é a 9.000, será exibida uma mensagem de configuração diferente do padrão.

O ESE (Mecanismo de Armazenamento Extensível) usa um conjunto de buffers de log para armazenar informações na RAM antes de gravar em logs de transações. O uso desses buffers melhora o desempenho do log de transações. Para servidores grandes, o valor padrão de 84 é muito baixo. Isso pode causar um excesso de operações de E/S na unidade de log de transações, significando uma redução de desempenho se o servidor estiver sob carga ou se os usuários estiverem enviando mensagens grandes. O aumento do número de buffers de log ESE melhora o desempenho, embora provoque mais uso de memória virtual.

Para definir corretamente esse valor, use as informações a seguir:

  • Para o Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1) ou Exchange 2000 Server Service Pack 2 (SP2), defina esse valor como 9000.

  • Para o Exchange 2000 Server Service Pack 3 (SP3), defina esse valor como 512.

  • Para o Exchange Server 2003, é usado um valor padrão 500 e você deve alterar o valor do atributo msExchESEParamLogBuffers para 9000.

Observação:
Se você ajustou anteriormente os buffers de log para 9000, certifique-se de reduzir manualmente essa configuração depois de aplicar o Exchange 2000 Server SP3. Essa alteração não é feita automaticamente quando você instala o Exchange 2000 Server SP3.

Se ocorrerem paralisações de log, isso poderá ser causado por um buffer muito baixo e você pode aumentar esse valor até 9000. O contador de desempenho Database\Log Record Stalls/s pode ser monitorado para determinar se estão ocorrendo paralisações de log. Não use um valor maior que 9000, pois pode corromper os arquivos do log de transações.

Observação:
Paralisações de registros de log/s é o número de registros de log que não podem ser adicionados aos buffers de log por segundo porque eles estão cheios. Se esse número for diferente de zero na maior parte do tempo, o tamanho do buffer de log poderá ser um afunilamento.

Você deve corrigir o valor usando uma ferramenta como a snap-in Active Directory Service Interfaces (ADSI) Edit, LDP (ldp.exe) ou qualquer outro cliente de protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para reverter para a configuração padrão

  1. Inicie o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração, expanda CN=Serviços, CN=Microsoft Exchange e CN=<ExchangeOrganizationName>.

  3. Expanda CN=Grupos Administrativos, expanda CN=<AdministrativeGroupName> e CN=Servidores.

  4. Expanda CN=<ServerName>, expanda CN=InformationStore, clique com o botão direito em CN=<StorageGroupName> e clique em Propriedades.

  5. No Editor de Atributos, clique no atributo msExchESEParamLogBuffers e clique em Editar.

  6. Na caixa Editar Atributo, defina o valor como 512 para o Exchange 2000 Server ou como 9000 para o Exchange Server 2003.

  7. Clique em Aplicar e em OK.

  8. Feche o ADSI Edit e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre como definir os buffers de log ESE, consulte o artigo 328466 da Base de Dados de Conhecimento Microsoft, "XADM: Os Buffers de Log ESE Definidos com um Valor Muito Baixo Podem Fazer com que o Armazenamento Pare de Responder" (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466).


Os buffers de log ESE estão definidos muito baixo neste grupo de armazenamento
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor msExchESEParamLogBuffers de cada objeto do grupo de armazenamento (classe msExchStorageGroup) no contêiner InformationStore. Se o Exchange Server Analyzer verificar que o valor para esse atributo é menor que 500, um aviso será exibido.

O ESE (Mecanismo de Armazenamento Extensível) usa um conjunto de buffers de log para armazenar informações na RAM antes de gravar em logs de transações. O uso desses buffers melhora o desempenho do log de transações. Para servidores grandes, o valor padrão de 84 é muito baixo. Isso pode causar um excesso de operações de E/S na unidade de log de transações, significando uma redução de desempenho se o servidor estiver sob carga ou se os usuários estiverem enviando mensagens grandes. O aumento do número de buffers de log ESE melhora o desempenho, embora provoque mais uso de memória virtual.

Para definir corretamente esse valor, use as informações a seguir:

  • Para o Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1) ou Exchange 2000 Server Service Pack 2 (SP2), defina esse valor como 9000.

  • Para o Exchange 2000 Server Service Pack 3 (SP3), defina esse valor como 512.

  • Para o Exchange Server 2003, é usado um valor padrão 500, e você deve alterar o valor do atributo msExchESEParamLogBuffers para 9000.

Observação:
Se você ajustou anteriormente os buffers de log para 9000, certifique-se de reduzir manualmente essa configuração depois de aplicar o Exchange 2000 Server SP3. Essa alteração não é feita automaticamente quando você instala o Exchange 2000 Server SP3.

Se ocorrerem paralisações de log, isso poderá ser causado por um buffer muito baixo e você pode aumentar esse valor até 9000. O contador de desempenho Database\Log Record Stalls/s pode ser monitorado para determinar se estão ocorrendo paralisações de log. Não use um valor maior que 9000, pois pode corromper os arquivos do log de transações.

Observação:
Paralisações de registros de log/s é o número de registros de log que não podem ser adicionados aos buffers de log por segundo porque eles estão cheios. Se esse número for diferente de zero na maior parte do tempo, o tamanho do buffer de log poderá ser um afunilamento.

Você deve corrigir o valor usando uma ferramenta como a snap-in Active Directory Service Interfaces (ADSI) Edit, LDP (ldp.exe) ou qualquer outro cliente de protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse aviso

  1. Inicie o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração, expanda CN=Serviços, CN=Microsoft Exchange e CN=<ExchangeOrganizationName>.

  3. Expanda CN=Grupos Administrativos, expanda CN=<AdministrativeGroupName> e CN=Servidores.

  4. Expanda CN=<ServerName>, expanda CN=InformationStore, clique com o botão direito em CN=<StorageGroupName> e clique em Propriedades.

  5. No Editor de Atributos, clique no atributo msExchESEParamLogBuffers e clique em Editar.

  6. Na caixa Editar Atributo, defina o valor como 512 para o Exchange 2000 Server ou como 9000 para o Exchange Server 2003.

  7. Clique em Aplicar e em OK.

  8. Feche o ADSI Edit e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre buffers de log ESE, consulte o artigo 328466 da Base de Dados de Conhecimento Microsoft, "XADM: Buffers de log ESE definidos muito baixos podem fazer com que o armazenamento pare de responder" (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466) (em inglês).

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como configurar buffers de log do ESE, consulte o artigo 328466 da Base de Dados de Conhecimento, "XADM: Os Buffers de Log ESE Definidos com um Valor Muito Baixo Podem Fazer com que o Armazenamento Pare de Responder" (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466).

Para obter mais informações sobre como funciona o ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda do Windows Server.


Os buffers de log do ESE estão definidos muito altos neste grupo de armazenamento
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchESEParamLogBuffers de cada grupo de armazenamento. Se o Exchange Server Analyzer determinar que o valor do atributo msExchESEParamLogBuffers de qualquer grupo de armazenamento é maior que 9.000, será exibido um erro.

O ESE (Mecanismo de Armazenamento Extensível) usa um conjunto de buffers de log para armazenar informações na RAM antes de gravar em logs de transações. O uso desses buffers melhora o desempenho do log de transações. Para servidores grandes, o valor padrão de 84 é muito baixo. Isso pode causar um excesso de operações de E/S na unidade de log de transações, significando uma redução de desempenho se o servidor estiver sob carga ou se os usuários estiverem enviando mensagens grandes. O aumento do número de buffers de log ESE melhora o desempenho, embora provoque mais uso de memória virtual.

Para definir corretamente esse valor, use as informações a seguir:

  • Para o Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1) ou Exchange 2000 Server Service Pack 2 (SP2), defina esse valor como 9000.

  • Para o Exchange 2000 Server Service Pack 3 (SP3), defina esse valor como 512.

  • Para o Exchange Server 2003, é usado um valor padrão 500, e você deve alterar o valor do atributo msExchESEParamLogBuffers para 9000.

Observação:
Se você ajustou anteriormente os buffers de log para 9000, certifique-se de reduzir manualmente essa configuração depois de aplicar o Exchange 2000 Server SP3. Essa alteração não é feita automaticamente quando você instala o Exchange 2000 Server SP3.

Se ocorrerem paralisações de log, isso poderá ser causado por um buffer muito baixo e você pode aumentar esse valor até 9000. O contador de desempenho Database\Log Record Stalls/s pode ser monitorado para determinar se estão ocorrendo paralisações de log. Não use um valor maior que 9000, pois pode corromper os arquivos do log de transações.

Observação:
Paralisações de registros de log/s é o número de registros de log que não podem ser adicionados aos buffers de log por segundo porque eles estão cheios. Se esse número for diferente de zero na maior parte do tempo, o tamanho do buffer de log poderá ser um afunilamento.

Você deve corrigir o valor usando uma ferramenta como a snap-in Active Directory Service Interfaces (ADSI) Edit, LDP (ldp.exe) ou qualquer outro cliente de protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro

  1. Inicie o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração, expanda CN=Serviços, CN=Microsoft Exchange e CN=<ExchangeOrganizationName>.

  3. Expanda CN=Grupos Administrativos, expanda CN=<AdministrativeGroupName> e CN=Servidores.

  4. Expanda CN=<ServerName>, expanda CN=InformationStore, clique com o botão direito em CN=<StorageGroupName> e clique em Propriedades.

  5. No Editor de Atributos, clique no atributo msExchESEParamLogBuffers e clique em Editar.

  6. Na caixa Editar Atributo, defina o valor como 512 para o Exchange 2000 Server ou como 9000 para o Exchange Server 2003.

  7. Clique em Aplicar e em OK.

  8. Feche o ADSI Edit e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como configurar buffers de log do ESE, consulte o artigo 328466 da Base de Dados de Conhecimento, "XADM: Os Buffers de Log ESE Definidos com um Valor Muito Baixo Podem Fazer com que o Armazenamento Pare de Responder" (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466).


O tamanho do arquivo de log do ESE foi alterado manualmente
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchESEParamLogFileSize do contêiner InformationStore. Se o Exchange Server Analyzer determinar que o valor do atributo msExchESEParamLogFileSize não é igual a 5120, será exibido um erro.

Esse valor se aplica a todos os grupos de armazenamento do servidor. Esse problema específico surge se o valor desse atributo tiver sido alterado do padrão (5120 KB ou 5 MB). Esse é o único valor aceito e nunca deve ser alterado.

Você deve corrigir o valor usando um utilitário como o snap-in ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe) ou qualquer outro cliente de protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro

  1. Abra um editor do Active Directory, como ADSI Edit, e localize o objeto InformationStore para o computador do Exchange Server no Active Directory.

    É possível encontrar o atributo msExchESEParamLogFileSize em:

    CN=Configuração, DC=Domínio, CN=Serviços, CN=Microsoft Exchange, CN= OrganizationName , CN=Grupos Administrativos, CN= AdministrativeGroupName , CN=Servidores, CN= ServerName , CN=Armazenamento de Informações

  2. Clique duas vezes no atributo msExchESEParamLogFileSize e defina seu valor como 5120.

  3. Feche o editor do Active Directory e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre como usar o LDP.exe para editar os atributos do Active Directory, consulte o artigo 260745 da Base de Dados de Conhecimento Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre como funciona o ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda do Windows Server.


O máximo de tabelas abertas do ESE foi codificado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-17

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar se o atributo msExchESEParamMaxOpenTables está presente para alguns objetos de grupo de armazenamento sob o objeto InformationStore do objeto do Exchange Server. Se o Analisador do Exchange detectar que o atributo msExchESEParamMaxOpenTables está presente e configurado, uma mensagem de configuração não padrão será exibida.

Por padrão, para o Exchange 2000 Server e Exchange Server 2003, esse atributo está presente mas não definido com algum valor. O Exchange Server armazena em cache dados sobre pastas que não estão sendo acessadas atualmente. Em alguns casos, isso pode contribuir para a fragmentação da memória virtual. Uma maneira de minimizar isso é reduzir o número máximo de tabelas de bancos de dados que podem ser abertas simultaneamente. O valor sugerido real para isso varia de acordo com a versão do Exchange Server e do service pack do Exchange que está instalado. Para o Exchange 2000 Server Service Pack 2, a configuração padrão para servidores de 8 processadores é de 85.000 tabelas por grupo de armazenamento. Isso é reduzido para 27.600 no Exchange 2000 Server Service Pack 3 para servidores de 8 processadores. Para servidores de 4 processadores, o valor é de 13.800. Essa valor pode ser diminuído para reduzir os problemas de fragmentação de memória virtual. Entretanto, a redução desse valor pode causar também situações em que as operações poderão falhar devido ao excesso de tabelas abertas. O erro ocorre porque o número máximo de tabelas que podem ser abertas simultaneamente está sendo reduzido, o que significa que o máximo será alcançado em breve.

O Exchange Server 2003 usa um método diferente para armazenar em cache dados sobre pastas que não estão sendo acessadas atualmente. Portanto, reduzir o número máximo de tabelas abertas não é necessário nem efetivo para reduzir os problemas de fragmentação de memória virtual. Esse atributo não deve ser definido em um servidor Exchange Server 2003.

A menos que você tenha sido instruído pelo Atendimento Microsoft a inserir um valor aqui, use a ferramenta ADSI (Active Directory Service Interfaces) Edit para limpar o valor definido nesse atributo.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP (ldp.exe) ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para limpar o valor do atributo msExchESEParamMaxOpenTables

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração, expanda CN=Serviços, CN=Microsoft Exchange e CN=ExchangeOrganizationName.

  3. Expanda CN=Grupos Administrativos, expanda CN=AdministrativeGroupName e CN=Servidores.

  4. Expanda CN=ExchangeServerName, expanda CN=InformationStore, clique com o botão direito em CN=StorageGroupName e clique em Propriedades.

  5. Em Selecione uma propriedade para exibir a caixa , clique em msExchESEParamMaxOpenTables.

  6. Na caixa Editar Atributo, clique em Limpar para alterar o valor para <não definido>.

  7. Clique em OK e em OK novamente.

  8. Feche o editor do Active Directory e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre esse atributo, consulte o artigo 325044 da Base de Dados de Conhecimento da Microsoft, "COMO: Solução de problemas de fragmentação da memória virtual no Exchange 2003 e no Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento, "XADM: Usando o utilitário LDP para modificar os atributos de objeto do Active Directory (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


O Banco de Dados do Exchange tem tamanho superior a 100 GB
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-17

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows® ) CIM_DataFile para determinar o valor da chave FileSize de cada banco de dados de armazenamento de informações do Exchange. Se o tamanho combinado do armazenamento de informações de um arquivo .edb e arquivo .stm exceder 100 GB (gigabytes), será exibido um aviso.

A Microsoft recomenda que os bancos de dados de armazenamento de informações não tenham mais de 50 GB. Supondo que seja feita a manutenção adequada, não haverá problemas operacionais com armazenamentos de caixas de correio com mais de 50 GB, entretanto, os tempos de backup e recuperação podem tornar armazenamentos de caixas de correio maiores inadequados para alguns SLAs (acordos de nível de serviço).

Se você tiver armazenamentos de caixas de correio com mais de 50 GB, verifique se o hardware corresponde ao acordo de nível de serviço adequado, de forma que a recuperação de grandes bancos de dados esteja incluída no SLA. Caso contrário, recomenda-se distribuir as caixas de correio entre vários armazenamentos de forma que nenhuma delas armazene mais de 50 GB.

Para corrigir esse aviso

  1. Considere a possibilidade de mover algumas das caixas de correio de grandes armazenamentos de informações para um novo armazenamento nesse ou em outro computador do Exchange Server.

  2. Se você moveu recentemente caixas de correio desse armazenamento de informações para outro, ou se excluiu recentemente caixas de correio desse armazenamento, a desfragmentação offline poderá diminuir o tamanho dos arquivos.

  3. Tente configurar os limites de tamanho de caixas de correio ou mensagens para evitar o crescimento ilimitado do banco de dados de armazenamento de informações.

Para obter mais informações sobre os arquivos .stm e .edb, consulte o artigo 232323 da Base de Dados de Conhecimento Microsoft, "Armazenamento de conteúdo nativo no Microsoft Exchange" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Para obter mais informações sobre a movimentação de caixas de correio no Exchange Server 2003, consulte o artigo 821829 da Base de Dados de Conhecimento, "Movendo caixas de correio no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Para obter mais informações sobre a movimentação de caixas de correio no Exchange 2000 Server, consulte o artigo 328810 da Base de Dados de Conhecimento, "Movendo caixas de correio entre servidores" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Para obter mais informações sobre como executar uma desfragmentação offline de um banco de dados do Exchange Server, consulte o artigo 328804 da Base de Dados de Conhecimento, "Como desfragmentar bancos de dados do Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Para obter mais informações sobre como definir limites de tamanho de mensagens, consulte o artigo 322679 da Base de Dados de Conhecimento, "Definir limites de tamanho para mensagens" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679) (em inglês).


Os arquivos de banco de dados do Exchange estão sendo gravados em uma pasta compactada
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Directory do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Compressed da pasta que contém os arquivos de bancos de dados de armazenamento de informações do Exchange. Se o valor de Compactado estiver definido como Verdadeiro nesta pasta, será exibido um erro.

Em um computador do Exchange 2000 Server ou do Exchange Server 2003, os bancos de dados de armazenamento de informações são gravados no seguinte local padrão:

<unidade> :\Arquivos de Programas\Exchsrvr\mdbdata

Em um computador do Exchange Server 2007, os arquivos de banco de dados são gravados no seguinte local padrão:

<unidade> :\Arquivos de Programas\Microsoft\Exchange Server\Caixa de Correio\<Nome do Grupo de Armazenamento>

A Microsoft não oferece suporte para o armazenamento de arquivos de dados do Exchange em um volume NTFS compactado. Quando você armazenar seus arquivos de dados do Exchange em um volume compactado, a sobrecarga adicional impactará bastante o desempenho do Exchange. Além disso, quando um banco de dados de armazenamento de informações atinge um determinado tamanho (aproximadamente 4 GB), a sua montagem poderá falhar ou ele poderá ficar danificado.

Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Os arquivos gerenciados pelo ESE (Mecanismo de Armazenamento Extensível) não são projetados para serem armazenados em uma unidade compactada. O Mecanismo de Armazenamento Extensível (ESE) depende da independência de setor para a recuperação baseada em log, e a compactação de arquivos invalida essa independência. A compactação não deve ser ativada para os volumes que hospedam bancos de dados ESE, ou qualquer banco de dados que usa o log de write-ahead.

Antes do Exchange 2000 Server Service Pack 3, era possível montar bancos de dados compactados de armazenamento de informações. Contudo, podem ocorrer danos em bancos de dados ou logs de armazenamento de informações do Exchange 2000 Server compactados por meio da compactação NTFS.

Com o Exchange 2000 Server Service Pack 3, arquivos do banco de dados de armazenamento de informações compactados de 128 MB ou menos são descompactados automaticamente. Quando os arquivos de banco de dados atingem um tamanho acima de 128 MB, o banco de dados não é montado e são geradas mensagens de erro no log do aplicativo. O Exchange 2000 Server Service Pack 3 impede a montagem de bancos de dados compactados com mais de 128 MB.

Para desativar a compactação de arquivos em uma pasta específica

  1. Clique com o botão direito na pasta em que você deseja desativar a compactação de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Compactar o conteúdo para economizar espaço em disco e clique em OK.

Para mover os arquivos de banco de dados contidos no Exchange 2000 Server ou Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos, expanda o seu grupo administrativo, expanda Servidores, expanda o seu servidor, expanda o seu grupo de armazenamento, clique com o botão direito em Armazenamento de Caixa de Correio e clique em Propriedades.

  3. Na guia Banco de Dados, em Banco de dados do Exchange ou Banco de dados de streaming do Exchange, clique em Procurar, digite o local do caminho para uma pasta em que a compactação não está habilitada e clique em OK.

  4. Clique em OK ou em Aplicar para aplicar as alterações e clique em Sim na mensagem de aviso.

    Após clicar em Sim, os armazenamentos (bancos de dados) serão desmontados, movidos e remontados. Quando esses procedimentos forem concluídos com êxito, você receberá a seguinte mensagem informativa:

    Os arquivos de banco de dados foram movidos com êxito.

Para mover o local dos arquivos do banco de dados do grupo de armazenamento do Exchange no Exchange Server 2007

  1. Siga as orientações contidas na documentação principal do Exchange Server 2007, "Como mover um caminho do grupo de armazenamento" (em inglês) (http://go.microsoft.com/fwlink/?LinkID=80747).

Para obter mais informações sobre os arquivos .stm e .edb, consulte o artigo 232323 da Base de Dados de Conhecimento Microsoft, "Armazenamento de conteúdo nativo no Microsoft Exchange" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).


Os arquivos de banco de dados do Exchange estão sendo gravados em uma partição não-NTFS
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Directory do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave FSName para o caminho do arquivo de banco de dados do Exchange. Se o Analisador do Exchange Server determinar que o valor da chave FSName não é igual a Sistema de Arquivo NTFS, um erro será exibido.

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em volumes não-NTFS. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .chk

  • .eml

Se você vir este erro, mova os arquivos de banco de dados para uma pasta contida em uma unidade NTFS. Como alternativa, se a unidade na qual os arquivos de banco de dados estão armazenados estiver formatada como uma unidade FAT, você poderá usar a ferramenta de linha de comando convert.exe para converter a unidade em NTFS.

Para mover os arquivos de banco de dados do Exchange no Exchange 2000 Server ou Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos, expanda o seu grupo administrativo, expanda Servidores, expanda o seu servidor, expanda o seu grupo de armazenamento, clique com o botão direito em Armazenamento de Caixa de Correio e clique em Propriedades.

  3. Na guia Banco de Dados, em Banco de dados do Exchange ou Banco de dados de streaming do Exchange, clique em Procurar, digite o local do caminho para uma pasta em um volume NTFS e clique em OK.

  4. Clique em OK ou em Aplicar para aplicar as alterações ou clique em Cancelar se não as desejar aplicar.

  5. Se você tiver clicado em OK ou em Aplicar, receberá a seguinte mensagem de aviso:

    Nota Você está prestes e realizar a(s) seguinte(s) operação(ões)

    • alterar o local do banco de dados do Exchange

    • alterar o local do banco de dados de streaming do Exchange

    Para executar a(s) operação(ões) solicitada(s), o armazenamento deve estar desmontado, o que o torna inacessível para os usuários.

    Deseja continuar?

    Observação:
    Somente as operações escolhidas serão listadas na mensagem de aviso. A mensagem de aviso contém os botões Sim e Não.

  6. Clique em Sim para continuar, ou então, clique em Não.

  7. Se você tiver clicado em Sim, os armazenamentos (bancos de dados) serão desmontados, movidos e remontados. Quando esses procedimentos forem concluídos com êxito, você receberá a seguinte mensagem informativa:

    Os arquivos de banco de dados foram movidos com êxito.

Para mover o local dos arquivos de banco de dados de um grupo de armazenamento do Exchange no Exchange Server 2007

  1. Siga as orientações contidas na documentação principal do Exchange Server 2007, "Como Mover um Caminho do Grupo de Armazenamento" (em inglês) (http://go.microsoft.com/fwlink/?LinkID=80747)

Como alternativa para o procedimento acima, se a unidade em que os arquivos estão armazenados estiver formatada como uma unidade FAT, você poderá usar a ferramenta de linha de comando convert.exe para converter a unidade em NTFS. Para obter informações sobre como usar a ferramenta de linha de comando convert.exe para converter uma partição FAT em uma partição NTFS, consulte o artigo 214579 da Base de Dados de Conhecimento Microsoft, "Como usar o convert.exe para converter uma partição no sistema de arquivos NTFS" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579) (página em inglês).


Os arquivos de banco de dados do Exchange estão sendo gravados em uma pasta criptografada
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®), Win32_Directory, para determinar o valor da chave Criptografado para a pasta que contém os arquivos de bancos de dados do Armazenamento de Informações do Exchange. Se o Exchange Server Analyzer encontrar o valor para Encrypted definido como True, um erro será exibido.

Em um computador do Exchange 2000 Server ou do Exchange Server 2003, os arquivos de banco de dados são gravados no seguinte local padrão:

<unidade> :\Arquivos de Programas\Exchsrvr\mdbdata

Em um computador do Exchange Server 2007, os arquivos de banco de dados são gravados no seguinte local padrão:

<unidade> :\Arquivos de Programas\Microsoft\Exchange Server\Caixa de Correio\<Nome do Grupo de Armazenamento>

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em um volume criptografado com EFS (Sistema de Criptografia de Arquivos). Quando você armazena seus arquivos de dados do Exchange em um volume criptografado, a sobrecarga afeta significativamente o desempenho do Exchange. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Para ajudar a proteger seus arquivos de dados do Exchange, é recomendável que você impeça o acesso não autorizado ao computador do Exchange e use o formato de mensagem S/MIME para criptografar dados de mensagens.

Para resolver esse erro, você deve desativar a criptografia de arquivos na pasta em que os arquivos de bancos de dados estão sendo gravados ou mova esses arquivos para uma pasta em que a criptografia não esteja habilitada.

Para desativar a criptografia de arquivos em uma determinada pasta

  1. Clique com o botão direito na pasta em que deseja desativar a criptografia de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Criptografar o conteúdo para proteger dados e clique em OK.

Para mover os arquivos de banco de dados contidos no Exchange 2000 Server ou no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos, expanda o seu grupo administrativo, expanda Servidores, expanda o seu servidor, expanda o seu grupo de armazenamento, clique com o botão direito em Armazenamento de Caixa de Correio e clique em Propriedades.

  3. Na guia Banco de Dados, em Banco de dados do Exchange ou Banco de dados de fluxo contínuo do Exchange, clique em Procurar, digite o local do caminho para uma pasta em que a criptografia não está ativada e clique em OK.

  4. Clique em OK ou em Aplicar para aplicar as alterações e clique em Sim na mensagem de aviso.

  5. Depois de clicar em Sim, os armazenamentos (bancos de dados) serão desmontados, movidos e remontados. Quando esses procedimentos forem concluídos com êxito, você receberá a seguinte mensagem informativa:

    Os arquivos de banco de dados foram movidos com êxito.

Para mover o local dos arquivos do banco de dados do grupo de armazenamento do Exchange no Exchange Server 2007

  1. Siga as orientações contidas na documentação principal do Exchange Server 2007, "Como mover um caminho de grupo de armazenamento" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80747)

Para obter mais informações sobre a movimentação de arquivos de bancos de dados, consulte o artigo 821915 da Base de Dados de Conhecimento da Microsoft, "Como mover bancos de dados e logs do Exchange no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915).

Para obter mais informações sobre arquivos de dados do Exchange Server e EFS, consulte o artigo 834638 da Base de Dados de Conhecimento, "Informações sobre o armazenamento de arquivos de dados em um volume criptografado no Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Para obter mais informações sobre como proteger mensagens no Exchange Server 2003, consulte o Guia de Segurança de Mensagens do Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47574).


Banco de Dados do Exchange está em um estado de Desligamento Anormal
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-10-30

A ferramenta Microsoft® Exchange Server Analyzer determinou que um de seus bancos de dados não foi desligado corretamente. Portanto, os arquivos do banco de dados ainda estão anexados aos arquivos de log.

Um estado de Desligamento Anormal não indica que o banco de dados esteja danificado. O estado de Desligamento Anormal indica apenas que os arquivos do banco de dados não foram desanexados corretamente do fluxo de log. Portanto, antes de iniciar novamente o banco de dados, você deve primerio recuperar os arquivos do banco de dados.

Da próxima vez em que o banco de dados for montado, essa recuperação será executada automaticamente. Se a recuperação automática falhar, você poderá usar a ferramenta Microsoft Exchange Server Disaster Recovery Analyzer para analisar os motivos da falha. Depois da análise, o Exchange Server Disaster Recovery Analyzer fornecerá recomendações para a recuperação manual dos arquivos do banco de dados.

Para corrigir esse erro

  • Coloque o banco de dados em estado de Desligamento Normal, repetindo os arquivos de log de transações necessários no banco de dados. Para repetir os arquivos de log, monte o banco de dados. Se essa ação falhar, use a ferramenta Exchange Server Disaster Recovery Analyzer para ajudar a isolar o motivo da falha.

Para obter mais informações sobre a ferramenta Exchange Server Disaster Recovery Analyzer Tool, consulte o artigo 922247 da Base de Dados de Conhecimento Microsoft, "Descrição da ferramenta Microsoft Exchange Server Disaster Recovery Analyzer Tool para Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=922247).


A agenda de manutenção online do banco de dados do Exchange está definida como Nunca
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo activationSchedule nos armazenamentos de caixas de correio e nos armazenamentos públicos. ISe o Analisador do Exchange Server detectar que o valor de activationSchedule está definido como Nunca, será exibido um aviso.

O atributo activationSchedule representa a configuração para a agenda de manutenção de bancos de dados online. A manutenção de bancos de dados online no Exchange Server é muito importante. Durante esse intervalo, são realizadas tarefas como limpeza do dumpster (exclusão de mensagens que passaram da data de retenção de item excluído), expiração de pasta pública (mensagens das pastas públicas que são mais antigas do que uma determinada data expiraram), limpeza da caixa de correio excluída e desfragmentação online (objetos de bancos de dados que não estão mais sendo usados são detectados e removidos, disponibilizando espaço adicional no banco de dados). Esses processos mantêm o computador do Exchange Server íntegro e o desempenho estável. A manutenção online deve ser configurada para ser executada pelo menos quatro horas por dia; caso isso não seja feito, haverá degradação do desempenho com o passar do tempo.

Recomenda-se configurar a manutenção de banco de dados online para ser executada em cada banco de dados (armazenamento de caixas de correio ou armazenamento de pastas públicas) durante quatro horas diariamente. Coordene os intervalos de manutenção online com as agendas de backup. Por exemplo, se os backups estiverem programados para execução de meia-noite às 2h, execute a manutenção online das 3 às 7h.

Isso é importante porque a manutenção online não será iniciada se a sessão de backup ainda estiver sendo executada. Se ocorrer sobreposição, o backup terá precedência sobre a manutenção. Nesse caso, o Exchange faz verificações a cada 15 minutos para confirmar se o backup terminou. Depois do término do backup, a manutenção será iniciada.

O armazenamento passa por 18 tarefas para executar a manutenção. Quando uma tarefa é iniciada, ela é terminada independentemente da janela de programação da manutenção. Entretanto, a manutenção não iniciará uma nova tarefa se a janela de programação expirar. Portanto, em alguns casos, nem todas as tarefas são terminadas em um determinado intervalo de manutenção. Se a manutenção for abreviada, será reiniciada de onde parou no próximo ciclo de manutenção.

Para habilitar a manutenção de bancos de dados online do Exchange 2000 Server e do Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores e, em seguida, expanda o servidor com o qual deseja trabalhar.

  3. Expanda o grupo de armazenamento com o qual deseja trabalhar.

  4. Na lista de armazenamento de dados disponíveis no painel de detalhes, clique com o botão direito no armazenamento com o qual deseja trabalhar e clique em Propriedades.

  5. Na caixa de diálogo Propriedades de Armazenamento, clique na guia Banco de Dados.

  6. Siga um destes procedimentos:

    • Na lista de intervalo Manutenção, selecione um intervalo.

    • Clique em Personalizar para acessar a caixa de diálogo Agenda e crie um intervalo personalizado.

  7. Clique em OK.

Para corrigir esse aviso no Exchange Server 2007

  1. Abra o Console de Gerenciamento do Exchange

  2. Expanda Configuração do Servidor e selecione o servidor com o qual deseja trabalhar.

  3. Expanda o grupo de armazenamento com o qual deseja trabalhar.

  4. Clique com o botão direito no armazenamento com o qual você deseja trabalhar e selecione Propriedades.

  5. Na guia Geral, clique em Agenda de manutenção e selecione um intervalo ou clique em Personalizar para criar uma agenda personalizada.

Para obter mais informações sobre as tarefas de manutenção de banco de dados online, consulte o artigo 159196 da Base de Dados de Conhecimento Microsoft, "XADM: Tarefas controladas pela agenda de manutenção IS" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196).


O serviço Armazenamento de Informações do Exchange não está configurado para executar como LocalSystem
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-02-27

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Services para determinar se a conta de inicialização especificada na propriedade StartName do serviço Armazenamento de Informações do Microsoft Exchange (MSExchangeIS) está usando a conta LocalSystem. Se o Exchange Server Analyzer detectar que o valor dessa propriedade em um computador do Exchange 2000 Server, do Exchange Server 2003 ou do Exchange Server 2007 é uma conta diferente de LocalSystem (também conhecida como conta SYSTEM), um aviso será exibido. Esse aviso não é acionado para computadores do Exchange server 5.5, em que espera-se e exige-se que o serviço Armazenamento de Informações do Microsoft Exchange seja executado em uma conta de usuário.

O Exchange 2000 Server, o Exchange Server 2003 e o Exchange Server 2007 devem ser iniciados em um contexto de segurança do LocalSystem, em vez de associar uma conta de usuário específica (e senha) para iniciar esses serviços. Isso garante que alterações de senha ou exclusões de contas de usuário não irão impedir que o Exchange funcione corretamente. Quando um serviço do Exchange que está sendo executado como LocalSystem acessa um servidor remoto, o Microsoft Windows 2000 Server ou Windows Server™ 2003 o autentica usando as credenciais da conta do computador.

A senha da conta do computador é alterada a cada sete dias por meio do mecanismo padrão de alteração de senhas. Isso ajuda a tornar a conta do computador mais segura do que uma conta de usuário típica, em que a senha não só é trocada em uma freqüência menor, como também tende a ser menos aleatória do que uma senha de conta de computador gerada aleatoriamente.

Alguns administradores que possuem experiência com o Exchange Server 5.5, em que uma conta de usuário é usada para serviços, alteram a conta de inicialização dos serviços do Exchange 2000 Server, do Exchange Server 2003 e do Exchange Server 2007, usando, em vez da conta LocalSystem padrão, uma conta de usuário.

No Exchange 2000 Server, no Exchange Server 2003 e no Exchange Server 2007, a Microsoft não oferece suporte à execução do serviço de Armazenamento de Informações do Microsoft Exchange em nenhuma outra conta que não a LocalSystem.

Para corrigir esse erro

  1. Clique em Iniciar, aponte para Programas, Ferramentas Administrativas e clique em Serviços.

  2. Na lista de serviços, clique com o botão direito em Armazenamento de Informações do Microsoft Exchange e clique em Propriedades.

  3. Na guia Logon, em Fazer logon como, clique em Conta Sistema Local e clique em OK.

  4. Com o botão direito, clique em Armazenamento de Informações do Microsoft Exchange e clique em Reiniciar.

Para obter mais informações sobre serviços do Exchange, consulte o artigo 239762 da Base de Dados de Conhecimento Microsoft, "Serviços do Exchange executados em LocalSystem" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


O serviço Armazenamento de Informações do Exchange não está sendo executado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o valor da chave Started no serviço Armazenamento de Informações do Microsoft Exchange está definido como True ou False.

Um valor igual a False indica que o serviço de Armazenamento de Informações do Microsoft Exchange não está em execução nesse computador do Exchange Server. Uma valor igual a True indica que o serviço de Armazenamento de Informações do Microsoft Exchange está em execução.

O Exchange Server Analyzer também examina a classe WMI Exchange_Server no namespace root\MicrosoftExchangeV2 para determinar o valor da chave IsFrontEndServer. Um valor Falso indica que o computador do Exchange Server não é um servidor front-end. Um valor True indica que o computador do Exchange Server é um servidor front-end do Exchange Server 2003 ou Exchange 2000 Server.

Se os valores de ambas as chaves avaliadas forem False nos sistemas do Exchange 2000 Server e do Exchange Server 2003, um aviso será exibido.

Se o valor False for retornado para a chave Win32_Service Started e o computador do Exchange Server estiver executando o Exchange Server 2007, um aviso será exibido.

Se as tentativas para iniciar o serviço Armazenamento de Informações do Microsoft Exchange falharem, isso poderia indicar um problema mais sério nesse computador do Exchange Server. Nesse caso, você deve examinar os logs de evento para obter detalhes sobre a falha. Você também deve certificar-se de que está executando o service pack mais recente da sua versão do Exchange Server.

Você pode obter o service pack mais recente do Exchange Server 2003 em "Downloads para o Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25097).

Para obter mais informações sobre causas conhecidas para a falha do serviço Armazenamento de Informações do Microsoft Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 827915, "O serviço Armazenamento de Informações pode parar inesperadamente durante a conversão de uma mensagem que não contenha a propriedade PR_MESSAGE_CLASS no Exchange 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602, "O serviço Armazenamento de Informações do Exchange Server 2003 pára de responder" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115, "O serviço Armazenamento de Informações não inicia após a atualização do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197, "O serviço Armazenamento de Informações pára inesperadamente quando uma mensagem com uma ID de mensagem da Internet nula é entregue localmente" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130, "O painel Pastas não é exibido ou o serviço Armazenamento de Informações é encerrado inesperadamente quando você utiliza o OWA para acessar sua caixa de correio no computador do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163, "'A instalação não consegue localizar uma mensagem de erro do servidor de catálogo global qualificado quando você tenta iniciar o serviço de armazenamento de informações" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579, "ID de Evento 7024 após a instalação do Exchange Server 2003 e o serviço Armazenamento de Informações do Exchange não inicia" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579)

  • 833841, "O serviço de Armazenamento de Informações do Microsoft Exchange inesperadamente pára de responder" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

Para obter mais informações sobre como usar servidores front-end do Exchange Server 2003 e do Exchange 2000 Server, consulte os seguintes sites:

  • Usando servidores front-End do Microsoft Exchange 2000 (em inglês) (http://go.microsoft.com/fwlink/?linkid=12055)

  • Topologia front-End e back-End do Exchange Server 2003 e do Exchange 2000 Server (em inglês) (http://go.microsoft.com/fwlink/?linkid=47567)


O serviço Armazenamento de Informações do Exchange não está em execução nesse servidor front-end
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Windows) para determinar os valores definidos para a chave Started dos serviços Armazenamento de Informações do Microsoft Exchange e protocolo SMTP. Um valor Falso indica que o serviço não está sendo executado. Um valor Verdadeiro indica que o serviço está sendo executado.

O Exchange Server Analyzer também examina a classe Exchange_Server do WMI no namespace root\MicrosoftExchangeV2 para determinar o valor da chave IsFrontEndServer. Um valor Falso indica que o computador do Exchange Server não é um servidor front-end. Um valor Verdadeiro indica que o computador do Exchange Server é um servidor front-end.

Se o Exchange Server Analyzer verificar que o valor Started é verdadeiro para o serviço SMTP, o valor Started para o serviço Armazenamento de Informações do Microsoft Exchange é False e que o valor para o IsFrontEndServer é True, será exibido um aviso.

O Exchange 2000 Server e o Exchange Server 2003 usam servidores front-end para aplicar proxy em solicitações de clientes POP3, IMAP4 e Microsoft Office Outlook® Web Access. Além disso, eles podem ser usados como servidores SMTP voltados para a Internet. Se esse servidor front-end aceitar e rotear mensagens SMTP, oferecer suporte para clientes IMAP (que usam SMTP para enviar mensagens), ou se esse servidor front-end estiver executando software compatível com VSAPI (API de Verificação de Vírus), o serviço Armazenamento de Informações do Microsoft Exchange deverá estar em execução. Caso contrário, o servidor front-end não poderá processar mensagens SMTP nem verificar mensagens usando VSAPI.

A não ser que o software antivírus compatível com SMTP ou VSAPI esteja sendo usado em um servidor front-end, a configuração recomendada é desconectar e excluir todos os armazenamentos de pasta pública do servidor front-end, parar o serviço Armazenamento de Informações do Microsoft Exchange e defini-lo como desabilitado. Além disso, o serviço SMTP deve ser parado, se não estiver sendo usado. Em computadores do Exchange Server que usam software compatível com SMTP ou VSAPI, o serviço Armazenamento de Informações do Microsoft Exchange deve estar em execução para entregar mensagens e atender a clientes de sistema de mensagens.

Para corrigir esse aviso

  1. Abra o snap-in Serviços do MMC.

  2. Clique com o botão direito no serviço Armazenamento de Informações do Microsoft Exchange e clique em Propriedades.

  3. Na guia Geral da página de propriedades do Armazenamento de Informações do Microsoft Exchange, verifique se o Tipo de inicialização está definido como Automático. Caso contrário, defina-o como Automático, clique em Aplicar e clique em OK.

  4. Clique com o botão direito no serviço Armazenamento de Informações do Microsoft Exchange e clique em Iniciar.

  5. Feche o snap-in Serviços.

Se as tentativas para iniciar o serviço Armazenamento de Informações do Microsoft Exchange falharem, isso poderia indicar um problema mais sério nesse computador do Exchange Server. Nesse caso, você deve examinar os logs de evento para obter detalhes sobre a falha. Você também deve certificar-se de que você está executando o service pack mais recente da sua versão do Exchange Server. Você pode obter o service pack mais recente para o Exchange Server no site "Home Page do Microsoft Exchange Server" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=21573).

Para obter mais informações sobre causas conhecidas de falhas no serviço Armazenamento de Informações do Microsoft Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 827915, "The Information Store service may stop unexpectedly while converting a message that does not contain the PR_MESSAGE_CLASS property in Exchange 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602, "Exchange Server 2003 Information Store service stops responding" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115, "The Information Store service does not start after you upgrade to Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197, "The Information Store service stops unexpectedly when a message with a null Internet message ID is delivered locally" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130, "The Folders pane does not appear or the Information Store service quits unexpectedly when you use OWA to access your mailbox on your Exchange Server 2003 computer" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163, "'Setup Cannot Locate a Qualifying Global Catalog Server' Error Message When You Try to Start the Information Store Service" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579, "Event ID 7024 After You Install Exchange Server 2003, and Exchange Information Store Service Does Not Start" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579)

  • 833841, "The Microsoft Exchange Information Store service unexpectedly stops responding" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

Para obter mais informações sobre o uso de servidores front-end, consulte o Guia de topologia front-end e back-end do Exchange Server 2003 e do Exchange 2000 Server (página em inglês) (http://go.microsoft.com/fwlink/?linkid=47567).


A unidade Sistema de Arquivos Instalável do Exchange está habilitada
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-02-28

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o mapeamento de letras da unidade do ExIFS (Sistema de Arquivos Instaláveis do Exchange) ou IFS está habilitado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Se o Exchange Server Analyzer encontrar o valor do Registro DriveLetter configurado com uma letra da unidade (como M), será exibido um erro.

O Exchange 2000 Server lançou um recurso denominado IFS. IFS é um driver no nível do kernel que reproduz alguns dados contidos nos Armazenamentos de Informações do Exchange para o sistema de arquivos do Microsoft Windows®. Nas novas instalações do Exchange 2000 Server e nas atualizações para o Exchange 2000 Server a partir do Exchange Server 5.5, o IFS é automaticamente instalado e uma letra da unidade (por padrão, a unidade M) foi atribuída e mapeada para o Armazenamento de Informações. Isso foi feito por meio do namespace \\.\BackOfficeStorage\.

O Exchange Server 2003 tem suporte para o IFS mas, por padrão, o mapeamento de letras da unidade está desabilitado. O valor do Registro DriveLetter não está presente nas novas instalações do Exchange Server 2003 e, em uma atualização do Exchange 2000 Server para o Exchange Server 2003, os dados do valor do Registro e, portanto, o mapeamento de letras da unidade, foi removido.

Como prática recomendada, convém não habilitar o mapeamento de letras da unidade do IFS no Exchange Server 2003 e removê-lo do Exchange 2000 Server. Há problemas conhecidos que podem ocorrer se a letra da unidade mapeada para o IFS for acessada ou verificada por antivírus ou por aplicativos com base no sistema de arquivos. Conseqüentemente, é recomendável remover o mapeamento de letras da unidade se o recurso IFS não estiver sendo usado.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. No painel direito, clique duas vezes no valor DriveLetter.

  4. No campo Dados de Valor, exclua a letra listada para que esse campo fique vazio.

  5. Feche o Editor do Registro e reinicie os serviços Atendedor do Sistema do Microsoft Exchange e Publicação na Web para que a alteração entre em vigor. Quando o serviço Atendedor do Sistema for reiniciado, todos os serviços que dependerem desse serviço, inclusive os serviços Pilhas MTA do Microsoft Exchange e Armazenamento de Informações do Microsoft Exchange, também serão reiniciados.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como remover o mapeamento da unidade M no Exchange 2000 Server, consulte o artigo 305145 da Base de Dados de Conhecimento da Microsoft, "Como remover o mapeamento da unidade M do IFS no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=305145).

Para obter mais informações sobre como adicionar o mapeamento da unidade M no Exchange 2003 Server, consulte o artigo 821836 da Base de Dados de Conhecimento da Microsoft, "Mapeamento da unidade M no IFS não está presente, por padrão, no Exchange 2003 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821836).


Configuração e desempenho do Exchange Server
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer Tool determinou que o servidor Exchange não está configurado para desempenho ideal.

Durante a operação regular, os servidores Exchange acessam vários arquivos. O local dos arquivos pode contribuir para um afunilamento de desempenho. Grupos de arquivos interdependentes, como unidades do log de transações, também são chamados de recursos.

Se a distribuição desses recursos contribuir para um afunilamento de disco, o Exchange Server Analyzer poderá exibir um aviso ou erro sobre o local dos recursos no servidor Exchange. Para verificar se esses recursos específicos estão isolados de outras demandas de carregamento, coloque os recursos em um dispositivo de armazenamento dedicado. A lista a seguir descreve como cada recurso é usado, incluindo recomendações de como você pode configurar o recurso.

  • Unidades do log de transações Os arquivos do log de transações mantêm o estado e a integridade dos seus arquivos .edb e .stm. Isso significa que os arquivos de log representam, de fato, os dados. Existe um arquivo do log de transações definido para cada grupo de armazenamento. Como os logs de transações são um componente de backup crítico para os dados nos arquivos do banco de dados do servidor Exchange, o servidor Exchange deve confirmar todos os dados no arquivo de log para que possa finalizar várias transações com os dados. Quaisquer atrasos na gravação da unidade do log de transações pode afetar gravemente o desempenho do servidor. Portanto, é importante que você isole as unidades do log de transações, de modo que as unidades tenham seu próprio subsistema de disco que não seja compartilhado por outro servidor, aplicativo ou recurso. Para melhor desempenho, verifique se cada log de transações tem uma unidade dedicada.

  • Local da unidade TEMP Na primeira instalação, o sistema operacional define o local do arquivo temporário na mesma unidade usada pelo sistema operacional. Isso significa que qualquer E/S da unidade TEMP competirá com a E/S de programas e operações do arquivo de páginação que estão sendo executadas nessa unidade. Essa competição de E/S afeta o desempenho. A unidade TEMP é usada para a entrega de mensagens e para a conversão do conteúdo de mensagens grandes. Se a unidade TEMP se tornar afunilada, o fluxo de mensagens e alguns aplicativos clientes serão afetados. Para evitar que o sistema operacional compita com a E/S da unidade TEMP e para reduzir o risco de problemas de desempenho no servidor Exchange, é recomendável que você:

    • Altere a configuração do ambiente global de TEMP para apontar para outro disco.

    • Mova a unidade TEMP para o seu próprio disco.

  • Local dos arquivos .edb e .stm Um banco de dados do Exchange consiste em dois arquivos:

    • Um arquivo .edb (conteúdo MAPI) Esse arquivo armazena todas as mensagens e tabelas MAPI usadas pelo processo Store.exe para localizar todas as mensagens e somas de verificação dos arquivos .edb e .stm e mensagens MAPI.

    • Um arquivo .stm (conteúdo não-MAPI) Esse arquivo contém mensagens que são transmitidas com seu conteúdo nativo da Internet.

    Como o acesso a qualquer tipo desses arquivos é geralmente aleatório, os dois tipos de arquivos podem ser incluídos no mesmo volume de disco. No entanto, é importante não colocar os arquivos .edb e .stm na mesma unidade dos logs de transações. Além disso, como é importante evitar um afunilamento de desempenho nas unidades que contêm os arquivos de banco de dados, é recomendável que você coloque esses arquivos em unidades dedicadas, de acordo com cada grupo de armazenamento.

  • Local do diretório SMTP A fila SMTP armazena mensagens SMTP até que o Exchange as grave em um banco de dados (o armazenamento de caixa de correio ou o armazenamento de pasta pública) ou as envie para outro servidor ou conector. Geralmente, as filas SMTP têm E/Ss pequenas e aleatórias. O Exchange Server Analyzer exibirá um aviso se o diretório SMTP estiver em uma unidade compartilhada por qualquer um dos seguintes:

    • Qualquer outro arquivo de dados do Exchange

    • Os diretórios TEMP ou TMP

    • O arquivo de paginação

    • A unidade do sistema

    Se não houver um afunilamento de disco no diretório SMTP, você poderá ignorar com segurança esse aviso. No entanto, se o tráfego nesta unidade for alto e a unidade exibir um afunilamento de desempenho, tente mover o diretório SMTP para sua própria unidade ou aumentar a capacidade da unidade que hospeda o diretório SMTP.

  • Local do arquivo de paginação O arquivo de paginação serve como uma extensão da memória física. Especificamente, ele é onde o sistema armazena páginas não utilizadas ou páginas que o sistema precisará posteriormente. O arquivo de paginação é sempre usado, até por servidores que tenham uma quantidade adequada de memória disponível. Esse uso constante é devido ao sistema operacional tentar armazenar apenas as páginas necessárias e o espaço livre suficiente para as operações. Por exemplo, uma ferramenta de impressão usada apenas na inicialização pode ter uma determinada quantidade de memória paginada para o disco e nunca tê-la de volta, caso nunca seja usada.

    Em servidores em que a memória física for muito usada, verifique se todo o acesso ao arquivo de página é o mais rápido possível. É recomendável que você crie um segundo arquivo de paginação em uma unidade dedicada a ele.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre as práticas recomendadas para projetar arquiteturas de armazenamento, consulte Práticas recomendadas comuns a diversas arquiteturas (http://go.microsoft.com/fwlink/?LinkId=72988) (em inglês).

  • Para obter mais informações sobre o dimensionamento do disco, latência e taxas de E/S, consulte Como calcular os requisitos de E/S do disco (http://go.microsoft.com/fwlink/?linkid=69747) (em inglês).


A porta TCP/IP de Armazenamento do Exchange foi substituída manualmente.
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-03-21

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de registro para determinar se o valor da porta para a interface de armazenamento do Exchange foi substituída manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Se o Analisador do Exchange Server detectar a presença e configuração da TCP/IP Port , será exibida uma mensagem de configuração não padrão.

O motivo mais comum para a configuração desse valor é habilitar clientes MAPI para se conectarem a um servidor Exchange existente no outro lado de um firewall. Esse cenário requer a abertura de várias portas em um firewall para habilitar clientes do Microsoft Office Outlook® 2003 ou do Outlook 2007 a se conectarem por meio do MAPI com um servidor Exchange, geralmente pela Internet. Há suporte para essa configuração. Para obter mais informações sobre como configurar clientes MAPI para se conectarem ao Exchange por meio de um firewall, consulte o artigo 270836 da Base de Dados de Conhecimento da Microsoft, "Mapeamentos de portas estáticas do Exchange 2000 e Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836). No entanto, se você não estiver utilizando esse cenário, você deverá remover a chave de Registro.

A implantação recomendada para usar o Outlook no Modo MAPI para se conectar a um servidor Exchange pela Internet é o uso de recursos RPC sobre HTTP, encontrados no Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 e Microsoft Windows® XP Professional. O Modo MAPI era conhecido anteriormente como modo "Corporativo" ou de "Grupo de trabalho".

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para remover a chave de Registro da porta TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Exclua o valor do Registro chamado TCP/IP Port.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para implantar o RPC sobre HTTPS

  1. Consulte "Cenários de implantação de RPC sobre HTTP do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Revise o artigo 833401 da Base de Dados de Conhecimento, "Como configurar RPC sobre HTTP em um único servidor no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  3. Revise o artigo 827330 da Base de Dados de Conhecimento, "Como solucionar problemas de conexão cliente RPC sobre HTTP no Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  4. Consulte o WebCast do Suporte da Microsoft, "Usando o Microsoft Exchange pela Internet (RPC/HTTP) com o Microsoft Office Outlook 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).


A porta TCP/IP de armazenamento do Exchange é inferior a 5000
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-01-11

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar a configuração TCP/IP Port do armazenamento do Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Se o Analisador do Exchange Server achar que o valor de TCP/IP Port está definido como um valor abaixo de 5000 (decimal), um aviso será exibido.

Se for necessário definir a configuração TCP/IP Port com um valor estático, recomenda-se defini-la com um valor igual ou superior a 5000. A definição de um valor inferior a 5000 pode fazer com que o servidor Exchange pare de atender nessa porta. O servidor Exchange permanecerá nesse estado até o reinício de um serviço, o qual dependerá de qual componente do Exchange foi codificado.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir a chave de Registro da porta TCP/IP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Clique duas vezes na chave TCP/IP Port e defina o campo Dados do valor para um inteiro acima de 5000 (decimal).

  4. Feche o editor de Registro.

  5. Reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que essa alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre configurações de porta, consulte o artigo 270836 da Base de Dados de Conhecimento, "Mapeamentos de porta estática do Exchange Server" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


Os logs de transações do Exchange estão sendo gravados em uma partição não-NTFS
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-02-27

Mensagem de Erro

Introdução

A ferramenta Microsoft Exchange Analyzer consulta a classe Win32_Directory de WMI (Instrumentação de Gerenciamento do Microsoft Windows®), para determinar o valor da chave FSName do caminho do arquivo de log de transações do Exchange. Se o Exchange Server Analyzer determinar que o valor da chave FSName não é igual a NTFS, será exibido um erro.

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em volumes não-NTFS. Os arquivos de dados do Exchange incluem todos os arquivos a seguir:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

Se receber esse erro, mova os logs de transações para uma pasta em uma unidade NTFS. Como alternativa, se a unidade em que o diretório de log de transações está armazenado estiver formatada como uma unidade FAT, você poderá usar a ferramenta de linha de comando convert.exe para converter a unidade em NTFS.

Para mover os logs de transações no Exchange 2000 Server ou no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda os Grupos Administrativos, expanda seu grupo administrativo, expanda Servidores, clique com o botão direito em seu grupo de armazenamento e clique em Propriedades.

  3. Na guia Geral, em Local de log de transações, clique em Procurar.

  4. Digite o caminho para o novo local dos arquivos de log e clique em OK.

  5. Clique em OK.

Para mover o local de arquivos de log de transações do grupo de armazenamento do Exchange para o Exchange Server 2007

  1. Siga as orientações contidas na documentação principal do Exchange Server 2007, "Como definir ou alterar o local de arquivos de log do grupo de armazenamento" (em inglês) (http://go.microsoft.com/fwlink/?LinkID=80702).

Como alternativa ao procedimento acima, se a unidade em que os arquivos estão armazenados estiver formatada como uma unidade FAT, você poderá usar a ferramenta de linha de comando convert.exe para converter a unidade em NTFS. Para obter mais informações sobre como usar a ferramenta de linha de comando convert.exe para converter uma partição FAT em uma partição NTFS, consulte o artigo 214579 da Base de Dados de Conhecimento Microsoft, "Como usar o Convert.exe para converter uma partição em um sistema de arquivos NTFS" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579).


Os logs de transações do Exchange são gravados em uma pasta compactada
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Directory para determinar o valor da chave Compactado para a pasta que contém os logs de transações de armazenamento de informações do Exchange: Se o valor de Compactado estiver definido como Verdadeiro nesta pasta, será exibido um erro.

Quando uma mensagem é entregue ao Exchange, ela é primeiramente gravada nos logs de transações antes de ser confirmada no armazenamento e entregue. Em um computador do Exchange 2000 Server ou Exchange Server 2003, os logs de transações são gravados no seguinte local padrão:

<unidade> :\Arquivos de Programas\Exchsrvr\mdbdata

Em um computador do Exchange Server 2007, os logs de transações são gravados no seguinte local padrão:

<unidade> :\Arquivos de Programas\Microsoft\Exchange Server\Caixa de Correio\<Nome do Grupo de Armazenamento>

A Microsoft não oferece suporte para o armazenamento de arquivos de dados do Exchange em um volume NTFS compactado. Quando você armazenar seus arquivos de dados do Exchange em um volume compactado, a sobrecarga adicional impactará bastante o desempenho do Exchange. Além disso, quando um banco de dados de armazenamento de informações atinge um determinado tamanho (aproximadamente 4 GB), a sua montagem pode falhar ou ele pode ser danificado.

Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Arquivos que são gerenciados pelo ESE (Mecanismo de Armazenamento Extensível) não devem ser armazenados em uma unidade compactada. O Mecanismo de Armazenamento Extensível (ESE) depende da independência de setor para a recuperação baseada em log, e a compactação de arquivos invalida essa independência. A compactação não deve ser ativada para os volumes que hospedam bancos de dados ESE, ou qualquer banco de dados que usa o log de write-ahead.

Antes do Exchange 2000 Server Service Pack 3, era possível montar bancos de dados compactados de armazenamento de informações. Contudo, podem ocorrer danos em bancos de dados ou logs de armazenamento de informações do Exchange 2000 Server compactados por meio da compactação NTFS.

Com o Exchange 2000 Server Service Pack 3, arquivos do banco de dados de armazenamento de informações compactados de 128 MB ou menos são descompactados automaticamente. Quando os arquivos de banco de dados atingem um tamanho acima de 128 MB, o banco de dados não é montado e são geradas mensagens de erro no log do aplicativo. O Exchange 2000 Server Service Pack 3 impede a montagem de bancos de dados compactados com mais de 128 MB.

Para desativar a compactação de uma pasta específica

  1. Clique com o botão direito na pasta onde você deseja desativar a compactação de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Compactar o conteúdo para economizar espaço em disco e clique em OK.

Para mover os logs de transações no Exchange 2000 Server ou no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda os Grupos Administrativos, expanda seu grupo administrativo, expanda Servidores, clique com o botão direito em seu grupo de armazenamento e clique em Propriedades.

  3. Na guia Geral, em Local de log de transação, clique em Procurar.

  4. Digite o caminho para o novo local dos arquivos de log e, depois, clique em OK.

  5. Clique em OK.

Para mover o local de arquivos de log de transações de um grupo de armazenamento do Exchange para o Exchange Server 2007

  1. Siga as orientações contidas na documentação principal do Exchange Server 2007, "Como Definir ou Alterar o Local de Arquivos de Log do Grupo de Armazenamento" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80702).

Para obter mais informações sobre como mover arquivos de log no Exchange Server 2003, consulte o artigo 821915 da Base de Dados de Conhecimento da Microsoft, "Como mover bancos de dados e logs do Exchange no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915).

Para obter mais informações sobre como mover arquivos de log no Exchange 2000 Server, consulte o artigo 239944 da Base de Dados de Conhecimento, "Como mover os logs de sistema ou de transações para outro local" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944).


Os logs de transações do Exchange são gravados em uma pasta criptografada
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-02-27

A ferramenta Microsoft Exchange Analyzer Tool consulta a classe Win32_Directory de WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Encrypted da pasta que contém os logs de transações do armazenamento de informações. Se o Exchange Analyzer detectar que o valor de Encrypted está definido como True, um erro será exibido.

Quando uma mensagem é entregue ao Exchange, ela é primeiramente gravada nos logs de transações antes de ser confirmada no armazenamento e entregue. Em um computador do Exchange 2000 Server ou Exchange Server 2003, os logs de transações são gravados no seguinte local padrão:

<unidade> :\Arquivos de Programas\Exchsrvr\mdbdata

Em um computador do Exchange Server 2007, os logs de transações são gravados no seguinte local padrão:

<unidade> :\Arquivos de Programas\Microsoft\Exchange Server\Caixa de Correio\<Nome do Grupo de Armazenamento>

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em um volume criptografado com EFS (Sistema de Criptografia de Arquivos). Quando você armazena seus arquivos de dados do Exchange em um volume criptografado, a sobrecarga adicional afeta significativamente o desempenho do Exchange Server. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Para ajudar a proteger seus arquivos de dados do Exchange, é recomendável que você impeça o acesso não autorizado ao computador do Exchange e que você use o formato de mensagem S/MIME para criptografar dados de mensagens.

Para resolver esse erro, você deve desativar a criptografia de arquivo na pasta onde os logs de transações estão sendo gravados ou mover os logs de transações para uma pasta em que a criptografia não esteja habilitada.

Para desativar a criptografia de arquivos em uma pasta especificada

  1. Clique com o botão direito na pasta em que deseja desativar a criptografia de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Criptografar o conteúdo para proteger dados e clique em OK.

Para mover os logs de transações no Exchange 2000 Server ou no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda os Grupos Administrativos, expanda seu grupo administrativo, expanda Servidores, clique com o botão direito em seu grupo de armazenamento e clique em Propriedades.

  3. Na guia Geral, em Local de log de transação, clique em Procurar.

  4. Digite o caminho para o novo local dos arquivos de log e, depois, clique em OK.

  5. Clique em OK.

Para mover o local de arquivos de log de transações do grupo de armazenamento do Exchange para o Exchange Server 2007

  1. Siga as orientações contidas na documentação principal do Exchange Server 2007, "Como definir ou alterar o local de arquivos de log do grupo de armazenamento" (em inglês) (http://go.microsoft.com/fwlink/?LinkID=80702).

Para obter mais informações sobre como mover arquivos de log, consulte o artigo 821915 da Base de Dados de Conhecimento da Microsoft, "Como mover bancos de dados e logs no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915).

Para obter mais informações sobre arquivos de dados do Exchange Server, consulte o artigo 834638 da Base de Dados de Conhecimento Microsoft, "Informações sobre o armazenamento de arquivos de dados em um volume criptografado no Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Para obter informações sobre como proteger mensagens no Microsoft Exchange Server 2003, consulte o Guia de Segurança de Mensagens do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=47574).


Os contadores de desempenho do ESE estendido estão habilitados
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte chave de Registro para determinar se o servidor Exchange inclui contadores estendidos do ESE (Mecanismo de Armazenamento Extensível) em sua biblioteca de contadores de desempenho:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ESE\Performance\Show Advanced Counters

Se o Exchange Server Analyzer perceber que o valor de dados da chave de Registro Show Advanced Counters é 1, ele exibirá uma mensagem de configuração não padrão.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para desabilitar os contadores de desempenho estendidos do ESE

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Exclua o valor Exibir Contadores Avançados na chave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ESE\Performance do Registro.

  3. Feche o editor de Registro.

  4. Reinicie o Monitor de Desempenho para aplicar a alteração.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft , "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Contadores de desempenho de armazenamento estendido estão habilitados
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte chave de Registro para determinar se Mdbperfx.dll existe na biblioteca do servidor Exchange dos contadores de desempenho:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Performance

Se o Exchange Server Analyzer considerar que o valor da Biblioteca inclui a cadeia de caracteres "mdbperfx.dll", ele exibirá uma mensagem de configuração não-padrão.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

O DLL Mdbperf.dll contém o conjunto padrão de contadores de desempenho de armazenamento. O DLL Mdbperfx.dll contém o mesmo conjunto padrão dos contadores de desempenho de armazenamento e também contém o conjunto estendido de contadores de desempenho de armazenamento.

Por padrão, os dados de valor da Biblioteca incluem o DLL Mdbperf.dll. Por padrão, os dados de valor da Biblioteca não contêm o DLL Mdbperfx.dll. A tabela a seguir lista os contadores de desempenho de armazenamento estendidos que o DLL Mdbperfx.dll contém.

Contador | Destino
FXGetBufferRopsCalled | O número total de operações RPC (Remote Procedure Call) FXGetBuffer
FXGetBufferRopsCalledPerSec | O número de operações RPC FXGetBuffer por segundo
FXGetBufferRopsAcceptedPerSec | O número de operações RPC FXGetBuffer aceitas por segundo
FXGetBufferRopsDenied | O número total de operações RPC FXGetBuffer negadas
FXGetBufferRopsDeniedPerSec | O número de operações RPC FXGetBuffer negadas por segundo
FXGetBufferCurrentCallerCount | O número de operações RPC FXGetBuffer simultâneas
FXGetBufferCurrentUsersExecuting | O número de operações RPC FXGetBuffer simultâneas em execução
Mensagens Verificadas como MIME | O número total de mensagens de nível superior processadas como MIME pelo verificador de vírus.
Mensagens Verificadas como MIME/s | A taxa de mensagens de nível superior processadas como MIME pelo verificador de vírus.
Mensagens Verificadas como MAPI | O número total de mensagens de nível superior processadas como MAPI pelo verificador de vírus.
Mensagens Verificadas como MAPI/s | A taxa de mensagens de nível superior processadas como MAPI pelo verificador de vírus.
Bytes Lidos | O número total de bytes lidos pelo verificador de vírus
Bytes Gravados | O número total de bytes gravados pelo verificador de vírus
Comprimento da Fila (Baixa Prioridade) | Número atual de solicitações pendentes de baixa prioridade que estão na fila para verificação de vírus
Threads | O número atual de threads em um pool de threads utilizados para verificação de vírus. Esta contagem não inclui o número de threads utilizados para verificação em segundo plano.
Verificações Certificadas pelo Carimbo de MFT | O número de vezes em que as verificações de vírus foram certificadas pelo carimbo na tabela Message Folder.
Verificações Certificadas pelo Carimbo MFT/s | A taxa com que as verificações de vírus são certificadas pelo carimbo na tabela Message Folder.
Verificações Certificadas pelo Carimbo de Instância | O número de vezes em que as verificações de vírus foram certificadas pelo carimbo da instância.
Verificações Certificadas pelo Carimbo de Instância/s | O número de vezes em que as verificações de vírus foram certificadas pelo carimbo da instância principal.
Verificações Certificadas pelo Carimbo de Instância Principal/s | A taxa com que as verificações de vírus são certificadas pelo carimbo da instância principal.
Verificações Não Certificadas | O número de vezes em que as verificações de vírus não foram certificadas por carimbo algum
Verificações Não Certificadas/s | A taxa com que verificações de vírus não são certificadas por carimbo algum
Bloqueios por Verificações | O número de vezes em que o processamento foi bloqueado para aguardar a conclusão da verificação de vírus.
Bloqueios por Verificações/s | A velocidade com que o processamento é bloqueado para aguardar a conclusão da verificação de vírus
Tempo Limite da Verificação | O número de vezes em que esgotou o tempo limite das operações que estavam aguardando a conclusão da verificação de vírus
Tempo Limite da Verificação/s | A taxa em que se esgotou o tempo limite das operações que estavam aguardando a conclusão da verificação de vírus
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para ativar os contadores de desempenho de armazenamento padrão

  1. Inicie um editor de Registro, como Regedit.exe ou Regedt32.exe.

  2. Localize o valor da Biblioteca sob a seguinte chave de Registro:

    HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\Performance

  3. No menu Editar, clique em Modificar.

  4. Na caixa Dados de Valor, altere o valor de c:\Arquivos de Programas\Exchsrvr\bin\mdbperfx.dll para c:\Arquivos de Programas\exchsrvr\bin\mdbperf.dll.

  5. Clique em OK e feche o editor de Registro.

  6. Reinicie o Monitor de Desempenho para aplicar a alteração.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a coleta de dados de desempenho sobre armazenamento do Exchange, consulte o artigo 821912 da Base de Dados de Conhecimento, "Como Coletar Dados de Diagnóstico para Ajudar a Resolver os Problemas de Armazenamento de Informações" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821912).


O parâmetro Constante de Retirada FXGetBuffer é não-padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte chave de Registro para determinar se o valor FXGetBuffer Backoff Constant foi criado:

HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se o Exchange Server Analyzer perceber que o valor FXGetBuffer Backoff Constant foi criado na chave de Registro ParametersSystem, o Exchange Server Analyzer exibirá uma mensagem de configuração não padrão.

Você pode usar o valor FXGetBuffer Backoff Constantpara controlar o número de clientes Microsoft Office Outlook® 2003 que são sincronizados com um servidor Exchange Server 2003 ao mesmo tempo. Você define o valor FXGetBuffer Backoff Constant para configurar a quantidade de tempo que um cliente Outlook deve esperar antes de tentar sincronizar novamente. O valor padrão do valor FXGetBuffer Backoff Constant é de 500 milissegundos.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária. No entanto, você pode excluir a chave de Registro FXGetBuffer Backoff Constant se desejar restaurar a configuração padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, consulte o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para restaurar a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Exclua o valor FXGetBuffer Backoff Constant.

  4. Feche o editor de Registro.

O serviço Armazenamento de Informações do Microsoft Exchange detecta as alterações em minutos. Não é necessário reiniciar o computador.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a configuração de chaves de Registro para controlar o número de clientes do Outlook que podem estar sincronizados com o Exchange Server 2003, consulte o artigo 818484 da Base de Dados de Conhecimento, "Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484).


O parâmetro de Contagem de Repetições FXGetBuffer é não padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte chave de Registro para determinar se o valor FXGetBuffer Retry Count foi criado:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se o Exchange Server Analyzer perceber que o valor FXGetBuffer Retry Count foi criado na chave de Registro ParametersSystem, o Exchange Server Analyzer exibirá uma mensagem de configuração não padrão.

Você pode usar o valor FXGetBuffer Retry Count para controlar o número de clientes Microsoft Office Outlook® 2003 que são sincronizados com um servidor Exchange Server 2003 ao mesmo tempo. Você define o valor FXGetBuffer Retry Count para configurar o número de vezes que um cliente do Outlook pode tentar sincronizar antes de ter o acesso concedido. O valor padrão é 10.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária. No entanto, você pode excluir a chave de Registro FXGetBuffer Retry Count se desejar restaurar a configuração padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, consulte o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para restaurar a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Exclua o valor FXGetBuffer Retry Count.

  4. Feche o editor de Registro.

O serviço Armazenamento de Informações do Microsoft Exchange detecta as alterações em minutos. Não é necessário reiniciar o computador.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a configuração de chaves de Registro para controlar o número de clientes do Outlook que podem estar sincronizados com o Exchange Server 2003, consulte o artigo 818484 da Base de Dados de Conhecimento, "Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484).


O parâmetro Ignorar Regra de Ausência Temporária Inválida foi definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer lê o Registro do computador do Exchange Server para verificar a presença da entrada de Registro Ignorar Regra Inválida de Ausência Temporária. Esse valor de Registro está presente em:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

Se o Exchange Server Analyzer verificar que a entrada do Registro Ignorar Regra Inválida de Ausência Temporária está presente e configurada com um valor de 1 ou maior, será exibida uma mensagem de configuração não padrão.

A entrada de Registro Ignorar Regra Inválida de Ausência Temporária é uma definição de configuração do Exchange 2000 Server, Exchange Server 2003 e Exchange Server 2007 criada especificamente para funcionar com o hotfix descrito no artigo 828875 da Base de Dados de Conhecimento da Microsoft, "Você não pode mover uma caixa de correio do Exchange depois de usar o utilitário Exmerge.exe" (em inglês) (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=828875).

Quando o programa Microsoft Exchange Mailbox Merge (Exmerge.exe) é usado para mover mensagens e outros itens de uma caixa de correio em um armazenamento para uma caixa de correio em outro armazenamento de caixa de correio, pode haver falha em uma tentativa subseqüente de mover a segunda caixa de correio. Isso pode acontecer por causa de uma regra de Ausência Temporária inválida nessa caixa de correio. Se desejar, você pode reverter para a configuração padrão, usando o procedimento descrito aqui.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. No painel da direita, localize e exclua o valor de Ignorar a Regra Inválida de Ausência Temporária.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O parâmetro de Registro Ignore Zombie Users foi definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool verifica no Registro do computador Exchange Server a presença da entrada de Registro Ignore Zombie users . Esse valor de Registro está presente em:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se o Exchange Server Analyzer encontrar a entrada de Registro Ignore Zombie users e ela estiver configurada com o valor 1 ou superior, será exibida uma mensagem de configuração não padrão.

Em uma organização do Exchange Server de vários modos, que contenha o Exchange Server 5.5 e o Exchange 2000 Server, ou em um ambiente anteriormente misto, talvez ocorram problemas nas seguintes condições:

  • Você atualiza a ACL (lista de controle de acesso) de caixas de correio e pastas públicas do Exchange Server 5.5 para o Exchange 2000 Server.

  • A ACL contém contas de usuário não representadas no serviço de diretório do Active Directory®.

Essas ACEs (entradas de controle de acesso) não usadas são conhecidas também como usuários zumbis. Desde março de 2003, após a distribuição do Service Pack 3 do Exchange 2000 Server, o comportamento padrão para o processamento de usuários zumbis foi alterado. Não é possível controlar esse comportamento usando a chave de Registro Ignore Zombie users.

O valor de Registro Ignore Zombie users pode ser usado nos servidores com o Exchange 2000 Server Service Pack 3 ou posterior instalado. Use essa entrada de Registro com cuidado e somente quando tiver certeza de que os usuários zumbis não resultam de problemas de replicação do ADC (Active Directory Connector), como latência. Esse valor de Registro faz com que o Exchange Server ignore os usuários zumbis e os remova da ACL das caixas de correio ou das pastas públicas. Se o usuário for válido, mas não estiver no Active Directory no momento em que a ACL for atualizada, ele será removido e você terá de adicioná-lo manualmente a cada ACL mais tarde.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel direito, localize e exclua o valor Ignore Zombie users.

  4. Feche o ADSI Edit e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como usar a chave de Registro Ignore Zombie Users, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 812963, "Usando a chave de Registro Ignore Zombie Users" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963)

  • 324323, "XADM: Ignorando contas de usuário não representadas no Active Directory durante a conversão da lista de controle de acesso" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323)


A manipulação de exceções de IMAIL foi desabilitada manualmente
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-17

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar a configuração do valor do Registro ExceptionHandling:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Se o Exchange Server Analyzer detectar o valor de Registro ExceptionHandling configurado com um valor igual a 0, será exibido um aviso.

No Exchange Server, o tratamento de exceções de IMAIL está ativado por padrão e não pode ser desativado pela interface do usuário. Entretanto, o tratamento de exceções de IMAIL pode ser desativado por meio do Registro.

A Microsoft recomenda que o tratamento de exceções de IMAIL permaneça habilitado, a menos que você esteja solucionando um problema ativamente. Por exemplo, você pode desativar o tratamento de exceções de IMAIL se tiver aplicativos personalizados que disparam eventos baseados em conteúdo MIME (Multipurpose Internet Mail Extensions) ou MAPI. A Microsoft recomenda que o tratamento de exceções de IMAIL seja desativado somente sob a orientação e instruções dos analistas de suporte do Atendimento Microsoft.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent.

  3. Clique duas vezes em ExceptionHandling:

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor de Registro ExceptionHandling, consulte o artigo 832174 da Base de Dados de Conhecimento, "Não há nenhuma opção para desativar a manipulação de exceções de IMAIL no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832174).


O serviço Armazenamento de Informações está configurado para interagir com a área de trabalho
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft®) Win32_Service para determinar o valor da propriedade DesktopInteract para o serviço MSExchangeIS (Armazenamento de Informações do Microsoft Exchange). Se o Analisador do Exchange Server detectar que o serviço de Armazenamento de Informações do Microsoft Exchange está configurado para interagir com a área de trabalho, o Analisador do Exchange Server exibirá um erro.

Essa configuração deve ser usada somente sob orientação do Atendimento Microsoft. A menos que o Atendimento Microsoft tenha orientado você a executar o serviço de Armazenamento de Informações do Microsoft Exchange nessa configuração, recomenda-se reconfigurar as propriedades do serviço Armazenamento de Informações do Microsoft Exchange para que não interaja com a área de trabalho.

Para configurar a conta de serviço de Armazenamento de Informações do Exchange

  1. Abra o snap-in Serviços do MMC.

  2. Localize e pare o serviço Armazenamento de Informações do Microsoft Exchange.

  3. Clique duas vezes no serviço Armazenamento de Informações do Microsoft Exchange.

  4. Na guia Logon da página Propriedades de Armazenamento de Informações do Microsoft Exchange, selecione Conta Sistema Local em Fazer logon como.

  5. Desmarque a caixa de seleção Permitir que o serviço interaja com a área de trabalho e clique em Aplicar.

  6. Em Status do Serviço, clique em Iniciar e clique em OK.

  7. Feche o snap-in Serviços.

Para obter mais informações sobre a configuração correta do serviço do Exchange, consulte o artigo 239762 da Base de Dados de Conhecimento Microsoft, "Serviços do Exchange executados em LocalSystem" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Aumentar o tamanho máximo do banco de dados para armazenamento da caixa de correio
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-12-15

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_DataFile de WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar as informações a seguir:

  • O caminho completo dos arquivos de banco de dados do Exchange.

  • O tamanho atual do armazenamento de caixa de correio.

O Exchange Server Analyzer também consulta a classe Win32_OperatingSystem de WMI para determinar informações adicionais:

  • A versão do sistema operacional Windows que está sendo executada no servidor Exchange.

  • A versão do Exchange Server que está instalada.

  • A edição do Exchange Server que está instalada.

  • A versão do nível do service pack para Exchange Server.

Finalmente, o Exchange Server Analyzer também lê a entrada de Registro a seguir para determinar se o valor de Database Size in Gb foi definido:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<NomedoServidor>\Private-<MailboxStoreGUID>

O Exchange Server Best Practices Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O servidor está executando o Exchange Server 2003.

  • O serviço tem o Service Pack 2 para Exchange Server 2003 instalado.

  • O tamanho do banco de dados do Exchange Server é maior que 16 gigabytes (GB).

  • O valor do Registro Database Size in Gb não foi definido.

Este erro indica que o tamanho do banco de dados do Exchange identificado está próximo a seu limite. O Service Pack 2 para Exchange Server 2003 aumenta os limites de armazenamento do banco de dados de 16 GB para 75 GB. Entretanto, para usar os novos limites, você deve adicionar manualmente o valor do Registro Database Size in Gb no Exchange Server.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse erro adicionando o valor do Registro Database Size em Gb (Tamanho do banco de dados em GB)

  1. No computador que está executando o Exchange Server, abra o editor de Registro, como Regedit.exe ou RegEdt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<NomedoServidor>\Private-<MailboxStoreGUID>

  3. Clique com o botão direito em MailboxStoreGUID, aponte para Novo e clique em Valor DWORD.

  4. Para o nome do novo valor, digite Limite de Tamanho do Banco de Dados em Gb.

  5. Clique duas vezes em Limite de Tamanho do Banco de Dados em Gb. Em Dados do Valor, digite um valor apropriado para o tamanho máximo do banco de dados, em GB. Clique em OK.

  6. Clique com o botão direito em MailboxStoreGUID, aponte para Novo e clique em Valor DWORD.

  7. Para o nome do novo valor, digite Buffer de Tamanho do Banco de Dados em Porcentagem.

  8. Clique duas vezes em Buffer de Tamanho do Banco de Dados em Porcentagem. Em Dados do Valor, digite um valor entre 1 e 100 para especificar quando você deseja que os eventos a serem registrados lhe avisem que você está se aproximando do tamanho máximo do banco de dados. Clique em OK.

    Observação:
    O valor padrão de 10 fará com que eventos de aviso sejam registrados quando restarem 10% da capacidade antes de você alcançar o tamanho máximo para esse banco de dados.

  9. Clique com o botão direito em MailboxStoreGUID, aponte para Novo e clique em Valor DWORD.

  10. Para o novo nome, digite Horário de Início da Verificação de Tamanho do Banco de Dados, em Horas Depois da Meia-Noite.

  11. Clique duas vezes em Horário de Início da Verificação de Tamanho do Banco de Dados, em Horas Depois da Meia-Noite. Em Dados do valor, digite um valor entre 0 e 23 para especificar quando deseja que o Exchange verifique o tamanho do banco de dados. Clique em OK.

    Observação:
    O valor padrão 5 faz com que o Exchange Server examine o tamanho do banco de dados 5 horas após meia-noite (05:00).

  12. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar e gerenciar os limites de tamanho de banco de dados do Exchange Server, consulte "Configuração e gerenciamento de limites de tamanho de banco de dados" (http://go.microsoft.com/fwlink/?LinkId=57029) (página em inglês).

Para obter informações sobre o tamanho máximo do banco de dados para o Exchange Server 2003 Standard Edition e Exchange 2000 Server Standard Edition, consulte o artigo 828070 da Base de Dados de Conhecimento Microsoft, "O armazenamento da caixa de correio do Exchange Server não é montado quando o banco de dados de Armazenamento da Caixa de Correio alcança o limite de 16 GB" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070) (em inglês).

Para obter mais informações sobre o SP2 para Exchange Server 2003, consulte o site do Exchange Server 2003 Service Pack 2, "Por que experimentar o Service Pack 2 para Exchange Server 2003?" (http://go.microsoft.com/fwlink/?LinkId=52073) (em inglês).


Aumentar o tamanho máximo do banco de dados para armazenamento de pasta pública
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-12-15

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_DataFile de WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar as informações a seguir:

  • O caminho completo para os arquivos de banco de dados do Exchange Server.

  • O tamanho atual do armazenamento de pasta pública.

O Exchange Server Analyzer também consulta a classe Win32_OperatingSystem de WMI para determinar informações adicionais:

  • A versão do sistema operacional Windows que está sendo executada no servidor Exchange.

  • A versão do Exchange Server que está instalada.

  • A edição do Exchange Server que está instalada.

  • A versão do nível do service pack para Exchange Server.

Finalmente, o Exchange Server Analyzer também lê a entrada de Registro a seguir para determinar se o valor de Database Size in Gb foi definido:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nome_do_Servidor>\Public-<GUID_de_Armazenamento_Público>

O Exchange Server Best Practices Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O servidor está executando o Exchange Server 2003.

  • O serviço tem o Service Pack 2 para Exchange Server 2003 instalado.

  • O tamanho do banco de dados do Exchange é maior que 16 gigabytes (GB).

  • O valor do Registro Database Size in Gb não foi definido.

Este erro indica que o banco de dados do Exchange Server identificado está próximo a seu limite de tamanho. O Service Pack 2 para Exchange Server 2003 aumenta os limites de armazenamento do banco de dados de 16 GB para 75 GB. Entretanto, para usar os novos limites, você deve adicionar manualmente o valor do Registro Database Size in Gb no Exchange Server.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse erro adicionando o valor do Registro Database Size em Gb (Tamanho do banco de dados em GB)

  1. No computador que está executando o Exchange Server, abra o editor de Registro, como Regedit.exe ou RegEdt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nome_do_Servidor>\Public-<GUID_de_Armazenamento_Público>

  3. Clique com o botão direito em GUID_de_Armazenamento_Público, aponte para Novo e clique em Valor DWORD.

  4. Para o nome do novo valor, digite Limite de Tamanho do Banco de Dados em Gb.

  5. Clique duas vezes em Limite de Tamanho do Banco de Dados em Gb. Em Dados do Valor, digite um valor apropriado para o tamanho máximo do banco de dados, em GB. Clique em OK.

  6. Clique com o botão direito em GUID_de_Armazenamento_Público, aponte para Novo e clique em Valor DWORD.

  7. Para o nome do novo valor, digite Buffer de Tamanho do Banco de Dados em Porcentagem.

  8. Clique duas vezes em Buffer de Tamanho do Banco de Dados em Porcentagem. Em Dados do Valor, digite um valor entre 1 e 100 para especificar quando você deseja que os eventos a serem registrados lhe avisem que você está se aproximando do tamanho máximo do banco de dados. Clique em OK.

    Observação:
    O valor padrão de 10 fará com que eventos de aviso sejam registrados quando restarem 10% da capacidade antes de você alcançar o tamanho máximo para esse banco de dados.

  9. Clique com o botão direito em GUID_de_Armazenamento_Público, aponte para Novo e clique em Valor DWORD.

  10. Para o novo nome, digite Horário de Início da Verificação de Tamanho do Banco de Dados, em Horas Depois da Meia-Noite.

  11. Clique duas vezes em Horário de Início da Verificação de Tamanho do Banco de Dados, em Horas Depois da Meia-Noite. Em Dados do valor, digite um valor entre 0 e 23 para especificar quando deseja que o Exchange verifique o tamanho do banco de dados. Clique em OK.

    Observação:
    O valor padrão 5 faz com que o Exchange Server examine o tamanho do banco de dados 5 horas após meia-noite (05:00).

  12. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar e gerenciar os limites de tamanho do banco de dados do Exchange, consulte "Configuração e gerenciamento de limites de tamanho de banco de dados" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=57029).

Para obter informações sobre o tamanho máximo do banco de dados para o Exchange Server 2003 Standard Edition e Exchange 2000 Server Standard Edition, consulte o artigo 828070 da Base de Dados de Conhecimento Microsoft, "O armazenamento da caixa de correio do Exchange Server não é montado quando o banco de dados de Armazenamento da Caixa de Correio alcança o limite de 16 GB" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070) (em inglês).

Para obter mais informações sobre o SP2 para Exchange Server 2003, consulte o site do Exchange Server 2003 Service Pack 2, "Por que experimentar o Service Pack 2 para Exchange Server 2003?" (http://go.microsoft.com/fwlink/?LinkId=52073) (em inglês).


Aumentar configuração de Buffers de Log do Log de Transações
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer determinou que o número de buffers de log do servidor é muito baixo. A ferramenta detectou que o valor de Paralizações de Registros de Log\Banco de Dados (Instância de Armazenamento de Informações)/seg do servidor é superior a 10 paralizações por segundo. Um valor superior a 10 indica que há um backup sendo gravado no log de transações. Essa situação pode ocorrer porque a unidade de log de transações ultrapassa sua capacidade de transferência ou porque os buffers de log estão definidos com um valor muito baixo.

As E/S de gravação de log são seqüenciais e de thread único, por isso a latência na E/S do log muitas vezes é um afunilamento para o sistema. As E/S de log são gravadas nos buffers de log primeiro; em seguida, o buffer é limpo por uma confirmação de capacidade ou não ociosa. Confirmação não ociosa significa que o buffer de log é gravado no disco imediatamente. Confirmação de capacidade significa que o buffer de log é gravado no disco quando o buffer está cheio.

O aumento do tamanho do buffer de log reduz a freqüência de liberações de capacidade, aumenta o tamanho da gravação de log e subseqüentemente reduz a latência geral de gravação de log. A redução da latência de gravação de E/S de log é uma forma importante de melhorar desempenho/escalabilidade da implementação do Exchange.

A recomendação geral é aumentar o tamanho do buffer para no máximo 9.000 no Exchange Server 2003 e para 512 no Exchange 2000 Server.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse aviso

  1. Inicie o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração, expanda CN=Serviços, CN=Microsoft Exchange e CN=NomeOrganizaçãoExchange.

  3. Expanda CN=Administrative Groups, expanda CN=AdministrativeGroupName e expanda CN=Servers.

  4. Expanda CN=ExchangeServerName, expanda CN=InformationStore, clique com o botão direito em CN=Storage Group Name e clique em Propriedades.

  5. Na caixa de diálogo Selecionar uma propriedade a ser exibida, clique em msExchESEParamLogBuffers.

  6. Na caixa de diálogo Editar Atributo, digite o valor apropriado da sua versão do Exchange para msExchESEParamLogBuffers e clique em Definir.

    Observação:
    Nos computadores que estiverem executando Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1), Exchange 2000 Server SP2 ou Exchange 2000 SP3, defina o valor como 512. Nos computadores que estiverem executando a versão original do Exchange Server 2003 ou do Exchange Server 2003 SP1, defina o valor como 9.000.

  7. Clique em Aplicar e em OK.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre como trabalhar com buffers de log, consulte o artigo "Buffers de log ESE definidos com um valor muito baixo podem fazer com que o serviço de Armazenamento de Informações do Microsoft Exchange pare de responder" da Base de Dados de Conhecimento Microsoft (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328466).


Porcentagem de memória inicial definida
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-05

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o valor de Porcentagem de Memória Inicial foi definido:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se o Exchange Server Analyzer detectar o valor Porcentagem de Memória Inicial presente e configurado com qualquer valor maior do que 0, será exibida uma mensagem de configuração não padrão.

A configuração do Registro Porcentagem de Memória Inicial foi introduzida como um mecanismo de ajuste fino da quantidade inicial de memória alocada para o armazenamento de informações do Exchange em 10 por cento da memória física total no servidor Exchange. Se você iniciar com essa alocação inicial e aumentar a partir daí, a fragmentação da memória virtual não ocorrerá com tanta freqüência. Esse valor do Registro não deve ser definido arbitrariamente e deve ser usado apenas sob orientação e instruções do Atendimento Microsoft.

As versões do Exchange Server do Exchange Server 2003 e posteriores incluem suporte para opções especiais de inicialização no Microsoft Windows® 2000 Advanced Server e Windows Server™ 2003, que ajudam a reduzir a fragmentação da memória virtual. Também foram feitas alterações adicionais para ajudar a evitar a fragmentação da memória virtual dos clusters do Exchange Server. Portanto, o valor do Registro Porcentagem de Memória Inicial não é mais necessário em versões do Exchange Server do Exchange Server 2003 e posteriores.

O valor de Registro Porcentagem de Memória Inicial funciona somente em computadores que estejam executando o Exchange 2000 Server. O Exchange Server 2003 e o Exchange Server 2007 irão ignorar esse valor se ele estiver presente e ele não terá nenhum efeito. Portanto, remova essa entrada de Registro antes de atualizar esse servidor Exchange do Exchange 2000 Server para o Exchange Server 2003.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para remover a definição de Registro Porcentagem de Memória Inicial

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel da direita, exclua o valor Porcentagem de Memória Inicial.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.
  • Para obter mais informações sobre um problema conhecido ao usar esse valor de Registro, consulte o artigo 810883 da Base de Dados de Conhecimento da Microsoft, "O valor de Registro 'Porcentagem de Memória Inicial' não tem efeito" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810883).

  • Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


A entrada de Registro Tamanho em KB da Reserva Inicial foi definida
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-04-27

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar se a entrada do Registro Tamanho em KB da Reserva Inicial está presente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Se o Exchange Server Analyzer detectar a presença da chave de Registro Tamanho em KB da Reserva Inicial e sua configuração com um valor acima de 0, será exibida uma mensagem de configuração não padrão.

O valor do Registro Tamanho em KB da Reserva Inicial é usado para reservar memória adicional para espaço de heap. O valor especificado é em kilobytes. O valor padrão para a maioria dos servidores Exchange é 655360 quilobytes (KB), que é igual a 640 megabytes (MB). Você pode reduzir esse valor para aumentar a quantidade de memória livre disponível e reduzir a fragmentação da memória virtual. Esse valor deve ser definido apenas com orientação e instruções dos profissionais de suporte do Atendimento Microsoft. Essa é uma mensagem informativa, e não é necessária nenhuma ação corretiva se esse valor do Registro foi adicionado sob orientação dos profissionais de suporte do Atendimento Microsoft.

Se você acha que essa entrada foi definida incorretamente, pode removê-la e voltar à configuração padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

  3. Exclua o valor chamado Tamanho em KB da Reserva Inicial.

  4. Feche o ADSI Edit e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre fragmentação de memória virtual, consulte o artigo da Base de Conhecimento, "COMO: Solucionar Problemas de Fragmentação da Memória Virtual no Exchange Server 2003 e Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)


O atributo legacyExchangeDN desse banco de dados do Exchange não corresponde ao servidor Exchange
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para conhecer o valor do atributo legacyExchangeDN de todos os bancos de dados de armazenamento de caixas de correio em um computador com o Exchange Server. Se o Exchange Server Analyzer detectar que o valor do atributo legacyExchangeDN de qualquer armazenamento de caixas de correio não corresponde ao do computador do Exchange Server que contém o armazenamento de caixas de correio, um erro será exibido.

Um atributo legacyExchangeDN incompatível poderia resultar do fato de um administrador ter modificado o Active Directory para recuperar um banco de dados em uma situação de recuperação de desastre. Para solucionar esse erro, é necessário modificar o atributo legacyExchangeDN usando o editor do Active Directory, como a ferramenta LDP (ldp.exe) ou o recurso ADSI (Active Directory Service Interfaces) Edit.

Para verificar se o atributo legacyExchangeDN está correto, examine o atributo legacyExchangeDN do servidor onde esse banco de dados reside, uma vez que, por ser um objeto filho desse servidor, esse banco de dados terá o mesmo legacyExchangeDN.

Examine também outros bancos de dados existentes neste servidor Exchange que não geraram esse erro, pois eles devem ter o mesmo legacyExchangeDN. Lembre-se de que vários outros objetos do sistema também têm esse atributo. Em uma situação em que o atributo legacyExchangeDN está inconsistente em um banco de dados, é provável que o atributo também esteja inconsistente nos vários outros objetos do sistema. Por essa razão, se você usar o LDP ou o ADSI Edit para corrigir um valor legacyExchangeDN, será necessário fazer isso em todos os demais objetos do sistema também.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003, do Exchange Server 2007, ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Expanda Configuração [DomainName] e expanda CN=Configuration,DC=DomainName,DC=DomainSuffix.

  3. Expanda a entrada CN=Services e expanda CN=Microsoft Exchange.

  4. Expanda CN=OrganizationName, expanda CN=Administrative Groups e expanda CN=AdminGroupName.

  5. Expanda as entradas CN=Servers, CN=ServerName e CN=InformationStore.

  6. Selecione CN=StorageGroupName e, no painel à direita, clique com o botão direito no armazenamento de caixas de correio cujo atributo legacyExchangeDN esteja consistente e clique em Propriedades.

  7. Role para legacyExchangeDN, selecione-o e clique em Editar.

  8. No campo Valor, digite o legacyExchangeDN correto.

  9. Feche o editor do Active Directory e reinicie o computador com o Exchange Server para que a alteração entre em vigor.

Para obter mais informações sobre como usar o ADSI Edit para criar um novo atributo legacyExchangeDN, consulte o artigo 273863 da Base de Dados de Conhecimento da Microsoft, "Como alterar o atributo LegacyExchangeDN no modo nativo com o ADSI Edit" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863).


O valor legacyExchangeDN está ausente nesse banco de dados do Exchange
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para conhecer o valor do atributo legacyExchangeDN de todos os bancos de dados de armazenamento de caixas de correio em um computador com o Exchange Server. Se o Exchange Server Analyzer não detectar um valor para o atributo legacyExchangeDN em nenhum armazenamento de caixa de correio, um erro será exibido.

A ausência de um atributo legacyExchangeDN poderia resultar do fato de um administrador ter modificado o Active Directory para recuperar um banco de dados em uma situação de recuperação de desastre. Para solucionar esse erro, é necessário modificar o atributo legacyExchangeDN usando o editor do Active Directory, como a ferramenta LDP (ldp.exe) ou o ADSI (Active Directory Service Interfaces) Edit.

Para verificar se o atributo legacyExchangeDN está correto, examine o atributo legacyExchangeDN do servidor onde esse banco de dados reside, pois sendo objeto filho desse servidor, esse banco de dados terá o mesmo legacyExchangeDN.

Examine também outros bancos de dados existentes neste servidor Exchange que não geraram esse erro, pois eles devem ter o mesmo legacyExchangeDN. Lembre-se de que vários outros objetos do sistema também têm esse atributo. Em uma situação de ausência do atributo legacyExchangeDN em um banco de dados, é provável que o atributo também esteja ausente em diversos outros objetos do sistema. Por essa razão, se você usar a ferramenta LDP ou ADSI Edit para adicionar um novo valor legacyExchangeDN, será necessário fazer isso em todos os demais objetos do sistema também.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, Exchange Server 2003 ou Exchange Server 2007, ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Expanda Configuration [DomainName], expanda, CN=Configuration,DC=DomainName,DC=DomainSuffix.

  3. Expanda a entrada CN=Services e expanda CN=Microsoft Exchange.

  4. Expanda CN=OrganizationName, expanda CN=Administrative Groups e expanda CN=AdminGroupName.

  5. Expanda as entradas CN=Servers, CN=ServerName e CN=InformationStore.

  6. Selecione CN=StorageGroupName e, no painel direito, clique com o botão direito no armazenamento de caixa de correio cujo atributo legacyExchangeDN está ausente e clique em Propriedades.

  7. Role para baixo para localizar legacyExchangeDN, selecione-o e clique em Editar.

  8. No campo Valor, digite o legacyExchangeDN correto.

  9. Feche o editor do Active Directory e reinicie o computador com o Exchange Server para que a alteração entre em vigor.

Para obter mais informações sobre como usar o ADSI Edit para criar um novo atributo legacyExchangeDN, consulte o artigo 273863 da Base de Dados de Conhecimento da Microsoft, "Como alterar o atributo LegacyExchangeDN no modo nativo com o ADSI Edit" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863).


O parâmetro LimitBodyParts foi definido manualmente
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada de Registro para determinar se o limite padrão de anexos em uma mensagem foi alterado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\LimitBodyParts

Se o Exchange Server Analyzer detectar que o valor do Registro LimitBodyParts está presente e configurado, uma mensagem de configuração não padrão será exibida.

Pelo design e por motivos de segurança, o Exchange Server limita o número de anexos (chamados partes do corpo) a 250. Se uma mensagem contiver mais de 250 anexos, um erro MAPI_E_TOO_BIG será gerado. Além disso, o serviço Armazenamento de Informações do Microsoft Exchange pode consumir memória e recursos de CPU em excesso com um número grande de anexos.

Existe uma oportunidade de configuração que permite aos administradores adicionar o valor do Registro LimitBodyParts e configurá-lo para usar um valor superior a 250. Na ausência dessa entrada, o valor padrão de 250 será usado.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para exibir ou alterar o valor do Registro LimitBodyParts

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. Examine e, se desejar, altere o valor LimitBodyParts. O valor aceito para essa entrada de Registro é qualquer número inteiro entre 250 e 4.294.967.295.

  4. Se for feita uma alteração, reinicie o computador do Exchange Server para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O parâmetro LimitEmbeddingDepth foi definido manualmente
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-30

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se os limites padrão do cabeçalho MIME no Exchange foram alterados:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Se o Exchange Server Analyzer verificar que algum valor de LimitEmbeddingDepth não foi definido, será exibida uma mensagem de configuração não padrão.

O Exchange 2000 Server Service Pack 3, o Exchange Server 2003 e o Exchange Server 2007 contém funcionalidade atualizada no processo de armazenamento de informações (store.exe) que define como MIMEs grandes ou formados irregularmente são manipulados. Essa funcionalidade foi adicionada para proteger melhor o Exchange Server contra ataques de negação de serviço mal-intencionados e mensagens MIME involuntariamente grandes e complexas. Alguns exemplos dos limites impostos a mensagens MIME enviadas ao armazenamento incluem limitação do número de destinatários, limitação do número de mensagens incorporadas e limitação do tamanho dos cabeçalhos MIME individuais.

Os valores padrão desses vários limites de cabeçalho MIME estão definidos no processo de armazenamento. No entanto, se uma chave de Registro tiver sido configurada para definir qualquer um desses limites, ela irá substituir o valor padrão de store.exe. Quando qualquer um dos diversos limites é excedido em uma mensagem MIME, uma notificação de falha na entrega é enviada ao remetente.

A limitação da profundidade de incorporação de MIME se refere ao número de mensagens MIME que podem ser incorporadas umas nas outras. Por exemplo, suponha que você recebeu a mensagem (m1) com uma mensagem anexada (m2). Quando você abre a mensagem anexada (m2), verifica que também há uma mensagem (m3) anexada a essa mensagem (m2). Assim, a mensagem original (m1) tem mensagens incorporadas em uma profundidade de 3 níveis. Por padrão, o Exchange permitirá mensagens com um nível de profundidade de incorporação de 100. Mensagens com mensagens incorporadas que excedam 100 níveis de profundidade podem consumir toda a memória de um servidor Exchange durante o tempo que leva para o servidor "desembrulhar" a mensagem, analisá-la e convertê-la em MAPI. É muito improvável que algum cliente de email ou servidor gere uma mensagem com esse nível de mensagens incorporadas. É mais provável que uma mensagem assim seja resultado de usuários mal-intencionados tentando um ataque de negação de serviço em seu sistema de mensagens.

Para reverter para a configuração padrão

  • Não é necessário executar nenhuma ação. A entrada de Registro estará presente apenas quando o hotfix do artigo 833607 da Base de Dados de Conhecimento da Microsoft, "O serviço Armazenamento de Informações do Microsoft Exchange usa 100 por cento dos recursos de CPU em um Exchange 2000 Server ou Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833607), foi instalado. O hotfix cria a entrada do Registro LimitEmbeddingDepth e a define com o valor 10.

Para obter mais informações sobre service packs e hotfixes do Exchange Server, consulte o artigo 328839 da Base de Dados de Conhecimento, "Como aplicar service packs e hotfixes do Exchange" (página em inglês) ( http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


O parâmetro LimitNestingLevels foi definido manualmente
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se os limites padrão de cabeçalho MIME (Multipurpose Internet Mail Extensions) no Exchange foram alterados:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Se o Exchange Server Analyzer verificar que foi definido algum valor para LimitNestingLevels, uma mensagem de configuração não padrão será exibida.

As partes MIME em um item de mensagem podem ser aninhadas. Se o nível de aninhamento for alto, o processo de conversão requer cada vez mais recursos para decodificar toda a mensagem. Uma única mensagem com uma parte MIME aninhada em 700 níveis pode demorar até 10 minutos para ser processada. Ao receber mensagens da Internet com as partes MIME aninhadas, o processo de conversão para para as partes MIME pode fazer com a entrega dessas mensagens seja lenta. Durante a entrega das mensagens, o servidor exigirá uma grande quantidade de recursos do sistema, especialmente da memória. Se um grande número dessas mensagens forem recebidas ao mesmo tempo, o sistema pode relatar pouca memória virtual disponível.

A limitação dos níveis de aninhamento do MIME refere-se ao número de tipos de conteúdo do MIME (como multipartes/misto ou multipartes/alternativo) que podem ser aninhados entre si. As mensagens geradas pela maioria dos clientes de e-mail (incluindo o Microsoft Outlook® e o Outlook Express) e os servidores de e-mail contêm poucos tipos de conteúdo MIME aninhados. Por exemplo, uma mensagem típica (mesmo com várias respostas, será representada em uma mensagem MIME como um tipo único de conteúdo. Os vários níveis de aninhamento são, em geral, resultado de um processo automatizado, que contrói mensagens MIME para usos específicos (como um aplicativo do fluxo de trabalho) ou de uma mensagem maliciosa construída com a finalidade específica de consumir recursos no servidor de e-mail.

Além de reforçar os níveis de aninhamento para o tipo de conteúdo, o Exchange Server utilizará o valor LimitNestingLevels (definido como um valor do Registro ou como valor padrão no processo de armazenamento) para forçar um limite para mensagens incorporadas. Se o valor do Registro LimitNestingLevels não estiver definido, o valor padrão de 30 níveis de aninhamento será forçado. O limite de mensagens incorporadas é definido multiplicando-se o valor de LimitNestingLevels por 16. Portanto, o valor padrão para o número de mensagens incorporadas é 480. Por exemplo, se LimitNestingLevels estiver configurado com o valor 5, serão aceitos, no máximo, 80 anexos.

Para reverter para a configuração padrão

  • Não é necessário executar nenhuma ação. O Exchange Server Analyzer está exibindo uma configuração não padrão para suas informações.

Para obter mais informações sobre o hotfix do Exchange 2000 Server relacionado ao valor do Registro LimitNestingLevels, consulte o artigo 289775 da Base de Dados de Conhecimento da Microsoft, "XADM: O Exchange 2000 Server tem falhas de memória causadas por excesso de mensagens incorporadas" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=289775).


O parâmetro LimitRecipients foi definido manualmente
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se os limites padrão do cabeçalho MIME no Exchange foram alterados:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Se o Exchange Server Analyzer verificar que foi definido algum valor para LimitRecipients, um aviso de configuração não padrão será exibido.

O Exchange 2000 Server Service Pack 2 (SP2) e versões posteriores do Exchange Server incluem funcionalidade atualizada no processo de armazenamento (store.exe) que define como MIMEs grandes ou formados de forma irregular são tratados. Essa funcionalidade foi adicionada para proteger mais o Exchange como destino contra ataques de negação de serviço por mensagens MIME maliciosas e excepcionais (involuntariamente grandes e complexas). Alguns exemplos dos limites impostos a mensagens MIME enviadas ao armazenamento incluem limitação do número de destinatários, limitação do número de mensagens incorporadas e limitação do tamanho dos cabeçalhos MIME individuais. Em versões anteriores do Exchange, nas quais os cabeçalhos MIME não vinculados podem entrar no armazenamento do Exchange para processamento, as mensagens MIME muito grandes ou complexas podem consumir quase todos os recursos (principalmente CPU) como resultado da análise, indexação e processamento do MIME.

Os valores padrão desses vários limites de cabeçalho MIME estão definidos no processo de armazenamento. No entanto, se uma chave de Registro tiver sido configurada para definir qualquer um desses limites, ela irá substituir o valor padrão de store.exe. Quando qualquer um dos diversos limites é excedido em uma mensagem MIME, uma notificação de falha na entrega é enviada ao remetente.

Se a chave de Registro LimitRecipients tiver sido definida, provavelmente é resultado de orientação do Atendimento Microsoft, já que essa chave não foi publicada. Sendo assim, a Microsoft não recomenda que essa configuração seja alterada.

O valor padrão de LimitRecipients (se não houver nenhuma chave de Registro) no processo de armazenamento é 65.535 destinatários por mensagem MIME.


Os buffers de log não estão otimizados para servidores com armazenamento de disco replicado que estão executando o Exchange Server 2003
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se as seguintes condições são verdadeiras:

  • O computador está executando o Exchange Server 2003.

  • O valor de msExchESEParamLogBuffers está entre 0 e 8.960.

O Exchange Server Analyzer consulta a classe Win32_PerfRawData_MSExchangeIS_MSExchangeIS do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se a seguinte condição é verdadeira:

  • O valor de VMLargestBlockSize é maior que 150.000.000.

O Exchange Server Analyzer determina se um dos seguintes serviços está em execução:

  • GeoSpanService

  • SRDFService

Se todas as condições mencionadas anteriormente forem verdadeiras, um erro será exibido.

O ESE (Mecanismo de Armazenamento Extensível) usa buffers de log para manter as transações na memória antes de confirmá-las nos logs de transações. Se não houver buffers de log suficientes, você poderá ter um número excessivo de E/Ss de disco na unidade de log de transações; isso reduzirá o desempenho.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP (ldp.exe) ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir esse erro

  1. No recurso ADSI Edit (Active Directory Service Interfaces), clique duas vezes no contêiner Configuração, expanda CN=Services, expanda CN=Microsoft Exchange e expanda CN=ExchangeOrganizationName.

  2. Expanda CN=Administrative Groups, expanda CN=AdministrativeGroupName e expanda CN=Servers.

  3. Expanda CN=ExchangeServerName, expanda CN=InformationStore, clique com o botão direito em CN=Storage Group Name e clique em Propriedades.

  4. Na caixa de diálogo Selecionar uma propriedade para exibição, clique em msExchESEParamLogBuffers.

  5. Na caixa Editar Atributo, digite 9000 para msExchESEParamLogBuffers e clique em Definir.

  6. Clique em Aplicar e em OK.

  7. Para que a alteração seja efetivada, reinicie o serviço Armazenamento de Informações do Microsoft Exchange.

Para obter mais informações, consulte o artigo 328466 da Base de Dados de Conhecimento Microsoft, "Buffers de log do ESE definidos com um valor muito baixo podem fazer com que o serviço Armazenamento de Informações do Microsoft Exchange pare de responder" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).


Os buffers de log podem não ser suficientes para os servidores com alto número de caixas de correio que estão executando o Exchange Server 2003
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-03-27

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se as seguintes condições são verdadeiras:

  • O computador está executando o Exchange Server 2003.

  • O valor de msExchESEParamLogBuffers está entre 0 e 8.960.

  • O número de caixas de correio no grupo de armazenamento é superior a 500.

O Exchange Server Analyzer consulta a classe Win32_PerfRawData_MSExchangeIS_MSExchangeIS do Microsoft WMI (Windows® Management Instrumentation) para determinar se a seguinte condição é verdadeira:

  • O valor de VMLargestBlockSize é superior a 150 milhões.

Se todas essas condições forem verdadeiras, um aviso será exibido.

O mecanismo de armazenamento extensível (ESE) utiliza buffers de log para manter transações na memória antes de confirmá-las nos logs de transações. Se não houver buffers de log suficientes, talvez você veja um número excessivo de E/Ss de disco na unidade de log de transações; isso reduzirá o desempenho.

Para corrigir esse aviso

  1. No recurso ADSI Edit (Active Directory Service Interfaces), clique duas vezes no contêiner Configuração, expanda CN=Services, expanda CN=Microsoft Exchange e expanda CN=ExchangeOrganizationName.

  2. Expanda CN=Administrative Groups, expanda CN=AdministrativeGroupName e expanda CN=Servers.

  3. Expanda CN=ExchangeServerName, expanda CN=InformationStore, clique com o botão direito em CN=Storage Group Name e clique em Propriedades.

  4. Na caixa Selecionar uma propriedade para exibição, clique em msExchESEParamLogBuffers.

  5. Na caixa Editar Atributo, digite 9000 para msExchESEParamLogBuffers e clique em Definir.

  6. Clique em Aplicar e em OK.

  7. Para que a alteração seja efetivada, reinicie o serviço Armazenamento de Informações do Microsoft Exchange.
Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP (ldp.exe) ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para obter mais informações, consulte o artigo 328466 da Base de Dados de Conhecimento Microsoft, "Buffers de log do ESE definidos com um valor muito baixo podem fazer com que o serviço Armazenamento de Informações do Microsoft Exchange pare de responder" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).


Arquivos de log armazenados na unidade de rede
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchESEParamLogFilePath de cada objeto de grupo de armazenamento. Esse atributo especifica o local dos arquivos de log de transações usados por bancos de dados no grupo de armazenamento.

O Exchange Server Analyzer também consulta o Active Directory para determinar a contagem das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Se o Analisador do Exchange Server detectar que o atributo msExchESEParamLogFilePath inicia com \\ em um Exchange Server com mais de 50 caixas de correio, será exibido um erro.

Esse erro indica que os arquivos de log de transações de um grupo de armazenamento estão sendo armazenados em um compartilhamento da rede. Se o atributo msExchESEParamLogFilePath iniciar com \\, significa que o caminho de arquivo de log usa um caminho UNC (Convenção Universal de Nomenclatura). Esta não é uma prática recomendada porque interrupções na conectividade da rede podem gerar erros no log de transações e no banco de dados, resultando em perda de dados ou bancos de dados danificados. É recomendável que você corrija esse problema o mais rápido possível.

Para corrigir esse erro

  • Mova os logs de transações do compartilhamento da rede para um disco local. Para obter um desempenho ideal, coloque todos os logs de transações em unidades distintas.

Para obter informações sobre como mover os logs de transações para outro local, consulte o artigo 239944 da Base de Dados de Conhecimento da Microsoft, "XADM: Como mover os logs de transações ou do sistema para outro local" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239944).


Discrepância da geração de log
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool detectou uma discrepância na geração do arquivo de log. Esse erro indica que um arquivo de log de transações foi renomeado com um número de seqüência inadequado.

Os arquivos de log de transações do Exchange são nomeados de acordo com o seguinte formato: EnnXXXXX.log

  • XXXXX = Um número de seqüência hexadecimal de cinco dígitos. Quando um novo conjunto de arquivos de log de transações for gerado, o primeiro log na seqüência será 000001 e o log seguinte será 00002, e assim, sucessivamente. Como cada log de transações grava seu próprio número de seqüência em seu cabeçalho, é possível saber se o nome do arquivo de log foi alterado.

  • Enn = O prefixo do log, que é uma seqüência de 3 caracteres compartilhada por todos os logs de transações desse grupo de armazenamento. Geralmente, o prefixo será E00, E01, E02, E03 ou R00 (para um grupo de armazenamento de recuperação).

O log atual que está sendo gravado é nomeado somente com o prefixo do log. Esse log não recebe um número de seqüência antes de ser fechado e de um novo log atual ser gerado. Portanto, o arquivo de log atual pode ter o nome E00.log. Quando esse arquivo de log estiver cheio, poderá ser renomeado para E0012345.log. Um novo E00.log seria gerado com um número de seqüência interno de 12346.

Para corrigir esse erro

  • Renomeie o arquivo de log para o número de seqüência adequado.
Para exibir o número de seqüência interno

  • Execute o seguinte comando:

    C:\Arquivos de Programas\Exchsrvr\Bin\Eseutil.exe /ML [nome do arquivo de log]

    O valor de lGeneration na saída deste comando lista o número de seqüência real do arquivo de log.


Os pares de logs são inconsistentes
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool determinou que alguns de seus arquivos de log necessários são inconsistentes. Esse erro indica que os arquivos de log podem ter sido violados, movidos, copiados, renomeados ou excluídos manualmente.

Para corrigir esse erro

  • Para obter uma análise avançada dos arquivos de log, entre em contato com o Centro de Ajuda e Suporte da Microsoft (http://go.microsoft.com/fwlink/?LinkId=31845).


Discrepância da assinatura do log
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer verificou que a assinatura de log em um ou mais de seus arquivos de log não coincide com outros arquivos de log na mesma pasta.

Esse problema não ocorre a menos que os arquivos de log tenham sido movidos, excluídos ou desordenados manualmente.

Observação:
Essa é uma situação de recuperação avançada e você pode preferir entrar em contato com o Centro de Ajuda e Suporte da Microsoft (http://go.microsoft.com/fwlink/?LinkId=31845) antes da implementação.

Cada arquivo de log de transação do Exchange é marcado com uma assinatura chamada Assinatura de Log. Essa assinatura identifica arquivos de log individuais que pertencem à mesma série de logs. Cada banco de dados do Exchange grava a Assinatura de Log da série de logs de transação à qual o banco de dados foi anexado pela última vez.

Bancos de dados do Exchange também têm uma assinatura, chamada de Assinatura de BD. A Assinatura de BD é gerada quando o banco de dados é criado. Se você usar Eseutil para desfragmentar ou reparar um banco de dados essa assinatura será alterada, porque os processo de reparação e desfragmentação executam alterações nos arquivos do banco de dados, sem registrar essas alteraçãoes nos logs de transação. Para fins de log, o banco de dados resultante de uma operação de reparo ou desfragmentação é um banco de dados novo ou diferente.

Diferentemente de Assinaturas de BD, as Assinaturas de Log nunca são alteradas durante a vida de uma série de arquivos de log.

Os arquivos de log gravam as Assinaturas de BD de todos os bancos de dados anexados quando o log é criado. Os bancos de dados gravam a Assinatura de Log da série de logs à qual o banco de dados foi anexado mais recentemente. Portanto, as Assinaturas de BD e de Log são úteis para corresponder bancos de dados com arquivos de log de transação.

Você pode desanexar um banco de dados do Exchange de um conjunto de logs e anexá-lo a outro. Isso pode ser feito movendo-se o banco de dados para um grupo de armazenamento diferente, ou removendo-se todos os logs de transação de um grupo de armazenamento de iniciando-se uma nova série de logs.

Se o banco de dados estiver em estado de Desligamento Anormal, apenas arquivos de log de transação com assinaturas que coincidam com a Assinatura de Log no cabeçalho do banco de dados poderão ser repetidos com êxito no banco de dados. Em estado de Desligamento Anormal, o banco de dados ainda está anexado a um determinado fluxo de logs e só pode executar a recuperação com esse fluxo de logs.

Se um banco de dados estiver em estado de Desligamento Normal, você pode conseguir executar arquivos de log de transação cujas assinaturas não correspondam à Assinatura de Log no cabeçalho do banco de dados. Isso poderá ser feito apenas na seguinte circunstância:

  1. O banco de dados foi desligado corretamente ao final da seqüência anterior de arquivos de log.

  2. O banco de dados foi, em seguida, anexado a uma nova seqüência de arquivos de log de transação e você tem acesso ao log de transação no qual o banco de dados foi anexado pela primeira vez ao novo conjunto de logs.

Para corrigir esse erro

  • É necessário conhecer o histórico do banco de dados e sob que circunstâncias, em relação ao banco de dados, foram gerados os logs de transação.

  • Nessa situação, antes de tentar a recuperação, sempre faça uma cópia dos arquivos do banco de dados e dos logs de transação. Uma tentativa de recuperação errada pode alterar arquivos de banco de dados ou o log de transação de modo a impossibilitar outra tentativa de recuperação.

  • Repita apenas um conjunto de logs de transação por vez com o banco de dados. Mova outros logs de transação para fora da pasta de recuperação.

  • Se o banco de dados estiver em estado de Desligamento Anormal, primeiramente será necessário repetir com êxito os logs de transação aos quais o banco de dados está anexado e colocar o banco de dados em estado de Desligamento Normal. Então você pode conseguir executar o segundo conjunto de arquivos de log com o banco de dados.

  • Se o banco de dados estiver em estado de Desligamento Normal, não é possível examinar os logs ou o banco de dados para verificar com certeza qual conjunto de logs de transação é o correto para ser repetido em primeiro lugar.


O logon foi restrito a determinados usuários
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro no computador do Exchange Server para determinar se a lista de usuários que possuem permissão para fazer logon no armazenamento de informações do Exchange foi limitada:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Logon Only As

Se o Exchange Server Analyzer localizar o valor de Registro Logon Restrito, um aviso será exibido.

O valor de Registro Logon Restrito é um valor de várias cadeias de caracteres (REG_MULTI_SZ) que contém a lista de atributos legacyExchangeDN das contas autorizadas a fazer logon no armazenamento de informações do Exchange. Esse valor de Registro, que não está presente por padrão, é geralmente adicionado durante períodos de operações de solução de problemas, manutenção e movimentação de caixas de correio.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel da direita, exclua o valor de Registro Logon Restrito.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter mais informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Para obter mais informações sobre o valor de Registro Logon Restrito, consulte o artigo 146764 da Base de Dados de Conhecimento Microsoft, "Limitando logons ao armazenamento de informações" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=146764).

Para obter informações sobre como limitar logons durante operações de movimentação de caixas de correio, consulte o artigo 218920 da Base de Dados de Conhecimento, "XADM: Como evitar logons durante a movimentação de caixas de correio" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=218920).


O valor do Registro Lookup SID Cache Expire foi definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte chave de Registro para determinar se a entrada de Registro Lookup Sid Cache Expire está presente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

O Analisador do Exchange Server exibirá uma mensagem de configuração não padrão, se as seguintes condições existirem:

  • A entrada de Registro Lookup Sid Cache Expire está presente.

  • A entrada do Registro Lookup Sid Cache Expire tem um valor diferente de 3,600.

Em servidores Exchange que estão executando o Exchange 2000 Server Service Pack 3 ou posterior, o armazenamento de informações cria um cache que contém SIDs (Identificadores de Segurança) e indica se o SID é um objeto de usuário ou objeto de grupo. Esse cache é criado e preenchido quando uma pasta pública é acessada pela primeira vez. Após o cache ter sido preenchido, todas as chamadas para pesquisar SIDs de contas são direcionadas, primeiramente, para o cache de armazenamento de informações. Se o SID não estiver no cache de armazenamento de informações, a chamada será feita para o controlador de domínio e, em seguida, as informações desse SID será adicionada ao cache.

Por padrão, o cache é mantido por uma hora. Se o cache exceder o padrão de 8 quilobytes (KB) de entradas, as entradas de cache mais antigas são removidas para abrir espaço para novas entradas. Você pode usar duas chaves de Registro para ajustar o tempo de cache padrão (Lookup Sid Cache Expire) e o tamanho de cache padrão (Lookup Sid Cache Size). É recomendável que você não altere essas configurações padrão, a menos que você tenha certeza de que a alteração melhorará o desempenho.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. No painel da direita, localize e exclua o valor de Lookup Sid Cache Expire . Se o valor de Lookup SID Cache Size também estiver definido, exclua-o também.

  4. Saia do editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor de Registro Lookup Sid Cache Expire, consulte o artigo 328907 da Base de Dados de Conhecimento Microsoft, "XADM: Access Control List Upgrades Cause Slow Public Folder Performance; Fix Requires Exchange 2000 SP2" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907).


O valor de Registro do Tamanho do Cache do SID de Pesquisa foi definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte chave de Registro para determinar se a entrada de Registro Lookup Sid Cache Size está presente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

O Analisador do Exchange Server exibirá uma mensagem de configuração não padrão, se as seguintes condições existirem:

  • A entrada de Registro Lookup Sid Cache Size está presente.

  • A entrada do Registro Lookup Sid Cache Size tem um valor diferente de 1.024.

Em servidores Exchange que estão executando o Exchange 2000 Server Service Pack 3 ou posterior, o armazenamento de informações cria um cache que contém SIDs (Identificadores de Segurança) e indica se o SID é um objeto de usuário ou objeto de grupo. Esse cache é criado e preenchido quando uma pasta pública é acessada pela primeira vez. Após o cache ter sido preenchido, todas as chamadas para pesquisar SIDs de contas são direcionadas, primeiramente, para o cache de armazenamento de informações. Se o SID não estiver no cache de armazenamento de informações, a chamada será feita para o controlador de domínio e, em seguida, as informações desse SID será adicionada ao cache.

Por padrão, o cache é mantido por uma hora. Se o cache exceder o padrão de 8 quilobytes (KB) de entradas, as entradas de cache mais antigas são removidas para abrir espaço para novas entradas. Você pode usar duas chaves de Registro para ajustar o tempo de cache padrão (Lookup Sid Cache Expire) e o tamanho de cache padrão (Lookup Sid Cache Size). É recomendável que você não altere essas configurações padrão, a menos que você tenha certeza de que a alteração melhorará o desempenho.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. No painel da direita, localize e exclua o valor de Lookup Sid Cache Size . Se o valor de Lookup SID Cache Expire também estiver definido, exclua-o também.

  4. Saia do editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor de Registro Lookup Sid Cache Size, consulte o artigo 328907 da Base de Dados de Conhecimento Microsoft, "XADM: Access Control List Upgrades Cause Slow Public Folder Performance; Fix Requires Exchange 2000 SP2" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907).


O evento de erro de memória virtual baixa foi substituído
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar se o limite para registrar em log um evento relacionado à fragmentação de memória virtual foi substituído manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Error Level

Se o Exchange Server Analyzer descobrir que o valor de Registro Nível de Erro de VM está presente e configurado, uma mensagem de configuração não padrão será exibida.

Em sistemas do Microsoft Windows® de 32 bits, há dois tipos de memória: memória física (a quantidade de memória real instalada no sistema) e espaço de endereçamento de memória virtual (um espaço de memória virtualizado de 4 gigabytes). Independentemente de quanta memória física esteja instalada no sistema, o tamanho total do espaço do endereço virtual é sempre o mesmo: 4 GB. Embora não seja o caso de todos os aplicativos de 32 bits, para o Exchange Server, o espaço de endereçamento virtual é igual à memória virtual; em outras palavras, os termos são usados alternadamente.

Durante o curso normal de operações, o armazenamento de informações do Exchange alocará, usará e desalocará repetidamente a memória virtual. Quando a memória virtual é alocada, usada e desalocada freqüentemente, pode acontecer uma fragmentação de memória virtual. A fragmentação da memória virtual é análoga à fragmentação do sistema de arquivos que pode ocorrer com o passar do tempo. Depois de um tempo, segmentos alocados da memória virtual não estão mais contíguos e o desempenho começa a diminuir. No caso do sistema de arquivos, você pode executar um aplicativo que realize a desfragmentação desse sistema; na maioria dos casos, isso pode ser feito enquanto o sistema está online e sendo acessado. No caso de fragmentação de memória virtual, não há ferramenta de desfragmentação. Em vez disso, para corrigir o problema, é necessário parar e iniciar o serviço Armazenamento de Informações do Microsoft Exchange ou reinicializar o sistema.

Quando um computador com o Exchange Server possui menos de 16 MB de espaço de endereçamento virtual contíguo livre, a seguinte mensagem de erro é registrada no log de eventos do aplicativo:

Origem: | MSExchangeIS
Categoria: | Desempenho
ID: | 9582
Digite: | Erro
Descrição: | A memória virtual necessária para executar o servidor Exchange está fragmentada de tal maneira que a operação normal pode começar a falhar. É altamente recomendável reiniciar todos os serviços do Exchange para corrigir esse problema.

O valor de Registro Nível de Erro de VM representa uma oportunidade de configuração que permite que o administrador substitua o aviso padrão de nível de 16 MB e defina um valor alternativo.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel à direita, exclua o valor de Nível de Erro de VM.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre solução de problemas de fragmentação de memória virtual no Exchange Server 2003 e no Exchange 2000 Server, consulte o artigo 325044 da Base de Dados de Conhecimento Microsoft, "COMO: Solucionar Problemas de Fragmentação da Memória Virtual no Exchange Server 2003 e Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)


O evento de aviso de memória virtual baixa foi substituído
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a entrada de Registro a seguir para determinar se o limite para registrar um evento referente à fragmentação de memória virtual foi substituído manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Warning Level

Se o Exchange Server Analyzer descobrir que o valor de Registro VM Warning Level está presente e configurado, uma mensagem de configuração não-padrão será exibida.

Em sistemas do Microsoft Windows® de 32 bits, há dois tipos de memória: memória física (a quantidade de memória real instalada no sistema) e espaço de endereçamento de memória virtual (um espaço de memória virtualizado de 4 gigabytes). Independentemente de quanta memória física esteja instalada no sistema, o tamanho total do espaço do endereço virtual é sempre o mesmo: 4 GB. Embora não seja o caso de todos os aplicativos de 32 bits, para o Exchange Server, o espaço de endereçamento virtual é igual à memória virtual; em outras palavras, os termos são usados alternadamente.

Durante o curso regular das operações, o armazenamento de informações do Exchange alocará, usará e desalocará repetidas vezes a memória virtual. Quando a memória virtual é alocada, usada e desalocada freqüentemente, pode acontecer uma fragmentação de memória virtual. A fragmentação da memória virtual é análoga à fragmentação do sistema de arquivos que pode ocorrer com o passar do tempo. Depois de um tempo, segmentos alocados da memória virtual não estão mais contíguos e o desempenho começa a diminuir. Para o sistema de arquivos, você pode executar um aplicativo que execute a desfragmentação do arquivo. Normalmente, isso pode ser feito enquanto o sistema está online e sendo acessado. Para a fragmentação da memória virtual, não existe uma ferramenta de desfragmentação; em vez disso, para corrigir o problema, você deve parar e iniciar o serviço Armazenamentos de Informações do Microsoft Exchange ou reiniciar o sistema.

Por padrão, quando um computador do Exchange Server possui menos de 32 MB de espaço de endereçamento virtual contíguo livre, a seguinte mensagem de aviso é registrada no log de eventos do aplicativo:

Origem: | MSExchangeIS
Categoria: | Desempenho
ID: | 9582
Digite: | Aviso
Descrição: | A memória virtual necessária para executar o servidor Exchange está fragmentada de tal maneira que o desempenho pode ser afetado. É altamente recomendável reiniciar todos os serviços do Exchange para corrigir esse problema.

O valor de Registro VM Warning Level representa uma oportunidade de configuração que permite que um administrador substitua o aviso padrão de nível de 32 MB e defina um valor alternativo.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel da direita, exclua o valor de VM Warning Level.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre solução de problemas de fragmentação de memória virtual no Exchange Server 2003 e no Exchange 2000 Server, consulte o artigo 325044 da Base de Dados de Conhecimento Microsoft, "COMO: Solucionar Problemas de Fragmentação da Memória Virtual no Exchange Server 2003 e Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)


O Limite de Idade de Cache de Caixa de correio foi definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-15

O Microsoft® Exchange Server Analyzer Tool consulta o Registro do computador do Exchange Server para verificar a presença da entrada de Registro Mailbox Cache Age Limit. Esse valor de Registro está presente em:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se o Exchange Server Analyzer detectar que a entrada de Registro Mailbox Cache Age Limit está presente e configurada com um valor 1 ou maior, uma mensagem de configuração não padrão será exibida.

O Exchange Server permite que sejam definidos limites de tamanho (cotas) em caixas de correio. As configurações de cota são armazenadas no serviço de diretório do Active Directory® e o Exchange Server lê periodicamente as informações do Active Directory para determinar se alguma alteração foi feita nesses limites. Por padrão, o Exchange Server coloca essas informações em cache por um período de duas horas (120 minutos), após o qual ele lê as informações no Active Directory novamente.

O valor do Registro Mailbox Cache Age Limit, que é representado em minutos, é usado para substituir o período de tempo padrão. Isso é especialmente útil em uma situação em que um usuário não consegue acessar sua caixa de correio porque o limite foi alcançado. Se o limite de idade de cache padrão estiver em vigor, o usuário não conseguirá acessar sua caixa de correio por até duas horas. O valor recomendado é 20 minutos. Não defina esse valor muito baixo porque isso pode causar problemas de desempenho.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. No painel direito, localize e exclua o valor Mailbox Cache Age Limit.

  4. Saia do editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro Mailbox Cache Age Limit, consulte o artigo 327378 da Base de Dados de Conhecimento, "XADM: Os limites de tamanho de caixa de correio do Exchange 2000 e do Exchange Server 2003 não são exigidos por um período de tempo razoável; a correção exige o Exchange 2000 SP3" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378) (em inglês).


O limite ocioso do cache de caixa de correio foi definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar se o Limite Ocioso de Cache de Caixa de Correio está presente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se a ferramenta verificar a presença da entrada do Registro Mailbox Cache Idle Limit, uma mensagem de configuração não padrão será exibida.

O Exchange Server permite que sejam definidos limites de tamanho (cotas) em caixas de correio. As configurações de cota são armazenadas no serviço de diretório do Active Directory® e o Exchange Server periodicamente lê essas informações no Active Directory para determinar se ocorreram mudanças nesses limites. O Exchange Server armazena em cache essas informações durante um período de tempo, após o qual ele relê as informações no Active Directory.

A configuração Mailbox Cache Age Limit e a configuração Mailbox Cache Idle Limit controlam por quanto tempo as entradas do cache de informações da caixa de correio sobreviverão. Um item será removido do cache se ele estiver no cache há mais tempo (em segundos) que o definido na configuração Mailbox Cache Age Limit. Um item será removido do cache se ele não for usado pelo tempo (em segundos) definido em Mailbox Cache Idle Limit. Os valores padrão para essas configurações são 7.200 segundos (120 minutos) para a configuração Mailbox Cache Age Limit e 900 segundos (15 minutos) para a configuração Mailbox Cache Idle Limit. O valor da configuração Mailbox Cache Idle Limit não deve ser maior que o valor da configuração Mailbox Cache Age Limit.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. No painel da direita, localize e exclua o valor de Mailbox Cache Idle Limit .

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro de Limite de Idade de Cache da Caixa de Correio, consulte o artigo 327378 da Base de Dados de Conhecimento, "XADM: Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


Tamanho do Cache da Caixa de Correio foi definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar se o Tamanho do Cache da Caixa de Correio está presente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se o Analisador do Exchange Server detectar que a entrada de Registro de Tamanho do Cache da Caixa de Correio está presente, uma mensagem de configuração não padrão será exibida.

O valor do Tamanho do Cache da Caixa de Correio controla o tamanho do cache dessa caixa de correio. O valor padrão é 256 MB. O Exchange Server permite que sejam definidos limites de tamanho (cotas) em caixas de correio. As configurações de cota são armazenadas no serviço de diretório Active Directory® e o Exchange Server periodicamente lê essas informações para determinar se ocorreram mudanças nesses limites. Por padrão, o Exchange Server armazena essa informação em cache por um período de duas horas (7.200 segundos) e depois relê a informação no Active Directory.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel da direita, localize e exclua o valor do Tamanho do Cache da Caixa de Correio.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro de Limite de Idade de Cache da Caixa de Correio, consulte o artigo 327378 da Base de Dados de Conhecimento, "XADM: Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


Tamanho do Cache da Caixa de Correio definido como zero
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada de Registro a seguir para determinar a configuração do valor do Tamanho do Cache da Caixa de Correio:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se o Exchange Server Analyzer perceber que o valor do Tamanho do Cache da Caixa de Correio está definido como 0, um erro será exibido.

O Exchange Server permite que sejam definidos limites de tamanho (cotas) em caixas de correio. As configurações de cota são armazenadas no serviço de diretório Active Directory® e o Exchange Server periodicamente lê essas informações para determinar se ocorreram mudanças nesses limites. O valor do Tamanho do Cache da Caixa de Correio controla o tamanho do cache dessa caixa de correio. O valor padrão é 256 MB. Quando definido como 0, o cache da caixa de correio está desativado. Definir esse valor como 0 não é recomendado, pois isso faz com que o componente do DSAccess (Directory Service Access) execute mais pesquisas do Active Directory. Além disso, definir esse valor como 0 pode causar falhas no armazenamento do Exchange e na movimentação de caixas de correio.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel da direita, localize e exclua o valor do Tamanho do Cache da Caixa de Correio.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro de Limite de Idade de Cache da Caixa de Correio, consulte o artigo 327378 da Base de Dados de Conhecimento, "XADM: Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


Armazenamento de Caixa de Correio controlado por diretiva
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-06-06

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchPolicyList de cada objeto de armazenamento de caixa de correio. O atributo msExchPolicyList determina se uma diretiva de caixa de correio do Exchange Server foi criada e atribuída a um armazenamento de caixa de correio. Se o Exchange Server Analyzer perceber que o atributo msExchPolicyList foi definido, ele exibirá uma mensagem de configuração não padrão.

Por padrão, quando os armazenamentos de caixa de correio são criados, eles não têm uma diretiva de caixa de correio atribuída. Entretanto, na maioria das vezes, os administradores criam diretivas de caixa de correio e as atribuem a vários armazenamentos de caixa de correio. Essas diretivas se aplicam a configurações como limites de armazenamento, atualizações de índices, intervalos de manutenção, mapeamentos para armazenamentos públicos e listas de endereços offline. Se uma diretiva de caixa de correio foi criada e atribuída a um armazenamento de caixa de correio, o Exchange Server Analyzer exibirá uma mensagem declarando que o armazenamento de caixa de correio está atualmente controlado por uma diretiva de caixa de correio. Nenhuma ação adicional é necessária.

Para remover uma diretiva de caixa de correio de um armazenamento de caixa de correio

  1. Abra o Gerenciador do Sistema do Exchange e expanda Grupos Administrativos na árvore do console.

  2. Expanda o Primeiro Grupo Administrativo e selecione Diretivas do Sistema.

  3. No painel de resultados, clique com o botão direito no armazenamento de caixa de correio e selecione Remover da diretiva.

  4. Na janela Gerenciador do Sistema do Exchange, clique em Sim para confirmar a remoção do armazenamento de caixa de correio.
Observação:
Se o nó das Diretivas do Sistema não estiver visível na árvore do console no Gerenciador do Sistema do Exchange, configure o Gerenciador do Sistema do Exchange para exibir Grupos Administrativos.

Para obter mais informações sobre diretivas de armazenamento de caixas de correio, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 822938, "How To: Usar as diretivas do sistema para configurar os limites de armazenamento de Caixa de Correio no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938).

  • 256141, "Como criar diretivas do sistema no Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256141).

Para obter mais informações sobre os arquivos de banco de dados do Exchange Server, consulte os seguintes tópicos do Exchange Server 2003:

  • "Gerenciando os armazenamentos de Caixa de Correio e os armazenamentos de pasta pública" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

  • "Compreendendo o armazenamento do Exchange Server 2003" em Trabalhando com armazenamentos do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


Arquivo de banco de dados de armazenamento de caixa de correio armazenado na unidade de rede
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchEDBFile de cada objeto de armazenamento de caixa de correio. Esse atributo especifica o local dos arquivos de bancos de dados usador por esse armazenamento de caixa de correio.

O Exchange Server Analyzer também consulta o Active Directory para determinar a contagem dos valores listados no atributo homeMDBBL de cada armazenamento de caixa de correio nesse servidor. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio. O Exchange Server Analyzer pode, então, calcular o número total de caixas de correio gerenciadas pelo servidor.

Se o Exchange Server Analyzer verificar que o atributo msExchEDBFile inicia com \\ em um Exchange Server com mais de 50 caixas de correio, será exibido um erro.

Esse erro indica que os arquivos do banco de dados de um armazenamento de caixa de correio estão sendo armazenados em um compartilhamento de rede. Se o atributo msExchEDBFile começar com \\, significa que o caminho de arquivo de log usa um caminho UNC (Convenção Universal de Nomenclatura). Essa não é uma prática recomendada, porque interrupções na conectividade da rede podem causar erros no banco de dados, resultando em perda de dados ou bancos de dados danificados. É recomendável que você corrija esse problema o mais rápido possível.

Para mover os arquivos de banco de dados para uma nova unidade

  1. No Gerenciador do Sistema do Exchange, expanda o objeto do servidor Exchange no qual reside o armazenamento, expanda o contêiner do grupo de armazenamento apropriado, clique com o botão direito no objeto do armazenamento desejado e clique em Propriedades.

  2. Especifique novos locais de arquivo na guia Banco de dados da caixa de diálogo Propriedades.

Para obter mais informações sobre arquivos de banco de dados do Exchange Server, consulte os seguintes tópicos:

  • "Gerenciando armazenamentos de caixas de correio e de pastas públicas" no Guia de Administração do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47617)

  • "Understanding the Exchange Server 2003 Store" em Working with the Exchange Server 2003 Store (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595)

Para obter mais informações sobre como usar o Exchange Server com unidades de rede, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328879, "Using Exchange Server with Storage Attached Network and network-attached storage devices" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • 839687, "Microsoft support policy on the use of network-attached storage devices with Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • 317173, "Exchange Server and network-attached storage" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • 317172, "Exchange Server 5.5 and network-attached storage" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


O limite de tamanho de Banco de Dados do Armazenamento da Caixa de Correio foi definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o valor do Registro Database Size Limit in Gb está presente e configurado para bancos de dados de armazenamento de caixa de correio:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

Se o Exchange Server Analyzer considerar que o valor Limite do Tamanho do Banco de Dados em Gb está presente e configurado, ele exibirá uma mensagem de configuração não-padrão.

Quando o Exchange Server 2003 Service Pack 2 (SP2) é aplicado ao Exchange Server 2003 Standard Edition, o limite de tamanho do banco de dados codificado no licenciamento é aumentado de 16 gigabytes (GB) para 75 GB. Você pode definir um limite de proteção de tamanho de banco de dados para impedir o aumento não intencional do tamanho do banco de dados. O valor do limite de tamanho padrão no SP2 é 18 GB, e esse valor padrão pode ser substituído pela criação de um valor de Registro Limite de Tamanho do Banco de Dados em Gb.

O limite de tamanho, de 50 GB, do banco de dados codificado no licenciamento do Exchange Server 2007 Standard Edition também pode ser aumentado com a criação do valor de registro Database Size Limit in Gb.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Exclua o valor Limite de Tamanho do Banco de Dados em Gb.

  4. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter informações sobre o SP2 do Exchange Server 2003, consulte o site do Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


O armazenamento de caixa de correio não tem um armazenamento padrão de pasta pública
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o atributo msExchPrivateMDB tem um armazenamento padrão de pasta pública atribuído ao armazenamento de caixa de correio.

O atributo msExchPrivateMDB é uma configuração de banco de dados privado para um objeto de armazenamento de caixa de correio. Por padrão, o atributo msExchHomePublicMDB está associado a um armazenamento de caixa de correio. O atributo msExchPrivateMDB é o MDB (banco de dados de mensagens públicas) principal.

Se o Exchange Server Analyzer detectar que o atributo msExchHomePublicMDB está excluído ou configurado incorretamente, o Exchange Server Analyzer exibirá um erro.

Cada armazenamento de caixa de correio deve estar associado a um armazenamento padrão de pasta pública, no servidor local ou em outro servidor. Para cada usuário habilitado para caixa de correio que tem o suporte de um armazenamento de caixa de correio específico, o armazenamento de pasta pública associado é o armazenamento principal de pasta pública do usuário. Se possível, use o armazenamento padrão de pasta pública no mesmo servidor que o armazenamento de caixa de correio.

Observação:
Ao utilizar o armazenamento padrão de pasta pública no mesmo servidor que o armazenamento de caixa de correio, você pode melhorar o desempenho quando os usuários acessarem as pastas públicas e simplificar a solução de problemas de acesso a essas pastas.
Para atribuir um armazenamento de pasta pública padrão ao armazenamento de caixa de correio

  1. No Gerenciador do Sistema do Exchange, clique com o botão direito no grupo de armazenamento onde reside o Armazenamento de Caixa de Correio.

  2. Clique com o botão direito no armazenamento de caixa de correio e clique em Propriedades.

  3. Na guia Geral, em Armazenamento de Pasta Pública Padrão, clique em Procurar e selecione o armazenamento de pasta pública que será associado a esse armazenamento de caixa de correio.

    Observação:
    Se você estiver criando um novo armazenamento de caixa de correio, o Exchange Server selecionará automaticamente um armazenamento público padrão, que está associado à árvore Pastas Públicas, e um catálogo de endereços offline, que os usuários baixarão para uso offline.

Para obter mais informações sobre como gerenciar os armazenamentos de caixa de correio e de pasta pública, consulte o Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617) (em inglês).


O armazenamento de caixa de correio excede 12 GB
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-02-28

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_DataFile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave FileSize de cada arquivo de banco de dados de armazenamento de caixa de correio do Exchange (arquivo .edb) e arquivo de streaming (arquivo .stm). O Exchange Server Analyzer também lê a seguinte ramificação do Registro para determinar a versão do Exchange Server que está instalada:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

Se o Exchange Server Analyzer detectar que o tamanho combinado de um par de um banco de dados de armazenamento de caixa de correio e de arquivos de streaming excede 12 GB em um computador que esteja executando o Microsoft Exchange Server 2003 Standard Edition ou o Microsoft Exchange 2000 Server Standard Edition, um aviso será exibido.

Os bancos de dados de armazenamento do Exchange Server 2003 Standard Edition e do Exchange 2000 Server Standard Edition não podem ficar maiores do que 16 GB. Depois que esse limite é atingido, o armazenamento da caixa de correio não será mais montado, e o Exchange ficará inacessível. Os bancos de dados de armazenamento do Exchange Server 2003 Enterprise Edition e no Exchange 2000 Server Enterprise Edition não estão limitados a 16 GB; eles são limitados apenas pelo hardware disponível, com o tamanho máximo, em teoria, de 16 terabytes.

Para corrigir esse aviso

  1. Considere mover algumas das caixas de correio do armazenamento de caixa de correio grande para um novo armazenamento de caixa de correio neste ou em outro computador do Exchange Server.

  2. Se você tiver movido recentemente caixas de correio desse armazenamento de informações para outro armazenamento ou se tiver excluído recentemente caixas de correio desse armazenamento de caixas de correio, a execução de uma desfragmentação offline poderá diminuir o tamanho dos arquivos.

  3. Considere definir os limites de tamanho de mensagem e de caixa de correio para evitar o crescimento ilimitado do armazenamento de caixa de correio.
Observação:
Com o lançamento do Exchange Server 2003 Service Pack 2 (SP2) no Exchange Server 2003 Standard Edition, o limite de tamanho do banco de dados de licenciamento codificado foi aumentado de 16 GB para 75 GB. O administrador pode definir um limite de proteção de tamanho de banco de dados (impedir o aumento não intencional do tamanho do banco de dados). O valor padrão é 18 GB no SP2 para a Standard Edition e o padrão de 18 GB pode ser substituído, editando-se a Chave do Registro Limite de Tamanho do Banco de Dados em Gb.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar o limite de tamanho do banco de dados para um banco de dados com o Exchange Server 2003 SP2

  1. No computador que estiver executando o Exchange Server, inicie Regedit.exe.

  2. Abra a seguinte chave do Registro: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Nome do servidor\GUID de Armazenamento da Caixa de Correio Particular

  3. Clique com o botão direito em GUID de Armazenamento Particular, aponte para Novo e clique em Valor DWORD.

  4. Para o nome do novo valor, digite Limite de Tamanho do Banco de Dados em Gb.

  5. Clique duas vezes em Limite de Tamanho do Banco de Dados em Gb. Em Dados do Valor, digite um valor apropriado para o tamanho máximo do banco de dados, em GB. Para o Exchange Server 2003 Standard Edition, digite um valor decimal entre 1 e 75 (o padrão é 18 GB). Para o Exchange Server 2003 Enterprise Edition, digite um valor decimal entre 1 e 8000 (o padrão é 8000 GB). Clique em OK.

  6. Clique com o botão direito em GUID de Armazenamento Particular, aponte para Novo e clique em Valor DWORD.

  7. Para o nome do novo valor, digite Buffer de Tamanho do Banco de Dados em Porcentagem.

  8. Clique duas vezes em Buffer de Tamanho do Banco de Dados em Porcentagem. Em Dados do valor, digite um valor decimal entre 1 e 100 para especificar quando você deseja que os eventos a serem registrados avisem que você está próximo de atingir o tamanho máximo para um banco de dados. O valor padrão 10 resultará em avisos nos eventos a serem registrados quando houver apenas mais 10 por cento da capacidade antes de atingir o tamanho máximo para esse banco de dados. Clique em OK.

  9. Clique com o botão direito em GUID de Armazenamento Particular, aponte para Novo e clique em Valor DWORD.

  10. Para o novo nome, digite Horário de Início da Verificação de Tamanho do Banco de Dados, em Horas Depois da Meia-Noite.

  11. Clique duas vezes em Horário de Início da Verificação de Tamanho do Banco de Dados, em Horas Depois da Meia-Noite. Em Dados do Valor, digite um valor entre 0 e 23 para especificar quando você deseja que o Exchange verifique o tamanho do banco de dados. O valor padrão 5 faz com que o Exchange Server verifique o tamanho do banco de dados 5 horas depois da meia-noite (5:00 AM). Clique em OK.

  12. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre os arquivos .stm e .edb, consulte o artigo 232323 da Base de Dados de Conhecimento da Microsoft, "Armazenamento de conteúdo nativo no Microsoft Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Para obter mais informações sobre como mover caixas de correio no Exchange Server 2003, consulte o artigo 821829 da Base de Dados de Conhecimento, "Movendo caixas de correio no Exchange Server 2003" (http://go.microsoft.com/fwlink/?Linkld=3052&kbid=821829).

Para obter mais informações sobre como mover caixas de correio no Exchange 2000 Server, consulte o artigo 328810 da Base de Dados de Conhecimento, "Movendo caixas de correio entre servidores" (http://go.microsoft.com/fwlink/?Linkld=3052&kbid=328810).

Para obter mais informações sobre como executar uma desfragmentação offline de um banco de dados do Exchange Server, consulte o artigo 328804 da Base de Dados de Conhecimento, "Como desfragmentar bancos de dados do Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Para obter mais informações sobre como definir limites de tamanho de mensagens, consulte o artigo 322679 da Base de Dados de Conhecimento, "Definir limites de tamanho para mensagens" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679) (em inglês).

Para obter mais informações sobre quando se alcança o tamanho máximo de banco de dados no Exchange Server 2003 Standard Edition e no Microsoft Exchange 2000 Server Standard Edition, consulte o artigo 828070 da Base de Dados de Conhecimento, "O armazenamento da caixa de correio do Exchange Server não é montado quando o banco de dados do armazenamento da caixa de correio atinge o limite de 16 GB" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Para obter informações sobre o SP2 do Exchange Server 2003, consulte o site do Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


O armazenamento de caixa de correio excede 15 GB
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-02-28

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_DataFile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave FileSize de cada arquivo de banco de dados de armazenamento de caixa de correio do Exchange (arquivo .edb) e arquivo de streaming (arquivo .stm). O Exchange Server Analyzer também lê a seguinte ramificação do Registro para determinar a versão do Exchange Server que está instalada:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<GUID do Produto Exchange>

Se o Exchange Server Analyzer detectar que o tamanho combinado de um par de arquivos de streaming e de banco de dados de armazenamento de caixas de correio ultrapassa 15 GB em um computador que está executando o Microsoft Exchange Server 2003 Standard Edition ou o Microsoft Exchange 2000 Server Standard Edition, um erro será exibido.

Os bancos de dados de armazenamento do Exchange Server 2003 Standard Edition e do Exchange 2000 Server Standard Edition não podem ficar maiores do que 16 GB. Depois que esse limite é atingido, o armazenamento da caixa de correio não será mais montado, e o Exchange ficará inacessível. Os bancos de dados de armazenamento do Exchange Server 2003 Enterprise Edition e no Exchange 2000 Server Enterprise Edition não estão limitados a 16 GB; eles são limitados apenas pelo hardware disponível, com o tamanho máximo, em teoria, de 16 terabytes.

Para corrigir esse erro

  1. Considere mover algumas das caixas de correio do armazenamento de caixa de correio grande para um novo armazenamento de caixa de correio neste ou em outro computador do Exchange Server.

  2. Se você tiver movido recentemente caixas de correio desse armazenamento de informações para outro armazenamento ou se tiver excluído recentemente caixas de correio desse armazenamento de caixas de correio, a execução de uma desfragmentação offline poderá diminuir o tamanho dos arquivos.

  3. Considere definir os limites de tamanho de mensagem e de caixa de correio para evitar o crescimento ilimitado do armazenamento de caixa de correio.
Observação:
Com o lançamento do Exchange Server 2003 Service Pack 2 (SP2) no Exchange Server 2003 Standard Edition, o limite de tamanho do banco de dados de licenciamento codificado foi aumentado de 16 GB para 75 GB. O administrador pode definir um limite de proteção de tamanho de banco de dados (impedir o aumento não intencional do tamanho do banco de dados). O valor padrão é 18 GB no SP2 para Standard Edition e o padrão de 18 GB pode ser substituído com a edição da chave de Registro Database Size Limit in GB.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar o limite de tamanho do banco de dados para um banco de dados com o Exchange Server 2003 SP2

  1. No computador que estiver executando o Exchange Server, inicie Regedit.exe.

  2. Abra a seguinte chave do Registro: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Nome do servidor\GUID de Armazenamento da Caixa de Correio Particular

  3. Clique com o botão direito em GUID de Armazenamento Particular, aponte para Novo e clique em Valor DWORD.

  4. Para o nome do novo valor, digite Limite de Tamanho do Banco de Dados em Gb.

  5. Clique duas vezes em Limite de Tamanho do Banco de Dados em Gb. Em Dados do Valor, digite um valor apropriado para o tamanho máximo do banco de dados, em GB. Para o Exchange Server 2003 Standard Edition, digite um valor decimal entre 1 e 75 (o padrão é 18 GB). Para o Exchange Server 2003 Enterprise Edition, digite um valor decimal entre 1 e 8000 (o padrão é 8000 GB). Clique em OK.

  6. Clique com o botão direito em GUID de Armazenamento Particular, aponte para Novo e clique em Valor DWORD.

  7. Para o nome do novo valor, digite Buffer de Tamanho do Banco de Dados em Porcentagem.

  8. Clique duas vezes em Buffer de Tamanho do Banco de Dados em Porcentagem. Em Dados do valor, digite um valor decimal entre 1 e 100 para especificar quando você deseja que os eventos a serem registrados avisem que você está próximo de atingir o tamanho máximo para um banco de dados. O valor padrão 10 resultará em avisos nos eventos a serem registrados quando houver apenas mais 10 por cento da capacidade antes de atingir o tamanho máximo para esse banco de dados. Clique em OK.

  9. Clique com o botão direito em GUID de Armazenamento Particular, aponte para Novo e clique em Valor DWORD.

  10. Para o novo nome, digite Horário de Início da Verificação de Tamanho do Banco de Dados, em Horas Depois da Meia-Noite.

  11. Clique duas vezes em Horário de Início da Verificação de Tamanho do Banco de Dados, em Horas Depois da Meia-Noite. Em Dados do Valor, digite um valor entre 0 e 23 para especificar quando você deseja que o Exchange verifique o tamanho do banco de dados. O valor padrão 5 faz com que o Exchange Server verifique o tamanho do banco de dados 5 horas depois da meia-noite (5:00 AM). Clique em OK.

  12. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre os arquivos .stm e .edb, consulte o artigo 232323 da Base de Dados de Conhecimento da Microsoft, "Armazenamento de conteúdo nativo no Microsoft Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Para obter mais informações sobre como mover caixas de correio no Exchange Server 2003, consulte o artigo 821829 da Base de Dados de Conhecimento, "Movendo caixas de correio no Exchange Server 2003" (http://go.microsoft.com/fwlink/?Linkld=3052&kbid=821829).

Para obter mais informações sobre como mover caixas de correio no Exchange 2000 Server, consulte o artigo 328810 da Base de Dados de Conhecimento, "Movendo caixas de correio entre servidores" (http://go.microsoft.com/fwlink/?Linkld=3052&kbid=328810).

Para obter mais informações sobre como executar uma desfragmentação offline de um banco de dados do Exchange Server, consulte o artigo 328804 da Base de Dados de Conhecimento, "Como desfragmentar bancos de dados do Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Para obter mais informações sobre como definir limites de tamanho de mensagens, consulte o artigo 322679 da Base de Dados de Conhecimento, "Definir limites de tamanho para mensagens" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679) (em inglês).

Para obter mais informações sobre quando se alcança o tamanho máximo de banco de dados no Exchange Server 2003 Standard Edition e no Exchange 2000 Server Standard Edition, consulte o artigo 828070 da Base de Dados de Conhecimento, "O armazenamento da caixa de correio do Exchange não é montado quando o banco de dados do armazenamento da caixa de correio atinge o limite de 16 Gb" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Para obter informações sobre o SP2 do Exchange Server 2003, consulte o site do Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


Há mais de 8 dias que não é feito um backup completo do armazenamento de caixas de correio
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Analisador do Microsoft® Exchange Server consulta cada armazenamento de caixas de correio para conhecer a data e hora do último backup completo. O Analisador do Exchange Server consulta também o serviço de diretórios do Active Directory® para conhecer o número de usuários com caixas de correio em cada armazenamento de caixas de correio. O Analisador do Exchange Server exibirá um aviso se duas das seguintes condições existirem:

  • O número de dias desde o último backup completo de armazenamento de uma caixa de correio for superior a oito.

  • Existirem mais de dez caixas de correio no armazenamento de caixa de correio.

O armazenamento de caixas de correio é um banco de dados para armazenar caixas de correio no Microsoft Exchange Server 2003 e no Exchange Server 2007. Um armazenamento de caixas de correio é formado por um arquivo Rich Text (.edb) e um arquivo de streaming de conteúdo nativo da Internet (.stm). Embora existam dois arquivos, os arquivos .edb e .stm, eles representam duas metades de um único banco de dados, em vez de dois bancos de dados distintos.

Os dados do armazenamento de caixas de correio e do armazenamento de pastas públicas nos bancos de dados e logs de transações do Exchange Server são os dados mais importantes de um backup na organização do Exchange Server. Você pode usar um backup de banco de dados do Exchange Server para restaurar uma caixa de correio danificada em um servidor em funcionamento, que esteja executando o Exchange Server. Você também pode usar os backups de bancos de dados do Exchange Server para restaurar seus bancos de dados do Exchange Server em outro servidor.

Como uma prática recomendada, você deve fazer backup completo de seus arquivos de banco de dados e logs de transações diariamente. Depois de concluir um backup completo de um grupo de armazenamento, os arquivos de log de transações confirmados nos bancos de dados do Exchange Server serão excluídos do servidor. Um backup completo oferece a vantagem da velocidade em um cenário de recuperação, pois basta um conjunto de fitas para restaurar todos os dados.

Observação:
É uma prática recomendada manter os logs de transações em um disco dedicado, separadamente dos arquivos de bancos de dados. Isso permite tolerância a falhas se um disco do banco de dados for destruído e, em alguns casos, aumenta o desempenho do banco de dados.
Importante:
Ao tentar fazer backup ou restaurar arquivos e pastas, você deve ter os direitos ou as permissões necessários atribuídos para a conta do usuário com que efetuou logon. Para criar backups do Exchange Server, você deverá ter direitos de operador de backup em nível de domínio. Para criar backups do sistema operacional Microsoft Windows Server™ 2003, você deve ter, no mínimo, direitos de operador de backup local.

A estratégia de backup escolhida para seus dados do Exchange Server depende do tamanho dos armazenamentos, da velocidade do software e hardware de backup, da capacidade do hardware e dos requisitos de tempo.

Para obter mais informações sobre estratégias de backup e operações de recuperação de desastres, consulte:

  • Guia de operações de recuperação de desastres do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47570).

  • Backup e restauração de banco de dados (http://go.microsoft.com/fwlink/?LinkId=80766).


Há mais de 60 dias que não é feito um backup completo do armazenamento de caixas de correio
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Analisador do Microsoft® Exchange Server consulta cada armazenamento de caixas de correio para conhecer a data e hora do último backup completo. O Exchange Server Analyzer consulta também o serviço de diretório do Active Directory® para conhecer o número de usuários com caixas de correio em cada armazenamento de caixas de correio. O Exchange Server Analyzer exibe um erro se ambas as condições a seguir forem verdadeiras:

  • O número de dias desde o último backup completo de um armazenamento de caixa de correio é maior que 60 dias.

  • Há mais de 10 caixas de correio no armazenamento de caixa de correio.

O armazenamento de caixas de correio é um banco de dados para armazenar caixas de correio no Microsoft Exchange Server 2003 e no Microsoft Exchange Server 2007. Um armazenamento de caixas de correio é formado por um arquivo Rich Text (.edb) e um arquivo de streaming de conteúdo nativo da Internet (.stm). Embora existam dois arquivos, os arquivos .edb e .stm, eles representam duas metades de um único banco de dados, em vez de dois bancos de dados distintos.

Os dados do armazenamento de caixas de correio e do armazenamento de pastas públicas nos bancos de dados e logs de transações do Exchange Server são os dados mais importantes de um backup na organização do Exchange Server. Você pode usar um backup de banco de dados do Exchange Server para restaurar uma caixa de correio danificada em um servidor em funcionamento, que esteja executando o Exchange Server. Você também pode usar os backups de bancos de dados do Exchange Server para restaurar seus bancos de dados do Exchange Server em outro servidor.

Como uma prática recomendada, você deve fazer backup completo de seus arquivos de banco de dados e logs de transações diariamente. Após concluir um backup completo, os arquivos de log de transações confirmados nos bancos de dados do Exchange Server são excluídos do servidor. Um backup completo oferece a vantagem da velocidade em um cenário de recuperação, pois basta um conjunto de fitas para restaurar todos os dados.

Observação:
É uma prática recomendada manter os logs de transações em um disco dedicado, separadamente dos arquivos de bancos de dados. Isso permite tolerância a falhas se um disco do banco de dados for destruído e, em alguns casos, aumenta o desempenho do banco de dados.
Importante:
Ao tentar fazer backup ou restaurar arquivos e pastas, você deve ter os direitos ou as permissões necessários atribuídos para a conta do usuário com que efetuou logon. Para criar backups do Exchange Server, você deverá ter direitos de operador de backup em nível de domínio. Para criar backups do sistema operacional Microsoft Windows Server™ 2003, você deve ter, no mínimo, direitos de operador de backup local.

A estratégia de backup escolhida para seus dados do Exchange Server depende do tamanho dos armazenamentos, da velocidade do software e hardware de backup, da capacidade do hardware e dos requisitos de tempo.

Para obter mais informações sobre estratégias de backup e operações de recuperação de desastres, consulte:

  • Guia de Operações de Recuperação de Desastres do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47570).

  • Backup e Restauração de Banco de Dados (em inglês) (http://go.microsoft.com/fwlink/?LinkID=80766).


Sobreposição de agendamentos de manutenção online do armazenamento de caixas de correio
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar se todos os armazenamentos de caixas de correio do grupo de armazenamento têm o mesmo agendamento de manutenção. Se o contêiner do grupo de armazenamento (classe msExchStorageGroup) tiver dois ou mais objetos de armazenamentos de caixas de correio (classe msExchPrivMDB), o Analisador do Exchange Server verificará o atributo activationSchedule de cada objeto de armazenamento de caixa de correio. Se o Analisador do Exchange Server detectar que esses valores (armazenados como cadeias de caracteres de octeto) são os mesmos para todos os armazenamentos de caixas de correio, ou que eles estão sobrepostos, será exibido um aviso.

Por padrão, os processos de manutenção de armazenamentos de caixas de correio são executados à noite, da 1 às 5 h. Em função dos recursos do servidor necessários para os processos de manutenção, recomenda-se modificar os agendamentos de manutenção de forma que os armazenamentos de caixas de correio tenham agendamentos em intervalos de, pelo menos, 15 minutos.

Para corrigir esse aviso no Exchange 2000 Server e no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores e, em seguida, expanda o servidor com o qual deseja trabalhar.

  3. Expanda o grupo de armazenamento com o qual deseja trabalhar.

  4. Clique com o botão direito no armazenamento com o qual você deseja trabalhar e selecione Propriedades.

  5. Na guia Banco de dados, clique em Intervalo de manutenção e clique em um novo intervalo ou clique em Personalizar para criar um agendamento personalizado.

Para corrigir esse aviso no Exchange Server 2007

  1. Abra o Console de Gerenciamento do Exchange

  2. Expanda Configuração do Servidor e selecione o servidor com o qual deseja trabalhar.

  3. Expanda o grupo de armazenamento com o qual deseja trabalhar.

  4. Clique com o botão direito no armazenamento com o qual você deseja trabalhar e selecione Propriedades.

  5. Na guia Geral, clique em Agenda de manutenção e selecione um novo intervalo ou clique em Personalizar para criar uma agenda personalizada.

Para obter mais informações sobre a manutenção do armazenamento do Exchange Server 2003, consulte "Configurando opções de manutenção de armazenamento e de backup" no Guia de Administração do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47617).


Os limites de proibição de envio e recebimento de armazenamento de caixa de correio são muito semelhantes
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar os limites de tamanho definidos para uma caixa de correio. Se o Exchange Server Analyzer verificar que a diferença entre os limites de caixa de correio Prohibit send e Prohibit send and receive é inferior a 20 por cento, será exibida uma mensagem de configuração de Prática Recomendada.

É prática recomendada separar os limites Prohibit send e Prohibit send and receive em pelo menos 20 por cento. Se a diferença entre os limites for inferior a 20 por cento, o usuário da caixa de correio pode não ter tempo suficiente para limpá-la antes que ela comece a rejeitar mensagens. Por exemplo, se os usuários forem proibidos de enviar novas mensagens quando suas caixas de correio atingirem 100 MB, o limite Prohibit send and receive deverá ser de pelo menos 120MB.

Observação:
Também é importante definir um limite de aviso nas caixas de correio. Quando a caixa de correio atinge o limite de aviso, será enviado um email avisando o usuário de que a caixa de correio está se aproximando do limite definido em Prohibit send.

Para corrigir esse problema, você deve aumentar a diferença entre os limites da caixa de correio Prohibit send e Prohibit send and receive para mais de 20 por cento.

Para definir limites da caixa de correio

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Localize o armazenamento de caixa de correio exibido na mensagem do Exchange Server Analyzer.

  3. Clique com o botão direito em MailboxStore_Name e selecione Propriedades.

  4. Selecione a guia Limites.

  5. Modifique o limite Proibir envio em (KB) ou o limite Proibir envio e recebimento em (KB), ou ambos.

  6. Clique em Aplicar e em OK.
Para definir limites de caixa de correio no Exchange Server 2007 utilizando o Console de Gerenciamento do Exchange

  1. Abra o Console de Gerenciamento do Exchange

  2. Localize o armazenamento de caixa de correio no Exchange Server Analyzer referente a esse problema.

  3. Clique com o botão direito em MailboxStore_Name e selecione Propriedades.

  4. Selecione a guia Limites.

  5. Modifique o Aviso de problema em (KB), o limite Proibir envio em (KB) e o limite Proibir envio e recebimento em (KB).

  6. Clique em Aplicar e em OK
Para definir limites de caixa de correio no Exchange Server 2007 utilizando o Shell de Gerenciamento do Exchange

  1. O exemplo a seguir mostra como definir o tamanho de caixa de correio no qual uma mensagem de aviso é enviada ao usuário. Este atributo aplica-se a todas as caixas de correio deste banco de dados de caixa de correio que não possuam seu próprio conjunto de atributos de cota de avisos. Você deve especificar um inteiro ou "ilimitado." O valor padrão é 1,9 GB (gigabytes).
Código da Cópia
Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680
  1. O exemplo a seguir mostra como definir o tamanho da caixa de correio a partir do qual usuários associados a caixas de correio desse banco de dados de caixa de correio não poderão mais enviar mensagens. Esse atributo se aplica a todas as caixas de correio desse banco de dados de caixa de correio que não possuam seu próprio conjunto de atributos de cota de proibição de envio. O valor de limite definido deve ser um inteiro ou "ilimitado".

Código da Cópia
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152
  1. O exemplo a seguir mostra como definir o tamanho de caixa de correio a partir do qual o usuário associado a essa caixa de correio não poderá mais enviar ou receber mensagens. O atributo se aplica a todas as caixas de correio desse banco de dados de caixa de correio que não possuam seu próprio conjunto de atributos de cota de proibição de envio e recebimento. Você deve especificar um inteiro ou "ilimitado."

Código da Cópia
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

Para obter mais informações sobre como gerenciar as caixas de correio do Exchange, consulte Trabalhando com Armazenamentos do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

Para obter mais informações sobre como gerenciar os limites de caixa de correio do Exchange no Exchange Server 2007, consulte "Como configurar limites e propriedades de bancos de dados" (em inglês) (http://go.microsoft.com/fwlink/?LinkID=80746)


O armazenamento de caixa de correio não será montado na inicialização
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchEDBOffline de todos os objetos com uma classe igual a msExchPrivateMDB. Objetos com essa classe são armazenamentos de caixas de correio.

Um valor de True para o atributo msExchEDBOffline indica que o armazenamento de caixas de correio não será montado automaticamente quando o serviço Armazenamento de Informações do Microsoft Exchange for iniciado. Um valor de False indica que o armazenamento de caixas de correio será montado na inicialização. Se o Exchange Server Analyzer verificar que o valor desse atributo é True, será exibido um aviso.

Esse aviso indica que a caixa de seleção Não montar este armazenamento na inicialização está marcada. Essa caixa de seleção está na guia Banco de Dados da caixa de diálogo Propriedades do armazenamento de caixas de correio. Quando a caixa de seleção está marcada, o armazenamento de caixas de correio não será montado automaticamente quando o serviço Armazenamento de Informações do Microsoft Exchange for iniciado. Na próxima vez em que o serviço Armazenamento de Informações do Microsoft Exchange for iniciado, por exemplo, após um reinício do servidor, um armazenamento de caixas de correio com esse atributo definido como True não será montado. É recomendável que armazenamentos de caixas de correio sejam montados automaticamente quando o serviço de Armazenamento de Informações do Microsoft Exchange for iniciado.

Para corrigir esse aviso no Exchange 2000 Server ou no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores e expanda o servidor que contém o armazenamento de caixas de correio que você deseja modificar.

  3. Expanda o grupo de armazenamento que contém o armazenamento de caixas de correio que deseja modificar.

  4. Clique com o botão direito no armazenamento de caixas de correio e clique em Propriedades.

  5. Na guia Banco de Dados, desmarque a caixa de seleção Não montar este armazenamento na inicialização.

  6. Clique em OK para salvar a configuração.

  7. Feche o Gerenciador do Sistema Exchange.

Para corrigir esse aviso no Exchange Server 2007

  1. Abra o Console de Gerenciamento do Exchange

  2. Expanda Configuração do Servidor e selecione o servidor com o qual deseja trabalhar.

  3. Expanda o grupo de armazenamento com o qual deseja trabalhar.

  4. Clique com o botão direito no banco de dados com o qual você deseja trabalhar e clique em Propriedades.

  5. Na guia Geral, desmarque a caixa de seleção Não montar este banco de dados na inicialização.

  6. Clique em OK para salvar a configuração.

  7. Feche o Console de Gerenciamento do Exchange

Para obter mais informações sobre esta opção, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 314218, "COMO FAZER PARA: Ativar ou desativar a montagem automática de armazenamentos de dados na inicialização no Exchange 2000 Server" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314218)

  • 285169, "XADM: Armazenamentos de Informações não são montados depois de usar a opção "/disasterrecovery" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285169)


O parâmetro Max FXGetBuffer Users é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se a chave de Registro Max FXGetBuffer Users foi criada:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se o Exchange Server Analyzer detectar que a chave do Registro Max FXGetBuffer Users foi criada em ParametersSystem, ele exibirá uma mensagem de configuração diferente do padrão.

Você pode usar a chave do Registro Max FXGetBuffer Users para controlar o número de clientes do Microsoft Office Outlook® 2003 sincronizados com um servidor Exchange Server 2003 ao mesmo tempo. Defina o valor da chave do Registro Max FXGetBuffer Users de modo a ignorar o limite em conexões RPCs (chamadas de procedimento remoto) simultâneas, feitas por clientes do Outlook. Ocasionalmente, essas conexões são citadas como ropFXSrcGetBuffers. Para calcular o valor padrão da chave do Registro Max FXGetBuffer Users, multiplique o número de processadores existentes no servidor por 2 e adicione 3. Por exemplo, em um servidor Exchange Server 2003 que possui dois processadores, o valor padrão é 7 ([2*2] + 3=7).

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para restaurar a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Exclua o valor Max FXGetBuffer Users.

  4. Feche o editor de Registro.

O serviço Armazenamento de Informações do Microsoft Exchange detecta as alterações em minutos. Não é necessário reiniciar o computador.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a configuração de chaves de Registro para controlar o número de clientes do Outlook que podem estar sincronizados com o Exchange Server 2003, consulte o artigo 818484 da Base de Dados de Conhecimento, "Valores do Registro e contadores que você pode usar para configurar e monitorar a sincronização de clientes do Outlook" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484).


O máximo de anexos por envio de mensagem foi alterado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada de Registro para determinar se o número máximo padrão de anexos por envio de mensagem foi alterado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtAttachment

Se o Exchange Server Analyzer detectar que o valor do Registro objtAttachment está presente e configurado com qualquer valor diferente do exibido na tabela a seguir, uma mensagem de configuração não padrão será exibida.

Entrada | Valor Padrão de RTM do Exchange Server 2003 | Valor Padrão do Exchange Server 2003 SP1 e Posteriores | Valor Padrão do Exchange Server 2007
objtAttachment | 100 | 500 | 500

Quando adicionado e configurado manualmente, o valor de Registro objtAttachment determina o número máximo de anexos por envio de mensagem por cliente MAPI. Quando um cliente MAPI tenta enviar uma mensagem com um número de anexos acima do permitido, o seguinte evento é registrado no log de eventos do aplicativo, no computador do Exchange Server que contém a caixa de correio do cliente:

Tipo de Evento: | Erro
ID do Evento: | 9646
Origem do Evento: | MSExchangeIS
Categoria do Evento: | Geral
Descrição: | Fechando a sessão Mapi "/o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName" por exceder o número máximo de xxx objetos do tipo "objtAttachment".

O valor do Registro objtAttachment representa uma oportunidade de configuração que fornece ao administrador um nível superior de controle sobre os recursos do Exchange Server usados pelos clientes MAPI.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Exclua o valor do Registro objtAttachment.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Como alternativa, se desejar usar o valor do Registro objtAttachment, em vez de excluí-lo, mantenha a definição do valor existente ou ajuste-o, conforme for necessário.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Para obter mais informações, consulte o artigo 830829 da Base de Dados de Conhecimento, "Seu computador do Exchange Server 2003 pode parar de responder depois que um cliente MAPI abrir um número maior do que o valor padrão de determinados objetos do servidor" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


O máximo de visualizações em cache foi modificado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretórios do Active Directory® para saber se o número máximo de exibições em cache por banco de dados foi modificado. Se a ferramenta Analisador do Exchange Server detectar que o atributo msExchMaxCachedViews foi alterado de sua configuração padrão 11, exibirá uma mensagem de configuração não padrão. O número de exibições em cache que você configurou por banco de dados está incluído na saída do Exchange Server Analyzer. É uma prática recomendada ter entre 5 e 20 exibições em cache.

O msExchMaxCachedViews é um atributo da classe de objeto msExchangePrivateMDB. Sendo assim, cada objeto do armazenamento de banco de dados de caixas de correio no Active Directory tem um valor do atributo msExchMaxCachedViews. O valor do atributo msExchMaxCachedViews especifica o número máximo de exibições em cache de uma pasta específica em uma caixa de correio. Nesse contexto, o termo "exibição" está relacionado às pastas exibidas quando um usuário acessa a caixa de correio do Microsoft Office Outlook® 2003 de outro usuário. Quando o acesso a uma pasta do Outlook é compartilhado por vários usuários, o Exchange Server gera uma exibição que oculta os itens particulares.

Ao exibir pela primeira vez o calendário, a pasta de contatos ou outros dados de alguém, um usuário do Outlook pode enfrentar atrasos. Após exibir a pasta, o usuário pode experimentar exibições mais rápidas nas tentativas subseqüentes, mas após um intervalo de tempo, ele pode enfrentar atrasos ao tentar acessar a pasta novamente. Geralmente, esse atraso é mais observado quando a pasta contém um grande número de itens. Um grande número significa 5.000 itens ou mais.

A ação de aplicação de uma exibição a uma pasta cria pastas de pesquisa no armazenamento do Exchange para cada usuário individual que acessar a pasta do Outlook. Após a sua criação, a pasta de pesquisa é armazenada em cache para uso posterior. Antes de criar uma nova pasta de pesquisa, o Exchange Server verifica se essa pasta já existe. Se a pasta de pesquisa existir, o Exchange Server usará aquela que está armazenada em cache para agilizar as exibições.

O atributo msExchMaxCachedViews define quantas pastas de pesquisa estão armazenadas em cache em uma pasta específica. Por exemplo, o atributo msExchMaxCachedViews pode definir quantas pastas de pesquisa estão em cache na pasta Calendário.

Se vários usuários compartilharem pastas do Outlook, você deverá determinar como equilibrar a distribuição de recursos no servidor e o desempenho aceitável do cliente. Quando armazenada em cache, uma pasta de pesquisa é atualizada à medida que seus dados são alterados. Essas atualizações usam recursos da CPU e do disco. Se forem mantidos vários cachês da pasta de pesquisa, o desempenho da CPU e do disco será muito afetado.

Por outro lado, quando o Exchange Server cria uma pasta de pesquisa pela primeira vez, o usuário que acessa a pasta do Outlook pode enfrentar um atraso quando essa pasta for construída.

Por exemplo, imagine um Exchange Server configurado com 11 pastas de pesquisa. O número padrão de pastas de pesquisa é 11. O Usuário A compartilha sua pasta Calendário com outros 15 usuários. O Usuário B acessa a pasta e enfrenta um atraso enquanto sua pasta de pesquisa é construída. Após a criação da pasta de pesquisa do Usuário B, o acesso à pasta Calendário do Usuário A ocorre rapidamente. Suponha que o Usuário B não acesse a pasta no restante do dia. Nesse ínterim, se outros 11 usuários acessarem a pasta, serão criadas pastas de pesquisa exclusivas para eles. Como apenas 11 pastas de pesquisa estão em cache, na próxima vez em que o Usuário B acessar o Calendário do Usuário A, ele enfrentará novamente um atraso enquanto uma nova pasta de pesquisa estiver sendo criada para ele.

A prática recomendada é restringir o número máximo de caches de pasta de pesquisa a 20 ou menos. Quando esse número for ultrapassado, principalmente para as pastas que contêm mais de 5.000 itens, o servidor pode ficar sobrecarregado ao tentar manter as pastas em cache.

Além disso, é uma prática recomendada ter não menos do que 5 caches. Se existirem usuários compartilhando pastas do Outlook com vários outros usuários, armazenar em cache apenas quatro pastas de pesquisa impactará a experiência do cliente e fará com que o servidor use mais recursos ao criar novos caches com mais freqüência.

O atributo msExchMaxCachedViews também pode ser definido no banco de dados de pastas públicas. Também são construídas pastas de pesquisa para as pastas públicas. Por padrão, as pastas públicas são recursos compartilhados que vários usuários podem acessar. Se as pastas públicas receberem muitas postagens, você deverá minimizar as pastas de pesquisa, pois o Exchange Server poderá experimentar um uso elevado da CPU e do disco à medida que ele atualiza as pastas de pesquisa. Além disso, não é recomendável tentar otimizar a experiência do cliente fornecendo muitos caches de pasta de pesquisa se muitos usuários diferentes acessam uma pasta pública. É provável que esses caches sejam descartados à medida que novas pastas de pesquisa forem criadas para novos usuários.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para modificar o atributo msExchMaxCachedViews

  1. Inicie a ferramenta ADSI Edit nas ferramentas de suporte do Microsoft Windows® 2000 ou do Windows Server 2003.

  2. Expanda os seguintes nós:

    • Contêiner de Configuração

    • Configuração

    • Serviços

    • Microsoft Exchange

    • Nome_da_Organização

    • Grupos Administrativos

    • Nome_do_Grupo_Administrativo

    • Servidores

    • Armazenamento de Informações

    • Nome_do_Grupo_de_Armazenamento

  3. No painel de detalhes, clique com o botão direito em Nome_do_Banco_de_Dados e clique em Propriedades.

  4. Na caixa Atributos, clique duas vezes em msExchMaxCachedViews.

  5. Na caixa de diálogo Editor de Atributo Inteiro, digite um inteiro entre 5 e 20 no campo Valor e clique em OK.

  6. Clique em Aplicar e feche ADSI Edit.

  7. Aguarde pelo menos 15 minutos para a replicação e reinicie o serviço Armazenamento de Informações do Microsoft Exchange no Exchange Server no qual você fez a modificação.


Máximo de visualizações em cache está definido muito alto
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretórios do Active Directory® para saber se o número máximo de exibições em cache por banco de dados foi modificado. Se o Exchange Server Analyzer verificar que o atributo msExchMaxCachedViews está definido com um valor acima de 20, ele exibirá um aviso. O número de exibições em cache que você configurou por banco de dados está incluído na saída do Exchange Server Analyzer. É uma prática recomendada ter entre 5 e 20 exibições em cache.

O msExchMaxCachedViews é um atributo da classe de objeto msExchangePrivateMDB. Sendo assim, cada objeto do armazenamento de banco de dados de caixas de correio no Active Directory tem um valor do atributo msExchMaxCachedViews. O valor do atributo msExchMaxCachedViews especifica o número máximo de exibições em cache de uma pasta específica em uma caixa de correio. Nesse contexto, o termo "exibição" está relacionado às pastas exibidas quando um usuário acessa a caixa de correio do Microsoft Office Outlook® 2003 de outro usuário. Quando o acesso a uma pasta do Outlook é compartilhado por vários usuários, o Exchange Server gera uma exibição que oculta os itens particulares.

Ao exibir pela primeira vez o calendário, a pasta de contatos ou outros dados de alguém, um usuário do Outlook pode enfrentar atrasos. Após exibir a pasta, o usuário pode experimentar exibições mais rápidas nas tentativas subseqüentes, mas após um intervalo de tempo, ele pode enfrentar atrasos ao tentar acessar a pasta novamente. Geralmente, esse atraso é mais observado quando a pasta contém um grande número de itens. Um grande número significa 5.000 itens ou mais.

A ação de aplicação de uma exibição a uma pasta cria pastas de pesquisa no armazenamento do Exchange para cada usuário individual que acessar a pasta do Outlook. Após a sua criação, a pasta de pesquisa é armazenada em cache para uso posterior. Antes de criar uma nova pasta de pesquisa, o Exchange Server verifica se essa pasta já existe. Se a pasta de pesquisa existir, o Exchange Server usará aquela que está armazenada em cache para agilizar as exibições.

O atributo msExchMaxCachedViews define quantas pastas de pesquisa estão armazenadas em cache em uma pasta específica. Por exemplo, o atributo msExchMaxCachedViews pode definir quantas pastas de pesquisa estão em cache na pasta Calendário.

Se vários usuários compartilharem pastas do Outlook, você deverá determinar como equilibrar a distribuição de recursos no servidor e o desempenho aceitável do cliente. Quando armazenada em cache, uma pasta de pesquisa é atualizada à medida que seus dados são alterados. Essas atualizações usam recursos da CPU e do disco. Se forem mantidos vários cachês da pasta de pesquisa, o desempenho da CPU e do disco será muito afetado.

Por outro lado, quando o Exchange Server cria uma pasta de pesquisa pela primeira vez, o usuário que acessa a pasta do Outlook pode enfrentar um atraso quando essa pasta for construída.

Por exemplo, imagine um Exchange Server configurado com 11 pastas de pesquisa. O número padrão de pastas de pesquisa é 11. O Usuário A compartilha sua pasta Calendário com outros 15 usuários. O Usuário B acessa a pasta e enfrenta um atraso enquanto sua pasta de pesquisa é construída. Após a criação da pasta de pesquisa do Usuário B, o acesso à pasta Calendário do Usuário A ocorre rapidamente. Suponha que o Usuário B não acesse a pasta no restante do dia. Nesse ínterim, se outros 11 usuários acessarem a pasta, serão criadas pastas de pesquisa exclusivas para eles. Como apenas 11 pastas de pesquisa estão em cache, na próxima vez em que o Usuário B acessar o Calendário do Usuário A, ele enfrentará novamente um atraso enquanto uma nova pasta de pesquisa estiver sendo criada para ele.

A prática recomendada é restringir o número máximo de caches de pasta de pesquisa a 20 ou menos. Quando esse número for ultrapassado, principalmente para as pastas que contêm mais de 5.000 itens, o servidor pode ficar sobrecarregado ao tentar manter as pastas em cache.

Além disso, é uma prática recomendada ter não menos do que 5 caches. Se existirem usuários compartilhando pastas do Outlook com vários outros usuários, armazenar em cache apenas quatro pastas de pesquisa impactará a experiência do cliente e fará com que o servidor use mais recursos ao criar novos caches com mais freqüência.

O atributo msExchMaxCachedViews também pode ser definido no banco de dados de pastas públicas. Também são construídas pastas de pesquisa para as pastas públicas. Por padrão, as pastas públicas são recursos compartilhados que vários usuários podem acessar. Se as pastas públicas receberem muitas postagens, você deverá minimizar as pastas de pesquisa, pois o Exchange Server poderá experimentar um uso elevado da CPU e do disco à medida que ele atualiza as pastas de pesquisa. Além disso, não é recomendável tentar otimizar a experiência do cliente fornecendo muitos caches de pasta de pesquisa se muitos usuários diferentes acessam uma pasta pública. É provável que esses caches sejam descartados à medida que novas pastas de pesquisa forem criadas para novos usuários.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para modificar o atributo msExchMaxCachedViews

  1. Inicie a ferramenta ADSI Edit nas ferramentas de suporte do Microsoft Windows® 2000 ou do Windows Server 2003.

  2. Expanda os seguintes nós:

    • Contêiner de Configuração

    • Configuração

    • Serviços

    • Microsoft Exchange

    • Nome_da_Organização

    • Grupos Administrativos

    • Nome_do_Grupo_Administrativo

    • Servidores

    • Armazenamento de Informações

    • Nome_do_Grupo_de_Armazenamento

  3. No painel de detalhes, clique com o botão direito em Nome_do_Banco_de_Dados e clique em Propriedades.

  4. Na caixa Atributos, clique duas vezes em msExchMaxCachedViews.

  5. Na caixa de diálogo Editor de Atributo Inteiro, digite um inteiro entre 5 e 20 no campo Valor e clique em OK.

  6. Clique em Aplicar e feche ADSI Edit.

  7. Aguarde pelo menos 15 minutos para a replicação e reinicie o serviço Armazenamento de Informações do Microsoft Exchange no Exchange Server no qual você fez a modificação.


Máximo de visualizações em cache está definido muito baixo
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretórios do Active Directory® para saber se o número máximo de exibições em cache por banco de dados foi modificado. Se o Exchange Server Analyzer detectar que o atributo msExchMaxCachedViews está definido como um valor inferior a 5, o Exchange Server Analyzer exibirá um aviso. O número de exibições em cache configuradas por banco de dados está contido na saída do Exchange Server Analyzer. É uma prática recomendada ter entre 5 e 20 exibições em cache.

O msExchMaxCachedViews é um atributo da classe de objeto msExchangePrivateMDB. Sendo assim, cada objeto do armazenamento de banco de dados de caixas de correio no Active Directory tem um valor do atributo msExchMaxCachedViews. O valor do atributo msExchMaxCachedViews especifica o número máximo de exibições em cache para uma pasta específica dentro de uma caixa de correio.

Nesse contexto, o termo "exibição" está relacionado às pastas exibidas quando um usuário acessa a caixa de correio do Microsoft Office Outlook® 2003 de outro usuário. Quando o acesso a uma pasta do Outlook é compartilhado por vários usuários, o Exchange Server gera uma exibição que oculta os itens particulares.

Ao exibir pela primeira vez o calendário, a pasta de contatos ou outros dados de alguém, um usuário do Outlook pode enfrentar atrasos. Após exibir a pasta, o usuário pode experimentar exibições mais rápidas nas tentativas subseqüentes, mas após um intervalo de tempo, ele pode enfrentar atrasos ao tentar acessar a pasta novamente. Geralmente, esse atraso é mais observado quando a pasta contém um grande número de itens. Um grande número significa 5.000 itens ou mais.

A ação de aplicação de uma exibição a uma pasta cria pastas de pesquisa no armazenamento do Exchange para cada usuário individual que acessar a pasta do Outlook. Após a sua criação, a pasta de pesquisa é armazenada em cache para uso posterior. Antes de criar uma nova pasta de pesquisa, o Exchange Server verifica se essa pasta já existe. Se a pasta de pesquisa existir, o Exchange Server usará aquela que está armazenada em cache para agilizar as exibições.

O atributo msExchMaxCachedViews define quantas pastas de pesquisa estão armazenadas em cache em uma pasta específica. Por exemplo, o atributo msExchMaxCachedViews pode definir quantas pastas de pesquisa estão em cache na pasta Calendário.

Se vários usuários compartilharem pastas do Outlook, você deverá determinar como equilibrar a distribuição de recursos no servidor e o desempenho aceitável do cliente. Quando armazenada em cache, uma pasta de pesquisa é atualizada à medida que seus dados são alterados. Essas atualizações usam recursos da CPU e do disco. Se forem mantidos vários cachês da pasta de pesquisa, o desempenho da CPU e do disco será muito afetado.

Por outro lado, quando o Exchange Server cria uma pasta de pesquisa pela primeira vez, o usuário que acessa a pasta do Outlook pode enfrentar um atraso quando essa pasta for construída.

Por exemplo, imagine um Exchange Server configurado com 11 pastas de pesquisa. O número padrão de pastas de pesquisa é 11. O Usuário A compartilha sua pasta Calendário com outros 15 usuários. O Usuário B acessa a pasta e enfrenta um atraso enquanto sua pasta de pesquisa é construída. Após a criação da pasta de pesquisa do Usuário B, o acesso à pasta Calendário do Usuário A ocorre rapidamente. Suponha que o Usuário B não acesse a pasta no restante do dia. Nesse ínterim, se outros 11 usuários acessarem a pasta, serão criadas pastas de pesquisa exclusivas para eles. Como apenas 11 pastas de pesquisa estão em cache, na próxima vez em que o Usuário B acessar o Calendário do Usuário A, ele enfrentará novamente um atraso enquanto uma nova pasta de pesquisa estiver sendo criada para ele.

A prática recomendada é restringir o número máximo de caches de pasta de pesquisa a 20 ou menos. Quando esse número for ultrapassado, principalmente para as pastas que contêm mais de 5.000 itens, o servidor pode ficar sobrecarregado ao tentar manter as pastas em cache.

Além disso, é uma prática recomendada ter não menos do que 5 caches. Se existirem usuários compartilhando pastas do Outlook com vários outros usuários, armazenar em cache apenas quatro pastas de pesquisa impactará a experiência do cliente e fará com que o servidor use mais recursos ao criar novos caches com mais freqüência.

O atributo msExchMaxCachedViews também pode ser definido no banco de dados de pastas públicas. Também são construídas pastas de pesquisa para as pastas públicas. Por padrão, as pastas públicas são recursos compartilhados que vários usuários podem acessar. Se as pastas públicas receberem muitas postagens, você deverá minimizar as pastas de pesquisa, pois o Exchange Server poderá experimentar um uso elevado da CPU e do disco à medida que ele atualiza as pastas de pesquisa. Além disso, não é recomendável tentar otimizar a experiência do cliente fornecendo muitos caches de pasta de pesquisa se muitos usuários diferentes acessam uma pasta pública. É provável que esses caches sejam descartados à medida que novas pastas de pesquisa forem criadas para novos usuários.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para modificar o atributo msExchMaxCachedViews

  1. Inicie a ferramenta ADSI Edit nas ferramentas de suporte do Microsoft Windows® 2000 ou do Windows Server 2003.

  2. Expanda os seguintes nós:

    • Contêiner de Configuração

    • Configuração

    • Serviços

    • Microsoft Exchange

    • Nome_da_Organização

    • Grupos Administrativos

    • Nome_do_Grupo_Administrativo

    • Servidores

    • Armazenamento de Informações

    • Nome_do_Grupo_de_Armazenamento

  3. No painel de detalhes, clique com o botão direito em Nome_do_Banco_de_Dados e clique em Propriedades.

  4. Na caixa Atributos, clique duas vezes em msExchMaxCachedViews.

  5. Na caixa de diálogo Editor de Atributo Inteiro, digite um inteiro entre 5 e 20 no campo Valor e clique em OK.

  6. Clique em Aplicar e feche ADSI Edit.

  7. Aguarde pelo menos 15 minutos para a replicação e reinicie o serviço Armazenamento de Informações do Microsoft Exchange no servidor Exchange no qual você fez a modificação.


O cache ESE máximo foi alterado manualmente
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-02-21

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar o valor do atributo msExchESEParamCacheSizeMax para todos os objetos de armazenamento da caixa de correio. Se o Exchange Server Analyzer detectar o valor do atributo msExchESEParamCacheSizeMax para qualquer armazenamento da caixa de correio maior do que 0, mas menor do que 219.727, uma mensagem de configuração não padrão será exibida.

No Exchange 2000 Server, uma grande área da memória virtual usada por STORE.EXE é alocada para o buffer ESE. O Exchange 2000 Server usa um padrão codificado de 858 megabytes (MB) para esse buffer. No Exchange Server 2003, a alocação do buffer ESE é baseada na presença da opção /3GB no arquivo Boot.ini. Se o comando /3GB estiver presente, o buffer do ESE é ajustado para 896 MB. Se /3GB não estiver presente, o buffer do ESE é ajustado para 576 MB. Apesar do auto-ajuste ser útil em todos os casos, você poderá preferir substituir o auto-ajuste e definir manualmente um valor mais apropriado para seu ambiente. Embora você possa ajustar esse valor para qualquer múltiplo de 8.192, é recomendável que use somente um valor da tabela a seguir.

Valor recomendado | Memória alocada | Comentários
147456 | 576 MB | Esse é o mínimo recomendado. Não defina nenhum valor inferior. Esse valor é útil em servidores restritos à memória virtual e em computadores do Exchange Server 2003 que são executados no Microsoft Windows® 2000 Server, que não oferece suporte à opção /3GB. Esse também é o valor padrão em sistemas que não usam a opção /3GB.
196608 | 768 MB | Esse valor é recomendado em servidores com grandes quantidades de memória virtual que registram em log o evento 9582 com freqüência.
219726 | 858 MB | Esse é o valor padrão no Exchange 2000 Server e é um bom valor para ser usado em sistemas que você estiver atualizando no local e que possuam grandes quantidades de memória virtual.
229376 | 896 MB | Esse é o valor padrão no Exchange Server 2003 e um bom valor para ser usado em sistemas novos, a não ser que o log de eventos do Aplicativo indique o contrário, com a presença de eventos 9582.
311296 | 1.2 GB | Esse é o valor máximo que você pode definir. Esse valor só deve ser usado em sistemas com 2 GB ou mais de memória física.

Antes de reconfigurar esse valor, você deve monitorar a quantidade de memória virtual consumida pelo processo STORE.EXE. Você pode fazer isso monitorando o objeto de desempenho do Processo no Windows. Em sistemas com a opção /3GB, o contador de Bytes Virtuais da instância STORE.EXE do objeto do Processo deve ser menor do que 2,8 GB. Em sistemas sem a opção /3GB, ele deve ser menor do que 1,8 GB. Se os valores forem maiores do que essas quantidades, você poderá precisar diminuir o valor de msExchESEParamCacheSizeMax. Se os valores forem menores do que isso, você poderá precisar aumentar o valor de msExchESEParamCacheSizeMax.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para ajustar o atributo msExchESEParamCacheSizeMax

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração.

  3. Expanda CN=Serviços.

  4. Expanda CN=Microsoft Exchange.

  5. Expanda CN=<Nome da Organização do Exchange>.

  6. Expanda CN=Grupos Administrativos.

  7. Expanda CN=<Nome do Grupo Administrativo>.

  8. Expanda CN=Servidores.

  9. Expanda CN=<Nome do Exchange Server>.

  10. Clique com o botão direito em CN=Armazenamento de Informações e clique em Propriedades.

  11. No campo atributos, role até msExchESEParamCacheSizeMax e clique duas vezes.

  12. No campo Valor, digite o valor que você deseja definir. Use a tabela deste artigo para determinar o valor ideal para seu sistema. Observe que o valor usado deve ser um múltiplo de 8192.

  13. Clique em OK e em OK novamente.

  14. Feche o editor do Active Directory e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre como otimizar o uso da memória, consulte o artigo 815372 da Base de Dados de Conhecimento Microsoft, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

Para obter mais informações sobre o atributo msExchESEParamCacheSizeMax, consulte o artigo 266768 da Base de Dados de Conhecimento, "XSTR: How to modify the Store Database maximum cache size" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


Cache máximo de ESE está definido muito alto
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-02-21

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar o valor do atributo msExchESEParamCacheSizeMax para todos os objetos de armazenamento da caixa de correio. O Exchange Server Analyzer também consulta a classe Win32_PerfRawData_MSExchangeIS_MSExchangeIS do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave VMLargestBlockSize. A chave VMLargestBlockSize representa o tamanho (em bytes) do maior bloco de memória virtual disponível.

Além disso, o Exchange Server Analyzer consulta o Active Directory para determinar a contagem das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Se o Exchange Server Analyzer verificar que o valor msExchESEParamCacheSizeMax é superior a 219726, e que o valor de VMLargestBlockSize é maior do que 50000000 mas menor do que 150000000 em um computador do Exchange Server com mais de 20 caixas de correio, um erro será exibido. Esse erro indica que o atributo msExchESEParamCacheSizeMax está definido com um valor muito alto nesse computador do Exchange Server.

No Exchange 2000 Server, um grande área da memória virtual usada por STORE.EXE é alocada para o Buffer do ESE. O Exchange 2000 Server usa um padrão codificado de 858 megabytes (MB) para esse buffer. No Exchange Server 2003, a alocação do buffer do ESE é baseada na presença do comando /3GB no arquivo Boot.ini. Se o comando /3GB estiver presente, o buffer do ESE é ajustado para 896 MB. Se /3GB não estiver presente, o buffer do ESE é ajustado para 576 MB. Apesar do ajusto automático ser útil em todos os casos, talvez você prefira substituí-lo e definir manualmente um valor mais apropriado para seu ambiente. Você pode ajustar esse valor como qualquer múltiplo de 8192, mas é recomendável usar apenas um dos valores da tabela a seguir.

Valor recomendado | Memória alocada | Comentários
147456 | 576 MB | Esse é o mínimo recomendado. Não defina nenhum valor inferior. Esse valor é útil em servidores restritos à memória virtual e em computadores do Exchange Server 2003 que são executados no Microsoft Windows 2000 Server, que não oferece suporte à opção /3GB. Esse também é o valor padrão em sistemas que não usam a opção /3GB.
196608 | 768 MB | Esse valor é recomendado em servidores com grandes quantidades de memória virtual que registram em log o evento 9582 com freqüência.
219726 | 858 MB | Esse é o valor padrão no Exchange 2000 Server e é um bom valor para ser usado em sistemas que você estiver atualizando no local e que possuam grandes quantidades de memória virtual.
229376 | 896 MB | Esse é o valor padrão no Exchange Server 2003 e um bom valor para ser usado em sistemas novos, a não ser que o log de eventos do Aplicativo indique o contrário, com a presença de eventos 9582.
311296 | 1.2 GB | Esse é o valor máximo que você pode definir. Esse valor só deve ser usado em sistemas com 2 GB ou mais de memória física.

Antes de reconfigurar esse valor, você deve monitorar a quantidade de memória virtual consumida pelo processo STORE.EXE. Você pode fazer isso monitorando o objeto de desempenho do Processo no Windows. Em sistemas com a opção /3GB, o contador de Bytes Virtuais da instância STORE.EXE do objeto do Processo deve ser menor do que 2,8 GB. Em sistemas sem a opção /3GB, ele deve ser menor do que 1,8 GB. Se os valores forem maiores do que essas quantidades, talvez seja necessário diminuir o valor de msExchESEParamCacheSizeMax. Se os valores forem menores do que isso, você pode preferir aumentar o valor de msExchESEParamCacheSizeMax.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para ajustar o atributo msExchESEParamCacheSizeMax

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração.

  3. Expanda CN=Serviços.

  4. Expanda CN=Microsoft Exchange.

  5. Expanda CN=<Nome da Organização do Exchange>.

  6. Expanda CN=Grupos Administrativos.

  7. Expanda CN=<Nome do Grupo Administrativo>.

  8. Expanda CN=Servidores.

  9. Expanda CN=<Nome do Exchange Server>.

  10. Clique com o botão direito em CN=Armazenamento de Informações e clique em Propriedades.

  11. No campo atributos, role até msExchESEParamCacheSizeMax e clique duas vezes.

  12. No campo Valor, digite o valor que você deseja definir. Use a tabela para determinar o valor ideal para seu sistema. Observe que o valor usado deve ser um múltiplo de 8192.

  13. Clique em OK e em OK novamente.

  14. Feche o editor do Active Directory e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre como otimizar o uso da memória, consulte o artigo 815372 da Base de Dados de Conhecimento Microsoft, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

Para obter mais informações sobre o atributo msExchESEParamCacheSizeMax, consulte o artigo 266768 da Base de Dados de Conhecimento, "XSTR: How to modify the Store Database maximum cache size" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


Tamanho do cache do ESE máximo aumentado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-02-21

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar o valor do atributo msExchESEParamCacheSizeMax para todos os objetos de armazenamento da caixa de correio.

O Exchange Server Analyzer também consulta a classe Win32_PerfRawData_MSExchangeIS_MSExchangeIS do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave VMLargestBlockSize. A chave VMLargestBlockSize representa o tamanho (em bytes) do maior bloco de memória virtual disponível.

Além disso, o Exchange Server Analyzer consulta o Active Directory para determinar a contagem das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Se o Analisador do Exchange Server detectar que o valor msExchESEParamCacheSizeMax deve ser maior que 219.726 e o valor de VMLargestBlockSize não estiver dentro dos valores a seguir no computador do Exchange Server com mais de 20 caixas de correio, um aviso será exibido:

  • Maior que 50000000 e menor que 150000000

  • Maior que 0 e menor que 50000001

Esse aviso indica que o atributo msExchESEParamCacheSizeMax foi aumentado nesse computador do Exchange Server e pode causar condições de pouca memória virtual.

No Exchange 2000 Server, uma grande área da memória virtual usada por STORE.EXE é alocada para o buffer ESE. O Exchange 2000 Server usa um padrão codificado de 858 megabytes (MB) para esse buffer. No Exchange Server 2003, a alocação do buffer ESE é baseada na presença da opção /3GB no arquivo Boot.ini. Se o comando /3GB estiver presente, o buffer do ESE é ajustado para 896 MB. Se /3GB não estiver presente, o buffer do ESE é ajustado para 576 MB. Apesar do auto-ajuste ser útil em todos os casos, você poderá preferir substituir o auto-ajuste e definir manualmente um valor mais apropriado para seu ambiente. Embora você possa ajustar esse valor para qualquer múltiplo de 8.192, é recomendável que use somente um valor da tabela a seguir:

Valor recomendado | Memória alocada | Comentários
147456 | 576 MB | Esse é o mínimo recomendado. Não defina nenhum valor inferior. Esse valor é útil em servidores restritos à memória virtual e em computadores do Exchange Server 2003 que são executados no Microsoft Windows 2000 Server, que não oferece suporte à opção /3GB. Esse também é o valor padrão em sistemas que não usam a opção /3GB.
196608 | 768 MB | Esse valor é recomendado em servidores com grandes quantidades de memória virtual que registram em log o evento 9582 com freqüência.
219726 | 858 MB | Esse é o valor padrão no Exchange 2000 Server e é um bom valor para ser usado em sistemas que você estiver atualizando no local e que possuam grandes quantidades de memória virtual.
229376 | 896 MB | Esse é o valor padrão no Exchange Server 2003 e um bom valor para ser usado em sistemas novos, a não ser que o log de eventos do Aplicativo indique o contrário, com a presença de eventos 9582.
311296 | 1.2 GB | Esse é o valor máximo que você pode definir. Esse valor só deve ser usado em sistemas com 2 GB ou mais de memória física.

Antes de reconfigurar esse valor, você deve monitorar a quantidade de memória virtual consumida pelo processo STORE.EXE. Você pode fazer isso monitorando o objeto de desempenho do Processo no Windows. Em sistemas com a opção /3GB, o contador de Bytes Virtuais da instância STORE.EXE do objeto do Processo deve ser menor do que 2,8 GB. Em sistemas sem a opção /3GB, ele deve ser menor do que 1,8 GB. Se os valores forem maiores do que essas quantidades, você poderá precisar diminuir o valor de msExchESEParamCacheSizeMax. Se os valores forem menores do que isso, você poderá precisar aumentar o valor de msExchESEParamCacheSizeMax.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para ajustar o atributo msExchESEParamCacheSizeMax

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração.

  3. Expanda CN=Serviços.

  4. Expanda CN=Microsoft Exchange.

  5. Expanda CN=<Nome da Organização do Exchange>.

  6. Expanda CN=Grupos Administrativos.

  7. Expanda CN=<Nome do Grupo Administrativo>.

  8. Expanda CN=Servidores.

  9. Expanda CN=<Nome do Exchange Server>.

  10. Clique com o botão direito em CN=Armazenamento de Informações e clique em Propriedades.

  11. No campo atributos, role até msExchESEParamCacheSizeMax e clique duas vezes.

  12. No campo Valor, digite o valor que você deseja definir. Use a tabela deste artigo para determinar o valor ideal para seu sistema. Observe que o valor usado deve ser um múltiplo de 8192.

  13. Clique em OK e em OK novamente.

  14. Feche o editor do Active Directory e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre como otimizar o uso da memória, consulte o artigo 815372 da Base de Dados de Conhecimento Microsoft, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

Para obter mais informações sobre o atributo msExchESEParamCacheSizeMax, consulte o artigo 266768 da Base de Dados de Conhecimento, "XSTR: How to modify the Store Database maximum cache size" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


O MaxOpenMessagesPerLogon foi definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-05-14

A ferramenta Microsoft Exchange Analyzer lê a entrada do Registro a seguir para determinar se o valor MaxOpenMessagesPerLogon está presente e configurado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se o Exchange Analyzer detectar que o valor de Registro MaxOpenMessagesPerLogon está presente e configurado com um valor maior que 0, uma mensagem de configuração não padrão será exibida.

Sempre que um cliente ou aplicativo MAPI abrir uma mensagem em um computador do Exchange Server, ele fará com que o serviço Armazenamento de Informações do Microsoft Exchange (store.exe) consuma uma pequena quantidade de memória física. Quando a mensagem for fechada pelo cliente Microsoft Office Outlook 2003 ou Outlook 2007, a memória será liberada. Para evitar que um ou mais clientes MAPI façam com que o serviço de armazenamento do Exchange aloque memória continuamente, foi introduzido um novo recurso de configuração no Exchange 2000 Server Service Pack 1 (SP1) que permite a um administrador limitar o número de mensagens que podem ser abertas simultaneamente em cada sessão de logon do cliente MAPI. A definição desse limite poderá ser útil em seu ambiente se determinados aplicativos cliente abrirem um grande número de mensagens de maneira não intencional, afetando o desempenho geral do servidor.

Esse recurso é implementado com o valor de Registro MaxOpenMessagesPerLogon no computador do Exchange Server. Recomenda-se a definição de um limite não superior a 1.000. O valor 1.000 permite que cada cliente utiliza aproximadamente 4 a 6 megabytes (MBs) de memória. Para alguns ambientes, pode ser mais adequado utilizar 500, um valor menor.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar um número máximo de mensagens abertas simultaneamente

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Abrir:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Clique com o botão direito em ParametersSystem, selecione Novo | Valor DWORD e dê o nome de MaxOpenMessagesPerLogon para o novo valor.

  4. No painel da direita, clique duas vezes no valor MaxOpenMessagesPerLogon e digite o número máximo de mensagens abertas simultaneamente, em decimal.

  5. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor de Registro MaxOpenMessagesPerLogon, consulte o artigo 289109 da Base de Dados de Conhecimento Microsoft, "XADM: Como limitar o número de mensagens abertas para cada logon MAPI" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=289109).


O número máximo de bancos de dados por grupo de armazenamento foi alterado manualmente
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchMaxStoresPerGroup de cada grupo de armazenamento. Se o Exchange Server Analyzer detectar que o valor do atributo msExchMaxStoresPerGroup de qualquer grupo de armazenamento não é igual a 5, será exibido um erro.

Esse valor se aplica a todos os grupos de armazenamento do servidor. Esse erro específico ocorre se o valor do atributo foi alterado de seu padrão 5. Esse é o único valor aceito e nunca deve ser modificado. O Exchange Server não funcionará corretamente se esse valor for aumentado.

Você deve corrigir o valor usando uma ferramenta como a snap-in Active Directory Service Interfaces (ADSI) Edit, LDP (ldp.exe) ou qualquer outro cliente de protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro

  1. Inicie o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração, expanda CN=Serviços, CN=Microsoft Exchange e CN=<ExchangeOrganizationName>.

  3. Expanda CN=Grupos Administrativos, expanda CN=<AdministrativeGroupName> e CN=Servidores.

  4. Expanda CN=<Nome_do_Servidor>, clique com o botão direito em CN=Armazenamento_de_Informações e clique em Propriedades.

  5. No Editor de Atributos, clique no atributo msExchMaxStoresPerGroup e, em seguida, clique em Editar.

  6. Na caixa Editar Atributo, defina o valor como 5.

  7. Clique em Aplicar e em OK.

  8. Feche o ADSI Edit e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração seja aplicada.

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre o número máximo permitido de grupos de armazenamento, consulte o artigo 251123 da Base de Dados de Conhecimento, "XADM: Número máximo de grupos de armazenamento no Exchange 2000 para o planejamento da capacidade do banco de dados" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251123) (página em inglês).

Para obter mais informações sobre como funciona o ADSI Edit, consulte o tópico "Adsiedit.msc: ADSI Edit" na Ajuda do Windows Server.


O número máximo de grupos de armazenamento foi alterado manualmente
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchMaxStorageGroups de cada contêiner do InformationStore. Se o Exchange Server Analyzer determinar que o valor de qualquer atributo msExchMaxStorageGroups não é igual a 4, um erro será exibido.

O único valor aceito para o atributo msExchMaxStorageGroups é 4 e esse valor nunca deve ser alterado. O Exchange não funcionará corretamente se esse valor for alterado.

Você deve corrigir o valor usando um editor do Active Directory, como o snap-in Active Directory Service Interfaces (ADSI) Edit, a ferramenta LDP (ldp.exe) ou qualquer outro cliente do protocolo LDAP versão 3.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP ou outro cliente da versão 3 do LDAP, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro

  1. Ao usar o ADSI Edit ou uma ferramenta semelhante, localize o objeto InformationStore desse servidor no Active Directory.

    O atributo msExchMaxStorageGroups pode ser encontrado em:

    CN=Configuração,DC=Domínio,CN=com, CN=Serviços, CN=Microsoft Exchange, CN= OrganizationName , CN=Grupos Administrativos, CN= Nome do Grupo Administrativo , CN=Servidores, CN= ServerName , CN=Armazenamento de Informações

  2. Edite o atributo msExchMaxStorageGroups inserindo 4 como o novo valor.

  3. Feche o editor do Active Directory e reinicie o computador do Exchange Server para que a alteração entre em vigor.

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


O máximo de objetos de pastas abertas por logon foi alterado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se foi alterado o número máximo padrão de pastas que podem ser abertas por sessão MAPI:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolder

Se o Exchange Server Analyzer detectar que o valor do Registro objtFolder existe e está configurado com qualquer valor diferente de 500, será exibida uma mensagem de configuração não-padrão.

Quando adicionado e configurado manualmente, o valor do Registro objtFolder determina o número máximo de pastas que podem ser abertas por cliente MAPI. Por padrão, o Exchange Server 2003 e o Exchange Server 2007 limitam o número de pastas abertas a 500. Quando um cliente MAPI tenta abrir mais de 500 pastas, o evento a seguir é registrado no log de eventos do aplicativo, no computador do Exchange Server que contém a caixa de correio do cliente:

Tipo de Evento: | Erro
ID do Evento: | 9646
Origem do Evento: | MSExchangeIS
Categoria do Evento: | Geral
Descrição: | Fechando sessão Mapi"/o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName" por ter excedido o número máximo de 500 objetos do tipo "objtFolder".

O valor do Registro objtFolder representa uma oportunidade de configuração que concede ao administrador um nível superior de controle sobre os recursos do Exchange Server usados por clientes MAPI.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Exclua o valor de Registro objtFolder.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

  5. Como alternativa, para usar o valor do Registro objtFolder , em vez de excluí-lo, mantenha-o definido como o valor já existente ou ajuste-o conforme necessário.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Para obter mais informações, consulte o artigo 830829 da Base de Dados de Conhecimento, "Seu computador do Exchange Server 2003 pode parar de responder depois que um cliente MAPI abrir um número maior do que o valor padrão de determinados objetos do servidor" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


O máximo de exibições de pastas abertas por logon foi alterado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se foi alterado o número máximo padrão de exibições de pastas que podem ser abertas por sessão MAPI:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolderView

Se o Exchange Server Analyzer detectar que o valor do Registro objtFolderView existe e está configurado com qualquer valor diferente de 500, será exibida uma mensagem de configuração não-padrão.

Quando adicionado e configurado manualmente, o valor do Registro objtFolderView determina o número máximo de exibições de pastas que podem ser abertas por cliente MAPI. Por padrão, o Exchange Server 2003 e o Exchange Server 2007 limitam o número de exibições de pastas abertas para 500. Quando um cliente MAPI tenta abrir mais de 500 exibições de pastas, o seguinte evento é registrado no log de eventos do aplicativo no computador do Exchange Server que contém a caixa de correio do cliente:

Tipo de Evento: Erro

Origem do Evento: MSExchangeIS

Categoria do Evento: Geral

Descrição: Fechando sessão Mapi "/o= OrganizationName /ou= AdministrativeGroupName /cn=Recipients/cn= UserName ", pois era maior que o máximo de 500 objetos do tipo "objtFolderView".

O valor do Registro objtFolderView representa uma oportunidade de configuração que concede a um administrador um nível superior de controle sobre os recursos do Exchange Server usados por clientes MAPI.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Exclua o valor do Registro objtFolderView.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

  5. Como alternativa, se você desejar usar o valor do Registro objtFolderView, em vez de excluí-lo, mantenha-o definido como o valor já existente ou ajuste-o conforme necessário.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Para obter mais informações, consulte o artigo 830829 da Base de Dados de Conhecimento da Microsoft, "Seu computador do Exchange Server 2003 pode parar de responder depois que um cliente MAPI abrir um número maior que o valor padrão de determinados objetos do servidor" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


O máximo de objetos de mensagens abertas por logon foi alterado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada de Registro para determinar se o número máximo padrão de mensagens abertas por sessão MAPI foi alterado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtMessage

Se o Exchange Server Analyzer detectar a entrada de Registro objtMessage presente e configurada com um valor diferente de 250, uma mensagem de configuração não padrão será exibida.

Quando adicionado e configurado manualmente, o valor do Registro objtMessage determina o número máximo de mensagens abertas por cliente MAPI. Por padrão, o Exchange Server 2003 e o Exchange Server 2007 limitam o número de mensagens abertas a 250. Quando um cliente MAPI tenta abrir mais de 250 mensagens, o seguinte evento é registrado no log de eventos do aplicativo no computador do Exchange Server que contém a caixa de correio do cliente:

Tipo de Evento: Erro

ID do Evento: 9646

Origem do Evento: MSExchangeIS

Categoria do Evento: Geral

Descrição: Fechando sessão Mapi "/o= OrganizationName /ou= AdministrativeGroupName /cn=Recipients/cn= UserName " porque excedeu o máximo de 250 objetos do tipo "objtMessage".

O valor do Registro objtMessage representa uma oportunidade de configuração que oferece a um administrador um maior nível de controle sobre os recursos do Exchange Server usados por clientes MAPI.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Exclua o valor do Registro objtMessage.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

  5. Como alternativa, se desejar usar o valor do Registro objtMessage, em vez de excluí-lo, mantenha o valor existente ou ajuste-o, conforme for necessário.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Para obter mais informações, consulte o artigo 830829 da Base de Dados de Conhecimento, "Seu computador do Exchange Server 2003 pode parar de responder depois que um cliente MAPI abrir um número maior do que o valor padrão de determinados objetos do servidor" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


A Freqüência Máxima de Sondagem é não padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer Tool lê o valor do Registro a seguir para determinar se o intervalo de sondagem para clientes do Microsoft Office Outlook® 2003 e do Outlook 2007, que acessam o Exchange Server 2003 ou o Exchange Server 2007 usando o RPC sobre HTTP, teve seu valor padrão modificado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Maximum Polling Frequency

Se o Analisador do Exchange Server detectar que a chave Maximum Polling Frequency está presente e configurada com um valor maior que 0, uma mensagem de configuração não padrão será exibida.

Ao fazer sua conexão inicial em um servidor Exchange, o Outlook se registra para novas notificações de mensagem. Sempre que uma nova mensagem for recebida em uma caixa de correio de usuário do Outlook, o Exchange enviará uma notificação para o Outlook usando Protocolo UDP. Quando o Outlook recebe essa notificação, ele recupera a mensagem do servidor Exchange e a exibe na pasta apropriada. Se o Outlook não receber novas notificações de email, ele reverterá para sondar o servidor Exchange. Embora a sondagem seja iniciada pelo Outlook, sua freqüência é ditada pelo servidor Exchange.

Por padrão, o Outlook 2003 sonda a cada 60 segundos. Você pode alterar a freqüência adicionando a entrada do Registro Maximum Polling Frequency ao servidor Exchange que contém a caixa de correio do usuário. O valor que você insere é o número mínimo de milissegundos entre os intervalos de sondagem. Se Maximum Polling Frequency não estiver presente, um valor padrão de 60 segundos (60.000 milissegundos) será usado. Esse valor padrão não significa que essa sondagem ocorre a cada 60 segundos. Em vez disso, o valor significa que a sondagem ocorrerá a qualquer hora entre o intervalo de freqüência de sondagem e duas vezes esse intervalo. Por exemplo, suponha que Maximum Polling Frequency está definido como 90 segundos. Nesse exemplo, a sondagem ocorrerá entre 90 e 180 segundos após a última sondagem.

Você não deve reduzir o valor abaixo do valor padrão de 60 segundos, pois isso prejudicará o desempenho do Exchange, do Outlook e da rede. Não é preciso ajustar esse valor, pois muitas ações de usuários verificarão novas mensagens como parte de operações internas. Por exemplo, se um usuário alternar entre pastas ou abrir uma mensagem, novos itens do servidor serão exibidos. Esse resultado ocorre porque quando o Outlook envia solicitações RPC necessárias para o Exchange efetivar a ação do usuário, um novo sinalizador de mensagem é verificado e, se estiver presente, a nova notificação de mensagem será incluída na resposta RPC enviada de volta para o Outlook.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Exclua o valor de Registro Maximum Polling Frequency.

  4. Reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações a respeito de RPC sobre HTTP, consulte o Guia de Situações de Implantação de RPC sobre HTTP no Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47577).


Tamanho mínimo do cache do ESE alterado manualmente
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-01-16

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchESEParamCacheSizeMin para todos os objetos de armazenamento da caixa de correio. Se o Exchange Server Analyzer detectar que o valor do atributo msExchESEParamCacheSizeMin de qualquer armazenamento de caixa de correio é maior do que 0, uma mensagem de configuração não padrão será exibida.

O serviço Armazenamento de Informações do Microsoft Exchange usa o cache do mecanismo de armazenamento extensível (ESE) como buffer quando grava dados do armazenamento no disco. O tamanho máximo de cache do Exchange 2000 Server é 858 MB. O Exchange Server 2003 determina dinamicamente o valor padrão da propriedade msExchESEParamCacheSizeMin, com base na quantidade de memória RAM física instalada no servidor.

Por exemplo, o tamanho de cache máximo para um computador do Exchange Server 2003 que tenha a opção /3GB definida no arquivo boot.ini é de 896 MB. Se o computador não tiver a opção /3GB definida, o tamanho máximo de cache será de 576 MB.

Você pode usar as seguintes informações para restaurar o valor original da propriedade msExchESEParamCacheSizeMin:

  • Se o Exchange Server 2003 estiver sendo executado no Microsoft Windows Server™ 2003 e o servidor tiver 2 GB ou mais de RAM, o msExchESEParamCacheSizeMin será de 131072 (512 MB).

  • Se o Exchange Server 2003 estiver sendo executado no Windows Server 2003 e o servidor tiver 768 MB ou mais, mas menos de 2 GB de RAM, o msExchESEParamCacheSizeMin será igual a "RAM/4*(4*1024)".

  • Se o Exchange Server 2003 estiver sendo executado no Windows Server 2003 e o servidor tiver menos de 768 MB de RAM, o msExchESEParamCacheSizeMin será igual a "RAM/8*(4*1024)".

Por exemplo:

  • O Windows Server 2003 com 512 MB de RAM terá um valor padrão para msExchESEParamCacheSizeMin de 16384 (páginas de 4 KB).

  • O Windows Server 2003 com 1 GB de RAM terá um valor padrão para msExchESEParamCacheSizeMin de 65536 (páginas de 4 KB).

  • O Windows Server 2003 com 4 GB de RAM terá um valor padrão para msExchESEParamCacheSizeMin de 131072 (páginas de 4 KB).

  • Se o Exchange Server 2003 estiver sendo executado no Microsoft Windows® 2000 Server, nenhum valor padrão será definido para msExchESEParamCacheSizeMin.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir que você reinstale o Windows Server 2003, o Exchange Server 2003, ou ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse aviso

  1. Abra um editor do Active Directory, como o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração.

  3. Expanda CN=Serviços.

  4. Expanda CN=Microsoft Exchange.

  5. Expanda CN=<Nome da Organização do Exchange>.

  6. Expanda CN=Grupos Administrativos.

  7. Expanda CN=<Nome do Grupo Administrativo>.

  8. Expanda CN=Servidores.

  9. Expanda CN=<Nome do Exchange Server>.

  10. Clique com o botão direito em CN=Armazenamento de Informações e clique em Propriedades.

  11. No campo de atributos, role até msExchESEParamCacheSizeMin e clique duas vezes nesse parâmetro.

  12. No campo Valor, digite o valor que você deseja definir. Você pode usar a fórmula padrão e editá-la de acordo com sua situação. O valor usado deve ser um múltiplo de 32 MB.

  13. Clique em OK e em OK novamente.

  14. Feche o editor do Active Directory e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre como ajustar o atributo msExchESEParamCacheSizeMin, consulte o artigo 822894 da Base de Dados de Conhecimento Microsoft , "O banco de dados Jet não funciona corretamente durante um backup ou durante uma operação de indexação de conteúdo" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822894).


O número de threads para o processo de armazenamento é alto
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Process para determinar o valor de ThreadCount para o processo Armazenamento de Informações do Exchange. Esse valor representa o número de segmentos de armazenamento ativos no servidor. Se existirem mais de 400 segmentos de armazenamento ativos, será exibida uma mensagem de aviso.

A causa mais comum desse problema é a execução de software antivírus incompatível, no mesmo computador.

Para corrigir esse aviso

  1. Consulte seu fornecedor para ter certeza de que você está executando software antivírus atualizado, compatível com o Exchange.

  2. Atualize o seu software antivírus.

Para obter mais informações sobre software antivírus e o Exchange Server 2003, consulte o artigo 823166 da Base de Dados de Conhecimento da Microsoft, "Visão geral do Exchange Server 2003 e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).


Parâmetro de Registro Limite de Largura de Banda do OAB (KBps) é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a chave de Registro a seguir para determinar se a chave de Registro OAB Bandwidth Threshold (KBps) foi criada:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se o Exchange Server Analyzer detectar que a chave do Registro OAB Bandwidth Threshold (KBps) foi criada em ParametersSystem, ele exibirá uma mensagem de configuração diferente do padrão.

No Microsoft Exchange Server 2003 Service Pack 1 (SP1), o administrador pode definir e configurar a chave de Registro OAB Bandwidth Threshold (KBps) para substituir a funcionalidade padrão e limitar a largura de banda que é usada para downloads completos de um catálogo de endereços offline a partir de um armazenamento público específico.

Por padrão, cada solicitação de cliente para um download completo de um catálogo de endereços é atendida imediatamente. Além disso, o armazenamento público não limita o número de downloads completos simultâneos de catálogos de endereços offline. O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária. No entanto, você pode excluir a chave de Registro OAB Bandwidth Threshold (KBps) se desejar restaurar a configuração padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para restaurar a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Exclua o valor Limite de Largura de Banda do OAB (KBps).

  4. Feche o editor de Registro.

O serviço Armazenamento de Informações do Microsoft Exchange detecta as alterações em minutos. Não é necessário reiniciar o computador.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre otimização da largura de banda consumida durante os downloads de catálogo de endereços offline, consulte o artigo 867623 da Base de Dados de Conhecimento, "Otimizando os downloads de catálogos de endereços offline para limitar o efeito de uma rede local no Exchange Server 2003," (http://go.microsoft.com/fwlink/?linkid=3052&kbid=867623).


O catálogo de endereços offline não está associado a um armazenamento de caixa de correio específico
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o atributo msExchUseOAB na classe msExchPrivateMDB foi configurado para usar um catálogo de endereços offline específico para um determinado armazenamento de caixa de correio em um banco de dados. A classe msExchPrivateMDB determina a configuração em um banco de dados particular. O atributo msExchUseOAB determina o catálogo de endereços offline específico que um determinado armazenamento de caixa de correio usa. Se o Exchange Server Analyzer perceber que está faltando o catálogo de endereços offline para o armazenamento de caixa de correio no banco de dados, o Exchange Server Analyzer exibirá uma mensagem de erro.

No Exchange 2000 Server e nas versões posteriores, uma lista de endereços offline está associada a todos os usuários contidos em um armazenamento de informações. Você não pode associar automaticamente uma lista de endereços offline a uma caixa de correio específica ou substituir as configurações da lista de endereços offline global para o armazenamento de informações ou o grupo de armazenamento.

Para associar uma lista de endereços offline a uma determinada caixa de correio, primeiro você deve criar uma lista de endereços offline que contenha uma cópia filtrada da lista de endereços global. Em seguida, você precisa associar a lista de endereços offline a uma determinada caixa de correio usando ADSI (Active Directory Service Interfaces) Edit ou outro cliente da versão 3 do LDAP para definir o atributo msExchUseOAB para o nome distinto completo da lista de endereços offline.

Cuidado:
Se modificar de maneira incorreta os atributos dos objetos do Active Directory ao usar o ADSI Edit, a ferramenta LDP (ldp.exe) ou outro cliente da versão 3 do LDAP, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003, do Exchange Server 2007, ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para obter instruções detalhadas sobre como associar um catálogo de endereços offline a uma determinada caixa de correio, consulte o artigo 275203 da Base de Dados de Conhecimento Microsoft, "Catálogo de endereços offline não pode ser associado a uma determinada caixa de correio" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=275203).

Para aprender mais sobre os catálogos de endereços offline, consulte Guia de Práticas Recomendadas do Catálogo de Endereços Offline (http://go.microsoft.com/fwlink/?LinkId=47583) (em inglês).


O Horário de Conclusão ANTIGO para um armazenamento de pasta pública é não padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada de Registro a seguir para determinar se o atraso do início da desfragmentação online teve sua configuração padrão alterada:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Completion Time

Se a ferramenta achar que a chave Horário de Conclusão ANTIGO está presente e configurada, uma mensagem de configuração não padrão será exibida. A chave Horário de Conclusão ANTIGO especifica o período de tempo em segundos que a desfragmentação online é executada após a janela de manutenção de armazenamento de informações. O valor padrão é 1 hora (3.600 segundos).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Exclua a chave OLD Completion Time.

  4. Feche o editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O Tempo de Execução Mínimo ANTIGO para um armazenamento de pasta pública é não padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar se o tempo de execução mínimo para desfragmentação online foi modificado em relação à configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Minimum RunTime

Se o Exchange Server Analyzer perceber que a chave OLD Minimum RunTime está presente, uma mensagem de configuração não padrão será exibida. A chave OLD Minimum RunTime especifica o tempo mínimo, em segundos, de execução da desfragmentação online.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Exclua a chave OLD Minimum RunTime.

  4. Feche o editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


A desfragmentação online foi desabilitada
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Analisador do Microsoft® Exchange consulta o serviço de diretório do Active Directory® para saber o valor do atributo msExchESEParamEnableOnlineDefrag em cada objeto de grupo de armazenamento. Um valor igual a Verdadeiro indica que a manutenção do banco de dados online ocorrerá de acordo com o agendamento configurado. Um valor igual a Falso indica que a manutenção online não ocorrerá. Se o Analisador do Exchange Server detectar que o valor do atributo msExchESEParamEnableOnlineDefrag está definido com Falso, será exibido um erro.

A manutenção do banco de dados online, inclusive a desfragmentação, no Exchange Server é muito importante. Durante esse intervalo, são realizadas tarefas, como a limpeza do dumpster (exclusão de mensagens que passaram da data de retenção de itens excluídos), expiração de pastas públicas (as mensagens anteriores a determinada data, contidas em pastas públicas, estão expiradas), limpeza de caixas de correio excluídas, desfragmentação online (objetos de bancos de dados que não estão mais sendo usados são detectados e removidos, disponibilizando espaço adicional no banco de dados) e assim por diante. Esses processos ajudam a manter o servidor Exchange íntegro e o desempenho estável. A manutenção de banco de dados online não deve ser definida com Nunca Executar porque essa ação pode degradar o desempenho no decorrer do tempo.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003, do Exchange Server 2007, ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro

  1. Clique em Iniciar, Executar, digite MMC e clique em OK.

  2. No MMC (Console de Gerenciamento Microsoft), clique em Arquivo e em Adicionar/Remover Snap-in.

  3. Na lista de Snap-ins Autônomos Disponíveis, selecione ADSI Edit, clique em Adicionar e em Fechar. Clique em OK na caixa Adicionar/Remover Snap-in.

  4. Clique com o botão direito em ADSI Edit e clique em Conectar a. Na caixa de diálogo Selecione um contexto de atribuição de nome conhecido, selecione Configuração e clique em OK.

  5. Expanda o contêiner de configuração, CN=Configuração, CN=Serviços, CN=Microsoft Exchange, CN=<Nome da Organização>, CN=Grupos Administrativos, CN=<Nome do Grupo Administrativo>, CN=Servidores, CN=<Nome do Servidor>, CN=Armazenamento de Informações.

  6. Clique com o botão direito em CN=<Nome do Grupo de Armazenamento> e clique em Propriedades.

  7. Na caixa de diálogo Propriedades do Grupo de Armazenamento, selecione msExchESEParamEnableOnlineDefrag na lista de atributos, clique em Editar e altere o valor para Verdadeiro.

  8. Feche o ADSI Edit e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre manutenção de banco de dados online, consulte os seguintes recursos do Exchange:

  • Artigo 314214 da Base de Dados de Conhecimento da Microsoft, "Como definir intervalos de manutenção nos armazenamentos de dados do Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314214).

  • Artigo interno sobre o Exchange Server 2007, "Manutenção do Armazenamento do Exchange" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80787).


Origem de aterramento preferida habilitada
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas do Registro para determinar se a chave Origem de Aterramento Preferida foi modificada do valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID of Public Store>\Preferred Backfill Source

Por padrão, a Origem de Aterramento Preferida não existe. Se o Exchange Server Analyzer verificar a presença da chave Origem de Aterramento Preferida, será exibida uma mensagem de configuração não padrão.

O aterramento ocorre quando o armazenamento de uma pasta pública determina que ele não recebeu todas as atualizações da pasta replicada (ou para a hierarquia) e deve recuperar as atualizações ausentes a partir de um outro armazenamento.

Para simplificar o processo de aterramento, o Exchange Server armazena informações sobre atualizações ausentes na matriz de aterramento.

A matriz de aterramento armazena essas informações por um período de tempo especificado (chamado tempo limite de aterramento). Se as atualizações ausentes chegarem em mensagens de replicação subseqüentes durante esse período, elas serão removidas da matriz de aterramento. A tabela lista os valores de tempo limite de aterramento padrão, que dependem de onde estão as atualizações ausentes e se elas já foram solicitadas antes.

Tipo de solicitação | O conteúdo está em um armazenamento no site local | O conteúdo está em um armazenamento em um site remoto
Aterramento inicial | 6 horas | 12 horas
Primeira repetição de aterramento | 12 horas | 24 horas
Repetições de aterramento subseqüentes | 24 horas | 48 horas

Se o tempo limite de aterramento expirar e as atualizações ainda estiverem ausentes, o Exchange Server 2003 cria uma ou mais solicitações de aterramento e determina quais servidores serão usados como fontes de aterramento.

Para selecionar um servidor (ou servidores) para usar como fonte de aterramento, o Exchange Server 2003 primeiro cria uma lista de todos os servidores que tenham réplicas da pasta e, depois, classifica a lista de acordo com a seqüência de critérios a seguir:

  • Classificar de acordo com o status do servidor. Os servidores desativos ou indisponíveis vão para o final da lista.

  • Classificar de acordo com o servidor de aterramento preferido. (se houver; este recurso só está disponível no Exchange Server 2003 e posterior). O Exchange Server 2003 verifica o objeto de armazenamento da pasta pública no serviço de diretório Active Directory® para obter o servidor de aterramento preferido. Essa configuração raramente é utilizada. Na maioria das circunstâncias, o processo de aterramento operará de forma mais eficiente se o Exchange Server 2003 selecionar um servidor de aterramento automaticamente. A maioria das implantações do Exchange Server 2003 não precisa de um servidor de aterramento preferido. O Atendimento Microsoft pode fornecer um script que defina um servidor de aterramento preferido se isso for exigido por sua implantação.

  • Classificar de acordo com o custo do transporte (do mais baixo para o mais alto). Os servidores no mesmo site têm prioridade sobre os servidores em sites remotos. O custo de transporte de um servidor é calculado pelo mecanismo de roteamento do Exchange Server 2003 e normalmente é usado para calcular a forma mais eficiente de entregar uma mensagem. Observe que em versões do Exchange anteriores ao Exchange Server 2003, o custo de transporte tem prioridade menor e só é considerado após a versão do Exchange e o número de alterações disponíveis.

  • Classificação de acordo com a versão do Exchange (da mais nova para a mais antiga).

  • Classificar de acordo com o número de alterações necessárias que estão disponíveis no servidor (do maior para o menor). Os servidores que não tiverem alterações ausentes serão eliminados da lista.

Se um servidor não tiver todas as alterações necessárias, o Exchange Server 2003 seleciona o próximo servidor na lista de classificação e envia uma solicitação de aterramento para esse servidor também. Esse processo é repetido até que todas as alterações tenham sido solicitadas. Esse recurso só está disponível no Exchange Server 2003 ou posterior; versões anteriores do Exchange enviam solicitações de aterramento para um servidor de cada vez se nenhum servidor específico contiver todas as atualizações ausentes para uma pasta específica. Após cada solicitação, versões anteriores do Exchange aguardam que o tempo de repetição (de 24 a 48 horas) se esgote antes de enviar a próxima solicitação.

Se o servidor selecionado não responder à solicitação de aterramento, o armazenamento marcará esse servidor como inativo e repetirá o processo de seleção. Os servidores marcados como inativos são enviados para o final da lista.

Na maioria das vezes, a topologia funcionará de modo eficiente se você permitir que o Exchange Server selecione automaticamente os servidores de aterramento. Para fins de solução de problemas, o Atendimento Microsoft pode sugerir a definição Origem de Aterramento Preferida. No entanto, só utilize esta opção quando precisar resolver um problema específico.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para redefinir a chave do Registro Origem de Aterramento Preferida

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID do Armazenamento Público>

  3. Examine ou edite o valor de Origem de Aterramento Preferida.

    O valor para essa entrada de Registro está em quilobytes (KB). Para restaurar o valor padrão, exclua a chave Origem de Aterramento Preferida e reinicialize o serviço Armazenamento de Informações do Microsoft Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre replicação de pasta pública, consulte "Controlling Exchange Server 2003 Public Folder Replication" em Working with the Exchange Server 2003 Store (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).


A origem de aterramento de Pasta Pública Preferida foi habilitada
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada de Registro para determinar se o Exchange foi configurado com uma origem de aterramento preferida para a hierarquia de pasta pública:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>\Preferred Backfill Source

Se o Exchange Server Analyzer detectar que o valor do Registro Origem de Aterramento Preferida está presente e configurado, uma mensagem de configuração não padrão será exibida.

O Exchange Server 2003 introduz um novo atributo do serviço de diretório do Active Directory® chamado msexchPreferredBackfillSource que pode ser usado para designar qual Exchange Server deve receber mensagens de solicitação de aterramento.

Quando uma pasta pública precisar replicar conteúdo, ela enviará uma consulta para a organização do Exchange para obter uma solicitação de aterramento. O primeiro servidor de pasta pública que responder será usado para aterrar os dados. Essa lógica supõe que o primeiro servidor de pasta pública a responder seja o mais próximo; no entanto, isso nem sempre é verdade. Uma oportunidade de configuração que permite que um administrador especifique o servidor preferido para o aterramento foi introduzida no Exchange Server 2003.

No Exchange Server 2003, você pode definir o servidor preferido para ser usado para aterramento de hierarquia de pasta pública e conteúdo, usando o atributo do Active Directory ou a entrada do valor de Registro Origem de Aterramento Preferida no servidor da pasta pública. O parâmetro do Active Directory é verificado primeiro. Se for nulo, o parâmetro do Registro será verificado. Se for inexistente, o algoritmo padrão do aterramento de pasta pública será usado.

Para usar o atributo do Active Directory, defina o DN (nome distinto) do armazenamento de pasta pública com necessidade de aterramento no atributo msExchPreferredBackfillSource nos objetos de armazenamento de pasta pública.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Se você optar por editar o atributo msExchPreferredBackfillSource no Active Directory, precisará usar um editor do Active Directory, como ADSI (Active Directory Service Interfaces) Edit ou a ferramenta LDP (ldp.exe).

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para especificar uma origem de aterramento de pasta pública preferida no Registro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nome do servidor>\Public-<GUID de Armazenamento de Informações Públicas>

  3. Examine e, se desejar, altere o valor Origem de Aterramento Preferida. O valor que deve ser inserido é o DN (Nome Distinto) do armazenamento de pasta pública do Exchange que você prefere ter como origem.

  4. Se uma alteração for feita, desmonte e remonte o armazenamento de informações públicas para que a alteração tenha efeito.

Para especificar uma origem de aterramento de pasta pública preferida no Active Directory

  1. Modifique o valor do objeto do Armazenamento de Pasta Pública afetado para msExchPreferredBackfillSource para apontar para a origem de aterramento desejada. É possível encontrar o atributo msExchPreferredBackfillSource em: CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName, CN=InformationStore, CN=StorageGroupName, CN=Public Folder Store

  2. O valor que deve ser inserido é o DN (Nome Distinto) do armazenamento de pasta pública do Exchange que você prefere ter como origem.

  3. Se uma alteração for feita, desmonte e remonte o armazenamento de informações públicas para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como modificar o Active Directory com a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento, "XADM: Usando o utilitário LDP para modificar os atributos de objeto do Active Directory" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745) (em inglês).


Fornecar mais espaço em disco
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer Tool determinou que o espaço em disco no computador executando o Exchange Server está abaixo dos níveis aceitáveis. O Exchange Server Analyzer mede o espaço em disco disponível para verificar se ele está dentro de uma faixa aceitável. Se a ferramenta detectar que o espaço em disco está abaixo dos níveis aceitáveis, exibirá uma mensagem de erro. É recomendável que todos os discos em computadores executando o Exchange Server contenham caixas de correio com pelo menos 10% de sua capacidade livre, o tempo todo.

O Exchange Server Analyzer testa as seguintes unidades:

  • Unidade do banco de dados

  • Unidade Temp

  • Unidade MailRoot

  • Unidade STM

  • Unidade do sistema

  • Unidade de Log

    Observação:
    A tabela de estado requer que o tamanho da unidade de log seja aumentado e os logs sejam arquivados.
  • Unidade de páginas

Para corrigir esse erro

  1. Para liberar espaço em disco, exclua os arquivos desnecessários do disco.

  2. Se o disco que tiver menos de 10% do espaço livre contiver dados que possam ser movidos com segurança para outro disco (como caixas de correio ou o arquivo de paginação do Microsoft Windows®), execute as etapas necessárias para mover esses dados.

  3. Adicione capacidade de disco ao computador executando o Exchange Server.

  4. Reduza o tamanho das caixas de correio ou mova usuários para outro servidor.

Para obter mais informações

  • Para obter mais informações sobre a movimentação de caixas de correio no Exchange Server 2003, consulte o artigo 821829 da Base de Dados de Conhecimento Microsoft, "Movendo caixas de correio no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

  • Para obter mais informações sobre a movimentação de caixas de correio no Exchange 2000 Server, consulte o artigo 328810 da Base de Dados de Conhecimento da Microsoft, "Movendo caixas de correio entre servidores" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

  • Para obter mais informações sobre como definir limites de caixas de correio com as diretivas do sistema no Exchange Server 2003, consulte o artigo 822938 da Base de Dados de Conhecimento da Microsoft, "COMO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938).

  • Para obter mais informações sobre como definir limites de caixas de correio com as diretivas do sistema no Exchange Server 2000, consulte o artigo 319130 da Base de Dados de Conhecimento da Microsoft, "COMO: Use System Policies to Configure Mailbox Storage Limits in Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130).

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre as práticas recomendadas para projetar arquiteturas de armazenamento, consulte Práticas recomendadas comuns a diversas arquiteturas (http://go.microsoft.com/fwlink/?LinkId=72988) (em inglês).

  • Para obter mais informações sobre o dimensionamento do disco, latência e taxas de E/S, consulte Como calcular os requisitos de E/S do disco (http://go.microsoft.com/fwlink/?linkid=69747) (em inglês).


Arquivo de banco de dados de armazenamento de pasta pública armazenado na unidade de rede
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para obter o valor do atributo msExchEDBFile de cada objeto de armazenamento de pasta pública. Esse atributo especifica o local dos arquivos de banco de dados usados por este armazenamento de pasta pública.

O Exchange Server Analyzer também consulta o Active Directory para determinar a contagem dos valores listados no atributo homeMDBBL de cada armazenamento de caixa de correio nesse servidor. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio. O Exchange Server Analyzer pode, então, calcular o número total de caixas de correio gerenciadas pelo servidor.

Se o Analisador do Exchange Server detectar que o atributo msExchEDBFile inicia com \\ em um Exchange Server com mais de 50 caixas de correio, será exibido um erro.

Esse erro indica que os arquivos de banco de dados do armazenamento de pastas públicas estão sendo armazenados em um compartilhamento da rede. Se o atributo msExchEDBFile começar com \\, significa que o caminho de arquivo de log usa um caminho UNC (Convenção Universal de Nomenclatura). Essa não é uma prática recomendada porque as interrupções na conectividade da rede podem gerar erros no banco de dados, resultando em perda de dados ou bancos de dados danificados. É recomendável que você corrija esse problema o mais rápido possível.

Para mover os arquivos de banco de dados para uma nova unidade

  1. No Gerenciador do Sistema do Exchange, expanda o objeto do servidor Exchange em que o armazenamento reside, expanda o contêiner do grupo de armazenamento adequado, clique com o botão direito no objeto de armazenamento de pastas públicas necessário e clique em Propriedades.

  2. Especifique novos locais de arquivo na guia Banco de dados da caixa de diálogo Propriedades.

Para obter mais informações sobre arquivos de banco de dados do Exchange Server, consulte os seguintes tópicos:

  • "Gerenciando os armazenamentos de caixas de correio e de pastas públicas" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617)

  • "Understanding the Exchange Server 2003 Store" em Working with the Exchange Server 2003 Store (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595)

Para obter mais informações sobre como usar o Exchange Server com unidades de rede, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328879, "Using Exchange Server with Storage Attached Network and network-attached storage devices" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • 839687, "Microsoft support policy on the use of network-attached storage devices with Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • 317173, "Exchange Server and network-attached storage" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • 317172, "Exchange Server 5.5 and network-attached storage" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


O limite de tamanho do Banco de Dados do Armazenamento de Pasta Pública foi definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o valor do Registro Database Size Limit in Gb está presente e configurado para o armazenamento de pastas públicas:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server_Name>\Public-<MailboxStoreGUID>

Se o Exchange Server Analyzer considerar que o valor Limite do Tamanho do Banco de Dados em Gb está presente e configurado, ele exibirá uma mensagem de configuração não-padrão.

Quando o Exchange Server 2003 Service Pack 2 (SP2) é aplicado ao Exchange Server 2003 Standard Edition, o limite de tamanho do banco de dados codificado no licenciamento é aumentado de 16 gigabytes (GB) para 75 GB. Você pode definir um limite de proteção de tamanho de banco de dados para impedir o aumento não intencional do tamanho do banco de dados. O valor do limite de tamanho padrão no SP2 é 18 GB, e esse valor padrão pode ser substituído pela criação de um valor de Registro Limite de Tamanho do Banco de Dados em Gb.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<MailboxStoreGUID>

  3. Exclua o valor Limite de Tamanho do Banco de Dados em Gb.

  4. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter informações sobre o SP2 do Exchange Server 2003, consulte o site do Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


O armazenamento de pasta pública não tem um backup completo há mais de 8 dias
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A Ferramenta Microsoft® Exchange Server Analyzer consulta o armazenamento de pasta pública para determinar a data e a hora do último backup completo. Se o Exchange Server Analyzer detectar que o número de dias desde o último backup completo de um armazenamento de pasta pública é maior que oito, o Exchange Server Analyzer exibirá um aviso.

O armazenamento de pasta pública guarda informações associadas a uma determinada árvore de pastas públicas, por exemplo, como a árvore está estruturada e as pastas nela contidas. Ele também armazena o conteúdo da pasta pública. Um armazenamento de pasta pública é composto de um arquivo.edb rich-text e um arquivo.stm streaming de conteúdo nativo da Internet.

Os dados do armazenamento de caixas de correio e do armazenamento de pastas públicas nos bancos de dados e logs de transações do Exchange Server são os dados mais importantes de um backup na organização do Exchange Server. Você pode usar um backup de banco de dados do Exchange Server para restaurar um armazenamento de pasta pública danificado para um servidor em funcionamento que execute o Exchange Server. Você também pode usar os backups de bancos de dados do Exchange Server para restaurar seus bancos de dados do Exchange Server em outro servidor.

Como uma prática recomendada, você deve fazer backup completo de seus arquivos de banco de dados e logs de transações diariamente. Após concluir um backup completo, os arquivos de log de transações confirmados nos bancos de dados do Exchange Server são excluídos do servidor. Um backup completo oferece a vantagem da velocidade em um cenário de recuperação, pois basta um conjunto de fitas para restaurar todos os dados.

Observação:
É uma prática recomendada manter os logs de transações em um disco dedicado, separadamente dos arquivos de bancos de dados. Isso permite tolerância a falhas se um disco do banco de dados for destruído e, em alguns casos, aumenta o desempenho do banco de dados.
Importante:
Ao tentar fazer backup ou restaurar arquivos e pastas, você deve ter os direitos ou as permissões necessários atribuídos para a conta do usuário com que efetuou logon. Para criar backups do Exchange Server, você deverá ter direitos de operador de backup em nível de domínio. Para criar backups do sistema operacional Microsoft Windows Server™ 2003, você deve ter, no mínimo, direitos de operador de backup local.

A estratégia de backup que você escolher para os dados do Exchange Server dependerá do tamanho dos armazenamentos, da velocidade do software e hardware de backup, da capacidade do hardware e dos requisitos de tempo.

Para obter mais informações sobre estratégias de backup, bem como sobre operações de recuperação de desastres, consulte:

  • Guia de Operações de Recuperação de Desastre do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47570).

  • Backup e Restauração de Banco de Dados (em inglês) (http://go.microsoft.com/fwlink/?LinkID=80766).


O armazenamento de pasta pública não tem um backup completo há mais de 60 dias
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A Ferramenta Microsoft® Exchange Server Analyzer consulta o armazenamento de pasta pública para determinar a data e a hora do último backup completo. Se o Exchange Server Analyzer verificar que o número de dias desde o último backup completo de um armazenamento de pasta pública é maior do que 60, será exibido um erro.

O armazenamento de pasta pública tem informações associadas com uma determinada árvore de pasta pública; por exemplo, como a árvore é estruturada e que pastas ela contém. O armazenamento de pasta pública também tem conteúdo de pastas públicas. Um armazenamento de pasta pública é composto de um arquivo.edb rich-text e um arquivo.stm streaming de conteúdo nativo da Internet.

Os dados do armazenamento de caixas de correio e do armazenamento de pastas públicas nos bancos de dados e logs de transações do Exchange Server são os dados mais importantes de um backup na organização do Exchange Server. Você pode usar um backup de banco de dados do Exchange Server para restaurar um armazenamento de pasta pública danificado para um servidor em funcionamento que execute o Exchange Server. Você também pode usar os backups de bancos de dados do Exchange Server para restaurar seus bancos de dados do Exchange Server em outro servidor.

Como uma prática recomendada, você deve fazer backup completo de seus arquivos de banco de dados e logs de transações diariamente. Após concluir um backup completo, os arquivos de log de transações confirmados nos bancos de dados do Exchange Server são excluídos do servidor. Um backup completo oferece a vantagem da velocidade em um cenário de recuperação, pois basta um conjunto de fitas para restaurar todos os dados.

Observação:
É uma prática recomendada manter os logs de transações em um disco dedicado, separadamente dos arquivos de bancos de dados. Essa prática recomendada melhora o desempenho do banco de dados, mas também fornece tolerância a falhas em caso de o disco do banco de dados ser destruído.
Importante:
Ao tentar fazer backup ou restaurar arquivos e pastas, você deve ter os direitos ou as permissões necessários atribuídos para a conta do usuário com que efetuou logon. Para criar backups do Exchange Server, você deverá ter direitos de operador de backup em nível de domínio. Para criar backups do sistema operacional Microsoft Windows Server™ 2003, você deve ter, no mínimo, direitos de operador de backup local.

A estratégia de backup que você escolher para os dados do Exchange Server dependerá do tamanho dos armazenamentos, da velocidade do software e hardware de backup, da capacidade do hardware e dos requisitos de tempo.

Para obter mais informações sobre estratégias de backup, bem como sobre operações de recuperação de desastres, consulte:

  • Guia de Operações de Recuperação de Desastre do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=47570).

  • Backup e Restauração de Banco de Dados (http://go.microsoft.com/fwlink/?LinkId=80766).


O armazenamento de pastas públicas excede 12 GB
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_DataFile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave FileSize de cada arquivo de banco de dados de armazenamento de pasta pública (arquivo .edb) e arquivo de streaming (arquivo .stm) do Exchange. O Exchange Server Analyzer também lê a seguinte ramificação do Registro para determinar a versão do Exchange Server que está instalada:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<GUID de produto do Exchange>

Se o Exchange Server Analyzer verificar que o tamanho combinado de um par de banco de dados de armazenamento de pasta pública e um arquivo de streaming excede 12 GB em um computador que esteja executando o Microsoft Exchange Server 2003 Standard Edition ou o Exchange 2000 Server Standard Edition, um aviso será exibido.

Os bancos de dados de armazenamento do Exchange Server 2003 Standard Edition e do Exchange 2000 Server Standard Edition não podem ficar maiores do que 16 GB. Depois que esse limite é atingido, o armazenamento da caixa de correio não será mais montado, e o Exchange ficará inacessível. Os bancos de dados de armazenamento do Exchange Server 2003 Enterprise Edition e no Exchange 2000 Server Enterprise Edition não estão limitados a 16 GB; eles são limitados apenas pelo hardware disponível, com o tamanho máximo, em teoria, de 16 terabytes.

Para corrigir esse aviso

  1. Considere a possibilidade de definir diretivas de expiração em pastas públicas que excluam mensagens depois de um certo tempo.

  2. Considere a possibilidade de definir limites de armazenamento para armazenamentos de pasta pública e pastas públicas individuais para evitar o crescimento ilimitado do armazenamento de pasta pública.

  3. Se você tiver excluído mensagens em massa ou removido réplicas de pasta desta pasta pública recentemente, a execução de uma desfragmentação online pode diminuir o tamanho dos arquivos.
Observação:
Com o lançamento do Exchange Server 2003 Service Pack 2 (SP2) no Exchange Server 2003 Standard Edition, o limite de tamanho do banco de dados de licenciamento codificado foi aumentado de 16 GB para 75 GB. O administrador pode definir um limite de proteção de tamanho de banco de dados (impedir o aumento não intencional do tamanho do banco de dados). O valor padrão é 18 GB no SP2 para a Standard Edition e o padrão de 18 GB pode ser substituído, editando-se a Chave do Registro Limite de Tamanho do Banco de Dados em Gb.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar o limite de tamanho do banco de dados para um banco de dados com o Exchange Server 2003 SP2

  1. No computador que estiver executando o Exchange Server, inicie Regedit.exe.

  2. Abra a seguinte chave do Registro: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Nome do servidor\ GUID de Armazenamento Público

  3. Clique com o botão direito em GUID de Armazenamento Público, aponte para Novo e clique em Valor DWORD.

  4. Para o nome do novo valor, digite Limite de Tamanho do Banco de Dados em Gb.

  5. Clique duas vezes em Limite de Tamanho do Banco de Dados em Gb. Em Dados do Valor, digite um valor apropriado para o tamanho máximo do banco de dados, em GB. Para o Exchange Server 2003 Standard Edition, digite um valor entre 1 e 75 (o padrão é 18 GB). Para o Exchange Server 2003 Enterprise Edition, digite um valor entre 1 e 8000 (o padrão é 8000 GB). Clique em OK.

  6. Clique com o botão direito em GUID de Armazenamento Público, aponte para Novo e clique em Valor DWORD.

  7. Para o nome do novo valor, digite Buffer de Tamanho do Banco de Dados em Porcentagem.

  8. Clique duas vezes em Buffer de Tamanho do Banco de Dados em Porcentagem. Em Dados do Valor, digite um valor entre 1 e 100 para especificar quando você deseja que os eventos a serem registrados lhe avisem que você está se aproximando do tamanho máximo do banco de dados. O valor padrão 10 resultará em avisos nos eventos a serem registrados quando houver apenas mais 10 por cento da capacidade antes de atingir o tamanho máximo para esse banco de dados. Clique em OK.

  9. Clique com o botão direito em GUID de Armazenamento Público, aponte para Novo e clique em Valor DWORD.

  10. Para o novo nome, digite Horário de Início da Verificação de Tamanho do Banco de Dados, em Horas Depois da Meia-Noite.

  11. Clique duas vezes em Horário de Início da Verificação de Tamanho do Banco de Dados, em Horas Depois da Meia-Noite. Em Dados do Valor, digite um valor entre 0 e 23 para especificar quando você deseja que o Exchange verifique o tamanho do banco de dados. O valor padrão 5 faz com que o Exchange Server verifique o tamanho do banco de dados 5 horas depois da meia-noite (5:00 AM). Clique em OK.

  12. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre os arquivos .stm e .edb, consulte o artigo 232323 da Base de Dados de Conhecimento da Microsoft, "Armazenamento de conteúdo nativo no Microsoft Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Para obter mais informações sobre como mover caixas de correio no Exchange Server 2003, consulte o artigo 821829 da Base de Dados de Conhecimento, "Movendo caixas de correio no Exchange Server 2003" (http://go.microsoft.com/fwlink/?Linkld=3052&kbid=821829).

Para obter mais informações sobre como mover caixas de correio no Exchange 2000 Server, consulte o artigo 328810 da Base de Dados de Conhecimento, "Movendo caixas de correio entre servidores" (http://go.microsoft.com/fwlink/?Linkld=3052&kbid=328810).

Para obter mais informações sobre como executar uma desfragmentação offline de um banco de dados do Exchange Server, consulte o artigo 328804 da Base de Dados de Conhecimento, "Como desfragmentar bancos de dados do Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Para obter mais informações sobre a definição de limites de armazenamento em pastas públicas, consulte o artigo 823144 da Base de Dados de Conhecimento, "COMO: Configurar limites de armazenamento em pastas públicas no Exchange 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144).

Para obter mais informações sobre como alcançar o tamanho máximo de banco de dados no Exchange Server 2003 Standard Edition e no Exchange 2000 Server Standard Edition, consulte o artigo 828070 da Base de Dados de Conhecimento Microsoft, "Armazenamento da caixa de correio do Exchange Server 2003 não monta quando o banco de dados do armazenamento de caixa de correio atinge o limite de 16 GB" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Para obter informações sobre o SP2 do Exchange Server 2003, consulte o site do Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


O armazenamento de pastas públicas excede 15 GB
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_DataFile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave FileSize de cada arquivo de banco de dados (arquivo .edb) e arquivo de streaming (arquivo .stm) do armazenamento de pastas públicas do Exchange. O Exchange Server Analyzer também lê a seguinte ramificação do Registro para determinar a versão do Exchange Server que está instalada:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<GUID de produto do Exchange>

Se o Exchange Server Analyzer detectar que o tamanho combinado de um par de arquivos de banco de dados e streaming do armazenamento de pastas públicas excede 15 GB em um computador que está executando o Microsoft Exchange Server 2003 Standard Edition ou Exchange 2000 Server Standard Edition, será exibido um erro.

Os bancos de dados de armazenamento do Exchange Server 2003 Standard Edition e do Exchange 2000 Server Standard Edition não podem ficar maiores do que 16 GB. Depois que esse limite é atingido, o armazenamento da caixa de correio não será mais montado, e o Exchange ficará inacessível. Os bancos de dados de armazenamento do Exchange Server 2003 Enterprise Edition e no Exchange 2000 Server Enterprise Edition não estão limitados a 16 GB; eles são limitados apenas pelo hardware disponível, com o tamanho máximo, em teoria, de 16 terabytes.

Para corrigir esse erro

  1. Considere a possibilidade de definir diretivas de expiração em pastas públicas que excluam mensagens depois de um certo tempo.

  2. Considere a possibilidade de definir limites de armazenamento para armazenamentos de pasta pública e pastas públicas individuais para evitar o crescimento ilimitado do armazenamento de pasta pública.

  3. Se você tiver excluído mensagens em massa ou removido réplicas de pasta desta pasta pública recentemente, a execução de uma desfragmentação online pode diminuir o tamanho dos arquivos.
Observação:
Com o lançamento do Exchange Server 2003 Service Pack 2 (SP2) para o Exchange Server 2003 Standard Edition, o limite de tamanho do banco de dados codificado no licenciamento foi aumentado de 16 GB para 75 GB. O administrador pode definir um limite de proteção de tamanho de banco de dados (impedir o aumento não intencional do tamanho do banco de dados). O valor padrão é 18 GB no SP2 para a Standard Edition e o padrão de 18 GB pode ser substituído, editando-se a Chave do Registro Limite de Tamanho do Banco de Dados em Gb.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar o limite de tamanho do banco de dados para um banco de dados com o Exchange Server 2003 SP2

  1. No computador que estiver executando o Exchange Server, inicie Regedit.exe.

  2. Abra a seguinte chave do Registro: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Nome do servidor\ GUID de Armazenamento Público

  3. Clique com o botão direito em GUID de Armazenamento Público, aponte para Novo e clique em Valor DWORD.

  4. Para o nome do novo valor, digite Limite de Tamanho do Banco de Dados em Gb.

  5. Clique duas vezes em Limite de Tamanho do Banco de Dados em Gb. Em Dados do Valor, digite um valor apropriado para o tamanho máximo do banco de dados, em GB. Para o Exchange Server 2003 Standard Edition, digite um valor entre 1 e 75 (o padrão é 18 GB). Para o Exchange Server 2003 Enterprise Edition, digite um valor entre 1 e 8000 (o padrão é 8000 GB). Clique em OK.

  6. Clique com o botão direito em GUID de Armazenamento Público, aponte para Novo e clique em Valor DWORD.

  7. Para o nome do novo valor, digite Buffer de Tamanho do Banco de Dados em Porcentagem.

  8. Clique duas vezes em Buffer de Tamanho do Banco de Dados em Porcentagem. Em Dados do Valor, digite um valor entre 1 e 100 para especificar quando você deseja que os eventos a serem registrados lhe avisem que você está se aproximando do tamanho máximo do banco de dados. O valor padrão 10 resultará em avisos nos eventos a serem registrados quando houver apenas mais 10 por cento da capacidade antes de atingir o tamanho máximo para esse banco de dados. Clique em OK.

  9. Clique com o botão direito em GUID de Armazenamento Público, aponte para Novo e clique em Valor DWORD.

  10. Para o novo nome, digite Horário de Início da Verificação de Tamanho do Banco de Dados, em Horas Depois da Meia-Noite.

  11. Clique duas vezes em Horário de Início da Verificação de Tamanho do Banco de Dados, em Horas Depois da Meia-Noite. Em Dados do Valor, digite um valor entre 0 e 23 para especificar quando você deseja que o Exchange verifique o tamanho do banco de dados. O valor padrão 5 faz com que o Exchange Server verifique o tamanho do banco de dados 5 horas depois da meia-noite (5:00 AM). Clique em OK.

  12. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre os arquivos .stm e .edb, consulte o artigo 232323 da Base de Dados de Conhecimento da Microsoft, "Armazenamento de conteúdo nativo no Microsoft Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Para obter mais informações sobre como mover caixas de correio no Exchange Server 2003, consulte o artigo 821829 da Base de Dados de Conhecimento, "Movendo caixas de correio no Exchange Server 2003" (http://go.microsoft.com/fwlink/?Linkld=3052&kbid=821829).

Para obter mais informações sobre como mover caixas de correio no Exchange 2000 Server, consulte o artigo 328810 da Base de Dados de Conhecimento, "Movendo caixas de correio entre servidores" (http://go.microsoft.com/fwlink/?Linkld=3052&kbid=328810).

Para obter mais informações sobre como executar uma desfragmentação offline de um banco de dados do Exchange Server, consulte o artigo 328804 da Base de Dados de Conhecimento, "Como desfragmentar bancos de dados do Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Para obter mais informações sobre a definição de limites de armazenamento em pastas públicas, consulte o artigo 823144 da Base de Dados de Conhecimento, "COMO: Configurar limites de armazenamento em pastas públicas no Exchange 2003"(http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144).

Para obter mais informações sobre quando se alcança o tamanho máximo de banco de dados no Exchange Server 2003 Standard Edition e no Exchange 2000 Server Standard Edition, consulte o artigo 828070 da Base de Dados de Conhecimento, "O armazenamento da caixa de correio do Exchange não é montado quando o banco de dados do armazenamento da caixa de correio atinge o limite de 16 Gb" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Para obter informações sobre o SP2 do Exchange Server 2003, consulte o site do Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


O armazenamento de pasta pública não tem um endereço de email
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-03-28

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor configurado do atributo mail de cada armazenamento de pasta pública. Se o Exchange Server Analyzer detectar que o atributo mail não está configurado para nenhum armazenamento de pasta pública, um erro será exibido.

Se um armazenamento de pasta pública não estiver configurado com um endereço SMTP, a replicação da hierarquia de pastas públicas não funcionará corretamente no armazenamento.

Tecnicamente, armazenamento de pasta pública é um tipo especial de caixa de correio do Exchange. Como todos os objetos habilitados para caixa de correio, um armazenamento de pasta pública deve ter os seguintes atributos configurados corretamente para enviar e receber email:

  • legacyExchangeDN Esse é o nome distinto do objeto no estilo do Exchange.

  • proxyAddresses Esse atributo contém todos os endereços de email que podem ser usados para enviar email ao destinatário.

  • textEncodedORAddress Esse atributo contém o endereço X.400 primário.

  • Mail Esse atributo contém o endereço SMTP primário do objeto, sem prefixo de endereço.

  • mailNickname Esse atributo é usado para gerar a URL de acesso à caixa de correio.

  • displayName Esse atributo contém o nome para exibição do objeto, como ele aparece na lista de endereços global e nas demais listas de endereços das quais o objeto é membro.

Se o atributo de email não estiver definido para um armazenamento de pasta pública, muitas vezes, isso indicará que o Serviço de Atualização de Destinatário não está configurado ou não está funcionando corretamente. Há dois tipos de Serviços de Atualização de Destinatário. Um é responsável por processar os objetos de sistema do Exchange no contêiner Configuração (o Serviço de Atualização de Destinatário Corporativo) e o outro é responsável por processar os destinatários de cada domínio (um Serviço de Atualização de Destinatário de domínio).

Existe apenas um Serviço de Atualização de Destinatário Corporativo em toda a floresta do Active Directory, porque há somente um contêiner Configuração. É esse Serviço de Atualização de Destinatário o responsável por configurar, entre outros itens, o atributo mail para armazenamentos de pasta pública. Se esse serviço estiver desabilitado, configurado incorretamente ou encontrar um problema, os atributos poderão não ser configurados de maneira correta e a replicação de pasta pública não funcionará corretamente. Resolva esse problema verificando a configuração do Serviço de Atualização de Destinatário Corporativo.

Para corrigir esse erro

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Destinatários e selecione o nó Serviços de Atualização de Destinatário.

  3. No painel da direita, clique com o botão direito no Serviço de Atualização de Destinatário que tem (Configuração Corporativa) como parte de seu nome e clique em Propriedades.

  4. Verifique se o campo Domínio tem o nome de domínio correto listado.

  5. Verifique se os computadores listados nos campos Servidor Exchange e Controlador de Domínio do Windows estão funcionando normalmente e disponíveis na rede. Se esses sistemas estiverem desativados, indisponíveis ou não forem os sistemas exigidos para executar tarefas do Serviço de Atualização de Destinatário, você poderá usar o botão Procurar para especificar uma máquina alternativa.

  6. Verifique se o Intervalo de atualização está definido como Executar sempre.

  7. Clique em OK para salvar as alterações.

  8. No painel da direita, clique com o botão direito no Serviço de Atualização de Destinatário que tem (Configuração Corporativa) como parte de seu nome e selecione Reconstruir. A seguinte mensagem será exibida:

    "Esta operação recalculará a associação de Lista de Endereços e as configurações de Diretiva de Destinatário de todos os destinatários contidos em 'contoso.com' no próximo intervalo de atualização agendado. Dependendo do número de destinatários no domínio, isso poderá levar várias horas. Deseja continuar?"

  9. Clique em Sim para reconstruir o Serviço de Atualização de Destinatário.

  10. Após 15 minutos, comece a monitorar o progresso do Serviço de Atualização de Destinatário, seguindo os procedimentos descritos no artigo 246127 da Base de Dados de Conhecimento Microsoft, "XADM: Como verificar o progresso do Serviço de Atualização de Destinatário" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127).

Para obter mais informações sobre o Serviço de Atualização de Destinatário, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 296479, "XADM: Requisitos para desabilitar o Serviço de Atualização de Destinatário" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296479)

  • 328738, "XADM: Como o Serviço de Atualização de Destinatário aplica as diretivas de destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253770, "XADM: Tarefas Executadas pelo Serviço de Atualização de Destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 288807, "Solução de problemas do Serviço de Atualização de Destinatário" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288807)

  • 319065, "COMO FAZER PARA: Trabalhar com o Serviço de Atualização de Destinatário do Exchange" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065)


O armazenamento de pasta pública não será montado na inicialização
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchEDBOffline de todos os objetos com uma classe msExchPublicMDB. Objetos com essa classe são armazenamentos de pasta pública.

Um valor igual a True para o atributo msExchEDBOffline indica que o armazenamento de pasta pública não será montado automaticamente quando o serviço Armazenamento de Informações do Microsoft Exchange for iniciado. Um valor igual a False indica que o armazenamento de pasta pública será montado na inicialização. Se o Exchange Server Analyzer detectar que o valor desse atributo está definido como True, um aviso será exibido.

Esse aviso indica que a caixa de seleção Não montar este armazenamento na inicialização está marcada. Essa caixa de seleção está na guia Banco de Dados da caixa de diálogo Propriedades do armazenamento de pasta pública. Quando a caixa de seleção estiver marcada, o armazenamento de pasta pública não será montado automaticamente quando o serviço Armazenamento de Informações do Microsoft Exchange for iniciado. Na próxima vez em que o serviço Armazenamento de Informações do Microsoft Exchange for iniciado, por exemplo, após uma reinicialização do servidor, um armazenamento de pasta pública com esse atributo definido como True não será montado. É recomendável que os armazenamentos de pasta pública sejam montados automaticamente quando o serviço Armazenamento de Informações do Microsoft Exchange for iniciado.

Para corrigir esse aviso no Exchange 2000 Server e no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores e, em seguida, expanda o servidor que contém o armazenamento de pasta pública que você deseja modificar.

  3. Expanda o grupo de armazenamento que contenha o armazenamento de pasta pública que você deseja modificar.

  4. Clique com o botão direito no armazenamento de pasta pública e clique em Propriedades.

  5. Na guia Banco de Dados, desmarque a caixa de seleção Não montar este armazenamento na inicialização.

  6. Clique em OK para salvar a configuração.

  7. Feche o Gerenciador do Sistema Exchange.

Para corrigir esse aviso no Exchange Server 2007

  1. Abra o Console de Gerenciamento do Exchange

  2. Expanda Configuração do Servidor e selecione o servidor com o qual deseja trabalhar.

  3. Expanda o grupo de armazenamento com o qual você deseja trabalhar.

  4. Clique com o botão direito no banco de dados de pasta pública com o qual você deseja trabalhar e, em seguida, clique em Propriedades.

  5. Na guia Geral, desmarque a caixa de seleção Não montar este banco de dados na inicialização.

  6. Clique em OK para salvar a configuração.

  7. Feche o Console de Gerenciamento do Exchange

Para obter mais informações sobre esta opção, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 314218, "COMO FAZER PARA: Desativar ou ativar a montagem automática de armazenamentos de dados na inicialização do Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314218)

  • 285169, "XADM: Armazenamentos de informações não são montados após o uso do comando "/disasterrecovery"" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=285169)


Atribuição de banco de dados de árvore de pasta pública
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchOwningPFTreeBL para cada classe do objeto msExchPFTree . O atributo msExchOwningPFTreeBL armazena uma lista de nomes distintos de armazenamentos de pasta pública que contêm uma réplica da árvore de pastas públicas. Se o Exchange Server Analyzer verificar que o atributo msExchOwningPFTreeBL em um objeto de árvore de pastas públicas está vazio, será exibido um aviso. Esse aviso indica que uma árvore de pastas públicas não pertence a nenhum armazenamento de pasta pública.

Cada árvore de pastas públicas (também chamada "hierarquia de pasta pública") é vinculada a um armazenamento de pasta pública. É preciso criar primeiro a árvore e depois o armazenamento. Se você ainda não vinculou a árvore a um banco de dados, esse aviso será exibido. Cada árvore de pastas públicas pode ter apenas um armazenamento em um servidor determinado. Uma árvore pode ter vários armazenamentos se cada armazenamento existir em um servidor separado. Em uma configuração assim, o Exchange replica as informações entre os armazenamentos, para manter a consistência da hierarquia.

Se clientes Microsoft Office Outlook® Web Access tentarem se conectar a qualquer pasta pública em uma árvore que não está associada a nenhum armazenamento de pasta pública, ocorrerá um erro de "serviço indisponível" (HTTP 503).

Para corrigir esse aviso, você deve executar uma das seguintes ações:

  • Vincular a árvore de pastas públicas a um banco de dados de pasta pública. Para vincular a árvore de pastas públicas a um banco de dados de pasta pública, é necessário primeiramente criar um novo banco de dados de pasta pública e, em seguida, localizar a árvore de pastas públicas e vinculá-los.

  • Excluir a árvore de pastas públicas. Se você ainda não vinculou a árvore de pastas públicas a um banco de dados de pasta pública, nenhum dado de usuário será perdido quando você excluir a árvore.

Para vincular a árvore de pastas públicas a um banco de dados de pasta pública

  1. No Gerenciador de Sistema do Exchange, expanda o servidor ao qual você deseja adicionar um armazenamento de pasta pública.

  2. Clique com o botão direito em um grupo de armazenamento específico, aponte para Novo e clique em Armazenamento Público.

  3. Em Nome, digite um nome para o novo banco de dados.

  4. Para associar a árvore de pastas públicas ao banco de dados, clique em Procurar e selecione a árvore de pastas públicas exibida no aviso do Exchange Server Analyzer.

  5. Clique em OK para salvar suas configurações.

  6. Para montar o novo armazenamento, clique em Sim.

Para excluir a árvore de pastas públicas

  1. No Gerenciador de Sistema do Exchange, expanda o nó Pastas onde está a árvore de pastas públicas.

  2. Clique com o botão direito na árvore de pastas públicas que você deseja excluir, clique em Excluir e em Sim.

Para obter mais informações sobre administração de pastas públicas, consulte "Gerenciando armazenamentos de caixas de correio e de pastas públicas" no Guia Administrativo do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?linkid=47617).

Para obter mais informações, consulte a Ajuda Online do Exchange Server 2003 Service Pack 1 (SP1) (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=29847).


Grupo de armazenamento de recuperação habilitado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchESEParamBaseName de todos os objetos com uma classe igual a msExchStorageGroup. Os objetos com essa classe são objetos de grupo de armazenamento. Um valor R00 no atributo msExchESEParamBaseName indica que o objeto de grupo de armazenamento é um grupo de armazenamento de recuperação. Se o Exchange Server Analyzer detectar que o valor desse atributo é R00, será exibido um aviso.

Esse aviso indica que existe um grupo de armazenamento de recuperação. É recomendável remover um grupo de armazenamento de recuperação depois de concluir o processo de recuperação. Se você não remover um grupo de armazenamento de recuperação, um administrador que não estiver familiarizado com grupos de armazenamento de recuperação poderá se confundir ao fazer uma recuperação padrão posteriormente.

Para corrigir esse aviso no Exchange 2000 Server e no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores e depois expanda o servidor que contém o grupo de armazenamento de recuperação a ser excluído.

  3. Clique com o botão direito no grupo de armazenamento de recuperação e depois clique em Excluir.

  4. Feche o Gerenciador do Sistema Exchange.

Para corrigir esse aviso no Exchange Server 2007

  1. Siga as orientações contidas na documentação principal do Exchange Server 2007, Como remover um grupo de armazenamento de recuperação (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80783).

Para obter mais informações sobre grupos de armazenamento de recuperação e o Exchange Server 2003, consulte Usando os grupos de armazenamento de recuperação do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=23233) e o artigo 824126 da Base de Dados de Conhecimento Microsoft, "Como usar grupos de armazenamento de recuperação no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824126).

Para obter mais informações sobre os grupos de armazenamento de recuperação e o Exchange Server 2007, consulte Compreendendo os grupos de armazenamento de recuperação (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80784).


Funcionalidade do grupo de armazenamento de recuperação desabilitada
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para saber se o valor para o atributo msExchMaxRestoreStorageGroups foi modificado. Se o Analisador do Exchange Server detectar que o atributo msExchMaxRestoreStorageGroups foi definido com 0, exibirá um erro.

O atributo msExchMaxRestoreStorageGroups é um atributo binário do objeto Armazenamento de Informações de cada computador do Exchange. Se o atributo msExchMaxRestoreStorageGroups estiver definido como 0, os grupos de amrazenamento de recuperação não poderão ser criados para determinado computador do Exchange.

Esse erro poderá ocorrer se você tiver executado uma atualização no local, do Exchange 2000 Server SP3 para o Exchange Server 2003 SP1, em um Cluster do Windows, em que o servidor virtual do Exchange não estava atualizado com o Exchange Server 2003. Observe que, ocasionalmente, essa situação de atualização no local também pode ocasionar uma falha do Outlook® Mobile Access.

Para corrigir o erro do grupo de armazenamento de recuperação, defina o atributo msExchMaxRestoreStorageGroupscomo 1 para o objeto Armazenamento de Informações de cada computador do Exchange. Os objetos de armazenamento de informações afetados constam na saída do Analisador do Exchange Server. Se você precisar de ajuda para resolver o problema do Outlook Mobile Access, entre em contato com o suporte técnico da Microsoft.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe) ou outro cliente LDAP (Lightweight Directory Access Protocol) versão 3, poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003, do Exchange Server 2007, ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para corrigir o erro do grupo de armazenamento de recuperação

  1. Inicie o ADSI Edit.

  2. Clique duas vezes no contêiner Configuração, expanda CN=Serviços, CN=Microsoft Exchange e CN=<ExchangeOrganizationName>.

  3. Expanda CN=Grupos Administrativos, expanda CN=<AdministrativeGroupName> e CN=Servidores.

  4. No painel de detalhes, clique com o botão direito em CN=InformationStore e clique em Propriedades.

  5. No Editor de Atributo, clique no atributo msExchMaxRestoreStorageGroups e em Editar.

  6. Na caixa Editar Atributo, digite 1.

  7. Clique em Aplicar e em OK.

  8. Feche o ADSI Edit. Reinicie o serviço de Armazenamento de Informações do Microsoft Exchange para efetivar a alteração.

Para obter mais informações sobre como usar a ferramenta LDP, consulte o artigo 260745 da Base de Dados de Conhecimento da Microsoft, "XADM: Usando o Utilitário LDP para Modificar os Atributos de Objeto do Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Para obter mais informações sobre grupos de armazenamento de recuperação do Exchange, consulte os seguintes recursos do Exchange:

  • Usando os grupos de armazenamento de recuperação do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47589).

  • Compreendendo os grupos de armazenamento de recuperação (em inglês) (http://go.microsoft.com/fwlink/?LinkID=80784)


A expiração da replicação para um servidor de pasta pública é não padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-05-25

A ferramenta Microsoft® Exchange Server Analyzer lê o seguinte valor de Registro para determinar se o intervalo em que o armazenamento do Exchange remove itens que excederam o período de retenção teve sua configuração padrão modificada:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<Nome do Servidor>\Public-<GUID de Pasta Pública>\Replication Expiry

Se o Analisador do Exchange Server achar que o valor de Registro Replication Expiry está presente e configurado, uma mensagem de configuração não padrão será exibida.

A expiração de mensagens é o processo usado para expirar as mensagens de pastas públicas que excederam um valor de tempo especificado. O intervalo padrão para a expiração de mensagens é 24 horas.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. Exclua o valor de Registro Replication Expiry.

  4. Reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a replicação de pastas públicas, consulte Trabalhando com o Armazenamento do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595) e o artigo 273479 da Base de Dados de Conhecimento, "Descrição da funcionalidade de referência de pastas públicas no Exchange 2000 Server e no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273479).


O Limite de Idade de Conflito da Pasta Replicação para um armazenamento de pasta pública diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê o seguinte valor de Registro para determinar se o envelhecimento do conflito de pastas teve sua configuração padrão modificada:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>\Replication Folder Conflict Age Limit

Se o Analisador do Exchange Server achar que o valor de Registro Replication Folder Conflict Age Limit está presente e configurado, uma mensagem de configuração não padrão será exibida.

Quando dois usuários editam e modificam a mesma mensagem em uma pasta pública, as mensagens salvas resultantes são definidas como estando em conflito. Essa situação poderá ocorrer quando houver uma gravação simultânea no mesmo servidor de pasta pública, ou se a mensagem for editada em dois servidores que contenham réplicas da pasta. Se nenhuma ação for realizada pelos proprietários da pasta pública no período estabelecido pelo limite de idade de conflito, o conflito será resolvido pelo armazenamento de pasta pública depois que o limite de idade tiver decorrido. O valor do Registro Limite de Idade de Conflito de Pasta de Replicação controla esse limite de idade. Seu valor é o número de dias que itens em conflito são permitidos.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. Exclua o valor de Registro Replication Folder Conflict Age Limit.

  4. Reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre replicação de pasta pública, consulte o artigo 273479 da Base de Dados de Conhecimento, "Compreendendo referências e replicação de pasta pública" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273479).


Valor de Limite de Contagem da Pasta de Replicação alterado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada de Registro a seguir para determinar se a chave Limite de Contagem de Pasta de Replicação foi modificada do valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ <servername> \Public -<GUID do Armazenamento Público> \Limite de Contagem de Pasta de Replicação

Se o Analisador do Exchange Server detectar que o Limite de Contagem de Pasta de Replicação está presente e configurado, uma mensagem de configuração não padrão será exibida.

Por padrão, o Limite de Contagem de Pasta de Replicação não existe. O valor Limite de Contagem de Pasta de Replicação representa o número máximo de pastas a serem empacotadas em uma mensagem de replicação de hierarquia (usada para replicar a hierarquia da árvore de pastas públicas e as propriedades de pastas públicas). O valor deve estar entre 1 e 1000; o valor padrão é 20. Essa chave do Registro não é válida no Exchange Server 2003 e em versões posteriores do Exchange Server.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para redefinir a chave do Registro Limite de Contagem de Pasta de Replicação

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID do Armazenamento Público>

  3. Examine ou edite o valor de Limite de Contagem de Pasta de Replicação.

    O valor para essa entrada de Registro está em quilobytes (KB). Para retornar ao valor padrão, exclua Limite de Contagem de Pasta de Replicação e reinicie o serviço Armazenamento de Informações do Microsoft Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre replicação de pasta pública, consulte "Controlling Exchange Server 2003 Public Folder Replication" em Working with the Exchange Server 2003 Store (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).


Foi alterado o valor de Tempo Limite de RMQ da Árvore da Pasta de Replicação
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar se a chave Tempo limite de RMQ da árvore da pasta de replicação foi modificada com relação ao valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ <servername> \Public -<GUID do Armazenamento Público> \Tempo limite de RMQ da árvore da pasta de replicação

Se o analisador do Exchange Server detectar que Tempo limite de RMQ da árvore da pasta de replicação está presente, uma mensagem de configuração não padrão será exibida.

Por padrão, Tempo limite de RMQ da árvore da pasta de replicação não existe. O Exchange usa mensagens de hierarquia para replicar a hierarquia da árvore de pastas públicas e as propridades de pasta públicas. Depois que o armazenamento de uma pasta pública recebe alterações replicadas, carrega as alterações na memória (filas de mensagens de replicação) para processar. O valor de Tempo limite de RMQ da árvore da pasta de replicação representa o tempo máximo que as alterações de hierarquia replicada permanecem na memória. O valor, em segundos, deve estar entre 3.600 (uma hora) e 2.592.000 (30 dias); o valor padrão é 604.800 (7 dias). As alterações processadas com êxito são prontamente excluídas da memória; caso contrário, as alterações serão mantidas na memória até que possam ser processadas ou até que o tempo limite se esgote, quando elas serão excluídas.

Por exemplo, suponha que uma alteração seja replicada para uma pasta e outra seja replicada para uma subpasta daquela pasta. Dependendo da topologia e do tempo decorrido entre as alterações, elas podem chegar no armazenamento da pasta pública de destino em qualquer ordem. Se a alteração na subpasta chegar primeiro, mas não puder ser processada corretamente até que a alteração na pasta pai tenha sido aplicada, o armazenamento da pasta pública manterá a alteração da subpasta na memória até que a alteração na pasta pai tenha chegado e sido processada. Se o tempo limite se esgotar antes que a alteração na pasta pai seja processada, a alteração na subpasta será excluída da memória. Posteriormente, após o processamento da alteração na pasta pai, o armazenamento da pasta pública poderá receber outra cópia da alteração na subpasta, que poderá ser processada com êxito. Se o armazenamento não receber outra cópia da alteração na subpasta, quando o armazenamento da pasta pública verificar seu status comparado a outros armazenamentos de pasta pública na topologia, notará que sua cópia na árvore da pasta pública não contém a alteração na subpasta e iniciará o processo de aterramento daquela alteração.

Na maioria das circunstâncias, a alteração no Tempo limite de RMQ da árvore da pasta de replicação do valor padrão não é recomendada. Se esse valor tiver sido alterado, pode ter sido temporariamente aumentado durante um período de tráfego intenso de replicação (por exemplo, após a adição de um novo armazenamento de pasta pública).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para redefinir a chave de Registro de Tempo limite de RMQ da árvore da pasta de replicação

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID do Armazenamento Público>

  3. Examine ou edite o valor de Tempo limite de RMQ da árvore da pasta de replicação.

    O valor dessa entrada do Registro está expresso em segundos. Para retornar ao valor padrão, exclua Tempo limite de RMQ da árvore da pasta de replicaçãoe reinicie o serviço de Armazenamento de Informações do Microsoft Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a replicação de pastas públicas, consulte "Controlando a replicação da pasta pública do Exchange Server 2003", em Trabalhando com o Armazenamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


O Limite de Idade Marcar para Exclusão da Pasta de Replicação para um armazenamento de pasta pública é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada de Registro para determinar se o intervalo para remoção de marcadores da pasta pública foi modificado do valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>\Replication Folder Tombstone Age Limit

Se o Exchange Server Analyzer detectar que Replication Folder Tombstone Age Limit está presente no Registro, será exibida uma mensagem de configuração não padrão.

As informações dos marcadores de pastas são usadas pela replicação de pastas públicas. O envelhecimento é necessário para evitar que a lista de marcadores de pastas fique desatualizada. O valor padrão de 180 dias pode ser substituído pelo valor do Registro Replication Folder Tombstone Age Limit.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>

  3. Exclua o valor de Registro Replication Folder Tombstone Age Limit.

  4. Reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro SiteName, consulte o artigo 159196 da Base de Dados de Conhecimento, "XADM: Tarefas controladas pela Agenda de Manutenção IS" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196) (em inglês).


O valor de Longo Atraso na Solicitação de Aterramento de Replicação foi alterado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para detectar se a chave Longo Atraso na Solicitação de Aterramento de Replicação foi modificada do valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<NomeDoServidor> \Public- <GUID do Armazenamento Público> \Longo Atraso na Solicitação de Aterramento de Replicação

Se o Analisador do Exchange Server detectar a presença da chave Longo Atraso na Solicitação de Aterramento de Replicação, será exibida uma mensagem de configuração não padrão.

Por padrão, a chave Longo Atraso na Solicitação de Aterramento de Replicação não existe. O aterramento ocorre quando o armazenamento de uma pasta pública determina que ele não recebeu todas as atualizações da pasta replicada (ou para a hierarquia) e deve recuperar as atualizações ausentes a partir de um outro armazenamento.

Para simplificar o processo de aterramento, o Exchange Server armazena informações sobre atualizações ausentes na matriz de aterramento. A matriz de aterramento armazena essas informações por um período de tempo especificado (chamado tempo limite de aterramento). Se as atualizações ausentes chegarem em mensagens de replicação subseqüentes durante esse período, elas serão removidas da matriz de aterramento. A tabela abaixo lista os valores de tempo limite de aterramento padrão, que dependem de onde há atualizações ausentes e se elas já foram solicitadas antes.

Tipo de solicitação | O conteúdo está em um armazenamento no site local | O conteúdo está em um armazenamento em um site remoto
Aterramento inicial | 6 horas | 12 horas
Primeira repetição de aterramento | 12 horas | 24 horas
Repetições de aterramento subseqüentes | 24 horas | 48 horas

Se o tempo limite de aterramento expirar e as atualizações ainda estiverem ausentes, o Exchange Server 2003 cria uma ou mais solicitações de aterramento e determina quais servidores serão usados como fontes de aterramento.

Para selecionar um servidor (ou servidores) para usar como fonte de aterramento, o Exchange Server 2003 primeiro cria uma lista de todos os servidores que tenham réplicas da pasta e, depois, classifica a lista de acordo com a seqüência de critérios a seguir:

  • Classificação de acordo com o status do servidor Servidores que estejam inativos ou indisponíveis são enviados para o final da lista.

  • Classificação de acordo com o servidor de aterramento preferido Se houver, esse recurso só estará disponível no Exchange Server 2003 ou posterior. O Exchange Server 2003 verifica o objeto de armazenamento da pasta pública no serviço de diretório Active Directory® para obter o servidor de aterramento preferido. Essa configuração raramente é utilizada. Na maioria das circunstâncias, o processo de aterramento operará de forma mais eficiente se o Exchange Server 2003 selecionar um servidor de aterramento automaticamente. A maioria das implantações do Exchange Server 2003 não precisa de um servidor de aterramento preferido. O Atendimento Microsoft pode fornecer um script que defina um servidor de aterramento preferido se isso for exigido por sua implantação.

  • Classificação de acordo com o custo de transporte (do mais baixo para o mais alto) Servidores no mesmo site têm prioridade sobre os servidores em sites remotos. O custo de transporte de um servidor é calculado pelo mecanismo de roteamento do Exchange Server 2003 e normalmente é usado para calcular a forma mais eficiente de entregar uma mensagem. Observe que em versões do Exchange anteriores ao Exchange Server 2003, o custo de transporte tem prioridade menor e só é considerado após a versão do Exchange e o número de alterações disponíveis.

  • Classificação de acordo com a versão do Exchange (da mais nova para a mais antiga)

  • Classificação de acordo com o número de alterações necessárias que estão disponíveis no servidor (do maior para o menor) Servidores que não tiverem nenhuma das alterações ausentes são eliminados da lista.

Se um servidor não tiver todas as alterações necessárias, o Exchange Server 2003 seleciona o próximo servidor na lista de classificação e envia uma solicitação de aterramento para esse servidor também. Esse processo é repetido até que todas as alterações tenham sido solicitadas. Esse recurso só está disponível no Exchange Server 2003 ou posterior; versões anteriores do Exchange enviam solicitações de aterramento para um servidor de cada vez se nenhum servidor específico contiver todas as atualizações ausentes para uma pasta específica. Após cada solicitação, versões anteriores do Exchange aguardam que o tempo de repetição (de 24 a 48 horas) se esgote antes de enviar a próxima solicitação.

Se o servidor selecionado não responder à solicitação de aterramento, o armazenamento marcará esse servidor como inativo e repetirá o processo de seleção. Os servidores marcados como inativos são enviados para o final da lista.

O valor de Longo Atraso na Solicitação de Aterramento de Replicação representa o tempo de retardo de um armazenamento antes de enviar uma solicitação de aterramento de dados não disponíveis no mesmo site do Exchange. O valor, em segundos, deve ser entre 900 e 2592000 (30 dias); o valor padrão é 43200 segundos (12 horas).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para redefinir a chave do Registro Longo Atraso na Solicitação de Aterramento de Replicação

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID de armazenamento público>

  3. Examine ou edite o valor de Longo Atraso na Solicitação de Aterramento de Replicação.

    O valor dessa entrada do Registro está expresso em segundos. Para retornar para o valor padrão, exclua a chave Longo Atraso na Solicitação de Aterramento de Replicação e reinicie o serviço Armazenamento de Informações do Microsoft Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a replicação de pastas públicas, consulte "Controlando a replicação da pasta pública do Exchange Server 2003", em Trabalhando com o Armazenamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


O valor do Tempo Limite Longo na Solicitação de Aterramento de Replicação foi alterado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A Ferramenta do Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar se a chave Tempo Limite Longo na Solicitação de Aterramento de Replicação foi modificada em relação ao valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<NomeDoServidor> \Public -<GUID do Armazenamento Público> \Tempo Limite Longo na Solicitação de Aterramento de Replicação

Se o Exchange Server Analyzer perceber a presença do Tempo Limite Longo na Solicitação de Aterramento de Replicação, uma mensagem de configuração não-padrão será exibida.

Por padrão, Tempo Limite Longo na Solicitação de Aterramento de Replicação não existe. O aterramento ocorre quando o armazenamento de uma pasta pública determina que ele não recebeu todas as atualizações da pasta replicada (ou para a hierarquia) e deve recuperar as atualizações ausentes a partir de um outro armazenamento.

Para simplificar o processo de aterramento, o Exchange Server armazena informações sobre atualizações ausentes na matriz de aterramento. A matriz de aterramento armazena essas informações por um período de tempo especificado (chamado tempo limite de aterramento). Se as atualizações ausentes chegarem em mensagens de replicação subseqüentes durante esse período, elas serão removidas da matriz de aterramento. A tabela abaixo lista os valores de tempo limite de aterramento padrão, que dependem de onde há atualizações ausentes e se elas já foram solicitadas antes.

Tipo de solicitação | O conteúdo está em um armazenamento no site local | O conteúdo está em um armazenamento em um site remoto
Aterramento inicial | 6 horas | 12 horas
Primeira repetição de aterramento | 12 horas | 24 horas
Repetições de aterramento subseqüentes | 24 horas | 48 horas

Se o tempo limite de aterramento expirar e as atualizações ainda estiverem ausentes, o Exchange Server 2003 cria uma ou mais solicitações de aterramento e determina quais servidores serão usados como fontes de aterramento.

Para selecionar um servidor (ou servidores) para usar como fonte de aterramento, o Exchange Server 2003 primeiro cria uma lista de todos os servidores que tenham réplicas da pasta e, depois, classifica a lista de acordo com a seqüência de critérios a seguir:

  • Classificação de acordo com o status do servidor Servidores que estejam inativos ou indisponíveis são enviados para o final da lista.

  • Classificação de acordo com o servidor de aterramento preferido Se houver, esse recurso só estará disponível no Exchange Server 2003 ou posterior. O Exchange Server 2003 verifica o objeto de armazenamento da pasta pública no serviço de diretório Active Directory® para obter o servidor de aterramento preferido. Essa configuração raramente é utilizada. Na maioria das circunstâncias, o processo de aterramento operará de forma mais eficiente se o Exchange Server 2003 selecionar um servidor de aterramento automaticamente. A maioria das implantações do Exchange Server 2003 não precisa de um servidor de aterramento preferido. O Atendimento Microsoft pode fornecer um script que defina um servidor de aterramento preferido se isso for exigido por sua implantação.

  • Classificação de acordo com o custo de transporte (do mais baixo para o mais alto) Servidores no mesmo site têm prioridade sobre os servidores em sites remotos. O custo de transporte de um servidor é calculado pelo mecanismo de roteamento do Exchange Server 2003 e normalmente é usado para calcular a forma mais eficiente de entregar uma mensagem. Observe que em versões do Exchange anteriores ao Exchange Server 2003, o custo de transporte tem prioridade menor e só é considerado após a versão do Exchange e o número de alterações disponíveis.

  • Classificação de acordo com a versão do Exchange (da mais nova para a mais antiga)

  • Classificação de acordo com o número de alterações necessárias que estão disponíveis no servidor (do maior para o menor) Servidores que não tiverem nenhuma das alterações ausentes são eliminados da lista.

Se um servidor não tiver todas as alterações necessárias, o Exchange Server 2003 seleciona o próximo servidor na lista de classificação e envia uma solicitação de aterramento para esse servidor também. Esse processo é repetido até que todas as alterações tenham sido solicitadas. Esse recurso só está disponível no Exchange Server 2003 ou posterior; versões anteriores do Exchange enviam solicitações de aterramento para um servidor de cada vez se nenhum servidor específico contiver todas as atualizações ausentes para uma pasta específica. Após cada solicitação, versões anteriores do Exchange aguardam que o tempo de repetição (de 24 a 48 horas) se esgote antes de enviar a próxima solicitação.

Se o servidor selecionado não responder à solicitação de aterramento, o armazenamento marcará esse servidor como inativo e repetirá o processo de seleção. Os servidores marcados como inativos são enviados para o final da lista.

O valor de Tempo Limite Longo na Solicitação de Aterramento de Replicação representa o valor de tempo limite que o armazenamento de pasta pública usa ao tentar enviar uma solicitação de aterramento para dados que não estão disponíveis no mesmo site do Exchange. O valor, em segundos, deve ser entre 900 e 2592000 (30 dias); o valor padrão é 86400 segundos (24 horas).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para redefinir a chave do Registro Tempo Limite Longo na Solicitação de Aterramento de Replicação

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID do Armazenamento Público>

  3. Examine ou edite o valor de Tempo Limite Longo na Solicitação de Aterramento de Replicação.

    O valor dessa entrada do Registro está expresso em segundos. Para retornar o valor padrão, você deve excluir Tempo Limite Longo na Solicitação de Aterramento de Replicação e reiniciar o serviço de Armazenamento de Informações do Microsoft Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre replicação de pasta pública, consulte "Controlling Exchange Server 2003 Public Folder Replication" em Working with the Exchange Server 2003 Store (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).


O valor da Repetição do Tempo Limite Longo na Solicitação de Aterramento de Replicação foi alterado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a entrada de Registro a seguir para determinar se a chave Repetição do Tempo Limite Longo na Solicitação de Aterramento de Replicação foi modificada do valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<NomeDoServidor> \Public- <GUID do Armazenamento Público> \Replication Long Backfill Request Timeout Retry

Se o Exchange Server Analyzer detectar que Repetição do Tempo Limite Longo na Solicitação de Aterramento de Replicação precisa estar presente, uma mensagem de configuração não padrão será exibida.

Por padrão, Repetição do Tempo Limite Longo na Solicitação de Aterramento de Replicação não existe. O aterramento ocorre quando o armazenamento de uma pasta pública determina que ele não recebeu todas as atualizações da pasta replicada (ou para a hierarquia) e deve recuperar as atualizações ausentes a partir de um outro armazenamento.

Para simplificar o processo de aterramento, o Exchange Server armazena informações sobre atualizações ausentes na matriz de aterramento. A matriz de aterramento armazena essas informações por um período de tempo especificado (chamado tempo limite de aterramento). Se as atualizações ausentes chegarem em mensagens de replicação subseqüentes durante esse período, elas serão removidas da matriz de aterramento. A tabela lista os valores de tempo limite de aterramento padrão, que dependem de onde estão as atualizações ausentes e se elas já foram solicitadas antes.

Tipo de solicitação | O conteúdo está em um armazenamento no site local | O conteúdo está em um armazenamento em um site remoto
Aterramento inicial | 6 horas | 12 horas
Primeira repetição de aterramento | 12 horas | 24 horas
Repetições de aterramento subseqüentes | 24 horas | 48 horas

Se o tempo limite de aterramento expirar e as atualizações ainda estiverem ausentes, o Exchange Server 2003 cria uma ou mais solicitações de aterramento e determina quais servidores serão usados como fontes de aterramento.

Para selecionar um servidor (ou servidores) para usar como fonte de aterramento, o Exchange Server 2003 primeiro cria uma lista de todos os servidores que tenham réplicas da pasta e, depois, classifica a lista de acordo com a seqüência de critérios a seguir:

  • Classificação de acordo com o status do servidor Servidores que estejam inativos ou indisponíveis são enviados para o final da lista.

  • Classificação de acordo com o servidor de aterramento preferido Se houver, esse recurso só estará disponível no Exchange Server 2003 ou posterior. O Exchange Server 2003 verifica o objeto de armazenamento da pasta pública no serviço de diretório Active Directory® para obter o servidor de aterramento preferido. Essa configuração raramente é utilizada. Na maioria das circunstâncias, o processo de aterramento operará de forma mais eficiente se o Exchange Server 2003 selecionar um servidor de aterramento automaticamente. A maioria das implantações do Exchange Server 2003 não precisa de um servidor de aterramento preferido. O Atendimento Microsoft pode fornecer um script que defina um servidor de aterramento preferido se isso for exigido por sua implantação.

  • Classificação de acordo com o custo de transporte (do mais baixo para o mais alto) Servidores no mesmo site têm prioridade sobre os servidores em sites remotos. O custo de transporte de um servidor é calculado pelo mecanismo de roteamento do Exchange Server 2003 e normalmente é usado para calcular a forma mais eficiente de entregar uma mensagem. Observe que em versões do Exchange anteriores ao Exchange Server 2003, o custo de transporte tem prioridade menor e só é considerado após a versão do Exchange e o número de alterações disponíveis.

  • Classificação de acordo com a versão do Exchange (da mais nova para a mais antiga)

  • Classificação de acordo com o número de alterações necessárias que estão disponíveis no servidor (do maior para o menor) Servidores que não tiverem nenhuma das alterações ausentes são eliminados da lista.

Se um servidor não tiver todas as alterações exigidas, o Exchange Server 2003 selecionará o próximo servidor na lista de classificação e envia uma solicitação de aterramento para esse servidor também. Esse processo é repetido até que todas as alterações tenham sido solicitadas. Esse recurso só está disponível no Exchange Server 2003 ou posterior; versões anteriores do Exchange enviam solicitações de aterramento para um servidor de cada vez se nenhum servidor específico contiver todas as atualizações ausentes para uma pasta específica. Após cada solicitação, versões anteriores do Exchange aguardam que o tempo de repetição (de 24 a 48 horas) se esgote antes de enviar a próxima solicitação.

Se o servidor selecionado não responder à solicitação de aterramento, o armazenamento marcará esse servidor como inativo e repetirá o processo de seleção. Os servidores marcados como inativos são enviados para o final da lista.

O valor Repetição do Tempo Limite Longo na Solicitação de Aterramento de Replicação representa o valor do tempo limite que o armazenamento de pasta pública usa quando envia uma solicitação de aterramento para dados que não estão disponíveis no mesmo site do Exchange e quando essa solicitação é uma repetição da solicitação de aterramento anterior. O valor, em segundos, deve ser entre 900 e 2592000 (30 dias); o valor padrão é 172800 segundos (48 horas).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para redefinir a chave de Registro Repetição do tempo limite longo na solicitação de aterramento de replicação

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID do Armazenamento Público>

  3. Examine ou edite o valor de Repetição do Tempo Limite Longo na Solicitação de Aterramento de Replicação.

    O valor dessa entrada do Registro está expresso em segundos. Para retornar o valor padrão, exclua Repetição do tempo limite longo na solicitação de aterramento de replicação e reinicie o serviço Armazenamento de Informações do Microsoft Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre replicação de pasta pública, consulte "Controlling Exchange Server 2003 Public Folder Replication" em Working with the Exchange Server 2003 Store (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).


As mensagens de replicação na inicialização foram habilitadas
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o Exchange foi configurado para gerar as mensagens de solicitação de status para a hierarquia da pasta pública:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server name>\Public-<Public Information Store GUID>\Enable Replication Messages At Startup

Se o Exchange Server Analyzer detectar que a entrada do Registro Ativar a Replicação de Mensagens na Inicialização está presente e configurada, uma mensagem de configuração não padrão será exibida.

No Exchange Server 5.5, cada computador que possui um armazenamento de pasta pública envia uma mensagem noturna de solicitação de status, para determinar o status da hierarquia da pasta pública. O Exchange 2000 Server e o Exchange Server 2003 não fazem isso. Em geral, no Exchange 2000 Server e no Exchange Server 2003, a mensagem de solicitação de status é enviada apenas uma vez durante o ciclo de vida de armazenamento da pasta pública; ela é enviada quando o armazenamento é criado.

No entanto, em determinadas circunstâncias, pode ser necessário gerar uma mensagem de solicitação de status. Por exemplo, se a hierarquia da pasta pública no computador do Exchange 2000 Server ou no Exchange Server 2003 não parecer replicar, ou a hierarquia da pasta pública replicar muito lentamente, a geração de uma mensagem de solicitação de status pode permitir que a replicação da hierarquia da pasta pública continue. Os problemas com a replicação da hierarquia da pasta pública podem ocorrer se a mensagem de solicitação de status original, enviada quando o armazenamento da pasta pública foi criado, foi eliminada e nunca reconhecida ou se a mensagem foi enviada a um servidor com uma hierarquia significativamente incompleta.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para exibir ou modificar o valor do Registro Aging Keep Time

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nome do servidor>\Public-<GUID de Armazenamento de Informações Públicas>

  3. Examine ou, se desejar, altere o valor de Ativar as Mensagens de Replicação na Inicialização. Esse valor REG_DWORD deve ser configurado como 1 para ser efetivado. Se você configurar o valor como 0 (a configuração padrão), nenhuma mensagem de solicitação de status será enviada quando o armazenamento de informações públicas iniciar.

  4. Se uma alteração for feita, feche o editor do Registro e desmonte e remonte o armazenamento de informações públicas para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre as mensagens de status de replicação da pasta pública e o valor do Registro Ativar as Mensagens de Replicação na Inicialização, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 321082, "XADM: Como enviar mensagens de solicitação de status de replicação no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321082)

  • 842273, "Como solucionar problemas de replicação de pasta pública no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273)


O valor do Pequeno Atraso na Solicitação de Aterramento de Replicação foi alterado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar se a chave Pequeno Atraso na Solicitação de Aterramento de Replicação foi modificada com relação ao valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<NomeDoServidor> \Public -<GUID do Armazenamento Público> \Pequeno Atraso na Solicitação de Aterramento de Replicação

Se o Analisador do Exchange Server detectar que Pequeno Atraso na Solicitação de Aterramento de Replicação está presente, uma mensagem de configuração não padrão será exibida.

Por padrão, Pequeno Atraso na Solicitação de Aterramento de Replicação não existe. O aterramento ocorre quando o armazenamento de uma pasta pública determina que ele não recebeu todas as atualizações da pasta replicada (ou para a hierarquia) e deve recuperar as atualizações ausentes a partir de um outro armazenamento.

Para simplificar o processo de aterramento, o Exchange Server armazena informações sobre atualizações ausentes na matriz de aterramento. A matriz de aterramento armazena essas informações por um período de tempo especificado (chamado tempo limite de aterramento). Se as atualizações ausentes chegarem em mensagens de replicação subseqüentes durante esse período, elas serão removidas da matriz de aterramento. A tabela lista os valores de tempo limite de aterramento padrão, que dependem de onde estão as atualizações ausentes e se elas já foram solicitadas antes.

Tipo de solicitação | O conteúdo está em um armazenamento no site local | O conteúdo está em um armazenamento em um site remoto
Aterramento inicial | 6 horas | 12 horas
Primeira repetição de aterramento | 12 horas | 24 horas
Repetições de aterramento subseqüentes | 24 horas | 48 horas

Se o tempo limite de aterramento expirar e as atualizações ainda estiverem ausentes, o Exchange Server 2003 cria uma ou mais solicitações de aterramento e determina quais servidores serão usados como fontes de aterramento.

Para selecionar um servidor (ou servidores) a ser usado como origem do aterramento, o Exchange Server 2003 primeiramente cria uma lista de todos os servidores que tenham réplicas da pasta e, em seguida, classifica a lista de acordo com a seguinte seqüência de critérios:

  • Classificação de acordo com o status do servidor Servidores que estejam inativos ou indisponíveis são enviados para o final da lista.

  • Classificação de acordo com o servidor de aterramento preferido Se houver, esse recurso só estará disponível no Exchange Server 2003 ou posterior. O Exchange Server 2003 verifica o objeto de armazenamento da pasta pública no serviço de diretório Active Directory® para obter o servidor de aterramento preferido. Essa configuração raramente é utilizada. Na maioria das circunstâncias, o processo de aterramento operará de forma mais eficiente se o Exchange Server 2003 selecionar um servidor de aterramento automaticamente. A maioria das implantações do Exchange Server 2003 não precisa de um servidor de aterramento preferido. O Atendimento Microsoft pode fornecer um script que defina um servidor de aterramento preferido se isso for exigido por sua implantação.

  • Classificação de acordo com o custo de transporte (do mais baixo para o mais alto) Servidores no mesmo site têm prioridade sobre os servidores em sites remotos. O custo de transporte de um servidor é calculado pelo mecanismo de roteamento do Exchange Server 2003 e normalmente é usado para calcular a forma mais eficiente de entregar uma mensagem. Observe que em versões do Exchange anteriores ao Exchange Server 2003, o custo de transporte tem prioridade menor e só é considerado após a versão do Exchange e o número de alterações disponíveis.

  • Classificação de acordo com a versão do Exchange (da mais nova para a mais antiga)

  • Classificação de acordo com o número de alterações necessárias que estão disponíveis no servidor (do maior para o menor) Servidores que não tiverem nenhuma das alterações ausentes são eliminados da lista.

Se um servidor não tiver todas as alterações necessárias, o Exchange Server 2003 seleciona o próximo servidor na lista de classificação e envia uma solicitação de aterramento para esse servidor também. Esse processo é repetido até que todas as alterações tenham sido solicitadas. Esse recurso só está disponível no Exchange Server 2003 ou posterior; versões anteriores do Exchange enviam solicitações de aterramento para um servidor de cada vez se nenhum servidor específico contiver todas as atualizações ausentes para uma pasta específica. Após cada solicitação, versões anteriores do Exchange aguardam que o tempo de repetição (de 24 a 48 horas) se esgote antes de enviar a próxima solicitação.

Se o servidor selecionado não responder à solicitação de aterramento, o armazenamento marcará esse servidor como inativo e repetirá o processo de seleção. Os servidores marcados como inativos são enviados para o final da lista.

O valor Pequeno Atraso na Solicitação de Aterramento de Replicação representa o período de tempo que o armazenamento de pasta pública atrasa antes de enviar uma solicitação de aterramento para dados que estão disponíveis no mesmo site do Exchange. O valor, em segundos, deve ser entre 900 e 2592000 (30 dias); o valor padrão é 21600 segundos (6 horas).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para redefinir a chave de Registro Pequeno Atraso na Solicitação de Aterramento de Replicação

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID do Armazenamento Público>

  3. Examine ou edite o valor de Pequeno Atraso na Solicitação de Aterramento de Replicação.

    O valor dessa entrada do Registro está expresso em segundos. Para retornar ao valor padrão, exclua Pequeno Atraso na Solicitação de Aterramento de Replicaçãoe reinicie o serviço de Armazenamento de Informações do Microsoft Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre replicação de pasta pública, consulte "Controlling Exchange Server 2003 Public Folder Replication" em Working with the Exchange Server 2003 Store (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).


O valor do Tempo Limite Curto na Solicitação de Aterramento de Replicação foi alterado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se a chave Tempo Limite Curto na Solicitação de Aterramento de Replicação foi modificada do valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ <servername> \Public -<GUID do Armazenamento Público> \Tempo Limite Curto na Solicitação de Aterramento de Replicação

Se o Exchange Server Analyzer detectar a presença de Tempo Limite Curto na Solicitação de Aterramento de Replicação, será exibida uma mensagem de configuração não-padrão.

Por padrão, a chave Tempo Limite Curto na Solicitação de Aterramento de Replicação não existe. O aterramento ocorre quando o armazenamento de uma pasta pública determina que ele não recebeu todas as atualizações da pasta replicada (ou para a hierarquia) e deve recuperar as atualizações ausentes a partir de um outro armazenamento.

Para simplificar o processo de aterramento, o Exchange Server armazena informações sobre atualizações ausentes na matriz de aterramento. A matriz de aterramento armazena essas informações por um período de tempo especificado (chamado tempo limite de aterramento). Se as atualizações ausentes chegarem em mensagens de replicação subseqüentes durante esse período, elas serão removidas da matriz de aterramento. A tabela abaixo lista os valores de tempo limite de aterramento padrão, que dependem de onde há atualizações ausentes e se elas já foram solicitadas antes.

Tipo de solicitação | O conteúdo está em um armazenamento no site local | O conteúdo está em um armazenamento em um site remoto
Aterramento inicial | 6 horas | 12 horas
Primeira repetição de aterramento | 12 horas | 24 horas
Repetições de aterramento subseqüentes | 24 horas | 48 horas

Se o tempo limite de aterramento expirar e as atualizações ainda estiverem ausentes, o Exchange Server 2003 cria uma ou mais solicitações de aterramento e determina quais servidores serão usados como fontes de aterramento.

Para selecionar um servidor (ou servidores) para usar como fonte de aterramento, o Exchange Server 2003 primeiro cria uma lista de todos os servidores que tenham réplicas da pasta e, depois, classifica a lista de acordo com a seqüência de critérios a seguir:

  • Classificação de acordo com o status do servidor Servidores que estejam inativos ou indisponíveis são enviados para o final da lista.

  • Classificação de acordo com o servidor de aterramento preferido Se houver, esse recurso só estará disponível no Exchange Server 2003 ou posterior. O Exchange Server 2003 verifica o objeto de armazenamento da pasta pública no serviço de diretório Active Directory® para obter o servidor de aterramento preferido. Essa configuração raramente é utilizada. Na maioria das circunstâncias, o processo de aterramento operará de forma mais eficiente se o Exchange Server 2003 selecionar um servidor de aterramento automaticamente. A maioria das implantações do Exchange Server 2003 não precisa de um servidor de aterramento preferido. O Atendimento Microsoft pode fornecer um script que defina um servidor de aterramento preferido se isso for exigido por sua implantação.

  • Classificação de acordo com o custo de transporte (do mais baixo para o mais alto) Servidores no mesmo site têm prioridade sobre os servidores em sites remotos. O custo de transporte de um servidor é calculado pelo mecanismo de roteamento do Exchange Server 2003 e normalmente é usado para calcular a forma mais eficiente de entregar uma mensagem. Observe que em versões do Exchange anteriores ao Exchange Server 2003, o custo de transporte tem prioridade menor e só é considerado após a versão do Exchange e o número de alterações disponíveis.

  • Classificação de acordo com a versão do Exchange (da mais nova para a mais antiga)

  • Classificação de acordo com o número de alterações necessárias que estão disponíveis no servidor (do maior para o menor) Servidores que não tiverem nenhuma das alterações ausentes são eliminados da lista.

Se um servidor não tiver todas as alterações necessárias, o Exchange Server 2003 seleciona o próximo servidor na lista de classificação e envia uma solicitação de aterramento para esse servidor também. Esse processo é repetido até que todas as alterações tenham sido solicitadas. Esse recurso só está disponível no Exchange Server 2003 ou posterior; versões anteriores do Exchange enviam solicitações de aterramento para um servidor de cada vez se nenhum servidor específico contiver todas as atualizações ausentes para uma pasta específica. Após cada solicitação, versões anteriores do Exchange aguardam que o tempo de repetição (de 24 a 48 horas) se esgote antes de enviar a próxima solicitação.

Se o servidor selecionado não responder à solicitação de aterramento, o armazenamento marcará esse servidor como inativo e repetirá o processo de seleção. Os servidores marcados como inativos são enviados para o final da lista.

O valor de Tempo Limite Curto na Solicitação de Aterramento de Replicação representa o valor do tempo limite usado por uma pasta pública ao tentar enviar uma solicitação de aterramento para dados disponíveis no mesmo site do Exchange. O valor, em segundos, deve ser entre 900 e 2592000 (30 dias); o valor padrão é 43200 segundos (12 horas).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para redefinir a chave do Registro Tempo Limite Curto na Solicitação de Aterramento de Replicação

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID do Armazenamento Público>

  3. Examine ou edite o valor de Tempo Limite Curto na Solicitação de Aterramento de Replicação.

    O valor dessa entrada do Registro está expresso em segundos. Para retornar ao valor padrão, exclua a chave Tempo Limite Curto na Solicitação de Aterramento de Replicação e reinicie o serviço Armazenamento de Informações do Microsoft Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre replicação de pasta pública, consulte "Controlling Exchange Server 2003 Public Folder Replication" em Working with the Exchange Server 2003 Store (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).


Valor de Tempo Limite Curto na Solicitação de Aterramento de Replicação alterado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada de Registro para determinar se a chave Tempo Limite Curto na Solicitação de Aterramento de Replicação teve seu valor padrão modificado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<NomeDoServidor> \Public -<GUID do Armazenamento Público> \Tempo Limite Curto na Solicitação de Aterramento de Replicação

Se o Exchange Server Analyzer verificar que Tempo Limite Curto na Solicitação de Aterramento de Replicação estiver presente, uma mensagem de configuração não padrão será exibida.

Por padrão, Repetição de Tempo Limite Curto na Solicitação de Aterramento de Replicação não existe. O aterramento ocorre quando o armazenamento de uma pasta pública determina que ele não recebeu todas as atualizações da pasta replicada (ou para a hierarquia) e deve recuperar as atualizações ausentes a partir de um outro armazenamento.

Para simplificar o processo de aterramento, o Exchange Server armazena informações sobre atualizações ausentes na matriz de aterramento. A matriz de aterramento armazena essas informações por um período de tempo especificado (chamado tempo limite de aterramento). Se as atualizações ausentes chegarem em mensagens de replicação subseqüentes durante esse período, elas serão removidas da matriz de aterramento. A tabela abaixo lista os valores de tempo limite de aterramento padrão, que dependem de onde há atualizações ausentes e se elas já foram solicitadas antes.

Tipo de solicitação | O conteúdo está em um armazenamento no site local | O conteúdo está em um armazenamento em um site remoto
Aterramento inicial | 6 horas | 12 horas
Primeira repetição de aterramento | 12 horas | 24 horas
Repetições de aterramento subseqüentes | 24 horas | 48 horas

Se o tempo limite de aterramento expirar e as atualizações ainda estiverem ausentes, o Exchange Server 2003 cria uma ou mais solicitações de aterramento e determina quais servidores serão usados como fontes de aterramento.

Para selecionar um servidor (ou servidores) para usar como fonte de aterramento, o Exchange Server 2003 primeiro cria uma lista de todos os servidores que tenham réplicas da pasta e, depois, classifica a lista de acordo com a seqüência de critérios a seguir:

  • Classificação de acordo com o status do servidor Servidores que estejam inativos ou indisponíveis são enviados para o final da lista.

  • Classificação de acordo com o servidor de aterramento preferido Se houver, esse recurso só estará disponível no Exchange Server 2003 ou posterior. O Exchange Server 2003 verifica o objeto de armazenamento da pasta pública no serviço de diretório Active Directory® para obter o servidor de aterramento preferido. Essa configuração raramente é utilizada. Na maioria das circunstâncias, o processo de aterramento operará de forma mais eficiente se o Exchange Server 2003 selecionar um servidor de aterramento automaticamente. A maioria das implantações do Exchange Server 2003 não precisa de um servidor de aterramento preferido. O Atendimento Microsoft pode fornecer um script que defina um servidor de aterramento preferido se isso for exigido por sua implantação.

  • Classificação de acordo com o custo de transporte (do mais baixo para o mais alto) Servidores no mesmo site têm prioridade sobre os servidores em sites remotos. O custo de transporte de um servidor é calculado pelo mecanismo de roteamento do Exchange Server 2003 e normalmente é usado para calcular a forma mais eficiente de entregar uma mensagem. Observe que em versões do Exchange anteriores ao Exchange Server 2003, o custo de transporte tem prioridade menor e só é considerado após a versão do Exchange e o número de alterações disponíveis.

  • Classificação de acordo com a versão do Exchange (da mais nova para a mais antiga)

  • Classificação de acordo com o número de alterações necessárias que estão disponíveis no servidor (do maior para o menor) Servidores que não tiverem nenhuma das alterações ausentes são eliminados da lista.

Se um servidor não tiver todas as alterações exigidas, o Exchange Server 2003 selecionará o próximo servidor na lista de classificação e envia uma solicitação de aterramento para esse servidor também. Esse processo é repetido até que todas as alterações tenham sido solicitadas. Esse recurso só está disponível no Exchange Server 2003 ou posterior; versões anteriores do Exchange enviam solicitações de aterramento para um servidor de cada vez se nenhum servidor específico contiver todas as atualizações ausentes para uma pasta específica. Após cada solicitação, versões anteriores do Exchange aguardam que o tempo de repetição (de 24 a 48 horas) se esgote antes de enviar a próxima solicitação.

Se o servidor selecionado não responder à solicitação de aterramento, o armazenamento marcará esse servidor como inativo e repetirá o processo de seleção. Os servidores marcados como inativos são enviados para o final da lista.

O valor Repetição de Tempo Limite Curto na Solicitação de Aterramento de Replicação representa o valor de tempo limite que o armazenamento de pasta pública usa ao enviar uma solicitação de aterramento para dados disponíveis no mesmo site do Exchange, e quando essa solicitação é uma repetição de uma solicitação de aterramento anterior. O valor, em segundos, deve ser entre 900 e 2592000 (30 dias); o valor padrão é 86400 segundos (24 horas).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para redefinir a chave de Registro Repetição de Tempo Limite Curto na Solicitação de Aterramento de Replicação

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID do Armazenamento Público>

  3. Examine ou edite o valor de Repetição de Tempo Limite Curto na Solicitação de Aterramento de Replicação.

    O valor dessa entrada do Registro está expresso em segundos. Para retornar ao valor padrão, você deve excluir Repetição de Tempo Limite Curto na Solicitação de Aterramento de Replicação e reiniciar o serviço Armazenamento de Informações do Microsoft Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre replicação de pasta pública, consulte "Controlling Exchange Server 2003 Public Folder Replication" em Working with the Exchange Server 2003 Store (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47595).


Tamanho do incremento da reserva definido
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-30

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o valor de Reserve Increment KB foi definido: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber de todos os objetos da classe msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 5.5", o computador estará executando o Microsoft Exchange Server 5.5. Se o valor da cadeia de caracteres incluir "Version 6.0", o computador estará executando o Microsoft Exchange 2000 Server. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador estará executando o Microsoft Exchange Server 2003; se incluir "Version 8.0", estará executando o Microsoft Exchange Server 2007.

Se o Exchange Server Analyzer detectar que o valor do Registro Reserve Increment KB existe em um computador que esteja executando o Exchange Server 2003, será exibida uma mensagem de configuração não-padrão.

O valor do Registro Reserve Increment KB substitui o valor do heap de memória nativo no Microsoft Windows®. O Windows inclui um gerenciador de heap em todo o processo que manipula as operações da memória para todos os processos. Sempre que um processo é instanciado, um heap padrão (chamado de heap de processo) é criado para esse processo. Os programas ou módulos carregados no processo também podem criar heaps adicionais, se necessários. O serviço Armazenamento de Informações do Microsoft Exchange, Store.exe, é um exemplo de processo que cria heaps adicionais quando necessários. Por padrão, o Store.exe define a memória inicial reservada para o espaço de heap como 20% da RAM física. O valor de Reserve Increment KB altera a reserva de memória inicial para heap para 10% da memória física.

O valor do Registro Reserve Increment KB só é útil para casos restritos. Além disso, esse valor só deve ser definido por recomendação e orientação do Atendimento Microsoft. Uma configuração incorreta ou o uso inadequado desse valor poderá resultar em desempenho reduzido e acelerar a fragmentação da memória virtual. Se esse valor foi definido sem consultar o Atendimento Microsoft, experimente removê-lo com o procedimento descrito a seguir.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel da direita, exclua o valor de Reserve Increment KB.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre como ajustar o Exchange Server 2003, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 325044, "COMO FAZER PARA: Solucionar problemas de fragmentação da memória virtual no Exchange 2003 e no Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372, "Como otimizar o uso da memória no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)


A compactação de buffer RPC está desabilitada
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a chave do Registro a seguir para determinar se a compactação de buffer de RPC (chamada de procedimento remoto) foi desabilitada.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Packing Enabled

Se o Exchange Server Analyzer detectar que os dados de valor da chave do Registro Rpc Packing Enabled foram definidos como 0, o Exchange Server Analyzer exibirá uma mensagem de configuração não padrão. A chave do Registro Rpc Packing Enabled é desabilitada quando seus dados de valor são definidos como 0.

Os dados de valor da chave Rpc Packing Enabled são uma das três entradas do Registro que os administradores podem acrescentar para configurar a compactação RPC entre o Microsoft Office Outlook® 2003 e o Exchange Server 2003.

O Outlook 2003 pode solicitar um buffer de dados de 96 KB. Porém, depois que o Exchange Server 2003 compactar os dados, o buffer de dados poderá ser significativamente menor do que a quantidade solicitada pelo Outlook 2003.

O Exchange Server 2003 tem suporte para compactação de buffer para aceitar várias taxas de compactação e manter os buffers cheios para maior eficiência.

Quando a chave do Registro Rpc Packing Enabled é habilitada, o Exchange Server 2003 continua a adicionar dados compactados ao buffer até enchê-lo. Para cada solicitação de dados, o Outlook 2003 pode baixar muito mais dados do que as versões anteriores do Outlook 2003, pelos seguintes motivos:

  • O Outlook 2003 solicita tamanhos de buffer maiores.

  • O Exchange Server 2003 tem suporte para compactação de buffer.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária. No entanto, você pode excluir a chave de Registro Rpc Packing Enabled se desejar restaurar a configuração padrão. Você também pode definir o valor de dados da chave do Registro Rpc Packing Enabled como 1, para habilitar a compactação de buffer de RPC.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para restaurar a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

    • Para excluir a entrada, exclua o valor Compactação RPC Habilitada.

    • Para preservar a entrada e habilitar a compactação de buffer RPC, clique duas vezes em Compactação RPC Habilitada, defina o valor como 1 e clique em OK.

  3. Feche o editor de Registro.

O serviço Armazenamento de Informações do Microsoft Exchange detecta as alterações em minutos. Não é necessário reiniciar o computador.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como definir chaves de Registro para configurar a compactação RPC entre clientes Outlook e o Exchange Server 2003, consulte o artigo 825371 da Base de Dados de Conhecimento, "Modificar Compactação de Chamada de Procedimento Remoto no Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371).


O Tamanho Mínimo da Compactação RPC é não padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Microsoft® Exchange Server Analyzer lê a entrada do Registro a seguir para determinar o tamanho mínimo de pacote para compactação de RPC (chamada de procedimento remoto).

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Compression Minimum Size

Se o Exchange Server Analyzer perceber que o valor de Rpc Compression Minimum Size é maior que 0, uma mensagem de configuração não padrão será exibida.

Por padrão, todos os dados RPC movidos entre o Microsoft Office Outlook® 2003 ou o Outlook 2007 e o Exchange Server 2003 ou o Exchange Server 2007 são compactados, independentemente do seu tamanho. Em alguns cenários, convém controlar a compactação RPC. Por exemplo, se você estiver tentando solucionar problemas de conectividade, exibindo os pacotes enviados pela rede, a compactação RPC pode dificultar o processo de análise, uma vez que você só vê os dados compactados no rastreamento.

Para configurar definições de compactação RPC, você pode adicionar três valores de chave de Registro às definições do sistema:

  • Tamanho Mínimo da Compactação RPC

  • Compactação RPC Habilitada

  • Empacotamento RPC Habilitado

O valor do Registro Rpc Compression Minimum Size determina o número mínimo de bytes exigidos para o pacote RPC antes da ativação da compactação. Se essa chave não estiver presente, será usado um valor padrão de 1.024 bytes.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Exclua a chave Rpc Compression Minimum Size. Se as chaves Rpc Compression Enabled e Rpc Packing Enabled estiverem presentes, exclua-as também.

  4. Feche o editor de Registro e reinicie o servidor Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como controlar a compactação de RPC, consulte o artigo 825371 da Base de Dados de Conhecimento, "Modificar a compactação de chamada de procedimento remoto no Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371).


O parâmetro RpcEtwTracing é não-padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte chave de Registro para determinar os dados do valor:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\RpcEtwTracing

Se o Exchange Server Analyzer detectar que os dados do valor da chave de Registro RpcEtwTracing estão definidos como 1, ele exibirá uma mensagem de configuração diferente do padrão.

Você usa os dados do valor para a chave de Registro RpcEtwTracing somente para solucionar problemas de rede entre o Microsoft Office Outlook® 2003 e o Exchange Server. Será recomendável desabilitar a chave de Registro RpcEtwTracing se você não estiver solucionando um problema no momento.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária. No entanto, você pode excluir a chave de Registro RpcEtwTracing se desejar restaurar a configuração padrão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para restaurar a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Exclua o valor de RpcEtwTracing.

  4. Feche o editor de Registro.

O serviço Armazenamento de Informações do Microsoft Exchange detecta as alterações em minutos. Não é necessário reiniciar o computador.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O servidor tem menos de quatro grupos de armazenamento, mas mais de quatro armazenamentos de caixas de correio definidos
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para contar o número de objetos StorageGroup e MailboxGroup existentes em um servidor que esteja executando o Exchange Server 2003. Se o Exchange Server Analyzer determinar que o número total de objetos StorageGroup é menor que quatro e o número total de objetos MailboxStore é maior que quatro, será exibido um erro.

Se você estiver usando o Exchange Server 2003 Standard Edition, cada computador do Exchange Server poderá ter um grupo de armazenamento, o qual oferece suporte a um armazenamento de caixa de correio e um armazenamento de pasta pública. Se estiver usando o Exchange Server 2003 Enterprise Edition, cada servidor poderá ter até quatro grupos de armazenamento, cada qual oferece suporte a até cinco bancos de dados (armazenamentos de caixa de correio ou de pasta pública).

A prática recomendada para configurar grupos de armazenamentos para computadores que estão executando o Exchange Server 2003 Enterprise Edition é incluir um grupo adicional de armazenamento para cada banco de dados novo, até que o número máximo de grupos armazenamento seja criado. Você pode distribuir a carga de caixas de correio na topologia do armazenamento do Exchange Server pelo máximo de grupos de armazenamento possível. Essa topologia tem as seguintes vantagens:

  • Ocorre um aumento na confiabilidade da topologia de armazenamento.

  • Ocorre um aumento na capacidade de recuperação da topologia de armazenamento.

  • A E/S de unidades pode ser gerenciada de modo mais eficiente.

Se você tiver menos de quatro grupos de armazenamento e mais de quatro armazenamentos de caixa de correio em um servidor que esteja executando o Exchange Server 2003 Enterprise Edition, execute as seguintes etapas para distribuir as caixas de correio pelo maior número possível de grupos de armazenamento.

Para resolver este erro

  1. No Gerenciador do Sistema do Exchange, selecione o servidor que relatou esse erro. Anote o número de grupos de armazenamento e armazenamentos de caixa de correio localizados no mesmo servidor. Anote o número de grupos de armazenamento que contêm mais de um armazenamento de caixa de correio.

  2. Crie grupos de armazenamento adicionais até que você tenha quatro grupos de armazenamento no computador executando o Exchange Server 2003 Enterprise Edition. Para obter informações sobre como criar um novo grupo de armazenamento, consulte "Adicionando um grupo de armazenamento" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617) (em inglês).

  3. Crie um novo armazenamento de caixa de correio em cada novo grupo de armazenamento criado. Para obter informações sobre como criar um novo armazenamento de caixa de correio, consulte "Adicionando um armazenamento de caixa de correio" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617) (em inglês).

  4. Mova as caixas de correio de um dos armazenamentos de caixa de correio contidos no grupo de armazenamento que possui vários armazenamentos de caixa de correio para o armazenamento de caixa de correio localizado em um grupo de armazenamento recém-criado. Use o Assistente para Mover Caixa de Correio para mover caixas de correio. Para obter informações detalhadas sobre como usar o Assistente para Mover Caixa de Correio, consulte " Usando o Assistente de Tarefas do Exchange para mover caixas de correio" no capítulo "Migrando do Exchange Server 5.5 para o Exchange Server 2003" do Guia de Implantação do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569) (em inglês).

Para obter mais informações sobre como configurar grupos de armazenamento no Exchange Server 2003, consulte o artigo 890699 da Base de Dados de Conhecimento Microsoft, "Como configurar grupos de armazenamento no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=890699) (em inglês).

Para obter informações sobre como configurar grupos de armazenamento, consulte a seção de configuração de grupos de armazenamento em "Planejando uma solução confiável de armazenamento back-end" no Guia de Alta Disponibilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47571) (em inglês).

Para obter recomendações gerais para ajudá-lo a maximizar a disponibilidade, tolerância a falhas e desempenho, consulte Otimizando o armazenamento no Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=49324) (em inglês).


Discrepância de assinatura entre o arquivo de banco de dados e o arquivo de streaming
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer determinou que há uma discrepância de asinatura entre o arquivo de banco de dados (.edb) do Exchange e seu arquivo correspondente de banco de dados de streaming (.stm) do Exchange.

Cada banco de dados do Exchange 2000 Server e do Exchange Server 2003 é composto de dois arquivos: o arquivo de banco de dados MAPI .edb e o arquivo de banco de dados de streaming .stm. Pares correspondentes desses arquivos compartilham uma assinatura de banco de dados comum. Se a assinatura do banco de dados não coincidir, a correspondência dos arquivos não será feita.

Você deve tratar os arquivos .edb e .stm como se fossem um só. Eles devem sempre ser movidos ou copiados juntos.

Para corrigir esse erro

  • Investigue a história dos arquivos do banco de dados. É possível que arquivos tenham sido copiados, movidos ou excluídos manualmente. Você deve corrigir esse problema para que seja possível recuperar o banco de dados.

  • Se você não conseguir localizar arquivos .edb e .stm correspondentes, pode ser possível usar Eseutil.exe para reparar apenas o arquivo .edb e usar Eseutil com a opção /createstm para descartar o arquivo .stm. Esse método resulta na perda de todas as informações do banco de dados de streaming.

    Observação:
    Se todos os usuários do banco de dados se conectam ao banco de dados usando um cliente MAPI como o Microsoft Office Outlook®, as informações armazenadas no banco de dados de streaming serão mínimas. Se os usuários se conectam ao banco de dados usando clientes POP3, IMAP ou Outlook Web Access, então o banco de dados de streaming contém parte ou todo o conteúdo da caixa de correio dos usuários.

Para obter mais informações sobre como reparar um banco de dados do Exchange, consulte o artigo 812357 da Base de Dados de Conhecimento Microsoft, "How to maintain your Exchange database after you repair by using the Eseutil /p tool in Exchange Server 5.5, in Exchange 2000 Server, and in Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357).


O endereço SMTP não está definido na diretiva de destinatário padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-12-03

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o endereço SMTP está especificado no atributo gatewayProxy da diretiva de destinatário padrão na organização do Exchange Server. Ao verificar que o atributo gatewayProxy não contém um endereço SMTP, o Exchange Server Analyzer exibirá um erro.

Esse erro é um erro crítico. É necessário adicionar o endereço SMTP, como SMTP:@contoso.com, ao atributo gatewayProxy da diretiva de destinatário padrão na organização do Exchange Server. A diretiva de destinatário padrão deve conter um endereço SMTP. Se não contiver, o serviço Armazenamento de Informações do Microsoft Exchange não será inicializado após o reinício. Essa falha ocorrerá em todos os servidores Exchange da organização do Exchange Server no próximo reinício do serviço Armazenamento de Informações do Microsoft Exchange.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou do Exchange Server 2007 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para adicionar o endereço SMTP ao atributo gatewayProxy da diretiva de destinatário padrão

  1. Inicie a ferramenta ADSI Edit nas ferramentas de suporte do Microsoft Windows® 2000 ou do Windows Server 2003.

  2. Expanda os seguintes nós:

    • Contêiner de Configuração

    • Configuração

    • Serviços

    • Microsoft Exchange

    • Nome_da_Organização

    • Diretivas de Destinatário

  3. No painel de detalhes, clique com o botão direito do mouse em CN=Diretiva Padrão e clique em Propriedades.

  4. Na caixa de diálogo Atributos, clique duas vezes em gatewayProxy.

  5. Na caixa de diálogo Editor de Cadeia de Caracteres de Vários Valores, digite SMTP:@nome_de_domínio.com no campo Valor a Ser Adicionado e clique em Adicionar.

    Observação:
    A sintaxe digitada é importante. Inclua SMTP:@ antes do nome de domínio da organização do Exchange Server. Não há espaços em branco nessa cadeia de caracteres.

  6. Clique em OK e depois em Aplicar; em seguida, feche o ADSI Edit.

  7. Espere pelo menos 15 minutos para replicação.


Os parâmetros do Registro de Rateio de RPC de Armazenamento não estão definidos com os valores corretos
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê três chaves do Registro para determinar se seus valores estão diferentes dos valores padrão. Todas as três chaves são valores DWORD que podem ser encontrados em:

HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

As chaves apresentam os seguintes nomes e valores padrão:

Valor DWORD Valor Decimal Padrão
  • ProrateStart

  • 40
  • ProrateMax

  • 10,000
  • ProrateFactor

  • 100

Se o Exchange Server Analyzer descobrir que qualquer um dos valores padrão foi alterado, uma mensagem de configuração não padrão será exibida.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para os valores padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

  3. No painel direito, clique duas vezes na entrada cujo valor foi alterado e configure-a com o valor padrão.

  4. Repita a etapa 3 se mais de um valor tiver sido alterado.

  5. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre threads do processo de armazenamento, consulte o artigo 267255 da Base de Dados de Conhecimento, "Threads store.exe utilizam memória disponível" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=267255).


O diretório de trabalho de armazenamento está ausente ou incorreto
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-30

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para verificar o diretório de trabalho do serviço Armazenamento de Informações do Microsoft Exchange.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Working Directory

O Exchange Server Analyzer exibirá um aviso se existirem as seguintes condições:

  • O diretório especificado como o Diretório de Trabalho não existe.

  • Você está executando o Exchange 2000 Server, o Exchange Server 2003 ou o Exchange Server 2007.

O Exchange Server usa o diretório de trabalho para armazenamento temporário. Por exemplo, o Exchange Server usa o diretório de trabalho durante o processo de conversão de mensagens. Ele também usa o diretório de trabalho para armazenar um banco de dados temporário durante a desfragmentação. Se o diretório de trabalho não for especificado corretamente, poderão ocorrer os seguintes problemas:

  • Mensagens com anexos poderão acumular na fila SMTP de entrega local.

  • Poderão ser recebidas mensagens sem anexos.

  • As mensagens poderão ser entregues sem êxito.

Por padrão, o Exchange 2000 Server e o Exchange Server 2003 definem o diretório de trabalho como o diretório mdbdata, pertencente ao diretório em que você instalou o Exchange Server. Por exemplo, se você instalar o Exchange Server no diretório C:\Arquivos de Programas\Exchsrvr, o Exchange Server definirá o diretório de trabalho como C:\Arquivos de Programas\Exchsrvr\mdbdata.

Por padrão, o Exchange Server 2007 define o diretório de trabalho como o diretório de banco de dados de caixa de correio, pertencente ao diretório em que você instalou o Exchange Server. Por exemplo, se você instalar o Exchange Server no diretório C:\Arquivos de Programas\Exchange Server, o Exchange Server 2007 definirá o diretório de trabalho como C:\Arquivos de Programas\Exchange Server\Caixa de Correio\MDBTemp

Para corrigir este aviso, especifique o diretório de trabalho como um diretório existente no servidor Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para especificar o diretório de trabalho usando regedit:

  1. Inicie o Editor do Registro (regedit).

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Atualize o valor do Registro Working Directory com o diretório de trabalho correto para o serviço Armazenamento de Informações do Microsoft Exchange, como C:\Arquivos de Programas\Exchsrvr\mdbdata.

    Observação:
    Essa alteração não exige o reinício do serviço Armazenamento de Informações do Microsoft Exchange.

  4. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor de Registro Working Directory, consulte o artigo 298415 da Base de Dados de Conhecimento, "Mensagens que possuem anexos não são entregues como esperado, e as mensagens de ID de Evento 12003 e 327 são registradas no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=298415).


A supressão de mensagens de ausência temporária para as listas de distribuição foi definida
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-02-27

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se as mensagens de ausência temporária estão sendo suprimidas para listas de distribuição:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\SuppressOOFsToDistributionLists

Se o Exchange Server Analyzer verificar que o valor de SuppressOOFsToDistributionLists é maior que 0, uma mensagem de configuração não padrão será exibida.

Quando uma mensagem é enviada para uma caixa de correio com o Assistente de Ausência Temporária habilitado, o remetente recebe uma mensagem que não tem um endereço no campo Para ou Cc, mas tem uma lista de distribuição no campo Cco e uma mensagem de ausência temporária é enviada para a lista de distribuição que está no campo Cco.

Se uma mensagem for enviada a um destinatário indicado somente no campo Cco, mas não em uma lista de distribuição, e o destinatário tiver ativado o Assistente de Ausência Temporária, o armazenamento de caixa de correio do destinatário enviará uma mensagem de ausência temporária, mesmo que o valor de Registro SuppressOOFsToDistributionLists esteja definido. Essa limitação se aplica apenas quando o destinatário está indicado no campo Cco e os campos Para e Cc estão em branco. Se houver pelo menos um usuário nos campos Para ou Cc, o parâmetro de Registro no computador do Exchange Server suprimirá os destinatários listados no campo Cco da geração de uma mensagem de ausência temporária.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para modificar o comportamento da geração de mensagem de ausência temporária

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Clique com o botão direito em ParametersSystem, aponte para Novo e clique em Valor DWORD.

  4. Nomeie o novo valor SuppressOOFsToDistributionLists.

  5. Clique com o botão direito em SuppressOOFsToDistributionLists e clique em Modificar.

  6. Na caixa de diálogo Dados do valor, digite 1 e clique em OK.

  7. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor de Registro SuppressOOFsToDistributionLists, consulte o artigo 825370 da Base de Dados de Conhecimento, "Mensagens de ausência temporária são enviadas para listas de distribuição que estão no campo Cco" (em inglês) (http://go.microsoft.com/fwlink/?lin k id=3052 & kbid=825370).


Foi alterado o valor limite que controla quantas vezes uma mensagem danificada pode ser transmitida para o armazenamento
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-08

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar o valor de PoisonThreshold:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<NomeDoServidorExchange> \Private- <PrivateInformationStoreGUID>

Se o Analisador do Exchange Server determinar que o valor de PoisonThreshold não é igual a 2, será exibida uma mensagem de configuração não padrão.

As versões do Exchange Server posteriores ao Exchange Server 2003 Service Pack 1 implementam um comportamento que ajuda a evitar que mensagens corrompidas ou inválidas interrompam o serviço de Armazenamento de Informações do Microsoft Exchange inesperadamente ou impeçam que ele seja iniciado corretamente.

No Exchange Server 2003 Service Pack 1 ou posteriores, mensagens que causam a interrupção inesperada do serviço de Armazenamento de Informações do Microsoft Exchange durante a conversão do formato MAPI para o formato MIME são controladas. A ID da mensagem danificada é armazenada no Registro quando a falha ocorre. Se uma mensagem danificada provocar a interrupção inesperada do armazenamento três vezes, essa informação será usada para evitar que a mensagem seja processada novamente quando o serviço Armazenamento de Informações do Microsoft Exchange for reiniciado pela quarta vez.

Quando o serviço Armazenamento de Informações do Microsoft Exchange for interrompido inesperadamente por causa de uma mensagem danificada, o valor do Registro PoisonIDs será criado em:

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<NomeDoServidorExchange> \Private- <PrivateInformationStoreGUID>

Além disso, um administrador pode criar a entrada do Registro PoisonThreshold. A chave PoisonThreshold controla o número máximo de vezes que uma mensagem pode ser transmitida para o armazenamento de informações do Exchange antes de ser adicionada à chave de Registro PoisonIDs. Por padrão, esse valor limite é 2. Para acionar o comportamento, o limite deve ser excedido. Portanto, o serviço Armazenamento de Informações do Microsoft Exchange pode ser interrompido 3 vezes devido a uma mensagem danificada antes que a mensagem seja bloqueada. Por exemplo, se uma mensagem estiver envolvida em 3 falhas, será bloqueada porque 3 é maior que o valor limite de 2.

Quando um evento de mensagem danificada é gravado no Registro, aparecerão mensagens de erro (IDs de evento 9680 e 9681) no log de eventos do aplicativo. Depois que o serviço Armazenamento de Informações do Microsoft Exchange for iniciado com êxito, o Exchange bloqueará a mensagem e tentará enviar uma notificação de falha de entrega. Em alguns casos, é possível que o Exchange não envie uma notificação de falha na entrega. Nesses casos, a mensagem bloqueada pode permanecer na fila até expirar. A chave de Registro PoisonIDs armazena até 10 valores de ID de mensagem. Quando o limite de dez for excedido e um novo evento de mensagem danificada for adicionado. O evento de mensagem danificada, que contém a data da falha mais antiga, é removido.

Observação:
As etapas para solução de problemas de mensagens danificadas individuais estiver além do escopo do Analisador do Exchange Server. Em alguns casos, o Atendimento Microsoft pode conseguir ajudar com a solução de problemas de mensagens danificadas individuais. Se estiver enfrentando problemas com o encerramento do Exchange Server 2003 ou posteriores por causa de mensagens danificadas, talvez seja útil habilitar a criação automática de relatórios de erros no computador do Exchange Server. Os dados do relatório de erros são usados para localizar e corrigir problemas ocorridos no software usado. Para obter mais informações sobre como habilitar o Relatório de Erros do Exchange, consulte Relatório de Erros do Exchange está desabilitado

Recomenda-se que o valor de PoisonThreshold seja alterado novamente para o seu valor padrão de 2.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ExchangeServerName>\Private-<PrivateInformationStoreGUID>

  3. No painel direito, clique duas vezes em PoisonThreshold.

  4. Nos dados de Valor, digite 2 (decimal) e clique em OK.

  5. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O rastreamento foi habilitado no processo de Armazenamento
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o Registro para verificar se a entrada de Registro Habilitar Rastreamento existe junto ao valor de Registro Rastrear LegacyDN do Usuário. Ambos os valores de Registro estão presentes na seguinte chave de Registro:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Se o Exchange Server Analyzer detectar que ambas as entradas de Registro estão presentes e configuradas, um aviso será exibido.

O valor do Registro DWORD Habilitar Rastreamento habilita o serviço Armazenamento de Informações do Microsoft Exchange para rastreamento. O rastreamento é usado na solução de problemas de inicialização do armazenamento do Exchange e pode afetar seriamente o desempenho. A menos que esteja solucionando um problema, não use essa configuração de Registro. Para habilitar o rastreamento para usuários específicos (rastreamento filtrado), adicione o valor da cadeia de caracteres do Registro Rastrear LegacyDN do Usuário. Se o valor Rastrear LegacyDN do Usuário não estiver presente, o rastreamento estará habilitado para todos os usuários. Se o valor Rastrear LegacyDN do Usuário estiver presente, o rastreamento será realizado para os usuários específicos listados nessa chave.

Se a solução de problemas não estiver sendo executada no computador do Exchange Server, esses valores de Registro não deveriam estar presentes.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Exclua os valores do Registro Habilitar Rastreamento e Rastrear LegacyDN do Usuário.

  4. Feche o editor de Registro e reinicie o computador para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre rastreamento por usuário em um servidor Exchange, consulte o artigo 296624 da Base de Dados de Conhecimento, "Recurso Rastreamento por Usuário Adicionado ao Exchange 2000 Server Service Pack 2 (SP2)" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624).


O rastreamento foi habilitado para o serviço de Armazenamento de Informações do Microsoft Exchange para todos os usuários
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2007-01-17

A ferramenta Microsoft® Exchange Server Analyzer lê o Registro para determinar se a entrada Habilitar Rastreamento está presente em:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Se o Exchange Server Analyzer localizar o valor do Registro de Habilitar Rastreamento presente e configurado, um aviso será exibido.

O valor do Registro DWORD de Habilitar Rastreamento permite que o serviço Armazenamento de Informações do Microsoft Exchange realize rastreamentos. O rastreamento é usado na solução de problemas de inicialização de armazenamento e pode afetar seriamente o desempenho. A menos que esteja solucionando um problema, essa configuração do Registro não deve ser usada. Para habilitar o rastreamento para usuários específicos, adicione o valor Rastrear LegacyDN do Usuário da cadeia de caracteres do Registro. Se esse valor não estiver presente, o rastreamento será habilitado para todos os usuários.

Se a solução de problemas não estiver sendo executada no computador com o Exchange Server, esse valor não deverá estar presente.

Observação:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, consulte o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Exclua o valor de Registro Habilitar Rastreamento.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter mais informações sobre como fazer isso, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês)(http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre rastreamento por usuário em um servidor Exchange, consulte o artigo 296624 da Base de Dados de Conhecimento, "Recurso Rastreamento por Usuário Adicionado ao Exchange 2000 Server Service Pack 2 (SP2)" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624).


Nomes de arquivo de log de transações concluídos
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool verifica a integridade dos arquivos de log de transações para cada grupo de armazenamento verificando os arquivos de log no disco do servidor. Para encontrar a localização dos arquivos de log, o Exchange Server Analyzer consulta o serviço de diretório do Active Directory®. Para cada objeto do grupo de armazenamento (classe msExchStorageGroup), o caminho do arquivo para os arquivos de log é armazenado no atributo msExchESEParamLogFilePath.

Os nomes dos arquivos de log de transações incluem números hexadecimais seqüenciais que identificam a seqüência dos arquivos de log. Por exemplo, o primeiro arquivo de log do Primeiro Grupo de Armazenamento padrão é chamado E0000001.log, o segundo é E0000002.log e assim por diante. A seqüência pode chegar até E00FFFFF.log. O Exchange pode criar até 1.030.000 arquivos de log exclusivos. Entretanto, quando o Exchange atinge o final da seqüência, os armazenamentos do grupo de armazenamento afetado não serão mais montados se tiverem sido desmontados depois que o limite for atingido. Se permanecerem montados, o armazenamento não desmontará os bancos de dados apesar de não poderem ocorrer operações de Jet. Normalmente, o Exchange pode ser executado durante vários anos antes de atingir esse limite.

Você verá essa mensagem como um aviso se o servidor especificado tiver usado mais de 950.000 arquivos de log de transações.

Você verá essa mensagem como um erro se o servidor especificado tiver usado mais de 1.020.000 arquivos de log de transações.

Para permitir que o armazenamento desmonte os bancos de dados de forma apropriada se esse limite for atingido, uma correção foi incluída no Exchange Server 2003 Service Pack 1. Um hotfix post-Service Pack 3 está disponível para o Exchange 2000 Server, conforme descrito no artigo 830408 da Base de Dados de Conhecimento da Microsoft, "Armazenamentos do banco de dados do Exchange permanecem montados embora todos os logs de transações que estavam disponíveis para o grupo de armazenamento tenham sido usados" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408).

Se o Exchange ainda não atingiu o limite de log de transações de 1.030.000, execute um backup online completo do servidor logo que possível. Para obter mais informações sobre a realização de um backup online completo do armazenamento do Exchange, consulte o Guia de Operações de Recuperação de Desastres do Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47570).

Se o Exchange atingiu esse limite, você deverá mover todos os logs de transações existentes para outro local. Depois de fazer isso, uma nova seqüência de arquivos de log começada por 0x00001 será gerada. Para garantir que o armazenamento do Exchange desmontará os bancos de dados de forma apropriada, você deve aplicar também a correção apropriada para sua versão do Exchange.

Observação:
Antes de mover os logs de transações, você deve verificar se todos os bancos de dados do grupo de armazenamento estão em um estado de Desligamento Normal.
Importante:
Depois de executar o procedimento abaixo, todos os backups anteriores serão invalidados. Isso não significa que os backups não podem ser recuperados. Entretanto, os backups não poderão mais ser rolados para frente com logs adicionais de transações. Se precisar recuperar um backup anterior depois de remover os logs de transações, você poderá recuperar dados somente até o momento em que a nova geração de logs foi criada.

Para resolver esse problema

  1. No Exchange Server 2003, instale o Service Pack 1, disponível no site de downloads do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=29090).

    -ou-

    No Exchange 2000 Server, obtenha e instale o hotfix mencionado no artigo 830408 da Base de Dados de Conhecimento da Microsoft, "Armazenamento de bancos de dados do Exchange permanecem montados embora todos os logs de transações disponíveis em um grupo de armazenamento tenham sido usados" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408).

  2. No grupo de armazenamento que ficou sem arquivos de log de transações, desmonte todos os bancos de dados. Para fazer isso, siga essas etapas:

    1. Abra o Gerenciador do Sistema do Exchange.

    2. Expanda Grupos Administrativos, expanda <AdministrativeGroupName>, expanda Servidores, expanda <ServerName> e expanda <StorageGroupName>.

    3. Clique com o botão direito no primeiro armazenamento desse grupo de armazenamento e clique em Desmontar Armazenamento. Repita essa etapa para cada armazenamento desse grupo de armazenamento.

  3. Verifique se cada banco de dados do grupo de armazenamento está em um estado de Desligamento Normal. Para fazer isso, siga essas etapas:

    1. No Gerenciador do Sistema do Exchange, clique com o botão direito no primeiro armazenamento do grupo de armazenamento que está sem arquivos de log de transações e clique em Propriedades.

    2. Clique na guia Banco de Dados e observe os caminhos e nomes de arquivos do banco de dados na caixa de banco de dados do Exchange e na caixa de banco de dados de fluxo contínuo do Exchange. Cada banco de dados do Exchange é composto por um conjunto de arquivos em pares com extensões de nomes de arquivo .edb e .stm. Repita esta etapa pra cada armazenamento no grupo de armazenamento.

    3. Em um prompt de comando, altere o diretório para a pasta bin do Exchange Server. Por exemplo, altere o diretório para C:\Arquivos de Programas\Exchsrvr\bin.

    4. Digite Eseutil /mh DatabaseFileName e pressione Enter. Repita essa etapa para cada armazenamento do grupo de armazenamento. Esse comando exibirá o cabeçalho do arquivo do banco de dados. O cabeçalho conterá uma destas duas linhas: Estado: Desligamento Normal ou Estado: Desligamento Anormal.

  4. Se o cabeçalho contiver a linha Estado: Desligamento Anormal, você deverá recuperar manualmente o banco de dados antes de remover os arquivos de log. Para fazer isso, siga essas etapas:

    1. No Gerenciador do Sistema do Exchange, clique com o botão direito no grupo de armazenamento que está sem arquivos de log de transações e clique em Propriedades.

    2. Clique na guia Geral e observe os caminhos dos logs de transações na caixa Local de logs de transações.

    3. Observe o caminho do arquivo de ponto de verificação da caixa Local de caminho do sistema.

    4. Em um prompt de comando, altere o diretório para a pasta bin do Exchange Server.

    5. Digite o seguinte comando e pressione Enter: Eseutil /r 3-CharacterLogfileBaseName /lDirectory:\LogfilePath /sDirectory:\CheckpointFilePath.

      Observação:
      Não digite um espaço entre a opção e os caminhos de diretório. Se você cometer um erro tipográfico nos caminhos listados no comando, a recuperação poderá falhar. Para evitar esse comportamento, você pode copiar o arquivo de ponto de verificação para a pasta do arquivo de log de transações. Em um prompt de comando padrão no diretório do arquivo de log, execute o comando Eseutil /r 3-CharacterLogfileBaseName. Por causa da opção /l e da opção padrão /s no diretório atual, não é preciso fornecer os caminhos dos arquivos de log ou os caminhos dos arquivos de ponto de verificação.
    6. Após a conclusão da recuperação, verifique se todos os arquivos do banco de dados estão agora em um estado de Desligamento Normal antes de mover os arquivos de log de transações e os arquivos de ponto de verificação. Se você mover os arquivos de log quando um banco de dados estiver em um estado de Desligamento Anormal, não poderá reiniciar o banco de dados. Se você não puder recuperar todos os bancos de dados para o estado de Desligamento Normal, entre em contato com o Atendimento Microsoft para obter mais informações.

  5. No Gerenciador do Sistema do Exchange, clique com o botão direito no grupo de armazenamento que está sem arquivos de log de transações e clique em Propriedades.

  6. Clique na guia Geral e observe os caminhos dos logs de transações na caixa Local dos logs de transações.

  7. Observe o caminho do arquivo de ponto de verificação na caixa Local do caminho do sistema.

  8. Mova os arquivos de log de transações e o arquivo de ponto de verificação para outro local. Os arquivos de log têm a extensão de nome de arquivo .log e os arquivos de ponto de verificação têm a extensão de nome de arquivo .chk.

  9. No Gerenciador de Sistema do Exchange, clique com o botão direito no primeiro armazenamento desmontado do grupo e clique em Montar Armazenamento.

  10. Repita esta etapa pra cada armazenamento no grupo de armazenamento. A seqüência de arquivos de log está agora redefinida no grupo de armazenamento.

  11. Faça um backup completo de todos os bancos de dados do grupo de armazenamento.

Para obter informações sobre o service packs do Exchange Server 2003, consulte o site do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21573).


O tamanho do maior bloco VM é baixo
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows) Win32_PerfRawData_MSExchangeIS_MSExchangeIS para determinar o valor da chave VMLargestBlockSize. A chave VMLargestBlockSize representa o tamanho (em bytes) do maior bloco de memória virtual disponível.

Além disso, o Exchange Server Analyzer também consulta o serviço de diretório Active Directory® para determinar a contagem das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Se o Exchange Server Analyzer perceber que o valor de VMLargestBlockSize é maior que 50000000 mas menor que 150000000 em um computador com o Exchange que tenha mais de 20 caixas de correio, um aviso será exibido.

Entre outras coisas, o Exchange Server usa a memória virtual para armazenar mensagens quando você as converte entre formatos MIME e MAPI, e como um buffer quando confirma as mensagens para o log de transações e para o armazenamento. Freqüentemente essas operações exigem grandes blocos contíguos de memória virtual para serem concluídas de forma rápida e eficiente. Esse aviso é exibido quando a memória virtual do computador do Exchange fica menos de 150 MB de espaço contíguo. Isso é conhecido como fragmentação de memória virtual.

Se a memória virtual for muito reduzida, você começará a ver mensagens de erro no log de eventos (ID do Evento 9582), que são erros de memória virtual. Se a memória virtual estiver muito baixa, você verá a ID de Evento 12800, que significa que as mensagens não estão sendo entregues porque não há memória suficiente para processá-las.

Para resolver esse aviso, siga estas recomendações na ordem em que são apresentadas.

Pesquise o erro, " Tamanho máximo do cache do ESE elevado", na saída do Analisador do Exchange Server.

Se o erro, Tamanho máximo do cache do ESE elevado, for retornado no mesmo computador do Exchange em que esse aviso de fragmentação de memória virtual é retornado, siga as recomendações do artigo, Cache máximo de ESE está definido muito alto.

A combinação dessas duas mensagens provavelmente indica que os problemas de fragmentação de memória virtual estão ocorrendo porque o cache ESE está sendo aumentado manualmente.

Reinicie o serviço Armazenamento de Informações do Exchange

Na descrição dessa mensagem de erro, o Exchange Server Analyzer especifica há quantos dias o serviço Armazenamento de Informações do Microsoft Exchange está em execução. Se o número de dias especificado for maior que 30, reinicie o serviço.

Para reiniciar o serviço de Armazenamento de Informações do Microsoft Exchange

  1. Abra o snap-in Serviços do MMC.

  2. Clique com o botão direito no serviço Armazenamento de Informações do Microsoft Exchange e clique em Reiniciar.

Calcule os limites de tamanho da mensagem

Se muitos usuários estiverem enviando mensagens grandes (com mais de 30 MB), a memória virtual poderá ser fragmentada mais cedo do que seria se os usuários não enviassem mensagens grandes. Conforme mencionado, a memória virtual é usada como um buffer quando o processo de armazenamento move dados de arquivos de log e os confirma para armazenamento. Se os dados movidos forem freqüentemente grandes, blocos grandes e contíguos de memória virtual serão consumidos rapidamente.

Se os dados grandes forem regularmente enviados por email e, esses dados forem enviados internamente, experimente configurar diretórios compartilhados em servidores de arquivo nos quais os usuários podem postar grandes blocos de dados.

É recomendável que você defina o limite máximo de tamanho de mensagem para 30 MB ou menos. Entretanto, se você precisar de um limite de tamanho de mensagem maior com anexos grandes para serem enviados pela organização do Exchange, poderá aumentar o limite de tamanho máximo de mensagem de saída acima de 30 MB. Além da fragmentação da memória virtual, aumentar o limite de tamanho da mensagem acima de 30 MB pode deixar o sistema mais vulnerável a ataques mal-intencionados. Não é recomendável permitir um limite de tamanho de mensagem maior que 30 MB.

Para definir limites de tamanho de mensagem

  1. No Gerenciador do Sistema do Exchange, expanda Configurações Globais, clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  2. Na caixa de diálogo Entrega de MensagensPropriedades , na guia Padrões, selecione a opção Enviando limite de tamanho da mensagem e insira o limite de tamanho desejado.

Verifique se o software antivírus está atualizado

Às vezes, um software antivírus desatualizado em execução no modo VSAPI (API de Verificação de Vírus) causa a fragmentação da memória virtual. Se você estiver executando o software antivírus no modo VSAPI, entre em contato com o fornecedor do antivírus e verifique se está executando a versão mais recente do software e dos drivers.

Mova as caixas de correio para outro servidor Exchange

Se tiver percorrido todos os procedimentos mas o Exchange Server Analyzer ainda estiver exibindo esse aviso, você deverá remover as caixas de correio do servidor afetado para reduzir sua carga. Há um excesso de caixas de correio neste servidor.

Para mover as caixas de correio no Exchange 2000 Server e Exchange Server 2003

  1. Em Usuários e Computadores do Active Directory, selecione o usuário ou usuários cujas caixas de correio você deseja mover.

  2. Clique com o botão direito na lista de usuários que você selecionou na etapa anterior e clique em Tarefas do Exchange.

  3. No Assistente de Tarefas do Exchange, na página Tarefas Disponíveis, clique em Mover Caixa de Correio e clique em Avançar.

  4. Leia cuidadosamente e siga as etapas restantes do assistente.

Para mover as caixas de correio no Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda o servidor do qual você deseja mover as caixas de correio, expanda o Grupo de Armazenamento do qual deseja mover as caixas de correio, expanda o Armazenamento de Caixa de Correio que contém as caixas de correio que deseja mover e clique em Caixas de Correio.

  2. No painel de detalhes, clique com o botão direito no usuário ou usuários cujas caixas de correio você deseja mover e clique em Tarefas do Exchange.

  3. No Assistente de Tarefas do Exchange, na página Tarefas Disponíveis, clique em Mover Caixa de Correio e clique em Avançar.

  4. Leia cuidadosamente e siga as etapas restantes do assistente.

Para obter mais informações sobre como resolver problemas de fragmentação de memória, consulte os seguintes artigos na Base de Dados de Conhecimento da Microsoft:

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 838233, "Seu computador pode estar lento ou parar de responder, e registrar repetidamente identificadores de evento 9582 e 1160 no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233)

Para obter mais detalhes sobre como definir limites de tamanho de mensagens, consulte o artigo 322679 da Base de Dados de Conhecimento, "Definir limites de tamanho para mensagens" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Para obter mais informações sobre como mover caixas de correio, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328810, "Movendo caixas de correio entre servidores" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)

  • 821829, "Movendo caixas de correio no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829)


O Tamanho do Maior Bloco de MV está atingindo o ponto crítico
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows) Win32_PerfRawData_MSExchangeIS_MSExchangeIS para determinar o valor da chave VMLargestBlockSize. A chave VMLargestBlockSize representa o tamanho (em bytes) do maior bloco de memória virtual disponível.

Além disso, o Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar a contagem das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Se o Exchange Server Analyzer perceber que o valor de VMLargestBlockSize é maior que 0 e menor que 50000001 em um computador do Exchange Server com mais de 20 caixas de correio, um erro será exibido.

Entre outras coisas, o servidor Exchange usa a memória virtual para armazenar mensagens ao convertê-las entre os formatos MIME e MAPI e como um buffer ao confirmar mensagens do log de transações e confirmar no armazenamento. Freqüentemente essas operações exigem grandes blocos contíguos de memória virtual para serem concluídas de forma rápida e eficiente. Se esse erro tiver sido exibido, a memória virtual do computador do Exchange tem menos de 50 MB de espaço contíguo. Isso é conhecido como fragmentação de memória virtual. Um servidor de caixa de correio do Exchange sendo executado com menos de 50 MB de memória virtual contígua é um erro crítico.

Se a memória virtual se esgotar muito, talvez você comece a ver alertas de erro no log de eventos (ID de Evento 9582), que são erros da memória virtual. Se a memória virtual estiver muito baixa, você verá a ID de Evento 12800, que significa que as mensagens não estão sendo enviadas porque não há memória suficiente para processá-las.

Para remediar esse erro, siga as recomendações abaixo, na ordem em que são apresentadas.

Pesquise o erro, " Tamanho máximo do cache do ESE elevado", na saída do Analisador do Exchange Server.

Se o erro, Tamanho máximo do cache do ESE elevado, for retornado no mesmo computador do Exchange em que esse aviso de fragmentação de memória virtual é retornado, siga as recomendações do artigo, Cache máximo de ESE está definido muito alto.

A combinação desses dois alertas provavelmente indica que os problemas de fragmentação da memória virtual são resultado do aumento manual do cache ESE

Reinicie o serviço Armazenamento de Informações do Exchange

Na descrição desse alerta, o Exchange Server Analyzer especifica há quantos dias que o serviço Armazenamento de Informações do Microsoft Exchange está em execução. Se o número de dias especificado for maior que 30, reinicie o serviço.

Para reiniciar o Armazenamento de Informações do Exchange

  1. Abra o snap-in Serviços do MMC.

  2. Clique com o botão direito no serviço Armazenamento de Informações do Microsoft Exchange e clique em Reiniciar.

Calcule os limites de tamanho da mensagem

Se houver muitos usuários enviando mensagens grandes (maiores que 30 MB), a memória virtual pode ficar fragmentada antes do que ficaria se não houvesse muitos usuários enviando mensagens grandes. Conforme foi mencionado anteriormente, a memória virtual é usada como um buffer quando o processo de armazenamento move dados de arquivos de log e os confirma no armazenamento. Se os dados movidos forem freqüentemente grandes, blocos grandes e contíguos da memória virtual serão consumidos rapidamente.

Se dados grandes forem enviados com freqüência usando o email, e esses dados forem enviados internamente, experimente definir diretórios compartilhados em servidores de arquivo nos quais os usuários podem postar grandes blocos de dados.

É recomendável que você defina o limite de tamanho máximo de mensagem para não mais de 30 MB. Entretanto, se você precisar de um limite de tamanho de mensagem maior com anexos grandes para serem enviados pela organização do Exchange, poderá aumentar o limite de tamanho máximo de mensagem de saída acima de 30 MB. Além da fragmentação da memória virtual, aumentar o limite de tamanho da mensagem acima de 30 MB pode deixar o sistema mais vulnerável a ataques mal-intencionados. Dessa forma, não é recomendável permitir um limite de tamanho de mensagem maior que 30 MB.

Para definir limites de tamanho de mensagem

  1. No Gerenciador do Sistema do Exchange, expanda Configurações Globais, clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  2. Na caixa de diálogo Entrega de MensagensPropriedades , na guia Padrões, selecione a opção Enviando limite de tamanho da mensagem e insira o limite de tamanho desejado.

Verifique se o software antivírus está atualizado

Em alguns casos, um software antivírus desatualizado sendo executado no modo VSAPI (API de Verificação de Vírus) causará fragmentação de memória virtual. Se você estiver executando o software antivírus no modo VSAPI, entre em contato com o fornecedor do antivírus e verifique se está executando a versão mais recente do software e dos drivers.

Mova as caixas de correio para outro servidor Exchange

Se você já tiver tentado todos os procedimentos anteriores e o Exchange Server Analyzer ainda estiver exibindo esse erro, ou a versão de aviso desse alerta (quando houver menos de 150 MB de espaço contíguo na memória virtual), você deverá mover as caixas de correio do servidor afetado para reduzir sua carga. Há um excesso de caixas de correio neste servidor.

Para mover as caixas de correio no Exchange 2000 Server e Exchange Server 2003

  1. Em Usuários e Computadores do Active Directory, selecione o usuário ou usuários cujas caixas de correio você deseja mover.

  2. Clique com o botão direito na lista de usuários que você selecionou na etapa anterior e clique em Tarefas do Exchange.

  3. No Assistente de Tarefas do Exchange, na página Tarefas Disponíveis, clique em Mover Caixa de Correio e clique em Avançar.

  4. Leia cuidadosamente e siga as etapas restantes do assistente.

Para mover as caixas de correio no Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda o servidor do qual você deseja mover as caixas de correio, expanda o Grupo de Armazenamento do qual deseja mover as caixas de correio, expanda o Armazenamento de Caixa de Correio que contém as caixas de correio que deseja mover e clique em Caixas de Correio.

  2. No painel de detalhes, clique com o botão direito no usuário ou usuários cujas caixas de correio você deseja mover e clique em Tarefas do Exchange.

  3. No Assistente de Tarefas do Exchange, na página Tarefas Disponíveis, clique em Mover Caixa de Correio e clique em Avançar.

  4. Leia cuidadosamente e siga as etapas restantes do assistente.

Para obter mais informações sobre como resolver problemas de fragmentação de memória, consulte os seguintes artigos na Base de Dados de Conhecimento da Microsoft:

  • 325044, "COMO FAZER PARA: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 838233, "Seu computador pode estar lento ou parar de responder, e registrar repetidamente identificadores de evento 9582 e 1160 no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233)

Para obter mais informações sobre como definir limites de tamanho de mensagens, consulte o artigo 322679 da Base de Dados de Conhecimento Microsoft, "Como configurar limites de tamanho para mensagens no Exchange Server" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Para obter mais informações sobre como mover caixas de correio, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328810, "Movendo caixas de correio entre servidores" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810)

  • 821829, "Como mover Caixas de Correio no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829)


VirtualReserveSize é não padrão
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê o valor de Registro a seguir para determinar se a alocação de memória inicial do componente ExIPC (Exchange Interprocess Communication) foi alterada do valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIPC\Parameters\VirtualReserveSize

Se o Exchange Server Analyzer perceber que a chave VirtualReserveSize está presente e configurada com um valor maior que 0, uma mensagem de configuração não padrão é exibida.

O ExIPC é um componente de enfileiramento que permite ao Inetinfo.exe (Serviços de Informações da Internet) e ao Store.exe (serviço de Armazenamento de Informações do Microsoft Exchange) mover os dados rapidamente para a frente e para trás. Geralmente, a alocação de memória inicial padrão para o ExIPC é suficiente. Por padrão, a chave VirtualReserveSize não está presente. Ela deve ser adicionada e configurada somente sob orientação dos Serviços de Consultoria Microsoft ou do Atendimento Microsoft.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\EXIPC\Parameters

  3. Exclua a chave VirtualReserveSize.

  4. Feche o editor do Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange e o Serviço de Administração do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o ExIPC, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 821879, "Definições dos componentes de transporte de chave no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821879).

  • 260995, "XCON: Definições dos componentes de transporte de chave no Exchange Server 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260995).


O intervalo de eventos de memória virtual foi substituído
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a entrada de Registro a seguir para determinar se o limite para registrar um evento referente à fragmentação de memória virtual foi substituído manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Intervalo de atualização de informações da memória virtual

Se o Exchange Server Analyzer verificar que o valor de Registro Intervalo de atualização de informações da memória virtual estiver presente, mas não for igual a 3600, uma mensagem de configuração não padrão será exibida.

Em sistemas do Microsoft Windows® de 32 bits, há dois tipos de memória: memória física (a quantidade de memória real instalada no sistema) e espaço de endereçamento de memória virtual (um espaço de memória virtualizado de 4 gigabytes). Independentemente de quanta memória física esteja instalada no sistema, o tamanho total do espaço do endereço virtual é sempre o mesmo: 4 GB. Embora não seja o caso de todos os aplicativos de 32 bits, para o Exchange Server, o espaço de endereçamento virtual é igual à memória virtual; em outras palavras, os termos são usados alternadamente.

Durante o curso normal de suas operações, o serviço Armazenamento de Informações do Microsoft Exchange, repetidamente, alocará, usará e desalocará memória virtual. Quando a memória virtual é alocada, usada e desalocada freqüentemente, pode acontecer uma fragmentação de memória virtual. A fragmentação da memória virtual é semelhante à fragmentação do sistema de arquivos que pode ocorrer com o passar do tempo. Depois de um tempo, segmentos alocados da memória virtual não estão mais contíguos e o desempenho começa a diminuir. No sistema de arquivos, é possível executar um aplicativo que executa a desfragmentação do sistema de arquivos e, na maioria das vezes, pode fazer isso com o sistema online e sendo acessado. Na fragmentação de memória virtual, não há ferramenta de desfragmentação; em seu lugar, para corrigir o problema, é necessário parar e iniciar o serviço Armazenamento de Informações do Microsoft Exchange ou reiniciar o sistema.

Por padrão, o serviço Armazenamento de Informações do Microsoft Exchange verifica se há memória virtual livre uma vez por hora (por exemplo, a cada 3.600 segundos). O valor de Registro Intervalo de atualização de informações da memória virtual representa uma oportunidade de configuração que permite a um administrador substituir o intervalo padrão de 3.600 segundos. Se você substituir o nível padrão, recomenda-se não definir o valor como menos de 5 minutos (300 segundos).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. No painel direito, exclua o valor de Intervalo de atualização de informações da memória virtual.

  4. Feche o editor de Registro e reinicie o serviço Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Para obter mais informações sobre solução de problemas de fragmentação de memória virtual no Exchange Server 2003 e no Exchange 2000 Server, consulte o artigo 325044 da Base de Dados de Conhecimento Microsoft, "COMO: Solucionar Problemas de Fragmentação da Memória Virtual no Exchange Server 2003 e Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)


Cache de Gravação de Reserva Não Habilitado
Microsoft Exchange Server Analyzer - Artigos > Armazenamento >

Última modificação do tópico: 2006-08-18

O Microsoft® Exchange Server Analyzer Tool determinou que o controlador de matriz de disco não está com o cache de gravação de reserva definido corretamente para as unidades que hospedam os logs de transações.

É recomendável habilitar o cache de gravação de reserva para 100 por cento no controlador de matriz de todas as unidades que hospedam logs de transações. Logs de transações raramente são lidos. Quanto maior a velocidade de gravação disponível a uma unidade de log de transações, melhor o desempenho de um servidor que executa o Exchange Server.

Para corrigir esse aviso

  • Habilite o cache de gravação de reserva.

Para obter mais informações sobre como configurar discos rígidos do servidor Exchange, consulte o artigo 188589 da Base de Dados de Conhecimento da Microsoft, "Controladores e discos rígidos em cache e banco de dados do Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=188589) (em inglês).


Software de terceiros
Microsoft Exchange Server Analyzer - Artigos >

Última modificação do tópico: 2005-11-18

Os artigos desta seção fornecem detalhes sobre o que a ferramenta Microsoft® Exchange Server Analyzer está avaliando em relação a softwares de terceiros. Além disso, esses artigos descrevem que ações você pode executar para resolver avisos, configurações não padrão e erros relacionados a softwares de terceiros localizados pelo Exchange Server Analyzer.


As exclusões da pasta do antivírus não foram configuradas
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta do Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar se Symantec AntiVirus Corporate Edition (Symantec AV) está instalado no Exchange Server, e se RealTime Protection (RTP) está habilitado:

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Storages\Filesystem\RealTimeScan

Se o Exchange Server Analyzer verificar que o valor do Registro HaveExceptionDirs está definido como 0, o Exchange Server Analyzer exibirá um erro. Um valor do Registro HaveExceptionDirs definido como 0 indica que as exclusões de pasta estão desabilitadas.

As exclusões de pasta impedem que pastas específicas sejam verificadas durante uma verificação antivírus em tempo real. Se você não tiver habilitado as exclusões de pasta no Exchange Server, os seguintes problemas poderão ocorrer:

  • Symantec AV RTP pode fornecer relatórios falso positivos em determinados arquivos limpos que são acessados durante a atividade normal do programa.

  • Symantec AV RTP pode relatar incorretamente arquivos infectados no software que a diretiva de segurança da sua corporação já permitir a execução no Exchange Server.

  • Symantec AV RTP pode verificar a estrutura do diretório do Exchange Server e causar detecções de vírus imprecisas, comportamento inesperado no servidor Exchange ou danificar os bancos de dados do Exchange Server.

Importante:
Você nunca deve executar software de verificação baseado em arquivo nos bancos de dados, logs e arquivos temporários do Exchange Server e arquivos de sistema do IIS (Serviços de Informações da Internet) ou na unidade (unidade M) do IFS (Sistema de Arquivos Instaláveis). Configure o software antivírus para evitar a verificação de pastas que contêm esses arquivos.

Você pode executar um software antivírus baseado em arquivo no sistema operacional do computador do Exchange Server e nos arquivos de programas do Exchange Server (a pasta Exchsrvr\Bin). No entanto, não execute o software antivírus baseado em arquivo nos seguintes arquivos e pastas:

  • Bancos de dados do Exchange Server (arquivos .mdb e .stm) e arquivos do log de transações (.log) (local padrão: \Exchsrvr\MDBData)

  • Arquivos .mta do Exchange Server (local padrão: \Exchsrvr\Mtadata)

  • Arquivos de log do controle de mensagens do Exchange Server (local padrão: \Exchsrvr\Server_Name.log)

  • Pastas do servidor virtual (local padrão: \Exchsrvr\Mailroot)

  • Arquivos SRS (Serviço de Replicação de Site) (local padrão: \Exchsrvr\Srsdata)

  • Arquivos de sistema IIS (Internet Information Service) (local padrão: \%SystemRoot%\System32\Inetsrv)

  • Arquivos do Internet Mail Connector (local padrão: \Exchsrvr\IMCData)

  • A pasta de trabalho usada para armazenar arquivos temporários de streaming usados para a conversão de mensagens. Por padrão, essa pasta de trabalho está localizada em \Exchsrvr\MDBData

  • Uma pasta temporária usada com utilitários de manutenção offline, como Eseutil.exe. Por padrão, essa pasta é o local de onde você executa os arquivos .exe, mas isso pode ser configurado ao executar o utilitário.

Você pode executar verificações baseadas em arquivo nas seguintes pastas:

  • Exchsrvr\Address

  • Exchsrvr\Bin

  • Exchsrvr\Exchweb

  • Exchsrvr\Res

  • Exchsrvr\Schema

Para obter informações detalhadas sobre como configurar exclusões na verificação RealTime no Symantec AntiVirus Corporate Edition, consulte o site do antivírus Symantec (http://www.symantec.com).

Observação:
Endereços da Web podem mudar, por isso, talvez você não consiga se conectar ao site ou sites mencionados aqui.

Para obter mais informações sobre como fortificar um ambiente do Exchange Server contra worms e vírus transmitidos por email, consulte "Reduzindo e erradicando vírus de email em um ambiente do Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47587).

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange Server com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros disponíveis para o Exchange Server, consulte os Parceiros do Exchange Server: Site do antivírus (http://go.microsoft.com/fwlink/?linkid=16226).


Antigen está verificando mensagens de replicação de pasta pública
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-03-13

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar se uma pasta pública está presente em cada servidor Exchange. Se o Exchange Server Analyzer detectar que o objeto InformationStore pertence à classe de objeto msExchPublicMDB, o servidor hospedará um armazenamento de pasta pública.

A ferramenta Microsoft® Exchange Server Analyzer também consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version para ANTIGENVSAPI.DLL. Um valor 1517 ou superior na chave Version para ANTIGENVSAPI.DLL indica que o Sybari Antigen para Microsoft Exchange versão 8.0 SR3 ou uma versão posterior está instalado no Exchange Server.

Por último, o Exchange Server Analyzer consulta a seguinte ramificação do Registro para determinar se a chave DoNotScanIPMReplicationMessages está presente e não tem um valor acima de 0:

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen para Exchange\DoNotScanIPMReplicationMessages

O valor da chave DoNotScanIPMReplicationMessages determina se o Sybari Antigen instalado verificará e possivelmente removerá as mensagens de replicação de pastas públicas do Exchange Server. Um valor menor que 1 na chave DoNotScanIPMReplicationMessages significa que o Antigen verificará a presença de vírus nos arquivos winmail.dat. O Exchange Server usa os arquivos Winmail.dat para diversas finalidades, inclusive para facilitar ainda mais a replicação de pastas públicas entre servidores. Se o Antigen modificar qualquer um desses arquivos Winmail.dat, o processo de replicação de pastas públicas falhará.

Se o Exchange Server Analyzer determinar que as seguintes condições existem, o Exchange Server Analyzer exibirá um erro:

  • O Exchange Server está hospendando um ou mais armazenamentos de pastas públicas

  • A compilação 1517 do Sybari Antigen ou uma versão posterior está instalada no servidor

  • A chave DoNotScanIPMReplicationMessages não está presente ou está presente, mas não tem um valor maior que 0.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\Software\Sybari Software\Antigen for Exchange

  3. Se a subchave DoNotScanIPMReplicationMessages já existir no painel da direita, clique duas vezes nessa subchave e defina o valor como 1.

  4. Se a subchave DoNotScanIPMReplicationMessages ainda não existir, clique com o botão direito no painel da direita para criá-la como um novo valor DWORD.

  5. Configure o valor de DoNotScanIPMReplicationMessages com 1.

    Observação:
    Se um vírus for replicado através da replicação de pastas públicas, mesmo que você tenha habilitado essa nova chave do Registro, o Antigen também detectará o vírus no trabalho de verificação em tempo real.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "Exchange e software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841) (página em inglês).

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166) (página em inglês).

  • 306105, "XGEN: Posição da Microsoft sobre soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkId=3052&kbid=306105) (página em inglês).

  • 245822, "Recomendações para solucionar problemas em um computador do Exchange Server com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkId=3052&kbid=245822) (página em inglês).


CA eTrust: Os arquivos EML/LOG/EDB/STM/DAT não estão na lista de exclusão de arquivos em tempo real
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê as entradas de Registro a seguir para obter a lista de extensões de arquivos que foram excluídos da verificação do antivírus eTrust Antivirus da Computer Associates em nível de arquivo em tempo real:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeExtList

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeExtList

Se o Exchange Server Analyzer verificar que o valor de szExcludeDirs não inclui extensões de arquivos que correspondam aos tipos de arquivos de dados do Exchange (.eml, .log, .edb, .stm ou .dat), um aviso será exibido.

eTrust Antivirus é um programa de verificação antivírus no nível de arquivo. Para determinar a versão do eTrust Antivirus instalado no computador com o Exchange Server, faça o seguinte:

  1. Navegue até Iniciar | Programas | eTrust Antivirus e clique em eTrust Antivirus para iniciar o aplicativo.

  2. No menu do aplicativo eTrust Antivirus, clique em Ajuda e clique em Sobre o eTrust Antivirus.

  3. Examine o campo Versão do Produto para determinar a versão do eTrust Antivirus.

Quando você usar verificadores de vírus no nível de arquivo em um computador do Exchange Server, poderão ocorrer os seguintes problemas:

  • Os verificadores de vírus no nível de arquivo verificam um arquivo quando ele é usado ou em um intervalo agendado, e podem bloquear ou colocar em quarentena um arquivo de log ou de banco de dados do Exchange enquanto o Exchange tenta usar o arquivo. Isso pode causar uma falha grave no Exchange Server e também gerar erros de banco de dados.

  • Podem ocorrer mais problemas se você verificar a unidade representada pelo IFS (Sistema de Arquivos Instalável) do Exchange, geralmente a unidade M, com o software de verificação de nível de arquivo.

Independentemente do antivírus no nível de arquivo usado, exclua sempre os seguintes arquivos e pastas dos verificadores de vírus no nível de arquivo:

  • arquivos .eml, .edb, .stm, .log, .dat e .chk.

  • A unidade do Exchange Server representada pelo IFS. Por padrão, é a unidade M.

  • Bancos de dados e arquivos de log do Exchange. Por padrão, eles estão localizados na pasta Exchsrvr\Mdbdata.

  • Os arquivos do Exchange MTA na pasta Exchsrvr\Mtadata.

  • Arquivos de log adicionais, como o arquivo Exchsrvr\server_name.log.

  • A pasta do servidor virtual Exchsrvr\Mailroot.

  • A pasta de trabalho usada para armazenar arquivos temporários de streaming usados para a conversão de mensagens. Por padrão, essa pasta está localizada em \Exchsrvr\MDBData, mas é possível configurar o local.

  • A pasta temporária usada com ferramentas de manutenção offline, como o Eseutil.exe. Por padrão, o arquivo .exe é executado a partir desta pasta, mas você pode configurar o local ao executar a ferramenta.

  • Os arquivos SRS (Serviço de Replicação de Site) na pasta Exchsrvr\Srsdata.

  • Os arquivos de sistema do Microsoft IIS (Serviços de Informações da Internet) na pasta %SystemRoot%\System32\Inetsrv.

  • Os arquivos de trabalho do IIS na pasta %SystemRoot%\IIS Temporary Compressed Files.

Para corrigir esse aviso

  1. Use a interface do usuário do eTrust Antivirus para excluir as pastas e arquivos listados anteriormente da verificação antivírus no nível de arquivo.

  2. Visite o site do CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156) para obter as informações mais recentes sobre como utilizar o eTrust Antivirus em um computador do Exchange Server.

    Observação:
    Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte Parceiros do Exchange: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).

Para obter mais informações sobre os problemas que podem ocorrer se você verificar a unidade IFS, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 298924, "XADM: Não faça backup nem verificação na unidade M do Exchange 2000 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: C1041737 Mensagem de erro exibida quando você monta bancos de dados" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: Itens do calendário desaparecem das pastas do usuário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: A unidade de dados do Exchange não foi excluída da verificação de trabalho manual
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê as seguintes entradas do Registro para obter a lista de diretórios excluídos da verificação manual antivírus no nível de arquivo, no eTrust Antivírus da Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

O Exchange Server Analyzer também lê o valor do atributo MsExchESEParamSystemPath no serviço de diretório do Active Directory®, que é um atributo de grupo de armazenamento que corresponde ao local do arquivo de log do sistema do Exchange.

Se o Exchange Server Analyzer perceber que o valor para szExcludeDirs não inclui o caminho que corresponde ao local do arquivo de dados do sistema do Exchange, um aviso será exibido.

eTrust Antivirus é um programa de verificação antivírus no nível de arquivo. Para determinar a versão do eTrust Antivirus instalada no computador do seu Exchange Server:

  1. Navegue até Iniciar | Programas | eTrust Antivirus e clique em eTrust Antivirus para iniciar o aplicativo.

  2. No menu do aplicativo eTrust Antivirus, clique em Ajuda e clique em Sobre o eTrust Antivirus.

  3. Examine o campo Versão do Produto para determinar a versão do eTrust Antivirus.

Quando você usar verificadores de vírus no nível de arquivo em um computador do Exchange Server, poderão ocorrer os seguintes problemas:

  • Os verificadores de vírus no nível de arquivo verificam um arquivo quando ele é usado ou em um intervalo agendado, e podem bloquear ou colocar em quarentena um arquivo de log ou de banco de dados do Exchange enquanto o Exchange tenta usar o arquivo. Isso pode causar uma falha grave no Exchange Server e também gerar erros de banco de dados.

  • Podem ocorrer mais problemas se você verificar a unidade representada pelo IFS (Sistema de Arquivos Instalável) do Exchange, geralmente a unidade M, com o software de verificação de nível de arquivo.

Independentemente do antivírus no nível de arquivo usado, exclua sempre os seguintes arquivos e pastas dos verificadores de vírus no nível de arquivo:

  • arquivos .eml, .edb, .stm, .log, .dat e .chk.

  • A unidade do Exchange Server representada pelo IFS. Por padrão, é a unidade M.

  • Bancos de dados e arquivos de log do Exchange. Por padrão, eles estão localizados na pasta Exchsrvr\Mdbdata.

  • Os arquivos do Exchange MTA na pasta Exchsrvr\Mtadata.

  • Arquivos de log adicionais, como o arquivo Exchsrvr\server_name.log.

  • A pasta do servidor virtual Exchsrvr\Mailroot.

  • A pasta de trabalho usada para armazenar arquivos temporários de streaming usados para a conversão de mensagens. Por padrão, essa pasta está localizada em \Exchsrvr\MDBData, mas é possível configurar o local.

  • A pasta temporária usada com ferramentas de manutenção offline, como o Eseutil.exe. Por padrão, o arquivo .exe é executado a partir desta pasta, mas você pode configurar o local ao executar a ferramenta.

  • Os arquivos SRS (Serviço de Replicação de Site) na pasta Exchsrvr\Srsdata.

  • Os arquivos de sistema do Microsoft IIS (Serviços de Informações da Internet) na pasta %SystemRoot%\System32\Inetsrv.

  • Os arquivos de trabalho do IIS na pasta %SystemRoot%\IIS Temporary Compressed Files.

Para corrigir esse aviso

  1. Use a interface do usuário do eTrust Antivirus para excluir as pastas e arquivos listados anteriormente da verificação antivírus no nível de arquivo.

  2. Visite o site do CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156) para obter as informações mais recentes sobre como utilizar o eTrust Antivirus em um computador do Exchange Server.

    Observação:
    Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte Parceiros do Exchange: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).

Para obter mais informações sobre os problemas que podem ocorrer se você verificar a unidade IFS, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 298924, "XADM: Não faça backup nem verificação na unidade M do Exchange 2000 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: C1041737 Mensagem de erro exibida quando você monta bancos de dados" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: Itens do calendário desaparecem das pastas do usuário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: A unidade de dados do Exchange não foi excluída da verificação em tempo real
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê as seguintes entradas de Registro para obter a lista dos diretórios que foram excluídos da verificação do antivírus eTrust Antivirus da Computer Associates em nível de arquivo em tempo real:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor do atributo MsExchESEParamSystemPath de cada grupo de armazenamento. Esse atributo representa o caminho dos arquivos de dados do Exchange.

Se o Exchange Server Analyzer perceber que o valor para szExcludeDirs não inclui o caminho que corresponde ao local do arquivo de dados do sistema do Exchange, um aviso será exibido.

eTrust Antivirus é um programa de verificação antivírus no nível de arquivo. Para determinar a versão do eTrust Antivirus instalada no computador do seu Exchange Server:

  1. Navegue até Iniciar | Programas | eTrust Antivirus e clique em eTrust Antivirus para iniciar o aplicativo.

  2. No menu do aplicativo eTrust Antivirus, clique em Ajuda e clique em Sobre o eTrust Antivirus.

  3. Examine o campo Versão do Produto para determinar a versão do eTrust Antivirus.

Quando você usar verificadores de vírus no nível de arquivo em um computador do Exchange Server, poderão ocorrer os seguintes problemas:

  • Os verificadores de vírus no nível de arquivo verificam um arquivo quando ele é usado ou em um intervalo agendado, e podem bloquear ou colocar em quarentena um arquivo de log ou de banco de dados do Exchange enquanto o Exchange tenta usar o arquivo. Isso pode causar uma falha grave no Exchange Server e também gerar erros de banco de dados.

  • Podem ocorrer mais problemas se você verificar a unidade representada pelo IFS (Sistema de Arquivos Instalável) do Exchange, geralmente a unidade M, com o software de verificação de nível de arquivo.

Independentemente do antivírus no nível de arquivo usado, exclua sempre os seguintes arquivos e pastas dos antivírus no nível de arquivo:

  • arquivos .eml, .edb, .stm, .log, .dat e .chk.

  • A unidade do Exchange Server representada pelo IFS. Por padrão, é a unidade M.

  • Bancos de dados e arquivos de log do Exchange. Por padrão, eles estão localizados na pasta Exchsrvr\Mdbdata.

  • Os arquivos do Exchange MTA na pasta Exchsrvr\Mtadata.

  • Arquivos de log adicionais, como o arquivo Exchsrvr\server_name.log.

  • A pasta do servidor virtual Exchsrvr\Mailroot.

  • A pasta de trabalho usada para armazenar arquivos temporários de streaming usados para a conversão de mensagens. Por padrão, essa pasta está localizada em \Exchsrvr\MDBData, mas é possível configurar o local.

  • A pasta temporária usada com ferramentas de manutenção offline, como o Eseutil.exe. Por padrão, o arquivo .exe é executado a partir desta pasta, mas você pode configurar o local ao executar a ferramenta.

  • Os arquivos SRS (Serviço de Replicação de Site) na pasta Exchsrvr\Srsdata.

  • Os arquivos de sistema do Microsoft IIS (Serviços de Informações da Internet) na pasta %SystemRoot%\System32\Inetsrv.

  • Os arquivos de trabalho do IIS na pasta %SystemRoot%\IIS Temporary Compressed Files.

Para corrigir esse aviso

  1. Use a interface do usuário do eTrust Antivirus para excluir as pastas e arquivos listados anteriormente da verificação antivírus no nível de arquivo.

  2. Visite o site do CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156) para obter as informações mais recentes sobre como utilizar o eTrust Antivirus em um computador do Exchange Server.

    Observação:
    Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte Parceiros do Exchange: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).

Para obter mais informações sobre os problemas que podem ocorrer se você verificar a unidade IFS, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 298924, "XADM: Não faça backup nem verificação na unidade M do Exchange 2000 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM:C1041737 Err Msg Displayed When You Mount Databases" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: Itens do calendário desaparecem das pastas do usuário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: O caminho IFS do Exchange não foi excluído da verificação de cargos manual
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê as seguintes entradas do Registro para obter a lista de diretórios excluídos da verificação manual antivírus no nível de arquivo, no eTrust Antivírus da Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

O Analisador do Exchange Server também lê a seguinte entrada do Registro para obter a letra da unidade que representa a unidade IFS (Sistema de Arquivos Instalável) do Exchange:

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

No Exchange 2000 Server, a letra da unidade padrão é M. A unidade IFS está desligada por padrão no Exchange Server 2003.

Se o Analisador do Exchange Server detectar que o valor de szExcludeDirs não inclui o caminho correspondente à unidade IFS, será exibido um aviso.

eTrust Antivirus é um programa de verificação antivírus no nível de arquivo. Para determinar a versão do eTrust Antivirus instalado no computador com o Exchange Server, faça o seguinte:

  1. Navegue até Iniciar | Programas | eTrust Antivirus e clique em eTrust Antivirus para iniciar o aplicativo.

  2. No menu do aplicativo eTrust Antivirus, clique em Ajuda e clique em Sobre o eTrust Antivirus.

  3. Examine o campo Versão do Produto para determinar a versão do eTrust Antivirus.

Quando você usar verificadores de vírus no nível de arquivo em um computador do Exchange Server, poderão ocorrer os seguintes problemas:

  • Os verificadores de vírus no nível de arquivo verificam um arquivo quando ele é usado ou em um intervalo agendado, e podem bloquear ou colocar em quarentena um arquivo de log ou de banco de dados do Exchange enquanto o Exchange tenta usar o arquivo. Isso pode causar uma falha grave no Exchange Server e também gerar erros de banco de dados.

  • Poderão ocorrer outros problemas se você verificar a unidade representada pelo IFS, geralmente a unidade M, com um software verificador de vírus no nível de arquivo.

Independentemente do antivírus no nível de arquivo usado, exclua sempre os seguintes arquivos e pastas dos verificadores de vírus no nível de arquivo:

  • arquivos .eml, .edb, .stm, .log, .dat e .chk.

  • A unidade do Exchange Server representada pelo IFS. Por padrão, é a unidade M.

  • Bancos de dados e arquivos de log do Exchange. Por padrão, eles estão localizados na pasta Exchsrvr\Mdbdata.

  • Os arquivos do Exchange MTA na pasta Exchsrvr\Mtadata.

  • Arquivos de log adicionais, como o arquivo Exchsrvr\server_name.log.

  • A pasta do servidor virtual Exchsrvr\Mailroot.

  • A pasta de trabalho usada para armazenar arquivos temporários de streaming usados para a conversão de mensagens. Por padrão, essa pasta está localizada em \Exchsrvr\MDBData, mas é possível configurar o local.

  • A pasta temporária usada com ferramentas de manutenção offline, como o Eseutil.exe. Por padrão, o arquivo .exe é executado a partir desta pasta, mas você pode configurar o local ao executar a ferramenta.

  • Os arquivos SRS (Serviço de Replicação de Site) na pasta Exchsrvr\Srsdata.

  • Os arquivos de sistema do Microsoft IIS (Serviços de Informações da Internet) na pasta %SystemRoot%\System32\Inetsrv.

  • Os arquivos de trabalho do IIS na pasta %SystemRoot%\IIS Temporary Compressed Files.

Para corrigir esse aviso

  1. Use a interface do usuário do eTrust Antivirus para excluir as pastas e arquivos listados anteriormente da verificação antivírus no nível de arquivo.

  2. Visite o site do eTrust Antivirus da Computer Associates (http://www3.ca.com/Solutions/Product.asp?ID=156) para obter as informações mais recentes sobre como usar o eTrust Antivirus em um computador com o Exchange Server.

    Observação:
    Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte Parceiros do Exchange: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).

Para obter mais informações sobre os problemas que podem ocorrer se você verificar a unidade IFS, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 298924, "XADM: Não faça backup nem verificação na unidade M do Exchange 2000 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: C1041737 Mensagem de erro exibida quando você monta bancos de dados" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: Itens do calendário desaparecem das pastas do usuário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: O caminho IFS do Exchange não foi excluído da verificação em tempo real
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê as seguintes entradas de Registro para obter a lista de diretórios que foram excluídos da verificação antivírus em nível de arquivo em tempo real no eTrust Antivirus da Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

O Analisador do Exchange Server também lê a seguinte entrada do Registro para obter a letra da unidade que representa a unidade IFS (Sistema de Arquivos Instalável) do Exchange:

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

No Exchange 2000 Server, a letra da unidade padrão é M. Por padrão, a unidade IFS fica desativada no Exchange Server 2003.

Se o Analisador do Exchange Server detectar que o valor de szExcludeDirs não inclui o caminho correspondente à unidade IFS, será exibido um aviso.

eTrust Antivirus é um programa de verificação antivírus no nível de arquivo. Para determinar a versão do eTrust Antivirus instalado no computador com o Exchange Server, faça o seguinte:

  1. Navegue até Iniciar | Programas | eTrust Antivirus e clique em eTrust Antivirus para iniciar o aplicativo.

  2. No menu do aplicativo eTrust Antivirus, clique em Ajuda e clique em Sobre o eTrust Antivirus.

  3. Examine o campo Versão do Produto para determinar a versão do eTrust Antivirus.

Quando você usar verificadores de vírus no nível de arquivo em um computador do Exchange Server, poderão ocorrer os seguintes problemas:

  • Os verificadores de vírus no nível de arquivo verificam um arquivo quando ele é usado ou em um intervalo agendado, e podem bloquear ou colocar em quarentena um arquivo de log ou de banco de dados do Exchange enquanto o Exchange tenta usar o arquivo. Isso pode causar uma falha grave no Exchange Server e também gerar erros de banco de dados.

  • Poderão ocorrer outros problemas se você verificar a unidade representada pelo IFS, geralmente a unidade M, com um software verificador de vírus no nível de arquivo.

Independentemente do antivírus no nível de arquivo usado, exclua sempre os seguintes arquivos e pastas dos verificadores de vírus no nível de arquivo:

  • arquivos .eml, .edb, .stm, .log, .dat e .chk.

  • A unidade do Exchange Server representada pelo IFS. Por padrão, é a unidade M.

  • Bancos de dados e arquivos de log do Exchange. Por padrão, eles estão localizados na pasta Exchsrvr\Mdbdata.

  • Os arquivos do Exchange MTA na pasta Exchsrvr\Mtadata.

  • Arquivos de log adicionais, como o arquivo Exchsrvr\server_name.log.

  • A pasta do servidor virtual Exchsrvr\Mailroot.

  • A pasta de trabalho usada para armazenar arquivos temporários de streaming usados para a conversão de mensagens. Por padrão, essa pasta está localizada em \Exchsrvr\MDBData, mas é possível configurar o local.

  • A pasta temporária usada com ferramentas de manutenção offline, como o Eseutil.exe. Por padrão, o arquivo .exe é executado a partir desta pasta, mas você pode configurar o local ao executar a ferramenta.

  • Os arquivos SRS (Serviço de Replicação de Site) na pasta Exchsrvr\Srsdata.

  • Os arquivos de sistema do Microsoft IIS (Serviços de Informações da Internet) na pasta %SystemRoot%\System32\Inetsrv.

  • Os arquivos de trabalho do IIS na pasta %SystemRoot%\IIS Temporary Compressed Files.

Para corrigir esse aviso

  1. Use a interface do usuário do eTrust Antivirus para excluir as pastas e arquivos listados anteriormente da verificação antivírus no nível de arquivo.

  2. Visite o site do CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156) para obter as informações mais recentes sobre como utilizar o eTrust Antivirus em um computador do Exchange Server.

    Observação:
    Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte Parceiros do Exchange: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).

Para obter mais informações sobre os problemas que podem ocorrer se você verificar a unidade IFS, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 298924, "XADM: Não faça backup nem verificação na unidade M do Exchange 2000 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: C1041737 Mensagem de erro exibida quando você monta bancos de dados" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: Itens do calendário desaparecem das pastas do usuário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: A verificação em tempo real está definida para verificar todos os arquivos, independentemente da extensão
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-04-21

A ferramenta Microsoft® Exchange Server Analyzer Tool lê as entradas de Registro a seguir para obter a lista de extensões de nome de arquivo que foram excluídas da verificação antivírus de nível de arquivo em tempo real no eTrust Antivirus da Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\dwFileFilterType

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\dwFileFilterType

Se o Exchange Server Analyzer determinar que o valor de dwFileFilterType está configurado para verificar todos os arquivos, independentemente da extensão, um aviso será exibido.

eTrust Antivirus é um programa de verificação antivírus no nível de arquivo. Para determinar a versão do eTrust Antivirus instalado no computador com o Exchange Server, faça o seguinte:

  1. Navegue até Iniciar | Programas | eTrust Antivirus e clique em eTrust Antivirus para iniciar o aplicativo.

  2. No menu do aplicativo eTrust Antivirus, clique em Ajuda e clique em Sobre o eTrust Antivirus.

  3. Examine o campo Versão do Produto para determinar a versão do eTrust Antivirus.

Quando você usar scanners de vírus no nível de arquivo em um computador do Exchange Server, poderão ocorrer os seguintes problemas:

  • Os verificadores de vírus no nível de arquivo verificam um arquivo quando ele é usado ou em um intervalo agendado, e podem bloquear ou colocar em quarentena um arquivo de log ou de banco de dados do Exchange enquanto o Exchange tenta usar o arquivo. Isso pode causar uma falha grave no Exchange Server e também gerar erros de banco de dados.

  • Podem ocorrer mais problemas se você verificar a unidade representada pelo IFS (Sistema de Arquivos Instalável) do Exchange, geralmente a unidade M, com o software de verificação de nível de arquivo.

Independentemente do antivírus no nível de arquivo usado, exclua sempre os seguintes arquivos e pastas dos verificadores de vírus no nível de arquivo:

  • arquivos .eml, .edb, .stm, .log, .dat e .chk.

  • A unidade do Exchange Server representada pelo IFS. Por padrão, é a unidade M: .

  • Bancos de dados e arquivos de log do Exchange. Por padrão, eles estão localizados na pasta Exchsrvr\Mdbdata.

  • Os arquivos do Exchange MTA na pasta Exchsrvr\Mtadata.

  • Arquivos de log adicionais, como o arquivo Exchsrvr\server_name.log.

  • A pasta do servidor virtual Exchsrvr\Mailroot.

  • A pasta de trabalho usada para armazenar arquivos temporários de streaming usados para a conversão de mensagens. Por padrão, essa pasta está localizada em \Exchsrvr\MDBData, mas é possível configurar o local.

  • A pasta temporária usada com ferramentas de manutenção offline, como o Eseutil.exe. Por padrão, o arquivo .exe é executado a partir desta pasta, mas você pode configurar o local ao executar a ferramenta.

  • Os arquivos SRS (Serviço de Replicação de Site) na pasta Exchsrvr\Srsdata.

  • Os arquivos de sistema do Microsoft IIS (Serviços de Informações da Internet) na pasta %SystemRoot%\System32\Inetsrv.

  • Os arquivos de trabalho do IIS na pasta %SystemRoot%\IIS Temporary Compressed Files.

Para corrigir esse aviso

  1. Use a interface do usuário do eTrust Antivirus para excluir as pastas e os arquivos listados da verificação antivírus no nível de arquivo.

  2. Visite o site do CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156) para obter as informações mais recentes sobre como utilizar o eTrust Antivirus em um computador do Exchange Server.

    Observação:
    Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte Parceiros do Exchange: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).

Para obter mais informações sobre os problemas que podem ocorrer se você verificar a unidade IFS, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 298924, "XADM: Não faça backup nem verificação na unidade M do Exchange 2000 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM:C1041737 Err Msg Displayed When You Mount Databases" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: Itens do calendário desaparecem das pastas do usuário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: A unidade do Grupo de Armazenamento não foi excluída da verificação de trabalho manual
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê as seguintes entradas do Registro para obter a lista de diretórios excluídos da verificação manual antivírus no nível de arquivo, no eTrust Antivírus da Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

O Exchange Server Analyzer também lê o valor do atributo MsExchESEParamSystemPath no serviço de diretório do Active Directory®, que é um atributo de grupo de armazenamento que corresponde ao local do arquivo de log do sistema do Exchange.

Se o Exchange Server Analyzer verificar que o valor de szExcludeDirs não inclui o caminho que corresponde ao local do arquivo de log do sistema do Exchange, um aviso será exibido.

eTrust Antivirus é um programa de verificação antivírus no nível de arquivo. Para determinar a versão do eTrust Antivirus instalado no computador do Exchange Server, faça o seguinte:

  1. Navegue até Iniciar | Programas | eTrust Antivirus e clique em eTrust Antivirus para iniciar o aplicativo.

  2. No menu do aplicativo eTrust Antivirus, clique em Ajuda e clique em Sobre o eTrust Antivirus.

  3. Examine o campo Versão do Produto para determinar a versão do eTrust Antivirus.

Quando você usar verificadores de vírus no nível de arquivo em um computador do Exchange Server, poderão ocorrer os seguintes problemas:

  • Os verificadores de vírus no nível de arquivo verificam um arquivo quando ele é usado ou em um intervalo agendado, e podem bloquear ou colocar em quarentena um arquivo de log ou de banco de dados do Exchange enquanto o Exchange tenta usar o arquivo. Isso pode causar uma falha grave no Exchange Server e também gerar erros de banco de dados.

  • Podem ocorrer mais problemas se você verificar a unidade representada pelo IFS (Sistema de Arquivos Instalável) do Exchange, geralmente a unidade M, com o software de verificação de nível de arquivo.

Independentemente do antivírus no nível de arquivo usado, exclua sempre os seguintes arquivos e pastas dos verificadores de vírus no nível de arquivo:

  • arquivos .eml, .edb, .stm, .log, .dat e .chk.

  • A unidade do Exchange Server representada pelo IFS. Por padrão, é a unidade M.

  • Bancos de dados e arquivos de log do Exchange. Por padrão, eles estão localizados na pasta Exchsrvr\Mdbdata.

  • Os arquivos do Exchange MTA na pasta Exchsrvr\Mtadata.

  • Arquivos de log adicionais, como o arquivo Exchsrvr\server_name.log.

  • A pasta do servidor virtual Exchsrvr\Mailroot.

  • A pasta de trabalho usada para armazenar arquivos temporários de streaming usados para a conversão de mensagens. Por padrão, essa pasta está localizada em \Exchsrvr\MDBData, mas é possível configurar o local.

  • A pasta temporária usada com ferramentas de manutenção offline, como o Eseutil.exe. Por padrão, o arquivo .exe é executado a partir desta pasta, mas você pode configurar o local ao executar a ferramenta.

  • Os arquivos SRS (Serviço de Replicação de Site) na pasta Exchsrvr\Srsdata.

  • Os arquivos de sistema do Microsoft IIS (Serviços de Informações da Internet) na pasta %SystemRoot%\System32\Inetsrv.

  • Os arquivos de trabalho do IIS na pasta %SystemRoot%\IIS Temporary Compressed Files.

Para corrigir esse aviso

  1. Use a interface do usuário do eTrust Antivirus para excluir as pastas e arquivos listados anteriormente da verificação antivírus no nível de arquivo.

  2. Visite o site do eTrust Antivirus da Computer Associates (http://www3.ca.com/Solutions/Product.asp?ID=156) para obter as informações mais recentes sobre como usar o eTrust Antivirus em um computador com o Exchange Server.

    Observação:
    Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

  • Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte Parceiros do Exchange: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).

Para obter mais informações sobre os problemas que podem ocorrer se você verificar a unidade IFS, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 298924, "XADM: Não faça backup nem verificação na unidade M do Exchange 2000 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: C1041737 Mensagem de erro exibida quando você monta bancos de dados" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: Itens do calendário desaparecem das pastas do usuário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: A unidade do Grupo de Armazenamento não foi excluída da verificação em tempo real
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê as seguintes entradas de Registro para obter a lista dos diretórios que foram excluídos da verificação do antivírus eTrust Antivirus da Computer Associates em nível de arquivo em tempo real:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

O Exchange Server Analyzer consulta também o valor do atributo MsExchESEParamSystemPath no serviço de diretório do Active Directory®, que é um atributo de grupo de armazenamento que corresponde ao local do arquivo de dados do sistema Exchange.

Se o Exchange Server Analyzer perceber que o valor para szExcludeDirs não inclui o caminho que corresponde ao local do arquivo de dados do sistema do Exchange, um aviso será exibido.

eTrust Antivirus é um programa de verificação antivírus no nível de arquivo. Para determinar a versão do eTrust Antivirus instalada no computador do seu Exchange Server:

  1. Navegue até Iniciar | Programas | eTrust Antivirus e clique em eTrust Antivirus para iniciar o aplicativo.

  2. No menu do aplicativo eTrust Antivirus, clique em Ajuda e clique em Sobre o eTrust Antivirus.

  3. Examine o campo Versão do Produto para determinar a versão do eTrust Antivirus.

Quando você usar verificadores de vírus no nível de arquivo em um computador do Exchange Server, poderão ocorrer os seguintes problemas:

  • Os verificadores de vírus no nível de arquivo verificam um arquivo quando ele é usado ou em um intervalo agendado, e podem bloquear ou colocar em quarentena um arquivo de log ou de banco de dados do Exchange enquanto o Exchange tenta usar o arquivo. Isso pode causar uma falha grave no Exchange Server e também gerar erros de banco de dados.

  • Podem ocorrer mais problemas se você verificar a unidade representada pelo IFS (Sistema de Arquivos Instalável) do Exchange, geralmente a unidade M, com o software de verificação de nível de arquivo.

Independentemente do antivírus no nível de arquivo usado, exclua sempre os seguintes arquivos e pastas dos verificadores de vírus no nível de arquivo:

  • arquivos .eml, .edb, .stm, .log, .dat e .chk.

  • A unidade do Exchange Server representada pelo IFS. Por padrão, é a unidade M.

  • Bancos de dados e arquivos de log do Exchange. Por padrão, eles estão localizados na pasta Exchsrvr\Mdbdata.

  • Os arquivos do Exchange MTA na pasta Exchsrvr\Mtadata.

  • Arquivos de log adicionais, como o arquivo Exchsrvr\server_name.log.

  • A pasta do servidor virtual Exchsrvr\Mailroot.

  • A pasta de trabalho usada para armazenar arquivos temporários de streaming usados para a conversão de mensagens. Por padrão, essa pasta está localizada em \Exchsrvr\MDBData, mas é possível configurar o local.

  • A pasta temporária usada com ferramentas de manutenção offline, como o Eseutil.exe. Por padrão, o arquivo .exe é executado a partir desta pasta, mas você pode configurar o local ao executar a ferramenta.

  • Os arquivos SRS (Serviço de Replicação de Site) na pasta Exchsrvr\Srsdata.

  • Os arquivos de sistema do Microsoft IIS (Serviços de Informações da Internet) na pasta %SystemRoot%\System32\Inetsrv.

  • Os arquivos de trabalho do IIS na pasta %SystemRoot%\IIS Temporary Compressed Files.

Para corrigir esse aviso

  1. Use a interface do usuário do eTrust Antivirus para excluir as pastas e arquivos listados anteriormente da verificação antivírus no nível de arquivo.

  2. Visite o site do CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156) para obter as informações mais recentes sobre como utilizar o eTrust Antivirus em um computador do Exchange Server.

    Observação:
    Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte Parceiros do Exchange: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).

Para obter mais informações sobre os problemas que podem ocorrer se você verificar a unidade IFS, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 298924, "XADM: Não faça backup nem verificação na unidade M do Exchange 2000 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: C1041737 Mensagem de erro exibida quando você monta bancos de dados" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: Itens do calendário desaparecem das pastas do usuário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: O processo do Exchange não foi excluído da verificação em tempo real
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê as entradas de Registro a seguir para obter a lista de processos que foram excluídos da verificação antivírus em nível de arquivo em tempo real no eTrust Antivirus da Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\RealTime\szExcludeProcessNames

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeProcessNames

Se o Exchange Server Analyzer detectar que o valor de szExcludeProcessNames não inclui STORE.EXE, EMSMTA.EXE e MAD.EXE, um aviso será exibido.

É recomendável não verificar os processos de Armazenamento de Informações do Microsoft Exchange (Store.exe), de MTA do Exchange (Emsmta.exe) e do Atendedor do Sistema (Mad.exe) com um scanner antivírus com base em nível de arquivo enquanto esses processos estiverem em execução.

eTrust Antivirus é um programa de verificação antivírus no nível de arquivo. Para determinar a versão do eTrust Antivirus instalado no computador com o Exchange Server, faça o seguinte:

  1. Navegue até Iniciar | Programas | eTrust Antivirus e clique em eTrust Antivirus para iniciar o aplicativo.

  2. No menu do aplicativo eTrust Antivirus, clique em Ajuda e clique em Sobre o eTrust Antivirus.

  3. Examine o campo Versão do Produto para determinar a versão do eTrust Antivirus.

Quando você usar verificadores de vírus no nível de arquivo em um computador do Exchange Server, poderão ocorrer os seguintes problemas:

  • Os verificadores de vírus no nível de arquivo verificam um arquivo quando ele é usado ou em um intervalo agendado, e podem bloquear ou colocar em quarentena um arquivo de log ou de banco de dados do Exchange enquanto o Exchange tenta usar o arquivo. Isso pode causar uma falha grave no Exchange Server e também gerar erros de banco de dados.

  • Poderão ocorrer outros problemas se você verificar a unidade representada pelo IFS, geralmente a unidade M, com um software verificador de vírus no nível de arquivo.

Independentemente do antivírus no nível de arquivo usado, exclua sempre os seguintes arquivos e pastas dos verificadores de vírus no nível de arquivo:

  • arquivos .eml, .edb, .stm, .log, .dat e .chk.

  • A unidade do Exchange Server representada pelo IFS. Por padrão, é a unidade M.

  • Bancos de dados e arquivos de log do Exchange. Por padrão, eles estão localizados na pasta Exchsrvr\Mdbdata.

  • Os arquivos do Exchange MTA na pasta Exchsrvr\Mtadata.

  • Arquivos de log adicionais, como o arquivo Exchsrvr\server_name.log.

  • A pasta do servidor virtual Exchsrvr\Mailroot.

  • A pasta de trabalho usada para armazenar arquivos temporários de streaming usados para a conversão de mensagens. Por padrão, essa pasta está localizada em \Exchsrvr\MDBData, mas é possível configurar o local.

  • A pasta temporária usada com ferramentas de manutenção offline, como o Eseutil.exe. Por padrão, o arquivo .exe é executado a partir desta pasta, mas você pode configurar o local ao executar a ferramenta.

  • Os arquivos SRS (Serviço de Replicação de Site) na pasta Exchsrvr\Srsdata.

  • Os arquivos de sistema do Microsoft IIS (Serviços de Informações da Internet) na pasta %SystemRoot%\System32\Inetsrv.

  • Os arquivos de trabalho do IIS na pasta %SystemRoot%\IIS Temporary Compressed Files.

Para corrigir esse aviso

  1. Use a interface do usuário do eTrust Antivirus para excluir as pastas e arquivos listados anteriormente da verificação antivírus no nível de arquivo.

  2. Visite o site do eTrust Antivirus da Computer Associates (http://www3.ca.com/Solutions/Product.asp?ID=156) para obter as informações mais recentes sobre como usar o eTrust Antivirus em um computador com o Exchange Server.

    Observação:
    Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte Parceiros do Exchange: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).

Para obter mais informações sobre os problemas que podem ocorrer se você verificar a unidade IFS, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 298924, "XADM: Não faça backup nem verificação na unidade M do Exchange 2000 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, "XADM: C1041737 Mensagem de erro exibida quando você monta bancos de dados" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, "XADM: Itens do calendário desaparecem das pastas do usuário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


Atualização de Segurança de Mensagens do Serviço de Cliente para SMB v2.0 disponível
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro:

HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Um valor de Versão igual a 6.2100 indica que a Segurança de Mensagens do Serviço ao Cliente para SMB v2.0 do Trend Micro ScanMail está instalada.

O Analisador do Microsoft® Exchange Server consulta também a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile para determinar a versão da Segurança de Mensagens do Serviço ao Cliente para SMB v2.0 que está instalada. Se o número de compilação principal for menor que 1145, o Analisador do Exchange Server exibirá um aviso.

Esse aviso indica que a Segurança de Mensagens do Serviço ao Cliente para SMB v2.0 está instalada no servidor Exchange e que uma atualização de software recomendada está disponível. A atualização recomendada é a Segurança de Mensagens do Serviço ao Cliente para SMB v2.0 Patch 2 do Componente de Mensagens. Essa atualização é altamente recomendável e pode melhorar o desempenho e a confiabilidade gerais do servidor.

Para corrigir esse aviso

  1. Visite o Trend Micro Update Center da Segurança de Mensagens do Serviço ao Cliente para SMB (http://www.trendmicro.com/download/product.asp?productid=39).

  2. Faça download e instale o Patch 2.
Observação:
As informações sobre sites de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.

Para obter mais informações sobre outras atualizações de produtos Trend Micro, consulte o site Trend Micro Update Center (http://www.trendmicro.com/download/).

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, Exchange e software antivírus (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, Visão geral do Exchange Server 2003 e do software antivírus (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, XGEN: Posição da Microsoft sobre soluções antivírus para o Exchange 2000 (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, Recomendações para solucionar problemas em um computador do Exchange Server com software antivírus instalado (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros disponíveis para o Exchange Server, consulte Parceiros do Exchange Server: Antivírus (em inglês) (http://go.microsoft.com/fwlink/?linkid=16226).


Considere instalar o HP Command View EVAPerf
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-09

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_SCSIController para determinar o valor da chave Name. Se o valor da chave Name for Compaq HSV110CCL, isso significa que pelo menos um volume de disco no servidor está sendo apresentado por uma SAN (rede de área de armazenamento) de HP EVA.

O Analisador do Exchange Server consulta a também a classe WMI Win32_Service para determinar o valor da chave Started do serviço EVSPDCS (HP StorageWorks Command View EVAPerf). Um valor False indica que o serviço não está sendo executado. Um valor True indica que o serviço está sendo executado.

O Analisador do Exchange Server exibirá uma sugestão de prática recomendada se as duas seguintes condições existirem:

  • Pelo menos um volume de disco no servidor está sendo apresentado por uma SAN de HP EVA.

  • O serviço EVSPDCS (HP StorageWorks Command View EVAPerf) não está presente ou em execução.

A HP fornece um aplicativo gratuito de gerenciamento de software que publica contadores de desempenho adicionais para SANs de HP StorageWorks. Os administradores podem usar esse aplicativo de gerenciamento de software para monitorar o desempenho de controladores e discos físicos individuais na SAN.

Para seguir a prática recomendada

  1. Acesse o site do Software HP StorageWorks Command View EVAPerf para baixar o aplicativo HP Command View EVAPerf (http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005).

    Observação:
    As informações sobre sites de terceiros são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.

  2. Execute o arquivo executável de auto-extração que você transferiu e siga as instruções para instalar o aplicativo.


O Serviço EMC PowerPath está parado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar o valor da chave Iniciado para o serviço EMC PowerPath Service. Um valor Verdadeiro indica que o Serviço EMC PowerPath está em execução e um valor Falso indica que o Serviço EMC PowerPath não está em execução. Se o Analisador do Exchange Server detectar que o valor da chave Iniciado é Falso, um aviso será exibido.

O EMC PowerPath é um software de E/S (MPIO) de vários caminhos. A definição de vários caminhos fornece acesso de dados de alta disponibilidade, permitindo que um host tenha até 32 caminhos para acessar um dispositivo de armazenamento externo, o que facilita o failover e o balanceamento de carga. A definição de vários caminhos não é um recurso do sistema operacional, mas tem suporte através do DDK (Driver Development Kit) MPIO, que fornece uma maneira para que os fornecedores de armazenamento criem soluções interoperáveis de vários caminhos.

Quando o software MPIO está em execução, o Microsoft Windows® detecta apenas uma única unidade enquanto o software MPIO gerencia as várias conexões a vários dispositivos de armazenamento. Se o software MPIO for interrompido, o Windows detectará todas as unidades de armazenamento anexadas como unidades independentes. Isso provavelmente causará erros e mau funcionamento do armazenamento.

Para iniciar o serviço EMC PowerPath

  1. Abra o snap-in Serviços do MMC.

  2. Clique com o botão direito no Serviço EMC PowerPath e clique em Propriedades.

  3. Na guia Geral da página de propriedades do Serviço EMC PowerPath, certifique-se de que Tipo de Inicialização está definido como Automático. Se não estiver, clique em Aplicar e clique em OK.

  4. Clique com o botão direito no Serviço EMC PowerPath e clique em Iniciar.

  5. Feche o snap-in Serviços.

Para obter informações gerais sobre como implantar diferentes tecnologias de armazenamento com o Windows, consulte "Planejando para usar os recursos de armazenamento do Windows com SANs" (http://go.microsoft.com/fwlink/?LinkId=33626).


EMC PowerPath Version Mismatch Between Cluster Nodes
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2007-07-25

A ferramenta Microsoft Exchange Analyzer lê a seguinte entrada do Registro para determinar qual versão do EMC PowerPath está instalada em cada nó do cluster:

HKEY_LOCAL_MACHINE\SOFTWARE\EMC\PowerPath\Version

Se o Exchange Analyzer detectar que o valor do segundo nó ou do nó subseqüente no cluster do Exchange é diferente para Version em relação ao valor para Version no primeiro nó do cluster do Exchange, será exibido um erro.

Esse erro indica que os nós nesse cluster do Exchange não estão sendo executados no mesmo nível do driver do EMC PowerPath. Recomendamos que todos os nós em um cluster do Exchange sejam executados no mesmo nível de driver do EMC PowerPath.

O EMC PowerPath é um software de E/S (MPIO) de vários caminhos. A definição de vários caminhos fornece acesso de dados de alta disponibilidade, permitindo que um host tenha até 32 caminhos para acessar um dispositivo de armazenamento externo, o que facilita o failover e o balanceamento de carga. A definição de vários caminhos não é um recurso do sistema operacional, mas tem suporte através do DDK (Driver Development Kit) MPIO, que fornece uma maneira para que os fornecedores de armazenamento criem soluções interoperáveis de vários caminhos.

Quando o software MPIO está em execução, o Microsoft Windows detecta apenas uma única unidade, enquanto o software MPIO gerencia as várias conexões para vários dispositivos de armazenamento. Se o driver MPIO não for compatível entre diferentes nós do cluster, ele poderá levar a problemas de failover do cluster.

Para resolver esse problema, você deve atualizar todos os nós para a mesma versão do driver do EMC PowerPath.

Para obter mais informações

Para obter mais informações sobre como implantar diferentes tecnologias de armazenamento com o Windows, consulte "Planning to Use Windows Storage Features with SANs" (http://go.microsoft.com/fwlink/?LinkId=33626).


O driver de Porta Emulex FC não foi atualizado há mais de dois anos
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-04-19

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_SCSIController do WMI (Instrumentação de Gerenciamento do Microsoft® Windows® para determinar se um valor está definido para a chave DriverName. A ferramenta Exchange Server Analyzer Tool determina se as seguintes condições existem:

  • O driver da Porta Emulex FC está instalado no servidor Exchange.

  • A versão atual do driver da Porta Emulex FC está instalada no servidor Exchange.

  • O driver da Porta Emulex FC foi atualizado nos últimos dois anos.

Se o Exchange Server Analyzer considerar que o valor para a chave DriverName não foi atualizado em mais de dois anos, o Exchange Server Analyzer exibirá um aviso.

O driver da Porta Emulex FC fornece funcionalidade apenas SCSI ou SCSI e IP simultaneamente em um único HBA (Host Bus Adapter) ou vários HBAs. O driver da Porta FC aceita as topologias FC-AL (Fibre Channel Arbitrated Loop), topologias ponto a ponto e topologias de malha. O driver da Porta FC é projetado para aplicativos especializados que exigem mapeamento de LUN (Número de Unidades Lógicas) ou ligação persistente.

Para atualizar o driver da Porta Emulex FC, consulte Downloads e Manuais para Windows (http://www.emulex.com/ts/docfc/winframe.htm). Se você precisar de drivers OEM especiais, consulte o site de software e documentação da Emulex (http://www.emulex.com/ts/index.html).

Observação:
As informações sobre sites da Web de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


O driver Emulex SCSIport Miniport não foi atualizado em mais de dois anos
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-06-14

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_SCSIController do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se há um valor definido para a chave DriverName. A ferramenta Exchange Server Analyzer Tool determina se as seguintes condições existem:

  • O driver Emulex SCSIport Miniport está instalada no servidor Exchange.

  • A versão atual do driver Emulex SCSIport Miniport está instalada no servidor Exchange.

  • O driver Emulex SCSIport Miniport foi atualizado nos últimos dois anos.

Se o Exchange Server Analyzer considerar que o valor para a chave DriverName não foi atualizado em mais de dois anos, o Exchange Server Analyzer exibirá um aviso.

O driver SCSIport Miniport fornece funcionalidades SCSI sobre topologias de loop arbitrado de Fibre Channel (FC-AL), topologias ponto a ponto e topologias de tecido.

Para atualizar o driver Emulex SCSIport Miniport, consulte Downloads e Manuais para o Windows (http://www.emulex.com/ts/docfc/winframe.htm). Se você precisar de drivers OEM especiais, consulte a documentação e software OEM (http://www.emulex.com/ts/index.html).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


O driver Emulex Storport Miniport não foi atualizado em mais de dois anos
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-06-14

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_SCSIController do WMI (Instrumentação de Gerenciamento do Microsoft® Windows® para determinar se um valor está definido para a chave DriverName. A ferramenta Exchange Server Analyzer Tool determina se as seguintes condições existem:

  • O driver da miniporta do Emulex Storport está instalado no servidor Exchange.

  • A versão atual do driver da miniporta do Emulex Storport está instalada no servidor Exchange.

  • O driver da miniporta do Emulex Storport foi atualizado nos últimos dois anos.

Se o Exchange Server Analyzer considerar que o valor para a chave DriverName não foi atualizado em mais de dois anos, o Exchange Server Analyzer exibirá um aviso.

O driver da miniporta do Emulex Storport otimiza o desempenho e a capacidade de gerenciamento das SANs (Redes de Área de Armazenamento) e das matrizes de disco baseadas em hardware. O driver da miniporta do Emulex Storport oferece suporte às topologias FC-AL (loop arbitrado de Fibre Channel), de ponto a ponto e de malha.

Para atualizar o driver da miniporta do Emulex Storport, consulte Downloads e manuais para o Windows (http://www.emulex.com/ts/docfc/winframe.htm). Se você precisar de drivers OEM especiais, consulte a documentação e software OEM (http://www.emulex.com/ts/index.html).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


Alto uso de CPU em processo que não é do Exchange
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

  • A ferramenta Microsoft® Exchange Server Analyzer localizou um processo do servidor não-Exchange que está utilizando no momento mais de 20 % da CPU disponível do servidor. Se um processo do servidor não-Exchange estiver usando mais de 20 % da CPU disponível, será exibido um erro.

  • É recomendável que os servidores que executam o Exchange Server sejam dedicados ao Exchange Server sempre que possível e executem o mínimo possível de aplicativos e serviços fora do Exchange.

Para corrigir esse erro

  • Se outro processo usar a maior parte da CPU, tente uma das seguintes opções:

    • Desative o processo e verifique se o problema foi sanado.

    • Mova esse processo para outro servidor, se possível.

    • Verifique se o processo está configurado corretamente e procure atualizações da Microsoft e o provedor do processo que trata esse problema.

    • Desinstale o processo, se você não precisar dele.

  • Se o processo não puder ser movido ou corrigido, o servidor deverá ser escalado novamente para permitir a carga adicionada do processo do servidor não-Exchange. Experimente mover os usuários para outro servidor Exchange como parte dessa nova escalação.


O HP/Compaq Secure Path Service está parado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o serviço HP/Compaq Secure Path está em execução. Se o Exchange Server Analyzer determinar que o serviço HP/Compaq Secure Path não está em execução, será exibido um aviso.

O serviço HP/Compaq Secure Path é um software MPTIO (Multipath I/O). A definição de vários caminhos fornece acesso de dados de alta disponibilidade, permitindo que um host tenha até 32 caminhos para acessar um dispositivo de armazenamento externo, o que facilita o failover e o balanceamento de carga. A definição de vários caminhos não é um recurso do sistema operacional, mas tem suporte através do DDK (Driver Development Kit) MPIO, que fornece uma maneira para que os fornecedores de armazenamento criem soluções interoperáveis de vários caminhos.

Quando o software MPIO é executado, o sistema operacional Windows detecta apenas uma unidade enquanto o software MPIO gerencia as várias conexões com diversos dispositivos de armazenamento. Se o software MPIO for interrompido, o Windows detectará todas as unidades de armazenamento anexadas como unidades independentes. Isso provavelmente causará erros e mau funcionamento do armazenamento.

Para corrigir esse aviso

  1. Abra o snap-in Serviços do MMC.

  2. Clique com o botão direito no serviço HP/Compaq Secure Path e depois clique em Propriedades.

  3. Na guia Geral da página de propriedades do serviço HP/Compaq Secure Path, verifique se o Tipo de inicialização está definido com Automática. Se não estiver, clique em Aplicar e clique em OK.

  4. Clique com o botão direito no serviço HP/Compaq Secure Path e clique em Iniciar.

  5. Feche o snap-in Serviços.

Para obter informações gerais sobre como implantar diferentes tecnologias de armazenamento com o Windows, consulte "Planejando usar recursos de armazenamento do Windows com SANs" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=33626).


Impacto de software de terceiros
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool determinou que você está executando software de terceiros no servidor Exchange. Esse software pode ser a causa do problema de desempenho do servidor. Softwares de terceiros podem incluir, sem limitação, os seguintes:

  • Produtos antivírus em nível de arquivo

  • Produtos antivírus de email que detectam o Exchange

  • Produtos anti-spam

  • Software de servidor de fax

  • Conector estrangeiro de colaboração ou de emails

  • Serviços de arquivos e impressões

  • Conectores de dispositivos móveis

Para corrigir esse erro

  • Se achar que o software de terceiros está degradando o desempenho do Exchange Server, desinstale ou desabilite o software de terceiros e avalie o desempenho do Exchange Server.

  • Se determinar que o software de terceiros está causando a redução de desempenho e o software for importante para a funcionalidade do servidor, experimente dedicar outro servidor para distribuir a carga entre dois servidores.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).


Atualização da versão do INO_FLPY.SYS disponível
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação do Gerenciamento do Microsoft Windows®) para determinar a versão do driver Ino_flpy.sys de filtro antivírus da Computer Associates.

O Exchange Server Analyzer consulta a classe CIM_Datafile do WMI para determinar o valor da chave Version para Ino_flpy.syse, dependendo do número da compilação da versão, pode ser necessária a atualização do software. Se o valor da chave Version indicar que o número da versão é inferior a 5.00.6100.109 para o arquivo Ino_flpy.sys file, um aviso será exibido.

Um número de versão inferior a 5.00.6100.109 indica que a versão mais atual do arquivo Ino_flpy.sys não está instalada no computador do Exchange Server e a versão mais atual do driver de filtro deve ser instalada. No site da Computer Associates, você encontra uma atualização de software antivírus para o arquivo Ino_flpy.sys. Esta atualização de software antivírus é altamente recomendável e pode melhorar o desempenho e a confiabilidade gerais do computador do Exchange Server.

Quando os programas de software antivírus Inoculan Computer Associates eTrust Antivirus versão 6.x ou 7.x e InoculateIT versão 6.x são instalados em um computador do Exchange 2000 Server ou Exchange Server 2003, o programa de Instalação copia os arquivos do driver de filtro antivírus Ino_flpy.sys e Ino_fltr.sys para a pasta %systemroot%\system32\drivers. Os arquivos do driver antivírus são drivers do modo Kernel do Windows NT® que são usados para iniciar os serviços de antivírus necessários. Versões mais antigas dos drivers de filtro podem causar resultados inesperados no computador do Exchange Server.

Para corrigir esse aviso

  1. Para obter as atualizações mais recentes do software antivírus para o arquivo ino_flpy.sys, visite o site da Computer Associates (http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp).

  2. Baixe a versão atualizada apropriada do eTrust ou InoculateIT.

  3. Faça um backup completo do computador do Exchange Server, incluindo um backup do arquivo Ino_flpy.sys.

  4. Instale a atualização mais recente do eTrust ou InoculateIT.
Observação:
Endereços da Web podem mudar, por isso, talvez você não consiga se conectar aos sites mencionados aqui.

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 240309, "How to Fully Disable Antivirus Software from Filtering Files" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309)

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte os Parceiros do Exchange: Site do antivírus (http://go.microsoft.com/fwlink/?linkid=16226).


Atualização da versão INO_FLTR.SYS disponível
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar a versão do driver de filtro antivírus Ino_fltr.sys da Computer Associates.

O Exchange Server Analyzer consulta a classe CIM_Datafile do WMI para determinar o valor da chave Version do Ino_fltr.sys e, com base no número de compilação da versão, uma atualização de software poderá ser necessária. Se o valor da chave Version indicar que o número da versão é inferior a 5.00.6100.142 no arquivo Ino_fltr.sys, um aviso será exibido.

Um número de versão inferior a 5.00.6100.142 indica que a versão mais atual do arquivo Ino_fltr.sys não está instalada no computador do Exchange Server e que uma versão mais atual do driver de filtro deverá ser instalada. Uma atualização de software antivírus para o arquivo Ino_fltr.sys pode ser encontrada no site da Computer Associates. Esta atualização de software antivírus é altamente recomendável e pode melhorar o desempenho e a confiabilidade gerais do computador do Exchange Server.

Quando os programas de software antivírus Inoculan Computer Associates eTrust Antivirus versão 6.x ou 7.x e InoculateIT versão 6.x são instalados em um computador do Exchange 2000 Server ou Exchange Server 2003, o programa de Instalação copia os arquivos do driver de filtro antivírus Ino_flpy.sys e Ino_fltr.sys para a pasta %systemroot%\system32\drivers. Os arquivos de filtro de driver antivírus são os drivers do modo Kernel do Windows NT® usados para iniciar os serviços antivírus necessários. Versões mais antigas dos drivers de filtro podem causar resultados inesperados no computador do Exchange Server.

Para corrigir esse aviso

  1. Para obter as atualizações mais recentes de software antivírus para o arquivo Ino_fltr.sys, visite o site da Computer Associates: (http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp).

  2. Baixe a versão atualizada apropriada do eTrust ou InoculateIT.

  3. Faça um backup completo do computador do Exchange Server, incluindo um backup do arquivo Ino_fltr.sys.

  4. Instale a atualização mais recente do eTrust ou InoculateIT.
Observação:
Endereços da Web podem mudar, por isso, talvez você não consiga se conectar aos sites mencionados aqui.

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 240309, "How to Fully Disable Antivirus Software from Filtering Files" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309)

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte os Parceiros do Exchange Server: Site do antivírus (http://go.microsoft.com/fwlink/?linkid=16226).


McAfee GroupShield 5.2 para atualização do Microsoft Exchange já disponível
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-04-19

A ferramenta Analisador do Microsoft® Exchange Server lê o seguinte valor de Registro para determinar se existe um arquivo de biblioteca VSAPI (Virus Scanning Application Programming Interface) registrado junto ao serviço Armazenamento de Informações do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Quando o McAfee GroupShield 5.2 para Microsoft Exchange estiver instalado no Exchange 2000 Server ou Exchange Server 2003, a entrada do Registro da Biblioteca terá o valor GSEVS2.DLL. Esse arquivo de biblioteca executa várias funções relacionadas à VSAPI no GroupShield 5.2 para Microsoft Exchange.

O Analisador do Exchange Server também consulta a classe WMI CIM_Datafile (Instrumentação de Gerenciamento do Microsoft Windows®) para conhecer o valor da chave Version para GSEVS2.DLL. Se o valor da chave Version indicar que o número da compilação é menor que 682 para esse arquivo, será exibido um aviso.

Um número de versão menor que 682 para GSEVS2.DLL indica que a versão mais recente do GroupShield 5.2 para Microsoft Exchange não está instalada. Existe uma atualização de software disponível para o GroupShield 5.2 para o Microsoft Exchange no site da McAfee. Essa atualização é altamente recomendável e pode melhorar o desempenho e a confiabilidade gerais. Alem disso, a atualização do GroupShield para Microsoft Exchange 5.2.682 garante que você está utilizando as versões mais recentes de DLLs importantes. O uso da versão mais recentes de gsevs2.dll aprimorou significativamente o desempenho e a confiabilidade nas implantações de sistemas de mensagens do Exchange Server.

Para corrigir esse aviso

  1. Determine a versão mais recente do GroupShield 5.2 para Microsoft Exchange Server, visitando a página Guided Knowledge Search do site da McAfee (http://knowledgemap.nai.com/). Utilize os seguintes artigos do McAfee Solutions KnowledgeBase e outros artigos do McAfee Solutions KnowledgeBase, localizados no site para determinar a versão mais recente:

    • ID de solução KB40567, "Obtendo a última versão do GroupShield e/ou SpamKiller"

    • ID da Solução KB nai18117, "Informações sobre a Versão do Produto para GroupShield para Exchange 2000"

  2. Visite o site da McAfee (https://secure.nai.com/us/forms/downloads/upgrades/login.asp).

  3. Baixe a atualização mais recente para a sua versão do GroupShield 5.2 para Microsoft Exchange Server.

  4. Faça um backup completo do computador com o Exchange Server.

  5. Instale a atualização mais recente do GroupShield 5.2 para Microsoft Exchange Server.
Observação:
As informações sobre sites da Web de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange Server com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte os Parceiros do Exchange Server: Site do antivírus (http://go.microsoft.com/fwlink/?linkid=16226).


McAfee GroupShield 6.0 para atualização do Microsoft Exchange já disponível
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê o seguinte valor de Registro para determinar se existe um arquivo de biblioteca VSAPI (Virus Scanning Application Programming Interface) registrado junto ao serviço Armazenamento de Informações do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Quando o McAfee GroupShield 6.0 para Microsoft Exchange estiver instalado no Exchange 2000 Server ou Exchange Server 2003, a entrada do Registro da Biblioteca terá o valor VSAPISCANSOURCE.DLL. Esse arquivo de biblioteca executa várias funções relacionadas à VSAPI no GroupShield 6.0 para Microsoft Exchange.

O Analisador do Exchange Server também consulta a classe WMI CIM_Datafile (Instrumentação de Gerenciamento do Microsoft Windows®) para conhecer o valor da chave Version para VSAPISCANSOURCE.DLL. Se o valor da chave Version indicar que o número da compilação é menor que 6.0.1148.0 para esse arquivo, será exibido um aviso.

Um número de versão menor que 6.0.1148.0 para VSAPISCANSOURCE.DLL indica que a versão mais recente do GroupShield 6.0 para Microsoft Exchange não está instalada. Existe uma atualização de software disponível para o GroupShield 6.0 para o Microsoft Exchange no site da McAfee. Essa atualização é altamente recomendável e pode melhorar o desempenho e a confiabilidade gerais.

Para corrigir esse aviso

  1. Conheça a última versão do GroupShield 6.0 para Microsoft Exchange, visitando a página Guided Knowledge Search do site da McAfee (http://knowledgemap.nai.com/). Use os seguintes artigos de Soluções McAfee e outros artigos de Soluções McAfee localizados neste site para determinar a versão mais recente:

    • ID de Solução nai18117 "Verificação de versão do produto GroupShield para Exchange 2000"

    • ID de Solução KB37636, "Números de versões do McAfee GroupShield 6.x para Microsoft Exchange"

    • ID de solução KB40567, "Obtendo a última versão do GroupShield e/ou SpamKiller"

  2. Visite a página Downloads de Produtos do site da McAfee (https://secure.nai.com/us/forms/downloads/upgrades/login.asp).

  3. Baixe a atualização mais recente para a sua versão do GroupShield 6.0 para Microsoft Exchange.

  4. Faça um backup completo do computador com o Exchange Server.

  5. Instale a atualização mais recente do GroupShield 6.0 para Microsoft Exchange.
Observação:
As informações sobre sites da Web de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange Server com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis para o Exchange Server, consulte os Parceiros do Exchange Server: Site do antivírus (http://go.microsoft.com/fwlink/?linkid=16226).


McAfee GroupShield está instalado neste servidor Exchange, mas o serviço está parado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar se o McAfee GroupShield para Microsoft Exchange está instalado e se o serviço McAfee GroupShield está em execução no computador do Exchange.

O Analisador do Exchange Server também consulta a classe WMI Win32_Service para determinar se a definição de valor da chave Started no serviço Armazenamento de Informações do Microsoft Exchange está definido como True ou False.

Um valor igual a Falso indica que o serviço Armazenamento de Informações não está executando nesse computador do Exchange Server. Uma valor igual a True indica que o serviço de Armazenamento de Informações do Microsoft Exchange está executando.

Se o Exchange Server Analyzer detectar que o serviço Armazenamento de Informações do Microsoft Exchange está em execução e que o McAfee GroupShield está instalado, mas o serviço McAfee GroupShield não foi iniciado, um aviso será exibido.

O McAfee GroupShield fornece proteção antivírus para o Exchange. Alguns motivos pelos quais o serviço McAfee GroupShield pode ter sido parado, bem como as soluções, estão listadas aqui.

  • O software no qual você está executando o Exchange Server pode ser uma versão de avaliação ou teste cujo prazo expirou. Nesse caso, talvez você precise reinstalar o McAfee GroupShield. No mínimo, para continuar usando esse software, você deve ativá-lo.

  • Um administrador pode ter parado involuntariamente o serviço McAfee GroupShield. Verifique se o serviço está definido para iniciar automaticamente e inicie o serviço.

  • Um worm mal intencionado, um vírus ou outro programa podem ter parado o serviço. Verifique se o serviço está definido para iniciar automaticamente e inicie o serviço. Se o serviço continuar a parar inesperadamente sem eventos de erro relevantes, verifique se o computador não está infectado com um worm mal intencionado e elimine a infecção do sistema, caso necessário.

A Microsoft geralmente recomenda que você implante um software antivírus projetado para sistemas de mensagens no gateway do protocolo SMTP ou nos servidores Exchange que hospedam caixas de correio. Para uma proteção mais segura, execute o software antivírus no gateway que verifica as mensagens MIME de entrada, e um verificador de vírus no Exchange Server que usa o VSAPI 2.5.

Para iniciar o serviço do McAfee GroupShield

  1. Abra o snap-in Serviços do MMC.

  2. Clique com o botão direito no serviço McAfee GroupShield e clique em Propriedades.

  3. Na guia Geral da página de propriedades de McAfee GroupShield, verifique se o Tipo de inicialização está definido como Automático. Se não estiver, clique em Aplicar e clique em OK.

  4. Clique com o botão direito no serviço McAfee GroupShield e clique em Iniciar.

  5. Feche o snap-in Serviços.

Além disso, você deve executar o software antivírus cliente na área de trabalho do usuário. Se você estiver executando um software antivírus projetado para sistemas de mensagens (ele pode analisar e verificar o MIME) no gateway ou no servidor Exchange, a execução de um verificador de nível de arquivo na área de trabalho é suficiente.

  • Para obter mais informações sobre os diferentes tipos de programas verificadores de vírus que normalmente são usados com o Microsoft Exchange Server 2003, consulte o artigo 823166 da Base de Dados de Conhecimento Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

  • Para obter mais informações sobre os diferentes tipos de programas antivírus que normalmente são usados com o Microsoft Exchange 2000 Server, consulte o artigo 328841 da Base de Dados de Conhecimento da Microsoft, "Exchange e o software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

  • Para obter mais informações sobre como fortificar um ambiente do Exchange contra worms e vírus transmitidos por email, consulte o informe oficial da Microsoft "Reduzindo e erradicando vírus de email em um ambiente do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=30732).


Messageware Plus Pack instalado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar se o Messageware Plus Pack está instalado em algum Exchange Server:

HKEY_LOCAL_MACHINE\Software\Messageware Incorporated\Core Services\PlusPack\Load

Se detectar que o valor de Load é igual a 1, o Exchange Server Analyzer exibirá uma mensagem de configuração não padrão.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

O Messageware Plus Pack é um suplemento do Microsoft Office Outlook® Web Access para Exchange Server 2003 produzido pela Messageware Incorporated. O Messageware Plus Pack estende e aprimora o Outlook Web Access para usuários do Outlook Web Access Basic e também para usuários do Outlook Web Access Premium.

Para obter mais informações sobre o Messageware Plus Pack, consulte o site "Messageware OWA Suite" (http://www.messageware.com).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


Compatibilidade da prevenção de execução de dados do Microsoft Antigen
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2007-02-19

A ferramenta Microsoft Exchange Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave Started para o serviço Microsoft Antigen. Um valor Falso indica que o serviço não está sendo executado. Um valor Verdadeiro indica que o serviço está sendo executado.

O Exchange Analyzer lê também a seguinte entrada do Registro para determinar se o mecanismo de verificação Kaspersky do Microsoft Antigen está instalado no Exchange Server. Essa entrada do Registro só poderá estar presente se o mecanismo de verificação Kaspersky estiver instalado no Exchange Server.

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\Scan Engines\Kaspersky

Por fim, se o Exchange Server estiver sendo executado no Microsoft Windows Server 2003 Service Pack 1 (SP1) ou em uma versão posterior, o Exchange Analyzer consultará a classe Win32_ComputerSystem do WMI para determinar se o valor da chave SystemStartupOptions contiver as cadeias de caracteres '/NOEXECUTE=OPTOUT' ou '/NOEXECUTE=ALWAYSON'. Isso indica que a DEP (Prevenção de Execução de Dados) está instalada no servidor. Prevenção de Execução de Dados é um conjunto de tecnologias de hardware e software que executa verificações adicionais na memória para ajudar a impedir a execução de código malicioso em um sistema.

Se o Exchange Analyzer determinar que as seguintes condições são verdadeiras, ele exibirá um aviso:

  • O serviço Microsoft Antigen está habilitado no servidor.

  • O mecanismo de verificação Kaspersky do Antigen está instalado.

  • O servidor Exchange está sendo executado no Microsoft Windows Server 2003 Service Pack 1 (SP1) ou uma versão posterior.

  • A Prevenção de Execução de Dados está habilitada no servidor.

Esse aviso indica que a configuração de servidor atual pode causar problemas de desempenho de verificação de vírus e mensagens.

Para resolver esse aviso, siga a orientação indicada no artigo 905952 da Base de Dados de Conhecimento Microsoft, "O desempenho de mensagens é mais lento do que o esperado no Antigen, e o cliente Antigen pára de responder" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905952) (página em inglês), para desabilitar seletivamente a DEP para programas individuais.

Para obter mais informações

Para obter mais informações sobre Prevenção de Execução de Dados, consulte o artigo 875352 da Base de Dados de Conhecimento Microsoft, "Uma descrição detalhada do recurso DEP (Prevenção de Execução de Dados) no Windows XP Service Pack 2, Windows XP Tablet PC Edition 2005 e Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875352). (página em inglês)


NSI Software Double-Take está instalado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started do serviço Double-Take. Um valor True indica que o serviço Double-Take está em execução no Exchange Server. Se o serviço Double-Take for detectado em um Exchange Server, o Exchange Server Analyzer exibirá uma mensagem de configuração diferente do padrão.

O Exchange Server Analyzer informa que essa configuração diferente do padrão é somente para fins informativos. Nenhuma ação é necessária.

O Double-Take, da NSI Software, Inc., copia arquivos selecionados pelo usuário ou volumes completos de um ou mais servidores de origem para um ou mais servidores de destino através de conexões de rede padrão. Essas cópias permitem que as empresas retomem rapidamente as atividades após um desastre ou uma interrupção do sistema, com ou sem a intervenção do usuário.

Para obter mais informações sobre o Double-Take, consulte o site, "Double-Take" (http://www.nsisoftware.com/pro/doubletake).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

O Double-Take é um software de replicação de dados. Para obter informações detalhadas sobre a replicação de dados de vários sites para o Exchange 2000 Server e Exchange Server 2003, consulte o artigo 895847 da Base de Dados de Conhecimento Microsoft, "Suporte para replicação de dados de vários sites no Exchange 2003 e Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895847).


Processo não-Exchange consumindo mais de 20% do tempo do processador
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usada para consultar os objetos contadores de desempenho em computadores executando o Exchange 2000 Server ou Exchange Server 2003. Esse mecanismo coleta dados do contador de %Processor Time (_Total) do objeto de desempenho do Processor para analisar os dados de desempenho.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • Há um afunilamento de processador.

  • Um ou mais processos não-Exchange estão usando mais de 20% do tempo médio total de CPU do servidor.

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • Há um afunilamento de processador.

  • Um ou mais processos não pertencentes ao Exchange estão usando mais de 10% do tempo médio total da CPU do servidor.

O contador de desempenho % Processor Time (_Total) sob o objeto de desempenho Process fornece o uso geral dos processadores. A utilização média da CPU deve ser sempre abaixo de 80 por cento. Médias mais altas indicam um afunilamento no processador. Picos freqüentes no tempo do processador acima de 90% também revelam um afunilamento no processador.

Removendo afunilamentos do processador

Há várias maneiras de remover afunilamentos do processador no servidor Exchange.

  • Primeiro, revise os aplicativos ou as tarefas que estão causando carga ao servidor. Descubra se o aplicativo está usando o tempo regulamentar do processador ou se está ocorrendo um problema no processo.

  • Se um aplicativo não-Exchange não for importante para esse servidor, execute-o em outro servidor. Se possível, mova as funções do servidor para outros computadores também. Por exemplo, se o processo Inetinfo estiver usando intensamente a CPU, experimente adicionar servidores front-end para se encarregar do trabalho de protocolo realizado pelo Inetinfo. Também é possível mover o acesso às pastas públicas para um servidor de pastas públicas dedicado. Por último, se um servidor executa muitas expansões da lista de distribuição, você pode reduzir o uso da CPU, deslocando a expansão da lista de distribuição para um servidor de expansão de lista de distribuição dedicado.

  • Se possível, adicione mais processadores ou processadores mais velozes ao servidor. Além disso, habilite a hyper-threading se houver suporte para essa tecnologia nos processadores. Você pode habilitar a hyper-threading configurando a BIOS do sistema. Para obter mais informações, consulte a documentação da Ajuda do fabricante do computador.

  • Se o aumento da força de processamento não for uma opção viável, reduza a carga sobre os processadores. Para reduzir o impacto global sobre o servidor, certifique-se de que as tarefas de alta utilização de E/S, da CPU ou devoradoras de memória ocorram fora do horário do expediente normal.

  • Assegure-se de que as tarefas de alta utilização da CPU, como backup e manutenção, ocorram fora do horário de pico. Além disso, certifique-se de que essas tarefas sejam executadas em etapas. Preparar uma tarefa significa definir diferentes horas de início e, de preferência, horas de término para cada tarefa. Preparar a manutenção e o backup de bancos de dados ou de grupos de armazenamento também reduz o efeito das tarefas de alta utilização de recursos.

Para obter mais informações

  • Para obter mais informações sobre os afunilamentos do processador, consulte Afunilamento do processador.

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Para obter mais informações sobre como mover caixas de correio do usuário para reduzir a carga do servidor, consulte Mover Caixas de Correio de Usuário para Outro Servidor.


Processo não-Exchange consumindo mais de 50% do tempo do processador
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-02-13

A ferramenta Analisador do Microsoft® Exchange Server dispõe de um mecanismo de coleta de dados de desempenho, usada para consultar os objetos contadores de desempenho em computadores executando o Exchange 2000 Server ou Exchange Server 2003. Esse mecanismo coleta dados do contador de %Processor Time (_Total) do objeto de desempenho do Processor para analisar os dados de desempenho.

Este contador de desempenho % Processor Time (_Total) no objeto de desempenho Process proporciona a utilização global dos processadores. A utilização média da CPU deve ser sempre abaixo de 80 por cento. Médias mais altas indicam um afunilamento no processador. Picos freqüentes no tempo do processador acima de 90% também revelam um afunilamento no processador.

Se o Exchange Server Analyzer determinar que um processo, que não é o do Exchange, está usando mais de 50% do tempo médio total da CPU do servidor, mesmo que não tenha sido detectado um afunilamento no processador, a ferramenta Exchange Server Analyzer Tool exibirá um aviso.

Removendo afunilamentos potenciais do processador

Há várias maneiras de remover afunilamentos potenciais do processador no servidor Exchange.

  • Primeiro, revise os aplicativos ou as tarefas que estão causando carga ao servidor. Descubra se o aplicativo está usando o tempo regulamentar do processador ou se está ocorrendo um problema no processo.

  • Se um aplicativo não-Exchange não for importante para esse servidor, execute-o em outro servidor. Se possível, mova as funções do servidor para outros computadores também. Por exemplo, se o processo Inetinfo estiver usando intensamente a CPU, experimente adicionar servidores front-end para se encarregar do trabalho de protocolo realizado pelo Inetinfo. Também é possível mover o acesso às pastas públicas para um servidor de pastas públicas dedicado. Por último, se um servidor executa muitas expansões da lista de distribuição, você pode reduzir o uso da CPU, deslocando a expansão da lista de distribuição para um servidor de expansão de lista de distribuição dedicado.

  • Se possível, adicione mais processadores ou processadores mais velozes ao servidor. Além disso, habilite a hyper-threading se houver suporte para essa tecnologia nos processadores. Você pode habilitar a hyper-threading configurando a BIOS do sistema. Para obter mais informações, consulte a documentação da Ajuda do fabricante do computador.

  • Se o aumento da força de processamento não for uma opção viável, reduza a carga sobre os processadores. Para reduzir o impacto global sobre o servidor, certifique-se de que as tarefas de alta utilização de E/S, da CPU ou devoradoras de memória ocorram fora do horário do expediente normal.

  • Assegure-se de que as tarefas de alta utilização da CPU, como backup e manutenção, ocorram fora do horário de pico. Além disso, certifique-se de que essas tarefas sejam executadas em etapas. Preparar uma tarefa significa definir diferentes horas de início e, de preferência, horas de término para cada tarefa. Preparar a manutenção e o backup de bancos de dados ou de grupos de armazenamento também reduz o efeito das tarefas de alta utilização de recursos.

Para obter mais informações

  • Para obter mais informações sobre os afunilamentos do processador, consulte Afunilamento do processador.

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Guia de desempenho e escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Solucionando problemas de desempenho do Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


Uma versão desatualizada do HP/Compaq Secure Path está instalada
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-13

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar a versão de software HP/Compaq Secure Path instalado no servidor Exchange. Se a versão do Secure Path não for 3.7.2.540, um aviso será exibido.

Para corrigir esse aviso, atualize o software Secure Path. Entre em contato com o fornecedor da HP/Compaq para atualizar esse software.

Para obter mais informações sobre as atualizações de software HP/Compaq Secure Path, visite o site da HP, "Caminho seguro do HP StorageWorks" (http://h18006.www1.hp.com/products/sanworks/softwaredrivers/securepath/index.html).

Observação:
As informações sobre sites da Web de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


A porta 25 está bloqueada
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer lê o seguinte valor de Registro para determinar se o McAfee VirusScan para Microsoft Exchange está instalado no servidor que está executando o Exchange Server:

HKEY_LOCAL_MACHINE\Software\Network Associates\TVD\VirusScan Enterprise\CurrentVersion

O Exchange Server Analyzer consulta também a seguinte ramificação de Registro para determinar como o produto VirusScan está configurado para bloquear portas:

HKLM\Software\Network Associates\TVD\Shared Components\On Access Scanner\BehaviourBlocking

As chaves dessa ramificação são usadas para configurar quais processos e portas estão bloqueados ou são permitidos com o recurso On Access do produto VirusScan.

Finalmente, o Exchange Server Analyzer consulta também a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) quanto ao valor da chave Started do serviço McAfee VirusScan para determinar se ele está sendo executado no servidor Exchange.

Um valor Falso indica que o serviço McAfee VirusScan não está sendo executado nesse servidor Exchange. Um valor Verdadeiro indica que o serviço McAfee VirusScan está sendo executado.

O Exchange Server Analyzer exibirá um aviso, se as seguintes condições forem verdadeiras:

  • O McAfee VirusScan está instalado e em execução no servidor Exchange.

  • A regra de bloqueio "Impedir worms de correspondência em massa de enviar email" está habilitada na Porta 25.

  • O serviço SMTP do Exchange não é excluído da regra de bloqueio.

Esse aviso indica que o aplicativo McAfee VirusScan está configurado de forma que ele possa bloquear a comunição legítima do Exchange Server pela porta 25. Podem ocorrer problemas de fluxo de mensagens.

Para resolver esse problema:

  • Considere se a regra de bloqueio "Impedir worms de correspondência em massa de enviar email" deve ser desabilitada ou não.

  • Adicione o serviço SMTP do Exchange Server à lista de exclusão para a regra de bloqueio "Impedir worms de correspondência em massa de enviar email".

Para obter mais informações

  • Para obter mais informações sobre como configurar o McAfee VirusScan para Microsoft Exchange, visite o McAfee Service Portal (http://knowledge.mcafee.com/).

    Observação:
    As informações sobre sites de terceiros são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.
  • Para obter mais informações sobre os diferentes tipos de programas verificadores de vírus que normalmente são usados com o Microsoft Exchange Server 2003, consulte o artigo 823166 da Base de Dados de Conhecimento Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

  • Para obter mais informações sobre os diferentes tipos de programas verificadores de vírus que normalmente são usados com o Microsoft Exchange 2000 Server, consulte o artigo 328841 da Base de Dados de Conhecimento Microsoft, "Exchange e software antivírus" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

  • Para obter mais informações sobre como fortalecer um ambiente do Exchange contra worms e vírus transmitidos por email, consulte o informe oficial da Microsoft "Reduzindo e erradicando vírus transmitidos por email em um ambiente do Exchange" (http://go.microsoft.com/fwlink/?LinkId=30732).


Red Earth Software Policy Patrol for Exchange Server Needs Update
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2007-07-24

A ferramenta Microsoft Exchange Analyzer lê o Registro para determinar se uma destas duas subchaves estão presentes:

HKEY_LOCAL_MACHINE\Software\Red Earth Software\Policy Patrol\3.0

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Red Earth Software\Policy Patrol\3.0

A presença de uma dessas ramificações indica que o Red Earth Policy Patrol versão 3.0 para Exchange Server está instalada no computador local.

Se o Exchange Analyzer detectar que o Policy Patrol versão 3 para Exchange Server está instalada no computador local, ele exibirá um aviso.

Esse aviso indica que uma atualização recomendada do Policy Patrol para Exchange Server está disponível.

Para corrigir esse aviso

  1. Visite o site de download do Red Earth Software Policy Patrol para Exchange Server em http://www.policypatrol.com/download.htm

  2. Baixe e instale todas as atualizações necessárias ou recomendadas para o Policy Patrol para Exchange Server.
Observação:
As informações sobre sites de terceiros são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


ScanMail para Microsoft Exchange e CA eTrust em execução juntos
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-15

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar qual versão do Trend Micro ScanMail para Microsoft Exchange está instalada no servidor Exchange:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\Version

Se os dados do valor Versão iniciarem com o número 7, isso indica que o ScanMail para o Microsoft Exchange Versão: 7 está instalada.

O Exchange Server Analyzer também lê a seguinte entrada do Registro para determinar se o eTrust da Computer Associates também está instalado no servidor Exchange:

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\

Se o valor do Registro CurrentVersion existir, isso indica que o eTrust Antivirus, versão 7, da Computer Associates está instalado no servidor Exchange.

Finalmente, o Exchange Server Analyzer consulta a classe Win32_Service do WMI para determinar o valor da chave Started do serviço InoRT, também conhecido como serviço eTrust Antivirus Realtime Server, na eTrust Antivirus.

O Exchange Server Analyzer exibe uma mensagem de prática recomendada se as seguintes condições forem verdadeiras:

  • Tanto o ScanMail para o Microsoft Exchange e o eTrust Antivirus estão instalados no servidor Exchange.

  • O serviço eTrust Antivirus Realtime Server foi iniciado.

A Trend Micro recomenda que qualquer software antivirus de arquivos com base em sistema, como o eTrust Antivirus, exclua as pastas do ScanMail para Microsoft Exchange da verificação. O ScanMail para Microsoft Exchange usa pastas temporárias em seu caminho para sua própria atividade de verificação. Se um scanner antivírus de baseado em sistema de arquivos verificar essas pastas temporárias, a verificação pode interferir com as operações normais do ScanMail para Microsoft Exchange.

É uma prática recomendada excluir as pastas do ScanMail para Microsoft Exchange da verificação em tempo real por softwares antivírus baseados em sistemas de arquivos, como o eTrust Antivirus da Computer Associates. Para obter mais informações sobre como usar o ScanMail para Microsoft Exchange em um computador com um software antivírus baseado em sistema de arquivos instalado, consulte o artigo da base de dados de conhecimento da Trend Micro, "Installing another antivirus application with ScanMail for Exchange also installed on the same server" (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=8540).

Observação:
As informações sobre sites de terceiros são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


O diretório de arquivo do ScanMail para Microsoft Exchange contém muitos arquivos
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-15

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a versão 7.0 do Trend Micro ScanMail para Microsoft Exchange está instalada:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\Version

O Exchange Server Analyzer conta o número de arquivos que estão presentes no diretório usado pelo ScanMail for Microsoft Exchange. Por padrão, o caminho do diretório de arquivo é este:

C:\Arquivos de programas\Trend Micro\Smex\Storage\Archive

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • A versão 7.0 do ScanMail for Microsoft Exchange está instalada.

  • Há mais de 1.000 arquivos no diretório usado pelo ScanMail para Microsoft Exchange.

Esse aviso indica a presença de muitos arquivos no diretório de arquivos usado pelo ScanMail para Microsoft Exchange. A Trend Micro recomenda que você verifique e limpe periodicamente a pasta de backup usada pelo ScanMail para Microsoft Exchange.


O diretório de backup do ScanMail para Microsoft Exchange contém muitos arquivos
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-15

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a versão 7.0 do Trend Micro ScanMail para Microsoft Exchange está instalada:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\Version

O Exchange Server Analyzer conta o número de arquivos presentes no diretório de backup usado pelo ScanMail for Microsoft Exchange. Por padrão, o caminho do diretório de backup é o seguinte:

C:\Arquivos de Programas\Trend Micro\Smex\Storage\Backup

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • A versão 7.0 do ScanMail for Microsoft Exchange está instalada.

  • Há mais de 1.000 arquivos no diretório de backup usado pelo ScanMail para Microsoft Exchange.

Esse aviso indica a presença de muitos arquivos no diretório de backup usado pelo ScanMail para Microsoft Exchange. A Trend Micro recomenda que você verifique e limpe regularmente a pasta de backup usada pelo ScanMail para Microsoft Exchange.


Exclusão de backup do ScanMail for Microsoft Exchange
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-15

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar os arquivos e as pastas que foram excluídos dos backups por meio do Windows Backup:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

O Exchange Server Analyzer procura especificamente por uma cadeia de caracteres que contenha "SMEX\DATA".

Se descobrir que a chave FilesNotToBackup contém um valor que possui a cadeia de caracteres "SMEX\DATA", o Exchange Server Analyzer exibirá um aviso.

Se não estiver usando o Windows Backup, você poderá ignorar esse aviso com segurança. Se estiver usando o Windows Backup, é recomendável que você remova a exclusão do diretório SMEX\DATA. O Trend Micro recomenda que os usuários façam backup de todos os arquivos que possuam a extensão .mdb. Os arquivos de backup poderão ser usados caso os arquivos .mdb de produção da pasta SMEX\DATA sejam danificados ou excluídos.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. Selecione FilesNotToBackup no painel esquerdo.

  4. No painel direito, clique com o botão direito do mouse no valor que contém a cadeia de caracteres "SMEX\DATA" e selecione Excluir.

  5. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O modo de depuração do ScanMail para Microsoft Exchange está habilitado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-15

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o modo de depuração está habilitado no ScanMail para Microsoft Exchange da Trend Micro:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\DebugModule

Se os dados do valor de DebugModule contiverem uma ou mais das seguintes cadeias de caracteres, o Exchange Server Analyzer exibirá um aviso:

  • HOST:1

  • CONFIG:1

  • MASTER:1

  • WATCHER:1

  • STORE:1

  • INETINFO:1

  • TCHER:1

  • MON:1

  • MONITOR:1

Este aviso indica que o modo de depuração está habilitado no momento para um ou mais módulos do ScanMail para Microsoft Exchange. A Trend Micro recomenda que o modo de depuração só seja habilitado quando for necessário, por exemplo, para solucionar problemas. A Trend Micro recomenda que, de outra forma, o modo de depuração seja desabilitado para operações habituais.

Para corrigir esse aviso

  1. Consulte o seguinte artigo da base de conhecimento da Trend Micro, "Habilitando a depuração do ScanMail para Exchange (SMEX) 7.0 através do Editor do Registro" (em inglês) (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=25532).

  2. Desabilite a depuração de todos os módulos seguindo as instruções contidas no artigo da base de conhecimento da Trend Micro.
Observação:
As informações sobre sites de terceiros são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


O diretório de quarentena do ScanMail para Microsoft Exchange contém muitos arquivos
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-15

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a versão 7.0 do Trend Micro ScanMail para Microsoft Exchange está instalada:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\Version

O Exchange Server Analyzer conta o número de arquivos no diretório de quarentena utilizado pelo ScanMail para Microsoft Exchange. Por padrão, o caminho para o diretório de quarentena é:

C:\Arquivos de Programas\Trend Micro\Smex\Storage\Quarantine

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • A versão 7.0 do ScanMail for Microsoft Exchange está instalada.

  • Existem mais de 1.000 arquivos no diretório de quarentena usado pelo ScanMail para Microsoft Exchange.

Esse aviso informa a presença de muitos arquivos no diretório de quarentena usado pelo ScanMail para Microsoft Exchange. A Trend Micro recomenda que você examine e limpe regularmente a pasta de quarentena usada pelo ScanMail para Microsoft Exchange.


ScanMail para diretório SharedResPool do Microsoft Exchange no caminho padrão
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2007-06-05

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar qual versão do Trend Micro ScanMail para Microsoft Exchange está instalada:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\Version

O Exchange Server Analyzer também lê a seguinte entrada do Registro para determinar o local da pasta SharedResPool:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SharedResPool

Finalmente, o Exchange Server Analyzer lê a seguinte entrada do Registro para determinar o local onde o ScanMail para Microsoft Exchange foi instalado:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\HomeDir

O Exchange Server Analyzer exibe uma mensagem de prática recomendada se as seguintes condições forem verdadeiras:

  • Versão do ScanMail para Microsoft Exchange: 7 está instalada.

  • A pasta SharedResPool está localizada no caminho do diretório raiz do ScanMail.

É uma prática recomendada relocar o diretório SharedResPool para uma unidade que seja mais rápida do que a do diretório raiz utilizado pelo ScanMail para Microsoft Exchange. A Trend Micro recomenda que os clientes reloquem a pasta SharedResPool para uma unidade mais rápida para melhorar o desempenho. O diretório SharedResPool contém arquivos de mapeamento de memória para os recursos compartilhados entre os processos incluídos no ScanMail para Microsoft Exchange Versão: 7.0. Você não deve excluir o conteúdo desse diretório.

Para obter mais informações sobre a pasta SharedResPool, consulte "O que são os diretórios SharedResPool e Engine do ScanMail para Exchange (SMEX) 7.0?" (página em inglês) (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26898).

Para obter mais informações sobre como mover a pasta SharedResPool, consulte "Movendo o diretório SharedResPool do ScanMail para Exchange (SMEX) 7.0 para outro local" (em inglês) (http://esupport.trendmicro.com/support/viewxml.do?ContentID=EN-127549&id=EN-127549).

Observação:
As informações sobre sites de terceiros são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


Verificação SMTP do ScanMail para Microsoft Exchange habilitada no servidor de caixa de correio
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-15

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte propriedade na metabase dos Serviços de Informação da Internet da Microsoft (IIS) para determinar as configurações atuais do Trend Micro ScanMail para o Microsoft Exchange:

LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes/{76719654-05A6-11d2-9dfd-00C04FA322BA}/Bindings/{6BA0CE4C-AC34-411E-B58A-EB715D04019D}/Enabled

O Exchange Server Analyzer também consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serverRole do objeto do servidor Exchange. o valor 1 para o atributo serverRole indica que o servidor Exchange foi configurado como servidor front-end. Um valor 0 indica que o servidor Exchange não está configurado como um servidor front-end.

O Analisador do Exchange Server também consulta a classe WMI Win32_OperatingSystem (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave OSProductSuite do servidor Exchange. Essa consulta é executada para determinar o sistema operaciona específico que está sendo executado no servidor Exchange.

O Exchange Server Analyzer também lê o valor do Registro a seguir para determinar qual versão do ScanMail para Exchange está sendo executada no servidor Exchange:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\Version

Se os dados do valor Version iniciarem com o número 7, isso indica que o ScanMail para o Microsoft Exchange Versão: 7 está instalada.

Finalmente, o Exchange Server Analyzer consulta o Active Directory para determinar o número de objetos com um atributo homeMDBBL configurado. Objetos com o atributo homeMDBBL configurado são objetos habilitados para caixa de correio. Portanto, a contagem do número de objetos com homeMDBBL configurado é o número de caixas de correio existentes.

O Exchange Server Analyzer exibe uma mensagem de prática recomendada se as seguintes condições forem verdadeiras:

  • Versão do ScanMail para Microsoft Exchange: 7 está instalada.

  • O ScanMail para Microsoft Exchange é configurado para executar verificação de SMTP em um servidor Exchange que não está configurado como servidor front-end.

  • O computador do Exchange Server contém mais de 20 caixas de correio.

  • O servidor Exchange não está sendo executado no Windows Small Business Server 2003 ou no Microsoft Small Business Server 2000.

A Trend Micro recomenda que os usuários do ScanMail para Microsoft Exchange, Versão: 7 desabilitem a verificação de SMTP e que usa o console de gerenciamento do ScanMail em servidores de caixa de correio que são servidores separados gateway ou bridgehead. Para obter o melhor desempenho e segurança, a TrendMail recomenda que a verificação de SMTP seja habilitada em servidores bridgehead gateway em vez de servidores de caixa de correio.


O diretório TEMP do ScanMail for Microsoft Exchange contém muitos arquivos
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-15

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a versão 7.0 do Trend Micro ScanMail para Microsoft Exchange está instalada:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\Version

Em seguida, a ferramenta Exchange Server Analyzer Tool contará o número de arquivos no diretório TEMP utilizado pelo ScanMail para Microsoft Exchange. Por padrão, o caminho do diretório TEMP usado pelo ScanMail para Microsoft Exchange é o seguinte:

C:\Arquivos de Programas\Trend Micro\Smex\Temp

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • A versão 7.0 do ScanMail for Microsoft Exchange está instalada.

  • Há mais de 100 arquivos no diretório TEMP usado pelo ScanMail for Microsoft Exchange.

Esse aviso indica a presença de muitos arquivos no diretório TEMP usado pelo ScanMail for Microsoft Exchange. Os arquivos nessa pasta são arquivos temporários usados pelo ScanMail for Microsoft Exchange. O ScanMail for Microsoft Exchange deve excluir automaticamente esses arquivos.

Se houver muitos arquivos com datas anteriores à data atual, a Trend Micro recomenda que você exclua os arquivos antigos.


O diretório TEMP do ScanMail para Microsoft Exchange contém muitos arquivos
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-15

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a versão 7.0 do Trend Micro ScanMail para Microsoft Exchange está instalada:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\Version

Se o ScanMail para Microsoft Exchange versão 7 estiver instalado, o Exchange Server Analyzer lerá a seguinte entrada de Registro para determinar o local do diretório TEMP utilizado pelo ScanMail para Microsoft Exchange:

HKLM\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\TempFolderPath

Em seguida, o Exchange Server Analyzer contará o número de arquivos no diretório TEMP utilizado pelo ScanMail para Microsoft Exchange.

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • A versão 7.0 do ScanMail for Microsoft Exchange está instalada.

  • Há mais de 100 arquivos no diretório TEMP usado pelo ScanMail for Microsoft Exchange.

Esse aviso indica a presença de muitos arquivos no diretório TEMP usado pelo ScanMail for Microsoft Exchange. Os arquivos nessa pasta são arquivos temporários usados pelo ScanMail for Microsoft Exchange. O ScanMail for Microsoft Exchange deve excluir automaticamente esses arquivos.

Se houver muitos arquivos com datas anteriores à data atual, a Trend Micro recomenda que você exclua os arquivos antigos.


O caminho da pasta temporária do ScanMail para Microsoft Exchange foi alterado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-15

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a versão 7.0 do Trend Micro ScanMail para Microsoft Exchange está instalada:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\Version

O Analisador do Exchange Server também lê a seguinte entrada para saber a localização da pasta temporária usada pelo ScanMail para Microsoft Exchange:

HKLM\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\TempFolderPath

Se o valor de TempFolderPath estiver presente e configurado no Registro, essa presença indica que a pasta temporária do ScanMail para Microsoft Exchange foi movida de seu local padrão.

Por último, o Analisador do Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile para calcular o valor da chave Version para o AdapterSMTP.dll. Esse módulo está incluído no ScanMail para Microsoft Exchange da Trend Micro. Um valor da chave Version para AdapterSMTP.dll inferior a 7.0.1366 indica ser necessária uma versão atualizada do ScanMail para Microsoft Exchange.

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • Versão do ScanMail para Microsoft Exchange: 7 está instalada.

  • A pasta temporária usada pelo ScanMail para Microsoft Exchange foi movida de seu local original.

  • A versão do arquivo adapterSMTP.dll é 7.0.1366 ou anterior.

A Trend Micro incluiu a possibilidade de realocar a pasta temporária em compilações recentes do ScanMail para Microsoft Exchange. Esse recurso só funciona nas compilações posteriores à 7.0.1366. Esse aviso indica que o local da pasta temporária foi alterado, mas a alteração não entrará em vigor porque esse servidor está executando uma compilação anterior do ScanMail para Microsoft Exchange que não aceita alteração de local da pasta temporária.

Para corrigir esse aviso

  1. Visite o site do Centro de atualizações da Trend Micro (http://www.trendmicro.com/download).

  2. Baixe e instale todas as atualizações obrigatórias ou recomendadas do ScanMail para Microsoft Exchange.
Observação:
As informações sobre sites de terceiros são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


Otimização do caminho da pasta temporária do ScanMail for Microsoft Exchange
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-15

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a versão 7.0 do Trend Micro ScanMail para Microsoft Exchange está instalada:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\Version

O Analisador do Exchange Server também lê a seguinte entrada para saber a localização da pasta temporária usada pelo ScanMail para Microsoft Exchange:

HKLM\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\TempFolderPath

Se o valor de TempFolderPath estiver presente e configurado no Registro, essa presença indica que a pasta temporária do ScanMail para Microsoft Exchange foi movida de seu local padrão.

Por último, o Analisador do Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile para calcular o valor da chave Version para o AdapterSMTP.dll. Esse módulo está incluído no ScanMail para Microsoft Exchange da Trend Micro.

O Exchange Server Analyzer exibe uma mensagem de prática recomendada se as seguintes condições forem verdadeiras:

  • Versão do ScanMail para Microsoft Exchange: 7 está instalada.

  • A pasta temporária usada pelo ScanMail para Microsoft Exchange permanece em seu local padrão original.

  • A versão do AdapterSMTP.dll oferece suporte ao redirecionamento da pasta temporária usada pelo ScanMail para Microsoft Exchange.

A Trend Micro incluiu a possibilidade de realocar a pasta temporária em compilações recentes do ScanMail para Microsoft Exchange. Esse recurso só funciona em compilações posteriores a 7.0.1366. Se você estiver usando uma compilação do ScanMail para Microsoft Exchange anterior à versão 7.0.1366, a Trend Micro recomenda que você reloque a pasta temporária para uma unidade mais rápida.

Para relocar a pasta temporária

  1. Consulte o artigo da base de dados de conhecimento da Trend Micro, "Os usuários podem alterar o local da pasta temporária do ScanMail para Exchange (SMEX) 7.0?" (página em inglês) (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26343).

  2. Execute os procedimentos descritos neste artigo para relocar a pasta temporária para uma unidade mais rápida.
Observação:
As informações sobre sites de terceiros são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


Atualização disponível do ScanMail para Microsoft Exchange
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-12-15

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para calcular o valor da chave Version para o adapterSMTP.dll. Esse módulo é incluído no ScanMail para Microsoft Exchange da Trend Micro.

Se o Exchange Server Analyzer verificar que o valor da chave Version do adapterSMTP.dll é menor do que 7.0.1366, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que o ScanMail para Microsoft Exchange versão 7 está instalado no servidor Exchange e que uma atualização de software recomendada está disponível. Essa atualização é altamente recomendável e pode melhorar o desempenho e a confiabilidade gerais do servidor.

Para corrigir esse aviso

  1. Visite o site Trend Micro Update Center (http://www.trendmicro.com/download/).

  2. Baixe e instale todas as atualizações necessárias ou recomendadas para o ScanMail para Microsoft Exchange.
Observação:
As informações sobre sites de terceiros são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


A verificação antivírus de transporte SMTP não está habilitada
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se há um valor definido para a chave Started no serviço SMSMSE (Symantec Mail Security for Microsoft Exchange). A classe Win32_Service determina se o SMSMSE está instalado no computador do Exchange Server 2003. Um valor True indica que o serviço SMSMSE está sendo executado. Um valor False indica que o serviço SMSMSE não está sendo executado. O Exchange Server Analyzer exibirá um aviso se existirem as seguintes condições:

  • O SMSMSE está instalado no computador do Exchange Server 2003.

  • A verificação antivírus de transporte SMTP não está habilitada.

No Exchange Server 2003, o mecanismo avançado de colocação em fila usa a API de Antivírus de Transporte do Exchange como um dos seis coletores de eventos de transporte para entregar mensagens em seus destinos. O coletor de eventos da API de Antivírus de Transporte do Exchange é implementada em OnSubmit.dll e permite que fornecedores que não são da Microsoft, como a Symantec, implementem scanners de vírus que examinam todas as mensagens em busca de anexos e estruturas de dados mal-intencionados antes que cheguem aos destinos. Esse evento é registrado para o evento OnSubmission.

Por padrão, a verificação antivírus de transporte não está habilitada, pois ela faz com que as mensagens sejam verificadas duas vezes, uma na camada SMTP e outra no armazenamento do Exchange. No entanto, se estiver usando servidores front-end para conectar uma organização do Exchange à Internet, você pode habilitar a verificação antivírus de transporte nesses servidores.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para habilitar a verificação antivírus de transporte

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para HKLM\Software\Microsoft\Exchange\Cluster.

  3. Crie um novo valor de DWORD com um nome de valor Enabled. Atribua um dado de valor 1 ao nome de valor Enabled.

  4. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Observação:
A funcionalidade de verificação de transporte está disponível apenas com scanners de vírus do Exchange baseados no VSAPI (Virus Scanning Application Programming Interface) 2.5.

Para obter mais informações sobre a Arquitetura de Transporte SMTP, consulte o Guia de Referência Técnica do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47891).

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 328841, "Exchange e software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841) (página em inglês).

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166) (página em inglês).

  • 306105, "XGEN: Posição da Microsoft sobre soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkId=3052&kbid=306105) (página em inglês).

  • 245822, "Recomendações para solucionar problemas em um computador do Exchange Server com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkId=3052&kbid=245822) (página em inglês).

Para obter uma lista de softwares antivírus de terceiros disponíveis para o Exchange Server, consulte os Parceiros do Exchange Server: Site do antivírus (http://go.microsoft.com/fwlink/?linkid=16226).

Observação:
Endereços da Web podem mudar, por isso, talvez você não consiga se conectar ao site ou sites mencionados aqui.


A atualização do Simpler-Webb Exchange Resource Manager está disponível
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-04-14

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile Microsoft para determinar o valor configurado para a chave de Versão de ERME2KAsyncSink.dll. Se o Exchange Server Analyzer detectar que o valor de Versão de ERME2KAsyncSink.dll é menor do que 1.015, um aviso será exibido.

O arquivo ERME2KAsyncSink.dll é um binário central do Simpler-Webb ERM (Exchange Resource Manager). Se a versão de ERME2KAsyncSink.dll for menor do que 1.015, isso indica que o ERM versão 1.2 ou anterior está instalado no servidor. Há um problema conhecido com o ERM versão 1.2, que pode fazer com que a fila de entrega local do Exchange pare a entrega das mensagens enquanto o Exchange OLE DB aguarda uma chamada de retorno do coletor de eventos ERM. O OLEDB do Microsoft Exchange está aguardando o coletor de eventos ERME2KAsyncSink.dll retornar da chamada OnSyncSave, enquanto o armazenamento do Exchange está sendo encerrado.

Uma falha ao retornar desta chamada poderia evitar o encerramento completo do Exchange Store. Esse problema foi resolvido no ERM versão 1.35.

Para corrigir esse aviso

  1. Use Adicionar ou Remover Programas para remover manualmente o ERM versão 1.2.

  2. Instale o ERM versão 1.35, disponível no site do Simpler-Webb (http://www.swinc.com/products/ERM/upgrade/).

    Observação:
    As informações sobre sites da Web de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


Atualização do Sybari Antigen 7.5 for Microsoft Exchange para o Exchange disponível
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê o seguinte valor de Registro para determinar se existe um arquivo de biblioteca VSAPI (Virus Scanning Application Programming Interface) registrado junto ao serviço Armazenamento de Informações do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

O Antigen 7.5 for Microsoft Exchange é um produto Sybari. Quando o Antigen 7.5 for Microsoft Exchange estiver instalado no Exchange 2000 Server ou Exchange Server 2003, a entrada de Registro da Biblioteca terá o valor ANTIGENVSAPI.DLL. O arquivo da biblioteca executa várias funções relacionadas a VSAPI no Antigen 7.5 for Microsoft Exchange.

O Analisador do Exchange Server também consulta a classe WMI CIM_Datafile (Instrumentação de Gerenciamento do Microsoft Windows®) para conhecer o valor da chave Version para ANTIGENVSAPI.DLL. Se o valor da chave Version indicar que o número da compilação é menor que 1316 para esse arquivo, será exibido um aviso.

Um número de versão menor que 1316 para ANTIGENVSAPI.DLL indica que a versão mais recente do Antigen 7.5 for Microsoft Exchange não está instalada. Uma atualização de software para o Antigen 7.5 for Microsoft Exchange está disponível no site da Sybari. Essa atualização é altamente recomendável e pode melhorar o desempenho e a confiabilidade gerais.

Para corrigir esse aviso

  1. Visite o site da Sybari, "Licensed Download Center" (http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx).

    Observação:
    Endereços da Web podem mudar, por isso, talvez você não consiga se conectar ao site mencionado aqui.

  2. Baixe a atualização mais recente para a sua versão do Antigen 7.5 for Microsoft Exchange.

  3. Faça um backup completo do computador do Exchange Server.

  4. Instale a atualização mais recente do Antigen 7.5 for Microsoft Exchange.

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange Server com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros disponíveis para o Exchange Server, consulte Exchange Server Partners: Antivirus Web site (em inglês) (http://go.microsoft.com/fwlink/?linkid=16226).


Atualização do Sybari Antigen 8.0 for Microsoft Exchange para o Exchange disponível
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-01-09

A ferramenta Analisador do Microsoft® Exchange Server lê o seguinte valor de Registro para determinar se existe um arquivo de biblioteca VSAPI (Virus Scanning Application Programming Interface) registrado junto ao serviço Armazenamento de Informações do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

O Antigen 8.0 for Microsoft Exchange é um produto Sybari. Quando o Antigen 8.0 for Microsoft Exchange estiver instalado no Exchange 2000 Server ou Exchange Server 2003, a entrada de Registro da Biblioteca terá o valor ANTIGENVSAPIEx.DLL. O arquivo da biblioteca executa várias funções relacionadas a VSAPI no Antigen 8.0 for Microsoft Exchange.

O Analisador do Exchange Server também consulta a classe WMI CIM_Datafile (Instrumentação de Gerenciamento do Microsoft Windows®) para conhecer o valor da chave Version para ANTIGENVSAPI.DLL. Se o valor da chave Version indicar que o número da compilação é menor que 1517 para esse arquivo, será exibido um aviso.

Um número de versão menor que 1517 para ANTIGENVSAPI.DLL indica que a versão mais recente do Antigen 8.0 for Microsoft Exchange não está instalada. Uma atualização de software para o Antigen 8.0 for Microsoft Exchange está disponível no site da Sybari. Essa atualização é altamente recomendável e pode melhorar o desempenho e a confiabilidade gerais.

Para corrigir esse aviso

  1. Visite o site da Sybari, "Licensed Download Center" (http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx).

    Observação:
    Endereços da Web podem mudar, por isso, talvez você não consiga se conectar ao site mencionado aqui.

  2. Baixe a atualização mais recente para a sua versão do Antigen 8.0 for Microsoft Exchange.

  3. Faça um backup completo do computador do Exchange Server.

  4. Instale a atualização mais recente do Antigen 8.0 for Microsoft Exchange.

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange Server com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros disponíveis para o Exchange Server, consulte Exchange Server Partners: Antivirus Web site (em inglês) (http://go.microsoft.com/fwlink/?linkid=16226).


O Sybari Antigen está instalado no servidor Exchange, mas o serviço AntigenStore não está executando.
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar se o Sybari Antigen está instalado e o serviço AntigenStore está sendo executado no computador do Exchange.

O Analisador do Exchange Server também consulta a classe WMI Win32_Service para determinar se a definição de valor da chave Started no serviço Armazenamento de Informações do Microsoft Exchange está definido como True ou False.

Um valor igual a False indica que o serviço de Armazenamento de Informações do Microsoft Exchange não está executando nesse computador do Exchange Server. Uma valor igual a True indica que o serviço de Armazenamento de Informações do Microsoft Exchange está executando.

Se o Exchange Server Analyzer detectar que o serviço Armazenamento de Informações do Microsoft Exchange está em execução, e que o Sybari Antigen está instalado, mas o serviço AntigenStore não foi iniciado, será exibido um aviso.

O Sybari Antigen fornece proteção antivírus para o Exchange Server. Algumas possíveis razões para a interrupção do serviço Sybari AntigenStore, junto com as soluções, são listadas aqui.

  • O software no qual você está executando o Exchange Server pode ser uma versão de avaliação ou teste cujo prazo expirou. Nesse caso, talvez você precise reinstalar o Sybari Antigen. No mínimo, para continuar usando esse software, você deve ativá-lo.

  • Um administrador pode ter parado involuntariamente o serviço do Sybari Antigen. Verifique se o serviço está definido para iniciar automaticamente e inicie o serviço.

  • Um worm mal intencionado, um vírus ou outro programa podem ter parado o serviço. Verifique se o serviço está definido para iniciar automaticamente e inicie o serviço. Se o serviço continuar a parar inesperadamente sem eventos de erro relevantes, verifique se o computador não está infectado com um worm mal intencionado e elimine a infecção do sistema, caso necessário.

Em geral, recomenda-se implantar um software antivírus projetado para sistemas de mensagens no gateway do protocolo SMTP ou nos servidores Exchange que hospedam caixas de correio. Para uma proteção mais segura, execute o software antivírus no gateway que verifica as mensagens MIME de entrada, e um verificador de vírus no Exchange Server que usa o VSAPI 2.5. Além disso, você deve executar o software antivírus cliente na área de trabalho do usuário. Se você estiver executando um software antivírus projetado para sistemas de mensagens (ele pode analisar e verificar o MIME) no gateway ou no servidor Exchange, a execução de um verificador de nível de arquivo na área de trabalho é suficiente.

Para iniciar o serviço AntigenStore

  1. Abra o snap-in Serviços do MMC.

  2. Clique com o botão direito no serviço AntigenStore e clique em Propriedades.

  3. Na guia Geral da página de propriedades do serviço AntigenStore, verifique se o Tipo de inicialização está definido como Automático. Se não estiver, defina como Automático, clique em Aplicar e clique em OK.

  4. Clique com o botão direito no serviço AntigenStore e clique em Iniciar.

  5. Feche o snap-in Serviços.

Para obter mais informações sobre como fortificar um ambiente do Exchange contra worms e vírus transmitidos por email, consulte "Slowing and Stopping E-Mail Viruses in an Exchange Server 2003 Environment" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47587).

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105

  • 245822, "Recomendações para a solução de problemas em um computador do Exchange com software antivírus instalado" http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822

Para obter uma lista de softwares antivírus de terceiros, disponíveis no Exchange Server, consulte Parceiros do Exchange Server: Antivirus Web site (em inglês) (http://go.microsoft.com/fwlink/?linkid=16226).


O Sybari Antigen está instalado no servidor Exchange, mas o serviço está parado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o Sybari Antigen está instalado, e se o serviço AntigenService está sendo executado no computador do Exchange Server.

O Analisador do Exchange Server também consulta a classe WMI Win32_Service para determinar se a definição de valor da chave Started no serviço Armazenamento de Informações do Microsoft Exchange está definido como True ou False.

Um valor igual a False indica que o serviço de Armazenamento de Informações do Microsoft Exchange não está executando nesse computador do Exchange Server. Uma valor igual a True indica que o serviço de Armazenamento de Informações do Microsoft Exchange está executando.

Se o Exchange Server Analyzer verificar que o serviço Armazenamento de Informações do Microsoft Exchange está sendo executado e que o Sybari Antigen está instalado, mas que o serviço AntigenService ainda não foi iniciado, um aviso será exibido.

O Sybari Antigen fornece proteção antivírus para o Exchange Server. A seguir, algumas razões pelas quais o serviço Sybari Antigen pode ter sido interrompido, junto com algumas soluções:

  • O software no qual você está executando o Exchange Server pode ser uma versão de avaliação (ou teste) cujo prazo expirou. Nesse caso, talvez você precise reinstalar o Sybari Antigen. No mínimo, para continuar usando esse software, você deve ativá-lo.

  • Um administrador pode ter parado involuntariamente o serviço do Sybari Antigen. Verifique se o serviço está definido para iniciar automaticamente e inicie o serviço.

  • Um worm mal intencionado, um vírus ou outro programa podem ter parado o serviço. Verifique se o serviço está definido para iniciar automaticamente e inicie o serviço. Se o serviço continuar a parar inesperadamente sem eventos de erro relevantes, verifique se o computador não está infectado com um worm mal intencionado e elimine a infecção do sistema, caso necessário.

Geralmente é recomendado que você implante um software antivírus projetado para sistemas de mensagens no gateway do protocolo SMTP ou nos servidores Exchange que hospedam caixas de correio. Para uma proteção mais segura, execute um software antivírus no gateway que verifica as mensagens MIME de entrada e um antivírus no servidor Exchange que usa o VSAPI 2.5. Além disso, você deve executar o software antivírus nos computadores clientes. Se você estiver executando um software antivírus projetado para sistemas de mensagens (ele pode analisar e verificar o MIME) no gateway ou no servidor Exchange, a execução de um scanner de nível de arquivo na área de trabalho é suficiente.

Para iniciar o serviço AntigenService

  1. Abra o snap-in Serviços do MMC.

  2. Clique com o botão direito no serviço AntigenService e clique em Propriedades.

  3. Na guia Geral da página de propriedade AntigenService, verifique se o Tipo de inicialização está definido como Automático. Se não estiver, defina como Automático, clique em Aplicar e clique em OK.

  4. Clique com o botão direito no serviço AntigenService e clique em Iniciar.

  5. Feche o snap-in Serviços.
  • Para obter mais informações sobre como proteger o ambiente do Exchange contra vírus e worms transmitidos por email, consulte "Retardando e interceptando os vírus de email em um ambiente do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47587).

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis no Exchange Server, consulte Parceiros do Exchange Server: Antivirus Web site (em inglês) (http://go.microsoft.com/fwlink/?linkid=16226).


As definições do Symantec Antivirus não são atualizadas há mais de 30 dias
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada de Registro para determinar se as seguintes condições são verdadeiras:

  • O antivírus Symantec está instalado no servidor.

  • Os seguintes arquivos de definição do antivírus estão atualizados:

    HKEY_LOCAL_MACHINE\Software\Symantec\SharedDefs\MicroDefs

Se o Exchange Server Analyzer detectar que os dados de valor para a chave do Registro BinHubStamp não são atualizados há mais de 30 dias, ele exibirá um aviso.

O antivírus Symantec para o Microsoft Exchange Server fornece proteção antivírus para o Exchange Server. É recomendado que você baixe a definição mais recente do antivírus Symantec, assim que for liberada. Certifique-se de implantar a atualização da definição de antivírus às seguintes camadas em sua organização:

  • Servidores de gateway de mensagens

  • Servidores Exchange

  • Estações de trabalho clientes

Para baixar as definições de vírus mais recentes, consulte o site do antivírus Symantec, "Home page da Symantec" (http://www.symantec.com).

Para obter mais informações sobre como proteger o ambiente do Exchange contra vírus e worms transmitidos por email, consulte "Retardando e interceptando os vírus de email em um ambiente do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47587).

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange Server com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis no Exchange Server, consulte Parceiros do Exchange Server: Antivirus Web site (em inglês) (http://go.microsoft.com/fwlink/?linkid=16226).

Observação:
Endereços da Web podem mudar, por isso, talvez você não consiga se conectar ao site ou sites mencionados aqui.


O Symantec Antivirus está instalado no servidor Exchange, mas o serviço está parado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se há um valor definido para a chave Started. A classe Win32_Service determina se o Symantec Antivirus para Exchange Server está instalado. O valor True na chave Started indica que o serviço Symantec Antivirus está sendo executado nesse computador do Exchange Server. O valor False na chave Started indica que o serviço Symantec Antivirus não está sendo executado nesse computador do Exchange Server.

Se descobrir que o Symantec Antivirus está instalado no computador do Exchange Server, mas que seu serviço não foi iniciado, o Exchange Server Analyzer exibirá um aviso.

O Symantec Antivirus fornece proteção antivírus para o Exchange Server. Alguns possíveis motivos para a interrupção do serviço Symantec Antivirus, juntamente com as soluções, estão listados aqui.

  • O software que você está executando no Exchange Server pode ser uma versão de avaliação ou de teste cujo prazo expirou. Nesse caso, talvez você precise reinstalar o Symantec Antivirus. No mínimo, para continuar usando o software, você precisará ativá-lo.

  • Um administrador pode ter parado involuntariamente o serviço Symantec Antivirus. Verifique se o serviço está definido para iniciar automaticamente e inicie o serviço.

  • Um worm mal intencionado, um vírus ou outro programa podem ter parado o serviço. Verifique se o serviço está definido para iniciar automaticamente e inicie o serviço. Se o serviço continuar a parar inesperadamente sem eventos de erro relevantes, verifique se o computador não está infectado por um worm mal-intencionado e desinfete o sistema, se necessário.

É recomendável que você implante um software antivírus projetado para sistemas de mensagens no gateway do protocolo SMTP ou nos servidores Exchange que hospedam caixas de correio. Para uma proteção mais segura, execute o software antivírus no gateway que verifica as mensagens MIME de entrada, e um verificador de vírus no Exchange Server que usa o VSAPI 2.5.

Para iniciar o serviço Symantec Antivirus

  1. Abra o snap-in Serviços do MMC.

  2. Clique com o botão direito do mouse no serviço Symantec Antivirus e, em seguida, clique em Properties.

  3. Na guia General da página de propriedades do Symantec Antivirus, verifique se o Start-up type está definido como Automatic. Se não estiver, clique em Aplicar e clique em OK.

  4. Clique com o botão direito do mouse no serviço Symantec Antivirus e, em seguida, clique em Start.

  5. Feche o snap-in Serviços.

Além disso, você deve executar um software antivírus cliente no desktop do usuário. Uma verificação no nível de arquivo no desktop oferecerá proteção suficiente se uma das seguintes condições for verdadeira:

  • Você está executando um software antivírus projetado para sistemas de mensagens que podem analisar e verificar MIME no gateway.

  • Você está executando um software antivírus projetado para sistemas de mensagens que podem analisar e verificar MIME no servidor Exchange.

Para obter mais informações sobre os diferentes tipos de programas verificador de vírus que normalmente são usados com o Microsoft Exchange Server 2003, consulte o artigo 823166 da Base de Dados de Conhecimento Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Para obter mais informações sobre os diferentes tipos de programas verificadores de vírus que normalmente são usados com o Microsoft Exchange Server 2000, consulte o artigo 328841 da Base de Dados de Conhecimento Microsoft, "Exchange e software verificador de vírus" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Para obter mais informações sobre como fortificar um ambiente do Exchange Server contra worms e vírus transmitidos por email, consulte "Reduzindo e erradicando vírus de email em um ambiente do Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47587).


Alertas de configuração da verificação antivírus do Symantec Mail Security para Exchange
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor definido para a chave Started do serviço SMSMSE (Symantec Mail Security para Microsoft Exchange).

Um valor True indica que o Symantec Mail Security para Microsoft Exchange Server está instalado neste computador do Exchange Server e que o serviço SMSMSE está em execução. Um valor False indica que o serviço SMSMSE não está sendo executado.

O Analisador do Exchange Server também consulta a classe WMI Win32_Service para determinar se a definição de valor da chave Started no serviço Armazenamento de Informações do Microsoft Exchange está definido como True ou False.

Um valor igual a False indica que o serviço de Armazenamento de Informações do Microsoft Exchange não está executando nesse computador do Exchange Server. Uma valor igual a True indica que o serviço de Armazenamento de Informações do Microsoft Exchange está executando.

Se o Exchange Server Analyzer detectar que o serviço Armazenamento de Informações do Microsoft Exchange está em execução e que o Symantec Mail Security para Microsoft Exchange está instalado, mas o serviço SMSMSE não está em execução, um aviso será exibido.

Uma das ameaças significativas ao seu ambiente são os vírus transmitidos por mensagens de email. Os vírus de email podem atacar os próprios sistemas dos computadores ou o ambiente de email, inundando o sistema com mensagens ao ponto de ocorrer sobrecarga. Você precisa se certificar de que tem proteção suficiente contra vírus em seu ambiente. Considere a proteção contra vírus no firewall, no gateway SMTP ou fora dele, em cada servidor Exchange e em todos os clientes.

Para corrigir esse aviso

  1. Inicie o snap-in Serviços do Windows no computador do Exchange Server.

  2. No painel da direita, role para baixo até o serviço Symantec Mail Security para Microsoft Exchange e clique duas vezes nele.

  3. Verifique se o valor na caixa suspensa Tipo de inicialização está definido como Automático.

  4. Clique em Iniciar para iniciar o serviço Symantec Mail Security para Microsoft Exchange.

  5. Clique em OK para salvar as alterações e fechar a caixa de diálogo Propriedades; em seguida, saia do snap-in.

Para obter mais informações sobre como fortificar um ambiente do Exchange contra worms e vírus transmitidos por email, consulte "Slowing and Stopping E-Mail Viruses in an Exchange Server 2003 Environment" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47587).

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis no Exchange Server, consulte Parceiros do Exchange Server: Antivirus Web site (em inglês) (http://go.microsoft.com/fwlink/?linkid=16226).


Atualização do Symantec Mail Security para Microsoft Exchange 4.5 disponível
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-02-14

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe CIM_Datafile do WMI para determinar o valor da chave Versão de Savfmsevsapi.dll. Se o valor da chave Versão indicar que o número de compilação é 4.5 para esse arquivo, será exibido um aviso.

O número de versão 4.5 para Savfmsevsapi.dll indica que você não está executando a versão mais atual do Symantec Mail Security para Microsoft Exchange 4.6x. Uma atualização de software para o Symantec Mail Security para Microsoft Exchange 4.6x está disponível no site da Symantec na Web. A atualização para a versão 4.63 ou versões posteriores é altamente recomendável e pode melhorar o desempenho e a confiabilidade gerais.

A seguir, alguns dos problemas conhecidos da execução da versão 4.5 do Savfmsevsapi.dll.

  • Processos de fluxo de mensagens do servidor Exchange podem sofrer uma diminuição de desempenho durante operações normais.

  • É feito backup de filas SMTP, como as filas Pesquisa de Diretório e Entrega Local.

  • O serviço Armazenamento de Informações do Microsoft Exchange não pode ser interrompido.

  • Clientes Microsoft Outlook® não podem se conectar ao servidor Exchange.

  • Mensagens enviadas de clientes outlook levam muito mais tempo do que o normal para entregar uma mensagem ao servidor Exchange. Clientes Outlook podem não responder por 30 segundos.

Para corrigir esse aviso

  1. Visite a página Enterprise Support do site da Symantec (http://www.symantec.com/techsupp/enterprise/).

  2. Atualiza para a versão 4.63 ou posterior.
Observação:
As informações sobre sites da Web de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, Exchange e software antivírus (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, Visão geral do Exchange Server 2003 e do software antivírus (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, XGEN: Posição da Microsoft sobre soluções antivírus para o Exchange 2000 (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, Recomendações para solucionar problemas em um computador do Exchange Server com software antivírus instalado (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros disponíveis para o Exchange Server, consulte Parceiros do Exchange Server: Antivírus (em inglês) (http://go.microsoft.com/fwlink/?linkid=16226).


Atualização do Trend Micro ScanMail para Microsoft Exchange disponível
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-01-09

A ferramenta Analisador do Microsoft® Exchange Server lê o seguinte valor de Registro para determinar se existe um arquivo de biblioteca VSAPI (Virus Scanning Application Programming Interface) registrado no Armazenamento de Informações do Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Quando o ScanMail para Microsoft Exchange, um produto da Trend Micro, estiver instalado no Exchange 2000 Server ou no Exchange Server 2003, a entrada de Registro da Biblioteca terá o valor SMXS3DLL.DLL. Esse arquivo de biblioteca executa várias funções relacionadas à VSAPI no ScanMail para Microsoft Exchange.

O Analisador do Exchange Server também consulta a classe WMI CIM_Datafile (Instrumentação de Gerenciamento do Microsoft Windows®) para conhecer o valor da chave Version para SMXS3DLL.DLL. Se o valor da chave Version indicar que o número da compilação é menor que 1174 para esse arquivo, será exibido um aviso.

Um número de versão menor que 1174 para SMXS3DLL.DLL indica que a versão mais recente do ScanMail para Microsoft Exchange não está instalada. Existe uma atualização de software disponível para o ScanMail para Microsoft Exchange no site da Trend Micro. Essa atualização é altamente recomendável e pode melhorar o desempenho e a confiabilidade gerais.

Para corrigir esse aviso

  1. Visite o site da Trend Micro na Web, "Update Center, ScanMail for Microsoft Exchange" (http://www.trendmicro.com/download/product.asp?productid=8).

  2. Baixe a atualização mais recente para a sua versão do ScanMail para Microsoft Exchange.

  3. Faça um backup completo do computador com o Exchange Server.

  4. Instale a atualização mais recente do ScanMail para Microsoft Exchange.

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros disponíveis para o Exchange Server, consulte Exchange Server Partners: Antivirus Web site (em inglês) (http://go.microsoft.com/fwlink/?linkid=16226).


O Trend Micro ServerProtect for Microsoft Windows está parado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar o valor da chave Started do serviço SpntSvc. O serviço SpntSvc é instalado pelo ServerProtect for Microsoft Windows, que é um produto da Trend Micro. Um valor True para a chave Started indica que o serviço está em execução e um valor False indica que o serviço não está em execução. Se o Analisador do Exchange Server detectar que o serviço SpntSvc não foi iniciado, será exibido um aviso.

ServerProtect para Microsoft Windows fornece uma verificação antivírus para servidores com base no sistema de arquivos, incluindo exclusão e remoção de vírus em tempo real.

Para iniciar o serviço SpntSvc

  1. Abra o snap-in Serviços do MMC.

  2. Clique com o botão direito no serviço ServerProtect Server e clique em Propriedades.

  3. Na guia Geral da página de propriedades do ServerProtect Server , verifique se o Tipo de inicialização está definido como Automático. Se não estiver, defina como Automático, clique em Aplicar e clique em OK.

  4. Clique com o botão direito no serviço ServerProtect Server e clique em Propriedades.

  5. Feche o snap-in Serviços.

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis no Exchange Server, consulte Parceiros do Exchange Server: Antivirus Web site (em inglês) (http://go.microsoft.com/fwlink/?linkid=16226).


Configuração do Trend ScanMail: desempenho pode ser aprimorado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-09-05

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar o valor de TempFileThreshold:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\ScanOption

O valor do Registro de TempFileThreshold é aplicável à verificação do corpo da mensagem e de anexos. Se o tamanho do corpo da mensagem ou do anexo for maior que o valor especificado na chave TempFileThreshold, será criado o arquivo temp no disco. Caso contrário, esse arquivo será criado na memória. O valor padrão de TempFileThreshold é de 3.072 quilobytes (3 MB).

O Exchange Server Analyzer também consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_ComputerSystem para obter o valor definido para a chave TotalPhysicalMemory. Esse valor representa a quantidade de RAM (memória de acesso aleatório) instalada no computador.

O Exchange Server Analyzer consulta também o serviço de diretório do Active Directory® para conhecer o valor do atributo delivContLength das configurações globais, localizado em:

CN=Configuração, CN=Serviços, CN=Microsoft Exchange, CN= OrganizationName , CN=Configurações Globais, CN=Entrega de Mensagens

Esse atributo representa o tamanho máximo das mensagens SMTP recebidas.

Se o Exchange Server Analyzer detectar que o valor de TempFileThreshold é menor que 70% do tamanho máximo da mensagem recebida em um computador do Exchange Server com 1 GB ou mais de RAM, será exibido um aviso.

Esse aviso indica que o valor do Registro TempFileThreshold não pode ser otimizado para seu ambiente. Esse valor deve estar definido como no mínimo igual ao tamanho do anexo limite definido nos servidores Exchange.

Observação:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\ScanOption

  3. No painel direito, clique duas vezes em TempFileThreshold.

  4. Digite um valor, em quilobytes, que seja igual ao tamanho médio da mensagem em sua organização. Por exemplo, se o tamanho médio da mensagem fosse 10 MB, você digitaria 10240.
Observação:
Pode ser necessária memória adicional do sistema se você aumentar esse valor. Por exemplo, se o valor de 'ScanningThreads' for definido como 8 e o valor de 'TempFileThreshold', com 10240, a memória mínima necessária para a verificação de vírus será de 80 MB (ScanningThreads * TempFileThreshold).
  1. Feche o editor de Registro e reinicie os serviços ScanMail_RealTimeScan e Microsoft Exchange Information Store para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Configuração do Trend ScanMail: O valor QuerySender do Registro está habilitado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-04-20

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started do serviço ScanMail_Action do Trend Micro ScanMail para Microsoft Exchange. Um valor Verdadeiro indica que o serviço ScanMail_Action está em execução, e um valor Falso indica que ele não está em execução.

O Exchange Server Analyzer também lê a entrada do Registro a seguir para determinar se o ScanMail para Microsoft Exchange está configurado para pesquisas com caracteres curinga no serviço de diretório do Active Directory®:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\QuerySender

Um valor 0 na entrada do Registro QuerySender indica que pesquisas com caracteres curingas estão desabilitadas. Um valor 1 na entrada do Registro QuerySender indica que pesquisas com caracteres curingas estão habilitadas.

Além disso, o Exchange Server Analyzer consulta o Active Directory para determinar o número de entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Se o Exchange Server Analyzer determinar que o serviço ScanMail_Action está em execução, que o Exchange Server contém mais de 100 caixas de correio e que a entrada do Registro QuerySender não está definida como 0, será exibido um aviso.

O Trend Micro ScanMail para Microsoft Exchange oferece proteção antivírus ao Exchange Server. Quando o ScanMail para Exchange está verificando uma mensagem enviada para uma lista de distribuição, seu comportamento padrão é procurar no catálogo global do Active Directory todos os destinatários das mensagens. Se existir um grande número de destinatários na lista de distribuição, esse comportamento poderá causar problemas de desempenho. Além disso, os contadores de desempenho a seguir serão altos se as recomendações deste artigo não forem implementadas:

  • MSExchangeIS/Comprimento da Fila de Verificação de Vírus

  • MSExchangeIS/Solicitações RPC

  • MSExchangeIS/Latência Média de RPC

Definir o valor QuerySender como 0 impede que o ScanMail para Microsoft Exchange consulte o catálogo global de todos os destinatários ao verificar mensagens enviadas para listas de distribuição.

Para corrigir esse aviso

  1. Entre em contato com a Trend Micro para obter informações sobre como usar o valor do Registro QuerySender (http://www.trendmicro.com/en/about/overview.htm).

  2. Para obter mais informações sobre o valor do Registro QuerySender, consulte a Trend Micro Solution ID 120393 (http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-120393).

    Observação:
    Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como proteger o ambiente do Exchange contra vírus e worms transmitidos por email, consulte "Retardando e interceptando os vírus de email em um ambiente do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47587).

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis no Exchange Server, consulte Parceiros do Exchange Server: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).


Configuração do Trend ScanMail: O serviço ScanMail_Monitor não depende do Serviço de Cluster
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-02-13

O Microsoft® Exchange Server Analyzer Tool lê a entrada do Registro a seguir em cada servidor que é um nó do cluster:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\CurrentVersion\Version

Um valor Version de 6.2.000 indica que a versão 6.2 do ScanMail para Microsoft Exchange está instalada.

O Exchange Server Analyzer também consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started para ClusSvc, o serviço de Cluster. Um valor Verdadeiro indica que o serviço de Cluster está em execução, e um valor Falso indica que não está em execução.

O Exchange Server Analyzer também lê a entrada do Registro a seguir em cada servidor que é nó de um cluster:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ScanMail_Monitor

Se o Exchange Server Analyzer detectar que a chave ScanMail_Monitor não inclui a entrada do Registro de valores múltiplos DependOnService com um valor de ClusSvc, o serviço ScanMail_Monitor não será dependente do serviço de Cluster.

O Exchange Server Analyzer exibirá uma mensagem de aviso se as seguintes condições forem verdadeiras:

  • O servidor está executando a versão TrendMicro ScanMail para Microsoft Exchange 6.2.

  • O servidor está executando o serviço de Cluster (ClusSvc).

  • O serviço ScanMail_Monitor não está configurado para depender do serviço de Cluster.

Depois que você instalar compilações do ScanMail para Microsoft Exchange 6.2, configure o serviço ScanMail_Monitor para depender do serviço de Cluster. Se você não configurar essa dependência, o serviço de Cluster parará de responder sempre que o nó for reiniciado.

Para corrigir esse aviso

  1. Consulte O serviço de Cluster do Microsoft Exchange pára inesperadamente depois que ScanMail para Exchange (SMEX) 6.2 Patch 1 é aplicado [ID da Solução: 21441] no site da Trend Micro (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionId=21441&id=21441) (em inglês).

    Observação:
    Embora o artigo 21441 da ID da Solução se refira especificamente à exigência de se configurar essa dependência após a instalação do Patch 1, este artigo é aplicável aos servidores que estão executando qualquer compilação do ScanMail para Microsoft Exchange 6.2.

  2. Adicione ao Registro o valor DependOnService de múltiplas cadeias de caracteres, conforme especificado na seção "Solutions" (Soluções) do artigo 21441 da ID de Solução.
Observação:
As informações sobre sites da Web de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.

Para obter mais informações sobre outras atualizações de produtos Trend Micro, consulte o site Trend Micro Update Center (http://www.trendmicro.com/download/).

Para obter mais informações sobre como usar o software antivírus com o Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, Exchange e software antivírus (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, Visão geral do Exchange Server 2003 e do software antivírus (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, XGEN: Posição da Microsoft sobre soluções antivírus para o Exchange 2000 (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, Recomendações para solucionar problemas em um computador do Exchange Server com software antivírus instalado (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros disponíveis para o Exchange Server, consulte Parceiros do Exchange Server: Antivírus (em inglês) (http://go.microsoft.com/fwlink/?linkid=16226).


Configuração do Trend ScanMail: O valor do Registro SkipWildcardSearchInGC está definido como 0
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave Iniciado para o serviço ScanMail_Action do Trend Micro ScanMail para Microsoft Exchange. Um valor Verdadeiro indica que o serviço ScanMail_Action está em execução, e um valor Falso indica que ele não está em execução.

O Exchange Server Analyzer também lê a entrada do Registro a seguir para determinar se o ScanMail para Microsoft Exchange está configurado para pesquisas com caracteres curinga no serviço de diretório do Active Directory®:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SkipWildcardSearchInGC

O valor 1 para a entrada do Registro SkipWildcardSearchInGC indica que pesquisas com caracteres curinga não estão habilitadas. Um valor 0 para a entrada SkipWildcardSearchInGC indica que pesquisas com caracteres curinga estão habilitadas.

Além disso, o Exchange Server Analyzer também consulta o Active Directory para determinar o número das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Se o Exchange Server Analyzer determinar que o serviço ScanMail_Action está em execução, que o servidor Exchange contém mais de 100 caixas de correio e que a entrada de Registro SkipWildcardSearchInGC está definida como 0, um aviso será exibido.

O Trend Micro ScanMail para Microsoft Exchange oferece proteção antivírus ao Exchange Server. Definir o valor SkipWildcardSearchInGC como 1 impede que o ScanMail para Microsoft Exchange resolva um nome que contenha um caractere curinga (*). Consultar um nome com um caractere curinga pode reduzir significativamente o desempenho do computador do Exchange Server, pois o ScanMail para Exchange acaba verificando o diretório inteiro. Além disso, os contadores de desempenho a seguir serão altos se as recomendações deste artigo não forem implementadas:

  • MSExchangeIS/Comprimento da Fila de Verificação de Vírus

  • MSExchangeIS/Solicitações RPC

  • MSExchangeIS/Latência Média de RPC

Para corrigir esse aviso

  1. Entre em contato com a Trend Micro para obter informações sobre como usar o valor de Registro SkipWildcardSearchInGC (página em inglês) (http://www.trendmicro.com/en/about/overview.htm).

  2. Para obter mais informações sobre o valor de Registro SkipWildcardSearchInGC, consulte a ID de solução 20393 da Trend Micro (página em inglês) (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=20393).

    Observação:
    Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como proteger o ambiente do Exchange contra vírus e worms transmitidos por email, consulte "Retardando e interceptando os vírus de email em um ambiente do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47587).

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (em inglês) em (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis no Exchange Server, consulte Parceiros do Exchange Server: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).


Configuração do Trend ScanMail: o valor do Registro MaxMessageCount é menor que 500
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a entrada do Registro a seguir para determinar o valor de MaxMessageCount:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

Além disso, o Exchange Server Analyzer consulta também o serviço de diretório do Active Directory® para determinar a contagem das entradas listadas no atributo homeMDBBL de cada armazenamento de caixa de correio. a contagem deste atributo representa o número de caixas de correio existentes no armazenamento de caixas de correio.

Se o Exchange Server Analyzer determinar que o Exchange Server contém mais de 100 caixas de correio, e que o valor de MaxMessageCount é inferior a 500, um aviso será exibido.

O Trend Micro ScanMail para Microsoft Exchange oferece proteção antivírus ao Exchange Server. Depois que o thread de verificação do ScanMail para Exchange conclui uma tarefa, ele grava os resultados da verificação em uma fila. Se houver muitos itens nessa fila, o thread de verificação deverá aguardar até que possa gravar na fila e liberar o thread. O limite de tamanho para os resultados da verificação é controlado pelo valor MaxMessageCount. A definição do valor MaxMessageCount como 500 otimiza o desempenho do ScanMail para Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

  3. No painel direito, clique duas vezes em MaxMessageCount.

  4. Digite o valor 500 (decimal).

  5. Feche o editor de Registro e reinicie os serviços ScanMail_RealTimeScan e Microsoft Exchange Information Store para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, leia o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o uso do valor do Registro MaxMessageCount, consulte o site da Trend Micro (http://www.trendmicro.com/en/about/overview.htm).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como proteger o ambiente do Exchange contra vírus e worms transmitidos por email, consulte "Retardando e interceptando os vírus de email em um ambiente do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47587).

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis no Exchange Server, consulte Parceiros do Exchange Server: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).


O Trend ScanMail está configurado para excluir todos os anexos de arquivo
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê várias entradas do Registro para determinar se o ScanMail para Microsoft Exchange está configurado para excluir anexos. Os valores de leitura estão no Registro em:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\ScanOption\Advance

Valor | Descrição
ActionType | Indica quais anexos deverão ser bloqueados, se o bloqueio de anexos estiver ativado. Um valor 0 indica que todos os anexos estão bloqueados. Um valor 3 indica que o administrador especificou uma lista de nomes de arquivos, de extensões de nomes de arquivos ou de tipos de arquivos verdadeiros. Para definir essa configuração, selecione a opção apropriada na caixa de diálogo Attachment Blocking Settings (Configurações de Bloqueio de Anexo) no Console de Gerenciamento do ScanMail.
EnableAlert | Indica se o bloqueio de anexos está habilitado. Um valor 1 indica que o bloqueio de anexos está habilitado. Um valor 0 indica que o bloqueio de anexos está desabilitado. Essa definição pode ser configurada marcando (habilitar) ou desmarcando (desabilitar) a caixa de seleção Habilitar bloqueio de anexos na página Verificação de Vírus | Opções no Console de Gerenciamento do ScanMail.

HKLM\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\ScanOption

Valor | Descrição
EnableEManager | Indica se o ScanMail eManager está habilitado. Um valor 1 indica que o eManager está habilitado. Um valor 0 indica que o bloqueio de anexos está desabilitado. Esta definição pode ser configurada marcando (habilitar) ou desmarcando (desabilitar) a caixa de seleção Habilitar o eManager no Console de Gerenciamento do ScanMail. Esta configuração está disponível apenas quando o ScanMail eManager, um produto complementar separado, está instalado.
EnableWebStoreDelMail | Indica se o Filtro Ativo de Mensagens do ScanMail está habilitado para mensagens de entrada. Um valor 1 indica que o Filtro Ativo de Mensagens está habilitado para mensagens de entrada. Um valor 0 indica que ele não está habilitado para mensagens de entrada. Esta definição pode ser configurada marcando (habilitar) ou desmarcando (desabilitar) a caixa de seleção Mensagens de Entrada na caixa de diálogo Filtro Ativo de Mensagens no Console de Gerenciamento do ScanMail.

O Analisador do Exchange Server também lê a entrada de Registro a seguir para determinar se a verificação de mensagens do BSAPI (Virus Scanning API) está habilitada:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Um valor 1 para Habilitado indica que a verificação VSAPI está habilitada. Um valor 0 indica que a verificação VSAPI não está habilitada. Esta definição pode ser configurada marcando (habilitar) ou desmarcando (desabilitar) a caixa de seleção Habilitar verificação de vírus VS API na página Verificação de Vírus | Opções no Console de Gerenciamento do ScanMail.

Se o Exchange Server Analyzer achar que todos os critérios a seguir são verdadeiros, um aviso será exibido:

  • A verificação VSAPI está Habilitada no ScanMail para Exchange

  • EnableAlert tem um valor 1

  • ActionType tem um valor 0

  • EnableEManager tem um valor 1

  • EnableWebStoreDelMail tem um valor 1

Esse aviso indica que o ScanMail está configurado para excluir todos os anexos durante a próxima verificação agendada ou manual.

Para corrigir esse aviso

  1. Verifique se deseja excluir os anexos.

  2. Se desejar, desabilite o bloqueio de anexos ou altere a ação de Excluir para Quarentena. Isto permite que administrador examine os arquivos em quarentena em busca de anexos que podem precisar ser mantidos.

Para obter mais informações sobre o ScanMail para Microsoft Exchange e o ScanMail eManager, visite o site da Trend Micro (http://www.trend.com.br).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


O Trend ScanMail está configurado para excluir anexos com nomes de arquivo específicos
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê várias entradas do Registro para determinar se o ScanMail para Microsoft Exchange está configurado para excluir anexos. Os valores de leitura estão localizados no Registro em:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\ScanOption\Advance

Valor | Descrição
ActionType | Indica quais anexos deverão ser bloqueados, se o bloqueio de anexos estiver ativado. Um valor 0 indica que todos os anexos estão bloqueados. Um valor 3 indica que o administrador especificou uma lista de extensões de nomes de arquivo, nomes de arquivos ou tipos de arquivos reais. Essa definição pode ser configurada selecionando a opção desejada na caixa de diálogo Configurações de Bloqueio de Anexos no Console de Gerenciamento do ScanMail.
EnableAlert | Indica se o bloqueio de anexos está habilitado. Um valor 1 indica que o bloqueio de anexos está habilitado. Um valor 0 indica que o bloqueio de anexos está desabilitado. Essa definição pode ser configurada marcando (habilitar) ou desmarcando (desabilitar) a caixa de seleção Habilitar bloqueio de anexos na página Verificação de Vírus | Opções no Console de Gerenciamento do ScanMail.
FileName | Um valor de cadeia de caracteres delimitada por ponto-e-vírgula que contém uma lista de arquivos a serem excluídos. Quando os arquivos especificados estiverem sendo bloqueados, esta definição poderá ser configurada inserindo os nomes dos arquivos desejados na caixa de diálogo Configurações de Bloqueio de Anexo no Console de Gerenciamento do ScanMail.

HKLM\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\ScanOption

Valor | Descrição
EnableEManager | Indica se o ScanMail eManager está habilitado. Um valor 1 indica que o eManager está habilitado. Um valor 0 indica que o bloqueio de anexos está desabilitado. Esta definição pode ser configurada marcando (habilitar) ou desmarcando (desabilitar) a caixa de seleção Habilitar o eManager no Console de Gerenciamento do ScanMail. Esta configuração está disponível apenas quando o ScanMail eManager, um produto complementar separado, está instalado.
EnableWebStoreDelMail | Indica se o Filtro Ativo de Mensagens do ScanMail está habilitado para mensagens de entrada. Um valor 1 indica que o Filtro Ativo de Mensagens está habilitado para mensagens de entrada. Um valor 0 indica que ele não está habilitado para mensagens de entrada. Esta definição pode ser configurada marcando (habilitar) ou desmarcando (desabilitar) a caixa de seleção Mensagens de Entrada na caixa de diálogo Filtro Ativo de Mensagens no Console de Gerenciamento do ScanMail.

O Exchange Server Analyzer também lê a seguinte entrada do Registro para determinar se a verificação de mensagens VSAPI (API de Verificação de Vírus) está habilitada:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Um valor 1 para Habilitado indica que a verificação VSAPI está habilitada. Um valor 0 indica que a verificação VSAPI não está habilitada. Esta definição pode ser configurada marcando (habilitar) ou desmarcando (desabilitar) a caixa de seleção Habilitar verificação de vírus VS API na página Verificação de Vírus | Opções no Console de Gerenciamento do ScanMail.

Se o Exchange Server Analyzer detectar que todos os critérios a seguir são verdadeiros, um aviso será exibido:

  • A verificação de VSAPI está habilitada no ScanMail para Exchange.

  • EnableAlert tem um valor 1

  • ActionType tem um valor 3

  • EnableEManager tem um valor 1

  • EnableWebStoreDelMail tem um valor 1

  • FileName não é nulo nem vazio

Este aviso indica que o ScanMail está configurado para excluir todos os anexos com os nomes listados na chave FileName durante a próxima verificação manual ou agendada.

Para corrigir esse aviso

  1. Verifique se você deseja que os anexos com nomes listados na chave FileName sejam excluídos.

  2. Se desejar, desabilite o bloqueio de anexos ou altere a ação de Excluir para Colocar em Quarentena. Isto permite que administrador examine os arquivos em quarentena em busca de anexos que podem precisar ser mantidos.

Para obter mais informações sobre o ScanMail para Microsoft Exchange e ScanMail eManager, consulte o site da Trend Micro (http://www.trend.com).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


O Trend ScanMail está configurado para excluir anexos com extensões de arquivo específicas
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê várias entradas do Registro para determinar se o ScanMail para Microsoft Exchange Server está configurado para excluir anexos. Os valores de leitura estão no Registro em:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\ScanOption\Advance

Valor | Descrição
ActionType | Indica quais anexos deverão ser bloqueados, se o bloqueio de anexos estiver ativado. Um valor 0 indica que todos os anexos estão bloqueados. Um valor igual a 3 indica que o administrador especificou uma lista de extensões de arquivo, nomes de arquivos ou tipos reais de arquivo. Essa definição pode ser configurada selecionando a opção desejada na caixa de diálogo Configurações de Bloqueio de Anexos no Console de Gerenciamento do ScanMail.
EnableAlert | Indica se o bloqueio de anexos está habilitado. Um valor 1 indica que o bloqueio de anexos está habilitado. Um valor 0 indica que o bloqueio de anexos está desabilitado. Essa definição pode ser configurada marcando (habilitar) ou desmarcando (desabilitar) a caixa de seleção Habilitar bloqueio de anexos na página Verificação de Vírus | Opções no Console de Gerenciamento do ScanMail.
Extension | Um valor de cadeia de caracteres delimitados por ponto-e-vírgula contendo uma lista de extensões de arquivos de anexos a serem excluídos. Quando os anexos especificados estiverem sendo bloqueados, essa definição poderá ser configurada, digitando as extensões necessárias na caixa de diálogo Configurações de Bloqueio de Anexo no Console de Gerenciamento do ScanMail.

HKLM\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\ScanOption

Valor | Descrição
EnableEManager | Indica se o ScanMail eManager está habilitado. Um valor 1 indica que o eManager está habilitado. Um valor 0 indica que o bloqueio de anexos está desabilitado. Esta definição pode ser configurada marcando (habilitar) ou desmarcando (desabilitar) a caixa de seleção Habilitar o eManager no Console de Gerenciamento do ScanMail. Esta configuração está disponível apenas quando o ScanMail eManager, um produto complementar separado, está instalado.
EnableWebStoreDelMail | Indica se o Filtro Ativo de Mensagens do ScanMail está habilitado para mensagens de entrada. Um valor 1 indica que o Filtro Ativo de Mensagens está habilitado para mensagens de entrada. Um valor 0 indica que ele não está habilitado para mensagens de entrada. Esta definição pode ser configurada marcando (habilitar) ou desmarcando (desabilitar) a caixa de seleção Mensagens de Entrada na caixa de diálogo Filtro Ativo de Mensagens no Console de Gerenciamento do ScanMail.

O Exchange Server Analyzer também lê a seguinte entrada do Registro para determinar se a verificação de mensagens VSAPI (API de Verificação de Vírus) está habilitada:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Um valor 1 para Habilitado indica que a verificação VSAPI está habilitada. Um valor 0 indica que a verificação VSAPI não está habilitada. Esta definição pode ser configurada marcando (habilitar) ou desmarcando (desabilitar) a caixa de seleção Habilitar verificação de vírus VS API na página Verificação de Vírus | Opções no Console de Gerenciamento do ScanMail.

Se o Exchange Server Analyzer detectar que todos os critérios a seguir são verdadeiros, um aviso será exibido:

  • A verificação VSAPI está Habilitada no ScanMail para Exchange

  • EnableAlert tem um valor 1

  • ActionType tem um valor 3

  • EnableEManager tem um valor 1

  • EnableWebStoreDelMail tem um valor 1

  • Extension não é nulo nem vazio

Esse aviso indicaque o ScanMail está configurado para excluir todos os anexos com as extensões listadas na chave Extension na próxima verificação agendada ou manual.

Para corrigir esse aviso

  1. Confirme se os anexos com as extensões listadas na chave Extension devem ser excluídos.

  2. Se desejar, desabilite o bloqueio de anexos ou altere a ação de Excluir para Quarentena. Isto permite que administrador examine os arquivos em quarentena em busca de anexos que podem precisar ser mantidos.

Para obter mais informações sobre o ScanMail para Microsoft Exchange Server e o ScanMail eManager, visite o site da Trend Micro (http://www.trend.com).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


O Trend ScanMail está configurado para processar as mensagens duas vezes
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started para o serviço ScanMail_RealTimeScan. Um valor True indica que o serviço ScanMail_RealTimeScan está iniciado e um valor False indica que o serviço ScanMail_RealTimeScan não está iniciado. O serviço ScanMail_RealTimeScan é um componente do aplicativo Trend Micro ScanMail para Microsoft Exchange. O Trend Micro ScanMail for Microsoft Exchange oferece proteção antivírus para o Exchange.

Além disso, o Exchange Server Analyzer lê a entrada do Registro a seguir para determinar a configuração do valor Enabled:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI

Um valor 1 em Enabled indica que a verificação antivírus no nível de transporte (algumas vezes citada como verificação SMTP) está habilitada, e um valor 0 indica que a verificação SMTP não está habilitada.

Se o Exchange Server Analyzer detectar que Enabled está definido como 1 e o valor da chave Started para o serviço ScanMail_RealTimeScan está definido como True, será exibido um aviso.

Esse aviso indica que as mensagens que fluem pelo computador do Exchange Server estão sendo verificadas duas vezes pelo mesmo mecanismo de verificação de aplicativos e vírus. Nem precisaria dizer que verificar a mesma mensagem duas vezes à medida que ela se move através dos componentes de transporte e armazenamento do Exchange Server consome recursos e não propicia nenhuma proteção nem benefícios adicionais. É recomendável manter a verificação de vírus VSAPI habilitada e desabilitar a verificação de mensagens SMTP usando o Console de Gerenciamento do ScanMail.

Geralmente, é recomendável que você implante um software antivírus projetado para sistemas de mensagens no gateway do protocolo SMTP ou nos servidores Exchange que hospedam caixas de correio. Para obter mais proteção, execute o software antivírus no gateway que verifica as mensagens MIME de entrada e um scanner de vírus no Exchange Server que usa o VSAPI 2.5. Além disso, você deve executar o software antivírus cliente na área de trabalho do usuário. Se você estiver executando um software antivírus projetado para sistemas de mensagens (ele pode analisar e verificar o MIME) no gateway ou no servidor Exchange, a execução de um verificador de nível de arquivo na área de trabalho é suficiente.

Para corrigir esse aviso

  1. Abra o Console de Gerenciamento do ScanMail e digite suas credenciais de logon.

  2. Na página Verificação de Vírus | Opções, certifique-se de que a caixa de seleção Habilitar verificação de vírus VS API está marcada.

  3. Na mesma página, desmarque a caixa de seleção Habilitar verificação de mensagens SMTP.

  4. Clique em Aplicar para salvar as alterações.

  5. Feche o Console de Gerenciamento do ScanMail.

Para obter mais informações sobre o ScanMail para Microsoft Exchange da Trend Micro, consulte o site da Trend Micro (http://kb.trendmicro.com/solutions/search).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e Software Antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e software antivírus" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft sobre soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=306105) (página em inglês).

  • 245822, "Recomendações para a solução de problemas em um computador do Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822) (página em inglês)


Baixa contagem de threads Trend ScanMail
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar o valor de MaxScanningThreadCount:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\ScanOption

O valor do Registro MaxScanningThreadCount representa o número máximo de threads que o ScanMail para Exchange pode criar para verificação. O valor padrão é 12.

O Exchange Server Analyzer também lê a seguinte entrada do Registro para determinar se a verificação de mensagens VSAPI (API de Verificação de Vírus) está habilitada:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Um valor 1 para Habilitado indica que a verificação VSAPI está habilitada. Um valor 0 indica que a verificação VSAPI não está habilitada.

O Analisador do Exchange Server também consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows) Win32_ComputerSystem para determinar o valor definido para a chave NumberOfProcessors. Esse valor representa o número de processadores instalados no computador, incluindo tanto processadores físicos quanto processadores lógicos. Usando a tecnologia Hyper-Threading da Intel, um processador físico pode ser dividido em dois processadores lógicos.

O Analisador do Exchange Server também consulta o serviço de diretório do Active Directory® para determinar o número de objetos com uma classe de objeto igual a msExchPrivateMDB. O contador desses objetos representa o número de armazenamentos de caixas de correio neste computador do Exchange Server.

Se o Exchange Server Analyzer detectar que o valor de MaxScanningThreadCount é menor que (2 × NumberOfProcessors + 1) + 3 + o número de armazenamentos de caixas de correio) em um computador do Exchange Server com verificação VSAPI habilitada, será exibido um aviso.

Observação:
Se o Hyper-Threading estiver habilitado, o valor de NumberOfProcessors será o dobro do número de processadores físicos. É recomendável que você use a fórmula acima para sistemas com processadores físicos, bem como para sistemas com processadores físicos e lógicos.

Este aviso indica que o valor do Registro MaxScanningThreadCount não pode ser otimizado para seu ambiente. Esse valor deve estar definido como no mínimo igual ao tamanho do anexo limite definido nos servidores Exchange. Para obter informações sobre um valor de Registro relacionado, consulte Baixa contagem do pool de threads Trend ScanMail.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\ScanOption

  3. No painel da direita, clique duas vezes em MaxScanningThreadCount.

  4. Insira um valor recomendado pelo Analisador do Exchange Server.

  5. Feche o editor do Registro e reinicie os serviços ScanMail_RealTimeScan e Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro MaxScanningThreadCount, consulte a Trend Micro Solution ID 13176 (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=13176).

Para obter mais informações sobre a tecnologia Hyper-Threading, consulte o site da Intel (http://www.intel.com/technology/hyperthread).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


Baixa contagem do pool de threads Trend ScanMail
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-04-21

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar o valor de ScanningThreadPoolCount:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\ScanOption

O valor do Registro ScanningThreadPoolCount representa o número de threads de verificação que serão inicializados e preparados para uso quando o ScanMail para serviços do Exchange for iniciado. O valor padrão é 12. Quando todos os threads criados na inicialização estiverem totalmente utilizados, o ScanMail para Exchange criará outros threads para serem usados até ele atingir o número de threads controlados pelo valor do Registro MaxScanningThreadCount descrito em Baixa contagem de threads Trend ScanMail.

O Analisador do Exchange Server também lê a entrada de Registro a seguir para determinar se a verificação de mensagens do BSAPI (Virus Scanning API) está habilitada:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Um valor 1 para Habilitado indica que a verificação VSAPI está habilitada. Um valor 0 indica que a verificação VSAPI não está habilitada.

O Analisador do Exchange Server também consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows) Win32_ComputerSystem para determinar o valor definido para a chave NumberOfProcessors. Esse valor representa o número de processadores instalados no computador, incluindo tanto processadores físicos quanto processadores lógicos. Usando a tecnologia Hyper-Threading da Intel, um processador físico pode ser dividido em dois processadores lógicos.

O Analisador do Exchange Server também consulta o serviço de diretório do Active Directory® para determinar o número de objetos com uma classe de objeto igual a msExchPrivateMDB. O contador desses objetos representa o número de armazenamentos de caixas de correio neste computador do Exchange Server.

Se o Exchange Server Analyzer detectar que o valor de ScanningThreadPoolCount é menor que (2 × NumberOfProcessors + 1) + 3 + o número de armazenamentos de caixas de correio) em um computador do Exchange Server com verificação VSAPI habilitada, será exibido um aviso.

Observação:
Se o Hyper-Threading estiver habilitado, o valor de NumberOfProcessors será o dobro do número de processadores físicos. É recomendável que você use a fórmula acima para sistemas com processadores físicos, bem como para sistemas com processadores físicos e lógicos.

Este aviso indica que o valor do Registro ScanningThreadPoolCount não pode ser otimizado para seu ambiente. Esse valor deve estar definido como no mínimo igual ao tamanho do anexo limite definido nos servidores Exchange.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\Software\TrendMicro\ScanMail para Exchange\RealTimeScan\ScanOption.

  3. No painel da direita, clique duas vezes em ScanningThreadPoolCount.

  4. Insira um valor recomendado pelo Analisador do Exchange Server.

  5. Feche o editor de Registro e reinicie os serviços ScanMail_RealTimeScan e Microsoft Exchange Information Store para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a tecnologia Hyper-Threading, visite o site da Intel (http://www.intel.com/technology/hyperthread).

Observação:
Os endereços na Web podem ser alterados e talvez você não consiga se conectar com os sites aqui mencionados.


Trend ScanMail está no modo de depuração
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-06-22

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a entrada do Registro a seguir para determinar o valor de ModuleName:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\Tools\Debug

O valor do Registro de ModuleName representa o nome do arquivo do módulo de depuração em uso.

O Exchange Server Analyzer também lê a seguinte entrada do Registro para determinar se a verificação de mensagens VSAPI (API de Verificação de Vírus) está habilitada:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Um valor 1 para Habilitado indica que a verificação VSAPI está habilitada. Um valor 0 indica que a verificação VSAPI não está habilitada.

Se o Exchange Server Analyzer detectar que a verificação VSAPI está habilitada e que o valor de Registro do ModuleName não está vazio ou nulo, um aviso será exibido.

A execução no modo de depuração causa um degradação substancial no desempenho devido ao controle de diagnóstico em segundo plano envolvido. A menos que você esteja resolvendo ativamente um problema que requeira a execução do ScanMail para Exchange no modo de depuração, é recomendável que o modo de depuração seja desativado.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\Software\TrendMicro\ScanMail for Exchange\Tools\Debug.

  3. No painel direito, clique duas vezes em ModuleName.

  4. Exclua os dados de valor dessa entrada, deixando a cadeia de caracteres em branco. Não exclua a chave ModuleName.

  5. Feche o editor do Registro e reinicie os serviços ScanMail_RealTimeScan e Armazenamento de Informações do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052).

Para obter mais informações sobre como verificar se o modo de depuração foi desabilitado, consulte a ID 119149 da Trend Micro Solution (http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-119149).

Observação:
As informações sobre sites da Web de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


O serviço Ação de Mensagens do Trend ScanMail está instalado neste servidor Exchange, mas o serviço está parado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o Trend Micro ScanMail para Exchange está instalado e se o serviço ScanMail_MailAction está sendo executado no computador do Exchange.

O Analisador do Exchange Server também consulta a classe WMI Win32_Service para determinar se a definição de valor da chave Started no serviço Armazenamento de Informações do Microsoft Exchange está definido como True ou False.

Um valor igual a False indica que o serviço de Armazenamento de Informações do Microsoft Exchange não está executando nesse computador do Exchange Server. Uma valor igual a True indica que o serviço de Armazenamento de Informações do Microsoft Exchange está executando.

Se o Exchange Server Analyzer verificar que o serviço Armazenamento de Informações do Microsoft Exchange está em execução e que o Trend Micro ScanMail para o Exchange está instalado, mas o serviço ScanMail_MailAction não foi iniciado, será exibido um aviso.

O Trend Micro ScanMail para Exchange fornece proteção antivírus para o Exchange Server. Alguns motivos pelos quais o serviço Trend ScanMail pode ter sido parado, assim como soluções, estão listados aqui.

  • O software que você está executando no servidor do Exchange pode ser uma versão de avaliação ou de teste que expirou. Nesse caso, você pode precisar reinstalar o Trend ScanMail. No mínimo, para continuar usando esse software, você deve ativá-lo.

  • Um administrador pode ter parado involuntariamente o serviço ScanMail_MailAction. Verifique se o serviço está definido para iniciar automaticamente e inicie o serviço.

  • Um worm mal intencionado, um vírus ou outro programa podem ter parado o serviço. Verifique se o serviço está definido para iniciar automaticamente e inicie o serviço. Se o serviço continuar a parar inesperadamente sem eventos de erro relevantes, verifique se o computador não está infectado com um worm mal intencionado e elimine a infecção do sistema, caso necessário.

Geralmente é recomendado que você implante um software antivírus projetado para sistemas de mensagens no gateway do protocolo SMTP ou nos servidores Exchange que hospedam caixas de correio. Para uma proteção mais segura, execute um software antivírus no gateway que verifica as mensagens MIME de entrada e um verificador de vírus no Exchange Server que usa o VSAPI 2.5. Além disso, você deve executar o software antivírus cliente na área de trabalho do usuário. Se você estiver executando um software antivírus projetado para sistemas de mensagens (ele pode analisar e verificar o MIME) no gateway ou no servidor Exchange, a execução de um scanner de nível de arquivo na área de trabalho é suficiente.

Para iniciar o serviço ScanMail_MailAction

  1. Abra o snap-in Serviços do MMC.

  2. Clique com o botão direito no serviço ScanMail_MailAction e clique em Propriedades.

  3. Na guia Geral da página de propriedades de ScanMail_MailAction, verifique se o Tipo de inicialização está definido como Automático. Caso contrário, defina-o como Automático, clique em Aplicar e clique em OK.

  4. Clique com o botão direito no serviço ScanMail_MailAction e clique em Iniciar.

  5. Feche o snap-in Serviços.
  • Para obter mais informações sobre como fortificar um ambiente do Exchange contra worms e vírus transmitidos por email, consulte "Slowing and Stopping E-Mail Viruses in an Exchange Server 2003 Environment" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47587).

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis no Exchange Server, consulte Parceiros do Exchange Server: Antivirus Web site (em inglês) (http://go.microsoft.com/fwlink/?linkid=16226).


O serviço em tempo real Trend ScanMail está instalado no servidor Exchange, mas o serviço está parado
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se o Trend Micro ScanMail do Microsoft Exchange está instalado e se o serviço ScanMail_RealTimeScan está sendo executado no computador do Exchange Server. Se o Exchange Server Analyzer verificar que o Trend Micro ScanMail do Microsoft Exchange está instalado, mas o serviço ScanMail_RealTimeScan não foi iniciado, uma mensagem será enviada.

O Trend Micro ScanMail for Microsoft Exchange oferece proteção antivírus para o Exchange. Alguns motivos para o serviço ScanMail_RealTimeScan ter parado, e soluções estão listados aqui:

  • O software que você está executando no seu servidor Exchange pode ser uma versão de avaliação (ou teste) que tenha expirado. Nesse caso, você pode precisar reinstalar o Trend Micro ScanMail do Microsoft Exchange. No mínimo, para continuar usando esse software, você deve ativá-lo.

  • Um administrador pode ter interrompido não intencionalmente o serviço ScanMail_RealTimeScan. Verifique se o serviço está definido para iniciar automaticamente e inicie o serviço.

  • Um worm mal intencionado, um vírus ou outro programa podem ter parado o serviço. Verifique se o serviço está definido para iniciar automaticamente e inicie o serviço. Se o serviço continuar a parar inesperadamente sem eventos de erro relevantes, verifique se o computador não está infectado com um worm mal intencionado e elimine a infecção do sistema, caso necessário.

Geralmente é recomendado que você implante um software antivírus projetado para sistemas de mensagens no gateway do protocolo SMTP ou nos servidores Exchange que hospedam caixas de correio. Para obter maior proteção, execute o software antivírus no gateway que verifica as mensagens MIME de entrada, e um verificador de vírus no servidor Exchange que usa VSAPI (API de Verificação de Vírus) versão 2.5. Além disso, você deve executar o software antivírus cliente na área de trabalho do usuário. Se você estiver executando um software antivírus projetado para sistemas de mensagens (ele pode analisar e verificar o MIME) no gateway ou no servidor Exchange, a execução de um verificador de nível de arquivo na área de trabalho é suficiente.

Para iniciar o serviço ScanMail_RealTimeScan

  1. Abra o snap-in Serviços do MMC.

  2. Clique com o botão direito no serviço ScanMail_RealTimeScan e clique em Propriedades.

  3. Na guia Geral da página de propriedades de ScanMail_RealTimeScan , certifique-se de que oTipo de inicialização está definido como Automático. Caso contrário, defina-o como Automático, clique em Aplicar e clique em OK.

  4. Clique com o botão direito no serviço ScanMail_RealTimeScan e clique em Iniciar.

  5. Feche o snap-in Serviços.
  • Para obter mais informações sobre como fortificar um ambiente do Exchange contra worms e vírus transmitidos por email, consulte "Slowing and Stopping E-Mail Viruses in an Exchange Server 2003 Environment" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47587).

Para obter mais informações sobre como usar o software antivírus com o Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 328841, "XADM: Exchange e software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Posição da Microsoft quanto às soluções antivírus para o Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Para obter uma lista de softwares antivírus de terceiros, disponíveis no Exchange Server, consulte Parceiros do Exchange Server: site de antivírus (http://go.microsoft.com/fwlink/?LinkId=16226).


Desativar suplementos de terceiros no cliente
Microsoft Exchange Server Analyzer - Artigos > Software de terceiros >

Última modificação do tópico: 2006-04-21

A ferramenta Analisador do Microsoft® Exchange Server determinou que você está executando um dos seguintes tipos de software de terceiros:

  • Um suplemento de terceiros do Microsoft Office Outlook®, como um software antivírus ou software de fax

  • Um aplicativo de terceiros que acessa o servidor Exchange

  • Software de terceiros para sincronização de dispositivos móveis

Recomenda-se que você investigue os tipos de aplicativos de terceiros que estão sendo executados por seus usuários e depois decida se deseja estabelecer restrições para esses aplicativos ou removê-los completamente. Lembre-se de que a execução de software de terceiros pode freqüentemente provocar cargas excessivas nos servidores.

Para desativar suplementos de terceiros no Outlook

  1. No Outlook, no menu Ferramentas, clique em Opções.

  2. Em Opções, clique na guia Outro e em Opções Avançadas.

  3. Em Opções Avançadas, clique em Gerenciador de Suplementos.

  4. Desmarque as caixas de seleção de suplementos de terceiros.

  5. Clique em OK.

  6. Reinicie o Outlook.

Para obter mais informações

  • Para obter mais informações sobre o desempenho do Exchange Server, consulte o Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte Troubleshooting Microsoft Exchange Server 2003 Performance (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).


Transporte
Microsoft Exchange Server Analyzer - Artigos >

Última modificação do tópico: 2005-11-18

Os artigos desta seção fornecem detalhes sobre o que a Ferramenta Microsoft® Exchange Server Analyzer está avaliando em relação a componentes de transporte do Exchange. Além disso, esses artigos descrevem ações que podem ser executadas para resolver erros relacionados a transporte, avisos e configurações não padrão encontrados pelo Exchange Server Analyzer.


8BITMIME não registrado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-18

A ferramenta Microsoft® Exchange Server Analyzer transmite o verbo de comando EHLO do ESMPT (Extended Simple Mail Transfer Protocol) para a porta 25 de um servidor remoto e analisa a resposta para detectar se o servidor remoto tem suporte para o verbo ESMTP 8BITMIME.

Se a resposta recebida do servidor remoto não contiver a cadeia de caracteres '250-8BITMIME', o Exchange Server Analyzer exibirá um aviso.

O Exchange Server 2003 usa verbos estendidos de SMTP específicos do Exchange para se comunicar com outros servidores executando o Exchange Server na organização. É mais eficiente se comunicar com verbos SMTP estendidos, específicos do Exchange, do que usar o SMTP padrão. Se o suporte para o conjunto de comandos ESMTP estiver desabilitado, o desempenho do Exchange Server pode ser prejudicado.

Este erro indica que o servidor remoto não tem suporte para o verbo de comando ESMTP 8BITMIME. O erro não indica se o servidor remoto é ou não é um servidor Exchange. Seja qual for o caso, as mensagens que exigem a extensão 8BITMIME não são roteadas.

Para resolver este problema, procure no conteúdo das filas SMTP mensagens que exigem a extensão 8BITMIME.

Para obter mais informações sobre como remover ou restaurar o suporte padrão para esses verbos, consulte o artigo 257569 da Base de Dados de Conhecimento Microsoft, "Como desligar os verbos ESMTP no Exchange 2000 Server e no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).

Para obter mais informações sobre como o Exchange Server usa os verbos de comando ESMTP, consulte "Como carregar corretamente o SMTP do Exchange" no Guia de Transporte e Roteamento do Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkId=71800)


ADAM LDAP Port Identified
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-07-23

A ferramenta Microsoft Exchange Analyzer lê as seguintes entradas do Registro para determinar as portas usadas pelo serviço de diretório do ADAM (Active Directory Application Mode) no servidor de Transporte de Borda:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\LdapPort

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\SslPort

ADAM é um serviço de diretório LDAP (Lightweight Directory Access Protocol) elaborado especificamente para ser usado com aplicativos habilitados para diretório. O ADAM armazena e replica apenas as informações específicas do aplicativo e não requer implantação em um controlador de domínio nem depende do serviço de diretório do Active Directory. O ADAM não fornece autenticação ou autorização de sistema operacional de rede.

No Microsoft Exchange Server 2007, a função de servidor Transporte de Borda usa o ADAM para armazenar informações de configuração e dados de destinatários para filtragem de conteúdo. Quando o ADAM está sincronizado com o Active Directory, também é possível usá-lo para fazer pesquisa de destinatários para segurança de mensagens.

Quando os dados são enviados do Active Directory para o ADAM, eles são enviados usando uma conexão LDAP pelas seguintes portas não-padrão:

  • LDAP: Porta 50389/TCP

  • LDAP Seguro: Porta 50636/UDP

Quando o Exchange Analyzer identifica as portas usadas pelo ADAM, ele exibe uma mensagem de práticas recomendadas.

Recomendamos o bloqueio de todas as portas que não são essenciais para acesso externo.

Para resolver esse problema, verifique se as portas identificadas pelo Exchange Analyzer como usadas para o ADAM não estão abertas para acesso externo.

Cuidado:
A Porta 50636/UDP é usada para o serviço Exchange EdgeSync e deverá permanecer aberta se a funcionalidade EdgeSync for desejada.
Para bloquear as portas ADAM identificadas para acesso externo usando o Windows Firewall

  1. Clique em Iniciar, Executar, digite firewall.cpl e clique em OK.

  2. Clique na guia Exceções.

  3. Selecione cada Programa ou Serviço listado na caixa Nome e clique em Editar para verificar as portas que estão abertas.

  4. Verifique se as portas relatadas pelo Exchange Analyzer como usadas para o ADAM não estão listadas.

  5. Se as portas identificadas estiverem listadas, verifique se elas não são usadas para outro tipo de comunincação necessária e feche-as desmarcando-as na janela Editar um Serviço.

  6. Clique em OK duas vezes para sair da configuração do Windows Firewall.

Para obter mais informações

Para obter mais informações sobre portas, autenticação e criptografia para todos os caminhos de dados usados pelo Exchange 2007, consulte"Data Path Security Reference" (http://go.microsoft.com/fwlink/?LinkId=95630).


Plug-in Antivírus instalado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-18

A ferramenta Microsoft® Exchange Server Analyzer pesquisa a seguinte entrada do Registro para detectar se o plug-in Auto-Protect de Emails de Internet, Symantec Antivirus Corporate Edition 9.x, está instalado:

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

A presença desta ramificação do Registro indica que o plug-in Auto-Protect de Emails de Internet, Symantec Antivirus Corporate Edition 9.x, está instalado no servidor executando o Exchange Server.

A ferramenta Microsoft® Exchange Server Analyzer também lê a seguinte entrada do Registro para detectar se o plug-in Auto-Protect de Emails de Internet, Symantec Antivirus Corporate Edition 9.x, está habilitado:

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

Um valor 1 em OnOff indica que o plugh-in Auto-Protect está habilitado. Um valor 0 indica que o plug-in Auto-Protect não está habilitado.

O Exchange Server Analyzer exibirá um aviso, se as seguintes condições forem verdadeiras:

  • O plug-in Auto-Protect de Emails de Internet, Symantec Antivirus Corporate Edition 9.x, está instalado.

  • O plug-in Auto-Protect de Emails de Internet, Symantec Antivirus Corporate Edition 9.x, não está habilitado.

Este aviso indica que a instalação e configuração do plug-in devem ser comparadas com as práticas recomendadas do fornecedor atual.

Para obter mais informações sobre as práticas recomendadas pelo fornecedor para este plug-in, consulte "Práticas recomendadas para o Auto-Protect, Symantec AntiVirus Corporate Edition 9.x, em um servidor Microsoft Exchange" (em inglês) (http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam).

Observação:
As informações sobre sites de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


Plug-in de Antivírus habilitado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-18

A ferramenta Microsoft® Exchange Server Analyzer pesquisa a seguinte entrada do Registro para detectar se o plug-in Auto-Protect de Emails de Internet, Symantec Antivirus Corporate Edition 9.x, está instalado.

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

A presença desta entrada do Registro indica que o plug-in Auto-Protect de Emails de Internet, Symantec Antivirus Corporate Edition 9.x, está instalado no servidor executando o Exchange Server.

A ferramenta Microsoft® Exchange Server Analyzer também lê a seguinte entrada do Registro para detectar se o plug-in Auto-Protect de Emails de Internet, Symantec Antivirus Corporate Edition 9.x, está habilitado.

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

Um valor 1 em OnOff indica que o plug-in Auto-Protect está habilitado. Um valor 0 indica que o plug-in Auto-Protect não está habilitado.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O plug-in Auto-Protect de Emails de Internet, Symantec Antivirus Corporate Edition 9.x, está instalado.

  • O plug-in Auto-Protect de Emails de Internet, Symantec Antivirus Corporate Edition 9.x, está habilitado.

Este aviso indica que a instalação e configuração do plug-in devem ser comparadas com as práticas recomendadas do fornecedor atual.

Para obter mais informações sobre as práticas recomendadas pelo fornecedor para este plug-in, consulte "Práticas recomendadas para o Auto-Protect, Symantec AntiVirus Corporate Edition 9.x, em um servidor Microsoft Exchange" (em inglês) (http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam).

Observação:
As informações sobre sites de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


O registro de Cco no diário está habilitado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar se o registro no diário de Cco (cópia oculta) está habilitado:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\JournalBCC

Se o Exchange Server Analyzer verificar que o valor de JournalBCC está definido como 1, será exibida uma mensagem de configuração não padrão.

O registro em diário de Cco é um diário somente de mensagens com a capacidade adicional de capturar os destinatários de Cco. Quando o registro de Cco no diário estiver habilitado, o Exchange Server capturará todos os destinatários, inclusive destinatários Cco, conhecidos no servidor de origem. Se essa lista de destinatários incluir listas de distribuição ocultas, listas de distribuição com base em consulta ou listas de distribuição que são expandidas em outro servidor, os destinatários dessas listas não serão incluídos na mensagem registrada no diário.

A funcionalidade de registro de Cco no diário é habilitada pela definição de uma chave do Registro. Para obter mais informações sobre como definir essa chave do Registro, consulte o artigo 810999 da Base de Dados de Conhecimento da Microsoft, "XADM: Informações de Cco Perdidas para Mensagens Registradas em Diário no Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810999).

Para habilitar registro de Cco no diário em um servidor específico, você deve primeiro configurar o diário somente de mensagens. A configuração JournalBCC não estará ativa quando existir a seguinte condição:

  • O Registro JournalBCC está definido como 1.

  • O registro no diário apenas para mensagens não está habilitado em nenhum dos bancos de dados no mesmo servidor.

O registro de mensagens no diário pode consumir muitos recursos de disco, rede e CPU. Portanto, o registro no diário exige um planejamento completo de implantação. O registro no diário deve ser habilitado somente no contexto de uma estrutura de solução de registro no diário abrangente.

Ignore esta mensagem de configuração não-padrão se as seguintes condições existirem:

  • Sua empresa exige o registro no diário.

  • Você implantou uma estrutura de solução de registro no diário.

Caso contrário, você deve desativar a funcionalidade de registro no diário. A desativação do registro em diário no banco de dados desabilitará o diário.

Para desativar o registro no diário somente de mensagens em um banco de dados

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda <your Exchange server>, expanda <storage group> e clique com o botão direito no armazenamento de caixa de correio.

  2. Na guia Geral, desmarque a caixa de diálogo Arquivar todas as mensagens enviadas ou recebidas por caixas de correio neste armazenamento.

  3. Aguarde 15 minutos para que o armazenamento do Exchange aplique as alterações. Você não precisa reiniciar o serviço Armazenamento de Informações do Microsoft Exchange.

Se você não deseja que o Exchange Server Analyzer exiba essa mensagem novamente, exclua a chave do Registro JournalBCC. A exclusão da chave do Registro JournalBCC não é necessária para desabilitar a funcionalidade de registro no diário.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para excluir a chave JournalBCC do Registro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. No painel da direita, localize e exclua o valor de JournalBCC .

  4. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como implantar uma solução de registro no diário, consulte Registrando no diário com o Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581) (em inglês).


BDAT não registrado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-18

A ferramenta Microsoft® Exchange Server Analyzer transmite o verbo de comando EHLO do ESMPT (Extended Simple Mail Transfer Protocol) para a porta 25 de um servidor remoto e analisa a resposta para detectar se o servidor remoto tem suporte para o verbo ESMTP de BDAT.

Se receber uma resposta com uma cadeia de caracteres que indique um erro não recuperável no servidor remoto, o Exchange Server Analyzer exibirá um erro.

O Exchange Server 2003 usa verbos estendidos de SMTP específicos do Exchange para se comunicar com outros servidores executando o Exchange Server na organização. É mais eficiente se comunicar com verbos SMTP estendidos, específicos do Exchange, do que usar o SMTP padrão. Se o suporte para o conjunto de comandos ESMTP estiver desabilitado, o desempenho do Exchange Server pode ser prejudicado.

Este erro indica que o servidor remoto não tem suporte para o verbo de comando ESMTP BDAT. O erro não indica se o servidor remoto é ou não é um servidor Exchange. Seja qual for o caso, as mensagens que exigem a extensão BDAT não são roteadas.

Para resolver este problema, procure no conteúdo das filas SMTP mensagens que exigem a extensão BDAT.

Para obter mais informações sobre como remover ou restaurar o suporte padrão para esses verbos, consulte o artigo 257569 da Base de Dados de Conhecimento Microsoft, "Como desligar os verbos ESMTP no Exchange 2000 Server e no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).

Para obter mais informações sobre como o Exchange Server usa os verbos de comando ESMTP, consulte "Como carregar corretamente o SMTP do Exchange" no Guia de Transporte e Roteamento do Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkID=71800).


Servidor bridgehead para verificar restrições de entrega de grupo de distribuição para RGC
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-09-18

A ferramenta Microsoft® Exchange Server Analyzer consulta os seguintes atributos de cada objeto Conector de Grupo de Roteamento (msExchRoutingGroupConnector) detectado no serviço de diretório do Active Directory®, para saber se há restrições de entrega definidas, baseadas em associação de grupos de distribuição.

dLMemRejectPerms | Contém os nomes de domínio (DNs) de uma lista de distribuição (DL) cujos membros não podem enviar através deste Conector de Grupo de Roteamento.
dLMemSubmitPerms | Contém os nomes de domínio (DNs) de uma lista de distribuição (DL) cujos membros podem enviar através deste Conector de Grupo de Roteamento.

Ao detectar conectores de grupo de roteamento com restrições de entrega baseadas em associação de grupos de distribuição, o Exchange Server Analyzer consultará o atributo msExchSourceBridgeheadServersDN dos conectores de grupos de roteamento detectados para saber se o servidor sendo analisado está definido como um servidor bridgehead para qualquer um desses conectores.

Por último, o Exchange Server Analyzer lê a seguinte chave do Registro para determinar se o valor de Registro CheckConnectorRestrictions está presente e configurado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

O Exchange Server Analyzer exibirá um aviso, se as seguintes condições forem verdadeiras:

  • Um conector do grupo de roteamento é usado para restringir a entrega, com base na associação do grupo de distribuição.

  • O servidor Exchange que está sendo analisado está designado como servidor bridgehead para esse conector de grupo de roteamento e sua tarefa é expandir o grupo de distribuição.

  • A chave CheckConnectorRestrictions está presente, definida como 1 e, portanto, habilitada.

Os comportamentos padrão para o categorizador é expandir recursivamente os grupos de distribuição e verificar as restrições de cada mensagem que passa pelo sistema.

Ao criar um grupo de roteamento, você designa um grupo de servidores que podem se comunicar entre si. Para que os servidores em diferentes grupos de roteamento se comuniquem entre si, você deve conectar os grupos de roteamento.

O método de conexão preferido é um conector de grupo de roteamento porque esse conector é projetado e destinado especificamente para conectar grupos de roteamento.

Os servidores que podem enviar mensagens através de um conector de grupo de roteamento são servidores bridgehead. Um servidor bridgehead é uma combinação de um servidor virtual SMTP (Simple Mail Transfer Protocol) com um servidor Exchange responsável por entregar todas as mensagens através de um conector.

Ao criar um conector de grupo de roteamento, você pode manter todos os servidores como servidores bridgehead para esse conector ou especificar somente um conjunto de servidores selecionados como bridgehead para esse conector. Os bridgeheads designados são os servidores cuja tarefa é a expansão da associação do grupo de distribuição.

Quando você envia mensagens usando conectores de grupo de roteamento com restrições de entrega definidas com base em associação de grupos de distribuição, o categorizador de mensagens deve expandir a associação do grupo de distribuição, obter a lista completa dos DNs dos membros e depois comparar essa lista aos DNs do remetente da lista. Uma operação de acesso ou de negação ocorre quando há correspondência de um DN em ambas as listas. Se um grupo de distribuição estiver aninhado em outro grupo de distribuição, a distribuição aninhada também será expandida.

Este aviso indica que as restrições de entrega baseadas na associação do grupo de distribuição podem instruir o enfileiramento das mensagens destinadas ao bridgehead, à medida que o categorizador verifica as restrições.

Para tratar desse aviso:

  • Configure o conector de grupo de roteamento para um grupo de roteamento local, como citado no artigo 329171 da Base de Conhecimento Microsoft, "XADM: A entrega de mensagens fica lenta se os destinatários estão configurados com restrições de entrega baseadas em associação de grupos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Use um servidor de catálogo global dedicado e mais robusto como o servidor bridgehead designado para o conector.

  • Configure caixas de correio individuais e não grupos de distribuição para restrições de entrega, como citado no artigo 812298 da Base de Dados de Conhecimento Microsoft, "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Considere a implementação de filtragem de remetentes SMTP.

  • Para os servidores com o Microsoft Exchange Server 2003 Service Pack 2 (SP2) ou versão posterior, considere a implementação de verificação de restrição não-hierárquica. Para os servidores com versões do Exchange anteriores ao Exchange 2003 SP2, considere uma atualização para o Exchange 2003 SP2.

Para obter mais informações

Para obter mais informações sobre a verificação de restrição não-hierárquica, consulte Considere a verificação da restrição não hierárquica.

Para obter mais informações sobre a filtragem de remetentes SMTP, consulte "Como habilitar a filtragem de remetentes" no Guia de Administração do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=71832).

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 329171, "XADM: A entrega de mensagens fica lenta se os destinatários estão configurados com restrições de entrega baseadas em associação de grupos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 895407 "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407) (em inglês).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949) (em inglês).


Servidor bridgehead para verificar restrições de entrega de grupo de distribuição para Conector SMTP
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-21

A ferramenta Microsoft® Exchange Server Analyzer consulta os seguintes atributos de cada objeto Conector SMTP (Simple Mail Transfer Protocol) ((msExchRoutingSMTPConnector) detectado no serviço de diretório do Active Directory®, para saber se as restrições de entrega estão definidas com base em associação de grupos de distribuição.

dLMemRejectPerms | Contém os nomes de domínio (DNs) de uma lista de distribuição (DL) cujos membros não podem enviar através deste Conector SMTP.
dLMemSubmitPerms | Contém os nomes de domínio (DNs) de uma lista de distribuição (DL) cujos membros podem enviar através deste Conector SMTP.

Ao detectar conectores SMTP com restrições de entrega baseadas em associação de grupos de distribuição, o Exchange Server Analyzer consultará o atributo msExchSourceBridgeheadServersDN dos conectores SMTP detectados para saber se o servidor analisado está definido como um servidor bridgehead para qualquer um desses conectores.

Por último, o Exchange Server Analyzer lê a seguinte chave do Registro para determinar se o valor de Registro CheckConnectorRestrictions está presente e configurado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

O Exchange Server Analyzer exibirá um aviso, se as seguintes condições forem verdadeiras:

  • Um conector SMTP é usado para restringir a entrega, com base na associação do grupo de distribuição.

  • O servidor Exchange que está sendo analisado está designado como servidor bridgehead para esse conector SMTP e sua tarefa é expandir o grupo de distribuição.

  • A chave CheckConnectorRestrictions está presente, definida como 1 e, portanto, habilitada.

Os comportamentos padrão para o categorizador é expandir recursivamente os grupos de distribuição e verificar as restrições de cada mensagem que passa pelo sistema.

Quando você envia uma mensagem usando um conector que aceita ou recusa mensagens de um grupo de distribuição, o categorizador de mensagens precisa expandir a associação do grupo de distribuição, obter a lista completa de DNs dos membros e comparar a lista de DNs com os DNs do remetente da lista. Uma operação de acesso ou de negação ocorre quando há correspondência de um DN em ambas as listas. Se um grupo de distribuição estiver aninhado em outro grupo de distribuição, a distribuição aninhada também será expandida.

O bridgehead designado é o servidor cuja tarefa é a expansão da associação do grupo de distribuição.

A verificação de restrições é controlada pelo valor de Registro CheckConnectorRestrictions, que deve ser definido no servidor bridgehead do Exchange e é a origem do conector que está sendo verificado. Se você especificar uma restrição, mas não criar o valor de Registro CheckConnectorRestrictions, a restrição não será verificada.

Por padrão, a verificação de restrições do conector está desligada. O desempenho do sistema será muito afetado se os grupos de distribuição forem expandidos e forem verificadas as restrições de cada mensagem que passar pelo sistema.

Este aviso indica que as restrições de entrega baseadas na associação do grupo de distribuição podem instruir o enfileiramento das mensagens destinadas ao bridgehead, à medida que o categorizador verifica as restrições.

Para tratar desse aviso:

  • Crie um grupo de roteamento dedicado para restrições do conector e configure-o para um Grupo de Roteamento local, como citado no artigo 329171 da Base de Dados de Conhecimento Microsoft, "XADM: A entrega de mensagens fica lenta se os destinatários estão configurados com restrições de entrega baseadas em associação de grupos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)

  • Use um servidor de catálogo global dedicado e mais robusto como o servidor bridgehead designado para o conector.

  • Configure caixas de correio individuais e não grupos de distribuição para restrições de entrega, como citado no artigo 812298 da Base de Dados de Conhecimento Microsoft, "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298)

  • Considere a implementação de filtragem de remetentes SMTP.

  • Para os servidores com o Microsoft Exchange Server 2003 Service Pack 2 (SP2) ou versão posterior, considere a implementação de verificação de restrição não-hierárquica. Para os servidores com versões do Exchange anteriores ao Exchange 2003 SP2, considere uma atualização para o Exchange 2003 SP2.

Para obter mais informações

Para obter mais informações sobre a verificação de restrição não-hierárquica, consulte Considere a verificação da restrição não hierárquica.

Para obter mais informações sobre a filtragem de remetentes SMTP, consulte "Como habilitar a filtragem de remetentes" no Guia de Administração do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=71832).

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 329171, "XADM: A entrega de mensagens fica lenta se os destinatários estão configurados com restrições de entrega baseadas em associação de grupos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 895407 "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407) (em inglês).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949) (em inglês).


Não foi possível conectar ao mestre de roteamento na porta 25
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-24

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchRoutingMasterDN de cada grupo de roteamento no grupo administrativo atual. Em seguida, o Exchange Server Analyzer tenta abrir uma conexão de soquete para o mestre de roteamento na porta TCP 25. Se o Exchange Server Analyzer não receber uma resposta personalizada esperada 25 Disponível, um erro será exibido.

Esse erro indica que o mestre de roteamento não está acessível na porta TCP 25 e que podem ocorrer falhas de roteamento como resultado. Para corrigir esse erro, você pode solucionar o problema de conectividade com o mestre de roteamento ou atribuir um novo mestre de roteamento.

Para solucionar o problema de conectividade com o mestre de roteamento

  1. É possível usar o telnet para a porta 25 a partir do próprio mestre de roteamento? Caso não, o problema não é na rede.

  2. Está tudo conectado? Todo seu hardware está funcionando corretamente?

  3. O DNS está funcionando e configurado corretamente?

  4. Seu roteador está funcionando corretamente?

  5. Existe algum firewall ou aplicativo impedindo a sua conexão?
Para atribuir um novo mestre de roteamento

  1. Abra o Gerenciador do Sistema do Exchange

  2. Clique com o botão direito no ícone Nome da Organização (Exchange) posicionado no topo da árvore, no painel da esquerda (onde Nome da Organização é aquele selecionado para sua organização do Exchange 2000) e clique em Propriedades.

  3. Clique em Exibir Grupos Administrativos, clique em Exibir Grupos de Roteamento e depois em OK.

  4. Expanda Grupos Administrativos, <AdministrativeGroup>e, em seguida, Grupos de Roteamento.

  5. Expanda o grupo de roteamento e clique em Membros.

  6. No painel da direita, clique com o botão direito no computador do Exchange que você deseja configurar como mestre do grupo de roteamento e clique em Definir como Mestre.

Para obter mais informações sobre como solucionar problemas de roteamento, configurar topologias de roteamento e conceitos avançados de roteamento, consulte "Solucionando problemas de roteamento" no Guia de Transporte e Roteamento do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).


Não foi possível conectar ao mestre de roteamento na porta 691
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-24

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo msExchRoutingMasterDN de cada grupo de roteamento no grupo administrativo atual. Em seguida, o Exchange Server Analyzer tenta abrir uma conexão de soquete para o mestre de roteamento na porta TCP 691. Se o Exchange Server Analyzer não receber uma resposta personalizada esperada 691 Disponível, um erro será exibido.

Esse erro indica que o mestre de roteamento não está acessível na porta TCP 691 e que podem ocorrer falhas de roteamento como resultado. Para corrigir esse erro, você pode solucionar o problema de conectividade com o mestre de roteamento ou atribuir um novo mestre de roteamento.

Para solucionar o problema de conectividade com o mestre de roteamento

  1. É possível usar o telnet para a porta 691 a partir do próprio mestre de roteamento? Caso não, o problema não é na rede.

  2. Está tudo conectado? Todo seu hardware está funcionando corretamente?

  3. O DNS está funcionando e configurado corretamente?

  4. Seu roteador está funcionando corretamente?

  5. Há algum firewall impedindo que você se conecte?
Para atribuir um novo mestre de roteamento

  1. Abra o Gerenciador do Sistema do Exchange

  2. Clique com o botão direito no ícone Nome da Organização (Exchange) posicionado no topo da árvore, no painel da esquerda (onde Nome da Organização é aquele selecionado para sua organização do Exchange 2000) e clique em Propriedades.

  3. Clique em Exibir Grupos Administrativos, clique em Exibir Grupos de Roteamento e depois em OK.

  4. Expanda Grupos Administrativos, <AdministrativeGroup>e, em seguida, Grupos de Roteamento.

  5. Expanda o grupo de roteamento e clique em Membros.

  6. No painel da direita, clique com o botão direito no computador do Exchange que você deseja configurar como mestre do grupo de roteamento e clique em Definir como Mestre.

Para obter mais informações sobre como solucionar problemas de roteamento, configurar topologias de roteamento e conceitos avançados de roteamento, consulte "Solucionando problemas de roteamento" no Guia de Transporte e Roteamento do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).


Não é possível localizar os registros 'Host' ou 'MX'
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-05-10

A ferramenta Microsoft Exchange Analyzer Tool executa uma pesquisa de DNS para recuperar os registros MX (Servidor de Mensagens) de um domínio. Se o Exchange Analyzer não puder recuperar os registros MX de um domínio no servidor DNS, ele tentará uma pesquisa de DNS para recuperar os registros Host (A) dos domínios para os quais o servidor Exchange está tentando enviar mensagens.

O Exchange Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O Exchange Analyzer não pode recuperar os registros MX de um domínio.

  • A operação de consulta ao DNS falha ao retornar um endereço IP para qualquer um dos registros Host (A).

Esse erro indica que os registros DNS Mail Exchanger (MX) e Host (A) do domínio e servidores parecem estar ausentes. Esse erro pode acarretar o backup das mensagens destinadas aos domínios remotos nas filas para Entrega Remota do servidor Exchange, além de outros atrasos de roteamentos ou de serviços.

Para determinar hosts de mensagens, o servidor Exchange de envio procura um registro MX. Em seguida, o servidor de envio resolve o registro MX em um endereço IP, procurando um registro de endereço (registro A).

A pesquisa dos registros Mail Exchanger (MX) e Host (A) no DNS pode falhar pelos seguintes motivos:

  • O servidor DNS está inativo ou inacessível por causa de uma falha de rede ou outras razões.

  • O registro Host (A) do servidor remoto está ausente do servidor DNS porque o registro está indisponível ou incorreto.

  • O servidor DNS não está configurado para permitir atualizações dinâmicas de registro de host.

  • O sistema está tentando enviar relatórios que não são para entrega, chamados NDRs, em resposta a mensagens de spam que podem mascarar seus domínios de origem. Se esse for o caso, exclua essas mensagens. Consulte o link para a ferramenta de arquivamento e exclusão de mensagens inválidas do Exchange Server na seção deste artigo, Para obter mais informações.

Para verificar se o servidor DNS está online e se os registros MX e Host estão presentes

  1. Confira se o servidor DNS está em execução fazendo uma ou mais das seguintes verificações:

    • Veja o status do servidor DNS no programa de Administração do DNS no servidor DNS.

    • Reinicie o servidor DNS. Para obter mais informações, consulte "Start, stop, pause, or restart a DNS server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Verifique a capacidade de resposta do servidor DNS usando o comando nslookup. Para obter mais informações, consulte as instruções em "Verificar a capacidade de resposta do servidor DNS com o comando nslookup" (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Use nslookup para verificar se os registros Mail Exchanger (MX) estão configurados corretamente. Para obter mais informações, consulte "Como usar Nslookup para verificar a configuração de registros MX" na seção "Verificando o design e a configuração de DNS" do Guia de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579) (em inglês).

  3. Use nslookup para verificar se o registro Host (A) existe no servidor DNS. Para obter mais informações, consulte "To verify A resource records exist in DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63001).

  4. Se o registro de recurso Host (A) não existir, adicione ou modifique manualmente o registro de recurso A ou configure o servidor DNS para habilitar atualizações dinâmicas de registro:

    • Adicione manualmente um registro de recurso A. Para obter mais informações, consulte "Add a resource record to a DNS zone" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Modifique manualmente um registro de recurso A. Consulte as instruções contidas em "Modificar um registro de recurso existente" (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Configure o servidor DNS para habilitar atualizações dinâmicas de registro de host. Para obter mais informações, consulte o artigo 816592 da Base de Dados de Conhecimento Microsoft, "How to configure DNS dynamic updates in Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).

Para obter mais informações

  • Para obter informações sobre como o Exchange Server 2003 usa o DNS para resolver endereços IP externos, consulte "Transport Dependencies for Exchange Server 2003" no Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Para obter informações sobre resolução de nomes do DNS, consulte o artigo 322856 da Base de Dados de Conhecimento Microsoft, "COMO FAZER: Configure DNS para Ser Usado com o Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Para obter informações sobre como solucionar problemas do DNS, consulte "Troubleshooting DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Para obter informações sobre o monitoramento do sistema Exchange Server 2003, consulte "Monitoramento do sistema com o Pacote de Gerenciamento do Exchange Server 2003" no Pacote de Gerenciamento do Exchange Server 2003 para MOM 2005 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Para obter informações sobre os registros de recursos Host (A), consulte "Managing Resource Records" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63004).

  • Para obter informações sobre exclusão e arquivamento de mensagens inválidas do Exchange Server, consulte "Exclusão e arquivamento de mensagens inválidas do Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=84239).


Não é possível identificar o remetente
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-08

A Ferramenta Microsoft® Exchange Server Analyzer consulta o valor do atributo proxyAddress do serviço de diretório do Active Directory® de todos os objetos do usuário para detectar se existe uma correspondência para o endereço SMTP (Simple Mail Transfer Protocol) do remetente local especificado pelo usuário.

Se o Exchange Server Analyzer não encontrar uma correspondência do proxyAddress para o endereço do remetente local especificado pelo usuário, será exibido um erro.

Esse processo indica que uma das condições a seguir é verdadeira:

  • O remetente local não existe na organização local do Exchange Server.

  • O endereço SMTP do remetente local especificado pelo usuário foi digitado incorretamente.

Para resolver este erro, verifique o endereço SMTP do remetente local especificado e repita a operação.

Para verificar o endereço do remetente local

  1. Inicie o Gerenciador do Sistema Exchange.

  2. Expanda Destinatário e, em seguida, Todas as Listas de Endereços Globais.

  3. Clique com o botão direito em Lista de Endereços Global Padrão e selecione Propriedades.

  4. Clique em Visualização para exibir os endereços SMTP de destinatários incluídos na Lista de Endereços Global Padrão.

  5. Verifique se o remetente local especificado está exibido e anote o endereço SMTP.


Coletor de Eventos CatDbgSink instalado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê os dados encontrados na propriedade LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes da metabase do IIS (Serviços de Informações da Internet) para determinar se o aplicativo de diagnóstico de fluxo de mensagens CatDbgSink está instalado em um computador que esteja executando o Exchange 2000 Server ou o Exchange Server 2003.

O aplicativo CatDbgSink é um coletor de eventos que pode ser usado para a solução de problemas de fluxo de mensagens em computadores que estejam executando o Exchange 2000 Server ou o Exchange Server 2003. Se o aplicativo CatDbgSink estiver instalado no servidor Exchange, o Exchange Server Analyzer exibirá um aviso informando que o aplicativo CatDbgSink está instalado e só deve ser usado para a solução de problemas de fluxo de mensagens.

Geralmente, o aplicativo CatDbgSink é enviado aos clientes para a solução de problemas de fluxo de mensagens em computadores que usam o Exchange 2000 Server e o Exchange Server 2003. O aplicativo CatDbgSink normalmente é instalado com a ajuda do Atendimento Microsoft. Depois que o aplicativo CatDbgSink for instalado e registrado com êxito, os clientes poderão usá-lo para criar arquivos de log para coletar informações de solução de problemas sobre fluxo de mensagens em servidores Exchange.

Às vezes, o aplicativo CatDbgSink não pode ser removido do servidor Exchange de produção depois que você isola e corrige um ou mais problemas. Se não for removido do computador do Exchange, o aplicativo CatDbgSink criará uma carga significativa que causa problemas de desempenho no servidor Exchange. Depois de diagnosticar problemas de fluxo de mensagens em um servidor Exchange de produção, remova o aplicativo CatDbgSink.

Para corrigir esse aviso

  1. Encontre a pasta local de instalação do CatDbgSink. Essa pasta contém os seguintes arquivos de instalação: Setup.vbs, CatDbgSink.dll, CatDbgSink.pdb e MustReadMe.txt.

  2. Em uma janela de prompt de comando, altere o diretório para a unidade local dos arquivos de instalação; por exemplo: C:\CatDbgSink.

  3. No prompt de comando, digite cscript setup.vbs uninstall 1

Observação:
O número 1 da linha de comando atribui a instância de servidor virtual SMTP, começando em 1.

Para obter mais informações sobre o aplicativo CatDbgSink, entre em contato com o Atendimento Microsoft (http://support.microsoft.com/default.aspx?pr=cntactms).


O categorizador está desabilitado para a instância do SMTP
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer analisa os dados encontrados na propriedade LM/SmtpSvc/%SMTPInstance%/RoutingSources na metabase do IIS (Serviços de Informação da Internet) para determinar o estado do Categorizador de Mensagens para cada VSI (instância do servidor virtual) SMTP em computadores que executam o Exchange 2000 Server ou o Exchange Server 2003.

O Exchange Server Analyzer determina se a chave SMTPDSUseCat existe na metabase do IIS e relata as descobertas. Se o Exchange Server Analyzer verificar que o SMTPDSUseCat existe e está definido como desabilitado, 0x000000, o Exchange Server Analyzer exibirá um erro. Se o Categorizador de Mensagens estiver desabilitado, o servidor Exchange experimentará graves problemas de fluxo de mensagens.

Por padrão, quando o serviço SMTP está instalado em um computador que está executando o Microsoft Windows® 2000 Server ou o Microsoft Windows Server™ 2003, a chave SMTPDSUseCat é criada na metabase do IIS. Por padrão, a chave SMTPDSUseCat é desabilitada (0). Quando o Exchange Server está instalado, a chave SMTPDSUseCat de metabase do IIS é removida. Isso habilita o Categorizador de Mensagens. Quando o serviço SMTP ou o Exchange Server está instalado em um computador que está executando o Windows 2000 Server ou o Windows Server 2003, um VSI SMTP padrão (1) é criado. O Categorizador de Mensagens poderá ser desabilitado em situações em que o Exchange Server seja instalado e o serviço SMTP seja desinstalado e, em seguida, reinstalado no computador. O Categorizador de Mensagens também pode ser desabilitado quando softwares de terceiros são instalados ou quando ocorre um erro de configuração administrativo.

Observação:
Cada instância de servidor virtual SMTP no servidor Exchange tem controle independente do estado do Categorizador de Mensagens.

O Categorizador de Mensagens examina cada mensagem que entra em cada VSI SMTP e determina as opções. As mensagens podem ser destinadas ao armazenamento local, a um host remoto através do MTA (agente de transferência de mensagens) ou um host remoto por SMTP. O Categorizador de Mensagens também trata da expansão da Lista de Distribuição (DL). O Categorizador de Mensagens examina as mensagens que entram em um servidor SMTP e determina o que fazer com elas. O Categorizador de Mensagens é um plug-in do mecanismo de enfileiramento avançado que executa consultas do protocolo LDAP em servidores de catálogo global na porta TCP 3268. O Categorizador de Mensagens é, essencialmente, uma coleção de coletores de eventos que executa resolução avançada de endereços em todas as mensagens que percorrem o mecanismo de enfileiramento avançado.

Observação:
A Ferramenta de Reinstalação do SMTP (Smtpreinstall.exe) está localizada no CD-ROM do Exchange 2000 Server SP2 na pasta \SUPPORT\UTILS\I386.
Para habilitar o Categorizador de Mensagens usando a Ferramenta de Reinstalação do SMTP

  1. Copie Smtpreinstall.exe na pasta \Exchsrvr\Bin.

  2. Clique duas vezes em Smtpreinstall.exe na pasta \Exchsrvr\Bin.

  3. Clique em OK na caixa de diálogo Reinstalação de SMTP do Microsoft Exchange para reiniciar o servidor Exchange.

Se você precisar exibir as propriedades na metabase do IIS, você poderá fazer isso, instalando o utilitário Metaedit 2.2 para o IIS 4.0/5.0 ou o utilitário IIS Metabase Explorer no IIS 6.0.

Cuidado:
Editar a metabase diretamente não é um prática recomendada.

Para obter mais informações sobre o categorizador de mensagens ou os utilitários de metabase do IIS disponíveis, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 290290, "XIMS: Não é possível enviar mensagens depois de reinstalar o serviço SMTP do IIS" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=290290)

  • 319885, "XCON: Mensagens enviadas na organização do Exchange 2000 Server não são entregues" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319885)

  • 231729, "XCON: a chave DSUseCat o Categorizador de Mensagens" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231729)

  • 232068, "How To: Baixar, instalar e remover o utilitário MetaEdit 2.2 do IIS" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232068)

Para baixar as ferramentas do Kit de Recursos do IIS 6.0, consulte ferramentas do Kit de Recursos do IIS 6.0 (Serviços de Informação da Internet) (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=33134)


Um evento de aviso de categorizador (ID: 6004) foi registrado em log nas últimas 24 horas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-05

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_NTLogEvent do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se um aviso de Evento 6004 foi registrado para o MSExchangeTransport nas últimas 24 horas.

Se descobrir que um aviso de Evento 6004 foi registrado para MSExchangeTransport nas últimas 24 horas, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que o categorizador encontrou um erro quando tentou processar uma mensagem.

O categorizador de mensagens examina as mensagens enviadas para um servidor SMTP e determina o que fazer com elas. As mensagens podem ser destinadas ao armazenamento local de informações, a um host remoto por meio do MTA ou a um host remoto por meio do SMTP. O categorizador também administra a expansão da lista de distribuição. Ele é um plug-in do mecanismo de enfileiramento avançado que executa consultas LDAP em servidores de catálogo global na porta TCP 3268. O categorizador é basicamente uma coleção de coletores de eventos que executam resolução de endereços avançada em cada mensagem que percorre o mecanismo de enfileiramento avançado. Além disso, o categorizador executa a resolução de endereços e o encaminhamento de emails, define os sinalizadores de conversão de conteúdo, expande listas de distribuição, impõe configurações globais e gera notificações de status de entrega. Ele também detecta rotas de destinatário alternativas e executa bifurcação, registro no diário e muitas outras funções.

Assim que a mensagem entra no categorizador, ele resolve o remetente do envelope procurando o endereço nos atributos de endereço de proxy, no serviço de diretório do Active Directory®. O categorizador também resolve o destinatário do envelope, pesquisando cada endereço no atributo de endereços de proxy, no Active Directory. Por exemplo, se a lista contiver uma lista de distribuição, ele expandirá a lista de modo a incluir esses membros se a expansão de lista de distribuição for permitida no servidor.

O evento 6004 do aviso Possible causes of MSExchangeTransport inclui o seguinte:

  • Problemas de DSAccess (Directory Service Access).

  • Falhas ou latência de replicação de diretório.

  • Servidores de catálogos globais sobrecarregados.

  • Problemas de DNS.

Para solucionar os problemas do aviso:

  • Verifique se o Exchange Server tem conectividade com um ou mais servidores de catálogo global. A ferramenta Monitor de Rede no Windows é muito útil para essa finalidade.

  • Examine as mensagens de notificação de status de entrega geradas. As notificações de status de entrega podem incluir relatórios de falha na entrega. As notificações de status de entrega descrevem mensagens de falhas permanentes e transitórias que freqüentemente terminam como erros de entrega permanentes.

  • Use o Controle de Mensagens para solucionar os problemas de mensagens presas no categorizador.

  • Use a ferramenta Coletor de Arquivo Morto para arquivar e analisar as mensagens de entrada e saída do Exchange Server.

  • Monitore os contadores de desempenho do categorizador no Monitor do Sistema.

Para obter mais informações sobre eventos e erros do Exchange Server 2003, consulte "Centro de mensagens de eventos e erros" (http://go.microsoft.com/fwlink/?LinkId=34258) (pode estar em inglês).

Para obter uma lista das mensagens de notificação de status de entrega e de falha na entrega geradas pelo Exchange Server e pelo Microsoft Windows Small Business Server, consulte o artigo 284204 da Base de Dados de Conhecimento da Microsoft, "Notificações de status de entrega no Exchange Server e no Small Business Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204) (pode estar em inglês).

Para obter informações sobre como usar a Central de Controle de Mensagens no Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 262162, "XADM: Usando a Central de Controle de Mensagens para rastrear uma mensagem" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162) (pode estar em inglês).

  • 246856, "XADM: Como habilitar o controle de mensagens no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856) (pode estar em inglês).

  • 821905, "IDs de eventos do controle de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905) (pode estar em inglês).

  • 823864, "Recursos aprimorados de controle de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864) (pode estar em inglês).

Para obter mais informações sobre como solucionar problemas do categorizador de mensagens, consulte o WebCast do Suporte da Microsoft, "Exchange 2000 Server: Solução de problemas do categorizador de mensagens e de notificações de falha na entrega" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137) (pode estar em inglês).

Para obter mais informações sobre a ferramenta Coletor de Arquivo Morto, consulte o artigo 307798 da Base de Dados de Conhecimento Microsoft, "O utilitário Coletor de Arquivo Morto está disponível no Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798) (pode estar em inglês).

Para obter informações gerais sobre como solucionar problemas relacionados a transporte, consulte os seguintes artigos e recursos da Base de Dados de Conhecimento Microsoft:

  • 821910, "Como solucionar problemas de transporte do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910) (pode estar em inglês).

  • 257265, "Solução de problemas gerais de transporte no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265) (pode estar em inglês).

  • 895853, "Como solucionar problemas de retransmissão de email no Exchange Server 2003 e no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853) (pode estar em inglês).

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Guia de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875) (pode estar em inglês).

Os contadores de desempenho do categorizador de mensagens são publicados separadamente, para cada instância do servidor virtual SMTP. Para obter uma lista dos contadores de desempenho disponíveis relacionados ao categorizador de mensagens, consulte o artigo 231734 da Base de Dados de Conhecimento Microsoft, "XCON: Contadores do monitor de desempenho do categorizador de mensagens " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734) (pode estar em inglês).


Um evento de aviso de categorizador (ID: 6006) foi registrado em log nas últimas 24 horas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_NTLogEvent do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se um aviso de Evento 6006 foi registrado para o MSExchangeTransport nas últimas 24 horas.

Se descobrir que um aviso de Evento 6006 foi registrado para MSExchangeTransport nas últimas 24 horas, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que as mensagens estão sendo interceptadas no categorizador de mensagens.

O categorizador de mensagens examina as mensagens enviadas para um servidor SMTP e determina o que fazer com elas. As mensagens podem ser destinadas ao armazenamento local de informações, a um host remoto por meio do MTA ou a um host remoto por meio do SMTP. O categorizador também administra a expansão da lista de distribuição. Ele é um plug-in do mecanismo de enfileiramento avançado que executa consultas LDAP em servidores de catálogo global na porta TCP 3268. O categorizador é basicamente uma coleção de coletores de eventos que executam resolução de endereços avançada em cada mensagem que percorre o mecanismo de enfileiramento avançado. Além disso, o categorizador executa a resolução de endereços e o encaminhamento de emails, define os sinalizadores de conversão de conteúdo, expande listas de distribuição, impõe configurações globais e gera notificações de status de entrega. Ele também detecta rotas de destinatário alternativas e executa bifurcação, registro no diário e muitas outras funções.

Assim que a mensagem entra no categorizador, ele resolve o remetente do envelope procurando o endereço nos atributos de endereço de proxy, no serviço de diretório do Active Directory®. O categorizador também resolve o destinatário do envelope, pesquisando cada endereço no atributo de endereços de proxy, no Active Directory. Por exemplo, se a lista contiver uma lista de distribuição, ele expandirá a lista de modo a incluir esses membros se a expansão de lista de distribuição for permitida no servidor.

O evento 6006 do aviso Possible causes of MSExchangeTransport inclui o seguinte:

  • Software antivírus desatualizado ou configurado incorretamente.

  • Expansão excessiva de grupo de distribuição.

  • Destinatários de registro no diário configurados incorretamente.

  • Permissões configuradas incorretamente para objetos do Exchange no Active Directory.

Para solucionar os problemas do aviso:

  • Verifique se você configurou corretamente o aplicativo antivírus de nível de arquivo para excluir diretórios específicos do Exchange Server. Para obter uma descrição das pastas que você não deve incluir ao verificar servidores que estejam executando o Microsoft Exchange Server, consulte o artigo 823166 da Base de Dados de Conhecimento Microsoft, "Visão geral do Exchange Server 2003 e do software antivírus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166) (pode estar em inglês).

  • Verifique se você está executando a versão mais atual do software aplicativo antivírus.

  • Examine as configurações de restrições de entrega de grupo de distribuição e remova as restrições desnecessárias.

  • Verifique se há alguma configuração incorreta no registro no diário.

  • Verifique se há permissões configuradas incorretamente nos objetos do Exchange no Active Directory.

Para obter mais informações

Para obter mais informações sobre a verificação de restrição não-hierárquica, consulte Considere a verificação da restrição não hierárquica.

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 895407 "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407) (pode estar em inglês).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949) (pode estar em inglês).

  • 812298 "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298) (pode estar em inglês).

Para obter mais informações sobre como implantar uma solução de diário, consulte "Registrando no diário com o Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=47581) (pode estar em inglês).

Para obter mais informações sobre a possível causa do ID de evento 6006 de Aviso do categorizador, consulte o artigo 922256 da Base de Dados de Conhecimento Microsoft, "As mensagens de email ficam presas na fila "Aguardando pesquisa de diretório" em uma organização do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=922256) (pode estar em inglês).

Para obter mais informações sobre eventos e erros do Exchange Server 2003, consulte "Centro de mensagens de eventos e erros" (http://go.microsoft.com/fwlink/?LinkId=34258) (pode estar em inglês).

Para obter uma lista das mensagens de notificação de status de entrega e de falha na entrega geradas pelo Exchange Server e pelo Microsoft Windows Small Business Server, consulte o artigo 284204 da Base de Dados de Conhecimento da Microsoft, "Notificações de status de entrega no Exchange Server e no Small Business Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204) (pode estar em inglês).

Para obter mais informações sobre como solucionar problemas do categorizador de mensagens, consulte o WebCast do Suporte da Microsoft, "Exchange 2000 Server: Solução de problemas do categorizador de mensagens e de notificações de falha na entrega" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137) (pode estar em inglês).

Para obter informações gerais sobre como solucionar problemas relacionados a transporte, consulte os seguintes artigos e recursos da Base de Dados de Conhecimento Microsoft:

  • 821910, "Como solucionar problemas de transporte do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910) (pode estar em inglês).

  • 257265, "Solução de problemas gerais de transporte no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265) (pode estar em inglês).

  • 895853, "Como solucionar problemas de retransmissão de email no Exchange Server 2003 e no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853) (pode estar em inglês).

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Guia de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875) (pode estar em inglês).

Os contadores de desempenho do categorizador de mensagens são publicados separadamente, para cada instância do servidor virtual SMTP. Para obter uma lista dos contadores de desempenho disponíveis relacionados ao categorizador de mensagens, consulte o artigo 231734 da Base de Dados de Conhecimento Microsoft, "XCON: Contadores do monitor de desempenho do categorizador de mensagens " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734) (pode estar em inglês).


Um evento de aviso de categorizador (ID: 6008) foi registrado em log nas últimas 24 horas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_NTLogEvent do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se um aviso de Evento 6008 foi registrado para o MSExchangeTransport nas últimas 24 horas.

Se descobrir que um aviso de evento 6008 foi registrado para MSExchangeTransport nas últimas 24 horas, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que o categorizador encontrou um erro quando tentou processar uma mensagem.

O categorizador de mensagens examina as mensagens recebidas em um servidor SMTP e determina o que fazer com elas. As mensagens podem ser destinadas ao armazenamento de informações local, a um host remoto, usando o MTA (agente de transferência de mensagens) ou a um host remoto usando o SMTP. O categorizador também trata da expansão da lista de distribuição. O categorizador é um plug-in para o mecanismo de enfileiramento avançado que executa consultas LDAP em servidores de catálogos globais na porta TCP 3268. O categorizador é basicamente uma coleção de coletores de eventos que executam resolução de endereços avançada em cada mensagem que percorre o mecanismo de enfileiramento avançado. O categorizador executa a resolução de endereços e o encaminhamento de emails, define os sinalizadores de conversão de conteúdo, expande listas de distribuição, força configurações globais e gera notificações de status de entrega. O categorizador também detecta rotas de destinatário alternativo e executa bifurcação, registro em diário e muitas outras funções.

Assim que a mensagem entra no categorizador de mensagens, ele resolve o remetente do envelope, procurando o endereço nos atributos de endereço do proxy, no serviço de diretório do Active Directory®. O categorizador também resolve o destinatário do envelope, pesquisando cada endereço nos atributos de endereços do proxy, no Active Directory. Por exemplo, se a lista contiver uma lista de distribuição, ela expandirá a lista de modo a incluir esses membros caso a expansão da lista de distribuição seja permitida no servidor.

O evento 6008 do aviso Possible causes of MSExchangeTransport inclui o seguinte:

  • Problemas de DSAccess (Directory Service Access).

  • Latência de replicação de diretório ou falhas.

  • Servidores de catálogos globais sobrecarregados.

  • Problemas de DNS.

  • Expansão excessiva do grupo de distribuição.

Para tratar desse aviso:

  • Verifique se o Exchange Server tem conectividade com um ou mais servidores de catálogo global. A ferramenta Monitor de Rede no Windows é muito útil para essa finalidade.

  • Examine as mensagens de notificação de status de entrega que estão sendo geradas. As notificações de status de entrega podem incluir relatórios de falha na entrega. As notificações de status de entrega descrevem mensagens de falhas permanente e transitória que freqüentemente terminam como erros de entrega permanentes.

  • Use o Controle de Mensagens para solucionar os problemas de mensagens atoladas no categorizador.

  • Use a ferramenta Coletor de Arquivo Morto para arquivar e analisar as mensagens de entrada e saída do Exchange Server.

  • Monitore os contadores de desempenho do categorizador no Monitor do Sistema.

  • Examine as configurações de restrições de entrega do grupo de distribuição e remova as restrições desnecessárias.

Para obter mais informações sobre eventos e erros do Exchange Server 2003, consulte "Centro de mensagens de eventos e erros" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34258).

Para obter uma lista das mensagens de notificação de status de entrega e de falha na entrega geradas pelo Exchange Server e Microsoft Windows Small Business Server, consulte o artigo 284204 da Base de Dados de Conhecimento Microsoft, "Notificações de status de entrega no Exchange Server e no Small Business Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Para obter informações sobre como usar a Central de Controle de Mensagens no Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 262162, "XADM: Usando a Central de Controle de Mensagens para rastrear uma mensagem" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856, "XADM: Como habilitar o controle de mensagens no Exchange 2000 Server e no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905, "IDs de eventos do controle de mensagens no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864, "Recursos aprimorados de Controle de Mensagens no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

Para obter mais informações sobre como solucionar problemas do categorizador de mensagens, consulte o WebCast do Suporte da Microsoft, "Exchange 2000 Server: Solução de problemas do Categorizador de Mensagens e de notificações de falha na entrega " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Para obter mais informações sobre a ferramenta Coletor de Arquivo Morto, consulte o artigo 307798 da Base de Dados de Conhecimento Microsoft, "O utilitário Coletor de Arquivo Morto está disponível no Service Pack 2" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Para obter mais informações sobre a verificação de restrição não-hierárquica, consulte Considere a verificação da restrição não hierárquica.

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 895407 "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Para obter informações gerais sobre como solucionar problemas relacionados a transporte, consulte os seguintes artigos e recursos da Base de Dados de Conhecimento Microsoft:

  • 821910, "Como solucionar problemas de transporte do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265, "Solução gerais de problemas de transporte no Exchange 2000 Server e Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

  • 895853, "Como solucionar problemas de retransmissão de email no Exchange Server 2003 e Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853).

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Guia de Transporte e Roteamento do Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkID=67875).

Os contadores de desempenho do categorizador de mensagens são publicados separadamente, para cada instância do servidor virtual SMTP. Para obter uma lista dos contadores de desempenho disponíveis, relacionados ao categorizador de mensagens, consulte o artigo 231734 da Base de Dados de Conhecimento Microsoft, "XCON: Contadores do Monitor de Desempenho para o Categorizador de Mensagens " (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


Filtragem de Conexão está habilitada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se a propriedade msExchServerBindingsFiltering de um objeto servidor virtual SMTP indica que a Filtragem de Conexão está habilitada para uma instância do servidor virtual SMTP.

O Exchange Server Analyzer consulta também o Active Directory para saber se as propriedades msExchSmtpConnectionRulesPriority, msExchSMTPGlobalIPAcceptList ou msExchSMTPGlobalIPDenyList indicam que a Filtragem de Conexão também está habilitada no nível das configurações globais.

O Exchange Server Analyzer exibe uma mensagem de aviso se existirem as seguintes condições:

  • A Filtragem de Conexão está habilitada na instância do servidor virtual SMTP.

  • A Filtragem de Conexão está habilitada no nível de Configurações Globais.

Esse aviso indica que a Filtragem de Conexão está realmente habilitada. Geralmente, a Filtragem de Conexão não é um problema. Contudo, se você estiver solucionando problemas de fluxo de mensagens que abrangem este servidor específico, convém verificar a configuração do filtro ou desabilitar temporariamente a Filtragem de Conexão para detectar se esse recurso está bloqueando incorretamente mensagens para destinatários válidos.

Para desabilitar um filtro de conexão em um servidor virtual SMTP

  1. Iniciar o Gerenciador do Sistema do Exchange: Clique em Iniciar, aponte para Todos os Programas, aponte para Microsoft Exchange e clique em Gerenciador do Sistema.

  2. Na árvore do console, expanda Servidores, expanda o servidor desejado e, em seguida, Protocolos e SMTP.

  3. Clique com o botão direito no servidor virtual SMTP em que deseja desabilitar o filtro e, em seguida, clique em Propriedades.

  4. Em Propriedades do <Servidor Virtual SMTP>, na guia Geral, clique em Avançado.

  5. Em Avançado, selecione o endereço IP para o qual deseja desabilitar o filtro e, em seguida, clique em Editar.

  6. Em Identificação, desmarque a caixa de seleção Aplicar Filtro de Conexão para desabilitar o filtro.

  7. Se houver vários servidores virtuais, repita as etapas 3 a 6 para cada servidor virtual em que deseje desabilitar o filtro.

Para obter mais informações sobre como configurar filtros de conexão, consulte o artigo 823866 da Base de Dados de Conhecimento da Microsoft, "Como configurar a filtragem de conexão para usar RBLs (Listas de Bloqueio em Tempo Real) e como configurar a filtragem de destinatários no Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866).

Para obter mais informações sobre a filtragem inteligente de mensagens, consulte o site do Exchange Intelligent Message Filter (http://go.microsoft.com/fwlink/?LinkId=21607).


O conector tem restrições de aceitação definidas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo dLMemDefault de cada conector SMTP no grupo de roteamento. O Analisador do Exchange Server também consulta o Active Directory para determinar o valor para os atributos authOrig e unauthOrig de cada conector. Os atributos unauthOrig e authOrig contêm listas de nomes distintos (DNs) de contas.

Por padrão, todos os conectores SMTP permitem que todos os usuários enviem mensagens por meio do conector. Quando dLMemDefault estiver definido como a configuração padrão igual a 1, as mensagens de todos serão aceitas, exceto daquelas contas listadas no atributo unauthOrig. Quando dLMemDefault estiver definido como 0, as mensagens de todos serão rejeitadas, exceto daquelas contas listadas no atributo authOrig.

O Analisador do Exchange Server exibirá uma mensagem de configuração não padrão, se as seguintes condições existirem:

  • O valor do atributo dLMemDefault definido como 0.

  • O atributo authOrig contém valores.

O conector especificado pelo Analisador do Exchange Server estiver configurado para aceitar apenas algumas mensagens. Apenas as contas que receberam permissões explícitas na guia Restrições de Entrega do conector têm permissão para enviar mensagens por meio do conector.

O Analisador do Exchange Server exibe a mensagem de configuração não padrão, apenas para fins informativos.

Para obter mais informações sobre conectores, consulte o Guia de Transporte e Roteamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


O conector tem restrições de rejeição definidas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo dLMemDefault de cada conector SMTP no grupo de roteamento. O Analisador do Exchange Server também consulta o Active Directory para determinar o valor para os atributos authOrig e unauthOrig de cada conector. Os atributos unauthOrig e authOrig contêm listas de nomes distintos (DNs) de contas.

Por padrão, todos os conectores SMTP permitem que todos os usuários enviem mensagens por meio do conector. Quando dLMemDefault estiver definido como a configuração padrão igual a 1, as mensagens de todos serão aceitas, exceto daquelas contas listadas no atributo unauthOrig. Quando dLMemDefault estiver definido como 0, as mensagens de todos serão rejeitadas, exceto daquelas contas listadas no atributo authOrig.

O Analisador do Exchange Server exibirá uma mensagem de configuração não padrão, se as seguintes condições existirem:

  • O valor do atributo dLMemDefault definido como 1.

  • O atributo unauthOrig contém valores.

O conector especificado pelo Exchange Server Analyzer está configurado para rejeitar algumas mensagens. As contas que tiveram suas permissões explicitamente negadas na guia Restrições de Entrega do conector não poderão enviar mensagens através do conector.

O Analisador do Exchange Server exibe a mensagem de configuração não padrão, apenas para fins informativos.

Para obter mais informações sobre conectores, consulte o Guia de Transporte e Roteamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


O conector rejeita todas as mensagens por padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo dLMemDefault de cada conector. O atributo dLMemDefault controla se as mensagens são aceitas ou rejeitadas por padrão.

Um valor igual a 0 para o atributo dLMemDefault indica que as mensagens serão rejeitadas por padrão. Um valor igual a 1 para o atributo dLMemDefault indica que as mensagens serão aceitas por padrão. Se o Exchange Server Analyzer detectar que o valor para o atributo dLMemDefault é 0, exibirá uma mensagem de configuração não padrão.

O conector que está especificado pelo Exchange Server Analyzer é configurado para rejeitar todas as mensagens por padrão. Apenas as contas que receberam permissões explícitas na guia Restrições de Entrega do conector têm permissão para enviar mensagens por meio do conector.

O Analisador do Exchange Server exibe a mensagem de configuração não padrão, apenas para fins informativos.

Para obter mais informações sobre conectores, consulte o Guia de Transporte e Roteamento do Exchange Server em http://go.microsoft.com/fwlink/?LinkId=47579)


A verificação de restrições do conector está habilitada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte ramificação do Registro para determinar se o valor de Registro CheckConnectorRestrictions está presente e configurado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Se o Exchange Server Analyzer encontrar o valor de CheckConnectorRestrictions presente e definido como 1, um aviso será exibido.

Se for necessário aplicar a um conector uma restrição baseada em lista de distribuição, habilite manualmente o processo de verificação dessa restrição. A verificação de restrições é controlada pelo valor de Registro CheckConnectorRestrictions, que deve ser definido no servidor bridgehead do Exchange e é a origem do conector que está sendo verificado. Se você especificar uma restrição, mas não criar o valor de Registro CheckConnectorRestrictions, a restrição não será verificada.

Por padrão, a verificação de restrições de conectores está desativada, pois a expansão de grupos de distribuição e a verificação das restrições de todas as mensagens que passam pelo sistema pode afetar o desempenho de modo significativo. Se possível, habilite essa configuração apenas quando for necessário (por exemplo, no servidor bridgehead do conector restrito).

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para desabilitar a verificação de restrição de conectores

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\Resvc\Parameters

  3. No painel direito, localize e exclua CheckConnectorRestrictions.

  4. Feche o editor do Registro e reinicie os serviços Mecanismo de Roteamento do Microsoft Exchange e Protocolo SMTP para que a alteração entre em vigor.

Para obter mais informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro da verificação de restrições de conectores, consulte o artigo 277872 da Base de Dados de Conhecimento Microsoft, "XCON: Connector Delivery Restrictions May Not Work Correctly" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


O Conector tem escopo para roteamento local
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-04-21

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchRoutingSMTPConnector de cada conector SMTP. Se o Exchange Server Analyzer verificar que o atributo msExchRoutingSMTPConnector inclui a cadeia de caracteres "Local:", o Exchange Server Analyzer exibirá uma mensagem de configuração não padrão. A presença da cadeia de caracteres "Local:" indica que o conector SMTP faz parte do escopo do roteamento local.

Um conector SMTP designa um roteamento isolado para emails. Você pode usar conectores SMTP para estabelecer um gateway para emails ou para se conectar a um domínio ou sistema de emails específico. Os conectores permitem definir opções específicas para o roteamento de emails designado.

Embora seja possível enviar e receber emails usando um servidor virtual SMTP, muitas organizações configuram um conector SMTP dedicado para roteamento de emails. O uso de um conector SMTP é recomendado porque oferece um roteamento isolado para mensagens que são destinadas à Internet. Além disso, mais opções de configuração estão disponíveis em um conector SMTP do que no servidor virtual SMTP.

O Analisador do Exchange Server exibe a mensagem de configuração não padrão, apenas para fins informativos.

Para obter mais informações sobre conectores SMTP, consulte o Guia de Transporte e Roteamento do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579)


Considere a verificação da restrição não hierárquica
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para cada objeto do Exchange Server no diretório. Se o Exchange Server Analyzer verificar que o valor do atributo serialNumber de um objeto do Exchange Server 2003 contém Service Pack 2 em seu valor de cadeia de caracteres, o Exchange Server Analyzer lê a seguinte chave do Registro para determinar se o valor do Registro CheckConnectorRestrictions está presente e configurado.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Essa condição indica que o servidor confere restrições de envio e recebimento antes de permitir que uma mensagem seja processada.

Se o Exchange Server Analyzer verificar que o valor para CheckConnectorRestrictions está presente, definido como 1, e, portanto, habilitado, ele tambem lerá a chave do Registro HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod para determinar se o valor do Registro RestrictionMethod está presente e como ele está configurado.

Se o Exchange Server Analyzer verificar que o valor do Registro RestrictionMethod está ausente ou definido como um valor diferente de 2, ele exibirá uma mensagem de prática recomendada.-

Resumindo, o Exchange Server Analyzer exibe uma mensagem de prática recomendada se as seguintes condições forem verdadeiras:

  • O Exchange Server 2003 tem o SP2 instalado.

  • O valor do Registro CheckConnectorRestrictions de HKLM\System\CurrentControlSet\Services\Resvc\Parameters está configurado para usar uma restrição baseada em lista de distribuição a um conector no computador local.

  • O valor do Registro RestrictionMethod de HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod está ausente ou definido como um valor diferente de 2.

O valor RestrictionMethod determina como o categorizador processará as restrições. O comportamento padrão para o categorizador é expandir recursivamente os grupos de distribuição e verificar as restrições de cada mensagem que passa pelo sistema. Esse comportamento padrão do categorizador pode afetar significativamente o desempenho e não é uma prática recomendada.

Se você definir o valor de RestrictionMethod como 2, os componentes de transporte nesse servidor Exchange não irão expandir a associação de grupos de distribuição quando o servidor verificar restrições. Essa configuração fornece o melhor desempenho para verificações de restrição. Além disso, para que a entrada do Registro RestrictionMethod tenha efeito, todos os grupos de distribuição com usuários que tenham restrições de entrega devem ser simples. Isto é, os grupos de distribuição restritos não têm grupos de distribuição aninhados. A lógica de expansão não funcionará se os grupos de distribuição restritos estiverem aninhados.

Para grupos de distribuição usados em restrições de conector, recomendamos que você defina o valor da entrada do Registro RestrictionMethod em um servidor bridgehead de conector que não tenha caixas de correio. Para restrições de usuário do Active Directory, se os grupos de distribuição restritos tiverem servidores de expansão, recomendamos a criação da entrada do Registro RestrictionMethod nos servidores de expansão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para criar a entrada do Registro RestrictionMethod e definir o valor como 2

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. No painel esquerdo, clique em Parâmetros.

  4. No menu Editar, aponte para Novo e clique em Valor DWORD.

  5. Digite RestrictionMethod e pressione ENTER para nomear a nova entrada do Registro.

  6. Clique com o botão direito em RestrictionMethod e clique em Modificar.

  7. Digite 2 e pressione ENTER.

  8. Saia do editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro RestrictionMethod, consulte o artigo 895407 da Base de Dados de Conhecimento Microsoft, "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407) (em inglês).

Para obter mais informações sobre o valor de Registro , consulte o artigo 277872 da Base de Dados de Conhecimento Microsoft, "XCON: Connector Delivery Restrictions May Not Work Correctly" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


A chave de Registro ConvertDSNInternetContent está configurada para executar a conversão de conteúdo de todas as mensagens
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para saber se o valor do Registro ConvertDSNInternetContent foi configurado para executar conversão de conteúdo de todas as mensagens recebidas pelo Armazenamento de Informações do Exchange no computador do Exchange Server 2003:

HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O valor do Registro ConvertDSNInternetContent foi criado manualmente.

  • Os dados do valor do Registro ConvertDSNInternetContent estão definidos como 1.

Dados de valor igual a 0 ou nenhum valor de Registro ConvertDSNInternetContent desabilitam a conversão de conteúdo de mensagens SMTP pelo Armazenamento de Informações do Exchange. Dados de valor igual a 1 habilitam a conversão do conteúdo de todas as mensagens, inclusive mensagens SMTP em todas as VSIs (instâncias de servidor virtual) ou em VSIs individuais.

Por padrão, o valor do Registro ConvertDSNInternetContent não é criado durante a instalação do Exchange Server 2003. O valor do Registro ConvertDSNInternetContent pode ser criado manualmente após a instalação do Exchange Server para alterar o comportamento de conversão do conteúdo no computador do Exchange Server 2003. Geralmente, as mensagens SMTP enviadas não devem ser submetidas à conversão do conteúdo. Se você habilitar a conversão do conteúdo de todas as mensagens, inclusive das mensagens SMTP, adicionará uma sobrecarga de processamento ao servidor Exchange. Essa sobrecarga adicional de processamento pode acarretar problemas de desempenho e de armazenamento do arquivo de log.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Você deve editar o Registro de modo a retornar o comportamento da conversão do conteúdo no computador do Exchange Server 2003 ao método mais eficiente de conversão.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para a chave de Registro a seguir: HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. No painel de detalhes, clique com o botão direito no no valor de Registro ConvertDSNInternetContent, clique em Modificar e altere os Dados do valor para 80. Clique em OK.

    Observação:
    Para excluir o valor do Registro ConvertDSNInternetContent, no painel de detalhes, clique com o botão direito no valor do Registro ConvertDSNInternetContent e clique em Excluir. Confirme a exclusão do valor do Registro clicando em Sim na caixa de diálogo.

  4. Feche o editor de Registro.

  5. Reinicie o servidor Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como editar o Registro do Microsoft Windows, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 322755, "Como fazer o backup, editar e restaurar o Registro no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Como fazer o backup, editar e restaurar o Registro no Windows XP e Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Grupo de distribuição identificado como um destino comum
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-04

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Exchange_Queue do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar os valores dos seguintes atributos para as filas do Protocolo SMTP do servidor virtual SMTP.

LinkId | Indica o identificador para o link que contém a fila.
QueueId | Indica o identificador da fila.
QueueName | Indica o nome da fila.
VirtualMachine | Indica o nome da máquina virtual que contém a fila.
VirtualServerName | Indica o nome do servidor virtual em que a fila está.
MessageCount | Indica o número de mensagens na fila.

O Exchange Server Analyzer usa as informações obtidas aqui para consultar a classe Exchange_QueuedSMTPMessage do WMI referente aos valores dos seguintes atributos das mensagens na fila:

Recipients | Indica os destinatários da mensagem.
Received | Indica o carimbo de hora recebido para a mensagem.
MessageId | Indica o identificador da mensagem em fila.
StateRetry | Indica que a transmissão é repetida para uma mensagem que não foi entregue com êxito.

Finalmente, o Exchange Server Analyzer usa os dados obtidos aqui para consultar o serviço de diretório do Active Directory® referente ao valor distinguishedName de cada objeto Recipient. O Exchange Server Analyzer determina se o destinatário é um usuário, um grupo de distribuição, uma pasta pública ou um armazenamento de pasta pública.

Se o Exchange Server Analyzer determinar que pelo menos 25% das mensagens presas na fila estejam endereçadas, no campo To: ou Cc:, a um grupo de distribuição específico, o Exchange Server Analyzer exibirá um aviso.

Se o Exchange Server Analyzer determinar que pelo menos 50% das mensagens presas na fila estejam endereçadas, no campo To: ou Cc:, a um grupo de distribuição específico, o Exchange Server Analyzer exibirá um erro.

Esse aviso ou erro significa que o grupo de distribuição identificado é um destino comum para mensagens que estão presas em uma fila SMTP.

Para resolver esse problema, o grupo de distribuição deve ser investigado da maneira a seguir quanto a problemas de configuração ou outras anomalias que poderão fazer com que as mensagens sejam colocadas em fila para ele.

  • Verifique se os atributos de objeto do grupo de distribuição estão corretamente definidos e contêm os valores corretos no Active Directory.

  • Reveja as permissões do Active Directory do objeto do grupo de distribuição para obter as configurações corretas.

  • Se o grupo de distribuição contiver um objeto de usuário de uso especial, ou seja, um destinatário de Registro em Diário designado, reveja as configurações do serviço ou os componentes aos quais o objeto de usuário está relacionado para obter a configuração correta.

  • Procure possíveis ataques de vírus ou UCE (email comercial não solicitado), ou spam, contra o grupo de distribuição.

  • Determine se as restrições de entrega do grupo de distribuição estão definidas incorretamente.

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Guia de Transporte e Roteamento do Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 895407, "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 329171, "XADM: A entrega de mensagens ficará lenta se os destinatários estiverem configurados com restrições de entrega baseadas em associação de grupos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


Categorizações anteriores falharam com um erro repetível
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos contadores de desempenho em computadores executando o Exchange 2000 Server ou Exchange Server 2003. Esse mecanismo coleta dados da Cat: Os contadores de desempenho Categorizações em andamento e Comprimento da Fila do Categorizador do objeto de desempenho SMTP Server para analisar os dados de desempenho.

O contador de desempenho 'Categorizações em andamento' mostra o número de categorizações em andamento, enquanto o contador de desempenho Comprimento da Fila do Categorizador indica o número de mensagens existentes na fila do categorizador.

Para essa consulta, o Exchange Server Analyzer recupera uma amostra a cada 6 segundos, por um período de 2 minutos. O Exchange Server Analyzer informa o valor médio do contador de desempenho no decorrer do intervalo de coleta.

O Exchange Server Analyzer examina o número médio de categorizações em andamento e compara esse número com o número de categorizações ainda na fila.

O Exchange Server Analyzer exibe um erro se, durante o período de amostra, as seguintes condições forem verdadeiras:

  • O número médio de categorizações em andamento for zero.

  • O comprimento médio da fila do categorizador for maior que zero.

O categorizador executa as seguintes operações principais:

  • Resolve e valida todos os destinatários.

  • Determina limites e restrições para todos os destinatários.

  • Expande listas de distribuição, caso necessário.

  • Determina se a mensagem é para entrega local ou remota.

Esse erro indica que existem mensagens paradas na fila do categorizador, cuja categorização falhou com um erro repetível.

Normalmente, as mensagens se acumulam nas filas porque o mecanismo de enfileiramento avançado não pode categorizá-las. É possível que o mecanismo de colocação em fila avançado não consiga acessar os servidores de catálogo global e as informações dos destinatários. Como alternativa, os servidores de catálogo global podem ficar inalcançáveis ou trabalhar lentamente. Além disso, as mensagens podem se acumular pelas seguintes razões:

  • O serviço de diretório do Active Directory® não está disponível.

    Observação:
    O categorizador usa o Active Directory para categorizar mensagens.
  • O Active Directory pode estar muito sobrecarregado se muitas mensagens estiverem na fila de pré-categorização.

  • Ocorre uma falha na conversão. O categorizador também manipula conversão de conteúdo.

  • O categorizador de mensagens não consegue localizar os armazenamentos de caixa de correio.

  • Se o protocolo SMTP tiver sido reinstalado ou removido, isso pode invalidar as seguintes chaves de metabase do IIS: /smtpsvc/DsUseCat and /smtpsvc/vsi#/DsUseCat.

    Observação:
    Determine se o SMTP foi reinstalado or removido.

É possível examinar as propriedades da fila para detectar a causa da falha. Por exemplo, se as propriedades de fila exibirem uma mensagem parecida com "Erro de SMTP", você deve consultar seus logs de eventos do servidor para localizar os erros de SMTP. Se não houver eventos no log, você deve aumentar o nível de log do SMTP.

Para obter mais informações sobre como solucionar problemas de filas SMTP e do Exchange, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Guia de Transporte e Roteamento do Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Artigo 823489 do Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489) (em inglês).

  • Artigo 821877 do Base de Dados de Conhecimento Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877) (em inglês).

  • Artigo 264054 do Base de Dados de Conhecimento Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054) (em inglês).

  • "Solucionando problemas de desempenho do Microsoft Exchange Server" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

  • "Guia de Desempenho e Escalabilidade do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576) (em inglês).

Os contadores de desempenho do categorizador de mensagens são publicados separadamente, para cada instância do servidor virtual SMTP. Para obter uma lista dos contadores de desempenho disponíveis, relacionados ao Categorizador de Mensagens, consulte o artigo 231734 da Base de Dados de Conhecimento Microsoft, "XCON: Contadores do Monitor de Desempenho para o Categorizador de Mensagens " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734) (em inglês).


Habilitar atualização automática do Intelligent Message Filter
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-02-13

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para todos os objetos do Exchange Server contidos no diretório. O atributo serialNumber é um valor de cadeia de caracteres que inclui a versão do Exchange Server e a versão do service pack, se instalado. Um valor do atributo serialNumber igual a Version 6.5 (Compilação 7638: Service Pack 2) indica que o servidor está executando o Exchange Sever 2003, Service Pack 2.

O Exchange Server Analyzer também consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started para ClusSvc, o serviço de Cluster. Um valor Verdadeiro indica que o serviço de Cluster está em execução, e um valor Falso indica que não está em execução.

O Exchange Server Analyzer também lê a entrada de Registro a seguir para determinar se o Microsoft Exchange Intelligent Message Filter está instalado e habilitado no servidor:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Se o Exchange Server Analyzer verificar que a entrada ContentFilterBindings na chave de Registro ContentFilter está presente, mas o valor ContentFilterBindings não estiver configurado, isso indicará que o Intelligent Message Filter não está habilitado no servidor.

Por fim, o Exchange Server Analyzer consulta a seguinte entrada de Registro para determinar se a subchave ContentFilterState está presente e a atualização automática do Intelligent Message Filter está habilitada no servidor:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\

Qualquer valor diferente de 1 para a subchave ContentFilterState indica que a atualização automática do Intelligent Message Filter não está habilitada.

O Analisador do Exchange Server exibirá uma mensagem de práticas recomendadas, se as seguintes condições forem verdadeiras:

  • O servidor está executando o Exchange Server 2003, Service Pack 2

  • O Exchange Server não tem cluster

  • O Intelligent Message Filter está habilitado

  • Atualizações automáticas do Intelligent Message Filter não estão habilitadas.

Por padrão, o recurso Intelligent Message Filter está instalado no Exchange Server 2003 SP2. Você deve habilitar manualmente o recurso Intelligent Message Filter para obter os benefícios dessa nova tecnologia de filtragem de mensagens. Após a habilitação do recurso Intelligent Message Filter, os arquivos .dat e .dll devem ser atualizados regularmente para manter o filtro atualizado e eficaz. O artigo mencionado na seção a seguir descreve o processo de atualização que mantém o Intelligent Message Filter atualizado.

Para obter informações sobre como habilitar a atualização automática do Intelligent Message Filter, consulte o artigo 907747 da Base de Dados de Conhecimento Microsoft, "Como atualizar o Intelligent Message Filter versão 2 no Exchange Server 2003 SP2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=907747).


O Registro no diário do tipo envelope está habilitado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-03-30

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo heuristics foi configurado para habilitar o registro no diário do tipo envelope. Por padrão, o atributo heuristics não é configurado. Se o Exchange Server Analyzer perceber que o atributo heuristics está definido como 512, o Exchange Server Analyzer exibe uma mensagem de configuração não padrão.

O registro no diário do tipo envelope permite que você armazene cabeçalhos P1 de mensagens. O cabeçalho de mensagens P1 é a informação de endereço usada pelos MTAs (agentes de transferência de mensagens) para rotear mensagens. Essa informação de endereço inclui informações sobre os destinatários que realmente receberam a mensagem, incluindo destinatários Cco (cópia oculta) e destinatários de grupos de distribuição. O registro no diário do tipo envelope entrega mensagens que estão sinalizadas para serem arquivadas, usando uma mensagem do tipo envelope que contém um relatório de diário e a mensagem original. A mensagem original é entregue como um anexo. O corpo do relatório de diário contém os dados do envelope de transporte da mensagem arquivada.

Para habilitar o registro de Cco em um determinado servidor, primeiro você deve configurar o registro no diário apenas para mensagens no nível do banco de dados. O atributo heuristics não está ativo quando existirem as seguintes condições:

  • O atributo heuristics está definido como 512.

  • O registro no diário apenas para mensagens não está habilitado em nenhum dos armazenamentos de banco de dados.

O registro de mensagens no diário pode consumir muitos recursos de disco, rede e CPU. Portanto, o registro no diário exige um planejamento completo de implantação. O registro no diário deve ser habilitado somente no contexto de uma estrutura de solução de registro no diário abrangente.

Ignore esta mensagem de configuração não-padrão se as seguintes condições existirem:

  • Sua empresa exige o registro no diário.

  • Você implantou uma estrutura de solução de registro no diário.

Caso contrário, você deve desativar a funcionalidade de registro no diário.

Para desativar o registro no diário somente de mensagens em um banco de dados

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda <seu servidor Exchange>, expanda <grupo de armazenamento> e clique com o botão direito no armazenamento da caixa de correio.

  2. Na guia Geral, limpe a caixa de seleção Arquivar todas as mensagens enviadas ou recebidas por caixas de correio neste armazenamento.

  3. Aguarde 15 minutos para que o armazenamento do Exchange aplique as alterações. Você não precisa reiniciar o serviço Armazenamento de Informações do Microsoft Exchange.

Se você não desejar que o Exchange Server Analyzer exiba essa mensagem novamente, desabilite o atributo heuristics. Não é necessário desabilitar o atributo heuristics para desabilitar a funcionalidade de diário.

Você pode desabilitar o registro no diário do tipo envelope usando a ferramenta Configuração Avançada do Registro em Diário de E-Mail (Exejcfg.exe). Você pode executar a ferramenta a partir de qualquer servidor com acesso ao Active Directory, mas é recomendável executar a ferramenta a partir de um controlador de domínio.

Para obter a documentação e a ferramenta Configuração Avançada do Registro em Diário de E-Mail, faça o download do pacote de ferramentas em http://go.microsoft.com/fwlink/?LinkId=33122. A ferramenta Configuração Avançada do Registro em Diário de E-Mail pode ser usada em ambientes do Exchange 2000 Server ou do Exchange Server 2003.

Para desabilitar o atributo heurística

  1. Faça download e descompacte a ferramenta Configuração Avançada do Registro em Diário de E-Mail em um diretório de sua escolha.

  2. Abra um prompt de comando.

  3. Vá para o diretório em que você instalou a ferramenta Configuração Avançada do Registro em Diário de E-Mail.

  4. Digite o seguinte comando para desabilitar o registro no diário do tipo envelope:

    Código da Cópia
    exejcfg -d

Para obter mais informações sobre como implantar uma solução de diário, consulte "Fazendo Diários com o Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47581).


Verbo ESMTP Não Aceito
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor para o atributo msExchSmtpInboundCommandSupportOptions de cada instância de um servidor virtual SMTP está configurado para dar suporte aos verbos SMTP estendidos padrão em conexões de entrada.

Esses verbos SMTP estão listados na tabela abaixo. Se o Exchange Server Analyzer verificar que algum dos verbos estendidos SMTP padrão para conexões de entradas não tem suporte, será exibido um aviso.

O Exchange Server 2003 usa esses verbos estendidos de SMTP exclusivos do Exchange para se comunicar com outros servidores Exchange da organização com mais eficiência do que com SMTP padrão. Esses verbos são controlados na metabase e nos coletores de eventos do Exchange Server. No Exchange Server 2003, o processo DS2MB é reponsável pela atualização de valores na metabase, copiando os valores do Active Directory. Ao desativar os coletores de eventos, você pode prejudicar o desempenho do Exchange Server.

Verbo SMTP Estendido Comentários

8BITMIME

Indica que o servidor virtual SMTP local tem suporte para mensagens MIME de oito bits.

BDAT, CHUNKING

Uma alternativa para o comando DATA. Aqui são necessários dois argumentos. Quando um servidor virtual SMTP responde à palavra chave EHLO com CHUNKING, ele está indicando que tem suporte para o comando BDAT e aceita mensagens em blocos.

  • O primeiro argumento indica o comprimento do bacote de dados binários. Desse modo, o host SMTP não precisa verificar continuamente o final dos dados. O servidor que está recebendo conta os bytes na mensagem. Quando o tamanho da mensagem é igual ao valor enviado pelo comando BDAT, o servidor pressupõe que recebeu todos os dados da mensagem.

  • O segundo argumento indica se o pacote de dados é o último pacote da transmissão atual. O segundo argumento é opcional.

BINARYMIME

Indica que o servidor virtual SMTP aceita mensagens que contêm material binário sem codificação de transporte, usando um parâmetro BODY com um valor de BINARYMIME com o comando MAIL. Quando o servidor SMTP aceita um comando MAIL com um parâmetro BODY de BINARYMIME, o servidor está concordando em preservar todos os bits de cada octeto passado com o comando BDAT. A extensão SMTP BINARYMIME só pode ser usada com CHUNKING.

notificação de status de entrega

Um comando ESMTP que habilita notificações de status de entrega como definido na RFC (Request for Comments) 1891.

ENHANCEDSTATUSCODES

Indica que o servidor SmTP fornece códigos de status de erro avançados. A parte de texto de todas as respostas de status SMTP, além da saudação inicial e de respostas a HELO e EHLO, é precedida por um código de status como definido na RFC 1893.

ETRN

Enviado por um servidor SMTP para requerer que o servidor virtual local envie todas as mensagens de email que possua na fila para os domínios indicados no comando ETRN.

TURN

Permite que um host remoto e o host local alternem funções e enviem mensagens na direção inversa, sem estabelecer uma nova conexão.

Para obter mais informações sobre como restaurar o suporte padrão para esses verbos, consulte o artigo 257569 da Base de Dados de Conhecimento da Microsoft,"Como desligar os verbos ESMTP no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).


Os verbos estendidos não estão sendo anunciados pelo servidor Exchange
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a propriedade SmtpInboundCommandSupportOptions na metabase do IIS (Serviços de Informações da Internet) para determinar se o Exchange Server foi configurado para dar suporte a Verbos Estendidos. Se o Exchange Server Analyzer verificar que a configuração SmtpInboundCommandSupportOptions não está definida como 7697601, será exibido um aviso.

Os Verbos Estendidos do SMTP são exigidos pelo Exchange 2000 Server e o Exchange Server 2003. O valor na metabase do IIS deve corresponder ao valor definido no serviço de diretório do Active Directory®. Se você estiver executando o Exchange Server em um ambiente de modo misto, esse valor deverá ser definido como 7697601.

Cuidado:
Se você modificar incorretamente os atributos de objetos do Active Directory ao usar ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para armazenar o valor padrão de SmtpInboundCommandSupportOptions

  1. Abra o ADSI Edit e conecte a um controlador de domínio.

  2. Abra o Contêiner de Configuração.

  3. Mova para o seguinte local:

    Configuration/Services/Microsoft Exchange/<Sua Organização>/Administrative Groups/<Seu Grupo Administrativo>/Servers/<Seu Servidor Exchange>/Protocols/SMTP/<Seu Servidor Virtual>.

  4. Clique com o botão direito no objeto do servidor virtual e clique em Propriedades.

  5. Para Selecionar uma propriedade para visualização, selecione msExchSmtpInboundCommandsSupportOptions.

  6. Em Editar Atributo, digite 7697601.

  7. Clique em Definir, Aplicar e OK.

  8. Fechar ADSI Edit.


Filas Congeladas Detectadas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-03

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave StateFrozen para as filas do Protocolo SMTP em um servidor.

Se o Exchange Server Analyzer perceber que o valor da chave StateFrozen para qualquer uma das filas SMTP em um servidor Exchange está definido como True, o Exchange Server Analyzer exibirá um erro.

Uma fila congelada significa que as sessões de transporte para essa fila foram paradas. Uma fila congelada impede mensagens de saída, mas novas mensagens podem ser adicionadas. Você pode alterar manualmente o estado de uma conexão, usando o menu de atalho em cada fila de link. Quando você usa o comando Forçar Conexão para alterar um estado de fila para Ativo, você imediatamente habilita uma conexão que envia as mensagens dessa fila.

Para obter informações sobre as filas SMTP específicas afetadas e a possível causa, consulte os seguintes artigos da ferramenta Exchange Server Analyzer Tool:

  • A fila 'Mensagens aguardando pesquisa de diretório' está congelada

  • A fila 'Mensagens aguardando para serem roteadas' está congelada

  • A fila 'Mensagens com Envio Pendente' está congelada

  • A fila 'Entrega Local' está congelada

  • A fila 'Entrega Remota' está congelada

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Artigo 823489 da Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Artigo 821877 da Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server"http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Atualização de filtro do Intelligent Message Filter disponível
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) CIM_Datafile para determinar se o arquivo MSExchange.UceContentFilter.dll existe no caminho a seguir no Exchange Server:

<caminho para arquivos binários do servidor Exchange>\MSCFv2\MSExchange.UceContentFilter.dll

Observação:
Nesse caminho, <caminho para arquivos binários do servidor Exchange> refere-se ao local da pasta bin.

Se MSExchange.UceContentFilter.dll não existir nesse local, o Analisador do Exchange Server exibirá uma recomendação de prática recomendada.

É recomendável que a atualização de filtro do Microsoft Exchange Intelligent Message Filter esteja instalada em todos os Exchange Servers com o Intelligent Message Filter instalado. A atualização de filtro do Intelligent Message Filter fornece a atualização de filtro Intelligent Message Filter SmartScreen™ mais recente para o Intelligent Message Filter. A atualização de filtro para o filtro SmartScreen contém características de spam atualizadas que melhoram a habilidade do Intelligent Message Filter em bloquear mensagens de email comerciais não solicitadas, também conhecidas como spam.

Observação:
Antes de instalar a atualização, você deve instalar o Intelligent Message Filter. Para instalar o Intelligent Message Filter, use uma conta com direitos administrativos locais e um membro de um grupo com a função Administradores do Exchange aplicada.

Depois de instalar o Intelligent Message Filter, execute o procedimento a seguir para instalar as atualizações.

Para obter e instalar a Atualização do Intelligent Message Filter

  1. Para obter as informações mais recentes do Exchange Intelligent Message Filter (http://go.microsoft.com/fwlink/?LinkId=41026).

  2. Consulte as notas de versão da atualização do Intelligent Message Filter em http://go.microsoft.com/fwlink/?LinkId=41027).

  3. Execute o pacote de atualização e siga as instruções do Assistente de Instalação do pacote de atualização.

Para obter mais informações, consulte o site do Exchange Intelligent Message Filter (http://go.microsoft.com/fwlink/?LinkId=21607).


A verificação de restrição simples está habilitada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo serialNumber para cada objeto do Exchange Server no diretório. Se o valor da cadeia de caracteres do atributo serialNumber de um objeto do servidor Exchange Server 2003 contiver Service Pack 2, isso indica que o servidor Exchange está executando uma versão de pré-lançamento do Exchange Server 2003 Service Pack 2.

O Exchange Server Analyzer lê também a seguinte entrada do Registro para determinar se o valor do Registro RestrictionMethod está presente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

O Exchange Server Analyzer exibirá uma mensagem de configuração não padrão, se as seguintes condições forem verdadeiras:

  • O Exchange Server 2003 Service Pack 2 está instalado.

  • O valor do Registro RestrictionMethod está presente e configurado para ter um valor igual a 2.

Essa configuração indica que os componentes de transporte nesse servidor Exchange não irão expandir a associação de grupos de distribuição quando o servidor verificar restrições. Essa configuração fornece o melhor desempenho para verificações de restrição.

Se você acredita que a presença e a configuração do valor do Registro RestrictionMethod estão em erro, poderá usar o seguinte procedimento para reverter para a configuração padrão. No entanto, pelo fato de a presença dessa chave em conjunto com o Exchange Server 2003 Service Pack 2 proporcionar o melhor desempenho para verificações de restrições, é recomendável que você deixe o valor do Registro RestrictionMethod com a sua configuração atual.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. No painel da direita, clique com o botão direito em RestrictionMethod e selecione Excluir.

  4. Feche o editor do Registro e reinicie os serviços Admin do IIS e Mecanismo de Roteamento do Microsoft Exchange para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro RestrictionMethod, consulte o artigo 895407 da Base de Dados de Conhecimento Microsoft, "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407) (em inglês).


Registros 'Host' encontrados, mas não Registros 'MX'
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

O Microsoft® Exchange Server Analyzer Tool consulta os servidores DNS (Sistema de Nome de Domínio) que usa para obter os registros do servidor de mensagens (MX) de domínios remotos para os quais o Exchange envia. Em seguida, o Exchange Server Analyzer faz uma pesquisa no DNS para recuperar os registros do Host (A) dos domínios remotos.

Se a operação de consulta ao DNS do Exchange Server Analyzer não retornar os registros MX dos domínios remotos, mas recuperar posteriormente os registros Host (A) desses mesmos domínios, o Exchange Server Analyzer exibirá um aviso.

Nessa situação, após a falha na recuperação dos registros MX, o Exchange Server poderá tentar enviar uma mensagem para os servidores indicados pelos registros Host (A). É muito importante que esses registros Host (A) indiquem os servidores de email corretos.

Alguns domínios podem configurar os respectivos registros Host (A) de modo a indicar um ISP (Provedor de Serviços de Internet) que, embora possa ter servidores de email válidos, talvez não seja o servidor de email autorizado para o destinatário pretendido. Nesse caso, a mensagem será recusada.

A pesquisa de DNS dos registros MX poderão falhar se o servidor DNS estiver fora do ar ou inacessível por causa de uma falha de rede ou por outros motivos.

Para verificar se o servidor DNS está online e se os registros MX estão presentes

  1. Confira se o servidor DNS está em execução fazendo uma ou mais das seguintes verificações:

    • Veja o status do servidor DNS no programa de Administração do DNS no servidor DNS.

    • Reinicie o servidor DNS. Para obter mais informações, consulte "Start, stop, pause, or restart a DNS server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Verifique a capacidade de resposta do servidor DNS usando o comando nslookup. Para obter mais informações, consulte as instruções em "Verify DNS server responsiveness using the nslookup command" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Use nslookup para verificar se os registros MX estão configurados corretamente. Para obter mais informações, consulte "Como usar Nslookup para verificar a configuração de registros MX" na seção "Verificando o design e a configuração de DNS" do Guia de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579) (em inglês).

Para obter mais informações

  • Para obter informações sobre como o Exchange Server 2003 usa o DNS para resolver endereços IP externos, consulte "Transport Dependencies for Exchange Server 2003" no Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Para obter informações sobre resolução de nomes do DNS, consulte o artigo 322856 da Base de Dados de Conhecimento Microsoft, "COMO FAZER: Configure DNS para Ser Usado com o Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Para obter informações sobre como solucionar problemas do DNS, consulte "Troubleshooting DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63003).


O valor do Registro PoolThreadLimit do IIS foi adicionado e configurado manualmente
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê as seguintes entradas de Registro para determinar se o número máximo de threads de pool do IIS (Serviços de Informações da Internet) foi modificado em relação ao valor padrão:

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\Inetinfo\Parameters\PoolThreadLimit

Se o Exchange Server Analyzer verificar que o PoolThreadLimit está presente e configurado com um valor alternativo, uma mensagem de configuração não padrão será exibida.

O valor de Registro PoolThreadLimit especifica o número máximo de threads de trabalho de entrada/saída (E/S) que podem ser criados no processo Inetinfo.exe process, que controla o número máximo de conexões simultâneas que podem ser feitas no IIS. Cada thread de pool procura uma solicitação de rede e a processa, devolvendo um arquivo estático ou passando a solicitação para uma DLL de extensão ISAPI (como ASP.DLL) ou para um aplicativo CGI (Interface Comum do Gateway). Se a extensão ISAPI processar uma solicitação sincronizada e demorar muito para processar solicitações, irá obstruir o thread de trabalho, deixando o IIS com menos threads de trabalho para processar outras solicitações. Por esse motivo, extensões ISAPI bem escritas, como ASP, implementam seus próprios pools de thread, colocam as solicitações em uma fila e as processam de forma assíncrona com seus próprios threads, para não obstruir threads de trabalho do IIS.

Por padrão, o IIS define PoolThreadLimit em:

2 * número de megabytes de RAM presentes na máquina

Se esse valor for superior a 256, será fixado em 256. Por padrão, esse valor de Registro não existe. Se esse valor estiver presente no Registro, ele substituirá o cálculo padrão do IIS.

Geralmente, se você achar que o limite padrão de 256 threads é inadequado, provavelmente tem uma extensão ISAPI mal escrita obstruindo threads de trabalho do IIS. 256 representa um número grande de threads ativos simultaneamente e incorrerá em sobrecarga significativa na sincronização e alternância de contexto.

O valor de Registro PoolThreadLimit é um limite rígido que inclui todos os threads de trabalho do IIS, incluindos os serviços HTTP, FTP, NNTP e SMTP.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Examine, exclua ou modifique o valor PoolThreadLimit.

  4. Feche o editor de Registro e reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro, e para obter informações sobre como editar o Registro, leia o artigo da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).


Restrição de tamanho da mensagem de entrada e saída
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-12-01

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo do limite de tamanho de mensagem de saída, que é submissionContLength, difere do atributo do limite de tamanho de mensagem de entrada, que é delivContLength. Se o Exchange Server Analyzer verificar que o limite de tamanho de mensagens de saída e limite de tamanho de mensagens de entrada são diferentes, o Exchange Server Analyzer exibirá uma mensagem de prática recomendada.

Recomendamos que você defina o limite de tamanho da mensagem de saída e o limite de tamanho da mensagem de entrada para o mesmo valor para proporcionar consistência na restrição da mensagem.

Para alterar o limite de tamanho da mensagem de saída para o Exchange 2000 Server e Exchange Server 2003

  1. Inicie o Gerenciador do Sistema Exchange.

  2. No painel da esquerda, expanda Configurações Globais.

  3. Clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  4. Na guia Padrões, em Tamanho da mensagem de envio, clique em Máximo (KB) e, depois, digite um número.
Para definir os limites de tamanho da mensagem de saída para o Exchange Server 2007

  1. No Shell de Gerenciamento do Exchange, execute o seguinte comando, em que <size> é inserido como o padrão de "ilimitado" ou o tamanho em B (Bytes), KB (Quilobytes) ou MB (Megabytes) em um intervalo de 0 a 2.147.483.647 bytes:
Código da Cópia
Set-TransportConfig -MaxSendSize <size>

Por exemplo, para definir o tamanho máximo de mensagem que pode ser enviado por usuários na Organização do Exchange como 10 Megabytes, insira:

Código da Cópia
Set-TransportConfig -MaxSendSize 10MB

Para definir o tamanho máximo de mensagem que pode ser enviado por usuários na Organização do Exchange como o valor padrão de ilimitado, insira:

Código da Cópia
Set-TransportConfig -MaxSendSize unlimited
 Para alterar o limite de tamanho de mensagens de entrada

  1. Inicie o Gerenciador do Sistema Exchange.

  2. No painel da esquerda, expanda Configurações Globais.

  3. Clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  4. Na guia Padrões, em Tamanho da mensagem de recebimento, clique em Máximo (KB) e digite um número.
Para definir os limites de tamanho da mensagem de entrada para o Exchange Server 2007

  1. No Shell de Gerenciamento do Exchange, execute o seguinte comando, em que <size> é inserido como o padrão de "ilimitado" ou o tamanho em B (Bytes), KB (Quilobytes) ou MB (Megabytes) em um intervalo de 0 a 2.147.483.647 bytes:
Código da Cópia
Set-TransportConfig -MaxReceiveSize <size>

Por exemplo, para definir o tamanho máximo de mensagem que pode ser recebido por destinatários na Organização do Exchange como 10 Megabytes, insira:

Código da Cópia
Set-TransportConfig -MaxReceiveSize 10MB

Para definir o tamanho máximo de mensagem que pode ser recebido por destinatários na Organização do Exchange como o valor padrão de ilimitado, insira:

Código da Cópia
Set-TransportConfig -MaxReceiveSize unlimited

Para obter mais informações sobre como definir limites de tamanho para mensagens no Exchange 2000 Server e no Exchange Server 2003, consulte o artigo 322679 da Base de Dados de Conhecimento Microsoft, "Como configurar limites de tamanho para mensagens no Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).

Para obter mais informações sobre o cmdlet TransportConfig para Exchange Server 2007, consulte "Set-TransportConfig" na Referência Técnica do Exchange Server 2007 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=79237).


Resposta personalizada do Intelligent Message Filter presente
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte chave de Registro para saber se o valor do Registro CustomRejectResponse está presente:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

O Analisador do Exchange Server exibirá uma mensagem de configuração não padrão, se as seguintes condições existirem:

  • O valor de CustomRejectResponse está presente.

  • Este valor é uma cadeia de caracteres válida.

    Observação:
    O valor da cadeia de caracteres de resposta deve começar com 550 5.7.1 para que seja reconhecida como válida.

Nenhuma ação corretiva é necessária.

No Exchange Server 2003 Service Pack 2 (SP2), a filtragem inteligente de mensagens está instalado e pronto para uso ao instalar o SP2. O Exchange Server 2003 SP2 permite a personalização da cadeia de caracteres de resposta do servidor, gerada e anexada à notificação de falha na entrega retornada ao remetente. A resposta padrão de 550 5.7.1 Ação solicitada não executada: mensagem recusada pode ser alterada para dar aos usuários legítimos bloqueados uma explicação significativa para o bloqueio de suas mensagens. Essa explicação pode ajudar a reduzir a investigação dos falsos positivos e os custos de suporte associados ao processamento anti-spam.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para alterar a cadeia de caracteres de resposta personalizada

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\Software\Microsoft\Exchange\ContentFilter

  3. No painel de tarefas à direita, clique com o botão direito no valor de CustomRejectResponse e selecione Modificar.

  4. Digite o valor da cadeia de caracteres a ser usada como resposta personalizada, começando essa cadeia de caracteres com 550 5.7.1. Por exemplo, digite 550 5.7.1 Domínio não é um remetente permitido para definir a cadeia de caracteres como uma cadeia de caracteres válida que será incluída na notificação de falha na entrega.

  5. Salve as alterações, saia do editor de Registro e reinicie o serviço SMTP para que as alterações entrem em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a filtragem inteligente de mensagens, consulte o site do Exchange Intelligent Message Filter (http://go.microsoft.com/fwlink/?LinkId=21607).

Para obter informações detalhadas sobre como executar tarefas de filtragem inteligente de mensagens, consulte "Configurar o Intelligent Message Filtering" na Ajuda on-line do Exchange Server 2003 SP2.

Para obter informações sobre o SP2 do Exchange Server 2003, consulte o site do Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


Lista de palavras personalizadas do Intelligent Message Filter presente
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta a classe CIM_Datafile da Instrumentação de Gerenciamento do Microsoft Windows® para verificar a presença de um arquivo MSExchange.UCEContentFilter.xml no servidor Exchange. Se o Exchange Server Analyzer encontrar um arquivo MSExchange.UCEContentFilter.xml no Exchange Server, será exibida uma mensagem de configuração não padrão. Nenhuma ação corretiva é necessária.

O arquivo MSExchange.UCEContentFilter.xml é um componente do recurso de pesagem personalizada no Intelligent Message Filter para Exchange Server 2003 Service Pack 2 (SP2).

O recurso de pesagem padrão no Intelligent Message Filter para SP2 permite que os administradores personalizem o comportamento do Intelligent Message Filter com base em frases que estão no corpo de uma mensagem de email, na linha de assunto ou em ambos. Não há interface de usuário associada ao recurso de pesagem personalizada. A pesagem personalizada é disponibilizada no formato de um arquivo de configuração XML, o MSExchange.UCEContentFilter.xml, que é lido pelo Intelligent Message Filter na inicialização e recarregado sempre que o arquivo for alterado. Se o arquivo MSExchange.UCEContentFilter.xml não estiver presente quando o Intelligent Message Filter for iniciado, é necessário reiniciar o serviço SMTP. O arquivo de pesagem personalizado MSExchange.UCEContentFilter.xml deve estar localizado no mesmo diretório que os arquivos MSExchange.UceContentFilter.dll e .dat.

Para obter mais informações sobre o arquivo de pesagem personalizada, consulte as Notas de Versão do Exchange Server 2003 Service Pack 2. As notas de versão do Exchange Server 2003 Service Pack 2 estão disponíveis no CD do SP2 e no site das Notas de Versão do Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52072).

Para obter informações sobre o SP2 do Exchange Server 2003, consulte o site do Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


Resposta personalizada inválida da Filtragem Inteligente de Mensagens
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte chave de Registro para saber se o valor do Registro CustomRejectResponse está presente:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

O Exchange Server Analyzer exibirá um aviso se existirem as seguintes condições:

  • O valor de CustomRejectResponse está presente.

  • Essa cadeia de caracteres de valor não inicia com 550 5.7.1.

    Observação:
    O valor da cadeia de caracteres de resposta deve começar com 550 5.7.1 para que seja reconhecida como válida.

O Exchange Server 2003 Service Pack 2 (SP2) permite a personalização da cadeia de caracteres de resposta do servidor que é gerada e anexada à notificação de falha de entrega retornada ao servidor. A resposta padrão de 550 5.7.1 Ação solicitada não executada: mensagem recusada pode ser alterada para dar aos usuários legítimos bloqueados uma explicação significativa para o bloqueio de suas mensagens. Essa explicação pode ajudar a reduzir a investigação dos falsos positivos e os custos de suporte associados ao processamento anti-spam.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\Software\Microsoft\Exchange\ContentFilter

  3. No painel de tarefas à direita, clique com o botão direito no valor de CustomRejectResponse e selecione Modificar.

  4. Digite o valor da cadeia de caracteres a ser usada como resposta personalizada, começando essa cadeia de caracteres com 550 5.7.1. Por exemplo, digite 550 5.7.1 Domínio não é um remetente permitido para definir a cadeia de caracteres como uma cadeia de caracteres válida que será incluída na notificação de falha na entrega.

  5. Salve as alterações, saia do editor de Registro e reinicie o serviço SMTP para que as alterações entrem em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a filtragem inteligente de mensagens, consulte o site do Exchange Intelligent Message Filter (http://go.microsoft.com/fwlink/?LinkId=21607).

Para obter informações detalhadas sobre como executar tarefas de filtragem inteligente de mensagens, consulte "Configurar o Intelligent Message Filtering" na Ajuda on-line do Exchange Server 2003 SP2.


O Intelligent Message Filter está habilitado no servidor de caixa de correio
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada de Registro a seguir para determinar se o Microsoft Exchange Intelligent Message Filter está instalado e habilitado no servidor:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

O Exchange Server Analyzer lê o valor de ContentFilterBindings da chave de Registro ContentFilter para determinar se o Intelligent Message Filter está instalado e habilitado no servidor.

O Exchange Server Analyzer consulta então o serviço de diretório do Active Directory® para determinar o valor do atributo msExchAuthenticationFlags do objeto do Exchange Server. O atributo msExchAuthenticationFlags representa o tipo de autenticação permitida no servidor. O Exchange Server Analyzer exibe uma mensagem de aviso se existirem as seguintes condições:

  • A autenticação no atributo msExchAuthenticationFlags foi configurada para permitir acesso anônimo ao servidor.

  • O servidor também hospeda caixas de correio.

O Intelligent Message Filter identifica as mensagens que provavelmente serão emails comerciais não solicitados (UCE). Para filtrar essas mensagens UCE eficazmente, será necessário implantar o Intelligent Message Filter nos servidores gateway ou bridgehead do Exchange, se você usar servidores de email que não sejam da Microsoft no gateway. Esses servidores gateway aceitam emails de entrada da Internet e encaminham essas mensagens ao servidor de caixa de correio apropriado. Em geral, servidores gateway não hospedam caixas de correio.

Além disso, é necessário habilitar o Intelligent Message Filter em cada servidor virtual SMTP que aceita mensagens de email da Internet nos servidores gateway do Exchange.

Importante:
Não desabilite o acesso anônimo nos servidores virtuais SMTP de gateway da Internet. Os servidores virtuais SMTP que aceitam email da Internet devem permitir acesso anônimo.

Para filtrar UCE, é possível configurar o Intelligent Message Filter definindo limites nas classificações de nível de confiança em spam atribuídas às mensagens de entrada, tanto no gateway quanto nos armazenamentos de caixa de correio do Exchange. O Intelligent Message Filter avalia cada mensagem que chega e atribui à mensagem uma classificação de nível de confiança com base na probabilidade de a mensagem ser UCE. Os servidores de caixa de correio do Exchange usam o limite e as definições de nível de confiança em spam especificados no armazenamento de caixa de correio para determinar se envia uma mensagem para a Caixa de Entrada ou para a pasta Lixo Eletrônico de um usuário.

Importante:
O Intelligent Message Filter não precisa estar instalado nos servidores de caixa de correio do Exchange. Se o Intelligent Message Filter estiver instalado e habilitado nos servidores virtuais SMTP de gateway, os servidores de caixa de correio do Exchange receberão a classificação de nível de confiança em spam com cada mensagem que chega e tomarão a ação adequada.

Para obter informações, consulte o site do Exchange Intelligent Message Filter (http://go.microsoft.com/fwlink/?LinkId=21607). Para obter mais informações sobre como configurar a organização do Exchange Server 2003 para enviar e receber emails da Internet, consulte o Guia de Transporte e Roteamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


O Intelligent Message Filter não está habilitado no servidor
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada de Registro a seguir para determinar se o Microsoft Exchange Intelligent Message Filter está instalado e habilitado no servidor:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Se o Analisador do Exchange Server detectar que a entrada do valor de ContentFilterBindings na chave de Registro ContentFilter está presente, mas o valor de ContentFilterBindings não está configurado, o Analisador do Exchange Server exibirá uma mensagem de aviso.

Observação:
A presença da entrada do valor de ContentFilterBindings na chave de Registro ContentFilter quando o valor de ContentFilterBindings não está configurado indica que a Intelligent Message Filter não está habilitada no servidor.
Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

O Microsoft Exchange Intelligent Message Filter identifica as mensagens que provavelmente serão UCE (email comercial não solicitado). Após a implantação do Intelligent Message Filter em servidores de gateway do Exchange ou em servidores bridgehead do Exchange que aceitam e-mail de entrada, habilite o Intelligent Message Filter em cada servidor virtual SMTP que aceita mensagens de email de Internet.

Para exibir a chave de Registro ContentFilter

  1. No Editor do Registro (regedit), no painel de detalhes, clique com o botão direito em ContentFilter para exibir a configuração de ContentFilterBindings.

    Observação:
    Se você não configurou o Intelligent Message Filter do Exchange no servidor virtual SMTP, o valor de ContentFilterBindings será nulo.

    Antes de editar o Registro e obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

É recomendável habilitar o Intelligent Message Filter do Exchange em todos os Exchange Servers que possuem esse recurso instalado. Para habilitar o Intelligent Message Filter no servidor virtual SMTP, execute o procedimento a seguir. Após habilitar o Intelligent Message Filter, verifique o valor da chave de Registro ContentFilter no Registro.

Para habilitar o Intelligent Message Filter

  1. Clique em Iniciar, aponte para Todos os Programas, aponte para Microsoft Exchange e clique em Gerenciador do Sistema.

  2. No Gerenciador do Sistema Exchange, expanda Servidores, Nome do servidor, Protocolos, SMTP, clique com o botão direito em Intelligent Message Filter e clique em Propriedades.

  3. Na guia Geral, em Aplicar o Intelligent Message Filter aos seguintes endereços IP de servidores virtuais, clique na caixa de seleção ao lado de cada servidor virtual SMTP em que este recurso deve ser habilitado.

    Caixa de diálogo Propriedades do Intelligent Message Filter

Para obter informações, consulte o site do Exchange Intelligent Message Filter (http://go.microsoft.com/fwlink/?LinkId=21607).


Servidor de Serviço de Atualização de Destinatário Inválido Designado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-07-30

A ferramenta Microsoft Exchange Analyzer consulta o serviço de diretório do Active Directory para determinar o valor do atributo msExchAddressListServiceLink para cada objeto do Serviço de Atualização de Destinatário do diretório. O atributo msExchAddressListServiceLink é um link do serviço de lista de endereços para um computador do Exchange Server que está executando o RUS (Serviço de Atualização de Destinatário).

O Exchange Analyzer, então, consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Version para o Serviço de Grupos Dinâmicos e Exibição de Catálogo de Endereços (abv_dg.dll) nos computadores do Exchange Server identificados. A chave Version do WMI indica o número de compilação do arquivo.

Caso o Exchange Analyzer descubra que o número de compilação do arquivo abv_dg.dll em qualquer um dos computadores identificados começa com 08, um erro será exibido.

Esse erro indica que o computador designado como servidor RUS está executando o Microsoft Exchange Server 2007.

O Serviço de Atualização de Destinatário é um componente do serviço Atendedor do Sistema do Exchange encontrado no Exchange 2000 Server e no Exchange Server 2003. O Serviço de Atualização de Destinatário para Exchange 2000 e Exchange 2003 cria e mantém valores de atributo específicos do Exchange no Active Directory. Essa funcionalidade é controlada pelo processo de criação de destinatário do Exchange 2007 e o Serviço de Atualização de Destinatário herdado não irá processar atualizações se estiver sendo executado em um servidor Exchange 2007.

Para solucionar esse erro, indique um Exchange 2000 Server ou Exchange Server 2003 para hospedar o Serviço de Atualização de Destinatário.

Para corrigir esse erro

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Em Destinatários, clique em Serviços de Atualização de Destinatário. No painel de navegação direito, clique com o botão direito na instância apropriada do Serviço de Atualização de Destinatário e clique em Propriedades.

  3. Na guia Geral, em Exchange Server, clique em Procurar e especifique um novo servidor Exchange 2000 Server ou Exchange Server 2003 para executar essa instância do RUS.

  4. Clique em OK e clique em OK novamente para que a alteração entre em vigor.


Grande quantidade de categorizações em andamento
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-21

A ferramenta Microsoft® Exchange Server Analyzer dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos contadores de desempenho em computadores executando o Exchange 2000 Server ou Exchange Server 2003. Esse mecanismo coleta dados da Cat: Contador de desempenho Categorizações em andamento do objeto de desempenho SMTP Server para analisar os dados de desempenho.

A Cat: O contador de desempenho Categorizações em andamento mostra o número de categorizações em andamento.

Para essa consulta, o Exchange Server Analyzer recupera uma amostra a cada 6 segundos, por um período de 2 minutos. O Exchange Server Analyzer informa o valor médio do contador de desempenho no decorrer do intervalo de coleta.

Ao detectar que o número médio de categorizações em andamento durante o período da amostra ultrapassa 800, o Exchange Server Analyzer exibirá um erro.

O categorizador executa as seguintes operações principais:

  • Resolve e valida todos os destinatários.

  • Determina limites e restrições para todos os destinatários.

  • Expande listas de distribuição, caso necessário.

  • Determina se a mensagem é para entrega local ou remota.

Este erro pode indicar que o servidor está enfrentando uma carga extra ou um problema de desempenho.

Para resolver este erro:

  • Descubra se a tensão no categorizador foi prevista ou procede de uma carga comum. Se a tensão no categorizador é oriunda de uma carga prevista, examine a orientação sobre o desempenho do Exchange neste artigos da Microsoft TechNet.

    • "Solucionando problemas de desempenho do Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

    • "Guia de Desempenho e Escalabilidade do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576) (em inglês).

  • Se a tensão no categorizador não é oriunda de uma carga prevista, verifique se há epidemias de vírus ou SPAM que possam gerar a carga.

Os contadores de desempenho do categorizador de mensagens são publicados separadamente, para cada instância do servidor virtual SMTP (Simple Mail Transfer Protocol). Para obter uma lista dos contadores de desempenho disponíveis, relacionados ao Categorizador de Mensagens, consulte o artigo 231734 da Base de Dados de Conhecimento Microsoft, "XCON: Contadores do Monitor de Desempenho para o Categorizador de Mensagens " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734) (em inglês).


Grande quantidade de caixas de correio com restrições de entrega do grupo de distribuição definidas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-21

A ferramenta Microsoft® Exchange Server Analyzer consulta os seguintes atributos de cada objeto usuário em todos os domínios encontrados no serviço de diretório do Active Directory® para detectar se alguma caixa de correio nos domínios possui restrições de entrega definidas, baseadas na associação do grupo de distribuição:

dLMemDefault | Controla se as mensagens são aceitas ou rejeitadas, por padrão. Quando definidas com a configuração padrão 1, as mensagens de todos são aceitas.
dLMemRejectPerms | Contém os nomes de domínio (DNs) de listas de distribuição (DL) cujos membros não podem enviar para este destinatário
dLMemSubmitPerms | Contém os nomes de domínio (DNs) de listas de distribuição (DL) cujos membros podem enviar para este destinatário.

Ao detectar a existência de mais de 500 caixas de correio no domínio com restrições de entrega definidas com base em associação de grupos de distribuição, o Exchange Server Analyzer exibirá um erro.

Esse erro indica que as restrições da entrega baseadas em associação de grupos de distribuição para muitas caixas de correio podem afetar o desempenho do fluxo de mensagens do Exchange.

Por padrão, o categorizador expande recursivamente os grupos de distribuição e verifica as restrições de cada mensagem que passa pelo sistema.

Ao enviar uma mensagem para um usuário que aceita ou recusa mensagens de um grupo de distribuição, o categorizador de mensagens precisa expandir a associação do grupo de distribuição, obter a lista completa de DNs dos membros e comparar a lista de DNs com os DNs do remetente da lista. Uma operação de acesso ou de negação ocorre quando um DN consta em ambas as listas. Se um grupo de distribuição estiver aninhado em outro grupo de distribuição, a distribuição aninhada também será expandida.

Para corrigir esse erro:

  • Examine os usuários cujas restrições de entrega do grupo de distribuição estão definidas e remova as restrições desnecessárias.

  • Configure caixas de correio individuais e não grupos de distribuição para restrições de entrega, como citado no artigo 812298 da Base de Dados de Conhecimento Microsoft, "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Para os servidores executando o Exchange Server 2003 Service Pack 2 (SP2) ou versão posterior, considere a implementação de verificação de restrição não-hierárquica. Para os servidores executando versões do Exchange anteriores ao Exchange 2003 SP2, considere atualizar para o Exchange 2003 SP2.

Para obter mais informações

Para obter mais informações sobre a verificação de restrição não-hierárquica, consulte Considere a verificação da restrição não hierárquica.

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 895407 "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407) (em inglês).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949) (em inglês).

  • 812298 "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298) (em inglês).


O roteamento de menor custo é habilitado em uma Organização em Modo Misto
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o roteamento de menor custo está habilitado no servidor que está executando o Exchange Server versão 5.5 em um ambiente de modo misto. O Exchange Server Analyzer exibirá um aviso se existirem as seguintes condições:

  • O roteamento de menor custo está habilitado.

  • Sua organização está executando o Exchange Server 2003 em um ambiente de modo misto com o Exchange Server 5.5.

Quando o roteamento de modo misto está habilitado em um ambiente de modo misto, os loops de mensagens podem ser criados. O Exchange Server 2003 usa um roteamento de estado do link. Portanto, o Exchange Server 2003 reencaminha as mensagens para outro servidor quando detecta que um link está desativado. Quando um servidor Exchange Server 5.5 está usando a opção Only use least cost routes na página de propriedades de Message Transfer Agent, a melhor rota muitas vezes é determinada para retornar ao servidor Exchange Server 2003 do qual a mensagem acabou de ser enviada. Quando a mensagem é retornada para o servidor Exchange Server 2003, a rota se torna um loop.

Em qualquer organização de modo misto que esteja roteando tanto o Exchange Server 5.5 quanto o Exchange Server 2003, é recomendável que a opção de roteamento de menor custo esteja desabilitada em todos os servidores que executam o Exchange Server 5.5.

Para desabilitar o roteamento de menor custo no Exchange Server 5.5

  1. No programa Microsoft Exchange Server Administrator, expanda o contêiner Organização, Site, Configuração, Servidores e clique no seu objeto do servidor.

  2. No painel direito, clique no objeto Agente de Transferência de Mensagem.

  3. Clique no menu Arquivo e clique em Propriedades.

  4. Na caixa de diálogo Propriedades do Agente de Transferência de Mensagem, na guia Geral, desmaque Usar somente roteamento de menor custo.

  5. Clique em OK.


A porta de escuta do SMTP parece ter tido seu padrão de 25 alterado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchServerBindings teve seu valor padrão 25 alterado. Por padrão, o atributo msExchServerBindings está definido como 25. Se a ferramenta achar que esse atributo não tem um valor igual a 25, uma mensagem de configuração não padrão será exibida.

O atributo msExchServerBindings representa a porta TCP na qual esse servidor SMTP escuta as conexões de entrada. Servidores virtuais SMTP podem ser configurados para ouvir em uma ou mais portas TCP. Por padrão, todos os servidores virtuais SMTP estão configurados para ouvir na porta TCP 25, a porta SMTP padrão. Se a porta de escuta SMTP teve seu valor padrão modificado e não inclui mais a porta TCP 25 em sua lista de portas de escuta, ela poderá interromper o fluxo de mensagens.

É aceitável alterar a porta de escuta do SMTP, desde que o restante da infra-estrutura de mensagens interna também seja modificado de acordo. Entretanto, portas alternativas não podem ser usadas para servidores SMTP virtuais que aceitam mensagens diretamente da Internet, como os servidores SMTP da Internet que enviam mensagens pela porta 25.

Observe que o Analisador do Exchange Server está procurando o valor para o servidor virtual do protocolo SMTP do Exchange. Esse servidor virtual do protocolo SMTP pode ou não ser o servidor SMTP que recebe mensagens diretamente da Internet. Existem alguns produtos antivírus e anti-spam projetados para receber mensagens SMTP da Internet na porta 25 e redirecioná-las para um servidor virtual SMTP do Exchange em outra porta. Nesse cenário, um servidor virtual SMTP do Exchange escutando em uma porta diferente da porta 25 é uma configuração aceitável.

Para exibir ou modificar a porta de escuta do servidor virtual SMTP

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  2. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e clique em Propriedades.

  3. Selecione a guia Geral e clique em Avançado.

  4. Uma lista de portas e endereços IP será exibida.

    • Para alterar a porta existente, selecione o endereço IP e clique em Editar. Altere o campo da porta TCP para 25.

    • Para adicionar a porta 25 como uma porta de escuta adicional, clique em Adicionar e adicione a nova combinação endereço IP/porta. Se você estiver usando Filtragem por Conexão, Remetente ou Destinatário, certifique-se de ter marcado as caixas de seleção corretas.

  5. Clique em OK para salvar as alterações e clique em OK novamente para sair da caixa de diálogo Avançado. Clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: How to Configure a SMTP Virtual Server Part 1," (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


A fila 'Entrega Local' está congelada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-03

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave StateFrozen da fila Entrega Local do SMTP.

Se o Exchange Server Analyzer verificar que o valor da chave StateFrozen para a fila Entrega Local de um servidor Exchange está definido como Verdadeiro, ele exibirá um erro.

Uma fila congelada significa que as sessões de transporte para essa fila foram paradas. Uma fila congelada impede mensagens de saída, mas novas mensagens podem ser adicionadas. Você pode alterar manualmente o estado de uma conexão, usando o menu de atalho em cada fila de link. Quando você usa o comando Forçar Conexão para alterar um estado de fila para Ativo, você imediatamente habilita uma conexão que envia as mensagens dessa fila.

A fila Entrega Local contém mensagens enfileiradas no servidor Exchange para entrega local em um armazenamento de caixas de correio ou de pastas públicas do Exchange Server.

As mensagens poderão se acumular nessa fila, se o servidor Exchange não estiver aceitando mensagens para entrega local. Uma entrega de mensagens lenta ou intermitente pode indicar uma mensagem em loop ou um problema de desempenho.

Para resolver esse erro, aumente o log de diagnóstico do serviço MSExchangeTransport para coletar informações sobre componentes do categorizador.

Para obter mais informações sobre como modificar as configurações de log, consulte "Como modificar as configurações de log para MSExchangeTransport", na seção "Solucionando problemas de fluxo de mensagens e SMTP" do Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Artigo 823489 da Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Artigo 821877 da Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server"http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


A fila 'Entrega Local' está em Repetição
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-03

A ferramenta do Microsoft® Exchange Server Analyzer consulta a classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Windows®) para determinar o valor da cave StateRetry para a fila Entrega Local do SMTP.

Se o Exchange Server Analyzer verificar que o valor da chave StateRetry para a fila Entrega Local em um servidor Exchange está configurado como True, o Exchange Server Analyzer exibirá um erro.

Se uma fila estiver no status de repetição, esse status indica que ocorreu pelo menos um erro nas tentativas anteriores de processar as mensagens na fila. Você pode alterar filas no estado Repetição ou Agendado para Ativo com o comando Forçar Conexão. Isso faz com que a fila funcione como se o intervalo de repetição já tivesse passado ou se o horário agendado tivesse sido atingido. Entretanto, nem sempre esse método pode funcionar. Lembre-se de que as propriedades de uma fila podem indicar um motivo específico para que uma fila esteja em Repetição.

A fila Entrega Local contém mensagens enfileiradas no servidor Exchange para entrega local em um armazenamento de caixas de correio ou de pastas públicas do Exchange Server.

As mensagens poderão se acumular nessa fila, se o servidor Exchange não estiver aceitando mensagens para entrega local. Uma entrega de mensagens lenta ou intermitente pode indicar uma mensagem em loop ou um problema de desempenho.

Para resolver esse erro, aumente o log de diagnóstico para que o serviço MSExchangeTransport colete informações sobre componentes do categorizador.

Para obter mais informações sobre como modificar as configurações de log, consulte "Como modificar as configurações de log para MSExchangeTransport", na seção "Solucionando problemas de fluxo de mensagens e SMTP" do Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Artigo 823489 da Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Artigo 821877 da Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server"http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Falha de aceitação de mensagens
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A Ferramenta do Microsoft® Exchange Server Analyzer tenta enviar uma mensagem para a conta do Postmaster ou para uma conta definida pelo usuário para o domínio SMTP da seguinte forma:

  • O Exchange Server Analyzer abre uma conexão de soquete para o servidor SMTP. Se o Exchange Server Analyzer receber o código de resposta 220, considera-se que essa etapa foi concluída com êxito.

  • O Exchange Server Analyzer transmite o verbo de comando SMTP EHLO. Se as condições a seguir forem verdadeiras, considera-se que essa etapa foi concluída com êxito:

    • O Exchange Server Analyzer recebe uma série de códigos de resposta de 250.

    • Uma dessas respostas incluem 250-X-LINK2STATE e 250-XEXCH50.

  • O Exchange Server Analyzer transmite o verbo de comando SMTP EMAIL DE: ExMFA-MailAcceptTest@Fabrikam.com. Se o Exchange Server Analyzer receber o código de resposta 250, considera-se que essa etapa foi concluída com êxito.

  • O Exchange Server Analyzer transmite o verbo de comando SMTP RCPT DE: Postmaster (ou uma conta definida pelo usuário)@<nomededomínio>.com. Se o Exchange Server Analyzer receber o código de resposta 250, considera-se que essa etapa foi concluída com êxito.

  • O Exchange Server Analyzer transmite o verbo de comando SMTP DATA com um corpo de mensagem de exemplo terminando com um ponto final. Se o Exchange Server Analyzer receber o código de resposta 250, considera-se que essa etapa foi concluída com êxito.

Se o Exchange Server Analyzer não puder concluir todas as etapas, ele exibirá um erro. O erro indica que pode haver um problema geral de fluxo de mensagens. Os links a seguir estão listados na ordem em que você deve solucionar o problema, iniciando no nível de servidor e continuando até o nível de rede.

Para corrigir esse erro

  1. Consulte "Solucionar problemas de roteamento" no Guia de Transporte e Roteamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579) (em inglês).

  2. Consulte o artigo 324867da Base de Dados de Conhecimento Microsoft, "Suporte WebCast: Microsoft Exchange 2000 Server: Solucionando problemas de fluxo de mensagens (visitado novamente)" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867) (em inglês).

  3. Consulte o Artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489) (em inglês).

  4. Consulte a Base de Dados de Conhecimento Microsoft artigo 324759, "Suporte WebCast: Microsoft Exchange 2000 Server: Solução de problemas de DNS em transportes " (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759) (em inglês).

Para obter mais informações sobre a conta Postmaster no Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 223860, "XCON: Caixa de correio do Postmaster SMTP deve ser definida manualmente" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860).

  • 313832, "Como definir uma conta do Postmaster SMTP no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832).


Falha de aceitação de mensagens, comando BDAT
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-21

A ferramenta Microsoft® Exchange Server Analyzer transmite o verbo de comando EHLO do ESMPT (Extended Simple Mail Transfer Protocol) para a porta 25 de um servidor remoto e analisa a resposta para detectar se o servidor remoto tem suporte para o verbo ESMTP de BDAT.

Se a resposta recebida do servidor remoto para o verbo de comando BDAT não indicar um erro não-recuperável, o Exchange Server Analyzer transmitirá uma mensagem de teste para o servidor remoto e analisará a resposta, para detectar se a transferência da mensagem foi bem-sucedida.

Se não receber a cadeia de caracteres '250' como resposta esperada, o Exchange Server Analyzer exibirá um erro.

O Exchange Server 2003 usa verbos estendidos de SMTP específicos do Exchange para se comunicar com outros servidores executando o Exchange Server na organização. É mais eficiente se comunicar com verbos SMTP estendidos, específicos do Exchange, do que usar o SMTP padrão. Se o suporte para o conjunto de comandos ESMTP estiver desabilitado, o desempenho do Exchange Server pode ser prejudicado.

O verbo de comando ESMTP BDAT é uma alternativa para o comando DATA. Quando um servidor virtual SMTP responde à palavra chave EHLO com CHUNKING, ele está indicando que tem suporte para o comando BDAT e aceita mensagens em blocos. Aqui são necessários dois argumentos:

  • O primeiro argumento indica o comprimento do pacote de dados binários. Desse modo, o host SMTP não precisa verificar continuamente o final dos dados. O servidor que está recebendo conta os bytes na mensagem. Quando o tamanho da mensagem é igual ao valor enviado pelo comando BDAT, o servidor pressupõe que recebeu todos os dados da mensagem.

  • O segundo argumento indica se o pacote de dados é o último pacote da transmissão atual. O segundo argumento é opcional.

Este erro indica que, embora exista suporte para o verbo de comando ESMTP BDAT no servidor remoto, o teste de aceitação de mensagens do BDAT subseqüente falhou.

Para resolver este erro, verifique no ambiente de mensagens se há problemas ou configurações que possam estar bloqueando o verbo de comando BDAT, como:

  • Interrupções transitórias na rede

  • Proxies SMTP

  • Firewalls

  • Aplicativos

Para obter mais informações sobre como remover ou restaurar o suporte padrão para esses verbos, consulte o artigo 257569 da Base de Dados de Conhecimento Microsoft, "Como desligar os verbos ESMTP no Exchange 2000 Server e no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).

Para obter mais informações sobre como o Exchange Server usa os verbos de comando ESMTP, consulte "Como carregar corretamente o SMTP do Exchange" no Guia de Transporte e Roteamento do Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkID=71800).


Armazenamento de caixa de correio identificado como destino comum
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-04

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Exchange_Queue do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar os valores dos seguintes atributos das filas do protocolo SMTP do servidor virtual SMTP.

LinkId | Indica o identificador do link que contém a fila.
QueueId | Indica o identificador da fila.
QueueName | Indica o nome da fila.
VirtualMachine | Indica o nome da máquina virtual que contém a fila.
VirtualServerName | Indica o nome do servidor virtual em que a fila está.
MessageCount | Indica o número de mensagens na fila.

O Exchange Server Analyzer usa as informações obtidas aqui para consultar a classe Exchange_QueuedSMTPMessage do WMI em relação aos valores dos seguintes atributos das mensagens na fila:

Recipients | Indica os destinatários da mensagem.
Received | Indica o carimbo de hora recebido para a mensagem.
MessageId | Indica o identificador da mensagem em fila.
StateRetry | Indica que a transmissão é repetida para uma mensagem que não foi entregue com êxito.

Por fim, o Exchange Server Analyzer usa os dados obtidos aqui para consultar o serviço de diretório do Active Directory® em relação aos seguintes valores de cada objeto Recipient. O Exchange Server Analyzer determina se o destinatário é um usuário, um grupo de distribuição, uma pasta pública ou um armazenamento de pasta pública.

distinguishedName | Indica o nome distinto do objeto.
msExchHomeServerName | Indica o servidor em que o destinatário está hospedado.
homeMDB | Indica o armazenamento de caixa de correio do destinatário.

Se determinar que pelo menos 25% das mensagens presas na fila estão endereçadas, no campo To: ou no campo Cc:, a destinatários cujas caixas de correio estão hospedadas no mesmo armazenamento, o Exchange Server Analyzer exibirá um aviso.

Se determinar que pelo menos 50% das mensagens presas na fila estão endereçadas, no campo To: ou no campo Cc:, a destinatários cujas caixas de correio estão hospedadas no mesmo armazenamento, o Exchange Server Analyzer exibirá um erro.

Esse aviso ou erro significa que o armazenamento de caixa de correio identificado é um destino comum para mensagens que estão presas em uma fila SMTP.

Para resolver esse problema, investigue o armazenamento de caixa de correio como mostrado a seguir para verificar se há problemas de configuração ou outras anomalias que poderão fazer com que as mensagens sejam colocadas em fila.

  • Verifique se os atributos de objeto de armazenamento estão corretamente definidos e contêm os valores corretos no Active Directory.

  • Reveja as permissões do Active Directory do objeto de armazenamento para obter as configurações corretas.

  • Se o armazenamento de caixa de correio for o armazenamento de um objeto de usuário de uso especial, isto é, um destinatário de Registro no Diário designado, reveja as configurações do serviço ou os componentes aos quais o objeto de usuário está relacionado para obter a configuração correta.

  • Procure possíveis emails comerciais não solicitados, ou spams, ou ataques de vírus contra os destinatários de armazenamento.

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Guia de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875) (pode estar em inglês).

  • Artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489). (pode estar em inglês).


A fila 'Mensagens com um destino inacessível' contém mensagens
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-04

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor das propriedades TypeCurrentlyUnreachable, LinkName e NumberofMessages para as filas do Protocolo SMTP em um servidor.

A propriedade TypeCurrentlyUnreachable, quando é True, especifica que o link (fila do Exchange) retém mensagens para destinos que no momento não podem ser obtidos.

A propriedade LinkName especifica o nome do link.

A propriedade NumberOfMessages especifica o número de mensagens que estão aguardando transmissão no link.

Se o Exchange Server Analyzer determinar que a fila do protocolo SMTP Mensagens com um destino inacessível contém todas as mensagens, o Exchange Server Analyzer exibirá um erro.

Esse erro indica que há mensagens na fila que não podem chegar ao servidor de destino pretendido. Por exemplo, o Exchange não pode determinar uma rota ou um conector para o destino final. Ou então, todas as rotas ou conectores disponíveis são marcados, conforme mostrado.

Para resolver esse erro, execute as seguintes etapas:

  • Determine se as mensagens da fila Mensagens com um destino inacessível são legítimas.

  • Reveja a orientação de erro e os links fornecidos pelo Exchange Server Analyzer.

  • Siga a orientação em "Para obter mais informações", posteriormente neste tópico.

Para obter mais informações

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).


A fila 'Mensagens com um destino inacessível' está congelada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Windows®) para determinar o valor da chave StateFrozen para a fila SMTP Mensagens com um destino inacessível.

Se o Exchange Server Analyzer detectar que o valor da chave StateFrozen da fila Mensagens com um destino inacessível em um servidor Exchange está definido como True, a ferramenta exibirá um erro.

Uma fila congelada significa que as sessões de transporte para essa fila foram paradas. Uma fila congelada impede mensagens de saída, mas novas mensagens podem ser adicionadas.

A fila Mensagens com um destino inacessível contém mensagens que não podem chegar ao servidor de destino pretendido. Por exemplo, o Exchange não pode determinar uma rota ou um conector para o destino final. Ou então, todas as rotas ou conectores disponíveis são marcados, conforme mostrado. As mensagens poderão se acumular nesta fila se qualquer uma das seguintes condições for verdadeira:

  • Nenhuma rota existe para entrega de mensagem.

  • Um conector ou uma fila de entrega remota do Exchange não está disponível.

  • Novas mensagens são movidas para essa fila quando um conector ou uma fila de entrega remota do Exchange está em um status de repetição e nenhuma rota disponível alternativa existe para o conector ou o destino remoto.

Para determinar esse erro, altere manualmente o estado da conexão, usando o menu de atalho em cada fila de link. Quando você usa o comando Forçar Conexão para alterar um estado de fila para Ativo, você imediatamente habilita uma conexão que envia as mensagens dessa fila. Se o erro persistir, eleve o nível de log dos diagnósticos do Mecanismo de Enfileiramento, conforme descrito em "Para obter mais informações", posteriormente neste tópico.

Para obter mais informações

Para obter mais informações sobre como modificar configurações de log, consulte "Como modificar as configurações de log para MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Manual de Transporte e Roteamento do Exchange (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 da Base de Dados de Conhecimento Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 da Base de Dados de Conhecimento Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


A fila 'Mensagens com um destino inacessível' está em repetição
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Windows®) para determinar o valor da chave StateRetry para a fila SMTP Mensagens com um destino inacessível.

Se o Exchange Server Analyzer detectar que o valor da chave StateRetry da fila Mensagens com um destino inacessível em um servidor Exchange estiver definido como True, a ferramenta exibirá um erro.

Se uma fila estiver no status de repetição, esse status indicará que ocorreu pelo menos um erro nas tentativas anteriores de processar as mensagens da fila.

Observação:
As propriedades de uma fila podem indicar um motivo específico para ela estar no status de repetição.

A fila Mensagens com um destino inacessível contém mensagens que não podem chegar ao servidor de destino pretendido. Por exemplo, o Exchange não pode determinar uma rota ou um conector para o destino final. Ou então, todas as rotas ou conectores disponíveis são marcados, conforme mostrado. As mensagens poderão se acumular nesta fila se qualquer uma das seguintes condições for verdadeira:

  • Nenhuma rota existe para entrega de mensagem.

  • Um conector ou uma fila de entrega remota do Exchange não está disponível.

  • Novas mensagens são movidas para essa fila quando um conector ou uma fila de entrega remota do Exchange está em um status de repetição e nenhuma rota disponível alternativa existe para o conector ou o destino remoto.

Para resolver esse erro, altere o estado Repetição para Ativo com o comando Forçar Conexão. Isso faz com que a fila funcione como se o intervalo de repetição tivesse sido ultrapassado. Entretanto, nem sempre esse método pode funcionar. Se o erro persistir, eleve o nível de log dos diagnósticos do Mecanismo de Enfileiramento, conforme descrito em "Para obter mais informações", posteriormente neste tópico.

Para obter mais informações

Para obter mais informações sobre como modificar configurações de log, consulte "Como modificar as configurações de log para MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Manual de Transporte e Roteamento do Exchange (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 da Base de Dados de Conhecimento Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 da Base de Dados de Conhecimento Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Caixas de correio com restrições de entrega do grupo de distribuição definidas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-21

A ferramenta Microsoft® Exchange Server Analyzer consulta os seguintes atributos de cada objeto usuário em todos os domínios encontrados no serviço de diretório do Active Directory® para detectar se alguma caixa de correio nos domínios possui restrições de entrega definidas, baseadas na associação do grupo de distribuição:

dLMemDefault | Controla se as mensagens são aceitas ou rejeitadas, por padrão. Quando definidas com a configuração padrão 1, as mensagens de todos são aceitas.
dLMemRejectPerms | Contém os nomes de domínio (DNs) de listas de distribuição (DL) cujos membros não podem enviar para este destinatário
dLMemSubmitPerms | Contém os nomes de domínio (DNs) de listas de distribuição (DL) cujos membros podem enviar para este destinatário.

Ao detectar a existência de caixas de correio no domínio, que possuem restrições de entrega definidas, com base em associação de grupos de distribuição, o Exchange Server Analyzer exibirá um aviso.

Este aviso indica que as restrições da entrega baseadas em associação de grupos de distribuição podem afetar o desempenho do fluxo de mensagens do Exchange.

Por padrão, o categorizador expande recursivamente os grupos de distribuição e verifica as restrições de cada mensagem que passa pelo sistema.

Ao enviar uma mensagem para um usuário que aceita ou recusa mensagens de um grupo de distribuição, o categorizador de mensagens precisa expandir a associação do grupo de distribuição, obter a lista completa de DNs dos membros e comparar a lista de DNs com os DNs do remetente da lista. Uma operação de acesso ou de negação ocorre quando um DN consta em ambas as listas. Se um grupo de distribuição estiver aninhado em outro grupo de distribuição, a distribuição aninhada também será expandida.

Para tratar desse aviso:

  • Examine os usuários cujas restrições de entrega do grupo de distribuição estão definidas e remova as restrições desnecessárias.

  • Configure caixas de correio individuais e não grupos de distribuição para restrições de entrega, como citado no artigo 812298 da Base de Dados de Conhecimento Microsoft, "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Para os servidores executando o Exchange Server 2003 Service Pack 2 (SP2) ou versão posterior, considere a implementação de verificação de restrição não-hierárquica. Para os servidores executando versões do Exchange anteriores ao Exchange 2003 SP2, considere atualizar para o Exchange 2003 SP2.

Para obter mais informações

Para obter mais informações sobre a verificação de restrição não-hierárquica, consulte Considere a verificação da restrição não hierárquica.

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 895407 "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407) (em inglês).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949) (em inglês).

  • 812298 "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298) (em inglês).


O tamanho máximo da mensagem de entrada não foi definido
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-01-05

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo delivContLength de configurações globais localizado em:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Se o Exchange Server Analyzer verificar que o valor do atributo delivContLength é menor do que 1, será exibido um erro.

Esse erro indica que não foi definido um limite máximo de tamanho de mensagem de entrada. Com base na largura de banda da rede e requisitos do usuário em sua organização, você pode limitar o tamanho da mensagem. No Exchange 2000 Server e no Exchange Server 2007, não há limite de tamanho de mensagem padrão. No Exchange Server 2003, o limite de tamanho padrão para enviar e receber mensagens é 10.240 KB. Esse limite de tamanho padrão do Exchange Server 2003 aplica-se a novas instalações e atualizações do Exchange 2000 Server nas quais não foi definido nenhum limite de tamanho de mensagens.

Você pode conservar recursos do sistema definindo limites de tamanho de mensagens que impeçam que usuários enviem e recebam mensagens de email grandes. Isso ajudará a limitar o tráfego da rede, economizar espaço em disco e melhorar o desempenho geral da rede. No Exchange 2000 Server e no Exchange Server 2003, você pode usar a guia Padrões em Propriedades de Entrega de Mensagens das Configurações Globais para especificar restrições de entrega para mensagens de entrada e saída. Para definir o tamanho máximo de mensagens individuais, selecione Máximo (KB) e, na caixa de texto, digite um tamanho máximo, em quilobytes (KB). Se não desejar limitar o tamanho de mensagens, selecione Sem limite. Os remetentes da organização receberão uma notificação de falha na entrega se tentarem enviar uma mensagem para um usuário que esteja além do limite de tamanho especificado. Dependendo das configurações de notificação de falha na entrega que você definir em Formatos de Mensagem da Internet, remetentes externos poderão não receber uma notificação de falha na entrega.

No Exchange Server 2007, você pode usar o Shell de Gerenciamento do Exchange para definir o parâmetro TransportConfig MaxReceiveSize da organização do Exchange.

Recomendamos que você defina o limite máximo de tamanho de mensagem para não mais que 10 MB. No entanto, se você precisar de um limite de tamanho de mensagem maior para que mensagens com anexos grandes sejam enviadas através da organização do Exchange, você pode aumentar o limite máximo de tamanho de mensagem de entrada para 30 MB. A definição de um limite de tamanho de mensagem superior a 30 MB pode reduzir o desempenho da rede e até mesmo tornar o sistema mais vulnerável a ataques contra a segurança.

Para definir os limites de tamanho da mensagem para o Exchange 2000 Server e o Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, expanda Configurações Globais, clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  2. Na caixa de diálogo Propriedades de Entrega de Mensagens, na guia Padrões, selecione a opção Limite de tamanho de mensagem de recebimento e digite o limite de tamanho que deseja.

Para definir os limites de tamanho da mensagem para o Exchange Server 2007

  1. No Shell de Gerenciamento do Exchange, execute o seguinte comando, onde <tamanho> é inserido como padrão de "ilimitado", ou o tamanho em B (Bytes), KB (quilobytes) ou MB (megabytes) em um intervalo de 0 a 2147483647 bytes:
Código da Cópia
Set-TransportConfig -MaxReceiveSize <size>

Por exemplo, para definir o tamanho máximo de mensagem que pode ser recebido por destinatários na Organização do Exchange como 10 Megabytes, insira:

Código da Cópia
Set-TransportConfig -MaxReceiveSize 10MB

Para definir o tamanho máximo de mensagem que pode ser recebido por destinatários na Organização do Exchange como o valor padrão de ilimitado, insira:

Código da Cópia
Set-TransportConfig -MaxReceiveSize unlimited
  • Para obter mais informações sobre como definir limites de tamanho de mensagens no Exchange 2000 Server e no Exchange Server 2003, consulte o artigo da Base de Dados de Conhecimento da Microsoft, "Definir Limites de Tamanho para Mensagens" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

  • Para obter mais informações sobre o cmdlet TransportConfig para Exchange Server 2007, consulte "Set-TransportConfig" na Referência Técnica do Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237) (pode estar em inglês).

  • Para obter mais informações sobre Formatos de Mensagens da Internet, consulte "Configurando diretivas SMTP para controlar a formatação de mensagens de saída e as respostas automáticas", no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617) (em inglês).


Tamanho máximo da mensagem de entrada está definido muito alto (>30 MB)
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-02-27

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo delivContLength de configurações globais localizado em:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Se o Exchange Server Analyzer verificar que o valor do atributo delivContLength é superior a 30720, será exibido um erro.

Esse erro indica que um limite máximo de tamanho de mensagem de entrada está definido com um valor superior a 30 megabytes (MB). No Exchange 2000 Server e no Exchange Server 2007, não há um limite de tamanho de mensagem padrão. No Exchange Server 2003, o limite de tamanho padrão para enviar e receber mensagens é 10.240 KB. Esse limite de tamanho padrão aplica-se a novas instalações e atualizações do Exchange 2000 Server nas quais não foi definido nenhum limite de tamanho de mensagens.

Você pode conservar recursos do sistema definindo limites de tamanho de mensagens que impeçam que usuários enviem e recebam mensagens de email grandes. Isso ajudará a limitar o tráfego da rede, economizar espaço em disco e melhorar o desempenho geral da rede. Para o Exchange 2000 Server e o Exchange Server 2003, você pode usar a guia Padrões em Propriedades de Entrega de Mensagens de suas Configurações Globais para especificar restrições de entrega para mensagens de entrada e saída. Para definir o tamanho máximo de mensagens individuais, selecione Máximo (KB) e, na caixa de texto, digite um tamanho máximo, em quilobytes (KB). Se não desejar limitar o tamanho de mensagens, selecione Sem limite. Os remetentes em sua organização receberão uma notificação de falha na entrega se eles tentarem enviar uma mensagem para um usuário que vá além do limite de tamanho especificado. Dependendo das configurações de notificação de falha na entrega que você definir em Formatos de Mensagem da Internet, remetentes externos poderão não receber uma notificação de falha na entrega.

No Exchange Server 2007, você pode usar o Shell de Gerenciamento do Exchange para definir o parâmetro TransportConfig MaxSendSize da organização do Exchange.

Recomendamos que você defina o limite máximo de tamanho de mensagem para não mais que 30 MB. Entretanto, se você precisar de um limite de tamanho de mensagem maior para que mensagens com anexos grandes sejam enviadas pela organização do Exchange, convém aumentar o limite máximo de tamanho de mensagem de entrada para mais de 30 MB. A definição de um limite de tamanho de mensagem superior a 30 MB pode reduzir o desempenho da rede e, até mesmo, tornar o sistema mais vulnerável a ataques de segurança.

Importante:
Embora possam parecer semelhantes, os resultados das configurações a seguir são extremamente diferentes em ambientes Exchange 2000 Server/Exchange Server 2003 puros e em ambientes Exchange Server 2007.

Definir as restrições de tamanho de mensagem de envio e recebimento como um valor 0 nas Configurações Globais de um usuário habilitado para caixa de correio, em um ambiente Exchange 2000 Server/Exchange Server 2003 puro, tem o efeito de remover inteiramente as restrições de tamanho de mensagem.

Definir os parâmetros TransportConfig -MaxSendSize e TransportConfig -MaxreceiveSize como um valor 0 em um sistema Exchange 2007 puro tem o efeito de restringir o envio de mensagens de qualquer tamanho.

Para definir os limites de tamanho da mensagem para o Exchange 2000 Server e o Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, expanda Configurações Globais, clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  2. Na caixa de diálogo Propriedades de Entrega de Mensagens, na guia Padrões, selecione a opção Limite de tamanho de mensagem de recebimento e digite o limite de tamanho que deseja.

Para definir os limites de tamanho da mensagem para o Exchange Server 2007

  1. No Shell de Gerenciamento do Exchange, execute o seguinte comando, em que <size> é inserido como o padrão de "ilimitado" ou o tamanho em B (Bytes), KB (Quilobytes) ou MB (Megabytes) em um intervalo de 0 a 2.147.483.647 bytes:
Código da Cópia
Set-TransportConfig -MaxReceiveSize <size>

Por exemplo, para definir o tamanho máximo de mensagem que pode ser recebido por destinatários na Organização do Exchange como 10 Megabytes, insira:

Código da Cópia
Set-TransportConfig -MaxReceiveSize 10MB

Para definir o tamanho máximo de mensagem que pode ser recebido por destinatários na Organização do Exchange como o valor padrão de ilimitado, insira:

Código da Cópia
Set-TransportConfig -MaxReceiveSize unlimited
  • Para obter mais informações sobre como definir limites de tamanho de mensagens no Exchange 2000 Server e no Exchange Server 2003, consulte o artigo 322679 da Base de Dados de Conhecimento Microsoft, "Definir limites de tamanho para mensagens" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Para obter mais informações sobre o cmdlet TransportConfig para Exchange Server 2007, consulte "Set-TransportConfig" na Referência Técnica do Exchange Server 2007 (em inglês) (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Para obter mais informações sobre Formatos de Mensagens da Internet, consulte "Configurando diretivas SMTP para controlar a formatação de email de saída e respostas automáticas" no Guia de Administração do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47617).


Tamanho máximo da mensagem de entrada pode estar definido muito baixo (<1 MB).
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-01-05

O Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo delivContLength de configurações globais localizado em:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Se o Exchange Server Analyzer verificar que o valor do atributo delivContLength é menor que 1024, porém maior que 0, um erro será exibido.

Esse erro indica que o limite máximo de tamanho de mensagem de entrada está definido como menos de 1 megabyte (MB). Um valor tão baixo pode impedir que o Exchange Server aceite algumas mensagens enviadas para sua organização. No Exchange 2000 Server e no Exchange Server 2007, não há um limite de tamanho de mensagem padrão. No Exchange Server 2003, o limite de tamanho padrão para enviar e receber mensagens é 10.240 KB. Esse limite de tamanho padrão aplica-se a novas instalações e atualizações do Exchange 2000 Server nas quais não foi definido nenhum limite de tamanho de mensagens.

Você pode conservar recursos do sistema definindo limites de tamanho de mensagens que impeçam que usuários enviem e recebam mensagens de email grandes. Isso ajudará a limitar o tráfego da rede, economizar espaço em disco e melhorar o desempenho geral da rede. Para o Exchange 2000 Server e o Exchange Server 2003, você pode usar a guia Padrões em Propriedades de Entrega de Mensagens de suas Configurações Globais para especificar restrições de entrega para mensagens de entrada e saída. Para definir o tamanho máximo de mensagens individuais, selecione Máximo (KB) e, na caixa de texto, digite um tamanho máximo, em quilobytes (KB). Se não desejar limitar o tamanho de mensagens, selecione Sem limite. Remetentes em sua organização receberão uma notificação de falha na entrega se tentarem enviar uma mensagem para um usuário que exceder o limite de tamanho especificado. Dependendo das configurações de notificação de falha na entrega que você definir em Formatos de Mensagem da Internet, remetentes externos poderão não receber uma notificação de falha na entrega.

No Exchange Server 2007, você pode usar o Shell de Gerenciamento do Exchange para definir o parâmetro TransportConfig MaxSendSize da organização do Exchange.

Recomendamos que você defina o limite máximo de tamanho de mensagem para não mais que 10 MB. No entanto, se você precisar de um limite de tamanho de mensagem maior para que mensagens com anexos grandes sejam enviadas através da organização do Exchange, você pode aumentar o limite máximo de tamanho de mensagem de entrada para 30 MB. A definição de um limite de tamanho de mensagem superior a 30 MB pode reduzir o desempenho da rede e, até mesmo, tornar o sistema mais vulnerável a ataques de segurança.

Para definir os limites de tamanho da mensagem para o Exchange 2000 Server e o Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, expanda Configurações Globais, clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  2. Na caixa de diálogo Propriedades de Entrega de Mensagens, na guia Padrões, selecione a opção Limite de tamanho de mensagens recebidas e digite o limite de tamanho desejado.

Para definir os limites de tamanho da mensagem para o Exchange Server 2007

  1. No Shell de Gerenciamento do Exchange, execute o seguinte comando, em que <size> é inserido como padrão de "ilimitado" ou o tamanho em B (bytes), KB (quilobytes) ou MB (megabytes) em um intervalo de 0 a 2147483647 bytes:
Código da Cópia
Set-TransportConfig -MaxReceiveSize <size>

Por exemplo, para definir o tamanho máximo de mensagem que pode ser recebido por destinatários na Organização do Exchange como 10 megabytes, insira:

Código da Cópia
Set-TransportConfig -MaxReceiveSize 10MB

Para definir o tamanho máximo de mensagem que pode ser recebido por destinatários na Organização do Exchange com o valor padrão de ilimitado, insira:

Código da Cópia
Set-TransportConfig -MaxReceiveSize unlimited
  • Para obter mais informações sobre como definir limites de tamanho de mensagens no Exchange 2000 Server e no Exchange Server 2003, consulte o artigo 322679 da Base de Dados de Conhecimento da Microsoft, "Definir limites de tamanho para mensagens" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Para obter mais informações sobre o cmdlet TransportConfig para Exchange Server 2007, consulte "Set-TransportConfig" na Referência Técnica do Exchange Server 2007 (em inglês) (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Para obter mais informações sobre Formatos de Mensagens da Internet, consulte "Configurando diretivas SMTP para controlar a formatação de email de saída e respostas automáticas" no Guia de administração do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47617).


MaxDSNSize não definido
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o tamanho máximo das mensagens de notificação de status de entrega foi definido:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

O Analisador do Exchange Server também consulta o serviço Active Directory® para conhecer o valor do atributo serialNumber de todos os objetos da classe msExchExchangeServer. Se o valor da cadeia de caracteres incluir "Version 5.5", o computador está executando o Microsoft Exchange Server 5.5. Se o valor da cadeia de caracteres incluir "Version 6.0", o computador está executando o Microsoft Exchange 2000 Server. Se o valor da cadeia de caracteres incluir "Version 6.5", o computador está executando o Microsoft Exchange Server 2003.

Se o Exchange Server Analyzer detectar que o valor do Registro MaxDSNSize não existe em um computador que está executando o Exchange 2000 Server ou Exchange Server 2003, será exibido um aviso.

O valor do Registro MaxDSNSize é opcional no Exchange Server que limita o tamanho das notificações de status de entrega. Esta opção configura o Exchange para remover os anexos se não for possível entregar uma mensagem. Se você adicionar esse valor do Registro, será recomendável utilizar um valor de 10240000 bytes (10 megabytes).

Observação:
O valor do Registro MaxDSNSize foi introduzido no Service Pack 2 (SP2) do Exchange 2000 Server e, portanto, exige o Exchange 2000 Server SP2 ou versões posteriores para funcionar. Além disso, no Service Pack 1 do Exchange Server 2003 e versões posteriores, é utilizado um valor de 10 megabytes na ausência do valor do Registro MaxDSNSize. Se você preferir, poderá adicionar o valor do Registro MaxDSNSize para substituir esse comportamento padrão.

Se você habilitar essa opção, você poderá salvar recursos de rede e de servidor. Contudo, há desvantagens nessa implementação da eliminação de anexos SMTP. Se você habilitar essa opção para remover os anexos da notificação de falha na entrega (NDR), os detalhes necessários para exibir a notificação no painel de visualização também serão removidos e o originador da mensagem não poderá usar a opção Enviar Novamente. Se o remetente da mensagem tentar usar a opção Enviar Novamente a partir de uma Notificação de Falha na Entrega, ele receberá a seguinte mensagem de erro: Não é possível reenviar a mensagem. O relatório de entregas não efetuadas não contém informações suficientes sobre a mensagem original. Para reenviar a mensagem, abra-a em sua pasta Itens Enviados, clique no menu Ações e em "Reenviar esta mensagem".

No entanto, o remetente da mensagem não consegue reenviar a mensagem, mesmo usando o método da mensagem de erro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\SMTPSvc

  3. Clique com o botão direito em SMTPSvc e selecione Nova | Chave. Atribua o nome Queuing à nova chave e deixe a classe em branco.

  4. Clique com o botão direito em Queuing e selecione Novo | Valor DWORD. Atribua o novo valor MaxDSNSize.

  5. No painel da direita, clique duas vezes no valor do Registro MaxDSNSize e digite o limite de tamanho (em bytes) desejado no campo de dados Valor. As mensagens acima desse valor que gerarem uma notificação de falha na entrega não retornarão os anexos ou propriedades de mensagens completas.

  6. Feche o Editor do Registro e reinicie o serviço Simple Mail Transfer Protocol (SMTP) para que a alteração seja aplicada.

Para obter mais informações sobre a definição do Registro MaxDSNSize, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 308303, "XCON: Opção para remover anexos de mensagens que geram uma notificação de falha na entrega" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303)

  • 323484, "XCON: Descrição do formato de mensagem da Internet com diversas partes/relatórios no Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484)


O tamanho máximo da mensagem de saída não foi definido
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-12-04

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar o valor do atributo submissionContLength das configurações globais localizado em:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Se o Exchange Server Analyzer verificar que o valor para o atributo submissionContLength é menor que 1, será exibido um erro.

Esse erro indica que o limite máximo de tamanho da mensagem de saída não foi definido. Com base na largura de banda da rede e requisitos do usuário em sua organização, você pode limitar o tamanho da mensagem. No Exchange 2000 Server e no Exchange Server 2007, não há um limite de tamanho de mensagem padrão. No Exchange Server 2003, o limite de tamanho padrão para enviar e receber mensagens é 10.240 KB. Esse limite de tamanho padrão aplica-se a novas instalações e atualizações do Exchange 2000 Server nas quais não foi definido nenhum limite de tamanho de mensagens.

Você pode conservar recursos do sistema definindo limites de tamanho de mensagens que impeçam que usuários enviem e recebam mensagens de email grandes. Isso ajudará a limitar o tráfego da rede, economizar espaço em disco e melhorar o desempenho geral da rede. Para o Exchange 2000 Server e Exchange Server 2003, você pode usar a guia Padrões em Propriedades de Entrega de Mensagens de suas Configurações Globais para especificar restrições de entrega para mensagens de entrada e saída. Para definir o tamanho máximo de mensagens individuais, selecione Máximo (KB) e, na caixa de texto, digite um tamanho máximo, em quilobytes (KB). Se não desejar limitar o tamanho de mensagens, selecione Sem limite. Os remetentes da organização receberão uma notificação de falha na entrega se tentarem enviar uma mensagem para um usuário que esteja além do limite de tamanho especificado. Dependendo das configurações de notificação de falha na entrega que você definir em Formatos de Mensagem da Internet, remetentes externos poderão ou não receber uma notificação de falha na entrega.

Para o Exchange Server 2007, você pode usar o Shell de Gerenciamento do Exchange para definir o parâmetro TransportConfig MaxSendSize da organização do Exchange.

É recomendável que você defina o limite de tamanho máximo de mensagem para não mais de 10 MB. Entretanto, se você precisar de um limite de tamanho de mensagem maior com anexos grandes para serem enviados pela organização do Exchange, poderá aumentar o limite de tamanho máximo de mensagem de saída para 30 MB. A definição de um limite de tamanho de mensagem superior a 30 MB pode reduzir o desempenho da sua rede e, até mesmo, tornar seu sistema mais vulnerável a ataques de segurança.

Para definir os limites de tamanho da mensagem para o Exchange 2000 Server e o Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, expanda Configurações Globais, clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  2. Na caixa de diálogo Propriedades de Entrega de Mensagens, na guia Padrões, selecione a opção Limite da mensagem de envio e digite o limite de tamanho desejado.

Para definir os limites de tamanho da mensagem para o Exchange Server 2007

  1. No Shell de Gerenciamento do Exchange, execute o seguinte comando, em que <size> é inserido como o padrão de "ilimitado" ou o tamanho em B (Bytes), KB (Quilobytes) ou MB (Megabytes) em um intervalo de 0 a 2.147.483.647 bytes:
Código da Cópia
Set-TransportConfig -MaxSendSize <size>

Por exemplo, para definir o tamanho máximo de mensagem que pode ser enviado por usuários na Organização do Exchange como 10 Megabytes, insira:

Código da Cópia
Set-TransportConfig -MaxSendSize 10MB

Para definir o tamanho máximo de mensagem que pode ser enviado por usuários na Organização do Exchange como o valor padrão de ilimitado, insira:

Código da Cópia
Set-TransportConfig -MaxSendSize unlimited
  • Para obter mais detalhes sobre como definir limites de tamanho de mensagens para o Exchange 2000 Server e o Exchange Server 2003, consulte o artigo 322679 da Base de Dados de Conhecimento Microsoft, "Definir limites de tamanho para mensagens" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

  • Para obter mais informações sobre o cmdlet TransportConfig para Exchange Server 2007, consulte "Set-TransportConfig" na Referência Técnica do Exchange Server 2007 (em inglês) (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Para obter mais informações sobre Formatos de Mensagem da Internet, consulte o tópico "Configuring SMTP Policies to Control Outbound Mail Formatting and Automatic Responses" no Exchange Server 2003 Administration Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47617).


Tamanho máximo da mensagem de saída está definido muito alto (>30 MB)
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-12-04

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar o valor do atributo submissionContLength das configurações globais localizado em:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Se o Exchange Server Analyzer detectar que o valor do atributo submissionContLength é maior do que 30.720, um erro será exibido.

Esse erro indica que o limite máximo de tamanho de mensagem de saída foi definido como um valor superior a 30 MB (megabytes). Com base na largura de banda da rede e requisitos do usuário na sua organização, você pode limitar o tamanho da mensagem para mensagens menores. No Exchange 2000 Server e no Exchange Server 2007, não há limite de tamanho de mensagem padrão. No Exchange Server 2003, o limite de tamanho padrão para enviar e receber mensagens é 10.240 KB. Esse limite de tamanho padrão aplica-se a novas instalações e atualizações do Exchange 2000 Server nas quais não foi definido nenhum limite de tamanho de mensagens.

Você pode conservar recursos do sistema definindo limites de tamanho de mensagens que impeçam que usuários enviem e recebam mensagens de email grandes. Isso irá ajudar a limitar o tráfego na rede, economizar espaço em disco e melhorar o desempenho geral da rede. No Exchange 2000 Server e no Exchange Server 2003, você pode usar a guia Padrões em Propriedades de Entrega de Mensagens das Configurações Globais para especificar restrições de entrega para mensagens de entrada e saída. Para definir o tamanho máximo de mensagens individuais, selecione Máximo (KB) e, na caixa de texto, digite um tamanho máximo, em quilobytes (KB). Se não desejar limitar o tamanho de mensagens, selecione Sem limite. Remetentes em sua organização receberão uma notificação de falha na entrega se tentarem enviar uma mensagem para um usuário que exceder o limite de tamanho especificado. Dependendo das configurações de notificação de falha na entrega que você definir em Formatos de Mensagem da Internet, remetentes externos poderão ou não receber uma notificação de falha na entrega.

No Exchange Server 2007, você pode usar o Shell de Gerenciamento do Exchange para definir o parâmetro TransportConfig MaxSendSize da organização do Exchange.

É recomendável que você defina o limite de tamanho máximo de mensagem para não mais de 10 MB. Entretanto, se você precisar de um limite de tamanho de mensagem maior com anexos grandes para serem enviados pela organização do Exchange, poderá aumentar o limite de tamanho máximo de mensagem de saída para 30 MB. A definição de um limite de tamanho de mensagem superior a 30 MB pode reduzir o desempenho da sua rede e, até mesmo, tornar seu sistema mais vulnerável a ataques de segurança.

Para definir os limites de tamanho da mensagem para o Exchange 2000 Server e o Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, expanda Configurações Globais, clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  2. Na caixa de diálogo Propriedades de Entrega de Mensagens, na guia Padrões, selecione a opção Limite da mensagem de envio e digite o limite de tamanho desejado.

Para definir os limites de tamanho da mensagem para o Exchange Server 2007

  1. No Shell de Gerenciamento do Exchange, execute o seguinte comando, onde <tamanho> é inserido como padrão de "ilimitado", ou o tamanho em B (Bytes), KB (quilobytes) ou MB (megabytes) em um intervalo de 0 a 2147483647 bytes:
Código da Cópia
Set-TransportConfig -MaxSendSize <size>

Por exemplo, para definir o tamanho máximo de mensagem que pode ser enviado por usuários na Organização do Exchange como 10 Megabytes, insira:

Código da Cópia
Set-TransportConfig -MaxSendSize 10MB

Para definir o tamanho máximo de mensagem que pode ser enviado por usuários na Organização do Exchange como o valor padrão de ilimitado, insira:

Código da Cópia
Set-TransportConfig -MaxSendSize unlimited
  • Para obter mais detalhes sobre como definir limites de tamanho de mensagens para o Exchange 2000 Server e o Exchange Server 2003, consulte o artigo da Base de Dados de Conhecimento Microsoft, "Definir limites de tamanho para mensagens" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679) (pode estar em inglês).

Para obter mais informações sobre o cmdlet TransportConfig para Exchange Server 2007, consulte "Set-TransportConfig" na Referência Técnica do Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237) (pode estar em inglês).

  • Para obter mais informações sobre Formatos de Mensagem da Internet, consulte o tópico "Configurando diretivas de SMTP para controlar a formatação de mensagens de saída e respostas automáticas" no Guia de Administração do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=21769).


Tamanho máximo da mensagem de saída pode estar definido muito baixo.
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-12-04

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar o valor do atributo submissionContLength das configurações globais localizado em:

CN=Configuração, CN=Serviços, CN=Microsoft Exchange, CN= OrganizationName , CN=Configurações Globais, CN=Entrega de Mensagens

Se o Exchange Server Analyzer verificar que o valor para o atributo submissionContLength é menor que 1024, porém maior que 0, será exibido um aviso.

Esse aviso indica que o limite máximo de tamanho da mensagem de saída foi definido como menos de 1 megabyte (MB). Com base na largura de banda de rede e nos requisitos de usuário de sua organização, talvez você deseje aumentar o tamanho das mensagens para permitir mensagens maiores. No Exchange 2000 Server e no Exchange Server 2007, não há um limite de tamanho de mensagem padrão. No Exchange Server 2003, o limite de tamanho padrão para enviar e receber mensagens é 10.240 KB. Esse limite de tamanho padrão aplica-se a novas instalações e atualizações do Exchange 2000 Server nas quais não foi definido nenhum limite de tamanho de mensagens.

Você pode conservar recursos do sistema definindo limites de tamanho de mensagens que impeçam que usuários enviem e recebam mensagens de email grandes. Isso ajudará a limitar o tráfego da rede, economizar espaço em disco e melhorar o desempenho geral da rede. Para o Exchange 2000 Server e o Exchange Server 2003, você pode usar a guia Padrões em Propriedades de Entrega de Mensagens de suas Configurações Globais para especificar restrições de entrega para mensagens de entrada e saída. Para definir o tamanho máximo de mensagens individuais, selecione Máximo (KB) e, na caixa de texto, digite um tamanho máximo, em quilobytes (KB). Se não desejar limitar o tamanho de mensagens, selecione Sem limite. Os remetentes em sua organização receberão uma notificação de falha na entrega se eles tentarem enviar uma mensagem para um usuário que vá além do limite de tamanho especificado. Dependendo das configurações de notificação de falha na entrega que você definir em Formatos de Mensagem da Internet, remetentes externos poderão ou não receber uma notificação de falha na entrega.

Para o Exchange Server 2007, você pode usar o Shell de Gerenciamento do Exchange para definir o parâmetro TransportConfig MaxSendSize da organização do Exchange.

É recomendável que você defina o limite de tamanho máximo de mensagem para não mais de 30 MB. Entretanto, se você precisar de um limite de tamanho de mensagem maior com anexos grandes para serem enviados pela organização do Exchange, poderá aumentar o limite de tamanho máximo de mensagem de saída para mais de 30 MB. A definição de um limite de tamanho de mensagem superior a 30 MB pode reduzir o desempenho da sua rede e, até mesmo, tornar seu sistema mais vulnerável a ataques de segurança.

Para definir os limites de tamanho da mensagem para o Exchange 2000 Server e o Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, expanda Configurações Globais, clique com o botão direito em Entrega de Mensagens e clique em Propriedades.

  2. Na caixa de diálogo Propriedades de Entrega de Mensagens, na guia Padrões, selecione a opção Limite da mensagem de envio e digite o limite de tamanho desejado.

Para definir os limites de tamanho da mensagem para o Exchange Server 2007

  1. No Shell de Gerenciamento do Exchange, execute o seguinte comando, em que <size> é inserido como o padrão de "ilimitado" ou o tamanho em B (Bytes), KB (Quilobytes) ou MB (Megabytes) em um intervalo de 0 a 2.147.483.647 bytes:
Código da Cópia
Set-TransportConfig -MaxSendSize <size>

Por exemplo, para definir o tamanho máximo de mensagem que pode ser enviado por usuários na Organização do Exchange como 10 Megabytes, insira:

Código da Cópia
Set-TransportConfig -MaxSendSize 10MB

Para definir o tamanho máximo de mensagem que pode ser enviado por usuários na Organização do Exchange como o valor padrão de ilimitado, insira:

Código da Cópia
Set-TransportConfig -MaxSendSize unlimited
  • Para obter mais detalhes sobre como definir limites de tamanho de mensagens para o Exchange 2000 Server e o Exchange Server 2003, consulte o artigo 322679 da Base de Dados de Conhecimento Microsoft, "Definir limites de tamanho para mensagens" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Para obter mais informações sobre o cmdlet TransportConfig para Exchange Server 2007, consulte "Set-TransportConfig" na Referência Técnica do Exchange Server 2007 (em inglês) (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Para obter mais informações sobre Formatos de Mensagem da Internet, consulte o tópico "Configuring SMTP Policies to Control Outbound Mail Formatting and Automatic Responses" no Exchange Server 2003 Administration Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47617).


O registro no diário somente para mensagens está habilitado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-01-10

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo msExchMessageJournalRecipient foi configurado para copiar emails para a caixa de correio de um destinatário. O atributo msExchMessageJournalRecipient é um atributo de objetos de armazenamento de caixa de correio do Active Directory. Por padrão, o atributo msExchMessageJournalRecipient não é configurado. Se o Exchange Server Analyzer verificar que o atributo msExchMessageJournalRecipient está configurado, ele exibirá uma mensagem de configuração não padrão. O Exchange Server Analyzer também exibe o nome do banco de dados e o nome do servidor em que o registro no diário apenas para mensagens está habilitado.

O registro no diário apenas para mensagens do Exchange Server 2003 ou o registro no diário do Exchange Server 2007 Standard cria uma cópia de todas as mensagens e os dados de cabeçalho de mensagem P2 correspondentes para e de usuários em um banco de dados de caixa de correio e envia a cópia da mensagem para uma caixa de correio especificada. O cabeçalho P2 da mensagem contém apenas os dados do destinatário da mensagem que o remetente declarou para os destinatários. Se uma mensagem externa for recebida da Internet, o Exchange Server registrará os cabeçalhos de mensagem P1 no diário. O cabeçalho de mensagens P1 é a informação de endereço usada pelos MTAs (agentes de transferência de mensagens) para rotear mensagens. Por padrão, quando o registro no diário somente para mensagens está habilitado, o Exchange Server não registra destinatários Cco (cópia oculta), destinatários de regras de encaminhamento de transporte ou destinatários de expansão do grupo de distribuição. Além disso, o Exchange Server não arquiva mensagens de relatório MAPI, como confirmações de leitura e notificações de ausência temporária.

O registro de mensagens no diário pode consumir muitos recursos de disco, rede e CPU. Portanto, o registro no diário exige um planejamento completo de implantação. O registro no diário deve ser habilitado somente no contexto de uma estrutura de solução de registro no diário abrangente.

Ignore essa mensagem de configuração não padrão se as seguintes condições forem verdadeiras:

  • Sua empresa exige o registro no diário.

  • Você implantou uma estrutura de solução de registro no diário.

Caso contrário, você deve desativar a funcionalidade de registro no diário.

Para desativar o registro no diário apenas para mensagens em um banco de dados do Exchange 2000 Server e do Exchange Server 2003

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, <seu servidor Exchange>, <grupo de armazenamento> e clique com o botão direito no armazenamento da caixa de correio.

  2. Na guia Geral, desmarque a caixa de diálogo Arquivar todas as mensagens enviadas ou recebidas por caixas de correio neste armazenamento.

  3. Aguarde 15 minutos para que o armazenamento do Exchange aplique as alterações. Você não precisa reiniciar o serviço Armazenamento de Informações do Microsoft Exchange.
Para desativar o registro no diário padrão em um banco de dados do Exchange Server 2007

  1. Siga as orientações contidas na documentação do produto do Exchange Server 2007, Como desabilitar o registro no diário do banco de dados por caixa de correio (em inglês) (http://go.microsoft.com/fwlink/?LinkId=80889).

Para obter mais informações sobre como implantar uma solução de registro no diário com o Exchange Server 2003, consulte Registro no diário com o Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47581).

Para obter mais informações sobre como implantar uma solução de registro no diário com o Exchange Server 2007, consulte Visão geral do registro no diário (em inglês) http://go.microsoft.com/fwlink/?LinkId=80820).


Loop de roteamento de mensagem pode existir
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchAlternateServer de cada servidor virtual SMTP. O Exchange Server Best Practices Analyzer também determina se o atributo msExchNonAuthoritativeDomains foi configurado de acordo com qualquer uma das diretivas de destinatário na organização. O Exchange Server Analyzer exibirá um aviso se existirem as seguintes condições:

  • Qualquer instância do atributo msExchAlternateServer foi definida.

  • O atributo msExchNonAuthoritativeDomains foi definido em qualquer diretiva do destinatário.

O Exchange Server Analyzer exibe um aviso porque as configurações mencionadas anteriormente podem gerar loops de mensagem: Os loops de mensagens podem ocorrer quando diferentes sistemas de mensagens estão configurados para operar juntos em uma única organização. Neste cenário, as diretivas de destinatário do Exchange Server e as configurações SMTP são usadas para rotear e entregar mensagens para grupos de usuários existentes nos sistemas de mensagens heterogêneos.

O atributo msExchAlternateServer é definido quando você especifica um endereço no campo Encaminhar ao host todas as mensagens com destinatários não resolvidos em uma página de propriedades do Servidor Virtual SMTP.

O atributo msExchNonAuthoritativeDomains é definido quando você desmarca a caixa de seleção Esta Organização do Exchange é responsável por todas as entregas de mensagens para este endereço na página de propriedades do endereço SMTP para uma diretiva de destinatário específica.

Portanto, se você especificar um domínio SMTP como não autoritativo, desmarcando a caixa de seleção Esta Organização do Exchange é responsável por todas as entregas de mensagens para este endereço e tiver especificado um endereço para destinatários não resolvidos em qualquer servidor virtual SMTP, o Exchange Server Analyzer exibirá um aviso. Contudo, é importante observar que a presença deste aviso não indica, de modo algum, a existência de um loop de mensagens em sua organização.

Se existir um domínio não autoritativo e pelo menos um servidor na organização tiver msExchAlternateServer definido, existirá a possibilidade de ocorrerem loops de roteamento de mensagens. Verifique se as seguintes condições existem:

  • Existem domínios autoritativos para todos os domínios em sua organização.

  • Os servidores virtuais SMTP estão configurados de modo que os domínios autoritivos manipulem todas as mensagens não resolvidas.

Em termos específicos, se você compartilhar um nome de domínio com outra organização, será recomendável que exista somente um caminho de entrada para o namespace desse domínio. Um servidor ou sistema de mensagens deve ser autoritativo para o domínio, para que o loop não ocorra. O servidor autoritativo deve ser o último sistema no caminho de entrada.

Não importa qual sistema é o receptor inicial. Não importa se existem mais de dois receptores iniciais. O importante é que somente um sistema seja o destino final.

Para alterar o atributo msExchAlternateServer

  1. No Gerenciador do Sistema Exchange, expanda Servidores, <Nome do Servidor>, Protocolos e expanda SMTP.

  2. Clique com o botão direito no seu servidor virtual SMTP e clique em Propriedades.

  3. Nas Propriedades do servidor virtual SMTP, clique na guia Mensagens.

  4. Na caixa Encaminhar todas as mensagens com destinatários não resolvidos ao host, digite o FQDN do servidor que receberá a mensagem não resolvida. Você também pode inserir o endereço IP do servidor entre colchetes ([ ]).

  5. Clique em OK.
Para alterar o atributo msExchNonAuthoritativeDomains

  1. No Gerenciador do Sistema do Exchange, expanda Destinatários e clique duas vezes em <Nome da Diretiva de Destinatário>.

  2. Na guia Endereços de Email (Diretiva), clique duas vezes em um endereço SMTP.

  3. Na página Propriedades do Endereço SMTP, uma marca em Esta Organização do Exchange é responsável por todas as entregas de mensagens para este endereço desmarca o atributo msExchNonAuthoritativeDomains. Ao desmarcar a caixa de seleção, você define o atributo msExchNonAuthoritativeDomains com o endereço SMTP especificado no campo Endereço.

Para obter mais informações sobre compartilhamento de espaços de endereçamento SMTP, consulte o artigo 321721 da Base de Dados de Conhecimento Microsoft, "Compartilhando espaços de endereçamento SMTP no Exchange 2000 Server e Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721) (em inglês).

Para obter mais informações sobre situações de implantação para conectividade da Internet, consulte "Situações de implantação para conectividade da Internet" no Guia de Roteamento e Transporte do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579) (em inglês).


A fila 'Mensagens aguardando pesquisa de diretório' está congelada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Analisador do Microsoft® Exchange Server consulta também a classe WMI (Instrumentação de Gerenciamento do Windows®) ExchangeLink para determinar o valor da chave StateFrozen para a fila Mensagens aguardando pesquisa de diretório do SMTP.

Se o Exchange Server Analyzer perceber que o valor da chave StateFrozen para a fila Mensagens aguardando pesquisa de diretório de um servidor Exchange está definido como True, o Exchange Server Analyzer exibirá um erro.

Uma fila congelada significa que as sessões de transporte para essa fila foram paradas. Uma fila congelada impede mensagens de saída, mas novas mensagens podem ser adicionadas. Você pode alterar manualmente o estado de uma conexão, usando o menu de atalho em cada fila de link. Quando você usa o comando Forçar Conexão para alterar um estado de fila para Ativo, você imediatamente habilita uma conexão que envia as mensagens dessa fila.

A fila Mensagens aguardando pesquisa de diretório contém mensagens para destinatários que ainda não foram resolvidas no serviço de diretório Active Directory®. As mensagens também são mantidas na fila enquanto listas de distribuição são expandidas.

Normalmente, as mensagens se acumulam nessa fila porque o mecanismo de enfileiramento avançado não pode categorizar a mensagem. O mecanismo de enfileiramento avançado pode não ser capaz de acessar os servidores do catálogo global e informações dos destinatários, ou os servidores do catálogo global estão inacessíveis ou com desempenho lento. Além disso, as mensagens podem se acumular pelas seguintes razões:

  • O Active Directory não está disponível.

    Observação:
    O categorizador usa o Active Directory para categorizar mensagens.
  • O Active Directory pode estar muito sobrecarregado se muitas mensagens estiverem na fila de pré-categorização.

  • Ocorre uma falha na conversão. O categorizador também manipula conversão de conteúdo.

  • O categorizador de mensagens não consegue localizar os armazenamentos de caixa de correio.

  • Se o SMTP foi reinstalado ou removido, isso pode invalidar as seguintes chaves de metabase do IIS: /smtpsvc/DsUseCat e /smtpsvc/vsi#/DsUseCat.

    Observação:
    Determine se o SMTP foi reinstalado or removido.

Para resolver esse erro, aumente o log de diagnóstico dos serviços MSExchangeDSAccess e MSExchangeTransport para coletar informações sobre os componentes do Categorizador.

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


A fila 'Mensagens aguardando pesquisa de diretório' está em repetição
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Windows®) para determinar o valor da chave StateFrozen para a fila Mensagens aguardando pesquisa de diretório do SMTP.

Se o Exchange Server Analyzer perceber que o valor da chave StateRetry para a fila Mensagens aguardando pesquisa de diretório de um servidor Exchange está definido como True, ele exibirá um erro.

Se uma fila estiver no status de repetição, esse status indica que ocorreu pelo menos um erro nas tentativas anteriores de processar as mensagens na fila. Você pode alterar filas no estado Repetição ou Agendado para Ativo com o comando Forçar Conexão. Isso faz com que a fila funcione como se o intervalo de repetição já tivesse passado ou se o horário agendado tivesse sido atingido. Entretanto, nem sempre esse método pode funcionar.

Observação:
As propriedades de uma fila podem indicar um motivo específico para ela estar na condição Repetir.

A fila Mensagens aguardando pesquisa de diretório contém mensagens para destinatários que ainda não foram resolvidas no serviço de diretório Active Directory®. As mensagens também são mantidas na fila enquanto listas de distribuição são expandidas.

Normalmente, as mensagens se acumulam nessa fila porque o mecanismo de enfileiramento avançado não pode categorizar a mensagem. O mecanismo de enfileiramento avançado pode não ser capaz de acessar os servidores do catálogo global e informações dos destinatários, ou os servidores do catálogo global estão inacessíveis ou com desempenho lento. Além disso, as mensagens podem se acumular pelas seguintes razões:

  • O Active Directory não está disponível.

    Observação:
    O categorizador usa o Active Directory para categorizar mensagens.
  • O Active Directory pode estar muito sobrecarregado se muitas mensagens estiverem na fila de pré-categorização.

  • Ocorre uma falha na conversão. O categorizador também manipula conversão de conteúdo.

  • O categorizador de mensagens não consegue localizar os armazenamentos de caixa de correio.

  • Se o SMTP foi reinstalado ou removido, isso pode invalidar as seguintes chaves de metabase do IIS: /smtpsvc/DsUseCat e /smtpsvc/vsi#/DsUseCat.

    Observação:
    Determine se o SMTP foi reinstalado or removido.

Para resolver esse erro, examine as propriedades da fila para determinar porque a fila está no status de repetição. Por exemplo, se as propriedades de fila exibirem uma mensagem parecida com "Erro de SMTP", você deve consultar seus logs de eventos do servidor para localizar os erros de SMTP. Se não houver eventos no log, você deve aumentar o nível de log do Protocolo SMTP.

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


A fila 'Mensagens com Envio Pendente' está congelada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-16

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®), ExchangeLink, para determinar o valor da chave StateFrozen para a fila SMTP Mensagens com envio pendente.

Se o Analisador do Exchange Server detectar que o valor da chave StateFrozen da fila Mensagens com envio pendente em um servidor Exchange está definido como True, exibirá um erro.

Uma fila congelada significa que as sessões de transporte para essa fila foram paradas. Uma fila congelada impede mensagens de saída, mas novas mensagens podem ser adicionadas. Você pode alterar manualmente o estado de uma conexão, usando o menu de atalho em cada fila de link. Quando você usa o comando Forçar Conexão para alterar um estado de fila para Ativo, você imediatamente habilita uma conexão que envia as mensagens dessa fila.

A fila Mensagens com Envio Pendente retém mensagens que foram confirmadas e aceitas pelo serviço SMTP.

As mensagens que estão nessa fila não foram processadas. Se as mensagens costumam acumular, pode existir um problema de desempenho. Os picos ocasionais no desempenho da CPU podem fazer com que as mensagens apareçam nessa fila intermitantemente. Com freqüência, os problemas com coletores de eventos, por exemplo, código de processamento SMTP personalizado para verificação antivírus e avisos de isenção, fazem com que as mensagens se acumulem nessa fila.

Para obter mais informações sobre como modificar configurações de log, consulte "How to Modify Logging Settings for MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


A fila 'Mensagens com envio Pendente' está em repetição
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave StateRetry da fila Mensagens com Envio Pendente do SMTP.

Se o Exchange Server Analyzer verificar que o valor da chave StateRetry para a fila Mensagens com Envio Pendente de um servidor Exchange está definido como True, ele exibirá um erro.

Se uma fila estiver no status de repetição, esse status indica que ocorreu pelo menos um erro nas tentativas anteriores de processar as mensagens na fila. Você pode alterar filas no estado Repetição ou Agendado para Ativo com o comando Forçar Conexão. Isso faz com que a fila funcione como se o intervalo de repetição já tivesse passado ou se o horário agendado tivesse sido atingido. Entretanto, nem sempre esse método pode funcionar.

Observação:
As propriedades de uma fila podem indicar um motivo específico para ela estar na condição Repetir.

A fila Mensagens com Envio Pendente retém mensagens que foram confirmadas e aceitas pelo serviço SMTP.

As mensagens que estão nessa fila não foram processadas. Se as mensagens estiverem se acumulando constantemente, talvez haja um problema de desempenho. Os picos ocasionais no desempenho da CPU podem fazer com que as mensagens apareçam nessa fila intermitantemente. Com freqüência, os problemas com coletores de eventos, por exemplo, código de processamento SMTP personalizado para verificação antivírus e avisos de isenção, fazem com que as mensagens se acumulem nessa fila.

Para obter mais informações sobre como modificar configurações de log, consulte "How to Modify Logging Settings for MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


A fila 'Mensagens aguardando para serem roteadas' está congelada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Windows®) para determinar o valor da chave StateFrozen para a fila do protocolo SMTP Mensagens aguardando para serem roteadas.

Se o Exchange Server Analyzer perceber que o valor da chave StateFrozen para a fila Mensagens aguardando pesquisa de diretório de um servidor Exchange está definido como True, o Exchange Server Analyzer exibirá um erro.

Uma fila congelada significa que as sessões de transporte para essa fila foram paradas. Uma fila congelada impede mensagens de saída, mas novas mensagens podem ser adicionadas. Você pode alterar manualmente o estado de uma conexão, usando o menu de atalho em cada fila de link. Quando você usa o comando Forçar Conexão para alterar um estado de fila para Ativo, você imediatamente habilita uma conexão que envia as mensagens dessa fila.

A fila Mensagens aguardando para serem roteadas mantém as mensagens até que o próximo servidor de destino seja determinado e move as mensagens para as filas de seus links repectivos.

As mensagens se acumulam nessa fila se existirem problemas de roteamento do Exchange Server. É possível fazer backup do roteamento de mensagens.

Para solucionar esse erro, aumente o log de diagnóstico para o serviço MSExchangeDSAccess e para o serviço MSExchangeTransport para coletar informações sobre componentes do categorizador.

Para obter mais informações sobre como modificar configurações de log, consulte "How to Modify Logging Settings for MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


A fila 'Mensagens aguardando para serem roteadas' está em repetição
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta do Microsoft® Exchange Server Analyzer consulta a classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Windows®) para determinar o valor da chave StateRetry para a fila de SMTP Mensagens aguardando para serem roteadas.

Se o Exchange Server Analyzer perceber que o valor da chave StateRetry para a fila Mensagens aguardando pesquisa de diretório de um servidor Exchange está definido como True, ele exibirá um erro.

Se uma fila estiver no status de repetição, esse status indica que ocorreu pelo menos um erro nas tentativas anteriores de processar as mensagens na fila. Você pode alterar filas no estado Repetição ou Agendado para Ativo com o comando Forçar Conexão. Isso faz com que a fila funcione como se o intervalo de repetição já tivesse passado ou se o horário agendado tivesse sido atingido. Entretanto, nem sempre esse método pode funcionar.

Observação:
As propriedades de uma fila podem indicar um motivo específico para ela estar na condição Repetir.

A fila Mensagens aguardando para serem roteadas armazena mensagens até que o servidor do próximo destino seja determinado e as move para suas respectivas filas de link.

As mensagens se acumulam nessa fila se existirem problemas de roteamento do Exchange Server. É possível fazer backup do roteamento de mensagens.

Para corrigir este erro, aumente o log de diagnóstico para o serviço MSExchangeTransport para coletar informações sobre componentes do Categorizador. Desabilite quaisquer restrições de conector desnecessárias, porque elas podem causar uma degradação significativa no desempenho do servidor. Você pode precisar ativar a chave do Registro CheckConnectorRestrictions para algumas restrições.

Para obter mais informações sobre como modificar configurações de log, consulte "How to Modify Logging Settings for MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Ligação de coletor de eventos de transporte ausente
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-01-11

A ferramenta Analisador do Microsoft® Exchange Server consulta a metabase do Microsoft IIS (Servidor de Informações da Internet) para enumerar a lista de ligações do coletor de eventos de transporte do SMTP (Simple Mail Transport Protocol). O Exchange Server Analyzer tenta localizar várias ligações de eventos padrão, com base na seguinte lista pré-preenchida no Exchange Server Analyzer:

  • Coletor de DSN Personalizado do Exchange

  • Coletor de Identificadores de Comandos de Entrada EHLO para XLSA

  • Coletor de Identificadores de Resposta EHLO para X-LSA

  • Coletor de Identificadores de Comandos de Entrada EOD

  • Categorizador do Exchange

  • Exchange LoadBalancer

  • Driver de Armazenamento NTFS do Exchange

  • Roteador do Exchange

  • Coletor de Logs do Protocolo SMTP do Exchange

  • Coletor EHLO de Segurança do Protocolo SMTP do Exchange

  • Coletor EXPS de Segurança do Protocolo SMTP do Exchange

  • Coletor EXPS-Aux de Segurança do Protocolo SMTP do Exchange

  • Coletor EXPS-EOD de Segurança do Protocolo SMTP do Exchange

  • Coletor de Correio de Segurança do Protocolo SMTP do Exchange

  • Coletor de Dados Anteriores XEXCH50 do Protocolo SMTP do Exchange

  • Coletor de Resposta EHLO XEXCH50 do Protocolo SMTP do Exchange

  • Coletor EOD XEXCH50 do Protocolo SMTP do Exchange

  • Coletor EHLO de Entrada XEXCH50 do Protocolo SMTP do Exchange

  • Coletor MAIL de Entrada XEXCH50 do Protocolo SMTP do Exchange

  • Coletor RCPT de Entrada XEXCH50 do Protocolo SMTP do Exchange

  • Coletor XEXCH50 de Entrada XEXCH50 do Protocolo SMTP do Exchange

  • Coletor do XEXCH50 por eventos de destinatário do Protocolo SMTP do Exchange

  • Coletor de Resposta RCPT XEXCH50 do Protocolo SMTP do Exchange

  • Coletor de Resposta XEXCH50 do Protocolo SMTP do Exchange

  • Driver de Armazenamento do Exchange

  • API do Antivírus de Transporte do Exchange

  • Coletor de Envios XEXCH50 de Transporte do Exchange

  • Coletor de Identificadores de Comandos de Entrada MAIL para TURF

  • Categorizador Móvel

  • Coletor EOD do Filtro de Conteúdo do MSExchange

  • Coletor MsgTrackLog

  • Coletor de Identificadores de Comandos de Entrada RCPT

  • Coletor de Log de Eventos do SMTP

  • UmConvSink

  • Coletor de Identificadores de Comandos de Entrada X-LSA

  • Coletor de Identificadores de Resposta X-LSA

  • Coletor X-SLA

Se o Analisador do Exchange Server achar que uma ou mais ligações de eventos padrão estão ausentes, ele gerará um aviso.

Um evento de transporte do SMTP ocorre quando os dados da mensagem são transportados para dentro ou para fora do serviço SMTP. Todas as mensagens passam por eventos. Isso inclui mensagens de entrada ou saída X.400 e RPC. Um exemplo comum de um evento de transporte de entrada é a chegada de uma mensagem ao serviço SMTP pela rede ou no diretório de recebimento do SMTP. Quando esse evento de transporte ocorre, uma fonte desse evento notifica os coletores de eventos de transporte, cada um dos quais pode executar algum tipo de ação com base no conteúdo dos dados da mensagem. O sistema não executa nenhuma outra ação com os dados da mensagem depois que ele passa os dados da mensagem para o coletor, até que o coletor conclua sua ação e retorne a mensagem. O coletor tem controle exclusivo dos dados e do estado da mensagem enquanto executa essa ação.

A falta de ligações de coletores de eventos de transporte pode causar problemas de fluxo de mensagens. Se o Exchange Server mostrar sintomas de problemas de fluxo de mensagens, como enfileiramento de mensagens, registre novamente os coletores de eventos de transporte.

Para registrar novamente os coletores de eventos de transporte

  1. No Microsoft Exchange Server, abra uma janela do prompt de comando e altere para a pasta \Arquivos de Programas\Exchsrvr\Bin.

  2. Digite os seguintes comandos para registrar novamente os coletores de eventos de transporte:

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. Execute novamente o Exchange Server Analyzer para verificar se os avisos não estão mais presentes. Se os avisos de coleta de eventos continuarem sendo exibidos e ocorrerem problemas de fluxo de mensagens, contate o Serviço de Suporte aos Produtos Microsoft (PSS).

Para obter mais informações sobre ligações de coletores de eventos de transporte, consulte os seguintes recursos do Exchange:

  • Artigo 258224 do Base de Dados de Conhecimento da Microsoft, "XCON: Enumerando os Coletores de Eventos de Transporte Registrados " (http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224)

  • "Projeto de Serviço SMTP" no Guia de Referência Técnica do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876)


O atributo msExchAlternateServer foi definido
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor para o atributo msExchAlternateServer de cada servidor virtual SMTP. Por padrão, o valor do atributo msExchAlternateServer não é definido. Se o Exchange Server Analyzer perceber que o atributo msExchAlternateServer foi definido, ele exibirá uma mensagem de configuração não padrão.

Você definiria o atributo msExchAlternateServer na seguinte situação de exemplo. Você compartilha um espaço de endereçamento SMTP, como um domínio SMTP, entre o Exchange Server 2003 e outro sistema de email. Nessa situação, o Exchange Server 2003 aceita a mensagem recebida da Internet. O Exchange Server 2003 procura um destinatário correspondente na organização do Exchange Server. Se não for encontrado um valor correspondente, o Exchange Server encaminhará a mensagem para o sistema de email externo. O sistema de recebimento também pode procurar uma correspondência. Se não for encontrada, ele poderá encaminhar a mensagem para um sistema de email de terceiros. O último sistema na cadeia deve ser autorizado para o domínio. O sistema de recebimento final deve procurar um destinatário correspondente. Se não for encontrado um destinatário correspondente, deverá ser gerada uma notificação de falha na entrega da mensagem. Se um sistema de recebimento procurar uma correspondência e, depois, retornar a mensagem para o sistema inicial quando não for encontrada uma correspondência, ocorrerão mensagens em loop.

Para alterar o atributo msExchAlternateServer

  1. No Gerenciador do Sistema Exchange, expanda Servidores, <Nome do Servidor>, Protocolos e expanda SMTP.

  2. Clique com o botão direito no seu servidor virtual SMTP e clique em Propriedades.

  3. Nas Propriedades do servidor virtual SMTP, clique na guia Mensagens.

  4. Na caixa Encaminhar todas as mensagens com destinatários não resolvidos ao host, digite o FQDN do servidor que receberá a mensagem não resolvida. Você também pode inserir o endereço IP do servidor entre colchetes ([ ]).

  5. Clique em OK.

Para obter mais informações sobre compartilhamento de espaços de endereçamento SMTP, consulte o artigo 321721 da Base de Dados de Conhecimento Microsoft, "Compartilhando espaços de endereçamento SMTP no Exchange 2000 Server e Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721) (em inglês).

Para obter mais informações sobre situações de implantação para conectividade da Internet, consulte "Situações de implantação para conectividade da Internet" no Guia de Roteamento e Transporte do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579) (em inglês).


O valor msExchMaxIncomingConnections teve sua configuração alterada do padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor configurado para o atributo msExchSmtpMaxIncomingConnections de cada servidor virtual SMTP.

Por padrão, em um computador do Exchange Server que não é parte de uma instalação do Microsoft Windows® Small Business Server 2003, o atributo msExchSmtpMaxIncomingConnections é configurado para um número ilimitado de conexões, como representado por um valor padrão de 2000000000 para esse atributo. Em um computador do Exchange Server que é parte de uma instalação do Microsoft Windows Small Business Server 2003, o número máximo padrão de conexões de entrada é 500.

O Exchange Server Analyzer também consulta a classe do WMI (Instrumentação de Gerenciamento do Windows) Win32_OperatingSystem para determinar o valor da chave OSProductSuite. O valor dessa chave corresponde a uma versão específica de um sistema operacional Windows Server.

Se o Exchange Server Analyzer verificar que o atributo msExchSmtpMaxIncomingConnections em um computador do Exchange Server que não é parte de uma instalação do Microsoft Windows Small Business Server 2003 não tem o valor 2000000000, será exibida uma mensagem de configuração não padrão. O valor de 2000000000 usado para esse atributo é um limite teórico e também o limite imposto para os elementos da interface de usuário que permitem que você configure esse valor.

Por outro lado, se o Exchange Server Analyzer verificar que o atributo msExchSmtpMaxIncomingConnections em um computador do Exchange Server que faz parte de uma instalação do Windows Small Business Server 2003 não tem o valor 500, será exibida uma mensagem de configuração não padrão.

Do ponto de vista da segurança, a limitação do número de conexões de entrada pode fazer sentido. A capacidade de aceitar um número essencialmente ilimitado de conexões SMTP de entrada pode se prestar a uma situação de negação de serviço. Muitas conexões simultâneas com o servidor virtual podem sobrecarregar a rede e causar baixo desempenho. Cada organização deve decidir qual é o valor apropriado para esse atributo.

Para exibir ou configurar o número máximo de conexões de entrada

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, expanda Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e clique em Propriedades.

  4. Clique em Geral:

    • Para limitar o número de conexões de entrada, marque a caixa de seleção Limitar o número de conexões a e digite o valor desejado.

    • Para reverter o número padrão de conexões de entrada ilimitadas, desmarque a caixa de seleção Limitar o número de conexões de entrada a.

  5. Clique em OK para salvar as alterações.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: How to Configure a SMTP Virtual Server Part 1," (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: Como configurar um servidor virtual SMTP Parte 2" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


O valor msExchSmtpMaxHopCount foi alterado do seu padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchSmtpMaxHopCount foi alterado do seu valor padrão.

No Exchange 2000 Server, o atributo msExchSmtpMaxHopCount é configurado com o valor padrão de 15. No Exchange Server 2003, esse atributo tem o valor padrão de 30. Se o Exchange Server Analyzer verificar que esse atributo não está mais definido com a configuração padrão, será exibida uma mensagem de configuração não padrão.

Uma mensagem pode ser roteada através de vários servidores SMTP diferentes (cada um chamado de um salto) antes de alcançar seu destino final. Para impedir que uma mensagem seja roteada incorretamente várias vezes (uma condição conhecida como um loop de mensagens) um administrador pode controlar o número máximo de saltos permitidos. O atributo mxExchSmtpMaxHopCount especifica o número de servidores SMTP através dos quais uma mensagem pode passar antes de ser devolvida ao rementente como não entregável.

É recomendado um valor de 30 para os servidores virtuais SMTP do Exchange 2000 Server e Exchange Server 2003.

Para corrigir esse erro

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  2. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e selecione Propriedades.

  3. Selecione a guia Entrega e clique em Avançado.

  4. Insira o valor desejado no campo Contagem máxima de saltos e clique em OK para salvar a alteração.

  5. Clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


O valor msExchSmtpMaxMessageSize teve seu valor alterado do padrão 0
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o valor do atributo msExchSmtpMaxMessageSize foi alterado do valor padrão 0. Por padrão, o atributo msExchSmtpMaxMessageSize é configurado para um tamanho de mensagem ilimitado. Se o Exchange Server Analyzer detectar que esse atributo não tem um valor 0 e que o Exchange não está em execução no Microsoft Windows® Small Business Server 2003, será exibida uma mensagem de aviso.

O atributo msExchSmtpMaxMessageSize representa o tamanho máximo de cada mensagem SMTP que pode ser enviada ou recebida. A partir de uma perspectiva de segurança, é uma prática recomendada limitar o tamanho máximo de mensagens SMTP que podem ser enviadas para a Internet ou recebidas dela. Contudo, para as mensagens SMTP internas, como aquelas que trafegam entre servidores Exchange na mesma organização, é recomendável que você deixe o atributo msExchSmtpMaxMessageSize definido como 0.

Internamente, o Exchange usa mensagens SMTP para manipular tarefas como replicação de pasta pública. Se o atributo msExchSmtpMaxMessageSize estiver configurado com um limite muito baixo, isso poderá acarretar problemas de replicação de pastas públicas e outras falhas na entrega de mensagens dentro da organização.

Se o servidor Exchange for um servidor bridgehead que transfere mensagens SMTP de e para a Internet, você poderá ignorar esse aviso com segurança. Se esse servidor Exchange manipular mensagens SMTP internas, você deverá restaurar o valor do atributo msExchSmtpMaxMessageSize para sua configuração padrão 0.

Observação:
Se você definir um limite de tamanho de mensagem muito baixo, isso poderá impedir a replicação do catálogo de endereços offline entre computadores do Exchange Server. Para obter mais informações sobre esse problema, consulte o artigo 326154 da Base de Dados de Conhecimento da Microsoft, "XADM: O OAB não será replicado se você definir uma restrição de tamanho de mensagens no nível do transporte" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154) (em inglês).

Para exibir e configurar o tamanho de mensagem SMTP máximo

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, um servidor Exchange, Protocolos e SMTP.

  2. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e selecione Propriedades.

  3. Selecione a guia Mensagens.

  4. Para restaurar para a configuração padrão 0, desmarque a caixa de seleção Limitar tamanho da mensagem a (KB). Como alternativa, deixe essa caixa marcada e configure o valor desejado.

  5. Clique em OK para salvar as alterações e fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: How to Configure a SMTP Virtual Server Part 1," (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


O valor de msExchSmtpMaxOutboundMsgPerDomain foi alterado do seu padrão de 20
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-07-07

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchSmtpMaxOutboundMsgPerDomain foi alterado do valor padrão 20. Por padrão, o atributo msExchSmtpMaxOutboundMsgPerDomain é configurado para um máximo de 20 mensagens de saída SMTP por conexão. Se o Analisador do Exchange Server achar que esse atributo não tem um valor 20, uma mensagem de configuração não padrão será exibida.

O atributo msExchSmtpMaxOutboundMsgPerDomain representa o número máximo de mensagens por conexão que podem ser enviadas por um servidor virtual SMTP no servidor Exchange. Por exemplo, se um servidor SMTP tiver 35 mensagens para enviar para microsoft.com e o atributo msExchSmtpMaxOutboundMsgPerDomain estiver definido em 20, serão feitas duas conexões para servidores de email responsáveis por mensagens para microsoft.com. A primeira conexão enviará o máximo de 20 mensagens e a segunda será feita para enviar as 15 mensagens restantes.

Geralmente, não há práticas recomendadas para determinar o valor correto para esse atributo. Cada organização deve determinar seu próprio valor adequado a ser configurado.

Para definir um número máximo de mensagens por conexão

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e clique em Propriedades.

  4. Clique em Mensagens.

  5. O valor atual do atributo msExchSmtpMaxOutboundMsgPerDomain está listado no campo Número limite de conexões para. Altere esse campo conforme necessário e clique em OK para salvar suas alterações. Os valores aceitos para esse campo incluem qualquer número inteiro entre 1 e 1999999999.

  6. Clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: Como configurar um Servidor Virtual SMTP Parte 1" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: Como configurar um Servidor Virtual SMTP Parte 2" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


O valor de msExchSmtpMaxOutgoingConnections foi alterado do seu padrão de 1.000
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchSmtpMaxOutgoingConnections teve seu valor padrão 1000 alterado. Por padrão, o atributo msExchSmtpMaxOutgoingConnections é configurado para no máximo 1000 conexões de saída SMTP. Se o Analisador do Exchange Server achar que esse atributo não tem um valor 1000, uma mensagem de configuração não padrão será exibida.

O atributo msExchSmtpMaxOutgoingConnections representa o número máximo de conexões de saída que podem ser feitas por um servidor virtual SMTP no servidor Exchange.

Geralmente, não há práticas recomendadas para determinar o valor correto para esse atributo. Cada organização deve determinar seu próprio valor adequado a ser configurado. Ou seja, o valor padrão pode ser muito alto para algumas organizações. Você pode monitorar e determinar o número real de conexões SMTP de saída feitas por um servidor virtual SMTP do Exchange, coletando os seguintes contadores de desempenho em seu servidor Exchange:

Objeto | Contador | Explanation
Servidor SMTP | Conexões de Saída Atuais | O número de conexões de saída atuais.
Servidor SMTP | Total de Conexões de Saída | O número total de tentativas de conexões de saída.

Se sua organização não fizer uso extensivo do SMTP de saída nesse servidor Exchange, convém diminuir o valor do atributo. Diminuir o número máximo de conexões SMTP de saída simultâneas que podem ser feitas a qualquer hora poderá reduzir potencialmente todos os picos de atividades do servidor SMTP. Essa redução pode ser causada por configuração incorreta, erro acidental, atividade mal-intencionada, loop de mensagem ou outro mau funcionamento, epidemia de vírus ou falha de segurança.

Para exibir e configurar o limite de conexões de saída

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e clique em Propriedades.

  4. Clique em Entrega e clique em Conexões de Saída.

  5. O valor atual do atributo msExchSmtpMaxOutgoingConnections está listado no campo Número limite de conexões para. Altere esse campo conforme necessário e clique em OK para salvar suas alterações. Os valores aceitos para esse campo incluem qualquer número inteiro entre 1 e 1999999999.

  6. Clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


O valor de msExchSmtpMaxOutgoingConnectionsPerDomain foi alterado do padrão de 100
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchESEParamLogFilePath foi alterado da configuração padrão. O atributo msExchSmtpMaxOutgoingConnectionsPerDomain representa o número máximo de conexões de saída por domínio que podem ser feitas por um servidor virtual SMTP no servidor Microsoft Exchange. Por padrão, em um computador do Exchange Server que não faz parte de uma instalação do Microsoft Windows® Small Business Server 2003, o atributo msExchSmtpMaxOutgoingConnectionsPerDomain é configurado com um valor padrão de 100. Em um computador do Exchange Server que é parte de uma instalação do Windows Small Business Server 2003, o número máximo padrão de conexões de saída por domínio é 10.

O Exchange Server Analyzer também consulta a classe do WMI (Instrumentação de Gerenciamento do Windows) Win32_OperatingSystem para determinar o valor da chave OSProductSuite. O valor dessa chave corresponde a uma versão específica de um sistema operacional Windows Server.

Se o Exchange Server Analyzer verificar que o atributo msExchSmtpMaxOutgoingConnectionsPerDomain em um computador do Exchange Server que não faz parte de uma instalação do Windows Small Business Server 2003 não tem o valor 500, será exibida uma mensagem de configuração não padrão.

Por outro lado, se o Exchange Server Analyzer verificar que o atributo msExchSmtpMaxOutgoingConnectionsPerDomain em um computador do Exchange Server que faz parte de uma instalação do Windows Small Business Server 2003 não tem o valor 10, será exibida uma mensagem de configuração não padrão.

Geralmente, não há práticas recomendadas para determinar o valor correto para esse atributo. Cada organização precisa determinar o valor apropriado a ser definido. Ou seja, o valor padrão pode ser muito alto para algumas organizações. Você pode monitorar e determinar o número real de conexões SMTP de saída feitas por um servidor virtual SMTP do Exchange, coletando os seguintes contadores de desempenho em seu servidor Exchange:

Objeto | Contador | Explanation
Servidor SMTP | Conexões de Saída Atuais | O número de conexões de saída atuais.
Servidor SMTP | Total de Conexões de Saída | O número total de tentativas de conexões de saída.

Se sua organização não usa SMTP de saída de forma extensiva nesse servidor Exchange, experimente diminuir o valor desse atributo. A diminuição do número máximo de conexões de saída SMTP simultâneas que podem ser feitas a qualquer momento retardar picos na atividade do servidor SMTP causados por configuração incorreta, erros involuntários, atividade mal-intencionada, um loop de mensagens ou outro mal funcionamento, ou uma epidemia de vírus ou violação de segurança.

Para exibir e configurar o limite de conexões de saída por domínio

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e clique em Propriedades.

  4. Clique em Entrega e clique em Conexões de Saída.

  5. O valor atual do atributo msExchSmtpMaxOutgoingConnectionsPerDomain está listado no campo Limitar número de conexões por domínio a. Altere esse campo como desejar e clique em OK para salvar as alterações. Os valores aceitos para esse campo incluem qualquer número inteiro entre 1 e 1999999999.

  6. Clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


O valor msExchSmtpMaxRecipients teve seu valor padrão de 64000 alterado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchSmtpMaxRecipients foi alterado do valor padrão de 64000. Por padrão, o atributo msExchSmtpMaxRecipients é configurado para 64.000 destinatários. Se o Exchange Server Analyzer achar que esse atributo não tem o valor 64000, uma mensagem de configuração não padrão será exibida.

Do ponto de vista da segurança, é recomendável limitar o tamanho máximo de destinatários para cada mensagem. Cada organização deve determinar qual é um valor aceitável para ela. A menos que você tenha um motivo para configurar o valor de outra forma, é recomendável que você mantenha o atributo msExchSmtpMaxRecipients definido como o padrão de 64000.

Para exibir e configurar o número máximo de destinatários

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  2. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e selecione Propriedades.

  3. Selecione a guia Mensagens.

  4. Para retornar à configuração padrão de 64000, verifique se a caixa de seleção Limitar número de destinatários por mensagem está marcada e digite o valor 64000. Como alternativa, você pode configurar esse campo com o valor desejado ou desmarcar a caixa de seleção para permitir um número ilimitado de destinatários.

  5. Clique em OK para salvar as alterações e fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: How to Configure a SMTP Virtual Server Part 1," (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


O valor msExchSmtpMaxSessionSize foi alterado de seu padrão de 0
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchSmtpMaxSessionSize foi alterado do valor padrão de 0. Por padrão, o atributo msExchSmtpMaxSessionSize é configurado com um tamanho de mensagem ilimitado. Se o Exchange Server Analyzer detectar que esse atributo não tem um valor igual a 0, uma mensagem de aviso será exibida.

O atributo msExchSmtpMaxSessionSize representa a quantidade máxima de dados em KB que será aceita em cada sessão do SMTP. De uma perspectiva de segurança, é prática recomendada limitar o tamanho das mensagens enviadas e recebidas pela Internet nas sessões do SMTP. Entretanto, nas sessões internas do SMTP, como aquelas entre servidores Exchange na mesma organização, recomenda-se deixar o atributo msExchSmtpMaxSessionSize definido como 0.

Internamente, o Exchange usa mensagens SMTP para manipular tarefas como replicação de pasta pública. Se o atributo msExchSmtpMaxSessionSize estiver configurado com um limite muito baixo, isso poderá causar problemas de replicação de pasta pública e outras falhas de entrega de mensagens dentro da organização.

Se o servidor Exchange for um servidor bridgehead que transfere mensagens SMTP de e para a Internet, você poderá ignorar esse aviso com segurança. Se esse servidor Exchange manipular mensagens SMTP internas, altere o valor do atributo msExchSmtpMaxSessionSize novamente para sua definição padrão de 0.

Para exibir e configurar o tamanho máximo de sessão do SMTP

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores; em seguida, expanda um servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, o servidor virtual SMTP padrão) e clique em Propriedades.

  4. Clique em Mensagens.

  5. Para reverter a definição padrão igual a 0, desmarque a caixa de seleção Limitar tamanho de sessão para (KB). Como alternativa, deixe essa caixa marcada e configure o valor desejado.

  6. Clique em OK para salvar as alterações e fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


O valor msExchSmtpOutgoingPort teve seu valor padrão de 25 alterado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchSmtpOutgoingPort teve seu valor padrão 25 alterado. Por padrão, o atributo msExchSmtpOutgoingPort está configurado para porta TCP 25. Se o Exchange Server Analyzer verificar que esse atributo está configurado para uma porta diferente de 25, um aviso será exibido.

Por padrão, os servidores SMTP estão configurados para aceitar conexões de entrada na porta TCP 25. O parâmetro msExchSmtpOutgoingPort representa a porta TCP à qual esse servidor Exchange tentará se conectar em todos os servidores SMTP remotos. Se os servidores SMTP remotos estiverem configurados para escutar nesta porta, uma conexão não poderá ser estabelecida.

A menos que parte ou toda a sua infra-estrutura interna tenha sido modificada para usar portas não padrão, é recomendável que você use a porta TCP 25 para toda a comunicação SMTP.

Para exibir ou alterar a porta de saída SMTP padrão

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  2. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e clique em Propriedades.

  3. Clique em Entrega e clique em Conexões de Saída.

  4. No campo porta TCP, digite a porta que você deseja usar para conexões de saída. Cada SMTP remoto com o qual você deseja se comunicar deve estar configurado para aceitar conexões na porta especificada. Na maioria dos casos, você não desejará alterar esse valor.

  5. Altere esse campo conforme necessário e clique em OK para salvar suas alterações.

  6. Clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


O valor de msExchSmtpRelayForAuth foi alterado do seu padrão True
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchSmtpRelayForAuth foi alterado do valor padrão. Por padrão, o atributo msExchSmtpRelayForAuth está configurado com o valor True. Se o Exchange Server Analyzer verificar que o atributo msExchSmtpRelayForAuthnão tem o valor True, uma mensagem de configuração não padrão será exibida.

Quando esse valor está definido como True, apenas conexões SMTP autenticadas podem retransmitir mensagens SMTP através do servidor virtual SMTP. Se essa configuração tiver sido alterada para False, isso indicará que a caixa de seleção "Permitir a retransmissão por todos os computadores que autenticam com êxito, independentemente da lista acima" nas configurações de Retransmissão da caixa de diálogo Propriedades do servidor virtual SMTP está desmarcada.

A retransmissão é a ação de uma conexão de entrada em seu servidor SMTP usado para enviar mensagens de email para domínios externos. Com mensagens de email comerciais não solicitadas, isso é feito enviando uma única mensagem de email para seu servidor SMTP com vários destinatários em domínios externos à organização. Como a configuração padrão para servidores SMTP é usar a autenticação anônima, o sistema usado para propagar as mensagens de email comerciais não solicitadas aceita a mensagem de entrada normalmente.

Após a mensagem ser aceita, o servidor SMTP reconhece que os destinatários da mensagem pertencem a domínios externos e o servidor SMTP envia as mensagens. Por isso, os usuários não autorizados que enviam mensagens de email comerciais não solicitadas precisam apenas enviar uma mensagem de entrada para seu servidor SMTP para que ela seja enviada para milhares de destinatários, o que reduz a capacidade de resposta do computador do Exchange Server, congestiona filas e causa insatisfação dos destinatários quando as mensagens chegam a suas Caixas de Entrada.

A principal maneira de controlar a retransmissão é não conceder permissões de retransmissão a outros hosts. No entanto, às vezes a retransmissão é necessária. Por exemplo, se você tiver clientes POP3 e IMAP4 que dependem do SMTP para enviar mensagens e têm motivos legítimos para enviar mensagens de email para domínios externos. Você pode contornar esse problema criando um segundo servidor virtual SMTP dedicado a receber mensagens de email de clientes POP3 e IMAP4. Esse servidor virtual SMTP adicional pode usar autenticação combinada com criptografia baseada em SSL (Secure Sockets Layer) e pode ser configurado para permitir a retransmissão para clientes autenticados. Para obter mais informações sobre como implementar essa configuração, consulte o artigo 319267 da Base de Dados de Conhecimento Microsoft, "COMO: Entrega de Mensagens do Cliente SSMTP no Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267).

Para exibir ou modificar o valor msExchSmtpRelayForAuth no Gerenciador do Sistema

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, expanda Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e clique em Propriedades.

  4. Selecione a guia Acesso e clique em Retransmitir.

  5. Marque ou desmarque a caixa de seleção Permitir a retransmissão por todos os computadores que autenticam com êxito, independentemente da lista acima.

  6. Clique em OK para salvar as alterações.

Se a caixa estiver marcada, o atributo msExchSmtpRelayForAuth deverá ser definido como True. Se a caixa estiver desmarcada, o atributo msExchSmtpRelayForAuth deverá ser definido como False.

Para obter informações adicionais sobre como controlar quais contas podem retransmitir mensagens, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 818778, "Usuários sem permissões para retransmitir mensagens podem enviar mensagens através do servidor virtual SMTP" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818778)

  • 310380, "COMO FAZER PARA: Impedir que o Exchange 2000 seja usado para retransmitir email no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380)


O valor msExchSmtpSmartHostType foi alterado em relação ao seu padrão de 0
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchSmtpSmartHostType foi alterado do valor padrão 0. Por padrão, o atributo msExchSmtpSmartHostType está definido como 0. Se o Analisador do Exchange Server detectar que esse atributo não tem um valor igual a 0, uma mensagem de configuração não padrão será exibida.

O atributo msExchSmtpSmartHostType indica se um servidor virtual SMTP está configurado para usar um host inteligente para entregar mensagens. Você pode encaminhar todas as mensagens de saída para domínios remotos por meio de um host inteligente, em vez de enviar essas mensagens diretamente para os domínios do destinatário. Quando o Exchange estiver configurado para usar um host inteligente, o valor do atributo msExchSmtpSmartHostType será alterado, conforme detalhado na tabela a seguir.

Configuração de host inteligente | Valor do atributo msExchSmtpSmartHostType
Sem host inteligente | 0
Host inteligente | 2
Host inteligente com primeira tentativa de entrega direta | 1

Nos computadores do Exchange Server 2003, esse valor será 0 ou 2. Nos computadores do Exchange 2000 Server, o valor pode ser 0, 1 ou 2. Um valor igual a 1 é definido quando a caixa de seleção Tentar entrega direta antes de enviar ao host inteligente estiver marcada. Essa caixa de seleção existe apenas nos computadores do Exchange 2000 Server. O Exchange Server 2003 não contém essa caixa de seleção.

A menos que você especifique um motivo para fazer isso, é recomendável deixar o atributo msExchSmtpSmartHostType na configuração padrão igual a 0.

Se seu ambiente exige um host inteligente e você tem (ou planeja ter) mais de um computador do Exchange Server em seu ambiente, é recomendável que use um Conector SMTP para todas as entradas de host inteligente. Dessa maneira, todas as mensagens internas são encaminhadas pelo Exchange Server e apenas suas mensagens externas serão encaminhadas pelo host inteligente.

Para exibir e configurar as definições do host inteligente

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e selecione Propriedades.

  4. Selecione a guia Entrega e clique em Avançado.

  5. Insira o host inteligente que você deseja usar. É possível identificar o host inteligente pelo nome de domínio totalmente qualificado ou por um endereço IP. Se você usar um endereço IP, deverá colocá-lo entre colchetes ([ ]). O Exchange verifica primeiro um nome de servidor e, depois, um endereço IP. Os colchetes identificam o valor como um endereço IP; portanto, a pesquisa DNS é ignorada.

  6. Se esse for um computador do Exchange 2000 Server, marque, opcionalmente, a caixa de seleção Tentar entrega direta antes de enviar ao host inteligente.

  7. Clique em OK para salvar as alterações e clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: Como configurar um servidor virtual SMTP parte 1" (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=266686).

  • 268163, "XCON: Como configurar um servidor virtual SMTP parte 2" (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=268163)


O serviço do MTA Stacks está configurado para interagir com a área de trabalho
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da propriedade DesktopInteract para o serviço Microsoft Exchange MTA Stacks (MSExchangeMTA). Se o Exchange Server Analyzer detectar que o serviço MTA está configurado para interagir com a área de trabalho, o Exchange Server Analyzer exibirá um erro.

Essa configuração deve ser usada somente sob orientação do Atendimento Microsoft. A menos que o Atendimento Microsoft tenha instruído você a executar o serviço MTA nessa configuração, recomenda-se reconfigurar as propriedades do serviço MTA Stacks de forma que ele não interaja com a área de trabalho.

Para configurar a conta de serviço do Exchange MTA Stacks

  1. Abra o snap-in Serviços do MMC.

  2. Localize e interrompa o serviço Microsoft Exchange MTA Stacks.

  3. Clique duas vezes no serviço Microsoft Exchange MTA Stacks.

  4. Na guia Logon da página Propriedades do Microsoft Exchange MTA Stacks, selecione Conta Sistema Local em Fazer logon como.

  5. Desmarque a caixa de seleção Permitir que o serviço interaja com a área de trabalho e clique em Aplicar.

  6. Em Status do Serviço, clique em Iniciar e clique em OK.

  7. Feche o snap-in Serviços.

Para obter mais informações sobre a configuração correta do serviço do Exchange, consulte o artigo 239762 da Base de Dados de Conhecimento Microsoft, "Serviços do Exchange executados em LocalSystem" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Nenhum registro 'Host' encontrado para os registros 'MX'
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-03

A Ferramenta Microsoft® Exchange Server Analyzer realiza uma pesquisa de DNS (Sistema de Nome de Domínio) para recuperar os registros MX (Servidor de Mensagens) para um domínio. Se os registros MX forem recuperados com êxito, o Exchange Server Analyzer executará uma pesquisa de DNS para recuperar os registros Host (A) dos servidores para os quais os registros MX apontam. Se a operação de pesquisa de DNS não retornar um endereço IP para nenhum dos registros Host (A), o Exchange Server Analyzer exibirá um erro.

Esse erro indica que o registro Host de DNS (A) parece estar ausente no servidor. Esse erro pode fazer com que o backup das mensagens destinadas a domínios remotos seja feito nas filas de Entrega Remota do servidor Exchange. Esse erro também pode causar outros atrasos de roteamento ou serviço.

A pesquisa de DNS do registro Host (A) de um registro MX pode falhar pelos seguintes motivos:

  • O servidor DNS está inativo ou não está respondendo devida a uma falha de rede ou por outras razões.

  • O registro Host (A) do servidor remoto está ausente do servidor DNS porque o registro está indisponível ou incorreto.

  • O servidor DNS não está configurado para habilitar atualizações dinâmicas de registro de host.

Para verificar se o servidor DNS está online e se o Registro de host está presente

  1. Confira se o servidor DNS está em execução fazendo uma ou mais das seguintes verificações:

    • Veja o status do servidor DNS no programa de Administração do DNS no servidor DNS.

    • Reinicie o servidor DNS. Para obter mais informações, consulte "Start, stop, pause, or restart a DNS server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Verifique a capacidade de resposta do servidor DNS usando o comando nslookup. Para obter mais informações, consulte "Verificar a capacidade de resposta do servidor DNS usando o comando nslookup" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Use nslookup para verificar se o registro Host (A) existe no servidor DNS. Para obter mais informações, consulte "To verify A resource records exist in DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63001).

  3. Se o registro de recurso Host (A) não existir, adicione ou modifique manualmente o registro de recurso A ou configure o servidor DNS para habilitar atualizações dinâmicas de registro:

    • Adicione manualmente um registro de recurso A. Para obter mais informações, consulte "Add a resource record to a DNS zone" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Modifique manualmente um registro de recurso A. Para obter mais informações, consulte "Modify an existing resource record" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Configure o servidor DNS para habilitar atualizações dinâmicas de registro de host. Para obter mais informações, consulte o artigo 816592 da Base de Dados de Conhecimento Microsoft, "How to configure DNS dynamic updates in Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).

Para obter mais informações

  • Para obter informações sobre como o Exchange Server 2003 usa o DNS para resolver endereços IP externos, consulte "Transport Dependencies for Exchange Server 2003" no Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Para obter informações sobre resolução de nomes do DNS, consulte o artigo 322856 da Base de Dados de Conhecimento Microsoft, "COMO FAZER: Configure DNS para Ser Usado com o Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Para obter informações sobre como solucionar problemas do DNS, consulte "Troubleshooting DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Para obter informações sobre monitoramento do sistema do Exchange Server 2003, consulte "Chapter 3: System Monitoring with Exchange Server 2003 Management Pack" in the Exchange Server 2003 Management Pack Guide for MOM 2000 SP1 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Para obter informações sobre os registros de recursos Host (A), consulte "Managing Resource Records" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63004).


Nenhum registro 'Host' encontrado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-04

A ferramenta Analisador do Microsoft® Exchange Server executa uma pesquisa DNS para recuperar os Registros Host (A) dos servidores remotos para o qual o servidor Exchange está tentando enviar mensagens. Se a operação de pesquisa DNS não retornar um endereço IP, o Analisador do Exchange Server exibirá um erro.

Esse erro indica que o Registro Host (A) DNS parece estar ausente no servidor remoto. Esse erro pode fazer com que as mensagens façam backup nas filas Entrega Remota no servidor Exchange.

A pesquisa DNS do Registro Host (A) no servidor remoto pode falhar pelas seguintes razões:

  • O servidor DNS está inativo ou não está respondendo devida a uma falha de rede ou por outras razões.

  • O registro Host (A) do servidor remoto está ausente do servidor DNS porque o registro está indisponível ou incorreto.

  • O servidor DNS não está configurado para habilitar atualizações dinâmicas de registro de host.

Para verificar se o servidor DNS está online e se o Registro de host está presente

  1. Confira se o servidor DNS está em execução fazendo uma ou mais das seguintes verificações:

    • Veja o status do servidor DNS no programa de Administração do DNS no servidor DNS.

    • Reinicie o servidor DNS. Para obter mais informações, consulte "Start, stop, pause, or restart a DNS server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Verifique a capacidade de resposta do servidor DNS usando o comando nslookup. Para obter mais informações, consulte "Verificar resposta do servidor DNS com o comando nslookup" (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Use nslookup para verificar se o registro Host (A) existe no servidor DNS. Para obter mais informações, consulte "To verify A resource records exist in DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63001).

  3. Se o registro de recurso Host (A) não existir, adicione ou modifique manualmente o registro de recurso A ou configure o servidor DNS para habilitar atualizações dinâmicas de registro:

    • Adicione manualmente um registro de recurso A. Para obter mais informações, consulte "Add a resource record to a DNS zone" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Modifique manualmente um registro de recurso A. Para obter mais informações, consulte "Modify an existing resource record" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Configure o servidor DNS para habilitar atualizações dinâmicas de registro de host. Para obter mais informações, consulte o artigo 816592 da Base de Dados de Conhecimento Microsoft, "How to configure DNS dynamic updates in Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).
  • Para obter informações sobre como o Exchange Server 2003 usa o DNS para resolver endereços IP externos, consulte "Transport Dependencies for Exchange Server 2003" no Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Para obter informações sobre resolução de nomes do DNS, consulte o artigo 322856 da Base de Dados de Conhecimento Microsoft, "COMO FAZER: Configure DNS para Ser Usado com o Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Para obter informações sobre como solucionar problemas do DNS, consulte "Troubleshooting DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Para obter informações sobre monitoramento do sistema do Exchange Server 2003, consulte "Chapter 3: System Monitoring with Exchange Server 2003 Management Pack" in the Exchange Server 2003 Management Pack Guide for MOM 2000 SP1 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Para obter informações sobre os registros de recursos Host (A), consulte "Managing Resource Records" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63004).


Nenhum registro 'MX' encontrado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

O Microsoft® Exchange Server Analyzer Tool consulta os servidores DNS (Sistema de Nome de Domínio) que usa para obter os registros do servidor de mensagens (MX) de domínios remotos para os quais o Exchange envia.

Se o Exchange Server Analyzer não poder recuperar os registros MX para um domínio remoto a partir dos servidores DNS que ele utiliza, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica a provável ausência dos registros MX do DNS para o domínio remoto.

Para determinar hosts de mensagens, o servidor Exchange de envio procura um registro MX. Em seguida, o servidor de envio resolve o registro MX para um endereço IP, procurando um registro de endereço (A).

Se os registros MX para domínios remotos estiverem ausentes, isso poderá provocar o backup das mensagens destinadas aos domínios remotos nas filas Entrega Remota do servidor Exchange, além de outros atrasos de roteamentos ou de serviços.

A pesquisa de DNS dos registros MX poderão falhar se o servidor DNS estiver fora do ar ou inacessível por causa de uma falha de rede ou por outros motivos.

Para verificar se o servidor DNS está online e se os registros MX estão presentes

  1. Confira se o servidor DNS está em execução fazendo uma ou mais das seguintes verificações:

    • Veja o status do servidor DNS no programa de Administração do DNS no servidor DNS.

    • Reinicie o servidor DNS. Para obter mais informações, consulte "Start, stop, pause, or restart a DNS server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Verifique a capacidade de resposta do servidor DNS usando o comando nslookup. Para obter mais informações, consulte as instruções em "Verify DNS server responsiveness using the nslookup command" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Use nslookup para verificar se os registros MX estão configurados corretamente. Para obter mais informações, consulte "Como usar Nslookup para verificar a configuração de registros MX" na seção "Verificando o design e a configuração de DNS" do Guia de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579) (em inglês).

Para obter mais informações

  • Para obter informações sobre como o Exchange Server 2003 usa o DNS para resolver endereços IP externos, consulte "Transport Dependencies for Exchange Server 2003" no Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Para obter informações sobre resolução de nomes do DNS, consulte o artigo 322856 da Base de Dados de Conhecimento Microsoft, "COMO FAZER: Configure DNS para Ser Usado com o Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Para obter informações sobre como solucionar problemas do DNS, consulte "Troubleshooting DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Para obter informações sobre monitoramento do sistema do Exchange Server 2003, consulte "Chapter 3: System Monitoring with Exchange Server 2003 Management Pack" in the Exchange Server 2003 Management Pack Guide for MOM 2000 SP1 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47573).


Grupo de distribuição aninhado encontrado em restrições de entrega
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-21

A ferramenta Microsoft® Exchange Server Analyzer consulta os seguintes atributos de cada objeto grupo de distribuição em todos os domínios encontrados no serviço de diretório do Active Directory® para detectar se algum grupo é usado para definir restrições de entrega baseadas na associação no grupo:

dLMemRejectPermsBL | Contém os DNs de destinatários ou conectores que não aceitarão mensagens deste grupo.
dLMemSubmitPermsBL | Contém os DNs de destinatários ou conectores que aceitarão mensagens deste grupo.

Ao detectar a existência de objetos de grupos utilizados para definir restrições de entrega, o Exchange Server Analyzer examinará esses grupos para descobrir se contêm grupos aninhados.

O Exchange Server Analyzer lê também a seguinte entrada do Registro para determinar se o valor do Registro RestrictionMethod está presente e como está configurado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

O Exchange Server Analyzer exibirá um aviso, se as seguintes condições forem verdadeiras:

  • A associação do Grupo de distribuição é usada para definir restrições de entrega.

  • Há grupos de distribuição aninhados nos grupos de distribuição que possuem restrições de entrega definidas.

  • O valor de Registro RestrictionMethod está presente e não está definido para forçar uma verificação de restrição simples.

Este erro indica que as restrições da entrega baseadas em associação de grupos de distribuição podem afetar bastante o desempenho do fluxo de mensagens do Exchange.

O comportamento padrão para o categorizador é expandir recursivamente os grupos de distribuição e verificar as restrições de cada mensagem que passa pelo sistema.

Quando você envia uma mensagem para um usuário que aceita ou recusa mensagens de um grupo de distribuição ou envia uma mensagem que passa por um conector que aceita ou recusa mensagem de um grupo de distribuição, o categorizador de mensagens precisa expandir a associação do grupo de distribuição, obter a lista completa de DNs dos membros e comparar a lista de DNs com os DNs do remetente da lista. Uma operação de acesso ou de negação ocorre quando há correspondência de um DN em ambas as listas. Se um grupo de distribuição estiver aninhado em outro grupo de distribuição, a distribuição aninhada também será expandida.

O valor RestrictionMethod determina como o categorizador processará as restrições. Se você definir o valor de RestrictionMethod como 2, os componentes de transporte nesse servidor que executa o Exchange Server não expandirão a associação de grupos de distribuição quando o servidor verificar restrições. Essa configuração fornece o melhor desempenho para verificações de restrição. Além disso, para que a entrada de Registro RestrictionMethod entre em vigor, todos os grupos de distribuição que incluírem usuários com restrições de entrega devem ser simples. Isto é, os grupos de distribuição restritos não têm grupos de distribuição aninhados. A lógica de expansão não funcionará se os grupos de distribuição restritos estiverem aninhados.

Para grupos de distribuição usados em restrições de conector, é recomendável definir o valor da entrada do Registro RestrictionMethod em um servidor bridgehead do conector que não possua caixas de correio. Para restrições de usuário do Active Directory, se os grupos de distribuição restritos tiverem servidores de expansão, será recomendável criar a entrada do Registro RestrictionMethod nos servidores de expansão.

Para corrigir esse erro:

  • Examine os usuários cujas restrições de entrega do grupo de distribuição estão definidas e remova as restrições desnecessárias.

  • Configure caixas de correio individuais e não grupos de distribuição para restrições de entrega, como citado no artigo 812298 da Base de Dados de Conhecimento Microsoft, "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Para os servidores com o Microsoft Exchange Server 2003 Service Pack 2 (SP2) ou versão posterior, considere a implementação de verificação de restrição não-hierárquica. Para os servidores com versões do Exchange anteriores ao Exchange 2003 SP2, considere uma atualização para o Exchange 2003 SP2.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para criar a entrada do Registro RestrictionMethod e definir seu valor como 2

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. No painel esquerdo, clique em Parâmetros.

  4. No menu Editar, aponte para Novo e clique em Valor DWORD.

  5. Digite RestrictionMethod e pressione ENTER para nomear a nova entrada do Registro.

  6. Clique com o botão direito em RestrictionMethod e clique em Modificar.

  7. Digite 2 e pressione ENTER.

  8. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (em inglês).

Para obter mais informações

Para obter mais informações sobre a verificação de restrição não-hierárquica, consulte Considere a verificação da restrição não hierárquica.

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 895407 "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407) (em inglês).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949) (em inglês).

  • 812298 "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298) (em inglês).

Para obter mais informações sobre o valor de Registro RestrictionMethod, consulte o artigo 895407 da Base de Dados de Conhecimento Microsoft, "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e externas é mais lenta do que o esperado após a configuração das restrições de entrega baseadas em grupos de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Para obter mais informações sobre o valor de Registro , consulte o artigo 277872 da Base de Dados de Conhecimento Microsoft, "XCON: Connector Delivery Restrictions May Not Work Correctly" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


Grupo de distribuição aninhado encontrado, mas verificação de restrição simples habilitada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-21

A ferramenta Microsoft® Exchange Server Analyzer consulta os seguintes atributos de cada objeto grupo de distribuição em todos os domínios encontrados no serviço de diretório do Active Directory® para detectar se algum grupo é usado para definir restrições de entrega baseadas na associação no grupo:

dLMemRejectPermsBL | Contém os DNs de destinatários ou conectores que não aceitarão mensagens deste grupo.
dLMemSubmitPermsBL | Contém os DNs de destinatários ou conectores que aceitarão mensagens deste grupo.

Ao detectar a existência de objetos do grupo utilizados para definir restrições de entrega, o Exchange Server Analyzer examinará esses grupos para descobrir se contêm grupos aninhados.

O Exchange Server Analyzer lê também a seguinte entrada do Registro para determinar se o valor do Registro RestrictionMethod está presente e como está configurado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

O Exchange Server Analyzer exibirá um aviso, se as seguintes condições forem verdadeiras:

  • A associação de grupos de distribuição é usada para definir restrições de entrega.

  • Há grupos de distribuição aninhados nos grupos de distribuição que possuem restrições de entrega definidas.

  • O valor de Registro RestrictionMethod está presente e definido para instruir uma verificação de restrição simples.

Este aviso indica que, embora o valor de Registro RestrictionMethod esteja definido para forçar uma verificação de restrição simples (não-hierárquica), os grupos de distribuição que possuem restrições de entrega definidas têm outros grupos de distribuição a eles incorporados (aninhados). A verificação de restrição simples não identificará corretamente os remetentes permitidos ou negados se os grupos de distribuição contiverem grupos de distribuição aninhados. Com a verificação de restrição simples, os grupos de distribuição aninhados não são expandidos.

Os comportamentos padrão para o categorizador é expandir recursivamente os grupos de distribuição e verificar as restrições de cada mensagem que passa pelo sistema.

Quando você envia uma mensagem para um usuário que aceita ou recusa mensagens de um grupo de distribuição ou envia uma mensagem que passa por um conector que aceita ou recusa mensagem de um grupo de distribuição, o categorizador de mensagens precisa expandir a associação do grupo de distribuição, obter a lista completa de DNs dos membros e comparar a lista de DNs com os DNs do remetente da lista. Uma operação de acesso ou de negação ocorre quando há correspondência de um DN em ambas as listas. Se um grupo de distribuição estiver aninhado em outro grupo de distribuição, a distribuição aninhada também será expandida.

O valor RestrictionMethod determina como o categorizador processará as restrições. Se você definir o valor de RestrictionMethod como 2, os componentes de transporte nesse servidor que executa o Exchange Server não expandirão a associação de grupos de distribuição quando o servidor verificar restrições. Essa configuração fornece o melhor desempenho para verificações de restrição. Além disso, para que a entrada de Registro RestrictionMethod entre em vigor, todos os grupos de distribuição que incluírem usuários com restrições de entrega devem ser simples. Isto é, os grupos de distribuição restritos não têm grupos de distribuição aninhados.

Para resolver este aviso, não aninhe grupos de distribuição em outros grupos de distribuição utilizados para restrições de entrega, quando a verificação de restrição simples estiver ativada.

Para obter mais informações

Para obter mais informações sobre a verificação de restrição não-hierárquica, consulte Considere a verificação da restrição não hierárquica.

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 895407 "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407) (em inglês).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949) (em inglês).

  • 812298 "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298) (em inglês).

Para obter mais informações sobre o valor de Registro RestrictionMethod, consulte o artigo 895407 da Base de Dados de Conhecimento Microsoft, "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e externas é mais lenta do que o esperado após a configuração das restrições de entrega baseadas em grupos de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Para obter mais informações sobre o valor de Registro , consulte o artigo 277872 da Base de Dados de Conhecimento Microsoft, "XCON: Connector Delivery Restrictions May Not Work Correctly" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


Nenhuma mensagem do remetente especificado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-03-07

A ferramenta Microsoft Exchange Server Analyzer Tool consulta o valor do atributo proxyAddress do serviço de diretório do Active Directory de todos os objetos do usuário para determinar se existe uma correspondência para o endereço SMTP do remetente local especificado pelo usuário.

Se for detectada uma correspondência com o proxyAddress de um objeto do usuário, o Exchange Server Analyzer procurará no Active Directory o valor do atributo msExchHomeServerName do objeto do usuário para saber se esse valor coincide com o nome do Exchange Server especificado pelo usuário.

Por fim, o Exchange Server Analyzer consulta a propriedade SenderAddress da classe Exchange_MessageTrackingEntry do Microsoft WMI (Instrumentação de Gerenciamento do Windows) no namespace root\MicrosoftExchangeV2 para identificar as mensagens rastreadas pelos logs de controle de mensagens, procedentes do remetente especificado pelo usuário.

Se não encontrar uma entrada do log de controle de mensagens com um valor da propriedade senderAddress que coincida com o legacyDN ou com o endereço SMTP do remetente especificado pelo usuário, o Exchange Server Analyzer exibirá um erro.

  • Esse processo indica que uma ou mais das condições a seguir são verdadeiras:

  • O remetente especificado pelo usuário não enviou quaisquer mensagens.

  • O período de retenção do log de controle de mensagens expirou e as entradas relevantes do log já foram excluídas.

  • O Controle de Mensagens não está habilitado para este servidor.

Para resolver esse problema:

  • Instrua o remetente especificado a enviar outra mensagem ao destinatário especificado.

  • Habilite o Centro de Controle de Mensagens.

  • Aumente o período de retenção do log de controle de mensagens ou controle uma mensagem mais atual.

Para obter mais informações sobre como habilitar o Centro de Controle de Mensagens, consulte "Como habilitar o Centro de Controle de Mensagens em um servidor" (http://go.microsoft.com/fwlink/?LinkId=71257) em "Solucionando problemas de fluxo de mensagens e de SMTP" no Guia de Roteamento de Transporte e do Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkID=67875).

Para obter mais informações sobre como usar o Controle de Mensagens, consulte o artigo 262162 da Base de Dados de Conhecimento Microsoft, "XADM: Usando o Centro de Controle de Mensagens para controlar uma mensagem (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162).


Nenhuma mensagem para o destinatário especificado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-12-07

A Ferramenta Microsoft® Exchange Server consulta o valor do atributo proxyAddress do serviço de diretório do Active Directory® de todos os objetos do usuário para detectar se existe uma correspondência para o endereço SMTP (Simple Mail Transfer Protocol) do remetente local especificado pelo usuário.

Se for detectada uma correspondência com o proxyAddress de um objeto do usuário, o Exchange Server Analyzer procurará no Active Directory o valor do atributo msExchHomeServerName do objeto do usuário para saber se esse valor coincide com o nome do Exchange Server especificado pelo usuário.

O Exchange Server Analyzer consulta a propriedade SenderAddress da classe WMI (da Instrumentação de Gerenciamento do Microsoft Windows®) Exchange_MessageTrackingEntry no namespace root\MicrosoftExchangeV2 para identificar as mensagens rastreadas pelos logs de controle de mensagens, procedentes do remetente especificado pelo usuário.

Por último, o Exchange Server Analyzer consulta a propriedade RecipientAddress da classe WMI Exchange_MessageTrackingEntry para identificar as mensagens rastreadas pelos logs de controle de mensagens para o destinatário especificado pelo usuário.

Se não encontrar uma entrada do log de controle de mensagens com um valor da propriedade RecipientAddress que coincida com o endereço SMTP do remetente especificado pelo usuário, o Exchange Server Analyzer exibirá um erro.

Esse processo indica que uma ou mais das condições a seguir são verdadeiras:

  • O remetente especificado pelo usuário não enviou quaisquer mensagens para o destinatário especificado pelo usuário.

  • O período de retenção do log de controle de mensagens expirou e as entradas relevantes do log já foram excluídas.

Para resolver esse problema:

  • Verifique se o endereço do destinatário especificado está correto.

  • Instrua o remetente especificado a enviar outra mensagem ao destinatário especificado.

  • Aumente o período de retenção do log de controle de mensagens ou controle uma mensagem mais atual.

Para obter mais informações sobre como aumentar o período de retenção de log do Centro de Controle de Mensagens, consulte "Como habilitar o Centro de Controle de Mensagens em um servidor" (em inglês) (http://go.microsoft.com/fwlink/?LinkID=71257).

Para obter mais informações sobre como usar o Controle de Mensagens, consulte o artigo 262162 da Base de Dados de Conhecimento Microsoft, "XADM: Usando o Centro de Controle de Mensagens para controlar uma mensagem (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162).


Nenhum status de fila disponível. Análise da fila SMTP anulada.
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-03-15

A ferramenta Microsoft Exchange Analyzer consulta a classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Microsoft Windows) para verificar o status das filas SMTP de um servidor Exchange.

SMTP é o protocolo de mensagens nativo para envio e transporte de mensagens no Exchange Server. Isso significa que os clientes usam SMTP para enviar mensagens e os servidores Exchange usam SMTP para entregar mensagens e dados de mensagens.

As propriedades da classe ExchangeLink do WMI retornam informações sobre os links de manipulação de mensagens (filas) entre servidores de mensagens. Um link pode conter zero ou mais objetos ExchangeQueue. Esse número depende do tráfego de mensagens atual no link.

O SMTP usa as filas SMTP para entregar mensagens interna e externamente. Durante a categorização e entrega de mensagens, o mecanismo de enfileiramento avançado envia mensagem por meio das filas SMTP de um servidor virtual SMTP. Se houver um problema na entrega da mensagem em qualquer ponto no processo, a mensagem permanecerá na fila em que ocorreu o problema.

Descrições de filas SMTP

Fila SMTP Descrição

[Nome de domínio local] (Entrega Local)

Contém mensagens enfileiradas no servidor Exchange para entrega local em um armazenamento de caixas de correio ou de pastas públicas do Exchange.

Mensagens aguardando pesquisa de diretório

Contém mensagens para destinatários que ainda não foram resolvidas no serviço de diretório do Microsoft Active Directory. As mensagens também são mantidas na fila enquanto listas de distribuição são expandidas.

Mensagens aguardando para serem roteadas

Retém as mensagens até que o servidor do próximo destino delas seja determinado e as move para as respectivas filas de link.

Entrega remota

[Nome do conector|

Nome do servidor| Domínio remoto]

Retém as mensagens destinadas para entrega remota. O nome da fila corresponde ao destino de entrega remota, que pode ser um conector, um servidor ou um domínio.

Destino final atualmente inacessível

O servidor de destino final para essas mensagens não pode ser atingido. Por exemplo, o Exchange não pode determinar um caminho de rede para o destino final.

Pré-envio

Retém as mensagens que foram reconhecidas e aceitas pelo serviço SMTP. O processamento dessas mensagens não começou.

Envio pendente de mensagens de DSN

Contém notificações de status de entrega, também conhecidas como notificações de falha na entrega que estão prontas para serem entregues pelo Exchange.

Observação As seguintes operações não estão disponíveis para essa fila:

  • Excluir Todas as Mensagens (nenhuma notificação de falha na entrega)

  • Excluir Todas as Mensagens (notificação de falha na entrega)

Fila de repetição de mensagens com falha

Contém mensagens em que ocorreu falha para algum tipo de envio de fila, quase sempre antes de qualquer outro processamento estar em execução. Por padrão, as mensagens nessa fila são reprocessadas em 60 minutos.

Mensagens enfileiradas para entrega adiada

Contém mensagens enfileiradas para entrega posteriormente, incluindo mensagens que foram enviadas por versões mais antigas do Outlook. (Você pode definir essa opção em computadores clientes do Outlook.)

Versões anteriores do Outlook dependem do MTA (agente de transferência de mensagem) para entrega da mensagem. Agora, no entanto, o SMTP controla a entrega de mensagem, não o MTA. Portanto, as mensagens enviadas por versões mais antigas do Outlook tratam a entrega adiada de forma diferente.

Essas mensagens permanecem nessa fila até o horário de entrega agendado.

Se o Exchange Analyzer não concluir a consulta com êxito para a classe ExchangeLink do WMI de um servidor, o Exchange Analyzer exibirá um erro.

Esse erro indica que a consulta WMI não conseguiu recuperar os dados solicitados.

As causas prováveis desse erro são:

  • A conta que executa o Exchange Analyzer não tem permissões suficientes para consultar classes WMI.

  • Um problema de rede impede que o Exchange Analyzer entre em contato com o computador.

  • Uma condição transitória de origem desconhecida provocou um tempo limite para a consulta.

Para corrigir esse erro, proceda da seguinte forma:

  1. Verifique se o computador do Exchange Server foi iniciado e está conectado à rede.

  2. Use o comando PING para ver se o computador do Exchange Server está acessível.

  3. Se houver um firewall, verifique se as portas de RPC (chamada de procedimento remoto) estão bloqueadas.

  4. Examine as permissões da conta na qual o Exchange Analyzer está sendo executado. A conta na qual o Exchange Analyzer está sendo executado deve ter permissões de Administrador local em cada servidor Exchange que ele verifica.

    Como alternativa, você pode conceder permissão específica de WMI para a conta na qual o Exchange Analyzer está sendo executado:

    1. No computador do Exchange, abra a árvore do MMC (Console de Gerenciamento Microsoft) Gerenciamento do Computador.

    2. Em Serviços e Aplicativos, clique com o botão direito em Controle WMI e clique em Propriedades.

    3. Na página Propriedade dos Controles WMI, clique na guia Segurança e expanda Raiz.

    4. Selecione a pasta CIMV2 e clique em Segurança.

    5. Na página Segurança para ROOT\CIMV2, adicione a conta sob a qual o Exchange Analyzer está sendo executado.

  5. Selecione a conta adicionada na Etapa 5 acima. Em Permissões para Conta_Selecionada, na coluna Permitir, selecione Habilitação Remota e Ler Segurança e clique em OK.

Para obter mais informações sobre como solucionar problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento Microsoft, "Como solucionar problemas de conectividade de rede" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Para obter mais informações sobre como solucionar problemas de conectividade da ferramenta Exchange Best Practices Analyzer Tool, consulte "Solucionando problemas de conectividade da ferramenta Microsoft Exchange Best Practices Analyzer Tool" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56285).

Para obter mais informações sobre requisitos de portas, consulte o artigo 832017 da Base de Dados de Conhecimento Microsoft, "Visão geral de serviço e requisitos de porta de rede para o sistema Windows Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Nenhum servidor ou domínio remoto estava disponível para testes de registros de DNS
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-07-06

A Ferramenta Microsoft® Exchange Server Analyzer tenta identificar e construir uma lista de FQDN (Nome de Domínio Totalmente Qualificado), endereços IP e nomes de domínio de servidores remotos aos quais mensagens em uma fila de entrega remota são destinadas.

A lista de FQDNs, endereços IP e nomes de domínio de servidores remotos é construída da seguinte forma:

  • A propriedade msExchSmtpFullyQualifiedDomainName do objeto do serviço de diretório Active Directory® do servidor virtual do protocolo SMTP é consultada.

    Observação:
    A propriedade msExchSmtpFullyQualifiedDomainName, por sua vez, é lida a partir da propriedade msExchTargetBridgeheadServersDN de um objeto de diretório de conector de grupo de roteamento quando é consultada em relação a servidores bridgehead de destino designados
  • A propriedade msExchSmtpSmartHost do objeto do conector SMTP do Active Directory é consultada em relação ao host inteligente designado para um conector SMTP.

  • A propriedade LinkName da classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) é consultada em relação a conexões diretas com servidores remotos.

Se o Exchange Server Analyzer determinar que a tentativa para construir essa lista não resultou em nenhuma entrada, ele exibirá um erro.

Esse erro indica:

  • Podem haver problemas de conexão do Active Directory ou de rede intermitente que estão causando problemas de fluxo de mensagens.

  • A conta que executa o Exchange Server Analyzer pode não ter permissões suficientes para consultar as informações.

Para corrigir esse erro

  1. Verifique se o computador do Exchange Server foi iniciado e está conectado à rede.

  2. Verifique se você tem conectividade de rede para um controlador de domínio do Active Directory.

  3. Especifique um controlador de domínio do Active Directory no Exchange Server Analyzer.

  4. Use o comando PING para verificar se o computador do Exchange Server está acessível.

  5. Se houver um firewall, verifique se as portas RPC estão bloqueadas.

  6. Examine as permissões da conta na qual o Exchange Server Analyzer está sendo executado. A conta na qual o Exchange Server Analyzer está sendo executado deve ter permissões de Administrador local em cada computador do Exchange Server que ele verifica.

Para obter mais informações sobre problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft , "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Para obter mais informações sobre problemas de conectividade do Exchange Server Analyzer, consulte "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56285).

Para obter mais informações sobre requisitos de portas, consulte o artigo 832017 da Base de Dados de Conhecimento da Microsoft, "Visão geral de serviço e requisitos de porta de rede para o sistema do Windows Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Nenhum servidor disponível para testes de comandos de SMTP
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-16

A ferramenta Microsoft® Exchange Server Analyzer Tool tenta identificar e criar uma lista de FQDNs (nomes de domínio totalmente qualificados), endereços IP e nomes de domínio de servidores remotos aos quais as mensagens de uma fila de entrega remota estão destinadas.

A lista de FQDNs, endereços IP e nomes de domínio de servidores remotos é criada da seguinte forma:

  • A propriedade msExchSmtpFullyQualifiedDomainName do objeto do serviço de diretório do Active Directory® do servidor virtual SMTP é consultada.

    Observação:
    A propriedade msExchSmtpFullyQualifiedDomainName, por sua vez, é lida na propriedade msExchTargetBridgeheadServersDN de um objeto de diretório de conector de grupo de roteamento quando é consultada em relação a servidores bridgehead de destino designados.
  • A propriedade msExchSmtpSmartHost do objeto do conector SMTP do Active Directory é consultada em relação ao host inteligente designado para um conector SMTP.

  • A propriedade LinkName da classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) é consultada em relação a conexões diretas com servidores remotos.

Se determinar que a tentativa de criar essa lista não resultou em nenhuma entrada, o Exchange Server Analyzer exibirá um erro.

Esse erro indica o seguinte:

  • Problemas de conexão intermitente do Active Directory ou de rede podem estar provocando problemas de fluxo de mensagens.

  • A conta que executa o Exchange Server Analyzer pode não ter permissões suficientes para consultar as informações.

Para corrigir esse erro

  1. Verifique se o servidor que está executando o servidor Exchange foi iniciado e está conectado à rede.

  2. Verifique se você tem conectividade de rede para um controlador de domínio do Active Directory.

  3. Especifique um controlador de domínio do Active Directory no Exchange Server Analyzer.

  4. Use o comando PING para verificar se o servidor Exchange está acessível.

  5. Se houver um firewall, verifique se as portas de RPC (chamada de procedimento remoto) estão bloqueadas.

  6. Examine as permissões da conta na qual o Exchange Server Analyzer está sendo executado. A conta na qual o Exchange Server Analyzer está sendo executado deve ter permissões de Administrador local em cada computador verificado do Exchange Server.

Para obter mais informações sobre problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento Microsoft , "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487) (pode estar em inglês).

Para obter mais informações sobre problemas de conectividade do Exchange Server Analyzer, consulte "Solucionando problemas de conexão do Microsoft Exchange Server Best Practices Analyzer Tool" (http://go.microsoft.com/fwlink/?LinkId=56285) (pode estar em inglês).

Para obter mais informações sobre requisitos de portas, consulte o artigo 832017 da Base de Dados de Conhecimento Microsoft, "Visão geral de serviço e requisitos de porta de rede para o sistema Windows Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017) (pode estar em inglês).


Nenhum servidor estava disponível para testes de conectividade
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-07-07

A Ferramenta Microsoft® Exchange Server Analyzer tenta identificar e construir uma lista de FQDN (Nome de Domínio Totalmente Qualificado), endereços IP e nomes de domínio de servidores remotos aos quais mensagens em uma fila de entrega remota são destinadas.

  • A lista de FQDNs, endereços IP e nomes de domínio de servidores remotos é construída da seguinte forma:

  • A propriedade msExchSmtpFullyQualifiedDomainName do objeto do serviço de diretório Active Directory® do servidor virtual do protocolo SMTP é consultada.

    Observação:
    A propriedade msExchSmtpFullyQualifiedDomainName, por sua vez, é lida a partir da propriedade msExchTargetBridgeheadServersDN de um objeto de diretório de conector de grupo de roteamento quando é consultada em relação a servidores bridgehead de destino designados
  • A propriedade msExchSmtpSmartHost do objeto do conector SMTP do Active Directory é consultada em relação ao host inteligente designado para um conector SMTP.

  • A propriedade LinkName da classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) é consultada em relação a conexões diretas com servidores remotos.

Se o Exchange Server Analyzer determinar que a tentativa para construir essa lista não resultou em nenhuma entrada, ele exibirá um erro.

Esse erro indica:

  • Podem haver problemas de conexão do Active Directory ou de rede intermitente que estão causando problemas de fluxo de mensagens.

  • A conta que executa o Exchange Server Analyzer pode não ter permissões suficientes para consultar as informações.

Para corrigir esse erro

  1. Verifique se o computador do Exchange Server foi iniciado e está conectado à rede.

  2. Verifique se você tem conectividade de rede para um controlador de domínio do Active Directory.

  3. Especifique um controlador de domínio do Active Directory no Exchange Server Analyzer.

  4. Use o comando PING para verificar se o computador do Exchange Server está acessível.

  5. Se houver um firewall, verifique se as portas RPC estão bloqueadas.

  6. Examine as permissões da conta na qual o Exchange Server Analyzer está sendo executado. A conta na qual o Exchange Server Analyzer está sendo executado deve ter permissões de Administrador local em cada computador do Exchange Server que ele verifica.

Para obter mais informações sobre problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft , "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Para obter mais informações sobre problemas de conectividade do Exchange Server Analyzer, consulte "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56285).

Para obter mais informações sobre requisitos de portas, consulte o artigo 832017 da Base de Dados de Conhecimento da Microsoft, "Visão geral de serviço e requisitos de porta de rede para o sistema do Windows Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Nenhum servidor estava disponível para verificações de nome de instância de SMTP
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-07-07

A Ferramenta Microsoft® Exchange Server Analyzer tenta identificar e construir uma lista de FQDN (Nome de Domínio Totalmente Qualificado), endereços IP e nomes de domínio de servidores remotos aos quais mensagens em uma fila de entrega remota são destinadas.

A lista de FQDNs, endereços IP e nomes de domínio de servidores remotos é construída da seguinte forma:

  • A propriedade msExchSmtpFullyQualifiedDomainName do objeto do serviço de diretório Active Directory® do servidor virtual do protocolo SMTP é consultada.

    Observação:
    A propriedade msExchSmtpFullyQualifiedDomainName, por sua vez, é lida a partir da propriedade msExchTargetBridgeheadServersDN de um objeto de diretório de conector de grupo de roteamento quando é consultada em relação a servidores bridgehead de destino designados
  • A propriedade msExchSmtpSmartHost do objeto do conector SMTP do Active Directory é consultada em relação ao host inteligente designado para um conector SMTP.

  • A propriedade LinkName da classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) é consultada em relação a conexões diretas com servidores remotos.

Se o Exchange Server Analyzer determinar que a tentativa para construir essa lista não resultou em nenhuma entrada, ele exibirá um erro.

Esse erro indica:

  • Podem haver problemas de conexão do Active Directory ou de rede intermitente que estão causando problemas de fluxo de mensagens.

  • A conta que executa o Exchange Server Analyzer pode não ter permissões suficientes para consultar as informações.

Para corrigir esse erro

  1. Verifique se o computador do Exchange Server foi iniciado e está conectado à rede.

  2. Verifique se você tem conectividade de rede para um controlador de domínio do Active Directory.

  3. Especifique um controlador de domínio do Active Directory no Exchange Server Analyzer.

  4. Use o comando PING para verificar se o computador do Exchange Server está acessível.

  5. Se houver um firewall, verifique se as portas RPC estão bloqueadas.

  6. Examine as permissões da conta na qual o Exchange Server Analyzer está sendo executado. A conta na qual o Exchange Server Analyzer está sendo executado deve ter permissões de Administrador local em cada computador do Exchange Server que ele verifica.

Para obter mais informações sobre problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft , "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Para obter mais informações sobre problemas de conectividade do Exchange Server Analyzer, consulte "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56285).

Para obter mais informações sobre requisitos de portas, consulte o artigo 832017 da Base de Dados de Conhecimento da Microsoft, "Visão geral de serviço e requisitos de porta de rede para o sistema do Windows Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Configuração de Cache de Serviço de Roteamento Diferente do Padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se a configuração padrão de cache de serviço de roteamento foi alterada:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\

Se o Exchange Server Analyzer verificar que o valor de Registro ServerCacheRefreshInterval foi criado manualmente, alterando a configuração binária padrão de 900 do Exchange Server, o Exchange Server Analyzer exibirá um aviso. Por padrão, o valor de Registro ServerCacheRefreshInterval não é criado pela instalação do Exchange Server. Entretanto, o valor de Registro ServerCacheRefreshInterval pode ser criado manualmente após a instalação do Exchange Server para alterar a configuração padrão de cache de serviço de roteamento. Se o valor de Registro for criado manualmente e sua configuração estiver incorreta, o servidor Exchange poderá ter problemas de fluxo de mensagens.

É recomendável que o valor de Registro ServerCacheRefreshInterval seja criado ou modificado somente após rigorosa consideração. Os valores padrão nos binários do Exchange Server foram cuidadosamente selecionados para um desempenho ideal para uso na maioria dos ambientes do Exchange Server. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento padrão do Exchange Server, configurando manualmente o Registro. Para cumprir as práticas recomendadas, se o valor de Registro ServerCacheRefreshInterval existir, talvez você deseje excluí-lo para retornar o servidor Exchange à configuração binária padrão do cache do serviço de roteamento. Sua decisão, entretanto, depende das definições de configuração personalizada do Exchange Server ou do ambiente Exchange.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. No entanto, talvez você deseje retornar o valor de Registro à configuração padrão editando o Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como fazer isso, consulte o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Clique em Iniciar, clique em Executar, digite Regedit e clique em OK.

  2. Na árvore do console, localize e clique na seguinte chave do Registro: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\RESvc\Parameters\

  3. No painel de detalhes, clique com o botão direito no valor do Registro ServerCacheRefreshInterval. Altere os dados do valor para 900.

  4. Opcionalmente, no painel de detalhes, você pode clicar com o botão direito no valor de Registro ServerCacheRefreshInterval e clicar em Excluir. Confirme a exclusão do valor de Registro clicando em Sim na caixa de diálogo.

  5. Reinicie o servidor Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como editar o Registro do Microsoft Windows, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 322755, "Como fazer o backup, editar e restaurar o Registro no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Como fazer o backup, editar e restaurar o Registro no Windows XP e Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valor de Registro LdapRequestTimeLimit SMTP não padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o padrão LdapRequestTimeLimit foi alterado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Se o Analisador do Exchange Server detectar que o valor do Registro LdapRequestTimeLimit foi criado manualmente para alterar a configuração binária do servidor Exchange padrão de 600 segundos, o Analisador do Exchange Server exibirá uma mensagem de aviso não padrão. Por padrão, o valor de Registro LdapRequestTimeLimit não é criado pela instalação do Exchange Server. Entretanto, o valor do Registro LdapRequestTimeLimit pode ser criado manualmente depois da instalação do Exchange Server para alterar o tempo máximo, em segundos, que uma única solicitação LDAP aguardará na fila. Se o valor de Registro for criado manualmente e sua configuração estiver incorreta, o servidor Exchange poderá experimentar problemas de transporte de mensagens.

Recomenda-se que o valor do Registro LdapRequestTimeLimit seja criado ou modificado somente após cuidadosa consideração. Os valores padrão nos binários para o servidor Exchange foram cuidadosamente selecionados para o desempenho ideal para uso na maioria dos ambientes do servidor Exchange. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento padrão do Exchange Server, configurando manualmente o Registro. Para cumprir as práticas recomendadas, se o valor de Registro LdapRequestTimeLimit existir, talvez você deseje excluí-lo para retornar o servidor Exchange à configuração binária padrão.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. No entanto, talvez você deseje retornar o valor de Registro à configuração padrão editando o Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como fazer isso, consulte o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Clique em Iniciar, clique em Executar, digite Regedit e clique em OK.

  2. Na árvore do console, localize e clique na seguinte chave de Registro: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. No painel de detalhes, clique com o botão direito no valor do Registro LdapRequestTimeLimit. Altere os dados do valor para 600.

  4. Opcionalmente, no painel de detalhes você pode clicar com o botão direito no valor de Registro LdapRequestTimeLimit e clicar em Excluir. Confirme a exclusão do valor de Registro clicando em Sim na caixa de diálogo.

  5. Reinicie o servidor Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como editar o Registro do Microsoft Windows, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 322755, "Como fazer o backup, editar e restaurar o Registro no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Como fazer o backup, editar e restaurar o Registro no Windows XP e Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valor de Registro LdapResultTimeout do SMTP não padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o padrão LdapResultTimeout foi alterado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Se o Exchange Server Analyzer perceber que a chave de Registro LdapResultTimeout foi criada manualmente, alterando a configuração binária padrão de 121 segundos do servidor Exchange, o Exchange Server Analyzer exibirá uma mensagem de aviso não-padrão. Por padrão, a chave do Registro LdapResultTimeout não é criada por uma instalação do Exchange Server. Contudo, a chave do Registro LdapResultTimeout pode ser criada manualmente após a instalação do Exchange Server para alterar o valor do tempo limite. LdapResultTimeout é o tempo máximo em segundos que os threads de conclusão do LDAP, para as conexões LDAP do categorizador, aguardam para serem processados. Se o tempo limite expirar e nenhum resultado novo for recebido de um servidor de catálogo global, as pesquisas pendentes falharão na conexão com LDAP_SERVER_DOWN. Esse processo habilita as pesquisas pendentes para serem reemitidas para novas conexões. Se o valor de Registro for criado manualmente e sua configuração estiver incorreta, o servidor Exchange poderá experimentar problemas de transporte de mensagens.

É recomendável que o valor de Registro LdapResultTimeout seja criado ou modificado somente após rigorosa consideração. Os valores padrão nos binários do Exchange Server foram cuidadosamente selecionados para um desempenho ideal para uso na maioria dos ambientes do Exchange Server. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento padrão do Exchange, configurando manualmente o Registro. Para cumprir as práticas recomendadas, se o valor de Registro LdapResultTimeout existir, talvez você deseje excluí-lo para retornar o servidor Exchange à configuração binária padrão.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. No entanto, talvez você deseje retornar o valor de Registro à configuração padrão editando o Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como fazer isso, consulte o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Clique em Iniciar, clique em Executar, digite Regedit e clique em OK.

  2. Na árvore do console, localize e clique na seguinte chave de Registro: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. No painel de detalhes, clique com o botão direito no valor de Registro LdapResultTimeout. Altere os dados do valor para 121.

  4. Opcionalmente, no painel de detalhes você pode clicar com o botão direito no valor de Registro LdapResultTimeout e clicar em Excluir. Confirme a exclusão do valor de Registro clicando em Sim na caixa de diálogo.

  5. Reinicie o servidor Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como editar o Registro do Microsoft Windows, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 322755, "Como fazer o backup, editar e restaurar o Registro no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Como fazer o backup, editar e restaurar o Registro no Windows XP e Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valor de Registro MaxConnectionRetries do SMTP diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o padrão MaxConnectionRetries foi alterado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Se o Exchange Server Analyzer verificar que o valor de Registro MaxConnectionRetries foi criado manualmente, alterando a configuração binária padrão de 20 do Exchange Server, o Exchange Server Analyzer exibirá uma mensagem de aviso não padrão. Por padrão, o valor de Registro MaxConnectionRetries não é criado pela instalação do Exchange Server. No entanto, o valor de Registro MaxConnectionRetries pode ser criado manualmente após a instalação do Exchange Server para alterar o valor. O valor MaxConnectionRetries define o número máximo de vezes que uma única categorização pode ter uma falha de sua conexão LDAP e ser emitida novamente em uma nova conexão. Após a falha da categorização de conexão de MaxConnectionRetries, ela é colocado na fila de repetição. Se o valor de Registro for criado manualmente e sua configuração estiver incorreta, o Exchange Server poderá ter problemas de transporte de mensagens.

É recomendável que o valor de Registro MaxConnectionRetries só seja criado ou modificado após uma avaliação cuidadosa. Os valores padrão nos binários do Exchange Server foram cuidadosamente selecionados para um desempenho ideal para uso na maioria dos ambientes do Exchange Server. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento padrão do Exchange Server, configurando manualmente o Registro. Para cumprir as práticas recomendadas, se o valor de Registro MaxConnectionRetries existir, talvez você queira excluí-lo para retornar o Exchange Server à configuração binária padrão.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. No entanto, talvez você deseje retornar o valor de Registro à configuração padrão editando o Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como fazer isso, consulte o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Clique em Iniciar, clique em Executar, digite Regedit e clique em OK.

  2. Na árvore do console, localize e clique na seguinte chave de Registro: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. No painel de detalhes, clique com o botão direito no valor de Registro MaxConnectionRetries. Altere o valor para 20.

  4. Opcionalmente, no painel de detalhes você pode clicar com o botão direito no valor de Registro MaxConnectionRetries e clicar em Excluir. Confirme a exclusão do valor de Registro clicando em Sim na caixa de diálogo.

  5. Reinicie o Exchange Server.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows". (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)

Para obter mais informações sobre como editar o Registro do Microsoft Windows, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 322755, "Como fazer o backup, editar e restaurar o Registro no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Como fazer o backup, editar e restaurar o Registro no Windows XP e Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valor de Registro MaxLdapConnections SMTP não padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o padrão MaxLdapConnections foi alterado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Se o Exchange Server Analyzer perceber que o valor de Registro MaxLdapConnections foi criado manualmente, alterando a configuração binária padrão de 8 do servidor Exchange, o Exchange Server Analyzer exibirá uma mensagem de aviso não padrão. Por padrão, o valor de Registro MaxLdapConnections não é criado pela instalação do Exchange. Entretanto, o valor do Registro MaxLdapConnections pode ser criado manualmente após a instalação do Exchange para alterar o valor. O valor MaxLdapConnections define o número máximo de conexões LDAP que o categorizador abre para um único servidor de catálogo global. Se o valor de Registro for criado manualmente e sua configuração estiver incorreta, o servidor Exchange poderá experimentar problemas de transporte de mensagens.

Cuidado:
O valor de Registro MaxLdapConnections deve corresponder sempre à definição do valor de Registro HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPoolThreads.

É recomendável que o valor de Registro MaxLdapConnections só seja criado ou modificado após uma avaliação cuidadosa. Os valores padrão nos binários para o servidor Exchange foram cuidadosamente selecionados para o desempenho ideal para uso na maioria dos ambientes do servidor Exchange. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento padrão do Exchange Server, configurando manualmente o Registro. Para cumprir as práticas recomendadas, se o valor de Registro MaxLdapConnections existir, talvez você deseje excluí-lo para retornar o servidor Exchange à configuração binária padrão.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. No entanto, talvez você deseje retornar o valor de Registro à configuração padrão editando o Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como fazer isso, consulte o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Clique em Iniciar, clique em Executar, digite Regedit e clique em OK.

  2. Na árvore do console, localize e clique na seguinte chave do Registro: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. No painel de detalhes, clique com o botão direito no valor do Registro MaxLdapConnections. Altere os dados do valor para 8.

  4. Opcionalmente, no painel de detalhes você pode clicar com o botão direito no valor de Registro MaxLdapConnections e clicar em Excluir. Confirme a exclusão do valor de Registro clicando em Sim na caixa de diálogo.

  5. Reinicie o servidor Exchange.

Antes de editar o Registro e para obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows". (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)

Para obter mais informações sobre como editar o Registro do Microsoft Windows, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 322755, "Como fazer o backup, editar e restaurar o Registro no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Como fazer o backup, editar e restaurar o Registro no Windows XP e Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valor de Registro MaxPendingSearches do SMTP não padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o padrão MaxPendingSearches foi alterado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Se o Exchange Server Analyzer perceber que o valor de Registro MaxPendingSearches foi criado manualmente, alterando a configuração binária padrão de 60 do servidor Exchange, o Exchange Server Analyzer exibirá uma mensagem de aviso não padrão. Por padrão, o valor de Registro MaxPendingSearches não é criado pela instalação do Exchange Server. No entanto, o valor de Registro MaxPendingSearches pode ser criado manualmente após a instalação do Exchange Server para alterar o valor. O valor MaxPendingSearches define o número de pesquisas LDAP pendentes que o categorizador mantém em um momento para um servidor de catálogo global particular. O número máximo de pesquisas pendentes por conexão era 1.024 no Exchange 2000 Server anterior ao SP3. O valor padrão no Exchange 2000 Server SP3 e no Exchange Server 2003 está definido como 60. Por exemplo, a alteração desse valor do padrão de 60 para 30 reduz o número total de pesquisas LDAP que o categorizador mantém em um servidor de catálogo global.

Se o valor de Registro for criado manualmente e sua configuração estiver incorreta, o servidor Exchange poderá experimentar problemas de transporte de mensagens.

É recomendável que o valor de Registro MaxPendingSearches só seja criado ou modificado após uma avaliação cuidadosa. Os valores padrão nos binários para o servidor Exchange foram cuidadosamente selecionados para o desempenho ideal para uso na maioria dos ambientes do servidor Exchange. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento padrão do Exchange, configurando manualmente o Registro. Para cumprir as práticas recomendadas, se o valor de Registro MaxPendingSearches existir, talvez você deseje excluí-lo para retornar o servidor Exchange à configuração binária padrão.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. No entanto, talvez você deseje retornar o valor de Registro à configuração padrão editando o Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como fazer isso, consulte o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Clique em Iniciar, clique em Executar, digite Regedit e clique em OK.

  2. Na árvore do console, localize e clique na seguinte chave de Registro: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. No painel de detalhes, clique com o botão direito no valor de Registro MaxPendingSearches. Altere os dados do valor para 60.

  4. Opcionalmente, no painel de detalhes você pode clicar com o botão direito no valor de Registro MaxPendingSearches e clicar em Excluir. Confirme a exclusão do valor de Registro clicando em Sim na caixa de diálogo.

  5. Reinicie o servidor Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como editar o Registro do Microsoft Windows, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

322755, "Como fazer backup, editar e restaurar o Registro do Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

322756, "Como fazer backup, editar e restaurar o Registro no Windows XP e Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valor de Registro MaxSearchBlockSize SMTP não padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o padrão MaxSearchBlockSize foi alterado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Se o Exchange Server Analyzer perceber que o valor de Registro MaxSearchBlockSize foi criado manualmente, alterando a configuração binária padrão de 20 do servidor Exchange, o Exchange Server Analyzer exibirá uma mensagem de aviso não padrão. Por padrão, o valor de Registro MaxSearchBlockSize não é criado pela instalação do Exchange Server. Entretanto, o valor do Registro MaxSearchBlockSize pode ser criado manualmente após a instalação do Exchange Server para alterar o valor. O valor MhelpsBlockSize define o número máximo de pesquisas do categorizador que podem ser enviadas como uma única pesquisa LDAP. Por meio da configuração do número máximo de pesquisas do categorizador, você pode ajudar a simplificar os filtros de pesquisa do categorizador.

Esse processo permite que as pesquisas pendentes sejam reenviadas para novas conexões. Se o valor de Registro for criado manualmente e sua configuração estiver incorreta, o servidor Exchange poderá experimentar problemas de transporte de mensagens.

É recomendável que o valor de Registro MaxSearchBlockSize só seja criado ou modificado após uma avaliação cuidadosa. Os valores padrão nos binários do Exchange Server foram cuidadosamente selecionados para um desempenho ideal para uso na maioria dos ambientes do servidor Exchange. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento padrão do Exchange Server, configurando manualmente o Registro. Para cumprir as práticas recomendadas, se o valor de Registro MaxSearchBlockSize existir, talvez você deseje excluí-lo para retornar o servidor Exchange à configuração binária padrão.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. No entanto, talvez você deseje retornar o valor de Registro à configuração padrão editando o Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como fazer isso, consulte o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Clique em Iniciar, clique em Executar, digite Regedit e clique em OK.

  2. Na árvore do console, localize e clique na seguinte chave de Registro: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. No painel de detalhes, clique com o botão direito no valor de Registro MaxSearchBlockSize. Altere os dados do valor para 20.

  4. Opcionalmente, no painel de detalhes você pode clicar com o botão direito no valor de Registro MaxSearchBlockSize e clicar em Excluir. Confirme a exclusão do valor de Registro clicando em Sim na caixa de diálogo.

  5. Reinicie o servidor Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como editar o Registro do Microsoft Windows, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 322755, "Como fazer o backup, editar e restaurar o Registro no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Como fazer o backup, editar e restaurar o Registro no Windows XP e Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valor de Registro TopoRecheckSecs de SMTP não-padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se ela foi alterada a partir do valor padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\TopoRecheckSecs.

Se o Exchange Server Analyzer detectar que o valor de TopoRecheckSecs não é igual ao valor padrão de 900 segundos, será exibida uma mensagem de configuração não-padrão. O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária. Como o DSAccess usa o valor do Registro TopoRecheckSecs para definir o intervalo de reconstrução da lista de catálogo global, uma configuração incorreta poderá provocar a redução no desempenho. A prática recomendada é usar as definições da configuração padrão do Exchange Server sempre que possível. Contudo, se esse valor do Registro estiver presente, ele poderá ter sido adicionado e configurado de acordo com a recomendação do Atendimento Microsoft para corrigir um problema ocorrido anteriormente. Considere a possibilidade de remover esse valor do Registro, a menos que ele tenha sido adicionado e configurado por recomendação do Atendimento Microsoft ou por orientação de outro especialista.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para excluir a chave do Registro TopoRecheckSecs

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. No painel da direita, localize e exclua o valor de TopoRecheckSecs .

  4. Feche o editor de Registro.

  5. Para tornar essa mudança definitiva, reinicie o Atendedor do Sistema.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como otimizar o posicionamento do catálogo global no Exchange Server, consulte Compreendendo e solucionando problemas de acesso a diretório (http://go.microsoft.com/fwlink/?LinkId=39012) (em inglês).


Servidor gateway não pertencente ao Exchange não definido como host inteligente
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-09

A ferramenta Microsoft® Exchange Server Analyzer consulta no serviço de diretório do Active Directory® o valor do atributo distingushedName da classe de objeto protocolCfgSMTPServer para listar todas as instâncias de servidor virtual SMTP (Simple Mail Transfer Protocol) no gateway do Exchange especificado pelo usuário.

Em seguida, o Exchange Server Analyzer consulta no Active Directory o valor dos atributos msExchSourceBridgeheadServersDN e routingList de cada objeto msExchRoutingSMTPConnector encontrado, para saber se o conector SMTP tem uma das instâncias de servidor virtual SMTP detectada, definida como bridgehead local para um espaço de endereçamento SMTP externo.

Por último, o Exchange Server Analyzer consulta no Active Directory o valor do atributo msExchSmtpSmartHost em todos os conectores SMTP detectados (objeto msExchRoutingSMTPConnector) para saber se um deles foi designado como host inteligente para o servidor gateway não pertencente ao Exchange, especificado pelo usuário.

Ao detectar que o servidor gateway não pertencente ao Exchange, especificado pelo usuário, não está configurado como um host inteligente, o Exchange Server Analyzer exibirá um aviso.

Este aviso indica que não existe uma rota explícita configurada a partir do servidor gateway do Exchange, especificado pelo usuário para o servidor gateway não pertencente ao Exchange, especificado pelo usuário, e que outros servidores diferentes deste último podem rotear inadvertidamente mensagens para fora da organização.

Para resolver este problema, indique o servidor gateway não pertencente ao Exchange como um host inteligente para um conector SMTP.

Para exibir e configurar as definições do host inteligente

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP, por exemplo, Servidor Virtual SMTP Padrão e selecione Propriedades.

  4. Selecione a guia Entrega e clique em Avançado.

  5. Insira o host inteligente que você deseja usar. É possível identificar o host inteligente pelo nome de domínio totalmente qualificado ou por um endereço IP. Se você usar um endereço IP, deverá colocá-lo entre colchetes ([ ]). O Exchange verifica primeiro um nome de servidor e, depois, um endereço IP. Os colchetes identificam o valor como um endereço IP. Portanto, a pesquisa de DNS é ignorada.

  6. Se esse for um servidor executando o Exchange 2000 Server, marque, opcionalmente, a caixa de seleção Tentar entrega direta antes de enviar ao host inteligente.

  7. Clique em OK para salvar as alterações e clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre como configurar um conector de host inteligente, consulte o artigo 821911 da Base de Dados de Conhecimento Microsoft, "Como configurar o Exchange Server 2003 para usar um endereço IP de host inteligente" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821911) (em inglês).

Para obter mais informações sobre como usar conectores SMTP, consulte o artigo 294736 da Base de Dados de Conhecimento Microsoft, "Quando criar conectores SMTP no Exchange 2000 e versões posteriores" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736).

Para obter mais informações sobre conectores SMTP, consulte o Guia de Transporte e Roteamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Possível sobrecarga no categorizador
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos contadores de desempenho em computadores executando o Exchange 2000 Server ou Exchange Server 2003. Esse mecanismo coleta dados da Cat: Mensagens enviadas/s' e da Cat: Contadores de desempenho Categorizações concluídas/s do objeto de desempenho SMTP Server para analisar os dados de desempenho.

A Cat: o contador de desempenho Mensagens enviadas/s indica o número de mensagens enviadas por segundo ao categorizador, enquanto a Cat: Categorizações concluídas/s indica a taxa de categorizações concluídas por segundo.

O Exchange Server Analyzer compara a média do total dos dois contadores para detectar se são consistentemente enviadas mais mensagens do que as processadas.

Ao detectar que o número médio total de mensagens enviadas por segundo ao categorizador é consistentemente maior, em duas mensagens, do que o número médio total de mensagens concluídas por segundo, o Exchange Server Analyzer exibe um aviso.

O categorizador executa as seguintes operações principais:

  • Resolve e valida todos os destinatários.

  • Determina limites e restrições para todos os destinatários.

  • Expande listas de distribuição, caso necessário.

  • Determina se a mensagem é para entrega local ou remota.

Este aviso indica que o categorizador pode estar sob análise. As possíveis causas podem ser investigadas e corrigidas onde for possível.

A análise do categorizador pode ser causada por uma demanda para processar várias mensagens devido a:

  • UCE (e-mail comercial não solicitado) ou spam.

  • Profileração de vírus.

  • Problemas de desempenho no servidor.

Para corrigir esse aviso:

  • Descubra se a tensão no categorizador foi prevista ou procede de uma carga comum. Se a tensão no categorizador é oriunda de uma carga prevista, examine a orientação sobre o desempenho do Exchange neste artigos da Microsoft TechNet.

    • "Solucionando problemas de desempenho do Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).

    • "Guia de Desempenho e Escalabilidade do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576) (em inglês).

  • Se a tensão no categorizador não é oriunda de uma carga prevista, verifique se há epidemias de vírus ou spam que possam gerar a carga.


Possível problema de gateway
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-09

A ferramenta Microsoft® Exchange Server Analyzer envia uma mensagem de teste para uma conta externa definida pelo usuário, a partir do servidor executando o Exchange Server. O Exchange Server Analyzer verifica os logs de controle de mensagens do servidor para saber se ocorreram problemas na entrega da mensagem de teste.

Como parte dessa verificação, o Exchange Server Analyzer consulta a propriedade EntryType da classe Exchange_MessageTrackingEntry do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) no namespace root\MicrosoftExchangeV2 para determinar por que uma ou mais entradas do log de controle de mensagens foram criadas.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O log de rastreamento de mensagens pode ser verificado com sucesso.

  • A mensagem de teste não realizou com êxito a transferência externa da fila.

  • Não foi gerada uma notificação de falha na entrega.

  • Existe um valor de 1034 para a propriedade EntryType.

  • A mensagem alcançou o servidor gateway de saída local especificado do Exchange.

Este erro pode indicar a ocorrência de problema de conexão entre o servidor gateway de saída local especificado do Exchange e o servidor remoto.

Para resolver esse erro, use o utilitário NSlookup para examinar possíveis problemas com a resolução de DNS (Sistema de Nome de Domínio). Para problemas de conexão e protocolo, como erros de Host inacessível, use o Telnet.exe para tentar conectar ao computador de destino. Para solucionar problemas de erros de protocolo, aumente o log de diagnóstico para o serviço MSExchangeTransport do componente SMTP (Simple Mail Transfer Protocol ) e examine os logs para verificar se há erros. Como alternativa, você pode usar a ferramenta Monitor de Rede (Netmon.exe) para obter informações sobre erros de conexão de rede.

Para obter mais informações sobre como modificar configurações de log, consulte "How to Modify Logging Settings for MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489) (em inglês).

  • Artigo 821877 do Base de Dados de Conhecimento Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877) (em inglês).

  • Artigo 264054 do Base de Dados de Conhecimento Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054) (eminglês).


Possível problema Inetinfo
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos contadores de desempenho em computadores executando o Exchange 2000 Server ou Exchange Server 2003. Esse mecanismo coleta dados da Cat: Contador de desempenho Categorizações em andamento do objeto de desempenho SMTP Server para analisar os dados de desempenho.

A Cat: O contador de desempenho Categorizações em andamento mostra o número de categorizações em andamento.

Para essa consulta, o Exchange Server Analyzer recupera uma amostra a cada 6 segundos, por um período de 2 minutos. O Exchange Server Analyzer informa o valor médio do contador de desempenho no decorrer do intervalo de coleta.

Ao detectar que o número mínimo de categorizações em andamento durante o período da amostra nunca é igual a zero, o Exchange Server Analyzer exibirá um aviso.

O categorizador executa as seguintes operações principais:

  • Resolve e valida todos os destinatários.

  • Determina limites e restrições para todos os destinatários.

  • Expande listas de distribuição, caso necessário.

  • Determina se a mensagem é para entrega local ou remota.

Se o servidor não estiver sob carga pesada, este aviso pode indicar que o processo Inetinfo.exe ou os recursos dos quais o processo Inetinfo.exe depende estão com um deadlock.

O serviço SMTP (Simple Mail Transfer Protocol) é executado no processo Inetinfo.exe e quando as mensagens passam através do subsistema de transporte, o SMTP utiliza intensamente os recursos do IIS (Internet Information Services).

Um deadlock ocorre quando dois ou mais processos (ou threads) aguardam mutuamente a conclusão do outro, para que o processo possa continuar. Conseqüentemente, todos os processos (ou threads) param de responder (são desligados). Em um deadlock, a execução dos processos nunca termina e os recursos do sistema ficam ocupados. Isso impede a inicialização de outros trabalhos.

Para corrigir esse aviso:

  • Descubra se a tensão no categorizador foi prevista ou procede de uma carga comum. Se o categorizador não estiver sob carga intensa, use os recursos mencionados na seção "Mais informações", para identificar possíeis problemas de desempenho ocorrendo no processo Inetinfo.exe ou nos recursos relacionados.

  • Verifique se o processo Inetinfo.exe está funcionando.

  • Para verificar uma situação de deadlock no Inetinfo.exe, siga a orientação de depuração contida no artigo 919791 da Base de Dados de Conhecimento Microsoft "Como usar a ferramenta Diagnóstico de Depuração para solucionar problemas de alta utilização da CPU por um processo no IIS" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791).

Para obter mais informações

Para obter mais informações sobre o Inetinfo.exe, consulte "Internet Information Services" no Guia de Referência Técnica do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=72966) (em inglês).

Para obter mais informações sobre como solucionar um problema de processo com deadlock, consulte o artigo 919791 da Base de Dados de Conhecimento Microsoft "Como usar a ferramenta Diagnóstico de Depuração para solucionar problemas de alta utilização da CPU por um processo no IIS" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791).

Para obter mais informações sobre o desempenho do Exchange Server, consulte "Guia de Desempenho e Escalabilidade do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576).

Para obter mais informações sobre como solucionar problemas de desempenho do Exchange Server, consulte "Solucionando Problemas de Desempenho do Microsoft Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588).


O possível problema não é do gateway
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-09

A ferramenta Microsoft® Exchange Server Analyzer envia uma mensagem de teste para um endereço SMTP de destinatário externo definido pelo usuário, a partir do servidor executando o Exchange Server. O Exchange Server Analyzer verifica os logs de controle de mensagens do servidor para saber se ocorreram problemas na entrega da mensagem de teste.

Como parte dessa verificação, o Exchange Server Analyzer consulta a propriedade EntryType da classe Exchange_MessageTrackingEntry do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) no namespace root\MicrosoftExchangeV2 para determinar por que uma ou mais entradas do log de controle de mensagens foram criadas.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O log de controle de mensagens pode ser verificado com sucesso.

  • A mensagem de teste não realizou com êxito a transferência externa da fila.

  • Não foi gerada uma notificação de falha na entrega.

  • Existe um valor de 1034 para a propriedade EntryType.

  • A mensagem não alcançou o servidor gateway de saída local especificado do Exchange.

Este erro pode indicar que a mensagem de teste ainda está em uma das filas SMTP (Simple Mail Transfer Protocol) de entrega remota no servidor de envio e que há um problema na fila.

A fila Entrega Remota armazena mensagens destinadas à entrega remota. O nome da fila corresponde ao destino de entrega remota. Esse destino pode ser um conector, um servidor ou um domínio.

Para solucionar problemas de erros de protocolo, aumente o log de diagnóstico para o serviço MSExchangeTransport do componente SMTP e consulte os logs para verificar se há erros. Como alternativa, você pode usar a ferramenta Monitor de Rede (Netmon.exe) para obter informações sobre erros de conexão de rede. Para reproduzir o problema, force a fila a tentar novamente. Examine o log de eventos para obter possíveis erros associados ao serviço Armazenamento de Informações do Microsoft Exchange.

Para obter mais informações sobre como modificar configurações de log, consulte "How to Modify Logging Settings for MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489) (em inglês).

  • Artigo 821877 do Base de Dados de Conhecimento Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877) (em inglês).

  • Artigo 264054 do Base de Dados de Conhecimento Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054) (em inglês).


Possível proxy SMTP detectado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-12-06

A ferramenta Microsoft® Exchange Server Analyzer tenta enviar uma mensagem para uma conta Postmaster ou uma conta definida pelo usuário para o domínio SMTP.

A seguinte resposta padrão é esperada quando o Exchange Server Analyzer abre uma conexão de soquete com o servidor SMTP.

"220 Nome do computador . Nome do domínio .com Microsoft ESMTP MAIL Service, Versão: Número da versão pronta em Data Hora +0000"

Se receber uma resposta não padrão com uma cadeia de caracteres específica de terceiros, o Exchange Server Analyzer exibirá um erro.

Esse erro indica que pode existir um servidor proxy SMTP de terceiros em execução por trás do servidor remoto.

Se o banner SMTP padrão não foi personalizado propositalmente pelo administrador do Exchange Server, esse aviso poderá indicar que o Exchange Server está por trás de um proxy SMTP filtrando os comandos ESMTP (SMTP Estendidos) do Exchange Server.

Se os comandos ESMTP do Exchange Server forem filtrados, isso poderá afetar significativamente o desempenho do Exchange e gerar o comportamento descrito no artigo 320027 da Base de Dados de Conhecimento Microsoft, "Não é possível enviar ou receber emails atrás de um firewall Cisco PIX" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027) (em inglês).

Para obter mais informações sobre os banners SMTP personalizados, consulte o seguinte artigo da Base de Dados de Conhecimento Microsoft:

  • 281224: XCON: Como modificar o banner SMTP (em inglês) (http://go.microsoft.com/fwlink/?linkID=3052&kbid=281224).


Possível problema de desempenho do categorizador
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer consulta na classe WMI (Instrumentação de Gerenciamento do Windows®) ExchangeLink o valor do atributo TypePendingCategorization da instância do protocolo SMTP ProtocolName para obter o número de mensagens na fila SMTP 'Mensagens aguardando pesquisa de diretório' (MADL).

As propriedades da classe WMI ExchangeLink retornam informações sobre os links de manipulação de mensagens (filas) entre servidores de mensagens. Um link pode conter zero ou mais objetos ExchangeQueue. Esse número depende do tráfego de mensagens atual no link.

O Exchange Server Analyzer dispõe de um mecanismo de coleta de dados de desempenho, usado para consultar os objetos contadores de desempenho em computadores executando o Exchange 2000 Server ou Exchange Server 2003.

Ao detectar a presença de mais de cinqüenta mensagens na fila MADL, o Exchange Server Analyzer instrui o mecanismo de coleta de dados de desempenho a coletar dados dos contadores de desempenho Cat: Mensagens Categorizadas e Cat: Categorizações concluídas do objeto de desempenho SMTP Server analisem dados de desempenho.

O contador Cat: Mensagens Categorizadas indica o número de mensagens enviadas pelo categorizador para colocação em fila, enquanto a o contador Cat: Categorizações concluídas indica o número total de mensagens enviadas ao categorizer que foram concluídas.

O categorizador executa as seguintes operações principais:

  • Resolve e valida todos os destinatários.

  • Determina limites e restrições para todos os destinatários.

  • Expande listas de distribuição, caso necessário.

  • Determina se a mensagem é para entrega local ou remota.

O Exchange Server Analyzer examina a média do total dos dois contadores para detectar se seus números aumentam durante o período de amostragem.

O Exchange Server Analyzer exibe um erro se as seguintes condições forem verdadeiras:

  • Existem 50 mensagens ou mais na fila MADL.

  • O contador Cat: Mensagens Categorizadas mostra um aumento, no período de amostragem, que indica um avanço ao passar as mensagens enviadas para o processo seguinte.

  • O contador Cat: Mensagens Concluídas mostra um aumento, no período de amostragem, que indica um avanço ao concliur com êxito a categorização das mensagens enviadas.

Esse erro indica que, embora o categorizador processe mensagens com êxito, o tamanho de sua fila continua alto e o desempenho pode ser prejudicado.

O desempenho do categorizador pode ser afetado por uma demanda para processar várias mensagens devido a:

  • UCE (e-mail comercial não solicitado) ou spam.

  • Profileração de vírus.

  • Problemas de desempenho no servidor.

Para corrigir esse aviso:

  • Descubra se a tensão no categorizador foi prevista ou procede de uma carga comum. Se a tensão no categorizador é oriunda de uma carga prevista, examine a orientação sobre o desempenho do Exchange nos seguintes recursos do Exchange.

    • Solucionando problemas de desempenho do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47588)

    • Guia de Desempenho e Escalabilidade do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576) (em inglês)

  • Se a tensão no categorizador não é oriunda de uma carga prevista, verifique se há epidemias de vírus ou spam que possam gerar a carga.


Possíveis Problemas de Expansão de Grupo de Distribuição Encontrados
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se o servidor Exchange está executando o Exchange Server 2003 Service Pack 2 (SP2) e está configurado para expandir grupos de distribuição quando fizer verificação de restrições de entrega:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

  • Um valor 1 para essa entrada significa que o servidor está configurado para expandir grupos de distribuição ao fazer verificação de restrições de entrega.

  • Um valor 2 para essa entrada indica que o servidor está configurado para não expandir grupos de distribuição ao fazer verificação de restrições de entrega.

Se o Exchange Server Analyzer verificar que o servidor está configurado para expandir grupos de distribuição ao fazer verificação de restrições de entrega, ele consultará os logs de eventos do servidor para verificar se os eventos de erro 6004, 6006 e 6008 ocorreram nas últimas 24 horas.

Esses eventos indicam que as mensagens estão ficando presas no categorizador de mensagens. O categorizador de mensagem é um componente do mecanismo de enfileiramento avançado que envia consultas do Protocolo LDAP ao servidor de catálogo global para executar pesquisas de diretório.

Por fim, o Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o seguinte:

  • Se existem mais de 500 caixas de correio na floresta com restrições de entrega definidas, de forma que pelo menos um grupo de distribuição é usado para permitir ou proibir remetentes.

  • Se um Conector do Grupo de Roteamento possui restrições de entrega baseadas na associação do grupo de distribuição e se o servidor bridgehead tem verificação de restrição do conector habilitada.

  • Se um conector SMTP possui restrições de entrega baseadas na associação de grupos de distribuição e se o servidor bridgehead tem verificação de restrição do conector habilitada.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O servidor Exchange Server 2003 SP2 está configurado para expandir grupos de distribuição ao fazer verificação de restrições de entrega.

  • O servidor Exchange registrou os eventos 6004, 6006 e 6008 nas últimas 24 horas.

  • Há mais de 500 caixas de correio na floresta com restrições de entrega definidas, de forma que pelo menos um grupo de distribuição é usado para permitir ou proibir remetentes, ou há um Conector do Grupo de Roteamento com restrições de entrega baseadas na associação do grupo de distribuição e o servidor bridgehead tem verificação de restrição do conector habilitada, ou um conector SMTP possui restrições de entrega baseadas na associação de grupos de distribuição e o servidor bridgehead tem verificação de restrição do conector habilitada.

O valor RestrictionMethod determina como o categorizador processará as restrições. O comportamento padrão para o categorizador é expandir recursivamente os grupos de distribuição e verificar as restrições de cada mensagem que passa pelo sistema. Quando uma mensagem de email é enviada para um destinatário configurado com uma restrição que rejeita mensagens de membros de um determinado grupo de distribuição ou de segurança, o Exchange Server deve expandir esse grupo para certificar-se de que o remetente não é membro do grupo restrito. Os resultados da expansão desse grupo não são armazenados em cache pelo Exchange Server e devem ser executados sempre. Isso faz com que as mensagens sejam mantidas nas filas do categorizador e pode atrasar o processamento da mensagem.

Se você definir o valor RestrictionMethod como 2, os componentes de transporte nesse servidor Exchange não irão expandir a associação de grupos de distribuição quando o servidor verificar restrições. Essa configuração fornece o melhor desempenho para verificações de restrição. Além disso, para que a entrada de Registro RestrictionMethod entre em vigor, todos os grupos de distribuição que incluírem usuários com restrições de entrega devem ser simples. Isto é, os grupos de distribuição restritos não têm grupos de distribuição aninhados. A lógica de expansão não funcionará se os grupos de distribuição restritos estiverem aninhados.

Para grupos de distribuição usados em restrições de conector, é recomendável definir o valor da entrada do Registro RestrictionMethod em um servidor bridgehead do conector que não possua caixas de correio. Para restrições de usuário do Active Directory, se os grupos de distribuição restritos possuírem servidores de expansão, é recomendável criar a entrada de Registro RestrictionMethod nos servidores de expansão.

Para obter mais informações sobre o que ocorre quando restrições de entrega são configuradas, consulte o artigo 812298 da Base de Dados de Conhecimento da Microsoft, "A entrega de mensagens fica lenta após a configuração das restrições de entrega baseadas em uma lista de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Para obter mais informações sobre o valor de Registro RestrictionMethod, consulte o artigo 895407 da Base de Dados de Conhecimento da Microsoft, "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e externas é mais lenta do que o esperado após a configuração das restrições de entrega baseadas nos grupos de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Para obter mais informações sobre eventos e erros do Exchange Server 2003, consulte "Events and Errors Message Center" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34258).

Para obter mais informações sobre Restrições de conector, consulte o artigo 277872 da Base de Dados de Conhecimento da Microsoft, "XCON: Connector Delivery Restrictions May Not Work Correctly" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).

Para obter mais informações sobre Filas SMTP, consulte o artigo 884996 da Base de Dados de Conhecimento da Microsoft, "As mensagens permanecem na fila SMTP 'Mensagens aguardando pesquisa de diretório' no Exchange Server 2003 ou no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=884996).


Possíveis problemas encontrados com o destinatário do diário de mensagens
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_NTLogEvent para determinar se uma das seguintes combinações Aviso de Categorizador/Evento de Erro ocorreu nas últimas 24 horas:

  • Evento 9004 e Evento 9003

  • Evento 9035 e Evento 6004

Esses eventos indicam que as mensagens estão ficando presas no categorizador de mensagens. O categorizador de mensagem é um componente do mecanismo de enfileiramento avançado que envia consultas do Protocolo LDAP ao servidor de catálogo global para executar pesquisas de diretório.

  • O Analisador do Exchange Server também consulta o serviço de diretório Active Directory® para determinar se uma das seguintes condições também é verdadeira:

  • O destinatário do diário designado para um armazenamento aponta para um objeto excluído.

  • O destinatário do diário designado para um armazenamento aponta para um objeto que não tem um mailNickname válido.

  • O destinatário do diário designado para um armazenamento aponta para uma conta desabilitada.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • Ocorreu uma das combinações de evento de Aviso/Erro listadas anteriormente.

  • Qualquer uma das condições de destinatário do diário designado também é verdadeira.

Esse erro indica que há um problema em potencial com o diário no ambiente do Exchange que pode colocar as mensagens em fila.

Para obter informações sobre como corrigir esse problema, consulte o artigo específico do Analisador do Exchange Server que relata o seu problema:

  • O destinatário do diário aponta para um objeto excluído

  • O destinatário do diário não é válido

  • O destinatário do diário aponta para uma conta desabilitada

  • Para obter informações sobre eventos e erros do Exchange Server 2003, consulte "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258).


Possíveis problemas de registro de mensagens no diário e do serviço de armazenamento encontrados
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_NTLogEvent para determinar se o evento de Aviso do Categorizador 9004 ocorreu nas últimas 24 horas.

O Analisador do Exchange Server consulta também a classe WMI Win32_Service para determinar se o serviço Armazenamento de Informações Microsoft Exchange (MSExchangeIS) está iniciado ou parado. Um valor diferente de Iniciado para a instância do MSExchangeIS significa que o serviço MSExchangeIS está parado.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O servidor registrou um evento de Aviso do Categorizador 9003 nas últimas 24 horas.

  • O serviço MSExchangeIS está parado.

Esse erro indica que existe um problema com o Diário de Mensagens ou o com o serviço Armazenamento de Informações do Microsoft Exchange (Store.exe) que pode provocar o enfileiramento de mensagens.

Esse problema poderá ocorrer se uma das condições a seguir for verdadeira:

  • O objeto de destinatário do diário foi excluído do serviço de diretório do Active Directory®.

  • O serviço Armazenamento de Informações não está executando ou foi desativado no computador do Exchange Server que é um servidor bridgehead SMTP.

  • Um ou mais armazenamentos de caixa de correio no servidor bridgehead SMTP estão desmontados.

Para resolver esse problema:

  • Certifique-se de que o servidor bridgehead SMTP esteja com o serviço Armazenamento de Informações habilitado e em execução. Certifique-se de que os armazenamentos de caixa de correio no servidor bridgehead SMTP estejam montados.

  • Certifique-se de que o objeto de destinatário do diário dos armazenamentos de caixa de correio não foi excluído do Active Directory.

Para determinar o destinatário do diário para um armazenamento de caixa de correio

  1. Inicie o Gerenciador do Sistema Exchange.

  2. Expanda Servidores, expanda <seu servidor Exchange>, expanda <grupo de armazenamento> e clique com o botão direito no armazenamento de caixa de correio e selecione Propriedades.

  3. Na guia Geral, visualize a conta que aparece imediatamente abaixo da caixa de seleção Arquivar todas as mensagens enviadas ou recebidas por caixas de correio neste armazenamento. Essa é a conta que está sendo usada como o destinatário do diário.

    Observação:
    Certifique-se de verificar o destinatário do diário de cada objeto de armazenamento de caixa de correio.
Para indicar uma nova caixa de correio de usuário como o destinatário do diário

  1. Inicie o Gerenciador do Sistema Exchange.

  2. Expanda Servidores, expanda <seu servidor Exchange>, expanda <grupo de armazenamento> e clique com o botão direito no armazenamento de caixa de correio e selecione Propriedades.

  3. Na guia Geral, clique em Procurar, à direita do texto Arquivar todas as mensagens enviadas ou recebidas pelas caixas de correio neste armazenamento, para especificar uma caixa de correio como a caixa de correio de diário.

    Observação:
    Todas as mensagens de diário para remetentes deste armazenamento de caixa de correio são enviadas para a caixa de correio que você especificar.

Para obter informações sobre esse problema, consulte O destinatário do diário aponta para um objeto excluído.

Para obter mais informações sobre eventos e erros do Exchange Server 2003, consulte "Events and Errors Message Center" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34258).

Para obter mais informações sobre como implantar uma solução de diário, consulte "Diário com Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=47581).


Possíveis problemas de permissões encontrados
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_NTLogEvent do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se os seguintes Eventos de Erro do Exchange Server ocorreram nas últimas 24 horas.

  • Evento 929.

  • Evento 9035.

  • Uma combinação de Eventos 9003, 9004 e 6004.

O evento de Erro 929 do Exchange Server pode ocorrer devido a permissões de acesso incorretas nos objetos do Exchange Server no serviço de diretório do Active Directory®.

Eventos de Erro 9003, 9004 e 6004 do Exchange Server indicam que as mensagens estão ficando presas no categorizador de mensagens. O categorizador de mensagem é um componente do mecanismo de enfileiramento avançado que envia consultas do Protocolo LDAP ao servidor de catálogo global para executar pesquisas de diretório.

O Exchange Server Analyzer também consulta o Active Directory para determinar se os atributos dos objetos relacionados ao Exchange indicam que há problemas de herança de permissões para esses objetos.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • Um dos seguintes Eventos ou combinação de Eventos foi registrado nas últimas 24 horas em um servidor que colocou mensagens na fila Mensagens aguardando pesquisa de diretório:

    • Evento 929.

    • Evento 9035.

    • A combinação de Eventos 9003, 9004 e 6004.

  • Objetos relacionados ao Exchage têm permissões de acesso ausentes ou incorretas.

Esse erro significa que há problemas de herança de permissões no ambiente do Exchange que podem causar a colocação de emails na fila.

Para resolver esse problema, siga as etapas no artigo 907969 da Base de Dados de Conhecimento Microsoft, "O ID de Evento 929 foi registrado, e a mensagem não é entregue de um servidor de emails para outro servidor de emails na organização do Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=907969) (página em inglês).

Para obter mais informações sobre eventos e erros do Exchange Server 2003, consulte "Events and Errors Message Center" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=34258).


Pasta pública identificada como destino comum
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-04

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Exchange_Queue do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar os valores dos seguintes atributos das filas do protocolo SMTP do servidor virtual SMTP.

LinkId | Indica o identificador do link que contém a fila.
QueueId | Indica o identificador da fila.
QueueName | Indica o nome da fila.
VirtualMachine | Indica o nome da máquina virtual que contém a fila.
VirtualServerName | Indica o nome do servidor virtual em que a fila está.
MessageCount | Indica o número de mensagens na fila.

O Exchange Server Analyzer usa as informações obtidas aqui para consultar a classe Exchange_QueuedSMTPMessage do WMI em relação aos valores dos seguintes atributos das mensagens na fila:

Recipients | Indica os destinatários da mensagem.
Received | Indica o carimbo de hora recebido para a mensagem.
MessageId | Indica o identificador da mensagem em fila.
StateRetry | Indica que a transmissão é repetida para uma mensagem que não foi entregue com êxito.

Por fim, o Exchange Server Analyzer usa os dados obtidos aqui para consultar o serviço de diretório do Active Directory® em relação ao valor distinguishedName de cada objeto Recipient. O Exchange Server Analyzer determina se o destinatário é um usuário, um grupo de distribuição, uma pasta pública ou um armazenamento de pasta pública.

Se determinar que pelo menos 25% das mensagens presas na fila estão endereçadas, no campo To: ou no campo Cc:, a uma pasta pública específica, o Exchange Server Analyzer exibirá um aviso.

Se determinar que pelo menos 50% das mensagens presas na fila estão endereçadas, no campo To: ou no campo Cc:, a uma pasta pública específica, o Exchange Server Analyzer exibirá um erro.

Esse aviso ou erro significa que a pasta pública identificada é um destino comum para mensagens que estão presas em uma fila SMTP.

Para resolver esse problema, investigue a pasta pública como mostrado a seguir para verificar se há problemas de configuração ou outras anomalias que poderão fazer com que as mensagens sejam colocadas em fila.

  • Verifique se os atributos de objeto de pasta pública estão corretamente definidos e contêm os valores corretos no Active Directory.

  • Reveja as permissões do Active Directory do objeto de pasta pública para obter as configurações corretas.

  • Procure possíveis emails comerciais não solicitados, ou spams, ou ataques de vírus contra pastas públicas.

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Guia de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875) (pode estar em inglês).

  • Artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489). (pode estar em inglês).


Armazenamento de pasta pública identificado como destino comum
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-04

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Exchange_Queue do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar os valores dos seguintes atributos das filas do protocolo SMTP do servidor virtual SMTP.

LinkId | Indica o identificador do link que contém a fila.
QueueId | Indica o identificador da fila.
QueueName | Indica o nome da fila.
VirtualMachine | Indica o nome da máquina virtual que contém a fila.
VirtualServerName | Indica o nome do servidor virtual em que a fila está.
MessageCount | Indica o número de mensagens na fila.

O Exchange Server Analyzer usa as informações obtidas aqui para consultar a classe Exchange_QueuedSMTPMessage do WMI em relação aos valores dos seguintes atributos das mensagens na fila:

Recipients | Indica os destinatários da mensagem.
Received | Indica o carimbo de hora recebido para a mensagem.
MessageId | Indica o identificador da mensagem em fila.
StateRetry | Indica que a transmissão é repetida para uma mensagem que não foi entregue com êxito.

Por fim, usa os dados obtidos aqui para consultar o serviço de diretório do Active Directory® em relação ao valor distinguishedName de cada objeto Recipient. O Exchange Server Analyzer determina se o destinatário é um usuário, um grupo de distribuição, uma pasta pública ou um armazenamento de pasta pública.

Se determinar que pelo menos 25% das mensagens presas na fila estão endereçadas, no campo To: ou no campo Cc:, a destinatários cujas caixas de correio estão hospedadas no mesmo armazenamento de pasta pública, o Exchange Server Analyzer exibirá um aviso.

Se determinar que pelo menos 50% das mensagens presas na fila estão endereçadas, no campo To: ou no campo Cc:, a destinatários cujas caixas de correio estão hospedadas no mesmo armazenamento de pasta pública, o Exchange Server Analyzer exibirá um erro.

Esse aviso ou erro significa que o armazenamento de pasta pública identificado é um destino comum para mensagens que estão presas em uma fila SMTP.

Para resolver esse problema, investigue o armazenamento de pasta pública como mostrado a seguir para verificar se há problemas de configuração, tempestades de replicação ou outras anomalias que poderão fazer com que as mensagens sejam colocadas em fila.

  • Verifique se os atributos de objeto de armazenamento estão corretamente definidos e contêm os valores corretos no Active Directory.

  • Reveja as permissões do Active Directory do objeto de armazenamento para obter as configurações corretas.

  • Procure possíveis emails comerciais não solicitados, ou spams, ou ataques de vírus contra pastas públicas.

  • Verifique as alterações feitas na hierarquia de pasta pública ou o conteúdo que possa gerar muitas replicações entre armazenamentos de pasta pública.

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Guia de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875) (pode estar em inglês).

  • Artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489). (pode estar em inglês).

  • Artigo 842273 da Base de Dados de Conhecimento Microsoft, "Como solucionar problemas de replicação de pasta pública no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273) (pode estar em inglês).


A filtragem por destinatário está habilitada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se a propriedade msExchServerBindingsFiltering de um objeto do servidor virtual SMTP indica que a Filtragem por Destinatário está habilitada para uma instância do servidor virtual SMTP.

A ferramenta Exchange Server Analyzer Tool consulta também o Active Directory para determinar se as propriedades msExchRecipTurfListNames ou msExchRecipTurfListOptions indicam que a Filtragem por Destinatário também está habilitada no nível de configurações globais.

Se a ferramenta Exchange Server Analyzer Tool detectar que a Filtragem por Destinatário está habilitada tanto na instância do servidor virtual SMTP, como no nível de Configurações Globais, ela exibirá um aviso.

Esse aviso indica que a Filtragem por Destinatário está efetivamente habilitada. A Filtragem por Destinatário normalmente não é um problema. No entanto, se você estiver solucionando problemas de fluxo de mensagens envolvendo esse servidor em particular, talvez queira verificar a configuração de filtro ou desabilitar temporariamente a Filtragem por Destinatário para determinar se ela está bloqueando erroneamente mensagens para destinatários válidos.

Para desabilitar um filtro de destinatário em um servidor virtual SMTP

  1. Iniciar o Gerenciador do Sistema do Exchange: Clique em Iniciar, aponte para Todos os Programas, aponte para Microsoft Exchange e clique em Gerenciador do Sistema.

  2. Na árvore do console, expanda Servidores, expanda o servidor desejado e, em seguida, Protocolos e SMTP.

  3. Clique com o botão direito no servidor virtual SMTP em que deseja desabilitar o filtro e, em seguida, clique em Propriedades.

  4. Em <SMTP Virtual Server> Propriedades, na guia Geral, clique em Avançado.

  5. Em Avançado, selecione o endereço IP para o qual deseja desabilitar o filtro e, em seguida, clique em Editar.

Em Identificação, desmarque a caixa de seleção Aplicar Filtro por Destinatário para desabilitar o filtro.

  1. Se houver vários servidores virtuais, repita as etapas 3 a 6 para cada servidor virtual em que deseje desabilitar o filtro.

Para obter mais informações sobre como configurar filtros por destinatários, consulte o artigo 823866 da Base de Dados de Conhecimento da Microsoft "Como configurar filtragem de conexão para usar RBLs (Listas de Bloqueio em Tempo Real) e como configurar a filtragem por destinatários no Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866).

Para obter mais informações sobre a filtragem inteligente de mensagens, consulte o site do Exchange Intelligent Message Filter (http://go.microsoft.com/fwlink/?LinkId=21607).


A fila 'Entrega Remota' está congelada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Windows®) para determinar o valor da chave StateFrozen da fila Entrega Remota do protocolo SMTP.

Se o Exchange Server Analyzer detectar que o valor da chave StateFrozen da Entrega Remota de um servidor Exchange está definido como True, o Exchange Server Analyzer exibirá um erro.

Uma fila congelada significa que as sessões de transporte para essa fila foram paradas. Uma fila congelada impede mensagens de saída, mas novas mensagens podem ser adicionadas. Você pode alterar manualmente o estado de uma conexão, usando o menu de atalho em cada fila de link. Quando você usa o comando Forçar Conexão para alterar um estado de fila para Ativo, você imediatamente habilita uma conexão que envia as mensagens dessa fila.

A fila Entrega Remota armazena mensagens que são destinadas para entrega remota. O nome da fila corresponde ao destino de entrega remota. Esse destino pode ser um conector, um servidor ou um domínio.

Para resolver esse erro, use o utilitário NSlookup para examinar possíveis problemas com a resolução de DNS (Sistema de Nome de Domínio). Para problemas de conexão e protocolo, como erros de Host inacessível, use o Telnet.exe para tentar conectar ao computador de destino. Para solucionar problemas de erros de protocolo, aumente o log de diagnóstico para o serviço MSExchangeTransport do componente Protocolo SMTP e consulte os logs de erros. Como alternativa, você pode usar a ferramenta Monitor de Rede (Netmon.exe) para obter informações sobre erros de conexão de rede. Para reproduzir o problema, force a fila a tentar novamente. Examine o log de eventos para obter possíveis erros associados ao serviço Armazenamento de Informações do Microsoft Exchange.

Para obter mais informações sobre como modificar configurações de log, consulte "How to Modify Logging Settings for MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


A fila 'Entrega Remota' está em Repetição
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) ExchangeLink para determinar o valor da chave StateRetry da fila Entrega Remota do SMTP.

Se o Exchange Server Analyzer detectar que o valor da chave StateRetry para a fila Entrega Remota de um servidor Exchange está definido como True, ele exibirá um erro.

Se uma fila estiver no status de repetição, esse status indica que ocorreu pelo menos um erro nas tentativas anteriores de processar as mensagens na fila. Você pode alterar filas no estado Repetição ou Agendado para Ativo com o comando Forçar Conexão. Isso faz com que a fila funcione como se o intervalo de repetição já tivesse passado ou se o horário agendado tivesse sido atingido. Entretanto, nem sempre esse método pode funcionar.

Observação:
As propriedades de uma fila podem indicar um motivo específico para ela estar na condição Repetir.

A fila Entrega Remota armazena mensagens que são destinadas para entrega remota. O nome da fila corresponde ao destino de entrega remota. Esse destino pode ser um conector, um servidor ou um domínio.

Para resolver esse erro, use o utilitário NSlookup para examinar possíveis problemas com a resolução de DNS (Sistema de Nome de Domínio). Para problemas de conexão e protocolo, como erros de Host inacessível, use o Telnet.exe para tentar conectar ao computador de destino. Para solucionar problemas de erros de protocolo, aumente o log de diagnóstico para o serviço MSExchangeTransport do componente Protocolo SMTP e consulte os logs de erros. Como alternativa, você pode usar a ferramenta Monitor de Rede (Netmon.exe) para obter informações sobre erros de conexão de rede. Para reproduzir o problema, force a fila a tentar novamente. Examine o log de eventos para obter possíveis erros associados ao serviço Armazenamento de Informações do Microsoft Exchange.

Para obter mais informações sobre como modificar configurações de log, consulte "How to Modify Logging Settings for MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Problema da fila 'Entrega Remota'
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A Ferramenta Microsoft® Exchange Server Analyzer envia uma mensagem de teste do servidor Exchange para a conta Postmaster ou uma conta definida pelo usuário para o domínio SMTP e, em seguida, verifica os logs de controle de mensagens do servidor para determinar se foi encontrado algum problema com a entrega da mensagem de teste.

Como parte dessa verificação, o Exchange Server Analyzer consulta a propriedade EntryType para a classe Exchange_MessageTrackingEntry da Instrumentação de Gerenciamento do Windows (WMI) no namespace root\MicrosoftExchangeV2 para determinar o que fez com que as entradas do log de rastreamento de mensagens fossem criadas.

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O log de rastreamento de mensagens pode ser verificado com sucesso.

  • A mensagem de teste não realizou com êxito a transferência externa da fila.

  • Não foi gerada uma notificação de falha na entrega.

  • Existe um valor de 1034 para a propriedade EntryType.

Esse erro indica que a mensagem de teste ainda está em uma das filas de Entrega Remota SMTP no servidor de envio e que há um problema com a fila.

A fila Entrega Remota armazena mensagens que são destinadas para entrega remota. O nome da fila corresponde ao destino de entrega remota. Esse destino pode ser um conector, um servidor ou um domínio.

Para resolver esse erro, use o utilitário NSlookup para examinar possíveis problemas com a resolução de DNS (Sistema de Nome de Domínio). Para problemas de conexão e protocolo, como erros de Host inacessível, use o Telnet.exe para tentar conectar ao computador de destino. Para solucionar problemas de erros de protocolo, aumente o log de diagnóstico para o serviço MSExchangeTransport do componente Protocolo SMTP e consulte os logs de erros. Como alternativa, você pode usar a ferramenta Monitor de Rede (Netmon.exe) para obter informações sobre erros de conexão de rede. Para reproduzir o problema, force a fila a tentar novamente. Examine o log de eventos para obter possíveis erros associados ao serviço Armazenamento de Informações do Microsoft Exchange.

Para obter mais informações sobre como modificar configurações de log, consulte "How to Modify Logging Settings for MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Repetir Categorização
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

O Microsoft® Exchange Server Analyzer Tool envia uma mensagem de teste do servidor Exchange para a conta do Postmaster ou para uma conta definida pelo usuário do domínio SMTP e, em seguida, verifica os logs de controle de mensagens do servidor para determinar se foram encontrados problemas na entrega da mensagem de teste.

Como parte dessa verificação, o Exchange Server Analyzer consulta a propriedade EntryType da classe Exchange_MessageTrackingEntry do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) com o namespace root\MicrosoftExchangeV2 para determinar a causa da entrada do log de controle de mensagens.

Se o Exchange Server Analyzer encontrar o valor 1032 para a propriedade EntryType, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que a mensagem de teste está em uma fila agendada para uma nova tentativa de categorização. Se uma fila estiver no status de repetição, esse status indica que ocorreu pelo menos um erro nas tentativas anteriores de processar as mensagens na fila. Você pode alterar filas no estado Repetição ou Agendado para Ativo com o comando Forçar Conexão. Isso faz com que a fila funcione como se o intervalo de repetição já tivesse passado ou se o horário agendado tivesse sido atingido. Entretanto, nem sempre esse método pode funcionar.

Observação:
As propriedades de uma fila podem indicar um motivo específico para ela estar na condição Repetir.

Normalmente, as mensagens se acumulam nas filas porque o mecanismo de enfileiramento avançado não pode categorizar a mensagem. O mecanismo de enfileiramento avançado pode não ser capaz de acessar os servidores do catálogo global e informações dos destinatários, ou os servidores do catálogo global estão inacessíveis ou com desempenho lento. Além disso, as mensagens podem se acumular pelas seguintes razões:

  • O Active Directory não está disponível.

    Observação:
    O categorizador usa o Active Directory para categorizar mensagens.
  • O Active Directory pode estar muito sobrecarregado se muitas mensagens estiverem na fila de pré-categorização.

  • Ocorre uma falha na conversão. O categorizador também manipula conversão de conteúdo.

  • O categorizador de mensagens não consegue localizar os armazenamentos de caixa de correio.

  • Se o SMTP foi reinstalado ou removido, isso pode invalidar as seguintes chaves de metabase do IIS: /smtpsvc/DsUseCat e /smtpsvc/vsi#/DsUseCat.

    Observação:
    Determine se o SMTP foi reinstalado or removido.

Se uma fila estiver em um status "Repetir", examine as propriedades da fila para determinar a causa. Por exemplo, se as propriedades de fila exibirem uma mensagem parecida com "Erro de SMTP", você deve consultar seus logs de eventos do servidor para localizar os erros de SMTP. Se não houver eventos no log, você deve aumentar o nível de log do Protocolo SMTP.

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Repetir entrega local
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-04

A ferramenta Analisador do Microsoft® Exchange Server envia uma mensagem de teste do servidor Exchange para a conta Postmaster ou uma conta definida pelo usuário para o domínio SMTP e, em seguida, verifica os logs de controle de mensagens do servidor para determinar se foi encontrado algum problema com a entrega da mensagem de teste.

Como parte dessa verificação, o Analisador do Exchange Server consulta a propriedade EntryType da classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Exchange_MessageTrackingEntry no namespace root\MicrosoftExchangeV2 para determinar a causa da entrada do log de controle de mensagens.

Se o Analisador do Exchange Server detectar o valor 1037 para a propriedade EntryType, o Analisador do Exchange Server exibirá um aviso.

Esse aviso indica que ocorreu pelo menos um erro nas tentativas anteriores de processar a mensagem na fila Entrega Local.

A fila Entrega Local contém mensagens enfileiradas no servidor Exchange para entrega local em um armazenamento de caixas de correio ou de pastas públicas do Exchange Server.

As mensagens poderão se acumular nessa fila, se o servidor Exchange não estiver aceitando mensagens para entrega local. Uma entrega de mensagens lenta ou intermitente pode indicar uma mensagem em loop ou um problema de desempenho.

Você pode alterar filas no estado Repetição ou Agendado para Ativo com o comando Forçar Conexão. Isso faz com que a fila funcione como se o intervalo de repetição já tivesse passado ou se o horário agendado tivesse sido atingido. Entretanto, nem sempre esse método pode funcionar.

Observação:
As propriedades de uma fila podem indicar um motivo específico para ela estar na condição Repetir.

Para resolver esse erro, aumente o log de diagnóstico para os componentes do driver de armazenamento SMTP do serviço MSExchangeIS e MSExchangeTransport.

Para obter mais informações sobre como modificar as configurações de log, consulte "Como modificar as configurações de log para MSExchangeTransport", na seção "Solucionando problemas de fluxo de mensagens e SMTP" do Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Repetir Roteamento
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

O Microsoft® Exchange Server Analyzer Tool envia uma mensagem de teste do servidor Exchange para a conta do Postmaster ou para uma conta definida pelo usuário do domínio SMTP e, em seguida, verifica os logs de controle de mensagens do servidor para determinar se foram encontrados problemas na entrega da mensagem de teste.

Como parte dessa verificação, a ferramenta Exchange Server Analyzer Tool consulta a propriedade EntryType da classe Exchange_MessageTrackingEntry do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) com o namespace root\MicrosoftExchangeV2 para determinar a causa da entrada do log de controle de mensagens.

Se o Exchange Server Analyzer encontrar o valor 1035 para a propriedade EntryType, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que a mensagens de teste está em uma fila agendada para uma repetição de roteamento. Se uma fila estiver no status de repetição, esse status indica que ocorreu pelo menos um erro nas tentativas anteriores de processar as mensagens na fila. Você pode alterar filas no estado Repetição ou Agendado para Ativo com o comando Forçar Conexão. Isso faz com que a fila funcione como se o intervalo de repetição já tivesse passado ou se o horário agendado tivesse sido atingido. Entretanto, nem sempre esse método pode funcionar.

Observação:
As propriedades de uma fila podem indicar um motivo específico para ela estar na condição Repetir.

As mensagens se acumulam nas filas, aguardando a repetição, se existirem problemas de roteamento do Exchange Server. As mensagens não foram roteadas devido a um erro transitório, ou seja, o mecanismo de roteamento não inicializou com êxito. As mensagens estão na fila de pré-roteamento aguardando uma repetição ou um novo roteamento.

Para resolver esse erro, aumente o log de diagnóstico do serviço MSExchangeTransport para coletar informações sobre o componente da categoria Roteamento. Desabilite quaisquer restrições de conector desnecessárias, porque elas podem causar uma degradação significativa no desempenho do servidor. Você pode precisar ativar a chave do Registro CheckConnectorRestrictions para algumas restrições.

Para obter mais informações sobre como modificar configurações de log, consulte "How to Modify Logging Settings for MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Pesquisas reversas de DNS foram habilitadas na metabase, mas não no servidor SMTP associado no Active Directory
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-01-17

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a propriedade a seguir na metabase do Internet Information Services (IIS) para determinar se seu valor corresponde ao valor configurado para o atributo msExchSmtpPerformReverseDnsLookup no serviço de diretório do Active Directory®:

/LM/SmtpSvc/<SMTP virtual server instance>/EnableReverseDnsLookup

Se o Exchange Server Analyzer perceber que os valores não correspondem, uma mensagem de aviso será exibida.

Se o valor na metabase do IIS não corresponder ao valor no Active Directory, ele poderá indicar um problema com a replicação do Active Directory ou um problema com o componente Directory-service-to-Metabase-replication (DS2MB) no Exchange.

A função do processo DS2MB é transferir informações de configuração do Active Directory para a metabase local. Essa configuração é armazenada na metabase local no lugar do Registro por razões de desempenho e escalabilidade. No Exchange 2000 Server e no Exchange Server 2003, todos os protocolos de Internet (SMTP, NNTP, POP3, IMAP4 e HTTP) são executados como componentes do IIS.

A cada 15 minutos, o processo DS2MB copia subárvores completas do Active Directory sem alterar a forma da subárvore. Essa é uma gravação unidirecional a partir do Active Directory para a metabase; a metabase nunca faz gravações no Active Directory.

A propriedade EnableReverseDnsLookup e o atributo msExchSmtpPerformReverseDnsLookup podem ter o valor TRUE ou FALSE. Um valor TRUE significa que o servidor virtual SMTP executará pesquisas reversas de DNS em todas as mensagens de entrada. Um valor FALSE significa que ele não desempenhará pesquisas reversas de DNS. A propriedade EnableReverseDnsLookup e o atributo msExchSmtpPerformReverseDnsLookup estão definidos como FALSE por padrão, devido ao potencial de redução do desempenho ocasionada por registros de DNS configurados incorretamente ou conexões com a Internet intermitentes.

Se a propriedade EnableReverseDnsLookup estiver definida como TRUE (habilitada) e o atributo msExchSmtpPerformReverseDnsLookup estiver definido como FALSE (desabilitado), isso significará que o Active Directory e a metabase do IIS não estão em sincronia. Se o problema for causado por uma falha no processo DS2MB, você pode fazer a correção seguindo o procedimento abaixo para a versão do Exchange Server que você está executando. Se o problema for causado por uma falha completa ou parcial da replicação do Active Directory, você pode usar o utilitário Active Directory Replication Monitor (ReplMon.exe) para verificar a integridade e o status da replicação do Active Directory. Você pode encontrar o ReplMon.exe nas Ferramentas de Suporte do Windows® no CD-ROM do Windows Server.

Para corrigir esse erro no Exchange Server 2003

  1. Verifique a presença de entradas do log de eventos do aplicativo com fonte MSExchangeMU. Se o DS2MB falhar, ele registará em log um evento no Exchange Server 2003.

  2. Se você não perceber nenhuma falha do DS2MB, use ReplMon para diagnosticar a replicação do Active Directory. Preste bastante atenção nos servidores de catálogo global que estão sendo usados pelo seu servidor virtual SMTP.

  3. Se você não vir falhas do DS2MB, ou após ter eliminado ou resolvido quaisquer problemas com a replicação do Active Directory, reinicie o serviço Atendedor do Sistema do Exchange.

Para corrigir esse erro no Exchange 2000 Server

  1. Use ReplMon para diagnosticar a replicação do Active Directory. Preste bastante atenção nos servidores de catálogo global que estão sendo usados pelo seu servidor virtual SMTP.

  2. Após ter eliminado ou resolvido quaisquer problemas com a replicação do Active Directory, reinicie o serviço Atendedor do Sistema do Exchange.

Para obter mais informações sobre o recurso de pesquisa reversa de DNS no Exchange, consulte o artigo 297412 da Base de Dados de Conhecimento da Microsoft, "A opção 'Executar pesquisa reversa de DNS para Mensagens de Entrada' é para resolução de nome de host" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os artigos 266686 da Base de Dados de Conhecimento Microsoft, "XCON: Como Configurar um Servidor Virtual SMTP Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) e 268163, "XCON: Como Configurar um Servidor Virtual SMTP Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Para obter mais informações sobre a replicação do Active Directory, consulte o artigo 232072 da Base de Dados de Conhecimento da Microsoft, "Iniciando a Replicação Entre os Parceiros de Replicação Direta do Active Directory" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Para obter mais informações sobre o processo DS2MB, consulte o artigo 240105 da Base de Dados de Conhecimento Microsoft, "XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Mecanismo de Roteamento:O parâmetro AttachedTimeout é não padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a lógica de roteamento do conector SMTP (Simple Mail Transfer Protocol) foi modificada na configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\AttachedTimeout

Se o Analisador do Exchange Server detectar a presença da chave de Registro AttachedTimeout e sua configuração com um valor acima de 300, será exibida uma mensagem de configuração não padrão.

A entrada do Registro AttachedTimeout é uma definição de configuração personalizada para o Exchange Server que determina a freqüência na qual o pacote ORG_INFO é enviado. Cada vez que o cliente de roteamento não se conecta a um servidor de roteamento, a versão do usuário da topologia será incrementada e fará com que o pacote ORG_INFO seja transmitido por toda a organização.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Exclua a chave de Registro AttachedTimeout.

  4. Feche o editor de Registro.

  5. Reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro AttachedTimeout, consulte o artigo 832281 da Base de Dados de Conhecimento, "Problemas de estado de ligação e problemas de roteamento no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832281).


Mecanismo de Roteamento:O parâmetro BestAddressMatchOnly é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a lógica de roteamento do conector SMTP (Simple Mail Transfer Protocol) foi modificada na configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\BestAddressMatchOnly

Se o Analisador do Exchange Server detectar a presença da chave de Registro BestAddressMatchOnly e sua configuração com um valor acima de 0, será exibida uma mensagem de configuração não padrão.

A entrada do Registro BestAddressMatchOnly é uma configuração personalizada do Exchange Server que faz com que mensagens enviadas para um determinado domínio sejam roteadas por meio de um conector específico, independentemente de quaisquer restrições existentes.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Exclua a chave de Registro BestAddressMatchOnly.

  4. Feche o editor de Registro.

  5. Reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Mecanismo de Roteamento: O parâmetro CheckConnectorRestrictions não é padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a lógica de roteamento do conector SMTP (Simple Mail Transfer Protocol) foi modificada na configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\CheckConnectorRestrictions

Se o Analisador do Exchange Server detectar a presença da chave de Registro CheckConnectorRestrictions e sua configuração com um valor acima de 0, será exibida uma mensagem de configuração não padrão.

A entrada do Registro CheckConnectorRestrictions é uma definição de configuração padrão para o Exchange Server que habilita a verificação de restrição no servidor bridgehead Exchange que é a origem do conector que está sendo verificado. Por padrão, a verificação de restrição de conectores é desativada porque pode afetar significativamente o desempenho, principalmente em configurações que usam muitos grupos de distribuição. As restrições serão verificadas para cada mensagem enviada a cada membro de cada grupo de distribuição transmitido pelo sistema. Se houver restrições especificadas, mas essa entrada no Registro não existir, a verificação de restrições não será executada.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Exclua a chave de Registro CheckConnectorRestrictions.

  4. Feche o editor de Registro.

  5. Reinicie o Serviço de Administração do IIS.

  6. Na guia Restrições de Entrega do conector, reabilite a opção de restrição.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro CheckConnectorRestrictions, consulte o artigo 277872 da Base de Dados de Conhecimento, "XCOM: Connector Delivery Restrictions May Not Work Correctly" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


Mecanismo de Roteamento: O parâmetro Configuration é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se a configuração padrão do intervalo de leitura do serviço de diretório do Active Directory® para definição do mecanismo de roteamento do Exchange foi modificada:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RESvc\Parameters\ReloadOsInterval

Se o Exchange Server Analyzer detectar que o valor de ReloadOsInterval não é igual a 3600, uma mensagem de configuração não padrão será exibida.

O valor de ReloadOsInterval é usado para especificar o intervalo no qual as informações de estado de vinculação de roteamento são atualizadas entre os servidores que executam o Exchange. O Exchange usa as informações de estado de vinculação de roteamento para que cada servidor possa determinar a rota mais barata para entregar uma mensagem e se os conectores que compõem a rota estão funcionando. Por padrão, os servidores Exchange lêem as informações de estado de vinculação no Active Directory a cada 3.600 segundos, ou seja, 1 hora.

Em determinadas situações, as informações de status do roteamento podem não ser dinamicamente propagadas entre os servidores de uma organização do Exchange. Alguns servidores da organização continuarão operando com informações de status de roteamento antigas e possivelmente incorretas. Como resultado, talvez novos conectores não apareçam quando você exibir um grupo de roteamento remoto usando a ferramenta WinRoute (Winroute.exe). Você pode usar a ferramenta WinRoute para verificar se as informações de estado de vinculação estão sendo propagadas. Para verificar se as informações estão sendo propagadas, use a ferramenta WinRoute para exibir as informações de estado de vinculação de vários locais diferentes da organização do Exchange e, em seguida, compare os números de versão de cada grupo de roteamento. A ferramenta WinRoute conecta-se à porta de estado de vinculação de um computador do Exchange Server e extrai as informações de estado de vinculação da organização do Exchange. Embora as informações de estado de vinculação sejam uma série de identificadores globais exclusivos (GUIDs), o WinRoute corresponde os GUIDs de conectores e servidores bridgehead aos objetos do Active Directory e apresenta as informações em formato legível.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para reverter para a configuração padrão

  1. Abra um editor de Registro, como Regedit.exe ou Regedt32.exe.

  2. Navegue para: HKLM\SYSTEM\CurrentControlSet\Services\RESvc\Parameters

  3. No painel da direita, clique duas vezes em ReloadOsInterval.

  4. Na caixa Dados do valor, digite 3600 e clique em OK.

  5. Feche o editor de Registro.

Antes de editar o Registro e obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre roteamento e estado de vinculação, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 842026, "As informações de status do roteamento não são propagadas corretamente para todos os servidores do Exchange 2000 Server ou do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842026)

  • 285130, "XCON: Informações de estado de vinculação" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285130)

Para baixar o WinRoute, uma ferramenta que ajuda a determinar as informações de estado de vinculação conhecidas do mestre de roteamento, consulte "Exchange Server WinRoute" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=25049).


Mecanismo de Roteamento:o parâmetro PollingInterval não é padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a lógica de roteamento do conector SMTP (Simple Mail Transfer Protocol) foi modificada na configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\PollingInterval

Se o Analisador do Exchange Server detectar a presença da chave de Registro PollingInterval e sua configuração com um valor acima de 300, será exibida uma mensagem de configuração não padrão.

A entrada do Registro PollingInterval é uma configuração personalizada do Exchange Server que ajuda a controlar a freqüência do tráfego de estado de vinculação entre grupos de roteamento, especificamente de e para o grupo de roteamento principal de um grupo de roteamento. Aumentar essa configuração evitará a falha de conexões, mas impedirá que você solucione o problema maior de links lentos entre membros de grupos de roteamento.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Exclua a chave de Registro PollingInterval.

  4. Feche o editor de Registro.

  5. Reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Mecanismo de Roteamento:O parâmetro StateChangeDelay não é padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a lógica de roteamento do conector SMTP (Simple Mail Transfer Protocol) foi modificada na configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\StateChangeDelay

Se o Analisador do Exchange Server detectar a presença da chave de Registro StateChangeDelay e sua configuração com um valor acima de 0, será exibida uma mensagem de configuração não padrão.

A entrada do Registro StateChangeDelay é uma definição de configuração padrão para o Exchange Server, que ajuda a controlar o intervalo no qual os conectores são marcados como indisponíveis e as notificações que ocorrem por causa de alteração de estado do conector e do servidor. Quando StateChangeDelay é definido com um valor maior que 0, um servidor só pode ser marcado como disponível ou indisponível uma vez a cada período de tempo definido por esse valor.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Exclua a chave de Registro StateChangeDelay.

  4. Feche o editor de Registro.

  5. Reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Mecanismo de Roteamento: O parâmetro SuppressStateChanges não é padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se a lógica de roteamento do conector SMTP (Simple Mail Transfer Protocol) foi modificada na configuração padrão:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\SuppressStateChanges

Se o Analisador do Exchange Server detectar a presença da chave de Registro SuppressStateChanges e sua configuração com um valor acima de 0, será exibida uma mensagem de configuração não padrão.

O Exchange Server 2003 inclui funcionalidade para detectar automaticamente alterações no estado de um link. Essas informações podem ser usadas para informar outros servidores que executam o Exchange Server 2003 que uma rota alternativa deverá ser usada, em vez da rota principal com custo mais baixo. As informações de estado do link estão divididas em alterações principais e secundárias. Uma alteração principal ocorre quando o administrador altera a topologia do roteamento, como a adição de um novo conector ou uma alteração de custo. As atualizações secundárias ocorrem quando o sistema detecta automaticamente a falha ou restauração de um link.

Esse recurso funciona melhor em organizações de pequeno e médio porte. Porém, em ambientes grandes com vários sites, a flutuação de rede em massa pode causar inundações de atualizações de links para a versão secundária. Para ser realmente eficiente, os dados do estado do link devem ser transmitidos para todos os servidores na organização. Além disso, quando o estado é alterado, a tabela inteira de estados do link é retransmitida, o que pode fazer com que uma quantidade significativa de dados seja transmitida pela rede. Nesses cenários, talvez seja útil suprimir alterações secundárias no estado do link. A entrada do Registro SuppressStateChanges é uma definição de configuração personalizada usada para suprimir alterações secundárias de estado do link. Quando SuppressStateChanges está definido como maior que 0, todas as alterações de estado do link nesse computador do Exchange Server são suprimidas.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Exclua a chave de Registro SuppressStateChanges.

  4. Feche o editor de Registro.

  5. Reinicie o SMTP, o Mecanismo de Roteamento do Microsoft Exchange e os serviços do Microsoft Exchange MTA Stacks para que a alteração tenha efeito.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre a chave do Registro SuppressStateChanges, consulte os seguintes guias da Microsoft:

  • Guia de Transporte e Roteamento do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Exchange Server 2003 Performance and Scalability Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47576)


Conector do grupo de roteamento com restrições de entrega do grupo de distribuição definidas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer consulta os seguintes atributos de cada objeto Conector de Grupo de Roteamento (msExchRoutingGroupConnector) detectado no serviço de diretório do Active Directory®, para saber se há restrições de entrega definidas, baseadas em associação de grupos de distribuição.

dLMemRejectPerms | Contém os nomes de domínio (DNs) de listas de distribuição (DL) cujos membros não podem enviar através deste Conector de Grupo de Roteamento.
dLMemSubmitPerms | Contém os nomes de domínio (DNs) de listas de distribuição (DL) cujos membros podem enviar através deste Conector de Grupo de Roteamento.

Ao detectar a existência de conectores de grupo de roteamento que possuem restrições de entrega definidas, com base em associação de grupos de distribuição, o Exchange Server Analyzer exibirá um aviso.

Este aviso indica que as restrições da entrega baseadas em associação de grupos de distribuição podem afetar o desempenho do fluxo de mensagens do Exchange.

Quando você envia mensagens usando conectores de grupo de roteamento com restrições de entrega definidas com base em associação de grupos de distribuição, o categorizador de mensagens deve expandir a associação do grupo de distribuição, obter a lista completa dos DNs dos membros e depois comparar essa lista aos DNs do remetente da lista. Uma operação de acesso ou de negação ocorre quando há correspondência de um DN em ambas as listas. Se um grupo de distribuição estiver aninhado em outro grupo de distribuição, a distribuição aninhada também será expandida.

Para tratar desse aviso:

  • Crie um grupo de roteamento dedicado para restrições do conector e configure-o para um Grupo de Roteamento local, como citado no artigo 329171 da Base de Dados de Conhecimento Microsoft, "XADM: A entrega de mensagens fica lenta se os destinatários estão configurados com restrições de entrega baseadas em associação de grupos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Use um servidor de catálogo global dedicado e mais robusto como o servidor bridgehead designado para o conector.

  • Configure caixas de correio individuais e não grupos de distribuição para restrições de entrega, como citado no artigo 812298 da Base de Dados de Conhecimento Microsoft, "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Considere a implementação de filtragem de remetente SMTP (Simple Mail Transfer Protocol).

  • Para os servidores executando o Exchange Server 2003 Service Pack 2 (SP2) ou versão posterior, considere a implementação de verificação de restrição não-hierárquica. Para os servidores com versões do Exchange anteriores ao Exchange 2003 SP2, considere uma atualização para o Exchange 2003 SP2.

Para obter mais informações

Para obter mais informações sobre a verificação de restrição não-hierárquica, consulte Considere a verificação da restrição não hierárquica.

Para obter mais informações sobre a filtragem de remetentes SMTP, consulte "Como habilitar a filtragem de remetentes" no Guia de Administração do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=72967).

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 329171, "XADM: A entrega de mensagens fica lenta se os destinatários estão configurados com restrições de entrega baseadas em associação de grupos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 895407 "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407) (em inglês).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949) (em inglês).


O mestre de grupo de roteamento foi excluído
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório Active Directory® para determinar o valor do atributo msExchRoutingMasterDN de cada contêiner do Grupo de Roteamento. Se o Analisador do Exchange Server detectar que o valor do atributo msExchRoutingMasterDN contém a cadeia de caracteres "DEL:", um erro será exibido.

O atributo msExchRoutingMasterDN é um atributo de valor único que armazena o nome distinto do computador do Exchange Server que serve como mestre de grupo de roteamento para cada grupo de roteamento. A presença da cadeia de caracteres "DEL:" poderia indicar que o mestre de grupo de roteamento foi excluído com a ferramenta Usuários e Computadores do Active Directory. Sem o mestre do grupo de roteamento, o Exchange não poderá atualizar ou manter corretamente a topologia de roteamento.

Quando você cria um grupo de roteamento, ao primeiro servidor desse grupo é atribuída a função de mestre do grupo de roteamento. O mestre do grupo de roteamento mantém informações do status do link atuais para o seu grupo de roteamento e as propaga para os outros servidores do grupo de roteamento. O mestre do grupo de roteamento monitora a configuração de roteamento que é gravada no Active Directory apenas para o seu grupo de roteamento. Servidores membros podem comunicar quaisquer informações sobre disponibilidade do servidor ou estado do conector para o mestre do grupo de roteamento. Por exemplo, se um servidor membro tentar contactar outro servidor em um grupo de roteamento diferente através de um conector, e esse vínculo não estiver disponível, o servidor membro notifica imediatamente o mestre do grupo de roteamento. Da mesma maneira, quando um servidor não mestre receber uma nova informação de estado de ligação, ele transferirá imediatamente a informação de estado do conector para o mestre de grupo de roteamento, para que outros servidores possam receber as informações sobre a alteração do roteamento.

Para corrigir esse erro

  1. No Gerenciador do Sistema Exchange e sob Grupos Administrativos, expanda Grupo_Administrativo e expanda Grupos de Roteamento.

  2. Expanda o grupo de roteamento e clique em Membros.

  3. No painel da direita, clique com o botão direito no computador do Exchange que você deseja configurar como mestre do grupo de roteamento e clique em Definir como Mestre.

Para obter mais informações sobre mestres de grupo de roteamento, consulte "Configuring a Routing Topology" no Exchange Server 2003 Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?linkid=47579).


Erro de associação do grupo de roteamento
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-21

A ferramenta Microsoft® Exchange Server Analyzer consulta no serviço de diretório do Active Directory® cada valor do atributo msExchRoutingGroupMembersBL nos objetos Routing Group para detectar se o servidor de vínculos inversos pertence ao grupo administrativo dedicado do Microsoft Exchange Server 2007, Grupo Administrativo do Exchange (FYDIBOHF23SPDLT).

O Exchange Server Analyzer também consulta o valor do atributo CN do objeto Routing Group para detectar se o valor é igual ao padrão do grupo de roteamento do Exchange 2007, Grupo de Roteamento do Exchange (DWBGZMFD01QNBJR).

O Exchange Server Analyzer exibirá um erro se as seguintes condições forem verdadeiras:

  • O servidor de links inversos pertence ao grupo administrativo dedicado do Exchange 2007, Grupo Administrativo do Exchange (FYDIBOHF23SPDLT).

  • O grupo de roteamento não é o padrão de grupo de roteamento do Exchange 2007, Grupo de Roteamento Exchange (DWBGZMFD01QNBJR).

Esse erro indica que o servidor pode ter sido movido manualmente do grupo de roteamento padrão do Exchange 2007. Isso pode causar problemas de roteamento.

O Microsoft Exchange Server 2003 e Microsoft Exchange 2000 Server usam grupos de roteamento para definir uma topologia de roteamento específica do Exchange. O Exchange 2007 usa sites do Active Directory para definir sua topologia de roteamento. O Exchange 2003 e o Exchange 2000 usam uma topologia de roteamento baseada em grupos de roteamento e conectores. Uma configuração de roteamento específica do Exchange não é mais necessária em uma organização pura do Exchange 2007. Uma organização pura do Exchange 2007 usa a topologia de sites do Active Directory para definir sua topologia de roteamento.

Para oferecer suporte para a coexistência entre essas duas topologias de roteamento, todos os servidores Exchange 2007 são automaticamente adicionados a um único grupo de roteamento durante a instalação do Exchange 2007. O grupo de roteamento do Exchange 2007 é reconhecido no Gerenciador do Sistema Exchange no Exchange 2003 ou Exchange 2000 como Grupo de Roteamento do Exchange (DWBGZMFD01QNBJR) dentro do Grupo Administrativo do Exchange (FYDIBOHF23SPDLT).

Para resolver esse problema, mova os servidores Exchange 2007 para o grupo de roteamento dedicado do Exchange 2007 ou remova e reinstale o servidor.


Conector de Envio Desabilitado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-07-30

A ferramenta Microsoft Exchange Analyzer usa o seguinte cmdlet do Shell de Gerenciamento do Exchange para todos os conectores de Envio do ambiente do Exchange que têm o valor de seu atributo Enabled definido como False. Um valor False no atributo Enabled do conector de Envio indica que o conector de Envio está desabilitado.

Get-SendConnector | where { $_.Enabled -eq $False}

O Exchange Analyzer consulta, então, o serviço de diretório do Active Directory para conhecer o valor do atributo serialNumber de todos os objetos da classe msExchExchangeServer.

Se o valor da cadeia de caracteres inclui Version 5.5, o computador está executando o Microsoft Exchange Server 5.5. Se o valor da cadeia de caracteres contém Versão 6.0, o computador está executando o Exchange 2000 Server. Se o valor da cadeia de caracteres inclui Version 6.5, o computador está executando o Exchange Server 2003 e se inclui Version 8, o computador está executando o Exchange Server 2007.

Caso o Exchange Analyzer determine que um conector de Envio está desabilitado em um ambiente do Exchange que também tenha os servidores Exchange 2000 ou Exchange 2003, um erro é exibido.

Esse erro indica que, enquanto o roteamento do Exchange 2007 irá ignorar conectores de Envio desabilitados, o Exchange 2000 e o Exchange 2003 não reconhecerão o sinalizador desabilitado do conector e ainda poderão tentar rotear mensagens através do conector, o que resultará em loops de roteamento.

Para solucionar este erro, exclua quaisquer conectores de Envio desabilitados em ambientes do Exchange que estejam executando o Exchange 2000 ou o Exchange 2003.

Pra excluir um conector de Envio desabilitado, siga as orientações para uso do cmdlet Remove-SendConnector do Shell de Gerenciamento do Exchange no tópico "Remove-SendConnector" (http://go.microsoft.com/fwlink/?LinkId=96007) da documentação do produto do Exchange Server 2007.


Filtragem por Remetente Habilitada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se a propriedade msExchServerBindingsTurflist de um objeto de servidor virtual SMTP indica que a filtragem do emissor está ativada para uma instância do servidor virtual SMTP.

O Exchange Server Analyzer também consulta o Active Directory para determinar se as propriedades msExchTurfListNames ou msExchTurfListOptions indicam que a filtragem do emissor também está hhabilitada no nível de configurações global.

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • A filtragem por remetente está habilitada na instância de servidor virtual SMTP.

  • A filtragem do emissor está ativada no nível de configurações global.

Esse aviso indica que a filtragem do emissor está efetivamente habilitada. Em geral, a filtragem do emissor não é um problema, a menos que esteja resolvendo problemas de fluxo de mensagens com esse servidor particular. Se esse for o caso, talvez você deseje verificar a configuração do filtro ou desabilitar temporariamente a filtragem do emissor para determinar se está bloqueando incorretamente mensagens legítimas de emissores válidos.

Para desabilitar um filtro do emissor em um servidor virtual SMTP

  1. Iniciar o Gerenciador do Sistema do Exchange: Clique em Iniciar, aponte para Todos os Programas, aponte para Microsoft Exchange e clique em Gerenciador do Sistema.

  2. Na árvore do console, expanda Servidores, expanda o servidor desejado e, em seguida, Protocolos e SMTP.

  3. Clique com o botão direito no servidor virtual SMTP em que deseja desabilitar o filtro e, em seguida, clique em Propriedades.

  4. Em Propriedades do <Servidor Virtual SMTP>, na guia Geral, clique em Avançado.

  5. Em Avançado, selecione o endereço IP para o qual deseja desabilitar o filtro e, em seguida, clique em Editar.

  6. Em Identificação, desmarque a caixa de seleção Aplicar Filtro de Remetente para desabilitar o filtro.

  7. Se houver vários servidores virtuais, repita as etapas 3 a 6 para cada servidor virtual em que deseje desabilitar o filtro.

Para obter mais informações sobre a filtragem inteligente de mensagens, consulte o site do Exchange Intelligent Message Filter (http://go.microsoft.com/fwlink/?LinkId=21607).

Para obter mais informações sobre como configurar a filtragem e o controle de spam, consulte "Configurando a Filtragem e o Controle de Spam" no Guia de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).


Filtragem por ID do Remetente Habilitada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se a propriedade msExchServerBindingsFiltering de um objeto de servidor virtual SMTP indica que o filtro de ID do remetente está habilitado para uma instância do servidor virtual SMTP.

O Exchange Server Analyzer também consulta o Active Directory para determinar se o atributo wWWHomePage do objeto Filtro de Conteúdo de UCE contém entradas para ID do remetente e filtro de conexão.

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • A filtragem por remetente está habilitada na instância de servidor virtual SMTP.

  • Filtro de remetente está habilitado no nível de objeto do Filtro de Conteúdo de UCE.

Esse aviso indica que o filtro de ID do remetente está habilitado de forma eficaz. O filtro de ID do remetente geralmente não é problema, a menos que você esteja solucionando problemas de fluxo de emails envolvendo esse servidor em particular. Se esse for o caso, você pode desejar verificar a configuração do filtro ou desabilitar temporariamente o filtro de ID do remetente para determinar se ele está bloqueando incorretamente emails de remetentes válidos.

Para desabilitar um filtro de ID de remetente em um servidor virtual SMTP

  1. Iniciar o Gerenciador do Sistema do Exchange: Clique em Iniciar, aponte para Todos os Programas, aponte para Microsoft Exchange e clique em Gerenciador do Sistema.

  2. Na árvore do console, expanda Servidores, expanda o servidor desejado e, em seguida, Protocolos e SMTP.

  3. Clique com o botão direito no servidor virtual SMTP em que deseja desabilitar o filtro e, em seguida, clique em Propriedades.

  4. Em Propriedades do <Servidor Virtual SMTP>, na guia Geral, clique em Avançado.

  5. Em Avançado, selecione o endereço IP para o qual deseja desabilitar o filtro e, em seguida, clique em Editar.

  6. Em Identificação, desmarque a caixa de seleção Aplicar Filtro de Remetente para desabilitar o filtro.

  7. Se houver vários servidores virtuais, repita as etapas 3 a 6 para cada servidor virtual em que deseje desabilitar o filtro.

Para obter mais informações sobre a filtragem inteligente de mensagens, consulte o site do Exchange Intelligent Message Filter (http://go.microsoft.com/fwlink/?LinkId=21607).


Servidor identificado como destino comum
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-04

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Exchange_Queue do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar os valores dos seguintes atributos das filas do protocolo SMTP do servidor virtual SMTP.

LinkId | Indica o identificador do link que contém a fila.
QueueId | Indica o identificador da fila.
QueueName | Indica o nome da fila.
VirtualMachine | Indica o nome da máquina virtual que contém a fila.
VirtualServerName | Indica o nome do servidor virtual em que a fila está.
MessageCount | Indica o número de mensagens na fila.

O Exchange Server Analyzer usa as informações obtidas aqui para consultar a classe Exchange_QueuedSMTPMessage do WMI em relação aos valores dos seguintes atributos das mensagens na fila:

Recipients | Indica os destinatários da mensagem.
Received | Indica o carimbo de hora recebido para a mensagem.
MessageId | Indica o identificador da mensagem em fila.
StateRetry | Indica que a transmissão é repetida para uma mensagem que não foi entregue com êxito.

Por fim, o Exchange Server Analyzer usa os dados obtidos aqui para consultar o serviço de diretório do Active Directory® em relação aos seguintes valores de cada objeto Destinatário. O Exchange Server Analyzer determina se o destinatário é um usuário, um grupo de distribuição, uma pasta pública ou um armazenamento de pasta pública.

distinguishedName | Indica o nome distinto do objeto.
msExchHomeServerName | Indica o servidor em que o destinatário está hospedado.
homeMDB | Indica o armazenamento de caixa de correio do destinatário.

Se determinar que pelo menos 25% das mensagens presas na fila estão endereçadas, no campo To: ou no campo Cc:, a destinatários hospedados em um servidor específico, o Exchange Server Analyzer exibirá um aviso.

Se determinar que pelo menos 50% das mensagens presas na fila estão endereçadas, no campo To: ou no campo Cc:, a destinatários hospedados em um servidor específico, o Exchange Server Analyzer exibirá um erro.

Esse aviso ou erro significa que o servidor identificado é um destino comum para mensagens que estão presas em uma fila SMTP.

Para resolver esse problema, investigue o servidor como mostrado a seguir para verificar se há problemas de configuração ou outras anomalias que poderão fazer com que as mensagens sejam colocadas em fila.

  • Verifique se os atributos de objeto de servidor estão corretamente definidos e contêm os valores corretos no Active Directory.

  • Reveja as permissões do Active Directory do objeto de servidor para obter as configurações corretas.

  • Se o servidor for o servidor primário de um objeto de usuário de uso especial, isto é, um destinatário de Registro no Diário designado, reveja as configurações do serviço ou os componentes aos quais o objeto de usuário está relacionado para obter a configuração correta.

  • Procure possíveis emails comerciais não solicitados, ou spams, ou ataques de vírus contra pastas públicas.

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Guia de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875) (pode estar em inglês).

  • Artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489). (pode estar em inglês).

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 895407 "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407) (pode estar em inglês).

  • 329171, "XADM: A entrega de mensagens fica lenta se os destinatários estão configurados com restrições de entrega baseadas em associação de grupos" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171) (pode estarem inglês).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949) (pode estar em inglês).

  • 812298 "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298) (pode estar em inglês).


Registro do coletor não encontrado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-01-11

A ferramenta Analisador do Microsoft® Exchange Server consulta a metabase do Microsoft IIS (Servidor de Informações da Internet) para enumerar a lista de ligações do coletor de eventos de transporte do SMTP (Simple Mail Transport Protocol). O Exchange Server Analyzer tenta localizar algumas ligações de evento padrão, com base em uma lista preenchida anteriormente no Exchange Server Analyzer. Para cada ligação, o Analisador do Exchange Server verifica os detalhes do Registro do COM (Modelo de Objeto do Componente) no Registro da seção a seguir:

HKEY_CLASSES_ROOT\CLSID\

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • Se houver uma ligação de coletor de eventos de transporte na metabase.

  • Se o registro COM correspondente estiver ausente do Registro.

Um evento de transporte do SMTP ocorre quando os dados da mensagem são transportados para dentro ou para fora do serviço SMTP. Todas as mensagens passam por eventos. Isso inclui mensagens de entrada ou saída X.400 e RPC. Um exemplo comum de um evento de transporte de entrada é a chegada de uma mensagem ao serviço SMTP pela rede ou no diretório de recebimento do SMTP. Quando esse evento de transporte ocorre, uma fonte desse evento notifica os coletores de eventos de transporte, cada um dos quais pode executar algum tipo de ação com base no conteúdo dos dados da mensagem. O sistema não executa nenhuma outra ação com os dados da mensagem depois que ele passa os dados da mensagem para o coletor, até que o coletor conclua sua ação e retorne a mensagem. O coletor tem controle exclusivo dos dados e do estado da mensagem enquanto executa essa ação.

A falta de registros COM para ligações de coletor de eventos de transporte pode causar problemas de fluxo de mensagens. Se o Exchange Server mostrar sintomas de problemas de fluxo de mensagens, como enfileiramento de mensagens, registre novamente os coletores de eventos de transporte.

Para registrar novamente os coletores de eventos de transporte

  1. No Microsoft Exchange Server, abra uma janela do prompt de comando e altere para a pasta \Arquivos de Programas\Exchsrvr\Bin.

  2. Digite os seguintes comandos para registrar novamente os coletores de eventos de transporte:

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. Execute novamente o Exchange Server Analyzer para verificar se os avisos ainda estão sendo exibidos. Se os avisos do registro de coleta de eventos continuarem sendo exibidos e ocorrerem problemas de fluxo de mensagens, contate o Atendimento Microsoft.

Para obter mais informações sobre ligações de coletores de eventos de transporte, consulte os seguintes recursos do Exchange:

  • Artigo 258224 do Base de Dados de Conhecimento da Microsoft, "XCON: Enumerando os Coletores de Eventos de Transporte Registrados " (http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224)

  • "Projeto de Serviço SMTP" no Guia de Referência Técnica do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876)


O host inteligente está definido no servidor virtual SMTP
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo msExchSmtpSmartHost foi configurado em um determinado servidor virtual SMTP. Se o Exchange Server Analyzer perceber que o atributo msExchSmtpSmartHost está configurado, ele exibirá um aviso.

Não é uma prática recomendada configurar um host inteligente em um servidor virtual SMTP. Em vez disso, você deve criar um conector SMTP e configurar o host inteligente nele.

No Exchange Server 2003, use o Assistente do Internet Mail para configurar a entrega de mensagens na Internet. Para obter mais informações, no Guia de Roteamento e Transporte do Exchange Server, consulte "Como usar o Assistente do Internet Mail" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=50099).

Para obter mais informações sobre como criar conectores SMTP, no Guia de Roteamento e Transporte do Exchange Server, consulte "Como criar um conector SMTP" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=50100).


O valor do Registro AdditionalPoolThreadsPerProc do SMTP foi definido manualmente
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-01-17

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se os threads de pool adicionais foram configurados manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\AdditionalPoolThreadsPerProc

Se o Exchange Server Analyzer detectar a presença e configuração de AdditionalPoolThreadsPerProc, será exibida uma mensagem de configuração não-padrão.

Existem cinco filas de trabalho no SMTP que usam um pool de threads conhecido como os threads ATQ. Pelo projeto, duas dessas filas podem, por padrão, usar até 90% dos threads disponíveis. Esse pool de threads é compartilhado pelo processo que aceita solicitações POP e IMAP. Portanto, em uma situação de carga moderada para alta, pode surgir uma circunstância em que o SMTP pode manter recursos dos serviços POP e IMAP.

Você pode reservar threads adequados para POP e IMAP limitando a porcentagem de threads que o SMTP pode usar. Para efetuar essa alteração, aumente o número total de threads disponíveis para o IIS. A única alternativa aqui é o aumento do uso de memória para os threads adicionais.

Existem dois valores de Registro que permitem controlar a porcentagem de threads do SMTP e threads adicionais por processador:

Local: HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

Valor: AdditionalPoolThreadsPerProc

Tipo: REG_DWORD

Local: HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

Valor: MaxPercentPoolThreads

Tipo: REG_DWORD

Ambos os valores do Registro devem ser ajustados em computadores agrupados do Exchange Server se a alta atividade do SMTP ocasiona a falha do POP3, IMAP4 ou de ambos os recursos. Você pode usar as fórmulas a seguir para calcular o valor ideal para seu cluster:

Valor de Registro | Fórmula
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * Número de servidores virtuais do protocolo)

Por exemplo, em um cluster do Exchange Server com dois servidores virtuais do protocolo, a fórmula para MaxPercentPoolThreads é 90 / (2*2) = 22. Ao calcular o valor de MaxPercentPoolThreads, se os cálculos resultarem em um valor que inclui uma vírgula decimal, você deverá arredondar o resultado para o próximo inteiro abaixo. Ao calcular o valor de AdditionalPoolThreadsPerProc, se os cálculos resultarem em um valor maior que 200, você também precisará atribuir o valor resultante a um valor de Registro adicional:

Local: HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

Valor: PoolThreadLimit

Tipo: REG_DWORD

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar a definição ideal no cluster do Exchange

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Crie um valor de Registro DWORD denominado AdditionalPoolThreadsPerProc e defina seus dados de valor para o número apropriado, com base nas fórmulas anteriores.

  4. Crie um valor de Registro DWORD denominado MaxPercentPoolThreads e defina seus dados de valor para o número apropriado, com base nas fórmulas anteriores.

  5. Feche o editor de Registro e reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o problema específico de recurso de cluster descrito neste artigo, consulte o artigo 281868 da Base de Dados de Conhecimento Microsoft, "XADM: Os servidores virtuais POP\IMAP4 falham repetidamente sob carga alta" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868).


Arquivo Morto do SMTP:Conjunto de cabeçalhos P1 do arquivo morto
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de registro para determinar se o Arquivo Morto do SMTP foi instalado e habilitado:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Dump P1

Se o Exchange Server Analyzer perceber que o valor de Dump P1 é maior que 0, uma mensagem de configuração não padrão será exibida.

O valor 0 indica que o arquivamento do cabeçalho P1 está desabilitado. O valor 1 indica que o arquivamento do cabeçalho P1 está habilitado. Valores diferentes de 0 ou 1 não têm suporte.

A ferramenta Arquivo Morto do SMTP é um script personalizado que habilita o arquivamento de todas as mensagens que entram e saem de uma pasta específica de um servidor Exchange. Por padrão, quando o Coletor de Arquivo Morto do SMTP está habilitado, todas as mensagens e seus destinatários são arquivados em um arquivo .eml, exceto os destinatários Cco.

Os cabeçalhos P1 também são conhecidos como dados de "envelope". Os dados de envelope representam a lista de destinatários real que o Exchange gera quando uma mensagem está em trânsito. Esses dados permitem que todos os destinatários recebam a mensagem. Ao contrário dos cabeçalhos P2, que são os destinatários conforme declarado pelo remetente em uma determinada mensagem recebida, os dados de envelope são alterados à medida que são transmitidos a vários destinos. Essas alterações ocorrem devido à expansão da lista de distribuição e ao comportamento da lista de distribuição oculta.

Por padrão, os cabeçalhos P1 não são arquivados quando você instala e habilita o Coletor de Arquivo Morto do SMTP. Normalmente, o arquivamento de cabeçalho P1 só é habilitado para fins de solução de problemas.

Se não quiser arquivar os cabeçalhos P1 nesse computador do Exchange, você poderá definir a chave do Registro Dump P1 como 0, ou você poderá desinstalar o Coletor de Arquivo Morto do SMTP. Quando você desinstala o Arquivo Morto do SMTP, todas as chaves de Registro usadas por ele são excluídas.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para desabilitar o arquivamento do cabeçalho P1

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Clique duas vezes na chave de Registro Dump P1, no campo Dados do valor, digite 0 e clique em OK.

  4. Feche o editor do Registro e reinicie o Serviço de Administração do IIS para que as alterações entrem em vigor.

Para desinstalar o Arquivo Morto do SMTP

  1. Clique em Iniciar, clique em Executar, digite cmd e clique em OK.

  2. Na pasta C:\Program Files\Exchsrvr\bin, digite cscript archivesink_setup.vbs e pressione Enter.

  3. Digite cscript archivesink_setup.vbs uninstall Virtual Server ID, onde Virtual Server ID é o número do servidor virtual em que o Arquivo Morto do SMTP está instalado.

  4. Saia da janela Prompt de Comando e reinicie o Serviço de Administração do IIS para que as alterações entrem em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar o Arquivo Morto do SMTP no Exchange Server 2003, consulte o artigo 871110 da Base de Dados de Conhecimento, "How to install and use the Archive Sink utility in Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Para obter mais informações sobre como configurar o Arquivo Morto do SMTP no Exchange 2000 Server, consulte o artigo 307798 da Base de Dados de Conhecimento, "The Archive Sink utility is available in Service Pack 2" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Para obter informações sobre como implantar uma solução de diário abrangente para fins de conformidade com regulamentos, consulte Journaling with Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47581).


Arquivo Morto do SMTP habilitado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de registro para determinar se o Arquivo Morto do SMTP foi instalado e habilitado:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable Smtp Messages

Se o Exchange Server Analyzer perceber que o valor de Enable Smtp Messages é maior que 0, uma mensagem de configuração não padrão será exibida.

Um valor 0 indica que o Coletor de Arquivo Morto do SMTP está desabilitado. Um valor 1 indica que o Coletor de Arquivo Morto do SMTP está habilitado. Valores diferentes de 0 ou 1 não têm suporte.

A ferramenta Arquivo Morto do SMTP é um script personalizado que habilita o arquivamento de todas as mensagens que entram e saem de uma pasta específica de um servidor Exchange. Por padrão, quando o Arquivo Morto do SMTP é habilitado, todas as mensagens e seus destinatários são arquivados em um arquivo .eml, exceto os destinatários Cco.

Por padrão, quando você habilita o arquivamento SMTP com o Coletor de Arquivo Morto do SMTP, todas as mensagens enviadas para transporte por SMTP pelo armazenamento do Exchange, ou por quaisquer outros coletores, disparam esse evento. Teoricamente, esse evento pode ser gerado uma vez para cada mensagem e ser arquivado apenas uma vez. O evento OnMessageSubmission é gerado antes dos eventos do categorizador ou de roteamento. Portanto, essas mensagens são chamadas de mensagens PreCat. Por padrão, as mensagens são arquivadas para esse evento quanto o Coletor de Arquivo Morto do SMTP é instalado. Mensagens arquivadas para esse evento contém o nome de arquivo de prefixo: ARCH_número aleatório.xml.

Se não desejar arquivar mensagens nesse computador do Exchange, você pode definir a chave do Registro Enable Smtp Messages como 0 ou desinstalar o Coletor de Arquivo Morto do SMTP. Quando você desinstala o Arquivo Morto do SMTP, todas as chaves de Registro usadas por ele são excluídas.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para desabilitar o Coletor de Arquivo Morto do SMTP

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Clique duas vezes na chave de Registro Enable Smtp Messages, no campo Dados do valor, digite 0 e clique em OK.

  4. Saia do editor do Registro e reinicie o Serviço de Administração do IIS para que as alterações entrem em vigor.

Para desinstalar o Arquivo Morto do SMTP

  1. Clique em Iniciar, clique em Executar, digite cmd e clique em OK.

  2. Na pasta C:\Program Files\Exchsrvr\bin, digite cscript archivesink_setup.vbs e pressione Enter.

  3. Digite cscript archivesink_setup.vbs uninstall Virtual Server ID, onde Virtual Server ID é o número do servidor virtual em que o Arquivo Morto do SMTP está instalado.

  4. Saia da janela Prompt de Comando e reinicie o Serviço de Administração do IIS para que as alterações entrem em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar o Arquivo Morto do SMTP no Exchange Server 2003, consulte o artigo 871110 da Base de Dados de Conhecimento, "How to install and use the Archive Sink utility in Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Para obter mais informações sobre como configurar o Arquivo Morto do SMTP no Exchange 2000 Server, consulte o artigo 307798 da Base de Dados de Conhecimento, "The Archive Sink utility is available in Service Pack 2" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Para obter mais informações sobre como implantar uma solução completa de diário com fins de conformidade com regulamentos, consulte Registrando em diário com o Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47581).


Arquivo Morto do SMTP:Pós-categorização definida
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de registro para determinar se o Arquivo Morto do SMTP foi instalado e habilitado:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PostCat

Se o Exchange Server Analyzer perceber que o valor de Enable PostCat é maior que 0, uma mensagem de configuração não padrão será exibida.

Um valor igual a 0 indica que o arquivamento de mensagens pós-categorização está desabilitado. Um valor igual a 1 indica que o arquivamento de mensagens pós-categorização está habilitado. Valores diferentes de 0 ou 1 não têm suporte.

A ferramenta Arquivo Morto do SMTP é um script personalizado que habilita o arquivamento de todas as mensagens que entram e saem de uma pasta específica de um servidor Exchange. Por padrão, quando o Arquivo Morto do SMTP é habilitado, todas as mensagens e seus destinatários são arquivados em um arquivo .eml, exceto os destinatários Cco.

Quando Enable PostCat está definido como 1, as mensagens são arquivadas após a categorização de uma mensagem. As mensagens podem acionar esse evento mais de uma vez, mas isso só pode ocorrer quando uma mensagem foi categorizada, enfileirada e depois enumerada novamente. As mensagens arquivadas para esse evento contêm o nome do arquivo de prefixo ARCH_POSTCAT_número aleatório.xml.

Se você não deseja arquivar as mensagens de pós-categorização nesse computador do Exchange, poderá definir a chave do Registro Enable PostCat como 0. Se não desejar arquivar nunca nesse computador, você poderá desinstalar o Coletor de Arquivo Morto do SMTP. Quando você desinstala o Arquivo Morto do SMTP, todas as chaves de Registro usadas por ele são excluídas.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para desabilitar o arquivamento de mensagens pós-categorização

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Clique duas vezes na chave de Registro Enable PostCat, no campo Dados do valor, digite 0 e clique em OK.

  4. Saia do editor do Registro e reinicie o Serviço de Administração do IIS para que as alterações entrem em vigor.

Para desinstalar o Arquivo Morto do SMTP

  1. Clique em Iniciar, clique em Executar, digite cmd e clique em OK.

  2. Na pasta C:\Program Files\Exchsrvr\bin, digite cscript archivesink_setup.vbs e pressione Enter.

  3. Digite cscript archivesink_setup.vbs uninstall Virtual Server ID, onde Virtual Server ID é o número do servidor virtual em que o Arquivo Morto do SMTP está instalado.

  4. Saia da janela Prompt de Comando e reinicie o Serviço de Administração do IIS para que as alterações entrem em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar o Arquivo Morto do SMTP no Exchange Server 2003, consulte o artigo 871110 da Base de Dados de Conhecimento, "Como instalar e usar o utilitário Arquivo Morto no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Para obter mais informações sobre como configurar o Arquivo Morto do SMTP no Exchange 2000 Server, consulte o artigo 307798 da Base de Dados de Conhecimento, "O utilitário de Arquivo Morto está disponível no Service Pack 2" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Para obter informações sobre como implantar uma solução de diário abrangente para fins de conformidade com regulamentos, consulte Journaling with Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47581).


Arquivo Morto do SMTP:Conjunto de pré-categorização
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de registro para determinar se o Arquivo Morto do SMTP foi instalado e habilitado:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PreCat

Se o Exchange Server Analyzer perceber que o valor de Enable PreCat é maior que 0, uma mensagem de configuração não padrão será exibida.

Um valor de 0 indica que o arquivamento da mensagem de pré-categorização está desabilitado. Um valor de 1 indica que o arquivamento da mensagem de pré-categorização está habilitado. Valores diferentes de 0 ou 1 não têm suporte.

A ferramenta Arquivo Morto do SMTP é um script personalizado que habilita o arquivamento de todas as mensagens que entram e saem de uma pasta específica de um servidor Exchange. Por padrão, quando o Arquivo Morto do SMTP é habilitado, todas as mensagens e seus destinatários são arquivados em um arquivo .eml, exceto os destinatários Cco.

Todas as mensagens enviadas para serem transportadas por SMTP, por armazenamento do Exchange ou por qualquer outro coletor acionam esse evento. Teoricamente, esse evento pode ser gerado uma vez para cada mensagem e ser arquivado apenas uma vez. O evento OnMessageSubmission é gerado antes dos eventos do categorizador ou de roteamento. Portanto, essas mensagens são chamadas de mensagens PreCat. Por padrão, as mensagens são arquivadas para esse evento quando o utilitário Coletor Ativo do SMTP está instalado. As mensagens arquivadas para esse evento contêm o prefixo ARCH_número aleatório.xml no nome do arquivo.

Se você não quiser arquivar mensagens de pré-categorização neste computador do Exchange, poderá definir a chave do Registro Enable PreCat como 0. Se não desejar arquivar nunca nesse computador, você poderá desinstalar o Coletor de Arquivo Morto do SMTP. Quando você desinstala o Arquivo Morto do SMTP, todas as chaves de Registro usadas por ele são excluídas.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para desabilitar o arquivamento de mensagem de pré-categorização

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Clique duas vezes na chave de Registro Enable PreCat, no campo Dados do valor, digite 0 e clique em OK.

  4. Feche o editor do Registro e reinicie o Serviço de Admin IIS para que as alterações entrem em vigor.

Para desinstalar o Arquivo Morto do SMTP

  1. Clique em Iniciar, clique em Executar, digite cmd e clique em OK.

  2. Na pasta C:\Program Files\Exchsrvr\bin, digite cscript archivesink_setup.vbs e pressione Enter.

  3. Digite cscript archivesink_setup.vbs uninstall Virtual Server ID, onde Virtual Server ID é o número do servidor virtual em que o Arquivo Morto do SMTP está instalado.

  4. Saia da janela Prompt de Comando e reinicie o Serviço de Administração do IIS para que as alterações entrem em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar o Coletor de Arquivo Morto do SMTP no Exchange Server 2003, consulte o artigo 871110 da Base de Dados de Conhecimento Microsoft, "Como instalar e usar o utilitário Coletor de Arquivo Morto no Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Para obter mais informações sobre como configurar o Coletor de Arquivo Morto do SMTP no Exchange 2000 Server, consulte o artigo 307798, "O utilitário Coletor de Arquivo Morto está disponível no Service Pack 2" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110) na Base de Dados de Conhecimento Microsoft.

Para obter informações sobre como implantar uma solução de diário abrangente para fins de conformidade com regulamentos, consulte Journaling with Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47581).


Arquivo Morto do SMTP:As mensagens do sistema estão sendo arquivadas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de registro para determinar se o Arquivo Morto do SMTP foi instalado e habilitado:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Archive System Messages

Se o Exchange Server Analyzer perceber que o valor de Archive System Messages é maior que 0, uma mensagem de configuração não padrão será exibida.

Um valor de 0 indica que as mensagens do sistema não estão arquivadas. Um valor de 1 indica que as mensagens do sistema estão arquivadas. Valores diferentes de 0 ou 1 não têm suporte.

A ferramenta Arquivo Morto do SMTP é um script personalizado que habilita o arquivamento de todas as mensagens que entram e saem de uma pasta específica de um servidor Exchange. Por padrão, quando o Arquivo Morto do SMTP é habilitado, todas as mensagens e seus destinatários são arquivados em um arquivo .eml, exceto os destinatários Cco.

Se você não quiser arquivar mensagens do sistema neste computador do Exchange, poderá definir a chave do Registro Archive System Messages como 0. Se não desejar arquivar nunca nesse computador, você poderá desinstalar o Coletor de Arquivo Morto do SMTP. Quando você desinstala o Arquivo Morto do SMTP, todas as chaves de Registro usadas por ele são excluídas.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para desabilitar o arquivamento de mensagens do sistema

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Clique duas vezes na chave de Registro Archive System Messages, no campo Dados do valor, digite 0 e clique em OK.

  4. Feche o editor do Registro e reinicie o Serviço de Administração do IIS para que as alterações entrem em vigor.

Para desinstalar o Arquivo Morto do SMTP

  1. Clique em Iniciar, clique em Executar, digite cmd e clique em OK.

  2. Na pasta C:\Program Files\Exchsrvr\bin, digite cscript archivesink_setup.vbs e pressione Enter.

  3. Digite cscript archivesink_setup.vbs uninstall Virtual Server ID, onde Virtual Server ID é o número do servidor virtual em que o Arquivo Morto do SMTP está instalado.

  4. Feche a janela do prompt de comando e reinicie o Serviço de Administração do IIS para que as alterações entrem em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como configurar o Arquivo Morto do SMTP no Exchange Server 2003, consulte o artigo 871110 da Base de Dados de Conhecimento, "How to install and use the Archive Sink utility in Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Para obter mais informações sobre como configurar o Arquivo Morto do SMTP no Exchange 2000 Server, consulte o artigo 307798 da Base de Dados de Conhecimento, "The Archive Sink utility is available in Service Pack 2" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Para obter informações sobre como implantar uma solução de diário abrangente para fins de conformidade com regulamentos, consulte Journaling with Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47581).


Os dados de Mensagens Inválidas do SMTP estão sendo gravados em uma pasta compactada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Directory do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Compressed da pasta Mensagens Inválidas do SMTP. Se o Exchange Server Analyzer localizar o valor para Compressed definido como True, um aviso será exibido.

Quando chegam mensagens ao computador do Exchange através do serviço SMTP, os dados são gravados no disco rígido como um arquivo .eml. Por padrão, esses arquivos são armazenados na pasta :\Arquivos de Programas\Exchsrvr\Mailroot da <unidade> na mesma partição em que o Exchange está instalado. Se a pasta na qual são armazenados os dados de mensagens inválidas do SMTP tiver a compactação de arquivos ativada, o desempenho do Exchange poderá ser seriamente reduzido. Por essa razão, não há suporte para compactação na pasta onde são armazenados dados de mensagens inválidas SMTP.

Se você receber esse aviso, desative a compactação na pasta onde são armazenados dados de mensagens inválidas SMTP, ou mova esses dados para uma pasta não compactada.

A Microsoft não dá suporte ao armazenamento de arquivos de dados do Exchange em um volume compactado. Quando você armazenar seus arquivos de dados do Exchange em um volume compactado, a sobrecarga adicional impactará bastante o desempenho do Exchange. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Para desativar a compactação de arquivos em uma pasta específica

  1. Clique com o botão direito na pasta em que deseja desativar a compactação de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Compactar o conteúdo para economizar espaço em disco e clique em OK.

Para mover a pasta Mensagens Inválidas no Exchange 2000 Server ou Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Clique em Grupos Administrativos, expanda seu grupo administrativo, Servidores, expanda seu servidor, Protocolos e SMTP.

  3. Clique com o botão direito no seu servidor virtual SMTP e clique em Parar.

  4. Clique com o botão direito no seu servidor virtual SMTP e clique em Propriedades.

  5. Na guia Mensagens, ao lado da caixa Diretório de mensagens inválidas, clique em Procurar e digite o caminho do novo local da pasta Fila.

  6. Clique em OK.

  7. Clique com o botão direito no seu servidor virtual SMTP e clique em Iniciar.

Para obter mais informações sobre como mover a pasta Mailroot, consulte o artigo 822933 da Base de Dados de Conhecimento da Microsoft, "How to change the Exchange 2003 SMTP Mailroot folder location" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).


Os dados de mensagens inválidas do SMTP estão sendo gravados em uma partição não-NTFS
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_NetworkAdapter de WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave FSName para o diretório de mensagens inválidas de SMTP do Exchange. Se o Analisador do Exchange Server determinar que o valor da chave FSName não é igual a NTFS, será exibido um aviso.

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em volumes não-NTFS. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

Ao ver esse aviso, você deve mover o Diretório de Mensagens Inválidas de SMTP para uma pasta na unidade de sistema do arquivo NTFS. Como alternativa, se a unidade na qual o diretório de Mensagens Inválidas está armazenado estiver formatada como uma unidade FAT, você poderá usar a ferramenta de linha de comando convert.exe para converter a unidade em NTFS.

Para mover o diretório de mensagens inválidas do SMTP para outra pasta

  1. Inicie o Gerenciador do Sistema Exchange.

  2. Clique em Grupos Administrativos, expanda seu grupo administrativo, Servidores, expanda seu servidor, Protocolos e SMTP.

  3. Clique com o botão direito no seu servidor virtual SMTP e clique em Parar.

  4. Clique com o botão direito no seu servidor virtual SMTP e clique em Propriedades.

  5. Na guia Mensagens, ao lado da caixa Diretório de mensagens inválidas, clique em Procurar e digite o caminho do novo local da pasta Mensagens inválidas.

  6. Clique em OK.

  7. Clique com o botão direito no seu servidor virtual SMTP e clique em Iniciar.

Para obter mais informações sobre como mover a pasta Mailroot, consulte o artigo 822933 da Base de Dados de Conhecimento da Microsoft, "How to change the Exchange 2003 SMTP Mailroot folder location" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Uma alternativa para o procedimento, se a unidade na qual os arquivos estão armazenados estiver formatada como uma unidade FAT, você poderá usar a ferramenta de linha de comando convert.exe para converter a unidade em NTFS. Para obter informações sobre como usar a ferramenta de linha de comando convert.exe para converter uma partição FAT em uma partição NTFS, consulte o artigo 214579 da Base de Dados de Conhecimento Microsoft, "Como usar o convert.exe para converter uma partição no sistema de arquivos NTFS" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579) (página em inglês).


Os dados de Mensagens Inválidas do SMTP estão sendo gravados em uma pasta criptografada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Directory do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Encrypted da pasta Mensagens Inválidas SMTP. Se o Exchange Server Analyzer perceber que o valor para Criptografado está definido como Verdadeiro, um aviso será exibido.

Quando chegam mensagens ao computador do Exchange através do serviço SMTP, os dados são gravados no disco rígido como um arquivo .eml. Por padrão, esses arquivos são armazenados na pasta :\Arquivos de Programas\Exchsrvr\Mailroot da <unidade> na mesma partição em que o Exchange está instalado. Se a pasta na qual são armazenados os dados de mensagens inválidas do SMTP tiver a criptografia de arquivo ativada, o desempenho do Exchange poderá ser reduzido gravemente. Portanto, não há suporte para criptografia da pasta onde são armazenados dados de mensagens inválidas SMTP.

Se você receber esse aviso, desative a criptografia na pasta onde são armazenados dados de mensagens inválidas SMTP, ou mova esses dados para uma pasta não criptografada.

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em um volume criptografado com EFS (Sistema de Criptografia de Arquivos). Quando você armazena seus arquivos de dados do Exchange em um volume criptografado, a sobrecarga afeta significativamente o desempenho do Exchange. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Para ajudar a proteger seus arquivos de dados do Exchange, é recomendável que você impeça o acesso não autorizado ao computador do Exchange e que você use o formato de mensagem S/MIME para criptografar dados de mensagens.

Para resolver esse erro, é necessário desativar a criptografia de arquivo na pasta Mensagens Inválidas ou mover a pasta Mensagens Inválidas para um local onde a critografia não esteja habilitada.

Para desativar a criptografia de arquivos em uma determinada pasta

  1. Clique com o botão direito na pasta em que deseja desativar a criptografia de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Criptografar o conteúdo para proteger dados e clique em OK.

Para mover a pasta Mensagens Inválidas no Exchange 2000 Server ou Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Clique em Grupos Administrativos, expanda seu grupo administrativo, Servidores, expanda seu servidor, Protocolos e SMTP.

  3. Clique com o botão direito no seu servidor virtual SMTP e clique em Parar.

  4. Clique com o botão direito no seu servidor virtual SMTP e clique em Propriedades.

  5. Na guia Mensagens, ao lado da caixa Diretório de mensagens inválidas, clique em Procurar e digite o caminho do novo local da pasta Fila.

  6. Clique em OK.

  7. Clique com o botão direito no seu servidor virtual SMTP e clique em Iniciar.

Para obter mais informações sobre como mover a pasta Mailroot, consulte o artigo 822933 da Base de Dados de Conhecimento da Microsoft, "How to change the Exchange 2003 SMTP Mailroot folder location" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Para obter mais informações sobre o EFS e os arquivos de dados do Exchange Server, consulte o artigo 834638 da Base de Dados de Conhecimento da Microsoft, "Information about the storage of data files on an encrypted volume in Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Para obter informações sobre como proteger mensagens no Exchange Server 2003, consulte Guia de Segurança de Mensagens do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=47574).


O valor do Registro CatRetryMinutes do SMTP não é padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se as configurações padrão de enfileiramento do SMTP foram alteradas:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se o Exchange Server Analyzer perceber que a chave CatRetryMinutes foi definida, o Exchange Server Analyzer exibirá uma mensagem não padrão.

É recomendável que os valores de enfileiramento padrão só sejam modificados após uma consideração completa. Os padrões foram selecionados atentamente para obter o desempenho ideal na maioria dos ambientes. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento do enfileiramento no Exchange Server.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre o enfileiramento do SMTP do Exchange, consulte a seguinte entrada no Blog da Equipe do Microsoft Exchange, "Explaining the Mysterious SMTP Advanced Queuing Engine" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=48585).


Aviso de configuração de SMTP
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-03

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar se o valor para o atributo msExchSmtpMaxMessageSize foi alterado do valor padrão 0. Por padrão, o atributo msExchSmtpMaxMessageSize é configurado para tamanho ilimitado de mensagem.

O Exchange Server Analyzer exibirá um aviso se existirem as seguintes condições:

  • O atributo msExchSmtpMaxMessageSize não tiver um valor igual a 0.

  • O Exchange não estiver executando no Microsoft Windows® Small Business Server 2003.

O atributo msExchSmtpMaxMessageSize representa o tamanho máximo de cada mensagem SMTP que pode ser enviada ou recebida. De uma perspectiva de segurança, é uma prática recomendada limitar o tamanho máximo das mensagens SMTP que podem ser enviadas e recebidas de e para a Internet. Entretanto, para mensagens SMTP internas, como aquelas que trafegam entre os servidores Exchange na mesma organização, é recomendável deixar o atributo msExchSmtpMaxMessageSize definido como 0.

Internamente, o Exchange usa mensagens SMTP para manipular tarefas como replicação de pasta pública. Se o atributo msExchSmtpMaxMessageSize estiver configurado para ter um limite muito baixo, esse limite poderá causar problemas de replicação de pasta pública e outras falhas de entrega de mensagens intra-organizacionais.

Se o servidor Exchange for um servidor bridgehead que transfere mensagens SMTP de e para a Internet, você poderá ignorar esse aviso com segurança. Se esse servidor Exchange manipula mensagens SMTP internas, você deverá alterar o valor do atributo msExchSmtpMaxMessageSize para sua configuração padrão igual a 0.

Observação:
Se você definir um limite de tamanho de mensagem muito baixo, isso poderá impedir a replicação do catálogo de endereços offline entre computadores do Exchange Server. Para obter mais informações, consulte o artigo 326154 da Base de Dados de Conhecimento da Microsoft, "Não é possível baixar o catálogo de endereços offline no Microsoft Outlook no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154).
Para exibir e configurar o tamanho de mensagem SMTP máximo

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  2. Clique com o botão direito em um servidor virtual SMTP, por exemplo, Servidor Virtual SMTP Padrão, e selecione Propriedades.

  3. Selecione a guia Mensagens.

  4. Para reverter para a configuração padrão igual a 0, desmarque a caixa de seleção Limitar tamanho da mensagem a (KB). Como alternativa, deixe essa caixa marcada e configure o valor desejado.

  5. Clique em OK para salvar as alterações e fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: How to Configure a SMTP Virtual Server Part 1" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, "XCON: How to Configure a SMTP Virtual Server Part 2" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Conector SMTP com restrições de entrega do grupo de distribuição definidas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer consulta os seguintes atributos de cada objeto Conector SMTP (Simple Mail Transfer Protocol) (msExchRoutingSMTPConnector)) detectados no serviço de diretório do Active Directory®, para detectar se têm restrições de entrega definidas, baseadas em associação de grupos de distribuição.

dLMemRejectPerms | Contém os nomes de domínio (DNs) de listas de distribuição (DL) cujos membros não podem enviar através deste Conector SMTP
dLMemSubmitPerms | Contém os nomes de domínio (DNs) de listas de distribuição (DL) cujos membros podem enviar através deste Conector SMTP

Ao detectar a existência de Conectores SMTP que possuem restrições de entrega definidas, com base em associação de grupos de distribuição, o Exchange Server Analyzer exibirá um aviso.

Este aviso indica que as restrições da entrega baseadas em associação de grupos de distribuição podem afetar o desempenho do fluxo de mensagens do Exchange.

Quando você envia mensagens usando Conectores SMTP com restrições de entrega definidas com base em associação de grupos de distribuição, o categorizador de mensagens deve expandir a associação do grupo de distribuição, obter a lista completa dos DNs dos membros e depois comparar essa lista aos DNs do remetente da lista. Uma operação de acesso ou de negação ocorre quando há correspondência de um DN em ambas as listas. Se um grupo de distribuição estiver aninhado em outro grupo de distribuição, a distribuição aninhada também será expandida.

Para tratar desse aviso:

  • Crie um grupo de roteamento dedicado para restrições do conector e configure-o para um Grupo de Roteamento local, como citado no artigo 329171 da Base de Conhecimento Microsoft, "XADM: A entrega de mensagens fica lenta se os destinatários estão configurados com restrições de entrega baseadas em associação de grupos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Use um servidor de catálogo global dedicado e mais robusto como o servidor bridgehead designado para o conector.

  • Configure caixas de correio individuais e não grupos de distribuição para restrições de entrega, como citado no artigo 812298 da Base de Dados de Conhecimento Microsoft, "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Considere a implementação de filtragem de remetentes SMTP.

  • Para os servidores executando o Exchange Server 2003 Service Pack 2 (SP2) ou versão posterior, considere a implementação de verificação de restrição não-hierárquica. Para os servidores com versões do Exchange anteriores ao Exchange 2003 SP2, considere uma atualização para o Exchange 2003 SP2.

Para obter mais informações

Para obter mais informações sobre a verificação de restrição não-hierárquica, consulte Considere a verificação da restrição não hierárquica.

Para obter mais informações sobre a filtragem de remetentes SMTP, consulte "Como habilitar a filtragem de remetentes" no Guia de Administração do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=72967).

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 329171, "XADM: A entrega de mensagens fica lenta se os destinatários estão configurados com restrições de entrega baseadas em associação de grupos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)

  • 895407 "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407) (em inglês).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949) (em inglês).


A regravação do domínio SMTP está habilitada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o valor do atributo heuristics no objeto do Servidor Virtual SMTP deste servidor do Exchange. Se o Exchange Server Analyzer verificar que o valor do atributo heuristics não é o valor padrão 131072, será exibido um erro.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre a ferramenta Reconfiguração de Endereço do Exchange Server, consulte Reconfiguração de Endereço do Exchange Server (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=25932).


O valor do Registro FailedMsgQRetryMinutes do SMTP é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se as configurações padrão de enfileiramento do SMTP foram alteradas:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se o Exchange Server Analyzer perceber que a chave FailedMsgQRetryMinutes foi definida, o Exchange Server Analyzer exibirá uma mensagem não padrão.

É recomendável que os valores de enfileiramento padrão só sejam modificados após uma consideração completa. Os padrões foram selecionados atentamente para obter o desempenho ideal na maioria dos ambientes. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento do enfileiramento no Exchange Server.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre o enfileiramento do SMTP do Exchange, consulte a seguinte entrada no Blog da Equipe do Microsoft Exchange, "Explaining the Mysterious SMTP Advanced Queuing Engine" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=48585).


O valor do Registro LocalDeliveryMaxBatch do SMTP é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada de Registro para determinar se a definição padrão no valor do Registro LocalDeliveryMaxBatch foi alterada:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%.

Se o Analisador do Exchange Server detectar que a definição do valor de Registro LocalDeliveryMaxBatch foi criada manualmente, alterando a definição binária padrão de 80 do servidor Exchange, exibirá uma mensagem de aviso não padrão.

Por padrão, o valor de Registro LocalDeliveryMaxBatch não é criado durante a instalação do Exchange Server. O valor do Registro LocalDeliveryMaxBatch pode ser criado manualmente após a instalação do Exchange Server para alterar o modo como o Armazenamento de Informações do Exchange processa e entrega internamente as mensagens. O servidor Exchange pode ter problemas de desempenho de armazenamento e transporte de mensagens, se as seguintes condições forem verdadeiras:

  • O valor do Registro LocalDeliveryMaxBatch for criado manualmente.

  • A definição do valor do Registro LocalDeliveryMaxBatch estiver configurada incorretamente.

É recomendável que o valor de Registro LocalDeliveryMaxBatch só seja criado ou modificado após uma avaliação cuidadosa. Os valores padrão nos binários para o servidor Exchange foram cuidadosamente selecionados para o desempenho ideal para uso na maioria dos ambientes do servidor Exchange. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento padrão do Exchange Server, configurando manualmente o Registro. Para cumprir as práticas recomendadas, se o valor do Registro LocalDeliveryMaxBatch já existir, talvez você queira excluí-lo para retornar o servidor Exchange à configuração binária padrão.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. No entanto, talvez você deseje retornar o valor de Registro à configuração padrão editando o Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para corrigir esse aviso

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para a chave de Registro a seguir: HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%

  3. No painel de detalhes, clique com o botão direito no no valor de Registro LocalDeliveryMaxBatch, clique em Modificar e altere os Dados do valor para 80. Clique em OK.

    Observação:
    Para excluir o valor do Registro LocalDeliveryMaxBatch, no painel de detalhes, clique com o botão direito no valor do Registro LocalDeliveryMaxBatch e clique em Excluir. Confirme a exclusão do valor de Registro clicando em Sim na caixa de diálogo.

  4. Feche o editor de Registro.

  5. Reinicie o servidor Exchange.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como editar o Registro do Microsoft Windows, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 322755, "Como fazer o backup, editar e restaurar o Registro no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "Como fazer o backup, editar e restaurar o Registro no Windows XP e Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


FQDN de instância do protocolo SMTP não corresponde ao nome de servidor resolvido do DNS
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-04

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para obter o valor do atributo msExchSmtpFullyQualifiedDomainName do objeto de servidor virtual do SMTP.

O Exchange Server Analyzer também tenta realizar um consulta de DNS (sistema de nome de domínio) nos servidores DNS configurados para o FQDN (nome de domínio totalmente qualificado) do servidor que está executando o Exchange Server. Essa conexão é estabelecida por meio de um processador de objeto personalizado que executa uma solicitação de resolução de nome e analisa os resultados.

O Exchange Server Analyzer compara os resultados das duas consultas. Se o valor do atributo msExchSmtpFullyQualifiedDomainName no objeto de servidor virtual do SMTP padrão não corresponder ao FQDN do DNS do servidor Exchange, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que os valores desses atributos podem ter sido manualmente alterados. Portanto, esses valores alterados podem contribuir para problemas de fluxo de mensagens nesse servidor.

O valor do atributo msExchSmtpFullyQualifiedDomainName especifica o FQDN para o servidor virtual SMTP e deve ser determinado pelo protocolo de rede DNS.

Deve existir um registro válido HOST DNS (A) para o valor desse atributo para permitir que os servidores de mensagens que tentarem resolver o FQDN do servidor virtual SMTP possam recuperar o endereço IP correto e rotear emails corretamente.

Para resolver esse aviso, determine se os valores foram intencionalmente alterados para uma finalidade válida. Se os valores tiverem sido alterados para uma finalidade válida, siga uma destas etapas:

  • Altere o valor do atributo msExchSmtpFullyQualifiedDomainName para que corresponda ao FQDN do DNS.

  • Configure o FQDN do DNS do Exchange Server para que corresponda ao valor do atributo msExchSmtpFullyQualifiedDomainName.

Cuidado:
Se modificar incorretamente os atributos de objetos do Active Directory ao usar a ADSI (Active Directory Service Interfaces) Edit, a ferramenta LDP (ldp.exe), ou outro cliente de protocolo LDAP versão 3, você poderá causar problemas graves. Esses problemas podem exigir que você reinstale o Microsoft Windows Server™ 2003, o Exchange Server 2003 ou ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para atualizar o valor do atributo msExchSMTPFullyQualifiedDomainName

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Grupos Administrativos, Servidores, o servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito no servidor virtual SMTP padrão e selecione Propriedades.

  4. Selecione a guia Entrega e clique em Avançado.

  5. Em Nome de domínio totalmente qualificado, insira o valor do atributo msExchSmtpFullyQualifiedDomainName.

  6. Clique em OK para salvar as alterações e, em seguida, clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.
Para configurar o FQDN do DNS do Exchange Server

  1. Siga a orientação em Como definir configurações no servidor DNS.

Para obter mais informações sobre o recurso de pesquisa reversa de DNS no Exchange, consulte "Adicionar um registro de recurso a uma zona do DNS" (http://go.microsoft.com/fwlink/?LinkId=63002).

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 266686, "XCON: Como configurar um servidor virtual SMTP Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (pode estar em inglês).

  • 268163, "XCON: Como configurar um servidor virtual SMTP Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (pode estar em inglês).

Para obter mais informações sobre o design do serviço SMTP, consulte "Design do serviço SMTP" no Guia de Referência Técnica do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876) (pode estar em inglês).


Instância de SMTP sem um conector SMTP de saída definido
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-22

A ferramenta Microsoft® Exchange Server Analyzer consulta no serviço de diretório do Active Directory® o valor do atributo distingushedName da classe de objeto protocolCfgSMTPServer para listar todas as instâncias de servidor virtual SMTP (Simple Mail Transfer Protocol) no gateway do Exchange especificado pelo usuário.

Em seguida, o Exchange Server Analyzer consulta no Active Directory o valor dos atributos msExchSourceBridgeheadServersDN e routingList de cada objeto msExchRoutingSMTPConnector encontrado, para saber se o conector SMTP tem uma das instâncias de servidor virtual SMTP detectada, definida como bridgehead local para um espaço de endereçamento SMTP externo.

Um conector SMTP indica uma rota isolada para mensagens. Você pode usar conectores SMTP para estabelecer um gateway para mensagens da Internet ou para conexão com um domínio ou sistema de mensagens específico. Os conectores permitem definir opções específicas para a rota de mensagens designada.

Ao detectar a inexistência de conectores SMTP com uma instância de servidor virtual SMTP do servidor gateway do Exchange definida como seu servidor bridgehead local, o Exchange Server Analyzer exibirá um aviso.

Este aviso indica que outros servidores, mas não o servidor gateway do Exchange especificado pelo usuário, podem rotear mensagens inadvertidamente fora da organização.

Convém criar um conector SMTP para designar uma instância de servidor virtual SMTP no servidor gateway especificado do Exchange como bridgehead, para evitar essa condição em que servidores diferentes do servidor gateway do Exchange especificado pelo usuário possam rotear inadvertidamente mensagens fora da organização.

Embora seja possível enviar e receber mensagens da Internet usando apenas um servidor virtual SMTP, é uma prática recomendada configurar um conector SMTP dedicado para rotear mensagens da Internet. O uso de um conector SMTP é recomendável porque providencia uma rota isolada para as mensagens destinadas à Internet. Além disso, existem mais opções de configuração disponíveis em um conector SMTP do que em um servidor virtual SMTP.

Para obter mais informações sobre como usar conectores SMTP, consulte o artigo 294736 da Base de Dados de Conhecimento Microsoft, "Quando criar conectores SMTP no Exchange 2000 e versão posterior" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736).

Para obter mais informações sobre conectores SMTP, consulte o Guia de Transporte e Roteamento do Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


O valor do Registro LocalRetryMinutes do SMTP é não padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se as configurações padrão de enfileiramento do SMTP foram alteradas:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se o Exchange Server Analyzer perceber que a chave LocalRetryMinutes foi definida, o Exchange Server Analyzer exibirá uma mensagem não padrão.

É recomendável que os valores de enfileiramento padrão só sejam modificados após uma consideração completa. Os padrões foram selecionados atentamente para obter o desempenho ideal na maioria dos ambientes. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento do enfileiramento no Exchange.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre o enfileiramento do SMTP do Exchange, consulte a seguinte entrada no Blog da Equipe do Microsoft Exchange, "Explaining the Mysterious SMTP Advanced Queuing Engine" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=48585).


O valor do Registro FileCacheLifeTimeSeconds do SMTP foi adicionado manualmente, mas pode não ser mais necessário
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar se a vida útil padrão de cada identificador de arquivo do IIS (Serviços de Informações da Internet) em cache teve seu valor padrão de 1.880 segundos (30 minutos) modificado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheLifeTimeSeconds

Se o Exchange Server Analyzer encontrar o FileCacheLifeTimeSeconds presente e configurado com um valor alternativo, uma mensagem de configuração não padrão será exibida.

O valor FileCacheLifeTimeSeconds especifica a vida útil dos identificadores de arquivo do IIS em cache. Os manipuladores de arquivos são armazenados em cache para melhorar o desempenho porque, dessa forma, evitam que o servidor execute E/S (entrada/saída) e ciclos da CPU redundantes. Sempre que a pilha de transporte do SMTP em um computador com o Exchange Server recebe uma mensagem, ela é canalizada para fora do sistema de arquivos onde aguarda o roteamento para seu destino. Para gravar no sistema de arquivos, a pilha de transporte do SMTP obtém um manipulador de arquivo e passa a mensagem para esse manipulador. Cada manipulador de arquivo consome aproximadamente 2 KB (kilobytes) de memória de pool paginado. O número padrão de manipuladores de arquivos em cache do IIS é de 800 para cada 32 MB.

O valor do Registro não está presente por padrão porque o Exchange 2000 Server Service Pack 2 (SP2) e posteriores e o Exchange Server 2003 são configurados para armazenar um número ideal de identificadores de arquivo em cache. O Exchange Server 2003 calcula dinamicamente as configurações adequadas para os identificadores de arquivos do SMTP, de modo que essas configurações não são mais necessárias. Portanto, antes de atualizar qualquer computador do Exchange 2000 Server com essas configurações para o Exchange Server 2003, você deve excluir essas entradas do Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. No painel da direita, exclua o valor FileCacheLifeTimeSeconds.

  4. Feche o editor do Registro e reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editar o Registro, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986) (em inglês).


O valor do Registro FileCacheMaxHandles do SMTP foi adicionado manualmente, mas pode não ser mais necessário
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada de Registro para determinar se o número máximo de identificadores de arquivos em cache do IIS (Serviços de Informações da Internet) teve seu valor padrão de 800 modificado:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheMaxHandles

Se o Exchange Server Analyzer detectar que FileCacheMaxHandles está presente e configurado com um valor diferente de 800, uma mensagem de configuração não padrão será exibida.

O valor FileCacheMaxHandles especifica o número máximo de identificadores de arquivos do IIS usados pelo Exchange para cada 32 MB (megabytes) de memória física. Os manipuladores de arquivos são armazenados em cache para melhorar o desempenho porque, dessa forma, evitam que o servidor execute E/S (entrada/saída) e ciclos da CPU redundantes. Sempre que a pilha de transporte do SMTP em um computador do Exchange Server recebe uma mensagem, ela é canalizada para fora do sistema de arquivos onde aguarda o roteamento para seu destino. Para gravar no sistema de arquivos, a pilha de transporte do SMTP obtém um manipulador de arquivo e passa a mensagem para esse manipulador. Cada manipulador de arquivo consome aproximadamente 2 KB (kilobytes) de memória de pool paginado. O número padrão de manipuladores de arquivos em cache do IIS é de 800 para cada 32 MB.

Antes do Service Pack 2 (SP2) para Exchange 2000 Server, restrições de desempenho de servidores Exchange que mantinham grandes filas de mensagens SMTP (por exemplo, uma média de 1.000 mensagens ou mais) eram encontradas historicamente devido a uma definição padrão do serviço SMTP de no máximo 1.000 manipuladores de arquivos. Como o Exchange 2000 Server predefiniu um número máximo de 1.000 manipuladores de arquivos, o serviço SMTP pôde gravar apenas 1.000 mensagens simultâneas no sistema de arquivos.

Para melhorar o desempenho nos sistemas de grande porte, três entradas do Registro eram ajustadas com freqüência simultaneamente, para aumentar o número máximo de manipuladores de arquivos que podiam ser abertos pelo serviço SMTP (para permitir o processamento de mais mensagens) e para diminuir o número de manipuladores de arquivos abertos para o sistema de arquivos instaláveis, outro componente do Exchange (para evitar ficar sem memória quando a fila estivesse grande). Estão listados a seguir os valores do Registro que, por padrão, não existiam e, portanto, deveriam ser adicionados manualmente:

Local: HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

Valor: MsgHandleThreshold

Tipo: REG_DWORD

Local: HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

Valor: MsgHandleAsyncThreshold

Tipo: REG_DWORD

Local: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Valor: FileCacheMaxHandles

Tipo: REG_DWORD

As entradas MsgHandleThreshold e MsgHandleAsyncThreshold geralmente são ajustadas para o mesmo valor (um valor maior que 1.000) e o valor de FileCacheMaxHandles é normalmente reduzido de 800 para 600.

Por padrão, esse valor do Registro não está presente porque o Exchange 2000 Server Service Pack 2 (SP2) e posterior determina dinamicamente os valores ideais a serem usados. Se esse servidor Exchange estiver executando o Exchange 2000 Server com Service Pack 1 ou anterior, é recomendável que você faça a atualização para o service pack e pacote de distribuição mais recentes. Assim que você atualizar para o código mais recente, exclua essas entradas do Registro.

O Exchange Server 2003 calcula dinamicamente as configurações adequadas para os manipuladores de arquivos do SMTP, de modo que essas configurações não são mais necessárias. Portanto, antes de atualizar qualquer computador do Exchange 2000 Server com essas configurações para o Exchange Server 2003, você deve excluir essas entradas do Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Exclua o valor FileCacheMaxHandles.

  4. Feche o editor de Registro e reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O valor de Registro GlitchRetrySeconds do SMTP foi definido manualmente
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-01-17

A ferramenta Analisador do Microsoft® Exchange Server lê a seguinte entrada do Registro para determinar se o tempo de espera das repetições em falha padrão foram substituídas manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\GlitchRetrySeconds

Se o Analisador do Exchange Server detectar que GlitchRetrySeconds está presente e configurado, uma mensagem de configuração não padrão será exibida.

Se o Exchange 2000 Server ou o Exchange Server 2003 tentar encaminhar uma mensagem para um sistema SMTP externo muito carregado, ele poderá receber um erro de servidor ocupado. Quando isso acontece, o Exchange entra em um estado conhecido como "repetição em falha". Nesse estado, o Exchange espera 60 segundos antes de tentar reenviar a mensagem e repete esse processo três vezes antes de reclassificar para outras ações. Se os servidores SMTP externos estiverem consistentemente ocupados, é recomendável reduzir o tempo de espera das repetições em falha para evitar o enfileiramento de mensagens em massa.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. No painel direito, exclua o valor GlitchRetrySeconds. Como alternativa, você pode reduzir o valor de GlitchRetrySeconds se estiver ocorrendo um enfileiramento em massa.

  4. Feche o editor de Registro e reinicie o serviço SMTP para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O valor do Registro IgnorePFTimeLimit do SMTP foi definido manualmente
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-01-17

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar se o número de dias durante os quais o mecanismo de roteamento do serviço SMTP ignora o novo armazenamento de pasta pública foi definido manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\IgnorePFTimeLimit

Se o Exchange Server Analyzer verificar que IgnorePFTimeLimit está presente e configurado, uma mensagem de configuração não padrão será exibida.

Quando um novo armazenamento de pasta pública é colocado online, você pode perceber, no Visualizador de Filas, que a fila de entrega local está crescendo. Se a hierarquia de pasta pública for grande, as mensagens na fila local continuam a aumentar e podem levar mais tempo para ser entregues. Em alguns casos, as mensagens podem não ser entregues.

Quando o novo servidor é introduzido, seu nome distinto é adicionado ao atributo msExchOwningPFTreeBL do objeto de Pasta Pública de Hierarquias de Pasta do grupo administrativo no serviço de diretório do Active Directory®. Quando o categorizador do servidor que recebe mensagens destinadas a pastas públicas ler o atributo msExchOwningPFTreeBL, ele deverá primeiramente selecionar o armazenamento de pasta pública local, se ele existir. Para balanceamento da carga, ele, em seguida, selecionará os armazenamentos de pasta pública na ordem em que estão listados. Como o novo servidor está listado em primeiro lugar, as mensagens são roteadas para ele e adicionadas à fila local de entrega do novo servidor. Se um armazenamento de pasta pública ainda não tiver recebido uma cópia da hierarquia, o servidor não poderá rotear as mensagens para um armazenamento que possua uma cópia da pasta de destino.

Você pode evitar esse problema, adicionando o valor IgnorePFTimeLimit ao Registro do novo servidor de pasta pública. Isso especificará o número de dias durante os quais o mecanismo de roteamento ignorará o novo armazenamento de pasta pública.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. No painel da direita, exclua IgnorePFTimeLimit.

  4. Feche o editor de Registro e reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Para obter mais informações sobre o problema e o valor do Registro IgnorePFTimeLimit descrito neste artigo, consulte o artigo 328870 da Base de Dados de Conhecimento Microsoft, "XADM: O roteamento de pasta pública é habilitado antes da replicação da hierarquia" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328870).

Antes de editar o Registro e para obter informações sobre como editá-lo, leia o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


A instância de SMTP tem várias ligações de porta configuradas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchServerBindings teve seu valor padrão 25 alterado ou vários valores foram definidos. Por padrão, o atributo msExchServerBindings está configurado para a porta TCP 25. Se o Analisador do Exchange Server detectar que esse atributo tem mais de um valor definido, uma mensagem de configuração não padrão será exibida junto com o nome do servidor SMTP virtual que tem vários valores definidos.

O atributo msExchServerBindings representa a porta TCP na qual esse servidor SMTP escuta as conexões de entrada. Servidores virtuais SMTP podem ser configurados para ouvir em uma ou mais portas TCP. Por padrão, todos os servidores virtuais SMTP estão configurados para ouvir na porta TCP 25, a porta SMTP padrão. Se a porta de escuta SMTP teve seu padrão modificado e inclui várias ligações de porta, ela poderá interromper o fluxo de mensagens.

É aceitável alterar a porta de escuta do SMTP, desde que o restante da infra-estrutura de mensagens interna também seja modificado de acordo. Entretanto, portas alternativas não podem ser usadas para servidores SMTP virtuais que aceitam mensagens diretamente da Internet, como os servidores SMTP da Internet que enviam mensagens pela porta 25.

O Analisador do Exchange Server está procurando o valor para o servidor virtual do protocolo SMTP do Exchange. Esse servidor virtual do protocolo SMTP pode ou não ser o servidor SMTP que recebe mensagens diretamente da Internet. Existem alguns produtos antivírus e anti-spam projetados para receber mensagens SMTP da Internet na porta 25 e redirecioná-las para um servidor virtual SMTP do Exchange em outra porta. Nesse cenário, um servidor virtual SMTP do Exchange que escuta em várias portas pode ser uma configuração aceitável.

Para exibir ou modificar a porta de escuta do servidor virtual SMTP

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e clique em Propriedades.

  4. Selecione a guia Geral e clique em Avançado.

  5. Uma lista de portas e endereços IP será exibida.

    • Para alterar a porta existente, selecione o endereço IP e clique em Editar. Altere o campo da porta TCP para 25.

    • Para adicionar a porta 25 como uma porta de escuta adicional, clique em Adicionar e adicione a nova combinação endereço IP/porta. Se você estiver usando Filtragem por Conexão, Remetente ou Destinatário, certifique-se de ter marcado as caixas de seleção corretas.

  6. Clique em OK para salvar as alterações e clique em OK novamente para sair da caixa de diálogo Avançado.

  7. Clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


Aviso de falha de mensagem SMTP - Falha geral de Mensagens Inválidas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_PerfRawData_SMTPSVC_SMTPServer do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave BadmailedMessagesGeneralFailure. O valor dessa chave representa o número de mensagens enviadas ao diretório Mensagens Inválidas por motivos não associados a um contador específico. O diretório Mensagens Inválidas é usado para armazenar mensagens que não puderam ser enviadas. Para obter informações sobre alguns dos outros contadores WMI de mensagens inválidas, consulte os seguintes artigos do Exchange Server Analyzer:

  • Aviso de falha de mensagem SMTP - Limite de contagem de saltos de mensagens inválidas

  • Aviso de falha de mensagem SMTP - Mensagens inválidas de notificação de falha na entrega do DSN

Há contadores que são incrementados quando uma mensagem é enviada ao diretório de Mensagens Inválidas por outros motivos também, inclusive em razão de um arquivo de retirada inválido, falta de destinatários e arquivo acionado por evento.

O Analisador do Exchange Server também consulta a chave WMI Win32_PerfRawData_PerfOS_System para determinar o valor de SystemUpTime.

Se o Exchange Server Analyzer determinar que o valor para a chave SystemUpTime é maior que 0 e o resultado do valor de BadmailedMessagesGeneralFailure dividido pelo valor de SystemUpTime for maior que 1000, um aviso será exibido.

Esse aviso indica que uma média de 1.000 ou mais mensagens por dia estão marcadas como não entregáveis e armazenadas no diretório Mensagens Inválidas. As mensagens do diretório Mensagens Inválidas devem ser excluídas manualmente. É recomendável conferir e excluir as mensagens do diretório Mensagens Inválidas como parte da manutenção normal do Exchange Server. O crescimento sem restrições do diretório Mensagens Inválidas poderá consumir todos o espaço em disco disponível e, por sua vez, causar o desmonte dos bancos de dados do Exchange.

Para corrigir esse aviso

  1. Examine as mensagens no diretório Mensagens Inválidas para determinar se a origem da mensagem é interna ou externa. As mensagens no diretório Mensagens Inválidas são armazenadas no formato ASCII e podem ser abertas e visualizadas no Bloco de Notas ou em outro editor de texto.

    • Se as mensagens parecerem ser geradas internamente, você poderá examinar os respectivos cabeçalhos para determinar sua origem.

    • Se as mensagens parecerem ter sido geradas externamente, poderá ser uma indicação de que o Exchange Server está sendo usado como um meio de retransmissão de mensagem.

Para obter informações sobre como controlar e configurar opções de retransmissão, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 310380, "COMO FAZER PARA: Impedir o Exchange 2000 de ser usado como um meio de retransmissão de mensagem no Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380) (em inglês)

  • 313395, "COMO FAZER PARA: Examinar restrições de retransmissão para conexões SMTP anônimas" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313395) (em inglês)

Para obter mais informações sobre desmontagens de bancos de dados devido a espaço livre em disco insuficiente, consulte o artigo 321825 da Base de Dados de Conhecimento Microsoft, "Bancos de dados são desmontados devido à falta de espaço em disco" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825).


Aviso de falha de mensagem SMTP - Limite de contagem de saltos de mensagens inválidas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_PerfRawData_SMTPSVC_SMTPServer do Microsoft WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave BadmailedMessagesHopCountExceeded. O valor dessa chave representa o número de mensagens enviadas ao diretório Mensagens Inválidas, pois excederam a contagem máxima de saltos. O diretório Mensagens Inválidas é usado para armazenar mensagens que não puderam ser enviadas. Para obter informações sobre alguns dos outros contadores WMI de Mensagens Inválidas, consulte os artigos da ferramenta Exchange Server Analyzer, Aviso de falha de mensagem SMTP - Falha geral de Mensagens Inválidas e Aviso de falha de mensagem SMTP - Mensagens inválidas de notificação de falha na entrega do DSN (páginas em inglês).

Há contadores que são incrementados quando uma mensagem é enviada ao diretório de Mensagens Inválidas por outros motivos também, inclusive em razão de um arquivo de retirada inválido, falta de destinatários e arquivo acionado por evento.

O Analisador do Exchange Server também consulta a chave WMI Win32_PerfRawData_PerfOS_System para determinar o valor de SystemUpTime.

Se o Exchange Server Analyzer determinar que o valor da chave SystemUpTime é maior que 0 e que o resultado do valor de BadmailedMessagesHopCountExceeded dividido pelo valor de SystemUpTime é maior que 100, um aviso será exibido.

Esse aviso indica que uma média de 100 ou mais mensagens por dia são marcadas como não entregues e armazenadas no diretório Mensagens Inválidas, pois excedem a contagem máxima de saltos. A contagem máxima de saltos é o número máximo de servidores SMTP através dos quais uma mensagem pode viajar para chegar do emissor para o destinatário. Sempre que uma mensagem viaja por um servidor SMTP, uma linha de texto representando o salto é adicionada ao cabeçalho da mensagem.

O número ideal de saltos de mensagem varia dependendo da topologia da rede e das necessidades do sistema de mensagens. Para impedir que uma mensagem seja roteada incorretamente várias vezes (uma condição conhecida como um loop de mensagens) um administrador pode controlar o número máximo de saltos permitidos. Para fazer isso, é necessário configurar a contagem máxima de saltos para o servidor virtual SMTP. No Exchange 2000 Server, a contagem de saltos padrão é 15. No Exchange Server 2003, o padrão é 30. É recomendável definir o valor 30 para os servidores virtuais SMTP do Exchange 2000 Server e do Exchange Server 2003.

As mensagens do diretório Mensagens Inválidas devem ser excluídas manualmente. É recomendável que se faça revisão e exclusão regulares das mensagens no diretório Mensagens Inválidas como parte da manutenção regular do Exchange Server. O crescimento sem restrições do diretório Mensagens Inválidas poderá consumir todos o espaço em disco disponível e, por sua vez, causar o desmonte dos bancos de dados do Exchange.

Para corrigir esse aviso

  1. Examine as mensagens no diretório Mensagens Inválidas para determinar se a origem da mensagem é interna ou externa. As mensagens no diretório Mensagens Inválidas são armazenadas no formato ASCII e podem ser abertas e visualizadas no Bloco de Notas ou em outro editor de texto.

    • Se as mensagens parecerem ser geradas internamente, você poderá examinar os respectivos cabeçalhos para determinar sua origem.

    • Se as mensagens parecerem ter sido geradas externamente, poderá ser uma indicação de que o Exchange Server está sendo usado como um meio de retransmissão de mensagem.

  2. Defina a contagem máxima de saltos como 30.

    1. Abra o Gerenciador do Sistema do Exchange.

    2. Expanda Servidores, expanda um servidor Exchange, expanda Protocolos e, por fim, expanda SMTP.

    3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e selecione Propriedades.

    4. Selecione a guia Entrega e clique em Avançado.

    5. Insira o valor desejado no campo Contagem máxima de saltos e clique em OK para salvar a alteração.

    6. Clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter informações sobre como controlar e configurar opções de retransmissão, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 310380, "COMO FAZER PARA: Impedir o Exchange 2000 de ser usado como um meio de retransmissão de mensagem no Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380) (em inglês)

  • 313395, "COMO FAZER PARA: Examinar restrições de retransmissão para conexões SMTP anônimas" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313395) (em inglês)

Para obter mais informações sobre as desmontagens do banco de dados devido a espaço em disco insuficiente, consulte o artigo 321825 da Base de Dados de Conhecimento Microsoft, "Bancos de dados são desmontados devido à falta de espaço em disco" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825).


Aviso de falha de mensagem SMTP - Mensagens inválidas de notificação de falha na entrega do DSN
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-23

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_PerfRawData_SMTPSVC_SMTPServer do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave BadmailedMessagesNDRofDSN. O valor dessa chave representa o número de mensagens de notificação de status de entrega enviadas para o diretório Mensagens Inválidas porque não puderam ser entregues. O diretório Mensagens Inválidas é usado para armazenar mensagens que não puderam ser enviadas. Para obter informações sobre alguns dos outros contadores WMI de Mensagens Inválidas, consulte os artigos do Exchange Server Analyzer, Aviso de falha de mensagem SMTP - Falha geral de Mensagens Inválidas e Aviso de falha de mensagem SMTP - Limite de contagem de saltos de mensagens inválidas.

Há contadores que são incrementados quando uma mensagem é enviada para o diretório de Mensagens Inválidas por outros motivos, inclusive em razão de um arquivo de recebimento inválido, ausência de destinatários e acionamento por evento.

O Analisador do Exchange Server também consulta a chave WMI Win32_PerfRawData_PerfOS_System para determinar o valor de SystemUpTime.

Se o Exchange Server Analyzer determinar que o valor da chave SystemUpTime é maior que 0 e que o resultado do valor de BadmailedMessagesNDRofDSN dividido pelo valor de SystemUpTime é maior que 1000, será exibido um aviso.

Esse aviso indica que uma média de 1.000 ou mais notificações de status de entrega por dia são armazenadas no diretório Mensagens Inválidas porque não puderam ser entregues. As mensagens do diretório Mensagens Inválidas devem ser excluídas manualmente. É recomendável que se faça revisão e exclusão regulares das mensagens no diretório Mensagens Inválidas como parte da manutenção regular do Exchange Server. O crescimento sem restrições do diretório Mensagens Inválidas poderá consumir todos o espaço em disco disponível e, por sua vez, causar o desmonte dos bancos de dados do Exchange.

Para corrigir esse aviso

  • Examine as mensagens do diretório Mensagens Inválidas para determinar se as notificações de status de entrega eram para destinatários internos ou externos. As mensagens no diretório Mensagens Inválidas são armazenadas no formato ASCII e podem ser abertas e visualizadas no Bloco de Notas ou em outro editor de texto.

    • Se as notificações de status de entrega eram para destinatários internos, isso indica um problema de fluxo de mensagens. A solução desse problema dependerá no código numérico específico retornado com a notificação de status de entrega.

    • Se as notificações de status de entrega eram para destinatários externos, isso pode indicar que o Exchange Server está sendo usado como retransmissão de mensagens. A solução desse problema também dependerá do código numérico retornado.

Para obter mais informações sobre os códigos numéricos de retorno de notificações de status de entrega, consulte o artigo 284204 da Base de Dados de Conhecimento Microsoft, Notificações de status de entrega no Exchange Server e no Small Business Server.

Para obter informações sobre como controlar e configurar opções de retransmissão, consulte o artigo 313395 da Base de Dados de Conhecimento Microsoft, COMO: Examinar restrições de retransmissões para conexões SMTP anônimas e filtrar mensagens de email não solicitadas no Exchange 2000 Server.

Para obter mais informações sobre desmontagem de banco de dados devido a espaço livre em disco insuficiente, consulte o artigo 321825 da Base de Dados de Conhecimento Microsoft, Bancos de dados são desmontados por falta de espaço em disco (página em inglês).


Aviso de falha de mensagem SMTP - Pesquisas de endereços do categorizador não encontradas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-03-20

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_PerfRawData_SMTPSVC_SMTPServer do WMI para determinar o valor da chave CatAddresslookupsnotfound. O valor dessa chave representa o número de pesquisas de endereço executadas pelo categorizador de mensagens que não encontraram um objeto de serviço de diretório. O Analisador do Exchange Server também consulta a chave WMI Win32_PerfRawData_PerfOS_System para determinar o valor de SystemUpTime.

Se o Exchange Server Analyzer verificar que o valor da chave SystemUpTime é maior do que 0 e que o resultado do valor de CatAddresslookupsnotfound dividido pelo valor de SystemUpTime é maior do que 5000, será exibido um aviso.

O categorizador de mensagens examina as mensagens recebidas em um servidor SMTP e decide o que fazer com elas. As mensagens podem ser destinadas ao armazenamento de informações local, a um host remoto, usando o MTA (agente de transferência de mensagens) ou destinadas a um host remoto, usando o SMTP. O categorizador também trata da expansão da lista de distribuição. O categorizador é um plug-in para o mecanismo de enfileiramento avançado que executa consultas LDAP (Lightweight Directory Access Protocol) em servidores de catálogos globais na porta TCP 3268. O categorizador é basicamente uma coleção de coletores de eventos que executam resolução de endereços avançada em cada mensagem que percorre o mecanismo de enfileiramento avançado. Ele executa resolução de endereços, encaminhamento de mensagens, define sinalizadores de conversão de conteúdo, expande listas de distribuição, impõe configurações globais, gera notificações de status de entrega, detecta roteamentos de destinatário alternativos, bifurcação, registro em diário e várias outras funções.

Quando uma mensagem insere o categorizador de mensagens, o categorizador resolve o remetente do envelope pesquisando o endereço nos atributos de endereço do proxy no serviço de diretório do Active Directory®. O categorizador também resolve o destinatário do envelope, pesquisando cada endereço nos atributos de endereços do proxy, no Active Directory. Por exemplo, se a lista contiver uma lista de distribuição, ele expandirá a lista de modo a incluir esses membros se a expansão de lista de distribuição for permitida no servidor.

Esse aviso indica que uma média de 5000 pesquisas de endereços do categorizador estão falhando a cada dia. Há várias causas para isso, inclusive problemas com o acesso DSAccess, latência ou falhas de replicação de diretório, ataques de dicionário contra os diretórios, problemas no DNS ou uso de endereços inválidos.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Examine se há erros nos logs de evento no computador do Exchange Server.

  2. Se você não localizar nenhum evento que lhe permita resolver o problema, considere aumentar o log de diagnóstico no Categorizador MSExchangeTransport para Máximo. Quando o log de diagnóstico estiver habilitado, verifique novamente se existem erros no log de eventos. Se a configuração do log de diagnóstico para o máximo não produzir entradas de log de eventos, configure o log de diagnóstico para o nível 7 usando o Registro. Ao definir para nível 7, a ID de Evento 9000 gerada pelo Categorizador de Mensagens será registrada, o que detalhará a função, o motivo da falha, o nome do destinatário que falhou e o tipo de destinatário. Para definir o log de diagnóstico para o nível 7:

    1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

    2. Navegue para:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. No painel direito, clique duas vezes no 2 Categorizador, defina o dado do valor com 7 e clique em OK.

    4. Feche o editor de Registro.

      Observação:
      Depois de concluir a solução de problemas, redefina o dado do valor do Categorizador do nível 2 novamente para 0.

  3. Verifique se o Exchange Server tem conectividade com um ou mais servidores de catálogo global. A ferramenta Monitor de Rede no Windows é muito útil para essa finalidade.

  4. Examine as mensagens de notificação de status de entrega que estão sendo geradas. As mensagens de notificação de status de entrega que podem incluir as notificações de falha na entrega descrevem mensagens de falhas permanentes e mensagens de falhas transitórias, que geralmente terminam como erros de entrega permanentes.

  5. Use o Controle de Mensagens para solucionar os problemas de mensagens atoladas no categorizador.

  6. Use a ferramenta Coletor de Arquivo Morto para arquivar e analisar as mensagens de entrada e saída do Exchange Server.

  7. Monitore os contadores de desempenho do categorizador no Monitor do Sistema.

Para obter uma lista das mensagens de notificação de status de entrega e de falha na entrega geradas pelo Exchange Server e Microsoft Windows Small Business Server, consulte o artigo 284204 da Base de Dados de Conhecimento da Microsoft, "Notificações de status de entrega no Exchange Server e no Small Business Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Para obter mais informações sobre como usar a Central de Controle de Mensagens no Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 262162, "XADM: Usando a Central de Controle de Mensagens para rastrear uma mensagem" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Como habilitar o Controle de Mensagens no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "IDs de eventos do Controle de Mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Recursos aprimorados de Controle de Mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

Para obter mais informações sobre como solucionar problemas do categorizador de mensagens, consulte o webcast do Suporte da Microsoft, "Exchange 2000 Server: Solução de problemas do Categorizador de Mensagens e de notificações de falha na entrega " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Para obter mais informações sobre a ferramenta Coletor de Arquivo Morto, consulte o artigo 307798 da Base de Dados de Conhecimento da Microsoft, "O utilitário Coletor de Arquivo Morto está disponível no Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Para obter mais informações gerais sobre como solucionar problemas relacionados a transporte, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 821910, "COMO FAZER: Solucionar Problemas de Transporte do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "XCON: General Troubleshooting for Exchange 2000 Transport Issues" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Os contadores de desempenho do categorizador de mensagens são publicados separadamente, para cada instância do servidor virtual SMTP. Para obter uma lista dos contadores de desempenho disponíveis, relacionados ao Categorizador de Mensagens, consulte o artigo 231734 da Base de Dados de Conhecimento da Microsoft, "XCON: Contadores do Monitor de Desempenho para o Categorizador de Mensagens " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Para obter informações sobre alguns dos outros contadores WMI do Categorizador, consulte os seguintes artigos do Analisador do Exchange Server:

  • Aviso de falha de mensagem SMTP - Falha do serviço de diretório do categorizador

  • Aviso de falha de mensagem SMTP - Falha de logon no diretório do categorizador

  • Aviso de falha de mensagem SMTP - Erro não repetível do categorizador

  • Aviso de falha de mensagem SMTP - Falha de falta de memória do categorizador

  • Aviso de falha de mensagem SMTP - Erro repetível do categorizador


Aviso de falha de mensagem SMTP - Falha de logon no diretório do categorizador
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_PerfRawData_SMTPSVC_SMTPServer do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave CatCategorizationsfailedDSlogonfailure. O valor dessa chave representa o número de categorizações que falharam devido a uma falha de logon do serviço de diretório. O Analisador do Exchange Server também consulta a chave WMI Win32_PerfRawData_PerfOS_System para determinar o valor de SystemUpTime.

Se o Exchange Server Analyzer determinar que o valor da chave SystemUpTime é maior que 0 e que o resultado do valor de CatCategorizationsfailedDSlogonfailure dividido pelo valor de SystemUpTime é maior que 50, será exibido um aviso.

O categorizador de mensagens examina as mensagens recebidas em um servidor SMTP e decide o que fazer com elas. As mensagens podem ser destinadas ao armazenamento de informações local, a um host remoto, usando o MTA (agente de transferência de mensagens) ou destinadas a um host remoto, usando o SMTP. O categorizador também trata da expansão da lista de distribuição. O categorizador é um plug-in para o mecanismo de enfileiramento avançado que executa consultas LDAP (Lightweight Directory Access Protocol) em servidores de catálogos globais na porta TCP 3268. O categorizador é basicamente uma coleção de coletores de eventos que executam resolução de endereços avançada em cada mensagem que percorre o mecanismo de enfileiramento avançado. Ele executa resolução de endereços, encaminhamento de mensagens, define sinalizadores de conversão de conteúdo, expande listas de distribuição, impõe configurações globais, gera notificações de status de entrega, detecta roteamentos de destinatário alternativos, bifurcação, registro em diário e várias outras funções.

Assim que a mensagem entra no categorizador de mensagens, ele resolve o remetente do envelope, procurando o endereço nos atributos de endereço do proxy, no serviço de diretório do Active Directory®. O categorizador também resolve o destinatário do envelope, pesquisando cada endereço nos atributos de endereços do proxy, no Active Directory. Por exemplo, se a lista contiver uma lista de distribuição, ele expandirá a lista de modo a incluir esses membros se a expansão de lista de distribuição for permitida no servidor.

Esse aviso indica que uma média de 50 ou mais tentativas de conexão com o serviço de diretório feitas pelo categorizador de mensagens está falhando todos os dias devido a falhas de logon. Há várias causas para isso, incluindo problemas com o DSAccess (directory service access), latência ou falhas na replicação de diretório, servidores de catálogo global sobrecarregados e problemas com DNS.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Verifique se existem erros nos logs de eventos no computador do Exchange Server.

  2. Se você não encontrar eventos que permitam solucionar o problema, experimente aumentar para o valor máximo o log de diagnóstico no Categorizador MSExchangeTransport. Assim que o log de diagnóstico estiver habilitado, verifique novamente se há erros no log de eventos. Se a configuração do log de diagnóstico com o valor máximo não gerar quaisquer entradas do log de eventos, configure o log de diagnóstico para o nível 7 usando o Registro. Quando definido com o nível 7, o ID de evento 9000 gerado pelo categorizador de mensagens será registrado, descrevendo a função, o motivo da falha, o nome do destinatário que falhou e o tipo de destinatário. Para definir o log de diagnóstico para o nível 7:

    1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

    2. Navegue para:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. No painel da direita, clique duas vezes em 2 Categorizador, defina o dado do valor como 7 e clique em OK.

    4. Feche o editor de Registro.

      Observação:
      Depois de concluir a solução de problemas, redefina o dado do valor do Categorizador do nível 2 novamente para 0.

  3. Verifique se o Exchange Server tem conectividade com um ou mais servidores de catálogo global. A ferramenta Monitor de Rede no Windows é muito útil para essa finalidade.

  4. Examine as mensagens de notificação de status de entrega que estão sendo geradas. As mensagens de notificação de status de entrega que podem incluir as notificações de falha na entrega descrevem mensagens de falhas permanentes e mensagens de falhas transitórias, que geralmente terminam como erros de entrega permanentes.

  5. Use o Controle de Mensagens para solucionar os problemas de mensagens atoladas no categorizador.

  6. Use a ferramenta Coletor de Arquivo Morto para arquivar e analisar as mensagens de entrada e saída do Exchange Server.

  7. Monitore os contadores de desempenho do categorizador no Monitor do Sistema.

Para obter uma lista das mensagens de notificação de status de entrega e de falha na entrega geradas pelo Exchange Server e Microsoft Windows Small Business Server, consulte o artigo 284204 da Base de Dados de Conhecimento Microsoft, "Notificações de status de entrega no Exchange Server e no Small Business Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Para obter informações sobre como usar o Central de Controle de Mensagens no Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 262162, "XADM: Usando a Central de Controle de Mensagens para rastrear uma mensagem" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Como habilitar o Controle de Mensagens no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "IDs de eventos do Controle de Mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Recursos aprimorados de Controle de Mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

Para obter mais informações sobre como solucionar problemas do categorizador de mensagens, consulte o WebCasts do Suporte da Microsoft, "Exchange 2000 Server: Solução de problemas do Categorizador de Mensagens e de notificações de falha na entrega " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Para obter mais informações sobre a ferramenta Coletor de Arquivo Morto, consulte o artigo 307798 da Base de Dados de Conhecimento da Microsoft, "O utilitário Coletor de Arquivo Morto está disponível no Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Para obter informações gerais sobre como solucionar problemas relacionados a transporte, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 821910, "COMO FAZER: Solucionar Problemas de Transporte do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "XCON: General Troubleshooting for Exchange 2000 Transport Issues" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Os contadores de desempenho do categorizador de mensagens são publicados separadamente, para cada instância do servidor virtual SMTP. Para obter uma lista dos contadores de desempenho disponíveis, relacionados ao categorizador de mensagens, consulte o artigo 231734 da Base de Dados de Conhecimento Microsoft, "XCON: Contadores do Monitor de Desempenho para o Categorizador de Mensagens " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Para obter informações sobre alguns dos outros contadores WMI do Categorizador, consulte os seguintes artigos do Exchange Server Analyzer:

  • Aviso de falha de mensagem SMTP - Falha do serviço de diretório do categorizador

  • Aviso de falha de mensagem SMTP - Pesquisas de endereços do categorizador não encontradas

  • Aviso de falha de mensagem SMTP - Erro não repetível do categorizador

  • Aviso de falha de mensagem SMTP - Falha de falta de memória do categorizador

  • Aviso de falha de mensagem SMTP - Erro repetível do categorizador


Aviso de falha de mensagem SMTP - Falha do serviço de diretório do categorizador
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-03-20

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_PerfRawData_SMTPSVC_SMTPServer para determinar o valor da chave CatCategorizationsfailedDSconnectionfailure. O valor dessa chave representa o número de categorizações que falharam devido a uma falha do serviço de conexão do servidor de diretório. O Exchange Server Analyzer consulta também a chave WMI Win32_PerfRawData_PerfOS_System para determinar o valor de SystemUpTime.

Se o Exchange Server Analyzer determinar que o valor da chave SystemUpTime é maior do que 0 e que o resultado do valor de CatCategorizationsfailedDSconnectionfailure dividido pelo valor de SystemUpTime é maior do que 50, um aviso será exibido.

O categorizador de mensagens examina as mensagens recebidas em um servidor SMTP e decide o que fazer com elas. As mensagens podem ser destinadas ao armazenamento de informações local, a um host remoto, usando o MTA (agente de transferência de mensagens) ou destinadas a um host remoto, usando o SMTP. O categorizador também trata da expansão da lista de distribuição. O categorizador é um plug-in para o mecanismo de enfileiramento avançado que executa consultas LDAP (Lightweight Directory Access Protocol) em servidores de catálogos globais na porta TCP 3268. O categorizador é basicamente uma coleção de coletores de eventos que executam resolução de endereços avançada em cada mensagem que percorre o mecanismo de enfileiramento avançado. Ele executa resolução de endereços, encaminhamento de mensagens, define sinalizadores de conversão de conteúdo, expande listas de distribuição, impõe configurações globais, gera notificações de status de entrega, detecta roteamentos de destinatário alternativos, bifurcação, registro em diário e várias outras funções.

Quando uma mensagem insere o categorizador de mensagens, o categorizador resolve o remetente do envelope pesquisando o endereço nos atributos de endereço do proxy no serviço de diretório do Active Directory®. O categorizador também resolve o destinatário do envelope, pesquisando cada endereço nos atributos de endereços do proxy, no Active Directory. Por exemplo, se a lista contiver uma lista de distribuição, ele expandirá a lista de modo a incluir esses membros se a expansão de lista de distribuição for permitida no servidor.

Esse aviso indica que uma média de 50 ou mais tentativas de conexão do serviço de diretório feitas pelo categorizador de mensagens estão caindo a cada dia. Há várias causas para isso, inclusive problemas com o acesso DSAccess, latência ou falhas de replicação de diretório, servidores de catálogo global sobrecarregados e problemas no DNS.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Examine se há erros nos logs de evento no computador do Exchange Server.

  2. Se você não localizar nenhum evento que lhe permita resolver o problema, considere aumentar o log de diagnóstico no Categorizador MSExchangeTransport para Máximo. Assim que o log de diagnóstico estiver habilitado, verifique novamente se há erros no log de eventos. Se a configuração do log de diagnóstico para o máximo não produzir entradas de log de eventos, configure o log de diagnóstico para o nível 7 usando o Registro. Ao definir para nível 7, a ID de Evento 9000 gerada pelo Categorizador de Mensagens será registrada, o que detalhará a função, o motivo da falha, o nome do destinatário que falhou e o tipo de destinatário. Para definir o log de diagnóstico para o nível 7:

    1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

    2. Navegue para:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. No painel direito, clique duas vezes no 2 Categorizador, defina o dado do valor com 7 e clique em OK.

    4. Feche o editor de Registro.

      Observação:
      Depois de concluir a solução de problemas, redefina o dado do valor do Categorizador do nível 2 novamente para 0.

  3. Verifique se o Exchange Server tem conectividade com um ou mais servidores de catálogo global. A ferramenta Monitor de Rede no Windows é muito útil para essa finalidade.

  4. Examine as mensagens de notificação de status de entrega que estão sendo geradas. As mensagens de notificação de status de entrega que podem incluir as notificações de falha na entrega descrevem mensagens de falhas permanentes e mensagens de falhas transitórias, que geralmente terminam como erros de entrega permanentes.

  5. Use o Controle de Mensagens para solucionar os problemas de mensagens atoladas no categorizador.

  6. Use a ferramenta Archive Sink para arquivar e analisar mensagens que entram e saem do Exchange Server.

  7. Monitore os contadores de desempenho do categorizador no Monitor do Sistema.

Para obter uma lista das mensagens de notificação de status de entrega e de falha na entrega geradas pelo Exchange Server e Microsoft Windows Small Business Server, consulte o artigo 284204 da Base de Dados de Conhecimento da Microsoft, "Notificações de status de entrega no Exchange Server e no Small Business Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Para obter mais informações sobre como usar a Central de Controle de Mensagens no Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 262162, "XADM: Usando a Central de Controle de Mensagens para rastrear uma mensagem" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Como habilitar o Controle de Mensagens no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "IDs de eventos do Controle de Mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Recursos aprimorados de Controle de Mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

Para obter mais informações sobre como solucionar problemas do categorizador de mensagens, consulte o WebCasts do Suporte da Microsoft, "Exchange 2000 Server: Solução de problemas do Categorizador de Mensagens e de notificações de falha na entrega " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Para obter mais informações sobre a ferramenta Coletor de Arquivo Morto, consulte o artigo 307798 da Base de Dados de Conhecimento da Microsoft, "O utilitário Coletor de Arquivo Morto está disponível no Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Para obter mais informações gerais sobre como solucionar problemas relacionados a transporte, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 821910, "COMO FAZER: Solucionar Problemas de Transporte do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "XCON: General Troubleshooting for Exchange 2000 Transport Issues" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Os contadores de desempenho do categorizador de mensagens são publicados separadamente, para cada instância do servidor virtual SMTP. Para obter uma lista dos contadores de desempenho disponíveis, relacionados ao Categorizador de Mensagens, consulte o artigo 231734 da Base de Dados de Conhecimento da Microsoft, "XCON: Contadores do Monitor de Desempenho para o Categorizador de Mensagens " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Para obter informações sobre alguns dos outros contadores WMI do Categorizador, consulte os seguintes artigos do Analisador do Exchange Server:

  • Aviso de falha de mensagem SMTP - Pesquisas de endereços do categorizador não encontradas

  • Aviso de falha de mensagem SMTP - Falha de logon no diretório do categorizador

  • Aviso de falha de mensagem SMTP - Erro não repetível do categorizador

  • Aviso de falha de mensagem SMTP - Falha de falta de memória do categorizador

  • Aviso de falha de mensagem SMTP - Erro repetível do categorizador


Aviso de falha de mensagem SMTP - Erro não repetível do categorizador
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_PerfRawData_SMTPSVC_SMTPServer do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave CatCategorizationsfailednonretryableerror. O valor dessa chave representa o número de categorizações que falharam devido a um erro fatal (não repetível). O Analisador do Exchange Server também consulta a chave WMI Win32_PerfRawData_PerfOS_System para determinar o valor de SystemUpTime.

Se o Exchange Server Analyzer determinar que o valor da chave SystemUpTime é maior que 0 e que o resultado do valor de CatCategorizationsfailednonretryableerror dividido pelo valor de SystemUpTime é maior que 50, será exibido um aviso.

O categorizador de mensagens examina as mensagens recebidas em um servidor SMTP e decide o que fazer com elas. As mensagens podem ser destinadas ao armazenamento de informações local, a um host remoto, usando o MTA (agente de transferência de mensagens) ou destinadas a um host remoto, usando o SMTP. O categorizador também trata da expansão da lista de distribuição. O categorizador é um plug-in para o mecanismo de enfileiramento avançado que executa consultas LDAP (Lightweight Directory Access Protocol) em servidores de catálogos globais na porta TCP 3268. O categorizador é basicamente uma coleção de coletores de eventos que executam resolução de endereços avançada em cada mensagem que percorre o mecanismo de enfileiramento avançado. Ele executa resolução de endereços, encaminhamento de mensagens, define sinalizadores de conversão de conteúdo, expande listas de distribuição, impõe configurações globais, gera notificações de status de entrega, detecta roteamentos de destinatário alternativos, bifurcação, registro em diário e várias outras funções.

Assim que a mensagem entra no categorizador de mensagens, ele resolve o remetente do envelope, procurando o endereço nos atributos de endereço do proxy, no serviço de diretório do Active Directory®. O categorizador também resolve o destinatário do envelope, pesquisando cada endereço nos atributos de endereços do proxy, no Active Directory. Por exemplo, se a lista contiver uma lista de distribuição, ele expandirá a lista de modo a incluir esses membros se a expansão de lista de distribuição for permitida no servidor.

Este aviso indica que está ocorrendo uma média de 50 erros ou mais todos os dias. Há várias causas para isso, inclusive problemas com o acesso DSAccess, latência ou falhas de replicação de diretório, servidores de catálogo global sobrecarregados e problemas no DNS.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Verifique se existem erros nos logs de eventos no computador do Exchange Server.

  2. Se você não encontrar eventos que permitam solucionar o problema, experimente aumentar para o valor máximo o log de diagnóstico no Categorizador MSExchangeTransport. Depois que o log de diagnóstico estiver habilitado, verifique novamente se existem erros no log de eventos. Se a configuração do log de diagnóstico com o valor máximo não gerar quaisquer entradas do log de eventos, configure o log de diagnóstico para o nível 7 usando o Registro. Quando definido com o nível 7, o ID de evento 9000 gerado pelo categorizador de mensagens será registrado, descrevendo a função, o motivo da falha, o nome do destinatário que falhou e o tipo de destinatário. Para definir o log de diagnóstico para o nível 7:

    1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

    2. Navegue para:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. No painel direito, clique duas vezes no 2 Categorizador, defina o dado do valor com 7 e clique em OK.

    4. Feche o editor de Registro.

      Observação:
      Depois de concluir a solução de problemas, redefina o dado do valor do Categorizador do nível 2 novamente para 0.

  3. Verifique se o Exchange Server tem conectividade com um ou mais servidores de catálogo global. A ferramenta Monitor de Rede no Windows é muito útil para essa finalidade.

  4. Examine as mensagens de notificação de status de entrega que estão sendo geradas. As mensagens de notificação de status de entrega que podem incluir as notificações de falha na entrega descrevem mensagens de falhas permanentes e mensagens de falhas transitórias, que geralmente terminam como erros de entrega permanentes.

  5. Use o Controle de Mensagens para solucionar os problemas de mensagens atoladas no categorizador.

  6. Use a ferramenta Archive Sink para arquivar e analisar mensagens que entram e saem do Exchange Server.

  7. Monitore os contadores de desempenho do categorizador no Monitor do Sistema.

Para obter uma lista das mensagens de notificação de status de entrega e de falha na entrega geradas pelo Exchange Server e Microsoft Windows Small Business Server, consulte o artigo 284204 da Base de Dados de Conhecimento da Microsoft, "Notificações de status de entrega no Exchange Server e no Small Business Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Para obter mais informações sobre como usar a Central de Controle de Mensagens no Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 262162, "XADM: Usando a Central de Controle de Mensagens para rastrear uma mensagem" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Como habilitar o Controle de Mensagens no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "IDs de eventos do Controle de Mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Recursos aprimorados de Controle de Mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

Para obter mais informações sobre como solucionar problemas do categorizador de mensagens, consulte o WebCasts do Suporte da Microsoft, "Exchange 2000 Server: Solução de problemas do Categorizador de Mensagens e de notificações de falha na entrega " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Para obter mais informações sobre a ferramenta Coletor de Arquivo Morto, consulte o artigo 307798 da Base de Dados de Conhecimento da Microsoft, "O utilitário Coletor de Arquivo Morto está disponível no Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Para obter mais informações gerais sobre como solucionar problemas relacionados a transporte, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 821910, "COMO FAZER: Solucionar Problemas de Transporte do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "XCON: General Troubleshooting for Exchange 2000 Transport Issues" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Os contadores de desempenho do categorizador de mensagens são publicados separadamente, para cada instância do servidor virtual SMTP. Para obter uma lista dos contadores de desempenho disponíveis, relacionados ao Categorizador de Mensagens, consulte o artigo 231734 da Base de Dados de Conhecimento da Microsoft, "XCON: Contadores do Monitor de Desempenho para o Categorizador de Mensagens " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Para obter informações sobre alguns dos outros contadores WMI do Categorizador, consulte os seguintes artigos do Analisador do Exchange Server:

  • Aviso de falha de mensagem SMTP - Pesquisas de endereços do categorizador não encontradas

  • Aviso de falha de mensagem SMTP - Falha de logon no diretório do categorizador

  • Aviso de falha de mensagem SMTP - Falha do serviço de diretório do categorizador

  • Aviso de falha de mensagem SMTP - Falha de falta de memória do categorizador

  • Aviso de falha de mensagem SMTP - Erro repetível do categorizador


Aviso de falha de mensagem SMTP - Falha de falta de memória do categorizador
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-03-28

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_PerfRawData_SMTPSVC_SMTPServer do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave CatCategorizationsfailedOutOfMemory. O valor dessa chave representa o número de categorizações que falharam por causa da falta de memória disponível. O Analisador do Exchange Server também consulta a chave WMI Win32_PerfRawData_PerfOS_System para determinar o valor de SystemUpTime.

Se o Exchange Server Analyzer determinar que o valor da chave SystemUpTime é maior que 0 e que o resultado do valor de BadmailedMessagesNDRofDSN dividido pelo valor de SystemUpTime é maior que 50, será exibido um aviso.

O categorizador de mensagens examina as mensagens recebidas em um servidor SMTP e decide o que fazer com elas. As mensagens podem ser destinadas ao armazenamento de informações local, a um host remoto, usando o MTA (agente de transferência de mensagens) ou destinadas a um host remoto, usando o SMTP. O categorizador também trata da expansão da lista de distribuição. O categorizador é um plug-in para o mecanismo de enfileiramento avançado que executa consultas LDAP (Lightweight Directory Access Protocol) em servidores de catálogos globais na porta TCP 3268. O categorizador é basicamente uma coleção de coletores de eventos que executam resolução de endereços avançada em cada mensagem que percorre o mecanismo de enfileiramento avançado. Ele executa resolução de endereços, encaminhamento de mensagens, define sinalizadores de conversão de conteúdo, expande listas de distribuição, impõe configurações globais, gera notificações de status de entrega, detecta roteamentos de destinatário alternativos, bifurcação, registro em diário e várias outras funções.

Assim que a mensagem entra no categorizador de mensagens, ele resolve o remetente do envelope, procurando o endereço nos atributos de endereço do proxy, no serviço de diretório do Active Directory®. O categorizador também resolve o destinatário do envelope, pesquisando cada endereço nos atributos de endereços do proxy, no Active Directory. Por exemplo, se a lista contiver uma lista de distribuição, ele expandirá a lista de modo a incluir esses membros se a expansão de lista de distribuição for permitida no servidor.

Esse aviso indica que uma média de 50 ou mais categorizações estão falhando a cada dia por causa da falta de memória disponível. Há várias causas para isso, inclusive problemas com o acesso DSAccess, latência ou falhas de replicação de diretório, servidores de catálogo global sobrecarregados e problemas no DNS.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Verifique se existem erros nos logs de eventos no computador do Exchange Server.

  2. Se você não encontrar eventos que permitam solucionar o problema, experimente aumentar para o valor máximo o log de diagnóstico no Categorizador MSExchangeTransport. Depois que o log de diagnóstico estiver habilitado, verifique novamente se existem erros no log de eventos. Se a configuração do log de diagnóstico com o valor máximo não gerar quaisquer entradas do log de eventos, configure o log de diagnóstico para o nível 7 usando o Registro. Quando definido com o nível 7, o ID de evento 9000 gerado pelo categorizador de mensagens será registrado, descrevendo a função, o motivo da falha, o nome do destinatário que falhou e o tipo de destinatário. Para definir o log de diagnóstico para o nível 7:

    1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

    2. Navegue para:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. No painel direito, clique duas vezes no 2 Categorizador, defina o dado do valor com 7 e clique em OK.

    4. Feche o editor de Registro.

      Observação:
      Depois de concluir a solução de problemas, redefina o dado do valor do Categorizador do nível 2 novamente para 0.

  3. Verifique se o Exchange Server tem conectividade com um ou mais servidores de catálogo global. A ferramenta Monitor de Rede no Windows é muito útil para essa finalidade.

  4. Examine as mensagens de notificação de status de entrega que estão sendo geradas. As mensagens de notificação de status de entrega que podem incluir as notificações de falha na entrega descrevem mensagens de falhas permanentes e mensagens de falhas transitórias, que geralmente terminam como erros de entrega permanentes.

  5. Use o Controle de Mensagens para solucionar os problemas de mensagens atoladas no categorizador.

  6. Use a ferramenta Coletor de Arquivo Morto para arquivar e analisar as mensagens de entrada e saída do Exchange Server.

  7. Monitore os contadores de desempenho do categorizador no Monitor do Sistema.

Para obter uma lista das mensagens de notificação de status de entrega e de falha na entrega geradas pelo Exchange Server e Microsoft Windows Small Business Server, consulte o artigo 284204 da Base de Dados de Conhecimento da Microsoft, "Notificações de status de entrega no Exchange Server e no Small Business Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Para obter mais informações sobre como usar a Central de Controle de Mensagens no Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 262162, "XADM: Usando a Central de Controle de Mensagens para rastrear uma mensagem" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Como habilitar o controle de mensagens no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856) (em inglês).

  • 821905, "IDs de eventos do Controle de Mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Recursos aprimorados de Controle de Mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

Para obter mais informações sobre como solucionar problemas do categorizador de mensagens, consulte o WebCasts do Suporte da Microsoft, "Exchange 2000 Server: Solução de problemas do Categorizador de Mensagens e de notificações de falha na entrega " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Para obter mais informações sobre a ferramenta Coletor de Arquivo Morto, consulte o artigo 307798 da Base de Dados de Conhecimento da Microsoft, "O utilitário Coletor de Arquivo Morto está disponível no Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Para obter mais informações gerais sobre como solucionar problemas relacionados a transporte, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 821910, "COMO FAZER: Solucionar problemas de transporte do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265, "Solução de problemas gerais de transporte no Exchange 2000 Server e no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=305 2 &kbid=257265) (em inglês).

Os contadores de desempenho do categorizador de mensagens são publicados separadamente, para cada instância do servidor virtual SMTP. Para obter uma lista dos contadores de desempenho disponíveis, relacionados ao Categorizador de Mensagens, consulte o artigo 231734 da Base de Dados de Conhecimento da Microsoft, "XCON: Contadores do Monitor de Desempenho para o Categorizador de Mensagens " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Para obter informações sobre alguns dos outros contadores WMI do Categorizador, consulte os seguintes artigos do Analisador do Exchange Server:

  • Aviso de falha de mensagem SMTP - Pesquisas de endereços do categorizador não encontradas

  • Aviso de falha de mensagem SMTP - Falha de logon no diretório do categorizador

  • Aviso de falha de mensagem SMTP - Falha do serviço de diretório do categorizador

  • Aviso de falha de mensagem SMTP - Erro não repetível do categorizador

  • Aviso de falha de mensagem SMTP - Erro repetível do categorizador


Aviso de falha de mensagem SMTP - Erro repetível do categorizador
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-03-20

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_PerfRawData_SMTPSVC_SMTPServer do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave CatCategorizationsfailedretryableerror. O valor dessa chave representa o número de categorizações que falharam com um erro repetível. O Analisador do Exchange Server também consulta a chave WMI Win32_PerfRawData_PerfOS_System para determinar o valor de SystemUpTime.

Se o Exchange Server Analyzer determinar que o valor da chave SystemUpTime é maior do que 0 e que o resultado do valor de CatCategorizationsfailedretryableerror dividido pelo valor de SystemUpTime é maior do que 500, será exibido um aviso.

O categorizador de mensagens examina as mensagens recebidas em um servidor SMTP e decide o que fazer com elas. As mensagens podem ser destinadas ao armazenamento de informações local, a um host remoto, usando o MTA (agente de transferência de mensagens) ou destinadas a um host remoto, usando o SMTP. O categorizador também trata da expansão da lista de distribuição. O categorizador é um plug-in para o mecanismo de enfileiramento avançado que executa consultas LDAP (Lightweight Directory Access Protocol) em servidores de catálogos globais na porta TCP 3268. O categorizador é basicamente uma coleção de coletores de eventos que executam resolução de endereços avançada em cada mensagem que percorre o mecanismo de enfileiramento avançado. Ele executa resolução de endereços, encaminhamento de mensagens, define sinalizadores de conversão de conteúdo, expande listas de distribuição, impõe configurações globais, gera notificações de status de entrega, detecta roteamentos de destinatário alternativos, bifurcação, registro em diário e várias outras funções.

Assim que a mensagem entra no categorizador de mensagens, ele resolve o remetente do envelope, procurando o endereço nos atributos de endereço do proxy, no serviço de diretório do Active Directory®. O categorizador também resolve o destinatário do envelope, pesquisando cada endereço nos atributos de endereços do proxy, no Active Directory. Por exemplo, se a lista contiver uma lista de distribuição, ele expandirá a lista de modo a incluir esses membros se a expansão de lista de distribuição for permitida no servidor.

Esse aviso indica que uma média de 500 ou mais categorizações estão falhando por dia com um erro repetível. Há várias causas para isso, incluindo problemas com o DSAccess (directory service access), latência ou falhas na replicação de diretório, servidores de catálogo global sobrecarregados e problemas com DNS.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse aviso

  1. Verifique se existem erros nos logs de eventos no computador do Exchange Server.

  2. Se você não encontrar eventos que permitam solucionar o problema, experimente aumentar para o valor máximo o log de diagnóstico no Categorizador MSExchangeTransport. Depois que o log de diagnóstico estiver habilitado, verifique novamente se existem erros no log de eventos. Se a configuração do log de diagnóstico com o valor máximo não gerar quaisquer entradas do log de eventos, configure o log de diagnóstico para o nível 7 usando o Registro. Quando definido com o nível 7, o ID de evento 9000 gerado pelo categorizador de mensagens será registrado, descrevendo a função, o motivo da falha, o nome do destinatário que falhou e o tipo de destinatário. Para definir o log de diagnóstico para o nível 7:

    1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

    2. Navegue para:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. No painel direito, clique duas vezes no 2 Categorizador, defina o dado do valor com 7 e clique em OK.

    4. Feche o editor de Registro.

      Observação:
      Depois de concluir a solução de problemas, redefina o dado do valor do Categorizador do nível 2 novamente para 0.

  3. Verifique se o Exchange Server tem conectividade com um ou mais servidores de catálogo global. A ferramenta Monitor de Rede no Windows é muito útil para essa finalidade.

  4. Examine as mensagens de notificação de status de entrega que estão sendo geradas. As mensagens de notificação de status de entrega que podem incluir as notificações de falha na entrega descrevem mensagens de falhas permanentes e mensagens de falhas transitórias, que geralmente terminam como erros de entrega permanentes.

  5. Use o Controle de Mensagens para solucionar os problemas de mensagens atoladas no categorizador.

  6. Use a ferramenta Coletor de Arquivo Morto para arquivar e analisar as mensagens de entrada e saída do Exchange Server.

  7. Monitore os contadores de desempenho do categorizador no Monitor do Sistema.

Para obter uma lista das mensagens de notificação de status de entrega e de falha na entrega geradas pelo Exchange Server e Microsoft Windows Small Business Server, consulte o artigo 284204 da Base de Dados de Conhecimento da Microsoft, "Notificações de status de entrega no Exchange Server e no Small Business Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Para obter mais informações sobre como usar a Central de Controle de Mensagens no Exchange Server, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 262162, "XADM: Usando a Central de Controle de Mensagens para rastrear uma mensagem" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162)

  • 246856, "XADM: Como habilitar o Controle de Mensagens no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856)

  • 821905, "IDs de eventos do Controle de Mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905)

  • 823864, "Recursos aprimorados de Controle de Mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864)

Para obter mais informações sobre como solucionar problemas do categorizador de mensagens, consulte o WebCasts do Suporte da Microsoft, "Exchange 2000 Server: Solução de problemas do Categorizador de Mensagens e de notificações de falha na entrega " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Para obter mais informações sobre a ferramenta Coletor de Arquivo Morto, consulte o artigo 307798 da Base de Dados de Conhecimento da Microsoft, "O utilitário Coletor de Arquivo Morto está disponível no Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Para obter mais informações gerais sobre como solucionar problemas relacionados a transporte, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 821910, "COMO FAZER: Solucionar Problemas de Transporte do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, "XCON: General Troubleshooting for Exchange 2000 Transport Issues" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Os contadores de desempenho do categorizador de mensagens são publicados separadamente, para cada instância do servidor virtual SMTP. Para obter uma lista dos contadores de desempenho disponíveis, relacionados ao Categorizador de Mensagens, consulte o artigo 231734 da Base de Dados de Conhecimento da Microsoft, "XCON: Contadores do Monitor de Desempenho para o Categorizador de Mensagens " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Para obter informações sobre alguns dos outros contadores WMI do Categorizador, consulte os seguintes artigos da ferramenta Exchange Server Analyzer:

  • Aviso de falha de mensagem SMTP - Pesquisas de endereços do categorizador não encontradas

  • Aviso de falha de mensagem SMTP - Falha de logon no diretório do categorizador

  • Aviso de falha de mensagem SMTP - Falha do serviço de diretório do categorizador

  • Aviso de falha de mensagem SMTP - Erro não repetível do categorizador

  • Aviso de falha de mensagem SMTP - Falha de falta de memória do categorizador


Os dados da fila de mensagens SMTP estão sendo gravados em uma pasta compactada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Directory do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Compressed da pasta da fila de mensagens SMTP. Se o Exchange Server Analyzer localizar o valor para Compressed definido como True, um aviso será exibido.

Quando chegam mensagens ao computador do Exchange através do serviço SMTP, os dados são gravados no disco rígido como um arquivo .eml. Por padrão, esses arquivos são armazenados na pasta :\Arquivos de Programas\Exchsrvr\Mailroot da <unidade> na mesma partição em que o Exchange está instalado. Se a pasta em que a fila de mensagens SMTP está armazenada tiver a compactação de arquivos ativada, o desempenho do Exchange poderá ser seriamente comprometido. Por isso, não há suporte para compactação da pasta em que a fila de mensagens SMTP está armazenada.

A Microsoft não dá suporte ao armazenamento de arquivos de dados do Exchange em um volume compactado. Quando você armazenar seus arquivos de dados do Exchange em um volume compactado, a sobrecarga adicional impactará bastante o desempenho do Exchange. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Para desativar a compactação de arquivos em uma pasta específica

  1. Clique com o botão direito na pasta onde você deseja desativar a compactação de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Compactar o conteúdo para economizar espaço em disco e clique em OK.

Para mover a pasta Mailroot no Exchange 2000 Server ou Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Clique em Grupos Administrativos, expanda seu grupo administrativo, Servidores, expanda seu servidor, Protocolos e SMTP.

  3. Clique com o botão direito no seu servidor virtual SMTP e clique em Parar.

  4. Clique com o botão direito no seu servidor virtual SMTP e clique em Propriedades.

  5. Na guia Mensagens, ao lado da caixa Diretório de fila, clique em Procurar e digite o caminho do novo local da pasta Fila.

  6. Clique em OK.

  7. Clique com o botão direito no seu servidor virtual SMTP e clique em Iniciar.

Para obter mais informações sobre como mover a pasta Mailroot, consulte o artigo 822933 da Base de Dados de Conhecimento da Microsoft, "How to change the Exchange 2003 SMTP Mailroot folder location" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).


Os dados da fila de mensagens SMTP estão sendo gravados em uma pasta criptografada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Directory da instrumentação de gerenciamento de Microsoft Windows® (WMI) para determinar o valor da chave Encrypted para a pasta de fila de email do protocolo SMTP. Se o Exchange Server Analyzer perceber que o valor para Criptografado está definido como Verdadeiro, um aviso será exibido.

Quando chegam mensagens ao computador do Exchange através do serviço SMTP, os dados são gravados no disco rígido como um arquivo .eml. Por padrão, esses arquivos são armazenados na pasta :\Arquivos de Programas\Exchsrvr\Mailroot da <unidade> na mesma partição em que o Exchange está instalado. Se a criptografia de arquivos estiver ativada na pasta em que a fila de email SMTP está armazenada, o desempenho do Exchange poderá ser seriamente prejudicado. Portanto, não há suporte para a criptografia da pasta em que a fila de email SMTP está armazenada.

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em um volume criptografado com EFS (Sistema de Criptografia de Arquivos). Quando você armazena seus arquivos de dados do Exchange em um volume criptografado, a sobrecarga adicional impacta significativamente o desempenho do Exchange. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Para ajudar a proteger seus arquivos de dados do Exchange, é recomendável que você impeça o acesso não autorizado ao computador do Exchange e que você use o formato de mensagem S/MIME para criptografar dados de mensagens.

Para resolver esse erro, você deve desativar a criptografia de arquivos na pasta de fila de email SMTP ou mover essa pasta para um local onde a criptografia não esteja habilitada.

Para desativar a criptografia de arquivos em uma determinada pasta

  1. Clique com o botão direito na pasta em que deseja desativar a criptografia de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Criptografar o conteúdo para proteger dados e clique em OK.

Para mover a pasta de fila de email SMTP no Exchange 2000 Server ou no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Clique em Grupos Administrativos, expanda seu grupo administrativo, Servidores, expanda seu servidor, Protocolos e SMTP.

  3. Clique com o botão direito no seu servidor virtual SMTP e clique em Parar.

  4. Clique com o botão direito no seu servidor virtual SMTP e clique em Propriedades.

  5. Na guia Mensagens, ao lado da caixa Diretório de mensagens inválidas, clique em Procurar e digite o caminho do novo local da pasta Fila.

  6. Clique em OK.

  7. Clique com o botão direito no seu servidor virtual SMTP e clique em Iniciar.

Para obter mais informações sobre como mover a pasta Mailroot, consulte o artigo 822933 da Base de Dados de Conhecimento da Microsoft, "How to change the Exchange 2003 SMTP Mailroot folder location" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Para obter mais informações sobre o EFS e os arquivos de dados do Exchange Server, consulte o artigo 834638 da Base de Dados de Conhecimento da Microsoft, "Information about the storage of data files on an encrypted volume in Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Para obter mais informações sobre como proteger mensagens no Microsoft Exchange Server 2003, consulte "Guia de segurança de mensagens do Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47574).


Os dados da fila de mensagens SMTP estão sendo gravados em uma partição não-NTFS
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

O Microsoft® Exchange Server Analyzer Tool consulta a classe Win32_Directory do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave Win32_Directory para o diretório da fila SMTP do Exchange. Se o Analisador do Exchange Server determinar que o valor da chave FSName não é igual a Sistema de Arquivo NTFS, um erro será exibido.

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em volumes não-NTFS. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

Se receber esse erro, você deverá mover o diretório de fila SMTP para uma pasta em uma unidade NTFS. Como alternativa, se a unidade em que o diretório de fila está armazenado estiver formatada como FAT, você poderá usar a ferramenta de linha de comando convert.exe para converter a unidade em NTFS.

Para mover a fila SMTP para outra pasta

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Clique em Grupos Administrativos, expanda seu grupo administrativo, Servidores, expanda seu servidor, Protocolos e SMTP.

  3. Clique com o botão direito no seu servidor virtual SMTP e clique em Parar.

  4. Clique com o botão direito no seu servidor virtual SMTP e clique em Propriedades.

  5. Na guia Mensagens, ao lado da caixa Diretório de mensagens inválidas, clique em Procurar e digite o caminho do novo local da pasta Fila.

  6. Clique em OK.

  7. Clique com o botão direito no seu servidor virtual SMTP e clique em Iniciar.

Para obter mais informações sobre como mover a pasta Mailroot, consulte o artigo 822933 da Base de Dados de Conhecimento da Microsoft, "How to change the Exchange 2003 SMTP Mailroot folder location" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Como alternativa ao procedimento descrito nesse artigo, se a unidade em que os arquivos estão armazenados for formatada como FAT, você poderá usar a ferramenta de linha de comando convert.exe para converter a unidade para NTFS. Para obter mais informações sobre como usar a ferramenta de linha de comando convert.exe para converter uma partição FAT para uma partição NTFS, consulte o artigo 214579 da Base de Dados de Conhecimento Microsoft, "Como utilizar o Convert.exe para converter uma partição para o sistema de arquivos NTFS" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579).


O valor de MaxDSNSize do SMTP foi definido manualmente
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-01-17

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a subchave de Registro a seguir para determinar se o tamanho máximo das mensagens de notificação de status de entrega (DSN) foram substituídas manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

Se o Exchange Server Analyzer detectar que MaxDSNSize precisa estar presente e configurado, uma mensagem de configuração não padrão será exibida.

O valor do Registro MaxDSNSize permite que um computador executando o Exchange 2000 Server Service Pack 2 (SP2) ou posterior remova os anexos caso uma mensagem não seja entregue. Se você habilitar essa opção, você poderá salvar recursos de rede e de servidor. Entretanto, existem desvantagens para essa implementação de remoção de anexos SMTP.

Se você habilitar essa opção para remover os anexos de uma notificação de falha na entrega, os detalhes necessários para exibir a notificação no painel de visualização também serão removidos e o originador da mensagem não poderá usar a opção Enviar Novamente. Se o remetente da mensagem tentar usar a opção Enviar Novamente a partir de uma Notificação de Falha na Entrega, ele receberá a seguinte mensagem de erro:

"Não é possível reenviar a mensagem. O relatório de entregas não efetuadas não contém informações suficientes sobre a mensagem original. Para reenviar a mensagem, abra-a em sua pasta Itens Enviados, clique no menu Ações e clique em Reenviar esta mensagem".

No entanto, o remetente da mensagem não consegue reenviar a mensagem, mesmo usando o método da mensagem de erro. Portanto, é recomendável que você use essa opção com cautela.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para modificar o valor do Registro MaxDSNSize

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Crie um valor de Registro DWORD chamado MaxDSNSize e defina seus dados de valor (em bytes) para o valor desejado.

  4. Saia do editor do Registro e reinicie o serviço SMTP para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o valor do Registro MaxDSNSize, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 308303, "XCON: Opção para remover anexos de mensagens que geram uma notificação de falha na entrega" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303)

  • 323484, "XCON: Descrição do formato de mensagem da Internet com diversas partes/relatórios no Exchange 2000" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484)


O valor do Registro MaxPendingCat de SMTP não é padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se as configurações padrão de enfileiramento do SMTP foram alteradas:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se o Exchange Server Analyzer perceber que a chave MaxPendingCat foi definida, o Exchange Server Analyzer exibirá uma mensagem não padrão.

É recomendável que os valores de enfileiramento padrão só sejam modificados após uma consideração completa. Os padrões foram selecionados atentamente para obter o desempenho ideal na maioria dos ambientes. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento do enfileiramento no Exchange.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre o enfileiramento do SMTP do Exchange, consulte a seguinte entrada no Blog da Equipe do Microsoft Exchange, "Explaining the Mysterious SMTP Advanced Queuing Engine" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=48585).


MaxMessageObjects do SMTP foi definido muito baixo
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar o número máximo de mensagens de email que o sistema pode alocar:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

Se o Exchange Server Analyzer verificar que o valor para MaxMessageObjects é menor do que 30001, um aviso será exibido.

Quando a fila contém o número máximo de mensagens, nenhuma mensagem de entrada adicional é aceita pelo protocolo SMTP. Cada mensagem de email residente na fila SMTP usa pelo menos 4 quilobytes (KB) de memória. Portanto, é possível atingir-se uma situação de pouca memória se a fila for muito grande.

O valor MaxMessageObjects não está presente por padrão, e o número máximo de mensagens é definido como 100.000. A definição de MaxMessageObjects com um valor menor reduz o número máximo de mensagens que podem residir na fila, diminuindo o espaço em disco necessário para SMTP. Depois que esse limite é alcançado, cada conexão SMTP estabelecida com o servidor retornará com um erro de falta de memória.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir um limite no número de mensagens SMTP que podem estar na fila

  1. Inicie um editor de Registro, como Regedit.exe ou Regedt32.exe.

  2. Navegue para: HKLM\Software\Microsoft\Exchange

  3. Clique com o botão direito na chave do Exchange e clique em Nova Chave. Nomeie a nova chave como MailMsg.

  4. Clique com o botão direito na chave MailMsg e clique em Novo Valor DWORD.

  5. Clique com o botão direito no novo valor, clique em Renomear e, em seguida, digite MaxMessageObjects.

  6. Clique duas vezes no valor MaxMessageObjects e defina-o para o número máximo de mensagens que você deseja colocar nas filas a qualquer momento. A menos que você precise processar mais mensagens, recomendamos um valor máximo de 100.000.

  7. Saia do editor do Registro e reinicie o serviço SMTP para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como definir limites de mensagens em filas, consulte o artigo 258748 da Base de Dados de Conhecimento da Microsoft, "Como definir um limite para o número de mensagens SMTP em filas" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748).


O parâmetro do Registro MaxMessageObjects do SMTP foi alterado de seu padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar o número máximo de mensagens de email que o sistema pode alocar:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

Se o Analisador do Exchange Server obtiver um valor de MaxMessageObjects acima de 0, será exibida uma mensagem de configuração não padrão.

Quando a fila contiver o número máximo de mensagens, nenhuma mensagem de entrada adicional será aceita pelo SMTP. Cada mensagem de email residente na fila SMTP usa pelo menos 4 KB (kilobytes) de memória; portanto, pode ocorrer uma situação de pouca memória com uma fila muito grande.

Por padrão, o valor de MaxMessageObjects não está presente e o número máximo de mensagens está definido como 100.000. Definir MaxMessageObjects com um valor inferior reduz o número máximo de mensagens que podem residir na fila, diminuindo, com isso, a memória máxima necessária para o SMTP. Depois que esse limite é alcançado, cada conexão SMTP estabelecida com o servidor retornará com um erro de falta de memória.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para definir um limite no número de mensagens SMTP que podem estar na fila

  1. Inicie um editor de Registro, como Regedit.exe ou Regedt32.exe.

  2. Navegue para: HKLM\Software\Microsoft\Exchange

  3. Clique com o botão direito na chave do Exchange e clique em Nova Chave. Nomeie a nova chave como MailMsg.

  4. Clique com o botão direito na chave MailMsg e clique em Novo Valor DWORD.

  5. Clique com o botão direito no novo valor, clique em Renomear e, em seguida, digite MaxMessageObjects.

  6. Clique duas vezes no valor MaxMessageObjects e defina-o para o número máximo de mensagens que você deseja colocar nas filas a qualquer momento. A menos que você precise processar mais mensagens, é recomendável usar um valor máximo de 100.000.

  7. Saia do Editor do Registro e reinicie o serviço SMTP para que a alteração entre em vigor.

Antes de editar o Registro e obter informações sobre como editar o Registro, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre como definir limites de mensagens em filas, consulte o artigo 258748 da Base de Dados de Conhecimento, "Como definir um limite para o número de mensagens SMTP em filas" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748).


O valor do Registro MaxPercentPoolThreads do SMTP foi definido manualmente
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-01-17

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se os threads de pool adicionais foram configurados manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPercentPoolThreads

Se o Exchange Server Analyzer verificar que o valor MaxPercentPoolThreads está presente e configurado, será exibida uma mensagem de configuração não padrão.

Existem cinco filas de trabalho no SMTP que usam um pool de threads conhecido como os threads ATQ. Pelo projeto, duas dessas filas podem, por padrão, usar até 90% dos threads disponíveis. Esse pool de threads é compartilhado pelo processo que aceita solicitações POP e IMAP. Portanto, em uma situação de carga moderada para alta, pode surgir uma circunstância em que o SMTP pode manter recursos dos serviços POP e IMAP.

Você pode reservar threads adequados para POP e IMAP limitando a porcentagem de threads que o SMTP pode usar. Para fazer essa alteração, aumente o número geral de threads disponíveis para o IIS. A única alternativa aqui é o aumento do uso de memória para os threads adicionais.

Existem dois valores de Registro que permitem controlar a porcentagem de threads do SMTP e threads adicionais por processador:

Local: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

Valor: AdditionalPoolThreadsPerProc

Tipo: REG_DWORD

Local: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

Valor: MaxPercentPoolThreads

Tipo: REG_DWORD

Ambos os valores de Registro deverão ser ajustados nos computadores agrupados do Exchange Server se um número elevado de atividades de SMTP fizer com que os recursos POP3, IMAP4, ou ambos, falhem. Você pode usar as fórmulas a seguir para calcular o valor ideal para seu cluster:

Valor de Registro | Fórmula
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * Número de servidores virtuais do protocolo)

Por exemplo, em um cluster do Exchange Server com dois servidores virtuais de protocolo, a fórmula para MaxPercentPoolThreads seria: 90 / (2*2) = 22. Ao calcular o valor de MaxPercentPoolThreads, se os seus cálculos resultarem em um valor que inclua um ponto decimal, arredonde o resultado para baixo com o próximo valor inteiro. Ao calcular o valor de AdditionalPoolThreadsPerProc, se os cálculos resultarem em um valor maior que 200, você também precisará atribuir o valor resultante a um valor de Registro adicional:

Local: HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

Valor: PoolThreadLimit

Tipo: REG_DWORD

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para configurar a definição ideal no cluster do Exchange

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Crie um valor de Registro DWORD denominado AdditionalPoolThreadsPerProc e defina seus dados de valor para o número apropriado, com base nas fórmulas anteriores.

  4. Crie um valor de Registro DWORD denominado MaxPercentPoolThreads e defina seus dados de valor para o número apropriado, com base nas fórmulas anteriores.

  5. Saia do editor de Registro e reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o problema de recurso de cluster específico, descrito nesse artigo, consulte a Base de Dados de Conhecimento, artigo 281868, "XADM: Os servidores virtuais POP\IMAP4 falham repetidamente sob carga alta" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868).


O valor do Registro MsgHandleAsyncThreshold do SMTP foi incluído manualmente, mas talvez não seja mais necessário
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-01-17

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a entrada do Registro a seguir para determinar se o número máximo de identificadores de arquivos assíncronos do IIS (Internet Information Services) foi modificado do valor padrão de 1.000:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleAsyncThreshold

Se o Exchange Server Analyzer detectar que MsgHandleAsyncThreshold está presente e configurado com um valor alternativo, um aviso será exibido.

O valor MsgHandleAsyncThreshold especifica o número máximo de identificadores de arquivos assíncronos que o IIS pode usar. Os manipuladores de arquivos são armazenados em cache para melhorar o desempenho porque, dessa forma, evitam que o servidor execute E/S (entrada/saída) e ciclos da CPU redundantes. Sempre que a pilha de transporte do SMTP em um computador com o Exchange Server recebe uma mensagem, ela é canalizada para fora do sistema de arquivos onde aguarda o roteamento para seu destino. Para gravar no sistema de arquivos, a pilha de transporte do SMTP obtém um manipulador de arquivo e passa a mensagem para esse manipulador. Cada manipulador de arquivo consome aproximadamente 2 KB (kilobytes) de memória de pool paginado. O número padrão de manipuladores de arquivos em cache do IIS é de 800 para cada 32 MB.

Antes do Exchange 2000 Server com Service Pack 2 (SP2), os servidores Exchange que mantinham grandes filas de mensagens SMTP (por exemplo, uma média de 1.000 ou mais mensagens) encontravam limitações de desempenho devido a uma definição padrão no serviço SMTP de, no máximo, 1.000 identificadores de arquivos. Como o Exchange 2000 Server predefiniu um número máximo de 1.000 manipuladores de arquivos, o serviço SMTP pôde gravar apenas 1.000 mensagens simultâneas no sistema de arquivos.

Para melhorar o desempenho nos sistemas de grande porte, três entradas do Registro eram ajustadas com freqüência simultaneamente, para aumentar o número máximo de manipuladores de arquivos que podiam ser abertos pelo serviço SMTP (para permitir o processamento de mais mensagens) e para diminuir o número de manipuladores de arquivos abertos para o sistema de arquivos instaláveis, outro componente do Exchange (para evitar ficar sem memória quando a fila estivesse grande). Estão listados a seguir os valores do Registro que, por padrão, não existiam e, portanto, deveriam ser adicionados manualmente:

Local: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Valor: MsgHandleThreshold

Tipo: REG_DWORD

Local: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Valor: MsgHandleAsyncThreshold

Tipo: REG_DWORD

Local: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Valor: FileCacheMaxHandles

Tipo: REG_DWORD

As entradas MsgHandleThreshold e MsgHandleAsyncThreshold normalmente são ajustadas para o mesmo valor (em geral, um valor superior a 1.000) e o valor FileCacheMaxHandles geralmente é reduzido de 800 para 600.

Por padrão, esse valor do Registro não está presente porque o Exchange 2000 Server com SP2 e posterior determina dinamicamente os valores ideais a serem usados. Se esse servidor Exchange estiver executando o Exchange 2000 Server com Service Pack 1 (SP1) ou anterior, recomenda-se fazer upgrade para o service pack e o pacote cumulativo mais recentes. Depois de atualizar para o código mais recente, exclua essas entradas do Registro.

O Exchange Server 2003 calcula dinamicamente as configurações adequadas para os manipuladores de arquivos do SMTP, de modo que essas configurações não são mais necessárias. Sendo assim, a menos que instruído de outra forma pelo Atendimento Microsoft, antes de atualizar quaisquer computadores do Exchange 2000 Server com essas configurações do Exchange Server 2003, exclua essas entradas do Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para reverter para a configuração padrão

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. No painel direito, exclua o valor MsgHandleAsyncThreshold.

  4. Feche o editor de Registro e reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


O valor do Registro MsgHandleThreshold do SMTP foi adicionado manualmente, mas pode não ser mais necessário
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada do Registro para determinar se o número máximo de identificadores de arquivos do IIS (Serviços de Informações da Internet) foi modificado do valor padrão de 1.000:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleThreshold

Se o Exchange Server Analyzer detectar que MsgHandleThreshold está presente e configurado com um valor alternativo, uma mensagem de configuração não-padrão será exibida.

O valor de MsgHandleThreshold especifica o número máximo de identificadores de arquivos que o IIS pode usar. Os manipuladores de arquivos são armazenados em cache para melhorar o desempenho porque, dessa forma, evitam que o servidor execute E/S (entrada/saída) e ciclos da CPU redundantes. Sempre que a pilha de transporte do SMTP em um computador com o Exchange Server recebe uma mensagem, ela é canalizada para fora do sistema de arquivos onde aguarda o roteamento para seu destino. Para gravar no sistema de arquivos, a pilha de transporte do SMTP obtém um manipulador de arquivo e passa a mensagem para esse manipulador. Cada manipulador de arquivo consome aproximadamente 2 KB (kilobytes) de memória de pool paginado. O número padrão de manipuladores de arquivos em cache do IIS é de 800 para cada 32 MB.

Antes do Exchange 2000 Server com Service Pack 2 (SP2), os servidores Exchange que sustentavam grandes filas de mensagens SMTP (por exemplo, uma média de 1.000 ou mais mensagens) já haviam encontrado restrições de desempenho devido a uma configuração padrão no serviço SMTP de um máximo de 1.000 identificadores de arquivo. Como o Exchange 2000 Server predefiniu um número máximo de 1.000 manipuladores de arquivos, o serviço SMTP pôde gravar apenas 1.000 mensagens simultâneas no sistema de arquivos.

Para melhorar o desempenho nos sistemas de grande porte, três entradas do Registro eram ajustadas com freqüência simultaneamente, para aumentar o número máximo de manipuladores de arquivos que podiam ser abertos pelo serviço SMTP (para permitir o processamento de mais mensagens) e para diminuir o número de manipuladores de arquivos abertos para o sistema de arquivos instaláveis, outro componente do Exchange (para evitar ficar sem memória quando a fila estivesse grande). Estão listados a seguir os valores do Registro que, por padrão, não existiam e, portanto, deveriam ser adicionados manualmente:

Local: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Valor: MsgHandleThreshold

Tipo: REG_DWORD

Local: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Valor: MsgHandleAsyncThreshold

Tipo: REG_DWORD

Local: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Valor: FileCacheMaxHandles

Tipo: REG_DWORD

As entradas MsgHandleThreshold e MsgHandleAsyncThreshold geralmente são ajustadas para o mesmo valor (um valor maior que 1.000) e o valor de FileCacheMaxHandles é normalmente reduzido de 800 para 600.

Se esse servidor Exchange estiver executando o Exchange 2000 Server, é uma prática recomendada que você faça a atualização para o service pack e pacote de distribuição mais recentes. Após a atualização para o código mais recente, é recomendável definir o MsgHandleThreshold com o valor padrão 1000.

O valor padrão de MsgHandleThreshold no Exchange Server 2003 é de 1000, de modo que essas configurações de substituição do Registro não são mais necessárias. Sendo assim, a menos que instruído de outra forma pelo Atendimento Microsoft, antes de atualizar quaisquer computadores do Exchange 2000 Server com essas configurações do Exchange Server 2003, exclua essas entradas do Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.

Para corrigir esse erro

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Exclua o valor MsgHandleThreshold.

  4. Feche o editor de Registro e reinicie o serviço Admin do IIS para que a alteração entre em vigor.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Os arquivos de recebimento SMTP estão sendo gravados em uma pasta compactada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Directory do WMI (Instrumentação de Gerenciamento do Windows) para determinar o valor da chave Compactado para a pasta de Retiradas SMTP. Se o Exchange Server Analyzer localizar o valor para Compressed definido como True, um aviso será exibido.

Quando chegam mensagens ao computador do Exchange através do serviço SMTP, os dados são gravados no disco rígido como um arquivo .eml. Por padrão, esses arquivos são armazenados na pasta :\Arquivos de Programas\Exchsrvr\Mailroot da <unidade> na mesma partição em que o Exchange está instalado. Se a pasta onde os dados de Retirada SMTP são armazenados está com a compactação de arquivos ligada, o desempenho do Exchange pode ser seriamente prejudicado. Portanto, não há suporte para compactação na pasta onde estão armazenados os dados de Retirada SMTP.

Se você recebeu este aviso, desligue a compactação na pasta onde são armazenados os dados de Retirada SMTP, ou mova os dados de Retirada SMTP para uma pasta que não seja compactada.

A Microsoft não dá suporte ao armazenamento de arquivos de dados do Exchange em um volume compactado. Quando você armazena seus arquivos de dados do Exchange em um volume compactado, a sobrecarga adicional afeta significativamente o desempenho do Exchange. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Para desativar a compactação de arquivos em uma pasta específica

  1. Clique com o botão direito na pasta em que deseja desativar a compactação de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Compactar o conteúdo para economizar espaço em disco e clique em OK.

Para obter mais informações sobre como mover a pasta PickUp, consulte o artigo da Base de Dados de Conhecimento da Microsoft, "Como alterar a localização da pasta SMTP Mailroot do Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).


Os arquivos de Recebimento SMTP estão sendo gravados em uma pasta criptografada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Directory do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Encrypted da pasta de Recebimento SMTP. Se o Exchange Server Analyzer perceber que o valor para Criptografado está definido como Verdadeiro, um aviso será exibido.

Quando chegam mensagens ao computador do Exchange através do serviço SMTP, os dados são gravados no disco rígido como um arquivo .eml. Por padrão, esses arquivos são armazenados na pasta :\Arquivos de Programas\Exchsrvr\Mailroot da <unidade> na mesma partição em que o Exchange está instalado. Se a pasta onde estão armazenados os dados de Recebimento SMTP tiver a criptografia de arquivos ativada, o desempenho do Exchange poderá ser gravemente reduzido. Portanto, não há suporte para criptografia da pasta onde são armazenados dados de Recebimento SMTP.

Se você receber esse aviso, desative a criptografia da pasta onde os dados de Recebimento SMTP estão armazenados ou mova-os para uma pasta não criptografada.

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em um volume criptografado com EFS (Sistema de Criptografia de Arquivos). Quando você armazena seus arquivos de dados do Exchange em um volume criptografado, a sobrecarga afeta significativamente o desempenho do Exchange. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

  • .chk

Para ajudar a proteger seus arquivos de dados do Exchange, é recomendável que você impeça o acesso não autorizado ao computador do Exchange e que você use o formato de mensagem S/MIME para criptografar dados de mensagens.

Para resolver esse erro, desative a criptografia da pasta de Recebimento ou mova-a para um local onde a criptografia não esteja habilitada.

Para desativar a criptografia de arquivos em uma determinada pasta

  1. Clique com o botão direito na pasta em que deseja desativar a criptografia de arquivos e clique em Propriedades.

  2. Na guia Geral, clique em Avançado.

  3. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Criptografar o conteúdo para proteger dados e clique em OK.

Para obter mais informações sobre como mover a pasta PickUp, consulte o artigo 822933 da Base de Dados de Conhecimento da Microsoft, "Como alterar a localização da pasta SMTP Mailroot do Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Para obter mais informações sobre arquivos de dados do Exchange Server e EFS, consulte o artigo 834638 da Base de Dados de Conhecimento, "Informações sobre o armazenamento de arquivos de dados em um volume criptografado no Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Para obter informações sobre como proteger mensagens no Exchange Server 2003, consulte Guia de Segurança de Mensagens do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=47574).


Os arquivos de retirada SMTP estão sendo gravados em uma partição não-NTFS
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows® ) Win32_Directory para determinar o valor da chave FSName do Diretório de Recebimento de SMTP do Exchange. Se o Analisador do Exchange Server determinar que o valor da chave FSName não é igual a NTFS, será exibido um aviso.

A Microsoft não oferece suporte ao armazenamento de arquivos de dados do Exchange em volumes não-NTFS. Os arquivos de dados do Exchange são os seguintes:

  • .edb

  • .stm

  • .log

  • .dat

  • .eml

Ao ver esse aviso, você deve mover o Diretório de Recebimento de SMTP para uma pasta na unidade de sistema do arquivo NTFS. Como alternativa, se a unidade na qual o Diretório de Recebimento está armazenado estiver formatada como uma unidade FAT, você poderá usar a ferramenta de linha de comando convert.exe para converter a unidade em NTFS.

Para obter mais informações sobre como mover a pasta PickUp, consulte o artigo 822933 da Base de Dados de Conhecimento da Microsoft, "Como alterar a localização da pasta SMTP Mailroot do Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Como alternativa, se a unidade na qual os arquivos estão armazenados estiver formatada como uma unidade FAT, você poderá usar a ferramenta de linha de comando convert.exe para converter a unidade em NTFS. Para obter informações sobre o uso da ferramenta de linha de comando convert.exe para converter uma partição FAT em uma partição NTFS, consulte o artigo 214579 da Base de Dados de Conhecimento, "Como usar o convert.exe para converter uma partição para o sistema de arquivos NTFS" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Alteração de Porta SMTP
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-11

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte propriedade na metabase do IIS (Serviços de Informações da Internet) para determinar se o seu valor corresponde ao valor padrão de 25:

LM/SmtpSvc/<Instância do servidor virtual SMTP>/SMTPPORT

Se o Exchange Server Analyzer verificar que o valor para a propriedade SMTPPORT não é 25, será exibido um aviso.

A propriedade SMTPPORT representa a porta TCP em que esse servidor SMTP escuta as conexões de entrada. Servidores virtuais SMTP podem ser configurados para ouvir em uma ou mais portas TCP. Por padrão, todos os servidores virtuais SMTP estão configurados para ouvir na porta TCP 25, a porta SMTP padrão. Se a porta de escuta do SMTP tiver sido modificada em relação ao padrão e não incluir mais a porta TCP 25 em sua lista de portas de escuta, essa modificação pode interromper o fluxo de mensagens.

É aceitável alterar a porta de escuta do SMTP, desde que o restante da infra-estrutura de mensagens interna também seja modificado de acordo. No entanto, normalmente, portas alternativas não podem ser usadas para servidores virtuais SMTP que aceitem mensagens diretamente da Internet, já que os servidores SMTP na Internet enviam mensagens através da porta 25.

Observação:
O Exchange Server Analyzer examina o valor do servidor virtual do protocolo SMTP do Exchange. Esse servidor virtual do protocolo SMTP não é necessariamente o servidor SMTP que recebe mensagens diretamente da Internet. Existem alguns produtos antivírus e anti-spam projetados para receber mensagens SMTP da Internet na porta 25 e redirecioná-las para um servidor virtual SMTP do Exchange em outra porta. Nessa situação, um servidor virtual SMTP do Exchange que escute em algum lugar que não a porta 25 é uma configuração aceitável.
Para exibir ou modificar a porta de escuta do servidor virtual SMTP

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  2. Clique com o botão direito em um servidor virtual SMTP, por exemplo, Servidor Virtual SMTP Padrão, e clique em Propriedades.

  3. Selecione a guia Geral e clique em Avançado.

  4. Uma lista de portas e endereços IP será exibida.

    • Para alterar a porta existente, selecione o endereço IP e clique em Editar. Altere o campo da porta TCP para 25.

    • Para adicionar a porta 25 como uma porta de escuta adicional, clique em Adicionar e adicione a nova combinação endereço IP/porta. Se você estiver usando filtragem por destinatário, remetente ou conexão, certifique-se de marcar as caixas de seleção apropriadas.

  5. Clique em OK para salvar as alterações e clique em OK novamente para sair da caixa de diálogo Avançado. Clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 266686, "XCON: How to Configure a SMTP Virtual Server Part 1" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, "XCON: How to Configure a SMTP Virtual Server Part 2" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


A pasta de fila SMTP contém uma grande quantidade de arquivos
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer consulta a metabase do IIS (Serviços de Informações da Internet) quanto ao valor do atributo QueueDirectory de cada instância de servidor virtual SMTP.

Em seguida, o Exchange Server Analyzer conta o número de arquivos contidos na pasta de fila especificada de cada servidor virtual SMTP.

Se o Exchange Server Analyzer achar que existem 50.000 arquivos ou mais na pasta de fila de um servidor virtual SMTP, o Exchange Server Analyzer exibirá um aviso.

Se o Exchange Server Analyzer achar que existem 90.000 arquivos ou mais na pasta de fila de um servidor virtual SMTP, o Exchange Server Analyzer exibirá um erro.

Esse aviso ou erro significa que há um acúmulo de mensagens que a instância do servidor virtual SMTP deve processar. O aviso ou erro indica um problema significativo de desempenho ou uma interrupção no servidor, pois o servidor não pode mais entregar a mensagem de entrada a tempo. As seguintes condições podem causar esse atraso:

  • O serviço de diretório Active Directory® não está sendo consultado rapidamente.

  • As mensagens não estão sendo liberadas rapidamente para entrega local ou SMTP.

Para resolver esse problema:

  • Reveja a legitimidade das mensagens na pasta de fila para verificar se o servidor não está sob carga anormal, devido a um UCE (email comercial não solicitado), ou spam, ou um ataque de vírus.

  • Verifique se o serviço SMTP está habilitado e em execução.

Para verificar se o serviço SMTP está iniciado

  1. Abra o snap-in de Serviços do MMC (Console de Gerenciamento Microsoft).

  2. No painel da direita, role para baixo até o serviço SMTP e clique nele duas vezes. Isso exibirá a caixa de diálogo Propriedades do protocolo SMTP.

  3. Verifique se o valor no menu suspenso Tipo de inicialização está definido como Automático.

  4. Clique em Iniciar para iniciar o serviço Atendedor do Sistema.

  5. Clique em OK para salvar as alterações e fechar a caixa de diálogo Propriedades do protocolo SMTP.

  6. Feche o snap-in Serviços.

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 da Base de Dados de Conhecimento Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400" (em inglês) http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 da Base de Dados de Conhecimento Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


A pasta de filas e a pasta de recebimentos SMTP são idênticas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para verificar se o diretório no qual as mensagens são retiradas não é o mesmo diretório para o qual as mensagens são enfileiradas para um servidor virtual SMTP específico. Se o Analisador do Exchange Server detectar que o atributo do Diretório de fila, que é msExchSmtpQueueDirectory e o atributo para o Diretório de recebimento, que é msExchSmtpPickupDirectory, são iguais, exibirá um erro.

Esse erro é um erro crítico. Se os atributos msExchSmtpQueueDirectory e msExchSmtpPickupDirectory estiverem definidos para o mesmo diretório, serão entregues mensagens duplicadas. Você pode atualizar esses atributos por meio do Active Directory Service Interfaces (ADSI) Edit.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP (ldp.exe) ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.
Para atualizar os atributos de msExchSmtpPickupDirectory ou msExchSmtpQueueDirectory usando o ADSI Edit

  1. Inicie a ferramenta ADSI Edit nas Ferramentas de Suporte do Windows® 2000 ou nas Ferramentas de Suporte do Windows Server 2003.

  2. Expanda os seguintes nós:

    • Contêiner de Configuração

    • Configuração

    • Serviços

    • Microsoft Exchange

    • Nome_da_Organização

    • Diretivas de Destinatário

    • Nome_do_Grupo_Administrativo

    • Servidores

    • Nome_do_Servidor

    • Protocolos

    • SMTP

  3. No painel de detalhes, clique com o botão direito em CN=1 (em que 1 é o servidor virtual SMTP padrão) e clique em Propriedades.

  4. Na lista Selecione que propriedades exibir, clique em Ambas.

  5. Atualize o atributo de msExchSmtpPickupDirectory para que ele não tenha mais conflito com msExchSmtpQueueDirectory e clique em Configurar após ter concluído.

  6. Clique em OK, clique em Aplicar e feche o ADSI Edit.

  7. Espere pelo menos 15 minutos para replicação.


A fila SMTP está na mesma unidade da partição do sistema
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para determinar o valor configurado para o atributo msExchSmtpQueueDirectory.

A ferramenta Analisador do Microsoft® Exchange Server consulta também a classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para determinar o valor da chave Iniciado para o serviço SMTP. Um valor Falso indica que o serviço não está sendo executado. Um valor Verdadeiro indica que o serviço está sendo executado. Além disso, o Analisador do Exchange Server consulta a classe WMI Win32_OperatingSystem para determinar o valor da chave WindowsDirectory. O valor dessa chave indica o local da unidade do sistema Windows.

Se o Analisador do Exchange Server detectar que o atributo msExchSmtpQueueDirectory está configurado com um caminho que inclui a mesma unidade da unidade do sistema, que o serviço SMTP está em execução e o Exchange não está em execução no Microsoft Windows Small Business Server, um aviso será exibido.

O atributo msExchSmtpQueueDirectory representa o caminho para a pasta de filas SMTP, também conhecida como a pasta Mailroot. Quando chegam mensagens ao servidor Exchange por meio do serviço SMTP, os dados são gravados no disco rígido como um arquivo .eml. Por padrão, esses arquivos são armazenados na pasta <unidade>:\Arquivos de Programas\Exchsrvr\Mailroot na mesma partição em que o Exchange está instalado.

Em algumas situações, como quando você configura um servidor bridgehead, é possível aumentar o desempenho do servidor Exchange se você mover o diretório SMTP Mailroot para uma partição ou disco rígido diferente. Como uma prática recomendada, a pasta SMTP Mailroot não deve estar na mesma unidade da unidade do sistema Windows. Em vez disso, ela deve estar em um disco rápido ou um subsistema de disco rápido para obter um desempenho ideal.

Embora a pasta Mailroot possa ser movida no Gerenciador do Sistema Exchange em um servidor virtual SMTP do Exchange Server 2003, movê-la em um servidor virtual SMTP do Exchange 2000 Server requer o uso de um editor do Active Directory de nível baixo, como o Active Directory Service Interfaces (ADSI) Edit.

Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP (ldp.exe) ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para corrigir esse erro no Exchange Server 2003

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e clique em Parar.

  4. Clique novamente com o botão direito no servidor virtual SMTP e clique em Propriedades.

  5. Clique na guia Mensagens.

  6. No campo Diretório de filas, especifique o caminho completo da pasta Mailroot apropriada. Você pode clicar em Procurar para procurar o computador local para o caminho.

  7. Clique em OK para salvar as alterações.

  8. Clique com o botão direito no servidor virtual SMTP e clique em Iniciar. O novo local será usado imediatamente.

Para corrigir esse erro no Exchange 2000 Server

  1. Pare todos os serviços do Exchange Server e do IIS no computador do Exchange 2000 Server cuja pasta Mailroot do servidor virtual SMTP você deseja modificar.

  2. Modifique o valor do servidor virtual SMTP afetado para msExchSmtpQueueDirectory para que ele seja configurado com o caminho apropriado.

  3. Espere o Active Directory replicar essa alteração para os servidores de catálogo globais usados por esse servidor Exchange.

  4. Inicie o serviço Atendedor do Sistema Microsoft Exchange.

  5. No computador do Exchange Server, verifique a presença de três instâncias de ID de Evento 1005 no log de eventos do Aplicativo que tem uma Origem de Evento igual a MSExchangeMU e a Categoria igual a Geral.

  6. Reinicie o computador do Exchange Server para que as alterações entrem em vigor.

Para obter mais informações sobre os dois procedimentos descritos, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 822933, "Como alterar o local da pasta Mailroot do SMTP do Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933)

  • 318230, "XCON: Como alterar o local do diretório Mailroot do SMTP do Exchange Server 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230)

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os artigos da Base de Dados de Conhecimento:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


O valor do Registro ResetMessageStatus do SMTP não é padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se as configurações padrão de enfileiramento do SMTP foram alteradas:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

O Exchange Server Analyzer exibe um erro se existirem as seguintes condições:

  • A chave ResetMessageStatus não está definida como 0 (zero).

  • O serviço de Cluster não está executando no Exchange Server.

Quando a chave do Registro ResetMessageStatus está definida como 1, todas as mensagens atualmente na fila passam por todas as filas internas de processamento novamente quando o Exchange Server é reiniciado. Por exemplo, todas as mensagens que estão na fila atualmente passarão novamente pelo categorizador quando o Exchange Server for reiniciado. Portanto, a chave ResetMessageStatus deve ser definida como 1 apenas para solucionar problemas de instalação de SMTP, como documentado no artigo 279616 da Base de Dados de Conhecimento Microsoft, "XCON: Adicionar uma chave do Registro para categorizar novamente mensagens " (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=279616). Se você não estiver solucionando problemas de instalação de SMTP, exclua essa chave do Registro.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para excluir a chave do Registro ResetMessageStatus.

  1. Abra um editor de Registro, como o Regedit.exe ou o Regedt32.exe.

  2. Navegue para: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. No painel da direita, localize e exclua o valor de ResetMessageStatus .

  4. Feche o editor de Registro.

Antes de editar o Registro e para obter informações sobre como editá-lo, consulte o artigo 256986 da Base de Dados de Conhecimento da Microsoft, "Descrição do Registro do Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Para obter mais informações sobre o enfileiramento do SMTP do Exchange, consulte a seguinte entrada no Blog da Equipe do Microsoft Exchange, "Explaining the Mysterious SMTP Advanced Queuing Engine" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=48585).


O valor do Registro ResetRoutesRetryMinutes de SMTP não é padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se as configurações padrão de enfileiramento do SMTP foram alteradas:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se o Exchange Server Analyzer perceber que a chave ResetRoutesRetryMinutes foi definida, o Exchange Server Analyzer exibirá uma mensagem não padrão.

É recomendável que os valores de enfileiramento padrão só sejam modificados após uma consideração completa. Os padrões foram selecionados atentamente para obter o desempenho ideal na maioria dos ambientes. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento do enfileiramento no Exchange Server.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre o enfileiramento do SMTP do Exchange, consulte a seguinte entrada no Blog da Equipe do Microsoft Exchange, "Explaining the Mysterious SMTP Advanced Queuing Engine" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=48585).


O valor do Registro RoutingRetryMinutes do SMTP é não padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se as configurações padrão de enfileiramento do SMTP foram alteradas:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se o Exchange Server Analyzer perceber que a chave RoutingRetryMinutes foi definida, o Exchange Server Analyzer exibirá uma mensagem não padrão.

É recomendável que os valores de enfileiramento padrão só sejam modificados após uma consideração completa. Os padrões foram selecionados atentamente para obter o desempenho ideal na maioria dos ambientes. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento do enfileiramento no Exchange Server.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre o enfileiramento do SMTP do Exchange, consulte a seguinte entrada no Blog da Equipe do Microsoft Exchange, "Explaining the Mysterious SMTP Advanced Queuing Engine" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=48585).


O valor do Registro SecondsPerDSNPass do SMTP não é padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada do Registro para determinar a configuração do valor SecondsPerDSNPass:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se perceber que a chave SecondsPerDSNPass está presente, mas não está definida como 10, o Exchange Server Analyzer exibirá uma mensagem de configuração não padrão.

Essa configuração é usada para otimizar as notificações de status de entrega. Além disso, ela especifica quantos segundos levará cada processamento de notificação de status de entrega. Assim que esse limite for ultrapassado, a geração de notificações de status de entrega será interrompida e reiniciada posteriormente. É recomendável que os valores padrão só sejam modificados depois que todos os aspectos tenham sido levados em consideração. Só modifique essa configuração específica após consultar os Serviços de Suporte Microsoft. Os padrões foram selecionados atentamente para obter o desempenho ideal na maioria dos ambientes. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento do enfileiramento no Exchange Server.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.


O servidor SMTP tem autenticação NTLM desabilitada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-11-10

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o bit do protocolo de autenticação NTLM (também conhecido como Autenticação Integrada do Windows) no atributo msExchAuthenticationFlags está configurado. Se o Exchange Server Analyzer determinar que o bit não está configurado e que o Exchange não está sendo executado no Microsoft Windows® Small Business Server, um aviso será exibido.

O atributo msExchAuthenticationFlags indica qual tipo de autenticação um servidor virtual do protocolo aceita. Esse atributo usa uma máscara de três bits.

Bit | Método de Autenticação
0 | Anônimo
1 | Básica
2 | NTLM (Autenticação Integrada do Windows)

Se o bit que controla a autenticação NTLM não estiver definido, o servidor virtual SMTP não permitirá a autenticação NTLM. Isso pode causar problemas de autenticação entre computadores do Exchange Server.

Para corrigir esse aviso

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, expanda Protocolos e SMTP.

  3. Clique com o botão direito no servidor virtual SMTP do Exchange e clique em Propriedades.

  4. Clique na guia Acesso, clique em Autenticação e marque a caixa de seleção Autenticação Integrada do Windows.

  5. Clique em OK e em OK novamente.

  6. Feche o Gerenciador do Sistema Exchange.

Para obter mais informações sobre métodos de autenticação para SMTP, consulte o Guia de Roteamento e Transporte do Exchange Server 2003 (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579), e consulte o artigo 319267 da Base de Dados de Conhecimento da Microsoft, "COMO: Entrega de Mensagens do Cliente SSMTP no Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267).


O valor do Registro SubmissionRetryMinutes do SMTP é diferente do padrão
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a seguinte entrada de Registro para determinar se as configurações padrão de enfileiramento do SMTP foram alteradas:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se o Exchange Server Analyzer perceber que a chave SubmissionRetryMinutes foi definida, o Exchange Server Analyzer exibirá uma mensagem não padrão.

É recomendável que os valores de enfileiramento padrão só sejam modificados após uma consideração completa. Os padrões foram selecionados atentamente para obter o desempenho ideal na maioria dos ambientes. Uma prática muito recomendada é tratar a causa raiz do problema, em vez de modificar o comportamento do enfileiramento no Exchange.

O Analisador do Exchange Server informa que essa configuração é somente para fins informativos. Nenhuma ação é necessária.

Para obter mais informações sobre o enfileiramento do SMTP do Exchange, consulte a seguinte entrada no Blog da Equipe do Microsoft Exchange, "Explaining the Mysterious SMTP Advanced Queuing Engine" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=48585).


O servidor virtual SMTP tem um limite de tamanho de mensagens maior do que o limite de tamanho de mensagens global
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Analisador do Microsoft® Exchange Server consulta o serviço de diretório do Active Directory® para comparar os limites do tamanho das mensagens de entrada do servidor virtual SMTP com os limites do tamanho da mensagem global de entrada.

O atributo do Active Directory que representa o limite do tamanho da mensagem do servidor virtual SMTP para mensagens de entrada e de saída é msExchSmtpMaxMessageSize. Esse valor é um atributo do objeto do servidor virtual SMTP no Active Directory, que é encontrado em:

CN= <Número do Servidor Virtual>, CN=SMTP, CN=Protocols, CN= <ServerName> , CN=Servidores, CN= <AdministrativeGroupName> , CN=Grupos Administrativos, CN= <OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration, DC= <DomainName>, DC=com

O atributo do Active Directory que representa o limite do tamanho das mensagens de entrada global é delivContLength. Esse valor é um atributo do objeto de entrega de mensagem das configurações globais da organização no Active Directory, que é encontrado em:

CN=Message Delivery, CN=Global Settings, CN= <OrganizationName> CN=Microsoft Exchange, CN=Services, CN=Configuration, DC= <DomainName>, DC=com

Se o Analisador do Exchange Server detectar que o valor de msExchSmtpMaxMessageSize é maior que o valor de delivContLength, um aviso será exibido.

Se algum servidor virtual SMTP tiver um limite de tamanho de mensagens maior do que o limite de tamanho de mensagens globais, isso pode fazer com que seja aceita a entrada de mensagens muito grandes e, subseqüentemente, que elas não sejam entregues. Para resolver esse problema, configure o servidor SMTP virtual com um tamanho máximo das mensagens igual ou menor ao limite de tamanho das mensagens de entrada.

Observação:
Se você definir um limite de tamanho de mensagem muito baixo, isso poderá impedir a replicação do catálogo de endereços offline entre computadores do Exchange Server. Para obter mais informações sobre esse problema, consulte o artigo 326154 da Base de Dados de Conhecimento da Microsoft, "XADM: O OAB não será replicado se você definir uma restrição de tamanho de mensagem no nível de transporte" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154).

Para corrigir esse aviso

  1. No Gerenciador do Sistema do Exchange, expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  2. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e selecione Propriedades.

  3. Selecione a guia Mensagens.

  4. Edite o valor do campo Limitar o tamanho da mensagem em (KB) para que ele seja igual ou menor que o limite de tamanho da mensagem global.

  5. Clique em OK para salvar as alterações e fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)

Para obter mais informações sobre como visualizar e editar as configurações no âmbito da organização, consulte o artigo 821881 da Base de Dados de Conhecimento da Microsoft, "Como modificar as configurações globais no Gerenciador do Sistema Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

Para obter mais informações sobre os limites de tamanho de mensagem global, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 298572, "Uma mensagem de email maior que o limite de tamanho de mensagens de saída ou que o limite de tamanho de mensagens de entrada não são entregues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298572)

  • 322679, "Definir limites de tamanho para mensagens" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)

  • 824111, "Alterações e atualizações das configurações de segurança que são apresentadas no Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824111)


Esse servidor virtual SMTP está configurado para executar pesquisas reversas de DNS em mensagens de entrada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-24

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o valor configurado para o atributo msExchSmtpPerformReverseDnsLookup foi modificado do valor padrão False. Por padrão, o atributo msExchSmtpPerformReverseDnsLookup é configurado para não executar pesquisas reversas de DNS para mensagens de entrada. Se o Exchange Server Analyzer verificar que esse atributo está definido como True, será exibido um aviso.

A opção Executar pesquisa reversa de DNS para mensagens de entrada não tem a mesma função de impedir o recebimento de mensagens de spam. Quando esta opção é usada, o Exchange Server executa uma consulta de DNS para resolver o endereço IP de origem das mensagens de entrada para um nome de host. Em seguida, o nome do host é anexado aos cabeçalhos das mensagens de email.

Com esse recurso habilitado, talvez você tenha diminuição do desempenho devido a registros de DNS configurados incorretamente ou a conexões intermintentes com a Internet. Portanto, talvez você prefira desabilitar essa opção quando a entrega de emails da Internet for mais lenta do que o esperado.

Para habilitar ou desabilitar pesquisas reversas de DNS em mensagens SMTP de entrada

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e clique em Propriedades.

  4. Clique na guia Entrega e clique em Avançado.

    • Para habilitar pesquisas reversas de DNS, marque a caixa de seleção Executar pesquisa reversa de DNS nas mensagens de entrada.

    • Para desabilitar pesquisas reversas de DNS, desmarque a caixa de seleção Executar pesquisa reversa de DNS nas mensagens de entrada.

  5. Clique em OK para salvar a alteração e clique em OK para sair da caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre o recurso de pesquisa reversa de DNS no Exchange, consulte o artigo 297412 da Base de Dados de Conhecimento da Microsoft, "The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)


Versão SP1 do Intelligent Message Filter está habilitada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Analisador do Microsoft® Exchange Server lê a entrada de Registro a seguir para determinar se o Microsoft Exchange Intelligent Message Filter está instalado e habilitado no servidor:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

O Exchange Server Analyzerr lê o valor de ContentFilterBindings na chave do Registro ContentFilter para determinar se o Intelligent Message Filter está instalado e habilitado no servidor.

Em seguida, o Analisador do Exchange Server consulta a classe CIM_Datafile do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se a versão de MSExchange.UceContentFilter.dll do Intelligent Message Filter do Exchange Server 2003 Service Pack 1 (SP1) está no seguinte caminho no Exchange Server:

<caminho para arquivos binários do servidor do Exchange>\MSCFv1\MSExchange.UceContentFilter.dll

Observação:
Nesse caminho, <caminho para arquivos binários do servidor Exchange> refere-se ao local da pasta bin.

Se a versão do Intelligent Message Filter do Exchange Server 2003 SP1 estiver instalada e habilitada no servidor, o Exchange Server Analyzer exibirá um aviso.

Este aviso indica que já existe uma versão mais recente do Intelligent Message Filter disponível. É recomendável que você instale a versão mais recente do Intelligent Message Filter. Se você estiver solucionando problemas de fluxo de mensagens que abrangem esse servidor específico, talvez você deseje desabilitar temporariamente o Intelligent Message Filter para determinar se esse recurso está bloqueando incorretamente mensagens legítimas.

Para desabilitar o Intelligent Message Filter

  1. Clique em Iniciar, aponte para Todos os Programas, aponte para Microsoft Exchange e clique em Gerenciador do Sistema.

  2. No Gerenciador do Sistema Exchange, expanda Servidores, Nome do servidor, Protocolos, SMTP, clique com o botão direito em Intelligent Message Filter e clique em Propriedades.

  3. Na guia Geral, em Aplicar o Intelligent Message Filter aos seguintes endereços IP de servidores virtuais, desmarque a caixa de seleção ao lado de cada servidor virtual SMTP no qual você deseje desabilitar o Intelligent Message Filter.

    Caixa de diálogo Propriedades do Intelligent Message Filter

Para obter mais informações, consulte o site do Exchange Intelligent Message Filter (http://go.microsoft.com/fwlink/?LinkId=21607).


Versão SP2 do Intelligent Message Filter habilitada
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-04

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se a propriedade msExchServerBindingsFiltering de um objeto do servidor virtual SMTP indica que o Intelligent Message Filter está habilitado para uma instância do servidor virtual SMTP.

O Exchange Server Analyzer também consulta o Active Directory para determinar se o msExchUceEnabled está habilitado no nível de Configurações Globais.

O Analisador do Exchange Server exibirá um aviso, se as seguintes condições forem verdadeiras:

  • O Intelligent Message Filter está habilitado para uma instância de servidor virtual SMTP.

  • O Intelligent Message está habilitado no nível de Configurações globais.

Esse aviso indica que a versão do Exchange Server 2003 Service Pack 2 (SP2) do Intelligent Message Filter está efetivamente habilitada. Ter a versão SP2 do Intelligent Message Filter habilitada geralmente não representa um problema, exceto quando estiver solucionando problemas de fluxo de mensagens envolvendo esse servidor específico. Se esse for o caso, talvez você deseje verificar a configuração do filtro ou desabilitar temporariamente o Intelligent Message Filter para determinar se ele está bloqueando incorretamente mensagens legítimas.

Para desabilitar o Intelligent Message Filter

  1. Clique em Iniciar, aponte para Todos os Programas, aponte para Microsoft Exchange e clique em Gerenciador do Sistema.

  2. No Gerenciador do Sistema do Exchange, expanda Servidores, Nome do servidor, Protocolos e SMTP.

  3. Em Propriedades do Servidor Virtual SMTP, na guia Geral, clique em Avançado.

  4. Selecione o endereço IP para o qual deseja desabilitar o Intelligent Message Filter e clique em Editar.

  5. Em Identificação, desmarque Aplicar Intelligent Message Filter.

  6. Se você tiver vários servidores virtuais, repita as Etapas 3 a 6 para cada servidor virtual para o qual deseje desabilitar o Intelligent Message Filter.

Para obter mais informações, consulte o site do Exchange Intelligent Message Filter (http://go.microsoft.com/fwlink/?LinkId=21607).


Servidor gateway especificado não usado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-09

A ferramenta Microsoft® Exchange Server Analyzer envia uma mensagem de teste do servidor Exchange para uma conta externa definida pelo usuário e, em seguida, verifica os logs de controle de mensagens do servidor para determinar se foi detectado algum problema na entrega da mensagem de teste.

Como parte dessa verificação, o Exchange Server Analyzer verifica se o servidor gateway do Exchange usado para rotear a mensagem para o destinatário externo é o mesmo especificado pelo usuário na página Inserir Informações do Servidor e do Usuário, da etapa Nome do Servidor e Credenciais.

Se detectar que a mensagem foi roteada com êxito fora da organização do Exchange mas não usou o servidor gateway especificado, o Exchange Server Analyzer exibirá um erro.

Este aviso indica que pode haver um problema na topologia de roteamento do Exchange e que estão presentes servidores gateway de saída desconhecidos.

Podem ocorrer problemas de roteamento se as entradas de Host Inteligente forem definidas no nível de servidor virtual e não no nível de conector. É uma prática recomendada que todas as entradas do Host Inteligente sejam definidas no conector SMTP e não no servidor virtual SMTP.

Para resolver este aviso, use as seguintes etapas:

  • Examine a configuração do servidor virtual SMTP (Simple Mail Transfer Protocol) para ter certeza de que não existem entradas de Host Inteligente definidas.

  • Examine na configuração dos servidores bridgehead locais se os espaço de endereçamento e custos estão corretos nos conectores.

Para exibir e configurar as definições do host inteligente

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Servidores, expanda um servidor Exchange, Protocolos e SMTP.

  3. Clique com o botão direito em um servidor virtual SMTP (por exemplo, Servidor Virtual SMTP Padrão) e selecione Propriedades.

  4. Selecione a guia Entrega e clique em Avançado.

  5. Desmarque todas as entradas de Host Inteligente.

  6. Clique em OK para salvar as alterações e clique em OK para fechar a caixa de diálogo Propriedades do servidor virtual SMTP.

Para obter mais informações sobre como configurar conectores SMTP, consulte o artigo 822941 da Base de Dados de Conhecimento Microsoft, "Como usar conectores SMTP para conectar grupos de roteamento no Exchange 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822941).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Guia de Transporte e Roteamento do Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Artigo 823489 do Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489) (em inglês).


Remetente especificado em servidor diferente
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-08-10

A Ferramenta Microsoft® Exchange Server consulta o valor do atributo proxyAddress do serviço de diretório do Active Directory® de todos os objetos do usuário para detectar se existe uma correspondência para o endereço SMTP (Simple Mail Transfer Protocol) do remetente local especificado pelo usuário.

Se for detectada uma correspondência com o proxyAddress de um objeto do usuário, o Exchange Server Analyzer procurará no Active Directory o valor do atributo msExchHomeServerName do objeto do usuário para saber se esse valor coincide com o nome do Exchange Server especificado pelo usuário.

Ao detectar que o valor do atributo msExchHomeServerName do remetente especificado pelo usuário não coincide com o nome do Exchange Server informado pelo usuário, o Exchange Server Analyzer exibe um aviso.

Esse aviso indica que foi informado um nome incorreto do Exchange Server ou que o problema no fluxo de mensagens afeta um servidor diferente do especificado pelo usuário.

Para resolver esse problema, certifique-se de inserir o nome correto do Exchange Server.

Para exibir as caixas de correio do usuário no servidor especificado

  1. Inicie o Gerenciador do Sistema do Exchange:

    Clique em Iniciar, aponte para Programas, Microsoft Exchange e clique em Gerenciador do Sistema.

  2. Em Gerenciador do Sistema do Exchange, navegue para e clique no seguinte contêiner:

    \Administrative Groups\ GroupName \Servers\ ServerName \ StorageGroupName \Mailbox Store\Mailboxes

  3. Verifique se a caixa de correio do usuário especificada é exibida no servidor do Exchange especificado.


Os servidores de destino não puderam ser identificados
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-07-06

A Ferramenta Microsoft® Exchange Server Analyzer tenta identificar e construir uma lista de FQDN (Nome de Domínio Totalmente Qualificado), endereços IP e nomes de domínio de servidores remotos aos quais mensagens em uma fila de entrega remota são destinadas.

A lista de FQDNs, endereços IP e nomes de domínio de servidores remotos é construída da seguinte forma:

  • A propriedade msExchSmtpFullyQualifiedDomainName do objeto do serviço de diretório Active Directory® do servidor virtual do protocolo SMTP é consultada.

    Observação:
    A propriedade msExchSmtpFullyQualifiedDomainName, por sua vez, é lida a partir da propriedade msExchTargetBridgeheadServersDN de um objeto de diretório de conector de grupo de roteamento quando é consultada em relação a servidores bridgehead de destino designados
  • A propriedade msExchSmtpSmartHost do objeto do conector SMTP do Active Directory é consultada em relação ao host inteligente designado para um conector SMTP.

  • A propriedade LinkName da classe ExchangeLink do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) é consultada em relação a conexões diretas com servidores remotos.

Se o Exchange Server Analyzer determinar que a tentativa para construir essa lista não resultou em nenhuma entrada, ele exibirá um erro.

Esse erro indica:

  • Podem haver problemas de conexão do Active Directory ou de rede intermitente que estão causando problemas de fluxo de mensagens.

  • A conta que executa o Exchange Server Analyzer pode não ter permissões suficientes para consultar as informações.

Para corrigir esse erro

  1. Verifique se o computador do Exchange Server foi iniciado e está conectado à rede.

  2. Verifique se você tem conectividade de rede para um controlador de domínio do Active Directory.

  3. Especifique um controlador de domínio do Active Directory no Exchange Server Analyzer.

  4. Use o comando PING para verificar se o computador do Exchange Server está acessível.

  5. Se houver um firewall, verifique se as portas RPC estão bloqueadas.

  6. Examine as permissões da conta na qual o Exchange Server Analyzer está sendo executado. A conta na qual o Exchange Server Analyzer está sendo executado deve ter permissões de Administrador local em cada computador do Exchange Server que ele verifica.

Para obter mais informações sobre problemas de conectividade de rede, consulte o artigo 325487 da Base de Dados de Conhecimento da Microsoft , "Como solucionar problemas de conectividade de rede" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Para obter mais informações sobre problemas de conectividade do Exchange Server Analyzer, consulte "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=56285).

Para obter mais informações sobre requisitos de portas, consulte o artigo 832017 da Base de Dados de Conhecimento da Microsoft, "Visão geral de serviço e requisitos de porta de rede para o sistema do Windows Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


TarpitTime foi implementado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-02-21

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a seguinte entrada de Registro para determinar se o recurso tar pit da filtragem por destinatário foi definido:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\TarpitTime

Se o Exchange Server Analyzer detectar que o valor de TarpitTime é maior do que 0 (zero), ele exibirá uma mensagem de configuração não padrão.

Tar pitting é a prática de diminuir a velocidade ou atrasar conexões ilegítimas intencionalmente para reduzir a taxa na qual spams automatizados podem ser enviados ou um ataque de colheita de dicionário pode ser realizado.

O recurso tar pit, que está disponível no Microsoft Windows Server™ 2003 Service Pack 1 (SP1), pode ser adicionado para funcionar com a filtragem por destinatário, conforme descrito no artigo 842851 da Base de Dados de Conhecimento Microsoft, "Recurso tar pit do SMTP para Microsoft Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851). Especificamente, o recurso tar pit estende a utilidade da filtragem de destinatário quando a caixa de seleção Filtrar destinatários que não estiverem no diretório estiver marcada na guia Filtragem por Destinatário em Configurações Globais.

O recurso tar pit é implementado configurando-se a subchave de Registro TarpitTime. A subchave de Registro TarpitTime supõe um valor decimal. O valor decimal traduz quantos segundos a sessão SMTP aguarda para responder a um remetente quando um destinatário não existe na organização do Exchange Server de destino.

A funcionalidade tar pit dificulta muito a ação de spammers que enviam mensagens não solicitadas para automatizar um ataque de colheita de diretório. Um ataque de colheita de diretório é uma tentativa de recuperar uma lista de endereços de email sabidamente válida de uma organização particular.

O protocolo SMTP reconhece destinatários aceitáveis durante uma sessão SMTP, retornando "2.1.5 Destinatário OK". No caso de um email ser enviado a um destinatário desconhecido, o protocolo SMTP retornará um erro "5.x.x". Por isso, um spammer pode usar um programa automatizado que usa nomes comuns ou termos de dicionário para construir endereços de email para um determinado domínio. O programa pode, então, reunir todos os endereços de email que retornarem "2.1.5 Destinatário OK" e descartar todos os que gerarem erros "5.x.x". O spammer pode, então, vender os endereços de email válidos ou usá-los como destinatários para mensagens não solicitadas.

Se a caixa de seleção Filtrar destinatários que não estiverem no Diretório estiver marcada, mas a subchave de Registro TarpitTime não estiver definida, o Exchange Server retornará imediatamente um erro "5.x.x", durante a sessão SMTP, para o remetente quando um destinatário não existir no serviço de diretório do Active Directory® de destino.

Como alternativa, se a subchave de Registro TarpitTime estiver definida e a caixa de seleção Filtrar destinatários que não estiverem no diretório estiver marcada, o SMTP esperará antes de retornar um erro "5.x.x". O valor decimal fornecido para a subchave de Registro TarpitTime é o número de segundos que o SMTP aguarda antes de retornar o erro. Essa pausa na sessão SMTP dificulta muito a automatização de um ataque de colheita de diretório.

Como mencionado anteriormente, o Exchange Server Analyzer exibirá uma mensagem de configuração não padrão se a subchave de Registro TarpitTime estiver definida. Essa mensagem tem uma finalidade apenas informativa.

Importante:
Este artigo contém informações sobre como editar o Registro. Antes de editar o Registro, verifique se entendeu como restaurá-lo, caso ocorra algum problema. Para obter informações sobre como restaurar o Registro, exiba o tópico da Ajuda "Restaurar o Registro" no Regedit.exe ou no Regedt32.exe.
Para exibir ou alterar a subchave de Registro TarpitTime

  1. Clique em Iniciar, clique em Executar, digite regedit na caixa Abrir e clique em OK.

  2. Localize e clique na seguinte subchave de Registro:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Parameters\TarpitTime

  3. A caixa Dados do valor contém um número decimal. Esse valor representa o número de segundos que você deseja atrasar as respostas de verificação de endereços SMTP para cada endereço que não existir no Active Directory.

  4. Se você alterar o valor ou excluir a subchave de registro TarpitTime, deverá reiniciar o serviço SMTP.

Para obter mais informações, consulte o artigo 842851 da Base de Dados de Conhecimento da Microsoft, "Recurso tar pit do SMTP para o Microsoft Windows Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851).


Email de teste gerou a notificação de falha na entrega
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A ferramenta Microsoft® Exchange Server Analyzer Tool envia uma mensagem de teste do servidor Exchange para a conta Postmaster ou uma conta definida pelo usuário para o domínio SMTP e, em seguida, verifica os logs de controle de mensagens do servidor para determinar se foram encontrados problemas com a entrega da mensagem de teste.

Como parte dessa verificação, o Exchange Server Analyzer consulta a propriedade EntryType da classe Exchange_MessageTrackingEntry do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) com o namespace root\MicrosoftExchangeV2 para determinar o que ocorreu para acarretar na criação de entradas do log de controle de mensagens.

Se o Exchange Server Analyzer encontrar o valor 1030 para a propriedade EntryType, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que a mensagem de teste gerou uma notificação de falha na entrega e pode ocorrer um problema na configuração do protocolo SMTP do servidor. Uma notificação de falha na entrega deverá ser esperada se o destinatário de destino não existir, mas isso será um problema se a mensagem de teste tiver sido enviada a um destinatário legítimo.

Como uma etapa de solução de problemas, convém que você tente enviar outras mensagens para o mesmo destinatário e examinar as notificações de falha na entrega para determinar a causa.

Para obter mais informações sobre como solucionar problemas de notificações de falha na entrega, consulte "Solucionando problemas de mensagens de notificação de falha na entrega" no Guia de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579) (em inglês).


Email de teste enviado para o diretório de mensagens inválidas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-05-17

A Ferramenta Microsoft® Exchange Server Analyzer envia uma mensagem de teste a partir do servidor Exchange para a conta do Postmaster ou uma conta definida por usuário no domínio do protocolo SMTP e verifica os logs de controle de mensagens do servidor para determinar se ocorreu algum problema na entrega da mensagem de teste.

Como parte dessa verificação, o Analisador do Exchange Server consulta a propriedade EntryType da classe WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Exchange_MessageTrackingEntry no namespace root\MicrosoftExchangeV2 para determinar a causa da entrada de log de controle de mensagens.

Se o Exchange Server Analyzer encontrar o valor 1021 para a propriedade EntryType, o Exchange Server Analyzer exibirá um aviso.

Esse aviso indica que a mensagem de teste foi enviada para o diretório de Mensagens Inválidas do servidor Exchange e há um problema com a configuração SMTP do servidor.

Uma mensagem é inserida no diretório Mensagens Inválidas por um dos seguintes motivos:

  • Ela não pode ser entregue.

  • O número máximo de tentativas foi excedido.

  • Ela não pode ser retornada para o remetente como inacessível.

Para obter mais informações sobre como testar o fluxo de mensagens de saída, consulte o artigo 297700 da Base de Dados de Conhecimento da Microsoft, "Como testar o fluxo de mensagens de saída com um arquivo na pasta de retiradas" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297700).

Para obter mais informações sobre problemas do SMTP e de fluxo de mensagens, consulte "Solucionar problemas de fluxo de mensagens e SMTP" no Guia de Roteamento e Transporte do Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).


Colocação de Mensagem de Teste na Fila SMTP
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-07-06

A Ferramenta Microsoft® Exchange Server Analyzer envia uma mensagem de teste do servidor Exchange para a conta Postmaster ou uma conta definida pelo usuário para o domínio SMTP e, em seguida, verifica os logs de controle de mensagens do servidor para determinar se foi encontrado algum problema com a entrega da mensagem de teste.

Como parte dessa verificação, o Exchange Server Analyzer consulta a propriedade EntryType da classe Exchange_MessageTrackingEntry do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) no namespace root\MicrosoftExchangeV2 para determinar por que as entradas do log de controle de mensagens foram criadas.

A tabela a seguir lista os valores EntryType possíveis retornados.

Nome do Valor | Valor
Mensagem recebida através de X400 | 0
Relatório recebido | 2
Mensagem enviada | 4
Mensagem transferida externamente | 7
Relatório transferido externamente | 8
Mensagem entregue | 9
Relatório entregue | 10
Lista de distribuição expandida | 26
Mensagem redirecionada | 28
Mensagem reencaminhada | 29
Servidor rebaixado por MTA | 31
Relatório absorvido | 33
Relatório gerado | 34
Relatório impossível de ser roteado descartado | 43
Mensagem excluída pelo Administrador | 50
Sonda excluída pelo Administrador | 51
Relatório excluído pelo Administrador | 52
Mensagem entregue localmente | 1000
Mensagem transferida internamente por backbone | 1001
Mensagem transferida externamente por backbone | 1002
Mensagem transferida externamente por gateway | 1003
Mensagem transferida internamente por gateway | 1004
Relatório transferido internamente por gateway | 1005
Relatório transferido externamente por gateway | 1006
Relatório gerado | 1007
SMTP: Mensagem em fila de saída | 1010
SMTP: Mensagem transferida externamente | 1011
SMTP: Mensagem de entrada recebida | 1012
SMTP: Mensagem de entrada transferida | 1013
SMTP: Mensagem reencaminhada | 1014
SMTP: Relatório transferido internamente | 1015
SMTP: Relatório transferido externamente | 1016
SMTP: Relatório gerado | 1017
SMTP: Relatório absorvido | 1018
SMTP: Mensagem enviada para Fila Avançada | 1019
SMTP: Iniciada transferência externa de mensagem | 1020
SMTP: Mensagem enviada para o diretório de mensagens inválidas | 1021
SMTP: Falha na Fila Avançada | 1022
SMTP: Mensagem entregue localmente | 1023
SMTP: Mensagem enviada ao Categorizador | 1024
SMTP: Envio de Mensagem para Fila Avançada Iniciado | 1025
SMTP: Fila Avançada falhou ao entregar mensagem | 1026
Driver de Armazenamento SMTP: Mensagem enviada do Armazenamento | 1027
Driver de Armazenamento SMTP: Mensagem enviada localmente para Armazenamento | 1028
Driver de Armazenamento SMTP: Mensagem enviada para MTA | 1029
SMTP: Gerada a notificação de falha na entrega | 1030
SMTP: Mensagem transferida externamente | 1031

O Exchange Server Analyzer exibirá um erro se os valores EntryType retornados indicarem que as seguintes condições são verdadeiras:

  • O log de rastreamento da mensagem de teste pode ser verificado com êxito.

  • A mensagem de teste não realizou com êxito a transferência externa da fila.

  • Uma Notificação de Falha na Entrega não foi gerada para a mensagem de teste.

  • A mensagem de teste não foi transferida para o diretório de Mensagens Inválidas.

  • A mensagem de teste não está em fila para entrega remota.

  • A mensagem de teste não foi enviada com êxito para o armazenamento local.

  • A mensagem de teste não está agendada para repetir categorização.

  • A mensagem de teste não está agendada para repetir roteamento.

  • A mensagem de teste não está agendada para repetir entrega local.

Esse erro significa que a mensagem de teste está colocada em uma das filas SMTP e é necessária análise adicional para determinar o motivo de ela estar presa ali.

Para resolver esse erro, use o utilitário NSlookup para examinar possíveis problemas com a resolução de DNS (Sistema de Nome de Domínio). Para problemas de conexão e protocolo, como erros de Host inacessível, use o Telnet.exe para tentar conectar ao computador de destino. Para solucionar problemas de erros de protocolo, aumente o log de diagnóstico para o serviço MSExchangeTransport do componente SMTP e consulte os logs para verificar se há erros. Como alternativa, você pode usar a ferramenta Monitor de Rede (Netmon.exe) para obter informações sobre erros de conexão de rede. Para reproduzir o problema, force a fila a tentar novamente. Examine o log de eventos para obter possíveis erros associados ao serviço Armazenamento de Informações do Microsoft Exchange.

Para obter mais informações sobre como modificar configurações de log, consulte "How to Modify Logging Settings for MSExchangeTransport" na seção "Troubleshooting Mail Flow and SMTP" do Exchange Server Transport and Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Manual de Transporte e Roteamento do Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Artigo 823489 do Base de Dados de Conhecimento da Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Artigo 821877 do Base de Dados de Conhecimento da Microsoft, "Descrição de campos nas guias de propriedades de filas SMTP e X.400 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Artigo 264054 do Base de Dados de Conhecimento da Microsoft, "XCON: Compreendendo os estados das filas no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Existem mais de 900 conectores em um Grupo de Roteamento
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-01-17

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretórios do Active Directory® para determinar o número de conectores presentes em um determinado grupo de roteamento, incluindo conectores SMTP, conectores de grupos de roteamento, conectores X.400 e conectores EDK. Se o Exchange Server Analyzer localizar mais de 900 conectores em um único grupo de roteamento, um aviso será exibido.

É recomendável que você use um máximo de 900 instâncias de qualquer tipo de objeto exclusivo do Exchange. Isso ocorre porque o Active Directory usa 1.000 como o padrão de tamanho máximo de página que ele retorna para qualquer solicitação fornecida. Significa que se for feita uma solicitação LDAP (Lightweight Directory Access Protocol) para um objeto e existirem mais de 1.000 instâncias desse objeto no Active Directory, nenhum resultado será retornado porque o tamanho máximo de página foi excedido.

No caso do Exchange Server, vários processos solicitam instanciação de tipos de objeto específico. Por exemplo, o Gerenciador do Sistema do Exchange faz uma solicitação LDAP ao Active Directory para criar a exibição da lista de todos os conectores de um grupo de roteamento. Se houver mais de 1.000 conectores em um único grupo de roteamento, o Active Directory não retornará resultados de consulta. Quando isso ocorrer, um erro será exibido no Gerenciador do Sistema do Exchange.

Embora o valor máximo do tamanho de página do Active Directory possa ser aumentado, isso não é recomendado nem aceito para o Exchange Server. Comportamento estranho e falhas são evidentes em ambientes do Exchange em que o valor do tamanho máximo de página foi aumentado.

Embora a recomendação seja permanecer em 900 ou abaixo disso para qualquer tipo de objeto exclusivo do Exchange Server, há suporte para até 1.000 tipos de objetos.

Para corrigir esse aviso

  1. Consolide conectores ou crie mais grupos de roteamento e realize um balanceamento de carga entre os conectores existentes.

  2. Examine o Active Directory em busca de conectores órfãos e remova-os do Active Directory.

  3. Experimente consolidar os servidores Exchange em sua organização.

Para obter informações sobre conectores e estrutura de grupos de roteamento, consulte o Guia de transporte e roteamento do Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47579).

Para obter mais informações sobre como consolidar os servidores Exchange, consulte Consolidação do servidor usando o Exchange Server 2003 (em inglês) (http://go.microsoft.com/fwlink/?linkid=47586).


Há uma discrepância com a configuração do nome de domínio totalmente qualificado entre o Active Directory e a metabase
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2007-01-17

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a propriedade a seguir na metabase do Internet Information Services (IIS) para determinar se seu valor corresponde ao valor configurado para o atributo msExchSmtpFullyQualifiedDomainName no serviço de diretório do Active Directory®:

/LM/SmtpSvc/<SMTP virtual server instance>/FullyQualifiedDomainName

Se o Exchange Server Analyzer verificar que os valores dos dois atributos não coincidem, uma mensagem de aviso será exibida.

Se o valor na metabase do IIS não corresponder ao valor no Active Directory, ele poderá indicar um problema com a replicação do Active Directory ou um problema com o componente Directory-service-to-Metabase-replication (DS2MB) no Exchange.

A função do processo DS2MB é transferir informações de configuração do Active Directory para a metabase local. Essa configuração é armazenada na metabase local no lugar do Registro por razões de desempenho e escalabilidade. No Exchange 2000 Server e no Exchange Server 2003, todos os protocolos de Internet (SMTP, NNTP, POP3, IMAP4 e HTTP) são executados como componentes do IIS.

A cada 15 minutos, o processo DS2MB copia subárvores completas do Active Directory sem alterar a forma da subárvore. Essa é uma gravação unidirecional a partir do Active Directory para a metabase; a metabase nunca faz gravações no Active Directory.

A propriedade FullyQualifiedDomainName e o atributo msExchSmtpFullyQualifiedDomainName usam um nome de servidor padrão, que corresponde ao nome de domínio totalmente qualificado do servidor Exchange (por exemplo, server.domain.com). Se a propriedade FullyQualifiedDomainName e o atributo msExchSmtpFullyQualifiedDomainName não tiverem o mesmo valor de nome de domínio totalmente qualificado, isso significa que o Active Directory e a metabase do IIS não estão em sincronia. Se o problema for causado por uma falha no processo DS2MB, você pode fazer a correção seguindo o procedimento abaixo para a versão do Exchange Server que você está executando. Se o problema for causado por uma falha completa ou parcial da replicação do Active Directory, você pode usar o utilitário Active Directory Replication Monitor (ReplMon.exe) para verificar a integridade e o status da replicação do Active Directory. Você pode encontrar o ReplMon.exe nas Ferramentas de Suporte do Microsoft Windows® no CD-ROM do Windows Server™ 2003.

Para corrigir esse aviso no Exchange Server 2003

  1. Verifique a presença de entradas do log de eventos do aplicativo com fonte MSExchangeMU. Se o DS2MB falhar, ele registará em log um evento no Exchange Server 2003.

  2. Se você não perceber nenhuma falha do DS2MB, use ReplMon para diagnosticar a replicação do Active Directory. Preste bastante atenção nos servidores de catálogo global que estão sendo usados pelo seu servidor virtual SMTP.

  3. Se você não vir falhas do DS2MB, ou após ter eliminado ou resolvido quaisquer problemas com a replicação do Active Directory, reinicie o serviço Atendedor do Sistema do Exchange.

Para corrigir esse aviso no Exchange 2000 Server

  1. Use ReplMon para diagnosticar a replicação do Active Directory. Preste bastante atenção nos servidores de catálogo global que estão sendo usados pelo seu servidor virtual SMTP.

  2. Após ter eliminado ou resolvido quaisquer problemas com a replicação do Active Directory, reinicie o serviço Atendedor do Sistema do Exchange.

Para obter mais informações sobre o recurso de pesquisa reversa de DNS no Exchange, consulte o artigo 297412 da Base de Dados de Conhecimento da Microsoft, "A opção 'Executar pesquisa reversa de DNS para Mensagens de Entrada'' é para resolução de nome de host" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento: 266686, "XCON: Como Configurar um Servidor Virtual SMTP Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) e 268163, "XCON: Como Configurar um Servidor Virtual SMTP Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Para obter mais informações sobre a replicação do Active Directory, consulte o artigo 232072 da Base de Dados de Conhecimento, "Iniciando a Replicação Entre os Parceiros de Replicação Direta do Active Directory" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Para obter mais informações sobre o processo DS2MB, consulte o artigo 240105 da Base de Dados de Conhecimento, "XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Há uma discrepância com a configuração da contagem máxima de saltos entre o Active Directory e a metabase
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A Ferramenta Microsoft® Exchange Server Analyzer lê a propriedade a seguir na metabase do Internet Information Services (IIS) para determinar se seu valor corresponde ao valor configurado para o atributo msExchSmtpMaxHopCount no serviço de diretório do Active Directory®:

/LM/SmtpSvc/<SMTP virtual server instance>/HopCount

Se o Exchange Server Analyzer detectar que os valores não correspondem, um aviso será exibido.

Se o valor na metabase do IIS não corresponder ao valor no Active Directory, ele poderá indicar um problema com a replicação do Active Directory ou um problema com o componente Directory-service-to-Metabase-replication (DS2MB) no Exchange.

A função do processo DS2MB é transferir informações de configuração do Active Directory para a metabase local. Essa configuração é armazenada na metabase local no lugar do Registro por razões de desempenho e escalabilidade. No Exchange 2000 Server e no Exchange Server 2003, todos os protocolos de Internet (SMTP, NNTP, POP3, IMAP4 e HTTP) são executados como componentes do IIS.

A cada 15 minutos, o processo DS2MB copia subárvores completas do Active Directory sem alterar a forma da subárvore. Essa é uma gravação unidirecional a partir do Active Directory para a metabase; a metabase nunca faz gravações no Active Directory.

Em um servidor virtual SMTP Exchange 2000 Server, o número padrão de saltos é 15. Em um servidor virtual SMTP Exchange Server 2003, o número padrão de saltos é 30. Independentemente do valor configurado, se a propriedade HopCount e o atributo msExchSmtpMaxHopCount não coincidirem, isso significa que o Active Directory e a metabase do IIS não estão sincronizados. Se o problema for causado por uma falha no processo DS2MB, você pode fazer a correção seguindo o procedimento abaixo para a versão do Exchange Server que você está executando. Se o problema for causado por uma falha completa ou parcial da replicação do Active Directory, você pode usar o utilitário Active Directory Replication Monitor (ReplMon.exe) para verificar a integridade e o status da replicação do Active Directory. Você pode encontrar o ReplMon.exe nas Ferramentas de Suporte do Microsoft Windows® no CD-ROM do Windows Server™ 2003.

Para corrigir esse erro no Exchange Server 2003

  1. Verifique a presença de entradas do log de eventos do aplicativo com fonte MSExchangeMU. Se o DS2MB falhar, ele registará em log um evento no Exchange Server 2003.

  2. Se você não perceber nenhuma falha do DS2MB, use ReplMon para diagnosticar a replicação do Active Directory. Preste bastante atenção nos servidores de catálogo global que estão sendo usados pelo seu servidor virtual SMTP.

  3. Se você encontrar falhas do DS2MB ou depois de ter eliminado ou resolvido todos os problemas com a replicação do Active Directory, reinicie o serviço Atendedor do Sistema do Exchange.

Para corrigir esse erro no Exchange 2000 Server

  1. Use ReplMon para diagnosticar a replicação do Active Directory. Preste bastante atenção nos servidores de catálogo global que estão sendo usados pelo seu servidor virtual SMTP.

  2. Depois de ter eliminado ou resolvido todos os problemas com a replicação do Active Directory, reinicie o serviço Atendedor do Sistema do Exchange.

Para obter mais informações sobre o recurso pesquisa reversa de DNS no Exchange, consulte a Base de Dados de Conhecimento Microsoft artigo 297412, "A Opção 'Executar Pesquisa Reversa de DNS para Mensagens de Entrada' é para Resolução de Nome de Host" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)

Para obter mais informações sobre a replicação do Active Directory, consulte o artigo 232072 da Base de Dados de Conhecimento Microsoft, "Iniciando a replicação entre os parceiros de replicação direta do Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072) (em inglês).

Para obter mais informações sobre o processo DS2MB, consulte o artigo 240105 da Base de Dados de Conhecimento, "XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Há uma discrepância com a configuração de tamanho máximo de mensagem entre o Active Directory e a metabase
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a propriedade a seguir na metabase do Internet Information Services (IIS) para determinar se seu valor corresponde ao valor configurado para o atributo msExchSmtpMaxMessageSize no serviço de diretório do Active Directory®:

/LM/SmtpSvc/<instância do servidor virtual SMTP>/MaxMessageSize

Se o Exchange Server Analyzer detectar que os valores não correspondem, um aviso será exibido.

Se o valor na metabase do IIS não corresponder ao valor no Active Directory, ele poderá indicar um problema com a replicação do Active Directory ou um problema com o componente Directory-service-to-Metabase-replication (DS2MB) no Exchange.

A função do processo DS2MB é transferir informações de configuração do Active Directory para a metabase local. Essa configuração é armazenada na metabase local no lugar do Registro por razões de desempenho e escalabilidade. No Exchange 2000 Server e no Exchange Server 2003, todos os protocolos de Internet (SMTP, NNTP, POP3, IMAP4 e HTTP) são executados como componentes do IIS.

A cada 15 minutos, o processo DS2MB copia subárvores completas do Active Directory sem alterar a forma da subárvore. Essa é uma gravação unidirecional a partir do Active Directory para a metabase; a metabase nunca faz gravações no Active Directory.

Tanto a propriedade MaxMessageSize quanto o atributo msExchSmtpMaxMessageSize usam uma configuração padrão de 0, o que significa que não há um limite de tamanho de mensagem imposto. Se a propriedade MaxMessageSize e o atributo msExchSmtpMaxMessageSize não tiverem o mesmo valor, isso significa que o Active Directory e a metabase do IIS não estão em sincronia. Se o problema for causado por uma falha no processo DS2MB, você pode fazer a correção seguindo o procedimento abaixo para a versão do Exchange Server que você está executando. Se o problema for causado por uma falha completa ou parcial da replicação do Active Directory, você pode usar o utilitário Active Directory Replication Monitor (ReplMon.exe) para verificar a integridade e o status da replicação do Active Directory. Você pode encontrar o ReplMon.exe nas Ferramentas de Suporte do Microsoft Windows® no CD-ROM do Windows Server™ 2003.

Para corrigir esse erro no Exchange Server 2003

  1. Verifique a presença de entradas do log de eventos do aplicativo com fonte MSExchangeMU. Se o DS2MB falhar, ele registará em log um evento no Exchange Server 2003.

  2. Se você não perceber nenhuma falha do DS2MB, use ReplMon para diagnosticar a replicação do Active Directory. Preste bastante atenção nos servidores de catálogo global que estão sendo usados pelo seu servidor virtual SMTP.

  3. Se você encontrar falhas do DS2MB ou depois de ter eliminado ou resolvido todos os problemas com a replicação do Active Directory, reinicie o serviço Atendedor do Sistema do Exchange.

Para corrigir esse erro no Exchange 2000 Server

  1. Use ReplMon para diagnosticar a replicação do Active Directory. Preste bastante atenção nos servidores de catálogo global que estão sendo usados pelo seu servidor virtual SMTP.

  2. Depois de ter eliminado ou resolvido todos os problemas com a replicação do Active Directory, reinicie o serviço Atendedor do Sistema do Exchange.

Para obter mais informações sobre o recurso de pesquisa reversa de DNS no Exchange, consulte o artigo 297412 da Base de Dados de Conhecimento da Microsoft, "The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)

Para obter mais informações sobre a replicação do Active Directory, consulte o artigo 232072 da Base de Dados de Conhecimento, "Iniciando a Replicação Entre o Active Directory e os Parceiros de Replicação Direta" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Para obter mais informações sobre o processo DS2MB, consulte o artigo 240105 da Base de Dados de Conhecimento, "XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Há uma discrepância na configuração do tamanho máximo da sessão entre o Active Directory e a metabase
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta Microsoft® Exchange Server Analyzer Tool lê a propriedade /LM/SmtpSvc/<SMTP virtual server instance>/MaxSessionSize na metabase do IIS (Serviços de Informações da Internet) para determinar se seu valor corresponde ao valor configurado para o atributo msExchSmtpMaxSessionSize no serviço de diretório do Active Directory®:

Se o Exchange Server Analyzer perceber que os valores não correspondem, uma mensagem de aviso será exibida.

Se o valor na metabase do IIS não corresponder ao valor no Active Directory, ele poderá indicar um problema com a replicação do Active Directory ou um problema com o componente de replicação Directory-service-to-Metabase (DS2MB) no Exchange.

A função do processo DS2MB é transferir informações de configuração do Active Directory para a metabase local. Essa configuração é armazenada na metabase local no lugar do Registro por razões de desempenho e escalabilidade. No Exchange 2000 Server e no Exchange Server 2003, todos os protocolos de Internet (SMTP, NNTP, POP3, IMAP4 e HTTP) são executados como componentes do IIS.

A cada 15 minutos, o processo DS2MB copia subárvores completas do Active Directory sem alterar a forma da subárvore. Essa é uma gravação unidirecional a partir do Active Directory para a metabase; a metabase nunca faz gravações no Active Directory.

Tanto a propriedade MaxSessionSize quanto o atributo msExchSmtpMaxSessionSize usam uma configuração padrão 0, o que significa que não há um limite de tamanho de sessão imposto. Se a propriedade MaxSessionSize e o atributo msExchSmtpMaxSessionSize não tiverem o mesmo valor, isso significa que o Active Directory e a metabase do IIS não estão em sincronia. Se o problema for causado por uma falha no processo DS2MB, você pode fazer a correção seguindo o procedimento abaixo para a versão do Exchange Server que você está executando. Se o problema for causado por uma falha completa ou parcial da replicação do Active Directory, você pode usar o utilitário Active Directory Replication Monitor (ReplMon.exe) para verificar a integridade e o status da replicação do Active Directory. Você pode encontrar o ReplMon.exe nas Ferramentas de Suporte do Microsoft Windows® no CD-ROM do Windows Server™ 2003.

Para corrigir esse erro no Exchange Server 2003

  1. Verifique a presença de entradas do log de eventos do aplicativo com fonte MSExchangeMU. Se o DS2MB falhar, ele registará em log um evento no Exchange Server 2003.

  2. Se você não perceber nenhuma falha do DS2MB, use ReplMon para diagnosticar a replicação do Active Directory. Preste bastante atenção nos servidores de catálogo global que estão sendo usados pelo seu servidor virtual SMTP.

  3. Se você não vir falhas do DS2MB, ou após ter eliminado ou resolvido quaisquer problemas com a replicação do Active Directory, reinicie o serviço Atendedor do Sistema do Exchange.

Para corrigir esse erro no Exchange 2000 Server

  1. Use ReplMon para diagnosticar a replicação do Active Directory. Preste bastante atenção nos servidores de catálogo global que estão sendo usados pelo seu servidor virtual SMTP.

  2. Após ter eliminado ou resolvido quaisquer problemas com a replicação do Active Directory, reinicie o serviço Atendedor do Sistema do Exchange.

Para obter mais informações sobre o recurso de pesquisa reversa de DNS no Exchange, consulte o artigo 297412 da Base de Dados de Conhecimento da Microsoft, "The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Para obter mais informações sobre configurações de servidor virtual SMTP, consulte os seguintes artigos da Base de Dados de Conhecimento:

  • 266686, "XCON: Como configurar um servidor virtual SMTP - Parte 1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) (em inglês)

  • 268163, "XCON: Como configurar um servidor virtual SMTP - Parte 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163) (em inglês)

Para obter mais informações sobre a replicação do Active Directory, consulte o artigo 232072 da Base de Dados de Conhecimento, "Iniciando a Replicação Entre o Active Directory e os Parceiros de Replicação Direta" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Para obter mais informações sobre o processo DS2MB, consulte o artigo 240105 da Base de Dados de Conhecimento, "XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Um evento de aviso do gerenciador de conexões de transporte foi registrado em log nas últimas 24 horas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-07-07

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_NTLogEvent do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se um aviso de Evento 4006 foi registrado em log para o MSExchangeTransport nas últimas 24 horas.

Se descobrir que um aviso de evento 4006 foi registrado para MSExchangeTransport nas últimas 24 horas, o Exchange Server Analyzer exibirá um aviso.

Esse aviso geralmente indica que uma tentativa de envio de email para um servidor remoto falhou.

Um aviso Event 4006 do MSExchangeTransport pode ocorrer devido às seguinte condições:

  • A conexão foi perdida pelo host remoto.

  • O serviço SMTP remoto rejeitou a negociação AUTH.

  • O servidor que está tentando entregar a mensagem não pode acessar as informações de entrega de mensagem da mensagem.

  • Ocorreu um erro SMTP.

  • O servidor que está tentando entregar a mensagem não pode se conectar ao servidor remoto.

  • Um host inteligente que foi especificado nas propriedades do servidor virtual SMTP está inacessível por alguma razão.

Para obter mais informações sobre um aviso de evento do MSExchangeTransport, localize os detalhes do evento no Events and Errors Message Center (http://go.microsoft.com/fwlink/?LinkId=34258).

Para obter mais informações sobre problemas para retransmissão de email no Exchange Server, consulte o artigo 895853 da Base de Dados de Conhecimento Microsoft, "How to troubleshoot mail relay issues in Exchange Server 2003 and in Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853).

Para obter mais informações sobre problemas de fluxo e SMTP, consulte "Troubleshooting Mail Flow and SMTP" no Exchange Server and Transport Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkID=67875).


Um evento de aviso do gerenciador de conexões de transporte foi registrado nas últimas 24 horas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-07-07

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_NTLogEvent do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar se um aviso de Evento 4001 foi registrado em log para o MSExchangeTransport nas últimas 24 horas.

Se descobrir que um aviso de evento 4001 foi registrado para MSExchangeTransport nas últimas 24 horas, o Exchange Server Analyzer exibirá um aviso.

Esse aviso geralmente indica que uma tentativa de envio de email para um servidor remoto falhou.

Um aviso de evento 4001 para MSExchangeTransport pode ocorrer quando o serviço do protocolo SMTP do Exchange 2000 Server ou do Exchange Server 2003 apresenta um ou mais problemas de entrega de email. As causas possíveis para esses problemas incluem problemas com o sistema de nome de domínio (DNS), a configuração de IP ou a instalação de arquivos DLL incorretos.

Para obter mais informações sobre um aviso de evento 4001, consulte os detalhes do evento no Events and Errors Message Center (http://go.microsoft.com/fwlink/?LinkId=34258).

Para obter mais informações sobre problemas para retransmissão de email no Exchange Server, consulte o artigo 895853 da Base de Dados de Conhecimento Microsoft, "How to troubleshoot mail relay issues in Exchange Server 2003 and in Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853).

Para obter mais informações sobre problemas de fluxo e SMTP, consulte "Troubleshooting Mail Flow and SMTP" no Exchange Server and Transport Routing Guide (em inglês) (http://go.microsoft.com/fwlink/?LinkID=67875).


Arquivo coletor de eventos de transporte não encontrado
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-01-10

A ferramenta Analisador do Microsoft® Exchange Server consulta a metabase do Microsoft IIS (Servidor de Informações da Internet) para enumerar a lista de ligações do coletor de eventos de transporte do SMTP (Simple Mail Transport Protocol). O Exchange Server Analyzer tenta localizar várias ligações de eventos padrão, com base em uma lista pré-preenchida no Exchange Server Analyzer. Para cada ligação, o Analisador do Exchange Server verifica os detalhes do Registro do COM (Modelo de Objeto do Componente) no Registro da seção a seguir:

HKEY_CLASSES_ROOT\CLSID\

Os detalhes de registro COM contêm o caminho completo do arquivo .dll associado. O Exchange Server Analyzer usa o WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para localizar o arquivo .dll e exibir seu número de versão. Se o Exchange Server Analyzer não localizar o arquivo .dll, o Exchange Server Analyzer exibirá um aviso detalhando o nome do arquivo e o caminho do arquivo .dll ausente.

Se o Analisador do Exchange Server achar que uma ou mais ligações de eventos padrão estão ausentes, ele gerará um aviso.

Um evento de transporte do SMTP ocorre quando os dados da mensagem são transportados para dentro ou para fora do serviço SMTP. Todas as mensagens passam por eventos. Isso inclui mensagens de entrada ou saída X.400 e RPC. Um exemplo comum de um evento de transporte de entrada é a chegada de uma mensagem ao serviço SMTP pela rede ou no diretório de recebimento do SMTP. Quando esse evento de transporte ocorre, uma fonte desse evento notifica os coletores de eventos de transporte, cada um dos quais pode executar algum tipo de ação com base no conteúdo dos dados da mensagem. O sistema não executa nenhuma outra ação com os dados da mensagem depois que ele passa os dados da mensagem para o coletor, até que o coletor conclua sua ação e retorne a mensagem. O coletor tem controle exclusivo dos dados e do estado da mensagem enquanto executa essa ação.

Os arquivos .dll ausentes para registros COM do coletor de eventos de transporte podem causar problemas de fluxo de mensagens. Se o Exchange Server exibir sintomas de problemas de fluxo de mensagens, como fila de mensagens, verifique se os arquivos .dll identificados estão presentes e reinstale-os se for necessário.

Para resolver esse problema

  1. Use o Explorer para localizar manualmente o arquivo .dll identificado. Geralmente, esse arquivo estará localizado na pasta \Arquivos de Programas\Exchsrvr\Bin.

  2. É seguro ignorar o aviso gerado pelo Exchange Server Analyzer se as condições a seguir forem verdadeiras:

    • O arquivo .dll está presente na pasta listada.

    • O servidor não mostra sinais de problemas no fluxo de mensagens.

  3. Copie o arquivo .dll ausente da mídia de instalação original do Exchange Server se as seguintes condições forem verdadeiras:

    • O arquivo .dll não está presente na pasta listada pelo Exchange Server Analyzer.

    • O servidor mostra sinais de problema no fluxo de mensagens.

    Como alternativa, aplique novamente o service pack mais recente do Exchange.

  4. Execute novamente o Exchange Server Analyzer para verificar se o aviso não é mais exibido.


As alterações na versão do usuário das informações sobre o estado do link foram suprimidas
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2005-11-18

A ferramenta do Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar se o atributo heuristics foi configurado para suprimir alterações na versão do usuário das informações de estado do link. Por padrão, o atributo heuristics não é configurado. Se o Exchange Server Analyzer perceber que o atributo heuristics está definido como 2048, o Exchange Server Analyzer exibe uma mensagem de configuração não padrão.

As tabelas de estado do link são usadas para garantir um roteamento de mensagem eficiente e confiável. Elas contêm informações sobre a versão de cada grupo de roteamento em forma de números de versão do usuário e maior e menor números de versão. Alterações maiores de versão têm prioridade máxima, seguida pelas alterações menores e, finalmente, alterações nos números de versão do usuário.

As alterações de versão do usuário ocorrem quando há uma atualização no serviço de diretório de nível básico. Essas alterações mínimas incluem alterações no mestre do grupo de roteamento, quando serviços são iniciados ou parados em um servidor do Exchange, quando outro servidor é adicionado ao grupo de roteamento ou quando um servidor membro perde a conexão com o mestre do grupo de roteamento.

Uma atualização no serviço de diretório de nível básico pode ocorrer quando um administrador do Exchange Server altera algo no nível do grupo de roteamento. Por exemplo, uma alteração na versão do usuário ocorre quando um administrador altera o nome de um grupo de roteamento, adiciona um servidor ou remove um servidor. Porém, a causa principal de alterações na versão do usuário são os dados de WMI (Instrumentação de Gerenciamento do Microsoft Windows) que estão em cada servidor. Esses dados informam os serviços que estão em execução. Se você parar e iniciar um serviço, as alterações da versão do usuário na tabela de estados do link serão replicadas para todos computadores do Exchange Server na organização.

Atualizações freqüentes da versão do usuário podem gerar uma quantidade indesejada de tráfego de rede e podem ser removidas, obtendo um hotfix no Atendimento Microsoft e configurando o atributo heuristics com o valor 2048 (0x800 em hexadecimais).

Se as atualizações da versão do usuário não estiverem gerando tráfego excessivo, é recomendável não removê-las.

Para reverter para a configuração padrão

  1. Abra o ADSI (Active Directory Service Interfaces) Edit.

  2. No ADSI Edit, expanda Contêiner de Configuração, CN=Configuração, DC=DomainName, DC=com, CN=Serviços e CN=Microsoft Exchange.

  3. Clique com o botão direito em CN=OrganizationName e clique em Propriedades.

  4. Na caixa Selecionar uma propriedade para exibição, clique em Heurística.

  5. Na caixa Editar Atributo, limpe o valor 0x800.

  6. Clique em Definir e em OK.

  7. Fechar ADSI Edit.
Cuidado:
Se você modificar de maneira incorreta os atributos dos objetos do Active Directory por meio do recurso ADSI Edit, da ferramenta LDP (ldp.exe) ou de outro cliente da versão 3 do LDAP (Lightweight Directory Access Protocol), poderá causar problemas graves. Esses problemas podem exigir a reinstalação do Microsoft Windows Server™ 2003, do Exchange Server 2003 ou de ambos. Você é responsável pelas modificações efetuadas nos atributos de objetos do Active Directory.

Para obter mais informações sobre o estado do link e números de versões do usuário, consulte "Propagação do estado do link" no Guia de Referências Técnicas para o Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=49367) (página em inglês).


Usuário identificado como um destino comum
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-09-06

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta a classe Exchange_Queue do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar os valores dos seguintes atributos para as filas do Protocolo SMTP do servidor virtual SMTP.

LinkId | Indica o identificador para o link que contém a fila.
QueueId | Indica o identificador da fila.
QueueName | Indica o nome da fila.
VirtualMachine | Indica o nome da máquina virtual que contém a fila.
VirtualServerName | Indica o nome do servidor virtual em que a fila está.
MessageCount | Indica o número de mensagens na fila.

O Exchange Server Analyzer usa as informações obtidas acima para consultar a classe Exchange_QueuedSMTPMessage do WMI referente aos valores dos seguintes atributos das mensagens na fila:

Destinatários | Indica os destinatários da mensagem.
Recebida | Indica o carimbo de hora recebido para a mensagem.
MessageId | Indica o identificador da mensagem em fila.
StateRetry | Indica que a transmissão está sendo repetida para uma mensagem que não foi entregue com êxito.

Finalmente, usando os dados obtidos na consulta anterior, o Exchange Server Analyzer consultará o serviço de diretório do Active Directory® referente aos seguintes valores de cada objeto Destinatário a ser determinado se o destinatário for um usuário, um grupo de distribuição, uma pasta pública ou um armazenamento de pasta pública:

distinguishedName | Indica o nome distinto do objeto.
msExchHomeServerName | Indica o servidor em que o destinatário está hospedado.
homeMDB | Indica o armazenamento de caixa de correio do destinatário.

Se o Exchange Server Analyzer determinar que pelo menos 25% das mensagens presas na fila estão endereçadas, em qualquer um dos campos Para: ou Cc:, a um usuário específico, o Exchange Server Analyzer exibirá um aviso.

Se o Exchange Server Analyzer determinar que pelo menos 50% das mensagens presas na fila estão endereçadas, em qualquer um dos campos Para: ou Cc:, a um usuário específico, o Exchange Server Analyzer exibirá um erro.

Esse aviso ou erro significa que o usuário identificado é um destino comum para mensagens que estão presas em uma fila SMTP.

Para determinar esse problema, o usuário deve ser investigado quanto a problemas de configuração ou outras anomalias que poderão fazer com que as mensagens sejam colocadas em fila para eles.

As áreas a serem investigadas incluem:

  • Assegurar que os atributos do objeto de usuário estejam definidos corretamente e contenham os valores corretos no Active Directory.

  • Rever se as permissões do Active Directory do objeto de usuários possuem as configurações corretas.

  • Procurar possíveis ataques de vírus ou Email Comercial Não Solicitado (UCE ou SPAM) contra o usuário.

  • Determinar se o usuário pertence a um grupo de distribuição que tenha restrições de entrega definidas incorretamente.

  • Se o objeto de usuário for um uso especial, ou seja, um destinatário de Registro em Diário designado, reveja as configurações do serviço ou os componentes aos quais o objeto de usuário está relacionado para obter a configuração correta.

Para obter mais informações sobre como solucionar problemas em filas SMTP, consulte os seguintes recursos do Exchange:

  • "Solucionando problemas de fluxo de mensagens e SMTP" no Guia de Transporte e Roteamento do Exchange Server (em inglês) (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Artigo 823489 da Base de Dados de Conhecimento Microsoft, "Como usar o Visualizador de Filas para solucionar problemas de fluxo de mensagens no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

Para obter mais informações sobre o efeito da restrição de grupo de distribuição no fluxo de mensagens do Exchange Server, consulte os artigos a seguir na Base de Dados de Conhecimento Microsoft:

  • 895407, "No Exchange Server 2003, a entrega de mensagens para caixas de correio locais e para caixas de correio externas é mais lenta do que o esperado depois que você configura as restrições de entrega com base nos grupos de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 329171, "XADM: A entrega de mensagens ficará lenta se os destinatários estiverem configurados com restrições de entrega baseadas em associação de grupos" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 839949 "Solucionando problemas de transporte de mensagens e grupos de distribuição no Exchange 2000 Server e no Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 "A entrega de mensagens fica lenta após a configuração de restrições de entrega baseadas em uma lista de distribuição" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


Problema de SMTP desconhecido
Microsoft Exchange Server Analyzer - Artigos > Transporte >

Última modificação do tópico: 2006-10-06

A ferramenta Microsoft® Exchange Server Analyzer consulta a classe Win32_Service do WMI (Instrumentação de Gerenciamento do Microsoft Windows®) para determinar o valor da chave Started para o serviço de protocolo SMTP. Um valor False indica que o serviço SMTP não está sendo executado. Um valor True indica que o serviço SMTP está sendo executado.

O Exchange Server Analyzer também consulta a metabase do IIS (Serviços de Informações de Internet) para determinar o valor da propriedade ServerState para a instância do servidor virtual SMTP.

A propriedade ServerStateapresenta o estado atual da instância do servidor. Os códigos de estado e os estados correspondentes são os seguintes:

Código de estado | Estado
1 | Iniciando
2 | Iniciado
3 | Parando
4 | Parado
5 | Pausando
6 | Em pausa
7 | Continuando

O Exchange Server Analyzer exibirá um aviso, se as seguintes condições forem verdadeiras:

  • O serviço SMTP está sendo executado.

  • Todas as instâncias de servidor virtual SMTP no servidor são iniciadas.

Esse aviso indica que, embora o serviço SMTP e as instâncias de servidor virtual SMTP pareçam ser funcionais, um problema que exige investigação adicional impede as portas SMTP de responderem corretamente.

Esse problema pode ser provocado por:

  • O serviço SMTP está em um estado suspenso.

  • Um firewall ou aplicativo antivírus está bloqueando a comunicação com as portas SMTP.

Para resolver esse problema:

  • Reinicie o serviço SMTP.

  • Reveja a configuração de todos os firewalls ou aplicativos antivírus com relação às portas SMTP.

  • Reveja a orientação de erro específica e os links fornecidos pelo Exchange Server Analyzer.

Para iniciar, parar ou pausar o serviço SMTP

  1. Clique em Iniciar, aponte para Ferramentas Administrativas e clique em Serviços do Componente.

  2. Na árvore do console, clique em Serviços (Local).

  3. No painel de resultados, clique com o botão direito em Protocolo SMTP e clique em Iniciar, Parar ou Pausar.


Preparação do Exchange Server 2007
Microsoft Exchange Server Analyzer - Artigos >

Última modificação do tópico: 2006-07-18

Os artigos dessa seção fornecem detalhes sobre o que a Ferramenta Analisador do Microsoft® Exchange Server está avaliando com relação a preparação do Exchange Server 2007. Além disso, esses artigos descrevem ações que podem ser tomadas para resolver erros, avisos e configurações não-padrão relacionados com pré-requisitos encontrados pelo Analisador do Exchange Server.


A herança da ACL (lista de controle de acesso) está bloqueada
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-06-19

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois as permissões necessárias não puderam ser propagadas.

A instalação do Exchange exige que a herança para permissões esteja habilitada nos objetos da árvore de Pasta Pública.

Para resolver esse problema, verifique se a configuração "Permitir que permissões se propaguem para este objeto e para os objetos filhos" está habilitada e execute novamente a instalação do Exchange Server 2007.

Para habilitar novamente a herança da árvore de Pasta Pública

  1. Abra o Gerenciador do Sistema do Exchange Server 2003.

  2. Clique com o botão direito no armazenamento de Pasta Pública e, em seguida, clique em Propriedades.

  3. Clique na guia Segurança e marque a caixa de seleção Permitir que permissões herdadas se propaguem para este objeto.


A extensão de esquema do Active Directory exige que o arquivo Ldifde.exe esteja instalado
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-06-19

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois o computador local não pode atualizar o esquema do Active Directory.

A instalação do Microsoft Exchange exige que o arquivo Ldifde.exe esteja instalado no computador local para fazer as extensões necessárias no esquema do Active Directory.

Para resolver esse problema, instale o Ldifde.exe no computador local e execute novamente a instalação do Exchange Server 2007 ou inicie a instalação a partir de um controlador de domínio.

Observação:
Quando o esquema do Active Directory tiver sido estendido, as funções de servidor do Exchange 2007 poderão ser instaladas no computador local sem a instalação do ldifde.exe.
Para instalar o Ldifde.exe no computador local

  1. Clique em Iniciar, Executar e, no campo Abrir, execute 'ServerManagerCmd -i RSAT-ADDS'.


O caminho de instalação do ADAM existe
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-26

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois houve falha na tentativa de instalar o ADAM (Modo de Aplicativo do Active Directory).

Há uma instalação mais antiga do ADAM no local padrão. A instalação do Exchange não pode executar uma nova instalação do ADAM em uma estrutura existente de diretório do ADAM.

Para resolver esse problema, remova a pasta existente do ADAM e reexecute a instalação do Exchange.


ADAM não instalado no computador local
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-22

A instalação do Microsoft Exchange Server 2007 não pode continuar porque o ADAM (Active Directory Application Mode) não está instalado neste computador.

ADAM é um serviço de diretório LDAP (Lightweight Directory Access Protocol) elaborado especificamente para ser usado com aplicativos habilitados para diretório. O ADAM armazena e replica apenas as informações específicas do aplicativo e não requer implantação em um controlador de domínio nem depende do serviço de diretório do Active Directory. O ADAM não fornece autenticação ou autorização de sistema operacional de rede.

No Exchange 2007, a função de servidor Transporte do Exchange usa o ADAM para armazenar informações de configuração. Quando o ADAM está sincronizado com o Active Directory, também é possível usá-lo para fazer pesquisa de destinatários para segurança de mensagens.

A instalação do Microsoft Exchange exige que o serviço do ADAM esteja instalado no computador local para que ela possa continuar.

Para resolver esse problema, instale o ADAM Service Pack 1 (SP1) a partir do "Active Directory Application Mode (ADAM)" (http://go.microsoft.com/fwlink/?linkid=71063) e execute a instalação novamente.


O ADAM não está instalado no computador local (Longhorn)
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-08-13

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois o ADAM (Active Directory Application Mode) não está instalado neste computador baseado em Windows Server 2008.

ADAM é um serviço de diretório LDAP (Lightweight Directory Access Protocol) elaborado especificamente para ser usado com aplicativos habilitados para diretório. O ADAM armazena e replica apenas as informações específicas do aplicativo e não requer implantação em um controlador de domínio nem depende do serviço de diretório do Active Directory. O ADAM não fornece autenticação ou autorização de sistema operacional de rede.

No Exchange 2007, a função de servidor Transporte do Exchange usa o ADAM para armazenar informações de configuração. Quando o ADAM está sincronizado com o Active Directory, também é possível usá-lo para fazer pesquisa de destinatários para segurança de mensagens.

A instalação do Microsoft Exchange exige que o serviço do ADAM esteja instalado no computador local para que ela possa continuar.

Para resolver esse problema, instale o ADAM no computador local que está executando o sistema operacional Windows Server 2008 e execute a instalação novamente.

Para instalar o ADAM no sistema operacional Windows Server 2008

  1. Clique em Iniciar, selecione Executar e digite o seguinte comando:

  2. cmd.exe /c start /w pkgmgr.exe /iu:"DirectoryServices-ADAM"

  3. Execute a instalação do Exchange 2007 novamente.


Aviso da Pesquisa do Analyzer
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-08-09

Este tópico pretende solucionar um problema específico acarretado pela ferramenta Exchange Server Analyzer. Você deve aplicá-lo apenas a sistemas em que a ferramenta Exchange Server Analyzer Tool tenha sido executada e estejam passando por esse problema específico.

A ferramenta Exchange Server Analyzer Tool, disponível como download gratuito, coleta remotamente dados de configuração de cada servidor da topologia e analisa automaticamente os dados. O relatório resultante detalha problemas importantes de configuração, problemas potenciais e configurações de produto diferentes do padrão. Ao seguir estas recomendações, você poderá atingir melhor desempenho, escalabilidade, confiabilidade e tempo de operação.

Para obter mais informações sobre a ferramenta ou para baixar as últimas versões, consulte "Microsoft Exchange Analyzers" em http://go.microsoft.com/fwlink/?linkid=34707.


Aviso de compatibilidade com o padrão de 32 bits
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-08-13

O programa de instalação do Microsoft Exchange Server 2007 exibiu esse aviso porque você está instalando a versão de 32 bits do Microsoft Exchange.

O Exchange 2007 está disponível em duas versões de plataforma: uma versão de plataforma (a versão de 64 bits) é para ambientes de produção ativos e a outra versão de plataforma (a versão de 32 bits) é para ambientes de não produção (como laboratórios, instalações de treinamento, demonstrações e ambientes de avaliação). Apenas a versão de 64 bits pode ser adquirida, pois não é possível executar servidores Exchange 2007 de 32 bits em produção.

Existem duas exceções com relação ao uso de produção e não produção da plataforma de 32 bits, pois a Microsoft permite o uso mínimo aceito da versão de 32 bits em ambientes de produção. Especificamente:

  • Você pode usar a versão de 32 bits das Ferramentas de Gerenciamento do Exchange em produção para administrar servidores Exchange 2007 a partir do Windows Server 2003 ou Windows XP. Nesse momento, você não pode usar a versão de 32 bits nem a de 64 bits no Windows Vista nem no Windows Server 2008. Espera-se que o suporte para Windows Vista e Windows Server 2008 seja fornecido no Service Pack 1 para Exchange 2007.

  • Você pode usar a versão de 32 bits da Instalação em produção para estender o esquema do serviço de diretório do Active Directory. Para obter as etapas detalhadas para preparar o Active Directory para Exchange 2007, consulte Como preparar o Active Directory e os domínios.

Nenhum outro uso da versão de 32 bits do Exchange 2007 em ambientes de produção é aceito.

Para baixar a versão de 32 bits das Ferramentas de Gerenciamento do Exchange, consulte "Ferramentas de Gerenciamento do Microsoft Exchange Server 2007 (32 bits)" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=82335). Para obter mais informações sobre as versões da plataforma Exchange 2007, consulte "Exchange Server 2007: Plataformas, edições e versões" (http://go.microsoft.com/fwlink/?LinkId=88051) na documentação do produto Exchange 2007.


Atualizações de fuso horário de 2007 para sistemas operacionais Microsoft Windows precisam ser instaladas
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-02-20

A instalação do Microsoft Exchange Server 2007 não pode continuar porque é necessária uma atualização para corrigir as configurações de fuso horário deste computador.

O programa de instalação do Exchange 2007 exige que a atualização de fuso horário para sistemas operacionais Windows mencionada no artigo 931836 da Base de Dados de Conhecimento Microsoft seja instalada.

Para resolver esse problema, instale a atualização mencionada no artigo 931836 da Base de Dados de Conhecimento Microsoft, "Atualização cumulativa de fuso horário de fevereiro de 2007 para sistemas operacionais Microsoft Windows" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=931836); em seguida, execute a instalação do Exchange 2007 novamente.


O Active Directory não existe ou não pode ser contatado
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-04-18

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois ele não consegue contatar um site de serviço de diretório válido do Active Directory.

A Instalação do Microsoft Exchange exige que o servidor usado para instalação do Microsoft Exchange consiga localizar o contexto de atribuição de nome de configuração no Active Directory.

Para resolver esse problema, verifique se a conta do usuário que está executando a Instalação do Microsoft Exchange está conectada ao Active Directory e execute novamente a instalação. Se isso não resolver o problema, nos tópicos abaixo, siga as orientações sobre como utilizar as ferramentas de suporte NETDIAG.Exe e DCDIAG.Exe e diagnosticar o problema.

Para obter mais informações sobre como solucionar problemas do Active Directory e sobre a configuração do Microsoft Exchange, consulte o seguinte:

  • "Solucionando problemas de operações do Active Directory" no Windows Server 2003: Operações (http://go.microsoft.com/fwlink/?LinkId=68099).

  • "Ferramentas para solucionar problemas do Active Directory" no Guia de Operações do Active Directory (http://go.microsoft.com/fwlink/?LinkId=68100).

  • "Contexto de atribuição de nomes de configuração" em "Trabalhando com as permissões do Active Directory no Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=47592).

  • "Trabalhando com as permissões do Active Directory no Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=47592).

  • "Visão geral de Netdiag" (em inglês) (http://go.microsoft.com/fwlink/?LinkID=69481).

  • "Visão geral de Dcdiag" (em inglês) (http://go.microsoft.com/fwlink/?LinkID=68936).


O domínio do Active Directory está em modo misto
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-08-10

A instalação do Microsoft Exchange Server 2007 não pode continuar, porque um domínio existente do Active Directory não está definido com o modo nativo ou superior do Microsoft Windows®°2000 Server.

A instalação do Exchange 2007 criará Grupos de Segurança Universal que só podem existir em domínios do modo nativo ou superior do Windows 2000 Server.

Para resolver esse problema, siga estas etapas para aumentar o nível funcional do domínio para, no mínimo, o nível nativo do Windows 2000 Server, e execute novamente a instalação do Exchange 2007.

Para aumentar o nível funcional do domínio

  1. Abra os Domínios e Confianças do Active Directory.

  2. Na árvore do console, clique com o botão direito no domínio cuja funcionalidade deve ser aumentada, e clique em Aumentar nível funcional do domínio.

  3. Em Selecione um nível funcional de domínio disponível, use um dos seguintes procedimentos:

    • Para aumentar o nível funcional do domínio para o nativo do Windows 2000 Server, clique em Windows 2000 nativo e, em seguida, em Aumentar.

    • Para aumentar o nível funcional do domínio para o Windows Server® 2003, clique em Windows Server 2003 e, em seguida, em Aumentar.
Cuidado:

Se o sistema tiver ou terá controladores de domínio executando o Windows NT® 4.0 e versões anteriores, não aumente o nível funcional do domínio para o Windows 2000 Server nativo. Após definir o nível funcional do domínio como Windows 2000 Server nativo, esse nível não poderá mais retornar ao modo misto do Windows 2000 Server.

Se o sistema tiver ou terá controladores de domínio executando o Windows NT 4.0 e versões anteriores ou o Windows 2000 Server, não aumente o nível funcional do domínio para o Windows Server 2003. Após definir o nível funcional do domínio como Windows Server 2003, esse nível não poderá mais retornar ao modo misto do Windows 2000 Server ou ao Windows 2000 Server nativo.


Preparação do Active Directory necessária
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-26

A instalação do Microsoft Exchange Server 2007 não pode continuar porque a tentativa de preparação de domínio falhou.

A instalação do Exchange exige que o serviço de diretório do Active Directory seja modificado para o Exchange Server 2007 antes que os domínios no Active Directory sejam preparados.

Para resolver esse problema, prepare o Active Directory com o comando Setup /PrepareAD e depois prepare os domínios.

Para obter mais informações sobre como executar o processo PrepareAD, consulte "Como preparar o Active Directory e os domínios" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=78453).


Porta ADAM já em uso
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

A instalação do Microsoft® Exchange Server 2007 não pode continuar, pois sua tentativa de instalar a função de Servidor de Gateway detectou que as portas atribuídas à sincronização do ADAM (Modo de Aplicativo do Active Directory®) já estão sendo usadas.

ADAM é um serviço de diretório LDAP (Lightweight Directory Access Protocol) elaborado especificamente para ser usado com aplicativos habilitados para diretório. O ADAM armazena e replica apenas as informações específicas do aplicativo e não requer implantação em um controlador de domínio nem depende do serviço do Active Directory. O ADAM não fornece autenticação ou autorização de sistema operacional de rede.

No Exchange 2007, o servidor de gateway usa o ADAM para armazenar informações de configuração. Quando o ADAM está sincronizado com o serviço de diretório do Active Directory, também é possível usá-lo para fazer pesquisa de destinatários para segurança de mensagens.

A instalação do Microsoft Exchange exige que portas específicas estejam disponíveis (não estejam sendo usadas) para serem atribuídas ao processo de sincronização do ADAM quando a função de Servidor de Gateway for instalada.

Para resolver esse problema, identifique e pare o processo que está usando as portas necessárias para o ADAM ou execute a instalação do Exchange 2007 com opções de linhas de comando para substituir as atribuições padrão de porta do ADAM.

Para executar a instalação substituindo as atribuições padrão de portas do ADAM

  1. Em um prompt de comando, digite o seguinte:

    Setup.exe /adamport:xxxx /adamsslport:yyyy

    • /adamport:<número da porta a ser atribuída ao ADAM>

    • /adamsslport:<número da porta a ser atribuída ao ADAM>


Hierarquia de pasta pública de aplicativo presente
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-05

A ferramenta Microsoft® Exchange Server Analyzer procura a hierarquia de pastas públicas de aplicativo no domínio do serviço de diretório do Active Directory®. Quando o Exchange Server Analyzer localiza árvores de pastas públicas que não são MAPI, o Exchange Server Analyzer exibe um aviso. O aviso indica que árvores de pastas públicas diferentes de MAPI estão presentes na organização do Exchange. Não há suporte para essas árvores de aplicativos personalizados no Exchange Server 2007.

Árvores de pastas públicas diferentes de MAPI são usadas no desenvolvimento de aplicativos personalizados. Essas árvores ocorrem no Microsoft Exchange 2000 Server e no Microsoft Exchange Server 2003, mas não têm suporte no Exchange 2007. É recomendável que antes da implantação do Exchange 2007 você:

  • Mova as árvores de pastas públicas diferentes de MAPI para um SharePoint Portal Server.

  • Mantenha os dados no servidor Exchange 2003.

Para obter mais informações sobre as diferentes hierarquias de pastas públicas, consulte "Selecionando o cliente apropriado para o acesso a pastas públicas do Exchange" (http:// go.microsoft.com/fwlink/?LinkId =46439).


Não é possível determinar o nome do site do Active Directory
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

Não é possível continuar a instalação do Microsoft® Exchange Server 2007 porque este servidor não parece pertencer a um site de serviço de diretório válido do Active Directory®.

A instalação do Microsoft Exchange exige que o servidor usado para a instalação do Exchange 2007 pertença a um site válido do Active Directory.

Para resolver esse problema, verifique se o servidor local é um membro de um site válido do Active Directory e execute novamente a instalação do Exchange Server 2007.

Você pode usar a opção /DsGetSite da ferramenta de linha de comando Nltest.exe para verificar e exibir a afiliação do site. Para obter mais informações, consulte "Nltest.exe: Visão geral do NLTest" na "Coleta de ferramentas e configurações" da Referência Técnica do Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=27734).

Para obter mais informações sobre como solucionar problemas do Active Directory, consulte "Solucionando problemas em operações do Active Directory" no Windows Server 2003: Operações (http://go.microsoft.com/fwlink/?linkid=68099).


Não é possível localizar um serviço de atualização de destinatário
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-05-16

O programa de Instalação do Microsoft® Exchange Server 2007 não pode continuar porque o RUS (Serviço de Atualização de Destinatário) responsável por um domínio na organização do Exchange existente não pode ser encontrado.

A Instalação do Microsoft Exchange exige que cada domínio na organização do Exchange existente tenha uma instância do Serviço de Atualização de Destinatário.

Se uma instância do Serviço de Atualização do Destinatário estiver ausente em um domínio, os novos objetos de usuário criados no domínio não receberão os endereços de email enviados a ele.

Para resolver esse problema, verifique se existe uma instância do Serviço de Atualização do Destinatário para cada domínio e crie uma instância do Serviço de Atualização do Destinatário para os domínios que não possuem e execute novamente a Instalação do Microsoft Exchange.

Para criar uma instância do Serviço de Atualização de Destinatário para um domínio

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Expanda Destinatários.

  3. Clique com o botão direito no nó Serviço de Atualização do Destinatário, clique em Novo e clique em Serviço de Atualização do Destinatário.

  4. Na janela Novo Objeto, clique em Procurar para localizar o nome do domínio.

  5. Selecione o nome de domínio e clique em OK.

  6. Na janela Novo Objeto, clique em Avançar e em Concluir.

Para obter mais informações sobre o Serviço de Atualização de Destinatário, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • "Como o Serviço de Atualização do Destinatário se aplica às diretivas de destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738).

  • "Como o Serviço de Atualização do Destinatário preenche as listas de endereços" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738).

  • Como verificar o progresso do Serviço de Atualização de Destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • Tarefas executadas pelo Serviço de Atualização de Destinatário" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


Não é possível remover o banco de dados da caixa de correio
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-06-20

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois o processo da função de servidor Desinstalar Caixa de Correio não pode remover um banco de dados de caixa de correio de usuário (armazenamento) do servidor local sem a possível perda de dados.

A instalação do Exchange 2007 verifica se todos os armazenamentos de caixa de correio foram removidos do servidor antes que a função de servidor Caixa de Correio seja removida. Entretanto, as caixas de correio de usuário podem ainda permanecer no servidor.

Para resolver esse problema, mova ou desabilite todas as caixas de correio de usuário do servidor e execute novamente a Instalação do Exchange 2007.

Para obter mais informações sobre como identificar caixas de correio no banco de dados, consulte o cmdlet "Get-Mailbox" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=93470) na documentação do produto do Exchange Server 2007.

Para obter mais informações sobre como desabilitar uma caixa de correio, consulte "Como desabilitar uma caixa de correio" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=93471) na documentação do produto do Exchange Server 2007.

Para obter mais informações sobre como remover bancos de dados de caixa de correio do Exchange Server 2007, consulte "Como remover um banco de dados de caixa de correio" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=93473) na documentação do produto do Exchange Server 2007.

Para obter mais informações sobre como gerenciar os armazenamentos ou réplicas de bancos de dados de caixa de correio, consulte Gerenciando armazenamentos de caixa de correio e armazenamentos de pasta pública no "Guia de Administração do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47617).


Não é possível remover banco de dados de pasta pública
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-01-23

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o processo de desinstalação da função de Servidor Caixa de Correio não pode remover o banco de dados de pastas públicas do servidor local sem uma possível perda de dados.

A instalação do Exchange 2007 exige que o banco de dados de pastas públicas seja removido do servidor antes da remoção da função de Servidor Caixa de Correio.

As réplicas de pastas públicas devem permanecer no servidor ou o banco de dados de pasta pública deve ser o último na organização do Exchange.

Para resolver esse problema, mova ou exclua o banco de dados de pasta pública no servidor e execute novamente a instalação do Exchange Server 2007.

Para obter mais informações sobre como remover bancos de dados de pasta pública no Exchange Server 2007, consulte "Como remover um banco de dados de pasta pública" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=81409) na documentação do produto do Exchange Server 2007.

Para obter mais informações sobre como gerenciar armazenamentos ou réplicas de bancos de dados de pastas públicas, consulte Gerenciando Armazenamentos de Caixas de Correio e Armazenamentos de Pastas Públicas no "Guia de Administração do Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?LinkId=47617).


Não é possível remover a função de servidor Unificação de Mensagens
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-26

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois houve falha na tentativa de desinstalar a função de servidor Unificação de Mensagens.

A instalação do Exchange 2007 verifica se a função de servidor Unificação de Mensagens a ser desinstalada está hospedando o ponto de publicação de prompts de um plano de discagem e se o plano de discagem tem outros servidores vinculados a ele.

Se a função de servidor Unificação de Mensagens estiver hospedando o ponto de publicação de prompts para um plano de discagem, o processo de desinstalação falhará.

Para resolver esse problema, mova o ponto de publicação de prompts para outro servidor e reexecute a instalação do Exchange 2007.

Para obter mais informações sobre como mover o ponto de publicação de prompts de um plano de discagem, consulte "Como alterar o ponto de publicação de prompts" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=82356).


Não é possível gravar no caminho de dados do CMS
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-26

A instalação do Microsoft Exchange Server 2007 não pode continuar, pois a tentativa de instalar a função de servidor Caixa de Correio em cluster em uma unidade de cluster compartilhada falhou.

A instalação do Exchange não conseguiu gravar no caminho de instalação de destino enviado para o parâmetro /CMSDataPath. A instalação do Exchange exige que o caminho de destino para os dados do servidor de caixas de correio em cluster seja um volume gravável.

Para resolver esse problema, especifique um caminho de destino para o /CMSDataPath que está na mídia de armazenamento gravável.

Para obter mais informações sobre como instalar o servidor de caixas de correio em cluster, consulte "Como instalar a função de servidor Caixa de Correio no nó ativo" (http://go.microsoft.com/fwlink/?LinkId=86624) na documentação do produto Exchange Server 2007.


Não é possível gravar no contêiner da organização do Exchange
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-05-04

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois o usuário conectado não tem as permissões de conta necessárias para gravar no contêiner da organização no serviço de diretório do Active Directory.

A instalação do Microsoft Exchange exige que o usuário que está conectado quando o Exchange 2007 é instalado tenha credenciais administrativas do Administrador de Empresas ou da Organização do Exchange.

Como parte do processo de instalação, a instalação do Exchange 2007 pode ter que criar objetos no contêiner de organização do Microsoft Exchange.

Para resolver esse problema, conceda ao usuário conectado permissões de Administrador de Empresas ou de Administrador de Organização do Exchange ou faça logon com uma conta que tenha essas permissões e reexecute a instalação do Exchange 2007.

Importante:
Não há suporte para a instalação entre florestas do Exchange 2007. Use uma conta que seja membro da floresta do Active Directory em que você está instalando o Exchange 2007.

Para obter mais informações sobre permissões do Active Directory necessárias com o Microsoft Exchange, consulte "Trabalhando com permissões do Active Directory no Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47592).


A função de Acesso para Cliente não foi detectada no site local
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

A Instalação do Microsoft® Exchange Server 2007 exibiu esse aviso porque uma função Acesso para Cliente existente não pôde ser detectada no site local do serviço de diretório do Active Directory®.

Você escolheu instalar a função de Servidor Caixa de Correio antes que uma instância da função Acesso para Cliente fosse instalada no site do Active Directory.

A função de servidor Acesso para Cliente aceita conexões com o servidor Exchange 2007 a partir de diversos clientes diferentes. Softwares clientes como Microsoft Outlook Express e Eudora usam conexões POP3 ou IMAP4 para se comunicar com o servidor Exchange. Hardwares clientes, como dispositivos móveis, usam ActiveSync, POP3 ou IMAP4 para se comunicar com o servidor Exchange.

Se os usuários acessarem suas caixas de entrada usando um cliente diferente do Microsoft Office Outlook®, você deverá instalar a função de servidor Acesso para Cliente na organização do Exchange.

Os usuários poderão se conectar às suas caixas de correio com o Outlook, mas não poderão usar o Outlook Web Access ou dispositivos móveis na mesma caixa de correio até que uma função Acesso para Cliente esteja presente no site do Active Directory local.


Recursos gerenciados por cluster precisam ser movidos ou colocados offline
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-04-09

A instalação do Microsoft Exchange Server 2007 não pode continuar porque a tentativa de instalar uma nova função de servidor Caixa de Correio ativa em cluster falhou.

O Exchange Server 2007 exige que os recursos gerenciados por cluster estejam inativos no nó do cluster em que a instalação está sendo executada.

Para resolver esse problema, mova todos os recursos gerenciados por cluster que pertencem a esse nó, incluindo os recursos de cluster que não são do Exchange Server, para outro nó no cluster. Como alternativa, coloque-os offline e execute novamente a instalação.

Para obter mais informações sobre como mover os serviços gerenciados por cluster relacionados ao Exchange, consulte o tópico do cmdlet "Move-ClusteredMailboxServer" (http://go.microsoft.com/fwlink/?LinkId=86627) na documentação do produto Exchange Server 2007.

Para obter mais informações sobre como colocar offline os serviços gerenciados por cluster relacionados ao Exchange, consulte o tópico do cmdlet "Stop-ClusteredMailboxServer" (http://go.microsoft.com/fwlink/?LinkId=86635) na documentação do produto Exchange Server 2007.

Para obter mais informações sobre o gerenciamento de recursos de cluster que não sejam do Exchange, consulte "Gerenciar Recursos" (http://go.microsoft.com/fwlink/?LinkId=86637) na Ajuda do Produto Windows Server 2003.


O serviço de cluster não foi iniciado
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-26

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois o Serviço de Cluster do Microsoft Windows Server não foi iniciado.

A instalação do Exchange 2007 exige que o serviço de cluster seja iniciado quando é instalado no computador local.

Para resolver esse problema, inicie o serviço de cluster no computador local e execute novamente a instalação do Exchange.

Para iniciar o serviço de cluster, consulte "Iniciar o serviço de cluster" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=86638) na Biblioteca Técnica do Windows Server 2003.


Atualização de cluster necessária (KB921181)
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-08-11

Não é possível continuar a instalação do Microsoft® Exchange Server 2007 porque é necessária uma atualização no nó do cluster.

O programa de Instalação do Exchange 2007 exige que a atualização do nó do cluster mencionada no artigo 921181 da Base de Dados de Conhecimento Microsoft seja instalada.

Para resolver este problema, instale a atualização mencionada no artigo 921181 da Base de Dados de Conhecimento Microsoft, "Está disponível uma atualização que adiciona um recurso de testemunha de compartilhamento de arquivos e um recurso de pulsações configuráveis de cluster nos clusters do servidor baseado no Windows Server 2003 Service Pack 1" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=69785) e execute novamente a instalação do Exchange 2007.


Caminho de dados CMS deve ser volume NTFS
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-26

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois houve falha na tentativa de instalar a Função de Servidor Caixas de Correio em Cluster em uma unidade de cluster compartilhada.

O caminho de instalação de destino enviado para o parâmetro /CMSDataPath é um volume não-NTFS. A instalação do Exchange exige que o caminho de destino dos dados do servidor de Caixa de Correio em Cluster seja um volume NTFS.

Para resolver esse problema, selecione outro caminho de destino para /CMSDataPath ou converta o volume de destino em NTFS e execute novamente a instalação do Exchange 2007.

Para obter mais informações sobre como converter um volume em NTFS, consulte o tópico "Converter" (http://go.microsoft.com/fwlink/?LinkId=86642) na Documentação do Produto do Windows XP Professional.


Nó de cluster atual pertence aos serviços de gerenciamento de cluster
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-04-09

A instalação do Microsoft Exchange Server 2007 não pode continuar porque sua tentativa de instalar o nó passivo do cluster falhou.

Os serviços de gerenciamento de cluster do Exchange pertencem a esse nó de cluster. A instalação do Exchange 2007 exige que os serviços de gerenciamento de cluster do Exchange sejam movidos desse nó antes que os arquivos do Exchange sejam removidos.

Para resolver esse problema, mova todos os recursos gerenciados por cluster que pertencem a esse nó, incluindo os recursos de cluster que não são do Exchange Server, para outro nó no cluster, ou coloque-os offline e execute de novo a instalação.

Para obter mais informações sobre como mover os serviços gerenciados por cluster relacionados ao Exchange, consulte o tópico do cmdlet "Move-ClusteredMailboxServer" (http://go.microsoft.com/fwlink/?LinkId=86627) na documentação do produto Exchange Server 2007.

Para obter mais informações sobre como colocar offline os serviços gerenciados por cluster relacionados ao Exchange, consulte o tópico do cmdlet "Stop-ClusteredMailboxServer" (http://go.microsoft.com/fwlink/?LinkId=86635) na documentação do produto Exchange Server 2007.

Para obter mais informações sobre o gerenciamento de recursos de cluster que não sejam do Exchange, consulte "Gerenciar Recursos" (http://go.microsoft.com/fwlink/?LinkId=86637) na Ajuda do Produto Windows Server 2003.


O serviço de Sistema de Eventos COM+ deve ser iniciado para que a instalação possa continuar
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-16

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois, como o serviço de Sistema de Eventos COM+ não foi iniciado no computador de destino, houve falha na tentativa de instalar as funções de servidor Transporte de Borda e Acesso para Cliente.

A instalação do Exchange 2007 exige que o status do serviço de Sistema de Eventos COM+ esteja definido como Iniciado no computador em que o Microsoft Exchange está sendo instalado.

O serviço de Sistema de Eventos COM+ oferece suporte à notificação de eventos do sistema para componentes COM+, o que fornece distribuição automática de eventos para componentes COM de inscrição.

As funções de servidor Acesso para Cliente e Transporte de Borda apresentam dependências em componentes COM+ inscritos no serviço de Sistema de Eventos COM+.

Para resolver esse problema, verifique se o status do serviço de Sistema de Eventos COM+ está definido como Iniciado no computador local e execute novamente a instalação do Microsoft Exchange.

Para definir o status do serviço de Sistema de Eventos COM+ como 'Iniciado'

  1. Clique com o botão direito em Meu Computador e, em seguida, clique em Gerenciar.

  2. Expanda o nó Serviços e Aplicativos e clique no nó Serviços.

  3. No painel direito, localize Sistema de Eventos Com+.

  4. Clique com o botão direito em Sistema de Eventos Com+ e, em seguida, clique em Propriedades.

  5. Defina o Tipo de Inicialização como Automático e o Status de serviço como Iniciado.

  6. Clique em Aplicar e em OK.


Detectado modelo de organização complexa do Exchange
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-08-10

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para obter o número de grupos de roteamento presentes na organização do Exchange. O Exchange Server Analyzer também consulta o Active Directory para obter o número de sites do Active Directory que contêm servidores Exchange executando o Microsoft Exchange 2000 Server ou Microsoft Exchange Server 2003.

O Exchange Server Analyzer classificará a organização do Exchange como uma organização complexa do Exchange, se as seguintes condições forem verdadeiras:

  • Existe mais de uma floresta do Active Directory.

  • O MIIS (Microsoft Identity Integration Server) está instalado em uma ou mais florestas.

Dos quatro modelos de organização definidos para o Microsoft Exchange Server 2007, a organização complexa do Exchange é o único modelo que inclui várias florestas do Active Directory ou o uso de tecnologia de sincronização.

Para fazer a transição de uma organização complexa do Exchange para o Exchange 2007

  1. Acesse a documentação do produto Exchange 2007 on-line (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Examine o tópico "Planejando uma organização complexa do Exchange" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=70505).


Não é possível localizar o 'Site Padrão' no computador local
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

Não é possível continuar a instalação do Microsoft® Exchange Server 2007 porque ela não consegue acessar o site padrão neste servidor.

A instalação do Exchange 2007 exige que a instalação da função de Acesso do Cliente acesse o site padrão criado pelo Microsoft IIS (Serviços de Informações da Internet).

A função de servidor Acesso para Cliente oferece a funcionalidade de acesso para cliente, como Microsoft Office Outlook® (quando conectado por HTTP), Outlook Web Access, Exchange ActiveSync®, e clientes que usam o protocolo POP3 ou IMAP4.

O IIS funciona como mecanismo dos protocolos HTTP, POP3, IMAP4, SMTP e NNTP.

Podem ocorrer casos nos quais o site padrão do IIS não existe mais. Ele pode ter sido excluído ou renomeado para algo diferente do Site Padrão.

Para resolver esse problema, remova primeiro o IIS e depois reinstale-o neste servidor. Em seguida, execute novamente a instalação do Exchange 2007.

Importante:
Desinstale e reinstale o IIS para resolver o problema. Não basta recriar ou renomear o diretório.
Para desinstalar o IIS usando Adicionar ou Remover um Componente do Windows no Painel de Controle

  1. No menu Iniciar, clique em Painel de Controle.

  2. Clique duas vezes em Adicionar ou Remover Programas.

  3. Clique em Adicionar/Remover Componentes do Windows.

  4. Na lista Componentes, clique na caixa de seleção Servidor de Aplicativos.

  5. Clique em Detalhes.

  6. Clique em Gerenciador de Serviços de Informações da Internet.

  7. Clique em Avançar.

  8. Clique em Concluir quando a desinstalação do IIS estiver concluída.
Para instalar o IIS usando o Painel de Controle

  1. No menu Iniciar, clique em Painel de Controle.

  2. Clique duas vezes em Adicionar ou Remover Programas.

  3. Clique em Adicionar/Remover Componentes do Windows.

  4. Na lista Componentes, clique na caixa de seleção Servidor de Aplicativos.

  5. Clique em Detalhes.

  6. Clique na caixa de seleção Gerenciador de Serviços de Informações da Internet.

  7. Clique em OK até retornar ao Assistente de Componentes do Windows.

  8. Clique em Avançar e conclua o Assistente de Componentes do Windows.


O serviço de Coordenador de Transações Distribuídas deve ser iniciado para que a instalação possa continuar
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-16

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois, como o serviço de Coordenador de Transações Distribuídas não foi iniciado no computador de destino, houve falha na tentativa de instalar as funções de servidor Unificação de Mensagens e Acesso para Cliente.

A instalação do Exchange 2007 exige que o status do serviço de Coordenador de Transações Distribuídas esteja definido como Iniciado no computador em que o Microsoft Exchange está sendo instalado.

O serviço de Coordenador de Transações Distribuídas fornece serviços criados para garantir transações completas e bem-sucedidas, mesmo com falhas do sistema, falhas de processo e falhas de comunicação.

Cada computador que participa de uma transação distribuída gerencia seus próprios recursos e dados e também trabalha juntamente com outros computadores na transação. Sobretudo, uma transação distribuída deve confirmar ou anular inteiramente seu trabalho em todos os computadores participantes. O Coordenador de Transações Distribuídas executa a função de coordenação da transação para os componentes envolvidos e atua como um gerenciador de transações para cada computador que gerencia transações.

As funções de servidor Unificação de Mensagens e Servidor de Acesso para Cliente têm dependências no serviço de Coordenador de Transações Distribuídas.

Para resolver esse problema, verifique se o status do serviço de Coordenador de Transações Distribuídas está definido como Iniciado no computador local e execute novamente a instalação do Microsoft Exchange.

Para definir o status do serviço de Coordenador de Transações Distribuídas como 'Iniciado'

  1. Clique com o botão direito em Meu Computador e, em seguida, clique em Gerenciar.

  2. Expanda o nó Serviços e Aplicativos e clique no nó Serviços.

  3. No painel direito, localize o Coordenador de Transações Distribuídas.

  4. Clique com o botão direito em Coordenador de Transações Distribuídas e, em seguida, clique em Propriedades.

  5. Defina o Tipo de Inicialização como Automático e o Status de serviço como Iniciado.

  6. Clique em Aplicar e em OK.


O sufixo DNS não está definido no computador local
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-05

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o FQDN (Nome de Domínio Totalmente Qualificado) do computador local não está definido.

A instalação do Exchange 2007 exige que o computador local tenha um sufixo DNS (Sistema de Nome de Domínio) válido definido.

Para resolver esse problema, defina o sufixo DNS para o computador local, reinicie o computador e reexecute a instalação do Exchange 2007.

Para definir o sufixo DNS primário do computador local

  1. Clique com o botão direito em Meu Computador e clique em Propriedades. A caixa de diálogo Propriedades do Sistema será exibida.

  2. Clique na guia Nome do Computador.

  3. Clique em Alterar. A caixa de diálogo Alterações no Nome do Computador será exibida.

  4. Clique em Mais. A caixa de diálogo Sufixo DNS e Nome NetBIOS do Computador será exibida.

  5. Digite o sufixo DNS apropriado para o domínio.

  6. Marque a caixa de seleção Alterar sufixo de DNS primário quando a associação do domínio for alterada.

  7. Clique em OK para salvar as alterações e clique em OK para sair da caixa de diálogo Alterações no Nome do Computador.

  8. Clique em OK para fechar a caixa de diálogo Propriedades do Sistema e reinicie o computador para que a alteração entre em vigor.

Para obter mais informações sobre Nomes DNS, consulte o artigo 909264 da Base de Dados de Conhecimento da Microsoft, "Convenções de nomenclatura no Active Directory para computadores, domínios e OUs" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264).


Substituição de Controlador de Domínio está definida no Registro
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois houve falha na tentativa de usar o controlador de domínio especificado. Um controlador de domínio foi estaticamente mapeado no Registro.

A instalação do Exchange 2007 exige que o controlador de domínio especificado no comando de instalação corresponda ao controlador de domínio que foi estaticamente mapeado com uma substituição de Registro.

Para resolver esse problema, execute a instalação novamente, especificando o controlador de domínio mapeado estaticamente para o parâmetro /DomainController: <FQDN do controlador de domínio mapeado estaticamente>.

Para obter mais informações sobre DSAccess e detecção de serviços de diretório, consulte o artigo 250570 da Base de Dados de Conhecimento Microsoft, "Detecção do servidor de serviço de diretório e uso do DSAccess" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


Preparação de domínio necessária
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois houve falha na tentativa de instalar a função de servidor.

A instalação do Microsoft Exchange exige que o domínio local seja preparado para o Exchange Server 2007 para que determinadas funções de servidor possam ser instaladas.

A preparação do domínio para o Exchange Server 2007 consiste nas seguintes tarefas:

  • Definir permissões no contêiner Domínio para os Servidores, os Administradores da Organização, os Usuários Autenticados e os Administradores de Caixa de Correio do Exchange.

  • Criar o contêiner Objetos do Sistema do Microsoft Exchange, caso ele ainda não exista, e definir permissões nesse contêiner para os Servidores, os Administradores da Organização e Usuários Autenticados do Exchange.

  • Criar um novo grupo global de domínio no domínio atual chamado Servidores do Domínio de Instalação do Exchange.

  • Adicionar o grupo Servidores de Domínio de Instalação do Exchange ao USG dos Servidores Exchange no domínio raiz.

Para resolver esse problema, execute setup /PrepareDomain para preparar o domínio local e tentar novamente a instalação da função de servidor.

Para obter mais informações sobre como executar o processo PrepareDomain, consulte "Como preparar o Active Directory e os domínios" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=78453).


A função Transporte de Borda não pode ser instalada no computador local
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-01-03

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque sua tentativa de instalar uma função de Servidor de Borda encontrou outras funções do Microsoft Exchange instaladas nesse servidor.

A instalação do Exchange 2007 não pode instalar a função de Servidor de Borda em um servidor que tenha outras funções do Microsoft Exchange instaladas.

A função de Servidor de Borda do Microsoft Exchange é implantada na rede de perímetro da organização e controla todo o fluxo de mensagens voltado para a Internet. Fornece a criptografia e a descriptografia de mensagens enviadas entre organizações confiáveis do Microsoft Exchange e também proteção contra spam.

Para resolver esse problema, instale a função de Servidor de Borda em um computador que não tenha outras funções do Microsoft Exchange instaladas.


Conector EDK encontrado na topologia
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-04

A ferramenta Microsoft® Exchange Server Analyzer Tool verifica no serviço de diretório do Active Directory® a existência de conectores EDK (Exchange Development Kit) na organização do Exchange. Se os conectores EDK forem encontrados no Active Directory, o Exchange Server Analyzer exibirá um aviso. O aviso indica que os conectores EDK não têm suporte no Microsoft Exchange Server 2007.

É recomendável que você entre em contato com o fornecedor terceirizado para obter um produto conector de substituição para o Exchange 2007. Como alternativa, você pode manter um Exchange 2003 ou Microsoft Exchange 2000 Server para dar suporte ao conector EDK.

Observação:
Os conectores EDK são aplicativos terceirizados construídos para fazer conexão aos sistemas de comunicação como máquinas de fax, SMS (Short Message Service), telex ou a outros sistemas de mensagens, como o Lotus Notes, que usa um conector de gateway. Os fornecedores não-Microsoft usam o EDK (Exchange Development Kit) para desenvolver conectores proprietários.


Esm.dll em uso por um ou mais processos
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-28

A instalação do Microsoft Exchange Server 2007 não pode continuar porque ocorreu um problema na tentativa de atualizar o servidor de acesso ao módulo.

A instalação do Exchange 2007 exige que determinados módulos não estejam em execução para que a atualização possa modificar os arquivos binários. O arquivo Esm.dll file é um desses módulos.

Para resolver esse problema, descarregue os processos em que o Esm.dll está aberto e execute de novo a instalação do Exchange 2007.

Para parar o processo em que o Esm.dll está aberto

  1. Inicie o Shell de Gerenciamento do Exchange.

  2. Use o cmdlet Get-Process para localizar a ID de processo dos processos que o Exchange Analyzer identificou.

  3. Get-Process < nome do processo >

  4. Use o cmdlet Stop-Process para parar o processo.

  5. Stop-Process < ID do processo >

  6. Em que <process ID> é o valor da ID de processo retornado do cmdlet Get-Process na etapa 2 aqui.

Para obter mais informações sobre o cmdlet Get-Process, consulte Usando o cmdlet Get-Process no tópico "O que posso fazer com o Windows PowerShell?" (em inglês).


'ExchHelp.chm' está aberto
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-16

A instalação do Microsoft Exchange Server 2007 não pode continuar porque ocorreu um problema na tentativa de atualizar o servidor de acesso ao arquivo.

A instalação do Exchange 2007 exige que determinados arquivos sejam fechados para que o processo de atualização possa modificar os arquivos ou processos que os acessam. O arquivo local de Ajuda do Exchange (ExchHelp.chm) é um desses arquivos.

Para resolver esse problema, feche o arquivo ExchHelp.chm e execute novamente a instalação do Exchange 2007.


Computadores do Exchange 2000 Server exigem atualização para o SP3
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois um ou mais servidores da organização existente estão executando o Exchange 2000 Server sem o Service Pack 3 ou uma versão posterior.

A instalação do Exchange 2007 exige que todos os computadores existentes com Exchange 2000 Server na organização estejam executando o Exchange 2000 Server Service Pack 3 (SP3).

Para resolver esse problema, atualize todos os computadores existentes com Exchange 2000 Server na organização para Exchange 2000 Server SP3 ou uma versão posterior e execute novamente a instalação do Exchange 2007.

Para obter mais informações sobre como atualizar computadores com o Exchange 2000 Server para Exchange 2000 Server SP3 ou uma versão posterior, consulte "Downloads para o Exchange 2000 Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=86647).


A organização do Exchange está no modo misto
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-05

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o contêiner de organização do Exchange para determinar o modo dessa organização. O Exchange Server Analyzer verifica o valor do atributo msExchangeMixedMode. Se o valor do atributo msExchangeMixedMode for True, o Exchange Server Analyzer exibirá um erro. A mensagem de erro indica que a organização do Exchange está sendo executada no modo misto. O Microsoft Exchange Server 2007 só pode ser instalado em a organização que esteja em modo nativo. Portanto, é necessário alternar uma organização que executa em modo misto para nativo, a fim de preparar uma implantação do Exchange 2007.

Observação:
Uma organização que é executa em modo nativo só pode conter servidores Exchange 2000 ou versões posteriores.

Para preparar-se para uma implantação do Exchange 2007, converta a organização do Exchange em modo nativo, seguindo estas etapas:

  1. Remova ou descomissione todos os servidores Exchange 5.5 restantes.

  2. No Gerenciador do Sistema do Exchange, abra as propriedades do objeto da organização do Exchange e alterne para o modo nativo.

Para obter mais informações sobre como converter uma organização do Exchange no modo nativo, consulte "Como converter de modo misto em modo nativo no Exchange" (http://go.microsoft.com/fwlink/?LinkId=56642) no Guia de Implantação do Exchange Server 2003 (em inglês).

Para obter mais informações sobre os modos misto e nativo do Microsoft Exchange, consulte os seguintes artigos da Base de Dados de Conhecimento Microsoft:

  • 270143, "Descrição dos modos misto e nativo no Exchange 2000 Server e Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270143) (em inglês).

  • 327779, "Como converter do modo misto no modo nativo no Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779) (em inglês).

  • 272314, "XADM: Preparando uma organização do modo misto para conversão em modo nativo" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=272314) (em inglês).


Computadores do Exchange Server 2003 exigem atualização para o SP2
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

A instalação do Microsoft Exchange Server 2007 não pode continuar porque um ou mais servidores na organização existente estão executando o Exchange Server 2003 sem o Service Pack 2 (ou uma versão posterior).

A instalação do Exchange 2007 exige que todos os computadores existentes do Exchange Server 2003 na organização estejam executando o Exchange Server 2003 Service Pack 2 (SP2) ou uma versão posterior.

Para resolver esse problema, atualize todos os computadores existentes do Exchange Server 2003 na organização para o Exchange Server 2003 SP2 ou uma versão posterior e execute novamente a instalação do Exchange 2007.

Para obter mais informações sobre a atualização de computadores do Exchange Server 2003 para o Exchange Server 2003 SP2 ou uma versão posterior, consulte "Downloads para o Exchange Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=21030).


O Exchange Server 2007 não pode ser usado com esta versão do Windows
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois o computador local não está executando uma versão do sistema operacional Microsoft Windows Server que seja compatível com o Exchange Server 2007.

A instalação do Exchange 2007 exige que a versão do Windows Server do computador local aceite a execução do Exchange Server 2007, conforme especificado pelos Requisitos do Sistema do Exchange Server 2007.

Para resolver esse problema, instale no computador local uma versão do sistema operacional Windows compatível com o Exchange Server 2007 ou instale o Exchange Server 2007 em um computador que esteja executando uma versão aceita do Windows Server.

Para obter mais informações sobre os requisitos do sistema do Exchange Server 2007, consulte "Requisitos do sistema Exchange Server 2007" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=86651).


Testemunha de compartilhamento de arquivos não configurada
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-23

A instalação do Microsoft Exchange Server 2007 não pode continuar porque uma testemunha de compartilhamento de arquivos não foi configurada para o cluster de CCR (replicação contínua de cluster).

Para sustentar a falha de qualquer nó em um cluster de quorum MNS (Conjunto de Nós Principais), você deve ter pelo menos três dispositivos que podem ser considerados como disponíveis. O recurso de testemunha de compartilhamento de arquivos permite usar um compartilhamento de arquivos externo como testemunha. Essa testemunha funciona como o terceiro dispositivo disponível em um cluster de quorum MNS de dois nós.

A instalação do Exchange 2007 exige que o recurso de testemunha de compartilhamento de arquivos seja configurado para a instalação da função de servidor Caixa de Correio em cluster em um ambiente de CCR.

Para resolver esse problema, siga o procedimento para criar e proteger o compartilhamento de arquivos para a testemunha, conforme mostrado em "Como configurar a testemunha de compartilhamento de arquivos" (http://go.microsoft.com/fwlink/?LinkId=78278). Em seguida, defina o valor MNSFileShare, mova o grupo de cluster duas vezes e tente executar a instalação do Microsoft Exchange novamente.


Não é possível delegar a primeira instalação da função
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

A instalação do Microsoft® Exchange Server 2007 não pode continuar, pois o usuário conectado não possui as permissões de conta necessárias para instalar a primeira função de servidor na topologia.

Embora a instalação do Microsoft Exchange permita o uso de delegação para instalar funções de servidor subseqüentes, ela exige que o usuário conectado possua credenciais administrativas na organização do Exchange para a instalação da primeira função de servidor do Exchange 2007.

Como parte da instalação da primeira função de servidor, a instalação do Exchange 2007 talvez precise criar objetos no contêiner da organização do Exchange.

Para resolver esse problema, conceda ao usuário conectado permissões de administrador da organização do Exchange ou faça logon usando uma conta que possua essas permissões e execute a instalação do Exchange 2007 novamente.


O Forefront Security para serviços do Exchange Server deve estar desabilitado
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-06-20

A instalação do Microsoft Exchange Server 2007 não pode continuar a atualização do Exchange Server 2007, porque os serviços do Microsoft Forefront Security para Exchange Server estão sendo executados no computador local.

A instalação do Exchange exige que os serviços do Forefront Security para Exchange Server sejam desabilitados para que a atualização do Exchange Server 2007 possa continuar.

Para resolver esse problema, desabilite os serviços do Forefront Security para Exchange Server e execute novamente a atualização do Exchange Server.

Para obter mais informações sobre como instalar um service pack ou uma atualização de software em um Exchange Server que esteja executando o Forefront Security, consulte o artigo 929080 da Base de Dados de Conhecimento Microsoft How to install a service pack or a software update on an Exchange Server computer that is running Forefront Security.


Atualização do Forefront Security para Exchange Server Necessária
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Aplica-se a: Exchange Server 2007, Exchange Server 2007 SP1
Última modificação do tópico: 2007-08-08

A instalação do Microsoft Exchange Server 2007 não pode continuar a atualização do Exchange 2007 porque o computador local está executando uma versão do Microsoft Forefront Security para Exchange Server que não é compatível com o Exchange Server 2007 Service Pack 1 (SP1).

A instalação do Exchange exige que a versão do Microsoft Forefront Security para Exchange Server esteja atualizada e que seus serviços sejam desabilitados para que a atualização do Exchange Server 2007 possa continuar.

Para resolver esse problema, atualize o Microsoft Forefront Security versão 10.0 para Exchange Server para o Microsoft Forefront Security para Exchange Server SP1 e desabilite os serviços do Microsoft Forefront Security para Exchange Server antes de continuar a atualização do Exchange Server.

Para obter mais informações

Para obter mais informações sobre instalação de um service pack ou atualização de software em um Exchange Server que esteja executando o Forefront Security, consulte o artigo 929080 da Base de Dados de Conhecimento da Microsoft "Como instalar um service pack ou atualização de software em um computador do Exchange Server que esteja executando o Forefront Security" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=929080).


O nome de domínio totalmente qualificado do computador corresponde a uma diretiva de destinatário
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-05-16

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o FQDN (Nome de Domínio Totalmente Qualificado) do computador locar coincide com o endereço SMTP de uma diretriz de destinatário.

A instalação do Microsoft Exchange requer que o FQDN dos servidores em uma organização do exchange não coincidam com endereços SMTP de diretivas de destinatários da mesma organização do Exchange.

Se o FQDN de um computador coincidir com o endereço SMTP de uma diretiva de destinatário, essa coincidência pode fazer com que mensagens falhem em SMTP e fiquem paralisadas nas filas do MTA.

Para resolver esse problema, renomeie o computador local ou remova ou renomeie a diretiva de destinatário e reexecute a instalação do Microsoft Exchange.

Para renomear o computador local

  1. Abra Sistema no Painel de Controle.

  2. Na guia Nome do Computador, clique em Alterar.

  3. Em Nome do computador, digite um novo nome para o computador e clique em OK. Você será instado a fornecer um nome de usuário e senha para renomear o computador no domínio.

  4. Clique em OK para fechar a caixa de diálogo Propriedades do Sistema. Você será solicitado a reiniciar o computador para aplicar as alterações.
Importante:
Se o computador que deseja renomear for um controlador de domínio, consulte "Renomear um controlador de domínio" (http://go.microsoft.com/fwlink/?LinkId=66828).
Para modificar o endereço SMTP da diretiva de destinatário

  1. Inicie o Gerenciador do Sistema Exchange.

  2. Clique em Organização, clique em Destinatários e em Diretivas de Destinatário.

  3. Clique duas vezes na diretiva que você deseja alterar.

  4. Clique na guia Endereços de Email e altere o endereço SMTP apropriado

Para obter mais informações sobre problemas de nomeação de Diretivas de Destinatário, consulte o artigo 288175 da Base de Dados de Conhecimento da Microsoft, "XCON: Diretiva de Destinatário não pode coincidir com o FQDN de nenhum servidor da organização, NDRs 5.4.8" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288175).


Um servidor de catálogo global não existe no site local
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

A instalação do Microsoft® Exchange Server 2007 não pode continuar, porque não existe um servidor de Catálogo Global no site em que você está tentando instalar o Microsoft Exchange.

A instalação do Microsoft Exchange exige que o site do serviço de diretório do Active Directory® do computador que está executando a instalação contenha um servidor que atue como um catálogo global.

Para resolver esse problema, execute um dos seguintes passos:

  • Transforme um controlador de domínio existente no site em um servidor de Catálogo Global.

  • Instale um novo servidor na função de servidor Catálogo Global.

Para transformar um controlador de domínio existente em um servidor de catálogo global

  1. Abra sites e serviços do Active Directory.

  2. Expanda Sites, expanda o Site e expanda Servidores.

  3. Selecione o controlador de domínio que você deseja especificar como um servidor de catálogo global.

  4. No painel direito, clique com o botão direito em Configurações NTDS e selecione Propriedades.

  5. Na guia Geral, marque a caixa de seleção Catálogo Global. A mudança ocorre dinamicamente sem reiniciar o servidor.
  • Para obter mais informações sobre como criar servidores de catálogo global, consulte o artigo 313994 da Base de Dados de Conhecimento Microsoft, "COMO: Criar ou mover um catálogo global no Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994).

  • Para obter mais informações sobre localização e disponibilidade de servidores de catálogo global em relação ao Exchange Server, consulte o artigo 875427 da Base de Dados de Conhecimento Microsoft, "Localização e proporções do servidor de catálogo global em uma organização do Exchange 2000 Server ou do Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427).


Atualizações globais necessárias
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-09-19

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o usuário conectado não tem permissões da conta necessárias para fazer atualizações Globais no serviço de diretório do Active Directory®.

A instalação do Microsoft Exchange exige que o usuário que está conectado quando o Exchange 2007 é instalado tenha credenciais administrativas do Administrador de Empresas.

Como parte do processo de instalação, a instalação do Exchange 2007 pode ter que fazer o seguinte:

  • Criar ou modificar objetos da organização do Exchange no serviço de diretório do Active Directory

  • Preparar todos os domínios da floresta do Active Directory para o Exchange 2007.

  • Preparar os domínios existentes do Exchange 2000 Server e do Exchange Server 2003 para o Exchange 2007.

Para resolver esse problema, conceda ao usuário conectado permissões de Administrador de Empresas ou faça logon com uma conta que tenha essas permissões e reexecute a instalação do Exchange 2007.

Para obter mais informações sobre permissões do Active Directory necessárias com o Exchange, consulte "Trabalhando com permissões do Active Directory no Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=47592).


O Registro do Host para o computador local não pode ser encontrado no banco de dados DNS
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-05

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o registro do Host (A) desse computador não pôde ser encontrado no banco de dados do DNS (Sistema de Nome de Domínio).

A instalação do Exchange 2007 requer que o computador local tenha um registro de HOST (A) válido no banco de dados do DNS autoritativo no domínio.

O Microsoft Exchange depende de registros do Host (A) do DNS do endereço IP de seu próximo servidor de destino interno ou externo.

Para resolver esse problema:

  • Verifique se a configuração TCP/IP local aponta para o servidor DNS correto.

    Para verificar a configuração TCP/IP local

    1. Verifique a configuração TCP/IP local Para obter mais informações, consulte "Configure TCP/IP to use DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=68094).
  • Use Nslookup.exe para verificar se o registro do Host (A) existe no servidor DNS. Para obter mais informações, consulte "To verify A resource records exist in DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63001).

Para obter informações sobre resolução de nome DNS, solução de problemas e registros do Host (A), consulte:

  • Artigo 322856 da Base de Dados de Conhecimento da Microsoft, "Como configurar o DNS para ser usado com o Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • "Solução de problemas do DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63003).

  • "Gerenciando registros de recursos" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63004).


Função de Transporte de Hub não detectada no site local
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

A instalação do Microsoft® Exchange Server 2007 exibe esse aviso quando uma função de servidor de Transporte de Hub existente não é detectada no site de serviço do diretório local do Active Directory®.

Você optou por instalar a função de Servidor de Caixa de Correio antes da instalação de uma instância da função de Transporte de Hub no site do Active Directory.

Os Serviços de Transporte de Hub do Exchange 2007 são implantados no Active Directory da organização. Os Serviços de Transporte de Hub administram todo o fluxo de mensagens da organização, aplicam regras organizacionais de roteamento de fluxo de mensagens e são responsáveis pela entrega de mensagens à caixa de correio dos destinatários.

Os usuários poderão fazer logon nas caixas de correio, mas só poderão enviar e receber emails a partir desse servidor de caixa de correio depois que a função de Transporte de Hub for instalada.


Hub Transport Server Not Present in Active Directory Site
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-07-25

A ferramenta Microsoft Exchange Analyzer consulta o serviço de diretório do Active Directory em busca do valor de qualquer objeto da classe msExchAdminGroupContainer na organização do Exchange que contém o identificador de Grupo Administrativo específico do Exchange Server 2007, FYDIBOHF23SPDLT.

Se o Exchange Analyzer determinar que existe um grupo administrativo do Exchange Server 2007 na organização do Exchange, ele consultará todos os sites do Active Directory na organização em busca do valor do atributo msExchCurrentServerRoles para cada objeto msExchExchangeServer para determinar se há uma função de servidor Caixa de Correio instalada em um dos sites encontrados.

Por fim, se o Exchange Analyzer determinar a existência de uma função de servidor Caixa de Correio instalada em um site, ele consultará o atributo msExchCurrentServerRoles de cada objeto msExchExchangeServer nesse site para descobrir se há também uma função de servidor Transporte de Hub instalada nesse mesmo site.

O Exchange Analyzer exibirá um erro se detectar a existência de uma função de servidor Caixa de Correio instalada em um site do Active Directory que não tenha instalada a função de servidor Transporte de Hub.

Esse erro indica que, embora haja uma função de servidor Caixa de Correio instalada no site do Active Directory, a mensagem não será transferida de uma caixa de correio para outra, mesmo se as caixas de correio estiverem no mesmo servidor, até que pelo menos uma função de servidor Transporte de Hub seja instalada no site.

A função de servidor Transporte de Hub é implantada no serviço de diretório do Acive Directory dentro de sua organização. Ela trata todo o fluxo de mensagens dentro da organização, aplica diretivas de mensagens organizacionais e é responsável por entregar mensagens na caixa de correio de um destinatário. Os servidores de Transporte de Hub fornecem as seguintes funcionalidades:

Fluxo de mensagens A função de servidor Transporte de Hub processa todas as mensagens enviadas dentro da organização do Exchange 2007 antes de elas serem entregues na Caixa de Entrada de um destinatário dentro da organização ou direcionadas a usuários fora da organização. Não há exceções para esse comportamento.

Categorização O categorizador executa resolução de destinatários, resolução de roteamento e conversão de conteúdo para todas as mensagens movimentadas no pipeline de transporte do Exchange 2007.

Roteamento A função de servidor Transporte de Hub determina o caminho de roteamento de todas as mensagens enviadas e recebidas na organização.

Entrega As mensagens são entregues na caixa de correio de um destinatário pelo driver de armazenamento. As mensagens enviadas pelos usuários da sua organização são retiradas da Caixa de Saída do remetente pelo driver de armazenamento e são colocadas na Fila de envio em um servidor de Transporte de Hub.

Para resolver esse erro, instale a função de servidor Transporte de Hub nos sites em que a função de servidor Caixa de Correio está instalada.

Para obter mais informações

Para obter mais informações sobre como implantar a função de servidor Transporte de Hub em um site, consulte "Deploying Server Roles" (http://go.microsoft.com/fwlink/?LinkId=83282) na documentação do produto Exchange Server 2007.


Componentes de compatibilidade do IIS 6 não instalados
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-08-13

A instalação do Microsoft Exchange Server 2007 não pode continuar sua tentativa de instalar as funções de servidor Acesso para Cliente e Caixa de Correio nem as Ferramentas Administrativas do Exchange 2007 no computador de destino baseado no Windows Server 2008, pois os componentes Compatibilidade da Metabase e Console de Gerenciamento do IIS 6 não estão instalados.

A instalação do Exchange 2007 exige que os componentes Compatibilidade da Metabase e Console de Gerenciamento do IIS 6 estejam presentes no computador baseado no Windows Server 2008 em que você está instalando as funções de servidor Acesso para Cliente e Caixa de Correio do Exchange 2007 ou as Ferramentas Administrativas do Exchange 2007.

Para resolver esse problema, instale o Componente de Compatibilidade da Metabase do IIS 6 no computador de destino e execute novamente a instalação do Microsoft Exchange.

Para instalar os Componentes de Compatibilidade de Gerenciamento do IIS 6.0 usando o Gerenciador do Servidor Windows Server 2008

  1. Clique em Iniciar, clique em Ferramentas Administrativas e, em seguida, clique em Gerenciador do Servidor.

  2. No painel de navegação à esquerda, expanda Funções, clique com o botão direito em Servidor Web (IIS) e selecione Adicionar Serviços de Função.

  3. No painel Selecionar Serviços de Função, role para baixo até Compatibilidade de Gerenciamento do IIS 6.

  4. Marque as caixas de seleção Compatibilidade da Metabase do IIS 6 e Console de Gerenciamento do IIS 6.

  5. Clique em Avançar no painel Selecionar Serviços de Função e clique em Instalar no painel Confirmar Seleções de Instalações.

  6. Clique em Fechar para sair do assistente para Adicionar Serviços de Função.


Componente do IIS 7 não instalado
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-08-09

A instalação do Microsoft Exchange Server 2007 não pode continuar a instalar a função de servidor de Acesso para Cliente no sistema baseado em Microsoft Windows Server 2008 porque os componentes necessários do IIS (Serviço de Informações da Internet) 7 não estão instalados.

A instalação do Exchange 2007 exige que o computador baseado em Windows Server 2008 no qual você está instalando a função de servidor Acesso para Cliente tenha os seguintes componentes do IIS 7 instalados antes de instalar a função de servidor Acesso para Cliente.

Componentes do IIS 7 necessários

Compactação de Conteúdo Dinâmico

Compactação de Conteúdo Estático

Autenticação Básica

Autenticação do Windows

Para resolver esse problema, instale os componentes necessários do IIS 7 no computador de destino e execute novamente a instalação do Microsoft Exchange.

Para instalar os Componentes do IIS 7 usando o Gerenciador do Servidor Windows Server 2008

  1. Clique em Iniciar, clique em Ferramentas Administrativas e, em seguida, clique em Gerenciador do Servidor.

  2. No painel de navegação à esquerda, expanda Funções, clique com o botão direito em Servidor Web (IIS) e selecione Adicionar Serviços de Função.

  3. No painel Selecionar Serviços de Função, role para baixo até IIS.

  4. Marque as caixas de marcação sob Segurança para Autenticação Básica e Autenticação do Windows.

  5. Marque as caixas de seleção sob Desempenho para Compactação Estática e Compactação Dinâmica.

  6. Clique em Avançar no painel Selecionar Serviços de Função e clique em Instalar no painel Confirmar Seleções de Instalações.

  7. Clique em Fechar para sair do assistente para Adicionar Serviços de Função.


Os Arquivos Comuns do IIS são necessários
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-08-14

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque os Arquivos Comuns do IIS (Microsoft Internet Information Service) não estão instalados neste servidor.

O Shell de Gerenciamento do Microsoft Exchange pode exigir acesso remoto à Metabase do IIS. A metabase é um repositório para a maioria dos valores de configuração do IIS. O acesso remoto à metabase exige que as DLLs adequadas do COM+ estejam instaladas no computador local.

Para resolver esse problema, instale os Arquivos Comuns do IIS e reexecute a Instalação do Exchange 2007.

Para instalar os Arquivos Comuns do IIS usando o Painel de Controle no Windows Server™ 2003

  1. No menu Iniciar, clique em Painel de Controle.

  2. Clique duas vezes em Adicionar ou Remover Programas.

  3. Clique em Adicionar/Remover Componentes do Windows.

  4. Na lista Componentes, clique na caixa de seleção Servidor de Aplicativos.

  5. Clique em Detalhes.

  6. Na lista Suncomponentes de Servidor de Aplicativos, clique na caixa de seleção Serviços de Informações da Internet (IIS).

  7. Clique em Detalhes.

  8. Clique na caixa de seleção Arquivos Comuns.

  9. Clique em OK até retornar ao Assistente de Componentes do Windows.

  10. Clique em Avançar e conclua o Assistente de Componentes do Windows.
Para instalar os Arquivos Comuns do IIS usando o Painel de Controle no Windows® XP

  1. No menu Iniciar, clique em Painel de Controle.

  2. Clique duas vezes em Adicionar ou Remover Programas.

  3. Clique em Adicionar/Remover Componentes do Windows.

  4. Na lista Componentes, clique na caixa de seleção Serviços de Informações da Internet (IIS).

  5. Clique em Detalhes.

  6. Clique na caixa de seleção Arquivos Comuns.

  7. Clique em OK até retornar ao Assistente de Componentes do Windows.

  8. Clique em Avançar e conclua o Assistente de Componentes do Windows.


O IIS está no modo de compatibilidade de 32 bits
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-08-11

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o IIS (Microsoft Internet Information Service) está sendo executado no modo de 32 bits neste computador de 64 bits.

O Exchange 2007 exige que o IIS esteja no modo de 64 bits pleno ao ser executado em um computador de 64 bits.

Para resolver esse problema, alterne o IIS para o modo de 64 bits e execute novamente a instalação do Microsoft Exchange.

Para alternar o IIS para o modo de 64 bits

  1. Abra um prompt de comando.

  2. Digite o seguinte:

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. Pressione Enter


Permissões insuficientes para preparar o Active Directory
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-21

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois houve falha na tentativa de preparação de domínio.

A instalação do Exchange exige que o serviço de diretório do Active Directory seja modificado para o Exchange Server 2007 para que os domínios do Active Directory possam ser preparados.

A conta usada para executar o comando setup /PrepareAD não possui permissões suficientes para executar esse comando, embora ela pareça pertencer ao grupo Administração de Empresa. A conta pode ter expirado.

Para resolver esse problema, verifique se a conta de usuário conectada é válida e se pertence ao grupo Administração de Empresa, ou faça logon com uma conta que tenha essas permissões e reexecute o comando setup /PrepareAD.

Para obter mais informações sobre como executar o processo PrepareAD, consulte "Como preparar o Active Directory e os domínios" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=78453).

Para obter mais informações sobre permissões do Active Directory necessárias com o Microsoft Exchange, consulte "Trabalhando com permissões do Active Directory no Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47592).


Permissões insuficientes para remover todas as funções de servidor
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois houve falha na tentativa de desinstalar todas as funções de servidor.

A instalação do Exchange 2007 exige que o usuário conectado durante a desinstalação das funções de servidor seja um membro dos grupos Administradores da Organização do Exchange ou do grupo Administração de Empresa.

Para resolver esse problema, conceda ao usuário conectado permissões de Administrador da Organização do Exchange ou registre-o no grupo Administração de Empresa. Você também pode fazer logon com uma conta que tenha essas permissões e executar novamente a instalação do Exchange 2007.

Para obter mais informações sobre permissões do Active Directory necessárias com o Microsoft Exchange, consulte "Trabalhando com permissões do Active Directory no Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=47592).


Permissões insuficientes para executar /PrepareDomain
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

A instalação do Microsoft Exchange Server 2007 não pode continuar porque a tentativa de executar o processo /PrepareDomain falhou. O usuário conectado tem permissões insuficientes para executar o processo /PrepareDomain.

A instalação do Exchange 2007 exige que o usuário conectado durante a execução do processo /PrepareDomain seja um membro do grupo Administradores de Domínio para o domínio a ser preparado e um membro do grupo Administradores da Organização do Exchange ou do grupo Administração de Empresa.

Para resolver esse problema, conceda ao usuário conectado permissões do grupo Admins. do Domínio do domínio que está sendo preparado e registre-os nos grupos Administração de Empresa ou Administradores da Organização do Exchange ou faça logon com uma conta que tenha essas permissões e execute de novo a instalação do Exchange 2007.

Para obter mais informações sobre permissões do Active Directory necessárias com o Microsoft Exchange, consulte "Trabalhando com permissões do Active Directory no Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47592).


Nome de domínio inválido do Sistema de Nome de Domínio
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-04-13

Não é possível continuar com a instalação do Microsoft Exchange Server 2007 porque o nome de domínio do DNS (sistema de nome de domínio) definido no computador local é inválido.

A instalação do Exchange 2007 não permite que o nome de domínio do DNS contenha caracteres diferentes de 'A-Z', 'a-z','0-9', '.' e '-'.

Para resolver esse problema, determine se os caracteres inválidos estão no nome da máquina do computador local ou no Nome de Domínio do DNS real.

  • Se os caracteres inválidos estiverem no nome da máquina do computador local, redefina o nome de domínio do DNS para o domínio no computador local usando somente caracteres válidos do intervalo de 'A-Z', 'a-z','0-9', '.' e '-', reinicie o computador e execute novamente a instalação do Exchange 2007.

  • Se os caracteres inválidos estiverem no nome de domínio do DNS da organização, considere a possibilidade de renomear o domínio DNS ou de instalar o Exchange 2007 em uma nova árvore de domínios.

Cuidado:
A alteração do nome de domínio do DNS pode afetar drasticamente toda a rede. Antes de fazer qualquer alteração no nome de domínio do DNS, converse com o administrador da rede.
Para verificar o nome de domínio do DNS do computador local

  1. Clique com o botão direito em Meu Computador e clique em Propriedades. A caixa de diálogo Propriedades do Sistema será exibida.

  2. Clique na guia Nome do Computador.

  3. Clique em Alterar. A caixa de diálogo Alterações no Nome do Computador será exibida.

  4. Clique em Mais. A caixa de diálogo Sufixo DNS e Nome NetBIOS do Computador será exibida.

  5. Verifique se somente caracteres no intervalo de 'A-Z', 'a-z','0-9', '.' e '-' são usados.

  6. Marque a caixa de seleção Alterar sufixo de DNS primário quando a associação do domínio for alterada.

  7. Clique em OK para salvar as alterações e, em seguida, clique em OK para sair da caixa de diálogo Alterações no Nome do Computador.

  8. Clique em OK para fechar a caixa de diálogo Propriedades do Sistema e reinicie o computador para que todas as alterações entrem em vigor.

Para obter mais informações sobre Nomes DNS, consulte o artigo 909264 da Base de Dados de Conhecimento da Microsoft, "Convenções de nomenclatura no Active Directory para computadores, domínios e OUs" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264).


Caminho de instalação inválido
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois houve falha na tentativa de instalar uma função de servidor Caixa de Correio em Cluster ou servidor Caixa de Correio em uma unidade de cluster compartilhada.

A instalação do Exchange exige que as funções do Exchange Server sejam instaladas em uma unidade que não seja um recurso de cluster compartilhado.

Para resolver esse problema, instale a função de servidor Caixa de Correio ou servidor Caixa de Correio em cluster em um caminho não designado como uma unidade de cluster compartilhada.

Para obter mais informações sobre como armazenar configurações em cluster, consulte "Alta disponibilidade" (http://go.microsoft.com/fwlink/?linkid=68190) na documentação do produto do Exchange Server 2007).


Formato inválido de caminho de destino do CMS
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois houve falha na tentativa de instalar a Função de Servidor Caixas de Correio em Cluster em uma unidade de cluster compartilhada.

O parâmetro /CMSDataPath: <Caminho_para_o_Banco_de_Dados> enviado estava em um formato UNC inválido. A instalação do Exchange exige que o parâmetro /CMSDataPath: <Caminho_para_o_Banco_de_Dados> especificado utilize uma atribuição de letra de unidade válida; por exemplo, /CMSDataPath: s:\<Caminho_para_o_Banco_de_Dados>, e não o formato UNC.

Para resolver esse problema, utilize uma atribuição de letra de unidade válida para o parâmetro /CMSDataPath: <Caminho_para_o_Banco_de_Dados>.

Para obter mais informações sobre como instalar o servidor de Caixas de Correio em cluster, consulte "Como instalar a Função de Servidor Caixa de Correio no nó ativo" (http://go.microsoft.com/fwlink/?LinkId=86624) (em inglês) na documentação do produto Exchange Server 2007.


A versão instalada do MOUNTMGR.SYS é incompatível com o Exchange Server
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

O programa de Instalação do Microsoft® Exchange Server 2007 não pode continuar porque a versão instalada do Mountmgr.sys é incompatível com o Microsoft Exchange.

O programa de Instalação do Exchange 2007 exige que o nó do cluster tenha instalada a atualização mencionada no artigo 898790 da Base de Dados de Conhecimento da Microsoft.

A versão do Mountmgr.sys instalada no nó de cluster pode causar falhas de ponto de montagem de volume. Esse problema acontece por causa de um problema no driver Mountmgr.sys. Esse é um problema de tempo intermitente que pode ocorrer quando um volume chega para ser montado em um ponto de montagem.

Para resolver esse problema, instale a atualização mencionada no artigo 898790 da Base de Dados de Conhecimento da Microsoft (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790) e execute a Instalação do Exchange 2007 novamente.

Para obter mais informações sobre esse problema, consulte o artigo 898790 da Base de Dados de Conhecimento Microsoft, "Volume mount points on disks in a server cluster may intermittently become unavailable after you install Windows Server 2003 Service Pack 1" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790).


A versão instalada do TCPIP.SYS é incompatível com o Exchange Server
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

Não é possível continuar a instalação do Microsoft® Exchange Server 2007 porque a versão instalada do Tcpip.sys é incompatível com o Microsoft Exchange.

A instalação do Exchange 2007 exige que o computador local tenha a atualização citada no artigo 898060 da Base de Dados de Conhecimento Microsoft instalada.

Esta máquina está executando atualmente o driver Tcpip.sys do Windows Server™ 2003 Service Pack 1. Esse driver pode causar problemas de conectividade em redes de longa distância.

Para resolver esse problema, instale a atualização citada pelo artigo 898060 da Base de Dados de Conhecimento Microsoft , em "Atualização para o Windows Server x64 Edition (KB898060)" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=59272), e execute novamente a instalação do Exchange 2007.

Para obter mais informações sobre esse aviso, consulte o artigo 898060 da Base de Dados de Conhecimento Microsoft, "A instalação da atualização de segurança MS05-019 ou do Windows Server 2003 Service Pack 1 pode fazer com que a conectividade de rede entre clientes e servidores falhe" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=898060).


Detectado modelo de organização grande do Exchange
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-08-10

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para obter o número de grupos de roteamento presentes na organização do Exchange. O Exchange Server Analyzer também consulta o Active Directory para obter o número de sites do Active Directory que contêm servidores Exchange executando o Microsoft Exchange 2000 Server ou Microsoft Exchange Server 2003.

O Exchange Server Analyzer classificará a organização do Exchange como uma organização grande do Exchange, se as seguintes condições forem verdadeiras:

  • Existem mais de 5 grupos de roteamento na organização do Exchange.

  • Os servidores executando o Exchange 2000 ou Exchange 2003 estão instalados em mais de 5 sites do Active Directory.

Para fazer a transição de uma organização grande do Exchange para o Exchange 2007

  1. Acesse a documentação do produto Microsoft Exchange Server 2007 on-line (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Examine o tópico "Planejando uma organização grande do Exchange" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=70504).


O computador local é um controlador de domínio de um domínio filho
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-12-29

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o computador local é um controlador de domínio para um domínio filho.

A instalação do Exchange 2007 não será feita em um controlador de domínio para um domínio filho, a menos que o controlador de domínio seja um servidor de catálogo global.

Para resolver este problema, promova o controlador de domínio a um servidor de catálogo global ou instale o Exchange 2007 em um controlador que não seja de domínio, um servidor de membro, no domínio filho, e execute novamente a instalação do Microsoft Exchange.

Para corrigir esse aviso fazendo do servidor Exchange um servidor de catálogo global

  1. No controlador de domínio, clique em Iniciar, aponte para Programas, clique em Ferramentas Administrativas e, em seguida, clique em Sites e Serviços do Active Directory.

  2. Na árvore do console, clique duas vezes em Sites, duas vezes no nome do site e duas vezes em Servidores.

  3. Clique duas vezes no controlador de domínio de destino.

  4. No painel de resultados, clique com o botão direito em Configurações NTDS e clique em Propriedades.

  5. Na guia Geral, marque a caixa de seleção Catálogo global.

  6. Reinicie o controlador de domínio.


O computador local já está executando o Exchange Server
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-01-15

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o computador local possui componentes do Microsoft Exchange anterior instalados.

A instalação do Exchange 2007 exige que o computador local não tenha componentes existentes do Microsoft Exchange instalados.

Para resolver essse problema, remova todos os componentes do Microsoft Exchange 2000 Server ou Microsoft Exchange Server 2003, depois reexecute a instalação do Microsoft Exchange.

Para remover componentes do Microsoft Exchange

  1. Clique em Iniciar, aponte para Configurações e clique em Painel de Controle.

  2. Clique duas vezes em Adicionar ou Remover Programas.

  3. Na lista Programas instalados, clique em Microsoft Exchange e depois em Alterar/Remover.

  4. No Assistente para Instalação do Microsoft Exchange, clique em Avançar.

  5. Na lista Ação na página Seleção de Componente, clique na seta para baixo, ao lado de cada componente instalado, e clique em Remover.

    Observação:
    Os componentes instalados têm uma marca de seleção ao lado, na lista Ação. Quando você clicar em Remover, a marca de seleção será substituída pela palavra Remover.

  6. Clique em Avançar duas vezes.

  7. Clique em Concluir.


O computador local não está executando o Windows Server 2003 Service Pack 1 ou posterior.
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-05

A instalação do Microsoft Exchange Server 2007 não pode continuar porque o computador local não está executando o Microsoft Windows Server™ 2003 Service Pack 1 (SP1) ou uma versão posterior.

A instalação do Exchange 2007 exige que o computador usado para o Microsoft Exchange esteja executando o Windows Server 2003 SP1 ou uma versão posterior.

Para resolver esse problema:

  • Execute a instalação do Exchange 2007 de um computador que esteja executando o Windows Server 2003 SP1 ou uma versão posterior.

  • Atualize o computador que deseja que execute a instalação do Exchange 2007 do Windows Server 2003 SP1 ou uma versão posterior.

Para obter mais informações sobre como atualizar o Windows Server 2003, consulte o artigo 810613 da Base de Dados de Conhecimento da Microsoft, "Caminhos com suporte para atualização para o Windows Server 2003 ou o Windows Small Business Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613).

Para obter o service pack mais recente do Windows Server 2003, consulte o Windows Server TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315).


O computador local é responsável por expandir a associação de grupo
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

Não é possível continuar a instalação do Microsoft® Exchange Server 2007 porque ocorreu uma falha ao tentar desinstalar uma função de Transporte de Hub responsável pela expansão da associação de grupo.

A instalação do Exchange 2007 exige que a expansão da lista de distribuição seja removida do servidor Bridgehead atual antes que a função de Transporte de Hub seja desinstalada.

A expansão de listas de distribuição possibilita a identificação de destinatários individuais que pertencem à lista de distribuição a ser identificada ou a identificação de listas de distribuição adicionais para expansão. Uma lista de distribuição expandida pode retornar o caminho para qualquer notificação de status de entrega necessária. As notificações de status de entrega notificam o administrador do Microsoft Exchange ou o remetente do email sobre o status de uma mensagem de email específica. Além disso, a expansão da lista de distribuição identifica se as mensagens de Ausência Temporária ou respostas geradas automaticamente devem ser enviadas ao remetente da mensagem original.

Para resolver esse problema, mova a expansão do grupo de distribuição para outro servidor e execute a instalação do Microsoft Exchange novamente.

Para alterar o servidor de expansão para um grupo de distribuição ou grupo dinâmico de distribuição

  1. Abra o Console de Gerenciamento do Exchange.

  2. Na árvore do console, expanda Configuração de Destinatário.

  3. Na árvore do console, clique em Grupo de Distribuição.

  4. Crie um filtro para exibir todos os grupos de distribuição e grupos dinâmicos de distribuição que usam o servidor Bridgehead atual como um servidor de expansão.

    1. No painel de ações, clique em Criar Filtro.

    2. Na lista suspensa de propriedade, clique em Servidor de Expansão.

    3. Na lista suspensa do operador, clique em É Igual.

    4. Na caixa de valores, clique no botão Procurar para selecionar o servidor Bridgehead que, no momento, está atuando como o servidor de expansão.
Observação:
A etapa a seguir é opcional.
  1. Clique em Adicionar Expressão para especificar os critérios de filtragem adicionais. Apenas mensagens que atendem a todos os critérios de filtro serão exibidas.

  2. Clique em Aplicar Filtro. Os resultados que atendem aos critérios do filtro são exibidos.

  1. No painel de resultados, clique no grupo de distribuição para o qual deseja alterar o servidor de expansão e clique em Propriedades no painel de ações.

  2. Em Propriedades, clique na guia Avançado.

  3. Na lista suspensa Servidor de expansão, selecione um servidor específico da lista ou selecione Qualquer servidor na organização.

  4. Repita as etapas 5 a 7 para todos os grupos de distribuição ou para grupos dinâmicos de distribuição que estão usando o servidor Bridgehead como seu servidor de expansão.


O computador local é responsável pela geração do catálogo de endereços offline
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

Não é possível continuar a instalação do Microsoft® Exchange Server 2007 porque ocorreu uma falha ao tentar desinstalar uma função de Caixa de Correio, responsável pela geração do catálogo de endereços offline.

A instalação do Exchange 2007 exige que, a menos que a função de Caixa de Correio seja a última na organização do Exchange, a geração do catálogo de endereços offline seja removida do servidor atual de Caixa de Correio, antes da desinstalação dessa função.

Para resolver esse problema, mova a geração do catálogo de endereços offline para outro servidor e execute novamente a instalação do Microsoft Exchange.

Para mover a geração do catálogo de endereços offline usando o Gerenciador do Sistema do Exchange

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Em Destinatários, clique em Listas de Endereços Offline.

  3. No painel direito, clique com o botão direito em Lista de Endereços Offline Padrão e clique em Propriedades.

    Observação:
    Use o mesmo procedimento para qualquer outra lista de endereços offline que produza esta mensagem.

  4. Na guia Geral, em Servidor da lista de endereços offline, clique em Procurar e clique no servidor Exchange que deseja usar.
Para mover a geração do catálogo de endereços offline usando o Console de Gerenciamento do Exchange

  1. Abra o Console de Gerenciamento do Exchange.

  2. Expanda Microsoft Exchange, expanda Configuração da Organização e selecione Caixa de Correio.

  3. No painel de resultados, clique na guia Catálogo de Endereços Offline.

  4. Na guia Catálogo de Endereços Offline, selecione o catálogo de endereços offline a ser movido. No painel de ações, clique em Mover.

  5. Depois que o Assistente para Mover Catálogo de Endereços Offline for exibido, selecione o novo servidor para hospedar a geração do catálogo de endereços offline usando o botão Procurar e, em seguida, clique em Mover.

  6. Para fechar o assistente, clique em Concluir.
Para usar o Shell de Gerenciamento do Exchange para mover a geração do catálogo de endereços offline

  • Execute o seguinte comando:

    Código da Cópia
    Move-OfflineAddressBook -Identity <OfflineAddressBookIdParameter> -Server <ServerIdParameter> [-DomainController <String>]


O computador local está executando a função de Transporte de Borda
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque sua tentativa de instalar uma função do Exchange 2007 encontrou a função de Servidor de Gateway já instalada nesse servidor.

A instalação do Exchange 2007 não pode instalar outras funções de servidor em um servidor que tenha a função de Servidor de Gateway do Microsoft Exchange instalada.

A função de Servidor de Gateway do Microsoft Exchange é implantada na rede de perímetro da organização, processa todo o fluxo de mensagens voltado para a Internet e oferece a criptografia e a descriptografia de mensagens enviadas entre organizações confiáveis do Microsoft Exchange, além de proteção contra spam.

Para resolver esse problema, instale as outras funções do Microsoft Exchange 2007 em um computador que não tenha a função de Servidor de Gateway instalada.


O computador local está executando Windows Server 2003 Web Edition
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o computador local está executando o Microsoft Windows Server ™ 2003, Web Edition.

A instalação do Exchange 2007 exige que você instale o Microsoft Exchange em um computador que executa um sistema operacional com suporte.

Para resolver esse problema, instale o Microsoft Exchange em uma edição diferente de Web Edition do Windows Server 2003 Service Pack 1 (SP1) ou mais recente.


O domínio local precisa ser atualizado
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois o usuário conectado não possui as permissões de conta necessárias para a preparação do domínio.

A instalação do Exchange exige que o usuário conectado quando Setup /PrepareDomain é executado seja um membro dos grupos Administradores da Organização do Exchange e Administradores de Domínio ou do grupo Administração de Empresa.

Para resolver esse problema, conceda ao usuário conectado permissões de Admins. do Domínio e Administrador da Organização do Exchange, registre-os no grupo Administração de Empresa. Você também pode fazer logon com uma conta que tenha essas permissões e executar novamente a instalação do Exchange 2007.

Para obter mais informações sobre permissões do Active Directory necessárias com o Microsoft Exchange, consulte "Trabalhando com permissões do Active Directory no Exchange Server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=47592).


Não é possível acessar a metabase local
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

A instalação do Microsoft® Exchange Server 2007 não pode continuar, pois não foi possível ler os dados da metabase local.

A instalação do Exchange 2007 exige que a instalação das funções de Servidor de Caixa de Correio ou Acesso para Cliente consiga ler a partir da metabase do IIS (Serviços de Informações da Internet) da Microsoft.

A metabase do IIS inclui informações que afetam o Microsoft Exchange, como configurações de protocolo para HTTP, diretórios virtuais para acesso a caixas de correio e dispositivos móveis e configurações de segurança HTTP.

Para resolver esse problema, verifique se o IIS está instalado corretamente e execute novamente a instalação do Microsoft Exchange.

Para verificar se o IIS está instalado corretamente, consulte os seguintes recursos:

  • Artigo 843093 da Base de Dados de Conhecimento Microsoft, "Como solucionar problemas de danificação da metabase do IIS em um computador baseado no Windows 2000 Server em execução no Exchange 2000 Server ou Exchange Server 2003" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=843093).

  • Artigo 240225 da Base de Dados de Conhecimento Microsoft, "Descrição dos utilitários Adsutil e MetaEdit usados para modificar a metabase" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225).

  • Artigo 317678 da Base de Dados de Conhecimento Microsoft, "COMO: Reiniciar o IIS (Serviços de Informações da Internet) no Exchange 2000 Server" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678).

Se a orientação nesses recursos não resolverem o problema, talvez você precise desinstalar e reinstalar o IIS.

Para desinstalar o IIS usando Adicionar ou Remover um Componente do Windows no Painel de Controle

  1. No menu Iniciar, clique em Painel de Controle.

  2. Clique duas vezes em Adicionar ou Remover Programas.

  3. Clique em Adicionar/Remover Componentes do Windows.

  4. Na lista Componentes, clique na caixa de seleção Servidor de Aplicativos.

  5. Clique em Detalhes.

  6. Clique em Gerenciador de Serviços de Informações da Internet.

  7. Clique em Avançar.

  8. Clique em Concluir quando o IIS estiver desinstalado.
Para instalar o IIS usando o Painel de Controle

  1. No menu Iniciar, clique em Painel de Controle.

  2. Clique duas vezes em Adicionar ou Remover Programas.

  3. Clique em Adicionar/Remover Componentes do Windows.

  4. Na lista Componentes, clique na caixa de seleção Servidor de Aplicativos.

  5. Clique em Detalhes.

  6. Clique na caixa de seleção Gerenciador de Serviços de Informações da Internet.

  7. Clique em OK até retornar ao Assistente de Componentes do Windows.

  8. Clique em Avançar e conclua o Assistente de Componentes do Windows.


O usuário conectado não é um membro do grupo Administradores local.
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o usuário conectado não é um membro do grupo de administradores do computador local.

A instalação do Exchange 2007 exige que o usuário conectado que instalar o Microsoft Exchange tenha acesso completo ao computador local.

Para resolver esse problema, faça logon no computador usando uma conta que tenha acesso de administrador local e execute a instalação do Microsoft Exchange novamente.


O usuário conectado não é um membro do grupo Administradores do Esquema
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-09-06

Não é possível continuar a instalação do Microsoft® Exchange Server 2007 porque o processo de atualização de esquemas não possui credenciais administrativas do Esquema do serviço de diretório do Active Directory® e credenciais administrativas da Empresa.

A instalação do Exchange 2007 exige que o usuário conectado que instala o Microsoft Exchange tenha credenciais administrativas do Esquema e da Empresa para a floresta do Active Directory.

Como parte do processo de instalação, a instalação do Microsoft Exchange estende o esquema do Active Directory para adicionar classes e atributos específicos do Exchange 2007.

Se o usuário conectado não tiver direitos administrativos da Empresa e de Administrador do Esquema, o processo de atualização de esquemas falhará.

Para resolver esse problema, adicione o usuário conectado aos grupos Administradores do Esquema e Administradores da Empresa, faça logoff e logon novamente, ou faça logoff e logon com uma conta que tenha credenciais administrativas do Esquema e da Empresa para a floresta do Active Directory.


Muitos nós ativos
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-23

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois houve falha na tentativa de criar uma nova função de servidor de Caixas de Correio em Cluster Ativas.

O Exchange Server 2007 exige que pelo menos um nó do cluster seja passivo para oferecer suporte a recuperação de falhas.

Para resolver esse problema, primeiro instale outra função de servidor Caixas de Correio em Cluster no ambiente e, em seguida, execute a instalação novamente.

Para obter mais informações sobre como instalar nós ativos e passivos, consulte "Alta disponibilidade" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=68190) na documentação do produto do Exchange Server 2007.


A especificação da unidade de banco de dados da caixa de correio está ausente
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-05-15

A instalação da Recuperação de Desastres do Microsoft® Exchange Server 2007 não pode continuar porque não é possível acessar a especificação da unidade do banco de dados de caixa de correio que foi usada na instalação anterior deste servidor.

A instalação da Recuperação de Desastres do Microsoft Exchange exige que as mesmas especificações de unidade de banco de dados de caixa de correio usadas anteriormente para este servidor estejam disponíveis durante a restauração.

Para resolver essa situação, configure as unidades para que correspondam à configuração da unidade lógica original e execute a instalação da Recuperação de Desastres do Microsoft Exchange novamente.

Atribuir ou alterar uma letra de unidade

  1. Abra Gerenciamento de Computador (Local).

  2. Na árvore do console, clique em Gerenciamento de Computador (Local), clique em Armazenamento e Gerenciamento de Disco.

  3. Clique com o botão direito em uma partição, unidade lógica ou volume e clique em Alterar Letras e Caminhos de Unidade.

  4. Use um dos procedimentos a seguir:

    • Para atribuir uma letra de unidade, clique em Adicionar, clique na letra de desejada e clique em OK.

    • Para modificar uma letra de unidade, clique nela, clique em Alterar, clique na letra de unidade que você deseja usar e clique em OK.

Para obter mais informações sobre como atribuir letras de unidade, consulte "Assign, change, or remove a drive letter" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=66764).


As mensagens atualmente existem em uma ou mais filas
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-05

A instalação do Microsoft® Exchange Server 2007 exibe este aviso porque uma tentativa de desinstalar uma função de transporte pode ocasionar perda de dados em uma fila de transporte.

A instalação do Exchange 2007 verifica se as filas de transporte estão vazias, antes de remover as funções associadas aos gerenciamento dessas filas.

Se você remover as funções de transporte antes da entrega das mensagens que ainda aguardam nas filas de transporte, é possível que essas mensagens sejam mantidas indefinidamente.

Para resolver esse problema, inspecione as filas mencionadas para verificar se elas estão vazias de mensagens antes de continuar a instalação.

Para exibir o conteúdo de uma fila

  1. Abra o Console de Gerenciamento do Exchange.

  2. Na árvore do console, clique em Caixa de Ferramentas.

  3. No painel de resultados, clique em Visualizador de Filas do Exchange.

  4. No painel de ações, clique em Abrir Ferramenta.

  5. No Visualizador de Filas, clique na guia Filas. É exibida uma lista de todas as filas no servidor ao qual você está conectado.

  6. Clique com o botão direito na fila desejada e selecione Propriedades para exibir as propriedades da fila.
Para exibir mensagens em uma fila

  1. Siga as etapas 1 a 4.

  2. No Visualizador de Filas, clique na guia Mensagens. É exibida uma lista de todas as mensagens no servidor ao qual você está conectado. Para ajustar a exibição a uma única fila, clique na guia Filas, clique duas vezes no nome da fila e clique na guia Servidor\Fila exibida.

  3. Para exibir informações detalhadas sobre uma mensagem, selecione uma mensagem e, no painel de ações, clique em Propriedades.


Atualização do Microsoft .NET Framework necessária
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-02-26

Não é possível continuar a instalação do Microsoft Exchange Server 2007 porque o computador local exige uma atualização de software.

A instalação do Exchange 2007 exige que a atualização adequada do Microsoft .NET Framework aqui mencionada esteja instalada no computador local.

Para resolver esse problema, saia da instalação do Exchange 2007, baixe e instale a atualização apropriada (32 ou 64 bits) das URLs a seguir e, em seguida, execute novamente a instalação do Exchange 2007.

Observação:
Ao clicar nos links a seguir, você será solicitado a baixar os arquivos diretamente.
  • Download de 64 bits, http://go.microsoft.com/fwlink/?linkid=74465

  • Download de 32 bits, http://go.microsoft.com/fwlink/?linkid=74469


Microsoft Core XML Services (MSXML) 6.0 necessário
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-08-21

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o Microsoft Core XML Services (MSXML) 6.0 não está instalado neste servidor.

Para todas as instalações de funções do servidor de Unificação de Mensagens, a instalação do Exchange 2007 exige que o MSXML 6.0 esteja instalado no computador para oferecer suporte para os serviços de fala da Microsoft.

Para resolver esse problema, instale o software do MSXML 6.0 a partir de http://go.microsoft.com/fwlink/?LinkId=70796 e execute novamente a instalação do Exchange 2007.


O caminho MNSFileShare é inválido
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois o caminho MNSFileShare é inválido.

O valor de MNSFileShare deve ser definido como um valor de cadeia de caracteres que contenha o caminho UNC de um compartilhamento de arquivo externo ao cluster, como \\servidor\nomedocompartilhamento.

Para resolver esse problema, forneça um valor para a propriedade MNSFileShare que seja um caminho UNC válido.

Para obter mais informações sobre como configurar a propriedade MNSFileShare, consulte "Como configurar a testemunha de compartilhamento de arquivos" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=78278).


Atualização de MSDAPS.DLL necessária
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-12-05

Não é possível continuar a instalação do Microsoft® Exchange Server 2007, pois o computador local exige uma atualização do software.

A instalação do Exchange 2007 exige que a atualização de MSDAPS.DLL mencionada a seguir esteja instalada no computador local.

Para resolver esse problema, baixe e instale a atualização vinculada a seguir e execute novamente a instalação do Exchange 2007.

  • http://go.microsoft.com/fwlink/?linkid=74467


O Network News Transport Service está instalado no momento
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-01-22

A Instalação do Microsoft® Exchange Server 2007 não pode continuar porque o serviço NNTP (Network News Transport Protocol) do Microsoft Windows® Server™ 2003 está instalado neste computador.

A Instalação do Microsoft Exchange exige que o serviço NNTP não esteja instalado em servidores que são usados para o Exchange 2007.

Para resolver esse problema, desinstale o serviço NNTP e execute novamente a Instalação do Microsoft Exchange.

Para desinstalar o serviço NNTP usando Adicionar ou Remover um Componente do Windows no Painel de Controle

  1. No menu Iniciar, clique em Painel de Controle.

  2. Clique duas vezes em Adicionar ou Remover Programas.

  3. Clique em Adicionar/Remover Componentes do Windows.

  4. Na lista Componentes, marque a caixa de seleção Servidor de Aplicativo e clique em Detalhes.

  5. Selecione Gerenciador dos Serviços de informações da Internet e clique em Detalhes.

  6. Selecione Serviço NNTP e clique para desmarcar a caixa de seleção.

  7. Clique em OK duas vezes para retornar à lista Componentes e clique em Avançar.

  8. Clique em Concluir quando o serviço NNTP estiver desinstalado.


Nenhuma função de servidor Acesso para Cliente encontrada
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-02-16

A ferramenta Microsoft Exchange Analyzer consulta o serviço de diretório do Active Directory em busca do valor de qualquer objeto da classe msExchAdminGroupContainer na organização do Exchange que contém o identificador de Grupo Administrativo específico do Exchange Server 2007, FYDIBOHF23SPDLT.

Se o Exchange Analyzer determinar que existe um grupo administrativo do Exchange Server 2007 na organização do Exchange, ele consultará todos os sites do Active Directory na organização em busca do valor do atributo msExchCurrentServerRoles para cada objeto msExchExchangeServer para determinar se há uma função de servidor Caixa de Correio instalada em um dos sites encontrados.

Por fim, se o Exchange Analyzer determinar a existência de uma função de servidor Caixa de Correio instalada em um site, ele consultará o atributo msExchCurrentServerRoles de cada objeto msExchExchangeServer nesse site para descobrir se há também uma função de servidor Acesso para Cliente instalada nesse mesmo site.

O Exchange Analyzer exibirá um aviso se detectar a existência de uma função de servidor Caixa de Correio instalada em um site do Active Directory que não tenha instalada a função de servidor Acesso para Cliente.

Esse aviso indica que, embora haja uma função de servidor Caixa de Correio instalada no site do Active Directory, os clientes de acesso de dispositivo móvel do Microsoft Office Outlook Web Access e do Exchange ActiveSync não conseguirão acessar seus emails nesse servidor de Caixa de Correio até que pelo menos uma função de servidor Acesso para Cliente esteja instalada no site.

A função de servidor Acesso para Cliente aceita conexões com o servidor Exchange 2007 em diversos clientes. Softwares clientes como Microsoft Outlook Express e Eudora usam conexões POP3 ou IMAP4 para se comunicar com o servidor Exchange. Hardwares clientes, como dispositivos móveis, usam ActiveSync, POP3 ou IMAP4 para se comunicar com o servidor Exchange.

Se os usuários acessarem suas caixas de entrada usando um cliente diferente do Microsoft Outlook, você deverá instalar a função de servidor Acesso para Cliente na organização do Exchange.

Para resolver esse aviso, se você tiver clientes que não usam o Microsoft Outlook que precisam acessar caixas de correio, instale a função de servidor Acesso para Cliente nos sites que têm uma função de servidor Caixa de Correio instalada.

Para obter mais informações

Para obter mais informações sobre como instalar a função de servidor Acesso para Cliente em um site, consulte "Implantando funções de servidor" (http://go.microsoft.com/fwlink/?LinkId=83282) (página em inglês) na documentação do produto Exchange Server 2007.


Espaço de endereçamento não padrão encontrado
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-08-21

A ferramenta Microsoft® Exchange Server Analyzer ao detectar a existência de um espaço de endereçamento não padrão em uma ou mais diretivas de destinatário.

Um espaço de endereço não padrão, ou proxy, é o endereço através do qual um objeto destinatário do Exchange Server é reconhecido em um sistema de mensagens externo.

Em versões anteriores do Exchange Server, o Serviço de Atualização de Destinatário era o responsável pelo suporte aos espaços de endereçamento não padrão.

No Microsoft Exchange Server 2007, o Serviço de Atualização de Destinatário não está implementado. O console administrativo do Exchange 2007 é responsável por gerar endereços proxy.

Os consoles administrativos devem ter uma DLL geradora de proxies carregada para cada espaço de endereçamento não padrão detectado.

Importante:
Se o console administrativo for executado em um computador de 64 bits, será necessária uma versão de 64 bits da DLL geradora de proxies.

Para resolver este aviso, entre em contato com o fornecedor que oferece suporte para o espaço de endereçamento externo e obtenha a DLL geradora de proxies compatível com o Exchange 2007.


Não pertencente ao site/domínio do controlador de esquemas
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-08-10

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o computador executando a instalação não está no mesmo site ou domínio do serviço de diretório do Active Directory® que o servidor que recebeu a atribuição da função de controlador de esquemas de domínio, também conhecido como operação principal única flexível ou FSMO.

A instalação do Exchange 2007 exige que o controlador de domínios que funciona como o controlador de esquemas de domínio esteja no mesmo site e domínio do computador local executando a instalação do Exchange.

O controlador de esquemas de domínio controla todas as atualizações e modificações no esquema do Active Directory.

Para resolver esse problema, execute a instalação do Exchange Server 2007 a partir do mesmo site e domínio do controlador de esquemas de domínio.

Você pode usar a ferramenta Controlador de Esquemas para identificar a função. Contudo, a DLL Schmmgmt.dll deve ser registrada para que a ferramenta Esquema esteja disponível como um snap-in MMC.

Para exibir o controlador de esquemas atual

  1. Em um prompt de comando, digite regsvr32 schmmgmt.dll.

    Observação:
    RegSvr32 estará registrada com êxito quando a seguinte caixa de diálogo for exibida:

    Êxito de DllRegisterServer em schmmgmt.dll.

  2. Para abrir um novo console de gerenciamento, clique em Iniciar, Executar e digite mmc.

  3. No menu Console, clique em Adicionar/Remover Snap-in.

  4. Clique em Adicionar para abrir a caixa de diálogo Adicionar Snap-in Autônomo.

  5. Selecione Esquema do Active Directory e clique em Adicionar.

  6. O "Esquema do Active Directory" é exibido em Adicionar/Remover Snap-in. Clique em Fechar e depois em OK para voltar ao console.

  7. Selecione Esquema do Active Directory para que as seções Classes e Atributos sejam exibidas no lado direito.

  8. Clique com o botão direito em Esquema do Active Directory e clique em Mestre de Operações.

  9. O controlador de esquemas atual é exibido


Nenhum controlador de domínio do Windows Server 2003 SP1 no domínio
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

A instalação do Microsoft Exchange Server 2007 não pode continuar porque o processo setup /PrepareLegacyExchangePermissions não conseguiu localizar um controlador de domínio que esteja executando o Microsoft Windows Server 2003 Service Pack 1 (SP1) ou uma versão posterior no domínio que está sendo preparado.

Em cada domínio em que você executará setup /PrepareLegacyExchangePermissions, a instalação deve contatar um controlador de domínio do Windows Server 2003 SP1. Setup /PrepareLegacyExchangePermissions não será concluído com êxito se não puder localizar pelo menos um controlador de domínio Windows Server 2003 SP1.

A execução do comando setup /PrepareLegacyExchangePermissions permite que o Serviço de Atualização de Destinatário herdado funcione corretamente. Antes de importar o novo esquema do Exchange 2007, o Exchange 2007 deve conceder novas permissões em cada domínio que você executou o DomainPrep do Exchange Server 2003 ou Exchange 2000 Server. O comando setup /PrepareLegacyExchangePermissions concede essas novas permissões.

Para resolver esse problema, atualize pelo menos um controlador de domínio em cada domínio onde você executará o setup /PrepareLegacyExchangePermissions para o Windows Server 2003 SP1 ou uma versão posterior, e execute a Instalação novamente.

Para obter mais informações sobre como preparar as permissões do Exchange herdadas, consulte "Preparando permissões herdadas do Exchange" (http://go.microsoft.com/fwlink/?linkid=81776) na documentação do produto Exchange Server 2007.


O servidor OAB foi excluído
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-21

A instalação do Microsoft Exchange Server 2007 não pode continuar porque sua tentativa de instalar a função de servidor Acesso para Cliente falhou. O servidor de Caixa de Correio do Exchange designado para hospedar o OAB (Catálogo de Endereços Offline) foi excluído.

A instalação do Exchange 2007 exige que haja um servidor válido de Caixa de Correio do Exchange que hospede a geração do OAB para que a instalação da função de servidor Acesso para Cliente continue.

Para resolver esse problema, designe um servidor válido de Caixa de Correio do Exchange como o host de geração do OAB e execute novamente a instalação do Exchange 2007.

Para obter informações sobre como designar um servidor Exchange para ser o host de geração do Catálogo de Endereços Offline, consulte "Como criar um Catálogo de Endereços Offline" (http://go.microsoft.com/fwlink/?LinkId=86314) na documentação do produto Exchange 2007.


Arquivos de bancos de dados mais antigos presentes
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

A Instalação do Microsoft® Exchange Server 2007 não pode continuar porque detectou arquivos de banco de dados do Microsoft Exchange existentes no caminho de instalação de destino.

A Instalação do Exchange 2007 exige que o caminho de instalação de destino esteja sem arquivos de banco de dados do Microsoft Exchange.

Para resolver esse problema, remova todos os arquivos existentes dos caminhos de instalação e execute novamente a Instalação.

Para excluir os arquivos de banco de dados existentes do Exchange Server do caminho de instalação de destino

  1. Em Meu Computador ou no Windows Explorer, localize o caminho de destino.

    Observação:
    Por padrão, os arquivos de banco de dados estão localizados em:

    <systemDrive>:\Arquivos de Programas\Microsoft\Exchange Server\Mailbox\First Storage Group.

  2. Clique com o botão direito nos arquivos a serem removidos e selecione Excluir.

  3. Na caixa de diálogo Confirmar Exclusão de Arquivo, clique em Sim.

  4. Repita as etapas 2 e 3 de todos os arquivos nos caminhos de instalação de destino.


Versão mais antiga do ADAM detectada
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

A instalação do Microsoft® Exchange Server 2007 exibe este aviso porque sua tentativa de instalar a função de Servidor de Gateway detectou uma versão mais antiga do ADAM (Active Directory® Application Mode) no servidor atual.

ADAM é um serviço de diretório LDAP (Lightweight Directory Access Protocol) elaborado especificamente para ser usado com aplicativos habilitados para diretório. O ADAM armazena e replica apenas as informações específicas do aplicativo e não requer implantação em um controlador de domínio nem depende do serviço do Active Directory. O ADAM não fornece autenticação ou autorização de sistema operacional de rede.

No Exchange 2007, o servidor de gateway usa o ADAM para armazenar informações de configuração. Quando o ADAM está sincronizado com o Active Directory, também é possível usá-lo para fazer pesquisa de destinatários para segurança de mensagens.

A instalação do Exchange 2007 atualizará automaticamente a instalação do ADAM para a versão Service Pack 1 (SP1).

Nenhuma ação será necessária, a menos que você não queira atualizar o ADAM. Nesse caso, você não deverá instalar a função de Servidor de Gateway no computador local.


Um ou mais servidores Active Directory Connector foram encontrados
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque um ou mais ADCs (Conectores do Active Directory) foram encontrados no ambiente atual do Microsoft Exchange.

O ADC replica objetos do Exchange Server versão 5.5 para o serviço de diretório do Active Directory® em um ambiente no modo misto do Microsoft Exchange e não tem suporte no Exchange 2007.

A instalação do Exchange 2007 exige a remoção de todos os componentes do ADC.

Para resolver esse problema, remova todos os componentes do ADC e execute novamente a instalação do Exchange 2007.

Para remover componentes do ADC (Conector do Active Directory)

  1. Para desabilitar o serviço ADC no servidor executando o serviço ADC, clique com o botão direito em Meu Computador na área de trabalho e clique em Gerenciar.

  2. Expanda o nó Serviços e Aplicativos e clique no nó Serviços.

  3. No painel da direita, clique com o botão direito em Conector do Microsoft Active Directory e clique em Propriedades.

  4. Altere o Tipo de Inicialização para Desabilitado. Na próxima inicialização do computador, o serviço ADC não será iniciado.

  5. Clique em Aplicar e em OK.

  6. Para desinstalar o serviço ADC, use o Assistente para Instalação do Active Directory, contido no CD do Microsoft Exchange 2000 Server ou do Microsoft Exchange Server 2003. Abra a pasta \ADC\I386 e clique duas vezes no programa Setup.exe. Siga os avisos para remover todos os componentes do serviço ADC.

    Importante:
    Conclua a etapa 6 e remova todos os componentes ADC para resolver o problema. Não basta desabilitar o serviço ADC.

Para obter mais informações sobre o ADC, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • 325300, "Suporte WebCast: Introdução ao Conector do Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300).

  • 325221, "Suporte WebCast: Conector Avançado do Microsoft Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221).

  • 312632, "Como instalar e configurar o Conector do Active Directory no Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632).


Somente um servidor de CCR permitido
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois houve falha na tentativa de criar um novo servidor de caixas de correio em cluster.

O Exchange Server 2007 exige que exista apenas um servidor de caixas de correio em cluster para replicação contínua em cluster no cluster CCR (replicação contínua em cluster). Já existe um servidor de caixas de correio em cluster nesse cluster CCR.

Para resolver esse problema, não tente instalar nesse cluster um servidor de caixa de correio em cluster adicional para replicação contínua em cluster.

Para obter mais informações sobre como instalar o servidor de caixas de correio em cluster em um ambiente de CCR, consulte "Como instalar a função de servidor Caixa de Correio no nó ativo" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=86624) na documentação do produto Exchange Server 2007.


Somente a função de Caixa de Correio pode ser instalada em um servidor de cluster
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-07

A Instalação do Microsoft® Exchange Server 2007 não pode continuar porque sua tentativa de instalar uma função diferente da função de servidor de Caixa de Correio nesse servidor de clusters falhou.

O Microsoft Exchange não oferece suporte a funções do Exchange 2007 diferentes da função de servidor de Caixa de Correio em que o serviço de cluster esteja instalado.

Para resolver esse problema, consulte "Alta disponibilidade para o Exchange 2007" no Guia de Operações do Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=68190).


A organização está no modo misto
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-05-15

A instalação do Microsoft Exchange Server 2007 não pode continuar, porque a organização existente do Microsoft Exchange não está no modo nativo.

A instalação do Exchange 2007 exige que a organização do Exchange existente esteja no modo nativo.

Para resolver esse problema, siga as etapas a seguir depois que o último Exchange Server versão 5.5 na organização existente for atualizado ou antes que o último servidor Exchange 5.5 seja descomissionado. Em seguida, execute novamente a instalação do Exchange 2007.

Observação:
Depois de alternar para o modo nativo, você não poderá alternar de volta para o modo misto.
Para alternar para o modo nativo

  1. Inicie o Gerenciador do Sistema do Exchange: Clique em Iniciar, aponte para Todos os Programas, aponte para Microsoft Exchange e clique em Gerenciador do Sistema.

  2. Na árvore do console, clique com o botão direito na organização que você deseja alternar para o modo nativo e clique em Propriedades.

  3. Em Propriedades de <Nome da Organização>, em Alterar modo de operação, clique em Alterar Modo.

  4. Na caixa de diálogo de aviso, clique em Sim se tiver certeza de que deseja mudar permanentemente para o modo nativo. Clique em Aplicar para aceitar o novo modo do Exchange.

Você deve reiniciar o serviço Armazenamento de Informações do Microsoft Exchange em todos os servidores Exchange de sua organização para aproveitar ao máximo o modo nativo do Exchange. Não é necessário reiniciar todos os serviços Armazenamento de Informações do Microsoft Exchange ao mesmo tempo, mas você deve reiniciar o serviço em cada um dos servidores para que o servidor aproveite todos os recursos do modo nativo do Exchange. Reinicie o serviço em seus servidores após a alteração para o modo nativo ter sido replicada para o controlador de domínio do Microsoft Windows® local.

Para reiniciar o serviço de Armazenamento de Informações do Microsoft Exchange

  1. Clique em Iniciar, clique em Executar, digite services.msc e clique em OK.

  2. No painel Serviços (Local), localize o serviço Armazenamento de Informações do Microsoft Exchange.

  3. Clique com o botão direito no serviço e clique em Reiniciar.

Para obter mais informações sobre como converter do modo misto para o modo nativo, consulte o artigo 32779 da Base de Dados de Conhecimento Microsoft, "COMO FAZER: Converter do modo misto para o modo nativo no Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779).


Não é possível entrar em contato com o servidor DNS primário
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-05

Não é possível continuar a instalação do Microsoft® Exchange Server 2007 porque não pode ser estabelecida a comunicação com o servidor DSN (Sistema de Nome de Domínio) primário.

A instalação do Exchange 2007 exige que o computador local se comunique com o banco de dados de DNS autoritativo do domínio.

O Microsoft Exchange depende do DNS para resolver o endereço IP de seu próximo servidor de destino interno ou externo.

A comunicação com o servidor DNS primário pode falhar pelos seguintes motivos:

  • A configuração do TCP/IP local não aponta para o servidor DNS correto.

  • O servidor DNS está inativo ou inacessível por causa de uma falha de rede ou outras razões.

Para resolver esse problema:

  • Verifique se a configuração TCP/IP local aponta para o servidor DNS correto.

Para verificar a configuração TCP/IP local

  1. Examine a configuração do TCP/IP local:

    Para obter mais informações, consulte "Configure TCP/IP to use DNS" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=68094).
  • Verifique se o servidor DNS está em execução e se pode ser contatado.

Para verificar se o servidor DNS está em execução e se pode ser contatado

  1. Confira se o servidor DNS está em execução fazendo uma ou mais das seguintes verificações:

    • Veja o status do servidor DNS no programa de Administração do DNS no servidor DNS.

    • Reinicie o servidor DNS.

      Para obter mais informações, consulte "Start, stop, pause, or restart a DNS server" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Verifique a capacidade de resposta do servidor DNS usando o comando nslookup.

      Para obter mais informações, consulte as instruções em "Verify DNS server responsiveness using the nslookup command" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=63000).


A especificação de unidade de banco de dados de pasta pública está ausente
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-05-15

A instalação da Recuperação de Desastres do Microsoft® Exchange Server 2007 não pode continuar, porque não é possível acessar a especificação de unidade de banco de dados de pasta pública que foi usada na instalação anterior desse servidor.

A instalação da Recuperação de Desastres do Microsoft Exchange requer que as mesmas especificações de unidade de banco de dados de pasta pública usadas anteriormente neste servidor estejam disponíveis durante a restauração.

Para resolver essa situação, configure as unidades para que correspondam à configuração da unidade lógica original e execute a instalação da Recuperação de Desastres do Microsoft Exchange novamente.

Atribuir ou alterar uma letra de unidade

  1. Abra Gerenciamento de Computador (Local).

  2. Na árvore do console, clique em Gerenciamento de Computador (Local), clique em Armazenamento e Gerenciamento de Disco.

  3. Clique com o botão direito em uma partição, unidade lógica ou volume e clique em Alterar Letras e Caminhos de Unidade.

  4. Use um dos procedimentos a seguir:

    • Para atribuir uma letra de unidade, clique em Adicionar, clique na letra de desejada e clique em OK.

    • Para modificar uma letra de unidade, clique nela, clique em Alterar, clique na letra de unidade que você deseja usar e clique em OK.

Para obter mais informações sobre como atribuir letras de unidade, consulte "Assign, change, or remove a drive letter" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=66764).


Não foi possível acessar remotamente o Registro em um nó em cluster
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-04-13

A instalação do Microsoft Exchange Server 2007 não pode continuar porque o Registro em um nó de cluster não pôde ser acessado.

A instalação do Exchange 2007 exige acesso ao Registro de todos os nó no cluster para recuperar várias configurações.

Para resolver esse problema, faça o seguinte:

  • Verifique se o serviço de Registro Remoto está em execução em todos os nós do cluster.

  • Verifique se a opção Compartilhamento de Arquivos e Impressora para Redes Microsoft está habilitada para o adaptador de rede listado primeiro na ordem de ligação.

  • Verifique se os valores das chaves de Registro a seguir são os mesmos em cada nó do cluster e são válidos para a diretiva de grupo relevante:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanmanworkstation\parameters\RequireSecuritySignature

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rdr\Parameters\EnableSecuritySignature

Para obter mais informações sobre como solucionar problemas de conectividade do Registro, consulte a seção Solução de problemas de conectividade do Registro em "Solução de problemas de conectividade da ferramenta Microsoft Exchange Server Best Practices Analyzer Tool" (http://go.microsoft.com/fwlink/?linkid=56285).


Remover Inscrição de Borda antes de desinstalar a função de servidor
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-21

A instalação do Microsoft Exchange Server 2007 não pode continuar porque o processo de desinstalação da função de servidor Transporte de Hub ou de Borda falhou, pois a função de servidor tem uma Inscrição de Borda.

Inscreva um servidor de Transporte de Borda em um site do Active Directory para associar esse servidor à organização do Exchange. O servidor de Transporte de Borda será carimbado com um atributo de site do Active Directory. Entre outras coisas, essa associação permite configurar a Inscrição de Borda como um servidor de origem para Conectores de Envio criados na organização do Exchange. Os servidores de Transporte de Hub na organização do Exchange usam um Conector de Envio intra-organizacional implícito para rotear emails para a Internet através do servidor de Transporte de Borda inscrito. A associação do site do Active Directory permite que os servidores de Transporte de Hub localizem o servidor de Transporte de Borda para fins de roteamento.

A instalação do Exchange 2007 exige que todas as Inscrições de Borda da função de servidor Transporte de Borda de destino ou a última função de servidor Transporte de Hub em um site, sejam removidas para que a desinstalação da função de servidor Transporte de Hub ou de Borda possa continuar.

Para resolver esse erro, use o cmdlet Get-EdgeSubscription para recuperar informações sobre as Inscrições de Borda e o cmdlet Remove-EdgeSubscription para remover a Inscrição de Borda do servidor de destino e executar novamente a instalação do Exchange 2007.

Para identificar e remover a Inscrição de Borda

  1. Siga a orientação no tópico Cmdlet Get-EdgeSubscription (http://go.microsoft.com/fwlink/?LinkId=86320) para identificar as Inscrições de Borda do servidor de destino.

  2. Siga a orientação no tópico Cmdlet Remove-EdgeSubscription (http://go.microsoft.com/fwlink/?LinkId=86321) para remover a Inscrição de Borda do servidor de destino.


FSMO do Esquema não é Windows Server 2003 Service Pack (SP1) ou superior
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-05

O Microsoft® Exchange Server Analyzer Tool verifica a floresta do serviço de diretório do Active Directory® para saber qual versão do servidor do sistema operacional está sendo executada no controlador de esquemas do controlador de domínios do Active Directory. Se o Exchange Server Analyzer verificar que o controlador de domínio mestre das operações do Active Directory, conhecido também como operação principal única flexível ou FSMO, não está executando o Microsoft Windows Server™ 2003 Service Pack 1 (SP1) ou uma versão posterior, o Exchange Server Analyzer exibirá um erro.

Esse erro indica que o Windows Server 2003 SP1 ou uma versão posterior é necessário para instalar o Microsoft Exchange Server 2007. É necessário o Windows Server 2003 SP1 ou uma versão posterior para dar suporte às novas estruturas de permissão do Exchange 2007.

Se o controlador de domínios FSMO do esquema do Active Directory não estiver executando o Windows Server 2003 SP1 ou uma versão posterior, a instalação do Exchange 2007 falhará.

Essa mensagem é uma verificação preliminar obrigatória para implantação do Exchange 2007. É recomendável que você tenha o Windows Server 2003 SP1 ou uma versão posterior em execução no controlador de esquemas do controlador de domínios do Active Directory em toda a floresta se planeja instalar o Exchange 2007.


O controlador de esquemas está executando o Windows 2000 Server
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-01-08

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o controlador de domínio ao qual foi atribuído a função de controlador de esquema do serviço de diretório do Active Directory®, também conhecido como FSMO (operação mestra única flexível), está executando o Microsoft Windows® 2000 Server.

A instalação do Exchange 2007 exige que o controlador de domínio que serve como esquema FSMO execute o Microsoft Windows Server™ 2003 Service Pack 1 (SP1) ou uma versão posterior.

O FSMO controla todas as atualizações e modificações no esquema do Active Directory.

Para resolver esse problema, atualize ou mova o controlador de domínio do FSMO para o Windows Server 2003 SP1 ou uma versão posterior do servidor, e execute novamente a instalação do Microsoft Exchange.

Para obter mais informações, consulte o artigo 325379 da Base de Dados de Conhecimento Microsoft, "Como atualizar os controladores de domínio do Windows 2000 para o Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325379).

Para obter mais informações sobre a transferência da função de mestre de infra-estrutura de um controlador de domínio para outro, consulte os seguintes artigos da Base de Dados de Conhecimento da Microsoft:

  • Para o Microsoft Windows Server™ 2003, consulte 324801, "Como exibir e transferir as funções FSMO no Windows Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Para o Microsoft Windows 2000 Server, consulte 255690, "COMO FAZER PARA: Exibir e transferir as funções FSMO na interface gráfica do usuário" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690)


O controlador de esquemas não está executando o Windows Server 2003 Service Pack 1 ou posterior
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois o controlador de domínio que atribuiu a função de controlador de esquemas do serviço de diretório do Active Directory, também conhecido como FSMO (Operação Mestra Única Flexível), não está sendo executado no Microsoft Windows Server 2003 Service Pack 1 (SP1) ou em uma versão posterior.

A Instalação do Exchange 2007 exige que o controlador de domínio que serve ao esquema FSMO execute o Windows Server 2003 SP1 ou uma versão posterior.

O FSMO controla todas as atualizações e modificações no esquema do Active Directory.

Para resolver esse problema, execute um ou mais dos seguintes procedimentos:

  • Atualize o controlador de domínio da FSMO para o Windows Server 2003 SP1 ou para uma versão posterior e reexecute a instalação do Microsoft Exchange.

  • Se houver um controlador de domínio da FSMO executando o Microsoft Windows Server 2003 Service Pack 1 (SP1) ou uma versão posterior na organização do Exchange, execute a instalação do Exchange 2007 com o parâmetro /domaincontroller apontando para esse controlador de domínio da FSMO:

    [/DomainController ou /dc <FQDN do controlador de domínio>]

    Use o parâmetro /DomainController para especificar o controlador de domínio a ser usado para ler e gravar no Active Directory durante a instalação. Você pode usar o formato do NetBIOS ou o FQDN (nome de domínio totalmente qualificado).

Para obter o service pack mais recente do Windows Server 2003, consulte o Windows Server TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315).

Para obter mais informações sobre os parâmetros da Instalação do Exchange Server 2007, consulte "Como instalar o Exchange 2007 no modo autônomo" (http://go.microsoft.com/fwlink/?LinkId=86476) na documentação do produto do Exchange Server 2007.


Setup Cannot Install Exchange to a Read-Only Domain Controller
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-07-23

A instalação do Microsoft Exchange Server 2007 não pode continuar porque o computador de destino é RODC (Controlador de Domínio Somente Leitura).

Os Controladores de Domínio Somente Leitura são um recurso do Active Directory do Windows Server 2008. O RODC é um tipo de opção de instalação de controlador de domínio que pode ser instalado em sites remotos que possam ter níveis inferiores de segurança física.

A Instalação do Exchange exige acesso de gravação ao computador de instalação de destino.

Para resolver esse problema, selecione um computador de instalação de destino que não esteja designado como um RODC e execute a Instalação novamente.


Falha de instalação ao instalar uma função de servidor
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-04-12

A instalação do Microsoft Exchange Server 2007 não pode continuar, pois ocorreu uma falha de instalação anterior durante a instalação de uma função de servidor.

A instalação do Exchange 2007 exige que uma instalação da função de servidor com falha seja reinstalada com êxito ou removida do processo de instalação para que qualquer outra tarefa de instalação possa continuar.

Para resolver esse problema, reinstale apenas as funções de servidor com falha ou remova-as.

Para reinstalar a função de servidor com falha da linha de comando

  1. Abra uma janela Prompt de Comando e navegue para os arquivos de instalação.

  2. Execute o seguinte comando:

    Código da Cópia
    Setup /roles:<Failed Server Role>

    Selecione entre uma ou mais das seguintes funções, em uma lista separada por vírgulas:

    ClientAccess (ou CA ou C)

    EdgeTransport (ou ET ou E)

    Observação:
    A função de servidor de Transporte de Borda não pode coexistir no mesmo computador com nenhuma outra função de servidor.
    Observação:
    Você deve implantar a função de servidor Transporte de Borda na rede de perímetro e fora da floresta do Active Directory.

    HubTransport (ou HT ou H)

    Mailbox (ou MB ou M)

    UnifiedMessaging (ou UM ou U)

    ManagementTools (ou MT ou T)

    Observação:
    Se você especificar ManagementTools, instalará o Console de Gerenciamento do Exchange, os cmdlets do Exchange no Shell de Gerenciamento do Exchange, o arquivo de Ajuda do Exchange, a Ferramenta Exchange Best Practices Analyzer Tool e o Assistente de Solução de Problemas do Exchange. As ferramentas de gerenciamento serão instaladas automaticamente se você instalar qualquer outra função de servidor.

    Por exemplo, para adicionar a função de servidor Transporte de Hub em um servidor de Caixa de Correio já existente, digite o seguinte: %LocalExchangeInstallationDir%\bin\Setup.com /role:HubTransport /Mode:Install

Observação:
Se qualquer função de servidor do Exchange Server 2007 tiver sido instalada com êxito, o assistente para Instalação será executado no modo de manutenção. Se nenhuma função tiver sido instalada com êxito anteriormente, o assistente para Instalação iniciará de onde parou.
Para usar o assistente para Instalação do Exchange Server 2007 no modo de manutenção para reinstalar a função de servidor com falha

  1. Faça logon no servidor para o qual deseja reinstalar uma função de servidor.

  2. Abra o Painel de Controle e clique duas vezes em Adicionar ou Remover Programas.

  3. Na página Alterar ou Remover Programas, selecione Microsoft Exchange Server e clique em Alterar.

  4. No assistente para Instalação do Exchange Server 2007, na página do Modo de Manutenção do Exchange, clique em Avançar.

  5. Na página Seleção de Função de Servidor, desmarque as caixas de seleção das funções de servidor que você deseja instalar e clique em Avançar.

    Observação:
    A função de servidor de Transporte de Borda não pode coexistir no mesmo computador com nenhuma outra função de servidor.
    Observação:
    Você deve implantar a função de servidor Transporte de Borda na rede de perímetro e fora da floresta do Active Directory.
    Observação:
    Se selecionar Ferramentas de Gerenciamento, você instalará o Console de Gerenciamento do Exchange, os cmdlets do Exchange para o Shell de Gerenciamento do Exchange e o arquivo de Ajuda do Exchange. As ferramentas de gerenciamento serão instaladas automaticamente se você instalar qualquer outra função de servidor.

  6. Se você tiver selecionado Função de Transporte de Hub e estiver instalando o Exchange 2007 em uma floresta que possua uma organização existente do Exchange Server 2003 ou do Exchange 2000 Server, na página Configurações de Fluxo de Mensagens, selecione um servidor bridgehead na organização existente que seja membro do grupo de roteamento do Exchange 2003 ou do Exchange 2000 para o qual você deseja criar um conector de grupo de roteamento.

  7. Na página Verificações de Preparação, exiba o status para determinar se as verificações de pré-requisitos de função de servidor e da organização foram concluídas com êxito. Se elas tiverem sido concluídas com êxito, clique em Instalar para instalar o Exchange 2007.

  8. Na página Conclusão, clique em Concluir.
Para usar o assistente para Instalação do Exchange Server 2007 para reinstalar a função de servidor com falha quando nenhuma outra função de servidor tiver sido instalada anteriormente com êxito

  1. Siga a orientação em "Como fazer uma instalação personalizada usando a Instalação do Exchange Server 2007" (http://go.microsoft.com/fwlink/?LinkId=86648) na documentação do produto Exchange Server 2007.
Para remover a função de servidor com falha

  1. Siga a orientação em "Como remover as funções de servidor do Exchange 2007" (http://go.microsoft.com/fwlink/?LinkId=86649) na documentação do produto Exchange Server 2007.

Para obter mais informações

Para obter mais informações sobre como instalar o Exchange 2007 em modo automático, consulte "Como instalar o Exchange 2007 no modo automático" (http://go.microsoft.com/fwlink/?LinkId=86476).


Este servidor é a Origem de um Conector de Grupo de Roteamento
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

A instalação do Microsoft Exchange Server 2007 não pode continuar porque sua tentativa de remover a função de servidor Transporte de Hub falhou. O computador local é a origem para um ou mais conectores de grupo de roteamento na organização do Exchange.

Um conector de grupo de roteamento é usado para enviar e receber mensagens entre servidores de Transporte de Hub do Exchange 2007 e servidores bridgehead Exchange Server 2003 ou Exchange 2000 Server. Quando o Exchange Server 2007 está instalado em um Exchange Server 2003 e uma organização do Exchange 2000 Server existentes, o grupo de roteamento necessário é criado durante a instalação.

A instalação do Exchange 2007 exige que todos os conectores de grupo de armazenamento de uma organização do Exchange sejam movidos ou excluídos do computador servidor de Transporte de Hub para que a função de servidor possa ser excluída.

Para resolver esse problema, mova ou exclua todos os conectores de grupo de roteamento do computador local e execute novamente a instalação.

Para mover o Conector de Grupo de Roteamento usando o Shell de Gerenciamento do Exchange

  1. Use o cmdlet Set-RoutingGroupConnector para modificar as propriedades de um conector de grupo de roteamento existente entre um grupo de roteamento do Microsoft Exchange Server 2007 e um grupo de roteamento do Exchange Server 2003 ou do Exchange 2000 Server.

  2. Esse exemplo usa o cmdlet Set-RoutingGroupConnector para modificar a origem de um conector de grupo de roteamento.
Código da Cópia
Set-RoutingGroupConnector -Identity "[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name" -SourceTransportServers [FQDN of desired Hub Transport Server]
 Para remover o Conector de Grupo de Roteamento usando o Shell de Gerenciamento do Exchange

  1. Use o cmdlet Remove-RoutingGroupConnector para remover um conector de grupo de roteamento entre um grupo de roteamento do Microsoft Exchange Server 2007 e um grupo de roteamento do Exchange Server 2003 ou do Exchange 2000 Server.

  2. O exemplo a seguir mostra como usar o cmdlet Remove-RoutingGroupConnector para remover o conector de grupo de roteamento especificado.
Código da Cópia
Remove-RoutingGroupConnector -Identity"[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name"

Para obter mais informações sobre como modificar ou remover conectores de grupo de roteamento, consulte os tópicos a seguir na documentação do produto Exchange Server 2007:

  • Set-RoutingGroupConnector (http://go.microsoft.com/fwlink/?LinkId=86659).

  • Remove-RoutingGroupConnector (http://go.microsoft.com/fwlink/?LinkId=86660).


Este servidor é a origem de um conector de envio
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois houve falha na tentativa de remover a função de servidor Transporte de Hub. O computador local é a origem de um ou mais conectores de envio da organização do Exchange.

Um conector de envio representa um gateway lógico através do qual mensagens de saída são enviadas.

A instalação do Exchange 2007 exige que todos os conectores de envio de uma organização do Exchange sejam movidos ou excluídos do computador servidor de Transporte de Hub para que a função de servidor possa ser excluída.

Para resolver esse problema, mova ou exclua todos os conectores de envio do computador local e reexecute a instalação.

Para obter mais informações sobre como modificar ou remover conectores de envio, consulte os seguintes tópicos na documentação do produto do Exchange Server 2007:

  • "Como remover um conector de envio" (http://go.microsoft.com/fwlink/?LinkId=86655).

  • "Como modificar a configuração de um conector de envio" (http://go.microsoft.com/fwlink/?LinkId=86655).


Detectado modelo de organização simples do Exchange
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-08-18

A ferramenta Microsoft® Exchange Server Analyzer consulta o serviço de diretório do Active Directory® para determinar o número de caixas de correio existentes no servidor. Cada objeto de armazenamento de caixa de correio (classe msExchPrivateMDB) tem um atributo homeMDBBL com diversos valores que lista todas as caixas de correio do armazenamento. Com a contagem desses valores, o Exchange Server Analyzer obtém o número total de caixas de correio do servidor.

O Exchange Server Analyzer também consulta o Active Directory para obter o número de sites doActive Directory que contêm Exchange Servers. Além disso, o Exchange Server Analyzer consulta o Active Directory para obter o número de servidores executando o Microsoft Exchange 2000 Server ou o Microsoft Exchange Server 2003. Por último, o Exchange Server Analyzer consulta o objeto WMI (Instrumentação de Gerenciamento do Microsoft Windows®) Win32_Service para saber se o serviço de Cluster do Windows está presente e em execução.

O Exchange Server Analyzer classificará a organização do Exchange como uma organização simples do Exchange, se as seguintes condições forem verdadeiras:

  • O número total de caixas de correio existentes na organização for menor que 1.000.

  • Os servidores Exchange estão instalados somente em um único site do Active Directory.

  • Há menos de 3 computadores executando o Exchange 2000 ou Exchange 2003.

  • Não há implementação de servidores Exchange agrupados.

Dos quatro modelos organizacionais definidos para o Microsoft Exchange Server 2007, a organização simples do Exchange representa a topologia mais comum na qual o Exchange 2007 pode ser implantado. A organização simples do Exchange contém:

  • Um único servidor Exchange que fornece todos os serviços do Exchange e armazena todos os dados do Exghange para a organização inteira.

  • Vários servidores do Exchange em uma topologia que inclui servidores de diretório redundantes e um servidor de Transporte de Borda em uma rede de perímetro.

Para fazer a transição de uma organização simples do Exchange para o Exchange 2007

  1. Acesse a documentação do produto Exchange 2007 on-line (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Expanda "Planejamento e Arquitetura", expanda "Planejando a implantação" e clique em "Planejando uma organização simples do Exchange".


O SMTP está instalado no momento
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-01-22

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o serviço SMTP do Microsoft Windows Server™ 2003 está instalado neste computador.

A instalação do Microsoft Exchange exige que o serviço SMTP não esteja instalado em servidores usados para o Exchange 2007.

Para resolver esse problema, desinstale o serviço SMTP e execute novamente a instalação do Microsoft Exchange.

Para desinstalar o serviço SMTP usando Adicionar ou Remover Componentes do Windows no Painel de Controle

  1. No menu Iniciar, clique em Painel de Controle.

  2. Clique duas vezes em Adicionar ou Remover Programas.

  3. Clique em Adicionar/Remover Componentes do Windows.

  4. Na lista Componentes, marque a caixa de seleção Servidor de Aplicativo e clique em Detalhes.

  5. Selecione Gerenciador dos Serviços de informações da Internet e clique em Detalhes.

  6. Selecione Serviço SMTP e clique para desmarcar a caixa de seleção.

  7. Clique em OK duas vezes para retornar à lista Componentes e clique em Avançar.

  8. Clique em Concluir quando o serviço SMTP for desinstalado.


O site não pode oferecer suporte a servidores Exchange 2007
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-08-11

A ferramenta Microsoft® Exchange Server Analyzer exibiu este aviso porque há sites na floresta do serviço de diretório do Active Directory que não possuem pelo menos um servidor de catálogo global em execução no Microsoft Windows Server™ 2003 Service Pack 1 (SP1) ou versão posterior.

A instalação do Microsoft Exchange Server 2007 exige que cada site do Active Directory que hospede um servidor executando o Exchange 2007 tenha pelo menos um servidor de catálogo global em execução no Windows Server 2003 SP1 ou versão posterior.

Para resolver este problema, atualize pelo menos um servidor de catálogo global em cada site do Active Directory para o Windows Server 2003 SP1 ou versão posterior.

Para obter mais informações sobre como atualizar para o Windows Server 2003, consulte o artigo 810613 da Base de Dados de Conhecimento Microsoft, "Caminhos com suporte para atualização para o Windows Server 2003 ou o Windows Small Business Server 2003" (em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613).

Para obter o service pack mais recente do Windows Server 2003, consulte o Windows Server TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315).


Detectado modelo de organização padrão do Exchange
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-08-10

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para determinar:

  • O número de caixas de correio existentes na organização.

  • O número de grupos de roteamento existentes na organização.

  • O número de sites do Active Directory existentes na organização.

  • O número de florestas do Active Directory existentes na organização.

  • Se o MIIS (Microsoft Identity Integration Server) está instalado.

A quantidade de cada item determina se o modelo de organização do Exchange é simples, padrão, grande ou complexo. Toda oganização não classificada como simples, grande ou complexa é automaticamente classificada como organização padrão do Exchange.

Dos quatro modelos organizacionais definidos para o Microsoft Exchange Server 2007, a organização padrão do Exchange representa a topologia mais comum na qual o Exchange 2007 é implantado. Quando o serviço de mensagens precisa crescer além dos limites de recursos de um único computador, a separação de serviços do Exchange 2007 em vários computadores torna-se a próxima divisão topológica: a organização padrão do Exchange. A organização padrão do Exchange é criada tendo como base a organização simples do Exchange, por meio da implantação de vários computadores que executam o Exchange.

Para fazer a transição de uma organização padrão do Exchange para o Exchange 2007

  1. Exiba on-line a documento do produto Exchange 2007 (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Expanda "Planejamento e Arquitetura", expanda "Planejando a implantação" e clique em "Planejando uma organização padrão do Exchange".


Endereços IP estáticos são recomendados em um cluster
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-05

A instalação do Microsoft® Exchange Server 2007 exibiu esse aviso porque uma ou mais interfaces de rede estão configuradas para usar o protocolo DHCP.

Uma prática recomendada indica que endereços IP estáticos sejam usados em interfaces de rede que gerenciam conexões de cliente e links de pulsação em um cluster de servidores Microsoft Windows. O uso de uma configuração dinâmica por DHCP não é recomendado, porque a falha em renovar uma licença de DHCP pode interromper as operações do cluster.

Para tratar esse aviso, configure cada interface de rede que gerencia conexões de cliente ou links de pulsação para usar um endereço IP estático.

Para configurar um endereço IP estático de uma conexão de rede

  1. No menu Iniciar, clique em Configurações e depois em Configurações de rede.

  2. Clique com o botão direito na conexão que você deseja configurar e clique em Propriedades.

  3. Na guia Geral, em Esta conexão usa os seguintes itens, clique em Protocolo TCP/IP e clique em Propriedades.

  4. Clique em Usar o seguinte endereço IP e, em Endereço IP, digite o endereço IP.

  5. Clique em OK duas vezes para concluir.

Para obter mais informações sobre a configuração ideal de rede para os clusters de servidor Windows, consulte "Clusters de Servidor: Práticas recomendadas de configuração de rede para Windows 2000 e Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=34304) (em inglês).

Para obter mais informações sobre configuração correta da pulsação de cluster, consulte o artigo 258750 da Base de Dados de Conhecimento Microsoft, "Configuração de 'Pulsação' particular recomendada em um servidor de cluster" (página em inglês) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


O caminho do armazenamento de um cluster de cópia única deve ser um disco de cluster
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

A instalação do Microsoft Exchange Server 2007 não pode continuar porque o caminho de armazenamento de um cluster de cópia única deve ser um disco de cluster.

No Exchange Server 2007, o SCC (cluster de cópia única) é uma solução em cluster que usa uma cópia única de um grupo de armazenamento no armazenamento compartilhado entre os nós no cluster.

Para resolver esse problema, especifique uma unidade de cluster para o caminho de dados e execute novamente a instalação do Exchange 2007.

Para obter mais informações sobre clusters de cópia única, consulte "Instalando um cluster de cópia única" (http://go.microsoft.com/fwlink/?LinkId=76162) na documentação do produto Exchange Server 2007.


Formato de endereçamento SMTP não aceito
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

A instalação do Microsoft Exchange Server 2007 não pode continuar porque a diretiva de destinatário especificada usa um formato de endereço SMTP não aceito.

A instalação do Exchange 2007 exige que todos os endereços SMTP usados para as diretivas de endereço de email não contenham literais de endereço IP, por exemplo: user@[10.10.1.1].

Para resolver esse problema, altere o valor do endereço SMTP na diretiva de destinatário, de forma que ele não contenha um literal de endereço IP. Substitua os colchetes ([]) e os número (10.10.1.1) do literal de endereço IP pelo formato de nomenclatura de DNS (Sistema de Nome de Domínio), por exemplo: user@contoso.com, e execute de novo a instalação do Exchange.

Para obter mais informações sobre o gerenciamento de diretivas de destinatário no Exchange Server 2007, consulte "Gerenciando diretivas de endereço de email" (http://go.microsoft.com/fwlink/?LinkId=86653).


Encontrado link de site SMTP
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-12-07

A ferramenta Microsoft® Exchange Server Analyzer exibe este aviso se encontrar links de sites baseados em SMTP (Simple Mail Transfer Protocol), no serviço de diretório do Active Directory®.

O roteamento do Microsoft Exchange Server 2007 vai ignorar os sites do Active Directory conectados através de links de sites SMTP. Se o Exchange 2007 estiver instalado em sites conectados somente através de um link de site SMTP, ocorrerão erros de roteamento.

Para resolver este problema, substitua os links de sites SMTP por links de sites baseados emIP.

Para obter mais informações sobre links de sites IP do Active Directory, consulte "Planejando usar sites do Active Directory para rotear email" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=71803).


A especificação da unidade de grupo de armazenamento está ausente
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-05-15

A instalação da Recuperação de Desastres do Microsoft® Exchange não pode continuar porque a instalação da Recuperação de Desastres não pode acessar a especificação da unidade de banco de dados do grupo de armazenamento foi utilizada em instalações anteriores desse servidor.

A instalação da Recuperação de Desastres do Microsoft Exchange exige que as mesmas especificações de unidade do banco de dados do grupo de armazenamento utilizadas anteriormente para esse servidor estejam disponíveis durante a restauração.

Para resolver essa situação, configure as unidades para que correspondam à configuração da unidade lógica original e execute a instalação da Recuperação de Desastres do Microsoft Exchange novamente.

Atribuir ou alterar uma letra de unidade

  1. Abra Gerenciamento de Computador (Local).

  2. Na árvore do console, clique em Gerenciamento de Computador (Local), clique em Armazenamento e Gerenciamento de Disco.

  3. Clique com o botão direito em uma partição, unidade lógica ou volume e clique em Alterar Letras e Caminhos de Unidade.

  4. Use um dos procedimentos a seguir:

    • Para atribuir uma letra de unidade, clique em Adicionar, clique na letra de desejada e clique em OK.

    • Para modificar uma letra de unidade, clique nela, clique em Alterar, clique na letra de unidade que você deseja usar e clique em OK.

Para obter mais informações sobre como atribuir letras de unidade, consulte "Assign, change, or remove a drive letter" (em inglês) (http://go.microsoft.com/fwlink/?LinkId=66764).


Incompatibilidade do caminho de instalação de destino
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a instalação do Microsoft Exchange Server 2007, pois o caminho de destino dos arquivos binários do Exchange não corresponde ao caminho de instalação existente do Exchange em outros nós de cluster.

O Exchange Server 2007 exige que nós do mesmo cluster tenham caminhos de instalação de destino consistentes para os arquivos binários do Exchange.

Para resolver esse problema, use um caminho de instalação de destino para os arquivos binários do Exchange que seja consistente em todos os nós do cluster.

Para obter mais informações sobre as instalações do Exchange Server 2007 de Alta Disponibilidade, consulte "Alta disponibilidade" (em inglês) (http://go.microsoft.com/fwlink/?linkid=68190) na documentação do produto Exchange Server 2007.


O caminho de destino está compactado
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-06

Não é possível continuar a instalação do Microsoft® Exchange Server 2007, pois o caminho da pasta de destino para a instalação do Microsoft Exchange está compactado.

A instalação do Microsoft Exchange requer que a primeira pasta no caminho de destino para a instalação não esteja compactada. Por padrão, a primeira pasta no caminho de destino para a instalação é C:\Arquivos de Programas.

Para resolver esse problema, desative a compactação para a primeira pasta no caminho de destino e reexecute a configuração do Exchange 2007.

Para desativar a compactação para o caminho de destino

  1. Em Meu Computador ou Windows Explorer, clique com o botão direito na pasta para descompactar.

  2. Clique em Propriedades para exibir a caixa de diálogo Propriedades.

  3. Na guia Geral, clique em Avançado.

  4. Na caixa de diálogo Atributos Avançados, desmarque a caixa de seleção Compactar o conteúdo para economizar espaço em disco e clique em OK.

  5. Na caixa de diálogo Propriedades, clique em OK.

  6. Quando o estado de compressão é alterado para a pasta, na caixa de diálogo Confirmar Alterações de Atributos, selecione Aplicar alterações a esta pasta, subpastas e arquivos.

  7. Clique em OK ao finalizar.


São recomendadas duas ou mais interfaces de rede em um cluster
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-05

A instalação do Microsoft® Exchange Server 2007 exibe este aviso porque o ambiente de cluster atual do Microsoft Windows tem apenas uma interface de rede definida.

É uma prática recomendada implementar ao menos uma interface de rede para a rede pública (conexão de cliente) e uma interface de rede para a rede privada (administrativa/pulsação) para evitar um único ponto de falha.

Para endereçar este aviso, implemente ao menos uma interface de rede adicional para o cluster do Microsoft Windows.

Para obter mais informações sobre a configuração ideal de rede para os clusters de servidor Windows, consulte " Clusters de Servidor: Práticas recomendadas de configuração de rede para Windows 2000 e Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=34304) (em inglês).


Não é possível conectar ao serviço de Registro Remoto
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-01-23

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o Registro no computador local não pôde ser acessado.

A instalação do Exchange 2007 precisa de acesso ao Registro local para recuperar várias configurações.

A instalação do Exchange tenta utilizar o DNS (Sistema de Nome de Domínio) para obter o FQDN (nome de domínio totalmente qualificado) do computador local para acessar o Registro.

A instalação não conseguiu recuperar o FQDN no DNS por causa de um erro de rede ou não foi conseguiu acessar o Registro.

Para resolver esse problema, verifique se o serviço de Registro remoto está em execução no computador local e se o Compartilhamento de Arquivos e Impressão está habilitado no primeiro adaptador de rede na ordem de ligação e, em seguida, execute a instalação do Exchange novamente.

Para verificar se o Serviço de Registro Remoto está em execução

  1. Clique em Iniciar, aponte para Configurações, Painel de Controle, Ferramentas Administrativas e clique duas vezes em Serviços.

  2. Verifique se o Serviço de Registro Remoto está com status Iniciado.
Para habilitar o Compartilhamento de Arquivos e Impressão no adaptador de rede principal

  1. Clique em Iniciar, aponte para Configurações, Painel de Controle, Conexões de Rede e Conexão de Área Local.

  2. Verifique se Compartilhamento de Arquivos e Impressora para Redes Microsoft está habilitado, ou seja, se a caixa de seleção está marcada.
Observação:
Se esse for um servidor em cluster, você deve verificar se o serviço de Registro Remoto está em execução em todos os nós do cluster e se o Compartilhamento de Arquivos e Impressora para Redes Microsoft está habilitado para o adaptador de rede que está listado primeiro na ordem de ligação.


Atualização do Windows Media Audio Voice Codec necessária
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-07-13

A instalação do Microsoft® Exchange Server 2007 não pode continuar porque o Microsoft Windows Media Audio Voice Codec não está instalado ou há uma versão mais recente do Windows Media Audio Voice Codec disponível.

A instalação do Exchange 2007 exige que você instale a versão mais recente do Windows Media Audio Voice Codec no servidor. O Windows Media Audio Voice Codec é necessário para oferecer suporte à função de servidor de Unificação de Mensagens do Exchange Server 2007.

Para resolver esse problema, instale a versão mais recente do Windows Media Audio Voice Codec existente em http://go.microsoft.com/fwlink/?LinkId=67407 e execute a instalação do Exchange 2007 novamente.


Atualização do Windows Media Encoder necessária
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-07-13

A configuração do Microsoft® Exchange Server 2007 não pode continuar, pois o Microsoft Windows Media Encoder não está instalado ou uma versão mais recente do Windows Media Encoder está disponível.

A configuração do Exchange 2007 exige a instalação da versão mais recente do Windows Media Encoder no servidor. O Windows Media Encoder é necessário para dar suporte à função de servidor de Unificação de Mensagens do Exchange Server 2007.

Para resolver esse problema, instale a versão mais recente do Windows Media Encoder a partir de http://go.microsoft.com/fwlink/?LinkId=67406 e reexecute a configuração do Exchange 2007.


O Serviço de Publicação na Web está desabilitado ou ausente
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-02-14

A configuração do Microsoft® Exchange Server 2007 não pode continuar, pois a tentativa de instalar a função de Servidor de Caixas de Correio ou Acesso para Cliente constatou que o Serviço de Publicação na Web está desabilitado ou não está instalado neste computador.

A configuração do Exchange 2007 exige que o computador no qual você está instalando o Microsoft Exchange tenha o Serviço de Publicação na Web instalado e definido como algo diferente de desabilitado.

Para resolver esse problema, verifique se o Serviço de Publicação na Web está instalado e desabilitado no computador local e execute novamente a instalação do Microsoft Exchange.

Para verificar se o Serviço de Publicação na Web está instalado e não está desabilitado

  1. Clique com o botão direito no Meu Computador na área de trabalho e clique em Gerenciar.

  2. Expanda o nó Serviços e Aplicativos e clique no nó Serviços.

  3. No painel direito, localize o Serviço de Publicação na Web.

    Se o Serviço de Publicação na Web não for exibido na lista de serviços instalados, execute as etapas do procedimento a seguir para instalá-lo.

  4. Se o Serviço de Publicação na Web for exibido, mas tiver um status diferente de Iniciado, continue com as etapas a seguir para iniciá-lo.

  5. Clique com o botão direito no Serviço de Publicação na Web e clique em Propriedades.

  6. Verifique se o Tipo de Inicialização é Automático e o Status de serviço está definido como Iniciado.

  7. Clique em Aplicar e em OK.
Para instalar o Serviço de Publicação na Web

  1. No menu Iniciar, selecione Configurações, Painel de Controle e clique em Adicionar ou Remover Programas.

  2. Clique em Adicionar/Remover Componentes do Windows.

  3. Na lista Componentes, marque a caixa de seleção Servidor de Aplicativo e clique em Detalhes.

  4. Selecione Gerenciador dos Serviços de informações da Internet e clique em Detalhes.

  5. Selecione Serviço da Web e marque a caixa de seleção.

  6. Clique em OK duas vezes para retornar à lista Componentes e clique em Avançar.

  7. Clique em Concluir quando o serviço IIS estiver instalado.


Desinstalar pacotes de idiomas de Unificação de Mensagens
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-16

A instalação do Microsoft Exchange Server 2007 não pode continuar porque a atualização da função de servidor Unificação de Mensagens falhou.

A instalação do Exchange exige que todos os pacotes de idiomas da função de servidor Unificação de Mensagens, exceto o pacote do idioma inglês, sejam desinstalados para que a atualização da função de servidor Unificação de Mensagens possa continuar.

Os pacotes de idiomas de UM (Unificação de Mensagens) incluídos no Exchange 2007 contêm prompts pré-gravados, suporte de conversão de TTS (Texto em Fala) para determinado idioma.

Os pacotes de idiomas de UM do Exchange 2007 permitem que chamadores e usuários do Outlook Voice Access interajam com o sistema de Unificação de Mensagens em vários idiomas.

Os pacotes existentes de idiomas diferentes do inglês precisam ser desinstalados para que os novos pacotes possam ser instalados.

Para resolver esse problema, desinstale todos os pacotes de idiomas da função de servidor Unificação de Mensagens, exceto o pacote de idioma inglês, e execute de novo a instalação do Exchange 2007.

Para obter mais informações sobre a desinstalação dos pacotes de idiomas da função de servidor de Unificação de Mensagens, consulte Como remover um pacote de idiomas de Unificação de Mensagens de um servidor de Unificação de Mensagens na documentação do produto Exchange 2007.


Atualização necessária para a recuperação de desastres
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2007-03-27

Não é possível continuar com a Recuperação de Desastres do Microsoft Exchange Server 2007, pois uma versão posterior do Exchange Server 2007 foi utilizada originalmente para instalar o Exchange Server neste computador.

A Recuperação de Desastres do Microsoft Exchange exige que a versão do Exchange Server 2007 utilizada para executar a recuperação do Exchange Server seja igual ou superior à versão originalmente utilizada para instalar o Exchange Server.

Para resolver esse problema, inicie a Recuperação de Desastres do Exchange Server 2007 a partir de uma versão do Exchange Server 2007 que seja igual ou superior à versão originalmente utilizada para instalar o Exchange Server.


Conector X400 encontrado na topologia
Microsoft Exchange Server Analyzer - Artigos > Preparação do Exchange Server 2007 >

Última modificação do tópico: 2006-06-05

A ferramenta Microsoft® Exchange Server Analyzer Tool consulta o serviço de diretório do Active Directory® para verificar se há conectores X.400. Se o Exchange Server Analyzer detectar a presença dos conectores X.400 na organização do Microsoft Exchange, o Exchange Server Analyzer exibirá um aviso. O aviso indica que o conector X.400, um protocolo usado para transportar mensagens entre os sistemas de mensagens anteriores, não tem suporte no Microsoft Exchange Server 2007.

No Microsoft Exchange 2000 Server e Microsoft Exchange Server 2003, o SMTP tornou-se o protocolo de transporte padrão. Embora os conectores X.400 tenham suporte no Exchange 2000 e Exchange 2003, não há suporte para esses conectores no Exchange 2007 porque seu uso foi reduzido com o passar dos anos. Se o suporte para X.400 ainda for necessário, será recomendável que você mantenha um servidor Exchange 2000 ou Exchange 2003. Do contrário, o conector X.400 poderá ser substituído pelo SMTP.

Para obter mais informações sobre a arquitetura de transporte do X.400 no Exchange 2003, consulte "Roteamento de mensagens do Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=65578).

Para obter mais informações sobre como implementar o conector X.400 no Exchange 2003, consulte "Implementando o contector X.400 - Compensa utilizá-lo com o Exchange Server 2003?" (http://www.msexchange.org/tutorials/X400-Connector-Exchange-Server-2003.html)

Observação:
As informações sobre sites da Web de terceiros neste tópico são fornecidas para ajudar você a encontrar as informações técnicas necessárias. As URLs estão sujeitas a alterações sem aviso.


Informações legais

Última modificação do tópico: 2007-04-06

As informações contidas neste documento, incluindo URLs e outras referências de sites da Internet, estão sujeitas a alterações sem aviso prévio. A menos que haja observação em contrário, os exemplos de empresas, organizações, produtos, nomes de domínio, endereços de email, logotipos, pessoas, lugares e eventos aqui representados são fictícios e nenhuma associação com qualquer empresa, organização, produto, nome de domínio, endereço de email, logotipo, pessoa, lugar ou evento real é intencional ou implícita. A conformidade com todas as leis de direitos autorais aplicáveis é responsabilidade do usuário. Sem limitação dos direitos de copyright, nenhuma parte deste documento pode ser reproduzida, armazenada ou introduzida em um sistema de recuperação, ou transmitida sob qualquer forma ou por qualquer meio (eletrônico, mecânico, fotocópia, gravação, etc.), ou para qualquer finalidade, sem a permissão por escrito da Microsoft Corporation.

A Microsoft pode ter patentes, ou solicitações de patentes, marcas registradas, direitos autorais ou outros direitos de propriedade intelectual que abrangem o assunto deste documento. Salvo declaração expressa em qualquer contrato de licença por escrito da Microsoft, o fornecimento deste documento não concede a você nenhuma licença a essas patentes, marcas registradas, direitos autorais ou outra propriedade intelectual.

© 2004-2006 Microsoft Corporation. Todos os direitos reservados.

Microsoft, Active Directory, ActiveSync, ActiveX, MSDN, Outlook, SharePoint, Visual C++, Win32, Windows, Windows NT, Windows Server e Windows Server System são marcas registradas ou marcas comerciais da Microsoft Corporation nos Estados Unidos e/ou outros países.

Os nomes de empresas e produtos reais aqui mencionados podem ser as marcas comerciais dos respectivos proprietários.